OfficeClip.BusinessLayer Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer Namespace

[This is preliminary documentation and is subject to change.]

The OfficeClip Business Layer contains the classes to facilitate information exchange between the database and user interface.

Classes

 | Class | Description
Public class | BusinessConstants | Defines various constants for the buinsess objects
Public class | NameValue | Name/value container for use in Name/Value collections
Public class | ObjectTypeRelation | Class for object type relations. Shows relation between types
Public class | Utility | Utility functions

Enumerations

 | Enumeration | Description
Public enumeration | BusinessConstants..::.DurationTypes | Duration types pertaining to any object with a defined duration.
Public enumeration | BusinessConstants..::.EmailAccountDirection | The direction of email accounts
Public enumeration | BusinessConstants..::.ExpensePaymentType | The Expense Payment Types
Public enumeration | BusinessConstants..::.FieldSize | Size of the fields for the database and user interface (in bytes)
Public enumeration | BusinessConstants..::.FixedRoles | Constants for Fixed roles available in the OfficeClip
Public enumeration | BusinessConstants..::.ObjectLevel | Gets the object levels for security
Public enumeration | BusinessConstants..::.ObjectType | The type of the security object
Public enumeration | BusinessConstants..::.OCServiceCommand | Various commands for OfficeClip Services.
Public enumeration | BusinessConstants..::.TaskFilter | The predetermined filters for the task
Public enumeration | BusinessConstants..::.TaskPriority | The priority of the task
Public enumeration | BusinessConstants..::.TaskStatus | The task status
Public enumeration | BusinessConstants..::.TaskTypes | Types of the task
Public enumeration | BusinessConstants..::.TimesheetPeriod | The timesheet period enumerated type

Copyright OfficeClip LLC 2007


BusinessConstants Class

[image]

OfficeClip API Documentation
BusinessConstants Class
Members See Also

[This is preliminary documentation and is subject to change.]

Defines various constants for the buinsess objects

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class BusinessConstants
Visual Basic (Declaration)
Public Class BusinessConstants
Visual C++
public ref class BusinessConstants

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer..::.BusinessConstants

See Also

BusinessConstants Members
OfficeClip.BusinessLayer Namespace


BusinessConstants Members

[image] [image]

OfficeClip API Documentation
BusinessConstants Members
BusinessConstants Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The BusinessConstants type exposes the following members.

Constructors

 | Name | Description
Public method | BusinessConstants |

Methods

 | Name | Description
 | DefaultAccessAppend | Default value of the append access
 | DefaultAccessDelete | default value of the delete access
 | DefaultAccessRead | Default value of the read access
 | DefaultAccessWrite | Default value of the write access
 | EnabledAccessAppend | Shows if the append access can be enabled for a particular object type
 | EnabledAccessDelete | Shows if the delete access can be enabled for the object type
 | EnabledAccessRead | Shows if the read access can be enabled for a particular object type
 | EnabledAccessWrite | Shows if the write access can be enabled for a particular object type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpensePaymentName | Returns the name of the expense payment type
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetApplicationNameFromObjectId | Returns the application name given the object type id
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHtmlAccessString | Gets the Html access string for a combination of the access values
 | GetObjectLevelColor | Gets the color corresponding to the various object levels. This is used to display various object types on the screen.
 | GetObjectNameFromObjectType | Gets the object name from the object type id
 | GetObjectTypes | Gets the type of the object
 | GetTaskPriorityName | Gets the string name of the task priority
 | GetTaskStatics | Gets the task static information. this contains the id and name for various task enumerated types.
 | GetTaskStatusName | gets the task status name from the enumerated type
 | GetTaskTypeName | Gets the string name of the task type
 | GetTimesheetPeriodName | Returns the name of the timesheet period
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsSecurityObjectType | Returns if the object is associated with the security type
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TestPasswordStrength | Tests the password strength based on the policy
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CalendarBusyColor | Busy color of the calendar event
CalendarFreeAlternateColor | Free alternate color of the calendar event
CalendarFreeColor | Free color of the calendar event
CalendarNoneColor | Color when nothing is selected
CalendarOutOfOfficeColor | Out of Office color of the calendar event
CalendarTentativeColor | Tentative color of the calendar event
OCBlankEmail | The blank email address
SecurityObjectSize | The size of the security object

Properties

Name | Description
SqlNVarCharMaxLimit | Limit imposed by the varchar size for the sql database. Returns 32000 if the sql server is 2005, or 4000 if it is 2000
TitleString | Returns the title string to be shown on the title bar of the browser

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


BusinessConstants Constructor

[image]

OfficeClip API Documentation
BusinessConstants Constructor
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BusinessConstants()

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


BusinessConstants Fields

[image] [image]

OfficeClip API Documentation
BusinessConstants Fields
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The BusinessConstants type exposes the following fields.

Fields

Name | Description
CalendarBusyColor | Busy color of the calendar event
CalendarFreeAlternateColor | Free alternate color of the calendar event
CalendarFreeColor | Free color of the calendar event
CalendarNoneColor | Color when nothing is selected
CalendarOutOfOfficeColor | Out of Office color of the calendar event
CalendarTentativeColor | Tentative color of the calendar event
OCBlankEmail | The blank email address
SecurityObjectSize | The size of the security object

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


CalendarBusyColor Field

[image]

OfficeClip API Documentation
BusinessConstants..::.CalendarBusyColor Field
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Busy color of the calendar event

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public const string CalendarBusyColor
Visual Basic (Declaration)
Public Const CalendarBusyColor As String
Visual C++
public:
literal String^ CalendarBusyColor

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


CalendarFreeAlternateColor Field

[image]

OfficeClip API Documentation
BusinessConstants..::.CalendarFreeAlternateColor Field
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Free alternate color of the calendar event

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public const string CalendarFreeAlternateColor
Visual Basic (Declaration)
Public Const CalendarFreeAlternateColor As String
Visual C++
public:
literal String^ CalendarFreeAlternateColor

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


CalendarFreeColor Field

[image]

OfficeClip API Documentation
BusinessConstants..::.CalendarFreeColor Field
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Free color of the calendar event

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public const string CalendarFreeColor
Visual Basic (Declaration)
Public Const CalendarFreeColor As String
Visual C++
public:
literal String^ CalendarFreeColor

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


CalendarNoneColor Field

[image]

OfficeClip API Documentation
BusinessConstants..::.CalendarNoneColor Field
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Color when nothing is selected

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public const string CalendarNoneColor
Visual Basic (Declaration)
Public Const CalendarNoneColor As String
Visual C++
public:
literal String^ CalendarNoneColor

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


CalendarOutOfOfficeColor Field

[image]

OfficeClip API Documentation
BusinessConstants..::.CalendarOutOfOfficeColor Field
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Out of Office color of the calendar event

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public const string CalendarOutOfOfficeColor
Visual Basic (Declaration)
Public Const CalendarOutOfOfficeColor As String
Visual C++
public:
literal String^ CalendarOutOfOfficeColor

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


CalendarTentativeColor Field

[image]

OfficeClip API Documentation
BusinessConstants..::.CalendarTentativeColor Field
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Tentative color of the calendar event

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public const string CalendarTentativeColor
Visual Basic (Declaration)
Public Const CalendarTentativeColor As String
Visual C++
public:
literal String^ CalendarTentativeColor

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


OCBlankEmail Field

[image]

OfficeClip API Documentation
BusinessConstants..::.OCBlankEmail Field
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The blank email address

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public const string OCBlankEmail
Visual Basic (Declaration)
Public Const OCBlankEmail As String
Visual C++
public:
literal String^ OCBlankEmail

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


SecurityObjectSize Field

[image]

OfficeClip API Documentation
BusinessConstants..::.SecurityObjectSize Field
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The size of the security object

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public const int SecurityObjectSize
Visual Basic (Declaration)
Public Const SecurityObjectSize As Integer
Visual C++
public:
literal int SecurityObjectSize

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


BusinessConstants Methods

[image] [image]

OfficeClip API Documentation
BusinessConstants Methods
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The BusinessConstants type exposes the following methods.

Methods

 | Name | Description
 | DefaultAccessAppend | Default value of the append access
 | DefaultAccessDelete | default value of the delete access
 | DefaultAccessRead | Default value of the read access
 | DefaultAccessWrite | Default value of the write access
 | EnabledAccessAppend | Shows if the append access can be enabled for a particular object type
 | EnabledAccessDelete | Shows if the delete access can be enabled for the object type
 | EnabledAccessRead | Shows if the read access can be enabled for a particular object type
 | EnabledAccessWrite | Shows if the write access can be enabled for a particular object type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpensePaymentName | Returns the name of the expense payment type
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetApplicationNameFromObjectId | Returns the application name given the object type id
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHtmlAccessString | Gets the Html access string for a combination of the access values
 | GetObjectLevelColor | Gets the color corresponding to the various object levels. This is used to display various object types on the screen.
 | GetObjectNameFromObjectType | Gets the object name from the object type id
 | GetObjectTypes | Gets the type of the object
 | GetTaskPriorityName | Gets the string name of the task priority
 | GetTaskStatics | Gets the task static information. this contains the id and name for various task enumerated types.
 | GetTaskStatusName | gets the task status name from the enumerated type
 | GetTaskTypeName | Gets the string name of the task type
 | GetTimesheetPeriodName | Returns the name of the timesheet period
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsSecurityObjectType | Returns if the object is associated with the security type
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TestPasswordStrength | Tests the password strength based on the policy
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


DefaultAccessAppend Method

[image]

OfficeClip API Documentation
BusinessConstants..::.DefaultAccessAppend Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Default value of the append access

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool DefaultAccessAppend(
    BusinessConstants..::.ObjectType oType
)
Visual Basic (Declaration)
Public Shared Function DefaultAccessAppend ( _
    oType As BusinessConstants..::.ObjectType _
) As Boolean
Visual C++
public:
static bool DefaultAccessAppend(
    BusinessConstants..::.ObjectType oType
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


DefaultAccessDelete Method

[image]

OfficeClip API Documentation
BusinessConstants..::.DefaultAccessDelete Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

default value of the delete access

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool DefaultAccessDelete(
    BusinessConstants..::.ObjectType oType
)
Visual Basic (Declaration)
Public Shared Function DefaultAccessDelete ( _
    oType As BusinessConstants..::.ObjectType _
) As Boolean
Visual C++
public:
static bool DefaultAccessDelete(
    BusinessConstants..::.ObjectType oType
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


DefaultAccessRead Method

[image]

OfficeClip API Documentation
BusinessConstants..::.DefaultAccessRead Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Default value of the read access

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool DefaultAccessRead(
    BusinessConstants..::.ObjectType oType
)
Visual Basic (Declaration)
Public Shared Function DefaultAccessRead ( _
    oType As BusinessConstants..::.ObjectType _
) As Boolean
Visual C++
public:
static bool DefaultAccessRead(
    BusinessConstants..::.ObjectType oType
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


DefaultAccessWrite Method

[image]

OfficeClip API Documentation
BusinessConstants..::.DefaultAccessWrite Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Default value of the write access

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool DefaultAccessWrite(
    BusinessConstants..::.ObjectType oType
)
Visual Basic (Declaration)
Public Shared Function DefaultAccessWrite ( _
    oType As BusinessConstants..::.ObjectType _
) As Boolean
Visual C++
public:
static bool DefaultAccessWrite(
    BusinessConstants..::.ObjectType oType
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


EnabledAccessAppend Method

[image]

OfficeClip API Documentation
BusinessConstants..::.EnabledAccessAppend Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the append access can be enabled for a particular object type

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool EnabledAccessAppend(
    BusinessConstants..::.ObjectType oType
)
Visual Basic (Declaration)
Public Shared Function EnabledAccessAppend ( _
    oType As BusinessConstants..::.ObjectType _
) As Boolean
Visual C++
public:
static bool EnabledAccessAppend(
    BusinessConstants..::.ObjectType oType
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type

Return Value

true if the append access can be enabled for the object type

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


EnabledAccessDelete Method

[image]

OfficeClip API Documentation
BusinessConstants..::.EnabledAccessDelete Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the delete access can be enabled for the object type

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool EnabledAccessDelete(
    BusinessConstants..::.ObjectType oType
)
Visual Basic (Declaration)
Public Shared Function EnabledAccessDelete ( _
    oType As BusinessConstants..::.ObjectType _
) As Boolean
Visual C++
public:
static bool EnabledAccessDelete(
    BusinessConstants..::.ObjectType oType
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type

Return Value

true if the delete access can be enabled for this object type

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


EnabledAccessRead Method

[image]

OfficeClip API Documentation
BusinessConstants..::.EnabledAccessRead Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the read access can be enabled for a particular object type

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool EnabledAccessRead(
    BusinessConstants..::.ObjectType oType
)
Visual Basic (Declaration)
Public Shared Function EnabledAccessRead ( _
    oType As BusinessConstants..::.ObjectType _
) As Boolean
Visual C++
public:
static bool EnabledAccessRead(
    BusinessConstants..::.ObjectType oType
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type

Return Value

true if the read access can be enabled for the object type

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


EnabledAccessWrite Method

[image]

OfficeClip API Documentation
BusinessConstants..::.EnabledAccessWrite Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the write access can be enabled for a particular object type.

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool EnabledAccessWrite(
    BusinessConstants..::.ObjectType oType
)
Visual Basic (Declaration)
Public Shared Function EnabledAccessWrite ( _
    oType As BusinessConstants..::.ObjectType _
) As Boolean
Visual C++
public:
static bool EnabledAccessWrite(
    BusinessConstants..::.ObjectType oType
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type.

Return Value

true if the write access can be enable for the object type.

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


ExpensePaymentName Method

[image]

OfficeClip API Documentation
BusinessConstants..::.ExpensePaymentName Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the name of the expense payment type

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string ExpensePaymentName(
    BusinessConstants..::.ExpensePaymentType ept
)
Visual Basic (Declaration)
Public Shared Function ExpensePaymentName ( _
    ept As BusinessConstants..::.ExpensePaymentType _
) As String
Visual C++
public:
static String^ ExpensePaymentName(
    BusinessConstants..::.ExpensePaymentType ept
)

Parameters

ept
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ExpensePaymentType
The expense payment type

Return Value

The expense payment name

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


GetApplicationNameFromObjectId Method

[image]

OfficeClip API Documentation
BusinessConstants..::.GetApplicationNameFromObjectId Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the application name given the object type id

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetApplicationNameFromObjectId(
    BusinessConstants..::.ObjectType ot
)
Visual Basic (Declaration)
Public Shared Function GetApplicationNameFromObjectId ( _
    ot As BusinessConstants..::.ObjectType _
) As String
Visual C++
public:
static String^ GetApplicationNameFromObjectId(
    BusinessConstants..::.ObjectType ot
)

Parameters

ot
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type

Return Value

The application name as string

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


GetHtmlAccessString Method

[image]

OfficeClip API Documentation
BusinessConstants..::.GetHtmlAccessString Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Html access string for a combination of the access values

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetHtmlAccessString(
    bool accessRead,
    bool accessWrite,
    bool accessAppend,
    bool accessDelete
)
Visual Basic (Declaration)
Public Shared Function GetHtmlAccessString ( _
    accessRead As Boolean, _
    accessWrite As Boolean, _
    accessAppend As Boolean, _
    accessDelete As Boolean _
) As String
Visual C++
public:
static String^ GetHtmlAccessString(
    bool accessRead,
    bool accessWrite,
    bool accessAppend,
    bool accessDelete
)

Parameters

accessRead
Type: System..::.Boolean
Whether the read access is granted
accessWrite
Type: System..::.Boolean
Whether the write access is granted
accessAppend
Type: System..::.Boolean
Whether the append access is granted
accessDelete
Type: System..::.Boolean
Whether the delete access is granted

Return Value

The html string that shows the access permisssion

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


GetObjectLevelColor Method

[image]

OfficeClip API Documentation
BusinessConstants..::.GetObjectLevelColor Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the color corresponding to the various object levels. This is used to display various object types on the screen.

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static Color GetObjectLevelColor(
    BusinessConstants..::.ObjectLevel ol
)
Visual Basic (Declaration)
Public Shared Function GetObjectLevelColor ( _
    ol As BusinessConstants..::.ObjectLevel _
) As Color
Visual C++
public:
static Color GetObjectLevelColor(
    BusinessConstants..::.ObjectLevel ol
)

Parameters

ol
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectLevel
The object level

Return Value

The color of the object level

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


GetObjectNameFromObjectType Method

[image]

OfficeClip API Documentation
BusinessConstants..::.GetObjectNameFromObjectType Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object name from the object type id

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetObjectNameFromObjectType(
    BusinessConstants..::.ObjectType ot
)
Visual Basic (Declaration)
Public Shared Function GetObjectNameFromObjectType ( _
    ot As BusinessConstants..::.ObjectType _
) As String
Visual C++
public:
static String^ GetObjectNameFromObjectType(
    BusinessConstants..::.ObjectType ot
)

Parameters

ot
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type id

Return Value

The object name

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


GetObjectTypes Method

[image]

OfficeClip API Documentation
BusinessConstants..::.GetObjectTypes Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the type of the object

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataTable GetObjectTypes()
Visual Basic (Declaration)
Public Shared Function GetObjectTypes As DataTable
Visual C++
public:
static DataTable^ GetObjectTypes()

Return Value

The datatable that gives the type information

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


GetTaskPriorityName Method

[image]

OfficeClip API Documentation
BusinessConstants..::.GetTaskPriorityName Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the string name of the task priority

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetTaskPriorityName(
    BusinessConstants..::.TaskPriority tp
)
Visual Basic (Declaration)
Public Shared Function GetTaskPriorityName ( _
    tp As BusinessConstants..::.TaskPriority _
) As String
Visual C++
public:
static String^ GetTaskPriorityName(
    BusinessConstants..::.TaskPriority tp
)

Parameters

tp
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TaskPriority
The task priority enumerated type

Return Value

The string name of the task priority

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


GetTaskStatics Method

[image]

OfficeClip API Documentation
BusinessConstants..::.GetTaskStatics Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the task static information. this contains the id and name for various task enumerated types.

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataSet GetTaskStatics(
    GroupSelection gs
)
Visual Basic (Declaration)
Public Shared Function GetTaskStatics ( _
    gs As GroupSelection _
) As DataSet
Visual C++
public:
static DataSet^ GetTaskStatics(
    GroupSelection gs
)

Parameters

gs
Type: OfficeClip.Utils..::.GroupSelection
The group selection criteria

Return Value

The dataset that provides the task static information

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


GetTaskStatusName Method

[image]

OfficeClip API Documentation
BusinessConstants..::.GetTaskStatusName Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

gets the task status name from the enumerated type

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetTaskStatusName(
    BusinessConstants..::.TaskStatus ts
)
Visual Basic (Declaration)
Public Shared Function GetTaskStatusName ( _
    ts As BusinessConstants..::.TaskStatus _
) As String
Visual C++
public:
static String^ GetTaskStatusName(
    BusinessConstants..::.TaskStatus ts
)

Parameters

ts
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TaskStatus
The task status enumerated type

Return Value

The task status name

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


GetTaskTypeName Method

[image]

OfficeClip API Documentation
BusinessConstants..::.GetTaskTypeName Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the string name of the task type

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetTaskTypeName(
    BusinessConstants..::.TaskTypes t
)
Visual Basic (Declaration)
Public Shared Function GetTaskTypeName ( _
    t As BusinessConstants..::.TaskTypes _
) As String
Visual C++
public:
static String^ GetTaskTypeName(
    BusinessConstants..::.TaskTypes t
)

Parameters

t
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TaskTypes
The task type

Return Value

The string name of the task

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


GetTimesheetPeriodName Method

[image]

OfficeClip API Documentation
BusinessConstants..::.GetTimesheetPeriodName Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the name of the timesheet period

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetTimesheetPeriodName(
    BusinessConstants..::.TimesheetPeriod tp
)
Visual Basic (Declaration)
Public Shared Function GetTimesheetPeriodName ( _
    tp As BusinessConstants..::.TimesheetPeriod _
) As String
Visual C++
public:
static String^ GetTimesheetPeriodName(
    BusinessConstants..::.TimesheetPeriod tp
)

Parameters

tp
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TimesheetPeriod
The timesheet period object

Return Value

The name of the timesheet period

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


IsSecurityObjectType Method

[image]

OfficeClip API Documentation
BusinessConstants..::.IsSecurityObjectType Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Returns if the object is associated with the security type

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool IsSecurityObjectType(
    BusinessConstants..::.ObjectType ot
)
Visual Basic (Declaration)
Public Shared Function IsSecurityObjectType ( _
    ot As BusinessConstants..::.ObjectType _
) As Boolean
Visual C++
public:
static bool IsSecurityObjectType(
    BusinessConstants..::.ObjectType ot
)

Parameters

ot
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The type pf the object

Return Value

true if the object has security type associated with it, false otherwise

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


TestPasswordStrength Method

[image]

OfficeClip API Documentation
BusinessConstants..::.TestPasswordStrength Method
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Tests the password strength based on the policy

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string TestPasswordStrength(
    string currentPassword
)
Visual Basic (Declaration)
Public Shared Function TestPasswordStrength ( _
    currentPassword As String _
) As String
Visual C++
public:
static String^ TestPasswordStrength(
    String^ currentPassword
)

Parameters

currentPassword
Type: System..::.String
The current password

Return Value

Empty if the password matches otherwise the error message

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


BusinessConstants Properties

[image] [image]

OfficeClip API Documentation
BusinessConstants Properties
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The BusinessConstants type exposes the following properties.

Properties

Name | Description
SqlNVarCharMaxLimit | Limit imposed by the varchar size for the sql database. Returns 32000 if the sql server is 2005, or 4000 if it is 2000
TitleString | Returns the title string to be shown on the title bar of the browser

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


SqlNVarCharMaxLimit Property

[image]

OfficeClip API Documentation
BusinessConstants..::.SqlNVarCharMaxLimit Property
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Limit imposed by the varchar size for the sql database. Returns 32000 if the sql server is 2005, or 4000 if it is 2000

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static int SqlNVarCharMaxLimit { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SqlNVarCharMaxLimit As Integer
Visual C++
public:
static property int SqlNVarCharMaxLimit {
    int get ();
}

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


TitleString Property

[image]

OfficeClip API Documentation
BusinessConstants..::.TitleString Property
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the title string to be shown on the title bar of the browser

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string TitleString { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TitleString As String
Visual C++
public:
static property String^ TitleString {
    String^ get ();
}

See Also

BusinessConstants Class
OfficeClip.BusinessLayer Namespace


BusinessConstants.DurationTypes Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.DurationTypes Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Duration types pertaining to any object with a defined duration.

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum DurationTypes
Visual Basic (Declaration)
Public Enumeration DurationTypes
Visual C++
public enum class DurationTypes

Members

Member name | Description
Minutes | Duration in minutes
Hours | Duration in hours
Days | Duration in days
Weeks | Duration in weeks
Months | Duration in months
Years | duration in years

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.EmailAccountDirection Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.EmailAccountDirection Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The direction of email accounts

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum EmailAccountDirection
Visual Basic (Declaration)
Public Enumeration EmailAccountDirection
Visual C++
public enum class EmailAccountDirection

Members

Member name | Description
None | None
ReceiveOnly | Account set for receive only
SendOnly | Account set for Send Only
SendAndReceive | Account set for send and receive

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.ExpensePaymentType Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.ExpensePaymentType Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The Expense Payment Types

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ExpensePaymentType
Visual Basic (Declaration)
Public Enumeration ExpensePaymentType
Visual C++
public enum class ExpensePaymentType

Members

Member name | Description
None | No Type (default)
PersonalCashOrCheck | Expense payment type of personal cash or check
PersonalCreditCard | Expense payment type of personal credit card
CompanyCreditCard | Expense payment type of company credit card

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.FieldSize Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.FieldSize Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Size of the fields for the database and user interface (in bytes)

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum FieldSize
Visual Basic (Declaration)
Public Enumeration FieldSize
Visual C++
public enum class FieldSize

Members

Member name | Description
None | None as placeholder
Numeric | Numeric field
Name | Name field used to hold short text (30 chars)
Text | Text field used to store short text
Description | Description field used to hold longer text (255 chars)
LongDescription | Long Description field used to hold long description (4000 chars)
CommaSeparatedIds | Size of the string for comma separated ids

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.FixedRoles Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.FixedRoles Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Constants for Fixed roles available in the OfficeClip

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum FixedRoles
Visual Basic (Declaration)
Public Enumeration FixedRoles
Visual C++
public enum class FixedRoles

Members

Member name | Description
None | None as placeholder
NotAvailable | Not Available placeholder
Administrator | OfficeClip Administrator role
AllMembers | OfficeClip all users role

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.ObjectLevel Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.ObjectLevel Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object levels for security

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ObjectLevel
Visual Basic (Declaration)
Public Enumeration ObjectLevel
Visual C++
public enum class ObjectLevel

Members

Member name | Description
None | The default object level
System | The system object level
Group | The group object level
Role | The role object level
User | The user object level

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.ObjectType Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.ObjectType Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The type of the security object

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ObjectType
Visual Basic (Declaration)
Public Enumeration ObjectType
Visual C++
public enum class ObjectType

Members

Member name | Description
None | None as placeholder
Document | The document type object
Task | The task type object
TimeSheet | The timesheet object
ExpenseReport | The expense report object
Event | The event object
BBForum | The bulletin board forum object
BBTopic | The bulletin board topic object
BBReply | The bulletin board reply object
Photo | the photo object
TrackerProject | The tracker project object
TrackerCase | The tracker case object
Announcement | The announcement object
Poll | The poll object
Alert | The alert object
Contact | The Contact object
Other | The other object used for test case
History | The history object
Appointment | The appointment object
Filter | The filter object
Email | The Email Object
Note | The Notes object
Campaign | The campaign object
Folder | The folder object
Account | The Account Object
Opportunity | The Opportunity Object
OfficeClipMembers | The OfficeClip Member Object
ExtranetMembers | The Extranet Member Object
AddressBookEntry | The OfficeClip Addressbook object
Projects | OfficeClip Projects
Reports | OfficeClip Reports
ContactRole | The contact role... mainly used as children of the opportunity
Relation | The Relation... mainly used as children of the Meta Entities
ObjectTypeSize | Placeholder for the size

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.OCServiceCommand Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.OCServiceCommand Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Various commands for OfficeClip Services.

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum OCServiceCommand
Visual Basic (Declaration)
Public Enumeration OCServiceCommand
Visual C++
public enum class OCServiceCommand

Members

Member name | Description
None | The default value showing that the command is not specified
DBInsert | Insert this object in the database
DBUpdate | Update this object in the database
DBDelete | Delete this object from this database

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.TaskFilter Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.TaskFilter Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The predetermined filters for the task

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum TaskFilter
Visual Basic (Declaration)
Public Enumeration TaskFilter
Visual C++
public enum class TaskFilter

Members

Member name | Description
None | The default filter
IncompleteStatus | Filter for incomplete status
All | No filter applied
HighPriority | All high priority tasks
MediumPriority | All medium priority tasks
LowPriority | All low priority tasks
OtherPriority | All other priority tasks
InProgressStatus | All tasks with inprogress status
CompletedStatus | All tasks with the completed status
PendingStatus | All tasks with the pending status
WaitingStatus | All tasks with the waiting status
OtherStatus | All tasks with the other status
TelephoneType | All tasks with type telephone
ToDoType | All taks with type todo
EmailType | All tasks with type email
OtherType | All taks with type other
Tomorrow | All tasks with due date of tomorrow
Next7Days | All tasks with due date of the next 7 days
Next30Days | All tasks with due date of the next 30 days
Next365Days | All tasks with the due date of next 365 days

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.TaskPriority Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.TaskPriority Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The priority of the task

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum TaskPriority
Visual Basic (Declaration)
Public Enumeration TaskPriority
Visual C++
public enum class TaskPriority

Members

Member name | Description
None | The default priority
High | High Priority
Medium | Medium Priority
Low | Low Priority
Other | Other not covered by the above

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.TaskStatus Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.TaskStatus Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The task status

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum TaskStatus
Visual Basic (Declaration)
Public Enumeration TaskStatus
Visual C++
public enum class TaskStatus

Members

Member name | Description
None | Default Task Status
InProgress | The task is in progress
Completed | The task is completed
Pending | The task is pending or deferred
Waiting | The task is waiting on someone else
Other | Any other reason not covered by the above

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.TaskTypes Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.TaskTypes Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

Types of the task

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum TaskTypes
Visual Basic (Declaration)
Public Enumeration TaskTypes
Visual C++
public enum class TaskTypes

Members

Member name | Description
None | The default value showing that no task type is specified
Telephone | The task type specifying the telephone calls
ToDo | The task type specifying todo list
Email | The task type specifying sending email
Other | The task type not covered by anything above

See Also

OfficeClip.BusinessLayer Namespace


BusinessConstants.TimesheetPeriod Enumeration

[image]

OfficeClip API Documentation
BusinessConstants..::.TimesheetPeriod Enumeration
BusinessConstants Class See Also

[This is preliminary documentation and is subject to change.]

The timesheet period enumerated type

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum TimesheetPeriod
Visual Basic (Declaration)
Public Enumeration TimesheetPeriod
Visual C++
public enum class TimesheetPeriod

Members

Member name | Description
None | Period not defined
Weekly | Weekly timesheet
BiWeekly | Biweekly timesheet
SemiMonthly | semimonthly timesheet, 1-15 and 16-end of the month
Monthly | monthly timesheet
Daily | Daily timesheet

See Also

OfficeClip.BusinessLayer Namespace


NameValue Class

[image]

OfficeClip API Documentation
NameValue Class
Members See Also

[This is preliminary documentation and is subject to change.]

Name/value container for use in Name/Value collections

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class NameValue
Visual Basic (Declaration)
Public Class NameValue
Visual C++
public ref class NameValue

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer..::.NameValue

See Also

NameValue Members
OfficeClip.BusinessLayer Namespace


NameValue Members

[image] [image]

OfficeClip API Documentation
NameValue Members
NameValue Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The NameValue type exposes the following members.

Constructors

 | Name | Description
Public method | NameValue | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

NameValue Class
OfficeClip.BusinessLayer Namespace


NameValue Constructor

[image] [image]

OfficeClip API Documentation
NameValue Constructor
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | NameValue()()() | constructor
Public method | NameValue(String, String) | contructor

See Also

NameValue Class
NameValue Members
OfficeClip.BusinessLayer Namespace


NameValue Constructor

[image]

OfficeClip API Documentation
NameValue Constructor
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NameValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NameValue()

See Also

NameValue Class
NameValue Overload
OfficeClip.BusinessLayer Namespace


NameValue Constructor (String, String)

[image]

OfficeClip API Documentation
NameValue Constructor (String, String)
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

contructor

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NameValue(
    string name,
    string val
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    val As String _
)
Visual C++
public:
NameValue(
    String^ name,
    String^ val
)

Parameters

name
Type: System..::.String
val
Type: System..::.String

See Also

NameValue Class
NameValue Overload
OfficeClip.BusinessLayer Namespace


NameValue Properties

[image] [image]

OfficeClip API Documentation
NameValue Properties
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

The NameValue type exposes the following properties.

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

NameValue Class
OfficeClip.BusinessLayer Namespace


Name Property

[image]

OfficeClip API Documentation
NameValue..::.Name Property
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

NameValue Class
OfficeClip.BusinessLayer Namespace


Value Property

[image]

OfficeClip API Documentation
NameValue..::.Value Property
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

NameValue Class
OfficeClip.BusinessLayer Namespace


ObjectTypeRelation Class

[image]

OfficeClip API Documentation
ObjectTypeRelation Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class for object type relations. Shows relation between types

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ObjectTypeRelation
Visual Basic (Declaration)
Public Class ObjectTypeRelation
Visual C++
public ref class ObjectTypeRelation

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer..::.ObjectTypeRelation

See Also

ObjectTypeRelation Members
OfficeClip.BusinessLayer Namespace


ObjectTypeRelation Members

[image] [image]

OfficeClip API Documentation
ObjectTypeRelation Members
ObjectTypeRelation Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The ObjectTypeRelation type exposes the following members.

Constructors

 | Name | Description
Public method | ObjectTypeRelation | The default constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllowedChildren | Get the allowed children object. This method checks up the applications that are allowed by the current user and returns only those child objects that are consistent with this.
Public method | GetAllParents | Gets all the parents of an object
Public method | GetChildren | Get the child objects for a parent type
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectTypeRelation Class
OfficeClip.BusinessLayer Namespace


ObjectTypeRelation Constructor

[image]

OfficeClip API Documentation
ObjectTypeRelation Constructor
ObjectTypeRelation Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ObjectTypeRelation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ObjectTypeRelation()

See Also

ObjectTypeRelation Class
OfficeClip.BusinessLayer Namespace


ObjectTypeRelation Methods

[image] [image]

OfficeClip API Documentation
ObjectTypeRelation Methods
ObjectTypeRelation Class See Also

[This is preliminary documentation and is subject to change.]

The ObjectTypeRelation type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllowedChildren | Get the allowed children object. This method checks up the applications that are allowed by the current user and returns only those child objects that are consistent with this.
Public method | GetAllParents | Gets all the parents of an object
Public method | GetChildren | Get the child objects for a parent type
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectTypeRelation Class
OfficeClip.BusinessLayer Namespace


GetAllowedChildren Method

[image]

OfficeClip API Documentation
ObjectTypeRelation..::.GetAllowedChildren Method
ObjectTypeRelation Class See Also

[This is preliminary documentation and is subject to change.]

Get the allowed children object. This method checks up the applications that are allowed by the current user and returns only those child objects that are consistent with this.

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<BusinessConstants..::.ObjectType> GetAllowedChildren(
    BusinessConstants..::.ObjectType parent
)
Visual Basic (Declaration)
Public Function GetAllowedChildren ( _
    parent As BusinessConstants..::.ObjectType _
) As List(Of BusinessConstants..::.ObjectType)
Visual C++
public:
List<BusinessConstants..::.ObjectType>^ GetAllowedChildren(
    BusinessConstants..::.ObjectType parent
)

Parameters

parent
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The parent object type

Return Value

The arraylist of allowed children. The session has to be valid if this method has to return the correct values. If the session is not present, then this methods throws an exception

See Also

ObjectTypeRelation Class
OfficeClip.BusinessLayer Namespace


GetAllParents Method

[image]

OfficeClip API Documentation
ObjectTypeRelation..::.GetAllParents Method
ObjectTypeRelation Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the parents of an object

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants..::.ObjectType[] GetAllParents(
    BusinessConstants..::.ObjectType child
)
Visual Basic (Declaration)
Public Function GetAllParents ( _
    child As BusinessConstants..::.ObjectType _
) As BusinessConstants..::.ObjectType()
Visual C++
public:
array<BusinessConstants..::.ObjectType>^ GetAllParents(
    BusinessConstants..::.ObjectType child
)

Parameters

child
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The child whose parents are sought

Return Value

The parents of the child

See Also

ObjectTypeRelation Class
OfficeClip.BusinessLayer Namespace


GetChildren Method

[image]

OfficeClip API Documentation
ObjectTypeRelation..::.GetChildren Method
ObjectTypeRelation Class See Also

[This is preliminary documentation and is subject to change.]

Get the child objects for a parent type

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<BusinessConstants..::.ObjectType> GetChildren(
    BusinessConstants..::.ObjectType parent
)
Visual Basic (Declaration)
Public Function GetChildren ( _
    parent As BusinessConstants..::.ObjectType _
) As List(Of BusinessConstants..::.ObjectType)
Visual C++
public:
List<BusinessConstants..::.ObjectType>^ GetChildren(
    BusinessConstants..::.ObjectType parent
)

Parameters

parent
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The parent object type

Return Value

The list of child objects

See Also

ObjectTypeRelation Class
OfficeClip.BusinessLayer Namespace


Utility Class

[image]

OfficeClip API Documentation
Utility Class
Members See Also

[This is preliminary documentation and is subject to change.]

Utility functions

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class Utility
Visual Basic (Declaration)
Public Class Utility
Visual C++
public ref class Utility

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer..::.Utility

See Also

Utility Members
OfficeClip.BusinessLayer Namespace


Utility Members

[image] [image]

OfficeClip API Documentation
Utility Members
Utility Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The Utility type exposes the following members.

Constructors

 | Name | Description
Public method | Utility |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBiweekStartDates | Get the range of biweekly start dates for timesheet and expense reports
 | GetDailyView | Returns the datatable after loading the calendar daily view. Only time related information is loaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMonthlyView | Returns a DataTable that contains the monthly view of the month for the selected date
 | GetMonthStartDates | Return the month start dates in the datatable
 | GetNumDays | Gets the number of days in the particular pay period
 | GetPeriodicView | Overloaded.
 | GetPeriodStartDates | Gets the multiple periods for the start dates of the timesheet and expense report
 | GetSemiMonthStartDates | Get the semi monthly start dates
 | GetStartDate | Gets the start date of the payroll cycle
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWeeklyView | Overloaded.
 | GetWeekStartDates | Returns the weekly start dates in a DataTable.
 | GetYearlyView | Returns the yearly view
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


Utility Constructor

[image]

OfficeClip API Documentation
Utility Constructor
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Utility()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Utility()

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


Utility Methods

[image] [image]

OfficeClip API Documentation
Utility Methods
Utility Class See Also

[This is preliminary documentation and is subject to change.]

The Utility type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBiweekStartDates | Get the range of biweekly start dates for timesheet and expense reports
 | GetDailyView | Returns the datatable after loading the calendar daily view. Only time related information is loaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMonthlyView | Returns a DataTable that contains the monthly view of the month for the selected date
 | GetMonthStartDates | Return the month start dates in the datatable
 | GetNumDays | Gets the number of days in the particular pay period
 | GetPeriodicView | Overloaded.
 | GetPeriodStartDates | Gets the multiple periods for the start dates of the timesheet and expense report
 | GetSemiMonthStartDates | Get the semi monthly start dates
 | GetStartDate | Gets the start date of the payroll cycle
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWeeklyView | Overloaded.
 | GetWeekStartDates | Returns the weekly start dates in a DataTable.
 | GetYearlyView | Returns the yearly view
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


GetBiweekStartDates Method

[image]

OfficeClip API Documentation
Utility..::.GetBiweekStartDates Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Get the range of biweekly start dates for timesheet and expense reports

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected static DataTable GetBiweekStartDates(
    DateTime selDate,
    DayOfWeek weekStartDay,
    DateTime payrollStartDate,
    int numPeriodForward,
    int numPeriodBackward
)
Visual Basic (Declaration)
Protected Shared Function GetBiweekStartDates ( _
    selDate As DateTime, _
    weekStartDay As DayOfWeek, _
    payrollStartDate As DateTime, _
    numPeriodForward As Integer, _
    numPeriodBackward As Integer _
) As DataTable
Visual C++
protected:
static DataTable^ GetBiweekStartDates(
    DateTime selDate,
    DayOfWeek weekStartDay,
    DateTime payrollStartDate,
    int numPeriodForward,
    int numPeriodBackward
)

Parameters

selDate
Type: System..::.DateTime
The date in question
weekStartDay
Type: System..::.DayOfWeek
The starting date of the week
payrollStartDate
Type: System..::.DateTime
The payroll start date
numPeriodForward
Type: System..::.Int32
numPeriodBackward
Type: System..::.Int32

Return Value

The datatable containing all the requested dates

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


GetDailyView Method

[image]

OfficeClip API Documentation
Utility..::.GetDailyView Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Returns the datatable after loading the calendar daily view. Only time related information is loaded.

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataTable GetDailyView(
    DateTime startDateTime,
    DateTime endDateTime
)
Visual Basic (Declaration)
Public Shared Function GetDailyView ( _
    startDateTime As DateTime, _
    endDateTime As DateTime _
) As DataTable
Visual C++
public:
static DataTable^ GetDailyView(
    DateTime startDateTime,
    DateTime endDateTime
)

Parameters

startDateTime
Type: System..::.DateTime
The date and time for the start of the day.
endDateTime
Type: System..::.DateTime
The date and time for the end of the day.

Return Value

The datatable having a unique id column and a description column showing the time of the day.

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


GetMonthlyView Method

[image]

OfficeClip API Documentation
Utility..::.GetMonthlyView Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Returns a DataTable that contains the monthly view of the month for the selected date

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataTable GetMonthlyView(
    DateTime selDate,
    bool includeDayHeader,
    DayOfWeek weekStartDay
)
Visual Basic (Declaration)
Public Shared Function GetMonthlyView ( _
    selDate As DateTime, _
    includeDayHeader As Boolean, _
    weekStartDay As DayOfWeek _
) As DataTable
Visual C++
public:
static DataTable^ GetMonthlyView(
    DateTime selDate,
    bool includeDayHeader,
    DayOfWeek weekStartDay
)

Parameters

selDate
Type: System..::.DateTime
The date for which the monthly view is supposed to be displayed
includeDayHeader
Type: System..::.Boolean
Whether the day header is supposed to be included. The day headers are three letter representation of the day of the week.
weekStartDay
Type: System..::.DayOfWeek
The week start day

Return Value

A DataTable consisting of the following parts, id - set to an unavailable constant, Dt - Set the minimum date value, Desc - the Description of the date.

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


GetMonthStartDates Method

[image]

OfficeClip API Documentation
Utility..::.GetMonthStartDates Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Return the month start dates in the datatable

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected static DataTable GetMonthStartDates(
    DateTime selDate,
    DateTime payrollStartDate,
    int numPeriodForward,
    int numPeriodBackward
)
Visual Basic (Declaration)
Protected Shared Function GetMonthStartDates ( _
    selDate As DateTime, _
    payrollStartDate As DateTime, _
    numPeriodForward As Integer, _
    numPeriodBackward As Integer _
) As DataTable
Visual C++
protected:
static DataTable^ GetMonthStartDates(
    DateTime selDate,
    DateTime payrollStartDate,
    int numPeriodForward,
    int numPeriodBackward
)

Parameters

selDate
Type: System..::.DateTime
The reference date, usually it is the current date
payrollStartDate
Type: System..::.DateTime
the date when the payroll starts
numPeriodForward
Type: System..::.Int32
numPeriodBackward
Type: System..::.Int32

Return Value

The datatable containing the dates

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


GetNumDays Method

[image]

OfficeClip API Documentation
Utility..::.GetNumDays Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Gets the number of days in the particular pay period

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static int GetNumDays(
    DateTime selDate,
    BusinessConstants..::.TimesheetPeriod tp
)
Visual Basic (Declaration)
Public Shared Function GetNumDays ( _
    selDate As DateTime, _
    tp As BusinessConstants..::.TimesheetPeriod _
) As Integer
Visual C++
public:
static int GetNumDays(
    DateTime selDate,
    BusinessConstants..::.TimesheetPeriod tp
)

Parameters

selDate
Type: System..::.DateTime
the date from which the pay period needs to be calculated
tp
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TimesheetPeriod
The timesheet period

Return Value

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


GetPeriodicView Method

[image] [image]

OfficeClip API Documentation
Utility..::.GetPeriodicView Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetPeriodicView(DateTime, BusinessConstants..::.TimesheetPeriod) | Gets the periodic view for timesheet and expense reports
GetPeriodicView(DateTime, DateTime) | Gets the periodic view for timesheet and expense reports
GetPeriodicView(DateTime, Int32) | Returns the periodic view on a datatable

See Also

Utility Class
Utility Members
OfficeClip.BusinessLayer Namespace


GetPeriodicView Method (DateTime, BusinessConstants.TimesheetPeriod)

[image]

OfficeClip API Documentation
Utility..::.GetPeriodicView Method (DateTime, BusinessConstants..::.TimesheetPeriod)
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Gets the periodic view for timesheet and expense reports

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataTable GetPeriodicView(
    DateTime selDate,
    BusinessConstants..::.TimesheetPeriod tp
)
Visual Basic (Declaration)
Public Shared Function GetPeriodicView ( _
    selDate As DateTime, _
    tp As BusinessConstants..::.TimesheetPeriod _
) As DataTable
Visual C++
public:
static DataTable^ GetPeriodicView(
    DateTime selDate,
    BusinessConstants..::.TimesheetPeriod tp
)

Parameters

selDate
Type: System..::.DateTime
The selected start date
tp
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TimesheetPeriod
The time period, this could be weekly, biweekly, semimonthly or monthly

Return Value

The datatable returns the following values Dt - The date in question, Desc1 - the day in question, Desc2 - The month in question, Hr - 0 (fixed value)

See Also

Utility Class
GetPeriodicView Overload
OfficeClip.BusinessLayer Namespace


GetPeriodicView Method (DateTime, DateTime)

[image]

OfficeClip API Documentation
Utility..::.GetPeriodicView Method (DateTime, DateTime)
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Gets the periodic view for timesheet and expense reports

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataTable GetPeriodicView(
    DateTime selDate,
    DateTime selEndDate
)
Visual Basic (Declaration)
Public Shared Function GetPeriodicView ( _
    selDate As DateTime, _
    selEndDate As DateTime _
) As DataTable
Visual C++
public:
static DataTable^ GetPeriodicView(
    DateTime selDate,
    DateTime selEndDate
)

Parameters

selDate
Type: System..::.DateTime
The selected start date
selEndDate
Type: System..::.DateTime
The selected end date

Return Value

The datatable returns the following values Dt - The date in question, Desc1 - the day in question, Desc2 - The month in question, Hr - 0 (fixed value)

See Also

Utility Class
GetPeriodicView Overload
OfficeClip.BusinessLayer Namespace


GetPeriodicView Method (DateTime, Int32)

[image]

OfficeClip API Documentation
Utility..::.GetPeriodicView Method (DateTime, Int32)
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Returns the periodic view on a datatable

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected static DataTable GetPeriodicView(
    DateTime selDate,
    int numDays
)
Visual Basic (Declaration)
Protected Shared Function GetPeriodicView ( _
    selDate As DateTime, _
    numDays As Integer _
) As DataTable
Visual C++
protected:
static DataTable^ GetPeriodicView(
    DateTime selDate,
    int numDays
)

Parameters

selDate
Type: System..::.DateTime
The selected date
numDays
Type: System..::.Int32
Number of days

Return Value

Te periodic view

See Also

Utility Class
GetPeriodicView Overload
OfficeClip.BusinessLayer Namespace


GetPeriodStartDates Method

[image]

OfficeClip API Documentation
Utility..::.GetPeriodStartDates Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Gets the multiple periods for the start dates of the timesheet and expense report

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataTable GetPeriodStartDates(
    BusinessConstants..::.TimesheetPeriod tp,
    DateTime selDate,
    DayOfWeek weekStartDay,
    DateTime payrollStartDate,
    int numPeriodForward,
    int numPeriodBackward
)
Visual Basic (Declaration)
Public Shared Function GetPeriodStartDates ( _
    tp As BusinessConstants..::.TimesheetPeriod, _
    selDate As DateTime, _
    weekStartDay As DayOfWeek, _
    payrollStartDate As DateTime, _
    numPeriodForward As Integer, _
    numPeriodBackward As Integer _
) As DataTable
Visual C++
public:
static DataTable^ GetPeriodStartDates(
    BusinessConstants..::.TimesheetPeriod tp,
    DateTime selDate,
    DayOfWeek weekStartDay,
    DateTime payrollStartDate,
    int numPeriodForward,
    int numPeriodBackward
)

Parameters

tp
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TimesheetPeriod
The timesheet period (weekly, biweekly, semimonthly or monthly
selDate
Type: System..::.DateTime
The selected date in question
weekStartDay
Type: System..::.DayOfWeek
The week start day
payrollStartDate
Type: System..::.DateTime
The payroll start date
numPeriodForward
Type: System..::.Int32
Number of period forward from the current date that should be returned
numPeriodBackward
Type: System..::.Int32
Number of period backward from the current date that should be returned

Return Value

The datatable corresponding to the dates

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


GetSemiMonthStartDates Method

[image]

OfficeClip API Documentation
Utility..::.GetSemiMonthStartDates Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Get the semi monthly start dates

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected static DataTable GetSemiMonthStartDates(
    DateTime selDate,
    DateTime payrollStartDate,
    int numPeriodForward,
    int numPeriodBackward
)
Visual Basic (Declaration)
Protected Shared Function GetSemiMonthStartDates ( _
    selDate As DateTime, _
    payrollStartDate As DateTime, _
    numPeriodForward As Integer, _
    numPeriodBackward As Integer _
) As DataTable
Visual C++
protected:
static DataTable^ GetSemiMonthStartDates(
    DateTime selDate,
    DateTime payrollStartDate,
    int numPeriodForward,
    int numPeriodBackward
)

Parameters

selDate
Type: System..::.DateTime
The date in question
payrollStartDate
Type: System..::.DateTime
The starting date of the payroll
numPeriodForward
Type: System..::.Int32
numPeriodBackward
Type: System..::.Int32

Return Value

The datatable containing all the dates

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


GetStartDate Method

[image]

OfficeClip API Documentation
Utility..::.GetStartDate Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Gets the start date of the payroll cycle

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DateTime GetStartDate(
    DateTime selDate,
    DayOfWeek weekStartDay,
    DateTime payrollStartDate,
    BusinessConstants..::.TimesheetPeriod tp
)
Visual Basic (Declaration)
Public Shared Function GetStartDate ( _
    selDate As DateTime, _
    weekStartDay As DayOfWeek, _
    payrollStartDate As DateTime, _
    tp As BusinessConstants..::.TimesheetPeriod _
) As DateTime
Visual C++
public:
static DateTime GetStartDate(
    DateTime selDate,
    DayOfWeek weekStartDay,
    DateTime payrollStartDate,
    BusinessConstants..::.TimesheetPeriod tp
)

Parameters

selDate
Type: System..::.DateTime
The selected date from where the start date has to be determined
weekStartDay
Type: System..::.DayOfWeek
The week start date for weekly and biweekly time and expenses
payrollStartDate
Type: System..::.DateTime
The start date of the payroll
tp
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TimesheetPeriod
The timesheet period: weekly, biweekly, semimonthly and semimonthly

Return Value

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


GetWeeklyView Method

[image] [image]

OfficeClip API Documentation
Utility..::.GetWeeklyView Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetWeeklyView(DateTime, DayOfWeek) | Returns the weekly view for a week
GetWeeklyView(DateTime, DayOfWeek, String) | Get the calendar date time after loading the weekly view. Only information related to the date and time are loaded

See Also

Utility Class
Utility Members
OfficeClip.BusinessLayer Namespace


GetWeeklyView Method (DateTime, DayOfWeek)

[image]

OfficeClip API Documentation
Utility..::.GetWeeklyView Method (DateTime, DayOfWeek)
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Returns the weekly view for a week

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataTable GetWeeklyView(
    DateTime selDate,
    DayOfWeek weekStartDay
)
Visual Basic (Declaration)
Public Shared Function GetWeeklyView ( _
    selDate As DateTime, _
    weekStartDay As DayOfWeek _
) As DataTable
Visual C++
public:
static DataTable^ GetWeeklyView(
    DateTime selDate,
    DayOfWeek weekStartDay
)

Parameters

selDate
Type: System..::.DateTime
The selected date
weekStartDay
Type: System..::.DayOfWeek
The start of the weekday

Return Value

The weekly view in a datatable

See Also

Utility Class
GetWeeklyView Overload
OfficeClip.BusinessLayer Namespace


GetWeeklyView Method (DateTime, DayOfWeek, String)

[image]

OfficeClip API Documentation
Utility..::.GetWeeklyView Method (DateTime, DayOfWeek, String)
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Get the calendar date time after loading the weekly view. Only information related to the date and time are loaded

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataTable GetWeeklyView(
    DateTime selDate,
    DayOfWeek weekStartDay,
    string workWeekString
)
Visual Basic (Declaration)
Public Shared Function GetWeeklyView ( _
    selDate As DateTime, _
    weekStartDay As DayOfWeek, _
    workWeekString As String _
) As DataTable
Visual C++
public:
static DataTable^ GetWeeklyView(
    DateTime selDate,
    DayOfWeek weekStartDay,
    String^ workWeekString
)

Parameters

selDate
Type: System..::.DateTime
The selected date of the week for which the information is loaded
weekStartDay
Type: System..::.DayOfWeek
The week start day from which the information need to be shown
workWeekString
Type: System..::.String
String that determines the work week

Return Value

The datatable returns the following values Dt - The date in question, Desc1 - the day in question, Desc2 - The month in question, Hr - 0 (fixed value)

See Also

Utility Class
GetWeeklyView Overload
OfficeClip.BusinessLayer Namespace


GetWeekStartDates Method

[image]

OfficeClip API Documentation
Utility..::.GetWeekStartDates Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Returns the weekly start dates in a DataTable.

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataTable GetWeekStartDates(
    DateTime selDate,
    DayOfWeek weekStartDay,
    DateTime payrollStartDate,
    int numPeriodForward,
    int numPeriodBackward
)
Visual Basic (Declaration)
Public Shared Function GetWeekStartDates ( _
    selDate As DateTime, _
    weekStartDay As DayOfWeek, _
    payrollStartDate As DateTime, _
    numPeriodForward As Integer, _
    numPeriodBackward As Integer _
) As DataTable
Visual C++
public:
static DataTable^ GetWeekStartDates(
    DateTime selDate,
    DayOfWeek weekStartDay,
    DateTime payrollStartDate,
    int numPeriodForward,
    int numPeriodBackward
)

Parameters

selDate
Type: System..::.DateTime
The date in question
weekStartDay
Type: System..::.DayOfWeek
The day that is assigned to be the start day of the week
payrollStartDate
Type: System..::.DateTime
The date when the payroll starts
numPeriodForward
Type: System..::.Int32
numPeriodBackward
Type: System..::.Int32

Return Value

The datatable containing two columns, Dt - The date of the day, Desc - The date in the string format

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


GetYearlyView Method

[image]

OfficeClip API Documentation
Utility..::.GetYearlyView Method
Utility Class See Also

[This is preliminary documentation and is subject to change.]

Returns the yearly view

Namespace: OfficeClip.BusinessLayer
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataTable GetYearlyView()
Visual Basic (Declaration)
Public Shared Function GetYearlyView As DataTable
Visual C++
public:
static DataTable^ GetYearlyView()

Return Value

Returns a DataTable, which has the following for each month, id - month number, Desc - the string representation of the month number.

See Also

Utility Class
OfficeClip.BusinessLayer Namespace


OfficeClip.BusinessLayer.Account Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Account Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the OfficeClip Account. An OfficeClip account is the highest level entity that can contain multiple organization

Classes

 | Class | Description
Public class | AccountInfo | Provides methods for interacting with the Account Information object.
Public class | AccountingInfo | Provides methods for interacting with the Accounting Information Objects.
Public class | AccountingInfo..::.CouponInfo | Information related to Coupons which can be used on accounts to get discounts.
Public class | AccountingPackageInfo | Structure for the accounting package information
Public class | AccountUserInfo | Provides methods to interact with the account user information object.
Public class | AddressInfo | Provides methods to access the Address information object.
Public class | GroupInfo | Provides methods and properties to access group information.
Public class | LdapAuthenticationInfo | Provides methods and properties to access the LDAP Authentication information.
Public class | LocateResultInfo | Provides methods and properties for the infomation of the pager.
Public class | LoginInfo | Provides methods and properties to access the login information.
Public class | OCSysInfo | Provides methods and properties to access the OfficeClip System Information Information.
Public class | PayPalReturnInfo | Structure for the papal return information
Public class | PendingInvitationInfo | Provides methods and properties to access pending invitation information.
Public class | RegionalSettings | The regional settings object
Public class | SmsInfo | Provides methods and properties to access the SMS information.
Public class | transactionInfo | Provides methods and properties to access the credit card transaction information.
Public class | UserAvailability | Provides methods to interact with the User Availability Object.
Public class | UserDiscountInfo | The class for the user discount information
Public class | UserInfo | Provides methods and properties to access the user information.
Public class | UserLoginInfo | Provides methods and properties to access the user login information.
Public class | UserPayrollInfo | Provides methods and properties to access the user information.

Enumerations

 | Enumeration | Description
Public enumeration | SmsInfoVerifiedState | Provides States for SMS Device Verification


AccountInfo Class

[image]

OfficeClip API Documentation
AccountInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods for interacting with the Account Information object.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class AccountInfo
Visual Basic (Declaration)
Public Class AccountInfo
Visual C++
public ref class AccountInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.AccountInfo

See Also

AccountInfo Members
OfficeClip.BusinessLayer.Account Namespace


AccountInfo Members

[image] [image]

OfficeClip API Documentation
AccountInfo Members
AccountInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AccountInfo type exposes the following members.

Constructors

 | Name | Description
Public method | AccountInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The system specific account identifier. This is unique for all accounts.
Public property | CreatedTimestamp | The created Timestamp for the account.
Public property | DiskSpaceQuota | The disk space quota
Public property | IsEvaluation | Returns true if the current version is the evaluation version.
Public property | IsFree | Returns true if the current version is the evaluation version.
Public property | LastModifiedTimestamp | The last modified Timestamp for the account.
Public property | NumDays | The number of days the account is Active.
Public property | NumDaysRemaining | The number of days remaining for the account.
Public property | NumDaysUsed | The number of days the account is used.
Public property | NumUsers | The total number of users for the account.
Public property | NumUsersRemaining | The number of users remaining who can be registered to the account.
Public property | NumUsersUsed | The number of users who has registered in the account.
Public property | Package | The package selected by the user
Public property | RegionalSettings | Regional Settings for the account
Public property | SiteHeader | The site Header
Public property | ValidUptoTimestamp | Determines how long the account is valid

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountInfo Constructor

[image] [image]

OfficeClip API Documentation
AccountInfo Constructor
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AccountInfo()()() | Default constructor.
Public method | AccountInfo(Int32, DateTime, DateTime, Int32, Int32, DateTime, Int32, Double) | Default constructor.

See Also

AccountInfo Class
AccountInfo Members
OfficeClip.BusinessLayer.Account Namespace


AccountInfo Constructor

[image]

OfficeClip API Documentation
AccountInfo Constructor
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AccountInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AccountInfo()

See Also

AccountInfo Class
AccountInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AccountInfo Constructor (Int32, DateTime, DateTime, Int32, Int32, DateTime, Int32, Double)

[image]

OfficeClip API Documentation
AccountInfo Constructor (Int32, DateTime, DateTime, Int32, Int32, DateTime, Int32, Double)
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AccountInfo(
    int accountId,
    DateTime createdTimestamp,
    DateTime validUptoTimestamp,
    int numUsers,
    int numUsersUsed,
    DateTime lastModifiedTimestamp,
    int package,
    double diskSpaceQuota
)
Visual Basic (Declaration)
Public Sub New ( _
    accountId As Integer, _
    createdTimestamp As DateTime, _
    validUptoTimestamp As DateTime, _
    numUsers As Integer, _
    numUsersUsed As Integer, _
    lastModifiedTimestamp As DateTime, _
    package As Integer, _
    diskSpaceQuota As Double _
)
Visual C++
public:
AccountInfo(
    int accountId,
    DateTime createdTimestamp,
    DateTime validUptoTimestamp,
    int numUsers,
    int numUsersUsed,
    DateTime lastModifiedTimestamp,
    int package,
    double diskSpaceQuota
)

Parameters

accountId
Type: System..::.Int32
createdTimestamp
Type: System..::.DateTime
validUptoTimestamp
Type: System..::.DateTime
numUsers
Type: System..::.Int32
numUsersUsed
Type: System..::.Int32
lastModifiedTimestamp
Type: System..::.DateTime
package
Type: System..::.Int32
diskSpaceQuota
Type: System..::.Double

See Also

AccountInfo Class
AccountInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AccountInfo Properties

[image] [image]

OfficeClip API Documentation
AccountInfo Properties
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The AccountInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The system specific account identifier. This is unique for all accounts.
Public property | CreatedTimestamp | The created Timestamp for the account.
Public property | DiskSpaceQuota | The disk space quota
Public property | IsEvaluation | Returns true if the current version is the evaluation version.
Public property | IsFree | Returns true if the current version is the evaluation version.
Public property | LastModifiedTimestamp | The last modified Timestamp for the account.
Public property | NumDays | The number of days the account is Active.
Public property | NumDaysRemaining | The number of days remaining for the account.
Public property | NumDaysUsed | The number of days the account is used.
Public property | NumUsers | The total number of users for the account.
Public property | NumUsersRemaining | The number of users remaining who can be registered to the account.
Public property | NumUsersUsed | The number of users who has registered in the account.
Public property | Package | The package selected by the user
Public property | RegionalSettings | Regional Settings for the account
Public property | SiteHeader | The site Header
Public property | ValidUptoTimestamp | Determines how long the account is valid

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountId Property

[image]

OfficeClip API Documentation
AccountInfo..::.AccountId Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system specific account identifier. This is unique for all accounts.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AccountId { get; set; }
Visual Basic (Declaration)
Public Property AccountId As Integer
Visual C++
public:
property int AccountId {
    int get ();
    void set (int value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


CreatedTimestamp Property

[image]

OfficeClip API Documentation
AccountInfo..::.CreatedTimestamp Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The created Timestamp for the account.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedTimestamp As DateTime
Visual C++
public:
property DateTime CreatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


DiskSpaceQuota Property

[image]

OfficeClip API Documentation
AccountInfo..::.DiskSpaceQuota Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The disk space quota

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double DiskSpaceQuota { get; set; }
Visual Basic (Declaration)
Public Property DiskSpaceQuota As Double
Visual C++
public:
property double DiskSpaceQuota {
    double get ();
    void set (double value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsEvaluation Property

[image]

OfficeClip API Documentation
AccountInfo..::.IsEvaluation Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns true if the current version is the evaluation version.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsEvaluation { get; set; }
Visual Basic (Declaration)
Public Property IsEvaluation As Boolean
Visual C++
public:
property bool IsEvaluation {
    bool get ();
    void set (bool value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsFree Property

[image]

OfficeClip API Documentation
AccountInfo..::.IsFree Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns true if the current version is the evaluation version.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsFree { get; set; }
Visual Basic (Declaration)
Public Property IsFree As Boolean
Visual C++
public:
property bool IsFree {
    bool get ();
    void set (bool value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


LastModifiedTimestamp Property

[image]

OfficeClip API Documentation
AccountInfo..::.LastModifiedTimestamp Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last modified Timestamp for the account.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime LastModifiedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property LastModifiedTimestamp As DateTime
Visual C++
public:
property DateTime LastModifiedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumDays Property

[image]

OfficeClip API Documentation
AccountInfo..::.NumDays Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The number of days the account is Active.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumDays { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumDays As Integer
Visual C++
public:
property int NumDays {
    int get ();
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumDaysRemaining Property

[image]

OfficeClip API Documentation
AccountInfo..::.NumDaysRemaining Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The number of days remaining for the account.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumDaysRemaining { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumDaysRemaining As Integer
Visual C++
public:
property int NumDaysRemaining {
    int get ();
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumDaysUsed Property

[image]

OfficeClip API Documentation
AccountInfo..::.NumDaysUsed Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The number of days the account is used.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumDaysUsed { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumDaysUsed As Integer
Visual C++
public:
property int NumDaysUsed {
    int get ();
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumUsers Property

[image]

OfficeClip API Documentation
AccountInfo..::.NumUsers Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The total number of users for the account.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumUsers { get; set; }
Visual Basic (Declaration)
Public Property NumUsers As Integer
Visual C++
public:
property int NumUsers {
    int get ();
    void set (int value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumUsersRemaining Property

[image]

OfficeClip API Documentation
AccountInfo..::.NumUsersRemaining Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The number of users remaining who can be registered to the account.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumUsersRemaining { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumUsersRemaining As Integer
Visual C++
public:
property int NumUsersRemaining {
    int get ();
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumUsersUsed Property

[image]

OfficeClip API Documentation
AccountInfo..::.NumUsersUsed Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The number of users who has registered in the account.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumUsersUsed { get; set; }
Visual Basic (Declaration)
Public Property NumUsersUsed As Integer
Visual C++
public:
property int NumUsersUsed {
    int get ();
    void set (int value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


Package Property

[image]

OfficeClip API Documentation
AccountInfo..::.Package Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The package selected by the user

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Package { get; set; }
Visual Basic (Declaration)
Public Property Package As Integer
Visual C++
public:
property int Package {
    int get ();
    void set (int value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


RegionalSettings Property

[image]

OfficeClip API Documentation
AccountInfo..::.RegionalSettings Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Regional Settings for the account

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RegionalSettings RegionalSettings { get; set; }
Visual Basic (Declaration)
Public Property RegionalSettings As RegionalSettings
Visual C++
public:
property RegionalSettings^ RegionalSettings {
    RegionalSettings^ get ();
    void set (RegionalSettings^ value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


SiteHeader Property

[image]

OfficeClip API Documentation
AccountInfo..::.SiteHeader Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The site Header

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SiteHeader { get; set; }
Visual Basic (Declaration)
Public Property SiteHeader As String
Visual C++
public:
property String^ SiteHeader {
    String^ get ();
    void set (String^ value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


ValidUptoTimestamp Property

[image]

OfficeClip API Documentation
AccountInfo..::.ValidUptoTimestamp Property
AccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Determines how long the account is valid

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ValidUptoTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ValidUptoTimestamp As DateTime
Visual C++
public:
property DateTime ValidUptoTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

AccountInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo Class

[image]

OfficeClip API Documentation
AccountingInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods for interacting with the Accounting Information Objects.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class AccountingInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class AccountingInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class AccountingInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.AccountingInfo

See Also

AccountingInfo Members
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo Members

[image] [image]

OfficeClip API Documentation
AccountingInfo Members
AccountingInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AccountingInfo type exposes the following members.

Constructors

 | Name | Description
Public method | AccountingInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDiscountPercentage | Gets the discount percentage for the user
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountingCycleDuration | Number of days in the accounting cycle.
Public property | AccountingKey | The unique key used for account for security purposes.
Public property | AccountingPackages | The list of available accounting packages
Public property | Coupons | Valid Coupon list.
Public property | DiscountInfos | The list of discount information
Public property | MaxAccountDocumentSpace | The maximum document space that can be assigned to an account.
Public property | MaxDuration | The maximum duration of the accounting usage.
Public property | MaxGroupDocumentSpace | The maximum document space that can be assigned to a group.
Public property | MaxUserDocumentSpace | The maximum document space that can be assigned to an user.
Public property | MaxUsersCount | The count of the maximum number of users.
Public property | MinimumUsers | Minimum number of users that are allowed
Public property | NumUsersIncrement | Increments by which the users can be increased in the account.
Public property | PerUnitAccountDocSpaceRate | The cost of the account document space for each unit.
Public property | PerUnitGroupDocSpaceRate | The cost of the group document space for each unit.
Public property | PerUnitPrivateDocSpaceRate | The cost of the private document space for each unit.
Public property | PerUserRatePerDuration | Per user rate for each duration.
Public property | TrialPeriodUsersCount | Number of usrs in the trial period.

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo Constructor

[image] [image]

OfficeClip API Documentation
AccountingInfo Constructor
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AccountingInfo()()() | The default constructor.
Public method | AccountingInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

AccountingInfo Class
AccountingInfo Members
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo Constructor

[image]

OfficeClip API Documentation
AccountingInfo Constructor
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AccountingInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AccountingInfo()

See Also

AccountingInfo Class
AccountingInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
AccountingInfo Constructor (SerializationInfo, StreamingContext)
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AccountingInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
AccountingInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Exceptions

Exception | Condition
OfficeClip.Utils..::.OCException |

See Also

AccountingInfo Class
AccountingInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo Methods

[image] [image]

OfficeClip API Documentation
AccountingInfo Methods
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The AccountingInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDiscountPercentage | Gets the discount percentage for the user
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetDiscountPercentage Method

[image]

OfficeClip API Documentation
AccountingInfo..::.GetDiscountPercentage Method
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the discount percentage for the user

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetDiscountPercentage(
    int numUsers
)
Visual Basic (Declaration)
Public Function GetDiscountPercentage ( _
    numUsers As Integer _
) As Double
Visual C++
public:
double GetDiscountPercentage(
    int numUsers
)

Parameters

numUsers
Type: System..::.Int32
The total number of users

Return Value

The doscount percentage

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
AccountingInfo..::.GetObjectData Method
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo Properties

[image] [image]

OfficeClip API Documentation
AccountingInfo Properties
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The AccountingInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountingCycleDuration | Number of days in the accounting cycle.
Public property | AccountingKey | The unique key used for account for security purposes.
Public property | AccountingPackages | The list of available accounting packages
Public property | Coupons | Valid Coupon list.
Public property | DiscountInfos | The list of discount information
Public property | MaxAccountDocumentSpace | The maximum document space that can be assigned to an account.
Public property | MaxDuration | The maximum duration of the accounting usage.
Public property | MaxGroupDocumentSpace | The maximum document space that can be assigned to a group.
Public property | MaxUserDocumentSpace | The maximum document space that can be assigned to an user.
Public property | MaxUsersCount | The count of the maximum number of users.
Public property | MinimumUsers | Minimum number of users that are allowed
Public property | NumUsersIncrement | Increments by which the users can be increased in the account.
Public property | PerUnitAccountDocSpaceRate | The cost of the account document space for each unit.
Public property | PerUnitGroupDocSpaceRate | The cost of the group document space for each unit.
Public property | PerUnitPrivateDocSpaceRate | The cost of the private document space for each unit.
Public property | PerUserRatePerDuration | Per user rate for each duration.
Public property | TrialPeriodUsersCount | Number of usrs in the trial period.

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingCycleDuration Property

[image]

OfficeClip API Documentation
AccountingInfo..::.AccountingCycleDuration Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

Number of days in the accounting cycle.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AccountingCycleDuration { get; set; }
Visual Basic (Declaration)
Public Property AccountingCycleDuration As Integer
Visual C++
public:
property int AccountingCycleDuration {
    int get ();
    void set (int value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingKey Property

[image]

OfficeClip API Documentation
AccountingInfo..::.AccountingKey Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique key used for account for security purposes.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AccountingKey { get; set; }
Visual Basic (Declaration)
Public Property AccountingKey As String
Visual C++
public:
property String^ AccountingKey {
    String^ get ();
    void set (String^ value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingPackages Property

[image]

OfficeClip API Documentation
AccountingInfo..::.AccountingPackages Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of available accounting packages

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList AccountingPackages { get; set; }
Visual Basic (Declaration)
Public Property AccountingPackages As ArrayList
Visual C++
public:
property ArrayList^ AccountingPackages {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


Coupons Property

[image]

OfficeClip API Documentation
AccountingInfo..::.Coupons Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

Valid Coupon list.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Coupons { get; set; }
Visual Basic (Declaration)
Public Property Coupons As ArrayList
Visual C++
public:
property ArrayList^ Coupons {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


DiscountInfos Property

[image]

OfficeClip API Documentation
AccountingInfo..::.DiscountInfos Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of discount information

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList DiscountInfos { get; set; }
Visual Basic (Declaration)
Public Property DiscountInfos As ArrayList
Visual C++
public:
property ArrayList^ DiscountInfos {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


MaxAccountDocumentSpace Property

[image]

OfficeClip API Documentation
AccountingInfo..::.MaxAccountDocumentSpace Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The maximum document space that can be assigned to an account.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MaxAccountDocumentSpace { get; set; }
Visual Basic (Declaration)
Public Property MaxAccountDocumentSpace As Integer
Visual C++
public:
property int MaxAccountDocumentSpace {
    int get ();
    void set (int value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


MaxDuration Property

[image]

OfficeClip API Documentation
AccountingInfo..::.MaxDuration Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The maximum duration of the accounting usage.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MaxDuration { get; set; }
Visual Basic (Declaration)
Public Property MaxDuration As Integer
Visual C++
public:
property int MaxDuration {
    int get ();
    void set (int value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


MaxGroupDocumentSpace Property

[image]

OfficeClip API Documentation
AccountingInfo..::.MaxGroupDocumentSpace Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The maximum document space that can be assigned to a group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MaxGroupDocumentSpace { get; set; }
Visual Basic (Declaration)
Public Property MaxGroupDocumentSpace As Integer
Visual C++
public:
property int MaxGroupDocumentSpace {
    int get ();
    void set (int value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


MaxUserDocumentSpace Property

[image]

OfficeClip API Documentation
AccountingInfo..::.MaxUserDocumentSpace Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The maximum document space that can be assigned to an user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MaxUserDocumentSpace { get; set; }
Visual Basic (Declaration)
Public Property MaxUserDocumentSpace As Integer
Visual C++
public:
property int MaxUserDocumentSpace {
    int get ();
    void set (int value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


MaxUsersCount Property

[image]

OfficeClip API Documentation
AccountingInfo..::.MaxUsersCount Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The count of the maximum number of users.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MaxUsersCount { get; set; }
Visual Basic (Declaration)
Public Property MaxUsersCount As Integer
Visual C++
public:
property int MaxUsersCount {
    int get ();
    void set (int value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


MinimumUsers Property

[image]

OfficeClip API Documentation
AccountingInfo..::.MinimumUsers Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

Minimum number of users that are allowed

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MinimumUsers { get; set; }
Visual Basic (Declaration)
Public Property MinimumUsers As Integer
Visual C++
public:
property int MinimumUsers {
    int get ();
    void set (int value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumUsersIncrement Property

[image]

OfficeClip API Documentation
AccountingInfo..::.NumUsersIncrement Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

Increments by which the users can be increased in the account.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumUsersIncrement { get; set; }
Visual Basic (Declaration)
Public Property NumUsersIncrement As Integer
Visual C++
public:
property int NumUsersIncrement {
    int get ();
    void set (int value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


PerUnitAccountDocSpaceRate Property

[image]

OfficeClip API Documentation
AccountingInfo..::.PerUnitAccountDocSpaceRate Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The cost of the account document space for each unit.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double PerUnitAccountDocSpaceRate { get; set; }
Visual Basic (Declaration)
Public Property PerUnitAccountDocSpaceRate As Double
Visual C++
public:
property double PerUnitAccountDocSpaceRate {
    double get ();
    void set (double value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


PerUnitGroupDocSpaceRate Property

[image]

OfficeClip API Documentation
AccountingInfo..::.PerUnitGroupDocSpaceRate Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The cost of the group document space for each unit.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double PerUnitGroupDocSpaceRate { get; set; }
Visual Basic (Declaration)
Public Property PerUnitGroupDocSpaceRate As Double
Visual C++
public:
property double PerUnitGroupDocSpaceRate {
    double get ();
    void set (double value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


PerUnitPrivateDocSpaceRate Property

[image]

OfficeClip API Documentation
AccountingInfo..::.PerUnitPrivateDocSpaceRate Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

The cost of the private document space for each unit.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double PerUnitPrivateDocSpaceRate { get; set; }
Visual Basic (Declaration)
Public Property PerUnitPrivateDocSpaceRate As Double
Visual C++
public:
property double PerUnitPrivateDocSpaceRate {
    double get ();
    void set (double value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


PerUserRatePerDuration Property

[image]

OfficeClip API Documentation
AccountingInfo..::.PerUserRatePerDuration Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

Per user rate for each duration.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double PerUserRatePerDuration { get; set; }
Visual Basic (Declaration)
Public Property PerUserRatePerDuration As Double
Visual C++
public:
property double PerUserRatePerDuration {
    double get ();
    void set (double value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


TrialPeriodUsersCount Property

[image]

OfficeClip API Documentation
AccountingInfo..::.TrialPeriodUsersCount Property
AccountingInfo Class See Also

[This is preliminary documentation and is subject to change.]

Number of usrs in the trial period.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TrialPeriodUsersCount { get; set; }
Visual Basic (Declaration)
Public Property TrialPeriodUsersCount As Integer
Visual C++
public:
property int TrialPeriodUsersCount {
    int get ();
    void set (int value);
}

See Also

AccountingInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo.CouponInfo Class

[image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo Class
AccountingInfo Class Members See Also

[This is preliminary documentation and is subject to change.]

Information related to Coupons which can be used on accounts to get discounts.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class CouponInfo : ISerializable
Visual Basic (Declaration)
Public Class CouponInfo _
    Implements ISerializable
Visual C++
public ref class CouponInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.AccountingInfo..::.CouponInfo

See Also

AccountingInfo..::.CouponInfo Members
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo.CouponInfo Members

[image] [image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo Members
AccountingInfo..::.CouponInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

Provides methods for interacting with the Accounting Information Objects.

The AccountingInfo..::.CouponInfo type exposes the following members.

Constructors

 | Name | Description
Public method | AccountingInfo..::.CouponInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DiscountAmount | The discount Amount on the coupon.
Public property | DiscountPercentage | The discount percentage for the particular discount.
Public property | EndDate | The end date of the coupon.
Public property | id | The unique id of the coupon.
Public property | StartDate | The start date ofthe coupon.

See Also

AccountingInfo..::.CouponInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo.CouponInfo Constructor

[image] [image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo Constructor
AccountingInfo..::.CouponInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AccountingInfo..::.CouponInfo()()() | Default constructor
Public method | AccountingInfo..::.CouponInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

AccountingInfo..::.CouponInfo Class
AccountingInfo..::.CouponInfo Members
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo.CouponInfo Constructor

[image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo Constructor
AccountingInfo..::.CouponInfo Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CouponInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CouponInfo()

See Also

AccountingInfo..::.CouponInfo Class
AccountingInfo..::.CouponInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo.CouponInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo Constructor (SerializationInfo, StreamingContext)
AccountingInfo..::.CouponInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CouponInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
CouponInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

AccountingInfo..::.CouponInfo Class
AccountingInfo..::.CouponInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo.CouponInfo Methods

[image] [image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo Methods
AccountingInfo..::.CouponInfo Class See Also

[This is preliminary documentation and is subject to change.]

The AccountingInfo..::.CouponInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccountingInfo..::.CouponInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo..::.GetObjectData Method
AccountingInfo..::.CouponInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

AccountingInfo..::.CouponInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingInfo.CouponInfo Properties

[image] [image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo Properties
AccountingInfo..::.CouponInfo Class See Also

[This is preliminary documentation and is subject to change.]

The AccountingInfo..::.CouponInfo type exposes the following properties.

Properties

 | Name | Description
Public property | DiscountAmount | The discount Amount on the coupon.
Public property | DiscountPercentage | The discount percentage for the particular discount.
Public property | EndDate | The end date of the coupon.
Public property | id | The unique id of the coupon.
Public property | StartDate | The start date ofthe coupon.

See Also

AccountingInfo..::.CouponInfo Class
OfficeClip.BusinessLayer.Account Namespace


DiscountAmount Property

[image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo..::.DiscountAmount Property
AccountingInfo..::.CouponInfo Class See Also

[This is preliminary documentation and is subject to change.]

The discount Amount on the coupon.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double DiscountAmount { get; set; }
Visual Basic (Declaration)
Public Property DiscountAmount As Double
Visual C++
public:
property double DiscountAmount {
    double get ();
    void set (double value);
}

See Also

AccountingInfo..::.CouponInfo Class
OfficeClip.BusinessLayer.Account Namespace


DiscountPercentage Property

[image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo..::.DiscountPercentage Property
AccountingInfo..::.CouponInfo Class See Also

[This is preliminary documentation and is subject to change.]

The discount percentage for the particular discount.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double DiscountPercentage { get; set; }
Visual Basic (Declaration)
Public Property DiscountPercentage As Double
Visual C++
public:
property double DiscountPercentage {
    double get ();
    void set (double value);
}

See Also

AccountingInfo..::.CouponInfo Class
OfficeClip.BusinessLayer.Account Namespace


EndDate Property

[image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo..::.EndDate Property
AccountingInfo..::.CouponInfo Class See Also

[This is preliminary documentation and is subject to change.]

The end date of the coupon.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime EndDate { get; set; }
Visual Basic (Declaration)
Public Property EndDate As DateTime
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

AccountingInfo..::.CouponInfo Class
OfficeClip.BusinessLayer.Account Namespace


id Property

[image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo..::.id Property
AccountingInfo..::.CouponInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the coupon.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string id { get; set; }
Visual Basic (Declaration)
Public Property id As String
Visual C++
public:
property String^ id {
    String^ get ();
    void set (String^ value);
}

See Also

AccountingInfo..::.CouponInfo Class
OfficeClip.BusinessLayer.Account Namespace


StartDate Property

[image]

OfficeClip API Documentation
AccountingInfo..::.CouponInfo..::.StartDate Property
AccountingInfo..::.CouponInfo Class See Also

[This is preliminary documentation and is subject to change.]

The start date ofthe coupon.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic (Declaration)
Public Property StartDate As DateTime
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

AccountingInfo..::.CouponInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingPackageInfo Class

[image]

OfficeClip API Documentation
AccountingPackageInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Structure for the accounting package information

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class AccountingPackageInfo : ISerializable
Visual Basic (Declaration)
Public Class AccountingPackageInfo _
    Implements ISerializable
Visual C++
public ref class AccountingPackageInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.AccountingPackageInfo

See Also

AccountingPackageInfo Members
OfficeClip.BusinessLayer.Account Namespace


AccountingPackageInfo Members

[image] [image]

OfficeClip API Documentation
AccountingPackageInfo Members
AccountingPackageInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AccountingPackageInfo type exposes the following members.

Constructors

 | Name | Description
Public method | AccountingPackageInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the serialized objet data
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BlockApplications | The set of applications to block
Public property | Id | The accounting package identifier
Public property | Name | The package name
Public property | UnitCost | The unit cost for the package

See Also

AccountingPackageInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingPackageInfo Constructor

[image] [image]

OfficeClip API Documentation
AccountingPackageInfo Constructor
AccountingPackageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AccountingPackageInfo()()() | The public constructor
Public method | AccountingPackageInfo(SerializationInfo, StreamingContext) | The public constructor

See Also

AccountingPackageInfo Class
AccountingPackageInfo Members
OfficeClip.BusinessLayer.Account Namespace


AccountingPackageInfo Constructor

[image]

OfficeClip API Documentation
AccountingPackageInfo Constructor
AccountingPackageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The public constructor

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AccountingPackageInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AccountingPackageInfo()

See Also

AccountingPackageInfo Class
AccountingPackageInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AccountingPackageInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
AccountingPackageInfo Constructor (SerializationInfo, StreamingContext)
AccountingPackageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The public constructor

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AccountingPackageInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
AccountingPackageInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The serialization information
context
Type: System.Runtime.Serialization..::.StreamingContext
The streaming context

See Also

AccountingPackageInfo Class
AccountingPackageInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AccountingPackageInfo Methods

[image] [image]

OfficeClip API Documentation
AccountingPackageInfo Methods
AccountingPackageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The AccountingPackageInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the serialized objet data
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccountingPackageInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
AccountingPackageInfo..::.GetObjectData Method
AccountingPackageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the serialized objet data

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The serialization information
context
Type: System.Runtime.Serialization..::.StreamingContext
The streaming context

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

AccountingPackageInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountingPackageInfo Properties

[image] [image]

OfficeClip API Documentation
AccountingPackageInfo Properties
AccountingPackageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The AccountingPackageInfo type exposes the following properties.

Properties

 | Name | Description
Public property | BlockApplications | The set of applications to block
Public property | Id | The accounting package identifier
Public property | Name | The package name
Public property | UnitCost | The unit cost for the package

See Also

AccountingPackageInfo Class
OfficeClip.BusinessLayer.Account Namespace


BlockApplications Property

[image]

OfficeClip API Documentation
AccountingPackageInfo..::.BlockApplications Property
AccountingPackageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The set of applications to block

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string BlockApplications { get; set; }
Visual Basic (Declaration)
Public Property BlockApplications As String
Visual C++
public:
property String^ BlockApplications {
    String^ get ();
    void set (String^ value);
}

See Also

AccountingPackageInfo Class
OfficeClip.BusinessLayer.Account Namespace


Id Property

[image]

OfficeClip API Documentation
AccountingPackageInfo..::.Id Property
AccountingPackageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The accounting package identifier

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Id { get; set; }
Visual Basic (Declaration)
Public Property Id As Integer
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

See Also

AccountingPackageInfo Class
OfficeClip.BusinessLayer.Account Namespace


Name Property

[image]

OfficeClip API Documentation
AccountingPackageInfo..::.Name Property
AccountingPackageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The package name

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

AccountingPackageInfo Class
OfficeClip.BusinessLayer.Account Namespace


UnitCost Property

[image]

OfficeClip API Documentation
AccountingPackageInfo..::.UnitCost Property
AccountingPackageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unit cost for the package

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double UnitCost { get; set; }
Visual Basic (Declaration)
Public Property UnitCost As Double
Visual C++
public:
property double UnitCost {
    double get ();
    void set (double value);
}

See Also

AccountingPackageInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountUserInfo Class

[image]

OfficeClip API Documentation
AccountUserInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods to interact with the account user information object.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class AccountUserInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class AccountUserInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class AccountUserInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.AccountUserInfo

See Also

AccountUserInfo Members
OfficeClip.BusinessLayer.Account Namespace


AccountUserInfo Members

[image] [image]

OfficeClip API Documentation
AccountUserInfo Members
AccountUserInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AccountUserInfo type exposes the following members.

Constructors

 | Name | Description
Public method | AccountUserInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The system generated unique account identifier.
Public property | IsOwner | If the user is an administrator of the account.
Public property | UserId | The system generated unique id of the account user.

See Also

AccountUserInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountUserInfo Constructor

[image] [image]

OfficeClip API Documentation
AccountUserInfo Constructor
AccountUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AccountUserInfo()()() | Default constructor.
Public method | AccountUserInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

AccountUserInfo Class
AccountUserInfo Members
OfficeClip.BusinessLayer.Account Namespace


AccountUserInfo Constructor

[image]

OfficeClip API Documentation
AccountUserInfo Constructor
AccountUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AccountUserInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AccountUserInfo()

See Also

AccountUserInfo Class
AccountUserInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AccountUserInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
AccountUserInfo Constructor (SerializationInfo, StreamingContext)
AccountUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AccountUserInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
AccountUserInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

AccountUserInfo Class
AccountUserInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AccountUserInfo Methods

[image] [image]

OfficeClip API Documentation
AccountUserInfo Methods
AccountUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The AccountUserInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AccountUserInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
AccountUserInfo..::.GetObjectData Method
AccountUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

AccountUserInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountUserInfo Properties

[image] [image]

OfficeClip API Documentation
AccountUserInfo Properties
AccountUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The AccountUserInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The system generated unique account identifier.
Public property | IsOwner | If the user is an administrator of the account.
Public property | UserId | The system generated unique id of the account user.

See Also

AccountUserInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountId Property

[image]

OfficeClip API Documentation
AccountUserInfo..::.AccountId Property
AccountUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique account identifier.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AccountId { get; set; }
Visual Basic (Declaration)
Public Property AccountId As Integer
Visual C++
public:
property int AccountId {
    int get ();
    void set (int value);
}

See Also

AccountUserInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsOwner Property

[image]

OfficeClip API Documentation
AccountUserInfo..::.IsOwner Property
AccountUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

If the user is an administrator of the account.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsOwner { get; set; }
Visual Basic (Declaration)
Public Property IsOwner As Boolean
Visual C++
public:
property bool IsOwner {
    bool get ();
    void set (bool value);
}

See Also

AccountUserInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserId Property

[image]

OfficeClip API Documentation
AccountUserInfo..::.UserId Property
AccountUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique id of the account user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

AccountUserInfo Class
OfficeClip.BusinessLayer.Account Namespace


AddressInfo Class

[image]

OfficeClip API Documentation
AddressInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods to access the Address information object.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class AddressInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class AddressInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class AddressInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.AddressInfo

See Also

AddressInfo Members
OfficeClip.BusinessLayer.Account Namespace


AddressInfo Members

[image] [image]

OfficeClip API Documentation
AddressInfo Members
AddressInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AddressInfo type exposes the following members.

Constructors

 | Name | Description
Public method | AddressInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToFormattedString | Converts the Address to the formatted string representation. This is used to display the Address as a formatted string.
Public method | ToString | Converts the Address to a string representation for debugging and display puposes. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | AddressId | Gets the system generated unique Address identifier.
Public property | City | The city of the Address.
Public property | Country | The Country for the Address.
Public property | CountryId | The system generated unique Country id.
Public property | Line1 | The line 1 of the Address.
Public property | Line2 | The line 2 of the Address.
Public property | State | The State part of the Address.
Public property | Zip | The zip code for the Address.

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


AddressInfo Constructor

[image] [image]

OfficeClip API Documentation
AddressInfo Constructor
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddressInfo()()() | The default constructor.
Public method | AddressInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

AddressInfo Class
AddressInfo Members
OfficeClip.BusinessLayer.Account Namespace


AddressInfo Constructor

[image]

OfficeClip API Documentation
AddressInfo Constructor
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AddressInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AddressInfo()

See Also

AddressInfo Class
AddressInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AddressInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
AddressInfo Constructor (SerializationInfo, StreamingContext)
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AddressInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
AddressInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

AddressInfo Class
AddressInfo Overload
OfficeClip.BusinessLayer.Account Namespace


AddressInfo Methods

[image] [image]

OfficeClip API Documentation
AddressInfo Methods
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

The AddressInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToFormattedString | Converts the Address to the formatted string representation. This is used to display the Address as a formatted string.
Public method | ToString | Converts the Address to a string representation for debugging and display puposes. (Overrides Object..::.ToString()()().)

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
AddressInfo..::.GetObjectData Method
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


ToFormattedString Method

[image]

OfficeClip API Documentation
AddressInfo..::.ToFormattedString Method
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

Converts the Address to the formatted string representation. This is used to display the Address as a formatted string.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToFormattedString()
Visual Basic (Declaration)
Public Function ToFormattedString As String
Visual C++
public:
String^ ToFormattedString()

Return Value

the formatted string representation of the Address.

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


ToString Method

[image]

OfficeClip API Documentation
AddressInfo..::.ToString Method
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

Converts the Address to a string representation for debugging and display puposes.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the Address.

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


AddressInfo Properties

[image] [image]

OfficeClip API Documentation
AddressInfo Properties
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

The AddressInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AddressId | Gets the system generated unique Address identifier.
Public property | City | The city of the Address.
Public property | Country | The Country for the Address.
Public property | CountryId | The system generated unique Country id.
Public property | Line1 | The line 1 of the Address.
Public property | Line2 | The line 2 of the Address.
Public property | State | The State part of the Address.
Public property | Zip | The zip code for the Address.

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


AddressId Property

[image]

OfficeClip API Documentation
AddressInfo..::.AddressId Property
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the system generated unique Address identifier.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AddressId { get; set; }
Visual Basic (Declaration)
Public Property AddressId As Integer
Visual C++
public:
property int AddressId {
    int get ();
    void set (int value);
}

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


City Property

[image]

OfficeClip API Documentation
AddressInfo..::.City Property
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

The city of the Address.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string City { get; set; }
Visual Basic (Declaration)
Public Property City As String
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


Country Property

[image]

OfficeClip API Documentation
AddressInfo..::.Country Property
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Country for the Address.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Country { get; set; }
Visual Basic (Declaration)
Public Property Country As String
Visual C++
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


CountryId Property

[image]

OfficeClip API Documentation
AddressInfo..::.CountryId Property
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique Country id.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CountryId { get; set; }
Visual Basic (Declaration)
Public Property CountryId As Integer
Visual C++
public:
property int CountryId {
    int get ();
    void set (int value);
}

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


Line1 Property

[image]

OfficeClip API Documentation
AddressInfo..::.Line1 Property
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

The line 1 of the Address.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Line1 { get; set; }
Visual Basic (Declaration)
Public Property Line1 As String
Visual C++
public:
property String^ Line1 {
    String^ get ();
    void set (String^ value);
}

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


Line2 Property

[image]

OfficeClip API Documentation
AddressInfo..::.Line2 Property
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

The line 2 of the Address.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Line2 { get; set; }
Visual Basic (Declaration)
Public Property Line2 As String
Visual C++
public:
property String^ Line2 {
    String^ get ();
    void set (String^ value);
}

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


State Property

[image]

OfficeClip API Documentation
AddressInfo..::.State Property
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

The State part of the Address.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string State { get; set; }
Visual Basic (Declaration)
Public Property State As String
Visual C++
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


Zip Property

[image]

OfficeClip API Documentation
AddressInfo..::.Zip Property
AddressInfo Class See Also

[This is preliminary documentation and is subject to change.]

The zip code for the Address.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Zip { get; set; }
Visual Basic (Declaration)
Public Property Zip As String
Visual C++
public:
property String^ Zip {
    String^ get ();
    void set (String^ value);
}

See Also

AddressInfo Class
OfficeClip.BusinessLayer.Account Namespace


GroupInfo Class

[image]

OfficeClip API Documentation
GroupInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access group information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class GroupInfo
Visual Basic (Declaration)
Public Class GroupInfo
Visual C++
public ref class GroupInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.GroupInfo

See Also

GroupInfo Members
OfficeClip.BusinessLayer.Account Namespace


GroupInfo Members

[image] [image]

OfficeClip API Documentation
GroupInfo Members
GroupInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The GroupInfo type exposes the following members.

Constructors

 | Name | Description
Public method | GroupInfo |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address | The Address information of the group.
Public property | AddressId | The Address identifier of the Address associated with the group.
Public property | Gdf1Name | The first user defined field name for the group.
Public property | Gdf2Name | The second user defined field name for the group.
Public property | Gdf3Name | The third user defined field name for the group.
Public property | Gdf4Name | The fourth user defined field name for the group.
Public property | Gdf5Name | The fifth user defined field name for the group.
Public property | GroupId | The unique identifier for the group.
Public property | GroupName | The name of the group.
Public property | GroupType | The type of the group, it could be organization or department
Public property | LastUpdatedByUserId | the identifier of the user who last updated the group information.
Public property | LastUpdatedTimestamp | The time when the group information was last updated.
Public property | ParentGroupId | The group identifier of the Parent group. This is meaningful if the group is of type Organization.
Public property | TimezoneId | The identifier for the group timezone. OfficeClip.Utils..::.TimeZoneInfo

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


GroupInfo Constructor

[image]

OfficeClip API Documentation
GroupInfo Constructor
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GroupInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupInfo()

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


GroupInfo Properties

[image] [image]

OfficeClip API Documentation
GroupInfo Properties
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The GroupInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Address | The Address information of the group.
Public property | AddressId | The Address identifier of the Address associated with the group.
Public property | Gdf1Name | The first user defined field name for the group.
Public property | Gdf2Name | The second user defined field name for the group.
Public property | Gdf3Name | The third user defined field name for the group.
Public property | Gdf4Name | The fourth user defined field name for the group.
Public property | Gdf5Name | The fifth user defined field name for the group.
Public property | GroupId | The unique identifier for the group.
Public property | GroupName | The name of the group.
Public property | GroupType | The type of the group, it could be organization or department
Public property | LastUpdatedByUserId | the identifier of the user who last updated the group information.
Public property | LastUpdatedTimestamp | The time when the group information was last updated.
Public property | ParentGroupId | The group identifier of the Parent group. This is meaningful if the group is of type Organization.
Public property | TimezoneId | The identifier for the group timezone. OfficeClip.Utils..::.TimeZoneInfo

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


Address Property

[image]

OfficeClip API Documentation
GroupInfo..::.Address Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Address information of the group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AddressInfo Address { get; set; }
Visual Basic (Declaration)
Public Property Address As AddressInfo
Visual C++
public:
property AddressInfo^ Address {
    AddressInfo^ get ();
    void set (AddressInfo^ value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


AddressId Property

[image]

OfficeClip API Documentation
GroupInfo..::.AddressId Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Address identifier of the Address associated with the group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AddressId { get; set; }
Visual Basic (Declaration)
Public Property AddressId As Integer
Visual C++
public:
property int AddressId {
    int get ();
    void set (int value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf1Name Property

[image]

OfficeClip API Documentation
GroupInfo..::.Gdf1Name Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first user defined field name for the group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf1Name { get; set; }
Visual Basic (Declaration)
Public Property Gdf1Name As String
Visual C++
public:
property String^ Gdf1Name {
    String^ get ();
    void set (String^ value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf2Name Property

[image]

OfficeClip API Documentation
GroupInfo..::.Gdf2Name Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second user defined field name for the group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf2Name { get; set; }
Visual Basic (Declaration)
Public Property Gdf2Name As String
Visual C++
public:
property String^ Gdf2Name {
    String^ get ();
    void set (String^ value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf3Name Property

[image]

OfficeClip API Documentation
GroupInfo..::.Gdf3Name Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The third user defined field name for the group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf3Name { get; set; }
Visual Basic (Declaration)
Public Property Gdf3Name As String
Visual C++
public:
property String^ Gdf3Name {
    String^ get ();
    void set (String^ value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf4Name Property

[image]

OfficeClip API Documentation
GroupInfo..::.Gdf4Name Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The fourth user defined field name for the group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf4Name { get; set; }
Visual Basic (Declaration)
Public Property Gdf4Name As String
Visual C++
public:
property String^ Gdf4Name {
    String^ get ();
    void set (String^ value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf5Name Property

[image]

OfficeClip API Documentation
GroupInfo..::.Gdf5Name Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The fifth user defined field name for the group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf5Name { get; set; }
Visual Basic (Declaration)
Public Property Gdf5Name As String
Visual C++
public:
property String^ Gdf5Name {
    String^ get ();
    void set (String^ value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


GroupId Property

[image]

OfficeClip API Documentation
GroupInfo..::.GroupId Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique identifier for the group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


GroupName Property

[image]

OfficeClip API Documentation
GroupInfo..::.GroupName Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GroupName { get; set; }
Visual Basic (Declaration)
Public Property GroupName As String
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


GroupType Property

[image]

OfficeClip API Documentation
GroupInfo..::.GroupType Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The type of the group, it could be organization or department

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GroupType GroupType { get; set; }
Visual Basic (Declaration)
Public Property GroupType As GroupType
Visual C++
public:
property GroupType GroupType {
    GroupType get ();
    void set (GroupType value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


LastUpdatedByUserId Property

[image]

OfficeClip API Documentation
GroupInfo..::.LastUpdatedByUserId Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

the identifier of the user who last updated the group information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LastUpdatedByUserId { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedByUserId As Integer
Visual C++
public:
property int LastUpdatedByUserId {
    int get ();
    void set (int value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


LastUpdatedTimestamp Property

[image]

OfficeClip API Documentation
GroupInfo..::.LastUpdatedTimestamp Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time when the group information was last updated.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime LastUpdatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedTimestamp As DateTime
Visual C++
public:
property DateTime LastUpdatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


ParentGroupId Property

[image]

OfficeClip API Documentation
GroupInfo..::.ParentGroupId Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The group identifier of the Parent group. This is meaningful if the group is of type Organization.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ParentGroupId { get; set; }
Visual Basic (Declaration)
Public Property ParentGroupId As Integer
Visual C++
public:
property int ParentGroupId {
    int get ();
    void set (int value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace


TimezoneId Property

[image]

OfficeClip API Documentation
GroupInfo..::.TimezoneId Property
GroupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the group timezone. OfficeClip.Utils..::.TimeZoneInfo

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TimezoneId { get; set; }
Visual Basic (Declaration)
Public Property TimezoneId As Integer
Visual C++
public:
property int TimezoneId {
    int get ();
    void set (int value);
}

See Also

GroupInfo Class
OfficeClip.BusinessLayer.Account Namespace
OfficeClip.Utils..::.TimeZoneInfo


LdapAuthenticationInfo Class

[image]

OfficeClip API Documentation
LdapAuthenticationInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the LDAP Authentication information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class LdapAuthenticationInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class LdapAuthenticationInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class LdapAuthenticationInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.LdapAuthenticationInfo

See Also

LdapAuthenticationInfo Members
OfficeClip.BusinessLayer.Account Namespace


LdapAuthenticationInfo Members

[image] [image]

OfficeClip API Documentation
LdapAuthenticationInfo Members
LdapAuthenticationInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The LdapAuthenticationInfo type exposes the following members.

Constructors

 | Name | Description
Public method | LdapAuthenticationInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountName | The account name for the LDAP server.
Public property | AccountPassword | The Password that is sent to the LDAP server for validation.
Public property | AuthenticationType | The authentication type for the LDAP server.
Public property | LdapUrl | The ldap url.
Public property | RootUrl | The root url for the LDAP server.
Public property | ServerName | The name of the LDAP server.
Public property | UserDN | The user distinguished name for the LDAP server.

See Also

LdapAuthenticationInfo Class
OfficeClip.BusinessLayer.Account Namespace


LdapAuthenticationInfo Constructor

[image] [image]

OfficeClip API Documentation
LdapAuthenticationInfo Constructor
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | LdapAuthenticationInfo()()() | The default constructor.
Public method | LdapAuthenticationInfo(String) | Constructor to create an object using the authentication string.
Public method | LdapAuthenticationInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

LdapAuthenticationInfo Class
LdapAuthenticationInfo Members
OfficeClip.BusinessLayer.Account Namespace


LdapAuthenticationInfo Constructor

[image]

OfficeClip API Documentation
LdapAuthenticationInfo Constructor
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public LdapAuthenticationInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LdapAuthenticationInfo()

See Also

LdapAuthenticationInfo Class
LdapAuthenticationInfo Overload
OfficeClip.BusinessLayer.Account Namespace


LdapAuthenticationInfo Constructor (String)

[image]

OfficeClip API Documentation
LdapAuthenticationInfo Constructor (String)
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an object using the authentication string.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public LdapAuthenticationInfo(
    string authenticationStr
)
Visual Basic (Declaration)
Public Sub New ( _
    authenticationStr As String _
)
Visual C++
public:
LdapAuthenticationInfo(
    String^ authenticationStr
)

Parameters

authenticationStr
Type: System..::.String
the LDAP authentication string.

See Also

LdapAuthenticationInfo Class
LdapAuthenticationInfo Overload
OfficeClip.BusinessLayer.Account Namespace


LdapAuthenticationInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
LdapAuthenticationInfo Constructor (SerializationInfo, StreamingContext)
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public LdapAuthenticationInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
LdapAuthenticationInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

LdapAuthenticationInfo Class
LdapAuthenticationInfo Overload
OfficeClip.BusinessLayer.Account Namespace


LdapAuthenticationInfo Methods

[image] [image]

OfficeClip API Documentation
LdapAuthenticationInfo Methods
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The LdapAuthenticationInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LdapAuthenticationInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
LdapAuthenticationInfo..::.GetObjectData Method
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

LdapAuthenticationInfo Class
OfficeClip.BusinessLayer.Account Namespace


LdapAuthenticationInfo Properties

[image] [image]

OfficeClip API Documentation
LdapAuthenticationInfo Properties
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The LdapAuthenticationInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountName | The account name for the LDAP server.
Public property | AccountPassword | The Password that is sent to the LDAP server for validation.
Public property | AuthenticationType | The authentication type for the LDAP server.
Public property | LdapUrl | The ldap url.
Public property | RootUrl | The root url for the LDAP server.
Public property | ServerName | The name of the LDAP server.
Public property | UserDN | The user distinguished name for the LDAP server.

See Also

LdapAuthenticationInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountName Property

[image]

OfficeClip API Documentation
LdapAuthenticationInfo..::.AccountName Property
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The account name for the LDAP server.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AccountName { get; }
Visual Basic (Declaration)
Public ReadOnly Property AccountName As String
Visual C++
public:
property String^ AccountName {
    String^ get ();
}

See Also

LdapAuthenticationInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountPassword Property

[image]

OfficeClip API Documentation
LdapAuthenticationInfo..::.AccountPassword Property
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Password that is sent to the LDAP server for validation.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AccountPassword { get; }
Visual Basic (Declaration)
Public ReadOnly Property AccountPassword As String
Visual C++
public:
property String^ AccountPassword {
    String^ get ();
}

See Also

LdapAuthenticationInfo Class
OfficeClip.BusinessLayer.Account Namespace


AuthenticationType Property

[image]

OfficeClip API Documentation
LdapAuthenticationInfo..::.AuthenticationType Property
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The authentication type for the LDAP server.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AuthenticationTypes AuthenticationType { get; }
Visual Basic (Declaration)
Public ReadOnly Property AuthenticationType As AuthenticationTypes
Visual C++
public:
property AuthenticationTypes AuthenticationType {
    AuthenticationTypes get ();
}

See Also

LdapAuthenticationInfo Class
OfficeClip.BusinessLayer.Account Namespace


LdapUrl Property

[image]

OfficeClip API Documentation
LdapAuthenticationInfo..::.LdapUrl Property
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ldap url.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LdapUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property LdapUrl As String
Visual C++
public:
property String^ LdapUrl {
    String^ get ();
}

See Also

LdapAuthenticationInfo Class
OfficeClip.BusinessLayer.Account Namespace


RootUrl Property

[image]

OfficeClip API Documentation
LdapAuthenticationInfo..::.RootUrl Property
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The root url for the LDAP server.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RootUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property RootUrl As String
Visual C++
public:
property String^ RootUrl {
    String^ get ();
}

See Also

LdapAuthenticationInfo Class
OfficeClip.BusinessLayer.Account Namespace


ServerName Property

[image]

OfficeClip API Documentation
LdapAuthenticationInfo..::.ServerName Property
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the LDAP server.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ServerName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ServerName As String
Visual C++
public:
property String^ ServerName {
    String^ get ();
}

See Also

LdapAuthenticationInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserDN Property

[image]

OfficeClip API Documentation
LdapAuthenticationInfo..::.UserDN Property
LdapAuthenticationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user distinguished name for the LDAP server.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UserDN { get; set; }
Visual Basic (Declaration)
Public Property UserDN As String
Visual C++
public:
property String^ UserDN {
    String^ get ();
    void set (String^ value);
}

See Also

LdapAuthenticationInfo Class
OfficeClip.BusinessLayer.Account Namespace


LocateResultInfo Class

[image]

OfficeClip API Documentation
LocateResultInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties for the infomation of the pager.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class LocateResultInfo
Visual Basic (Declaration)
Public Class LocateResultInfo
Visual C++
public ref class LocateResultInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.LocateResultInfo

See Also

LocateResultInfo Members
OfficeClip.BusinessLayer.Account Namespace


LocateResultInfo Members

[image] [image]

OfficeClip API Documentation
LocateResultInfo Members
LocateResultInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The LocateResultInfo type exposes the following members.

Constructors

 | Name | Description
Public method | LocateResultInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PagerInfo | The pager information.
Public property | ResultString | The result string after the page is sent. The localized output shows whether the page is pending, successfully sent or failed.
Public property | Status | The Status.

See Also

LocateResultInfo Class
OfficeClip.BusinessLayer.Account Namespace


LocateResultInfo Constructor

[image] [image]

OfficeClip API Documentation
LocateResultInfo Constructor
LocateResultInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | LocateResultInfo()()() | The default constructor.
Public method | LocateResultInfo(String, Int32) | The constructor taking the pager information and the Status.

See Also

LocateResultInfo Class
LocateResultInfo Members
OfficeClip.BusinessLayer.Account Namespace


LocateResultInfo Constructor

[image]

OfficeClip API Documentation
LocateResultInfo Constructor
LocateResultInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public LocateResultInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LocateResultInfo()

See Also

LocateResultInfo Class
LocateResultInfo Overload
OfficeClip.BusinessLayer.Account Namespace


LocateResultInfo Constructor (String, Int32)

[image]

OfficeClip API Documentation
LocateResultInfo Constructor (String, Int32)
LocateResultInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor taking the pager information and the Status.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public LocateResultInfo(
    string pagerInfo,
    int status
)
Visual Basic (Declaration)
Public Sub New ( _
    pagerInfo As String, _
    status As Integer _
)
Visual C++
public:
LocateResultInfo(
    String^ pagerInfo,
    int status
)

Parameters

pagerInfo
Type: System..::.String
The pager information.
status
Type: System..::.Int32
The Status.

See Also

LocateResultInfo Class
LocateResultInfo Overload
OfficeClip.BusinessLayer.Account Namespace


LocateResultInfo Properties

[image] [image]

OfficeClip API Documentation
LocateResultInfo Properties
LocateResultInfo Class See Also

[This is preliminary documentation and is subject to change.]

The LocateResultInfo type exposes the following properties.

Properties

 | Name | Description
Public property | PagerInfo | The pager information.
Public property | ResultString | The result string after the page is sent. The localized output shows whether the page is pending, successfully sent or failed.
Public property | Status | The Status.

See Also

LocateResultInfo Class
OfficeClip.BusinessLayer.Account Namespace


PagerInfo Property

[image]

OfficeClip API Documentation
LocateResultInfo..::.PagerInfo Property
LocateResultInfo Class See Also

[This is preliminary documentation and is subject to change.]

The pager information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PagerInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagerInfo As String
Visual C++
public:
property String^ PagerInfo {
    String^ get ();
}

See Also

LocateResultInfo Class
OfficeClip.BusinessLayer.Account Namespace


ResultString Property

[image]

OfficeClip API Documentation
LocateResultInfo..::.ResultString Property
LocateResultInfo Class See Also

[This is preliminary documentation and is subject to change.]

The result string after the page is sent. The localized output shows whether the page is pending, successfully sent or failed.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ResultString { get; }
Visual Basic (Declaration)
Public ReadOnly Property ResultString As String
Visual C++
public:
property String^ ResultString {
    String^ get ();
}

See Also

LocateResultInfo Class
OfficeClip.BusinessLayer.Account Namespace


Status Property

[image]

OfficeClip API Documentation
LocateResultInfo..::.Status Property
LocateResultInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Status.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Status { get; }
Visual Basic (Declaration)
Public ReadOnly Property Status As Integer
Visual C++
public:
property int Status {
    int get ();
}

See Also

LocateResultInfo Class
OfficeClip.BusinessLayer.Account Namespace


LoginInfo Class

[image]

OfficeClip API Documentation
LoginInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the login information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class LoginInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class LoginInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class LoginInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.LoginInfo

See Also

LoginInfo Members
OfficeClip.BusinessLayer.Account Namespace


LoginInfo Members

[image] [image]

OfficeClip API Documentation
LoginInfo Members
LoginInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The LoginInfo type exposes the following members.

Constructors

 | Name | Description
Public method | LoginInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EmailAddress | The email Address used for login.
Public property | Password | The Password used for login.

See Also

LoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


LoginInfo Constructor

[image] [image]

OfficeClip API Documentation
LoginInfo Constructor
LoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | LoginInfo()()() | The default constructor.
Public method | LoginInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

LoginInfo Class
LoginInfo Members
OfficeClip.BusinessLayer.Account Namespace


LoginInfo Constructor

[image]

OfficeClip API Documentation
LoginInfo Constructor
LoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public LoginInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoginInfo()

See Also

LoginInfo Class
LoginInfo Overload
OfficeClip.BusinessLayer.Account Namespace


LoginInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
LoginInfo Constructor (SerializationInfo, StreamingContext)
LoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public LoginInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
LoginInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

LoginInfo Class
LoginInfo Overload
OfficeClip.BusinessLayer.Account Namespace


LoginInfo Methods

[image] [image]

OfficeClip API Documentation
LoginInfo Methods
LoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The LoginInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
LoginInfo..::.GetObjectData Method
LoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

LoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


LoginInfo Properties

[image] [image]

OfficeClip API Documentation
LoginInfo Properties
LoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The LoginInfo type exposes the following properties.

Properties

 | Name | Description
Public property | EmailAddress | The email Address used for login.
Public property | Password | The Password used for login.

See Also

LoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


EmailAddress Property

[image]

OfficeClip API Documentation
LoginInfo..::.EmailAddress Property
LoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Address used for login.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic (Declaration)
Public Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

LoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


Password Property

[image]

OfficeClip API Documentation
LoginInfo..::.Password Property
LoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Password used for login.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

LoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


OCSysInfo Class

[image]

OfficeClip API Documentation
OCSysInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the OfficeClip System Information Information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCSysInfo
Visual Basic (Declaration)
Public Class OCSysInfo
Visual C++
public ref class OCSysInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.OCSysInfo

See Also

OCSysInfo Members
OfficeClip.BusinessLayer.Account Namespace


OCSysInfo Members

[image] [image]

OfficeClip API Documentation
OCSysInfo Members
OCSysInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCSysInfo type exposes the following members.

Constructors

 | Name | Description
Public method | OCSysInfo | Overloaded.

Methods

 | Name | Description
Public method | CheckValid |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetHash | Gets the hash value
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicationOk | Shows if the application is allowed to be executed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Al | al.
Public property | AlStr | alStr.
Public property | AspCode | The asp code
Public property | dy | Day.
Public property | Email | Email
Public property | HostName | Host Name
Public property | IsEval | True if it is Evaluation
Public property | IsExpress | True if the implementation is for OfficeClip express
Public property | IsUnlimited | Is unlimited user allowed.
Public property | Limit | The Limit on the number of days.
Public property | mn | Month.
Public property | nd | The number of days.
Public property | ne | ne.
Public property | np | np.
Public property | nu | The number of users.
Public property | NumberOfUsers | Total number of users.
Public property | ProductName | The product name
Public property | SerialNumber | The serial number
Public property | TimeLimit | Time Limit for the license.
Public property | UpgradeLimit | Date till the upgrade is possible.
Public property | UpgradeTimeLimit | The upgraded time Limit for the license.
Public property | ValidUptoTimestamp | How long the license is valid. If DateTime.MinValue is returned then there is an error If DateTime.MaxValue is returned then the timelimit is infinite
Public property | yr | Year.

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


OCSysInfo Constructor

[image] [image]

OfficeClip API Documentation
OCSysInfo Constructor
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCSysInfo()()() | The default constructor.
Public method | OCSysInfo(String) |

See Also

OCSysInfo Class
OCSysInfo Members
OfficeClip.BusinessLayer.Account Namespace


OCSysInfo Constructor

[image]

OfficeClip API Documentation
OCSysInfo Constructor
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCSysInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCSysInfo()

See Also

OCSysInfo Class
OCSysInfo Overload
OfficeClip.BusinessLayer.Account Namespace


OCSysInfo Constructor (String)

[image]

OfficeClip API Documentation
OCSysInfo Constructor (String)
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCSysInfo(
    string fileName
)
Visual Basic (Declaration)
Public Sub New ( _
    fileName As String _
)
Visual C++
public:
OCSysInfo(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

OCSysInfo Class
OCSysInfo Overload
OfficeClip.BusinessLayer.Account Namespace


OCSysInfo Methods

[image] [image]

OfficeClip API Documentation
OCSysInfo Methods
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

The OCSysInfo type exposes the following methods.

Methods

 | Name | Description
Public method | CheckValid |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetHash | Gets the hash value
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicationOk | Shows if the application is allowed to be executed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


CheckValid Method

[image]

OfficeClip API Documentation
OCSysInfo..::.CheckValid Method
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CheckValid(
    XmlDocument doc
)
Visual Basic (Declaration)
Public Sub CheckValid ( _
    doc As XmlDocument _
)
Visual C++
public:
void CheckValid(
    XmlDocument^ doc
)

Parameters

doc
Type: System.Xml..::.XmlDocument

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetHash Method

[image]

OfficeClip API Documentation
OCSysInfo..::.GetHash Method
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the hash value

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetHash(
    string str
)
Visual Basic (Declaration)
Protected Function GetHash ( _
    str As String _
) As String
Visual C++
protected:
String^ GetHash(
    String^ str
)

Parameters

str
Type: System..::.String

Return Value

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsApplicationOk Method

[image]

OfficeClip API Documentation
OCSysInfo..::.IsApplicationOk Method
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the application is allowed to be executed.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsApplicationOk(
    Constants..::.ApplicationType aType
)
Visual Basic (Declaration)
Public Function IsApplicationOk ( _
    aType As Constants..::.ApplicationType _
) As Boolean
Visual C++
public:
bool IsApplicationOk(
    Constants..::.ApplicationType aType
)

Parameters

aType
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
The application type.

Return Value

true if the application is allowed to be executed, false otherwise.

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


OCSysInfo Properties

[image] [image]

OfficeClip API Documentation
OCSysInfo Properties
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

The OCSysInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Al | al.
Public property | AlStr | alStr.
Public property | AspCode | The asp code
Public property | dy | Day.
Public property | Email | Email
Public property | HostName | Host Name
Public property | IsEval | True if it is Evaluation
Public property | IsExpress | True if the implementation is for OfficeClip express
Public property | IsUnlimited | Is unlimited user allowed.
Public property | Limit | The Limit on the number of days.
Public property | mn | Month.
Public property | nd | The number of days.
Public property | ne | ne.
Public property | np | np.
Public property | nu | The number of users.
Public property | NumberOfUsers | Total number of users.
Public property | ProductName | The product name
Public property | SerialNumber | The serial number
Public property | TimeLimit | Time Limit for the license.
Public property | UpgradeLimit | Date till the upgrade is possible.
Public property | UpgradeTimeLimit | The upgraded time Limit for the license.
Public property | ValidUptoTimestamp | How long the license is valid. If DateTime.MinValue is returned then there is an error If DateTime.MaxValue is returned then the timelimit is infinite
Public property | yr | Year.

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


Al Property

[image]

OfficeClip API Documentation
OCSysInfo..::.Al Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

al.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Al { get; }
Visual Basic (Declaration)
Public ReadOnly Property Al As ArrayList
Visual C++
public:
property ArrayList^ Al {
    ArrayList^ get ();
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


AlStr Property

[image]

OfficeClip API Documentation
OCSysInfo..::.AlStr Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

alStr.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AlStr { get; set; }
Visual Basic (Declaration)
Public Property AlStr As String
Visual C++
public:
property String^ AlStr {
    String^ get ();
    void set (String^ value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


AspCode Property

[image]

OfficeClip API Documentation
OCSysInfo..::.AspCode Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

The asp code

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AspCode { get; set; }
Visual Basic (Declaration)
Public Property AspCode As String
Visual C++
public:
property String^ AspCode {
    String^ get ();
    void set (String^ value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


dy Property

[image]

OfficeClip API Documentation
OCSysInfo..::.dy Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Day.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int dy { get; set; }
Visual Basic (Declaration)
Public Property dy As Integer
Visual C++
public:
property int dy {
    int get ();
    void set (int value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


Email Property

[image]

OfficeClip API Documentation
OCSysInfo..::.Email Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Email

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Email { get; set; }
Visual Basic (Declaration)
Public Property Email As String
Visual C++
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


HostName Property

[image]

OfficeClip API Documentation
OCSysInfo..::.HostName Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Host Name

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string HostName { get; set; }
Visual Basic (Declaration)
Public Property HostName As String
Visual C++
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsEval Property

[image]

OfficeClip API Documentation
OCSysInfo..::.IsEval Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

True if it is Evaluation

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsEval { get; set; }
Visual Basic (Declaration)
Public Property IsEval As Boolean
Visual C++
public:
property bool IsEval {
    bool get ();
    void set (bool value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsExpress Property

[image]

OfficeClip API Documentation
OCSysInfo..::.IsExpress Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

True if the implementation is for OfficeClip express

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsExpress { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExpress As Boolean
Visual C++
public:
property bool IsExpress {
    bool get ();
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsUnlimited Property

[image]

OfficeClip API Documentation
OCSysInfo..::.IsUnlimited Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Is unlimited user allowed.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsUnlimited { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsUnlimited As Boolean
Visual C++
public:
property bool IsUnlimited {
    bool get ();
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


Limit Property

[image]

OfficeClip API Documentation
OCSysInfo..::.Limit Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Limit on the number of days.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime Limit { get; }
Visual Basic (Declaration)
Public ReadOnly Property Limit As DateTime
Visual C++
public:
property DateTime Limit {
    DateTime get ();
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


mn Property

[image]

OfficeClip API Documentation
OCSysInfo..::.mn Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Month.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int mn { get; set; }
Visual Basic (Declaration)
Public Property mn As Integer
Visual C++
public:
property int mn {
    int get ();
    void set (int value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


nd Property

[image]

OfficeClip API Documentation
OCSysInfo..::.nd Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

The number of days.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int nd { get; set; }
Visual Basic (Declaration)
Public Property nd As Integer
Visual C++
public:
property int nd {
    int get ();
    void set (int value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


ne Property

[image]

OfficeClip API Documentation
OCSysInfo..::.ne Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

ne.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ne { get; set; }
Visual Basic (Declaration)
Public Property ne As Integer
Visual C++
public:
property int ne {
    int get ();
    void set (int value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


np Property

[image]

OfficeClip API Documentation
OCSysInfo..::.np Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

np.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int np { get; set; }
Visual Basic (Declaration)
Public Property np As Integer
Visual C++
public:
property int np {
    int get ();
    void set (int value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


nu Property

[image]

OfficeClip API Documentation
OCSysInfo..::.nu Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

The number of users.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int nu { get; set; }
Visual Basic (Declaration)
Public Property nu As Integer
Visual C++
public:
property int nu {
    int get ();
    void set (int value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumberOfUsers Property

[image]

OfficeClip API Documentation
OCSysInfo..::.NumberOfUsers Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Total number of users.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string NumberOfUsers { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumberOfUsers As String
Visual C++
public:
property String^ NumberOfUsers {
    String^ get ();
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


ProductName Property

[image]

OfficeClip API Documentation
OCSysInfo..::.ProductName Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

The product name

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProductName { get; set; }
Visual Basic (Declaration)
Public Property ProductName As String
Visual C++
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


SerialNumber Property

[image]

OfficeClip API Documentation
OCSysInfo..::.SerialNumber Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

The serial number

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SerialNumber { get; set; }
Visual Basic (Declaration)
Public Property SerialNumber As String
Visual C++
public:
property String^ SerialNumber {
    String^ get ();
    void set (String^ value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


TimeLimit Property

[image]

OfficeClip API Documentation
OCSysInfo..::.TimeLimit Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Time Limit for the license.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TimeLimit { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimeLimit As String
Visual C++
public:
property String^ TimeLimit {
    String^ get ();
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


UpgradeLimit Property

[image]

OfficeClip API Documentation
OCSysInfo..::.UpgradeLimit Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Date till the upgrade is possible.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime UpgradeLimit { get; }
Visual Basic (Declaration)
Public ReadOnly Property UpgradeLimit As DateTime
Visual C++
public:
property DateTime UpgradeLimit {
    DateTime get ();
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


UpgradeTimeLimit Property

[image]

OfficeClip API Documentation
OCSysInfo..::.UpgradeTimeLimit Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

The upgraded time Limit for the license.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UpgradeTimeLimit { get; }
Visual Basic (Declaration)
Public ReadOnly Property UpgradeTimeLimit As String
Visual C++
public:
property String^ UpgradeTimeLimit {
    String^ get ();
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


ValidUptoTimestamp Property

[image]

OfficeClip API Documentation
OCSysInfo..::.ValidUptoTimestamp Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

How long the license is valid. If DateTime.MinValue is returned then there is an error If DateTime.MaxValue is returned then the timelimit is infinite

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ValidUptoTimestamp { get; }
Visual Basic (Declaration)
Public ReadOnly Property ValidUptoTimestamp As DateTime
Visual C++
public:
property DateTime ValidUptoTimestamp {
    DateTime get ();
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


yr Property

[image]

OfficeClip API Documentation
OCSysInfo..::.yr Property
OCSysInfo Class See Also

[This is preliminary documentation and is subject to change.]

Year.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int yr { get; set; }
Visual Basic (Declaration)
Public Property yr As Integer
Visual C++
public:
property int yr {
    int get ();
    void set (int value);
}

See Also

OCSysInfo Class
OfficeClip.BusinessLayer.Account Namespace


PayPalReturnInfo Class

[image]

OfficeClip API Documentation
PayPalReturnInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Structure for the papal return information

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class PayPalReturnInfo
Visual Basic (Declaration)
Public Class PayPalReturnInfo
Visual C++
public ref class PayPalReturnInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.PayPalReturnInfo

See Also

PayPalReturnInfo Members
OfficeClip.BusinessLayer.Account Namespace


PayPalReturnInfo Members

[image] [image]

OfficeClip API Documentation
PayPalReturnInfo Members
PayPalReturnInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PayPalReturnInfo type exposes the following members.

Constructors

 | Name | Description
Public method | PayPalReturnInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serializes the paypal information
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The unique id of the account
Public property | DocStorageList | The document storage list
Public property | NumDays | The number of days
Public property | NumUsers | The total number of users
Public property | ReminderDate | The reminder date
Public property | SelectedPackage | The selected package by the user
Public property | Ti | The transaction information object
Public property | UserId | The user id

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


PayPalReturnInfo Constructor

[image] [image]

OfficeClip API Documentation
PayPalReturnInfo Constructor
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PayPalReturnInfo(String) | The paypal return information constructor
Public method | PayPalReturnInfo(transactionInfo, Int32, Int32, Int32, Int32, DateTime, ArrayList, Int32) | COnstructor for the paypal return information

See Also

PayPalReturnInfo Class
PayPalReturnInfo Members
OfficeClip.BusinessLayer.Account Namespace


PayPalReturnInfo Constructor (String)

[image]

OfficeClip API Documentation
PayPalReturnInfo Constructor (String)
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

The paypal return information constructor

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PayPalReturnInfo(
    string serializedString
)
Visual Basic (Declaration)
Public Sub New ( _
    serializedString As String _
)
Visual C++
public:
PayPalReturnInfo(
    String^ serializedString
)

Parameters

serializedString
Type: System..::.String
The serialized string to create the object

See Also

PayPalReturnInfo Class
PayPalReturnInfo Overload
OfficeClip.BusinessLayer.Account Namespace


PayPalReturnInfo Constructor (transactionInfo, Int32, Int32, Int32, Int32, DateTime, ArrayList, Int32)

[image]

OfficeClip API Documentation
PayPalReturnInfo Constructor (transactionInfo, Int32, Int32, Int32, Int32, DateTime, ArrayList, Int32)
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

COnstructor for the paypal return information

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PayPalReturnInfo(
    transactionInfo ti,
    int accountId,
    int numUsers,
    int numDays,
    int userId,
    DateTime reminderDate,
    ArrayList docStorageList,
    int selectedPackage
)
Visual Basic (Declaration)
Public Sub New ( _
    ti As transactionInfo, _
    accountId As Integer, _
    numUsers As Integer, _
    numDays As Integer, _
    userId As Integer, _
    reminderDate As DateTime, _
    docStorageList As ArrayList, _
    selectedPackage As Integer _
)
Visual C++
public:
PayPalReturnInfo(
    transactionInfo^ ti,
    int accountId,
    int numUsers,
    int numDays,
    int userId,
    DateTime reminderDate,
    ArrayList^ docStorageList,
    int selectedPackage
)

Parameters

ti
Type: OfficeClip.BusinessLayer.Account..::.transactionInfo
The intransaction information object
accountId
Type: System..::.Int32
The unique id of the account
numUsers
Type: System..::.Int32
The total number of users
numDays
Type: System..::.Int32
The number of days
userId
Type: System..::.Int32
The unique id of the user
reminderDate
Type: System..::.DateTime
The reminder date
docStorageList
Type: System.Collections..::.ArrayList
The document storage list
selectedPackage
Type: System..::.Int32
The list of selected package

See Also

PayPalReturnInfo Class
PayPalReturnInfo Overload
OfficeClip.BusinessLayer.Account Namespace


PayPalReturnInfo Methods

[image] [image]

OfficeClip API Documentation
PayPalReturnInfo Methods
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PayPalReturnInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serializes the paypal information
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


Serialize Method

[image]

OfficeClip API Documentation
PayPalReturnInfo..::.Serialize Method
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

Serializes the paypal information

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Serialize()
Visual Basic (Declaration)
Public Function Serialize As String
Visual C++
public:
String^ Serialize()

Return Value

The serialized string

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


PayPalReturnInfo Properties

[image] [image]

OfficeClip API Documentation
PayPalReturnInfo Properties
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PayPalReturnInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The unique id of the account
Public property | DocStorageList | The document storage list
Public property | NumDays | The number of days
Public property | NumUsers | The total number of users
Public property | ReminderDate | The reminder date
Public property | SelectedPackage | The selected package by the user
Public property | Ti | The transaction information object
Public property | UserId | The user id

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccountId Property

[image]

OfficeClip API Documentation
PayPalReturnInfo..::.AccountId Property
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the account

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AccountId { get; }
Visual Basic (Declaration)
Public ReadOnly Property AccountId As Integer
Visual C++
public:
property int AccountId {
    int get ();
}

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


DocStorageList Property

[image]

OfficeClip API Documentation
PayPalReturnInfo..::.DocStorageList Property
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

The document storage list

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList DocStorageList { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocStorageList As ArrayList
Visual C++
public:
property ArrayList^ DocStorageList {
    ArrayList^ get ();
}

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumDays Property

[image]

OfficeClip API Documentation
PayPalReturnInfo..::.NumDays Property
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

The number of days

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumDays { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumDays As Integer
Visual C++
public:
property int NumDays {
    int get ();
}

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumUsers Property

[image]

OfficeClip API Documentation
PayPalReturnInfo..::.NumUsers Property
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

The total number of users

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumUsers { get; }
Visual Basic (Declaration)
Public ReadOnly Property NumUsers As Integer
Visual C++
public:
property int NumUsers {
    int get ();
}

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


ReminderDate Property

[image]

OfficeClip API Documentation
PayPalReturnInfo..::.ReminderDate Property
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

The reminder date

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ReminderDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReminderDate As DateTime
Visual C++
public:
property DateTime ReminderDate {
    DateTime get ();
}

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


SelectedPackage Property

[image]

OfficeClip API Documentation
PayPalReturnInfo..::.SelectedPackage Property
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

The selected package by the user

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SelectedPackage { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedPackage As Integer
Visual C++
public:
property int SelectedPackage {
    int get ();
}

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


Ti Property

[image]

OfficeClip API Documentation
PayPalReturnInfo..::.Ti Property
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

The transaction information object

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public transactionInfo Ti { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ti As transactionInfo
Visual C++
public:
property transactionInfo^ Ti {
    transactionInfo^ get ();
}

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserId Property

[image]

OfficeClip API Documentation
PayPalReturnInfo..::.UserId Property
PayPalReturnInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user id

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; }
Visual Basic (Declaration)
Public ReadOnly Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
}

See Also

PayPalReturnInfo Class
OfficeClip.BusinessLayer.Account Namespace


PendingInvitationInfo Class

[image]

OfficeClip API Documentation
PendingInvitationInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access pending invitation information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class PendingInvitationInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PendingInvitationInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class PendingInvitationInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.PendingInvitationInfo

See Also

PendingInvitationInfo Members
OfficeClip.BusinessLayer.Account Namespace


PendingInvitationInfo Members

[image] [image]

OfficeClip API Documentation
PendingInvitationInfo Members
PendingInvitationInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PendingInvitationInfo type exposes the following members.

Constructors

 | Name | Description
Public method | PendingInvitationInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FirstName | The firstname of the user for which the invitatiaon is pending.
Public property | GroupId | The identifier of the group for which the invitation is pending.
Public property | GroupName | The name of for which the invitation is pending.
Public property | GroupType | The type of the group for which the invitation is pending. The group type could be "P" - Private, "O" - Organization, "G" - Group or "D" - Department.
Public property | InvitedByUserId | The unique identifier of the user who invited the current user for whom the invitation is pending.
Public property | LastName | The last name of the user for which the invitation is pending.

See Also

PendingInvitationInfo Class
OfficeClip.BusinessLayer.Account Namespace


PendingInvitationInfo Constructor

[image] [image]

OfficeClip API Documentation
PendingInvitationInfo Constructor
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PendingInvitationInfo()()() | The default constructor.
Public method | PendingInvitationInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

PendingInvitationInfo Class
PendingInvitationInfo Members
OfficeClip.BusinessLayer.Account Namespace


PendingInvitationInfo Constructor

[image]

OfficeClip API Documentation
PendingInvitationInfo Constructor
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PendingInvitationInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PendingInvitationInfo()

See Also

PendingInvitationInfo Class
PendingInvitationInfo Overload
OfficeClip.BusinessLayer.Account Namespace


PendingInvitationInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
PendingInvitationInfo Constructor (SerializationInfo, StreamingContext)
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PendingInvitationInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
PendingInvitationInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

PendingInvitationInfo Class
PendingInvitationInfo Overload
OfficeClip.BusinessLayer.Account Namespace


PendingInvitationInfo Methods

[image] [image]

OfficeClip API Documentation
PendingInvitationInfo Methods
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PendingInvitationInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PendingInvitationInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
PendingInvitationInfo..::.GetObjectData Method
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

PendingInvitationInfo Class
OfficeClip.BusinessLayer.Account Namespace


PendingInvitationInfo Properties

[image] [image]

OfficeClip API Documentation
PendingInvitationInfo Properties
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PendingInvitationInfo type exposes the following properties.

Properties

 | Name | Description
Public property | FirstName | The firstname of the user for which the invitatiaon is pending.
Public property | GroupId | The identifier of the group for which the invitation is pending.
Public property | GroupName | The name of for which the invitation is pending.
Public property | GroupType | The type of the group for which the invitation is pending. The group type could be "P" - Private, "O" - Organization, "G" - Group or "D" - Department.
Public property | InvitedByUserId | The unique identifier of the user who invited the current user for whom the invitation is pending.
Public property | LastName | The last name of the user for which the invitation is pending.

See Also

PendingInvitationInfo Class
OfficeClip.BusinessLayer.Account Namespace


FirstName Property

[image]

OfficeClip API Documentation
PendingInvitationInfo..::.FirstName Property
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The firstname of the user for which the invitatiaon is pending.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

PendingInvitationInfo Class
OfficeClip.BusinessLayer.Account Namespace


GroupId Property

[image]

OfficeClip API Documentation
PendingInvitationInfo..::.GroupId Property
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier of the group for which the invitation is pending.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

PendingInvitationInfo Class
OfficeClip.BusinessLayer.Account Namespace


GroupName Property

[image]

OfficeClip API Documentation
PendingInvitationInfo..::.GroupName Property
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of for which the invitation is pending.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GroupName { get; set; }
Visual Basic (Declaration)
Public Property GroupName As String
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

See Also

PendingInvitationInfo Class
OfficeClip.BusinessLayer.Account Namespace


GroupType Property

[image]

OfficeClip API Documentation
PendingInvitationInfo..::.GroupType Property
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The type of the group for which the invitation is pending. The group type could be "P" - Private, "O" - Organization, "G" - Group or "D" - Department.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GroupType { get; set; }
Visual Basic (Declaration)
Public Property GroupType As String
Visual C++
public:
property String^ GroupType {
    String^ get ();
    void set (String^ value);
}

See Also

PendingInvitationInfo Class
OfficeClip.BusinessLayer.Account Namespace


InvitedByUserId Property

[image]

OfficeClip API Documentation
PendingInvitationInfo..::.InvitedByUserId Property
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique identifier of the user who invited the current user for whom the invitation is pending.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int InvitedByUserId { get; set; }
Visual Basic (Declaration)
Public Property InvitedByUserId As Integer
Visual C++
public:
property int InvitedByUserId {
    int get ();
    void set (int value);
}

See Also

PendingInvitationInfo Class
OfficeClip.BusinessLayer.Account Namespace


LastName Property

[image]

OfficeClip API Documentation
PendingInvitationInfo..::.LastName Property
PendingInvitationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last name of the user for which the invitation is pending.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

PendingInvitationInfo Class
OfficeClip.BusinessLayer.Account Namespace


RegionalSettings Class

[image]

OfficeClip API Documentation
RegionalSettings Class
Members See Also

[This is preliminary documentation and is subject to change.]

The regional settings object

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class RegionalSettings
Visual Basic (Declaration)
Public Class RegionalSettings
Visual C++
public ref class RegionalSettings

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.RegionalSettings

See Also

RegionalSettings Members
OfficeClip.BusinessLayer.Account Namespace


RegionalSettings Members

[image] [image]

OfficeClip API Documentation
RegionalSettings Members
RegionalSettings Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RegionalSettings type exposes the following members.

Constructors

 | Name | Description
Public method | RegionalSettings | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a serialized regional setting (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | Culture | The culture
Public property | LongDate | Long Date
Public property | LongTime | Long Time
Public property | MediumDate | Medium date
Public property | MediumTime | Medium time
Public property | ShortDate | Short date
Public property | ShortTime | Short time
Public property | UICulture | The ui culture

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


RegionalSettings Constructor

[image] [image]

OfficeClip API Documentation
RegionalSettings Constructor
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | RegionalSettings()()() | Constructor
Public method | RegionalSettings(String) | Constructor

See Also

RegionalSettings Class
RegionalSettings Members
OfficeClip.BusinessLayer.Account Namespace


RegionalSettings Constructor

[image]

OfficeClip API Documentation
RegionalSettings Constructor
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RegionalSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RegionalSettings()

See Also

RegionalSettings Class
RegionalSettings Overload
OfficeClip.BusinessLayer.Account Namespace


RegionalSettings Constructor (String)

[image]

OfficeClip API Documentation
RegionalSettings Constructor (String)
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RegionalSettings(
    string settings
)
Visual Basic (Declaration)
Public Sub New ( _
    settings As String _
)
Visual C++
public:
RegionalSettings(
    String^ settings
)

Parameters

settings
Type: System..::.String
the serialized settings

See Also

RegionalSettings Class
RegionalSettings Overload
OfficeClip.BusinessLayer.Account Namespace


RegionalSettings Methods

[image] [image]

OfficeClip API Documentation
RegionalSettings Methods
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

The RegionalSettings type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates a serialized regional setting (Overrides Object..::.ToString()()().)

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


ToString Method

[image]

OfficeClip API Documentation
RegionalSettings..::.ToString Method
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Creates a serialized regional setting

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


RegionalSettings Properties

[image] [image]

OfficeClip API Documentation
RegionalSettings Properties
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

The RegionalSettings type exposes the following properties.

Properties

 | Name | Description
Public property | Culture | The culture
Public property | LongDate | Long Date
Public property | LongTime | Long Time
Public property | MediumDate | Medium date
Public property | MediumTime | Medium time
Public property | ShortDate | Short date
Public property | ShortTime | Short time
Public property | UICulture | The ui culture

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


Culture Property

[image]

OfficeClip API Documentation
RegionalSettings..::.Culture Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

The culture

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Culture { get; set; }
Visual Basic (Declaration)
Public Property Culture As String
Visual C++
public:
property String^ Culture {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


LongDate Property

[image]

OfficeClip API Documentation
RegionalSettings..::.LongDate Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Long Date

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LongDate { get; set; }
Visual Basic (Declaration)
Public Property LongDate As String
Visual C++
public:
property String^ LongDate {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


LongTime Property

[image]

OfficeClip API Documentation
RegionalSettings..::.LongTime Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Long Time

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LongTime { get; set; }
Visual Basic (Declaration)
Public Property LongTime As String
Visual C++
public:
property String^ LongTime {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


MediumDate Property

[image]

OfficeClip API Documentation
RegionalSettings..::.MediumDate Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Medium date

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string MediumDate { get; set; }
Visual Basic (Declaration)
Public Property MediumDate As String
Visual C++
public:
property String^ MediumDate {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


MediumTime Property

[image]

OfficeClip API Documentation
RegionalSettings..::.MediumTime Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Medium time

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string MediumTime { get; set; }
Visual Basic (Declaration)
Public Property MediumTime As String
Visual C++
public:
property String^ MediumTime {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


ShortDate Property

[image]

OfficeClip API Documentation
RegionalSettings..::.ShortDate Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Short date

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ShortDate { get; set; }
Visual Basic (Declaration)
Public Property ShortDate As String
Visual C++
public:
property String^ ShortDate {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


ShortTime Property

[image]

OfficeClip API Documentation
RegionalSettings..::.ShortTime Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Short time

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ShortTime { get; set; }
Visual Basic (Declaration)
Public Property ShortTime As String
Visual C++
public:
property String^ ShortTime {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


UICulture Property

[image]

OfficeClip API Documentation
RegionalSettings..::.UICulture Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

The ui culture

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UICulture { get; set; }
Visual Basic (Declaration)
Public Property UICulture As String
Visual C++
public:
property String^ UICulture {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.BusinessLayer.Account Namespace


SmsInfo Class

[image]

OfficeClip API Documentation
SmsInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the SMS information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class SmsInfo
Visual Basic (Declaration)
Public Class SmsInfo
Visual C++
public ref class SmsInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.SmsInfo

See Also

SmsInfo Members
OfficeClip.BusinessLayer.Account Namespace


SmsInfo Members

[image] [image]

OfficeClip API Documentation
SmsInfo Members
SmsInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The SmsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | SmsInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Prepares and returns Sms Information as string. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | IsSmsEmail | Gets or Sets value for IsSmsEmail
Public property | SmsCATAppID | Gets or Sets ClickATell App_ID for SMS
Public property | SmsCATPassWord | Gets or Sets ClickATell Password for SMS
Public property | SmsCATUserName | Gets or Sets ClickATell UserName for SMS
Public property | SmsEnabled | Gets or Sets SMS is Enabled
Public property | SmsEnableManualAlerts | Gets or Sets value SMS is Enable for Manual Alerts
Public property | SmsEnableSystemNotification | Gets or Sets value SMS is Enable for System Notification
Public property | SmsPhoneNumber | Gets or Sets ClickATell Password for SMS
Public property | SmsSize | Gets or Sets value for IsSmsEmail
Public property | SmsVerficationCode | Gets or Sets SMS VerficationCode
Public property | SmsVerfied | Gets or Sets SMS is Verfied

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsInfo Constructor

[image] [image]

OfficeClip API Documentation
SmsInfo Constructor
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | SmsInfo()()() | The default constructor.
Public method | SmsInfo(String) |

See Also

SmsInfo Class
SmsInfo Members
OfficeClip.BusinessLayer.Account Namespace


SmsInfo Constructor

[image]

OfficeClip API Documentation
SmsInfo Constructor
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public SmsInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SmsInfo()

See Also

SmsInfo Class
SmsInfo Overload
OfficeClip.BusinessLayer.Account Namespace


SmsInfo Constructor (String)

[image]

OfficeClip API Documentation
SmsInfo Constructor (String)
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public SmsInfo(
    string info
)
Visual Basic (Declaration)
Public Sub New ( _
    info As String _
)
Visual C++
public:
SmsInfo(
    String^ info
)

Parameters

info
Type: System..::.String

See Also

SmsInfo Class
SmsInfo Overload
OfficeClip.BusinessLayer.Account Namespace


SmsInfo Methods

[image] [image]

OfficeClip API Documentation
SmsInfo Methods
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The SmsInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Prepares and returns Sms Information as string. (Overrides Object..::.ToString()()().)

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


ToString Method

[image]

OfficeClip API Documentation
SmsInfo..::.ToString Method
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Prepares and returns Sms Information as string.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

SMS Information Details string

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsInfo Properties

[image] [image]

OfficeClip API Documentation
SmsInfo Properties
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The SmsInfo type exposes the following properties.

Properties

 | Name | Description
Public property | IsSmsEmail | Gets or Sets value for IsSmsEmail
Public property | SmsCATAppID | Gets or Sets ClickATell App_ID for SMS
Public property | SmsCATPassWord | Gets or Sets ClickATell Password for SMS
Public property | SmsCATUserName | Gets or Sets ClickATell UserName for SMS
Public property | SmsEnabled | Gets or Sets SMS is Enabled
Public property | SmsEnableManualAlerts | Gets or Sets value SMS is Enable for Manual Alerts
Public property | SmsEnableSystemNotification | Gets or Sets value SMS is Enable for System Notification
Public property | SmsPhoneNumber | Gets or Sets ClickATell Password for SMS
Public property | SmsSize | Gets or Sets value for IsSmsEmail
Public property | SmsVerficationCode | Gets or Sets SMS VerficationCode
Public property | SmsVerfied | Gets or Sets SMS is Verfied

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsSmsEmail Property

[image]

OfficeClip API Documentation
SmsInfo..::.IsSmsEmail Property
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or Sets value for IsSmsEmail

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSmsEmail { get; set; }
Visual Basic (Declaration)
Public Property IsSmsEmail As Boolean
Visual C++
public:
property bool IsSmsEmail {
    bool get ();
    void set (bool value);
}

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsCATAppID Property

[image]

OfficeClip API Documentation
SmsInfo..::.SmsCATAppID Property
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or Sets ClickATell App_ID for SMS

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SmsCATAppID { get; set; }
Visual Basic (Declaration)
Public Property SmsCATAppID As String
Visual C++
public:
property String^ SmsCATAppID {
    String^ get ();
    void set (String^ value);
}

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsCATPassWord Property

[image]

OfficeClip API Documentation
SmsInfo..::.SmsCATPassWord Property
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or Sets ClickATell Password for SMS

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SmsCATPassWord { get; set; }
Visual Basic (Declaration)
Public Property SmsCATPassWord As String
Visual C++
public:
property String^ SmsCATPassWord {
    String^ get ();
    void set (String^ value);
}

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsCATUserName Property

[image]

OfficeClip API Documentation
SmsInfo..::.SmsCATUserName Property
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or Sets ClickATell UserName for SMS

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SmsCATUserName { get; set; }
Visual Basic (Declaration)
Public Property SmsCATUserName As String
Visual C++
public:
property String^ SmsCATUserName {
    String^ get ();
    void set (String^ value);
}

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsEnabled Property

[image]

OfficeClip API Documentation
SmsInfo..::.SmsEnabled Property
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or Sets SMS is Enabled

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool SmsEnabled { get; set; }
Visual Basic (Declaration)
Public Property SmsEnabled As Boolean
Visual C++
public:
property bool SmsEnabled {
    bool get ();
    void set (bool value);
}

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsEnableManualAlerts Property

[image]

OfficeClip API Documentation
SmsInfo..::.SmsEnableManualAlerts Property
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or Sets value SMS is Enable for Manual Alerts

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool SmsEnableManualAlerts { get; set; }
Visual Basic (Declaration)
Public Property SmsEnableManualAlerts As Boolean
Visual C++
public:
property bool SmsEnableManualAlerts {
    bool get ();
    void set (bool value);
}

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsEnableSystemNotification Property

[image]

OfficeClip API Documentation
SmsInfo..::.SmsEnableSystemNotification Property
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or Sets value SMS is Enable for System Notification

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool SmsEnableSystemNotification { get; set; }
Visual Basic (Declaration)
Public Property SmsEnableSystemNotification As Boolean
Visual C++
public:
property bool SmsEnableSystemNotification {
    bool get ();
    void set (bool value);
}

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsPhoneNumber Property

[image]

OfficeClip API Documentation
SmsInfo..::.SmsPhoneNumber Property
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or Sets ClickATell Password for SMS

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SmsPhoneNumber { get; set; }
Visual Basic (Declaration)
Public Property SmsPhoneNumber As String
Visual C++
public:
property String^ SmsPhoneNumber {
    String^ get ();
    void set (String^ value);
}

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsSize Property

[image]

OfficeClip API Documentation
SmsInfo..::.SmsSize Property
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or Sets value for IsSmsEmail

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SmsSize { get; set; }
Visual Basic (Declaration)
Public Property SmsSize As Integer
Visual C++
public:
property int SmsSize {
    int get ();
    void set (int value);
}

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsVerficationCode Property

[image]

OfficeClip API Documentation
SmsInfo..::.SmsVerficationCode Property
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or Sets SMS VerficationCode

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SmsVerficationCode { get; set; }
Visual Basic (Declaration)
Public Property SmsVerficationCode As String
Visual C++
public:
property String^ SmsVerficationCode {
    String^ get ();
    void set (String^ value);
}

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsVerfied Property

[image]

OfficeClip API Documentation
SmsInfo..::.SmsVerfied Property
SmsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or Sets SMS is Verfied

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool SmsVerfied { get; set; }
Visual Basic (Declaration)
Public Property SmsVerfied As Boolean
Visual C++
public:
property bool SmsVerfied {
    bool get ();
    void set (bool value);
}

See Also

SmsInfo Class
OfficeClip.BusinessLayer.Account Namespace


SmsInfoVerifiedState Enumeration

[image]

OfficeClip API Documentation
SmsInfoVerifiedState Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides States for SMS Device Verification

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum SmsInfoVerifiedState
Visual Basic (Declaration)
Public Enumeration SmsInfoVerifiedState
Visual C++
public enum class SmsInfoVerifiedState

Members

Member name | Description
VERIFIED | The SMS Device has been Verified Successfully
NOTSENT | The SMS Device Verification has not been requested.
SENT | The SMS Device Verification Code has been sent.

See Also

OfficeClip.BusinessLayer.Account Namespace


transactionInfo Class

[image]

OfficeClip API Documentation
transactionInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the credit card transaction information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class transactionInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class transactionInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class transactionInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.transactionInfo

See Also

transactionInfo Members
OfficeClip.BusinessLayer.Account Namespace


transactionInfo Members

[image] [image]

OfficeClip API Documentation
transactionInfo Members
transactionInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The transactionInfo type exposes the following members.

Constructors

 | Name | Description
Public method | transactionInfo | Overloaded.

Methods

 | Name | Description
Public method | dump | Dumps the content of the object for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Amount | The Amount of transaction using the credit card.
Public property | BillingAddress | The billing Address of the credit card.
Public property | CardName | The card name(i.e. the type of the card).
Public property | CardNumber | The full card number.
Public property | CardNumber1 | The first four digit of the card number.
Public property | CardNumber2 | The second four digit of the card number.
Public property | CardNumber3 | The third four digits of the credit card.
Public property | CardNumber4 | The last four digits of the credit card.
Public property | CompanyName | The Company name.
Public property | EmailAddress | The email Address of the user who placed the order.
Public property | ExpirationDate | The expiration date of the credit card.
Public property | ExpirationDay | The expiration day of the credit card.
Public property | ExpirationMonth | The expiration month of the credit card.
Public property | ExpirationYear | The expiration year of the credit card.
Public property | Merchant | The Merchant name.
Public property | NameOnCard | The name on the credit card.
Public property | Notes | The notes.
Public property | OrderId | The system generated identifier for the order.
Public property | PersonName | The Company name.
Public property | PhoneNumber | The telephone number for the transaction.
Public property | ProductDesc | The Description of the Product.
Public property | PurchaseDate | The purchase date of the order.
Public property | PurchaseMethod | The method of purchase. The purchase can be done either via credit card or the purchase order.
Public property | PurchaseOrderNumber | The purchase order number.
Public property | ReturnUrl | The return url where the control is transferred after the order is processed.
Public property | ShippingAddress | The shipping Address of the transaction.
Public property | ShippingAmount | The shipping charge.

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


transactionInfo Constructor

[image] [image]

OfficeClip API Documentation
transactionInfo Constructor
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | transactionInfo(Int32) | The default constructor.
Public method | transactionInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

transactionInfo Class
transactionInfo Members
OfficeClip.BusinessLayer.Account Namespace


transactionInfo Constructor (Int32)

[image]

OfficeClip API Documentation
transactionInfo Constructor (Int32)
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public transactionInfo(
    int AccountId
)
Visual Basic (Declaration)
Public Sub New ( _
    AccountId As Integer _
)
Visual C++
public:
transactionInfo(
    int AccountId
)

Parameters

AccountId
Type: System..::.Int32

See Also

transactionInfo Class
transactionInfo Overload
OfficeClip.BusinessLayer.Account Namespace


transactionInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
transactionInfo Constructor (SerializationInfo, StreamingContext)
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public transactionInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
transactionInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

transactionInfo Class
transactionInfo Overload
OfficeClip.BusinessLayer.Account Namespace


transactionInfo Methods

[image] [image]

OfficeClip API Documentation
transactionInfo Methods
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The transactionInfo type exposes the following methods.

Methods

 | Name | Description
Public method | dump | Dumps the content of the object for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


dump Method

[image]

OfficeClip API Documentation
transactionInfo..::.dump Method
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the content of the object for debugging purposes

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string dump()
Visual Basic (Declaration)
Public Function dump As String
Visual C++
public:
String^ dump()

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
transactionInfo..::.GetObjectData Method
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


transactionInfo Properties

[image] [image]

OfficeClip API Documentation
transactionInfo Properties
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The transactionInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Amount | The Amount of transaction using the credit card.
Public property | BillingAddress | The billing Address of the credit card.
Public property | CardName | The card name(i.e. the type of the card).
Public property | CardNumber | The full card number.
Public property | CardNumber1 | The first four digit of the card number.
Public property | CardNumber2 | The second four digit of the card number.
Public property | CardNumber3 | The third four digits of the credit card.
Public property | CardNumber4 | The last four digits of the credit card.
Public property | CompanyName | The Company name.
Public property | EmailAddress | The email Address of the user who placed the order.
Public property | ExpirationDate | The expiration date of the credit card.
Public property | ExpirationDay | The expiration day of the credit card.
Public property | ExpirationMonth | The expiration month of the credit card.
Public property | ExpirationYear | The expiration year of the credit card.
Public property | Merchant | The Merchant name.
Public property | NameOnCard | The name on the credit card.
Public property | Notes | The notes.
Public property | OrderId | The system generated identifier for the order.
Public property | PersonName | The Company name.
Public property | PhoneNumber | The telephone number for the transaction.
Public property | ProductDesc | The Description of the Product.
Public property | PurchaseDate | The purchase date of the order.
Public property | PurchaseMethod | The method of purchase. The purchase can be done either via credit card or the purchase order.
Public property | PurchaseOrderNumber | The purchase order number.
Public property | ReturnUrl | The return url where the control is transferred after the order is processed.
Public property | ShippingAddress | The shipping Address of the transaction.
Public property | ShippingAmount | The shipping charge.

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


Amount Property

[image]

OfficeClip API Documentation
transactionInfo..::.Amount Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Amount of transaction using the credit card.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double Amount { get; set; }
Visual Basic (Declaration)
Public Property Amount As Double
Visual C++
public:
property double Amount {
    double get ();
    void set (double value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


BillingAddress Property

[image]

OfficeClip API Documentation
transactionInfo..::.BillingAddress Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The billing Address of the credit card.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AddressInfo BillingAddress { get; set; }
Visual Basic (Declaration)
Public Property BillingAddress As AddressInfo
Visual C++
public:
property AddressInfo^ BillingAddress {
    AddressInfo^ get ();
    void set (AddressInfo^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


CardName Property

[image]

OfficeClip API Documentation
transactionInfo..::.CardName Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The card name(i.e. the type of the card).

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CardName { get; set; }
Visual Basic (Declaration)
Public Property CardName As String
Visual C++
public:
property String^ CardName {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


CardNumber Property

[image]

OfficeClip API Documentation
transactionInfo..::.CardNumber Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The full card number.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CardNumber { get; set; }
Visual Basic (Declaration)
Public Property CardNumber As String
Visual C++
public:
property String^ CardNumber {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


CardNumber1 Property

[image]

OfficeClip API Documentation
transactionInfo..::.CardNumber1 Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first four digit of the card number.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CardNumber1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property CardNumber1 As String
Visual C++
public:
property String^ CardNumber1 {
    String^ get ();
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


CardNumber2 Property

[image]

OfficeClip API Documentation
transactionInfo..::.CardNumber2 Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second four digit of the card number.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CardNumber2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property CardNumber2 As String
Visual C++
public:
property String^ CardNumber2 {
    String^ get ();
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


CardNumber3 Property

[image]

OfficeClip API Documentation
transactionInfo..::.CardNumber3 Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The third four digits of the credit card.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CardNumber3 { get; }
Visual Basic (Declaration)
Public ReadOnly Property CardNumber3 As String
Visual C++
public:
property String^ CardNumber3 {
    String^ get ();
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


CardNumber4 Property

[image]

OfficeClip API Documentation
transactionInfo..::.CardNumber4 Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last four digits of the credit card.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CardNumber4 { get; }
Visual Basic (Declaration)
Public ReadOnly Property CardNumber4 As String
Visual C++
public:
property String^ CardNumber4 {
    String^ get ();
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


CompanyName Property

[image]

OfficeClip API Documentation
transactionInfo..::.CompanyName Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Company name.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CompanyName { get; set; }
Visual Basic (Declaration)
Public Property CompanyName As String
Visual C++
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


EmailAddress Property

[image]

OfficeClip API Documentation
transactionInfo..::.EmailAddress Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Address of the user who placed the order.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic (Declaration)
Public Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


ExpirationDate Property

[image]

OfficeClip API Documentation
transactionInfo..::.ExpirationDate Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The expiration date of the credit card.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ExpirationDate { get; set; }
Visual Basic (Declaration)
Public Property ExpirationDate As DateTime
Visual C++
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


ExpirationDay Property

[image]

OfficeClip API Documentation
transactionInfo..::.ExpirationDay Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The expiration day of the credit card.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpirationDay { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExpirationDay As Integer
Visual C++
public:
property int ExpirationDay {
    int get ();
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


ExpirationMonth Property

[image]

OfficeClip API Documentation
transactionInfo..::.ExpirationMonth Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The expiration month of the credit card.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpirationMonth { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExpirationMonth As Integer
Visual C++
public:
property int ExpirationMonth {
    int get ();
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


ExpirationYear Property

[image]

OfficeClip API Documentation
transactionInfo..::.ExpirationYear Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The expiration year of the credit card.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpirationYear { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExpirationYear As Integer
Visual C++
public:
property int ExpirationYear {
    int get ();
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


Merchant Property

[image]

OfficeClip API Documentation
transactionInfo..::.Merchant Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Merchant name.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Merchant { get; set; }
Visual Basic (Declaration)
Public Property Merchant As String
Visual C++
public:
property String^ Merchant {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


NameOnCard Property

[image]

OfficeClip API Documentation
transactionInfo..::.NameOnCard Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name on the credit card.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string NameOnCard { get; set; }
Visual Basic (Declaration)
Public Property NameOnCard As String
Visual C++
public:
property String^ NameOnCard {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


Notes Property

[image]

OfficeClip API Documentation
transactionInfo..::.Notes Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The notes.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


OrderId Property

[image]

OfficeClip API Documentation
transactionInfo..::.OrderId Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated identifier for the order.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string OrderId { get; set; }
Visual Basic (Declaration)
Public Property OrderId As String
Visual C++
public:
property String^ OrderId {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


PersonName Property

[image]

OfficeClip API Documentation
transactionInfo..::.PersonName Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Company name.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PersonName { get; set; }
Visual Basic (Declaration)
Public Property PersonName As String
Visual C++
public:
property String^ PersonName {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


PhoneNumber Property

[image]

OfficeClip API Documentation
transactionInfo..::.PhoneNumber Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The telephone number for the transaction.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PhoneNumber { get; set; }
Visual Basic (Declaration)
Public Property PhoneNumber As String
Visual C++
public:
property String^ PhoneNumber {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


ProductDesc Property

[image]

OfficeClip API Documentation
transactionInfo..::.ProductDesc Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Description of the Product.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProductDesc { get; set; }
Visual Basic (Declaration)
Public Property ProductDesc As String
Visual C++
public:
property String^ ProductDesc {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


PurchaseDate Property

[image]

OfficeClip API Documentation
transactionInfo..::.PurchaseDate Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The purchase date of the order.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime PurchaseDate { get; set; }
Visual Basic (Declaration)
Public Property PurchaseDate As DateTime
Visual C++
public:
property DateTime PurchaseDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


PurchaseMethod Property

[image]

OfficeClip API Documentation
transactionInfo..::.PurchaseMethod Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The method of purchase. The purchase can be done either via credit card or the purchase order.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PurchaseMethod PurchaseMethod { get; set; }
Visual Basic (Declaration)
Public Property PurchaseMethod As PurchaseMethod
Visual C++
public:
property PurchaseMethod PurchaseMethod {
    PurchaseMethod get ();
    void set (PurchaseMethod value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


PurchaseOrderNumber Property

[image]

OfficeClip API Documentation
transactionInfo..::.PurchaseOrderNumber Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The purchase order number.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PurchaseOrderNumber { get; set; }
Visual Basic (Declaration)
Public Property PurchaseOrderNumber As String
Visual C++
public:
property String^ PurchaseOrderNumber {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


ReturnUrl Property

[image]

OfficeClip API Documentation
transactionInfo..::.ReturnUrl Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The return url where the control is transferred after the order is processed.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReturnUrl { get; set; }
Visual Basic (Declaration)
Public Property ReturnUrl As String
Visual C++
public:
property String^ ReturnUrl {
    String^ get ();
    void set (String^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


ShippingAddress Property

[image]

OfficeClip API Documentation
transactionInfo..::.ShippingAddress Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The shipping Address of the transaction.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AddressInfo ShippingAddress { get; set; }
Visual Basic (Declaration)
Public Property ShippingAddress As AddressInfo
Visual C++
public:
property AddressInfo^ ShippingAddress {
    AddressInfo^ get ();
    void set (AddressInfo^ value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


ShippingAmount Property

[image]

OfficeClip API Documentation
transactionInfo..::.ShippingAmount Property
transactionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The shipping charge.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double ShippingAmount { get; set; }
Visual Basic (Declaration)
Public Property ShippingAmount As Double
Visual C++
public:
property double ShippingAmount {
    double get ();
    void set (double value);
}

See Also

transactionInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserAvailability Class

[image]

OfficeClip API Documentation
UserAvailability Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods to interact with the User Availability Object.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class UserAvailability
Visual Basic (Declaration)
Public Class UserAvailability
Visual C++
public ref class UserAvailability

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.UserAvailability

See Also

UserAvailability Members
OfficeClip.BusinessLayer.Account Namespace


UserAvailability Members

[image] [image]

OfficeClip API Documentation
UserAvailability Members
UserAvailability Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The UserAvailability type exposes the following members.

Constructors

 | Name | Description
Public method | UserAvailability | The default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EventId | The system generated unique id of the Alias.
Public property | ShowAs | The Alias as a String.
Public property | UserId | The system generated unique id of the group.

See Also

UserAvailability Class
OfficeClip.BusinessLayer.Account Namespace


UserAvailability Constructor

[image]

OfficeClip API Documentation
UserAvailability Constructor
UserAvailability Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserAvailability()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserAvailability()

See Also

UserAvailability Class
OfficeClip.BusinessLayer.Account Namespace


UserAvailability Properties

[image] [image]

OfficeClip API Documentation
UserAvailability Properties
UserAvailability Class See Also

[This is preliminary documentation and is subject to change.]

The UserAvailability type exposes the following properties.

Properties

 | Name | Description
Public property | EventId | The system generated unique id of the Alias.
Public property | ShowAs | The Alias as a String.
Public property | UserId | The system generated unique id of the group.

See Also

UserAvailability Class
OfficeClip.BusinessLayer.Account Namespace


EventId Property

[image]

OfficeClip API Documentation
UserAvailability..::.EventId Property
UserAvailability Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique id of the Alias.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EventId { get; set; }
Visual Basic (Declaration)
Public Property EventId As Integer
Visual C++
public:
property int EventId {
    int get ();
    void set (int value);
}

See Also

UserAvailability Class
OfficeClip.BusinessLayer.Account Namespace


ShowAs Property

[image]

OfficeClip API Documentation
UserAvailability..::.ShowAs Property
UserAvailability Class See Also

[This is preliminary documentation and is subject to change.]

The Alias as a String.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventShowAs ShowAs { get; set; }
Visual Basic (Declaration)
Public Property ShowAs As EventShowAs
Visual C++
public:
property EventShowAs ShowAs {
    EventShowAs get ();
    void set (EventShowAs value);
}

See Also

UserAvailability Class
OfficeClip.BusinessLayer.Account Namespace


UserId Property

[image]

OfficeClip API Documentation
UserAvailability..::.UserId Property
UserAvailability Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique id of the group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

UserAvailability Class
OfficeClip.BusinessLayer.Account Namespace


UserDiscountInfo Class

[image]

OfficeClip API Documentation
UserDiscountInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

The class for the user discount information

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class UserDiscountInfo : ISerializable
Visual Basic (Declaration)
Public Class UserDiscountInfo _
    Implements ISerializable
Visual C++
public ref class UserDiscountInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.UserDiscountInfo

See Also

UserDiscountInfo Members
OfficeClip.BusinessLayer.Account Namespace


UserDiscountInfo Members

[image] [image]

OfficeClip API Documentation
UserDiscountInfo Members
UserDiscountInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The UserDiscountInfo type exposes the following members.

Constructors

 | Name | Description
Public method | UserDiscountInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Get the object data
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NumUsers | Total number of users
Public property | Percent | Percentage discount

See Also

UserDiscountInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserDiscountInfo Constructor

[image] [image]

OfficeClip API Documentation
UserDiscountInfo Constructor
UserDiscountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | UserDiscountInfo()()() | Constructor for the user discount information
Public method | UserDiscountInfo(Int32, Double) | The constructor for the user discount information
Public method | UserDiscountInfo(SerializationInfo, StreamingContext) | Constructor for the user discount information

See Also

UserDiscountInfo Class
UserDiscountInfo Members
OfficeClip.BusinessLayer.Account Namespace


UserDiscountInfo Constructor

[image]

OfficeClip API Documentation
UserDiscountInfo Constructor
UserDiscountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for the user discount information

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserDiscountInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserDiscountInfo()

See Also

UserDiscountInfo Class
UserDiscountInfo Overload
OfficeClip.BusinessLayer.Account Namespace


UserDiscountInfo Constructor (Int32, Double)

[image]

OfficeClip API Documentation
UserDiscountInfo Constructor (Int32, Double)
UserDiscountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor for the user discount information

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserDiscountInfo(
    int numUsers,
    double percent
)
Visual Basic (Declaration)
Public Sub New ( _
    numUsers As Integer, _
    percent As Double _
)
Visual C++
public:
UserDiscountInfo(
    int numUsers,
    double percent
)

Parameters

numUsers
Type: System..::.Int32
The total number of the users
percent
Type: System..::.Double
The percentage

See Also

UserDiscountInfo Class
UserDiscountInfo Overload
OfficeClip.BusinessLayer.Account Namespace


UserDiscountInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
UserDiscountInfo Constructor (SerializationInfo, StreamingContext)
UserDiscountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for the user discount information

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserDiscountInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
UserDiscountInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The serialization information
context
Type: System.Runtime.Serialization..::.StreamingContext
The serialization context

See Also

UserDiscountInfo Class
UserDiscountInfo Overload
OfficeClip.BusinessLayer.Account Namespace


UserDiscountInfo Methods

[image] [image]

OfficeClip API Documentation
UserDiscountInfo Methods
UserDiscountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The UserDiscountInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Get the object data
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserDiscountInfo Class
OfficeClip.BusinessLayer.Account Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
UserDiscountInfo..::.GetObjectData Method
UserDiscountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Get the object data

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The serialization information
context
Type: System.Runtime.Serialization..::.StreamingContext
The serialization context

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

UserDiscountInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserDiscountInfo Properties

[image] [image]

OfficeClip API Documentation
UserDiscountInfo Properties
UserDiscountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The UserDiscountInfo type exposes the following properties.

Properties

 | Name | Description
Public property | NumUsers | Total number of users
Public property | Percent | Percentage discount

See Also

UserDiscountInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumUsers Property

[image]

OfficeClip API Documentation
UserDiscountInfo..::.NumUsers Property
UserDiscountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Total number of users

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumUsers { get; set; }
Visual Basic (Declaration)
Public Property NumUsers As Integer
Visual C++
public:
property int NumUsers {
    int get ();
    void set (int value);
}

See Also

UserDiscountInfo Class
OfficeClip.BusinessLayer.Account Namespace


Percent Property

[image]

OfficeClip API Documentation
UserDiscountInfo..::.Percent Property
UserDiscountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Percentage discount

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double Percent { get; set; }
Visual Basic (Declaration)
Public Property Percent As Double
Visual C++
public:
property double Percent {
    double get ();
    void set (double value);
}

See Also

UserDiscountInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserInfo Class

[image]

OfficeClip API Documentation
UserInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the user information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class UserInfo
Visual Basic (Declaration)
Public Class UserInfo
Visual C++
public ref class UserInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.UserInfo
OfficeClip.BusinessLayer.Sync..::.OCUserInfo

See Also

UserInfo Members
OfficeClip.BusinessLayer.Account Namespace


UserInfo Members

[image] [image]

OfficeClip API Documentation
UserInfo Members
UserInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The UserInfo type exposes the following members.

Constructors

 | Name | Description
Public method | UserInfo | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the information for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShowFullName | Show the full name of the user
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessRightsId | The access rights identifier of the user.
Public property | ActivationCode | The activation code of the user record.
Public property | Active | Shows if the user is active. Valid values are "Y" (active) and "N" (inactive).
Public property | BirthDate | The birth date of the user.
Public property | CellPhone | The mobile phone number of for the user.
Public property | CurrencyCode | The currency code
Public property | EmailAddress | The email Address of the user.
Public property | FaxNumber | The fax number of the user.
Public property | FirstName | The first name of the user.
Public property | FullName | The full name
Public property | FullNameWithEmail | Gets the full name with email
Public property | Gdf1Name | The first group defined field name.
Public property | Gdf1Value | The first group defined field value.
Public property | Gdf2Name | The second group defined field name.
Public property | Gdf2Value | The second group defined field value.
Public property | Gdf3Name | The third group defined field name.
Public property | Gdf3Value | The third group defined field value.
Public property | Gdf4Name | The fourth group defined field name.
Public property | Gdf4Value | The fourth group defined field value.
Public property | Gdf5Name | The fifth group defined field name.
Public property | Gdf5Value | The fifth group defined field value.
Public property | HomeAddress | The home Address of the user.
Public property | HomeAddressId | The home Address identifier of the user.
Public property | HomePage | The homepage for the user.
Public property | HomePhone | The home phone number of the user.
Public property | IsAdmin | Shows if the user is an administrator. This field is context sensitive. If the user information is collected wrt a group, it will be group admin. For account users, it will signify account administrator.
Public property | IsCodeActivated | Shows if the activation code is used by the invited user and the account is activated.
Public property | IsExtranetUser | Returns true if user is a Extranet User
Public property | LastName | The last name of the user.
Public property | LastUpdatedByUserId | The user identifier of the user who last updated the user record.
Public property | LastUpdatedTimestamp | The Timestamp of when the user record is last updated.
Public property | LdapAccountName | The ldap account name of the user.
Public property | Location | The Location for the user.
Public property | MobileEmailAddress | Gets the mobile email address
Public property | Notes | The Notes for the user.
Public property | Organization | The Organization for the user.
Public property | OtherPhone | The other phone number of the user.
Public property | Password | The encrypted user Password.
Public property | PreferredPhoneNumber | The preferred phone number of the user. The value is 1 for work1, 2 for work2, 3 for home, 4 for other and 5 for cell, the value is null if not set.
Public property | PreferredPhoneValue | The preferred phone value
Public property | ReadTermsCond | Shows whether the user has read the terms and conditions. Valid values are "Y" (read terms and conditions) and "N" (not read the terms and conditions).
Public property | ResetPassword | Shows whether the Password is reset. Valid values are "Y" (Password is reset) and "N" (the Password is not reset).
Public property | Udf1Name | The first user defined name of the user object.
Public property | Udf1Value | The first user defined field value of the user.
Public property | Udf2Name | The second user defined field name of the user.
Public property | Udf2Value | The value of the second user defined field for the user.
Public property | UserCreatedTimestamp | The Timestamp of the user record creation.
Public property | UserId | The system generated unique identifier for the user.
Public property | UserSmsInfo |
Public property | WorkAddress | The work Address of the user.
Public property | WorkAddressId | The work Address identifier of the user.
Public property | WorkPhonePrimary | The primary work phone of the user.
Public property | WorkPhoneSecondary | The secondary work phone of the user.
Public property | WorkTitle | The work Title of the user.

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserInfo Constructor

[image] [image]

OfficeClip API Documentation
UserInfo Constructor
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | UserInfo()()() | The default constructor.
Public method | UserInfo(UserInfo) | The copy constructor.

See Also

UserInfo Class
UserInfo Members
OfficeClip.BusinessLayer.Account Namespace


UserInfo Constructor

[image]

OfficeClip API Documentation
UserInfo Constructor
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserInfo()

See Also

UserInfo Class
UserInfo Overload
OfficeClip.BusinessLayer.Account Namespace


UserInfo Constructor (UserInfo)

[image]

OfficeClip API Documentation
UserInfo Constructor (UserInfo)
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The copy constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserInfo(
    UserInfo ui
)
Visual Basic (Declaration)
Public Sub New ( _
    ui As UserInfo _
)
Visual C++
public:
UserInfo(
    UserInfo^ ui
)

Parameters

ui
Type: OfficeClip.BusinessLayer.Account..::.UserInfo
The user information object.

See Also

UserInfo Class
UserInfo Overload
OfficeClip.BusinessLayer.Account Namespace


UserInfo Methods

[image] [image]

OfficeClip API Documentation
UserInfo Methods
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The UserInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the information for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShowFullName | Show the full name of the user
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Dump Method

[image]

OfficeClip API Documentation
UserInfo..::.Dump Method
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the information for debugging

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


ShowFullName Method

[image]

OfficeClip API Documentation
UserInfo..::.ShowFullName Method
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Show the full name of the user

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ShowFullName(
    SortByName sbn
)
Visual Basic (Declaration)
Public Function ShowFullName ( _
    sbn As SortByName _
) As String
Visual C++
public:
String^ ShowFullName(
    SortByName sbn
)

Parameters

sbn
Type: OfficeClip.Utils..::.SortByName
Determines the format of the name representation

Return Value

The full name

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserInfo Properties

[image] [image]

OfficeClip API Documentation
UserInfo Properties
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The UserInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccessRightsId | The access rights identifier of the user.
Public property | ActivationCode | The activation code of the user record.
Public property | Active | Shows if the user is active. Valid values are "Y" (active) and "N" (inactive).
Public property | BirthDate | The birth date of the user.
Public property | CellPhone | The mobile phone number of for the user.
Public property | CurrencyCode | The currency code
Public property | EmailAddress | The email Address of the user.
Public property | FaxNumber | The fax number of the user.
Public property | FirstName | The first name of the user.
Public property | FullName | The full name
Public property | FullNameWithEmail | Gets the full name with email
Public property | Gdf1Name | The first group defined field name.
Public property | Gdf1Value | The first group defined field value.
Public property | Gdf2Name | The second group defined field name.
Public property | Gdf2Value | The second group defined field value.
Public property | Gdf3Name | The third group defined field name.
Public property | Gdf3Value | The third group defined field value.
Public property | Gdf4Name | The fourth group defined field name.
Public property | Gdf4Value | The fourth group defined field value.
Public property | Gdf5Name | The fifth group defined field name.
Public property | Gdf5Value | The fifth group defined field value.
Public property | HomeAddress | The home Address of the user.
Public property | HomeAddressId | The home Address identifier of the user.
Public property | HomePage | The homepage for the user.
Public property | HomePhone | The home phone number of the user.
Public property | IsAdmin | Shows if the user is an administrator. This field is context sensitive. If the user information is collected wrt a group, it will be group admin. For account users, it will signify account administrator.
Public property | IsCodeActivated | Shows if the activation code is used by the invited user and the account is activated.
Public property | IsExtranetUser | Returns true if user is a Extranet User
Public property | LastName | The last name of the user.
Public property | LastUpdatedByUserId | The user identifier of the user who last updated the user record.
Public property | LastUpdatedTimestamp | The Timestamp of when the user record is last updated.
Public property | LdapAccountName | The ldap account name of the user.
Public property | Location | The Location for the user.
Public property | MobileEmailAddress | Gets the mobile email address
Public property | Notes | The Notes for the user.
Public property | Organization | The Organization for the user.
Public property | OtherPhone | The other phone number of the user.
Public property | Password | The encrypted user Password.
Public property | PreferredPhoneNumber | The preferred phone number of the user. The value is 1 for work1, 2 for work2, 3 for home, 4 for other and 5 for cell, the value is null if not set.
Public property | PreferredPhoneValue | The preferred phone value
Public property | ReadTermsCond | Shows whether the user has read the terms and conditions. Valid values are "Y" (read terms and conditions) and "N" (not read the terms and conditions).
Public property | ResetPassword | Shows whether the Password is reset. Valid values are "Y" (Password is reset) and "N" (the Password is not reset).
Public property | Udf1Name | The first user defined name of the user object.
Public property | Udf1Value | The first user defined field value of the user.
Public property | Udf2Name | The second user defined field name of the user.
Public property | Udf2Value | The value of the second user defined field for the user.
Public property | UserCreatedTimestamp | The Timestamp of the user record creation.
Public property | UserId | The system generated unique identifier for the user.
Public property | UserSmsInfo |
Public property | WorkAddress | The work Address of the user.
Public property | WorkAddressId | The work Address identifier of the user.
Public property | WorkPhonePrimary | The primary work phone of the user.
Public property | WorkPhoneSecondary | The secondary work phone of the user.
Public property | WorkTitle | The work Title of the user.

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


AccessRightsId Property

[image]

OfficeClip API Documentation
UserInfo..::.AccessRightsId Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The access rights identifier of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AccessRightsId { get; set; }
Visual Basic (Declaration)
Public Property AccessRightsId As Integer
Visual C++
public:
property int AccessRightsId {
    int get ();
    void set (int value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


ActivationCode Property

[image]

OfficeClip API Documentation
UserInfo..::.ActivationCode Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The activation code of the user record.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ActivationCode { get; set; }
Visual Basic (Declaration)
Public Property ActivationCode As String
Visual C++
public:
property String^ ActivationCode {
    String^ get ();
    void set (String^ value);
}

Remarks

The activation code is set when an user is invited. The activation code is sent to the user via email. The invited user should use the same activation code to activate OfficeClip account.

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Active Property

[image]

OfficeClip API Documentation
UserInfo..::.Active Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the user is active. Valid values are "Y" (active) and "N" (inactive).

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool Active { get; set; }
Visual Basic (Declaration)
Public Property Active As Boolean
Visual C++
public:
property bool Active {
    bool get ();
    void set (bool value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


BirthDate Property

[image]

OfficeClip API Documentation
UserInfo..::.BirthDate Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The birth date of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime BirthDate { get; set; }
Visual Basic (Declaration)
Public Property BirthDate As DateTime
Visual C++
public:
property DateTime BirthDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


CellPhone Property

[image]

OfficeClip API Documentation
UserInfo..::.CellPhone Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The mobile phone number of for the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CellPhone { get; set; }
Visual Basic (Declaration)
Public Property CellPhone As String
Visual C++
public:
property String^ CellPhone {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


CurrencyCode Property

[image]

OfficeClip API Documentation
UserInfo..::.CurrencyCode Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The currency code

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CurrencyCode { get; set; }
Visual Basic (Declaration)
Public Property CurrencyCode As String
Visual C++
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


EmailAddress Property

[image]

OfficeClip API Documentation
UserInfo..::.EmailAddress Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Address of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic (Declaration)
Public Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


FaxNumber Property

[image]

OfficeClip API Documentation
UserInfo..::.FaxNumber Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The fax number of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FaxNumber { get; set; }
Visual Basic (Declaration)
Public Property FaxNumber As String
Visual C++
public:
property String^ FaxNumber {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


FirstName Property

[image]

OfficeClip API Documentation
UserInfo..::.FirstName Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first name of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


FullName Property

[image]

OfficeClip API Documentation
UserInfo..::.FullName Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The full name

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FullName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullName As String
Visual C++
public:
property String^ FullName {
    String^ get ();
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


FullNameWithEmail Property

[image]

OfficeClip API Documentation
UserInfo..::.FullNameWithEmail Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the full name with email

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FullNameWithEmail { get; }
Visual Basic (Declaration)
Public ReadOnly Property FullNameWithEmail As String
Visual C++
public:
property String^ FullNameWithEmail {
    String^ get ();
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf1Name Property

[image]

OfficeClip API Documentation
UserInfo..::.Gdf1Name Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first group defined field name.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf1Name { get; set; }
Visual Basic (Declaration)
Public Property Gdf1Name As String
Visual C++
public:
property String^ Gdf1Name {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf1Value Property

[image]

OfficeClip API Documentation
UserInfo..::.Gdf1Value Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first group defined field value.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf1Value { get; set; }
Visual Basic (Declaration)
Public Property Gdf1Value As String
Visual C++
public:
property String^ Gdf1Value {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf2Name Property

[image]

OfficeClip API Documentation
UserInfo..::.Gdf2Name Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second group defined field name.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf2Name { get; set; }
Visual Basic (Declaration)
Public Property Gdf2Name As String
Visual C++
public:
property String^ Gdf2Name {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf2Value Property

[image]

OfficeClip API Documentation
UserInfo..::.Gdf2Value Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second group defined field value.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf2Value { get; set; }
Visual Basic (Declaration)
Public Property Gdf2Value As String
Visual C++
public:
property String^ Gdf2Value {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf3Name Property

[image]

OfficeClip API Documentation
UserInfo..::.Gdf3Name Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The third group defined field name.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf3Name { get; set; }
Visual Basic (Declaration)
Public Property Gdf3Name As String
Visual C++
public:
property String^ Gdf3Name {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf3Value Property

[image]

OfficeClip API Documentation
UserInfo..::.Gdf3Value Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The third group defined field value.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf3Value { get; set; }
Visual Basic (Declaration)
Public Property Gdf3Value As String
Visual C++
public:
property String^ Gdf3Value {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf4Name Property

[image]

OfficeClip API Documentation
UserInfo..::.Gdf4Name Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The fourth group defined field name.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf4Name { get; set; }
Visual Basic (Declaration)
Public Property Gdf4Name As String
Visual C++
public:
property String^ Gdf4Name {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf4Value Property

[image]

OfficeClip API Documentation
UserInfo..::.Gdf4Value Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The fourth group defined field value.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf4Value { get; set; }
Visual Basic (Declaration)
Public Property Gdf4Value As String
Visual C++
public:
property String^ Gdf4Value {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf5Name Property

[image]

OfficeClip API Documentation
UserInfo..::.Gdf5Name Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The fifth group defined field name.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf5Name { get; set; }
Visual Basic (Declaration)
Public Property Gdf5Name As String
Visual C++
public:
property String^ Gdf5Name {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Gdf5Value Property

[image]

OfficeClip API Documentation
UserInfo..::.Gdf5Value Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The fifth group defined field value.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Gdf5Value { get; set; }
Visual Basic (Declaration)
Public Property Gdf5Value As String
Visual C++
public:
property String^ Gdf5Value {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


HomeAddress Property

[image]

OfficeClip API Documentation
UserInfo..::.HomeAddress Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The home Address of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AddressInfo HomeAddress { get; set; }
Visual Basic (Declaration)
Public Property HomeAddress As AddressInfo
Visual C++
public:
property AddressInfo^ HomeAddress {
    AddressInfo^ get ();
    void set (AddressInfo^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


HomeAddressId Property

[image]

OfficeClip API Documentation
UserInfo..::.HomeAddressId Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The home Address identifier of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int HomeAddressId { get; set; }
Visual Basic (Declaration)
Public Property HomeAddressId As Integer
Visual C++
public:
property int HomeAddressId {
    int get ();
    void set (int value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


HomePage Property

[image]

OfficeClip API Documentation
UserInfo..::.HomePage Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The homepage for the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string HomePage { get; set; }
Visual Basic (Declaration)
Public Property HomePage As String
Visual C++
public:
property String^ HomePage {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


HomePhone Property

[image]

OfficeClip API Documentation
UserInfo..::.HomePhone Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The home phone number of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string HomePhone { get; set; }
Visual Basic (Declaration)
Public Property HomePhone As String
Visual C++
public:
property String^ HomePhone {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsAdmin Property

[image]

OfficeClip API Documentation
UserInfo..::.IsAdmin Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the user is an administrator. This field is context sensitive. If the user information is collected wrt a group, it will be group admin. For account users, it will signify account administrator.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAdmin { get; set; }
Visual Basic (Declaration)
Public Property IsAdmin As Boolean
Visual C++
public:
property bool IsAdmin {
    bool get ();
    void set (bool value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsCodeActivated Property

[image]

OfficeClip API Documentation
UserInfo..::.IsCodeActivated Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the activation code is used by the invited user and the account is activated.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsCodeActivated { get; set; }
Visual Basic (Declaration)
Public Property IsCodeActivated As Boolean
Visual C++
public:
property bool IsCodeActivated {
    bool get ();
    void set (bool value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsExtranetUser Property

[image]

OfficeClip API Documentation
UserInfo..::.IsExtranetUser Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns true if user is a Extranet User

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsExtranetUser { get; set; }
Visual Basic (Declaration)
Public Property IsExtranetUser As Boolean
Visual C++
public:
property bool IsExtranetUser {
    bool get ();
    void set (bool value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


LastName Property

[image]

OfficeClip API Documentation
UserInfo..::.LastName Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last name of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


LastUpdatedByUserId Property

[image]

OfficeClip API Documentation
UserInfo..::.LastUpdatedByUserId Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user identifier of the user who last updated the user record.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LastUpdatedByUserId { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedByUserId As Integer
Visual C++
public:
property int LastUpdatedByUserId {
    int get ();
    void set (int value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


LastUpdatedTimestamp Property

[image]

OfficeClip API Documentation
UserInfo..::.LastUpdatedTimestamp Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp of when the user record is last updated.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime LastUpdatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedTimestamp As DateTime
Visual C++
public:
property DateTime LastUpdatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


LdapAccountName Property

[image]

OfficeClip API Documentation
UserInfo..::.LdapAccountName Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ldap account name of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LdapAccountName { get; set; }
Visual Basic (Declaration)
Public Property LdapAccountName As String
Visual C++
public:
property String^ LdapAccountName {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Location Property

[image]

OfficeClip API Documentation
UserInfo..::.Location Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Location for the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


MobileEmailAddress Property

[image]

OfficeClip API Documentation
UserInfo..::.MobileEmailAddress Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the mobile email address

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string MobileEmailAddress { get; set; }
Visual Basic (Declaration)
Public Property MobileEmailAddress As String
Visual C++
public:
property String^ MobileEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Notes Property

[image]

OfficeClip API Documentation
UserInfo..::.Notes Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Notes for the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Organization Property

[image]

OfficeClip API Documentation
UserInfo..::.Organization Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Organization for the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Organization { get; set; }
Visual Basic (Declaration)
Public Property Organization As String
Visual C++
public:
property String^ Organization {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


OtherPhone Property

[image]

OfficeClip API Documentation
UserInfo..::.OtherPhone Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The other phone number of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string OtherPhone { get; set; }
Visual Basic (Declaration)
Public Property OtherPhone As String
Visual C++
public:
property String^ OtherPhone {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Password Property

[image]

OfficeClip API Documentation
UserInfo..::.Password Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The encrypted user Password.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


PreferredPhoneNumber Property

[image]

OfficeClip API Documentation
UserInfo..::.PreferredPhoneNumber Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The preferred phone number of the user. The value is 1 for work1, 2 for work2, 3 for home, 4 for other and 5 for cell, the value is null if not set.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int PreferredPhoneNumber { get; set; }
Visual Basic (Declaration)
Public Property PreferredPhoneNumber As Integer
Visual C++
public:
property int PreferredPhoneNumber {
    int get ();
    void set (int value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


PreferredPhoneValue Property

[image]

OfficeClip API Documentation
UserInfo..::.PreferredPhoneValue Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The preferred phone value

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PreferredPhoneValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreferredPhoneValue As String
Visual C++
public:
property String^ PreferredPhoneValue {
    String^ get ();
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


ReadTermsCond Property

[image]

OfficeClip API Documentation
UserInfo..::.ReadTermsCond Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the user has read the terms and conditions. Valid values are "Y" (read terms and conditions) and "N" (not read the terms and conditions).

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool ReadTermsCond { get; set; }
Visual Basic (Declaration)
Public Property ReadTermsCond As Boolean
Visual C++
public:
property bool ReadTermsCond {
    bool get ();
    void set (bool value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


ResetPassword Property

[image]

OfficeClip API Documentation
UserInfo..::.ResetPassword Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the Password is reset. Valid values are "Y" (Password is reset) and "N" (the Password is not reset).

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool ResetPassword { get; set; }
Visual Basic (Declaration)
Public Property ResetPassword As Boolean
Visual C++
public:
property bool ResetPassword {
    bool get ();
    void set (bool value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Udf1Name Property

[image]

OfficeClip API Documentation
UserInfo..::.Udf1Name Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first user defined name of the user object.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Udf1Name { get; set; }
Visual Basic (Declaration)
Public Property Udf1Name As String
Visual C++
public:
property String^ Udf1Name {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Udf1Value Property

[image]

OfficeClip API Documentation
UserInfo..::.Udf1Value Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first user defined field value of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Udf1Value { get; set; }
Visual Basic (Declaration)
Public Property Udf1Value As String
Visual C++
public:
property String^ Udf1Value {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Udf2Name Property

[image]

OfficeClip API Documentation
UserInfo..::.Udf2Name Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second user defined field name of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Udf2Name { get; set; }
Visual Basic (Declaration)
Public Property Udf2Name As String
Visual C++
public:
property String^ Udf2Name {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


Udf2Value Property

[image]

OfficeClip API Documentation
UserInfo..::.Udf2Value Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The value of the second user defined field for the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Udf2Value { get; set; }
Visual Basic (Declaration)
Public Property Udf2Value As String
Visual C++
public:
property String^ Udf2Value {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserCreatedTimestamp Property

[image]

OfficeClip API Documentation
UserInfo..::.UserCreatedTimestamp Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp of the user record creation.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime UserCreatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property UserCreatedTimestamp As DateTime
Visual C++
public:
property DateTime UserCreatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserId Property

[image]

OfficeClip API Documentation
UserInfo..::.UserId Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserSmsInfo Property

[image]

OfficeClip API Documentation
UserInfo..::.UserSmsInfo Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public SmsInfo UserSmsInfo { get; set; }
Visual Basic (Declaration)
Public Property UserSmsInfo As SmsInfo
Visual C++
public:
property SmsInfo^ UserSmsInfo {
    SmsInfo^ get ();
    void set (SmsInfo^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


WorkAddress Property

[image]

OfficeClip API Documentation
UserInfo..::.WorkAddress Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The work Address of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AddressInfo WorkAddress { get; set; }
Visual Basic (Declaration)
Public Property WorkAddress As AddressInfo
Visual C++
public:
property AddressInfo^ WorkAddress {
    AddressInfo^ get ();
    void set (AddressInfo^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


WorkAddressId Property

[image]

OfficeClip API Documentation
UserInfo..::.WorkAddressId Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The work Address identifier of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int WorkAddressId { get; set; }
Visual Basic (Declaration)
Public Property WorkAddressId As Integer
Visual C++
public:
property int WorkAddressId {
    int get ();
    void set (int value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


WorkPhonePrimary Property

[image]

OfficeClip API Documentation
UserInfo..::.WorkPhonePrimary Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The primary work phone of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string WorkPhonePrimary { get; set; }
Visual Basic (Declaration)
Public Property WorkPhonePrimary As String
Visual C++
public:
property String^ WorkPhonePrimary {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


WorkPhoneSecondary Property

[image]

OfficeClip API Documentation
UserInfo..::.WorkPhoneSecondary Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The secondary work phone of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string WorkPhoneSecondary { get; set; }
Visual Basic (Declaration)
Public Property WorkPhoneSecondary As String
Visual C++
public:
property String^ WorkPhoneSecondary {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


WorkTitle Property

[image]

OfficeClip API Documentation
UserInfo..::.WorkTitle Property
UserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The work Title of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string WorkTitle { get; set; }
Visual Basic (Declaration)
Public Property WorkTitle As String
Visual C++
public:
property String^ WorkTitle {
    String^ get ();
    void set (String^ value);
}

See Also

UserInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserLoginInfo Class

[image]

OfficeClip API Documentation
UserLoginInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the user login information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class UserLoginInfo
Visual Basic (Declaration)
Public Class UserLoginInfo
Visual C++
public ref class UserLoginInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.UserLoginInfo

See Also

UserLoginInfo Members
OfficeClip.BusinessLayer.Account Namespace


UserLoginInfo Members

[image] [image]

OfficeClip API Documentation
UserLoginInfo Members
UserLoginInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The UserLoginInfo type exposes the following members.

Constructors

 | Name | Description
Public method | UserLoginInfo | The default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActivationCode | The activation code for the user.
Public property | Active | Shows whether the user is active. Valid values are "Y" (active) and "N" (not active)
Public property | EmailAddress | The email Address of the user.
Public property | FirstName | The first name of the user.
Public property | IsCodeActivated | Shows whether the user has activated the code.
Public property | IsReadTermsAndCondition | Is the terms and condition read
Public property | IsResetPassword | Shows if the Password is reset for the user recoed.
Public property | LastName | The last name of the user.
Public property | LastUpdatedByUserId | the user identifier of the user who last updated this user login information.
Public property | LastUpdatedTimestamp | The Timestamp of the last Update of this user login information.
Public property | NumberOfUserGroups | the number of users in the group.
Public property | Password | The encrypted Password for the user.
Public property | ReadTermsCond | Shows whether the user has read the terms and conditions.
Public property | ResetPassword | Shows whether the Password is reset for the user.
Public property | UserCreatedTimestamp | The Timestamp of the createion time of this user login information.
Public property | UserId | The identifier of the user.

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserLoginInfo Constructor

[image]

OfficeClip API Documentation
UserLoginInfo Constructor
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserLoginInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserLoginInfo()

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserLoginInfo Properties

[image] [image]

OfficeClip API Documentation
UserLoginInfo Properties
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The UserLoginInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ActivationCode | The activation code for the user.
Public property | Active | Shows whether the user is active. Valid values are "Y" (active) and "N" (not active)
Public property | EmailAddress | The email Address of the user.
Public property | FirstName | The first name of the user.
Public property | IsCodeActivated | Shows whether the user has activated the code.
Public property | IsReadTermsAndCondition | Is the terms and condition read
Public property | IsResetPassword | Shows if the Password is reset for the user recoed.
Public property | LastName | The last name of the user.
Public property | LastUpdatedByUserId | the user identifier of the user who last updated this user login information.
Public property | LastUpdatedTimestamp | The Timestamp of the last Update of this user login information.
Public property | NumberOfUserGroups | the number of users in the group.
Public property | Password | The encrypted Password for the user.
Public property | ReadTermsCond | Shows whether the user has read the terms and conditions.
Public property | ResetPassword | Shows whether the Password is reset for the user.
Public property | UserCreatedTimestamp | The Timestamp of the createion time of this user login information.
Public property | UserId | The identifier of the user.

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


ActivationCode Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.ActivationCode Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The activation code for the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ActivationCode { get; set; }
Visual Basic (Declaration)
Public Property ActivationCode As String
Visual C++
public:
property String^ ActivationCode {
    String^ get ();
    void set (String^ value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


Active Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.Active Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the user is active. Valid values are "Y" (active) and "N" (not active)

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Active { get; set; }
Visual Basic (Declaration)
Public Property Active As String
Visual C++
public:
property String^ Active {
    String^ get ();
    void set (String^ value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


EmailAddress Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.EmailAddress Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Address of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic (Declaration)
Public Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


FirstName Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.FirstName Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first name of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsCodeActivated Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.IsCodeActivated Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the user has activated the code.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsCodeActivated { get; set; }
Visual Basic (Declaration)
Public Property IsCodeActivated As Boolean
Visual C++
public:
property bool IsCodeActivated {
    bool get ();
    void set (bool value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsReadTermsAndCondition Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.IsReadTermsAndCondition Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

Is the terms and condition read

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsReadTermsAndCondition { get; set; }
Visual Basic (Declaration)
Public Property IsReadTermsAndCondition As Boolean
Visual C++
public:
property bool IsReadTermsAndCondition {
    bool get ();
    void set (bool value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


IsResetPassword Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.IsResetPassword Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the Password is reset for the user recoed.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsResetPassword { get; set; }
Visual Basic (Declaration)
Public Property IsResetPassword As Boolean
Visual C++
public:
property bool IsResetPassword {
    bool get ();
    void set (bool value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


LastName Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.LastName Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last name of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


LastUpdatedByUserId Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.LastUpdatedByUserId Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

the user identifier of the user who last updated this user login information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LastUpdatedByUserId { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedByUserId As Integer
Visual C++
public:
property int LastUpdatedByUserId {
    int get ();
    void set (int value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


LastUpdatedTimestamp Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.LastUpdatedTimestamp Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp of the last Update of this user login information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime LastUpdatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedTimestamp As DateTime
Visual C++
public:
property DateTime LastUpdatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


NumberOfUserGroups Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.NumberOfUserGroups Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

the number of users in the group.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumberOfUserGroups { get; set; }
Visual Basic (Declaration)
Public Property NumberOfUserGroups As Integer
Visual C++
public:
property int NumberOfUserGroups {
    int get ();
    void set (int value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


Password Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.Password Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The encrypted Password for the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


ReadTermsCond Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.ReadTermsCond Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the user has read the terms and conditions.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool ReadTermsCond { get; set; }
Visual Basic (Declaration)
Public Property ReadTermsCond As Boolean
Visual C++
public:
property bool ReadTermsCond {
    bool get ();
    void set (bool value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


ResetPassword Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.ResetPassword Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the Password is reset for the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool ResetPassword { get; set; }
Visual Basic (Declaration)
Public Property ResetPassword As Boolean
Visual C++
public:
property bool ResetPassword {
    bool get ();
    void set (bool value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserCreatedTimestamp Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.UserCreatedTimestamp Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp of the createion time of this user login information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime UserCreatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property UserCreatedTimestamp As DateTime
Visual C++
public:
property DateTime UserCreatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserId Property

[image]

OfficeClip API Documentation
UserLoginInfo..::.UserId Property
UserLoginInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier of the user.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

UserLoginInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserPayrollInfo Class

[image]

OfficeClip API Documentation
UserPayrollInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the user information.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class UserPayrollInfo
Visual Basic (Declaration)
Public Class UserPayrollInfo
Visual C++
public ref class UserPayrollInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.UserPayrollInfo

See Also

UserPayrollInfo Members
OfficeClip.BusinessLayer.Account Namespace


UserPayrollInfo Members

[image] [image]

OfficeClip API Documentation
UserPayrollInfo Members
UserPayrollInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The UserPayrollInfo type exposes the following members.

Constructors

 | Name | Description
Public method | UserPayrollInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EmployeeId | The unique id of the employee
Public property | Field1 | The user-defined field 1
Public property | Field2 | The user-defined field 2
Public property | Field3 | The user-defined field 3
Public property | Field4 | The user-defined field 4
Public property | Field5 | The user-defined field 5
Public property | JoiningDate | The joining date of the member
Public property | LeavingDate | The date when the member leaves the organization
Public property | PayrollNotes | The payroll notes
Public property | PayrollStartDate | The start date of the payroll. This date should match the date from when the member starts entering the timesheet. This is required to make sure that the biweekly timesheets begin with the correct week.
Public property | TimesheetPeriod | The Timesheet period

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


UserPayrollInfo Constructor

[image] [image]

OfficeClip API Documentation
UserPayrollInfo Constructor
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | UserPayrollInfo()()() | The default constructor
Public method | UserPayrollInfo(String, BusinessConstants..::.TimesheetPeriod, DateTime, DateTime, DateTime, String, String, String, String, String, String) | Constuctor to create a user payroll object

See Also

UserPayrollInfo Class
UserPayrollInfo Members
OfficeClip.BusinessLayer.Account Namespace


UserPayrollInfo Constructor

[image]

OfficeClip API Documentation
UserPayrollInfo Constructor
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserPayrollInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserPayrollInfo()

See Also

UserPayrollInfo Class
UserPayrollInfo Overload
OfficeClip.BusinessLayer.Account Namespace


UserPayrollInfo Constructor (String, BusinessConstants.TimesheetPeriod, DateTime, DateTime, DateTime, String, String, String, String, String, String)

[image]

OfficeClip API Documentation
UserPayrollInfo Constructor (String, BusinessConstants..::.TimesheetPeriod, DateTime, DateTime, DateTime, String, String, String, String, String, String)
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constuctor to create a user payroll object

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserPayrollInfo(
    string employeeId,
    BusinessConstants..::.TimesheetPeriod timesheetPeriod,
    DateTime payrollStartDate,
    DateTime joiningDate,
    DateTime leavingDate,
    string payrollNotes,
    string field1,
    string field2,
    string field3,
    string field4,
    string field5
)
Visual Basic (Declaration)
Public Sub New ( _
    employeeId As String, _
    timesheetPeriod As BusinessConstants..::.TimesheetPeriod, _
    payrollStartDate As DateTime, _
    joiningDate As DateTime, _
    leavingDate As DateTime, _
    payrollNotes As String, _
    field1 As String, _
    field2 As String, _
    field3 As String, _
    field4 As String, _
    field5 As String _
)
Visual C++
public:
UserPayrollInfo(
    String^ employeeId,
    BusinessConstants..::.TimesheetPeriod timesheetPeriod,
    DateTime payrollStartDate,
    DateTime joiningDate,
    DateTime leavingDate,
    String^ payrollNotes,
    String^ field1,
    String^ field2,
    String^ field3,
    String^ field4,
    String^ field5
)

Parameters

employeeId
Type: System..::.String
The unique id of the employee
timesheetPeriod
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TimesheetPeriod
The timesheet period
payrollStartDate
Type: System..::.DateTime
The start date of the payroll. This date should match the date from when the member starts entering the timesheet. This is required to make sure that the biweekly timesheets begin with the correct week.
joiningDate
Type: System..::.DateTime
The joining date of the member
leavingDate
Type: System..::.DateTime
The leaving date of the member
payrollNotes
Type: System..::.String
The payroll notes
field1
Type: System..::.String
The user-defined field 1
field2
Type: System..::.String
The user-defined field 2
field3
Type: System..::.String
The user-defined field 3
field4
Type: System..::.String
The user-defined field 4
field5
Type: System..::.String
The user-defined field 5

See Also

UserPayrollInfo Class
UserPayrollInfo Overload
OfficeClip.BusinessLayer.Account Namespace


UserPayrollInfo Properties

[image] [image]

OfficeClip API Documentation
UserPayrollInfo Properties
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The UserPayrollInfo type exposes the following properties.

Properties

 | Name | Description
Public property | EmployeeId | The unique id of the employee
Public property | Field1 | The user-defined field 1
Public property | Field2 | The user-defined field 2
Public property | Field3 | The user-defined field 3
Public property | Field4 | The user-defined field 4
Public property | Field5 | The user-defined field 5
Public property | JoiningDate | The joining date of the member
Public property | LeavingDate | The date when the member leaves the organization
Public property | PayrollNotes | The payroll notes
Public property | PayrollStartDate | The start date of the payroll. This date should match the date from when the member starts entering the timesheet. This is required to make sure that the biweekly timesheets begin with the correct week.
Public property | TimesheetPeriod | The Timesheet period

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


EmployeeId Property

[image]

OfficeClip API Documentation
UserPayrollInfo..::.EmployeeId Property
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the employee

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmployeeId { get; set; }
Visual Basic (Declaration)
Public Property EmployeeId As String
Visual C++
public:
property String^ EmployeeId {
    String^ get ();
    void set (String^ value);
}

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


Field1 Property

[image]

OfficeClip API Documentation
UserPayrollInfo..::.Field1 Property
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user-defined field 1

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Field1 { get; set; }
Visual Basic (Declaration)
Public Property Field1 As String
Visual C++
public:
property String^ Field1 {
    String^ get ();
    void set (String^ value);
}

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


Field2 Property

[image]

OfficeClip API Documentation
UserPayrollInfo..::.Field2 Property
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user-defined field 2

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Field2 { get; set; }
Visual Basic (Declaration)
Public Property Field2 As String
Visual C++
public:
property String^ Field2 {
    String^ get ();
    void set (String^ value);
}

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


Field3 Property

[image]

OfficeClip API Documentation
UserPayrollInfo..::.Field3 Property
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user-defined field 3

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Field3 { get; set; }
Visual Basic (Declaration)
Public Property Field3 As String
Visual C++
public:
property String^ Field3 {
    String^ get ();
    void set (String^ value);
}

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


Field4 Property

[image]

OfficeClip API Documentation
UserPayrollInfo..::.Field4 Property
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user-defined field 4

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Field4 { get; set; }
Visual Basic (Declaration)
Public Property Field4 As String
Visual C++
public:
property String^ Field4 {
    String^ get ();
    void set (String^ value);
}

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


Field5 Property

[image]

OfficeClip API Documentation
UserPayrollInfo..::.Field5 Property
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user-defined field 5

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Field5 { get; set; }
Visual Basic (Declaration)
Public Property Field5 As String
Visual C++
public:
property String^ Field5 {
    String^ get ();
    void set (String^ value);
}

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


JoiningDate Property

[image]

OfficeClip API Documentation
UserPayrollInfo..::.JoiningDate Property
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The joining date of the member

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime JoiningDate { get; set; }
Visual Basic (Declaration)
Public Property JoiningDate As DateTime
Visual C++
public:
property DateTime JoiningDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


LeavingDate Property

[image]

OfficeClip API Documentation
UserPayrollInfo..::.LeavingDate Property
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date when the member leaves the organization

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime LeavingDate { get; set; }
Visual Basic (Declaration)
Public Property LeavingDate As DateTime
Visual C++
public:
property DateTime LeavingDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


PayrollNotes Property

[image]

OfficeClip API Documentation
UserPayrollInfo..::.PayrollNotes Property
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The payroll notes

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PayrollNotes { get; set; }
Visual Basic (Declaration)
Public Property PayrollNotes As String
Visual C++
public:
property String^ PayrollNotes {
    String^ get ();
    void set (String^ value);
}

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


PayrollStartDate Property

[image]

OfficeClip API Documentation
UserPayrollInfo..::.PayrollStartDate Property
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The start date of the payroll. This date should match the date from when the member starts entering the timesheet. This is required to make sure that the biweekly timesheets begin with the correct week.

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime PayrollStartDate { get; set; }
Visual Basic (Declaration)
Public Property PayrollStartDate As DateTime
Visual C++
public:
property DateTime PayrollStartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


TimesheetPeriod Property

[image]

OfficeClip API Documentation
UserPayrollInfo..::.TimesheetPeriod Property
UserPayrollInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timesheet period

Namespace: OfficeClip.BusinessLayer.Account
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants..::.TimesheetPeriod TimesheetPeriod { get; set; }
Visual Basic (Declaration)
Public Property TimesheetPeriod As BusinessConstants..::.TimesheetPeriod
Visual C++
public:
property BusinessConstants..::.TimesheetPeriod TimesheetPeriod {
    BusinessConstants..::.TimesheetPeriod get ();
    void set (BusinessConstants..::.TimesheetPeriod value);
}

See Also

UserPayrollInfo Class
OfficeClip.BusinessLayer.Account Namespace


OfficeClip.BusinessLayer.Desktop Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Desktop Namespace

[This is preliminary documentation and is subject to change.]

Contains the business layer for all desktop applications, this includes, calendar, tasks, email, members etc.

Classes

 | Class | Description
Public class | DocumentInfo | Class to hold the document information.
Public class | DocumentStatus | Class to hold the document information.
Public class | DocumentStorageInfo | Provides access to the document storage information object used for accounting.
Public class | EventInfo | Provides methods and properties for the calendar event information.
Public class | EventQueryString | Class to represent query string for the event
Public class | FolderInfo | Provides methods and properties to access the document folder information.
Public class | MeetingAttendeeInfo | Provides methods and properties to access the information related to the meeting attendies.
Public class | RecurrenceInfo | Provides methods and properties to access the recurring information for an event or reminders.
Public class | ResourceInfo | provides methods and properties to access the resource information.
Public class | TaskInfo | Provides methods to interact with the Task Information Object.

Enumerations

 | Enumeration | Description
Public enumeration | DocumentStatus..::.DeleteFolderStatus | Defines the different possible return statuses while attempting to Delete a folder.
Public enumeration | DocumentStatus..::.DocumentDeleteStatus | Defines the different possible return statuses while attempting to Delete a document.
Public enumeration | DocumentStatus..::.DocumentPreInsertStatus | Defines the different possible return statuses while attempting to Insert a document.
Public enumeration | DocumentStatus..::.RenameDocumentStatus | Defines the different possible return statuses while attempting to rename a document.
Public enumeration | DocumentStatus..::.UpdateDocumentStatus | Defines the different possible return statuses while attempting to update a document.


DocumentInfo Class

[image]

OfficeClip API Documentation
DocumentInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to hold the document information.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class DocumentInfo
Visual Basic (Declaration)
Public Class DocumentInfo
Visual C++
public ref class DocumentInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop..::.DocumentInfo

See Also

DocumentInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


DocumentInfo Members

[image] [image]

OfficeClip API Documentation
DocumentInfo Members
DocumentInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The DocumentInfo type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Active | Shows if the document is Active. Returns "Y" or "N".
Public property | ApplicationId | The application id for the application that created the document. This is meaningful if the document is created by an application.
Public property | ApplicationSecondaryId | The secondary id of an application. This is meaningful if the document is created by an application.
Public property | AppsDescription | The Description of the document. This is meaningful if the document is created by an application.
Public property | CreatedByUserId | The unique id of the user who created the document.
Public property | CreatedByUserName | Returns the name of the user who created the document.
Public property | CreatedDate | The created date of the document.
Public property | DocumentDescription | Tthe Description of the document.
Public property | DocumentDirectory | The directory path of the document.
Public property | DocumentId | The system generated unique document id.
Public property | DocumentKeyword | The keywords for the documents.
Public property | DocumentName | The name of the document.
Public property | DocumentPath | The complete path of the document file.
Public property | FileSize | The file size of the document (in KB).
Public property | GroupId | The system generated unique id of the group that contains the document.
Public property | id1 | The first id for the document.
Public property | id2 | The second id for the document.
Public property | IsLocked | Shows if the document is locked.
Public property | IsShared | Shows if this document is shared with some user.
Public property | LockedByUserId | The user id of the user who locked the document. This is only meaningful if the document is locked.
Public property | LockedByUserName | The name of the user who locked the document.
Public property | ModifiedByUserId | The unique id of the user who last modified the document.
Public property | ModifiedByUserName | The name of the user who last modified the document.
Public property | ModifiedDate | The last modified date of the document.
Public property | ParentFolderId | The unique id of the Parent folder of the document. Returns null if there is no Parent folder for the document.
Public property | ParentFolderName | The folder name of the Parent folder of the document. This is meaningful only if the document has a Parent folder.
Public property | Rev | The revision of the document.
Public property | SharedByUserId | The user id of the user who shared the document. This is meaningful if the document is shared.
Public property | SharedByUserName | The name of the user who shared the document. This is meaningful only if the document is shared.
Public property | VirtualPath | The name of the virtual path.

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentInfo Constructor

[image] [image]

OfficeClip API Documentation
DocumentInfo Constructor
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | DocumentInfo(Int32, String, String, String, String, Int32, String, Int32, String, Int32, String, DateTime, DateTime, Int32, Int32, String, String, String, String, String, Double, Int32) | The constructor of the document information.
Public method | DocumentInfo(Int32, String, String, String, String, Int32, String, Int32, String, Int32, String, DateTime, DateTime, Int32, Int32, String, String, String, String, String, Double, Int32, Int32, Int32, Int32, Int32, Int32) | The constructor of the document information.

See Also

DocumentInfo Class
DocumentInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


DocumentInfo Constructor (Int32, String, String, String, String, Int32, String, Int32, String, Int32, String, DateTime, DateTime, Int32, Int32, String, String, String, String, String, Double, Int32)

[image]

OfficeClip API Documentation
DocumentInfo Constructor (Int32, String, String, String, String, Int32, String, Int32, String, Int32, String, DateTime, DateTime, Int32, Int32, String, String, String, String, String, Double, Int32)
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor of the document information.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentInfo(
    int documentId,
    string documentName,
    string virtualPath,
    string documentPath,
    string active,
    int lockedByUserId,
    string lockedByUserName,
    int sharedByUserId,
    string sharedByUserName,
    int createdByUserId,
    string createdByUserName,
    DateTime createdDate,
    DateTime modifiedDate,
    int parentFolderId,
    int modifiedByUserId,
    string modifiedByUserName,
    string parentFolderName,
    string documentDescription,
    string documentKeyword,
    string appsDescription,
    double fileSize,
    int rev
)
Visual Basic (Declaration)
Public Sub New ( _
    documentId As Integer, _
    documentName As String, _
    virtualPath As String, _
    documentPath As String, _
    active As String, _
    lockedByUserId As Integer, _
    lockedByUserName As String, _
    sharedByUserId As Integer, _
    sharedByUserName As String, _
    createdByUserId As Integer, _
    createdByUserName As String, _
    createdDate As DateTime, _
    modifiedDate As DateTime, _
    parentFolderId As Integer, _
    modifiedByUserId As Integer, _
    modifiedByUserName As String, _
    parentFolderName As String, _
    documentDescription As String, _
    documentKeyword As String, _
    appsDescription As String, _
    fileSize As Double, _
    rev As Integer _
)
Visual C++
public:
DocumentInfo(
    int documentId,
    String^ documentName,
    String^ virtualPath,
    String^ documentPath,
    String^ active,
    int lockedByUserId,
    String^ lockedByUserName,
    int sharedByUserId,
    String^ sharedByUserName,
    int createdByUserId,
    String^ createdByUserName,
    DateTime createdDate,
    DateTime modifiedDate,
    int parentFolderId,
    int modifiedByUserId,
    String^ modifiedByUserName,
    String^ parentFolderName,
    String^ documentDescription,
    String^ documentKeyword,
    String^ appsDescription,
    double fileSize,
    int rev
)

Parameters

documentId
Type: System..::.Int32
The system generated unique document id.
documentName
Type: System..::.String
The name of the document.
virtualPath
Type: System..::.String
The virtual path name.
documentPath
Type: System..::.String
Full real path name of the document.
active
Type: System..::.String
Shows if the document is Active.
lockedByUserId
Type: System..::.Int32
The user id of the user who locked this document.
lockedByUserName
Type: System..::.String
The user name of the user who locked this document.
sharedByUserId
Type: System..::.Int32
the user id of the user who has shared this document with somebody else
sharedByUserName
Type: System..::.String
The user name of the user who has shared the document with someone else.
createdByUserId
Type: System..::.Int32
The user id of the user who created the document.
createdByUserName
Type: System..::.String
The user name of the user who created the document.
createdDate
Type: System..::.DateTime
The created date of the document.
modifiedDate
Type: System..::.DateTime
The date when the document the document was last modified.
parentFolderId
Type: System..::.Int32
The id of the Parent folder for this document.
modifiedByUserId
Type: System..::.Int32
The user id of the user who modified the document last time.
modifiedByUserName
Type: System..::.String
The user name of the user who modified the document the last time.
parentFolderName
Type: System..::.String
The name of the Parent folder of this document.
documentDescription
Type: System..::.String
the Description that is associated with this document.
documentKeyword
Type: System..::.String
the keyword that is associated with this document.
appsDescription
Type: System..::.String
The Description of the document if this document is an application document, i.e. it is created by an application.
fileSize
Type: System..::.Double
The file size (in KB) for the document.
rev
Type: System..::.Int32
The revision of the document

See Also

DocumentInfo Class
DocumentInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


DocumentInfo Constructor (Int32, String, String, String, String, Int32, String, Int32, String, Int32, String, DateTime, DateTime, Int32, Int32, String, String, String, String, String, Double, Int32, Int32, Int32, Int32, Int32, Int32)

[image]

OfficeClip API Documentation
DocumentInfo Constructor (Int32, String, String, String, String, Int32, String, Int32, String, Int32, String, DateTime, DateTime, Int32, Int32, String, String, String, String, String, Double, Int32, Int32, Int32, Int32, Int32, Int32)
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor of the document information.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentInfo(
    int documentId,
    string documentName,
    string virtualPath,
    string documentPath,
    string active,
    int lockedByUserId,
    string lockedByUserName,
    int sharedByUserId,
    string sharedByUserName,
    int createdByUserId,
    string createdByUserName,
    DateTime createdDate,
    DateTime modifiedDate,
    int parentFolderId,
    int modifiedByUserId,
    string modifiedByUserName,
    string parentFolderName,
    string documentDescription,
    string documentKeyword,
    string appsDescription,
    double fileSize,
    int applicationId,
    int applicationSecondaryId,
    int id1,
    int id2,
    int groupId,
    int rev
)
Visual Basic (Declaration)
Public Sub New ( _
    documentId As Integer, _
    documentName As String, _
    virtualPath As String, _
    documentPath As String, _
    active As String, _
    lockedByUserId As Integer, _
    lockedByUserName As String, _
    sharedByUserId As Integer, _
    sharedByUserName As String, _
    createdByUserId As Integer, _
    createdByUserName As String, _
    createdDate As DateTime, _
    modifiedDate As DateTime, _
    parentFolderId As Integer, _
    modifiedByUserId As Integer, _
    modifiedByUserName As String, _
    parentFolderName As String, _
    documentDescription As String, _
    documentKeyword As String, _
    appsDescription As String, _
    fileSize As Double, _
    applicationId As Integer, _
    applicationSecondaryId As Integer, _
    id1 As Integer, _
    id2 As Integer, _
    groupId As Integer, _
    rev As Integer _
)
Visual C++
public:
DocumentInfo(
    int documentId,
    String^ documentName,
    String^ virtualPath,
    String^ documentPath,
    String^ active,
    int lockedByUserId,
    String^ lockedByUserName,
    int sharedByUserId,
    String^ sharedByUserName,
    int createdByUserId,
    String^ createdByUserName,
    DateTime createdDate,
    DateTime modifiedDate,
    int parentFolderId,
    int modifiedByUserId,
    String^ modifiedByUserName,
    String^ parentFolderName,
    String^ documentDescription,
    String^ documentKeyword,
    String^ appsDescription,
    double fileSize,
    int applicationId,
    int applicationSecondaryId,
    int id1,
    int id2,
    int groupId,
    int rev
)

Parameters

documentId
Type: System..::.Int32
The system generated unique document id.
documentName
Type: System..::.String
The name of the document.
virtualPath
Type: System..::.String
The virtual path name.
documentPath
Type: System..::.String
Full path name of the document.
active
Type: System..::.String
Shows if the document is Active.
lockedByUserId
Type: System..::.Int32
The user id of the user who locked this document.
lockedByUserName
Type: System..::.String
The user name of the user who locked this document.
sharedByUserId
Type: System..::.Int32
the user id of the user who has shared this document with somebody else
sharedByUserName
Type: System..::.String
The user name of the user who has shared the document with someone else.
createdByUserId
Type: System..::.Int32
The user id of the user who created the document.
createdByUserName
Type: System..::.String
The user name of the user who created the document.
createdDate
Type: System..::.DateTime
The created date of the document.
modifiedDate
Type: System..::.DateTime
The date when the document the document was last modified.
parentFolderId
Type: System..::.Int32
The id of the Parent folder for this document.
modifiedByUserId
Type: System..::.Int32
The user id of the user who modified the document last time.
modifiedByUserName
Type: System..::.String
The user name of the user who modified the document the last time.
parentFolderName
Type: System..::.String
The name of the Parent folder of this document.
documentDescription
Type: System..::.String
the Description that is associated with this document.
documentKeyword
Type: System..::.String
the keyword that is associated with this document.
appsDescription
Type: System..::.String
The Description of the document if this document is an application document, i.e. it is created by an application.
fileSize
Type: System..::.Double
The file size (in KB) for the document.
applicationId
Type: System..::.Int32
The id of the application that created the document.
applicationSecondaryId
Type: System..::.Int32
The secondary id of the application that created the document.
id1
Type: System..::.Int32
The user defined id number 1
id2
Type: System..::.Int32
The user defined id number 2
groupId
Type: System..::.Int32
The group id of the group to which this document belongs to.
rev
Type: System..::.Int32
The revision of the document.

See Also

DocumentInfo Class
DocumentInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


DocumentInfo Properties

[image] [image]

OfficeClip API Documentation
DocumentInfo Properties
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The DocumentInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Active | Shows if the document is Active. Returns "Y" or "N".
Public property | ApplicationId | The application id for the application that created the document. This is meaningful if the document is created by an application.
Public property | ApplicationSecondaryId | The secondary id of an application. This is meaningful if the document is created by an application.
Public property | AppsDescription | The Description of the document. This is meaningful if the document is created by an application.
Public property | CreatedByUserId | The unique id of the user who created the document.
Public property | CreatedByUserName | Returns the name of the user who created the document.
Public property | CreatedDate | The created date of the document.
Public property | DocumentDescription | Tthe Description of the document.
Public property | DocumentDirectory | The directory path of the document.
Public property | DocumentId | The system generated unique document id.
Public property | DocumentKeyword | The keywords for the documents.
Public property | DocumentName | The name of the document.
Public property | DocumentPath | The complete path of the document file.
Public property | FileSize | The file size of the document (in KB).
Public property | GroupId | The system generated unique id of the group that contains the document.
Public property | id1 | The first id for the document.
Public property | id2 | The second id for the document.
Public property | IsLocked | Shows if the document is locked.
Public property | IsShared | Shows if this document is shared with some user.
Public property | LockedByUserId | The user id of the user who locked the document. This is only meaningful if the document is locked.
Public property | LockedByUserName | The name of the user who locked the document.
Public property | ModifiedByUserId | The unique id of the user who last modified the document.
Public property | ModifiedByUserName | The name of the user who last modified the document.
Public property | ModifiedDate | The last modified date of the document.
Public property | ParentFolderId | The unique id of the Parent folder of the document. Returns null if there is no Parent folder for the document.
Public property | ParentFolderName | The folder name of the Parent folder of the document. This is meaningful only if the document has a Parent folder.
Public property | Rev | The revision of the document.
Public property | SharedByUserId | The user id of the user who shared the document. This is meaningful if the document is shared.
Public property | SharedByUserName | The name of the user who shared the document. This is meaningful only if the document is shared.
Public property | VirtualPath | The name of the virtual path.

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Active Property

[image]

OfficeClip API Documentation
DocumentInfo..::.Active Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the document is Active. Returns "Y" or "N".

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Active { get; }
Visual Basic (Declaration)
Public ReadOnly Property Active As String
Visual C++
public:
property String^ Active {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ApplicationId Property

[image]

OfficeClip API Documentation
DocumentInfo..::.ApplicationId Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The application id for the application that created the document. This is meaningful if the document is created by an application.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ApplicationId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationId As Integer
Visual C++
public:
property int ApplicationId {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ApplicationSecondaryId Property

[image]

OfficeClip API Documentation
DocumentInfo..::.ApplicationSecondaryId Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The secondary id of an application. This is meaningful if the document is created by an application.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ApplicationSecondaryId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationSecondaryId As Integer
Visual C++
public:
property int ApplicationSecondaryId {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


AppsDescription Property

[image]

OfficeClip API Documentation
DocumentInfo..::.AppsDescription Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Description of the document. This is meaningful if the document is created by an application.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AppsDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppsDescription As String
Visual C++
public:
property String^ AppsDescription {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


CreatedByUserId Property

[image]

OfficeClip API Documentation
DocumentInfo..::.CreatedByUserId Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user who created the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedByUserId { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreatedByUserId As Integer
Visual C++
public:
property int CreatedByUserId {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


CreatedByUserName Property

[image]

OfficeClip API Documentation
DocumentInfo..::.CreatedByUserName Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the name of the user who created the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CreatedByUserName { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreatedByUserName As String
Visual C++
public:
property String^ CreatedByUserName {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


CreatedDate Property

[image]

OfficeClip API Documentation
DocumentInfo..::.CreatedDate Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The created date of the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreatedDate As DateTime
Visual C++
public:
property DateTime CreatedDate {
    DateTime get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentDescription Property

[image]

OfficeClip API Documentation
DocumentInfo..::.DocumentDescription Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Tthe Description of the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DocumentDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentDescription As String
Visual C++
public:
property String^ DocumentDescription {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentDirectory Property

[image]

OfficeClip API Documentation
DocumentInfo..::.DocumentDirectory Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The directory path of the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DocumentDirectory { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentDirectory As String
Visual C++
public:
property String^ DocumentDirectory {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentId Property

[image]

OfficeClip API Documentation
DocumentInfo..::.DocumentId Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique document id.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int DocumentId { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentId As Integer
Visual C++
public:
property int DocumentId {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentKeyword Property

[image]

OfficeClip API Documentation
DocumentInfo..::.DocumentKeyword Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The keywords for the documents.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DocumentKeyword { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentKeyword As String
Visual C++
public:
property String^ DocumentKeyword {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentName Property

[image]

OfficeClip API Documentation
DocumentInfo..::.DocumentName Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DocumentName { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentName As String
Visual C++
public:
property String^ DocumentName {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentPath Property

[image]

OfficeClip API Documentation
DocumentInfo..::.DocumentPath Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The complete path of the document file.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DocumentPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentPath As String
Visual C++
public:
property String^ DocumentPath {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


FileSize Property

[image]

OfficeClip API Documentation
DocumentInfo..::.FileSize Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The file size of the document (in KB).

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double FileSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileSize As Double
Visual C++
public:
property double FileSize {
    double get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


GroupId Property

[image]

OfficeClip API Documentation
DocumentInfo..::.GroupId Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique id of the group that contains the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


id1 Property

[image]

OfficeClip API Documentation
DocumentInfo..::.id1 Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first id for the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int id1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property id1 As Integer
Visual C++
public:
property int id1 {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


id2 Property

[image]

OfficeClip API Documentation
DocumentInfo..::.id2 Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second id for the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int id2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property id2 As Integer
Visual C++
public:
property int id2 {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsLocked Property

[image]

OfficeClip API Documentation
DocumentInfo..::.IsLocked Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the document is locked.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsLocked { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLocked As Boolean
Visual C++
public:
property bool IsLocked {
    bool get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsShared Property

[image]

OfficeClip API Documentation
DocumentInfo..::.IsShared Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if this document is shared with some user.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShared { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsShared As Boolean
Visual C++
public:
property bool IsShared {
    bool get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


LockedByUserId Property

[image]

OfficeClip API Documentation
DocumentInfo..::.LockedByUserId Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user id of the user who locked the document. This is only meaningful if the document is locked.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LockedByUserId { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockedByUserId As Integer
Visual C++
public:
property int LockedByUserId {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


LockedByUserName Property

[image]

OfficeClip API Documentation
DocumentInfo..::.LockedByUserName Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user who locked the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LockedByUserName { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockedByUserName As String
Visual C++
public:
property String^ LockedByUserName {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ModifiedByUserId Property

[image]

OfficeClip API Documentation
DocumentInfo..::.ModifiedByUserId Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user who last modified the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ModifiedByUserId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ModifiedByUserId As Integer
Visual C++
public:
property int ModifiedByUserId {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ModifiedByUserName Property

[image]

OfficeClip API Documentation
DocumentInfo..::.ModifiedByUserName Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user who last modified the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ModifiedByUserName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ModifiedByUserName As String
Visual C++
public:
property String^ ModifiedByUserName {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ModifiedDate Property

[image]

OfficeClip API Documentation
DocumentInfo..::.ModifiedDate Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last modified date of the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ModifiedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ModifiedDate As DateTime
Visual C++
public:
property DateTime ModifiedDate {
    DateTime get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ParentFolderId Property

[image]

OfficeClip API Documentation
DocumentInfo..::.ParentFolderId Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the Parent folder of the document. Returns null if there is no Parent folder for the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ParentFolderId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentFolderId As Integer
Visual C++
public:
property int ParentFolderId {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ParentFolderName Property

[image]

OfficeClip API Documentation
DocumentInfo..::.ParentFolderName Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The folder name of the Parent folder of the document. This is meaningful only if the document has a Parent folder.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ParentFolderName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentFolderName As String
Visual C++
public:
property String^ ParentFolderName {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Rev Property

[image]

OfficeClip API Documentation
DocumentInfo..::.Rev Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The revision of the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Rev { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rev As Integer
Visual C++
public:
property int Rev {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


SharedByUserId Property

[image]

OfficeClip API Documentation
DocumentInfo..::.SharedByUserId Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user id of the user who shared the document. This is meaningful if the document is shared.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SharedByUserId { get; }
Visual Basic (Declaration)
Public ReadOnly Property SharedByUserId As Integer
Visual C++
public:
property int SharedByUserId {
    int get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


SharedByUserName Property

[image]

OfficeClip API Documentation
DocumentInfo..::.SharedByUserName Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user who shared the document. This is meaningful only if the document is shared.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SharedByUserName { get; }
Visual Basic (Declaration)
Public ReadOnly Property SharedByUserName As String
Visual C++
public:
property String^ SharedByUserName {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


VirtualPath Property

[image]

OfficeClip API Documentation
DocumentInfo..::.VirtualPath Property
DocumentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the virtual path.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string VirtualPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property VirtualPath As String
Visual C++
public:
property String^ VirtualPath {
    String^ get ();
}

See Also

DocumentInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStatus Class

[image]

OfficeClip API Documentation
DocumentStatus Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to hold the document information.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class DocumentStatus
Visual Basic (Declaration)
Public Class DocumentStatus
Visual C++
public ref class DocumentStatus

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop..::.DocumentStatus

See Also

DocumentStatus Members
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStatus Members

[image] [image]

OfficeClip API Documentation
DocumentStatus Members
DocumentStatus Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The DocumentStatus type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentStatus |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
NoSpaceAvailable | The constant to specify that there is no available space.

See Also

DocumentStatus Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStatus Constructor

[image]

OfficeClip API Documentation
DocumentStatus Constructor
DocumentStatus Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStatus()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentStatus()

See Also

DocumentStatus Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStatus Fields

[image] [image]

OfficeClip API Documentation
DocumentStatus Fields
DocumentStatus Class See Also

[This is preliminary documentation and is subject to change.]

The DocumentStatus type exposes the following fields.

Fields

Name | Description
NoSpaceAvailable | The constant to specify that there is no available space.

See Also

DocumentStatus Class
OfficeClip.BusinessLayer.Desktop Namespace


NoSpaceAvailable Field

[image]

OfficeClip API Documentation
DocumentStatus..::.NoSpaceAvailable Field
DocumentStatus Class See Also

[This is preliminary documentation and is subject to change.]

The constant to specify that there is no available space.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int NoSpaceAvailable
Visual Basic (Declaration)
Public Shared ReadOnly NoSpaceAvailable As Integer
Visual C++
public:
static initonly int NoSpaceAvailable

See Also

DocumentStatus Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStatus.DeleteFolderStatus Enumeration

[image]

OfficeClip API Documentation
DocumentStatus..::.DeleteFolderStatus Enumeration
DocumentStatus Class See Also

[This is preliminary documentation and is subject to change.]

Defines the different possible return statuses while attempting to Delete a folder.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum DeleteFolderStatus
Visual Basic (Declaration)
Public Enumeration DeleteFolderStatus
Visual C++
public enum class DeleteFolderStatus

Members

Member name | Description
Success | Indicates that Delete folder was successful.
TransactionFailed | Inicates that the transaction failed.
FolderBelongsToAnotherUser | Indicates that folder belongs to another user.
FolderHasFiles | Indicates that the folder being deleted has files inside.
FileSystemError | Indicates that a file system error occurred while deleting the folder.

See Also

OfficeClip.BusinessLayer.Desktop Namespace


DocumentStatus.DocumentDeleteStatus Enumeration

[image]

OfficeClip API Documentation
DocumentStatus..::.DocumentDeleteStatus Enumeration
DocumentStatus Class See Also

[This is preliminary documentation and is subject to change.]

Defines the different possible return statuses while attempting to Delete a document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum DocumentDeleteStatus
Visual Basic (Declaration)
Public Enumeration DocumentDeleteStatus
Visual C++
public enum class DocumentDeleteStatus

Members

Member name | Description
Success | Indicates that the Document Delete was successful.
TransactionFailed | Indicates that the transaction failed during deleting the document.
ShareExists | Indicates that the share for this document exists.

See Also

OfficeClip.BusinessLayer.Desktop Namespace


DocumentStatus.DocumentPreInsertStatus Enumeration

[image]

OfficeClip API Documentation
DocumentStatus..::.DocumentPreInsertStatus Enumeration
DocumentStatus Class See Also

[This is preliminary documentation and is subject to change.]

Defines the different possible return statuses while attempting to Insert a document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum DocumentPreInsertStatus
Visual Basic (Declaration)
Public Enumeration DocumentPreInsertStatus
Visual C++
public enum class DocumentPreInsertStatus

Members

Member name | Description
Success | Indicates that the pre Insert status was successful.
Failure | Indicates that the pre Insert status check failed.
NoSpaceAvailable | Indicates that there is no space available.
FileExistsPermissionOk | Indicates that the file exists and the permission is ok.
FileExistsNoPermission | Indicates that file exists and there was no permission on the file.
FileExistsAndShared | Indicates that the file exists and is shared.
FileLocked | Indicates that the file is locked.
InvalidCharactersInFileName | Indicates that there were invalid characters in the file name.
MovedOrCopiedFileInSameFolder | Indicates that file is being moved or copied from a particular folder to the same folder.
NoWritePermission | Indicates that the current user does not have any write permission on the file
FolderExistsPermissionOk | Indicates that the folder exists and the permission is ok.

See Also

OfficeClip.BusinessLayer.Desktop Namespace


DocumentStatus.RenameDocumentStatus Enumeration

[image]

OfficeClip API Documentation
DocumentStatus..::.RenameDocumentStatus Enumeration
DocumentStatus Class See Also

[This is preliminary documentation and is subject to change.]

Defines the different possible return statuses while attempting to rename a document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum RenameDocumentStatus
Visual Basic (Declaration)
Public Enumeration RenameDocumentStatus
Visual C++
public enum class RenameDocumentStatus

Members

Member name | Description
Success | Indicates that the document rename was successful.
Failure | Indicates that the document rename failed.
AlreadyExists | Indicates that the document being renamed to already exists.

See Also

OfficeClip.BusinessLayer.Desktop Namespace


DocumentStatus.UpdateDocumentStatus Enumeration

[image]

OfficeClip API Documentation
DocumentStatus..::.UpdateDocumentStatus Enumeration
DocumentStatus Class See Also

[This is preliminary documentation and is subject to change.]

Defines the different possible return statuses while attempting to update a document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum UpdateDocumentStatus
Visual Basic (Declaration)
Public Enumeration UpdateDocumentStatus
Visual C++
public enum class UpdateDocumentStatus

Members

Member name | Description
Success | Indicates that the document rename was successful.
Failure | Indicates that the document rename failed.

See Also

OfficeClip.BusinessLayer.Desktop Namespace


DocumentStorageInfo Class

[image]

OfficeClip API Documentation
DocumentStorageInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides access to the document storage information object used for accounting.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class DocumentStorageInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DocumentStorageInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class DocumentStorageInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop..::.DocumentStorageInfo

See Also

DocumentStorageInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStorageInfo Members

[image] [image]

OfficeClip API Documentation
DocumentStorageInfo Members
DocumentStorageInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The DocumentStorageInfo type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentStorageInfo | Overloaded.

Methods

 | Name | Description
Public method | Dump | Prints out the document name, space and storage type
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DocStorageType | shows if the information is private.
Public property | DocumentSpace | The document space for the storage information.
Public property | id | The system generated unique id of the document storage information.
Public property | name | The name in the document storage information.

See Also

DocumentStorageInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStorageInfo Constructor

[image] [image]

OfficeClip API Documentation
DocumentStorageInfo Constructor
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | DocumentStorageInfo()()() | The default constructor.
Public method | DocumentStorageInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.
Public method | DocumentStorageInfo(Int32, DocumentStorageType, Double, String) | The public constructor

See Also

DocumentStorageInfo Class
DocumentStorageInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStorageInfo Constructor

[image]

OfficeClip API Documentation
DocumentStorageInfo Constructor
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStorageInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentStorageInfo()

See Also

DocumentStorageInfo Class
DocumentStorageInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStorageInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
DocumentStorageInfo Constructor (SerializationInfo, StreamingContext)
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStorageInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
DocumentStorageInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

DocumentStorageInfo Class
DocumentStorageInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStorageInfo Constructor (Int32, DocumentStorageType, Double, String)

[image]

OfficeClip API Documentation
DocumentStorageInfo Constructor (Int32, DocumentStorageType, Double, String)
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The public constructor

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStorageInfo(
    int id,
    DocumentStorageType docStorageType,
    double documentSpace,
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    id As Integer, _
    docStorageType As DocumentStorageType, _
    documentSpace As Double, _
    name As String _
)
Visual C++
public:
DocumentStorageInfo(
    int id,
    DocumentStorageType docStorageType,
    double documentSpace,
    String^ name
)

Parameters

id
Type: System..::.Int32
The unique id of the document storage
docStorageType
Type: OfficeClip.Utils..::.DocumentStorageType
The type of the document storage
documentSpace
Type: System..::.Double
The document space
name
Type: System..::.String
The document name

See Also

DocumentStorageInfo Class
DocumentStorageInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStorageInfo Methods

[image] [image]

OfficeClip API Documentation
DocumentStorageInfo Methods
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The DocumentStorageInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Prints out the document name, space and storage type
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentStorageInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Dump Method

[image]

OfficeClip API Documentation
DocumentStorageInfo..::.Dump Method
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Prints out the document name, space and storage type

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

Name, storage type, and space

See Also

DocumentStorageInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
DocumentStorageInfo..::.GetObjectData Method
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

DocumentStorageInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentStorageInfo Properties

[image] [image]

OfficeClip API Documentation
DocumentStorageInfo Properties
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The DocumentStorageInfo type exposes the following properties.

Properties

 | Name | Description
Public property | DocStorageType | shows if the information is private.
Public property | DocumentSpace | The document space for the storage information.
Public property | id | The system generated unique id of the document storage information.
Public property | name | The name in the document storage information.

See Also

DocumentStorageInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocStorageType Property

[image]

OfficeClip API Documentation
DocumentStorageInfo..::.DocStorageType Property
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

shows if the information is private.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStorageType DocStorageType { get; set; }
Visual Basic (Declaration)
Public Property DocStorageType As DocumentStorageType
Visual C++
public:
property DocumentStorageType DocStorageType {
    DocumentStorageType get ();
    void set (DocumentStorageType value);
}

See Also

DocumentStorageInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocumentSpace Property

[image]

OfficeClip API Documentation
DocumentStorageInfo..::.DocumentSpace Property
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The document space for the storage information.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double DocumentSpace { get; set; }
Visual Basic (Declaration)
Public Property DocumentSpace As Double
Visual C++
public:
property double DocumentSpace {
    double get ();
    void set (double value);
}

See Also

DocumentStorageInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


id Property

[image]

OfficeClip API Documentation
DocumentStorageInfo..::.id Property
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique id of the document storage information.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int id { get; set; }
Visual Basic (Declaration)
Public Property id As Integer
Visual C++
public:
property int id {
    int get ();
    void set (int value);
}

See Also

DocumentStorageInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


name Property

[image]

OfficeClip API Documentation
DocumentStorageInfo..::.name Property
DocumentStorageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name in the document storage information.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string name { get; set; }
Visual Basic (Declaration)
Public Property name As String
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}

See Also

DocumentStorageInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EventInfo Class

[image]

OfficeClip API Documentation
EventInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties for the calendar event information.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class EventInfo
Visual Basic (Declaration)
Public Class EventInfo
Visual C++
public ref class EventInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop..::.EventInfo
OfficeClip.BusinessLayer.Sync..::.OCCSVEventInfo

See Also

EventInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


EventInfo Members

[image] [image]

OfficeClip API Documentation
EventInfo Members
EventInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The EventInfo type exposes the following members.

Constructors

 | Name | Description
Public method | EventInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPersonalOnlyInformationChanged | Determines if the personal only information is changed between two events. This is useful to determine if the user has changed the reminder and the busy information. This information may be required to stop sending emails to everybody when the personal information is changed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attachments | A list of attachments.
Public property | CreatedByUserId | The creator user id of the event.
Public property | CreatedTimestamp | The Timestamp of when the event is created.
Public property | DocIdList | the list of comma separated unique document identifier associated with this event.
Public property | EndDatetime | The date and time of the end of the event.
Public property | EventDescription | The Description of the event.
Public property | EventGroupId | The unique id of the group which this event belongs to.
Public property | EventGroupName | The name of the group to which the event belongs to.
Public property | EventId | The system generated unique id of the event.
Public property | EventName | The Title of the event.
Public property | EventType | The event type of the event.
Public property | EventUserId | The unique identifier of the user who created the event.
Public property | FirstOcurrenceDatetime | The first occurence datetime of this recurring event.
Public property | IsAllDayEvent | Shows whether the event is all day event.
Public property | IsReminderSelected | Shows if the reminder is selected for the event.
Public property | IsResourceReserved | Shows if the resource for this event is reserved.
Public property | IsRSVP | Shows if the event has an RSVP.
Public property | LabelId | The event label (classification)
Public property | LastOcurrenceDatetime | the last occurence of datetime for this event.
Public property | Location | The Location of the event.
Public property | MeetingAttendees | A list of meeting attendies.
Public property | ModifiedByUserId | The modified by user id
Public property | ModifiedTimestamp | The modified timestamp
Public property | NotifyGroup | Shows whether to notify the group for this event.
Public property | ParentObjectId | The id of the parent object
Public property | ParentObjectType | The type of the parent object
Public property | Recurrence | Te Recurrence information about the event.
Public property | Regarding | The regarding string
Public property | RemDocIdList | A list of comma separated document identifiers that needs to be removed inthis event.
Public property | RemindAtDatetime | The date and time of the event reminder.
Public property | RepeatInfoText | The text of the repeat information of the event.
Public property | RepeatingSequenceId | The sequence id of the repeating sequence event.
Public property | ResourceId | The unique id of the resource associated with this event.
Public property | ResourceName | The name of the resource associated with the event.
Public property | ShowAs | How the event is shown on the screen.
Public property | StartDatetime | The date and time of the start of the event.
Public property | TimezoneId | The timezone id of the event.
Public property | url | The Uniform Resource Locator associated with this event.
Public property | WhenToRemind | The time (in String format) of the reminder of the event.
Public property | WhoToRemind | The name of the person to remind for the event.

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EventInfo Constructor

[image] [image]

OfficeClip API Documentation
EventInfo Constructor
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | EventInfo()()() | The default constructor.
Public method | EventInfo(EventInfo) | The copy constructor to create the event information object from another event object.

See Also

EventInfo Class
EventInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


EventInfo Constructor

[image]

OfficeClip API Documentation
EventInfo Constructor
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EventInfo()

See Also

EventInfo Class
EventInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


EventInfo Constructor (EventInfo)

[image]

OfficeClip API Documentation
EventInfo Constructor (EventInfo)
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The copy constructor to create the event information object from another event object.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventInfo(
    EventInfo ei
)
Visual Basic (Declaration)
Public Sub New ( _
    ei As EventInfo _
)
Visual C++
public:
EventInfo(
    EventInfo^ ei
)

Parameters

ei
Type: OfficeClip.BusinessLayer.Desktop..::.EventInfo
the event information object that is being copied.

See Also

EventInfo Class
EventInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


EventInfo Methods

[image] [image]

OfficeClip API Documentation
EventInfo Methods
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EventInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPersonalOnlyInformationChanged | Determines if the personal only information is changed between two events. This is useful to determine if the user has changed the reminder and the busy information. This information may be required to stop sending emails to everybody when the personal information is changed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsPersonalOnlyInformationChanged Method

[image]

OfficeClip API Documentation
EventInfo..::.IsPersonalOnlyInformationChanged Method
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the personal only information is changed between two events. This is useful to determine if the user has changed the reminder and the busy information. This information may be required to stop sending emails to everybody when the personal information is changed.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsPersonalOnlyInformationChanged(
    EventInfo oldEi
)
Visual Basic (Declaration)
Public Function IsPersonalOnlyInformationChanged ( _
    oldEi As EventInfo _
) As Boolean
Visual C++
public:
bool IsPersonalOnlyInformationChanged(
    EventInfo^ oldEi
)

Parameters

oldEi
Type: OfficeClip.BusinessLayer.Desktop..::.EventInfo
The event info objec to compare with

Return Value

true if only personal information is changed or it is a personal event, false otherwise.

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EventInfo Properties

[image] [image]

OfficeClip API Documentation
EventInfo Properties
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EventInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Attachments | A list of attachments.
Public property | CreatedByUserId | The creator user id of the event.
Public property | CreatedTimestamp | The Timestamp of when the event is created.
Public property | DocIdList | the list of comma separated unique document identifier associated with this event.
Public property | EndDatetime | The date and time of the end of the event.
Public property | EventDescription | The Description of the event.
Public property | EventGroupId | The unique id of the group which this event belongs to.
Public property | EventGroupName | The name of the group to which the event belongs to.
Public property | EventId | The system generated unique id of the event.
Public property | EventName | The Title of the event.
Public property | EventType | The event type of the event.
Public property | EventUserId | The unique identifier of the user who created the event.
Public property | FirstOcurrenceDatetime | The first occurence datetime of this recurring event.
Public property | IsAllDayEvent | Shows whether the event is all day event.
Public property | IsReminderSelected | Shows if the reminder is selected for the event.
Public property | IsResourceReserved | Shows if the resource for this event is reserved.
Public property | IsRSVP | Shows if the event has an RSVP.
Public property | LabelId | The event label (classification)
Public property | LastOcurrenceDatetime | the last occurence of datetime for this event.
Public property | Location | The Location of the event.
Public property | MeetingAttendees | A list of meeting attendies.
Public property | ModifiedByUserId | The modified by user id
Public property | ModifiedTimestamp | The modified timestamp
Public property | NotifyGroup | Shows whether to notify the group for this event.
Public property | ParentObjectId | The id of the parent object
Public property | ParentObjectType | The type of the parent object
Public property | Recurrence | Te Recurrence information about the event.
Public property | Regarding | The regarding string
Public property | RemDocIdList | A list of comma separated document identifiers that needs to be removed inthis event.
Public property | RemindAtDatetime | The date and time of the event reminder.
Public property | RepeatInfoText | The text of the repeat information of the event.
Public property | RepeatingSequenceId | The sequence id of the repeating sequence event.
Public property | ResourceId | The unique id of the resource associated with this event.
Public property | ResourceName | The name of the resource associated with the event.
Public property | ShowAs | How the event is shown on the screen.
Public property | StartDatetime | The date and time of the start of the event.
Public property | TimezoneId | The timezone id of the event.
Public property | url | The Uniform Resource Locator associated with this event.
Public property | WhenToRemind | The time (in String format) of the reminder of the event.
Public property | WhoToRemind | The name of the person to remind for the event.

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Attachments Property

[image]

OfficeClip API Documentation
EventInfo..::.Attachments Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

A list of attachments.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Attachments { get; set; }
Visual Basic (Declaration)
Public Property Attachments As ArrayList
Visual C++
public:
property ArrayList^ Attachments {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


CreatedByUserId Property

[image]

OfficeClip API Documentation
EventInfo..::.CreatedByUserId Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The creator user id of the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedByUserId { get; set; }
Visual Basic (Declaration)
Public Property CreatedByUserId As Integer
Visual C++
public:
property int CreatedByUserId {
    int get ();
    void set (int value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


CreatedTimestamp Property

[image]

OfficeClip API Documentation
EventInfo..::.CreatedTimestamp Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp of when the event is created.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedTimestamp As DateTime
Visual C++
public:
property DateTime CreatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DocIdList Property

[image]

OfficeClip API Documentation
EventInfo..::.DocIdList Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

the list of comma separated unique document identifier associated with this event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DocIdList { get; set; }
Visual Basic (Declaration)
Public Property DocIdList As String
Visual C++
public:
property String^ DocIdList {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EndDatetime Property

[image]

OfficeClip API Documentation
EventInfo..::.EndDatetime Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date and time of the end of the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime EndDatetime { get; set; }
Visual Basic (Declaration)
Public Property EndDatetime As DateTime
Visual C++
public:
property DateTime EndDatetime {
    DateTime get ();
    void set (DateTime value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EventDescription Property

[image]

OfficeClip API Documentation
EventInfo..::.EventDescription Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Description of the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EventDescription { get; set; }
Visual Basic (Declaration)
Public Property EventDescription As String
Visual C++
public:
property String^ EventDescription {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EventGroupId Property

[image]

OfficeClip API Documentation
EventInfo..::.EventGroupId Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the group which this event belongs to.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EventGroupId { get; set; }
Visual Basic (Declaration)
Public Property EventGroupId As Integer
Visual C++
public:
property int EventGroupId {
    int get ();
    void set (int value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EventGroupName Property

[image]

OfficeClip API Documentation
EventInfo..::.EventGroupName Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the group to which the event belongs to.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EventGroupName { get; set; }
Visual Basic (Declaration)
Public Property EventGroupName As String
Visual C++
public:
property String^ EventGroupName {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EventId Property

[image]

OfficeClip API Documentation
EventInfo..::.EventId Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique id of the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EventId { get; set; }
Visual Basic (Declaration)
Public Property EventId As Integer
Visual C++
public:
property int EventId {
    int get ();
    void set (int value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EventName Property

[image]

OfficeClip API Documentation
EventInfo..::.EventName Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Title of the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EventName { get; set; }
Visual Basic (Declaration)
Public Property EventName As String
Visual C++
public:
property String^ EventName {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EventType Property

[image]

OfficeClip API Documentation
EventInfo..::.EventType Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The event type of the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventType EventType { get; set; }
Visual Basic (Declaration)
Public Property EventType As EventType
Visual C++
public:
property EventType EventType {
    EventType get ();
    void set (EventType value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EventUserId Property

[image]

OfficeClip API Documentation
EventInfo..::.EventUserId Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique identifier of the user who created the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EventUserId { get; set; }
Visual Basic (Declaration)
Public Property EventUserId As Integer
Visual C++
public:
property int EventUserId {
    int get ();
    void set (int value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


FirstOcurrenceDatetime Property

[image]

OfficeClip API Documentation
EventInfo..::.FirstOcurrenceDatetime Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first occurence datetime of this recurring event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime FirstOcurrenceDatetime { get; set; }
Visual Basic (Declaration)
Public Property FirstOcurrenceDatetime As DateTime
Visual C++
public:
property DateTime FirstOcurrenceDatetime {
    DateTime get ();
    void set (DateTime value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsAllDayEvent Property

[image]

OfficeClip API Documentation
EventInfo..::.IsAllDayEvent Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the event is all day event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAllDayEvent { get; set; }
Visual Basic (Declaration)
Public Property IsAllDayEvent As Boolean
Visual C++
public:
property bool IsAllDayEvent {
    bool get ();
    void set (bool value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsReminderSelected Property

[image]

OfficeClip API Documentation
EventInfo..::.IsReminderSelected Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the reminder is selected for the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsReminderSelected { get; set; }
Visual Basic (Declaration)
Public Property IsReminderSelected As Boolean
Visual C++
public:
property bool IsReminderSelected {
    bool get ();
    void set (bool value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsResourceReserved Property

[image]

OfficeClip API Documentation
EventInfo..::.IsResourceReserved Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the resource for this event is reserved.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsResourceReserved { get; set; }
Visual Basic (Declaration)
Public Property IsResourceReserved As Boolean
Visual C++
public:
property bool IsResourceReserved {
    bool get ();
    void set (bool value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsRSVP Property

[image]

OfficeClip API Documentation
EventInfo..::.IsRSVP Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the event has an RSVP.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsRSVP { get; set; }
Visual Basic (Declaration)
Public Property IsRSVP As Boolean
Visual C++
public:
property bool IsRSVP {
    bool get ();
    void set (bool value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


LabelId Property

[image]

OfficeClip API Documentation
EventInfo..::.LabelId Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The event label (classification)

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LabelId { get; set; }
Visual Basic (Declaration)
Public Property LabelId As Integer
Visual C++
public:
property int LabelId {
    int get ();
    void set (int value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


LastOcurrenceDatetime Property

[image]

OfficeClip API Documentation
EventInfo..::.LastOcurrenceDatetime Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

the last occurence of datetime for this event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime LastOcurrenceDatetime { get; set; }
Visual Basic (Declaration)
Public Property LastOcurrenceDatetime As DateTime
Visual C++
public:
property DateTime LastOcurrenceDatetime {
    DateTime get ();
    void set (DateTime value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Location Property

[image]

OfficeClip API Documentation
EventInfo..::.Location Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Location of the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


MeetingAttendees Property

[image]

OfficeClip API Documentation
EventInfo..::.MeetingAttendees Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

A list of meeting attendies.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList MeetingAttendees { get; set; }
Visual Basic (Declaration)
Public Property MeetingAttendees As ArrayList
Visual C++
public:
property ArrayList^ MeetingAttendees {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ModifiedByUserId Property

[image]

OfficeClip API Documentation
EventInfo..::.ModifiedByUserId Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The modified by user id

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ModifiedByUserId { get; set; }
Visual Basic (Declaration)
Public Property ModifiedByUserId As Integer
Visual C++
public:
property int ModifiedByUserId {
    int get ();
    void set (int value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ModifiedTimestamp Property

[image]

OfficeClip API Documentation
EventInfo..::.ModifiedTimestamp Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The modified timestamp

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ModifiedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ModifiedTimestamp As DateTime
Visual C++
public:
property DateTime ModifiedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


NotifyGroup Property

[image]

OfficeClip API Documentation
EventInfo..::.NotifyGroup Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether to notify the group for this event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool NotifyGroup { get; set; }
Visual Basic (Declaration)
Public Property NotifyGroup As Boolean
Visual C++
public:
property bool NotifyGroup {
    bool get ();
    void set (bool value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ParentObjectId Property

[image]

OfficeClip API Documentation
EventInfo..::.ParentObjectId Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The id of the parent object

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ParentObjectId { get; set; }
Visual Basic (Declaration)
Public Property ParentObjectId As Integer
Visual C++
public:
property int ParentObjectId {
    int get ();
    void set (int value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ParentObjectType Property

[image]

OfficeClip API Documentation
EventInfo..::.ParentObjectType Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The type of the parent object

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants..::.ObjectType ParentObjectType { get; set; }
Visual Basic (Declaration)
Public Property ParentObjectType As BusinessConstants..::.ObjectType
Visual C++
public:
property BusinessConstants..::.ObjectType ParentObjectType {
    BusinessConstants..::.ObjectType get ();
    void set (BusinessConstants..::.ObjectType value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Recurrence Property

[image]

OfficeClip API Documentation
EventInfo..::.Recurrence Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Te Recurrence information about the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RecurrenceInfo Recurrence { get; set; }
Visual Basic (Declaration)
Public Property Recurrence As RecurrenceInfo
Visual C++
public:
property RecurrenceInfo^ Recurrence {
    RecurrenceInfo^ get ();
    void set (RecurrenceInfo^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Regarding Property

[image]

OfficeClip API Documentation
EventInfo..::.Regarding Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The regarding string

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Regarding { get; set; }
Visual Basic (Declaration)
Public Property Regarding As String
Visual C++
public:
property String^ Regarding {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RemDocIdList Property

[image]

OfficeClip API Documentation
EventInfo..::.RemDocIdList Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

A list of comma separated document identifiers that needs to be removed inthis event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RemDocIdList { get; set; }
Visual Basic (Declaration)
Public Property RemDocIdList As String
Visual C++
public:
property String^ RemDocIdList {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RemindAtDatetime Property

[image]

OfficeClip API Documentation
EventInfo..::.RemindAtDatetime Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date and time of the event reminder.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime RemindAtDatetime { get; set; }
Visual Basic (Declaration)
Public Property RemindAtDatetime As DateTime
Visual C++
public:
property DateTime RemindAtDatetime {
    DateTime get ();
    void set (DateTime value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RepeatInfoText Property

[image]

OfficeClip API Documentation
EventInfo..::.RepeatInfoText Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The text of the repeat information of the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RepeatInfoText { get; set; }
Visual Basic (Declaration)
Public Property RepeatInfoText As String
Visual C++
public:
property String^ RepeatInfoText {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RepeatingSequenceId Property

[image]

OfficeClip API Documentation
EventInfo..::.RepeatingSequenceId Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The sequence id of the repeating sequence event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RepeatingSequenceId { get; set; }
Visual Basic (Declaration)
Public Property RepeatingSequenceId As Integer
Visual C++
public:
property int RepeatingSequenceId {
    int get ();
    void set (int value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ResourceId Property

[image]

OfficeClip API Documentation
EventInfo..::.ResourceId Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the resource associated with this event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ResourceId { get; set; }
Visual Basic (Declaration)
Public Property ResourceId As Integer
Visual C++
public:
property int ResourceId {
    int get ();
    void set (int value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ResourceName Property

[image]

OfficeClip API Documentation
EventInfo..::.ResourceName Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the resource associated with the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ResourceName { get; set; }
Visual Basic (Declaration)
Public Property ResourceName As String
Visual C++
public:
property String^ ResourceName {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ShowAs Property

[image]

OfficeClip API Documentation
EventInfo..::.ShowAs Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

How the event is shown on the screen.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventShowAs ShowAs { get; set; }
Visual Basic (Declaration)
Public Property ShowAs As EventShowAs
Visual C++
public:
property EventShowAs ShowAs {
    EventShowAs get ();
    void set (EventShowAs value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


StartDatetime Property

[image]

OfficeClip API Documentation
EventInfo..::.StartDatetime Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date and time of the start of the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime StartDatetime { get; set; }
Visual Basic (Declaration)
Public Property StartDatetime As DateTime
Visual C++
public:
property DateTime StartDatetime {
    DateTime get ();
    void set (DateTime value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TimezoneId Property

[image]

OfficeClip API Documentation
EventInfo..::.TimezoneId Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The timezone id of the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TimezoneId { get; set; }
Visual Basic (Declaration)
Public Property TimezoneId As Integer
Visual C++
public:
property int TimezoneId {
    int get ();
    void set (int value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


url Property

[image]

OfficeClip API Documentation
EventInfo..::.url Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Uniform Resource Locator associated with this event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string url { get; set; }
Visual Basic (Declaration)
Public Property url As String
Visual C++
public:
property String^ url {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


WhenToRemind Property

[image]

OfficeClip API Documentation
EventInfo..::.WhenToRemind Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time (in String format) of the reminder of the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string WhenToRemind { get; set; }
Visual Basic (Declaration)
Public Property WhenToRemind As String
Visual C++
public:
property String^ WhenToRemind {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


WhoToRemind Property

[image]

OfficeClip API Documentation
EventInfo..::.WhoToRemind Property
EventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the person to remind for the event.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string WhoToRemind { get; set; }
Visual Basic (Declaration)
Public Property WhoToRemind As String
Visual C++
public:
property String^ WhoToRemind {
    String^ get ();
    void set (String^ value);
}

See Also

EventInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EventQueryString Class

[image]

OfficeClip API Documentation
EventQueryString Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent query string for the event

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class EventQueryString
Visual Basic (Declaration)
Public Class EventQueryString
Visual C++
public ref class EventQueryString

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop..::.EventQueryString

See Also

EventQueryString Members
OfficeClip.BusinessLayer.Desktop Namespace


EventQueryString Members

[image] [image]

OfficeClip API Documentation
EventQueryString Members
EventQueryString Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The EventQueryString type exposes the following members.

Constructors

 | Name | Description
Public method | EventQueryString | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUrl | Creates the url

Properties

 | Name | Description
Public property | CalDate | The calendar date
Public property | CView | The Calendar View

See Also

EventQueryString Class
OfficeClip.BusinessLayer.Desktop Namespace


EventQueryString Constructor

[image] [image]

OfficeClip API Documentation
EventQueryString Constructor
EventQueryString Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | EventQueryString(NameValueCollection) | Constructor
Public method | EventQueryString(DateTime, CalendarView) | Constructor

See Also

EventQueryString Class
EventQueryString Members
OfficeClip.BusinessLayer.Desktop Namespace


EventQueryString Constructor (NameValueCollection)

[image]

OfficeClip API Documentation
EventQueryString Constructor (NameValueCollection)
EventQueryString Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventQueryString(
    NameValueCollection queryString
)
Visual Basic (Declaration)
Public Sub New ( _
    queryString As NameValueCollection _
)
Visual C++
public:
EventQueryString(
    NameValueCollection^ queryString
)

Parameters

queryString
Type: System.Collections.Specialized..::.NameValueCollection

See Also

EventQueryString Class
EventQueryString Overload
OfficeClip.BusinessLayer.Desktop Namespace


EventQueryString Constructor (DateTime, CalendarView)

[image]

OfficeClip API Documentation
EventQueryString Constructor (DateTime, CalendarView)
EventQueryString Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventQueryString(
    DateTime calDate,
    CalendarView cView
)
Visual Basic (Declaration)
Public Sub New ( _
    calDate As DateTime, _
    cView As CalendarView _
)
Visual C++
public:
EventQueryString(
    DateTime calDate,
    CalendarView cView
)

Parameters

calDate
Type: System..::.DateTime
cView
Type: OfficeClip.Utils..::.CalendarView

See Also

EventQueryString Class
EventQueryString Overload
OfficeClip.BusinessLayer.Desktop Namespace


EventQueryString Methods

[image] [image]

OfficeClip API Documentation
EventQueryString Methods
EventQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The EventQueryString type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToUrl | Creates the url

See Also

EventQueryString Class
OfficeClip.BusinessLayer.Desktop Namespace


ToUrl Method

[image]

OfficeClip API Documentation
EventQueryString..::.ToUrl Method
EventQueryString Class See Also

[This is preliminary documentation and is subject to change.]

Creates the url

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToUrl(
    string location
)
Visual Basic (Declaration)
Public Function ToUrl ( _
    location As String _
) As String
Visual C++
public:
String^ ToUrl(
    String^ location
)

Parameters

location
Type: System..::.String
The url location

Return Value

The url

See Also

EventQueryString Class
OfficeClip.BusinessLayer.Desktop Namespace


EventQueryString Properties

[image] [image]

OfficeClip API Documentation
EventQueryString Properties
EventQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The EventQueryString type exposes the following properties.

Properties

 | Name | Description
Public property | CalDate | The calendar date
Public property | CView | The Calendar View

See Also

EventQueryString Class
OfficeClip.BusinessLayer.Desktop Namespace


CalDate Property

[image]

OfficeClip API Documentation
EventQueryString..::.CalDate Property
EventQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The calendar date

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CalDate { get; set; }
Visual Basic (Declaration)
Public Property CalDate As DateTime
Visual C++
public:
property DateTime CalDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

EventQueryString Class
OfficeClip.BusinessLayer.Desktop Namespace


CView Property

[image]

OfficeClip API Documentation
EventQueryString..::.CView Property
EventQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The Calendar View

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CalendarView CView { get; set; }
Visual Basic (Declaration)
Public Property CView As CalendarView
Visual C++
public:
property CalendarView CView {
    CalendarView get ();
    void set (CalendarView value);
}

See Also

EventQueryString Class
OfficeClip.BusinessLayer.Desktop Namespace


FolderInfo Class

[image]

OfficeClip API Documentation
FolderInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the document folder information.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class FolderInfo
Visual Basic (Declaration)
Public Class FolderInfo
Visual C++
public ref class FolderInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop..::.FolderInfo

See Also

FolderInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


FolderInfo Members

[image] [image]

OfficeClip API Documentation
FolderInfo Members
FolderInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The FolderInfo type exposes the following members.

Constructors

 | Name | Description
Public method | FolderInfo | Constructor using various parameters.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AppId | The application identifier of the application that cteated the folder.
Public property | CreatedByUserId | The identifier of the user who created the folder.
Public property | CreatedByUserName | The name of the user who created the folder.
Public property | CreatedDate | The date on which the folder is created.
Public property | FolderId | The system generated unique identifier for the folder.
Public property | FolderName | The name of the folder.
Public property | FolderPath | The full path of the folder.
Public property | FolderType | The type of the folder. Possible values are "G" - for group folder, "P" for private folder and "A" for folder created by application.
Public property | GroupId | The identifier of the group where the folder belongs.
Public property | Level | The Level of the folder.
Public property | ModifiedByUserId | The unique id of the user who last modified the document.
Public property | ModifiedByUserName | The unique name of the user who last modified the document.
Public property | ModifiedDate | The last modified date of the document.
Public property | ParentId | The application identifier of the application that cteated the folder.
Public property | VirtualPath | The name of the virtual Path

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


FolderInfo Constructor

[image]

OfficeClip API Documentation
FolderInfo Constructor
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor using various parameters.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public FolderInfo(
    int folderId,
    string folderName,
    string folderPath,
    string virtualPath,
    string level,
    int createdByUserId,
    string createdByUserName,
    DateTime modifiedDate,
    int modifiedByUserId,
    string modifiedByUserName,
    DateTime createdDate,
    int groupId,
    int appId,
    int parentId
)
Visual Basic (Declaration)
Public Sub New ( _
    folderId As Integer, _
    folderName As String, _
    folderPath As String, _
    virtualPath As String, _
    level As String, _
    createdByUserId As Integer, _
    createdByUserName As String, _
    modifiedDate As DateTime, _
    modifiedByUserId As Integer, _
    modifiedByUserName As String, _
    createdDate As DateTime, _
    groupId As Integer, _
    appId As Integer, _
    parentId As Integer _
)
Visual C++
public:
FolderInfo(
    int folderId,
    String^ folderName,
    String^ folderPath,
    String^ virtualPath,
    String^ level,
    int createdByUserId,
    String^ createdByUserName,
    DateTime modifiedDate,
    int modifiedByUserId,
    String^ modifiedByUserName,
    DateTime createdDate,
    int groupId,
    int appId,
    int parentId
)

Parameters

folderId
Type: System..::.Int32
The system generated unique identifier for the document folder.
folderName
Type: System..::.String
The name of the folder.
folderPath
Type: System..::.String
The full path of the folder.
virtualPath
Type: System..::.String
The virtual path
level
Type: System..::.String
The Level of the folder.
createdByUserId
Type: System..::.Int32
The unique identifier for the user who created the folder.
createdByUserName
Type: System..::.String
The name of the user who created the folder.
modifiedDate
Type: System..::.DateTime
The date on which the folder is modified.
modifiedByUserId
Type: System..::.Int32
The unique id of the user who modified the folder
modifiedByUserName
Type: System..::.String
The modified by user name
createdDate
Type: System..::.DateTime
The created date
groupId
Type: System..::.Int32
The unique identifier of the group where this folder belongs to.
appId
Type: System..::.Int32
The application identifier of the application that created the folder.
parentId
Type: System..::.Int32
The Id of the parent folder.

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


FolderInfo Properties

[image] [image]

OfficeClip API Documentation
FolderInfo Properties
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The FolderInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AppId | The application identifier of the application that cteated the folder.
Public property | CreatedByUserId | The identifier of the user who created the folder.
Public property | CreatedByUserName | The name of the user who created the folder.
Public property | CreatedDate | The date on which the folder is created.
Public property | FolderId | The system generated unique identifier for the folder.
Public property | FolderName | The name of the folder.
Public property | FolderPath | The full path of the folder.
Public property | FolderType | The type of the folder. Possible values are "G" - for group folder, "P" for private folder and "A" for folder created by application.
Public property | GroupId | The identifier of the group where the folder belongs.
Public property | Level | The Level of the folder.
Public property | ModifiedByUserId | The unique id of the user who last modified the document.
Public property | ModifiedByUserName | The unique name of the user who last modified the document.
Public property | ModifiedDate | The last modified date of the document.
Public property | ParentId | The application identifier of the application that cteated the folder.
Public property | VirtualPath | The name of the virtual Path

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


AppId Property

[image]

OfficeClip API Documentation
FolderInfo..::.AppId Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The application identifier of the application that cteated the folder.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AppId { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppId As Integer
Visual C++
public:
property int AppId {
    int get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


CreatedByUserId Property

[image]

OfficeClip API Documentation
FolderInfo..::.CreatedByUserId Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier of the user who created the folder.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedByUserId { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreatedByUserId As Integer
Visual C++
public:
property int CreatedByUserId {
    int get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


CreatedByUserName Property

[image]

OfficeClip API Documentation
FolderInfo..::.CreatedByUserName Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user who created the folder.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CreatedByUserName { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreatedByUserName As String
Visual C++
public:
property String^ CreatedByUserName {
    String^ get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


CreatedDate Property

[image]

OfficeClip API Documentation
FolderInfo..::.CreatedDate Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date on which the folder is created.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreatedDate As DateTime
Visual C++
public:
property DateTime CreatedDate {
    DateTime get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


FolderId Property

[image]

OfficeClip API Documentation
FolderInfo..::.FolderId Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the folder.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int FolderId { get; }
Visual Basic (Declaration)
Public ReadOnly Property FolderId As Integer
Visual C++
public:
property int FolderId {
    int get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


FolderName Property

[image]

OfficeClip API Documentation
FolderInfo..::.FolderName Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the folder.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FolderName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FolderName As String
Visual C++
public:
property String^ FolderName {
    String^ get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


FolderPath Property

[image]

OfficeClip API Documentation
FolderInfo..::.FolderPath Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The full path of the folder.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FolderPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property FolderPath As String
Visual C++
public:
property String^ FolderPath {
    String^ get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


FolderType Property

[image]

OfficeClip API Documentation
FolderInfo..::.FolderType Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The type of the folder. Possible values are "G" - for group folder, "P" for private folder and "A" for folder created by application.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FolderType { get; }
Visual Basic (Declaration)
Public ReadOnly Property FolderType As String
Visual C++
public:
property String^ FolderType {
    String^ get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


GroupId Property

[image]

OfficeClip API Documentation
FolderInfo..::.GroupId Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier of the group where the folder belongs.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Level Property

[image]

OfficeClip API Documentation
FolderInfo..::.Level Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Level of the folder.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Level { get; }
Visual Basic (Declaration)
Public ReadOnly Property Level As String
Visual C++
public:
property String^ Level {
    String^ get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ModifiedByUserId Property

[image]

OfficeClip API Documentation
FolderInfo..::.ModifiedByUserId Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user who last modified the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ModifiedByUserId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ModifiedByUserId As Integer
Visual C++
public:
property int ModifiedByUserId {
    int get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ModifiedByUserName Property

[image]

OfficeClip API Documentation
FolderInfo..::.ModifiedByUserName Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique name of the user who last modified the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ModifiedByUserName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ModifiedByUserName As String
Visual C++
public:
property String^ ModifiedByUserName {
    String^ get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ModifiedDate Property

[image]

OfficeClip API Documentation
FolderInfo..::.ModifiedDate Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last modified date of the document.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ModifiedDate { get; }
Visual Basic (Declaration)
Public ReadOnly Property ModifiedDate As DateTime
Visual C++
public:
property DateTime ModifiedDate {
    DateTime get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ParentId Property

[image]

OfficeClip API Documentation
FolderInfo..::.ParentId Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The application identifier of the application that cteated the folder.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ParentId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentId As Integer
Visual C++
public:
property int ParentId {
    int get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


VirtualPath Property

[image]

OfficeClip API Documentation
FolderInfo..::.VirtualPath Property
FolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the virtual Path

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string VirtualPath { get; }
Visual Basic (Declaration)
Public ReadOnly Property VirtualPath As String
Visual C++
public:
property String^ VirtualPath {
    String^ get ();
}

See Also

FolderInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


MeetingAttendeeInfo Class

[image]

OfficeClip API Documentation
MeetingAttendeeInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the information related to the meeting attendies.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class MeetingAttendeeInfo : ISerializable,
    IComparer
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MeetingAttendeeInfo _
    Implements ISerializable, IComparer
Visual C++
[SerializableAttribute]
public ref class MeetingAttendeeInfo : ISerializable,
    IComparer

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop..::.MeetingAttendeeInfo

See Also

MeetingAttendeeInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


MeetingAttendeeInfo Members

[image] [image]

OfficeClip API Documentation
MeetingAttendeeInfo Members
MeetingAttendeeInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MeetingAttendeeInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MeetingAttendeeInfo | Overloaded.

Methods

 | Name | Description
Public method | Compare | Implements the compare method for the IComparer Interface
Public method | Equals | Overrides the Object.Equals(Object) method for using in comparison of objects in Collections. (Overrides Object..::.Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the Object.GetHashCode() method. (Overrides Object..::.GetHashCode()()().)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EmailAddress | Meeting attendies email Address.
Public property | IsExternal | If the meeting attendee is external or not.
Public property | Name | Meeting attendies name.
Public property | UserId | The user identifier ofthe meeting attendies.

See Also

MeetingAttendeeInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


MeetingAttendeeInfo Constructor

[image] [image]

OfficeClip API Documentation
MeetingAttendeeInfo Constructor
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MeetingAttendeeInfo()()() | The default constructor for the meeting attendee
Public method | MeetingAttendeeInfo(Int32) | The constructor.
Public method | MeetingAttendeeInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.
Public method | MeetingAttendeeInfo(String, String) | Constructor to create object using the name and email Address.
Public method | MeetingAttendeeInfo(Int32, String, String, Boolean) | Constructor to create object using the user id, name and email Address.

See Also

MeetingAttendeeInfo Class
MeetingAttendeeInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


MeetingAttendeeInfo Constructor

[image]

OfficeClip API Documentation
MeetingAttendeeInfo Constructor
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for the meeting attendee

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MeetingAttendeeInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MeetingAttendeeInfo()

See Also

MeetingAttendeeInfo Class
MeetingAttendeeInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


MeetingAttendeeInfo Constructor (Int32)

[image]

OfficeClip API Documentation
MeetingAttendeeInfo Constructor (Int32)
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MeetingAttendeeInfo(
    int uid
)
Visual Basic (Declaration)
Public Sub New ( _
    uid As Integer _
)
Visual C++
public:
MeetingAttendeeInfo(
    int uid
)

Parameters

uid
Type: System..::.Int32
unique user id

See Also

MeetingAttendeeInfo Class
MeetingAttendeeInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


MeetingAttendeeInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
MeetingAttendeeInfo Constructor (SerializationInfo, StreamingContext)
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MeetingAttendeeInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
MeetingAttendeeInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

MeetingAttendeeInfo Class
MeetingAttendeeInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


MeetingAttendeeInfo Constructor (String, String)

[image]

OfficeClip API Documentation
MeetingAttendeeInfo Constructor (String, String)
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create object using the name and email Address.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MeetingAttendeeInfo(
    string en,
    string ena
)
Visual Basic (Declaration)
Public Sub New ( _
    en As String, _
    ena As String _
)
Visual C++
public:
MeetingAttendeeInfo(
    String^ en,
    String^ ena
)

Parameters

en
Type: System..::.String
The attendies name.
ena
Type: System..::.String
the attendies email Address.

See Also

MeetingAttendeeInfo Class
MeetingAttendeeInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


MeetingAttendeeInfo Constructor (Int32, String, String, Boolean)

[image]

OfficeClip API Documentation
MeetingAttendeeInfo Constructor (Int32, String, String, Boolean)
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create object using the user id, name and email Address.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MeetingAttendeeInfo(
    int attendeeUserId,
    string attendeeName,
    string attendeeEmailAddress,
    bool isExternalUser
)
Visual Basic (Declaration)
Public Sub New ( _
    attendeeUserId As Integer, _
    attendeeName As String, _
    attendeeEmailAddress As String, _
    isExternalUser As Boolean _
)
Visual C++
public:
MeetingAttendeeInfo(
    int attendeeUserId,
    String^ attendeeName,
    String^ attendeeEmailAddress,
    bool isExternalUser
)

Parameters

attendeeUserId
Type: System..::.Int32
the user identifier of the meeting attendies.
attendeeName
Type: System..::.String
The attendies name
attendeeEmailAddress
Type: System..::.String
The attendies email Address.
isExternalUser
Type: System..::.Boolean
Flag (True/False) indicating that it is true or false.

See Also

MeetingAttendeeInfo Class
MeetingAttendeeInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


MeetingAttendeeInfo Methods

[image] [image]

OfficeClip API Documentation
MeetingAttendeeInfo Methods
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MeetingAttendeeInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Compare | Implements the compare method for the IComparer Interface
Public method | Equals | Overrides the Object.Equals(Object) method for using in comparison of objects in Collections. (Overrides Object..::.Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Overrides the Object.GetHashCode() method. (Overrides Object..::.GetHashCode()()().)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeetingAttendeeInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Compare Method

[image]

OfficeClip API Documentation
MeetingAttendeeInfo..::.Compare Method
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Implements the compare method for the IComparer Interface

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Compare(
    Object o1,
    Object o2
)
Visual Basic (Declaration)
Public Function Compare ( _
    o1 As Object, _
    o2 As Object _
) As Integer
Visual C++
public:
virtual int Compare(
    Object^ o1,
    Object^ o2
) sealed

Parameters

o1
Type: System..::.Object
First object to compare.
o2
Type: System..::.Object
Second object to compare.

Return Value

-1 if object is less, 0 if equal, 1 if greater.

Implements

IComparer..::.Compare(Object, Object)

See Also

MeetingAttendeeInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Equals Method

[image]

OfficeClip API Documentation
MeetingAttendeeInfo..::.Equals Method
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overrides the Object.Equals(Object) method for using in comparison of objects in Collections.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Equals(
    Object o
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    o As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ o
) override

Parameters

o
Type: System..::.Object
Object of type MeetingAttendeeInfo.

Return Value

True of equal to this object else false.

See Also

MeetingAttendeeInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


GetHashCode Method

[image]

OfficeClip API Documentation
MeetingAttendeeInfo..::.GetHashCode Method
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overrides the Object.GetHashCode() method.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

Hashcoded value of this object.

See Also

MeetingAttendeeInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
MeetingAttendeeInfo..::.GetObjectData Method
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

MeetingAttendeeInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


MeetingAttendeeInfo Properties

[image] [image]

OfficeClip API Documentation
MeetingAttendeeInfo Properties
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MeetingAttendeeInfo type exposes the following properties.

Properties

 | Name | Description
Public property | EmailAddress | Meeting attendies email Address.
Public property | IsExternal | If the meeting attendee is external or not.
Public property | Name | Meeting attendies name.
Public property | UserId | The user identifier ofthe meeting attendies.

See Also

MeetingAttendeeInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EmailAddress Property

[image]

OfficeClip API Documentation
MeetingAttendeeInfo..::.EmailAddress Property
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Meeting attendies email Address.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailAddress { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
}

See Also

MeetingAttendeeInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsExternal Property

[image]

OfficeClip API Documentation
MeetingAttendeeInfo..::.IsExternal Property
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

If the meeting attendee is external or not.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsExternal { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsExternal As Boolean
Visual C++
public:
property bool IsExternal {
    bool get ();
}

See Also

MeetingAttendeeInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Name Property

[image]

OfficeClip API Documentation
MeetingAttendeeInfo..::.Name Property
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Meeting attendies name.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

MeetingAttendeeInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


UserId Property

[image]

OfficeClip API Documentation
MeetingAttendeeInfo..::.UserId Property
MeetingAttendeeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user identifier ofthe meeting attendies.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; }
Visual Basic (Declaration)
Public ReadOnly Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
}

See Also

MeetingAttendeeInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RecurrenceInfo Class

[image]

OfficeClip API Documentation
RecurrenceInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the recurring information for an event or reminders.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class RecurrenceInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class RecurrenceInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class RecurrenceInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop..::.RecurrenceInfo

See Also

RecurrenceInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


RecurrenceInfo Members

[image] [image]

OfficeClip API Documentation
RecurrenceInfo Members
RecurrenceInfo Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The RecurrenceInfo type exposes the following members.

Constructors

 | Name | Description
Public method | RecurrenceInfo | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetRecurringDates | Gets the arraylist of recurring dates from the given date
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the object to String. (Overrides Object..::.ToString()()().)

Fields

 | Name | Description
Public field | DailyCount | The daily count.
Public field | IsDailyWeekday | Shows if the daily restricted only to the weekedays.
Public field | IsMonthlyDayBasis | Shows if the monthly Recurrence on the basis of a particular day.
Public field | IsRangeEndByDate | Shows if the range is selected by the End By date.
Public field | IsYearlyMonthBasis | Shows if the yearly Recurrence is on monthly basis.
Public field | MonthlyDayMonthNum | The month number for the monthly Recurrence on daily basis.
Public field | MonthlyDayNum | The monthly Recurrence day number.
Public field | MonthlyWeekCount | The week of the month for monthly Recurrence.
Public field | MonthlyWeekDay | The day of the week for monthly Recurrence.
Public field | MonthlyWeekMonthNum | The monthly Recurrence month number.
Public field | Period | The period of Recurrence.
Public field | RangeEndByDate | The range end by date.
Public field | RangeOccurrencesCount | The occurence count for the range.
Public field | Weekday | The day of the week.
Public field | WeeklyCount | The weekly count.
Public field | YearlyDay | The day for the yearly Recurrence.
Public field | YearlyMonth | The month for the yearly Recurrence.
Public field | YearlyWeekCount | Yearly Recurrence week count.
Public field | YearlyWeekDay | Yearly Recurrence week day.
Public field | YearlyWeekMonth | Yearly Recurrence week month.

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RecurrenceInfo Constructor

[image] [image]

OfficeClip API Documentation
RecurrenceInfo Constructor
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | RecurrenceInfo()()() | The default constructor.
Public method | RecurrenceInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.
Public method | RecurrenceInfo(Periodicity, Int32, Boolean, Int32, ArrayList, Boolean, Int32, Int32, Int32, Int32, Int32, Boolean, Int32, Int32, Int32, Int32, Int32, Boolean, Int32, DateTime) | Constructor to create an object given all the contents.

See Also

RecurrenceInfo Class
RecurrenceInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


RecurrenceInfo Constructor

[image]

OfficeClip API Documentation
RecurrenceInfo Constructor
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RecurrenceInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RecurrenceInfo()

See Also

RecurrenceInfo Class
RecurrenceInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


RecurrenceInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
RecurrenceInfo Constructor (SerializationInfo, StreamingContext)
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RecurrenceInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
RecurrenceInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

RecurrenceInfo Class
RecurrenceInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


RecurrenceInfo Constructor (Periodicity, Int32, Boolean, Int32, ArrayList, Boolean, Int32, Int32, Int32, Int32, Int32, Boolean, Int32, Int32, Int32, Int32, Int32, Boolean, Int32, DateTime)

[image]

OfficeClip API Documentation
RecurrenceInfo Constructor (Periodicity, Int32, Boolean, Int32, ArrayList, Boolean, Int32, Int32, Int32, Int32, Int32, Boolean, Int32, Int32, Int32, Int32, Int32, Boolean, Int32, DateTime)
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an object given all the contents.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RecurrenceInfo(
    Periodicity pPeriod,
    int pDailyCount,
    bool pIsDailyWeekday,
    int pWeeklyCount,
    ArrayList pWeekday,
    bool pIsMonthlyDayBasis,
    int pMonthlyDayNum,
    int pMonthlyDayMonthNum,
    int pMonthlyWeekCount,
    int pMonthlyWeekDay,
    int pMonthlyWeekMonthNum,
    bool pIsYearlyMonthBasis,
    int pYearlyMonth,
    int pYearlyDay,
    int pYearlyWeekCount,
    int pYearlyWeekDay,
    int pYearlyWeekMonth,
    bool pIsRangeEndByDate,
    int pRangeOccurrencesCount,
    DateTime pRangeEndByDate
)
Visual Basic (Declaration)
Public Sub New ( _
    pPeriod As Periodicity, _
    pDailyCount As Integer, _
    pIsDailyWeekday As Boolean, _
    pWeeklyCount As Integer, _
    pWeekday As ArrayList, _
    pIsMonthlyDayBasis As Boolean, _
    pMonthlyDayNum As Integer, _
    pMonthlyDayMonthNum As Integer, _
    pMonthlyWeekCount As Integer, _
    pMonthlyWeekDay As Integer, _
    pMonthlyWeekMonthNum As Integer, _
    pIsYearlyMonthBasis As Boolean, _
    pYearlyMonth As Integer, _
    pYearlyDay As Integer, _
    pYearlyWeekCount As Integer, _
    pYearlyWeekDay As Integer, _
    pYearlyWeekMonth As Integer, _
    pIsRangeEndByDate As Boolean, _
    pRangeOccurrencesCount As Integer, _
    pRangeEndByDate As DateTime _
)
Visual C++
public:
RecurrenceInfo(
    Periodicity pPeriod,
    int pDailyCount,
    bool pIsDailyWeekday,
    int pWeeklyCount,
    ArrayList^ pWeekday,
    bool pIsMonthlyDayBasis,
    int pMonthlyDayNum,
    int pMonthlyDayMonthNum,
    int pMonthlyWeekCount,
    int pMonthlyWeekDay,
    int pMonthlyWeekMonthNum,
    bool pIsYearlyMonthBasis,
    int pYearlyMonth,
    int pYearlyDay,
    int pYearlyWeekCount,
    int pYearlyWeekDay,
    int pYearlyWeekMonth,
    bool pIsRangeEndByDate,
    int pRangeOccurrencesCount,
    DateTime pRangeEndByDate
)

Parameters

pPeriod
Type: OfficeClip.Utils..::.Periodicity
The period of Recurrence.
pDailyCount
Type: System..::.Int32
The daily count.
pIsDailyWeekday
Type: System..::.Boolean
Shows if the daily restricted only to the weekedays.
pWeeklyCount
Type: System..::.Int32
The weekly count.
pWeekday
Type: System.Collections..::.ArrayList
The day of the week.
pIsMonthlyDayBasis
Type: System..::.Boolean
Shows if the monthly Recurrence on the basis of a particular day.
pMonthlyDayNum
Type: System..::.Int32
The monthly Recurrence day number.
pMonthlyDayMonthNum
Type: System..::.Int32
The month number for the monthly Recurrence on daily basis.
pMonthlyWeekCount
Type: System..::.Int32
The week of the month for monthly Recurrence.
pMonthlyWeekDay
Type: System..::.Int32
The day of the week for monthly Recurrence.
pMonthlyWeekMonthNum
Type: System..::.Int32
The monthly Recurrence month number.
pIsYearlyMonthBasis
Type: System..::.Boolean
Shows if the yearly Recurrence is on monthly basis.
pYearlyMonth
Type: System..::.Int32
The month for the yearly Recurrence.
pYearlyDay
Type: System..::.Int32
The day for the yearly Recurrence.
pYearlyWeekCount
Type: System..::.Int32
Yearly Recurrence week count.
pYearlyWeekDay
Type: System..::.Int32
Yearly Recurrence week day.
pYearlyWeekMonth
Type: System..::.Int32
Yearly Recurrence week month.
pIsRangeEndByDate
Type: System..::.Boolean
Shows if the range is selected by the End By date.
pRangeOccurrencesCount
Type: System..::.Int32
The occurence count for the range.
pRangeEndByDate
Type: System..::.DateTime
The range end by date.

See Also

RecurrenceInfo Class
RecurrenceInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


RecurrenceInfo Fields

[image] [image]

OfficeClip API Documentation
RecurrenceInfo Fields
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The RecurrenceInfo type exposes the following fields.

Fields

 | Name | Description
Public field | DailyCount | The daily count.
Public field | IsDailyWeekday | Shows if the daily restricted only to the weekedays.
Public field | IsMonthlyDayBasis | Shows if the monthly Recurrence on the basis of a particular day.
Public field | IsRangeEndByDate | Shows if the range is selected by the End By date.
Public field | IsYearlyMonthBasis | Shows if the yearly Recurrence is on monthly basis.
Public field | MonthlyDayMonthNum | The month number for the monthly Recurrence on daily basis.
Public field | MonthlyDayNum | The monthly Recurrence day number.
Public field | MonthlyWeekCount | The week of the month for monthly Recurrence.
Public field | MonthlyWeekDay | The day of the week for monthly Recurrence.
Public field | MonthlyWeekMonthNum | The monthly Recurrence month number.
Public field | Period | The period of Recurrence.
Public field | RangeEndByDate | The range end by date.
Public field | RangeOccurrencesCount | The occurence count for the range.
Public field | Weekday | The day of the week.
Public field | WeeklyCount | The weekly count.
Public field | YearlyDay | The day for the yearly Recurrence.
Public field | YearlyMonth | The month for the yearly Recurrence.
Public field | YearlyWeekCount | Yearly Recurrence week count.
Public field | YearlyWeekDay | Yearly Recurrence week day.
Public field | YearlyWeekMonth | Yearly Recurrence week month.

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DailyCount Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.DailyCount Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The daily count.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int DailyCount
Visual Basic (Declaration)
Public DailyCount As Integer
Visual C++
public:
int DailyCount

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsDailyWeekday Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.IsDailyWeekday Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the daily restricted only to the weekedays.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsDailyWeekday
Visual Basic (Declaration)
Public IsDailyWeekday As Boolean
Visual C++
public:
bool IsDailyWeekday

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsMonthlyDayBasis Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.IsMonthlyDayBasis Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the monthly Recurrence on the basis of a particular day.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsMonthlyDayBasis
Visual Basic (Declaration)
Public IsMonthlyDayBasis As Boolean
Visual C++
public:
bool IsMonthlyDayBasis

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsRangeEndByDate Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.IsRangeEndByDate Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the range is selected by the End By date.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsRangeEndByDate
Visual Basic (Declaration)
Public IsRangeEndByDate As Boolean
Visual C++
public:
bool IsRangeEndByDate

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsYearlyMonthBasis Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.IsYearlyMonthBasis Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the yearly Recurrence is on monthly basis.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsYearlyMonthBasis
Visual Basic (Declaration)
Public IsYearlyMonthBasis As Boolean
Visual C++
public:
bool IsYearlyMonthBasis

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


MonthlyDayMonthNum Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.MonthlyDayMonthNum Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The month number for the monthly Recurrence on daily basis.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MonthlyDayMonthNum
Visual Basic (Declaration)
Public MonthlyDayMonthNum As Integer
Visual C++
public:
int MonthlyDayMonthNum

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


MonthlyDayNum Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.MonthlyDayNum Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The monthly Recurrence day number.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MonthlyDayNum
Visual Basic (Declaration)
Public MonthlyDayNum As Integer
Visual C++
public:
int MonthlyDayNum

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


MonthlyWeekCount Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.MonthlyWeekCount Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The week of the month for monthly Recurrence.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MonthlyWeekCount
Visual Basic (Declaration)
Public MonthlyWeekCount As Integer
Visual C++
public:
int MonthlyWeekCount

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


MonthlyWeekDay Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.MonthlyWeekDay Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The day of the week for monthly Recurrence.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MonthlyWeekDay
Visual Basic (Declaration)
Public MonthlyWeekDay As Integer
Visual C++
public:
int MonthlyWeekDay

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


MonthlyWeekMonthNum Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.MonthlyWeekMonthNum Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The monthly Recurrence month number.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MonthlyWeekMonthNum
Visual Basic (Declaration)
Public MonthlyWeekMonthNum As Integer
Visual C++
public:
int MonthlyWeekMonthNum

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Period Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.Period Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The period of Recurrence.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Periodicity Period
Visual Basic (Declaration)
Public Period As Periodicity
Visual C++
public:
Periodicity Period

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RangeEndByDate Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.RangeEndByDate Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The range end by date.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime RangeEndByDate
Visual Basic (Declaration)
Public RangeEndByDate As DateTime
Visual C++
public:
DateTime RangeEndByDate

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RangeOccurrencesCount Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.RangeOccurrencesCount Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The occurence count for the range.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RangeOccurrencesCount
Visual Basic (Declaration)
Public RangeOccurrencesCount As Integer
Visual C++
public:
int RangeOccurrencesCount

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Weekday Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.Weekday Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The day of the week.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Weekday
Visual Basic (Declaration)
Public Weekday As ArrayList
Visual C++
public:
ArrayList^ Weekday

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


WeeklyCount Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.WeeklyCount Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The weekly count.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int WeeklyCount
Visual Basic (Declaration)
Public WeeklyCount As Integer
Visual C++
public:
int WeeklyCount

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


YearlyDay Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.YearlyDay Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The day for the yearly Recurrence.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int YearlyDay
Visual Basic (Declaration)
Public YearlyDay As Integer
Visual C++
public:
int YearlyDay

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


YearlyMonth Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.YearlyMonth Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The month for the yearly Recurrence.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int YearlyMonth
Visual Basic (Declaration)
Public YearlyMonth As Integer
Visual C++
public:
int YearlyMonth

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


YearlyWeekCount Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.YearlyWeekCount Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Yearly Recurrence week count.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int YearlyWeekCount
Visual Basic (Declaration)
Public YearlyWeekCount As Integer
Visual C++
public:
int YearlyWeekCount

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


YearlyWeekDay Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.YearlyWeekDay Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Yearly Recurrence week day.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int YearlyWeekDay
Visual Basic (Declaration)
Public YearlyWeekDay As Integer
Visual C++
public:
int YearlyWeekDay

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


YearlyWeekMonth Field

[image]

OfficeClip API Documentation
RecurrenceInfo..::.YearlyWeekMonth Field
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Yearly Recurrence week month.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int YearlyWeekMonth
Visual Basic (Declaration)
Public YearlyWeekMonth As Integer
Visual C++
public:
int YearlyWeekMonth

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RecurrenceInfo Methods

[image] [image]

OfficeClip API Documentation
RecurrenceInfo Methods
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The RecurrenceInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetRecurringDates | Gets the arraylist of recurring dates from the given date
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the object to String. (Overrides Object..::.ToString()()().)

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Dump Method

[image]

OfficeClip API Documentation
RecurrenceInfo..::.Dump Method
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the object for debugging.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

The output string for debugging.

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
RecurrenceInfo..::.GetObjectData Method
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


GetRecurringDates Method

[image]

OfficeClip API Documentation
RecurrenceInfo..::.GetRecurringDates Method
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the arraylist of recurring dates from the given date

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetRecurringDates(
    DateTime startDate
)
Visual Basic (Declaration)
Public Function GetRecurringDates ( _
    startDate As DateTime _
) As ArrayList
Visual C++
public:
ArrayList^ GetRecurringDates(
    DateTime startDate
)

Parameters

startDate
Type: System..::.DateTime
The start date from which the recurrence should be found

Return Value

The arraylist of the recurring date

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ToString Method

[image]

OfficeClip API Documentation
RecurrenceInfo..::.ToString Method
RecurrenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Converts the object to String.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The value of the object.

See Also

RecurrenceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ResourceInfo Class

[image]

OfficeClip API Documentation
ResourceInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

provides methods and properties to access the resource information.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ResourceInfo
Visual Basic (Declaration)
Public Class ResourceInfo
Visual C++
public ref class ResourceInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop..::.ResourceInfo

See Also

ResourceInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


ResourceInfo Members

[image] [image]

OfficeClip API Documentation
ResourceInfo Members
ResourceInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ResourceInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ResourceInfo | The default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddressId | The Address identifier for the resource Address.
Public property | Capacity | The Capacity for the resource.
Public property | Features | The feature set for the resource.
Public property | GroupId | The identifier for the group that holds the resource.
Public property | IsActive | Shows if the resource is Active. Valid values are "Y" and "N".
Public property | ResourceAddress | The Address of the resource.
Public property | ResourceId | The system generated unique identifier for the resource.
Public property | ResourceName | The name of the resource.
Public property | ResourceType | The resource type.
Public property | ResourceTypeId | The identifier for the resource type.
Public property | Udf1Name | The first user defined field name of the resource.
Public property | Udf1Value | The value of the first user defined field for the resource.
Public property | Udf2Name | The second user defined field name for the resource.
Public property | Udf2Value | The value of the second user defined field for the resource.

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ResourceInfo Constructor

[image]

OfficeClip API Documentation
ResourceInfo Constructor
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ResourceInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ResourceInfo()

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ResourceInfo Properties

[image] [image]

OfficeClip API Documentation
ResourceInfo Properties
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ResourceInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AddressId | The Address identifier for the resource Address.
Public property | Capacity | The Capacity for the resource.
Public property | Features | The feature set for the resource.
Public property | GroupId | The identifier for the group that holds the resource.
Public property | IsActive | Shows if the resource is Active. Valid values are "Y" and "N".
Public property | ResourceAddress | The Address of the resource.
Public property | ResourceId | The system generated unique identifier for the resource.
Public property | ResourceName | The name of the resource.
Public property | ResourceType | The resource type.
Public property | ResourceTypeId | The identifier for the resource type.
Public property | Udf1Name | The first user defined field name of the resource.
Public property | Udf1Value | The value of the first user defined field for the resource.
Public property | Udf2Name | The second user defined field name for the resource.
Public property | Udf2Value | The value of the second user defined field for the resource.

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


AddressId Property

[image]

OfficeClip API Documentation
ResourceInfo..::.AddressId Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Address identifier for the resource Address.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AddressId { get; set; }
Visual Basic (Declaration)
Public Property AddressId As Integer
Visual C++
public:
property int AddressId {
    int get ();
    void set (int value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Capacity Property

[image]

OfficeClip API Documentation
ResourceInfo..::.Capacity Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Capacity for the resource.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Capacity { get; set; }
Visual Basic (Declaration)
Public Property Capacity As String
Visual C++
public:
property String^ Capacity {
    String^ get ();
    void set (String^ value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Features Property

[image]

OfficeClip API Documentation
ResourceInfo..::.Features Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The feature set for the resource.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Features { get; set; }
Visual Basic (Declaration)
Public Property Features As String
Visual C++
public:
property String^ Features {
    String^ get ();
    void set (String^ value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


GroupId Property

[image]

OfficeClip API Documentation
ResourceInfo..::.GroupId Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the group that holds the resource.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsActive Property

[image]

OfficeClip API Documentation
ResourceInfo..::.IsActive Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the resource is Active. Valid values are "Y" and "N".

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As String
Visual C++
public:
property String^ IsActive {
    String^ get ();
    void set (String^ value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ResourceAddress Property

[image]

OfficeClip API Documentation
ResourceInfo..::.ResourceAddress Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Address of the resource.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AddressInfo ResourceAddress { get; set; }
Visual Basic (Declaration)
Public Property ResourceAddress As AddressInfo
Visual C++
public:
property AddressInfo^ ResourceAddress {
    AddressInfo^ get ();
    void set (AddressInfo^ value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ResourceId Property

[image]

OfficeClip API Documentation
ResourceInfo..::.ResourceId Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the resource.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ResourceId { get; set; }
Visual Basic (Declaration)
Public Property ResourceId As Integer
Visual C++
public:
property int ResourceId {
    int get ();
    void set (int value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ResourceName Property

[image]

OfficeClip API Documentation
ResourceInfo..::.ResourceName Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the resource.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ResourceName { get; set; }
Visual Basic (Declaration)
Public Property ResourceName As String
Visual C++
public:
property String^ ResourceName {
    String^ get ();
    void set (String^ value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ResourceType Property

[image]

OfficeClip API Documentation
ResourceInfo..::.ResourceType Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The resource type.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ResourceType { get; set; }
Visual Basic (Declaration)
Public Property ResourceType As String
Visual C++
public:
property String^ ResourceType {
    String^ get ();
    void set (String^ value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ResourceTypeId Property

[image]

OfficeClip API Documentation
ResourceInfo..::.ResourceTypeId Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the resource type.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ResourceTypeId { get; set; }
Visual Basic (Declaration)
Public Property ResourceTypeId As Integer
Visual C++
public:
property int ResourceTypeId {
    int get ();
    void set (int value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Udf1Name Property

[image]

OfficeClip API Documentation
ResourceInfo..::.Udf1Name Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first user defined field name of the resource.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Udf1Name { get; set; }
Visual Basic (Declaration)
Public Property Udf1Name As String
Visual C++
public:
property String^ Udf1Name {
    String^ get ();
    void set (String^ value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Udf1Value Property

[image]

OfficeClip API Documentation
ResourceInfo..::.Udf1Value Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The value of the first user defined field for the resource.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Udf1Value { get; set; }
Visual Basic (Declaration)
Public Property Udf1Value As String
Visual C++
public:
property String^ Udf1Value {
    String^ get ();
    void set (String^ value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Udf2Name Property

[image]

OfficeClip API Documentation
ResourceInfo..::.Udf2Name Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second user defined field name for the resource.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Udf2Name { get; set; }
Visual Basic (Declaration)
Public Property Udf2Name As String
Visual C++
public:
property String^ Udf2Name {
    String^ get ();
    void set (String^ value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Udf2Value Property

[image]

OfficeClip API Documentation
ResourceInfo..::.Udf2Value Property
ResourceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The value of the second user defined field for the resource.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Udf2Value { get; set; }
Visual Basic (Declaration)
Public Property Udf2Value As String
Visual C++
public:
property String^ Udf2Value {
    String^ get ();
    void set (String^ value);
}

See Also

ResourceInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskInfo Class

[image]

OfficeClip API Documentation
TaskInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods to interact with the Task Information Object.

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TaskInfo
Visual Basic (Declaration)
Public Class TaskInfo
Visual C++
public ref class TaskInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop..::.TaskInfo

See Also

TaskInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


TaskInfo Members

[image] [image]

OfficeClip API Documentation
TaskInfo Members
TaskInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TaskInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TaskInfo | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the task to the string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAccess | Sets the access permission for the task
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessAppend | Shows if the task has append access
Public property | AccessDelete | Shows if the task has delete access
Public property | AccessRead | Shows if the task has read access
Public property | AccessWrite | Shows if the task has write access
Public property | ActualDuration | Actual duration in minutes
Public property | CompletionDate | The completion date for the task
Public property | CreatedByTimestamp | Timestamp of the creation of the task
Public property | CreatedByUserId | The unique id of the creator
Public property | Description | The description of the task
Public property | DueDate | The date when the task is due
Public property | EstimatedDuration | Estimated duration in minutes
Public property | GroupId | The unique id iof the group
Public property | GroupName | The name of the group
Public property | IsPrivate | Shows if the task is private
Public property | IsReminderSelected | Shows if the reminder is selected for the task
Public property | ModifiedByTimestamp | Timestamp of last modification
Public property | ModifiedByUserId | The unique id of the user who last modified the task
Public property | ParentId | The id of the parent object
Public property | ParentObjectType | The type of the parent object
Public property | PercentComplete | The percent complete value for the task
Public property | Recurrence | The task recurrence object
Public property | Regarding | The regarding string
Public property | RemindAtDatetime | The exact date and time for the reminder
Public property | RepeatInfotext | The text for the repeat information for the task
Public property | RepeatingSequenceId | The if of the repeating sequence for the task
Public property | StartDate | The start date for the task
Public property | Subject | The subject of the task
Public property | TaskAssignments | The Task Assignment string
Public property | TaskId | The unique id for the task
Public property | TaskOwnerId | The unique user id of the task owner
Public property | TaskOwnerName | the name of the task owner
Public property | TaskPriority | The priority of the task
Public property | TaskPriorityName | the name of the task priority
Public property | TaskStatus | The status of the task
Public property | TaskStatusName | The name of the task status
Public property | TaskType | the type of the task
Public property | TaskTypeName | The name of the task type
Public property | WhenToRemind | The time when the reminder would go
Public property | WhoToRemind | The entity who would be reminded for the task

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskInfo Constructor

[image] [image]

OfficeClip API Documentation
TaskInfo Constructor
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TaskInfo()()() | The default constructor
Public method | TaskInfo(Int32, Int32, String, Int32, String, BusinessConstants..::.TaskTypes, BusinessConstants..::.TaskPriority, BusinessConstants..::.TaskStatus, DateTime, DateTime, DateTime, Double, Int32, Int32, String, Boolean, String, String, DateTime, RecurrenceInfo, Boolean, String, String, Int32, BusinessConstants..::.ObjectType, Int32, String, Int32, DateTime, Int32, DateTime) | Creates a new task
Public method | TaskInfo(Int32, Int32, String, Int32, String, BusinessConstants..::.TaskTypes, String, BusinessConstants..::.TaskPriority, String, BusinessConstants..::.TaskStatus, String, DateTime, DateTime, DateTime, Double, Int32, Int32, String, Boolean, String, String, DateTime, RecurrenceInfo, Boolean, String, String, Int32, BusinessConstants..::.ObjectType, Int32, String, Int32, DateTime, Int32, DateTime) | The constructor that creates an object from all its members

See Also

TaskInfo Class
TaskInfo Members
OfficeClip.BusinessLayer.Desktop Namespace


TaskInfo Constructor

[image]

OfficeClip API Documentation
TaskInfo Constructor
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TaskInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TaskInfo()

See Also

TaskInfo Class
TaskInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


TaskInfo Constructor (Int32, Int32, String, Int32, String, BusinessConstants.TaskTypes, BusinessConstants.TaskPriority, BusinessConstants.TaskStatus, DateTime, DateTime, DateTime, Double, Int32, Int32, String, Boolean, String, String, DateTime, RecurrenceInfo, Boolean, String, String, Int32, Busines

[image]

OfficeClip API Documentation
TaskInfo Constructor (Int32, Int32, String, Int32, String, BusinessConstants..::.TaskTypes, BusinessConstants..::.TaskPriority, BusinessConstants..::.TaskStatus, DateTime, DateTime, DateTime, Double, Int32, Int32, String, Boolean, String, String, DateTime, RecurrenceInfo, Boolean, String, String, Int32, BusinessConstants..::.ObjectType, Int32, String, Int32, DateTime, Int32, DateTime)
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Creates a new task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TaskInfo(
    int taskId,
    int groupId,
    string groupName,
    int taskOwnerId,
    string taskOwnerName,
    BusinessConstants..::.TaskTypes taskType,
    BusinessConstants..::.TaskPriority taskPriority,
    BusinessConstants..::.TaskStatus taskStatus,
    DateTime dueDate,
    DateTime startDate,
    DateTime completionDate,
    double percentComplete,
    int estimatedDuration,
    int actualDuration,
    string repeatInfoText,
    bool isReminderSelected,
    string whoToRemind,
    string whenToRemind,
    DateTime remindAtDatetime,
    RecurrenceInfo recurrence,
    bool isPrivate,
    string subject,
    string description,
    int repeatingSequenceId,
    BusinessConstants..::.ObjectType parentObjectType,
    int parentId,
    string taskAssignments,
    int createdByUserId,
    DateTime createdByTimestamp,
    int modifiedByUserId,
    DateTime modifiedByTimestamp
)
Visual Basic (Declaration)
Public Sub New ( _
    taskId As Integer, _
    groupId As Integer, _
    groupName As String, _
    taskOwnerId As Integer, _
    taskOwnerName As String, _
    taskType As BusinessConstants..::.TaskTypes, _
    taskPriority As BusinessConstants..::.TaskPriority, _
    taskStatus As BusinessConstants..::.TaskStatus, _
    dueDate As DateTime, _
    startDate As DateTime, _
    completionDate As DateTime, _
    percentComplete As Double, _
    estimatedDuration As Integer, _
    actualDuration As Integer, _
    repeatInfoText As String, _
    isReminderSelected As Boolean, _
    whoToRemind As String, _
    whenToRemind As String, _
    remindAtDatetime As DateTime, _
    recurrence As RecurrenceInfo, _
    isPrivate As Boolean, _
    subject As String, _
    description As String, _
    repeatingSequenceId As Integer, _
    parentObjectType As BusinessConstants..::.ObjectType, _
    parentId As Integer, _
    taskAssignments As String, _
    createdByUserId As Integer, _
    createdByTimestamp As DateTime, _
    modifiedByUserId As Integer, _
    modifiedByTimestamp As DateTime _
)
Visual C++
public:
TaskInfo(
    int taskId,
    int groupId,
    String^ groupName,
    int taskOwnerId,
    String^ taskOwnerName,
    BusinessConstants..::.TaskTypes taskType,
    BusinessConstants..::.TaskPriority taskPriority,
    BusinessConstants..::.TaskStatus taskStatus,
    DateTime dueDate,
    DateTime startDate,
    DateTime completionDate,
    double percentComplete,
    int estimatedDuration,
    int actualDuration,
    String^ repeatInfoText,
    bool isReminderSelected,
    String^ whoToRemind,
    String^ whenToRemind,
    DateTime remindAtDatetime,
    RecurrenceInfo^ recurrence,
    bool isPrivate,
    String^ subject,
    String^ description,
    int repeatingSequenceId,
    BusinessConstants..::.ObjectType parentObjectType,
    int parentId,
    String^ taskAssignments,
    int createdByUserId,
    DateTime createdByTimestamp,
    int modifiedByUserId,
    DateTime modifiedByTimestamp
)

Parameters

taskId
Type: System..::.Int32
The unique if for the task
groupId
Type: System..::.Int32
The unique id for the group
groupName
Type: System..::.String
The name of the group
taskOwnerId
Type: System..::.Int32
The unique id of the task owner
taskOwnerName
Type: System..::.String
The name of the task owner
taskType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TaskTypes
The type of the task
taskPriority
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TaskPriority
The priority of the task
taskStatus
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TaskStatus
The status of the task
dueDate
Type: System..::.DateTime
The date when the task is due
startDate
Type: System..::.DateTime
The start date for the task
completionDate
Type: System..::.DateTime
The completion date for the task
percentComplete
Type: System..::.Double
The percent complete for the task
estimatedDuration
Type: System..::.Int32
The estimated duration for the task
actualDuration
Type: System..::.Int32
The actual duration for the task
repeatInfoText
Type: System..::.String
The repeat info text for the task
isReminderSelected
Type: System..::.Boolean
true if the reminder is selected
whoToRemind
Type: System..::.String
The entity to be reminded for the task
whenToRemind
Type: System..::.String
The time when the reminder should go
remindAtDatetime
Type: System..::.DateTime
The exact datetime of the reminder
recurrence
Type: OfficeClip.BusinessLayer.Desktop..::.RecurrenceInfo
The recurrence object
isPrivate
Type: System..::.Boolean
true if the task is private
subject
Type: System..::.String
The subject for the task
description
Type: System..::.String
the description for the task
repeatingSequenceId
Type: System..::.Int32
The repeating sequence id for the task
parentObjectType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The parent object type for the task
parentId
Type: System..::.Int32
the parent id for the task
taskAssignments
Type: System..::.String
Who the task is assigned to
createdByUserId
Type: System..::.Int32
The unique id of the user who created the task
createdByTimestamp
Type: System..::.DateTime
The task creation timestamp
modifiedByUserId
Type: System..::.Int32
The unique id of the user who last modified the task
modifiedByTimestamp
Type: System..::.DateTime
The last modified timestamp

See Also

TaskInfo Class
TaskInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


TaskInfo Constructor (Int32, Int32, String, Int32, String, BusinessConstants.TaskTypes, String, BusinessConstants.TaskPriority, String, BusinessConstants.TaskStatus, String, DateTime, DateTime, DateTime, Double, Int32, Int32, String, Boolean, String, String, DateTime, RecurrenceInfo, Boolean, String

[image]

OfficeClip API Documentation
TaskInfo Constructor (Int32, Int32, String, Int32, String, BusinessConstants..::.TaskTypes, String, BusinessConstants..::.TaskPriority, String, BusinessConstants..::.TaskStatus, String, DateTime, DateTime, DateTime, Double, Int32, Int32, String, Boolean, String, String, DateTime, RecurrenceInfo, Boolean, String, String, Int32, BusinessConstants..::.ObjectType, Int32, String, Int32, DateTime, Int32, DateTime)
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor that creates an object from all its members

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TaskInfo(
    int taskId,
    int groupId,
    string groupName,
    int taskOwnerId,
    string taskOwnerName,
    BusinessConstants..::.TaskTypes taskType,
    string taskTypeName,
    BusinessConstants..::.TaskPriority taskPriority,
    string taskPriorityName,
    BusinessConstants..::.TaskStatus taskStatus,
    string taskStatusName,
    DateTime dueDate,
    DateTime startDate,
    DateTime completionDate,
    double percentComplete,
    int estimatedDuration,
    int actualDuration,
    string repeatInfoText,
    bool isReminderSelected,
    string whoToRemind,
    string whenToRemind,
    DateTime remindAtDatetime,
    RecurrenceInfo recurrence,
    bool isPrivate,
    string subject,
    string description,
    int repeatingSequenceId,
    BusinessConstants..::.ObjectType parentObjectType,
    int parentId,
    string taskAssignments,
    int createdByUserId,
    DateTime createdByTimestamp,
    int modifiedByUserId,
    DateTime modifiedByTimestamp
)
Visual Basic (Declaration)
Public Sub New ( _
    taskId As Integer, _
    groupId As Integer, _
    groupName As String, _
    taskOwnerId As Integer, _
    taskOwnerName As String, _
    taskType As BusinessConstants..::.TaskTypes, _
    taskTypeName As String, _
    taskPriority As BusinessConstants..::.TaskPriority, _
    taskPriorityName As String, _
    taskStatus As BusinessConstants..::.TaskStatus, _
    taskStatusName As String, _
    dueDate As DateTime, _
    startDate As DateTime, _
    completionDate As DateTime, _
    percentComplete As Double, _
    estimatedDuration As Integer, _
    actualDuration As Integer, _
    repeatInfoText As String, _
    isReminderSelected As Boolean, _
    whoToRemind As String, _
    whenToRemind As String, _
    remindAtDatetime As DateTime, _
    recurrence As RecurrenceInfo, _
    isPrivate As Boolean, _
    subject As String, _
    description As String, _
    repeatingSequenceId As Integer, _
    parentObjectType As BusinessConstants..::.ObjectType, _
    parentId As Integer, _
    taskAssignments As String, _
    createdByUserId As Integer, _
    createdByTimestamp As DateTime, _
    modifiedByUserId As Integer, _
    modifiedByTimestamp As DateTime _
)
Visual C++
public:
TaskInfo(
    int taskId,
    int groupId,
    String^ groupName,
    int taskOwnerId,
    String^ taskOwnerName,
    BusinessConstants..::.TaskTypes taskType,
    String^ taskTypeName,
    BusinessConstants..::.TaskPriority taskPriority,
    String^ taskPriorityName,
    BusinessConstants..::.TaskStatus taskStatus,
    String^ taskStatusName,
    DateTime dueDate,
    DateTime startDate,
    DateTime completionDate,
    double percentComplete,
    int estimatedDuration,
    int actualDuration,
    String^ repeatInfoText,
    bool isReminderSelected,
    String^ whoToRemind,
    String^ whenToRemind,
    DateTime remindAtDatetime,
    RecurrenceInfo^ recurrence,
    bool isPrivate,
    String^ subject,
    String^ description,
    int repeatingSequenceId,
    BusinessConstants..::.ObjectType parentObjectType,
    int parentId,
    String^ taskAssignments,
    int createdByUserId,
    DateTime createdByTimestamp,
    int modifiedByUserId,
    DateTime modifiedByTimestamp
)

Parameters

taskId
Type: System..::.Int32
The unique id of the task
groupId
Type: System..::.Int32
The unique id of the group
groupName
Type: System..::.String
The name of the grouyp
taskOwnerId
Type: System..::.Int32
The id of the task owner
taskOwnerName
Type: System..::.String
The name of the owner
taskType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TaskTypes
The task type
taskTypeName
Type: System..::.String
The name of the task type
taskPriority
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TaskPriority
The task priority
taskPriorityName
Type: System..::.String
The name of the task priority
taskStatus
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TaskStatus
The task status
taskStatusName
Type: System..::.String
The name of the task status
dueDate
Type: System..::.DateTime
The due date i of the task
startDate
Type: System..::.DateTime
The start date of the task
completionDate
Type: System..::.DateTime
The completion date of the task
percentComplete
Type: System..::.Double
The percentage complete value of the task
estimatedDuration
Type: System..::.Int32
The estimated duration of the task
actualDuration
Type: System..::.Int32
The actual duration of the task
repeatInfoText
Type: System..::.String
The repeat info text of the task
isReminderSelected
Type: System..::.Boolean
true if the reminder is selected
whoToRemind
Type: System..::.String
The type of entity to be reminded
whenToRemind
Type: System..::.String
The time when the reminder should go
remindAtDatetime
Type: System..::.DateTime
The time at which the reminder should go
recurrence
Type: OfficeClip.BusinessLayer.Desktop..::.RecurrenceInfo
The recurrence object
isPrivate
Type: System..::.Boolean
true if the task is private
subject
Type: System..::.String
The subject of the task
description
Type: System..::.String
The description of the task
repeatingSequenceId
Type: System..::.Int32
The repeating sequence id of the task
parentObjectType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The type of the parent object for the task
parentId
Type: System..::.Int32
The id of the parent for the task
taskAssignments
Type: System..::.String
Who the task is assigned to
createdByUserId
Type: System..::.Int32
The unique id of the user that created the task
createdByTimestamp
Type: System..::.DateTime
The timestamp of the user that created the task
modifiedByUserId
Type: System..::.Int32
The last modified user id of the task
modifiedByTimestamp
Type: System..::.DateTime
The timestamp of the task when it was last modified

See Also

TaskInfo Class
TaskInfo Overload
OfficeClip.BusinessLayer.Desktop Namespace


TaskInfo Methods

[image] [image]

OfficeClip API Documentation
TaskInfo Methods
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TaskInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the task to the string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetAccess | Sets the access permission for the task
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Dump Method

[image]

OfficeClip API Documentation
TaskInfo..::.Dump Method
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the task to the string

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

The string value of the task object

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


SetAccess Method

[image]

OfficeClip API Documentation
TaskInfo..::.SetAccess Method
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Sets the access permission for the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void SetAccess(
    bool isRead,
    bool isWrite,
    bool isAppend,
    bool isDelete
)
Visual Basic (Declaration)
Public Sub SetAccess ( _
    isRead As Boolean, _
    isWrite As Boolean, _
    isAppend As Boolean, _
    isDelete As Boolean _
)
Visual C++
public:
void SetAccess(
    bool isRead,
    bool isWrite,
    bool isAppend,
    bool isDelete
)

Parameters

isRead
Type: System..::.Boolean
The read permission
isWrite
Type: System..::.Boolean
The write permission
isAppend
Type: System..::.Boolean
The append permission
isDelete
Type: System..::.Boolean
The delete permission

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskInfo Properties

[image] [image]

OfficeClip API Documentation
TaskInfo Properties
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TaskInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccessAppend | Shows if the task has append access
Public property | AccessDelete | Shows if the task has delete access
Public property | AccessRead | Shows if the task has read access
Public property | AccessWrite | Shows if the task has write access
Public property | ActualDuration | Actual duration in minutes
Public property | CompletionDate | The completion date for the task
Public property | CreatedByTimestamp | Timestamp of the creation of the task
Public property | CreatedByUserId | The unique id of the creator
Public property | Description | The description of the task
Public property | DueDate | The date when the task is due
Public property | EstimatedDuration | Estimated duration in minutes
Public property | GroupId | The unique id iof the group
Public property | GroupName | The name of the group
Public property | IsPrivate | Shows if the task is private
Public property | IsReminderSelected | Shows if the reminder is selected for the task
Public property | ModifiedByTimestamp | Timestamp of last modification
Public property | ModifiedByUserId | The unique id of the user who last modified the task
Public property | ParentId | The id of the parent object
Public property | ParentObjectType | The type of the parent object
Public property | PercentComplete | The percent complete value for the task
Public property | Recurrence | The task recurrence object
Public property | Regarding | The regarding string
Public property | RemindAtDatetime | The exact date and time for the reminder
Public property | RepeatInfotext | The text for the repeat information for the task
Public property | RepeatingSequenceId | The if of the repeating sequence for the task
Public property | StartDate | The start date for the task
Public property | Subject | The subject of the task
Public property | TaskAssignments | The Task Assignment string
Public property | TaskId | The unique id for the task
Public property | TaskOwnerId | The unique user id of the task owner
Public property | TaskOwnerName | the name of the task owner
Public property | TaskPriority | The priority of the task
Public property | TaskPriorityName | the name of the task priority
Public property | TaskStatus | The status of the task
Public property | TaskStatusName | The name of the task status
Public property | TaskType | the type of the task
Public property | TaskTypeName | The name of the task type
Public property | WhenToRemind | The time when the reminder would go
Public property | WhoToRemind | The entity who would be reminded for the task

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


AccessAppend Property

[image]

OfficeClip API Documentation
TaskInfo..::.AccessAppend Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the task has append access

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool AccessAppend { get; }
Visual Basic (Declaration)
Public ReadOnly Property AccessAppend As Boolean
Visual C++
public:
property bool AccessAppend {
    bool get ();
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


AccessDelete Property

[image]

OfficeClip API Documentation
TaskInfo..::.AccessDelete Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the task has delete access

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool AccessDelete { get; }
Visual Basic (Declaration)
Public ReadOnly Property AccessDelete As Boolean
Visual C++
public:
property bool AccessDelete {
    bool get ();
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


AccessRead Property

[image]

OfficeClip API Documentation
TaskInfo..::.AccessRead Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the task has read access

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool AccessRead { get; }
Visual Basic (Declaration)
Public ReadOnly Property AccessRead As Boolean
Visual C++
public:
property bool AccessRead {
    bool get ();
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


AccessWrite Property

[image]

OfficeClip API Documentation
TaskInfo..::.AccessWrite Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the task has write access

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool AccessWrite { get; }
Visual Basic (Declaration)
Public ReadOnly Property AccessWrite As Boolean
Visual C++
public:
property bool AccessWrite {
    bool get ();
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ActualDuration Property

[image]

OfficeClip API Documentation
TaskInfo..::.ActualDuration Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Actual duration in minutes

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ActualDuration { get; set; }
Visual Basic (Declaration)
Public Property ActualDuration As Integer
Visual C++
public:
property int ActualDuration {
    int get ();
    void set (int value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


CompletionDate Property

[image]

OfficeClip API Documentation
TaskInfo..::.CompletionDate Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The completion date for the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CompletionDate { get; set; }
Visual Basic (Declaration)
Public Property CompletionDate As DateTime
Visual C++
public:
property DateTime CompletionDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


CreatedByTimestamp Property

[image]

OfficeClip API Documentation
TaskInfo..::.CreatedByTimestamp Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Timestamp of the creation of the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedByTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedByTimestamp As DateTime
Visual C++
public:
property DateTime CreatedByTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


CreatedByUserId Property

[image]

OfficeClip API Documentation
TaskInfo..::.CreatedByUserId Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the creator

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedByUserId { get; set; }
Visual Basic (Declaration)
Public Property CreatedByUserId As Integer
Visual C++
public:
property int CreatedByUserId {
    int get ();
    void set (int value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Description Property

[image]

OfficeClip API Documentation
TaskInfo..::.Description Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The description of the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


DueDate Property

[image]

OfficeClip API Documentation
TaskInfo..::.DueDate Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date when the task is due

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime DueDate { get; set; }
Visual Basic (Declaration)
Public Property DueDate As DateTime
Visual C++
public:
property DateTime DueDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


EstimatedDuration Property

[image]

OfficeClip API Documentation
TaskInfo..::.EstimatedDuration Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Estimated duration in minutes

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EstimatedDuration { get; set; }
Visual Basic (Declaration)
Public Property EstimatedDuration As Integer
Visual C++
public:
property int EstimatedDuration {
    int get ();
    void set (int value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


GroupId Property

[image]

OfficeClip API Documentation
TaskInfo..::.GroupId Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id iof the group

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


GroupName Property

[image]

OfficeClip API Documentation
TaskInfo..::.GroupName Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the group

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GroupName { get; set; }
Visual Basic (Declaration)
Public Property GroupName As String
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsPrivate Property

[image]

OfficeClip API Documentation
TaskInfo..::.IsPrivate Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the task is private

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsPrivate { get; set; }
Visual Basic (Declaration)
Public Property IsPrivate As Boolean
Visual C++
public:
property bool IsPrivate {
    bool get ();
    void set (bool value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


IsReminderSelected Property

[image]

OfficeClip API Documentation
TaskInfo..::.IsReminderSelected Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the reminder is selected for the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsReminderSelected { get; set; }
Visual Basic (Declaration)
Public Property IsReminderSelected As Boolean
Visual C++
public:
property bool IsReminderSelected {
    bool get ();
    void set (bool value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ModifiedByTimestamp Property

[image]

OfficeClip API Documentation
TaskInfo..::.ModifiedByTimestamp Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Timestamp of last modification

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ModifiedByTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ModifiedByTimestamp As DateTime
Visual C++
public:
property DateTime ModifiedByTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ModifiedByUserId Property

[image]

OfficeClip API Documentation
TaskInfo..::.ModifiedByUserId Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user who last modified the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ModifiedByUserId { get; set; }
Visual Basic (Declaration)
Public Property ModifiedByUserId As Integer
Visual C++
public:
property int ModifiedByUserId {
    int get ();
    void set (int value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ParentId Property

[image]

OfficeClip API Documentation
TaskInfo..::.ParentId Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The id of the parent object

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ParentId { get; set; }
Visual Basic (Declaration)
Public Property ParentId As Integer
Visual C++
public:
property int ParentId {
    int get ();
    void set (int value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


ParentObjectType Property

[image]

OfficeClip API Documentation
TaskInfo..::.ParentObjectType Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The type of the parent object

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants..::.ObjectType ParentObjectType { get; set; }
Visual Basic (Declaration)
Public Property ParentObjectType As BusinessConstants..::.ObjectType
Visual C++
public:
property BusinessConstants..::.ObjectType ParentObjectType {
    BusinessConstants..::.ObjectType get ();
    void set (BusinessConstants..::.ObjectType value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


PercentComplete Property

[image]

OfficeClip API Documentation
TaskInfo..::.PercentComplete Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The percent complete value for the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double PercentComplete { get; set; }
Visual Basic (Declaration)
Public Property PercentComplete As Double
Visual C++
public:
property double PercentComplete {
    double get ();
    void set (double value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Recurrence Property

[image]

OfficeClip API Documentation
TaskInfo..::.Recurrence Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The task recurrence object

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RecurrenceInfo Recurrence { get; set; }
Visual Basic (Declaration)
Public Property Recurrence As RecurrenceInfo
Visual C++
public:
property RecurrenceInfo^ Recurrence {
    RecurrenceInfo^ get ();
    void set (RecurrenceInfo^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Regarding Property

[image]

OfficeClip API Documentation
TaskInfo..::.Regarding Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The regarding string

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Regarding { get; set; }
Visual Basic (Declaration)
Public Property Regarding As String
Visual C++
public:
property String^ Regarding {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RemindAtDatetime Property

[image]

OfficeClip API Documentation
TaskInfo..::.RemindAtDatetime Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The exact date and time for the reminder

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime RemindAtDatetime { get; set; }
Visual Basic (Declaration)
Public Property RemindAtDatetime As DateTime
Visual C++
public:
property DateTime RemindAtDatetime {
    DateTime get ();
    void set (DateTime value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RepeatInfotext Property

[image]

OfficeClip API Documentation
TaskInfo..::.RepeatInfotext Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The text for the repeat information for the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RepeatInfotext { get; set; }
Visual Basic (Declaration)
Public Property RepeatInfotext As String
Visual C++
public:
property String^ RepeatInfotext {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


RepeatingSequenceId Property

[image]

OfficeClip API Documentation
TaskInfo..::.RepeatingSequenceId Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The if of the repeating sequence for the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RepeatingSequenceId { get; set; }
Visual Basic (Declaration)
Public Property RepeatingSequenceId As Integer
Visual C++
public:
property int RepeatingSequenceId {
    int get ();
    void set (int value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


StartDate Property

[image]

OfficeClip API Documentation
TaskInfo..::.StartDate Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The start date for the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic (Declaration)
Public Property StartDate As DateTime
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


Subject Property

[image]

OfficeClip API Documentation
TaskInfo..::.Subject Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The subject of the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Subject { get; set; }
Visual Basic (Declaration)
Public Property Subject As String
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskAssignments Property

[image]

OfficeClip API Documentation
TaskInfo..::.TaskAssignments Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Task Assignment string

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TaskAssignments { get; set; }
Visual Basic (Declaration)
Public Property TaskAssignments As String
Visual C++
public:
property String^ TaskAssignments {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskId Property

[image]

OfficeClip API Documentation
TaskInfo..::.TaskId Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id for the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TaskId { get; set; }
Visual Basic (Declaration)
Public Property TaskId As Integer
Visual C++
public:
property int TaskId {
    int get ();
    void set (int value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskOwnerId Property

[image]

OfficeClip API Documentation
TaskInfo..::.TaskOwnerId Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique user id of the task owner

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TaskOwnerId { get; set; }
Visual Basic (Declaration)
Public Property TaskOwnerId As Integer
Visual C++
public:
property int TaskOwnerId {
    int get ();
    void set (int value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskOwnerName Property

[image]

OfficeClip API Documentation
TaskInfo..::.TaskOwnerName Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

the name of the task owner

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TaskOwnerName { get; set; }
Visual Basic (Declaration)
Public Property TaskOwnerName As String
Visual C++
public:
property String^ TaskOwnerName {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskPriority Property

[image]

OfficeClip API Documentation
TaskInfo..::.TaskPriority Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The priority of the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants..::.TaskPriority TaskPriority { get; set; }
Visual Basic (Declaration)
Public Property TaskPriority As BusinessConstants..::.TaskPriority
Visual C++
public:
property BusinessConstants..::.TaskPriority TaskPriority {
    BusinessConstants..::.TaskPriority get ();
    void set (BusinessConstants..::.TaskPriority value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskPriorityName Property

[image]

OfficeClip API Documentation
TaskInfo..::.TaskPriorityName Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

the name of the task priority

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TaskPriorityName { get; set; }
Visual Basic (Declaration)
Public Property TaskPriorityName As String
Visual C++
public:
property String^ TaskPriorityName {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskStatus Property

[image]

OfficeClip API Documentation
TaskInfo..::.TaskStatus Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The status of the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants..::.TaskStatus TaskStatus { get; set; }
Visual Basic (Declaration)
Public Property TaskStatus As BusinessConstants..::.TaskStatus
Visual C++
public:
property BusinessConstants..::.TaskStatus TaskStatus {
    BusinessConstants..::.TaskStatus get ();
    void set (BusinessConstants..::.TaskStatus value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskStatusName Property

[image]

OfficeClip API Documentation
TaskInfo..::.TaskStatusName Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the task status

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TaskStatusName { get; set; }
Visual Basic (Declaration)
Public Property TaskStatusName As String
Visual C++
public:
property String^ TaskStatusName {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskType Property

[image]

OfficeClip API Documentation
TaskInfo..::.TaskType Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

the type of the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants..::.TaskTypes TaskType { get; set; }
Visual Basic (Declaration)
Public Property TaskType As BusinessConstants..::.TaskTypes
Visual C++
public:
property BusinessConstants..::.TaskTypes TaskType {
    BusinessConstants..::.TaskTypes get ();
    void set (BusinessConstants..::.TaskTypes value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


TaskTypeName Property

[image]

OfficeClip API Documentation
TaskInfo..::.TaskTypeName Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the task type

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TaskTypeName { get; set; }
Visual Basic (Declaration)
Public Property TaskTypeName As String
Visual C++
public:
property String^ TaskTypeName {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


WhenToRemind Property

[image]

OfficeClip API Documentation
TaskInfo..::.WhenToRemind Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time when the reminder would go

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string WhenToRemind { get; set; }
Visual Basic (Declaration)
Public Property WhenToRemind As String
Visual C++
public:
property String^ WhenToRemind {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


WhoToRemind Property

[image]

OfficeClip API Documentation
TaskInfo..::.WhoToRemind Property
TaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The entity who would be reminded for the task

Namespace: OfficeClip.BusinessLayer.Desktop
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string WhoToRemind { get; set; }
Visual Basic (Declaration)
Public Property WhoToRemind As String
Visual C++
public:
property String^ WhoToRemind {
    String^ get ();
    void set (String^ value);
}

See Also

TaskInfo Class
OfficeClip.BusinessLayer.Desktop Namespace


OfficeClip.BusinessLayer.Desktop.Email Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Desktop.Email Namespace

[This is preliminary documentation and is subject to change.]

Business Layer information for the email

Classes

 | Class | Description
Public class | EmailAccountInfo | Provides methods and properties to access the email account information.
Public class | EmailFolderInfo | Provides methods and properties to access the email folder information object.
Public class | EmailInfo | Provides methods and properties to access email information.
Public class | EmailPreferenceInfo | Provides the methods and properties for the email preference object.
Public class | EmailRuleInfo | Provides the members and properties to access the rmail rule information object.
Public class | emailSearchInfo | Provides the methods and desription for the email search information.
Public class | MailingListInfo | Provides methods and properties for the mailing list for sending emails.
Public class | MailingListMemberInfo | Provides the methods and properties to access the mailing list menber information.


EmailAccountInfo Class

[image]

OfficeClip API Documentation
EmailAccountInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the email account information.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class EmailAccountInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class EmailAccountInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class EmailAccountInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop.Email..::.EmailAccountInfo

See Also

EmailAccountInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailAccountInfo Members

[image] [image]

OfficeClip API Documentation
EmailAccountInfo Members
EmailAccountInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The EmailAccountInfo type exposes the following members.

Constructors

 | Name | Description
Public method | EmailAccountInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountEmailAddress | The email Address of the account.
Public property | ColorScheme | The color scheme of the account.
Public property | DeleteFromServer | The interval between sync
Public property | Direction | The direction of the account.
Public property | DownloadHeader | The interval between sync
Public property | DownloadMessageSize | The interval between sync
Public property | EmailAccountId | The sustem generated unique email account id.
Public property | EmailAccountName | The name of the email account.
Public property | InserverSecurity | The interval between sync
Public property | LeaveCopyOnServer | Shows if a copy of the email should be left on the server.
Public property | OutgoingServerName | The name of the outgoing server.
Public property | OutgoingServerNeedsAuthentication | Shows whether the outgoing server needs authentication.
Public property | OutgoingServerSameAsIncoming | Shows if the outgoing SMTP server is same as the incoming SMTP server.
Public property | OutgoingServerType | The type of the outgoing server.
Public property | OutgoingServerUserName | The user name of the outgoing server who has login previlege of the server.
Public property | OutgoingServerUserPassword | The Password of the outgoing server.
Public property | OutserverPortNumber | The interval between sync
Public property | OutserverSecurity | The interval between sync
Public property | PortNumber | The port number of the SMTP server for the email account.
Public property | ServerName | The name of the email server of the email account.
Public property | ServerTimeout | The server timeout in seconds.
Public property | ServerType | The server type of the email server.
Public property | SyncInterval | The interval between sync
Public property | UserId | The system generated unique user id for the user who the account belongs to.
Public property | UserName | The user name of the user who the account belongs to.
Public property | UserPassword | The Password for the account.

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailAccountInfo Constructor

[image] [image]

OfficeClip API Documentation
EmailAccountInfo Constructor
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | EmailAccountInfo()()() | The default constructor.
Public method | EmailAccountInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

EmailAccountInfo Class
EmailAccountInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailAccountInfo Constructor

[image]

OfficeClip API Documentation
EmailAccountInfo Constructor
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailAccountInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmailAccountInfo()

See Also

EmailAccountInfo Class
EmailAccountInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailAccountInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
EmailAccountInfo Constructor (SerializationInfo, StreamingContext)
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailAccountInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
EmailAccountInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

EmailAccountInfo Class
EmailAccountInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailAccountInfo Methods

[image] [image]

OfficeClip API Documentation
EmailAccountInfo Methods
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EmailAccountInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
EmailAccountInfo..::.GetObjectData Method
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailAccountInfo Properties

[image] [image]

OfficeClip API Documentation
EmailAccountInfo Properties
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EmailAccountInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountEmailAddress | The email Address of the account.
Public property | ColorScheme | The color scheme of the account.
Public property | DeleteFromServer | The interval between sync
Public property | Direction | The direction of the account.
Public property | DownloadHeader | The interval between sync
Public property | DownloadMessageSize | The interval between sync
Public property | EmailAccountId | The sustem generated unique email account id.
Public property | EmailAccountName | The name of the email account.
Public property | InserverSecurity | The interval between sync
Public property | LeaveCopyOnServer | Shows if a copy of the email should be left on the server.
Public property | OutgoingServerName | The name of the outgoing server.
Public property | OutgoingServerNeedsAuthentication | Shows whether the outgoing server needs authentication.
Public property | OutgoingServerSameAsIncoming | Shows if the outgoing SMTP server is same as the incoming SMTP server.
Public property | OutgoingServerType | The type of the outgoing server.
Public property | OutgoingServerUserName | The user name of the outgoing server who has login previlege of the server.
Public property | OutgoingServerUserPassword | The Password of the outgoing server.
Public property | OutserverPortNumber | The interval between sync
Public property | OutserverSecurity | The interval between sync
Public property | PortNumber | The port number of the SMTP server for the email account.
Public property | ServerName | The name of the email server of the email account.
Public property | ServerTimeout | The server timeout in seconds.
Public property | ServerType | The server type of the email server.
Public property | SyncInterval | The interval between sync
Public property | UserId | The system generated unique user id for the user who the account belongs to.
Public property | UserName | The user name of the user who the account belongs to.
Public property | UserPassword | The Password for the account.

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


AccountEmailAddress Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.AccountEmailAddress Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Address of the account.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AccountEmailAddress { get; set; }
Visual Basic (Declaration)
Public Property AccountEmailAddress As String
Visual C++
public:
property String^ AccountEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ColorScheme Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.ColorScheme Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The color scheme of the account.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ColorScheme { get; set; }
Visual Basic (Declaration)
Public Property ColorScheme As String
Visual C++
public:
property String^ ColorScheme {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


DeleteFromServer Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.DeleteFromServer Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The interval between sync

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DeleteFromServer { get; set; }
Visual Basic (Declaration)
Public Property DeleteFromServer As String
Visual C++
public:
property String^ DeleteFromServer {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


Direction Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.Direction Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The direction of the account.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants..::.EmailAccountDirection Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As BusinessConstants..::.EmailAccountDirection
Visual C++
public:
property BusinessConstants..::.EmailAccountDirection Direction {
    BusinessConstants..::.EmailAccountDirection get ();
    void set (BusinessConstants..::.EmailAccountDirection value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


DownloadHeader Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.DownloadHeader Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The interval between sync

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DownloadHeader { get; set; }
Visual Basic (Declaration)
Public Property DownloadHeader As String
Visual C++
public:
property String^ DownloadHeader {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


DownloadMessageSize Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.DownloadMessageSize Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The interval between sync

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int DownloadMessageSize { get; set; }
Visual Basic (Declaration)
Public Property DownloadMessageSize As Integer
Visual C++
public:
property int DownloadMessageSize {
    int get ();
    void set (int value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailAccountId Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.EmailAccountId Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The sustem generated unique email account id.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EmailAccountId { get; set; }
Visual Basic (Declaration)
Public Property EmailAccountId As Integer
Visual C++
public:
property int EmailAccountId {
    int get ();
    void set (int value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailAccountName Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.EmailAccountName Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the email account.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailAccountName { get; set; }
Visual Basic (Declaration)
Public Property EmailAccountName As String
Visual C++
public:
property String^ EmailAccountName {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


InserverSecurity Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.InserverSecurity Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The interval between sync

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string InserverSecurity { get; set; }
Visual Basic (Declaration)
Public Property InserverSecurity As String
Visual C++
public:
property String^ InserverSecurity {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


LeaveCopyOnServer Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.LeaveCopyOnServer Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if a copy of the email should be left on the server.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool LeaveCopyOnServer { get; set; }
Visual Basic (Declaration)
Public Property LeaveCopyOnServer As Boolean
Visual C++
public:
property bool LeaveCopyOnServer {
    bool get ();
    void set (bool value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


OutgoingServerName Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.OutgoingServerName Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the outgoing server.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string OutgoingServerName { get; set; }
Visual Basic (Declaration)
Public Property OutgoingServerName As String
Visual C++
public:
property String^ OutgoingServerName {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


OutgoingServerNeedsAuthentication Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.OutgoingServerNeedsAuthentication Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the outgoing server needs authentication.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool OutgoingServerNeedsAuthentication { get; set; }
Visual Basic (Declaration)
Public Property OutgoingServerNeedsAuthentication As Boolean
Visual C++
public:
property bool OutgoingServerNeedsAuthentication {
    bool get ();
    void set (bool value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


OutgoingServerSameAsIncoming Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.OutgoingServerSameAsIncoming Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the outgoing SMTP server is same as the incoming SMTP server.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool OutgoingServerSameAsIncoming { get; set; }
Visual Basic (Declaration)
Public Property OutgoingServerSameAsIncoming As Boolean
Visual C++
public:
property bool OutgoingServerSameAsIncoming {
    bool get ();
    void set (bool value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


OutgoingServerType Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.OutgoingServerType Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The type of the outgoing server.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string OutgoingServerType { get; set; }
Visual Basic (Declaration)
Public Property OutgoingServerType As String
Visual C++
public:
property String^ OutgoingServerType {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


OutgoingServerUserName Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.OutgoingServerUserName Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user name of the outgoing server who has login previlege of the server.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string OutgoingServerUserName { get; set; }
Visual Basic (Declaration)
Public Property OutgoingServerUserName As String
Visual C++
public:
property String^ OutgoingServerUserName {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


OutgoingServerUserPassword Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.OutgoingServerUserPassword Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Password of the outgoing server.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string OutgoingServerUserPassword { get; set; }
Visual Basic (Declaration)
Public Property OutgoingServerUserPassword As String
Visual C++
public:
property String^ OutgoingServerUserPassword {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


OutserverPortNumber Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.OutserverPortNumber Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The interval between sync

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int OutserverPortNumber { get; set; }
Visual Basic (Declaration)
Public Property OutserverPortNumber As Integer
Visual C++
public:
property int OutserverPortNumber {
    int get ();
    void set (int value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


OutserverSecurity Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.OutserverSecurity Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The interval between sync

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string OutserverSecurity { get; set; }
Visual Basic (Declaration)
Public Property OutserverSecurity As String
Visual C++
public:
property String^ OutserverSecurity {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


PortNumber Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.PortNumber Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The port number of the SMTP server for the email account.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int PortNumber { get; set; }
Visual Basic (Declaration)
Public Property PortNumber As Integer
Visual C++
public:
property int PortNumber {
    int get ();
    void set (int value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ServerName Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.ServerName Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the email server of the email account.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ServerName { get; set; }
Visual Basic (Declaration)
Public Property ServerName As String
Visual C++
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ServerTimeout Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.ServerTimeout Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The server timeout in seconds.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ServerTimeout { get; set; }
Visual Basic (Declaration)
Public Property ServerTimeout As Integer
Visual C++
public:
property int ServerTimeout {
    int get ();
    void set (int value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ServerType Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.ServerType Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The server type of the email server.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ServerType { get; set; }
Visual Basic (Declaration)
Public Property ServerType As String
Visual C++
public:
property String^ ServerType {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


SyncInterval Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.SyncInterval Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The interval between sync

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SyncInterval { get; set; }
Visual Basic (Declaration)
Public Property SyncInterval As Integer
Visual C++
public:
property int SyncInterval {
    int get ();
    void set (int value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


UserId Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.UserId Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique user id for the user who the account belongs to.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


UserName Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.UserName Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user name of the user who the account belongs to.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


UserPassword Property

[image]

OfficeClip API Documentation
EmailAccountInfo..::.UserPassword Property
EmailAccountInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Password for the account.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UserPassword { get; set; }
Visual Basic (Declaration)
Public Property UserPassword As String
Visual C++
public:
property String^ UserPassword {
    String^ get ();
    void set (String^ value);
}

See Also

EmailAccountInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderInfo Class

[image]

OfficeClip API Documentation
EmailFolderInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the email folder information object.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class EmailFolderInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class EmailFolderInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class EmailFolderInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop.Email..::.EmailFolderInfo

See Also

EmailFolderInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderInfo Members

[image] [image]

OfficeClip API Documentation
EmailFolderInfo Members
EmailFolderInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The EmailFolderInfo type exposes the following members.

Constructors

 | Name | Description
Public method | EmailFolderInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedTimestamp | The created Timestamp of the email folder.
Public property | EmailFolderId | The unique id of the email folder.
Public property | EmailFolderName | The name of the email folder.
Public property | EmailFolderTypeId | The id of the folder type of the email folder.
Public property | IsEmptyAllowed | Shows if the empty email folder is allowed.
Public property | ModifiedTimestamp | The Timestamp when the folder was last modified.
Public property | UserId | the system generated unique id of the user who owns the email folder.

See Also

EmailFolderInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderInfo Constructor

[image] [image]

OfficeClip API Documentation
EmailFolderInfo Constructor
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | EmailFolderInfo()()() | The default constructor.
Public method | EmailFolderInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

EmailFolderInfo Class
EmailFolderInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderInfo Constructor

[image]

OfficeClip API Documentation
EmailFolderInfo Constructor
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailFolderInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmailFolderInfo()

See Also

EmailFolderInfo Class
EmailFolderInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
EmailFolderInfo Constructor (SerializationInfo, StreamingContext)
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailFolderInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
EmailFolderInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Exceptions

Exception | Condition
OfficeClip.Utils..::.OCException |

See Also

EmailFolderInfo Class
EmailFolderInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderInfo Methods

[image] [image]

OfficeClip API Documentation
EmailFolderInfo Methods
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EmailFolderInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailFolderInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
EmailFolderInfo..::.GetObjectData Method
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

EmailFolderInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderInfo Properties

[image] [image]

OfficeClip API Documentation
EmailFolderInfo Properties
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EmailFolderInfo type exposes the following properties.

Properties

 | Name | Description
Public property | CreatedTimestamp | The created Timestamp of the email folder.
Public property | EmailFolderId | The unique id of the email folder.
Public property | EmailFolderName | The name of the email folder.
Public property | EmailFolderTypeId | The id of the folder type of the email folder.
Public property | IsEmptyAllowed | Shows if the empty email folder is allowed.
Public property | ModifiedTimestamp | The Timestamp when the folder was last modified.
Public property | UserId | the system generated unique id of the user who owns the email folder.

See Also

EmailFolderInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


CreatedTimestamp Property

[image]

OfficeClip API Documentation
EmailFolderInfo..::.CreatedTimestamp Property
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The created Timestamp of the email folder.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedTimestamp As DateTime
Visual C++
public:
property DateTime CreatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

EmailFolderInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderId Property

[image]

OfficeClip API Documentation
EmailFolderInfo..::.EmailFolderId Property
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the email folder.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EmailFolderId { get; set; }
Visual Basic (Declaration)
Public Property EmailFolderId As Integer
Visual C++
public:
property int EmailFolderId {
    int get ();
    void set (int value);
}

See Also

EmailFolderInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderName Property

[image]

OfficeClip API Documentation
EmailFolderInfo..::.EmailFolderName Property
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the email folder.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailFolderName { get; set; }
Visual Basic (Declaration)
Public Property EmailFolderName As String
Visual C++
public:
property String^ EmailFolderName {
    String^ get ();
    void set (String^ value);
}

See Also

EmailFolderInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderTypeId Property

[image]

OfficeClip API Documentation
EmailFolderInfo..::.EmailFolderTypeId Property
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The id of the folder type of the email folder.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EmailFolderTypeId { get; set; }
Visual Basic (Declaration)
Public Property EmailFolderTypeId As Integer
Visual C++
public:
property int EmailFolderTypeId {
    int get ();
    void set (int value);
}

See Also

EmailFolderInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


IsEmptyAllowed Property

[image]

OfficeClip API Documentation
EmailFolderInfo..::.IsEmptyAllowed Property
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the empty email folder is allowed.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsEmptyAllowed { get; set; }
Visual Basic (Declaration)
Public Property IsEmptyAllowed As String
Visual C++
public:
property String^ IsEmptyAllowed {
    String^ get ();
    void set (String^ value);
}

See Also

EmailFolderInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ModifiedTimestamp Property

[image]

OfficeClip API Documentation
EmailFolderInfo..::.ModifiedTimestamp Property
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp when the folder was last modified.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ModifiedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ModifiedTimestamp As DateTime
Visual C++
public:
property DateTime ModifiedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

EmailFolderInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


UserId Property

[image]

OfficeClip API Documentation
EmailFolderInfo..::.UserId Property
EmailFolderInfo Class See Also

[This is preliminary documentation and is subject to change.]

the system generated unique id of the user who owns the email folder.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

EmailFolderInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailInfo Class

[image]

OfficeClip API Documentation
EmailInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access email information.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class EmailInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class EmailInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class EmailInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop.Email..::.EmailInfo

See Also

EmailInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailInfo Members

[image] [image]

OfficeClip API Documentation
EmailInfo Members
EmailInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The EmailInfo type exposes the following members.

Constructors

 | Name | Description
Public method | EmailInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedTimestamp | the Timestamp when this email was created.
Public property | EmailAccountId | The account id of the account which contains this email.
Public property | EmailFolderId | The folder id of the folder where the email belongs.
Public property | EmailFolderTypeId | The type of the folder which contains this email.
Public property | EmailId | The system generated unique identifier for the email.
Public property | EmailStatus | The Status of the email.
Public property | ForwardedTimestamp | The Timestamp on when this email was last forwarded to an user.
Public property | ForwardFromEmailId | The email id from where this email was forwarded from.
Public property | FromEmailAddress | The from email address
Public property | IsAttachmentPresent | Shows if the attachment is present
Public property | MessageId | The identifier for the message for the email.
Public property | Priority | The email priority, valid values are "Normal", "High" and "Low"
Public property | ReceivedTimestamp | The Timestamp when this email was received by the user.
Public property | RepliedTimestamp | The Timestamp when this email was replied.
Public property | ReplyToEmailId | The identifier for the Reply To:
Public property | SentTimestamp | The Timestamp when this email was sent.
Public property | Size | The email size
Public property | Subject | The email subject
Public property | ToEmailAddress | The to email address
Public property | UserId | The unique id of the user who owns this email.

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailInfo Constructor

[image] [image]

OfficeClip API Documentation
EmailInfo Constructor
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | EmailInfo()()() | The default constructor.
Public method | EmailInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

EmailInfo Class
EmailInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailInfo Constructor

[image]

OfficeClip API Documentation
EmailInfo Constructor
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmailInfo()

See Also

EmailInfo Class
EmailInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
EmailInfo Constructor (SerializationInfo, StreamingContext)
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
EmailInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

EmailInfo Class
EmailInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailInfo Methods

[image] [image]

OfficeClip API Documentation
EmailInfo Methods
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EmailInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
EmailInfo..::.GetObjectData Method
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailInfo Properties

[image] [image]

OfficeClip API Documentation
EmailInfo Properties
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EmailInfo type exposes the following properties.

Properties

 | Name | Description
Public property | CreatedTimestamp | the Timestamp when this email was created.
Public property | EmailAccountId | The account id of the account which contains this email.
Public property | EmailFolderId | The folder id of the folder where the email belongs.
Public property | EmailFolderTypeId | The type of the folder which contains this email.
Public property | EmailId | The system generated unique identifier for the email.
Public property | EmailStatus | The Status of the email.
Public property | ForwardedTimestamp | The Timestamp on when this email was last forwarded to an user.
Public property | ForwardFromEmailId | The email id from where this email was forwarded from.
Public property | FromEmailAddress | The from email address
Public property | IsAttachmentPresent | Shows if the attachment is present
Public property | MessageId | The identifier for the message for the email.
Public property | Priority | The email priority, valid values are "Normal", "High" and "Low"
Public property | ReceivedTimestamp | The Timestamp when this email was received by the user.
Public property | RepliedTimestamp | The Timestamp when this email was replied.
Public property | ReplyToEmailId | The identifier for the Reply To:
Public property | SentTimestamp | The Timestamp when this email was sent.
Public property | Size | The email size
Public property | Subject | The email subject
Public property | ToEmailAddress | The to email address
Public property | UserId | The unique id of the user who owns this email.

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


CreatedTimestamp Property

[image]

OfficeClip API Documentation
EmailInfo..::.CreatedTimestamp Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

the Timestamp when this email was created.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedTimestamp As DateTime
Visual C++
public:
property DateTime CreatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailAccountId Property

[image]

OfficeClip API Documentation
EmailInfo..::.EmailAccountId Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The account id of the account which contains this email.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EmailAccountId { get; set; }
Visual Basic (Declaration)
Public Property EmailAccountId As Integer
Visual C++
public:
property int EmailAccountId {
    int get ();
    void set (int value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderId Property

[image]

OfficeClip API Documentation
EmailInfo..::.EmailFolderId Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The folder id of the folder where the email belongs.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EmailFolderId { get; set; }
Visual Basic (Declaration)
Public Property EmailFolderId As Integer
Visual C++
public:
property int EmailFolderId {
    int get ();
    void set (int value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailFolderTypeId Property

[image]

OfficeClip API Documentation
EmailInfo..::.EmailFolderTypeId Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The type of the folder which contains this email.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EmailFolderTypeId { get; set; }
Visual Basic (Declaration)
Public Property EmailFolderTypeId As Integer
Visual C++
public:
property int EmailFolderTypeId {
    int get ();
    void set (int value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailId Property

[image]

OfficeClip API Documentation
EmailInfo..::.EmailId Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the email.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EmailId { get; set; }
Visual Basic (Declaration)
Public Property EmailId As Integer
Visual C++
public:
property int EmailId {
    int get ();
    void set (int value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailStatus Property

[image]

OfficeClip API Documentation
EmailInfo..::.EmailStatus Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Status of the email.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailStatus EmailStatus { get; set; }
Visual Basic (Declaration)
Public Property EmailStatus As EmailStatus
Visual C++
public:
property EmailStatus EmailStatus {
    EmailStatus get ();
    void set (EmailStatus value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ForwardedTimestamp Property

[image]

OfficeClip API Documentation
EmailInfo..::.ForwardedTimestamp Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp on when this email was last forwarded to an user.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ForwardedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ForwardedTimestamp As DateTime
Visual C++
public:
property DateTime ForwardedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ForwardFromEmailId Property

[image]

OfficeClip API Documentation
EmailInfo..::.ForwardFromEmailId Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email id from where this email was forwarded from.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ForwardFromEmailId { get; set; }
Visual Basic (Declaration)
Public Property ForwardFromEmailId As Integer
Visual C++
public:
property int ForwardFromEmailId {
    int get ();
    void set (int value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


FromEmailAddress Property

[image]

OfficeClip API Documentation
EmailInfo..::.FromEmailAddress Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The from email address

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FromEmailAddress { get; set; }
Visual Basic (Declaration)
Public Property FromEmailAddress As String
Visual C++
public:
property String^ FromEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


IsAttachmentPresent Property

[image]

OfficeClip API Documentation
EmailInfo..::.IsAttachmentPresent Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the attachment is present

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAttachmentPresent { get; set; }
Visual Basic (Declaration)
Public Property IsAttachmentPresent As Boolean
Visual C++
public:
property bool IsAttachmentPresent {
    bool get ();
    void set (bool value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MessageId Property

[image]

OfficeClip API Documentation
EmailInfo..::.MessageId Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the message for the email.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string MessageId { get; set; }
Visual Basic (Declaration)
Public Property MessageId As String
Visual C++
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


Priority Property

[image]

OfficeClip API Documentation
EmailInfo..::.Priority Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email priority, valid values are "Normal", "High" and "Low"

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Priority { get; set; }
Visual Basic (Declaration)
Public Property Priority As String
Visual C++
public:
property String^ Priority {
    String^ get ();
    void set (String^ value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ReceivedTimestamp Property

[image]

OfficeClip API Documentation
EmailInfo..::.ReceivedTimestamp Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp when this email was received by the user.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ReceivedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ReceivedTimestamp As DateTime
Visual C++
public:
property DateTime ReceivedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


RepliedTimestamp Property

[image]

OfficeClip API Documentation
EmailInfo..::.RepliedTimestamp Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp when this email was replied.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime RepliedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property RepliedTimestamp As DateTime
Visual C++
public:
property DateTime RepliedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ReplyToEmailId Property

[image]

OfficeClip API Documentation
EmailInfo..::.ReplyToEmailId Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the Reply To:

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ReplyToEmailId { get; set; }
Visual Basic (Declaration)
Public Property ReplyToEmailId As Integer
Visual C++
public:
property int ReplyToEmailId {
    int get ();
    void set (int value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


SentTimestamp Property

[image]

OfficeClip API Documentation
EmailInfo..::.SentTimestamp Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp when this email was sent.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime SentTimestamp { get; set; }
Visual Basic (Declaration)
Public Property SentTimestamp As DateTime
Visual C++
public:
property DateTime SentTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


Size Property

[image]

OfficeClip API Documentation
EmailInfo..::.Size Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email size

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public long Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Long
Visual C++
public:
property long long Size {
    long long get ();
    void set (long long value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


Subject Property

[image]

OfficeClip API Documentation
EmailInfo..::.Subject Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email subject

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Subject { get; set; }
Visual Basic (Declaration)
Public Property Subject As String
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ToEmailAddress Property

[image]

OfficeClip API Documentation
EmailInfo..::.ToEmailAddress Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The to email address

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToEmailAddress { get; set; }
Visual Basic (Declaration)
Public Property ToEmailAddress As String
Visual C++
public:
property String^ ToEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


UserId Property

[image]

OfficeClip API Documentation
EmailInfo..::.UserId Property
EmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user who owns this email.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

EmailInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailPreferenceInfo Class

[image]

OfficeClip API Documentation
EmailPreferenceInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides the methods and properties for the email preference object.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class EmailPreferenceInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class EmailPreferenceInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class EmailPreferenceInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop.Email..::.EmailPreferenceInfo

See Also

EmailPreferenceInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailPreferenceInfo Members

[image] [image]

OfficeClip API Documentation
EmailPreferenceInfo Members
EmailPreferenceInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The EmailPreferenceInfo type exposes the following members.

Constructors

 | Name | Description
Public method | EmailPreferenceInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsCheckOnStart | Determines whether the new emails are checked when the email application is started
Public property | IsSaveMessage | Determines whether the sent out messages are saved by default on the sent folder
Public property | ReplyIncludeOriginalText | shows whether the reply includes the original text.
Public property | ReplyOriginalTextIndicator | The indicator to show the original text with the reply.
Public property | ReplyToAddress | The Reply To Address for the email preference.
Public property | SendAccountId | The default account id from which all emails will be sent
Public property | Signature | The Signature of the user who owns the email preference.
Public property | UseRichTextFormat | Shows whether the Rich Text Format is used for composing emails.
Public property | UserId | The system generated unique id of the user who owns the email preference.

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailPreferenceInfo Constructor

[image] [image]

OfficeClip API Documentation
EmailPreferenceInfo Constructor
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | EmailPreferenceInfo()()() | The default constructor.
Public method | EmailPreferenceInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

EmailPreferenceInfo Class
EmailPreferenceInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailPreferenceInfo Constructor

[image]

OfficeClip API Documentation
EmailPreferenceInfo Constructor
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailPreferenceInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmailPreferenceInfo()

See Also

EmailPreferenceInfo Class
EmailPreferenceInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailPreferenceInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
EmailPreferenceInfo Constructor (SerializationInfo, StreamingContext)
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailPreferenceInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
EmailPreferenceInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

EmailPreferenceInfo Class
EmailPreferenceInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailPreferenceInfo Methods

[image] [image]

OfficeClip API Documentation
EmailPreferenceInfo Methods
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EmailPreferenceInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
EmailPreferenceInfo..::.GetObjectData Method
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailPreferenceInfo Properties

[image] [image]

OfficeClip API Documentation
EmailPreferenceInfo Properties
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EmailPreferenceInfo type exposes the following properties.

Properties

 | Name | Description
Public property | IsCheckOnStart | Determines whether the new emails are checked when the email application is started
Public property | IsSaveMessage | Determines whether the sent out messages are saved by default on the sent folder
Public property | ReplyIncludeOriginalText | shows whether the reply includes the original text.
Public property | ReplyOriginalTextIndicator | The indicator to show the original text with the reply.
Public property | ReplyToAddress | The Reply To Address for the email preference.
Public property | SendAccountId | The default account id from which all emails will be sent
Public property | Signature | The Signature of the user who owns the email preference.
Public property | UseRichTextFormat | Shows whether the Rich Text Format is used for composing emails.
Public property | UserId | The system generated unique id of the user who owns the email preference.

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


IsCheckOnStart Property

[image]

OfficeClip API Documentation
EmailPreferenceInfo..::.IsCheckOnStart Property
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Determines whether the new emails are checked when the email application is started

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsCheckOnStart { get; set; }
Visual Basic (Declaration)
Public Property IsCheckOnStart As Boolean
Visual C++
public:
property bool IsCheckOnStart {
    bool get ();
    void set (bool value);
}

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


IsSaveMessage Property

[image]

OfficeClip API Documentation
EmailPreferenceInfo..::.IsSaveMessage Property
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Determines whether the sent out messages are saved by default on the sent folder

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSaveMessage { get; set; }
Visual Basic (Declaration)
Public Property IsSaveMessage As Boolean
Visual C++
public:
property bool IsSaveMessage {
    bool get ();
    void set (bool value);
}

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ReplyIncludeOriginalText Property

[image]

OfficeClip API Documentation
EmailPreferenceInfo..::.ReplyIncludeOriginalText Property
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

shows whether the reply includes the original text.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool ReplyIncludeOriginalText { get; set; }
Visual Basic (Declaration)
Public Property ReplyIncludeOriginalText As Boolean
Visual C++
public:
property bool ReplyIncludeOriginalText {
    bool get ();
    void set (bool value);
}

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ReplyOriginalTextIndicator Property

[image]

OfficeClip API Documentation
EmailPreferenceInfo..::.ReplyOriginalTextIndicator Property
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The indicator to show the original text with the reply.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReplyOriginalTextIndicator { get; set; }
Visual Basic (Declaration)
Public Property ReplyOriginalTextIndicator As String
Visual C++
public:
property String^ ReplyOriginalTextIndicator {
    String^ get ();
    void set (String^ value);
}

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ReplyToAddress Property

[image]

OfficeClip API Documentation
EmailPreferenceInfo..::.ReplyToAddress Property
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Reply To Address for the email preference.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReplyToAddress { get; set; }
Visual Basic (Declaration)
Public Property ReplyToAddress As String
Visual C++
public:
property String^ ReplyToAddress {
    String^ get ();
    void set (String^ value);
}

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


SendAccountId Property

[image]

OfficeClip API Documentation
EmailPreferenceInfo..::.SendAccountId Property
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default account id from which all emails will be sent

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SendAccountId { get; set; }
Visual Basic (Declaration)
Public Property SendAccountId As Integer
Visual C++
public:
property int SendAccountId {
    int get ();
    void set (int value);
}

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


Signature Property

[image]

OfficeClip API Documentation
EmailPreferenceInfo..::.Signature Property
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Signature of the user who owns the email preference.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Signature { get; set; }
Visual Basic (Declaration)
Public Property Signature As String
Visual C++
public:
property String^ Signature {
    String^ get ();
    void set (String^ value);
}

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


UseRichTextFormat Property

[image]

OfficeClip API Documentation
EmailPreferenceInfo..::.UseRichTextFormat Property
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the Rich Text Format is used for composing emails.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool UseRichTextFormat { get; set; }
Visual Basic (Declaration)
Public Property UseRichTextFormat As Boolean
Visual C++
public:
property bool UseRichTextFormat {
    bool get ();
    void set (bool value);
}

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


UserId Property

[image]

OfficeClip API Documentation
EmailPreferenceInfo..::.UserId Property
EmailPreferenceInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique id of the user who owns the email preference.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

EmailPreferenceInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailRuleInfo Class

[image]

OfficeClip API Documentation
EmailRuleInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides the members and properties to access the rmail rule information object.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class EmailRuleInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class EmailRuleInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class EmailRuleInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop.Email..::.EmailRuleInfo

See Also

EmailRuleInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailRuleInfo Members

[image] [image]

OfficeClip API Documentation
EmailRuleInfo Members
EmailRuleInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The EmailRuleInfo type exposes the following members.

Constructors

 | Name | Description
Public method | EmailRuleInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActionId | The Action id of the email rule.
Public property | ActionValue | The Action value of the email rule.
Public property | ConditionFieldId | The condition field id of the email rule.
Public property | ConditionId | The condition id of the email rule.
Public property | ConditionValue | The condition value of the email rule.
Public property | ConditionValueId | The condition value id of the email rule.
Public property | EmailRuleId | The unique id for the email rule.
Public property | RuleOrderNumber | The rule order number of the email rule.
Public property | UserId | The user id of the user to whom this rule belongs.

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailRuleInfo Constructor

[image] [image]

OfficeClip API Documentation
EmailRuleInfo Constructor
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | EmailRuleInfo()()() | The default constructor.
Public method | EmailRuleInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

EmailRuleInfo Class
EmailRuleInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailRuleInfo Constructor

[image]

OfficeClip API Documentation
EmailRuleInfo Constructor
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailRuleInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmailRuleInfo()

See Also

EmailRuleInfo Class
EmailRuleInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailRuleInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
EmailRuleInfo Constructor (SerializationInfo, StreamingContext)
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailRuleInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
EmailRuleInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

EmailRuleInfo Class
EmailRuleInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailRuleInfo Methods

[image] [image]

OfficeClip API Documentation
EmailRuleInfo Methods
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EmailRuleInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
EmailRuleInfo..::.GetObjectData Method
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailRuleInfo Properties

[image] [image]

OfficeClip API Documentation
EmailRuleInfo Properties
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The EmailRuleInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ActionId | The Action id of the email rule.
Public property | ActionValue | The Action value of the email rule.
Public property | ConditionFieldId | The condition field id of the email rule.
Public property | ConditionId | The condition id of the email rule.
Public property | ConditionValue | The condition value of the email rule.
Public property | ConditionValueId | The condition value id of the email rule.
Public property | EmailRuleId | The unique id for the email rule.
Public property | RuleOrderNumber | The rule order number of the email rule.
Public property | UserId | The user id of the user to whom this rule belongs.

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ActionId Property

[image]

OfficeClip API Documentation
EmailRuleInfo..::.ActionId Property
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Action id of the email rule.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ActionId { get; set; }
Visual Basic (Declaration)
Public Property ActionId As Integer
Visual C++
public:
property int ActionId {
    int get ();
    void set (int value);
}

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ActionValue Property

[image]

OfficeClip API Documentation
EmailRuleInfo..::.ActionValue Property
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Action value of the email rule.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ActionValue { get; set; }
Visual Basic (Declaration)
Public Property ActionValue As String
Visual C++
public:
property String^ ActionValue {
    String^ get ();
    void set (String^ value);
}

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ConditionFieldId Property

[image]

OfficeClip API Documentation
EmailRuleInfo..::.ConditionFieldId Property
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The condition field id of the email rule.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ConditionFieldId { get; set; }
Visual Basic (Declaration)
Public Property ConditionFieldId As Integer
Visual C++
public:
property int ConditionFieldId {
    int get ();
    void set (int value);
}

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ConditionId Property

[image]

OfficeClip API Documentation
EmailRuleInfo..::.ConditionId Property
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The condition id of the email rule.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ConditionId { get; set; }
Visual Basic (Declaration)
Public Property ConditionId As Integer
Visual C++
public:
property int ConditionId {
    int get ();
    void set (int value);
}

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ConditionValue Property

[image]

OfficeClip API Documentation
EmailRuleInfo..::.ConditionValue Property
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The condition value of the email rule.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ConditionValue { get; set; }
Visual Basic (Declaration)
Public Property ConditionValue As String
Visual C++
public:
property String^ ConditionValue {
    String^ get ();
    void set (String^ value);
}

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ConditionValueId Property

[image]

OfficeClip API Documentation
EmailRuleInfo..::.ConditionValueId Property
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The condition value id of the email rule.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ConditionValueId { get; set; }
Visual Basic (Declaration)
Public Property ConditionValueId As Integer
Visual C++
public:
property int ConditionValueId {
    int get ();
    void set (int value);
}

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailRuleId Property

[image]

OfficeClip API Documentation
EmailRuleInfo..::.EmailRuleId Property
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id for the email rule.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EmailRuleId { get; set; }
Visual Basic (Declaration)
Public Property EmailRuleId As Integer
Visual C++
public:
property int EmailRuleId {
    int get ();
    void set (int value);
}

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


RuleOrderNumber Property

[image]

OfficeClip API Documentation
EmailRuleInfo..::.RuleOrderNumber Property
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The rule order number of the email rule.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RuleOrderNumber { get; set; }
Visual Basic (Declaration)
Public Property RuleOrderNumber As Integer
Visual C++
public:
property int RuleOrderNumber {
    int get ();
    void set (int value);
}

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


UserId Property

[image]

OfficeClip API Documentation
EmailRuleInfo..::.UserId Property
EmailRuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user id of the user to whom this rule belongs.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

EmailRuleInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


emailSearchInfo Class

[image]

OfficeClip API Documentation
emailSearchInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides the methods and desription for the email search information.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class emailSearchInfo
Visual Basic (Declaration)
Public Class emailSearchInfo
Visual C++
public ref class emailSearchInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop.Email..::.emailSearchInfo

See Also

emailSearchInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


emailSearchInfo Members

[image] [image]

OfficeClip API Documentation
emailSearchInfo Members
emailSearchInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The emailSearchInfo type exposes the following members.

Constructors

 | Name | Description
Public method | emailSearchInfo | The default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttachmentStatus | The email attachment Status as a search field.
Public property | EmailSearchBySize | The email size as a search field.
Public property | EmailSearchByTime | The timespan for the email search.
Public property | EmailStatus | The email Status as a search field.
Public property | EmailTimestamp | The email Timestamp field.
Public property | FromEmailAddress | The From email Address search in field.
Public property | Priority | The email Priority as a search field.
Public property | SearchForText | The text to search for.
Public property | SearchIn | The search in field.
Public property | SizeValue1 | The from value of the size in the email search field.
Public property | SizeValue2 | The To value of the size in the email search field.
Public property | ToEmailAddress | The To Email Address search in field.

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


emailSearchInfo Constructor

[image]

OfficeClip API Documentation
emailSearchInfo Constructor
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public emailSearchInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
emailSearchInfo()

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


emailSearchInfo Properties

[image] [image]

OfficeClip API Documentation
emailSearchInfo Properties
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The emailSearchInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AttachmentStatus | The email attachment Status as a search field.
Public property | EmailSearchBySize | The email size as a search field.
Public property | EmailSearchByTime | The timespan for the email search.
Public property | EmailStatus | The email Status as a search field.
Public property | EmailTimestamp | The email Timestamp field.
Public property | FromEmailAddress | The From email Address search in field.
Public property | Priority | The email Priority as a search field.
Public property | SearchForText | The text to search for.
Public property | SearchIn | The search in field.
Public property | SizeValue1 | The from value of the size in the email search field.
Public property | SizeValue2 | The To value of the size in the email search field.
Public property | ToEmailAddress | The To Email Address search in field.

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


AttachmentStatus Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.AttachmentStatus Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email attachment Status as a search field.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailAttachmentStatus AttachmentStatus { get; set; }
Visual Basic (Declaration)
Public Property AttachmentStatus As EmailAttachmentStatus
Visual C++
public:
property EmailAttachmentStatus AttachmentStatus {
    EmailAttachmentStatus get ();
    void set (EmailAttachmentStatus value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailSearchBySize Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.EmailSearchBySize Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email size as a search field.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailSearchBySize EmailSearchBySize { get; set; }
Visual Basic (Declaration)
Public Property EmailSearchBySize As EmailSearchBySize
Visual C++
public:
property EmailSearchBySize EmailSearchBySize {
    EmailSearchBySize get ();
    void set (EmailSearchBySize value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailSearchByTime Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.EmailSearchByTime Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The timespan for the email search.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailSearchByTime EmailSearchByTime { get; set; }
Visual Basic (Declaration)
Public Property EmailSearchByTime As EmailSearchByTime
Visual C++
public:
property EmailSearchByTime EmailSearchByTime {
    EmailSearchByTime get ();
    void set (EmailSearchByTime value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailStatus Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.EmailStatus Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Status as a search field.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailStatus EmailStatus { get; set; }
Visual Basic (Declaration)
Public Property EmailStatus As EmailStatus
Visual C++
public:
property EmailStatus EmailStatus {
    EmailStatus get ();
    void set (EmailStatus value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


EmailTimestamp Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.EmailTimestamp Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Timestamp field.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailTimestamps EmailTimestamp { get; set; }
Visual Basic (Declaration)
Public Property EmailTimestamp As EmailTimestamps
Visual C++
public:
property EmailTimestamps EmailTimestamp {
    EmailTimestamps get ();
    void set (EmailTimestamps value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


FromEmailAddress Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.FromEmailAddress Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The From email Address search in field.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FromEmailAddress { get; set; }
Visual Basic (Declaration)
Public Property FromEmailAddress As String
Visual C++
public:
property String^ FromEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


Priority Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.Priority Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Priority as a search field.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailPriority Priority { get; set; }
Visual Basic (Declaration)
Public Property Priority As EmailPriority
Visual C++
public:
property EmailPriority Priority {
    EmailPriority get ();
    void set (EmailPriority value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


SearchForText Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.SearchForText Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The text to search for.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SearchForText { get; set; }
Visual Basic (Declaration)
Public Property SearchForText As String
Visual C++
public:
property String^ SearchForText {
    String^ get ();
    void set (String^ value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


SearchIn Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.SearchIn Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The search in field.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EmailSearchIn SearchIn { get; set; }
Visual Basic (Declaration)
Public Property SearchIn As EmailSearchIn
Visual C++
public:
property EmailSearchIn SearchIn {
    EmailSearchIn get ();
    void set (EmailSearchIn value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


SizeValue1 Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.SizeValue1 Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The from value of the size in the email search field.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SizeValue1 { get; set; }
Visual Basic (Declaration)
Public Property SizeValue1 As Integer
Visual C++
public:
property int SizeValue1 {
    int get ();
    void set (int value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


SizeValue2 Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.SizeValue2 Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The To value of the size in the email search field.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SizeValue2 { get; set; }
Visual Basic (Declaration)
Public Property SizeValue2 As Integer
Visual C++
public:
property int SizeValue2 {
    int get ();
    void set (int value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ToEmailAddress Property

[image]

OfficeClip API Documentation
emailSearchInfo..::.ToEmailAddress Property
emailSearchInfo Class See Also

[This is preliminary documentation and is subject to change.]

The To Email Address search in field.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToEmailAddress { get; set; }
Visual Basic (Declaration)
Public Property ToEmailAddress As String
Visual C++
public:
property String^ ToEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

emailSearchInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListInfo Class

[image]

OfficeClip API Documentation
MailingListInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties for the mailing list for sending emails.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class MailingListInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MailingListInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class MailingListInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop.Email..::.MailingListInfo

See Also

MailingListInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListInfo Members

[image] [image]

OfficeClip API Documentation
MailingListInfo Members
MailingListInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MailingListInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MailingListInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAlreadyPresent | Shows whether the mailing list is already present.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedTimestamp | The time at which the mailing list is created.
Public property | MailingListId | The system dependent unique identifier for the mailing list.
Public property | MailingListMembers | The list of mailing list members.
Public property | MailingListName | The name of the mailing list.
Public property | ModifiedTimestamp | The time when the mailing list was last modified.
Public property | UserId | The identifier of the user who created the mailing list.

See Also

MailingListInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListInfo Constructor

[image] [image]

OfficeClip API Documentation
MailingListInfo Constructor
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MailingListInfo()()() | The default constructor.
Public method | MailingListInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

MailingListInfo Class
MailingListInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListInfo Constructor

[image]

OfficeClip API Documentation
MailingListInfo Constructor
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MailingListInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MailingListInfo()

See Also

MailingListInfo Class
MailingListInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
MailingListInfo Constructor (SerializationInfo, StreamingContext)
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MailingListInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
MailingListInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

MailingListInfo Class
MailingListInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListInfo Methods

[image] [image]

OfficeClip API Documentation
MailingListInfo Methods
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MailingListInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAlreadyPresent | Shows whether the mailing list is already present.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MailingListInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
MailingListInfo..::.GetObjectData Method
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

MailingListInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


IsAlreadyPresent Method

[image]

OfficeClip API Documentation
MailingListInfo..::.IsAlreadyPresent Method
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the mailing list is already present.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAlreadyPresent(
    string emailAddress
)
Visual Basic (Declaration)
Public Function IsAlreadyPresent ( _
    emailAddress As String _
) As Boolean
Visual C++
public:
bool IsAlreadyPresent(
    String^ emailAddress
)

Parameters

emailAddress
Type: System..::.String

Return Value

true if the email address is already present, false otherwise

See Also

MailingListInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListInfo Properties

[image] [image]

OfficeClip API Documentation
MailingListInfo Properties
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MailingListInfo type exposes the following properties.

Properties

 | Name | Description
Public property | CreatedTimestamp | The time at which the mailing list is created.
Public property | MailingListId | The system dependent unique identifier for the mailing list.
Public property | MailingListMembers | The list of mailing list members.
Public property | MailingListName | The name of the mailing list.
Public property | ModifiedTimestamp | The time when the mailing list was last modified.
Public property | UserId | The identifier of the user who created the mailing list.

See Also

MailingListInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


CreatedTimestamp Property

[image]

OfficeClip API Documentation
MailingListInfo..::.CreatedTimestamp Property
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time at which the mailing list is created.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedTimestamp As DateTime
Visual C++
public:
property DateTime CreatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

MailingListInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListId Property

[image]

OfficeClip API Documentation
MailingListInfo..::.MailingListId Property
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system dependent unique identifier for the mailing list.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MailingListId { get; set; }
Visual Basic (Declaration)
Public Property MailingListId As Integer
Visual C++
public:
property int MailingListId {
    int get ();
    void set (int value);
}

See Also

MailingListInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListMembers Property

[image]

OfficeClip API Documentation
MailingListInfo..::.MailingListMembers Property
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of mailing list members.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList MailingListMembers { get; set; }
Visual Basic (Declaration)
Public Property MailingListMembers As ArrayList
Visual C++
public:
property ArrayList^ MailingListMembers {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

MailingListInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListName Property

[image]

OfficeClip API Documentation
MailingListInfo..::.MailingListName Property
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the mailing list.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string MailingListName { get; set; }
Visual Basic (Declaration)
Public Property MailingListName As String
Visual C++
public:
property String^ MailingListName {
    String^ get ();
    void set (String^ value);
}

See Also

MailingListInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


ModifiedTimestamp Property

[image]

OfficeClip API Documentation
MailingListInfo..::.ModifiedTimestamp Property
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time when the mailing list was last modified.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ModifiedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ModifiedTimestamp As DateTime
Visual C++
public:
property DateTime ModifiedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

MailingListInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


UserId Property

[image]

OfficeClip API Documentation
MailingListInfo..::.UserId Property
MailingListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier of the user who created the mailing list.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

MailingListInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListMemberInfo Class

[image]

OfficeClip API Documentation
MailingListMemberInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides the methods and properties to access the mailing list menber information.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class MailingListMemberInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MailingListMemberInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class MailingListMemberInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop.Email..::.MailingListMemberInfo

See Also

MailingListMemberInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListMemberInfo Members

[image] [image]

OfficeClip API Documentation
MailingListMemberInfo Members
MailingListMemberInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MailingListMemberInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MailingListMemberInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MailingListId | The system generated unique identifier for the mailing list.
Public property | MailingListMemberId | The identifier for the mailing list member.
Public property | MemberEmailAddress | The email Address of the mailing list.
Public property | MemberName | The name of the mailing list member.
Public property | MemberUserId | The user who created the mailing list.

See Also

MailingListMemberInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListMemberInfo Constructor

[image] [image]

OfficeClip API Documentation
MailingListMemberInfo Constructor
MailingListMemberInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MailingListMemberInfo()()() | The default constructor
Public method | MailingListMemberInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

MailingListMemberInfo Class
MailingListMemberInfo Members
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListMemberInfo Constructor

[image]

OfficeClip API Documentation
MailingListMemberInfo Constructor
MailingListMemberInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MailingListMemberInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MailingListMemberInfo()

See Also

MailingListMemberInfo Class
MailingListMemberInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListMemberInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
MailingListMemberInfo Constructor (SerializationInfo, StreamingContext)
MailingListMemberInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MailingListMemberInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
MailingListMemberInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

MailingListMemberInfo Class
MailingListMemberInfo Overload
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListMemberInfo Methods

[image] [image]

OfficeClip API Documentation
MailingListMemberInfo Methods
MailingListMemberInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MailingListMemberInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MailingListMemberInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
MailingListMemberInfo..::.GetObjectData Method
MailingListMemberInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

MailingListMemberInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListMemberInfo Properties

[image] [image]

OfficeClip API Documentation
MailingListMemberInfo Properties
MailingListMemberInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MailingListMemberInfo type exposes the following properties.

Properties

 | Name | Description
Public property | MailingListId | The system generated unique identifier for the mailing list.
Public property | MailingListMemberId | The identifier for the mailing list member.
Public property | MemberEmailAddress | The email Address of the mailing list.
Public property | MemberName | The name of the mailing list member.
Public property | MemberUserId | The user who created the mailing list.

See Also

MailingListMemberInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListId Property

[image]

OfficeClip API Documentation
MailingListMemberInfo..::.MailingListId Property
MailingListMemberInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the mailing list.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MailingListId { get; set; }
Visual Basic (Declaration)
Public Property MailingListId As Integer
Visual C++
public:
property int MailingListId {
    int get ();
    void set (int value);
}

See Also

MailingListMemberInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MailingListMemberId Property

[image]

OfficeClip API Documentation
MailingListMemberInfo..::.MailingListMemberId Property
MailingListMemberInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the mailing list member.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MailingListMemberId { get; set; }
Visual Basic (Declaration)
Public Property MailingListMemberId As Integer
Visual C++
public:
property int MailingListMemberId {
    int get ();
    void set (int value);
}

See Also

MailingListMemberInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MemberEmailAddress Property

[image]

OfficeClip API Documentation
MailingListMemberInfo..::.MemberEmailAddress Property
MailingListMemberInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Address of the mailing list.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string MemberEmailAddress { get; set; }
Visual Basic (Declaration)
Public Property MemberEmailAddress As String
Visual C++
public:
property String^ MemberEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

MailingListMemberInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MemberName Property

[image]

OfficeClip API Documentation
MailingListMemberInfo..::.MemberName Property
MailingListMemberInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the mailing list member.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string MemberName { get; set; }
Visual Basic (Declaration)
Public Property MemberName As String
Visual C++
public:
property String^ MemberName {
    String^ get ();
    void set (String^ value);
}

See Also

MailingListMemberInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


MemberUserId Property

[image]

OfficeClip API Documentation
MailingListMemberInfo..::.MemberUserId Property
MailingListMemberInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user who created the mailing list.

Namespace: OfficeClip.BusinessLayer.Desktop.Email
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MemberUserId { get; set; }
Visual Basic (Declaration)
Public Property MemberUserId As Integer
Visual C++
public:
property int MemberUserId {
    int get ();
    void set (int value);
}

See Also

MailingListMemberInfo Class
OfficeClip.BusinessLayer.Desktop.Email Namespace


OfficeClip.BusinessLayer.Extranet Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Extranet Namespace

[This is preliminary documentation and is subject to change.]

Business Layer information for Customer portal

Classes

 | Class | Description
Public class | ExtranetKbInfo | Provides members and properties to access the extranet knowledge base field information.
Public class | ExtranetUserInfo | Class to represent the extranet user information
Public class | FeatureInfo | FeatureIno is used as a container for information about a feature. The AdminControl and UserControl properties contain the filename of the user controls that are used by the Extranet framework to implement a particular feature.
Public class | IssueTrackerDetailsInfo | IssueTrackerDetailsInfo is a business object that contains information relevant to Issue Tracker related features. Properties values are set in either the creation or edit of a feature item and then passed to the DB Layer for storage.
Public class | ItemInfo | ItemInfo is the business object that is used to capture information during the creation or editing of a feature item. The AdminControlLocation and UserControlLocation contain the values of the dynamically loaded User Controls that are used by the Extranet framework to provide a particular feature.
Public class | OrgInfo | OrgIfo is the business object that is used to capture various properties about the organization providing the Extranet.
Public class | PermissionItem | PermissionItem is a business object that is used in a collection to identify all users having access to a secure feature item.
Public class | PermissionItemCollection | PermissionItemCollection is a collection of PermissionItems and is used as an access control list for specifying what extranet users have access to a secure feature item.


ExtranetKbInfo Class

[image]

OfficeClip API Documentation
ExtranetKbInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides members and properties to access the extranet knowledge base field information.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ExtranetKbInfo
Visual Basic (Declaration)
Public Class ExtranetKbInfo
Visual C++
public ref class ExtranetKbInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet..::.ExtranetKbInfo

See Also

ExtranetKbInfo Members
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetKbInfo Members

[image] [image]

OfficeClip API Documentation
ExtranetKbInfo Members
ExtranetKbInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExtranetKbInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExtranetKbInfo | Overloaded.

Methods

 | Name | Description
Public method | AddSelectedField | Adds the selected field from the extranet to the knowledge base. This field shows up in the knowledge base screen.
Public method | Dump | Ourputs a dump of the object for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldSize | Gets the size of the fields array. This returns the number of fields in the knowledge base.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSelectedField | Gets the value of the selected field from the object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Serialize this object to a readable format. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | CaseId | The unique id of the extranet case
Public property | FilterString | The string value to filter
Public property | FilterTypeId | Shows the type of the filter selected from the knowledge base creation screen.
Public property | IsHtml | Shows if the knowledge base is html based. Html based knowledge base will show the details in Html
Public property | ProjectId | The database generated unique id of the project
Public property | SubTopicId | The database generated unique id of the subtopic of the knowledge base
Public property | TopicId | The database generated unique id of the topic of the knowledge base
Public property | WelcomeText | Shows the Knowledge base welcome message.

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetKbInfo Constructor

[image] [image]

OfficeClip API Documentation
ExtranetKbInfo Constructor
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExtranetKbInfo()()() | The empty constructor
Public method | ExtranetKbInfo(String) | Constructor that takes the encoded string and creates a knowledge base

See Also

ExtranetKbInfo Class
ExtranetKbInfo Members
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetKbInfo Constructor

[image]

OfficeClip API Documentation
ExtranetKbInfo Constructor
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

The empty constructor

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExtranetKbInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExtranetKbInfo()

See Also

ExtranetKbInfo Class
ExtranetKbInfo Overload
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetKbInfo Constructor (String)

[image]

OfficeClip API Documentation
ExtranetKbInfo Constructor (String)
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that takes the encoded string and creates a knowledge base

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExtranetKbInfo(
    string str
)
Visual Basic (Declaration)
Public Sub New ( _
    str As String _
)
Visual C++
public:
ExtranetKbInfo(
    String^ str
)

Parameters

str
Type: System..::.String
The string that is encoded specifically for the extranet knowledge base

See Also

ExtranetKbInfo Class
ExtranetKbInfo Overload
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetKbInfo Methods

[image] [image]

OfficeClip API Documentation
ExtranetKbInfo Methods
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExtranetKbInfo type exposes the following methods.

Methods

 | Name | Description
Public method | AddSelectedField | Adds the selected field from the extranet to the knowledge base. This field shows up in the knowledge base screen.
Public method | Dump | Ourputs a dump of the object for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldSize | Gets the size of the fields array. This returns the number of fields in the knowledge base.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSelectedField | Gets the value of the selected field from the object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Serialize this object to a readable format. (Overrides Object..::.ToString()()().)

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


AddSelectedField Method

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.AddSelectedField Method
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

Adds the selected field from the extranet to the knowledge base. This field shows up in the knowledge base screen.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void AddSelectedField(
    string val
)
Visual Basic (Declaration)
Public Sub AddSelectedField ( _
    val As String _
)
Visual C++
public:
void AddSelectedField(
    String^ val
)

Parameters

val
Type: System..::.String
The selected field value

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


Dump Method

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.Dump Method
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

Ourputs a dump of the object for debugging purposes

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

the ascii dump of the object.

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


GetFieldSize Method

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.GetFieldSize Method
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the size of the fields array. This returns the number of fields in the knowledge base.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GetFieldSize()
Visual Basic (Declaration)
Public Function GetFieldSize As Integer
Visual C++
public:
int GetFieldSize()

Return Value

The number of fields.

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


GetSelectedField Method

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.GetSelectedField Method
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the value of the selected field from the object.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetSelectedField(
    int index
)
Visual Basic (Declaration)
Public Function GetSelectedField ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetSelectedField(
    int index
)

Parameters

index
Type: System..::.Int32
The integer index determined by the extranet field id TrackerFieldsNameId

Return Value

The string value of the selected field.

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ToString Method

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.ToString Method
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

Serialize this object to a readable format.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The serialized object.

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetKbInfo Properties

[image] [image]

OfficeClip API Documentation
ExtranetKbInfo Properties
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExtranetKbInfo type exposes the following properties.

Properties

 | Name | Description
Public property | CaseId | The unique id of the extranet case
Public property | FilterString | The string value to filter
Public property | FilterTypeId | Shows the type of the filter selected from the knowledge base creation screen.
Public property | IsHtml | Shows if the knowledge base is html based. Html based knowledge base will show the details in Html
Public property | ProjectId | The database generated unique id of the project
Public property | SubTopicId | The database generated unique id of the subtopic of the knowledge base
Public property | TopicId | The database generated unique id of the topic of the knowledge base
Public property | WelcomeText | Shows the Knowledge base welcome message.

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


CaseId Property

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.CaseId Property
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the extranet case

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CaseId { get; set; }
Visual Basic (Declaration)
Public Property CaseId As String
Visual C++
public:
property String^ CaseId {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


FilterString Property

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.FilterString Property
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

The string value to filter

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FilterString { get; set; }
Visual Basic (Declaration)
Public Property FilterString As String
Visual C++
public:
property String^ FilterString {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


FilterTypeId Property

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.FilterTypeId Property
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows the type of the filter selected from the knowledge base creation screen.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FilterTypeId { get; set; }
Visual Basic (Declaration)
Public Property FilterTypeId As String
Visual C++
public:
property String^ FilterTypeId {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


IsHtml Property

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.IsHtml Property
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the knowledge base is html based. Html based knowledge base will show the details in Html

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsHtml { get; set; }
Visual Basic (Declaration)
Public Property IsHtml As String
Visual C++
public:
property String^ IsHtml {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ProjectId Property

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.ProjectId Property
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

The database generated unique id of the project

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProjectId { get; set; }
Visual Basic (Declaration)
Public Property ProjectId As String
Visual C++
public:
property String^ ProjectId {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


SubTopicId Property

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.SubTopicId Property
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

The database generated unique id of the subtopic of the knowledge base

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SubTopicId { get; set; }
Visual Basic (Declaration)
Public Property SubTopicId As String
Visual C++
public:
property String^ SubTopicId {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


TopicId Property

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.TopicId Property
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

The database generated unique id of the topic of the knowledge base

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TopicId { get; set; }
Visual Basic (Declaration)
Public Property TopicId As String
Visual C++
public:
property String^ TopicId {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


WelcomeText Property

[image]

OfficeClip API Documentation
ExtranetKbInfo..::.WelcomeText Property
ExtranetKbInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows the Knowledge base welcome message.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string WelcomeText { get; set; }
Visual Basic (Declaration)
Public Property WelcomeText As String
Visual C++
public:
property String^ WelcomeText {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetKbInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetUserInfo Class

[image]

OfficeClip API Documentation
ExtranetUserInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the extranet user information

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ExtranetUserInfo
Visual Basic (Declaration)
Public Class ExtranetUserInfo
Visual C++
public ref class ExtranetUserInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet..::.ExtranetUserInfo

See Also

ExtranetUserInfo Members
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetUserInfo Members

[image] [image]

OfficeClip API Documentation
ExtranetUserInfo Members
ExtranetUserInfo Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The ExtranetUserInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExtranetUserInfo |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _emailAddress | The email address of the user
Protected field | _firstName | The first name of the user
Protected field | _isExternal | Determines if the use is an extranet user
Protected field | _lastName | The last name of the user
Protected field | _password | The password of the user
Protected field | _userId | The unique id of the user

Properties

 | Name | Description
Public property | EmailAddress | the email address of the user
Public property | FirstName | the first name of the user
Public property | IsExternalUser | true if the user is an external user, false otherwise
Public property | LastName | the last name of the user
Public property | Name | the name of the user
Public property | Password | the user password
Public property | UserID | The unique id of the user

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetUserInfo Constructor

[image]

OfficeClip API Documentation
ExtranetUserInfo Constructor
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExtranetUserInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExtranetUserInfo()

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetUserInfo Fields

[image] [image]

OfficeClip API Documentation
ExtranetUserInfo Fields
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExtranetUserInfo type exposes the following fields.

Fields

 | Name | Description
Protected field | _emailAddress | The email address of the user
Protected field | _firstName | The first name of the user
Protected field | _isExternal | Determines if the use is an extranet user
Protected field | _lastName | The last name of the user
Protected field | _password | The password of the user
Protected field | _userId | The unique id of the user

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_emailAddress Field

[image]

OfficeClip API Documentation
ExtranetUserInfo..::._emailAddress Field
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email address of the user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _emailAddress
Visual Basic (Declaration)
Protected _emailAddress As String
Visual C++
protected:
String^ _emailAddress

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_firstName Field

[image]

OfficeClip API Documentation
ExtranetUserInfo..::._firstName Field
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first name of the user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _firstName
Visual Basic (Declaration)
Protected _firstName As String
Visual C++
protected:
String^ _firstName

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_isExternal Field

[image]

OfficeClip API Documentation
ExtranetUserInfo..::._isExternal Field
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the use is an extranet user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected bool _isExternal
Visual Basic (Declaration)
Protected _isExternal As Boolean
Visual C++
protected:
bool _isExternal

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_lastName Field

[image]

OfficeClip API Documentation
ExtranetUserInfo..::._lastName Field
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last name of the user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _lastName
Visual Basic (Declaration)
Protected _lastName As String
Visual C++
protected:
String^ _lastName

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_password Field

[image]

OfficeClip API Documentation
ExtranetUserInfo..::._password Field
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The password of the user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _password
Visual Basic (Declaration)
Protected _password As String
Visual C++
protected:
String^ _password

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_userId Field

[image]

OfficeClip API Documentation
ExtranetUserInfo..::._userId Field
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _userId
Visual Basic (Declaration)
Protected _userId As Integer
Visual C++
protected:
int _userId

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetUserInfo Properties

[image] [image]

OfficeClip API Documentation
ExtranetUserInfo Properties
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExtranetUserInfo type exposes the following properties.

Properties

 | Name | Description
Public property | EmailAddress | the email address of the user
Public property | FirstName | the first name of the user
Public property | IsExternalUser | true if the user is an external user, false otherwise
Public property | LastName | the last name of the user
Public property | Name | the name of the user
Public property | Password | the user password
Public property | UserID | The unique id of the user

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


EmailAddress Property

[image]

OfficeClip API Documentation
ExtranetUserInfo..::.EmailAddress Property
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

the email address of the user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic (Declaration)
Public Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


FirstName Property

[image]

OfficeClip API Documentation
ExtranetUserInfo..::.FirstName Property
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

the first name of the user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


IsExternalUser Property

[image]

OfficeClip API Documentation
ExtranetUserInfo..::.IsExternalUser Property
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

true if the user is an external user, false otherwise

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsExternalUser { get; set; }
Visual Basic (Declaration)
Public Property IsExternalUser As Boolean
Visual C++
public:
property bool IsExternalUser {
    bool get ();
    void set (bool value);
}

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


LastName Property

[image]

OfficeClip API Documentation
ExtranetUserInfo..::.LastName Property
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

the last name of the user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


Name Property

[image]

OfficeClip API Documentation
ExtranetUserInfo..::.Name Property
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

the name of the user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


Password Property

[image]

OfficeClip API Documentation
ExtranetUserInfo..::.Password Property
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

the user password

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


UserID Property

[image]

OfficeClip API Documentation
ExtranetUserInfo..::.UserID Property
ExtranetUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserID { get; set; }
Visual Basic (Declaration)
Public Property UserID As Integer
Visual C++
public:
property int UserID {
    int get ();
    void set (int value);
}

See Also

ExtranetUserInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


FeatureInfo Class

[image]

OfficeClip API Documentation
FeatureInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

FeatureIno is used as a container for information about a feature. The AdminControl and UserControl properties contain the filename of the user controls that are used by the Extranet framework to implement a particular feature.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class FeatureInfo
Visual Basic (Declaration)
Public Class FeatureInfo
Visual C++
public ref class FeatureInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet..::.FeatureInfo

See Also

FeatureInfo Members
OfficeClip.BusinessLayer.Extranet Namespace


FeatureInfo Members

[image] [image]

OfficeClip API Documentation
FeatureInfo Members
FeatureInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The FeatureInfo type exposes the following members.

Constructors

 | Name | Description
Public method | FeatureInfo |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdminControl |
Public property | ApplicationId |
Public property | Argument |
Public property | FeatureId |
Public property | FeatureName | the name of the feature
Public property | Restriction |
Public property | UserControl |

See Also

FeatureInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


FeatureInfo Constructor

[image]

OfficeClip API Documentation
FeatureInfo Constructor
FeatureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public FeatureInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FeatureInfo()

See Also

FeatureInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


FeatureInfo Properties

[image] [image]

OfficeClip API Documentation
FeatureInfo Properties
FeatureInfo Class See Also

[This is preliminary documentation and is subject to change.]

The FeatureInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AdminControl |
Public property | ApplicationId |
Public property | Argument |
Public property | FeatureId |
Public property | FeatureName | the name of the feature
Public property | Restriction |
Public property | UserControl |

See Also

FeatureInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


AdminControl Property

[image]

OfficeClip API Documentation
FeatureInfo..::.AdminControl Property
FeatureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AdminControl { get; set; }
Visual Basic (Declaration)
Public Property AdminControl As String
Visual C++
public:
property String^ AdminControl {
    String^ get ();
    void set (String^ value);
}

See Also

FeatureInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ApplicationId Property

[image]

OfficeClip API Documentation
FeatureInfo..::.ApplicationId Property
FeatureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ApplicationId { get; set; }
Visual Basic (Declaration)
Public Property ApplicationId As Integer
Visual C++
public:
property int ApplicationId {
    int get ();
    void set (int value);
}

See Also

FeatureInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


Argument Property

[image]

OfficeClip API Documentation
FeatureInfo..::.Argument Property
FeatureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Argument { get; set; }
Visual Basic (Declaration)
Public Property Argument As String
Visual C++
public:
property String^ Argument {
    String^ get ();
    void set (String^ value);
}

See Also

FeatureInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


FeatureId Property

[image]

OfficeClip API Documentation
FeatureInfo..::.FeatureId Property
FeatureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int FeatureId { get; set; }
Visual Basic (Declaration)
Public Property FeatureId As Integer
Visual C++
public:
property int FeatureId {
    int get ();
    void set (int value);
}

See Also

FeatureInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


FeatureName Property

[image]

OfficeClip API Documentation
FeatureInfo..::.FeatureName Property
FeatureInfo Class See Also

[This is preliminary documentation and is subject to change.]

the name of the feature

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FeatureName { get; set; }
Visual Basic (Declaration)
Public Property FeatureName As String
Visual C++
public:
property String^ FeatureName {
    String^ get ();
    void set (String^ value);
}

See Also

FeatureInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


Restriction Property

[image]

OfficeClip API Documentation
FeatureInfo..::.Restriction Property
FeatureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Restrictions Restriction { get; set; }
Visual Basic (Declaration)
Public Property Restriction As Restrictions
Visual C++
public:
property Restrictions Restriction {
    Restrictions get ();
    void set (Restrictions value);
}

See Also

FeatureInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


UserControl Property

[image]

OfficeClip API Documentation
FeatureInfo..::.UserControl Property
FeatureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UserControl { get; set; }
Visual Basic (Declaration)
Public Property UserControl As String
Visual C++
public:
property String^ UserControl {
    String^ get ();
    void set (String^ value);
}

See Also

FeatureInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


IssueTrackerDetailsInfo Class

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

IssueTrackerDetailsInfo is a business object that contains information relevant to Issue Tracker related features. Properties values are set in either the creation or edit of a feature item and then passed to the DB Layer for storage.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class IssueTrackerDetailsInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class IssueTrackerDetailsInfo
Visual C++
[SerializableAttribute]
public ref class IssueTrackerDetailsInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet..::.IssueTrackerDetailsInfo

See Also

IssueTrackerDetailsInfo Members
OfficeClip.BusinessLayer.Extranet Namespace


IssueTrackerDetailsInfo Members

[image] [image]

OfficeClip API Documentation
IssueTrackerDetailsInfo Members
IssueTrackerDetailsInfo Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The IssueTrackerDetailsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | IssueTrackerDetailsInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _adminEmail | Administrator email
Protected field | _adminId | Administrator id
Protected field | _confirmMsg | Confirm message
Protected field | _copyConfirmToAdmin | Copy confirm to admin
Protected field | _groupID | Group id
Protected field | _groupName | Group name
Protected field | _itemId | Item id
Protected field | _pid | Pid
Protected field | _trackingTicketRequired | Determines if the tracking ticket is required

Properties

 | Name | Description
Public property | AdminEmail | The email address of the administrator
Public property | AdminID | The unique user id of the administrator
Public property | ConfirmMsg | The confirmation message after the issue is entered
Public property | CopyConfirmToAdmin | true if the isue will be Cc'ed to the administrator
Public property | GroupID | The unique id for the group
Public property | GroupName | the name of the group
Public property | ItemID | The unique id of the item
Public property | ProjectID | The unique id of the project
Public property | TrackingTicketRequired | true if the tracking ticket will be sent to the user after he/she enters the issue

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


IssueTrackerDetailsInfo Constructor

[image] [image]

OfficeClip API Documentation
IssueTrackerDetailsInfo Constructor
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | IssueTrackerDetailsInfo(String) | constructor
Public method | IssueTrackerDetailsInfo(FeatureItem) | constructor

See Also

IssueTrackerDetailsInfo Class
IssueTrackerDetailsInfo Members
OfficeClip.BusinessLayer.Extranet Namespace


IssueTrackerDetailsInfo Constructor (String)

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo Constructor (String)
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IssueTrackerDetailsInfo(
    string itemXml
)
Visual Basic (Declaration)
Public Sub New ( _
    itemXml As String _
)
Visual C++
public:
IssueTrackerDetailsInfo(
    String^ itemXml
)

Parameters

itemXml
Type: System..::.String
the xml string

See Also

IssueTrackerDetailsInfo Class
IssueTrackerDetailsInfo Overload
OfficeClip.BusinessLayer.Extranet Namespace


IssueTrackerDetailsInfo Constructor (FeatureItem)

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo Constructor (FeatureItem)
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IssueTrackerDetailsInfo(
    FeatureItem fi
)
Visual Basic (Declaration)
Public Sub New ( _
    fi As FeatureItem _
)
Visual C++
public:
IssueTrackerDetailsInfo(
    FeatureItem^ fi
)

Parameters

fi
Type: OfficeClip.BusinessLayer.Extranet.Xml..::.FeatureItem

See Also

IssueTrackerDetailsInfo Class
IssueTrackerDetailsInfo Overload
OfficeClip.BusinessLayer.Extranet Namespace


IssueTrackerDetailsInfo Fields

[image] [image]

OfficeClip API Documentation
IssueTrackerDetailsInfo Fields
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The IssueTrackerDetailsInfo type exposes the following fields.

Fields

 | Name | Description
Protected field | _adminEmail | Administrator email
Protected field | _adminId | Administrator id
Protected field | _confirmMsg | Confirm message
Protected field | _copyConfirmToAdmin | Copy confirm to admin
Protected field | _groupID | Group id
Protected field | _groupName | Group name
Protected field | _itemId | Item id
Protected field | _pid | Pid
Protected field | _trackingTicketRequired | Determines if the tracking ticket is required

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_adminEmail Field

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::._adminEmail Field
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Administrator email

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _adminEmail
Visual Basic (Declaration)
Protected _adminEmail As String
Visual C++
protected:
String^ _adminEmail

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_adminId Field

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::._adminId Field
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Administrator id

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _adminId
Visual Basic (Declaration)
Protected _adminId As Integer
Visual C++
protected:
int _adminId

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_confirmMsg Field

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::._confirmMsg Field
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Confirm message

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _confirmMsg
Visual Basic (Declaration)
Protected _confirmMsg As String
Visual C++
protected:
String^ _confirmMsg

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_copyConfirmToAdmin Field

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::._copyConfirmToAdmin Field
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Copy confirm to admin

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected bool _copyConfirmToAdmin
Visual Basic (Declaration)
Protected _copyConfirmToAdmin As Boolean
Visual C++
protected:
bool _copyConfirmToAdmin

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_groupID Field

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::._groupID Field
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Group id

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _groupID
Visual Basic (Declaration)
Protected _groupID As Integer
Visual C++
protected:
int _groupID

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_groupName Field

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::._groupName Field
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Group name

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _groupName
Visual Basic (Declaration)
Protected _groupName As String
Visual C++
protected:
String^ _groupName

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_itemId Field

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::._itemId Field
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Item id

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _itemId
Visual Basic (Declaration)
Protected _itemId As Integer
Visual C++
protected:
int _itemId

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_pid Field

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::._pid Field
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Pid

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _pid
Visual Basic (Declaration)
Protected _pid As Integer
Visual C++
protected:
int _pid

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


_trackingTicketRequired Field

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::._trackingTicketRequired Field
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the tracking ticket is required

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected bool _trackingTicketRequired
Visual Basic (Declaration)
Protected _trackingTicketRequired As Boolean
Visual C++
protected:
bool _trackingTicketRequired

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


IssueTrackerDetailsInfo Properties

[image] [image]

OfficeClip API Documentation
IssueTrackerDetailsInfo Properties
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The IssueTrackerDetailsInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AdminEmail | The email address of the administrator
Public property | AdminID | The unique user id of the administrator
Public property | ConfirmMsg | The confirmation message after the issue is entered
Public property | CopyConfirmToAdmin | true if the isue will be Cc'ed to the administrator
Public property | GroupID | The unique id for the group
Public property | GroupName | the name of the group
Public property | ItemID | The unique id of the item
Public property | ProjectID | The unique id of the project
Public property | TrackingTicketRequired | true if the tracking ticket will be sent to the user after he/she enters the issue

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


AdminEmail Property

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::.AdminEmail Property
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email address of the administrator

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AdminEmail { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdminEmail As String
Visual C++
public:
property String^ AdminEmail {
    String^ get ();
}

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


AdminID Property

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::.AdminID Property
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique user id of the administrator

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AdminID { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdminID As Integer
Visual C++
public:
property int AdminID {
    int get ();
}

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ConfirmMsg Property

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::.ConfirmMsg Property
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The confirmation message after the issue is entered

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ConfirmMsg { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConfirmMsg As String
Visual C++
public:
property String^ ConfirmMsg {
    String^ get ();
}

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


CopyConfirmToAdmin Property

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::.CopyConfirmToAdmin Property
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

true if the isue will be Cc'ed to the administrator

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool CopyConfirmToAdmin { get; }
Visual Basic (Declaration)
Public ReadOnly Property CopyConfirmToAdmin As Boolean
Visual C++
public:
property bool CopyConfirmToAdmin {
    bool get ();
}

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


GroupID Property

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::.GroupID Property
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id for the group

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupID { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupID As Integer
Visual C++
public:
property int GroupID {
    int get ();
}

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


GroupName Property

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::.GroupName Property
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

the name of the group

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GroupName { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupName As String
Visual C++
public:
property String^ GroupName {
    String^ get ();
}

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ItemID Property

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::.ItemID Property
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the item

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ItemID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemID As Integer
Visual C++
public:
property int ItemID {
    int get ();
}

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ProjectID Property

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::.ProjectID Property
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the project

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ProjectID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectID As Integer
Visual C++
public:
property int ProjectID {
    int get ();
}

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


TrackingTicketRequired Property

[image]

OfficeClip API Documentation
IssueTrackerDetailsInfo..::.TrackingTicketRequired Property
IssueTrackerDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

true if the tracking ticket will be sent to the user after he/she enters the issue

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool TrackingTicketRequired { get; }
Visual Basic (Declaration)
Public ReadOnly Property TrackingTicketRequired As Boolean
Visual C++
public:
property bool TrackingTicketRequired {
    bool get ();
}

See Also

IssueTrackerDetailsInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ItemInfo Class

[image]

OfficeClip API Documentation
ItemInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

ItemInfo is the business object that is used to capture information during the creation or editing of a feature item. The AdminControlLocation and UserControlLocation contain the values of the dynamically loaded User Controls that are used by the Extranet framework to provide a particular feature.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ItemInfo
Visual Basic (Declaration)
Public Class ItemInfo
Visual C++
public ref class ItemInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet..::.ItemInfo

See Also

ItemInfo Members
OfficeClip.BusinessLayer.Extranet Namespace


ItemInfo Members

[image] [image]

OfficeClip API Documentation
ItemInfo Members
ItemInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ItemInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ItemInfo | default constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Active | True if the extranet item is active
Public property | AdminControlLocation | The location from where the admin control is picked up
Public property | AppId | The unique id of the application
Public property | AppName | the name of the application
Public property | CreatedDate | The date when the item is created
Public property | ExternalUrl | The url with which the extranet user will have access to the extranet
Public property | FeatureId | The unique id of the feature
Public property | FeatureName | the name of the feature
Public property | ItemDetailXml |
Public property | ItemId | The unique id of the item
Public property | ItemName | the name of the item
Public property | Permissions | The permission matrix of the extranet item
Public property | Restrictions | the restrictions on the extranet item
Public property | Show | True if the item is shown to the extranet user on the extranet screen
Public property | UserControlLocation | The location from where the admin control is picked up
Public property | UserId | The id of the user that created the item
Public property | UserName | The name of the user that created the item

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ItemInfo Constructor

[image]

OfficeClip API Documentation
ItemInfo Constructor
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

default constructor

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ItemInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ItemInfo()

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ItemInfo Properties

[image] [image]

OfficeClip API Documentation
ItemInfo Properties
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ItemInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Active | True if the extranet item is active
Public property | AdminControlLocation | The location from where the admin control is picked up
Public property | AppId | The unique id of the application
Public property | AppName | the name of the application
Public property | CreatedDate | The date when the item is created
Public property | ExternalUrl | The url with which the extranet user will have access to the extranet
Public property | FeatureId | The unique id of the feature
Public property | FeatureName | the name of the feature
Public property | ItemDetailXml |
Public property | ItemId | The unique id of the item
Public property | ItemName | the name of the item
Public property | Permissions | The permission matrix of the extranet item
Public property | Restrictions | the restrictions on the extranet item
Public property | Show | True if the item is shown to the extranet user on the extranet screen
Public property | UserControlLocation | The location from where the admin control is picked up
Public property | UserId | The id of the user that created the item
Public property | UserName | The name of the user that created the item

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


Active Property

[image]

OfficeClip API Documentation
ItemInfo..::.Active Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

True if the extranet item is active

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool Active { get; set; }
Visual Basic (Declaration)
Public Property Active As Boolean
Visual C++
public:
property bool Active {
    bool get ();
    void set (bool value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


AdminControlLocation Property

[image]

OfficeClip API Documentation
ItemInfo..::.AdminControlLocation Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The location from where the admin control is picked up

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AdminControlLocation { get; set; }
Visual Basic (Declaration)
Public Property AdminControlLocation As String
Visual C++
public:
property String^ AdminControlLocation {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


AppId Property

[image]

OfficeClip API Documentation
ItemInfo..::.AppId Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the application

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AppId { get; set; }
Visual Basic (Declaration)
Public Property AppId As Integer
Visual C++
public:
property int AppId {
    int get ();
    void set (int value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


AppName Property

[image]

OfficeClip API Documentation
ItemInfo..::.AppName Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

the name of the application

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AppName { get; set; }
Visual Basic (Declaration)
Public Property AppName As String
Visual C++
public:
property String^ AppName {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


CreatedDate Property

[image]

OfficeClip API Documentation
ItemInfo..::.CreatedDate Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date when the item is created

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedDate { get; set; }
Visual Basic (Declaration)
Public Property CreatedDate As DateTime
Visual C++
public:
property DateTime CreatedDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ExternalUrl Property

[image]

OfficeClip API Documentation
ItemInfo..::.ExternalUrl Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The url with which the extranet user will have access to the extranet

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ExternalUrl { get; set; }
Visual Basic (Declaration)
Public Property ExternalUrl As String
Visual C++
public:
property String^ ExternalUrl {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


FeatureId Property

[image]

OfficeClip API Documentation
ItemInfo..::.FeatureId Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the feature

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int FeatureId { get; set; }
Visual Basic (Declaration)
Public Property FeatureId As Integer
Visual C++
public:
property int FeatureId {
    int get ();
    void set (int value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


FeatureName Property

[image]

OfficeClip API Documentation
ItemInfo..::.FeatureName Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

the name of the feature

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FeatureName { get; set; }
Visual Basic (Declaration)
Public Property FeatureName As String
Visual C++
public:
property String^ FeatureName {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ItemDetailXml Property

[image]

OfficeClip API Documentation
ItemInfo..::.ItemDetailXml Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ItemDetailXml { get; set; }
Visual Basic (Declaration)
Public Property ItemDetailXml As String
Visual C++
public:
property String^ ItemDetailXml {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ItemId Property

[image]

OfficeClip API Documentation
ItemInfo..::.ItemId Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the item

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ItemId { get; set; }
Visual Basic (Declaration)
Public Property ItemId As Integer
Visual C++
public:
property int ItemId {
    int get ();
    void set (int value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ItemName Property

[image]

OfficeClip API Documentation
ItemInfo..::.ItemName Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

the name of the item

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ItemName { get; set; }
Visual Basic (Declaration)
Public Property ItemName As String
Visual C++
public:
property String^ ItemName {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


Permissions Property

[image]

OfficeClip API Documentation
ItemInfo..::.Permissions Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The permission matrix of the extranet item

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PermissionItemCollection Permissions { get; set; }
Visual Basic (Declaration)
Public Property Permissions As PermissionItemCollection
Visual C++
public:
property PermissionItemCollection^ Permissions {
    PermissionItemCollection^ get ();
    void set (PermissionItemCollection^ value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


Restrictions Property

[image]

OfficeClip API Documentation
ItemInfo..::.Restrictions Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

the restrictions on the extranet item

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Restrictions Restrictions { get; set; }
Visual Basic (Declaration)
Public Property Restrictions As Restrictions
Visual C++
public:
property Restrictions Restrictions {
    Restrictions get ();
    void set (Restrictions value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


Show Property

[image]

OfficeClip API Documentation
ItemInfo..::.Show Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

True if the item is shown to the extranet user on the extranet screen

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool Show { get; set; }
Visual Basic (Declaration)
Public Property Show As Boolean
Visual C++
public:
property bool Show {
    bool get ();
    void set (bool value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


UserControlLocation Property

[image]

OfficeClip API Documentation
ItemInfo..::.UserControlLocation Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The location from where the admin control is picked up

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UserControlLocation { get; set; }
Visual Basic (Declaration)
Public Property UserControlLocation As String
Visual C++
public:
property String^ UserControlLocation {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


UserId Property

[image]

OfficeClip API Documentation
ItemInfo..::.UserId Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The id of the user that created the item

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


UserName Property

[image]

OfficeClip API Documentation
ItemInfo..::.UserName Property
ItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user that created the item

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

ItemInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


OrgInfo Class

[image]

OfficeClip API Documentation
OrgInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

OrgIfo is the business object that is used to capture various properties about the organization providing the Extranet.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OrgInfo
Visual Basic (Declaration)
Public Class OrgInfo
Visual C++
public ref class OrgInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet..::.OrgInfo

See Also

OrgInfo Members
OfficeClip.BusinessLayer.Extranet Namespace


OrgInfo Members

[image] [image]

OfficeClip API Documentation
OrgInfo Members
OrgInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OrgInfo type exposes the following members.

Constructors

 | Name | Description
Public method | OrgInfo |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddToContacts | true if the newly registered user will be added to the contact
Public property | AllowOnlineRegistration | true if the online registration is allowed
Public property | BrowserTitle | The bowser title that is shown at the top frame of the browser window
Public property | CopyrightText | The copyright text that goes to the bottom of the page
Public property | CopyrightUrl | The url of the copyright text
Public property | ExtranetUrl | The url by which the extranet users will have access to the officeclip extranet
Public property | FooterHtml | the html for the footer
Public property | GroupId | The unique id of the group
Public property | HeaderHtml | The html for the header
Public property | IsLicenseValid | Tests if the extranet license is valid for the account
Public property | OrgId | the unique id of the organization
Public property | PageTitle | The page title for the extranet home page
Public property | SessionTimeout | The time after which the extranet session times out (in minutes)
Public property | Theme | DThe extranet theme
Public property | XslUrl | The url of the xsl file

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


OrgInfo Constructor

[image]

OfficeClip API Documentation
OrgInfo Constructor
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OrgInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OrgInfo()

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


OrgInfo Properties

[image] [image]

OfficeClip API Documentation
OrgInfo Properties
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

The OrgInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AddToContacts | true if the newly registered user will be added to the contact
Public property | AllowOnlineRegistration | true if the online registration is allowed
Public property | BrowserTitle | The bowser title that is shown at the top frame of the browser window
Public property | CopyrightText | The copyright text that goes to the bottom of the page
Public property | CopyrightUrl | The url of the copyright text
Public property | ExtranetUrl | The url by which the extranet users will have access to the officeclip extranet
Public property | FooterHtml | the html for the footer
Public property | GroupId | The unique id of the group
Public property | HeaderHtml | The html for the header
Public property | IsLicenseValid | Tests if the extranet license is valid for the account
Public property | OrgId | the unique id of the organization
Public property | PageTitle | The page title for the extranet home page
Public property | SessionTimeout | The time after which the extranet session times out (in minutes)
Public property | Theme | DThe extranet theme
Public property | XslUrl | The url of the xsl file

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


AddToContacts Property

[image]

OfficeClip API Documentation
OrgInfo..::.AddToContacts Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

true if the newly registered user will be added to the contact

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool AddToContacts { get; set; }
Visual Basic (Declaration)
Public Property AddToContacts As Boolean
Visual C++
public:
property bool AddToContacts {
    bool get ();
    void set (bool value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


AllowOnlineRegistration Property

[image]

OfficeClip API Documentation
OrgInfo..::.AllowOnlineRegistration Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

true if the online registration is allowed

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool AllowOnlineRegistration { get; set; }
Visual Basic (Declaration)
Public Property AllowOnlineRegistration As Boolean
Visual C++
public:
property bool AllowOnlineRegistration {
    bool get ();
    void set (bool value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


BrowserTitle Property

[image]

OfficeClip API Documentation
OrgInfo..::.BrowserTitle Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

The bowser title that is shown at the top frame of the browser window

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string BrowserTitle { get; set; }
Visual Basic (Declaration)
Public Property BrowserTitle As String
Visual C++
public:
property String^ BrowserTitle {
    String^ get ();
    void set (String^ value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


CopyrightText Property

[image]

OfficeClip API Documentation
OrgInfo..::.CopyrightText Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

The copyright text that goes to the bottom of the page

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CopyrightText { get; set; }
Visual Basic (Declaration)
Public Property CopyrightText As String
Visual C++
public:
property String^ CopyrightText {
    String^ get ();
    void set (String^ value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


CopyrightUrl Property

[image]

OfficeClip API Documentation
OrgInfo..::.CopyrightUrl Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

The url of the copyright text

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CopyrightUrl { get; set; }
Visual Basic (Declaration)
Public Property CopyrightUrl As String
Visual C++
public:
property String^ CopyrightUrl {
    String^ get ();
    void set (String^ value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


ExtranetUrl Property

[image]

OfficeClip API Documentation
OrgInfo..::.ExtranetUrl Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

The url by which the extranet users will have access to the officeclip extranet

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ExtranetUrl { get; set; }
Visual Basic (Declaration)
Public Property ExtranetUrl As String
Visual C++
public:
property String^ ExtranetUrl {
    String^ get ();
    void set (String^ value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


FooterHtml Property

[image]

OfficeClip API Documentation
OrgInfo..::.FooterHtml Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

the html for the footer

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FooterHtml { get; set; }
Visual Basic (Declaration)
Public Property FooterHtml As String
Visual C++
public:
property String^ FooterHtml {
    String^ get ();
    void set (String^ value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


GroupId Property

[image]

OfficeClip API Documentation
OrgInfo..::.GroupId Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the group

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


HeaderHtml Property

[image]

OfficeClip API Documentation
OrgInfo..::.HeaderHtml Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

The html for the header

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string HeaderHtml { get; set; }
Visual Basic (Declaration)
Public Property HeaderHtml As String
Visual C++
public:
property String^ HeaderHtml {
    String^ get ();
    void set (String^ value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


IsLicenseValid Property

[image]

OfficeClip API Documentation
OrgInfo..::.IsLicenseValid Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

Tests if the extranet license is valid for the account

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsLicenseValid { get; set; }
Visual Basic (Declaration)
Public Property IsLicenseValid As Boolean
Visual C++
public:
property bool IsLicenseValid {
    bool get ();
    void set (bool value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


OrgId Property

[image]

OfficeClip API Documentation
OrgInfo..::.OrgId Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

the unique id of the organization

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int OrgId { get; set; }
Visual Basic (Declaration)
Public Property OrgId As Integer
Visual C++
public:
property int OrgId {
    int get ();
    void set (int value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


PageTitle Property

[image]

OfficeClip API Documentation
OrgInfo..::.PageTitle Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

The page title for the extranet home page

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PageTitle { get; set; }
Visual Basic (Declaration)
Public Property PageTitle As String
Visual C++
public:
property String^ PageTitle {
    String^ get ();
    void set (String^ value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


SessionTimeout Property

[image]

OfficeClip API Documentation
OrgInfo..::.SessionTimeout Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time after which the extranet session times out (in minutes)

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SessionTimeout { get; set; }
Visual Basic (Declaration)
Public Property SessionTimeout As Integer
Visual C++
public:
property int SessionTimeout {
    int get ();
    void set (int value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


Theme Property

[image]

OfficeClip API Documentation
OrgInfo..::.Theme Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

DThe extranet theme

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Theme { get; set; }
Visual Basic (Declaration)
Public Property Theme As String
Visual C++
public:
property String^ Theme {
    String^ get ();
    void set (String^ value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


XslUrl Property

[image]

OfficeClip API Documentation
OrgInfo..::.XslUrl Property
OrgInfo Class See Also

[This is preliminary documentation and is subject to change.]

The url of the xsl file

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string XslUrl { get; set; }
Visual Basic (Declaration)
Public Property XslUrl As String
Visual C++
public:
property String^ XslUrl {
    String^ get ();
    void set (String^ value);
}

See Also

OrgInfo Class
OfficeClip.BusinessLayer.Extranet Namespace


PermissionItem Class

[image]

OfficeClip API Documentation
PermissionItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

PermissionItem is a business object that is used in a collection to identify all users having access to a secure feature item.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class PermissionItem
Visual Basic (Declaration)
Public Class PermissionItem
Visual C++
public ref class PermissionItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet..::.PermissionItem

See Also

PermissionItem Members
OfficeClip.BusinessLayer.Extranet Namespace


PermissionItem Members

[image] [image]

OfficeClip API Documentation
PermissionItem Members
PermissionItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PermissionItem type exposes the following members.

Constructors

 | Name | Description
Public method | PermissionItem | constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UserId | Unique id of the user

See Also

PermissionItem Class
OfficeClip.BusinessLayer.Extranet Namespace


PermissionItem Constructor

[image]

OfficeClip API Documentation
PermissionItem Constructor
PermissionItem Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PermissionItem(
    int userId
)
Visual Basic (Declaration)
Public Sub New ( _
    userId As Integer _
)
Visual C++
public:
PermissionItem(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user

See Also

PermissionItem Class
OfficeClip.BusinessLayer.Extranet Namespace


PermissionItem Properties

[image] [image]

OfficeClip API Documentation
PermissionItem Properties
PermissionItem Class See Also

[This is preliminary documentation and is subject to change.]

The PermissionItem type exposes the following properties.

Properties

 | Name | Description
Public property | UserId | Unique id of the user

See Also

PermissionItem Class
OfficeClip.BusinessLayer.Extranet Namespace


UserId Property

[image]

OfficeClip API Documentation
PermissionItem..::.UserId Property
PermissionItem Class See Also

[This is preliminary documentation and is subject to change.]

Unique id of the user

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

PermissionItem Class
OfficeClip.BusinessLayer.Extranet Namespace


PermissionItemCollection Class

[image]

OfficeClip API Documentation
PermissionItemCollection Class
Members See Also

[This is preliminary documentation and is subject to change.]

PermissionItemCollection is a collection of PermissionItems and is used as an access control list for specifying what extranet users have access to a secure feature item.

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class PermissionItemCollection : ICollection,
    IEnumerable
Visual Basic (Declaration)
Public Class PermissionItemCollection _
    Implements ICollection, IEnumerable
Visual C++
public ref class PermissionItemCollection : ICollection,
    IEnumerable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet..::.PermissionItemCollection

See Also

PermissionItemCollection Members
OfficeClip.BusinessLayer.Extranet Namespace


PermissionItemCollection Members

[image] [image]

OfficeClip API Documentation
PermissionItemCollection Members
PermissionItemCollection Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PermissionItemCollection type exposes the following members.

Constructors

 | Name | Description
Public method | PermissionItemCollection | constructor

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAuthorized | Determines if the user is authorized to access the extranet item
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | ItemPermission |
Public property | ItemPermissionString |
Public property | SyncRoot |

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


PermissionItemCollection Constructor

[image]

OfficeClip API Documentation
PermissionItemCollection Constructor
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PermissionItemCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PermissionItemCollection()

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


PermissionItemCollection Methods

[image] [image]

OfficeClip API Documentation
PermissionItemCollection Methods
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

The PermissionItemCollection type exposes the following methods.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAuthorized | Determines if the user is authorized to access the extranet item
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


Add Method

[image] [image]

OfficeClip API Documentation
PermissionItemCollection..::.Add Method
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Add(Int32) | Adds an item to the collection
Public method | Add(PermissionItem) | Adds an item to the collection

See Also

PermissionItemCollection Class
PermissionItemCollection Members
OfficeClip.BusinessLayer.Extranet Namespace


Add Method (Int32)

[image]

OfficeClip API Documentation
PermissionItemCollection..::.Add Method (Int32)
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Add(
    int userId
)
Visual Basic (Declaration)
Public Function Add ( _
    userId As Integer _
) As Integer
Visual C++
public:
int Add(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user

See Also

PermissionItemCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet Namespace


Add Method (PermissionItem)

[image]

OfficeClip API Documentation
PermissionItemCollection..::.Add Method (PermissionItem)
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Add(
    PermissionItem item
)
Visual Basic (Declaration)
Public Function Add ( _
    item As PermissionItem _
) As Integer
Visual C++
public:
int Add(
    PermissionItem^ item
)

Parameters

item
Type: OfficeClip.BusinessLayer.Extranet..::.PermissionItem
The permission item to be added

See Also

PermissionItemCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet Namespace


CopyTo Method

[image]

OfficeClip API Documentation
PermissionItemCollection..::.CopyTo Method
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::.Array
index
Type: System..::.Int32

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
PermissionItemCollection..::.GetEnumerator Method
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


IsAuthorized Method

[image]

OfficeClip API Documentation
PermissionItemCollection..::.IsAuthorized Method
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the user is authorized to access the extranet item

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAuthorized(
    int userId
)
Visual Basic (Declaration)
Public Function IsAuthorized ( _
    userId As Integer _
) As Boolean
Visual C++
public:
bool IsAuthorized(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


PermissionItemCollection Properties

[image] [image]

OfficeClip API Documentation
PermissionItemCollection Properties
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

The PermissionItemCollection type exposes the following properties.

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | ItemPermission |
Public property | ItemPermissionString |
Public property | SyncRoot |

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


Count Property

[image]

OfficeClip API Documentation
PermissionItemCollection..::.Count Property
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

The count of the items in the collection

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


IsSynchronized Property

[image]

OfficeClip API Documentation
PermissionItemCollection..::.IsSynchronized Property
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Implements

ICollection..::.IsSynchronized

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


Item Property

[image]

OfficeClip API Documentation
PermissionItemCollection..::.Item Property
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PermissionItem this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PermissionItem
Visual C++
public:
property PermissionItem^ default[int index] {
    PermissionItem^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


ItemPermission Property

[image]

OfficeClip API Documentation
PermissionItemCollection..::.ItemPermission Property
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ItemPermission ItemPermission { get; set; }
Visual Basic (Declaration)
Public Property ItemPermission As ItemPermission
Visual C++
public:
property ItemPermission ItemPermission {
    ItemPermission get ();
    void set (ItemPermission value);
}

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


ItemPermissionString Property

[image]

OfficeClip API Documentation
PermissionItemCollection..::.ItemPermissionString Property
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ItemPermissionString { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemPermissionString As String
Visual C++
public:
property String^ ItemPermissionString {
    String^ get ();
}

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


SyncRoot Property

[image]

OfficeClip API Documentation
PermissionItemCollection..::.SyncRoot Property
PermissionItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Implements

ICollection..::.SyncRoot

See Also

PermissionItemCollection Class
OfficeClip.BusinessLayer.Extranet Namespace


OfficeClip.BusinessLayer.Extranet.User Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Extranet.User Namespace

[This is preliminary documentation and is subject to change.]

Business Layer information for the user part of the customer portal

Classes

 | Class | Description
Public class | ApplicationLink | ApplicationLink is business object that is used to create links to public and secure links of Extranet feature items. The Url property is called to provide a Url pointing to the ExtranetFeature page that includes the encrypted Group and item ID.
Public class | ApplicationLinks | Collection of ApplicationLink's for an Extranet Application.
Public class | ApplicationLinksCollection | Collection of ApplicationLinks for public or secure Extranet feature items.
Public class | CaseDetailItem | Class used to provide information to display a case item label and value for a particular field ID.
Public class | CaseDetailItemCollection | Collection class containing an array of CaseDetilItem(s)
Public class | CaseDetails | Business object used to display case status and details. Contains two collections: One used in building the drop down list for status, and the other for diplaying the case item field name/label and current value.
Public class | ExtranetValueNameCollection | The collection of extranet name value
Public class | IssueTrackerSettings | The class to represent the settings of the issue tracker
Public class | NameValue | Name/value container for use in Name/Value collections
Public class | NoteDetail | Note details business object used in displaying details about a specific note.
Public class | NoteDetailsCollection | the class to represent the collection of the note detail


ApplicationLink Class

[image]

OfficeClip API Documentation
ApplicationLink Class
Members See Also

[This is preliminary documentation and is subject to change.]

ApplicationLink is business object that is used to create links to public and secure links of Extranet feature items. The Url property is called to provide a Url pointing to the ExtranetFeature page that includes the encrypted Group and item ID.

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ApplicationLink
Visual Basic (Declaration)
Public Class ApplicationLink
Visual C++
public ref class ApplicationLink

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.User..::.ApplicationLink

See Also

ApplicationLink Members
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLink Members

[image] [image]

OfficeClip API Documentation
ApplicationLink Members
ApplicationLink Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ApplicationLink type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationLink | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ItemName | the name of the item
Public property | Url |

See Also

ApplicationLink Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLink Constructor

[image] [image]

OfficeClip API Documentation
ApplicationLink Constructor
ApplicationLink Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ApplicationLink(Int32, String, ApplicationLinksCollection) | constructor
Public method | ApplicationLink(Int32, String, String, ApplicationLinksCollection) | constructor

See Also

ApplicationLink Class
ApplicationLink Members
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLink Constructor (Int32, String, ApplicationLinksCollection)

[image]

OfficeClip API Documentation
ApplicationLink Constructor (Int32, String, ApplicationLinksCollection)
ApplicationLink Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationLink(
    int itemId,
    string itemName,
    ApplicationLinksCollection parentCollection
)
Visual Basic (Declaration)
Public Sub New ( _
    itemId As Integer, _
    itemName As String, _
    parentCollection As ApplicationLinksCollection _
)
Visual C++
public:
ApplicationLink(
    int itemId,
    String^ itemName,
    ApplicationLinksCollection^ parentCollection
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
itemName
Type: System..::.String
the name of the item
parentCollection
Type: OfficeClip.BusinessLayer.Extranet.User..::.ApplicationLinksCollection
Reference to parent collection containing this Application Link. Used to access the Group ID of the collection.

See Also

ApplicationLink Class
ApplicationLink Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLink Constructor (Int32, String, String, ApplicationLinksCollection)

[image]

OfficeClip API Documentation
ApplicationLink Constructor (Int32, String, String, ApplicationLinksCollection)
ApplicationLink Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationLink(
    int itemId,
    string itemName,
    string argument,
    ApplicationLinksCollection parentCollection
)
Visual Basic (Declaration)
Public Sub New ( _
    itemId As Integer, _
    itemName As String, _
    argument As String, _
    parentCollection As ApplicationLinksCollection _
)
Visual C++
public:
ApplicationLink(
    int itemId,
    String^ itemName,
    String^ argument,
    ApplicationLinksCollection^ parentCollection
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
itemName
Type: System..::.String
the name of the user
argument
Type: System..::.String
The list of arguments
parentCollection
Type: OfficeClip.BusinessLayer.Extranet.User..::.ApplicationLinksCollection

See Also

ApplicationLink Class
ApplicationLink Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLink Properties

[image] [image]

OfficeClip API Documentation
ApplicationLink Properties
ApplicationLink Class See Also

[This is preliminary documentation and is subject to change.]

The ApplicationLink type exposes the following properties.

Properties

 | Name | Description
Public property | ItemName | the name of the item
Public property | Url |

See Also

ApplicationLink Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ItemName Property

[image]

OfficeClip API Documentation
ApplicationLink..::.ItemName Property
ApplicationLink Class See Also

[This is preliminary documentation and is subject to change.]

the name of the item

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ItemName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemName As String
Visual C++
public:
property String^ ItemName {
    String^ get ();
}

See Also

ApplicationLink Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Url Property

[image]

OfficeClip API Documentation
ApplicationLink..::.Url Property
ApplicationLink Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Url { get; }
Visual Basic (Declaration)
Public ReadOnly Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
}

See Also

ApplicationLink Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinks Class

[image]

OfficeClip API Documentation
ApplicationLinks Class
Members See Also

[This is preliminary documentation and is subject to change.]

Collection of ApplicationLink's for an Extranet Application.

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ApplicationLinks
Visual Basic (Declaration)
Public Class ApplicationLinks
Visual C++
public ref class ApplicationLinks

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.User..::.ApplicationLinks

See Also

ApplicationLinks Members
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinks Members

[image] [image]

OfficeClip API Documentation
ApplicationLinks Members
ApplicationLinks Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ApplicationLinks type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationLinks | Overloaded.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AppName | the name of the application
Public property | Count | The count of the items in the collection
Public property | Item |
Public property | Links |

See Also

ApplicationLinks Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinks Constructor

[image] [image]

OfficeClip API Documentation
ApplicationLinks Constructor
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ApplicationLinks(ApplicationLinksCollection) |
Public method | ApplicationLinks(String, ApplicationLinksCollection) |

See Also

ApplicationLinks Class
ApplicationLinks Members
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinks Constructor (ApplicationLinksCollection)

[image]

OfficeClip API Documentation
ApplicationLinks Constructor (ApplicationLinksCollection)
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationLinks(
    ApplicationLinksCollection parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ApplicationLinksCollection _
)
Visual C++
public:
ApplicationLinks(
    ApplicationLinksCollection^ parent
)

Parameters

parent
Type: OfficeClip.BusinessLayer.Extranet.User..::.ApplicationLinksCollection

See Also

ApplicationLinks Class
ApplicationLinks Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinks Constructor (String, ApplicationLinksCollection)

[image]

OfficeClip API Documentation
ApplicationLinks Constructor (String, ApplicationLinksCollection)
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationLinks(
    string applicationName,
    ApplicationLinksCollection parent
)
Visual Basic (Declaration)
Public Sub New ( _
    applicationName As String, _
    parent As ApplicationLinksCollection _
)
Visual C++
public:
ApplicationLinks(
    String^ applicationName,
    ApplicationLinksCollection^ parent
)

Parameters

applicationName
Type: System..::.String
the name of the application
parent
Type: OfficeClip.BusinessLayer.Extranet.User..::.ApplicationLinksCollection

See Also

ApplicationLinks Class
ApplicationLinks Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinks Methods

[image] [image]

OfficeClip API Documentation
ApplicationLinks Methods
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

The ApplicationLinks type exposes the following methods.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationLinks Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method

[image] [image]

OfficeClip API Documentation
ApplicationLinks..::.Add Method
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Add(Int32, String) | Adds an item to the collection
Public method | Add(Int32, String, String) | Adds an item to the collection

See Also

ApplicationLinks Class
ApplicationLinks Members
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method (Int32, String)

[image]

OfficeClip API Documentation
ApplicationLinks..::.Add Method (Int32, String)
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    int itemId,
    string itemName
)
Visual Basic (Declaration)
Public Sub Add ( _
    itemId As Integer, _
    itemName As String _
)
Visual C++
public:
void Add(
    int itemId,
    String^ itemName
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
itemName
Type: System..::.String
the name of the item

See Also

ApplicationLinks Class
Add Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method (Int32, String, String)

[image]

OfficeClip API Documentation
ApplicationLinks..::.Add Method (Int32, String, String)
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    int itemId,
    string itemName,
    string argument
)
Visual Basic (Declaration)
Public Sub Add ( _
    itemId As Integer, _
    itemName As String, _
    argument As String _
)
Visual C++
public:
void Add(
    int itemId,
    String^ itemName,
    String^ argument
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
itemName
Type: System..::.String
the name of the item
argument
Type: System..::.String
The list of arguments

See Also

ApplicationLinks Class
Add Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
ApplicationLinks..::.GetEnumerator Method
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
IEnumerator^ GetEnumerator()

Return Value

See Also

ApplicationLinks Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinks Properties

[image] [image]

OfficeClip API Documentation
ApplicationLinks Properties
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

The ApplicationLinks type exposes the following properties.

Properties

 | Name | Description
Public property | AppName | the name of the application
Public property | Count | The count of the items in the collection
Public property | Item |
Public property | Links |

See Also

ApplicationLinks Class
OfficeClip.BusinessLayer.Extranet.User Namespace


AppName Property

[image]

OfficeClip API Documentation
ApplicationLinks..::.AppName Property
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

the name of the application

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AppName { get; set; }
Visual Basic (Declaration)
Public Property AppName As String
Visual C++
public:
property String^ AppName {
    String^ get ();
    void set (String^ value);
}

See Also

ApplicationLinks Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Count Property

[image]

OfficeClip API Documentation
ApplicationLinks..::.Count Property
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

The count of the items in the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

ApplicationLinks Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Item Property

[image]

OfficeClip API Documentation
ApplicationLinks..::.Item Property
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationLink this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ApplicationLink
Visual C++
public:
property ApplicationLink^ default[int index] {
    ApplicationLink^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ApplicationLinks Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Links Property

[image]

OfficeClip API Documentation
ApplicationLinks..::.Links Property
ApplicationLinks Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Links { get; }
Visual Basic (Declaration)
Public ReadOnly Property Links As ArrayList
Visual C++
public:
property ArrayList^ Links {
    ArrayList^ get ();
}

See Also

ApplicationLinks Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinksCollection Class

[image]

OfficeClip API Documentation
ApplicationLinksCollection Class
Members See Also

[This is preliminary documentation and is subject to change.]

Collection of ApplicationLinks for public or secure Extranet feature items.

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ApplicationLinksCollection
Visual Basic (Declaration)
Public Class ApplicationLinksCollection
Visual C++
public ref class ApplicationLinksCollection

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.User..::.ApplicationLinksCollection

See Also

ApplicationLinksCollection Members
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinksCollection Members

[image] [image]

OfficeClip API Documentation
ApplicationLinksCollection Members
ApplicationLinksCollection Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ApplicationLinksCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationLinksCollection |

Methods

 | Name | Description
Public method | Add | Adds an item to the collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationLinks |
Public property | GroupID | The unique id of the group

See Also

ApplicationLinksCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinksCollection Constructor

[image]

OfficeClip API Documentation
ApplicationLinksCollection Constructor
ApplicationLinksCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationLinksCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ApplicationLinksCollection()

See Also

ApplicationLinksCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinksCollection Methods

[image] [image]

OfficeClip API Documentation
ApplicationLinksCollection Methods
ApplicationLinksCollection Class See Also

[This is preliminary documentation and is subject to change.]

The ApplicationLinksCollection type exposes the following methods.

Methods

 | Name | Description
Public method | Add | Adds an item to the collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationLinksCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method

[image]

OfficeClip API Documentation
ApplicationLinksCollection..::.Add Method
ApplicationLinksCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationLinks Add(
    string applicationName
)
Visual Basic (Declaration)
Public Function Add ( _
    applicationName As String _
) As ApplicationLinks
Visual C++
public:
ApplicationLinks^ Add(
    String^ applicationName
)

Parameters

applicationName
Type: System..::.String
the name of the application

Return Value

See Also

ApplicationLinksCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
ApplicationLinksCollection..::.GetEnumerator Method
ApplicationLinksCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
IEnumerator^ GetEnumerator()

Return Value

See Also

ApplicationLinksCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinksCollection Properties

[image] [image]

OfficeClip API Documentation
ApplicationLinksCollection Properties
ApplicationLinksCollection Class See Also

[This is preliminary documentation and is subject to change.]

The ApplicationLinksCollection type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationLinks |
Public property | GroupID | The unique id of the group

See Also

ApplicationLinksCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ApplicationLinks Property

[image]

OfficeClip API Documentation
ApplicationLinksCollection..::.ApplicationLinks Property
ApplicationLinksCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList ApplicationLinks { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationLinks As ArrayList
Visual C++
public:
property ArrayList^ ApplicationLinks {
    ArrayList^ get ();
}

See Also

ApplicationLinksCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


GroupID Property

[image]

OfficeClip API Documentation
ApplicationLinksCollection..::.GroupID Property
ApplicationLinksCollection Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the group

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupID { get; set; }
Visual Basic (Declaration)
Public Property GroupID As Integer
Visual C++
public:
property int GroupID {
    int get ();
    void set (int value);
}

See Also

ApplicationLinksCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItem Class

[image]

OfficeClip API Documentation
CaseDetailItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class used to provide information to display a case item label and value for a particular field ID.

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class CaseDetailItem
Visual Basic (Declaration)
Public Class CaseDetailItem
Visual C++
public ref class CaseDetailItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.User..::.CaseDetailItem

See Also

CaseDetailItem Members
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItem Members

[image] [image]

OfficeClip API Documentation
CaseDetailItem Members
CaseDetailItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The CaseDetailItem type exposes the following members.

Constructors

 | Name | Description
Public method | CaseDetailItem | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FieldDisplayLabel |
Public property | FieldID |
Public property | FieldValue |

See Also

CaseDetailItem Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItem Constructor

[image] [image]

OfficeClip API Documentation
CaseDetailItem Constructor
CaseDetailItem Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | CaseDetailItem()()() |
Public method | CaseDetailItem(Int32, String) |
Public method | CaseDetailItem(Int32, String, String) |

See Also

CaseDetailItem Class
CaseDetailItem Members
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItem Constructor

[image]

OfficeClip API Documentation
CaseDetailItem Constructor
CaseDetailItem Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CaseDetailItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CaseDetailItem()

See Also

CaseDetailItem Class
CaseDetailItem Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItem Constructor (Int32, String)

[image]

OfficeClip API Documentation
CaseDetailItem Constructor (Int32, String)
CaseDetailItem Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CaseDetailItem(
    int fieldId,
    string displayLabel
)
Visual Basic (Declaration)
Public Sub New ( _
    fieldId As Integer, _
    displayLabel As String _
)
Visual C++
public:
CaseDetailItem(
    int fieldId,
    String^ displayLabel
)

Parameters

fieldId
Type: System..::.Int32
displayLabel
Type: System..::.String

See Also

CaseDetailItem Class
CaseDetailItem Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItem Constructor (Int32, String, String)

[image]

OfficeClip API Documentation
CaseDetailItem Constructor (Int32, String, String)
CaseDetailItem Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CaseDetailItem(
    int fieldId,
    string fieldLabel,
    string fieldValue
)
Visual Basic (Declaration)
Public Sub New ( _
    fieldId As Integer, _
    fieldLabel As String, _
    fieldValue As String _
)
Visual C++
public:
CaseDetailItem(
    int fieldId,
    String^ fieldLabel,
    String^ fieldValue
)

Parameters

fieldId
Type: System..::.Int32
Field ID identifying the case detail item being displayed.
fieldLabel
Type: System..::.String
The identifying label of the case detail item being displayed
fieldValue
Type: System..::.String
Value of case detail item being displayed.

See Also

CaseDetailItem Class
CaseDetailItem Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItem Properties

[image] [image]

OfficeClip API Documentation
CaseDetailItem Properties
CaseDetailItem Class See Also

[This is preliminary documentation and is subject to change.]

The CaseDetailItem type exposes the following properties.

Properties

 | Name | Description
Public property | FieldDisplayLabel |
Public property | FieldID |
Public property | FieldValue |

See Also

CaseDetailItem Class
OfficeClip.BusinessLayer.Extranet.User Namespace


FieldDisplayLabel Property

[image]

OfficeClip API Documentation
CaseDetailItem..::.FieldDisplayLabel Property
CaseDetailItem Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FieldDisplayLabel { get; set; }
Visual Basic (Declaration)
Public Property FieldDisplayLabel As String
Visual C++
public:
property String^ FieldDisplayLabel {
    String^ get ();
    void set (String^ value);
}

See Also

CaseDetailItem Class
OfficeClip.BusinessLayer.Extranet.User Namespace


FieldID Property

[image]

OfficeClip API Documentation
CaseDetailItem..::.FieldID Property
CaseDetailItem Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int FieldID { get; set; }
Visual Basic (Declaration)
Public Property FieldID As Integer
Visual C++
public:
property int FieldID {
    int get ();
    void set (int value);
}

See Also

CaseDetailItem Class
OfficeClip.BusinessLayer.Extranet.User Namespace


FieldValue Property

[image]

OfficeClip API Documentation
CaseDetailItem..::.FieldValue Property
CaseDetailItem Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FieldValue { get; set; }
Visual Basic (Declaration)
Public Property FieldValue As String
Visual C++
public:
property String^ FieldValue {
    String^ get ();
    void set (String^ value);
}

See Also

CaseDetailItem Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItemCollection Class

[image]

OfficeClip API Documentation
CaseDetailItemCollection Class
Members See Also

[This is preliminary documentation and is subject to change.]

Collection class containing an array of CaseDetilItem(s)

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class CaseDetailItemCollection : ICollection,
    IEnumerable
Visual Basic (Declaration)
Public Class CaseDetailItemCollection _
    Implements ICollection, IEnumerable
Visual C++
public ref class CaseDetailItemCollection : ICollection,
    IEnumerable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.User..::.CaseDetailItemCollection

See Also

CaseDetailItemCollection Members
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItemCollection Members

[image] [image]

OfficeClip API Documentation
CaseDetailItemCollection Members
CaseDetailItemCollection Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The CaseDetailItemCollection type exposes the following members.

Constructors

 | Name | Description
Public method | CaseDetailItemCollection |

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetEnumerator | Gets the enumerator
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | Items | Returns the collection of CaseDetailItems(s)
Public property | SyncRoot |

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItemCollection Constructor

[image]

OfficeClip API Documentation
CaseDetailItemCollection Constructor
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CaseDetailItemCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CaseDetailItemCollection()

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItemCollection Methods

[image] [image]

OfficeClip API Documentation
CaseDetailItemCollection Methods
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

The CaseDetailItemCollection type exposes the following methods.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetEnumerator | Gets the enumerator
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method

[image] [image]

OfficeClip API Documentation
CaseDetailItemCollection..::.Add Method
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Add(CaseDetailItem) | Adds an item to the collection
Public method | Add(Int32, String) | Adds an item to the collection
Public method | Add(Int32, String, String) | Adds an item to the collection

See Also

CaseDetailItemCollection Class
CaseDetailItemCollection Members
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method (CaseDetailItem)

[image]

OfficeClip API Documentation
CaseDetailItemCollection..::.Add Method (CaseDetailItem)
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    CaseDetailItem item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As CaseDetailItem _
)
Visual C++
public:
void Add(
    CaseDetailItem^ item
)

Parameters

item
Type: OfficeClip.BusinessLayer.Extranet.User..::.CaseDetailItem

See Also

CaseDetailItemCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method (Int32, String)

[image]

OfficeClip API Documentation
CaseDetailItemCollection..::.Add Method (Int32, String)
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CaseDetailItem Add(
    int fieldId,
    string fieldLabel
)
Visual Basic (Declaration)
Public Function Add ( _
    fieldId As Integer, _
    fieldLabel As String _
) As CaseDetailItem
Visual C++
public:
CaseDetailItem^ Add(
    int fieldId,
    String^ fieldLabel
)

Parameters

fieldId
Type: System..::.Int32
fieldLabel
Type: System..::.String

Return Value

See Also

CaseDetailItemCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method (Int32, String, String)

[image]

OfficeClip API Documentation
CaseDetailItemCollection..::.Add Method (Int32, String, String)
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    int fieldId,
    string fieldLabel,
    string fieldValue
)
Visual Basic (Declaration)
Public Sub Add ( _
    fieldId As Integer, _
    fieldLabel As String, _
    fieldValue As String _
)
Visual C++
public:
void Add(
    int fieldId,
    String^ fieldLabel,
    String^ fieldValue
)

Parameters

fieldId
Type: System..::.Int32
fieldLabel
Type: System..::.String
fieldValue
Type: System..::.String

See Also

CaseDetailItemCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


CopyTo Method

[image]

OfficeClip API Documentation
CaseDetailItemCollection..::.CopyTo Method
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::.Array
index
Type: System..::.Int32

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Get Method

[image]

OfficeClip API Documentation
CaseDetailItemCollection..::.Get Method
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CaseDetailItem Get(
    int fieldId
)
Visual Basic (Declaration)
Public Function Get ( _
    fieldId As Integer _
) As CaseDetailItem
Visual C++
public:
CaseDetailItem^ Get(
    int fieldId
)

Parameters

fieldId
Type: System..::.Int32

Return Value

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
CaseDetailItemCollection..::.GetEnumerator Method
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Gets the enumerator

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

The enumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetailItemCollection Properties

[image] [image]

OfficeClip API Documentation
CaseDetailItemCollection Properties
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

The CaseDetailItemCollection type exposes the following properties.

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | Items | Returns the collection of CaseDetailItems(s)
Public property | SyncRoot |

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Count Property

[image]

OfficeClip API Documentation
CaseDetailItemCollection..::.Count Property
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

The count of the items in the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


IsSynchronized Property

[image]

OfficeClip API Documentation
CaseDetailItemCollection..::.IsSynchronized Property
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Implements

ICollection..::.IsSynchronized

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Item Property

[image]

OfficeClip API Documentation
CaseDetailItemCollection..::.Item Property
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CaseDetailItem this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As CaseDetailItem
Visual C++
public:
property CaseDetailItem^ default[int index] {
    CaseDetailItem^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Items Property

[image]

OfficeClip API Documentation
CaseDetailItemCollection..::.Items Property
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Returns the collection of CaseDetailItems(s)

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As ArrayList
Visual C++
public:
property ArrayList^ Items {
    ArrayList^ get ();
}

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


SyncRoot Property

[image]

OfficeClip API Documentation
CaseDetailItemCollection..::.SyncRoot Property
CaseDetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Implements

ICollection..::.SyncRoot

See Also

CaseDetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetails Class

[image]

OfficeClip API Documentation
CaseDetails Class
Members See Also

[This is preliminary documentation and is subject to change.]

Business object used to display case status and details. Contains two collections: One used in building the drop down list for status, and the other for diplaying the case item field name/label and current value.

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class CaseDetails
Visual Basic (Declaration)
Public Class CaseDetails
Visual C++
public ref class CaseDetails

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.User..::.CaseDetails

See Also

CaseDetails Members
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetails Members

[image] [image]

OfficeClip API Documentation
CaseDetails Members
CaseDetails Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The CaseDetails type exposes the following members.

Constructors

 | Name | Description
Public method | CaseDetails | default constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CaseDisplayItems | Returns the collection used in displaying field names and current values.
Public property | CaseID | The unique id of the case
Public property | CaseName | the name of the case
Public property | CaseNumber | the case number
Public property | CaseStatusList | Returns the collection class that will be used to build the case Status drop down list. This class contains the selected value, as well as a collection of name/value pairs that will be used to build the Status DropDownList.
Public property | ProjectName | the name of the project

See Also

CaseDetails Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetails Constructor

[image]

OfficeClip API Documentation
CaseDetails Constructor
CaseDetails Class See Also

[This is preliminary documentation and is subject to change.]

default constructor

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CaseDetails()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CaseDetails()

See Also

CaseDetails Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDetails Properties

[image] [image]

OfficeClip API Documentation
CaseDetails Properties
CaseDetails Class See Also

[This is preliminary documentation and is subject to change.]

The CaseDetails type exposes the following properties.

Properties

 | Name | Description
Public property | CaseDisplayItems | Returns the collection used in displaying field names and current values.
Public property | CaseID | The unique id of the case
Public property | CaseName | the name of the case
Public property | CaseNumber | the case number
Public property | CaseStatusList | Returns the collection class that will be used to build the case Status drop down list. This class contains the selected value, as well as a collection of name/value pairs that will be used to build the Status DropDownList.
Public property | ProjectName | the name of the project

See Also

CaseDetails Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseDisplayItems Property

[image]

OfficeClip API Documentation
CaseDetails..::.CaseDisplayItems Property
CaseDetails Class See Also

[This is preliminary documentation and is subject to change.]

Returns the collection used in displaying field names and current values.

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CaseDetailItemCollection CaseDisplayItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property CaseDisplayItems As CaseDetailItemCollection
Visual C++
public:
property CaseDetailItemCollection^ CaseDisplayItems {
    CaseDetailItemCollection^ get ();
}

See Also

CaseDetails Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseID Property

[image]

OfficeClip API Documentation
CaseDetails..::.CaseID Property
CaseDetails Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the case

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CaseID { get; set; }
Visual Basic (Declaration)
Public Property CaseID As Integer
Visual C++
public:
property int CaseID {
    int get ();
    void set (int value);
}

See Also

CaseDetails Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseName Property

[image]

OfficeClip API Documentation
CaseDetails..::.CaseName Property
CaseDetails Class See Also

[This is preliminary documentation and is subject to change.]

the name of the case

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CaseName { get; set; }
Visual Basic (Declaration)
Public Property CaseName As String
Visual C++
public:
property String^ CaseName {
    String^ get ();
    void set (String^ value);
}

See Also

CaseDetails Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseNumber Property

[image]

OfficeClip API Documentation
CaseDetails..::.CaseNumber Property
CaseDetails Class See Also

[This is preliminary documentation and is subject to change.]

the case number

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CaseNumber { get; set; }
Visual Basic (Declaration)
Public Property CaseNumber As String
Visual C++
public:
property String^ CaseNumber {
    String^ get ();
    void set (String^ value);
}

See Also

CaseDetails Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseStatusList Property

[image]

OfficeClip API Documentation
CaseDetails..::.CaseStatusList Property
CaseDetails Class See Also

[This is preliminary documentation and is subject to change.]

Returns the collection class that will be used to build the case Status drop down list. This class contains the selected value, as well as a collection of name/value pairs that will be used to build the Status DropDownList.

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExtranetValueNameCollection CaseStatusList { get; set; }
Visual Basic (Declaration)
Public Property CaseStatusList As ExtranetValueNameCollection
Visual C++
public:
property ExtranetValueNameCollection^ CaseStatusList {
    ExtranetValueNameCollection^ get ();
    void set (ExtranetValueNameCollection^ value);
}

See Also

CaseDetails Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ProjectName Property

[image]

OfficeClip API Documentation
CaseDetails..::.ProjectName Property
CaseDetails Class See Also

[This is preliminary documentation and is subject to change.]

the name of the project

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProjectName { get; set; }
Visual Basic (Declaration)
Public Property ProjectName As String
Visual C++
public:
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}

See Also

CaseDetails Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ExtranetValueNameCollection Class

[image]

OfficeClip API Documentation
ExtranetValueNameCollection Class
Members See Also

[This is preliminary documentation and is subject to change.]

The collection of extranet name value

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ExtranetValueNameCollection
Visual Basic (Declaration)
Public Class ExtranetValueNameCollection
Visual C++
public ref class ExtranetValueNameCollection

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.User..::.ExtranetValueNameCollection

See Also

ExtranetValueNameCollection Members
OfficeClip.BusinessLayer.Extranet.User Namespace


ExtranetValueNameCollection Members

[image] [image]

OfficeClip API Documentation
ExtranetValueNameCollection Members
ExtranetValueNameCollection Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExtranetValueNameCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ExtranetValueNameCollection | default constructor

Methods

 | Name | Description
Public method | Add | Adds a name/value pair to the collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | Item | Indexed Name/Value item in collection
Public property | SelectedValue | Selected value of collection

See Also

ExtranetValueNameCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ExtranetValueNameCollection Constructor

[image]

OfficeClip API Documentation
ExtranetValueNameCollection Constructor
ExtranetValueNameCollection Class See Also

[This is preliminary documentation and is subject to change.]

default constructor

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExtranetValueNameCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExtranetValueNameCollection()

See Also

ExtranetValueNameCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ExtranetValueNameCollection Methods

[image] [image]

OfficeClip API Documentation
ExtranetValueNameCollection Methods
ExtranetValueNameCollection Class See Also

[This is preliminary documentation and is subject to change.]

The ExtranetValueNameCollection type exposes the following methods.

Methods

 | Name | Description
Public method | Add | Adds a name/value pair to the collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtranetValueNameCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method

[image]

OfficeClip API Documentation
ExtranetValueNameCollection..::.Add Method
ExtranetValueNameCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds a name/value pair to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    string name,
    string val
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    val As String _
)
Visual C++
public:
void Add(
    String^ name,
    String^ val
)

Parameters

name
Type: System..::.String
val
Type: System..::.String

See Also

ExtranetValueNameCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ExtranetValueNameCollection Properties

[image] [image]

OfficeClip API Documentation
ExtranetValueNameCollection Properties
ExtranetValueNameCollection Class See Also

[This is preliminary documentation and is subject to change.]

The ExtranetValueNameCollection type exposes the following properties.

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | Item | Indexed Name/Value item in collection
Public property | SelectedValue | Selected value of collection

See Also

ExtranetValueNameCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Count Property

[image]

OfficeClip API Documentation
ExtranetValueNameCollection..::.Count Property
ExtranetValueNameCollection Class See Also

[This is preliminary documentation and is subject to change.]

The count of the items in the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

ExtranetValueNameCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Item Property

[image]

OfficeClip API Documentation
ExtranetValueNameCollection..::.Item Property
ExtranetValueNameCollection Class See Also

[This is preliminary documentation and is subject to change.]

Indexed Name/Value item in collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NameValue this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As NameValue
Visual C++
public:
property NameValue^ default[int index] {
    NameValue^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ExtranetValueNameCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


SelectedValue Property

[image]

OfficeClip API Documentation
ExtranetValueNameCollection..::.SelectedValue Property
ExtranetValueNameCollection Class See Also

[This is preliminary documentation and is subject to change.]

Selected value of collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SelectedValue { get; set; }
Visual Basic (Declaration)
Public Property SelectedValue As String
Visual C++
public:
property String^ SelectedValue {
    String^ get ();
    void set (String^ value);
}

See Also

ExtranetValueNameCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


IssueTrackerSettings Class

[image]

OfficeClip API Documentation
IssueTrackerSettings Class
Members See Also

[This is preliminary documentation and is subject to change.]

The class to represent the settings of the issue tracker

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class IssueTrackerSettings
Visual Basic (Declaration)
Public Class IssueTrackerSettings
Visual C++
public ref class IssueTrackerSettings

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.User..::.IssueTrackerSettings

See Also

IssueTrackerSettings Members
OfficeClip.BusinessLayer.Extranet.User Namespace


IssueTrackerSettings Members

[image] [image]

OfficeClip API Documentation
IssueTrackerSettings Members
IssueTrackerSettings Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The IssueTrackerSettings type exposes the following members.

Constructors

 | Name | Description
Public method | IssueTrackerSettings | default constructor

Methods

 | Name | Description
Public method | EncryptedQueryStringArgument | The encrypted query string argument
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _attachments | Whether to display the attachment control
Protected field | _caseId | The case id
Protected field | _email | email
Protected field | _featureItem | feature item xml
Protected field | _groupId | unique id of the group
Protected field | _hasTrackingTicket | Has Tracking Ticket
Protected field | _isSecure | Is secured
Protected field | _itemId | The item id
Protected field | _itemXml | The item xml
Protected field | _projectId | The project id
Protected field | _queryStringArguement | Query string argument
Protected field | _returnUrl | The return url
Protected field | _statusMsg | Status Message
Protected field | _userId | The unique id of the user

Properties

 | Name | Description
Public property | Attachments | Whether to display the attachment control
Public property | CaseID | the unique id of the case
Public property | EMailAddress | The email address of the user
Public property | FeatureItem | The feature item
Public property | GroupID | The unique id of the group
Public property | HasTrackingTicket | True if the issue has the tracking ticket
Public property | IsSecure | True if the tracker item is secure
Public property | ItemID | the unique id of the item
Public property | ItemXml | teh xml representation of the item
Public property | ProjectID | The unique id of the project
Public property | QueryStringArgument | The query string argument
Public property | ReturnUrl | The return url
Public property | StatusMsg | The status message
Public property | UserID | The unique id of the user

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


IssueTrackerSettings Constructor

[image]

OfficeClip API Documentation
IssueTrackerSettings Constructor
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

default constructor

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IssueTrackerSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
IssueTrackerSettings()

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


IssueTrackerSettings Fields

[image] [image]

OfficeClip API Documentation
IssueTrackerSettings Fields
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The IssueTrackerSettings type exposes the following fields.

Fields

 | Name | Description
Protected field | _attachments | Whether to display the attachment control
Protected field | _caseId | The case id
Protected field | _email | email
Protected field | _featureItem | feature item xml
Protected field | _groupId | unique id of the group
Protected field | _hasTrackingTicket | Has Tracking Ticket
Protected field | _isSecure | Is secured
Protected field | _itemId | The item id
Protected field | _itemXml | The item xml
Protected field | _projectId | The project id
Protected field | _queryStringArguement | Query string argument
Protected field | _returnUrl | The return url
Protected field | _statusMsg | Status Message
Protected field | _userId | The unique id of the user

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_attachments Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._attachments Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

Whether to display the attachment control

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected bool _attachments
Visual Basic (Declaration)
Protected _attachments As Boolean
Visual C++
protected:
bool _attachments

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_caseId Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._caseId Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The case id

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _caseId
Visual Basic (Declaration)
Protected _caseId As Integer
Visual C++
protected:
int _caseId

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_email Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._email Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

email

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _email
Visual Basic (Declaration)
Protected _email As String
Visual C++
protected:
String^ _email

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_featureItem Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._featureItem Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

feature item xml

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected FeatureItem _featureItem
Visual Basic (Declaration)
Protected _featureItem As FeatureItem
Visual C++
protected:
FeatureItem^ _featureItem

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_groupId Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._groupId Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

unique id of the group

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _groupId
Visual Basic (Declaration)
Protected _groupId As Integer
Visual C++
protected:
int _groupId

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_hasTrackingTicket Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._hasTrackingTicket Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

Has Tracking Ticket

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected bool _hasTrackingTicket
Visual Basic (Declaration)
Protected _hasTrackingTicket As Boolean
Visual C++
protected:
bool _hasTrackingTicket

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_isSecure Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._isSecure Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

Is secured

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected bool _isSecure
Visual Basic (Declaration)
Protected _isSecure As Boolean
Visual C++
protected:
bool _isSecure

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_itemId Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._itemId Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The item id

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _itemId
Visual Basic (Declaration)
Protected _itemId As Integer
Visual C++
protected:
int _itemId

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_itemXml Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._itemXml Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The item xml

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _itemXml
Visual Basic (Declaration)
Protected _itemXml As String
Visual C++
protected:
String^ _itemXml

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_projectId Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._projectId Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The project id

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _projectId
Visual Basic (Declaration)
Protected _projectId As Integer
Visual C++
protected:
int _projectId

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_queryStringArguement Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._queryStringArguement Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

Query string argument

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _queryStringArguement
Visual Basic (Declaration)
Protected _queryStringArguement As String
Visual C++
protected:
String^ _queryStringArguement

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_returnUrl Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._returnUrl Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The return url

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _returnUrl
Visual Basic (Declaration)
Protected _returnUrl As String
Visual C++
protected:
String^ _returnUrl

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_statusMsg Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._statusMsg Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

Status Message

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _statusMsg
Visual Basic (Declaration)
Protected _statusMsg As String
Visual C++
protected:
String^ _statusMsg

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


_userId Field

[image]

OfficeClip API Documentation
IssueTrackerSettings..::._userId Field
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _userId
Visual Basic (Declaration)
Protected _userId As Integer
Visual C++
protected:
int _userId

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


IssueTrackerSettings Methods

[image] [image]

OfficeClip API Documentation
IssueTrackerSettings Methods
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The IssueTrackerSettings type exposes the following methods.

Methods

 | Name | Description
Public method | EncryptedQueryStringArgument | The encrypted query string argument
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


EncryptedQueryStringArgument Method

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.EncryptedQueryStringArgument Method
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The encrypted query string argument

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void EncryptedQueryStringArgument(
    string arg
)
Visual Basic (Declaration)
Public Sub EncryptedQueryStringArgument ( _
    arg As String _
)
Visual C++
public:
void EncryptedQueryStringArgument(
    String^ arg
)

Parameters

arg
Type: System..::.String
The query string argument (plain text)

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


IssueTrackerSettings Properties

[image] [image]

OfficeClip API Documentation
IssueTrackerSettings Properties
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The IssueTrackerSettings type exposes the following properties.

Properties

 | Name | Description
Public property | Attachments | Whether to display the attachment control
Public property | CaseID | the unique id of the case
Public property | EMailAddress | The email address of the user
Public property | FeatureItem | The feature item
Public property | GroupID | The unique id of the group
Public property | HasTrackingTicket | True if the issue has the tracking ticket
Public property | IsSecure | True if the tracker item is secure
Public property | ItemID | the unique id of the item
Public property | ItemXml | teh xml representation of the item
Public property | ProjectID | The unique id of the project
Public property | QueryStringArgument | The query string argument
Public property | ReturnUrl | The return url
Public property | StatusMsg | The status message
Public property | UserID | The unique id of the user

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Attachments Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.Attachments Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

Whether to display the attachment control

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool Attachments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Attachments As Boolean
Visual C++
public:
property bool Attachments {
    bool get ();
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CaseID Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.CaseID Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

the unique id of the case

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CaseID { get; set; }
Visual Basic (Declaration)
Public Property CaseID As Integer
Visual C++
public:
property int CaseID {
    int get ();
    void set (int value);
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


EMailAddress Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.EMailAddress Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The email address of the user

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EMailAddress { get; set; }
Visual Basic (Declaration)
Public Property EMailAddress As String
Visual C++
public:
property String^ EMailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


FeatureItem Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.FeatureItem Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The feature item

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public FeatureItem FeatureItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property FeatureItem As FeatureItem
Visual C++
public:
property FeatureItem^ FeatureItem {
    FeatureItem^ get ();
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


GroupID Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.GroupID Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the group

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupID { get; set; }
Visual Basic (Declaration)
Public Property GroupID As Integer
Visual C++
public:
property int GroupID {
    int get ();
    void set (int value);
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


HasTrackingTicket Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.HasTrackingTicket Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

True if the issue has the tracking ticket

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool HasTrackingTicket { get; set; }
Visual Basic (Declaration)
Public Property HasTrackingTicket As Boolean
Visual C++
public:
property bool HasTrackingTicket {
    bool get ();
    void set (bool value);
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


IsSecure Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.IsSecure Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

True if the tracker item is secure

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSecure { get; set; }
Visual Basic (Declaration)
Public Property IsSecure As Boolean
Visual C++
public:
property bool IsSecure {
    bool get ();
    void set (bool value);
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ItemID Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.ItemID Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

the unique id of the item

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ItemID { get; set; }
Visual Basic (Declaration)
Public Property ItemID As Integer
Visual C++
public:
property int ItemID {
    int get ();
    void set (int value);
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ItemXml Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.ItemXml Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

teh xml representation of the item

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ItemXml { get; set; }
Visual Basic (Declaration)
Public Property ItemXml As String
Visual C++
public:
property String^ ItemXml {
    String^ get ();
    void set (String^ value);
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ProjectID Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.ProjectID Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the project

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ProjectID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProjectID As Integer
Visual C++
public:
property int ProjectID {
    int get ();
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


QueryStringArgument Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.QueryStringArgument Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The query string argument

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string QueryStringArgument { get; set; }
Visual Basic (Declaration)
Public Property QueryStringArgument As String
Visual C++
public:
property String^ QueryStringArgument {
    String^ get ();
    void set (String^ value);
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


ReturnUrl Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.ReturnUrl Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The return url

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReturnUrl { get; set; }
Visual Basic (Declaration)
Public Property ReturnUrl As String
Visual C++
public:
property String^ ReturnUrl {
    String^ get ();
    void set (String^ value);
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


StatusMsg Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.StatusMsg Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The status message

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string StatusMsg { get; set; }
Visual Basic (Declaration)
Public Property StatusMsg As String
Visual C++
public:
property String^ StatusMsg {
    String^ get ();
    void set (String^ value);
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


UserID Property

[image]

OfficeClip API Documentation
IssueTrackerSettings..::.UserID Property
IssueTrackerSettings Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserID { get; set; }
Visual Basic (Declaration)
Public Property UserID As Integer
Visual C++
public:
property int UserID {
    int get ();
    void set (int value);
}

See Also

IssueTrackerSettings Class
OfficeClip.BusinessLayer.Extranet.User Namespace


NameValue Class

[image]

OfficeClip API Documentation
NameValue Class
Members See Also

[This is preliminary documentation and is subject to change.]

Name/value container for use in Name/Value collections

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class NameValue
Visual Basic (Declaration)
Public Class NameValue
Visual C++
public ref class NameValue

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.User..::.NameValue

See Also

NameValue Members
OfficeClip.BusinessLayer.Extranet.User Namespace


NameValue Members

[image] [image]

OfficeClip API Documentation
NameValue Members
NameValue Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The NameValue type exposes the following members.

Constructors

 | Name | Description
Public method | NameValue | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

NameValue Class
OfficeClip.BusinessLayer.Extranet.User Namespace


NameValue Constructor

[image] [image]

OfficeClip API Documentation
NameValue Constructor
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | NameValue()()() | constructor
Public method | NameValue(String, String) | contructor

See Also

NameValue Class
NameValue Members
OfficeClip.BusinessLayer.Extranet.User Namespace


NameValue Constructor

[image]

OfficeClip API Documentation
NameValue Constructor
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NameValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NameValue()

See Also

NameValue Class
NameValue Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


NameValue Constructor (String, String)

[image]

OfficeClip API Documentation
NameValue Constructor (String, String)
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

contructor

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NameValue(
    string name,
    string val
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    val As String _
)
Visual C++
public:
NameValue(
    String^ name,
    String^ val
)

Parameters

name
Type: System..::.String
val
Type: System..::.String

See Also

NameValue Class
NameValue Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


NameValue Properties

[image] [image]

OfficeClip API Documentation
NameValue Properties
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

The NameValue type exposes the following properties.

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

NameValue Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Name Property

[image]

OfficeClip API Documentation
NameValue..::.Name Property
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

NameValue Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Value Property

[image]

OfficeClip API Documentation
NameValue..::.Value Property
NameValue Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

NameValue Class
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteDetail Class

[image]

OfficeClip API Documentation
NoteDetail Class
Members See Also

[This is preliminary documentation and is subject to change.]

Note details business object used in displaying details about a specific note.

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class NoteDetail
Visual Basic (Declaration)
Public Class NoteDetail
Visual C++
public ref class NoteDetail

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.User..::.NoteDetail

See Also

NoteDetail Members
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteDetail Members

[image] [image]

OfficeClip API Documentation
NoteDetail Members
NoteDetail Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The NoteDetail type exposes the following members.

Constructors

 | Name | Description
Public method | NoteDetail | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Created | Date string indicating when note was created.
Public property | CreatedBy | Who created the note
Public property | NoteID | the unique id of the note
Public property | NoteText | The text of the note

See Also

NoteDetail Class
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteDetail Constructor

[image] [image]

OfficeClip API Documentation
NoteDetail Constructor
NoteDetail Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | NoteDetail(String, String, String) | constructor
Public method | NoteDetail(Int32, String, String, String) | constructor

See Also

NoteDetail Class
NoteDetail Members
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteDetail Constructor (String, String, String)

[image]

OfficeClip API Documentation
NoteDetail Constructor (String, String, String)
NoteDetail Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NoteDetail(
    string createdBy,
    string created,
    string noteText
)
Visual Basic (Declaration)
Public Sub New ( _
    createdBy As String, _
    created As String, _
    noteText As String _
)
Visual C++
public:
NoteDetail(
    String^ createdBy,
    String^ created,
    String^ noteText
)

Parameters

createdBy
Type: System..::.String
E-mail address of user creating the note.
created
Type: System..::.String
Date string identifying when the note was created.
noteText
Type: System..::.String
The text of the note created.

See Also

NoteDetail Class
NoteDetail Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteDetail Constructor (Int32, String, String, String)

[image]

OfficeClip API Documentation
NoteDetail Constructor (Int32, String, String, String)
NoteDetail Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NoteDetail(
    int noteId,
    string createdBy,
    string created,
    string noteText
)
Visual Basic (Declaration)
Public Sub New ( _
    noteId As Integer, _
    createdBy As String, _
    created As String, _
    noteText As String _
)
Visual C++
public:
NoteDetail(
    int noteId,
    String^ createdBy,
    String^ created,
    String^ noteText
)

Parameters

noteId
Type: System..::.Int32
The unique id of the note
createdBy
Type: System..::.String
E-mail address of user creating the note.
created
Type: System..::.String
Date string identifying when the note was created.
noteText
Type: System..::.String
The text of the note created.

See Also

NoteDetail Class
NoteDetail Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteDetail Properties

[image] [image]

OfficeClip API Documentation
NoteDetail Properties
NoteDetail Class See Also

[This is preliminary documentation and is subject to change.]

The NoteDetail type exposes the following properties.

Properties

 | Name | Description
Public property | Created | Date string indicating when note was created.
Public property | CreatedBy | Who created the note
Public property | NoteID | the unique id of the note
Public property | NoteText | The text of the note

See Also

NoteDetail Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Created Property

[image]

OfficeClip API Documentation
NoteDetail..::.Created Property
NoteDetail Class See Also

[This is preliminary documentation and is subject to change.]

Date string indicating when note was created.

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Created { get; }
Visual Basic (Declaration)
Public ReadOnly Property Created As String
Visual C++
public:
property String^ Created {
    String^ get ();
}

See Also

NoteDetail Class
OfficeClip.BusinessLayer.Extranet.User Namespace


CreatedBy Property

[image]

OfficeClip API Documentation
NoteDetail..::.CreatedBy Property
NoteDetail Class See Also

[This is preliminary documentation and is subject to change.]

Who created the note

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CreatedBy { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreatedBy As String
Visual C++
public:
property String^ CreatedBy {
    String^ get ();
}

See Also

NoteDetail Class
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteID Property

[image]

OfficeClip API Documentation
NoteDetail..::.NoteID Property
NoteDetail Class See Also

[This is preliminary documentation and is subject to change.]

the unique id of the note

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NoteID { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoteID As Integer
Visual C++
public:
property int NoteID {
    int get ();
}

See Also

NoteDetail Class
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteText Property

[image]

OfficeClip API Documentation
NoteDetail..::.NoteText Property
NoteDetail Class See Also

[This is preliminary documentation and is subject to change.]

The text of the note

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string NoteText { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoteText As String
Visual C++
public:
property String^ NoteText {
    String^ get ();
}

See Also

NoteDetail Class
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteDetailsCollection Class

[image]

OfficeClip API Documentation
NoteDetailsCollection Class
Members See Also

[This is preliminary documentation and is subject to change.]

the class to represent the collection of the note detail

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class NoteDetailsCollection : ICollection,
    IEnumerable
Visual Basic (Declaration)
Public Class NoteDetailsCollection _
    Implements ICollection, IEnumerable
Visual C++
public ref class NoteDetailsCollection : ICollection,
    IEnumerable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.User..::.NoteDetailsCollection

See Also

NoteDetailsCollection Members
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteDetailsCollection Members

[image] [image]

OfficeClip API Documentation
NoteDetailsCollection Members
NoteDetailsCollection Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The NoteDetailsCollection type exposes the following members.

Constructors

 | Name | Description
Public method | NoteDetailsCollection | constructor

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | NoteList |
Public property | SyncRoot |

See Also

NoteDetailsCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteDetailsCollection Constructor

[image]

OfficeClip API Documentation
NoteDetailsCollection Constructor
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NoteDetailsCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoteDetailsCollection()

See Also

NoteDetailsCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteDetailsCollection Methods

[image] [image]

OfficeClip API Documentation
NoteDetailsCollection Methods
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

The NoteDetailsCollection type exposes the following methods.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoteDetailsCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method

[image] [image]

OfficeClip API Documentation
NoteDetailsCollection..::.Add Method
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Add(NoteDetail) | Adds an item to the collection
Public method | Add(String, String, String) | Adds an item to the collection

See Also

NoteDetailsCollection Class
NoteDetailsCollection Members
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method (NoteDetail)

[image]

OfficeClip API Documentation
NoteDetailsCollection..::.Add Method (NoteDetail)
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    NoteDetail item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As NoteDetail _
)
Visual C++
public:
void Add(
    NoteDetail^ item
)

Parameters

item
Type: OfficeClip.BusinessLayer.Extranet.User..::.NoteDetail

See Also

NoteDetailsCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


Add Method (String, String, String)

[image]

OfficeClip API Documentation
NoteDetailsCollection..::.Add Method (String, String, String)
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    string createdBy,
    string created,
    string noteText
)
Visual Basic (Declaration)
Public Sub Add ( _
    createdBy As String, _
    created As String, _
    noteText As String _
)
Visual C++
public:
void Add(
    String^ createdBy,
    String^ created,
    String^ noteText
)

Parameters

createdBy
Type: System..::.String
E-mail address of user creating the note.
created
Type: System..::.String
Date string identifying when the note was created.
noteText
Type: System..::.String
The text of the note created.

See Also

NoteDetailsCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.User Namespace


CopyTo Method

[image]

OfficeClip API Documentation
NoteDetailsCollection..::.CopyTo Method
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::.Array
index
Type: System..::.Int32

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

NoteDetailsCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
NoteDetailsCollection..::.GetEnumerator Method
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

Implements

IEnumerable..::.GetEnumerator()()()

See Also

NoteDetailsCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteDetailsCollection Properties

[image] [image]

OfficeClip API Documentation
NoteDetailsCollection Properties
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

The NoteDetailsCollection type exposes the following properties.

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | NoteList |
Public property | SyncRoot |

See Also

NoteDetailsCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Count Property

[image]

OfficeClip API Documentation
NoteDetailsCollection..::.Count Property
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

The count of the items in the collection

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

NoteDetailsCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


IsSynchronized Property

[image]

OfficeClip API Documentation
NoteDetailsCollection..::.IsSynchronized Property
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Implements

ICollection..::.IsSynchronized

See Also

NoteDetailsCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


Item Property

[image]

OfficeClip API Documentation
NoteDetailsCollection..::.Item Property
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NoteDetail this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As NoteDetail
Visual C++
public:
property NoteDetail^ default[int index] {
    NoteDetail^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

NoteDetailsCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


NoteList Property

[image]

OfficeClip API Documentation
NoteDetailsCollection..::.NoteList Property
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList NoteList { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoteList As ArrayList
Visual C++
public:
property ArrayList^ NoteList {
    ArrayList^ get ();
}

See Also

NoteDetailsCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


SyncRoot Property

[image]

OfficeClip API Documentation
NoteDetailsCollection..::.SyncRoot Property
NoteDetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.User
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Implements

ICollection..::.SyncRoot

See Also

NoteDetailsCollection Class
OfficeClip.BusinessLayer.Extranet.User Namespace


OfficeClip.BusinessLayer.Extranet.Utility Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Extranet.Utility Namespace

[This is preliminary documentation and is subject to change.]

Business Layer information for the Customer Portal utility

Classes

 | Class | Description
Public class | AuthenticatedTicket | The authenticated ticket object
Public class | AuthTkt | Serializable class for encrypted argument acting as a business object container for User ID, Emai Address, and Host IP address.
Public class | Default | Class to represent the extranet default
Public class | ExAppSettings | Provides various url mapping needed for the Extranet application
Public class | ExSecurity | Interface for class

Interfaces

 | Interface | Description
Public interface | IAuthTkt | Interface definitions for ExSecurity class

Enumerations

 | Enumeration | Description
Public enumeration | ControlMode | The Control Mode
Public enumeration | ExtranetLoginStatus | Enumeration of possible states seen after a user log in attempt
Public enumeration | IssueTrackerInputMode | The issue tracker input mode
Public enumeration | ItemPermission | The item permission
Public enumeration | Restrictions | Restrictions
Public enumeration | WzPanel | Wizard Panel


AuthenticatedTicket Class

[image]

OfficeClip API Documentation
AuthenticatedTicket Class
Members See Also

[This is preliminary documentation and is subject to change.]

The authenticated ticket object

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class AuthenticatedTicket
Visual Basic (Declaration)
Public Class AuthenticatedTicket
Visual C++
public ref class AuthenticatedTicket

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Utility..::.AuthenticatedTicket

See Also

AuthenticatedTicket Members
OfficeClip.BusinessLayer.Extranet.Utility Namespace


AuthenticatedTicket Members

[image] [image]

OfficeClip API Documentation
AuthenticatedTicket Members
AuthenticatedTicket Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The AuthenticatedTicket type exposes the following members.

Constructors

 | Name | Description
Public method | AuthenticatedTicket |

Methods

 | Name | Description
 | CookieAndUrlArgIsValidated | Determines if the cookie and the url object is validated
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get_eAuthTktFromCookie | Retrieves the authenticated ticket from the cookie
 | GetEncodedCookieAndEncryptedArg | Class responsible for Extranet Authentication
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AuthenticatedTicket Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


AuthenticatedTicket Constructor

[image]

OfficeClip API Documentation
AuthenticatedTicket Constructor
AuthenticatedTicket Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AuthenticatedTicket()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AuthenticatedTicket()

See Also

AuthenticatedTicket Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


AuthenticatedTicket Methods

[image] [image]

OfficeClip API Documentation
AuthenticatedTicket Methods
AuthenticatedTicket Class See Also

[This is preliminary documentation and is subject to change.]

The AuthenticatedTicket type exposes the following methods.

Methods

 | Name | Description
 | CookieAndUrlArgIsValidated | Determines if the cookie and the url object is validated
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get_eAuthTktFromCookie | Retrieves the authenticated ticket from the cookie
 | GetEncodedCookieAndEncryptedArg | Class responsible for Extranet Authentication
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AuthenticatedTicket Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


CookieAndUrlArgIsValidated Method

[image]

OfficeClip API Documentation
AuthenticatedTicket..::.CookieAndUrlArgIsValidated Method
AuthenticatedTicket Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the cookie and the url object is validated

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool CookieAndUrlArgIsValidated(
    int groupId,
    string encodedCookie,
    string encryptedUrlArg,
    string clientIpAddress
)
Visual Basic (Declaration)
Public Shared Function CookieAndUrlArgIsValidated ( _
    groupId As Integer, _
    encodedCookie As String, _
    encryptedUrlArg As String, _
    clientIpAddress As String _
) As Boolean
Visual C++
public:
static bool CookieAndUrlArgIsValidated(
    int groupId,
    String^ encodedCookie,
    String^ encryptedUrlArg,
    String^ clientIpAddress
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
encodedCookie
Type: System..::.String
the encoded cookie
encryptedUrlArg
Type: System..::.String
The encrypted url argument
clientIpAddress
Type: System..::.String
The ip address of the client

Return Value

true if the cookie and the argument is validated

See Also

AuthenticatedTicket Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


Get_eAuthTktFromCookie Method

[image]

OfficeClip API Documentation
AuthenticatedTicket..::.Get_eAuthTktFromCookie Method
AuthenticatedTicket Class See Also

[This is preliminary documentation and is subject to change.]

Retrieves the authenticated ticket from the cookie

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static AuthTkt Get_eAuthTktFromCookie(
    string encodedCookieTxt,
    int groupId
)
Visual Basic (Declaration)
Public Shared Function Get_eAuthTktFromCookie ( _
    encodedCookieTxt As String, _
    groupId As Integer _
) As AuthTkt
Visual C++
public:
static AuthTkt^ Get_eAuthTktFromCookie(
    String^ encodedCookieTxt,
    int groupId
)

Parameters

encodedCookieTxt
Type: System..::.String
The text for the encoded cookie
groupId
Type: System..::.Int32
The unique id of the group

Return Value

The authenticated ticket object

See Also

AuthenticatedTicket Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


GetEncodedCookieAndEncryptedArg Method

[image]

OfficeClip API Documentation
AuthenticatedTicket..::.GetEncodedCookieAndEncryptedArg Method
AuthenticatedTicket Class See Also

[This is preliminary documentation and is subject to change.]

Class responsible for Extranet Authentication

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static void GetEncodedCookieAndEncryptedArg(
    int groupId,
    AuthTkt tkt,
    TimeSpan tsExpires,
    out HttpCookie cookie,
    out string encryptedArg
)
Visual Basic (Declaration)
Public Shared Sub GetEncodedCookieAndEncryptedArg ( _
    groupId As Integer, _
    tkt As AuthTkt, _
    tsExpires As TimeSpan, _
    <OutAttribute> ByRef cookie As HttpCookie, _
    <OutAttribute> ByRef encryptedArg As String _
)
Visual C++
public:
static void GetEncodedCookieAndEncryptedArg(
    int groupId,
    AuthTkt^ tkt,
    TimeSpan tsExpires,
    [OutAttribute] HttpCookie^% cookie,
    [OutAttribute] String^% encryptedArg
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
tkt
Type: OfficeClip.BusinessLayer.Extranet.Utility..::.AuthTkt
The authenticated ticket object
tsExpires
Type: System..::.TimeSpan
time period for the cookie expiration
cookie
Type: System.Web..::.HttpCookie%
The cookie to keep track of the session
encryptedArg
Type: System..::.String%
The encrypted argument

See Also

AuthenticatedTicket Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


AuthTkt Class

[image]

OfficeClip API Documentation
AuthTkt Class
Members See Also

[This is preliminary documentation and is subject to change.]

Serializable class for encrypted argument acting as a business object container for User ID, Emai Address, and Host IP address.

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class AuthTkt
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class AuthTkt
Visual C++
[SerializableAttribute]
public ref class AuthTkt

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Utility..::.AuthTkt

See Also

AuthTkt Members
OfficeClip.BusinessLayer.Extranet.Utility Namespace


AuthTkt Members

[image] [image]

OfficeClip API Documentation
AuthTkt Members
AuthTkt Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The AuthTkt type exposes the following members.

Constructors

 | Name | Description
Public method | AuthTkt | default constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _email | The email
Protected field | _ipAddress | The ip address
Protected field | _userId | The user id

Properties

 | Name | Description
Public property | Email | The email of the user
Public property | IpAddress | the ip address of the user
Public property | UserID | The unique id of the user

See Also

AuthTkt Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


AuthTkt Constructor

[image]

OfficeClip API Documentation
AuthTkt Constructor
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

default constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AuthTkt()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AuthTkt()

See Also

AuthTkt Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


AuthTkt Fields

[image] [image]

OfficeClip API Documentation
AuthTkt Fields
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The AuthTkt type exposes the following fields.

Fields

 | Name | Description
Protected field | _email | The email
Protected field | _ipAddress | The ip address
Protected field | _userId | The user id

See Also

AuthTkt Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


_email Field

[image]

OfficeClip API Documentation
AuthTkt..::._email Field
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The email

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _email
Visual Basic (Declaration)
Protected _email As String
Visual C++
protected:
String^ _email

See Also

AuthTkt Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


_ipAddress Field

[image]

OfficeClip API Documentation
AuthTkt..::._ipAddress Field
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The ip address

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _ipAddress
Visual Basic (Declaration)
Protected _ipAddress As String
Visual C++
protected:
String^ _ipAddress

See Also

AuthTkt Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


_userId Field

[image]

OfficeClip API Documentation
AuthTkt..::._userId Field
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The user id

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _userId
Visual Basic (Declaration)
Protected _userId As Integer
Visual C++
protected:
int _userId

See Also

AuthTkt Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


AuthTkt Properties

[image] [image]

OfficeClip API Documentation
AuthTkt Properties
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The AuthTkt type exposes the following properties.

Properties

 | Name | Description
Public property | Email | The email of the user
Public property | IpAddress | the ip address of the user
Public property | UserID | The unique id of the user

See Also

AuthTkt Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


Email Property

[image]

OfficeClip API Documentation
AuthTkt..::.Email Property
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The email of the user

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Email { get; set; }
Visual Basic (Declaration)
Public Property Email As String
Visual C++
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

See Also

AuthTkt Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


IpAddress Property

[image]

OfficeClip API Documentation
AuthTkt..::.IpAddress Property
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

the ip address of the user

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IpAddress { get; set; }
Visual Basic (Declaration)
Public Property IpAddress As String
Visual C++
public:
property String^ IpAddress {
    String^ get ();
    void set (String^ value);
}

See Also

AuthTkt Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


UserID Property

[image]

OfficeClip API Documentation
AuthTkt..::.UserID Property
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserID { get; set; }
Visual Basic (Declaration)
Public Property UserID As Integer
Visual C++
public:
property int UserID {
    int get ();
    void set (int value);
}

See Also

AuthTkt Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ControlMode Enumeration

[image]

OfficeClip API Documentation
ControlMode Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The Control Mode

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ControlMode
Visual Basic (Declaration)
Public Enumeration ControlMode
Visual C++
public enum class ControlMode

Members

Member name | Description
None | None
Add | Add
Edit | Edit

See Also

OfficeClip.BusinessLayer.Extranet.Utility Namespace


Default Class

[image]

OfficeClip API Documentation
Default Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the extranet default

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class Default
Visual Basic (Declaration)
Public Class Default
Visual C++
public ref class Default

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Utility..::.Default

See Also

Default Members
OfficeClip.BusinessLayer.Extranet.Utility Namespace


Default Members

[image] [image]

OfficeClip API Documentation
Default Members
Default Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The Default type exposes the following members.

Constructors

 | Name | Description
Public method | Default |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BrowserTitle | The browser title
CopyrightText | The copyright text
CopyrightUrl | The copyright url
PageTitle | The page title
SessionTimeout | The session timeout
XslUrl | The url of the xsl

Properties

Name | Description
Footer | footer of the extranet home page
Header | Header of the extranet home page

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


Default Constructor

[image]

OfficeClip API Documentation
Default Constructor
Default Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Default()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Default()

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


Default Fields

[image] [image]

OfficeClip API Documentation
Default Fields
Default Class See Also

[This is preliminary documentation and is subject to change.]

The Default type exposes the following fields.

Fields

Name | Description
BrowserTitle | The browser title
CopyrightText | The copyright text
CopyrightUrl | The copyright url
PageTitle | The page title
SessionTimeout | The session timeout
XslUrl | The url of the xsl

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


BrowserTitle Field

[image]

OfficeClip API Documentation
Default..::.BrowserTitle Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The browser title

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string BrowserTitle
Visual Basic (Declaration)
Public Shared BrowserTitle As String
Visual C++
public:
static String^ BrowserTitle

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


CopyrightText Field

[image]

OfficeClip API Documentation
Default..::.CopyrightText Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The copyright text

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string CopyrightText
Visual Basic (Declaration)
Public Shared CopyrightText As String
Visual C++
public:
static String^ CopyrightText

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


CopyrightUrl Field

[image]

OfficeClip API Documentation
Default..::.CopyrightUrl Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The copyright url

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string CopyrightUrl
Visual Basic (Declaration)
Public Shared CopyrightUrl As String
Visual C++
public:
static String^ CopyrightUrl

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


PageTitle Field

[image]

OfficeClip API Documentation
Default..::.PageTitle Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The page title

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string PageTitle
Visual Basic (Declaration)
Public Shared PageTitle As String
Visual C++
public:
static String^ PageTitle

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


SessionTimeout Field

[image]

OfficeClip API Documentation
Default..::.SessionTimeout Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The session timeout

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static int SessionTimeout
Visual Basic (Declaration)
Public Shared SessionTimeout As Integer
Visual C++
public:
static int SessionTimeout

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


XslUrl Field

[image]

OfficeClip API Documentation
Default..::.XslUrl Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The url of the xsl

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string XslUrl
Visual Basic (Declaration)
Public Shared XslUrl As String
Visual C++
public:
static String^ XslUrl

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


Default Properties

[image] [image]

OfficeClip API Documentation
Default Properties
Default Class See Also

[This is preliminary documentation and is subject to change.]

The Default type exposes the following properties.

Properties

Name | Description
Footer | footer of the extranet home page
Header | Header of the extranet home page

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


Footer Property

[image]

OfficeClip API Documentation
Default..::.Footer Property
Default Class See Also

[This is preliminary documentation and is subject to change.]

footer of the extranet home page

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string Footer { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Footer As String
Visual C++
public:
static property String^ Footer {
    String^ get ();
}

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


Header Property

[image]

OfficeClip API Documentation
Default..::.Header Property
Default Class See Also

[This is preliminary documentation and is subject to change.]

Header of the extranet home page

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string Header { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Header As String
Visual C++
public:
static property String^ Header {
    String^ get ();
}

See Also

Default Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExAppSettings Class

[image]

OfficeClip API Documentation
ExAppSettings Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides various url mapping needed for the Extranet application

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ExAppSettings
Visual Basic (Declaration)
Public Class ExAppSettings
Visual C++
public ref class ExAppSettings

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Utility..::.ExAppSettings

See Also

ExAppSettings Members
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExAppSettings Members

[image] [image]

OfficeClip API Documentation
ExAppSettings Members
ExAppSettings Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The ExAppSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ExAppSettings | default constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetExtranetGroupId | Gets the extranet home page path
 | GetExtranetHomePageUrl | Gets the extranet home page path
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSerialNumberTail4 | Gets the last 4 digits of the serial number
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MapExtranetFeatureItemUrl | Overloaded.
 | MapExtranetUsersPath | Maps given file to the Extranet Users virtual directory
 | MapOcPath | Returns the officeclip path
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExAppSettings Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExAppSettings Constructor

[image]

OfficeClip API Documentation
ExAppSettings Constructor
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

default constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExAppSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExAppSettings()

See Also

ExAppSettings Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExAppSettings Methods

[image] [image]

OfficeClip API Documentation
ExAppSettings Methods
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The ExAppSettings type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetExtranetGroupId | Gets the extranet home page path
 | GetExtranetHomePageUrl | Gets the extranet home page path
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSerialNumberTail4 | Gets the last 4 digits of the serial number
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MapExtranetFeatureItemUrl | Overloaded.
 | MapExtranetUsersPath | Maps given file to the Extranet Users virtual directory
 | MapOcPath | Returns the officeclip path
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExAppSettings Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


GetExtranetGroupId Method

[image]

OfficeClip API Documentation
ExAppSettings..::.GetExtranetGroupId Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the extranet home page path

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static int GetExtranetGroupId(
    string eStr
)
Visual Basic (Declaration)
Public Shared Function GetExtranetGroupId ( _
    eStr As String _
) As Integer
Visual C++
public:
static int GetExtranetGroupId(
    String^ eStr
)

Parameters

eStr
Type: System..::.String
encoded string

Return Value

The group Id

See Also

ExAppSettings Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


GetExtranetHomePageUrl Method

[image]

OfficeClip API Documentation
ExAppSettings..::.GetExtranetHomePageUrl Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the extranet home page path

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetExtranetHomePageUrl(
    int groupId
)
Visual Basic (Declaration)
Public Shared Function GetExtranetHomePageUrl ( _
    groupId As Integer _
) As String
Visual C++
public:
static String^ GetExtranetHomePageUrl(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

Return Value

The physical path to the extranet home page

See Also

ExAppSettings Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


GetSerialNumberTail4 Method

[image]

OfficeClip API Documentation
ExAppSettings..::.GetSerialNumberTail4 Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the last 4 digits of the serial number

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetSerialNumberTail4()
Visual Basic (Declaration)
Public Shared Function GetSerialNumberTail4 As String
Visual C++
public:
static String^ GetSerialNumberTail4()

Return Value

See Also

ExAppSettings Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


MapExtranetFeatureItemUrl Method

[image] [image]

OfficeClip API Documentation
ExAppSettings..::.MapExtranetFeatureItemUrl Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MapExtranetFeatureItemUrl(Int32, Int32) | gets the path to the extranet feature item url
MapExtranetFeatureItemUrl(Int32, Int32, String) | gets the path to the extranet feature item url

See Also

ExAppSettings Class
ExAppSettings Members
OfficeClip.BusinessLayer.Extranet.Utility Namespace


MapExtranetFeatureItemUrl Method (Int32, Int32)

[image]

OfficeClip API Documentation
ExAppSettings..::.MapExtranetFeatureItemUrl Method (Int32, Int32)
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

gets the path to the extranet feature item url

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string MapExtranetFeatureItemUrl(
    int itemId,
    int groupId
)
Visual Basic (Declaration)
Public Shared Function MapExtranetFeatureItemUrl ( _
    itemId As Integer, _
    groupId As Integer _
) As String
Visual C++
public:
static String^ MapExtranetFeatureItemUrl(
    int itemId,
    int groupId
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
groupId
Type: System..::.Int32
The unique id of the group

Return Value

The extranet feature item url

See Also

ExAppSettings Class
MapExtranetFeatureItemUrl Overload
OfficeClip.BusinessLayer.Extranet.Utility Namespace


MapExtranetFeatureItemUrl Method (Int32, Int32, String)

[image]

OfficeClip API Documentation
ExAppSettings..::.MapExtranetFeatureItemUrl Method (Int32, Int32, String)
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

gets the path to the extranet feature item url

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string MapExtranetFeatureItemUrl(
    int itemId,
    int groupId,
    string argument
)
Visual Basic (Declaration)
Public Shared Function MapExtranetFeatureItemUrl ( _
    itemId As Integer, _
    groupId As Integer, _
    argument As String _
) As String
Visual C++
public:
static String^ MapExtranetFeatureItemUrl(
    int itemId,
    int groupId,
    String^ argument
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
groupId
Type: System..::.Int32
the unique id of the group
argument
Type: System..::.String
The list of arguments

Return Value

The extranet feature item url

See Also

ExAppSettings Class
MapExtranetFeatureItemUrl Overload
OfficeClip.BusinessLayer.Extranet.Utility Namespace


MapExtranetUsersPath Method

[image]

OfficeClip API Documentation
ExAppSettings..::.MapExtranetUsersPath Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Maps given file to the Extranet Users virtual directory

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string MapExtranetUsersPath(
    string filename
)
Visual Basic (Declaration)
Public Shared Function MapExtranetUsersPath ( _
    filename As String _
) As String
Visual C++
public:
static String^ MapExtranetUsersPath(
    String^ filename
)

Parameters

filename
Type: System..::.String
The name of the file

Return Value

The extranet user path

See Also

ExAppSettings Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


MapOcPath Method

[image]

OfficeClip API Documentation
ExAppSettings..::.MapOcPath Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Returns the officeclip path

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string MapOcPath(
    string filename
)
Visual Basic (Declaration)
Public Shared Function MapOcPath ( _
    filename As String _
) As String
Visual C++
public:
static String^ MapOcPath(
    String^ filename
)

Parameters

filename
Type: System..::.String
The name of the file

Return Value

See Also

ExAppSettings Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExSecurity Class

[image]

OfficeClip API Documentation
ExSecurity Class
Members See Also

[This is preliminary documentation and is subject to change.]

Interface for class

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ExSecurity : IAuthTkt
Visual Basic (Declaration)
Public Class ExSecurity _
    Implements IAuthTkt
Visual C++
public ref class ExSecurity : IAuthTkt

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Utility..::.ExSecurity

See Also

ExSecurity Members
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExSecurity Members

[image] [image]

OfficeClip API Documentation
ExSecurity Members
ExSecurity Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The ExSecurity type exposes the following members.

Constructors

 | Name | Description
Public method | ExSecurity | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _argument | The argument
Protected field | _decryptedCnt | The decrypted count
Protected field | _encodedAuthTkt | Encoded authentication ticket
Protected field | _encryptedId | The encrypted id
Protected field | _error | System error
Protected field | _groupId | The group id
Protected field | _itemId | The item id
Protected field | _tkt | The authentication ticket

Properties

 | Name | Description
Public property | Argument | The list of the arguments
Public property | EncryptedId | The encrypted id
Public property | ErrorMsg | The error message
Public property | GroupId | The unique id of the group
Public property | IAuthTkt | Returns IAuthTkt interface for ExSecurity instance.
Public property | ItemId | The unique id of the item

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExSecurity Constructor

[image] [image]

OfficeClip API Documentation
ExSecurity Constructor
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExSecurity(String) | constructor
Public method | ExSecurity(Int32, Int32) | constructor
Public method | ExSecurity(Int32, Int32, String) | constructor

See Also

ExSecurity Class
ExSecurity Members
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExSecurity Constructor (String)

[image]

OfficeClip API Documentation
ExSecurity Constructor (String)
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExSecurity(
    string encryptedId
)
Visual Basic (Declaration)
Public Sub New ( _
    encryptedId As String _
)
Visual C++
public:
ExSecurity(
    String^ encryptedId
)

Parameters

encryptedId
Type: System..::.String
The encrypted id

See Also

ExSecurity Class
ExSecurity Overload
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExSecurity Constructor (Int32, Int32)

[image]

OfficeClip API Documentation
ExSecurity Constructor (Int32, Int32)
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExSecurity(
    int groupId,
    int itemId
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    itemId As Integer _
)
Visual C++
public:
ExSecurity(
    int groupId,
    int itemId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
itemId
Type: System..::.Int32
The unique id of the item

See Also

ExSecurity Class
ExSecurity Overload
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExSecurity Constructor (Int32, Int32, String)

[image]

OfficeClip API Documentation
ExSecurity Constructor (Int32, Int32, String)
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExSecurity(
    int groupId,
    int itemId,
    string argument
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    itemId As Integer, _
    argument As String _
)
Visual C++
public:
ExSecurity(
    int groupId,
    int itemId,
    String^ argument
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
itemId
Type: System..::.Int32
The unique id of the item
argument
Type: System..::.String
The list of arguments

See Also

ExSecurity Class
ExSecurity Overload
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExSecurity Fields

[image] [image]

OfficeClip API Documentation
ExSecurity Fields
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The ExSecurity type exposes the following fields.

Fields

 | Name | Description
Protected field | _argument | The argument
Protected field | _decryptedCnt | The decrypted count
Protected field | _encodedAuthTkt | Encoded authentication ticket
Protected field | _encryptedId | The encrypted id
Protected field | _error | System error
Protected field | _groupId | The group id
Protected field | _itemId | The item id
Protected field | _tkt | The authentication ticket

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


_argument Field

[image]

OfficeClip API Documentation
ExSecurity..::._argument Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The argument

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _argument
Visual Basic (Declaration)
Protected _argument As String
Visual C++
protected:
String^ _argument

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


_decryptedCnt Field

[image]

OfficeClip API Documentation
ExSecurity..::._decryptedCnt Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The decrypted count

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _decryptedCnt
Visual Basic (Declaration)
Protected _decryptedCnt As Integer
Visual C++
protected:
int _decryptedCnt

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


_encodedAuthTkt Field

[image]

OfficeClip API Documentation
ExSecurity..::._encodedAuthTkt Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Encoded authentication ticket

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _encodedAuthTkt
Visual Basic (Declaration)
Protected _encodedAuthTkt As String
Visual C++
protected:
String^ _encodedAuthTkt

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


_encryptedId Field

[image]

OfficeClip API Documentation
ExSecurity..::._encryptedId Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The encrypted id

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _encryptedId
Visual Basic (Declaration)
Protected _encryptedId As String
Visual C++
protected:
String^ _encryptedId

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


_error Field

[image]

OfficeClip API Documentation
ExSecurity..::._error Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

System error

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _error
Visual Basic (Declaration)
Protected _error As String
Visual C++
protected:
String^ _error

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


_groupId Field

[image]

OfficeClip API Documentation
ExSecurity..::._groupId Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The group id

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _groupId
Visual Basic (Declaration)
Protected _groupId As Integer
Visual C++
protected:
int _groupId

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


_itemId Field

[image]

OfficeClip API Documentation
ExSecurity..::._itemId Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The item id

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int _itemId
Visual Basic (Declaration)
Protected _itemId As Integer
Visual C++
protected:
int _itemId

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


_tkt Field

[image]

OfficeClip API Documentation
ExSecurity..::._tkt Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The authentication ticket

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected AuthTkt _tkt
Visual Basic (Declaration)
Protected _tkt As AuthTkt
Visual C++
protected:
AuthTkt^ _tkt

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExSecurity Properties

[image] [image]

OfficeClip API Documentation
ExSecurity Properties
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The ExSecurity type exposes the following properties.

Properties

 | Name | Description
Public property | Argument | The list of the arguments
Public property | EncryptedId | The encrypted id
Public property | ErrorMsg | The error message
Public property | GroupId | The unique id of the group
Public property | IAuthTkt | Returns IAuthTkt interface for ExSecurity instance.
Public property | ItemId | The unique id of the item

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


Argument Property

[image]

OfficeClip API Documentation
ExSecurity..::.Argument Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The list of the arguments

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Argument { get; }
Visual Basic (Declaration)
Public ReadOnly Property Argument As String
Visual C++
public:
property String^ Argument {
    String^ get ();
}

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


EncryptedId Property

[image]

OfficeClip API Documentation
ExSecurity..::.EncryptedId Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The encrypted id

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EncryptedId { get; }
Visual Basic (Declaration)
Public ReadOnly Property EncryptedId As String
Visual C++
public:
property String^ EncryptedId {
    String^ get ();
}

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ErrorMsg Property

[image]

OfficeClip API Documentation
ExSecurity..::.ErrorMsg Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The error message

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ErrorMsg { get; }
Visual Basic (Declaration)
Public ReadOnly Property ErrorMsg As String
Visual C++
public:
property String^ ErrorMsg {
    String^ get ();
}

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


GroupId Property

[image]

OfficeClip API Documentation
ExSecurity..::.GroupId Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the group

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
}

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


IAuthTkt Property

[image]

OfficeClip API Documentation
ExSecurity..::.IAuthTkt Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Returns IAuthTkt interface for ExSecurity instance.

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IAuthTkt IAuthTkt { get; }
Visual Basic (Declaration)
Public ReadOnly Property IAuthTkt As IAuthTkt
Visual C++
public:
property IAuthTkt^ IAuthTkt {
    IAuthTkt^ get ();
}

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ItemId Property

[image]

OfficeClip API Documentation
ExSecurity..::.ItemId Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the item

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ItemId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemId As Integer
Visual C++
public:
property int ItemId {
    int get ();
}

See Also

ExSecurity Class
OfficeClip.BusinessLayer.Extranet.Utility Namespace


ExtranetLoginStatus Enumeration

[image]

OfficeClip API Documentation
ExtranetLoginStatus Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumeration of possible states seen after a user log in attempt

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ExtranetLoginStatus
Visual Basic (Declaration)
Public Enumeration ExtranetLoginStatus
Visual C++
public enum class ExtranetLoginStatus

Members

Member name | Description
Success |
InvalidLoginPassword |
SiteLicenseExpired |
AccountLicenseExpired |
DatabaseOfficeClipVersionMismatch |
OfficeClipUndergoneMajorUpgrade |
CurrentUpgradeIncompatibleWithOfficeClipLicense |

See Also

OfficeClip.BusinessLayer.Extranet.Utility Namespace


IAuthTkt Interface

[image]

OfficeClip API Documentation
IAuthTkt Interface
Members See Also

[This is preliminary documentation and is subject to change.]

Interface definitions for ExSecurity class

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public interface IAuthTkt
Visual Basic (Declaration)
Public Interface IAuthTkt
Visual C++
public interface class IAuthTkt

See Also

IAuthTkt Members
OfficeClip.BusinessLayer.Extranet.Utility Namespace


IAuthTkt Members

[image] [image]

OfficeClip API Documentation
IAuthTkt Members
IAuthTkt Interface Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The IAuthTkt type exposes the following members.

Methods

 | Name | Description
Public method | CookieAndUrlArgIsValidated | Interface function to test if the url and the cookie argument is validated
Public method | Get_eAuthTktFromCookie | Interface function to get the authenticated cookie from the ticket
Public method | GetEncodedAuthTktCookie | Interface to get encoded authentication ticket cookie
Public method | GetEncryptedUrlArg | Interface method to get the encrypted url argument

Properties

 | Name | Description
Public property | eAuthTkt | Interface property for the authentication ticket

See Also

IAuthTkt Interface
OfficeClip.BusinessLayer.Extranet.Utility Namespace


IAuthTkt Methods

[image] [image]

OfficeClip API Documentation
IAuthTkt Methods
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

The IAuthTkt type exposes the following methods.

Methods

 | Name | Description
Public method | CookieAndUrlArgIsValidated | Interface function to test if the url and the cookie argument is validated
Public method | Get_eAuthTktFromCookie | Interface function to get the authenticated cookie from the ticket
Public method | GetEncodedAuthTktCookie | Interface to get encoded authentication ticket cookie
Public method | GetEncryptedUrlArg | Interface method to get the encrypted url argument

See Also

IAuthTkt Interface
OfficeClip.BusinessLayer.Extranet.Utility Namespace


CookieAndUrlArgIsValidated Method

[image]

OfficeClip API Documentation
IAuthTkt..::.CookieAndUrlArgIsValidated Method
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

Interface function to test if the url and the cookie argument is validated

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
bool CookieAndUrlArgIsValidated(
    string encodedCookie,
    string encryptedUrlArg,
    string clientIpAddress
)
Visual Basic (Declaration)
Function CookieAndUrlArgIsValidated ( _
    encodedCookie As String, _
    encryptedUrlArg As String, _
    clientIpAddress As String _
) As Boolean
Visual C++
bool CookieAndUrlArgIsValidated(
    String^ encodedCookie,
    String^ encryptedUrlArg,
    String^ clientIpAddress
)

Parameters

encodedCookie
Type: System..::.String
The encoded cookie
encryptedUrlArg
Type: System..::.String
The encrypted url argument
clientIpAddress
Type: System..::.String
The client ip address

Return Value

true if the cookie and the url argument is validated

See Also

IAuthTkt Interface
OfficeClip.BusinessLayer.Extranet.Utility Namespace


Get_eAuthTktFromCookie Method

[image]

OfficeClip API Documentation
IAuthTkt..::.Get_eAuthTktFromCookie Method
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

Interface function to get the authenticated cookie from the ticket

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
AuthTkt Get_eAuthTktFromCookie(
    string encodedCookie
)
Visual Basic (Declaration)
Function Get_eAuthTktFromCookie ( _
    encodedCookie As String _
) As AuthTkt
Visual C++
AuthTkt^ Get_eAuthTktFromCookie(
    String^ encodedCookie
)

Parameters

encodedCookie
Type: System..::.String
The encoded cookie

Return Value

The authenticated ticket

See Also

IAuthTkt Interface
OfficeClip.BusinessLayer.Extranet.Utility Namespace


GetEncodedAuthTktCookie Method

[image]

OfficeClip API Documentation
IAuthTkt..::.GetEncodedAuthTktCookie Method
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

Interface to get encoded authentication ticket cookie

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
HttpCookie GetEncodedAuthTktCookie(
    ref AuthTkt tkt,
    TimeSpan tsExpires
)
Visual Basic (Declaration)
Function GetEncodedAuthTktCookie ( _
    ByRef tkt As AuthTkt, _
    tsExpires As TimeSpan _
) As HttpCookie
Visual C++
HttpCookie^ GetEncodedAuthTktCookie(
    AuthTkt^% tkt,
    TimeSpan tsExpires
)

Parameters

tkt
Type: OfficeClip.BusinessLayer.Extranet.Utility..::.AuthTkt %
The authentication ticket
tsExpires
Type: System..::.TimeSpan
The timespan for the expiration of the cookie

Return Value

The http cookie

See Also

IAuthTkt Interface
OfficeClip.BusinessLayer.Extranet.Utility Namespace


GetEncryptedUrlArg Method

[image]

OfficeClip API Documentation
IAuthTkt..::.GetEncryptedUrlArg Method
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

Interface method to get the encrypted url argument

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
string GetEncryptedUrlArg(
    ref AuthTkt tkt
)
Visual Basic (Declaration)
Function GetEncryptedUrlArg ( _
    ByRef tkt As AuthTkt _
) As String
Visual C++
String^ GetEncryptedUrlArg(
    AuthTkt^% tkt
)

Parameters

tkt
Type: OfficeClip.BusinessLayer.Extranet.Utility..::.AuthTkt %
The authentication ticket

Return Value

The encrypted url argument

See Also

IAuthTkt Interface
OfficeClip.BusinessLayer.Extranet.Utility Namespace


IAuthTkt Properties

[image] [image]

OfficeClip API Documentation
IAuthTkt Properties
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

The IAuthTkt type exposes the following properties.

Properties

 | Name | Description
Public property | eAuthTkt | Interface property for the authentication ticket

See Also

IAuthTkt Interface
OfficeClip.BusinessLayer.Extranet.Utility Namespace


eAuthTkt Property

[image]

OfficeClip API Documentation
IAuthTkt..::.eAuthTkt Property
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

Interface property for the authentication ticket

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
AuthTkt eAuthTkt { get; }
Visual Basic (Declaration)
ReadOnly Property eAuthTkt As AuthTkt
Visual C++
property AuthTkt^ eAuthTkt {
    AuthTkt^ get ();
}

See Also

IAuthTkt Interface
OfficeClip.BusinessLayer.Extranet.Utility Namespace


IssueTrackerInputMode Enumeration

[image]

OfficeClip API Documentation
IssueTrackerInputMode Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The issue tracker input mode

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum IssueTrackerInputMode
Visual Basic (Declaration)
Public Enumeration IssueTrackerInputMode
Visual C++
public enum class IssueTrackerInputMode

Members

Member name | Description
ListCases | list cases
EnterCase | Enter cases
CaseDetails | Case details
ShowPublicMessage | Show public message

See Also

OfficeClip.BusinessLayer.Extranet.Utility Namespace


ItemPermission Enumeration

[image]

OfficeClip API Documentation
ItemPermission Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The item permission

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ItemPermission
Visual Basic (Declaration)
Public Enumeration ItemPermission
Visual C++
public enum class ItemPermission

Members

Member name | Description
Public | Public
AllExtranetUsers | All Extranet Users
SelectedExtranetUsers | Selected Extranet Users

See Also

OfficeClip.BusinessLayer.Extranet.Utility Namespace


Restrictions Enumeration

[image]

OfficeClip API Documentation
Restrictions Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Restrictions

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum Restrictions
Visual Basic (Declaration)
Public Enumeration Restrictions
Visual C++
public enum class Restrictions

Members

Member name | Description
None | None
PublicOnly | Public only
SecureOnly | Secure only

See Also

OfficeClip.BusinessLayer.Extranet.Utility Namespace


WzPanel Enumeration

[image]

OfficeClip API Documentation
WzPanel Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Wizard Panel

Namespace: OfficeClip.BusinessLayer.Extranet.Utility
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum WzPanel
Visual Basic (Declaration)
Public Enumeration WzPanel
Visual C++
public enum class WzPanel

Members

Member name | Description
One | First Panel
Two | Second Panel
Three | Third Panel
Four | Fourth Panel

See Also

OfficeClip.BusinessLayer.Extranet.Utility Namespace


OfficeClip.BusinessLayer.Extranet.Xml Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Extranet.Xml Namespace

[This is preliminary documentation and is subject to change.]

Business Layer information for the Customer Portal

Classes

 | Class | Description
Public class | DetailItem | Container class consisting of a collection of DetailItemData with identifiers for did and name. The did/name combination must be unique amoung its siblings.
Public class | DetailItemCollection | The class to represent the collection of the detail item
Public class | DetailItemData | Class used to store and render the xml of name/value properties of an Extranet Feature Item.
Public class | DetailItemDataCollection | Class used to store collection of DetailItemData that contains name/value properties of an Extranet Feature Item.
Public class | Details | Class used to hold collection of DetailItems that contains abstract identifiers/properties of type and value
Public class | DetailsCollection | Collection class used by FeatureItem to contain Details
Public class | FeatureItem | Class for creating Feature Item Detail XML or associated business objects from supplied feature Item XML.


DetailItem Class

[image]

OfficeClip API Documentation
DetailItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

Container class consisting of a collection of DetailItemData with identifiers for did and name. The did/name combination must be unique amoung its siblings.

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class DetailItem
Visual Basic (Declaration)
Public Class DetailItem
Visual C++
public ref class DetailItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Xml..::.DetailItem

See Also

DetailItem Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItem Members

[image] [image]

OfficeClip API Documentation
DetailItem Members
DetailItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The DetailItem type exposes the following members.

Constructors

 | Name | Description
Public method | DetailItem | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

Properties

 | Name | Description
Public property | Did | The detail item id
Public property | Items |
Public property | Name | The detail item name

See Also

DetailItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItem Constructor

[image] [image]

OfficeClip API Documentation
DetailItem Constructor
DetailItem Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | DetailItem(DataRow, DataRowCollection) | constructor
Public method | DetailItem(Int32, String) | constructor

See Also

DetailItem Class
DetailItem Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItem Constructor (DataRow, DataRowCollection)

[image]

OfficeClip API Documentation
DetailItem Constructor (DataRow, DataRowCollection)
DetailItem Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItem(
    DataRow drDetailItem,
    DataRowCollection childRows
)
Visual Basic (Declaration)
Public Sub New ( _
    drDetailItem As DataRow, _
    childRows As DataRowCollection _
)
Visual C++
public:
DetailItem(
    DataRow^ drDetailItem,
    DataRowCollection^ childRows
)

Parameters

drDetailItem
Type: System.Data..::.DataRow
DataRow containing the did and name
childRows
Type: System.Data..::.DataRowCollection
DataRow child collection containing DetailItemData

See Also

DetailItem Class
DetailItem Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItem Constructor (Int32, String)

[image]

OfficeClip API Documentation
DetailItem Constructor (Int32, String)
DetailItem Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItem(
    int did,
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    did As Integer, _
    name As String _
)
Visual C++
public:
DetailItem(
    int did,
    String^ name
)

Parameters

did
Type: System..::.Int32
The detail item id
name
Type: System..::.String
The detail item name

See Also

DetailItem Class
DetailItem Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItem Methods

[image] [image]

OfficeClip API Documentation
DetailItem Methods
DetailItem Class See Also

[This is preliminary documentation and is subject to change.]

The DetailItem type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

See Also

DetailItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


ToXml Method

[image]

OfficeClip API Documentation
DetailItem..::.ToXml Method
DetailItem Class See Also

[This is preliminary documentation and is subject to change.]

Serialize the object to the xml format

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToXml()
Visual Basic (Declaration)
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

See Also

DetailItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItem Properties

[image] [image]

OfficeClip API Documentation
DetailItem Properties
DetailItem Class See Also

[This is preliminary documentation and is subject to change.]

The DetailItem type exposes the following properties.

Properties

 | Name | Description
Public property | Did | The detail item id
Public property | Items |
Public property | Name | The detail item name

See Also

DetailItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Did Property

[image]

OfficeClip API Documentation
DetailItem..::.Did Property
DetailItem Class See Also

[This is preliminary documentation and is subject to change.]

The detail item id

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Did { get; set; }
Visual Basic (Declaration)
Public Property Did As Integer
Visual C++
public:
property int Did {
    int get ();
    void set (int value);
}

See Also

DetailItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Items Property

[image]

OfficeClip API Documentation
DetailItem..::.Items Property
DetailItem Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItemDataCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As DetailItemDataCollection
Visual C++
public:
property DetailItemDataCollection^ Items {
    DetailItemDataCollection^ get ();
}

See Also

DetailItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Name Property

[image]

OfficeClip API Documentation
DetailItem..::.Name Property
DetailItem Class See Also

[This is preliminary documentation and is subject to change.]

The detail item name

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

DetailItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemCollection Class

[image]

OfficeClip API Documentation
DetailItemCollection Class
Members See Also

[This is preliminary documentation and is subject to change.]

The class to represent the collection of the detail item

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class DetailItemCollection : ICollection,
    IEnumerable
Visual Basic (Declaration)
Public Class DetailItemCollection _
    Implements ICollection, IEnumerable
Visual C++
public ref class DetailItemCollection : ICollection,
    IEnumerable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Xml..::.DetailItemCollection

See Also

DetailItemCollection Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemCollection Members

[image] [image]

OfficeClip API Documentation
DetailItemCollection Members
DetailItemCollection Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The DetailItemCollection type exposes the following members.

Constructors

 | Name | Description
Public method | DetailItemCollection | constructor

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Overloaded.
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |

See Also

DetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemCollection Constructor

[image]

OfficeClip API Documentation
DetailItemCollection Constructor
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItemCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailItemCollection()

See Also

DetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemCollection Methods

[image] [image]

OfficeClip API Documentation
DetailItemCollection Methods
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

The DetailItemCollection type exposes the following methods.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Overloaded.
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

See Also

DetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Add Method

[image] [image]

OfficeClip API Documentation
DetailItemCollection..::.Add Method
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Add(DetailItem) | Adds an item to the collection
Public method | Add(DataRow, DataRowCollection) | Adds an item to the collection
Public method | Add(Int32, String) | Adds an item to the collection

See Also

DetailItemCollection Class
DetailItemCollection Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Add Method (DetailItem)

[image]

OfficeClip API Documentation
DetailItemCollection..::.Add Method (DetailItem)
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    DetailItem item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As DetailItem _
)
Visual C++
public:
void Add(
    DetailItem^ item
)

Parameters

item
Type: OfficeClip.BusinessLayer.Extranet.Xml..::.DetailItem
The detail item object

See Also

DetailItemCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Add Method (DataRow, DataRowCollection)

[image]

OfficeClip API Documentation
DetailItemCollection..::.Add Method (DataRow, DataRowCollection)
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    DataRow drDetailItem,
    DataRowCollection dataRows
)
Visual Basic (Declaration)
Public Sub Add ( _
    drDetailItem As DataRow, _
    dataRows As DataRowCollection _
)
Visual C++
public:
void Add(
    DataRow^ drDetailItem,
    DataRowCollection^ dataRows
)

Parameters

drDetailItem
Type: System.Data..::.DataRow
DataRow containing DetailItem
dataRows
Type: System.Data..::.DataRowCollection
Child rows containing DetailItemData for this DetailItem

See Also

DetailItemCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Add Method (Int32, String)

[image]

OfficeClip API Documentation
DetailItemCollection..::.Add Method (Int32, String)
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItem Add(
    int did,
    string name
)
Visual Basic (Declaration)
Public Function Add ( _
    did As Integer, _
    name As String _
) As DetailItem
Visual C++
public:
DetailItem^ Add(
    int did,
    String^ name
)

Parameters

did
Type: System..::.Int32
the unique id of the item detail
name
Type: System..::.String
The name of the detail item

Return Value

The Detail Item object

See Also

DetailItemCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


CopyTo Method

[image]

OfficeClip API Documentation
DetailItemCollection..::.CopyTo Method
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::.Array
index
Type: System..::.Int32

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

DetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Get Method

[image] [image]

OfficeClip API Documentation
DetailItemCollection..::.Get Method
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Get(Int32) |
Public method | Get(String) |

See Also

DetailItemCollection Class
DetailItemCollection Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Get Method (Int32)

[image]

OfficeClip API Documentation
DetailItemCollection..::.Get Method (Int32)
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItem Get(
    int did
)
Visual Basic (Declaration)
Public Function Get ( _
    did As Integer _
) As DetailItem
Visual C++
public:
DetailItem^ Get(
    int did
)

Parameters

did
Type: System..::.Int32
The detail item id

Return Value

See Also

DetailItemCollection Class
Get Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Get Method (String)

[image]

OfficeClip API Documentation
DetailItemCollection..::.Get Method (String)
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItem Get(
    string name
)
Visual Basic (Declaration)
Public Function Get ( _
    name As String _
) As DetailItem
Visual C++
public:
DetailItem^ Get(
    String^ name
)

Parameters

name
Type: System..::.String
The detail item name

Return Value

The detail item object

See Also

DetailItemCollection Class
Get Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
DetailItemCollection..::.GetEnumerator Method
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


ToXml Method

[image]

OfficeClip API Documentation
DetailItemCollection..::.ToXml Method
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Serialize the object to the xml format

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToXml()
Visual Basic (Declaration)
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

Xml for each DetailItem in collection.

See Also

DetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemCollection Properties

[image] [image]

OfficeClip API Documentation
DetailItemCollection Properties
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

The DetailItemCollection type exposes the following properties.

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |

See Also

DetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Count Property

[image]

OfficeClip API Documentation
DetailItemCollection..::.Count Property
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

The count of the items in the collection

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

DetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


IsSynchronized Property

[image]

OfficeClip API Documentation
DetailItemCollection..::.IsSynchronized Property
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Implements

ICollection..::.IsSynchronized

See Also

DetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Item Property

[image]

OfficeClip API Documentation
DetailItemCollection..::.Item Property
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItem this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As DetailItem
Visual C++
public:
property DetailItem^ default[int index] {
    DetailItem^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

DetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


SyncRoot Property

[image]

OfficeClip API Documentation
DetailItemCollection..::.SyncRoot Property
DetailItemCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Implements

ICollection..::.SyncRoot

See Also

DetailItemCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemData Class

[image]

OfficeClip API Documentation
DetailItemData Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class used to store and render the xml of name/value properties of an Extranet Feature Item.

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class DetailItemData
Visual Basic (Declaration)
Public Class DetailItemData
Visual C++
public ref class DetailItemData

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Xml..::.DetailItemData

See Also

DetailItemData Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemData Members

[image] [image]

OfficeClip API Documentation
DetailItemData Members
DetailItemData Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The DetailItemData type exposes the following members.

Constructors

 | Name | Description
Public method | DetailItemData | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

DetailItemData Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemData Constructor

[image] [image]

OfficeClip API Documentation
DetailItemData Constructor
DetailItemData Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | DetailItemData(DataRow) | constructor
Public method | DetailItemData(String, String) | constructor

See Also

DetailItemData Class
DetailItemData Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemData Constructor (DataRow)

[image]

OfficeClip API Documentation
DetailItemData Constructor (DataRow)
DetailItemData Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItemData(
    DataRow drData
)
Visual Basic (Declaration)
Public Sub New ( _
    drData As DataRow _
)
Visual C++
public:
DetailItemData(
    DataRow^ drData
)

Parameters

drData
Type: System.Data..::.DataRow

See Also

DetailItemData Class
DetailItemData Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemData Constructor (String, String)

[image]

OfficeClip API Documentation
DetailItemData Constructor (String, String)
DetailItemData Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItemData(
    string name,
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    value As String _
)
Visual C++
public:
DetailItemData(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::.String
value
Type: System..::.String

See Also

DetailItemData Class
DetailItemData Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemData Methods

[image] [image]

OfficeClip API Documentation
DetailItemData Methods
DetailItemData Class See Also

[This is preliminary documentation and is subject to change.]

The DetailItemData type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

See Also

DetailItemData Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


ToXml Method

[image]

OfficeClip API Documentation
DetailItemData..::.ToXml Method
DetailItemData Class See Also

[This is preliminary documentation and is subject to change.]

Serialize the object to the xml format

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToXml()
Visual Basic (Declaration)
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

See Also

DetailItemData Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemData Properties

[image] [image]

OfficeClip API Documentation
DetailItemData Properties
DetailItemData Class See Also

[This is preliminary documentation and is subject to change.]

The DetailItemData type exposes the following properties.

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

DetailItemData Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Name Property

[image]

OfficeClip API Documentation
DetailItemData..::.Name Property
DetailItemData Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

DetailItemData Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Value Property

[image]

OfficeClip API Documentation
DetailItemData..::.Value Property
DetailItemData Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

DetailItemData Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemDataCollection Class

[image]

OfficeClip API Documentation
DetailItemDataCollection Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class used to store collection of DetailItemData that contains name/value properties of an Extranet Feature Item.

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class DetailItemDataCollection : ICollection,
    IEnumerable
Visual Basic (Declaration)
Public Class DetailItemDataCollection _
    Implements ICollection, IEnumerable
Visual C++
public ref class DetailItemDataCollection : ICollection,
    IEnumerable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Xml..::.DetailItemDataCollection

See Also

DetailItemDataCollection Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemDataCollection Members

[image] [image]

OfficeClip API Documentation
DetailItemDataCollection Members
DetailItemDataCollection Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The DetailItemDataCollection type exposes the following members.

Constructors

 | Name | Description
Public method | DetailItemDataCollection |

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemDataCollection Constructor

[image]

OfficeClip API Documentation
DetailItemDataCollection Constructor
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItemDataCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailItemDataCollection()

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemDataCollection Methods

[image] [image]

OfficeClip API Documentation
DetailItemDataCollection Methods
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

The DetailItemDataCollection type exposes the following methods.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Add Method

[image] [image]

OfficeClip API Documentation
DetailItemDataCollection..::.Add Method
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Add(DetailItemData) | Adds an item to the collection
Public method | Add(String, String) | Adds an item to the collection

See Also

DetailItemDataCollection Class
DetailItemDataCollection Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Add Method (DetailItemData)

[image]

OfficeClip API Documentation
DetailItemDataCollection..::.Add Method (DetailItemData)
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    DetailItemData item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As DetailItemData _
)
Visual C++
public:
void Add(
    DetailItemData^ item
)

Parameters

item
Type: OfficeClip.BusinessLayer.Extranet.Xml..::.DetailItemData

See Also

DetailItemDataCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Add Method (String, String)

[image]

OfficeClip API Documentation
DetailItemDataCollection..::.Add Method (String, String)
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItemData Add(
    string iName,
    string iValue
)
Visual Basic (Declaration)
Public Function Add ( _
    iName As String, _
    iValue As String _
) As DetailItemData
Visual C++
public:
DetailItemData^ Add(
    String^ iName,
    String^ iValue
)

Parameters

iName
Type: System..::.String
iValue
Type: System..::.String

Return Value

See Also

DetailItemDataCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


CopyTo Method

[image]

OfficeClip API Documentation
DetailItemDataCollection..::.CopyTo Method
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::.Array
index
Type: System..::.Int32

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Get Method

[image]

OfficeClip API Documentation
DetailItemDataCollection..::.Get Method
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItemData Get(
    string name
)
Visual Basic (Declaration)
Public Function Get ( _
    name As String _
) As DetailItemData
Visual C++
public:
DetailItemData^ Get(
    String^ name
)

Parameters

name
Type: System..::.String

Return Value

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
DetailItemDataCollection..::.GetEnumerator Method
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


ToXml Method

[image]

OfficeClip API Documentation
DetailItemDataCollection..::.ToXml Method
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

Serialize the object to the xml format

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToXml()
Visual Basic (Declaration)
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailItemDataCollection Properties

[image] [image]

OfficeClip API Documentation
DetailItemDataCollection Properties
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

The DetailItemDataCollection type exposes the following properties.

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Count Property

[image]

OfficeClip API Documentation
DetailItemDataCollection..::.Count Property
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

The count of the items in the collection

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


IsSynchronized Property

[image]

OfficeClip API Documentation
DetailItemDataCollection..::.IsSynchronized Property
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Implements

ICollection..::.IsSynchronized

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Item Property

[image]

OfficeClip API Documentation
DetailItemDataCollection..::.Item Property
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItemData this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As DetailItemData
Visual C++
public:
property DetailItemData^ default[int index] {
    DetailItemData^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


SyncRoot Property

[image]

OfficeClip API Documentation
DetailItemDataCollection..::.SyncRoot Property
DetailItemDataCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Implements

ICollection..::.SyncRoot

See Also

DetailItemDataCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Details Class

[image]

OfficeClip API Documentation
Details Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class used to hold collection of DetailItems that contains abstract identifiers/properties of type and value

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class Details
Visual Basic (Declaration)
Public Class Details
Visual C++
public ref class Details

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Xml..::.Details

See Also

Details Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Details Members

[image] [image]

OfficeClip API Documentation
Details Members
Details Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The Details type exposes the following members.

Constructors

 | Name | Description
Public method | Details | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

Properties

 | Name | Description
Public property | Items |
Public property | Type | The detail type
Public property | Value | The detail value

See Also

Details Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Details Constructor

[image] [image]

OfficeClip API Documentation
Details Constructor
Details Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Details(DataRow, DataRowCollection) | constructor
Public method | Details(String, String) | constructor

See Also

Details Class
Details Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Details Constructor (DataRow, DataRowCollection)

[image]

OfficeClip API Documentation
Details Constructor (DataRow, DataRowCollection)
Details Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Details(
    DataRow drDetails,
    DataRowCollection detailItemTables
)
Visual Basic (Declaration)
Public Sub New ( _
    drDetails As DataRow, _
    detailItemTables As DataRowCollection _
)
Visual C++
public:
Details(
    DataRow^ drDetails,
    DataRowCollection^ detailItemTables
)

Parameters

drDetails
Type: System.Data..::.DataRow
DataRow containing the type/value of the Details.
detailItemTables
Type: System.Data..::.DataRowCollection
Child rows conaining data for DetailItemData

See Also

Details Class
Details Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Details Constructor (String, String)

[image]

OfficeClip API Documentation
Details Constructor (String, String)
Details Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Details(
    string dType,
    string dValue
)
Visual Basic (Declaration)
Public Sub New ( _
    dType As String, _
    dValue As String _
)
Visual C++
public:
Details(
    String^ dType,
    String^ dValue
)

Parameters

dType
Type: System..::.String
The detail type
dValue
Type: System..::.String
The detail value

See Also

Details Class
Details Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Details Methods

[image] [image]

OfficeClip API Documentation
Details Methods
Details Class See Also

[This is preliminary documentation and is subject to change.]

The Details type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

See Also

Details Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


ToXml Method

[image]

OfficeClip API Documentation
Details..::.ToXml Method
Details Class See Also

[This is preliminary documentation and is subject to change.]

Serialize the object to the xml format

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToXml()
Visual Basic (Declaration)
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

See Also

Details Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Details Properties

[image] [image]

OfficeClip API Documentation
Details Properties
Details Class See Also

[This is preliminary documentation and is subject to change.]

The Details type exposes the following properties.

Properties

 | Name | Description
Public property | Items |
Public property | Type | The detail type
Public property | Value | The detail value

See Also

Details Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Items Property

[image]

OfficeClip API Documentation
Details..::.Items Property
Details Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailItemCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As DetailItemCollection
Visual C++
public:
property DetailItemCollection^ Items {
    DetailItemCollection^ get ();
}

See Also

Details Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Type Property

[image]

OfficeClip API Documentation
Details..::.Type Property
Details Class See Also

[This is preliminary documentation and is subject to change.]

The detail type

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As String
Visual C++
public:
property String^ Type {
    String^ get ();
}

See Also

Details Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Value Property

[image]

OfficeClip API Documentation
Details..::.Value Property
Details Class See Also

[This is preliminary documentation and is subject to change.]

The detail value

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
}

See Also

Details Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailsCollection Class

[image]

OfficeClip API Documentation
DetailsCollection Class
Members See Also

[This is preliminary documentation and is subject to change.]

Collection class used by FeatureItem to contain Details

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class DetailsCollection : ICollection,
    IEnumerable
Visual Basic (Declaration)
Public Class DetailsCollection _
    Implements ICollection, IEnumerable
Visual C++
public ref class DetailsCollection : ICollection,
    IEnumerable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Xml..::.DetailsCollection

See Also

DetailsCollection Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailsCollection Members

[image] [image]

OfficeClip API Documentation
DetailsCollection Members
DetailsCollection Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The DetailsCollection type exposes the following members.

Constructors

 | Name | Description
Public method | DetailsCollection |

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailsCollection Constructor

[image]

OfficeClip API Documentation
DetailsCollection Constructor
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailsCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DetailsCollection()

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailsCollection Methods

[image] [image]

OfficeClip API Documentation
DetailsCollection Methods
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

The DetailsCollection type exposes the following methods.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Add Method

[image] [image]

OfficeClip API Documentation
DetailsCollection..::.Add Method
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Add(Details) | Adds an item to the collection
Public method | Add(DataRow, DataRowCollection) | Adds an item to the collection
Public method | Add(String, String) | Adds an item to the collection

See Also

DetailsCollection Class
DetailsCollection Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Add Method (Details)

[image]

OfficeClip API Documentation
DetailsCollection..::.Add Method (Details)
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    Details item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As Details _
)
Visual C++
public:
void Add(
    Details^ item
)

Parameters

item
Type: OfficeClip.BusinessLayer.Extranet.Xml..::.Details

See Also

DetailsCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Add Method (DataRow, DataRowCollection)

[image]

OfficeClip API Documentation
DetailsCollection..::.Add Method (DataRow, DataRowCollection)
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    DataRow drDetails,
    DataRowCollection detailItemTables
)
Visual Basic (Declaration)
Public Sub Add ( _
    drDetails As DataRow, _
    detailItemTables As DataRowCollection _
)
Visual C++
public:
void Add(
    DataRow^ drDetails,
    DataRowCollection^ detailItemTables
)

Parameters

drDetails
Type: System.Data..::.DataRow
detailItemTables
Type: System.Data..::.DataRowCollection

See Also

DetailsCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Add Method (String, String)

[image]

OfficeClip API Documentation
DetailsCollection..::.Add Method (String, String)
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds an item to the collection

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Details Add(
    string dType,
    string dValue
)
Visual Basic (Declaration)
Public Function Add ( _
    dType As String, _
    dValue As String _
) As Details
Visual C++
public:
Details^ Add(
    String^ dType,
    String^ dValue
)

Parameters

dType
Type: System..::.String
dValue
Type: System..::.String

Return Value

See Also

DetailsCollection Class
Add Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


CopyTo Method

[image]

OfficeClip API Documentation
DetailsCollection..::.CopyTo Method
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::.Array
index
Type: System..::.Int32

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Get Method

[image]

OfficeClip API Documentation
DetailsCollection..::.Get Method
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Details Get(
    string dType,
    string dValue
)
Visual Basic (Declaration)
Public Function Get ( _
    dType As String, _
    dValue As String _
) As Details
Visual C++
public:
Details^ Get(
    String^ dType,
    String^ dValue
)

Parameters

dType
Type: System..::.String
dValue
Type: System..::.String

Return Value

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
DetailsCollection..::.GetEnumerator Method
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


ToXml Method

[image]

OfficeClip API Documentation
DetailsCollection..::.ToXml Method
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Serialize the object to the xml format

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToXml()
Visual Basic (Declaration)
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


DetailsCollection Properties

[image] [image]

OfficeClip API Documentation
DetailsCollection Properties
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

The DetailsCollection type exposes the following properties.

Properties

 | Name | Description
Public property | Count | The count of the items in the collection
Public property | IsSynchronized |
Public property | Item |
Public property | SyncRoot |

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Count Property

[image]

OfficeClip API Documentation
DetailsCollection..::.Count Property
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

The count of the items in the collection

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


IsSynchronized Property

[image]

OfficeClip API Documentation
DetailsCollection..::.IsSynchronized Property
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Implements

ICollection..::.IsSynchronized

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Item Property

[image]

OfficeClip API Documentation
DetailsCollection..::.Item Property
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Details this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Details
Visual C++
public:
property Details^ default[int index] {
    Details^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


SyncRoot Property

[image]

OfficeClip API Documentation
DetailsCollection..::.SyncRoot Property
DetailsCollection Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Implements

ICollection..::.SyncRoot

See Also

DetailsCollection Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


FeatureItem Class

[image]

OfficeClip API Documentation
FeatureItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class for creating Feature Item Detail XML or associated business objects from supplied feature Item XML.

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class FeatureItem
Visual Basic (Declaration)
Public Class FeatureItem
Visual C++
public ref class FeatureItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Extranet.Xml..::.FeatureItem

See Also

FeatureItem Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


FeatureItem Members

[image] [image]

OfficeClip API Documentation
FeatureItem Members
FeatureItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The FeatureItem type exposes the following members.

Constructors

 | Name | Description
Public method | FeatureItem | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

Properties

 | Name | Description
Public property | ID | The id of the feature item
Public property | Items |
Public property | Value | The value of the feature item

See Also

FeatureItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


FeatureItem Constructor

[image] [image]

OfficeClip API Documentation
FeatureItem Constructor
FeatureItem Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | FeatureItem()()() | default constructor
Public method | FeatureItem(String) | constructor
Public method | FeatureItem(Int32, String) | constructor

See Also

FeatureItem Class
FeatureItem Members
OfficeClip.BusinessLayer.Extranet.Xml Namespace


FeatureItem Constructor

[image]

OfficeClip API Documentation
FeatureItem Constructor
FeatureItem Class See Also

[This is preliminary documentation and is subject to change.]

default constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public FeatureItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FeatureItem()

See Also

FeatureItem Class
FeatureItem Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


FeatureItem Constructor (String)

[image]

OfficeClip API Documentation
FeatureItem Constructor (String)
FeatureItem Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public FeatureItem(
    string featureXml
)
Visual Basic (Declaration)
Public Sub New ( _
    featureXml As String _
)
Visual C++
public:
FeatureItem(
    String^ featureXml
)

Parameters

featureXml
Type: System..::.String
The feature xml string

See Also

FeatureItem Class
FeatureItem Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


FeatureItem Constructor (Int32, String)

[image]

OfficeClip API Documentation
FeatureItem Constructor (Int32, String)
FeatureItem Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public FeatureItem(
    int fId,
    string fValue
)
Visual Basic (Declaration)
Public Sub New ( _
    fId As Integer, _
    fValue As String _
)
Visual C++
public:
FeatureItem(
    int fId,
    String^ fValue
)

Parameters

fId
Type: System..::.Int32
The unique id of the feature
fValue
Type: System..::.String
The value of the feature

See Also

FeatureItem Class
FeatureItem Overload
OfficeClip.BusinessLayer.Extranet.Xml Namespace


FeatureItem Methods

[image] [image]

OfficeClip API Documentation
FeatureItem Methods
FeatureItem Class See Also

[This is preliminary documentation and is subject to change.]

The FeatureItem type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Serialize the object to the xml format

See Also

FeatureItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


ToXml Method

[image]

OfficeClip API Documentation
FeatureItem..::.ToXml Method
FeatureItem Class See Also

[This is preliminary documentation and is subject to change.]

Serialize the object to the xml format

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToXml()
Visual Basic (Declaration)
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

See Also

FeatureItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


FeatureItem Properties

[image] [image]

OfficeClip API Documentation
FeatureItem Properties
FeatureItem Class See Also

[This is preliminary documentation and is subject to change.]

The FeatureItem type exposes the following properties.

Properties

 | Name | Description
Public property | ID | The id of the feature item
Public property | Items |
Public property | Value | The value of the feature item

See Also

FeatureItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


ID Property

[image]

OfficeClip API Documentation
FeatureItem..::.ID Property
FeatureItem Class See Also

[This is preliminary documentation and is subject to change.]

The id of the feature item

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ID { get; set; }
Visual Basic (Declaration)
Public Property ID As Integer
Visual C++
public:
property int ID {
    int get ();
    void set (int value);
}

See Also

FeatureItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Items Property

[image]

OfficeClip API Documentation
FeatureItem..::.Items Property
FeatureItem Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DetailsCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As DetailsCollection
Visual C++
public:
property DetailsCollection^ Items {
    DetailsCollection^ get ();
}

See Also

FeatureItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


Value Property

[image]

OfficeClip API Documentation
FeatureItem..::.Value Property
FeatureItem Class See Also

[This is preliminary documentation and is subject to change.]

The value of the feature item

Namespace: OfficeClip.BusinessLayer.Extranet.Xml
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

FeatureItem Class
OfficeClip.BusinessLayer.Extranet.Xml Namespace


OfficeClip.BusinessLayer.Framework Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Framework Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the OfficeClip framework. The framwork manages toolbar. menubar, button bar etc.

Classes

 | Class | Description
Public class | AlphabetListItem | Class for alphabetic list shown at the top of the user manager
Public class | ApplicationAccess | Class to represent the application access
Public class | ApplicationInfo | Provides methods for interacting with the Application Information Object.
Public class | ApplicationItem | Class to represent the application items
Public class | ButtonbarItem | Class to represent the button bar
Public class | Classification | class for classification
Public class | Constants | Class for represting OfficeClip framework constants
Public class | GenericReport | The generic report class
Public class | LeftbarItem | class to represent he left bar item
Public class | LoginSetupInfo | The login setup information class
Public class | MenuItem | Class that describes the menu item in OfficeClip
Public class | PropertyInfo | Provides methods and properties to access the property information. The object created from this class can be serialized.
Public class | RightMenuButtonItem | Class to represent the button bar
Public class | TimeZoneInfo | The Time Zone structure.
Public class | ToolbarItem | Class to represent a toolbar item

Interfaces

 | Interface | Description
Public interface | IOCDateTimeFormatInfo | An interface for the OfficeClip Date and Time Fromat Information.

Enumerations

 | Enumeration | Description
Public enumeration | Constants..::.ApplicationType | Enumerated type for the applications
Public enumeration | Constants..::.MenubarType | Menubar item
Public enumeration | Constants..::.ToolbarType | The type of the toolbar


AlphabetListItem Class

[image]

OfficeClip API Documentation
AlphabetListItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class for alphabetic list shown at the top of the user manager

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class AlphabetListItem
Visual Basic (Declaration)
Public Class AlphabetListItem
Visual C++
public ref class AlphabetListItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.AlphabetListItem

See Also

AlphabetListItem Members
OfficeClip.BusinessLayer.Framework Namespace


AlphabetListItem Members

[image] [image]

OfficeClip API Documentation
AlphabetListItem Members
AlphabetListItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AlphabetListItem type exposes the following members.

Constructors

 | Name | Description
Public method | AlphabetListItem | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Alphabet | The alphabet
Public property | IsPresent | determines if the alphabet is present
Public property | IsSelected | Determins if the alphabet is selected

See Also

AlphabetListItem Class
OfficeClip.BusinessLayer.Framework Namespace


AlphabetListItem Constructor

[image]

OfficeClip API Documentation
AlphabetListItem Constructor
AlphabetListItem Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AlphabetListItem(
    char alphabet,
    bool isPresent,
    bool isActive
)
Visual Basic (Declaration)
Public Sub New ( _
    alphabet As Char, _
    isPresent As Boolean, _
    isActive As Boolean _
)
Visual C++
public:
AlphabetListItem(
    wchar_t alphabet,
    bool isPresent,
    bool isActive
)

Parameters

alphabet
Type: System..::.Char
isPresent
Type: System..::.Boolean
isActive
Type: System..::.Boolean

See Also

AlphabetListItem Class
OfficeClip.BusinessLayer.Framework Namespace


AlphabetListItem Properties

[image] [image]

OfficeClip API Documentation
AlphabetListItem Properties
AlphabetListItem Class See Also

[This is preliminary documentation and is subject to change.]

The AlphabetListItem type exposes the following properties.

Properties

 | Name | Description
Public property | Alphabet | The alphabet
Public property | IsPresent | determines if the alphabet is present
Public property | IsSelected | Determins if the alphabet is selected

See Also

AlphabetListItem Class
OfficeClip.BusinessLayer.Framework Namespace


Alphabet Property

[image]

OfficeClip API Documentation
AlphabetListItem..::.Alphabet Property
AlphabetListItem Class See Also

[This is preliminary documentation and is subject to change.]

The alphabet

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public char Alphabet { get; set; }
Visual Basic (Declaration)
Public Property Alphabet As Char
Visual C++
public:
property wchar_t Alphabet {
    wchar_t get ();
    void set (wchar_t value);
}

See Also

AlphabetListItem Class
OfficeClip.BusinessLayer.Framework Namespace


IsPresent Property

[image]

OfficeClip API Documentation
AlphabetListItem..::.IsPresent Property
AlphabetListItem Class See Also

[This is preliminary documentation and is subject to change.]

determines if the alphabet is present

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsPresent { get; set; }
Visual Basic (Declaration)
Public Property IsPresent As Boolean
Visual C++
public:
property bool IsPresent {
    bool get ();
    void set (bool value);
}

See Also

AlphabetListItem Class
OfficeClip.BusinessLayer.Framework Namespace


IsSelected Property

[image]

OfficeClip API Documentation
AlphabetListItem..::.IsSelected Property
AlphabetListItem Class See Also

[This is preliminary documentation and is subject to change.]

Determins if the alphabet is selected

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

AlphabetListItem Class
OfficeClip.BusinessLayer.Framework Namespace


ApplicationAccess Class

[image]

OfficeClip API Documentation
ApplicationAccess Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the application access

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ApplicationAccess
Visual Basic (Declaration)
Public Class ApplicationAccess
Visual C++
public ref class ApplicationAccess

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.ApplicationAccess

See Also

ApplicationAccess Members
OfficeClip.BusinessLayer.Framework Namespace


ApplicationAccess Members

[image] [image]

OfficeClip API Documentation
ApplicationAccess Members
ApplicationAccess Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ApplicationAccess type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationAccess | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAllowed | Determines if the application is allowed
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AppIdByteArray | The array of application ids
Public property | AppIdList | The list of application id
Public property | AppNameIdArray | The array of application id and name

See Also

ApplicationAccess Class
OfficeClip.BusinessLayer.Framework Namespace


ApplicationAccess Constructor

[image]

OfficeClip API Documentation
ApplicationAccess Constructor
ApplicationAccess Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationAccess(
    byte[] appIds
)
Visual Basic (Declaration)
Public Sub New ( _
    appIds As Byte() _
)
Visual C++
public:
ApplicationAccess(
    array<unsigned char>^ appIds
)

Parameters

appIds
Type: array<System..::.Byte>[]()[]

See Also

ApplicationAccess Class
OfficeClip.BusinessLayer.Framework Namespace


ApplicationAccess Methods

[image] [image]

OfficeClip API Documentation
ApplicationAccess Methods
ApplicationAccess Class See Also

[This is preliminary documentation and is subject to change.]

The ApplicationAccess type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAllowed | Determines if the application is allowed
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationAccess Class
OfficeClip.BusinessLayer.Framework Namespace


IsAllowed Method

[image]

OfficeClip API Documentation
ApplicationAccess..::.IsAllowed Method
ApplicationAccess Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the application is allowed

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAllowed(
    Constants..::.ApplicationType appId
)
Visual Basic (Declaration)
Public Function IsAllowed ( _
    appId As Constants..::.ApplicationType _
) As Boolean
Visual C++
public:
bool IsAllowed(
    Constants..::.ApplicationType appId
)

Parameters

appId
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
The unique application id

Return Value

True if the application is allowed, false otherwise

See Also

ApplicationAccess Class
OfficeClip.BusinessLayer.Framework Namespace


ApplicationAccess Properties

[image] [image]

OfficeClip API Documentation
ApplicationAccess Properties
ApplicationAccess Class See Also

[This is preliminary documentation and is subject to change.]

The ApplicationAccess type exposes the following properties.

Properties

 | Name | Description
Public property | AppIdByteArray | The array of application ids
Public property | AppIdList | The list of application id
Public property | AppNameIdArray | The array of application id and name

See Also

ApplicationAccess Class
OfficeClip.BusinessLayer.Framework Namespace


AppIdByteArray Property

[image]

OfficeClip API Documentation
ApplicationAccess..::.AppIdByteArray Property
ApplicationAccess Class See Also

[This is preliminary documentation and is subject to change.]

The array of application ids

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public byte[] AppIdByteArray { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppIdByteArray As Byte()
Visual C++
public:
property array<unsigned char>^ AppIdByteArray {
    array<unsigned char>^ get ();
}

See Also

ApplicationAccess Class
OfficeClip.BusinessLayer.Framework Namespace


AppIdList Property

[image]

OfficeClip API Documentation
ApplicationAccess..::.AppIdList Property
ApplicationAccess Class See Also

[This is preliminary documentation and is subject to change.]

The list of application id

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<int> AppIdList { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppIdList As List(Of Integer)
Visual C++
public:
property List<int>^ AppIdList {
    List<int>^ get ();
}

See Also

ApplicationAccess Class
OfficeClip.BusinessLayer.Framework Namespace


AppNameIdArray Property

[image]

OfficeClip API Documentation
ApplicationAccess..::.AppNameIdArray Property
ApplicationAccess Class See Also

[This is preliminary documentation and is subject to change.]

The array of application id and name

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<ApplicationItem> AppNameIdArray { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppNameIdArray As List(Of ApplicationItem)
Visual C++
public:
property List<ApplicationItem^>^ AppNameIdArray {
    List<ApplicationItem^>^ get ();
}

See Also

ApplicationAccess Class
OfficeClip.BusinessLayer.Framework Namespace


ApplicationInfo Class

[image]

OfficeClip API Documentation
ApplicationInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods for interacting with the Application Information Object.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ApplicationInfo
Visual Basic (Declaration)
Public Class ApplicationInfo
Visual C++
public ref class ApplicationInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.ApplicationInfo

See Also

ApplicationInfo Members
OfficeClip.BusinessLayer.Framework Namespace


ApplicationInfo Members

[image] [image]

OfficeClip API Documentation
ApplicationInfo Members
ApplicationInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ApplicationInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Active | If the application is Active. True is Active, False is inactive.
Public property | Text | The application name.
Public property | Type | The unique system generated id of the application.
Public property | url | The application unique resource locator.

See Also

ApplicationInfo Class
OfficeClip.BusinessLayer.Framework Namespace


ApplicationInfo Constructor

[image] [image]

OfficeClip API Documentation
ApplicationInfo Constructor
ApplicationInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ApplicationInfo()()() | The default constructor.
Public method | ApplicationInfo(String, String, Constants..::.ApplicationType, Boolean) | The constructor to set the values of the application information object.

See Also

ApplicationInfo Class
ApplicationInfo Members
OfficeClip.BusinessLayer.Framework Namespace


ApplicationInfo Constructor

[image]

OfficeClip API Documentation
ApplicationInfo Constructor
ApplicationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ApplicationInfo()

See Also

ApplicationInfo Class
ApplicationInfo Overload
OfficeClip.BusinessLayer.Framework Namespace


ApplicationInfo Constructor (String, String, Constants.ApplicationType, Boolean)

[image]

OfficeClip API Documentation
ApplicationInfo Constructor (String, String, Constants..::.ApplicationType, Boolean)
ApplicationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor to set the values of the application information object.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationInfo(
    string Text,
    string Url,
    Constants..::.ApplicationType type,
    bool active
)
Visual Basic (Declaration)
Public Sub New ( _
    Text As String, _
    Url As String, _
    type As Constants..::.ApplicationType, _
    active As Boolean _
)
Visual C++
public:
ApplicationInfo(
    String^ Text,
    String^ Url,
    Constants..::.ApplicationType type,
    bool active
)

Parameters

Text
Type: System..::.String
The name of the application.
Url
Type: System..::.String
The url ofthe application.
type
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
The application type.
active
Type: System..::.Boolean
Determines whether the application is Active, True = Active, False = inactive.

See Also

ApplicationInfo Class
ApplicationInfo Overload
OfficeClip.BusinessLayer.Framework Namespace


ApplicationInfo Properties

[image] [image]

OfficeClip API Documentation
ApplicationInfo Properties
ApplicationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ApplicationInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Active | If the application is Active. True is Active, False is inactive.
Public property | Text | The application name.
Public property | Type | The unique system generated id of the application.
Public property | url | The application unique resource locator.

See Also

ApplicationInfo Class
OfficeClip.BusinessLayer.Framework Namespace


Active Property

[image]

OfficeClip API Documentation
ApplicationInfo..::.Active Property
ApplicationInfo Class See Also

[This is preliminary documentation and is subject to change.]

If the application is Active. True is Active, False is inactive.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool Active { get; set; }
Visual Basic (Declaration)
Public Property Active As Boolean
Visual C++
public:
property bool Active {
    bool get ();
    void set (bool value);
}

See Also

ApplicationInfo Class
OfficeClip.BusinessLayer.Framework Namespace


Text Property

[image]

OfficeClip API Documentation
ApplicationInfo..::.Text Property
ApplicationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The application name.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ApplicationInfo Class
OfficeClip.BusinessLayer.Framework Namespace


Type Property

[image]

OfficeClip API Documentation
ApplicationInfo..::.Type Property
ApplicationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique system generated id of the application.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Constants..::.ApplicationType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As Constants..::.ApplicationType
Visual C++
public:
property Constants..::.ApplicationType Type {
    Constants..::.ApplicationType get ();
}

See Also

ApplicationInfo Class
OfficeClip.BusinessLayer.Framework Namespace


url Property

[image]

OfficeClip API Documentation
ApplicationInfo..::.url Property
ApplicationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The application unique resource locator.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string url { get; set; }
Visual Basic (Declaration)
Public Property url As String
Visual C++
public:
property String^ url {
    String^ get ();
    void set (String^ value);
}

See Also

ApplicationInfo Class
OfficeClip.BusinessLayer.Framework Namespace


ApplicationItem Class

[image]

OfficeClip API Documentation
ApplicationItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the application items

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ApplicationItem
Visual Basic (Declaration)
Public Class ApplicationItem
Visual C++
public ref class ApplicationItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.ApplicationItem

See Also

ApplicationItem Members
OfficeClip.BusinessLayer.Framework Namespace


ApplicationItem Members

[image] [image]

OfficeClip API Documentation
ApplicationItem Members
ApplicationItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ApplicationItem type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationItem | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AppId | The application id
Public property | AppName | The application name

See Also

ApplicationItem Class
OfficeClip.BusinessLayer.Framework Namespace


ApplicationItem Constructor

[image]

OfficeClip API Documentation
ApplicationItem Constructor
ApplicationItem Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationItem(
    int appId,
    string appName
)
Visual Basic (Declaration)
Public Sub New ( _
    appId As Integer, _
    appName As String _
)
Visual C++
public:
ApplicationItem(
    int appId,
    String^ appName
)

Parameters

appId
Type: System..::.Int32
appName
Type: System..::.String

See Also

ApplicationItem Class
OfficeClip.BusinessLayer.Framework Namespace


ApplicationItem Properties

[image] [image]

OfficeClip API Documentation
ApplicationItem Properties
ApplicationItem Class See Also

[This is preliminary documentation and is subject to change.]

The ApplicationItem type exposes the following properties.

Properties

 | Name | Description
Public property | AppId | The application id
Public property | AppName | The application name

See Also

ApplicationItem Class
OfficeClip.BusinessLayer.Framework Namespace


AppId Property

[image]

OfficeClip API Documentation
ApplicationItem..::.AppId Property
ApplicationItem Class See Also

[This is preliminary documentation and is subject to change.]

The application id

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AppId { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppId As Integer
Visual C++
public:
property int AppId {
    int get ();
}

See Also

ApplicationItem Class
OfficeClip.BusinessLayer.Framework Namespace


AppName Property

[image]

OfficeClip API Documentation
ApplicationItem..::.AppName Property
ApplicationItem Class See Also

[This is preliminary documentation and is subject to change.]

The application name

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AppName { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppName As String
Visual C++
public:
property String^ AppName {
    String^ get ();
}

See Also

ApplicationItem Class
OfficeClip.BusinessLayer.Framework Namespace


ButtonbarItem Class

[image]

OfficeClip API Documentation
ButtonbarItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the button bar

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ButtonbarItem
Visual Basic (Declaration)
Public Class ButtonbarItem
Visual C++
public ref class ButtonbarItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.ButtonbarItem

See Also

ButtonbarItem Members
OfficeClip.BusinessLayer.Framework Namespace


ButtonbarItem Members

[image] [image]

OfficeClip API Documentation
ButtonbarItem Members
ButtonbarItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ButtonbarItem type exposes the following members.

Constructors

 | Name | Description
Public method | ButtonbarItem | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlternateText | The alternate text of the button (e.g. in alert)
Public property | ImageUrl | The url from where the button image is extracted
Public property | IsHidden | Shows if the buttonbar item is hidden
Public property | IsSelected | Shows if the buttonbar item is selected
Public property | SkinId | The unique id of the skin
Public property | Target | The target of the Url
Public property | Text | the text of the button bar item
Public property | Url | The url that is linked with the button

See Also

ButtonbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


ButtonbarItem Constructor

[image] [image]

OfficeClip API Documentation
ButtonbarItem Constructor
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ButtonbarItem(String) | constructor
Public method | ButtonbarItem(String, String, String) | constructor

See Also

ButtonbarItem Class
ButtonbarItem Members
OfficeClip.BusinessLayer.Framework Namespace


ButtonbarItem Constructor (String)

[image]

OfficeClip API Documentation
ButtonbarItem Constructor (String)
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ButtonbarItem(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)
Visual C++
public:
ButtonbarItem(
    String^ text
)

Parameters

text
Type: System..::.String

See Also

ButtonbarItem Class
ButtonbarItem Overload
OfficeClip.BusinessLayer.Framework Namespace


ButtonbarItem Constructor (String, String, String)

[image]

OfficeClip API Documentation
ButtonbarItem Constructor (String, String, String)
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ButtonbarItem(
    string text,
    string url,
    string imageUrl
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String, _
    url As String, _
    imageUrl As String _
)
Visual C++
public:
ButtonbarItem(
    String^ text,
    String^ url,
    String^ imageUrl
)

Parameters

text
Type: System..::.String
url
Type: System..::.String
imageUrl
Type: System..::.String

See Also

ButtonbarItem Class
ButtonbarItem Overload
OfficeClip.BusinessLayer.Framework Namespace


ButtonbarItem Properties

[image] [image]

OfficeClip API Documentation
ButtonbarItem Properties
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The ButtonbarItem type exposes the following properties.

Properties

 | Name | Description
Public property | AlternateText | The alternate text of the button (e.g. in alert)
Public property | ImageUrl | The url from where the button image is extracted
Public property | IsHidden | Shows if the buttonbar item is hidden
Public property | IsSelected | Shows if the buttonbar item is selected
Public property | SkinId | The unique id of the skin
Public property | Target | The target of the Url
Public property | Text | the text of the button bar item
Public property | Url | The url that is linked with the button

See Also

ButtonbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


AlternateText Property

[image]

OfficeClip API Documentation
ButtonbarItem..::.AlternateText Property
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The alternate text of the button (e.g. in alert)

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AlternateText { get; set; }
Visual Basic (Declaration)
Public Property AlternateText As String
Visual C++
public:
property String^ AlternateText {
    String^ get ();
    void set (String^ value);
}

See Also

ButtonbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


ImageUrl Property

[image]

OfficeClip API Documentation
ButtonbarItem..::.ImageUrl Property
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The url from where the button image is extracted

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ImageUrl { get; set; }
Visual Basic (Declaration)
Public Property ImageUrl As String
Visual C++
public:
property String^ ImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

ButtonbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


IsHidden Property

[image]

OfficeClip API Documentation
ButtonbarItem..::.IsHidden Property
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the buttonbar item is hidden

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsHidden { get; set; }
Visual Basic (Declaration)
Public Property IsHidden As Boolean
Visual C++
public:
property bool IsHidden {
    bool get ();
    void set (bool value);
}

See Also

ButtonbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


IsSelected Property

[image]

OfficeClip API Documentation
ButtonbarItem..::.IsSelected Property
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the buttonbar item is selected

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

ButtonbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


SkinId Property

[image]

OfficeClip API Documentation
ButtonbarItem..::.SkinId Property
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the skin

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SkinId { get; set; }
Visual Basic (Declaration)
Public Property SkinId As String
Visual C++
public:
property String^ SkinId {
    String^ get ();
    void set (String^ value);
}

See Also

ButtonbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


Target Property

[image]

OfficeClip API Documentation
ButtonbarItem..::.Target Property
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The target of the Url

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Target { get; set; }
Visual Basic (Declaration)
Public Property Target As String
Visual C++
public:
property String^ Target {
    String^ get ();
    void set (String^ value);
}

See Also

ButtonbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


Text Property

[image]

OfficeClip API Documentation
ButtonbarItem..::.Text Property
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

the text of the button bar item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ButtonbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


Url Property

[image]

OfficeClip API Documentation
ButtonbarItem..::.Url Property
ButtonbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The url that is linked with the button

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Url { get; set; }
Visual Basic (Declaration)
Public Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

See Also

ButtonbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


Classification Class

[image]

OfficeClip API Documentation
Classification Class
Members See Also

[This is preliminary documentation and is subject to change.]

class for classification

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class Classification
Visual Basic (Declaration)
Public Class Classification
Visual C++
public ref class Classification

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.Classification

See Also

Classification Members
OfficeClip.BusinessLayer.Framework Namespace


Classification Members

[image] [image]

OfficeClip API Documentation
Classification Members
Classification Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The Classification type exposes the following members.

Constructors

 | Name | Description
Public method | Classification | constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | color of the label
Public property | LabelId | The label id
Public property | Name | The label name

See Also

Classification Class
OfficeClip.BusinessLayer.Framework Namespace


Classification Constructor

[image]

OfficeClip API Documentation
Classification Constructor
Classification Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Classification(
    int labelId,
    string color,
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    labelId As Integer, _
    color As String, _
    name As String _
)
Visual C++
public:
Classification(
    int labelId,
    String^ color,
    String^ name
)

Parameters

labelId
Type: System..::.Int32
color
Type: System..::.String
name
Type: System..::.String

See Also

Classification Class
OfficeClip.BusinessLayer.Framework Namespace


Classification Properties

[image] [image]

OfficeClip API Documentation
Classification Properties
Classification Class See Also

[This is preliminary documentation and is subject to change.]

The Classification type exposes the following properties.

Properties

 | Name | Description
Public property | Color | color of the label
Public property | LabelId | The label id
Public property | Name | The label name

See Also

Classification Class
OfficeClip.BusinessLayer.Framework Namespace


Color Property

[image]

OfficeClip API Documentation
Classification..::.Color Property
Classification Class See Also

[This is preliminary documentation and is subject to change.]

color of the label

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Color { get; set; }
Visual Basic (Declaration)
Public Property Color As String
Visual C++
public:
property String^ Color {
    String^ get ();
    void set (String^ value);
}

See Also

Classification Class
OfficeClip.BusinessLayer.Framework Namespace


LabelId Property

[image]

OfficeClip API Documentation
Classification..::.LabelId Property
Classification Class See Also

[This is preliminary documentation and is subject to change.]

The label id

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LabelId { get; set; }
Visual Basic (Declaration)
Public Property LabelId As Integer
Visual C++
public:
property int LabelId {
    int get ();
    void set (int value);
}

See Also

Classification Class
OfficeClip.BusinessLayer.Framework Namespace


Name Property

[image]

OfficeClip API Documentation
Classification..::.Name Property
Classification Class See Also

[This is preliminary documentation and is subject to change.]

The label name

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Classification Class
OfficeClip.BusinessLayer.Framework Namespace


Constants Class

[image]

OfficeClip API Documentation
Constants Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class for represting OfficeClip framework constants

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class Constants
Visual Basic (Declaration)
Public Class Constants
Visual C++
public ref class Constants

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.Constants

See Also

Constants Members
OfficeClip.BusinessLayer.Framework Namespace


Constants Members

[image] [image]

OfficeClip API Documentation
Constants Members
Constants Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The Constants type exposes the following members.

Constructors

 | Name | Description
Public method | Constants |

Methods

 | Name | Description
 | AllApplications | Gets the list of all the applications
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDiskApplicationPath | Gets the disk path of the application
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHelpUrl | Overloaded.
 | GetName | Overloaded.
 | GetToolTip | Overloaded.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUrl | Returns the url for the application
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QuickHelpDestination | Gets the quick help destination for the toolbar item
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ApplicationAccess | Gets the application access

See Also

Constants Class
OfficeClip.BusinessLayer.Framework Namespace


Constants Constructor

[image]

OfficeClip API Documentation
Constants Constructor
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Constants()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Constants()

See Also

Constants Class
OfficeClip.BusinessLayer.Framework Namespace


Constants Methods

[image] [image]

OfficeClip API Documentation
Constants Methods
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The Constants type exposes the following methods.

Methods

 | Name | Description
 | AllApplications | Gets the list of all the applications
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDiskApplicationPath | Gets the disk path of the application
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHelpUrl | Overloaded.
 | GetName | Overloaded.
 | GetToolTip | Overloaded.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUrl | Returns the url for the application
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QuickHelpDestination | Gets the quick help destination for the toolbar item
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Constants Class
OfficeClip.BusinessLayer.Framework Namespace


AllApplications Method

[image]

OfficeClip API Documentation
Constants..::.AllApplications Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of all the applications

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static ArrayList AllApplications()
Visual Basic (Declaration)
Public Shared Function AllApplications As ArrayList
Visual C++
public:
static ArrayList^ AllApplications()

Return Value

See Also

Constants Class
OfficeClip.BusinessLayer.Framework Namespace


GetDiskApplicationPath Method

[image]

OfficeClip API Documentation
Constants..::.GetDiskApplicationPath Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the disk path of the application

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetDiskApplicationPath(
    int userId,
    Constants..::.ApplicationType aType
)
Visual Basic (Declaration)
Public Shared Function GetDiskApplicationPath ( _
    userId As Integer, _
    aType As Constants..::.ApplicationType _
) As String
Visual C++
public:
static String^ GetDiskApplicationPath(
    int userId,
    Constants..::.ApplicationType aType
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
aType
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
The application type

Return Value

The application path

See Also

Constants Class
OfficeClip.BusinessLayer.Framework Namespace


GetHelpUrl Method

[image] [image]

OfficeClip API Documentation
Constants..::.GetHelpUrl Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetHelpUrl(String) |
GetHelpUrl(Constants..::.ToolbarType, Constants..::.ApplicationType, String) | Gets the help url. When clicked it will take the user to the appropriate help page

See Also

Constants Class
Constants Members
OfficeClip.BusinessLayer.Framework Namespace


GetHelpUrl Method (String)

[image]

OfficeClip API Documentation
Constants..::.GetHelpUrl Method (String)
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetHelpUrl(
    string helpPage
)
Visual Basic (Declaration)
Public Shared Function GetHelpUrl ( _
    helpPage As String _
) As String
Visual C++
public:
static String^ GetHelpUrl(
    String^ helpPage
)

Parameters

helpPage
Type: System..::.String

See Also

Constants Class
GetHelpUrl Overload
OfficeClip.BusinessLayer.Framework Namespace


GetHelpUrl Method (Constants.ToolbarType, Constants.ApplicationType, String)

[image]

OfficeClip API Documentation
Constants..::.GetHelpUrl Method (Constants..::.ToolbarType, Constants..::.ApplicationType, String)
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the help url. When clicked it will take the user to the appropriate help page

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetHelpUrl(
    Constants..::.ToolbarType tt,
    Constants..::.ApplicationType at,
    string helpPage
)
Visual Basic (Declaration)
Public Shared Function GetHelpUrl ( _
    tt As Constants..::.ToolbarType, _
    at As Constants..::.ApplicationType, _
    helpPage As String _
) As String
Visual C++
public:
static String^ GetHelpUrl(
    Constants..::.ToolbarType tt,
    Constants..::.ApplicationType at,
    String^ helpPage
)

Parameters

tt
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ToolbarType
The toolbar type
at
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
The application type
helpPage
Type: System..::.String
The help page

Return Value

The help page url

See Also

Constants Class
GetHelpUrl Overload
OfficeClip.BusinessLayer.Framework Namespace


GetName Method

[image] [image]

OfficeClip API Documentation
Constants..::.GetName Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetName(Constants..::.ApplicationType) | Get the name of the application (for the left bar)
GetName(Constants..::.MenubarType) | Gets the name of the menubar item
GetName(Constants..::.ToolbarType) | Gets the name of the toolbar item

See Also

Constants Class
Constants Members
OfficeClip.BusinessLayer.Framework Namespace


GetName Method (Constants.ApplicationType)

[image]

OfficeClip API Documentation
Constants..::.GetName Method (Constants..::.ApplicationType)
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Get the name of the application (for the left bar)

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetName(
    Constants..::.ApplicationType at
)
Visual Basic (Declaration)
Public Shared Function GetName ( _
    at As Constants..::.ApplicationType _
) As String
Visual C++
public:
static String^ GetName(
    Constants..::.ApplicationType at
)

Parameters

at
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
The application type

Return Value

The name of the application

See Also

Constants Class
GetName Overload
OfficeClip.BusinessLayer.Framework Namespace


GetName Method (Constants.MenubarType)

[image]

OfficeClip API Documentation
Constants..::.GetName Method (Constants..::.MenubarType)
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the name of the menubar item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetName(
    Constants..::.MenubarType mt
)
Visual Basic (Declaration)
Public Shared Function GetName ( _
    mt As Constants..::.MenubarType _
) As String
Visual C++
public:
static String^ GetName(
    Constants..::.MenubarType mt
)

Parameters

mt
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.MenubarType

Return Value

See Also

Constants Class
GetName Overload
OfficeClip.BusinessLayer.Framework Namespace


GetName Method (Constants.ToolbarType)

[image]

OfficeClip API Documentation
Constants..::.GetName Method (Constants..::.ToolbarType)
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the name of the toolbar item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetName(
    Constants..::.ToolbarType tt
)
Visual Basic (Declaration)
Public Shared Function GetName ( _
    tt As Constants..::.ToolbarType _
) As String
Visual C++
public:
static String^ GetName(
    Constants..::.ToolbarType tt
)

Parameters

tt
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ToolbarType
The toolbar item

Return Value

The name of the toolbar item

See Also

Constants Class
GetName Overload
OfficeClip.BusinessLayer.Framework Namespace


GetToolTip Method

[image] [image]

OfficeClip API Documentation
Constants..::.GetToolTip Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetToolTip(Constants..::.ApplicationType) | Gets the tooltip for the applications (for the left bar)
GetToolTip(Constants..::.ToolbarType) | Gets the tooltip for the toolbar item

See Also

Constants Class
Constants Members
OfficeClip.BusinessLayer.Framework Namespace


GetToolTip Method (Constants.ApplicationType)

[image]

OfficeClip API Documentation
Constants..::.GetToolTip Method (Constants..::.ApplicationType)
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tooltip for the applications (for the left bar)

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetToolTip(
    Constants..::.ApplicationType at
)
Visual Basic (Declaration)
Public Shared Function GetToolTip ( _
    at As Constants..::.ApplicationType _
) As String
Visual C++
public:
static String^ GetToolTip(
    Constants..::.ApplicationType at
)

Parameters

at
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
The application type

Return Value

The tooltip for the application items

See Also

Constants Class
GetToolTip Overload
OfficeClip.BusinessLayer.Framework Namespace


GetToolTip Method (Constants.ToolbarType)

[image]

OfficeClip API Documentation
Constants..::.GetToolTip Method (Constants..::.ToolbarType)
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tooltip for the toolbar item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetToolTip(
    Constants..::.ToolbarType tt
)
Visual Basic (Declaration)
Public Shared Function GetToolTip ( _
    tt As Constants..::.ToolbarType _
) As String
Visual C++
public:
static String^ GetToolTip(
    Constants..::.ToolbarType tt
)

Parameters

tt
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ToolbarType
The toolbar type

Return Value

The tooltip for toolbar item

See Also

Constants Class
GetToolTip Overload
OfficeClip.BusinessLayer.Framework Namespace


GetUrl Method

[image]

OfficeClip API Documentation
Constants..::.GetUrl Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the url for the application

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetUrl(
    int applicationId
)
Visual Basic (Declaration)
Public Shared Function GetUrl ( _
    applicationId As Integer _
) As String
Visual C++
public:
static String^ GetUrl(
    int applicationId
)

Parameters

applicationId
Type: System..::.Int32

Return Value

See Also

Constants Class
OfficeClip.BusinessLayer.Framework Namespace


QuickHelpDestination Method

[image]

OfficeClip API Documentation
Constants..::.QuickHelpDestination Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the quick help destination for the toolbar item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string QuickHelpDestination(
    Constants..::.ToolbarType tt
)
Visual Basic (Declaration)
Public Shared Function QuickHelpDestination ( _
    tt As Constants..::.ToolbarType _
) As String
Visual C++
public:
static String^ QuickHelpDestination(
    Constants..::.ToolbarType tt
)

Parameters

tt
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ToolbarType
The toolbar type

Return Value

The destination for the quick help

See Also

Constants Class
OfficeClip.BusinessLayer.Framework Namespace


Constants Properties

[image] [image]

OfficeClip API Documentation
Constants Properties
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The Constants type exposes the following properties.

Properties

Name | Description
ApplicationAccess | Gets the application access

See Also

Constants Class
OfficeClip.BusinessLayer.Framework Namespace


ApplicationAccess Property

[image]

OfficeClip API Documentation
Constants..::.ApplicationAccess Property
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the application access

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static ApplicationAccess ApplicationAccess { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ApplicationAccess As ApplicationAccess
Visual C++
public:
static property ApplicationAccess^ ApplicationAccess {
    ApplicationAccess^ get ();
}

See Also

Constants Class
OfficeClip.BusinessLayer.Framework Namespace


Constants.ApplicationType Enumeration

[image]

OfficeClip API Documentation
Constants..::.ApplicationType Enumeration
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for the applications

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ApplicationType
Visual Basic (Declaration)
Public Enumeration ApplicationType
Visual C++
public enum class ApplicationType

Members

Member name | Description
None | No application
Calendar | Calendar application
CustomMessage | Custom message application (depricated)
GroupBookmark | group bookmark application
Tracker | Issue tracker application
ExpenseReport | Expense Report application
Timesheet | Timesheet application
BulletinBoard | Bulletin board application
DocumentManagement | Document Management application
Member | Member application
HomePage | Home Page application
Alerts | Alerts application
Polls | Polls application
Photos | Photos application
Announcements | Announcements application
Email | Email application
Tasks | Tasks application
Notes | Notes application
ContactManager | ContactManager application
Extranet | Extranet application
AccountManager | Account Manager application
Newsfeed | Newsfeed application
AddressBook | Address Book application
Campaigns | Campaigns application
Opportunities | Opportunities application
Projects | Projects application
PunchClock | The punch clock
Setup | The setup application... this is not a real application in the database but is kept here for UI reasons

See Also

OfficeClip.BusinessLayer.Framework Namespace


Constants.MenubarType Enumeration

[image]

OfficeClip API Documentation
Constants..::.MenubarType Enumeration
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Menubar item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum MenubarType
Visual Basic (Declaration)
Public Enumeration MenubarType
Visual C++
public enum class MenubarType

Members

Member name | Description
None | None
File | File menubar item
Tools | Tools menubar item
Help | Help menubar item
LogOff | Logoff menubar item
HelpAboutOfficeClip | Help About OfficeClip menubar item
HelpApplications | Help application menubar item
HelpAlert | Help alert menubar item
HelpOfficePortal | Help Office Portal menubar item
HelpDesktop | Help Desktop menubar item
HelpContactManager | Help Contact Manager menubar item
HelpIssueTracker | Help Issue Tracker menubar item
HelpTimeExpenses | Help Time Expenses menubar item
HelpProjects | Help Projects menubar item
HelpSetup | Help Setup menubar item
HelpQuickStart | Help Quick Start menubar item
HelpQuickStartOfficePortal | Help Quick Start Office Portal menubar item
HelpQuickStartDesktop | Help Quick Start Desktop menubar item
HelpQuickStartContactManager | Help Quick Start Contact Manager menubar item
HelpQuickStartIssueTracker | Help Quick Start Issue Tracker
HelpQuickStartTimeExpenses | Help Quick Start Time Expenses
HelpQuickStartProjects | Help Quick Start Projects
EnterBugEnhancement | Enter Bug Enhancements
HelpQuickStartSetup | Help Quick Start Setup
HelpQuickStartExtranet | Extranet Quick Start Setup
HelpExtranet | Extranet Help

See Also

OfficeClip.BusinessLayer.Framework Namespace


Constants.ToolbarType Enumeration

[image]

OfficeClip API Documentation
Constants..::.ToolbarType Enumeration
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The type of the toolbar

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ToolbarType
Visual Basic (Declaration)
Public Enumeration ToolbarType
Visual C++
public enum class ToolbarType

Members

Member name | Description
Separator | Toolbar vertical separator
None | None
Alert | Alert Toolbar item
Portal | Office Portal toolbar item
Desktop | Desktop toolbar item
CRM | CRM toolbar item
Tracker | Tracker Toolbar item
TE | Time and Expenses toolbar item
Setup | Setup toolbar item
Help | Help toolbar item
Logoff | Logoff toolbar item
Projects | Projects toolbar item
Extranet | The Extranet Toolbar Item

See Also

OfficeClip.BusinessLayer.Framework Namespace


GenericReport Class

[image]

OfficeClip API Documentation
GenericReport Class
Members See Also

[This is preliminary documentation and is subject to change.]

The generic report class

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class GenericReport
Visual Basic (Declaration)
Public Class GenericReport
Visual C++
public ref class GenericReport

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.GenericReport

See Also

GenericReport Members
OfficeClip.BusinessLayer.Framework Namespace


GenericReport Members

[image] [image]

OfficeClip API Documentation
GenericReport Members
GenericReport Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The GenericReport type exposes the following members.

Constructors

 | Name | Description
Public method | GenericReport |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldHeading | Gets the heading of the particular field
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFieldHeading | Sets the field heading
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | _marginRatio | The default page margin ratio
Public field | TotalPagePixel | Total number of pixel on the page

Properties

 | Name | Description
Public property | FieldHeading | The array of field headings
Public property | LastActiveField | The last active field
Public property | MarginRatio | The margin ratio of the page
Public property | Position | The position of the items on the page
Public property | ReportCriteria | The report criteria, this is creating some problems in the ODT so it is supressed.
Public property | ReportDs | The report dataset
Public property | SortByFormula | Sort by formula array
Public property | TotalFormula | The total formulas
Public property | TotalLeft | Total left position
Public property | TotalWidth | The total widths

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


GenericReport Constructor

[image]

OfficeClip API Documentation
GenericReport Constructor
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GenericReport()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GenericReport()

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


GenericReport Fields

[image] [image]

OfficeClip API Documentation
GenericReport Fields
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The GenericReport type exposes the following fields.

Fields

 | Name | Description
Public field | _marginRatio | The default page margin ratio
Public field | TotalPagePixel | Total number of pixel on the page

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


_marginRatio Field

[image]

OfficeClip API Documentation
GenericReport..::._marginRatio Field
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The default page margin ratio

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double _marginRatio
Visual Basic (Declaration)
Public _marginRatio As Double
Visual C++
public:
double _marginRatio

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


TotalPagePixel Field

[image]

OfficeClip API Documentation
GenericReport..::.TotalPagePixel Field
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

Total number of pixel on the page

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public readonly int TotalPagePixel
Visual Basic (Declaration)
Public ReadOnly TotalPagePixel As Integer
Visual C++
public:
initonly int TotalPagePixel

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


GenericReport Methods

[image] [image]

OfficeClip API Documentation
GenericReport Methods
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The GenericReport type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldHeading | Gets the heading of the particular field
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetFieldHeading | Sets the field heading
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


GetFieldHeading Method

[image]

OfficeClip API Documentation
GenericReport..::.GetFieldHeading Method
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

Gets the heading of the particular field

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetFieldHeading(
    int i
)
Visual Basic (Declaration)
Public Function GetFieldHeading ( _
    i As Integer _
) As String
Visual C++
public:
String^ GetFieldHeading(
    int i
)

Parameters

i
Type: System..::.Int32
The field index

Return Value

The heading

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


SetFieldHeading Method

[image]

OfficeClip API Documentation
GenericReport..::.SetFieldHeading Method
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

Sets the field heading

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void SetFieldHeading(
    int i,
    string str
)
Visual Basic (Declaration)
Public Sub SetFieldHeading ( _
    i As Integer, _
    str As String _
)
Visual C++
public:
void SetFieldHeading(
    int i,
    String^ str
)

Parameters

i
Type: System..::.Int32
The field index
str
Type: System..::.String
The heading

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


GenericReport Properties

[image] [image]

OfficeClip API Documentation
GenericReport Properties
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The GenericReport type exposes the following properties.

Properties

 | Name | Description
Public property | FieldHeading | The array of field headings
Public property | LastActiveField | The last active field
Public property | MarginRatio | The margin ratio of the page
Public property | Position | The position of the items on the page
Public property | ReportCriteria | The report criteria, this is creating some problems in the ODT so it is supressed.
Public property | ReportDs | The report dataset
Public property | SortByFormula | Sort by formula array
Public property | TotalFormula | The total formulas
Public property | TotalLeft | Total left position
Public property | TotalWidth | The total widths

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


FieldHeading Property

[image]

OfficeClip API Documentation
GenericReport..::.FieldHeading Property
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The array of field headings

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string[] FieldHeading { get; set; }
Visual Basic (Declaration)
Public Property FieldHeading As String()
Visual C++
public:
property array<String^>^ FieldHeading {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


LastActiveField Property

[image]

OfficeClip API Documentation
GenericReport..::.LastActiveField Property
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The last active field

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LastActiveField { get; set; }
Visual Basic (Declaration)
Public Property LastActiveField As Integer
Visual C++
public:
property int LastActiveField {
    int get ();
    void set (int value);
}

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


MarginRatio Property

[image]

OfficeClip API Documentation
GenericReport..::.MarginRatio Property
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The margin ratio of the page

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double MarginRatio { get; set; }
Visual Basic (Declaration)
Public Property MarginRatio As Double
Visual C++
public:
property double MarginRatio {
    double get ();
    void set (double value);
}

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


Position Property

[image]

OfficeClip API Documentation
GenericReport..::.Position Property
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The position of the items on the page

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Position { get; set; }
Visual Basic (Declaration)
Public Property Position As ArrayList
Visual C++
public:
property ArrayList^ Position {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


ReportCriteria Property

[image]

OfficeClip API Documentation
GenericReport..::.ReportCriteria Property
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The report criteria, this is creating some problems in the ODT so it is supressed.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Criteria ReportCriteria { get; set; }
Visual Basic (Declaration)
Public Property ReportCriteria As Criteria
Visual C++
public:
property Criteria^ ReportCriteria {
    Criteria^ get ();
    void set (Criteria^ value);
}

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


ReportDs Property

[image]

OfficeClip API Documentation
GenericReport..::.ReportDs Property
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The report dataset

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet ReportDs { get; set; }
Visual Basic (Declaration)
Public Property ReportDs As DataSet
Visual C++
public:
property DataSet^ ReportDs {
    DataSet^ get ();
    void set (DataSet^ value);
}

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


SortByFormula Property

[image]

OfficeClip API Documentation
GenericReport..::.SortByFormula Property
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

Sort by formula array

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string[] SortByFormula { get; set; }
Visual Basic (Declaration)
Public Property SortByFormula As String()
Visual C++
public:
property array<String^>^ SortByFormula {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


TotalFormula Property

[image]

OfficeClip API Documentation
GenericReport..::.TotalFormula Property
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The total formulas

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string[] TotalFormula { get; set; }
Visual Basic (Declaration)
Public Property TotalFormula As String()
Visual C++
public:
property array<String^>^ TotalFormula {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


TotalLeft Property

[image]

OfficeClip API Documentation
GenericReport..::.TotalLeft Property
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

Total left position

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int[] TotalLeft { get; set; }
Visual Basic (Declaration)
Public Property TotalLeft As Integer()
Visual C++
public:
property array<int>^ TotalLeft {
    array<int>^ get ();
    void set (array<int>^ value);
}

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


TotalWidth Property

[image]

OfficeClip API Documentation
GenericReport..::.TotalWidth Property
GenericReport Class See Also

[This is preliminary documentation and is subject to change.]

The total widths

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int[] TotalWidth { get; set; }
Visual Basic (Declaration)
Public Property TotalWidth As Integer()
Visual C++
public:
property array<int>^ TotalWidth {
    array<int>^ get ();
    void set (array<int>^ value);
}

See Also

GenericReport Class
OfficeClip.BusinessLayer.Framework Namespace


IOCDateTimeFormatInfo Interface

[image]

OfficeClip API Documentation
IOCDateTimeFormatInfo Interface
Members See Also

[This is preliminary documentation and is subject to change.]

An interface for the OfficeClip Date and Time Fromat Information.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public interface IOCDateTimeFormatInfo
Visual Basic (Declaration)
Public Interface IOCDateTimeFormatInfo
Visual C++
public interface class IOCDateTimeFormatInfo

See Also

IOCDateTimeFormatInfo Members
OfficeClip.BusinessLayer.Framework Namespace


IOCDateTimeFormatInfo Members

[image] [image]

OfficeClip API Documentation
IOCDateTimeFormatInfo Members
IOCDateTimeFormatInfo Interface Properties See Also

[This is preliminary documentation and is subject to change.]

The IOCDateTimeFormatInfo type exposes the following members.

Properties

 | Name | Description
Public property | DateFormatStr | The date format string.
Public property | DateTimeFormat | The Date Time Format.
Public property | TimeFormatStr | The time format string.

See Also

IOCDateTimeFormatInfo Interface
OfficeClip.BusinessLayer.Framework Namespace


IOCDateTimeFormatInfo Properties

[image] [image]

OfficeClip API Documentation
IOCDateTimeFormatInfo Properties
IOCDateTimeFormatInfo Interface See Also

[This is preliminary documentation and is subject to change.]

The IOCDateTimeFormatInfo type exposes the following properties.

Properties

 | Name | Description
Public property | DateFormatStr | The date format string.
Public property | DateTimeFormat | The Date Time Format.
Public property | TimeFormatStr | The time format string.

See Also

IOCDateTimeFormatInfo Interface
OfficeClip.BusinessLayer.Framework Namespace


DateFormatStr Property

[image]

OfficeClip API Documentation
IOCDateTimeFormatInfo..::.DateFormatStr Property
IOCDateTimeFormatInfo Interface See Also

[This is preliminary documentation and is subject to change.]

The date format string.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
string DateFormatStr { set; }
Visual Basic (Declaration)
WriteOnly Property DateFormatStr As String
Visual C++
property String^ DateFormatStr {
    void set (String^ value);
}

See Also

IOCDateTimeFormatInfo Interface
OfficeClip.BusinessLayer.Framework Namespace


DateTimeFormat Property

[image]

OfficeClip API Documentation
IOCDateTimeFormatInfo..::.DateTimeFormat Property
IOCDateTimeFormatInfo Interface See Also

[This is preliminary documentation and is subject to change.]

The Date Time Format.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
DateTimeFormatInfo DateTimeFormat { set; }
Visual Basic (Declaration)
WriteOnly Property DateTimeFormat As DateTimeFormatInfo
Visual C++
property DateTimeFormatInfo^ DateTimeFormat {
    void set (DateTimeFormatInfo^ value);
}

See Also

IOCDateTimeFormatInfo Interface
OfficeClip.BusinessLayer.Framework Namespace


TimeFormatStr Property

[image]

OfficeClip API Documentation
IOCDateTimeFormatInfo..::.TimeFormatStr Property
IOCDateTimeFormatInfo Interface See Also

[This is preliminary documentation and is subject to change.]

The time format string.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
string TimeFormatStr { set; }
Visual Basic (Declaration)
WriteOnly Property TimeFormatStr As String
Visual C++
property String^ TimeFormatStr {
    void set (String^ value);
}

See Also

IOCDateTimeFormatInfo Interface
OfficeClip.BusinessLayer.Framework Namespace


LeftbarItem Class

[image]

OfficeClip API Documentation
LeftbarItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

class to represent he left bar item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class LeftbarItem
Visual Basic (Declaration)
Public Class LeftbarItem
Visual C++
public ref class LeftbarItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.LeftbarItem

See Also

LeftbarItem Members
OfficeClip.BusinessLayer.Framework Namespace


LeftbarItem Members

[image] [image]

OfficeClip API Documentation
LeftbarItem Members
LeftbarItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The LeftbarItem type exposes the following members.

Constructors

 | Name | Description
Public method | LeftbarItem | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | true if the leftbar item is visible
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The id of the leftbar item
Public property | ImageUrl | The image url
Public property | IsSelected | True if the left bar item is selected
Public property | Name | The name of the app domain item
Public property | SkinID | The skin id
Public property | ToolTip | The tooltip
Public property | Url | The url

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


LeftbarItem Constructor

[image]

OfficeClip API Documentation
LeftbarItem Constructor
LeftbarItem Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public LeftbarItem(
    int id,
    string name,
    string skinID,
    string url,
    string imageUrl,
    string toolTip
)
Visual Basic (Declaration)
Public Sub New ( _
    id As Integer, _
    name As String, _
    skinID As String, _
    url As String, _
    imageUrl As String, _
    toolTip As String _
)
Visual C++
public:
LeftbarItem(
    int id,
    String^ name,
    String^ skinID,
    String^ url,
    String^ imageUrl,
    String^ toolTip
)

Parameters

id
Type: System..::.Int32
name
Type: System..::.String
skinID
Type: System..::.String
url
Type: System..::.String
imageUrl
Type: System..::.String
toolTip
Type: System..::.String

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


LeftbarItem Methods

[image] [image]

OfficeClip API Documentation
LeftbarItem Methods
LeftbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The LeftbarItem type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | true if the leftbar item is visible
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


IsVisible Method

[image]

OfficeClip API Documentation
LeftbarItem..::.IsVisible Method
LeftbarItem Class See Also

[This is preliminary documentation and is subject to change.]

true if the leftbar item is visible

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsVisible(
    byte[] filter
)
Visual Basic (Declaration)
Public Function IsVisible ( _
    filter As Byte() _
) As Boolean
Visual C++
public:
bool IsVisible(
    array<unsigned char>^ filter
)

Parameters

filter
Type: array<System..::.Byte>[]()[]
list of allowed applications

Return Value

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


LeftbarItem Properties

[image] [image]

OfficeClip API Documentation
LeftbarItem Properties
LeftbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The LeftbarItem type exposes the following properties.

Properties

 | Name | Description
Public property | Id | The id of the leftbar item
Public property | ImageUrl | The image url
Public property | IsSelected | True if the left bar item is selected
Public property | Name | The name of the app domain item
Public property | SkinID | The skin id
Public property | ToolTip | The tooltip
Public property | Url | The url

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


Id Property

[image]

OfficeClip API Documentation
LeftbarItem..::.Id Property
LeftbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The id of the leftbar item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Id { get; set; }
Visual Basic (Declaration)
Public Property Id As Integer
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


ImageUrl Property

[image]

OfficeClip API Documentation
LeftbarItem..::.ImageUrl Property
LeftbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The image url

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ImageUrl { get; set; }
Visual Basic (Declaration)
Public Property ImageUrl As String
Visual C++
public:
property String^ ImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


IsSelected Property

[image]

OfficeClip API Documentation
LeftbarItem..::.IsSelected Property
LeftbarItem Class See Also

[This is preliminary documentation and is subject to change.]

True if the left bar item is selected

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


Name Property

[image]

OfficeClip API Documentation
LeftbarItem..::.Name Property
LeftbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The name of the app domain item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


SkinID Property

[image]

OfficeClip API Documentation
LeftbarItem..::.SkinID Property
LeftbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The skin id

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SkinID { get; set; }
Visual Basic (Declaration)
Public Property SkinID As String
Visual C++
public:
property String^ SkinID {
    String^ get ();
    void set (String^ value);
}

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


ToolTip Property

[image]

OfficeClip API Documentation
LeftbarItem..::.ToolTip Property
LeftbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The tooltip

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


Url Property

[image]

OfficeClip API Documentation
LeftbarItem..::.Url Property
LeftbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The url

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Url { get; set; }
Visual Basic (Declaration)
Public Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

See Also

LeftbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


LoginSetupInfo Class

[image]

OfficeClip API Documentation
LoginSetupInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

The login setup information class

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class LoginSetupInfo
Visual Basic (Declaration)
Public Class LoginSetupInfo
Visual C++
public ref class LoginSetupInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.LoginSetupInfo

See Also

LoginSetupInfo Members
OfficeClip.BusinessLayer.Framework Namespace


LoginSetupInfo Members

[image] [image]

OfficeClip API Documentation
LoginSetupInfo Members
LoginSetupInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The LoginSetupInfo type exposes the following members.

Constructors

 | Name | Description
Public method | LoginSetupInfo |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FooterHtml | The footer html
Public property | HeaderHtml | The header html
Public property | Message | The html message that appears on he login page
Public property | PoweredByHtml | The url for the powered by text
Public property | PoweredByText | The powered by text

See Also

LoginSetupInfo Class
OfficeClip.BusinessLayer.Framework Namespace


LoginSetupInfo Constructor

[image]

OfficeClip API Documentation
LoginSetupInfo Constructor
LoginSetupInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public LoginSetupInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoginSetupInfo()

See Also

LoginSetupInfo Class
OfficeClip.BusinessLayer.Framework Namespace


LoginSetupInfo Properties

[image] [image]

OfficeClip API Documentation
LoginSetupInfo Properties
LoginSetupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The LoginSetupInfo type exposes the following properties.

Properties

 | Name | Description
Public property | FooterHtml | The footer html
Public property | HeaderHtml | The header html
Public property | Message | The html message that appears on he login page
Public property | PoweredByHtml | The url for the powered by text
Public property | PoweredByText | The powered by text

See Also

LoginSetupInfo Class
OfficeClip.BusinessLayer.Framework Namespace


FooterHtml Property

[image]

OfficeClip API Documentation
LoginSetupInfo..::.FooterHtml Property
LoginSetupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The footer html

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FooterHtml { get; set; }
Visual Basic (Declaration)
Public Property FooterHtml As String
Visual C++
public:
property String^ FooterHtml {
    String^ get ();
    void set (String^ value);
}

See Also

LoginSetupInfo Class
OfficeClip.BusinessLayer.Framework Namespace


HeaderHtml Property

[image]

OfficeClip API Documentation
LoginSetupInfo..::.HeaderHtml Property
LoginSetupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The header html

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string HeaderHtml { get; set; }
Visual Basic (Declaration)
Public Property HeaderHtml As String
Visual C++
public:
property String^ HeaderHtml {
    String^ get ();
    void set (String^ value);
}

See Also

LoginSetupInfo Class
OfficeClip.BusinessLayer.Framework Namespace


Message Property

[image]

OfficeClip API Documentation
LoginSetupInfo..::.Message Property
LoginSetupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The html message that appears on he login page

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Message { get; set; }
Visual Basic (Declaration)
Public Property Message As String
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

See Also

LoginSetupInfo Class
OfficeClip.BusinessLayer.Framework Namespace


PoweredByHtml Property

[image]

OfficeClip API Documentation
LoginSetupInfo..::.PoweredByHtml Property
LoginSetupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The url for the powered by text

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PoweredByHtml { get; set; }
Visual Basic (Declaration)
Public Property PoweredByHtml As String
Visual C++
public:
property String^ PoweredByHtml {
    String^ get ();
    void set (String^ value);
}

See Also

LoginSetupInfo Class
OfficeClip.BusinessLayer.Framework Namespace


PoweredByText Property

[image]

OfficeClip API Documentation
LoginSetupInfo..::.PoweredByText Property
LoginSetupInfo Class See Also

[This is preliminary documentation and is subject to change.]

The powered by text

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PoweredByText { get; set; }
Visual Basic (Declaration)
Public Property PoweredByText As String
Visual C++
public:
property String^ PoweredByText {
    String^ get ();
    void set (String^ value);
}

See Also

LoginSetupInfo Class
OfficeClip.BusinessLayer.Framework Namespace


MenuItem Class

[image]

OfficeClip API Documentation
MenuItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class that describes the menu item in OfficeClip

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MenuItem
Visual Basic (Declaration)
Public Class MenuItem
Visual C++
public ref class MenuItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.MenuItem

See Also

MenuItem Members
OfficeClip.BusinessLayer.Framework Namespace


MenuItem Members

[image] [image]

OfficeClip API Documentation
MenuItem Members
MenuItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MenuItem type exposes the following members.

Constructors

 | Name | Description
Public method | MenuItem | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines if the menu item is visible
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AppId | The application id
Public property | Children | The list of children for menu items
Public property | Id | The id of the menu item
Public property | ImageUrl | The url for the image
Public property | Name | The menu item name
Public property | NavigateUrl | The navigate url for the menu item
Public property | Target | The target of the menu item
Public property | ToolTip | The tooltip of the menu item
Public property | UniqueKey | The unique key for the menu item

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


MenuItem Constructor

[image]

OfficeClip API Documentation
MenuItem Constructor
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuItem(
    int id,
    int appId,
    string name,
    string navigateUrl,
    string target,
    string toolTip,
    string imageUrl,
    List<MenuItem> children
)
Visual Basic (Declaration)
Public Sub New ( _
    id As Integer, _
    appId As Integer, _
    name As String, _
    navigateUrl As String, _
    target As String, _
    toolTip As String, _
    imageUrl As String, _
    children As List(Of MenuItem) _
)
Visual C++
public:
MenuItem(
    int id,
    int appId,
    String^ name,
    String^ navigateUrl,
    String^ target,
    String^ toolTip,
    String^ imageUrl,
    List<MenuItem^>^ children
)

Parameters

id
Type: System..::.Int32
appId
Type: System..::.Int32
name
Type: System..::.String
navigateUrl
Type: System..::.String
target
Type: System..::.String
toolTip
Type: System..::.String
imageUrl
Type: System..::.String
children
Type: System.Collections.Generic..::.List<(Of <( MenuItem >)>)

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


MenuItem Methods

[image] [image]

OfficeClip API Documentation
MenuItem Methods
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

The MenuItem type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsVisible | Determines if the menu item is visible
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


IsVisible Method

[image]

OfficeClip API Documentation
MenuItem..::.IsVisible Method
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the menu item is visible

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsVisible(
    byte[] filter
)
Visual Basic (Declaration)
Public Function IsVisible ( _
    filter As Byte() _
) As Boolean
Visual C++
public:
bool IsVisible(
    array<unsigned char>^ filter
)

Parameters

filter
Type: array<System..::.Byte>[]()[]
The array of applications

Return Value

true if the menu item is visible, false otherwise

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


MenuItem Properties

[image] [image]

OfficeClip API Documentation
MenuItem Properties
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

The MenuItem type exposes the following properties.

Properties

 | Name | Description
Public property | AppId | The application id
Public property | Children | The list of children for menu items
Public property | Id | The id of the menu item
Public property | ImageUrl | The url for the image
Public property | Name | The menu item name
Public property | NavigateUrl | The navigate url for the menu item
Public property | Target | The target of the menu item
Public property | ToolTip | The tooltip of the menu item
Public property | UniqueKey | The unique key for the menu item

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


AppId Property

[image]

OfficeClip API Documentation
MenuItem..::.AppId Property
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

The application id

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AppId { get; set; }
Visual Basic (Declaration)
Public Property AppId As Integer
Visual C++
public:
property int AppId {
    int get ();
    void set (int value);
}

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


Children Property

[image]

OfficeClip API Documentation
MenuItem..::.Children Property
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

The list of children for menu items

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<MenuItem> Children { get; set; }
Visual Basic (Declaration)
Public Property Children As List(Of MenuItem)
Visual C++
public:
property List<MenuItem^>^ Children {
    List<MenuItem^>^ get ();
    void set (List<MenuItem^>^ value);
}

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


Id Property

[image]

OfficeClip API Documentation
MenuItem..::.Id Property
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

The id of the menu item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Id { get; set; }
Visual Basic (Declaration)
Public Property Id As Integer
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


ImageUrl Property

[image]

OfficeClip API Documentation
MenuItem..::.ImageUrl Property
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

The url for the image

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ImageUrl { get; set; }
Visual Basic (Declaration)
Public Property ImageUrl As String
Visual C++
public:
property String^ ImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


Name Property

[image]

OfficeClip API Documentation
MenuItem..::.Name Property
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

The menu item name

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


NavigateUrl Property

[image]

OfficeClip API Documentation
MenuItem..::.NavigateUrl Property
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

The navigate url for the menu item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string NavigateUrl { get; set; }
Visual Basic (Declaration)
Public Property NavigateUrl As String
Visual C++
public:
property String^ NavigateUrl {
    String^ get ();
    void set (String^ value);
}

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


Target Property

[image]

OfficeClip API Documentation
MenuItem..::.Target Property
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

The target of the menu item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Target { get; set; }
Visual Basic (Declaration)
Public Property Target As String
Visual C++
public:
property String^ Target {
    String^ get ();
    void set (String^ value);
}

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


ToolTip Property

[image]

OfficeClip API Documentation
MenuItem..::.ToolTip Property
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

The tooltip of the menu item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


UniqueKey Property

[image]

OfficeClip API Documentation
MenuItem..::.UniqueKey Property
MenuItem Class See Also

[This is preliminary documentation and is subject to change.]

The unique key for the menu item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UniqueKey { get; }
Visual Basic (Declaration)
Public ReadOnly Property UniqueKey As String
Visual C++
public:
property String^ UniqueKey {
    String^ get ();
}

See Also

MenuItem Class
OfficeClip.BusinessLayer.Framework Namespace


PropertyInfo Class

[image]

OfficeClip API Documentation
PropertyInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the property information. The object created from this class can be serialized.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class PropertyInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PropertyInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class PropertyInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.PropertyInfo

See Also

PropertyInfo Members
OfficeClip.BusinessLayer.Framework Namespace


PropertyInfo Members

[image] [image]

OfficeClip API Documentation
PropertyInfo Members
PropertyInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PropertyInfo type exposes the following members.

Constructors

 | Name | Description
Public method | PropertyInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | The property name.
Public property | Value | The property value.

See Also

PropertyInfo Class
OfficeClip.BusinessLayer.Framework Namespace


PropertyInfo Constructor

[image] [image]

OfficeClip API Documentation
PropertyInfo Constructor
PropertyInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PropertyInfo()()() | The default constructor.
Public method | PropertyInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.
Public method | PropertyInfo(String, String) | The construction using the name value pair.

See Also

PropertyInfo Class
PropertyInfo Members
OfficeClip.BusinessLayer.Framework Namespace


PropertyInfo Constructor

[image]

OfficeClip API Documentation
PropertyInfo Constructor
PropertyInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PropertyInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PropertyInfo()

See Also

PropertyInfo Class
PropertyInfo Overload
OfficeClip.BusinessLayer.Framework Namespace


PropertyInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
PropertyInfo Constructor (SerializationInfo, StreamingContext)
PropertyInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PropertyInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
PropertyInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

PropertyInfo Class
PropertyInfo Overload
OfficeClip.BusinessLayer.Framework Namespace


PropertyInfo Constructor (String, String)

[image]

OfficeClip API Documentation
PropertyInfo Constructor (String, String)
PropertyInfo Class See Also

[This is preliminary documentation and is subject to change.]

The construction using the name value pair.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PropertyInfo(
    string nm,
    string vl
)
Visual Basic (Declaration)
Public Sub New ( _
    nm As String, _
    vl As String _
)
Visual C++
public:
PropertyInfo(
    String^ nm,
    String^ vl
)

Parameters

nm
Type: System..::.String
vl
Type: System..::.String

See Also

PropertyInfo Class
PropertyInfo Overload
OfficeClip.BusinessLayer.Framework Namespace


PropertyInfo Methods

[image] [image]

OfficeClip API Documentation
PropertyInfo Methods
PropertyInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PropertyInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyInfo Class
OfficeClip.BusinessLayer.Framework Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
PropertyInfo..::.GetObjectData Method
PropertyInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

PropertyInfo Class
OfficeClip.BusinessLayer.Framework Namespace


PropertyInfo Properties

[image] [image]

OfficeClip API Documentation
PropertyInfo Properties
PropertyInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PropertyInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Name | The property name.
Public property | Value | The property value.

See Also

PropertyInfo Class
OfficeClip.BusinessLayer.Framework Namespace


Name Property

[image]

OfficeClip API Documentation
PropertyInfo..::.Name Property
PropertyInfo Class See Also

[This is preliminary documentation and is subject to change.]

The property name.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

PropertyInfo Class
OfficeClip.BusinessLayer.Framework Namespace


Value Property

[image]

OfficeClip API Documentation
PropertyInfo..::.Value Property
PropertyInfo Class See Also

[This is preliminary documentation and is subject to change.]

The property value.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

PropertyInfo Class
OfficeClip.BusinessLayer.Framework Namespace


RightMenuButtonItem Class

[image]

OfficeClip API Documentation
RightMenuButtonItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the button bar

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class RightMenuButtonItem
Visual Basic (Declaration)
Public Class RightMenuButtonItem
Visual C++
public ref class RightMenuButtonItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.RightMenuButtonItem

See Also

RightMenuButtonItem Members
OfficeClip.BusinessLayer.Framework Namespace


RightMenuButtonItem Members

[image] [image]

OfficeClip API Documentation
RightMenuButtonItem Members
RightMenuButtonItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RightMenuButtonItem type exposes the following members.

Constructors

 | Name | Description
Public method | RightMenuButtonItem | constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsHidden | Shows if the buttonbar item is hidden
Public property | Type | Shows if the buttonbar item is selected

See Also

RightMenuButtonItem Class
OfficeClip.BusinessLayer.Framework Namespace


RightMenuButtonItem Constructor

[image]

OfficeClip API Documentation
RightMenuButtonItem Constructor
RightMenuButtonItem Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RightMenuButtonItem(
    string type
)
Visual Basic (Declaration)
Public Sub New ( _
    type As String _
)
Visual C++
public:
RightMenuButtonItem(
    String^ type
)

Parameters

type
Type: System..::.String

See Also

RightMenuButtonItem Class
OfficeClip.BusinessLayer.Framework Namespace


RightMenuButtonItem Properties

[image] [image]

OfficeClip API Documentation
RightMenuButtonItem Properties
RightMenuButtonItem Class See Also

[This is preliminary documentation and is subject to change.]

The RightMenuButtonItem type exposes the following properties.

Properties

 | Name | Description
Public property | IsHidden | Shows if the buttonbar item is hidden
Public property | Type | Shows if the buttonbar item is selected

See Also

RightMenuButtonItem Class
OfficeClip.BusinessLayer.Framework Namespace


IsHidden Property

[image]

OfficeClip API Documentation
RightMenuButtonItem..::.IsHidden Property
RightMenuButtonItem Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the buttonbar item is hidden

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsHidden { get; set; }
Visual Basic (Declaration)
Public Property IsHidden As Boolean
Visual C++
public:
property bool IsHidden {
    bool get ();
    void set (bool value);
}

See Also

RightMenuButtonItem Class
OfficeClip.BusinessLayer.Framework Namespace


Type Property

[image]

OfficeClip API Documentation
RightMenuButtonItem..::.Type Property
RightMenuButtonItem Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the buttonbar item is selected

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

RightMenuButtonItem Class
OfficeClip.BusinessLayer.Framework Namespace


TimeZoneInfo Class

[image]

OfficeClip API Documentation
TimeZoneInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

The Time Zone structure.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TimeZoneInfo
Visual Basic (Declaration)
Public Class TimeZoneInfo
Visual C++
public ref class TimeZoneInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.TimeZoneInfo

See Also

TimeZoneInfo Members
OfficeClip.BusinessLayer.Framework Namespace


TimeZoneInfo Members

[image] [image]

OfficeClip API Documentation
TimeZoneInfo Members
TimeZoneInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TimeZoneInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TimeZoneInfo |

Methods

 | Name | Description
Public method | Dump | Converts, the object into string (for debugging purposes)
Public method | Equals | Overloaded.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplyDst | Whether this timezone need to be applied.
Public property | DstDur | Daylight saving duration in minutes, 0 denotes null in the database.
Public property | FlDay | // Fall Day, Utils.Constants.NotAvailable denotes null in database, , legal values are 0(Sunday) - 6(Saturday).
Public property | FlMon | Fall Month, Utils.Constants.NotAvailable denotes null in database.
Public property | FlTimeMin | Fall minute in from the midnight.
Public property | FlWeek | Fall Week, "" denotes null in database.
Public property | SprDay | Spring Day of Week, Utils.Constants.NotAvailable denotes null in the database, legal values are 0(Sunday) - 6(Saturday)
Public property | SprMon | Spring Month, Utils.Constants.NotAvailable denotes null in the database.
Public property | SprTimeMin | Spring minute from the midnight.
Public property | SprWeek | Spring Week, "" denotes null in database.
Public property | TimeZoneId | Time zone id in the officeclip database, Utils.Constants.NotAvailable denotes uninitialized value .
Public property | TimeZoneVal | The offset from the GMT in minutes.

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


TimeZoneInfo Constructor

[image]

OfficeClip API Documentation
TimeZoneInfo Constructor
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimeZoneInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeZoneInfo()

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


TimeZoneInfo Methods

[image] [image]

OfficeClip API Documentation
TimeZoneInfo Methods
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimeZoneInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Converts, the object into string (for debugging purposes)
Public method | Equals | Overloaded.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


Dump Method

[image]

OfficeClip API Documentation
TimeZoneInfo..::.Dump Method
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Converts, the object into string (for debugging purposes)

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


Equals Method

[image] [image]

OfficeClip API Documentation
TimeZoneInfo..::.Equals Method
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(TimeZoneInfo) | Tests whether the timezone given in the argument is equal to the current class.

See Also

TimeZoneInfo Class
TimeZoneInfo Members
OfficeClip.BusinessLayer.Framework Namespace


Equals Method (TimeZoneInfo)

[image]

OfficeClip API Documentation
TimeZoneInfo..::.Equals Method (TimeZoneInfo)
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Tests whether the timezone given in the argument is equal to the current class.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool Equals(
    TimeZoneInfo tz
)
Visual Basic (Declaration)
Public Function Equals ( _
    tz As TimeZoneInfo _
) As Boolean
Visual C++
public:
bool Equals(
    TimeZoneInfo^ tz
)

Parameters

tz
Type: OfficeClip.BusinessLayer.Framework..::.TimeZoneInfo
The TimeZone to compare with

See Also

TimeZoneInfo Class
Equals Overload
OfficeClip.BusinessLayer.Framework Namespace


TimeZoneInfo Properties

[image] [image]

OfficeClip API Documentation
TimeZoneInfo Properties
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimeZoneInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ApplyDst | Whether this timezone need to be applied.
Public property | DstDur | Daylight saving duration in minutes, 0 denotes null in the database.
Public property | FlDay | // Fall Day, Utils.Constants.NotAvailable denotes null in database, , legal values are 0(Sunday) - 6(Saturday).
Public property | FlMon | Fall Month, Utils.Constants.NotAvailable denotes null in database.
Public property | FlTimeMin | Fall minute in from the midnight.
Public property | FlWeek | Fall Week, "" denotes null in database.
Public property | SprDay | Spring Day of Week, Utils.Constants.NotAvailable denotes null in the database, legal values are 0(Sunday) - 6(Saturday)
Public property | SprMon | Spring Month, Utils.Constants.NotAvailable denotes null in the database.
Public property | SprTimeMin | Spring minute from the midnight.
Public property | SprWeek | Spring Week, "" denotes null in database.
Public property | TimeZoneId | Time zone id in the officeclip database, Utils.Constants.NotAvailable denotes uninitialized value .
Public property | TimeZoneVal | The offset from the GMT in minutes.

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


ApplyDst Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.ApplyDst Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Whether this timezone need to be applied.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool ApplyDst { get; set; }
Visual Basic (Declaration)
Public Property ApplyDst As Boolean
Visual C++
public:
property bool ApplyDst {
    bool get ();
    void set (bool value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


DstDur Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.DstDur Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Daylight saving duration in minutes, 0 denotes null in the database.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int DstDur { get; set; }
Visual Basic (Declaration)
Public Property DstDur As Integer
Visual C++
public:
property int DstDur {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


FlDay Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.FlDay Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

// Fall Day, Utils.Constants.NotAvailable denotes null in database, , legal values are 0(Sunday) - 6(Saturday).

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int FlDay { get; set; }
Visual Basic (Declaration)
Public Property FlDay As Integer
Visual C++
public:
property int FlDay {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


FlMon Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.FlMon Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Fall Month, Utils.Constants.NotAvailable denotes null in database.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int FlMon { get; set; }
Visual Basic (Declaration)
Public Property FlMon As Integer
Visual C++
public:
property int FlMon {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


FlTimeMin Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.FlTimeMin Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Fall minute in from the midnight.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int FlTimeMin { get; set; }
Visual Basic (Declaration)
Public Property FlTimeMin As Integer
Visual C++
public:
property int FlTimeMin {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


FlWeek Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.FlWeek Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Fall Week, "" denotes null in database.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FlWeek { get; set; }
Visual Basic (Declaration)
Public Property FlWeek As String
Visual C++
public:
property String^ FlWeek {
    String^ get ();
    void set (String^ value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


SprDay Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.SprDay Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Spring Day of Week, Utils.Constants.NotAvailable denotes null in the database, legal values are 0(Sunday) - 6(Saturday)

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SprDay { get; set; }
Visual Basic (Declaration)
Public Property SprDay As Integer
Visual C++
public:
property int SprDay {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


SprMon Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.SprMon Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Spring Month, Utils.Constants.NotAvailable denotes null in the database.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SprMon { get; set; }
Visual Basic (Declaration)
Public Property SprMon As Integer
Visual C++
public:
property int SprMon {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


SprTimeMin Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.SprTimeMin Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Spring minute from the midnight.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SprTimeMin { get; set; }
Visual Basic (Declaration)
Public Property SprTimeMin As Integer
Visual C++
public:
property int SprTimeMin {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


SprWeek Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.SprWeek Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Spring Week, "" denotes null in database.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SprWeek { get; set; }
Visual Basic (Declaration)
Public Property SprWeek As String
Visual C++
public:
property String^ SprWeek {
    String^ get ();
    void set (String^ value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


TimeZoneId Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.TimeZoneId Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Time zone id in the officeclip database, Utils.Constants.NotAvailable denotes uninitialized value .

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TimeZoneId { get; set; }
Visual Basic (Declaration)
Public Property TimeZoneId As Integer
Visual C++
public:
property int TimeZoneId {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


TimeZoneVal Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.TimeZoneVal Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The offset from the GMT in minutes.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TimeZoneVal { get; set; }
Visual Basic (Declaration)
Public Property TimeZoneVal As Integer
Visual C++
public:
property int TimeZoneVal {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.BusinessLayer.Framework Namespace


ToolbarItem Class

[image]

OfficeClip API Documentation
ToolbarItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a toolbar item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ToolbarItem
Visual Basic (Declaration)
Public Class ToolbarItem
Visual C++
public ref class ToolbarItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework..::.ToolbarItem

See Also

ToolbarItem Members
OfficeClip.BusinessLayer.Framework Namespace


ToolbarItem Members

[image] [image]

OfficeClip API Documentation
ToolbarItem Members
ToolbarItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ToolbarItem type exposes the following members.

Constructors

 | Name | Description
Public method | ToolbarItem | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEffectiveUrl | The effective url
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicationInLeftbar | Shows if the application is in the leftbar for this toolbar
Public method | IsVisible | Is the toolbar visible. Note that any item that has application id greater than 500 is always selected
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlternateSkinID | The alternate skin id, activated when the mouse hovers on the toolbar item.
Public property | AppId | The application id
Public property | Id | The unique id
Public property | IsSelected | Determines if the toolbar item is selected
Public property | Lis | Leftbar item list for the toolbar item
Public property | Name | The name
Public property | ResetSkinID | Teh reset skin id (user for alert toolbar)
Public property | SkinID | The skin id
Public property | ToolTip | The tooltip
Public property | Url | The url

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


ToolbarItem Constructor

[image]

OfficeClip API Documentation
ToolbarItem Constructor
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ToolbarItem(
    int id,
    int appId,
    string name,
    string skinID,
    string alternateSkinID,
    string url,
    string toolTip,
    List<LeftbarItem> lis
)
Visual Basic (Declaration)
Public Sub New ( _
    id As Integer, _
    appId As Integer, _
    name As String, _
    skinID As String, _
    alternateSkinID As String, _
    url As String, _
    toolTip As String, _
    lis As List(Of LeftbarItem) _
)
Visual C++
public:
ToolbarItem(
    int id,
    int appId,
    String^ name,
    String^ skinID,
    String^ alternateSkinID,
    String^ url,
    String^ toolTip,
    List<LeftbarItem^>^ lis
)

Parameters

id
Type: System..::.Int32
appId
Type: System..::.Int32
name
Type: System..::.String
skinID
Type: System..::.String
alternateSkinID
Type: System..::.String
url
Type: System..::.String
toolTip
Type: System..::.String
lis
Type: System.Collections.Generic..::.List<(Of <( LeftbarItem >)>)

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


ToolbarItem Methods

[image] [image]

OfficeClip API Documentation
ToolbarItem Methods
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The ToolbarItem type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEffectiveUrl | The effective url
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsApplicationInLeftbar | Shows if the application is in the leftbar for this toolbar
Public method | IsVisible | Is the toolbar visible. Note that any item that has application id greater than 500 is always selected
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


GetEffectiveUrl Method

[image]

OfficeClip API Documentation
ToolbarItem..::.GetEffectiveUrl Method
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The effective url

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetEffectiveUrl(
    byte[] filter
)
Visual Basic (Declaration)
Public Function GetEffectiveUrl ( _
    filter As Byte() _
) As String
Visual C++
public:
String^ GetEffectiveUrl(
    array<unsigned char>^ filter
)

Parameters

filter
Type: array<System..::.Byte>[]()[]
The byte aray of application id

Return Value

The effective url

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


IsApplicationInLeftbar Method

[image]

OfficeClip API Documentation
ToolbarItem..::.IsApplicationInLeftbar Method
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the application is in the leftbar for this toolbar

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsApplicationInLeftbar(
    int appId
)
Visual Basic (Declaration)
Public Function IsApplicationInLeftbar ( _
    appId As Integer _
) As Boolean
Visual C++
public:
bool IsApplicationInLeftbar(
    int appId
)

Parameters

appId
Type: System..::.Int32
The application id to be searched

Return Value

true if the application is found, false if not found

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


IsVisible Method

[image]

OfficeClip API Documentation
ToolbarItem..::.IsVisible Method
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

Is the toolbar visible. Note that any item that has application id greater than 500 is always selected

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsVisible(
    byte[] filter
)
Visual Basic (Declaration)
Public Function IsVisible ( _
    filter As Byte() _
) As Boolean
Visual C++
public:
bool IsVisible(
    array<unsigned char>^ filter
)

Parameters

filter
Type: array<System..::.Byte>[]()[]
The array of application id

Return Value

true if visible but false otherwise

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


ToolbarItem Properties

[image] [image]

OfficeClip API Documentation
ToolbarItem Properties
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The ToolbarItem type exposes the following properties.

Properties

 | Name | Description
Public property | AlternateSkinID | The alternate skin id, activated when the mouse hovers on the toolbar item.
Public property | AppId | The application id
Public property | Id | The unique id
Public property | IsSelected | Determines if the toolbar item is selected
Public property | Lis | Leftbar item list for the toolbar item
Public property | Name | The name
Public property | ResetSkinID | Teh reset skin id (user for alert toolbar)
Public property | SkinID | The skin id
Public property | ToolTip | The tooltip
Public property | Url | The url

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


AlternateSkinID Property

[image]

OfficeClip API Documentation
ToolbarItem..::.AlternateSkinID Property
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The alternate skin id, activated when the mouse hovers on the toolbar item.

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AlternateSkinID { get; set; }
Visual Basic (Declaration)
Public Property AlternateSkinID As String
Visual C++
public:
property String^ AlternateSkinID {
    String^ get ();
    void set (String^ value);
}

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


AppId Property

[image]

OfficeClip API Documentation
ToolbarItem..::.AppId Property
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The application id

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AppId { get; set; }
Visual Basic (Declaration)
Public Property AppId As Integer
Visual C++
public:
property int AppId {
    int get ();
    void set (int value);
}

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


Id Property

[image]

OfficeClip API Documentation
ToolbarItem..::.Id Property
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The unique id

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Id { get; set; }
Visual Basic (Declaration)
Public Property Id As Integer
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


IsSelected Property

[image]

OfficeClip API Documentation
ToolbarItem..::.IsSelected Property
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the toolbar item is selected

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


Lis Property

[image]

OfficeClip API Documentation
ToolbarItem..::.Lis Property
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

Leftbar item list for the toolbar item

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<LeftbarItem> Lis { get; set; }
Visual Basic (Declaration)
Public Property Lis As List(Of LeftbarItem)
Visual C++
public:
property List<LeftbarItem^>^ Lis {
    List<LeftbarItem^>^ get ();
    void set (List<LeftbarItem^>^ value);
}

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


Name Property

[image]

OfficeClip API Documentation
ToolbarItem..::.Name Property
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The name

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


ResetSkinID Property

[image]

OfficeClip API Documentation
ToolbarItem..::.ResetSkinID Property
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

Teh reset skin id (user for alert toolbar)

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ResetSkinID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ResetSkinID As String
Visual C++
public:
property String^ ResetSkinID {
    String^ get ();
}

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


SkinID Property

[image]

OfficeClip API Documentation
ToolbarItem..::.SkinID Property
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The skin id

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SkinID { get; set; }
Visual Basic (Declaration)
Public Property SkinID As String
Visual C++
public:
property String^ SkinID {
    String^ get ();
    void set (String^ value);
}

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


ToolTip Property

[image]

OfficeClip API Documentation
ToolbarItem..::.ToolTip Property
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The tooltip

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToolTip { get; set; }
Visual Basic (Declaration)
Public Property ToolTip As String
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


Url Property

[image]

OfficeClip API Documentation
ToolbarItem..::.Url Property
ToolbarItem Class See Also

[This is preliminary documentation and is subject to change.]

The url

Namespace: OfficeClip.BusinessLayer.Framework
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Url { get; set; }
Visual Basic (Declaration)
Public Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

See Also

ToolbarItem Class
OfficeClip.BusinessLayer.Framework Namespace


OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the Html Status

Classes

 | Class | Description
Public class | Item | The html status information class for consolidating error messages
Public class | List | Html status information to represent list


Item Class

[image]

OfficeClip API Documentation
Item Class
Members See Also

[This is preliminary documentation and is subject to change.]

The html status information class for consolidating error messages

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class Item
Visual Basic (Declaration)
Public Class Item
Visual C++
public ref class Item

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.HtmlStatus..::.Item

See Also

Item Members
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


Item Members

[image] [image]

OfficeClip API Documentation
Item Members
Item Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The Item type exposes the following members.

Constructors

 | Name | Description
Public method | Item | The public constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetEmphasis |
Public method | ToHtml | Converts the object information to html value
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Emphasize | Put emphasis on the item (make it bold!

See Also

Item Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


Item Constructor

[image]

OfficeClip API Documentation
Item Constructor
Item Class See Also

[This is preliminary documentation and is subject to change.]

The public constructor

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Item(
    bool isError,
    string status
)
Visual Basic (Declaration)
Public Sub New ( _
    isError As Boolean, _
    status As String _
)
Visual C++
public:
Item(
    bool isError,
    String^ status
)

Parameters

isError
Type: System..::.Boolean
if it is an error
status
Type: System..::.String
the status string

See Also

Item Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


Item Methods

[image] [image]

OfficeClip API Documentation
Item Methods
Item Class See Also

[This is preliminary documentation and is subject to change.]

The Item type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SetEmphasis |
Public method | ToHtml | Converts the object information to html value
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Item Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


SetEmphasis Method

[image]

OfficeClip API Documentation
Item..::.SetEmphasis Method
Item Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string SetEmphasis(
    string val
)
Visual Basic (Declaration)
Protected Function SetEmphasis ( _
    val As String _
) As String
Visual C++
protected:
String^ SetEmphasis(
    String^ val
)

Parameters

val
Type: System..::.String

Return Value

See Also

Item Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


ToHtml Method

[image]

OfficeClip API Documentation
Item..::.ToHtml Method
Item Class See Also

[This is preliminary documentation and is subject to change.]

Converts the object information to html value

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToHtml()
Visual Basic (Declaration)
Public Function ToHtml As String
Visual C++
public:
String^ ToHtml()

Return Value

The Html string representation of the object

See Also

Item Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


Item Properties

[image] [image]

OfficeClip API Documentation
Item Properties
Item Class See Also

[This is preliminary documentation and is subject to change.]

The Item type exposes the following properties.

Properties

 | Name | Description
Public property | Emphasize | Put emphasis on the item (make it bold!

See Also

Item Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


Emphasize Property

[image]

OfficeClip API Documentation
Item..::.Emphasize Property
Item Class See Also

[This is preliminary documentation and is subject to change.]

Put emphasis on the item (make it bold!

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool Emphasize { set; }
Visual Basic (Declaration)
Public WriteOnly Property Emphasize As Boolean
Visual C++
public:
property bool Emphasize {
    void set (bool value);
}

See Also

Item Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


List Class

[image]

OfficeClip API Documentation
List Class
Members See Also

[This is preliminary documentation and is subject to change.]

Html status information to represent list

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class List
Visual Basic (Declaration)
Public Class List
Visual C++
public ref class List

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.HtmlStatus..::.List

See Also

List Members
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


List Members

[image] [image]

OfficeClip API Documentation
List Members
List Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The List type exposes the following members.

Constructors

 | Name | Description
Public method | List | Overloaded.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToHtml | Converts the object to its html representation
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | ocr | oc resources object

Properties

 | Name | Description
 | ItemCssClass | The item style sheet
 | ItemErrorCssClass | The item error stylesheet
 | ItemErrorImgPath | the item error image path
Public property | TitleCssClass | The title stylesheet

See Also

List Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


List Constructor

[image] [image]

OfficeClip API Documentation
List Constructor
List Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | List()()() | Constructor
Public method | List(String) | Constructor

See Also

List Class
List Members
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


List Constructor

[image]

OfficeClip API Documentation
List Constructor
List Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
List()

See Also

List Class
List Overload
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


List Constructor (String)

[image]

OfficeClip API Documentation
List Constructor (String)
List Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List(
    string title
)
Visual Basic (Declaration)
Public Sub New ( _
    title As String _
)
Visual C++
public:
List(
    String^ title
)

Parameters

title
Type: System..::.String

See Also

List Class
List Overload
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


List Fields

[image] [image]

OfficeClip API Documentation
List Fields
List Class See Also

[This is preliminary documentation and is subject to change.]

The List type exposes the following fields.

Fields

 | Name | Description
Protected field | ocr | oc resources object

See Also

List Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


ocr Field

[image]

OfficeClip API Documentation
List..::.ocr Field
List Class See Also

[This is preliminary documentation and is subject to change.]

oc resources object

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected OCResources ocr
Visual Basic (Declaration)
Protected ocr As OCResources
Visual C++
protected:
OCResources^ ocr

See Also

List Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


List Methods

[image] [image]

OfficeClip API Documentation
List Methods
List Class See Also

[This is preliminary documentation and is subject to change.]

The List type exposes the following methods.

Methods

 | Name | Description
Public method | Add | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToHtml | Converts the object to its html representation
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

List Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


Add Method

[image] [image]

OfficeClip API Documentation
List..::.Add Method
List Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Add(Boolean, String) | Adds an entry to the object
Public method | Add(Boolean, String, Boolean) |

See Also

List Class
List Members
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


Add Method (Boolean, String)

[image]

OfficeClip API Documentation
List..::.Add Method (Boolean, String)
List Class See Also

[This is preliminary documentation and is subject to change.]

Adds an entry to the object

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    bool isError,
    string status
)
Visual Basic (Declaration)
Public Sub Add ( _
    isError As Boolean, _
    status As String _
)
Visual C++
public:
void Add(
    bool isError,
    String^ status
)

Parameters

isError
Type: System..::.Boolean
true if the entry to be added is an error entry
status
Type: System..::.String
the status message

See Also

List Class
Add Overload
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


Add Method (Boolean, String, Boolean)

[image]

OfficeClip API Documentation
List..::.Add Method (Boolean, String, Boolean)
List Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Add(
    bool isError,
    string status,
    bool emphasis
)
Visual Basic (Declaration)
Public Sub Add ( _
    isError As Boolean, _
    status As String, _
    emphasis As Boolean _
)
Visual C++
public:
void Add(
    bool isError,
    String^ status,
    bool emphasis
)

Parameters

isError
Type: System..::.Boolean
status
Type: System..::.String
emphasis
Type: System..::.Boolean

See Also

List Class
Add Overload
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


ToHtml Method

[image]

OfficeClip API Documentation
List..::.ToHtml Method
List Class See Also

[This is preliminary documentation and is subject to change.]

Converts the object to its html representation

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToHtml()
Visual Basic (Declaration)
Public Function ToHtml As String
Visual C++
public:
String^ ToHtml()

Return Value

the html representation of the object

See Also

List Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


List Properties

[image] [image]

OfficeClip API Documentation
List Properties
List Class See Also

[This is preliminary documentation and is subject to change.]

The List type exposes the following properties.

Properties

 | Name | Description
 | ItemCssClass | The item style sheet
 | ItemErrorCssClass | The item error stylesheet
 | ItemErrorImgPath | the item error image path
Public property | TitleCssClass | The title stylesheet

See Also

List Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


ItemCssClass Property

[image]

OfficeClip API Documentation
List..::.ItemCssClass Property
List Class See Also

[This is preliminary documentation and is subject to change.]

The item style sheet

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string ItemCssClass { get; set; }
Visual Basic (Declaration)
Public Shared Property ItemCssClass As String
Visual C++
public:
static property String^ ItemCssClass {
    String^ get ();
    void set (String^ value);
}

See Also

List Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


ItemErrorCssClass Property

[image]

OfficeClip API Documentation
List..::.ItemErrorCssClass Property
List Class See Also

[This is preliminary documentation and is subject to change.]

The item error stylesheet

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string ItemErrorCssClass { get; set; }
Visual Basic (Declaration)
Public Shared Property ItemErrorCssClass As String
Visual C++
public:
static property String^ ItemErrorCssClass {
    String^ get ();
    void set (String^ value);
}

See Also

List Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


ItemErrorImgPath Property

[image]

OfficeClip API Documentation
List..::.ItemErrorImgPath Property
List Class See Also

[This is preliminary documentation and is subject to change.]

the item error image path

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string ItemErrorImgPath { get; set; }
Visual Basic (Declaration)
Public Shared Property ItemErrorImgPath As String
Visual C++
public:
static property String^ ItemErrorImgPath {
    String^ get ();
    void set (String^ value);
}

See Also

List Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


TitleCssClass Property

[image]

OfficeClip API Documentation
List..::.TitleCssClass Property
List Class See Also

[This is preliminary documentation and is subject to change.]

The title stylesheet

Namespace: OfficeClip.BusinessLayer.Framework.HtmlStatus
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TitleCssClass { get; set; }
Visual Basic (Declaration)
Public Property TitleCssClass As String
Visual C++
public:
property String^ TitleCssClass {
    String^ get ();
    void set (String^ value);
}

See Also

List Class
OfficeClip.BusinessLayer.Framework.HtmlStatus Namespace


OfficeClip.BusinessLayer.Framework.Profile Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Framework.Profile Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the profile. In OfficeClip, two types of profiles are possible, user profile and the organization profile

Classes

 | Class | Description
Public class | BulletinBoardUserProfile | Class for bulletin board user profile
Public class | CalendarGroupProfile | Class the describe the calendar group Profile
Public class | CalendarUserProfile | The calendar user profile
Public class | DocumentUserProfile | Class to represent the document user profile
Public class | ExpenseGroupProfile | Class to represent the expense group profile
Public class | ExpenseUserProfile | Class to represent the expense user profile
Public class | GeneralUserProfile | Class to represent the general user profile
Public class | ProfileBase | The base class for user and group profile
Public class | ProfileHttpContext | The http profile context
Public class | PunchClockGroupProfile | Punch Clock Group Profile
Public class | PunchClockUserProfile | Class to represent the punch clock user profile
Public class | TimesheetGroupProfile | Class to represent the timesheet group profile
Public class | TimesheetUserProfile | The timesheet user profile
Public class | TrackerUserProfile | Class for issue tracker user profile

Enumerations

 | Enumeration | Description
Public enumeration | BulletinBoardUserEnum | Enumerated type for the user profile of bulletin board
Public enumeration | CalendarGroupEnum | Enumerated types for the calendar group profile
Public enumeration | CalendarUserEnum | Enumerated types for the user profile for the calendar
Public enumeration | DocumentUserEnum | Enumerated types for the user profile for documents
Public enumeration | ExpenseGroupEnum | Enumerated types for the group profile for expenses
Public enumeration | ExpenseUserEnum | Enumerated type for the user profile for expenses
Public enumeration | GeneralUserEnum | Enumerated types for the general user profiles
Public enumeration | PunchClockGroupEnum | Enumerated type for the group profile for punch clock
Public enumeration | PunchClockUserEnum | Enumerated type for the user profile for punch clock
Public enumeration | TimesheetGroupEnum | Enumeration for the group profile for timesheet
Public enumeration | TimesheetUserEnum | Enumerated type for the user profile for timesheet
Public enumeration | TrackerUserEnum | Enumerated types for the user profile for tracker


BulletinBoardUserEnum Enumeration

[image]

OfficeClip API Documentation
BulletinBoardUserEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for the user profile of bulletin board

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum BulletinBoardUserEnum
Visual Basic (Declaration)
Public Enumeration BulletinBoardUserEnum
Visual C++
public enum class BulletinBoardUserEnum

Members

Member name | Description
ApplicationLastVisited | Application last visited time
ApplicationLastVisitedBackup | Application last visited backup time

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


BulletinBoardUserProfile Class

[image]

OfficeClip API Documentation
BulletinBoardUserProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class for bulletin board user profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class BulletinBoardUserProfile : ProfileBase
Visual Basic (Declaration)
Public Class BulletinBoardUserProfile _
    Inherits ProfileBase
Visual C++
public ref class BulletinBoardUserProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.BulletinBoardUserProfile

See Also

BulletinBoardUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


BulletinBoardUserProfile Members

[image] [image]

OfficeClip API Documentation
BulletinBoardUserProfile Members
BulletinBoardUserProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The BulletinBoardUserProfile type exposes the following members.

Constructors

 | Name | Description
Public method | BulletinBoardUserProfile | Overloaded.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited |
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | ApplicationLastVisited | application last visited
Public property | ApplicationLastVisitedBackup | application last visited

See Also

BulletinBoardUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


BulletinBoardUserProfile Constructor

[image] [image]

OfficeClip API Documentation
BulletinBoardUserProfile Constructor
BulletinBoardUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | BulletinBoardUserProfile()()() | Constructor
Public method | BulletinBoardUserProfile(String) | Constructor

See Also

BulletinBoardUserProfile Class
BulletinBoardUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


BulletinBoardUserProfile Constructor

[image]

OfficeClip API Documentation
BulletinBoardUserProfile Constructor
BulletinBoardUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BulletinBoardUserProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BulletinBoardUserProfile()

See Also

BulletinBoardUserProfile Class
BulletinBoardUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


BulletinBoardUserProfile Constructor (String)

[image]

OfficeClip API Documentation
BulletinBoardUserProfile Constructor (String)
BulletinBoardUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BulletinBoardUserProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
BulletinBoardUserProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

BulletinBoardUserProfile Class
BulletinBoardUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


BulletinBoardUserProfile Methods

[image] [image]

OfficeClip API Documentation
BulletinBoardUserProfile Methods
BulletinBoardUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The BulletinBoardUserProfile type exposes the following methods.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited |
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BulletinBoardUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CopyApplicationLastVisitedBackupToApplicationLastVisited Method

[image]

OfficeClip API Documentation
BulletinBoardUserProfile..::.CopyApplicationLastVisitedBackupToApplicationLastVisited Method
BulletinBoardUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyApplicationLastVisitedBackupToApplicationLastVisited()
Visual Basic (Declaration)
Public Sub CopyApplicationLastVisitedBackupToApplicationLastVisited
Visual C++
public:
void CopyApplicationLastVisitedBackupToApplicationLastVisited()

See Also

BulletinBoardUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
BulletinBoardUserProfile..::.GetBool Method
BulletinBoardUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

BulletinBoardUserProfile Class
BulletinBoardUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


BulletinBoardUserProfile Properties

[image] [image]

OfficeClip API Documentation
BulletinBoardUserProfile Properties
BulletinBoardUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The BulletinBoardUserProfile type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationLastVisited | application last visited
Public property | ApplicationLastVisitedBackup | application last visited

See Also

BulletinBoardUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisited Property

[image]

OfficeClip API Documentation
BulletinBoardUserProfile..::.ApplicationLastVisited Property
BulletinBoardUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

application last visited

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisited { get; set; }
Visual Basic (Declaration)
Public Property ApplicationLastVisited As DateTime
Visual C++
public:
property DateTime ApplicationLastVisited {
    DateTime get ();
    void set (DateTime value);
}

See Also

BulletinBoardUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisitedBackup Property

[image]

OfficeClip API Documentation
BulletinBoardUserProfile..::.ApplicationLastVisitedBackup Property
BulletinBoardUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

application last visited

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisitedBackup { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationLastVisitedBackup As DateTime
Visual C++
public:
property DateTime ApplicationLastVisitedBackup {
    DateTime get ();
}

See Also

BulletinBoardUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarGroupEnum Enumeration

[image]

OfficeClip API Documentation
CalendarGroupEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types for the calendar group profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum CalendarGroupEnum
Visual Basic (Declaration)
Public Enumeration CalendarGroupEnum
Visual C++
public enum class CalendarGroupEnum

Members

Member name | Description
WorkDayStartTime | Work day start time
WorkDayEndTime | Work day end time
DefaultEventType | Default event type
WeekStartDay | Work start day of the week
WorkDays | Work days

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarGroupProfile Class

[image]

OfficeClip API Documentation
CalendarGroupProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class the describe the calendar group Profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class CalendarGroupProfile : ProfileBase
Visual Basic (Declaration)
Public Class CalendarGroupProfile _
    Inherits ProfileBase
Visual C++
public ref class CalendarGroupProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.CalendarGroupProfile

See Also

CalendarGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarGroupProfile Members

[image] [image]

OfficeClip API Documentation
CalendarGroupProfile Members
CalendarGroupProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The CalendarGroupProfile type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarGroupProfile | Overloaded.

Methods

 | Name | Description
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | DefaultEventType | The default event type
Public property | WeekStartDay | The start of the weekday
Public property | WorkDayEndTime | The end time of the weekday in 24 hour format
Public property | WorkDays | Work days
Public property | WorkDayStartTime | The start time of the weekday in 24 hour format

See Also

CalendarGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarGroupProfile Constructor

[image] [image]

OfficeClip API Documentation
CalendarGroupProfile Constructor
CalendarGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | CalendarGroupProfile()()() | Constructor
Public method | CalendarGroupProfile(String) | Constructor

See Also

CalendarGroupProfile Class
CalendarGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarGroupProfile Constructor

[image]

OfficeClip API Documentation
CalendarGroupProfile Constructor
CalendarGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CalendarGroupProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalendarGroupProfile()

See Also

CalendarGroupProfile Class
CalendarGroupProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarGroupProfile Constructor (String)

[image]

OfficeClip API Documentation
CalendarGroupProfile Constructor (String)
CalendarGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CalendarGroupProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
CalendarGroupProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

CalendarGroupProfile Class
CalendarGroupProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarGroupProfile Properties

[image] [image]

OfficeClip API Documentation
CalendarGroupProfile Properties
CalendarGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The CalendarGroupProfile type exposes the following properties.

Properties

 | Name | Description
Public property | DefaultEventType | The default event type
Public property | WeekStartDay | The start of the weekday
Public property | WorkDayEndTime | The end time of the weekday in 24 hour format
Public property | WorkDays | Work days
Public property | WorkDayStartTime | The start time of the weekday in 24 hour format

See Also

CalendarGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


DefaultEventType Property

[image]

OfficeClip API Documentation
CalendarGroupProfile..::.DefaultEventType Property
CalendarGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The default event type

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventType DefaultEventType { get; set; }
Visual Basic (Declaration)
Public Property DefaultEventType As EventType
Visual C++
public:
property EventType DefaultEventType {
    EventType get ();
    void set (EventType value);
}

See Also

CalendarGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


WeekStartDay Property

[image]

OfficeClip API Documentation
CalendarGroupProfile..::.WeekStartDay Property
CalendarGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The start of the weekday

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DayOfWeek WeekStartDay { get; set; }
Visual Basic (Declaration)
Public Property WeekStartDay As DayOfWeek
Visual C++
public:
property DayOfWeek WeekStartDay {
    DayOfWeek get ();
    void set (DayOfWeek value);
}

See Also

CalendarGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


WorkDayEndTime Property

[image]

OfficeClip API Documentation
CalendarGroupProfile..::.WorkDayEndTime Property
CalendarGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The end time of the weekday in 24 hour format

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int WorkDayEndTime { get; set; }
Visual Basic (Declaration)
Public Property WorkDayEndTime As Integer
Visual C++
public:
property int WorkDayEndTime {
    int get ();
    void set (int value);
}

See Also

CalendarGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


WorkDays Property

[image]

OfficeClip API Documentation
CalendarGroupProfile..::.WorkDays Property
CalendarGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Work days

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string WorkDays { get; set; }
Visual Basic (Declaration)
Public Property WorkDays As String
Visual C++
public:
property String^ WorkDays {
    String^ get ();
    void set (String^ value);
}

See Also

CalendarGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


WorkDayStartTime Property

[image]

OfficeClip API Documentation
CalendarGroupProfile..::.WorkDayStartTime Property
CalendarGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The start time of the weekday in 24 hour format

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int WorkDayStartTime { get; set; }
Visual Basic (Declaration)
Public Property WorkDayStartTime As Integer
Visual C++
public:
property int WorkDayStartTime {
    int get ();
    void set (int value);
}

See Also

CalendarGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarUserEnum Enumeration

[image]

OfficeClip API Documentation
CalendarUserEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types for the user profile for the calendar

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum CalendarUserEnum
Visual Basic (Declaration)
Public Enumeration CalendarUserEnum
Visual C++
public enum class CalendarUserEnum

Members

Member name | Description
DefaultView | The calendar default view
ApplicationLastVisited | Time when the application was last visited
ApplicationLastVisitedBackup | Last visited backup value
DefaultEventShowAs | How the Show As values of the events are shown by default (busy, tentative, free or out of office)
GroupSelection | Shows the event scope as All Orgs, This Orgs or Private

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarUserProfile Class

[image]

OfficeClip API Documentation
CalendarUserProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

The calendar user profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class CalendarUserProfile : ProfileBase
Visual Basic (Declaration)
Public Class CalendarUserProfile _
    Inherits ProfileBase
Visual C++
public ref class CalendarUserProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.CalendarUserProfile

See Also

CalendarUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarUserProfile Members

[image] [image]

OfficeClip API Documentation
CalendarUserProfile Members
CalendarUserProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The CalendarUserProfile type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarUserProfile | Overloaded.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited |
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | ApplicationLastVisited | Application last visited
Public property | ApplicationLastVisitedBackup | Application last visited backup
Public property | DefaultEventShowAs | Default event show as
Public property | DefaultView | The default view of the calendar
Public property | GroupSelection | GroupSelection

See Also

CalendarUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarUserProfile Constructor

[image] [image]

OfficeClip API Documentation
CalendarUserProfile Constructor
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | CalendarUserProfile()()() | Constructor
Public method | CalendarUserProfile(String) | Constructor

See Also

CalendarUserProfile Class
CalendarUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarUserProfile Constructor

[image]

OfficeClip API Documentation
CalendarUserProfile Constructor
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CalendarUserProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalendarUserProfile()

See Also

CalendarUserProfile Class
CalendarUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarUserProfile Constructor (String)

[image]

OfficeClip API Documentation
CalendarUserProfile Constructor (String)
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CalendarUserProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
CalendarUserProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

CalendarUserProfile Class
CalendarUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarUserProfile Methods

[image] [image]

OfficeClip API Documentation
CalendarUserProfile Methods
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The CalendarUserProfile type exposes the following methods.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited |
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CalendarUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CopyApplicationLastVisitedBackupToApplicationLastVisited Method

[image]

OfficeClip API Documentation
CalendarUserProfile..::.CopyApplicationLastVisitedBackupToApplicationLastVisited Method
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyApplicationLastVisitedBackupToApplicationLastVisited()
Visual Basic (Declaration)
Public Sub CopyApplicationLastVisitedBackupToApplicationLastVisited
Visual C++
public:
void CopyApplicationLastVisitedBackupToApplicationLastVisited()

See Also

CalendarUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
CalendarUserProfile..::.GetBool Method
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

CalendarUserProfile Class
CalendarUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


CalendarUserProfile Properties

[image] [image]

OfficeClip API Documentation
CalendarUserProfile Properties
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The CalendarUserProfile type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationLastVisited | Application last visited
Public property | ApplicationLastVisitedBackup | Application last visited backup
Public property | DefaultEventShowAs | Default event show as
Public property | DefaultView | The default view of the calendar
Public property | GroupSelection | GroupSelection

See Also

CalendarUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisited Property

[image]

OfficeClip API Documentation
CalendarUserProfile..::.ApplicationLastVisited Property
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Application last visited

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisited { get; set; }
Visual Basic (Declaration)
Public Property ApplicationLastVisited As DateTime
Visual C++
public:
property DateTime ApplicationLastVisited {
    DateTime get ();
    void set (DateTime value);
}

See Also

CalendarUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisitedBackup Property

[image]

OfficeClip API Documentation
CalendarUserProfile..::.ApplicationLastVisitedBackup Property
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Application last visited backup

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisitedBackup { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationLastVisitedBackup As DateTime
Visual C++
public:
property DateTime ApplicationLastVisitedBackup {
    DateTime get ();
}

See Also

CalendarUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


DefaultEventShowAs Property

[image]

OfficeClip API Documentation
CalendarUserProfile..::.DefaultEventShowAs Property
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Default event show as

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventShowAs DefaultEventShowAs { get; set; }
Visual Basic (Declaration)
Public Property DefaultEventShowAs As EventShowAs
Visual C++
public:
property EventShowAs DefaultEventShowAs {
    EventShowAs get ();
    void set (EventShowAs value);
}

See Also

CalendarUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


DefaultView Property

[image]

OfficeClip API Documentation
CalendarUserProfile..::.DefaultView Property
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The default view of the calendar

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CalendarView DefaultView { get; set; }
Visual Basic (Declaration)
Public Property DefaultView As CalendarView
Visual C++
public:
property CalendarView DefaultView {
    CalendarView get ();
    void set (CalendarView value);
}

See Also

CalendarUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GroupSelection Property

[image]

OfficeClip API Documentation
CalendarUserProfile..::.GroupSelection Property
CalendarUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

GroupSelection

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GroupSelection GroupSelection { get; set; }
Visual Basic (Declaration)
Public Property GroupSelection As GroupSelection
Visual C++
public:
property GroupSelection GroupSelection {
    GroupSelection get ();
    void set (GroupSelection value);
}

See Also

CalendarUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


DocumentUserEnum Enumeration

[image]

OfficeClip API Documentation
DocumentUserEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types for the user profile for documents

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum DocumentUserEnum
Visual Basic (Declaration)
Public Enumeration DocumentUserEnum
Visual C++
public enum class DocumentUserEnum

Members

Member name | Description
ApplicationLastVisited | Aplication last visited time
ApplicationLastVisitedBackup | Application last visited backup time

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


DocumentUserProfile Class

[image]

OfficeClip API Documentation
DocumentUserProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the document user profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class DocumentUserProfile : ProfileBase
Visual Basic (Declaration)
Public Class DocumentUserProfile _
    Inherits ProfileBase
Visual C++
public ref class DocumentUserProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.DocumentUserProfile

See Also

DocumentUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


DocumentUserProfile Members

[image] [image]

OfficeClip API Documentation
DocumentUserProfile Members
DocumentUserProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The DocumentUserProfile type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentUserProfile | Overloaded.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited |
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | ApplicationLastVisited | application last backup
Public property | ApplicationLastVisitedBackup | Application last visited backup

See Also

DocumentUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


DocumentUserProfile Constructor

[image] [image]

OfficeClip API Documentation
DocumentUserProfile Constructor
DocumentUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | DocumentUserProfile()()() | constructor
Public method | DocumentUserProfile(String) | constructor

See Also

DocumentUserProfile Class
DocumentUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


DocumentUserProfile Constructor

[image]

OfficeClip API Documentation
DocumentUserProfile Constructor
DocumentUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentUserProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentUserProfile()

See Also

DocumentUserProfile Class
DocumentUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


DocumentUserProfile Constructor (String)

[image]

OfficeClip API Documentation
DocumentUserProfile Constructor (String)
DocumentUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentUserProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
DocumentUserProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

DocumentUserProfile Class
DocumentUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


DocumentUserProfile Methods

[image] [image]

OfficeClip API Documentation
DocumentUserProfile Methods
DocumentUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The DocumentUserProfile type exposes the following methods.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited |
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CopyApplicationLastVisitedBackupToApplicationLastVisited Method

[image]

OfficeClip API Documentation
DocumentUserProfile..::.CopyApplicationLastVisitedBackupToApplicationLastVisited Method
DocumentUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyApplicationLastVisitedBackupToApplicationLastVisited()
Visual Basic (Declaration)
Public Sub CopyApplicationLastVisitedBackupToApplicationLastVisited
Visual C++
public:
void CopyApplicationLastVisitedBackupToApplicationLastVisited()

See Also

DocumentUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
DocumentUserProfile..::.GetBool Method
DocumentUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

DocumentUserProfile Class
DocumentUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


DocumentUserProfile Properties

[image] [image]

OfficeClip API Documentation
DocumentUserProfile Properties
DocumentUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The DocumentUserProfile type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationLastVisited | application last backup
Public property | ApplicationLastVisitedBackup | Application last visited backup

See Also

DocumentUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisited Property

[image]

OfficeClip API Documentation
DocumentUserProfile..::.ApplicationLastVisited Property
DocumentUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

application last backup

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisited { get; set; }
Visual Basic (Declaration)
Public Property ApplicationLastVisited As DateTime
Visual C++
public:
property DateTime ApplicationLastVisited {
    DateTime get ();
    void set (DateTime value);
}

See Also

DocumentUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisitedBackup Property

[image]

OfficeClip API Documentation
DocumentUserProfile..::.ApplicationLastVisitedBackup Property
DocumentUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Application last visited backup

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisitedBackup { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationLastVisitedBackup As DateTime
Visual C++
public:
property DateTime ApplicationLastVisitedBackup {
    DateTime get ();
}

See Also

DocumentUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseGroupEnum Enumeration

[image]

OfficeClip API Documentation
ExpenseGroupEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types for the group profile for expenses

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ExpenseGroupEnum
Visual Basic (Declaration)
Public Enumeration ExpenseGroupEnum
Visual C++
public enum class ExpenseGroupEnum

Members

Member name | Description
ShowHistory | Show the expense work history
AllowSelfApprove | Allows self approval for the expense
NumberOfRows | Number of rows in the expense
WeekStartDay | The week start day for the expense
ShowDetail | Show detail of the expense below each expense item
ShowAttachment | Determines if the attachments are to be shown on the expense entry/edit screen
ShowTotals | If the row and column totals are to be shown on the expese entry/edit screen
ExpenseTypeAlias | Alias for the expense type
AccountAlias | Alias for the account
ProjectAlias | Alias for the project
NumberOfStartingPeriodForward | The total number of forward periods (in the future) that the timesheet can be created for
NumberOfStartingPeriodBackward | The total number of backward periods (in the past) that the timesheet can be created for
ShowPayments | If the payment processing screen is shown to the administrator
BulkApprove | Shows whether the Bulk Approval feature is enabled
AutoApprove | Shows whether the Auto Approval feature is enabled
ExpenseHeader | Expense Header
ExpenseFooter | Expense Footer
CostPerMile | Cost per mile

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseGroupProfile Class

[image]

OfficeClip API Documentation
ExpenseGroupProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the expense group profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ExpenseGroupProfile : ProfileBase
Visual Basic (Declaration)
Public Class ExpenseGroupProfile _
    Inherits ProfileBase
Visual C++
public ref class ExpenseGroupProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.ExpenseGroupProfile

See Also

ExpenseGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseGroupProfile Members

[image] [image]

OfficeClip API Documentation
ExpenseGroupProfile Members
ExpenseGroupProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseGroupProfile type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseGroupProfile | Overloaded.

Methods

 | Name | Description
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | AccountAlias | string value of the alias for the account
Public property | CostPerMile |
Public property | ExpenseFooter | Expense Footer
Public property | ExpenseHeader | Expense Header
Public property | ExpenseTypeAlias | string value of the alias for expense type
Public property | IsAllowSelfApprove | Whether the self approve is allowed on the time / expenses
Public property | IsAutoApprove | Whether the Bulk Approve is allowed on the expenses
Public property | IsBulkApprove | Whether the Bulk Approve is allowed on the expenses
Public property | IsShowAttachment | Whether the attachment needs to be shown
Public property | IsShowDetail | Whether the detail needs to be shown
Public property | IsShowHistory | Whether the history needs to be shown
Public property | IsShowPayments | Whether the Payment processing are to be shown in expenses (it is only shown to the administrator
Public property | IsShowTotals | Whether the Totals are to be shown in time and expenses
Public property | NumberOfRows | Total number of rows
Public property | NumberOfStartingPeriodBackward | The total number of backward periods (in the future) that the timesheet can be created for
Public property | NumberOfStartingPeriodForward | The total number of forward periods (in the future) that the timesheet can be created for
Public property | ProjectAlias | string value of the alias for project
Public property | WeekStartDay | The start of the weekday

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseGroupProfile Constructor

[image] [image]

OfficeClip API Documentation
ExpenseGroupProfile Constructor
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpenseGroupProfile()()() | Constructor
Public method | ExpenseGroupProfile(String) | Constructor

See Also

ExpenseGroupProfile Class
ExpenseGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseGroupProfile Constructor

[image]

OfficeClip API Documentation
ExpenseGroupProfile Constructor
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseGroupProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseGroupProfile()

See Also

ExpenseGroupProfile Class
ExpenseGroupProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseGroupProfile Constructor (String)

[image]

OfficeClip API Documentation
ExpenseGroupProfile Constructor (String)
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseGroupProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
ExpenseGroupProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

ExpenseGroupProfile Class
ExpenseGroupProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseGroupProfile Properties

[image] [image]

OfficeClip API Documentation
ExpenseGroupProfile Properties
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseGroupProfile type exposes the following properties.

Properties

 | Name | Description
Public property | AccountAlias | string value of the alias for the account
Public property | CostPerMile |
Public property | ExpenseFooter | Expense Footer
Public property | ExpenseHeader | Expense Header
Public property | ExpenseTypeAlias | string value of the alias for expense type
Public property | IsAllowSelfApprove | Whether the self approve is allowed on the time / expenses
Public property | IsAutoApprove | Whether the Bulk Approve is allowed on the expenses
Public property | IsBulkApprove | Whether the Bulk Approve is allowed on the expenses
Public property | IsShowAttachment | Whether the attachment needs to be shown
Public property | IsShowDetail | Whether the detail needs to be shown
Public property | IsShowHistory | Whether the history needs to be shown
Public property | IsShowPayments | Whether the Payment processing are to be shown in expenses (it is only shown to the administrator
Public property | IsShowTotals | Whether the Totals are to be shown in time and expenses
Public property | NumberOfRows | Total number of rows
Public property | NumberOfStartingPeriodBackward | The total number of backward periods (in the future) that the timesheet can be created for
Public property | NumberOfStartingPeriodForward | The total number of forward periods (in the future) that the timesheet can be created for
Public property | ProjectAlias | string value of the alias for project
Public property | WeekStartDay | The start of the weekday

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


AccountAlias Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.AccountAlias Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

string value of the alias for the account

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AccountAlias { get; set; }
Visual Basic (Declaration)
Public Property AccountAlias As String
Visual C++
public:
property String^ AccountAlias {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CostPerMile Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.CostPerMile Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double CostPerMile { get; set; }
Visual Basic (Declaration)
Public Property CostPerMile As Double
Visual C++
public:
property double CostPerMile {
    double get ();
    void set (double value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseFooter Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.ExpenseFooter Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Expense Footer

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ExpenseFooter { get; set; }
Visual Basic (Declaration)
Public Property ExpenseFooter As String
Visual C++
public:
property String^ ExpenseFooter {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseHeader Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.ExpenseHeader Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Expense Header

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ExpenseHeader { get; set; }
Visual Basic (Declaration)
Public Property ExpenseHeader As String
Visual C++
public:
property String^ ExpenseHeader {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseTypeAlias Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.ExpenseTypeAlias Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

string value of the alias for expense type

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ExpenseTypeAlias { get; set; }
Visual Basic (Declaration)
Public Property ExpenseTypeAlias As String
Visual C++
public:
property String^ ExpenseTypeAlias {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsAllowSelfApprove Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.IsAllowSelfApprove Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the self approve is allowed on the time / expenses

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAllowSelfApprove { get; set; }
Visual Basic (Declaration)
Public Property IsAllowSelfApprove As Boolean
Visual C++
public:
property bool IsAllowSelfApprove {
    bool get ();
    void set (bool value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsAutoApprove Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.IsAutoApprove Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the Bulk Approve is allowed on the expenses

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAutoApprove { get; set; }
Visual Basic (Declaration)
Public Property IsAutoApprove As Boolean
Visual C++
public:
property bool IsAutoApprove {
    bool get ();
    void set (bool value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsBulkApprove Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.IsBulkApprove Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the Bulk Approve is allowed on the expenses

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsBulkApprove { get; set; }
Visual Basic (Declaration)
Public Property IsBulkApprove As Boolean
Visual C++
public:
property bool IsBulkApprove {
    bool get ();
    void set (bool value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsShowAttachment Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.IsShowAttachment Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the attachment needs to be shown

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowAttachment { get; set; }
Visual Basic (Declaration)
Public Property IsShowAttachment As Boolean
Visual C++
public:
property bool IsShowAttachment {
    bool get ();
    void set (bool value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsShowDetail Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.IsShowDetail Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the detail needs to be shown

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowDetail { get; set; }
Visual Basic (Declaration)
Public Property IsShowDetail As Boolean
Visual C++
public:
property bool IsShowDetail {
    bool get ();
    void set (bool value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsShowHistory Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.IsShowHistory Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the history needs to be shown

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowHistory { get; set; }
Visual Basic (Declaration)
Public Property IsShowHistory As Boolean
Visual C++
public:
property bool IsShowHistory {
    bool get ();
    void set (bool value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsShowPayments Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.IsShowPayments Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the Payment processing are to be shown in expenses (it is only shown to the administrator

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowPayments { get; set; }
Visual Basic (Declaration)
Public Property IsShowPayments As Boolean
Visual C++
public:
property bool IsShowPayments {
    bool get ();
    void set (bool value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsShowTotals Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.IsShowTotals Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the Totals are to be shown in time and expenses

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowTotals { get; set; }
Visual Basic (Declaration)
Public Property IsShowTotals As Boolean
Visual C++
public:
property bool IsShowTotals {
    bool get ();
    void set (bool value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


NumberOfRows Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.NumberOfRows Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Total number of rows

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumberOfRows { get; set; }
Visual Basic (Declaration)
Public Property NumberOfRows As Integer
Visual C++
public:
property int NumberOfRows {
    int get ();
    void set (int value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


NumberOfStartingPeriodBackward Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.NumberOfStartingPeriodBackward Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The total number of backward periods (in the future) that the timesheet can be created for

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumberOfStartingPeriodBackward { get; set; }
Visual Basic (Declaration)
Public Property NumberOfStartingPeriodBackward As Integer
Visual C++
public:
property int NumberOfStartingPeriodBackward {
    int get ();
    void set (int value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


NumberOfStartingPeriodForward Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.NumberOfStartingPeriodForward Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The total number of forward periods (in the future) that the timesheet can be created for

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumberOfStartingPeriodForward { get; set; }
Visual Basic (Declaration)
Public Property NumberOfStartingPeriodForward As Integer
Visual C++
public:
property int NumberOfStartingPeriodForward {
    int get ();
    void set (int value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProjectAlias Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.ProjectAlias Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

string value of the alias for project

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProjectAlias { get; set; }
Visual Basic (Declaration)
Public Property ProjectAlias As String
Visual C++
public:
property String^ ProjectAlias {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


WeekStartDay Property

[image]

OfficeClip API Documentation
ExpenseGroupProfile..::.WeekStartDay Property
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The start of the weekday

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DayOfWeek WeekStartDay { get; set; }
Visual Basic (Declaration)
Public Property WeekStartDay As DayOfWeek
Visual C++
public:
property DayOfWeek WeekStartDay {
    DayOfWeek get ();
    void set (DayOfWeek value);
}

See Also

ExpenseGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseUserEnum Enumeration

[image]

OfficeClip API Documentation
ExpenseUserEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for the user profile for expenses

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ExpenseUserEnum
Visual Basic (Declaration)
Public Enumeration ExpenseUserEnum
Visual C++
public enum class ExpenseUserEnum

Members

Member name | Description
ApplicationLastVisited | Application last visited time
ApplicationLastVisitedBackup | Application last visited time in the last session
IsThisGroupOnly | Show expense sheets for this group only

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseUserProfile Class

[image]

OfficeClip API Documentation
ExpenseUserProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the expense user profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ExpenseUserProfile : ProfileBase
Visual Basic (Declaration)
Public Class ExpenseUserProfile _
    Inherits ProfileBase
Visual C++
public ref class ExpenseUserProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.ExpenseUserProfile

See Also

ExpenseUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseUserProfile Members

[image] [image]

OfficeClip API Documentation
ExpenseUserProfile Members
ExpenseUserProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseUserProfile type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseUserProfile | Overloaded.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited | Copy Application Last VisitedBackup To ApplicationLastVisited
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | ApplicationLastVisited | application last visited
Public property | ApplicationLastVisitedBackup | application last visited backup
Public property | IsThisGroupOnly | Whether to show expense sheets for all groups

See Also

ExpenseUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseUserProfile Constructor

[image] [image]

OfficeClip API Documentation
ExpenseUserProfile Constructor
ExpenseUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpenseUserProfile()()() | Constructor
Public method | ExpenseUserProfile(String) | Constructor

See Also

ExpenseUserProfile Class
ExpenseUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseUserProfile Constructor

[image]

OfficeClip API Documentation
ExpenseUserProfile Constructor
ExpenseUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseUserProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseUserProfile()

See Also

ExpenseUserProfile Class
ExpenseUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseUserProfile Constructor (String)

[image]

OfficeClip API Documentation
ExpenseUserProfile Constructor (String)
ExpenseUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseUserProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
ExpenseUserProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

ExpenseUserProfile Class
ExpenseUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseUserProfile Methods

[image] [image]

OfficeClip API Documentation
ExpenseUserProfile Methods
ExpenseUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseUserProfile type exposes the following methods.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited | Copy Application Last VisitedBackup To ApplicationLastVisited
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpenseUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CopyApplicationLastVisitedBackupToApplicationLastVisited Method

[image]

OfficeClip API Documentation
ExpenseUserProfile..::.CopyApplicationLastVisitedBackupToApplicationLastVisited Method
ExpenseUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Copy Application Last VisitedBackup To ApplicationLastVisited

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyApplicationLastVisitedBackupToApplicationLastVisited()
Visual Basic (Declaration)
Public Sub CopyApplicationLastVisitedBackupToApplicationLastVisited
Visual C++
public:
void CopyApplicationLastVisitedBackupToApplicationLastVisited()

See Also

ExpenseUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
ExpenseUserProfile..::.GetBool Method
ExpenseUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

ExpenseUserProfile Class
ExpenseUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


ExpenseUserProfile Properties

[image] [image]

OfficeClip API Documentation
ExpenseUserProfile Properties
ExpenseUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseUserProfile type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationLastVisited | application last visited
Public property | ApplicationLastVisitedBackup | application last visited backup
Public property | IsThisGroupOnly | Whether to show expense sheets for all groups

See Also

ExpenseUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisited Property

[image]

OfficeClip API Documentation
ExpenseUserProfile..::.ApplicationLastVisited Property
ExpenseUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

application last visited

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisited { get; set; }
Visual Basic (Declaration)
Public Property ApplicationLastVisited As DateTime
Visual C++
public:
property DateTime ApplicationLastVisited {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisitedBackup Property

[image]

OfficeClip API Documentation
ExpenseUserProfile..::.ApplicationLastVisitedBackup Property
ExpenseUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

application last visited backup

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisitedBackup { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationLastVisitedBackup As DateTime
Visual C++
public:
property DateTime ApplicationLastVisitedBackup {
    DateTime get ();
}

See Also

ExpenseUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsThisGroupOnly Property

[image]

OfficeClip API Documentation
ExpenseUserProfile..::.IsThisGroupOnly Property
ExpenseUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether to show expense sheets for all groups

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsThisGroupOnly { get; set; }
Visual Basic (Declaration)
Public Property IsThisGroupOnly As Boolean
Visual C++
public:
property bool IsThisGroupOnly {
    bool get ();
    void set (bool value);
}

See Also

ExpenseUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GeneralUserEnum Enumeration

[image]

OfficeClip API Documentation
GeneralUserEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types for the general user profiles

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum GeneralUserEnum
Visual Basic (Declaration)
Public Enumeration GeneralUserEnum
Visual C++
public enum class GeneralUserEnum

Members

Member name | Description
UserTimezoneId | The unique id of the user timezone
LastAccessedGroupId | The last accessed group id
IsOfficeClipReadOnly | Is the OfficeClip access readonly
IsLeftBarMinimized | Is the left bar minimized
QuickHelpSupressList | The list of which quick help screen needs to be supressed
IsLeftBarVisible | Is the left bar visible
IsToolBarVisible | Is the toolbar visible
IsMenuBarPageType | Te type of the menubar (if it is hidden or popup)
LastVisitedApplicationId | The appliction that the user last visited

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


GeneralUserProfile Class

[image]

OfficeClip API Documentation
GeneralUserProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the general user profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class GeneralUserProfile : ProfileBase
Visual Basic (Declaration)
Public Class GeneralUserProfile _
    Inherits ProfileBase
Visual C++
public ref class GeneralUserProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.GeneralUserProfile

See Also

GeneralUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


GeneralUserProfile Members

[image] [image]

OfficeClip API Documentation
GeneralUserProfile Members
GeneralUserProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The GeneralUserProfile type exposes the following members.

Constructors

 | Name | Description
Public method | GeneralUserProfile | Overloaded.

Methods

 | Name | Description
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | IsLeftBarMinimized | Determines if the left bar is minimized
Public property | IsLeftBarVisible | Determines if the left bar is visible
Public property | IsMenuBarPageType | Determines if the menubar is page type
Public property | IsOfficeClipReadOnly | Determins if the OfficeClip instance is read only
Public property | IsToolBarVisible | Determines if the toolbar is visible
Public property | LastAccessedGroupId | The last access group id
Public property | LastVisitedApplicationId | The application id of the last visited application
Public property | QuickHelpSupressList | The quick help supress list, i.e. the list of toolbars that won't show quick help
Public property | UserTimezoneId | user timezone id

See Also

GeneralUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GeneralUserProfile Constructor

[image] [image]

OfficeClip API Documentation
GeneralUserProfile Constructor
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GeneralUserProfile()()() | Constructor
Public method | GeneralUserProfile(String) | Constructor

See Also

GeneralUserProfile Class
GeneralUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


GeneralUserProfile Constructor

[image]

OfficeClip API Documentation
GeneralUserProfile Constructor
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GeneralUserProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeneralUserProfile()

See Also

GeneralUserProfile Class
GeneralUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


GeneralUserProfile Constructor (String)

[image]

OfficeClip API Documentation
GeneralUserProfile Constructor (String)
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GeneralUserProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
GeneralUserProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

GeneralUserProfile Class
GeneralUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


GeneralUserProfile Properties

[image] [image]

OfficeClip API Documentation
GeneralUserProfile Properties
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The GeneralUserProfile type exposes the following properties.

Properties

 | Name | Description
Public property | IsLeftBarMinimized | Determines if the left bar is minimized
Public property | IsLeftBarVisible | Determines if the left bar is visible
Public property | IsMenuBarPageType | Determines if the menubar is page type
Public property | IsOfficeClipReadOnly | Determins if the OfficeClip instance is read only
Public property | IsToolBarVisible | Determines if the toolbar is visible
Public property | LastAccessedGroupId | The last access group id
Public property | LastVisitedApplicationId | The application id of the last visited application
Public property | QuickHelpSupressList | The quick help supress list, i.e. the list of toolbars that won't show quick help
Public property | UserTimezoneId | user timezone id

See Also

GeneralUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsLeftBarMinimized Property

[image]

OfficeClip API Documentation
GeneralUserProfile..::.IsLeftBarMinimized Property
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the left bar is minimized

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsLeftBarMinimized { get; set; }
Visual Basic (Declaration)
Public Property IsLeftBarMinimized As Boolean
Visual C++
public:
property bool IsLeftBarMinimized {
    bool get ();
    void set (bool value);
}

See Also

GeneralUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsLeftBarVisible Property

[image]

OfficeClip API Documentation
GeneralUserProfile..::.IsLeftBarVisible Property
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the left bar is visible

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsLeftBarVisible { get; set; }
Visual Basic (Declaration)
Public Property IsLeftBarVisible As Boolean
Visual C++
public:
property bool IsLeftBarVisible {
    bool get ();
    void set (bool value);
}

See Also

GeneralUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsMenuBarPageType Property

[image]

OfficeClip API Documentation
GeneralUserProfile..::.IsMenuBarPageType Property
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the menubar is page type

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsMenuBarPageType { get; set; }
Visual Basic (Declaration)
Public Property IsMenuBarPageType As Boolean
Visual C++
public:
property bool IsMenuBarPageType {
    bool get ();
    void set (bool value);
}

See Also

GeneralUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsOfficeClipReadOnly Property

[image]

OfficeClip API Documentation
GeneralUserProfile..::.IsOfficeClipReadOnly Property
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Determins if the OfficeClip instance is read only

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsOfficeClipReadOnly { get; set; }
Visual Basic (Declaration)
Public Property IsOfficeClipReadOnly As Boolean
Visual C++
public:
property bool IsOfficeClipReadOnly {
    bool get ();
    void set (bool value);
}

See Also

GeneralUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsToolBarVisible Property

[image]

OfficeClip API Documentation
GeneralUserProfile..::.IsToolBarVisible Property
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the toolbar is visible

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsToolBarVisible { get; set; }
Visual Basic (Declaration)
Public Property IsToolBarVisible As Boolean
Visual C++
public:
property bool IsToolBarVisible {
    bool get ();
    void set (bool value);
}

See Also

GeneralUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


LastAccessedGroupId Property

[image]

OfficeClip API Documentation
GeneralUserProfile..::.LastAccessedGroupId Property
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The last access group id

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LastAccessedGroupId { get; set; }
Visual Basic (Declaration)
Public Property LastAccessedGroupId As Integer
Visual C++
public:
property int LastAccessedGroupId {
    int get ();
    void set (int value);
}

See Also

GeneralUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


LastVisitedApplicationId Property

[image]

OfficeClip API Documentation
GeneralUserProfile..::.LastVisitedApplicationId Property
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The application id of the last visited application

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LastVisitedApplicationId { get; set; }
Visual Basic (Declaration)
Public Property LastVisitedApplicationId As Integer
Visual C++
public:
property int LastVisitedApplicationId {
    int get ();
    void set (int value);
}

See Also

GeneralUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


QuickHelpSupressList Property

[image]

OfficeClip API Documentation
GeneralUserProfile..::.QuickHelpSupressList Property
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The quick help supress list, i.e. the list of toolbars that won't show quick help

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string QuickHelpSupressList { get; set; }
Visual Basic (Declaration)
Public Property QuickHelpSupressList As String
Visual C++
public:
property String^ QuickHelpSupressList {
    String^ get ();
    void set (String^ value);
}

See Also

GeneralUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


UserTimezoneId Property

[image]

OfficeClip API Documentation
GeneralUserProfile..::.UserTimezoneId Property
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

user timezone id

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserTimezoneId { get; set; }
Visual Basic (Declaration)
Public Property UserTimezoneId As Integer
Visual C++
public:
property int UserTimezoneId {
    int get ();
    void set (int value);
}

See Also

GeneralUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProfileBase Class

[image]

OfficeClip API Documentation
ProfileBase Class
Members See Also

[This is preliminary documentation and is subject to change.]

The base class for user and group profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ProfileBase
Visual Basic (Declaration)
Public Class ProfileBase
Visual C++
public ref class ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.PunchClockGroupProfile
OfficeClip.BusinessLayer.Framework.Profile..::.CalendarGroupProfile
OfficeClip.BusinessLayer.Framework.Profile..::.TrackerUserProfile
OfficeClip.BusinessLayer.Framework.Profile..::.PunchClockUserProfile
OfficeClip.BusinessLayer.Framework.Profile..::.BulletinBoardUserProfile
OfficeClip.BusinessLayer.Framework.Profile..::.ExpenseGroupProfile
OfficeClip.BusinessLayer.Framework.Profile..::.GeneralUserProfile
OfficeClip.BusinessLayer.Framework.Profile..::.ExpenseUserProfile
OfficeClip.BusinessLayer.Framework.Profile..::.TimesheetGroupProfile
OfficeClip.BusinessLayer.Framework.Profile..::.DocumentUserProfile
OfficeClip.BusinessLayer.Framework.Profile..::.TimesheetUserProfile
OfficeClip.BusinessLayer.Framework.Profile..::.CalendarUserProfile

See Also

ProfileBase Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProfileBase Members

[image] [image]

OfficeClip API Documentation
ProfileBase Members
ProfileBase Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The ProfileBase type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileBase | Overloaded.

Methods

 | Name | Description
Protected method | EnumSize | Size of the enumerated type
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property
Protected method | GetDateTime | Gets the datetime of a property
Protected method | GetDayOfWeek | Gets the Day of week value of the property
Protected method | GetDouble | Gets the integer value of the profile property
Protected method | GetEventShowAs | Gets the Event Show As value of the property
Protected method | GetEventType | Sets the event show as value of the property
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property
Protected method | GetString | Gets the string representation of the profile property
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile
Protected method | SetBool | Sets the boolean value of the property
Protected method | SetCalendarView | Sets the calendar view
Protected method | SetDateTime | Sets the datetime of the property
Protected method | SetDayOfWeek | Sets the day of week value of the property
Protected method | SetDouble | Sets the integer value of the property
Protected method | SetEventShowAs | Sets the event show as value of the poperty
Protected method | SetEventType | Sets the event type
Protected method | SetGroupSelection | Sets the group selection to the value passed
Protected method | SetInt | Sets the integer value of the property
Protected method | SetString | Sets the string value of the profile property
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProfileBase Constructor

[image] [image]

OfficeClip API Documentation
ProfileBase Constructor
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ProfileBase(Type) | Constructor
Public method | ProfileBase(String, Type) | Constructor

See Also

ProfileBase Class
ProfileBase Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProfileBase Constructor (Type)

[image]

OfficeClip API Documentation
ProfileBase Constructor (Type)
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ProfileBase(
    Type type
)
Visual Basic (Declaration)
Public Sub New ( _
    type As Type _
)
Visual C++
public:
ProfileBase(
    Type^ type
)

Parameters

type
Type: System..::.Type

See Also

ProfileBase Class
ProfileBase Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProfileBase Constructor (String, Type)

[image]

OfficeClip API Documentation
ProfileBase Constructor (String, Type)
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ProfileBase(
    string serialized,
    Type type
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String, _
    type As Type _
)
Visual C++
public:
ProfileBase(
    String^ serialized,
    Type^ type
)

Parameters

serialized
Type: System..::.String
type
Type: System..::.Type

See Also

ProfileBase Class
ProfileBase Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProfileBase Fields

[image] [image]

OfficeClip API Documentation
ProfileBase Fields
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

The ProfileBase type exposes the following fields.

Fields

 | Name | Description
Protected field | props | List of properties

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


props Field

[image]

OfficeClip API Documentation
ProfileBase..::.props Field
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

List of properties

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected List<string> props
Visual Basic (Declaration)
Protected props As List(Of String)
Visual C++
protected:
List<String^>^ props

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProfileBase Methods

[image] [image]

OfficeClip API Documentation
ProfileBase Methods
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

The ProfileBase type exposes the following methods.

Methods

 | Name | Description
Protected method | EnumSize | Size of the enumerated type
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property
Protected method | GetDateTime | Gets the datetime of a property
Protected method | GetDayOfWeek | Gets the Day of week value of the property
Protected method | GetDouble | Gets the integer value of the profile property
Protected method | GetEventShowAs | Gets the Event Show As value of the property
Protected method | GetEventType | Sets the event show as value of the property
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property
Protected method | GetString | Gets the string representation of the profile property
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile
Protected method | SetBool | Sets the boolean value of the property
Protected method | SetCalendarView | Sets the calendar view
Protected method | SetDateTime | Sets the datetime of the property
Protected method | SetDayOfWeek | Sets the day of week value of the property
Protected method | SetDouble | Sets the integer value of the property
Protected method | SetEventShowAs | Sets the event show as value of the poperty
Protected method | SetEventType | Sets the event type
Protected method | SetGroupSelection | Sets the group selection to the value passed
Protected method | SetInt | Sets the integer value of the property
Protected method | SetString | Sets the string value of the profile property
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


EnumSize Method

[image]

OfficeClip API Documentation
ProfileBase..::.EnumSize Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Size of the enumerated type

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int EnumSize(
    Type type
)
Visual Basic (Declaration)
Protected Function EnumSize ( _
    type As Type _
) As Integer
Visual C++
protected:
int EnumSize(
    Type^ type
)

Parameters

type
Type: System..::.Type

Return Value

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
ProfileBase..::.GetBool Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value

See Also

ProfileBase Class
ProfileBase Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method (Int32)

[image]

OfficeClip API Documentation
ProfileBase..::.GetBool Method (Int32)
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Gets the boolean value of the property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected bool GetBool(
    int index
)
Visual Basic (Declaration)
Protected Function GetBool ( _
    index As Integer _
) As Boolean
Visual C++
protected:
bool GetBool(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the property

Return Value

The value of the property

See Also

ProfileBase Class
GetBool Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method (Int32, Boolean)

[image]

OfficeClip API Documentation
ProfileBase..::.GetBool Method (Int32, Boolean)
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Gets the boolean value of the property with a default value

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected bool GetBool(
    int index,
    bool defaultValue
)
Visual Basic (Declaration)
Protected Function GetBool ( _
    index As Integer, _
    defaultValue As Boolean _
) As Boolean
Visual C++
protected:
bool GetBool(
    int index,
    bool defaultValue
)

Parameters

index
Type: System..::.Int32
The index of the property
defaultValue
Type: System..::.Boolean
The default value if the string at the index is empty

Return Value

The value of the property

See Also

ProfileBase Class
GetBool Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetCalendarView Method

[image]

OfficeClip API Documentation
ProfileBase..::.GetCalendarView Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Gets the calendar view for a property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected CalendarView GetCalendarView(
    int index
)
Visual Basic (Declaration)
Protected Function GetCalendarView ( _
    index As Integer _
) As CalendarView
Visual C++
protected:
CalendarView GetCalendarView(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the property

Return Value

The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetDateTime Method

[image]

OfficeClip API Documentation
ProfileBase..::.GetDateTime Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Gets the datetime of a property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected DateTime GetDateTime(
    int index
)
Visual Basic (Declaration)
Protected Function GetDateTime ( _
    index As Integer _
) As DateTime
Visual C++
protected:
DateTime GetDateTime(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the property

Return Value

Te datetime property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetDayOfWeek Method

[image]

OfficeClip API Documentation
ProfileBase..::.GetDayOfWeek Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Day of week value of the property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected DayOfWeek GetDayOfWeek(
    int index
)
Visual Basic (Declaration)
Protected Function GetDayOfWeek ( _
    index As Integer _
) As DayOfWeek
Visual C++
protected:
DayOfWeek GetDayOfWeek(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the property

Return Value

The Day of week value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetDouble Method

[image]

OfficeClip API Documentation
ProfileBase..::.GetDouble Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Gets the integer value of the profile property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected double GetDouble(
    int index
)
Visual Basic (Declaration)
Protected Function GetDouble ( _
    index As Integer _
) As Double
Visual C++
protected:
double GetDouble(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the property

Return Value

The integer value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetEventShowAs Method

[image]

OfficeClip API Documentation
ProfileBase..::.GetEventShowAs Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Event Show As value of the property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected EventShowAs GetEventShowAs(
    int index
)
Visual Basic (Declaration)
Protected Function GetEventShowAs ( _
    index As Integer _
) As EventShowAs
Visual C++
protected:
EventShowAs GetEventShowAs(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the property

Return Value

The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetEventType Method

[image]

OfficeClip API Documentation
ProfileBase..::.GetEventType Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Sets the event show as value of the property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected EventType GetEventType(
    int index
)
Visual Basic (Declaration)
Protected Function GetEventType ( _
    index As Integer _
) As EventType
Visual C++
protected:
EventType GetEventType(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the property

Return Value

The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetGroupSelection Method

[image]

OfficeClip API Documentation
ProfileBase..::.GetGroupSelection Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Gets the grouyp selection. By default it returns the current group

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected GroupSelection GetGroupSelection(
    int index
)
Visual Basic (Declaration)
Protected Function GetGroupSelection ( _
    index As Integer _
) As GroupSelection
Visual C++
protected:
GroupSelection GetGroupSelection(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the property

Return Value

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetInt Method

[image]

OfficeClip API Documentation
ProfileBase..::.GetInt Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Gets the integer value of the profile property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected int GetInt(
    int index
)
Visual Basic (Declaration)
Protected Function GetInt ( _
    index As Integer _
) As Integer
Visual C++
protected:
int GetInt(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the property

Return Value

The integer value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetString Method

[image]

OfficeClip API Documentation
ProfileBase..::.GetString Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Gets the string representation of the profile property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetString(
    int index
)
Visual Basic (Declaration)
Protected Function GetString ( _
    index As Integer _
) As String
Visual C++
protected:
String^ GetString(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the property

Return Value

The string value of the profile property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


Serialize Method

[image]

OfficeClip API Documentation
ProfileBase..::.Serialize Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

The serialized profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Serialize()
Visual Basic (Declaration)
Public Function Serialize As String
Visual C++
public:
String^ Serialize()

Return Value

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


SetBool Method

[image]

OfficeClip API Documentation
ProfileBase..::.SetBool Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Sets the boolean value of the property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetBool(
    int index,
    bool value
)
Visual Basic (Declaration)
Protected Sub SetBool ( _
    index As Integer, _
    value As Boolean _
)
Visual C++
protected:
void SetBool(
    int index,
    bool value
)

Parameters

index
Type: System..::.Int32
The index of the property
value
Type: System..::.Boolean
The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


SetCalendarView Method

[image]

OfficeClip API Documentation
ProfileBase..::.SetCalendarView Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Sets the calendar view

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetCalendarView(
    int index,
    CalendarView value
)
Visual Basic (Declaration)
Protected Sub SetCalendarView ( _
    index As Integer, _
    value As CalendarView _
)
Visual C++
protected:
void SetCalendarView(
    int index,
    CalendarView value
)

Parameters

index
Type: System..::.Int32
The index of the property
value
Type: OfficeClip.Utils..::.CalendarView
The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


SetDateTime Method

[image]

OfficeClip API Documentation
ProfileBase..::.SetDateTime Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Sets the datetime of the property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetDateTime(
    int index,
    DateTime value
)
Visual Basic (Declaration)
Protected Sub SetDateTime ( _
    index As Integer, _
    value As DateTime _
)
Visual C++
protected:
void SetDateTime(
    int index,
    DateTime value
)

Parameters

index
Type: System..::.Int32
The index of the property
value
Type: System..::.DateTime
The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


SetDayOfWeek Method

[image]

OfficeClip API Documentation
ProfileBase..::.SetDayOfWeek Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Sets the day of week value of the property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetDayOfWeek(
    int index,
    DayOfWeek value
)
Visual Basic (Declaration)
Protected Sub SetDayOfWeek ( _
    index As Integer, _
    value As DayOfWeek _
)
Visual C++
protected:
void SetDayOfWeek(
    int index,
    DayOfWeek value
)

Parameters

index
Type: System..::.Int32
The index of the property
value
Type: System..::.DayOfWeek
The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


SetDouble Method

[image]

OfficeClip API Documentation
ProfileBase..::.SetDouble Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Sets the integer value of the property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetDouble(
    int index,
    double value
)
Visual Basic (Declaration)
Protected Sub SetDouble ( _
    index As Integer, _
    value As Double _
)
Visual C++
protected:
void SetDouble(
    int index,
    double value
)

Parameters

index
Type: System..::.Int32
The index value of the property
value
Type: System..::.Double
The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


SetEventShowAs Method

[image]

OfficeClip API Documentation
ProfileBase..::.SetEventShowAs Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Sets the event show as value of the poperty

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetEventShowAs(
    int index,
    EventShowAs value
)
Visual Basic (Declaration)
Protected Sub SetEventShowAs ( _
    index As Integer, _
    value As EventShowAs _
)
Visual C++
protected:
void SetEventShowAs(
    int index,
    EventShowAs value
)

Parameters

index
Type: System..::.Int32
The index of the property
value
Type: OfficeClip.Utils..::.EventShowAs
The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


SetEventType Method

[image]

OfficeClip API Documentation
ProfileBase..::.SetEventType Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Sets the event type

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetEventType(
    int index,
    EventType value
)
Visual Basic (Declaration)
Protected Sub SetEventType ( _
    index As Integer, _
    value As EventType _
)
Visual C++
protected:
void SetEventType(
    int index,
    EventType value
)

Parameters

index
Type: System..::.Int32
The index of the property
value
Type: OfficeClip.Utils..::.EventType
The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


SetGroupSelection Method

[image]

OfficeClip API Documentation
ProfileBase..::.SetGroupSelection Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Sets the group selection to the value passed

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetGroupSelection(
    int index,
    GroupSelection value
)
Visual Basic (Declaration)
Protected Sub SetGroupSelection ( _
    index As Integer, _
    value As GroupSelection _
)
Visual C++
protected:
void SetGroupSelection(
    int index,
    GroupSelection value
)

Parameters

index
Type: System..::.Int32
The index of the property
value
Type: OfficeClip.Utils..::.GroupSelection
The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


SetInt Method

[image]

OfficeClip API Documentation
ProfileBase..::.SetInt Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Sets the integer value of the property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetInt(
    int index,
    int value
)
Visual Basic (Declaration)
Protected Sub SetInt ( _
    index As Integer, _
    value As Integer _
)
Visual C++
protected:
void SetInt(
    int index,
    int value
)

Parameters

index
Type: System..::.Int32
The index value of the property
value
Type: System..::.Int32
The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


SetString Method

[image]

OfficeClip API Documentation
ProfileBase..::.SetString Method
ProfileBase Class See Also

[This is preliminary documentation and is subject to change.]

Sets the string value of the profile property

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetString(
    int index,
    string value
)
Visual Basic (Declaration)
Protected Sub SetString ( _
    index As Integer, _
    value As String _
)
Visual C++
protected:
void SetString(
    int index,
    String^ value
)

Parameters

index
Type: System..::.Int32
The index of the property
value
Type: System..::.String
The value of the property

See Also

ProfileBase Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProfileHttpContext Class

[image]

OfficeClip API Documentation
ProfileHttpContext Class
Members See Also

[This is preliminary documentation and is subject to change.]

The http profile context

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ProfileHttpContext
Visual Basic (Declaration)
Public Class ProfileHttpContext
Visual C++
public ref class ProfileHttpContext

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileHttpContext

See Also

ProfileHttpContext Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProfileHttpContext Members

[image] [image]

OfficeClip API Documentation
ProfileHttpContext Members
ProfileHttpContext Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ProfileHttpContext type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileHttpContext |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AType | The application type
Public property | GroupId | The unique id of the group
Public property | Profile | The profile string
Public property | UserId | The unique id of the user

See Also

ProfileHttpContext Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProfileHttpContext Constructor

[image]

OfficeClip API Documentation
ProfileHttpContext Constructor
ProfileHttpContext Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ProfileHttpContext()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProfileHttpContext()

See Also

ProfileHttpContext Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProfileHttpContext Properties

[image] [image]

OfficeClip API Documentation
ProfileHttpContext Properties
ProfileHttpContext Class See Also

[This is preliminary documentation and is subject to change.]

The ProfileHttpContext type exposes the following properties.

Properties

 | Name | Description
Public property | AType | The application type
Public property | GroupId | The unique id of the group
Public property | Profile | The profile string
Public property | UserId | The unique id of the user

See Also

ProfileHttpContext Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


AType Property

[image]

OfficeClip API Documentation
ProfileHttpContext..::.AType Property
ProfileHttpContext Class See Also

[This is preliminary documentation and is subject to change.]

The application type

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Constants..::.ApplicationType AType { get; set; }
Visual Basic (Declaration)
Public Property AType As Constants..::.ApplicationType
Visual C++
public:
property Constants..::.ApplicationType AType {
    Constants..::.ApplicationType get ();
    void set (Constants..::.ApplicationType value);
}

See Also

ProfileHttpContext Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GroupId Property

[image]

OfficeClip API Documentation
ProfileHttpContext..::.GroupId Property
ProfileHttpContext Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the group

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

ProfileHttpContext Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


Profile Property

[image]

OfficeClip API Documentation
ProfileHttpContext..::.Profile Property
ProfileHttpContext Class See Also

[This is preliminary documentation and is subject to change.]

The profile string

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Profile { get; set; }
Visual Basic (Declaration)
Public Property Profile As String
Visual C++
public:
property String^ Profile {
    String^ get ();
    void set (String^ value);
}

See Also

ProfileHttpContext Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


UserId Property

[image]

OfficeClip API Documentation
ProfileHttpContext..::.UserId Property
ProfileHttpContext Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

ProfileHttpContext Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockGroupEnum Enumeration

[image]

OfficeClip API Documentation
PunchClockGroupEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for the group profile for punch clock

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum PunchClockGroupEnum
Visual Basic (Declaration)
Public Enumeration PunchClockGroupEnum
Visual C++
public enum class PunchClockGroupEnum

Members

Member name | Description
IsAllowMemberEdit | Allows members to edit their own punch clock
IsShowHistory | Show history on the punch edit screen

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockGroupProfile Class

[image]

OfficeClip API Documentation
PunchClockGroupProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

Punch Clock Group Profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class PunchClockGroupProfile : ProfileBase
Visual Basic (Declaration)
Public Class PunchClockGroupProfile _
    Inherits ProfileBase
Visual C++
public ref class PunchClockGroupProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.PunchClockGroupProfile

See Also

PunchClockGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockGroupProfile Members

[image] [image]

OfficeClip API Documentation
PunchClockGroupProfile Members
PunchClockGroupProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The PunchClockGroupProfile type exposes the following members.

Constructors

 | Name | Description
Public method | PunchClockGroupProfile | Overloaded.

Methods

 | Name | Description
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | IsAllowMemberEdit | Whether the members will be allowed to edit the puched entries
Public property | IsShowHistory | Whether the history will be shown on the viewedit screen

See Also

PunchClockGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockGroupProfile Constructor

[image] [image]

OfficeClip API Documentation
PunchClockGroupProfile Constructor
PunchClockGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PunchClockGroupProfile()()() | Constructor
Public method | PunchClockGroupProfile(String) | Constructor

See Also

PunchClockGroupProfile Class
PunchClockGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockGroupProfile Constructor

[image]

OfficeClip API Documentation
PunchClockGroupProfile Constructor
PunchClockGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchClockGroupProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PunchClockGroupProfile()

See Also

PunchClockGroupProfile Class
PunchClockGroupProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockGroupProfile Constructor (String)

[image]

OfficeClip API Documentation
PunchClockGroupProfile Constructor (String)
PunchClockGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchClockGroupProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
PunchClockGroupProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

PunchClockGroupProfile Class
PunchClockGroupProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockGroupProfile Properties

[image] [image]

OfficeClip API Documentation
PunchClockGroupProfile Properties
PunchClockGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The PunchClockGroupProfile type exposes the following properties.

Properties

 | Name | Description
Public property | IsAllowMemberEdit | Whether the members will be allowed to edit the puched entries
Public property | IsShowHistory | Whether the history will be shown on the viewedit screen

See Also

PunchClockGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsAllowMemberEdit Property

[image]

OfficeClip API Documentation
PunchClockGroupProfile..::.IsAllowMemberEdit Property
PunchClockGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the members will be allowed to edit the puched entries

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAllowMemberEdit { get; set; }
Visual Basic (Declaration)
Public Property IsAllowMemberEdit As Boolean
Visual C++
public:
property bool IsAllowMemberEdit {
    bool get ();
    void set (bool value);
}

See Also

PunchClockGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsShowHistory Property

[image]

OfficeClip API Documentation
PunchClockGroupProfile..::.IsShowHistory Property
PunchClockGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the history will be shown on the viewedit screen

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowHistory { get; set; }
Visual Basic (Declaration)
Public Property IsShowHistory As Boolean
Visual C++
public:
property bool IsShowHistory {
    bool get ();
    void set (bool value);
}

See Also

PunchClockGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockUserEnum Enumeration

[image]

OfficeClip API Documentation
PunchClockUserEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for the user profile for punch clock

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum PunchClockUserEnum
Visual Basic (Declaration)
Public Enumeration PunchClockUserEnum
Visual C++
public enum class PunchClockUserEnum

Members

Member name | Description
ApplicationLastVisited | Application last visited time
ApplicationLastVisitedBackup | Application last visited time in the last session

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockUserProfile Class

[image]

OfficeClip API Documentation
PunchClockUserProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the punch clock user profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class PunchClockUserProfile : ProfileBase
Visual Basic (Declaration)
Public Class PunchClockUserProfile _
    Inherits ProfileBase
Visual C++
public ref class PunchClockUserProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.PunchClockUserProfile

See Also

PunchClockUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockUserProfile Members

[image] [image]

OfficeClip API Documentation
PunchClockUserProfile Members
PunchClockUserProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The PunchClockUserProfile type exposes the following members.

Constructors

 | Name | Description
Public method | PunchClockUserProfile | Overloaded.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited | Copy Application Last VisitedBackup To ApplicationLastVisited
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | ApplicationLastVisited | application last visited
Public property | ApplicationLastVisitedBackup | application last visited backup

See Also

PunchClockUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockUserProfile Constructor

[image] [image]

OfficeClip API Documentation
PunchClockUserProfile Constructor
PunchClockUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PunchClockUserProfile()()() | Constructor
Public method | PunchClockUserProfile(String) | Constructor

See Also

PunchClockUserProfile Class
PunchClockUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockUserProfile Constructor

[image]

OfficeClip API Documentation
PunchClockUserProfile Constructor
PunchClockUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchClockUserProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PunchClockUserProfile()

See Also

PunchClockUserProfile Class
PunchClockUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockUserProfile Constructor (String)

[image]

OfficeClip API Documentation
PunchClockUserProfile Constructor (String)
PunchClockUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchClockUserProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
PunchClockUserProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

PunchClockUserProfile Class
PunchClockUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockUserProfile Methods

[image] [image]

OfficeClip API Documentation
PunchClockUserProfile Methods
PunchClockUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The PunchClockUserProfile type exposes the following methods.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited | Copy Application Last VisitedBackup To ApplicationLastVisited
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PunchClockUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CopyApplicationLastVisitedBackupToApplicationLastVisited Method

[image]

OfficeClip API Documentation
PunchClockUserProfile..::.CopyApplicationLastVisitedBackupToApplicationLastVisited Method
PunchClockUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Copy Application Last VisitedBackup To ApplicationLastVisited

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyApplicationLastVisitedBackupToApplicationLastVisited()
Visual Basic (Declaration)
Public Sub CopyApplicationLastVisitedBackupToApplicationLastVisited
Visual C++
public:
void CopyApplicationLastVisitedBackupToApplicationLastVisited()

See Also

PunchClockUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
PunchClockUserProfile..::.GetBool Method
PunchClockUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

PunchClockUserProfile Class
PunchClockUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


PunchClockUserProfile Properties

[image] [image]

OfficeClip API Documentation
PunchClockUserProfile Properties
PunchClockUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The PunchClockUserProfile type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationLastVisited | application last visited
Public property | ApplicationLastVisitedBackup | application last visited backup

See Also

PunchClockUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisited Property

[image]

OfficeClip API Documentation
PunchClockUserProfile..::.ApplicationLastVisited Property
PunchClockUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

application last visited

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisited { get; set; }
Visual Basic (Declaration)
Public Property ApplicationLastVisited As DateTime
Visual C++
public:
property DateTime ApplicationLastVisited {
    DateTime get ();
    void set (DateTime value);
}

See Also

PunchClockUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisitedBackup Property

[image]

OfficeClip API Documentation
PunchClockUserProfile..::.ApplicationLastVisitedBackup Property
PunchClockUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

application last visited backup

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisitedBackup { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationLastVisitedBackup As DateTime
Visual C++
public:
property DateTime ApplicationLastVisitedBackup {
    DateTime get ();
}

See Also

PunchClockUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetGroupEnum Enumeration

[image]

OfficeClip API Documentation
TimesheetGroupEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumeration for the group profile for timesheet

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum TimesheetGroupEnum
Visual Basic (Declaration)
Public Enumeration TimesheetGroupEnum
Visual C++
public enum class TimesheetGroupEnum

Members

Member name | Description
ShowPayroll | Show payroll on the new/edit timesheet screen
ShowHistory | Show timesheet history
AllowSelfApprove | Allow timesheet to be approved by the creator
NumberOfRows | Default number of rows for the timesheet
WeekStartDay | Te week start day for the timesheet
ShowDetail | Show the detail link for the hours on the timesheet
ShowAttachment | Whether the attachment can be added to the timesheet
ColonBased | If the duration should be represented as colon based (:) or decimal (.)
ShowTotals | Shows the totals of each rows and column
ServiceItemAlias | Alias for the service item
AccountAlias | Alias for the account
ProjectAlias | Alias for the project
DCAA | If the DCAA tracking is acivated, when activated DCAA tracking foces users to enter a note for each changes and shows detail timesheet modification history.
NumberOfStartingPeriodForward | The total number of forward periods (in the future) that the timesheet can be created for
NumberOfStartingPeriodBackward | The total number of backward periods (in the past) that the timesheet can be created for
ProxyEnabled | Shows whether the proxy feature is enabled
BulkApprove | Shows whether the Bulk Approval feature is enabled
AutoApprove | Shows whether the Auto Approval feature is enabled
TimesheetHeader | Timesheet Header
TimesheetFooter | Timesheet Footer

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetGroupProfile Class

[image]

OfficeClip API Documentation
TimesheetGroupProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the timesheet group profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TimesheetGroupProfile : ProfileBase
Visual Basic (Declaration)
Public Class TimesheetGroupProfile _
    Inherits ProfileBase
Visual C++
public ref class TimesheetGroupProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.TimesheetGroupProfile

See Also

TimesheetGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetGroupProfile Members

[image] [image]

OfficeClip API Documentation
TimesheetGroupProfile Members
TimesheetGroupProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The TimesheetGroupProfile type exposes the following members.

Constructors

 | Name | Description
Public method | TimesheetGroupProfile | Overloaded.

Methods

 | Name | Description
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | AccountAlias | string value of the alias for the account
Public property | IsAllowProxy | Whether the proxy feature is enabled
Public property | IsAllowSelfApprove | Whether the self approve is allowed on the time / expenses
Public property | IsAutoApprove | Whether the Auto Approve is allowed on the timesheets
Public property | IsBulkApprove | Whether the Bulk Approve is allowed on the timesheets
Public property | IsColonBased | Whether the timesheet time is shown as hh:mm or hh.mm
Public property | IsDCAA | True if the dcaa tracking is activated, under DCAA tracking all changes are recorded and the comments are mandatory when a timesheet is edited.
Public property | IsShowAttachment | Whether the attachment needs to be shown
Public property | IsShowDetail | Whether the detail needs to be shown
Public property | IsShowHistory | Whether the history needs to be shown
Public property | IsShowPayroll | Whether the Totals are to be shown in time and expenses
Public property | IsShowTotals | Whether the Totals are to be shown in time and expenses
Public property | NumberOfRows | Total number of rows
Public property | NumberOfStartingPeriodBackward | The total number of backward periods (in the future) that the timesheet can be created for
Public property | NumberOfStartingPeriodForward | The total number of forward periods (in the future) that the timesheet can be created for
Public property | ProjectAlias | string value of the alias for project
Public property | ServiceItemAlias | string value of the alias for service item
Public property | TimesheetFooter | Timesheet Footer
Public property | TimesheetHeader | Timesheet Header
Public property | WeekStartDay | The start of the weekday

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetGroupProfile Constructor

[image] [image]

OfficeClip API Documentation
TimesheetGroupProfile Constructor
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TimesheetGroupProfile()()() | Constructor
Public method | TimesheetGroupProfile(String) | Constructor

See Also

TimesheetGroupProfile Class
TimesheetGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetGroupProfile Constructor

[image]

OfficeClip API Documentation
TimesheetGroupProfile Constructor
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetGroupProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimesheetGroupProfile()

See Also

TimesheetGroupProfile Class
TimesheetGroupProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetGroupProfile Constructor (String)

[image]

OfficeClip API Documentation
TimesheetGroupProfile Constructor (String)
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetGroupProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
TimesheetGroupProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

TimesheetGroupProfile Class
TimesheetGroupProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetGroupProfile Properties

[image] [image]

OfficeClip API Documentation
TimesheetGroupProfile Properties
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetGroupProfile type exposes the following properties.

Properties

 | Name | Description
Public property | AccountAlias | string value of the alias for the account
Public property | IsAllowProxy | Whether the proxy feature is enabled
Public property | IsAllowSelfApprove | Whether the self approve is allowed on the time / expenses
Public property | IsAutoApprove | Whether the Auto Approve is allowed on the timesheets
Public property | IsBulkApprove | Whether the Bulk Approve is allowed on the timesheets
Public property | IsColonBased | Whether the timesheet time is shown as hh:mm or hh.mm
Public property | IsDCAA | True if the dcaa tracking is activated, under DCAA tracking all changes are recorded and the comments are mandatory when a timesheet is edited.
Public property | IsShowAttachment | Whether the attachment needs to be shown
Public property | IsShowDetail | Whether the detail needs to be shown
Public property | IsShowHistory | Whether the history needs to be shown
Public property | IsShowPayroll | Whether the Totals are to be shown in time and expenses
Public property | IsShowTotals | Whether the Totals are to be shown in time and expenses
Public property | NumberOfRows | Total number of rows
Public property | NumberOfStartingPeriodBackward | The total number of backward periods (in the future) that the timesheet can be created for
Public property | NumberOfStartingPeriodForward | The total number of forward periods (in the future) that the timesheet can be created for
Public property | ProjectAlias | string value of the alias for project
Public property | ServiceItemAlias | string value of the alias for service item
Public property | TimesheetFooter | Timesheet Footer
Public property | TimesheetHeader | Timesheet Header
Public property | WeekStartDay | The start of the weekday

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


AccountAlias Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.AccountAlias Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

string value of the alias for the account

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AccountAlias { get; set; }
Visual Basic (Declaration)
Public Property AccountAlias As String
Visual C++
public:
property String^ AccountAlias {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsAllowProxy Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.IsAllowProxy Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the proxy feature is enabled

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAllowProxy { get; set; }
Visual Basic (Declaration)
Public Property IsAllowProxy As Boolean
Visual C++
public:
property bool IsAllowProxy {
    bool get ();
    void set (bool value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsAllowSelfApprove Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.IsAllowSelfApprove Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the self approve is allowed on the time / expenses

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAllowSelfApprove { get; set; }
Visual Basic (Declaration)
Public Property IsAllowSelfApprove As Boolean
Visual C++
public:
property bool IsAllowSelfApprove {
    bool get ();
    void set (bool value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsAutoApprove Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.IsAutoApprove Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the Auto Approve is allowed on the timesheets

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAutoApprove { get; set; }
Visual Basic (Declaration)
Public Property IsAutoApprove As Boolean
Visual C++
public:
property bool IsAutoApprove {
    bool get ();
    void set (bool value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsBulkApprove Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.IsBulkApprove Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the Bulk Approve is allowed on the timesheets

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsBulkApprove { get; set; }
Visual Basic (Declaration)
Public Property IsBulkApprove As Boolean
Visual C++
public:
property bool IsBulkApprove {
    bool get ();
    void set (bool value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsColonBased Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.IsColonBased Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the timesheet time is shown as hh:mm or hh.mm

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsColonBased { get; set; }
Visual Basic (Declaration)
Public Property IsColonBased As Boolean
Visual C++
public:
property bool IsColonBased {
    bool get ();
    void set (bool value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsDCAA Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.IsDCAA Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

True if the dcaa tracking is activated, under DCAA tracking all changes are recorded and the comments are mandatory when a timesheet is edited.

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsDCAA { get; set; }
Visual Basic (Declaration)
Public Property IsDCAA As Boolean
Visual C++
public:
property bool IsDCAA {
    bool get ();
    void set (bool value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsShowAttachment Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.IsShowAttachment Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the attachment needs to be shown

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowAttachment { get; set; }
Visual Basic (Declaration)
Public Property IsShowAttachment As Boolean
Visual C++
public:
property bool IsShowAttachment {
    bool get ();
    void set (bool value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsShowDetail Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.IsShowDetail Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the detail needs to be shown

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowDetail { get; set; }
Visual Basic (Declaration)
Public Property IsShowDetail As Boolean
Visual C++
public:
property bool IsShowDetail {
    bool get ();
    void set (bool value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsShowHistory Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.IsShowHistory Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the history needs to be shown

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowHistory { get; set; }
Visual Basic (Declaration)
Public Property IsShowHistory As Boolean
Visual C++
public:
property bool IsShowHistory {
    bool get ();
    void set (bool value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsShowPayroll Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.IsShowPayroll Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the Totals are to be shown in time and expenses

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowPayroll { get; set; }
Visual Basic (Declaration)
Public Property IsShowPayroll As Boolean
Visual C++
public:
property bool IsShowPayroll {
    bool get ();
    void set (bool value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsShowTotals Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.IsShowTotals Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether the Totals are to be shown in time and expenses

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowTotals { get; set; }
Visual Basic (Declaration)
Public Property IsShowTotals As Boolean
Visual C++
public:
property bool IsShowTotals {
    bool get ();
    void set (bool value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


NumberOfRows Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.NumberOfRows Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Total number of rows

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumberOfRows { get; set; }
Visual Basic (Declaration)
Public Property NumberOfRows As Integer
Visual C++
public:
property int NumberOfRows {
    int get ();
    void set (int value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


NumberOfStartingPeriodBackward Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.NumberOfStartingPeriodBackward Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The total number of backward periods (in the future) that the timesheet can be created for

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumberOfStartingPeriodBackward { get; set; }
Visual Basic (Declaration)
Public Property NumberOfStartingPeriodBackward As Integer
Visual C++
public:
property int NumberOfStartingPeriodBackward {
    int get ();
    void set (int value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


NumberOfStartingPeriodForward Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.NumberOfStartingPeriodForward Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The total number of forward periods (in the future) that the timesheet can be created for

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumberOfStartingPeriodForward { get; set; }
Visual Basic (Declaration)
Public Property NumberOfStartingPeriodForward As Integer
Visual C++
public:
property int NumberOfStartingPeriodForward {
    int get ();
    void set (int value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ProjectAlias Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.ProjectAlias Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

string value of the alias for project

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProjectAlias { get; set; }
Visual Basic (Declaration)
Public Property ProjectAlias As String
Visual C++
public:
property String^ ProjectAlias {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ServiceItemAlias Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.ServiceItemAlias Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

string value of the alias for service item

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ServiceItemAlias { get; set; }
Visual Basic (Declaration)
Public Property ServiceItemAlias As String
Visual C++
public:
property String^ ServiceItemAlias {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetFooter Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.TimesheetFooter Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Timesheet Footer

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TimesheetFooter { get; set; }
Visual Basic (Declaration)
Public Property TimesheetFooter As String
Visual C++
public:
property String^ TimesheetFooter {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetHeader Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.TimesheetHeader Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Timesheet Header

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TimesheetHeader { get; set; }
Visual Basic (Declaration)
Public Property TimesheetHeader As String
Visual C++
public:
property String^ TimesheetHeader {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


WeekStartDay Property

[image]

OfficeClip API Documentation
TimesheetGroupProfile..::.WeekStartDay Property
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

The start of the weekday

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DayOfWeek WeekStartDay { get; set; }
Visual Basic (Declaration)
Public Property WeekStartDay As DayOfWeek
Visual C++
public:
property DayOfWeek WeekStartDay {
    DayOfWeek get ();
    void set (DayOfWeek value);
}

See Also

TimesheetGroupProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetUserEnum Enumeration

[image]

OfficeClip API Documentation
TimesheetUserEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for the user profile for timesheet

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum TimesheetUserEnum
Visual Basic (Declaration)
Public Enumeration TimesheetUserEnum
Visual C++
public enum class TimesheetUserEnum

Members

Member name | Description
ApplicationLastVisited | When the application was last visited
ApplicationLastVisitedBackup | Application lat visited time in the last session
IsThisGroupOnly | Show time sheets for this group only

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetUserProfile Class

[image]

OfficeClip API Documentation
TimesheetUserProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

The timesheet user profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TimesheetUserProfile : ProfileBase
Visual Basic (Declaration)
Public Class TimesheetUserProfile _
    Inherits ProfileBase
Visual C++
public ref class TimesheetUserProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.TimesheetUserProfile

See Also

TimesheetUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetUserProfile Members

[image] [image]

OfficeClip API Documentation
TimesheetUserProfile Members
TimesheetUserProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The TimesheetUserProfile type exposes the following members.

Constructors

 | Name | Description
Public method | TimesheetUserProfile | Overloaded.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited |
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | ApplicationLastVisited | application last visited
Public property | ApplicationLastVisitedBackup | application last visited backup
Public property | IsThisGroupOnly | Whether to show time sheets for all groups

See Also

TimesheetUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetUserProfile Constructor

[image] [image]

OfficeClip API Documentation
TimesheetUserProfile Constructor
TimesheetUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TimesheetUserProfile()()() | Constructor
Public method | TimesheetUserProfile(String) | The constructor

See Also

TimesheetUserProfile Class
TimesheetUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetUserProfile Constructor

[image]

OfficeClip API Documentation
TimesheetUserProfile Constructor
TimesheetUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetUserProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimesheetUserProfile()

See Also

TimesheetUserProfile Class
TimesheetUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetUserProfile Constructor (String)

[image]

OfficeClip API Documentation
TimesheetUserProfile Constructor (String)
TimesheetUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetUserProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
TimesheetUserProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

TimesheetUserProfile Class
TimesheetUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetUserProfile Methods

[image] [image]

OfficeClip API Documentation
TimesheetUserProfile Methods
TimesheetUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetUserProfile type exposes the following methods.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited |
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimesheetUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CopyApplicationLastVisitedBackupToApplicationLastVisited Method

[image]

OfficeClip API Documentation
TimesheetUserProfile..::.CopyApplicationLastVisitedBackupToApplicationLastVisited Method
TimesheetUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyApplicationLastVisitedBackupToApplicationLastVisited()
Visual Basic (Declaration)
Public Sub CopyApplicationLastVisitedBackupToApplicationLastVisited
Visual C++
public:
void CopyApplicationLastVisitedBackupToApplicationLastVisited()

See Also

TimesheetUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
TimesheetUserProfile..::.GetBool Method
TimesheetUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

TimesheetUserProfile Class
TimesheetUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


TimesheetUserProfile Properties

[image] [image]

OfficeClip API Documentation
TimesheetUserProfile Properties
TimesheetUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetUserProfile type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationLastVisited | application last visited
Public property | ApplicationLastVisitedBackup | application last visited backup
Public property | IsThisGroupOnly | Whether to show time sheets for all groups

See Also

TimesheetUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisited Property

[image]

OfficeClip API Documentation
TimesheetUserProfile..::.ApplicationLastVisited Property
TimesheetUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

application last visited

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisited { get; set; }
Visual Basic (Declaration)
Public Property ApplicationLastVisited As DateTime
Visual C++
public:
property DateTime ApplicationLastVisited {
    DateTime get ();
    void set (DateTime value);
}

See Also

TimesheetUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisitedBackup Property

[image]

OfficeClip API Documentation
TimesheetUserProfile..::.ApplicationLastVisitedBackup Property
TimesheetUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

application last visited backup

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisitedBackup { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationLastVisitedBackup As DateTime
Visual C++
public:
property DateTime ApplicationLastVisitedBackup {
    DateTime get ();
}

See Also

TimesheetUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


IsThisGroupOnly Property

[image]

OfficeClip API Documentation
TimesheetUserProfile..::.IsThisGroupOnly Property
TimesheetUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Whether to show time sheets for all groups

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsThisGroupOnly { get; set; }
Visual Basic (Declaration)
Public Property IsThisGroupOnly As Boolean
Visual C++
public:
property bool IsThisGroupOnly {
    bool get ();
    void set (bool value);
}

See Also

TimesheetUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


TrackerUserEnum Enumeration

[image]

OfficeClip API Documentation
TrackerUserEnum Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types for the user profile for tracker

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum TrackerUserEnum
Visual Basic (Declaration)
Public Enumeration TrackerUserEnum
Visual C++
public enum class TrackerUserEnum

Members

Member name | Description
ApplicationLastVisited | Application last visited time
ApplicationLastVisitedBackup | Application last visited backup time

See Also

OfficeClip.BusinessLayer.Framework.Profile Namespace


TrackerUserProfile Class

[image]

OfficeClip API Documentation
TrackerUserProfile Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class for issue tracker user profile

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerUserProfile : ProfileBase
Visual Basic (Declaration)
Public Class TrackerUserProfile _
    Inherits ProfileBase
Visual C++
public ref class TrackerUserProfile : public ProfileBase

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase
OfficeClip.BusinessLayer.Framework.Profile..::.TrackerUserProfile

See Also

TrackerUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


TrackerUserProfile Members

[image] [image]

OfficeClip API Documentation
TrackerUserProfile Members
TrackerUserProfile Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerUserProfile type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerUserProfile | Overloaded.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited |
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | props | List of properties (Inherited from ProfileBase.)

Properties

 | Name | Description
Public property | ApplicationLastVisited | Application last visited
Public property | ApplicationLastVisitedBackup | Application last visited backup

See Also

TrackerUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


TrackerUserProfile Constructor

[image] [image]

OfficeClip API Documentation
TrackerUserProfile Constructor
TrackerUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TrackerUserProfile()()() | Constructor
Public method | TrackerUserProfile(String) | Constructor

See Also

TrackerUserProfile Class
TrackerUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


TrackerUserProfile Constructor

[image]

OfficeClip API Documentation
TrackerUserProfile Constructor
TrackerUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerUserProfile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerUserProfile()

See Also

TrackerUserProfile Class
TrackerUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


TrackerUserProfile Constructor (String)

[image]

OfficeClip API Documentation
TrackerUserProfile Constructor (String)
TrackerUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerUserProfile(
    string serialized
)
Visual Basic (Declaration)
Public Sub New ( _
    serialized As String _
)
Visual C++
public:
TrackerUserProfile(
    String^ serialized
)

Parameters

serialized
Type: System..::.String

See Also

TrackerUserProfile Class
TrackerUserProfile Overload
OfficeClip.BusinessLayer.Framework.Profile Namespace


TrackerUserProfile Methods

[image] [image]

OfficeClip API Documentation
TrackerUserProfile Methods
TrackerUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerUserProfile type exposes the following methods.

Methods

 | Name | Description
Public method | CopyApplicationLastVisitedBackupToApplicationLastVisited |
Protected method | EnumSize | Size of the enumerated type (Inherited from ProfileBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetBool | Overloaded.
Protected method | GetCalendarView | Gets the calendar view for a property (Inherited from ProfileBase.)
Protected method | GetDateTime | Gets the datetime of a property (Inherited from ProfileBase.)
Protected method | GetDayOfWeek | Gets the Day of week value of the property (Inherited from ProfileBase.)
Protected method | GetDouble | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetEventShowAs | Gets the Event Show As value of the property (Inherited from ProfileBase.)
Protected method | GetEventType | Sets the event show as value of the property (Inherited from ProfileBase.)
Protected method | GetGroupSelection | Gets the grouyp selection. By default it returns the current group (Inherited from ProfileBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetInt | Gets the integer value of the profile property (Inherited from ProfileBase.)
Protected method | GetString | Gets the string representation of the profile property (Inherited from ProfileBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | The serialized profile (Inherited from ProfileBase.)
Protected method | SetBool | Sets the boolean value of the property (Inherited from ProfileBase.)
Protected method | SetCalendarView | Sets the calendar view (Inherited from ProfileBase.)
Protected method | SetDateTime | Sets the datetime of the property (Inherited from ProfileBase.)
Protected method | SetDayOfWeek | Sets the day of week value of the property (Inherited from ProfileBase.)
Protected method | SetDouble | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetEventShowAs | Sets the event show as value of the poperty (Inherited from ProfileBase.)
Protected method | SetEventType | Sets the event type (Inherited from ProfileBase.)
Protected method | SetGroupSelection | Sets the group selection to the value passed (Inherited from ProfileBase.)
Protected method | SetInt | Sets the integer value of the property (Inherited from ProfileBase.)
Protected method | SetString | Sets the string value of the profile property (Inherited from ProfileBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


CopyApplicationLastVisitedBackupToApplicationLastVisited Method

[image]

OfficeClip API Documentation
TrackerUserProfile..::.CopyApplicationLastVisitedBackupToApplicationLastVisited Method
TrackerUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyApplicationLastVisitedBackupToApplicationLastVisited()
Visual Basic (Declaration)
Public Sub CopyApplicationLastVisitedBackupToApplicationLastVisited
Visual C++
public:
void CopyApplicationLastVisitedBackupToApplicationLastVisited()

See Also

TrackerUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
TrackerUserProfile..::.GetBool Method
TrackerUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

TrackerUserProfile Class
TrackerUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


TrackerUserProfile Properties

[image] [image]

OfficeClip API Documentation
TrackerUserProfile Properties
TrackerUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerUserProfile type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationLastVisited | Application last visited
Public property | ApplicationLastVisitedBackup | Application last visited backup

See Also

TrackerUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisited Property

[image]

OfficeClip API Documentation
TrackerUserProfile..::.ApplicationLastVisited Property
TrackerUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Application last visited

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisited { get; set; }
Visual Basic (Declaration)
Public Property ApplicationLastVisited As DateTime
Visual C++
public:
property DateTime ApplicationLastVisited {
    DateTime get ();
    void set (DateTime value);
}

See Also

TrackerUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


ApplicationLastVisitedBackup Property

[image]

OfficeClip API Documentation
TrackerUserProfile..::.ApplicationLastVisitedBackup Property
TrackerUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Application last visited backup

Namespace: OfficeClip.BusinessLayer.Framework.Profile
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ApplicationLastVisitedBackup { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplicationLastVisitedBackup As DateTime
Visual C++
public:
property DateTime ApplicationLastVisitedBackup {
    DateTime get ();
}

See Also

TrackerUserProfile Class
OfficeClip.BusinessLayer.Framework.Profile Namespace


OfficeClip.BusinessLayer.Framework.Provider Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Framework.Provider Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the provider. the .net provider architecture allows cookie cutter templates for various features.

Enumerations

 | Enumeration | Description
Public enumeration | OcAuthenticationProviderStatus | Class to represent the enumerated type for authentication provider status


OcAuthenticationProviderStatus Enumeration

[image]

OfficeClip API Documentation
OcAuthenticationProviderStatus Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Class to represent the enumerated type for authentication provider status

Namespace: OfficeClip.BusinessLayer.Framework.Provider
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum OcAuthenticationProviderStatus
Visual Basic (Declaration)
Public Enumeration OcAuthenticationProviderStatus
Visual C++
public enum class OcAuthenticationProviderStatus

Members

Member name | Description
Success | Success

See Also

OfficeClip.BusinessLayer.Framework.Provider Namespace


OfficeClip.BusinessLayer.Framework.TrackTime Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Framework.TrackTime Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for tracking time in various applications

Classes

 | Class | Description
Public class | TracktimeInfo | This class is used to track time for each unit of task. It is currently used for Contact Manager, Tasks and Issue Tracker
Public class | TrackTimeUdfInfo | The user-defined fields for the track time - TrackTimeUdfInfo


TracktimeInfo Class

[image]

OfficeClip API Documentation
TracktimeInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class is used to track time for each unit of task. It is currently used for Contact Manager, Tasks and Issue Tracker

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TracktimeInfo
Visual Basic (Declaration)
Public Class TracktimeInfo
Visual C++
public ref class TracktimeInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.TrackTime..::.TracktimeInfo

See Also

TracktimeInfo Members
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TracktimeInfo Members

[image] [image]

OfficeClip API Documentation
TracktimeInfo Members
TracktimeInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TracktimeInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TracktimeInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationId | The unique id of the application
Public property | Description | A free form notes giving the description of the time
Public property | Duration | The duration of the task in minute
Public property | EmailAddress | The email address of the user
Public property | GroupId | The unique id of the group
Public property | IsMarked | True if this entry is used in the timesheet
Public property | LastUpdatedTimestamp | A System generated timestamp
Public property | Notes | A free form notes giving the description of the time
Public property | PrimaryId | The primary id of the object, e.g. for tracker case this value will be case_id
Public property | TrackDate | Teh datetime for the recorded duration
Public property | TracktimeId | Unique id of the track time
Public property | Udf1 | The user defined field 1
Public property | Udf2 | The user defined field 1
Public property | UserId | The unique id of the user
Public property | UserName | The name of the user

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TracktimeInfo Constructor

[image] [image]

OfficeClip API Documentation
TracktimeInfo Constructor
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TracktimeInfo()()() | The default constructor
Public method | TracktimeInfo(Int32, Int32, Int32, Int32, Int32, DateTime, Int32, Boolean, String, String, DateTime, String, String, String, String) | Constructor

See Also

TracktimeInfo Class
TracktimeInfo Members
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TracktimeInfo Constructor

[image]

OfficeClip API Documentation
TracktimeInfo Constructor
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TracktimeInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TracktimeInfo()

See Also

TracktimeInfo Class
TracktimeInfo Overload
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TracktimeInfo Constructor (Int32, Int32, Int32, Int32, Int32, DateTime, Int32, Boolean, String, String, DateTime, String, String, String, String)

[image]

OfficeClip API Documentation
TracktimeInfo Constructor (Int32, Int32, Int32, Int32, Int32, DateTime, Int32, Boolean, String, String, DateTime, String, String, String, String)
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TracktimeInfo(
    int tracktimeId,
    int applicationId,
    int primaryId,
    int userId,
    int groupId,
    DateTime trackDate,
    int duration,
    bool isMarked,
    string notes,
    string description,
    DateTime lastUpdatedTimestamp,
    string userName,
    string emailAddress,
    string udf1,
    string udf2
)
Visual Basic (Declaration)
Public Sub New ( _
    tracktimeId As Integer, _
    applicationId As Integer, _
    primaryId As Integer, _
    userId As Integer, _
    groupId As Integer, _
    trackDate As DateTime, _
    duration As Integer, _
    isMarked As Boolean, _
    notes As String, _
    description As String, _
    lastUpdatedTimestamp As DateTime, _
    userName As String, _
    emailAddress As String, _
    udf1 As String, _
    udf2 As String _
)
Visual C++
public:
TracktimeInfo(
    int tracktimeId,
    int applicationId,
    int primaryId,
    int userId,
    int groupId,
    DateTime trackDate,
    int duration,
    bool isMarked,
    String^ notes,
    String^ description,
    DateTime lastUpdatedTimestamp,
    String^ userName,
    String^ emailAddress,
    String^ udf1,
    String^ udf2
)

Parameters

tracktimeId
Type: System..::.Int32
The unique id of the track time
applicationId
Type: System..::.Int32
The unique id of the application
primaryId
Type: System..::.Int32
The primary id
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the group
trackDate
Type: System..::.DateTime
The date when the event is tracked
duration
Type: System..::.Int32
The duration of the track
isMarked
Type: System..::.Boolean
True if it is marked
notes
Type: System..::.String
The tracking notes
description
Type: System..::.String
The tracking description
lastUpdatedTimestamp
Type: System..::.DateTime
The last updated timestamp
userName
Type: System..::.String
The user name
emailAddress
Type: System..::.String
the email address
udf1
Type: System..::.String
The first udf
udf2
Type: System..::.String
the second udf

See Also

TracktimeInfo Class
TracktimeInfo Overload
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TracktimeInfo Properties

[image] [image]

OfficeClip API Documentation
TracktimeInfo Properties
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TracktimeInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationId | The unique id of the application
Public property | Description | A free form notes giving the description of the time
Public property | Duration | The duration of the task in minute
Public property | EmailAddress | The email address of the user
Public property | GroupId | The unique id of the group
Public property | IsMarked | True if this entry is used in the timesheet
Public property | LastUpdatedTimestamp | A System generated timestamp
Public property | Notes | A free form notes giving the description of the time
Public property | PrimaryId | The primary id of the object, e.g. for tracker case this value will be case_id
Public property | TrackDate | Teh datetime for the recorded duration
Public property | TracktimeId | Unique id of the track time
Public property | Udf1 | The user defined field 1
Public property | Udf2 | The user defined field 1
Public property | UserId | The unique id of the user
Public property | UserName | The name of the user

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


ApplicationId Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.ApplicationId Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the application

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ApplicationId { get; set; }
Visual Basic (Declaration)
Public Property ApplicationId As Integer
Visual C++
public:
property int ApplicationId {
    int get ();
    void set (int value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


Description Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.Description Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

A free form notes giving the description of the time

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


Duration Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.Duration Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The duration of the task in minute

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Duration { get; set; }
Visual Basic (Declaration)
Public Property Duration As Integer
Visual C++
public:
property int Duration {
    int get ();
    void set (int value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


EmailAddress Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.EmailAddress Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email address of the user

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic (Declaration)
Public Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


GroupId Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.GroupId Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the group

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


IsMarked Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.IsMarked Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

True if this entry is used in the timesheet

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsMarked { get; set; }
Visual Basic (Declaration)
Public Property IsMarked As Boolean
Visual C++
public:
property bool IsMarked {
    bool get ();
    void set (bool value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


LastUpdatedTimestamp Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.LastUpdatedTimestamp Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

A System generated timestamp

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime LastUpdatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedTimestamp As DateTime
Visual C++
public:
property DateTime LastUpdatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


Notes Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.Notes Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

A free form notes giving the description of the time

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


PrimaryId Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.PrimaryId Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The primary id of the object, e.g. for tracker case this value will be case_id

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int PrimaryId { get; set; }
Visual Basic (Declaration)
Public Property PrimaryId As Integer
Visual C++
public:
property int PrimaryId {
    int get ();
    void set (int value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TrackDate Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.TrackDate Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Teh datetime for the recorded duration

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime TrackDate { get; set; }
Visual Basic (Declaration)
Public Property TrackDate As DateTime
Visual C++
public:
property DateTime TrackDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TracktimeId Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.TracktimeId Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Unique id of the track time

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TracktimeId { get; set; }
Visual Basic (Declaration)
Public Property TracktimeId As Integer
Visual C++
public:
property int TracktimeId {
    int get ();
    void set (int value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


Udf1 Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.Udf1 Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user defined field 1

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Udf1 { get; set; }
Visual Basic (Declaration)
Public Property Udf1 As String
Visual C++
public:
property String^ Udf1 {
    String^ get ();
    void set (String^ value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


Udf2 Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.Udf2 Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user defined field 1

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Udf2 { get; set; }
Visual Basic (Declaration)
Public Property Udf2 As String
Visual C++
public:
property String^ Udf2 {
    String^ get ();
    void set (String^ value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


UserId Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.UserId Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


UserName Property

[image]

OfficeClip API Documentation
TracktimeInfo..::.UserName Property
TracktimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

TracktimeInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TrackTimeUdfInfo Class

[image]

OfficeClip API Documentation
TrackTimeUdfInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

The user-defined fields for the track time - TrackTimeUdfInfo

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackTimeUdfInfo
Visual Basic (Declaration)
Public Class TrackTimeUdfInfo
Visual C++
public ref class TrackTimeUdfInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.TrackTime..::.TrackTimeUdfInfo

See Also

TrackTimeUdfInfo Members
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TrackTimeUdfInfo Members

[image] [image]

OfficeClip API Documentation
TrackTimeUdfInfo Members
TrackTimeUdfInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackTimeUdfInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TrackTimeUdfInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationId | The unique id of the application
Public property | FieldDefault1 | The default value of the first udf field, It holds the comma separated list texts
Public property | FieldDefault2 | The second udf field. It consists of the list text values
Public property | FieldName1 | The first udf field name.
Public property | FieldName2 | The second udf field name.
Public property | FieldType1 | The first user defined field type, valid values are TEXT, LIST. An empty value or null denotes that this field is not present.
Public property | FieldType2 | The second udf field type, valid values are TEXT, LIST. An empty value or null denotes that this field is not present.
Public property | GroupId | The unique id of the group

See Also

TrackTimeUdfInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TrackTimeUdfInfo Constructor

[image] [image]

OfficeClip API Documentation
TrackTimeUdfInfo Constructor
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TrackTimeUdfInfo()()() | The default constructor
Public method | TrackTimeUdfInfo(Int32, Int32, String, String, String, String, String, String) | Constructor

See Also

TrackTimeUdfInfo Class
TrackTimeUdfInfo Members
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TrackTimeUdfInfo Constructor

[image]

OfficeClip API Documentation
TrackTimeUdfInfo Constructor
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackTimeUdfInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackTimeUdfInfo()

See Also

TrackTimeUdfInfo Class
TrackTimeUdfInfo Overload
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TrackTimeUdfInfo Constructor (Int32, Int32, String, String, String, String, String, String)

[image]

OfficeClip API Documentation
TrackTimeUdfInfo Constructor (Int32, Int32, String, String, String, String, String, String)
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackTimeUdfInfo(
    int groupId,
    int applicationId,
    string fieldType1,
    string fieldDefault1,
    string fieldType2,
    string fieldDefault2,
    string fieldName1,
    string fieldName2
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    applicationId As Integer, _
    fieldType1 As String, _
    fieldDefault1 As String, _
    fieldType2 As String, _
    fieldDefault2 As String, _
    fieldName1 As String, _
    fieldName2 As String _
)
Visual C++
public:
TrackTimeUdfInfo(
    int groupId,
    int applicationId,
    String^ fieldType1,
    String^ fieldDefault1,
    String^ fieldType2,
    String^ fieldDefault2,
    String^ fieldName1,
    String^ fieldName2
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
applicationId
Type: System..::.Int32
The unique id of the application
fieldType1
Type: System..::.String
The first field type
fieldDefault1
Type: System..::.String
The first field default
fieldType2
Type: System..::.String
The second field type
fieldDefault2
Type: System..::.String
The second field default
fieldName1
Type: System..::.String
The first field name
fieldName2
Type: System..::.String
The second field name

See Also

TrackTimeUdfInfo Class
TrackTimeUdfInfo Overload
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


TrackTimeUdfInfo Properties

[image] [image]

OfficeClip API Documentation
TrackTimeUdfInfo Properties
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TrackTimeUdfInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationId | The unique id of the application
Public property | FieldDefault1 | The default value of the first udf field, It holds the comma separated list texts
Public property | FieldDefault2 | The second udf field. It consists of the list text values
Public property | FieldName1 | The first udf field name.
Public property | FieldName2 | The second udf field name.
Public property | FieldType1 | The first user defined field type, valid values are TEXT, LIST. An empty value or null denotes that this field is not present.
Public property | FieldType2 | The second udf field type, valid values are TEXT, LIST. An empty value or null denotes that this field is not present.
Public property | GroupId | The unique id of the group

See Also

TrackTimeUdfInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


ApplicationId Property

[image]

OfficeClip API Documentation
TrackTimeUdfInfo..::.ApplicationId Property
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the application

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ApplicationId { get; set; }
Visual Basic (Declaration)
Public Property ApplicationId As Integer
Visual C++
public:
property int ApplicationId {
    int get ();
    void set (int value);
}

See Also

TrackTimeUdfInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


FieldDefault1 Property

[image]

OfficeClip API Documentation
TrackTimeUdfInfo..::.FieldDefault1 Property
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default value of the first udf field, It holds the comma separated list texts

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FieldDefault1 { get; set; }
Visual Basic (Declaration)
Public Property FieldDefault1 As String
Visual C++
public:
property String^ FieldDefault1 {
    String^ get ();
    void set (String^ value);
}

See Also

TrackTimeUdfInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


FieldDefault2 Property

[image]

OfficeClip API Documentation
TrackTimeUdfInfo..::.FieldDefault2 Property
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second udf field. It consists of the list text values

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FieldDefault2 { get; set; }
Visual Basic (Declaration)
Public Property FieldDefault2 As String
Visual C++
public:
property String^ FieldDefault2 {
    String^ get ();
    void set (String^ value);
}

See Also

TrackTimeUdfInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


FieldName1 Property

[image]

OfficeClip API Documentation
TrackTimeUdfInfo..::.FieldName1 Property
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first udf field name.

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FieldName1 { get; set; }
Visual Basic (Declaration)
Public Property FieldName1 As String
Visual C++
public:
property String^ FieldName1 {
    String^ get ();
    void set (String^ value);
}

See Also

TrackTimeUdfInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


FieldName2 Property

[image]

OfficeClip API Documentation
TrackTimeUdfInfo..::.FieldName2 Property
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second udf field name.

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FieldName2 { get; set; }
Visual Basic (Declaration)
Public Property FieldName2 As String
Visual C++
public:
property String^ FieldName2 {
    String^ get ();
    void set (String^ value);
}

See Also

TrackTimeUdfInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


FieldType1 Property

[image]

OfficeClip API Documentation
TrackTimeUdfInfo..::.FieldType1 Property
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first user defined field type, valid values are TEXT, LIST. An empty value or null denotes that this field is not present.

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FieldType1 { get; set; }
Visual Basic (Declaration)
Public Property FieldType1 As String
Visual C++
public:
property String^ FieldType1 {
    String^ get ();
    void set (String^ value);
}

See Also

TrackTimeUdfInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


FieldType2 Property

[image]

OfficeClip API Documentation
TrackTimeUdfInfo..::.FieldType2 Property
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second udf field type, valid values are TEXT, LIST. An empty value or null denotes that this field is not present.

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FieldType2 { get; set; }
Visual Basic (Declaration)
Public Property FieldType2 As String
Visual C++
public:
property String^ FieldType2 {
    String^ get ();
    void set (String^ value);
}

See Also

TrackTimeUdfInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


GroupId Property

[image]

OfficeClip API Documentation
TrackTimeUdfInfo..::.GroupId Property
TrackTimeUdfInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the group

Namespace: OfficeClip.BusinessLayer.Framework.TrackTime
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

TrackTimeUdfInfo Class
OfficeClip.BusinessLayer.Framework.TrackTime Namespace


OfficeClip.BusinessLayer.Framework.Workflow Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Framework.Workflow Namespace

[This is preliminary documentation and is subject to change.]

Business Layer template for workflow

Classes

 | Class | Description
Public class | WorkflowActionInfo | Provides the methods and properties to access the workflow Action object.
Public class | WorkflowActions | Provides methods and properties to access the workflow actions.
Public class | WorkflowDefinitionDetailsInfo | Provides methods and attributes to access the workflow definition detail.
Public class | WorkflowDefinitionInfo | Provides methods and properties for the workflow definition.
Public class | WorkflowHistoryInfo | Provides methods and properties to access the workflow history.
Public class | WorkflowInboxNotificationsInfo | Provides methods and properties to access the workflow inbox notifications.
Public class | WorkflowInfo | Provides methods and properties for ht eworkflow information.


WorkflowActionInfo Class

[image]

OfficeClip API Documentation
WorkflowActionInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides the methods and properties to access the workflow Action object.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class WorkflowActionInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class WorkflowActionInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class WorkflowActionInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowActionInfo

See Also

WorkflowActionInfo Members
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowActionInfo Members

[image] [image]

OfficeClip API Documentation
WorkflowActionInfo Members
WorkflowActionInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The WorkflowActionInfo type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowActionInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | The workflow Action.
Public property | ActionName | The workflow Action name.
Public property | ActionType | The workflow Action type.
Public property | RouteToUserFirstName | The user name of the user to whom the workflow document is routed to.
Public property | RouteToUserId | The user identifier of the user to whom the workflow document is routed to.
Public property | RouteToUserLastName | The user name of the user to whom the workflow document is routed to.
Public property | RouteToUserName | The user name of the user to whom the workflow document is routed to.

See Also

WorkflowActionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowActionInfo Constructor

[image] [image]

OfficeClip API Documentation
WorkflowActionInfo Constructor
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | WorkflowActionInfo()()() | The default constructor.
Public method | WorkflowActionInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

WorkflowActionInfo Class
WorkflowActionInfo Members
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowActionInfo Constructor

[image]

OfficeClip API Documentation
WorkflowActionInfo Constructor
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowActionInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkflowActionInfo()

See Also

WorkflowActionInfo Class
WorkflowActionInfo Overload
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowActionInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
WorkflowActionInfo Constructor (SerializationInfo, StreamingContext)
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowActionInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
WorkflowActionInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

WorkflowActionInfo Class
WorkflowActionInfo Overload
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowActionInfo Methods

[image] [image]

OfficeClip API Documentation
WorkflowActionInfo Methods
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The WorkflowActionInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowActionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
WorkflowActionInfo..::.GetObjectData Method
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

WorkflowActionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowActionInfo Properties

[image] [image]

OfficeClip API Documentation
WorkflowActionInfo Properties
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The WorkflowActionInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Action | The workflow Action.
Public property | ActionName | The workflow Action name.
Public property | ActionType | The workflow Action type.
Public property | RouteToUserFirstName | The user name of the user to whom the workflow document is routed to.
Public property | RouteToUserId | The user identifier of the user to whom the workflow document is routed to.
Public property | RouteToUserLastName | The user name of the user to whom the workflow document is routed to.
Public property | RouteToUserName | The user name of the user to whom the workflow document is routed to.

See Also

WorkflowActionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


Action Property

[image]

OfficeClip API Documentation
WorkflowActionInfo..::.Action Property
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The workflow Action.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowAction Action { get; set; }
Visual Basic (Declaration)
Public Property Action As WorkflowAction
Visual C++
public:
property WorkflowAction Action {
    WorkflowAction get ();
    void set (WorkflowAction value);
}

See Also

WorkflowActionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


ActionName Property

[image]

OfficeClip API Documentation
WorkflowActionInfo..::.ActionName Property
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The workflow Action name.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ActionName { get; set; }
Visual Basic (Declaration)
Public Property ActionName As String
Visual C++
public:
property String^ ActionName {
    String^ get ();
    void set (String^ value);
}

See Also

WorkflowActionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


ActionType Property

[image]

OfficeClip API Documentation
WorkflowActionInfo..::.ActionType Property
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The workflow Action type.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ActionType { get; set; }
Visual Basic (Declaration)
Public Property ActionType As String
Visual C++
public:
property String^ ActionType {
    String^ get ();
    void set (String^ value);
}

See Also

WorkflowActionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


RouteToUserFirstName Property

[image]

OfficeClip API Documentation
WorkflowActionInfo..::.RouteToUserFirstName Property
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user name of the user to whom the workflow document is routed to.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RouteToUserFirstName { get; set; }
Visual Basic (Declaration)
Public Property RouteToUserFirstName As String
Visual C++
public:
property String^ RouteToUserFirstName {
    String^ get ();
    void set (String^ value);
}

See Also

WorkflowActionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


RouteToUserId Property

[image]

OfficeClip API Documentation
WorkflowActionInfo..::.RouteToUserId Property
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user identifier of the user to whom the workflow document is routed to.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RouteToUserId { get; set; }
Visual Basic (Declaration)
Public Property RouteToUserId As Integer
Visual C++
public:
property int RouteToUserId {
    int get ();
    void set (int value);
}

See Also

WorkflowActionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


RouteToUserLastName Property

[image]

OfficeClip API Documentation
WorkflowActionInfo..::.RouteToUserLastName Property
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user name of the user to whom the workflow document is routed to.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RouteToUserLastName { get; set; }
Visual Basic (Declaration)
Public Property RouteToUserLastName As String
Visual C++
public:
property String^ RouteToUserLastName {
    String^ get ();
    void set (String^ value);
}

See Also

WorkflowActionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


RouteToUserName Property

[image]

OfficeClip API Documentation
WorkflowActionInfo..::.RouteToUserName Property
WorkflowActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user name of the user to whom the workflow document is routed to.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RouteToUserName { get; }
Visual Basic (Declaration)
Public ReadOnly Property RouteToUserName As String
Visual C++
public:
property String^ RouteToUserName {
    String^ get ();
}

See Also

WorkflowActionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowActions Class

[image]

OfficeClip API Documentation
WorkflowActions Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the workflow actions.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class WorkflowActions
Visual Basic (Declaration)
Public Class WorkflowActions
Visual C++
public ref class WorkflowActions

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowActions

See Also

WorkflowActions Members
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowActions Members

[image] [image]

OfficeClip API Documentation
WorkflowActions Members
WorkflowActions Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The WorkflowActions type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowActions | Constructor to create the workflow Action based on the workflow list.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRouteToUserId | Returns the workflow route to the user.
Public method | GetRouteToUserName | Gets the user name of the user who the documetn is routed to.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActionAllowed | shows if the workflow is allowed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowActions Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowActions Constructor

[image]

OfficeClip API Documentation
WorkflowActions Constructor
WorkflowActions Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create the workflow Action based on the workflow list.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowActions(
    ArrayList al
)
Visual Basic (Declaration)
Public Sub New ( _
    al As ArrayList _
)
Visual C++
public:
WorkflowActions(
    ArrayList^ al
)

Parameters

al
Type: System.Collections..::.ArrayList
The workflow list.

See Also

WorkflowActions Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowActions Methods

[image] [image]

OfficeClip API Documentation
WorkflowActions Methods
WorkflowActions Class See Also

[This is preliminary documentation and is subject to change.]

The WorkflowActions type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRouteToUserId | Returns the workflow route to the user.
Public method | GetRouteToUserName | Gets the user name of the user who the documetn is routed to.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActionAllowed | shows if the workflow is allowed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowActions Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


GetRouteToUserId Method

[image]

OfficeClip API Documentation
WorkflowActions..::.GetRouteToUserId Method
WorkflowActions Class See Also

[This is preliminary documentation and is subject to change.]

Returns the workflow route to the user.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GetRouteToUserId(
    WorkflowAction wa
)
Visual Basic (Declaration)
Public Function GetRouteToUserId ( _
    wa As WorkflowAction _
) As Integer
Visual C++
public:
int GetRouteToUserId(
    WorkflowAction wa
)

Parameters

wa
Type: OfficeClip.Utils..::.WorkflowAction
the workflow Action.

Return Value

The workflow route identifier.

See Also

WorkflowActions Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


GetRouteToUserName Method

[image]

OfficeClip API Documentation
WorkflowActions..::.GetRouteToUserName Method
WorkflowActions Class See Also

[This is preliminary documentation and is subject to change.]

Gets the user name of the user who the documetn is routed to.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetRouteToUserName(
    WorkflowAction wa
)
Visual Basic (Declaration)
Public Function GetRouteToUserName ( _
    wa As WorkflowAction _
) As String
Visual C++
public:
String^ GetRouteToUserName(
    WorkflowAction wa
)

Parameters

wa
Type: OfficeClip.Utils..::.WorkflowAction
The workflow Action.

Return Value

The user name.

See Also

WorkflowActions Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


IsActionAllowed Method

[image]

OfficeClip API Documentation
WorkflowActions..::.IsActionAllowed Method
WorkflowActions Class See Also

[This is preliminary documentation and is subject to change.]

shows if the workflow is allowed.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsActionAllowed(
    WorkflowAction wa
)
Visual Basic (Declaration)
Public Function IsActionAllowed ( _
    wa As WorkflowAction _
) As Boolean
Visual C++
public:
bool IsActionAllowed(
    WorkflowAction wa
)

Parameters

wa
Type: OfficeClip.Utils..::.WorkflowAction
The workflow Action.

Return Value

true if the Action is allowed, false otherwise.

See Also

WorkflowActions Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionDetailsInfo Class

[image]

OfficeClip API Documentation
WorkflowDefinitionDetailsInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and attributes to access the workflow definition detail.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class WorkflowDefinitionDetailsInfo
Visual Basic (Declaration)
Public Class WorkflowDefinitionDetailsInfo
Visual C++
public ref class WorkflowDefinitionDetailsInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowDefinitionDetailsInfo

See Also

WorkflowDefinitionDetailsInfo Members
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionDetailsInfo Members

[image] [image]

OfficeClip API Documentation
WorkflowDefinitionDetailsInfo Members
WorkflowDefinitionDetailsInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The WorkflowDefinitionDetailsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowDefinitionDetailsInfo | The default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultIoBox | the default input/output box.
Public property | DefaultStatusId | The default status identifier.
Public property | StageId | The workflow stage identifier.
Public property | UserId | The user identifier of the user who this workflow definition belongs to.
Public property | WorkflowDefinitionId | The workflow definition identifier.

See Also

WorkflowDefinitionDetailsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionDetailsInfo Constructor

[image]

OfficeClip API Documentation
WorkflowDefinitionDetailsInfo Constructor
WorkflowDefinitionDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowDefinitionDetailsInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkflowDefinitionDetailsInfo()

See Also

WorkflowDefinitionDetailsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionDetailsInfo Properties

[image] [image]

OfficeClip API Documentation
WorkflowDefinitionDetailsInfo Properties
WorkflowDefinitionDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The WorkflowDefinitionDetailsInfo type exposes the following properties.

Properties

 | Name | Description
Public property | DefaultIoBox | the default input/output box.
Public property | DefaultStatusId | The default status identifier.
Public property | StageId | The workflow stage identifier.
Public property | UserId | The user identifier of the user who this workflow definition belongs to.
Public property | WorkflowDefinitionId | The workflow definition identifier.

See Also

WorkflowDefinitionDetailsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


DefaultIoBox Property

[image]

OfficeClip API Documentation
WorkflowDefinitionDetailsInfo..::.DefaultIoBox Property
WorkflowDefinitionDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

the default input/output box.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DefaultIoBox { get; set; }
Visual Basic (Declaration)
Public Property DefaultIoBox As String
Visual C++
public:
property String^ DefaultIoBox {
    String^ get ();
    void set (String^ value);
}

See Also

WorkflowDefinitionDetailsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


DefaultStatusId Property

[image]

OfficeClip API Documentation
WorkflowDefinitionDetailsInfo..::.DefaultStatusId Property
WorkflowDefinitionDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default status identifier.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int DefaultStatusId { get; set; }
Visual Basic (Declaration)
Public Property DefaultStatusId As Integer
Visual C++
public:
property int DefaultStatusId {
    int get ();
    void set (int value);
}

See Also

WorkflowDefinitionDetailsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


StageId Property

[image]

OfficeClip API Documentation
WorkflowDefinitionDetailsInfo..::.StageId Property
WorkflowDefinitionDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The workflow stage identifier.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int StageId { get; set; }
Visual Basic (Declaration)
Public Property StageId As Integer
Visual C++
public:
property int StageId {
    int get ();
    void set (int value);
}

See Also

WorkflowDefinitionDetailsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


UserId Property

[image]

OfficeClip API Documentation
WorkflowDefinitionDetailsInfo..::.UserId Property
WorkflowDefinitionDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user identifier of the user who this workflow definition belongs to.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

WorkflowDefinitionDetailsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionId Property

[image]

OfficeClip API Documentation
WorkflowDefinitionDetailsInfo..::.WorkflowDefinitionId Property
WorkflowDefinitionDetailsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The workflow definition identifier.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int WorkflowDefinitionId { get; set; }
Visual Basic (Declaration)
Public Property WorkflowDefinitionId As Integer
Visual C++
public:
property int WorkflowDefinitionId {
    int get ();
    void set (int value);
}

See Also

WorkflowDefinitionDetailsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionInfo Class

[image]

OfficeClip API Documentation
WorkflowDefinitionInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties for the workflow definition.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class WorkflowDefinitionInfo
Visual Basic (Declaration)
Public Class WorkflowDefinitionInfo
Visual C++
public ref class WorkflowDefinitionInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowDefinitionInfo

See Also

WorkflowDefinitionInfo Members
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionInfo Members

[image] [image]

OfficeClip API Documentation
WorkflowDefinitionInfo Members
WorkflowDefinitionInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The WorkflowDefinitionInfo type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowDefinitionInfo | The default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplicationId | The application identifier to which this workflow definition is linked with.
Public property | ForUserId | The user identifier of the user for whom the workflow definition is created.
Public property | GroupId | The group identifier of the group to which the workflow belongs to.
Public property | WorkflowDefinitionDetails | The list of workflow definition details.
Public property | WorkflowDefinitionId | The workflow definition identifier.
Public property | WorkflowInboxNotifications | The list of workflow inbox notifications.
Public property | WorkflowType | The type of the workflow.

See Also

WorkflowDefinitionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionInfo Constructor

[image]

OfficeClip API Documentation
WorkflowDefinitionInfo Constructor
WorkflowDefinitionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowDefinitionInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkflowDefinitionInfo()

See Also

WorkflowDefinitionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionInfo Properties

[image] [image]

OfficeClip API Documentation
WorkflowDefinitionInfo Properties
WorkflowDefinitionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The WorkflowDefinitionInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationId | The application identifier to which this workflow definition is linked with.
Public property | ForUserId | The user identifier of the user for whom the workflow definition is created.
Public property | GroupId | The group identifier of the group to which the workflow belongs to.
Public property | WorkflowDefinitionDetails | The list of workflow definition details.
Public property | WorkflowDefinitionId | The workflow definition identifier.
Public property | WorkflowInboxNotifications | The list of workflow inbox notifications.
Public property | WorkflowType | The type of the workflow.

See Also

WorkflowDefinitionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


ApplicationId Property

[image]

OfficeClip API Documentation
WorkflowDefinitionInfo..::.ApplicationId Property
WorkflowDefinitionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The application identifier to which this workflow definition is linked with.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ApplicationId { get; set; }
Visual Basic (Declaration)
Public Property ApplicationId As Integer
Visual C++
public:
property int ApplicationId {
    int get ();
    void set (int value);
}

See Also

WorkflowDefinitionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


ForUserId Property

[image]

OfficeClip API Documentation
WorkflowDefinitionInfo..::.ForUserId Property
WorkflowDefinitionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user identifier of the user for whom the workflow definition is created.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ForUserId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ForUserId As Integer
Visual C++
public:
property int ForUserId {
    int get ();
}

See Also

WorkflowDefinitionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


GroupId Property

[image]

OfficeClip API Documentation
WorkflowDefinitionInfo..::.GroupId Property
WorkflowDefinitionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The group identifier of the group to which the workflow belongs to.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

WorkflowDefinitionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionDetails Property

[image]

OfficeClip API Documentation
WorkflowDefinitionInfo..::.WorkflowDefinitionDetails Property
WorkflowDefinitionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of workflow definition details.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList WorkflowDefinitionDetails { get; set; }
Visual Basic (Declaration)
Public Property WorkflowDefinitionDetails As ArrayList
Visual C++
public:
property ArrayList^ WorkflowDefinitionDetails {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

WorkflowDefinitionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionId Property

[image]

OfficeClip API Documentation
WorkflowDefinitionInfo..::.WorkflowDefinitionId Property
WorkflowDefinitionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The workflow definition identifier.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int WorkflowDefinitionId { get; set; }
Visual Basic (Declaration)
Public Property WorkflowDefinitionId As Integer
Visual C++
public:
property int WorkflowDefinitionId {
    int get ();
    void set (int value);
}

See Also

WorkflowDefinitionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInboxNotifications Property

[image]

OfficeClip API Documentation
WorkflowDefinitionInfo..::.WorkflowInboxNotifications Property
WorkflowDefinitionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of workflow inbox notifications.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList WorkflowInboxNotifications { get; set; }
Visual Basic (Declaration)
Public Property WorkflowInboxNotifications As ArrayList
Visual C++
public:
property ArrayList^ WorkflowInboxNotifications {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

WorkflowDefinitionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowType Property

[image]

OfficeClip API Documentation
WorkflowDefinitionInfo..::.WorkflowType Property
WorkflowDefinitionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The type of the workflow.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowType WorkflowType { get; set; }
Visual Basic (Declaration)
Public Property WorkflowType As WorkflowType
Visual C++
public:
property WorkflowType WorkflowType {
    WorkflowType get ();
    void set (WorkflowType value);
}

See Also

WorkflowDefinitionInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowHistoryInfo Class

[image]

OfficeClip API Documentation
WorkflowHistoryInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the workflow history.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class WorkflowHistoryInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class WorkflowHistoryInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class WorkflowHistoryInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowHistoryInfo

See Also

WorkflowHistoryInfo Members
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowHistoryInfo Members

[image] [image]

OfficeClip API Documentation
WorkflowHistoryInfo Members
WorkflowHistoryInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The WorkflowHistoryInfo type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowHistoryInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | The action attribute
Public property | ActionId | The Action identifier of the workflow history.
Public property | ActionTimestamp | The Action Timestamp of the workflow history.
Public property | ActionType | The action type attribute
Public property | ApplicationId | The application identifier of the application to which this workflow history belongs.
Public property | id | The system generated unique identifier of the workflow history.
Public property | Name | The name attribute
Public property | UserId | The user identifier of this creator of the workflow history.

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowHistoryInfo Constructor

[image] [image]

OfficeClip API Documentation
WorkflowHistoryInfo Constructor
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | WorkflowHistoryInfo()()() | The default constructor.
Public method | WorkflowHistoryInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

WorkflowHistoryInfo Class
WorkflowHistoryInfo Members
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowHistoryInfo Constructor

[image]

OfficeClip API Documentation
WorkflowHistoryInfo Constructor
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowHistoryInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkflowHistoryInfo()

See Also

WorkflowHistoryInfo Class
WorkflowHistoryInfo Overload
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowHistoryInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
WorkflowHistoryInfo Constructor (SerializationInfo, StreamingContext)
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowHistoryInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
WorkflowHistoryInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

WorkflowHistoryInfo Class
WorkflowHistoryInfo Overload
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowHistoryInfo Methods

[image] [image]

OfficeClip API Documentation
WorkflowHistoryInfo Methods
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The WorkflowHistoryInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
WorkflowHistoryInfo..::.GetObjectData Method
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowHistoryInfo Properties

[image] [image]

OfficeClip API Documentation
WorkflowHistoryInfo Properties
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The WorkflowHistoryInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Action | The action attribute
Public property | ActionId | The Action identifier of the workflow history.
Public property | ActionTimestamp | The Action Timestamp of the workflow history.
Public property | ActionType | The action type attribute
Public property | ApplicationId | The application identifier of the application to which this workflow history belongs.
Public property | id | The system generated unique identifier of the workflow history.
Public property | Name | The name attribute
Public property | UserId | The user identifier of this creator of the workflow history.

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


Action Property

[image]

OfficeClip API Documentation
WorkflowHistoryInfo..::.Action Property
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The action attribute

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Action { get; set; }
Visual Basic (Declaration)
Public Property Action As String
Visual C++
public:
property String^ Action {
    String^ get ();
    void set (String^ value);
}

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


ActionId Property

[image]

OfficeClip API Documentation
WorkflowHistoryInfo..::.ActionId Property
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Action identifier of the workflow history.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ActionId { get; set; }
Visual Basic (Declaration)
Public Property ActionId As Integer
Visual C++
public:
property int ActionId {
    int get ();
    void set (int value);
}

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


ActionTimestamp Property

[image]

OfficeClip API Documentation
WorkflowHistoryInfo..::.ActionTimestamp Property
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Action Timestamp of the workflow history.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ActionTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ActionTimestamp As DateTime
Visual C++
public:
property DateTime ActionTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


ActionType Property

[image]

OfficeClip API Documentation
WorkflowHistoryInfo..::.ActionType Property
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The action type attribute

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ActionType { get; set; }
Visual Basic (Declaration)
Public Property ActionType As String
Visual C++
public:
property String^ ActionType {
    String^ get ();
    void set (String^ value);
}

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


ApplicationId Property

[image]

OfficeClip API Documentation
WorkflowHistoryInfo..::.ApplicationId Property
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The application identifier of the application to which this workflow history belongs.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ApplicationId { get; set; }
Visual Basic (Declaration)
Public Property ApplicationId As Integer
Visual C++
public:
property int ApplicationId {
    int get ();
    void set (int value);
}

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


id Property

[image]

OfficeClip API Documentation
WorkflowHistoryInfo..::.id Property
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier of the workflow history.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int id { get; set; }
Visual Basic (Declaration)
Public Property id As Integer
Visual C++
public:
property int id {
    int get ();
    void set (int value);
}

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


Name Property

[image]

OfficeClip API Documentation
WorkflowHistoryInfo..::.Name Property
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name attribute

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


UserId Property

[image]

OfficeClip API Documentation
WorkflowHistoryInfo..::.UserId Property
WorkflowHistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user identifier of this creator of the workflow history.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

WorkflowHistoryInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInboxNotificationsInfo Class

[image]

OfficeClip API Documentation
WorkflowInboxNotificationsInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the workflow inbox notifications.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class WorkflowInboxNotificationsInfo
Visual Basic (Declaration)
Public Class WorkflowInboxNotificationsInfo
Visual C++
public ref class WorkflowInboxNotificationsInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowInboxNotificationsInfo

See Also

WorkflowInboxNotificationsInfo Members
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInboxNotificationsInfo Members

[image] [image]

OfficeClip API Documentation
WorkflowInboxNotificationsInfo Members
WorkflowInboxNotificationsInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The WorkflowInboxNotificationsInfo type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowInboxNotificationsInfo | the default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Status | The workflow inbox status.
Public property | StatusId | The inbox status identifier.
Public property | WorkflowDefinitionId | The workflow definition identifier.

See Also

WorkflowInboxNotificationsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInboxNotificationsInfo Constructor

[image]

OfficeClip API Documentation
WorkflowInboxNotificationsInfo Constructor
WorkflowInboxNotificationsInfo Class See Also

[This is preliminary documentation and is subject to change.]

the default constructor.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowInboxNotificationsInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkflowInboxNotificationsInfo()

See Also

WorkflowInboxNotificationsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInboxNotificationsInfo Properties

[image] [image]

OfficeClip API Documentation
WorkflowInboxNotificationsInfo Properties
WorkflowInboxNotificationsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The WorkflowInboxNotificationsInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Status | The workflow inbox status.
Public property | StatusId | The inbox status identifier.
Public property | WorkflowDefinitionId | The workflow definition identifier.

See Also

WorkflowInboxNotificationsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


Status Property

[image]

OfficeClip API Documentation
WorkflowInboxNotificationsInfo..::.Status Property
WorkflowInboxNotificationsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The workflow inbox status.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Status { get; set; }
Visual Basic (Declaration)
Public Property Status As String
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

See Also

WorkflowInboxNotificationsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


StatusId Property

[image]

OfficeClip API Documentation
WorkflowInboxNotificationsInfo..::.StatusId Property
WorkflowInboxNotificationsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The inbox status identifier.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int StatusId { get; set; }
Visual Basic (Declaration)
Public Property StatusId As Integer
Visual C++
public:
property int StatusId {
    int get ();
    void set (int value);
}

See Also

WorkflowInboxNotificationsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionId Property

[image]

OfficeClip API Documentation
WorkflowInboxNotificationsInfo..::.WorkflowDefinitionId Property
WorkflowInboxNotificationsInfo Class See Also

[This is preliminary documentation and is subject to change.]

The workflow definition identifier.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int WorkflowDefinitionId { get; set; }
Visual Basic (Declaration)
Public Property WorkflowDefinitionId As Integer
Visual C++
public:
property int WorkflowDefinitionId {
    int get ();
    void set (int value);
}

See Also

WorkflowInboxNotificationsInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInfo Class

[image]

OfficeClip API Documentation
WorkflowInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties for ht eworkflow information.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class WorkflowInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class WorkflowInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class WorkflowInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowInfo

See Also

WorkflowInfo Members
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInfo Members

[image] [image]

OfficeClip API Documentation
WorkflowInfo Members
WorkflowInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The WorkflowInfo type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActionId | the Action identifier of the workflow.
Public property | ApplicationId | The application identifier for the application which created the workflow.
Public property | id | the system generated unique workflow identifier.
Public property | ItemUserId | the user identifier of the item.
Public property | RouteToUserId | The user identifier towhom the workflow document is routed to.
Public property | StageId | The workflow stage identifier.
Public property | UserId | The user identifier of the user of this workflow.
Public property | WeekStartingDate | The week starting date for the workflow.
Public property | WorkflowDefinitionId | The workflow definition identifier.
Public property | WorkflowTypeId | The workflow type identifier.

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInfo Constructor

[image] [image]

OfficeClip API Documentation
WorkflowInfo Constructor
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | WorkflowInfo()()() | The default constructor.
Public method | WorkflowInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

WorkflowInfo Class
WorkflowInfo Members
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInfo Constructor

[image]

OfficeClip API Documentation
WorkflowInfo Constructor
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkflowInfo()

See Also

WorkflowInfo Class
WorkflowInfo Overload
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
WorkflowInfo Constructor (SerializationInfo, StreamingContext)
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
WorkflowInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

WorkflowInfo Class
WorkflowInfo Overload
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInfo Methods

[image] [image]

OfficeClip API Documentation
WorkflowInfo Methods
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

The WorkflowInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
WorkflowInfo..::.GetObjectData Method
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowInfo Properties

[image] [image]

OfficeClip API Documentation
WorkflowInfo Properties
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

The WorkflowInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ActionId | the Action identifier of the workflow.
Public property | ApplicationId | The application identifier for the application which created the workflow.
Public property | id | the system generated unique workflow identifier.
Public property | ItemUserId | the user identifier of the item.
Public property | RouteToUserId | The user identifier towhom the workflow document is routed to.
Public property | StageId | The workflow stage identifier.
Public property | UserId | The user identifier of the user of this workflow.
Public property | WeekStartingDate | The week starting date for the workflow.
Public property | WorkflowDefinitionId | The workflow definition identifier.
Public property | WorkflowTypeId | The workflow type identifier.

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


ActionId Property

[image]

OfficeClip API Documentation
WorkflowInfo..::.ActionId Property
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

the Action identifier of the workflow.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ActionId { get; set; }
Visual Basic (Declaration)
Public Property ActionId As Integer
Visual C++
public:
property int ActionId {
    int get ();
    void set (int value);
}

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


ApplicationId Property

[image]

OfficeClip API Documentation
WorkflowInfo..::.ApplicationId Property
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

The application identifier for the application which created the workflow.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ApplicationId { get; set; }
Visual Basic (Declaration)
Public Property ApplicationId As Integer
Visual C++
public:
property int ApplicationId {
    int get ();
    void set (int value);
}

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


id Property

[image]

OfficeClip API Documentation
WorkflowInfo..::.id Property
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

the system generated unique workflow identifier.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int id { get; set; }
Visual Basic (Declaration)
Public Property id As Integer
Visual C++
public:
property int id {
    int get ();
    void set (int value);
}

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


ItemUserId Property

[image]

OfficeClip API Documentation
WorkflowInfo..::.ItemUserId Property
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

the user identifier of the item.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ItemUserId { get; set; }
Visual Basic (Declaration)
Public Property ItemUserId As Integer
Visual C++
public:
property int ItemUserId {
    int get ();
    void set (int value);
}

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


RouteToUserId Property

[image]

OfficeClip API Documentation
WorkflowInfo..::.RouteToUserId Property
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user identifier towhom the workflow document is routed to.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RouteToUserId { get; set; }
Visual Basic (Declaration)
Public Property RouteToUserId As Integer
Visual C++
public:
property int RouteToUserId {
    int get ();
    void set (int value);
}

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


StageId Property

[image]

OfficeClip API Documentation
WorkflowInfo..::.StageId Property
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

The workflow stage identifier.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int StageId { get; set; }
Visual Basic (Declaration)
Public Property StageId As Integer
Visual C++
public:
property int StageId {
    int get ();
    void set (int value);
}

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


UserId Property

[image]

OfficeClip API Documentation
WorkflowInfo..::.UserId Property
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user identifier of the user of this workflow.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WeekStartingDate Property

[image]

OfficeClip API Documentation
WorkflowInfo..::.WeekStartingDate Property
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

The week starting date for the workflow.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime WeekStartingDate { get; set; }
Visual Basic (Declaration)
Public Property WeekStartingDate As DateTime
Visual C++
public:
property DateTime WeekStartingDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowDefinitionId Property

[image]

OfficeClip API Documentation
WorkflowInfo..::.WorkflowDefinitionId Property
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

The workflow definition identifier.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int WorkflowDefinitionId { get; set; }
Visual Basic (Declaration)
Public Property WorkflowDefinitionId As Integer
Visual C++
public:
property int WorkflowDefinitionId {
    int get ();
    void set (int value);
}

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


WorkflowTypeId Property

[image]

OfficeClip API Documentation
WorkflowInfo..::.WorkflowTypeId Property
WorkflowInfo Class See Also

[This is preliminary documentation and is subject to change.]

The workflow type identifier.

Namespace: OfficeClip.BusinessLayer.Framework.Workflow
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int WorkflowTypeId { get; set; }
Visual Basic (Declaration)
Public Property WorkflowTypeId As Integer
Visual C++
public:
property int WorkflowTypeId {
    int get ();
    void set (int value);
}

See Also

WorkflowInfo Class
OfficeClip.BusinessLayer.Framework.Workflow Namespace


OfficeClip.BusinessLayer.Metabase Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Metabase Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the metabase

Classes

 | Class | Description
Public class | ContactRoleDetail |
Public class | HistoryInfo | The history information for the metabase. This objects stores all the metabase history (changes done to any metabase objects or its children).
Public class | MetaConstants | Represents the constants of the metabase
Public class | MetaConvert | Class to convert the meta information into various forms
Public class | MetaFilterInfo | Meta Filter information class
Public class | MetaInfo | The meta information object provides information on an attribute
Public class | MetaInfoCollection | A collection of meta information objects, i.e. a collection of meta attributes
Public class | MetaListInfo | The meta list item information store
Public class | MetaListInfoCollection | Class to represent the list item collection
Public class | MetaQueryString | The class for creating a query string for the metadata
Public class | MetaReportInfo | The meta report information object
Public class | MetaSearch | Class to search for the information defined by a particular pattern
Public class | MetaSelectSet | Class for manipulating the list of meta objects returned from the database
Public class | MetaValidate | Class to validate the meta information
Public class | Relation |
Public class | RelationType |

Enumerations

 | Enumeration | Description
Public enumeration | MetaConstants..::.DateInterval | The date interval enumerated type
Public enumeration | MetaConstants..::.FilterAttributeOrder | Enumeration types for filter attribute order
Public enumeration | MetaConstants..::.FilterFunction | Enumerated type for filter function
Public enumeration | MetaConstants..::.FilterGroupByType | Enumerated type for filter group by
Public enumeration | MetaConstants..::.MetaBasicType | The basic type of the meta list, the basic types are simple types.
Public enumeration | MetaConstants..::.MetaEntity | The meta entity enumerated type
Public enumeration | MetaConstants..::.MetaHistoryState | The meta history search state enumerated type
Public enumeration | MetaConstants..::.MetaJoinType | The join types for meta entity
Public enumeration | MetaConstants..::.MetaSqlTypes | Meta sql enumerated types
Public enumeration | MetaConstants..::.MetaType | The meta type enumeration type
Public enumeration | MetaConstants..::.ReportSortOrder | The report sort order enumerated type


ContactRoleDetail Class

[image]

OfficeClip API Documentation
ContactRoleDetail Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ContactRoleDetail
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ContactRoleDetail
Visual C++
[SerializableAttribute]
public ref class ContactRoleDetail

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.ContactRoleDetail

See Also

ContactRoleDetail Members
OfficeClip.BusinessLayer.Metabase Namespace


ContactRoleDetail Members

[image] [image]

OfficeClip API Documentation
ContactRoleDetail Members
ContactRoleDetail Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ContactRoleDetail type exposes the following members.

Constructors

 | Name | Description
Public method | ContactRoleDetail |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContactId |
Public property | EmailAddress |
Public property | FirstName |
Public property | IsPrimary |
Public property | LastName |
Public property | RoleId |
Public property | RoleName |
Public property | WorkPhone | The Work Phone

See Also

ContactRoleDetail Class
OfficeClip.BusinessLayer.Metabase Namespace


ContactRoleDetail Constructor

[image]

OfficeClip API Documentation
ContactRoleDetail Constructor
ContactRoleDetail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ContactRoleDetail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContactRoleDetail()

See Also

ContactRoleDetail Class
OfficeClip.BusinessLayer.Metabase Namespace


ContactRoleDetail Properties

[image] [image]

OfficeClip API Documentation
ContactRoleDetail Properties
ContactRoleDetail Class See Also

[This is preliminary documentation and is subject to change.]

The ContactRoleDetail type exposes the following properties.

Properties

 | Name | Description
Public property | ContactId |
Public property | EmailAddress |
Public property | FirstName |
Public property | IsPrimary |
Public property | LastName |
Public property | RoleId |
Public property | RoleName |
Public property | WorkPhone | The Work Phone

See Also

ContactRoleDetail Class
OfficeClip.BusinessLayer.Metabase Namespace


ContactId Property

[image]

OfficeClip API Documentation
ContactRoleDetail..::.ContactId Property
ContactRoleDetail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ContactId { get; set; }
Visual Basic (Declaration)
Public Property ContactId As Integer
Visual C++
public:
property int ContactId {
    int get ();
    void set (int value);
}

See Also

ContactRoleDetail Class
OfficeClip.BusinessLayer.Metabase Namespace


EmailAddress Property

[image]

OfficeClip API Documentation
ContactRoleDetail..::.EmailAddress Property
ContactRoleDetail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic (Declaration)
Public Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

ContactRoleDetail Class
OfficeClip.BusinessLayer.Metabase Namespace


FirstName Property

[image]

OfficeClip API Documentation
ContactRoleDetail..::.FirstName Property
ContactRoleDetail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

ContactRoleDetail Class
OfficeClip.BusinessLayer.Metabase Namespace


IsPrimary Property

[image]

OfficeClip API Documentation
ContactRoleDetail..::.IsPrimary Property
ContactRoleDetail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsPrimary { get; set; }
Visual Basic (Declaration)
Public Property IsPrimary As Boolean
Visual C++
public:
property bool IsPrimary {
    bool get ();
    void set (bool value);
}

See Also

ContactRoleDetail Class
OfficeClip.BusinessLayer.Metabase Namespace


LastName Property

[image]

OfficeClip API Documentation
ContactRoleDetail..::.LastName Property
ContactRoleDetail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

ContactRoleDetail Class
OfficeClip.BusinessLayer.Metabase Namespace


RoleId Property

[image]

OfficeClip API Documentation
ContactRoleDetail..::.RoleId Property
ContactRoleDetail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RoleId { get; set; }
Visual Basic (Declaration)
Public Property RoleId As Integer
Visual C++
public:
property int RoleId {
    int get ();
    void set (int value);
}

See Also

ContactRoleDetail Class
OfficeClip.BusinessLayer.Metabase Namespace


RoleName Property

[image]

OfficeClip API Documentation
ContactRoleDetail..::.RoleName Property
ContactRoleDetail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RoleName { get; set; }
Visual Basic (Declaration)
Public Property RoleName As String
Visual C++
public:
property String^ RoleName {
    String^ get ();
    void set (String^ value);
}

See Also

ContactRoleDetail Class
OfficeClip.BusinessLayer.Metabase Namespace


WorkPhone Property

[image]

OfficeClip API Documentation
ContactRoleDetail..::.WorkPhone Property
ContactRoleDetail Class See Also

[This is preliminary documentation and is subject to change.]

The Work Phone

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string WorkPhone { get; set; }
Visual Basic (Declaration)
Public Property WorkPhone As String
Visual C++
public:
property String^ WorkPhone {
    String^ get ();
    void set (String^ value);
}

See Also

ContactRoleDetail Class
OfficeClip.BusinessLayer.Metabase Namespace


HistoryInfo Class

[image]

OfficeClip API Documentation
HistoryInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

The history information for the metabase. This objects stores all the metabase history (changes done to any metabase objects or its children).

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class HistoryInfo
Visual Basic (Declaration)
Public Class HistoryInfo
Visual C++
public ref class HistoryInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.HistoryInfo

See Also

HistoryInfo Members
OfficeClip.BusinessLayer.Metabase Namespace


HistoryInfo Members

[image] [image]

OfficeClip API Documentation
HistoryInfo Members
HistoryInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The HistoryInfo type exposes the following members.

Constructors

 | Name | Description
Public method | HistoryInfo | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the task to the string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | The meta history state
Public property | ChildEntity | The type of child entity
Public property | Desc | The description of the history item
Public property | OType | The meta object type
Public property | PrimaryKey | The unique id of the object
Public property | Timestamp | The time when the history is recorded
Public property | Title | The history title
Public property | UserId | The unique id of the user

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


HistoryInfo Constructor

[image] [image]

OfficeClip API Documentation
HistoryInfo Constructor
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | HistoryInfo()()() | The default constructor
Public method | HistoryInfo(BusinessConstants..::.ObjectType, Int32, MetaConstants..::.MetaEntity, MetaConstants..::.MetaHistoryState, String, String, Int32, DateTime) | The copy constructor

See Also

HistoryInfo Class
HistoryInfo Members
OfficeClip.BusinessLayer.Metabase Namespace


HistoryInfo Constructor

[image]

OfficeClip API Documentation
HistoryInfo Constructor
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public HistoryInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HistoryInfo()

See Also

HistoryInfo Class
HistoryInfo Overload
OfficeClip.BusinessLayer.Metabase Namespace


HistoryInfo Constructor (BusinessConstants.ObjectType, Int32, MetaConstants.MetaEntity, MetaConstants.MetaHistoryState, String, String, Int32, DateTime)

[image]

OfficeClip API Documentation
HistoryInfo Constructor (BusinessConstants..::.ObjectType, Int32, MetaConstants..::.MetaEntity, MetaConstants..::.MetaHistoryState, String, String, Int32, DateTime)
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The copy constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public HistoryInfo(
    BusinessConstants..::.ObjectType oType,
    int primaryKey,
    MetaConstants..::.MetaEntity childEntity,
    MetaConstants..::.MetaHistoryState action,
    string title,
    string desc,
    int userId,
    DateTime timestamp
)
Visual Basic (Declaration)
Public Sub New ( _
    oType As BusinessConstants..::.ObjectType, _
    primaryKey As Integer, _
    childEntity As MetaConstants..::.MetaEntity, _
    action As MetaConstants..::.MetaHistoryState, _
    title As String, _
    desc As String, _
    userId As Integer, _
    timestamp As DateTime _
)
Visual C++
public:
HistoryInfo(
    BusinessConstants..::.ObjectType oType,
    int primaryKey,
    MetaConstants..::.MetaEntity childEntity,
    MetaConstants..::.MetaHistoryState action,
    String^ title,
    String^ desc,
    int userId,
    DateTime timestamp
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type
primaryKey
Type: System..::.Int32
The primary key
childEntity
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The child entity
action
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaHistoryState
The meta history state
title
Type: System..::.String
The title of the history
desc
Type: System..::.String
The history description
userId
Type: System..::.Int32
The unique id of the user
timestamp
Type: System..::.DateTime
The timestamp when the history is recorded

See Also

HistoryInfo Class
HistoryInfo Overload
OfficeClip.BusinessLayer.Metabase Namespace


HistoryInfo Methods

[image] [image]

OfficeClip API Documentation
HistoryInfo Methods
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The HistoryInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the task to the string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Dump Method

[image]

OfficeClip API Documentation
HistoryInfo..::.Dump Method
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the task to the string

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

The string value of the task object

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


HistoryInfo Properties

[image] [image]

OfficeClip API Documentation
HistoryInfo Properties
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The HistoryInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Action | The meta history state
Public property | ChildEntity | The type of child entity
Public property | Desc | The description of the history item
Public property | OType | The meta object type
Public property | PrimaryKey | The unique id of the object
Public property | Timestamp | The time when the history is recorded
Public property | Title | The history title
Public property | UserId | The unique id of the user

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Action Property

[image]

OfficeClip API Documentation
HistoryInfo..::.Action Property
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The meta history state

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaConstants..::.MetaHistoryState Action { get; set; }
Visual Basic (Declaration)
Public Property Action As MetaConstants..::.MetaHistoryState
Visual C++
public:
property MetaConstants..::.MetaHistoryState Action {
    MetaConstants..::.MetaHistoryState get ();
    void set (MetaConstants..::.MetaHistoryState value);
}

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


ChildEntity Property

[image]

OfficeClip API Documentation
HistoryInfo..::.ChildEntity Property
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The type of child entity

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaConstants..::.MetaEntity ChildEntity { get; set; }
Visual Basic (Declaration)
Public Property ChildEntity As MetaConstants..::.MetaEntity
Visual C++
public:
property MetaConstants..::.MetaEntity ChildEntity {
    MetaConstants..::.MetaEntity get ();
    void set (MetaConstants..::.MetaEntity value);
}

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Desc Property

[image]

OfficeClip API Documentation
HistoryInfo..::.Desc Property
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The description of the history item

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Desc { get; set; }
Visual Basic (Declaration)
Public Property Desc As String
Visual C++
public:
property String^ Desc {
    String^ get ();
    void set (String^ value);
}

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


OType Property

[image]

OfficeClip API Documentation
HistoryInfo..::.OType Property
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The meta object type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants..::.ObjectType OType { get; set; }
Visual Basic (Declaration)
Public Property OType As BusinessConstants..::.ObjectType
Visual C++
public:
property BusinessConstants..::.ObjectType OType {
    BusinessConstants..::.ObjectType get ();
    void set (BusinessConstants..::.ObjectType value);
}

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


PrimaryKey Property

[image]

OfficeClip API Documentation
HistoryInfo..::.PrimaryKey Property
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the object

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int PrimaryKey { get; set; }
Visual Basic (Declaration)
Public Property PrimaryKey As Integer
Visual C++
public:
property int PrimaryKey {
    int get ();
    void set (int value);
}

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Timestamp Property

[image]

OfficeClip API Documentation
HistoryInfo..::.Timestamp Property
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time when the history is recorded

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime Timestamp { get; set; }
Visual Basic (Declaration)
Public Property Timestamp As DateTime
Visual C++
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Title Property

[image]

OfficeClip API Documentation
HistoryInfo..::.Title Property
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The history title

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


UserId Property

[image]

OfficeClip API Documentation
HistoryInfo..::.UserId Property
HistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

HistoryInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants Class

[image]

OfficeClip API Documentation
MetaConstants Class
Members See Also

[This is preliminary documentation and is subject to change.]

Represents the constants of the metabase

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaConstants
Visual Basic (Declaration)
Public Class MetaConstants
Visual C++
public ref class MetaConstants

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaConstants

See Also

MetaConstants Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants Members

[image] [image]

OfficeClip API Documentation
MetaConstants Members
MetaConstants Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaConstants type exposes the following members.

Constructors

 | Name | Description
Public method | MetaConstants |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetApplicationTypeFromMetaEntity | Gets the application type from the meta entity
 | GetAttributeName | Gets the name of the attribute from the metabase datatable
 | GetAttributeType | Gets the type of the attribute from the metabase datatable
 | GetBasicType | Get the basic type given the meta type
 | GetBasicTypeName | Gets the meta basic type name from the meta basic type id
 | GetConditionString | Gets the conditions string from the filter
 | GetEditUrl | Gets the edit url
 | GetEntityFromObjectType | Returns the mapping of meta entity from the object type
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHistoryNotes | Gets the notes to be shown on the history
 | GetListUrl | Gets the url for the list
 | GetMetaCsvPath | Gets the meta csv path. This is the path where the csv file will be stored
 | GetMetaEntityName | Gets the entity name from the entity enumeration type
 | GetMetaTypeName | Translates the meta type name from the meta type enumerated type
 | GetObjectTypeFromEntity | Returns the mapping of object type from the meta entity
 | GetOcCsvPropertyList | Gets the OfficeClip project property list
 | GetReadUrl | Gets the url for the read
 | GetReportTypeSize | Gets the report type size. This is used for rendering the report
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsMetaEditable | Shows whether the entity is editable by any user. This parameter itself does not give the full access, the security object should provide permission to do this.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MetaHistoryStateString | Gets the meta history state search string from the meta history search type
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
HugeTextColumnSize | Size of the Long Text Column, usually used for long description
HugeTextRowSize | Size of the Long Text Row, usually used for long description
LongTextCharacterSize | Maximum number of characters on the Long Text Field
LongTextColumnSize | Size of the Long Text Column, usually used for long description
LongTextRowSize | Size of the Long Text Row, usually used for long description
ReportFieldsLimit | Maximum number of fields that a report can have
ShortTextCharacterSize | The number of characters in the short text
ShortTextColumnSize | The number of columns of the short text
ShortTextRowSize | The number of rows for the short text
TextCharacterSize | The total number of characters in the long text
TextColumnSize | The column size of the long text. Usually used for smaller description
TextRowSize | The row size of long text, usually used for smaller description

Properties

Name | Description
HugeTextCharacterSize | Maximum number of characters on the Long Text Field

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants Constructor

[image]

OfficeClip API Documentation
MetaConstants Constructor
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaConstants()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaConstants()

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants Fields

[image] [image]

OfficeClip API Documentation
MetaConstants Fields
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The MetaConstants type exposes the following fields.

Fields

Name | Description
HugeTextColumnSize | Size of the Long Text Column, usually used for long description
HugeTextRowSize | Size of the Long Text Row, usually used for long description
LongTextCharacterSize | Maximum number of characters on the Long Text Field
LongTextColumnSize | Size of the Long Text Column, usually used for long description
LongTextRowSize | Size of the Long Text Row, usually used for long description
ReportFieldsLimit | Maximum number of fields that a report can have
ShortTextCharacterSize | The number of characters in the short text
ShortTextColumnSize | The number of columns of the short text
ShortTextRowSize | The number of rows for the short text
TextCharacterSize | The total number of characters in the long text
TextColumnSize | The column size of the long text. Usually used for smaller description
TextRowSize | The row size of long text, usually used for smaller description

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


HugeTextColumnSize Field

[image]

OfficeClip API Documentation
MetaConstants..::.HugeTextColumnSize Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Size of the Long Text Column, usually used for long description

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int HugeTextColumnSize
Visual Basic (Declaration)
Public Shared ReadOnly HugeTextColumnSize As Integer
Visual C++
public:
static initonly int HugeTextColumnSize

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


HugeTextRowSize Field

[image]

OfficeClip API Documentation
MetaConstants..::.HugeTextRowSize Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Size of the Long Text Row, usually used for long description

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int HugeTextRowSize
Visual Basic (Declaration)
Public Shared ReadOnly HugeTextRowSize As Integer
Visual C++
public:
static initonly int HugeTextRowSize

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


LongTextCharacterSize Field

[image]

OfficeClip API Documentation
MetaConstants..::.LongTextCharacterSize Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Maximum number of characters on the Long Text Field

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int LongTextCharacterSize
Visual Basic (Declaration)
Public Shared ReadOnly LongTextCharacterSize As Integer
Visual C++
public:
static initonly int LongTextCharacterSize

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


LongTextColumnSize Field

[image]

OfficeClip API Documentation
MetaConstants..::.LongTextColumnSize Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Size of the Long Text Column, usually used for long description

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int LongTextColumnSize
Visual Basic (Declaration)
Public Shared ReadOnly LongTextColumnSize As Integer
Visual C++
public:
static initonly int LongTextColumnSize

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


LongTextRowSize Field

[image]

OfficeClip API Documentation
MetaConstants..::.LongTextRowSize Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Size of the Long Text Row, usually used for long description

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int LongTextRowSize
Visual Basic (Declaration)
Public Shared ReadOnly LongTextRowSize As Integer
Visual C++
public:
static initonly int LongTextRowSize

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


ReportFieldsLimit Field

[image]

OfficeClip API Documentation
MetaConstants..::.ReportFieldsLimit Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Maximum number of fields that a report can have

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int ReportFieldsLimit
Visual Basic (Declaration)
Public Shared ReadOnly ReportFieldsLimit As Integer
Visual C++
public:
static initonly int ReportFieldsLimit

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


ShortTextCharacterSize Field

[image]

OfficeClip API Documentation
MetaConstants..::.ShortTextCharacterSize Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The number of characters in the short text

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int ShortTextCharacterSize
Visual Basic (Declaration)
Public Shared ReadOnly ShortTextCharacterSize As Integer
Visual C++
public:
static initonly int ShortTextCharacterSize

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


ShortTextColumnSize Field

[image]

OfficeClip API Documentation
MetaConstants..::.ShortTextColumnSize Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The number of columns of the short text

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int ShortTextColumnSize
Visual Basic (Declaration)
Public Shared ReadOnly ShortTextColumnSize As Integer
Visual C++
public:
static initonly int ShortTextColumnSize

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


ShortTextRowSize Field

[image]

OfficeClip API Documentation
MetaConstants..::.ShortTextRowSize Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The number of rows for the short text

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int ShortTextRowSize
Visual Basic (Declaration)
Public Shared ReadOnly ShortTextRowSize As Integer
Visual C++
public:
static initonly int ShortTextRowSize

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


TextCharacterSize Field

[image]

OfficeClip API Documentation
MetaConstants..::.TextCharacterSize Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The total number of characters in the long text

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int TextCharacterSize
Visual Basic (Declaration)
Public Shared ReadOnly TextCharacterSize As Integer
Visual C++
public:
static initonly int TextCharacterSize

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


TextColumnSize Field

[image]

OfficeClip API Documentation
MetaConstants..::.TextColumnSize Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The column size of the long text. Usually used for smaller description

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int TextColumnSize
Visual Basic (Declaration)
Public Shared ReadOnly TextColumnSize As Integer
Visual C++
public:
static initonly int TextColumnSize

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


TextRowSize Field

[image]

OfficeClip API Documentation
MetaConstants..::.TextRowSize Field
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The row size of long text, usually used for smaller description

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int TextRowSize
Visual Basic (Declaration)
Public Shared ReadOnly TextRowSize As Integer
Visual C++
public:
static initonly int TextRowSize

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants Methods

[image] [image]

OfficeClip API Documentation
MetaConstants Methods
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The MetaConstants type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetApplicationTypeFromMetaEntity | Gets the application type from the meta entity
 | GetAttributeName | Gets the name of the attribute from the metabase datatable
 | GetAttributeType | Gets the type of the attribute from the metabase datatable
 | GetBasicType | Get the basic type given the meta type
 | GetBasicTypeName | Gets the meta basic type name from the meta basic type id
 | GetConditionString | Gets the conditions string from the filter
 | GetEditUrl | Gets the edit url
 | GetEntityFromObjectType | Returns the mapping of meta entity from the object type
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHistoryNotes | Gets the notes to be shown on the history
 | GetListUrl | Gets the url for the list
 | GetMetaCsvPath | Gets the meta csv path. This is the path where the csv file will be stored
 | GetMetaEntityName | Gets the entity name from the entity enumeration type
 | GetMetaTypeName | Translates the meta type name from the meta type enumerated type
 | GetObjectTypeFromEntity | Returns the mapping of object type from the meta entity
 | GetOcCsvPropertyList | Gets the OfficeClip project property list
 | GetReadUrl | Gets the url for the read
 | GetReportTypeSize | Gets the report type size. This is used for rendering the report
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsMetaEditable | Shows whether the entity is editable by any user. This parameter itself does not give the full access, the security object should provide permission to do this.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MetaHistoryStateString | Gets the meta history state search string from the meta history search type
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetApplicationTypeFromMetaEntity Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetApplicationTypeFromMetaEntity Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the application type from the meta entity

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static Constants..::.ApplicationType GetApplicationTypeFromMetaEntity(
    MetaConstants..::.MetaEntity me
)
Visual Basic (Declaration)
Public Shared Function GetApplicationTypeFromMetaEntity ( _
    me As MetaConstants..::.MetaEntity _
) As Constants..::.ApplicationType
Visual C++
public:
static Constants..::.ApplicationType GetApplicationTypeFromMetaEntity(
    MetaConstants..::.MetaEntity me
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity

Return Value

The application type

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetAttributeName Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetAttributeName Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the name of the attribute from the metabase datatable

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetAttributeName(
    ref DataTable dtMetabase,
    int attrId
)
Visual Basic (Declaration)
Public Shared Function GetAttributeName ( _
    ByRef dtMetabase As DataTable, _
    attrId As Integer _
) As String
Visual C++
public:
static String^ GetAttributeName(
    DataTable^% dtMetabase,
    int attrId
)

Parameters

dtMetabase
Type: System.Data..::.DataTable%
The Metabase table
attrId
Type: System..::.Int32
The unique id of the attribute

Return Value

The attribute name

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetAttributeType Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetAttributeType Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the type of the attribute from the metabase datatable

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static MetaConstants..::.MetaType GetAttributeType(
    ref DataTable dtMetabase,
    int attrId
)
Visual Basic (Declaration)
Public Shared Function GetAttributeType ( _
    ByRef dtMetabase As DataTable, _
    attrId As Integer _
) As MetaConstants..::.MetaType
Visual C++
public:
static MetaConstants..::.MetaType GetAttributeType(
    DataTable^% dtMetabase,
    int attrId
)

Parameters

dtMetabase
Type: System.Data..::.DataTable%
The Metabase table
attrId
Type: System..::.Int32
The unique id of the attribute

Return Value

The attribute name

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetBasicType Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetBasicType Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Get the basic type given the meta type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static MetaConstants..::.MetaBasicType GetBasicType(
    MetaConstants..::.MetaType mt
)
Visual Basic (Declaration)
Public Shared Function GetBasicType ( _
    mt As MetaConstants..::.MetaType _
) As MetaConstants..::.MetaBasicType
Visual C++
public:
static MetaConstants..::.MetaBasicType GetBasicType(
    MetaConstants..::.MetaType mt
)

Parameters

mt
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaType
The meta type

Return Value

The basic type

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetBasicTypeName Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetBasicTypeName Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta basic type name from the meta basic type id

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetBasicTypeName(
    MetaConstants..::.MetaBasicType mt
)
Visual Basic (Declaration)
Public Shared Function GetBasicTypeName ( _
    mt As MetaConstants..::.MetaBasicType _
) As String
Visual C++
public:
static String^ GetBasicTypeName(
    MetaConstants..::.MetaBasicType mt
)

Parameters

mt
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaBasicType
The meta basic type id

Return Value

The meta basic type name

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetConditionString Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetConditionString Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the conditions string from the filter

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetConditionString(
    MetaConstants..::.FilterFunction ffunc
)
Visual Basic (Declaration)
Public Shared Function GetConditionString ( _
    ffunc As MetaConstants..::.FilterFunction _
) As String
Visual C++
public:
static String^ GetConditionString(
    MetaConstants..::.FilterFunction ffunc
)

Parameters

ffunc
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.FilterFunction
The filter function

Return Value

The condition string, this is usually used for visual aid

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetEditUrl Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetEditUrl Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the edit url

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetEditUrl(
    MetaConstants..::.MetaEntity me
)
Visual Basic (Declaration)
Public Shared Function GetEditUrl ( _
    me As MetaConstants..::.MetaEntity _
) As String
Visual C++
public:
static String^ GetEditUrl(
    MetaConstants..::.MetaEntity me
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity

Return Value

The edit url string

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetEntityFromObjectType Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetEntityFromObjectType Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the mapping of meta entity from the object type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static MetaConstants..::.MetaEntity GetEntityFromObjectType(
    BusinessConstants..::.ObjectType oType
)
Visual Basic (Declaration)
Public Shared Function GetEntityFromObjectType ( _
    oType As BusinessConstants..::.ObjectType _
) As MetaConstants..::.MetaEntity
Visual C++
public:
static MetaConstants..::.MetaEntity GetEntityFromObjectType(
    BusinessConstants..::.ObjectType oType
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The type of the object

Return Value

The meta entity

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetHistoryNotes Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetHistoryNotes Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the notes to be shown on the history

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetHistoryNotes(
    int historyActionId,
    string title,
    string comment
)
Visual Basic (Declaration)
Public Shared Function GetHistoryNotes ( _
    historyActionId As Integer, _
    title As String, _
    comment As String _
) As String
Visual C++
public:
static String^ GetHistoryNotes(
    int historyActionId,
    String^ title,
    String^ comment
)

Parameters

historyActionId
Type: System..::.Int32
The action id for the history
title
Type: System..::.String
The title of the history
comment
Type: System..::.String
The comments for the history

Return Value

The history note string

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetListUrl Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetListUrl Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the url for the list

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetListUrl(
    MetaConstants..::.MetaEntity me
)
Visual Basic (Declaration)
Public Shared Function GetListUrl ( _
    me As MetaConstants..::.MetaEntity _
) As String
Visual C++
public:
static String^ GetListUrl(
    MetaConstants..::.MetaEntity me
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity

Return Value

The url string

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetMetaCsvPath Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetMetaCsvPath Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta csv path. This is the path where the csv file will be stored

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetMetaCsvPath(
    MetaConstants..::.MetaEntity me,
    int externalId
)
Visual Basic (Declaration)
Public Shared Function GetMetaCsvPath ( _
    me As MetaConstants..::.MetaEntity, _
    externalId As Integer _
) As String
Visual C++
public:
static String^ GetMetaCsvPath(
    MetaConstants..::.MetaEntity me,
    int externalId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalId
Type: System..::.Int32
The external id, usually the group id

Return Value

The csv path

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetMetaEntityName Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetMetaEntityName Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the entity name from the entity enumeration type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetMetaEntityName(
    MetaConstants..::.MetaEntity me
)
Visual Basic (Declaration)
Public Shared Function GetMetaEntityName ( _
    me As MetaConstants..::.MetaEntity _
) As String
Visual C++
public:
static String^ GetMetaEntityName(
    MetaConstants..::.MetaEntity me
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The entity enumeration type

Return Value

The meta entity name

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetMetaTypeName Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetMetaTypeName Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Translates the meta type name from the meta type enumerated type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetMetaTypeName(
    MetaConstants..::.MetaType mt
)
Visual Basic (Declaration)
Public Shared Function GetMetaTypeName ( _
    mt As MetaConstants..::.MetaType _
) As String
Visual C++
public:
static String^ GetMetaTypeName(
    MetaConstants..::.MetaType mt
)

Parameters

mt
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaType
The meta type

Return Value

The type name

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetObjectTypeFromEntity Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetObjectTypeFromEntity Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the mapping of object type from the meta entity

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static BusinessConstants..::.ObjectType GetObjectTypeFromEntity(
    MetaConstants..::.MetaEntity entityId
)
Visual Basic (Declaration)
Public Shared Function GetObjectTypeFromEntity ( _
    entityId As MetaConstants..::.MetaEntity _
) As BusinessConstants..::.ObjectType
Visual C++
public:
static BusinessConstants..::.ObjectType GetObjectTypeFromEntity(
    MetaConstants..::.MetaEntity entityId
)

Parameters

entityId
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The id of the entity

Return Value

The object type

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetOcCsvPropertyList Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetOcCsvPropertyList Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the OfficeClip project property list

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataView GetOcCsvPropertyList(
    Object o
)
Visual Basic (Declaration)
Public Shared Function GetOcCsvPropertyList ( _
    o As Object _
) As DataView
Visual C++
public:
static DataView^ GetOcCsvPropertyList(
    Object^ o
)

Parameters

o
Type: System..::.Object
The input object

Return Value

The dataview that gives the project property list

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetReadUrl Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetReadUrl Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the url for the read

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetReadUrl(
    MetaConstants..::.MetaEntity me
)
Visual Basic (Declaration)
Public Shared Function GetReadUrl ( _
    me As MetaConstants..::.MetaEntity _
) As String
Visual C++
public:
static String^ GetReadUrl(
    MetaConstants..::.MetaEntity me
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity

Return Value

The url string

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


GetReportTypeSize Method

[image]

OfficeClip API Documentation
MetaConstants..::.GetReportTypeSize Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the report type size. This is used for rendering the report

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static int GetReportTypeSize(
    MetaConstants..::.MetaType mt
)
Visual Basic (Declaration)
Public Shared Function GetReportTypeSize ( _
    mt As MetaConstants..::.MetaType _
) As Integer
Visual C++
public:
static int GetReportTypeSize(
    MetaConstants..::.MetaType mt
)

Parameters

mt
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaType
The meta type for the report

Return Value

The type size of the report

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


IsMetaEditable Method

[image]

OfficeClip API Documentation
MetaConstants..::.IsMetaEditable Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the entity is editable by any user. This parameter itself does not give the full access, the security object should provide permission to do this.

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool IsMetaEditable(
    MetaConstants..::.MetaEntity me,
    bool[] roleAccess
)
Visual Basic (Declaration)
Public Shared Function IsMetaEditable ( _
    me As MetaConstants..::.MetaEntity, _
    roleAccess As Boolean() _
) As Boolean
Visual C++
public:
static bool IsMetaEditable(
    MetaConstants..::.MetaEntity me,
    array<bool>^ roleAccess
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
roleAccess
Type: array<System..::.Boolean>[]()[]
The role access matrix.

Return Value

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaHistoryStateString Method

[image]

OfficeClip API Documentation
MetaConstants..::.MetaHistoryStateString Method
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta history state search string from the meta history search type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string MetaHistoryStateString(
    MetaConstants..::.MetaHistoryState mhs
)
Visual Basic (Declaration)
Public Shared Function MetaHistoryStateString ( _
    mhs As MetaConstants..::.MetaHistoryState _
) As String
Visual C++
public:
static String^ MetaHistoryStateString(
    MetaConstants..::.MetaHistoryState mhs
)

Parameters

mhs
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaHistoryState
The meta history search state

Return Value

The meta history search string

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants Properties

[image] [image]

OfficeClip API Documentation
MetaConstants Properties
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The MetaConstants type exposes the following properties.

Properties

Name | Description
HugeTextCharacterSize | Maximum number of characters on the Long Text Field

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


HugeTextCharacterSize Property

[image]

OfficeClip API Documentation
MetaConstants..::.HugeTextCharacterSize Property
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Maximum number of characters on the Long Text Field

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static int HugeTextCharacterSize { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HugeTextCharacterSize As Integer
Visual C++
public:
static property int HugeTextCharacterSize {
    int get ();
}

See Also

MetaConstants Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants.DateInterval Enumeration

[image]

OfficeClip API Documentation
MetaConstants..::.DateInterval Enumeration
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The date interval enumerated type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum DateInterval
Visual Basic (Declaration)
Public Enumeration DateInterval
Visual C++
public enum class DateInterval

Members

Member name | Description
None | Default
Today | Today
Yesterday | Yesterday
LastWeek | Last Week
LastMonth | Last Month
LastQuarter | Last Quarter
LastYear | Last Year

See Also

OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants.FilterAttributeOrder Enumeration

[image]

OfficeClip API Documentation
MetaConstants..::.FilterAttributeOrder Enumeration
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Enumeration types for filter attribute order

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum FilterAttributeOrder
Visual Basic (Declaration)
Public Enumeration FilterAttributeOrder
Visual C++
public enum class FilterAttributeOrder

Members

Member name | Description
None | The default order
Asc | The ascending order
Desc | The descending order

See Also

OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants.FilterFunction Enumeration

[image]

OfficeClip API Documentation
MetaConstants..::.FilterFunction Enumeration
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for filter function

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum FilterFunction
Visual Basic (Declaration)
Public Enumeration FilterFunction
Visual C++
public enum class FilterFunction

Members

Member name | Description
None | Default
Eq | Equals
Gt | Greater Than
Lt | Less Than
Ge | Greater Than and Equal to
Le | Less than and Equal To
Ne | Not Equal

See Also

OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants.FilterGroupByType Enumeration

[image]

OfficeClip API Documentation
MetaConstants..::.FilterGroupByType Enumeration
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for filter group by

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum FilterGroupByType
Visual Basic (Declaration)
Public Enumeration FilterGroupByType
Visual C++
public enum class FilterGroupByType

Members

Member name | Description
None | Default

See Also

OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants.MetaBasicType Enumeration

[image]

OfficeClip API Documentation
MetaConstants..::.MetaBasicType Enumeration
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The basic type of the meta list, the basic types are simple types.

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum MetaBasicType
Visual Basic (Declaration)
Public Enumeration MetaBasicType
Visual C++
public enum class MetaBasicType

Members

Member name | Description
None | The default basic type
List | The list basic type
Text | The text basic type
Number | The number basic type
Float | The float basic type
Date | The date basic type, this contains the date and datetime
Boolean | The boolean basic type
Ids | The basic type for all the ids

See Also

OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants.MetaEntity Enumeration

[image]

OfficeClip API Documentation
MetaConstants..::.MetaEntity Enumeration
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The meta entity enumerated type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum MetaEntity
Visual Basic (Declaration)
Public Enumeration MetaEntity
Visual C++
public enum class MetaEntity

Members

Member name | Description
None | The default metaentity
Test | The meta entity used for testing
Contact | The contact meta entity
Appointment | The appointment meta entity
Task | The task meta entity
Document | The document meta entity
Filter | The filter meta entity
TrackerProject | The tracker project meta entity
Email | The Email MetaEntity
Note | The Note
TrackerCase | Issue
Account | Account
Opportunity | Opportunity
Projects | Projects in general
CampaignInfo | Campaign Info

See Also

OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants.MetaHistoryState Enumeration

[image]

OfficeClip API Documentation
MetaConstants..::.MetaHistoryState Enumeration
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The meta history search state enumerated type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum MetaHistoryState
Visual Basic (Declaration)
Public Enumeration MetaHistoryState
Visual C++
public enum class MetaHistoryState

Members

Member name | Description
None | No State
Added | The entity is added
Modified | The entity is modified
Deleted | The entity is deleted
Reassigned | The entity is reassigned
Completed | The entity is completed
UpdatedTo | The entity is updated to a certain value
AssignedTo | The entity is assigned to a certain value

See Also

OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants.MetaJoinType Enumeration

[image]

OfficeClip API Documentation
MetaConstants..::.MetaJoinType Enumeration
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The join types for meta entity

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum MetaJoinType
Visual Basic (Declaration)
Public Enumeration MetaJoinType
Visual C++
public enum class MetaJoinType

Members

Member name | Description
None | The default meta join type
Inner | The inner join type
Left | The left join type
LeftOuter | The left outer join type
Right | The right join type
RightOuter | The right outer join type

See Also

OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants.MetaSqlTypes Enumeration

[image]

OfficeClip API Documentation
MetaConstants..::.MetaSqlTypes Enumeration
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

Meta sql enumerated types

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum MetaSqlTypes
Visual Basic (Declaration)
Public Enumeration MetaSqlTypes
Visual C++
public enum class MetaSqlTypes

Members

Member name | Description
None | The default type
SqlSelectByPk | Select by primary key
SqlSelectAll | Select All
SqlSelectByFilter | select by filter
SqlSelectLists | select lists
SqlInsert | insert
SqlDelete | Delete
SqlUpdateFixed | Update for fixed attribute type
SqlUpdateUdf | Update for udf attribute type
SqlSelectPreferred | selection criteria for preferred values

See Also

OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants.MetaType Enumeration

[image]

OfficeClip API Documentation
MetaConstants..::.MetaType Enumeration
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The meta type enumeration type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum MetaType
Visual Basic (Declaration)
Public Enumeration MetaType
Visual C++
public enum class MetaType

Members

Member name | Description
None | Default
List | The List Type
Date | The Date Type
DateTime | The DateTime Type
ShortText | The short text type
Text | The long text type
Number | The number type
Float | The float type
Email | The Email type
Identifier | The identifier type, denotes unique identifier
ForeignKey | The foreign key type
Currency | The currency type
Boolean | The boolean type, usually a checkbox, cannot be null
ListLookup | The list lookup type, use the external popup instead of drop down, no new value can be entered
PickList | The picklist type, using an external popup to aid entering the value
LongText | The Long Text Type
UserList | The user list, shows a list of all members of the current group
OwnerList | The owner list
AccountList | The Account list, shows a list of all accounts of the current group
HugeText | The huge text is really limited by the database varchar(max) size.
UnknownType | The unknown type. These are the types that is not visible anywhere with metadata.
MetaTypeLength | Requires to create array, change this value if the number of this list item is changed

See Also

OfficeClip.BusinessLayer.Metabase Namespace


MetaConstants.ReportSortOrder Enumeration

[image]

OfficeClip API Documentation
MetaConstants..::.ReportSortOrder Enumeration
MetaConstants Class See Also

[This is preliminary documentation and is subject to change.]

The report sort order enumerated type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ReportSortOrder
Visual Basic (Declaration)
Public Enumeration ReportSortOrder
Visual C++
public enum class ReportSortOrder

Members

Member name | Description
None | The default
OriginalOrder | The original order
Ascending | The ascending order
Descending | The descending order

See Also

OfficeClip.BusinessLayer.Metabase Namespace


MetaConvert Class

[image]

OfficeClip API Documentation
MetaConvert Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to convert the meta information into various forms

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaConvert
Visual Basic (Declaration)
Public Class MetaConvert
Visual C++
public ref class MetaConvert

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaConvert

See Also

MetaConvert Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaConvert Members

[image] [image]

OfficeClip API Documentation
MetaConvert Members
MetaConvert Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The MetaConvert type exposes the following members.

Constructors

 | Name | Description
Public method | MetaConvert |

Methods

 | Name | Description
 | ConvertFromDateInterval | Overloaded.
 | ConvertFromTrackerType | Converts the tracker type to the metabase type
 | ConvertHashTable | Converts the hashtable to be processed by the insert. Note that any fields that is not matched with the proper type will be flagged as null
 | ConvertToDateInterval | Converts the input string to a date interval
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetListValueFromText | Gets the list values from the dataset using a lookup id
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MetaTypeConvertSql | Converts the meta information for sql processing
 | MetaTypeSqlConvertFrom | Used for conversion functions for creating the sql statement
 | MetaTypeSqlConvertTo | Used for conversion functions for creating the sql statement
 | RefreshDataSet | Refreshes the dataset
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaConvert Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaConvert Constructor

[image]

OfficeClip API Documentation
MetaConvert Constructor
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaConvert()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaConvert()

See Also

MetaConvert Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaConvert Methods

[image] [image]

OfficeClip API Documentation
MetaConvert Methods
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

The MetaConvert type exposes the following methods.

Methods

 | Name | Description
 | ConvertFromDateInterval | Overloaded.
 | ConvertFromTrackerType | Converts the tracker type to the metabase type
 | ConvertHashTable | Converts the hashtable to be processed by the insert. Note that any fields that is not matched with the proper type will be flagged as null
 | ConvertToDateInterval | Converts the input string to a date interval
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetListValueFromText | Gets the list values from the dataset using a lookup id
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MetaTypeConvertSql | Converts the meta information for sql processing
 | MetaTypeSqlConvertFrom | Used for conversion functions for creating the sql statement
 | MetaTypeSqlConvertTo | Used for conversion functions for creating the sql statement
 | RefreshDataSet | Refreshes the dataset
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaConvert Class
OfficeClip.BusinessLayer.Metabase Namespace


ConvertFromDateInterval Method

[image] [image]

OfficeClip API Documentation
MetaConvert..::.ConvertFromDateInterval Method
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFromDateInterval(String) | Converts the date interval to string
ConvertFromDateInterval(MetaConstants..::.DateInterval) | Converts the date interval to string

See Also

MetaConvert Class
MetaConvert Members
OfficeClip.BusinessLayer.Metabase Namespace


ConvertFromDateInterval Method (String)

[image]

OfficeClip API Documentation
MetaConvert..::.ConvertFromDateInterval Method (String)
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the date interval to string

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string ConvertFromDateInterval(
    string strDi
)
Visual Basic (Declaration)
Public Shared Function ConvertFromDateInterval ( _
    strDi As String _
) As String
Visual C++
public:
static String^ ConvertFromDateInterval(
    String^ strDi
)

Parameters

strDi
Type: System..::.String
The date interval to be converted

Return Value

The converted string

See Also

MetaConvert Class
ConvertFromDateInterval Overload
OfficeClip.BusinessLayer.Metabase Namespace


ConvertFromDateInterval Method (MetaConstants.DateInterval)

[image]

OfficeClip API Documentation
MetaConvert..::.ConvertFromDateInterval Method (MetaConstants..::.DateInterval)
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the date interval to string

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string ConvertFromDateInterval(
    MetaConstants..::.DateInterval di
)
Visual Basic (Declaration)
Public Shared Function ConvertFromDateInterval ( _
    di As MetaConstants..::.DateInterval _
) As String
Visual C++
public:
static String^ ConvertFromDateInterval(
    MetaConstants..::.DateInterval di
)

Parameters

di
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.DateInterval
The date interval to be converted

Return Value

The converted string

See Also

MetaConvert Class
ConvertFromDateInterval Overload
OfficeClip.BusinessLayer.Metabase Namespace


ConvertFromTrackerType Method

[image]

OfficeClip API Documentation
MetaConvert..::.ConvertFromTrackerType Method
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the tracker type to the metabase type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static MetaConstants..::.MetaType ConvertFromTrackerType(
    string type
)
Visual Basic (Declaration)
Public Shared Function ConvertFromTrackerType ( _
    type As String _
) As MetaConstants..::.MetaType
Visual C++
public:
static MetaConstants..::.MetaType ConvertFromTrackerType(
    String^ type
)

Parameters

type
Type: System..::.String
The type as specified in the tracker

Return Value

The metadata type corresponding to the tracker type

See Also

MetaConvert Class
OfficeClip.BusinessLayer.Metabase Namespace


ConvertHashTable Method

[image]

OfficeClip API Documentation
MetaConvert..::.ConvertHashTable Method
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the hashtable to be processed by the insert. Note that any fields that is not matched with the proper type will be flagged as null

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static Hashtable ConvertHashTable(
    DataSet ds,
    Hashtable inpHash,
    List<UserInfo> uil
)
Visual Basic (Declaration)
Public Shared Function ConvertHashTable ( _
    ds As DataSet, _
    inpHash As Hashtable, _
    uil As List(Of UserInfo) _
) As Hashtable
Visual C++
public:
static Hashtable^ ConvertHashTable(
    DataSet^ ds,
    Hashtable^ inpHash,
    List<UserInfo^>^ uil
)

Parameters

ds
Type: System.Data..::.DataSet
The dataset
inpHash
Type: System.Collections..::.Hashtable
The input hash table
uil
Type: System.Collections.Generic..::.List<(Of <( UserInfo >)>)
The datatable of the owners

Return Value

See Also

MetaConvert Class
OfficeClip.BusinessLayer.Metabase Namespace


ConvertToDateInterval Method

[image]

OfficeClip API Documentation
MetaConvert..::.ConvertToDateInterval Method
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the input string to a date interval

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static MetaConstants..::.DateInterval ConvertToDateInterval(
    string str
)
Visual Basic (Declaration)
Public Shared Function ConvertToDateInterval ( _
    str As String _
) As MetaConstants..::.DateInterval
Visual C++
public:
static MetaConstants..::.DateInterval ConvertToDateInterval(
    String^ str
)

Parameters

str
Type: System..::.String
The string to be converted

Return Value

The converted date interval

See Also

MetaConvert Class
OfficeClip.BusinessLayer.Metabase Namespace


GetListValueFromText Method

[image]

OfficeClip API Documentation
MetaConvert..::.GetListValueFromText Method
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list values from the dataset using a lookup id

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetListValueFromText(
    DataSet ds,
    int lookupId,
    Object oVal
)
Visual Basic (Declaration)
Public Shared Function GetListValueFromText ( _
    ds As DataSet, _
    lookupId As Integer, _
    oVal As Object _
) As String
Visual C++
public:
static String^ GetListValueFromText(
    DataSet^ ds,
    int lookupId,
    Object^ oVal
)

Parameters

ds
Type: System.Data..::.DataSet
The meta dataset
lookupId
Type: System..::.Int32
The id to lookup for the list values
oVal
Type: System..::.Object
The object value

Return Value

The list value

See Also

MetaConvert Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaTypeConvertSql Method

[image]

OfficeClip API Documentation
MetaConvert..::.MetaTypeConvertSql Method
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the meta information for sql processing

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static Object MetaTypeConvertSql(
    Object o,
    MetaConstants..::.MetaType mt,
    bool isFixed
)
Visual Basic (Declaration)
Public Shared Function MetaTypeConvertSql ( _
    o As Object, _
    mt As MetaConstants..::.MetaType, _
    isFixed As Boolean _
) As Object
Visual C++
public:
static Object^ MetaTypeConvertSql(
    Object^ o,
    MetaConstants..::.MetaType mt,
    bool isFixed
)

Parameters

o
Type: System..::.Object
The object to be converted
mt
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaType
The meta type
isFixed
Type: System..::.Boolean
true if the object is the attribute of fixed type

Return Value

The converted meta type object.

See Also

MetaConvert Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaTypeSqlConvertFrom Method

[image]

OfficeClip API Documentation
MetaConvert..::.MetaTypeSqlConvertFrom Method
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Used for conversion functions for creating the sql statement

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string MetaTypeSqlConvertFrom(
    string str,
    MetaConstants..::.MetaType mt,
    bool isFixed
)
Visual Basic (Declaration)
Public Shared Function MetaTypeSqlConvertFrom ( _
    str As String, _
    mt As MetaConstants..::.MetaType, _
    isFixed As Boolean _
) As String
Visual C++
public:
static String^ MetaTypeSqlConvertFrom(
    String^ str,
    MetaConstants..::.MetaType mt,
    bool isFixed
)

Parameters

str
Type: System..::.String
The input string
mt
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaType
The meta type
isFixed
Type: System..::.Boolean
True if the parameter is of fixed type, false if it is of udf type

Return Value

The converted string

See Also

MetaConvert Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaTypeSqlConvertTo Method

[image]

OfficeClip API Documentation
MetaConvert..::.MetaTypeSqlConvertTo Method
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Used for conversion functions for creating the sql statement

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string MetaTypeSqlConvertTo(
    Object obj,
    MetaConstants..::.MetaType mt,
    bool isFixed
)
Visual Basic (Declaration)
Public Shared Function MetaTypeSqlConvertTo ( _
    obj As Object, _
    mt As MetaConstants..::.MetaType, _
    isFixed As Boolean _
) As String
Visual C++
public:
static String^ MetaTypeSqlConvertTo(
    Object^ obj,
    MetaConstants..::.MetaType mt,
    bool isFixed
)

Parameters

obj
Type: System..::.Object
The meta type object
mt
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaType
The meta type
isFixed
Type: System..::.Boolean
true if it is a fixed type, false if it is udf type

Return Value

The converted string

See Also

MetaConvert Class
OfficeClip.BusinessLayer.Metabase Namespace


RefreshDataSet Method

[image]

OfficeClip API Documentation
MetaConvert..::.RefreshDataSet Method
MetaConvert Class See Also

[This is preliminary documentation and is subject to change.]

Refreshes the dataset

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static DataTable RefreshDataSet(
    DataSet ds
)
Visual Basic (Declaration)
Public Shared Function RefreshDataSet ( _
    ds As DataSet _
) As DataTable
Visual C++
public:
static DataTable^ RefreshDataSet(
    DataSet^ ds
)

Parameters

ds
Type: System.Data..::.DataSet
The meta dataset to be refreshed

Return Value

The table of the refreshed data

See Also

MetaConvert Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaFilterInfo Class

[image]

OfficeClip API Documentation
MetaFilterInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Meta Filter information class

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaFilterInfo
Visual Basic (Declaration)
Public Class MetaFilterInfo
Visual C++
public ref class MetaFilterInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaFilterInfo

See Also

MetaFilterInfo Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaFilterInfo Members

[image] [image]

OfficeClip API Documentation
MetaFilterInfo Members
MetaFilterInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaFilterInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MetaFilterInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EntityId | The unique id of the entity
Public property | Filter | The filter object
Public property | FilterId | The unique id of the filter
Public property | IsOwner | Shows if the current user is the owner
Public property | IsPrivate | Shows if the filter is private
Public property | MetaId | The meta id
Public property | Name | The name of the filter

See Also

MetaFilterInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaFilterInfo Constructor

[image] [image]

OfficeClip API Documentation
MetaFilterInfo Constructor
MetaFilterInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaFilterInfo()()() | The default constructor
Public method | MetaFilterInfo(String, Boolean, Boolean, Int32, Int32, Int32, MF) | The constructor

See Also

MetaFilterInfo Class
MetaFilterInfo Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaFilterInfo Constructor

[image]

OfficeClip API Documentation
MetaFilterInfo Constructor
MetaFilterInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaFilterInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaFilterInfo()

See Also

MetaFilterInfo Class
MetaFilterInfo Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaFilterInfo Constructor (String, Boolean, Boolean, Int32, Int32, Int32, MF)

[image]

OfficeClip API Documentation
MetaFilterInfo Constructor (String, Boolean, Boolean, Int32, Int32, Int32, MF)
MetaFilterInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaFilterInfo(
    string name,
    bool isPrivate,
    bool isOwner,
    int entityId,
    int metaId,
    int filterId,
    MF filter
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    isPrivate As Boolean, _
    isOwner As Boolean, _
    entityId As Integer, _
    metaId As Integer, _
    filterId As Integer, _
    filter As MF _
)
Visual C++
public:
MetaFilterInfo(
    String^ name,
    bool isPrivate,
    bool isOwner,
    int entityId,
    int metaId,
    int filterId,
    MF^ filter
)

Parameters

name
Type: System..::.String
The filter name
isPrivate
Type: System..::.Boolean
true if the filter is private
isOwner
Type: System..::.Boolean
true if the current user is the owner
entityId
Type: System..::.Int32
The entity id
metaId
Type: System..::.Int32
The meta id (usually external id like groupid)
filterId
Type: System..::.Int32
The unique id of the filter
filter
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.MF
the filter object

See Also

MetaFilterInfo Class
MetaFilterInfo Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaFilterInfo Properties

[image] [image]

OfficeClip API Documentation
MetaFilterInfo Properties
MetaFilterInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MetaFilterInfo type exposes the following properties.

Properties

 | Name | Description
Public property | EntityId | The unique id of the entity
Public property | Filter | The filter object
Public property | FilterId | The unique id of the filter
Public property | IsOwner | Shows if the current user is the owner
Public property | IsPrivate | Shows if the filter is private
Public property | MetaId | The meta id
Public property | Name | The name of the filter

See Also

MetaFilterInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


EntityId Property

[image]

OfficeClip API Documentation
MetaFilterInfo..::.EntityId Property
MetaFilterInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the entity

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EntityId { get; set; }
Visual Basic (Declaration)
Public Property EntityId As Integer
Visual C++
public:
property int EntityId {
    int get ();
    void set (int value);
}

See Also

MetaFilterInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Filter Property

[image]

OfficeClip API Documentation
MetaFilterInfo..::.Filter Property
MetaFilterInfo Class See Also

[This is preliminary documentation and is subject to change.]

The filter object

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MF Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As MF
Visual C++
public:
property MF^ Filter {
    MF^ get ();
    void set (MF^ value);
}

See Also

MetaFilterInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


FilterId Property

[image]

OfficeClip API Documentation
MetaFilterInfo..::.FilterId Property
MetaFilterInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the filter

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int FilterId { get; set; }
Visual Basic (Declaration)
Public Property FilterId As Integer
Visual C++
public:
property int FilterId {
    int get ();
    void set (int value);
}

See Also

MetaFilterInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


IsOwner Property

[image]

OfficeClip API Documentation
MetaFilterInfo..::.IsOwner Property
MetaFilterInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the current user is the owner

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsOwner { get; set; }
Visual Basic (Declaration)
Public Property IsOwner As Boolean
Visual C++
public:
property bool IsOwner {
    bool get ();
    void set (bool value);
}

See Also

MetaFilterInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


IsPrivate Property

[image]

OfficeClip API Documentation
MetaFilterInfo..::.IsPrivate Property
MetaFilterInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the filter is private

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsPrivate { get; set; }
Visual Basic (Declaration)
Public Property IsPrivate As Boolean
Visual C++
public:
property bool IsPrivate {
    bool get ();
    void set (bool value);
}

See Also

MetaFilterInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaId Property

[image]

OfficeClip API Documentation
MetaFilterInfo..::.MetaId Property
MetaFilterInfo Class See Also

[This is preliminary documentation and is subject to change.]

The meta id

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MetaId { get; set; }
Visual Basic (Declaration)
Public Property MetaId As Integer
Visual C++
public:
property int MetaId {
    int get ();
    void set (int value);
}

See Also

MetaFilterInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Name Property

[image]

OfficeClip API Documentation
MetaFilterInfo..::.Name Property
MetaFilterInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the filter

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

MetaFilterInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfo Class

[image]

OfficeClip API Documentation
MetaInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

The meta information object provides information on an attribute

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaInfo
Visual Basic (Declaration)
Public Class MetaInfo
Visual C++
public ref class MetaInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaInfo

See Also

MetaInfo Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfo Members

[image] [image]

OfficeClip API Documentation
MetaInfo Members
MetaInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MetaInfo | Overloaded.

Methods

 | Name | Description
Public method | Dump | The dump function for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnName | The column name of the attribute
Public property | Id | The unique id of the attribute
Public property | IsFixed | Shows if the attribute is of fixed type
Public property | IsReadOnly | Shows if the attribute is read-only
Public property | IsRequired | Shows if the attribute is a required attribute
Public property | Name | The name of the attribute
Public property | SectionId | The section id of the attribute
Public property | SectionName | The section name of the attribute
Public property | Type | The type of the attribute
Public property | Value | The value of the attribute

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfo Constructor

[image] [image]

OfficeClip API Documentation
MetaInfo Constructor
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaInfo()()() | The default constructor
Public method | MetaInfo(Int32, String, MetaConstants..::.MetaType, Object, Boolean, Boolean, Boolean, String, String, Int32) | Constructor

See Also

MetaInfo Class
MetaInfo Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfo Constructor

[image]

OfficeClip API Documentation
MetaInfo Constructor
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaInfo()

See Also

MetaInfo Class
MetaInfo Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfo Constructor (Int32, String, MetaConstants.MetaType, Object, Boolean, Boolean, Boolean, String, String, Int32)

[image]

OfficeClip API Documentation
MetaInfo Constructor (Int32, String, MetaConstants..::.MetaType, Object, Boolean, Boolean, Boolean, String, String, Int32)
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaInfo(
    int id,
    string name,
    MetaConstants..::.MetaType type,
    Object val,
    bool isRequired,
    bool isFixed,
    bool isReadOnly,
    string columnName,
    string sectionName,
    int sectionId
)
Visual Basic (Declaration)
Public Sub New ( _
    id As Integer, _
    name As String, _
    type As MetaConstants..::.MetaType, _
    val As Object, _
    isRequired As Boolean, _
    isFixed As Boolean, _
    isReadOnly As Boolean, _
    columnName As String, _
    sectionName As String, _
    sectionId As Integer _
)
Visual C++
public:
MetaInfo(
    int id,
    String^ name,
    MetaConstants..::.MetaType type,
    Object^ val,
    bool isRequired,
    bool isFixed,
    bool isReadOnly,
    String^ columnName,
    String^ sectionName,
    int sectionId
)

Parameters

id
Type: System..::.Int32
The id of the meta attribute
name
Type: System..::.String
The name of the meta attribute
type
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaType
The type of the meta attribute
val
Type: System..::.Object
The value of the meta attribute
isRequired
Type: System..::.Boolean
Shows if the attribute is required
isFixed
Type: System..::.Boolean
Shows if the attribute is fixed
isReadOnly
Type: System..::.Boolean
Shows if the attribute is read-only
columnName
Type: System..::.String
The name of the column
sectionName
Type: System..::.String
The name of the section
sectionId
Type: System..::.Int32
The id of the section

See Also

MetaInfo Class
MetaInfo Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfo Methods

[image] [image]

OfficeClip API Documentation
MetaInfo Methods
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MetaInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | The dump function for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Dump Method

[image]

OfficeClip API Documentation
MetaInfo..::.Dump Method
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The dump function for debugging

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

The deserialized string representation of the object

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfo Properties

[image] [image]

OfficeClip API Documentation
MetaInfo Properties
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MetaInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ColumnName | The column name of the attribute
Public property | Id | The unique id of the attribute
Public property | IsFixed | Shows if the attribute is of fixed type
Public property | IsReadOnly | Shows if the attribute is read-only
Public property | IsRequired | Shows if the attribute is a required attribute
Public property | Name | The name of the attribute
Public property | SectionId | The section id of the attribute
Public property | SectionName | The section name of the attribute
Public property | Type | The type of the attribute
Public property | Value | The value of the attribute

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


ColumnName Property

[image]

OfficeClip API Documentation
MetaInfo..::.ColumnName Property
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The column name of the attribute

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ColumnName { get; set; }
Visual Basic (Declaration)
Public Property ColumnName As String
Visual C++
public:
property String^ ColumnName {
    String^ get ();
    void set (String^ value);
}

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Id Property

[image]

OfficeClip API Documentation
MetaInfo..::.Id Property
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the attribute

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Id { get; set; }
Visual Basic (Declaration)
Public Property Id As Integer
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


IsFixed Property

[image]

OfficeClip API Documentation
MetaInfo..::.IsFixed Property
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the attribute is of fixed type

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsFixed { get; set; }
Visual Basic (Declaration)
Public Property IsFixed As Boolean
Visual C++
public:
property bool IsFixed {
    bool get ();
    void set (bool value);
}

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


IsReadOnly Property

[image]

OfficeClip API Documentation
MetaInfo..::.IsReadOnly Property
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the attribute is read-only

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic (Declaration)
Public Property IsReadOnly As Boolean
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


IsRequired Property

[image]

OfficeClip API Documentation
MetaInfo..::.IsRequired Property
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the attribute is a required attribute

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsRequired { get; set; }
Visual Basic (Declaration)
Public Property IsRequired As Boolean
Visual C++
public:
property bool IsRequired {
    bool get ();
    void set (bool value);
}

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Name Property

[image]

OfficeClip API Documentation
MetaInfo..::.Name Property
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the attribute

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


SectionId Property

[image]

OfficeClip API Documentation
MetaInfo..::.SectionId Property
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The section id of the attribute

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SectionId { get; set; }
Visual Basic (Declaration)
Public Property SectionId As Integer
Visual C++
public:
property int SectionId {
    int get ();
    void set (int value);
}

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


SectionName Property

[image]

OfficeClip API Documentation
MetaInfo..::.SectionName Property
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The section name of the attribute

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SectionName { get; set; }
Visual Basic (Declaration)
Public Property SectionName As String
Visual C++
public:
property String^ SectionName {
    String^ get ();
    void set (String^ value);
}

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Type Property

[image]

OfficeClip API Documentation
MetaInfo..::.Type Property
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The type of the attribute

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaConstants..::.MetaType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As MetaConstants..::.MetaType
Visual C++
public:
property MetaConstants..::.MetaType Type {
    MetaConstants..::.MetaType get ();
    void set (MetaConstants..::.MetaType value);
}

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Value Property

[image]

OfficeClip API Documentation
MetaInfo..::.Value Property
MetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The value of the attribute

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

MetaInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfoCollection Class

[image]

OfficeClip API Documentation
MetaInfoCollection Class
Members See Also

[This is preliminary documentation and is subject to change.]

A collection of meta information objects, i.e. a collection of meta attributes

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaInfoCollection : IEnumerable
Visual Basic (Declaration)
Public Class MetaInfoCollection _
    Implements IEnumerable
Visual C++
public ref class MetaInfoCollection : IEnumerable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaInfoCollection

See Also

MetaInfoCollection Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfoCollection Members

[image] [image]

OfficeClip API Documentation
MetaInfoCollection Members
MetaInfoCollection Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaInfoCollection type exposes the following members.

Constructors

 | Name | Description
Public method | MetaInfoCollection | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the object information on the string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets the enumerator of the meta info collection
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TranslateMetaListValues | Some of the values of the metainfo comes out to be the lists, this function converts them to the real values when applicable. Also it converts the null values to empty string

Properties

 | Name | Description
Public property | Item | The array operator
Public property | Length | The length of the meta information
Public property | MetaInfos | The array of meta information

See Also

MetaInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfoCollection Constructor

[image] [image]

OfficeClip API Documentation
MetaInfoCollection Constructor
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaInfoCollection()()() | The default constructor
Public method | MetaInfoCollection(Int32) | Constructor
Public method | MetaInfoCollection(array<MetaInfo>[]()[]) | Constructor

See Also

MetaInfoCollection Class
MetaInfoCollection Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfoCollection Constructor

[image]

OfficeClip API Documentation
MetaInfoCollection Constructor
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaInfoCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaInfoCollection()

See Also

MetaInfoCollection Class
MetaInfoCollection Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfoCollection Constructor (Int32)

[image]

OfficeClip API Documentation
MetaInfoCollection Constructor (Int32)
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaInfoCollection(
    int size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Integer _
)
Visual C++
public:
MetaInfoCollection(
    int size
)

Parameters

size
Type: System..::.Int32
The size of the collection

See Also

MetaInfoCollection Class
MetaInfoCollection Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfoCollection Constructor (MetaInfo[])

[image]

OfficeClip API Documentation
MetaInfoCollection Constructor (array<MetaInfo>[]()[])
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaInfoCollection(
    MetaInfo[] metaInfos
)
Visual Basic (Declaration)
Public Sub New ( _
    metaInfos As MetaInfo() _
)
Visual C++
public:
MetaInfoCollection(
    array<MetaInfo^>^ metaInfos
)

Parameters

metaInfos
Type: array< OfficeClip.BusinessLayer.Metabase..::.MetaInfo >[]()[]
The meta info collection

See Also

MetaInfoCollection Class
MetaInfoCollection Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfoCollection Methods

[image] [image]

OfficeClip API Documentation
MetaInfoCollection Methods
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

The MetaInfoCollection type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the object information on the string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets the enumerator of the meta info collection
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TranslateMetaListValues | Some of the values of the metainfo comes out to be the lists, this function converts them to the real values when applicable. Also it converts the null values to empty string

See Also

MetaInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


Dump Method

[image]

OfficeClip API Documentation
MetaInfoCollection..::.Dump Method
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the object information on the string

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

The dumped string

See Also

MetaInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
MetaInfoCollection..::.GetEnumerator Method
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

Gets the enumerator of the meta info collection

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

The enumerator of the meta info collection

Implements

IEnumerable..::.GetEnumerator()()()

See Also

MetaInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


TranslateMetaListValues Method

[image]

OfficeClip API Documentation
MetaInfoCollection..::.TranslateMetaListValues Method
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

Some of the values of the metainfo comes out to be the lists, this function converts them to the real values when applicable. Also it converts the null values to empty string

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void TranslateMetaListValues()
Visual Basic (Declaration)
Public Sub TranslateMetaListValues
Visual C++
public:
void TranslateMetaListValues()

See Also

MetaInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfoCollection Properties

[image] [image]

OfficeClip API Documentation
MetaInfoCollection Properties
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

The MetaInfoCollection type exposes the following properties.

Properties

 | Name | Description
Public property | Item | The array operator
Public property | Length | The length of the meta information
Public property | MetaInfos | The array of meta information

See Also

MetaInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


Item Property

[image]

OfficeClip API Documentation
MetaInfoCollection..::.Item Property
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

The array operator

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public virtual MetaInfo this[
    int i
] { get; set; }
Visual Basic (Declaration)
Public Overridable Default Property Item ( _
    i As Integer _
) As MetaInfo
Visual C++
public:
virtual property MetaInfo^ default[int i] {
    MetaInfo^ get (int i);
    void set (int i, MetaInfo^ value);
}

Parameters

i
Type: System..::.Int32

See Also

MetaInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


Length Property

[image]

OfficeClip API Documentation
MetaInfoCollection..::.Length Property
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

The length of the meta information

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Integer
Visual C++
public:
property int Length {
    int get ();
}

See Also

MetaInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaInfos Property

[image]

OfficeClip API Documentation
MetaInfoCollection..::.MetaInfos Property
MetaInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

The array of meta information

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaInfo[] MetaInfos { get; set; }
Visual Basic (Declaration)
Public Property MetaInfos As MetaInfo()
Visual C++
public:
property array<MetaInfo^>^ MetaInfos {
    array<MetaInfo^>^ get ();
    void set (array<MetaInfo^>^ value);
}

See Also

MetaInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfo Class

[image]

OfficeClip API Documentation
MetaListInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

The meta list item information store

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaListInfo
Visual Basic (Declaration)
Public Class MetaListInfo
Visual C++
public ref class MetaListInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaListInfo

See Also

MetaListInfo Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfo Members

[image] [image]

OfficeClip API Documentation
MetaListInfo Members
MetaListInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaListInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MetaListInfo | Overloaded.

Methods

 | Name | Description
Public method | Dump | String dump of the object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The unique id of the list item
Public property | IsDefault | Shows if the list item is default
Public property | IsSelected | Shows if the list item is selected
Public property | Value | The value of the list item

See Also

MetaListInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfo Constructor

[image] [image]

OfficeClip API Documentation
MetaListInfo Constructor
MetaListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaListInfo()()() | The default constructor
Public method | MetaListInfo(Int32, String, Boolean, Boolean) | The constructor

See Also

MetaListInfo Class
MetaListInfo Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfo Constructor

[image]

OfficeClip API Documentation
MetaListInfo Constructor
MetaListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaListInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaListInfo()

See Also

MetaListInfo Class
MetaListInfo Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfo Constructor (Int32, String, Boolean, Boolean)

[image]

OfficeClip API Documentation
MetaListInfo Constructor (Int32, String, Boolean, Boolean)
MetaListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaListInfo(
    int id,
    string val,
    bool isSelected,
    bool isDefault
)
Visual Basic (Declaration)
Public Sub New ( _
    id As Integer, _
    val As String, _
    isSelected As Boolean, _
    isDefault As Boolean _
)
Visual C++
public:
MetaListInfo(
    int id,
    String^ val,
    bool isSelected,
    bool isDefault
)

Parameters

id
Type: System..::.Int32
The id of the list item
val
Type: System..::.String
The value of the list item
isSelected
Type: System..::.Boolean
True if the list is selected
isDefault
Type: System..::.Boolean
True if the list is default

See Also

MetaListInfo Class
MetaListInfo Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfo Methods

[image] [image]

OfficeClip API Documentation
MetaListInfo Methods
MetaListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MetaListInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | String dump of the object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaListInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Dump Method

[image]

OfficeClip API Documentation
MetaListInfo..::.Dump Method
MetaListInfo Class See Also

[This is preliminary documentation and is subject to change.]

String dump of the object

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

The string dump of the object

See Also

MetaListInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfo Properties

[image] [image]

OfficeClip API Documentation
MetaListInfo Properties
MetaListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MetaListInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Id | The unique id of the list item
Public property | IsDefault | Shows if the list item is default
Public property | IsSelected | Shows if the list item is selected
Public property | Value | The value of the list item

See Also

MetaListInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Id Property

[image]

OfficeClip API Documentation
MetaListInfo..::.Id Property
MetaListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the list item

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Id { get; set; }
Visual Basic (Declaration)
Public Property Id As Integer
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

See Also

MetaListInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


IsDefault Property

[image]

OfficeClip API Documentation
MetaListInfo..::.IsDefault Property
MetaListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the list item is default

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsDefault { get; set; }
Visual Basic (Declaration)
Public Property IsDefault As Boolean
Visual C++
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}

See Also

MetaListInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


IsSelected Property

[image]

OfficeClip API Documentation
MetaListInfo..::.IsSelected Property
MetaListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the list item is selected

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

MetaListInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Value Property

[image]

OfficeClip API Documentation
MetaListInfo..::.Value Property
MetaListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The value of the list item

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

MetaListInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfoCollection Class

[image]

OfficeClip API Documentation
MetaListInfoCollection Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the list item collection

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaListInfoCollection
Visual Basic (Declaration)
Public Class MetaListInfoCollection
Visual C++
public ref class MetaListInfoCollection

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaListInfoCollection

See Also

MetaListInfoCollection Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfoCollection Members

[image] [image]

OfficeClip API Documentation
MetaListInfoCollection Members
MetaListInfoCollection Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaListInfoCollection type exposes the following members.

Constructors

 | Name | Description
Public method | MetaListInfoCollection | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the object to a string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSelectedItem | Gets the selected meta list item
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | The array operator
Public property | MetaListInfos | The array of meta list items

See Also

MetaListInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfoCollection Constructor

[image] [image]

OfficeClip API Documentation
MetaListInfoCollection Constructor
MetaListInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaListInfoCollection()()() | Teh default constructor
Public method | MetaListInfoCollection(Int32) | The constructor

See Also

MetaListInfoCollection Class
MetaListInfoCollection Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfoCollection Constructor

[image]

OfficeClip API Documentation
MetaListInfoCollection Constructor
MetaListInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

Teh default constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaListInfoCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaListInfoCollection()

See Also

MetaListInfoCollection Class
MetaListInfoCollection Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfoCollection Constructor (Int32)

[image]

OfficeClip API Documentation
MetaListInfoCollection Constructor (Int32)
MetaListInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

The constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaListInfoCollection(
    int size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Integer _
)
Visual C++
public:
MetaListInfoCollection(
    int size
)

Parameters

size
Type: System..::.Int32
The default size of the collection

See Also

MetaListInfoCollection Class
MetaListInfoCollection Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfoCollection Methods

[image] [image]

OfficeClip API Documentation
MetaListInfoCollection Methods
MetaListInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

The MetaListInfoCollection type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the object to a string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSelectedItem | Gets the selected meta list item
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaListInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


Dump Method

[image]

OfficeClip API Documentation
MetaListInfoCollection..::.Dump Method
MetaListInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the object to a string

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

The string dump of the object

See Also

MetaListInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


GetSelectedItem Method

[image]

OfficeClip API Documentation
MetaListInfoCollection..::.GetSelectedItem Method
MetaListInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

Gets the selected meta list item

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaListInfo GetSelectedItem()
Visual Basic (Declaration)
Public Function GetSelectedItem As MetaListInfo
Visual C++
public:
MetaListInfo^ GetSelectedItem()

Return Value

The selected meta list item

See Also

MetaListInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfoCollection Properties

[image] [image]

OfficeClip API Documentation
MetaListInfoCollection Properties
MetaListInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

The MetaListInfoCollection type exposes the following properties.

Properties

 | Name | Description
Public property | Item | The array operator
Public property | MetaListInfos | The array of meta list items

See Also

MetaListInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


Item Property

[image]

OfficeClip API Documentation
MetaListInfoCollection..::.Item Property
MetaListInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

The array operator

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaListInfo this[
    int i
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    i As Integer _
) As MetaListInfo
Visual C++
public:
property MetaListInfo^ default[int i] {
    MetaListInfo^ get (int i);
    void set (int i, MetaListInfo^ value);
}

Parameters

i
Type: System..::.Int32

See Also

MetaListInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaListInfos Property

[image]

OfficeClip API Documentation
MetaListInfoCollection..::.MetaListInfos Property
MetaListInfoCollection Class See Also

[This is preliminary documentation and is subject to change.]

The array of meta list items

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaListInfo[] MetaListInfos { get; set; }
Visual Basic (Declaration)
Public Property MetaListInfos As MetaListInfo()
Visual C++
public:
property array<MetaListInfo^>^ MetaListInfos {
    array<MetaListInfo^>^ get ();
    void set (array<MetaListInfo^>^ value);
}

See Also

MetaListInfoCollection Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaQueryString Class

[image]

OfficeClip API Documentation
MetaQueryString Class
Members See Also

[This is preliminary documentation and is subject to change.]

The class for creating a query string for the metadata

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class MetaQueryString
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MetaQueryString
Visual C++
[SerializableAttribute]
public ref class MetaQueryString

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaQueryString

See Also

MetaQueryString Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaQueryString Members

[image] [image]

OfficeClip API Documentation
MetaQueryString Members
MetaQueryString Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaQueryString type exposes the following members.

Constructors

 | Name | Description
Public method | MetaQueryString | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Overloaded.

Properties

 | Name | Description
Public property | ExternalId | The group id in question
Public property | FilterId | The unique id of the filter
Public property | IsDescending | True if in descending order, false otherwise
Public property | Me | The metaentity in question
Public property | OrderId | The unique id of the order by field
Public property | PageNum | The page number
Public property | PrimaryKey | The unique id of the data in question
Public property | SearchId | The unique search id
Public property | SearchStr | The search string
Public property | Show | The show string

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaQueryString Constructor

[image] [image]

OfficeClip API Documentation
MetaQueryString Constructor
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaQueryString(MetaConstants..::.MetaEntity, Int32, Int32, Int32, Int32, Boolean, String, Int32, Int32, String) | The constructor for crating the metaquerystring object
Public method | MetaQueryString(Page, Int32) | The constructor for the metaquery string for an asp.net page
Public method | MetaQueryString(MetaConstants..::.MetaEntity, Int32) | Constructor
Public method | MetaQueryString(MetaConstants..::.MetaEntity, Int32, Int32) | Constructor

See Also

MetaQueryString Class
MetaQueryString Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaQueryString Constructor (MetaConstants.MetaEntity, Int32, Int32, Int32, Int32, Boolean, String, Int32, Int32, String)

[image]

OfficeClip API Documentation
MetaQueryString Constructor (MetaConstants..::.MetaEntity, Int32, Int32, Int32, Int32, Boolean, String, Int32, Int32, String)
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The constructor for crating the metaquerystring object

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaQueryString(
    MetaConstants..::.MetaEntity me,
    int externalId,
    int primaryKey,
    int filterId,
    int orderId,
    bool isDescending,
    string searchStr,
    int pageNum,
    int searchId,
    string show
)
Visual Basic (Declaration)
Public Sub New ( _
    me As MetaConstants..::.MetaEntity, _
    externalId As Integer, _
    primaryKey As Integer, _
    filterId As Integer, _
    orderId As Integer, _
    isDescending As Boolean, _
    searchStr As String, _
    pageNum As Integer, _
    searchId As Integer, _
    show As String _
)
Visual C++
public:
MetaQueryString(
    MetaConstants..::.MetaEntity me,
    int externalId,
    int primaryKey,
    int filterId,
    int orderId,
    bool isDescending,
    String^ searchStr,
    int pageNum,
    int searchId,
    String^ show
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalId
Type: System..::.Int32
The id of the group in question
primaryKey
Type: System..::.Int32
The unique id of the data in question
filterId
Type: System..::.Int32
The unique id of the filter
orderId
Type: System..::.Int32
The unique id of the order
isDescending
Type: System..::.Boolean
true if in descending order false otherwise
searchStr
Type: System..::.String
The string to be searched
pageNum
Type: System..::.Int32
The page number
searchId
Type: System..::.Int32
The unique id of the search
show
Type: System..::.String
true if it is to be shown to everybody

See Also

MetaQueryString Class
MetaQueryString Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaQueryString Constructor (Page, Int32)

[image]

OfficeClip API Documentation
MetaQueryString Constructor (Page, Int32)
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The constructor for the metaquery string for an asp.net page

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaQueryString(
    Page page,
    int currentGroupId
)
Visual Basic (Declaration)
Public Sub New ( _
    page As Page, _
    currentGroupId As Integer _
)
Visual C++
public:
MetaQueryString(
    Page^ page,
    int currentGroupId
)

Parameters

page
Type: System.Web.UI..::.Page
The asp.net pagge in question
currentGroupId
Type: System..::.Int32
The current group id

See Also

MetaQueryString Class
MetaQueryString Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaQueryString Constructor (MetaConstants.MetaEntity, Int32)

[image]

OfficeClip API Documentation
MetaQueryString Constructor (MetaConstants..::.MetaEntity, Int32)
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaQueryString(
    MetaConstants..::.MetaEntity me,
    int externalId
)
Visual Basic (Declaration)
Public Sub New ( _
    me As MetaConstants..::.MetaEntity, _
    externalId As Integer _
)
Visual C++
public:
MetaQueryString(
    MetaConstants..::.MetaEntity me,
    int externalId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The metaentity
externalId
Type: System..::.Int32
The external id, in this case group id

See Also

MetaQueryString Class
MetaQueryString Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaQueryString Constructor (MetaConstants.MetaEntity, Int32, Int32)

[image]

OfficeClip API Documentation
MetaQueryString Constructor (MetaConstants..::.MetaEntity, Int32, Int32)
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaQueryString(
    MetaConstants..::.MetaEntity me,
    int externalId,
    int primaryKey
)
Visual Basic (Declaration)
Public Sub New ( _
    me As MetaConstants..::.MetaEntity, _
    externalId As Integer, _
    primaryKey As Integer _
)
Visual C++
public:
MetaQueryString(
    MetaConstants..::.MetaEntity me,
    int externalId,
    int primaryKey
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalId
Type: System..::.Int32
The external id, in this case group id
primaryKey
Type: System..::.Int32
The primary key

See Also

MetaQueryString Class
MetaQueryString Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaQueryString Methods

[image] [image]

OfficeClip API Documentation
MetaQueryString Methods
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The MetaQueryString type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Overloaded.

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


ToString Method

[image] [image]

OfficeClip API Documentation
MetaQueryString..::.ToString Method
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToString(String) | Converts the query string to a string to pass on via web

See Also

MetaQueryString Class
MetaQueryString Members
OfficeClip.BusinessLayer.Metabase Namespace


ToString Method (String)

[image]

OfficeClip API Documentation
MetaQueryString..::.ToString Method (String)
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

Converts the query string to a string to pass on via web

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToString(
    string url
)
Visual Basic (Declaration)
Public Function ToString ( _
    url As String _
) As String
Visual C++
public:
String^ ToString(
    String^ url
)

Parameters

url
Type: System..::.String
The url in question

Return Value

The querystring

See Also

MetaQueryString Class
ToString Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaQueryString Properties

[image] [image]

OfficeClip API Documentation
MetaQueryString Properties
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The MetaQueryString type exposes the following properties.

Properties

 | Name | Description
Public property | ExternalId | The group id in question
Public property | FilterId | The unique id of the filter
Public property | IsDescending | True if in descending order, false otherwise
Public property | Me | The metaentity in question
Public property | OrderId | The unique id of the order by field
Public property | PageNum | The page number
Public property | PrimaryKey | The unique id of the data in question
Public property | SearchId | The unique search id
Public property | SearchStr | The search string
Public property | Show | The show string

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


ExternalId Property

[image]

OfficeClip API Documentation
MetaQueryString..::.ExternalId Property
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The group id in question

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExternalId { get; set; }
Visual Basic (Declaration)
Public Property ExternalId As Integer
Visual C++
public:
property int ExternalId {
    int get ();
    void set (int value);
}

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


FilterId Property

[image]

OfficeClip API Documentation
MetaQueryString..::.FilterId Property
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the filter

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int FilterId { get; set; }
Visual Basic (Declaration)
Public Property FilterId As Integer
Visual C++
public:
property int FilterId {
    int get ();
    void set (int value);
}

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


IsDescending Property

[image]

OfficeClip API Documentation
MetaQueryString..::.IsDescending Property
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

True if in descending order, false otherwise

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsDescending { get; set; }
Visual Basic (Declaration)
Public Property IsDescending As Boolean
Visual C++
public:
property bool IsDescending {
    bool get ();
    void set (bool value);
}

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


Me Property

[image]

OfficeClip API Documentation
MetaQueryString..::.Me Property
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The metaentity in question

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaConstants..::.MetaEntity Me { get; set; }
Visual Basic (Declaration)
Public Property Me As MetaConstants..::.MetaEntity
Visual C++
public:
property MetaConstants..::.MetaEntity Me {
    MetaConstants..::.MetaEntity get ();
    void set (MetaConstants..::.MetaEntity value);
}

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


OrderId Property

[image]

OfficeClip API Documentation
MetaQueryString..::.OrderId Property
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the order by field

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int OrderId { get; set; }
Visual Basic (Declaration)
Public Property OrderId As Integer
Visual C++
public:
property int OrderId {
    int get ();
    void set (int value);
}

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


PageNum Property

[image]

OfficeClip API Documentation
MetaQueryString..::.PageNum Property
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The page number

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int PageNum { get; set; }
Visual Basic (Declaration)
Public Property PageNum As Integer
Visual C++
public:
property int PageNum {
    int get ();
    void set (int value);
}

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


PrimaryKey Property

[image]

OfficeClip API Documentation
MetaQueryString..::.PrimaryKey Property
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the data in question

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int PrimaryKey { get; set; }
Visual Basic (Declaration)
Public Property PrimaryKey As Integer
Visual C++
public:
property int PrimaryKey {
    int get ();
    void set (int value);
}

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


SearchId Property

[image]

OfficeClip API Documentation
MetaQueryString..::.SearchId Property
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The unique search id

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SearchId { get; set; }
Visual Basic (Declaration)
Public Property SearchId As Integer
Visual C++
public:
property int SearchId {
    int get ();
    void set (int value);
}

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


SearchStr Property

[image]

OfficeClip API Documentation
MetaQueryString..::.SearchStr Property
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The search string

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SearchStr { get; set; }
Visual Basic (Declaration)
Public Property SearchStr As String
Visual C++
public:
property String^ SearchStr {
    String^ get ();
    void set (String^ value);
}

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


Show Property

[image]

OfficeClip API Documentation
MetaQueryString..::.Show Property
MetaQueryString Class See Also

[This is preliminary documentation and is subject to change.]

The show string

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Show { get; set; }
Visual Basic (Declaration)
Public Property Show As String
Visual C++
public:
property String^ Show {
    String^ get ();
    void set (String^ value);
}

See Also

MetaQueryString Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaReportInfo Class

[image]

OfficeClip API Documentation
MetaReportInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

The meta report information object

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaReportInfo
Visual Basic (Declaration)
Public Class MetaReportInfo
Visual C++
public ref class MetaReportInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaReportInfo

See Also

MetaReportInfo Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaReportInfo Members

[image] [image]

OfficeClip API Documentation
MetaReportInfo Members
MetaReportInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaReportInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MetaReportInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributes | Gets all the attributes
Public method | GetFilterInfo | Gets the filter object
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsExtFilter | Is the filter an external filter
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedByUserId | The unique id of the created by user
Public property | Criteria | The criteria object
Public property | Description | The description of the report
Public property | EntityId | The unique id of the entity
Public property | ExtFilter | The external filter object
Public property | Filter | The filter object
Public property | IsOwner | True if the current user is the owner
Public property | IsPrivate | True if the report is private
Public property | MetaId | The meta or external id (usually the group id)
Public property | Name | The name of the report
Public property | ReportId | The unique id of the report

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaReportInfo Constructor

[image] [image]

OfficeClip API Documentation
MetaReportInfo Constructor
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaReportInfo()()() | The default constructor
Public method | MetaReportInfo(String, String, Boolean, Boolean, Int32, Int32, Int32, ExtMF, Criteria, Int32) | The constructor
Public method | MetaReportInfo(String, String, Boolean, Boolean, Int32, Int32, Int32, MF, Criteria, Int32) | The constructor

See Also

MetaReportInfo Class
MetaReportInfo Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaReportInfo Constructor

[image]

OfficeClip API Documentation
MetaReportInfo Constructor
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaReportInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaReportInfo()

See Also

MetaReportInfo Class
MetaReportInfo Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaReportInfo Constructor (String, String, Boolean, Boolean, Int32, Int32, Int32, ExtMF, Criteria, Int32)

[image]

OfficeClip API Documentation
MetaReportInfo Constructor (String, String, Boolean, Boolean, Int32, Int32, Int32, ExtMF, Criteria, Int32)
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaReportInfo(
    string name,
    string description,
    bool isPrivate,
    bool isOwner,
    int entityId,
    int metaId,
    int reportId,
    ExtMF extFilter,
    Criteria criteria,
    int createdByUserId
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    description As String, _
    isPrivate As Boolean, _
    isOwner As Boolean, _
    entityId As Integer, _
    metaId As Integer, _
    reportId As Integer, _
    extFilter As ExtMF, _
    criteria As Criteria, _
    createdByUserId As Integer _
)
Visual C++
public:
MetaReportInfo(
    String^ name,
    String^ description,
    bool isPrivate,
    bool isOwner,
    int entityId,
    int metaId,
    int reportId,
    ExtMF^ extFilter,
    Criteria^ criteria,
    int createdByUserId
)

Parameters

name
Type: System..::.String
The name of the object
description
Type: System..::.String
The description
isPrivate
Type: System..::.Boolean
True if the information is private
isOwner
Type: System..::.Boolean
True if the current user is the owner
entityId
Type: System..::.Int32
The entity id
metaId
Type: System..::.Int32
The meta id (usually the group id)
reportId
Type: System..::.Int32
The unique id of the report
extFilter
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.ExtMF
The external filter object
criteria
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.Criteria
The criteria object
createdByUserId
Type: System..::.Int32
the created by user

See Also

MetaReportInfo Class
MetaReportInfo Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaReportInfo Constructor (String, String, Boolean, Boolean, Int32, Int32, Int32, MF, Criteria, Int32)

[image]

OfficeClip API Documentation
MetaReportInfo Constructor (String, String, Boolean, Boolean, Int32, Int32, Int32, MF, Criteria, Int32)
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaReportInfo(
    string name,
    string description,
    bool isPrivate,
    bool isOwner,
    int entityId,
    int metaId,
    int reportId,
    MF filter,
    Criteria criteria,
    int createdByUserId
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    description As String, _
    isPrivate As Boolean, _
    isOwner As Boolean, _
    entityId As Integer, _
    metaId As Integer, _
    reportId As Integer, _
    filter As MF, _
    criteria As Criteria, _
    createdByUserId As Integer _
)
Visual C++
public:
MetaReportInfo(
    String^ name,
    String^ description,
    bool isPrivate,
    bool isOwner,
    int entityId,
    int metaId,
    int reportId,
    MF^ filter,
    Criteria^ criteria,
    int createdByUserId
)

Parameters

name
Type: System..::.String
The name of the object
description
Type: System..::.String
The description
isPrivate
Type: System..::.Boolean
True if the information is private
isOwner
Type: System..::.Boolean
True if the current user is the owner
entityId
Type: System..::.Int32
The entity id
metaId
Type: System..::.Int32
The meta id (usually the group id)
reportId
Type: System..::.Int32
The unique id of the report
filter
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.MF
The filter object
criteria
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.Criteria
The criteria object
createdByUserId
Type: System..::.Int32
the created by user

See Also

MetaReportInfo Class
MetaReportInfo Overload
OfficeClip.BusinessLayer.Metabase Namespace


MetaReportInfo Methods

[image] [image]

OfficeClip API Documentation
MetaReportInfo Methods
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MetaReportInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributes | Gets all the attributes
Public method | GetFilterInfo | Gets the filter object
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsExtFilter | Is the filter an external filter
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


GetAttributes Method

[image]

OfficeClip API Documentation
MetaReportInfo..::.GetAttributes Method
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the attributes

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string[] GetAttributes()
Visual Basic (Declaration)
Public Function GetAttributes As String()
Visual C++
public:
array<String^>^ GetAttributes()

Return Value

The string array of attributes

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


GetFilterInfo Method

[image]

OfficeClip API Documentation
MetaReportInfo..::.GetFilterInfo Method
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the filter object

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaFilterInfo GetFilterInfo()
Visual Basic (Declaration)
Public Function GetFilterInfo As MetaFilterInfo
Visual C++
public:
MetaFilterInfo^ GetFilterInfo()

Return Value

The meta filter information

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


IsExtFilter Method

[image]

OfficeClip API Documentation
MetaReportInfo..::.IsExtFilter Method
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

Is the filter an external filter

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsExtFilter()
Visual Basic (Declaration)
Public Function IsExtFilter As Boolean
Visual C++
public:
bool IsExtFilter()

Return Value

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaReportInfo Properties

[image] [image]

OfficeClip API Documentation
MetaReportInfo Properties
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MetaReportInfo type exposes the following properties.

Properties

 | Name | Description
Public property | CreatedByUserId | The unique id of the created by user
Public property | Criteria | The criteria object
Public property | Description | The description of the report
Public property | EntityId | The unique id of the entity
Public property | ExtFilter | The external filter object
Public property | Filter | The filter object
Public property | IsOwner | True if the current user is the owner
Public property | IsPrivate | True if the report is private
Public property | MetaId | The meta or external id (usually the group id)
Public property | Name | The name of the report
Public property | ReportId | The unique id of the report

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


CreatedByUserId Property

[image]

OfficeClip API Documentation
MetaReportInfo..::.CreatedByUserId Property
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the created by user

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedByUserId { get; set; }
Visual Basic (Declaration)
Public Property CreatedByUserId As Integer
Visual C++
public:
property int CreatedByUserId {
    int get ();
    void set (int value);
}

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Criteria Property

[image]

OfficeClip API Documentation
MetaReportInfo..::.Criteria Property
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The criteria object

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Criteria Criteria { get; set; }
Visual Basic (Declaration)
Public Property Criteria As Criteria
Visual C++
public:
property Criteria^ Criteria {
    Criteria^ get ();
    void set (Criteria^ value);
}

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Description Property

[image]

OfficeClip API Documentation
MetaReportInfo..::.Description Property
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The description of the report

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


EntityId Property

[image]

OfficeClip API Documentation
MetaReportInfo..::.EntityId Property
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the entity

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EntityId { get; set; }
Visual Basic (Declaration)
Public Property EntityId As Integer
Visual C++
public:
property int EntityId {
    int get ();
    void set (int value);
}

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


ExtFilter Property

[image]

OfficeClip API Documentation
MetaReportInfo..::.ExtFilter Property
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The external filter object

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExtMF ExtFilter { get; set; }
Visual Basic (Declaration)
Public Property ExtFilter As ExtMF
Visual C++
public:
property ExtMF^ ExtFilter {
    ExtMF^ get ();
    void set (ExtMF^ value);
}

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Filter Property

[image]

OfficeClip API Documentation
MetaReportInfo..::.Filter Property
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The filter object

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MF Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As MF
Visual C++
public:
property MF^ Filter {
    MF^ get ();
    void set (MF^ value);
}

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


IsOwner Property

[image]

OfficeClip API Documentation
MetaReportInfo..::.IsOwner Property
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

True if the current user is the owner

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsOwner { get; set; }
Visual Basic (Declaration)
Public Property IsOwner As Boolean
Visual C++
public:
property bool IsOwner {
    bool get ();
    void set (bool value);
}

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


IsPrivate Property

[image]

OfficeClip API Documentation
MetaReportInfo..::.IsPrivate Property
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

True if the report is private

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsPrivate { get; set; }
Visual Basic (Declaration)
Public Property IsPrivate As Boolean
Visual C++
public:
property bool IsPrivate {
    bool get ();
    void set (bool value);
}

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaId Property

[image]

OfficeClip API Documentation
MetaReportInfo..::.MetaId Property
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The meta or external id (usually the group id)

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MetaId { get; set; }
Visual Basic (Declaration)
Public Property MetaId As Integer
Visual C++
public:
property int MetaId {
    int get ();
    void set (int value);
}

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


Name Property

[image]

OfficeClip API Documentation
MetaReportInfo..::.Name Property
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the report

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


ReportId Property

[image]

OfficeClip API Documentation
MetaReportInfo..::.ReportId Property
MetaReportInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the report

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ReportId { get; set; }
Visual Basic (Declaration)
Public Property ReportId As Integer
Visual C++
public:
property int ReportId {
    int get ();
    void set (int value);
}

See Also

MetaReportInfo Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaSearch Class

[image]

OfficeClip API Documentation
MetaSearch Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to search for the information defined by a particular pattern

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaSearch
Visual Basic (Declaration)
Public Class MetaSearch
Visual C++
public ref class MetaSearch

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaSearch

See Also

MetaSearch Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaSearch Members

[image] [image]

OfficeClip API Documentation
MetaSearch Members
MetaSearch Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The MetaSearch type exposes the following members.

Constructors

 | Name | Description
Public method | MetaSearch |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSearchWhereClause | Gets the where clause of the search
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaSearch Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaSearch Constructor

[image]

OfficeClip API Documentation
MetaSearch Constructor
MetaSearch Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaSearch()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaSearch()

See Also

MetaSearch Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaSearch Methods

[image] [image]

OfficeClip API Documentation
MetaSearch Methods
MetaSearch Class See Also

[This is preliminary documentation and is subject to change.]

The MetaSearch type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSearchWhereClause | Gets the where clause of the search
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaSearch Class
OfficeClip.BusinessLayer.Metabase Namespace


GetSearchWhereClause Method

[image]

OfficeClip API Documentation
MetaSearch..::.GetSearchWhereClause Method
MetaSearch Class See Also

[This is preliminary documentation and is subject to change.]

Gets the where clause of the search

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetSearchWhereClause(
    ref DataSet dsLists,
    string searchStr,
    int searchId,
    int filterId
)
Visual Basic (Declaration)
Public Shared Function GetSearchWhereClause ( _
    ByRef dsLists As DataSet, _
    searchStr As String, _
    searchId As Integer, _
    filterId As Integer _
) As String
Visual C++
public:
static String^ GetSearchWhereClause(
    DataSet^% dsLists,
    String^ searchStr,
    int searchId,
    int filterId
)

Parameters

dsLists
Type: System.Data..::.DataSet%
The dataset for the meta lists
searchStr
Type: System..::.String
The search string
searchId
Type: System..::.Int32
The unique id of the search
filterId
Type: System..::.Int32

Return Value

The created where clause for the search

See Also

MetaSearch Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaSelectSet Class

[image]

OfficeClip API Documentation
MetaSelectSet Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class for manipulating the list of meta objects returned from the database

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaSelectSet
Visual Basic (Declaration)
Public Class MetaSelectSet
Visual C++
public ref class MetaSelectSet

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaSelectSet

See Also

MetaSelectSet Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaSelectSet Members

[image] [image]

OfficeClip API Documentation
MetaSelectSet Members
MetaSelectSet Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The MetaSelectSet type exposes the following members.

Constructors

 | Name | Description
Public method | MetaSelectSet |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMetaInfoCollection | Returns the metainfo collection when the data is requested via the primary key.
 | GetMetaValue | returns the value of the id supplied
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RearrangeSelectSet | Rearranges the dataset to make it suitable for display and reporting
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaSelectSet Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaSelectSet Constructor

[image]

OfficeClip API Documentation
MetaSelectSet Constructor
MetaSelectSet Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaSelectSet()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaSelectSet()

See Also

MetaSelectSet Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaSelectSet Methods

[image] [image]

OfficeClip API Documentation
MetaSelectSet Methods
MetaSelectSet Class See Also

[This is preliminary documentation and is subject to change.]

The MetaSelectSet type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMetaInfoCollection | Returns the metainfo collection when the data is requested via the primary key.
 | GetMetaValue | returns the value of the id supplied
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RearrangeSelectSet | Rearranges the dataset to make it suitable for display and reporting
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaSelectSet Class
OfficeClip.BusinessLayer.Metabase Namespace


GetMetaInfoCollection Method

[image]

OfficeClip API Documentation
MetaSelectSet..::.GetMetaInfoCollection Method
MetaSelectSet Class See Also

[This is preliminary documentation and is subject to change.]

Returns the metainfo collection when the data is requested via the primary key.

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static MetaInfoCollection GetMetaInfoCollection(
    ref DataSet ds,
    bool isEmpty
)
Visual Basic (Declaration)
Public Shared Function GetMetaInfoCollection ( _
    ByRef ds As DataSet, _
    isEmpty As Boolean _
) As MetaInfoCollection
Visual C++
public:
static MetaInfoCollection^ GetMetaInfoCollection(
    DataSet^% ds,
    bool isEmpty
)

Parameters

ds
Type: System.Data..::.DataSet%
The dtaset returned by the database
isEmpty
Type: System..::.Boolean
true if the collection is empty

Return Value

the collection, null if no data is returned from the dataset

See Also

MetaSelectSet Class
OfficeClip.BusinessLayer.Metabase Namespace


GetMetaValue Method

[image]

OfficeClip API Documentation
MetaSelectSet..::.GetMetaValue Method
MetaSelectSet Class See Also

[This is preliminary documentation and is subject to change.]

returns the value of the id supplied

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetMetaValue(
    DataSet ds,
    Object oid,
    int colId
)
Visual Basic (Declaration)
Public Shared Function GetMetaValue ( _
    ds As DataSet, _
    oid As Object, _
    colId As Integer _
) As String
Visual C++
public:
static String^ GetMetaValue(
    DataSet^ ds,
    Object^ oid,
    int colId
)

Parameters

ds
Type: System.Data..::.DataSet
The dataset that contains all the data information
oid
Type: System..::.Object
The id for which the value is desired
colId
Type: System..::.Int32
The column id of the column of table 1

Return Value

The value

See Also

MetaSelectSet Class
OfficeClip.BusinessLayer.Metabase Namespace


RearrangeSelectSet Method

[image]

OfficeClip API Documentation
MetaSelectSet..::.RearrangeSelectSet Method
MetaSelectSet Class See Also

[This is preliminary documentation and is subject to change.]

Rearranges the dataset to make it suitable for display and reporting

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static void RearrangeSelectSet(
    ref DataSet ds,
    bool isEmpty
)
Visual Basic (Declaration)
Public Shared Sub RearrangeSelectSet ( _
    ByRef ds As DataSet, _
    isEmpty As Boolean _
)
Visual C++
public:
static void RearrangeSelectSet(
    DataSet^% ds,
    bool isEmpty
)

Parameters

ds
Type: System.Data..::.DataSet%
The dataset that is returned from the database
isEmpty
Type: System..::.Boolean
means that the data table is not present and is empty

See Also

MetaSelectSet Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaValidate Class

[image]

OfficeClip API Documentation
MetaValidate Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to validate the meta information

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaValidate
Visual Basic (Declaration)
Public Class MetaValidate
Visual C++
public ref class MetaValidate

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.MetaValidate

See Also

MetaValidate Members
OfficeClip.BusinessLayer.Metabase Namespace


MetaValidate Members

[image] [image]

OfficeClip API Documentation
MetaValidate Members
MetaValidate Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The MetaValidate type exposes the following members.

Constructors

 | Name | Description
Public method | MetaValidate |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | Validate | Validates the meta information against the hashtable

See Also

MetaValidate Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaValidate Constructor

[image]

OfficeClip API Documentation
MetaValidate Constructor
MetaValidate Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaValidate()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaValidate()

See Also

MetaValidate Class
OfficeClip.BusinessLayer.Metabase Namespace


MetaValidate Methods

[image] [image]

OfficeClip API Documentation
MetaValidate Methods
MetaValidate Class See Also

[This is preliminary documentation and is subject to change.]

The MetaValidate type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | Validate | Validates the meta information against the hashtable

See Also

MetaValidate Class
OfficeClip.BusinessLayer.Metabase Namespace


Validate Method

[image]

OfficeClip API Documentation
MetaValidate..::.Validate Method
MetaValidate Class See Also

[This is preliminary documentation and is subject to change.]

Validates the meta information against the hashtable

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static bool Validate(
    DataTable dt,
    Hashtable ht
)
Visual Basic (Declaration)
Public Shared Function Validate ( _
    dt As DataTable, _
    ht As Hashtable _
) As Boolean
Visual C++
public:
static bool Validate(
    DataTable^ dt,
    Hashtable^ ht
)

Parameters

dt
Type: System.Data..::.DataTable
The data table for meta information
ht
Type: System.Collections..::.Hashtable
The hashtable

Return Value

True if it is validated, false otherwise

See Also

MetaValidate Class
OfficeClip.BusinessLayer.Metabase Namespace


Relation Class

[image]

OfficeClip API Documentation
Relation Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class Relation
Visual Basic (Declaration)
Public Class Relation
Visual C++
public ref class Relation

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.Relation

See Also

Relation Members
OfficeClip.BusinessLayer.Metabase Namespace


Relation Members

[image] [image]

OfficeClip API Documentation
Relation Members
Relation Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The Relation type exposes the following members.

Constructors

 | Name | Description
Public method | Relation | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ObjectId |
Public property | ObjectName |
Public property | ObjectTypeId |
Public property | ParentObjectId |
Public property | ParentObjectName |
Public property | ParentObjectTypeId |
Public property | RelationId |
Public property | RelationName |
Public property | RelationTypeId |

See Also

Relation Class
OfficeClip.BusinessLayer.Metabase Namespace


Relation Constructor

[image] [image]

OfficeClip API Documentation
Relation Constructor
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Relation(Int32, Int32, Int32, Int32, Int32, Int32) |
Public method | Relation(Int32, String, String, String, Int32, Int32, Int32, Int32) |

See Also

Relation Class
Relation Members
OfficeClip.BusinessLayer.Metabase Namespace


Relation Constructor (Int32, Int32, Int32, Int32, Int32, Int32)

[image]

OfficeClip API Documentation
Relation Constructor (Int32, Int32, Int32, Int32, Int32, Int32)
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Relation(
    int relId,
    int relTypeId,
    int objId,
    int objTypeId,
    int parObjId,
    int parObjTypeId
)
Visual Basic (Declaration)
Public Sub New ( _
    relId As Integer, _
    relTypeId As Integer, _
    objId As Integer, _
    objTypeId As Integer, _
    parObjId As Integer, _
    parObjTypeId As Integer _
)
Visual C++
public:
Relation(
    int relId,
    int relTypeId,
    int objId,
    int objTypeId,
    int parObjId,
    int parObjTypeId
)

Parameters

relId
Type: System..::.Int32
relTypeId
Type: System..::.Int32
objId
Type: System..::.Int32
objTypeId
Type: System..::.Int32
parObjId
Type: System..::.Int32
parObjTypeId
Type: System..::.Int32

See Also

Relation Class
Relation Overload
OfficeClip.BusinessLayer.Metabase Namespace


Relation Constructor (Int32, String, String, String, Int32, Int32, Int32, Int32)

[image]

OfficeClip API Documentation
Relation Constructor (Int32, String, String, String, Int32, Int32, Int32, Int32)
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Relation(
    int relId,
    string objName,
    string parentObjName,
    string rel,
    int parId,
    int parTypeId,
    int childId,
    int childTypeId
)
Visual Basic (Declaration)
Public Sub New ( _
    relId As Integer, _
    objName As String, _
    parentObjName As String, _
    rel As String, _
    parId As Integer, _
    parTypeId As Integer, _
    childId As Integer, _
    childTypeId As Integer _
)
Visual C++
public:
Relation(
    int relId,
    String^ objName,
    String^ parentObjName,
    String^ rel,
    int parId,
    int parTypeId,
    int childId,
    int childTypeId
)

Parameters

relId
Type: System..::.Int32
RelationId
objName
Type: System..::.String
Object Name
parentObjName
Type: System..::.String
Parent Object Name
rel
Type: System..::.String
Relation
parId
Type: System..::.Int32
parent object id
parTypeId
Type: System..::.Int32
parent object type id
childId
Type: System..::.Int32
Object Id
childTypeId
Type: System..::.Int32
Object Type Id

See Also

Relation Class
Relation Overload
OfficeClip.BusinessLayer.Metabase Namespace


Relation Properties

[image] [image]

OfficeClip API Documentation
Relation Properties
Relation Class See Also

[This is preliminary documentation and is subject to change.]

The Relation type exposes the following properties.

Properties

 | Name | Description
Public property | ObjectId |
Public property | ObjectName |
Public property | ObjectTypeId |
Public property | ParentObjectId |
Public property | ParentObjectName |
Public property | ParentObjectTypeId |
Public property | RelationId |
Public property | RelationName |
Public property | RelationTypeId |

See Also

Relation Class
OfficeClip.BusinessLayer.Metabase Namespace


ObjectId Property

[image]

OfficeClip API Documentation
Relation..::.ObjectId Property
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ObjectId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectId As Integer
Visual C++
public:
property int ObjectId {
    int get ();
}

See Also

Relation Class
OfficeClip.BusinessLayer.Metabase Namespace


ObjectName Property

[image]

OfficeClip API Documentation
Relation..::.ObjectName Property
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ObjectName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectName As String
Visual C++
public:
property String^ ObjectName {
    String^ get ();
}

See Also

Relation Class
OfficeClip.BusinessLayer.Metabase Namespace


ObjectTypeId Property

[image]

OfficeClip API Documentation
Relation..::.ObjectTypeId Property
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ObjectTypeId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectTypeId As Integer
Visual C++
public:
property int ObjectTypeId {
    int get ();
}

See Also

Relation Class
OfficeClip.BusinessLayer.Metabase Namespace


ParentObjectId Property

[image]

OfficeClip API Documentation
Relation..::.ParentObjectId Property
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ParentObjectId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentObjectId As Integer
Visual C++
public:
property int ParentObjectId {
    int get ();
}

See Also

Relation Class
OfficeClip.BusinessLayer.Metabase Namespace


ParentObjectName Property

[image]

OfficeClip API Documentation
Relation..::.ParentObjectName Property
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ParentObjectName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentObjectName As String
Visual C++
public:
property String^ ParentObjectName {
    String^ get ();
}

See Also

Relation Class
OfficeClip.BusinessLayer.Metabase Namespace


ParentObjectTypeId Property

[image]

OfficeClip API Documentation
Relation..::.ParentObjectTypeId Property
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ParentObjectTypeId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentObjectTypeId As Integer
Visual C++
public:
property int ParentObjectTypeId {
    int get ();
}

See Also

Relation Class
OfficeClip.BusinessLayer.Metabase Namespace


RelationId Property

[image]

OfficeClip API Documentation
Relation..::.RelationId Property
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RelationId { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelationId As Integer
Visual C++
public:
property int RelationId {
    int get ();
}

See Also

Relation Class
OfficeClip.BusinessLayer.Metabase Namespace


RelationName Property

[image]

OfficeClip API Documentation
Relation..::.RelationName Property
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RelationName { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelationName As String
Visual C++
public:
property String^ RelationName {
    String^ get ();
}

See Also

Relation Class
OfficeClip.BusinessLayer.Metabase Namespace


RelationTypeId Property

[image]

OfficeClip API Documentation
Relation..::.RelationTypeId Property
Relation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RelationTypeId { get; }
Visual Basic (Declaration)
Public ReadOnly Property RelationTypeId As Integer
Visual C++
public:
property int RelationTypeId {
    int get ();
}

See Also

Relation Class
OfficeClip.BusinessLayer.Metabase Namespace


RelationType Class

[image]

OfficeClip API Documentation
RelationType Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class RelationType
Visual Basic (Declaration)
Public Class RelationType
Visual C++
public ref class RelationType

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase..::.RelationType

See Also

RelationType Members
OfficeClip.BusinessLayer.Metabase Namespace


RelationType Members

[image] [image]

OfficeClip API Documentation
RelationType Members
RelationType Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RelationType type exposes the following members.

Constructors

 | Name | Description
Public method | RelationType | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GroupId |
Public property | RelationName |
Public property | RelationTypeId |

See Also

RelationType Class
OfficeClip.BusinessLayer.Metabase Namespace


RelationType Constructor

[image] [image]

OfficeClip API Documentation
RelationType Constructor
RelationType Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | RelationType()()() |
Public method | RelationType(Int32, Int32, String) |

See Also

RelationType Class
RelationType Members
OfficeClip.BusinessLayer.Metabase Namespace


RelationType Constructor

[image]

OfficeClip API Documentation
RelationType Constructor
RelationType Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RelationType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RelationType()

See Also

RelationType Class
RelationType Overload
OfficeClip.BusinessLayer.Metabase Namespace


RelationType Constructor (Int32, Int32, String)

[image]

OfficeClip API Documentation
RelationType Constructor (Int32, Int32, String)
RelationType Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RelationType(
    int relTypeId,
    int grpId,
    string relName
)
Visual Basic (Declaration)
Public Sub New ( _
    relTypeId As Integer, _
    grpId As Integer, _
    relName As String _
)
Visual C++
public:
RelationType(
    int relTypeId,
    int grpId,
    String^ relName
)

Parameters

relTypeId
Type: System..::.Int32
grpId
Type: System..::.Int32
relName
Type: System..::.String

See Also

RelationType Class
RelationType Overload
OfficeClip.BusinessLayer.Metabase Namespace


RelationType Properties

[image] [image]

OfficeClip API Documentation
RelationType Properties
RelationType Class See Also

[This is preliminary documentation and is subject to change.]

The RelationType type exposes the following properties.

Properties

 | Name | Description
Public property | GroupId |
Public property | RelationName |
Public property | RelationTypeId |

See Also

RelationType Class
OfficeClip.BusinessLayer.Metabase Namespace


GroupId Property

[image]

OfficeClip API Documentation
RelationType..::.GroupId Property
RelationType Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

RelationType Class
OfficeClip.BusinessLayer.Metabase Namespace


RelationName Property

[image]

OfficeClip API Documentation
RelationType..::.RelationName Property
RelationType Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RelationName { get; set; }
Visual Basic (Declaration)
Public Property RelationName As String
Visual C++
public:
property String^ RelationName {
    String^ get ();
    void set (String^ value);
}

See Also

RelationType Class
OfficeClip.BusinessLayer.Metabase Namespace


RelationTypeId Property

[image]

OfficeClip API Documentation
RelationType..::.RelationTypeId Property
RelationType Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Metabase
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RelationTypeId { get; set; }
Visual Basic (Declaration)
Public Property RelationTypeId As Integer
Visual C++
public:
property int RelationTypeId {
    int get ();
    void set (int value);
}

See Also

RelationType Class
OfficeClip.BusinessLayer.Metabase Namespace


OfficeClip.BusinessLayer.Metabase.Filter Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Metabase.Filter Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the metabase filters

Classes

 | Class | Description
Public class | Criteria | Class for the Report Filter criteria
Public class | CriteriaPosition | Class for determining the position of the criteria
Public class | ExtMF | Class that contains a bunch of filter attributes and filter id and is used only for external filters, i.e. the predetermined filters
Public class | FC | Class to specify a filter
Public class | MF | Class that contains a bunch of filter attributes and filter conditions


Criteria Class

[image]

OfficeClip API Documentation
Criteria Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class for the Report Filter criteria

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class Criteria
Visual Basic (Declaration)
Public Class Criteria
Visual C++
public ref class Criteria

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase.Filter..::.Criteria

See Also

Criteria Members
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Criteria Members

[image] [image]

OfficeClip API Documentation
Criteria Members
Criteria Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The Criteria type exposes the following members.

Constructors

 | Name | Description
Public method | Criteria | The empty default constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAttribute | Removes the attribute from the criteria list
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Groups | array of groups
Public property | GroupSorts | Report Sort Order Array
Public property | Margin | The margin of the report
Public property | OrderByFields | The array of the ids of the order by fields
Public property | OrderBySorts | The array of the report sort orders
Public property | ReportFooter | The Report Footer
Public property | ReportHeader | The Report Header Name
Public property | RTotalFields | The array of fields total

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Criteria Constructor

[image]

OfficeClip API Documentation
Criteria Constructor
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

The empty default constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Criteria()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Criteria()

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Criteria Methods

[image] [image]

OfficeClip API Documentation
Criteria Methods
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

The Criteria type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAttribute | Removes the attribute from the criteria list
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


RemoveAttribute Method

[image]

OfficeClip API Documentation
Criteria..::.RemoveAttribute Method
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

Removes the attribute from the criteria list

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool RemoveAttribute(
    int attrId
)
Visual Basic (Declaration)
Public Function RemoveAttribute ( _
    attrId As Integer _
) As Boolean
Visual C++
public:
bool RemoveAttribute(
    int attrId
)

Parameters

attrId
Type: System..::.Int32
The id of the attribute

Return Value

true if the criteria got removed, false otherwise

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Criteria Properties

[image] [image]

OfficeClip API Documentation
Criteria Properties
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

The Criteria type exposes the following properties.

Properties

 | Name | Description
Public property | Groups | array of groups
Public property | GroupSorts | Report Sort Order Array
Public property | Margin | The margin of the report
Public property | OrderByFields | The array of the ids of the order by fields
Public property | OrderBySorts | The array of the report sort orders
Public property | ReportFooter | The Report Footer
Public property | ReportHeader | The Report Header Name
Public property | RTotalFields | The array of fields total

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Groups Property

[image]

OfficeClip API Documentation
Criteria..::.Groups Property
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

array of groups

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int[] Groups { get; set; }
Visual Basic (Declaration)
Public Property Groups As Integer()
Visual C++
public:
property array<int>^ Groups {
    array<int>^ get ();
    void set (array<int>^ value);
}

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


GroupSorts Property

[image]

OfficeClip API Documentation
Criteria..::.GroupSorts Property
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

Report Sort Order Array

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaConstants..::.ReportSortOrder[] GroupSorts { get; set; }
Visual Basic (Declaration)
Public Property GroupSorts As MetaConstants..::.ReportSortOrder()
Visual C++
public:
property array<MetaConstants..::.ReportSortOrder>^ GroupSorts {
    array<MetaConstants..::.ReportSortOrder>^ get ();
    void set (array<MetaConstants..::.ReportSortOrder>^ value);
}

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Margin Property

[image]

OfficeClip API Documentation
Criteria..::.Margin Property
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

The margin of the report

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Margin { get; set; }
Visual Basic (Declaration)
Public Property Margin As Integer
Visual C++
public:
property int Margin {
    int get ();
    void set (int value);
}

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


OrderByFields Property

[image]

OfficeClip API Documentation
Criteria..::.OrderByFields Property
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

The array of the ids of the order by fields

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int[] OrderByFields { get; set; }
Visual Basic (Declaration)
Public Property OrderByFields As Integer()
Visual C++
public:
property array<int>^ OrderByFields {
    array<int>^ get ();
    void set (array<int>^ value);
}

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


OrderBySorts Property

[image]

OfficeClip API Documentation
Criteria..::.OrderBySorts Property
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

The array of the report sort orders

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaConstants..::.ReportSortOrder[] OrderBySorts { get; set; }
Visual Basic (Declaration)
Public Property OrderBySorts As MetaConstants..::.ReportSortOrder()
Visual C++
public:
property array<MetaConstants..::.ReportSortOrder>^ OrderBySorts {
    array<MetaConstants..::.ReportSortOrder>^ get ();
    void set (array<MetaConstants..::.ReportSortOrder>^ value);
}

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


ReportFooter Property

[image]

OfficeClip API Documentation
Criteria..::.ReportFooter Property
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

The Report Footer

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportFooter { get; set; }
Visual Basic (Declaration)
Public Property ReportFooter As String
Visual C++
public:
property String^ ReportFooter {
    String^ get ();
    void set (String^ value);
}

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


ReportHeader Property

[image]

OfficeClip API Documentation
Criteria..::.ReportHeader Property
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

The Report Header Name

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportHeader { get; set; }
Visual Basic (Declaration)
Public Property ReportHeader As String
Visual C++
public:
property String^ ReportHeader {
    String^ get ();
    void set (String^ value);
}

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


RTotalFields Property

[image]

OfficeClip API Documentation
Criteria..::.RTotalFields Property
Criteria Class See Also

[This is preliminary documentation and is subject to change.]

The array of fields total

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int[] RTotalFields { get; set; }
Visual Basic (Declaration)
Public Property RTotalFields As Integer()
Visual C++
public:
property array<int>^ RTotalFields {
    array<int>^ get ();
    void set (array<int>^ value);
}

See Also

Criteria Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


CriteriaPosition Class

[image]

OfficeClip API Documentation
CriteriaPosition Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class for determining the position of the criteria

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class CriteriaPosition
Visual Basic (Declaration)
Public Class CriteriaPosition
Visual C++
public ref class CriteriaPosition

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase.Filter..::.CriteriaPosition

See Also

CriteriaPosition Members
OfficeClip.BusinessLayer.Metabase.Filter Namespace


CriteriaPosition Members

[image] [image]

OfficeClip API Documentation
CriteriaPosition Members
CriteriaPosition Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The CriteriaPosition type exposes the following members.

Constructors

 | Name | Description
Public method | CriteriaPosition | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Left | The left position
Public property | PositionId | The id of the position
Public property | Width | The width

See Also

CriteriaPosition Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


CriteriaPosition Constructor

[image] [image]

OfficeClip API Documentation
CriteriaPosition Constructor
CriteriaPosition Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | CriteriaPosition()()() | The default constructor
Public method | CriteriaPosition(Int32, Int32, Int32) | Constructor

See Also

CriteriaPosition Class
CriteriaPosition Members
OfficeClip.BusinessLayer.Metabase.Filter Namespace


CriteriaPosition Constructor

[image]

OfficeClip API Documentation
CriteriaPosition Constructor
CriteriaPosition Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CriteriaPosition()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CriteriaPosition()

See Also

CriteriaPosition Class
CriteriaPosition Overload
OfficeClip.BusinessLayer.Metabase.Filter Namespace


CriteriaPosition Constructor (Int32, Int32, Int32)

[image]

OfficeClip API Documentation
CriteriaPosition Constructor (Int32, Int32, Int32)
CriteriaPosition Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CriteriaPosition(
    int positionId,
    int left,
    int width
)
Visual Basic (Declaration)
Public Sub New ( _
    positionId As Integer, _
    left As Integer, _
    width As Integer _
)
Visual C++
public:
CriteriaPosition(
    int positionId,
    int left,
    int width
)

Parameters

positionId
Type: System..::.Int32
The id of the position
left
Type: System..::.Int32
The left position
width
Type: System..::.Int32
The width

See Also

CriteriaPosition Class
CriteriaPosition Overload
OfficeClip.BusinessLayer.Metabase.Filter Namespace


CriteriaPosition Properties

[image] [image]

OfficeClip API Documentation
CriteriaPosition Properties
CriteriaPosition Class See Also

[This is preliminary documentation and is subject to change.]

The CriteriaPosition type exposes the following properties.

Properties

 | Name | Description
Public property | Left | The left position
Public property | PositionId | The id of the position
Public property | Width | The width

See Also

CriteriaPosition Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Left Property

[image]

OfficeClip API Documentation
CriteriaPosition..::.Left Property
CriteriaPosition Class See Also

[This is preliminary documentation and is subject to change.]

The left position

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Integer
Visual C++
public:
property int Left {
    int get ();
    void set (int value);
}

See Also

CriteriaPosition Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


PositionId Property

[image]

OfficeClip API Documentation
CriteriaPosition..::.PositionId Property
CriteriaPosition Class See Also

[This is preliminary documentation and is subject to change.]

The id of the position

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int PositionId { get; set; }
Visual Basic (Declaration)
Public Property PositionId As Integer
Visual C++
public:
property int PositionId {
    int get ();
    void set (int value);
}

See Also

CriteriaPosition Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Width Property

[image]

OfficeClip API Documentation
CriteriaPosition..::.Width Property
CriteriaPosition Class See Also

[This is preliminary documentation and is subject to change.]

The width

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

CriteriaPosition Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


ExtMF Class

[image]

OfficeClip API Documentation
ExtMF Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class that contains a bunch of filter attributes and filter id and is used only for external filters, i.e. the predetermined filters

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ExtMF
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExtMF
Visual C++
[SerializableAttribute]
public ref class ExtMF

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase.Filter..::.ExtMF

See Also

ExtMF Members
OfficeClip.BusinessLayer.Metabase.Filter Namespace


ExtMF Members

[image] [image]

OfficeClip API Documentation
ExtMF Members
ExtMF Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExtMF type exposes the following members.

Constructors

 | Name | Description
Public method | ExtMF | Overloaded.

Methods

 | Name | Description
Public method | Attributes | Array of attributes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttributePresent | Checks if the attribute is present
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAttribute | Removes a given attribute from the filter
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FAs | The filter attributes
Public property | FilterId | filter id
Public property | FilterName | filter name

See Also

ExtMF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


ExtMF Constructor

[image] [image]

OfficeClip API Documentation
ExtMF Constructor
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExtMF()()() | The default constructor
Public method | ExtMF(SerializationInfo, StreamingContext) | Constructor
Public method | ExtMF(String, Int32, String) | Constructor

See Also

ExtMF Class
ExtMF Members
OfficeClip.BusinessLayer.Metabase.Filter Namespace


ExtMF Constructor

[image]

OfficeClip API Documentation
ExtMF Constructor
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExtMF()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExtMF()

See Also

ExtMF Class
ExtMF Overload
OfficeClip.BusinessLayer.Metabase.Filter Namespace


ExtMF Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
ExtMF Constructor (SerializationInfo, StreamingContext)
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExtMF(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExtMF(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Serialization info
context
Type: System.Runtime.Serialization..::.StreamingContext
streaming context

See Also

ExtMF Class
ExtMF Overload
OfficeClip.BusinessLayer.Metabase.Filter Namespace


ExtMF Constructor (String, Int32, String)

[image]

OfficeClip API Documentation
ExtMF Constructor (String, Int32, String)
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExtMF(
    string filterAttributes,
    int filterId,
    string filterName
)
Visual Basic (Declaration)
Public Sub New ( _
    filterAttributes As String, _
    filterId As Integer, _
    filterName As String _
)
Visual C++
public:
ExtMF(
    String^ filterAttributes,
    int filterId,
    String^ filterName
)

Parameters

filterAttributes
Type: System..::.String
The filter attributes
filterId
Type: System..::.Int32
The filter id
filterName
Type: System..::.String
The name of the filter

See Also

ExtMF Class
ExtMF Overload
OfficeClip.BusinessLayer.Metabase.Filter Namespace


ExtMF Methods

[image] [image]

OfficeClip API Documentation
ExtMF Methods
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

The ExtMF type exposes the following methods.

Methods

 | Name | Description
Public method | Attributes | Array of attributes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttributePresent | Checks if the attribute is present
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAttribute | Removes a given attribute from the filter
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtMF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Attributes Method

[image]

OfficeClip API Documentation
ExtMF..::.Attributes Method
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

Array of attributes

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string[] Attributes()
Visual Basic (Declaration)
Public Function Attributes As String()
Visual C++
public:
array<String^>^ Attributes()

Return Value

See Also

ExtMF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


IsAttributePresent Method

[image]

OfficeClip API Documentation
ExtMF..::.IsAttributePresent Method
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

Checks if the attribute is present

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAttributePresent(
    int attr
)
Visual Basic (Declaration)
Public Function IsAttributePresent ( _
    attr As Integer _
) As Boolean
Visual C++
public:
bool IsAttributePresent(
    int attr
)

Parameters

attr
Type: System..::.Int32
The attribute id to check

Return Value

true if present, false otherwise

See Also

ExtMF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


RemoveAttribute Method

[image]

OfficeClip API Documentation
ExtMF..::.RemoveAttribute Method
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

Removes a given attribute from the filter

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool RemoveAttribute(
    int attrId
)
Visual Basic (Declaration)
Public Function RemoveAttribute ( _
    attrId As Integer _
) As Boolean
Visual C++
public:
bool RemoveAttribute(
    int attrId
)

Parameters

attrId
Type: System..::.Int32
The unique id of the attribute

Return Value

true if the attribute is removed, false otherwise

See Also

ExtMF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


ExtMF Properties

[image] [image]

OfficeClip API Documentation
ExtMF Properties
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

The ExtMF type exposes the following properties.

Properties

 | Name | Description
Public property | FAs | The filter attributes
Public property | FilterId | filter id
Public property | FilterName | filter name

See Also

ExtMF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FAs Property

[image]

OfficeClip API Documentation
ExtMF..::.FAs Property
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

The filter attributes

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FAs { get; set; }
Visual Basic (Declaration)
Public Property FAs As String
Visual C++
public:
property String^ FAs {
    String^ get ();
    void set (String^ value);
}

See Also

ExtMF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FilterId Property

[image]

OfficeClip API Documentation
ExtMF..::.FilterId Property
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

filter id

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int FilterId { get; set; }
Visual Basic (Declaration)
Public Property FilterId As Integer
Visual C++
public:
property int FilterId {
    int get ();
    void set (int value);
}

See Also

ExtMF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FilterName Property

[image]

OfficeClip API Documentation
ExtMF..::.FilterName Property
ExtMF Class See Also

[This is preliminary documentation and is subject to change.]

filter name

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FilterName { get; set; }
Visual Basic (Declaration)
Public Property FilterName As String
Visual C++
public:
property String^ FilterName {
    String^ get ();
    void set (String^ value);
}

See Also

ExtMF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FC Class

[image]

OfficeClip API Documentation
FC Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to specify a filter

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class FC
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class FC
Visual C++
[SerializableAttribute]
public ref class FC

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase.Filter..::.FC

See Also

FC Members
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FC Members

[image] [image]

OfficeClip API Documentation
FC Members
FC Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The FC type exposes the following members.

Constructors

 | Name | Description
Public method | FC | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveListValue | Removes the list value for a particular attribute and list item
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cid | The choice id
Public property | FFunc | The filter function
Public property | Value | The filter value

See Also

FC Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FC Constructor

[image] [image]

OfficeClip API Documentation
FC Constructor
FC Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | FC()()() | The default constructor
Public method | FC(SerializationInfo, StreamingContext) | Constructor
Public method | FC(MetaConstants..::.FilterFunction, Int32, String) | Constructor

See Also

FC Class
FC Members
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FC Constructor

[image]

OfficeClip API Documentation
FC Constructor
FC Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public FC()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FC()

See Also

FC Class
FC Overload
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FC Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
FC Constructor (SerializationInfo, StreamingContext)
FC Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public FC(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
FC(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Serializatoin information
context
Type: System.Runtime.Serialization..::.StreamingContext
Streaming Context

See Also

FC Class
FC Overload
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FC Constructor (MetaConstants.FilterFunction, Int32, String)

[image]

OfficeClip API Documentation
FC Constructor (MetaConstants..::.FilterFunction, Int32, String)
FC Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public FC(
    MetaConstants..::.FilterFunction ffunc,
    int choiceId,
    string val
)
Visual Basic (Declaration)
Public Sub New ( _
    ffunc As MetaConstants..::.FilterFunction, _
    choiceId As Integer, _
    val As String _
)
Visual C++
public:
FC(
    MetaConstants..::.FilterFunction ffunc,
    int choiceId,
    String^ val
)

Parameters

ffunc
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.FilterFunction
The filter function
choiceId
Type: System..::.Int32
The choice id
val
Type: System..::.String
The value for the filter

See Also

FC Class
FC Overload
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FC Methods

[image] [image]

OfficeClip API Documentation
FC Methods
FC Class See Also

[This is preliminary documentation and is subject to change.]

The FC type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveListValue | Removes the list value for a particular attribute and list item
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FC Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


RemoveListValue Method

[image]

OfficeClip API Documentation
FC..::.RemoveListValue Method
FC Class See Also

[This is preliminary documentation and is subject to change.]

Removes the list value for a particular attribute and list item

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool RemoveListValue(
    int attributeId,
    int ListItemId
)
Visual Basic (Declaration)
Public Function RemoveListValue ( _
    attributeId As Integer, _
    ListItemId As Integer _
) As Boolean
Visual C++
public:
bool RemoveListValue(
    int attributeId,
    int ListItemId
)

Parameters

attributeId
Type: System..::.Int32
The unique id of the attribute
ListItemId
Type: System..::.Int32
The unique id of the list item

Return Value

True if the list could be removed, false otherwise

See Also

FC Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FC Properties

[image] [image]

OfficeClip API Documentation
FC Properties
FC Class See Also

[This is preliminary documentation and is subject to change.]

The FC type exposes the following properties.

Properties

 | Name | Description
Public property | Cid | The choice id
Public property | FFunc | The filter function
Public property | Value | The filter value

See Also

FC Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Cid Property

[image]

OfficeClip API Documentation
FC..::.Cid Property
FC Class See Also

[This is preliminary documentation and is subject to change.]

The choice id

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Cid { get; set; }
Visual Basic (Declaration)
Public Property Cid As Integer
Visual C++
public:
property int Cid {
    int get ();
    void set (int value);
}

See Also

FC Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FFunc Property

[image]

OfficeClip API Documentation
FC..::.FFunc Property
FC Class See Also

[This is preliminary documentation and is subject to change.]

The filter function

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaConstants..::.FilterFunction FFunc { get; set; }
Visual Basic (Declaration)
Public Property FFunc As MetaConstants..::.FilterFunction
Visual C++
public:
property MetaConstants..::.FilterFunction FFunc {
    MetaConstants..::.FilterFunction get ();
    void set (MetaConstants..::.FilterFunction value);
}

See Also

FC Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Value Property

[image]

OfficeClip API Documentation
FC..::.Value Property
FC Class See Also

[This is preliminary documentation and is subject to change.]

The filter value

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

FC Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


MF Class

[image]

OfficeClip API Documentation
MF Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class that contains a bunch of filter attributes and filter conditions

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class MF
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MF
Visual C++
[SerializableAttribute]
public ref class MF

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Metabase.Filter..::.MF

See Also

MF Members
OfficeClip.BusinessLayer.Metabase.Filter Namespace


MF Members

[image] [image]

OfficeClip API Documentation
MF Members
MF Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MF type exposes the following members.

Constructors

 | Name | Description
Public method | MF | Overloaded.

Methods

 | Name | Description
Public method | Attributes | Array of attributes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttributePresent | Checks if the attribute is present
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAttribute | Removes a given attribute from the filter
Public method | RemoveConditionListValue | Removes the filter condition list value
Public method | RemoveFilterCondition | Removes a filter condition
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FAs | The filter attributes
Public property | FCs | Array of filter conditions

See Also

MF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


MF Constructor

[image] [image]

OfficeClip API Documentation
MF Constructor
MF Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MF()()() | The default constructor
Public method | MF(SerializationInfo, StreamingContext) | Constructor
Public method | MF(String, array<FC>[]()[]) | Constructor

See Also

MF Class
MF Members
OfficeClip.BusinessLayer.Metabase.Filter Namespace


MF Constructor

[image]

OfficeClip API Documentation
MF Constructor
MF Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MF()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MF()

See Also

MF Class
MF Overload
OfficeClip.BusinessLayer.Metabase.Filter Namespace


MF Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
MF Constructor (SerializationInfo, StreamingContext)
MF Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MF(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
MF(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
Serialization info
context
Type: System.Runtime.Serialization..::.StreamingContext
streaming context

See Also

MF Class
MF Overload
OfficeClip.BusinessLayer.Metabase.Filter Namespace


MF Constructor (String, FC[])

[image]

OfficeClip API Documentation
MF Constructor (String, array<FC>[]()[])
MF Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MF(
    string filterAttributes,
    FC[] filterConditions
)
Visual Basic (Declaration)
Public Sub New ( _
    filterAttributes As String, _
    filterConditions As FC() _
)
Visual C++
public:
MF(
    String^ filterAttributes,
    array<FC^>^ filterConditions
)

Parameters

filterAttributes
Type: System..::.String
The filter attributes
filterConditions
Type: array< OfficeClip.BusinessLayer.Metabase.Filter..::.FC >[]()[]
The filter conditions

See Also

MF Class
MF Overload
OfficeClip.BusinessLayer.Metabase.Filter Namespace


MF Methods

[image] [image]

OfficeClip API Documentation
MF Methods
MF Class See Also

[This is preliminary documentation and is subject to change.]

The MF type exposes the following methods.

Methods

 | Name | Description
Public method | Attributes | Array of attributes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAttributePresent | Checks if the attribute is present
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAttribute | Removes a given attribute from the filter
Public method | RemoveConditionListValue | Removes the filter condition list value
Public method | RemoveFilterCondition | Removes a filter condition
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


Attributes Method

[image]

OfficeClip API Documentation
MF..::.Attributes Method
MF Class See Also

[This is preliminary documentation and is subject to change.]

Array of attributes

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string[] Attributes()
Visual Basic (Declaration)
Public Function Attributes As String()
Visual C++
public:
array<String^>^ Attributes()

Return Value

See Also

MF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


IsAttributePresent Method

[image]

OfficeClip API Documentation
MF..::.IsAttributePresent Method
MF Class See Also

[This is preliminary documentation and is subject to change.]

Checks if the attribute is present

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAttributePresent(
    int attr
)
Visual Basic (Declaration)
Public Function IsAttributePresent ( _
    attr As Integer _
) As Boolean
Visual C++
public:
bool IsAttributePresent(
    int attr
)

Parameters

attr
Type: System..::.Int32
The attribute id to check

Return Value

true if present, false otherwise

See Also

MF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


RemoveAttribute Method

[image]

OfficeClip API Documentation
MF..::.RemoveAttribute Method
MF Class See Also

[This is preliminary documentation and is subject to change.]

Removes a given attribute from the filter

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool RemoveAttribute(
    int attrId
)
Visual Basic (Declaration)
Public Function RemoveAttribute ( _
    attrId As Integer _
) As Boolean
Visual C++
public:
bool RemoveAttribute(
    int attrId
)

Parameters

attrId
Type: System..::.Int32
The unique id of the attribute

Return Value

true if the attribute is removed, false otherwise

See Also

MF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


RemoveConditionListValue Method

[image]

OfficeClip API Documentation
MF..::.RemoveConditionListValue Method
MF Class See Also

[This is preliminary documentation and is subject to change.]

Removes the filter condition list value

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool RemoveConditionListValue(
    int attributeId,
    int listItemId
)
Visual Basic (Declaration)
Public Function RemoveConditionListValue ( _
    attributeId As Integer, _
    listItemId As Integer _
) As Boolean
Visual C++
public:
bool RemoveConditionListValue(
    int attributeId,
    int listItemId
)

Parameters

attributeId
Type: System..::.Int32
The unique id of the attribute
listItemId
Type: System..::.Int32
The unique id of the list item

Return Value

See Also

MF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


RemoveFilterCondition Method

[image]

OfficeClip API Documentation
MF..::.RemoveFilterCondition Method
MF Class See Also

[This is preliminary documentation and is subject to change.]

Removes a filter condition

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool RemoveFilterCondition(
    int choiceId
)
Visual Basic (Declaration)
Public Function RemoveFilterCondition ( _
    choiceId As Integer _
) As Boolean
Visual C++
public:
bool RemoveFilterCondition(
    int choiceId
)

Parameters

choiceId
Type: System..::.Int32
The choice id of the filter condition

Return Value

true if the filter condition could be removed, false otherwise.

See Also

MF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


MF Properties

[image] [image]

OfficeClip API Documentation
MF Properties
MF Class See Also

[This is preliminary documentation and is subject to change.]

The MF type exposes the following properties.

Properties

 | Name | Description
Public property | FAs | The filter attributes
Public property | FCs | Array of filter conditions

See Also

MF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FAs Property

[image]

OfficeClip API Documentation
MF..::.FAs Property
MF Class See Also

[This is preliminary documentation and is subject to change.]

The filter attributes

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FAs { get; set; }
Visual Basic (Declaration)
Public Property FAs As String
Visual C++
public:
property String^ FAs {
    String^ get ();
    void set (String^ value);
}

See Also

MF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


FCs Property

[image]

OfficeClip API Documentation
MF..::.FCs Property
MF Class See Also

[This is preliminary documentation and is subject to change.]

Array of filter conditions

Namespace: OfficeClip.BusinessLayer.Metabase.Filter
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public FC[] FCs { get; set; }
Visual Basic (Declaration)
Public Property FCs As FC()
Visual C++
public:
property array<FC^>^ FCs {
    array<FC^>^ get ();
    void set (array<FC^>^ value);
}

See Also

MF Class
OfficeClip.BusinessLayer.Metabase.Filter Namespace


OfficeClip.BusinessLayer.OfficePortal Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.OfficePortal Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the Office Portal

Classes

 | Class | Description
Public class | NoteInfo | Summary description for NoteInfo.
Public class | PhotoInfo | Provides methods and properties to access the information relating to the photos.


NoteInfo Class

[image]

OfficeClip API Documentation
NoteInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Summary description for NoteInfo.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class NoteInfo
Visual Basic (Declaration)
Public Class NoteInfo
Visual C++
public ref class NoteInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.OfficePortal..::.NoteInfo

See Also

NoteInfo Members
OfficeClip.BusinessLayer.OfficePortal Namespace


NoteInfo Members

[image] [image]

OfficeClip API Documentation
NoteInfo Members
NoteInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The NoteInfo type exposes the following members.

Constructors

 | Name | Description
Public method | NoteInfo | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the task to the string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedByTimestamp | The timestamp when the note was created
Public property | CreatedByUserId | The unique id of the note creator
Public property | GroupId | The unique id of the group that created the note
Public property | IsGroup | True if the note is visible to the group, false otherwise
Public property | ModifiedByTimestamp | The timestamp when the note was last modified
Public property | ModifiedByUserId | The unique id of the user who last modified the note
Public property | Note | The note description
Public property | NoteId | The unique id of the note
Public property | ParentId | The note parent object id. The value is -1 if the note does not have any parent
Public property | ParentObjectType | The object type of the object that is parent to this note.

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


NoteInfo Constructor

[image] [image]

OfficeClip API Documentation
NoteInfo Constructor
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | NoteInfo()()() | Default constructor
Public method | NoteInfo(Int32, String, Int32, DateTime, Boolean, Int32, Int32, DateTime, BusinessConstants..::.ObjectType, Int32) | The copy constructor

See Also

NoteInfo Class
NoteInfo Members
OfficeClip.BusinessLayer.OfficePortal Namespace


NoteInfo Constructor

[image]

OfficeClip API Documentation
NoteInfo Constructor
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NoteInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoteInfo()

See Also

NoteInfo Class
NoteInfo Overload
OfficeClip.BusinessLayer.OfficePortal Namespace


NoteInfo Constructor (Int32, String, Int32, DateTime, Boolean, Int32, Int32, DateTime, BusinessConstants.ObjectType, Int32)

[image]

OfficeClip API Documentation
NoteInfo Constructor (Int32, String, Int32, DateTime, Boolean, Int32, Int32, DateTime, BusinessConstants..::.ObjectType, Int32)
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The copy constructor

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NoteInfo(
    int noteId,
    string note,
    int createdByUserId,
    DateTime createdByTimestamp,
    bool isGroup,
    int groupId,
    int modifiedByUserId,
    DateTime modifiedTimestamp,
    BusinessConstants..::.ObjectType parentObjectType,
    int parentId
)
Visual Basic (Declaration)
Public Sub New ( _
    noteId As Integer, _
    note As String, _
    createdByUserId As Integer, _
    createdByTimestamp As DateTime, _
    isGroup As Boolean, _
    groupId As Integer, _
    modifiedByUserId As Integer, _
    modifiedTimestamp As DateTime, _
    parentObjectType As BusinessConstants..::.ObjectType, _
    parentId As Integer _
)
Visual C++
public:
NoteInfo(
    int noteId,
    String^ note,
    int createdByUserId,
    DateTime createdByTimestamp,
    bool isGroup,
    int groupId,
    int modifiedByUserId,
    DateTime modifiedTimestamp,
    BusinessConstants..::.ObjectType parentObjectType,
    int parentId
)

Parameters

noteId
Type: System..::.Int32
The unique id of the note
note
Type: System..::.String
The note description
createdByUserId
Type: System..::.Int32
The unique id of the note creator
createdByTimestamp
Type: System..::.DateTime
The timestamp of the the note creation
isGroup
Type: System..::.Boolean
true if the note is visible to the group.
groupId
Type: System..::.Int32
The unique id of the group that the note is created in
modifiedByUserId
Type: System..::.Int32
The unique id of the user who last modified the note
modifiedTimestamp
Type: System..::.DateTime
The time when the note was last modified
parentObjectType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
the parent object type
parentId
Type: System..::.Int32
The id of the parent object

See Also

NoteInfo Class
NoteInfo Overload
OfficeClip.BusinessLayer.OfficePortal Namespace


NoteInfo Methods

[image] [image]

OfficeClip API Documentation
NoteInfo Methods
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The NoteInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the task to the string
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


Dump Method

[image]

OfficeClip API Documentation
NoteInfo..::.Dump Method
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the task to the string

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

The string value of the task object

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


NoteInfo Properties

[image] [image]

OfficeClip API Documentation
NoteInfo Properties
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The NoteInfo type exposes the following properties.

Properties

 | Name | Description
Public property | CreatedByTimestamp | The timestamp when the note was created
Public property | CreatedByUserId | The unique id of the note creator
Public property | GroupId | The unique id of the group that created the note
Public property | IsGroup | True if the note is visible to the group, false otherwise
Public property | ModifiedByTimestamp | The timestamp when the note was last modified
Public property | ModifiedByUserId | The unique id of the user who last modified the note
Public property | Note | The note description
Public property | NoteId | The unique id of the note
Public property | ParentId | The note parent object id. The value is -1 if the note does not have any parent
Public property | ParentObjectType | The object type of the object that is parent to this note.

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


CreatedByTimestamp Property

[image]

OfficeClip API Documentation
NoteInfo..::.CreatedByTimestamp Property
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The timestamp when the note was created

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedByTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedByTimestamp As DateTime
Visual C++
public:
property DateTime CreatedByTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


CreatedByUserId Property

[image]

OfficeClip API Documentation
NoteInfo..::.CreatedByUserId Property
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the note creator

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedByUserId { get; set; }
Visual Basic (Declaration)
Public Property CreatedByUserId As Integer
Visual C++
public:
property int CreatedByUserId {
    int get ();
    void set (int value);
}

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


GroupId Property

[image]

OfficeClip API Documentation
NoteInfo..::.GroupId Property
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the group that created the note

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


IsGroup Property

[image]

OfficeClip API Documentation
NoteInfo..::.IsGroup Property
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

True if the note is visible to the group, false otherwise

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsGroup { get; set; }
Visual Basic (Declaration)
Public Property IsGroup As Boolean
Visual C++
public:
property bool IsGroup {
    bool get ();
    void set (bool value);
}

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


ModifiedByTimestamp Property

[image]

OfficeClip API Documentation
NoteInfo..::.ModifiedByTimestamp Property
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The timestamp when the note was last modified

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ModifiedByTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ModifiedByTimestamp As DateTime
Visual C++
public:
property DateTime ModifiedByTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


ModifiedByUserId Property

[image]

OfficeClip API Documentation
NoteInfo..::.ModifiedByUserId Property
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user who last modified the note

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ModifiedByUserId { get; set; }
Visual Basic (Declaration)
Public Property ModifiedByUserId As Integer
Visual C++
public:
property int ModifiedByUserId {
    int get ();
    void set (int value);
}

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


Note Property

[image]

OfficeClip API Documentation
NoteInfo..::.Note Property
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The note description

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Note { get; set; }
Visual Basic (Declaration)
Public Property Note As String
Visual C++
public:
property String^ Note {
    String^ get ();
    void set (String^ value);
}

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


NoteId Property

[image]

OfficeClip API Documentation
NoteInfo..::.NoteId Property
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the note

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NoteId { get; set; }
Visual Basic (Declaration)
Public Property NoteId As Integer
Visual C++
public:
property int NoteId {
    int get ();
    void set (int value);
}

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


ParentId Property

[image]

OfficeClip API Documentation
NoteInfo..::.ParentId Property
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The note parent object id. The value is -1 if the note does not have any parent

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ParentId { get; set; }
Visual Basic (Declaration)
Public Property ParentId As Integer
Visual C++
public:
property int ParentId {
    int get ();
    void set (int value);
}

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


ParentObjectType Property

[image]

OfficeClip API Documentation
NoteInfo..::.ParentObjectType Property
NoteInfo Class See Also

[This is preliminary documentation and is subject to change.]

The object type of the object that is parent to this note.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants..::.ObjectType ParentObjectType { get; set; }
Visual Basic (Declaration)
Public Property ParentObjectType As BusinessConstants..::.ObjectType
Visual C++
public:
property BusinessConstants..::.ObjectType ParentObjectType {
    BusinessConstants..::.ObjectType get ();
    void set (BusinessConstants..::.ObjectType value);
}

See Also

NoteInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


PhotoInfo Class

[image]

OfficeClip API Documentation
PhotoInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the information relating to the photos.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class PhotoInfo
Visual Basic (Declaration)
Public Class PhotoInfo
Visual C++
public ref class PhotoInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.OfficePortal..::.PhotoInfo

See Also

PhotoInfo Members
OfficeClip.BusinessLayer.OfficePortal Namespace


PhotoInfo Members

[image] [image]

OfficeClip API Documentation
PhotoInfo Members
PhotoInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PhotoInfo type exposes the following members.

Constructors

 | Name | Description
Public method | PhotoInfo | The constructor to create a photo information object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AlbumName | The name of the album that holds the photo.
Public property | Cdate | The created Timestamp for the photo.
Public property | CreatedByUserId | The identifier of the user who created the photo.
Public property | CreatedByUserName | The name of the user who created the photo.
Public property | FolderId | The identifier of the folder that holds the photo.
Public property | PhotoDesc | The Description of the photo.
Public property | PhotoFile | the filename of the photo.
Public property | PhotoName | The name of the photo.

See Also

PhotoInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


PhotoInfo Constructor

[image]

OfficeClip API Documentation
PhotoInfo Constructor
PhotoInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor to create a photo information object.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PhotoInfo(
    int photoId,
    string photoFile,
    int folderId,
    string photoName,
    string photoDesc,
    DateTime cdate,
    int createdByUserId,
    string createdByUserName,
    string albumName
)
Visual Basic (Declaration)
Public Sub New ( _
    photoId As Integer, _
    photoFile As String, _
    folderId As Integer, _
    photoName As String, _
    photoDesc As String, _
    cdate As DateTime, _
    createdByUserId As Integer, _
    createdByUserName As String, _
    albumName As String _
)
Visual C++
public:
PhotoInfo(
    int photoId,
    String^ photoFile,
    int folderId,
    String^ photoName,
    String^ photoDesc,
    DateTime cdate,
    int createdByUserId,
    String^ createdByUserName,
    String^ albumName
)

Parameters

photoId
Type: System..::.Int32
The system generated unique identifier for the photos.
photoFile
Type: System..::.String
The file name of the photo.
folderId
Type: System..::.Int32
The folder identifier which holds the photo.
photoName
Type: System..::.String
The user given name for the photo.
photoDesc
Type: System..::.String
The Description of the photo.
cdate
Type: System..::.DateTime
The created date for the photo.
createdByUserId
Type: System..::.Int32
The identifier of the user who created the photo.
createdByUserName
Type: System..::.String
the name of the user who created the photo.
albumName
Type: System..::.String
The name of the album that holds the photo.

See Also

PhotoInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


PhotoInfo Properties

[image] [image]

OfficeClip API Documentation
PhotoInfo Properties
PhotoInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PhotoInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AlbumName | The name of the album that holds the photo.
Public property | Cdate | The created Timestamp for the photo.
Public property | CreatedByUserId | The identifier of the user who created the photo.
Public property | CreatedByUserName | The name of the user who created the photo.
Public property | FolderId | The identifier of the folder that holds the photo.
Public property | PhotoDesc | The Description of the photo.
Public property | PhotoFile | the filename of the photo.
Public property | PhotoName | The name of the photo.

See Also

PhotoInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


AlbumName Property

[image]

OfficeClip API Documentation
PhotoInfo..::.AlbumName Property
PhotoInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the album that holds the photo.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AlbumName { get; }
Visual Basic (Declaration)
Public ReadOnly Property AlbumName As String
Visual C++
public:
property String^ AlbumName {
    String^ get ();
}

See Also

PhotoInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


Cdate Property

[image]

OfficeClip API Documentation
PhotoInfo..::.Cdate Property
PhotoInfo Class See Also

[This is preliminary documentation and is subject to change.]

The created Timestamp for the photo.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime Cdate { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cdate As DateTime
Visual C++
public:
property DateTime Cdate {
    DateTime get ();
}

See Also

PhotoInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


CreatedByUserId Property

[image]

OfficeClip API Documentation
PhotoInfo..::.CreatedByUserId Property
PhotoInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier of the user who created the photo.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedByUserId { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreatedByUserId As Integer
Visual C++
public:
property int CreatedByUserId {
    int get ();
}

See Also

PhotoInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


CreatedByUserName Property

[image]

OfficeClip API Documentation
PhotoInfo..::.CreatedByUserName Property
PhotoInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user who created the photo.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CreatedByUserName { get; }
Visual Basic (Declaration)
Public ReadOnly Property CreatedByUserName As String
Visual C++
public:
property String^ CreatedByUserName {
    String^ get ();
}

See Also

PhotoInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


FolderId Property

[image]

OfficeClip API Documentation
PhotoInfo..::.FolderId Property
PhotoInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier of the folder that holds the photo.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int FolderId { get; }
Visual Basic (Declaration)
Public ReadOnly Property FolderId As Integer
Visual C++
public:
property int FolderId {
    int get ();
}

See Also

PhotoInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


PhotoDesc Property

[image]

OfficeClip API Documentation
PhotoInfo..::.PhotoDesc Property
PhotoInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Description of the photo.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PhotoDesc { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhotoDesc As String
Visual C++
public:
property String^ PhotoDesc {
    String^ get ();
}

See Also

PhotoInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


PhotoFile Property

[image]

OfficeClip API Documentation
PhotoInfo..::.PhotoFile Property
PhotoInfo Class See Also

[This is preliminary documentation and is subject to change.]

the filename of the photo.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PhotoFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhotoFile As String
Visual C++
public:
property String^ PhotoFile {
    String^ get ();
}

See Also

PhotoInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


PhotoName Property

[image]

OfficeClip API Documentation
PhotoInfo..::.PhotoName Property
PhotoInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the photo.

Namespace: OfficeClip.BusinessLayer.OfficePortal
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PhotoName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PhotoName As String
Visual C++
public:
property String^ PhotoName {
    String^ get ();
}

See Also

PhotoInfo Class
OfficeClip.BusinessLayer.OfficePortal Namespace


OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the Office Portal Corporate menus (this is not used currently)

Classes

 | Class | Description
Public class | MenuCollectionInfo | Provides properties and methods to access the menu collection to create the corporate home page Menus.
Public class | MenuInfo | Represents the group/Organization's menu information.
Public class | MenuItemInfo | Provides methods and properties to access the information of a menu item.


MenuCollectionInfo Class

[image]

OfficeClip API Documentation
MenuCollectionInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides properties and methods to access the menu collection to create the corporate home page Menus.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class MenuCollectionInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MenuCollectionInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class MenuCollectionInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.OfficePortal.CorpMenu..::.MenuCollectionInfo

See Also

MenuCollectionInfo Members
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuCollectionInfo Members

[image] [image]

OfficeClip API Documentation
MenuCollectionInfo Members
MenuCollectionInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MenuCollectionInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MenuCollectionInfo | Overloaded.

Methods

 | Name | Description
Public method | add | Adds the menu item to the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMenuItem | Gets a menu item from the collection.
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an item from the collection
Public method | SetMenuItem | Sets a menu item ion the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Direction | The Direction
Public property | ListIndex | The list Index
Public property | Menus | A list of all the Menus contained in the collection.
Public property | Parent | The Parent of the menu item.

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuCollectionInfo Constructor

[image] [image]

OfficeClip API Documentation
MenuCollectionInfo Constructor
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MenuCollectionInfo(Int32) | Constructor that takes the Index of the list.
Public method | MenuCollectionInfo(Int32, Int32) | Constructor that takes the list Index and the Direction
Public method | MenuCollectionInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

MenuCollectionInfo Class
MenuCollectionInfo Members
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuCollectionInfo Constructor (Int32)

[image]

OfficeClip API Documentation
MenuCollectionInfo Constructor (Int32)
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that takes the Index of the list.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuCollectionInfo(
    int listIndex
)
Visual Basic (Declaration)
Public Sub New ( _
    listIndex As Integer _
)
Visual C++
public:
MenuCollectionInfo(
    int listIndex
)

Parameters

listIndex
Type: System..::.Int32
The Index of the list.

See Also

MenuCollectionInfo Class
MenuCollectionInfo Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuCollectionInfo Constructor (Int32, Int32)

[image]

OfficeClip API Documentation
MenuCollectionInfo Constructor (Int32, Int32)
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that takes the list Index and the Direction

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuCollectionInfo(
    int listIndex,
    int direction
)
Visual Basic (Declaration)
Public Sub New ( _
    listIndex As Integer, _
    direction As Integer _
)
Visual C++
public:
MenuCollectionInfo(
    int listIndex,
    int direction
)

Parameters

listIndex
Type: System..::.Int32
The list Index.
direction
Type: System..::.Int32
The Direction.

See Also

MenuCollectionInfo Class
MenuCollectionInfo Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuCollectionInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
MenuCollectionInfo Constructor (SerializationInfo, StreamingContext)
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuCollectionInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
MenuCollectionInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

MenuCollectionInfo Class
MenuCollectionInfo Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuCollectionInfo Methods

[image] [image]

OfficeClip API Documentation
MenuCollectionInfo Methods
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MenuCollectionInfo type exposes the following methods.

Methods

 | Name | Description
Public method | add | Adds the menu item to the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMenuItem | Gets a menu item from the collection.
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes an item from the collection
Public method | SetMenuItem | Sets a menu item ion the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


add Method

[image]

OfficeClip API Documentation
MenuCollectionInfo..::.add Method
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Adds the menu item to the collection.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void add(
    MenuItemInfo mii
)
Visual Basic (Declaration)
Public Sub add ( _
    mii As MenuItemInfo _
)
Visual C++
public:
void add(
    MenuItemInfo^ mii
)

Parameters

mii
Type: OfficeClip.BusinessLayer.OfficePortal.CorpMenu..::.MenuItemInfo

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


GetMenuItem Method

[image]

OfficeClip API Documentation
MenuCollectionInfo..::.GetMenuItem Method
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets a menu item from the collection.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuItemInfo GetMenuItem(
    int index
)
Visual Basic (Declaration)
Public Function GetMenuItem ( _
    index As Integer _
) As MenuItemInfo
Visual C++
public:
MenuItemInfo^ GetMenuItem(
    int index
)

Parameters

index
Type: System..::.Int32
The Index of the item that is required.

Return Value

The menu item information for the item.

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
MenuCollectionInfo..::.GetObjectData Method
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


Remove Method

[image]

OfficeClip API Documentation
MenuCollectionInfo..::.Remove Method
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Removes an item from the collection

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Remove(
    int index
)
Visual Basic (Declaration)
Public Sub Remove ( _
    index As Integer _
)
Visual C++
public:
void Remove(
    int index
)

Parameters

index
Type: System..::.Int32
The Index of the item that needs to be removed.

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


SetMenuItem Method

[image]

OfficeClip API Documentation
MenuCollectionInfo..::.SetMenuItem Method
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Sets a menu item ion the collection.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void SetMenuItem(
    MenuItemInfo mii
)
Visual Basic (Declaration)
Public Sub SetMenuItem ( _
    mii As MenuItemInfo _
)
Visual C++
public:
void SetMenuItem(
    MenuItemInfo^ mii
)

Parameters

mii
Type: OfficeClip.BusinessLayer.OfficePortal.CorpMenu..::.MenuItemInfo
The menu item information that is to be set.

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuCollectionInfo Properties

[image] [image]

OfficeClip API Documentation
MenuCollectionInfo Properties
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MenuCollectionInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Direction | The Direction
Public property | ListIndex | The list Index
Public property | Menus | A list of all the Menus contained in the collection.
Public property | Parent | The Parent of the menu item.

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


Direction Property

[image]

OfficeClip API Documentation
MenuCollectionInfo..::.Direction Property
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Direction

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As Integer
Visual C++
public:
property int Direction {
    int get ();
    void set (int value);
}

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


ListIndex Property

[image]

OfficeClip API Documentation
MenuCollectionInfo..::.ListIndex Property
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list Index

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ListIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ListIndex As Integer
Visual C++
public:
property int ListIndex {
    int get ();
}

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


Menus Property

[image]

OfficeClip API Documentation
MenuCollectionInfo..::.Menus Property
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

A list of all the Menus contained in the collection.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Menus { get; set; }
Visual Basic (Declaration)
Public Property Menus As ArrayList
Visual C++
public:
property ArrayList^ Menus {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


Parent Property

[image]

OfficeClip API Documentation
MenuCollectionInfo..::.Parent Property
MenuCollectionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Parent of the menu item.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuItemInfo Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As MenuItemInfo
Visual C++
public:
property MenuItemInfo^ Parent {
    MenuItemInfo^ get ();
    void set (MenuItemInfo^ value);
}

See Also

MenuCollectionInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuInfo Class

[image]

OfficeClip API Documentation
MenuInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Represents the group/Organization's menu information.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class MenuInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MenuInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class MenuInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.OfficePortal.CorpMenu..::.MenuInfo

See Also

MenuInfo Members
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuInfo Members

[image] [image]

OfficeClip API Documentation
MenuInfo Members
MenuInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MenuInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MenuInfo | Overloaded.

Methods

 | Name | Description
Public method | add | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMenuItem | Gets the menuitem represented by the MenuItemInfo object in a specific menulist and having a specific index.
Public method | GetMenuList | Gets the menulist represented by the MenuCollectionInfo object in a specific list index.
Public method | GetObjectData | Populates a SerializationInfo object with data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFileNameUsed | Checks whether a particular file name is used inside a menu definition.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Gets the xml document corresponding to information in the instantiated MenuInfo object.
Public method | Update | Update the Title and link information of a menuitem in a specific menulist with a specific index value.

Properties

 | Name | Description
Public property | IsEmpty | Gets whether the menu is totally empty i.e. without any menulist or menuitem.
Public property | MenuLists | The hashtable which stores all the menulists contained in the menu object.

See Also

MenuInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuInfo Constructor

[image] [image]

OfficeClip API Documentation
MenuInfo Constructor
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MenuInfo()()() | Initializes a new instance of MenuInfo class. By default always a menulist is created containing one menuitem which is represented by the MenuItemInfo class.
Public method | MenuInfo(String) | Initializes a new instance of MenuInfo class from a previously saved xml document. It behaves like a default constructor if the file does not exist or is empty.
Public method | MenuInfo(SerializationInfo, StreamingContext) | The constructor which implements the ISerializable interface.

See Also

MenuInfo Class
MenuInfo Members
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuInfo Constructor

[image]

OfficeClip API Documentation
MenuInfo Constructor
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of MenuInfo class. By default always a menulist is created containing one menuitem which is represented by the MenuItemInfo class.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MenuInfo()

See Also

MenuInfo Class
MenuInfo Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuInfo Constructor (String)

[image]

OfficeClip API Documentation
MenuInfo Constructor (String)
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of MenuInfo class from a previously saved xml document. It behaves like a default constructor if the file does not exist or is empty.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuInfo(
    string filePath
)
Visual Basic (Declaration)
Public Sub New ( _
    filePath As String _
)
Visual C++
public:
MenuInfo(
    String^ filePath
)

Parameters

filePath
Type: System..::.String
The fully qualified path of the xml document containing the menu details and mapping with the uploaded files.

Exceptions

Exception | Condition
OfficeClip.Utils..::.OCException | Raises an exception if there is an error in loading the xml document. This may happen when the xml file is manually edited and is rendered invalid.

See Also

MenuInfo Class
MenuInfo Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
MenuInfo Constructor (SerializationInfo, StreamingContext)
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor which implements the ISerializable interface.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
MenuInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object which contains the serialization info.
context
Type: System.Runtime.Serialization..::.StreamingContext
The source serialized stream from where the object values are read.

See Also

MenuInfo Class
MenuInfo Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuInfo Methods

[image] [image]

OfficeClip API Documentation
MenuInfo Methods
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MenuInfo type exposes the following methods.

Methods

 | Name | Description
Public method | add | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMenuItem | Gets the menuitem represented by the MenuItemInfo object in a specific menulist and having a specific index.
Public method | GetMenuList | Gets the menulist represented by the MenuCollectionInfo object in a specific list index.
Public method | GetObjectData | Populates a SerializationInfo object with data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFileNameUsed | Checks whether a particular file name is used inside a menu definition.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToXml | Gets the xml document corresponding to information in the instantiated MenuInfo object.
Public method | Update | Update the Title and link information of a menuitem in a specific menulist with a specific index value.

See Also

MenuInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


add Method

[image] [image]

OfficeClip API Documentation
MenuInfo..::.add Method
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | add(Int32, String, String, String) | Creates and adds a new MenuItemInfo object to the menulist with Index value of lstIndex.
Public method | add(MenuItemInfo, Int32, String, String, String) | Creates a new MenuItemInfo object and adds to a newly created menulist and establishes the link between the Parent MenuItemInfo object.

See Also

MenuInfo Class
MenuInfo Members
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


add Method (Int32, String, String, String)

[image]

OfficeClip API Documentation
MenuInfo..::.add Method (Int32, String, String, String)
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Creates and adds a new MenuItemInfo object to the menulist with Index value of lstIndex.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int add(
    int lstIndex,
    string screenName,
    string fileName,
    string url
)
Visual Basic (Declaration)
Public Function add ( _
    lstIndex As Integer, _
    screenName As String, _
    fileName As String, _
    url As String _
) As Integer
Visual C++
public:
int add(
    int lstIndex,
    String^ screenName,
    String^ fileName,
    String^ url
)

Parameters

lstIndex
Type: System..::.Int32
The Index of the menulist to which the new MenuItemInfo object has to be added.
screenName
Type: System..::.String
The Title of the new menuitem.
fileName
Type: System..::.String
The file name of the html file to be mapped to the new menuitem.
url
Type: System..::.String
The url link to be mapped to the new menuitem.

Return Value

The Index of the newly created menuitem.

See Also

MenuInfo Class
add Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


add Method (MenuItemInfo, Int32, String, String, String)

[image]

OfficeClip API Documentation
MenuInfo..::.add Method (MenuItemInfo, Int32, String, String, String)
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Creates a new MenuItemInfo object and adds to a newly created menulist and establishes the link between the Parent MenuItemInfo object.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int add(
    MenuItemInfo parentMenuItem,
    int currentListIndex,
    string screenName,
    string fileName,
    string url
)
Visual Basic (Declaration)
Public Function add ( _
    parentMenuItem As MenuItemInfo, _
    currentListIndex As Integer, _
    screenName As String, _
    fileName As String, _
    url As String _
) As Integer
Visual C++
public:
int add(
    MenuItemInfo^ parentMenuItem,
    int currentListIndex,
    String^ screenName,
    String^ fileName,
    String^ url
)

Parameters

parentMenuItem
Type: OfficeClip.BusinessLayer.OfficePortal.CorpMenu..::.MenuItemInfo
The Parent menuitem under which a new menulist is being added.
currentListIndex
Type: System..::.Int32
The list index of the menulist in which the Parent MenuItemInfo object belongs.
screenName
Type: System..::.String
The Title of the new menuitem to be created in the Child menulist
fileName
Type: System..::.String
The file name of the html file to be mapped to the new menuitem.
url
Type: System..::.String
The url link to be mapped to the new menuitem.

Return Value

The list index of the new Child menulist created.

See Also

MenuInfo Class
add Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


GetMenuItem Method

[image]

OfficeClip API Documentation
MenuInfo..::.GetMenuItem Method
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the menuitem represented by the MenuItemInfo object in a specific menulist and having a specific index.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuItemInfo GetMenuItem(
    int listIndex,
    int index
)
Visual Basic (Declaration)
Public Function GetMenuItem ( _
    listIndex As Integer, _
    index As Integer _
) As MenuItemInfo
Visual C++
public:
MenuItemInfo^ GetMenuItem(
    int listIndex,
    int index
)

Parameters

listIndex
Type: System..::.Int32
The index of the menulist in which the menuitem is contained.
index
Type: System..::.Int32
The index of the menuitem.

Return Value

The menuitem represented by the MenuItemInfo object.

See Also

MenuInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


GetMenuList Method

[image]

OfficeClip API Documentation
MenuInfo..::.GetMenuList Method
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the menulist represented by the MenuCollectionInfo object in a specific list index.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuCollectionInfo GetMenuList(
    int listIndex
)
Visual Basic (Declaration)
Public Function GetMenuList ( _
    listIndex As Integer _
) As MenuCollectionInfo
Visual C++
public:
MenuCollectionInfo^ GetMenuList(
    int listIndex
)

Parameters

listIndex
Type: System..::.Int32
The index of the menulist to be get.

Return Value

The menulist represented by the MenuCollectionInfo object.

See Also

MenuInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
MenuInfo..::.GetObjectData Method
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Populates a SerializationInfo object with data needed to serialize the target object.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

MenuInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


IsFileNameUsed Method

[image]

OfficeClip API Documentation
MenuInfo..::.IsFileNameUsed Method
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Checks whether a particular file name is used inside a menu definition.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsFileNameUsed(
    string fileName
)
Visual Basic (Declaration)
Public Function IsFileNameUsed ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool IsFileNameUsed(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
Name of the file which needs to be checked.

Return Value

Flag indicating whether a particular file name is used inside a menu definition or not.

See Also

MenuInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


Remove Method

[image] [image]

OfficeClip API Documentation
MenuInfo..::.Remove Method
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Remove(Int32) | Removes the menulist along with all the menuitems and Child menulists if any.
Public method | Remove(Int32, Int32) | Removes a specific menuitem with a value of Index in the menulist having the list Index lstIndex.

See Also

MenuInfo Class
MenuInfo Members
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


Remove Method (Int32)

[image]

OfficeClip API Documentation
MenuInfo..::.Remove Method (Int32)
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Removes the menulist along with all the menuitems and Child menulists if any.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Remove(
    int lstIndex
)
Visual Basic (Declaration)
Public Sub Remove ( _
    lstIndex As Integer _
)
Visual C++
public:
void Remove(
    int lstIndex
)

Parameters

lstIndex
Type: System..::.Int32
The Index of the menulist in the hashtable to be removed.

See Also

MenuInfo Class
Remove Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


Remove Method (Int32, Int32)

[image]

OfficeClip API Documentation
MenuInfo..::.Remove Method (Int32, Int32)
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Removes a specific menuitem with a value of Index in the menulist having the list Index lstIndex.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Remove(
    int lstIndex,
    int index
)
Visual Basic (Declaration)
Public Sub Remove ( _
    lstIndex As Integer, _
    index As Integer _
)
Visual C++
public:
void Remove(
    int lstIndex,
    int index
)

Parameters

lstIndex
Type: System..::.Int32
The Index of the menulist in which to search for the menuitem to be deleted.
index
Type: System..::.Int32
The Index of the menuitem to be removed from the list.

See Also

MenuInfo Class
Remove Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


ToXml Method

[image]

OfficeClip API Documentation
MenuInfo..::.ToXml Method
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the xml document corresponding to information in the instantiated MenuInfo object.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToXml()
Visual Basic (Declaration)
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

Returns the formatted string of the xml representation of the menu structure contained in the currently instantiated MenuInfo object.

See Also

MenuInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


Update Method

[image]

OfficeClip API Documentation
MenuInfo..::.Update Method
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Update the Title and link information of a menuitem in a specific menulist with a specific index value.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Update(
    int listIndex,
    int index,
    string screenName,
    string fileName,
    string url
)
Visual Basic (Declaration)
Public Sub Update ( _
    listIndex As Integer, _
    index As Integer, _
    screenName As String, _
    fileName As String, _
    url As String _
)
Visual C++
public:
void Update(
    int listIndex,
    int index,
    String^ screenName,
    String^ fileName,
    String^ url
)

Parameters

listIndex
Type: System..::.Int32
The index of the menulist in which to look for the item to be updated.
index
Type: System..::.Int32
The index of the menuitem whose information is to be updated.
screenName
Type: System..::.String
The new Title of the menuitem.
fileName
Type: System..::.String
The new file name to be mapped to the menuitem.
url
Type: System..::.String
The url link to the menuitem.

Remarks

Either fileName or url should have a value. One of them should be empty.

See Also

MenuInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuInfo Properties

[image] [image]

OfficeClip API Documentation
MenuInfo Properties
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MenuInfo type exposes the following properties.

Properties

 | Name | Description
Public property | IsEmpty | Gets whether the menu is totally empty i.e. without any menulist or menuitem.
Public property | MenuLists | The hashtable which stores all the menulists contained in the menu object.

See Also

MenuInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


IsEmpty Property

[image]

OfficeClip API Documentation
MenuInfo..::.IsEmpty Property
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets whether the menu is totally empty i.e. without any menulist or menuitem.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

MenuInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuLists Property

[image]

OfficeClip API Documentation
MenuInfo..::.MenuLists Property
MenuInfo Class See Also

[This is preliminary documentation and is subject to change.]

The hashtable which stores all the menulists contained in the menu object.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Hashtable MenuLists { get; set; }
Visual Basic (Declaration)
Public Property MenuLists As Hashtable
Visual C++
public:
property Hashtable^ MenuLists {
    Hashtable^ get ();
    void set (Hashtable^ value);
}

See Also

MenuInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuItemInfo Class

[image]

OfficeClip API Documentation
MenuItemInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the information of a menu item.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class MenuItemInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class MenuItemInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class MenuItemInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.OfficePortal.CorpMenu..::.MenuItemInfo

See Also

MenuItemInfo Members
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuItemInfo Members

[image] [image]

OfficeClip API Documentation
MenuItemInfo Members
MenuItemInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MenuItemInfo type exposes the following members.

Constructors

 | Name | Description
Public method | MenuItemInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlNode | GEts the xml node for the menu item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Child | The Child of the menu collection information.
Public property | ChildListIndex | The list index of the Child.
Public property | Current | The menu collection information.
Public property | CurrentListIndex | the current list index of the menu collection information.
Public property | FileName | the file name of the menu item. Valid if the menu item points to a file.
Public property | Index | The index of the menu item.
Public property | ScreenName | The screen name of the menu item.
Public property | url | The url that points from the menu item. Valid if the menu item is a url.

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuItemInfo Constructor

[image] [image]

OfficeClip API Documentation
MenuItemInfo Constructor
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MenuItemInfo()()() | The default constructor for the menu item information.
Public method | MenuItemInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.
Public method | MenuItemInfo(Int32, String, String, String, MenuCollectionInfo) | Constructor to create the menu item information object.

See Also

MenuItemInfo Class
MenuItemInfo Members
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuItemInfo Constructor

[image]

OfficeClip API Documentation
MenuItemInfo Constructor
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for the menu item information.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuItemInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MenuItemInfo()

See Also

MenuItemInfo Class
MenuItemInfo Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuItemInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
MenuItemInfo Constructor (SerializationInfo, StreamingContext)
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuItemInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
MenuItemInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

MenuItemInfo Class
MenuItemInfo Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuItemInfo Constructor (Int32, String, String, String, MenuCollectionInfo)

[image]

OfficeClip API Documentation
MenuItemInfo Constructor (Int32, String, String, String, MenuCollectionInfo)
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create the menu item information object.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuItemInfo(
    int index,
    string screenName,
    string fileName,
    string url,
    MenuCollectionInfo current
)
Visual Basic (Declaration)
Public Sub New ( _
    index As Integer, _
    screenName As String, _
    fileName As String, _
    url As String, _
    current As MenuCollectionInfo _
)
Visual C++
public:
MenuItemInfo(
    int index,
    String^ screenName,
    String^ fileName,
    String^ url,
    MenuCollectionInfo^ current
)

Parameters

index
Type: System..::.Int32
The Index of the menu item.
screenName
Type: System..::.String
The screen name of the menu item.
fileName
Type: System..::.String
The file name of the menu item. Valid if the menu item points to a file.
url
Type: System..::.String
the url of the menu item. Valid if the menu item points to a url.
current
Type: OfficeClip.BusinessLayer.OfficePortal.CorpMenu..::.MenuCollectionInfo
The current menu item collection.

See Also

MenuItemInfo Class
MenuItemInfo Overload
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuItemInfo Methods

[image] [image]

OfficeClip API Documentation
MenuItemInfo Methods
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MenuItemInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXmlNode | GEts the xml node for the menu item.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
MenuItemInfo..::.GetObjectData Method
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


GetXmlNode Method

[image]

OfficeClip API Documentation
MenuItemInfo..::.GetXmlNode Method
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

GEts the xml node for the menu item.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public XmlNode GetXmlNode(
    XmlDocument xmlDoc
)
Visual Basic (Declaration)
Public Function GetXmlNode ( _
    xmlDoc As XmlDocument _
) As XmlNode
Visual C++
public:
XmlNode^ GetXmlNode(
    XmlDocument^ xmlDoc
)

Parameters

xmlDoc
Type: System.Xml..::.XmlDocument
The xml document.

Return Value

The xml node.

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


MenuItemInfo Properties

[image] [image]

OfficeClip API Documentation
MenuItemInfo Properties
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The MenuItemInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Child | The Child of the menu collection information.
Public property | ChildListIndex | The list index of the Child.
Public property | Current | The menu collection information.
Public property | CurrentListIndex | the current list index of the menu collection information.
Public property | FileName | the file name of the menu item. Valid if the menu item points to a file.
Public property | Index | The index of the menu item.
Public property | ScreenName | The screen name of the menu item.
Public property | url | The url that points from the menu item. Valid if the menu item is a url.

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


Child Property

[image]

OfficeClip API Documentation
MenuItemInfo..::.Child Property
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Child of the menu collection information.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuCollectionInfo Child { get; set; }
Visual Basic (Declaration)
Public Property Child As MenuCollectionInfo
Visual C++
public:
property MenuCollectionInfo^ Child {
    MenuCollectionInfo^ get ();
    void set (MenuCollectionInfo^ value);
}

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


ChildListIndex Property

[image]

OfficeClip API Documentation
MenuItemInfo..::.ChildListIndex Property
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list index of the Child.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ChildListIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildListIndex As Integer
Visual C++
public:
property int ChildListIndex {
    int get ();
}

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


Current Property

[image]

OfficeClip API Documentation
MenuItemInfo..::.Current Property
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The menu collection information.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MenuCollectionInfo Current { get; }
Visual Basic (Declaration)
Public ReadOnly Property Current As MenuCollectionInfo
Visual C++
public:
property MenuCollectionInfo^ Current {
    MenuCollectionInfo^ get ();
}

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


CurrentListIndex Property

[image]

OfficeClip API Documentation
MenuItemInfo..::.CurrentListIndex Property
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

the current list index of the menu collection information.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CurrentListIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentListIndex As Integer
Visual C++
public:
property int CurrentListIndex {
    int get ();
}

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


FileName Property

[image]

OfficeClip API Documentation
MenuItemInfo..::.FileName Property
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

the file name of the menu item. Valid if the menu item points to a file.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FileName { get; set; }
Visual Basic (Declaration)
Public Property FileName As String
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


Index Property

[image]

OfficeClip API Documentation
MenuItemInfo..::.Index Property
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The index of the menu item.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
}

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


ScreenName Property

[image]

OfficeClip API Documentation
MenuItemInfo..::.ScreenName Property
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The screen name of the menu item.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ScreenName { get; set; }
Visual Basic (Declaration)
Public Property ScreenName As String
Visual C++
public:
property String^ ScreenName {
    String^ get ();
    void set (String^ value);
}

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


url Property

[image]

OfficeClip API Documentation
MenuItemInfo..::.url Property
MenuItemInfo Class See Also

[This is preliminary documentation and is subject to change.]

The url that points from the menu item. Valid if the menu item is a url.

Namespace: OfficeClip.BusinessLayer.OfficePortal.CorpMenu
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string url { get; set; }
Visual Basic (Declaration)
Public Property url As String
Visual C++
public:
property String^ url {
    String^ get ();
    void set (String^ value);
}

See Also

MenuItemInfo Class
OfficeClip.BusinessLayer.OfficePortal.CorpMenu Namespace


OfficeClip.BusinessLayer.Projects Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Projects Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the OfficeClip projects

Classes

 | Class | Description
Public class | ClientInfo | Provides methods and properties to access the client information for Time and Expenses application.
Public class | ProjectInfo | Provides methods and properties to access the Project information on the Time and Expense module.


ClientInfo Class

[image]

OfficeClip API Documentation
ClientInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the client information for Time and Expenses application.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ClientInfo
Visual Basic (Declaration)
Public Class ClientInfo
Visual C++
public ref class ClientInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Projects..::.ClientInfo

See Also

ClientInfo Members
OfficeClip.BusinessLayer.Projects Namespace


ClientInfo Members

[image] [image]

OfficeClip API Documentation
ClientInfo Members
ClientInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ClientInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ClientInfo | The default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The system generated unique account id.
Public property | City | The city part of the address
Public property | ContactPerson | The contact person for the client.
Public property | ContactPhone | The contact phone number for the client.
Public property | Country | The country for the address
Public property | EmailAddress | The email Address for the client.
Public property | GroupId | The unique group identifier of the group where this client belongs.
Public property | IsActive | Determins if the is client Active.
Public property | name | The actual name of the client.
Public property | Notes | The free form Notes that is used for the client.
Public property | Projects | A list of all the Projects that belongs to this client.
Public property | ScreenName | The name of the client that is displayed on the screen.
Public property | State | The state part of the address
Public property | StreetAddress1 | The first line of the street address
Public property | StreetAddress2 | The second line of the street address
Public property | Zip | The zip code for the address

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ClientInfo Constructor

[image]

OfficeClip API Documentation
ClientInfo Constructor
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ClientInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ClientInfo()

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ClientInfo Properties

[image] [image]

OfficeClip API Documentation
ClientInfo Properties
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ClientInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The system generated unique account id.
Public property | City | The city part of the address
Public property | ContactPerson | The contact person for the client.
Public property | ContactPhone | The contact phone number for the client.
Public property | Country | The country for the address
Public property | EmailAddress | The email Address for the client.
Public property | GroupId | The unique group identifier of the group where this client belongs.
Public property | IsActive | Determins if the is client Active.
Public property | name | The actual name of the client.
Public property | Notes | The free form Notes that is used for the client.
Public property | Projects | A list of all the Projects that belongs to this client.
Public property | ScreenName | The name of the client that is displayed on the screen.
Public property | State | The state part of the address
Public property | StreetAddress1 | The first line of the street address
Public property | StreetAddress2 | The second line of the street address
Public property | Zip | The zip code for the address

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


AccountId Property

[image]

OfficeClip API Documentation
ClientInfo..::.AccountId Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique account id.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AccountId { get; set; }
Visual Basic (Declaration)
Public Property AccountId As Integer
Visual C++
public:
property int AccountId {
    int get ();
    void set (int value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


City Property

[image]

OfficeClip API Documentation
ClientInfo..::.City Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The city part of the address

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string City { get; set; }
Visual Basic (Declaration)
Public Property City As String
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ContactPerson Property

[image]

OfficeClip API Documentation
ClientInfo..::.ContactPerson Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The contact person for the client.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ContactPerson { get; set; }
Visual Basic (Declaration)
Public Property ContactPerson As String
Visual C++
public:
property String^ ContactPerson {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ContactPhone Property

[image]

OfficeClip API Documentation
ClientInfo..::.ContactPhone Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The contact phone number for the client.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ContactPhone { get; set; }
Visual Basic (Declaration)
Public Property ContactPhone As String
Visual C++
public:
property String^ ContactPhone {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


Country Property

[image]

OfficeClip API Documentation
ClientInfo..::.Country Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The country for the address

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Country { get; set; }
Visual Basic (Declaration)
Public Property Country As String
Visual C++
public:
property String^ Country {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


EmailAddress Property

[image]

OfficeClip API Documentation
ClientInfo..::.EmailAddress Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Address for the client.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic (Declaration)
Public Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


GroupId Property

[image]

OfficeClip API Documentation
ClientInfo..::.GroupId Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique group identifier of the group where this client belongs.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


IsActive Property

[image]

OfficeClip API Documentation
ClientInfo..::.IsActive Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

Determins if the is client Active.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As String
Visual C++
public:
property String^ IsActive {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


name Property

[image]

OfficeClip API Documentation
ClientInfo..::.name Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The actual name of the client.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string name { get; set; }
Visual Basic (Declaration)
Public Property name As String
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


Notes Property

[image]

OfficeClip API Documentation
ClientInfo..::.Notes Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The free form Notes that is used for the client.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


Projects Property

[image]

OfficeClip API Documentation
ClientInfo..::.Projects Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

A list of all the Projects that belongs to this client.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Projects { get; set; }
Visual Basic (Declaration)
Public Property Projects As ArrayList
Visual C++
public:
property ArrayList^ Projects {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ScreenName Property

[image]

OfficeClip API Documentation
ClientInfo..::.ScreenName Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the client that is displayed on the screen.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ScreenName { get; set; }
Visual Basic (Declaration)
Public Property ScreenName As String
Visual C++
public:
property String^ ScreenName {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


State Property

[image]

OfficeClip API Documentation
ClientInfo..::.State Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The state part of the address

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string State { get; set; }
Visual Basic (Declaration)
Public Property State As String
Visual C++
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


StreetAddress1 Property

[image]

OfficeClip API Documentation
ClientInfo..::.StreetAddress1 Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first line of the street address

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string StreetAddress1 { get; set; }
Visual Basic (Declaration)
Public Property StreetAddress1 As String
Visual C++
public:
property String^ StreetAddress1 {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


StreetAddress2 Property

[image]

OfficeClip API Documentation
ClientInfo..::.StreetAddress2 Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second line of the street address

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string StreetAddress2 { get; set; }
Visual Basic (Declaration)
Public Property StreetAddress2 As String
Visual C++
public:
property String^ StreetAddress2 {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


Zip Property

[image]

OfficeClip API Documentation
ClientInfo..::.Zip Property
ClientInfo Class See Also

[This is preliminary documentation and is subject to change.]

The zip code for the address

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Zip { get; set; }
Visual Basic (Declaration)
Public Property Zip As String
Visual C++
public:
property String^ Zip {
    String^ get ();
    void set (String^ value);
}

See Also

ClientInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ProjectInfo Class

[image]

OfficeClip API Documentation
ProjectInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the Project information on the Time and Expense module.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ProjectInfo
Visual Basic (Declaration)
Public Class ProjectInfo
Visual C++
public ref class ProjectInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Projects..::.ProjectInfo

See Also

ProjectInfo Members
OfficeClip.BusinessLayer.Projects Namespace


ProjectInfo Members

[image] [image]

OfficeClip API Documentation
ProjectInfo Members
ProjectInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ProjectInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectInfo | The default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The account identifier for the Project.
Public property | AmountSpent | Amount spent on the Project.
Public property | BudgetedAmount | Budgeted Amount for the Project.
Public property | BudgetedHours | Budgeted hours for the Project.
Public property | ContactPerson | The contact person for the Project.
Public property | ContactPhone | The phone number of the contact person for the Project.
Public property | EndDate | The end date for the Project.
Public property | id | The id of the Project.
Public property | IsActive | Shows if the Project is active. Valid values are "Y" or "N".
Public property | name | The name of the Project.
Public property | Notes | Notes for the Project.
Public property | PercentCompleted | Percentage of the Project completed.
Public property | ProjectId | The system generated unique identifier for the Project.
Public property | ScreenName | The screen name for the Project.
Public property | StartDate | The start date for the Project.

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ProjectInfo Constructor

[image]

OfficeClip API Documentation
ProjectInfo Constructor
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ProjectInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectInfo()

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ProjectInfo Properties

[image] [image]

OfficeClip API Documentation
ProjectInfo Properties
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ProjectInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The account identifier for the Project.
Public property | AmountSpent | Amount spent on the Project.
Public property | BudgetedAmount | Budgeted Amount for the Project.
Public property | BudgetedHours | Budgeted hours for the Project.
Public property | ContactPerson | The contact person for the Project.
Public property | ContactPhone | The phone number of the contact person for the Project.
Public property | EndDate | The end date for the Project.
Public property | id | The id of the Project.
Public property | IsActive | Shows if the Project is active. Valid values are "Y" or "N".
Public property | name | The name of the Project.
Public property | Notes | Notes for the Project.
Public property | PercentCompleted | Percentage of the Project completed.
Public property | ProjectId | The system generated unique identifier for the Project.
Public property | ScreenName | The screen name for the Project.
Public property | StartDate | The start date for the Project.

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


AccountId Property

[image]

OfficeClip API Documentation
ProjectInfo..::.AccountId Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The account identifier for the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AccountId { get; set; }
Visual Basic (Declaration)
Public Property AccountId As Integer
Visual C++
public:
property int AccountId {
    int get ();
    void set (int value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


AmountSpent Property

[image]

OfficeClip API Documentation
ProjectInfo..::.AmountSpent Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

Amount spent on the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double AmountSpent { get; set; }
Visual Basic (Declaration)
Public Property AmountSpent As Double
Visual C++
public:
property double AmountSpent {
    double get ();
    void set (double value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


BudgetedAmount Property

[image]

OfficeClip API Documentation
ProjectInfo..::.BudgetedAmount Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

Budgeted Amount for the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double BudgetedAmount { get; set; }
Visual Basic (Declaration)
Public Property BudgetedAmount As Double
Visual C++
public:
property double BudgetedAmount {
    double get ();
    void set (double value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


BudgetedHours Property

[image]

OfficeClip API Documentation
ProjectInfo..::.BudgetedHours Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

Budgeted hours for the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double BudgetedHours { get; set; }
Visual Basic (Declaration)
Public Property BudgetedHours As Double
Visual C++
public:
property double BudgetedHours {
    double get ();
    void set (double value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ContactPerson Property

[image]

OfficeClip API Documentation
ProjectInfo..::.ContactPerson Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The contact person for the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ContactPerson { get; set; }
Visual Basic (Declaration)
Public Property ContactPerson As String
Visual C++
public:
property String^ ContactPerson {
    String^ get ();
    void set (String^ value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ContactPhone Property

[image]

OfficeClip API Documentation
ProjectInfo..::.ContactPhone Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The phone number of the contact person for the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ContactPhone { get; set; }
Visual Basic (Declaration)
Public Property ContactPhone As String
Visual C++
public:
property String^ ContactPhone {
    String^ get ();
    void set (String^ value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


EndDate Property

[image]

OfficeClip API Documentation
ProjectInfo..::.EndDate Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The end date for the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime EndDate { get; set; }
Visual Basic (Declaration)
Public Property EndDate As DateTime
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


id Property

[image]

OfficeClip API Documentation
ProjectInfo..::.id Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The id of the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string id { get; set; }
Visual Basic (Declaration)
Public Property id As String
Visual C++
public:
property String^ id {
    String^ get ();
    void set (String^ value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


IsActive Property

[image]

OfficeClip API Documentation
ProjectInfo..::.IsActive Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the Project is active. Valid values are "Y" or "N".

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As String
Visual C++
public:
property String^ IsActive {
    String^ get ();
    void set (String^ value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


name Property

[image]

OfficeClip API Documentation
ProjectInfo..::.name Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string name { get; set; }
Visual Basic (Declaration)
Public Property name As String
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


Notes Property

[image]

OfficeClip API Documentation
ProjectInfo..::.Notes Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

Notes for the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


PercentCompleted Property

[image]

OfficeClip API Documentation
ProjectInfo..::.PercentCompleted Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

Percentage of the Project completed.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double PercentCompleted { get; set; }
Visual Basic (Declaration)
Public Property PercentCompleted As Double
Visual C++
public:
property double PercentCompleted {
    double get ();
    void set (double value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ProjectId Property

[image]

OfficeClip API Documentation
ProjectInfo..::.ProjectId Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ProjectId { get; set; }
Visual Basic (Declaration)
Public Property ProjectId As Integer
Visual C++
public:
property int ProjectId {
    int get ();
    void set (int value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


ScreenName Property

[image]

OfficeClip API Documentation
ProjectInfo..::.ScreenName Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The screen name for the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ScreenName { get; set; }
Visual Basic (Declaration)
Public Property ScreenName As String
Visual C++
public:
property String^ ScreenName {
    String^ get ();
    void set (String^ value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


StartDate Property

[image]

OfficeClip API Documentation
ProjectInfo..::.StartDate Property
ProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The start date for the Project.

Namespace: OfficeClip.BusinessLayer.Projects
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic (Declaration)
Public Property StartDate As DateTime
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ProjectInfo Class
OfficeClip.BusinessLayer.Projects Namespace


OfficeClip.BusinessLayer.Reports Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Reports Namespace

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:OfficeClip.BusinessLayer.Reports]

Classes

 | Class | Description
Public class | GeneralObject | Object is serialized [ Stored in viewstate ]
Public class | ReportApplication | Object is serialized [ Stored in viewstate ]
Public class | ReportCategory | Object is serialized [ Stored in viewstate ]
Public class | ReportFilter | Object is serialized [ Stored in viewstate ]
Public class | ReportType | Object is serialized [ Stored in viewstate ]
Public class | ReportXml | ReportXml class


GeneralObject Class

[image]

OfficeClip API Documentation
GeneralObject Class
Members See Also

[This is preliminary documentation and is subject to change.]

Object is serialized [ Stored in viewstate ]

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class GeneralObject
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class GeneralObject
Visual C++
[SerializableAttribute]
public ref class GeneralObject

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Reports..::.GeneralObject

See Also

GeneralObject Members
OfficeClip.BusinessLayer.Reports Namespace


GeneralObject Members

[image] [image]

OfficeClip API Documentation
GeneralObject Members
GeneralObject Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The GeneralObject type exposes the following members.

Constructors

 | Name | Description
Public method | GeneralObject | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Category | Gets or sets category id
Public property | Description | Gets or sets report description
Public property | Footer | Gets or sets report footer
Public property | Header | Gets or sets report header
Public property | Name | Gets or sets report name
Public property | Type | Gets or sets type id

See Also

GeneralObject Class
OfficeClip.BusinessLayer.Reports Namespace


GeneralObject Constructor

[image] [image]

OfficeClip API Documentation
GeneralObject Constructor
GeneralObject Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GeneralObject()()() | Initializes a new instance of the GeneralObject class
Public method | GeneralObject(String, String, String, String, String, String) | Initializes a new instance of the GeneralObject class

See Also

GeneralObject Class
GeneralObject Members
OfficeClip.BusinessLayer.Reports Namespace


GeneralObject Constructor

[image]

OfficeClip API Documentation
GeneralObject Constructor
GeneralObject Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GeneralObject class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GeneralObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeneralObject()

See Also

GeneralObject Class
GeneralObject Overload
OfficeClip.BusinessLayer.Reports Namespace


GeneralObject Constructor (String, String, String, String, String, String)

[image]

OfficeClip API Documentation
GeneralObject Constructor (String, String, String, String, String, String)
GeneralObject Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the GeneralObject class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GeneralObject(
    string category,
    string type,
    string name,
    string description,
    string header,
    string footer
)
Visual Basic (Declaration)
Public Sub New ( _
    category As String, _
    type As String, _
    name As String, _
    description As String, _
    header As String, _
    footer As String _
)
Visual C++
public:
GeneralObject(
    String^ category,
    String^ type,
    String^ name,
    String^ description,
    String^ header,
    String^ footer
)

Parameters

category
Type: System..::.String
unique report category id
type
Type: System..::.String
unique report type id
name
Type: System..::.String
report name
description
Type: System..::.String
report description
header
Type: System..::.String
report header text
footer
Type: System..::.String
report footer text

See Also

GeneralObject Class
GeneralObject Overload
OfficeClip.BusinessLayer.Reports Namespace


GeneralObject Properties

[image] [image]

OfficeClip API Documentation
GeneralObject Properties
GeneralObject Class See Also

[This is preliminary documentation and is subject to change.]

The GeneralObject type exposes the following properties.

Properties

 | Name | Description
Public property | Category | Gets or sets category id
Public property | Description | Gets or sets report description
Public property | Footer | Gets or sets report footer
Public property | Header | Gets or sets report header
Public property | Name | Gets or sets report name
Public property | Type | Gets or sets type id

See Also

GeneralObject Class
OfficeClip.BusinessLayer.Reports Namespace


Category Property

[image]

OfficeClip API Documentation
GeneralObject..::.Category Property
GeneralObject Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets category id

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Category { get; set; }
Visual Basic (Declaration)
Public Property Category As String
Visual C++
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

See Also

GeneralObject Class
OfficeClip.BusinessLayer.Reports Namespace


Description Property

[image]

OfficeClip API Documentation
GeneralObject..::.Description Property
GeneralObject Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report description

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

GeneralObject Class
OfficeClip.BusinessLayer.Reports Namespace


Footer Property

[image]

OfficeClip API Documentation
GeneralObject..::.Footer Property
GeneralObject Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report footer

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Footer { get; set; }
Visual Basic (Declaration)
Public Property Footer As String
Visual C++
public:
property String^ Footer {
    String^ get ();
    void set (String^ value);
}

See Also

GeneralObject Class
OfficeClip.BusinessLayer.Reports Namespace


Header Property

[image]

OfficeClip API Documentation
GeneralObject..::.Header Property
GeneralObject Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report header

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Header { get; set; }
Visual Basic (Declaration)
Public Property Header As String
Visual C++
public:
property String^ Header {
    String^ get ();
    void set (String^ value);
}

See Also

GeneralObject Class
OfficeClip.BusinessLayer.Reports Namespace


Name Property

[image]

OfficeClip API Documentation
GeneralObject..::.Name Property
GeneralObject Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report name

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

GeneralObject Class
OfficeClip.BusinessLayer.Reports Namespace


Type Property

[image]

OfficeClip API Documentation
GeneralObject..::.Type Property
GeneralObject Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets type id

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

GeneralObject Class
OfficeClip.BusinessLayer.Reports Namespace


ReportApplication Class

[image]

OfficeClip API Documentation
ReportApplication Class
Members See Also

[This is preliminary documentation and is subject to change.]

Object is serialized [ Stored in viewstate ]

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ReportApplication
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ReportApplication
Visual C++
[SerializableAttribute]
public ref class ReportApplication

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Reports..::.ReportApplication

See Also

ReportApplication Members
OfficeClip.BusinessLayer.Reports Namespace


ReportApplication Members

[image] [image]

OfficeClip API Documentation
ReportApplication Members
ReportApplication Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ReportApplication type exposes the following members.

Constructors

 | Name | Description
Public method | ReportApplication | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | Gets or sets list of ReportCategory objects

See Also

ReportApplication Class
OfficeClip.BusinessLayer.Reports Namespace


ReportApplication Constructor

[image] [image]

OfficeClip API Documentation
ReportApplication Constructor
ReportApplication Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ReportApplication()()() | Initializes a new instance of the ReportApplication class
Public method | ReportApplication(List<(Of <(ReportCategory>)>)) | Initializes a new instance of the ReportApplication class

See Also

ReportApplication Class
ReportApplication Members
OfficeClip.BusinessLayer.Reports Namespace


ReportApplication Constructor

[image]

OfficeClip API Documentation
ReportApplication Constructor
ReportApplication Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ReportApplication class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReportApplication()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportApplication()

See Also

ReportApplication Class
ReportApplication Overload
OfficeClip.BusinessLayer.Reports Namespace


ReportApplication Constructor (List(ReportCategory))

[image]

OfficeClip API Documentation
ReportApplication Constructor (List<(Of <(ReportCategory>)>))
ReportApplication Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ReportApplication class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReportApplication(
    List<ReportCategory> categories
)
Visual Basic (Declaration)
Public Sub New ( _
    categories As List(Of ReportCategory) _
)
Visual C++
public:
ReportApplication(
    List<ReportCategory^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::.List<(Of <( ReportCategory >)>)
list of ReportCategory objects

See Also

ReportApplication Class
ReportApplication Overload
OfficeClip.BusinessLayer.Reports Namespace


ReportApplication Properties

[image] [image]

OfficeClip API Documentation
ReportApplication Properties
ReportApplication Class See Also

[This is preliminary documentation and is subject to change.]

The ReportApplication type exposes the following properties.

Properties

 | Name | Description
Public property | Categories | Gets or sets list of ReportCategory objects

See Also

ReportApplication Class
OfficeClip.BusinessLayer.Reports Namespace


Categories Property

[image]

OfficeClip API Documentation
ReportApplication..::.Categories Property
ReportApplication Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets list of ReportCategory objects

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<ReportCategory> Categories { get; set; }
Visual Basic (Declaration)
Public Property Categories As List(Of ReportCategory)
Visual C++
public:
property List<ReportCategory^>^ Categories {
    List<ReportCategory^>^ get ();
    void set (List<ReportCategory^>^ value);
}

See Also

ReportApplication Class
OfficeClip.BusinessLayer.Reports Namespace


ReportCategory Class

[image]

OfficeClip API Documentation
ReportCategory Class
Members See Also

[This is preliminary documentation and is subject to change.]

Object is serialized [ Stored in viewstate ]

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ReportCategory
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ReportCategory
Visual C++
[SerializableAttribute]
public ref class ReportCategory

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Reports..::.ReportCategory

See Also

ReportCategory Members
OfficeClip.BusinessLayer.Reports Namespace


ReportCategory Members

[image] [image]

OfficeClip API Documentation
ReportCategory Members
ReportCategory Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ReportCategory type exposes the following members.

Constructors

 | Name | Description
Public method | ReportCategory | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ReportCategoryName | Gets or sets category name
Public property | ReportTypeList | Gets or sets list of report types

See Also

ReportCategory Class
OfficeClip.BusinessLayer.Reports Namespace


ReportCategory Constructor

[image] [image]

OfficeClip API Documentation
ReportCategory Constructor
ReportCategory Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ReportCategory()()() | Initializes a new instance of the ReportCategory class
Public method | ReportCategory(String, List<(Of <(ReportType>)>)) | Initializes a new instance of the ReportCategory class

See Also

ReportCategory Class
ReportCategory Members
OfficeClip.BusinessLayer.Reports Namespace


ReportCategory Constructor

[image]

OfficeClip API Documentation
ReportCategory Constructor
ReportCategory Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ReportCategory class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReportCategory()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportCategory()

See Also

ReportCategory Class
ReportCategory Overload
OfficeClip.BusinessLayer.Reports Namespace


ReportCategory Constructor (String, List(ReportType))

[image]

OfficeClip API Documentation
ReportCategory Constructor (String, List<(Of <(ReportType>)>))
ReportCategory Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ReportCategory class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReportCategory(
    string name,
    List<ReportType> listRepType
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    listRepType As List(Of ReportType) _
)
Visual C++
public:
ReportCategory(
    String^ name,
    List<ReportType^>^ listRepType
)

Parameters

name
Type: System..::.String
category name
listRepType
Type: System.Collections.Generic..::.List<(Of <( ReportType >)>)
list of report type under this category

See Also

ReportCategory Class
ReportCategory Overload
OfficeClip.BusinessLayer.Reports Namespace


ReportCategory Properties

[image] [image]

OfficeClip API Documentation
ReportCategory Properties
ReportCategory Class See Also

[This is preliminary documentation and is subject to change.]

The ReportCategory type exposes the following properties.

Properties

 | Name | Description
Public property | ReportCategoryName | Gets or sets category name
Public property | ReportTypeList | Gets or sets list of report types

See Also

ReportCategory Class
OfficeClip.BusinessLayer.Reports Namespace


ReportCategoryName Property

[image]

OfficeClip API Documentation
ReportCategory..::.ReportCategoryName Property
ReportCategory Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets category name

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportCategoryName { get; set; }
Visual Basic (Declaration)
Public Property ReportCategoryName As String
Visual C++
public:
property String^ ReportCategoryName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportCategory Class
OfficeClip.BusinessLayer.Reports Namespace


ReportTypeList Property

[image]

OfficeClip API Documentation
ReportCategory..::.ReportTypeList Property
ReportCategory Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets list of report types

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<ReportType> ReportTypeList { get; set; }
Visual Basic (Declaration)
Public Property ReportTypeList As List(Of ReportType)
Visual C++
public:
property List<ReportType^>^ ReportTypeList {
    List<ReportType^>^ get ();
    void set (List<ReportType^>^ value);
}

See Also

ReportCategory Class
OfficeClip.BusinessLayer.Reports Namespace


ReportFilter Class

[image]

OfficeClip API Documentation
ReportFilter Class
Members See Also

[This is preliminary documentation and is subject to change.]

Object is serialized [ Stored in viewstate ]

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ReportFilter
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ReportFilter
Visual C++
[SerializableAttribute]
public ref class ReportFilter

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Reports..::.ReportFilter

See Also

ReportFilter Members
OfficeClip.BusinessLayer.Reports Namespace


ReportFilter Members

[image] [image]

OfficeClip API Documentation
ReportFilter Members
ReportFilter Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ReportFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ReportFilter | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Arguments | Gets or sets list of arguments for the filter
Public property | DefaultValues | Gets or sets the default values to be selected in the filter
Public property | FullyQualifiedName | Gets or sets fully qualified name of the filter
Public property | IsSelected | Gets or sets whether the filter is selected or not
Public property | ReportFilterLocation | Gets or sets report filter location
Public property | ReportFilterName | Gets or sets report filter name

See Also

ReportFilter Class
OfficeClip.BusinessLayer.Reports Namespace


ReportFilter Constructor

[image] [image]

OfficeClip API Documentation
ReportFilter Constructor
ReportFilter Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ReportFilter()()() | Initializes a new instance of the ReportFilter class
Public method | ReportFilter(String, String) | Initializes a new instance of the ReportFilter class

See Also

ReportFilter Class
ReportFilter Members
OfficeClip.BusinessLayer.Reports Namespace


ReportFilter Constructor

[image]

OfficeClip API Documentation
ReportFilter Constructor
ReportFilter Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ReportFilter class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReportFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportFilter()

See Also

ReportFilter Class
ReportFilter Overload
OfficeClip.BusinessLayer.Reports Namespace


ReportFilter Constructor (String, String)

[image]

OfficeClip API Documentation
ReportFilter Constructor (String, String)
ReportFilter Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ReportFilter class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReportFilter(
    string name,
    string filter_location
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    filter_location As String _
)
Visual C++
public:
ReportFilter(
    String^ name,
    String^ filter_location
)

Parameters

name
Type: System..::.String
filter name
filter_location
Type: System..::.String
filter location

See Also

ReportFilter Class
ReportFilter Overload
OfficeClip.BusinessLayer.Reports Namespace


ReportFilter Properties

[image] [image]

OfficeClip API Documentation
ReportFilter Properties
ReportFilter Class See Also

[This is preliminary documentation and is subject to change.]

The ReportFilter type exposes the following properties.

Properties

 | Name | Description
Public property | Arguments | Gets or sets list of arguments for the filter
Public property | DefaultValues | Gets or sets the default values to be selected in the filter
Public property | FullyQualifiedName | Gets or sets fully qualified name of the filter
Public property | IsSelected | Gets or sets whether the filter is selected or not
Public property | ReportFilterLocation | Gets or sets report filter location
Public property | ReportFilterName | Gets or sets report filter name

See Also

ReportFilter Class
OfficeClip.BusinessLayer.Reports Namespace


Arguments Property

[image]

OfficeClip API Documentation
ReportFilter..::.Arguments Property
ReportFilter Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets list of arguments for the filter

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string[] Arguments { get; set; }
Visual Basic (Declaration)
Public Property Arguments As String()
Visual C++
public:
property array<String^>^ Arguments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

ReportFilter Class
OfficeClip.BusinessLayer.Reports Namespace


DefaultValues Property

[image]

OfficeClip API Documentation
ReportFilter..::.DefaultValues Property
ReportFilter Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets the default values to be selected in the filter

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DefaultValues { get; set; }
Visual Basic (Declaration)
Public Property DefaultValues As String
Visual C++
public:
property String^ DefaultValues {
    String^ get ();
    void set (String^ value);
}

See Also

ReportFilter Class
OfficeClip.BusinessLayer.Reports Namespace


FullyQualifiedName Property

[image]

OfficeClip API Documentation
ReportFilter..::.FullyQualifiedName Property
ReportFilter Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets fully qualified name of the filter

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FullyQualifiedName { get; set; }
Visual Basic (Declaration)
Public Property FullyQualifiedName As String
Visual C++
public:
property String^ FullyQualifiedName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportFilter Class
OfficeClip.BusinessLayer.Reports Namespace


IsSelected Property

[image]

OfficeClip API Documentation
ReportFilter..::.IsSelected Property
ReportFilter Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets whether the filter is selected or not

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

ReportFilter Class
OfficeClip.BusinessLayer.Reports Namespace


ReportFilterLocation Property

[image]

OfficeClip API Documentation
ReportFilter..::.ReportFilterLocation Property
ReportFilter Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report filter location

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportFilterLocation { get; set; }
Visual Basic (Declaration)
Public Property ReportFilterLocation As String
Visual C++
public:
property String^ ReportFilterLocation {
    String^ get ();
    void set (String^ value);
}

See Also

ReportFilter Class
OfficeClip.BusinessLayer.Reports Namespace


ReportFilterName Property

[image]

OfficeClip API Documentation
ReportFilter..::.ReportFilterName Property
ReportFilter Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report filter name

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportFilterName { get; set; }
Visual Basic (Declaration)
Public Property ReportFilterName As String
Visual C++
public:
property String^ ReportFilterName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportFilter Class
OfficeClip.BusinessLayer.Reports Namespace


ReportType Class

[image]

OfficeClip API Documentation
ReportType Class
Members See Also

[This is preliminary documentation and is subject to change.]

Object is serialized [ Stored in viewstate ]

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ReportType
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ReportType
Visual C++
[SerializableAttribute]
public ref class ReportType

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Reports..::.ReportType

See Also

ReportType Members
OfficeClip.BusinessLayer.Reports Namespace


ReportType Members

[image] [image]

OfficeClip API Documentation
ReportType Members
ReportType Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ReportType type exposes the following members.

Constructors

 | Name | Description
Public method | ReportType | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ReportFilterList | Gets or sets avilable filter list for the report type
Public property | ReportName | Gets or sets report name
Public property | ReportTypeDesc | Gets or sets report report type description
Public property | ReportTypeFooter | Gets or sets report type footer text
Public property | ReportTypeHeader | Gets or sets report type header text
Public property | ReportTypeName | Gets or sets report type
Public property | ReportTypeRDLC_Loc | Gets or sets report type's rdlc file location

See Also

ReportType Class
OfficeClip.BusinessLayer.Reports Namespace


ReportType Constructor

[image] [image]

OfficeClip API Documentation
ReportType Constructor
ReportType Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ReportType()()() | Initializes a new instance of the ReportType class
Public method | ReportType(String, String, String, String, String, List<(Of <(ReportFilter>)>)) |

See Also

ReportType Class
ReportType Members
OfficeClip.BusinessLayer.Reports Namespace


ReportType Constructor

[image]

OfficeClip API Documentation
ReportType Constructor
ReportType Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ReportType class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReportType()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportType()

See Also

ReportType Class
ReportType Overload
OfficeClip.BusinessLayer.Reports Namespace


ReportType Constructor (String, String, String, String, String, List(ReportFilter))

[image]

OfficeClip API Documentation
ReportType Constructor (String, String, String, String, String, List<(Of <(ReportFilter>)>))
ReportType Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReportType(
    string name,
    string description,
    string header,
    string footer,
    string rdlc_location,
    List<ReportFilter> listRepFilter
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    description As String, _
    header As String, _
    footer As String, _
    rdlc_location As String, _
    listRepFilter As List(Of ReportFilter) _
)
Visual C++
public:
ReportType(
    String^ name,
    String^ description,
    String^ header,
    String^ footer,
    String^ rdlc_location,
    List<ReportFilter^>^ listRepFilter
)

Parameters

name
Type: System..::.String
description
Type: System..::.String
header
Type: System..::.String
footer
Type: System..::.String
rdlc_location
Type: System..::.String
listRepFilter
Type: System.Collections.Generic..::.List<(Of <( ReportFilter >)>)

See Also

ReportType Class
ReportType Overload
OfficeClip.BusinessLayer.Reports Namespace


ReportType Properties

[image] [image]

OfficeClip API Documentation
ReportType Properties
ReportType Class See Also

[This is preliminary documentation and is subject to change.]

The ReportType type exposes the following properties.

Properties

 | Name | Description
Public property | ReportFilterList | Gets or sets avilable filter list for the report type
Public property | ReportName | Gets or sets report name
Public property | ReportTypeDesc | Gets or sets report report type description
Public property | ReportTypeFooter | Gets or sets report type footer text
Public property | ReportTypeHeader | Gets or sets report type header text
Public property | ReportTypeName | Gets or sets report type
Public property | ReportTypeRDLC_Loc | Gets or sets report type's rdlc file location

See Also

ReportType Class
OfficeClip.BusinessLayer.Reports Namespace


ReportFilterList Property

[image]

OfficeClip API Documentation
ReportType..::.ReportFilterList Property
ReportType Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets avilable filter list for the report type

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<ReportFilter> ReportFilterList { get; set; }
Visual Basic (Declaration)
Public Property ReportFilterList As List(Of ReportFilter)
Visual C++
public:
property List<ReportFilter^>^ ReportFilterList {
    List<ReportFilter^>^ get ();
    void set (List<ReportFilter^>^ value);
}

See Also

ReportType Class
OfficeClip.BusinessLayer.Reports Namespace


ReportName Property

[image]

OfficeClip API Documentation
ReportType..::.ReportName Property
ReportType Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report name

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportName { get; set; }
Visual Basic (Declaration)
Public Property ReportName As String
Visual C++
public:
property String^ ReportName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportType Class
OfficeClip.BusinessLayer.Reports Namespace


ReportTypeDesc Property

[image]

OfficeClip API Documentation
ReportType..::.ReportTypeDesc Property
ReportType Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report report type description

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportTypeDesc { get; set; }
Visual Basic (Declaration)
Public Property ReportTypeDesc As String
Visual C++
public:
property String^ ReportTypeDesc {
    String^ get ();
    void set (String^ value);
}

See Also

ReportType Class
OfficeClip.BusinessLayer.Reports Namespace


ReportTypeFooter Property

[image]

OfficeClip API Documentation
ReportType..::.ReportTypeFooter Property
ReportType Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report type footer text

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportTypeFooter { get; set; }
Visual Basic (Declaration)
Public Property ReportTypeFooter As String
Visual C++
public:
property String^ ReportTypeFooter {
    String^ get ();
    void set (String^ value);
}

See Also

ReportType Class
OfficeClip.BusinessLayer.Reports Namespace


ReportTypeHeader Property

[image]

OfficeClip API Documentation
ReportType..::.ReportTypeHeader Property
ReportType Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report type header text

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportTypeHeader { get; set; }
Visual Basic (Declaration)
Public Property ReportTypeHeader As String
Visual C++
public:
property String^ ReportTypeHeader {
    String^ get ();
    void set (String^ value);
}

See Also

ReportType Class
OfficeClip.BusinessLayer.Reports Namespace


ReportTypeName Property

[image]

OfficeClip API Documentation
ReportType..::.ReportTypeName Property
ReportType Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report type

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportTypeName { get; set; }
Visual Basic (Declaration)
Public Property ReportTypeName As String
Visual C++
public:
property String^ ReportTypeName {
    String^ get ();
    void set (String^ value);
}

See Also

ReportType Class
OfficeClip.BusinessLayer.Reports Namespace


ReportTypeRDLC_Loc Property

[image]

OfficeClip API Documentation
ReportType..::.ReportTypeRDLC_Loc Property
ReportType Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets report type's rdlc file location

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportTypeRDLC_Loc { get; set; }
Visual Basic (Declaration)
Public Property ReportTypeRDLC_Loc As String
Visual C++
public:
property String^ ReportTypeRDLC_Loc {
    String^ get ();
    void set (String^ value);
}

See Also

ReportType Class
OfficeClip.BusinessLayer.Reports Namespace


ReportXml Class

[image]

OfficeClip API Documentation
ReportXml Class
Members See Also

[This is preliminary documentation and is subject to change.]

ReportXml class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ReportXml
Visual Basic (Declaration)
Public Class ReportXml
Visual C++
public ref class ReportXml

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Reports..::.ReportXml

See Also

ReportXml Members
OfficeClip.BusinessLayer.Reports Namespace


ReportXml Members

[image] [image]

OfficeClip API Documentation
ReportXml Members
ReportXml Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ReportXml type exposes the following members.

Constructors

 | Name | Description
Public method | ReportXml | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayCategoriesList | returns a list of categories to be displayed in report wizard for user selection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectsFromXML | Returns report application objects present in "ReportBase.xml [list of categories ]"
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ReportXmlFile | Gets or sets ReportXmlFile

See Also

ReportXml Class
OfficeClip.BusinessLayer.Reports Namespace


ReportXml Constructor

[image] [image]

OfficeClip API Documentation
ReportXml Constructor
ReportXml Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ReportXml()()() | Initializes a new instance of the ReportXml class
Public method | ReportXml(String) | Initializes a new instance of the ReportXml class

See Also

ReportXml Class
ReportXml Members
OfficeClip.BusinessLayer.Reports Namespace


ReportXml Constructor

[image]

OfficeClip API Documentation
ReportXml Constructor
ReportXml Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ReportXml class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReportXml()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportXml()

See Also

ReportXml Class
ReportXml Overload
OfficeClip.BusinessLayer.Reports Namespace


ReportXml Constructor (String)

[image]

OfficeClip API Documentation
ReportXml Constructor (String)
ReportXml Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the ReportXml class

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReportXml(
    string file
)
Visual Basic (Declaration)
Public Sub New ( _
    file As String _
)
Visual C++
public:
ReportXml(
    String^ file
)

Parameters

file
Type: System..::.String
file to be read

See Also

ReportXml Class
ReportXml Overload
OfficeClip.BusinessLayer.Reports Namespace


ReportXml Methods

[image] [image]

OfficeClip API Documentation
ReportXml Methods
ReportXml Class See Also

[This is preliminary documentation and is subject to change.]

The ReportXml type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDisplayCategoriesList | returns a list of categories to be displayed in report wizard for user selection.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectsFromXML | Returns report application objects present in "ReportBase.xml [list of categories ]"
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportXml Class
OfficeClip.BusinessLayer.Reports Namespace


GetDisplayCategoriesList Method

[image]

OfficeClip API Documentation
ReportXml..::.GetDisplayCategoriesList Method
ReportXml Class See Also

[This is preliminary documentation and is subject to change.]

returns a list of categories to be displayed in report wizard for user selection.

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<string> GetDisplayCategoriesList(
    int applicationID
)
Visual Basic (Declaration)
Public Function GetDisplayCategoriesList ( _
    applicationID As Integer _
) As List(Of String)
Visual C++
public:
List<String^>^ GetDisplayCategoriesList(
    int applicationID
)

Parameters

applicationID
Type: System..::.Int32
unique application id

Return Value

list of categories to be displayed

See Also

ReportXml Class
OfficeClip.BusinessLayer.Reports Namespace


GetObjectsFromXML Method

[image]

OfficeClip API Documentation
ReportXml..::.GetObjectsFromXML Method
ReportXml Class See Also

[This is preliminary documentation and is subject to change.]

Returns report application objects present in "ReportBase.xml [list of categories ]"

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReportApplication GetObjectsFromXML(
    int appId
)
Visual Basic (Declaration)
Public Function GetObjectsFromXML ( _
    appId As Integer _
) As ReportApplication
Visual C++
public:
ReportApplication^ GetObjectsFromXML(
    int appId
)

Parameters

appId
Type: System..::.Int32
unique application id

Return Value

ReportApplication object [list of categories]

See Also

ReportXml Class
OfficeClip.BusinessLayer.Reports Namespace


ReportXml Properties

[image] [image]

OfficeClip API Documentation
ReportXml Properties
ReportXml Class See Also

[This is preliminary documentation and is subject to change.]

The ReportXml type exposes the following properties.

Properties

 | Name | Description
Public property | ReportXmlFile | Gets or sets ReportXmlFile

See Also

ReportXml Class
OfficeClip.BusinessLayer.Reports Namespace


ReportXmlFile Property

[image]

OfficeClip API Documentation
ReportXml..::.ReportXmlFile Property
ReportXml Class See Also

[This is preliminary documentation and is subject to change.]

Gets or sets ReportXmlFile

Namespace: OfficeClip.BusinessLayer.Reports
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReportXmlFile { get; set; }
Visual Basic (Declaration)
Public Property ReportXmlFile As String
Visual C++
public:
property String^ ReportXmlFile {
    String^ get ();
    void set (String^ value);
}

See Also

ReportXml Class
OfficeClip.BusinessLayer.Reports Namespace


OfficeClip.BusinessLayer.Rules Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Rules Namespace

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:OfficeClip.BusinessLayer.Rules]

Classes

 | Class | Description
Public class | ActionInfo |
Public class | ConditionInfo |
Public class | NotificationInfo |
Public class | RulesInfo |

Enumerations

 | Enumeration | Description
Public enumeration | OperatorFlag |


ActionInfo Class

[image]

OfficeClip API Documentation
ActionInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ActionInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ActionInfo
Visual C++
[SerializableAttribute]
public ref class ActionInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Rules..::.ActionInfo

See Also

ActionInfo Members
OfficeClip.BusinessLayer.Rules Namespace


ActionInfo Members

[image] [image]

OfficeClip API Documentation
ActionInfo Members
ActionInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ActionInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ActionInfo |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActionName |
Public property | ArgumentList |
Public property | AssemblyName |
Public property | Description |

See Also

ActionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ActionInfo Constructor

[image]

OfficeClip API Documentation
ActionInfo Constructor
ActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ActionInfo(
    string actionName,
    string desc,
    string arg1,
    string arg2,
    string arg3,
    string arg4,
    string assemblyName
)
Visual Basic (Declaration)
Public Sub New ( _
    actionName As String, _
    desc As String, _
    arg1 As String, _
    arg2 As String, _
    arg3 As String, _
    arg4 As String, _
    assemblyName As String _
)
Visual C++
public:
ActionInfo(
    String^ actionName,
    String^ desc,
    String^ arg1,
    String^ arg2,
    String^ arg3,
    String^ arg4,
    String^ assemblyName
)

Parameters

actionName
Type: System..::.String
desc
Type: System..::.String
arg1
Type: System..::.String
arg2
Type: System..::.String
arg3
Type: System..::.String
arg4
Type: System..::.String
assemblyName
Type: System..::.String

See Also

ActionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ActionInfo Properties

[image] [image]

OfficeClip API Documentation
ActionInfo Properties
ActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ActionInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ActionName |
Public property | ArgumentList |
Public property | AssemblyName |
Public property | Description |

See Also

ActionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ActionName Property

[image]

OfficeClip API Documentation
ActionInfo..::.ActionName Property
ActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ActionName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ActionName As String
Visual C++
public:
property String^ ActionName {
    String^ get ();
}

See Also

ActionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ArgumentList Property

[image]

OfficeClip API Documentation
ActionInfo..::.ArgumentList Property
ActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string[] ArgumentList { get; }
Visual Basic (Declaration)
Public ReadOnly Property ArgumentList As String()
Visual C++
public:
property array<String^>^ ArgumentList {
    array<String^>^ get ();
}

See Also

ActionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


AssemblyName Property

[image]

OfficeClip API Documentation
ActionInfo..::.AssemblyName Property
ActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AssemblyName { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssemblyName As String
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
}

See Also

ActionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


Description Property

[image]

OfficeClip API Documentation
ActionInfo..::.Description Property
ActionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

ActionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ConditionInfo Class

[image]

OfficeClip API Documentation
ConditionInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ConditionInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ConditionInfo
Visual C++
[SerializableAttribute]
public ref class ConditionInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Rules..::.ConditionInfo

See Also

ConditionInfo Members
OfficeClip.BusinessLayer.Rules Namespace


ConditionInfo Members

[image] [image]

OfficeClip API Documentation
ConditionInfo Members
ConditionInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ConditionInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ConditionInfo |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArgumentList |
Public property | AssemblyName |
Public property | ConditionName |
Public property | ConditionType |
Public property | Description |
Public property | OperatorFlag |
Public property | OrderIndex |
Public property | TriggerName |

See Also

ConditionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ConditionInfo Constructor

[image]

OfficeClip API Documentation
ConditionInfo Constructor
ConditionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ConditionInfo(
    string conditionName,
    string assemblyName,
    string desc,
    string arg1,
    string arg2,
    string arg3,
    string arg4,
    OperatorFlag op,
    int index,
    string triggerName,
    string conditionType
)
Visual Basic (Declaration)
Public Sub New ( _
    conditionName As String, _
    assemblyName As String, _
    desc As String, _
    arg1 As String, _
    arg2 As String, _
    arg3 As String, _
    arg4 As String, _
    op As OperatorFlag, _
    index As Integer, _
    triggerName As String, _
    conditionType As String _
)
Visual C++
public:
ConditionInfo(
    String^ conditionName,
    String^ assemblyName,
    String^ desc,
    String^ arg1,
    String^ arg2,
    String^ arg3,
    String^ arg4,
    OperatorFlag op,
    int index,
    String^ triggerName,
    String^ conditionType
)

Parameters

conditionName
Type: System..::.String
assemblyName
Type: System..::.String
desc
Type: System..::.String
arg1
Type: System..::.String
arg2
Type: System..::.String
arg3
Type: System..::.String
arg4
Type: System..::.String
op
Type: OfficeClip.BusinessLayer.Rules..::.OperatorFlag
index
Type: System..::.Int32
triggerName
Type: System..::.String
conditionType
Type: System..::.String

See Also

ConditionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ConditionInfo Properties

[image] [image]

OfficeClip API Documentation
ConditionInfo Properties
ConditionInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ConditionInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ArgumentList |
Public property | AssemblyName |
Public property | ConditionName |
Public property | ConditionType |
Public property | Description |
Public property | OperatorFlag |
Public property | OrderIndex |
Public property | TriggerName |

See Also

ConditionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ArgumentList Property

[image]

OfficeClip API Documentation
ConditionInfo..::.ArgumentList Property
ConditionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string[] ArgumentList { get; }
Visual Basic (Declaration)
Public ReadOnly Property ArgumentList As String()
Visual C++
public:
property array<String^>^ ArgumentList {
    array<String^>^ get ();
}

See Also

ConditionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


AssemblyName Property

[image]

OfficeClip API Documentation
ConditionInfo..::.AssemblyName Property
ConditionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AssemblyName { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssemblyName As String
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
}

See Also

ConditionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ConditionName Property

[image]

OfficeClip API Documentation
ConditionInfo..::.ConditionName Property
ConditionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ConditionName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConditionName As String
Visual C++
public:
property String^ ConditionName {
    String^ get ();
}

See Also

ConditionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ConditionType Property

[image]

OfficeClip API Documentation
ConditionInfo..::.ConditionType Property
ConditionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ConditionType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConditionType As String
Visual C++
public:
property String^ ConditionType {
    String^ get ();
}

See Also

ConditionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


Description Property

[image]

OfficeClip API Documentation
ConditionInfo..::.Description Property
ConditionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

ConditionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


OperatorFlag Property

[image]

OfficeClip API Documentation
ConditionInfo..::.OperatorFlag Property
ConditionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OperatorFlag OperatorFlag { get; }
Visual Basic (Declaration)
Public ReadOnly Property OperatorFlag As OperatorFlag
Visual C++
public:
property OperatorFlag OperatorFlag {
    OperatorFlag get ();
}

See Also

ConditionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


OrderIndex Property

[image]

OfficeClip API Documentation
ConditionInfo..::.OrderIndex Property
ConditionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int OrderIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property OrderIndex As Integer
Visual C++
public:
property int OrderIndex {
    int get ();
}

See Also

ConditionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


TriggerName Property

[image]

OfficeClip API Documentation
ConditionInfo..::.TriggerName Property
ConditionInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TriggerName { get; }
Visual Basic (Declaration)
Public ReadOnly Property TriggerName As String
Visual C++
public:
property String^ TriggerName {
    String^ get ();
}

See Also

ConditionInfo Class
OfficeClip.BusinessLayer.Rules Namespace


NotificationInfo Class

[image]

OfficeClip API Documentation
NotificationInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class NotificationInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class NotificationInfo
Visual C++
[SerializableAttribute]
public ref class NotificationInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Rules..::.NotificationInfo

See Also

NotificationInfo Members
OfficeClip.BusinessLayer.Rules Namespace


NotificationInfo Members

[image] [image]

OfficeClip API Documentation
NotificationInfo Members
NotificationInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The NotificationInfo type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationInfo |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArgumentList |
Public property | Description |
Public property | NotificationName |

See Also

NotificationInfo Class
OfficeClip.BusinessLayer.Rules Namespace


NotificationInfo Constructor

[image]

OfficeClip API Documentation
NotificationInfo Constructor
NotificationInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NotificationInfo(
    string notificationName,
    string desc,
    string arg1,
    string arg2,
    string arg3,
    string arg4
)
Visual Basic (Declaration)
Public Sub New ( _
    notificationName As String, _
    desc As String, _
    arg1 As String, _
    arg2 As String, _
    arg3 As String, _
    arg4 As String _
)
Visual C++
public:
NotificationInfo(
    String^ notificationName,
    String^ desc,
    String^ arg1,
    String^ arg2,
    String^ arg3,
    String^ arg4
)

Parameters

notificationName
Type: System..::.String
desc
Type: System..::.String
arg1
Type: System..::.String
arg2
Type: System..::.String
arg3
Type: System..::.String
arg4
Type: System..::.String

See Also

NotificationInfo Class
OfficeClip.BusinessLayer.Rules Namespace


NotificationInfo Properties

[image] [image]

OfficeClip API Documentation
NotificationInfo Properties
NotificationInfo Class See Also

[This is preliminary documentation and is subject to change.]

The NotificationInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ArgumentList |
Public property | Description |
Public property | NotificationName |

See Also

NotificationInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ArgumentList Property

[image]

OfficeClip API Documentation
NotificationInfo..::.ArgumentList Property
NotificationInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string[] ArgumentList { get; }
Visual Basic (Declaration)
Public ReadOnly Property ArgumentList As String()
Visual C++
public:
property array<String^>^ ArgumentList {
    array<String^>^ get ();
}

See Also

NotificationInfo Class
OfficeClip.BusinessLayer.Rules Namespace


Description Property

[image]

OfficeClip API Documentation
NotificationInfo..::.Description Property
NotificationInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

NotificationInfo Class
OfficeClip.BusinessLayer.Rules Namespace


NotificationName Property

[image]

OfficeClip API Documentation
NotificationInfo..::.NotificationName Property
NotificationInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string NotificationName { get; }
Visual Basic (Declaration)
Public ReadOnly Property NotificationName As String
Visual C++
public:
property String^ NotificationName {
    String^ get ();
}

See Also

NotificationInfo Class
OfficeClip.BusinessLayer.Rules Namespace


OperatorFlag Enumeration

[image]

OfficeClip API Documentation
OperatorFlag Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum OperatorFlag
Visual Basic (Declaration)
Public Enumeration OperatorFlag
Visual C++
public enum class OperatorFlag

Members

Member name | Description
AND |
OR |
NONE |

See Also

OfficeClip.BusinessLayer.Rules Namespace


RulesInfo Class

[image]

OfficeClip API Documentation
RulesInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class RulesInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class RulesInfo
Visual C++
[SerializableAttribute]
public ref class RulesInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Rules..::.RulesInfo

See Also

RulesInfo Members
OfficeClip.BusinessLayer.Rules Namespace


RulesInfo Members

[image] [image]

OfficeClip API Documentation
RulesInfo Members
RulesInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RulesInfo type exposes the following members.

Constructors

 | Name | Description
Public method | RulesInfo |

Methods

 | Name | Description
Public method | AddAction |
Public method | AddCondition |
Public method | AddNotification |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActionInfoList |
Public method | GetActionsString |
Public method | GetConditionInfoList |
Public method | GetConditionsString |
Public method | GetFrequencyString |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNotificationInfoList |
Public method | GetNotificationsString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAction |
Public method | RemoveCondition |
Public method | RemoveNotification |
Public method | ToString | (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | AppID |
Public property | GroupID |
Public property | IsEnabled |
Public property | Name |
Public property | RuleGroupID |
Public property | SecondaryId |
Public property | TimeTriggerFreq |
Public property | UserID |

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


RulesInfo Constructor

[image]

OfficeClip API Documentation
RulesInfo Constructor
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RulesInfo(
    int userid,
    int groupId,
    int appId,
    string ruleGroupId,
    int secondaryId
)
Visual Basic (Declaration)
Public Sub New ( _
    userid As Integer, _
    groupId As Integer, _
    appId As Integer, _
    ruleGroupId As String, _
    secondaryId As Integer _
)
Visual C++
public:
RulesInfo(
    int userid,
    int groupId,
    int appId,
    String^ ruleGroupId,
    int secondaryId
)

Parameters

userid
Type: System..::.Int32
groupId
Type: System..::.Int32
appId
Type: System..::.Int32
ruleGroupId
Type: System..::.String
secondaryId
Type: System..::.Int32

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


RulesInfo Methods

[image] [image]

OfficeClip API Documentation
RulesInfo Methods
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

The RulesInfo type exposes the following methods.

Methods

 | Name | Description
Public method | AddAction |
Public method | AddCondition |
Public method | AddNotification |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActionInfoList |
Public method | GetActionsString |
Public method | GetConditionInfoList |
Public method | GetConditionsString |
Public method | GetFrequencyString |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNotificationInfoList |
Public method | GetNotificationsString |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAction |
Public method | RemoveCondition |
Public method | RemoveNotification |
Public method | ToString | (Overrides Object..::.ToString()()().)

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


AddAction Method

[image]

OfficeClip API Documentation
RulesInfo..::.AddAction Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void AddAction(
    ActionInfo info
)
Visual Basic (Declaration)
Public Sub AddAction ( _
    info As ActionInfo _
)
Visual C++
public:
void AddAction(
    ActionInfo^ info
)

Parameters

info
Type: OfficeClip.BusinessLayer.Rules..::.ActionInfo

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


AddCondition Method

[image]

OfficeClip API Documentation
RulesInfo..::.AddCondition Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void AddCondition(
    ConditionInfo info
)
Visual Basic (Declaration)
Public Sub AddCondition ( _
    info As ConditionInfo _
)
Visual C++
public:
void AddCondition(
    ConditionInfo^ info
)

Parameters

info
Type: OfficeClip.BusinessLayer.Rules..::.ConditionInfo

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


AddNotification Method

[image]

OfficeClip API Documentation
RulesInfo..::.AddNotification Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void AddNotification(
    NotificationInfo info
)
Visual Basic (Declaration)
Public Sub AddNotification ( _
    info As NotificationInfo _
)
Visual C++
public:
void AddNotification(
    NotificationInfo^ info
)

Parameters

info
Type: OfficeClip.BusinessLayer.Rules..::.NotificationInfo

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


GetActionInfoList Method

[image]

OfficeClip API Documentation
RulesInfo..::.GetActionInfoList Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<ActionInfo> GetActionInfoList()
Visual Basic (Declaration)
Public Function GetActionInfoList As List(Of ActionInfo)
Visual C++
public:
List<ActionInfo^>^ GetActionInfoList()

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


GetActionsString Method

[image]

OfficeClip API Documentation
RulesInfo..::.GetActionsString Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetActionsString()
Visual Basic (Declaration)
Public Function GetActionsString As String
Visual C++
public:
String^ GetActionsString()

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


GetConditionInfoList Method

[image]

OfficeClip API Documentation
RulesInfo..::.GetConditionInfoList Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<ConditionInfo> GetConditionInfoList()
Visual Basic (Declaration)
Public Function GetConditionInfoList As List(Of ConditionInfo)
Visual C++
public:
List<ConditionInfo^>^ GetConditionInfoList()

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


GetConditionsString Method

[image]

OfficeClip API Documentation
RulesInfo..::.GetConditionsString Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetConditionsString()
Visual Basic (Declaration)
Public Function GetConditionsString As String
Visual C++
public:
String^ GetConditionsString()

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


GetFrequencyString Method

[image]

OfficeClip API Documentation
RulesInfo..::.GetFrequencyString Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetFrequencyString()
Visual Basic (Declaration)
Public Function GetFrequencyString As String
Visual C++
public:
String^ GetFrequencyString()

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


GetNotificationInfoList Method

[image]

OfficeClip API Documentation
RulesInfo..::.GetNotificationInfoList Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<NotificationInfo> GetNotificationInfoList()
Visual Basic (Declaration)
Public Function GetNotificationInfoList As List(Of NotificationInfo)
Visual C++
public:
List<NotificationInfo^>^ GetNotificationInfoList()

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


GetNotificationsString Method

[image]

OfficeClip API Documentation
RulesInfo..::.GetNotificationsString Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetNotificationsString()
Visual Basic (Declaration)
Public Function GetNotificationsString As String
Visual C++
public:
String^ GetNotificationsString()

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


RemoveAction Method

[image]

OfficeClip API Documentation
RulesInfo..::.RemoveAction Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool RemoveAction(
    ActionInfo info
)
Visual Basic (Declaration)
Public Function RemoveAction ( _
    info As ActionInfo _
) As Boolean
Visual C++
public:
bool RemoveAction(
    ActionInfo^ info
)

Parameters

info
Type: OfficeClip.BusinessLayer.Rules..::.ActionInfo

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


RemoveCondition Method

[image]

OfficeClip API Documentation
RulesInfo..::.RemoveCondition Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool RemoveCondition(
    ConditionInfo info
)
Visual Basic (Declaration)
Public Function RemoveCondition ( _
    info As ConditionInfo _
) As Boolean
Visual C++
public:
bool RemoveCondition(
    ConditionInfo^ info
)

Parameters

info
Type: OfficeClip.BusinessLayer.Rules..::.ConditionInfo

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


RemoveNotification Method

[image]

OfficeClip API Documentation
RulesInfo..::.RemoveNotification Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool RemoveNotification(
    NotificationInfo info
)
Visual Basic (Declaration)
Public Function RemoveNotification ( _
    info As NotificationInfo _
) As Boolean
Visual C++
public:
bool RemoveNotification(
    NotificationInfo^ info
)

Parameters

info
Type: OfficeClip.BusinessLayer.Rules..::.NotificationInfo

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


ToString Method

[image]

OfficeClip API Documentation
RulesInfo..::.ToString Method
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


RulesInfo Properties

[image] [image]

OfficeClip API Documentation
RulesInfo Properties
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

The RulesInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AppID |
Public property | GroupID |
Public property | IsEnabled |
Public property | Name |
Public property | RuleGroupID |
Public property | SecondaryId |
Public property | TimeTriggerFreq |
Public property | UserID |

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


AppID Property

[image]

OfficeClip API Documentation
RulesInfo..::.AppID Property
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AppID { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppID As Integer
Visual C++
public:
property int AppID {
    int get ();
}

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


GroupID Property

[image]

OfficeClip API Documentation
RulesInfo..::.GroupID Property
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupID { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupID As Integer
Visual C++
public:
property int GroupID {
    int get ();
}

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


IsEnabled Property

[image]

OfficeClip API Documentation
RulesInfo..::.IsEnabled Property
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsEnabled As Boolean
Visual C++
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


Name Property

[image]

OfficeClip API Documentation
RulesInfo..::.Name Property
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


RuleGroupID Property

[image]

OfficeClip API Documentation
RulesInfo..::.RuleGroupID Property
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RuleGroupID { get; }
Visual Basic (Declaration)
Public ReadOnly Property RuleGroupID As String
Visual C++
public:
property String^ RuleGroupID {
    String^ get ();
}

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


SecondaryId Property

[image]

OfficeClip API Documentation
RulesInfo..::.SecondaryId Property
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SecondaryId { get; }
Visual Basic (Declaration)
Public ReadOnly Property SecondaryId As Integer
Visual C++
public:
property int SecondaryId {
    int get ();
}

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


TimeTriggerFreq Property

[image]

OfficeClip API Documentation
RulesInfo..::.TimeTriggerFreq Property
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TimeTriggerFreq { get; set; }
Visual Basic (Declaration)
Public Property TimeTriggerFreq As Integer
Visual C++
public:
property int TimeTriggerFreq {
    int get ();
    void set (int value);
}

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


UserID Property

[image]

OfficeClip API Documentation
RulesInfo..::.UserID Property
RulesInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Rules
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserID { get; }
Visual Basic (Declaration)
Public ReadOnly Property UserID As Integer
Visual C++
public:
property int UserID {
    int get ();
}

See Also

RulesInfo Class
OfficeClip.BusinessLayer.Rules Namespace


OfficeClip.BusinessLayer.Security Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Security Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the OfficeClip security. In OfficeClip an object can have three types of security associated with it: organization level security, role security and user decurity

Classes

 | Class | Description
Public class | PermissionData |
Public class | RoleAccess | This class defines types and placeholder for the various accesslevels in OfficeClip. Each application has some functions for which permission can be given for various levels of users and groups
Public class | RoleInfo | Provides methods and properties to access the role information. An important thing to be noted in this class is that the role_id = -2 is reserved for the role name "Administrator" and the role_id = -3 is reserver for the role name "All Members". These two roles cannot changed as they are fixed by the system.
Public class | RoleUser | Captures the user id and description of the user who belongs to the role
Public class | SecurityObject | Represents the object security of any object in the OfficeClip system. There can be three types of object security which are, group based object security, role based object secirity and user based object security. This class contains two ids userId and roleId. Both roleId and userId cannot be present at one time.


PermissionData Class

[image]

OfficeClip API Documentation
PermissionData Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class PermissionData
Visual Basic (Declaration)
Public Class PermissionData
Visual C++
public ref class PermissionData

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Security..::.PermissionData

See Also

PermissionData Members
OfficeClip.BusinessLayer.Security Namespace


PermissionData Members

[image] [image]

OfficeClip API Documentation
PermissionData Members
PermissionData Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PermissionData type exposes the following members.

Constructors

 | Name | Description
Public method | PermissionData | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The unique id
Public property | PermName | Perm Name
Public property | RadPerm | Rad Perm
Public property | RowSpan | Row Span
Public property | Title | Title

See Also

PermissionData Class
OfficeClip.BusinessLayer.Security Namespace


PermissionData Constructor

[image]

OfficeClip API Documentation
PermissionData Constructor
PermissionData Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PermissionData(
    int theId,
    string theTitle,
    string thePermName,
    int theRowSpan,
    bool theRadPerm
)
Visual Basic (Declaration)
Public Sub New ( _
    theId As Integer, _
    theTitle As String, _
    thePermName As String, _
    theRowSpan As Integer, _
    theRadPerm As Boolean _
)
Visual C++
public:
PermissionData(
    int theId,
    String^ theTitle,
    String^ thePermName,
    int theRowSpan,
    bool theRadPerm
)

Parameters

theId
Type: System..::.Int32
theTitle
Type: System..::.String
thePermName
Type: System..::.String
theRowSpan
Type: System..::.Int32
theRadPerm
Type: System..::.Boolean

See Also

PermissionData Class
OfficeClip.BusinessLayer.Security Namespace


PermissionData Properties

[image] [image]

OfficeClip API Documentation
PermissionData Properties
PermissionData Class See Also

[This is preliminary documentation and is subject to change.]

The PermissionData type exposes the following properties.

Properties

 | Name | Description
Public property | Id | The unique id
Public property | PermName | Perm Name
Public property | RadPerm | Rad Perm
Public property | RowSpan | Row Span
Public property | Title | Title

See Also

PermissionData Class
OfficeClip.BusinessLayer.Security Namespace


Id Property

[image]

OfficeClip API Documentation
PermissionData..::.Id Property
PermissionData Class See Also

[This is preliminary documentation and is subject to change.]

The unique id

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As Integer
Visual C++
public:
property int Id {
    int get ();
}

See Also

PermissionData Class
OfficeClip.BusinessLayer.Security Namespace


PermName Property

[image]

OfficeClip API Documentation
PermissionData..::.PermName Property
PermissionData Class See Also

[This is preliminary documentation and is subject to change.]

Perm Name

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PermName { get; }
Visual Basic (Declaration)
Public ReadOnly Property PermName As String
Visual C++
public:
property String^ PermName {
    String^ get ();
}

See Also

PermissionData Class
OfficeClip.BusinessLayer.Security Namespace


RadPerm Property

[image]

OfficeClip API Documentation
PermissionData..::.RadPerm Property
PermissionData Class See Also

[This is preliminary documentation and is subject to change.]

Rad Perm

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool RadPerm { get; set; }
Visual Basic (Declaration)
Public Property RadPerm As Boolean
Visual C++
public:
property bool RadPerm {
    bool get ();
    void set (bool value);
}

See Also

PermissionData Class
OfficeClip.BusinessLayer.Security Namespace


RowSpan Property

[image]

OfficeClip API Documentation
PermissionData..::.RowSpan Property
PermissionData Class See Also

[This is preliminary documentation and is subject to change.]

Row Span

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RowSpan { get; }
Visual Basic (Declaration)
Public ReadOnly Property RowSpan As Integer
Visual C++
public:
property int RowSpan {
    int get ();
}

See Also

PermissionData Class
OfficeClip.BusinessLayer.Security Namespace


Title Property

[image]

OfficeClip API Documentation
PermissionData..::.Title Property
PermissionData Class See Also

[This is preliminary documentation and is subject to change.]

Title

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Title { get; }
Visual Basic (Declaration)
Public ReadOnly Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

PermissionData Class
OfficeClip.BusinessLayer.Security Namespace


RoleAccess Class

[image]

OfficeClip API Documentation
RoleAccess Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class defines types and placeholder for the various accesslevels in OfficeClip. Each application has some functions for which permission can be given for various levels of users and groups

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class RoleAccess
Visual Basic (Declaration)
Public Class RoleAccess
Visual C++
public ref class RoleAccess

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Security..::.RoleAccess

See Also

RoleAccess Members
OfficeClip.BusinessLayer.Security Namespace


RoleAccess Members

[image] [image]

OfficeClip API Documentation
RoleAccess Members
RoleAccess Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RoleAccess type exposes the following members.

Constructors

 | Name | Description
Public method | RoleAccess | Overloaded.

Methods

 | Name | Description
Public method | Dump | dump for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The id of the access function
Public property | Value | The value of the access function

See Also

RoleAccess Class
OfficeClip.BusinessLayer.Security Namespace


RoleAccess Constructor

[image] [image]

OfficeClip API Documentation
RoleAccess Constructor
RoleAccess Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | RoleAccess()()() | The role access constructor
Public method | RoleAccess(AccessFunction, Boolean) | The role access constructor

See Also

RoleAccess Class
RoleAccess Members
OfficeClip.BusinessLayer.Security Namespace


RoleAccess Constructor

[image]

OfficeClip API Documentation
RoleAccess Constructor
RoleAccess Class See Also

[This is preliminary documentation and is subject to change.]

The role access constructor

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RoleAccess()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoleAccess()

See Also

RoleAccess Class
RoleAccess Overload
OfficeClip.BusinessLayer.Security Namespace


RoleAccess Constructor (AccessFunction, Boolean)

[image]

OfficeClip API Documentation
RoleAccess Constructor (AccessFunction, Boolean)
RoleAccess Class See Also

[This is preliminary documentation and is subject to change.]

The role access constructor

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RoleAccess(
    AccessFunction id,
    bool val
)
Visual Basic (Declaration)
Public Sub New ( _
    id As AccessFunction, _
    val As Boolean _
)
Visual C++
public:
RoleAccess(
    AccessFunction id,
    bool val
)

Parameters

id
Type: OfficeClip.Utils..::.AccessFunction
The id of the access function
val
Type: System..::.Boolean
The value of the access function

See Also

RoleAccess Class
RoleAccess Overload
OfficeClip.BusinessLayer.Security Namespace


RoleAccess Methods

[image] [image]

OfficeClip API Documentation
RoleAccess Methods
RoleAccess Class See Also

[This is preliminary documentation and is subject to change.]

The RoleAccess type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | dump for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoleAccess Class
OfficeClip.BusinessLayer.Security Namespace


Dump Method

[image]

OfficeClip API Documentation
RoleAccess..::.Dump Method
RoleAccess Class See Also

[This is preliminary documentation and is subject to change.]

dump for debugging

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

See Also

RoleAccess Class
OfficeClip.BusinessLayer.Security Namespace


RoleAccess Properties

[image] [image]

OfficeClip API Documentation
RoleAccess Properties
RoleAccess Class See Also

[This is preliminary documentation and is subject to change.]

The RoleAccess type exposes the following properties.

Properties

 | Name | Description
Public property | Id | The id of the access function
Public property | Value | The value of the access function

See Also

RoleAccess Class
OfficeClip.BusinessLayer.Security Namespace


Id Property

[image]

OfficeClip API Documentation
RoleAccess..::.Id Property
RoleAccess Class See Also

[This is preliminary documentation and is subject to change.]

The id of the access function

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AccessFunction Id { get; set; }
Visual Basic (Declaration)
Public Property Id As AccessFunction
Visual C++
public:
property AccessFunction Id {
    AccessFunction get ();
    void set (AccessFunction value);
}

See Also

RoleAccess Class
OfficeClip.BusinessLayer.Security Namespace


Value Property

[image]

OfficeClip API Documentation
RoleAccess..::.Value Property
RoleAccess Class See Also

[This is preliminary documentation and is subject to change.]

The value of the access function

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Boolean
Visual C++
public:
property bool Value {
    bool get ();
    void set (bool value);
}

See Also

RoleAccess Class
OfficeClip.BusinessLayer.Security Namespace


RoleInfo Class

[image]

OfficeClip API Documentation
RoleInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the role information. An important thing to be noted in this class is that the role_id = -2 is reserved for the role name "Administrator" and the role_id = -3 is reserver for the role name "All Members". These two roles cannot changed as they are fixed by the system.

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class RoleInfo
Visual Basic (Declaration)
Public Class RoleInfo
Visual C++
public ref class RoleInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Security..::.RoleInfo

See Also

RoleInfo Members
OfficeClip.BusinessLayer.Security Namespace


RoleInfo Members

[image] [image]

OfficeClip API Documentation
RoleInfo Members
RoleInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RoleInfo type exposes the following members.

Constructors

 | Name | Description
Public method | RoleInfo | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleAccesses | The Access matrix of the role
Public property | RoleDescription | The name of the role
Public property | RoleId | The unique id of the role
Public property | RoleName | The name of the role
Public property | RoleUsers | The list of user ids for the role

See Also

RoleInfo Class
OfficeClip.BusinessLayer.Security Namespace


RoleInfo Constructor

[image] [image]

OfficeClip API Documentation
RoleInfo Constructor
RoleInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | RoleInfo()()() | The default constructor.
Public method | RoleInfo(Int32, String, String, array<RoleAccess>[]()[], array<RoleUser>[]()[]) | The constructor to create the object from its values

See Also

RoleInfo Class
RoleInfo Members
OfficeClip.BusinessLayer.Security Namespace


RoleInfo Constructor

[image]

OfficeClip API Documentation
RoleInfo Constructor
RoleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RoleInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoleInfo()

See Also

RoleInfo Class
RoleInfo Overload
OfficeClip.BusinessLayer.Security Namespace


RoleInfo Constructor (Int32, String, String, RoleAccess[], RoleUser[])

[image]

OfficeClip API Documentation
RoleInfo Constructor (Int32, String, String, array<RoleAccess>[]()[], array<RoleUser>[]()[])
RoleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor to create the object from its values

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RoleInfo(
    int roleId,
    string roleName,
    string roleDescription,
    RoleAccess[] roleAccesses,
    RoleUser[] roleUsers
)
Visual Basic (Declaration)
Public Sub New ( _
    roleId As Integer, _
    roleName As String, _
    roleDescription As String, _
    roleAccesses As RoleAccess(), _
    roleUsers As RoleUser() _
)
Visual C++
public:
RoleInfo(
    int roleId,
    String^ roleName,
    String^ roleDescription,
    array<RoleAccess^>^ roleAccesses,
    array<RoleUser^>^ roleUsers
)

Parameters

roleId
Type: System..::.Int32
The unique roleId determined by the system.
roleName
Type: System..::.String
The name of the role.
roleDescription
Type: System..::.String
The description of the role
roleAccesses
Type: array< OfficeClip.BusinessLayer.Security..::.RoleAccess >[]()[]
The function access matrix of the role
roleUsers
Type: array< OfficeClip.BusinessLayer.Security..::.RoleUser >[]()[]
The list of user ids of the users who belongs to this role

See Also

RoleInfo Class
RoleInfo Overload
OfficeClip.BusinessLayer.Security Namespace


RoleInfo Methods

[image] [image]

OfficeClip API Documentation
RoleInfo Methods
RoleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The RoleInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoleInfo Class
OfficeClip.BusinessLayer.Security Namespace


Dump Method

[image]

OfficeClip API Documentation
RoleInfo..::.Dump Method
RoleInfo Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the object for debugging

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

the debug dump

See Also

RoleInfo Class
OfficeClip.BusinessLayer.Security Namespace


RoleInfo Properties

[image] [image]

OfficeClip API Documentation
RoleInfo Properties
RoleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The RoleInfo type exposes the following properties.

Properties

 | Name | Description
Public property | RoleAccesses | The Access matrix of the role
Public property | RoleDescription | The name of the role
Public property | RoleId | The unique id of the role
Public property | RoleName | The name of the role
Public property | RoleUsers | The list of user ids for the role

See Also

RoleInfo Class
OfficeClip.BusinessLayer.Security Namespace


RoleAccesses Property

[image]

OfficeClip API Documentation
RoleInfo..::.RoleAccesses Property
RoleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Access matrix of the role

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RoleAccess[] RoleAccesses { get; set; }
Visual Basic (Declaration)
Public Property RoleAccesses As RoleAccess()
Visual C++
public:
property array<RoleAccess^>^ RoleAccesses {
    array<RoleAccess^>^ get ();
    void set (array<RoleAccess^>^ value);
}

See Also

RoleInfo Class
OfficeClip.BusinessLayer.Security Namespace


RoleDescription Property

[image]

OfficeClip API Documentation
RoleInfo..::.RoleDescription Property
RoleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the role

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RoleDescription { get; set; }
Visual Basic (Declaration)
Public Property RoleDescription As String
Visual C++
public:
property String^ RoleDescription {
    String^ get ();
    void set (String^ value);
}

See Also

RoleInfo Class
OfficeClip.BusinessLayer.Security Namespace


RoleId Property

[image]

OfficeClip API Documentation
RoleInfo..::.RoleId Property
RoleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the role

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RoleId { get; set; }
Visual Basic (Declaration)
Public Property RoleId As Integer
Visual C++
public:
property int RoleId {
    int get ();
    void set (int value);
}

See Also

RoleInfo Class
OfficeClip.BusinessLayer.Security Namespace


RoleName Property

[image]

OfficeClip API Documentation
RoleInfo..::.RoleName Property
RoleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the role

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RoleName { get; set; }
Visual Basic (Declaration)
Public Property RoleName As String
Visual C++
public:
property String^ RoleName {
    String^ get ();
    void set (String^ value);
}

See Also

RoleInfo Class
OfficeClip.BusinessLayer.Security Namespace


RoleUsers Property

[image]

OfficeClip API Documentation
RoleInfo..::.RoleUsers Property
RoleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of user ids for the role

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RoleUser[] RoleUsers { get; set; }
Visual Basic (Declaration)
Public Property RoleUsers As RoleUser()
Visual C++
public:
property array<RoleUser^>^ RoleUsers {
    array<RoleUser^>^ get ();
    void set (array<RoleUser^>^ value);
}

See Also

RoleInfo Class
OfficeClip.BusinessLayer.Security Namespace


RoleUser Class

[image]

OfficeClip API Documentation
RoleUser Class
Members See Also

[This is preliminary documentation and is subject to change.]

Captures the user id and description of the user who belongs to the role

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class RoleUser
Visual Basic (Declaration)
Public Class RoleUser
Visual C++
public ref class RoleUser

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Security..::.RoleUser

See Also

RoleUser Members
OfficeClip.BusinessLayer.Security Namespace


RoleUser Members

[image] [image]

OfficeClip API Documentation
RoleUser Members
RoleUser Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RoleUser type exposes the following members.

Constructors

 | Name | Description
Public method | RoleUser | Overloaded.

Methods

 | Name | Description
Public method | Dump | Outputs the class content for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoleUserDescription | The description of the role user
Public property | RoleUserId | The unique id of the role user

See Also

RoleUser Class
OfficeClip.BusinessLayer.Security Namespace


RoleUser Constructor

[image] [image]

OfficeClip API Documentation
RoleUser Constructor
RoleUser Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | RoleUser()()() | The constructor for the role user
Public method | RoleUser(Int32, String) | The constructor for the role user

See Also

RoleUser Class
RoleUser Members
OfficeClip.BusinessLayer.Security Namespace


RoleUser Constructor

[image]

OfficeClip API Documentation
RoleUser Constructor
RoleUser Class See Also

[This is preliminary documentation and is subject to change.]

The constructor for the role user

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RoleUser()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoleUser()

See Also

RoleUser Class
RoleUser Overload
OfficeClip.BusinessLayer.Security Namespace


RoleUser Constructor (Int32, String)

[image]

OfficeClip API Documentation
RoleUser Constructor (Int32, String)
RoleUser Class See Also

[This is preliminary documentation and is subject to change.]

The constructor for the role user

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RoleUser(
    int roleUserId,
    string roleUserDescription
)
Visual Basic (Declaration)
Public Sub New ( _
    roleUserId As Integer, _
    roleUserDescription As String _
)
Visual C++
public:
RoleUser(
    int roleUserId,
    String^ roleUserDescription
)

Parameters

roleUserId
Type: System..::.Int32
The unique id of the role user
roleUserDescription
Type: System..::.String
The role user description

See Also

RoleUser Class
RoleUser Overload
OfficeClip.BusinessLayer.Security Namespace


RoleUser Methods

[image] [image]

OfficeClip API Documentation
RoleUser Methods
RoleUser Class See Also

[This is preliminary documentation and is subject to change.]

The RoleUser type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Outputs the class content for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoleUser Class
OfficeClip.BusinessLayer.Security Namespace


Dump Method

[image]

OfficeClip API Documentation
RoleUser..::.Dump Method
RoleUser Class See Also

[This is preliminary documentation and is subject to change.]

Outputs the class content for debugging purposes

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

the dump of the class information

See Also

RoleUser Class
OfficeClip.BusinessLayer.Security Namespace


RoleUser Properties

[image] [image]

OfficeClip API Documentation
RoleUser Properties
RoleUser Class See Also

[This is preliminary documentation and is subject to change.]

The RoleUser type exposes the following properties.

Properties

 | Name | Description
Public property | RoleUserDescription | The description of the role user
Public property | RoleUserId | The unique id of the role user

See Also

RoleUser Class
OfficeClip.BusinessLayer.Security Namespace


RoleUserDescription Property

[image]

OfficeClip API Documentation
RoleUser..::.RoleUserDescription Property
RoleUser Class See Also

[This is preliminary documentation and is subject to change.]

The description of the role user

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RoleUserDescription { get; set; }
Visual Basic (Declaration)
Public Property RoleUserDescription As String
Visual C++
public:
property String^ RoleUserDescription {
    String^ get ();
    void set (String^ value);
}

See Also

RoleUser Class
OfficeClip.BusinessLayer.Security Namespace


RoleUserId Property

[image]

OfficeClip API Documentation
RoleUser..::.RoleUserId Property
RoleUser Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the role user

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RoleUserId { get; set; }
Visual Basic (Declaration)
Public Property RoleUserId As Integer
Visual C++
public:
property int RoleUserId {
    int get ();
    void set (int value);
}

See Also

RoleUser Class
OfficeClip.BusinessLayer.Security Namespace


SecurityObject Class

[image]

OfficeClip API Documentation
SecurityObject Class
Members See Also

[This is preliminary documentation and is subject to change.]

Represents the object security of any object in the OfficeClip system. There can be three types of object security which are, group based object security, role based object secirity and user based object security. This class contains two ids userId and roleId. Both roleId and userId cannot be present at one time.

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class SecurityObject
Visual Basic (Declaration)
Public Class SecurityObject
Visual C++
public ref class SecurityObject

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Security..::.SecurityObject

See Also

SecurityObject Members
OfficeClip.BusinessLayer.Security Namespace


SecurityObject Members

[image] [image]

OfficeClip API Documentation
SecurityObject Members
SecurityObject Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The SecurityObject type exposes the following members.

Constructors

 | Name | Description
Public method | SecurityObject | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dump the class content on a string for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetNavigateUrl | Gets the navigator url
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessAppend | The append access bit
Public property | AccessDelete | The delete access bit
Public property | AccessRead | The read access bit
Public property | AccessWrite | The write access bit
Public property | Description | The description of the object, usually role name or the user name
Public property | GroupId | The unique id of the object
Public property | IsLocked | The type of the object
Public property | ObjectId | The unique id of the object
Public property | ObjectType | The type of the object
Public property | RoleId | The unique id of the role, the value of -1 denotes that the object does not represent the role based security.
Public property | UserId | The unique id of the user, the value of -1 denotes that the object does not denote role based security.

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


SecurityObject Constructor

[image] [image]

OfficeClip API Documentation
SecurityObject Constructor
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | SecurityObject()()() | The default constructor
Public method | SecurityObject(Int32, Int32, Int32, Int32, BusinessConstants..::.ObjectType, String, Boolean, Boolean, Boolean, Boolean, Boolean) | The constructor to create an object from its value

See Also

SecurityObject Class
SecurityObject Members
OfficeClip.BusinessLayer.Security Namespace


SecurityObject Constructor

[image]

OfficeClip API Documentation
SecurityObject Constructor
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SecurityObject()

See Also

SecurityObject Class
SecurityObject Overload
OfficeClip.BusinessLayer.Security Namespace


SecurityObject Constructor (Int32, Int32, Int32, Int32, BusinessConstants.ObjectType, String, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

OfficeClip API Documentation
SecurityObject Constructor (Int32, Int32, Int32, Int32, BusinessConstants..::.ObjectType, String, Boolean, Boolean, Boolean, Boolean, Boolean)
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The constructor to create an object from its value

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObject(
    int roleId,
    int userId,
    int objectId,
    int groupId,
    BusinessConstants..::.ObjectType objectType,
    string description,
    bool isLocked,
    bool accessRead,
    bool accessWrite,
    bool accessAppend,
    bool accessDelete
)
Visual Basic (Declaration)
Public Sub New ( _
    roleId As Integer, _
    userId As Integer, _
    objectId As Integer, _
    groupId As Integer, _
    objectType As BusinessConstants..::.ObjectType, _
    description As String, _
    isLocked As Boolean, _
    accessRead As Boolean, _
    accessWrite As Boolean, _
    accessAppend As Boolean, _
    accessDelete As Boolean _
)
Visual C++
public:
SecurityObject(
    int roleId,
    int userId,
    int objectId,
    int groupId,
    BusinessConstants..::.ObjectType objectType,
    String^ description,
    bool isLocked,
    bool accessRead,
    bool accessWrite,
    bool accessAppend,
    bool accessDelete
)

Parameters

roleId
Type: System..::.Int32
The unique id of the role
userId
Type: System..::.Int32
The unique id of the user
objectId
Type: System..::.Int32
The unique id of the object
groupId
Type: System..::.Int32
The unique idof the group
objectType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The type of the object
description
Type: System..::.String
The description of the entry (usually name of the user or role)
isLocked
Type: System..::.Boolean
If the permission is locked so that user cannot change it.
accessRead
Type: System..::.Boolean
The read access bit
accessWrite
Type: System..::.Boolean
The write access bit
accessAppend
Type: System..::.Boolean
The append access bit
accessDelete
Type: System..::.Boolean
The delete access bit

See Also

SecurityObject Class
SecurityObject Overload
OfficeClip.BusinessLayer.Security Namespace


SecurityObject Methods

[image] [image]

OfficeClip API Documentation
SecurityObject Methods
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The SecurityObject type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dump the class content on a string for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetNavigateUrl | Gets the navigator url
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


Dump Method

[image]

OfficeClip API Documentation
SecurityObject..::.Dump Method
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

Dump the class content on a string for debugging purposes

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

The dump of the class content

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


GetNavigateUrl Method

[image]

OfficeClip API Documentation
SecurityObject..::.GetNavigateUrl Method
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

Gets the navigator url

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetNavigateUrl(
    int objectId,
    int ownerId,
    string ownerName,
    int objectType,
    string description,
    bool isFullAccess
)
Visual Basic (Declaration)
Public Shared Function GetNavigateUrl ( _
    objectId As Integer, _
    ownerId As Integer, _
    ownerName As String, _
    objectType As Integer, _
    description As String, _
    isFullAccess As Boolean _
) As String
Visual C++
public:
static String^ GetNavigateUrl(
    int objectId,
    int ownerId,
    String^ ownerName,
    int objectType,
    String^ description,
    bool isFullAccess
)

Parameters

objectId
Type: System..::.Int32
The unique id of the object
ownerId
Type: System..::.Int32
The unique id of the owner
ownerName
Type: System..::.String
The name of the owner
objectType
Type: System..::.Int32
The type of the object
description
Type: System..::.String
The description of the object
isFullAccess
Type: System..::.Boolean
true if full access is provided, false otherwise

Return Value

The navigator url string

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


SecurityObject Properties

[image] [image]

OfficeClip API Documentation
SecurityObject Properties
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The SecurityObject type exposes the following properties.

Properties

 | Name | Description
Public property | AccessAppend | The append access bit
Public property | AccessDelete | The delete access bit
Public property | AccessRead | The read access bit
Public property | AccessWrite | The write access bit
Public property | Description | The description of the object, usually role name or the user name
Public property | GroupId | The unique id of the object
Public property | IsLocked | The type of the object
Public property | ObjectId | The unique id of the object
Public property | ObjectType | The type of the object
Public property | RoleId | The unique id of the role, the value of -1 denotes that the object does not represent the role based security.
Public property | UserId | The unique id of the user, the value of -1 denotes that the object does not denote role based security.

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


AccessAppend Property

[image]

OfficeClip API Documentation
SecurityObject..::.AccessAppend Property
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The append access bit

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool AccessAppend { get; set; }
Visual Basic (Declaration)
Public Property AccessAppend As Boolean
Visual C++
public:
property bool AccessAppend {
    bool get ();
    void set (bool value);
}

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


AccessDelete Property

[image]

OfficeClip API Documentation
SecurityObject..::.AccessDelete Property
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The delete access bit

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool AccessDelete { get; set; }
Visual Basic (Declaration)
Public Property AccessDelete As Boolean
Visual C++
public:
property bool AccessDelete {
    bool get ();
    void set (bool value);
}

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


AccessRead Property

[image]

OfficeClip API Documentation
SecurityObject..::.AccessRead Property
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The read access bit

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool AccessRead { get; set; }
Visual Basic (Declaration)
Public Property AccessRead As Boolean
Visual C++
public:
property bool AccessRead {
    bool get ();
    void set (bool value);
}

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


AccessWrite Property

[image]

OfficeClip API Documentation
SecurityObject..::.AccessWrite Property
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The write access bit

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool AccessWrite { get; set; }
Visual Basic (Declaration)
Public Property AccessWrite As Boolean
Visual C++
public:
property bool AccessWrite {
    bool get ();
    void set (bool value);
}

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


Description Property

[image]

OfficeClip API Documentation
SecurityObject..::.Description Property
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The description of the object, usually role name or the user name

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


GroupId Property

[image]

OfficeClip API Documentation
SecurityObject..::.GroupId Property
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the object

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


IsLocked Property

[image]

OfficeClip API Documentation
SecurityObject..::.IsLocked Property
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The type of the object

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic (Declaration)
Public Property IsLocked As Boolean
Visual C++
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


ObjectId Property

[image]

OfficeClip API Documentation
SecurityObject..::.ObjectId Property
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the object

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ObjectId { get; set; }
Visual Basic (Declaration)
Public Property ObjectId As Integer
Visual C++
public:
property int ObjectId {
    int get ();
    void set (int value);
}

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


ObjectType Property

[image]

OfficeClip API Documentation
SecurityObject..::.ObjectType Property
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The type of the object

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public BusinessConstants..::.ObjectType ObjectType { get; set; }
Visual Basic (Declaration)
Public Property ObjectType As BusinessConstants..::.ObjectType
Visual C++
public:
property BusinessConstants..::.ObjectType ObjectType {
    BusinessConstants..::.ObjectType get ();
    void set (BusinessConstants..::.ObjectType value);
}

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


RoleId Property

[image]

OfficeClip API Documentation
SecurityObject..::.RoleId Property
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the role, the value of -1 denotes that the object does not represent the role based security.

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RoleId { get; set; }
Visual Basic (Declaration)
Public Property RoleId As Integer
Visual C++
public:
property int RoleId {
    int get ();
    void set (int value);
}

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


UserId Property

[image]

OfficeClip API Documentation
SecurityObject..::.UserId Property
SecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user, the value of -1 denotes that the object does not denote role based security.

Namespace: OfficeClip.BusinessLayer.Security
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

SecurityObject Class
OfficeClip.BusinessLayer.Security Namespace


OfficeClip.BusinessLayer.Service Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Service Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for the OfficeClip Web Service (this is not used currently)

Classes

 | Class | Description
Public class | GroupContent | Description of the group content service object
Public class | MetaValue | Class to represent a contact
Public class | OCContact | Class to represent a contact
Public class | OCContacts | Class to represent a contact
Public class | OCEvent | Class to represent a task
Public class | OCGroupEvents | Class to represent a task
Public class | OCMap | Class to map the felds of the OfficeClip object with the external object
Public class | OCMetaInfo | Class to represent a meta information object
Public class | OCNote | Class to represent a note
Public class | OCPrivateEvents | Class to represent a task
Public class | OCRole | Class to represent a role collection
Public class | OCSecurity | Class to represent a role collection
Public class | OCSecurityObject | Class to represent a role collection
Public class | OCService | Base class for all the OfficeClip Services
Public class | OCSystem | The class to hold the system information
Public class | OCTask | Class to represent a task
Public class | OCTasks | Class to represent tasks
Public class | OCTrackerCase | Service class for individual cases
Public class | OCTrackerField | Represents a single field of the tracker project
Public class | OCTrackerFields | Class to represent a list of fields for a project
Public class | OCTrackerProject | Class to represent a tracker project
Public class | OCUser | Class to represent a task
Public class | OCUsers | Class to represent personal address book
Public class | SystemContent | The class to hold system contents
Public class | TrackerFieldListArg | Class to represent the field list argument
Public class | TrackerFieldValue | Class to represent a tracker field value

Interfaces

 | Interface | Description
Public interface | IOCService | The IOCService interface


GroupContent Class

[image]

OfficeClip API Documentation
GroupContent Class
Members See Also

[This is preliminary documentation and is subject to change.]

Description of the group content service object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class GroupContent
Visual Basic (Declaration)
Public Class GroupContent
Visual C++
public ref class GroupContent

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.GroupContent

See Also

GroupContent Members
OfficeClip.BusinessLayer.Service Namespace


GroupContent Members

[image] [image]

OfficeClip API Documentation
GroupContent Members
GroupContent Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The GroupContent type exposes the following members.

Constructors

 | Name | Description
Public method | GroupContent | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayName | The display name
Public property | Id | The unique id
Public property | ServiceType | The service type
Public property | Sid | The service id

See Also

GroupContent Class
OfficeClip.BusinessLayer.Service Namespace


GroupContent Constructor

[image] [image]

OfficeClip API Documentation
GroupContent Constructor
GroupContent Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GroupContent()()() | The default constuctor
Public method | GroupContent(OCServiceType, String, Int32, String) | Constructor

See Also

GroupContent Class
GroupContent Members
OfficeClip.BusinessLayer.Service Namespace


GroupContent Constructor

[image]

OfficeClip API Documentation
GroupContent Constructor
GroupContent Class See Also

[This is preliminary documentation and is subject to change.]

The default constuctor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GroupContent()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupContent()

See Also

GroupContent Class
GroupContent Overload
OfficeClip.BusinessLayer.Service Namespace


GroupContent Constructor (OCServiceType, String, Int32, String)

[image]

OfficeClip API Documentation
GroupContent Constructor (OCServiceType, String, Int32, String)
GroupContent Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GroupContent(
    OCServiceType serviceType,
    string displayName,
    int id,
    string sid
)
Visual Basic (Declaration)
Public Sub New ( _
    serviceType As OCServiceType, _
    displayName As String, _
    id As Integer, _
    sid As String _
)
Visual C++
public:
GroupContent(
    OCServiceType serviceType,
    String^ displayName,
    int id,
    String^ sid
)

Parameters

serviceType
Type: OfficeClip.Utils..::.OCServiceType
The service type
displayName
Type: System..::.String
The display name
id
Type: System..::.Int32
The unique id
sid
Type: System..::.String
The service id of the object

See Also

GroupContent Class
GroupContent Overload
OfficeClip.BusinessLayer.Service Namespace


GroupContent Properties

[image] [image]

OfficeClip API Documentation
GroupContent Properties
GroupContent Class See Also

[This is preliminary documentation and is subject to change.]

The GroupContent type exposes the following properties.

Properties

 | Name | Description
Public property | DisplayName | The display name
Public property | Id | The unique id
Public property | ServiceType | The service type
Public property | Sid | The service id

See Also

GroupContent Class
OfficeClip.BusinessLayer.Service Namespace


DisplayName Property

[image]

OfficeClip API Documentation
GroupContent..::.DisplayName Property
GroupContent Class See Also

[This is preliminary documentation and is subject to change.]

The display name

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DisplayName { get; set; }
Visual Basic (Declaration)
Public Property DisplayName As String
Visual C++
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}

See Also

GroupContent Class
OfficeClip.BusinessLayer.Service Namespace


Id Property

[image]

OfficeClip API Documentation
GroupContent..::.Id Property
GroupContent Class See Also

[This is preliminary documentation and is subject to change.]

The unique id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Id { get; set; }
Visual Basic (Declaration)
Public Property Id As Integer
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

See Also

GroupContent Class
OfficeClip.BusinessLayer.Service Namespace


ServiceType Property

[image]

OfficeClip API Documentation
GroupContent..::.ServiceType Property
GroupContent Class See Also

[This is preliminary documentation and is subject to change.]

The service type

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceType ServiceType { get; set; }
Visual Basic (Declaration)
Public Property ServiceType As OCServiceType
Visual C++
public:
property OCServiceType ServiceType {
    OCServiceType get ();
    void set (OCServiceType value);
}

See Also

GroupContent Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
GroupContent..::.Sid Property
GroupContent Class See Also

[This is preliminary documentation and is subject to change.]

The service id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Sid { get; set; }
Visual Basic (Declaration)
Public Property Sid As String
Visual C++
public:
property String^ Sid {
    String^ get ();
    void set (String^ value);
}

See Also

GroupContent Class
OfficeClip.BusinessLayer.Service Namespace


IOCService Interface

[image]

OfficeClip API Documentation
IOCService Interface
Members See Also

[This is preliminary documentation and is subject to change.]

The IOCService interface

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public interface IOCService
Visual Basic (Declaration)
Public Interface IOCService
Visual C++
public interface class IOCService

See Also

IOCService Members
OfficeClip.BusinessLayer.Service Namespace


IOCService Members

[image] [image]

OfficeClip API Documentation
IOCService Members
IOCService Interface Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The IOCService type exposes the following members.

Methods

 | Name | Description
Public method | Dump | Dump for debugging

Properties

 | Name | Description
Public property | Checksum | The checksum for two way synchronization, usually this is the timestamp in universal format
Public property | Command | The service command to manipulate the object
Public property | Lock | Shows whether the object is locked for editing
Public property | Sid | The service id

See Also

IOCService Interface
OfficeClip.BusinessLayer.Service Namespace


IOCService Methods

[image] [image]

OfficeClip API Documentation
IOCService Methods
IOCService Interface See Also

[This is preliminary documentation and is subject to change.]

The IOCService type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dump for debugging

See Also

IOCService Interface
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
IOCService..::.Dump Method
IOCService Interface See Also

[This is preliminary documentation and is subject to change.]

Dump for debugging

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
string Dump()
Visual Basic (Declaration)
Function Dump As String
Visual C++
String^ Dump()

Return Value

The output for debugging

See Also

IOCService Interface
OfficeClip.BusinessLayer.Service Namespace


IOCService Properties

[image] [image]

OfficeClip API Documentation
IOCService Properties
IOCService Interface See Also

[This is preliminary documentation and is subject to change.]

The IOCService type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum for two way synchronization, usually this is the timestamp in universal format
Public property | Command | The service command to manipulate the object
Public property | Lock | Shows whether the object is locked for editing
Public property | Sid | The service id

See Also

IOCService Interface
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
IOCService..::.Checksum Property
IOCService Interface See Also

[This is preliminary documentation and is subject to change.]

The checksum for two way synchronization, usually this is the timestamp in universal format

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
string Checksum { get; set; }
Visual Basic (Declaration)
Property Checksum As String
Visual C++
property String^ Checksum {
    String^ get ();
    void set (String^ value);
}

See Also

IOCService Interface
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
IOCService..::.Command Property
IOCService Interface See Also

[This is preliminary documentation and is subject to change.]

The service command to manipulate the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get ();
    void set (BusinessConstants..::.OCServiceCommand value);
}

See Also

IOCService Interface
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
IOCService..::.Lock Property
IOCService Interface See Also

[This is preliminary documentation and is subject to change.]

Shows whether the object is locked for editing

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
bool Lock { get; set; }
Visual Basic (Declaration)
Property Lock As Boolean
Visual C++
property bool Lock {
    bool get ();
    void set (bool value);
}

See Also

IOCService Interface
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
IOCService..::.Sid Property
IOCService Interface See Also

[This is preliminary documentation and is subject to change.]

The service id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
string Sid { get; set; }
Visual Basic (Declaration)
Property Sid As String
Visual C++
property String^ Sid {
    String^ get ();
    void set (String^ value);
}

See Also

IOCService Interface
OfficeClip.BusinessLayer.Service Namespace


MetaValue Class

[image]

OfficeClip API Documentation
MetaValue Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a contact

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaValue
Visual Basic (Declaration)
Public Class MetaValue
Visual C++
public ref class MetaValue

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.MetaValue

See Also

MetaValue Members
OfficeClip.BusinessLayer.Service Namespace


MetaValue Members

[image] [image]

OfficeClip API Documentation
MetaValue Members
MetaValue Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaValue type exposes the following members.

Constructors

 | Name | Description
Public method | MetaValue | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttrId | The unique id of the attribute
Public property | ColName | The name of the column
Public property | Val | The value

See Also

MetaValue Class
OfficeClip.BusinessLayer.Service Namespace


MetaValue Constructor

[image] [image]

OfficeClip API Documentation
MetaValue Constructor
MetaValue Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaValue()()() | The default constructor for serialization
Public method | MetaValue(Int32, String, String) | Construct a task object from the task id

See Also

MetaValue Class
MetaValue Members
OfficeClip.BusinessLayer.Service Namespace


MetaValue Constructor

[image]

OfficeClip API Documentation
MetaValue Constructor
MetaValue Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaValue()

See Also

MetaValue Class
MetaValue Overload
OfficeClip.BusinessLayer.Service Namespace


MetaValue Constructor (Int32, String, String)

[image]

OfficeClip API Documentation
MetaValue Constructor (Int32, String, String)
MetaValue Class See Also

[This is preliminary documentation and is subject to change.]

Construct a task object from the task id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaValue(
    int attrId,
    string colName,
    string val
)
Visual Basic (Declaration)
Public Sub New ( _
    attrId As Integer, _
    colName As String, _
    val As String _
)
Visual C++
public:
MetaValue(
    int attrId,
    String^ colName,
    String^ val
)

Parameters

attrId
Type: System..::.Int32
The unique id of the attribute
colName
Type: System..::.String
The name of the column
val
Type: System..::.String
The column value

See Also

MetaValue Class
MetaValue Overload
OfficeClip.BusinessLayer.Service Namespace


MetaValue Methods

[image] [image]

OfficeClip API Documentation
MetaValue Methods
MetaValue Class See Also

[This is preliminary documentation and is subject to change.]

The MetaValue type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaValue Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
MetaValue..::.Dump Method
MetaValue Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

The string representation of the object

See Also

MetaValue Class
OfficeClip.BusinessLayer.Service Namespace


MetaValue Properties

[image] [image]

OfficeClip API Documentation
MetaValue Properties
MetaValue Class See Also

[This is preliminary documentation and is subject to change.]

The MetaValue type exposes the following properties.

Properties

 | Name | Description
Public property | AttrId | The unique id of the attribute
Public property | ColName | The name of the column
Public property | Val | The value

See Also

MetaValue Class
OfficeClip.BusinessLayer.Service Namespace


AttrId Property

[image]

OfficeClip API Documentation
MetaValue..::.AttrId Property
MetaValue Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the attribute

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AttrId { get; set; }
Visual Basic (Declaration)
Public Property AttrId As Integer
Visual C++
public:
property int AttrId {
    int get ();
    void set (int value);
}

See Also

MetaValue Class
OfficeClip.BusinessLayer.Service Namespace


ColName Property

[image]

OfficeClip API Documentation
MetaValue..::.ColName Property
MetaValue Class See Also

[This is preliminary documentation and is subject to change.]

The name of the column

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ColName { get; set; }
Visual Basic (Declaration)
Public Property ColName As String
Visual C++
public:
property String^ ColName {
    String^ get ();
    void set (String^ value);
}

See Also

MetaValue Class
OfficeClip.BusinessLayer.Service Namespace


Val Property

[image]

OfficeClip API Documentation
MetaValue..::.Val Property
MetaValue Class See Also

[This is preliminary documentation and is subject to change.]

The value

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Val { get; set; }
Visual Basic (Declaration)
Public Property Val As String
Visual C++
public:
property String^ Val {
    String^ get ();
    void set (String^ value);
}

See Also

MetaValue Class
OfficeClip.BusinessLayer.Service Namespace


OCContact Class

[image]

OfficeClip API Documentation
OCContact Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a contact

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCContact : OCService, IOCService
Visual Basic (Declaration)
Public Class OCContact _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCContact : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCContact

See Also

OCContact Members
OfficeClip.BusinessLayer.Service Namespace


OCContact Members

[image] [image]

OfficeClip API Documentation
OCContact Members
OCContact Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCContact type exposes the following members.

Constructors

 | Name | Description
Public method | OCContact | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Attachments | Gets the events object
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Events | Gets the events object
Public property | History | Gets the events object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | MetaValues | Gets the contactinfo object
Public property | Notes | Gets the events object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | Tasks | Gets the tasks object

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


OCContact Constructor

[image] [image]

OfficeClip API Documentation
OCContact Constructor
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCContact()()() | The default constructor for serialization
Public method | OCContact(Int32) | Construct a contact object from the contact id
Public method | OCContact(Int32, array<MetaValue>[]()[], array<OCTask>[]()[], array<OCEvent>[]()[], array<OCNote>[]()[], array<HistoryInfo>[]()[], array<String>[]()[]) | Constructor to load the values of the object

See Also

OCContact Class
OCContact Members
OfficeClip.BusinessLayer.Service Namespace


OCContact Constructor

[image]

OfficeClip API Documentation
OCContact Constructor
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCContact()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCContact()

See Also

OCContact Class
OCContact Overload
OfficeClip.BusinessLayer.Service Namespace


OCContact Constructor (Int32)

[image]

OfficeClip API Documentation
OCContact Constructor (Int32)
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

Construct a contact object from the contact id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCContact(
    int contactId
)
Visual Basic (Declaration)
Public Sub New ( _
    contactId As Integer _
)
Visual C++
public:
OCContact(
    int contactId
)

Parameters

contactId
Type: System..::.Int32
The unique id of the contact

See Also

OCContact Class
OCContact Overload
OfficeClip.BusinessLayer.Service Namespace


OCContact Constructor (Int32, MetaValue[], OCTask[], OCEvent[], OCNote[], HistoryInfo[], String[])

[image]

OfficeClip API Documentation
OCContact Constructor (Int32, array<MetaValue>[]()[], array<OCTask>[]()[], array<OCEvent>[]()[], array<OCNote>[]()[], array<HistoryInfo>[]()[], array<String>[]()[])
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCContact(
    int contactId,
    MetaValue[] metaValues,
    OCTask[] tasks,
    OCEvent[] events,
    OCNote[] notes,
    HistoryInfo[] history,
    string[] attachments
)
Visual Basic (Declaration)
Public Sub New ( _
    contactId As Integer, _
    metaValues As MetaValue(), _
    tasks As OCTask(), _
    events As OCEvent(), _
    notes As OCNote(), _
    history As HistoryInfo(), _
    attachments As String() _
)
Visual C++
public:
OCContact(
    int contactId,
    array<MetaValue^>^ metaValues,
    array<OCTask^>^ tasks,
    array<OCEvent^>^ events,
    array<OCNote^>^ notes,
    array<HistoryInfo^>^ history,
    array<String^>^ attachments
)

Parameters

contactId
Type: System..::.Int32
The unique id of the contact
metaValues
Type: array< OfficeClip.BusinessLayer.Service..::.MetaValue >[]()[]
Array of metavalue objects
tasks
Type: array< OfficeClip.BusinessLayer.Service..::.OCTask >[]()[]
Array of task objects
events
Type: array< OfficeClip.BusinessLayer.Service..::.OCEvent >[]()[]
Array of events object
notes
Type: array< OfficeClip.BusinessLayer.Service..::.OCNote >[]()[]
Array of notes objects
history
Type: array< OfficeClip.BusinessLayer.Metabase..::.HistoryInfo >[]()[]
Array of history objects
attachments
Type: array<System..::.String>[]()[]
Array of attachment objects

See Also

OCContact Class
OCContact Overload
OfficeClip.BusinessLayer.Service Namespace


OCContact Methods

[image] [image]

OfficeClip API Documentation
OCContact Methods
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

The OCContact type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCContact..::.Dump Method
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


OCContact Properties

[image] [image]

OfficeClip API Documentation
OCContact Properties
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

The OCContact type exposes the following properties.

Properties

 | Name | Description
Public property | Attachments | Gets the events object
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Events | Gets the events object
Public property | History | Gets the events object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | MetaValues | Gets the contactinfo object
Public property | Notes | Gets the events object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | Tasks | Gets the tasks object

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


Attachments Property

[image]

OfficeClip API Documentation
OCContact..::.Attachments Property
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

Gets the events object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string[] Attachments { get; set; }
Visual Basic (Declaration)
Public Property Attachments As String()
Visual C++
public:
property array<String^>^ Attachments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCContact..::.Checksum Property
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCContact..::.Command Property
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


Events Property

[image]

OfficeClip API Documentation
OCContact..::.Events Property
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

Gets the events object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCEvent[] Events { get; set; }
Visual Basic (Declaration)
Public Property Events As OCEvent()
Visual C++
public:
property array<OCEvent^>^ Events {
    array<OCEvent^>^ get ();
    void set (array<OCEvent^>^ value);
}

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


History Property

[image]

OfficeClip API Documentation
OCContact..::.History Property
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

Gets the events object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public HistoryInfo[] History { get; set; }
Visual Basic (Declaration)
Public Property History As HistoryInfo()
Visual C++
public:
property array<HistoryInfo^>^ History {
    array<HistoryInfo^>^ get ();
    void set (array<HistoryInfo^>^ value);
}

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCContact..::.Lock Property
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


MetaValues Property

[image]

OfficeClip API Documentation
OCContact..::.MetaValues Property
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

Gets the contactinfo object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaValue[] MetaValues { get; set; }
Visual Basic (Declaration)
Public Property MetaValues As MetaValue()
Visual C++
public:
property array<MetaValue^>^ MetaValues {
    array<MetaValue^>^ get ();
    void set (array<MetaValue^>^ value);
}

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


Notes Property

[image]

OfficeClip API Documentation
OCContact..::.Notes Property
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

Gets the events object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCNote[] Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As OCNote()
Visual C++
public:
property array<OCNote^>^ Notes {
    array<OCNote^>^ get ();
    void set (array<OCNote^>^ value);
}

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCContact..::.Sid Property
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


Tasks Property

[image]

OfficeClip API Documentation
OCContact..::.Tasks Property
OCContact Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tasks object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTask[] Tasks { get; set; }
Visual Basic (Declaration)
Public Property Tasks As OCTask()
Visual C++
public:
property array<OCTask^>^ Tasks {
    array<OCTask^>^ get ();
    void set (array<OCTask^>^ value);
}

See Also

OCContact Class
OfficeClip.BusinessLayer.Service Namespace


OCContacts Class

[image]

OfficeClip API Documentation
OCContacts Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a contact

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCContacts : OCService, IOCService
Visual Basic (Declaration)
Public Class OCContacts _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCContacts : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCContacts

See Also

OCContacts Members
OfficeClip.BusinessLayer.Service Namespace


OCContacts Members

[image] [image]

OfficeClip API Documentation
OCContacts Members
OCContacts Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCContacts type exposes the following members.

Constructors

 | Name | Description
Public method | OCContacts | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Contacts | Gets the array of contact objects
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | MetaInfos | Gets the array of metainfo objects
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCContacts Class
OfficeClip.BusinessLayer.Service Namespace


OCContacts Constructor

[image] [image]

OfficeClip API Documentation
OCContacts Constructor
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCContacts()()() | The default constructor for serialization
Public method | OCContacts(Int32) | Construct a contact object from the contact id
Public method | OCContacts(Int32, array<OCContact>[]()[], array<OCMetaInfo>[]()[]) | Constructor to load the values of the contacts

See Also

OCContacts Class
OCContacts Members
OfficeClip.BusinessLayer.Service Namespace


OCContacts Constructor

[image]

OfficeClip API Documentation
OCContacts Constructor
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCContacts()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCContacts()

See Also

OCContacts Class
OCContacts Overload
OfficeClip.BusinessLayer.Service Namespace


OCContacts Constructor (Int32)

[image]

OfficeClip API Documentation
OCContacts Constructor (Int32)
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

Construct a contact object from the contact id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCContacts(
    int groupId
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer _
)
Visual C++
public:
OCContacts(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the contact

See Also

OCContacts Class
OCContacts Overload
OfficeClip.BusinessLayer.Service Namespace


OCContacts Constructor (Int32, OCContact[], OCMetaInfo[])

[image]

OfficeClip API Documentation
OCContacts Constructor (Int32, array<OCContact>[]()[], array<OCMetaInfo>[]()[])
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the contacts

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCContacts(
    int groupId,
    OCContact[] contacts,
    OCMetaInfo[] metaInfos
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    contacts As OCContact(), _
    metaInfos As OCMetaInfo() _
)
Visual C++
public:
OCContacts(
    int groupId,
    array<OCContact^>^ contacts,
    array<OCMetaInfo^>^ metaInfos
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
contacts
Type: array< OfficeClip.BusinessLayer.Service..::.OCContact >[]()[]
The array of contact objects
metaInfos
Type: array< OfficeClip.BusinessLayer.Service..::.OCMetaInfo >[]()[]
The array of ocmetainfo objects

See Also

OCContacts Class
OCContacts Overload
OfficeClip.BusinessLayer.Service Namespace


OCContacts Methods

[image] [image]

OfficeClip API Documentation
OCContacts Methods
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

The OCContacts type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCContacts Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCContacts..::.Dump Method
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCContacts Class
OfficeClip.BusinessLayer.Service Namespace


OCContacts Properties

[image] [image]

OfficeClip API Documentation
OCContacts Properties
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

The OCContacts type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Contacts | Gets the array of contact objects
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | MetaInfos | Gets the array of metainfo objects
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCContacts Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCContacts..::.Checksum Property
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCContacts Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCContacts..::.Command Property
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCContacts Class
OfficeClip.BusinessLayer.Service Namespace


Contacts Property

[image]

OfficeClip API Documentation
OCContacts..::.Contacts Property
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

Gets the array of contact objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCContact[] Contacts { get; set; }
Visual Basic (Declaration)
Public Property Contacts As OCContact()
Visual C++
public:
property array<OCContact^>^ Contacts {
    array<OCContact^>^ get ();
    void set (array<OCContact^>^ value);
}

See Also

OCContacts Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCContacts..::.Lock Property
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCContacts Class
OfficeClip.BusinessLayer.Service Namespace


MetaInfos Property

[image]

OfficeClip API Documentation
OCContacts..::.MetaInfos Property
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

Gets the array of metainfo objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCMetaInfo[] MetaInfos { get; set; }
Visual Basic (Declaration)
Public Property MetaInfos As OCMetaInfo()
Visual C++
public:
property array<OCMetaInfo^>^ MetaInfos {
    array<OCMetaInfo^>^ get ();
    void set (array<OCMetaInfo^>^ value);
}

See Also

OCContacts Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCContacts..::.Sid Property
OCContacts Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCContacts Class
OfficeClip.BusinessLayer.Service Namespace


OCEvent Class

[image]

OfficeClip API Documentation
OCEvent Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a task

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCEvent : OCService, IOCService
Visual Basic (Declaration)
Public Class OCEvent _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCEvent : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCEvent

See Also

OCEvent Members
OfficeClip.BusinessLayer.Service Namespace


OCEvent Members

[image] [image]

OfficeClip API Documentation
OCEvent Members
OCEvent Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCEvent type exposes the following members.

Constructors

 | Name | Description
Public method | OCEvent | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | EventInfo | Gets the taskinfo object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCEvent Class
OfficeClip.BusinessLayer.Service Namespace


OCEvent Constructor

[image] [image]

OfficeClip API Documentation
OCEvent Constructor
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCEvent()()() | The default constructor for serialization
Public method | OCEvent(Int32) | Construct an event object from the task id
Public method | OCEvent(EventInfo) | Constructor to load the values of the object

See Also

OCEvent Class
OCEvent Members
OfficeClip.BusinessLayer.Service Namespace


OCEvent Constructor

[image]

OfficeClip API Documentation
OCEvent Constructor
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCEvent()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCEvent()

See Also

OCEvent Class
OCEvent Overload
OfficeClip.BusinessLayer.Service Namespace


OCEvent Constructor (Int32)

[image]

OfficeClip API Documentation
OCEvent Constructor (Int32)
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

Construct an event object from the task id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCEvent(
    int eventId
)
Visual Basic (Declaration)
Public Sub New ( _
    eventId As Integer _
)
Visual C++
public:
OCEvent(
    int eventId
)

Parameters

eventId
Type: System..::.Int32
The unique id of the event

See Also

OCEvent Class
OCEvent Overload
OfficeClip.BusinessLayer.Service Namespace


OCEvent Constructor (EventInfo)

[image]

OfficeClip API Documentation
OCEvent Constructor (EventInfo)
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCEvent(
    EventInfo eventInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    eventInfo As EventInfo _
)
Visual C++
public:
OCEvent(
    EventInfo^ eventInfo
)

Parameters

eventInfo
Type: OfficeClip.BusinessLayer.Desktop..::.EventInfo
The event info to load values in the object

See Also

OCEvent Class
OCEvent Overload
OfficeClip.BusinessLayer.Service Namespace


OCEvent Methods

[image] [image]

OfficeClip API Documentation
OCEvent Methods
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

The OCEvent type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCEvent Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCEvent..::.Dump Method
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCEvent Class
OfficeClip.BusinessLayer.Service Namespace


OCEvent Properties

[image] [image]

OfficeClip API Documentation
OCEvent Properties
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

The OCEvent type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | EventInfo | Gets the taskinfo object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCEvent Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCEvent..::.Checksum Property
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCEvent Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCEvent..::.Command Property
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCEvent Class
OfficeClip.BusinessLayer.Service Namespace


EventInfo Property

[image]

OfficeClip API Documentation
OCEvent..::.EventInfo Property
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

Gets the taskinfo object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventInfo EventInfo { get; set; }
Visual Basic (Declaration)
Public Property EventInfo As EventInfo
Visual C++
public:
property EventInfo^ EventInfo {
    EventInfo^ get ();
    void set (EventInfo^ value);
}

See Also

OCEvent Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCEvent..::.Lock Property
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCEvent Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCEvent..::.Sid Property
OCEvent Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCEvent Class
OfficeClip.BusinessLayer.Service Namespace


OCGroupEvents Class

[image]

OfficeClip API Documentation
OCGroupEvents Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a task

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCGroupEvents : OCService, IOCService
Visual Basic (Declaration)
Public Class OCGroupEvents _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCGroupEvents : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCGroupEvents

See Also

OCGroupEvents Members
OfficeClip.BusinessLayer.Service Namespace


OCGroupEvents Members

[image] [image]

OfficeClip API Documentation
OCGroupEvents Members
OCGroupEvents Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCGroupEvents type exposes the following members.

Constructors

 | Name | Description
Public method | OCGroupEvents | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Events | Gets the taskinfo object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCGroupEvents Class
OfficeClip.BusinessLayer.Service Namespace


OCGroupEvents Constructor

[image] [image]

OfficeClip API Documentation
OCGroupEvents Constructor
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCGroupEvents()()() | The default constructor for serialization
Public method | OCGroupEvents(Int32) | Construct an event object from the group id
Public method | OCGroupEvents(Int32, array<EventInfo>[]()[]) | Constructor to load the values of the object
Public method | OCGroupEvents(Int32, array<OCEvent>[]()[]) | Constructor to load the values of the object

See Also

OCGroupEvents Class
OCGroupEvents Members
OfficeClip.BusinessLayer.Service Namespace


OCGroupEvents Constructor

[image]

OfficeClip API Documentation
OCGroupEvents Constructor
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCGroupEvents()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCGroupEvents()

See Also

OCGroupEvents Class
OCGroupEvents Overload
OfficeClip.BusinessLayer.Service Namespace


OCGroupEvents Constructor (Int32)

[image]

OfficeClip API Documentation
OCGroupEvents Constructor (Int32)
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

Construct an event object from the group id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCGroupEvents(
    int groupId
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer _
)
Visual C++
public:
OCGroupEvents(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

See Also

OCGroupEvents Class
OCGroupEvents Overload
OfficeClip.BusinessLayer.Service Namespace


OCGroupEvents Constructor (Int32, EventInfo[])

[image]

OfficeClip API Documentation
OCGroupEvents Constructor (Int32, array<EventInfo>[]()[])
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCGroupEvents(
    int groupId,
    EventInfo[] eventInfos
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    eventInfos As EventInfo() _
)
Visual C++
public:
OCGroupEvents(
    int groupId,
    array<EventInfo^>^ eventInfos
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
eventInfos
Type: array< OfficeClip.BusinessLayer.Desktop..::.EventInfo >[]()[]
The event info array to load values in the object

See Also

OCGroupEvents Class
OCGroupEvents Overload
OfficeClip.BusinessLayer.Service Namespace


OCGroupEvents Constructor (Int32, OCEvent[])

[image]

OfficeClip API Documentation
OCGroupEvents Constructor (Int32, array<OCEvent>[]()[])
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCGroupEvents(
    int groupId,
    OCEvent[] events
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    events As OCEvent() _
)
Visual C++
public:
OCGroupEvents(
    int groupId,
    array<OCEvent^>^ events
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
events
Type: array< OfficeClip.BusinessLayer.Service..::.OCEvent >[]()[]
The array of events

See Also

OCGroupEvents Class
OCGroupEvents Overload
OfficeClip.BusinessLayer.Service Namespace


OCGroupEvents Methods

[image] [image]

OfficeClip API Documentation
OCGroupEvents Methods
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

The OCGroupEvents type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCGroupEvents Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCGroupEvents..::.Dump Method
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCGroupEvents Class
OfficeClip.BusinessLayer.Service Namespace


OCGroupEvents Properties

[image] [image]

OfficeClip API Documentation
OCGroupEvents Properties
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

The OCGroupEvents type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Events | Gets the taskinfo object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCGroupEvents Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCGroupEvents..::.Checksum Property
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCGroupEvents Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCGroupEvents..::.Command Property
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCGroupEvents Class
OfficeClip.BusinessLayer.Service Namespace


Events Property

[image]

OfficeClip API Documentation
OCGroupEvents..::.Events Property
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

Gets the taskinfo object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCEvent[] Events { get; set; }
Visual Basic (Declaration)
Public Property Events As OCEvent()
Visual C++
public:
property array<OCEvent^>^ Events {
    array<OCEvent^>^ get ();
    void set (array<OCEvent^>^ value);
}

See Also

OCGroupEvents Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCGroupEvents..::.Lock Property
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCGroupEvents Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCGroupEvents..::.Sid Property
OCGroupEvents Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCGroupEvents Class
OfficeClip.BusinessLayer.Service Namespace


OCMap Class

[image]

OfficeClip API Documentation
OCMap Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to map the felds of the OfficeClip object with the external object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCMap
Visual Basic (Declaration)
Public Class OCMap
Visual C++
public ref class OCMap

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCMap

See Also

OCMap Members
OfficeClip.BusinessLayer.Service Namespace


OCMap Members

[image] [image]

OfficeClip API Documentation
OCMap Members
OCMap Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCMap type exposes the following members.

Constructors

 | Name | Description
Public method | OCMap | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DestinationCheckSum | The checksum of the destination
Public property | DestinationId | The unique id of the destination object
Public property | IsOkay | True if the value is okay, false otherwise
Public property | SourceId | The unique id of the source object

See Also

OCMap Class
OfficeClip.BusinessLayer.Service Namespace


OCMap Constructor

[image] [image]

OfficeClip API Documentation
OCMap Constructor
OCMap Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCMap()()() | The default constructor
Public method | OCMap(String, String, String, Boolean) | Constructor

See Also

OCMap Class
OCMap Members
OfficeClip.BusinessLayer.Service Namespace


OCMap Constructor

[image]

OfficeClip API Documentation
OCMap Constructor
OCMap Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCMap()

See Also

OCMap Class
OCMap Overload
OfficeClip.BusinessLayer.Service Namespace


OCMap Constructor (String, String, String, Boolean)

[image]

OfficeClip API Documentation
OCMap Constructor (String, String, String, Boolean)
OCMap Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap(
    string sourceId,
    string destinationId,
    string destinationCheckSum,
    bool isOkay
)
Visual Basic (Declaration)
Public Sub New ( _
    sourceId As String, _
    destinationId As String, _
    destinationCheckSum As String, _
    isOkay As Boolean _
)
Visual C++
public:
OCMap(
    String^ sourceId,
    String^ destinationId,
    String^ destinationCheckSum,
    bool isOkay
)

Parameters

sourceId
Type: System..::.String
The id of the source object
destinationId
Type: System..::.String
The id of the destination object
destinationCheckSum
Type: System..::.String
The destination checksum
isOkay
Type: System..::.Boolean
true if the mapping is okay false otherwise

See Also

OCMap Class
OCMap Overload
OfficeClip.BusinessLayer.Service Namespace


OCMap Properties

[image] [image]

OfficeClip API Documentation
OCMap Properties
OCMap Class See Also

[This is preliminary documentation and is subject to change.]

The OCMap type exposes the following properties.

Properties

 | Name | Description
Public property | DestinationCheckSum | The checksum of the destination
Public property | DestinationId | The unique id of the destination object
Public property | IsOkay | True if the value is okay, false otherwise
Public property | SourceId | The unique id of the source object

See Also

OCMap Class
OfficeClip.BusinessLayer.Service Namespace


DestinationCheckSum Property

[image]

OfficeClip API Documentation
OCMap..::.DestinationCheckSum Property
OCMap Class See Also

[This is preliminary documentation and is subject to change.]

The checksum of the destination

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DestinationCheckSum { get; set; }
Visual Basic (Declaration)
Public Property DestinationCheckSum As String
Visual C++
public:
property String^ DestinationCheckSum {
    String^ get ();
    void set (String^ value);
}

See Also

OCMap Class
OfficeClip.BusinessLayer.Service Namespace


DestinationId Property

[image]

OfficeClip API Documentation
OCMap..::.DestinationId Property
OCMap Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the destination object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DestinationId { get; set; }
Visual Basic (Declaration)
Public Property DestinationId As String
Visual C++
public:
property String^ DestinationId {
    String^ get ();
    void set (String^ value);
}

See Also

OCMap Class
OfficeClip.BusinessLayer.Service Namespace


IsOkay Property

[image]

OfficeClip API Documentation
OCMap..::.IsOkay Property
OCMap Class See Also

[This is preliminary documentation and is subject to change.]

True if the value is okay, false otherwise

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsOkay { get; set; }
Visual Basic (Declaration)
Public Property IsOkay As Boolean
Visual C++
public:
property bool IsOkay {
    bool get ();
    void set (bool value);
}

See Also

OCMap Class
OfficeClip.BusinessLayer.Service Namespace


SourceId Property

[image]

OfficeClip API Documentation
OCMap..::.SourceId Property
OCMap Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the source object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SourceId { get; set; }
Visual Basic (Declaration)
Public Property SourceId As String
Visual C++
public:
property String^ SourceId {
    String^ get ();
    void set (String^ value);
}

See Also

OCMap Class
OfficeClip.BusinessLayer.Service Namespace


OCMetaInfo Class

[image]

OfficeClip API Documentation
OCMetaInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a meta information object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCMetaInfo : OCService, IOCService
Visual Basic (Declaration)
Public Class OCMetaInfo _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCMetaInfo : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCMetaInfo

See Also

OCMetaInfo Members
OfficeClip.BusinessLayer.Service Namespace


OCMetaInfo Members

[image] [image]

OfficeClip API Documentation
OCMetaInfo Members
OCMetaInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCMetaInfo type exposes the following members.

Constructors

 | Name | Description
Public method | OCMetaInfo | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | MetaInfo | Gets the meta information object
Public property | MetaLists | Gets the meta list information object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCMetaInfo Class
OfficeClip.BusinessLayer.Service Namespace


OCMetaInfo Constructor

[image] [image]

OfficeClip API Documentation
OCMetaInfo Constructor
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCMetaInfo()()() | The default constructor for serialization
Public method | OCMetaInfo(MetaConstants..::.MetaEntity, Int32) | Construct a metainfo object from the entity id and attribute id
Public method | OCMetaInfo(MetaConstants..::.MetaEntity, MetaInfo, array<MetaListInfo>[]()[]) | Constructor to create a metainfo object

See Also

OCMetaInfo Class
OCMetaInfo Members
OfficeClip.BusinessLayer.Service Namespace


OCMetaInfo Constructor

[image]

OfficeClip API Documentation
OCMetaInfo Constructor
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCMetaInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCMetaInfo()

See Also

OCMetaInfo Class
OCMetaInfo Overload
OfficeClip.BusinessLayer.Service Namespace


OCMetaInfo Constructor (MetaConstants.MetaEntity, Int32)

[image]

OfficeClip API Documentation
OCMetaInfo Constructor (MetaConstants..::.MetaEntity, Int32)
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Construct a metainfo object from the entity id and attribute id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCMetaInfo(
    MetaConstants..::.MetaEntity entity,
    int attrId
)
Visual Basic (Declaration)
Public Sub New ( _
    entity As MetaConstants..::.MetaEntity, _
    attrId As Integer _
)
Visual C++
public:
OCMetaInfo(
    MetaConstants..::.MetaEntity entity,
    int attrId
)

Parameters

entity
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The unique id of the entity. E.g. Contact is an entity
attrId
Type: System..::.Int32
The unique id of the attribute

See Also

OCMetaInfo Class
OCMetaInfo Overload
OfficeClip.BusinessLayer.Service Namespace


OCMetaInfo Constructor (MetaConstants.MetaEntity, MetaInfo, MetaListInfo[])

[image]

OfficeClip API Documentation
OCMetaInfo Constructor (MetaConstants..::.MetaEntity, MetaInfo, array<MetaListInfo>[]()[])
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create a metainfo object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCMetaInfo(
    MetaConstants..::.MetaEntity entity,
    MetaInfo metaInfo,
    MetaListInfo[] metaLists
)
Visual Basic (Declaration)
Public Sub New ( _
    entity As MetaConstants..::.MetaEntity, _
    metaInfo As MetaInfo, _
    metaLists As MetaListInfo() _
)
Visual C++
public:
OCMetaInfo(
    MetaConstants..::.MetaEntity entity,
    MetaInfo^ metaInfo,
    array<MetaListInfo^>^ metaLists
)

Parameters

entity
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The unique id of the entity. E.g. Contact is an entity
metaInfo
Type: OfficeClip.BusinessLayer.Metabase..::.MetaInfo
The meta information object
metaLists
Type: array< OfficeClip.BusinessLayer.Metabase..::.MetaListInfo >[]()[]
The array of metalists objects

See Also

OCMetaInfo Class
OCMetaInfo Overload
OfficeClip.BusinessLayer.Service Namespace


OCMetaInfo Methods

[image] [image]

OfficeClip API Documentation
OCMetaInfo Methods
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The OCMetaInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCMetaInfo Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCMetaInfo..::.Dump Method
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCMetaInfo Class
OfficeClip.BusinessLayer.Service Namespace


OCMetaInfo Properties

[image] [image]

OfficeClip API Documentation
OCMetaInfo Properties
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The OCMetaInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | MetaInfo | Gets the meta information object
Public property | MetaLists | Gets the meta list information object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCMetaInfo Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCMetaInfo..::.Checksum Property
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCMetaInfo Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCMetaInfo..::.Command Property
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCMetaInfo Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCMetaInfo..::.Lock Property
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCMetaInfo Class
OfficeClip.BusinessLayer.Service Namespace


MetaInfo Property

[image]

OfficeClip API Documentation
OCMetaInfo..::.MetaInfo Property
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta information object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaInfo MetaInfo { get; set; }
Visual Basic (Declaration)
Public Property MetaInfo As MetaInfo
Visual C++
public:
property MetaInfo^ MetaInfo {
    MetaInfo^ get ();
    void set (MetaInfo^ value);
}

See Also

OCMetaInfo Class
OfficeClip.BusinessLayer.Service Namespace


MetaLists Property

[image]

OfficeClip API Documentation
OCMetaInfo..::.MetaLists Property
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta list information object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public MetaListInfo[] MetaLists { get; set; }
Visual Basic (Declaration)
Public Property MetaLists As MetaListInfo()
Visual C++
public:
property array<MetaListInfo^>^ MetaLists {
    array<MetaListInfo^>^ get ();
    void set (array<MetaListInfo^>^ value);
}

See Also

OCMetaInfo Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCMetaInfo..::.Sid Property
OCMetaInfo Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCMetaInfo Class
OfficeClip.BusinessLayer.Service Namespace


OCNote Class

[image]

OfficeClip API Documentation
OCNote Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a note

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCNote : OCService, IOCService
Visual Basic (Declaration)
Public Class OCNote _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCNote : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCNote

See Also

OCNote Members
OfficeClip.BusinessLayer.Service Namespace


OCNote Members

[image] [image]

OfficeClip API Documentation
OCNote Members
OCNote Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCNote type exposes the following members.

Constructors

 | Name | Description
Public method | OCNote | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | NoteInfo | Gets the noteinfo object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCNote Class
OfficeClip.BusinessLayer.Service Namespace


OCNote Constructor

[image] [image]

OfficeClip API Documentation
OCNote Constructor
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCNote()()() | The default constructor for serialization
Public method | OCNote(Int32) | Construct a note object from the note id
Public method | OCNote(NoteInfo) | Constructor to load the values of the object

See Also

OCNote Class
OCNote Members
OfficeClip.BusinessLayer.Service Namespace


OCNote Constructor

[image]

OfficeClip API Documentation
OCNote Constructor
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCNote()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCNote()

See Also

OCNote Class
OCNote Overload
OfficeClip.BusinessLayer.Service Namespace


OCNote Constructor (Int32)

[image]

OfficeClip API Documentation
OCNote Constructor (Int32)
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

Construct a note object from the note id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCNote(
    int noteId
)
Visual Basic (Declaration)
Public Sub New ( _
    noteId As Integer _
)
Visual C++
public:
OCNote(
    int noteId
)

Parameters

noteId
Type: System..::.Int32
The unique id of the note

See Also

OCNote Class
OCNote Overload
OfficeClip.BusinessLayer.Service Namespace


OCNote Constructor (NoteInfo)

[image]

OfficeClip API Documentation
OCNote Constructor (NoteInfo)
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCNote(
    NoteInfo noteInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    noteInfo As NoteInfo _
)
Visual C++
public:
OCNote(
    NoteInfo^ noteInfo
)

Parameters

noteInfo
Type: OfficeClip.BusinessLayer.OfficePortal..::.NoteInfo
The note info to load values in the object

See Also

OCNote Class
OCNote Overload
OfficeClip.BusinessLayer.Service Namespace


OCNote Methods

[image] [image]

OfficeClip API Documentation
OCNote Methods
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

The OCNote type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCNote Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCNote..::.Dump Method
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCNote Class
OfficeClip.BusinessLayer.Service Namespace


OCNote Properties

[image] [image]

OfficeClip API Documentation
OCNote Properties
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

The OCNote type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | NoteInfo | Gets the noteinfo object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCNote Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCNote..::.Checksum Property
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCNote Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCNote..::.Command Property
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCNote Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCNote..::.Lock Property
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCNote Class
OfficeClip.BusinessLayer.Service Namespace


NoteInfo Property

[image]

OfficeClip API Documentation
OCNote..::.NoteInfo Property
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

Gets the noteinfo object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public NoteInfo NoteInfo { get; set; }
Visual Basic (Declaration)
Public Property NoteInfo As NoteInfo
Visual C++
public:
property NoteInfo^ NoteInfo {
    NoteInfo^ get ();
    void set (NoteInfo^ value);
}

See Also

OCNote Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCNote..::.Sid Property
OCNote Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCNote Class
OfficeClip.BusinessLayer.Service Namespace


OCPrivateEvents Class

[image]

OfficeClip API Documentation
OCPrivateEvents Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a task

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCPrivateEvents : OCService, IOCService
Visual Basic (Declaration)
Public Class OCPrivateEvents _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCPrivateEvents : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCPrivateEvents

See Also

OCPrivateEvents Members
OfficeClip.BusinessLayer.Service Namespace


OCPrivateEvents Members

[image] [image]

OfficeClip API Documentation
OCPrivateEvents Members
OCPrivateEvents Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCPrivateEvents type exposes the following members.

Constructors

 | Name | Description
Public method | OCPrivateEvents | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Events | Gets the taskinfo object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCPrivateEvents Class
OfficeClip.BusinessLayer.Service Namespace


OCPrivateEvents Constructor

[image] [image]

OfficeClip API Documentation
OCPrivateEvents Constructor
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCPrivateEvents()()() | The default constructor for serialization
Public method | OCPrivateEvents(Int32) | Construct an user object
Public method | OCPrivateEvents(Int32, array<EventInfo>[]()[]) | Constructor to load the values of the object
Public method | OCPrivateEvents(Int32, array<OCEvent>[]()[]) | Constructor to load the values of the object

See Also

OCPrivateEvents Class
OCPrivateEvents Members
OfficeClip.BusinessLayer.Service Namespace


OCPrivateEvents Constructor

[image]

OfficeClip API Documentation
OCPrivateEvents Constructor
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCPrivateEvents()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCPrivateEvents()

See Also

OCPrivateEvents Class
OCPrivateEvents Overload
OfficeClip.BusinessLayer.Service Namespace


OCPrivateEvents Constructor (Int32)

[image]

OfficeClip API Documentation
OCPrivateEvents Constructor (Int32)
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

Construct an user object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCPrivateEvents(
    int userId
)
Visual Basic (Declaration)
Public Sub New ( _
    userId As Integer _
)
Visual C++
public:
OCPrivateEvents(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user

See Also

OCPrivateEvents Class
OCPrivateEvents Overload
OfficeClip.BusinessLayer.Service Namespace


OCPrivateEvents Constructor (Int32, EventInfo[])

[image]

OfficeClip API Documentation
OCPrivateEvents Constructor (Int32, array<EventInfo>[]()[])
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCPrivateEvents(
    int userId,
    EventInfo[] eventInfos
)
Visual Basic (Declaration)
Public Sub New ( _
    userId As Integer, _
    eventInfos As EventInfo() _
)
Visual C++
public:
OCPrivateEvents(
    int userId,
    array<EventInfo^>^ eventInfos
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
eventInfos
Type: array< OfficeClip.BusinessLayer.Desktop..::.EventInfo >[]()[]
The array of event info to load values in the object

See Also

OCPrivateEvents Class
OCPrivateEvents Overload
OfficeClip.BusinessLayer.Service Namespace


OCPrivateEvents Constructor (Int32, OCEvent[])

[image]

OfficeClip API Documentation
OCPrivateEvents Constructor (Int32, array<OCEvent>[]()[])
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCPrivateEvents(
    int userId,
    OCEvent[] events
)
Visual Basic (Declaration)
Public Sub New ( _
    userId As Integer, _
    events As OCEvent() _
)
Visual C++
public:
OCPrivateEvents(
    int userId,
    array<OCEvent^>^ events
)

Parameters

userId
Type: System..::.Int32
The unique id of the object
events
Type: array< OfficeClip.BusinessLayer.Service..::.OCEvent >[]()[]
The event array object

See Also

OCPrivateEvents Class
OCPrivateEvents Overload
OfficeClip.BusinessLayer.Service Namespace


OCPrivateEvents Methods

[image] [image]

OfficeClip API Documentation
OCPrivateEvents Methods
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

The OCPrivateEvents type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCPrivateEvents Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCPrivateEvents..::.Dump Method
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCPrivateEvents Class
OfficeClip.BusinessLayer.Service Namespace


OCPrivateEvents Properties

[image] [image]

OfficeClip API Documentation
OCPrivateEvents Properties
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

The OCPrivateEvents type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Events | Gets the taskinfo object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCPrivateEvents Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCPrivateEvents..::.Checksum Property
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCPrivateEvents Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCPrivateEvents..::.Command Property
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCPrivateEvents Class
OfficeClip.BusinessLayer.Service Namespace


Events Property

[image]

OfficeClip API Documentation
OCPrivateEvents..::.Events Property
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

Gets the taskinfo object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCEvent[] Events { get; set; }
Visual Basic (Declaration)
Public Property Events As OCEvent()
Visual C++
public:
property array<OCEvent^>^ Events {
    array<OCEvent^>^ get ();
    void set (array<OCEvent^>^ value);
}

See Also

OCPrivateEvents Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCPrivateEvents..::.Lock Property
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCPrivateEvents Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCPrivateEvents..::.Sid Property
OCPrivateEvents Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCPrivateEvents Class
OfficeClip.BusinessLayer.Service Namespace


OCRole Class

[image]

OfficeClip API Documentation
OCRole Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a role collection

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCRole : OCService, IOCService
Visual Basic (Declaration)
Public Class OCRole _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCRole : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCRole

See Also

OCRole Members
OfficeClip.BusinessLayer.Service Namespace


OCRole Members

[image] [image]

OfficeClip API Documentation
OCRole Members
OCRole Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCRole type exposes the following members.

Constructors

 | Name | Description
Public method | OCRole | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | RoleInfo | The role info object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCRole Class
OfficeClip.BusinessLayer.Service Namespace


OCRole Constructor

[image] [image]

OfficeClip API Documentation
OCRole Constructor
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCRole()()() | The default constructor for serialization
Public method | OCRole(RoleInfo) | Constructor to load the values of the object
Public method | OCRole(Int32, Int32) | Construct a role object from the role id

See Also

OCRole Class
OCRole Members
OfficeClip.BusinessLayer.Service Namespace


OCRole Constructor

[image]

OfficeClip API Documentation
OCRole Constructor
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCRole()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCRole()

See Also

OCRole Class
OCRole Overload
OfficeClip.BusinessLayer.Service Namespace


OCRole Constructor (RoleInfo)

[image]

OfficeClip API Documentation
OCRole Constructor (RoleInfo)
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCRole(
    RoleInfo roleInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    roleInfo As RoleInfo _
)
Visual C++
public:
OCRole(
    RoleInfo^ roleInfo
)

Parameters

roleInfo
Type: OfficeClip.BusinessLayer.Security..::.RoleInfo
The role info

See Also

OCRole Class
OCRole Overload
OfficeClip.BusinessLayer.Service Namespace


OCRole Constructor (Int32, Int32)

[image]

OfficeClip API Documentation
OCRole Constructor (Int32, Int32)
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

Construct a role object from the role id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCRole(
    int groupId,
    int roleId
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    roleId As Integer _
)
Visual C++
public:
OCRole(
    int groupId,
    int roleId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
roleId
Type: System..::.Int32
The unique id of the role

See Also

OCRole Class
OCRole Overload
OfficeClip.BusinessLayer.Service Namespace


OCRole Methods

[image] [image]

OfficeClip API Documentation
OCRole Methods
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

The OCRole type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCRole Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCRole..::.Dump Method
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCRole Class
OfficeClip.BusinessLayer.Service Namespace


OCRole Properties

[image] [image]

OfficeClip API Documentation
OCRole Properties
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

The OCRole type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | RoleInfo | The role info object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCRole Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCRole..::.Checksum Property
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCRole Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCRole..::.Command Property
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCRole Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCRole..::.Lock Property
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCRole Class
OfficeClip.BusinessLayer.Service Namespace


RoleInfo Property

[image]

OfficeClip API Documentation
OCRole..::.RoleInfo Property
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

The role info object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RoleInfo RoleInfo { get; set; }
Visual Basic (Declaration)
Public Property RoleInfo As RoleInfo
Visual C++
public:
property RoleInfo^ RoleInfo {
    RoleInfo^ get ();
    void set (RoleInfo^ value);
}

See Also

OCRole Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCRole..::.Sid Property
OCRole Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCRole Class
OfficeClip.BusinessLayer.Service Namespace


OCSecurity Class

[image]

OfficeClip API Documentation
OCSecurity Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a role collection

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCSecurity : OCService, IOCService
Visual Basic (Declaration)
Public Class OCSecurity _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCSecurity : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCSecurity

See Also

OCSecurity Members
OfficeClip.BusinessLayer.Service Namespace


OCSecurity Members

[image] [image]

OfficeClip API Documentation
OCSecurity Members
OCSecurity Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCSecurity type exposes the following members.

Constructors

 | Name | Description
Public method | OCSecurity | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRoles | Gets the array of RoleInfo object
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | OCRoles | Get the OCRoles array
Public property | OCSecurityObject | The OfficeClip security object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCSecurity Class
OfficeClip.BusinessLayer.Service Namespace


OCSecurity Constructor

[image] [image]

OfficeClip API Documentation
OCSecurity Constructor
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCSecurity()()() | The default constructor for serialization
Public method | OCSecurity(Int32) | The default constructor for serialization
Public method | OCSecurity(array<OCRole>[]()[], OCSecurityObject) | Constructor to load the values of the object

See Also

OCSecurity Class
OCSecurity Members
OfficeClip.BusinessLayer.Service Namespace


OCSecurity Constructor

[image]

OfficeClip API Documentation
OCSecurity Constructor
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCSecurity()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCSecurity()

See Also

OCSecurity Class
OCSecurity Overload
OfficeClip.BusinessLayer.Service Namespace


OCSecurity Constructor (Int32)

[image]

OfficeClip API Documentation
OCSecurity Constructor (Int32)
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCSecurity(
    int groupId
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer _
)
Visual C++
public:
OCSecurity(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

See Also

OCSecurity Class
OCSecurity Overload
OfficeClip.BusinessLayer.Service Namespace


OCSecurity Constructor (OCRole[], OCSecurityObject)

[image]

OfficeClip API Documentation
OCSecurity Constructor (array<OCRole>[]()[], OCSecurityObject)
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCSecurity(
    OCRole[] ocRoles,
    OCSecurityObject ocsecurityObject
)
Visual Basic (Declaration)
Public Sub New ( _
    ocRoles As OCRole(), _
    ocsecurityObject As OCSecurityObject _
)
Visual C++
public:
OCSecurity(
    array<OCRole^>^ ocRoles,
    OCSecurityObject^ ocsecurityObject
)

Parameters

ocRoles
Type: array< OfficeClip.BusinessLayer.Service..::.OCRole >[]()[]
The roles array
ocsecurityObject
Type: OfficeClip.BusinessLayer.Service..::.OCSecurityObject
The officeclip security object

See Also

OCSecurity Class
OCSecurity Overload
OfficeClip.BusinessLayer.Service Namespace


OCSecurity Methods

[image] [image]

OfficeClip API Documentation
OCSecurity Methods
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The OCSecurity type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetRoles | Gets the array of RoleInfo object
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCSecurity Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCSecurity..::.Dump Method
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCSecurity Class
OfficeClip.BusinessLayer.Service Namespace


GetRoles Method

[image]

OfficeClip API Documentation
OCSecurity..::.GetRoles Method
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Gets the array of RoleInfo object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RoleInfo[] GetRoles()
Visual Basic (Declaration)
Public Function GetRoles As RoleInfo()
Visual C++
public:
array<RoleInfo^>^ GetRoles()

Return Value

The array of the RoleInfo objects

See Also

OCSecurity Class
OfficeClip.BusinessLayer.Service Namespace


OCSecurity Properties

[image] [image]

OfficeClip API Documentation
OCSecurity Properties
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The OCSecurity type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | OCRoles | Get the OCRoles array
Public property | OCSecurityObject | The OfficeClip security object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCSecurity Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCSecurity..::.Checksum Property
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCSecurity Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCSecurity..::.Command Property
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCSecurity Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCSecurity..::.Lock Property
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCSecurity Class
OfficeClip.BusinessLayer.Service Namespace


OCRoles Property

[image]

OfficeClip API Documentation
OCSecurity..::.OCRoles Property
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Get the OCRoles array

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCRole[] OCRoles { get; set; }
Visual Basic (Declaration)
Public Property OCRoles As OCRole()
Visual C++
public:
property array<OCRole^>^ OCRoles {
    array<OCRole^>^ get ();
    void set (array<OCRole^>^ value);
}

See Also

OCSecurity Class
OfficeClip.BusinessLayer.Service Namespace


OCSecurityObject Property

[image]

OfficeClip API Documentation
OCSecurity..::.OCSecurityObject Property
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The OfficeClip security object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCSecurityObject OCSecurityObject { get; set; }
Visual Basic (Declaration)
Public Property OCSecurityObject As OCSecurityObject
Visual C++
public:
property OCSecurityObject^ OCSecurityObject {
    OCSecurityObject^ get ();
    void set (OCSecurityObject^ value);
}

See Also

OCSecurity Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCSecurity..::.Sid Property
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCSecurity Class
OfficeClip.BusinessLayer.Service Namespace


OCSecurityObject Class

[image]

OfficeClip API Documentation
OCSecurityObject Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a role collection

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCSecurityObject : OCService, IOCService
Visual Basic (Declaration)
Public Class OCSecurityObject _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCSecurityObject : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCSecurityObject

See Also

OCSecurityObject Members
OfficeClip.BusinessLayer.Service Namespace


OCSecurityObject Members

[image] [image]

OfficeClip API Documentation
OCSecurityObject Members
OCSecurityObject Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCSecurityObject type exposes the following members.

Constructors

 | Name | Description
Public method | OCSecurityObject | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | SecurityObjects | The array of security objects
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCSecurityObject Class
OfficeClip.BusinessLayer.Service Namespace


OCSecurityObject Constructor

[image] [image]

OfficeClip API Documentation
OCSecurityObject Constructor
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCSecurityObject()()() | The default constructor for serialization
Public method | OCSecurityObject(Int32) | Construct a security object from the group id
Public method | OCSecurityObject(array<SecurityObject>[]()[]) | Constructor to load the values of the object

See Also

OCSecurityObject Class
OCSecurityObject Members
OfficeClip.BusinessLayer.Service Namespace


OCSecurityObject Constructor

[image]

OfficeClip API Documentation
OCSecurityObject Constructor
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCSecurityObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCSecurityObject()

See Also

OCSecurityObject Class
OCSecurityObject Overload
OfficeClip.BusinessLayer.Service Namespace


OCSecurityObject Constructor (Int32)

[image]

OfficeClip API Documentation
OCSecurityObject Constructor (Int32)
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

Construct a security object from the group id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCSecurityObject(
    int groupId
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer _
)
Visual C++
public:
OCSecurityObject(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

See Also

OCSecurityObject Class
OCSecurityObject Overload
OfficeClip.BusinessLayer.Service Namespace


OCSecurityObject Constructor (SecurityObject[])

[image]

OfficeClip API Documentation
OCSecurityObject Constructor (array<SecurityObject>[]()[])
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCSecurityObject(
    SecurityObject[] sobs
)
Visual Basic (Declaration)
Public Sub New ( _
    sobs As SecurityObject() _
)
Visual C++
public:
OCSecurityObject(
    array<SecurityObject^>^ sobs
)

Parameters

sobs
Type: array< OfficeClip.BusinessLayer.Security..::.SecurityObject >[]()[]
The aary of security object

See Also

OCSecurityObject Class
OCSecurityObject Overload
OfficeClip.BusinessLayer.Service Namespace


OCSecurityObject Methods

[image] [image]

OfficeClip API Documentation
OCSecurityObject Methods
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The OCSecurityObject type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCSecurityObject Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCSecurityObject..::.Dump Method
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCSecurityObject Class
OfficeClip.BusinessLayer.Service Namespace


OCSecurityObject Properties

[image] [image]

OfficeClip API Documentation
OCSecurityObject Properties
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The OCSecurityObject type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | SecurityObjects | The array of security objects
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCSecurityObject Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCSecurityObject..::.Checksum Property
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCSecurityObject Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCSecurityObject..::.Command Property
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCSecurityObject Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCSecurityObject..::.Lock Property
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCSecurityObject Class
OfficeClip.BusinessLayer.Service Namespace


SecurityObjects Property

[image]

OfficeClip API Documentation
OCSecurityObject..::.SecurityObjects Property
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

The array of security objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObject[] SecurityObjects { get; set; }
Visual Basic (Declaration)
Public Property SecurityObjects As SecurityObject()
Visual C++
public:
property array<SecurityObject^>^ SecurityObjects {
    array<SecurityObject^>^ get ();
    void set (array<SecurityObject^>^ value);
}

See Also

OCSecurityObject Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCSecurityObject..::.Sid Property
OCSecurityObject Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCSecurityObject Class
OfficeClip.BusinessLayer.Service Namespace


OCService Class

[image]

OfficeClip API Documentation
OCService Class
Members See Also

[This is preliminary documentation and is subject to change.]

Base class for all the OfficeClip Services

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCService : IOCService
Visual Basic (Declaration)
Public Class OCService _
    Implements IOCService
Visual C++
public ref class OCService : IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCEvent
OfficeClip.BusinessLayer.Service..::.OCGroupEvents
OfficeClip.BusinessLayer.Service..::.OCTrackerCase
OfficeClip.BusinessLayer.Service..::.OCSecurity
OfficeClip.BusinessLayer.Service..::.OCPrivateEvents
OfficeClip.BusinessLayer.Service..::.OCTrackerFields
OfficeClip.BusinessLayer.Service..::.OCNote
OfficeClip.BusinessLayer.Service..::.OCSecurityObject
OfficeClip.BusinessLayer.Service..::.OCContact
OfficeClip.BusinessLayer.Service..::.OCTasks
OfficeClip.BusinessLayer.Service..::.OCMetaInfo
OfficeClip.BusinessLayer.Service..::.OCUser
OfficeClip.BusinessLayer.Service..::.OCContacts
OfficeClip.BusinessLayer.Service..::.OCTrackerField
OfficeClip.BusinessLayer.Service..::.OCUsers
OfficeClip.BusinessLayer.Service..::.OCTrackerProject
OfficeClip.BusinessLayer.Service..::.OCTask
OfficeClip.BusinessLayer.Service..::.OCRole

See Also

OCService Members
OfficeClip.BusinessLayer.Service Namespace


OCService Members

[image] [image]

OfficeClip API Documentation
OCService Members
OCService Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCService type exposes the following members.

Constructors

 | Name | Description
Public method | OCService | Overloaded.

Methods

 | Name | Description
Public method | Dump | The dump of this object for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveCommand | The resolve command
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp
Public property | Command | Commands to be executed on this object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object
Public property | Sid | A unique service id, unique across all the OCService objects

See Also

OCService Class
OfficeClip.BusinessLayer.Service Namespace


OCService Constructor

[image] [image]

OfficeClip API Documentation
OCService Constructor
OCService Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCService()()() | The default constructor for serialization
Public method | OCService(OCServiceType, Int32) | The service constructor
Public method | OCService(String, Boolean, BusinessConstants..::.OCServiceCommand) | Constructor of the service
Public method | OCService(OCServiceType, Int32, Int32) | The service constructor

See Also

OCService Class
OCService Members
OfficeClip.BusinessLayer.Service Namespace


OCService Constructor

[image]

OfficeClip API Documentation
OCService Constructor
OCService Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCService()

See Also

OCService Class
OCService Overload
OfficeClip.BusinessLayer.Service Namespace


OCService Constructor (OCServiceType, Int32)

[image]

OfficeClip API Documentation
OCService Constructor (OCServiceType, Int32)
OCService Class See Also

[This is preliminary documentation and is subject to change.]

The service constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCService(
    OCServiceType ost,
    int primaryId
)
Visual Basic (Declaration)
Public Sub New ( _
    ost As OCServiceType, _
    primaryId As Integer _
)
Visual C++
public:
OCService(
    OCServiceType ost,
    int primaryId
)

Parameters

ost
Type: OfficeClip.Utils..::.OCServiceType
The service type, determines the type of the object
primaryId
Type: System..::.Int32
The primary id of the service type

See Also

OCService Class
OCService Overload
OfficeClip.BusinessLayer.Service Namespace


OCService Constructor (String, Boolean, BusinessConstants.OCServiceCommand)

[image]

OfficeClip API Documentation
OCService Constructor (String, Boolean, BusinessConstants..::.OCServiceCommand)
OCService Class See Also

[This is preliminary documentation and is subject to change.]

Constructor of the service

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCService(
    string sid,
    bool lck,
    BusinessConstants..::.OCServiceCommand command
)
Visual Basic (Declaration)
Public Sub New ( _
    sid As String, _
    lck As Boolean, _
    command As BusinessConstants..::.OCServiceCommand _
)
Visual C++
public:
OCService(
    String^ sid,
    bool lck,
    BusinessConstants..::.OCServiceCommand command
)

Parameters

sid
Type: System..::.String
The service identifier
lck
Type: System..::.Boolean
The lock
command
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.OCServiceCommand
The command to execute

See Also

OCService Class
OCService Overload
OfficeClip.BusinessLayer.Service Namespace


OCService Constructor (OCServiceType, Int32, Int32)

[image]

OfficeClip API Documentation
OCService Constructor (OCServiceType, Int32, Int32)
OCService Class See Also

[This is preliminary documentation and is subject to change.]

The service constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCService(
    OCServiceType ost,
    int primaryId,
    int secondaryId
)
Visual Basic (Declaration)
Public Sub New ( _
    ost As OCServiceType, _
    primaryId As Integer, _
    secondaryId As Integer _
)
Visual C++
public:
OCService(
    OCServiceType ost,
    int primaryId,
    int secondaryId
)

Parameters

ost
Type: OfficeClip.Utils..::.OCServiceType
The service type, determines the type of the objcet
primaryId
Type: System..::.Int32
The primary id of the service type
secondaryId
Type: System..::.Int32
The secondary id of the service type

See Also

OCService Class
OCService Overload
OfficeClip.BusinessLayer.Service Namespace


OCService Methods

[image] [image]

OfficeClip API Documentation
OCService Methods
OCService Class See Also

[This is preliminary documentation and is subject to change.]

The OCService type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | The dump of this object for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveCommand | The resolve command
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCService Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCService..::.Dump Method
OCService Class See Also

[This is preliminary documentation and is subject to change.]

The dump of this object for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public virtual string Dump()
Visual Basic (Declaration)
Public Overridable Function Dump As String
Visual C++
public:
virtual String^ Dump()

Return Value

The dump of this object

Implements

IOCService..::.Dump()()()

See Also

OCService Class
OfficeClip.BusinessLayer.Service Namespace


ResolveCommand Method

[image]

OfficeClip API Documentation
OCService..::.ResolveCommand Method
OCService Class See Also

[This is preliminary documentation and is subject to change.]

The resolve command

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static BusinessConstants..::.OCServiceCommand ResolveCommand(
    OCServiceImportPolicy policy,
    BusinessConstants..::.OCServiceCommand command,
    bool isPresent,
    string sid
)
Visual Basic (Declaration)
Public Shared Function ResolveCommand ( _
    policy As OCServiceImportPolicy, _
    command As BusinessConstants..::.OCServiceCommand, _
    isPresent As Boolean, _
    sid As String _
) As BusinessConstants..::.OCServiceCommand
Visual C++
public:
static BusinessConstants..::.OCServiceCommand ResolveCommand(
    OCServiceImportPolicy policy,
    BusinessConstants..::.OCServiceCommand command,
    bool isPresent,
    String^ sid
)

Parameters

policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
command
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.OCServiceCommand
isPresent
Type: System..::.Boolean
sid
Type: System..::.String

Return Value

See Also

OCService Class
OfficeClip.BusinessLayer.Service Namespace


OCService Properties

[image] [image]

OfficeClip API Documentation
OCService Properties
OCService Class See Also

[This is preliminary documentation and is subject to change.]

The OCService type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp
Public property | Command | Commands to be executed on this object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object
Public property | Sid | A unique service id, unique across all the OCService objects

See Also

OCService Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCService..::.Checksum Property
OCService Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public virtual string Checksum { get; set; }
Visual Basic (Declaration)
Public Overridable Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get ();
    void set (String^ value);
}

Implements

IOCService..::.Checksum

See Also

OCService Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCService..::.Command Property
OCService Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public virtual BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overridable Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get ();
    void set (BusinessConstants..::.OCServiceCommand value);
}

Implements

IOCService..::.Command

See Also

OCService Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCService..::.Lock Property
OCService Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public virtual bool Lock { get; set; }
Visual Basic (Declaration)
Public Overridable Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get ();
    void set (bool value);
}

Implements

IOCService..::.Lock

See Also

OCService Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCService..::.Sid Property
OCService Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public virtual string Sid { get; set; }
Visual Basic (Declaration)
Public Overridable Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get ();
    void set (String^ value);
}

Implements

IOCService..::.Sid

See Also

OCService Class
OfficeClip.BusinessLayer.Service Namespace


OCSystem Class

[image]

OfficeClip API Documentation
OCSystem Class
Members See Also

[This is preliminary documentation and is subject to change.]

The class to hold the system information

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCSystem
Visual Basic (Declaration)
Public Class OCSystem
Visual C++
public ref class OCSystem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCSystem

See Also

OCSystem Members
OfficeClip.BusinessLayer.Service Namespace


OCSystem Members

[image] [image]

OfficeClip API Documentation
OCSystem Members
OCSystem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCSystem type exposes the following members.

Constructors

 | Name | Description
Public method | OCSystem | Overloaded.

Methods

 | Name | Description
Public method | AddSystemContent | Adds a system content object to the class
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveSystemContent | Removes the system content
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SystemContents | The array of system contents
Public property | UserId | The unique id of the user

See Also

OCSystem Class
OfficeClip.BusinessLayer.Service Namespace


OCSystem Constructor

[image] [image]

OfficeClip API Documentation
OCSystem Constructor
OCSystem Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCSystem()()() | The default constructor
Public method | OCSystem(Int32, array<SystemContent>[]()[]) | Constructor

See Also

OCSystem Class
OCSystem Members
OfficeClip.BusinessLayer.Service Namespace


OCSystem Constructor

[image]

OfficeClip API Documentation
OCSystem Constructor
OCSystem Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCSystem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCSystem()

See Also

OCSystem Class
OCSystem Overload
OfficeClip.BusinessLayer.Service Namespace


OCSystem Constructor (Int32, SystemContent[])

[image]

OfficeClip API Documentation
OCSystem Constructor (Int32, array<SystemContent>[]()[])
OCSystem Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCSystem(
    int userId,
    SystemContent[] systemContents
)
Visual Basic (Declaration)
Public Sub New ( _
    userId As Integer, _
    systemContents As SystemContent() _
)
Visual C++
public:
OCSystem(
    int userId,
    array<SystemContent^>^ systemContents
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
systemContents
Type: array< OfficeClip.BusinessLayer.Service..::.SystemContent >[]()[]
The array of system content objects

See Also

OCSystem Class
OCSystem Overload
OfficeClip.BusinessLayer.Service Namespace


OCSystem Methods

[image] [image]

OfficeClip API Documentation
OCSystem Methods
OCSystem Class See Also

[This is preliminary documentation and is subject to change.]

The OCSystem type exposes the following methods.

Methods

 | Name | Description
Public method | AddSystemContent | Adds a system content object to the class
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveSystemContent | Removes the system content
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCSystem Class
OfficeClip.BusinessLayer.Service Namespace


AddSystemContent Method

[image]

OfficeClip API Documentation
OCSystem..::.AddSystemContent Method
OCSystem Class See Also

[This is preliminary documentation and is subject to change.]

Adds a system content object to the class

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void AddSystemContent(
    SystemContent systemContent
)
Visual Basic (Declaration)
Public Sub AddSystemContent ( _
    systemContent As SystemContent _
)
Visual C++
public:
void AddSystemContent(
    SystemContent^ systemContent
)

Parameters

systemContent
Type: OfficeClip.BusinessLayer.Service..::.SystemContent
The system content object

See Also

OCSystem Class
OfficeClip.BusinessLayer.Service Namespace


RemoveSystemContent Method

[image]

OfficeClip API Documentation
OCSystem..::.RemoveSystemContent Method
OCSystem Class See Also

[This is preliminary documentation and is subject to change.]

Removes the system content

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void RemoveSystemContent(
    int groupId
)
Visual Basic (Declaration)
Public Sub RemoveSystemContent ( _
    groupId As Integer _
)
Visual C++
public:
void RemoveSystemContent(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

See Also

OCSystem Class
OfficeClip.BusinessLayer.Service Namespace


OCSystem Properties

[image] [image]

OfficeClip API Documentation
OCSystem Properties
OCSystem Class See Also

[This is preliminary documentation and is subject to change.]

The OCSystem type exposes the following properties.

Properties

 | Name | Description
Public property | SystemContents | The array of system contents
Public property | UserId | The unique id of the user

See Also

OCSystem Class
OfficeClip.BusinessLayer.Service Namespace


SystemContents Property

[image]

OfficeClip API Documentation
OCSystem..::.SystemContents Property
OCSystem Class See Also

[This is preliminary documentation and is subject to change.]

The array of system contents

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public SystemContent[] SystemContents { get; set; }
Visual Basic (Declaration)
Public Property SystemContents As SystemContent()
Visual C++
public:
property array<SystemContent^>^ SystemContents {
    array<SystemContent^>^ get ();
    void set (array<SystemContent^>^ value);
}

See Also

OCSystem Class
OfficeClip.BusinessLayer.Service Namespace


UserId Property

[image]

OfficeClip API Documentation
OCSystem..::.UserId Property
OCSystem Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

OCSystem Class
OfficeClip.BusinessLayer.Service Namespace


OCTask Class

[image]

OfficeClip API Documentation
OCTask Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a task

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCTask : OCService, IOCService
Visual Basic (Declaration)
Public Class OCTask _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCTask : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCTask

See Also

OCTask Members
OfficeClip.BusinessLayer.Service Namespace


OCTask Members

[image] [image]

OfficeClip API Documentation
OCTask Members
OCTask Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCTask type exposes the following members.

Constructors

 | Name | Description
Public method | OCTask | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | TaskInfo | Gets the taskinfo object

See Also

OCTask Class
OfficeClip.BusinessLayer.Service Namespace


OCTask Constructor

[image] [image]

OfficeClip API Documentation
OCTask Constructor
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCTask()()() | The default constructor for serialization
Public method | OCTask(Int32) | Construct a task object from the task id
Public method | OCTask(TaskInfo) | Constructor to load the values of the object

See Also

OCTask Class
OCTask Members
OfficeClip.BusinessLayer.Service Namespace


OCTask Constructor

[image]

OfficeClip API Documentation
OCTask Constructor
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTask()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCTask()

See Also

OCTask Class
OCTask Overload
OfficeClip.BusinessLayer.Service Namespace


OCTask Constructor (Int32)

[image]

OfficeClip API Documentation
OCTask Constructor (Int32)
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

Construct a task object from the task id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTask(
    int taskId
)
Visual Basic (Declaration)
Public Sub New ( _
    taskId As Integer _
)
Visual C++
public:
OCTask(
    int taskId
)

Parameters

taskId
Type: System..::.Int32
The unique id of the task

See Also

OCTask Class
OCTask Overload
OfficeClip.BusinessLayer.Service Namespace


OCTask Constructor (TaskInfo)

[image]

OfficeClip API Documentation
OCTask Constructor (TaskInfo)
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTask(
    TaskInfo taskInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    taskInfo As TaskInfo _
)
Visual C++
public:
OCTask(
    TaskInfo^ taskInfo
)

Parameters

taskInfo
Type: OfficeClip.BusinessLayer.Desktop..::.TaskInfo
The task info to load values in the object

See Also

OCTask Class
OCTask Overload
OfficeClip.BusinessLayer.Service Namespace


OCTask Methods

[image] [image]

OfficeClip API Documentation
OCTask Methods
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

The OCTask type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCTask Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCTask..::.Dump Method
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCTask Class
OfficeClip.BusinessLayer.Service Namespace


OCTask Properties

[image] [image]

OfficeClip API Documentation
OCTask Properties
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

The OCTask type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | TaskInfo | Gets the taskinfo object

See Also

OCTask Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCTask..::.Checksum Property
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCTask Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCTask..::.Command Property
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCTask Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCTask..::.Lock Property
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCTask Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCTask..::.Sid Property
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCTask Class
OfficeClip.BusinessLayer.Service Namespace


TaskInfo Property

[image]

OfficeClip API Documentation
OCTask..::.TaskInfo Property
OCTask Class See Also

[This is preliminary documentation and is subject to change.]

Gets the taskinfo object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TaskInfo TaskInfo { get; set; }
Visual Basic (Declaration)
Public Property TaskInfo As TaskInfo
Visual C++
public:
property TaskInfo^ TaskInfo {
    TaskInfo^ get ();
    void set (TaskInfo^ value);
}

See Also

OCTask Class
OfficeClip.BusinessLayer.Service Namespace


OCTasks Class

[image]

OfficeClip API Documentation
OCTasks Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent tasks

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCTasks : OCService, IOCService
Visual Basic (Declaration)
Public Class OCTasks _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCTasks : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCTasks

See Also

OCTasks Members
OfficeClip.BusinessLayer.Service Namespace


OCTasks Members

[image] [image]

OfficeClip API Documentation
OCTasks Members
OCTasks Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCTasks type exposes the following members.

Constructors

 | Name | Description
Public method | OCTasks | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | GroupTasks | Gets the tasks object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | PrivateTasks | Gets the tasks object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCTasks Class
OfficeClip.BusinessLayer.Service Namespace


OCTasks Constructor

[image] [image]

OfficeClip API Documentation
OCTasks Constructor
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCTasks()()() | The default constructor for serialization
Public method | OCTasks(Int32, Int32) | Construct a task object from the task id
Public method | OCTasks(Int32, Int32, array<TaskInfo>[]()[], array<TaskInfo>[]()[]) | Constructor to load the values of the object
Public method | OCTasks(Int32, Int32, array<OCTask>[]()[], array<OCTask>[]()[]) | Constructor to load the values of the object

See Also

OCTasks Class
OCTasks Members
OfficeClip.BusinessLayer.Service Namespace


OCTasks Constructor

[image]

OfficeClip API Documentation
OCTasks Constructor
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTasks()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCTasks()

See Also

OCTasks Class
OCTasks Overload
OfficeClip.BusinessLayer.Service Namespace


OCTasks Constructor (Int32, Int32)

[image]

OfficeClip API Documentation
OCTasks Constructor (Int32, Int32)
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

Construct a task object from the task id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTasks(
    int groupId,
    int userId
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    userId As Integer _
)
Visual C++
public:
OCTasks(
    int groupId,
    int userId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user

See Also

OCTasks Class
OCTasks Overload
OfficeClip.BusinessLayer.Service Namespace


OCTasks Constructor (Int32, Int32, TaskInfo[], TaskInfo[])

[image]

OfficeClip API Documentation
OCTasks Constructor (Int32, Int32, array<TaskInfo>[]()[], array<TaskInfo>[]()[])
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTasks(
    int groupId,
    int userId,
    TaskInfo[] privateTaskInfos,
    TaskInfo[] groupTaskInfos
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    userId As Integer, _
    privateTaskInfos As TaskInfo(), _
    groupTaskInfos As TaskInfo() _
)
Visual C++
public:
OCTasks(
    int groupId,
    int userId,
    array<TaskInfo^>^ privateTaskInfos,
    array<TaskInfo^>^ groupTaskInfos
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user
privateTaskInfos
Type: array< OfficeClip.BusinessLayer.Desktop..::.TaskInfo >[]()[]
The array of the private task information
groupTaskInfos
Type: array< OfficeClip.BusinessLayer.Desktop..::.TaskInfo >[]()[]
The array of group task information

See Also

OCTasks Class
OCTasks Overload
OfficeClip.BusinessLayer.Service Namespace


OCTasks Constructor (Int32, Int32, OCTask[], OCTask[])

[image]

OfficeClip API Documentation
OCTasks Constructor (Int32, Int32, array<OCTask>[]()[], array<OCTask>[]()[])
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTasks(
    int groupId,
    int userId,
    OCTask[] privateTasks,
    OCTask[] groupTasks
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    userId As Integer, _
    privateTasks As OCTask(), _
    groupTasks As OCTask() _
)
Visual C++
public:
OCTasks(
    int groupId,
    int userId,
    array<OCTask^>^ privateTasks,
    array<OCTask^>^ groupTasks
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user
privateTasks
Type: array< OfficeClip.BusinessLayer.Service..::.OCTask >[]()[]
The array of the OfficeClip Private Tasks
groupTasks
Type: array< OfficeClip.BusinessLayer.Service..::.OCTask >[]()[]
The array of teh OfficeClip Group Tasks

See Also

OCTasks Class
OCTasks Overload
OfficeClip.BusinessLayer.Service Namespace


OCTasks Methods

[image] [image]

OfficeClip API Documentation
OCTasks Methods
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

The OCTasks type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCTasks Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCTasks..::.Dump Method
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCTasks Class
OfficeClip.BusinessLayer.Service Namespace


OCTasks Properties

[image] [image]

OfficeClip API Documentation
OCTasks Properties
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

The OCTasks type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | GroupTasks | Gets the tasks object
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | PrivateTasks | Gets the tasks object
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)

See Also

OCTasks Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCTasks..::.Checksum Property
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCTasks Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCTasks..::.Command Property
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCTasks Class
OfficeClip.BusinessLayer.Service Namespace


GroupTasks Property

[image]

OfficeClip API Documentation
OCTasks..::.GroupTasks Property
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tasks object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTask[] GroupTasks { get; set; }
Visual Basic (Declaration)
Public Property GroupTasks As OCTask()
Visual C++
public:
property array<OCTask^>^ GroupTasks {
    array<OCTask^>^ get ();
    void set (array<OCTask^>^ value);
}

See Also

OCTasks Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCTasks..::.Lock Property
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCTasks Class
OfficeClip.BusinessLayer.Service Namespace


PrivateTasks Property

[image]

OfficeClip API Documentation
OCTasks..::.PrivateTasks Property
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tasks object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTask[] PrivateTasks { get; set; }
Visual Basic (Declaration)
Public Property PrivateTasks As OCTask()
Visual C++
public:
property array<OCTask^>^ PrivateTasks {
    array<OCTask^>^ get ();
    void set (array<OCTask^>^ value);
}

See Also

OCTasks Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCTasks..::.Sid Property
OCTasks Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCTasks Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerCase Class

[image]

OfficeClip API Documentation
OCTrackerCase Class
Members See Also

[This is preliminary documentation and is subject to change.]

Service class for individual cases

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCTrackerCase : OCService, IOCService
Visual Basic (Declaration)
Public Class OCTrackerCase _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCTrackerCase : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCTrackerCase

See Also

OCTrackerCase Members
OfficeClip.BusinessLayer.Service Namespace


OCTrackerCase Members

[image] [image]

OfficeClip API Documentation
OCTrackerCase Members
OCTrackerCase Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerCase type exposes the following members.

Constructors

 | Name | Description
Public method | OCTrackerCase | Overloaded.

Methods

 | Name | Description
Public method | Dump | Function to dump the class values in a string (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | TrackerFieldValues | Values of the tracker fields

See Also

OCTrackerCase Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerCase Constructor

[image] [image]

OfficeClip API Documentation
OCTrackerCase Constructor
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCTrackerCase()()() | The default constructor used for serialization purposes
Public method | OCTrackerCase(OCTrackerCase) | The copy constructor
Public method | OCTrackerCase(TrackerCaseInfo) | Constructor to create an instance from the tracker case information
Public method | OCTrackerCase(array<TrackerFieldValue>[]()[]) | Constructor to create an instance from fields

See Also

OCTrackerCase Class
OCTrackerCase Members
OfficeClip.BusinessLayer.Service Namespace


OCTrackerCase Constructor

[image]

OfficeClip API Documentation
OCTrackerCase Constructor
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor used for serialization purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerCase()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCTrackerCase()

See Also

OCTrackerCase Class
OCTrackerCase Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerCase Constructor (OCTrackerCase)

[image]

OfficeClip API Documentation
OCTrackerCase Constructor (OCTrackerCase)
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

The copy constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerCase(
    OCTrackerCase octc
)
Visual Basic (Declaration)
Public Sub New ( _
    octc As OCTrackerCase _
)
Visual C++
public:
OCTrackerCase(
    OCTrackerCase^ octc
)

Parameters

octc
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerCase
The OfficeClip Tracker Case object

See Also

OCTrackerCase Class
OCTrackerCase Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerCase Constructor (TrackerCaseInfo)

[image]

OfficeClip API Documentation
OCTrackerCase Constructor (TrackerCaseInfo)
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the tracker case information

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerCase(
    TrackerCaseInfo tci
)
Visual Basic (Declaration)
Public Sub New ( _
    tci As TrackerCaseInfo _
)
Visual C++
public:
OCTrackerCase(
    TrackerCaseInfo^ tci
)

Parameters

tci
Type: OfficeClip.BusinessLayer.Tracker..::.TrackerCaseInfo
The tracker case information

See Also

OCTrackerCase Class
OCTrackerCase Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerCase Constructor (TrackerFieldValue[])

[image]

OfficeClip API Documentation
OCTrackerCase Constructor (array<TrackerFieldValue>[]()[])
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from fields

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerCase(
    TrackerFieldValue[] field
)
Visual Basic (Declaration)
Public Sub New ( _
    field As TrackerFieldValue() _
)
Visual C++
public:
OCTrackerCase(
    array<TrackerFieldValue^>^ field
)

Parameters

field
Type: array< OfficeClip.BusinessLayer.Service..::.TrackerFieldValue >[]()[]
A collection of all the tracker fields

See Also

OCTrackerCase Class
OCTrackerCase Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerCase Methods

[image] [image]

OfficeClip API Documentation
OCTrackerCase Methods
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerCase type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Function to dump the class values in a string (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCTrackerCase Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCTrackerCase..::.Dump Method
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

Function to dump the class values in a string

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The dump of class values in a string

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCTrackerCase Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerCase Properties

[image] [image]

OfficeClip API Documentation
OCTrackerCase Properties
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerCase type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | TrackerFieldValues | Values of the tracker fields

See Also

OCTrackerCase Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCTrackerCase..::.Checksum Property
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCTrackerCase Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCTrackerCase..::.Command Property
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCTrackerCase Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCTrackerCase..::.Lock Property
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCTrackerCase Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCTrackerCase..::.Sid Property
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCTrackerCase Class
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldValues Property

[image]

OfficeClip API Documentation
OCTrackerCase..::.TrackerFieldValues Property
OCTrackerCase Class See Also

[This is preliminary documentation and is subject to change.]

Values of the tracker fields

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerFieldValue[] TrackerFieldValues { get; set; }
Visual Basic (Declaration)
Public Property TrackerFieldValues As TrackerFieldValue()
Visual C++
public:
property array<TrackerFieldValue^>^ TrackerFieldValues {
    array<TrackerFieldValue^>^ get ();
    void set (array<TrackerFieldValue^>^ value);
}

See Also

OCTrackerCase Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerField Class

[image]

OfficeClip API Documentation
OCTrackerField Class
Members See Also

[This is preliminary documentation and is subject to change.]

Represents a single field of the tracker project

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCTrackerField : OCService, IOCService
Visual Basic (Declaration)
Public Class OCTrackerField _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCTrackerField : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCTrackerField

See Also

OCTrackerField Members
OfficeClip.BusinessLayer.Service Namespace


OCTrackerField Members

[image] [image]

OfficeClip API Documentation
OCTrackerField Members
OCTrackerField Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerField type exposes the following members.

Constructors

 | Name | Description
Public method | OCTrackerField | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Id | The id of the field
Public property | IsMandatory | True if the field is mandatory
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Name | The name of the field
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | TrackerFieldListArgs | The list of field arguments
Public property | Type | The type of the field

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerField Constructor

[image] [image]

OfficeClip API Documentation
OCTrackerField Constructor
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCTrackerField()()() | The default constructor for serialization
Public method | OCTrackerField(Int32, String, String, array<TrackerFieldListArg>[]()[], Boolean) | Constructor to create the instance from parts
Public method | OCTrackerField(Int32, String, String, DataSet%, Boolean) | constructor to create the instance from the parts

See Also

OCTrackerField Class
OCTrackerField Members
OfficeClip.BusinessLayer.Service Namespace


OCTrackerField Constructor

[image]

OfficeClip API Documentation
OCTrackerField Constructor
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerField()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCTrackerField()

See Also

OCTrackerField Class
OCTrackerField Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerField Constructor (Int32, String, String, TrackerFieldListArg[], Boolean)

[image]

OfficeClip API Documentation
OCTrackerField Constructor (Int32, String, String, array<TrackerFieldListArg>[]()[], Boolean)
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create the instance from parts

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerField(
    int id,
    string name,
    string type,
    TrackerFieldListArg[] tfla,
    bool isMandatory
)
Visual Basic (Declaration)
Public Sub New ( _
    id As Integer, _
    name As String, _
    type As String, _
    tfla As TrackerFieldListArg(), _
    isMandatory As Boolean _
)
Visual C++
public:
OCTrackerField(
    int id,
    String^ name,
    String^ type,
    array<TrackerFieldListArg^>^ tfla,
    bool isMandatory
)

Parameters

id
Type: System..::.Int32
The field id
name
Type: System..::.String
The name of the field
type
Type: System..::.String
The type of the tracker field
tfla
Type: array< OfficeClip.BusinessLayer.Service..::.TrackerFieldListArg >[]()[]
the tracker field arguments. This is currently used if the field is a list.
isMandatory
Type: System..::.Boolean
Is the field mandatory

See Also

OCTrackerField Class
OCTrackerField Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerField Constructor (Int32, String, String, DataSet, Boolean)

[image]

OfficeClip API Documentation
OCTrackerField Constructor (Int32, String, String, DataSet%, Boolean)
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

constructor to create the instance from the parts

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerField(
    int id,
    string name,
    string type,
    ref DataSet ds,
    bool isMandatory
)
Visual Basic (Declaration)
Public Sub New ( _
    id As Integer, _
    name As String, _
    type As String, _
    ByRef ds As DataSet, _
    isMandatory As Boolean _
)
Visual C++
public:
OCTrackerField(
    int id,
    String^ name,
    String^ type,
    DataSet^% ds,
    bool isMandatory
)

Parameters

id
Type: System..::.Int32
The field id
name
Type: System..::.String
The name of the field
type
Type: System..::.String
The type of the tracker field
ds
Type: System.Data..::.DataSet%
The dataset constains the description of the fields
isMandatory
Type: System..::.Boolean
true if the tracker field is mandatory

See Also

OCTrackerField Class
OCTrackerField Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerField Methods

[image] [image]

OfficeClip API Documentation
OCTrackerField Methods
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerField type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCTrackerField..::.Dump Method
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the object for debugging

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

the debug dump

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerField Properties

[image] [image]

OfficeClip API Documentation
OCTrackerField Properties
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerField type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Id | The id of the field
Public property | IsMandatory | True if the field is mandatory
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Name | The name of the field
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | TrackerFieldListArgs | The list of field arguments
Public property | Type | The type of the field

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCTrackerField..::.Checksum Property
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCTrackerField..::.Command Property
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


Id Property

[image]

OfficeClip API Documentation
OCTrackerField..::.Id Property
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

The id of the field

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Id { get; set; }
Visual Basic (Declaration)
Public Property Id As Integer
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


IsMandatory Property

[image]

OfficeClip API Documentation
OCTrackerField..::.IsMandatory Property
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

True if the field is mandatory

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsMandatory { get; set; }
Visual Basic (Declaration)
Public Property IsMandatory As Boolean
Visual C++
public:
property bool IsMandatory {
    bool get ();
    void set (bool value);
}

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCTrackerField..::.Lock Property
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


Name Property

[image]

OfficeClip API Documentation
OCTrackerField..::.Name Property
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

The name of the field

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCTrackerField..::.Sid Property
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldListArgs Property

[image]

OfficeClip API Documentation
OCTrackerField..::.TrackerFieldListArgs Property
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

The list of field arguments

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerFieldListArg[] TrackerFieldListArgs { get; set; }
Visual Basic (Declaration)
Public Property TrackerFieldListArgs As TrackerFieldListArg()
Visual C++
public:
property array<TrackerFieldListArg^>^ TrackerFieldListArgs {
    array<TrackerFieldListArg^>^ get ();
    void set (array<TrackerFieldListArg^>^ value);
}

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


Type Property

[image]

OfficeClip API Documentation
OCTrackerField..::.Type Property
OCTrackerField Class See Also

[This is preliminary documentation and is subject to change.]

The type of the field

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

OCTrackerField Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerFields Class

[image]

OfficeClip API Documentation
OCTrackerFields Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a list of fields for a project

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCTrackerFields : OCService, IOCService
Visual Basic (Declaration)
Public Class OCTrackerFields _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCTrackerFields : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCTrackerFields

See Also

OCTrackerFields Members
OfficeClip.BusinessLayer.Service Namespace


OCTrackerFields Members

[image] [image]

OfficeClip API Documentation
OCTrackerFields Members
OCTrackerFields Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerFields type exposes the following members.

Constructors

 | Name | Description
Public method | OCTrackerFields | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | TrackerFields | A List of tracker fields

See Also

OCTrackerFields Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerFields Constructor

[image] [image]

OfficeClip API Documentation
OCTrackerFields Constructor
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCTrackerFields()()() | Default constructor for serialization
Public method | OCTrackerFields(Int32) | Constructor for OfficeClip tracker fields
Public method | OCTrackerFields(array<OCTrackerField>[]()[]) | Constructor for creating an instance from a list of fields

See Also

OCTrackerFields Class
OCTrackerFields Members
OfficeClip.BusinessLayer.Service Namespace


OCTrackerFields Constructor

[image]

OfficeClip API Documentation
OCTrackerFields Constructor
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerFields()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCTrackerFields()

See Also

OCTrackerFields Class
OCTrackerFields Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerFields Constructor (Int32)

[image]

OfficeClip API Documentation
OCTrackerFields Constructor (Int32)
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for OfficeClip tracker fields

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerFields(
    int projectId
)
Visual Basic (Declaration)
Public Sub New ( _
    projectId As Integer _
)
Visual C++
public:
OCTrackerFields(
    int projectId
)

Parameters

projectId
Type: System..::.Int32
the unique id of the project

See Also

OCTrackerFields Class
OCTrackerFields Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerFields Constructor (OCTrackerField[])

[image]

OfficeClip API Documentation
OCTrackerFields Constructor (array<OCTrackerField>[]()[])
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for creating an instance from a list of fields

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerFields(
    OCTrackerField[] fields
)
Visual Basic (Declaration)
Public Sub New ( _
    fields As OCTrackerField() _
)
Visual C++
public:
OCTrackerFields(
    array<OCTrackerField^>^ fields
)

Parameters

fields
Type: array< OfficeClip.BusinessLayer.Service..::.OCTrackerField >[]()[]
A list of tracker fields

See Also

OCTrackerFields Class
OCTrackerFields Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerFields Methods

[image] [image]

OfficeClip API Documentation
OCTrackerFields Methods
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerFields type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCTrackerFields Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCTrackerFields..::.Dump Method
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the object for debugging

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

the debug dump

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCTrackerFields Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerFields Properties

[image] [image]

OfficeClip API Documentation
OCTrackerFields Properties
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerFields type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | TrackerFields | A List of tracker fields

See Also

OCTrackerFields Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCTrackerFields..::.Checksum Property
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCTrackerFields Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCTrackerFields..::.Command Property
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCTrackerFields Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCTrackerFields..::.Lock Property
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCTrackerFields Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCTrackerFields..::.Sid Property
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCTrackerFields Class
OfficeClip.BusinessLayer.Service Namespace


TrackerFields Property

[image]

OfficeClip API Documentation
OCTrackerFields..::.TrackerFields Property
OCTrackerFields Class See Also

[This is preliminary documentation and is subject to change.]

A List of tracker fields

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerField[] TrackerFields { get; set; }
Visual Basic (Declaration)
Public Property TrackerFields As OCTrackerField()
Visual C++
public:
property array<OCTrackerField^>^ TrackerFields {
    array<OCTrackerField^>^ get ();
    void set (array<OCTrackerField^>^ value);
}

See Also

OCTrackerFields Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerProject Class

[image]

OfficeClip API Documentation
OCTrackerProject Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a tracker project

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCTrackerProject : OCService, IOCService
Visual Basic (Declaration)
Public Class OCTrackerProject _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCTrackerProject : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCTrackerProject

See Also

OCTrackerProject Members
OfficeClip.BusinessLayer.Service Namespace


OCTrackerProject Members

[image] [image]

OfficeClip API Documentation
OCTrackerProject Members
OCTrackerProject Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerProject type exposes the following members.

Constructors

 | Name | Description
Public method | OCTrackerProject | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | OCTrackerFields | The tracker project fields
Public property | OCTrackerFieldValues | The tracker cases
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | TrackerProjectInfo | The tracker project information structure

See Also

OCTrackerProject Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerProject Constructor

[image] [image]

OfficeClip API Documentation
OCTrackerProject Constructor
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCTrackerProject()()() | The default constructor for serialization
Public method | OCTrackerProject(Int32) | Constructor
Public method | OCTrackerProject(OCTrackerFields, array<OCTrackerCase>[]()[], TrackerProjectInfo) | The constructor to create an instance.

See Also

OCTrackerProject Class
OCTrackerProject Members
OfficeClip.BusinessLayer.Service Namespace


OCTrackerProject Constructor

[image]

OfficeClip API Documentation
OCTrackerProject Constructor
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerProject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCTrackerProject()

See Also

OCTrackerProject Class
OCTrackerProject Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerProject Constructor (Int32)

[image]

OfficeClip API Documentation
OCTrackerProject Constructor (Int32)
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerProject(
    int projectId
)
Visual Basic (Declaration)
Public Sub New ( _
    projectId As Integer _
)
Visual C++
public:
OCTrackerProject(
    int projectId
)

Parameters

projectId
Type: System..::.Int32
the unique id of the project

See Also

OCTrackerProject Class
OCTrackerProject Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerProject Constructor (OCTrackerFields, OCTrackerCase[], TrackerProjectInfo)

[image]

OfficeClip API Documentation
OCTrackerProject Constructor (OCTrackerFields, array<OCTrackerCase>[]()[], TrackerProjectInfo)
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

The constructor to create an instance.

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerProject(
    OCTrackerFields fieldName,
    OCTrackerCase[] fieldValue,
    TrackerProjectInfo tpi
)
Visual Basic (Declaration)
Public Sub New ( _
    fieldName As OCTrackerFields, _
    fieldValue As OCTrackerCase(), _
    tpi As TrackerProjectInfo _
)
Visual C++
public:
OCTrackerProject(
    OCTrackerFields^ fieldName,
    array<OCTrackerCase^>^ fieldValue,
    TrackerProjectInfo^ tpi
)

Parameters

fieldName
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerFields
The array of the fields
fieldValue
Type: array< OfficeClip.BusinessLayer.Service..::.OCTrackerCase >[]()[]
The array of the cases
tpi
Type: OfficeClip.BusinessLayer.Tracker..::.TrackerProjectInfo
The tracker project information

See Also

OCTrackerProject Class
OCTrackerProject Overload
OfficeClip.BusinessLayer.Service Namespace


OCTrackerProject Methods

[image] [image]

OfficeClip API Documentation
OCTrackerProject Methods
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerProject type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCTrackerProject Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCTrackerProject..::.Dump Method
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the object for debugging

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

the debug dump

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCTrackerProject Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerProject Properties

[image] [image]

OfficeClip API Documentation
OCTrackerProject Properties
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

The OCTrackerProject type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | OCTrackerFields | The tracker project fields
Public property | OCTrackerFieldValues | The tracker cases
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | TrackerProjectInfo | The tracker project information structure

See Also

OCTrackerProject Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCTrackerProject..::.Checksum Property
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCTrackerProject Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCTrackerProject..::.Command Property
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCTrackerProject Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCTrackerProject..::.Lock Property
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCTrackerProject Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerFields Property

[image]

OfficeClip API Documentation
OCTrackerProject..::.OCTrackerFields Property
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

The tracker project fields

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerFields OCTrackerFields { get; set; }
Visual Basic (Declaration)
Public Property OCTrackerFields As OCTrackerFields
Visual C++
public:
property OCTrackerFields^ OCTrackerFields {
    OCTrackerFields^ get ();
    void set (OCTrackerFields^ value);
}

See Also

OCTrackerProject Class
OfficeClip.BusinessLayer.Service Namespace


OCTrackerFieldValues Property

[image]

OfficeClip API Documentation
OCTrackerProject..::.OCTrackerFieldValues Property
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

The tracker cases

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerCase[] OCTrackerFieldValues { get; set; }
Visual Basic (Declaration)
Public Property OCTrackerFieldValues As OCTrackerCase()
Visual C++
public:
property array<OCTrackerCase^>^ OCTrackerFieldValues {
    array<OCTrackerCase^>^ get ();
    void set (array<OCTrackerCase^>^ value);
}

See Also

OCTrackerProject Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCTrackerProject..::.Sid Property
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCTrackerProject Class
OfficeClip.BusinessLayer.Service Namespace


TrackerProjectInfo Property

[image]

OfficeClip API Documentation
OCTrackerProject..::.TrackerProjectInfo Property
OCTrackerProject Class See Also

[This is preliminary documentation and is subject to change.]

The tracker project information structure

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerProjectInfo TrackerProjectInfo { get; set; }
Visual Basic (Declaration)
Public Property TrackerProjectInfo As TrackerProjectInfo
Visual C++
public:
property TrackerProjectInfo^ TrackerProjectInfo {
    TrackerProjectInfo^ get ();
    void set (TrackerProjectInfo^ value);
}

See Also

OCTrackerProject Class
OfficeClip.BusinessLayer.Service Namespace


OCUser Class

[image]

OfficeClip API Documentation
OCUser Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a task

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCUser : OCService, IOCService
Visual Basic (Declaration)
Public Class OCUser _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCUser : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCUser

See Also

OCUser Members
OfficeClip.BusinessLayer.Service Namespace


OCUser Members

[image] [image]

OfficeClip API Documentation
OCUser Members
OCUser Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCUser type exposes the following members.

Constructors

 | Name | Description
Public method | OCUser | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | ServiceType | the OfficeClip service type
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | UserInfo | Gets the taskinfo object

See Also

OCUser Class
OfficeClip.BusinessLayer.Service Namespace


OCUser Constructor

[image] [image]

OfficeClip API Documentation
OCUser Constructor
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCUser()()() | The default constructor for serialization
Public method | OCUser(OCUser) | Copy constructor for OfficeClip service user
Public method | OCUser(OCServiceType, UserInfo) | Constructor to load the values of the object
Public method | OCUser(OCServiceType, Int32) | Construct a user object from the user id

See Also

OCUser Class
OCUser Members
OfficeClip.BusinessLayer.Service Namespace


OCUser Constructor

[image]

OfficeClip API Documentation
OCUser Constructor
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCUser()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCUser()

See Also

OCUser Class
OCUser Overload
OfficeClip.BusinessLayer.Service Namespace


OCUser Constructor (OCUser)

[image]

OfficeClip API Documentation
OCUser Constructor (OCUser)
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

Copy constructor for OfficeClip service user

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCUser(
    OCUser ocUser
)
Visual Basic (Declaration)
Public Sub New ( _
    ocUser As OCUser _
)
Visual C++
public:
OCUser(
    OCUser^ ocUser
)

Parameters

ocUser
Type: OfficeClip.BusinessLayer.Service..::.OCUser
The OfficeClip service user

See Also

OCUser Class
OCUser Overload
OfficeClip.BusinessLayer.Service Namespace


OCUser Constructor (OCServiceType, UserInfo)

[image]

OfficeClip API Documentation
OCUser Constructor (OCServiceType, UserInfo)
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCUser(
    OCServiceType ost,
    UserInfo userInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    ost As OCServiceType, _
    userInfo As UserInfo _
)
Visual C++
public:
OCUser(
    OCServiceType ost,
    UserInfo^ userInfo
)

Parameters

ost
Type: OfficeClip.Utils..::.OCServiceType
The OfficeClip Service type
userInfo
Type: OfficeClip.BusinessLayer.Account..::.UserInfo
The user info to load values in the object

See Also

OCUser Class
OCUser Overload
OfficeClip.BusinessLayer.Service Namespace


OCUser Constructor (OCServiceType, Int32)

[image]

OfficeClip API Documentation
OCUser Constructor (OCServiceType, Int32)
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

Construct a user object from the user id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCUser(
    OCServiceType ost,
    int userDetailId
)
Visual Basic (Declaration)
Public Sub New ( _
    ost As OCServiceType, _
    userDetailId As Integer _
)
Visual C++
public:
OCUser(
    OCServiceType ost,
    int userDetailId
)

Parameters

ost
Type: OfficeClip.Utils..::.OCServiceType
The OfficeClip Service Type
userDetailId
Type: System..::.Int32
The unique id of the user details

See Also

OCUser Class
OCUser Overload
OfficeClip.BusinessLayer.Service Namespace


OCUser Methods

[image] [image]

OfficeClip API Documentation
OCUser Methods
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

The OCUser type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCUser Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCUser..::.Dump Method
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCUser Class
OfficeClip.BusinessLayer.Service Namespace


OCUser Properties

[image] [image]

OfficeClip API Documentation
OCUser Properties
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

The OCUser type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | ServiceType | the OfficeClip service type
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | UserInfo | Gets the taskinfo object

See Also

OCUser Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCUser..::.Checksum Property
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCUser Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCUser..::.Command Property
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCUser Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCUser..::.Lock Property
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCUser Class
OfficeClip.BusinessLayer.Service Namespace


ServiceType Property

[image]

OfficeClip API Documentation
OCUser..::.ServiceType Property
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

the OfficeClip service type

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceType ServiceType { get; set; }
Visual Basic (Declaration)
Public Property ServiceType As OCServiceType
Visual C++
public:
property OCServiceType ServiceType {
    OCServiceType get ();
    void set (OCServiceType value);
}

See Also

OCUser Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCUser..::.Sid Property
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCUser Class
OfficeClip.BusinessLayer.Service Namespace


UserInfo Property

[image]

OfficeClip API Documentation
OCUser..::.UserInfo Property
OCUser Class See Also

[This is preliminary documentation and is subject to change.]

Gets the taskinfo object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserInfo UserInfo { get; set; }
Visual Basic (Declaration)
Public Property UserInfo As UserInfo
Visual C++
public:
property UserInfo^ UserInfo {
    UserInfo^ get ();
    void set (UserInfo^ value);
}

See Also

OCUser Class
OfficeClip.BusinessLayer.Service Namespace


OCUsers Class

[image]

OfficeClip API Documentation
OCUsers Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent personal address book

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCUsers : OCService, IOCService
Visual Basic (Declaration)
Public Class OCUsers _
    Inherits OCService _
    Implements IOCService
Visual C++
public ref class OCUsers : public OCService,
    IOCService

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.OCService
OfficeClip.BusinessLayer.Service..::.OCUsers

See Also

OCUsers Members
OfficeClip.BusinessLayer.Service Namespace


OCUsers Members

[image] [image]

OfficeClip API Documentation
OCUsers Members
OCUsers Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCUsers type exposes the following members.

Constructors

 | Name | Description
Public method | OCUsers | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | ServiceType | The OfficeClip Service type
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | Users | Gets the tasks object

See Also

OCUsers Class
OfficeClip.BusinessLayer.Service Namespace


OCUsers Constructor

[image] [image]

OfficeClip API Documentation
OCUsers Constructor
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCUsers()()() | The default constructor for serialization
Public method | OCUsers(OCServiceType, Int32) | Construct a task object from the task id
Public method | OCUsers(OCServiceType, Int32, array<OCUser>[]()[]) | Constructor to load the values of the object
Public method | OCUsers(OCServiceType, Int32, Int32, array<UserInfo>[]()[]) | Constructor to load the values of the object

See Also

OCUsers Class
OCUsers Members
OfficeClip.BusinessLayer.Service Namespace


OCUsers Constructor

[image]

OfficeClip API Documentation
OCUsers Constructor
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCUsers()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCUsers()

See Also

OCUsers Class
OCUsers Overload
OfficeClip.BusinessLayer.Service Namespace


OCUsers Constructor (OCServiceType, Int32)

[image]

OfficeClip API Documentation
OCUsers Constructor (OCServiceType, Int32)
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

Construct a task object from the task id

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCUsers(
    OCServiceType ost,
    int groupId
)
Visual Basic (Declaration)
Public Sub New ( _
    ost As OCServiceType, _
    groupId As Integer _
)
Visual C++
public:
OCUsers(
    OCServiceType ost,
    int groupId
)

Parameters

ost
Type: OfficeClip.Utils..::.OCServiceType
The OfficeClip service type
groupId
Type: System..::.Int32
The unique id of the group

See Also

OCUsers Class
OCUsers Overload
OfficeClip.BusinessLayer.Service Namespace


OCUsers Constructor (OCServiceType, Int32, OCUser[])

[image]

OfficeClip API Documentation
OCUsers Constructor (OCServiceType, Int32, array<OCUser>[]()[])
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCUsers(
    OCServiceType ost,
    int groupId,
    OCUser[] users
)
Visual Basic (Declaration)
Public Sub New ( _
    ost As OCServiceType, _
    groupId As Integer, _
    users As OCUser() _
)
Visual C++
public:
OCUsers(
    OCServiceType ost,
    int groupId,
    array<OCUser^>^ users
)

Parameters

ost
Type: OfficeClip.Utils..::.OCServiceType
The OfficeClip service type
groupId
Type: System..::.Int32
the unique id of the group
users
Type: array< OfficeClip.BusinessLayer.Service..::.OCUser >[]()[]
The array of OfficeClip users

See Also

OCUsers Class
OCUsers Overload
OfficeClip.BusinessLayer.Service Namespace


OCUsers Constructor (OCServiceType, Int32, Int32, UserInfo[])

[image]

OfficeClip API Documentation
OCUsers Constructor (OCServiceType, Int32, Int32, array<UserInfo>[]()[])
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to load the values of the object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCUsers(
    OCServiceType ost,
    int groupId,
    int userDetailId,
    UserInfo[] userInfos
)
Visual Basic (Declaration)
Public Sub New ( _
    ost As OCServiceType, _
    groupId As Integer, _
    userDetailId As Integer, _
    userInfos As UserInfo() _
)
Visual C++
public:
OCUsers(
    OCServiceType ost,
    int groupId,
    int userDetailId,
    array<UserInfo^>^ userInfos
)

Parameters

ost
Type: OfficeClip.Utils..::.OCServiceType
The OfficeClip service type
groupId
Type: System..::.Int32
The unique id of the group
userDetailId
Type: System..::.Int32
The unique id of the user detail
userInfos
Type: array< OfficeClip.BusinessLayer.Account..::.UserInfo >[]()[]
The user information array

See Also

OCUsers Class
OCUsers Overload
OfficeClip.BusinessLayer.Service Namespace


OCUsers Methods

[image] [image]

OfficeClip API Documentation
OCUsers Methods
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

The OCUsers type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps for debugging purposes (Overrides OCService ..::. Dump()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCUsers Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
OCUsers..::.Dump Method
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

Dumps for debugging purposes

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Dump()
Visual Basic (Declaration)
Public Overrides Function Dump As String
Visual C++
public:
virtual String^ Dump() override

Return Value

The string representation of the object

Implements

IOCService..::.Dump()()()
IOCService..::.Dump()()()

See Also

OCUsers Class
OfficeClip.BusinessLayer.Service Namespace


OCUsers Properties

[image] [image]

OfficeClip API Documentation
OCUsers Properties
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

The OCUsers type exposes the following properties.

Properties

 | Name | Description
Public property | Checksum | The checksum, used for synchronization purposes. Usually this is the last modification timestamp (Overrides OCService ..::. Checksum.)
Public property | Command | Commands to be executed on this object (Overrides OCService ..::. Command.)
Public property | Lock | The lock bit, used to determine whether editing is allowed on this object (Overrides OCService ..::. Lock.)
Public property | ServiceType | The OfficeClip Service type
Public property | Sid | A unique service id, unique across all the OCService objects (Overrides OCService ..::. Sid.)
Public property | Users | Gets the tasks object

See Also

OCUsers Class
OfficeClip.BusinessLayer.Service Namespace


Checksum Property

[image]

OfficeClip API Documentation
OCUsers..::.Checksum Property
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

The checksum, used for synchronization purposes. Usually this is the last modification timestamp

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Checksum { get; set; }
Visual Basic (Declaration)
Public Overrides Property Checksum As String
Visual C++
public:
virtual property String^ Checksum {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Checksum
IOCService..::.Checksum

See Also

OCUsers Class
OfficeClip.BusinessLayer.Service Namespace


Command Property

[image]

OfficeClip API Documentation
OCUsers..::.Command Property
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

Commands to be executed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override BusinessConstants..::.OCServiceCommand Command { get; set; }
Visual Basic (Declaration)
Public Overrides Property Command As BusinessConstants..::.OCServiceCommand
Visual C++
public:
virtual property BusinessConstants..::.OCServiceCommand Command {
    BusinessConstants..::.OCServiceCommand get () override;
    void set (BusinessConstants..::.OCServiceCommand value) override;
}

Implements

IOCService..::.Command
IOCService..::.Command

See Also

OCUsers Class
OfficeClip.BusinessLayer.Service Namespace


Lock Property

[image]

OfficeClip API Documentation
OCUsers..::.Lock Property
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

The lock bit, used to determine whether editing is allowed on this object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Lock { get; set; }
Visual Basic (Declaration)
Public Overrides Property Lock As Boolean
Visual C++
public:
virtual property bool Lock {
    bool get () override;
    void set (bool value) override;
}

Implements

IOCService..::.Lock
IOCService..::.Lock

See Also

OCUsers Class
OfficeClip.BusinessLayer.Service Namespace


ServiceType Property

[image]

OfficeClip API Documentation
OCUsers..::.ServiceType Property
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

The OfficeClip Service type

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceType ServiceType { get; set; }
Visual Basic (Declaration)
Public Property ServiceType As OCServiceType
Visual C++
public:
property OCServiceType ServiceType {
    OCServiceType get ();
    void set (OCServiceType value);
}

See Also

OCUsers Class
OfficeClip.BusinessLayer.Service Namespace


Sid Property

[image]

OfficeClip API Documentation
OCUsers..::.Sid Property
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

A unique service id, unique across all the OCService objects

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string Sid { get; set; }
Visual Basic (Declaration)
Public Overrides Property Sid As String
Visual C++
public:
virtual property String^ Sid {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IOCService..::.Sid
IOCService..::.Sid

See Also

OCUsers Class
OfficeClip.BusinessLayer.Service Namespace


Users Property

[image]

OfficeClip API Documentation
OCUsers..::.Users Property
OCUsers Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tasks object

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCUser[] Users { get; set; }
Visual Basic (Declaration)
Public Property Users As OCUser()
Visual C++
public:
property array<OCUser^>^ Users {
    array<OCUser^>^ get ();
    void set (array<OCUser^>^ value);
}

See Also

OCUsers Class
OfficeClip.BusinessLayer.Service Namespace


SystemContent Class

[image]

OfficeClip API Documentation
SystemContent Class
Members See Also

[This is preliminary documentation and is subject to change.]

The class to hold system contents

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class SystemContent
Visual Basic (Declaration)
Public Class SystemContent
Visual C++
public ref class SystemContent

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.SystemContent

See Also

SystemContent Members
OfficeClip.BusinessLayer.Service Namespace


SystemContent Members

[image] [image]

OfficeClip API Documentation
SystemContent Members
SystemContent Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The SystemContent type exposes the following members.

Constructors

 | Name | Description
Public method | SystemContent | Overloaded.

Methods

 | Name | Description
Public method | AddGroupContent | Add the group content
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveGroupContent | Remove a group content
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GroupContents | Teh array of group contents
Public property | GroupId | The unique id of the group
Public property | GroupName | The name of the group

See Also

SystemContent Class
OfficeClip.BusinessLayer.Service Namespace


SystemContent Constructor

[image] [image]

OfficeClip API Documentation
SystemContent Constructor
SystemContent Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | SystemContent()()() | The default constructor
Public method | SystemContent(Int32, String, array<GroupContent>[]()[]) | Constructor

See Also

SystemContent Class
SystemContent Members
OfficeClip.BusinessLayer.Service Namespace


SystemContent Constructor

[image]

OfficeClip API Documentation
SystemContent Constructor
SystemContent Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public SystemContent()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SystemContent()

See Also

SystemContent Class
SystemContent Overload
OfficeClip.BusinessLayer.Service Namespace


SystemContent Constructor (Int32, String, GroupContent[])

[image]

OfficeClip API Documentation
SystemContent Constructor (Int32, String, array<GroupContent>[]()[])
SystemContent Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public SystemContent(
    int groupId,
    string groupName,
    GroupContent[] groupContents
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    groupName As String, _
    groupContents As GroupContent() _
)
Visual C++
public:
SystemContent(
    int groupId,
    String^ groupName,
    array<GroupContent^>^ groupContents
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
groupName
Type: System..::.String
the name of the group
groupContents
Type: array< OfficeClip.BusinessLayer.Service..::.GroupContent >[]()[]
The array of group contents

See Also

SystemContent Class
SystemContent Overload
OfficeClip.BusinessLayer.Service Namespace


SystemContent Methods

[image] [image]

OfficeClip API Documentation
SystemContent Methods
SystemContent Class See Also

[This is preliminary documentation and is subject to change.]

The SystemContent type exposes the following methods.

Methods

 | Name | Description
Public method | AddGroupContent | Add the group content
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveGroupContent | Remove a group content
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SystemContent Class
OfficeClip.BusinessLayer.Service Namespace


AddGroupContent Method

[image]

OfficeClip API Documentation
SystemContent..::.AddGroupContent Method
SystemContent Class See Also

[This is preliminary documentation and is subject to change.]

Add the group content

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void AddGroupContent(
    GroupContent groupContent
)
Visual Basic (Declaration)
Public Sub AddGroupContent ( _
    groupContent As GroupContent _
)
Visual C++
public:
void AddGroupContent(
    GroupContent^ groupContent
)

Parameters

groupContent
Type: OfficeClip.BusinessLayer.Service..::.GroupContent
The group content

See Also

SystemContent Class
OfficeClip.BusinessLayer.Service Namespace


RemoveGroupContent Method

[image]

OfficeClip API Documentation
SystemContent..::.RemoveGroupContent Method
SystemContent Class See Also

[This is preliminary documentation and is subject to change.]

Remove a group content

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void RemoveGroupContent(
    string sid
)
Visual Basic (Declaration)
Public Sub RemoveGroupContent ( _
    sid As String _
)
Visual C++
public:
void RemoveGroupContent(
    String^ sid
)

Parameters

sid
Type: System..::.String
The unique service id

See Also

SystemContent Class
OfficeClip.BusinessLayer.Service Namespace


SystemContent Properties

[image] [image]

OfficeClip API Documentation
SystemContent Properties
SystemContent Class See Also

[This is preliminary documentation and is subject to change.]

The SystemContent type exposes the following properties.

Properties

 | Name | Description
Public property | GroupContents | Teh array of group contents
Public property | GroupId | The unique id of the group
Public property | GroupName | The name of the group

See Also

SystemContent Class
OfficeClip.BusinessLayer.Service Namespace


GroupContents Property

[image]

OfficeClip API Documentation
SystemContent..::.GroupContents Property
SystemContent Class See Also

[This is preliminary documentation and is subject to change.]

Teh array of group contents

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GroupContent[] GroupContents { get; set; }
Visual Basic (Declaration)
Public Property GroupContents As GroupContent()
Visual C++
public:
property array<GroupContent^>^ GroupContents {
    array<GroupContent^>^ get ();
    void set (array<GroupContent^>^ value);
}

See Also

SystemContent Class
OfficeClip.BusinessLayer.Service Namespace


GroupId Property

[image]

OfficeClip API Documentation
SystemContent..::.GroupId Property
SystemContent Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the group

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

SystemContent Class
OfficeClip.BusinessLayer.Service Namespace


GroupName Property

[image]

OfficeClip API Documentation
SystemContent..::.GroupName Property
SystemContent Class See Also

[This is preliminary documentation and is subject to change.]

The name of the group

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GroupName { get; set; }
Visual Basic (Declaration)
Public Property GroupName As String
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

See Also

SystemContent Class
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldListArg Class

[image]

OfficeClip API Documentation
TrackerFieldListArg Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent the field list argument

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerFieldListArg
Visual Basic (Declaration)
Public Class TrackerFieldListArg
Visual C++
public ref class TrackerFieldListArg

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.TrackerFieldListArg

See Also

TrackerFieldListArg Members
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldListArg Members

[image] [image]

OfficeClip API Documentation
TrackerFieldListArg Members
TrackerFieldListArg Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerFieldListArg type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerFieldListArg | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | The name of the list item
Public property | Value | The value of the list item

See Also

TrackerFieldListArg Class
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldListArg Constructor

[image] [image]

OfficeClip API Documentation
TrackerFieldListArg Constructor
TrackerFieldListArg Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TrackerFieldListArg()()() | Default constructor for serialization
Public method | TrackerFieldListArg(String, String) | Constructor to instantiate from parts

See Also

TrackerFieldListArg Class
TrackerFieldListArg Members
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldListArg Constructor

[image]

OfficeClip API Documentation
TrackerFieldListArg Constructor
TrackerFieldListArg Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor for serialization

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerFieldListArg()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerFieldListArg()

See Also

TrackerFieldListArg Class
TrackerFieldListArg Overload
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldListArg Constructor (String, String)

[image]

OfficeClip API Documentation
TrackerFieldListArg Constructor (String, String)
TrackerFieldListArg Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to instantiate from parts

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerFieldListArg(
    string name,
    string val
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    val As String _
)
Visual C++
public:
TrackerFieldListArg(
    String^ name,
    String^ val
)

Parameters

name
Type: System..::.String
The name of the list item
val
Type: System..::.String
The value of the list item

See Also

TrackerFieldListArg Class
TrackerFieldListArg Overload
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldListArg Methods

[image] [image]

OfficeClip API Documentation
TrackerFieldListArg Methods
TrackerFieldListArg Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerFieldListArg type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerFieldListArg Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
TrackerFieldListArg..::.Dump Method
TrackerFieldListArg Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the object for debugging

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

the debug dump

See Also

TrackerFieldListArg Class
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldListArg Properties

[image] [image]

OfficeClip API Documentation
TrackerFieldListArg Properties
TrackerFieldListArg Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerFieldListArg type exposes the following properties.

Properties

 | Name | Description
Public property | Name | The name of the list item
Public property | Value | The value of the list item

See Also

TrackerFieldListArg Class
OfficeClip.BusinessLayer.Service Namespace


Name Property

[image]

OfficeClip API Documentation
TrackerFieldListArg..::.Name Property
TrackerFieldListArg Class See Also

[This is preliminary documentation and is subject to change.]

The name of the list item

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerFieldListArg Class
OfficeClip.BusinessLayer.Service Namespace


Value Property

[image]

OfficeClip API Documentation
TrackerFieldListArg..::.Value Property
TrackerFieldListArg Class See Also

[This is preliminary documentation and is subject to change.]

The value of the list item

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerFieldListArg Class
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldValue Class

[image]

OfficeClip API Documentation
TrackerFieldValue Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to represent a tracker field value

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerFieldValue
Visual Basic (Declaration)
Public Class TrackerFieldValue
Visual C++
public ref class TrackerFieldValue

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Service..::.TrackerFieldValue

See Also

TrackerFieldValue Members
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldValue Members

[image] [image]

OfficeClip API Documentation
TrackerFieldValue Members
TrackerFieldValue Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerFieldValue type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerFieldValue | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The Id of the field, represents the position where it is at
Public property | Value | The value of the field

See Also

TrackerFieldValue Class
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldValue Constructor

[image] [image]

OfficeClip API Documentation
TrackerFieldValue Constructor
TrackerFieldValue Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TrackerFieldValue()()() | The default constructor
Public method | TrackerFieldValue(Int32, String) | The constructor to extract the object from parts

See Also

TrackerFieldValue Class
TrackerFieldValue Members
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldValue Constructor

[image]

OfficeClip API Documentation
TrackerFieldValue Constructor
TrackerFieldValue Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerFieldValue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerFieldValue()

See Also

TrackerFieldValue Class
TrackerFieldValue Overload
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldValue Constructor (Int32, String)

[image]

OfficeClip API Documentation
TrackerFieldValue Constructor (Int32, String)
TrackerFieldValue Class See Also

[This is preliminary documentation and is subject to change.]

The constructor to extract the object from parts

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerFieldValue(
    int id,
    string val
)
Visual Basic (Declaration)
Public Sub New ( _
    id As Integer, _
    val As String _
)
Visual C++
public:
TrackerFieldValue(
    int id,
    String^ val
)

Parameters

id
Type: System..::.Int32
The id of the field
val
Type: System..::.String
The value of the field

See Also

TrackerFieldValue Class
TrackerFieldValue Overload
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldValue Methods

[image] [image]

OfficeClip API Documentation
TrackerFieldValue Methods
TrackerFieldValue Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerFieldValue type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the object for debugging
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerFieldValue Class
OfficeClip.BusinessLayer.Service Namespace


Dump Method

[image]

OfficeClip API Documentation
TrackerFieldValue..::.Dump Method
TrackerFieldValue Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the object for debugging

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

the debug dump

See Also

TrackerFieldValue Class
OfficeClip.BusinessLayer.Service Namespace


TrackerFieldValue Properties

[image] [image]

OfficeClip API Documentation
TrackerFieldValue Properties
TrackerFieldValue Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerFieldValue type exposes the following properties.

Properties

 | Name | Description
Public property | Id | The Id of the field, represents the position where it is at
Public property | Value | The value of the field

See Also

TrackerFieldValue Class
OfficeClip.BusinessLayer.Service Namespace


Id Property

[image]

OfficeClip API Documentation
TrackerFieldValue..::.Id Property
TrackerFieldValue Class See Also

[This is preliminary documentation and is subject to change.]

The Id of the field, represents the position where it is at

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Id { get; set; }
Visual Basic (Declaration)
Public Property Id As Integer
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

See Also

TrackerFieldValue Class
OfficeClip.BusinessLayer.Service Namespace


Value Property

[image]

OfficeClip API Documentation
TrackerFieldValue..::.Value Property
TrackerFieldValue Class See Also

[This is preliminary documentation and is subject to change.]

The value of the field

Namespace: OfficeClip.BusinessLayer.Service
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerFieldValue Class
OfficeClip.BusinessLayer.Service Namespace


OfficeClip.BusinessLayer.Sync Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Sync Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for synchronization

Classes

 | Class | Description
Public class | OCCSVEventInfo | Provides methods and properties to access the calendar information for csv format.
Public class | OCQBTimer | Provides methods and properties to access information related to the OfficeClip and Quickbooks interface.
Public class | OCQBTimer..::.OCQBClass | Provides methods and properties to access the quickbooks class.
Public class | OCQBTimer..::.OCQBCustomerProject | Provides methods and properties to access the quickbooks Customer Project.
Public class | OCQBTimer..::.OCQBEmployee | Provides methods and properties to access the employee information.
Public class | OCQBTimer..::.OCQBHeader | Provides methods and properties to access the quickbooks headers.
Public class | OCQBTimer..::.OCQBInvoiceItem | Provides methods and properties to access the Quickbooks invoice item.
Public class | OCQBTimer..::.OCQBTimeHeader | Provides methods and properties to access the quickbooks time header information.
Public class | OCQBTimer..::.OCQBVendor | Provides methods and properties to access the quickbooks Vendors.
Public class | OCUserInfo | Provides methods and properties to access the user information for the CSV file.
Public class | OCVCalendar | Provides methods and properties to access the vCalendar collection.
Public class | OCVCard | Encapsulates all the parsing methods of the vCard currently it will support versions 2.1 to 3.0
Public class | OCVCardCollection | Porvides methods and properties to access the vCard Collection class
Public class | OCvEvent | Provides methods and properties to access the OfficeClip vCalendar information.


OCCSVEventInfo Class

[image]

OfficeClip API Documentation
OCCSVEventInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the calendar information for csv format.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCCSVEventInfo : EventInfo, IOCDateTimeFormatInfo
Visual Basic (Declaration)
Public Class OCCSVEventInfo _
    Inherits EventInfo _
    Implements IOCDateTimeFormatInfo
Visual C++
public ref class OCCSVEventInfo : public EventInfo,
    IOCDateTimeFormatInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Desktop..::.EventInfo
OfficeClip.BusinessLayer.Sync..::.OCCSVEventInfo

See Also

OCCSVEventInfo Members
OfficeClip.BusinessLayer.Sync Namespace


OCCSVEventInfo Members

[image] [image]

OfficeClip API Documentation
OCCSVEventInfo Members
OCCSVEventInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCCSVEventInfo type exposes the following members.

Constructors

 | Name | Description
Public method | OCCSVEventInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEventInfo | Gets the event information for the event.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPersonalOnlyInformationChanged | Determines if the personal only information is changed between two events. This is useful to determine if the user has changed the reminder and the busy information. This information may be required to stop sending emails to everybody when the personal information is changed. (Inherited from EventInfo.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | All_Day_Event | Sets whether the event is all day event.
Public property | Attachments | A list of attachments. (Inherited from EventInfo.)
Public property | CreatedByUserId | The creator user id of the event. (Inherited from EventInfo.)
Public property | CreatedTimestamp | The Timestamp of when the event is created. (Inherited from EventInfo.)
Public property | DateFormatStr | The date format for the event.
Public property | DateTimeFormat | The datetime format for the event.
Public property | DocIdList | the list of comma separated unique document identifier associated with this event. (Inherited from EventInfo.)
Public property | End_Date | The end date of the event in the proper date format.
Public property | End_Time | the end time of the event in the proper time format.
Public property | EndDatetime | The date and time of the end of the event. (Inherited from EventInfo.)
Public property | Event_Description | the Description of the event.
Public property | Event_Name | the Title of the event.
Public property | EventDescription | The Description of the event. (Inherited from EventInfo.)
Public property | EventGroupId | The unique id of the group which this event belongs to. (Inherited from EventInfo.)
Public property | EventGroupName | The name of the group to which the event belongs to. (Inherited from EventInfo.)
Public property | EventId | The system generated unique id of the event. (Inherited from EventInfo.)
Public property | EventName | The Title of the event. (Inherited from EventInfo.)
Public property | EventType | The event type of the event. (Inherited from EventInfo.)
Public property | EventUserId | The unique identifier of the user who created the event. (Inherited from EventInfo.)
Public property | FirstOcurrenceDatetime | The first occurence datetime of this recurring event. (Inherited from EventInfo.)
Public property | IsAllDayEvent | Shows whether the event is all day event. (Inherited from EventInfo.)
Public property | IsReminderSelected | Shows if the reminder is selected for the event. (Inherited from EventInfo.)
Public property | IsResourceReserved | Shows if the resource for this event is reserved. (Inherited from EventInfo.)
Public property | IsRSVP | Shows if the event has an RSVP. (Inherited from EventInfo.)
Public property | LabelId | The event label (classification) (Inherited from EventInfo.)
Public property | LastOcurrenceDatetime | the last occurence of datetime for this event. (Inherited from EventInfo.)
Public property | Location | The Location of the event.
Public property | MeetingAttendees | A list of meeting attendies. (Inherited from EventInfo.)
Public property | ModifiedByUserId | The modified by user id (Inherited from EventInfo.)
Public property | ModifiedTimestamp | The modified timestamp (Inherited from EventInfo.)
Public property | NotifyGroup | Shows whether to notify the group for this event. (Inherited from EventInfo.)
Public property | ParentObjectId | The id of the parent object (Inherited from EventInfo.)
Public property | ParentObjectType | The type of the parent object (Inherited from EventInfo.)
Public property | Recurrence | Te Recurrence information about the event. (Inherited from EventInfo.)
Public property | Regarding | The regarding string (Inherited from EventInfo.)
Public property | RemDocIdList | A list of comma separated document identifiers that needs to be removed inthis event. (Inherited from EventInfo.)
Public property | RemindAtDatetime | The date and time of the event reminder. (Inherited from EventInfo.)
Public property | Reminder_Date | The reminder date in the proper date format.
Public property | Reminder_Time | the reminder time in the proper time format.
Public property | RepeatInfoText | The text of the repeat information of the event. (Inherited from EventInfo.)
Public property | RepeatingSequenceId | The sequence id of the repeating sequence event. (Inherited from EventInfo.)
Public property | ResourceId | The unique id of the resource associated with this event. (Inherited from EventInfo.)
Public property | ResourceName | The name of the resource associated with the event. (Inherited from EventInfo.)
Public property | Show_Time_As | Shows how the time will be shown as. Valid values are Busy, Free,Tentative and OutOfOffice.
Public property | ShowAs | How the event is shown on the screen. (Inherited from EventInfo.)
Public property | Start_Date | The start date of the event in the proper date format.
Public property | Start_Time | The start time of the event in the proper time format.
Public property | StartDatetime | The date and time of the start of the event. (Inherited from EventInfo.)
Public property | TimeFormatStr | The time format forthe event.
Public property | TimezoneId | The timezone id of the event. (Inherited from EventInfo.)
Public property | url | The Uniform Resource Locator associated with this event. (Inherited from EventInfo.)
Public property | WhenToRemind | The time (in String format) of the reminder of the event. (Inherited from EventInfo.)
Public property | WhoToRemind | The name of the person to remind for the event. (Inherited from EventInfo.)

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


OCCSVEventInfo Constructor

[image] [image]

OfficeClip API Documentation
OCCSVEventInfo Constructor
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCCSVEventInfo()()() | Default constructor for the event information for the csv format.
Public method | OCCSVEventInfo(EventInfo) | Constructor for the event information for the csv format taking event information as argument.

See Also

OCCSVEventInfo Class
OCCSVEventInfo Members
OfficeClip.BusinessLayer.Sync Namespace


OCCSVEventInfo Constructor

[image]

OfficeClip API Documentation
OCCSVEventInfo Constructor
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor for the event information for the csv format.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCCSVEventInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCCSVEventInfo()

See Also

OCCSVEventInfo Class
OCCSVEventInfo Overload
OfficeClip.BusinessLayer.Sync Namespace


OCCSVEventInfo Constructor (EventInfo)

[image]

OfficeClip API Documentation
OCCSVEventInfo Constructor (EventInfo)
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for the event information for the csv format taking event information as argument.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCCSVEventInfo(
    EventInfo ei
)
Visual Basic (Declaration)
Public Sub New ( _
    ei As EventInfo _
)
Visual C++
public:
OCCSVEventInfo(
    EventInfo^ ei
)

Parameters

ei
Type: OfficeClip.BusinessLayer.Desktop..::.EventInfo
the event information.

See Also

OCCSVEventInfo Class
OCCSVEventInfo Overload
OfficeClip.BusinessLayer.Sync Namespace


OCCSVEventInfo Methods

[image] [image]

OfficeClip API Documentation
OCCSVEventInfo Methods
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The OCCSVEventInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEventInfo | Gets the event information for the event.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsPersonalOnlyInformationChanged | Determines if the personal only information is changed between two events. This is useful to determine if the user has changed the reminder and the busy information. This information may be required to stop sending emails to everybody when the personal information is changed. (Inherited from EventInfo.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


GetEventInfo Method

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.GetEventInfo Method
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the event information for the event.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventInfo GetEventInfo()
Visual Basic (Declaration)
Public Function GetEventInfo As EventInfo
Visual C++
public:
EventInfo^ GetEventInfo()

Return Value

the event information.

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


OCCSVEventInfo Properties

[image] [image]

OfficeClip API Documentation
OCCSVEventInfo Properties
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The OCCSVEventInfo type exposes the following properties.

Properties

 | Name | Description
Public property | All_Day_Event | Sets whether the event is all day event.
Public property | Attachments | A list of attachments. (Inherited from EventInfo.)
Public property | CreatedByUserId | The creator user id of the event. (Inherited from EventInfo.)
Public property | CreatedTimestamp | The Timestamp of when the event is created. (Inherited from EventInfo.)
Public property | DateFormatStr | The date format for the event.
Public property | DateTimeFormat | The datetime format for the event.
Public property | DocIdList | the list of comma separated unique document identifier associated with this event. (Inherited from EventInfo.)
Public property | End_Date | The end date of the event in the proper date format.
Public property | End_Time | the end time of the event in the proper time format.
Public property | EndDatetime | The date and time of the end of the event. (Inherited from EventInfo.)
Public property | Event_Description | the Description of the event.
Public property | Event_Name | the Title of the event.
Public property | EventDescription | The Description of the event. (Inherited from EventInfo.)
Public property | EventGroupId | The unique id of the group which this event belongs to. (Inherited from EventInfo.)
Public property | EventGroupName | The name of the group to which the event belongs to. (Inherited from EventInfo.)
Public property | EventId | The system generated unique id of the event. (Inherited from EventInfo.)
Public property | EventName | The Title of the event. (Inherited from EventInfo.)
Public property | EventType | The event type of the event. (Inherited from EventInfo.)
Public property | EventUserId | The unique identifier of the user who created the event. (Inherited from EventInfo.)
Public property | FirstOcurrenceDatetime | The first occurence datetime of this recurring event. (Inherited from EventInfo.)
Public property | IsAllDayEvent | Shows whether the event is all day event. (Inherited from EventInfo.)
Public property | IsReminderSelected | Shows if the reminder is selected for the event. (Inherited from EventInfo.)
Public property | IsResourceReserved | Shows if the resource for this event is reserved. (Inherited from EventInfo.)
Public property | IsRSVP | Shows if the event has an RSVP. (Inherited from EventInfo.)
Public property | LabelId | The event label (classification) (Inherited from EventInfo.)
Public property | LastOcurrenceDatetime | the last occurence of datetime for this event. (Inherited from EventInfo.)
Public property | Location | The Location of the event.
Public property | MeetingAttendees | A list of meeting attendies. (Inherited from EventInfo.)
Public property | ModifiedByUserId | The modified by user id (Inherited from EventInfo.)
Public property | ModifiedTimestamp | The modified timestamp (Inherited from EventInfo.)
Public property | NotifyGroup | Shows whether to notify the group for this event. (Inherited from EventInfo.)
Public property | ParentObjectId | The id of the parent object (Inherited from EventInfo.)
Public property | ParentObjectType | The type of the parent object (Inherited from EventInfo.)
Public property | Recurrence | Te Recurrence information about the event. (Inherited from EventInfo.)
Public property | Regarding | The regarding string (Inherited from EventInfo.)
Public property | RemDocIdList | A list of comma separated document identifiers that needs to be removed inthis event. (Inherited from EventInfo.)
Public property | RemindAtDatetime | The date and time of the event reminder. (Inherited from EventInfo.)
Public property | Reminder_Date | The reminder date in the proper date format.
Public property | Reminder_Time | the reminder time in the proper time format.
Public property | RepeatInfoText | The text of the repeat information of the event. (Inherited from EventInfo.)
Public property | RepeatingSequenceId | The sequence id of the repeating sequence event. (Inherited from EventInfo.)
Public property | ResourceId | The unique id of the resource associated with this event. (Inherited from EventInfo.)
Public property | ResourceName | The name of the resource associated with the event. (Inherited from EventInfo.)
Public property | Show_Time_As | Shows how the time will be shown as. Valid values are Busy, Free,Tentative and OutOfOffice.
Public property | ShowAs | How the event is shown on the screen. (Inherited from EventInfo.)
Public property | Start_Date | The start date of the event in the proper date format.
Public property | Start_Time | The start time of the event in the proper time format.
Public property | StartDatetime | The date and time of the start of the event. (Inherited from EventInfo.)
Public property | TimeFormatStr | The time format forthe event.
Public property | TimezoneId | The timezone id of the event. (Inherited from EventInfo.)
Public property | url | The Uniform Resource Locator associated with this event. (Inherited from EventInfo.)
Public property | WhenToRemind | The time (in String format) of the reminder of the event. (Inherited from EventInfo.)
Public property | WhoToRemind | The name of the person to remind for the event. (Inherited from EventInfo.)

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


All_Day_Event Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.All_Day_Event Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Sets whether the event is all day event.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string All_Day_Event { set; }
Visual Basic (Declaration)
Public WriteOnly Property All_Day_Event As String
Visual C++
public:
property String^ All_Day_Event {
    void set (String^ value);
}

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


DateFormatStr Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.DateFormatStr Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date format for the event.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DateFormatStr { set; }
Visual Basic (Declaration)
Public WriteOnly Property DateFormatStr As String
Visual C++
public:
virtual property String^ DateFormatStr {
    void set (String^ value) sealed;
}

Implements

IOCDateTimeFormatInfo..::.DateFormatStr

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


DateTimeFormat Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.DateTimeFormat Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The datetime format for the event.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTimeFormatInfo DateTimeFormat { set; }
Visual Basic (Declaration)
Public WriteOnly Property DateTimeFormat As DateTimeFormatInfo
Visual C++
public:
virtual property DateTimeFormatInfo^ DateTimeFormat {
    void set (DateTimeFormatInfo^ value) sealed;
}

Implements

IOCDateTimeFormatInfo..::.DateTimeFormat

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


End_Date Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.End_Date Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The end date of the event in the proper date format.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string End_Date { set; }
Visual Basic (Declaration)
Public WriteOnly Property End_Date As String
Visual C++
public:
property String^ End_Date {
    void set (String^ value);
}

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


End_Time Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.End_Time Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

the end time of the event in the proper time format.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string End_Time { set; }
Visual Basic (Declaration)
Public WriteOnly Property End_Time As String
Visual C++
public:
property String^ End_Time {
    void set (String^ value);
}

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Event_Description Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.Event_Description Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

the Description of the event.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Event_Description { set; }
Visual Basic (Declaration)
Public WriteOnly Property Event_Description As String
Visual C++
public:
property String^ Event_Description {
    void set (String^ value);
}

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Event_Name Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.Event_Name Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

the Title of the event.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Event_Name { set; }
Visual Basic (Declaration)
Public WriteOnly Property Event_Name As String
Visual C++
public:
property String^ Event_Name {
    void set (String^ value);
}

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Location Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.Location Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Location of the event.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Location { set; }
Visual Basic (Declaration)
Public WriteOnly Property Location As String
Visual C++
public:
property String^ Location {
    void set (String^ value);
}

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Reminder_Date Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.Reminder_Date Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The reminder date in the proper date format.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Reminder_Date { set; }
Visual Basic (Declaration)
Public WriteOnly Property Reminder_Date As String
Visual C++
public:
property String^ Reminder_Date {
    void set (String^ value);
}

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Reminder_Time Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.Reminder_Time Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

the reminder time in the proper time format.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Reminder_Time { set; }
Visual Basic (Declaration)
Public WriteOnly Property Reminder_Time As String
Visual C++
public:
property String^ Reminder_Time {
    void set (String^ value);
}

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Show_Time_As Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.Show_Time_As Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows how the time will be shown as. Valid values are Busy, Free,Tentative and OutOfOffice.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Show_Time_As { set; }
Visual Basic (Declaration)
Public WriteOnly Property Show_Time_As As String
Visual C++
public:
property String^ Show_Time_As {
    void set (String^ value);
}

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Start_Date Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.Start_Date Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The start date of the event in the proper date format.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Start_Date { set; }
Visual Basic (Declaration)
Public WriteOnly Property Start_Date As String
Visual C++
public:
property String^ Start_Date {
    void set (String^ value);
}

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Start_Time Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.Start_Time Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The start time of the event in the proper time format.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Start_Time { set; }
Visual Basic (Declaration)
Public WriteOnly Property Start_Time As String
Visual C++
public:
property String^ Start_Time {
    void set (String^ value);
}

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


TimeFormatStr Property

[image]

OfficeClip API Documentation
OCCSVEventInfo..::.TimeFormatStr Property
OCCSVEventInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time format forthe event.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TimeFormatStr { set; }
Visual Basic (Declaration)
Public WriteOnly Property TimeFormatStr As String
Visual C++
public:
virtual property String^ TimeFormatStr {
    void set (String^ value) sealed;
}

Implements

IOCDateTimeFormatInfo..::.TimeFormatStr

See Also

OCCSVEventInfo Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer Class

[image]

OfficeClip API Documentation
OCQBTimer Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access information related to the OfficeClip and Quickbooks interface.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class OCQBTimer : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OCQBTimer _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class OCQBTimer : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCQBTimer

See Also

OCQBTimer Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer Members

[image] [image]

OfficeClip API Documentation
OCQBTimer Members
OCQBTimer Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer type exposes the following members.

Constructors

 | Name | Description
Public method | OCQBTimer | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsClassInQB | Determins if the class is in the quickbooks
Public method | IsCustomerProjectInQB | Shows if the Customer projet is already in the quickbooks.
Public method | IsInvoiceItemInQB | Shows if the invoice item is already in the quickbooks.
Public method | IsUserInQBEmployees | Shows if the user is already in the quickbooks.
Public method | IsUserInQBVendors | Shows if the user is a member of the quickbooks vendor list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Classes | The list of Classes.
Public property | CustomerProjects | The list of Customer Projects.
Public property | Employees | The list of Employees.
Public property | header | The quickbooks header.
Public property | InvoiceItems | The list of invoice items.
Public property | TimeHeader | The quickbooks time header.
Public property | Vendors | The list of Vendors.

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer Constructor

[image] [image]

OfficeClip API Documentation
OCQBTimer Constructor
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCQBTimer(HttpPostedFile) | The constructor that creates the object using the posted specification file.
Public method | OCQBTimer(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

OCQBTimer Class
OCQBTimer Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer Constructor (HttpPostedFile)

[image]

OfficeClip API Documentation
OCQBTimer Constructor (HttpPostedFile)
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

The constructor that creates the object using the posted specification file.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBTimer(
    HttpPostedFile pFile
)
Visual Basic (Declaration)
Public Sub New ( _
    pFile As HttpPostedFile _
)
Visual C++
public:
OCQBTimer(
    HttpPostedFile^ pFile
)

Parameters

pFile
Type: System.Web..::.HttpPostedFile
The posted specification file.

See Also

OCQBTimer Class
OCQBTimer Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
OCQBTimer Constructor (SerializationInfo, StreamingContext)
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBTimer(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
OCQBTimer(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

OCQBTimer Class
OCQBTimer Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer Methods

[image] [image]

OfficeClip API Documentation
OCQBTimer Methods
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsClassInQB | Determins if the class is in the quickbooks
Public method | IsCustomerProjectInQB | Shows if the Customer projet is already in the quickbooks.
Public method | IsInvoiceItemInQB | Shows if the invoice item is already in the quickbooks.
Public method | IsUserInQBEmployees | Shows if the user is already in the quickbooks.
Public method | IsUserInQBVendors | Shows if the user is a member of the quickbooks vendor list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
OCQBTimer..::.GetObjectData Method
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


IsClassInQB Method

[image]

OfficeClip API Documentation
OCQBTimer..::.IsClassInQB Method
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

Determins if the class is in the quickbooks

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsClassInQB(
    string strClass
)
Visual Basic (Declaration)
Public Function IsClassInQB ( _
    strClass As String _
) As Boolean
Visual C++
public:
bool IsClassInQB(
    String^ strClass
)

Parameters

strClass
Type: System..::.String
The name of the class

Return Value

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


IsCustomerProjectInQB Method

[image]

OfficeClip API Documentation
OCQBTimer..::.IsCustomerProjectInQB Method
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the Customer projet is already in the quickbooks.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsCustomerProjectInQB(
    string customerProject
)
Visual Basic (Declaration)
Public Function IsCustomerProjectInQB ( _
    customerProject As String _
) As Boolean
Visual C++
public:
bool IsCustomerProjectInQB(
    String^ customerProject
)

Parameters

customerProject
Type: System..::.String
The Project name for Customer Project.

Return Value

true if the Customer Project is already in quickbooks, false otherwise.

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


IsInvoiceItemInQB Method

[image]

OfficeClip API Documentation
OCQBTimer..::.IsInvoiceItemInQB Method
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the invoice item is already in the quickbooks.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsInvoiceItemInQB(
    string invoiceItem
)
Visual Basic (Declaration)
Public Function IsInvoiceItemInQB ( _
    invoiceItem As String _
) As Boolean
Visual C++
public:
bool IsInvoiceItemInQB(
    String^ invoiceItem
)

Parameters

invoiceItem
Type: System..::.String
The invoice item.

Return Value

true if the invoice item is already in quickbooks, false otherwise.

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


IsUserInQBEmployees Method

[image]

OfficeClip API Documentation
OCQBTimer..::.IsUserInQBEmployees Method
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the user is already in the quickbooks.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsUserInQBEmployees(
    string userName
)
Visual Basic (Declaration)
Public Function IsUserInQBEmployees ( _
    userName As String _
) As Boolean
Visual C++
public:
bool IsUserInQBEmployees(
    String^ userName
)

Parameters

userName
Type: System..::.String
The name of the user.

Return Value

true if the user is already in the quickbooks, false otherwise.

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


IsUserInQBVendors Method

[image]

OfficeClip API Documentation
OCQBTimer..::.IsUserInQBVendors Method
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the user is a member of the quickbooks vendor list.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsUserInQBVendors(
    string userName
)
Visual Basic (Declaration)
Public Function IsUserInQBVendors ( _
    userName As String _
) As Boolean
Visual C++
public:
bool IsUserInQBVendors(
    String^ userName
)

Parameters

userName
Type: System..::.String
the name of the user.

Return Value

true if the user is a vendor in quickbooks, false otherwise.

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer Properties

[image] [image]

OfficeClip API Documentation
OCQBTimer Properties
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer type exposes the following properties.

Properties

 | Name | Description
Public property | Classes | The list of Classes.
Public property | CustomerProjects | The list of Customer Projects.
Public property | Employees | The list of Employees.
Public property | header | The quickbooks header.
Public property | InvoiceItems | The list of invoice items.
Public property | TimeHeader | The quickbooks time header.
Public property | Vendors | The list of Vendors.

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


Classes Property

[image]

OfficeClip API Documentation
OCQBTimer..::.Classes Property
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

The list of Classes.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Classes { get; set; }
Visual Basic (Declaration)
Public Property Classes As ArrayList
Visual C++
public:
property ArrayList^ Classes {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


CustomerProjects Property

[image]

OfficeClip API Documentation
OCQBTimer..::.CustomerProjects Property
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

The list of Customer Projects.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList CustomerProjects { get; set; }
Visual Basic (Declaration)
Public Property CustomerProjects As ArrayList
Visual C++
public:
property ArrayList^ CustomerProjects {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


Employees Property

[image]

OfficeClip API Documentation
OCQBTimer..::.Employees Property
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

The list of Employees.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Employees { get; set; }
Visual Basic (Declaration)
Public Property Employees As ArrayList
Visual C++
public:
property ArrayList^ Employees {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


header Property

[image]

OfficeClip API Documentation
OCQBTimer..::.header Property
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

The quickbooks header.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBTimer..::.OCQBHeader header { get; set; }
Visual Basic (Declaration)
Public Property header As OCQBTimer..::.OCQBHeader
Visual C++
public:
property OCQBTimer..::.OCQBHeader^ header {
    OCQBTimer..::.OCQBHeader^ get ();
    void set (OCQBTimer..::.OCQBHeader^ value);
}

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


InvoiceItems Property

[image]

OfficeClip API Documentation
OCQBTimer..::.InvoiceItems Property
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

The list of invoice items.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList InvoiceItems { get; set; }
Visual Basic (Declaration)
Public Property InvoiceItems As ArrayList
Visual C++
public:
property ArrayList^ InvoiceItems {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


TimeHeader Property

[image]

OfficeClip API Documentation
OCQBTimer..::.TimeHeader Property
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

The quickbooks time header.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBTimer..::.OCQBTimeHeader TimeHeader { get; set; }
Visual Basic (Declaration)
Public Property TimeHeader As OCQBTimer..::.OCQBTimeHeader
Visual C++
public:
property OCQBTimer..::.OCQBTimeHeader^ TimeHeader {
    OCQBTimer..::.OCQBTimeHeader^ get ();
    void set (OCQBTimer..::.OCQBTimeHeader^ value);
}

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


Vendors Property

[image]

OfficeClip API Documentation
OCQBTimer..::.Vendors Property
OCQBTimer Class See Also

[This is preliminary documentation and is subject to change.]

The list of Vendors.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList Vendors { get; set; }
Visual Basic (Declaration)
Public Property Vendors As ArrayList
Visual C++
public:
property ArrayList^ Vendors {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

OCQBTimer Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBClass Class

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBClass Class
OCQBTimer Class Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the quickbooks class.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class OCQBClass : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OCQBClass _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class OCQBClass : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCQBTimer..::.OCQBClass

See Also

OCQBTimer..::.OCQBClass Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBClass Members

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBClass Members
OCQBTimer..::.OCQBClass Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access information related to the OfficeClip and Quickbooks interface.

The OCQBTimer..::.OCQBClass type exposes the following members.

Constructors

 | Name | Description
Public method | OCQBTimer..::.OCQBClass | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | name | The name of the class.
Public property | RefNum | The reference number for the class.
Public property | Timestamp | the class Timestamp.

See Also

OCQBTimer..::.OCQBClass Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBClass Constructor

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBClass Constructor
OCQBTimer..::.OCQBClass Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCQBTimer..::.OCQBClass()()() | The default constructor
Public method | OCQBTimer..::.OCQBClass(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

OCQBTimer..::.OCQBClass Class
OCQBTimer..::.OCQBClass Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBClass Constructor

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBClass Constructor
OCQBTimer..::.OCQBClass Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBClass()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCQBClass()

See Also

OCQBTimer..::.OCQBClass Class
OCQBTimer..::.OCQBClass Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBClass Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBClass Constructor (SerializationInfo, StreamingContext)
OCQBTimer..::.OCQBClass Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBClass(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
OCQBClass(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

OCQBTimer..::.OCQBClass Class
OCQBTimer..::.OCQBClass Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBClass Methods

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBClass Methods
OCQBTimer..::.OCQBClass Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBClass type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCQBTimer..::.OCQBClass Class
OfficeClip.BusinessLayer.Sync Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBClass..::.GetObjectData Method
OCQBTimer..::.OCQBClass Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

OCQBTimer..::.OCQBClass Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBClass Properties

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBClass Properties
OCQBTimer..::.OCQBClass Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBClass type exposes the following properties.

Properties

 | Name | Description
Public property | name | The name of the class.
Public property | RefNum | The reference number for the class.
Public property | Timestamp | the class Timestamp.

See Also

OCQBTimer..::.OCQBClass Class
OfficeClip.BusinessLayer.Sync Namespace


name Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBClass..::.name Property
OCQBTimer..::.OCQBClass Class See Also

[This is preliminary documentation and is subject to change.]

The name of the class.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string name { get; set; }
Visual Basic (Declaration)
Public Property name As String
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBClass Class
OfficeClip.BusinessLayer.Sync Namespace


RefNum Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBClass..::.RefNum Property
OCQBTimer..::.OCQBClass Class See Also

[This is preliminary documentation and is subject to change.]

The reference number for the class.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RefNum { get; set; }
Visual Basic (Declaration)
Public Property RefNum As String
Visual C++
public:
property String^ RefNum {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBClass Class
OfficeClip.BusinessLayer.Sync Namespace


Timestamp Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBClass..::.Timestamp Property
OCQBTimer..::.OCQBClass Class See Also

[This is preliminary documentation and is subject to change.]

the class Timestamp.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Timestamp { get; set; }
Visual Basic (Declaration)
Public Property Timestamp As Integer
Visual C++
public:
property int Timestamp {
    int get ();
    void set (int value);
}

See Also

OCQBTimer..::.OCQBClass Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBCustomerProject Class

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject Class
OCQBTimer Class Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the quickbooks Customer Project.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class OCQBCustomerProject : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OCQBCustomerProject _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class OCQBCustomerProject : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCQBTimer..::.OCQBCustomerProject

See Also

OCQBTimer..::.OCQBCustomerProject Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBCustomerProject Members

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject Members
OCQBTimer..::.OCQBCustomerProject Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access information related to the OfficeClip and Quickbooks interface.

The OCQBTimer..::.OCQBCustomerProject type exposes the following members.

Constructors

 | Name | Description
Public method | OCQBTimer..::.OCQBCustomerProject | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address | The Address of the Customer.
Public property | Customer | The Customer name.
Public property | CustomerProjectName | The name of the Customer Project in quickbooks.
Public property | IsCustomer | Shows if the object is the Customer.
Public property | IsProject | Shows if teh object is a Project.
Public property | Project | The Project name.
Public property | RefNum | The reference number.
Public property | Timestamp | The created Timestamp.

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBCustomerProject Constructor

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject Constructor
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCQBTimer..::.OCQBCustomerProject()()() | The default constructor.
Public method | OCQBTimer..::.OCQBCustomerProject(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

OCQBTimer..::.OCQBCustomerProject Class
OCQBTimer..::.OCQBCustomerProject Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBCustomerProject Constructor

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject Constructor
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBCustomerProject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCQBCustomerProject()

See Also

OCQBTimer..::.OCQBCustomerProject Class
OCQBTimer..::.OCQBCustomerProject Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBCustomerProject Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject Constructor (SerializationInfo, StreamingContext)
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBCustomerProject(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
OCQBCustomerProject(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

OCQBTimer..::.OCQBCustomerProject Class
OCQBTimer..::.OCQBCustomerProject Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBCustomerProject Methods

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject Methods
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBCustomerProject type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject..::.GetObjectData Method
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBCustomerProject Properties

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject Properties
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBCustomerProject type exposes the following properties.

Properties

 | Name | Description
Public property | Address | The Address of the Customer.
Public property | Customer | The Customer name.
Public property | CustomerProjectName | The name of the Customer Project in quickbooks.
Public property | IsCustomer | Shows if the object is the Customer.
Public property | IsProject | Shows if teh object is a Project.
Public property | Project | The Project name.
Public property | RefNum | The reference number.
Public property | Timestamp | The created Timestamp.

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


Address Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject..::.Address Property
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

The Address of the Customer.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public AddressInfo Address { get; set; }
Visual Basic (Declaration)
Public Property Address As AddressInfo
Visual C++
public:
property AddressInfo^ Address {
    AddressInfo^ get ();
    void set (AddressInfo^ value);
}

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


Customer Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject..::.Customer Property
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

The Customer name.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Customer { get; set; }
Visual Basic (Declaration)
Public Property Customer As String
Visual C++
public:
property String^ Customer {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


CustomerProjectName Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject..::.CustomerProjectName Property
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

The name of the Customer Project in quickbooks.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CustomerProjectName { get; set; }
Visual Basic (Declaration)
Public Property CustomerProjectName As String
Visual C++
public:
property String^ CustomerProjectName {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


IsCustomer Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject..::.IsCustomer Property
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the object is the Customer.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsCustomer { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCustomer As Boolean
Visual C++
public:
property bool IsCustomer {
    bool get ();
}

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


IsProject Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject..::.IsProject Property
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

Shows if teh object is a Project.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsProject { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsProject As Boolean
Visual C++
public:
property bool IsProject {
    bool get ();
}

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


Project Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject..::.Project Property
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

The Project name.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Project { get; set; }
Visual Basic (Declaration)
Public Property Project As String
Visual C++
public:
property String^ Project {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


RefNum Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject..::.RefNum Property
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

The reference number.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RefNum { get; set; }
Visual Basic (Declaration)
Public Property RefNum As String
Visual C++
public:
property String^ RefNum {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


Timestamp Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBCustomerProject..::.Timestamp Property
OCQBTimer..::.OCQBCustomerProject Class See Also

[This is preliminary documentation and is subject to change.]

The created Timestamp.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Timestamp { get; set; }
Visual Basic (Declaration)
Public Property Timestamp As Integer
Visual C++
public:
property int Timestamp {
    int get ();
    void set (int value);
}

See Also

OCQBTimer..::.OCQBCustomerProject Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBEmployee Class

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee Class
OCQBTimer Class Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the employee information.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class OCQBEmployee : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OCQBEmployee _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class OCQBEmployee : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCQBTimer..::.OCQBEmployee

See Also

OCQBTimer..::.OCQBEmployee Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBEmployee Members

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee Members
OCQBTimer..::.OCQBEmployee Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access information related to the OfficeClip and Quickbooks interface.

The OCQBTimer..::.OCQBEmployee type exposes the following members.

Constructors

 | Name | Description
Public method | OCQBTimer..::.OCQBEmployee | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | name | The name of the employee.
Public property | RefNum | The reference number of the employee
Public property | ScreenName | The screen name of the employee.
Public property | Timestamp | the Timestamp whent he employee record is created.

See Also

OCQBTimer..::.OCQBEmployee Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBEmployee Constructor

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee Constructor
OCQBTimer..::.OCQBEmployee Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCQBTimer..::.OCQBEmployee()()() | The default constructor.
Public method | OCQBTimer..::.OCQBEmployee(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

OCQBTimer..::.OCQBEmployee Class
OCQBTimer..::.OCQBEmployee Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBEmployee Constructor

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee Constructor
OCQBTimer..::.OCQBEmployee Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBEmployee()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCQBEmployee()

See Also

OCQBTimer..::.OCQBEmployee Class
OCQBTimer..::.OCQBEmployee Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBEmployee Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee Constructor (SerializationInfo, StreamingContext)
OCQBTimer..::.OCQBEmployee Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBEmployee(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
OCQBEmployee(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

OCQBTimer..::.OCQBEmployee Class
OCQBTimer..::.OCQBEmployee Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBEmployee Methods

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee Methods
OCQBTimer..::.OCQBEmployee Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBEmployee type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCQBTimer..::.OCQBEmployee Class
OfficeClip.BusinessLayer.Sync Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee..::.GetObjectData Method
OCQBTimer..::.OCQBEmployee Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

OCQBTimer..::.OCQBEmployee Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBEmployee Properties

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee Properties
OCQBTimer..::.OCQBEmployee Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBEmployee type exposes the following properties.

Properties

 | Name | Description
Public property | name | The name of the employee.
Public property | RefNum | The reference number of the employee
Public property | ScreenName | The screen name of the employee.
Public property | Timestamp | the Timestamp whent he employee record is created.

See Also

OCQBTimer..::.OCQBEmployee Class
OfficeClip.BusinessLayer.Sync Namespace


name Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee..::.name Property
OCQBTimer..::.OCQBEmployee Class See Also

[This is preliminary documentation and is subject to change.]

The name of the employee.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string name { get; set; }
Visual Basic (Declaration)
Public Property name As String
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBEmployee Class
OfficeClip.BusinessLayer.Sync Namespace


RefNum Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee..::.RefNum Property
OCQBTimer..::.OCQBEmployee Class See Also

[This is preliminary documentation and is subject to change.]

The reference number of the employee

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RefNum { get; set; }
Visual Basic (Declaration)
Public Property RefNum As String
Visual C++
public:
property String^ RefNum {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBEmployee Class
OfficeClip.BusinessLayer.Sync Namespace


ScreenName Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee..::.ScreenName Property
OCQBTimer..::.OCQBEmployee Class See Also

[This is preliminary documentation and is subject to change.]

The screen name of the employee.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ScreenName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScreenName As String
Visual C++
public:
property String^ ScreenName {
    String^ get ();
}

See Also

OCQBTimer..::.OCQBEmployee Class
OfficeClip.BusinessLayer.Sync Namespace


Timestamp Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBEmployee..::.Timestamp Property
OCQBTimer..::.OCQBEmployee Class See Also

[This is preliminary documentation and is subject to change.]

the Timestamp whent he employee record is created.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Timestamp { get; set; }
Visual Basic (Declaration)
Public Property Timestamp As Integer
Visual C++
public:
property int Timestamp {
    int get ();
    void set (int value);
}

See Also

OCQBTimer..::.OCQBEmployee Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBHeader Class

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader Class
OCQBTimer Class Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the quickbooks headers.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class OCQBHeader : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OCQBHeader _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class OCQBHeader : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCQBTimer..::.OCQBHeader

See Also

OCQBTimer..::.OCQBHeader Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBHeader Members

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader Members
OCQBTimer..::.OCQBHeader Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access information related to the OfficeClip and Quickbooks interface.

The OCQBTimer..::.OCQBHeader type exposes the following members.

Constructors

 | Name | Description
Public method | OCQBTimer..::.OCQBHeader | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccntNT | Quickbooks account.
Public property | AccntNTSplitTime | Quickbooks account split time.
Public property | Date | Date created.
Public property | IifVersion | The quickbooks iif Version.
Public property | Product | The name of the Product.
Public property | ProductRelease | The release of the Product.
Public property | ProductVersion | The Version of the Product.
Public property | Time | Time created.

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBHeader Constructor

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader Constructor
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCQBTimer..::.OCQBHeader()()() | The default constructor.
Public method | OCQBTimer..::.OCQBHeader(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

OCQBTimer..::.OCQBHeader Class
OCQBTimer..::.OCQBHeader Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBHeader Constructor

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader Constructor
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBHeader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCQBHeader()

See Also

OCQBTimer..::.OCQBHeader Class
OCQBTimer..::.OCQBHeader Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBHeader Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader Constructor (SerializationInfo, StreamingContext)
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBHeader(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
OCQBHeader(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

OCQBTimer..::.OCQBHeader Class
OCQBTimer..::.OCQBHeader Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBHeader Methods

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader Methods
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBHeader type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader..::.GetObjectData Method
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBHeader Properties

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader Properties
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBHeader type exposes the following properties.

Properties

 | Name | Description
Public property | AccntNT | Quickbooks account.
Public property | AccntNTSplitTime | Quickbooks account split time.
Public property | Date | Date created.
Public property | IifVersion | The quickbooks iif Version.
Public property | Product | The name of the Product.
Public property | ProductRelease | The release of the Product.
Public property | ProductVersion | The Version of the Product.
Public property | Time | Time created.

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


AccntNT Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader..::.AccntNT Property
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

Quickbooks account.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AccntNT { get; set; }
Visual Basic (Declaration)
Public Property AccntNT As String
Visual C++
public:
property String^ AccntNT {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


AccntNTSplitTime Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader..::.AccntNTSplitTime Property
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

Quickbooks account split time.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AccntNTSplitTime { get; set; }
Visual Basic (Declaration)
Public Property AccntNTSplitTime As String
Visual C++
public:
property String^ AccntNTSplitTime {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


Date Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader..::.Date Property
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

Date created.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Date { get; set; }
Visual Basic (Declaration)
Public Property Date As String
Visual C++
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


IifVersion Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader..::.IifVersion Property
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

The quickbooks iif Version.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IifVersion { get; set; }
Visual Basic (Declaration)
Public Property IifVersion As String
Visual C++
public:
property String^ IifVersion {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


Product Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader..::.Product Property
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

The name of the Product.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Product { get; set; }
Visual Basic (Declaration)
Public Property Product As String
Visual C++
public:
property String^ Product {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


ProductRelease Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader..::.ProductRelease Property
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

The release of the Product.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProductRelease { get; set; }
Visual Basic (Declaration)
Public Property ProductRelease As String
Visual C++
public:
property String^ ProductRelease {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


ProductVersion Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader..::.ProductVersion Property
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

The Version of the Product.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProductVersion { get; set; }
Visual Basic (Declaration)
Public Property ProductVersion As String
Visual C++
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


Time Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBHeader..::.Time Property
OCQBTimer..::.OCQBHeader Class See Also

[This is preliminary documentation and is subject to change.]

Time created.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Time { get; set; }
Visual Basic (Declaration)
Public Property Time As String
Visual C++
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBHeader Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBInvoiceItem Class

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem Class
OCQBTimer Class Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the Quickbooks invoice item.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class OCQBInvoiceItem : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OCQBInvoiceItem _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class OCQBInvoiceItem : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCQBTimer..::.OCQBInvoiceItem

See Also

OCQBTimer..::.OCQBInvoiceItem Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBInvoiceItem Members

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem Members
OCQBTimer..::.OCQBInvoiceItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access information related to the OfficeClip and Quickbooks interface.

The OCQBTimer..::.OCQBInvoiceItem type exposes the following members.

Constructors

 | Name | Description
Public method | OCQBTimer..::.OCQBInvoiceItem | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CodeAndName | The invoice item reference number.
Public property | Description | the invoice item Description.
Public property | InvoiceItemType | The invoice item type.
Public property | name | The invoice item name.
Public property | RefNum | The invoice item reference number.
Public property | Timestamp | The invoice item Timestamp

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBInvoiceItem Constructor

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem Constructor
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCQBTimer..::.OCQBInvoiceItem()()() | The default constructor.
Public method | OCQBTimer..::.OCQBInvoiceItem(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OCQBTimer..::.OCQBInvoiceItem Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBInvoiceItem Constructor

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem Constructor
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBInvoiceItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCQBInvoiceItem()

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OCQBTimer..::.OCQBInvoiceItem Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBInvoiceItem Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem Constructor (SerializationInfo, StreamingContext)
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBInvoiceItem(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
OCQBInvoiceItem(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OCQBTimer..::.OCQBInvoiceItem Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBInvoiceItem Methods

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem Methods
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBInvoiceItem type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OfficeClip.BusinessLayer.Sync Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem..::.GetObjectData Method
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBInvoiceItem Properties

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem Properties
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBInvoiceItem type exposes the following properties.

Properties

 | Name | Description
Public property | CodeAndName | The invoice item reference number.
Public property | Description | the invoice item Description.
Public property | InvoiceItemType | The invoice item type.
Public property | name | The invoice item name.
Public property | RefNum | The invoice item reference number.
Public property | Timestamp | The invoice item Timestamp

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OfficeClip.BusinessLayer.Sync Namespace


CodeAndName Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem..::.CodeAndName Property
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

The invoice item reference number.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CodeAndName { get; }
Visual Basic (Declaration)
Public ReadOnly Property CodeAndName As String
Visual C++
public:
property String^ CodeAndName {
    String^ get ();
}

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OfficeClip.BusinessLayer.Sync Namespace


Description Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem..::.Description Property
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

the invoice item Description.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OfficeClip.BusinessLayer.Sync Namespace


InvoiceItemType Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem..::.InvoiceItemType Property
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

The invoice item type.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string InvoiceItemType { get; set; }
Visual Basic (Declaration)
Public Property InvoiceItemType As String
Visual C++
public:
property String^ InvoiceItemType {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OfficeClip.BusinessLayer.Sync Namespace


name Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem..::.name Property
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

The invoice item name.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string name { get; set; }
Visual Basic (Declaration)
Public Property name As String
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OfficeClip.BusinessLayer.Sync Namespace


RefNum Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem..::.RefNum Property
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

The invoice item reference number.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RefNum { get; set; }
Visual Basic (Declaration)
Public Property RefNum As String
Visual C++
public:
property String^ RefNum {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OfficeClip.BusinessLayer.Sync Namespace


Timestamp Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBInvoiceItem..::.Timestamp Property
OCQBTimer..::.OCQBInvoiceItem Class See Also

[This is preliminary documentation and is subject to change.]

The invoice item Timestamp

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Timestamp { get; set; }
Visual Basic (Declaration)
Public Property Timestamp As Integer
Visual C++
public:
property int Timestamp {
    int get ();
    void set (int value);
}

See Also

OCQBTimer..::.OCQBInvoiceItem Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBTimeHeader Class

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader Class
OCQBTimer Class Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the quickbooks time header information.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class OCQBTimeHeader : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OCQBTimeHeader _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class OCQBTimeHeader : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCQBTimer..::.OCQBTimeHeader

See Also

OCQBTimer..::.OCQBTimeHeader Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBTimeHeader Members

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader Members
OCQBTimer..::.OCQBTimeHeader Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access information related to the OfficeClip and Quickbooks interface.

The OCQBTimer..::.OCQBTimeHeader type exposes the following members.

Constructors

 | Name | Description
Public method | OCQBTimer..::.OCQBTimeHeader | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CompanyCreateTime | The created Timestamp for the company in the quickbooks.
Public property | CompanyName | The quickbooks company name.
Public property | FromTimer | Shows if the information is gathered from the timer.
Public property | ImportedBefore | Shows whether the information is imported before.
Public property | rel | The quickbooks release.
Public property | Version | The quickbooks Version.

See Also

OCQBTimer..::.OCQBTimeHeader Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBTimeHeader Constructor

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader Constructor
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCQBTimer..::.OCQBTimeHeader()()() | The default constructor.
Public method | OCQBTimer..::.OCQBTimeHeader(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

OCQBTimer..::.OCQBTimeHeader Class
OCQBTimer..::.OCQBTimeHeader Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBTimeHeader Constructor

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader Constructor
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBTimeHeader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCQBTimeHeader()

See Also

OCQBTimer..::.OCQBTimeHeader Class
OCQBTimer..::.OCQBTimeHeader Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBTimeHeader Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader Constructor (SerializationInfo, StreamingContext)
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBTimeHeader(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
OCQBTimeHeader(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

OCQBTimer..::.OCQBTimeHeader Class
OCQBTimer..::.OCQBTimeHeader Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBTimeHeader Methods

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader Methods
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBTimeHeader type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCQBTimer..::.OCQBTimeHeader Class
OfficeClip.BusinessLayer.Sync Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader..::.GetObjectData Method
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

OCQBTimer..::.OCQBTimeHeader Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBTimeHeader Properties

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader Properties
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBTimeHeader type exposes the following properties.

Properties

 | Name | Description
Public property | CompanyCreateTime | The created Timestamp for the company in the quickbooks.
Public property | CompanyName | The quickbooks company name.
Public property | FromTimer | Shows if the information is gathered from the timer.
Public property | ImportedBefore | Shows whether the information is imported before.
Public property | rel | The quickbooks release.
Public property | Version | The quickbooks Version.

See Also

OCQBTimer..::.OCQBTimeHeader Class
OfficeClip.BusinessLayer.Sync Namespace


CompanyCreateTime Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader..::.CompanyCreateTime Property
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

The created Timestamp for the company in the quickbooks.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CompanyCreateTime { get; set; }
Visual Basic (Declaration)
Public Property CompanyCreateTime As String
Visual C++
public:
property String^ CompanyCreateTime {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBTimeHeader Class
OfficeClip.BusinessLayer.Sync Namespace


CompanyName Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader..::.CompanyName Property
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

The quickbooks company name.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CompanyName { get; set; }
Visual Basic (Declaration)
Public Property CompanyName As String
Visual C++
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBTimeHeader Class
OfficeClip.BusinessLayer.Sync Namespace


FromTimer Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader..::.FromTimer Property
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the information is gathered from the timer.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FromTimer { get; set; }
Visual Basic (Declaration)
Public Property FromTimer As String
Visual C++
public:
property String^ FromTimer {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBTimeHeader Class
OfficeClip.BusinessLayer.Sync Namespace


ImportedBefore Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader..::.ImportedBefore Property
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the information is imported before.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ImportedBefore { get; set; }
Visual Basic (Declaration)
Public Property ImportedBefore As String
Visual C++
public:
property String^ ImportedBefore {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBTimeHeader Class
OfficeClip.BusinessLayer.Sync Namespace


rel Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader..::.rel Property
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

The quickbooks release.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int rel { get; set; }
Visual Basic (Declaration)
Public Property rel As Integer
Visual C++
public:
property int rel {
    int get ();
    void set (int value);
}

See Also

OCQBTimer..::.OCQBTimeHeader Class
OfficeClip.BusinessLayer.Sync Namespace


Version Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBTimeHeader..::.Version Property
OCQBTimer..::.OCQBTimeHeader Class See Also

[This is preliminary documentation and is subject to change.]

The quickbooks Version.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Version { get; set; }
Visual Basic (Declaration)
Public Property Version As Integer
Visual C++
public:
property int Version {
    int get ();
    void set (int value);
}

See Also

OCQBTimer..::.OCQBTimeHeader Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBVendor Class

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor Class
OCQBTimer Class Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the quickbooks Vendors.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class OCQBVendor : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OCQBVendor _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class OCQBVendor : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCQBTimer..::.OCQBVendor

See Also

OCQBTimer..::.OCQBVendor Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBVendor Members

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor Members
OCQBTimer..::.OCQBVendor Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access information related to the OfficeClip and Quickbooks interface.

The OCQBTimer..::.OCQBVendor type exposes the following members.

Constructors

 | Name | Description
Public method | OCQBTimer..::.OCQBVendor | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | name | The name of the vendor.
Public property | RefNum | The reference number of teh vendor.
Public property | ScreenName | The screen name of the vendor.
Public property | Timestamp | the Timestamp when the vendor is created.

See Also

OCQBTimer..::.OCQBVendor Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBVendor Constructor

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor Constructor
OCQBTimer..::.OCQBVendor Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCQBTimer..::.OCQBVendor()()() | The default constructor.
Public method | OCQBTimer..::.OCQBVendor(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

OCQBTimer..::.OCQBVendor Class
OCQBTimer..::.OCQBVendor Members
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBVendor Constructor

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor Constructor
OCQBTimer..::.OCQBVendor Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBVendor()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCQBVendor()

See Also

OCQBTimer..::.OCQBVendor Class
OCQBTimer..::.OCQBVendor Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBVendor Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor Constructor (SerializationInfo, StreamingContext)
OCQBTimer..::.OCQBVendor Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCQBVendor(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
OCQBVendor(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

OCQBTimer..::.OCQBVendor Class
OCQBTimer..::.OCQBVendor Overload
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBVendor Methods

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor Methods
OCQBTimer..::.OCQBVendor Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBVendor type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCQBTimer..::.OCQBVendor Class
OfficeClip.BusinessLayer.Sync Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor..::.GetObjectData Method
OCQBTimer..::.OCQBVendor Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

OCQBTimer..::.OCQBVendor Class
OfficeClip.BusinessLayer.Sync Namespace


OCQBTimer.OCQBVendor Properties

[image] [image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor Properties
OCQBTimer..::.OCQBVendor Class See Also

[This is preliminary documentation and is subject to change.]

The OCQBTimer..::.OCQBVendor type exposes the following properties.

Properties

 | Name | Description
Public property | name | The name of the vendor.
Public property | RefNum | The reference number of teh vendor.
Public property | ScreenName | The screen name of the vendor.
Public property | Timestamp | the Timestamp when the vendor is created.

See Also

OCQBTimer..::.OCQBVendor Class
OfficeClip.BusinessLayer.Sync Namespace


name Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor..::.name Property
OCQBTimer..::.OCQBVendor Class See Also

[This is preliminary documentation and is subject to change.]

The name of the vendor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string name { get; set; }
Visual Basic (Declaration)
Public Property name As String
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBVendor Class
OfficeClip.BusinessLayer.Sync Namespace


RefNum Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor..::.RefNum Property
OCQBTimer..::.OCQBVendor Class See Also

[This is preliminary documentation and is subject to change.]

The reference number of teh vendor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RefNum { get; set; }
Visual Basic (Declaration)
Public Property RefNum As String
Visual C++
public:
property String^ RefNum {
    String^ get ();
    void set (String^ value);
}

See Also

OCQBTimer..::.OCQBVendor Class
OfficeClip.BusinessLayer.Sync Namespace


ScreenName Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor..::.ScreenName Property
OCQBTimer..::.OCQBVendor Class See Also

[This is preliminary documentation and is subject to change.]

The screen name of the vendor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ScreenName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScreenName As String
Visual C++
public:
property String^ ScreenName {
    String^ get ();
}

See Also

OCQBTimer..::.OCQBVendor Class
OfficeClip.BusinessLayer.Sync Namespace


Timestamp Property

[image]

OfficeClip API Documentation
OCQBTimer..::.OCQBVendor..::.Timestamp Property
OCQBTimer..::.OCQBVendor Class See Also

[This is preliminary documentation and is subject to change.]

the Timestamp when the vendor is created.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Timestamp { get; set; }
Visual Basic (Declaration)
Public Property Timestamp As Integer
Visual C++
public:
property int Timestamp {
    int get ();
    void set (int value);
}

See Also

OCQBTimer..::.OCQBVendor Class
OfficeClip.BusinessLayer.Sync Namespace


OCUserInfo Class

[image]

OfficeClip API Documentation
OCUserInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the user information for the CSV file.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCUserInfo : UserInfo, IOCDateTimeFormatInfo
Visual Basic (Declaration)
Public Class OCUserInfo _
    Inherits UserInfo _
    Implements IOCDateTimeFormatInfo
Visual C++
public ref class OCUserInfo : public UserInfo,
    IOCDateTimeFormatInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Account..::.UserInfo
OfficeClip.BusinessLayer.Sync..::.OCUserInfo

See Also

OCUserInfo Members
OfficeClip.BusinessLayer.Sync Namespace


OCUserInfo Members

[image] [image]

OfficeClip API Documentation
OCUserInfo Members
OCUserInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCUserInfo type exposes the following members.

Constructors

 | Name | Description
Public method | OCUserInfo | Overloaded.

Methods

 | Name | Description
Public method | Dump | Dumps the information for debugging (Inherited from UserInfo.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserInfo | Gets the user information object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShowFullName | Show the full name of the user (Inherited from UserInfo.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccessRightsId | The access rights identifier of the user. (Inherited from UserInfo.)
Public property | ActivationCode | The activation code of the user record. (Inherited from UserInfo.)
Public property | Active | Shows if the user is active. Valid values are "Y" (active) and "N" (inactive). (Inherited from UserInfo.)
Public property | BirthDate | The birth date of the user. (Inherited from UserInfo.)
Public property | Cell_Phone | The mobile phone number.
Public property | CellPhone | The mobile phone number of for the user. (Inherited from UserInfo.)
Public property | CurrencyCode | The currency code (Inherited from UserInfo.)
Public property | DateFormatStr | The date format string.
Public property | DateTimeFormat | The datetime format for the date and time information represented in the csv file.
Public property | Email_Address | The email Address of the user on the object.
Public property | EmailAddress | The email Address of the user. (Inherited from UserInfo.)
Public property | Fax_Number | The fax number.
Public property | FaxNumber | The fax number of the user. (Inherited from UserInfo.)
Public property | First_Name | The first name of the user on the object.
Public property | FirstName | The first name of the user. (Inherited from UserInfo.)
Public property | FullName | The full name (Inherited from UserInfo.)
Public property | FullNameWithEmail | Gets the full name with email (Inherited from UserInfo.)
Public property | Gdf1Name | The first group defined field name. (Inherited from UserInfo.)
Public property | Gdf1Value | The first group defined field value. (Inherited from UserInfo.)
Public property | Gdf2Name | The second group defined field name. (Inherited from UserInfo.)
Public property | Gdf2Value | The second group defined field value. (Inherited from UserInfo.)
Public property | Gdf3Name | The third group defined field name. (Inherited from UserInfo.)
Public property | Gdf3Value | The third group defined field value. (Inherited from UserInfo.)
Public property | Gdf4Name | The fourth group defined field name. (Inherited from UserInfo.)
Public property | Gdf4Value | The fourth group defined field value. (Inherited from UserInfo.)
Public property | Gdf5Name | The fifth group defined field name. (Inherited from UserInfo.)
Public property | Gdf5Value | The fifth group defined field value. (Inherited from UserInfo.)
Public property | Home_Address_Line1 | The Line 1 of the home Address.
Public property | Home_Address_Line2 | The line 2 of the home Address.
Public property | Home_City | The home city.
Public property | Home_Country | The home Country.
Public property | Home_Page | the url of the home page.
Public property | Home_Phone | The home phone number for the object.
Public property | Home_State | The home State.
Public property | Home_Zip | The home zip code.
Public property | HomeAddress | The home Address of the user. (Inherited from UserInfo.)
Public property | HomeAddressId | The home Address identifier of the user. (Inherited from UserInfo.)
Public property | HomePage | The homepage for the user. (Inherited from UserInfo.)
Public property | HomePhone | The home phone number of the user. (Inherited from UserInfo.)
Public property | IsAdmin | Shows if the user is an administrator. This field is context sensitive. If the user information is collected wrt a group, it will be group admin. For account users, it will signify account administrator. (Inherited from UserInfo.)
Public property | IsCodeActivated | Shows if the activation code is used by the invited user and the account is activated. (Inherited from UserInfo.)
Public property | IsExtranetUser | Returns true if user is a Extranet User (Inherited from UserInfo.)
Public property | Last_Name | The last name of the user on the object.
Public property | LastName | The last name of the user. (Inherited from UserInfo.)
Public property | LastUpdatedByUserId | The user identifier of the user who last updated the user record. (Inherited from UserInfo.)
Public property | LastUpdatedTimestamp | The Timestamp of when the user record is last updated. (Inherited from UserInfo.)
Public property | Ldap_Account_Name | The LDAP account name for the user.
Public property | LdapAccountName | The ldap account name of the user. (Inherited from UserInfo.)
Public property | Location | Location
Public property | MobileEmailAddress | Gets the mobile email address (Inherited from UserInfo.)
Public property | Notes | The Notes for the user. (Inherited from UserInfo.)
Public property | Organization | The Organization name where the user belongs to. This is not necessarily same as the OfficeClip Organization which the user is a memner of.
Public property | Other_Phone | The other phone number.
Public property | OtherPhone | The other phone number of the user. (Inherited from UserInfo.)
Public property | Password | the Password for the user.
Public property | PreferredPhoneNumber | The preferred phone number of the user. The value is 1 for work1, 2 for work2, 3 for home, 4 for other and 5 for cell, the value is null if not set. (Inherited from UserInfo.)
Public property | PreferredPhoneValue | The preferred phone value (Inherited from UserInfo.)
Public property | ReadTermsCond | Shows whether the user has read the terms and conditions. Valid values are "Y" (read terms and conditions) and "N" (not read the terms and conditions). (Inherited from UserInfo.)
Public property | ResetPassword | Shows whether the Password is reset. Valid values are "Y" (Password is reset) and "N" (the Password is not reset). (Inherited from UserInfo.)
Public property | TimeFormatStr | The time format string.
Public property | Title | The Organization Title.
Public property | Udf1Name | The first user defined name of the user object. (Inherited from UserInfo.)
Public property | Udf1Value | The first user defined field value of the user. (Inherited from UserInfo.)
Public property | Udf2Name | The second user defined field name of the user. (Inherited from UserInfo.)
Public property | Udf2Value | The value of the second user defined field for the user. (Inherited from UserInfo.)
Public property | UserCreatedTimestamp | The Timestamp of the user record creation. (Inherited from UserInfo.)
Public property | UserId | The system generated unique identifier for the user. (Inherited from UserInfo.)
Public property | UserSmsInfo | (Inherited from UserInfo.)
Public property | Work_Address_Line1 | The line 1 of the work Address.
Public property | Work_Address_Line2 | The line 2 of the work Address.
Public property | Work_City | the city for the work Address.
Public property | Work_Country | The Country for the work Address.
Public property | Work_Phone_Primary | The primary work telephone number for the user.
Public property | Work_Phone_Secondary | The secondary work phone number for the object.
Public property | Work_State | The State of the work Address.
Public property | Work_Zip | The zip code for the work Address.
Public property | WorkAddress | The work Address of the user. (Inherited from UserInfo.)
Public property | WorkAddressId | The work Address identifier of the user. (Inherited from UserInfo.)
Public property | WorkPhonePrimary | The primary work phone of the user. (Inherited from UserInfo.)
Public property | WorkPhoneSecondary | The secondary work phone of the user. (Inherited from UserInfo.)
Public property | WorkTitle | The work Title of the user. (Inherited from UserInfo.)

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


OCUserInfo Constructor

[image] [image]

OfficeClip API Documentation
OCUserInfo Constructor
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCUserInfo()()() | The default constructor.
Public method | OCUserInfo(UserInfo) | The constructor that creates this object out of the user information object.

See Also

OCUserInfo Class
OCUserInfo Members
OfficeClip.BusinessLayer.Sync Namespace


OCUserInfo Constructor

[image]

OfficeClip API Documentation
OCUserInfo Constructor
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCUserInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCUserInfo()

See Also

OCUserInfo Class
OCUserInfo Overload
OfficeClip.BusinessLayer.Sync Namespace


OCUserInfo Constructor (UserInfo)

[image]

OfficeClip API Documentation
OCUserInfo Constructor (UserInfo)
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor that creates this object out of the user information object.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCUserInfo(
    UserInfo ui
)
Visual Basic (Declaration)
Public Sub New ( _
    ui As UserInfo _
)
Visual C++
public:
OCUserInfo(
    UserInfo^ ui
)

Parameters

ui
Type: OfficeClip.BusinessLayer.Account..::.UserInfo
The user information object.

See Also

OCUserInfo Class
OCUserInfo Overload
OfficeClip.BusinessLayer.Sync Namespace


OCUserInfo Methods

[image] [image]

OfficeClip API Documentation
OCUserInfo Methods
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The OCUserInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumps the information for debugging (Inherited from UserInfo.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserInfo | Gets the user information object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShowFullName | Show the full name of the user (Inherited from UserInfo.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


GetUserInfo Method

[image]

OfficeClip API Documentation
OCUserInfo..::.GetUserInfo Method
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the user information object.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserInfo GetUserInfo()
Visual Basic (Declaration)
Public Function GetUserInfo As UserInfo
Visual C++
public:
UserInfo^ GetUserInfo()

Return Value

The user information object.

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


OCUserInfo Properties

[image] [image]

OfficeClip API Documentation
OCUserInfo Properties
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The OCUserInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccessRightsId | The access rights identifier of the user. (Inherited from UserInfo.)
Public property | ActivationCode | The activation code of the user record. (Inherited from UserInfo.)
Public property | Active | Shows if the user is active. Valid values are "Y" (active) and "N" (inactive). (Inherited from UserInfo.)
Public property | BirthDate | The birth date of the user. (Inherited from UserInfo.)
Public property | Cell_Phone | The mobile phone number.
Public property | CellPhone | The mobile phone number of for the user. (Inherited from UserInfo.)
Public property | CurrencyCode | The currency code (Inherited from UserInfo.)
Public property | DateFormatStr | The date format string.
Public property | DateTimeFormat | The datetime format for the date and time information represented in the csv file.
Public property | Email_Address | The email Address of the user on the object.
Public property | EmailAddress | The email Address of the user. (Inherited from UserInfo.)
Public property | Fax_Number | The fax number.
Public property | FaxNumber | The fax number of the user. (Inherited from UserInfo.)
Public property | First_Name | The first name of the user on the object.
Public property | FirstName | The first name of the user. (Inherited from UserInfo.)
Public property | FullName | The full name (Inherited from UserInfo.)
Public property | FullNameWithEmail | Gets the full name with email (Inherited from UserInfo.)
Public property | Gdf1Name | The first group defined field name. (Inherited from UserInfo.)
Public property | Gdf1Value | The first group defined field value. (Inherited from UserInfo.)
Public property | Gdf2Name | The second group defined field name. (Inherited from UserInfo.)
Public property | Gdf2Value | The second group defined field value. (Inherited from UserInfo.)
Public property | Gdf3Name | The third group defined field name. (Inherited from UserInfo.)
Public property | Gdf3Value | The third group defined field value. (Inherited from UserInfo.)
Public property | Gdf4Name | The fourth group defined field name. (Inherited from UserInfo.)
Public property | Gdf4Value | The fourth group defined field value. (Inherited from UserInfo.)
Public property | Gdf5Name | The fifth group defined field name. (Inherited from UserInfo.)
Public property | Gdf5Value | The fifth group defined field value. (Inherited from UserInfo.)
Public property | Home_Address_Line1 | The Line 1 of the home Address.
Public property | Home_Address_Line2 | The line 2 of the home Address.
Public property | Home_City | The home city.
Public property | Home_Country | The home Country.
Public property | Home_Page | the url of the home page.
Public property | Home_Phone | The home phone number for the object.
Public property | Home_State | The home State.
Public property | Home_Zip | The home zip code.
Public property | HomeAddress | The home Address of the user. (Inherited from UserInfo.)
Public property | HomeAddressId | The home Address identifier of the user. (Inherited from UserInfo.)
Public property | HomePage | The homepage for the user. (Inherited from UserInfo.)
Public property | HomePhone | The home phone number of the user. (Inherited from UserInfo.)
Public property | IsAdmin | Shows if the user is an administrator. This field is context sensitive. If the user information is collected wrt a group, it will be group admin. For account users, it will signify account administrator. (Inherited from UserInfo.)
Public property | IsCodeActivated | Shows if the activation code is used by the invited user and the account is activated. (Inherited from UserInfo.)
Public property | IsExtranetUser | Returns true if user is a Extranet User (Inherited from UserInfo.)
Public property | Last_Name | The last name of the user on the object.
Public property | LastName | The last name of the user. (Inherited from UserInfo.)
Public property | LastUpdatedByUserId | The user identifier of the user who last updated the user record. (Inherited from UserInfo.)
Public property | LastUpdatedTimestamp | The Timestamp of when the user record is last updated. (Inherited from UserInfo.)
Public property | Ldap_Account_Name | The LDAP account name for the user.
Public property | LdapAccountName | The ldap account name of the user. (Inherited from UserInfo.)
Public property | Location | Location
Public property | MobileEmailAddress | Gets the mobile email address (Inherited from UserInfo.)
Public property | Notes | The Notes for the user. (Inherited from UserInfo.)
Public property | Organization | The Organization name where the user belongs to. This is not necessarily same as the OfficeClip Organization which the user is a memner of.
Public property | Other_Phone | The other phone number.
Public property | OtherPhone | The other phone number of the user. (Inherited from UserInfo.)
Public property | Password | the Password for the user.
Public property | PreferredPhoneNumber | The preferred phone number of the user. The value is 1 for work1, 2 for work2, 3 for home, 4 for other and 5 for cell, the value is null if not set. (Inherited from UserInfo.)
Public property | PreferredPhoneValue | The preferred phone value (Inherited from UserInfo.)
Public property | ReadTermsCond | Shows whether the user has read the terms and conditions. Valid values are "Y" (read terms and conditions) and "N" (not read the terms and conditions). (Inherited from UserInfo.)
Public property | ResetPassword | Shows whether the Password is reset. Valid values are "Y" (Password is reset) and "N" (the Password is not reset). (Inherited from UserInfo.)
Public property | TimeFormatStr | The time format string.
Public property | Title | The Organization Title.
Public property | Udf1Name | The first user defined name of the user object. (Inherited from UserInfo.)
Public property | Udf1Value | The first user defined field value of the user. (Inherited from UserInfo.)
Public property | Udf2Name | The second user defined field name of the user. (Inherited from UserInfo.)
Public property | Udf2Value | The value of the second user defined field for the user. (Inherited from UserInfo.)
Public property | UserCreatedTimestamp | The Timestamp of the user record creation. (Inherited from UserInfo.)
Public property | UserId | The system generated unique identifier for the user. (Inherited from UserInfo.)
Public property | UserSmsInfo | (Inherited from UserInfo.)
Public property | Work_Address_Line1 | The line 1 of the work Address.
Public property | Work_Address_Line2 | The line 2 of the work Address.
Public property | Work_City | the city for the work Address.
Public property | Work_Country | The Country for the work Address.
Public property | Work_Phone_Primary | The primary work telephone number for the user.
Public property | Work_Phone_Secondary | The secondary work phone number for the object.
Public property | Work_State | The State of the work Address.
Public property | Work_Zip | The zip code for the work Address.
Public property | WorkAddress | The work Address of the user. (Inherited from UserInfo.)
Public property | WorkAddressId | The work Address identifier of the user. (Inherited from UserInfo.)
Public property | WorkPhonePrimary | The primary work phone of the user. (Inherited from UserInfo.)
Public property | WorkPhoneSecondary | The secondary work phone of the user. (Inherited from UserInfo.)
Public property | WorkTitle | The work Title of the user. (Inherited from UserInfo.)

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Cell_Phone Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Cell_Phone Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The mobile phone number.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Cell_Phone { get; set; }
Visual Basic (Declaration)
Public Property Cell_Phone As String
Visual C++
public:
property String^ Cell_Phone {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


DateFormatStr Property

[image]

OfficeClip API Documentation
OCUserInfo..::.DateFormatStr Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date format string.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DateFormatStr { set; }
Visual Basic (Declaration)
Public WriteOnly Property DateFormatStr As String
Visual C++
public:
virtual property String^ DateFormatStr {
    void set (String^ value) sealed;
}

Implements

IOCDateTimeFormatInfo..::.DateFormatStr

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


DateTimeFormat Property

[image]

OfficeClip API Documentation
OCUserInfo..::.DateTimeFormat Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The datetime format for the date and time information represented in the csv file.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTimeFormatInfo DateTimeFormat { set; }
Visual Basic (Declaration)
Public WriteOnly Property DateTimeFormat As DateTimeFormatInfo
Visual C++
public:
virtual property DateTimeFormatInfo^ DateTimeFormat {
    void set (DateTimeFormatInfo^ value) sealed;
}

Implements

IOCDateTimeFormatInfo..::.DateTimeFormat

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Email_Address Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Email_Address Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Address of the user on the object.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Email_Address { get; set; }
Visual Basic (Declaration)
Public Property Email_Address As String
Visual C++
public:
property String^ Email_Address {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Fax_Number Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Fax_Number Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The fax number.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Fax_Number { get; set; }
Visual Basic (Declaration)
Public Property Fax_Number As String
Visual C++
public:
property String^ Fax_Number {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


First_Name Property

[image]

OfficeClip API Documentation
OCUserInfo..::.First_Name Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first name of the user on the object.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string First_Name { get; set; }
Visual Basic (Declaration)
Public Property First_Name As String
Visual C++
public:
property String^ First_Name {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Home_Address_Line1 Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Home_Address_Line1 Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Line 1 of the home Address.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Home_Address_Line1 { get; set; }
Visual Basic (Declaration)
Public Property Home_Address_Line1 As String
Visual C++
public:
property String^ Home_Address_Line1 {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Home_Address_Line2 Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Home_Address_Line2 Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The line 2 of the home Address.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Home_Address_Line2 { get; set; }
Visual Basic (Declaration)
Public Property Home_Address_Line2 As String
Visual C++
public:
property String^ Home_Address_Line2 {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Home_City Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Home_City Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The home city.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Home_City { get; set; }
Visual Basic (Declaration)
Public Property Home_City As String
Visual C++
public:
property String^ Home_City {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Home_Country Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Home_Country Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The home Country.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Home_Country { get; set; }
Visual Basic (Declaration)
Public Property Home_Country As String
Visual C++
public:
property String^ Home_Country {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Home_Page Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Home_Page Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

the url of the home page.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Home_Page { get; set; }
Visual Basic (Declaration)
Public Property Home_Page As String
Visual C++
public:
property String^ Home_Page {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Home_Phone Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Home_Phone Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The home phone number for the object.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Home_Phone { get; set; }
Visual Basic (Declaration)
Public Property Home_Phone As String
Visual C++
public:
property String^ Home_Phone {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Home_State Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Home_State Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The home State.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Home_State { get; set; }
Visual Basic (Declaration)
Public Property Home_State As String
Visual C++
public:
property String^ Home_State {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Home_Zip Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Home_Zip Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The home zip code.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Home_Zip { get; set; }
Visual Basic (Declaration)
Public Property Home_Zip As String
Visual C++
public:
property String^ Home_Zip {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Last_Name Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Last_Name Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last name of the user on the object.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Last_Name { get; set; }
Visual Basic (Declaration)
Public Property Last_Name As String
Visual C++
public:
property String^ Last_Name {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Ldap_Account_Name Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Ldap_Account_Name Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The LDAP account name for the user.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Ldap_Account_Name { get; set; }
Visual Basic (Declaration)
Public Property Ldap_Account_Name As String
Visual C++
public:
property String^ Ldap_Account_Name {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Location Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Location Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

Location

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Location { get; set; }
Visual Basic (Declaration)
Public Property Location As String
Visual C++
public:
property String^ Location {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Organization Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Organization Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Organization name where the user belongs to. This is not necessarily same as the OfficeClip Organization which the user is a memner of.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Organization { get; set; }
Visual Basic (Declaration)
Public Property Organization As String
Visual C++
public:
property String^ Organization {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Other_Phone Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Other_Phone Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The other phone number.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Other_Phone { get; set; }
Visual Basic (Declaration)
Public Property Other_Phone As String
Visual C++
public:
property String^ Other_Phone {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Password Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Password Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

the Password for the user.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


TimeFormatStr Property

[image]

OfficeClip API Documentation
OCUserInfo..::.TimeFormatStr Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time format string.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TimeFormatStr { set; }
Visual Basic (Declaration)
Public WriteOnly Property TimeFormatStr As String
Visual C++
public:
virtual property String^ TimeFormatStr {
    void set (String^ value) sealed;
}

Implements

IOCDateTimeFormatInfo..::.TimeFormatStr

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Title Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Title Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Organization Title.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Work_Address_Line1 Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Work_Address_Line1 Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The line 1 of the work Address.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Work_Address_Line1 { get; set; }
Visual Basic (Declaration)
Public Property Work_Address_Line1 As String
Visual C++
public:
property String^ Work_Address_Line1 {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Work_Address_Line2 Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Work_Address_Line2 Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The line 2 of the work Address.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Work_Address_Line2 { get; set; }
Visual Basic (Declaration)
Public Property Work_Address_Line2 As String
Visual C++
public:
property String^ Work_Address_Line2 {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Work_City Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Work_City Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

the city for the work Address.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Work_City { get; set; }
Visual Basic (Declaration)
Public Property Work_City As String
Visual C++
public:
property String^ Work_City {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Work_Country Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Work_Country Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Country for the work Address.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Work_Country { get; set; }
Visual Basic (Declaration)
Public Property Work_Country As String
Visual C++
public:
property String^ Work_Country {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Work_Phone_Primary Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Work_Phone_Primary Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The primary work telephone number for the user.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Work_Phone_Primary { get; set; }
Visual Basic (Declaration)
Public Property Work_Phone_Primary As String
Visual C++
public:
property String^ Work_Phone_Primary {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Work_Phone_Secondary Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Work_Phone_Secondary Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The secondary work phone number for the object.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Work_Phone_Secondary { get; set; }
Visual Basic (Declaration)
Public Property Work_Phone_Secondary As String
Visual C++
public:
property String^ Work_Phone_Secondary {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Work_State Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Work_State Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The State of the work Address.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Work_State { get; set; }
Visual Basic (Declaration)
Public Property Work_State As String
Visual C++
public:
property String^ Work_State {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


Work_Zip Property

[image]

OfficeClip API Documentation
OCUserInfo..::.Work_Zip Property
OCUserInfo Class See Also

[This is preliminary documentation and is subject to change.]

The zip code for the work Address.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Work_Zip { get; set; }
Visual Basic (Declaration)
Public Property Work_Zip As String
Visual C++
public:
property String^ Work_Zip {
    String^ get ();
    void set (String^ value);
}

See Also

OCUserInfo Class
OfficeClip.BusinessLayer.Sync Namespace


OCVCalendar Class

[image]

OfficeClip API Documentation
OCVCalendar Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the vCalendar collection.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCVCalendar : ICollection,
    IEnumerable
Visual Basic (Declaration)
Public Class OCVCalendar _
    Implements ICollection, IEnumerable
Visual C++
public ref class OCVCalendar : ICollection,
    IEnumerable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCVCalendar

See Also

OCVCalendar Members
OfficeClip.BusinessLayer.Sync Namespace


OCVCalendar Members

[image] [image]

OfficeClip API Documentation
OCVCalendar Members
OCVCalendar Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCVCalendar type exposes the following members.

Constructors

 | Name | Description
Public method | OCVCalendar | Overloaded.

Methods

 | Name | Description
Public method | add | Adds an event ot the collection.
Public method | CopyTo | Copy the object to an array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Get an enumerator to enumerate through the collection. This function is not implemented and any attempt to use it throws an exception.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Store | Writes the current object to the stringwriter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Number of events in the collection.
Public property | IsSynchronized | Gets a value which says whether the access to the object is synchronized (thread-safe).
Public property | Item | Indexer to return the event using the index in the collection.
Public property | Status | returns 0 if successful, -1 the file is not in the vCard -2 the file is ill-formed -3 vCard file Version not supported
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


OCVCalendar Constructor

[image] [image]

OfficeClip API Documentation
OCVCalendar Constructor
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCVCalendar(TimeZoneInfo) | The default constructor.
Public method | OCVCalendar(ArrayList, TimeZoneInfo) | Constructor that creates the object with the list of events.
Public method | OCVCalendar(HttpPostedFile, TimeZoneInfo) | Reads the calendar into EventInfo structure. Can only read one calendar currently

See Also

OCVCalendar Class
OCVCalendar Members
OfficeClip.BusinessLayer.Sync Namespace


OCVCalendar Constructor (TimeZoneInfo)

[image]

OfficeClip API Documentation
OCVCalendar Constructor (TimeZoneInfo)
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCVCalendar(
    TimeZoneInfo userTzInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    userTzInfo As TimeZoneInfo _
)
Visual C++
public:
OCVCalendar(
    TimeZoneInfo^ userTzInfo
)

Parameters

userTzInfo
Type: OfficeClip.Utils..::.TimeZoneInfo

See Also

OCVCalendar Class
OCVCalendar Overload
OfficeClip.BusinessLayer.Sync Namespace


OCVCalendar Constructor (ArrayList, TimeZoneInfo)

[image]

OfficeClip API Documentation
OCVCalendar Constructor (ArrayList, TimeZoneInfo)
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that creates the object with the list of events.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCVCalendar(
    ArrayList eventList,
    TimeZoneInfo userTzInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    eventList As ArrayList, _
    userTzInfo As TimeZoneInfo _
)
Visual C++
public:
OCVCalendar(
    ArrayList^ eventList,
    TimeZoneInfo^ userTzInfo
)

Parameters

eventList
Type: System.Collections..::.ArrayList
The list of OfficeClip events.
userTzInfo
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone information

See Also

OCVCalendar Class
OCVCalendar Overload
OfficeClip.BusinessLayer.Sync Namespace


OCVCalendar Constructor (HttpPostedFile, TimeZoneInfo)

[image]

OfficeClip API Documentation
OCVCalendar Constructor (HttpPostedFile, TimeZoneInfo)
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

Reads the calendar into EventInfo structure. Can only read one calendar currently

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCVCalendar(
    HttpPostedFile pFile,
    TimeZoneInfo userTzinfo
)
Visual Basic (Declaration)
Public Sub New ( _
    pFile As HttpPostedFile, _
    userTzinfo As TimeZoneInfo _
)
Visual C++
public:
OCVCalendar(
    HttpPostedFile^ pFile,
    TimeZoneInfo^ userTzinfo
)

Parameters

pFile
Type: System.Web..::.HttpPostedFile
The posted vCalendar file.
userTzinfo
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone information

See Also

OCVCalendar Class
OCVCalendar Overload
OfficeClip.BusinessLayer.Sync Namespace


OCVCalendar Methods

[image] [image]

OfficeClip API Documentation
OCVCalendar Methods
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

The OCVCalendar type exposes the following methods.

Methods

 | Name | Description
Public method | add | Adds an event ot the collection.
Public method | CopyTo | Copy the object to an array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Get an enumerator to enumerate through the collection. This function is not implemented and any attempt to use it throws an exception.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Store | Writes the current object to the stringwriter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


add Method

[image]

OfficeClip API Documentation
OCVCalendar..::.add Method
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

Adds an event ot the collection.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int add(
    OCvEvent vEvent
)
Visual Basic (Declaration)
Public Function add ( _
    vEvent As OCvEvent _
) As Integer
Visual C++
public:
int add(
    OCvEvent^ vEvent
)

Parameters

vEvent
Type: OfficeClip.BusinessLayer.Sync..::.OCvEvent
The OfficeClip event

Return Value

The ArrayList index where the event is added.

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


CopyTo Method

[image]

OfficeClip API Documentation
OCVCalendar..::.CopyTo Method
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

Copy the object to an array.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyTo(
    Array array,
    int startIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    startIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int startIndex
) sealed

Parameters

array
Type: System..::.Array
the destination array.
startIndex
Type: System..::.Int32
the start index where copy should begin.

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
OCVCalendar..::.GetEnumerator Method
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

Get an enumerator to enumerate through the collection. This function is not implemented and any attempt to use it throws an exception.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

The enumerator interface to enumerate though the interface.

Implements

IEnumerable..::.GetEnumerator()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException |

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


Store Method

[image]

OfficeClip API Documentation
OCVCalendar..::.Store Method
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

Writes the current object to the stringwriter.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Store(
    StringWriter sw
)
Visual Basic (Declaration)
Public Sub Store ( _
    sw As StringWriter _
)
Visual C++
public:
void Store(
    StringWriter^ sw
)

Parameters

sw
Type: System.IO..::.StringWriter
the stringwriter to write the object to.

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


OCVCalendar Properties

[image] [image]

OfficeClip API Documentation
OCVCalendar Properties
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

The OCVCalendar type exposes the following properties.

Properties

 | Name | Description
Public property | Count | Number of events in the collection.
Public property | IsSynchronized | Gets a value which says whether the access to the object is synchronized (thread-safe).
Public property | Item | Indexer to return the event using the index in the collection.
Public property | Status | returns 0 if successful, -1 the file is not in the vCard -2 the file is ill-formed -3 vCard file Version not supported
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


Count Property

[image]

OfficeClip API Documentation
OCVCalendar..::.Count Property
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

Number of events in the collection.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


IsSynchronized Property

[image]

OfficeClip API Documentation
OCVCalendar..::.IsSynchronized Property
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

Gets a value which says whether the access to the object is synchronized (thread-safe).

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Implements

ICollection..::.IsSynchronized

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


Item Property

[image]

OfficeClip API Documentation
OCVCalendar..::.Item Property
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

Indexer to return the event using the index in the collection.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Object this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
property Object^ default[int index] {
    Object^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


Status Property

[image]

OfficeClip API Documentation
OCVCalendar..::.Status Property
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

returns 0 if successful, -1 the file is not in the vCard -2 the file is ill-formed -3 vCard file Version not supported

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Status { get; }
Visual Basic (Declaration)
Public ReadOnly Property Status As Integer
Visual C++
public:
property int Status {
    int get ();
}

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


SyncRoot Property

[image]

OfficeClip API Documentation
OCVCalendar..::.SyncRoot Property
OCVCalendar Class See Also

[This is preliminary documentation and is subject to change.]

Gets an object that can be used to synchronize access to the collection.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Implements

ICollection..::.SyncRoot

See Also

OCVCalendar Class
OfficeClip.BusinessLayer.Sync Namespace


OCVCard Class

[image]

OfficeClip API Documentation
OCVCard Class
Members See Also

[This is preliminary documentation and is subject to change.]

Encapsulates all the parsing methods of the vCard currently it will support versions 2.1 to 3.0

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCVCard
Visual Basic (Declaration)
Public Class OCVCard
Visual C++
public ref class OCVCard

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCVCard

See Also

OCVCard Members
OfficeClip.BusinessLayer.Sync Namespace


OCVCard Members

[image] [image]

OfficeClip API Documentation
OCVCard Members
OCVCard Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCVCard type exposes the following members.

Constructors

 | Name | Description
Public method | OCVCard | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | load | Gets the user information associated with this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Store | Will Store the user information on the string writer in the vCard format
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCVCard Class
OfficeClip.BusinessLayer.Sync Namespace


OCVCard Constructor

[image] [image]

OfficeClip API Documentation
OCVCard Constructor
OCVCard Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCVCard(StringReader) | Constructor to create a vCard from a vCard file
Public method | OCVCard(UserInfo) | Constructor to create a vCard object out of the UserInfo This can be used for exporting vCard

See Also

OCVCard Class
OCVCard Members
OfficeClip.BusinessLayer.Sync Namespace


OCVCard Constructor (StringReader)

[image]

OfficeClip API Documentation
OCVCard Constructor (StringReader)
OCVCard Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create a vCard from a vCard file

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCVCard(
    StringReader sReader
)
Visual Basic (Declaration)
Public Sub New ( _
    sReader As StringReader _
)
Visual C++
public:
OCVCard(
    StringReader^ sReader
)

Parameters

sReader
Type: System.IO..::.StringReader
The Reader previously opened by the calling program to read the vCard file

See Also

OCVCard Class
OCVCard Overload
OfficeClip.BusinessLayer.Sync Namespace


OCVCard Constructor (UserInfo)

[image]

OfficeClip API Documentation
OCVCard Constructor (UserInfo)
OCVCard Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create a vCard object out of the UserInfo This can be used for exporting vCard

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCVCard(
    UserInfo uInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    uInfo As UserInfo _
)
Visual C++
public:
OCVCard(
    UserInfo^ uInfo
)

Parameters

uInfo
Type: OfficeClip.BusinessLayer.Account..::.UserInfo
The user info structure

See Also

OCVCard Class
OCVCard Overload
OfficeClip.BusinessLayer.Sync Namespace


OCVCard Methods

[image] [image]

OfficeClip API Documentation
OCVCard Methods
OCVCard Class See Also

[This is preliminary documentation and is subject to change.]

The OCVCard type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | load | Gets the user information associated with this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Store | Will Store the user information on the string writer in the vCard format
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCVCard Class
OfficeClip.BusinessLayer.Sync Namespace


load Method

[image]

OfficeClip API Documentation
OCVCard..::.load Method
OCVCard Class See Also

[This is preliminary documentation and is subject to change.]

Gets the user information associated with this object.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public UserInfo load()
Visual Basic (Declaration)
Public Function load As UserInfo
Visual C++
public:
UserInfo^ load()

Return Value

The user information object.

See Also

OCVCard Class
OfficeClip.BusinessLayer.Sync Namespace


Store Method

[image]

OfficeClip API Documentation
OCVCard..::.Store Method
OCVCard Class See Also

[This is preliminary documentation and is subject to change.]

Will Store the user information on the string writer in the vCard format

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Store(
    StringWriter sw
)
Visual Basic (Declaration)
Public Sub Store ( _
    sw As StringWriter _
)
Visual C++
public:
void Store(
    StringWriter^ sw
)

Parameters

sw
Type: System.IO..::.StringWriter
The stringwriter where the output will be written in the vCard format

See Also

OCVCard Class
OfficeClip.BusinessLayer.Sync Namespace


OCVCardCollection Class

[image]

OfficeClip API Documentation
OCVCardCollection Class
Members See Also

[This is preliminary documentation and is subject to change.]

Porvides methods and properties to access the vCard Collection class

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCVCardCollection : ICollection,
    IEnumerable
Visual Basic (Declaration)
Public Class OCVCardCollection _
    Implements ICollection, IEnumerable
Visual C++
public ref class OCVCardCollection : ICollection,
    IEnumerable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCVCardCollection

See Also

OCVCardCollection Members
OfficeClip.BusinessLayer.Sync Namespace


OCVCardCollection Members

[image] [image]

OfficeClip API Documentation
OCVCardCollection Members
OCVCardCollection Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCVCardCollection type exposes the following members.

Constructors

 | Name | Description
Public method | OCVCardCollection | Overloaded.

Methods

 | Name | Description
Public method | add | Adds a vCard in the collection.
Public method | CopyTo | Copies the collection to an array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Get an enumerator to enumerate through the collection. This function is not implemented and any attempt to use it throws an exception.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Store | Writes the collection information to a StringWriter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Number of contacts in the collection.
Public property | IsSynchronized | Gets a value which says whether the access to the object is synchronized (thread-safe).
Public property | Item | Indexer to return the contacts using the index in the collection.
Public property | Status | returns 0 if successful, -1 the file is not in the vCard -2 the file is ill-formed -3 vCard file Version not supported
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


OCVCardCollection Constructor

[image] [image]

OfficeClip API Documentation
OCVCardCollection Constructor
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCVCardCollection()()() | the default constructor.
Public method | OCVCardCollection(HttpPostedFile) | Constructor that takes the posted file as an argument.

See Also

OCVCardCollection Class
OCVCardCollection Members
OfficeClip.BusinessLayer.Sync Namespace


OCVCardCollection Constructor

[image]

OfficeClip API Documentation
OCVCardCollection Constructor
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

the default constructor.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCVCardCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCVCardCollection()

See Also

OCVCardCollection Class
OCVCardCollection Overload
OfficeClip.BusinessLayer.Sync Namespace


OCVCardCollection Constructor (HttpPostedFile)

[image]

OfficeClip API Documentation
OCVCardCollection Constructor (HttpPostedFile)
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that takes the posted file as an argument.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCVCardCollection(
    HttpPostedFile pFile
)
Visual Basic (Declaration)
Public Sub New ( _
    pFile As HttpPostedFile _
)
Visual C++
public:
OCVCardCollection(
    HttpPostedFile^ pFile
)

Parameters

pFile
Type: System.Web..::.HttpPostedFile

See Also

OCVCardCollection Class
OCVCardCollection Overload
OfficeClip.BusinessLayer.Sync Namespace


OCVCardCollection Methods

[image] [image]

OfficeClip API Documentation
OCVCardCollection Methods
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

The OCVCardCollection type exposes the following methods.

Methods

 | Name | Description
Public method | add | Adds a vCard in the collection.
Public method | CopyTo | Copies the collection to an array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Get an enumerator to enumerate through the collection. This function is not implemented and any attempt to use it throws an exception.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Store | Writes the collection information to a StringWriter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


add Method

[image]

OfficeClip API Documentation
OCVCardCollection..::.add Method
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

Adds a vCard in the collection.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int add(
    OCVCard vCard
)
Visual Basic (Declaration)
Public Function add ( _
    vCard As OCVCard _
) As Integer
Visual C++
public:
int add(
    OCVCard^ vCard
)

Parameters

vCard
Type: OfficeClip.BusinessLayer.Sync..::.OCVCard
the vCard to be added to the collection.

Return Value

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


CopyTo Method

[image]

OfficeClip API Documentation
OCVCardCollection..::.CopyTo Method
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

Copies the collection to an array.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CopyTo(
    Array array,
    int startIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    startIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int startIndex
) sealed

Parameters

array
Type: System..::.Array
The destination array.
startIndex
Type: System..::.Int32
The index of the collection from where the copy should begin.

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
OCVCardCollection..::.GetEnumerator Method
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

Get an enumerator to enumerate through the collection. This function is not implemented and any attempt to use it throws an exception.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

The enumerator interface to enumerate though the interface.

Implements

IEnumerable..::.GetEnumerator()()()

Exceptions

Exception | Condition
System..::.InvalidOperationException |

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


Store Method

[image]

OfficeClip API Documentation
OCVCardCollection..::.Store Method
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

Writes the collection information to a StringWriter.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void Store(
    StringWriter sw
)
Visual Basic (Declaration)
Public Sub Store ( _
    sw As StringWriter _
)
Visual C++
public:
void Store(
    StringWriter^ sw
)

Parameters

sw
Type: System.IO..::.StringWriter
the stringwriter to write the collection information to.

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


OCVCardCollection Properties

[image] [image]

OfficeClip API Documentation
OCVCardCollection Properties
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

The OCVCardCollection type exposes the following properties.

Properties

 | Name | Description
Public property | Count | Number of contacts in the collection.
Public property | IsSynchronized | Gets a value which says whether the access to the object is synchronized (thread-safe).
Public property | Item | Indexer to return the contacts using the index in the collection.
Public property | Status | returns 0 if successful, -1 the file is not in the vCard -2 the file is ill-formed -3 vCard file Version not supported
Public property | SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


Count Property

[image]

OfficeClip API Documentation
OCVCardCollection..::.Count Property
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

Number of contacts in the collection.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


IsSynchronized Property

[image]

OfficeClip API Documentation
OCVCardCollection..::.IsSynchronized Property
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

Gets a value which says whether the access to the object is synchronized (thread-safe).

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Implements

ICollection..::.IsSynchronized

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


Item Property

[image]

OfficeClip API Documentation
OCVCardCollection..::.Item Property
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

Indexer to return the contacts using the index in the collection.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Object this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
property Object^ default[int index] {
    Object^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


Status Property

[image]

OfficeClip API Documentation
OCVCardCollection..::.Status Property
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

returns 0 if successful, -1 the file is not in the vCard -2 the file is ill-formed -3 vCard file Version not supported

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Status { get; }
Visual Basic (Declaration)
Public ReadOnly Property Status As Integer
Visual C++
public:
property int Status {
    int get ();
}

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


SyncRoot Property

[image]

OfficeClip API Documentation
OCVCardCollection..::.SyncRoot Property
OCVCardCollection Class See Also

[This is preliminary documentation and is subject to change.]

Gets an object that can be used to synchronize access to the collection.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Implements

ICollection..::.SyncRoot

See Also

OCVCardCollection Class
OfficeClip.BusinessLayer.Sync Namespace


OCvEvent Class

[image]

OfficeClip API Documentation
OCvEvent Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the OfficeClip vCalendar information.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class OCvEvent
Visual Basic (Declaration)
Public Class OCvEvent
Visual C++
public ref class OCvEvent

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Sync..::.OCvEvent

See Also

OCvEvent Members
OfficeClip.BusinessLayer.Sync Namespace


OCvEvent Members

[image] [image]

OfficeClip API Documentation
OCvEvent Members
OCvEvent Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCvEvent type exposes the following members.

Constructors

 | Name | Description
Public method | OCvEvent | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Tests if the current event is a valid event.
Public method | load | Gets the EventInfo for this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCvEvent Class
OfficeClip.BusinessLayer.Sync Namespace


OCvEvent Constructor

[image] [image]

OfficeClip API Documentation
OCvEvent Constructor
OCvEvent Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCvEvent(EventInfo, TimeZoneInfo) | Constructor to create a vCalendar object out of the EventInfo This can be used for exporting vCalendar
Public method | OCvEvent(StringReader, Double, TimeZoneInfo) | Constructor to create a vCalendar from a vCal file

See Also

OCvEvent Class
OCvEvent Members
OfficeClip.BusinessLayer.Sync Namespace


OCvEvent Constructor (EventInfo, TimeZoneInfo)

[image]

OfficeClip API Documentation
OCvEvent Constructor (EventInfo, TimeZoneInfo)
OCvEvent Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create a vCalendar object out of the EventInfo This can be used for exporting vCalendar

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCvEvent(
    EventInfo eInfo,
    TimeZoneInfo userTzInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    eInfo As EventInfo, _
    userTzInfo As TimeZoneInfo _
)
Visual C++
public:
OCvEvent(
    EventInfo^ eInfo,
    TimeZoneInfo^ userTzInfo
)

Parameters

eInfo
Type: OfficeClip.BusinessLayer.Desktop..::.EventInfo
The event info structure
userTzInfo
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone info

See Also

OCvEvent Class
OCvEvent Overload
OfficeClip.BusinessLayer.Sync Namespace


OCvEvent Constructor (StringReader, Double, TimeZoneInfo)

[image]

OfficeClip API Documentation
OCvEvent Constructor (StringReader, Double, TimeZoneInfo)
OCvEvent Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create a vCalendar from a vCal file

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public OCvEvent(
    StringReader sReader,
    double version,
    TimeZoneInfo userTzInfo
)
Visual Basic (Declaration)
Public Sub New ( _
    sReader As StringReader, _
    version As Double, _
    userTzInfo As TimeZoneInfo _
)
Visual C++
public:
OCvEvent(
    StringReader^ sReader,
    double version,
    TimeZoneInfo^ userTzInfo
)

Parameters

sReader
Type: System.IO..::.StringReader
The Reader previously opened by the calling program to read the vCalendar file
version
Type: System..::.Double
The vCalendar version, Version 1.0 is for vCalendar and version 2.0 is for the iCalendar.
userTzInfo
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone info

See Also

OCvEvent Class
OCvEvent Overload
OfficeClip.BusinessLayer.Sync Namespace


OCvEvent Methods

[image] [image]

OfficeClip API Documentation
OCvEvent Methods
OCvEvent Class See Also

[This is preliminary documentation and is subject to change.]

The OCvEvent type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Tests if the current event is a valid event.
Public method | load | Gets the EventInfo for this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCvEvent Class
OfficeClip.BusinessLayer.Sync Namespace


IsValid Method

[image]

OfficeClip API Documentation
OCvEvent..::.IsValid Method
OCvEvent Class See Also

[This is preliminary documentation and is subject to change.]

Tests if the current event is a valid event.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsValid()
Visual Basic (Declaration)
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

true if the event is a valid event, false otherwise.

See Also

OCvEvent Class
OfficeClip.BusinessLayer.Sync Namespace


load Method

[image]

OfficeClip API Documentation
OCvEvent..::.load Method
OCvEvent Class See Also

[This is preliminary documentation and is subject to change.]

Gets the EventInfo for this object.

Namespace: OfficeClip.BusinessLayer.Sync
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public EventInfo load()
Visual Basic (Declaration)
Public Function load As EventInfo
Visual C++
public:
EventInfo^ load()

Return Value

The event information structure.

See Also

OCvEvent Class
OfficeClip.BusinessLayer.Sync Namespace


OfficeClip.BusinessLayer.TE Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.TE Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for time and expenses

Classes

 | Class | Description
Public class | ExpenseAirfareInfo | Provides methods and properties for the Time and Expenses Airfare information object.
Public class | ExpenseAutorentalInfo | Provides the methods and properties to access the Time and Expenses auto rental object.
Public class | ExpenseCommentInfo | Provides methods and properties to access the expense Comment information object for the Time and Expenses application.
Public class | ExpenseDetailInfo | Provides methods and properties to access the expense detail object.
Public class | ExpensehistoryInfo | Provides the methods and properties for the expense history information.
Public class | ExpenseHotelInfo | Provides methods and properties for the expense hotel information object.
Public class | ExpenseInfo | Provides the methods and properties to access the expense object.
Public class | ExpenseMileageInfo |
Public class | ExpenseTaxiInfo | Provides the Members and Properties for the expenses for taxi fare.
Public class | ExpenseTelephoneInfo | Provides methods and properties for the telephone expenses.
Public class | ExpenseTypeInfo | Provides methods and properties to access the expense type related information.
Public class | GroupExpenseTypeInfo | Provides methods and properties to access the expense template information.
Public class | GroupTimesheetTaskInfo | Provides methods and properties for timesheet information.
Public class | ParentChildInfo |
Public class | PayrollCategoryInfo | Provides methods to interact with the Time and Expenses Payroll Information Object.
Public class | PunchDayInfo | Represents the group/Organization's menu information.
Public class | PunchTimeInfo | Represents the group/Organization's menu information.
Public class | ReimbursementPaymentInfo |
Public class | RuleInfo | Represents the group/Organization's menu information.
Public class | TimesheetCommentInfo | Provides information for timesheet Comments.
Public class | TimesheetDetailInfo | Provides methods and properties for the timesheet detail object.
Public class | TimesheetInfo | Provides the methods and properties to access the timesheet information.
Public class | TimesheetTaskInfo | Provides methods and properties to access the timesheet task information.


ExpenseAirfareInfo Class

[image]

OfficeClip API Documentation
ExpenseAirfareInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties for the Time and Expenses Airfare information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ExpenseAirfareInfo : ExpenseDetailInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExpenseAirfareInfo _
    Inherits ExpenseDetailInfo
Visual C++
[SerializableAttribute]
public ref class ExpenseAirfareInfo : public ExpenseDetailInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
OfficeClip.BusinessLayer.TE..::.ExpenseAirfareInfo

See Also

ExpenseAirfareInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseAirfareInfo Members

[image] [image]

OfficeClip API Documentation
ExpenseAirfareInfo Members
ExpenseAirfareInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseAirfareInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseAirfareInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ArrivalAirport | The arrival airport name.
Public property | ArrivalDate | The arrival date.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | DepartureAirport | The departure airport name.
Public property | DepartureDate | The departure date.
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Shows if the detail is available on the airfare expense information object. (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)

See Also

ExpenseAirfareInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseAirfareInfo Constructor

[image] [image]

OfficeClip API Documentation
ExpenseAirfareInfo Constructor
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpenseAirfareInfo()()() | The default constructor.
Public method | ExpenseAirfareInfo(ExpenseDetailInfo) | The constructor that creates the object by taking an object of the superclass.
Public method | ExpenseAirfareInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

ExpenseAirfareInfo Class
ExpenseAirfareInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseAirfareInfo Constructor

[image]

OfficeClip API Documentation
ExpenseAirfareInfo Constructor
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseAirfareInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseAirfareInfo()

See Also

ExpenseAirfareInfo Class
ExpenseAirfareInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseAirfareInfo Constructor (ExpenseDetailInfo)

[image]

OfficeClip API Documentation
ExpenseAirfareInfo Constructor (ExpenseDetailInfo)
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor that creates the object by taking an object of the superclass.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseAirfareInfo(
    ExpenseDetailInfo edi
)
Visual Basic (Declaration)
Public Sub New ( _
    edi As ExpenseDetailInfo _
)
Visual C++
public:
ExpenseAirfareInfo(
    ExpenseDetailInfo^ edi
)

Parameters

edi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
The expense detail specification.

See Also

ExpenseAirfareInfo Class
ExpenseAirfareInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseAirfareInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
ExpenseAirfareInfo Constructor (SerializationInfo, StreamingContext)
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseAirfareInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExpenseAirfareInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

ExpenseAirfareInfo Class
ExpenseAirfareInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseAirfareInfo Methods

[image] [image]

OfficeClip API Documentation
ExpenseAirfareInfo Methods
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseAirfareInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpenseAirfareInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
ExpenseAirfareInfo..::.GetObjectData Method
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

ExpenseAirfareInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseAirfareInfo Properties

[image] [image]

OfficeClip API Documentation
ExpenseAirfareInfo Properties
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseAirfareInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ArrivalAirport | The arrival airport name.
Public property | ArrivalDate | The arrival date.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | DepartureAirport | The departure airport name.
Public property | DepartureDate | The departure date.
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Shows if the detail is available on the airfare expense information object. (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)

See Also

ExpenseAirfareInfo Class
OfficeClip.BusinessLayer.TE Namespace


ArrivalAirport Property

[image]

OfficeClip API Documentation
ExpenseAirfareInfo..::.ArrivalAirport Property
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

The arrival airport name.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ArrivalAirport { get; set; }
Visual Basic (Declaration)
Public Property ArrivalAirport As String
Visual C++
public:
property String^ ArrivalAirport {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseAirfareInfo Class
OfficeClip.BusinessLayer.TE Namespace


ArrivalDate Property

[image]

OfficeClip API Documentation
ExpenseAirfareInfo..::.ArrivalDate Property
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

The arrival date.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ArrivalDate { get; set; }
Visual Basic (Declaration)
Public Property ArrivalDate As DateTime
Visual C++
public:
property DateTime ArrivalDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseAirfareInfo Class
OfficeClip.BusinessLayer.TE Namespace


DepartureAirport Property

[image]

OfficeClip API Documentation
ExpenseAirfareInfo..::.DepartureAirport Property
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

The departure airport name.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DepartureAirport { get; set; }
Visual Basic (Declaration)
Public Property DepartureAirport As String
Visual C++
public:
property String^ DepartureAirport {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseAirfareInfo Class
OfficeClip.BusinessLayer.TE Namespace


DepartureDate Property

[image]

OfficeClip API Documentation
ExpenseAirfareInfo..::.DepartureDate Property
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

The departure date.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime DepartureDate { get; set; }
Visual Basic (Declaration)
Public Property DepartureDate As DateTime
Visual C++
public:
property DateTime DepartureDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseAirfareInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsDetailAvailable Property

[image]

OfficeClip API Documentation
ExpenseAirfareInfo..::.IsDetailAvailable Property
ExpenseAirfareInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the detail is available on the airfare expense information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool IsDetailAvailable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDetailAvailable As Boolean
Visual C++
public:
virtual property bool IsDetailAvailable {
    bool get () override;
}

See Also

ExpenseAirfareInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseAutorentalInfo Class

[image]

OfficeClip API Documentation
ExpenseAutorentalInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides the methods and properties to access the Time and Expenses auto rental object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ExpenseAutorentalInfo : ExpenseDetailInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExpenseAutorentalInfo _
    Inherits ExpenseDetailInfo
Visual C++
[SerializableAttribute]
public ref class ExpenseAutorentalInfo : public ExpenseDetailInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
OfficeClip.BusinessLayer.TE..::.ExpenseAutorentalInfo

See Also

ExpenseAutorentalInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseAutorentalInfo Members

[image] [image]

OfficeClip API Documentation
ExpenseAutorentalInfo Members
ExpenseAutorentalInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseAutorentalInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseAutorentalInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | city | The city of the rental agency.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | FromDate | The date when auto rental is started.
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Shows if the detail is available on the auto rental expense object. (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | RentalAgency | The name of the rental agency.
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)
Public property | ToDate | The date when the auto rental is ended.

See Also

ExpenseAutorentalInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseAutorentalInfo Constructor

[image] [image]

OfficeClip API Documentation
ExpenseAutorentalInfo Constructor
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpenseAutorentalInfo()()() | The default constructor.
Public method | ExpenseAutorentalInfo(ExpenseDetailInfo) | The constructor that takes the superclass object as an argument.
Public method | ExpenseAutorentalInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

ExpenseAutorentalInfo Class
ExpenseAutorentalInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseAutorentalInfo Constructor

[image]

OfficeClip API Documentation
ExpenseAutorentalInfo Constructor
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseAutorentalInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseAutorentalInfo()

See Also

ExpenseAutorentalInfo Class
ExpenseAutorentalInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseAutorentalInfo Constructor (ExpenseDetailInfo)

[image]

OfficeClip API Documentation
ExpenseAutorentalInfo Constructor (ExpenseDetailInfo)
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor that takes the superclass object as an argument.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseAutorentalInfo(
    ExpenseDetailInfo edi
)
Visual Basic (Declaration)
Public Sub New ( _
    edi As ExpenseDetailInfo _
)
Visual C++
public:
ExpenseAutorentalInfo(
    ExpenseDetailInfo^ edi
)

Parameters

edi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
The expense detail information object.

See Also

ExpenseAutorentalInfo Class
ExpenseAutorentalInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseAutorentalInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
ExpenseAutorentalInfo Constructor (SerializationInfo, StreamingContext)
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseAutorentalInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExpenseAutorentalInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

ExpenseAutorentalInfo Class
ExpenseAutorentalInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseAutorentalInfo Methods

[image] [image]

OfficeClip API Documentation
ExpenseAutorentalInfo Methods
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseAutorentalInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpenseAutorentalInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
ExpenseAutorentalInfo..::.GetObjectData Method
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

ExpenseAutorentalInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseAutorentalInfo Properties

[image] [image]

OfficeClip API Documentation
ExpenseAutorentalInfo Properties
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseAutorentalInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | city | The city of the rental agency.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | FromDate | The date when auto rental is started.
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Shows if the detail is available on the auto rental expense object. (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | RentalAgency | The name of the rental agency.
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)
Public property | ToDate | The date when the auto rental is ended.

See Also

ExpenseAutorentalInfo Class
OfficeClip.BusinessLayer.TE Namespace


city Property

[image]

OfficeClip API Documentation
ExpenseAutorentalInfo..::.city Property
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

The city of the rental agency.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string city { get; set; }
Visual Basic (Declaration)
Public Property city As String
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseAutorentalInfo Class
OfficeClip.BusinessLayer.TE Namespace


FromDate Property

[image]

OfficeClip API Documentation
ExpenseAutorentalInfo..::.FromDate Property
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date when auto rental is started.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime FromDate { get; set; }
Visual Basic (Declaration)
Public Property FromDate As DateTime
Visual C++
public:
property DateTime FromDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseAutorentalInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsDetailAvailable Property

[image]

OfficeClip API Documentation
ExpenseAutorentalInfo..::.IsDetailAvailable Property
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the detail is available on the auto rental expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool IsDetailAvailable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDetailAvailable As Boolean
Visual C++
public:
virtual property bool IsDetailAvailable {
    bool get () override;
}

See Also

ExpenseAutorentalInfo Class
OfficeClip.BusinessLayer.TE Namespace


RentalAgency Property

[image]

OfficeClip API Documentation
ExpenseAutorentalInfo..::.RentalAgency Property
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the rental agency.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RentalAgency { get; set; }
Visual Basic (Declaration)
Public Property RentalAgency As String
Visual C++
public:
property String^ RentalAgency {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseAutorentalInfo Class
OfficeClip.BusinessLayer.TE Namespace


ToDate Property

[image]

OfficeClip API Documentation
ExpenseAutorentalInfo..::.ToDate Property
ExpenseAutorentalInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date when the auto rental is ended.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ToDate { get; set; }
Visual Basic (Declaration)
Public Property ToDate As DateTime
Visual C++
public:
property DateTime ToDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseAutorentalInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseCommentInfo Class

[image]

OfficeClip API Documentation
ExpenseCommentInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the expense Comment information object for the Time and Expenses application.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ExpenseCommentInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExpenseCommentInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ExpenseCommentInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ExpenseCommentInfo

See Also

ExpenseCommentInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseCommentInfo Members

[image] [image]

OfficeClip API Documentation
ExpenseCommentInfo Members
ExpenseCommentInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseCommentInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseCommentInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comment | The Comment associated with the expense Comment information object.
Public property | CommentDate | The date when the Comment was entered on the expense Comment information object.
Public property | CommentId | The unique identifier for the Comment.
Public property | ExpenseId | The system generated unique identifier for the expense.
Public property | UserId | The unique identifier for the user who owns this expense Comment information.
Public property | UserName | The name of the user who owns this expense Comment information object.

See Also

ExpenseCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseCommentInfo Constructor

[image] [image]

OfficeClip API Documentation
ExpenseCommentInfo Constructor
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpenseCommentInfo()()() | The default constructor.
Public method | ExpenseCommentInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

ExpenseCommentInfo Class
ExpenseCommentInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseCommentInfo Constructor

[image]

OfficeClip API Documentation
ExpenseCommentInfo Constructor
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseCommentInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseCommentInfo()

See Also

ExpenseCommentInfo Class
ExpenseCommentInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseCommentInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
ExpenseCommentInfo Constructor (SerializationInfo, StreamingContext)
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseCommentInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExpenseCommentInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

ExpenseCommentInfo Class
ExpenseCommentInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseCommentInfo Methods

[image] [image]

OfficeClip API Documentation
ExpenseCommentInfo Methods
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseCommentInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpenseCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
ExpenseCommentInfo..::.GetObjectData Method
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ExpenseCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseCommentInfo Properties

[image] [image]

OfficeClip API Documentation
ExpenseCommentInfo Properties
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseCommentInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Comment | The Comment associated with the expense Comment information object.
Public property | CommentDate | The date when the Comment was entered on the expense Comment information object.
Public property | CommentId | The unique identifier for the Comment.
Public property | ExpenseId | The system generated unique identifier for the expense.
Public property | UserId | The unique identifier for the user who owns this expense Comment information.
Public property | UserName | The name of the user who owns this expense Comment information object.

See Also

ExpenseCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


Comment Property

[image]

OfficeClip API Documentation
ExpenseCommentInfo..::.Comment Property
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Comment associated with the expense Comment information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Comment { get; set; }
Visual Basic (Declaration)
Public Property Comment As String
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


CommentDate Property

[image]

OfficeClip API Documentation
ExpenseCommentInfo..::.CommentDate Property
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date when the Comment was entered on the expense Comment information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CommentDate { get; set; }
Visual Basic (Declaration)
Public Property CommentDate As DateTime
Visual C++
public:
property DateTime CommentDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


CommentId Property

[image]

OfficeClip API Documentation
ExpenseCommentInfo..::.CommentId Property
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique identifier for the Comment.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CommentId { get; set; }
Visual Basic (Declaration)
Public Property CommentId As Integer
Visual C++
public:
property int CommentId {
    int get ();
    void set (int value);
}

See Also

ExpenseCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseId Property

[image]

OfficeClip API Documentation
ExpenseCommentInfo..::.ExpenseId Property
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpenseId { get; set; }
Visual Basic (Declaration)
Public Property ExpenseId As Integer
Visual C++
public:
property int ExpenseId {
    int get ();
    void set (int value);
}

See Also

ExpenseCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


UserId Property

[image]

OfficeClip API Documentation
ExpenseCommentInfo..::.UserId Property
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique identifier for the user who owns this expense Comment information.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

ExpenseCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


UserName Property

[image]

OfficeClip API Documentation
ExpenseCommentInfo..::.UserName Property
ExpenseCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user who owns this expense Comment information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseDetailInfo Class

[image]

OfficeClip API Documentation
ExpenseDetailInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the expense detail object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ExpenseDetailInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExpenseDetailInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ExpenseDetailInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
OfficeClip.BusinessLayer.TE..::.ExpenseAirfareInfo
OfficeClip.BusinessLayer.TE..::.ExpenseHotelInfo
OfficeClip.BusinessLayer.TE..::.ExpenseTelephoneInfo
OfficeClip.BusinessLayer.TE..::.ExpenseMileageInfo
OfficeClip.BusinessLayer.TE..::.ExpenseTaxiInfo
OfficeClip.BusinessLayer.TE..::.ExpenseAutorentalInfo

See Also

ExpenseDetailInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseDetailInfo Members

[image] [image]

OfficeClip API Documentation
ExpenseDetailInfo Members
ExpenseDetailInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseDetailInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseDetailInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object.
Public property | AccountName | The name of the account associated with this expense detail information object.
Public property | Amount | The Amount of the expense.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created.
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object.
Public property | Description | The textual Description for this expense.
Public property | Detail | Details of the ExpenseDetail
Public property | ExpenseDate | The date when this expense was made.
Public property | ExpenseDetailId | The system generated identifier for the expense detail.
Public property | ExpenseId | The system generated unique identifier for the expense.
Public property | ExpenseName | The name of the expense.
Public property | ExpenseTypeId | The identifier for the expense type.
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail.
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable.
Public property | IsDetailAvailable | Shows if the detail is available for the expense detail object.
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified.
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object.
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object.
Public property | PaymentMode | Payment Mode
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object.
Public property | ProjectName | The name of the Project associated with this expense detail information object.
Public property | Reimbursed | The Reimbursed Amount
Public property | ReimbursedNote | The Notes of Reimbursed
Public property | SerialNumber | The serial number for the expense detail information object.
Public property | tax | The tax Amount for this expense.

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseDetailInfo Constructor

[image] [image]

OfficeClip API Documentation
ExpenseDetailInfo Constructor
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpenseDetailInfo()()() | The default constructor.
Public method | ExpenseDetailInfo(ExpenseDetailInfo) | The copy constructor.
Public method | ExpenseDetailInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

ExpenseDetailInfo Class
ExpenseDetailInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseDetailInfo Constructor

[image]

OfficeClip API Documentation
ExpenseDetailInfo Constructor
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseDetailInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseDetailInfo()

See Also

ExpenseDetailInfo Class
ExpenseDetailInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseDetailInfo Constructor (ExpenseDetailInfo)

[image]

OfficeClip API Documentation
ExpenseDetailInfo Constructor (ExpenseDetailInfo)
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The copy constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseDetailInfo(
    ExpenseDetailInfo edi
)
Visual Basic (Declaration)
Public Sub New ( _
    edi As ExpenseDetailInfo _
)
Visual C++
public:
ExpenseDetailInfo(
    ExpenseDetailInfo^ edi
)

Parameters

edi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
The expense detail information object that is supposed to be copied to the new object.

See Also

ExpenseDetailInfo Class
ExpenseDetailInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseDetailInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
ExpenseDetailInfo Constructor (SerializationInfo, StreamingContext)
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseDetailInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExpenseDetailInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

ExpenseDetailInfo Class
ExpenseDetailInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseDetailInfo Methods

[image] [image]

OfficeClip API Documentation
ExpenseDetailInfo Methods
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseDetailInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.GetObjectData Method
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseDetailInfo Properties

[image] [image]

OfficeClip API Documentation
ExpenseDetailInfo Properties
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseDetailInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object.
Public property | AccountName | The name of the account associated with this expense detail information object.
Public property | Amount | The Amount of the expense.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created.
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object.
Public property | Description | The textual Description for this expense.
Public property | Detail | Details of the ExpenseDetail
Public property | ExpenseDate | The date when this expense was made.
Public property | ExpenseDetailId | The system generated identifier for the expense detail.
Public property | ExpenseId | The system generated unique identifier for the expense.
Public property | ExpenseName | The name of the expense.
Public property | ExpenseTypeId | The identifier for the expense type.
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail.
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable.
Public property | IsDetailAvailable | Shows if the detail is available for the expense detail object.
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified.
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object.
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object.
Public property | PaymentMode | Payment Mode
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object.
Public property | ProjectName | The name of the Project associated with this expense detail information object.
Public property | Reimbursed | The Reimbursed Amount
Public property | ReimbursedNote | The Notes of Reimbursed
Public property | SerialNumber | The serial number for the expense detail information object.
Public property | tax | The tax Amount for this expense.

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


AccountId Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.AccountId Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated identifier for the account associates with this expense detail information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AccountId { get; set; }
Visual Basic (Declaration)
Public Property AccountId As Integer
Visual C++
public:
property int AccountId {
    int get ();
    void set (int value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


AccountName Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.AccountName Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the account associated with this expense detail information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AccountName { get; set; }
Visual Basic (Declaration)
Public Property AccountName As String
Visual C++
public:
property String^ AccountName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


Amount Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.Amount Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Amount of the expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double Amount { get; set; }
Visual Basic (Declaration)
Public Property Amount As Double
Visual C++
public:
property double Amount {
    double get ();
    void set (double value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


CreatedByTimestamp Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.CreatedByTimestamp Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The created date and time of when this expense detail information object is created.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedByTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedByTimestamp As DateTime
Visual C++
public:
property DateTime CreatedByTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


CreatedByUserId Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.CreatedByUserId Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the user who created this expense detail object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedByUserId { get; set; }
Visual Basic (Declaration)
Public Property CreatedByUserId As Integer
Visual C++
public:
property int CreatedByUserId {
    int get ();
    void set (int value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


Description Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.Description Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The textual Description for this expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


Detail Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.Detail Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Details of the ExpenseDetail

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Detail { get; set; }
Visual Basic (Declaration)
Public Property Detail As String
Visual C++
public:
property String^ Detail {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseDate Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.ExpenseDate Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date when this expense was made.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ExpenseDate { get; set; }
Visual Basic (Declaration)
Public Property ExpenseDate As DateTime
Visual C++
public:
property DateTime ExpenseDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseDetailId Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.ExpenseDetailId Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated identifier for the expense detail.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpenseDetailId { get; set; }
Visual Basic (Declaration)
Public Property ExpenseDetailId As Integer
Visual C++
public:
property int ExpenseDetailId {
    int get ();
    void set (int value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseId Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.ExpenseId Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpenseId { get; set; }
Visual Basic (Declaration)
Public Property ExpenseId As Integer
Visual C++
public:
property int ExpenseId {
    int get ();
    void set (int value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseName Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.ExpenseName Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ExpenseName { get; set; }
Visual Basic (Declaration)
Public Property ExpenseName As String
Visual C++
public:
property String^ ExpenseName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeId Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.ExpenseTypeId Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the expense type.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpenseTypeId { get; set; }
Visual Basic (Declaration)
Public Property ExpenseTypeId As Integer
Visual C++
public:
property int ExpenseTypeId {
    int get ();
    void set (int value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeUniqueId Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.ExpenseTypeUniqueId Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated identifier for the teplate for this expense detail.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpenseTypeUniqueId { get; set; }
Visual Basic (Declaration)
Public Property ExpenseTypeUniqueId As Integer
Visual C++
public:
property int ExpenseTypeUniqueId {
    int get ();
    void set (int value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsBillable Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.IsBillable Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsBillable { get; set; }
Visual Basic (Declaration)
Public Property IsBillable As String
Visual C++
public:
property String^ IsBillable {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsDetailAvailable Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.IsDetailAvailable Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the detail is available for the expense detail object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public virtual bool IsDetailAvailable { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsDetailAvailable As Boolean
Visual C++
public:
virtual property bool IsDetailAvailable {
    bool get ();
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ModifiedByTimestamp Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.ModifiedByTimestamp Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time stamp when the expense detail information object is last modified.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ModifiedByTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ModifiedByTimestamp As DateTime
Visual C++
public:
property DateTime ModifiedByTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ModifiedByUserId Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.ModifiedByUserId Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user identifier of the user who last modified the expense detail information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ModifiedByUserId { get; set; }
Visual Basic (Declaration)
Public Property ModifiedByUserId As Integer
Visual C++
public:
property int ModifiedByUserId {
    int get ();
    void set (int value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


PaymentMethodId Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.PaymentMethodId Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the payment method for the expense detail information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int PaymentMethodId { get; set; }
Visual Basic (Declaration)
Public Property PaymentMethodId As Integer
Visual C++
public:
property int PaymentMethodId {
    int get ();
    void set (int value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


PaymentMode Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.PaymentMode Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Payment Mode

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PaymentMode { get; set; }
Visual Basic (Declaration)
Public Property PaymentMode As String
Visual C++
public:
property String^ PaymentMode {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ProjectId Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.ProjectId Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the Project associated with this expense detail information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ProjectId { get; set; }
Visual Basic (Declaration)
Public Property ProjectId As Integer
Visual C++
public:
property int ProjectId {
    int get ();
    void set (int value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ProjectName Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.ProjectName Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the Project associated with this expense detail information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProjectName { get; set; }
Visual Basic (Declaration)
Public Property ProjectName As String
Visual C++
public:
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


Reimbursed Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.Reimbursed Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Reimbursed Amount

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public float Reimbursed { get; set; }
Visual Basic (Declaration)
Public Property Reimbursed As Single
Visual C++
public:
property float Reimbursed {
    float get ();
    void set (float value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ReimbursedNote Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.ReimbursedNote Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Notes of Reimbursed

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ReimbursedNote { get; set; }
Visual Basic (Declaration)
Public Property ReimbursedNote As String
Visual C++
public:
property String^ ReimbursedNote {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


SerialNumber Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.SerialNumber Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The serial number for the expense detail information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SerialNumber { get; set; }
Visual Basic (Declaration)
Public Property SerialNumber As Integer
Visual C++
public:
property int SerialNumber {
    int get ();
    void set (int value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


tax Property

[image]

OfficeClip API Documentation
ExpenseDetailInfo..::.tax Property
ExpenseDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The tax Amount for this expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double tax { get; set; }
Visual Basic (Declaration)
Public Property tax As Double
Visual C++
public:
property double tax {
    double get ();
    void set (double value);
}

See Also

ExpenseDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpensehistoryInfo Class

[image]

OfficeClip API Documentation
ExpensehistoryInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides the methods and properties for the expense history information.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ExpensehistoryInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExpensehistoryInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ExpensehistoryInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ExpensehistoryInfo

See Also

ExpensehistoryInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpensehistoryInfo Members

[image] [image]

OfficeClip API Documentation
ExpensehistoryInfo Members
ExpensehistoryInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpensehistoryInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExpensehistoryInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActionId | The identifier for the Action that has taken place for the expense history information object.
Public property | ActionTimestamp | The Timestamp when the Action was done on the expense history infomation object.
Public property | ExpenseId | The unique identifier for the expense.
Public property | UserId | The unique identifier of the user who wrote the expense history information object.

See Also

ExpensehistoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpensehistoryInfo Constructor

[image] [image]

OfficeClip API Documentation
ExpensehistoryInfo Constructor
ExpensehistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpensehistoryInfo()()() | The default constructor.
Public method | ExpensehistoryInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

ExpensehistoryInfo Class
ExpensehistoryInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpensehistoryInfo Constructor

[image]

OfficeClip API Documentation
ExpensehistoryInfo Constructor
ExpensehistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpensehistoryInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpensehistoryInfo()

See Also

ExpensehistoryInfo Class
ExpensehistoryInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpensehistoryInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
ExpensehistoryInfo Constructor (SerializationInfo, StreamingContext)
ExpensehistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpensehistoryInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExpensehistoryInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

ExpensehistoryInfo Class
ExpensehistoryInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpensehistoryInfo Methods

[image] [image]

OfficeClip API Documentation
ExpensehistoryInfo Methods
ExpensehistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpensehistoryInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpensehistoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
ExpensehistoryInfo..::.GetObjectData Method
ExpensehistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ExpensehistoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpensehistoryInfo Properties

[image] [image]

OfficeClip API Documentation
ExpensehistoryInfo Properties
ExpensehistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpensehistoryInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ActionId | The identifier for the Action that has taken place for the expense history information object.
Public property | ActionTimestamp | The Timestamp when the Action was done on the expense history infomation object.
Public property | ExpenseId | The unique identifier for the expense.
Public property | UserId | The unique identifier of the user who wrote the expense history information object.

See Also

ExpensehistoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


ActionId Property

[image]

OfficeClip API Documentation
ExpensehistoryInfo..::.ActionId Property
ExpensehistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the Action that has taken place for the expense history information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ActionId { get; set; }
Visual Basic (Declaration)
Public Property ActionId As Integer
Visual C++
public:
property int ActionId {
    int get ();
    void set (int value);
}

See Also

ExpensehistoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


ActionTimestamp Property

[image]

OfficeClip API Documentation
ExpensehistoryInfo..::.ActionTimestamp Property
ExpensehistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp when the Action was done on the expense history infomation object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ActionTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ActionTimestamp As DateTime
Visual C++
public:
property DateTime ActionTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpensehistoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseId Property

[image]

OfficeClip API Documentation
ExpensehistoryInfo..::.ExpenseId Property
ExpensehistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique identifier for the expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpenseId { get; set; }
Visual Basic (Declaration)
Public Property ExpenseId As Integer
Visual C++
public:
property int ExpenseId {
    int get ();
    void set (int value);
}

See Also

ExpensehistoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


UserId Property

[image]

OfficeClip API Documentation
ExpensehistoryInfo..::.UserId Property
ExpensehistoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique identifier of the user who wrote the expense history information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

ExpensehistoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseHotelInfo Class

[image]

OfficeClip API Documentation
ExpenseHotelInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties for the expense hotel information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ExpenseHotelInfo : ExpenseDetailInfo, ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExpenseHotelInfo _
    Inherits ExpenseDetailInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ExpenseHotelInfo : public ExpenseDetailInfo,
    ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
OfficeClip.BusinessLayer.TE..::.ExpenseHotelInfo

See Also

ExpenseHotelInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseHotelInfo Members

[image] [image]

OfficeClip API Documentation
ExpenseHotelInfo Members
ExpenseHotelInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseHotelInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseHotelInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | city | The name of the city where the expense is made.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | FromDate | The starting date of the expense.
Public property | HotelName | The name of the hotel where the expense is made.
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Shows if the detail is available for the expense hotel information object. (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)
Public property | ToDate | The end date for the expense.

See Also

ExpenseHotelInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseHotelInfo Constructor

[image] [image]

OfficeClip API Documentation
ExpenseHotelInfo Constructor
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpenseHotelInfo()()() | The default constructor.
Public method | ExpenseHotelInfo(ExpenseDetailInfo) | The constructor that takes the superclass object as a parameter.
Public method | ExpenseHotelInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

ExpenseHotelInfo Class
ExpenseHotelInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseHotelInfo Constructor

[image]

OfficeClip API Documentation
ExpenseHotelInfo Constructor
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseHotelInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseHotelInfo()

See Also

ExpenseHotelInfo Class
ExpenseHotelInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseHotelInfo Constructor (ExpenseDetailInfo)

[image]

OfficeClip API Documentation
ExpenseHotelInfo Constructor (ExpenseDetailInfo)
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor that takes the superclass object as a parameter.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseHotelInfo(
    ExpenseDetailInfo edi
)
Visual Basic (Declaration)
Public Sub New ( _
    edi As ExpenseDetailInfo _
)
Visual C++
public:
ExpenseHotelInfo(
    ExpenseDetailInfo^ edi
)

Parameters

edi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
The expense detail information object.

See Also

ExpenseHotelInfo Class
ExpenseHotelInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseHotelInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
ExpenseHotelInfo Constructor (SerializationInfo, StreamingContext)
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseHotelInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExpenseHotelInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

ExpenseHotelInfo Class
ExpenseHotelInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseHotelInfo Methods

[image] [image]

OfficeClip API Documentation
ExpenseHotelInfo Methods
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseHotelInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpenseHotelInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
ExpenseHotelInfo..::.GetObjectData Method
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ExpenseHotelInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseHotelInfo Properties

[image] [image]

OfficeClip API Documentation
ExpenseHotelInfo Properties
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseHotelInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | city | The name of the city where the expense is made.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | FromDate | The starting date of the expense.
Public property | HotelName | The name of the hotel where the expense is made.
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Shows if the detail is available for the expense hotel information object. (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)
Public property | ToDate | The end date for the expense.

See Also

ExpenseHotelInfo Class
OfficeClip.BusinessLayer.TE Namespace


city Property

[image]

OfficeClip API Documentation
ExpenseHotelInfo..::.city Property
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the city where the expense is made.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string city { get; set; }
Visual Basic (Declaration)
Public Property city As String
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseHotelInfo Class
OfficeClip.BusinessLayer.TE Namespace


FromDate Property

[image]

OfficeClip API Documentation
ExpenseHotelInfo..::.FromDate Property
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

The starting date of the expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime FromDate { get; set; }
Visual Basic (Declaration)
Public Property FromDate As DateTime
Visual C++
public:
property DateTime FromDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseHotelInfo Class
OfficeClip.BusinessLayer.TE Namespace


HotelName Property

[image]

OfficeClip API Documentation
ExpenseHotelInfo..::.HotelName Property
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the hotel where the expense is made.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string HotelName { get; set; }
Visual Basic (Declaration)
Public Property HotelName As String
Visual C++
public:
property String^ HotelName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseHotelInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsDetailAvailable Property

[image]

OfficeClip API Documentation
ExpenseHotelInfo..::.IsDetailAvailable Property
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the detail is available for the expense hotel information object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool IsDetailAvailable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDetailAvailable As Boolean
Visual C++
public:
virtual property bool IsDetailAvailable {
    bool get () override;
}

See Also

ExpenseHotelInfo Class
OfficeClip.BusinessLayer.TE Namespace


ToDate Property

[image]

OfficeClip API Documentation
ExpenseHotelInfo..::.ToDate Property
ExpenseHotelInfo Class See Also

[This is preliminary documentation and is subject to change.]

The end date for the expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ToDate { get; set; }
Visual Basic (Declaration)
Public Property ToDate As DateTime
Visual C++
public:
property DateTime ToDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseHotelInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseInfo Class

[image]

OfficeClip API Documentation
ExpenseInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides the methods and properties to access the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ExpenseInfo
Visual Basic (Declaration)
Public Class ExpenseInfo
Visual C++
public ref class ExpenseInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ExpenseInfo

See Also

ExpenseInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseInfo Members

[image] [image]

OfficeClip API Documentation
ExpenseInfo Members
ExpenseInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseInfo | The default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccountAndProjectName | Gets the name of the Customer and the Project name delimited by a "/" character.
Public method | GetAccountName | Gets the Customer name for a particular row of the expense object.
Public method | GetAmount | Gets the Amount of a row and column of the expense object.
Public method | GetAmountTotal | Gets the total Amount of expense for an expense object.
Public method | GetBillableAmount | Gets the total billable Amount for the expense items on the expense object.
Public method | GetEditableComments | Gets the editable Comments for the expense object for a particular user.
Public method | GetExpenseAmount | Gets the Amount of the expense.
Public method | getExpenseDetail |
Public method | GetExpenseType | Gets the expense type for the for a particular row on the expense object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNonBillableAmount | Gets the total non-billable Amount for the expense items on the expense object.
Public method | GetNonEditableComments | Gets the non-editable Comments from the expense object for a particular user.
Public method | GetProjectName | Gets the Project name for a particular row of the expense object.
Public method | GetRow | Gets a list of expense detail for a row of the expense object.
Public method | GetRows | Returns a list of expense details in the expense object.
Public method | GetRowTotal | Gets the total of an expense row on the expense report.
Public method | GetSerializedExpenseDetails | Gets the serialized detail for a particular expense.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsExpenseDetailAvailable | Shows if the expense detail is available
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSV | Converts the expense object to a Comma Separated Value (CSV file).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedTimestamp | The created Timestamp for this expense object.
Public property | CurrencyCode | Teh currency code
Public property | CurrencyRate | Teh currency rate
Public property | DocIdList | The comma separated list of document ids for documents that are attached to this expense object.
Public property | ExpenseComments | the list of expense Comments.
Public property | ExpenseDetails | The list of expense details.
Public property | ExpenseId | The system generated unique identifier for the expense object.
Public property | ExportedTimestamp | The Timestamp when the expense object was exported.
Public property | FromDate | The start date of this expense.
Public property | GroupId | The group identifier for the group where this expense object belongs.
Public property | GroupName | The group name of the group where this expense object belongs.
Public property | IsExported | Shows whether this expense object is exported. Legal values are "Y" and "N".
Public property | NumLines | the number of lines of expenses in this expense object.
Public property | RemDocIdList | The list of comma separated document ids for documents that have been removed from the expense object.
Public property | ToDate | The end date for this expense.
Public property | UserId | The unique identifier for the user who created this expense object.
Public property | UserName | The name of the user who created this expense object.
Public property | WorkflowHistory | The list of history of workflow for the expense object.
Public property | WorkflowTypeId | Get the workflow type id corresponding to this particular expense.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseInfo Constructor

[image]

OfficeClip API Documentation
ExpenseInfo Constructor
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseInfo()

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseInfo Methods

[image] [image]

OfficeClip API Documentation
ExpenseInfo Methods
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccountAndProjectName | Gets the name of the Customer and the Project name delimited by a "/" character.
Public method | GetAccountName | Gets the Customer name for a particular row of the expense object.
Public method | GetAmount | Gets the Amount of a row and column of the expense object.
Public method | GetAmountTotal | Gets the total Amount of expense for an expense object.
Public method | GetBillableAmount | Gets the total billable Amount for the expense items on the expense object.
Public method | GetEditableComments | Gets the editable Comments for the expense object for a particular user.
Public method | GetExpenseAmount | Gets the Amount of the expense.
Public method | getExpenseDetail |
Public method | GetExpenseType | Gets the expense type for the for a particular row on the expense object.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNonBillableAmount | Gets the total non-billable Amount for the expense items on the expense object.
Public method | GetNonEditableComments | Gets the non-editable Comments from the expense object for a particular user.
Public method | GetProjectName | Gets the Project name for a particular row of the expense object.
Public method | GetRow | Gets a list of expense detail for a row of the expense object.
Public method | GetRows | Returns a list of expense details in the expense object.
Public method | GetRowTotal | Gets the total of an expense row on the expense report.
Public method | GetSerializedExpenseDetails | Gets the serialized detail for a particular expense.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsExpenseDetailAvailable | Shows if the expense detail is available
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSV | Converts the expense object to a Comma Separated Value (CSV file).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetAccountAndProjectName Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetAccountAndProjectName Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the name of the Customer and the Project name delimited by a "/" character.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetAccountAndProjectName(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetAccountAndProjectName ( _
    rowNumber As Integer _
) As String
Visual C++
public:
String^ GetAccountAndProjectName(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number of the expense object.

Return Value

The Customer and the Project name delimited by a "/" character.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetAccountName Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetAccountName Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Customer name for a particular row of the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetAccountName(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetAccountName ( _
    rowNumber As Integer _
) As String
Visual C++
public:
String^ GetAccountName(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number of the expense object.

Return Value

The Customer name.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetAmount Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetAmount Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Amount of a row and column of the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetAmount(
    int rowNumber,
    int columnNumber
)
Visual Basic (Declaration)
Public Function GetAmount ( _
    rowNumber As Integer, _
    columnNumber As Integer _
) As Double
Visual C++
public:
double GetAmount(
    int rowNumber,
    int columnNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number for which the Amount is desired.
columnNumber
Type: System..::.Int32
the column number for which the Amount is desired.

Return Value

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetAmountTotal Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetAmountTotal Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the total Amount of expense for an expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetAmountTotal()
Visual Basic (Declaration)
Public Function GetAmountTotal As Double
Visual C++
public:
double GetAmountTotal()

Return Value

The total Amount of expense on the expense object. This is the total for all the rows and columns on the expense object.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetBillableAmount Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetBillableAmount Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the total billable Amount for the expense items on the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetBillableAmount()
Visual Basic (Declaration)
Public Function GetBillableAmount As Double
Visual C++
public:
double GetBillableAmount()

Return Value

The total Amount that is assigned as billable.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetEditableComments Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetEditableComments Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the editable Comments for the expense object for a particular user.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetEditableComments(
    int userId
)
Visual Basic (Declaration)
Public Function GetEditableComments ( _
    userId As Integer _
) As String
Visual C++
public:
String^ GetEditableComments(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.

Return Value

The Comment string for the expense object.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetExpenseAmount Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetExpenseAmount Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Amount of the expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetExpenseAmount(
    int rowNumber,
    int columnNumber
)
Visual Basic (Declaration)
Public Function GetExpenseAmount ( _
    rowNumber As Integer, _
    columnNumber As Integer _
) As Double
Visual C++
public:
double GetExpenseAmount(
    int rowNumber,
    int columnNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row of where the expense is found. Usually rows signifies Customer, Projects and tasks.
columnNumber
Type: System..::.Int32
The column where the expense is found. Usually columns signifies a date.

Return Value

The expense Amount for the cell.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


getExpenseDetail Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.getExpenseDetail Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseDetailInfo getExpenseDetail(
    int rowNumber,
    int columnNumber
)
Visual Basic (Declaration)
Public Function getExpenseDetail ( _
    rowNumber As Integer, _
    columnNumber As Integer _
) As ExpenseDetailInfo
Visual C++
public:
ExpenseDetailInfo^ getExpenseDetail(
    int rowNumber,
    int columnNumber
)

Parameters

rowNumber
Type: System..::.Int32
columnNumber
Type: System..::.Int32

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetExpenseType Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetExpenseType Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the expense type for the for a particular row on the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetExpenseType(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetExpenseType ( _
    rowNumber As Integer _
) As String
Visual C++
public:
String^ GetExpenseType(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
the row number for which the expense type is desired.

Return Value

The type of expense for the particular row.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetNonBillableAmount Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetNonBillableAmount Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the total non-billable Amount for the expense items on the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetNonBillableAmount()
Visual Basic (Declaration)
Public Function GetNonBillableAmount As Double
Visual C++
public:
double GetNonBillableAmount()

Return Value

The total Amount that is assigned as non-billable.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetNonEditableComments Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetNonEditableComments Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the non-editable Comments from the expense object for a particular user.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetNonEditableComments(
    int userId
)
Visual Basic (Declaration)
Public Function GetNonEditableComments ( _
    userId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetNonEditableComments(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.

Return Value

The non-editable Comments in the expense object.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetProjectName Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetProjectName Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Project name for a particular row of the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetProjectName(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetProjectName ( _
    rowNumber As Integer _
) As String
Visual C++
public:
String^ GetProjectName(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number of the expense object.

Return Value

The name of the Project for the expense object.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetRow Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetRow Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of expense detail for a row of the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetRow(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetRow ( _
    rowNumber As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetRow(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number of the row for which the detail is desired.

Return Value

The list of expense detail object.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetRows Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetRows Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns a list of expense details in the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetRows()
Visual Basic (Declaration)
Public Function GetRows As ArrayList
Visual C++
public:
ArrayList^ GetRows()

Return Value

The lsit of expense detail

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetRowTotal Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetRowTotal Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the total of an expense row on the expense report.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetRowTotal(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetRowTotal ( _
    rowNumber As Integer _
) As Double
Visual C++
public:
double GetRowTotal(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number for which the total is required.

Return Value

The total Amount of expense for that row.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetSerializedExpenseDetails Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.GetSerializedExpenseDetails Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the serialized detail for a particular expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetSerializedExpenseDetails(
    int rowNumber,
    int columnNumber
)
Visual Basic (Declaration)
Public Function GetSerializedExpenseDetails ( _
    rowNumber As Integer, _
    columnNumber As Integer _
) As String
Visual C++
public:
String^ GetSerializedExpenseDetails(
    int rowNumber,
    int columnNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row of where the expense is found. Usually rows signifies Customer, Projects and tasks.
columnNumber
Type: System..::.Int32
The column where the expense is found. Usually columns signifies a date.

Return Value

The serialized expense Amount for the cell.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsExpenseDetailAvailable Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.IsExpenseDetailAvailable Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the expense detail is available

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsExpenseDetailAvailable(
    int rowNumber,
    int columnNumber
)
Visual Basic (Declaration)
Public Function IsExpenseDetailAvailable ( _
    rowNumber As Integer, _
    columnNumber As Integer _
) As Boolean
Visual C++
public:
bool IsExpenseDetailAvailable(
    int rowNumber,
    int columnNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row of where the expense is found. Usually rows signifies Customer, Projects and tasks.
columnNumber
Type: System..::.Int32
>The column where the expense is found. Usually columns signifies a date.

Return Value

True if the expense detail is avbl, false otherwise...

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


ToCSV Method

[image]

OfficeClip API Documentation
ExpenseInfo..::.ToCSV Method
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Converts the expense object to a Comma Separated Value (CSV file).

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToCSV()
Visual Basic (Declaration)
Public Function ToCSV As String
Visual C++
public:
String^ ToCSV()

Return Value

The CSV string representation of the expense object.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseInfo Properties

[image] [image]

OfficeClip API Documentation
ExpenseInfo Properties
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseInfo type exposes the following properties.

Properties

 | Name | Description
Public property | CreatedTimestamp | The created Timestamp for this expense object.
Public property | CurrencyCode | Teh currency code
Public property | CurrencyRate | Teh currency rate
Public property | DocIdList | The comma separated list of document ids for documents that are attached to this expense object.
Public property | ExpenseComments | the list of expense Comments.
Public property | ExpenseDetails | The list of expense details.
Public property | ExpenseId | The system generated unique identifier for the expense object.
Public property | ExportedTimestamp | The Timestamp when the expense object was exported.
Public property | FromDate | The start date of this expense.
Public property | GroupId | The group identifier for the group where this expense object belongs.
Public property | GroupName | The group name of the group where this expense object belongs.
Public property | IsExported | Shows whether this expense object is exported. Legal values are "Y" and "N".
Public property | NumLines | the number of lines of expenses in this expense object.
Public property | RemDocIdList | The list of comma separated document ids for documents that have been removed from the expense object.
Public property | ToDate | The end date for this expense.
Public property | UserId | The unique identifier for the user who created this expense object.
Public property | UserName | The name of the user who created this expense object.
Public property | WorkflowHistory | The list of history of workflow for the expense object.
Public property | WorkflowTypeId | Get the workflow type id corresponding to this particular expense.

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


CreatedTimestamp Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.CreatedTimestamp Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The created Timestamp for this expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedTimestamp As DateTime
Visual C++
public:
property DateTime CreatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


CurrencyCode Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.CurrencyCode Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Teh currency code

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CurrencyCode { get; set; }
Visual Basic (Declaration)
Public Property CurrencyCode As String
Visual C++
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


CurrencyRate Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.CurrencyRate Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Teh currency rate

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double CurrencyRate { get; set; }
Visual Basic (Declaration)
Public Property CurrencyRate As Double
Visual C++
public:
property double CurrencyRate {
    double get ();
    void set (double value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


DocIdList Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.DocIdList Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The comma separated list of document ids for documents that are attached to this expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DocIdList { get; set; }
Visual Basic (Declaration)
Public Property DocIdList As String
Visual C++
public:
property String^ DocIdList {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseComments Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.ExpenseComments Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

the list of expense Comments.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList ExpenseComments { get; set; }
Visual Basic (Declaration)
Public Property ExpenseComments As ArrayList
Visual C++
public:
property ArrayList^ ExpenseComments {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseDetails Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.ExpenseDetails Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of expense details.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList ExpenseDetails { get; set; }
Visual Basic (Declaration)
Public Property ExpenseDetails As ArrayList
Visual C++
public:
property ArrayList^ ExpenseDetails {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseId Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.ExpenseId Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpenseId { get; set; }
Visual Basic (Declaration)
Public Property ExpenseId As Integer
Visual C++
public:
property int ExpenseId {
    int get ();
    void set (int value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExportedTimestamp Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.ExportedTimestamp Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp when the expense object was exported.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ExportedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ExportedTimestamp As DateTime
Visual C++
public:
property DateTime ExportedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


FromDate Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.FromDate Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The start date of this expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime FromDate { get; set; }
Visual Basic (Declaration)
Public Property FromDate As DateTime
Visual C++
public:
property DateTime FromDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupId Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.GroupId Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The group identifier for the group where this expense object belongs.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupName Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.GroupName Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The group name of the group where this expense object belongs.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GroupName { get; set; }
Visual Basic (Declaration)
Public Property GroupName As String
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsExported Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.IsExported Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether this expense object is exported. Legal values are "Y" and "N".

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsExported { get; set; }
Visual Basic (Declaration)
Public Property IsExported As String
Visual C++
public:
property String^ IsExported {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


NumLines Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.NumLines Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

the number of lines of expenses in this expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumLines { get; set; }
Visual Basic (Declaration)
Public Property NumLines As Integer
Visual C++
public:
property int NumLines {
    int get ();
    void set (int value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


RemDocIdList Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.RemDocIdList Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of comma separated document ids for documents that have been removed from the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RemDocIdList { get; set; }
Visual Basic (Declaration)
Public Property RemDocIdList As String
Visual C++
public:
property String^ RemDocIdList {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


ToDate Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.ToDate Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The end date for this expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ToDate { get; set; }
Visual Basic (Declaration)
Public Property ToDate As DateTime
Visual C++
public:
property DateTime ToDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


UserId Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.UserId Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique identifier for the user who created this expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


UserName Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.UserName Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user who created this expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


WorkflowHistory Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.WorkflowHistory Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of history of workflow for the expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList WorkflowHistory { get; set; }
Visual Basic (Declaration)
Public Property WorkflowHistory As ArrayList
Visual C++
public:
property ArrayList^ WorkflowHistory {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


WorkflowTypeId Property

[image]

OfficeClip API Documentation
ExpenseInfo..::.WorkflowTypeId Property
ExpenseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Get the workflow type id corresponding to this particular expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int WorkflowTypeId { get; set; }
Visual Basic (Declaration)
Public Property WorkflowTypeId As Integer
Visual C++
public:
property int WorkflowTypeId {
    int get ();
    void set (int value);
}

See Also

ExpenseInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseMileageInfo Class

[image]

OfficeClip API Documentation
ExpenseMileageInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ExpenseMileageInfo : ExpenseDetailInfo, ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExpenseMileageInfo _
    Inherits ExpenseDetailInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ExpenseMileageInfo : public ExpenseDetailInfo,
    ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
OfficeClip.BusinessLayer.TE..::.ExpenseMileageInfo

See Also

ExpenseMileageInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseMileageInfo Members

[image] [image]

OfficeClip API Documentation
ExpenseMileageInfo Members
ExpenseMileageInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseMileageInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseMileageInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Returns true/false by checking the details of ExpenseMileage (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | Mileage | Mileage
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)

See Also

ExpenseMileageInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseMileageInfo Constructor

[image] [image]

OfficeClip API Documentation
ExpenseMileageInfo Constructor
ExpenseMileageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpenseMileageInfo()()() | Default constructor
Public method | ExpenseMileageInfo(ExpenseDetailInfo) | Constructor with Super Class Object as parameter
Public method | ExpenseMileageInfo(SerializationInfo, StreamingContext) |

See Also

ExpenseMileageInfo Class
ExpenseMileageInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseMileageInfo Constructor

[image]

OfficeClip API Documentation
ExpenseMileageInfo Constructor
ExpenseMileageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseMileageInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseMileageInfo()

See Also

ExpenseMileageInfo Class
ExpenseMileageInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseMileageInfo Constructor (ExpenseDetailInfo)

[image]

OfficeClip API Documentation
ExpenseMileageInfo Constructor (ExpenseDetailInfo)
ExpenseMileageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor with Super Class Object as parameter

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseMileageInfo(
    ExpenseDetailInfo edi
)
Visual Basic (Declaration)
Public Sub New ( _
    edi As ExpenseDetailInfo _
)
Visual C++
public:
ExpenseMileageInfo(
    ExpenseDetailInfo^ edi
)

Parameters

edi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
Super Class Object

See Also

ExpenseMileageInfo Class
ExpenseMileageInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseMileageInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
ExpenseMileageInfo Constructor (SerializationInfo, StreamingContext)
ExpenseMileageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseMileageInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExpenseMileageInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
SerializationInfo Object
context
Type: System.Runtime.Serialization..::.StreamingContext
StreamingContext Object

See Also

ExpenseMileageInfo Class
ExpenseMileageInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseMileageInfo Methods

[image] [image]

OfficeClip API Documentation
ExpenseMileageInfo Methods
ExpenseMileageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseMileageInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpenseMileageInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
ExpenseMileageInfo..::.GetObjectData Method
ExpenseMileageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
SerializationInfo Object
context
Type: System.Runtime.Serialization..::.StreamingContext
StreamingContext Object

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ExpenseMileageInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseMileageInfo Properties

[image] [image]

OfficeClip API Documentation
ExpenseMileageInfo Properties
ExpenseMileageInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseMileageInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Returns true/false by checking the details of ExpenseMileage (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | Mileage | Mileage
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)

See Also

ExpenseMileageInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsDetailAvailable Property

[image]

OfficeClip API Documentation
ExpenseMileageInfo..::.IsDetailAvailable Property
ExpenseMileageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns true/false by checking the details of ExpenseMileage

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool IsDetailAvailable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDetailAvailable As Boolean
Visual C++
public:
virtual property bool IsDetailAvailable {
    bool get () override;
}

See Also

ExpenseMileageInfo Class
OfficeClip.BusinessLayer.TE Namespace


Mileage Property

[image]

OfficeClip API Documentation
ExpenseMileageInfo..::.Mileage Property
ExpenseMileageInfo Class See Also

[This is preliminary documentation and is subject to change.]

Mileage

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double Mileage { get; set; }
Visual Basic (Declaration)
Public Property Mileage As Double
Visual C++
public:
property double Mileage {
    double get ();
    void set (double value);
}

See Also

ExpenseMileageInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTaxiInfo Class

[image]

OfficeClip API Documentation
ExpenseTaxiInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides the Members and Properties for the expenses for taxi fare.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ExpenseTaxiInfo : ExpenseDetailInfo, ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExpenseTaxiInfo _
    Inherits ExpenseDetailInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ExpenseTaxiInfo : public ExpenseDetailInfo,
    ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
OfficeClip.BusinessLayer.TE..::.ExpenseTaxiInfo

See Also

ExpenseTaxiInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseTaxiInfo Members

[image] [image]

OfficeClip API Documentation
ExpenseTaxiInfo Members
ExpenseTaxiInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseTaxiInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseTaxiInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | city | The city of the taxi expense.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Shows if the detail is available for this taxi expense object. (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)
Public property | TaxiLineName | The name of the taxi company.

See Also

ExpenseTaxiInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTaxiInfo Constructor

[image] [image]

OfficeClip API Documentation
ExpenseTaxiInfo Constructor
ExpenseTaxiInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpenseTaxiInfo()()() | The default constructor.
Public method | ExpenseTaxiInfo(ExpenseDetailInfo) | The constructor that takes the superclass as an argument.
Public method | ExpenseTaxiInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

ExpenseTaxiInfo Class
ExpenseTaxiInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseTaxiInfo Constructor

[image]

OfficeClip API Documentation
ExpenseTaxiInfo Constructor
ExpenseTaxiInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseTaxiInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseTaxiInfo()

See Also

ExpenseTaxiInfo Class
ExpenseTaxiInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseTaxiInfo Constructor (ExpenseDetailInfo)

[image]

OfficeClip API Documentation
ExpenseTaxiInfo Constructor (ExpenseDetailInfo)
ExpenseTaxiInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor that takes the superclass as an argument.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseTaxiInfo(
    ExpenseDetailInfo edi
)
Visual Basic (Declaration)
Public Sub New ( _
    edi As ExpenseDetailInfo _
)
Visual C++
public:
ExpenseTaxiInfo(
    ExpenseDetailInfo^ edi
)

Parameters

edi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
The expense detail information.

See Also

ExpenseTaxiInfo Class
ExpenseTaxiInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseTaxiInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
ExpenseTaxiInfo Constructor (SerializationInfo, StreamingContext)
ExpenseTaxiInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseTaxiInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExpenseTaxiInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

ExpenseTaxiInfo Class
ExpenseTaxiInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseTaxiInfo Methods

[image] [image]

OfficeClip API Documentation
ExpenseTaxiInfo Methods
ExpenseTaxiInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseTaxiInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpenseTaxiInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
ExpenseTaxiInfo..::.GetObjectData Method
ExpenseTaxiInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ExpenseTaxiInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTaxiInfo Properties

[image] [image]

OfficeClip API Documentation
ExpenseTaxiInfo Properties
ExpenseTaxiInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseTaxiInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | city | The city of the taxi expense.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Shows if the detail is available for this taxi expense object. (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)
Public property | TaxiLineName | The name of the taxi company.

See Also

ExpenseTaxiInfo Class
OfficeClip.BusinessLayer.TE Namespace


city Property

[image]

OfficeClip API Documentation
ExpenseTaxiInfo..::.city Property
ExpenseTaxiInfo Class See Also

[This is preliminary documentation and is subject to change.]

The city of the taxi expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string city { get; set; }
Visual Basic (Declaration)
Public Property city As String
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseTaxiInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsDetailAvailable Property

[image]

OfficeClip API Documentation
ExpenseTaxiInfo..::.IsDetailAvailable Property
ExpenseTaxiInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the detail is available for this taxi expense object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool IsDetailAvailable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDetailAvailable As Boolean
Visual C++
public:
virtual property bool IsDetailAvailable {
    bool get () override;
}

See Also

ExpenseTaxiInfo Class
OfficeClip.BusinessLayer.TE Namespace


TaxiLineName Property

[image]

OfficeClip API Documentation
ExpenseTaxiInfo..::.TaxiLineName Property
ExpenseTaxiInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the taxi company.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TaxiLineName { get; set; }
Visual Basic (Declaration)
Public Property TaxiLineName As String
Visual C++
public:
property String^ TaxiLineName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseTaxiInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTelephoneInfo Class

[image]

OfficeClip API Documentation
ExpenseTelephoneInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties for the telephone expenses.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ExpenseTelephoneInfo : ExpenseDetailInfo, ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExpenseTelephoneInfo _
    Inherits ExpenseDetailInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class ExpenseTelephoneInfo : public ExpenseDetailInfo,
    ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
OfficeClip.BusinessLayer.TE..::.ExpenseTelephoneInfo

See Also

ExpenseTelephoneInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseTelephoneInfo Members

[image] [image]

OfficeClip API Documentation
ExpenseTelephoneInfo Members
ExpenseTelephoneInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseTelephoneInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseTelephoneInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | city | City where the Telephone expense is made.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Shows if the detail is available for the telephone expense. (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | PhoneNumber | The phone number for the telephone expense.
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)

See Also

ExpenseTelephoneInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTelephoneInfo Constructor

[image] [image]

OfficeClip API Documentation
ExpenseTelephoneInfo Constructor
ExpenseTelephoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpenseTelephoneInfo()()() | The default constructor
Public method | ExpenseTelephoneInfo(ExpenseDetailInfo) | The constructor that takes an object of the base class as an argument.
Public method | ExpenseTelephoneInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

ExpenseTelephoneInfo Class
ExpenseTelephoneInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseTelephoneInfo Constructor

[image]

OfficeClip API Documentation
ExpenseTelephoneInfo Constructor
ExpenseTelephoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseTelephoneInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseTelephoneInfo()

See Also

ExpenseTelephoneInfo Class
ExpenseTelephoneInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseTelephoneInfo Constructor (ExpenseDetailInfo)

[image]

OfficeClip API Documentation
ExpenseTelephoneInfo Constructor (ExpenseDetailInfo)
ExpenseTelephoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor that takes an object of the base class as an argument.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseTelephoneInfo(
    ExpenseDetailInfo edi
)
Visual Basic (Declaration)
Public Sub New ( _
    edi As ExpenseDetailInfo _
)
Visual C++
public:
ExpenseTelephoneInfo(
    ExpenseDetailInfo^ edi
)

Parameters

edi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
The expense detail object.

See Also

ExpenseTelephoneInfo Class
ExpenseTelephoneInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseTelephoneInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
ExpenseTelephoneInfo Constructor (SerializationInfo, StreamingContext)
ExpenseTelephoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseTelephoneInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExpenseTelephoneInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

ExpenseTelephoneInfo Class
ExpenseTelephoneInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseTelephoneInfo Methods

[image] [image]

OfficeClip API Documentation
ExpenseTelephoneInfo Methods
ExpenseTelephoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseTelephoneInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpenseTelephoneInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
ExpenseTelephoneInfo..::.GetObjectData Method
ExpenseTelephoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ExpenseTelephoneInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTelephoneInfo Properties

[image] [image]

OfficeClip API Documentation
ExpenseTelephoneInfo Properties
ExpenseTelephoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseTelephoneInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The system generated identifier for the account associates with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | AccountName | The name of the account associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Amount | The Amount of the expense. (Inherited from ExpenseDetailInfo.)
Public property | city | City where the Telephone expense is made.
Public property | CreatedByTimestamp | The created date and time of when this expense detail information object is created. (Inherited from ExpenseDetailInfo.)
Public property | CreatedByUserId | The system generated unique identifier for the user who created this expense detail object. (Inherited from ExpenseDetailInfo.)
Public property | Description | The textual Description for this expense. (Inherited from ExpenseDetailInfo.)
Public property | Detail | Details of the ExpenseDetail (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDate | The date when this expense was made. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseDetailId | The system generated identifier for the expense detail. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseId | The system generated unique identifier for the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseName | The name of the expense. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeId | The identifier for the expense type. (Inherited from ExpenseDetailInfo.)
Public property | ExpenseTypeUniqueId | The system generated identifier for the teplate for this expense detail. (Inherited from ExpenseDetailInfo.)
Public property | IsBillable | shows if the expense detail is billable. Uses the value "Y" for billable and "N" for non billable. (Inherited from ExpenseDetailInfo.)
Public property | IsDetailAvailable | Shows if the detail is available for the telephone expense. (Overrides ExpenseDetailInfo ..::. IsDetailAvailable.)
Public property | ModifiedByTimestamp | The time stamp when the expense detail information object is last modified. (Inherited from ExpenseDetailInfo.)
Public property | ModifiedByUserId | The user identifier of the user who last modified the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMethodId | The system generated unique identifier for the payment method for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | PaymentMode | Payment Mode (Inherited from ExpenseDetailInfo.)
Public property | PhoneNumber | The phone number for the telephone expense.
Public property | ProjectId | The system generated unique identifier for the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | ProjectName | The name of the Project associated with this expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | Reimbursed | The Reimbursed Amount (Inherited from ExpenseDetailInfo.)
Public property | ReimbursedNote | The Notes of Reimbursed (Inherited from ExpenseDetailInfo.)
Public property | SerialNumber | The serial number for the expense detail information object. (Inherited from ExpenseDetailInfo.)
Public property | tax | The tax Amount for this expense. (Inherited from ExpenseDetailInfo.)

See Also

ExpenseTelephoneInfo Class
OfficeClip.BusinessLayer.TE Namespace


city Property

[image]

OfficeClip API Documentation
ExpenseTelephoneInfo..::.city Property
ExpenseTelephoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

City where the Telephone expense is made.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string city { get; set; }
Visual Basic (Declaration)
Public Property city As String
Visual C++
public:
property String^ city {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseTelephoneInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsDetailAvailable Property

[image]

OfficeClip API Documentation
ExpenseTelephoneInfo..::.IsDetailAvailable Property
ExpenseTelephoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the detail is available for the telephone expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool IsDetailAvailable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsDetailAvailable As Boolean
Visual C++
public:
virtual property bool IsDetailAvailable {
    bool get () override;
}

See Also

ExpenseTelephoneInfo Class
OfficeClip.BusinessLayer.TE Namespace


PhoneNumber Property

[image]

OfficeClip API Documentation
ExpenseTelephoneInfo..::.PhoneNumber Property
ExpenseTelephoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The phone number for the telephone expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PhoneNumber { get; set; }
Visual Basic (Declaration)
Public Property PhoneNumber As String
Visual C++
public:
property String^ PhoneNumber {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseTelephoneInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeInfo Class

[image]

OfficeClip API Documentation
ExpenseTypeInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the expense type related information.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class ExpenseTypeInfo : ISerializable,
    IComparable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ExpenseTypeInfo _
    Implements ISerializable, IComparable
Visual C++
[SerializableAttribute]
public ref class ExpenseTypeInfo : ISerializable,
    IComparable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ExpenseTypeInfo

See Also

ExpenseTypeInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeInfo Members

[image] [image]

OfficeClip API Documentation
ExpenseTypeInfo Members
ExpenseTypeInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseTypeInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseTypeInfo | Overloaded.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides Object..::.Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::.GetHashCode()()().)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowBillableModify | Shows whether modifications are allowed on the billable option for the expenses created using this type.
Public property | ExpenseName | The name of the expense type.
Public property | ExpenseTypeAndBillable |
Public property | ExpenseTypeId | The unique identifier for the expense type.
Public property | ExpenseTypeKey | The expense type key for the expense type.
Public property | ExpenseTypeUniqueId | The expense template detail identifier for the expense type.
Public property | GroupId | The group identifier for the group which owns the expense template.
Public property | IsActive | Gets or set a expense type IsActive.Valid values are "Y" (type is active) or "N" (type is not active).
Public property | IsBillable | Shows whether the expense created by this type is billable. The values can either be "Y" or "N".
Public property | IsDetailMandatory | Shows if the detail is mandatory on the expense that uses this type.
Public property | TemplateExpenseTypeName | The expense type name on the template.

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeInfo Constructor

[image] [image]

OfficeClip API Documentation
ExpenseTypeInfo Constructor
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExpenseTypeInfo()()() | The default constructor.
Public method | ExpenseTypeInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

ExpenseTypeInfo Class
ExpenseTypeInfo Members
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeInfo Constructor

[image]

OfficeClip API Documentation
ExpenseTypeInfo Constructor
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseTypeInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseTypeInfo()

See Also

ExpenseTypeInfo Class
ExpenseTypeInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
ExpenseTypeInfo Constructor (SerializationInfo, StreamingContext)
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseTypeInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExpenseTypeInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

ExpenseTypeInfo Class
ExpenseTypeInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeInfo Methods

[image] [image]

OfficeClip API Documentation
ExpenseTypeInfo Methods
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseTypeInfo type exposes the following methods.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides Object..::.Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::.GetHashCode()()().)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


CompareTo Method

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.CompareTo Method
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object

Implements

IComparable..::.CompareTo(Object)

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


Equals Method

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.Equals Method
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetHashCode Method

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.GetHashCode Method
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.GetObjectData Method
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeInfo Properties

[image] [image]

OfficeClip API Documentation
ExpenseTypeInfo Properties
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseTypeInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AllowBillableModify | Shows whether modifications are allowed on the billable option for the expenses created using this type.
Public property | ExpenseName | The name of the expense type.
Public property | ExpenseTypeAndBillable |
Public property | ExpenseTypeId | The unique identifier for the expense type.
Public property | ExpenseTypeKey | The expense type key for the expense type.
Public property | ExpenseTypeUniqueId | The expense template detail identifier for the expense type.
Public property | GroupId | The group identifier for the group which owns the expense template.
Public property | IsActive | Gets or set a expense type IsActive.Valid values are "Y" (type is active) or "N" (type is not active).
Public property | IsBillable | Shows whether the expense created by this type is billable. The values can either be "Y" or "N".
Public property | IsDetailMandatory | Shows if the detail is mandatory on the expense that uses this type.
Public property | TemplateExpenseTypeName | The expense type name on the template.

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


AllowBillableModify Property

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.AllowBillableModify Property
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether modifications are allowed on the billable option for the expenses created using this type.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AllowBillableModify { get; set; }
Visual Basic (Declaration)
Public Property AllowBillableModify As String
Visual C++
public:
property String^ AllowBillableModify {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseName Property

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.ExpenseName Property
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the expense type.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ExpenseName { get; set; }
Visual Basic (Declaration)
Public Property ExpenseName As String
Visual C++
public:
property String^ ExpenseName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeAndBillable Property

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.ExpenseTypeAndBillable Property
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ExpenseTypeAndBillable { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExpenseTypeAndBillable As String
Visual C++
public:
property String^ ExpenseTypeAndBillable {
    String^ get ();
}

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeId Property

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.ExpenseTypeId Property
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique identifier for the expense type.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpenseTypeId { get; set; }
Visual Basic (Declaration)
Public Property ExpenseTypeId As Integer
Visual C++
public:
property int ExpenseTypeId {
    int get ();
    void set (int value);
}

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeKey Property

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.ExpenseTypeKey Property
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The expense type key for the expense type.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ExpenseTypeKey { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExpenseTypeKey As String
Visual C++
public:
property String^ ExpenseTypeKey {
    String^ get ();
}

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypeUniqueId Property

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.ExpenseTypeUniqueId Property
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The expense template detail identifier for the expense type.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpenseTypeUniqueId { get; set; }
Visual Basic (Declaration)
Public Property ExpenseTypeUniqueId As Integer
Visual C++
public:
property int ExpenseTypeUniqueId {
    int get ();
    void set (int value);
}

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupId Property

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.GroupId Property
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The group identifier for the group which owns the expense template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsActive Property

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.IsActive Property
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or set a expense type IsActive.Valid values are "Y" (type is active) or "N" (type is not active).

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As String
Visual C++
public:
property String^ IsActive {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsBillable Property

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.IsBillable Property
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the expense created by this type is billable. The values can either be "Y" or "N".

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsBillable { get; set; }
Visual Basic (Declaration)
Public Property IsBillable As String
Visual C++
public:
property String^ IsBillable {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsDetailMandatory Property

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.IsDetailMandatory Property
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the detail is mandatory on the expense that uses this type.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsDetailMandatory { get; set; }
Visual Basic (Declaration)
Public Property IsDetailMandatory As String
Visual C++
public:
property String^ IsDetailMandatory {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


TemplateExpenseTypeName Property

[image]

OfficeClip API Documentation
ExpenseTypeInfo..::.TemplateExpenseTypeName Property
ExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The expense type name on the template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TemplateExpenseTypeName { get; set; }
Visual Basic (Declaration)
Public Property TemplateExpenseTypeName As String
Visual C++
public:
property String^ TemplateExpenseTypeName {
    String^ get ();
    void set (String^ value);
}

See Also

ExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupExpenseTypeInfo Class

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the expense template information.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class GroupExpenseTypeInfo
Visual Basic (Declaration)
Public Class GroupExpenseTypeInfo
Visual C++
public ref class GroupExpenseTypeInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.GroupExpenseTypeInfo

See Also

GroupExpenseTypeInfo Members
OfficeClip.BusinessLayer.TE Namespace


GroupExpenseTypeInfo Members

[image] [image]

OfficeClip API Documentation
GroupExpenseTypeInfo Members
GroupExpenseTypeInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The GroupExpenseTypeInfo type exposes the following members.

Constructors

 | Name | Description
Public method | GroupExpenseTypeInfo | The default constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDuplicateExpenseType | Returns the duplicate expense type for the expense template.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeUniqueId | Gets the template detail identifier for the expense template.
Public method | IsAllowBillable | Finds if the change expense billable is allowed.
Public method | IsBillable | Finds if the expense type is billable.
Public method | IsDetailMandatory | Finds if the detail in mandatory for the expenses.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExpenseTypes | A list of expense types on the expense template.
Public property | FooterText | The footer text for the expense template.
Public property | GroupId | The unique identifier for the group which the expense template belongs to.
Public property | HeaderText | The header text for the expense template.
Public property | IsActive | Shows if the expense template is Active. The value can be either "Y" or "N".
Public property | NumLines | The number of lines on the expense template.

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupExpenseTypeInfo Constructor

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo Constructor
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GroupExpenseTypeInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupExpenseTypeInfo()

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupExpenseTypeInfo Methods

[image] [image]

OfficeClip API Documentation
GroupExpenseTypeInfo Methods
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The GroupExpenseTypeInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDuplicateExpenseType | Returns the duplicate expense type for the expense template.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeUniqueId | Gets the template detail identifier for the expense template.
Public method | IsAllowBillable | Finds if the change expense billable is allowed.
Public method | IsBillable | Finds if the expense type is billable.
Public method | IsDetailMandatory | Finds if the detail in mandatory for the expenses.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetDuplicateExpenseType Method

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo..::.GetDuplicateExpenseType Method
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the duplicate expense type for the expense template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetDuplicateExpenseType()
Visual Basic (Declaration)
Public Function GetDuplicateExpenseType As String
Visual C++
public:
String^ GetDuplicateExpenseType()

Return Value

The duplicate expense type for the expense template.

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetTypeUniqueId Method

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo..::.GetTypeUniqueId Method
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the template detail identifier for the expense template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GetTypeUniqueId(
    int expenseTypeId
)
Visual Basic (Declaration)
Public Function GetTypeUniqueId ( _
    expenseTypeId As Integer _
) As Integer
Visual C++
public:
int GetTypeUniqueId(
    int expenseTypeId
)

Parameters

expenseTypeId
Type: System..::.Int32
The expense type id.

Return Value

The template detail identifier.

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsAllowBillable Method

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo..::.IsAllowBillable Method
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Finds if the change expense billable is allowed.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsAllowBillable(
    int expenseTypeId
)
Visual Basic (Declaration)
Public Function IsAllowBillable ( _
    expenseTypeId As Integer _
) As String
Visual C++
public:
String^ IsAllowBillable(
    int expenseTypeId
)

Parameters

expenseTypeId
Type: System..::.Int32
The expense type identifier.

Return Value

"Y" if the expense type is billable, "F" otherwise.

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsBillable Method

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo..::.IsBillable Method
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Finds if the expense type is billable.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsBillable(
    int expenseTypeId
)
Visual Basic (Declaration)
Public Function IsBillable ( _
    expenseTypeId As Integer _
) As String
Visual C++
public:
String^ IsBillable(
    int expenseTypeId
)

Parameters

expenseTypeId
Type: System..::.Int32
The expense type identifier.

Return Value

"Y" if the expense type is billable, "F" otherwise.

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsDetailMandatory Method

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo..::.IsDetailMandatory Method
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Finds if the detail in mandatory for the expenses.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsDetailMandatory(
    int expenseTypeId,
    int expenseTypeUniqueId
)
Visual Basic (Declaration)
Public Function IsDetailMandatory ( _
    expenseTypeId As Integer, _
    expenseTypeUniqueId As Integer _
) As Boolean
Visual C++
public:
bool IsDetailMandatory(
    int expenseTypeId,
    int expenseTypeUniqueId
)

Parameters

expenseTypeId
Type: System..::.Int32
The identifier for the expense type.
expenseTypeUniqueId
Type: System..::.Int32
The unique identifier for the expense type.

Return Value

True if the detail is mandatory, false otherwise.

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupExpenseTypeInfo Properties

[image] [image]

OfficeClip API Documentation
GroupExpenseTypeInfo Properties
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The GroupExpenseTypeInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ExpenseTypes | A list of expense types on the expense template.
Public property | FooterText | The footer text for the expense template.
Public property | GroupId | The unique identifier for the group which the expense template belongs to.
Public property | HeaderText | The header text for the expense template.
Public property | IsActive | Shows if the expense template is Active. The value can be either "Y" or "N".
Public property | NumLines | The number of lines on the expense template.

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseTypes Property

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo..::.ExpenseTypes Property
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

A list of expense types on the expense template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList ExpenseTypes { get; set; }
Visual Basic (Declaration)
Public Property ExpenseTypes As ArrayList
Visual C++
public:
property ArrayList^ ExpenseTypes {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


FooterText Property

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo..::.FooterText Property
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The footer text for the expense template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FooterText { get; set; }
Visual Basic (Declaration)
Public Property FooterText As String
Visual C++
public:
property String^ FooterText {
    String^ get ();
    void set (String^ value);
}

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupId Property

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo..::.GroupId Property
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique identifier for the group which the expense template belongs to.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


HeaderText Property

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo..::.HeaderText Property
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The header text for the expense template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string HeaderText { get; set; }
Visual Basic (Declaration)
Public Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsActive Property

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo..::.IsActive Property
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the expense template is Active. The value can be either "Y" or "N".

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As String
Visual C++
public:
property String^ IsActive {
    String^ get ();
    void set (String^ value);
}

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


NumLines Property

[image]

OfficeClip API Documentation
GroupExpenseTypeInfo..::.NumLines Property
GroupExpenseTypeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The number of lines on the expense template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumLines { get; set; }
Visual Basic (Declaration)
Public Property NumLines As Integer
Visual C++
public:
property int NumLines {
    int get ();
    void set (int value);
}

See Also

GroupExpenseTypeInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupTimesheetTaskInfo Class

[image]

OfficeClip API Documentation
GroupTimesheetTaskInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties for timesheet information.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class GroupTimesheetTaskInfo
Visual Basic (Declaration)
Public Class GroupTimesheetTaskInfo
Visual C++
public ref class GroupTimesheetTaskInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.GroupTimesheetTaskInfo

See Also

GroupTimesheetTaskInfo Members
OfficeClip.BusinessLayer.TE Namespace


GroupTimesheetTaskInfo Members

[image] [image]

OfficeClip API Documentation
GroupTimesheetTaskInfo Members
GroupTimesheetTaskInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The GroupTimesheetTaskInfo type exposes the following members.

Constructors

 | Name | Description
Public method | GroupTimesheetTaskInfo | The timesheet template information constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAllowBillable | Shows if in a particular task, modifying billability is allowed.
Public method | IsBillable | Shows if a particular task is billable.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | TaskExists | Shows if the timesheet exists for the timesheet task information.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FooterText | The footer text for the timesheet template.
Public property | GroupId | The group identifier for the group which owns the timesheet template.
Public property | HeaderText | The header text for the timesheet template.
Public property | IsActive | Shows if the timesheet template is active. Valid values are "Y" (for active) and "N" (for inactive).
Public property | NumLines | The number of lines on the timesheet template.
Public property | TimesheetTasks | The ArrayList for timesheet tasks.

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupTimesheetTaskInfo Constructor

[image]

OfficeClip API Documentation
GroupTimesheetTaskInfo Constructor
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The timesheet template information constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public GroupTimesheetTaskInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupTimesheetTaskInfo()

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupTimesheetTaskInfo Methods

[image] [image]

OfficeClip API Documentation
GroupTimesheetTaskInfo Methods
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The GroupTimesheetTaskInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAllowBillable | Shows if in a particular task, modifying billability is allowed.
Public method | IsBillable | Shows if a particular task is billable.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | TaskExists | Shows if the timesheet exists for the timesheet task information.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsAllowBillable Method

[image]

OfficeClip API Documentation
GroupTimesheetTaskInfo..::.IsAllowBillable Method
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if in a particular task, modifying billability is allowed.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsAllowBillable(
    int taskId
)
Visual Basic (Declaration)
Public Function IsAllowBillable ( _
    taskId As Integer _
) As String
Visual C++
public:
String^ IsAllowBillable(
    int taskId
)

Parameters

taskId
Type: System..::.Int32
The unique identifier for a task.

Return Value

"Y" if the task is billable, "N" otherwise.

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsBillable Method

[image]

OfficeClip API Documentation
GroupTimesheetTaskInfo..::.IsBillable Method
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if a particular task is billable.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsBillable(
    int taskId
)
Visual Basic (Declaration)
Public Function IsBillable ( _
    taskId As Integer _
) As String
Visual C++
public:
String^ IsBillable(
    int taskId
)

Parameters

taskId
Type: System..::.Int32
The unique identifier for a task.

Return Value

"Y" if the task is billable, "N" otherwise.

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


TaskExists Method

[image]

OfficeClip API Documentation
GroupTimesheetTaskInfo..::.TaskExists Method
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the timesheet exists for the timesheet task information.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool TaskExists(
    TimesheetTaskInfo tti
)
Visual Basic (Declaration)
Public Function TaskExists ( _
    tti As TimesheetTaskInfo _
) As Boolean
Visual C++
public:
bool TaskExists(
    TimesheetTaskInfo^ tti
)

Parameters

tti
Type: OfficeClip.BusinessLayer.TE..::.TimesheetTaskInfo
The timesheet task information.

Return Value

true if the timesheet is found for the task information, false otherwise.

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupTimesheetTaskInfo Properties

[image] [image]

OfficeClip API Documentation
GroupTimesheetTaskInfo Properties
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The GroupTimesheetTaskInfo type exposes the following properties.

Properties

 | Name | Description
Public property | FooterText | The footer text for the timesheet template.
Public property | GroupId | The group identifier for the group which owns the timesheet template.
Public property | HeaderText | The header text for the timesheet template.
Public property | IsActive | Shows if the timesheet template is active. Valid values are "Y" (for active) and "N" (for inactive).
Public property | NumLines | The number of lines on the timesheet template.
Public property | TimesheetTasks | The ArrayList for timesheet tasks.

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


FooterText Property

[image]

OfficeClip API Documentation
GroupTimesheetTaskInfo..::.FooterText Property
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The footer text for the timesheet template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FooterText { get; set; }
Visual Basic (Declaration)
Public Property FooterText As String
Visual C++
public:
property String^ FooterText {
    String^ get ();
    void set (String^ value);
}

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupId Property

[image]

OfficeClip API Documentation
GroupTimesheetTaskInfo..::.GroupId Property
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The group identifier for the group which owns the timesheet template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


HeaderText Property

[image]

OfficeClip API Documentation
GroupTimesheetTaskInfo..::.HeaderText Property
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The header text for the timesheet template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string HeaderText { get; set; }
Visual Basic (Declaration)
Public Property HeaderText As String
Visual C++
public:
property String^ HeaderText {
    String^ get ();
    void set (String^ value);
}

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsActive Property

[image]

OfficeClip API Documentation
GroupTimesheetTaskInfo..::.IsActive Property
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the timesheet template is active. Valid values are "Y" (for active) and "N" (for inactive).

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As String
Visual C++
public:
property String^ IsActive {
    String^ get ();
    void set (String^ value);
}

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


NumLines Property

[image]

OfficeClip API Documentation
GroupTimesheetTaskInfo..::.NumLines Property
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The number of lines on the timesheet template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumLines { get; set; }
Visual Basic (Declaration)
Public Property NumLines As Integer
Visual C++
public:
property int NumLines {
    int get ();
    void set (int value);
}

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetTasks Property

[image]

OfficeClip API Documentation
GroupTimesheetTaskInfo..::.TimesheetTasks Property
GroupTimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ArrayList for timesheet tasks.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList TimesheetTasks { get; set; }
Visual Basic (Declaration)
Public Property TimesheetTasks As ArrayList
Visual C++
public:
property ArrayList^ TimesheetTasks {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

GroupTimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


ParentChildInfo Class

[image]

OfficeClip API Documentation
ParentChildInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ParentChildInfo
Visual Basic (Declaration)
Public Class ParentChildInfo
Visual C++
public ref class ParentChildInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ParentChildInfo

See Also

ParentChildInfo Members
OfficeClip.BusinessLayer.TE Namespace


ParentChildInfo Members

[image] [image]

OfficeClip API Documentation
ParentChildInfo Members
ParentChildInfo Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The ParentChildInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ParentChildInfo |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::.ToString()()().)

Fields

 | Name | Description
Protected field | _text |
Protected field | _value |

Properties

 | Name | Description
Public property | ChildNodes |
Public property | Text |
Public property | Value |

See Also

ParentChildInfo Class
OfficeClip.BusinessLayer.TE Namespace


ParentChildInfo Constructor

[image]

OfficeClip API Documentation
ParentChildInfo Constructor
ParentChildInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ParentChildInfo(
    string text,
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String, _
    value As String _
)
Visual C++
public:
ParentChildInfo(
    String^ text,
    String^ value
)

Parameters

text
Type: System..::.String
value
Type: System..::.String

See Also

ParentChildInfo Class
OfficeClip.BusinessLayer.TE Namespace


ParentChildInfo Fields

[image] [image]

OfficeClip API Documentation
ParentChildInfo Fields
ParentChildInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ParentChildInfo type exposes the following fields.

Fields

 | Name | Description
Protected field | _text |
Protected field | _value |

See Also

ParentChildInfo Class
OfficeClip.BusinessLayer.TE Namespace


_text Field

[image]

OfficeClip API Documentation
ParentChildInfo..::._text Field
ParentChildInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _text
Visual Basic (Declaration)
Protected _text As String
Visual C++
protected:
String^ _text

See Also

ParentChildInfo Class
OfficeClip.BusinessLayer.TE Namespace


_value Field

[image]

OfficeClip API Documentation
ParentChildInfo..::._value Field
ParentChildInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string _value
Visual Basic (Declaration)
Protected _value As String
Visual C++
protected:
String^ _value

See Also

ParentChildInfo Class
OfficeClip.BusinessLayer.TE Namespace


ParentChildInfo Methods

[image] [image]

OfficeClip API Documentation
ParentChildInfo Methods
ParentChildInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ParentChildInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::.ToString()()().)

See Also

ParentChildInfo Class
OfficeClip.BusinessLayer.TE Namespace


ToString Method

[image]

OfficeClip API Documentation
ParentChildInfo..::.ToString Method
ParentChildInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ParentChildInfo Class
OfficeClip.BusinessLayer.TE Namespace


ParentChildInfo Properties

[image] [image]

OfficeClip API Documentation
ParentChildInfo Properties
ParentChildInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ParentChildInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ChildNodes |
Public property | Text |
Public property | Value |

See Also

ParentChildInfo Class
OfficeClip.BusinessLayer.TE Namespace


ChildNodes Property

[image]

OfficeClip API Documentation
ParentChildInfo..::.ChildNodes Property
ParentChildInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public List<ParentChildInfo> ChildNodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildNodes As List(Of ParentChildInfo)
Visual C++
public:
property List<ParentChildInfo^>^ ChildNodes {
    List<ParentChildInfo^>^ get ();
}

See Also

ParentChildInfo Class
OfficeClip.BusinessLayer.TE Namespace


Text Property

[image]

OfficeClip API Documentation
ParentChildInfo..::.Text Property
ParentChildInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ParentChildInfo Class
OfficeClip.BusinessLayer.TE Namespace


Value Property

[image]

OfficeClip API Documentation
ParentChildInfo..::.Value Property
ParentChildInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

ParentChildInfo Class
OfficeClip.BusinessLayer.TE Namespace


PayrollCategoryInfo Class

[image]

OfficeClip API Documentation
PayrollCategoryInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods to interact with the Time and Expenses Payroll Information Object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class PayrollCategoryInfo
Visual Basic (Declaration)
Public Class PayrollCategoryInfo
Visual C++
public ref class PayrollCategoryInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.PayrollCategoryInfo

See Also

PayrollCategoryInfo Members
OfficeClip.BusinessLayer.TE Namespace


PayrollCategoryInfo Members

[image] [image]

OfficeClip API Documentation
PayrollCategoryInfo Members
PayrollCategoryInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PayrollCategoryInfo type exposes the following members.

Constructors

 | Name | Description
Public method | PayrollCategoryInfo | Overloaded.

Methods

 | Name | Description
Public method | CodeWithOverhead | Returns the code with overhead
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FullNameWithOverhead | Return the full name with overhead
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AvailableTime | Teh available time
Public property | Id | The payroll id
Public property | IsActive | True if it is an overhead
Public property | Notes | The payroll notes
Public property | PayrollCategoryId | The system generated unique id.
Public property | PayrollCode | The payroll code
Public property | PayrollFullName | The payroll full name
Public property | UsedTime | The used time

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


PayrollCategoryInfo Constructor

[image] [image]

OfficeClip API Documentation
PayrollCategoryInfo Constructor
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PayrollCategoryInfo()()() | The default constructor.
Public method | PayrollCategoryInfo(Int32, String, String, String, String, Decimal, Decimal, Boolean) | Constructor

See Also

PayrollCategoryInfo Class
PayrollCategoryInfo Members
OfficeClip.BusinessLayer.TE Namespace


PayrollCategoryInfo Constructor

[image]

OfficeClip API Documentation
PayrollCategoryInfo Constructor
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PayrollCategoryInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PayrollCategoryInfo()

See Also

PayrollCategoryInfo Class
PayrollCategoryInfo Overload
OfficeClip.BusinessLayer.TE Namespace


PayrollCategoryInfo Constructor (Int32, String, String, String, String, Decimal, Decimal, Boolean)

[image]

OfficeClip API Documentation
PayrollCategoryInfo Constructor (Int32, String, String, String, String, Decimal, Decimal, Boolean)
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PayrollCategoryInfo(
    int payrollCategoryId,
    string payrollCode,
    string payrollFullName,
    string notes,
    string id,
    decimal availableTime,
    decimal usedTime,
    bool isActive
)
Visual Basic (Declaration)
Public Sub New ( _
    payrollCategoryId As Integer, _
    payrollCode As String, _
    payrollFullName As String, _
    notes As String, _
    id As String, _
    availableTime As Decimal, _
    usedTime As Decimal, _
    isActive As Boolean _
)
Visual C++
public:
PayrollCategoryInfo(
    int payrollCategoryId,
    String^ payrollCode,
    String^ payrollFullName,
    String^ notes,
    String^ id,
    Decimal availableTime,
    Decimal usedTime,
    bool isActive
)

Parameters

payrollCategoryId
Type: System..::.Int32
The payroll category id
payrollCode
Type: System..::.String
The payroll code
payrollFullName
Type: System..::.String
The payroll full name
notes
Type: System..::.String
The payroll notes
id
Type: System..::.String
The payroll foreign key
availableTime
Type: System..::.Decimal
The available time
usedTime
Type: System..::.Decimal
The user time
isActive
Type: System..::.Boolean
true if it is an Active item

See Also

PayrollCategoryInfo Class
PayrollCategoryInfo Overload
OfficeClip.BusinessLayer.TE Namespace


PayrollCategoryInfo Methods

[image] [image]

OfficeClip API Documentation
PayrollCategoryInfo Methods
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PayrollCategoryInfo type exposes the following methods.

Methods

 | Name | Description
Public method | CodeWithOverhead | Returns the code with overhead
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FullNameWithOverhead | Return the full name with overhead
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


CodeWithOverhead Method

[image]

OfficeClip API Documentation
PayrollCategoryInfo..::.CodeWithOverhead Method
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the code with overhead

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CodeWithOverhead()
Visual Basic (Declaration)
Public Function CodeWithOverhead As String
Visual C++
public:
String^ CodeWithOverhead()

Return Value

The code with overhead

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


FullNameWithOverhead Method

[image]

OfficeClip API Documentation
PayrollCategoryInfo..::.FullNameWithOverhead Method
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Return the full name with overhead

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FullNameWithOverhead()
Visual Basic (Declaration)
Public Function FullNameWithOverhead As String
Visual C++
public:
String^ FullNameWithOverhead()

Return Value

The full name with overhead

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


PayrollCategoryInfo Properties

[image] [image]

OfficeClip API Documentation
PayrollCategoryInfo Properties
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PayrollCategoryInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AvailableTime | Teh available time
Public property | Id | The payroll id
Public property | IsActive | True if it is an overhead
Public property | Notes | The payroll notes
Public property | PayrollCategoryId | The system generated unique id.
Public property | PayrollCode | The payroll code
Public property | PayrollFullName | The payroll full name
Public property | UsedTime | The used time

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


AvailableTime Property

[image]

OfficeClip API Documentation
PayrollCategoryInfo..::.AvailableTime Property
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Teh available time

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public decimal AvailableTime { get; set; }
Visual Basic (Declaration)
Public Property AvailableTime As Decimal
Visual C++
public:
property Decimal AvailableTime {
    Decimal get ();
    void set (Decimal value);
}

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


Id Property

[image]

OfficeClip API Documentation
PayrollCategoryInfo..::.Id Property
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The payroll id

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsActive Property

[image]

OfficeClip API Documentation
PayrollCategoryInfo..::.IsActive Property
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

True if it is an overhead

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As Boolean
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


Notes Property

[image]

OfficeClip API Documentation
PayrollCategoryInfo..::.Notes Property
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The payroll notes

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Notes { get; set; }
Visual Basic (Declaration)
Public Property Notes As String
Visual C++
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


PayrollCategoryId Property

[image]

OfficeClip API Documentation
PayrollCategoryInfo..::.PayrollCategoryId Property
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique id.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int PayrollCategoryId { get; set; }
Visual Basic (Declaration)
Public Property PayrollCategoryId As Integer
Visual C++
public:
property int PayrollCategoryId {
    int get ();
    void set (int value);
}

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


PayrollCode Property

[image]

OfficeClip API Documentation
PayrollCategoryInfo..::.PayrollCode Property
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The payroll code

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PayrollCode { get; set; }
Visual Basic (Declaration)
Public Property PayrollCode As String
Visual C++
public:
property String^ PayrollCode {
    String^ get ();
    void set (String^ value);
}

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


PayrollFullName Property

[image]

OfficeClip API Documentation
PayrollCategoryInfo..::.PayrollFullName Property
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The payroll full name

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PayrollFullName { get; set; }
Visual Basic (Declaration)
Public Property PayrollFullName As String
Visual C++
public:
property String^ PayrollFullName {
    String^ get ();
    void set (String^ value);
}

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


UsedTime Property

[image]

OfficeClip API Documentation
PayrollCategoryInfo..::.UsedTime Property
PayrollCategoryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The used time

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public decimal UsedTime { get; set; }
Visual Basic (Declaration)
Public Property UsedTime As Decimal
Visual C++
public:
property Decimal UsedTime {
    Decimal get ();
    void set (Decimal value);
}

See Also

PayrollCategoryInfo Class
OfficeClip.BusinessLayer.TE Namespace


PunchDayInfo Class

[image]

OfficeClip API Documentation
PunchDayInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Represents the group/Organization's menu information.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class PunchDayInfo
Visual Basic (Declaration)
Public Class PunchDayInfo
Visual C++
public ref class PunchDayInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.PunchDayInfo

See Also

PunchDayInfo Members
OfficeClip.BusinessLayer.TE Namespace


PunchDayInfo Members

[image] [image]

OfficeClip API Documentation
PunchDayInfo Members
PunchDayInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PunchDayInfo type exposes the following members.

Constructors

 | Name | Description
Public method | PunchDayInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetTotalPunchedTime | The total punch time
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNotPunched | Checks if not punched at all
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BreakTime | The break time
Public property | PunchDate | The punch date
Public property | PunchTime1 | The punch time for the first punch
Public property | PunchTime2 | The punch time for the second punch
Public property | PunchTime3 | The punch time for the third punch
Public property | PunchTime4 | The punch time for the fourth punch
Public property | UserId | The unique if of the user

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


PunchDayInfo Constructor

[image] [image]

OfficeClip API Documentation
PunchDayInfo Constructor
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PunchDayInfo(Int32, DateTime) | The punch dat information constructor
Public method | PunchDayInfo(Int32, DateTime, PunchTimeInfo, PunchTimeInfo, PunchTimeInfo, PunchTimeInfo, Int32) | Punch day information constructor

See Also

PunchDayInfo Class
PunchDayInfo Members
OfficeClip.BusinessLayer.TE Namespace


PunchDayInfo Constructor (Int32, DateTime)

[image]

OfficeClip API Documentation
PunchDayInfo Constructor (Int32, DateTime)
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

The punch dat information constructor

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchDayInfo(
    int userId,
    DateTime punchDate
)
Visual Basic (Declaration)
Public Sub New ( _
    userId As Integer, _
    punchDate As DateTime _
)
Visual C++
public:
PunchDayInfo(
    int userId,
    DateTime punchDate
)

Parameters

userId
Type: System..::.Int32
the unique id of the user
punchDate
Type: System..::.DateTime
The unique punch date

See Also

PunchDayInfo Class
PunchDayInfo Overload
OfficeClip.BusinessLayer.TE Namespace


PunchDayInfo Constructor (Int32, DateTime, PunchTimeInfo, PunchTimeInfo, PunchTimeInfo, PunchTimeInfo, Int32)

[image]

OfficeClip API Documentation
PunchDayInfo Constructor (Int32, DateTime, PunchTimeInfo, PunchTimeInfo, PunchTimeInfo, PunchTimeInfo, Int32)
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

Punch day information constructor

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchDayInfo(
    int userId,
    DateTime punchDate,
    PunchTimeInfo punchTime1,
    PunchTimeInfo punchTime2,
    PunchTimeInfo punchTime3,
    PunchTimeInfo punchTime4,
    int breakTime
)
Visual Basic (Declaration)
Public Sub New ( _
    userId As Integer, _
    punchDate As DateTime, _
    punchTime1 As PunchTimeInfo, _
    punchTime2 As PunchTimeInfo, _
    punchTime3 As PunchTimeInfo, _
    punchTime4 As PunchTimeInfo, _
    breakTime As Integer _
)
Visual C++
public:
PunchDayInfo(
    int userId,
    DateTime punchDate,
    PunchTimeInfo^ punchTime1,
    PunchTimeInfo^ punchTime2,
    PunchTimeInfo^ punchTime3,
    PunchTimeInfo^ punchTime4,
    int breakTime
)

Parameters

userId
Type: System..::.Int32
the unique id of the user
punchDate
Type: System..::.DateTime
the puch date
punchTime1
Type: OfficeClip.BusinessLayer.TE..::.PunchTimeInfo
The punch time of the first punch
punchTime2
Type: OfficeClip.BusinessLayer.TE..::.PunchTimeInfo
The punch time of the second punch
punchTime3
Type: OfficeClip.BusinessLayer.TE..::.PunchTimeInfo
The punch time of the third punch
punchTime4
Type: OfficeClip.BusinessLayer.TE..::.PunchTimeInfo
The punch time of the fourth punch
breakTime
Type: System..::.Int32
The break time

See Also

PunchDayInfo Class
PunchDayInfo Overload
OfficeClip.BusinessLayer.TE Namespace


PunchDayInfo Methods

[image] [image]

OfficeClip API Documentation
PunchDayInfo Methods
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PunchDayInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetTotalPunchedTime | The total punch time
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNotPunched | Checks if not punched at all
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetTotalPunchedTime Method

[image]

OfficeClip API Documentation
PunchDayInfo..::.GetTotalPunchedTime Method
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

The total punch time

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GetTotalPunchedTime()
Visual Basic (Declaration)
Public Function GetTotalPunchedTime As Integer
Visual C++
public:
int GetTotalPunchedTime()

Return Value

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsNotPunched Method

[image]

OfficeClip API Documentation
PunchDayInfo..::.IsNotPunched Method
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

Checks if not punched at all

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsNotPunched()
Visual Basic (Declaration)
Public Function IsNotPunched As Boolean
Visual C++
public:
bool IsNotPunched()

Return Value

True if not punched at all

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


PunchDayInfo Properties

[image] [image]

OfficeClip API Documentation
PunchDayInfo Properties
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PunchDayInfo type exposes the following properties.

Properties

 | Name | Description
Public property | BreakTime | The break time
Public property | PunchDate | The punch date
Public property | PunchTime1 | The punch time for the first punch
Public property | PunchTime2 | The punch time for the second punch
Public property | PunchTime3 | The punch time for the third punch
Public property | PunchTime4 | The punch time for the fourth punch
Public property | UserId | The unique if of the user

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


BreakTime Property

[image]

OfficeClip API Documentation
PunchDayInfo..::.BreakTime Property
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

The break time

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int BreakTime { get; set; }
Visual Basic (Declaration)
Public Property BreakTime As Integer
Visual C++
public:
property int BreakTime {
    int get ();
    void set (int value);
}

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


PunchDate Property

[image]

OfficeClip API Documentation
PunchDayInfo..::.PunchDate Property
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

The punch date

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime PunchDate { get; set; }
Visual Basic (Declaration)
Public Property PunchDate As DateTime
Visual C++
public:
property DateTime PunchDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


PunchTime1 Property

[image]

OfficeClip API Documentation
PunchDayInfo..::.PunchTime1 Property
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

The punch time for the first punch

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchTimeInfo PunchTime1 { get; set; }
Visual Basic (Declaration)
Public Property PunchTime1 As PunchTimeInfo
Visual C++
public:
property PunchTimeInfo^ PunchTime1 {
    PunchTimeInfo^ get ();
    void set (PunchTimeInfo^ value);
}

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


PunchTime2 Property

[image]

OfficeClip API Documentation
PunchDayInfo..::.PunchTime2 Property
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

The punch time for the second punch

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchTimeInfo PunchTime2 { get; set; }
Visual Basic (Declaration)
Public Property PunchTime2 As PunchTimeInfo
Visual C++
public:
property PunchTimeInfo^ PunchTime2 {
    PunchTimeInfo^ get ();
    void set (PunchTimeInfo^ value);
}

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


PunchTime3 Property

[image]

OfficeClip API Documentation
PunchDayInfo..::.PunchTime3 Property
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

The punch time for the third punch

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchTimeInfo PunchTime3 { get; set; }
Visual Basic (Declaration)
Public Property PunchTime3 As PunchTimeInfo
Visual C++
public:
property PunchTimeInfo^ PunchTime3 {
    PunchTimeInfo^ get ();
    void set (PunchTimeInfo^ value);
}

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


PunchTime4 Property

[image]

OfficeClip API Documentation
PunchDayInfo..::.PunchTime4 Property
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

The punch time for the fourth punch

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchTimeInfo PunchTime4 { get; set; }
Visual Basic (Declaration)
Public Property PunchTime4 As PunchTimeInfo
Visual C++
public:
property PunchTimeInfo^ PunchTime4 {
    PunchTimeInfo^ get ();
    void set (PunchTimeInfo^ value);
}

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


UserId Property

[image]

OfficeClip API Documentation
PunchDayInfo..::.UserId Property
PunchDayInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique if of the user

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

PunchDayInfo Class
OfficeClip.BusinessLayer.TE Namespace


PunchTimeInfo Class

[image]

OfficeClip API Documentation
PunchTimeInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Represents the group/Organization's menu information.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class PunchTimeInfo
Visual Basic (Declaration)
Public Class PunchTimeInfo
Visual C++
public ref class PunchTimeInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.PunchTimeInfo

See Also

PunchTimeInfo Members
OfficeClip.BusinessLayer.TE Namespace


PunchTimeInfo Members

[image] [image]

OfficeClip API Documentation
PunchTimeInfo Members
PunchTimeInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PunchTimeInfo type exposes the following members.

Constructors

 | Name | Description
Public method | PunchTimeInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Returns true if the current object and the argument are equal
Public method | IsNotPunched | Shows if not pucned on the same day at all
Public method | IsPunchedIn | Shows if punched in
Public method | IsPunchedOut | Shows if punched out
Public method | IsPunchError | Only happens if the punch in time is greater than the punch out time. Excludes the case when the out time is not punched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HourIn | The hour part of the time when punched in
Public property | HourOut | The hour part of the time when punched out
Public property | InTime | The time when punched in
Public property | MinuteIn | The minute part of the time when punched in
Public property | MinuteOut | The minute part of the time when punched out
Public property | OutTime | The time when punched out

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


PunchTimeInfo Constructor

[image] [image]

OfficeClip API Documentation
PunchTimeInfo Constructor
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PunchTimeInfo()()() | Punch Clock Information Constructor
Public method | PunchTimeInfo(Int32, Int32) | Punch Clock Information Constructor

See Also

PunchTimeInfo Class
PunchTimeInfo Members
OfficeClip.BusinessLayer.TE Namespace


PunchTimeInfo Constructor

[image]

OfficeClip API Documentation
PunchTimeInfo Constructor
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Punch Clock Information Constructor

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchTimeInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PunchTimeInfo()

See Also

PunchTimeInfo Class
PunchTimeInfo Overload
OfficeClip.BusinessLayer.TE Namespace


PunchTimeInfo Constructor (Int32, Int32)

[image]

OfficeClip API Documentation
PunchTimeInfo Constructor (Int32, Int32)
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Punch Clock Information Constructor

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public PunchTimeInfo(
    int inTime,
    int outTime
)
Visual Basic (Declaration)
Public Sub New ( _
    inTime As Integer, _
    outTime As Integer _
)
Visual C++
public:
PunchTimeInfo(
    int inTime,
    int outTime
)

Parameters

inTime
Type: System..::.Int32
outTime
Type: System..::.Int32

See Also

PunchTimeInfo Class
PunchTimeInfo Overload
OfficeClip.BusinessLayer.TE Namespace


PunchTimeInfo Methods

[image] [image]

OfficeClip API Documentation
PunchTimeInfo Methods
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PunchTimeInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Returns true if the current object and the argument are equal
Public method | IsNotPunched | Shows if not pucned on the same day at all
Public method | IsPunchedIn | Shows if punched in
Public method | IsPunchedOut | Shows if punched out
Public method | IsPunchError | Only happens if the punch in time is greater than the punch out time. Excludes the case when the out time is not punched.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsEqual Method

[image]

OfficeClip API Documentation
PunchTimeInfo..::.IsEqual Method
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns true if the current object and the argument are equal

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsEqual(
    PunchTimeInfo newPTI
)
Visual Basic (Declaration)
Public Function IsEqual ( _
    newPTI As PunchTimeInfo _
) As Boolean
Visual C++
public:
bool IsEqual(
    PunchTimeInfo^ newPTI
)

Parameters

newPTI
Type: OfficeClip.BusinessLayer.TE..::.PunchTimeInfo
Punch time information to compare with

Return Value

true if equal

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsNotPunched Method

[image]

OfficeClip API Documentation
PunchTimeInfo..::.IsNotPunched Method
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if not pucned on the same day at all

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsNotPunched()
Visual Basic (Declaration)
Public Function IsNotPunched As Boolean
Visual C++
public:
bool IsNotPunched()

Return Value

True if not pucned on the same day at all

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsPunchedIn Method

[image]

OfficeClip API Documentation
PunchTimeInfo..::.IsPunchedIn Method
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if punched in

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsPunchedIn()
Visual Basic (Declaration)
Public Function IsPunchedIn As Boolean
Visual C++
public:
bool IsPunchedIn()

Return Value

true if punched in

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsPunchedOut Method

[image]

OfficeClip API Documentation
PunchTimeInfo..::.IsPunchedOut Method
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if punched out

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsPunchedOut()
Visual Basic (Declaration)
Public Function IsPunchedOut As Boolean
Visual C++
public:
bool IsPunchedOut()

Return Value

true if punched out

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsPunchError Method

[image]

OfficeClip API Documentation
PunchTimeInfo..::.IsPunchError Method
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

Only happens if the punch in time is greater than the punch out time. Excludes the case when the out time is not punched.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsPunchError()
Visual Basic (Declaration)
Public Function IsPunchError As Boolean
Visual C++
public:
bool IsPunchError()

Return Value

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


PunchTimeInfo Properties

[image] [image]

OfficeClip API Documentation
PunchTimeInfo Properties
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The PunchTimeInfo type exposes the following properties.

Properties

 | Name | Description
Public property | HourIn | The hour part of the time when punched in
Public property | HourOut | The hour part of the time when punched out
Public property | InTime | The time when punched in
Public property | MinuteIn | The minute part of the time when punched in
Public property | MinuteOut | The minute part of the time when punched out
Public property | OutTime | The time when punched out

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


HourIn Property

[image]

OfficeClip API Documentation
PunchTimeInfo..::.HourIn Property
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The hour part of the time when punched in

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int HourIn { get; set; }
Visual Basic (Declaration)
Public Property HourIn As Integer
Visual C++
public:
property int HourIn {
    int get ();
    void set (int value);
}

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


HourOut Property

[image]

OfficeClip API Documentation
PunchTimeInfo..::.HourOut Property
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The hour part of the time when punched out

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int HourOut { get; set; }
Visual Basic (Declaration)
Public Property HourOut As Integer
Visual C++
public:
property int HourOut {
    int get ();
    void set (int value);
}

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


InTime Property

[image]

OfficeClip API Documentation
PunchTimeInfo..::.InTime Property
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time when punched in

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int InTime { get; set; }
Visual Basic (Declaration)
Public Property InTime As Integer
Visual C++
public:
property int InTime {
    int get ();
    void set (int value);
}

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


MinuteIn Property

[image]

OfficeClip API Documentation
PunchTimeInfo..::.MinuteIn Property
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The minute part of the time when punched in

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MinuteIn { get; set; }
Visual Basic (Declaration)
Public Property MinuteIn As Integer
Visual C++
public:
property int MinuteIn {
    int get ();
    void set (int value);
}

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


MinuteOut Property

[image]

OfficeClip API Documentation
PunchTimeInfo..::.MinuteOut Property
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The minute part of the time when punched out

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int MinuteOut { get; set; }
Visual Basic (Declaration)
Public Property MinuteOut As Integer
Visual C++
public:
property int MinuteOut {
    int get ();
    void set (int value);
}

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


OutTime Property

[image]

OfficeClip API Documentation
PunchTimeInfo..::.OutTime Property
PunchTimeInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time when punched out

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int OutTime { get; set; }
Visual Basic (Declaration)
Public Property OutTime As Integer
Visual C++
public:
property int OutTime {
    int get ();
    void set (int value);
}

See Also

PunchTimeInfo Class
OfficeClip.BusinessLayer.TE Namespace


ReimbursementPaymentInfo Class

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ReimbursementPaymentInfo
Visual Basic (Declaration)
Public Class ReimbursementPaymentInfo
Visual C++
public ref class ReimbursementPaymentInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.ReimbursementPaymentInfo

See Also

ReimbursementPaymentInfo Members
OfficeClip.BusinessLayer.TE Namespace


ReimbursementPaymentInfo Members

[image] [image]

OfficeClip API Documentation
ReimbursementPaymentInfo Members
ReimbursementPaymentInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ReimbursementPaymentInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ReimbursementPaymentInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Adjustment | The Adjustment Amount
Public property | AdjustmentDate | The Adjustment Date
Public property | AdjustmentNote | The Adjustment Notes
Public property | CashAdvance | The Cash Advance Amount
Public property | ExpenseId | The system generated unique identifier for the expense.
Public property | FromDate | The Expense's From Date
Public property | Payment | The Paid Amount
Public property | PaymentDate | The Payment Date
Public property | PaymentNote | The Payment Notes
Public property | ToDate | The Expense's To Date
Public property | TotalAmount | The Total Amount for the ExpenseSheet
Public property | TotalPaid | The Total Paid Amount for the ExpenseSheet
Public property | TotalReimbursed | The Reimbursed Amount for the ExpenseSheet

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


ReimbursementPaymentInfo Constructor

[image] [image]

OfficeClip API Documentation
ReimbursementPaymentInfo Constructor
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ReimbursementPaymentInfo()()() |
Public method | ReimbursementPaymentInfo(Int32, Single, Single, String, Single, String) | OverLoaded Constructor

See Also

ReimbursementPaymentInfo Class
ReimbursementPaymentInfo Members
OfficeClip.BusinessLayer.TE Namespace


ReimbursementPaymentInfo Constructor

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo Constructor
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReimbursementPaymentInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReimbursementPaymentInfo()

See Also

ReimbursementPaymentInfo Class
ReimbursementPaymentInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ReimbursementPaymentInfo Constructor (Int32, Single, Single, String, Single, String)

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo Constructor (Int32, Single, Single, String, Single, String)
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

OverLoaded Constructor

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ReimbursementPaymentInfo(
    int expenseId,
    float cashAdvance,
    float adjustment,
    string adjustmentNote,
    float payment,
    string paymentNote
)
Visual Basic (Declaration)
Public Sub New ( _
    expenseId As Integer, _
    cashAdvance As Single, _
    adjustment As Single, _
    adjustmentNote As String, _
    payment As Single, _
    paymentNote As String _
)
Visual C++
public:
ReimbursementPaymentInfo(
    int expenseId,
    float cashAdvance,
    float adjustment,
    String^ adjustmentNote,
    float payment,
    String^ paymentNote
)

Parameters

expenseId
Type: System..::.Int32
expenseId as int
cashAdvance
Type: System..::.Single
cashAdvance as float
adjustment
Type: System..::.Single
adjustment as float
adjustmentNote
Type: System..::.String
adjustmentNote as string
payment
Type: System..::.Single
payment as float
paymentNote
Type: System..::.String
paymentNote as string

See Also

ReimbursementPaymentInfo Class
ReimbursementPaymentInfo Overload
OfficeClip.BusinessLayer.TE Namespace


ReimbursementPaymentInfo Properties

[image] [image]

OfficeClip API Documentation
ReimbursementPaymentInfo Properties
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ReimbursementPaymentInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Adjustment | The Adjustment Amount
Public property | AdjustmentDate | The Adjustment Date
Public property | AdjustmentNote | The Adjustment Notes
Public property | CashAdvance | The Cash Advance Amount
Public property | ExpenseId | The system generated unique identifier for the expense.
Public property | FromDate | The Expense's From Date
Public property | Payment | The Paid Amount
Public property | PaymentDate | The Payment Date
Public property | PaymentNote | The Payment Notes
Public property | ToDate | The Expense's To Date
Public property | TotalAmount | The Total Amount for the ExpenseSheet
Public property | TotalPaid | The Total Paid Amount for the ExpenseSheet
Public property | TotalReimbursed | The Reimbursed Amount for the ExpenseSheet

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


Adjustment Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.Adjustment Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Adjustment Amount

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public float Adjustment { get; set; }
Visual Basic (Declaration)
Public Property Adjustment As Single
Visual C++
public:
property float Adjustment {
    float get ();
    void set (float value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


AdjustmentDate Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.AdjustmentDate Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Adjustment Date

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime AdjustmentDate { get; set; }
Visual Basic (Declaration)
Public Property AdjustmentDate As DateTime
Visual C++
public:
property DateTime AdjustmentDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


AdjustmentNote Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.AdjustmentNote Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Adjustment Notes

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AdjustmentNote { get; set; }
Visual Basic (Declaration)
Public Property AdjustmentNote As String
Visual C++
public:
property String^ AdjustmentNote {
    String^ get ();
    void set (String^ value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


CashAdvance Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.CashAdvance Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Cash Advance Amount

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public float CashAdvance { get; set; }
Visual Basic (Declaration)
Public Property CashAdvance As Single
Visual C++
public:
property float CashAdvance {
    float get ();
    void set (float value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExpenseId Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.ExpenseId Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the expense.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ExpenseId { get; set; }
Visual Basic (Declaration)
Public Property ExpenseId As Integer
Visual C++
public:
property int ExpenseId {
    int get ();
    void set (int value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


FromDate Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.FromDate Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Expense's From Date

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime FromDate { get; set; }
Visual Basic (Declaration)
Public Property FromDate As DateTime
Visual C++
public:
property DateTime FromDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


Payment Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.Payment Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Paid Amount

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public float Payment { get; set; }
Visual Basic (Declaration)
Public Property Payment As Single
Visual C++
public:
property float Payment {
    float get ();
    void set (float value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


PaymentDate Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.PaymentDate Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Payment Date

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime PaymentDate { get; set; }
Visual Basic (Declaration)
Public Property PaymentDate As DateTime
Visual C++
public:
property DateTime PaymentDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


PaymentNote Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.PaymentNote Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Payment Notes

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PaymentNote { get; set; }
Visual Basic (Declaration)
Public Property PaymentNote As String
Visual C++
public:
property String^ PaymentNote {
    String^ get ();
    void set (String^ value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


ToDate Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.ToDate Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Expense's To Date

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ToDate { get; set; }
Visual Basic (Declaration)
Public Property ToDate As DateTime
Visual C++
public:
property DateTime ToDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


TotalAmount Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.TotalAmount Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Total Amount for the ExpenseSheet

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public float TotalAmount { get; set; }
Visual Basic (Declaration)
Public Property TotalAmount As Single
Visual C++
public:
property float TotalAmount {
    float get ();
    void set (float value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


TotalPaid Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.TotalPaid Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Total Paid Amount for the ExpenseSheet

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public float TotalPaid { get; set; }
Visual Basic (Declaration)
Public Property TotalPaid As Single
Visual C++
public:
property float TotalPaid {
    float get ();
    void set (float value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


TotalReimbursed Property

[image]

OfficeClip API Documentation
ReimbursementPaymentInfo..::.TotalReimbursed Property
ReimbursementPaymentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Reimbursed Amount for the ExpenseSheet

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public float TotalReimbursed { get; set; }
Visual Basic (Declaration)
Public Property TotalReimbursed As Single
Visual C++
public:
property float TotalReimbursed {
    float get ();
    void set (float value);
}

See Also

ReimbursementPaymentInfo Class
OfficeClip.BusinessLayer.TE Namespace


RuleInfo Class

[image]

OfficeClip API Documentation
RuleInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Represents the group/Organization's menu information.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class RuleInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class RuleInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class RuleInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.RuleInfo

See Also

RuleInfo Members
OfficeClip.BusinessLayer.TE Namespace


RuleInfo Members

[image] [image]

OfficeClip API Documentation
RuleInfo Members
RuleInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RuleInfo type exposes the following members.

Constructors

 | Name | Description
Public method | RuleInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo object with data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InputArgument1 | The first input argument
Public property | InputArgument2 | The second input argument
Public property | InputArgument3 | The third input argument
Public property | InputArgument4 | The fourth input argument
Public property | InputArgument5 | The fifth input argument
Public property | IsCustom | Is this a custom rule
Public property | OutputArgument1 | The first output argument
Public property | OutputArgument2 | The second output argument
Public property | OutputArgument3 | The third output argument
Public property | OutputArgument4 | The fourth output argument
Public property | RuleId | The unique id of the rule
Public property | RuleIfDescription | The description of the if part of the rule
Public property | RuleThenDescription | The description of the then part of the description
Public property | RuleType | The type of the rule

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


RuleInfo Constructor

[image] [image]

OfficeClip API Documentation
RuleInfo Constructor
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | RuleInfo(Int32, String, String, Boolean, String, String, String, String, String, String, String, String, String, String) | The rule information constructor
Public method | RuleInfo(SerializationInfo, StreamingContext) | The constructor which implements the ISerializable interface.

See Also

RuleInfo Class
RuleInfo Members
OfficeClip.BusinessLayer.TE Namespace


RuleInfo Constructor (Int32, String, String, Boolean, String, String, String, String, String, String, String, String, String, String)

[image]

OfficeClip API Documentation
RuleInfo Constructor (Int32, String, String, Boolean, String, String, String, String, String, String, String, String, String, String)
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The rule information constructor

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RuleInfo(
    int ruleId,
    string ruleIfDescription,
    string ruleThenDescription,
    bool isCustom,
    string ruleType,
    string inputArgument1,
    string inputArgument2,
    string inputArgument3,
    string inputArgument4,
    string inputArgument5,
    string outputArgument1,
    string outputArgument2,
    string outputArgument3,
    string outputArgument4
)
Visual Basic (Declaration)
Public Sub New ( _
    ruleId As Integer, _
    ruleIfDescription As String, _
    ruleThenDescription As String, _
    isCustom As Boolean, _
    ruleType As String, _
    inputArgument1 As String, _
    inputArgument2 As String, _
    inputArgument3 As String, _
    inputArgument4 As String, _
    inputArgument5 As String, _
    outputArgument1 As String, _
    outputArgument2 As String, _
    outputArgument3 As String, _
    outputArgument4 As String _
)
Visual C++
public:
RuleInfo(
    int ruleId,
    String^ ruleIfDescription,
    String^ ruleThenDescription,
    bool isCustom,
    String^ ruleType,
    String^ inputArgument1,
    String^ inputArgument2,
    String^ inputArgument3,
    String^ inputArgument4,
    String^ inputArgument5,
    String^ outputArgument1,
    String^ outputArgument2,
    String^ outputArgument3,
    String^ outputArgument4
)

Parameters

ruleId
Type: System..::.Int32
The unique id of the rule
ruleIfDescription
Type: System..::.String
The description of the if condition
ruleThenDescription
Type: System..::.String
The description of the then condition
isCustom
Type: System..::.Boolean
determines if the rule is a custom rule
ruleType
Type: System..::.String
The type of the rule
inputArgument1
Type: System..::.String
The first input argument
inputArgument2
Type: System..::.String
The second input argument
inputArgument3
Type: System..::.String
The third input argument
inputArgument4
Type: System..::.String
the fourth input argument
inputArgument5
Type: System..::.String
The fifth input argument
outputArgument1
Type: System..::.String
The first output argument
outputArgument2
Type: System..::.String
The second output argument
outputArgument3
Type: System..::.String
The third output argument
outputArgument4
Type: System..::.String
The fourth output argument

See Also

RuleInfo Class
RuleInfo Overload
OfficeClip.BusinessLayer.TE Namespace


RuleInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
RuleInfo Constructor (SerializationInfo, StreamingContext)
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor which implements the ISerializable interface.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public RuleInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
RuleInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The object which contains the serialization info.
context
Type: System.Runtime.Serialization..::.StreamingContext
The source serialized stream from where the object values are read.

See Also

RuleInfo Class
RuleInfo Overload
OfficeClip.BusinessLayer.TE Namespace


RuleInfo Methods

[image] [image]

OfficeClip API Documentation
RuleInfo Methods
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The RuleInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo object with data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
RuleInfo..::.GetObjectData Method
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

Populates a SerializationInfo object with data needed to serialize the target object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.Serialization..::.StreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


RuleInfo Properties

[image] [image]

OfficeClip API Documentation
RuleInfo Properties
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The RuleInfo type exposes the following properties.

Properties

 | Name | Description
Public property | InputArgument1 | The first input argument
Public property | InputArgument2 | The second input argument
Public property | InputArgument3 | The third input argument
Public property | InputArgument4 | The fourth input argument
Public property | InputArgument5 | The fifth input argument
Public property | IsCustom | Is this a custom rule
Public property | OutputArgument1 | The first output argument
Public property | OutputArgument2 | The second output argument
Public property | OutputArgument3 | The third output argument
Public property | OutputArgument4 | The fourth output argument
Public property | RuleId | The unique id of the rule
Public property | RuleIfDescription | The description of the if part of the rule
Public property | RuleThenDescription | The description of the then part of the description
Public property | RuleType | The type of the rule

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


InputArgument1 Property

[image]

OfficeClip API Documentation
RuleInfo..::.InputArgument1 Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first input argument

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string InputArgument1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property InputArgument1 As String
Visual C++
public:
property String^ InputArgument1 {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


InputArgument2 Property

[image]

OfficeClip API Documentation
RuleInfo..::.InputArgument2 Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second input argument

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string InputArgument2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property InputArgument2 As String
Visual C++
public:
property String^ InputArgument2 {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


InputArgument3 Property

[image]

OfficeClip API Documentation
RuleInfo..::.InputArgument3 Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The third input argument

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string InputArgument3 { get; }
Visual Basic (Declaration)
Public ReadOnly Property InputArgument3 As String
Visual C++
public:
property String^ InputArgument3 {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


InputArgument4 Property

[image]

OfficeClip API Documentation
RuleInfo..::.InputArgument4 Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The fourth input argument

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string InputArgument4 { get; }
Visual Basic (Declaration)
Public ReadOnly Property InputArgument4 As String
Visual C++
public:
property String^ InputArgument4 {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


InputArgument5 Property

[image]

OfficeClip API Documentation
RuleInfo..::.InputArgument5 Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The fifth input argument

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string InputArgument5 { get; }
Visual Basic (Declaration)
Public ReadOnly Property InputArgument5 As String
Visual C++
public:
property String^ InputArgument5 {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsCustom Property

[image]

OfficeClip API Documentation
RuleInfo..::.IsCustom Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

Is this a custom rule

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsCustom { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCustom As Boolean
Visual C++
public:
property bool IsCustom {
    bool get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


OutputArgument1 Property

[image]

OfficeClip API Documentation
RuleInfo..::.OutputArgument1 Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first output argument

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string OutputArgument1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property OutputArgument1 As String
Visual C++
public:
property String^ OutputArgument1 {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


OutputArgument2 Property

[image]

OfficeClip API Documentation
RuleInfo..::.OutputArgument2 Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The second output argument

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string OutputArgument2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property OutputArgument2 As String
Visual C++
public:
property String^ OutputArgument2 {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


OutputArgument3 Property

[image]

OfficeClip API Documentation
RuleInfo..::.OutputArgument3 Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The third output argument

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string OutputArgument3 { get; }
Visual Basic (Declaration)
Public ReadOnly Property OutputArgument3 As String
Visual C++
public:
property String^ OutputArgument3 {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


OutputArgument4 Property

[image]

OfficeClip API Documentation
RuleInfo..::.OutputArgument4 Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The fourth output argument

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string OutputArgument4 { get; }
Visual Basic (Declaration)
Public ReadOnly Property OutputArgument4 As String
Visual C++
public:
property String^ OutputArgument4 {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


RuleId Property

[image]

OfficeClip API Documentation
RuleInfo..::.RuleId Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the rule

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int RuleId { get; }
Visual Basic (Declaration)
Public ReadOnly Property RuleId As Integer
Visual C++
public:
property int RuleId {
    int get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


RuleIfDescription Property

[image]

OfficeClip API Documentation
RuleInfo..::.RuleIfDescription Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The description of the if part of the rule

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RuleIfDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property RuleIfDescription As String
Visual C++
public:
property String^ RuleIfDescription {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


RuleThenDescription Property

[image]

OfficeClip API Documentation
RuleInfo..::.RuleThenDescription Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The description of the then part of the description

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RuleThenDescription { get; }
Visual Basic (Declaration)
Public ReadOnly Property RuleThenDescription As String
Visual C++
public:
property String^ RuleThenDescription {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


RuleType Property

[image]

OfficeClip API Documentation
RuleInfo..::.RuleType Property
RuleInfo Class See Also

[This is preliminary documentation and is subject to change.]

The type of the rule

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RuleType { get; }
Visual Basic (Declaration)
Public ReadOnly Property RuleType As String
Visual C++
public:
property String^ RuleType {
    String^ get ();
}

See Also

RuleInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetCommentInfo Class

[image]

OfficeClip API Documentation
TimesheetCommentInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides information for timesheet Comments.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class TimesheetCommentInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class TimesheetCommentInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class TimesheetCommentInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.TimesheetCommentInfo

See Also

TimesheetCommentInfo Members
OfficeClip.BusinessLayer.TE Namespace


TimesheetCommentInfo Members

[image] [image]

OfficeClip API Documentation
TimesheetCommentInfo Members
TimesheetCommentInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TimesheetCommentInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TimesheetCommentInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comment | The Comment for the timesheet.
Public property | CommentDate | The date when the Comment is created for the timesheet.
Public property | CommentId | The identifier for the Comment.
Public property | TimesheetId | The identifier for the timesheet.
Public property | UserId | The identifier for the user who created the timesheet.
Public property | UserName | The name of the user who created the timesheet.

See Also

TimesheetCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetCommentInfo Constructor

[image] [image]

OfficeClip API Documentation
TimesheetCommentInfo Constructor
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TimesheetCommentInfo()()() | The default constructor.
Public method | TimesheetCommentInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

TimesheetCommentInfo Class
TimesheetCommentInfo Members
OfficeClip.BusinessLayer.TE Namespace


TimesheetCommentInfo Constructor

[image]

OfficeClip API Documentation
TimesheetCommentInfo Constructor
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetCommentInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimesheetCommentInfo()

See Also

TimesheetCommentInfo Class
TimesheetCommentInfo Overload
OfficeClip.BusinessLayer.TE Namespace


TimesheetCommentInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
TimesheetCommentInfo Constructor (SerializationInfo, StreamingContext)
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetCommentInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
TimesheetCommentInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

TimesheetCommentInfo Class
TimesheetCommentInfo Overload
OfficeClip.BusinessLayer.TE Namespace


TimesheetCommentInfo Methods

[image] [image]

OfficeClip API Documentation
TimesheetCommentInfo Methods
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetCommentInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimesheetCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
TimesheetCommentInfo..::.GetObjectData Method
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

TimesheetCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetCommentInfo Properties

[image] [image]

OfficeClip API Documentation
TimesheetCommentInfo Properties
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetCommentInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Comment | The Comment for the timesheet.
Public property | CommentDate | The date when the Comment is created for the timesheet.
Public property | CommentId | The identifier for the Comment.
Public property | TimesheetId | The identifier for the timesheet.
Public property | UserId | The identifier for the user who created the timesheet.
Public property | UserName | The name of the user who created the timesheet.

See Also

TimesheetCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


Comment Property

[image]

OfficeClip API Documentation
TimesheetCommentInfo..::.Comment Property
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Comment for the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Comment { get; set; }
Visual Basic (Declaration)
Public Property Comment As String
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


CommentDate Property

[image]

OfficeClip API Documentation
TimesheetCommentInfo..::.CommentDate Property
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date when the Comment is created for the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CommentDate { get; set; }
Visual Basic (Declaration)
Public Property CommentDate As DateTime
Visual C++
public:
property DateTime CommentDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

TimesheetCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


CommentId Property

[image]

OfficeClip API Documentation
TimesheetCommentInfo..::.CommentId Property
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the Comment.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CommentId { get; set; }
Visual Basic (Declaration)
Public Property CommentId As Integer
Visual C++
public:
property int CommentId {
    int get ();
    void set (int value);
}

See Also

TimesheetCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetId Property

[image]

OfficeClip API Documentation
TimesheetCommentInfo..::.TimesheetId Property
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TimesheetId { get; set; }
Visual Basic (Declaration)
Public Property TimesheetId As Integer
Visual C++
public:
property int TimesheetId {
    int get ();
    void set (int value);
}

See Also

TimesheetCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


UserId Property

[image]

OfficeClip API Documentation
TimesheetCommentInfo..::.UserId Property
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the user who created the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

TimesheetCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


UserName Property

[image]

OfficeClip API Documentation
TimesheetCommentInfo..::.UserName Property
TimesheetCommentInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user who created the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetCommentInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetDetailInfo Class

[image]

OfficeClip API Documentation
TimesheetDetailInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties for the timesheet detail object.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class TimesheetDetailInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class TimesheetDetailInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class TimesheetDetailInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.TimesheetDetailInfo

See Also

TimesheetDetailInfo Members
OfficeClip.BusinessLayer.TE Namespace


TimesheetDetailInfo Members

[image] [image]

OfficeClip API Documentation
TimesheetDetailInfo Members
TimesheetDetailInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TimesheetDetailInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TimesheetDetailInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The account identifier for the timesheet detial.
Public property | AccountName | The account name for the timesheet detail.
Public property | CreatedByTimestamp | The Timestamp of the timesheet detail.
Public property | CreatedByUserId | The identifier of the user who created the task.
Public property | Description | The Description for the task.
Public property | IsBillable | Shows if the task associated with the timesheet detail is billable. Valid values are "Y" and "N"
Public property | ModifiedByTimestamp | the Timestamp of the last modification of the timesheet detail.
Public property | ModifiedByUserId | The identifier fot the user who last modified the timesheet detail.
Public property | PayrollCategoryId | The payroll Category id for the task.
Public property | PayrollCode | The payroll Code for the task.
Public property | ProjectId | The identifier for the Project for the timesheet detail.
Public property | ProjectName | The name of the Project for the timesheet detail.
Public property | SerialNumber | The serial number for the task.
Public property | TaskCode | The code for the task.
Public property | TaskDate | The task date for the timesheet detail.
Public property | TaskId | The task identifier
Public property | TaskName | The name of the task.
Public property | TimeDuration | The time duration for the task.
Public property | TimesheetDetailId | The identifier for the timesheet detail.
Public property | TimesheetId | The system generated identifier for the timesheet.

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetDetailInfo Constructor

[image] [image]

OfficeClip API Documentation
TimesheetDetailInfo Constructor
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TimesheetDetailInfo()()() | The default constructor.
Public method | TimesheetDetailInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

TimesheetDetailInfo Class
TimesheetDetailInfo Members
OfficeClip.BusinessLayer.TE Namespace


TimesheetDetailInfo Constructor

[image]

OfficeClip API Documentation
TimesheetDetailInfo Constructor
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetDetailInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimesheetDetailInfo()

See Also

TimesheetDetailInfo Class
TimesheetDetailInfo Overload
OfficeClip.BusinessLayer.TE Namespace


TimesheetDetailInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
TimesheetDetailInfo Constructor (SerializationInfo, StreamingContext)
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetDetailInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
TimesheetDetailInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

TimesheetDetailInfo Class
TimesheetDetailInfo Overload
OfficeClip.BusinessLayer.TE Namespace


TimesheetDetailInfo Methods

[image] [image]

OfficeClip API Documentation
TimesheetDetailInfo Methods
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetDetailInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.GetObjectData Method
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetDetailInfo Properties

[image] [image]

OfficeClip API Documentation
TimesheetDetailInfo Properties
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetDetailInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The account identifier for the timesheet detial.
Public property | AccountName | The account name for the timesheet detail.
Public property | CreatedByTimestamp | The Timestamp of the timesheet detail.
Public property | CreatedByUserId | The identifier of the user who created the task.
Public property | Description | The Description for the task.
Public property | IsBillable | Shows if the task associated with the timesheet detail is billable. Valid values are "Y" and "N"
Public property | ModifiedByTimestamp | the Timestamp of the last modification of the timesheet detail.
Public property | ModifiedByUserId | The identifier fot the user who last modified the timesheet detail.
Public property | PayrollCategoryId | The payroll Category id for the task.
Public property | PayrollCode | The payroll Code for the task.
Public property | ProjectId | The identifier for the Project for the timesheet detail.
Public property | ProjectName | The name of the Project for the timesheet detail.
Public property | SerialNumber | The serial number for the task.
Public property | TaskCode | The code for the task.
Public property | TaskDate | The task date for the timesheet detail.
Public property | TaskId | The task identifier
Public property | TaskName | The name of the task.
Public property | TimeDuration | The time duration for the task.
Public property | TimesheetDetailId | The identifier for the timesheet detail.
Public property | TimesheetId | The system generated identifier for the timesheet.

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


AccountId Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.AccountId Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The account identifier for the timesheet detial.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AccountId { get; set; }
Visual Basic (Declaration)
Public Property AccountId As Integer
Visual C++
public:
property int AccountId {
    int get ();
    void set (int value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


AccountName Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.AccountName Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The account name for the timesheet detail.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AccountName { get; set; }
Visual Basic (Declaration)
Public Property AccountName As String
Visual C++
public:
property String^ AccountName {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


CreatedByTimestamp Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.CreatedByTimestamp Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp of the timesheet detail.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedByTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedByTimestamp As DateTime
Visual C++
public:
property DateTime CreatedByTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


CreatedByUserId Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.CreatedByUserId Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier of the user who created the task.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedByUserId { get; set; }
Visual Basic (Declaration)
Public Property CreatedByUserId As Integer
Visual C++
public:
property int CreatedByUserId {
    int get ();
    void set (int value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


Description Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.Description Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Description for the task.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsBillable Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.IsBillable Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the task associated with the timesheet detail is billable. Valid values are "Y" and "N"

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsBillable { get; set; }
Visual Basic (Declaration)
Public Property IsBillable As String
Visual C++
public:
property String^ IsBillable {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ModifiedByTimestamp Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.ModifiedByTimestamp Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

the Timestamp of the last modification of the timesheet detail.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ModifiedByTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ModifiedByTimestamp As DateTime
Visual C++
public:
property DateTime ModifiedByTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ModifiedByUserId Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.ModifiedByUserId Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier fot the user who last modified the timesheet detail.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ModifiedByUserId { get; set; }
Visual Basic (Declaration)
Public Property ModifiedByUserId As Integer
Visual C++
public:
property int ModifiedByUserId {
    int get ();
    void set (int value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


PayrollCategoryId Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.PayrollCategoryId Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The payroll Category id for the task.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int PayrollCategoryId { get; set; }
Visual Basic (Declaration)
Public Property PayrollCategoryId As Integer
Visual C++
public:
property int PayrollCategoryId {
    int get ();
    void set (int value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


PayrollCode Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.PayrollCode Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The payroll Code for the task.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PayrollCode { get; set; }
Visual Basic (Declaration)
Public Property PayrollCode As String
Visual C++
public:
property String^ PayrollCode {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ProjectId Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.ProjectId Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the Project for the timesheet detail.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ProjectId { get; set; }
Visual Basic (Declaration)
Public Property ProjectId As Integer
Visual C++
public:
property int ProjectId {
    int get ();
    void set (int value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


ProjectName Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.ProjectName Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the Project for the timesheet detail.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProjectName { get; set; }
Visual Basic (Declaration)
Public Property ProjectName As String
Visual C++
public:
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


SerialNumber Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.SerialNumber Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The serial number for the task.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SerialNumber { get; set; }
Visual Basic (Declaration)
Public Property SerialNumber As Integer
Visual C++
public:
property int SerialNumber {
    int get ();
    void set (int value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


TaskCode Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.TaskCode Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The code for the task.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TaskCode { get; set; }
Visual Basic (Declaration)
Public Property TaskCode As String
Visual C++
public:
property String^ TaskCode {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


TaskDate Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.TaskDate Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The task date for the timesheet detail.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime TaskDate { get; set; }
Visual Basic (Declaration)
Public Property TaskDate As DateTime
Visual C++
public:
property DateTime TaskDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


TaskId Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.TaskId Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The task identifier

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TaskId { get; set; }
Visual Basic (Declaration)
Public Property TaskId As Integer
Visual C++
public:
property int TaskId {
    int get ();
    void set (int value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


TaskName Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.TaskName Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the task.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TaskName { get; set; }
Visual Basic (Declaration)
Public Property TaskName As String
Visual C++
public:
property String^ TaskName {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimeDuration Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.TimeDuration Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time duration for the task.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double TimeDuration { get; set; }
Visual Basic (Declaration)
Public Property TimeDuration As Double
Visual C++
public:
property double TimeDuration {
    double get ();
    void set (double value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetDetailId Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.TimesheetDetailId Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the timesheet detail.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TimesheetDetailId { get; set; }
Visual Basic (Declaration)
Public Property TimesheetDetailId As Integer
Visual C++
public:
property int TimesheetDetailId {
    int get ();
    void set (int value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetId Property

[image]

OfficeClip API Documentation
TimesheetDetailInfo..::.TimesheetId Property
TimesheetDetailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated identifier for the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TimesheetId { get; set; }
Visual Basic (Declaration)
Public Property TimesheetId As Integer
Visual C++
public:
property int TimesheetId {
    int get ();
    void set (int value);
}

See Also

TimesheetDetailInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetInfo Class

[image]

OfficeClip API Documentation
TimesheetInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides the methods and properties to access the timesheet information.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class TimesheetInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class TimesheetInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class TimesheetInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.TimesheetInfo

See Also

TimesheetInfo Members
OfficeClip.BusinessLayer.TE Namespace


TimesheetInfo Members

[image] [image]

OfficeClip API Documentation
TimesheetInfo Members
TimesheetInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TimesheetInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TimesheetInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccountAndProjectName | Get the Account and Project name (separated by a "/" character) of a particular row of the timesheet.
Public method | GetAccountName | GEts the Customer name for a particular row in the timesheet.
Public method | GetBillableTimeDuration | GEt the total billable time duration of the timesheet.
Public method | GetEditableComments | Gets the editable Comment of the timesheet for a particular user.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNonBillableTimeDuration | Get the total non-billable duration of the timesheet.
Public method | GetNonEditableComments | Gets the non-editable Comment of the timesheet for a particular user.
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetPayrollCode |
Public method | GetProjectName | Gets the Project name of a particular row of the timesheet.
Public method | GetRow | Overloaded.
Public method | GetRows | Gets the number of rows in the timesheet.
Public method | GetRowTotal | Get the total time for a row of the timesheet.
Public method | GetSerializedTimesheetDetails | Gets the serialized timesheet detail in a String.
Public method | GetTaskCodeAndName | Gets the task name and code (separated by a "/") of a particular row of the timesheet.
Public method | GetTaskName | Gets the task name for the row
Public method | GetTimeDuration | Gets the time duration for a cell on the timesheet.
Public method | GetTimeDurationTotal | Gets the total time duration for the timesheet.
Public method | getTimesheetDetail | Gets the timesheet detail for a cell on the timesheet.
Public method | GetTimesheetDuration | Gets the duration of a particular cell on the timesheet.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSV | Converts the timesheet to its csv format.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreatedTimestamp | The Timestamp for the timesheet creation.
Public property | DocIdList | A comma separated String of the document identifiers for all documents that are attached to this timesheet.
Public property | ExportedTimestamp | The time when this timesheet was exported.
Public property | FirstName | The first name
Public property | FromDate | The first date of the timesheet.
Public property | GroupId | the identifier for the group.
Public property | GroupName | The group name of the group that owns the timesheet.
Public property | IsExported | Shows if the timesheet is exported. Valid values are "Y" (means exported) and "N" (not exported).
Public property | LastName | The last name
Public property | NumLines | Number of rows in the timesheet.
Public property | RemDocIdList | A comma separated String of the document identifiers for all documents that are removed from this timesheet.
Public property | TimesheetComments | The list of Comments on this timesheet.
Public property | TimesheetDetails | The list of all the timesheet details on this timesheet.
Public property | TimesheetId | The system generated identifier for the timesheet.
Public property | ToDate | The last date of the timesheet.
Public property | UserId | The identifier for the user that owns the timesheet.
Public property | UserName | The name of the user that owns the timesheet.
Public property | WorkflowHistory | The list of workflow history for this timesheet.
Public property | WorkflowTypeId | Get the workflow type id corresponding to this particular timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetInfo Constructor

[image] [image]

OfficeClip API Documentation
TimesheetInfo Constructor
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TimesheetInfo()()() | The default constructor.
Public method | TimesheetInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

TimesheetInfo Class
TimesheetInfo Members
OfficeClip.BusinessLayer.TE Namespace


TimesheetInfo Constructor

[image]

OfficeClip API Documentation
TimesheetInfo Constructor
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimesheetInfo()

See Also

TimesheetInfo Class
TimesheetInfo Overload
OfficeClip.BusinessLayer.TE Namespace


TimesheetInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
TimesheetInfo Constructor (SerializationInfo, StreamingContext)
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
TimesheetInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

TimesheetInfo Class
TimesheetInfo Overload
OfficeClip.BusinessLayer.TE Namespace


TimesheetInfo Methods

[image] [image]

OfficeClip API Documentation
TimesheetInfo Methods
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccountAndProjectName | Get the Account and Project name (separated by a "/" character) of a particular row of the timesheet.
Public method | GetAccountName | GEts the Customer name for a particular row in the timesheet.
Public method | GetBillableTimeDuration | GEt the total billable time duration of the timesheet.
Public method | GetEditableComments | Gets the editable Comment of the timesheet for a particular user.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNonBillableTimeDuration | Get the total non-billable duration of the timesheet.
Public method | GetNonEditableComments | Gets the non-editable Comment of the timesheet for a particular user.
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetPayrollCode |
Public method | GetProjectName | Gets the Project name of a particular row of the timesheet.
Public method | GetRow | Overloaded.
Public method | GetRows | Gets the number of rows in the timesheet.
Public method | GetRowTotal | Get the total time for a row of the timesheet.
Public method | GetSerializedTimesheetDetails | Gets the serialized timesheet detail in a String.
Public method | GetTaskCodeAndName | Gets the task name and code (separated by a "/") of a particular row of the timesheet.
Public method | GetTaskName | Gets the task name for the row
Public method | GetTimeDuration | Gets the time duration for a cell on the timesheet.
Public method | GetTimeDurationTotal | Gets the total time duration for the timesheet.
Public method | getTimesheetDetail | Gets the timesheet detail for a cell on the timesheet.
Public method | GetTimesheetDuration | Gets the duration of a particular cell on the timesheet.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToCSV | Converts the timesheet to its csv format.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetAccountAndProjectName Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetAccountAndProjectName Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Get the Account and Project name (separated by a "/" character) of a particular row of the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetAccountAndProjectName(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetAccountAndProjectName ( _
    rowNumber As Integer _
) As String
Visual C++
public:
String^ GetAccountAndProjectName(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number of the timesheet.

Return Value

The Customer and Project name (separated by a "/" character) of the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetAccountName Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetAccountName Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

GEts the Customer name for a particular row in the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetAccountName(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetAccountName ( _
    rowNumber As Integer _
) As String
Visual C++
public:
String^ GetAccountName(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number of the timesheet.

Return Value

The Customer name on the row of the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetBillableTimeDuration Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetBillableTimeDuration Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

GEt the total billable time duration of the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetBillableTimeDuration()
Visual Basic (Declaration)
Public Function GetBillableTimeDuration As Double
Visual C++
public:
double GetBillableTimeDuration()

Return Value

The total billable duration of the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetEditableComments Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetEditableComments Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the editable Comment of the timesheet for a particular user.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetEditableComments(
    int userId,
    bool isDCAA
)
Visual Basic (Declaration)
Public Function GetEditableComments ( _
    userId As Integer, _
    isDCAA As Boolean _
) As String
Visual C++
public:
String^ GetEditableComments(
    int userId,
    bool isDCAA
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
isDCAA
Type: System..::.Boolean
True if DCAA tracking is set.

Return Value

The editable Comment of the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetNonBillableTimeDuration Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetNonBillableTimeDuration Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Get the total non-billable duration of the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetNonBillableTimeDuration()
Visual Basic (Declaration)
Public Function GetNonBillableTimeDuration As Double
Visual C++
public:
double GetNonBillableTimeDuration()

Return Value

the total non-billable duration of the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetNonEditableComments Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetNonEditableComments Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the non-editable Comment of the timesheet for a particular user.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetNonEditableComments(
    int userId,
    bool isDCAA
)
Visual Basic (Declaration)
Public Function GetNonEditableComments ( _
    userId As Integer, _
    isDCAA As Boolean _
) As ArrayList
Visual C++
public:
ArrayList^ GetNonEditableComments(
    int userId,
    bool isDCAA
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
isDCAA
Type: System..::.Boolean
True if DCAA tracking is set.

Return Value

The non-editable Comment of the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetObjectData Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetPayrollCode Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetPayrollCode Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetPayrollCode(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetPayrollCode ( _
    rowNumber As Integer _
) As String
Visual C++
public:
String^ GetPayrollCode(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetProjectName Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetProjectName Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Project name of a particular row of the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetProjectName(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetProjectName ( _
    rowNumber As Integer _
) As String
Visual C++
public:
String^ GetProjectName(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number of the timesheet.

Return Value

The Project name of the row of the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetRow Method

[image] [image]

OfficeClip API Documentation
TimesheetInfo..::.GetRow Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetRow(Int32) | Gets the row of the timesheet information
Public method | GetRow(Int32, BusinessConstants..::.TimesheetPeriod) | Get an ArrayList of timesheet detail for a particular row.

See Also

TimesheetInfo Class
TimesheetInfo Members
OfficeClip.BusinessLayer.TE Namespace


GetRow Method (Int32)

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetRow Method (Int32)
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the row of the timesheet information

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetRow(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetRow ( _
    rowNumber As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetRow(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number

Return Value

The arraylist of the row information

See Also

TimesheetInfo Class
GetRow Overload
OfficeClip.BusinessLayer.TE Namespace


GetRow Method (Int32, BusinessConstants.TimesheetPeriod)

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetRow Method (Int32, BusinessConstants..::.TimesheetPeriod)
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Get an ArrayList of timesheet detail for a particular row.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetRow(
    int rowNumber,
    BusinessConstants..::.TimesheetPeriod period
)
Visual Basic (Declaration)
Public Function GetRow ( _
    rowNumber As Integer, _
    period As BusinessConstants..::.TimesheetPeriod _
) As ArrayList
Visual C++
public:
ArrayList^ GetRow(
    int rowNumber,
    BusinessConstants..::.TimesheetPeriod period
)

Parameters

rowNumber
Type: System..::.Int32
the row number of the timesheet.
period
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TimesheetPeriod
the period of the timesheet (weekly , biweekly etc.)

Return Value

The list of timesheet detail for the row.

See Also

TimesheetInfo Class
GetRow Overload
OfficeClip.BusinessLayer.TE Namespace


GetRows Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetRows Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the number of rows in the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetRows()
Visual Basic (Declaration)
Public Function GetRows As ArrayList
Visual C++
public:
ArrayList^ GetRows()

Return Value

The number of rows in the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetRowTotal Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetRowTotal Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Get the total time for a row of the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetRowTotal(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetRowTotal ( _
    rowNumber As Integer _
) As Double
Visual C++
public:
double GetRowTotal(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
the row number of the timesheet.

Return Value

The total time for the row.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetSerializedTimesheetDetails Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetSerializedTimesheetDetails Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the serialized timesheet detail in a String.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetSerializedTimesheetDetails(
    int rowNumber,
    int columnNumber
)
Visual Basic (Declaration)
Public Function GetSerializedTimesheetDetails ( _
    rowNumber As Integer, _
    columnNumber As Integer _
) As String
Visual C++
public:
String^ GetSerializedTimesheetDetails(
    int rowNumber,
    int columnNumber
)

Parameters

rowNumber
Type: System..::.Int32
The task row of the timesheet.
columnNumber
Type: System..::.Int32
The date column of the timesheet.

Return Value

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetTaskCodeAndName Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetTaskCodeAndName Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the task name and code (separated by a "/") of a particular row of the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetTaskCodeAndName(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetTaskCodeAndName ( _
    rowNumber As Integer _
) As String
Visual C++
public:
String^ GetTaskCodeAndName(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number of the timesheet.

Return Value

The task name and code (separated by a "/") of the row of the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetTaskName Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetTaskName Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the task name for the row

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetTaskName(
    int rowNumber
)
Visual Basic (Declaration)
Public Function GetTaskName ( _
    rowNumber As Integer _
) As String
Visual C++
public:
String^ GetTaskName(
    int rowNumber
)

Parameters

rowNumber
Type: System..::.Int32
The row number

Return Value

The task name

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetTimeDuration Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetTimeDuration Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the time duration for a cell on the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetTimeDuration(
    int rowNumber,
    int columnNumber
)
Visual Basic (Declaration)
Public Function GetTimeDuration ( _
    rowNumber As Integer, _
    columnNumber As Integer _
) As Double
Visual C++
public:
double GetTimeDuration(
    int rowNumber,
    int columnNumber
)

Parameters

rowNumber
Type: System..::.Int32
The task row of the timesheet.
columnNumber
Type: System..::.Int32
The date column of the timesheet.

Return Value

The time duration of the cell on the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetTimeDurationTotal Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetTimeDurationTotal Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the total time duration for the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetTimeDurationTotal()
Visual Basic (Declaration)
Public Function GetTimeDurationTotal As Double
Visual C++
public:
double GetTimeDurationTotal()

Return Value

the totoal timeduration of the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


getTimesheetDetail Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.getTimesheetDetail Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the timesheet detail for a cell on the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetDetailInfo getTimesheetDetail(
    int rowNumber,
    int columnNumber
)
Visual Basic (Declaration)
Public Function getTimesheetDetail ( _
    rowNumber As Integer, _
    columnNumber As Integer _
) As TimesheetDetailInfo
Visual C++
public:
TimesheetDetailInfo^ getTimesheetDetail(
    int rowNumber,
    int columnNumber
)

Parameters

rowNumber
Type: System..::.Int32
The task row of the timesheet.
columnNumber
Type: System..::.Int32
The date column of the timesheet.

Return Value

The timesheet detail of the cell on the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetTimesheetDuration Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.GetTimesheetDuration Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the duration of a particular cell on the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public double GetTimesheetDuration(
    int rowNumber,
    int columnNumber
)
Visual Basic (Declaration)
Public Function GetTimesheetDuration ( _
    rowNumber As Integer, _
    columnNumber As Integer _
) As Double
Visual C++
public:
double GetTimesheetDuration(
    int rowNumber,
    int columnNumber
)

Parameters

rowNumber
Type: System..::.Int32
The task row of the timesheet.
columnNumber
Type: System..::.Int32
The date column of the timesheet.

Return Value

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


ToCSV Method

[image]

OfficeClip API Documentation
TimesheetInfo..::.ToCSV Method
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Converts the timesheet to its csv format.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ToCSV()
Visual Basic (Declaration)
Public Function ToCSV As String
Visual C++
public:
String^ ToCSV()

Return Value

The csv format of the timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetInfo Properties

[image] [image]

OfficeClip API Documentation
TimesheetInfo Properties
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetInfo type exposes the following properties.

Properties

 | Name | Description
Public property | CreatedTimestamp | The Timestamp for the timesheet creation.
Public property | DocIdList | A comma separated String of the document identifiers for all documents that are attached to this timesheet.
Public property | ExportedTimestamp | The time when this timesheet was exported.
Public property | FirstName | The first name
Public property | FromDate | The first date of the timesheet.
Public property | GroupId | the identifier for the group.
Public property | GroupName | The group name of the group that owns the timesheet.
Public property | IsExported | Shows if the timesheet is exported. Valid values are "Y" (means exported) and "N" (not exported).
Public property | LastName | The last name
Public property | NumLines | Number of rows in the timesheet.
Public property | RemDocIdList | A comma separated String of the document identifiers for all documents that are removed from this timesheet.
Public property | TimesheetComments | The list of Comments on this timesheet.
Public property | TimesheetDetails | The list of all the timesheet details on this timesheet.
Public property | TimesheetId | The system generated identifier for the timesheet.
Public property | ToDate | The last date of the timesheet.
Public property | UserId | The identifier for the user that owns the timesheet.
Public property | UserName | The name of the user that owns the timesheet.
Public property | WorkflowHistory | The list of workflow history for this timesheet.
Public property | WorkflowTypeId | Get the workflow type id corresponding to this particular timesheet.

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


CreatedTimestamp Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.CreatedTimestamp Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Timestamp for the timesheet creation.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedTimestamp As DateTime
Visual C++
public:
property DateTime CreatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


DocIdList Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.DocIdList Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

A comma separated String of the document identifiers for all documents that are attached to this timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string DocIdList { get; set; }
Visual Basic (Declaration)
Public Property DocIdList As String
Visual C++
public:
property String^ DocIdList {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


ExportedTimestamp Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.ExportedTimestamp Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The time when this timesheet was exported.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ExportedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property ExportedTimestamp As DateTime
Visual C++
public:
property DateTime ExportedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


FirstName Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.FirstName Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first name

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


FromDate Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.FromDate Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The first date of the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime FromDate { get; set; }
Visual Basic (Declaration)
Public Property FromDate As DateTime
Visual C++
public:
property DateTime FromDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupId Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.GroupId Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

the identifier for the group.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupName Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.GroupName Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The group name of the group that owns the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GroupName { get; set; }
Visual Basic (Declaration)
Public Property GroupName As String
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsExported Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.IsExported Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the timesheet is exported. Valid values are "Y" (means exported) and "N" (not exported).

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsExported { get; set; }
Visual Basic (Declaration)
Public Property IsExported As String
Visual C++
public:
property String^ IsExported {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


LastName Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.LastName Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last name

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


NumLines Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.NumLines Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Number of rows in the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumLines { get; set; }
Visual Basic (Declaration)
Public Property NumLines As Integer
Visual C++
public:
property int NumLines {
    int get ();
    void set (int value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


RemDocIdList Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.RemDocIdList Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

A comma separated String of the document identifiers for all documents that are removed from this timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RemDocIdList { get; set; }
Visual Basic (Declaration)
Public Property RemDocIdList As String
Visual C++
public:
property String^ RemDocIdList {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetComments Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.TimesheetComments Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of Comments on this timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList TimesheetComments { get; set; }
Visual Basic (Declaration)
Public Property TimesheetComments As ArrayList
Visual C++
public:
property ArrayList^ TimesheetComments {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetDetails Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.TimesheetDetails Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of all the timesheet details on this timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList TimesheetDetails { get; set; }
Visual Basic (Declaration)
Public Property TimesheetDetails As ArrayList
Visual C++
public:
property ArrayList^ TimesheetDetails {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetId Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.TimesheetId Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated identifier for the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TimesheetId { get; set; }
Visual Basic (Declaration)
Public Property TimesheetId As Integer
Visual C++
public:
property int TimesheetId {
    int get ();
    void set (int value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


ToDate Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.ToDate Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last date of the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ToDate { get; set; }
Visual Basic (Declaration)
Public Property ToDate As DateTime
Visual C++
public:
property DateTime ToDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


UserId Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.UserId Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The identifier for the user that owns the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


UserName Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.UserName Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user that owns the timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UserName { get; set; }
Visual Basic (Declaration)
Public Property UserName As String
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


WorkflowHistory Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.WorkflowHistory Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

The list of workflow history for this timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList WorkflowHistory { get; set; }
Visual Basic (Declaration)
Public Property WorkflowHistory As ArrayList
Visual C++
public:
property ArrayList^ WorkflowHistory {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


WorkflowTypeId Property

[image]

OfficeClip API Documentation
TimesheetInfo..::.WorkflowTypeId Property
TimesheetInfo Class See Also

[This is preliminary documentation and is subject to change.]

Get the workflow type id corresponding to this particular timesheet.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int WorkflowTypeId { get; set; }
Visual Basic (Declaration)
Public Property WorkflowTypeId As Integer
Visual C++
public:
property int WorkflowTypeId {
    int get ();
    void set (int value);
}

See Also

TimesheetInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetTaskInfo Class

[image]

OfficeClip API Documentation
TimesheetTaskInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods and properties to access the timesheet task information.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class TimesheetTaskInfo : ISerializable,
    IComparable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class TimesheetTaskInfo _
    Implements ISerializable, IComparable
Visual C++
[SerializableAttribute]
public ref class TimesheetTaskInfo : ISerializable,
    IComparable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.TE..::.TimesheetTaskInfo

See Also

TimesheetTaskInfo Members
OfficeClip.BusinessLayer.TE Namespace


TimesheetTaskInfo Members

[image] [image]

OfficeClip API Documentation
TimesheetTaskInfo Members
TimesheetTaskInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TimesheetTaskInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TimesheetTaskInfo | Overloaded.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides Object..::.Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::.GetHashCode()()().)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The unique id of the account
Public property | AllowBillableModify | shows if the billable option is allowed to be modified on the screen. Valid values are "Y" (modification allowed) or "N" (modification not allowed.
Public property | GroupId | The group identifier for the group which owns the timesheet template.
Public property | IsActive | Gets or set a task item IsActive.Valid values are "Y" (Task is active) or "N" (Task is not active).
Public property | IsBillable | Shows if the timesheet task is billable. Valid values as "Y" (for billable) and "N" (for non-billable).
Public property | ProjectId | The unique id of the project
Public property | TaskCode | The timesheet task code.
Public property | TaskId | The timesheet task identifier.
Public property | TaskName | The timesheet task name.
Public property | TimesheetTaskAndBillable |
Public property | TimesheetTaskKey | The key for the timesheet task.
Public property | TimesheetTaskNameAndCode | The name and code (separated by a "-" delimiter) of the timesheet task.

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetTaskInfo Constructor

[image] [image]

OfficeClip API Documentation
TimesheetTaskInfo Constructor
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TimesheetTaskInfo()()() | The default constructor.
Public method | TimesheetTaskInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

TimesheetTaskInfo Class
TimesheetTaskInfo Members
OfficeClip.BusinessLayer.TE Namespace


TimesheetTaskInfo Constructor

[image]

OfficeClip API Documentation
TimesheetTaskInfo Constructor
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetTaskInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimesheetTaskInfo()

See Also

TimesheetTaskInfo Class
TimesheetTaskInfo Overload
OfficeClip.BusinessLayer.TE Namespace


TimesheetTaskInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
TimesheetTaskInfo Constructor (SerializationInfo, StreamingContext)
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetTaskInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
TimesheetTaskInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

TimesheetTaskInfo Class
TimesheetTaskInfo Overload
OfficeClip.BusinessLayer.TE Namespace


TimesheetTaskInfo Methods

[image] [image]

OfficeClip API Documentation
TimesheetTaskInfo Methods
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetTaskInfo type exposes the following methods.

Methods

 | Name | Description
Public method | CompareTo |
Public method | Equals | (Overrides Object..::.Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::.GetHashCode()()().)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


CompareTo Method

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.CompareTo Method
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::.Object

Implements

IComparable..::.CompareTo(Object)

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


Equals Method

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.Equals Method
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::.Object

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetHashCode Method

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.GetHashCode Method
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.GetObjectData Method
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetTaskInfo Properties

[image] [image]

OfficeClip API Documentation
TimesheetTaskInfo Properties
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetTaskInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The unique id of the account
Public property | AllowBillableModify | shows if the billable option is allowed to be modified on the screen. Valid values are "Y" (modification allowed) or "N" (modification not allowed.
Public property | GroupId | The group identifier for the group which owns the timesheet template.
Public property | IsActive | Gets or set a task item IsActive.Valid values are "Y" (Task is active) or "N" (Task is not active).
Public property | IsBillable | Shows if the timesheet task is billable. Valid values as "Y" (for billable) and "N" (for non-billable).
Public property | ProjectId | The unique id of the project
Public property | TaskCode | The timesheet task code.
Public property | TaskId | The timesheet task identifier.
Public property | TaskName | The timesheet task name.
Public property | TimesheetTaskAndBillable |
Public property | TimesheetTaskKey | The key for the timesheet task.
Public property | TimesheetTaskNameAndCode | The name and code (separated by a "-" delimiter) of the timesheet task.

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


AccountId Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.AccountId Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the account

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AccountId { get; set; }
Visual Basic (Declaration)
Public Property AccountId As Integer
Visual C++
public:
property int AccountId {
    int get ();
    void set (int value);
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


AllowBillableModify Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.AllowBillableModify Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

shows if the billable option is allowed to be modified on the screen. Valid values are "Y" (modification allowed) or "N" (modification not allowed.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AllowBillableModify { get; set; }
Visual Basic (Declaration)
Public Property AllowBillableModify As String
Visual C++
public:
property String^ AllowBillableModify {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


GroupId Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.GroupId Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The group identifier for the group which owns the timesheet template.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsActive Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.IsActive Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets or set a task item IsActive.Valid values are "Y" (Task is active) or "N" (Task is not active).

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As String
Visual C++
public:
property String^ IsActive {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


IsBillable Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.IsBillable Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the timesheet task is billable. Valid values as "Y" (for billable) and "N" (for non-billable).

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsBillable { get; set; }
Visual Basic (Declaration)
Public Property IsBillable As String
Visual C++
public:
property String^ IsBillable {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


ProjectId Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.ProjectId Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the project

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ProjectId { get; set; }
Visual Basic (Declaration)
Public Property ProjectId As Integer
Visual C++
public:
property int ProjectId {
    int get ();
    void set (int value);
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


TaskCode Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.TaskCode Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The timesheet task code.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TaskCode { get; set; }
Visual Basic (Declaration)
Public Property TaskCode As String
Visual C++
public:
property String^ TaskCode {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


TaskId Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.TaskId Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The timesheet task identifier.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TaskId { get; set; }
Visual Basic (Declaration)
Public Property TaskId As Integer
Visual C++
public:
property int TaskId {
    int get ();
    void set (int value);
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


TaskName Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.TaskName Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The timesheet task name.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TaskName { get; set; }
Visual Basic (Declaration)
Public Property TaskName As String
Visual C++
public:
property String^ TaskName {
    String^ get ();
    void set (String^ value);
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetTaskAndBillable Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.TimesheetTaskAndBillable Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TimesheetTaskAndBillable { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimesheetTaskAndBillable As String
Visual C++
public:
property String^ TimesheetTaskAndBillable {
    String^ get ();
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetTaskKey Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.TimesheetTaskKey Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The key for the timesheet task.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TimesheetTaskKey { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimesheetTaskKey As String
Visual C++
public:
property String^ TimesheetTaskKey {
    String^ get ();
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


TimesheetTaskNameAndCode Property

[image]

OfficeClip API Documentation
TimesheetTaskInfo..::.TimesheetTaskNameAndCode Property
TimesheetTaskInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name and code (separated by a "-" delimiter) of the timesheet task.

Namespace: OfficeClip.BusinessLayer.TE
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TimesheetTaskNameAndCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property TimesheetTaskNameAndCode As String
Visual C++
public:
property String^ TimesheetTaskNameAndCode {
    String^ get ();
}

See Also

TimesheetTaskInfo Class
OfficeClip.BusinessLayer.TE Namespace


OfficeClip.BusinessLayer.Template Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Template Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for email templates

Classes

 | Class | Description
Public class | CampaignInfo | Description of the Class CampaignInfo
Public class | Constants | The class that consists of template Utils.Constants.
Public class | LetterheadInfo | Class for creating the letterhead LetterheadInfo
Public class | ObjectItem | Class to hold the object item of the template
Public class | TemplateAnnounceMail |
Public class | TemplateBulletingBoardMail |
Public class | TemplateEventMail |
Public class | TemplateExtranetPublicUserMail |
Public class | TemplateGenericMail |
Public class | TemplateInfo | Description of the Class TemplateInfo
Public class | TemplateIssueTrackerMail |
Public class | TemplateMail |
Public class | TemplateMailInfo |
Public class | TemplateTimeAndExpensesMail |

Enumerations

 | Enumeration | Description
Public enumeration | Category | Category enumerated type
Public enumeration | ItemConstants | The enumerated type item constants
Public enumeration | TemplateNameId | The template name id enumerated type
Public enumeration | TemplateType | The template type enumerated type


CampaignInfo Class

[image]

OfficeClip API Documentation
CampaignInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Description of the Class CampaignInfo

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class CampaignInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CampaignInfo
Visual C++
[SerializableAttribute]
public ref class CampaignInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.CampaignInfo

See Also

CampaignInfo Members
OfficeClip.BusinessLayer.Template Namespace


CampaignInfo Members

[image] [image]

OfficeClip API Documentation
CampaignInfo Members
CampaignInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The CampaignInfo type exposes the following members.

Constructors

 | Name | Description
Public method | CampaignInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignId |
Public property | EmailAccountId |
Public property | IsMailMerge |
Public property | IsRecurring |
Public property | LetterheadId | Teh unique id of the letterhead
Public property | SenderEmail | The email address of the sender
Public property | SenderName | Teh name of the sender
Public property | TInfo | The template information object

See Also

CampaignInfo Class
OfficeClip.BusinessLayer.Template Namespace


CampaignInfo Constructor

[image] [image]

OfficeClip API Documentation
CampaignInfo Constructor
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | CampaignInfo()()() | The default constructor
Public method | CampaignInfo(Int32, TemplateInfo, Int32, Boolean, Boolean, Int32, String, String) | Constructor

See Also

CampaignInfo Class
CampaignInfo Members
OfficeClip.BusinessLayer.Template Namespace


CampaignInfo Constructor

[image]

OfficeClip API Documentation
CampaignInfo Constructor
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CampaignInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CampaignInfo()

See Also

CampaignInfo Class
CampaignInfo Overload
OfficeClip.BusinessLayer.Template Namespace


CampaignInfo Constructor (Int32, TemplateInfo, Int32, Boolean, Boolean, Int32, String, String)

[image]

OfficeClip API Documentation
CampaignInfo Constructor (Int32, TemplateInfo, Int32, Boolean, Boolean, Int32, String, String)
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public CampaignInfo(
    int campaignId,
    TemplateInfo tInfo,
    int emailAccountId,
    bool isRecurring,
    bool isMailMerge,
    int letterheadId,
    string senderName,
    string senderEmail
)
Visual Basic (Declaration)
Public Sub New ( _
    campaignId As Integer, _
    tInfo As TemplateInfo, _
    emailAccountId As Integer, _
    isRecurring As Boolean, _
    isMailMerge As Boolean, _
    letterheadId As Integer, _
    senderName As String, _
    senderEmail As String _
)
Visual C++
public:
CampaignInfo(
    int campaignId,
    TemplateInfo^ tInfo,
    int emailAccountId,
    bool isRecurring,
    bool isMailMerge,
    int letterheadId,
    String^ senderName,
    String^ senderEmail
)

Parameters

campaignId
Type: System..::.Int32
The unique id of the campaign
tInfo
Type: OfficeClip.BusinessLayer.Template..::.TemplateInfo
The template information
emailAccountId
Type: System..::.Int32
The unique id of teh email account
isRecurring
Type: System..::.Boolean
True if it is a recurring campaign
isMailMerge
Type: System..::.Boolean
True if it is a mail-merge campaign
letterheadId
Type: System..::.Int32
The unique id of the letterhead
senderName
Type: System..::.String
The name of the sender
senderEmail
Type: System..::.String
The email address of the sender

See Also

CampaignInfo Class
CampaignInfo Overload
OfficeClip.BusinessLayer.Template Namespace


CampaignInfo Properties

[image] [image]

OfficeClip API Documentation
CampaignInfo Properties
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

The CampaignInfo type exposes the following properties.

Properties

 | Name | Description
Public property | CampaignId |
Public property | EmailAccountId |
Public property | IsMailMerge |
Public property | IsRecurring |
Public property | LetterheadId | Teh unique id of the letterhead
Public property | SenderEmail | The email address of the sender
Public property | SenderName | Teh name of the sender
Public property | TInfo | The template information object

See Also

CampaignInfo Class
OfficeClip.BusinessLayer.Template Namespace


CampaignId Property

[image]

OfficeClip API Documentation
CampaignInfo..::.CampaignId Property
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CampaignId { get; set; }
Visual Basic (Declaration)
Public Property CampaignId As Integer
Visual C++
public:
property int CampaignId {
    int get ();
    void set (int value);
}

See Also

CampaignInfo Class
OfficeClip.BusinessLayer.Template Namespace


EmailAccountId Property

[image]

OfficeClip API Documentation
CampaignInfo..::.EmailAccountId Property
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int EmailAccountId { get; set; }
Visual Basic (Declaration)
Public Property EmailAccountId As Integer
Visual C++
public:
property int EmailAccountId {
    int get ();
    void set (int value);
}

See Also

CampaignInfo Class
OfficeClip.BusinessLayer.Template Namespace


IsMailMerge Property

[image]

OfficeClip API Documentation
CampaignInfo..::.IsMailMerge Property
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsMailMerge { get; set; }
Visual Basic (Declaration)
Public Property IsMailMerge As Boolean
Visual C++
public:
property bool IsMailMerge {
    bool get ();
    void set (bool value);
}

See Also

CampaignInfo Class
OfficeClip.BusinessLayer.Template Namespace


IsRecurring Property

[image]

OfficeClip API Documentation
CampaignInfo..::.IsRecurring Property
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsRecurring { get; set; }
Visual Basic (Declaration)
Public Property IsRecurring As Boolean
Visual C++
public:
property bool IsRecurring {
    bool get ();
    void set (bool value);
}

See Also

CampaignInfo Class
OfficeClip.BusinessLayer.Template Namespace


LetterheadId Property

[image]

OfficeClip API Documentation
CampaignInfo..::.LetterheadId Property
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

Teh unique id of the letterhead

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LetterheadId { get; set; }
Visual Basic (Declaration)
Public Property LetterheadId As Integer
Visual C++
public:
property int LetterheadId {
    int get ();
    void set (int value);
}

See Also

CampaignInfo Class
OfficeClip.BusinessLayer.Template Namespace


SenderEmail Property

[image]

OfficeClip API Documentation
CampaignInfo..::.SenderEmail Property
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email address of the sender

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SenderEmail { get; set; }
Visual Basic (Declaration)
Public Property SenderEmail As String
Visual C++
public:
property String^ SenderEmail {
    String^ get ();
    void set (String^ value);
}

See Also

CampaignInfo Class
OfficeClip.BusinessLayer.Template Namespace


SenderName Property

[image]

OfficeClip API Documentation
CampaignInfo..::.SenderName Property
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

Teh name of the sender

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SenderName { get; set; }
Visual Basic (Declaration)
Public Property SenderName As String
Visual C++
public:
property String^ SenderName {
    String^ get ();
    void set (String^ value);
}

See Also

CampaignInfo Class
OfficeClip.BusinessLayer.Template Namespace


TInfo Property

[image]

OfficeClip API Documentation
CampaignInfo..::.TInfo Property
CampaignInfo Class See Also

[This is preliminary documentation and is subject to change.]

The template information object

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateInfo TInfo { get; set; }
Visual Basic (Declaration)
Public Property TInfo As TemplateInfo
Visual C++
public:
property TemplateInfo^ TInfo {
    TemplateInfo^ get ();
    void set (TemplateInfo^ value);
}

See Also

CampaignInfo Class
OfficeClip.BusinessLayer.Template Namespace


Category Enumeration

[image]

OfficeClip API Documentation
Category Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Category enumerated type

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum Category
Visual Basic (Declaration)
Public Enumeration Category
Visual C++
public enum class Category

Members

Member name | Description
None | No category
System | System category
User | User Category
Meta | Meta Category, mainly used for metaentities like contacts etc

See Also

OfficeClip.BusinessLayer.Template Namespace


Constants Class

[image]

OfficeClip API Documentation
Constants Class
Members See Also

[This is preliminary documentation and is subject to change.]

The class that consists of template Utils.Constants.

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class Constants
Visual Basic (Declaration)
Public Class Constants
Visual C++
public ref class Constants

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.Constants

See Also

Constants Members
OfficeClip.BusinessLayer.Template Namespace


Constants Members

[image] [image]

OfficeClip API Documentation
Constants Members
Constants Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The Constants type exposes the following members.

Constructors

 | Name | Description
Public method | Constants |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCategoryName | Gets the category name from the category enumerated type
 | GetEntityAttributes | Sets the entity and attribute of an item. Note that if the attribute name matches the pattern "DateTime", it will print both date and time. If it just matches with "Date", it will only print date, if it matches with "Time" it will only print time.
 | GetEntityItems | Get the items from the template
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetNameString | Gets the name of the item constant
 | GetSystemTemplateName | The system category uses the template name to identify a particular template.
 | GetSystemTemplateSMS | Gets the SMS string for the system template. The cariable are represented as {{domain.property:length}} where domain and property are the same as represented in the template but length is the maximum length of the string for this variable. If the variable length exceeds this value, there will be a ... appended to the end.
 | GetTemplateTypeName | Gets the template type name from the template type enumerated type
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Constants Class
OfficeClip.BusinessLayer.Template Namespace


Constants Constructor

[image]

OfficeClip API Documentation
Constants Constructor
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Constants()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Constants()

See Also

Constants Class
OfficeClip.BusinessLayer.Template Namespace


Constants Methods

[image] [image]

OfficeClip API Documentation
Constants Methods
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The Constants type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCategoryName | Gets the category name from the category enumerated type
 | GetEntityAttributes | Sets the entity and attribute of an item. Note that if the attribute name matches the pattern "DateTime", it will print both date and time. If it just matches with "Date", it will only print date, if it matches with "Time" it will only print time.
 | GetEntityItems | Get the items from the template
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetNameString | Gets the name of the item constant
 | GetSystemTemplateName | The system category uses the template name to identify a particular template.
 | GetSystemTemplateSMS | Gets the SMS string for the system template. The cariable are represented as {{domain.property:length}} where domain and property are the same as represented in the template but length is the maximum length of the string for this variable. If the variable length exceeds this value, there will be a ... appended to the end.
 | GetTemplateTypeName | Gets the template type name from the template type enumerated type
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Constants Class
OfficeClip.BusinessLayer.Template Namespace


GetCategoryName Method

[image]

OfficeClip API Documentation
Constants..::.GetCategoryName Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the category name from the category enumerated type

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetCategoryName(
    Category cat
)
Visual Basic (Declaration)
Public Shared Function GetCategoryName ( _
    cat As Category _
) As String
Visual C++
public:
static String^ GetCategoryName(
    Category cat
)

Parameters

cat
Type: OfficeClip.BusinessLayer.Template..::.Category
The category enumerated type

Return Value

Teh category name

See Also

Constants Class
OfficeClip.BusinessLayer.Template Namespace


GetEntityAttributes Method

[image]

OfficeClip API Documentation
Constants..::.GetEntityAttributes Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Sets the entity and attribute of an item. Note that if the attribute name matches the pattern "DateTime", it will print both date and time. If it just matches with "Date", it will only print date, if it matches with "Time" it will only print time.

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static ObjectItem GetEntityAttributes(
    ItemConstants ic
)
Visual Basic (Declaration)
Public Shared Function GetEntityAttributes ( _
    ic As ItemConstants _
) As ObjectItem
Visual C++
public:
static ObjectItem^ GetEntityAttributes(
    ItemConstants ic
)

Parameters

ic
Type: OfficeClip.BusinessLayer.Template..::.ItemConstants
The entity constant

Return Value

The Object item that will consist of entity and attribute.

See Also

Constants Class
OfficeClip.BusinessLayer.Template Namespace


GetEntityItems Method

[image]

OfficeClip API Documentation
Constants..::.GetEntityItems Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Get the items from the template

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static ObjectItem[] GetEntityItems(
    TemplateType tt
)
Visual Basic (Declaration)
Public Shared Function GetEntityItems ( _
    tt As TemplateType _
) As ObjectItem()
Visual C++
public:
static array<ObjectItem^>^ GetEntityItems(
    TemplateType tt
)

Parameters

tt
Type: OfficeClip.BusinessLayer.Template..::.TemplateType
Teh template type

Return Value

The array of object items

See Also

Constants Class
OfficeClip.BusinessLayer.Template Namespace


GetNameString Method

[image]

OfficeClip API Documentation
Constants..::.GetNameString Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the name of the item constant

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetNameString(
    ItemConstants ic
)
Visual Basic (Declaration)
Public Shared Function GetNameString ( _
    ic As ItemConstants _
) As String
Visual C++
public:
static String^ GetNameString(
    ItemConstants ic
)

Parameters

ic
Type: OfficeClip.BusinessLayer.Template..::.ItemConstants
the item constants enumerated type

Return Value

The name string

See Also

Constants Class
OfficeClip.BusinessLayer.Template Namespace


GetSystemTemplateName Method

[image]

OfficeClip API Documentation
Constants..::.GetSystemTemplateName Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The system category uses the template name to identify a particular template.

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetSystemTemplateName(
    TemplateNameId stId
)
Visual Basic (Declaration)
Public Shared Function GetSystemTemplateName ( _
    stId As TemplateNameId _
) As String
Visual C++
public:
static String^ GetSystemTemplateName(
    TemplateNameId stId
)

Parameters

stId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
The template id

Return Value

The actual name for the template to be used for display

See Also

Constants Class
OfficeClip.BusinessLayer.Template Namespace


GetSystemTemplateSMS Method

[image]

OfficeClip API Documentation
Constants..::.GetSystemTemplateSMS Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the SMS string for the system template. The cariable are represented as {{domain.property:length}} where domain and property are the same as represented in the template but length is the maximum length of the string for this variable. If the variable length exceeds this value, there will be a ... appended to the end.

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetSystemTemplateSMS(
    TemplateNameId stId
)
Visual Basic (Declaration)
Public Shared Function GetSystemTemplateSMS ( _
    stId As TemplateNameId _
) As String
Visual C++
public:
static String^ GetSystemTemplateSMS(
    TemplateNameId stId
)

Parameters

stId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId

Return Value

The SMS string

See Also

Constants Class
OfficeClip.BusinessLayer.Template Namespace


GetTemplateTypeName Method

[image]

OfficeClip API Documentation
Constants..::.GetTemplateTypeName Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gets the template type name from the template type enumerated type

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetTemplateTypeName(
    TemplateType tt
)
Visual Basic (Declaration)
Public Shared Function GetTemplateTypeName ( _
    tt As TemplateType _
) As String
Visual C++
public:
static String^ GetTemplateTypeName(
    TemplateType tt
)

Parameters

tt
Type: OfficeClip.BusinessLayer.Template..::.TemplateType
The template type enumerated type

Return Value

The template name

See Also

Constants Class
OfficeClip.BusinessLayer.Template Namespace


ItemConstants Enumeration

[image]

OfficeClip API Documentation
ItemConstants Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The enumerated type item constants

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum ItemConstants
Visual Basic (Declaration)
Public Enumeration ItemConstants
Visual C++
public enum class ItemConstants

Members

Member name | Description
None | No Item constant
LoginUser | The login user item constant
Group | Teh group item constant
Event | The event item constant
EmailRecipientUser | The email recipient user item constant
Announcement | Teh announcement item constant
GroupAdministrator | Teh group administrator item constant
Password | The password item constant
DocumentShare | The document share item constant
BulletinBoardForum | Teh bulletin board forum item constant
OfficeClipConstant | Teh officeclip constant item constant
LDAP | The ldap item constant
BulletinBoardTopic | Teh bulletin board topic item constant
GenericObject | teh generic object item constant
BulletinBoardReply | Teh bulleting board reply item constant
TimeAndExpenses | The time and expenses item constant
UserDetail | Teh user detail item constant
Poll | Teh poll item constant
IssueTracker | Teh issue tracker item constant
ContactManager | Teh contact manager item constant
CustomerPortal | The extranet item constants
CustomerPortalEvent | The Extranet event constant

See Also

OfficeClip.BusinessLayer.Template Namespace


LetterheadInfo Class

[image]

OfficeClip API Documentation
LetterheadInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class for creating the letterhead LetterheadInfo

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class LetterheadInfo
Visual Basic (Declaration)
Public Class LetterheadInfo
Visual C++
public ref class LetterheadInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.LetterheadInfo

See Also

LetterheadInfo Members
OfficeClip.BusinessLayer.Template Namespace


LetterheadInfo Members

[image] [image]

OfficeClip API Documentation
LetterheadInfo Members
LetterheadInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The LetterheadInfo type exposes the following members.

Constructors

 | Name | Description
Public method | LetterheadInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The unique id of the account
Public property | CreatedByTimestamp | The created timestamp
Public property | CreatedByUserId | The created user id
Public property | Html | The html content of the letterhead
Public property | LastUpdatedTimestamp | The last updated timestamp
Public property | LastUpdatedUserId | The last update userid
Public property | LastUpdatedUserName | The last update user name
Public property | LetterheadId | The unique id of the letterhead
Public property | Name | The name of teh letterhead

See Also

LetterheadInfo Class
OfficeClip.BusinessLayer.Template Namespace


LetterheadInfo Constructor

[image] [image]

OfficeClip API Documentation
LetterheadInfo Constructor
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | LetterheadInfo()()() | The default constructor
Public method | LetterheadInfo(Int32, Decimal, String, String, Int32, DateTime, Int32, DateTime) | Constructor

See Also

LetterheadInfo Class
LetterheadInfo Members
OfficeClip.BusinessLayer.Template Namespace


LetterheadInfo Constructor

[image]

OfficeClip API Documentation
LetterheadInfo Constructor
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public LetterheadInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LetterheadInfo()

See Also

LetterheadInfo Class
LetterheadInfo Overload
OfficeClip.BusinessLayer.Template Namespace


LetterheadInfo Constructor (Int32, Decimal, String, String, Int32, DateTime, Int32, DateTime)

[image]

OfficeClip API Documentation
LetterheadInfo Constructor (Int32, Decimal, String, String, Int32, DateTime, Int32, DateTime)
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public LetterheadInfo(
    int letterheadId,
    decimal accountId,
    string name,
    string html,
    int createdByUserId,
    DateTime createdByTimestamp,
    int lastUpdatedUserId,
    DateTime lastUpdatedTimestamp
)
Visual Basic (Declaration)
Public Sub New ( _
    letterheadId As Integer, _
    accountId As Decimal, _
    name As String, _
    html As String, _
    createdByUserId As Integer, _
    createdByTimestamp As DateTime, _
    lastUpdatedUserId As Integer, _
    lastUpdatedTimestamp As DateTime _
)
Visual C++
public:
LetterheadInfo(
    int letterheadId,
    Decimal accountId,
    String^ name,
    String^ html,
    int createdByUserId,
    DateTime createdByTimestamp,
    int lastUpdatedUserId,
    DateTime lastUpdatedTimestamp
)

Parameters

letterheadId
Type: System..::.Int32
The unique id of the letterhead
accountId
Type: System..::.Decimal
the unique id of the account
name
Type: System..::.String
The name of the letterhead
html
Type: System..::.String
the heml part of the letterhead
createdByUserId
Type: System..::.Int32
the unique id of the created user
createdByTimestamp
Type: System..::.DateTime
The created by timestamp
lastUpdatedUserId
Type: System..::.Int32
The last updated user id
lastUpdatedTimestamp
Type: System..::.DateTime
The last updated timestamp

See Also

LetterheadInfo Class
LetterheadInfo Overload
OfficeClip.BusinessLayer.Template Namespace


LetterheadInfo Properties

[image] [image]

OfficeClip API Documentation
LetterheadInfo Properties
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

The LetterheadInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The unique id of the account
Public property | CreatedByTimestamp | The created timestamp
Public property | CreatedByUserId | The created user id
Public property | Html | The html content of the letterhead
Public property | LastUpdatedTimestamp | The last updated timestamp
Public property | LastUpdatedUserId | The last update userid
Public property | LastUpdatedUserName | The last update user name
Public property | LetterheadId | The unique id of the letterhead
Public property | Name | The name of teh letterhead

See Also

LetterheadInfo Class
OfficeClip.BusinessLayer.Template Namespace


AccountId Property

[image]

OfficeClip API Documentation
LetterheadInfo..::.AccountId Property
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the account

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public decimal AccountId { get; set; }
Visual Basic (Declaration)
Public Property AccountId As Decimal
Visual C++
public:
property Decimal AccountId {
    Decimal get ();
    void set (Decimal value);
}

See Also

LetterheadInfo Class
OfficeClip.BusinessLayer.Template Namespace


CreatedByTimestamp Property

[image]

OfficeClip API Documentation
LetterheadInfo..::.CreatedByTimestamp Property
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

The created timestamp

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedByTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedByTimestamp As DateTime
Visual C++
public:
property DateTime CreatedByTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

LetterheadInfo Class
OfficeClip.BusinessLayer.Template Namespace


CreatedByUserId Property

[image]

OfficeClip API Documentation
LetterheadInfo..::.CreatedByUserId Property
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

The created user id

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedByUserId { get; set; }
Visual Basic (Declaration)
Public Property CreatedByUserId As Integer
Visual C++
public:
property int CreatedByUserId {
    int get ();
    void set (int value);
}

See Also

LetterheadInfo Class
OfficeClip.BusinessLayer.Template Namespace


Html Property

[image]

OfficeClip API Documentation
LetterheadInfo..::.Html Property
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

The html content of the letterhead

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Html { get; set; }
Visual Basic (Declaration)
Public Property Html As String
Visual C++
public:
property String^ Html {
    String^ get ();
    void set (String^ value);
}

See Also

LetterheadInfo Class
OfficeClip.BusinessLayer.Template Namespace


LastUpdatedTimestamp Property

[image]

OfficeClip API Documentation
LetterheadInfo..::.LastUpdatedTimestamp Property
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last updated timestamp

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime LastUpdatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedTimestamp As DateTime
Visual C++
public:
property DateTime LastUpdatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

LetterheadInfo Class
OfficeClip.BusinessLayer.Template Namespace


LastUpdatedUserId Property

[image]

OfficeClip API Documentation
LetterheadInfo..::.LastUpdatedUserId Property
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last update userid

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LastUpdatedUserId { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedUserId As Integer
Visual C++
public:
property int LastUpdatedUserId {
    int get ();
    void set (int value);
}

See Also

LetterheadInfo Class
OfficeClip.BusinessLayer.Template Namespace


LastUpdatedUserName Property

[image]

OfficeClip API Documentation
LetterheadInfo..::.LastUpdatedUserName Property
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last update user name

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string LastUpdatedUserName { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedUserName As String
Visual C++
public:
property String^ LastUpdatedUserName {
    String^ get ();
    void set (String^ value);
}

See Also

LetterheadInfo Class
OfficeClip.BusinessLayer.Template Namespace


LetterheadId Property

[image]

OfficeClip API Documentation
LetterheadInfo..::.LetterheadId Property
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the letterhead

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LetterheadId { get; set; }
Visual Basic (Declaration)
Public Property LetterheadId As Integer
Visual C++
public:
property int LetterheadId {
    int get ();
    void set (int value);
}

See Also

LetterheadInfo Class
OfficeClip.BusinessLayer.Template Namespace


Name Property

[image]

OfficeClip API Documentation
LetterheadInfo..::.Name Property
LetterheadInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of teh letterhead

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

LetterheadInfo Class
OfficeClip.BusinessLayer.Template Namespace


ObjectItem Class

[image]

OfficeClip API Documentation
ObjectItem Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to hold the object item of the template

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class ObjectItem
Visual Basic (Declaration)
Public Class ObjectItem
Visual C++
public ref class ObjectItem

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.ObjectItem

See Also

ObjectItem Members
OfficeClip.BusinessLayer.Template Namespace


ObjectItem Members

[image] [image]

OfficeClip API Documentation
ObjectItem Members
ObjectItem Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ObjectItem type exposes the following members.

Constructors

 | Name | Description
Public method | ObjectItem | The Object item

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNameString | Gets the name string
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the class content to a string (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | Name | Teh item constant name
Public property | Vals | The value

See Also

ObjectItem Class
OfficeClip.BusinessLayer.Template Namespace


ObjectItem Constructor

[image]

OfficeClip API Documentation
ObjectItem Constructor
ObjectItem Class See Also

[This is preliminary documentation and is subject to change.]

The Object item

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ObjectItem(
    ItemConstants name,
    string vals
)
Visual Basic (Declaration)
Public Sub New ( _
    name As ItemConstants, _
    vals As String _
)
Visual C++
public:
ObjectItem(
    ItemConstants name,
    String^ vals
)

Parameters

name
Type: OfficeClip.BusinessLayer.Template..::.ItemConstants
The item constant enumerated type
vals
Type: System..::.String
The value

See Also

ObjectItem Class
OfficeClip.BusinessLayer.Template Namespace


ObjectItem Methods

[image] [image]

OfficeClip API Documentation
ObjectItem Methods
ObjectItem Class See Also

[This is preliminary documentation and is subject to change.]

The ObjectItem type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNameString | Gets the name string
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts the class content to a string (Overrides Object..::.ToString()()().)

See Also

ObjectItem Class
OfficeClip.BusinessLayer.Template Namespace


GetNameString Method

[image]

OfficeClip API Documentation
ObjectItem..::.GetNameString Method
ObjectItem Class See Also

[This is preliminary documentation and is subject to change.]

Gets the name string

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetNameString()
Visual Basic (Declaration)
Public Function GetNameString As String
Visual C++
public:
String^ GetNameString()

Return Value

The name string

See Also

ObjectItem Class
OfficeClip.BusinessLayer.Template Namespace


ToString Method

[image]

OfficeClip API Documentation
ObjectItem..::.ToString Method
ObjectItem Class See Also

[This is preliminary documentation and is subject to change.]

Converts the class content to a string

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The class content

See Also

ObjectItem Class
OfficeClip.BusinessLayer.Template Namespace


ObjectItem Properties

[image] [image]

OfficeClip API Documentation
ObjectItem Properties
ObjectItem Class See Also

[This is preliminary documentation and is subject to change.]

The ObjectItem type exposes the following properties.

Properties

 | Name | Description
Public property | Name | Teh item constant name
Public property | Vals | The value

See Also

ObjectItem Class
OfficeClip.BusinessLayer.Template Namespace


Name Property

[image]

OfficeClip API Documentation
ObjectItem..::.Name Property
ObjectItem Class See Also

[This is preliminary documentation and is subject to change.]

Teh item constant name

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ItemConstants Name { get; set; }
Visual Basic (Declaration)
Public Property Name As ItemConstants
Visual C++
public:
property ItemConstants Name {
    ItemConstants get ();
    void set (ItemConstants value);
}

See Also

ObjectItem Class
OfficeClip.BusinessLayer.Template Namespace


Vals Property

[image]

OfficeClip API Documentation
ObjectItem..::.Vals Property
ObjectItem Class See Also

[This is preliminary documentation and is subject to change.]

The value

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Vals { get; set; }
Visual Basic (Declaration)
Public Property Vals As String
Visual C++
public:
property String^ Vals {
    String^ get ();
    void set (String^ value);
}

See Also

ObjectItem Class
OfficeClip.BusinessLayer.Template Namespace


TemplateAnnounceMail Class

[image]

OfficeClip API Documentation
TemplateAnnounceMail Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TemplateAnnounceMail : TemplateMail
Visual Basic (Declaration)
Public Class TemplateAnnounceMail _
    Inherits TemplateMail
Visual C++
public ref class TemplateAnnounceMail : public TemplateMail

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.TemplateMail
OfficeClip.BusinessLayer.Template..::.TemplateAnnounceMail

See Also

TemplateAnnounceMail Members
OfficeClip.BusinessLayer.Template Namespace


TemplateAnnounceMail Members

[image] [image]

OfficeClip API Documentation
TemplateAnnounceMail Members
TemplateAnnounceMail Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The TemplateAnnounceMail type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateAnnounceMail |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | announceId |
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | stnId | (Inherited from TemplateMail.)
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateAnnounceMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateAnnounceMail Constructor

[image]

OfficeClip API Documentation
TemplateAnnounceMail Constructor
TemplateAnnounceMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateAnnounceMail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateAnnounceMail()

See Also

TemplateAnnounceMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateAnnounceMail Fields

[image] [image]

OfficeClip API Documentation
TemplateAnnounceMail Fields
TemplateAnnounceMail Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateAnnounceMail type exposes the following fields.

Fields

 | Name | Description
Public field | announceId |
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | stnId | (Inherited from TemplateMail.)
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateAnnounceMail Class
OfficeClip.BusinessLayer.Template Namespace


announceId Field

[image]

OfficeClip API Documentation
TemplateAnnounceMail..::.announceId Field
TemplateAnnounceMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int announceId
Visual Basic (Declaration)
Public announceId As Integer
Visual C++
public:
int announceId

See Also

TemplateAnnounceMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateBulletingBoardMail Class

[image]

OfficeClip API Documentation
TemplateBulletingBoardMail Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TemplateBulletingBoardMail : TemplateMail
Visual Basic (Declaration)
Public Class TemplateBulletingBoardMail _
    Inherits TemplateMail
Visual C++
public ref class TemplateBulletingBoardMail : public TemplateMail

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.TemplateMail
OfficeClip.BusinessLayer.Template..::.TemplateBulletingBoardMail

See Also

TemplateBulletingBoardMail Members
OfficeClip.BusinessLayer.Template Namespace


TemplateBulletingBoardMail Members

[image] [image]

OfficeClip API Documentation
TemplateBulletingBoardMail Members
TemplateBulletingBoardMail Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The TemplateBulletingBoardMail type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateBulletingBoardMail |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | forumId |
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | replyId |
Public field | stnId | (Inherited from TemplateMail.)
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | topicId |
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateBulletingBoardMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateBulletingBoardMail Constructor

[image]

OfficeClip API Documentation
TemplateBulletingBoardMail Constructor
TemplateBulletingBoardMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateBulletingBoardMail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateBulletingBoardMail()

See Also

TemplateBulletingBoardMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateBulletingBoardMail Fields

[image] [image]

OfficeClip API Documentation
TemplateBulletingBoardMail Fields
TemplateBulletingBoardMail Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateBulletingBoardMail type exposes the following fields.

Fields

 | Name | Description
Public field | forumId |
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | replyId |
Public field | stnId | (Inherited from TemplateMail.)
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | topicId |
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateBulletingBoardMail Class
OfficeClip.BusinessLayer.Template Namespace


forumId Field

[image]

OfficeClip API Documentation
TemplateBulletingBoardMail..::.forumId Field
TemplateBulletingBoardMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int forumId
Visual Basic (Declaration)
Public forumId As Integer
Visual C++
public:
int forumId

See Also

TemplateBulletingBoardMail Class
OfficeClip.BusinessLayer.Template Namespace


replyId Field

[image]

OfficeClip API Documentation
TemplateBulletingBoardMail..::.replyId Field
TemplateBulletingBoardMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int replyId
Visual Basic (Declaration)
Public replyId As Integer
Visual C++
public:
int replyId

See Also

TemplateBulletingBoardMail Class
OfficeClip.BusinessLayer.Template Namespace


topicId Field

[image]

OfficeClip API Documentation
TemplateBulletingBoardMail..::.topicId Field
TemplateBulletingBoardMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int topicId
Visual Basic (Declaration)
Public topicId As Integer
Visual C++
public:
int topicId

See Also

TemplateBulletingBoardMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateEventMail Class

[image]

OfficeClip API Documentation
TemplateEventMail Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TemplateEventMail : TemplateMail
Visual Basic (Declaration)
Public Class TemplateEventMail _
    Inherits TemplateMail
Visual C++
public ref class TemplateEventMail : public TemplateMail

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.TemplateMail
OfficeClip.BusinessLayer.Template..::.TemplateEventMail

See Also

TemplateEventMail Members
OfficeClip.BusinessLayer.Template Namespace


TemplateEventMail Members

[image] [image]

OfficeClip API Documentation
TemplateEventMail Members
TemplateEventMail Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The TemplateEventMail type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateEventMail |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | attachments |
Public field | eventAttendees |
Public field | eventId |
Public field | eventResources |
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | stnId | (Inherited from TemplateMail.)
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateEventMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateEventMail Constructor

[image]

OfficeClip API Documentation
TemplateEventMail Constructor
TemplateEventMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateEventMail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateEventMail()

See Also

TemplateEventMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateEventMail Fields

[image] [image]

OfficeClip API Documentation
TemplateEventMail Fields
TemplateEventMail Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateEventMail type exposes the following fields.

Fields

 | Name | Description
Public field | attachments |
Public field | eventAttendees |
Public field | eventId |
Public field | eventResources |
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | stnId | (Inherited from TemplateMail.)
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateEventMail Class
OfficeClip.BusinessLayer.Template Namespace


attachments Field

[image]

OfficeClip API Documentation
TemplateEventMail..::.attachments Field
TemplateEventMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList attachments
Visual Basic (Declaration)
Public attachments As ArrayList
Visual C++
public:
ArrayList^ attachments

See Also

TemplateEventMail Class
OfficeClip.BusinessLayer.Template Namespace


eventAttendees Field

[image]

OfficeClip API Documentation
TemplateEventMail..::.eventAttendees Field
TemplateEventMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string eventAttendees
Visual Basic (Declaration)
Public eventAttendees As String
Visual C++
public:
String^ eventAttendees

See Also

TemplateEventMail Class
OfficeClip.BusinessLayer.Template Namespace


eventId Field

[image]

OfficeClip API Documentation
TemplateEventMail..::.eventId Field
TemplateEventMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int eventId
Visual Basic (Declaration)
Public eventId As Integer
Visual C++
public:
int eventId

See Also

TemplateEventMail Class
OfficeClip.BusinessLayer.Template Namespace


eventResources Field

[image]

OfficeClip API Documentation
TemplateEventMail..::.eventResources Field
TemplateEventMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string eventResources
Visual Basic (Declaration)
Public eventResources As String
Visual C++
public:
String^ eventResources

See Also

TemplateEventMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateExtranetPublicUserMail Class

[image]

OfficeClip API Documentation
TemplateExtranetPublicUserMail Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TemplateExtranetPublicUserMail : TemplateMail
Visual Basic (Declaration)
Public Class TemplateExtranetPublicUserMail _
    Inherits TemplateMail
Visual C++
public ref class TemplateExtranetPublicUserMail : public TemplateMail

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.TemplateMail
OfficeClip.BusinessLayer.Template..::.TemplateExtranetPublicUserMail

See Also

TemplateExtranetPublicUserMail Members
OfficeClip.BusinessLayer.Template Namespace


TemplateExtranetPublicUserMail Members

[image] [image]

OfficeClip API Documentation
TemplateExtranetPublicUserMail Members
TemplateExtranetPublicUserMail Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The TemplateExtranetPublicUserMail type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateExtranetPublicUserMail |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | extranetUrl |
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | stnId | (Inherited from TemplateMail.)
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateExtranetPublicUserMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateExtranetPublicUserMail Constructor

[image]

OfficeClip API Documentation
TemplateExtranetPublicUserMail Constructor
TemplateExtranetPublicUserMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateExtranetPublicUserMail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateExtranetPublicUserMail()

See Also

TemplateExtranetPublicUserMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateExtranetPublicUserMail Fields

[image] [image]

OfficeClip API Documentation
TemplateExtranetPublicUserMail Fields
TemplateExtranetPublicUserMail Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateExtranetPublicUserMail type exposes the following fields.

Fields

 | Name | Description
Public field | extranetUrl |
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | stnId | (Inherited from TemplateMail.)
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateExtranetPublicUserMail Class
OfficeClip.BusinessLayer.Template Namespace


extranetUrl Field

[image]

OfficeClip API Documentation
TemplateExtranetPublicUserMail..::.extranetUrl Field
TemplateExtranetPublicUserMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string extranetUrl
Visual Basic (Declaration)
Public extranetUrl As String
Visual C++
public:
String^ extranetUrl

See Also

TemplateExtranetPublicUserMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateGenericMail Class

[image]

OfficeClip API Documentation
TemplateGenericMail Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TemplateGenericMail : TemplateMail
Visual Basic (Declaration)
Public Class TemplateGenericMail _
    Inherits TemplateMail
Visual C++
public ref class TemplateGenericMail : public TemplateMail

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.TemplateMail
OfficeClip.BusinessLayer.Template..::.TemplateGenericMail

See Also

TemplateGenericMail Members
OfficeClip.BusinessLayer.Template Namespace


TemplateGenericMail Members

[image] [image]

OfficeClip API Documentation
TemplateGenericMail Members
TemplateGenericMail Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The TemplateGenericMail type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateGenericMail |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | objectAdditionalInfo |
Public field | objectDescription |
Public field | objectTitle |
Public field | objectType |
Public field | stnId | (Inherited from TemplateMail.)
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateGenericMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateGenericMail Constructor

[image]

OfficeClip API Documentation
TemplateGenericMail Constructor
TemplateGenericMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateGenericMail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateGenericMail()

See Also

TemplateGenericMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateGenericMail Fields

[image] [image]

OfficeClip API Documentation
TemplateGenericMail Fields
TemplateGenericMail Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateGenericMail type exposes the following fields.

Fields

 | Name | Description
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | objectAdditionalInfo |
Public field | objectDescription |
Public field | objectTitle |
Public field | objectType |
Public field | stnId | (Inherited from TemplateMail.)
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateGenericMail Class
OfficeClip.BusinessLayer.Template Namespace


objectAdditionalInfo Field

[image]

OfficeClip API Documentation
TemplateGenericMail..::.objectAdditionalInfo Field
TemplateGenericMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string objectAdditionalInfo
Visual Basic (Declaration)
Public objectAdditionalInfo As String
Visual C++
public:
String^ objectAdditionalInfo

See Also

TemplateGenericMail Class
OfficeClip.BusinessLayer.Template Namespace


objectDescription Field

[image]

OfficeClip API Documentation
TemplateGenericMail..::.objectDescription Field
TemplateGenericMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string objectDescription
Visual Basic (Declaration)
Public objectDescription As String
Visual C++
public:
String^ objectDescription

See Also

TemplateGenericMail Class
OfficeClip.BusinessLayer.Template Namespace


objectTitle Field

[image]

OfficeClip API Documentation
TemplateGenericMail..::.objectTitle Field
TemplateGenericMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string objectTitle
Visual Basic (Declaration)
Public objectTitle As String
Visual C++
public:
String^ objectTitle

See Also

TemplateGenericMail Class
OfficeClip.BusinessLayer.Template Namespace


objectType Field

[image]

OfficeClip API Documentation
TemplateGenericMail..::.objectType Field
TemplateGenericMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string objectType
Visual Basic (Declaration)
Public objectType As String
Visual C++
public:
String^ objectType

See Also

TemplateGenericMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateInfo Class

[image]

OfficeClip API Documentation
TemplateInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Description of the Class TemplateInfo

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class TemplateInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class TemplateInfo
Visual C++
[SerializableAttribute]
public ref class TemplateInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.TemplateInfo

See Also

TemplateInfo Members
OfficeClip.BusinessLayer.Template Namespace


TemplateInfo Members

[image] [image]

OfficeClip API Documentation
TemplateInfo Members
TemplateInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TemplateInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId |
Public property | Category |
Public property | CreatedByTimestamp |
Public property | CreatedByUserId |
Public property | Description |
Public property | GroupId |
Public property | Html |
Public property | IsActive | True if the template is active
Public property | IsHtml |
Public property | LastUpdatedTimestamp |
Public property | LastUpdatedUserId |
Public property | Name |
Public property | Subject |
Public property | TemplateId |
Public property | TemplateType |
Public property | Text |
Public property | UserId |

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


TemplateInfo Constructor

[image] [image]

OfficeClip API Documentation
TemplateInfo Constructor
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TemplateInfo()()() | The default constructor
Public method | TemplateInfo(Int32, Decimal, Decimal, Decimal, TemplateType, Category, Boolean, String, String, String, String, String, Int32, DateTime, Int32, DateTime, Boolean) | Constructor

See Also

TemplateInfo Class
TemplateInfo Members
OfficeClip.BusinessLayer.Template Namespace


TemplateInfo Constructor

[image]

OfficeClip API Documentation
TemplateInfo Constructor
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateInfo()

See Also

TemplateInfo Class
TemplateInfo Overload
OfficeClip.BusinessLayer.Template Namespace


TemplateInfo Constructor (Int32, Decimal, Decimal, Decimal, TemplateType, Category, Boolean, String, String, String, String, String, Int32, DateTime, Int32, DateTime, Boolean)

[image]

OfficeClip API Documentation
TemplateInfo Constructor (Int32, Decimal, Decimal, Decimal, TemplateType, Category, Boolean, String, String, String, String, String, Int32, DateTime, Int32, DateTime, Boolean)
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateInfo(
    int templateId,
    decimal accountId,
    decimal groupId,
    decimal userId,
    TemplateType templateType,
    Category category,
    bool isHtml,
    string name,
    string description,
    string subject,
    string html,
    string text,
    int createdByUserId,
    DateTime createdByTimestamp,
    int lastUpdatedUserId,
    DateTime lastUpdatedTimestamp,
    bool isActive
)
Visual Basic (Declaration)
Public Sub New ( _
    templateId As Integer, _
    accountId As Decimal, _
    groupId As Decimal, _
    userId As Decimal, _
    templateType As TemplateType, _
    category As Category, _
    isHtml As Boolean, _
    name As String, _
    description As String, _
    subject As String, _
    html As String, _
    text As String, _
    createdByUserId As Integer, _
    createdByTimestamp As DateTime, _
    lastUpdatedUserId As Integer, _
    lastUpdatedTimestamp As DateTime, _
    isActive As Boolean _
)
Visual C++
public:
TemplateInfo(
    int templateId,
    Decimal accountId,
    Decimal groupId,
    Decimal userId,
    TemplateType templateType,
    Category category,
    bool isHtml,
    String^ name,
    String^ description,
    String^ subject,
    String^ html,
    String^ text,
    int createdByUserId,
    DateTime createdByTimestamp,
    int lastUpdatedUserId,
    DateTime lastUpdatedTimestamp,
    bool isActive
)

Parameters

templateId
Type: System..::.Int32
The unique id of the constructor
accountId
Type: System..::.Decimal
The unique id of the account
groupId
Type: System..::.Decimal
The unique id of the group
userId
Type: System..::.Decimal
The unique id of the user
templateType
Type: OfficeClip.BusinessLayer.Template..::.TemplateType
The template type enumerated type
category
Type: OfficeClip.BusinessLayer.Template..::.Category
The category enumerated type
isHtml
Type: System..::.Boolean
true if the template is an html template, false if it is a text template
name
Type: System..::.String
the name of the template
description
Type: System..::.String
The description of the template
subject
Type: System..::.String
The subject of the tempalte
html
Type: System..::.String
The html part of the template
text
Type: System..::.String
The text part of teh template
createdByUserId
Type: System..::.Int32
The unique id of the creator
createdByTimestamp
Type: System..::.DateTime
the created by timestamp
lastUpdatedUserId
Type: System..::.Int32
the unique id of the last updated user
lastUpdatedTimestamp
Type: System..::.DateTime
the last updated timestamp
isActive
Type: System..::.Boolean
true if active

See Also

TemplateInfo Class
TemplateInfo Overload
OfficeClip.BusinessLayer.Template Namespace


TemplateInfo Properties

[image] [image]

OfficeClip API Documentation
TemplateInfo Properties
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId |
Public property | Category |
Public property | CreatedByTimestamp |
Public property | CreatedByUserId |
Public property | Description |
Public property | GroupId |
Public property | Html |
Public property | IsActive | True if the template is active
Public property | IsHtml |
Public property | LastUpdatedTimestamp |
Public property | LastUpdatedUserId |
Public property | Name |
Public property | Subject |
Public property | TemplateId |
Public property | TemplateType |
Public property | Text |
Public property | UserId |

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


AccountId Property

[image]

OfficeClip API Documentation
TemplateInfo..::.AccountId Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public decimal AccountId { get; set; }
Visual Basic (Declaration)
Public Property AccountId As Decimal
Visual C++
public:
property Decimal AccountId {
    Decimal get ();
    void set (Decimal value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


Category Property

[image]

OfficeClip API Documentation
TemplateInfo..::.Category Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Category Category { get; set; }
Visual Basic (Declaration)
Public Property Category As Category
Visual C++
public:
property Category Category {
    Category get ();
    void set (Category value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


CreatedByTimestamp Property

[image]

OfficeClip API Documentation
TemplateInfo..::.CreatedByTimestamp Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedByTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedByTimestamp As DateTime
Visual C++
public:
property DateTime CreatedByTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


CreatedByUserId Property

[image]

OfficeClip API Documentation
TemplateInfo..::.CreatedByUserId Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedByUserId { get; set; }
Visual Basic (Declaration)
Public Property CreatedByUserId As Integer
Visual C++
public:
property int CreatedByUserId {
    int get ();
    void set (int value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


Description Property

[image]

OfficeClip API Documentation
TemplateInfo..::.Description Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


GroupId Property

[image]

OfficeClip API Documentation
TemplateInfo..::.GroupId Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public decimal GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Decimal
Visual C++
public:
property Decimal GroupId {
    Decimal get ();
    void set (Decimal value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


Html Property

[image]

OfficeClip API Documentation
TemplateInfo..::.Html Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Html { get; set; }
Visual Basic (Declaration)
Public Property Html As String
Visual C++
public:
property String^ Html {
    String^ get ();
    void set (String^ value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


IsActive Property

[image]

OfficeClip API Documentation
TemplateInfo..::.IsActive Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

True if the template is active

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As Boolean
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


IsHtml Property

[image]

OfficeClip API Documentation
TemplateInfo..::.IsHtml Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsHtml { get; set; }
Visual Basic (Declaration)
Public Property IsHtml As Boolean
Visual C++
public:
property bool IsHtml {
    bool get ();
    void set (bool value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


LastUpdatedTimestamp Property

[image]

OfficeClip API Documentation
TemplateInfo..::.LastUpdatedTimestamp Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime LastUpdatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedTimestamp As DateTime
Visual C++
public:
property DateTime LastUpdatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


LastUpdatedUserId Property

[image]

OfficeClip API Documentation
TemplateInfo..::.LastUpdatedUserId Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LastUpdatedUserId { get; set; }
Visual Basic (Declaration)
Public Property LastUpdatedUserId As Integer
Visual C++
public:
property int LastUpdatedUserId {
    int get ();
    void set (int value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


Name Property

[image]

OfficeClip API Documentation
TemplateInfo..::.Name Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


Subject Property

[image]

OfficeClip API Documentation
TemplateInfo..::.Subject Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Subject { get; set; }
Visual Basic (Declaration)
Public Property Subject As String
Visual C++
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


TemplateId Property

[image]

OfficeClip API Documentation
TemplateInfo..::.TemplateId Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TemplateId { get; set; }
Visual Basic (Declaration)
Public Property TemplateId As Integer
Visual C++
public:
property int TemplateId {
    int get ();
    void set (int value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


TemplateType Property

[image]

OfficeClip API Documentation
TemplateInfo..::.TemplateType Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateType TemplateType { get; set; }
Visual Basic (Declaration)
Public Property TemplateType As TemplateType
Visual C++
public:
property TemplateType TemplateType {
    TemplateType get ();
    void set (TemplateType value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


Text Property

[image]

OfficeClip API Documentation
TemplateInfo..::.Text Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


UserId Property

[image]

OfficeClip API Documentation
TemplateInfo..::.UserId Property
TemplateInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public decimal UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Decimal
Visual C++
public:
property Decimal UserId {
    Decimal get ();
    void set (Decimal value);
}

See Also

TemplateInfo Class
OfficeClip.BusinessLayer.Template Namespace


TemplateIssueTrackerMail Class

[image]

OfficeClip API Documentation
TemplateIssueTrackerMail Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TemplateIssueTrackerMail : TemplateMail
Visual Basic (Declaration)
Public Class TemplateIssueTrackerMail _
    Inherits TemplateMail
Visual C++
public ref class TemplateIssueTrackerMail : public TemplateMail

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.TemplateMail
OfficeClip.BusinessLayer.Template..::.TemplateIssueTrackerMail

See Also

TemplateIssueTrackerMail Members
OfficeClip.BusinessLayer.Template Namespace


TemplateIssueTrackerMail Members

[image] [image]

OfficeClip API Documentation
TemplateIssueTrackerMail Members
TemplateIssueTrackerMail Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The TemplateIssueTrackerMail type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateIssueTrackerMail |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | attachments |
Public field | caseDetail |
Public field | caseNum |
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | stnId | (Inherited from TemplateMail.)
Public field | subject |
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateIssueTrackerMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateIssueTrackerMail Constructor

[image]

OfficeClip API Documentation
TemplateIssueTrackerMail Constructor
TemplateIssueTrackerMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateIssueTrackerMail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateIssueTrackerMail()

See Also

TemplateIssueTrackerMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateIssueTrackerMail Fields

[image] [image]

OfficeClip API Documentation
TemplateIssueTrackerMail Fields
TemplateIssueTrackerMail Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateIssueTrackerMail type exposes the following fields.

Fields

 | Name | Description
Public field | attachments |
Public field | caseDetail |
Public field | caseNum |
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | stnId | (Inherited from TemplateMail.)
Public field | subject |
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateIssueTrackerMail Class
OfficeClip.BusinessLayer.Template Namespace


attachments Field

[image]

OfficeClip API Documentation
TemplateIssueTrackerMail..::.attachments Field
TemplateIssueTrackerMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList attachments
Visual Basic (Declaration)
Public attachments As ArrayList
Visual C++
public:
ArrayList^ attachments

See Also

TemplateIssueTrackerMail Class
OfficeClip.BusinessLayer.Template Namespace


caseDetail Field

[image]

OfficeClip API Documentation
TemplateIssueTrackerMail..::.caseDetail Field
TemplateIssueTrackerMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string caseDetail
Visual Basic (Declaration)
Public caseDetail As String
Visual C++
public:
String^ caseDetail

See Also

TemplateIssueTrackerMail Class
OfficeClip.BusinessLayer.Template Namespace


caseNum Field

[image]

OfficeClip API Documentation
TemplateIssueTrackerMail..::.caseNum Field
TemplateIssueTrackerMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string caseNum
Visual Basic (Declaration)
Public caseNum As String
Visual C++
public:
String^ caseNum

See Also

TemplateIssueTrackerMail Class
OfficeClip.BusinessLayer.Template Namespace


subject Field

[image]

OfficeClip API Documentation
TemplateIssueTrackerMail..::.subject Field
TemplateIssueTrackerMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string subject
Visual Basic (Declaration)
Public subject As String
Visual C++
public:
String^ subject

See Also

TemplateIssueTrackerMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateMail Class

[image]

OfficeClip API Documentation
TemplateMail Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TemplateMail
Visual Basic (Declaration)
Public Class TemplateMail
Visual C++
public ref class TemplateMail

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.TemplateMail
OfficeClip.BusinessLayer.Template..::.TemplateTimeAndExpensesMail
OfficeClip.BusinessLayer.Template..::.TemplateExtranetPublicUserMail
OfficeClip.BusinessLayer.Template..::.TemplateAnnounceMail
OfficeClip.BusinessLayer.Template..::.TemplateIssueTrackerMail
OfficeClip.BusinessLayer.Template..::.TemplateBulletingBoardMail
OfficeClip.BusinessLayer.Template..::.TemplateGenericMail
OfficeClip.BusinessLayer.Template..::.TemplateEventMail

See Also

TemplateMail Members
OfficeClip.BusinessLayer.Template Namespace


TemplateMail Members

[image] [image]

OfficeClip API Documentation
TemplateMail Members
TemplateMail Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The TemplateMail type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateMail |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | fromEmail |
Public field | fromName |
Public field | groupId |
Public field | stnId |
Public field | toEmail |
Public field | toName |
Public field | userId |

See Also

TemplateMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateMail Constructor

[image]

OfficeClip API Documentation
TemplateMail Constructor
TemplateMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateMail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateMail()

See Also

TemplateMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateMail Fields

[image] [image]

OfficeClip API Documentation
TemplateMail Fields
TemplateMail Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateMail type exposes the following fields.

Fields

 | Name | Description
Public field | fromEmail |
Public field | fromName |
Public field | groupId |
Public field | stnId |
Public field | toEmail |
Public field | toName |
Public field | userId |

See Also

TemplateMail Class
OfficeClip.BusinessLayer.Template Namespace


fromEmail Field

[image]

OfficeClip API Documentation
TemplateMail..::.fromEmail Field
TemplateMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string fromEmail
Visual Basic (Declaration)
Public fromEmail As String
Visual C++
public:
String^ fromEmail

See Also

TemplateMail Class
OfficeClip.BusinessLayer.Template Namespace


fromName Field

[image]

OfficeClip API Documentation
TemplateMail..::.fromName Field
TemplateMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string fromName
Visual Basic (Declaration)
Public fromName As String
Visual C++
public:
String^ fromName

See Also

TemplateMail Class
OfficeClip.BusinessLayer.Template Namespace


groupId Field

[image]

OfficeClip API Documentation
TemplateMail..::.groupId Field
TemplateMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int groupId
Visual Basic (Declaration)
Public groupId As Integer
Visual C++
public:
int groupId

See Also

TemplateMail Class
OfficeClip.BusinessLayer.Template Namespace


stnId Field

[image]

OfficeClip API Documentation
TemplateMail..::.stnId Field
TemplateMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateNameId stnId
Visual Basic (Declaration)
Public stnId As TemplateNameId
Visual C++
public:
TemplateNameId stnId

See Also

TemplateMail Class
OfficeClip.BusinessLayer.Template Namespace


toEmail Field

[image]

OfficeClip API Documentation
TemplateMail..::.toEmail Field
TemplateMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string toEmail
Visual Basic (Declaration)
Public toEmail As String
Visual C++
public:
String^ toEmail

See Also

TemplateMail Class
OfficeClip.BusinessLayer.Template Namespace


toName Field

[image]

OfficeClip API Documentation
TemplateMail..::.toName Field
TemplateMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string toName
Visual Basic (Declaration)
Public toName As String
Visual C++
public:
String^ toName

See Also

TemplateMail Class
OfficeClip.BusinessLayer.Template Namespace


userId Field

[image]

OfficeClip API Documentation
TemplateMail..::.userId Field
TemplateMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int userId
Visual Basic (Declaration)
Public userId As Integer
Visual C++
public:
int userId

See Also

TemplateMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateMailInfo Class

[image]

OfficeClip API Documentation
TemplateMailInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TemplateMailInfo
Visual Basic (Declaration)
Public Class TemplateMailInfo
Visual C++
public ref class TemplateMailInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.TemplateMailInfo

See Also

TemplateMailInfo Members
OfficeClip.BusinessLayer.Template Namespace


TemplateMailInfo Members

[image] [image]

OfficeClip API Documentation
TemplateMailInfo Members
TemplateMailInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TemplateMailInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateMailInfo |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdminEmailAddress |
Public property | Connstring |
Public property | HostStr |
Public property | HostUrl |
Public property | InfoList |
Public property | Session |
Public property | TemplateId |
Public property | TemplateTypeId |
Public property | UniqueId |

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


TemplateMailInfo Constructor

[image]

OfficeClip API Documentation
TemplateMailInfo Constructor
TemplateMailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateMailInfo(
    ConfigureInfo session,
    string hostUrl,
    string hostStr,
    string uniqueId,
    string adminEmailId,
    string connString,
    int templateId,
    int templateTypeId,
    ArrayList infoList
)
Visual Basic (Declaration)
Public Sub New ( _
    session As ConfigureInfo, _
    hostUrl As String, _
    hostStr As String, _
    uniqueId As String, _
    adminEmailId As String, _
    connString As String, _
    templateId As Integer, _
    templateTypeId As Integer, _
    infoList As ArrayList _
)
Visual C++
public:
TemplateMailInfo(
    ConfigureInfo^ session,
    String^ hostUrl,
    String^ hostStr,
    String^ uniqueId,
    String^ adminEmailId,
    String^ connString,
    int templateId,
    int templateTypeId,
    ArrayList^ infoList
)

Parameters

session
Type: OfficeClip.Utils..::.ConfigureInfo
hostUrl
Type: System..::.String
hostStr
Type: System..::.String
uniqueId
Type: System..::.String
adminEmailId
Type: System..::.String
connString
Type: System..::.String
templateId
Type: System..::.Int32
templateTypeId
Type: System..::.Int32
infoList
Type: System.Collections..::.ArrayList

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


TemplateMailInfo Properties

[image] [image]

OfficeClip API Documentation
TemplateMailInfo Properties
TemplateMailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateMailInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AdminEmailAddress |
Public property | Connstring |
Public property | HostStr |
Public property | HostUrl |
Public property | InfoList |
Public property | Session |
Public property | TemplateId |
Public property | TemplateTypeId |
Public property | UniqueId |

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


AdminEmailAddress Property

[image]

OfficeClip API Documentation
TemplateMailInfo..::.AdminEmailAddress Property
TemplateMailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AdminEmailAddress { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdminEmailAddress As String
Visual C++
public:
property String^ AdminEmailAddress {
    String^ get ();
}

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


Connstring Property

[image]

OfficeClip API Documentation
TemplateMailInfo..::.Connstring Property
TemplateMailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Connstring { get; }
Visual Basic (Declaration)
Public ReadOnly Property Connstring As String
Visual C++
public:
property String^ Connstring {
    String^ get ();
}

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


HostStr Property

[image]

OfficeClip API Documentation
TemplateMailInfo..::.HostStr Property
TemplateMailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string HostStr { get; }
Visual Basic (Declaration)
Public ReadOnly Property HostStr As String
Visual C++
public:
property String^ HostStr {
    String^ get ();
}

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


HostUrl Property

[image]

OfficeClip API Documentation
TemplateMailInfo..::.HostUrl Property
TemplateMailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string HostUrl { get; }
Visual Basic (Declaration)
Public ReadOnly Property HostUrl As String
Visual C++
public:
property String^ HostUrl {
    String^ get ();
}

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


InfoList Property

[image]

OfficeClip API Documentation
TemplateMailInfo..::.InfoList Property
TemplateMailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList InfoList { get; }
Visual Basic (Declaration)
Public ReadOnly Property InfoList As ArrayList
Visual C++
public:
property ArrayList^ InfoList {
    ArrayList^ get ();
}

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


Session Property

[image]

OfficeClip API Documentation
TemplateMailInfo..::.Session Property
TemplateMailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public ConfigureInfo Session { get; }
Visual Basic (Declaration)
Public ReadOnly Property Session As ConfigureInfo
Visual C++
public:
property ConfigureInfo^ Session {
    ConfigureInfo^ get ();
}

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


TemplateId Property

[image]

OfficeClip API Documentation
TemplateMailInfo..::.TemplateId Property
TemplateMailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TemplateId { get; }
Visual Basic (Declaration)
Public ReadOnly Property TemplateId As Integer
Visual C++
public:
property int TemplateId {
    int get ();
}

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


TemplateTypeId Property

[image]

OfficeClip API Documentation
TemplateMailInfo..::.TemplateTypeId Property
TemplateMailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int TemplateTypeId { get; }
Visual Basic (Declaration)
Public ReadOnly Property TemplateTypeId As Integer
Visual C++
public:
property int TemplateTypeId {
    int get ();
}

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


UniqueId Property

[image]

OfficeClip API Documentation
TemplateMailInfo..::.UniqueId Property
TemplateMailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UniqueId { get; }
Visual Basic (Declaration)
Public ReadOnly Property UniqueId As String
Visual C++
public:
property String^ UniqueId {
    String^ get ();
}

See Also

TemplateMailInfo Class
OfficeClip.BusinessLayer.Template Namespace


TemplateNameId Enumeration

[image]

OfficeClip API Documentation
TemplateNameId Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The template name id enumerated type

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum TemplateNameId
Visual Basic (Declaration)
Public Enumeration TemplateNameId
Visual C++
public enum class TemplateNameId

Members

Member name | Description
None | No template name id
NotifyNewGroupEvent | Notify new group event template name
NotifyUpdateGroupEvent | Notify update group event template name
AnnounceCreation | Announcement creation template name
CreateAnotherGroup | Cration of a new group template name
TimeExpenseApproveReject | Timesheet and expense report approve and reject template name
TimeExpenseNotifySubmitted | Timesheet and Expense report submitted notification template name
ExternalForgotPassword | External email forgot password template name
ForumIsEdited | Forum is edited template name
ShareDocumentsWithCode | Share document with code template name
ShareDocumentsWithoutCode | Share document without code template name
GrantAdminPrivelege | Grant administrative privelege template name
RevokeAdminPrivelege | Revoke administrator privelege template name
InviteMemberInGroup | Invite member in group template name
InviteAlreadyRegisteredMemberInGroup | Invite already registered member in group template name
InviteLDAPMemberInGroup | Invite LDAP member in group template name
InviteAlreadyRegisteredLDAPMemberInGroup | Invite already registered LDAP member in group template name
InviteNewMeetingExternalMember | Invite new external member template name
InviteNewMeetingOfficeClipMember | Invite new OfficeClip member template name
UpdateMeetingExternalMember | Update meeting external member template name
UpdateMeetingOfficeClipMember | Update meeting OfficeClip member template name
RemoveUser | Remove user template name
RemoveMeeting | Remove meeting template name
ForumIsCreated | Forum is created template name
NewTopic | New topic template name
NotifyObjectAssignment | Notify object assignment template name
NotifyObjectOwnership | Notify object ownership template name
NotifyReplyPosted | Notify reply posted template name
ReinviteRegisteredMember | Reinvite registered members template name
ReinviteUnRegisteredMember | Reinvite unregistered members template name
RejectGroupInvitation | Reject group invitation template name
ResetPassword | Reset password template name
TrackerEmailForward | tracker email forward template name
TrackerEmailFromRules | Tracker email from rules template name
TimeExpenseSubmissionStatus | Timesheet Submission Status template name
NewExtranetUserCreation | Template when a new extranet user is created
UpdateExtranetPassword | Template when the extranet user data is changed
ExtranetUserIssueTrackerPublicEmail | Template when the public issue tracker email is sent
ExtranetUserIssueTrackerPublicEmailWithTracking | Template when the public issue tracker email is sent with tracking
ExtranetUserIssueTrackerSecuredEmail | Template when the public issue tracker email is sent
ExtranetCalendarRequestEvent | Template to send email when calendar event is requested
NewExtranetPublicNotification | Template to notify public users regarding the presence of extranet
AnnounceEdit | Editing of an announcement
CustomerPortalResetPassword | Email Template for resetting the password of a Extranet user.

See Also

OfficeClip.BusinessLayer.Template Namespace


TemplateTimeAndExpensesMail Class

[image]

OfficeClip API Documentation
TemplateTimeAndExpensesMail Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TemplateTimeAndExpensesMail : TemplateMail
Visual Basic (Declaration)
Public Class TemplateTimeAndExpensesMail _
    Inherits TemplateMail
Visual C++
public ref class TemplateTimeAndExpensesMail : public TemplateMail

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Template..::.TemplateMail
OfficeClip.BusinessLayer.Template..::.TemplateTimeAndExpensesMail

See Also

TemplateTimeAndExpensesMail Members
OfficeClip.BusinessLayer.Template Namespace


TemplateTimeAndExpensesMail Members

[image] [image]

OfficeClip API Documentation
TemplateTimeAndExpensesMail Members
TemplateTimeAndExpensesMail Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The TemplateTimeAndExpensesMail type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateTimeAndExpensesMail |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | isTimesheet |
Public field | periodStarting |
Public field | status |
Public field | stnId | (Inherited from TemplateMail.)
Public field | submittedBy |
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateTimeAndExpensesMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateTimeAndExpensesMail Constructor

[image]

OfficeClip API Documentation
TemplateTimeAndExpensesMail Constructor
TemplateTimeAndExpensesMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateTimeAndExpensesMail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateTimeAndExpensesMail()

See Also

TemplateTimeAndExpensesMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateTimeAndExpensesMail Fields

[image] [image]

OfficeClip API Documentation
TemplateTimeAndExpensesMail Fields
TemplateTimeAndExpensesMail Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateTimeAndExpensesMail type exposes the following fields.

Fields

 | Name | Description
Public field | fromEmail | (Inherited from TemplateMail.)
Public field | fromName | (Inherited from TemplateMail.)
Public field | groupId | (Inherited from TemplateMail.)
Public field | isTimesheet |
Public field | periodStarting |
Public field | status |
Public field | stnId | (Inherited from TemplateMail.)
Public field | submittedBy |
Public field | toEmail | (Inherited from TemplateMail.)
Public field | toName | (Inherited from TemplateMail.)
Public field | userId | (Inherited from TemplateMail.)

See Also

TemplateTimeAndExpensesMail Class
OfficeClip.BusinessLayer.Template Namespace


isTimesheet Field

[image]

OfficeClip API Documentation
TemplateTimeAndExpensesMail..::.isTimesheet Field
TemplateTimeAndExpensesMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool isTimesheet
Visual Basic (Declaration)
Public isTimesheet As Boolean
Visual C++
public:
bool isTimesheet

See Also

TemplateTimeAndExpensesMail Class
OfficeClip.BusinessLayer.Template Namespace


periodStarting Field

[image]

OfficeClip API Documentation
TemplateTimeAndExpensesMail..::.periodStarting Field
TemplateTimeAndExpensesMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string periodStarting
Visual Basic (Declaration)
Public periodStarting As String
Visual C++
public:
String^ periodStarting

See Also

TemplateTimeAndExpensesMail Class
OfficeClip.BusinessLayer.Template Namespace


status Field

[image]

OfficeClip API Documentation
TemplateTimeAndExpensesMail..::.status Field
TemplateTimeAndExpensesMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string status
Visual Basic (Declaration)
Public status As String
Visual C++
public:
String^ status

See Also

TemplateTimeAndExpensesMail Class
OfficeClip.BusinessLayer.Template Namespace


submittedBy Field

[image]

OfficeClip API Documentation
TemplateTimeAndExpensesMail..::.submittedBy Field
TemplateTimeAndExpensesMail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string submittedBy
Visual Basic (Declaration)
Public submittedBy As String
Visual C++
public:
String^ submittedBy

See Also

TemplateTimeAndExpensesMail Class
OfficeClip.BusinessLayer.Template Namespace


TemplateType Enumeration

[image]

OfficeClip API Documentation
TemplateType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The template type enumerated type

Namespace: OfficeClip.BusinessLayer.Template
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public enum TemplateType
Visual Basic (Declaration)
Public Enumeration TemplateType
Visual C++
public enum class TemplateType

Members

Member name | Description
None | no template type
CalendarEvent | The calendar event template type
Announcement | The announcement template type
Group | The group template type
Password | The password template type
DocumentShare | The document share template type
BulletinBoardForum | The bulletin board forum template type
LDAP | The LDAP template type
BulletinBoardTopic | The bulletin board template type
GenericObject | The generic object template type
BulletinBoardReply | The bulletin board reply template type
TimeAndExpenses | The time and expenses template type
UserDetail | Teh user detail template type
Poll | The poll template type
IssueTracker | The issue tracker template type
ContactManager | The contact manager template type
AddMember | The invite member template type
InviteLDAPMember | The invite LDAP member template type
ExtranetAdmin | The template for the mail that is sent by the extranet administrators
ExtranetUsersTracker | The template for the mail that is sent by the extranet users
ExtranetRequestCalendarEvent | Requests calendar Events
ExtranetPublicInformation | Send extranet notification to public
CustomerPortalPassword |
CampaignMail | Campaign Mail

See Also

OfficeClip.BusinessLayer.Template Namespace


OfficeClip.BusinessLayer.Tracker Namespace

[image]

OfficeClip API Documentation
OfficeClip.BusinessLayer.Tracker Namespace

[This is preliminary documentation and is subject to change.]

Business Layer for issue tracker

Classes

 | Class | Description
Public class | TrackerCaseInfo | Provides members and properties to access the tracker case information.
Public class | TrackerCaseListInfo | Provides a business layer interface to the tracker caseList screen
Public class | TrackerEmailInfo | Provides members and properties to access the tracker email information.
Public class | TrackerEmailMessageId | Provides members and properties to access the tracker email message id.
Public class | TrackerKBInfo | Provides members and properties to access the tracker knowledge base field information.
Public class | TrackerProjectInfo | Provide the methods and properties for the tracker Project information.
Public class | TrackerQueryInfo | This class provides a business layer interface to the tracker caseList screen


TrackerCaseInfo Class

[image]

OfficeClip API Documentation
TrackerCaseInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides members and properties to access the tracker case information.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerCaseInfo
Visual Basic (Declaration)
Public Class TrackerCaseInfo
Visual C++
public ref class TrackerCaseInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Tracker..::.TrackerCaseInfo

See Also

TrackerCaseInfo Members
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseInfo Members

[image] [image]

OfficeClip API Documentation
TrackerCaseInfo Members
TrackerCaseInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerCaseInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerCaseInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets an enumerator to enumerate through all the user defined fields.
Public method | GetFieldValue | Gets the field value depending on the fieldid that is selected
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSortedKeys | Gets the sorted keys
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUdf | Gets the user defined field value of a particular field in this case.
Public method | IsUdfPresent | Shows if the udf (user defined field) is present
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetUdf | Sets an user defined field for this case.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UdfCount | Gets the count of the total number of elements in the tracker case. This includes the udf and fixed fields.

Properties

 | Name | Description
Public property | AssignedEmailAddress | The email address of the assigned to user
Public property | AssignedId | The id of the Assigned to user
Public property | AssignedName | The name of the assigned to user
Public property | CaseId | The system generated unique identifier for the tracker case.
Public property | CaseNum | The case number of the case.
Public property | Category | The Category value of the case.
Public property | CategoryId | The system generated unique identifier for the Category of the case.
Public property | Comments | the Comments of the case.
Public property | CreatedByEmailAddress | The email Address of the user who created the case.
Public property | CreatedById | The user identifier of the creator of the case.
Public property | CreatedByName | The name of the creator of the case.
Public property | CreatedDate | the created date for the case.
Public property | Criticality | The Criticality value for the case.
Public property | CriticalityId | The system generated unique identifier for the Criticality of the case.
Public property | Description | The Description of the case.
Public property | ExternalEmailAddress | The external email Address of the user who created the case. This is the email of the user if the user has created the case without logging into OfficeClip.
Public property | IsActive | Shows whether the tracker case is Active or archived. The value is true if Active and false if archived.
Public property | IsExternal | Shows if the creator of the case is an external user. That is if the user has created the case without logging into OfficeClip.
Public property | kind | The kind value of the case.
Public property | KindId | The system generated unique identifier for the kind of the case.
Public property | ModifiedByEmailAddress | The email Address of the user who last modified the case.
Public property | ModifiedById | The user identifier of the user who last modified the case.
Public property | ModifiedByName | The name of the user who last modified the case.
Public property | ModifiedDate | The date on which the case was last modified.
Public property | ObjectId | The object id
Public property | ObjectTypeId | The object type id
Public property | RegardingName | The regarding name
Public property | Resolution | The Resolution of the case.
Public property | Status | The status name for the case.
Public property | StatusId | The system generated unique identifier for the case status.
Public property | Title | The Title of the case.
Public property | Udfs | Returns the udf hashtable, the key is the id of the udf and the value is the value of udf in string

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseInfo Constructor

[image] [image]

OfficeClip API Documentation
TrackerCaseInfo Constructor
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TrackerCaseInfo()()() | The default constructor.
Public method | TrackerCaseInfo(SqlDataReader) | Constructor that uses the SqlDataReader populated from the database.
Public method | TrackerCaseInfo(SqlDataReader, Boolean) | Constructor that uses the SqlDataReader populated from the database and the if the session is available. The session is not available if the tracker cases are entered from a web page (in CRM) as opposed to from the tracker application screen.

See Also

TrackerCaseInfo Class
TrackerCaseInfo Members
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseInfo Constructor

[image]

OfficeClip API Documentation
TrackerCaseInfo Constructor
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerCaseInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerCaseInfo()

See Also

TrackerCaseInfo Class
TrackerCaseInfo Overload
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseInfo Constructor (SqlDataReader)

[image]

OfficeClip API Documentation
TrackerCaseInfo Constructor (SqlDataReader)
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that uses the SqlDataReader populated from the database.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerCaseInfo(
    SqlDataReader sdr
)
Visual Basic (Declaration)
Public Sub New ( _
    sdr As SqlDataReader _
)
Visual C++
public:
TrackerCaseInfo(
    SqlDataReader^ sdr
)

Parameters

sdr
Type: System.Data.SqlClient..::.SqlDataReader
the sql data reader populated from the database.

See Also

TrackerCaseInfo Class
TrackerCaseInfo Overload
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseInfo Constructor (SqlDataReader, Boolean)

[image]

OfficeClip API Documentation
TrackerCaseInfo Constructor (SqlDataReader, Boolean)
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that uses the SqlDataReader populated from the database and the if the session is available. The session is not available if the tracker cases are entered from a web page (in CRM) as opposed to from the tracker application screen.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerCaseInfo(
    SqlDataReader sdr,
    bool isSessionAvailable
)
Visual Basic (Declaration)
Public Sub New ( _
    sdr As SqlDataReader, _
    isSessionAvailable As Boolean _
)
Visual C++
public:
TrackerCaseInfo(
    SqlDataReader^ sdr,
    bool isSessionAvailable
)

Parameters

sdr
Type: System.Data.SqlClient..::.SqlDataReader
The sql data reader populated from the database.
isSessionAvailable
Type: System..::.Boolean
whether the session is available.

See Also

TrackerCaseInfo Class
TrackerCaseInfo Overload
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseInfo Methods

[image] [image]

OfficeClip API Documentation
TrackerCaseInfo Methods
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerCaseInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Gets an enumerator to enumerate through all the user defined fields.
Public method | GetFieldValue | Gets the field value depending on the fieldid that is selected
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSortedKeys | Gets the sorted keys
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUdf | Gets the user defined field value of a particular field in this case.
Public method | IsUdfPresent | Shows if the udf (user defined field) is present
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetUdf | Sets an user defined field for this case.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UdfCount | Gets the count of the total number of elements in the tracker case. This includes the udf and fixed fields.

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetEnumerator Method

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.GetEnumerator Method
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets an enumerator to enumerate through all the user defined fields.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public IDictionaryEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IDictionaryEnumerator
Visual C++
public:
IDictionaryEnumerator^ GetEnumerator()

Return Value

The user defined fields enumerator.

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetFieldValue Method

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.GetFieldValue Method
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the field value depending on the fieldid that is selected

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetFieldValue(
    TrackerFieldsNameId fieldId
)
Visual Basic (Declaration)
Public Function GetFieldValue ( _
    fieldId As TrackerFieldsNameId _
) As String
Visual C++
public:
String^ GetFieldValue(
    TrackerFieldsNameId fieldId
)

Parameters

fieldId
Type: OfficeClip.Utils..::.TrackerFieldsNameId
The id of the field TrackerFieldsNameId

Return Value

The string value of the field

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetSortedKeys Method

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.GetSortedKeys Method
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the sorted keys

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int[] GetSortedKeys()
Visual Basic (Declaration)
Public Function GetSortedKeys As Integer()
Visual C++
public:
array<int>^ GetSortedKeys()

Return Value

The array of the sorted keys

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetUdf Method

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.GetUdf Method
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the user defined field value of a particular field in this case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetUdf(
    int udfNum
)
Visual Basic (Declaration)
Public Function GetUdf ( _
    udfNum As Integer _
) As String
Visual C++
public:
String^ GetUdf(
    int udfNum
)

Parameters

udfNum
Type: System..::.Int32
The user defined field number.

Return Value

The user defined field value.

Exceptions

Exception | Condition
OfficeClip.Utils..::.OCException |

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


IsUdfPresent Method

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.IsUdfPresent Method
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the udf (user defined field) is present

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsUdfPresent(
    int udfNum
)
Visual Basic (Declaration)
Public Function IsUdfPresent ( _
    udfNum As Integer _
) As Boolean
Visual C++
public:
bool IsUdfPresent(
    int udfNum
)

Parameters

udfNum
Type: System..::.Int32
The udf (user defined field) number

Return Value

true if the udf (user defined field) is present, false otherwise

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


SetUdf Method

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.SetUdf Method
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Sets an user defined field for this case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void SetUdf(
    int udfNum,
    string val
)
Visual Basic (Declaration)
Public Sub SetUdf ( _
    udfNum As Integer, _
    val As String _
)
Visual C++
public:
void SetUdf(
    int udfNum,
    String^ val
)

Parameters

udfNum
Type: System..::.Int32
The user defined field number.
val
Type: System..::.String
The user defined field value that is to be set.

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


UdfCount Method

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.UdfCount Method
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the count of the total number of elements in the tracker case. This includes the udf and fixed fields.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int UdfCount()
Visual Basic (Declaration)
Public Function UdfCount As Integer
Visual C++
public:
int UdfCount()

Return Value

The total number of elements including the udf and fixed fields

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseInfo Properties

[image] [image]

OfficeClip API Documentation
TrackerCaseInfo Properties
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerCaseInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AssignedEmailAddress | The email address of the assigned to user
Public property | AssignedId | The id of the Assigned to user
Public property | AssignedName | The name of the assigned to user
Public property | CaseId | The system generated unique identifier for the tracker case.
Public property | CaseNum | The case number of the case.
Public property | Category | The Category value of the case.
Public property | CategoryId | The system generated unique identifier for the Category of the case.
Public property | Comments | the Comments of the case.
Public property | CreatedByEmailAddress | The email Address of the user who created the case.
Public property | CreatedById | The user identifier of the creator of the case.
Public property | CreatedByName | The name of the creator of the case.
Public property | CreatedDate | the created date for the case.
Public property | Criticality | The Criticality value for the case.
Public property | CriticalityId | The system generated unique identifier for the Criticality of the case.
Public property | Description | The Description of the case.
Public property | ExternalEmailAddress | The external email Address of the user who created the case. This is the email of the user if the user has created the case without logging into OfficeClip.
Public property | IsActive | Shows whether the tracker case is Active or archived. The value is true if Active and false if archived.
Public property | IsExternal | Shows if the creator of the case is an external user. That is if the user has created the case without logging into OfficeClip.
Public property | kind | The kind value of the case.
Public property | KindId | The system generated unique identifier for the kind of the case.
Public property | ModifiedByEmailAddress | The email Address of the user who last modified the case.
Public property | ModifiedById | The user identifier of the user who last modified the case.
Public property | ModifiedByName | The name of the user who last modified the case.
Public property | ModifiedDate | The date on which the case was last modified.
Public property | ObjectId | The object id
Public property | ObjectTypeId | The object type id
Public property | RegardingName | The regarding name
Public property | Resolution | The Resolution of the case.
Public property | Status | The status name for the case.
Public property | StatusId | The system generated unique identifier for the case status.
Public property | Title | The Title of the case.
Public property | Udfs | Returns the udf hashtable, the key is the id of the udf and the value is the value of udf in string

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


AssignedEmailAddress Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.AssignedEmailAddress Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email address of the assigned to user

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AssignedEmailAddress { get; }
Visual Basic (Declaration)
Public ReadOnly Property AssignedEmailAddress As String
Visual C++
public:
property String^ AssignedEmailAddress {
    String^ get ();
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


AssignedId Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.AssignedId Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The id of the Assigned to user

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AssignedId { get; set; }
Visual Basic (Declaration)
Public Property AssignedId As Integer
Visual C++
public:
property int AssignedId {
    int get ();
    void set (int value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


AssignedName Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.AssignedName Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the assigned to user

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string AssignedName { get; set; }
Visual Basic (Declaration)
Public Property AssignedName As String
Visual C++
public:
property String^ AssignedName {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CaseId Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.CaseId Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the tracker case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CaseId { get; set; }
Visual Basic (Declaration)
Public Property CaseId As Integer
Visual C++
public:
property int CaseId {
    int get ();
    void set (int value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CaseNum Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.CaseNum Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The case number of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CaseNum { get; set; }
Visual Basic (Declaration)
Public Property CaseNum As String
Visual C++
public:
property String^ CaseNum {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


Category Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.Category Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Category value of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Category { get; set; }
Visual Basic (Declaration)
Public Property Category As String
Visual C++
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CategoryId Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.CategoryId Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the Category of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CategoryId { get; set; }
Visual Basic (Declaration)
Public Property CategoryId As Integer
Visual C++
public:
property int CategoryId {
    int get ();
    void set (int value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


Comments Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.Comments Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

the Comments of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Comments { get; set; }
Visual Basic (Declaration)
Public Property Comments As String
Visual C++
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CreatedByEmailAddress Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.CreatedByEmailAddress Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Address of the user who created the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CreatedByEmailAddress { get; set; }
Visual Basic (Declaration)
Public Property CreatedByEmailAddress As String
Visual C++
public:
property String^ CreatedByEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CreatedById Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.CreatedById Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user identifier of the creator of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CreatedById { get; set; }
Visual Basic (Declaration)
Public Property CreatedById As Integer
Visual C++
public:
property int CreatedById {
    int get ();
    void set (int value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CreatedByName Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.CreatedByName Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the creator of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CreatedByName { get; set; }
Visual Basic (Declaration)
Public Property CreatedByName As String
Visual C++
public:
property String^ CreatedByName {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CreatedDate Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.CreatedDate Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

the created date for the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedDate { get; set; }
Visual Basic (Declaration)
Public Property CreatedDate As DateTime
Visual C++
public:
property DateTime CreatedDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


Criticality Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.Criticality Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Criticality value for the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Criticality { get; set; }
Visual Basic (Declaration)
Public Property Criticality As String
Visual C++
public:
property String^ Criticality {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CriticalityId Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.CriticalityId Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the Criticality of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CriticalityId { get; set; }
Visual Basic (Declaration)
Public Property CriticalityId As Integer
Visual C++
public:
property int CriticalityId {
    int get ();
    void set (int value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


Description Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.Description Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Description of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ExternalEmailAddress Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.ExternalEmailAddress Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The external email Address of the user who created the case. This is the email of the user if the user has created the case without logging into OfficeClip.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ExternalEmailAddress { get; set; }
Visual Basic (Declaration)
Public Property ExternalEmailAddress As String
Visual C++
public:
property String^ ExternalEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


IsActive Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.IsActive Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows whether the tracker case is Active or archived. The value is true if Active and false if archived.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As Boolean
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


IsExternal Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.IsExternal Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the creator of the case is an external user. That is if the user has created the case without logging into OfficeClip.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsExternal { get; set; }
Visual Basic (Declaration)
Public Property IsExternal As Boolean
Visual C++
public:
property bool IsExternal {
    bool get ();
    void set (bool value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


kind Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.kind Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The kind value of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string kind { get; set; }
Visual Basic (Declaration)
Public Property kind As String
Visual C++
public:
property String^ kind {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


KindId Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.KindId Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the kind of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int KindId { get; set; }
Visual Basic (Declaration)
Public Property KindId As Integer
Visual C++
public:
property int KindId {
    int get ();
    void set (int value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ModifiedByEmailAddress Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.ModifiedByEmailAddress Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Address of the user who last modified the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ModifiedByEmailAddress { get; set; }
Visual Basic (Declaration)
Public Property ModifiedByEmailAddress As String
Visual C++
public:
property String^ ModifiedByEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ModifiedById Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.ModifiedById Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The user identifier of the user who last modified the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ModifiedById { get; set; }
Visual Basic (Declaration)
Public Property ModifiedById As Integer
Visual C++
public:
property int ModifiedById {
    int get ();
    void set (int value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ModifiedByName Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.ModifiedByName Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the user who last modified the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ModifiedByName { get; set; }
Visual Basic (Declaration)
Public Property ModifiedByName As String
Visual C++
public:
property String^ ModifiedByName {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ModifiedDate Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.ModifiedDate Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The date on which the case was last modified.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime ModifiedDate { get; set; }
Visual Basic (Declaration)
Public Property ModifiedDate As DateTime
Visual C++
public:
property DateTime ModifiedDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ObjectId Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.ObjectId Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The object id

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ObjectId { get; set; }
Visual Basic (Declaration)
Public Property ObjectId As Integer
Visual C++
public:
property int ObjectId {
    int get ();
    void set (int value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ObjectTypeId Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.ObjectTypeId Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The object type id

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ObjectTypeId { get; set; }
Visual Basic (Declaration)
Public Property ObjectTypeId As Integer
Visual C++
public:
property int ObjectTypeId {
    int get ();
    void set (int value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


RegardingName Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.RegardingName Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The regarding name

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string RegardingName { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegardingName As String
Visual C++
public:
property String^ RegardingName {
    String^ get ();
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


Resolution Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.Resolution Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Resolution of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Resolution { get; set; }
Visual Basic (Declaration)
Public Property Resolution As String
Visual C++
public:
property String^ Resolution {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


Status Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.Status Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The status name for the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Status { get; set; }
Visual Basic (Declaration)
Public Property Status As String
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


StatusId Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.StatusId Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique identifier for the case status.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int StatusId { get; set; }
Visual Basic (Declaration)
Public Property StatusId As Integer
Visual C++
public:
property int StatusId {
    int get ();
    void set (int value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


Title Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.Title Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Title of the case.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Title { get; set; }
Visual Basic (Declaration)
Public Property Title As String
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


Udfs Property

[image]

OfficeClip API Documentation
TrackerCaseInfo..::.Udfs Property
TrackerCaseInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the udf hashtable, the key is the id of the udf and the value is the value of udf in string

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public Hashtable Udfs { get; }
Visual Basic (Declaration)
Public ReadOnly Property Udfs As Hashtable
Visual C++
public:
property Hashtable^ Udfs {
    Hashtable^ get ();
}

See Also

TrackerCaseInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseListInfo Class

[image]

OfficeClip API Documentation
TrackerCaseListInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a business layer interface to the tracker caseList screen

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerCaseListInfo
Visual Basic (Declaration)
Public Class TrackerCaseListInfo
Visual C++
public ref class TrackerCaseListInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Tracker..::.TrackerCaseListInfo

See Also

TrackerCaseListInfo Members
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseListInfo Members

[image] [image]

OfficeClip API Documentation
TrackerCaseListInfo Members
TrackerCaseListInfo Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The TrackerCaseListInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerCaseListInfo |

Methods

 | Name | Description
Public method | ChangeNullToUnspecified | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | fixedFieldQueryString | Returns the fixed field query string which corresponds to a particular search string
Public method | GetCaseListFieldPosition | Gets the field Position of the field elements on the case list table
Public method | GetFieldOptions | Creates the Option List for the search combo box and sort combo box
Public method | GetFilterOptions | Get all the options for the filter drop down box on the case list screen.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetLikeString | Gets the like string from the like boolean
Protected method | GetQueryString | Gets the general query string
Public method | GetShowLink | Gets which column hyperlink are to be shown on the case list screen.
Public method | GetTablePosition | Gets the Position of various tracker table depending on the field list
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUserQueryString | Returns the user query string
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SearchExpression | Creates the tracker search expression for the case list screen. This expression is in the SQL format and directly sent to the database.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | udfQueryString | Returns the udf query string

Fields

 | Name | Description
Protected field | isLike | shows if the query hould be done with " like " or " not like "

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseListInfo Constructor

[image]

OfficeClip API Documentation
TrackerCaseListInfo Constructor
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerCaseListInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerCaseListInfo()

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseListInfo Fields

[image] [image]

OfficeClip API Documentation
TrackerCaseListInfo Fields
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerCaseListInfo type exposes the following fields.

Fields

 | Name | Description
Protected field | isLike | shows if the query hould be done with " like " or " not like "

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


isLike Field

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.isLike Field
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

shows if the query hould be done with " like " or " not like "

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected bool isLike
Visual Basic (Declaration)
Protected isLike As Boolean
Visual C++
protected:
bool isLike

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerCaseListInfo Methods

[image] [image]

OfficeClip API Documentation
TrackerCaseListInfo Methods
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerCaseListInfo type exposes the following methods.

Methods

 | Name | Description
Public method | ChangeNullToUnspecified | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | fixedFieldQueryString | Returns the fixed field query string which corresponds to a particular search string
Public method | GetCaseListFieldPosition | Gets the field Position of the field elements on the case list table
Public method | GetFieldOptions | Creates the Option List for the search combo box and sort combo box
Public method | GetFilterOptions | Get all the options for the filter drop down box on the case list screen.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetLikeString | Gets the like string from the like boolean
Protected method | GetQueryString | Gets the general query string
Public method | GetShowLink | Gets which column hyperlink are to be shown on the case list screen.
Public method | GetTablePosition | Gets the Position of various tracker table depending on the field list
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUserQueryString | Returns the user query string
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SearchExpression | Creates the tracker search expression for the case list screen. This expression is in the SQL format and directly sent to the database.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | udfQueryString | Returns the udf query string

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ChangeNullToUnspecified Method

[image] [image]

OfficeClip API Documentation
TrackerCaseListInfo..::.ChangeNullToUnspecified Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ChangeNullToUnspecified(DataSet, Int32, Boolean, Boolean) | Changes database null to the unspecified value to be displayed on the screen. This routine changes all the rows in the table.
Public method | ChangeNullToUnspecified(DataSet, Int32, Int32, Int32, Boolean, Boolean) | Changes database null to the unspecified value to be displayed on the screen. This routine changes only one element of the table.

See Also

TrackerCaseListInfo Class
TrackerCaseListInfo Members
OfficeClip.BusinessLayer.Tracker Namespace


ChangeNullToUnspecified Method (DataSet, Int32, Boolean, Boolean)

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.ChangeNullToUnspecified Method (DataSet, Int32, Boolean, Boolean)
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Changes database null to the unspecified value to be displayed on the screen. This routine changes all the rows in the table.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void ChangeNullToUnspecified(
    DataSet ds,
    int tablePosition,
    bool isDisp,
    bool isBlank
)
Visual Basic (Declaration)
Public Sub ChangeNullToUnspecified ( _
    ds As DataSet, _
    tablePosition As Integer, _
    isDisp As Boolean, _
    isBlank As Boolean _
)
Visual C++
public:
void ChangeNullToUnspecified(
    DataSet^ ds,
    int tablePosition,
    bool isDisp,
    bool isBlank
)

Parameters

ds
Type: System.Data..::.DataSet
The dataset to change.
tablePosition
Type: System..::.Int32
The Position of the table in the dataset where the change is desired.
isDisp
Type: System..::.Boolean
Shows if the output is supposed to be displayed on the screen. If not, we will not bother the convert the left angular bracket character to "<"
isBlank
Type: System..::.Boolean
if true then the output is shown as blank otherwise it is shown as unspecified.

See Also

TrackerCaseListInfo Class
ChangeNullToUnspecified Overload
OfficeClip.BusinessLayer.Tracker Namespace


ChangeNullToUnspecified Method (DataSet, Int32, Int32, Int32, Boolean, Boolean)

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.ChangeNullToUnspecified Method (DataSet, Int32, Int32, Int32, Boolean, Boolean)
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Changes database null to the unspecified value to be displayed on the screen. This routine changes only one element of the table.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void ChangeNullToUnspecified(
    DataSet ds,
    int tablePosition,
    int row,
    int column,
    bool isDisp,
    bool isBlank
)
Visual Basic (Declaration)
Public Sub ChangeNullToUnspecified ( _
    ds As DataSet, _
    tablePosition As Integer, _
    row As Integer, _
    column As Integer, _
    isDisp As Boolean, _
    isBlank As Boolean _
)
Visual C++
public:
void ChangeNullToUnspecified(
    DataSet^ ds,
    int tablePosition,
    int row,
    int column,
    bool isDisp,
    bool isBlank
)

Parameters

ds
Type: System.Data..::.DataSet
The dataset to change.
tablePosition
Type: System..::.Int32
The Position of the table in the dataset where the change is desired.
row
Type: System..::.Int32
The table row to change.
column
Type: System..::.Int32
the table column to change.
isDisp
Type: System..::.Boolean
Shows if the output is supposed to be displayed on the screen. If not, we will not bother the convert the left angular bracket characters to "<"
isBlank
Type: System..::.Boolean
if true then the output is shown as blank otherwise it is shown as unspecified.

See Also

TrackerCaseListInfo Class
ChangeNullToUnspecified Overload
OfficeClip.BusinessLayer.Tracker Namespace


fixedFieldQueryString Method

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.fixedFieldQueryString Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the fixed field query string which corresponds to a particular search string

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string fixedFieldQueryString(
    TrackerFieldsNameId tid,
    string searchStr
)
Visual Basic (Declaration)
Protected Function fixedFieldQueryString ( _
    tid As TrackerFieldsNameId, _
    searchStr As String _
) As String
Visual C++
protected:
String^ fixedFieldQueryString(
    TrackerFieldsNameId tid,
    String^ searchStr
)

Parameters

tid
Type: OfficeClip.Utils..::.TrackerFieldsNameId
searchStr
Type: System..::.String

Return Value

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetCaseListFieldPosition Method

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.GetCaseListFieldPosition Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the field Position of the field elements on the case list table

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GetCaseListFieldPosition(
    TrackerFieldsNameId fieldId
)
Visual Basic (Declaration)
Public Function GetCaseListFieldPosition ( _
    fieldId As TrackerFieldsNameId _
) As Integer
Visual C++
public:
int GetCaseListFieldPosition(
    TrackerFieldsNameId fieldId
)

Parameters

fieldId
Type: OfficeClip.Utils..::.TrackerFieldsNameId
The id of the field whose Position is required to be determined

Return Value

The Position of the field on the table

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetFieldOptions Method

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.GetFieldOptions Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Creates the Option List for the search combo box and sort combo box

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetFieldOptions(
    SqlDataReader sdr
)
Visual Basic (Declaration)
Public Function GetFieldOptions ( _
    sdr As SqlDataReader _
) As DataTable
Visual C++
public:
DataTable^ GetFieldOptions(
    SqlDataReader^ sdr
)

Parameters

sdr
Type: System.Data.SqlClient..::.SqlDataReader
The SqlDataReader

Return Value

A Dataset with id, name and isSort, if isSort is true, then these values will be included in the sort combo box, the isListSorted field is N, D or A depending on if the udf listbox is sorted, this field does not have much use for anything else.

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetFilterOptions Method

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.GetFilterOptions Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Get all the options for the filter drop down box on the case list screen.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetFilterOptions(
    DataSet result
)
Visual Basic (Declaration)
Public Function GetFilterOptions ( _
    result As DataSet _
) As DataTable
Visual C++
public:
DataTable^ GetFilterOptions(
    DataSet^ result
)

Parameters

result
Type: System.Data..::.DataSet
The set for the filter options.

Return Value

The table with all the filter options.

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetLikeString Method

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.GetLikeString Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the like string from the like boolean

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetLikeString(
    bool isLikeVal
)
Visual Basic (Declaration)
Protected Function GetLikeString ( _
    isLikeVal As Boolean _
) As String
Visual C++
protected:
String^ GetLikeString(
    bool isLikeVal
)

Parameters

isLikeVal
Type: System..::.Boolean

Return Value

The like string for the database

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetQueryString Method

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.GetQueryString Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the general query string

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetQueryString(
    string lhs,
    string rhs,
    bool isList
)
Visual Basic (Declaration)
Protected Function GetQueryString ( _
    lhs As String, _
    rhs As String, _
    isList As Boolean _
) As String
Visual C++
protected:
String^ GetQueryString(
    String^ lhs,
    String^ rhs,
    bool isList
)

Parameters

lhs
Type: System..::.String
The left hand side
rhs
Type: System..::.String
The right hand side
isList
Type: System..::.Boolean
Is the parameter a list

Return Value

The query expression

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetShowLink Method

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.GetShowLink Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets which column hyperlink are to be shown on the case list screen.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetShowLink(
    DataSet ds,
    string sortField
)
Visual Basic (Declaration)
Public Function GetShowLink ( _
    ds As DataSet, _
    sortField As String _
) As DataTable
Visual C++
public:
DataTable^ GetShowLink(
    DataSet^ ds,
    String^ sortField
)

Parameters

ds
Type: System.Data..::.DataSet
The dataset in question.
sortField
Type: System..::.String
The sort field.

Return Value

The table with the links set.

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetTablePosition Method

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.GetTablePosition Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Position of various tracker table depending on the field list

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GetTablePosition(
    TrackerFieldsNameId id
)
Visual Basic (Declaration)
Public Function GetTablePosition ( _
    id As TrackerFieldsNameId _
) As Integer
Visual C++
public:
int GetTablePosition(
    TrackerFieldsNameId id
)

Parameters

id
Type: OfficeClip.Utils..::.TrackerFieldsNameId
The id of the tracker field that specifies the table

Return Value

The Position of the table on the dataset of the field list

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetUserQueryString Method

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.GetUserQueryString Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the user query string

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetUserQueryString(
    string lhs,
    string rhs,
    string andCond
)
Visual Basic (Declaration)
Protected Function GetUserQueryString ( _
    lhs As String, _
    rhs As String, _
    andCond As String _
) As String
Visual C++
protected:
String^ GetUserQueryString(
    String^ lhs,
    String^ rhs,
    String^ andCond
)

Parameters

lhs
Type: System..::.String
The left hand side
rhs
Type: System..::.String
The right hand side
andCond
Type: System..::.String
The and condition

Return Value

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


SearchExpression Method

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.SearchExpression Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Creates the tracker search expression for the case list screen. This expression is in the SQL format and directly sent to the database.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SearchExpression(
    ArrayList al,
    string searchStr,
    DataTable dtNames,
    bool isLikeVal
)
Visual Basic (Declaration)
Public Function SearchExpression ( _
    al As ArrayList, _
    searchStr As String, _
    dtNames As DataTable, _
    isLikeVal As Boolean _
) As String
Visual C++
public:
String^ SearchExpression(
    ArrayList^ al,
    String^ searchStr,
    DataTable^ dtNames,
    bool isLikeVal
)

Parameters

al
Type: System.Collections..::.ArrayList
list of search expressions.
searchStr
Type: System..::.String
The search string.
dtNames
Type: System.Data..::.DataTable
The datatable of field names.
isLikeVal
Type: System..::.Boolean
true if the search is "Is" false if it is "Is Not"

Return Value

The search expression that can be sent to the database.

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


udfQueryString Method

[image]

OfficeClip API Documentation
TrackerCaseListInfo..::.udfQueryString Method
TrackerCaseListInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the udf query string

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string udfQueryString(
    int id,
    string searchStr
)
Visual Basic (Declaration)
Protected Function udfQueryString ( _
    id As Integer, _
    searchStr As String _
) As String
Visual C++
protected:
String^ udfQueryString(
    int id,
    String^ searchStr
)

Parameters

id
Type: System..::.Int32
searchStr
Type: System..::.String

Return Value

See Also

TrackerCaseListInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerEmailInfo Class

[image]

OfficeClip API Documentation
TrackerEmailInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides members and properties to access the tracker email information.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerEmailInfo
Visual Basic (Declaration)
Public Class TrackerEmailInfo
Visual C++
public ref class TrackerEmailInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Tracker..::.TrackerEmailInfo

See Also

TrackerEmailInfo Members
OfficeClip.BusinessLayer.Tracker Namespace


TrackerEmailInfo Members

[image] [image]

OfficeClip API Documentation
TrackerEmailInfo Members
TrackerEmailInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerEmailInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerEmailInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssignedTo | The assigned to user id
Public property | CategoryId | The category Id
Public property | CriticalityId | The criticality Id
Public property | InserverPort | InserverPort default 110
Public property | InserverSecurity | InserverSecurity Y or N
Public property | KindId | The kind id
Public property | LastModifiedDateTime | The last modified time
Public property | LastModifiedUserId | The last modified user id
Public property | LeaveMessage | Determines if a copy of the email is left in the server
Public property | PopLogin | The pop server login id
Public property | PopPassword | The pop server password
Public property | PopServer | The pop server
Public property | ProjectId | The project id
Public property | StatusId | The status id
Public property | SyncInterval | The sync interval. OfficeClip will load the emails at each sync interval

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerEmailInfo Constructor

[image] [image]

OfficeClip API Documentation
TrackerEmailInfo Constructor
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TrackerEmailInfo()()() | Constructor
Public method | TrackerEmailInfo(Int32, String, String, String, Int32, Int32, Int32, Int32, Int32, Boolean, Int32, Int32, DateTime, String, Int32) | Constructor

See Also

TrackerEmailInfo Class
TrackerEmailInfo Members
OfficeClip.BusinessLayer.Tracker Namespace


TrackerEmailInfo Constructor

[image]

OfficeClip API Documentation
TrackerEmailInfo Constructor
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerEmailInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerEmailInfo()

See Also

TrackerEmailInfo Class
TrackerEmailInfo Overload
OfficeClip.BusinessLayer.Tracker Namespace


TrackerEmailInfo Constructor (Int32, String, String, String, Int32, Int32, Int32, Int32, Int32, Boolean, Int32, Int32, DateTime, String, Int32)

[image]

OfficeClip API Documentation
TrackerEmailInfo Constructor (Int32, String, String, String, Int32, Int32, Int32, Int32, Int32, Boolean, Int32, Int32, DateTime, String, Int32)
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerEmailInfo(
    int projectId,
    string popServer,
    string popLogin,
    string popPassword,
    int statusId,
    int criticalityId,
    int categoryId,
    int kindId,
    int assignedTo,
    bool leaveMessage,
    int syncInterval,
    int lastModifiedUserId,
    DateTime lastModifiedDateTime,
    string inserverSecurity,
    int inserverPort
)
Visual Basic (Declaration)
Public Sub New ( _
    projectId As Integer, _
    popServer As String, _
    popLogin As String, _
    popPassword As String, _
    statusId As Integer, _
    criticalityId As Integer, _
    categoryId As Integer, _
    kindId As Integer, _
    assignedTo As Integer, _
    leaveMessage As Boolean, _
    syncInterval As Integer, _
    lastModifiedUserId As Integer, _
    lastModifiedDateTime As DateTime, _
    inserverSecurity As String, _
    inserverPort As Integer _
)
Visual C++
public:
TrackerEmailInfo(
    int projectId,
    String^ popServer,
    String^ popLogin,
    String^ popPassword,
    int statusId,
    int criticalityId,
    int categoryId,
    int kindId,
    int assignedTo,
    bool leaveMessage,
    int syncInterval,
    int lastModifiedUserId,
    DateTime lastModifiedDateTime,
    String^ inserverSecurity,
    int inserverPort
)

Parameters

projectId
Type: System..::.Int32
popServer
Type: System..::.String
popLogin
Type: System..::.String
popPassword
Type: System..::.String
statusId
Type: System..::.Int32
criticalityId
Type: System..::.Int32
categoryId
Type: System..::.Int32
kindId
Type: System..::.Int32
assignedTo
Type: System..::.Int32
leaveMessage
Type: System..::.Boolean
syncInterval
Type: System..::.Int32
lastModifiedUserId
Type: System..::.Int32
lastModifiedDateTime
Type: System..::.DateTime
inserverSecurity
Type: System..::.String
inserverPort
Type: System..::.Int32

See Also

TrackerEmailInfo Class
TrackerEmailInfo Overload
OfficeClip.BusinessLayer.Tracker Namespace


TrackerEmailInfo Properties

[image] [image]

OfficeClip API Documentation
TrackerEmailInfo Properties
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerEmailInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AssignedTo | The assigned to user id
Public property | CategoryId | The category Id
Public property | CriticalityId | The criticality Id
Public property | InserverPort | InserverPort default 110
Public property | InserverSecurity | InserverSecurity Y or N
Public property | KindId | The kind id
Public property | LastModifiedDateTime | The last modified time
Public property | LastModifiedUserId | The last modified user id
Public property | LeaveMessage | Determines if a copy of the email is left in the server
Public property | PopLogin | The pop server login id
Public property | PopPassword | The pop server password
Public property | PopServer | The pop server
Public property | ProjectId | The project id
Public property | StatusId | The status id
Public property | SyncInterval | The sync interval. OfficeClip will load the emails at each sync interval

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


AssignedTo Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.AssignedTo Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The assigned to user id

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int AssignedTo { get; set; }
Visual Basic (Declaration)
Public Property AssignedTo As Integer
Visual C++
public:
property int AssignedTo {
    int get ();
    void set (int value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CategoryId Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.CategoryId Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The category Id

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CategoryId { get; set; }
Visual Basic (Declaration)
Public Property CategoryId As Integer
Visual C++
public:
property int CategoryId {
    int get ();
    void set (int value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CriticalityId Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.CriticalityId Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The criticality Id

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int CriticalityId { get; set; }
Visual Basic (Declaration)
Public Property CriticalityId As Integer
Visual C++
public:
property int CriticalityId {
    int get ();
    void set (int value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


InserverPort Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.InserverPort Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

InserverPort default 110

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int InserverPort { get; set; }
Visual Basic (Declaration)
Public Property InserverPort As Integer
Visual C++
public:
property int InserverPort {
    int get ();
    void set (int value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


InserverSecurity Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.InserverSecurity Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

InserverSecurity Y or N

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string InserverSecurity { get; set; }
Visual Basic (Declaration)
Public Property InserverSecurity As String
Visual C++
public:
property String^ InserverSecurity {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


KindId Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.KindId Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The kind id

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int KindId { get; set; }
Visual Basic (Declaration)
Public Property KindId As Integer
Visual C++
public:
property int KindId {
    int get ();
    void set (int value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


LastModifiedDateTime Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.LastModifiedDateTime Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last modified time

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime LastModifiedDateTime { get; set; }
Visual Basic (Declaration)
Public Property LastModifiedDateTime As DateTime
Visual C++
public:
property DateTime LastModifiedDateTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


LastModifiedUserId Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.LastModifiedUserId Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The last modified user id

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int LastModifiedUserId { get; set; }
Visual Basic (Declaration)
Public Property LastModifiedUserId As Integer
Visual C++
public:
property int LastModifiedUserId {
    int get ();
    void set (int value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


LeaveMessage Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.LeaveMessage Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

Determines if a copy of the email is left in the server

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool LeaveMessage { get; set; }
Visual Basic (Declaration)
Public Property LeaveMessage As Boolean
Visual C++
public:
property bool LeaveMessage {
    bool get ();
    void set (bool value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


PopLogin Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.PopLogin Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The pop server login id

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PopLogin { get; set; }
Visual Basic (Declaration)
Public Property PopLogin As String
Visual C++
public:
property String^ PopLogin {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


PopPassword Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.PopPassword Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The pop server password

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PopPassword { get; set; }
Visual Basic (Declaration)
Public Property PopPassword As String
Visual C++
public:
property String^ PopPassword {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


PopServer Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.PopServer Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The pop server

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string PopServer { get; set; }
Visual Basic (Declaration)
Public Property PopServer As String
Visual C++
public:
property String^ PopServer {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ProjectId Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.ProjectId Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The project id

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ProjectId { get; set; }
Visual Basic (Declaration)
Public Property ProjectId As Integer
Visual C++
public:
property int ProjectId {
    int get ();
    void set (int value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


StatusId Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.StatusId Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The status id

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int StatusId { get; set; }
Visual Basic (Declaration)
Public Property StatusId As Integer
Visual C++
public:
property int StatusId {
    int get ();
    void set (int value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


SyncInterval Property

[image]

OfficeClip API Documentation
TrackerEmailInfo..::.SyncInterval Property
TrackerEmailInfo Class See Also

[This is preliminary documentation and is subject to change.]

The sync interval. OfficeClip will load the emails at each sync interval

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int SyncInterval { get; set; }
Visual Basic (Declaration)
Public Property SyncInterval As Integer
Visual C++
public:
property int SyncInterval {
    int get ();
    void set (int value);
}

See Also

TrackerEmailInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerEmailMessageId Class

[image]

OfficeClip API Documentation
TrackerEmailMessageId Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides members and properties to access the tracker email message id.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerEmailMessageId
Visual Basic (Declaration)
Public Class TrackerEmailMessageId
Visual C++
public ref class TrackerEmailMessageId

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Tracker..::.TrackerEmailMessageId

See Also

TrackerEmailMessageId Members
OfficeClip.BusinessLayer.Tracker Namespace


TrackerEmailMessageId Members

[image] [image]

OfficeClip API Documentation
TrackerEmailMessageId Members
TrackerEmailMessageId Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerEmailMessageId type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerEmailMessageId |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsMarked | Determines if the message is marked
Public property | MessageId | Te message id

See Also

TrackerEmailMessageId Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerEmailMessageId Constructor

[image]

OfficeClip API Documentation
TrackerEmailMessageId Constructor
TrackerEmailMessageId Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerEmailMessageId()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerEmailMessageId()

See Also

TrackerEmailMessageId Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerEmailMessageId Properties

[image] [image]

OfficeClip API Documentation
TrackerEmailMessageId Properties
TrackerEmailMessageId Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerEmailMessageId type exposes the following properties.

Properties

 | Name | Description
Public property | IsMarked | Determines if the message is marked
Public property | MessageId | Te message id

See Also

TrackerEmailMessageId Class
OfficeClip.BusinessLayer.Tracker Namespace


IsMarked Property

[image]

OfficeClip API Documentation
TrackerEmailMessageId..::.IsMarked Property
TrackerEmailMessageId Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the message is marked

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsMarked { get; set; }
Visual Basic (Declaration)
Public Property IsMarked As Boolean
Visual C++
public:
property bool IsMarked {
    bool get ();
    void set (bool value);
}

See Also

TrackerEmailMessageId Class
OfficeClip.BusinessLayer.Tracker Namespace


MessageId Property

[image]

OfficeClip API Documentation
TrackerEmailMessageId..::.MessageId Property
TrackerEmailMessageId Class See Also

[This is preliminary documentation and is subject to change.]

Te message id

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string MessageId { get; set; }
Visual Basic (Declaration)
Public Property MessageId As String
Visual C++
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerEmailMessageId Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerKBInfo Class

[image]

OfficeClip API Documentation
TrackerKBInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides members and properties to access the tracker knowledge base field information.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerKBInfo
Visual Basic (Declaration)
Public Class TrackerKBInfo
Visual C++
public ref class TrackerKBInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Tracker..::.TrackerKBInfo

See Also

TrackerKBInfo Members
OfficeClip.BusinessLayer.Tracker Namespace


TrackerKBInfo Members

[image] [image]

OfficeClip API Documentation
TrackerKBInfo Members
TrackerKBInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerKBInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerKBInfo | Overloaded.

Methods

 | Name | Description
Public method | AddSelectedField | Adds the selected field from the tracker to the knowledge base. This field shows up in the knowledge base screen.
Public method | Dump | Ourputs a dump of the object for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldSize | Gets the size of the fields array. This returns the number of fields in the knowledge base.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSelectedField | Gets the value of the selected field from the object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Serialize this object to a readable format. (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | CaseId | The unique id of the tracker case
Public property | FilterString | The string value to filter
Public property | FilterTypeId | Shows the type of the filter selected from the knowledge base creation screen.
Public property | IsHtml | Shows if the knowledge base is html based. Html based knowledge base will show the details in Html
Public property | ProjectId | The database generated unique id of the project
Public property | SubTopicId | The database generated unique id of the subtopic of the knowledge base
Public property | TopicId | The database generated unique id of the topic of the knowledge base
Public property | UniqueCode | The unique code to make sure that the object created is valid

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerKBInfo Constructor

[image] [image]

OfficeClip API Documentation
TrackerKBInfo Constructor
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TrackerKBInfo()()() | The empty constructor
Public method | TrackerKBInfo(String) | Constructor that takes the encoded string and creates a knowledge base

See Also

TrackerKBInfo Class
TrackerKBInfo Members
OfficeClip.BusinessLayer.Tracker Namespace


TrackerKBInfo Constructor

[image]

OfficeClip API Documentation
TrackerKBInfo Constructor
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

The empty constructor

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerKBInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerKBInfo()

See Also

TrackerKBInfo Class
TrackerKBInfo Overload
OfficeClip.BusinessLayer.Tracker Namespace


TrackerKBInfo Constructor (String)

[image]

OfficeClip API Documentation
TrackerKBInfo Constructor (String)
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that takes the encoded string and creates a knowledge base

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerKBInfo(
    string str
)
Visual Basic (Declaration)
Public Sub New ( _
    str As String _
)
Visual C++
public:
TrackerKBInfo(
    String^ str
)

Parameters

str
Type: System..::.String
The string that is encoded specifically for the tracker knowledge base

See Also

TrackerKBInfo Class
TrackerKBInfo Overload
OfficeClip.BusinessLayer.Tracker Namespace


TrackerKBInfo Methods

[image] [image]

OfficeClip API Documentation
TrackerKBInfo Methods
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerKBInfo type exposes the following methods.

Methods

 | Name | Description
Public method | AddSelectedField | Adds the selected field from the tracker to the knowledge base. This field shows up in the knowledge base screen.
Public method | Dump | Ourputs a dump of the object for debugging purposes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFieldSize | Gets the size of the fields array. This returns the number of fields in the knowledge base.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSelectedField | Gets the value of the selected field from the object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Serialize this object to a readable format. (Overrides Object..::.ToString()()().)

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


AddSelectedField Method

[image]

OfficeClip API Documentation
TrackerKBInfo..::.AddSelectedField Method
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

Adds the selected field from the tracker to the knowledge base. This field shows up in the knowledge base screen.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void AddSelectedField(
    string val
)
Visual Basic (Declaration)
Public Sub AddSelectedField ( _
    val As String _
)
Visual C++
public:
void AddSelectedField(
    String^ val
)

Parameters

val
Type: System..::.String
The selected field value

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


Dump Method

[image]

OfficeClip API Documentation
TrackerKBInfo..::.Dump Method
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

Ourputs a dump of the object for debugging purposes

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

Return Value

the ascii dump of the object.

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetFieldSize Method

[image]

OfficeClip API Documentation
TrackerKBInfo..::.GetFieldSize Method
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the size of the fields array. This returns the number of fields in the knowledge base.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GetFieldSize()
Visual Basic (Declaration)
Public Function GetFieldSize As Integer
Visual C++
public:
int GetFieldSize()

Return Value

The number of fields.

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetSelectedField Method

[image]

OfficeClip API Documentation
TrackerKBInfo..::.GetSelectedField Method
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the value of the selected field from the object.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string GetSelectedField(
    int index
)
Visual Basic (Declaration)
Public Function GetSelectedField ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetSelectedField(
    int index
)

Parameters

index
Type: System..::.Int32
The integer index determined by the tracker field id TrackerFieldsNameId

Return Value

The string value of the selected field.

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ToString Method

[image]

OfficeClip API Documentation
TrackerKBInfo..::.ToString Method
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

Serialize this object to a readable format.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The serialized object.

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerKBInfo Properties

[image] [image]

OfficeClip API Documentation
TrackerKBInfo Properties
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerKBInfo type exposes the following properties.

Properties

 | Name | Description
Public property | CaseId | The unique id of the tracker case
Public property | FilterString | The string value to filter
Public property | FilterTypeId | Shows the type of the filter selected from the knowledge base creation screen.
Public property | IsHtml | Shows if the knowledge base is html based. Html based knowledge base will show the details in Html
Public property | ProjectId | The database generated unique id of the project
Public property | SubTopicId | The database generated unique id of the subtopic of the knowledge base
Public property | TopicId | The database generated unique id of the topic of the knowledge base
Public property | UniqueCode | The unique code to make sure that the object created is valid

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CaseId Property

[image]

OfficeClip API Documentation
TrackerKBInfo..::.CaseId Property
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the tracker case

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string CaseId { get; set; }
Visual Basic (Declaration)
Public Property CaseId As String
Visual C++
public:
property String^ CaseId {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


FilterString Property

[image]

OfficeClip API Documentation
TrackerKBInfo..::.FilterString Property
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

The string value to filter

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FilterString { get; set; }
Visual Basic (Declaration)
Public Property FilterString As String
Visual C++
public:
property String^ FilterString {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


FilterTypeId Property

[image]

OfficeClip API Documentation
TrackerKBInfo..::.FilterTypeId Property
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows the type of the filter selected from the knowledge base creation screen.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string FilterTypeId { get; set; }
Visual Basic (Declaration)
Public Property FilterTypeId As String
Visual C++
public:
property String^ FilterTypeId {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


IsHtml Property

[image]

OfficeClip API Documentation
TrackerKBInfo..::.IsHtml Property
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the knowledge base is html based. Html based knowledge base will show the details in Html

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string IsHtml { get; set; }
Visual Basic (Declaration)
Public Property IsHtml As String
Visual C++
public:
property String^ IsHtml {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ProjectId Property

[image]

OfficeClip API Documentation
TrackerKBInfo..::.ProjectId Property
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

The database generated unique id of the project

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProjectId { get; set; }
Visual Basic (Declaration)
Public Property ProjectId As String
Visual C++
public:
property String^ ProjectId {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


SubTopicId Property

[image]

OfficeClip API Documentation
TrackerKBInfo..::.SubTopicId Property
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

The database generated unique id of the subtopic of the knowledge base

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string SubTopicId { get; set; }
Visual Basic (Declaration)
Public Property SubTopicId As String
Visual C++
public:
property String^ SubTopicId {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TopicId Property

[image]

OfficeClip API Documentation
TrackerKBInfo..::.TopicId Property
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

The database generated unique id of the topic of the knowledge base

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string TopicId { get; set; }
Visual Basic (Declaration)
Public Property TopicId As String
Visual C++
public:
property String^ TopicId {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


UniqueCode Property

[image]

OfficeClip API Documentation
TrackerKBInfo..::.UniqueCode Property
TrackerKBInfo Class See Also

[This is preliminary documentation and is subject to change.]

The unique code to make sure that the object created is valid

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string UniqueCode { get; }
Visual Basic (Declaration)
Public ReadOnly Property UniqueCode As String
Visual C++
public:
property String^ UniqueCode {
    String^ get ();
}

See Also

TrackerKBInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerProjectInfo Class

[image]

OfficeClip API Documentation
TrackerProjectInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provide the methods and properties for the tracker Project information.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class TrackerProjectInfo : ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class TrackerProjectInfo _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class TrackerProjectInfo : ISerializable

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Tracker..::.TrackerProjectInfo

See Also

TrackerProjectInfo Members
OfficeClip.BusinessLayer.Tracker Namespace


TrackerProjectInfo Members

[image] [image]

OfficeClip API Documentation
TrackerProjectInfo Members
TrackerProjectInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerProjectInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerProjectInfo | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Counter | The value of the tracker Counter. The Counter contains the integral part of the last case number.
Public property | CreatedTimestamp | The created Timestamp of the tracker Project.
Public property | EmailAlias | The email Alias of the tracker Project. This is not used currently.
Public property | EmailDefaultStatus | The default email status. This is not used currently.
Public property | GroupId | the identifier of the group to which this Project belongs to.
Public property | IsActive | Shows if the Project is active. Valid values are "Y" (for active) and "N" (for inactive).
Public property | IsPrefix | Shows if the user defined Prefix is possible.
Public property | NumberRecordsPerPage | The number of records to be shown on a page of the case list.
Public property | Prefix | The Prefix of the Project. The Prefix is the first three letter of the case number.
Public property | ProjectId | The system generated unique Project identifier.
Public property | ProjectName | The name of the Project.

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerProjectInfo Constructor

[image] [image]

OfficeClip API Documentation
TrackerProjectInfo Constructor
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TrackerProjectInfo()()() | The default constructor.
Public method | TrackerProjectInfo(SerializationInfo, StreamingContext) | The constructor using the SerializationInfo and the StreamingContext.

See Also

TrackerProjectInfo Class
TrackerProjectInfo Members
OfficeClip.BusinessLayer.Tracker Namespace


TrackerProjectInfo Constructor

[image]

OfficeClip API Documentation
TrackerProjectInfo Constructor
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerProjectInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerProjectInfo()

See Also

TrackerProjectInfo Class
TrackerProjectInfo Overload
OfficeClip.BusinessLayer.Tracker Namespace


TrackerProjectInfo Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
TrackerProjectInfo Constructor (SerializationInfo, StreamingContext)
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The constructor using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerProjectInfo(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
TrackerProjectInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

See Also

TrackerProjectInfo Class
TrackerProjectInfo Overload
OfficeClip.BusinessLayer.Tracker Namespace


TrackerProjectInfo Methods

[image] [image]

OfficeClip API Documentation
TrackerProjectInfo Methods
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerProjectInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | Gets the object data using the SerializationInfo and the StreamingContext.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GetObjectData Method

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.GetObjectData Method
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object data using the SerializationInfo and the StreamingContext.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The Serialization information object.
context
Type: System.Runtime.Serialization..::.StreamingContext
The context object.

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerProjectInfo Properties

[image] [image]

OfficeClip API Documentation
TrackerProjectInfo Properties
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerProjectInfo type exposes the following properties.

Properties

 | Name | Description
Public property | Counter | The value of the tracker Counter. The Counter contains the integral part of the last case number.
Public property | CreatedTimestamp | The created Timestamp of the tracker Project.
Public property | EmailAlias | The email Alias of the tracker Project. This is not used currently.
Public property | EmailDefaultStatus | The default email status. This is not used currently.
Public property | GroupId | the identifier of the group to which this Project belongs to.
Public property | IsActive | Shows if the Project is active. Valid values are "Y" (for active) and "N" (for inactive).
Public property | IsPrefix | Shows if the user defined Prefix is possible.
Public property | NumberRecordsPerPage | The number of records to be shown on a page of the case list.
Public property | Prefix | The Prefix of the Project. The Prefix is the first three letter of the case number.
Public property | ProjectId | The system generated unique Project identifier.
Public property | ProjectName | The name of the Project.

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


Counter Property

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.Counter Property
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The value of the tracker Counter. The Counter contains the integral part of the last case number.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int Counter { get; set; }
Visual Basic (Declaration)
Public Property Counter As Integer
Visual C++
public:
property int Counter {
    int get ();
    void set (int value);
}

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CreatedTimestamp Property

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.CreatedTimestamp Property
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The created Timestamp of the tracker Project.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime CreatedTimestamp { get; set; }
Visual Basic (Declaration)
Public Property CreatedTimestamp As DateTime
Visual C++
public:
property DateTime CreatedTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


EmailAlias Property

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.EmailAlias Property
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The email Alias of the tracker Project. This is not used currently.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailAlias { get; set; }
Visual Basic (Declaration)
Public Property EmailAlias As String
Visual C++
public:
property String^ EmailAlias {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


EmailDefaultStatus Property

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.EmailDefaultStatus Property
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The default email status. This is not used currently.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string EmailDefaultStatus { get; set; }
Visual Basic (Declaration)
Public Property EmailDefaultStatus As String
Visual C++
public:
property String^ EmailDefaultStatus {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


GroupId Property

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.GroupId Property
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

the identifier of the group to which this Project belongs to.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


IsActive Property

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.IsActive Property
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the Project is active. Valid values are "Y" (for active) and "N" (for inactive).

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As Boolean
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


IsPrefix Property

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.IsPrefix Property
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the user defined Prefix is possible.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsPrefix { get; set; }
Visual Basic (Declaration)
Public Property IsPrefix As Boolean
Visual C++
public:
property bool IsPrefix {
    bool get ();
    void set (bool value);
}

Remarks

Valid values are "Y" (possible) and "N" (not possible). If the p[roject does not have the IsPrefix set, it means that the case number is always Prefix by the first letter of the user's first name and the first letter of the user's last name.

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


NumberRecordsPerPage Property

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.NumberRecordsPerPage Property
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The number of records to be shown on a page of the case list.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int NumberRecordsPerPage { get; set; }
Visual Basic (Declaration)
Public Property NumberRecordsPerPage As Integer
Visual C++
public:
property int NumberRecordsPerPage {
    int get ();
    void set (int value);
}

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


Prefix Property

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.Prefix Property
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The Prefix of the Project. The Prefix is the first three letter of the case number.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string Prefix { get; set; }
Visual Basic (Declaration)
Public Property Prefix As String
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ProjectId Property

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.ProjectId Property
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The system generated unique Project identifier.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public int ProjectId { get; set; }
Visual Basic (Declaration)
Public Property ProjectId As Integer
Visual C++
public:
property int ProjectId {
    int get ();
    void set (int value);
}

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


ProjectName Property

[image]

OfficeClip API Documentation
TrackerProjectInfo..::.ProjectName Property
TrackerProjectInfo Class See Also

[This is preliminary documentation and is subject to change.]

The name of the Project.

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public string ProjectName { get; set; }
Visual Basic (Declaration)
Public Property ProjectName As String
Visual C++
public:
property String^ ProjectName {
    String^ get ();
    void set (String^ value);
}

See Also

TrackerProjectInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerQueryInfo Class

[image]

OfficeClip API Documentation
TrackerQueryInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class provides a business layer interface to the tracker caseList screen

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerQueryInfo
Visual Basic (Declaration)
Public Class TrackerQueryInfo
Visual C++
public ref class TrackerQueryInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.BusinessLayer.Tracker..::.TrackerQueryInfo

See Also

TrackerQueryInfo Members
OfficeClip.BusinessLayer.Tracker Namespace


TrackerQueryInfo Members

[image] [image]

OfficeClip API Documentation
TrackerQueryInfo Members
TrackerQueryInfo Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The TrackerQueryInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerQueryInfo |

Methods

 | Name | Description
Public method | CreateFilterString | Creates the query string and the display string for the filter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | fillDisplayBuffer | Fills the display buffer
Protected method | fillFilterBuffer |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getDateString | Converts the date object to the server timezone and then sends it to the database for execution
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerQueryInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerQueryInfo Constructor

[image]

OfficeClip API Documentation
TrackerQueryInfo Constructor
TrackerQueryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerQueryInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerQueryInfo()

See Also

TrackerQueryInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


TrackerQueryInfo Methods

[image] [image]

OfficeClip API Documentation
TrackerQueryInfo Methods
TrackerQueryInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerQueryInfo type exposes the following methods.

Methods

 | Name | Description
Public method | CreateFilterString | Creates the query string and the display string for the filter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | fillDisplayBuffer | Fills the display buffer
Protected method | fillFilterBuffer |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getDateString | Converts the date object to the server timezone and then sends it to the database for execution
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerQueryInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


CreateFilterString Method

[image]

OfficeClip API Documentation
TrackerQueryInfo..::.CreateFilterString Method
TrackerQueryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Creates the query string and the display string for the filter

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
public void CreateFilterString(
    ref DataTable dt,
    ref string filterString,
    ref string displayString
)
Visual Basic (Declaration)
Public Sub CreateFilterString ( _
    ByRef dt As DataTable, _
    ByRef filterString As String, _
    ByRef displayString As String _
)
Visual C++
public:
void CreateFilterString(
    DataTable^% dt,
    String^% filterString,
    String^% displayString
)

Parameters

dt
Type: System.Data..::.DataTable%
The datatable which is populated by the user interface
filterString
Type: System..::.String%
The string which will be executed by the database if this option is selected
displayString
Type: System..::.String%
The string which will be displayed if the user wishes to see the query string in clear text

See Also

TrackerQueryInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


fillDisplayBuffer Method

[image]

OfficeClip API Documentation
TrackerQueryInfo..::.fillDisplayBuffer Method
TrackerQueryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Fills the display buffer

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void fillDisplayBuffer(
    ref StringBuilder displaySb,
    string str1,
    string str2,
    string str3
)
Visual Basic (Declaration)
Protected Sub fillDisplayBuffer ( _
    ByRef displaySb As StringBuilder, _
    str1 As String, _
    str2 As String, _
    str3 As String _
)
Visual C++
protected:
void fillDisplayBuffer(
    StringBuilder^% displaySb,
    String^ str1,
    String^ str2,
    String^ str3
)

Parameters

displaySb
Type: System.Text..::.StringBuilder%
The output stringbuilder
str1
Type: System..::.String
First string
str2
Type: System..::.String
Second string
str3
Type: System..::.String
Third string

See Also

TrackerQueryInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


fillFilterBuffer Method

[image]

OfficeClip API Documentation
TrackerQueryInfo..::.fillFilterBuffer Method
TrackerQueryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected void fillFilterBuffer(
    ref StringBuilder filterSb,
    string str1,
    string str2,
    string str3,
    string str4
)
Visual Basic (Declaration)
Protected Sub fillFilterBuffer ( _
    ByRef filterSb As StringBuilder, _
    str1 As String, _
    str2 As String, _
    str3 As String, _
    str4 As String _
)
Visual C++
protected:
void fillFilterBuffer(
    StringBuilder^% filterSb,
    String^ str1,
    String^ str2,
    String^ str3,
    String^ str4
)

Parameters

filterSb
Type: System.Text..::.StringBuilder%
str1
Type: System..::.String
str2
Type: System..::.String
str3
Type: System..::.String
str4
Type: System..::.String

See Also

TrackerQueryInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


getDateString Method

[image]

OfficeClip API Documentation
TrackerQueryInfo..::.getDateString Method
TrackerQueryInfo Class See Also

[This is preliminary documentation and is subject to change.]

Converts the date object to the server timezone and then sends it to the database for execution

Namespace: OfficeClip.BusinessLayer.Tracker
Assembly: OfficeClip.BusinessLayer (in OfficeClip.BusinessLayer)
Version: 8.1.1.0

Syntax

C#
protected string getDateString(
    Object o
)
Visual Basic (Declaration)
Protected Function getDateString ( _
    o As Object _
) As String
Visual C++
protected:
String^ getDateString(
    Object^ o
)

Parameters

o
Type: System..::.Object

Return Value

See Also

TrackerQueryInfo Class
OfficeClip.BusinessLayer.Tracker Namespace


OfficeClip.DBLayer Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer Namespace

[This is preliminary documentation and is subject to change.]

OfficeClip Database layer. This later facilitates communication between the database and various parts of OfficeClip

Classes

 | Class | Description
Public class | DBConstants | Constants for the business object
Public class | OfficeClipDB | The base class of the data layer.

Enumerations

 | Enumeration | Description
Public enumeration | DBConstants..::.DocumentPreInsertStatus | Defines the different possible return statuses while attempting to Insert a document.
Public enumeration | DBConstants..::.ProcessWhichEvent | Enumerated type for the type of event which can be processed
Public enumeration | DBConstants..::.ReturnValue | Return values for the DBLayer functions


DBConstants Class

[image]

OfficeClip API Documentation
DBConstants Class
Members See Also

[This is preliminary documentation and is subject to change.]

Constants for the business object

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class DBConstants
Visual Basic (Declaration)
Public Class DBConstants
Visual C++
public ref class DBConstants

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.DBConstants

See Also

DBConstants Members
OfficeClip.DBLayer Namespace


DBConstants Members

[image] [image]

OfficeClip API Documentation
DBConstants Members
DBConstants Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The DBConstants type exposes the following members.

Constructors

 | Name | Description
Public method | DBConstants |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
NoSpaceAvailable | Defines the constant to indicate that there is no space available for a new document to be created either for a user or for a group.
RuleTimesheetDayHours | The string to denote the total hours in a day in the rule timesheet
RuleTimesheetEmptyInfo | The string to denote the rule name for empty customer and task
RuleTimesheetNegativeTime | The string to denote negative time in the rule timesheet
RuleTimesheetTotalHours | The string to denote total hours in the rule timesheet

See Also

DBConstants Class
OfficeClip.DBLayer Namespace


DBConstants Constructor

[image]

OfficeClip API Documentation
DBConstants Constructor
DBConstants Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DBConstants()

See Also

DBConstants Class
OfficeClip.DBLayer Namespace


DBConstants Fields

[image] [image]

OfficeClip API Documentation
DBConstants Fields
DBConstants Class See Also

[This is preliminary documentation and is subject to change.]

The DBConstants type exposes the following fields.

Fields

Name | Description
NoSpaceAvailable | Defines the constant to indicate that there is no space available for a new document to be created either for a user or for a group.
RuleTimesheetDayHours | The string to denote the total hours in a day in the rule timesheet
RuleTimesheetEmptyInfo | The string to denote the rule name for empty customer and task
RuleTimesheetNegativeTime | The string to denote negative time in the rule timesheet
RuleTimesheetTotalHours | The string to denote total hours in the rule timesheet

See Also

DBConstants Class
OfficeClip.DBLayer Namespace


NoSpaceAvailable Field

[image]

OfficeClip API Documentation
DBConstants..::.NoSpaceAvailable Field
DBConstants Class See Also

[This is preliminary documentation and is subject to change.]

Defines the constant to indicate that there is no space available for a new document to be created either for a user or for a group.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly int NoSpaceAvailable
Visual Basic (Declaration)
Public Shared ReadOnly NoSpaceAvailable As Integer
Visual C++
public:
static initonly int NoSpaceAvailable

See Also

DBConstants Class
OfficeClip.DBLayer Namespace


RuleTimesheetDayHours Field

[image]

OfficeClip API Documentation
DBConstants..::.RuleTimesheetDayHours Field
DBConstants Class See Also

[This is preliminary documentation and is subject to change.]

The string to denote the total hours in a day in the rule timesheet

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly string RuleTimesheetDayHours
Visual Basic (Declaration)
Public Shared ReadOnly RuleTimesheetDayHours As String
Visual C++
public:
static initonly String^ RuleTimesheetDayHours

See Also

DBConstants Class
OfficeClip.DBLayer Namespace


RuleTimesheetEmptyInfo Field

[image]

OfficeClip API Documentation
DBConstants..::.RuleTimesheetEmptyInfo Field
DBConstants Class See Also

[This is preliminary documentation and is subject to change.]

The string to denote the rule name for empty customer and task

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly string RuleTimesheetEmptyInfo
Visual Basic (Declaration)
Public Shared ReadOnly RuleTimesheetEmptyInfo As String
Visual C++
public:
static initonly String^ RuleTimesheetEmptyInfo

See Also

DBConstants Class
OfficeClip.DBLayer Namespace


RuleTimesheetNegativeTime Field

[image]

OfficeClip API Documentation
DBConstants..::.RuleTimesheetNegativeTime Field
DBConstants Class See Also

[This is preliminary documentation and is subject to change.]

The string to denote negative time in the rule timesheet

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly string RuleTimesheetNegativeTime
Visual Basic (Declaration)
Public Shared ReadOnly RuleTimesheetNegativeTime As String
Visual C++
public:
static initonly String^ RuleTimesheetNegativeTime

See Also

DBConstants Class
OfficeClip.DBLayer Namespace


RuleTimesheetTotalHours Field

[image]

OfficeClip API Documentation
DBConstants..::.RuleTimesheetTotalHours Field
DBConstants Class See Also

[This is preliminary documentation and is subject to change.]

The string to denote total hours in the rule timesheet

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static readonly string RuleTimesheetTotalHours
Visual Basic (Declaration)
Public Shared ReadOnly RuleTimesheetTotalHours As String
Visual C++
public:
static initonly String^ RuleTimesheetTotalHours

See Also

DBConstants Class
OfficeClip.DBLayer Namespace


DBConstants.DocumentPreInsertStatus Enumeration

[image]

OfficeClip API Documentation
DBConstants..::.DocumentPreInsertStatus Enumeration
DBConstants Class See Also

[This is preliminary documentation and is subject to change.]

Defines the different possible return statuses while attempting to Insert a document.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public enum DocumentPreInsertStatus
Visual Basic (Declaration)
Public Enumeration DocumentPreInsertStatus
Visual C++
public enum class DocumentPreInsertStatus

Members

Member name | Description
Success | Indicates that the pre Insert status was successful.
Failure | Indicates that the pre Insert status check failed.
NoSpaceAvailable | Indicates that there is no space available.
FileExistsPermissionOk | Indicates that the file exists and the permission is ok.
FileExistsNoPermission | Indicates that file exists and there was no permission on the file.
FileExistsAndShared | Indicates that the file exists and is shared.
FileLocked | Indicates that the file is locked.
InvalidCharactersInFileName | Indicates that there were invalid characters in the file name.
MovedOrCopiedFileInSameFolder | Indicates that file is being moved or copied from a particular folder to the same folder.
NoWritePermission | Indicates that the current user does not have any write permission on the file

See Also

OfficeClip.DBLayer Namespace


DBConstants.ProcessWhichEvent Enumeration

[image]

OfficeClip API Documentation
DBConstants..::.ProcessWhichEvent Enumeration
DBConstants Class See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for the type of event which can be processed

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public enum ProcessWhichEvent
Visual Basic (Declaration)
Public Enumeration ProcessWhichEvent
Visual C++
public enum class ProcessWhichEvent

Members

Member name | Description
ThisEventOnly | Only the current event can be processed
AllFutureEvents | All future events can be processed
AllEvents | All events including the current and the future can be processed
NonRecurring | A non recurring event and is a special case

See Also

OfficeClip.DBLayer Namespace


DBConstants.ReturnValue Enumeration

[image]

OfficeClip API Documentation
DBConstants..::.ReturnValue Enumeration
DBConstants Class See Also

[This is preliminary documentation and is subject to change.]

Return values for the DBLayer functions

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public enum ReturnValue
Visual Basic (Declaration)
Public Enumeration ReturnValue
Visual C++
public enum class ReturnValue

Members

Member name | Description
Success | Shows Success value
Failure | Shows failure value
DuplicateValue | Insertion failed because there is a duplicate entry in the database
RegisteredUsersOnly | Feature only reserved for registered users

See Also

OfficeClip.DBLayer Namespace


OfficeClipDB Class

[image]

OfficeClip API Documentation
OfficeClipDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

The base class of the data layer.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class OfficeClipDB : IDisposable
Visual Basic (Declaration)
Public Class OfficeClipDB _
    Implements IDisposable
Visual C++
public ref class OfficeClipDB : IDisposable

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Security..::.SecurityObjectDB
OfficeClip.DBLayer.Security..::.RolesDB
OfficeClip.DBLayer.Service..::.EventDB
OfficeClip.DBLayer.Metabase..::.MetaSqlDB
OfficeClip.DBLayer.Metabase..::.MetaDB
OfficeClip.DBLayer.Metabase..::.TrackerMetaDB
OfficeClip.DBLayer.Metabase..::.MetaAdminDB
OfficeClip.DBLayer.Metabase..::.MetaFilterDB
OfficeClip.DBLayer.Framework..::.RemoveUserDataDB
OfficeClip.DBLayer.Framework..::.TrackTimeDB
OfficeClip.DBLayer.Framework..::.ReminderDB
OfficeClip.DBLayer.Framework..::.WorkflowDB
OfficeClip.DBLayer.Framework..::.TimezoneDB
OfficeClip.DBLayer.Framework..::.GlobalDB
OfficeClip.DBLayer.Framework..::.AddressDB
OfficeClip.DBLayer.Framework..::.ReportDB
OfficeClip.DBLayer.Framework..::.ApplicationDB
OfficeClip.DBLayer.Framework..::.FrameworkDB
OfficeClip.DBLayer.Framework..::.OCSmsDB
OfficeClip.DBLayer.Framework..::.GeneralDB
OfficeClip.DBLayer.Framework..::.HolidaysDB
OfficeClip.DBLayer.Framework..::.ProfileDB
OfficeClip.DBLayer.Desktop..::.TaskDB
OfficeClip.DBLayer.Desktop..::.NoticeDB
OfficeClip.DBLayer.Desktop..::.DocumentDB
OfficeClip.DBLayer.Desktop..::.EmailDB
OfficeClip.DBLayer.Desktop..::.AddressBookDB
OfficeClip.DBLayer.Desktop..::.DocumentViewDB
OfficeClip.DBLayer.Desktop..::.CalendarDB
OfficeClip.DBLayer.Desktop..::.ResourcesDB
OfficeClip.DBLayer.Tracker..::.TrackerEmailDB
OfficeClip.DBLayer.Tracker..::.TrackerSyncDB
OfficeClip.DBLayer.Tracker..::.TrackerDB
OfficeClip.DBLayer.TE..::.QuickBooksDB
OfficeClip.DBLayer.TE..::.PunchDB
OfficeClip.DBLayer.TE..::.TimesheetDB
OfficeClip.DBLayer.TE..::.PaymentsDB
OfficeClip.DBLayer.TE..::.ExpenseDB
OfficeClip.DBLayer.TE..::.CommonDB
OfficeClip.DBLayer.Account..::.InviteMemberDB
OfficeClip.DBLayer.Account..::.UserInfoDB
OfficeClip.DBLayer.Account..::.LdapDB
OfficeClip.DBLayer.Account..::.SubscriptionDB
OfficeClip.DBLayer.Account..::.ImportExportDB
OfficeClip.DBLayer.Account..::.MainDB
OfficeClip.DBLayer.Account..::.AccountDB
OfficeClip.DBLayer.Account..::.GroupDB
OfficeClip.DBLayer.Account..::.UserDB
OfficeClip.DBLayer.Account..::.SmsInfoDB
OfficeClip.DBLayer.Template..::.LetterheadDB
OfficeClip.DBLayer.Template..::.TemplateDB
OfficeClip.DBLayer.OfficePortal..::.AlertDB
OfficeClip.DBLayer.OfficePortal..::.NotesDB
OfficeClip.DBLayer.OfficePortal..::.PhotoDB
OfficeClip.DBLayer.OfficePortal..::.GroupbookmarkDB
OfficeClip.DBLayer.OfficePortal..::.PortletDB
OfficeClip.DBLayer.OfficePortal..::.PollDB
OfficeClip.DBLayer.OfficePortal..::.BbDB
OfficeClip.DBLayer.OfficePortal..::.AnnounceDB
OfficeClip.DBLayer.Reports..::.RdlReportDB
OfficeClip.DBLayer.Extranet..::.ExtranetDB
OfficeClip.DBLayer.Projects..::.ProjectDB
OfficeClip.DBLayer.Provider..::.PersonalizationDB
OfficeClip.DBLayer.Rules..::.RulesInfoDB
OfficeClip.DBLayer.Oem..::.OemDB

See Also

OfficeClipDB Members
OfficeClip.DBLayer Namespace


OfficeClipDB Members

[image] [image]

OfficeClip API Documentation
OfficeClipDB Members
OfficeClipDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OfficeClipDB type exposes the following members.

Constructors

 | Name | Description
Public method | OfficeClipDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters
Public method | Close | Close the connection, data adapter and the command
Public method | Commit | Commits the transaction
Public method | Dispose | disposes the object for garbage collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader
Protected method | ExecuteScalar | Executes the query that returns a single valur
Protected method | Fill | Fills the dataset
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count
Public method | GetParameterValue | Gets the value of the parameter
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application.
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set.

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


OfficeClipDB Constructor

[image] [image]

OfficeClip API Documentation
OfficeClipDB Constructor
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OfficeClipDB()()() | The default constructor
Public method | OfficeClipDB(Boolean) | Constructor
Public method | OfficeClipDB(String) | Constructor
Public method | OfficeClipDB(OfficeClipDB) | The copy constructor

See Also

OfficeClipDB Class
OfficeClipDB Members
OfficeClip.DBLayer Namespace


OfficeClipDB Constructor

[image]

OfficeClip API Documentation
OfficeClipDB Constructor
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OfficeClipDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OfficeClipDB()

See Also

OfficeClipDB Class
OfficeClipDB Overload
OfficeClip.DBLayer Namespace


OfficeClipDB Constructor (Boolean)

[image]

OfficeClip API Documentation
OfficeClipDB Constructor (Boolean)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OfficeClipDB(
    bool isSync
)
Visual Basic (Declaration)
Public Sub New ( _
    isSync As Boolean _
)
Visual C++
public:
OfficeClipDB(
    bool isSync
)

Parameters

isSync
Type: System..::.Boolean
true if the sync is enabled

See Also

OfficeClipDB Class
OfficeClipDB Overload
OfficeClip.DBLayer Namespace


OfficeClipDB Constructor (String)

[image]

OfficeClip API Documentation
OfficeClipDB Constructor (String)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OfficeClipDB(
    string connString
)
Visual Basic (Declaration)
Public Sub New ( _
    connString As String _
)
Visual C++
public:
OfficeClipDB(
    String^ connString
)

Parameters

connString
Type: System..::.String
The connection string

See Also

OfficeClipDB Class
OfficeClipDB Overload
OfficeClip.DBLayer Namespace


OfficeClipDB Constructor (OfficeClipDB)

[image]

OfficeClip API Documentation
OfficeClipDB Constructor (OfficeClipDB)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

The copy constructor

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OfficeClipDB(
    OfficeClipDB odb
)
Visual Basic (Declaration)
Public Sub New ( _
    odb As OfficeClipDB _
)
Visual C++
public:
OfficeClipDB(
    OfficeClipDB^ odb
)

Parameters

odb
Type: OfficeClip.DBLayer..::.OfficeClipDB
The OfficeClipDB object that needs to be copied

See Also

OfficeClipDB Class
OfficeClipDB Overload
OfficeClip.DBLayer Namespace


OfficeClipDB Methods

[image] [image]

OfficeClip API Documentation
OfficeClipDB Methods
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

The OfficeClipDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters
Public method | Close | Close the connection, data adapter and the command
Public method | Commit | Commits the transaction
Public method | Dispose | disposes the object for garbage collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader
Protected method | ExecuteScalar | Executes the query that returns a single valur
Protected method | Fill | Fills the dataset
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count
Public method | GetParameterValue | Gets the value of the parameter
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
OfficeClipDB..::.AddOutputParameter Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip.

See Also

OfficeClipDB Class
OfficeClipDB Members
OfficeClip.DBLayer Namespace


AddOutputParameter Method (String, SqlDbType, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddOutputParameter Method (String, SqlDbType, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds an output parameter

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SqlParameter AddOutputParameter(
    string parameterSP,
    SqlDbType sdt,
    int size
)
Visual Basic (Declaration)
Public Function AddOutputParameter ( _
    parameterSP As String, _
    sdt As SqlDbType, _
    size As Integer _
) As SqlParameter
Visual C++
public:
SqlParameter^ AddOutputParameter(
    String^ parameterSP,
    SqlDbType sdt,
    int size
)

Parameters

parameterSP
Type: System..::.String
The name of the stored procedure parameter
sdt
Type: System.Data..::.SqlDbType
The sql data type
size
Type: System..::.Int32
The size of the parameter

Return Value

The sql parameter object

See Also

OfficeClipDB Class
AddOutputParameter Overload
OfficeClip.DBLayer Namespace


AddOutputParameter Method (SqlCommand, String, SqlDbType, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddOutputParameter Method (SqlCommand, String, SqlDbType, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds output parameter and returns the parameter

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected SqlParameter AddOutputParameter(
    SqlCommand myCommand,
    string parameterSP,
    SqlDbType sdt,
    int size
)
Visual Basic (Declaration)
Protected Function AddOutputParameter ( _
    myCommand As SqlCommand, _
    parameterSP As String, _
    sdt As SqlDbType, _
    size As Integer _
) As SqlParameter
Visual C++
protected:
SqlParameter^ AddOutputParameter(
    SqlCommand^ myCommand,
    String^ parameterSP,
    SqlDbType sdt,
    int size
)

Parameters

myCommand
Type: System.Data.SqlClient..::.SqlCommand
The SqlCommand object passed as reference
parameterSP
Type: System..::.String
The Stored Procudure parameter name string
sdt
Type: System.Data..::.SqlDbType
SqlDbType enumerated type to ensure the parameter type is correctly passed
size
Type: System..::.Int32
size of the input parameter

See Also

OfficeClipDB Class
AddOutputParameter Overload
OfficeClip.DBLayer Namespace


AddOutputParameter Method (String, SqlDbType, Int32, Int32, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddOutputParameter Method (String, SqlDbType, Int32, Int32, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds an output parameter

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SqlParameter AddOutputParameter(
    string parameterSP,
    SqlDbType sdt,
    int size,
    int precision,
    int scale
)
Visual Basic (Declaration)
Public Function AddOutputParameter ( _
    parameterSP As String, _
    sdt As SqlDbType, _
    size As Integer, _
    precision As Integer, _
    scale As Integer _
) As SqlParameter
Visual C++
public:
SqlParameter^ AddOutputParameter(
    String^ parameterSP,
    SqlDbType sdt,
    int size,
    int precision,
    int scale
)

Parameters

parameterSP
Type: System..::.String
The name of the stored procedure parameter
sdt
Type: System.Data..::.SqlDbType
The sql data type
size
Type: System..::.Int32
The size of the parameter
precision
Type: System..::.Int32
The precision of the parameter
scale
Type: System..::.Int32
The scale of the parameter

Return Value

The sql parameter object

See Also

OfficeClipDB Class
AddOutputParameter Overload
OfficeClip.DBLayer Namespace


AddOutputParameter Method (SqlCommand, String, SqlDbType, Int32, Int32, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddOutputParameter Method (SqlCommand, String, SqlDbType, Int32, Int32, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Provides a way to add the output parameter to OfficeClip.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected SqlParameter AddOutputParameter(
    SqlCommand myCommand,
    string parameterSP,
    SqlDbType sdt,
    int size,
    int precision,
    int scale
)
Visual Basic (Declaration)
Protected Function AddOutputParameter ( _
    myCommand As SqlCommand, _
    parameterSP As String, _
    sdt As SqlDbType, _
    size As Integer, _
    precision As Integer, _
    scale As Integer _
) As SqlParameter
Visual C++
protected:
SqlParameter^ AddOutputParameter(
    SqlCommand^ myCommand,
    String^ parameterSP,
    SqlDbType sdt,
    int size,
    int precision,
    int scale
)

Parameters

myCommand
Type: System.Data.SqlClient..::.SqlCommand
The sql command parameter
parameterSP
Type: System..::.String
The stored procedure to put the output parameter.
sdt
Type: System.Data..::.SqlDbType
The db type parameter.
size
Type: System..::.Int32
The size of the field.
precision
Type: System..::.Int32
The precision of the field for float, double etc.
scale
Type: System..::.Int32
The scale of the field.

Return Value

The sql output parameter object.

See Also

OfficeClipDB Class
AddOutputParameter Overload
OfficeClip.DBLayer Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameter Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list.
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list.
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list.
Public method | AddParameter(String, String) | Adds a parameter to the parameter list.
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list.
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list.

See Also

OfficeClipDB Class
OfficeClipDB Members
OfficeClip.DBLayer Namespace


AddParameter Method (String, Boolean)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameter Method (String, Boolean)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a parameter to the parameter list.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void AddParameter(
    string parameterSP,
    bool parameterValue
)
Visual Basic (Declaration)
Public Sub AddParameter ( _
    parameterSP As String, _
    parameterValue As Boolean _
)
Visual C++
public:
void AddParameter(
    String^ parameterSP,
    bool parameterValue
)

Parameters

parameterSP
Type: System..::.String
The name of the stored procedure parameter
parameterValue
Type: System..::.Boolean
The value of the parameter

See Also

OfficeClipDB Class
AddParameter Overload
OfficeClip.DBLayer Namespace


AddParameter Method (String, Byte[])

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameter Method (String, array<Byte>[]()[])
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds the stored procedure parameter

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void AddParameter(
    string parameterSP,
    byte[] parameterValue
)
Visual Basic (Declaration)
Public Sub AddParameter ( _
    parameterSP As String, _
    parameterValue As Byte() _
)
Visual C++
public:
void AddParameter(
    String^ parameterSP,
    array<unsigned char>^ parameterValue
)

Parameters

parameterSP
Type: System..::.String
parameterValue
Type: array<System..::.Byte>[]()[]

See Also

OfficeClipDB Class
AddParameter Overload
OfficeClip.DBLayer Namespace


AddParameter Method (String, DateTime)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameter Method (String, DateTime)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a parameter to the parameter list.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void AddParameter(
    string parameterSP,
    DateTime parameterValue
)
Visual Basic (Declaration)
Public Sub AddParameter ( _
    parameterSP As String, _
    parameterValue As DateTime _
)
Visual C++
public:
void AddParameter(
    String^ parameterSP,
    DateTime parameterValue
)

Parameters

parameterSP
Type: System..::.String
The name of the stored procedure parameter
parameterValue
Type: System..::.DateTime
The value of the parameter

See Also

OfficeClipDB Class
AddParameter Overload
OfficeClip.DBLayer Namespace


AddParameter Method (String, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameter Method (String, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a parameter to the parameter list.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void AddParameter(
    string parameterSP,
    int parameterValue
)
Visual Basic (Declaration)
Public Sub AddParameter ( _
    parameterSP As String, _
    parameterValue As Integer _
)
Visual C++
public:
void AddParameter(
    String^ parameterSP,
    int parameterValue
)

Parameters

parameterSP
Type: System..::.String
The name of the stored procedure parameter
parameterValue
Type: System..::.Int32
The value of the parameter

See Also

OfficeClipDB Class
AddParameter Overload
OfficeClip.DBLayer Namespace


AddParameter Method (String, String)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameter Method (String, String)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a parameter to the parameter list.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void AddParameter(
    string parameterSP,
    string parameterValue
)
Visual Basic (Declaration)
Public Sub AddParameter ( _
    parameterSP As String, _
    parameterValue As String _
)
Visual C++
public:
void AddParameter(
    String^ parameterSP,
    String^ parameterValue
)

Parameters

parameterSP
Type: System..::.String
The name of the stored procedure parameter
parameterValue
Type: System..::.String
The value of the parameter

See Also

OfficeClipDB Class
AddParameter Overload
OfficeClip.DBLayer Namespace


AddParameter Method (String, SqlDbType, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameter Method (String, SqlDbType, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a parameter to the parameter list. The parameter value will be null

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void AddParameter(
    string parameterSP,
    SqlDbType sdt,
    int size
)
Visual Basic (Declaration)
Public Sub AddParameter ( _
    parameterSP As String, _
    sdt As SqlDbType, _
    size As Integer _
)
Visual C++
public:
void AddParameter(
    String^ parameterSP,
    SqlDbType sdt,
    int size
)

Parameters

parameterSP
Type: System..::.String
The name of the stored procedure parameter
sdt
Type: System.Data..::.SqlDbType
The sql data type
size
Type: System..::.Int32
The size of the parameter in bytes

See Also

OfficeClipDB Class
AddParameter Overload
OfficeClip.DBLayer Namespace


AddParameter Method (String, String, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameter Method (String, String, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a parameter to the parameter list.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void AddParameter(
    string parameterSP,
    string parameterValue,
    int size
)
Visual Basic (Declaration)
Public Sub AddParameter ( _
    parameterSP As String, _
    parameterValue As String, _
    size As Integer _
)
Visual C++
public:
void AddParameter(
    String^ parameterSP,
    String^ parameterValue,
    int size
)

Parameters

parameterSP
Type: System..::.String
The name of the stored procedure parameter
parameterValue
Type: System..::.String
The value of the parameter
size
Type: System..::.Int32
The size of the parameter in bytes

See Also

OfficeClipDB Class
AddParameter Overload
OfficeClip.DBLayer Namespace


AddParameter Method (String, Double, Int32, Int32, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameter Method (String, Double, Int32, Int32, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a parameter to the parameter list.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void AddParameter(
    string parameterSP,
    double parameterValue,
    int size,
    int precision,
    int scale
)
Visual Basic (Declaration)
Public Sub AddParameter ( _
    parameterSP As String, _
    parameterValue As Double, _
    size As Integer, _
    precision As Integer, _
    scale As Integer _
)
Visual C++
public:
void AddParameter(
    String^ parameterSP,
    double parameterValue,
    int size,
    int precision,
    int scale
)

Parameters

parameterSP
Type: System..::.String
The name of the stored procedure parameter
parameterValue
Type: System..::.Double
The value of the parameter
size
Type: System..::.Int32
The size of the parameter in bytes
precision
Type: System..::.Int32
The precision of the parameter
scale
Type: System..::.Int32
The scale of the parameter

See Also

OfficeClipDB Class
AddParameter Overload
OfficeClip.DBLayer Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameters Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure.
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure.
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.

See Also

OfficeClipDB Class
OfficeClipDB Members
OfficeClip.DBLayer Namespace


AddParameters Method (SqlCommand, String, Byte[], SqlDbType)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameters Method (SqlCommand, String, array<Byte>[]()[], SqlDbType)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AddParameters(
    SqlCommand myCommand,
    string parameterSP,
    byte[] parameterValue,
    SqlDbType sdt
)
Visual Basic (Declaration)
Protected Sub AddParameters ( _
    myCommand As SqlCommand, _
    parameterSP As String, _
    parameterValue As Byte(), _
    sdt As SqlDbType _
)
Visual C++
protected:
void AddParameters(
    SqlCommand^ myCommand,
    String^ parameterSP,
    array<unsigned char>^ parameterValue,
    SqlDbType sdt
)

Parameters

myCommand
Type: System.Data.SqlClient..::.SqlCommand
The SqlCommand object passed as reference.
parameterSP
Type: System..::.String
The Stored Procudure parameter name string.
parameterValue
Type: array<System..::.Byte>[]()[]
The value of the parameter to be assigned in integer.
sdt
Type: System.Data..::.SqlDbType
SqlDbType enumerated type to ensure the parameter type is correctly passed.

See Also

OfficeClipDB Class
AddParameters Overload
OfficeClip.DBLayer Namespace


AddParameters Method (SqlCommand, String, SqlDbType, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameters Method (SqlCommand, String, SqlDbType, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a null parameter for the stored procedure.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AddParameters(
    SqlCommand myCommand,
    string parameterSP,
    SqlDbType sdt,
    int size
)
Visual Basic (Declaration)
Protected Sub AddParameters ( _
    myCommand As SqlCommand, _
    parameterSP As String, _
    sdt As SqlDbType, _
    size As Integer _
)
Visual C++
protected:
void AddParameters(
    SqlCommand^ myCommand,
    String^ parameterSP,
    SqlDbType sdt,
    int size
)

Parameters

myCommand
Type: System.Data.SqlClient..::.SqlCommand
The SqlCommand object passed as reference.
parameterSP
Type: System..::.String
The Stored Procedure parameter name string.
sdt
Type: System.Data..::.SqlDbType
SqlDbType enumerated type to ensure the parameter type is correctly passed.
size
Type: System..::.Int32
size of the input parameter.

See Also

OfficeClipDB Class
AddParameters Overload
OfficeClip.DBLayer Namespace


AddParameters Method (SqlCommand, String, String, SqlDbType)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameters Method (SqlCommand, String, String, SqlDbType)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AddParameters(
    SqlCommand myCommand,
    string parameterSP,
    string parameterValue,
    SqlDbType sdt
)
Visual Basic (Declaration)
Protected Sub AddParameters ( _
    myCommand As SqlCommand, _
    parameterSP As String, _
    parameterValue As String, _
    sdt As SqlDbType _
)
Visual C++
protected:
void AddParameters(
    SqlCommand^ myCommand,
    String^ parameterSP,
    String^ parameterValue,
    SqlDbType sdt
)

Parameters

myCommand
Type: System.Data.SqlClient..::.SqlCommand
The SqlCommand object passed as reference.
parameterSP
Type: System..::.String
The Stored Procudure parameter name string.
parameterValue
Type: System..::.String
The value of the parameter to be assigned in string.
sdt
Type: System.Data..::.SqlDbType
SqlDbType enumerated type to ensure the parameter type is correctly passed.

See Also

OfficeClipDB Class
AddParameters Overload
OfficeClip.DBLayer Namespace


AddParameters Method (SqlCommand, String, Boolean, SqlDbType, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameters Method (SqlCommand, String, Boolean, SqlDbType, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a boolean parameter for the stored procedure.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AddParameters(
    SqlCommand myCommand,
    string parameterSP,
    bool parameterValue,
    SqlDbType sdt,
    int size
)
Visual Basic (Declaration)
Protected Sub AddParameters ( _
    myCommand As SqlCommand, _
    parameterSP As String, _
    parameterValue As Boolean, _
    sdt As SqlDbType, _
    size As Integer _
)
Visual C++
protected:
void AddParameters(
    SqlCommand^ myCommand,
    String^ parameterSP,
    bool parameterValue,
    SqlDbType sdt,
    int size
)

Parameters

myCommand
Type: System.Data.SqlClient..::.SqlCommand
The SqlCommand object passed as reference.
parameterSP
Type: System..::.String
The Stored Procedure parameter name string.
parameterValue
Type: System..::.Boolean
The value of the parameter
sdt
Type: System.Data..::.SqlDbType
SqlDbType enumerated type to ensure the parameter type is correctly passed.
size
Type: System..::.Int32
size of the input parameter.

See Also

OfficeClipDB Class
AddParameters Overload
OfficeClip.DBLayer Namespace


AddParameters Method (SqlCommand, String, DateTime, SqlDbType, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameters Method (SqlCommand, String, DateTime, SqlDbType, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AddParameters(
    SqlCommand myCommand,
    string parameterSP,
    DateTime parameterValue,
    SqlDbType sdt,
    int size
)
Visual Basic (Declaration)
Protected Sub AddParameters ( _
    myCommand As SqlCommand, _
    parameterSP As String, _
    parameterValue As DateTime, _
    sdt As SqlDbType, _
    size As Integer _
)
Visual C++
protected:
void AddParameters(
    SqlCommand^ myCommand,
    String^ parameterSP,
    DateTime parameterValue,
    SqlDbType sdt,
    int size
)

Parameters

myCommand
Type: System.Data.SqlClient..::.SqlCommand
The SqlCommand object passed as reference.
parameterSP
Type: System..::.String
The Stored Procudure parameter name string.
parameterValue
Type: System..::.DateTime
The value of the parameter to be assigned in datetime.
sdt
Type: System.Data..::.SqlDbType
SqlDbType enumerated type to ensure the parameter type is correctly passed.
size
Type: System..::.Int32
size of the input parameter.

See Also

OfficeClipDB Class
AddParameters Overload
OfficeClip.DBLayer Namespace


AddParameters Method (SqlCommand, String, Int32, SqlDbType, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameters Method (SqlCommand, String, Int32, SqlDbType, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AddParameters(
    SqlCommand myCommand,
    string parameterSP,
    int parameterValue,
    SqlDbType sdt,
    int size
)
Visual Basic (Declaration)
Protected Sub AddParameters ( _
    myCommand As SqlCommand, _
    parameterSP As String, _
    parameterValue As Integer, _
    sdt As SqlDbType, _
    size As Integer _
)
Visual C++
protected:
void AddParameters(
    SqlCommand^ myCommand,
    String^ parameterSP,
    int parameterValue,
    SqlDbType sdt,
    int size
)

Parameters

myCommand
Type: System.Data.SqlClient..::.SqlCommand
The SqlCommand object passed as reference.
parameterSP
Type: System..::.String
The Stored Procudure parameter name string.
parameterValue
Type: System..::.Int32
The value of the parameter to be assigned in integer.
sdt
Type: System.Data..::.SqlDbType
SqlDbType enumerated type to ensure the parameter type is correctly passed.
size
Type: System..::.Int32
size of the input parameter.

See Also

OfficeClipDB Class
AddParameters Overload
OfficeClip.DBLayer Namespace


AddParameters Method (SqlCommand, String, String, SqlDbType, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameters Method (SqlCommand, String, String, SqlDbType, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AddParameters(
    SqlCommand myCommand,
    string parameterSP,
    string parameterValue,
    SqlDbType sdt,
    int size
)
Visual Basic (Declaration)
Protected Sub AddParameters ( _
    myCommand As SqlCommand, _
    parameterSP As String, _
    parameterValue As String, _
    sdt As SqlDbType, _
    size As Integer _
)
Visual C++
protected:
void AddParameters(
    SqlCommand^ myCommand,
    String^ parameterSP,
    String^ parameterValue,
    SqlDbType sdt,
    int size
)

Parameters

myCommand
Type: System.Data.SqlClient..::.SqlCommand
The SqlCommand object passed as reference.
parameterSP
Type: System..::.String
The Stored Procudure parameter name string.
parameterValue
Type: System..::.String
The value of the parameter to be assigned in string.
sdt
Type: System.Data..::.SqlDbType
SqlDbType enumerated type to ensure the parameter type is correctly passed.
size
Type: System..::.Int32
size of the input parameter.

See Also

OfficeClipDB Class
AddParameters Overload
OfficeClip.DBLayer Namespace


AddParameters Method (SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.AddParameters Method (SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AddParameters(
    SqlCommand myCommand,
    string parameterSP,
    double parameterValue,
    SqlDbType sdt,
    int size,
    int precision,
    int scale
)
Visual Basic (Declaration)
Protected Sub AddParameters ( _
    myCommand As SqlCommand, _
    parameterSP As String, _
    parameterValue As Double, _
    sdt As SqlDbType, _
    size As Integer, _
    precision As Integer, _
    scale As Integer _
)
Visual C++
protected:
void AddParameters(
    SqlCommand^ myCommand,
    String^ parameterSP,
    double parameterValue,
    SqlDbType sdt,
    int size,
    int precision,
    int scale
)

Parameters

myCommand
Type: System.Data.SqlClient..::.SqlCommand
The SqlCommand object passed as reference.
parameterSP
Type: System..::.String
The Stored Procudure parameter name string.
parameterValue
Type: System..::.Double
The value of the parameter to be assigned in double.
sdt
Type: System.Data..::.SqlDbType
SqlDbType enumerated type to ensure the parameter type is correctly passed.
size
Type: System..::.Int32
size of the input parameter.
precision
Type: System..::.Int32
Precision of the input parameter.
scale
Type: System..::.Int32
Scale of the input parameter.

See Also

OfficeClipDB Class
AddParameters Overload
OfficeClip.DBLayer Namespace


ClearParameters Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.ClearParameters Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Clear all the sql stored procedure parameters

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void ClearParameters()
Visual Basic (Declaration)
Public Sub ClearParameters
Visual C++
public:
void ClearParameters()

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


Close Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.Close Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Close the connection, data adapter and the command

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


Commit Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.Commit Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Commits the transaction

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Commit()
Visual Basic (Declaration)
Public Sub Commit
Visual C++
public:
void Commit()

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


Dispose Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.Dispose Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

disposes the object for garbage collection

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
OfficeClipDB..::.ExecuteNonQuery Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query
Protected method | ExecuteNonQuery(Boolean) |
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels

See Also

OfficeClipDB Class
OfficeClipDB Members
OfficeClip.DBLayer Namespace


ExecuteNonQuery Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.ExecuteNonQuery Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Executes the query

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void ExecuteNonQuery()
Visual Basic (Declaration)
Protected Sub ExecuteNonQuery
Visual C++
protected:
void ExecuteNonQuery()

See Also

OfficeClipDB Class
ExecuteNonQuery Overload
OfficeClip.DBLayer Namespace


ExecuteNonQuery Method (Boolean)

[image]

OfficeClip API Documentation
OfficeClipDB..::.ExecuteNonQuery Method (Boolean)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void ExecuteNonQuery(
    bool isTransaction
)
Visual Basic (Declaration)
Protected Sub ExecuteNonQuery ( _
    isTransaction As Boolean _
)
Visual C++
protected:
void ExecuteNonQuery(
    bool isTransaction
)

Parameters

isTransaction
Type: System..::.Boolean

See Also

OfficeClipDB Class
ExecuteNonQuery Overload
OfficeClip.DBLayer Namespace


ExecuteNonQuery Method (IsolationLevel)

[image]

OfficeClip API Documentation
OfficeClipDB..::.ExecuteNonQuery Method (IsolationLevel)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Executes the query with isolation levels

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void ExecuteNonQuery(
    IsolationLevel transactionIsolationLevel
)
Visual Basic (Declaration)
Protected Sub ExecuteNonQuery ( _
    transactionIsolationLevel As IsolationLevel _
)
Visual C++
protected:
void ExecuteNonQuery(
    IsolationLevel transactionIsolationLevel
)

Parameters

transactionIsolationLevel
Type: System.Data..::.IsolationLevel

See Also

OfficeClipDB Class
ExecuteNonQuery Overload
OfficeClip.DBLayer Namespace


ExecuteReader Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.ExecuteReader Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Executes the sql datareader

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected SqlDataReader ExecuteReader()
Visual Basic (Declaration)
Protected Function ExecuteReader As SqlDataReader
Visual C++
protected:
SqlDataReader^ ExecuteReader()

Return Value

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


ExecuteScalar Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.ExecuteScalar Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Executes the query that returns a single valur

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected Object ExecuteScalar()
Visual Basic (Declaration)
Protected Function ExecuteScalar As Object
Visual C++
protected:
Object^ ExecuteScalar()

Return Value

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


Fill Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.Fill Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Fills the dataset

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected DataSet Fill()
Visual Basic (Declaration)
Protected Function Fill As DataSet
Visual C++
protected:
DataSet^ Fill()

Return Value

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


GetParameterCount Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.GetParameterCount Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the parameter count

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetParameterCount()
Visual Basic (Declaration)
Public Function GetParameterCount As Integer
Visual C++
public:
int GetParameterCount()

Return Value

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


GetParameterValue Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.GetParameterValue Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the value of the parameter

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public Object GetParameterValue(
    string parameter
)
Visual Basic (Declaration)
Public Function GetParameterValue ( _
    parameter As String _
) As Object
Visual C++
public:
Object^ GetParameterValue(
    String^ parameter
)

Parameters

parameter
Type: System..::.String
The name of the parameter

Return Value

The value of the parameter as returned as an object. This value should be typecasted appropriately.

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


Init Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.Init Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Initialize the connection parameters

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void Init()
Visual Basic (Declaration)
Protected Sub Init
Visual C++
protected:
void Init()

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
OfficeClipDB..::.InitTransaction Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters

See Also

OfficeClipDB Class
OfficeClipDB Members
OfficeClip.DBLayer Namespace


InitTransaction Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.InitTransaction Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Initialize the connection string and the transaction parameters

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InitTransaction()
Visual Basic (Declaration)
Public Sub InitTransaction
Visual C++
public:
void InitTransaction()

See Also

OfficeClipDB Class
InitTransaction Overload
OfficeClip.DBLayer Namespace


InitTransaction Method (IsolationLevel)

[image]

OfficeClip API Documentation
OfficeClipDB..::.InitTransaction Method (IsolationLevel)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Initialize the connection string and the transaction parameters

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InitTransaction(
    IsolationLevel transactionIsolationLevel
)
Visual Basic (Declaration)
Public Sub InitTransaction ( _
    transactionIsolationLevel As IsolationLevel _
)
Visual C++
public:
void InitTransaction(
    IsolationLevel transactionIsolationLevel
)

Parameters

transactionIsolationLevel
Type: System.Data..::.IsolationLevel
The transaction type field

See Also

OfficeClipDB Class
InitTransaction Overload
OfficeClip.DBLayer Namespace


Rollback Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.Rollback Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Rolls back the transaction

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Rollback()
Visual Basic (Declaration)
Public Sub Rollback
Visual C++
public:
void Rollback()

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


SetParameterValue Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.SetParameterValue Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the parameter value of the sql parameter to a known value

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetParameterValue(
    string parameter,
    Object parameterValue
)
Visual Basic (Declaration)
Public Sub SetParameterValue ( _
    parameter As String, _
    parameterValue As Object _
)
Visual C++
public:
void SetParameterValue(
    String^ parameter,
    Object^ parameterValue
)

Parameters

parameter
Type: System..::.String
The sql parameter
parameterValue
Type: System..::.Object
The parameter value

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
OfficeClipDB..::.SetSPCommand Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command

See Also

OfficeClipDB Class
OfficeClipDB Members
OfficeClip.DBLayer Namespace


SetSPCommand Method (String)

[image]

OfficeClip API Documentation
OfficeClipDB..::.SetSPCommand Method (String)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the stored procedure command

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetSPCommand(
    string spName
)
Visual Basic (Declaration)
Protected Sub SetSPCommand ( _
    spName As String _
)
Visual C++
protected:
void SetSPCommand(
    String^ spName
)

Parameters

spName
Type: System..::.String

See Also

OfficeClipDB Class
SetSPCommand Overload
OfficeClip.DBLayer Namespace


SetSPCommand Method (String, Int32)

[image]

OfficeClip API Documentation
OfficeClipDB..::.SetSPCommand Method (String, Int32)
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the stored procedure command

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetSPCommand(
    string spName,
    int commandTimeout
)
Visual Basic (Declaration)
Protected Sub SetSPCommand ( _
    spName As String, _
    commandTimeout As Integer _
)
Visual C++
protected:
void SetSPCommand(
    String^ spName,
    int commandTimeout
)

Parameters

spName
Type: System..::.String
commandTimeout
Type: System..::.Int32
The timeout, if explicitly set

See Also

OfficeClipDB Class
SetSPCommand Overload
OfficeClip.DBLayer Namespace


SetSPDataAdapter Method

[image]

OfficeClip API Documentation
OfficeClipDB..::.SetSPDataAdapter Method
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the stored procedure data adapter

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetSPDataAdapter(
    string spName
)
Visual Basic (Declaration)
Protected Sub SetSPDataAdapter ( _
    spName As String _
)
Visual C++
protected:
void SetSPDataAdapter(
    String^ spName
)

Parameters

spName
Type: System..::.String

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


OfficeClipDB Properties

[image] [image]

OfficeClip API Documentation
OfficeClipDB Properties
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

The OfficeClipDB type exposes the following properties.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application.
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set.

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


ConnectionString Property

[image]

OfficeClip API Documentation
OfficeClipDB..::.ConnectionString Property
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string ConnectionString { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConnectionString As String
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
}

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


DBConnString Property

[image]

OfficeClip API Documentation
OfficeClipDB..::.DBConnString Property
OfficeClipDB Class See Also

[This is preliminary documentation and is subject to change.]

The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set.

Namespace: OfficeClip.DBLayer
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string DBConnString { get; set; }
Visual Basic (Declaration)
Protected Property DBConnString As String
Visual C++
protected:
property String^ DBConnString {
    String^ get ();
    void set (String^ value);
}

See Also

OfficeClipDB Class
OfficeClip.DBLayer Namespace


OfficeClip.DBLayer.Account Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Account Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip accounts

Classes

 | Class | Description
Public class | AccountDB | Allows management of Account related functions. It enables querying information related to an account as to what users and groups are contained within an Account. Also, it helps manage the admin permissions within the Account.
Public class | GroupDB | Provides a set of Group functionality related functions.
Public class | ImportExportDB | Provides a set of Import and Export related functions.
Public class | InviteMemberDB |
Public class | LdapDB | Implements all the functions and operations to enable authentication and integration to LDAP servers.
Public class | MainDB | Provides a set of core functions in the framework of the OfficeClip application.
Public class | SmsInfoDB | Provides a set of functions to get and update the user's Sms Inforamtion.
Public class | SubscriptionDB | Allows management of Account subscription for online users.
Public class | UserDB | Provides a set of user related functions.
Public class | UserInfoDB | Provides a set of functions to get and upate the user's data..


AccountDB Class

[image]

OfficeClip API Documentation
AccountDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Allows management of Account related functions. It enables querying information related to an account as to what users and groups are contained within an Account. Also, it helps manage the admin permissions within the Account.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class AccountDB : OfficeClipDB
Visual Basic (Declaration)
Public Class AccountDB _
    Inherits OfficeClipDB
Visual C++
public ref class AccountDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Account..::.AccountDB

See Also

AccountDB Members
OfficeClip.DBLayer.Account Namespace


AccountDB Members

[image] [image]

OfficeClip API Documentation
AccountDB Members
AccountDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AccountDB type exposes the following members.

Constructors

 | Name | Description
Public method | AccountDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteAccount | Deletes all the data in the database for all the groups and users withing the account. The documents are also deleted and the storage space is released.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccountAllSiteAdmins | Gets the account of all the site administrator
Public method | GetAccountApplicationBlocks | Gets the dataset for all the applications that are blocked
Public method | GetAccountGroupsList | Gets the list of groups corresponding to a particular account.
Public method | GetAccountInfo | Gets all the account related information for a particular account identified by the AccountId.
Public method | GetAccountInfoFromUserId | Get all the account related information from the database for the account of the Current logged in user.
Public method | GetAccountingCycleDuration | Gets the number of days allowed in the trial period based on the information provided in the accounting.xml resource file
Public method | GetAccountNonAdminGroupList | Gets a list of groups within the list of all the groups belonging to a particular account where the Current logged in user is not an admin.
Public method | GetAccountsForRdlc | List of Accounts in a particular group (used in rdl reports)
Public method | GetAccountUserInfo | Gets the account information for a give user identified by the userId.
Public method | GetAccountUsersList | Gets a DataSet of all the users belonging to a particular account
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetOldAccounts | Returns a list of all the accounts in which none of the users have used the system in certain number of days
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTrialPeriodUsersCount | Gets the number of users allowed in the trial period based on the information provided in the accounting.xml resource file
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsersCount | Gets the user count of a particular account
Public method | GrantAccountAdminPrivilege | Grants account ownership or admin privilege on a particular account to a particular user.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | IsUserInExistingAccount | Finds if the user is in existing account
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RevokeAccountAdminPrivilege | Revokes account ownership or admin privilege on a particular account to a particular user.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAccountApplicationBlockForManager | Updates the account application block for the manager
Public method | UpdateAccountApplicationBlockForOfficeClip | Overloaded.
Public method | UpdateRegionalSettings | Updates the regional settings
Public method | UpdateSiteHeader | Updates the site header

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


AccountDB Constructor

[image] [image]

OfficeClip API Documentation
AccountDB Constructor
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AccountDB()()() | Constructor
Public method | AccountDB(Boolean) | The constructor

See Also

AccountDB Class
AccountDB Members
OfficeClip.DBLayer.Account Namespace


AccountDB Constructor

[image]

OfficeClip API Documentation
AccountDB Constructor
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public AccountDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AccountDB()

See Also

AccountDB Class
AccountDB Overload
OfficeClip.DBLayer.Account Namespace


AccountDB Constructor (Boolean)

[image]

OfficeClip API Documentation
AccountDB Constructor (Boolean)
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

The constructor

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public AccountDB(
    bool isSync
)
Visual Basic (Declaration)
Public Sub New ( _
    isSync As Boolean _
)
Visual C++
public:
AccountDB(
    bool isSync
)

Parameters

isSync
Type: System..::.Boolean

See Also

AccountDB Class
AccountDB Overload
OfficeClip.DBLayer.Account Namespace


AccountDB Methods

[image] [image]

OfficeClip API Documentation
AccountDB Methods
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

The AccountDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteAccount | Deletes all the data in the database for all the groups and users withing the account. The documents are also deleted and the storage space is released.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccountAllSiteAdmins | Gets the account of all the site administrator
Public method | GetAccountApplicationBlocks | Gets the dataset for all the applications that are blocked
Public method | GetAccountGroupsList | Gets the list of groups corresponding to a particular account.
Public method | GetAccountInfo | Gets all the account related information for a particular account identified by the AccountId.
Public method | GetAccountInfoFromUserId | Get all the account related information from the database for the account of the Current logged in user.
Public method | GetAccountingCycleDuration | Gets the number of days allowed in the trial period based on the information provided in the accounting.xml resource file
Public method | GetAccountNonAdminGroupList | Gets a list of groups within the list of all the groups belonging to a particular account where the Current logged in user is not an admin.
Public method | GetAccountsForRdlc | List of Accounts in a particular group (used in rdl reports)
Public method | GetAccountUserInfo | Gets the account information for a give user identified by the userId.
Public method | GetAccountUsersList | Gets a DataSet of all the users belonging to a particular account
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetOldAccounts | Returns a list of all the accounts in which none of the users have used the system in certain number of days
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTrialPeriodUsersCount | Gets the number of users allowed in the trial period based on the information provided in the accounting.xml resource file
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUsersCount | Gets the user count of a particular account
Public method | GrantAccountAdminPrivilege | Grants account ownership or admin privilege on a particular account to a particular user.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | IsUserInExistingAccount | Finds if the user is in existing account
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RevokeAccountAdminPrivilege | Revokes account ownership or admin privilege on a particular account to a particular user.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAccountApplicationBlockForManager | Updates the account application block for the manager
Public method | UpdateAccountApplicationBlockForOfficeClip | Overloaded.
Public method | UpdateRegionalSettings | Updates the regional settings
Public method | UpdateSiteHeader | Updates the site header

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
AccountDB..::.AddOutputParameter Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

AccountDB Class
AccountDB Members
OfficeClip.DBLayer.Account Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
AccountDB..::.AddParameter Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

AccountDB Class
AccountDB Members
OfficeClip.DBLayer.Account Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
AccountDB..::.AddParameters Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

AccountDB Class
AccountDB Members
OfficeClip.DBLayer.Account Namespace


DeleteAccount Method

[image]

OfficeClip API Documentation
AccountDB..::.DeleteAccount Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all the data in the database for all the groups and users withing the account. The documents are also deleted and the storage space is released.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteAccount(
    int accountId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function DeleteAccount ( _
    accountId As Integer, _
    currentGroupId As Integer _
) As Integer
Visual C++
public:
int DeleteAccount(
    int accountId,
    int currentGroupId
)

Parameters

accountId
Type: System..::.Int32
Id of a particular account to be deleted.
currentGroupId
Type: System..::.Int32
Id of the current group

Return Value

0 in case of success, -1 in case of an error.

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
AccountDB..::.ExecuteNonQuery Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

AccountDB Class
AccountDB Members
OfficeClip.DBLayer.Account Namespace


GetAccountAllSiteAdmins Method

[image]

OfficeClip API Documentation
AccountDB..::.GetAccountAllSiteAdmins Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the account of all the site administrator

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAccountAllSiteAdmins()
Visual Basic (Declaration)
Public Function GetAccountAllSiteAdmins As DataSet
Visual C++
public:
DataSet^ GetAccountAllSiteAdmins()

Return Value

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


GetAccountApplicationBlocks Method

[image]

OfficeClip API Documentation
AccountDB..::.GetAccountApplicationBlocks Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the dataset for all the applications that are blocked

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAccountApplicationBlocks(
    int userId
)
Visual Basic (Declaration)
Public Function GetAccountApplicationBlocks ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAccountApplicationBlocks(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the logged in user (usually the account manager)

Return Value

The dataset for account blocks
  • applicationId (System.Int32) The unique application id
  • managerBit (System.Boolean) The account manager controlled bit
  • officeClipBit (System.Boolean) The officeclip controlled bit

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


GetAccountGroupsList Method

[image]

OfficeClip API Documentation
AccountDB..::.GetAccountGroupsList Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of groups corresponding to a particular account.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAccountGroupsList(
    int accountId
)
Visual Basic (Declaration)
Public Function GetAccountGroupsList ( _
    accountId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAccountGroupsList(
    int accountId
)

Parameters

accountId
Type: System..::.Int32
The id corresponding to a particular account.

Return Value

DataSet containing a single DataTable with the following columns
  • GroupId (System.Int32) The id of the group
  • groupName (System.String) The name of the group

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


GetAccountInfo Method

[image]

OfficeClip API Documentation
AccountDB..::.GetAccountInfo Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the account related information for a particular account identified by the AccountId.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public AccountInfo GetAccountInfo(
    int accountId
)
Visual Basic (Declaration)
Public Function GetAccountInfo ( _
    accountId As Integer _
) As AccountInfo
Visual C++
public:
AccountInfo^ GetAccountInfo(
    int accountId
)

Parameters

accountId
Type: System..::.Int32
The id of the account for which the information is to be retrieved.

Return Value

The AccountInfo object containing all the information related to account identified by the AccountId.

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace
OfficeClip.BusinessLayer.Account..::.AccountInfo


GetAccountInfoFromUserId Method

[image]

OfficeClip API Documentation
AccountDB..::.GetAccountInfoFromUserId Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Get all the account related information from the database for the account of the Current logged in user.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public AccountInfo GetAccountInfoFromUserId(
    int currentUserId
)
Visual Basic (Declaration)
Public Function GetAccountInfoFromUserId ( _
    currentUserId As Integer _
) As AccountInfo
Visual C++
public:
AccountInfo^ GetAccountInfoFromUserId(
    int currentUserId
)

Parameters

currentUserId
Type: System..::.Int32

Return Value

The AccountUserInfo object containing all the information related to the Current logged in user.

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace
OfficeClip.BusinessLayer.Account..::.AccountInfo


GetAccountingCycleDuration Method

[image]

OfficeClip API Documentation
AccountDB..::.GetAccountingCycleDuration Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the number of days allowed in the trial period based on the information provided in the accounting.xml resource file

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetAccountingCycleDuration()
Visual Basic (Declaration)
Public Function GetAccountingCycleDuration As Integer
Visual C++
public:
int GetAccountingCycleDuration()

Return Value

The nuber of days

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


GetAccountNonAdminGroupList Method

[image]

OfficeClip API Documentation
AccountDB..::.GetAccountNonAdminGroupList Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of groups within the list of all the groups belonging to a particular account where the Current logged in user is not an admin.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAccountNonAdminGroupList(
    int accountId,
    int userId
)
Visual Basic (Declaration)
Public Function GetAccountNonAdminGroupList ( _
    accountId As Integer, _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAccountNonAdminGroupList(
    int accountId,
    int userId
)

Parameters

accountId
Type: System..::.Int32
id corresponding to a particular account.
userId
Type: System..::.Int32
The system generated unique id for the user.

Return Value

DataSet containing a single DataTable with the following columns
  • GroupId (System.Int32) The id of the group
  • groupName (System.String) The name of the group

Remarks

Please note privilege is not of being the admin or owner of the account but the in a group. So this method returns a set of groups where the Current logged in user is not an admin and those groups are part of the account identified by the parameter AccountId.

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


GetAccountsForRdlc Method

[image]

OfficeClip API Documentation
AccountDB..::.GetAccountsForRdlc Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

List of Accounts in a particular group (used in rdl reports)

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAccountsForRdlc(
    int groupId
)
Visual Basic (Declaration)
Public Function GetAccountsForRdlc ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAccountsForRdlc(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

list of available account names in a group

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


GetAccountUserInfo Method

[image]

OfficeClip API Documentation
AccountDB..::.GetAccountUserInfo Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the account information for a give user identified by the userId.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public AccountUserInfo GetAccountUserInfo(
    int userId
)
Visual Basic (Declaration)
Public Function GetAccountUserInfo ( _
    userId As Integer _
) As AccountUserInfo
Visual C++
public:
AccountUserInfo^ GetAccountUserInfo(
    int userId
)

Parameters

userId
Type: System..::.Int32
The id of the user in the users table.

Return Value

The AccountUserInfo object containing all the information related to the given user.

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace
OfficeClip.BusinessLayer.Account..::.AccountUserInfo


GetAccountUsersList Method

[image]

OfficeClip API Documentation
AccountDB..::.GetAccountUsersList Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a DataSet of all the users belonging to a particular account

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAccountUsersList(
    int accountId
)
Visual Basic (Declaration)
Public Function GetAccountUsersList ( _
    accountId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAccountUsersList(
    int accountId
)

Parameters

accountId
Type: System..::.Int32
The id corresponding to a particular account.

Return Value

DataSet containing a single DataTable with the following columns
  • name (System.String) Name of the User
  • emailAddress (System.String) Email Address of the user
  • loginName (System.String) The login name for the user (used mainly for LDAP)
  • nameAndEmailAddress (System.String) Name and Email Address concatenated
  • UserId (System.Int32) id of the user
  • loginTimestamp (System.DateTime) DateTime in Current logged in user's timezone when the this particular user logged into OfficeClip.
  • loginCount (System.Int32) Count of total number of times this particular user has logged in into OfficeClip
  • IsAdmin (System.String) Whether this user is owner in that account.

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


GetOldAccounts Method

[image]

OfficeClip API Documentation
AccountDB..::.GetOldAccounts Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns a list of all the accounts in which none of the users have used the system in certain number of days

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetOldAccounts(
    int numDays
)
Visual Basic (Declaration)
Public Function GetOldAccounts ( _
    numDays As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetOldAccounts(
    int numDays
)

Parameters

numDays
Type: System..::.Int32
The number of days in which the for which the users have not used the sytem.

Return Value

A DataSet containing a single table with a single column AccountId (System.Int32)

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


GetTrialPeriodUsersCount Method

[image]

OfficeClip API Documentation
AccountDB..::.GetTrialPeriodUsersCount Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the number of users allowed in the trial period based on the information provided in the accounting.xml resource file

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetTrialPeriodUsersCount()
Visual Basic (Declaration)
Public Function GetTrialPeriodUsersCount As Integer
Visual C++
public:
int GetTrialPeriodUsersCount()

Return Value

The number of users

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


GetUsersCount Method

[image]

OfficeClip API Documentation
AccountDB..::.GetUsersCount Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the user count of a particular account

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetUsersCount(
    int accountId
)
Visual Basic (Declaration)
Public Function GetUsersCount ( _
    accountId As Integer _
) As Integer
Visual C++
public:
int GetUsersCount(
    int accountId
)

Parameters

accountId
Type: System..::.Int32
The unique id of the account

Return Value

The number of users in the account

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


GrantAccountAdminPrivilege Method

[image]

OfficeClip API Documentation
AccountDB..::.GrantAccountAdminPrivilege Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Grants account ownership or admin privilege on a particular account to a particular user.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GrantAccountAdminPrivilege(
    int accountId,
    int userId
)
Visual Basic (Declaration)
Public Function GrantAccountAdminPrivilege ( _
    accountId As Integer, _
    userId As Integer _
) As Integer
Visual C++
public:
int GrantAccountAdminPrivilege(
    int accountId,
    int userId
)

Parameters

accountId
Type: System..::.Int32
id corresponding to a particular account
userId
Type: System..::.Int32
id of one of the users in that account who has to be granted ownership or admin privileges.

Return Value

0 if successful,Utils.Constants.NotAvailable otherwise. Throws Utils.OCException if there is a system or database exception.

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
AccountDB..::.InitTransaction Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

AccountDB Class
AccountDB Members
OfficeClip.DBLayer.Account Namespace


IsUserInExistingAccount Method

[image]

OfficeClip API Documentation
AccountDB..::.IsUserInExistingAccount Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Finds if the user is in existing account

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int IsUserInExistingAccount(
    string emailAddress,
    int currentUserId,
    out int status
)
Visual Basic (Declaration)
Public Function IsUserInExistingAccount ( _
    emailAddress As String, _
    currentUserId As Integer, _
    <OutAttribute> ByRef status As Integer _
) As Integer
Visual C++
public:
int IsUserInExistingAccount(
    String^ emailAddress,
    int currentUserId,
    [OutAttribute] int% status
)

Parameters

emailAddress
Type: System..::.String
currentUserId
Type: System..::.Int32
status
Type: System..::.Int32%

Return Value

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


RevokeAccountAdminPrivilege Method

[image]

OfficeClip API Documentation
AccountDB..::.RevokeAccountAdminPrivilege Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Revokes account ownership or admin privilege on a particular account to a particular user.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RevokeAccountAdminPrivilege(
    int accountId,
    int userId
)
Visual Basic (Declaration)
Public Function RevokeAccountAdminPrivilege ( _
    accountId As Integer, _
    userId As Integer _
) As Integer
Visual C++
public:
int RevokeAccountAdminPrivilege(
    int accountId,
    int userId
)

Parameters

accountId
Type: System..::.Int32
id corresponding to a particular account
userId
Type: System..::.Int32
id of one of the users in that account who has to be revoked ownership or admin privileges.

Return Value

0 if successful, -2 if the user is the only ownder of the account and hence privileges can not be revoked, Utils.Constants.NotAvailable in case of a general error. Throws Utils.OCException if there is a system or database exception.

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
AccountDB..::.SetSPCommand Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

AccountDB Class
AccountDB Members
OfficeClip.DBLayer.Account Namespace


UpdateAccountApplicationBlockForManager Method

[image]

OfficeClip API Documentation
AccountDB..::.UpdateAccountApplicationBlockForManager Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the account application block for the manager

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateAccountApplicationBlockForManager(
    int userId,
    int applicationId,
    bool managerBit
)
Visual Basic (Declaration)
Public Function UpdateAccountApplicationBlockForManager ( _
    userId As Integer, _
    applicationId As Integer, _
    managerBit As Boolean _
) As Integer
Visual C++
public:
int UpdateAccountApplicationBlockForManager(
    int userId,
    int applicationId,
    bool managerBit
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
applicationId
Type: System..::.Int32
The unique id of the application
managerBit
Type: System..::.Boolean
The manager bit

Return Value

0 if successful, negative if error

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


UpdateAccountApplicationBlockForOfficeClip Method

[image] [image]

OfficeClip API Documentation
AccountDB..::.UpdateAccountApplicationBlockForOfficeClip Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | UpdateAccountApplicationBlockForOfficeClip(Int32, Int32) | Update the block on the account application for OfficeClip
Public method | UpdateAccountApplicationBlockForOfficeClip(Int32, Int32, Boolean) | Updates the account application block for OfficeClip

See Also

AccountDB Class
AccountDB Members
OfficeClip.DBLayer.Account Namespace


UpdateAccountApplicationBlockForOfficeClip Method (Int32, Int32)

[image]

OfficeClip API Documentation
AccountDB..::.UpdateAccountApplicationBlockForOfficeClip Method (Int32, Int32)
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Update the block on the account application for OfficeClip

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateAccountApplicationBlockForOfficeClip(
    int userId,
    int selectedPackage
)
Visual Basic (Declaration)
Public Function UpdateAccountApplicationBlockForOfficeClip ( _
    userId As Integer, _
    selectedPackage As Integer _
) As Integer
Visual C++
public:
int UpdateAccountApplicationBlockForOfficeClip(
    int userId,
    int selectedPackage
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
selectedPackage
Type: System..::.Int32
The selected package

Return Value

0 if success, otherwise error

See Also

AccountDB Class
UpdateAccountApplicationBlockForOfficeClip Overload
OfficeClip.DBLayer.Account Namespace


UpdateAccountApplicationBlockForOfficeClip Method (Int32, Int32, Boolean)

[image]

OfficeClip API Documentation
AccountDB..::.UpdateAccountApplicationBlockForOfficeClip Method (Int32, Int32, Boolean)
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the account application block for OfficeClip

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateAccountApplicationBlockForOfficeClip(
    int userId,
    int applicationId,
    bool officeClipBit
)
Visual Basic (Declaration)
Public Function UpdateAccountApplicationBlockForOfficeClip ( _
    userId As Integer, _
    applicationId As Integer, _
    officeClipBit As Boolean _
) As Integer
Visual C++
public:
int UpdateAccountApplicationBlockForOfficeClip(
    int userId,
    int applicationId,
    bool officeClipBit
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
applicationId
Type: System..::.Int32
The unique id of the application
officeClipBit
Type: System..::.Boolean
The OfficeClip bit

Return Value

0 if successful and -1 if failed

See Also

AccountDB Class
UpdateAccountApplicationBlockForOfficeClip Overload
OfficeClip.DBLayer.Account Namespace


UpdateRegionalSettings Method

[image]

OfficeClip API Documentation
AccountDB..::.UpdateRegionalSettings Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the regional settings

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateRegionalSettings(
    int accountId,
    RegionalSettings settings
)
Visual Basic (Declaration)
Public Sub UpdateRegionalSettings ( _
    accountId As Integer, _
    settings As RegionalSettings _
)
Visual C++
public:
void UpdateRegionalSettings(
    int accountId,
    RegionalSettings^ settings
)

Parameters

accountId
Type: System..::.Int32
settings
Type: OfficeClip.Utils..::.RegionalSettings

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


UpdateSiteHeader Method

[image]

OfficeClip API Documentation
AccountDB..::.UpdateSiteHeader Method
AccountDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the site header

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateSiteHeader(
    int accountId,
    string siteHeader
)
Visual Basic (Declaration)
Public Sub UpdateSiteHeader ( _
    accountId As Integer, _
    siteHeader As String _
)
Visual C++
public:
void UpdateSiteHeader(
    int accountId,
    String^ siteHeader
)

Parameters

accountId
Type: System..::.Int32
The unique id of the account
siteHeader
Type: System..::.String
The site header string

See Also

AccountDB Class
OfficeClip.DBLayer.Account Namespace


GroupDB Class

[image]

OfficeClip API Documentation
GroupDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Group functionality related functions.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class GroupDB : OfficeClipDB
Visual Basic (Declaration)
Public Class GroupDB _
    Inherits OfficeClipDB
Visual C++
public ref class GroupDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Account..::.GroupDB

See Also

GroupDB Members
OfficeClip.DBLayer.Account Namespace


GroupDB Members

[image] [image]

OfficeClip API Documentation
GroupDB Members
GroupDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The GroupDB type exposes the following members.

Constructors

 | Name | Description
Public method | GroupDB |

Methods

 | Name | Description
Public method | AddDepartment | Inserts a new department for an organization in the OfficeClip database.
Public method | AddExistingMemberToGroup | Inserts an Existing User in OfficeClip to a particular group. This method should not be called from anywhere except for OEM add/Remove members. It should not be called for inviting members.
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | AddUsersToGroup | Adds users to a particular group.
Public method | ChangeName | Renames the the name of a particular group, organization or department.
Public method | ChkDeleteStatus | Checks the group Delete status and returns a list of things that need to be deleted from the group before it can be deleted.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | CreateGroup | Overloaded.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllGroups | Gets all the groups for the current account
Public method | GetAudits | Returns the Audit list of the group within a time range. This list is arranged in terms of Name.
Public method | GetDefaultCurrency |
Public method | GetDepartments | Gets the Departments for an organization identified by grpId.
Public method | GetGroupAdmins | Gets the list of Ids of the users with admin privileges for a particular group.
Public method | GetGroupCurrencyList | Get the list of the group currency
Public method | GetGroupInfo | Gets all the information related to a particular group identified by GroupId.
Public method | GetGroupList | Gets the list of all the groups where a user is member.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLastLoginTimestamp | Gets the Data and Time when the user last logged in into OfficeClip.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertDefaultCurrency |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveGroup | Deletes a particular group identified by GroupId.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetTimezoneId | Sets the timezone id of the currently selected group in the session.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCurrencyRate |
Public method | UserCount | Gets the count of number of users either registered or unregistered members in a particular group.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


GroupDB Constructor

[image]

OfficeClip API Documentation
GroupDB Constructor
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GroupDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupDB()

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


GroupDB Methods

[image] [image]

OfficeClip API Documentation
GroupDB Methods
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

The GroupDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddDepartment | Inserts a new department for an organization in the OfficeClip database.
Public method | AddExistingMemberToGroup | Inserts an Existing User in OfficeClip to a particular group. This method should not be called from anywhere except for OEM add/Remove members. It should not be called for inviting members.
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | AddUsersToGroup | Adds users to a particular group.
Public method | ChangeName | Renames the the name of a particular group, organization or department.
Public method | ChkDeleteStatus | Checks the group Delete status and returns a list of things that need to be deleted from the group before it can be deleted.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | CreateGroup | Overloaded.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllGroups | Gets all the groups for the current account
Public method | GetAudits | Returns the Audit list of the group within a time range. This list is arranged in terms of Name.
Public method | GetDefaultCurrency |
Public method | GetDepartments | Gets the Departments for an organization identified by grpId.
Public method | GetGroupAdmins | Gets the list of Ids of the users with admin privileges for a particular group.
Public method | GetGroupCurrencyList | Get the list of the group currency
Public method | GetGroupInfo | Gets all the information related to a particular group identified by GroupId.
Public method | GetGroupList | Gets the list of all the groups where a user is member.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLastLoginTimestamp | Gets the Data and Time when the user last logged in into OfficeClip.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertDefaultCurrency |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveGroup | Deletes a particular group identified by GroupId.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetTimezoneId | Sets the timezone id of the currently selected group in the session.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCurrencyRate |
Public method | UserCount | Gets the count of number of users either registered or unregistered members in a particular group.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


AddDepartment Method

[image]

OfficeClip API Documentation
GroupDB..::.AddDepartment Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new department for an organization in the OfficeClip database.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int AddDepartment(
    string deptName,
    int orgId,
    int userId
)
Visual Basic (Declaration)
Public Function AddDepartment ( _
    deptName As String, _
    orgId As Integer, _
    userId As Integer _
) As Integer
Visual C++
public:
int AddDepartment(
    String^ deptName,
    int orgId,
    int userId
)

Parameters

deptName
Type: System..::.String
The name of the new department
orgId
Type: System..::.Int32
The GroupId of the organization to which this department belongs.
userId
Type: System..::.Int32
The unique id of the current user

Return Value

0 when successful, -1 when the Id passed for the Parent organization is not really an organization i.e. it could be of a group or of another department.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


AddExistingMemberToGroup Method

[image]

OfficeClip API Documentation
GroupDB..::.AddExistingMemberToGroup Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts an Existing User in OfficeClip to a particular group. This method should not be called from anywhere except for OEM add/Remove members. It should not be called for inviting members.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int AddExistingMemberToGroup(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function AddExistingMemberToGroup ( _
    userId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int AddExistingMemberToGroup(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The existing user id of the member being added.
groupId
Type: System..::.Int32
The group id in which the new member is being added.

Return Value

0 if successful, -1 if the member is already present -2 if unable to send verification email

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
GroupDB..::.AddOutputParameter Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

GroupDB Class
GroupDB Members
OfficeClip.DBLayer.Account Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
GroupDB..::.AddParameter Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

GroupDB Class
GroupDB Members
OfficeClip.DBLayer.Account Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
GroupDB..::.AddParameters Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

GroupDB Class
GroupDB Members
OfficeClip.DBLayer.Account Namespace


AddUsersToGroup Method

[image]

OfficeClip API Documentation
GroupDB..::.AddUsersToGroup Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds users to a particular group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int AddUsersToGroup(
    string userList,
    int groupId,
    int userId,
    ref int[] statuses,
    ref string[] names,
    ref string[] emailAddresses,
    ref string[] ldapAccountNames
)
Visual Basic (Declaration)
Public Function AddUsersToGroup ( _
    userList As String, _
    groupId As Integer, _
    userId As Integer, _
    ByRef statuses As Integer(), _
    ByRef names As String(), _
    ByRef emailAddresses As String(), _
    ByRef ldapAccountNames As String() _
) As Integer
Visual C++
public:
int AddUsersToGroup(
    String^ userList,
    int groupId,
    int userId,
    array<int>^% statuses,
    array<String^>^% names,
    array<String^>^% emailAddresses,
    array<String^>^% ldapAccountNames
)

Parameters

userList
Type: System..::.String
The list of comma separated userDetailIds to be added to a particular group.
groupId
Type: System..::.Int32
The group id of the group where the users are to be invited/added.
userId
Type: System..::.Int32
The unique id of the current user
statuses
Type: array<System..::.Int32>[]()[]%
Array of statuses
names
Type: array<System..::.String>[]()[]%
Array of names
emailAddresses
Type: array<System..::.String>[]()[]%
The email address
ldapAccountNames
Type: array<System..::.String>[]()[]%
The LDAP account names

Return Value

0 if successful -1 The member being added already belongs to this group or organization. -2 if any of the invited users could not be added because an email could not be sent. -3 if any of the invited users could not be added because an alert could be created. -4 The member can not be added/invited because accounting is enabled and the account where the user should belong could not be determined. -5 The member can not be added/invited because accounting is enabled and the user already belongs to another account. -6 The member can not be added/invited because accounting is enabled and the account has reached the number of users Limit. -7 The member can not be added because the site license user Limit has been reached.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


ChangeName Method

[image]

OfficeClip API Documentation
GroupDB..::.ChangeName Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Renames the the name of a particular group, organization or department.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ChangeName(
    string groupName,
    int groupId
)
Visual Basic (Declaration)
Public Function ChangeName ( _
    groupName As String, _
    groupId As Integer _
) As Integer
Visual C++
public:
int ChangeName(
    String^ groupName,
    int groupId
)

Parameters

groupName
Type: System..::.String
The new name of the group which needs to be assigned to a particular group.
groupId
Type: System..::.Int32
Id of the group which needs to be renamed.

Return Value

0 if successful, -1 if the new name being assigned is already taken up by another group or organization or another department within the same organization.

Remarks

Please note that the same name can be assigned to a department of a different organization or another way of saying this would be that two different organizations can have departments with the same name.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


ChkDeleteStatus Method

[image]

OfficeClip API Documentation
GroupDB..::.ChkDeleteStatus Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks the group Delete status and returns a list of things that need to be deleted from the group before it can be deleted.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SqlDataReader ChkDeleteStatus(
    int groupId
)
Visual Basic (Declaration)
Public Function ChkDeleteStatus ( _
    groupId As Integer _
) As SqlDataReader
Visual C++
public:
SqlDataReader^ ChkDeleteStatus(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

SqlDataReader containing the id (of enum DeleteGroupAppType) and the count for each type. The SqlDataReader has the following columns.
  • id (System.Int32)
                    Id indicating where all the group dependent data is present.
                    1 = Departments within the organization.
                        This will only be valid if we are trying to Delete the organization.
                    2 = Registered users in this group.
                    3 = Unregistered users in the group.
                    4 = Events
                    5 = Group Alerts
                    6 = Documents
                    7 = Document Folders
                    8 = Application Documents
                    9 = Application Document Folders
                    10 = Reservations
                    11 = Resources
                    12 = Group Bookmars
                    13 = Tracker Projects
                    14 = Polls
                    15 = Photo Allbum
                    16 = Announcements.
                    17 = Forums
                    18 = Topics
                    19 = Timesheets
                    20 = Expenses
                    21 = Group Address Book
  • cnt (System.Int32)Count indicating how many items are dependent on this group.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


CreateGroup Method

[image] [image]

OfficeClip API Documentation
GroupDB..::.CreateGroup Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | CreateGroup(String, Int32, ConfigureInfo, Boolean) | Creates a new group or organization.
Public method | CreateGroup(String, String, Int32, ConfigureInfo, Boolean, Int32%) | Creates the group or the organization and invites/adds users into it.

See Also

GroupDB Class
GroupDB Members
OfficeClip.DBLayer.Account Namespace


CreateGroup Method (String, Int32, ConfigureInfo, Boolean)

[image]

OfficeClip API Documentation
GroupDB..::.CreateGroup Method (String, Int32, ConfigureInfo, Boolean)
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates a new group or organization.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int CreateGroup(
    string groupName,
    int tzId,
    ConfigureInfo session,
    bool isSendEmail
)
Visual Basic (Declaration)
Public Function CreateGroup ( _
    groupName As String, _
    tzId As Integer, _
    session As ConfigureInfo, _
    isSendEmail As Boolean _
) As Integer
Visual C++
public:
int CreateGroup(
    String^ groupName,
    int tzId,
    ConfigureInfo^ session,
    bool isSendEmail
)

Parameters

groupName
Type: System..::.String
Name of the new group or organization.
tzId
Type: System..::.Int32
Id of the timezone to which the group belongs.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session
isSendEmail
Type: System..::.Boolean
Is the email supposed to be sent

Return Value

If of the newly created group, -1 in case a group or organization with the same name already exists, -2 in case the group type is not Group or organization.

Remarks

This method should not be called for creation of a department or address book. It will return an error in that case.

See Also

GroupDB Class
CreateGroup Overload
OfficeClip.DBLayer.Account Namespace


CreateGroup Method (String, String, Int32, ConfigureInfo, Boolean, Int32)

[image]

OfficeClip API Documentation
GroupDB..::.CreateGroup Method (String, String, Int32, ConfigureInfo, Boolean, Int32%)
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates the group or the organization and invites/adds users into it.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int CreateGroup(
    string userList,
    string groupName,
    int tzId,
    ConfigureInfo session,
    bool isSendEmail,
    out int groupId
)
Visual Basic (Declaration)
Public Function CreateGroup ( _
    userList As String, _
    groupName As String, _
    tzId As Integer, _
    session As ConfigureInfo, _
    isSendEmail As Boolean, _
    <OutAttribute> ByRef groupId As Integer _
) As Integer
Visual C++
public:
int CreateGroup(
    String^ userList,
    String^ groupName,
    int tzId,
    ConfigureInfo^ session,
    bool isSendEmail,
    [OutAttribute] int% groupId
)

Parameters

userList
Type: System..::.String
The list of comma separated userIds of the users to be added.
groupName
Type: System..::.String
The name of the group.
tzId
Type: System..::.Int32
The timezone id for the group
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session
isSendEmail
Type: System..::.Boolean
Is the email supposed to be sent
groupId
Type: System..::.Int32%
The unique id of the organization

Return Value

the new groupId if successful, -100 if the group or the organization is already present. -2 if any of the invited users could not be added because an email could not be sent. -3 if any of the invited users could not be added because an alert could be created. -4 The member can not be added because accounting is enabled and the account where the user should belong could not be determined. -5 The member can not be added because accounting is enabled and the user already belongs to another account. -6 The member can not be added because accounting is enabled and the account has reached the number of users Limit. -7 The member can not be added because the site license user Limit has been reached.

See Also

GroupDB Class
CreateGroup Overload
OfficeClip.DBLayer.Account Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
GroupDB..::.ExecuteNonQuery Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

GroupDB Class
GroupDB Members
OfficeClip.DBLayer.Account Namespace


GetAllGroups Method

[image]

OfficeClip API Documentation
GroupDB..::.GetAllGroups Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the groups for the current account

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<GroupInfo> GetAllGroups()
Visual Basic (Declaration)
Public Function GetAllGroups As List(Of GroupInfo)
Visual C++
public:
List<GroupInfo^>^ GetAllGroups()

Return Value

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


GetAudits Method

[image]

OfficeClip API Documentation
GroupDB..::.GetAudits Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the Audit list of the group within a time range. This list is arranged in terms of Name.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAudits(
    int groupId,
    DateTime fromdate,
    DateTime todate
)
Visual Basic (Declaration)
Public Function GetAudits ( _
    groupId As Integer, _
    fromdate As DateTime, _
    todate As DateTime _
) As DataSet
Visual C++
public:
DataSet^ GetAudits(
    int groupId,
    DateTime fromdate,
    DateTime todate
)

Parameters

groupId
Type: System..::.Int32
The unique id of the organization
fromdate
Type: System..::.DateTime
Starting Date and Time of the range for which the audit list has to be retrieved.
todate
Type: System..::.DateTime
Ending Date and Time of the range for which the audit list has to be retrieved.

Return Value

DataSet containing of all the audit information. This DataSet consists of a single DataTable with the following columns.
  • name (System.String)Name of the user for whom the audit information being returned.
  • email (System.String)Email Address of the user.
  • user_id (System.Int32)Id of the user.
  • loginTimestamp (System.DateTime)Date and Time when the user last logged in into OfficeClip system.
  • loginCount (System.Int32)Number of times the user has logged in within the given date and time range.
  • membercount (System.Int32)Number of members added/invited by the user into organization/Group.
  • evtcount (System.Int32)Number of events created by the user.
  • postcount (System.Int32)Number of topics or replies posted by the user.
  • uploadcount (System.Int32)Number of documents uploaded by the user.
  • downloadcount (System.Int32)Number of documents downloaded by the user.
  • rescount (System.Int32)Number of reservations created by the user.
  • exptimecount (System.Int32)Number of timesheets or expenses created by the user.
  • casecount (System.Int32)Number of tracker cases created by the user.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


GetDefaultCurrency Method

[image]

OfficeClip API Documentation
GroupDB..::.GetDefaultCurrency Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetDefaultCurrency(
    int groupId
)
Visual Basic (Declaration)
Public Function GetDefaultCurrency ( _
    groupId As Integer _
) As String
Visual C++
public:
String^ GetDefaultCurrency(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


GetDepartments Method

[image]

OfficeClip API Documentation
GroupDB..::.GetDepartments Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Departments for an organization identified by grpId.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GroupInfo[] GetDepartments(
    int orgId
)
Visual Basic (Declaration)
Public Function GetDepartments ( _
    orgId As Integer _
) As GroupInfo()
Visual C++
public:
array<GroupInfo^>^ GetDepartments(
    int orgId
)

Parameters

orgId
Type: System..::.Int32
Id of the organization for which all the departments are to be returned.

Return Value

SqlDataReader containing the ids and names of all the departments for a particular orgnaization. The SqlDataReader has the following columns.
  • GroupId (System.Int32)Id of the department.
  • groupName (System.String)Name of the department.

Remarks

If the id passed is not that of an orgnization, then an empty SqlDataReader will be returned.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


GetGroupAdmins Method

[image]

OfficeClip API Documentation
GroupDB..::.GetGroupAdmins Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of Ids of the users with admin privileges for a particular group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetGroupAdmins(
    int groupId
)
Visual Basic (Declaration)
Public Function GetGroupAdmins ( _
    groupId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetGroupAdmins(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
Id of the group for which all the admins have to be retrieved.

Return Value

ArrayList of ids of the users with admin privileges in a particular group.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


GetGroupCurrencyList Method

[image]

OfficeClip API Documentation
GroupDB..::.GetGroupCurrencyList Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the list of the group currency

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetGroupCurrencyList(
    int groupId,
    bool isShowDefault
)
Visual Basic (Declaration)
Public Function GetGroupCurrencyList ( _
    groupId As Integer, _
    isShowDefault As Boolean _
) As DataTable
Visual C++
public:
DataTable^ GetGroupCurrencyList(
    int groupId,
    bool isShowDefault
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
isShowDefault
Type: System..::.Boolean
true if the default is required to be shown

Return Value

The datatable consisting of the currency list

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


GetGroupInfo Method

[image]

OfficeClip API Documentation
GroupDB..::.GetGroupInfo Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to a particular group identified by GroupId.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GroupInfo GetGroupInfo(
    int groupId
)
Visual Basic (Declaration)
Public Function GetGroupInfo ( _
    groupId As Integer _
) As GroupInfo
Visual C++
public:
GroupInfo^ GetGroupInfo(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
Id of the group for which all the information has to be retrieved.

Return Value

Instance of the GroupInfo object containing all the information related to a group. OfficeClip.BusinessLayer.Account..::.GroupInfo

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


GetGroupList Method

[image]

OfficeClip API Documentation
GroupDB..::.GetGroupList Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of all the groups where a user is member.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<GroupInfo> GetGroupList(
    int userId
)
Visual Basic (Declaration)
Public Function GetGroupList ( _
    userId As Integer _
) As List(Of GroupInfo)
Visual C++
public:
List<GroupInfo^>^ GetGroupList(
    int userId
)

Parameters

userId
Type: System..::.Int32
Id of the user for whom all the groups are to be returned. If userId is -1, then information for all the groups will be returned.

Return Value

SqlDataReader giving information about all the groups where a user is currently a member of. The SqlDataReader consists of the following columns.
  • GroupId (System.Int32)Id of the group, organization or department.
  • groupName (System.String)Name of the group, organization or department.
  • parentId (System.Int32)Id of the orgnization to which the department belongs if the Current record corresponds to that of a department.
  • type (System.String)Type of the group. Possible values are 'G', 'O' or 'D' corresponding to group, organization or department.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


GetLastLoginTimestamp Method

[image]

OfficeClip API Documentation
GroupDB..::.GetLastLoginTimestamp Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Data and Time when the user last logged in into OfficeClip.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DateTime GetLastLoginTimestamp(
    int userId
)
Visual Basic (Declaration)
Public Function GetLastLoginTimestamp ( _
    userId As Integer _
) As DateTime
Visual C++
public:
DateTime GetLastLoginTimestamp(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

Data and Time when the user last logged in into OfficeClip.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
GroupDB..::.InitTransaction Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

GroupDB Class
GroupDB Members
OfficeClip.DBLayer.Account Namespace


InsertDefaultCurrency Method

[image]

OfficeClip API Documentation
GroupDB..::.InsertDefaultCurrency Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertDefaultCurrency(
    int groupId,
    int userId,
    string code
)
Visual Basic (Declaration)
Public Sub InsertDefaultCurrency ( _
    groupId As Integer, _
    userId As Integer, _
    code As String _
)
Visual C++
public:
void InsertDefaultCurrency(
    int groupId,
    int userId,
    String^ code
)

Parameters

groupId
Type: System..::.Int32
userId
Type: System..::.Int32
code
Type: System..::.String

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


RemoveGroup Method

[image]

OfficeClip API Documentation
GroupDB..::.RemoveGroup Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a particular group identified by GroupId.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RemoveGroup(
    int groupId
)
Visual Basic (Declaration)
Public Function RemoveGroup ( _
    groupId As Integer _
) As Integer
Visual C++
public:
int RemoveGroup(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
Id of the group to be deleted.

Return Value

0 when successful, -1 in case of an error.

Remarks

This method also deletes the documents uploaded in the document management application for this particular group and the documents attached to this group's objects from other OfficeClip applications.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
GroupDB..::.SetSPCommand Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

GroupDB Class
GroupDB Members
OfficeClip.DBLayer.Account Namespace


SetTimezoneId Method

[image]

OfficeClip API Documentation
GroupDB..::.SetTimezoneId Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the timezone id of the currently selected group in the session.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetTimezoneId(
    int timezoneId,
    int groupId
)
Visual Basic (Declaration)
Public Sub SetTimezoneId ( _
    timezoneId As Integer, _
    groupId As Integer _
)
Visual C++
public:
void SetTimezoneId(
    int timezoneId,
    int groupId
)

Parameters

timezoneId
Type: System..::.Int32
Id of the timezone which needs to be set for the Current group.
groupId
Type: System..::.Int32
The unique id of the organization

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


UpdateCurrencyRate Method

[image]

OfficeClip API Documentation
GroupDB..::.UpdateCurrencyRate Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateCurrencyRate(
    int groupId,
    int userId,
    DataTable dt
)
Visual Basic (Declaration)
Public Sub UpdateCurrencyRate ( _
    groupId As Integer, _
    userId As Integer, _
    dt As DataTable _
)
Visual C++
public:
void UpdateCurrencyRate(
    int groupId,
    int userId,
    DataTable^ dt
)

Parameters

groupId
Type: System..::.Int32
userId
Type: System..::.Int32
dt
Type: System.Data..::.DataTable

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


UserCount Method

[image]

OfficeClip API Documentation
GroupDB..::.UserCount Method
GroupDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the count of number of users either registered or unregistered members in a particular group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UserCount(
    int groupId
)
Visual Basic (Declaration)
Public Function UserCount ( _
    groupId As Integer _
) As Integer
Visual C++
public:
int UserCount(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
Id of the group for which the count of users has to be retrieved.

Return Value

Count of number of users either registered or unregistered members in a particular group. -1 if no group exists

Remarks

This method can also be called for Organizations, Departments or Address Books.

See Also

GroupDB Class
OfficeClip.DBLayer.Account Namespace


ImportExportDB Class

[image]

OfficeClip API Documentation
ImportExportDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Import and Export related functions.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class ImportExportDB : OfficeClipDB
Visual Basic (Declaration)
Public Class ImportExportDB _
    Inherits OfficeClipDB
Visual C++
public ref class ImportExportDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Account..::.ImportExportDB

See Also

ImportExportDB Members
OfficeClip.DBLayer.Account Namespace


ImportExportDB Members

[image] [image]

OfficeClip API Documentation
ImportExportDB Members
ImportExportDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ImportExportDB type exposes the following members.

Constructors

 | Name | Description
Public method | ImportExportDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPrivateIOEvents | Gets the Private IO events for exporting to various formats
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImportAddressBookEntriesFromCsv | Imports contacts from a CSV file into a particular address book.
Public method | ImportAddressBookEntriesFromVCard | Imports contacts from a VCard file into a particular address book.
Public method | ImportMembersFromCsv | Imports members from a CSV file. This function will import all the valid members into OfficeClip without giving any warning into a particular group.
Public method | ImportMembersFromVCard | Imports members from a vCard file. This function will import all the valid members into a particular group.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Protected method | SetErrorStatus | Sets the error status
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

ImportExportDB Class
OfficeClip.DBLayer.Account Namespace


ImportExportDB Constructor

[image]

OfficeClip API Documentation
ImportExportDB Constructor
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ImportExportDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImportExportDB()

See Also

ImportExportDB Class
OfficeClip.DBLayer.Account Namespace


ImportExportDB Methods

[image] [image]

OfficeClip API Documentation
ImportExportDB Methods
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

The ImportExportDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPrivateIOEvents | Gets the Private IO events for exporting to various formats
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImportAddressBookEntriesFromCsv | Imports contacts from a CSV file into a particular address book.
Public method | ImportAddressBookEntriesFromVCard | Imports contacts from a VCard file into a particular address book.
Public method | ImportMembersFromCsv | Imports members from a CSV file. This function will import all the valid members into OfficeClip without giving any warning into a particular group.
Public method | ImportMembersFromVCard | Imports members from a vCard file. This function will import all the valid members into a particular group.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Protected method | SetErrorStatus | Sets the error status
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImportExportDB Class
OfficeClip.DBLayer.Account Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
ImportExportDB..::.AddOutputParameter Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

ImportExportDB Class
ImportExportDB Members
OfficeClip.DBLayer.Account Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
ImportExportDB..::.AddParameter Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

ImportExportDB Class
ImportExportDB Members
OfficeClip.DBLayer.Account Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
ImportExportDB..::.AddParameters Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

ImportExportDB Class
ImportExportDB Members
OfficeClip.DBLayer.Account Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
ImportExportDB..::.ExecuteNonQuery Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

ImportExportDB Class
ImportExportDB Members
OfficeClip.DBLayer.Account Namespace


GetPrivateIOEvents Method

[image]

OfficeClip API Documentation
ImportExportDB..::.GetPrivateIOEvents Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Private IO events for exporting to various formats

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPrivateIOEvents(
    int userid,
    string storedProcedureName
)
Visual Basic (Declaration)
Public Function GetPrivateIOEvents ( _
    userid As Integer, _
    storedProcedureName As String _
) As DataSet
Visual C++
public:
DataSet^ GetPrivateIOEvents(
    int userid,
    String^ storedProcedureName
)

Parameters

userid
Type: System..::.Int32
The id of the user
storedProcedureName
Type: System..::.String
The Stored procedure name, There can be multiple stored procedure each having the same Signature

Return Value

The DataSet corresponding to the IO event This DataSet consists of a single DataTable with the following columns.

See Also

ImportExportDB Class
OfficeClip.DBLayer.Account Namespace


ImportAddressBookEntriesFromCsv Method

[image]

OfficeClip API Documentation
ImportExportDB..::.ImportAddressBookEntriesFromCsv Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Imports contacts from a CSV file into a particular address book.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable ImportAddressBookEntriesFromCsv(
    ArrayList csvUserList,
    int selectedOption,
    int addressbookId
)
Visual Basic (Declaration)
Public Function ImportAddressBookEntriesFromCsv ( _
    csvUserList As ArrayList, _
    selectedOption As Integer, _
    addressbookId As Integer _
) As DataTable
Visual C++
public:
DataTable^ ImportAddressBookEntriesFromCsv(
    ArrayList^ csvUserList,
    int selectedOption,
    int addressbookId
)

Parameters

csvUserList
Type: System.Collections..::.ArrayList
ArrayList of OCUserInfo objects containing all the information loaded from the CSV file.
selectedOption
Type: System..::.Int32
Integer flag indicating what should be done when a member being imported is already present in the Address Book.
            1 = Overwrite OfficeClip information with the file item imported.
            2 = Do not import names which are already in OfficeClip.
            3 = Allow duplicates to be merged with the OfficeClip information.
addressbookId
Type: System..::.Int32
The unique id of the address book

Return Value

DataTable consisting of name email Address and status of the result of individual import of each address book entry. The DataTable consists of the following columns.
  • name (System.String)Name of the Contact being imported.
  • emailAddress (System.String)Email Address of the address book entry being imported.
  • status (System.Int32) This flag indicates the result of individual import into the Address Book. 0 when Import was successful, -1 in case of an error.

Remarks

There is no password generated nor any email sent while importing a address book entry in the address book.

See Also

ImportExportDB Class
OfficeClip.DBLayer.Account Namespace


ImportAddressBookEntriesFromVCard Method

[image]

OfficeClip API Documentation
ImportExportDB..::.ImportAddressBookEntriesFromVCard Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Imports contacts from a VCard file into a particular address book.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable ImportAddressBookEntriesFromVCard(
    HttpPostedFile postedFile,
    int selectedOption,
    int addressbookId,
    ref int status
)
Visual Basic (Declaration)
Public Function ImportAddressBookEntriesFromVCard ( _
    postedFile As HttpPostedFile, _
    selectedOption As Integer, _
    addressbookId As Integer, _
    ByRef status As Integer _
) As DataTable
Visual C++
public:
DataTable^ ImportAddressBookEntriesFromVCard(
    HttpPostedFile^ postedFile,
    int selectedOption,
    int addressbookId,
    int% status
)

Parameters

postedFile
Type: System.Web..::.HttpPostedFile
The posted (uploaded) VCard File.
selectedOption
Type: System..::.Int32
Integer flag indicating what should be done when a member being imported is already present in the Address Book.
            1 = Overwrite OfficeClip information with the file item imported.
            2 = Do not import names which are already in OfficeClip.
            3 = Allow duplicates to be merged with the OfficeClip information.
addressbookId
Type: System..::.Int32
The unique id of the address book
status
Type: System..::.Int32%
Return status. 0 if successful, -1 the file is not in the vCard -2 the file is ill-formed -3 vCard file Version not supported

Return Value

DataTable consisting of name email Address and status of the result of individual import of each address book entry. The DataTable consists of the following columns.
  • name (System.String)Name of the Contact being imported.
  • emailAddress (System.String)Email Address of the address book entry being imported.
  • status (System.Int32) This flag indicates the result of individual import into the Address Book. 0 when Import was successful, -1 in case of an error.

Remarks

There is no password generated nor any email sent while importing a address book entry in the address book.

See Also

ImportExportDB Class
OfficeClip.DBLayer.Account Namespace


ImportMembersFromCsv Method

[image]

OfficeClip API Documentation
ImportExportDB..::.ImportMembersFromCsv Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Imports members from a CSV file. This function will import all the valid members into OfficeClip without giving any warning into a particular group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable ImportMembersFromCsv(
    ArrayList csvUserList,
    int selectedOption,
    bool chkPassword,
    int groupId,
    bool isCurrentUserAdmin,
    int currentUserId
)
Visual Basic (Declaration)
Public Function ImportMembersFromCsv ( _
    csvUserList As ArrayList, _
    selectedOption As Integer, _
    chkPassword As Boolean, _
    groupId As Integer, _
    isCurrentUserAdmin As Boolean, _
    currentUserId As Integer _
) As DataTable
Visual C++
public:
DataTable^ ImportMembersFromCsv(
    ArrayList^ csvUserList,
    int selectedOption,
    bool chkPassword,
    int groupId,
    bool isCurrentUserAdmin,
    int currentUserId
)

Parameters

csvUserList
Type: System.Collections..::.ArrayList
ArrayList of OCUserInfo objects containing all the information loaded from the CSV file.
selectedOption
Type: System..::.Int32
How the file is imported
            1 = Overwrite officeclip information with the file imported.
            2 = Do not import names already in officeclip.
            3 = Allow duplicates to be merged with the OfficeClip information.
chkPassword
Type: System..::.Boolean
If true then send the password to all imported members
groupId
Type: System..::.Int32
Id of the group in which the member is being imported.
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator
currentUserId
Type: System..::.Int32
The user id of the current user

Return Value

DataTable consisting of name email Address and status of the result of individual import of each member. The DataTable consists of the following columns.
  • name (System.String)Name of the Member being imported.
  • emailAddress (System.String)Email Address of the Member being imported.
  • status (System.Int32) This flag indicates the result of individual import into the Group. 0 if the import was successful -2 if any of the invited users could not be imported because an email could not be sent. -3 if any of the invited users could not be imported because an alert could be created. -4 The member can not be imported because accounting is enabled and the account where the user should belong could not be determined. -5 The member can not be imported because accounting is enabled and the user already belongs to another account. -6 The member can not be imported because accounting is enabled and the account has reached the number of users Limit. -7 The member can not be imported because the site license user Limit has been reached.

See Also

ImportExportDB Class
OfficeClip.DBLayer.Account Namespace


ImportMembersFromVCard Method

[image]

OfficeClip API Documentation
ImportExportDB..::.ImportMembersFromVCard Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Imports members from a vCard file. This function will import all the valid members into a particular group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable ImportMembersFromVCard(
    HttpPostedFile postedFile,
    int selectedOption,
    bool chkPassword,
    ref int status,
    int groupId,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function ImportMembersFromVCard ( _
    postedFile As HttpPostedFile, _
    selectedOption As Integer, _
    chkPassword As Boolean, _
    ByRef status As Integer, _
    groupId As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
) As DataTable
Visual C++
public:
DataTable^ ImportMembersFromVCard(
    HttpPostedFile^ postedFile,
    int selectedOption,
    bool chkPassword,
    int% status,
    int groupId,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

postedFile
Type: System.Web..::.HttpPostedFile
The http posted file
selectedOption
Type: System..::.Int32
How the file is imported
            1 = Overwrite officeclip information with the file imported.
            2 = Do not import names already in officeclip.
            3 = Allow duplicates to be merged with the OfficeClip information.
chkPassword
Type: System..::.Boolean
If true then send the password to all imported members
status
Type: System..::.Int32%
0 if successful, -1 the file is not in the vCard -2 the file is ill-formed -3 vCard file Version not supported
groupId
Type: System..::.Int32
Id of the group in which the members need to be imported.
currentUserId
Type: System..::.Int32
The current user id
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

DataTable consisting of name email Address and status of the result of individual import of each member. The DataTable consists of the following columns.
  • name (System.String)Name of the Member being imported.
  • emailAddress (System.String)Email Address of the Member being imported.
  • status (System.Int32) This flag indicates the result of individual import into the Group. 0 if the import was successful -2 if any of the invited users could not be imported because an email could not be sent. -3 if any of the invited users could not be imported because an alert could be created. -4 The member can not be imported because accounting is enabled and the account where the user should belong could not be determined. -5 The member can not be imported because accounting is enabled and the user already belongs to another account. -6 The member can not be imported because accounting is enabled and the account has reached the number of users Limit. -7 The member can not be imported because the site license user Limit has been reached.

See Also

ImportExportDB Class
OfficeClip.DBLayer.Account Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
ImportExportDB..::.InitTransaction Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

ImportExportDB Class
ImportExportDB Members
OfficeClip.DBLayer.Account Namespace


SetErrorStatus Method

[image]

OfficeClip API Documentation
ImportExportDB..::.SetErrorStatus Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the error status

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetErrorStatus(
    int errorId,
    int userId,
    DataRow dRow
)
Visual Basic (Declaration)
Protected Sub SetErrorStatus ( _
    errorId As Integer, _
    userId As Integer, _
    dRow As DataRow _
)
Visual C++
protected:
void SetErrorStatus(
    int errorId,
    int userId,
    DataRow^ dRow
)

Parameters

errorId
Type: System..::.Int32
userId
Type: System..::.Int32
dRow
Type: System.Data..::.DataRow

See Also

ImportExportDB Class
OfficeClip.DBLayer.Account Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
ImportExportDB..::.SetSPCommand Method
ImportExportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

ImportExportDB Class
ImportExportDB Members
OfficeClip.DBLayer.Account Namespace


InviteMemberDB Class

[image]

OfficeClip API Documentation
InviteMemberDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class InviteMemberDB : OfficeClipDB
Visual Basic (Declaration)
Public Class InviteMemberDB _
    Inherits OfficeClipDB
Visual C++
public ref class InviteMemberDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Account..::.InviteMemberDB

See Also

InviteMemberDB Members
OfficeClip.DBLayer.Account Namespace


InviteMemberDB Members

[image] [image]

OfficeClip API Documentation
InviteMemberDB Members
InviteMemberDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The InviteMemberDB type exposes the following members.

Constructors

 | Name | Description
Public method | InviteMemberDB |

Methods

 | Name | Description
Public method | AddMember | Creates a new user in the specified group
Public method | AddMembers | Overloaded.
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPendingInvitations | Gets a list of all the pending invitations and its related information for a particular user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveMember | Removes a given member from a particular group based on the userDetailId.
Public method | RemoveMemberFromAllGroups | Removes a member from all possible groups where this user is a member of. The input to this method can be a registered or unregistered member of OfficeClip.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SendInvitationEMail | Sends the new invitation email to the user. This email is sent only when the user is introduced to OfficeClip for the first time
Public method | sendRemoveNotificationEMail | Sends the new invitation email to the user. This email is sent only when the user is introduced to OfficeClip for the first time.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

InviteMemberDB Class
OfficeClip.DBLayer.Account Namespace


InviteMemberDB Constructor

[image]

OfficeClip API Documentation
InviteMemberDB Constructor
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public InviteMemberDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InviteMemberDB()

See Also

InviteMemberDB Class
OfficeClip.DBLayer.Account Namespace


InviteMemberDB Methods

[image] [image]

OfficeClip API Documentation
InviteMemberDB Methods
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

The InviteMemberDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddMember | Creates a new user in the specified group
Public method | AddMembers | Overloaded.
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPendingInvitations | Gets a list of all the pending invitations and its related information for a particular user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveMember | Removes a given member from a particular group based on the userDetailId.
Public method | RemoveMemberFromAllGroups | Removes a member from all possible groups where this user is a member of. The input to this method can be a registered or unregistered member of OfficeClip.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SendInvitationEMail | Sends the new invitation email to the user. This email is sent only when the user is introduced to OfficeClip for the first time
Public method | sendRemoveNotificationEMail | Sends the new invitation email to the user. This email is sent only when the user is introduced to OfficeClip for the first time.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InviteMemberDB Class
OfficeClip.DBLayer.Account Namespace


AddMember Method

[image]

OfficeClip API Documentation
InviteMemberDB..::.AddMember Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates a new user in the specified group

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int AddMember(
    int groupId,
    string firstName,
    string lastName,
    string emailAddress,
    string password,
    int creatorId,
    string login_name,
    out int userId
)
Visual Basic (Declaration)
Public Function AddMember ( _
    groupId As Integer, _
    firstName As String, _
    lastName As String, _
    emailAddress As String, _
    password As String, _
    creatorId As Integer, _
    login_name As String, _
    <OutAttribute> ByRef userId As Integer _
) As Integer
Visual C++
public:
int AddMember(
    int groupId,
    String^ firstName,
    String^ lastName,
    String^ emailAddress,
    String^ password,
    int creatorId,
    String^ login_name,
    [OutAttribute] int% userId
)

Parameters

groupId
Type: System..::.Int32
The database generated id of the group
firstName
Type: System..::.String
The first name of the user
lastName
Type: System..::.String
The last name of the user
emailAddress
Type: System..::.String
The email address of the user
password
Type: System..::.String
The user password
creatorId
Type: System..::.Int32
The database generated id of the creator
login_name
Type: System..::.String
The login name for
userId
Type: System..::.Int32%
returned ID of the newly created user

Return Value

0 if the operation was successful, false otherwise

See Also

InviteMemberDB Class
OfficeClip.DBLayer.Account Namespace


AddMembers Method

[image] [image]

OfficeClip API Documentation
InviteMemberDB..::.AddMembers Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddMembers(Int32, Int32, ConfigureInfo) | Add member into a group based on the userDetailId of the user which is registered
Public method | AddMembers(Int32, Int32, Int32%, String%, String%, String%, Int32) | Add a new member with userId and GroupId as input parameter

See Also

InviteMemberDB Class
InviteMemberDB Members
OfficeClip.DBLayer.Account Namespace


AddMembers Method (Int32, Int32, ConfigureInfo)

[image]

OfficeClip API Documentation
InviteMemberDB..::.AddMembers Method (Int32, Int32, ConfigureInfo)
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Add member into a group based on the userDetailId of the user which is registered

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int AddMembers(
    int userId,
    int groupId,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function AddMembers ( _
    userId As Integer, _
    groupId As Integer, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int AddMembers(
    int userId,
    int groupId,
    ConfigureInfo^ session
)

Parameters

userId
Type: System..::.Int32
Unique id of the user.
groupId
Type: System..::.Int32
Id of the group in which this member has to be added.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

  • 0success
  • -1the user is already present in the group
  • -2email could not be sent
  • -3the alert could not be sent
  • -4the accounting is enabled and the user can be added to the account, but the account_id of the invitor is null for some reason.
  • -5accounting is enabled and the user is already present in some other paid account If accounting is not enabled then this check is skipped
  • -6accounting is enabled and the user can be added to the account, if the number of users in this account reached.
  • -7by any reason the site users license Limit drops below zero.
  • -8if LDAP authentication is enabled and the ldap account name being added is already used up.

See Also

InviteMemberDB Class
AddMembers Overload
OfficeClip.DBLayer.Account Namespace


AddMembers Method (Int32, Int32, Int32, String, String, String, Int32)

[image]

OfficeClip API Documentation
InviteMemberDB..::.AddMembers Method (Int32, Int32, Int32%, String%, String%, String%, Int32)
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Add a new member with userId and GroupId as input parameter

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int AddMembers(
    int userId,
    int groupId,
    ref int status,
    ref string name,
    ref string emailAddress,
    ref string ldapAccountName,
    int currentUserId
)
Visual Basic (Declaration)
Public Function AddMembers ( _
    userId As Integer, _
    groupId As Integer, _
    ByRef status As Integer, _
    ByRef name As String, _
    ByRef emailAddress As String, _
    ByRef ldapAccountName As String, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int AddMembers(
    int userId,
    int groupId,
    int% status,
    String^% name,
    String^% emailAddress,
    String^% ldapAccountName,
    int currentUserId
)

Parameters

userId
Type: System..::.Int32
Unique id of the user to be added to the group
groupId
Type: System..::.Int32
Id of the group to which the user is being added
status
Type: System..::.Int32%
name
Type: System..::.String%
The name of the user to be added
emailAddress
Type: System..::.String%
The email address of the user to be added
ldapAccountName
Type: System..::.String%
The ldap account name
currentUserId
Type: System..::.Int32
Teh user id of the login user

Return Value

  • 0success
  • -1the user is already present in the group
  • -2email could not be sent
  • -3the alert could not be sent
  • -4the accounting is enabled and the user can be added to the account, but the account_id of the invitor is null for some reason.
  • -5accounting is enabled and the user is already present in some other paid account If accounting is not enabled then this check is skipped
  • -6accounting is enabled and the user can be added to the account, if the number of users in this account reached.
  • -7by any reason the site users license Limit drops below zero.
  • -8if LDAP authentication is enabled and the ldap account name being added is already used up.

See Also

InviteMemberDB Class
AddMembers Overload
OfficeClip.DBLayer.Account Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
InviteMemberDB..::.AddOutputParameter Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

InviteMemberDB Class
InviteMemberDB Members
OfficeClip.DBLayer.Account Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
InviteMemberDB..::.AddParameter Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

InviteMemberDB Class
InviteMemberDB Members
OfficeClip.DBLayer.Account Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
InviteMemberDB..::.AddParameters Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

InviteMemberDB Class
InviteMemberDB Members
OfficeClip.DBLayer.Account Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
InviteMemberDB..::.ExecuteNonQuery Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

InviteMemberDB Class
InviteMemberDB Members
OfficeClip.DBLayer.Account Namespace


GetPendingInvitations Method

[image]

OfficeClip API Documentation
InviteMemberDB..::.GetPendingInvitations Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the pending invitations and its related information for a particular user.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPendingInvitations(
    int userId
)
Visual Basic (Declaration)
Public Function GetPendingInvitations ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetPendingInvitations(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.

Return Value

DataSet containing all the pending invitations and its related information for the currently logged in user. This DataSet consists of a single DataTable with the following columns.
  • GroupId (System.Int32)Id of the group corresponding to which there is a pending invitation.
  • groupName (System.String)Name of the group where there is a pending invitation.
  • admin (System.String)Name of the group administrator who sent the invitation which is currently pending.
  • AdminEmailAddress (System.String)Email Address of the group administrator who sent the invitation.
  • adminPhoneNumber (System.String)Primary work phone number of the group administrator who sent the invitation.

See Also

InviteMemberDB Class
OfficeClip.DBLayer.Account Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
InviteMemberDB..::.InitTransaction Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

InviteMemberDB Class
InviteMemberDB Members
OfficeClip.DBLayer.Account Namespace


RemoveMember Method

[image]

OfficeClip API Documentation
InviteMemberDB..::.RemoveMember Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes a given member from a particular group based on the userDetailId.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RemoveMember(
    int userId,
    int groupId,
    bool sendNotification,
    string groupName,
    string fromName,
    string fromEmailAddress,
    int currentUserId
)
Visual Basic (Declaration)
Public Function RemoveMember ( _
    userId As Integer, _
    groupId As Integer, _
    sendNotification As Boolean, _
    groupName As String, _
    fromName As String, _
    fromEmailAddress As String, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int RemoveMember(
    int userId,
    int groupId,
    bool sendNotification,
    String^ groupName,
    String^ fromName,
    String^ fromEmailAddress,
    int currentUserId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
groupId
Type: System..::.Int32
The group id corresponding to the UserDetail ID for a given group.
sendNotification
Type: System..::.Boolean
Flag to indicate whether to send an email notification or not.
groupName
Type: System..::.String
The name of the group from who the email address will be sent
fromName
Type: System..::.String
The name from who the email will be sent
fromEmailAddress
Type: System..::.String
The email address from who the email will be sent
currentUserId
Type: System..::.Int32
The current user id

Return Value

0 if it is successful, -1 In case the user is the only admin in the group, -2 if there is an error sending the email

See Also

InviteMemberDB Class
OfficeClip.DBLayer.Account Namespace


RemoveMemberFromAllGroups Method

[image]

OfficeClip API Documentation
InviteMemberDB..::.RemoveMemberFromAllGroups Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes a member from all possible groups where this user is a member of. The input to this method can be a registered or unregistered member of OfficeClip.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RemoveMemberFromAllGroups(
    int userId,
    int currentUserId
)
Visual Basic (Declaration)
Public Function RemoveMemberFromAllGroups ( _
    userId As Integer, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int RemoveMemberFromAllGroups(
    int userId,
    int currentUserId
)

Parameters

userId
Type: System..::.Int32
Id of the user.
currentUserId
Type: System..::.Int32
The current user id, can be -1 if currentUserId is not available

Return Value

0 if successful or group id of the group where this user is the only admin and hence can not be removed, -1 if there is any other system failure, -2 if there was a failure in sending the email to the user. OfficeClip.BusinessLayer.Framework..::.PropertyInfo

Remarks

If the user is an only admin in any one single group, this whole operation will fail.

See Also

InviteMemberDB Class
OfficeClip.DBLayer.Account Namespace


SendInvitationEMail Method

[image]

OfficeClip API Documentation
InviteMemberDB..::.SendInvitationEMail Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends the new invitation email to the user. This email is sent only when the user is introduced to OfficeClip for the first time

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool SendInvitationEMail(
    int status,
    string name,
    string emailAddress,
    string ldapAccountName,
    string password,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function SendInvitationEMail ( _
    status As Integer, _
    name As String, _
    emailAddress As String, _
    ldapAccountName As String, _
    password As String, _
    session As ConfigureInfo _
) As Boolean
Visual C++
public:
bool SendInvitationEMail(
    int status,
    String^ name,
    String^ emailAddress,
    String^ ldapAccountName,
    String^ password,
    ConfigureInfo^ session
)

Parameters

status
Type: System..::.Int32
What kind of email need to be sent
name
Type: System..::.String
The name of the new member
emailAddress
Type: System..::.String
The email Address of the new member
ldapAccountName
Type: System..::.String
Ldap Account Name of the new member if LDAP Authentication is enabled.
password
Type: System..::.String
Unencrypted password
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

True, if successfully sent the email, False otherwise

See Also

InviteMemberDB Class
OfficeClip.DBLayer.Account Namespace


sendRemoveNotificationEMail Method

[image]

OfficeClip API Documentation
InviteMemberDB..::.sendRemoveNotificationEMail Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends the new invitation email to the user. This email is sent only when the user is introduced to OfficeClip for the first time.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool sendRemoveNotificationEMail(
    int userDetailId,
    string firstName,
    string lastName,
    string emailAddress,
    int groupId,
    string fromName,
    string fromEmailAddress,
    int currentUserId
)
Visual Basic (Declaration)
Public Function sendRemoveNotificationEMail ( _
    userDetailId As Integer, _
    firstName As String, _
    lastName As String, _
    emailAddress As String, _
    groupId As Integer, _
    fromName As String, _
    fromEmailAddress As String, _
    currentUserId As Integer _
) As Boolean
Visual C++
public:
bool sendRemoveNotificationEMail(
    int userDetailId,
    String^ firstName,
    String^ lastName,
    String^ emailAddress,
    int groupId,
    String^ fromName,
    String^ fromEmailAddress,
    int currentUserId
)

Parameters

userDetailId
Type: System..::.Int32
userDetailId of the new member to whom the notification is being sent.
firstName
Type: System..::.String
The first name of the new member.
lastName
Type: System..::.String
The last name of the new member.
emailAddress
Type: System..::.String
The email Address of the new member.
groupId
Type: System..::.Int32
The unique id of the group
fromName
Type: System..::.String
The name from who the email will be sent
fromEmailAddress
Type: System..::.String
The email address from who the email will be sent
currentUserId
Type: System..::.Int32
Unique id of the logged in user

Return Value

True, if successfully sent the email, False otherwise

See Also

InviteMemberDB Class
OfficeClip.DBLayer.Account Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
InviteMemberDB..::.SetSPCommand Method
InviteMemberDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

InviteMemberDB Class
InviteMemberDB Members
OfficeClip.DBLayer.Account Namespace


LdapDB Class

[image]

OfficeClip API Documentation
LdapDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Implements all the functions and operations to enable authentication and integration to LDAP servers.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class LdapDB : OfficeClipDB
Visual Basic (Declaration)
Public Class LdapDB _
    Inherits OfficeClipDB
Visual C++
public ref class LdapDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Account..::.LdapDB

See Also

LdapDB Members
OfficeClip.DBLayer.Account Namespace


LdapDB Members

[image] [image]

OfficeClip API Documentation
LdapDB Members
LdapDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The LdapDB type exposes the following members.

Constructors

 | Name | Description
Public method | LdapDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAuthenticationTypes | Get all the possible Authentication types supported by the .Net framework.
Public method | GetChildDistinguishedNames | Gets the list of all the distinguished names at a given base url on an LDAP Server.
Public method | GetDistinguishedNames | Gets the list of all the distinguished names at the base (rootDSE).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLdapUsers | Gets a list of OCUserInfo objects from an LDAP server using the authentication information provided along with the base where user objects are stored. The values from the LDAP server are retrieved for which the mapping was provided between the OfficeClip OCUserInfo property names and the LDAP User property names. The mapping is used corresponding to a particular group identified by the given GroupId.
Public method | GetOCLdapPropertyNames | Gets a list of previously saved if any otherwise default mapping of the LDAP property names corresponding to OfficeClip property names for a User object.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserPropertyNames | Gets a list of all the properties available on an LDAP server in the objects in a given base (or node).
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | IsValidAccount | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

LdapDB Class
OfficeClip.DBLayer.Account Namespace


LdapDB Constructor

[image]

OfficeClip API Documentation
LdapDB Constructor
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public LdapDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LdapDB()

See Also

LdapDB Class
OfficeClip.DBLayer.Account Namespace


LdapDB Methods

[image] [image]

OfficeClip API Documentation
LdapDB Methods
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

The LdapDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAuthenticationTypes | Get all the possible Authentication types supported by the .Net framework.
Public method | GetChildDistinguishedNames | Gets the list of all the distinguished names at a given base url on an LDAP Server.
Public method | GetDistinguishedNames | Gets the list of all the distinguished names at the base (rootDSE).
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLdapUsers | Gets a list of OCUserInfo objects from an LDAP server using the authentication information provided along with the base where user objects are stored. The values from the LDAP server are retrieved for which the mapping was provided between the OfficeClip OCUserInfo property names and the LDAP User property names. The mapping is used corresponding to a particular group identified by the given GroupId.
Public method | GetOCLdapPropertyNames | Gets a list of previously saved if any otherwise default mapping of the LDAP property names corresponding to OfficeClip property names for a User object.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserPropertyNames | Gets a list of all the properties available on an LDAP server in the objects in a given base (or node).
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | IsValidAccount | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LdapDB Class
OfficeClip.DBLayer.Account Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
LdapDB..::.AddOutputParameter Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

LdapDB Class
LdapDB Members
OfficeClip.DBLayer.Account Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
LdapDB..::.AddParameter Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

LdapDB Class
LdapDB Members
OfficeClip.DBLayer.Account Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
LdapDB..::.AddParameters Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

LdapDB Class
LdapDB Members
OfficeClip.DBLayer.Account Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
LdapDB..::.ExecuteNonQuery Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

LdapDB Class
LdapDB Members
OfficeClip.DBLayer.Account Namespace


GetAuthenticationTypes Method

[image]

OfficeClip API Documentation
LdapDB..::.GetAuthenticationTypes Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Get all the possible Authentication types supported by the .Net framework.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetAuthenticationTypes()
Visual Basic (Declaration)
Public Function GetAuthenticationTypes As DataTable
Visual C++
public:
DataTable^ GetAuthenticationTypes()

Return Value

DataTable containing two columns of numeric value of the AuthenticationType and the Description. 1. Id (System.Int32) 2. Desc (System.String) Typecast Int value of Id to AuthenticationTypes to get the appropriate AuthenticationType.

See Also

LdapDB Class
OfficeClip.DBLayer.Account Namespace


GetChildDistinguishedNames Method

[image]

OfficeClip API Documentation
LdapDB..::.GetChildDistinguishedNames Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of all the distinguished names at a given base url on an LDAP Server.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetChildDistinguishedNames(
    LdapAuthenticationInfo ldai
)
Visual Basic (Declaration)
Public Function GetChildDistinguishedNames ( _
    ldai As LdapAuthenticationInfo _
) As ArrayList
Visual C++
public:
ArrayList^ GetChildDistinguishedNames(
    LdapAuthenticationInfo^ ldai
)

Parameters

ldai
Type: OfficeClip.BusinessLayer.Account..::.LdapAuthenticationInfo
The LdapAuthenticationInfo object containing the name of the server and the other authentication information.

Return Value

Array List of PropertyInfo object containing the distinguished name in both the property name and property value fields.

See Also

LdapDB Class
OfficeClip.DBLayer.Account Namespace


GetDistinguishedNames Method

[image]

OfficeClip API Documentation
LdapDB..::.GetDistinguishedNames Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of all the distinguished names at the base (rootDSE).

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetDistinguishedNames(
    LdapAuthenticationInfo ldai
)
Visual Basic (Declaration)
Public Function GetDistinguishedNames ( _
    ldai As LdapAuthenticationInfo _
) As ArrayList
Visual C++
public:
ArrayList^ GetDistinguishedNames(
    LdapAuthenticationInfo^ ldai
)

Parameters

ldai
Type: OfficeClip.BusinessLayer.Account..::.LdapAuthenticationInfo
The LdapAuthenticationInfo object containing the name of the server and the other authentication information.

Return Value

Array List of PropertyInfo object containing the distinguished name in both the property name and property value fields.

See Also

LdapDB Class
OfficeClip.DBLayer.Account Namespace


GetLdapUsers Method

[image]

OfficeClip API Documentation
LdapDB..::.GetLdapUsers Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of OCUserInfo objects from an LDAP server using the authentication information provided along with the base where user objects are stored. The values from the LDAP server are retrieved for which the mapping was provided between the OfficeClip OCUserInfo property names and the LDAP User property names. The mapping is used corresponding to a particular group identified by the given GroupId.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetLdapUsers(
    LdapAuthenticationInfo ldai,
    int groupId,
    bool importForAddressBookEntries
)
Visual Basic (Declaration)
Public Function GetLdapUsers ( _
    ldai As LdapAuthenticationInfo, _
    groupId As Integer, _
    importForAddressBookEntries As Boolean _
) As ArrayList
Visual C++
public:
ArrayList^ GetLdapUsers(
    LdapAuthenticationInfo^ ldai,
    int groupId,
    bool importForAddressBookEntries
)

Parameters

ldai
Type: OfficeClip.BusinessLayer.Account..::.LdapAuthenticationInfo
The LdapAuthenticationInfo object containing the name of the server and the other authentication information.
groupId
Type: System..::.Int32
The id of the group corresponding to the group for which the mapping is to be used.
importForAddressBookEntries
Type: System..::.Boolean
True if the users are to be imported into Address Book otherwise false (for Groups, Organizations and Departments).

Return Value

ArrayList of OCUserInfo objects containing data from the a particular LDAP server.

See Also

LdapDB Class
OfficeClip.DBLayer.Account Namespace


GetOCLdapPropertyNames Method

[image]

OfficeClip API Documentation
LdapDB..::.GetOCLdapPropertyNames Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of previously saved if any otherwise default mapping of the LDAP property names corresponding to OfficeClip property names for a User object.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetOCLdapPropertyNames(
    int groupId
)
Visual Basic (Declaration)
Public Function GetOCLdapPropertyNames ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetOCLdapPropertyNames(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The group id for which the saved (if any) mapping is to be retrieved.

Return Value

Returns a DataSet representation of the ldap.xml corresponding to the previously saved xml mapping in for a particular group or the default from the ldap.xml in the resources folder.

See Also

LdapDB Class
OfficeClip.DBLayer.Account Namespace


GetUserPropertyNames Method

[image]

OfficeClip API Documentation
LdapDB..::.GetUserPropertyNames Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the properties available on an LDAP server in the objects in a given base (or node).

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetUserPropertyNames(
    LdapAuthenticationInfo ldai,
    ArrayList properties
)
Visual Basic (Declaration)
Public Function GetUserPropertyNames ( _
    ldai As LdapAuthenticationInfo, _
    properties As ArrayList _
) As DataTable
Visual C++
public:
DataTable^ GetUserPropertyNames(
    LdapAuthenticationInfo^ ldai,
    ArrayList^ properties
)

Parameters

ldai
Type: OfficeClip.BusinessLayer.Account..::.LdapAuthenticationInfo
The LdapAuthenticationInfo object containing the name of the server and the other authentication information.
properties
Type: System.Collections..::.ArrayList
Properties that need to be mapped and if all of these are mapped, the search stops and the list is returned in a DataTable.

Return Value

A DataTable containing two columns 1. property (System.String) 2. propertyValue (System.String) Both contain the same property name except that propertyValue is converted to lower case to enable lowercased string comparison.

See Also

LdapDB Class
OfficeClip.DBLayer.Account Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
LdapDB..::.InitTransaction Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

LdapDB Class
LdapDB Members
OfficeClip.DBLayer.Account Namespace


IsValidAccount Method

[image] [image]

OfficeClip API Documentation
LdapDB..::.IsValidAccount Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | IsValidAccount()()() | Authenticates the account information specified in the LdapAuthenticationString in the web.config
Public method | IsValidAccount(String, String) | Authenticates a given account name and password against the LDAP server specified in the LdapAuthenticationString in the web.config
Public method | IsValidAccount(String, String, String) | Authenticates a given account name and password on a given LDAP Server. By default the authentication is done on the default space unless specified in the LDAP Server name.
Public method | IsValidAccount(String, String, String, AuthenticationTypes) | Authenticates a given account name and password on a given LDAP Server using a particualar authentication type. By default the authentication is done on the default space unless specified in the LDAP Server name.

See Also

LdapDB Class
LdapDB Members
OfficeClip.DBLayer.Account Namespace


IsValidAccount Method

[image]

OfficeClip API Documentation
LdapDB..::.IsValidAccount Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Authenticates the account information specified in the LdapAuthenticationString in the web.config

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsValidAccount()
Visual Basic (Declaration)
Public Function IsValidAccount As Boolean
Visual C++
public:
bool IsValidAccount()

Return Value

True if successful, False otherwise.

See Also

LdapDB Class
IsValidAccount Overload
OfficeClip.DBLayer.Account Namespace


IsValidAccount Method (String, String)

[image]

OfficeClip API Documentation
LdapDB..::.IsValidAccount Method (String, String)
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Authenticates a given account name and password against the LDAP server specified in the LdapAuthenticationString in the web.config

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsValidAccount(
    string accountName,
    string accountPassword
)
Visual Basic (Declaration)
Public Function IsValidAccount ( _
    accountName As String, _
    accountPassword As String _
) As Boolean
Visual C++
public:
bool IsValidAccount(
    String^ accountName,
    String^ accountPassword
)

Parameters

accountName
Type: System..::.String
Account name on the LDAP Server
accountPassword
Type: System..::.String
password corresponding to the Account Name

Return Value

True if successful, False otherwise.

See Also

LdapDB Class
IsValidAccount Overload
OfficeClip.DBLayer.Account Namespace


IsValidAccount Method (String, String, String)

[image]

OfficeClip API Documentation
LdapDB..::.IsValidAccount Method (String, String, String)
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Authenticates a given account name and password on a given LDAP Server. By default the authentication is done on the default space unless specified in the LDAP Server name.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsValidAccount(
    string serverName,
    string accountName,
    string accountPassword
)
Visual Basic (Declaration)
Public Function IsValidAccount ( _
    serverName As String, _
    accountName As String, _
    accountPassword As String _
) As Boolean
Visual C++
public:
bool IsValidAccount(
    String^ serverName,
    String^ accountName,
    String^ accountPassword
)

Parameters

serverName
Type: System..::.String
The name of the LDAP server. This value can be just a server hostname, IP Address or a fully qualified LDAP URL e.g. LDAP://myldapserver.com. It can also include a specific base e.g. LDAP://myldapserver.com/CN=Users,DC=myserser,DC=net
accountName
Type: System..::.String
Account name on the LDAP Server
accountPassword
Type: System..::.String
password corresponding to the Account Name

Return Value

True if successful, False otherwise.

See Also

LdapDB Class
IsValidAccount Overload
OfficeClip.DBLayer.Account Namespace


IsValidAccount Method (String, String, String, AuthenticationTypes)

[image]

OfficeClip API Documentation
LdapDB..::.IsValidAccount Method (String, String, String, AuthenticationTypes)
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Authenticates a given account name and password on a given LDAP Server using a particualar authentication type. By default the authentication is done on the default space unless specified in the LDAP Server name.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsValidAccount(
    string serverName,
    string accountName,
    string accountPassword,
    AuthenticationTypes authType
)
Visual Basic (Declaration)
Public Function IsValidAccount ( _
    serverName As String, _
    accountName As String, _
    accountPassword As String, _
    authType As AuthenticationTypes _
) As Boolean
Visual C++
public:
bool IsValidAccount(
    String^ serverName,
    String^ accountName,
    String^ accountPassword,
    AuthenticationTypes authType
)

Parameters

serverName
Type: System..::.String
The name of the LDAP server. This value can be just a server hostname, IP Address or a fully qualified LDAP URL e.g. LDAP://myldapserver.com. It can also include a specific base e.g. LDAP://myldapserver.com/CN=Users,DC=myserser,DC=net
accountName
Type: System..::.String
Account name on the LDAP Server
accountPassword
Type: System..::.String
password corresponding to the Account Name
authType
Type: System.DirectoryServices..::.AuthenticationTypes
The authentication type supported by the LDAP server.

Return Value

True if successful, False otherwise.

See Also

LdapDB Class
IsValidAccount Overload
OfficeClip.DBLayer.Account Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
LdapDB..::.SetSPCommand Method
LdapDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

LdapDB Class
LdapDB Members
OfficeClip.DBLayer.Account Namespace


MainDB Class

[image]

OfficeClip API Documentation
MainDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of core functions in the framework of the OfficeClip application.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class MainDB : OfficeClipDB
Visual Basic (Declaration)
Public Class MainDB _
    Inherits OfficeClipDB
Visual C++
public ref class MainDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Account..::.MainDB

See Also

MainDB Members
OfficeClip.DBLayer.Account Namespace


MainDB Members

[image] [image]

OfficeClip API Documentation
MainDB Members
MainDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MainDB type exposes the following members.

Constructors

 | Name | Description
Public method | MainDB | The default constructor

Methods

 | Name | Description
Public method | ActivateEmail | Activates the user's email indentified by the activationCode provided by the user.
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ApplyForgotPassword | Sends a new randomly created password for the user in the email in case the user has forgotten the password.
Public method | ChangeCurrentlySelectedGroup | Sets the currently selected group in the session to a particular group for the currently logged in user.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetRegistrationEula | Gets the end user's license agreement to be shown and accepted by the user at the time of registration.
Public method | GetRegistrationQuestions | Gets a set of questions to be asked at the time of registration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PasswordInOldFormat | Checks whether the password is in the old format i.e. prior to Version 6.1.1.
Public method | RegisterUser | Registers a user in the OfficeClip system.
Public method | ResetCustomerPortalPassword | Resets the Extranet password
Public method | ResetPassword | Resets the password for a particular user.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetDemoUserLogin |
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDemoData | Updates the demo data... NOTE: This functions hould only be used with demo data otherwise it will mess up the dates of all officeclip data...
Public method | UpdateRegistrationDetails | Updates the registration details for a user.
Public method | ValidateUserLogin | Validates a user based on a given email Address and password.
Public method | ValidateUserRegistration | Validates whether the user can be registered based on the values filled up by the user on the registration form.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


MainDB Constructor

[image]

OfficeClip API Documentation
MainDB Constructor
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MainDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MainDB()

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


MainDB Methods

[image] [image]

OfficeClip API Documentation
MainDB Methods
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

The MainDB type exposes the following methods.

Methods

 | Name | Description
Public method | ActivateEmail | Activates the user's email indentified by the activationCode provided by the user.
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ApplyForgotPassword | Sends a new randomly created password for the user in the email in case the user has forgotten the password.
Public method | ChangeCurrentlySelectedGroup | Sets the currently selected group in the session to a particular group for the currently logged in user.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetRegistrationEula | Gets the end user's license agreement to be shown and accepted by the user at the time of registration.
Public method | GetRegistrationQuestions | Gets a set of questions to be asked at the time of registration.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PasswordInOldFormat | Checks whether the password is in the old format i.e. prior to Version 6.1.1.
Public method | RegisterUser | Registers a user in the OfficeClip system.
Public method | ResetCustomerPortalPassword | Resets the Extranet password
Public method | ResetPassword | Resets the password for a particular user.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetDemoUserLogin |
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDemoData | Updates the demo data... NOTE: This functions hould only be used with demo data otherwise it will mess up the dates of all officeclip data...
Public method | UpdateRegistrationDetails | Updates the registration details for a user.
Public method | ValidateUserLogin | Validates a user based on a given email Address and password.
Public method | ValidateUserRegistration | Validates whether the user can be registered based on the values filled up by the user on the registration form.

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


ActivateEmail Method

[image]

OfficeClip API Documentation
MainDB..::.ActivateEmail Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Activates the user's email indentified by the activationCode provided by the user.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ActivateEmail(
    string activationCode
)
Visual Basic (Declaration)
Public Function ActivateEmail ( _
    activationCode As String _
) As Integer
Visual C++
public:
int ActivateEmail(
    String^ activationCode
)

Parameters

activationCode
Type: System..::.String
The email actication code provided by the user which was received in the email validating that user's email Address exists and is correct.

Return Value

0 when successful, -1 when activation code could be found in the system, -2 when the activation code provided is already activated.

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
MainDB..::.AddOutputParameter Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

MainDB Class
MainDB Members
OfficeClip.DBLayer.Account Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
MainDB..::.AddParameter Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

MainDB Class
MainDB Members
OfficeClip.DBLayer.Account Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
MainDB..::.AddParameters Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

MainDB Class
MainDB Members
OfficeClip.DBLayer.Account Namespace


ApplyForgotPassword Method

[image]

OfficeClip API Documentation
MainDB..::.ApplyForgotPassword Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends a new randomly created password for the user in the email in case the user has forgotten the password.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ApplyForgotPassword(
    string emailAddress
)
Visual Basic (Declaration)
Public Function ApplyForgotPassword ( _
    emailAddress As String _
) As Integer
Visual C++
public:
int ApplyForgotPassword(
    String^ emailAddress
)

Parameters

emailAddress
Type: System..::.String
Email Address of the user. (Login id in OfficeClip system.)

Return Value

Id of the user whose password has been updated and sent, -1 in case of an error.

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


ChangeCurrentlySelectedGroup Method

[image]

OfficeClip API Documentation
MainDB..::.ChangeCurrentlySelectedGroup Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the currently selected group in the session to a particular group for the currently logged in user.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void ChangeCurrentlySelectedGroup(
    int currentUserId,
    int groupId
)
Visual Basic (Declaration)
Public Sub ChangeCurrentlySelectedGroup ( _
    currentUserId As Integer, _
    groupId As Integer _
)
Visual C++
public:
void ChangeCurrentlySelectedGroup(
    int currentUserId,
    int groupId
)

Parameters

currentUserId
Type: System..::.Int32
The id of the current user
groupId
Type: System..::.Int32
Id of a particular group which has to be set as the currently selected group.

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
MainDB..::.ExecuteNonQuery Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

MainDB Class
MainDB Members
OfficeClip.DBLayer.Account Namespace


GetRegistrationEula Method

[image]

OfficeClip API Documentation
MainDB..::.GetRegistrationEula Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the end user's license agreement to be shown and accepted by the user at the time of registration.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetRegistrationEula(
    OCResources ocr
)
Visual Basic (Declaration)
Public Function GetRegistrationEula ( _
    ocr As OCResources _
) As DataSet
Visual C++
public:
DataSet^ GetRegistrationEula(
    OCResources^ ocr
)

Parameters

ocr
Type: OfficeClip.Utils..::.OCResources
The OfficeClip resource object.

Return Value

DataSet corresponding to the registrationEULA.xml resource document. Please refer to the OfficeClip customization document (level 1 customization) for more information on how to use and customize these questions.

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


GetRegistrationQuestions Method

[image]

OfficeClip API Documentation
MainDB..::.GetRegistrationQuestions Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a set of questions to be asked at the time of registration.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetRegistrationQuestions(
    OCResources ocr
)
Visual Basic (Declaration)
Public Function GetRegistrationQuestions ( _
    ocr As OCResources _
) As DataSet
Visual C++
public:
DataSet^ GetRegistrationQuestions(
    OCResources^ ocr
)

Parameters

ocr
Type: OfficeClip.Utils..::.OCResources
The OfficeClip resource object.

Return Value

DataSet corresponding to the registrationQuestions.xml resource document. Please refer to the OfficeClip customization document (level 1 customization) for more information on how to use and customize these questions.

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
MainDB..::.InitTransaction Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

MainDB Class
MainDB Members
OfficeClip.DBLayer.Account Namespace


PasswordInOldFormat Method

[image]

OfficeClip API Documentation
MainDB..::.PasswordInOldFormat Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks whether the password is in the old format i.e. prior to Version 6.1.1.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool PasswordInOldFormat(
    string emailAddress
)
Visual Basic (Declaration)
Public Function PasswordInOldFormat ( _
    emailAddress As String _
) As Boolean
Visual C++
public:
bool PasswordInOldFormat(
    String^ emailAddress
)

Parameters

emailAddress
Type: System..::.String
Email Address which needs to be checked.

Return Value

Flag (True/False) indicating whether the email Address is in old format or not.

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


RegisterUser Method

[image]

OfficeClip API Documentation
MainDB..::.RegisterUser Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Registers a user in the OfficeClip system.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RegisterUser(
    string firstName,
    string lastName,
    string emailAddress,
    string ldapAccountName,
    string password,
    string workPhonePrimary,
    string groupName,
    string grpType,
    int groupTimezoneId,
    int userTimezoneId,
    AddressInfo ai,
    out int userId,
    out int groupId
)
Visual Basic (Declaration)
Public Function RegisterUser ( _
    firstName As String, _
    lastName As String, _
    emailAddress As String, _
    ldapAccountName As String, _
    password As String, _
    workPhonePrimary As String, _
    groupName As String, _
    grpType As String, _
    groupTimezoneId As Integer, _
    userTimezoneId As Integer, _
    ai As AddressInfo, _
    <OutAttribute> ByRef userId As Integer, _
    <OutAttribute> ByRef groupId As Integer _
) As Integer
Visual C++
public:
int RegisterUser(
    String^ firstName,
    String^ lastName,
    String^ emailAddress,
    String^ ldapAccountName,
    String^ password,
    String^ workPhonePrimary,
    String^ groupName,
    String^ grpType,
    int groupTimezoneId,
    int userTimezoneId,
    AddressInfo^ ai,
    [OutAttribute] int% userId,
    [OutAttribute] int% groupId
)

Parameters

firstName
Type: System..::.String
First name of the user.
lastName
Type: System..::.String
Last name of the user.
emailAddress
Type: System..::.String
Email Address of the user.
ldapAccountName
Type: System..::.String
LDAP Account Name of the user.
password
Type: System..::.String
password of the user.
workPhonePrimary
Type: System..::.String
Primary work phone number of the user.
groupName
Type: System..::.String
Name of the group or organization.
grpType
Type: System..::.String
Type of the group i.e. whether it is group or organization. OfficeClip.Utils..::.GroupType
groupTimezoneId
Type: System..::.Int32
Timezone id of the group.
userTimezoneId
Type: System..::.Int32
Timezone id of the user.
ai
Type: OfficeClip.BusinessLayer.Account..::.AddressInfo
Instance of AddressInfo object containing all the information related to the Address of the registering user.
userId
Type: System..::.Int32%
The unique id of the user
groupId
Type: System..::.Int32%
The unique id of the group

Return Value

Integer flag indicating whether the registration was successful or not. Following is the list of possible values returned and their meanings. 0 = Successful -1 = Group or Orgnaization name already exists. -2 = User is already registered. -3 = LDAP Account Name entered has already been used for another user (If LDAP Authentication is enabled). -4 = LDAP Account Name entered could not be authenticated on the LDAP Server. (If LDAP Authentication is enabled).

Remarks

Please make sure that firstName, lastName, emailAddress, ldapAccountName, password values are not empty. The validation for emptyness should be done before calling this method. Also note that only organization and Group type should be passed as argument during registration.

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


ResetCustomerPortalPassword Method

[image]

OfficeClip API Documentation
MainDB..::.ResetCustomerPortalPassword Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Resets the Extranet password

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ResetCustomerPortalPassword(
    string emailAddress,
    string customerPortalUrl
)
Visual Basic (Declaration)
Public Function ResetCustomerPortalPassword ( _
    emailAddress As String, _
    customerPortalUrl As String _
) As Integer
Visual C++
public:
int ResetCustomerPortalPassword(
    String^ emailAddress,
    String^ customerPortalUrl
)

Parameters

emailAddress
Type: System..::.String
customerPortalUrl
Type: System..::.String

Return Value

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


ResetPassword Method

[image]

OfficeClip API Documentation
MainDB..::.ResetPassword Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Resets the password for a particular user.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ResetPassword(
    int userId,
    string newPassword
)
Visual Basic (Declaration)
Public Function ResetPassword ( _
    userId As Integer, _
    newPassword As String _
) As Integer
Visual C++
public:
int ResetPassword(
    int userId,
    String^ newPassword
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
newPassword
Type: System..::.String
New password to be set.

Return Value

0 when successful, -1 in case of an error.

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


SetDemoUserLogin Method

[image]

OfficeClip API Documentation
MainDB..::.SetDemoUserLogin Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool SetDemoUserLogin(
    string emailAddress
)
Visual Basic (Declaration)
Public Function SetDemoUserLogin ( _
    emailAddress As String _
) As Boolean
Visual C++
public:
bool SetDemoUserLogin(
    String^ emailAddress
)

Parameters

emailAddress
Type: System..::.String

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
MainDB..::.SetSPCommand Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

MainDB Class
MainDB Members
OfficeClip.DBLayer.Account Namespace


UpdateDemoData Method

[image]

OfficeClip API Documentation
MainDB..::.UpdateDemoData Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the demo data... NOTE: This functions hould only be used with demo data otherwise it will mess up the dates of all officeclip data...

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateDemoData()
Visual Basic (Declaration)
Public Sub UpdateDemoData
Visual C++
public:
void UpdateDemoData()

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


UpdateRegistrationDetails Method

[image]

OfficeClip API Documentation
MainDB..::.UpdateRegistrationDetails Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the registration details for a user.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateRegistrationDetails(
    int loginUserId,
    int loginGroupId,
    string firstName,
    string lastName,
    string workPhonePrimary,
    int pagerTypeId,
    string pagerId,
    string pagerCompanyServicePhone,
    string pagerCompanyNumberFromlist,
    int userTimezoneId,
    AddressInfo ai,
    ArrayList registrationOptions
)
Visual Basic (Declaration)
Public Function UpdateRegistrationDetails ( _
    loginUserId As Integer, _
    loginGroupId As Integer, _
    firstName As String, _
    lastName As String, _
    workPhonePrimary As String, _
    pagerTypeId As Integer, _
    pagerId As String, _
    pagerCompanyServicePhone As String, _
    pagerCompanyNumberFromlist As String, _
    userTimezoneId As Integer, _
    ai As AddressInfo, _
    registrationOptions As ArrayList _
) As Integer
Visual C++
public:
int UpdateRegistrationDetails(
    int loginUserId,
    int loginGroupId,
    String^ firstName,
    String^ lastName,
    String^ workPhonePrimary,
    int pagerTypeId,
    String^ pagerId,
    String^ pagerCompanyServicePhone,
    String^ pagerCompanyNumberFromlist,
    int userTimezoneId,
    AddressInfo^ ai,
    ArrayList^ registrationOptions
)

Parameters

loginUserId
Type: System..::.Int32
The unique id of the currently logged in user.
loginGroupId
Type: System..::.Int32
The unique id of the group of the currently logged in user.
firstName
Type: System..::.String
First name of the user.
lastName
Type: System..::.String
Last name of the user.
workPhonePrimary
Type: System..::.String
Primary work phone number of the user.
pagerTypeId
Type: System..::.Int32
The id which determines the type of the pager (service provider)
pagerId
Type: System..::.String
Pager Id of the user.
pagerCompanyServicePhone
Type: System..::.String
Pager company's service phone number. Usually the 1-800 number.
pagerCompanyNumberFromlist
Type: System..::.String
Flag indicating whether Pager Comapny Number is from a provided list or not
userTimezoneId
Type: System..::.Int32
Timezone id of the user.
ai
Type: OfficeClip.BusinessLayer.Account..::.AddressInfo
Instance of the AddressInfo object containing all the Address information of the registering user.
registrationOptions
Type: System.Collections..::.ArrayList
ArrayList of RegistrationQuestionsInfo objects containing all the registration time questions and user's responses.

Return Value

0 when successful, -1 in case of an error.

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


ValidateUserLogin Method

[image]

OfficeClip API Documentation
MainDB..::.ValidateUserLogin Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Validates a user based on a given email Address and password.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ValidateUserLogin(
    string emailAddress,
    string password,
    out string errMessage
)
Visual Basic (Declaration)
Public Function ValidateUserLogin ( _
    emailAddress As String, _
    password As String, _
    <OutAttribute> ByRef errMessage As String _
) As Integer
Visual C++
public:
int ValidateUserLogin(
    String^ emailAddress,
    String^ password,
    [OutAttribute] String^% errMessage
)

Parameters

emailAddress
Type: System..::.String
Email Address of the user.
password
Type: System..::.String
password of the user.
errMessage
Type: System..::.String%
The error message

Return Value

Integer flag indicating whether the user could be successfully authenticated. Following is the list of possible values returned and their meanings. 0 = Successful -1 = Invalid Login-password -2 = Site license expired -3 = Account license expired -4 = Database and OfficeClip Version do not match -5 = OfficeClip has undergone a major upgrade. As a result, you need to reset password using Forgot password on the website and login again. -6 = Current upgrade is incompatible with your Current OfficeClip license. -7 = User not present in the system. Ask OfficeClip Administrator to add the user

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


ValidateUserRegistration Method

[image]

OfficeClip API Documentation
MainDB..::.ValidateUserRegistration Method
MainDB Class See Also

[This is preliminary documentation and is subject to change.]

Validates whether the user can be registered based on the values filled up by the user on the registration form.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ValidateUserRegistration(
    string emailAddress,
    string ldapAccountName,
    string groupName,
    string grpType
)
Visual Basic (Declaration)
Public Function ValidateUserRegistration ( _
    emailAddress As String, _
    ldapAccountName As String, _
    groupName As String, _
    grpType As String _
) As Integer
Visual C++
public:
int ValidateUserRegistration(
    String^ emailAddress,
    String^ ldapAccountName,
    String^ groupName,
    String^ grpType
)

Parameters

emailAddress
Type: System..::.String
Email Address of the user.
ldapAccountName
Type: System..::.String
Ldap Account Name of the user if LDAP authentication is enabled.
groupName
Type: System..::.String
Name of the group being created by the user.
grpType
Type: System..::.String
Type of the group being created by the user.

Return Value

Integer flag indicating whether the validation was successful or not. Following is the list of possible values returned and their meanings. 0 = Successful -1 = Group or Orgnaization name already exists. -2 = User is already registered. -3 = LDAP Account name already exists (If LDAP Authentication is enabled). -4 = LDAP Account Name entered could not be authenticated on the LDAP Server. (If LDAP Authentication is enabled).

Remarks

Please make sure that none of these values are not empty. The validation for emptyness should be done before calling this method. Also note that only organization and Group type should be passed as argument during registration.

See Also

MainDB Class
OfficeClip.DBLayer.Account Namespace


SmsInfoDB Class

[image]

OfficeClip API Documentation
SmsInfoDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of functions to get and update the user's Sms Inforamtion.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class SmsInfoDB : OfficeClipDB
Visual Basic (Declaration)
Public Class SmsInfoDB _
    Inherits OfficeClipDB
Visual C++
public ref class SmsInfoDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Account..::.SmsInfoDB

See Also

SmsInfoDB Members
OfficeClip.DBLayer.Account Namespace


SmsInfoDB Members

[image] [image]

OfficeClip API Documentation
SmsInfoDB Members
SmsInfoDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The SmsInfoDB type exposes the following members.

Constructors

 | Name | Description
Public method | SmsInfoDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteSMS | REmoves the SMS information for the user
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetSmsDetailInfo | Gets the Sms Info form userdetails table
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Public method | SetSmsDetailInfo | Updates the SMS Info into usersdetails table.
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

SmsInfoDB Class
OfficeClip.DBLayer.Account Namespace


SmsInfoDB Constructor

[image]

OfficeClip API Documentation
SmsInfoDB Constructor
SmsInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SmsInfoDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SmsInfoDB()

See Also

SmsInfoDB Class
OfficeClip.DBLayer.Account Namespace


SmsInfoDB Methods

[image] [image]

OfficeClip API Documentation
SmsInfoDB Methods
SmsInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

The SmsInfoDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteSMS | REmoves the SMS information for the user
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetSmsDetailInfo | Gets the Sms Info form userdetails table
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Public method | SetSmsDetailInfo | Updates the SMS Info into usersdetails table.
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SmsInfoDB Class
OfficeClip.DBLayer.Account Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
SmsInfoDB..::.AddOutputParameter Method
SmsInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

SmsInfoDB Class
SmsInfoDB Members
OfficeClip.DBLayer.Account Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
SmsInfoDB..::.AddParameter Method
SmsInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

SmsInfoDB Class
SmsInfoDB Members
OfficeClip.DBLayer.Account Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
SmsInfoDB..::.AddParameters Method
SmsInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

SmsInfoDB Class
SmsInfoDB Members
OfficeClip.DBLayer.Account Namespace


DeleteSMS Method

[image]

OfficeClip API Documentation
SmsInfoDB..::.DeleteSMS Method
SmsInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

REmoves the SMS information for the user

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteSMS(
    int userId
)
Visual Basic (Declaration)
Public Sub DeleteSMS ( _
    userId As Integer _
)
Visual C++
public:
void DeleteSMS(
    int userId
)

Parameters

userId
Type: System..::.Int32

See Also

SmsInfoDB Class
OfficeClip.DBLayer.Account Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
SmsInfoDB..::.ExecuteNonQuery Method
SmsInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

SmsInfoDB Class
SmsInfoDB Members
OfficeClip.DBLayer.Account Namespace


GetSmsDetailInfo Method

[image]

OfficeClip API Documentation
SmsInfoDB..::.GetSmsDetailInfo Method
SmsInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Sms Info form userdetails table

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SmsInfo GetSmsDetailInfo(
    int userId
)
Visual Basic (Declaration)
Public Function GetSmsDetailInfo ( _
    userId As Integer _
) As SmsInfo
Visual C++
public:
SmsInfo^ GetSmsDetailInfo(
    int userId
)

Parameters

userId
Type: System..::.Int32
the user id of the user

Return Value

See Also

SmsInfoDB Class
OfficeClip.DBLayer.Account Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
SmsInfoDB..::.InitTransaction Method
SmsInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

SmsInfoDB Class
SmsInfoDB Members
OfficeClip.DBLayer.Account Namespace


SetSmsDetailInfo Method

[image]

OfficeClip API Documentation
SmsInfoDB..::.SetSmsDetailInfo Method
SmsInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the SMS Info into usersdetails table.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetSmsDetailInfo(
    SmsInfo info,
    int userId
)
Visual Basic (Declaration)
Public Sub SetSmsDetailInfo ( _
    info As SmsInfo, _
    userId As Integer _
)
Visual C++
public:
void SetSmsDetailInfo(
    SmsInfo^ info,
    int userId
)

Parameters

info
Type: OfficeClip.BusinessLayer.Account..::.SmsInfo
the SmsInfo object
userId
Type: System..::.Int32
the user id of the user

See Also

SmsInfoDB Class
OfficeClip.DBLayer.Account Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
SmsInfoDB..::.SetSPCommand Method
SmsInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

SmsInfoDB Class
SmsInfoDB Members
OfficeClip.DBLayer.Account Namespace


SubscriptionDB Class

[image]

OfficeClip API Documentation
SubscriptionDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Allows management of Account subscription for online users.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class SubscriptionDB : OfficeClipDB
Visual Basic (Declaration)
Public Class SubscriptionDB _
    Inherits OfficeClipDB
Visual C++
public ref class SubscriptionDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Account..::.SubscriptionDB

See Also

SubscriptionDB Members
OfficeClip.DBLayer.Account Namespace


SubscriptionDB Members

[image] [image]

OfficeClip API Documentation
SubscriptionDB Members
SubscriptionDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The SubscriptionDB type exposes the following members.

Constructors

 | Name | Description
Public method | SubscriptionDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Public method | ExtendSubscription | Extends the subscription for a particular account.
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccountingCycleDuration | Gets the number of days allowed in the trial period based on the information provided in the accounting.xml resource file
Public method | GetAccountUsersAccess | Gets a list of all the users in a particular account and the date and time when they last accessed OfficeClip
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetOldAccounts | Returns a list of all the accounts in which none of the users have used the system in certain number of days
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetProviderUrl | Gets the url that has to be sent to the provider via http request.
Public method | GetTrialPeriodUsersCount | Gets the number of users allowed in the trial period based on the information provided in the accounting.xml resource file
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PayNow | Overloaded.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SendSaleConfirmationCC | Sends a Credit Card sale notification
Public method | SendSaleConfirmationPO | Sends a Purchase order sale notification
Public method | SendSaleNotice | Sends a sale notification
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

SubscriptionDB Class
OfficeClip.DBLayer.Account Namespace


SubscriptionDB Constructor

[image] [image]

OfficeClip API Documentation
SubscriptionDB Constructor
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | SubscriptionDB()()() | Constructor
Public method | SubscriptionDB(Boolean) | Constructor

See Also

SubscriptionDB Class
SubscriptionDB Members
OfficeClip.DBLayer.Account Namespace


SubscriptionDB Constructor

[image]

OfficeClip API Documentation
SubscriptionDB Constructor
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SubscriptionDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SubscriptionDB()

See Also

SubscriptionDB Class
SubscriptionDB Overload
OfficeClip.DBLayer.Account Namespace


SubscriptionDB Constructor (Boolean)

[image]

OfficeClip API Documentation
SubscriptionDB Constructor (Boolean)
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SubscriptionDB(
    bool isSync
)
Visual Basic (Declaration)
Public Sub New ( _
    isSync As Boolean _
)
Visual C++
public:
SubscriptionDB(
    bool isSync
)

Parameters

isSync
Type: System..::.Boolean

See Also

SubscriptionDB Class
SubscriptionDB Overload
OfficeClip.DBLayer.Account Namespace


SubscriptionDB Methods

[image] [image]

OfficeClip API Documentation
SubscriptionDB Methods
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

The SubscriptionDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Public method | ExtendSubscription | Extends the subscription for a particular account.
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccountingCycleDuration | Gets the number of days allowed in the trial period based on the information provided in the accounting.xml resource file
Public method | GetAccountUsersAccess | Gets a list of all the users in a particular account and the date and time when they last accessed OfficeClip
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetOldAccounts | Returns a list of all the accounts in which none of the users have used the system in certain number of days
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetProviderUrl | Gets the url that has to be sent to the provider via http request.
Public method | GetTrialPeriodUsersCount | Gets the number of users allowed in the trial period based on the information provided in the accounting.xml resource file
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PayNow | Overloaded.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SendSaleConfirmationCC | Sends a Credit Card sale notification
Public method | SendSaleConfirmationPO | Sends a Purchase order sale notification
Public method | SendSaleNotice | Sends a sale notification
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubscriptionDB Class
OfficeClip.DBLayer.Account Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
SubscriptionDB..::.AddOutputParameter Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

SubscriptionDB Class
SubscriptionDB Members
OfficeClip.DBLayer.Account Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
SubscriptionDB..::.AddParameter Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

SubscriptionDB Class
SubscriptionDB Members
OfficeClip.DBLayer.Account Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
SubscriptionDB..::.AddParameters Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

SubscriptionDB Class
SubscriptionDB Members
OfficeClip.DBLayer.Account Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
SubscriptionDB..::.ExecuteNonQuery Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

SubscriptionDB Class
SubscriptionDB Members
OfficeClip.DBLayer.Account Namespace


ExtendSubscription Method

[image]

OfficeClip API Documentation
SubscriptionDB..::.ExtendSubscription Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Extends the subscription for a particular account.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ExtendSubscription(
    transactionInfo ti,
    int accountId,
    int numberOfUsers,
    int numberOfDays,
    ArrayList docStorageList,
    ref string detailError,
    int selectedPackage,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function ExtendSubscription ( _
    ti As transactionInfo, _
    accountId As Integer, _
    numberOfUsers As Integer, _
    numberOfDays As Integer, _
    docStorageList As ArrayList, _
    ByRef detailError As String, _
    selectedPackage As Integer, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int ExtendSubscription(
    transactionInfo^ ti,
    int accountId,
    int numberOfUsers,
    int numberOfDays,
    ArrayList^ docStorageList,
    String^% detailError,
    int selectedPackage,
    ConfigureInfo^ session
)

Parameters

ti
Type: OfficeClip.BusinessLayer.Account..::.transactionInfo
The information related to the credit card or the purchase order. and the Amount.
accountId
Type: System..::.Int32
Id of the account whose subscription is to be extended
numberOfUsers
Type: System..::.Int32
Number of users Limit in the account
numberOfDays
Type: System..::.Int32
Number of days for which the subscription has to be extended beyond the Current Limit
docStorageList
Type: System.Collections..::.ArrayList
ArrayList of DocumentStorageInfo objects specifying the Amount of disk storage that has to be allocated corresponding to a particular group or user.
detailError
Type: System..::.String%
The detail error that is returned.
selectedPackage
Type: System..::.Int32
The package selected for the user
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

0 = successful, negative number as error

See Also

SubscriptionDB Class
OfficeClip.DBLayer.Account Namespace


GetAccountingCycleDuration Method

[image]

OfficeClip API Documentation
SubscriptionDB..::.GetAccountingCycleDuration Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the number of days allowed in the trial period based on the information provided in the accounting.xml resource file

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetAccountingCycleDuration()
Visual Basic (Declaration)
Public Function GetAccountingCycleDuration As Integer
Visual C++
public:
int GetAccountingCycleDuration()

Return Value

The nuber of days

See Also

SubscriptionDB Class
OfficeClip.DBLayer.Account Namespace


GetAccountUsersAccess Method

[image]

OfficeClip API Documentation
SubscriptionDB..::.GetAccountUsersAccess Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the users in a particular account and the date and time when they last accessed OfficeClip

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAccountUsersAccess(
    int accountId
)
Visual Basic (Declaration)
Public Function GetAccountUsersAccess ( _
    accountId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAccountUsersAccess(
    int accountId
)

Parameters

accountId
Type: System..::.Int32
Id of a particular account

Return Value

DataSet containing a single table with the following columns
  • UserId (System.Int32) Id of the user in the account
  • UserName (System.String) Name of the user.
  • lastAccessTimestamp (System.DateTime) Date and time when the user last accessed OfficeClip

See Also

SubscriptionDB Class
OfficeClip.DBLayer.Account Namespace


GetOldAccounts Method

[image]

OfficeClip API Documentation
SubscriptionDB..::.GetOldAccounts Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns a list of all the accounts in which none of the users have used the system in certain number of days

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetOldAccounts(
    int numDays
)
Visual Basic (Declaration)
Public Function GetOldAccounts ( _
    numDays As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetOldAccounts(
    int numDays
)

Parameters

numDays
Type: System..::.Int32
The number of days in which the for which the users have not used the sytem.

Return Value

A DataSet containing a single table with a single column AccountId (System.Int32)

See Also

SubscriptionDB Class
OfficeClip.DBLayer.Account Namespace


GetProviderUrl Method

[image]

OfficeClip API Documentation
SubscriptionDB..::.GetProviderUrl Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the url that has to be sent to the provider via http request.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetProviderUrl(
    string category,
    transactionInfo ti,
    ref string urlStr,
    ref string headerStr,
    ref ArrayList resultArr
)
Visual Basic (Declaration)
Public Sub GetProviderUrl ( _
    category As String, _
    ti As transactionInfo, _
    ByRef urlStr As String, _
    ByRef headerStr As String, _
    ByRef resultArr As ArrayList _
)
Visual C++
public:
void GetProviderUrl(
    String^ category,
    transactionInfo^ ti,
    String^% urlStr,
    String^% headerStr,
    ArrayList^% resultArr
)

Parameters

category
Type: System..::.String
The provider category as specified in the specification file
ti
Type: OfficeClip.BusinessLayer.Account..::.transactionInfo
The transaction information object
urlStr
Type: System..::.String%
The url string to be returned
headerStr
Type: System..::.String%
The header string
resultArr
Type: System.Collections..::.ArrayList%
The result array

See Also

SubscriptionDB Class
OfficeClip.DBLayer.Account Namespace


GetTrialPeriodUsersCount Method

[image]

OfficeClip API Documentation
SubscriptionDB..::.GetTrialPeriodUsersCount Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the number of users allowed in the trial period based on the information provided in the accounting.xml resource file

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetTrialPeriodUsersCount()
Visual Basic (Declaration)
Public Function GetTrialPeriodUsersCount As Integer
Visual C++
public:
int GetTrialPeriodUsersCount()

Return Value

The number of users

See Also

SubscriptionDB Class
OfficeClip.DBLayer.Account Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
SubscriptionDB..::.InitTransaction Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

SubscriptionDB Class
SubscriptionDB Members
OfficeClip.DBLayer.Account Namespace


PayNow Method

[image] [image]

OfficeClip API Documentation
SubscriptionDB..::.PayNow Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PayNow(transactionInfo, String%, ConfigureInfo) | Creates a credit card or a purchase order transaction based on the information provided in the trasactionInfo object.
Public method | PayNow(transactionInfo, Boolean, String%, ConfigureInfo) | Creates a credit card or a purchase order transaction based on the information provided in the trasactionInfo object.

See Also

SubscriptionDB Class
SubscriptionDB Members
OfficeClip.DBLayer.Account Namespace


PayNow Method (transactionInfo, String, ConfigureInfo)

[image]

OfficeClip API Documentation
SubscriptionDB..::.PayNow Method (transactionInfo, String%, ConfigureInfo)
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates a credit card or a purchase order transaction based on the information provided in the trasactionInfo object.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int PayNow(
    transactionInfo ti,
    ref string detailError,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function PayNow ( _
    ti As transactionInfo, _
    ByRef detailError As String, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int PayNow(
    transactionInfo^ ti,
    String^% detailError,
    ConfigureInfo^ session
)

Parameters

ti
Type: OfficeClip.BusinessLayer.Account..::.transactionInfo
The information related to the credit card or the purchase order and the Amount.
detailError
Type: System..::.String%
The detail error returned by the service provider.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

0 when transaction is successfully processed. -1 in case of a general error -2 in case there is an error processing the credit card transaction.

See Also

SubscriptionDB Class
PayNow Overload
OfficeClip.DBLayer.Account Namespace


PayNow Method (transactionInfo, Boolean, String, ConfigureInfo)

[image]

OfficeClip API Documentation
SubscriptionDB..::.PayNow Method (transactionInfo, Boolean, String%, ConfigureInfo)
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates a credit card or a purchase order transaction based on the information provided in the trasactionInfo object.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int PayNow(
    transactionInfo ti,
    bool sendNoticeAndConfirmation,
    ref string detailError,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function PayNow ( _
    ti As transactionInfo, _
    sendNoticeAndConfirmation As Boolean, _
    ByRef detailError As String, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int PayNow(
    transactionInfo^ ti,
    bool sendNoticeAndConfirmation,
    String^% detailError,
    ConfigureInfo^ session
)

Parameters

ti
Type: OfficeClip.BusinessLayer.Account..::.transactionInfo
The information related to the credit card or the purchase order and the Amount.
sendNoticeAndConfirmation
Type: System..::.Boolean
Flag to indicate whether an email notification should be sent or not.
detailError
Type: System..::.String%
The detailed error returned by the service provider
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

0 when transaction is successfully processed. -1 in case of a general error -2 in case there is an error processing the credit card transaction.

See Also

SubscriptionDB Class
PayNow Overload
OfficeClip.DBLayer.Account Namespace


SendSaleConfirmationCC Method

[image]

OfficeClip API Documentation
SubscriptionDB..::.SendSaleConfirmationCC Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends a Credit Card sale notification

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SendSaleConfirmationCC(
    transactionInfo ti,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Sub SendSaleConfirmationCC ( _
    ti As transactionInfo, _
    session As ConfigureInfo _
)
Visual C++
public:
void SendSaleConfirmationCC(
    transactionInfo^ ti,
    ConfigureInfo^ session
)

Parameters

ti
Type: OfficeClip.BusinessLayer.Account..::.transactionInfo
The information related to the credit card and the Amount.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

See Also

SubscriptionDB Class
OfficeClip.DBLayer.Account Namespace


SendSaleConfirmationPO Method

[image]

OfficeClip API Documentation
SubscriptionDB..::.SendSaleConfirmationPO Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends a Purchase order sale notification

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SendSaleConfirmationPO(
    transactionInfo ti,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Sub SendSaleConfirmationPO ( _
    ti As transactionInfo, _
    session As ConfigureInfo _
)
Visual C++
public:
void SendSaleConfirmationPO(
    transactionInfo^ ti,
    ConfigureInfo^ session
)

Parameters

ti
Type: OfficeClip.BusinessLayer.Account..::.transactionInfo
The information related to the purchase order and the Amount.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

See Also

SubscriptionDB Class
OfficeClip.DBLayer.Account Namespace


SendSaleNotice Method

[image]

OfficeClip API Documentation
SubscriptionDB..::.SendSaleNotice Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends a sale notification

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SendSaleNotice(
    transactionInfo ti,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Sub SendSaleNotice ( _
    ti As transactionInfo, _
    session As ConfigureInfo _
)
Visual C++
public:
void SendSaleNotice(
    transactionInfo^ ti,
    ConfigureInfo^ session
)

Parameters

ti
Type: OfficeClip.BusinessLayer.Account..::.transactionInfo
The information related to The user session the credit card or the purchase order. and the Amount.
session
Type: OfficeClip.Utils..::.ConfigureInfo

See Also

SubscriptionDB Class
OfficeClip.DBLayer.Account Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
SubscriptionDB..::.SetSPCommand Method
SubscriptionDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

SubscriptionDB Class
SubscriptionDB Members
OfficeClip.DBLayer.Account Namespace


UserDB Class

[image]

OfficeClip API Documentation
UserDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of user related functions.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class UserDB : OfficeClipDB
Visual Basic (Declaration)
Public Class UserDB _
    Inherits OfficeClipDB
Visual C++
public ref class UserDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Account..::.UserDB

See Also

UserDB Members
OfficeClip.DBLayer.Account Namespace


UserDB Members

[image] [image]

OfficeClip API Documentation
UserDB Members
UserDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The UserDB type exposes the following members.

Constructors

 | Name | Description
Public method | UserDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | AdjustUserCurrencyDefault |
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Public method | ExportCsv | Get the CSV formatted text for the selected fields from the users's details corresponding to a particular group.
Public method | ExportVCard | Gets the all the information of all the members of a particular group in a VCard format.
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllUsers | Gets all the users from the OfficeClip System.
Public method | GetAlphabetLinks | Returns the first alphabets of the first name or the last name depending on the value of orderBy argument for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMembersList | Returns all the user from a system who can be seen by a particular user.
Public method | GetNonGroupMemberList | This method returns a set of all the members of the OfficeClip account who are not a member of a given group.
Public method | GetNonMembersList | Returns all the user who can be seen by a particular user, and does not belong to a particular group.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPassword | Gets the password string for a particular user, this string is used to compare the user's password to allow user entry to the system. The string being compared to and the password value obtained from the database both are in one way encrypted format.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserIdFromEmail | Get the user's id from the given the email Address in a particular group.
Public method | GetUsersByGroup | Gets all the users for a particular group sorted by a given sort condition.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetPassword | Resets user password and the mail is sent using the name and email Address of the currently logged in user.
Public method | ResetPasswordInDatabase | Resets the password in the database and returns the password in cleartext as the output. This method is required because it will encourage reuse of this part for both reset password and Reinvite members
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SearchUsers | Gets the information of all the users for a particular user matching the search criteria.
Public method | SetAdminStatus | Grants or revokes admin privileges to a set of users in a particular group.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetSuccessfulLoginDate | Sets a Timestamp in the database which marking the the user's login date and time for the user who is currently logging in.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdatePassword | Encrypts the password for a particular user using the MD5 algorithm and saves the password in the database.
Public method | UpdatePin | Encrypts the user pin number (used for mobile access) for a particular user using the MD5 algorithm and saves the password in the database.
Public method | UpdateUserCurrency |

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


UserDB Constructor

[image]

OfficeClip API Documentation
UserDB Constructor
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public UserDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserDB()

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


UserDB Methods

[image] [image]

OfficeClip API Documentation
UserDB Methods
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

The UserDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | AdjustUserCurrencyDefault |
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Public method | ExportCsv | Get the CSV formatted text for the selected fields from the users's details corresponding to a particular group.
Public method | ExportVCard | Gets the all the information of all the members of a particular group in a VCard format.
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllUsers | Gets all the users from the OfficeClip System.
Public method | GetAlphabetLinks | Returns the first alphabets of the first name or the last name depending on the value of orderBy argument for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMembersList | Returns all the user from a system who can be seen by a particular user.
Public method | GetNonGroupMemberList | This method returns a set of all the members of the OfficeClip account who are not a member of a given group.
Public method | GetNonMembersList | Returns all the user who can be seen by a particular user, and does not belong to a particular group.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPassword | Gets the password string for a particular user, this string is used to compare the user's password to allow user entry to the system. The string being compared to and the password value obtained from the database both are in one way encrypted format.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserIdFromEmail | Get the user's id from the given the email Address in a particular group.
Public method | GetUsersByGroup | Gets all the users for a particular group sorted by a given sort condition.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetPassword | Resets user password and the mail is sent using the name and email Address of the currently logged in user.
Public method | ResetPasswordInDatabase | Resets the password in the database and returns the password in cleartext as the output. This method is required because it will encourage reuse of this part for both reset password and Reinvite members
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SearchUsers | Gets the information of all the users for a particular user matching the search criteria.
Public method | SetAdminStatus | Grants or revokes admin privileges to a set of users in a particular group.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetSuccessfulLoginDate | Sets a Timestamp in the database which marking the the user's login date and time for the user who is currently logging in.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdatePassword | Encrypts the password for a particular user using the MD5 algorithm and saves the password in the database.
Public method | UpdatePin | Encrypts the user pin number (used for mobile access) for a particular user using the MD5 algorithm and saves the password in the database.
Public method | UpdateUserCurrency |

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
UserDB..::.AddOutputParameter Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

UserDB Class
UserDB Members
OfficeClip.DBLayer.Account Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
UserDB..::.AddParameter Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

UserDB Class
UserDB Members
OfficeClip.DBLayer.Account Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
UserDB..::.AddParameters Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

UserDB Class
UserDB Members
OfficeClip.DBLayer.Account Namespace


AdjustUserCurrencyDefault Method

[image]

OfficeClip API Documentation
UserDB..::.AdjustUserCurrencyDefault Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void AdjustUserCurrencyDefault(
    int groupId
)
Visual Basic (Declaration)
Public Sub AdjustUserCurrencyDefault ( _
    groupId As Integer _
)
Visual C++
public:
void AdjustUserCurrencyDefault(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
UserDB..::.ExecuteNonQuery Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

UserDB Class
UserDB Members
OfficeClip.DBLayer.Account Namespace


ExportCsv Method

[image]

OfficeClip API Documentation
UserDB..::.ExportCsv Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the CSV formatted text for the selected fields from the users's details corresponding to a particular group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string ExportCsv(
    int groupId,
    ArrayList fields,
    bool isExternal
)
Visual Basic (Declaration)
Public Function ExportCsv ( _
    groupId As Integer, _
    fields As ArrayList, _
    isExternal As Boolean _
) As String
Visual C++
public:
String^ ExportCsv(
    int groupId,
    ArrayList^ fields,
    bool isExternal
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.
fields
Type: System.Collections..::.ArrayList
The list of all the fields from the user details for which the data should be returned in a comma separated format.
isExternal
Type: System..::.Boolean
Is the user an extranet user

Return Value

The comman separated values of the users details each line per user.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


ExportVCard Method

[image]

OfficeClip API Documentation
UserDB..::.ExportVCard Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the all the information of all the members of a particular group in a VCard format.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string ExportVCard(
    int groupId
)
Visual Basic (Declaration)
Public Function ExportVCard ( _
    groupId As Integer _
) As String
Visual C++
public:
String^ ExportVCard(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique identifier for the group.

Return Value

Text string containing all the information of the members of a currently selected group in VCard format.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


GetAllUsers Method

[image]

OfficeClip API Documentation
UserDB..::.GetAllUsers Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the users from the OfficeClip System.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<UserInfo> GetAllUsers(
    bool isExternal,
    bool isActive
)
Visual Basic (Declaration)
Public Function GetAllUsers ( _
    isExternal As Boolean, _
    isActive As Boolean _
) As List(Of UserInfo)
Visual C++
public:
List<UserInfo^>^ GetAllUsers(
    bool isExternal,
    bool isActive
)

Parameters

isExternal
Type: System..::.Boolean
true if the user is an extranet user
isActive
Type: System..::.Boolean
Is active users required to be returned

Return Value

An array of userinfo object

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


GetAlphabetLinks Method

[image]

OfficeClip API Documentation
UserDB..::.GetAlphabetLinks Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the first alphabets of the first name or the last name depending on the value of orderBy argument for a particular group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<AlphabetListItem> GetAlphabetLinks(
    SortByName orderBy,
    int groupId
)
Visual Basic (Declaration)
Public Function GetAlphabetLinks ( _
    orderBy As SortByName, _
    groupId As Integer _
) As List(Of AlphabetListItem)
Visual C++
public:
List<AlphabetListItem^>^ GetAlphabetLinks(
    SortByName orderBy,
    int groupId
)

Parameters

orderBy
Type: OfficeClip.Utils..::.SortByName
Enumerated value determining whether to sort the user list by the first character of the first name or last name. SortByName
groupId
Type: System..::.Int32
Id of the group.

Return Value

DataSet containing the list of alphabets for which there are users in the particular group. This DataSet consists of a single DataTable with the following columns.
  • Alphabet (System.String)Single character alphabet signifying that there are users in the list who have either their first name or last name starting with it.
  • isPresent (System.Boolean)Flag indicating whether the users corresponding to that particular alphabet are present or not.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


GetMembersList Method

[image]

OfficeClip API Documentation
UserDB..::.GetMembersList Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns all the user from a system who can be seen by a particular user.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<UserInfo> GetMembersList(
    int userId
)
Visual Basic (Declaration)
Public Function GetMembersList ( _
    userId As Integer _
) As List(Of UserInfo)
Visual C++
public:
List<UserInfo^>^ GetMembersList(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.

Return Value

DataTable containing the id, name and email Address of all the users who can be seen by the currently logged in user. This DataTable consists of the following two columns.
  • userId (System.Int32)Id of the user.
  • firstName (System.String)first name of the user.
  • lastName (System.String)last name of the user.
  • emailAddress (System.String)Email Address of the user.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


GetNonGroupMemberList Method

[image]

OfficeClip API Documentation
UserDB..::.GetNonGroupMemberList Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

This method returns a set of all the members of the OfficeClip account who are not a member of a given group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<UserInfo> GetNonGroupMemberList(
    int groupId
)
Visual Basic (Declaration)
Public Function GetNonGroupMemberList ( _
    groupId As Integer _
) As List(Of UserInfo)
Visual C++
public:
List<UserInfo^>^ GetNonGroupMemberList(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The id of the group whose non-members have to be obtained.

Return Value

Returns a DataSet of all the registered non group members for a group. This DataSet Consists of a single DataTable with the following columns.
  • firstName (System.String)First Name of the user.
  • lastName (System.String)Last Name of the user.
  • emailAddress (System.String)Email Address of the user.
  • UserId (System.Int32)Id of the user.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


GetNonMembersList Method

[image]

OfficeClip API Documentation
UserDB..::.GetNonMembersList Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns all the user who can be seen by a particular user, and does not belong to a particular group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<UserInfo> GetNonMembersList(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetNonMembersList ( _
    userId As Integer, _
    groupId As Integer _
) As List(Of UserInfo)
Visual C++
public:
List<UserInfo^>^ GetNonMembersList(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
Id of a particular user.
groupId
Type: System..::.Int32
Id of a particular group.

Return Value

DataTable containing the id, name and email Address of the respective users. This DataTable consists of the following two columns.
  • id (System.Int32)Id of the user.
  • nameAndEMail (System.String)Name and email Address of the user.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


GetPassword Method

[image]

OfficeClip API Documentation
UserDB..::.GetPassword Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the password string for a particular user, this string is used to compare the user's password to allow user entry to the system. The string being compared to and the password value obtained from the database both are in one way encrypted format.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetPassword(
    int userId
)
Visual Basic (Declaration)
Public Function GetPassword ( _
    userId As Integer _
) As String
Visual C++
public:
String^ GetPassword(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id for the user.

Return Value

The encrypted user password string.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


GetUserIdFromEmail Method

[image]

OfficeClip API Documentation
UserDB..::.GetUserIdFromEmail Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the user's id from the given the email Address in a particular group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetUserIdFromEmail(
    string emailAddress,
    bool isExternal
)
Visual Basic (Declaration)
Public Function GetUserIdFromEmail ( _
    emailAddress As String, _
    isExternal As Boolean _
) As Integer
Visual C++
public:
int GetUserIdFromEmail(
    String^ emailAddress,
    bool isExternal
)

Parameters

emailAddress
Type: System..::.String
The email Address of the user for whom the id is to be obtained.
isExternal
Type: System..::.Boolean
Is the user an extranet user

Return Value

Id of the user if successful, -1 in case of an error.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


GetUsersByGroup Method

[image]

OfficeClip API Documentation
UserDB..::.GetUsersByGroup Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the users for a particular group sorted by a given sort condition.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<UserInfo> GetUsersByGroup(
    SortByName orderBy,
    int groupId,
    UserType userType
)
Visual Basic (Declaration)
Public Function GetUsersByGroup ( _
    orderBy As SortByName, _
    groupId As Integer, _
    userType As UserType _
) As List(Of UserInfo)
Visual C++
public:
List<UserInfo^>^ GetUsersByGroup(
    SortByName orderBy,
    int groupId,
    UserType userType
)

Parameters

orderBy
Type: OfficeClip.Utils..::.SortByName
Enumerated value determining whether to sort the user list by the first character of the first name or last name. SortByName
groupId
Type: System..::.Int32
Id of the group.
userType
Type: OfficeClip.Utils..::.UserType

Return Value

DataSet containing information related to the users for the currently selected group. This DataSet consists of a single DataTable with the following columns.
  • groupType (System.String)Flag (P,G,D,O) indicating the type of the group.
  • UserId (System.Int32)Id of the user.
  • IsAdmin (System.String)Flag (Y/N) indicating whether this user is the admin this particular group.
  • userDetailId (System.Int32)userDetailId of the user.
  • IsRegistered (System.String)Flag (Y/N) indicating whether the user is registered in this particular group or not.
  • emailAddress (System.String)Email Address of the user.
  • name (System.String)Name of the user (first name and last name concatenated by a blank space).
  • nameAndEmail (System.String)Name and email Address of the user.
  • firstAlphabet (System.String)First alphabet of either the first name or the last name depending upon the sort criteria mentioned above.
  • location (System.String)location of the user.
  • WorkTitle (System.String)Work title of the user.
  • PreferredPhoneNumber (System.String)One of the phone numbers of work phone primary, work phone secondary, other phone, home phone or the cell phone based on the preference set by the user as the most preferred number to contacted at. If the user has not set the preference, then the primary work phone nuber is returned.
  • workPhonePrimary (System.String)Primary work phone number.
  • workPhoneSecondary (System.String)Secondary work phone number.
  • otherPhone (System.String)Other phone number.
  • cellPhone (System.String)Cell or mobile phone number of the user.
  • faxNumber (System.String)Fax number of the user.
  • message (System.String)If the user has left a notice or a message to the group members.
  • LastUpdatedTimestamp (System.DateTime)Date and time when the user's information was last updated.
  • joiningTimestamp (System.DateTime)Date and Time when this user joined this particular group.
  • InvitationStatus (System.String)Flag (A,R,P,N) indicating whether the user has accepted (A) the invitation or rejected (R) the invitation, or the invitation is pending (P) or it is a record corresponding to a address book (N) which none of the above.
  • organization (System.String)organization to which the user belongs.
  • BirthDate (System.DateTime)Date of the birth of the user.
  • waline1 (System.String)First line of the work Address of the user.
  • waline2 (System.String)Second line of the work Address of the user.
  • wacity (System.String)City of the work Address of the user.
  • wastate (System.String)State of the work Address of the user.
  • wazip (System.String)Zip code of the work Address of the user.
  • wacountry (System.String)Country of the work Address of the user.
  • haline1 (System.String)First line of the home Address of the user.
  • haline2 (System.String)Second line of the home Address of the user.
  • hacity (System.String)City of the home Address of the user.
  • hastate (System.String)State of the home Address of the user.
  • hazip (System.String)Zip code of the home Address of the user.
  • hacountry (System.String)Country of the home Address of the user.
The type of the user (i.e. member or Extranet users)

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
UserDB..::.InitTransaction Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

UserDB Class
UserDB Members
OfficeClip.DBLayer.Account Namespace


ResetPassword Method

[image]

OfficeClip API Documentation
UserDB..::.ResetPassword Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Resets user password and the mail is sent using the name and email Address of the currently logged in user.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void ResetPassword(
    int userId,
    string pw,
    bool isEmail,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Sub ResetPassword ( _
    userId As Integer, _
    pw As String, _
    isEmail As Boolean, _
    session As ConfigureInfo _
)
Visual C++
public:
void ResetPassword(
    int userId,
    String^ pw,
    bool isEmail,
    ConfigureInfo^ session
)

Parameters

userId
Type: System..::.Int32
The user id for whose the password has to be reset.
pw
Type: System..::.String
The password to reset, if empty, a system selected password is emailed
isEmail
Type: System..::.Boolean
true if the password is to be sent via email
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


ResetPasswordInDatabase Method

[image]

OfficeClip API Documentation
UserDB..::.ResetPasswordInDatabase Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Resets the password in the database and returns the password in cleartext as the output. This method is required because it will encourage reuse of this part for both reset password and Reinvite members

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string ResetPasswordInDatabase(
    int groupId,
    int userId,
    string pw
)
Visual Basic (Declaration)
Public Function ResetPasswordInDatabase ( _
    groupId As Integer, _
    userId As Integer, _
    pw As String _
) As String
Visual C++
public:
String^ ResetPasswordInDatabase(
    int groupId,
    int userId,
    String^ pw
)

Parameters

groupId
Type: System..::.Int32
The unique id of the organization
userId
Type: System..::.Int32
the user id of the user
pw
Type: System..::.String
The password to be explicity set

Return Value

The new password in cleartext

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


SearchUsers Method

[image]

OfficeClip API Documentation
UserDB..::.SearchUsers Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the information of all the users for a particular user matching the search criteria.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable SearchUsers(
    int userId,
    string searchText,
    string searchBy
)
Visual Basic (Declaration)
Public Function SearchUsers ( _
    userId As Integer, _
    searchText As String, _
    searchBy As String _
) As DataTable
Visual C++
public:
DataTable^ SearchUsers(
    int userId,
    String^ searchText,
    String^ searchBy
)

Parameters

userId
Type: System..::.Int32
The unique user id.
searchText
Type: System..::.String
The text string to search for.
searchBy
Type: System..::.String
This parameter can take the following values indicating which field to use for while searching.
  • firstname
  • lastname
  • emailaddress
  • initials
  • all

Return Value

DataSet containing the information of the users matching the search criteria. This DataSet consists of a single DataTable with the following columns.
  • userDetailId (System.Int32)userDetailId of the user.
  • UserId (System.Int32)Id of the user.
  • UserName (System.String)Name of the user (first name and last name concatenated by a blank space).
  • emailAddress (System.String)Email Address of the user.
  • PreferredPhoneNumber (System.String)One of the phone numbers of work phone primary, work phone secondary, other phone, home phone or the cell phone based on the preference set by the user as the most preferred number to contacted at. If the user has not set the preference, then the primary work phone nuber is returned.
  • workPhonePrimary (System.String)Primary work phone number.
  • GroupId (System.Int32)Id of the group to which the user matching he search criteria belongs.
  • groupType (System.String)Flag (P,G,D,O) indicating the type of the group.
  • groupName (System.String)Name of the group.
  • groupIE (System.String)Flag (I,E) indicating whether the user matching the search criteria is internal or external to the OfficeClip system i.e. whether it is address book entry or a member.
  • IsRegistered (System.String)Flag (Y/N) indicating whether the user is registered in this particular group or not.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


SetAdminStatus Method

[image]

OfficeClip API Documentation
UserDB..::.SetAdminStatus Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Grants or revokes admin privileges to a set of users in a particular group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetAdminStatus(
    bool isGrant,
    string userIds,
    ConfigureInfo session,
    bool isSendEmail
)
Visual Basic (Declaration)
Public Sub SetAdminStatus ( _
    isGrant As Boolean, _
    userIds As String, _
    session As ConfigureInfo, _
    isSendEmail As Boolean _
)
Visual C++
public:
void SetAdminStatus(
    bool isGrant,
    String^ userIds,
    ConfigureInfo^ session,
    bool isSendEmail
)

Parameters

isGrant
Type: System..::.Boolean
Flag (True/False) indicating whether the admin privilege should be granted or revoked.
userIds
Type: System..::.String
A comma separated list of user ids
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session
isSendEmail
Type: System..::.Boolean
Is the emails required to be sent

Remarks

Please make sure that the userDetailIds are the ones corresponding to the registered record.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
UserDB..::.SetSPCommand Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

UserDB Class
UserDB Members
OfficeClip.DBLayer.Account Namespace


SetSuccessfulLoginDate Method

[image]

OfficeClip API Documentation
UserDB..::.SetSuccessfulLoginDate Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets a Timestamp in the database which marking the the user's login date and time for the user who is currently logging in.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetSuccessfulLoginDate(
    int currentUserId
)
Visual Basic (Declaration)
Public Sub SetSuccessfulLoginDate ( _
    currentUserId As Integer _
)
Visual C++
public:
void SetSuccessfulLoginDate(
    int currentUserId
)

Parameters

currentUserId
Type: System..::.Int32

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


UpdatePassword Method

[image]

OfficeClip API Documentation
UserDB..::.UpdatePassword Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Encrypts the password for a particular user using the MD5 algorithm and saves the password in the database.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdatePassword(
    int groupId,
    int userId,
    string password
)
Visual Basic (Declaration)
Public Sub UpdatePassword ( _
    groupId As Integer, _
    userId As Integer, _
    password As String _
)
Visual C++
public:
void UpdatePassword(
    int groupId,
    int userId,
    String^ password
)

Parameters

groupId
Type: System..::.Int32
The unique id of the organization
userId
Type: System..::.Int32
The unique id of the user.
password
Type: System..::.String
The password in cleartext.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


UpdatePin Method

[image]

OfficeClip API Documentation
UserDB..::.UpdatePin Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Encrypts the user pin number (used for mobile access) for a particular user using the MD5 algorithm and saves the password in the database.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdatePin(
    int groupId,
    int userId,
    string pin
)
Visual Basic (Declaration)
Public Sub UpdatePin ( _
    groupId As Integer, _
    userId As Integer, _
    pin As String _
)
Visual C++
public:
void UpdatePin(
    int groupId,
    int userId,
    String^ pin
)

Parameters

groupId
Type: System..::.Int32
The unique id of the organization
userId
Type: System..::.Int32
The unique id for the user.
pin
Type: System..::.String
The pin in cleartext.

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


UpdateUserCurrency Method

[image]

OfficeClip API Documentation
UserDB..::.UpdateUserCurrency Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateUserCurrency(
    int groupId,
    int userId,
    string code
)
Visual Basic (Declaration)
Public Sub UpdateUserCurrency ( _
    groupId As Integer, _
    userId As Integer, _
    code As String _
)
Visual C++
public:
void UpdateUserCurrency(
    int groupId,
    int userId,
    String^ code
)

Parameters

groupId
Type: System..::.Int32
userId
Type: System..::.Int32
code
Type: System..::.String

See Also

UserDB Class
OfficeClip.DBLayer.Account Namespace


UserInfoDB Class

[image]

OfficeClip API Documentation
UserInfoDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of functions to get and upate the user's data..

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class UserInfoDB : OfficeClipDB
Visual Basic (Declaration)
Public Class UserInfoDB _
    Inherits OfficeClipDB
Visual C++
public ref class UserInfoDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Account..::.UserInfoDB

See Also

UserInfoDB Members
OfficeClip.DBLayer.Account Namespace


UserInfoDB Members

[image] [image]

OfficeClip API Documentation
UserInfoDB Members
UserInfoDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The UserInfoDB type exposes the following members.

Constructors

 | Name | Description
Public method | UserInfoDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserInfo | Overloaded.
Public method | GetUserInfoByUserListSP | Gets the user information from the user detail list.
Public method | GetUserPayrollInfo | Gets the user payroll information
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetUserInfo | Updates all the user details i.e. both the users table and the userdetails table corresponding to a particular group.
Public method | SetUserPayrollInfo | Sets the user payroll information
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyUserLogin |

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

UserInfoDB Class
OfficeClip.DBLayer.Account Namespace


UserInfoDB Constructor

[image]

OfficeClip API Documentation
UserInfoDB Constructor
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public UserInfoDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserInfoDB()

See Also

UserInfoDB Class
OfficeClip.DBLayer.Account Namespace


UserInfoDB Methods

[image] [image]

OfficeClip API Documentation
UserInfoDB Methods
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

The UserInfoDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserInfo | Overloaded.
Public method | GetUserInfoByUserListSP | Gets the user information from the user detail list.
Public method | GetUserPayrollInfo | Gets the user payroll information
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetUserInfo | Updates all the user details i.e. both the users table and the userdetails table corresponding to a particular group.
Public method | SetUserPayrollInfo | Sets the user payroll information
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerifyUserLogin |

See Also

UserInfoDB Class
OfficeClip.DBLayer.Account Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
UserInfoDB..::.AddOutputParameter Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

UserInfoDB Class
UserInfoDB Members
OfficeClip.DBLayer.Account Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
UserInfoDB..::.AddParameter Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

UserInfoDB Class
UserInfoDB Members
OfficeClip.DBLayer.Account Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
UserInfoDB..::.AddParameters Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

UserInfoDB Class
UserInfoDB Members
OfficeClip.DBLayer.Account Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
UserInfoDB..::.ExecuteNonQuery Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

UserInfoDB Class
UserInfoDB Members
OfficeClip.DBLayer.Account Namespace


GetUserInfo Method

[image] [image]

OfficeClip API Documentation
UserInfoDB..::.GetUserInfo Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetUserInfo(Int32) | Get the user information
Public method | GetUserInfo(Int32, Int32) | Get the all the data corresponding to the users and userdetails from the database for a particular user in a particular group. This could be corresponding to an unregistered user also.

See Also

UserInfoDB Class
UserInfoDB Members
OfficeClip.DBLayer.Account Namespace


GetUserInfo Method (Int32)

[image]

OfficeClip API Documentation
UserInfoDB..::.GetUserInfo Method (Int32)
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the user information

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public UserInfo GetUserInfo(
    int userId
)
Visual Basic (Declaration)
Public Function GetUserInfo ( _
    userId As Integer _
) As UserInfo
Visual C++
public:
UserInfo^ GetUserInfo(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

See Also

UserInfoDB Class
GetUserInfo Overload
OfficeClip.DBLayer.Account Namespace


GetUserInfo Method (Int32, Int32)

[image]

OfficeClip API Documentation
UserInfoDB..::.GetUserInfo Method (Int32, Int32)
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the all the data corresponding to the users and userdetails from the database for a particular user in a particular group. This could be corresponding to an unregistered user also.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public UserInfo GetUserInfo(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetUserInfo ( _
    userId As Integer, _
    groupId As Integer _
) As UserInfo
Visual C++
public:
UserInfo^ GetUserInfo(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
Id of the user.
groupId
Type: System..::.Int32
Id of the group.

Return Value

Instance of the UserInfo object containing all the information related to a particular user. UserInfo

See Also

UserInfoDB Class
GetUserInfo Overload
OfficeClip.DBLayer.Account Namespace


GetUserInfoByUserListSP Method

[image]

OfficeClip API Documentation
UserInfoDB..::.GetUserInfoByUserListSP Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the user information from the user detail list.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SqlDataReader GetUserInfoByUserListSP(
    string userList
)
Visual Basic (Declaration)
Public Function GetUserInfoByUserListSP ( _
    userList As String _
) As SqlDataReader
Visual C++
public:
SqlDataReader^ GetUserInfoByUserListSP(
    String^ userList
)

Parameters

userList
Type: System..::.String
A comma separated list of user ids

Return Value

SqlDataReader containing information related to a user. This SqlDataReader consists of the following columns.
  • UserId (System.Int32)Id of the user.
  • name (System.String)Name of the user.
  • emailAddress (System.String)Email Address of the user.
  • userId (System.Int32)userDetailId of the user.

Remarks

Make sure to Close the SqlDataReader after the use otherwise it will leave and connection open (till garbage collector releases the Data Reader). If not closed explicitly, the .Net framework might hang and slow down because of the number of open connections Limit might be reached.

See Also

UserInfoDB Class
OfficeClip.DBLayer.Account Namespace


GetUserPayrollInfo Method

[image]

OfficeClip API Documentation
UserInfoDB..::.GetUserPayrollInfo Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the user payroll information

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public UserPayrollInfo GetUserPayrollInfo(
    int userId
)
Visual Basic (Declaration)
Public Function GetUserPayrollInfo ( _
    userId As Integer _
) As UserPayrollInfo
Visual C++
public:
UserPayrollInfo^ GetUserPayrollInfo(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user

Return Value

The user payroll information

See Also

UserInfoDB Class
OfficeClip.DBLayer.Account Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
UserInfoDB..::.InitTransaction Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

UserInfoDB Class
UserInfoDB Members
OfficeClip.DBLayer.Account Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
UserInfoDB..::.SetSPCommand Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

UserInfoDB Class
UserInfoDB Members
OfficeClip.DBLayer.Account Namespace


SetUserInfo Method

[image]

OfficeClip API Documentation
UserInfoDB..::.SetUserInfo Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the user details i.e. both the users table and the userdetails table corresponding to a particular group.

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetUserInfo(
    int loggedInUserId,
    int userId,
    int groupId,
    UserInfo uf,
    string docIdList,
    string remDocIdList,
    ref DateTime updateTime,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function SetUserInfo ( _
    loggedInUserId As Integer, _
    userId As Integer, _
    groupId As Integer, _
    uf As UserInfo, _
    docIdList As String, _
    remDocIdList As String, _
    ByRef updateTime As DateTime, _
    isCurrentUserAdmin As Boolean _
) As Integer
Visual C++
public:
int SetUserInfo(
    int loggedInUserId,
    int userId,
    int groupId,
    UserInfo^ uf,
    String^ docIdList,
    String^ remDocIdList,
    DateTime% updateTime,
    bool isCurrentUserAdmin
)

Parameters

loggedInUserId
Type: System..::.Int32
The user who is currently logged in.
userId
Type: System..::.Int32
The incoming user id of the user.
groupId
Type: System..::.Int32
The group id to determine which userdetail record has to be updated.
uf
Type: OfficeClip.BusinessLayer.Account..::.UserInfo
The incoming business layer object which contains all the user/userdetail data. UserInfo
docIdList
Type: System..::.String
The documentid list of the photos if any to be added.
remDocIdList
Type: System..::.String
The documentid list of the photos if any to be removed.
updateTime
Type: System..::.DateTime%
The update time
isCurrentUserAdmin
Type: System..::.Boolean
Is the logged in user an administrator

Return Value

0 if successful, -1 in case of a general error, -2 when the email Address being updated is already used by another user.

Remarks

OfficeClip allows to change the email Address (which happens to be the primary login id into the OfficeClip system.). Hence this method checks whether if the the email Address being updated is already taken up by another user. If so, -2 is returned as error message.

See Also

UserInfoDB Class
OfficeClip.DBLayer.Account Namespace


SetUserPayrollInfo Method

[image]

OfficeClip API Documentation
UserInfoDB..::.SetUserPayrollInfo Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the user payroll information

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetUserPayrollInfo(
    int createdUserId,
    int userId,
    UserPayrollInfo upi
)
Visual Basic (Declaration)
Public Function SetUserPayrollInfo ( _
    createdUserId As Integer, _
    userId As Integer, _
    upi As UserPayrollInfo _
) As Integer
Visual C++
public:
int SetUserPayrollInfo(
    int createdUserId,
    int userId,
    UserPayrollInfo^ upi
)

Parameters

createdUserId
Type: System..::.Int32
the unique id of the user who created the payroll information
userId
Type: System..::.Int32
The current user id
upi
Type: OfficeClip.BusinessLayer.Account..::.UserPayrollInfo
The user payroll information object

Return Value

0 if successful, -1 if error

See Also

UserInfoDB Class
OfficeClip.DBLayer.Account Namespace


VerifyUserLogin Method

[image]

OfficeClip API Documentation
UserInfoDB..::.VerifyUserLogin Method
UserInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Account
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool VerifyUserLogin(
    string loginName
)
Visual Basic (Declaration)
Public Function VerifyUserLogin ( _
    loginName As String _
) As Boolean
Visual C++
public:
bool VerifyUserLogin(
    String^ loginName
)

Parameters

loginName
Type: System..::.String

See Also

UserInfoDB Class
OfficeClip.DBLayer.Account Namespace


OfficeClip.DBLayer.Desktop Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Desktop Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip desktop

Classes

 | Class | Description
Public class | AddressBookDB | Provides a set of Group functionality related functions.
Public class | CalendarDB | Provides a set of Calendar application related functions.
Public class | DocumentDB | Summary description for DocumentDB
Public class | DocumentError | Class to hold the document information.
Public class | DocumentViewDB | Summary description for DocumentDB
Public class | EmailDB | Provides a set of Email application related functions.
Public class | NoticeDB | Provides a set of Notice application related functions.
Public class | ResourcesDB | Provides a set of Resource Reservation related functions.
Public class | TaskDB | Provides a set of Tasks application related functions.


AddressBookDB Class

[image]

OfficeClip API Documentation
AddressBookDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Group functionality related functions.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class AddressBookDB : OfficeClipDB
Visual Basic (Declaration)
Public Class AddressBookDB _
    Inherits OfficeClipDB
Visual C++
public ref class AddressBookDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Desktop..::.AddressBookDB

See Also

AddressBookDB Members
OfficeClip.DBLayer.Desktop Namespace


AddressBookDB Members

[image] [image]

OfficeClip API Documentation
AddressBookDB Members
AddressBookDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AddressBookDB type exposes the following members.

Constructors

 | Name | Description
Public method | AddressBookDB | Default Constructor

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | CreateAddressBook | Creates a new address book into the database for the currently logged in user. This method is used to create either a private address book or the address book shared by other group members.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAddressBook | Gets all the Address Books for the currently logged in user. This method returns both the private address books for the user and also the shared address books belonging to the currently selected group.
Public method | GetAddressBookInfo | Determines whether a particular Address Book list is a shared address book or not.
Public method | GetAddresses | Get the address information
Public method | GetAlphabetLinks | Returns the first alphabets of the first name or the last name depending on the value of orderBy argument for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertAddress | InsertAddress
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAddress | Removes address
Public method | RemoveAddressBook | Removes a address book identified by GroupId.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SearchUsers | Gets the information of all the users for a particular user matching the search criteria.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAddress | Updates address
Public method | UpdateAddressBookInfo |

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


AddressBookDB Constructor

[image]

OfficeClip API Documentation
AddressBookDB Constructor
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Default Constructor

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public AddressBookDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AddressBookDB()

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


AddressBookDB Methods

[image] [image]

OfficeClip API Documentation
AddressBookDB Methods
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

The AddressBookDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | CreateAddressBook | Creates a new address book into the database for the currently logged in user. This method is used to create either a private address book or the address book shared by other group members.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAddressBook | Gets all the Address Books for the currently logged in user. This method returns both the private address books for the user and also the shared address books belonging to the currently selected group.
Public method | GetAddressBookInfo | Determines whether a particular Address Book list is a shared address book or not.
Public method | GetAddresses | Get the address information
Public method | GetAlphabetLinks | Returns the first alphabets of the first name or the last name depending on the value of orderBy argument for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertAddress | InsertAddress
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAddress | Removes address
Public method | RemoveAddressBook | Removes a address book identified by GroupId.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SearchUsers | Gets the information of all the users for a particular user matching the search criteria.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAddress | Updates address
Public method | UpdateAddressBookInfo |

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
AddressBookDB..::.AddOutputParameter Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

AddressBookDB Class
AddressBookDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
AddressBookDB..::.AddParameter Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

AddressBookDB Class
AddressBookDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
AddressBookDB..::.AddParameters Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

AddressBookDB Class
AddressBookDB Members
OfficeClip.DBLayer.Desktop Namespace


CreateAddressBook Method

[image]

OfficeClip API Documentation
AddressBookDB..::.CreateAddressBook Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates a new address book into the database for the currently logged in user. This method is used to create either a private address book or the address book shared by other group members.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int CreateAddressBook(
    int groupId,
    int userId,
    string addressBookName,
    bool isShared
)
Visual Basic (Declaration)
Public Function CreateAddressBook ( _
    groupId As Integer, _
    userId As Integer, _
    addressBookName As String, _
    isShared As Boolean _
) As Integer
Visual C++
public:
int CreateAddressBook(
    int groupId,
    int userId,
    String^ addressBookName,
    bool isShared
)

Parameters

groupId
Type: System..::.Int32
The unique id of the organization
userId
Type: System..::.Int32
The unique id of the current user
addressBookName
Type: System..::.String
Name of the address book to be created.
isShared
Type: System..::.Boolean
Flag (True/False) indicating whether the newly created address book is private or is shared with the members of the currently selected group.

Return Value

Id of the newly created address book, -1 in case of an error.

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
AddressBookDB..::.ExecuteNonQuery Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

AddressBookDB Class
AddressBookDB Members
OfficeClip.DBLayer.Desktop Namespace


GetAddressBook Method

[image]

OfficeClip API Documentation
AddressBookDB..::.GetAddressBook Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the Address Books for the currently logged in user. This method returns both the private address books for the user and also the shared address books belonging to the currently selected group.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAddressBook(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetAddressBook ( _
    userId As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAddressBook(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32

Return Value

SqlDataReader containing all the information related to the address books visible to the user. The SqlDataReader has the following columns.
  • groupId (System.Int32)Id of the address book.
  • gName (System.String)Name of the address book.
  • isPrivate (System.String)Flag (Y/N) indicating whether this address book is a private address book or is shared by the currently selected group.
  • CreatedBy (System.String)Name of the user who created this address book.
  • CreatedTimestamp (System.DateTime)Date and time when this address book was created.

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


GetAddressBookInfo Method

[image]

OfficeClip API Documentation
AddressBookDB..::.GetAddressBookInfo Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Determines whether a particular Address Book list is a shared address book or not.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetAddressBookInfo(
    int addressbookId,
    ref bool isShare,
    ref string name
)
Visual Basic (Declaration)
Public Sub GetAddressBookInfo ( _
    addressbookId As Integer, _
    ByRef isShare As Boolean, _
    ByRef name As String _
)
Visual C++
public:
void GetAddressBookInfo(
    int addressbookId,
    bool% isShare,
    String^% name
)

Parameters

addressbookId
Type: System..::.Int32
The unique id of the addressbook
isShare
Type: System..::.Boolean%
Is the address book shared
name
Type: System..::.String%
The name of the addressbook

Return Value

Returns the true if the addressbook is shared.

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


GetAddresses Method

[image]

OfficeClip API Documentation
AddressBookDB..::.GetAddresses Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the address information

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<UserInfo> GetAddresses(
    int addressbookId,
    int addressId
)
Visual Basic (Declaration)
Public Function GetAddresses ( _
    addressbookId As Integer, _
    addressId As Integer _
) As List(Of UserInfo)
Visual C++
public:
List<UserInfo^>^ GetAddresses(
    int addressbookId,
    int addressId
)

Parameters

addressbookId
Type: System..::.Int32
The id of the addressbook, -1 if only one address is requested
addressId
Type: System..::.Int32
The id of the address, -1 if the whole addressbook is requested

Return Value

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


GetAlphabetLinks Method

[image]

OfficeClip API Documentation
AddressBookDB..::.GetAlphabetLinks Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the first alphabets of the first name or the last name depending on the value of orderBy argument for a particular group.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<AlphabetListItem> GetAlphabetLinks(
    SortByName orderBy,
    int addressbookId
)
Visual Basic (Declaration)
Public Function GetAlphabetLinks ( _
    orderBy As SortByName, _
    addressbookId As Integer _
) As List(Of AlphabetListItem)
Visual C++
public:
List<AlphabetListItem^>^ GetAlphabetLinks(
    SortByName orderBy,
    int addressbookId
)

Parameters

orderBy
Type: OfficeClip.Utils..::.SortByName
Enumerated value determining whether to sort the user list by the first character of the first name or last name. SortByName
addressbookId
Type: System..::.Int32
The unique id of the address book

Return Value

DataSet containing the list of alphabets for which there are users in the particular group. This DataSet consists of a single DataTable with the following columns.
  • Alphabet (System.String)Single character alphabet signifying that there are users in the list who have either their first name or last name starting with it.
  • isPresent (System.Boolean)Flag indicating whether the users corresponding to that particular alphabet are present or not.

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
AddressBookDB..::.InitTransaction Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

AddressBookDB Class
AddressBookDB Members
OfficeClip.DBLayer.Desktop Namespace


InsertAddress Method

[image]

OfficeClip API Documentation
AddressBookDB..::.InsertAddress Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

InsertAddress

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertAddress(
    int addressbookId,
    UserInfo uf,
    ref int status
)
Visual Basic (Declaration)
Public Function InsertAddress ( _
    addressbookId As Integer, _
    uf As UserInfo, _
    ByRef status As Integer _
) As Integer
Visual C++
public:
int InsertAddress(
    int addressbookId,
    UserInfo^ uf,
    int% status
)

Parameters

addressbookId
Type: System..::.Int32
uf
Type: OfficeClip.BusinessLayer.Account..::.UserInfo
status
Type: System..::.Int32%

Return Value

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


RemoveAddress Method

[image]

OfficeClip API Documentation
AddressBookDB..::.RemoveAddress Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes address

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RemoveAddress(
    int addressId
)
Visual Basic (Declaration)
Public Function RemoveAddress ( _
    addressId As Integer _
) As Integer
Visual C++
public:
int RemoveAddress(
    int addressId
)

Parameters

addressId
Type: System..::.Int32

Return Value

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


RemoveAddressBook Method

[image]

OfficeClip API Documentation
AddressBookDB..::.RemoveAddressBook Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes a address book identified by GroupId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RemoveAddressBook(
    int addressbookId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function RemoveAddressBook ( _
    addressbookId As Integer, _
    currentGroupId As Integer _
) As Integer
Visual C++
public:
int RemoveAddressBook(
    int addressbookId,
    int currentGroupId
)

Parameters

addressbookId
Type: System..::.Int32
The unique id of the addressbook
currentGroupId
Type: System..::.Int32
The id of the current organization

Return Value

0 when successful, -1 in case of an error.

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


SearchUsers Method

[image]

OfficeClip API Documentation
AddressBookDB..::.SearchUsers Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the information of all the users for a particular user matching the search criteria.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable SearchUsers(
    int userId,
    int groupId,
    string searchText,
    string searchBy,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function SearchUsers ( _
    userId As Integer, _
    groupId As Integer, _
    searchText As String, _
    searchBy As String, _
    isAdmin As Boolean _
) As DataTable
Visual C++
public:
DataTable^ SearchUsers(
    int userId,
    int groupId,
    String^ searchText,
    String^ searchBy,
    bool isAdmin
)

Parameters

userId
Type: System..::.Int32
The unique user id.
groupId
Type: System..::.Int32
The unique id of the organization
searchText
Type: System..::.String
The text string to search for.
searchBy
Type: System..::.String
This parameter can take the following values indicating which field to use for while searching.
  • firstname
  • lastname
  • emailaddress
  • initials
  • all
isAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

DataSet containing the information of the users matching the search criteria. This DataSet consists of a single DataTable with the following columns.
  • userDetailId (System.Int32)userDetailId of the user.
  • UserId (System.Int32)Id of the user.
  • UserName (System.String)Name of the user (first name and last name concatenated by a blank space).
  • emailAddress (System.String)Email Address of the user.
  • PreferredPhoneNumber (System.String)One of the phone numbers of work phone primary, work phone secondary, other phone, home phone or the cell phone based on the preference set by the user as the most preferred number to contacted at. If the user has not set the preference, then the primary work phone nuber is returned.
  • workPhonePrimary (System.String)Primary work phone number.
  • GroupId (System.Int32)Id of the group to which the user matching he search criteria belongs.
  • groupType (System.String)Flag (P,G,D,O) indicating the type of the group.
  • groupName (System.String)Name of the group.
  • groupIE (System.String)Flag (I,E) indicating whether the user matching the search criteria is internal or external to the OfficeClip system i.e. whether it is address book entry or a member.
  • IsRegistered (System.String)Flag (Y/N) indicating whether the user is registered in this particular group or not.

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
AddressBookDB..::.SetSPCommand Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

AddressBookDB Class
AddressBookDB Members
OfficeClip.DBLayer.Desktop Namespace


UpdateAddress Method

[image]

OfficeClip API Documentation
AddressBookDB..::.UpdateAddress Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates address

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateAddress(
    UserInfo uf
)
Visual Basic (Declaration)
Public Function UpdateAddress ( _
    uf As UserInfo _
) As Integer
Visual C++
public:
int UpdateAddress(
    UserInfo^ uf
)

Parameters

uf
Type: OfficeClip.BusinessLayer.Account..::.UserInfo

Return Value

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateAddressBookInfo Method

[image]

OfficeClip API Documentation
AddressBookDB..::.UpdateAddressBookInfo Method
AddressBookDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateAddressBookInfo(
    int addressbookId,
    bool isShare,
    string name,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function UpdateAddressBookInfo ( _
    addressbookId As Integer, _
    isShare As Boolean, _
    name As String, _
    currentGroupId As Integer _
) As Integer
Visual C++
public:
int UpdateAddressBookInfo(
    int addressbookId,
    bool isShare,
    String^ name,
    int currentGroupId
)

Parameters

addressbookId
Type: System..::.Int32
isShare
Type: System..::.Boolean
name
Type: System..::.String
currentGroupId
Type: System..::.Int32
The id of the current organization

Return Value

-2 if already exists, 0 if successful

See Also

AddressBookDB Class
OfficeClip.DBLayer.Desktop Namespace


CalendarDB Class

[image]

OfficeClip API Documentation
CalendarDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Calendar application related functions.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class CalendarDB : OfficeClipDB
Visual Basic (Declaration)
Public Class CalendarDB _
    Inherits OfficeClipDB
Visual C++
public ref class CalendarDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Desktop..::.CalendarDB

See Also

CalendarDB Members
OfficeClip.DBLayer.Desktop Namespace


CalendarDB Members

[image] [image]

OfficeClip API Documentation
CalendarDB Members
CalendarDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The CalendarDB type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarDB |

Methods

 | Name | Description
Public method | AcceptRSVP | Accepts the RSVP for a particular user for a particular event.
Public method | ActivatePublishUrl | Activates the publish Url
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Protected method | AdjustUserAvailabilityForMeeting | Adjusts the user availability record based on the event info.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeactivatePublishUrl | Deactivates the event publish url corresponding to a particular group.
Public method | DeleteCalenderReminder | Deletes a reminder corresponding to an event.
Public method | DeleteEvent | Deletes a single event or a set of repeating events depending on the option chosen by the user.
Public method | DeleteUserAvailability | Removes the user availability.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Public method | ExportVCalendar | Gets the string representation of all the events between a time range in vCalendar format for a particular user in a particular group. Please note that the userTzInfo object should be corresponding to that of that particular user for whom you are sending the userId.
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttachmentPaths |
Public method | GetEvent | Gets all the information related to a particular event identified by a GroupId.
Public method | GetEventReminderInfo | Overloaded.
Public method | GetEventResource | Gets the Id of a resource if any for a particular event.
Public method | GetEvents | Returns the events for a date range based on event type selection.
Public method | GetEventsForMetabase | Gets all the events for a particular object in the metabase
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMeetingAttendees | Gets a list of all the meeting attendees for a particular event.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPublishEvents | Returns the events for a date range based for a particular group..
Public method | GetPublishUrl | Gets the the information corresponding to an encrypted event publish info string.
Public method | GetResourceAvailability | Gets the availability information for a user between a time range.
Public method | GetRsvpList | Gets the list of status of RSVP corresponding to all the attendees of a meeting.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUpcomingEvents | Overloaded.
Public method | GetUserAvailability | Overloaded.
Public method | ImportEventsFromCsv | Imports a set of events mapped from a CSV file which has been exported from Outlook or Lotus Notes events.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertCalendarReminder | Inserts the calendar reminder
Public method | InsertEvent | Overloaded.
Public method | InsertMeetingAttendees | Inserts the meeting attendees of an event into the database and sends a notification about the meeting to all the attendees.
Public method | InsertUserAvailability | Inserts the user availability information corresponding to an event for the currently logged in user.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RejectRsvp | Rejects the RSVP for a particular user for a particular event.
Protected method | ResolveAvailabilityConflict |
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SendRsvpToTheGroup | Sends an RSVP to all the group members of a group for an event.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateEvent | Updates back the information related to a particular event into the database for a particular user.
Protected method | UpdateEvent1 | Updates back the information related to a particular event into the database.
Public method | UpdateEventParent | Updates the event parent
Public method | UpdateMeetingAttendees | Updates the meeting attendees information into the database. This method should generally be called while updating event information.
Public method | UpdateReadOnlyEvent | Provides the ability to update the readonly event, only the busy/free schedule and the reminder settings can be updated in this way
Public method | UpdateUserAvailability | Inserts the user availability information corresponding to an event for a particular user.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


CalendarDB Constructor

[image]

OfficeClip API Documentation
CalendarDB Constructor
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public CalendarDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalendarDB()

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


CalendarDB Methods

[image] [image]

OfficeClip API Documentation
CalendarDB Methods
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

The CalendarDB type exposes the following methods.

Methods

 | Name | Description
Public method | AcceptRSVP | Accepts the RSVP for a particular user for a particular event.
Public method | ActivatePublishUrl | Activates the publish Url
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Protected method | AdjustUserAvailabilityForMeeting | Adjusts the user availability record based on the event info.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeactivatePublishUrl | Deactivates the event publish url corresponding to a particular group.
Public method | DeleteCalenderReminder | Deletes a reminder corresponding to an event.
Public method | DeleteEvent | Deletes a single event or a set of repeating events depending on the option chosen by the user.
Public method | DeleteUserAvailability | Removes the user availability.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Public method | ExportVCalendar | Gets the string representation of all the events between a time range in vCalendar format for a particular user in a particular group. Please note that the userTzInfo object should be corresponding to that of that particular user for whom you are sending the userId.
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttachmentPaths |
Public method | GetEvent | Gets all the information related to a particular event identified by a GroupId.
Public method | GetEventReminderInfo | Overloaded.
Public method | GetEventResource | Gets the Id of a resource if any for a particular event.
Public method | GetEvents | Returns the events for a date range based on event type selection.
Public method | GetEventsForMetabase | Gets all the events for a particular object in the metabase
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMeetingAttendees | Gets a list of all the meeting attendees for a particular event.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPublishEvents | Returns the events for a date range based for a particular group..
Public method | GetPublishUrl | Gets the the information corresponding to an encrypted event publish info string.
Public method | GetResourceAvailability | Gets the availability information for a user between a time range.
Public method | GetRsvpList | Gets the list of status of RSVP corresponding to all the attendees of a meeting.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUpcomingEvents | Overloaded.
Public method | GetUserAvailability | Overloaded.
Public method | ImportEventsFromCsv | Imports a set of events mapped from a CSV file which has been exported from Outlook or Lotus Notes events.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertCalendarReminder | Inserts the calendar reminder
Public method | InsertEvent | Overloaded.
Public method | InsertMeetingAttendees | Inserts the meeting attendees of an event into the database and sends a notification about the meeting to all the attendees.
Public method | InsertUserAvailability | Inserts the user availability information corresponding to an event for the currently logged in user.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RejectRsvp | Rejects the RSVP for a particular user for a particular event.
Protected method | ResolveAvailabilityConflict |
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SendRsvpToTheGroup | Sends an RSVP to all the group members of a group for an event.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateEvent | Updates back the information related to a particular event into the database for a particular user.
Protected method | UpdateEvent1 | Updates back the information related to a particular event into the database.
Public method | UpdateEventParent | Updates the event parent
Public method | UpdateMeetingAttendees | Updates the meeting attendees information into the database. This method should generally be called while updating event information.
Public method | UpdateReadOnlyEvent | Provides the ability to update the readonly event, only the busy/free schedule and the reminder settings can be updated in this way
Public method | UpdateUserAvailability | Inserts the user availability information corresponding to an event for a particular user.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


AcceptRSVP Method

[image]

OfficeClip API Documentation
CalendarDB..::.AcceptRSVP Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Accepts the RSVP for a particular user for a particular event.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int AcceptRSVP(
    int userId,
    int eventId,
    string status,
    DBConstants..::.ProcessWhichEvent pwe
)
Visual Basic (Declaration)
Public Function AcceptRSVP ( _
    userId As Integer, _
    eventId As Integer, _
    status As String, _
    pwe As DBConstants..::.ProcessWhichEvent _
) As Integer
Visual C++
public:
int AcceptRSVP(
    int userId,
    int eventId,
    String^ status,
    DBConstants..::.ProcessWhichEvent pwe
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
eventId
Type: System..::.Int32
Id of the event for which the user wants to set the RSVP status.
status
Type: System..::.String
Value indicating the type of avaialability for this user to be displayed to other users for the time perioed of the event.
            F = Free
            O = Out of Office
            B = Busy
            T = Tentative
pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
The kind of event to be processed

Return Value

0 if successful, -1 in case of an error

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


ActivatePublishUrl Method

[image]

OfficeClip API Documentation
CalendarDB..::.ActivatePublishUrl Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Activates the publish Url

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string ActivatePublishUrl(
    int userId,
    int groupId,
    bool showEvents,
    bool enableRequestFeature,
    int requestToUserId
)
Visual Basic (Declaration)
Public Function ActivatePublishUrl ( _
    userId As Integer, _
    groupId As Integer, _
    showEvents As Boolean, _
    enableRequestFeature As Boolean, _
    requestToUserId As Integer _
) As String
Visual C++
public:
String^ ActivatePublishUrl(
    int userId,
    int groupId,
    bool showEvents,
    bool enableRequestFeature,
    int requestToUserId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
showEvents
Type: System..::.Boolean
enableRequestFeature
Type: System..::.Boolean
requestToUserId
Type: System..::.Int32

Return Value

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
CalendarDB..::.AddOutputParameter Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

CalendarDB Class
CalendarDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
CalendarDB..::.AddParameter Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

CalendarDB Class
CalendarDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
CalendarDB..::.AddParameters Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

CalendarDB Class
CalendarDB Members
OfficeClip.DBLayer.Desktop Namespace


AdjustUserAvailabilityForMeeting Method

[image]

OfficeClip API Documentation
CalendarDB..::.AdjustUserAvailabilityForMeeting Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Adjusts the user availability record based on the event info.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AdjustUserAvailabilityForMeeting(
    EventInfo ei,
    TimeZoneInfo serverTz
)
Visual Basic (Declaration)
Protected Sub AdjustUserAvailabilityForMeeting ( _
    ei As EventInfo, _
    serverTz As TimeZoneInfo _
)
Visual C++
protected:
void AdjustUserAvailabilityForMeeting(
    EventInfo^ ei,
    TimeZoneInfo^ serverTz
)

Parameters

ei
Type: OfficeClip.BusinessLayer.Desktop..::.EventInfo
The eventinfo structure
serverTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The timezone of the server

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


DeactivatePublishUrl Method

[image]

OfficeClip API Documentation
CalendarDB..::.DeactivatePublishUrl Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Deactivates the event publish url corresponding to a particular group.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeactivatePublishUrl(
    int groupId
)
Visual Basic (Declaration)
Public Function DeactivatePublishUrl ( _
    groupId As Integer _
) As Integer
Visual C++
public:
int DeactivatePublishUrl(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group.

Return Value

0 if successful, -1 in case of an error.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteCalenderReminder Method

[image]

OfficeClip API Documentation
CalendarDB..::.DeleteCalenderReminder Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a reminder corresponding to an event.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteCalenderReminder(
    int eventId
)
Visual Basic (Declaration)
Public Function DeleteCalenderReminder ( _
    eventId As Integer _
) As Integer
Visual C++
public:
int DeleteCalenderReminder(
    int eventId
)

Parameters

eventId
Type: System..::.Int32
Id of a particular event corresponding to which the reminder is to be deleted.

Return Value

0 if successful, -1 in case of an error.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteEvent Method

[image]

OfficeClip API Documentation
CalendarDB..::.DeleteEvent Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a single event or a set of repeating events depending on the option chosen by the user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteEvent(
    int eventId,
    DBConstants..::.ProcessWhichEvent whichEvent,
    int userId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function DeleteEvent ( _
    eventId As Integer, _
    whichEvent As DBConstants..::.ProcessWhichEvent, _
    userId As Integer, _
    isAdmin As Boolean _
) As Integer
Visual C++
public:
int DeleteEvent(
    int eventId,
    DBConstants..::.ProcessWhichEvent whichEvent,
    int userId,
    bool isAdmin
)

Parameters

eventId
Type: System..::.Int32
Id of the event to be deleted.
whichEvent
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
The type of event to be deleted
userId
Type: System..::.Int32
The unique id of the user
isAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Enumerated value of ProcessWhichEvent type signifying whether to Delete just one single event, all events (repeating instances including) or only remaining future occurrences of repeating events.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace
OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent


DeleteUserAvailability Method

[image]

OfficeClip API Documentation
CalendarDB..::.DeleteUserAvailability Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the user availability.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteUserAvailability(
    int eventId,
    int userId
)
Visual Basic (Declaration)
Public Sub DeleteUserAvailability ( _
    eventId As Integer, _
    userId As Integer _
)
Visual C++
public:
void DeleteUserAvailability(
    int eventId,
    int userId
)

Parameters

eventId
Type: System..::.Int32
The unique id of the event.
userId
Type: System..::.Int32
The unique id of the user

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
CalendarDB..::.ExecuteNonQuery Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

CalendarDB Class
CalendarDB Members
OfficeClip.DBLayer.Desktop Namespace


ExportVCalendar Method

[image]

OfficeClip API Documentation
CalendarDB..::.ExportVCalendar Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the string representation of all the events between a time range in vCalendar format for a particular user in a particular group. Please note that the userTzInfo object should be corresponding to that of that particular user for whom you are sending the userId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string ExportVCalendar(
    ConfigureInfo configInfo,
    DateTime startDateTime,
    DateTime endDateTime
)
Visual Basic (Declaration)
Public Function ExportVCalendar ( _
    configInfo As ConfigureInfo, _
    startDateTime As DateTime, _
    endDateTime As DateTime _
) As String
Visual C++
public:
String^ ExportVCalendar(
    ConfigureInfo^ configInfo,
    DateTime startDateTime,
    DateTime endDateTime
)

Parameters

configInfo
Type: OfficeClip.Utils..::.ConfigureInfo
Session configuration info
startDateTime
Type: System..::.DateTime
Starting Date and Time of the range. (This value is in User's timezone)
endDateTime
Type: System..::.DateTime
Ending Date and Time of the range. (This value is in User's timezone)

Return Value

vCard stirng containing all the events for the currently logged in user within the reqeusted time range.

Remarks

Please note that the userTzInfo object should be corresponding to that of that particular user for whom you are sending the userId.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


GetAttachmentPaths Method

[image]

OfficeClip API Documentation
CalendarDB..::.GetAttachmentPaths Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetAttachmentPaths(
    int issueId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetAttachmentPaths ( _
    issueId As Integer, _
    groupId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetAttachmentPaths(
    int issueId,
    int groupId
)

Parameters

issueId
Type: System..::.Int32
groupId
Type: System..::.Int32

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEvent Method

[image]

OfficeClip API Documentation
CalendarDB..::.GetEvent Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to a particular event identified by a GroupId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public EventInfo GetEvent(
    int eventId,
    TimeZoneInfo userTz,
    int userId
)
Visual Basic (Declaration)
Public Function GetEvent ( _
    eventId As Integer, _
    userTz As TimeZoneInfo, _
    userId As Integer _
) As EventInfo
Visual C++
public:
EventInfo^ GetEvent(
    int eventId,
    TimeZoneInfo^ userTz,
    int userId
)

Parameters

eventId
Type: System..::.Int32
Id of the event for which all the details have to be retieved.
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone
userId
Type: System..::.Int32
The unique id of the current user

Return Value

Instance of EventInfo object containing all the information of a particular event.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace
OfficeClip.BusinessLayer.Desktop..::.EventInfo


GetEventReminderInfo Method

[image] [image]

OfficeClip API Documentation
CalendarDB..::.GetEventReminderInfo Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetEventReminderInfo(Int32, DateTime, Boolean%, String%, String%, DateTime%, Int32) | Gets the reminder information of the currently logged in user corresponding to a particular event identified by eventId.
Public method | GetEventReminderInfo(Int32, Int32, DateTime, Boolean%, String%, String%, DateTime%) | Gets the reminder information of a particular user corresponding to a particular event identified by eventId.

See Also

CalendarDB Class
CalendarDB Members
OfficeClip.DBLayer.Desktop Namespace


GetEventReminderInfo Method (Int32, DateTime, Boolean, String, String, DateTime, Int32)

[image]

OfficeClip API Documentation
CalendarDB..::.GetEventReminderInfo Method (Int32, DateTime, Boolean%, String%, String%, DateTime%, Int32)
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the reminder information of the currently logged in user corresponding to a particular event identified by eventId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetEventReminderInfo(
    int eventId,
    DateTime startDatetime,
    ref bool isReminderSelected,
    ref string whoToRemind,
    ref string whenToRemind,
    ref DateTime remindTime,
    int userId
)
Visual Basic (Declaration)
Public Sub GetEventReminderInfo ( _
    eventId As Integer, _
    startDatetime As DateTime, _
    ByRef isReminderSelected As Boolean, _
    ByRef whoToRemind As String, _
    ByRef whenToRemind As String, _
    ByRef remindTime As DateTime, _
    userId As Integer _
)
Visual C++
public:
void GetEventReminderInfo(
    int eventId,
    DateTime startDatetime,
    bool% isReminderSelected,
    String^% whoToRemind,
    String^% whenToRemind,
    DateTime% remindTime,
    int userId
)

Parameters

eventId
Type: System..::.Int32
Id of the event for which the reminder information is to be obtained.
startDatetime
Type: System..::.DateTime
Date and Time of the reminder created corresponding to a particular event.
isReminderSelected
Type: System..::.Boolean%
Flag (True/False) indicating whether a reminder is created for this event or not.
whoToRemind
Type: System..::.String%
This tells whether just the person creating the reminder has to be reminded or if it is a group event, all the group members should be reminded.
whenToRemind
Type: System..::.String%
The difference in time (with reference to the event start date and time) when the reminder will be sent.
remindTime
Type: System..::.DateTime%
The remind time
userId
Type: System..::.Int32
The unique id of the current user

See Also

CalendarDB Class
GetEventReminderInfo Overload
OfficeClip.DBLayer.Desktop Namespace


GetEventReminderInfo Method (Int32, Int32, DateTime, Boolean, String, String, DateTime)

[image]

OfficeClip API Documentation
CalendarDB..::.GetEventReminderInfo Method (Int32, Int32, DateTime, Boolean%, String%, String%, DateTime%)
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the reminder information of a particular user corresponding to a particular event identified by eventId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetEventReminderInfo(
    int userId,
    int eventId,
    DateTime startDatetime,
    ref bool isReminderSelected,
    ref string whoToRemind,
    ref string whenToRemind,
    ref DateTime remindTime
)
Visual Basic (Declaration)
Public Sub GetEventReminderInfo ( _
    userId As Integer, _
    eventId As Integer, _
    startDatetime As DateTime, _
    ByRef isReminderSelected As Boolean, _
    ByRef whoToRemind As String, _
    ByRef whenToRemind As String, _
    ByRef remindTime As DateTime _
)
Visual C++
public:
void GetEventReminderInfo(
    int userId,
    int eventId,
    DateTime startDatetime,
    bool% isReminderSelected,
    String^% whoToRemind,
    String^% whenToRemind,
    DateTime% remindTime
)

Parameters

userId
Type: System..::.Int32
The unique id for the user.
eventId
Type: System..::.Int32
Id of the event for which the reminder information is to be obtained.
startDatetime
Type: System..::.DateTime
Date and Time of the reminder created corresponding to a particular event.
isReminderSelected
Type: System..::.Boolean%
Flag (True/False) indicating whether a reminder is created for this event or not.
whoToRemind
Type: System..::.String%
This tells whether just the person creating the reminder has to be reminded or if it is a group event, all the group members should be reminded.
whenToRemind
Type: System..::.String%
The difference in time (with reference to the event start date and time) when the reminder will be sent.
remindTime
Type: System..::.DateTime%
The remind time

See Also

CalendarDB Class
GetEventReminderInfo Overload
OfficeClip.DBLayer.Desktop Namespace


GetEventResource Method

[image]

OfficeClip API Documentation
CalendarDB..::.GetEventResource Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Id of a resource if any for a particular event.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetEventResource(
    int eventId
)
Visual Basic (Declaration)
Public Function GetEventResource ( _
    eventId As Integer _
) As Integer
Visual C++
public:
int GetEventResource(
    int eventId
)

Parameters

eventId
Type: System..::.Int32
Id of the event for which the resource is to be found.

Return Value

Id of the resource if there is any resource resereved for a particular event otherwise -1.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEvents Method

[image]

OfficeClip API Documentation
CalendarDB..::.GetEvents Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the events for a date range based on event type selection.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetEvents(
    DateTime startDateTime,
    DateTime endDateTime,
    GroupSelection eventType,
    TimeZoneInfo userTzInfo,
    TimeZoneInfo serverTzInfo,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetEvents ( _
    startDateTime As DateTime, _
    endDateTime As DateTime, _
    eventType As GroupSelection, _
    userTzInfo As TimeZoneInfo, _
    serverTzInfo As TimeZoneInfo, _
    userId As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetEvents(
    DateTime startDateTime,
    DateTime endDateTime,
    GroupSelection eventType,
    TimeZoneInfo^ userTzInfo,
    TimeZoneInfo^ serverTzInfo,
    int userId,
    int groupId
)

Parameters

startDateTime
Type: System..::.DateTime
Start date and time of the range.
endDateTime
Type: System..::.DateTime
End date and time of the range.
eventType
Type: OfficeClip.Utils..::.GroupSelection
Type of event whether all group events (where the user belongs), currently selected group's events or private events.
userTzInfo
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone information.
serverTzInfo
Type: OfficeClip.Utils..::.TimeZoneInfo
The server timezone information.
userId
Type: System..::.Int32
The unique id of the user.
groupId
Type: System..::.Int32
The unique id of the group.

Return Value

DataSet containing all the event related information. The DataSet contains a single table with following columns.
  • eventId (System.Int32) Id of a particular event.
  • eventName (System.String) Name of the event.
  • groupName (System.String) Name of the group for which this event is created. It will have a null value when a particular event is a private event.
  • startWeekDay (System.Int32) Day of the week when the event starts.
  • sartDay (System.Int32) Day of the month when the event starts.
  • isPrivate (System.String) Flag (Y/N) indicating whether this event is a private event or not.
  • startDateTime (System.DateTime) Date and Time when the event starts.
  • startHour (System.Int32) Hour when the event starts.
  • startMinute (System.Int32) Minute when the event starts.
  • startTime (System.String) Time at which the event starts.
  • endDateTime (System.DateTime) Date and Time when the event ends.
  • endTime (System.String) Time at which the event ends.
  • odtm (System.Int32) Duration in minutes which the day light saving time offset depending on the timezone of Current logged in user and the timezone for which the event was created.
  • location (System.String) location of the event.
  • url (System.String) Url of the event.
  • createdDateTime (System.DateTime) Date and Time when this event was created.
  • description (System.String) The description of the event.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEventsForMetabase Method

[image]

OfficeClip API Documentation
CalendarDB..::.GetEventsForMetabase Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the events for a particular object in the metabase

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetEventsForMetabase(
    MetaConstants..::.MetaEntity me,
    int objectId
)
Visual Basic (Declaration)
Public Function GetEventsForMetabase ( _
    me As MetaConstants..::.MetaEntity, _
    objectId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetEventsForMetabase(
    MetaConstants..::.MetaEntity me,
    int objectId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity id
objectId
Type: System..::.Int32
The unique object id in the metabase

Return Value

The dataset of events

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


GetMeetingAttendees Method

[image]

OfficeClip API Documentation
CalendarDB..::.GetMeetingAttendees Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the meeting attendees for a particular event.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetMeetingAttendees(
    int eventId
)
Visual Basic (Declaration)
Public Function GetMeetingAttendees ( _
    eventId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetMeetingAttendees(
    int eventId
)

Parameters

eventId
Type: System..::.Int32
The id of a Meeting type event.

Return Value

ArrayList of MeetingAttendeeInfo object. The MeetingAttendeeInfo object instance will have the userId, of all the attendees which are internal to OfficeClip system (i.e. they are OfficeClip members). If an attendee is not a member, the userId, field of that MeetingAttendeeInfo object will contain a negative random number.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


GetPublishEvents Method

[image]

OfficeClip API Documentation
CalendarDB..::.GetPublishEvents Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the events for a date range based for a particular group..

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPublishEvents(
    int groupId,
    DateTime startDateTime,
    DateTime endDateTime,
    TimeZoneInfo userTzInfo
)
Visual Basic (Declaration)
Public Function GetPublishEvents ( _
    groupId As Integer, _
    startDateTime As DateTime, _
    endDateTime As DateTime, _
    userTzInfo As TimeZoneInfo _
) As DataSet
Visual C++
public:
DataSet^ GetPublishEvents(
    int groupId,
    DateTime startDateTime,
    DateTime endDateTime,
    TimeZoneInfo^ userTzInfo
)

Parameters

groupId
Type: System..::.Int32
Id of the group or which the events have to be retrieved.
startDateTime
Type: System..::.DateTime
Start date and time of the range.
endDateTime
Type: System..::.DateTime
End date and time of the range.
userTzInfo
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone info structure.

Return Value

DataSet containing all the event related information. The DataSet contains a single table with following columns.
  • eventId (System.Int32) Id of a particular event.
  • eventName (System.String) Name of the event.
  • groupName (System.String) Name of the group for which this event is created. It will have a null value when a particular event is a private event.
  • startWeekDay (System.Int32) Day of the week when the event starts.
  • sartDay (System.Int32) Day of the month when the event starts.
  • isPrivate (System.String) Flag (Y/N) indicating whether this event is a private event or not.
  • startDateTime (System.DateTime) Date and Time when the event starts.
  • startHour (System.Int32) Hour when the event starts.
  • startMinute (System.Int32) Minute when the event starts.
  • startTime (System.String) Time at which the event starts.
  • endDateTime (System.DateTime) Date and Time when the event ends.
  • endTime (System.String) Time at which the event ends.
  • odtm (System.Int32) Duration in minutes which the day light saving time offset depending on the timezone of Current logged in user and the timezone for which the event was created.
  • location (System.String) location of the event.
  • url (System.String) Url of the event.
  • createdDateTime (System.DateTime) Date and Time when this event was created.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


GetPublishUrl Method

[image]

OfficeClip API Documentation
CalendarDB..::.GetPublishUrl Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the the information corresponding to an encrypted event publish info string.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetPublishUrl(
    string publishInfo,
    ref int groupId,
    ref int createdByUserId,
    ref bool isActivated,
    ref bool showEvents,
    ref bool enableRequestFeature,
    ref int requestToUserId
)
Visual Basic (Declaration)
Public Sub GetPublishUrl ( _
    publishInfo As String, _
    ByRef groupId As Integer, _
    ByRef createdByUserId As Integer, _
    ByRef isActivated As Boolean, _
    ByRef showEvents As Boolean, _
    ByRef enableRequestFeature As Boolean, _
    ByRef requestToUserId As Integer _
)
Visual C++
public:
void GetPublishUrl(
    String^ publishInfo,
    int% groupId,
    int% createdByUserId,
    bool% isActivated,
    bool% showEvents,
    bool% enableRequestFeature,
    int% requestToUserId
)

Parameters

publishInfo
Type: System..::.String
Encrypted publish information related to the event published for a group.
groupId
Type: System..::.Int32%
Id of the group corresponding to which the publish information has to be obtained.
createdByUserId
Type: System..::.Int32%
Id of the user who is publishing the events.
isActivated
Type: System..::.Boolean%
Flag (True/False) indicating whether publish url is activated.
showEvents
Type: System..::.Boolean%
Flag (True/False) indicating whether to show the events or not.
enableRequestFeature
Type: System..::.Boolean%
Flag (True/False) indicating whether the external users can request an event from the published events screen.
requestToUserId
Type: System..::.Int32%
Id of the user to whom the new event requests should be sent.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


GetResourceAvailability Method

[image]

OfficeClip API Documentation
CalendarDB..::.GetResourceAvailability Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the availability information for a user between a time range.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetResourceAvailability(
    int resourceId,
    DateTime startDatetime,
    DateTime endDatetime
)
Visual Basic (Declaration)
Public Function GetResourceAvailability ( _
    resourceId As Integer, _
    startDatetime As DateTime, _
    endDatetime As DateTime _
) As DataView
Visual C++
public:
DataView^ GetResourceAvailability(
    int resourceId,
    DateTime startDatetime,
    DateTime endDatetime
)

Parameters

resourceId
Type: System..::.Int32
Id of the resource whose availability information is to be obtained.
startDatetime
Type: System..::.DateTime
Starting Date and Time of the time range. (This is the date and time based on currenly logged in User's timezone).
endDatetime
Type: System..::.DateTime
Ending Date and Time of the time range. (This is the date and time based on currenly logged in User's timezone).

Return Value

DataView containing the user's availability information. DataView has the following two columns.
  • id (System.Int32) -- number between 0 to 95 corresponding to each quarter of an hour over a 24 hour period.
  • status (System.String) -- value determining the availability F = Free B = Busy

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


GetRsvpList Method

[image]

OfficeClip API Documentation
CalendarDB..::.GetRsvpList Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of status of RSVP corresponding to all the attendees of a meeting.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetRsvpList(
    int eventId
)
Visual Basic (Declaration)
Public Function GetRsvpList ( _
    eventId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetRsvpList(
    int eventId
)

Parameters

eventId
Type: System..::.Int32
Id of the event of type meeting.

Return Value

DataSet containing the RSVP status information corresponding to meeting attendees. DataSet contains a single table with the following columns.
  • name (System.String) Name of the meeting attendee.
  • response (System.Int32) Value corresponding whether the RSVP is accepted, rejected or pending. Possible values are as follows: 1 = Accepted 2 = Rejected 0 = Pending

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


GetUpcomingEvents Method

[image] [image]

OfficeClip API Documentation
CalendarDB..::.GetUpcomingEvents Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetUpcomingEvents(Int32, Int32, GroupSelection) | Gets all the upcoming events for a particular user in a particular group (applicable only if event type selected is groupType) from the database based on the type of event selected.
Public method | GetUpcomingEvents(GroupSelection, Int32, Int32) | Gets all the upcoming events for the currently logged in user from the database based on the type of event selected.

See Also

CalendarDB Class
CalendarDB Members
OfficeClip.DBLayer.Desktop Namespace


GetUpcomingEvents Method (Int32, Int32, GroupSelection)

[image]

OfficeClip API Documentation
CalendarDB..::.GetUpcomingEvents Method (Int32, Int32, GroupSelection)
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the upcoming events for a particular user in a particular group (applicable only if event type selected is groupType) from the database based on the type of event selected.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetUpcomingEvents(
    int userId,
    int groupId,
    GroupSelection eventType
)
Visual Basic (Declaration)
Public Function GetUpcomingEvents ( _
    userId As Integer, _
    groupId As Integer, _
    eventType As GroupSelection _
) As DataSet
Visual C++
public:
DataSet^ GetUpcomingEvents(
    int userId,
    int groupId,
    GroupSelection eventType
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
groupId
Type: System..::.Int32
The unique id of the group.
eventType
Type: OfficeClip.Utils..::.GroupSelection
The type of events which need to be returned. OfficeClip.Utils..::.GroupSelection

Return Value

DataSet containing all the upcoming event releated information. DataSet contains a single table containing the following columns.
  • eventId (System.Int32) Id of the event.
  • eventName (System.String) Name of the event.
  • EventDescription (System.String) Description of the event.
  • groupName (System.String) Name of the group to which the event belongs if it is a group type event.
  • startDatetime (System.DateTime) Starting Date and Time of the event. (Convert into currently logged in user's timezone)
  • endDatetime (System.DateTime) Ending Date and Time of the event. (Convert into currently logged in user's timezone)
  • isPrivate (System.String) Flag (Y/N) indicating whether event is a group or private event.

See Also

CalendarDB Class
GetUpcomingEvents Overload
OfficeClip.DBLayer.Desktop Namespace


GetUpcomingEvents Method (GroupSelection, Int32, Int32)

[image]

OfficeClip API Documentation
CalendarDB..::.GetUpcomingEvents Method (GroupSelection, Int32, Int32)
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the upcoming events for the currently logged in user from the database based on the type of event selected.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetUpcomingEvents(
    GroupSelection eventType,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetUpcomingEvents ( _
    eventType As GroupSelection, _
    userId As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetUpcomingEvents(
    GroupSelection eventType,
    int userId,
    int groupId
)

Parameters

eventType
Type: OfficeClip.Utils..::.GroupSelection
The type of events which need to be returned. OfficeClip.Utils..::.GroupSelection
userId
Type: System..::.Int32
The unique id of the current user
groupId
Type: System..::.Int32
The unique id of the organization

Return Value

DataSet containing all the upcoming event releated information. DataSet contains a single table containing the following columns.
  • eventId (System.Int32) Id of the event.
  • eventName (System.String) Name of the event.
  • EventDescription (System.String) Description of the event.
  • groupName (System.String) Name of the group to which the event belongs if it is a group type event.
  • startDatetime (System.DateTime) Starting Date and Time of the event. (Convert into currently logged in user's timezone)
  • endDatetime (System.DateTime) Ending Date and Time of the event. (Convert into currently logged in user's timezone)
  • isPrivate (System.String) Flag (Y/N) indicating whether event is a group or private event.

See Also

CalendarDB Class
GetUpcomingEvents Overload
OfficeClip.DBLayer.Desktop Namespace


GetUserAvailability Method

[image] [image]

OfficeClip API Documentation
CalendarDB..::.GetUserAvailability Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetUserAvailability(Int32, Int32) | Gets the event display availability status for a particular user for a particular event identified by eventId.
Public method | GetUserAvailability(Int32, DateTime, DateTime) | Gets the availability information for a user between a time range.

See Also

CalendarDB Class
CalendarDB Members
OfficeClip.DBLayer.Desktop Namespace


GetUserAvailability Method (Int32, Int32)

[image]

OfficeClip API Documentation
CalendarDB..::.GetUserAvailability Method (Int32, Int32)
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the event display availability status for a particular user for a particular event identified by eventId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetUserAvailability(
    int userId,
    int eventId
)
Visual Basic (Declaration)
Public Function GetUserAvailability ( _
    userId As Integer, _
    eventId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetUserAvailability(
    int userId,
    int eventId
)

Parameters

userId
Type: System..::.Int32
The unique id for the user.
eventId
Type: System..::.Int32
Id of the event for which the user's availability has to be determined.

Return Value

Value of the EventShowAs representing whether the user is Busy, Free, Out of Office, or is Tentatively available. OfficeClip.Utils..::.EventShowAs

See Also

CalendarDB Class
GetUserAvailability Overload
OfficeClip.DBLayer.Desktop Namespace


GetUserAvailability Method (Int32, DateTime, DateTime)

[image]

OfficeClip API Documentation
CalendarDB..::.GetUserAvailability Method (Int32, DateTime, DateTime)
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the availability information for a user between a time range.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetUserAvailability(
    int userId,
    DateTime startDatetime,
    DateTime endDatetime
)
Visual Basic (Declaration)
Public Function GetUserAvailability ( _
    userId As Integer, _
    startDatetime As DateTime, _
    endDatetime As DateTime _
) As DataView
Visual C++
public:
DataView^ GetUserAvailability(
    int userId,
    DateTime startDatetime,
    DateTime endDatetime
)

Parameters

userId
Type: System..::.Int32
Id of the user whose availability information is to be obtained.
startDatetime
Type: System..::.DateTime
Starting Date and Time of the time range. (This is the date and time based on currenly logged in User's timezone).
endDatetime
Type: System..::.DateTime
Ending Date and Time of the time range. (This is the date and time based on currenly logged in User's timezone).

Return Value

DataView containing the user's availability information. DataView has the following two columns.
  • id (System.Int32) -- number between 0 to 95 corresponding to each quarter of an hour over a 24 hour period.
  • status (System.String) -- value determining the availability
F = Free
B = Busy
O = Out of Office
T = Tentative

See Also

CalendarDB Class
GetUserAvailability Overload
OfficeClip.DBLayer.Desktop Namespace


ImportEventsFromCsv Method

[image]

OfficeClip API Documentation
CalendarDB..::.ImportEventsFromCsv Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Imports a set of events mapped from a CSV file which has been exported from Outlook or Lotus Notes events.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable ImportEventsFromCsv(
    ArrayList csvEventList,
    bool isGroupEvent,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function ImportEventsFromCsv ( _
    csvEventList As ArrayList, _
    isGroupEvent As Boolean, _
    session As ConfigureInfo _
) As DataTable
Visual C++
public:
DataTable^ ImportEventsFromCsv(
    ArrayList^ csvEventList,
    bool isGroupEvent,
    ConfigureInfo^ session
)

Parameters

csvEventList
Type: System.Collections..::.ArrayList
List of OCCSVEventInfo objects containing all the event information mapped from a CSV file.
isGroupEvent
Type: System..::.Boolean
Flag (True/False) indicating whether the events being imported are to imported as Group Events.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session

Return Value

DataTable indicating the status of the import whether it was successful. DataTable has following columns.
  • eventName (System.String) -- Name of the imported Event
  • startDatetime (System.DateTime) -- Date and Time when the event is starting.
  • endDatetime (System.DateTime) -- Date and Time when the event is ending.
  • status -- (System.String) -- String describing the status of the import whether it was successful or it failed.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
CalendarDB..::.InitTransaction Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

CalendarDB Class
CalendarDB Members
OfficeClip.DBLayer.Desktop Namespace


InsertCalendarReminder Method

[image]

OfficeClip API Documentation
CalendarDB..::.InsertCalendarReminder Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the calendar reminder

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertCalendarReminder(
    int eventUserId,
    int eventId,
    string eventName,
    EventShowAs showAs,
    DateTime startTime,
    DateTime endTime,
    TimeSpan beforeEventTimeSpan
)
Visual Basic (Declaration)
Public Function InsertCalendarReminder ( _
    eventUserId As Integer, _
    eventId As Integer, _
    eventName As String, _
    showAs As EventShowAs, _
    startTime As DateTime, _
    endTime As DateTime, _
    beforeEventTimeSpan As TimeSpan _
) As Integer
Visual C++
public:
int InsertCalendarReminder(
    int eventUserId,
    int eventId,
    String^ eventName,
    EventShowAs showAs,
    DateTime startTime,
    DateTime endTime,
    TimeSpan beforeEventTimeSpan
)

Parameters

eventUserId
Type: System..::.Int32
eventId
Type: System..::.Int32
eventName
Type: System..::.String
showAs
Type: OfficeClip.Utils..::.EventShowAs
startTime
Type: System..::.DateTime
endTime
Type: System..::.DateTime
beforeEventTimeSpan
Type: System..::.TimeSpan

Return Value

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertEvent Method

[image] [image]

OfficeClip API Documentation
CalendarDB..::.InsertEvent Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InsertEvent(EventType, String, String, String, Boolean, Int32, String, DateTime, DateTime, EventShowAs, String, Int32, String, Int32, Int32, BusinessConstants..::.ObjectType, Int32, Int32, DateTime%, Int32) | Inserts all the different values corresponding to an event into the database.
Public method | InsertEvent(EventInfo, ConfigureInfo, DateTime%) | Inserts a new event or a set of new repeating events into the database.

See Also

CalendarDB Class
CalendarDB Members
OfficeClip.DBLayer.Desktop Namespace


InsertEvent Method (EventType, String, String, String, Boolean, Int32, String, DateTime, DateTime, EventShowAs, String, Int32, String, Int32, Int32, BusinessConstants.ObjectType, Int32, Int32, DateTime, Int32)

[image]

OfficeClip API Documentation
CalendarDB..::.InsertEvent Method (EventType, String, String, String, Boolean, Int32, String, DateTime, DateTime, EventShowAs, String, Int32, String, Int32, Int32, BusinessConstants..::.ObjectType, Int32, Int32, DateTime%, Int32)
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the different values corresponding to an event into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertEvent(
    EventType eventType,
    string eventName,
    string location,
    string url,
    bool IsRSVP,
    int resourceId,
    string EventDescription,
    DateTime startDatetime,
    DateTime endDatetime,
    EventShowAs showAs,
    string RepeatInfoText,
    int repeatingSequenceId,
    string docIdList,
    int EventUserId,
    int labelId,
    BusinessConstants..::.ObjectType parentObjectType,
    int parentObjectId,
    int createdByUserId,
    ref DateTime modifiedTime,
    int groupId
)
Visual Basic (Declaration)
Public Function InsertEvent ( _
    eventType As EventType, _
    eventName As String, _
    location As String, _
    url As String, _
    IsRSVP As Boolean, _
    resourceId As Integer, _
    EventDescription As String, _
    startDatetime As DateTime, _
    endDatetime As DateTime, _
    showAs As EventShowAs, _
    RepeatInfoText As String, _
    repeatingSequenceId As Integer, _
    docIdList As String, _
    EventUserId As Integer, _
    labelId As Integer, _
    parentObjectType As BusinessConstants..::.ObjectType, _
    parentObjectId As Integer, _
    createdByUserId As Integer, _
    ByRef modifiedTime As DateTime, _
    groupId As Integer _
) As Integer
Visual C++
public:
int InsertEvent(
    EventType eventType,
    String^ eventName,
    String^ location,
    String^ url,
    bool IsRSVP,
    int resourceId,
    String^ EventDescription,
    DateTime startDatetime,
    DateTime endDatetime,
    EventShowAs showAs,
    String^ RepeatInfoText,
    int repeatingSequenceId,
    String^ docIdList,
    int EventUserId,
    int labelId,
    BusinessConstants..::.ObjectType parentObjectType,
    int parentObjectId,
    int createdByUserId,
    DateTime% modifiedTime,
    int groupId
)

Parameters

eventType
Type: OfficeClip.Utils..::.EventType
Type of the event. OfficeClip.Utils..::.EventType
eventName
Type: System..::.String
Name of the event.
location
Type: System..::.String
location where the event is going to take place.
url
Type: System..::.String
Url of a web page giving extra information about the event or otherwise related information.
IsRSVP
Type: System..::.Boolean
Flag indicating whether an RSVP has been requested for the meeting event.
resourceId
Type: System..::.Int32
Id of the resource being reserved with the event.
EventDescription
Type: System..::.String
Description of the event.
startDatetime
Type: System..::.DateTime
Date and Time when the event is going to start. (Converted to the Server's timezone).
endDatetime
Type: System..::.DateTime
Date and Time when the event is going to end. (Converted to the Server's timezone).
showAs
Type: OfficeClip.Utils..::.EventShowAs
Enumerated value EventShowAs determining the availablility of the user during the time period of the event. OfficeClip.Utils..::.EventShowAs
RepeatInfoText
Type: System..::.String
Textual string giving briefly describing the event and when it is going to take place.
repeatingSequenceId
Type: System..::.Int32
The unique id assigned to a set of repeating events.
docIdList
Type: System..::.String
Ids of the documents (comma separated) created and attached along with the event using the docattach.ascx control.
EventUserId
Type: System..::.Int32
The user id of the event creator
labelId
Type: System..::.Int32
The label Id
parentObjectType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
the object type of the parent
parentObjectId
Type: System..::.Int32
The parent object id
createdByUserId
Type: System..::.Int32
The user id of the user that has created the event
modifiedTime
Type: System..::.DateTime%
The time this event is modified
groupId
Type: System..::.Int32
the unique id of the organization

Return Value

Id of the newly created event, -1 in case there is an error.

See Also

CalendarDB Class
InsertEvent Overload
OfficeClip.DBLayer.Desktop Namespace


InsertEvent Method (EventInfo, ConfigureInfo, DateTime)

[image]

OfficeClip API Documentation
CalendarDB..::.InsertEvent Method (EventInfo, ConfigureInfo, DateTime%)
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new event or a set of new repeating events into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertEvent(
    EventInfo ei,
    ConfigureInfo session,
    ref DateTime modifiedTime
)
Visual Basic (Declaration)
Public Function InsertEvent ( _
    ei As EventInfo, _
    session As ConfigureInfo, _
    ByRef modifiedTime As DateTime _
) As Integer
Visual C++
public:
int InsertEvent(
    EventInfo^ ei,
    ConfigureInfo^ session,
    DateTime% modifiedTime
)

Parameters

ei
Type: OfficeClip.BusinessLayer.Desktop..::.EventInfo
Instance of the EventInfo object containing all the detailed information about the event.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session
modifiedTime
Type: System..::.DateTime%
The time of last modification

Return Value

Id of the newly created event if successful, -1 in case of an error.

See Also

CalendarDB Class
InsertEvent Overload
OfficeClip.DBLayer.Desktop Namespace
OfficeClip.BusinessLayer.Desktop..::.EventInfo


InsertMeetingAttendees Method

[image]

OfficeClip API Documentation
CalendarDB..::.InsertMeetingAttendees Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the meeting attendees of an event into the database and sends a notification about the meeting to all the attendees.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertMeetingAttendees(
    EventInfo ei,
    bool isFromUpdate,
    int indx,
    bool sendEmailOnUpdate,
    TimeZoneInfo serverTz,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function InsertMeetingAttendees ( _
    ei As EventInfo, _
    isFromUpdate As Boolean, _
    indx As Integer, _
    sendEmailOnUpdate As Boolean, _
    serverTz As TimeZoneInfo, _
    userId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int InsertMeetingAttendees(
    EventInfo^ ei,
    bool isFromUpdate,
    int indx,
    bool sendEmailOnUpdate,
    TimeZoneInfo^ serverTz,
    int userId,
    int groupId
)

Parameters

ei
Type: OfficeClip.BusinessLayer.Desktop..::.EventInfo
Instance of an EventInfo object containing all the meeting attendees.
isFromUpdate
Type: System..::.Boolean
Flag (True/False) indicating whether this method is called from Update of an event.
indx
Type: System..::.Int32
Sequential Index corresponding each of the repeating event.
sendEmailOnUpdate
Type: System..::.Boolean
Shows whether the email needs to be sent on event update.
serverTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The timezone of the server
userId
Type: System..::.Int32
The unique id of the current user
groupId
Type: System..::.Int32
The unique id of the organization

Return Value

0 if successful, -1 in case of an error.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertUserAvailability Method

[image]

OfficeClip API Documentation
CalendarDB..::.InsertUserAvailability Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the user availability information corresponding to an event for the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertUserAvailability(
    int eventId,
    DateTime startDateTime,
    DateTime endDateTime,
    EventShowAs showAs,
    int EventUserId
)
Visual Basic (Declaration)
Public Function InsertUserAvailability ( _
    eventId As Integer, _
    startDateTime As DateTime, _
    endDateTime As DateTime, _
    showAs As EventShowAs, _
    EventUserId As Integer _
) As Integer
Visual C++
public:
int InsertUserAvailability(
    int eventId,
    DateTime startDateTime,
    DateTime endDateTime,
    EventShowAs showAs,
    int EventUserId
)

Parameters

eventId
Type: System..::.Int32
Id of the event for which the user availability has to be inserted.
startDateTime
Type: System..::.DateTime
Date and Time when the event is going to start. (Converted to Server's Timezone).
endDateTime
Type: System..::.DateTime
Date and Time when the event is going to end. (Converted to Server's Timezone).
showAs
Type: OfficeClip.Utils..::.EventShowAs
Enumerated value of EventShowAs determining what kind of availability has to be displayed for the user for time period of the event. The user id of the event creatorOfficeClip.Utils..::.EventShowAs
EventUserId
Type: System..::.Int32

Return Value

0 if successful, -1 in case of an error.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


RejectRsvp Method

[image]

OfficeClip API Documentation
CalendarDB..::.RejectRsvp Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Rejects the RSVP for a particular user for a particular event.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RejectRsvp(
    int userId,
    int eventId
)
Visual Basic (Declaration)
Public Function RejectRsvp ( _
    userId As Integer, _
    eventId As Integer _
) As Integer
Visual C++
public:
int RejectRsvp(
    int userId,
    int eventId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
eventId
Type: System..::.Int32
Id of the event for which the user wants to set the RSVP status.

Return Value

0 if successful, -1 in case of an error

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


ResolveAvailabilityConflict Method

[image]

OfficeClip API Documentation
CalendarDB..::.ResolveAvailabilityConflict Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void ResolveAvailabilityConflict(
    ref string currentAvail,
    string newAvail
)
Visual Basic (Declaration)
Protected Sub ResolveAvailabilityConflict ( _
    ByRef currentAvail As String, _
    newAvail As String _
)
Visual C++
protected:
void ResolveAvailabilityConflict(
    String^% currentAvail,
    String^ newAvail
)

Parameters

currentAvail
Type: System..::.String%
newAvail
Type: System..::.String

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


SendRsvpToTheGroup Method

[image]

OfficeClip API Documentation
CalendarDB..::.SendRsvpToTheGroup Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends an RSVP to all the group members of a group for an event.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendRsvpToTheGroup(
    int eventId,
    string eventName,
    DateTime startDatetime,
    string url,
    int groupId,
    TimeZoneInfo serverTz,
    int userId
)
Visual Basic (Declaration)
Public Function SendRsvpToTheGroup ( _
    eventId As Integer, _
    eventName As String, _
    startDatetime As DateTime, _
    url As String, _
    groupId As Integer, _
    serverTz As TimeZoneInfo, _
    userId As Integer _
) As Integer
Visual C++
public:
int SendRsvpToTheGroup(
    int eventId,
    String^ eventName,
    DateTime startDatetime,
    String^ url,
    int groupId,
    TimeZoneInfo^ serverTz,
    int userId
)

Parameters

eventId
Type: System..::.Int32
Id of the event.
eventName
Type: System..::.String
Name of the event.
startDatetime
Type: System..::.DateTime
Date and Time when the event is going to start.
url
Type: System..::.String
Url of the web page giving additional information about the event or otherwise information related to the event.
groupId
Type: System..::.Int32
The unique id of the organization
serverTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The server timezone
userId
Type: System..::.Int32
The unique id of the current user

Return Value

0 when successful, -1 in case of an error.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
CalendarDB..::.SetSPCommand Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

CalendarDB Class
CalendarDB Members
OfficeClip.DBLayer.Desktop Namespace


UpdateEvent Method

[image]

OfficeClip API Documentation
CalendarDB..::.UpdateEvent Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates back the information related to a particular event into the database for a particular user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateEvent(
    EventInfo ei,
    ConfigureInfo session,
    ref DateTime lastModifiedTime
)
Visual Basic (Declaration)
Public Function UpdateEvent ( _
    ei As EventInfo, _
    session As ConfigureInfo, _
    ByRef lastModifiedTime As DateTime _
) As Integer
Visual C++
public:
int UpdateEvent(
    EventInfo^ ei,
    ConfigureInfo^ session,
    DateTime% lastModifiedTime
)

Parameters

ei
Type: OfficeClip.BusinessLayer.Desktop..::.EventInfo
Instance of EventInfo object containing all the information related to a particular event. EventInfo
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session
lastModifiedTime
Type: System..::.DateTime%
The time of last modification

Return Value

Id of the event being updated if successful, otherwise -1.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateEvent1 Method

[image]

OfficeClip API Documentation
CalendarDB..::.UpdateEvent1 Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates back the information related to a particular event into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected int UpdateEvent1(
    EventInfo ei,
    ConfigureInfo session,
    ref DateTime lastModifiedTime
)
Visual Basic (Declaration)
Protected Function UpdateEvent1 ( _
    ei As EventInfo, _
    session As ConfigureInfo, _
    ByRef lastModifiedTime As DateTime _
) As Integer
Visual C++
protected:
int UpdateEvent1(
    EventInfo^ ei,
    ConfigureInfo^ session,
    DateTime% lastModifiedTime
)

Parameters

ei
Type: OfficeClip.BusinessLayer.Desktop..::.EventInfo
Instance of EventInfo object containing all the information related to a particular event. EventInfo
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session
lastModifiedTime
Type: System..::.DateTime%
The time of last modification

Return Value

Id of the event being updated if successful, otherwise -1.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateEventParent Method

[image]

OfficeClip API Documentation
CalendarDB..::.UpdateEventParent Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the event parent

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateEventParent(
    int eventId,
    BusinessConstants..::.ObjectType pType,
    int parentId
)
Visual Basic (Declaration)
Public Sub UpdateEventParent ( _
    eventId As Integer, _
    pType As BusinessConstants..::.ObjectType, _
    parentId As Integer _
)
Visual C++
public:
void UpdateEventParent(
    int eventId,
    BusinessConstants..::.ObjectType pType,
    int parentId
)

Parameters

eventId
Type: System..::.Int32
The unique id of the event
pType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type
parentId
Type: System..::.Int32
The unique id of the parent

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateMeetingAttendees Method

[image]

OfficeClip API Documentation
CalendarDB..::.UpdateMeetingAttendees Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the meeting attendees information into the database. This method should generally be called while updating event information.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateMeetingAttendees(
    EventInfo ei,
    ArrayList oldMeetingAttendeeList,
    bool sendEmailOnUpdate,
    TimeZoneInfo serverTz,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function UpdateMeetingAttendees ( _
    ei As EventInfo, _
    oldMeetingAttendeeList As ArrayList, _
    sendEmailOnUpdate As Boolean, _
    serverTz As TimeZoneInfo, _
    userId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int UpdateMeetingAttendees(
    EventInfo^ ei,
    ArrayList^ oldMeetingAttendeeList,
    bool sendEmailOnUpdate,
    TimeZoneInfo^ serverTz,
    int userId,
    int groupId
)

Parameters

ei
Type: OfficeClip.BusinessLayer.Desktop..::.EventInfo
Instance of an EventInfo object containing all the meeting attendees.
oldMeetingAttendeeList
Type: System.Collections..::.ArrayList
ArrayList of MeetingAttendeeInfo objects. OfficeClip.BusinessLayer.Desktop..::.MeetingAttendeeInfo
sendEmailOnUpdate
Type: System..::.Boolean
Determines if the email is sent on update
serverTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The timezone of the server
userId
Type: System..::.Int32
The unique id of the current user
groupId
Type: System..::.Int32
The unique id of the organization

Return Value

0 if successful, -1 in case of an error.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateReadOnlyEvent Method

[image]

OfficeClip API Documentation
CalendarDB..::.UpdateReadOnlyEvent Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Provides the ability to update the readonly event, only the busy/free schedule and the reminder settings can be updated in this way

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateReadOnlyEvent(
    int id,
    int EventUserId,
    string whenToRemind,
    string whoToRemind,
    EventShowAs showAs,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateReadOnlyEvent ( _
    id As Integer, _
    EventUserId As Integer, _
    whenToRemind As String, _
    whoToRemind As String, _
    showAs As EventShowAs, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int UpdateReadOnlyEvent(
    int id,
    int EventUserId,
    String^ whenToRemind,
    String^ whoToRemind,
    EventShowAs showAs,
    ConfigureInfo^ session
)

Parameters

id
Type: System..::.Int32
The unique id of the event
EventUserId
Type: System..::.Int32
The id of the user for whom the event was originally created
whenToRemind
Type: System..::.String
When the events is required to be reminded
whoToRemind
Type: System..::.String
Who needs to be reminded for this event
showAs
Type: OfficeClip.Utils..::.EventShowAs
How the free/busy schedule will be shown as
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session

Return Value

eventid if success, -1 if error

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateUserAvailability Method

[image]

OfficeClip API Documentation
CalendarDB..::.UpdateUserAvailability Method
CalendarDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the user availability information corresponding to an event for a particular user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateUserAvailability(
    int eventId,
    int userId,
    DateTime startDateTime,
    DateTime endDateTime,
    EventShowAs showAs
)
Visual Basic (Declaration)
Public Function UpdateUserAvailability ( _
    eventId As Integer, _
    userId As Integer, _
    startDateTime As DateTime, _
    endDateTime As DateTime, _
    showAs As EventShowAs _
) As Integer
Visual C++
public:
int UpdateUserAvailability(
    int eventId,
    int userId,
    DateTime startDateTime,
    DateTime endDateTime,
    EventShowAs showAs
)

Parameters

eventId
Type: System..::.Int32
Id of the event for which the user availability has to be inserted.
userId
Type: System..::.Int32
Id of the user whose availability has to be set.
startDateTime
Type: System..::.DateTime
Date and Time when the event is going to start. (Converted to Server's Timezone).
endDateTime
Type: System..::.DateTime
Date and Time when the event is going to end. (Converted to Server's Timezone).
showAs
Type: OfficeClip.Utils..::.EventShowAs
Enumerated value of EventShowAs determining what kind of availability has to be displayed for the user for time period of the event. OfficeClip.Utils..::.EventShowAs

Return Value

0 if successful, -1 in case of an error.

See Also

CalendarDB Class
OfficeClip.DBLayer.Desktop Namespace


DocumentDB Class

[image]

OfficeClip API Documentation
DocumentDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Summary description for DocumentDB

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class DocumentDB : OfficeClipDB
Visual Basic (Declaration)
Public Class DocumentDB _
    Inherits OfficeClipDB
Visual C++
public ref class DocumentDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Desktop..::.DocumentDB

See Also

DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


DocumentDB Members

[image] [image]

OfficeClip API Documentation
DocumentDB Members
DocumentDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The DocumentDB type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | CheckDocumentSets | Checks the document (or folder) set and make sure that the operation that is supposed to be done on this set is allowed. The output status is flagged on the datatable.--------------------------------------------------------
Public method | CheckGroupApplicationFolder | Checks whether the application area folder is created corresponding to a particular application for a particular group. If the folder does not already exist, it is created.
Public method | CheckPreInsert | Overloaded.
Public method | CheckUserApplicationFolder | Checks whether the application area folder is created corresponding to a particular application for a particular user. If the folder does not already exist, it is created.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Copy | This function copies file from one folder to another.
Protected method | CopyFile | Copies the file into the file system.
Public method | CreateNewFolder | Creates a new folder for a particular group/user.
Public method | DeleteDocumentDB | Deletes the record corresponding to the document identified by documentId in the database and returns the file name of that document.
Public method | DeleteFolderDB | Deletes the record for a particular user corresponding to the folder identified by folderId in the database.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Protected method | DocumentRenameFilesystem |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAddressLinks |
Public method | GetApplicationFolderId | Gets the folder id corresponding to the application folder for either a user or a group.
Public method | GetApplicationInfo | Gets all the information related to those documents in the document management system which are being attached with other OfficeClip applications for a particular group.
Public method | GetAttachedDocs | Gets all the documents attached to an item inside a particular folder.
Public method | GetDiskSpaceUsed | Gets the used disk space for the current account
Public method | GetDiskSpaceUsedForAccount | Gets the used disk space for an account
Public method | GetDocumentInfo | Gets the document related information for a particular document identified by documentId.
Public method | GetDocumentInfoFromDocList | Gets document information based on document comma separated id list
Public method | GetDocumentName | Gets a delimited name of all documents.
Public method | GetDocumentSendInfo | Shows the documents which are passed to the user via email using the id
Public method | getFldDocs | Gets the document details for the folder
Public method | getFolderDocs | Gets the contents of a folder, then returns True/False if the folder is empty or not.
Protected method | getFolderDocuments | Gets the document details for the folder
Public method | GetFolderInfo | Gets the folder related information for a particular folder identified by folderId.
Public method | GetGroupSpace | Gets the space related to a group. If the group space information is not present, then it is created using default value specified in web.config.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetHistory | Returns the history of all the operations performed on the document.
Public method | GetItemDocs | Gets all documents attached to a another OfficeClip object. For example, timesheet, expense or tracker case.
Public method | GetLatestRevision | Gets the latest revision of a particular document.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetSharedDocuments | Gets the shared documents for a particular user and for a particular group.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSpace | Gets the space related to a particular user. If the user space information is not present, then it is created using default value specified in web.config.
Public method | GetVirtualFolder | Gets the virtual folder path
Public method | GetVirtualFolderForApplication |
Public method | GetVirtualFolderOld | Overloaded.
Public method | GetVirtualPath | Overloaded.
Public method | HasEnoughDiskSpace | Checks if there is enough disk space
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertDocumentHistory | Inserts an entry in the document history table.
Public method | InsertFileAndDocument | Inserts a document in a folder
Public method | IsDocumentPresent | Checks if a particular document is present.
Public method | IsPostedFileValid | Check if the file represented by the posted (uploaded) file is sytactically valid.
Public method | MarkDocumentActive | Mark all the documents as Active for deletion whose comma delimited list of document ids is being passed as argument and also set the new folder name (instead of -negative random).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAllItemDocs | Deletes all documents attached to a another OfficeClip object. For example, timesheet, expense or tracker case.
Public method | RemoveAttachment | Removes the Attachment document attached to another OfficeClip object.
Public method | RemoveAttachmentIfTemp | Remove the Attachment if it is marked as temp.
Public method | RemoveAttachments | Remove the Attachments identified by the list of comma separated document ids
Public method | RemoveDocument | Overloaded.
Public method | RemoveFolder | Removes the folder and all the associated documents
Public method | RemoveShare | Removes the set of share from the system
Public method | RenameDocument | Renames the documents of the document set
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | Search | Gets the search result from the database using a particular group and a particular user.
Public method | SetLock | Sets a lock on a particular document by the currently logged in user.
Public method | SetLockDownload | Sets lock and Download status on a particular document for the currently logged in user.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetUnlock | Unlocks a particular document by a particular user.
Public method | SetupGroupApplicationFolder | Intializes the folder information in the database with default space related information and also creates a folder for group's application related documents. Does nothing if intialization has already taken place.
Public method | SetupInitialFolders | Sets up the initial folders
Public method | SetupUserApplicationFolder | Intializes the folder information in the database with default space related information and also creates a folder for currently logged in users's application related documents. Does nothing if intialization has already taken place.
Public method | SetViewDownload | Sets view and download status on a particular document for the currently logged in user.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDocumentStorage | Updates all the document storage information for the a user or the group. based on the information in the DocumentStorageInfo object.
Public method | UpdateKeywordDescription |

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


DocumentDB Constructor

[image] [image]

OfficeClip API Documentation
DocumentDB Constructor
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | DocumentDB()()() | Constructor
Public method | DocumentDB(Boolean) | Constructor
Public method | DocumentDB(OfficeClipDB) | Constructor

See Also

DocumentDB Class
DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


DocumentDB Constructor

[image]

OfficeClip API Documentation
DocumentDB Constructor
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentDB()

See Also

DocumentDB Class
DocumentDB Overload
OfficeClip.DBLayer.Desktop Namespace


DocumentDB Constructor (Boolean)

[image]

OfficeClip API Documentation
DocumentDB Constructor (Boolean)
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentDB(
    bool isSync
)
Visual Basic (Declaration)
Public Sub New ( _
    isSync As Boolean _
)
Visual C++
public:
DocumentDB(
    bool isSync
)

Parameters

isSync
Type: System..::.Boolean

See Also

DocumentDB Class
DocumentDB Overload
OfficeClip.DBLayer.Desktop Namespace


DocumentDB Constructor (OfficeClipDB)

[image]

OfficeClip API Documentation
DocumentDB Constructor (OfficeClipDB)
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentDB(
    OfficeClipDB ma
)
Visual Basic (Declaration)
Public Sub New ( _
    ma As OfficeClipDB _
)
Visual C++
public:
DocumentDB(
    OfficeClipDB^ ma
)

Parameters

ma
Type: OfficeClip.DBLayer..::.OfficeClipDB

See Also

DocumentDB Class
DocumentDB Overload
OfficeClip.DBLayer.Desktop Namespace


DocumentDB Methods

[image] [image]

OfficeClip API Documentation
DocumentDB Methods
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

The DocumentDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | CheckDocumentSets | Checks the document (or folder) set and make sure that the operation that is supposed to be done on this set is allowed. The output status is flagged on the datatable.--------------------------------------------------------
Public method | CheckGroupApplicationFolder | Checks whether the application area folder is created corresponding to a particular application for a particular group. If the folder does not already exist, it is created.
Public method | CheckPreInsert | Overloaded.
Public method | CheckUserApplicationFolder | Checks whether the application area folder is created corresponding to a particular application for a particular user. If the folder does not already exist, it is created.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Copy | This function copies file from one folder to another.
Protected method | CopyFile | Copies the file into the file system.
Public method | CreateNewFolder | Creates a new folder for a particular group/user.
Public method | DeleteDocumentDB | Deletes the record corresponding to the document identified by documentId in the database and returns the file name of that document.
Public method | DeleteFolderDB | Deletes the record for a particular user corresponding to the folder identified by folderId in the database.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Protected method | DocumentRenameFilesystem |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAddressLinks |
Public method | GetApplicationFolderId | Gets the folder id corresponding to the application folder for either a user or a group.
Public method | GetApplicationInfo | Gets all the information related to those documents in the document management system which are being attached with other OfficeClip applications for a particular group.
Public method | GetAttachedDocs | Gets all the documents attached to an item inside a particular folder.
Public method | GetDiskSpaceUsed | Gets the used disk space for the current account
Public method | GetDiskSpaceUsedForAccount | Gets the used disk space for an account
Public method | GetDocumentInfo | Gets the document related information for a particular document identified by documentId.
Public method | GetDocumentInfoFromDocList | Gets document information based on document comma separated id list
Public method | GetDocumentName | Gets a delimited name of all documents.
Public method | GetDocumentSendInfo | Shows the documents which are passed to the user via email using the id
Public method | getFldDocs | Gets the document details for the folder
Public method | getFolderDocs | Gets the contents of a folder, then returns True/False if the folder is empty or not.
Protected method | getFolderDocuments | Gets the document details for the folder
Public method | GetFolderInfo | Gets the folder related information for a particular folder identified by folderId.
Public method | GetGroupSpace | Gets the space related to a group. If the group space information is not present, then it is created using default value specified in web.config.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetHistory | Returns the history of all the operations performed on the document.
Public method | GetItemDocs | Gets all documents attached to a another OfficeClip object. For example, timesheet, expense or tracker case.
Public method | GetLatestRevision | Gets the latest revision of a particular document.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetSharedDocuments | Gets the shared documents for a particular user and for a particular group.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserSpace | Gets the space related to a particular user. If the user space information is not present, then it is created using default value specified in web.config.
Public method | GetVirtualFolder | Gets the virtual folder path
Public method | GetVirtualFolderForApplication |
Public method | GetVirtualFolderOld | Overloaded.
Public method | GetVirtualPath | Overloaded.
Public method | HasEnoughDiskSpace | Checks if there is enough disk space
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertDocumentHistory | Inserts an entry in the document history table.
Public method | InsertFileAndDocument | Inserts a document in a folder
Public method | IsDocumentPresent | Checks if a particular document is present.
Public method | IsPostedFileValid | Check if the file represented by the posted (uploaded) file is sytactically valid.
Public method | MarkDocumentActive | Mark all the documents as Active for deletion whose comma delimited list of document ids is being passed as argument and also set the new folder name (instead of -negative random).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveAllItemDocs | Deletes all documents attached to a another OfficeClip object. For example, timesheet, expense or tracker case.
Public method | RemoveAttachment | Removes the Attachment document attached to another OfficeClip object.
Public method | RemoveAttachmentIfTemp | Remove the Attachment if it is marked as temp.
Public method | RemoveAttachments | Remove the Attachments identified by the list of comma separated document ids
Public method | RemoveDocument | Overloaded.
Public method | RemoveFolder | Removes the folder and all the associated documents
Public method | RemoveShare | Removes the set of share from the system
Public method | RenameDocument | Renames the documents of the document set
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | Search | Gets the search result from the database using a particular group and a particular user.
Public method | SetLock | Sets a lock on a particular document by the currently logged in user.
Public method | SetLockDownload | Sets lock and Download status on a particular document for the currently logged in user.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetUnlock | Unlocks a particular document by a particular user.
Public method | SetupGroupApplicationFolder | Intializes the folder information in the database with default space related information and also creates a folder for group's application related documents. Does nothing if intialization has already taken place.
Public method | SetupInitialFolders | Sets up the initial folders
Public method | SetupUserApplicationFolder | Intializes the folder information in the database with default space related information and also creates a folder for currently logged in users's application related documents. Does nothing if intialization has already taken place.
Public method | SetViewDownload | Sets view and download status on a particular document for the currently logged in user.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDocumentStorage | Updates all the document storage information for the a user or the group. based on the information in the DocumentStorageInfo object.
Public method | UpdateKeywordDescription |

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
DocumentDB..::.AddOutputParameter Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

DocumentDB Class
DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
DocumentDB..::.AddParameter Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

DocumentDB Class
DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
DocumentDB..::.AddParameters Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

DocumentDB Class
DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


CheckDocumentSets Method

[image]

OfficeClip API Documentation
DocumentDB..::.CheckDocumentSets Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks the document (or folder) set and make sure that the operation that is supposed to be done on this set is allowed. The output status is flagged on the datatable.--------------------------------------------------------

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable CheckDocumentSets(
    string fids,
    string dids,
    bool isRecursive,
    bool isDeleteCheck,
    bool isSrcGroupFolder,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function CheckDocumentSets ( _
    fids As String, _
    dids As String, _
    isRecursive As Boolean, _
    isDeleteCheck As Boolean, _
    isSrcGroupFolder As Boolean, _
    session As ConfigureInfo _
) As DataTable
Visual C++
public:
DataTable^ CheckDocumentSets(
    String^ fids,
    String^ dids,
    bool isRecursive,
    bool isDeleteCheck,
    bool isSrcGroupFolder,
    ConfigureInfo^ session
)

Parameters

fids
Type: System..::.String
A list of all the folder ids as obtained from the screen.
dids
Type: System..::.String
A list of all the document ids as obtained from the screen.
isRecursive
Type: System..::.Boolean
Recurse the folder if true
isDeleteCheck
Type: System..::.Boolean
If the delete operation is checked.
isSrcGroupFolder
Type: System..::.Boolean
Flag (True/False) indicating whether the source of the ids is a group folder.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session object

Return Value

The datatable having the following elements
  • docIdThe id of the document, -1 if it is not a document
  • folderIdThe id of the folder, -1 if it is not a folder
  • isErrorTrue if there is an error
  • docNameThe name of the document, empty if not a document
  • folderNameThe name of the folder, empty if it is not a folder
  • docKeyThe keyword associated with the document
  • docDescThe Description associated with the document
  • CommentsAny Comments, can be used to send back the error message

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


CheckGroupApplicationFolder Method

[image]

OfficeClip API Documentation
DocumentDB..::.CheckGroupApplicationFolder Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks whether the application area folder is created corresponding to a particular application for a particular group. If the folder does not already exist, it is created.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string CheckGroupApplicationFolder(
    int userId,
    int groupId,
    int applicationId
)
Visual Basic (Declaration)
Public Function CheckGroupApplicationFolder ( _
    userId As Integer, _
    groupId As Integer, _
    applicationId As Integer _
) As String
Visual C++
public:
String^ CheckGroupApplicationFolder(
    int userId,
    int groupId,
    int applicationId
)

Parameters

userId
Type: System..::.Int32
Unique id of the user.
groupId
Type: System..::.Int32
Id of the group for which the application area folder is being checked and created.
applicationId
Type: System..::.Int32
Id of the application whose application area folder is being checked and created.

Return Value

Absolute disk path as mapped from virtual directory path of the application area folder for the respective group.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


CheckPreInsert Method

[image] [image]

OfficeClip API Documentation
DocumentDB..::.CheckPreInsert Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | CheckPreInsert(Int32, Int32) | Checks the preinsert condition for the folder
Public method | CheckPreInsert(Int32, Boolean, Int32, Int32, HttpPostedFile, String%, Int32, Boolean) | Check if the document can be inserted in the folder for a particular group.

See Also

DocumentDB Class
DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


CheckPreInsert Method (Int32, Int32)

[image]

OfficeClip API Documentation
DocumentDB..::.CheckPreInsert Method (Int32, Int32)
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks the preinsert condition for the folder

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStatus..::.DocumentPreInsertStatus CheckPreInsert(
    int destFolderId,
    int srcFolderId
)
Visual Basic (Declaration)
Public Function CheckPreInsert ( _
    destFolderId As Integer, _
    srcFolderId As Integer _
) As DocumentStatus..::.DocumentPreInsertStatus
Visual C++
public:
DocumentStatus..::.DocumentPreInsertStatus CheckPreInsert(
    int destFolderId,
    int srcFolderId
)

Parameters

destFolderId
Type: System..::.Int32
Id of the destination folder.
srcFolderId
Type: System..::.Int32
Id of the source folder.

Return Value

The document status

See Also

DocumentDB Class
CheckPreInsert Overload
OfficeClip.DBLayer.Desktop Namespace


CheckPreInsert Method (Int32, Boolean, Int32, Int32, HttpPostedFile, String, Int32, Boolean)

[image]

OfficeClip API Documentation
DocumentDB..::.CheckPreInsert Method (Int32, Boolean, Int32, Int32, HttpPostedFile, String%, Int32, Boolean)
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Check if the document can be inserted in the folder for a particular group.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStatus..::.DocumentPreInsertStatus CheckPreInsert(
    int userId,
    bool isAdmin,
    int groupId,
    int folderId,
    HttpPostedFile postedFile,
    ref string retStr,
    int srcDocumentId,
    bool isMove
)
Visual Basic (Declaration)
Public Function CheckPreInsert ( _
    userId As Integer, _
    isAdmin As Boolean, _
    groupId As Integer, _
    folderId As Integer, _
    postedFile As HttpPostedFile, _
    ByRef retStr As String, _
    srcDocumentId As Integer, _
    isMove As Boolean _
) As DocumentStatus..::.DocumentPreInsertStatus
Visual C++
public:
DocumentStatus..::.DocumentPreInsertStatus CheckPreInsert(
    int userId,
    bool isAdmin,
    int groupId,
    int folderId,
    HttpPostedFile^ postedFile,
    String^% retStr,
    int srcDocumentId,
    bool isMove
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
isAdmin
Type: System..::.Boolean
Flag (True/False) indicating whether the user (whose userId, is passed as argument) is an admin or not.
groupId
Type: System..::.Int32
Id of the group.
folderId
Type: System..::.Int32
The id of the folder where is document is to be inserted.
postedFile
Type: System.Web..::.HttpPostedFile
The posted file, if this is non-null then srcFolderId should be -1.
retStr
Type: System..::.String%
A meaningful return string depending on the error code
srcDocumentId
Type: System..::.Int32
The source document id which will need to be transferred, this can be used in lieu of postedFile, if this is used, postedFile should be passed as null. This variable is useful when you are moving or copying files.
isMove
Type: System..::.Boolean
Flag indicating whether it is a move or copy operation. This parameter is valid only if the srcDocumentId is a non empty string.

Return Value

Enumerated value DocumentPreInsertStatus indicating if the operation succeeded or failed.

See Also

DocumentDB Class
CheckPreInsert Overload
OfficeClip.DBLayer.Desktop Namespace


CheckUserApplicationFolder Method

[image]

OfficeClip API Documentation
DocumentDB..::.CheckUserApplicationFolder Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks whether the application area folder is created corresponding to a particular application for a particular user. If the folder does not already exist, it is created.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string CheckUserApplicationFolder(
    int applicationId,
    int userId
)
Visual Basic (Declaration)
Public Function CheckUserApplicationFolder ( _
    applicationId As Integer, _
    userId As Integer _
) As String
Visual C++
public:
String^ CheckUserApplicationFolder(
    int applicationId,
    int userId
)

Parameters

applicationId
Type: System..::.Int32
Id of the application whose application area folder is being checked and created.
userId
Type: System..::.Int32
Id of the user for which the application area folder is being checked and created.

Return Value

Absolute disk path as mapped from virtual directory path of the application area folder for the respective user.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


Copy Method

[image]

OfficeClip API Documentation
DocumentDB..::.Copy Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

This function copies file from one folder to another.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Copy(
    int userId,
    int groupId,
    int srcDocumentId,
    int destFolderId,
    int srcFolderId,
    string srcName,
    bool isVersion
)
Visual Basic (Declaration)
Public Function Copy ( _
    userId As Integer, _
    groupId As Integer, _
    srcDocumentId As Integer, _
    destFolderId As Integer, _
    srcFolderId As Integer, _
    srcName As String, _
    isVersion As Boolean _
) As Integer
Visual C++
public:
int Copy(
    int userId,
    int groupId,
    int srcDocumentId,
    int destFolderId,
    int srcFolderId,
    String^ srcName,
    bool isVersion
)

Parameters

userId
Type: System..::.Int32
The unique id of the user whose document has to be moved or copied.
groupId
Type: System..::.Int32
The unique id of the group whose document has to be moved or copied.
srcDocumentId
Type: System..::.Int32
The document-id of the source.
destFolderId
Type: System..::.Int32
The folder-id of the destination.
srcFolderId
Type: System..::.Int32
The id of the source folder
srcName
Type: System..::.String
The name of the source folder.
isVersion
Type: System..::.Boolean
Flag (True/False) indicating if a new version is created.

Return Value

The document id of the destination document if successful -1 otherwise.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


CopyFile Method

[image]

OfficeClip API Documentation
DocumentDB..::.CopyFile Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Copies the file into the file system.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void CopyFile(
    int srcFolderId,
    int destFolderId,
    int userId,
    int groupId,
    string fileName,
    int revision
)
Visual Basic (Declaration)
Protected Sub CopyFile ( _
    srcFolderId As Integer, _
    destFolderId As Integer, _
    userId As Integer, _
    groupId As Integer, _
    fileName As String, _
    revision As Integer _
)
Visual C++
protected:
void CopyFile(
    int srcFolderId,
    int destFolderId,
    int userId,
    int groupId,
    String^ fileName,
    int revision
)

Parameters

srcFolderId
Type: System..::.Int32
The id of the source folder.
destFolderId
Type: System..::.Int32
The folder-id of the destination.
userId
Type: System..::.Int32
The unique id of the user whose document has to be moved or copied.
groupId
Type: System..::.Int32
The unique id of the group whose document has to be moved or copied.
fileName
Type: System..::.String
The name of the file moved or copied into the file system.
revision
Type: System..::.Int32
The revision of the document.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


CreateNewFolder Method

[image]

OfficeClip API Documentation
DocumentDB..::.CreateNewFolder Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates a new folder for a particular group/user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int CreateNewFolder(
    int userId,
    int groupId,
    int parentFolderId,
    string folderName
)
Visual Basic (Declaration)
Public Function CreateNewFolder ( _
    userId As Integer, _
    groupId As Integer, _
    parentFolderId As Integer, _
    folderName As String _
) As Integer
Visual C++
public:
int CreateNewFolder(
    int userId,
    int groupId,
    int parentFolderId,
    String^ folderName
)

Parameters

userId
Type: System..::.Int32
If of the user creating the new folder.
groupId
Type: System..::.Int32
Id of the group for which the new folder has to be created.
parentFolderId
Type: System..::.Int32
The Parent folder id below which the new folder is created.
folderName
Type: System..::.String
The name of the new folder.

Return Value

The folder id of the new folder, -2 if the folder is already present, -1 any other error

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteDocumentDB Method

[image]

OfficeClip API Documentation
DocumentDB..::.DeleteDocumentDB Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the record corresponding to the document identified by documentId in the database and returns the file name of that document.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStatus..::.DocumentDeleteStatus DeleteDocumentDB(
    int documentId,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function DeleteDocumentDB ( _
    documentId As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
) As DocumentStatus..::.DocumentDeleteStatus
Visual C++
public:
DocumentStatus..::.DocumentDeleteStatus DeleteDocumentDB(
    int documentId,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

documentId
Type: System..::.Int32
Id of the document whose record has to be deleted in the database.
currentUserId
Type: System..::.Int32
Unique id of the current user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Enumerated value DocumentDeleteStatus indicating if the operation succeeded or failed. OfficeClip.BusinessLayer.Desktop..::.DocumentStatus..::.DocumentDeleteStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteFolderDB Method

[image]

OfficeClip API Documentation
DocumentDB..::.DeleteFolderDB Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the record for a particular user corresponding to the folder identified by folderId in the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStatus..::.DeleteFolderStatus DeleteFolderDB(
    int userId,
    bool isAdmin,
    int folderId,
    bool forceDelete
)
Visual Basic (Declaration)
Public Function DeleteFolderDB ( _
    userId As Integer, _
    isAdmin As Boolean, _
    folderId As Integer, _
    forceDelete As Boolean _
) As DocumentStatus..::.DeleteFolderStatus
Visual C++
public:
DocumentStatus..::.DeleteFolderStatus DeleteFolderDB(
    int userId,
    bool isAdmin,
    int folderId,
    bool forceDelete
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
isAdmin
Type: System..::.Boolean
Flag (True/False) indicating whether the user corresponding to the user id (in the argument) is an admin or not?
folderId
Type: System..::.Int32
Id of the folder whose record has to be deleted in the database.
forceDelete
Type: System..::.Boolean
Flag (True/False) indicating that if Child folder and documents exist, Delete them as well. If this value False and Child documents/folders exist, an error is returned.

Return Value

Enumerated value DeleteFolderStatus indicating if the operation succeeded or failed.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


DocumentRenameFilesystem Method

[image]

OfficeClip API Documentation
DocumentDB..::.DocumentRenameFilesystem Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected bool DocumentRenameFilesystem(
    string oldName,
    int id,
    bool isFolder,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Protected Function DocumentRenameFilesystem ( _
    oldName As String, _
    id As Integer, _
    isFolder As Boolean, _
    userId As Integer, _
    groupId As Integer _
) As Boolean
Visual C++
protected:
bool DocumentRenameFilesystem(
    String^ oldName,
    int id,
    bool isFolder,
    int userId,
    int groupId
)

Parameters

oldName
Type: System..::.String
The previous name of the document/folder.
id
Type: System..::.Int32
The unique id of the document/folder being renamed.
isFolder
Type: System..::.Boolean
Flag (True/False) indicating whether the document is a folder.
userId
Type: System..::.Int32
The unique id of the user whose document/folder is renamed.
groupId
Type: System..::.Int32
The unique id of the group whose document/folder is renamed.

Return Value

Flag (True/False) indicating the rename succeeded or not.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
DocumentDB..::.ExecuteNonQuery Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

DocumentDB Class
DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


GetAddressLinks Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetAddressLinks Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAddressLinks(
    int folderId
)
Visual Basic (Declaration)
Public Function GetAddressLinks ( _
    folderId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAddressLinks(
    int folderId
)

Parameters

folderId
Type: System..::.Int32
Id of the folder for which the virtual path is displayed as a link.

Return Value

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetApplicationFolderId Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetApplicationFolderId Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the folder id corresponding to the application folder for either a user or a group.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetApplicationFolderId(
    bool isPrivate,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetApplicationFolderId ( _
    isPrivate As Boolean, _
    userId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int GetApplicationFolderId(
    bool isPrivate,
    int userId,
    int groupId
)

Parameters

isPrivate
Type: System..::.Boolean
Flag (True/False) indicating whether the folderId being requested is that of the group or a user.
userId
Type: System..::.Int32
Id of the user whose application folder id is being retrieved. This field's value is ignored when isPrivate is False.
groupId
Type: System..::.Int32
Id of the group whose application folder id is being retrieved. This field's value is ignored when isPrivate is True.

Return Value

Id of the respective application folder.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetApplicationInfo Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetApplicationInfo Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to those documents in the document management system which are being attached with other OfficeClip applications for a particular group.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetApplicationInfo(
    int userId,
    int groupId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function GetApplicationInfo ( _
    userId As Integer, _
    groupId As Integer, _
    isAdmin As Boolean _
) As DataSet
Visual C++
public:
DataSet^ GetApplicationInfo(
    int userId,
    int groupId,
    bool isAdmin
)

Parameters

userId
Type: System..::.Int32
The unique id of the user. Please note that this user should belong to the group whose GroupId is passed in the next argument.
groupId
Type: System..::.Int32
Id of the group.
isAdmin
Type: System..::.Boolean
Shows if the logged in user is an administrator.

Return Value

DataSet containing all the information related to the documents attached with other OfficeClip application objects for e.g. Timesheets, Expenses, Tracker cases, Events etc. DataSet consists of a single DataTable with the following columns.
  • docId (System.Int32) Id of the document.
  • docName (System.String) Name of the document.
  • CreatedBy (System.String) Name of the user who created the document.
  • CreatedTimestamp (System.DateTime) Name of the user who created the document.
  • AppId (System.Int32) Id of the OfficeClip application with which this particular document is attached.
  • id1 (System.Int32) If of the OfficeClip object (in another application) with which this particular document is attached.
  • appName (System.String) Name of the OfficeClip Application with which this particular document is attached.
  • appsDesc (System.String) Description of this document set for the other applicaitons.
  • isPrivate (System.String) Flag (Y/N) indicating whether this is a group or private document.
  • sizeoffile (System.Double) Size of the document.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetAttachedDocs Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetAttachedDocs Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the documents attached to an item inside a particular folder.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAttachedDocs(
    string documentIds,
    bool isUserTz
)
Visual Basic (Declaration)
Public Function GetAttachedDocs ( _
    documentIds As String, _
    isUserTz As Boolean _
) As DataSet
Visual C++
public:
DataSet^ GetAttachedDocs(
    String^ documentIds,
    bool isUserTz
)

Parameters

documentIds
Type: System..::.String
Delimited list of documentIds
isUserTz
Type: System..::.Boolean
Flag (True/False) indicating whether it is the user's timezone.

Return Value

Dataset with all the necessary document information.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetDiskSpaceUsed Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetDiskSpaceUsed Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the used disk space for the current account

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus GetDiskSpaceUsed(
    int userId,
    ref double permittedSpace,
    ref double usedSpace
)
Visual Basic (Declaration)
Public Function GetDiskSpaceUsed ( _
    userId As Integer, _
    ByRef permittedSpace As Double, _
    ByRef usedSpace As Double _
) As ReturnStatus
Visual C++
public:
ReturnStatus GetDiskSpaceUsed(
    int userId,
    double% permittedSpace,
    double% usedSpace
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
permittedSpace
Type: System..::.Double%
The permitted space for the account
usedSpace
Type: System..::.Double%
The used space for the account

Return Value

The status that determines if the operation was successful

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetDiskSpaceUsedForAccount Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetDiskSpaceUsedForAccount Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the used disk space for an account

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus GetDiskSpaceUsedForAccount(
    int accountId,
    ref double permittedSpace,
    ref double usedSpace
)
Visual Basic (Declaration)
Public Function GetDiskSpaceUsedForAccount ( _
    accountId As Integer, _
    ByRef permittedSpace As Double, _
    ByRef usedSpace As Double _
) As ReturnStatus
Visual C++
public:
ReturnStatus GetDiskSpaceUsedForAccount(
    int accountId,
    double% permittedSpace,
    double% usedSpace
)

Parameters

accountId
Type: System..::.Int32
The database generated id of the account
permittedSpace
Type: System..::.Double%
The permitted space for the account
usedSpace
Type: System..::.Double%
The used space for the account

Return Value

The status that determines if the operation was successful

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetDocumentInfo Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetDocumentInfo Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the document related information for a particular document identified by documentId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentInfo GetDocumentInfo(
    int documentId
)
Visual Basic (Declaration)
Public Function GetDocumentInfo ( _
    documentId As Integer _
) As DocumentInfo
Visual C++
public:
DocumentInfo^ GetDocumentInfo(
    int documentId
)

Parameters

documentId
Type: System..::.Int32
Id of the document for which the information is being retrieved.

Return Value

Instance of the DocumentInfo object containing all the information related to a particular document. OfficeClip.BusinessLayer.Desktop..::.DocumentInfo

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetDocumentInfoFromDocList Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetDocumentInfoFromDocList Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets document information based on document comma separated id list

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetDocumentInfoFromDocList(
    string docList
)
Visual Basic (Declaration)
Public Function GetDocumentInfoFromDocList ( _
    docList As String _
) As DataTable
Visual C++
public:
DataTable^ GetDocumentInfoFromDocList(
    String^ docList
)

Parameters

docList
Type: System..::.String
A comma separated list of all the document ids.

Return Value

A comma delimited list of names of the documents.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetDocumentName Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetDocumentName Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a delimited name of all documents.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetDocumentName(
    string docList,
    string delimiter
)
Visual Basic (Declaration)
Public Function GetDocumentName ( _
    docList As String, _
    delimiter As String _
) As String
Visual C++
public:
String^ GetDocumentName(
    String^ docList,
    String^ delimiter
)

Parameters

docList
Type: System..::.String
A comma separated list of all the document ids.
delimiter
Type: System..::.String
The string delimiter.

Return Value

A comma delimited list of names of the documents.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetDocumentSendInfo Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetDocumentSendInfo Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Shows the documents which are passed to the user via email using the id

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetDocumentSendInfo(
    int docSendId
)
Visual Basic (Declaration)
Public Function GetDocumentSendInfo ( _
    docSendId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetDocumentSendInfo(
    int docSendId
)

Parameters

docSendId
Type: System..::.Int32
The id to retrieve the documents

Return Value

DataSet containing all the document related information. DataSet contains a single DataTable with the following columns.
  • retCode (System.String) Return code.
  • emailAddress (System.String) Email Address of the person to whom the link is to be sent.
  • urlId (System.String) Unique id in the url
  • docId (System.Int32) Id of the document.
  • docName (System.String) Name of the document.
  • docSize (System.Double) Size of the document.
  • CreatedDate (System.DateTime) Date and Time when the document was created.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


getFldDocs Method

[image]

OfficeClip API Documentation
DocumentDB..::.getFldDocs Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the document details for the folder

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SqlDataReader getFldDocs(
    int folderId
)
Visual Basic (Declaration)
Public Function getFldDocs ( _
    folderId As Integer _
) As SqlDataReader
Visual C++
public:
SqlDataReader^ getFldDocs(
    int folderId
)

Parameters

folderId
Type: System..::.Int32
The id of the folder

Return Value

The following values are returned with the following columns.
  • docName (System.String) Name of the document.
  • docId (System.Int32) Id of the document.
  • createdId (System.Int32) Id of the user who created the document.

Remarks

Make sure to Close the SqlDataReader after the use otherwise it will leave and connection open (till garbage collector releases the Data Reader). If not closed explicitly, the .Net framework might hang and slow down because of the number of open connections Limit might be reached.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


getFolderDocs Method

[image]

OfficeClip API Documentation
DocumentDB..::.getFolderDocs Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the contents of a folder, then returns True/False if the folder is empty or not.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool getFolderDocs(
    int folderId
)
Visual Basic (Declaration)
Public Function getFolderDocs ( _
    folderId As Integer _
) As Boolean
Visual C++
public:
bool getFolderDocs(
    int folderId
)

Parameters

folderId
Type: System..::.Int32
The id of the folder.

Return Value

Flag (True/False)

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


getFolderDocuments Method

[image]

OfficeClip API Documentation
DocumentDB..::.getFolderDocuments Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the document details for the folder

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected SqlDataReader getFolderDocuments(
    int folderId
)
Visual Basic (Declaration)
Protected Function getFolderDocuments ( _
    folderId As Integer _
) As SqlDataReader
Visual C++
protected:
SqlDataReader^ getFolderDocuments(
    int folderId
)

Parameters

folderId
Type: System..::.Int32
The id of the folder

Return Value

The following values are returned with the following columns.
  • docName (System.String) Name of the document.
  • docId (System.Int32) Id of the document.
  • createdId (System.Int32) Id of the user who created the document.

Remarks

Make sure to Close the SqlDataReader after the use otherwise it will leave and connection open (till garbage collector releases the Data Reader). If not closed explicitly, the .Net framework might hang and slow down because of the number of open connections Limit might be reached.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetFolderInfo Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetFolderInfo Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the folder related information for a particular folder identified by folderId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public FolderInfo GetFolderInfo(
    int folderId
)
Visual Basic (Declaration)
Public Function GetFolderInfo ( _
    folderId As Integer _
) As FolderInfo
Visual C++
public:
FolderInfo^ GetFolderInfo(
    int folderId
)

Parameters

folderId
Type: System..::.Int32
Id of the folder for which the information is being retrieved.

Return Value

Instance of the FolderInfo object containing all the information related to a particular folder. OfficeClip.BusinessLayer.Desktop..::.FolderInfo

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetGroupSpace Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetGroupSpace Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the space related to a group. If the group space information is not present, then it is created using default value specified in web.config.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus GetGroupSpace(
    int groupId,
    int userId,
    ref double usedSpace
)
Visual Basic (Declaration)
Public Function GetGroupSpace ( _
    groupId As Integer, _
    userId As Integer, _
    ByRef usedSpace As Double _
) As ReturnStatus
Visual C++
public:
ReturnStatus GetGroupSpace(
    int groupId,
    int userId,
    double% usedSpace
)

Parameters

groupId
Type: System..::.Int32
The id of the group for which the document space information is to be obtained
userId
Type: System..::.Int32
Id of the user creating the group space information.
usedSpace
Type: System..::.Double%
Total used space in MB

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetHistory Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetHistory Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the history of all the operations performed on the document.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SqlDataReader GetHistory(
    int documentId
)
Visual Basic (Declaration)
Public Function GetHistory ( _
    documentId As Integer _
) As SqlDataReader
Visual C++
public:
SqlDataReader^ GetHistory(
    int documentId
)

Parameters

documentId
Type: System..::.Int32
Id of the document for which the history has to be returned.

Return Value

SqlDataReader containing all the information related to the history of a particular document. The SqlDataReader consists of the following columns.
  • activityId (System.Int32)

Id indicating the type of operation that was perfomed on the document.
1 = Lock
2 = Update & Unlock
3 = Unlock
4 = Rename
5 = View/Download
6 = Move
7 = Copy
8 = Upload
9 = Lock & Download
  • activityTimestamp (System.DateTime) Date and Time when the particular operation was performed on the document.
  • name (System.String) Name of the user who performed the operation on the document.
  • emailAddress (System.String) Email Address of the user who performed the operation on the document.

Remarks

Make sure to Close the SqlDataReader after the use otherwise it will leave and connection open (till garbage collector releases the Data Reader). If not closed explicitly, the .Net framework might hang and slow down because of the number of open connections Limit might be reached.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetItemDocs Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetItemDocs Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all documents attached to a another OfficeClip object. For example, timesheet, expense or tracker case.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetItemDocs(
    int itemId,
    int applicationId,
    int applicationSecondaryId
)
Visual Basic (Declaration)
Public Function GetItemDocs ( _
    itemId As Integer, _
    applicationId As Integer, _
    applicationSecondaryId As Integer _
) As String
Visual C++
public:
String^ GetItemDocs(
    int itemId,
    int applicationId,
    int applicationSecondaryId
)

Parameters

itemId
Type: System..::.Int32
Id of another OfficeClip object for which all the attached (if any) are to be retrieved.
applicationId
Type: System..::.Int32
Id of the application to which object belongs whose attachments are being retrieved.
applicationSecondaryId
Type: System..::.Int32
Secondary Id distinguishing between two different kinds of objects belonging to an application.

Return Value

Comma delimited string of document Ids of all the attached documents.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetLatestRevision Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetLatestRevision Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the latest revision of a particular document.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetLatestRevision(
    int folderId,
    string documentName
)
Visual Basic (Declaration)
Public Function GetLatestRevision ( _
    folderId As Integer, _
    documentName As String _
) As Integer
Visual C++
public:
int GetLatestRevision(
    int folderId,
    String^ documentName
)

Parameters

folderId
Type: System..::.Int32
The id of the folder.
documentName
Type: System..::.String
The name of the document.

Return Value

The latest revision value of the document.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetSharedDocuments Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetSharedDocuments Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the shared documents for a particular user and for a particular group.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetSharedDocuments(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetSharedDocuments ( _
    userId As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetSharedDocuments(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user. Please note that this user should belong to the group whose GroupId is passed as next argument.
groupId
Type: System..::.Int32
The unique id of the group.

Return Value

DataSet consisting of a single DataTable with the following columns
  • created (System.DateTime) Date and time when the document was created.
  • id (System.Int32) Id to be send with the document.
  • detailId (System.Int32) Detail id to be send with the document.
  • docName (System.String) Name of the document.
  • folderName (System.String) Name of the the document's folder.
  • emailAddress (System.String) Email Address to whom the document is to be sent.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetUserSpace Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetUserSpace Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the space related to a particular user. If the user space information is not present, then it is created using default value specified in web.config.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus GetUserSpace(
    int userId,
    ref double usedSpace
)
Visual Basic (Declaration)
Public Function GetUserSpace ( _
    userId As Integer, _
    ByRef usedSpace As Double _
) As ReturnStatus
Visual C++
public:
ReturnStatus GetUserSpace(
    int userId,
    double% usedSpace
)

Parameters

userId
Type: System..::.Int32
Id of the user whose space information has to be retrieved.
usedSpace
Type: System..::.Double%
Total used space in MB

Return Value

returns true if successful, false if no record exists

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetVirtualFolder Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetVirtualFolder Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the virtual folder path

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetVirtualFolder(
    int createdUserId,
    int folderGroupId,
    int folderId
)
Visual Basic (Declaration)
Public Function GetVirtualFolder ( _
    createdUserId As Integer, _
    folderGroupId As Integer, _
    folderId As Integer _
) As String
Visual C++
public:
String^ GetVirtualFolder(
    int createdUserId,
    int folderGroupId,
    int folderId
)

Parameters

createdUserId
Type: System..::.Int32
The created user id
folderGroupId
Type: System..::.Int32
The folder group id
folderId
Type: System..::.Int32
The unique id of the folder

Return Value

The virtual folder path

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetVirtualFolderForApplication Method

[image]

OfficeClip API Documentation
DocumentDB..::.GetVirtualFolderForApplication Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetVirtualFolderForApplication(
    int groupId,
    int applicationId,
    int id1,
    int folderCreatedbyUserId
)
Visual Basic (Declaration)
Public Function GetVirtualFolderForApplication ( _
    groupId As Integer, _
    applicationId As Integer, _
    id1 As Integer, _
    folderCreatedbyUserId As Integer _
) As String
Visual C++
public:
String^ GetVirtualFolderForApplication(
    int groupId,
    int applicationId,
    int id1,
    int folderCreatedbyUserId
)

Parameters

groupId
Type: System..::.Int32
Id of a particular group.
applicationId
Type: System..::.Int32
Id of the application to which object belongs to which this document is attached.
id1
Type: System..::.Int32
Id of another OfficeClip object with which this document is attached.
folderCreatedbyUserId
Type: System..::.Int32
Id of the user who created the folder

Return Value

Directory Path

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


GetVirtualFolderOld Method

[image] [image]

OfficeClip API Documentation
DocumentDB..::.GetVirtualFolderOld Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetVirtualFolderOld(Int32, Int32, Int32) | Gets the virtual folder path corresponding to currently selected group and currently logged in user where the document will be stored based on the value of level.
Public method | GetVirtualFolderOld(Int32, Int32, String) | Gets the virtual folder path corresponding to a particular group or user where the document will be stored based on the value of level.

See Also

DocumentDB Class
DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


GetVirtualFolderOld Method (Int32, Int32, Int32)

[image]

OfficeClip API Documentation
DocumentDB..::.GetVirtualFolderOld Method (Int32, Int32, Int32)
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the virtual folder path corresponding to currently selected group and currently logged in user where the document will be stored based on the value of level.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetVirtualFolderOld(
    int userId,
    int groupId,
    int folderId
)
Visual Basic (Declaration)
Public Function GetVirtualFolderOld ( _
    userId As Integer, _
    groupId As Integer, _
    folderId As Integer _
) As String
Visual C++
public:
String^ GetVirtualFolderOld(
    int userId,
    int groupId,
    int folderId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
groupId
Type: System..::.Int32
Id of the group whose virtual folder path has to be retrieved.
folderId
Type: System..::.Int32
Id of the folder for which the virtual folder path is being retrieved.

Return Value

See Also

DocumentDB Class
GetVirtualFolderOld Overload
OfficeClip.DBLayer.Desktop Namespace


GetVirtualFolderOld Method (Int32, Int32, String)

[image]

OfficeClip API Documentation
DocumentDB..::.GetVirtualFolderOld Method (Int32, Int32, String)
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the virtual folder path corresponding to a particular group or user where the document will be stored based on the value of level.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetVirtualFolderOld(
    int userId,
    int groupId,
    string level
)
Visual Basic (Declaration)
Public Function GetVirtualFolderOld ( _
    userId As Integer, _
    groupId As Integer, _
    level As String _
) As String
Visual C++
public:
String^ GetVirtualFolderOld(
    int userId,
    int groupId,
    String^ level
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
groupId
Type: System..::.Int32
Id of the group whose virtual folder path has to be retrieved.
level
Type: System..::.String
A string indicating whether a root virtual folder returned is for a group or user. String starting with "001" indicates that a particular group's virtual folder path will be returned. String starting with "002" indicates that the currently logged in user's virtual folder path will be returned.

Return Value

The path for the respective virtual folder.

Remarks

If the respective virtual folder is not present, it is created.

See Also

DocumentDB Class
GetVirtualFolderOld Overload
OfficeClip.DBLayer.Desktop Namespace


GetVirtualPath Method

[image] [image]

OfficeClip API Documentation
DocumentDB..::.GetVirtualPath Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetVirtualPath(Int32) |
Public method | GetVirtualPath(Int32, String) |

See Also

DocumentDB Class
DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


GetVirtualPath Method (Int32)

[image]

OfficeClip API Documentation
DocumentDB..::.GetVirtualPath Method (Int32)
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetVirtualPath(
    int folderId
)
Visual Basic (Declaration)
Public Function GetVirtualPath ( _
    folderId As Integer _
) As String
Visual C++
public:
String^ GetVirtualPath(
    int folderId
)

Parameters

folderId
Type: System..::.Int32
Id of the folder for which the virtual path is being retrieved.

Return Value

The path for the respective virtual folder.

See Also

DocumentDB Class
GetVirtualPath Overload
OfficeClip.DBLayer.Desktop Namespace


GetVirtualPath Method (Int32, String)

[image]

OfficeClip API Documentation
DocumentDB..::.GetVirtualPath Method (Int32, String)
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetVirtualPath(
    int folderId,
    string documentName
)
Visual Basic (Declaration)
Public Function GetVirtualPath ( _
    folderId As Integer, _
    documentName As String _
) As String
Visual C++
public:
String^ GetVirtualPath(
    int folderId,
    String^ documentName
)

Parameters

folderId
Type: System..::.Int32
Id of the folder for which the virtual path is being retrieved.
documentName
Type: System..::.String
Name of document appended to the virtual path.

Return Value

The virtual path concatenated with the document name.

See Also

DocumentDB Class
GetVirtualPath Overload
OfficeClip.DBLayer.Desktop Namespace


HasEnoughDiskSpace Method

[image]

OfficeClip API Documentation
DocumentDB..::.HasEnoughDiskSpace Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks if there is enough disk space

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool HasEnoughDiskSpace(
    int userId,
    double size
)
Visual Basic (Declaration)
Public Function HasEnoughDiskSpace ( _
    userId As Integer, _
    size As Double _
) As Boolean
Visual C++
public:
bool HasEnoughDiskSpace(
    int userId,
    double size
)

Parameters

userId
Type: System..::.Int32
size
Type: System..::.Double

Return Value

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
DocumentDB..::.InitTransaction Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

DocumentDB Class
DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


InsertDocumentHistory Method

[image]

OfficeClip API Documentation
DocumentDB..::.InsertDocumentHistory Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts an entry in the document history table.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertDocumentHistory(
    int userId,
    int documentId,
    DocHistoryStatus dhs
)
Visual Basic (Declaration)
Public Sub InsertDocumentHistory ( _
    userId As Integer, _
    documentId As Integer, _
    dhs As DocHistoryStatus _
)
Visual C++
public:
void InsertDocumentHistory(
    int userId,
    int documentId,
    DocHistoryStatus dhs
)

Parameters

userId
Type: System..::.Int32
The unique id of the user inserting the document history.
documentId
Type: System..::.Int32
The id of the document.
dhs
Type: OfficeClip.Utils..::.DocHistoryStatus
The document history status as provided in the DocHistoryStatus enumerated type. OfficeClip.Utils..::.DocHistoryStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertFileAndDocument Method

[image]

OfficeClip API Documentation
DocumentDB..::.InsertFileAndDocument Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a document in a folder

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertFileAndDocument(
    int groupId,
    string postedFileName,
    Stream postedFileStream,
    int folderId,
    string documentKey,
    string documentDesc,
    string isPrivateFlag,
    int applicationId,
    int applicationSecondaryId,
    int id,
    string appsDescription,
    int userId,
    string level,
    string groupName,
    string userName,
    bool isChecked
)
Visual Basic (Declaration)
Public Function InsertFileAndDocument ( _
    groupId As Integer, _
    postedFileName As String, _
    postedFileStream As Stream, _
    folderId As Integer, _
    documentKey As String, _
    documentDesc As String, _
    isPrivateFlag As String, _
    applicationId As Integer, _
    applicationSecondaryId As Integer, _
    id As Integer, _
    appsDescription As String, _
    userId As Integer, _
    level As String, _
    groupName As String, _
    userName As String, _
    isChecked As Boolean _
) As Integer
Visual C++
public:
int InsertFileAndDocument(
    int groupId,
    String^ postedFileName,
    Stream^ postedFileStream,
    int folderId,
    String^ documentKey,
    String^ documentDesc,
    String^ isPrivateFlag,
    int applicationId,
    int applicationSecondaryId,
    int id,
    String^ appsDescription,
    int userId,
    String^ level,
    String^ groupName,
    String^ userName,
    bool isChecked
)

Parameters

groupId
Type: System..::.Int32
Id of the group for which the document is to be stored. If isPrivate is "Y", this parameter will be ignored.
postedFileName
Type: System..::.String
Name of the document being created.
postedFileStream
Type: System.IO..::.Stream
File stream of the content of the document.
folderId
Type: System..::.Int32
The id of the folder where the document is supposed to be inserted.
documentKey
Type: System..::.String
Key or keywords associated with a document which can be used while searching for a document.
documentDesc
Type: System..::.String
Description of the document.
isPrivateFlag
Type: System..::.String
Is the document private
applicationId
Type: System..::.Int32
Id of the application to which object belongs to which this document is attached.
applicationSecondaryId
Type: System..::.Int32
Secondary Id distinguishing between two different kinds of objects belonging to an application.
id
Type: System..::.Int32
Id of another OfficeClip object with which this document is attached.
appsDescription
Type: System..::.String
Description when this document is attached to an object of another application.
userId
Type: System..::.Int32
Id of the user to who is uploading the document.
level
Type: System..::.String
A string indicating what level deep is the folder in which document is being stored. Moreover, if this string is starting with "001", it indicates that the currently selected group's virtual folder be used in storing the document. String starting with "002" indicates that the currently logged in user's virtual folder will be used in storing the document. String starting with "003" indicates that the application's virtual folder will be used in storing the document. After 001 or 002 or 003 the set of next two digits tell the order in which the document will appear on the screen and evey next set of two digit signifies the level deep below the root older level, that particular document is residing.
groupName
Type: System..::.String
Name of the current group.
userName
Type: System..::.String
Name of the current user.
isChecked
Type: System..::.Boolean
Flag (True/False) indicating whether a new revision should be created.

Return Value

Id of the newly inserted document.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


IsDocumentPresent Method

[image]

OfficeClip API Documentation
DocumentDB..::.IsDocumentPresent Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks if a particular document is present.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsDocumentPresent(
    int folderId,
    string documentName
)
Visual Basic (Declaration)
Public Function IsDocumentPresent ( _
    folderId As Integer, _
    documentName As String _
) As Boolean
Visual C++
public:
bool IsDocumentPresent(
    int folderId,
    String^ documentName
)

Parameters

folderId
Type: System..::.Int32
The id of the folder (or album id in case of photo).
documentName
Type: System..::.String
The name of the document.

Return Value

True if present, False if not.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


IsPostedFileValid Method

[image]

OfficeClip API Documentation
DocumentDB..::.IsPostedFileValid Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Check if the file represented by the posted (uploaded) file is sytactically valid.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus IsPostedFileValid(
    HttpPostedFile postedFile
)
Visual Basic (Declaration)
Public Function IsPostedFileValid ( _
    postedFile As HttpPostedFile _
) As ReturnStatus
Visual C++
public:
ReturnStatus IsPostedFileValid(
    HttpPostedFile^ postedFile
)

Parameters

postedFile
Type: System.Web..::.HttpPostedFile
The posted (uploaded) file.

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


MarkDocumentActive Method

[image]

OfficeClip API Documentation
DocumentDB..::.MarkDocumentActive Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Mark all the documents as Active for deletion whose comma delimited list of document ids is being passed as argument and also set the new folder name (instead of -negative random).

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus MarkDocumentActive(
    string docIdList,
    int id,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function MarkDocumentActive ( _
    docIdList As String, _
    id As Integer, _
    userId As Integer, _
    groupId As Integer _
) As ReturnStatus
Visual C++
public:
ReturnStatus MarkDocumentActive(
    String^ docIdList,
    int id,
    int userId,
    int groupId
)

Parameters

docIdList
Type: System..::.String
Comma delimited list of document ids which are to be marked as Active and whose folder name is to be updated.
id
Type: System..::.Int32
Id of another OfficeClip object to which all the documents in the delimited list belong. This id is updated as folder name where this document is stored in the file system.
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the organiation

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


RemoveAllItemDocs Method

[image]

OfficeClip API Documentation
DocumentDB..::.RemoveAllItemDocs Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all documents attached to a another OfficeClip object. For example, timesheet, expense or tracker case.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus RemoveAllItemDocs(
    int itemId,
    int applicationId,
    int applicationSecondaryId,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function RemoveAllItemDocs ( _
    itemId As Integer, _
    applicationId As Integer, _
    applicationSecondaryId As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
) As ReturnStatus
Visual C++
public:
ReturnStatus RemoveAllItemDocs(
    int itemId,
    int applicationId,
    int applicationSecondaryId,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

itemId
Type: System..::.Int32
Id of another OfficeClip object for which all the attached (if any) are to be removed.
applicationId
Type: System..::.Int32
Id of the application to which object belongs whose attachments are being removed.
applicationSecondaryId
Type: System..::.Int32
Secondary Id distinguishing between two different kinds of objects belonging to an application.
currentUserId
Type: System..::.Int32
The unique id of the user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


RemoveAttachment Method

[image]

OfficeClip API Documentation
DocumentDB..::.RemoveAttachment Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the Attachment document attached to another OfficeClip object.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus RemoveAttachment(
    int documentId,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function RemoveAttachment ( _
    documentId As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
) As ReturnStatus
Visual C++
public:
ReturnStatus RemoveAttachment(
    int documentId,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

documentId
Type: System..::.Int32
Id of the document being deleted.
currentUserId
Type: System..::.Int32
The unique id of the current user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


RemoveAttachmentIfTemp Method

[image]

OfficeClip API Documentation
DocumentDB..::.RemoveAttachmentIfTemp Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Remove the Attachment if it is marked as temp.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus RemoveAttachmentIfTemp(
    int documentId,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function RemoveAttachmentIfTemp ( _
    documentId As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
) As ReturnStatus
Visual C++
public:
ReturnStatus RemoveAttachmentIfTemp(
    int documentId,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

documentId
Type: System..::.Int32
Id of the document
currentUserId
Type: System..::.Int32
The unique id of the current user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


RemoveAttachments Method

[image]

OfficeClip API Documentation
DocumentDB..::.RemoveAttachments Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Remove the Attachments identified by the list of comma separated document ids

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus RemoveAttachments(
    string remDocIdList,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function RemoveAttachments ( _
    remDocIdList As String, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
) As ReturnStatus
Visual C++
public:
ReturnStatus RemoveAttachments(
    String^ remDocIdList,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

remDocIdList
Type: System..::.String
Comma delimited string of all the documents to be removed.
currentUserId
Type: System..::.Int32
The unique id of the current user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


RemoveDocument Method

[image] [image]

OfficeClip API Documentation
DocumentDB..::.RemoveDocument Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | RemoveDocument(Int32, Int32, Boolean) | Removes the document
Public method | RemoveDocument(Int32, Int32, Int32, Boolean) | Removes the document

See Also

DocumentDB Class
DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


RemoveDocument Method (Int32, Int32, Boolean)

[image]

OfficeClip API Documentation
DocumentDB..::.RemoveDocument Method (Int32, Int32, Boolean)
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the document

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus RemoveDocument(
    int documentId,
    int currentUserId,
    bool isCurrentuserAdmin
)
Visual Basic (Declaration)
Public Function RemoveDocument ( _
    documentId As Integer, _
    currentUserId As Integer, _
    isCurrentuserAdmin As Boolean _
) As ReturnStatus
Visual C++
public:
ReturnStatus RemoveDocument(
    int documentId,
    int currentUserId,
    bool isCurrentuserAdmin
)

Parameters

documentId
Type: System..::.Int32
Id of the document being deleted.
currentUserId
Type: System..::.Int32
Unique id of the current user
isCurrentuserAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
RemoveDocument Overload
OfficeClip.DBLayer.Desktop Namespace


RemoveDocument Method (Int32, Int32, Int32, Boolean)

[image]

OfficeClip API Documentation
DocumentDB..::.RemoveDocument Method (Int32, Int32, Int32, Boolean)
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the document

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus RemoveDocument(
    int documentId,
    int userId,
    int groupId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function RemoveDocument ( _
    documentId As Integer, _
    userId As Integer, _
    groupId As Integer, _
    isAdmin As Boolean _
) As ReturnStatus
Visual C++
public:
ReturnStatus RemoveDocument(
    int documentId,
    int userId,
    int groupId,
    bool isAdmin
)

Parameters

documentId
Type: System..::.Int32
Id of the document being deleted.
userId
Type: System..::.Int32
The unique id of the user.
groupId
Type: System..::.Int32
Id of a particular group.
isAdmin
Type: System..::.Boolean
Flag (True/False) indicating whether the user (whose userId, is passed as argument) is an admin or not.

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
RemoveDocument Overload
OfficeClip.DBLayer.Desktop Namespace


RemoveFolder Method

[image]

OfficeClip API Documentation
DocumentDB..::.RemoveFolder Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the folder and all the associated documents

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStatus..::.DeleteFolderStatus RemoveFolder(
    int userId,
    int groupId,
    bool isAdmin,
    int folderId
)
Visual Basic (Declaration)
Public Function RemoveFolder ( _
    userId As Integer, _
    groupId As Integer, _
    isAdmin As Boolean, _
    folderId As Integer _
) As DocumentStatus..::.DeleteFolderStatus
Visual C++
public:
DocumentStatus..::.DeleteFolderStatus RemoveFolder(
    int userId,
    int groupId,
    bool isAdmin,
    int folderId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
groupId
Type: System..::.Int32
Id of a particular group.
isAdmin
Type: System..::.Boolean
Flag (True/False) indicating whether the user (whose userId, is passed as argument) is an admin or not.
folderId
Type: System..::.Int32
The id of the folder

Return Value

Enumerated value DeleteFolderStatus indicating if the operation succeeded or failed. OfficeClip.BusinessLayer.Desktop..::.DocumentStatus..::.DeleteFolderStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


RemoveShare Method

[image]

OfficeClip API Documentation
DocumentDB..::.RemoveShare Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the set of share from the system

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus RemoveShare(
    ArrayList al
)
Visual Basic (Declaration)
Public Function RemoveShare ( _
    al As ArrayList _
) As ReturnStatus
Visual C++
public:
ReturnStatus RemoveShare(
    ArrayList^ al
)

Parameters

al
Type: System.Collections..::.ArrayList
The arraylist of send_id and send_detail_id

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


RenameDocument Method

[image]

OfficeClip API Documentation
DocumentDB..::.RenameDocument Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Renames the documents of the document set

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStatus..::.RenameDocumentStatus RenameDocument(
    string name,
    int id,
    bool isFolder,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function RenameDocument ( _
    name As String, _
    id As Integer, _
    isFolder As Boolean, _
    userId As Integer, _
    groupId As Integer _
) As DocumentStatus..::.RenameDocumentStatus
Visual C++
public:
DocumentStatus..::.RenameDocumentStatus RenameDocument(
    String^ name,
    int id,
    bool isFolder,
    int userId,
    int groupId
)

Parameters

name
Type: System..::.String
The name of the document/folder being renamed.
id
Type: System..::.Int32
The unique id of the document/folder being renamed.
isFolder
Type: System..::.Boolean
Flag (True/False) indicating whether the document is a folder.
userId
Type: System..::.Int32
The unique id of the user whose document/folder is renamed.
groupId
Type: System..::.Int32
The unique id of the group whose document/folder is renamed.

Return Value

Enumerated value RenameDocumentStatus indicating if the operation succeeded or failed. OfficeClip.BusinessLayer.Desktop..::.DocumentStatus..::.RenameDocumentStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


Search Method

[image]

OfficeClip API Documentation
DocumentDB..::.Search Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the search result from the database using a particular group and a particular user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet Search(
    int userId,
    int groupId,
    int textSelectOption,
    int sizeSelectOption,
    int dateSelectOption,
    string textValue,
    double sizeValue,
    string fromDate,
    string toDate
)
Visual Basic (Declaration)
Public Function Search ( _
    userId As Integer, _
    groupId As Integer, _
    textSelectOption As Integer, _
    sizeSelectOption As Integer, _
    dateSelectOption As Integer, _
    textValue As String, _
    sizeValue As Double, _
    fromDate As String, _
    toDate As String _
) As DataSet
Visual C++
public:
DataSet^ Search(
    int userId,
    int groupId,
    int textSelectOption,
    int sizeSelectOption,
    int dateSelectOption,
    String^ textValue,
    double sizeValue,
    String^ fromDate,
    String^ toDate
)

Parameters

userId
Type: System..::.Int32
The unique id of the user. Please note that user should belong to the group whose GroupId is passed in the next argument.
groupId
Type: System..::.Int32
Id of a particular group.
textSelectOption
Type: System..::.Int32
The text selected option by the user
            -1 = Not Available
            1 = All
            2 = File Name
            3 = Detail
            4 = Keywords
            5 = Created By
sizeSelectOption
Type: System..::.Int32
-1 = Not Available
            1 = Equal To
            2 = Less Than
            3 = More Than
dateSelectOption
Type: System..::.Int32
-1 = Not Available
            1 = Created Date
            2 = Modified Date
textValue
Type: System..::.String
The text value for search, required only if txtSelectOption is positive
sizeValue
Type: System..::.Double
The size of the file(in KB), required only if sizeSelectOption is positive
fromDate
Type: System..::.String
The from date, is used when the dateSelectOption is positive, in string format MM/dd/yyyy
toDate
Type: System..::.String
The to date, is used when the dateSelectOption is positive, in string format MM/dd/yyyy

Return Value

DataSet containg all the results matching the search criteria. DataSet consists of single DataTable with the following columns.
  • sizeOfFile (System.Double) Size of the document.
  • docId (System.Int32) Id of the document.
  • docName (System.String) Name of the document.
  • folderName (System.String) Name of the folder.
  • created (System.DateTime) Date and Time when the document was created.
  • UserName (System.String) Name of the user who created the document.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


SetLock Method

[image]

OfficeClip API Documentation
DocumentDB..::.SetLock Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets a lock on a particular document by the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus SetLock(
    int userId,
    int documentId,
    DocHistoryStatus mode
)
Visual Basic (Declaration)
Public Function SetLock ( _
    userId As Integer, _
    documentId As Integer, _
    mode As DocHistoryStatus _
) As ReturnStatus
Visual C++
public:
ReturnStatus SetLock(
    int userId,
    int documentId,
    DocHistoryStatus mode
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
documentId
Type: System..::.Int32
Id of the document.
mode
Type: OfficeClip.Utils..::.DocHistoryStatus
The mode in which the lock has been put on the document. OfficeClip.Utils..::.DocHistoryStatus

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


SetLockDownload Method

[image]

OfficeClip API Documentation
DocumentDB..::.SetLockDownload Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets lock and Download status on a particular document for the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus SetLockDownload(
    int documentId,
    DocHistoryStatus mode,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function SetLockDownload ( _
    documentId As Integer, _
    mode As DocHistoryStatus, _
    userId As Integer, _
    groupId As Integer _
) As ReturnStatus
Visual C++
public:
ReturnStatus SetLockDownload(
    int documentId,
    DocHistoryStatus mode,
    int userId,
    int groupId
)

Parameters

documentId
Type: System..::.Int32
Id of the document.
mode
Type: OfficeClip.Utils..::.DocHistoryStatus
The mode in which the lock and Download status has been put on the document. OfficeClip.Utils..::.DocHistoryStatus
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the group

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
DocumentDB..::.SetSPCommand Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

DocumentDB Class
DocumentDB Members
OfficeClip.DBLayer.Desktop Namespace


SetUnlock Method

[image]

OfficeClip API Documentation
DocumentDB..::.SetUnlock Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Unlocks a particular document by a particular user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus SetUnlock(
    int userId,
    int documentId,
    DocHistoryStatus mode
)
Visual Basic (Declaration)
Public Function SetUnlock ( _
    userId As Integer, _
    documentId As Integer, _
    mode As DocHistoryStatus _
) As ReturnStatus
Visual C++
public:
ReturnStatus SetUnlock(
    int userId,
    int documentId,
    DocHistoryStatus mode
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
documentId
Type: System..::.Int32
Id of the document.
mode
Type: OfficeClip.Utils..::.DocHistoryStatus
The mode in which the document is being unlocked. OfficeClip.Utils..::.DocHistoryStatus

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


SetupGroupApplicationFolder Method

[image]

OfficeClip API Documentation
DocumentDB..::.SetupGroupApplicationFolder Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Intializes the folder information in the database with default space related information and also creates a folder for group's application related documents. Does nothing if intialization has already taken place.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus SetupGroupApplicationFolder(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function SetupGroupApplicationFolder ( _
    userId As Integer, _
    groupId As Integer _
) As ReturnStatus
Visual C++
public:
ReturnStatus SetupGroupApplicationFolder(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
Id of the user for which the intialization has to be done.
groupId
Type: System..::.Int32
Id of the group for which the intialization has to be done.

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


SetupInitialFolders Method

[image]

OfficeClip API Documentation
DocumentDB..::.SetupInitialFolders Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets up the initial folders

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetupInitialFolders(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Sub SetupInitialFolders ( _
    userId As Integer, _
    groupId As Integer _
)
Visual C++
public:
void SetupInitialFolders(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the group

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


SetupUserApplicationFolder Method

[image]

OfficeClip API Documentation
DocumentDB..::.SetupUserApplicationFolder Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Intializes the folder information in the database with default space related information and also creates a folder for currently logged in users's application related documents. Does nothing if intialization has already taken place.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus SetupUserApplicationFolder(
    int userId
)
Visual Basic (Declaration)
Public Function SetupUserApplicationFolder ( _
    userId As Integer _
) As ReturnStatus
Visual C++
public:
ReturnStatus SetupUserApplicationFolder(
    int userId
)

Parameters

userId
Type: System..::.Int32
Id of the user for which the application folder is setup.

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


SetViewDownload Method

[image]

OfficeClip API Documentation
DocumentDB..::.SetViewDownload Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets view and download status on a particular document for the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus SetViewDownload(
    int documentId,
    DocHistoryStatus mode,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function SetViewDownload ( _
    documentId As Integer, _
    mode As DocHistoryStatus, _
    userId As Integer, _
    groupId As Integer _
) As ReturnStatus
Visual C++
public:
ReturnStatus SetViewDownload(
    int documentId,
    DocHistoryStatus mode,
    int userId,
    int groupId
)

Parameters

documentId
Type: System..::.Int32
Id of the document.
mode
Type: OfficeClip.Utils..::.DocHistoryStatus
The mode in which the view and download status has been put on the document. OfficeClip.Utils..::.DocHistoryStatus
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the group

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateDocumentStorage Method

[image]

OfficeClip API Documentation
DocumentDB..::.UpdateDocumentStorage Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the document storage information for the a user or the group. based on the information in the DocumentStorageInfo object.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateDocumentStorage(
    DocumentStorageInfo dsi
)
Visual Basic (Declaration)
Public Function UpdateDocumentStorage ( _
    dsi As DocumentStorageInfo _
) As Integer
Visual C++
public:
int UpdateDocumentStorage(
    DocumentStorageInfo^ dsi
)

Parameters

dsi
Type: OfficeClip.BusinessLayer.Desktop..::.DocumentStorageInfo
Instance of the DocumentStorageInfo object containing the information about the document storage to be updated for a group or user.

Return Value

0 if successful, -1 in case of an error.

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateKeywordDescription Method

[image]

OfficeClip API Documentation
DocumentDB..::.UpdateKeywordDescription Method
DocumentDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStatus..::.UpdateDocumentStatus UpdateKeywordDescription(
    string keyword,
    string description,
    int id,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function UpdateKeywordDescription ( _
    keyword As String, _
    description As String, _
    id As Integer, _
    userId As Integer, _
    groupId As Integer _
) As DocumentStatus..::.UpdateDocumentStatus
Visual C++
public:
DocumentStatus..::.UpdateDocumentStatus UpdateKeywordDescription(
    String^ keyword,
    String^ description,
    int id,
    int userId,
    int groupId
)

Parameters

keyword
Type: System..::.String
The keyword(s) related to that particular document.
description
Type: System..::.String
The description(s) related to that particular document.
id
Type: System..::.Int32
The id of the document.
userId
Type: System..::.Int32
Id of the particular user.
groupId
Type: System..::.Int32
Id of the particular group.

Return Value

Enumerated value UpdateDocumentStatus indicating if the operation succeeded or failed. OfficeClip.BusinessLayer.Desktop..::.DocumentStatus..::.UpdateDocumentStatus

See Also

DocumentDB Class
OfficeClip.DBLayer.Desktop Namespace


DocumentError Class

[image]

OfficeClip API Documentation
DocumentError Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to hold the document information.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class DocumentError
Visual Basic (Declaration)
Public Class DocumentError
Visual C++
public ref class DocumentError

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Desktop..::.DocumentError

See Also

DocumentError Members
OfficeClip.DBLayer.Desktop Namespace


DocumentError Members

[image] [image]

OfficeClip API Documentation
DocumentError Members
DocumentError Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The DocumentError type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentError |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetPreInsertErrorString | Gets the preinserted error string
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ocr | OfficeClip Resources

See Also

DocumentError Class
OfficeClip.DBLayer.Desktop Namespace


DocumentError Constructor

[image]

OfficeClip API Documentation
DocumentError Constructor
DocumentError Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentError()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentError()

See Also

DocumentError Class
OfficeClip.DBLayer.Desktop Namespace


DocumentError Fields

[image] [image]

OfficeClip API Documentation
DocumentError Fields
DocumentError Class See Also

[This is preliminary documentation and is subject to change.]

The DocumentError type exposes the following fields.

Fields

Name | Description
ocr | OfficeClip Resources

See Also

DocumentError Class
OfficeClip.DBLayer.Desktop Namespace


ocr Field

[image]

OfficeClip API Documentation
DocumentError..::.ocr Field
DocumentError Class See Also

[This is preliminary documentation and is subject to change.]

OfficeClip Resources

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected static OCResources ocr
Visual Basic (Declaration)
Protected Shared ocr As OCResources
Visual C++
protected:
static OCResources^ ocr

See Also

DocumentError Class
OfficeClip.DBLayer.Desktop Namespace


DocumentError Methods

[image] [image]

OfficeClip API Documentation
DocumentError Methods
DocumentError Class See Also

[This is preliminary documentation and is subject to change.]

The DocumentError type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetPreInsertErrorString | Gets the preinserted error string
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentError Class
OfficeClip.DBLayer.Desktop Namespace


GetPreInsertErrorString Method

[image]

OfficeClip API Documentation
DocumentError..::.GetPreInsertErrorString Method
DocumentError Class See Also

[This is preliminary documentation and is subject to change.]

Gets the preinserted error string

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static string GetPreInsertErrorString(
    DocumentStatus..::.DocumentPreInsertStatus status,
    bool isWarn,
    bool isVersion
)
Visual Basic (Declaration)
Public Shared Function GetPreInsertErrorString ( _
    status As DocumentStatus..::.DocumentPreInsertStatus, _
    isWarn As Boolean, _
    isVersion As Boolean _
) As String
Visual C++
public:
static String^ GetPreInsertErrorString(
    DocumentStatus..::.DocumentPreInsertStatus status,
    bool isWarn,
    bool isVersion
)

Parameters

status
Type: OfficeClip.BusinessLayer.Desktop..::.DocumentStatus..::.DocumentPreInsertStatus
The document preinsert status
isWarn
Type: System..::.Boolean
true if the warning is desired
isVersion
Type: System..::.Boolean
true if the document will be saved with a higher revision if it already exists

Return Value

See Also

DocumentError Class
OfficeClip.DBLayer.Desktop Namespace


DocumentViewDB Class

[image]

OfficeClip API Documentation
DocumentViewDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Summary description for DocumentDB

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class DocumentViewDB : OfficeClipDB
Visual Basic (Declaration)
Public Class DocumentViewDB _
    Inherits OfficeClipDB
Visual C++
public ref class DocumentViewDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Desktop..::.DocumentViewDB

See Also

DocumentViewDB Members
OfficeClip.DBLayer.Desktop Namespace


DocumentViewDB Members

[image] [image]

OfficeClip API Documentation
DocumentViewDB Members
DocumentViewDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The DocumentViewDB type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentViewDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAttributeString | Gets the folder/document properties as an abbreviated string.
Public method | GetFolderChildren | Overloaded.
Public method | GetFolderRootId | Gets the id of the root folder.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Protected method | GetParentId | Gets the parentId of the current folderId.
Public method | GetType | Overloaded.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

DocumentViewDB Class
OfficeClip.DBLayer.Desktop Namespace


DocumentViewDB Constructor

[image]

OfficeClip API Documentation
DocumentViewDB Constructor
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentViewDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DocumentViewDB()

See Also

DocumentViewDB Class
OfficeClip.DBLayer.Desktop Namespace


DocumentViewDB Methods

[image] [image]

OfficeClip API Documentation
DocumentViewDB Methods
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

The DocumentViewDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetAttributeString | Gets the folder/document properties as an abbreviated string.
Public method | GetFolderChildren | Overloaded.
Public method | GetFolderRootId | Gets the id of the root folder.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Protected method | GetParentId | Gets the parentId of the current folderId.
Public method | GetType | Overloaded.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentViewDB Class
OfficeClip.DBLayer.Desktop Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
DocumentViewDB..::.AddOutputParameter Method
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

DocumentViewDB Class
DocumentViewDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
DocumentViewDB..::.AddParameter Method
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

DocumentViewDB Class
DocumentViewDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
DocumentViewDB..::.AddParameters Method
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

DocumentViewDB Class
DocumentViewDB Members
OfficeClip.DBLayer.Desktop Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
DocumentViewDB..::.ExecuteNonQuery Method
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

DocumentViewDB Class
DocumentViewDB Members
OfficeClip.DBLayer.Desktop Namespace


GetAttributeString Method

[image]

OfficeClip API Documentation
DocumentViewDB..::.GetAttributeString Method
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the folder/document properties as an abbreviated string.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetAttributeString(
    Object read,
    Object write,
    Object append,
    Object delete
)
Visual Basic (Declaration)
Protected Function GetAttributeString ( _
    read As Object, _
    write As Object, _
    append As Object, _
    delete As Object _
) As String
Visual C++
protected:
String^ GetAttributeString(
    Object^ read,
    Object^ write,
    Object^ append,
    Object^ delete
)

Parameters

read
Type: System..::.Object
Object representing the read permission.
write
Type: System..::.Object
Object representing the write permission.
append
Type: System..::.Object
Object representing the append permission.
delete
Type: System..::.Object
Object representing the delete permission.

Return Value

Concatenated string with the available permissions.

See Also

DocumentViewDB Class
OfficeClip.DBLayer.Desktop Namespace


GetFolderChildren Method

[image] [image]

OfficeClip API Documentation
DocumentViewDB..::.GetFolderChildren Method
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetFolderChildren(Int32, Boolean, Boolean, DataTable%, DataTable%, ConfigureInfo) |
Public method | GetFolderChildren(Int32, Boolean, Boolean, String, Boolean, Boolean, ConfigureInfo) | Gets all the folders and documents for a particular folder(s)

See Also

DocumentViewDB Class
DocumentViewDB Members
OfficeClip.DBLayer.Desktop Namespace


GetFolderChildren Method (Int32, Boolean, Boolean, DataTable, DataTable, ConfigureInfo)

[image]

OfficeClip API Documentation
DocumentViewDB..::.GetFolderChildren Method (Int32, Boolean, Boolean, DataTable%, DataTable%, ConfigureInfo)
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetFolderChildren(
    int folderId,
    bool isGroupFolder,
    bool isAllRev,
    ref DataTable dtFolder,
    ref DataTable dtDocument,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Sub GetFolderChildren ( _
    folderId As Integer, _
    isGroupFolder As Boolean, _
    isAllRev As Boolean, _
    ByRef dtFolder As DataTable, _
    ByRef dtDocument As DataTable, _
    session As ConfigureInfo _
)
Visual C++
public:
void GetFolderChildren(
    int folderId,
    bool isGroupFolder,
    bool isAllRev,
    DataTable^% dtFolder,
    DataTable^% dtDocument,
    ConfigureInfo^ session
)

Parameters

folderId
Type: System..::.Int32
Id of the folder.
isGroupFolder
Type: System..::.Boolean
Flag (True/False) indicating whether the folder is a group folder.
isAllRev
Type: System..::.Boolean
true if all the revisions needs to be shown
dtFolder
Type: System.Data..::.DataTable%
Datatable schema for the folder output datatable.
dtDocument
Type: System.Data..::.DataTable%
Datatable schema for the document output datatable.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session

See Also

DocumentViewDB Class
GetFolderChildren Overload
OfficeClip.DBLayer.Desktop Namespace


GetFolderChildren Method (Int32, Boolean, Boolean, String, Boolean, Boolean, ConfigureInfo)

[image]

OfficeClip API Documentation
DocumentViewDB..::.GetFolderChildren Method (Int32, Boolean, Boolean, String, Boolean, Boolean, ConfigureInfo)
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the folders and documents for a particular folder(s)

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetFolderChildren(
    int folderId,
    bool isGroupFolder,
    bool isAllRev,
    string sortColumn,
    bool isAscending,
    bool showFolderOnly,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function GetFolderChildren ( _
    folderId As Integer, _
    isGroupFolder As Boolean, _
    isAllRev As Boolean, _
    sortColumn As String, _
    isAscending As Boolean, _
    showFolderOnly As Boolean, _
    session As ConfigureInfo _
) As DataTable
Visual C++
public:
DataTable^ GetFolderChildren(
    int folderId,
    bool isGroupFolder,
    bool isAllRev,
    String^ sortColumn,
    bool isAscending,
    bool showFolderOnly,
    ConfigureInfo^ session
)

Parameters

folderId
Type: System..::.Int32
Id of the folder.
isGroupFolder
Type: System..::.Boolean
Flag (True/False) indicating whether the folder is a group folder.
isAllRev
Type: System..::.Boolean
sortColumn
Type: System..::.String
Name of the column currenty been sorted by.
isAscending
Type: System..::.Boolean
Flag (True/False) indicating if the sort is in ASC or DESC order.
showFolderOnly
Type: System..::.Boolean
Flag (True/False) indicating whether only the folders should be shown.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session

Return Value

DataTable with all the folders and/or documents with all their attributes.

See Also

DocumentViewDB Class
GetFolderChildren Overload
OfficeClip.DBLayer.Desktop Namespace


GetFolderRootId Method

[image]

OfficeClip API Documentation
DocumentViewDB..::.GetFolderRootId Method
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the id of the root folder.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetFolderRootId(
    int rootFolderId,
    bool isGroupFolder,
    int groupId,
    int userId
)
Visual Basic (Declaration)
Public Function GetFolderRootId ( _
    rootFolderId As Integer, _
    isGroupFolder As Boolean, _
    groupId As Integer, _
    userId As Integer _
) As Integer
Visual C++
public:
int GetFolderRootId(
    int rootFolderId,
    bool isGroupFolder,
    int groupId,
    int userId
)

Parameters

rootFolderId
Type: System..::.Int32
Id of the folder for which the root folderId needs to be obtained.
isGroupFolder
Type: System..::.Boolean
Flag (True/False) indicating whether the folder is a group folder.
groupId
Type: System..::.Int32
Id of the group.
userId
Type: System..::.Int32
Id of the user.

Return Value

See Also

DocumentViewDB Class
OfficeClip.DBLayer.Desktop Namespace


GetParentId Method

[image]

OfficeClip API Documentation
DocumentViewDB..::.GetParentId Method
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the parentId of the current folderId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected int GetParentId(
    int folderId
)
Visual Basic (Declaration)
Protected Function GetParentId ( _
    folderId As Integer _
) As Integer
Visual C++
protected:
int GetParentId(
    int folderId
)

Parameters

folderId
Type: System..::.Int32
Id of the folder.

Return Value

Id of the folder's parent folder.

See Also

DocumentViewDB Class
OfficeClip.DBLayer.Desktop Namespace


GetType Method

[image] [image]

OfficeClip API Documentation
DocumentViewDB..::.GetType Method
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetType(String) | Gets the type of the document.

See Also

DocumentViewDB Class
DocumentViewDB Members
OfficeClip.DBLayer.Desktop Namespace


GetType Method (String)

[image]

OfficeClip API Documentation
DocumentViewDB..::.GetType Method (String)
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the type of the document.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetType(
    string fileName
)
Visual Basic (Declaration)
Protected Function GetType ( _
    fileName As String _
) As String
Visual C++
protected:
String^ GetType(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
Name of the file.

Return Value

The type of the document as a string.

See Also

DocumentViewDB Class
GetType Overload
OfficeClip.DBLayer.Desktop Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
DocumentViewDB..::.InitTransaction Method
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

DocumentViewDB Class
DocumentViewDB Members
OfficeClip.DBLayer.Desktop Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
DocumentViewDB..::.SetSPCommand Method
DocumentViewDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

DocumentViewDB Class
DocumentViewDB Members
OfficeClip.DBLayer.Desktop Namespace


EmailDB Class

[image]

OfficeClip API Documentation
EmailDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Email application related functions.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class EmailDB : OfficeClipDB
Visual Basic (Declaration)
Public Class EmailDB _
    Inherits OfficeClipDB
Visual C++
public ref class EmailDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Desktop..::.EmailDB

See Also

EmailDB Members
OfficeClip.DBLayer.Desktop Namespace


EmailDB Members

[image] [image]

OfficeClip API Documentation
EmailDB Members
EmailDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The EmailDB type exposes the following members.

Constructors

 | Name | Description
Public method | EmailDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteBlockedEmailAddress | Removes a particular email Address from the blocked sender list.
Public method | DeleteEmail | Deletes a particular email idenfied by emailId in the database and the filesystem.
Public method | DeleteEmailAccount | Deletes all the information related to a particular email account identified by emailAccountId.
Public method | DeleteEmailFolder | Deletes all the information related to a particular email folder.
Public method | DeleteEmailInfo | Deletes a particular email idenfied by emailId in the database and the filesystem.
Public method | DeleteEmailPreference | Deletes the email preferences for a particular user.
Public method | DeleteEmailRule | Deletes all the details corresponding to a particular rule indentified by emailRuleId.
Public method | DeleteMailingList | Deletes the complete mailing list including all the members if any.
Public method | DeleteMailingListMember | Deletes a mailing list member from the mailing list.
Public method | DeleteMailingListMembers | Deletes all mailing list members from the mailing list.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccountColorSchemes | Gets all the color schemes specified in the OfficeClip email account color sheme resource file (desktop/email/accountColorScheme.xml). Please refer to the
Public method | GetBlockSenderList | Gets a list of email addresses, emails from which need to be discarded.
Public method | GetEmailAccount | Gets all the details related to the a particular email account identified by the emailAccountId.
Public method | GetEmailAccounts | Gets all the information for all the email accounts for the currently logged in user.
 | GetEmailFileLocation | Gets the email file location
Public method | GetEmailFolder | Gets all the information related to a particular email folder identified by the emailFolderId.
Public method | GetEmailFolderNames | Gets a list of all the email folders for currently logged in user.
Public method | GetEmailFolders | Gets all the email folders created for the currently logged in user.
Public method | GetEmailInfo | Gets all the information corresponding to a particular email identified by emailId.
Public method | GetEmailInfoList | Gets all the information List of all emails info for those emailIds supplied in eidList.
Public method | GetEmailListGridLayout | Returns the order in which the columns in the email list are to be displayed. For more information refer to the OfficeClip customization document, level 1 customization using the emailList.xml.
Public method | GetEmailListGridNumberOfRows | Gets the number of rows per page as specified in the xml configuration file emailList.xml. Please refer to the OfficeClip level 1 customization help.
Public method | GetEmailPreference | Gets the email preferences for a particular user.
Public method | GetEmailRule | Gets all the details corresponding to a particular email rule identified by emailRuleId.
Public method | GetEmailRules | Gets all the details corresponding to all the email rules set by the currently logged in user.
Public method | GetEmails | Gets all the stored emails and their related information in the OfficeClip database for the currently logged in user.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMailingListInfo | Gets all the information related to a particular mailing list identified by the mailingListId.
Public method | GetMailingListMembers | Gets all the mailing list members corresponding to a particular mailing list identified by the mailingListId.
Public method | GetMailingLists | Gets all the mailing lists created by the currently logged in user.
Public method | GetMailingListSelectionList | Gets all the members of the all the groups (only name and email Address) where the currenly logged in user belongs and all the memebers of all the address books visible to the user. All these members' and contacts' names and email addresses are merged in one unique list in order for the user to select from it to add to his/her mailing list.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertBlockedEmailAddress | Inserts a new email Address into the blocked sender list for the currently logged in user.
Public method | InsertEmailAccount | Inserts all the details related to the a particular email account into the database.
Public method | InsertEmailFileIntoFileSystem | Inserts the email file into the file system
Public method | InsertEmailFolder | Inserts all the information related to a particular email folder.
Public method | InsertEmailInfo | Inserts all the information corresponding to a particular email.
Public method | InsertEmailRule | Inserts all the details related to an email rule into the database.
Public method | InsertMailingList | Inserts a new mailing list into the database.
Public method | InsertMailingListMemberInfo | Inserts a new mailing list member into a mailing list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PutEmailsInFolder | Puts a single email or a set of emails into a particular folder.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateBlockedEmailAddress | Inserts a new email Address into the blocked sender list if it already does not exist for the currently logged in user.
Public method | UpdateEmailAccount | Updates all the details related to the a particular email account into the database.
Public method | UpdateEmailFolder | Updates all the information related to a particular email folder.
Public method | UpdateEmailInfo | Updates all the information corresponding to a particular email into the database.
Public method | UpdateEmailMarkDeleted | Overloaded.
Public method | UpdateEmailMoveRuleDown | Moves a particular email rule down in the order for the currently logged in user.
Public method | UpdateEmailMoveRuleUp | Moves a particular email rule up in the order for the currently logged in user.
Public method | UpdateEmailPreference | Updates the email preferences for a particular user in the database.
Public method | UpdateEmailRule | Updates all the details related to an email rule into the database.
Public method | UpdateMailingList | Updates mailing list information into the database.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


EmailDB Constructor

[image] [image]

OfficeClip API Documentation
EmailDB Constructor
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | EmailDB()()() | Constructor
Public method | EmailDB(OfficeClipDB) | Constructor

See Also

EmailDB Class
EmailDB Members
OfficeClip.DBLayer.Desktop Namespace


EmailDB Constructor

[image]

OfficeClip API Documentation
EmailDB Constructor
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public EmailDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmailDB()

See Also

EmailDB Class
EmailDB Overload
OfficeClip.DBLayer.Desktop Namespace


EmailDB Constructor (OfficeClipDB)

[image]

OfficeClip API Documentation
EmailDB Constructor (OfficeClipDB)
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public EmailDB(
    OfficeClipDB ma
)
Visual Basic (Declaration)
Public Sub New ( _
    ma As OfficeClipDB _
)
Visual C++
public:
EmailDB(
    OfficeClipDB^ ma
)

Parameters

ma
Type: OfficeClip.DBLayer..::.OfficeClipDB

See Also

EmailDB Class
EmailDB Overload
OfficeClip.DBLayer.Desktop Namespace


EmailDB Methods

[image] [image]

OfficeClip API Documentation
EmailDB Methods
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

The EmailDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteBlockedEmailAddress | Removes a particular email Address from the blocked sender list.
Public method | DeleteEmail | Deletes a particular email idenfied by emailId in the database and the filesystem.
Public method | DeleteEmailAccount | Deletes all the information related to a particular email account identified by emailAccountId.
Public method | DeleteEmailFolder | Deletes all the information related to a particular email folder.
Public method | DeleteEmailInfo | Deletes a particular email idenfied by emailId in the database and the filesystem.
Public method | DeleteEmailPreference | Deletes the email preferences for a particular user.
Public method | DeleteEmailRule | Deletes all the details corresponding to a particular rule indentified by emailRuleId.
Public method | DeleteMailingList | Deletes the complete mailing list including all the members if any.
Public method | DeleteMailingListMember | Deletes a mailing list member from the mailing list.
Public method | DeleteMailingListMembers | Deletes all mailing list members from the mailing list.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccountColorSchemes | Gets all the color schemes specified in the OfficeClip email account color sheme resource file (desktop/email/accountColorScheme.xml). Please refer to the
Public method | GetBlockSenderList | Gets a list of email addresses, emails from which need to be discarded.
Public method | GetEmailAccount | Gets all the details related to the a particular email account identified by the emailAccountId.
Public method | GetEmailAccounts | Gets all the information for all the email accounts for the currently logged in user.
 | GetEmailFileLocation | Gets the email file location
Public method | GetEmailFolder | Gets all the information related to a particular email folder identified by the emailFolderId.
Public method | GetEmailFolderNames | Gets a list of all the email folders for currently logged in user.
Public method | GetEmailFolders | Gets all the email folders created for the currently logged in user.
Public method | GetEmailInfo | Gets all the information corresponding to a particular email identified by emailId.
Public method | GetEmailInfoList | Gets all the information List of all emails info for those emailIds supplied in eidList.
Public method | GetEmailListGridLayout | Returns the order in which the columns in the email list are to be displayed. For more information refer to the OfficeClip customization document, level 1 customization using the emailList.xml.
Public method | GetEmailListGridNumberOfRows | Gets the number of rows per page as specified in the xml configuration file emailList.xml. Please refer to the OfficeClip level 1 customization help.
Public method | GetEmailPreference | Gets the email preferences for a particular user.
Public method | GetEmailRule | Gets all the details corresponding to a particular email rule identified by emailRuleId.
Public method | GetEmailRules | Gets all the details corresponding to all the email rules set by the currently logged in user.
Public method | GetEmails | Gets all the stored emails and their related information in the OfficeClip database for the currently logged in user.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMailingListInfo | Gets all the information related to a particular mailing list identified by the mailingListId.
Public method | GetMailingListMembers | Gets all the mailing list members corresponding to a particular mailing list identified by the mailingListId.
Public method | GetMailingLists | Gets all the mailing lists created by the currently logged in user.
Public method | GetMailingListSelectionList | Gets all the members of the all the groups (only name and email Address) where the currenly logged in user belongs and all the memebers of all the address books visible to the user. All these members' and contacts' names and email addresses are merged in one unique list in order for the user to select from it to add to his/her mailing list.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertBlockedEmailAddress | Inserts a new email Address into the blocked sender list for the currently logged in user.
Public method | InsertEmailAccount | Inserts all the details related to the a particular email account into the database.
Public method | InsertEmailFileIntoFileSystem | Inserts the email file into the file system
Public method | InsertEmailFolder | Inserts all the information related to a particular email folder.
Public method | InsertEmailInfo | Inserts all the information corresponding to a particular email.
Public method | InsertEmailRule | Inserts all the details related to an email rule into the database.
Public method | InsertMailingList | Inserts a new mailing list into the database.
Public method | InsertMailingListMemberInfo | Inserts a new mailing list member into a mailing list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PutEmailsInFolder | Puts a single email or a set of emails into a particular folder.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateBlockedEmailAddress | Inserts a new email Address into the blocked sender list if it already does not exist for the currently logged in user.
Public method | UpdateEmailAccount | Updates all the details related to the a particular email account into the database.
Public method | UpdateEmailFolder | Updates all the information related to a particular email folder.
Public method | UpdateEmailInfo | Updates all the information corresponding to a particular email into the database.
Public method | UpdateEmailMarkDeleted | Overloaded.
Public method | UpdateEmailMoveRuleDown | Moves a particular email rule down in the order for the currently logged in user.
Public method | UpdateEmailMoveRuleUp | Moves a particular email rule up in the order for the currently logged in user.
Public method | UpdateEmailPreference | Updates the email preferences for a particular user in the database.
Public method | UpdateEmailRule | Updates all the details related to an email rule into the database.
Public method | UpdateMailingList | Updates mailing list information into the database.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
EmailDB..::.AddOutputParameter Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

EmailDB Class
EmailDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
EmailDB..::.AddParameter Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

EmailDB Class
EmailDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
EmailDB..::.AddParameters Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

EmailDB Class
EmailDB Members
OfficeClip.DBLayer.Desktop Namespace


DeleteBlockedEmailAddress Method

[image]

OfficeClip API Documentation
EmailDB..::.DeleteBlockedEmailAddress Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes a particular email Address from the blocked sender list.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteBlockedEmailAddress(
    string blockedEmailAddress,
    int userId
)
Visual Basic (Declaration)
Public Function DeleteBlockedEmailAddress ( _
    blockedEmailAddress As String, _
    userId As Integer _
) As Integer
Visual C++
public:
int DeleteBlockedEmailAddress(
    String^ blockedEmailAddress,
    int userId
)

Parameters

blockedEmailAddress
Type: System..::.String
Email Address which needs to be removed from the blocked sender list.
userId
Type: System..::.Int32
Unique id for the user

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteEmail Method

[image]

OfficeClip API Documentation
EmailDB..::.DeleteEmail Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a particular email idenfied by emailId in the database and the filesystem.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteEmail(
    int emailId,
    int userId
)
Visual Basic (Declaration)
Public Function DeleteEmail ( _
    emailId As Integer, _
    userId As Integer _
) As Integer
Visual C++
public:
int DeleteEmail(
    int emailId,
    int userId
)

Parameters

emailId
Type: System..::.Int32
Id of the email which needs to be deleted.
userId
Type: System..::.Int32
Unique id for the user

Return Value

0 when successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteEmailAccount Method

[image]

OfficeClip API Documentation
EmailDB..::.DeleteEmailAccount Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all the information related to a particular email account identified by emailAccountId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteEmailAccount(
    int emailAccountId
)
Visual Basic (Declaration)
Public Function DeleteEmailAccount ( _
    emailAccountId As Integer _
) As Integer
Visual C++
public:
int DeleteEmailAccount(
    int emailAccountId
)

Parameters

emailAccountId
Type: System..::.Int32
Id of the email account.

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteEmailFolder Method

[image]

OfficeClip API Documentation
EmailDB..::.DeleteEmailFolder Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all the information related to a particular email folder.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteEmailFolder(
    int emailFolderId
)
Visual Basic (Declaration)
Public Function DeleteEmailFolder ( _
    emailFolderId As Integer _
) As Integer
Visual C++
public:
int DeleteEmailFolder(
    int emailFolderId
)

Parameters

emailFolderId
Type: System..::.Int32
Id of the email folder to be deleted.

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteEmailInfo Method

[image]

OfficeClip API Documentation
EmailDB..::.DeleteEmailInfo Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a particular email idenfied by emailId in the database and the filesystem.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteEmailInfo(
    int emailId
)
Visual Basic (Declaration)
Public Function DeleteEmailInfo ( _
    emailId As Integer _
) As Integer
Visual C++
public:
int DeleteEmailInfo(
    int emailId
)

Parameters

emailId
Type: System..::.Int32
Id of the email which needs to be deleted.

Return Value

0 when successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteEmailPreference Method

[image]

OfficeClip API Documentation
EmailDB..::.DeleteEmailPreference Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the email preferences for a particular user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteEmailPreference(
    int userId
)
Visual Basic (Declaration)
Public Function DeleteEmailPreference ( _
    userId As Integer _
) As Integer
Visual C++
public:
int DeleteEmailPreference(
    int userId
)

Parameters

userId
Type: System..::.Int32
Id of the user for whom the email preferences.

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteEmailRule Method

[image]

OfficeClip API Documentation
EmailDB..::.DeleteEmailRule Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all the details corresponding to a particular rule indentified by emailRuleId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteEmailRule(
    int emailRuleId,
    int userId
)
Visual Basic (Declaration)
Public Function DeleteEmailRule ( _
    emailRuleId As Integer, _
    userId As Integer _
) As Integer
Visual C++
public:
int DeleteEmailRule(
    int emailRuleId,
    int userId
)

Parameters

emailRuleId
Type: System..::.Int32
Id of the email rule which needs to be deleted.
userId
Type: System..::.Int32
Unique id for the user

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteMailingList Method

[image]

OfficeClip API Documentation
EmailDB..::.DeleteMailingList Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the complete mailing list including all the members if any.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteMailingList(
    int mailingListId
)
Visual Basic (Declaration)
Public Function DeleteMailingList ( _
    mailingListId As Integer _
) As Integer
Visual C++
public:
int DeleteMailingList(
    int mailingListId
)

Parameters

mailingListId
Type: System..::.Int32
Id of the mailing list which needs to be deleted.

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteMailingListMember Method

[image]

OfficeClip API Documentation
EmailDB..::.DeleteMailingListMember Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a mailing list member from the mailing list.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteMailingListMember(
    int mailingListId,
    int mailingListMemberId
)
Visual Basic (Declaration)
Public Function DeleteMailingListMember ( _
    mailingListId As Integer, _
    mailingListMemberId As Integer _
) As Integer
Visual C++
public:
int DeleteMailingListMember(
    int mailingListId,
    int mailingListMemberId
)

Parameters

mailingListId
Type: System..::.Int32
Id of the mailing list from which the member needs to be deleted.
mailingListMemberId
Type: System..::.Int32
Id of the member who needs to be deleted from the mailing list.

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteMailingListMembers Method

[image]

OfficeClip API Documentation
EmailDB..::.DeleteMailingListMembers Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all mailing list members from the mailing list.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteMailingListMembers(
    int mailingListId
)
Visual Basic (Declaration)
Public Function DeleteMailingListMembers ( _
    mailingListId As Integer _
) As Integer
Visual C++
public:
int DeleteMailingListMembers(
    int mailingListId
)

Parameters

mailingListId
Type: System..::.Int32
Id of the mailing list from which the all the members need to be deleted.

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
EmailDB..::.ExecuteNonQuery Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

EmailDB Class
EmailDB Members
OfficeClip.DBLayer.Desktop Namespace


GetAccountColorSchemes Method

[image]

OfficeClip API Documentation
EmailDB..::.GetAccountColorSchemes Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the color schemes specified in the OfficeClip email account color sheme resource file (desktop/email/accountColorScheme.xml). Please refer to the

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAccountColorSchemes()
Visual Basic (Declaration)
Public Function GetAccountColorSchemes As DataSet
Visual C++
public:
DataSet^ GetAccountColorSchemes()

Return Value

DataSet containing the name all the OfficeClip supported colors to be used for highlighting mails from a particular email account. The DataSet contains a DataTable called Color with a column called Value (System.String) specifying the name of color.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetBlockSenderList Method

[image]

OfficeClip API Documentation
EmailDB..::.GetBlockSenderList Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of email addresses, emails from which need to be discarded.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetBlockSenderList(
    int userId
)
Visual Basic (Declaration)
Public Function GetBlockSenderList ( _
    userId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetBlockSenderList(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

List of email addresses which if found in the from property of an email message, that email message needs to be discarded.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailAccount Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailAccount Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details related to the a particular email account identified by the emailAccountId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public EmailAccountInfo GetEmailAccount(
    int emailAccountId
)
Visual Basic (Declaration)
Public Function GetEmailAccount ( _
    emailAccountId As Integer _
) As EmailAccountInfo
Visual C++
public:
EmailAccountInfo^ GetEmailAccount(
    int emailAccountId
)

Parameters

emailAccountId
Type: System..::.Int32
Id of the email account for which the details are to be retrieved.

Return Value

Instance of the EmailAccountInfo object containing all the details to a particular email account. OfficeClip.BusinessLayer.Desktop.Email..::.EmailAccountInfo

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailAccounts Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailAccounts Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information for all the email accounts for the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetEmailAccounts(
    int userId,
    bool isSendOnly
)
Visual Basic (Declaration)
Public Function GetEmailAccounts ( _
    userId As Integer, _
    isSendOnly As Boolean _
) As DataTable
Visual C++
public:
DataTable^ GetEmailAccounts(
    int userId,
    bool isSendOnly
)

Parameters

userId
Type: System..::.Int32
isSendOnly
Type: System..::.Boolean

Return Value

DataSet containing all the information related to all the email accounts for the Current user. DataSet consists of a single DataTable with the following columns.
  • emailAccountId (System.Int32) Id of the email account.
  • UserId (System.Int32) Id of the user to which this particular email account belongs. (Always the currently logged in user).
  • EmailAccountName (System.String) Name of the email account.
  • serverName (System.String) Name of the POP email server.
  • UserName (System.String) User's login name on the POP email server.
  • UserPassword (System.String) User's password on the POP email server.
  • PortNumber (System.Int32) The port number to which to connect to on the POP email server. (Usually this value is 110).
  • ServerTimeout (System.Int32) Time (in seconds) for which to wait while trying to connecting to the POP email server.
  • LeaveCopyOnServer (System.String) Flag (Y/N) indicating whether while downloading new mails, a copy should be left on the email server.
  • ColorScheme (System.String) Name of the color to be used to highlight emails from a particular POP email server.
  • ServerType (System.String) Type of the server, POP, IMAP, etc. (This field is not yet used. It has been kept for future enhancements for providing integration with different types of mail servers.)
  • OutgoingServerSameAsIncoming (System.String) Flag (Y/N) indicating whether the outgoing (SMTP) server is same as the POP email server specified above.
  • OutgoingServerName (System.String) Name of the outgoing (SMTP) mail server to send outgoing emails.
  • OutgoingServerNeedsAuthentication (System.String) Flag (Y/N) indicating whether the outgoing (SMTP) mail server needs authentication i.e. whether a user id and password needs to be specified while connecting to the SMTP server.
  • OutgoingServerType (System.String) Type of the outgoing mail server. (This field is not yet used. It has been kept for future enhancements for providing integration with different types of mail servers.)
  • OutgoingServerUserName (System.String) The user id on the outgoing email server. This field is only present if outgoing server needs authentication.
  • OutgoingServerUserPassword (System.String) password corresponding to the user id on the outgoing email server. This field is only present if outgoing server needs authentication.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailFileLocation Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailFileLocation Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the email file location

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static bool GetEmailFileLocation(
    int emailId,
    int userId,
    out string fileLocation
)
Visual Basic (Declaration)
Public Shared Function GetEmailFileLocation ( _
    emailId As Integer, _
    userId As Integer, _
    <OutAttribute> ByRef fileLocation As String _
) As Boolean
Visual C++
public:
static bool GetEmailFileLocation(
    int emailId,
    int userId,
    [OutAttribute] String^% fileLocation
)

Parameters

emailId
Type: System..::.Int32
userId
Type: System..::.Int32
fileLocation
Type: System..::.String%

Return Value

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailFolder Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailFolder Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to a particular email folder identified by the emailFolderId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public EmailFolderInfo GetEmailFolder(
    int emailFolderId
)
Visual Basic (Declaration)
Public Function GetEmailFolder ( _
    emailFolderId As Integer _
) As EmailFolderInfo
Visual C++
public:
EmailFolderInfo^ GetEmailFolder(
    int emailFolderId
)

Parameters

emailFolderId
Type: System..::.Int32
Id of the email folder.

Return Value

Instance of EmailFolderInfo object containing all the information for a particular email folder. OfficeClip.BusinessLayer.Desktop.Email..::.EmailFolderInfo

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailFolderNames Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailFolderNames Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the email folders for currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetEmailFolderNames(
    int userId
)
Visual Basic (Declaration)
Public Function GetEmailFolderNames ( _
    userId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetEmailFolderNames(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

DataTable containing the following columns.
  • emailFolderId (System.Int32)Id of the email folder.
  • EmailFolderName (Syste.String)Name of the email folder.

Remarks

This function returns an extra row with value "Put In Folder" with id = 0 as the first row. If this row is not required, run the commad DataRow.Delete() and DataTable.AcceptChanges() before binding to a control.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailFolders Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailFolders Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the email folders created for the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetEmailFolders(
    int userId
)
Visual Basic (Declaration)
Public Function GetEmailFolders ( _
    userId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetEmailFolders(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

DataTable with the following columns.
  • emailFolderId (System.Int32)Id of the email folder.
  • EmailFolderTypeId (System.Int32)Type of email folder.
                    1 = Inbox
                    2 = Sent Messages
                    3 = Drafts
                    4 = Deleted
                    10 = User Defined
  • EmailFolderName (System.String)Name of the email folder.
  • messageCount (System.Int32)Number of email messages in a particular email folder.
  • newMessageCount (System.Int32)Number of new (unread) email messages in a particular email folder.
  • totalMessageSize (System.Int32)Total size (in KB) of all the email messages in a particular email folder.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailInfo Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailInfo Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information corresponding to a particular email identified by emailId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public EmailInfo GetEmailInfo(
    int emailId
)
Visual Basic (Declaration)
Public Function GetEmailInfo ( _
    emailId As Integer _
) As EmailInfo
Visual C++
public:
EmailInfo^ GetEmailInfo(
    int emailId
)

Parameters

emailId
Type: System..::.Int32
Id of the email.

Return Value

Instance of the EmailInfo object containing all the information corresponding to a particular email. OfficeClip.BusinessLayer.Desktop.Email..::.EmailInfo

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailInfoList Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailInfoList Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information List of all emails info for those emailIds supplied in eidList.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<EmailInfo> GetEmailInfoList(
    ArrayList eidList
)
Visual Basic (Declaration)
Public Function GetEmailInfoList ( _
    eidList As ArrayList _
) As List(Of EmailInfo)
Visual C++
public:
List<EmailInfo^>^ GetEmailInfoList(
    ArrayList^ eidList
)

Parameters

eidList
Type: System.Collections..::.ArrayList

Return Value

Instance of the EmailInfo object containing all the information corresponding to a particular email. OfficeClip.BusinessLayer.Desktop.Email..::.EmailInfo

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailListGridLayout Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailListGridLayout Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the order in which the columns in the email list are to be displayed. For more information refer to the OfficeClip customization document, level 1 customization using the emailList.xml.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetEmailListGridLayout()
Visual Basic (Declaration)
Public Function GetEmailListGridLayout As ArrayList
Visual C++
public:
ArrayList^ GetEmailListGridLayout()

Return Value

ArrayList of the all the email column names in the order in which they are to be displayed on the email list screen.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailListGridNumberOfRows Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailListGridNumberOfRows Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the number of rows per page as specified in the xml configuration file emailList.xml. Please refer to the OfficeClip level 1 customization help.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetEmailListGridNumberOfRows()
Visual Basic (Declaration)
Public Function GetEmailListGridNumberOfRows As Integer
Visual C++
public:
int GetEmailListGridNumberOfRows()

Return Value

Number of rows to be displayed on the email list screen.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailPreference Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailPreference Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the email preferences for a particular user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public EmailPreferenceInfo GetEmailPreference(
    int userId
)
Visual Basic (Declaration)
Public Function GetEmailPreference ( _
    userId As Integer _
) As EmailPreferenceInfo
Visual C++
public:
EmailPreferenceInfo^ GetEmailPreference(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

Instance of the EmailPreferenceInfo object containg all the information related to the email preferences of a particular user. OfficeClip.BusinessLayer.Desktop.Email..::.EmailPreferenceInfo

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailRule Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailRule Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details corresponding to a particular email rule identified by emailRuleId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public EmailRuleInfo GetEmailRule(
    int emailRuleId
)
Visual Basic (Declaration)
Public Function GetEmailRule ( _
    emailRuleId As Integer _
) As EmailRuleInfo
Visual C++
public:
EmailRuleInfo^ GetEmailRule(
    int emailRuleId
)

Parameters

emailRuleId
Type: System..::.Int32
Id of the email rule.

Return Value

Instance of EmailRuleInfo object containing all the details corresponding to a particular email rule set by the user. OfficeClip.BusinessLayer.Desktop.Email..::.EmailRuleInfo

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmailRules Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmailRules Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details corresponding to all the email rules set by the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetEmailRules(
    int userId
)
Visual Basic (Declaration)
Public Function GetEmailRules ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetEmailRules(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

DataSet containg all the email rules information. This DataSet consists of a single DataTable with the following columns.
  • emailRuleId (System.Int32)Id of the email rule.
  • UserId (System.Int32)Id of the user who has created this email rule. (Currently logged in user.)
  • ConditionId (System.Int32)This is the type of the condition. Possible values are 1 or 2.
  • ConditionFieldId (System.Int32)Id of the condition fields
                    Values corresponding to the condition type 1 are:
                    0 = Contains
                    1 = Does not contain
                    2 = Contains word
                    3 = Starts with
                    4 = Ends with
                    5 = Equals
                    Values corresponding to the condition type 2 are:
                    0 = Message size
                    1 = Attachments size
  • ConditionValueId (System.Int32)Field id corresponding to the condition id.
                    Field values corresponding to fields of condition type 1 are:
                    0 = From Address
                    1 = From name
                    2 = Subject
                    3 = Text
                    4 = To or CC
                    5 = Account
                    Field values corresponding to fields of condition type 2 are:
                    0 = Is greater than
                    1 = Is less than
  • ConditionValue (System.String)Value specified by the user to match the condition.
  • ActionId (System.Int32)Id of the action to be taken if the value specified by the user matches the condition.
                    1 = Move the email to a specific folder
                    2 = Mark the email message as high priority
                    3 = Notify the user of the email in OfficeClip alerts
  • ActionValue (System.Int32)This contains the email folder in which the user wishes the email to be moved if action id chosen is 1.
  • RuleOrderNumber (System.Int32)This determines the order in which a particular rule will be processed.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetEmails Method

[image]

OfficeClip API Documentation
EmailDB..::.GetEmails Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the stored emails and their related information in the OfficeClip database for the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetEmails(
    int userId
)
Visual Basic (Declaration)
Public Function GetEmails ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetEmails(
    int userId
)

Parameters

userId
Type: System..::.Int32
the unique id of the user

Return Value

DataSet containing all information related to the emails stored in the OfficeClip database which were retrieved earlier. The DataSet consists of a single DataTable with the following columns.
  • emailId (System.Int32)Id of the email.
  • emailFolderId (System.Int32)Id of the folder in which this particular email is stored.
  • EmailFolderTypeId (System.Int32)Type of the folder in which this particular email is stored.
                    1 = Inbox
                    2 = Sent Messages
                    3 = Drafts
                    4 = Delete
                    10 = User Defined.
  • UserId (System.Int32)Id of the user for whom the emails are being retrieved. (The currenly logged in user.)
  • emailAccountId (System.Int32)Id of the email account corresponding to the Email server from which this particular email has been downloaded.
  • ReceivedTimestamp (System.DateTime)Date and Time at which this email was received on the email server.
  • RepliedTimestamp (System.DateTime)Date and Time when the user replied to this particular email.
  • ReplyToEmailId (System.Int32)Id of the email if this email was sent as a reply to an email.
  • ForwardedTimestamp (System.DateTime)Date and Time when the user forwarded this particular email
  • ForwardFromEmailId (System.Int32)Id of the email if this email was sent as a forward to an email.
  • SentTimestamp (System.Int32)Date and Time when this mail was sent by this user.
  • EmailStatus (System.Int32) Numeric value corresponding to the EmailStatus enumerated type indicating the Current status of this particular email. OfficeClip.Utils..::.EmailStatus
  • messageId (System.String)Unique ID assigned by the email server to each email message.
  • fromEmailAddress (System.String)The from email address of the email message.
  • toEmailAddress (System.String)The to email address of the email message.
  • subject (System.String)The subject of the email message.
  • size (System.Int32)The size of the email message.
  • isAttachmentPresent (System.Boolean)Whether an attachment is present with the email message.
  • priority (System.String)The priority of the email email message.
  • EmailAccountName (System.String)Name of the email account corresponding to the email server from which this email was downloaded.
  • accountColorScheme (System.String)Name of the color scheme to be used to highlight this email to signify that it has been downloaded from a particular email server.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetMailingListInfo Method

[image]

OfficeClip API Documentation
EmailDB..::.GetMailingListInfo Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to a particular mailing list identified by the mailingListId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MailingListInfo GetMailingListInfo(
    int mailingListId
)
Visual Basic (Declaration)
Public Function GetMailingListInfo ( _
    mailingListId As Integer _
) As MailingListInfo
Visual C++
public:
MailingListInfo^ GetMailingListInfo(
    int mailingListId
)

Parameters

mailingListId
Type: System..::.Int32
Id of the mailing list for which the information needs to be retrieved.

Return Value

Instance of the MailingListInfo object containing all the information related to the mailing list. OfficeClip.BusinessLayer.Desktop.Email..::.MailingListInfo

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetMailingListMembers Method

[image]

OfficeClip API Documentation
EmailDB..::.GetMailingListMembers Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the mailing list members corresponding to a particular mailing list identified by the mailingListId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetMailingListMembers(
    int mailingListId
)
Visual Basic (Declaration)
Public Function GetMailingListMembers ( _
    mailingListId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetMailingListMembers(
    int mailingListId
)

Parameters

mailingListId
Type: System..::.Int32
Id of the mailing list whose members are to be retrieved.

Return Value

ArrayList of MailingListMemberInfo list member info objects containing all the details of each member in the list. OfficeClip.BusinessLayer.Desktop.Email..::.MailingListMemberInfo

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetMailingLists Method

[image]

OfficeClip API Documentation
EmailDB..::.GetMailingLists Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the mailing lists created by the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetMailingLists(
    int userId
)
Visual Basic (Declaration)
Public Function GetMailingLists ( _
    userId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetMailingLists(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

DataTable containing the name and id of the email mailing lists created by the Current user. This DataTable has the following two columns.
  • mailingListId (System.Int32)Id of the mailing list.
  • MailingListName (System.String)Name of the mailing list.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


GetMailingListSelectionList Method

[image]

OfficeClip API Documentation
EmailDB..::.GetMailingListSelectionList Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the members of the all the groups (only name and email Address) where the currenly logged in user belongs and all the memebers of all the address books visible to the user. All these members' and contacts' names and email addresses are merged in one unique list in order for the user to select from it to add to his/her mailing list.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetMailingListSelectionList(
    int userId,
    int groupId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function GetMailingListSelectionList ( _
    userId As Integer, _
    groupId As Integer, _
    isAdmin As Boolean _
) As DataView
Visual C++
public:
DataView^ GetMailingListSelectionList(
    int userId,
    int groupId,
    bool isAdmin
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
isAdmin
Type: System..::.Boolean

Return Value

DataView containing the following two columns.
  • MemberUserId (System.Int32)Id of the member or address book entry selected to be added to the mailing list.
  • memberNameAndEmail (System.String)Name and email Address of the member or address book entry selected to be added to the mailing list.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
EmailDB..::.InitTransaction Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

EmailDB Class
EmailDB Members
OfficeClip.DBLayer.Desktop Namespace


InsertBlockedEmailAddress Method

[image]

OfficeClip API Documentation
EmailDB..::.InsertBlockedEmailAddress Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new email Address into the blocked sender list for the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertBlockedEmailAddress(
    string blockedEmailAddress,
    int userId
)
Visual Basic (Declaration)
Public Function InsertBlockedEmailAddress ( _
    blockedEmailAddress As String, _
    userId As Integer _
) As Integer
Visual C++
public:
int InsertBlockedEmailAddress(
    String^ blockedEmailAddress,
    int userId
)

Parameters

blockedEmailAddress
Type: System..::.String
Email Address which need to be added to the blocked list.
userId
Type: System..::.Int32
Unique id for the user

Return Value

0 if successful, -1 in case of a general error, -2 when the email Address being added is already in the blocked sender list.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertEmailAccount Method

[image]

OfficeClip API Documentation
EmailDB..::.InsertEmailAccount Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the details related to the a particular email account into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertEmailAccount(
    EmailAccountInfo eai
)
Visual Basic (Declaration)
Public Function InsertEmailAccount ( _
    eai As EmailAccountInfo _
) As Integer
Visual C++
public:
int InsertEmailAccount(
    EmailAccountInfo^ eai
)

Parameters

eai
Type: OfficeClip.BusinessLayer.Desktop.Email..::.EmailAccountInfo
Instance of the EmailAccountInfo object containing all the details to a particular email account. OfficeClip.BusinessLayer.Desktop.Email..::.EmailAccountInfo

Return Value

Id of the newly created email account if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertEmailFileIntoFileSystem Method

[image]

OfficeClip API Documentation
EmailDB..::.InsertEmailFileIntoFileSystem Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the email file into the file system

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertEmailFileIntoFileSystem(
    int groupId,
    int userId,
    int emailId,
    OCMailMessage message
)
Visual Basic (Declaration)
Public Function InsertEmailFileIntoFileSystem ( _
    groupId As Integer, _
    userId As Integer, _
    emailId As Integer, _
    message As OCMailMessage _
) As Integer
Visual C++
public:
int InsertEmailFileIntoFileSystem(
    int groupId,
    int userId,
    int emailId,
    OCMailMessage^ message
)

Parameters

groupId
Type: System..::.Int32
userId
Type: System..::.Int32
emailId
Type: System..::.Int32
message
Type: OCMailMessage

Return Value

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertEmailFolder Method

[image]

OfficeClip API Documentation
EmailDB..::.InsertEmailFolder Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the information related to a particular email folder.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertEmailFolder(
    EmailFolderInfo efi
)
Visual Basic (Declaration)
Public Function InsertEmailFolder ( _
    efi As EmailFolderInfo _
) As Integer
Visual C++
public:
int InsertEmailFolder(
    EmailFolderInfo^ efi
)

Parameters

efi
Type: OfficeClip.BusinessLayer.Desktop.Email..::.EmailFolderInfo
Instance of EmailFolderInfo object containing all the information for a particular email folder. OfficeClip.BusinessLayer.Desktop.Email..::.EmailFolderInfo

Return Value

Id of the newly created email folder if successful, -1 in case another folder of same name exists, -2 any other error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertEmailInfo Method

[image]

OfficeClip API Documentation
EmailDB..::.InsertEmailInfo Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the information corresponding to a particular email.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertEmailInfo(
    EmailInfo ei
)
Visual Basic (Declaration)
Public Function InsertEmailInfo ( _
    ei As EmailInfo _
) As Integer
Visual C++
public:
int InsertEmailInfo(
    EmailInfo^ ei
)

Parameters

ei
Type: OfficeClip.BusinessLayer.Desktop.Email..::.EmailInfo
Instance of the EmailInfo object containing all the information corresponding to a particular email. OfficeClip.BusinessLayer.Desktop.Email..::.EmailInfo

Return Value

Id of the newly created email if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertEmailRule Method

[image]

OfficeClip API Documentation
EmailDB..::.InsertEmailRule Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the details related to an email rule into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertEmailRule(
    EmailRuleInfo eri
)
Visual Basic (Declaration)
Public Function InsertEmailRule ( _
    eri As EmailRuleInfo _
) As Integer
Visual C++
public:
int InsertEmailRule(
    EmailRuleInfo^ eri
)

Parameters

eri
Type: OfficeClip.BusinessLayer.Desktop.Email..::.EmailRuleInfo
Instance of the EmailRuleInfo object containing all the information related to a particular email rule which needs to be stored.

Return Value

Id of the newly created email rule if successful, -1 in case of an error. OfficeClip.BusinessLayer.Desktop.Email..::.EmailRuleInfo

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertMailingList Method

[image]

OfficeClip API Documentation
EmailDB..::.InsertMailingList Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new mailing list into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertMailingList(
    MailingListInfo mli
)
Visual Basic (Declaration)
Public Function InsertMailingList ( _
    mli As MailingListInfo _
) As Integer
Visual C++
public:
int InsertMailingList(
    MailingListInfo^ mli
)

Parameters

mli
Type: OfficeClip.BusinessLayer.Desktop.Email..::.MailingListInfo
Instance of the MailingListInfo object to be inserted into the database. OfficeClip.BusinessLayer.Desktop.Email..::.MailingListInfo

Return Value

Id of the newly created mailing list if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertMailingListMemberInfo Method

[image]

OfficeClip API Documentation
EmailDB..::.InsertMailingListMemberInfo Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new mailing list member into a mailing list.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertMailingListMemberInfo(
    MailingListMemberInfo mlmi
)
Visual Basic (Declaration)
Public Function InsertMailingListMemberInfo ( _
    mlmi As MailingListMemberInfo _
) As Integer
Visual C++
public:
int InsertMailingListMemberInfo(
    MailingListMemberInfo^ mlmi
)

Parameters

mlmi
Type: OfficeClip.BusinessLayer.Desktop.Email..::.MailingListMemberInfo
Instance of MailingListMemberInfo object which needs to be inserted into a mailing list. OfficeClip.BusinessLayer.Desktop.Email..::.MailingListMemberInfo

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


PutEmailsInFolder Method

[image]

OfficeClip API Documentation
EmailDB..::.PutEmailsInFolder Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Puts a single email or a set of emails into a particular folder.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int PutEmailsInFolder(
    int folderId,
    ArrayList emailIdList
)
Visual Basic (Declaration)
Public Function PutEmailsInFolder ( _
    folderId As Integer, _
    emailIdList As ArrayList _
) As Integer
Visual C++
public:
int PutEmailsInFolder(
    int folderId,
    ArrayList^ emailIdList
)

Parameters

folderId
Type: System..::.Int32
Id of the folder into which the selected email or emails have to be moved.
emailIdList
Type: System.Collections..::.ArrayList
ArrayList of ids of the emails which need to be moved to a particular email folder identified by emailFolderId.

Return Value

0 when successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
EmailDB..::.SetSPCommand Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

EmailDB Class
EmailDB Members
OfficeClip.DBLayer.Desktop Namespace


UpdateBlockedEmailAddress Method

[image]

OfficeClip API Documentation
EmailDB..::.UpdateBlockedEmailAddress Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new email Address into the blocked sender list if it already does not exist for the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateBlockedEmailAddress(
    string blockedEmailAddress,
    int userId
)
Visual Basic (Declaration)
Public Function UpdateBlockedEmailAddress ( _
    blockedEmailAddress As String, _
    userId As Integer _
) As Integer
Visual C++
public:
int UpdateBlockedEmailAddress(
    String^ blockedEmailAddress,
    int userId
)

Parameters

blockedEmailAddress
Type: System..::.String
Email Address which need to be added to the blocked list.
userId
Type: System..::.Int32
Unique id for the user

Return Value

0 if successful, -1 in case of an error

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateEmailAccount Method

[image]

OfficeClip API Documentation
EmailDB..::.UpdateEmailAccount Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the details related to the a particular email account into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateEmailAccount(
    EmailAccountInfo eai
)
Visual Basic (Declaration)
Public Function UpdateEmailAccount ( _
    eai As EmailAccountInfo _
) As Integer
Visual C++
public:
int UpdateEmailAccount(
    EmailAccountInfo^ eai
)

Parameters

eai
Type: OfficeClip.BusinessLayer.Desktop.Email..::.EmailAccountInfo
Instance of the EmailAccountInfo object containing all the details to a particular email account. OfficeClip.BusinessLayer.Desktop.Email..::.EmailAccountInfo

Return Value

0 when successful, -1 in case of a general error, -2 in case the email account name specified is already present corresponding to another email server for the same user.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateEmailFolder Method

[image]

OfficeClip API Documentation
EmailDB..::.UpdateEmailFolder Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the information related to a particular email folder.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateEmailFolder(
    EmailFolderInfo efi
)
Visual Basic (Declaration)
Public Function UpdateEmailFolder ( _
    efi As EmailFolderInfo _
) As Integer
Visual C++
public:
int UpdateEmailFolder(
    EmailFolderInfo^ efi
)

Parameters

efi
Type: OfficeClip.BusinessLayer.Desktop.Email..::.EmailFolderInfo
Instance of EmailFolderInfo object containing all the information for a particular email folder. OfficeClip.BusinessLayer.Desktop.Email..::.EmailFolderInfo

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateEmailInfo Method

[image]

OfficeClip API Documentation
EmailDB..::.UpdateEmailInfo Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the information corresponding to a particular email into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateEmailInfo(
    EmailInfo ei
)
Visual Basic (Declaration)
Public Function UpdateEmailInfo ( _
    ei As EmailInfo _
) As Integer
Visual C++
public:
int UpdateEmailInfo(
    EmailInfo^ ei
)

Parameters

ei
Type: OfficeClip.BusinessLayer.Desktop.Email..::.EmailInfo
Instance of the EmailInfo object containing all the information corresponding to a particular email. OfficeClip.BusinessLayer.Desktop.Email..::.EmailInfo

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateEmailMarkDeleted Method

[image] [image]

OfficeClip API Documentation
EmailDB..::.UpdateEmailMarkDeleted Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | UpdateEmailMarkDeleted(ArrayList) | Marks a single or a set of emails as deleted.
Public method | UpdateEmailMarkDeleted(Int32) | Marks a single or a set of emails as deleted.

See Also

EmailDB Class
EmailDB Members
OfficeClip.DBLayer.Desktop Namespace


UpdateEmailMarkDeleted Method (ArrayList)

[image]

OfficeClip API Documentation
EmailDB..::.UpdateEmailMarkDeleted Method (ArrayList)
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Marks a single or a set of emails as deleted.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateEmailMarkDeleted(
    ArrayList emailIdList
)
Visual Basic (Declaration)
Public Function UpdateEmailMarkDeleted ( _
    emailIdList As ArrayList _
) As Integer
Visual C++
public:
int UpdateEmailMarkDeleted(
    ArrayList^ emailIdList
)

Parameters

emailIdList
Type: System.Collections..::.ArrayList
ArrayList of Ids of all the emails which need to be marked as deleted.

Return Value

0 when successful, -1 in case of an error.

See Also

EmailDB Class
UpdateEmailMarkDeleted Overload
OfficeClip.DBLayer.Desktop Namespace


UpdateEmailMarkDeleted Method (Int32)

[image]

OfficeClip API Documentation
EmailDB..::.UpdateEmailMarkDeleted Method (Int32)
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Marks a single or a set of emails as deleted.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateEmailMarkDeleted(
    int emailId
)
Visual Basic (Declaration)
Public Function UpdateEmailMarkDeleted ( _
    emailId As Integer _
) As Integer
Visual C++
public:
int UpdateEmailMarkDeleted(
    int emailId
)

Parameters

emailId
Type: System..::.Int32
Id of the email which needs to be marked as deleted.

Return Value

0 when successful, -1 in case of an error.

See Also

EmailDB Class
UpdateEmailMarkDeleted Overload
OfficeClip.DBLayer.Desktop Namespace


UpdateEmailMoveRuleDown Method

[image]

OfficeClip API Documentation
EmailDB..::.UpdateEmailMoveRuleDown Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Moves a particular email rule down in the order for the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateEmailMoveRuleDown(
    int emailRuleId,
    int userId
)
Visual Basic (Declaration)
Public Function UpdateEmailMoveRuleDown ( _
    emailRuleId As Integer, _
    userId As Integer _
) As Integer
Visual C++
public:
int UpdateEmailMoveRuleDown(
    int emailRuleId,
    int userId
)

Parameters

emailRuleId
Type: System..::.Int32
Id of the email rule which needs to be moved down in order among the other.
userId
Type: System..::.Int32
Unique id for the user

Return Value

0 if successful, -1 in case of an error.

Remarks

If the email rule id being passed as parameter to this method is that of the last rule in order, it will have no effect.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateEmailMoveRuleUp Method

[image]

OfficeClip API Documentation
EmailDB..::.UpdateEmailMoveRuleUp Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Moves a particular email rule up in the order for the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateEmailMoveRuleUp(
    int emailRuleId,
    int userId
)
Visual Basic (Declaration)
Public Function UpdateEmailMoveRuleUp ( _
    emailRuleId As Integer, _
    userId As Integer _
) As Integer
Visual C++
public:
int UpdateEmailMoveRuleUp(
    int emailRuleId,
    int userId
)

Parameters

emailRuleId
Type: System..::.Int32
Id of the email rule which needs to be moved up in order among the other.
userId
Type: System..::.Int32
Unique id for the user

Return Value

0 if successful, -1 in case of an error.

Remarks

If the email rule id being passed as parameter to this method is that of the first rule in order, it will have no effect.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateEmailPreference Method

[image]

OfficeClip API Documentation
EmailDB..::.UpdateEmailPreference Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the email preferences for a particular user in the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateEmailPreference(
    EmailPreferenceInfo epi
)
Visual Basic (Declaration)
Public Function UpdateEmailPreference ( _
    epi As EmailPreferenceInfo _
) As Integer
Visual C++
public:
int UpdateEmailPreference(
    EmailPreferenceInfo^ epi
)

Parameters

epi
Type: OfficeClip.BusinessLayer.Desktop.Email..::.EmailPreferenceInfo
Instance of the EmailPreferenceInfo object containg all the information related to the email preferences of a particular user. OfficeClip.BusinessLayer.Desktop.Email..::.EmailPreferenceInfo

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateEmailRule Method

[image]

OfficeClip API Documentation
EmailDB..::.UpdateEmailRule Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the details related to an email rule into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateEmailRule(
    EmailRuleInfo eri
)
Visual Basic (Declaration)
Public Function UpdateEmailRule ( _
    eri As EmailRuleInfo _
) As Integer
Visual C++
public:
int UpdateEmailRule(
    EmailRuleInfo^ eri
)

Parameters

eri
Type: OfficeClip.BusinessLayer.Desktop.Email..::.EmailRuleInfo
Instance of the EmailRuleInfo object containing all the information related to a particular email rule which needs to be stored.

Return Value

0 if successful, -1 in case of an error. OfficeClip.BusinessLayer.Desktop.Email..::.EmailRuleInfo

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateMailingList Method

[image]

OfficeClip API Documentation
EmailDB..::.UpdateMailingList Method
EmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates mailing list information into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateMailingList(
    MailingListInfo mli
)
Visual Basic (Declaration)
Public Function UpdateMailingList ( _
    mli As MailingListInfo _
) As Integer
Visual C++
public:
int UpdateMailingList(
    MailingListInfo^ mli
)

Parameters

mli
Type: OfficeClip.BusinessLayer.Desktop.Email..::.MailingListInfo
Instance of the MailingListInfo object to be updated into the database. OfficeClip.BusinessLayer.Desktop.Email..::.MailingListInfo

Return Value

0 if successful, -1 in case of an error.

See Also

EmailDB Class
OfficeClip.DBLayer.Desktop Namespace


NoticeDB Class

[image]

OfficeClip API Documentation
NoticeDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Notice application related functions.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class NoticeDB : OfficeClipDB
Visual Basic (Declaration)
Public Class NoticeDB _
    Inherits OfficeClipDB
Visual C++
public ref class NoticeDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Desktop..::.NoticeDB

See Also

NoticeDB Members
OfficeClip.DBLayer.Desktop Namespace


NoticeDB Members

[image] [image]

OfficeClip API Documentation
NoticeDB Members
NoticeDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The NoticeDB type exposes the following members.

Constructors

 | Name | Description
Public method | NoticeDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllNotices | Gets all the notices for a group
Public method | GetCurrentNotice | The details of the notice if any if it is Active for a particular user at the Current moment.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNoticeDetail | Gets the details of a particular notice.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertNotice | Insert a new notice into the database for a particular user.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveNotice | Remove a particular notice from the database.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateNotice | Update the notice details.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

NoticeDB Class
OfficeClip.DBLayer.Desktop Namespace


NoticeDB Constructor

[image]

OfficeClip API Documentation
NoticeDB Constructor
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public NoticeDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NoticeDB()

See Also

NoticeDB Class
OfficeClip.DBLayer.Desktop Namespace


NoticeDB Methods

[image] [image]

OfficeClip API Documentation
NoticeDB Methods
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

The NoticeDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllNotices | Gets all the notices for a group
Public method | GetCurrentNotice | The details of the notice if any if it is Active for a particular user at the Current moment.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNoticeDetail | Gets the details of a particular notice.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertNotice | Insert a new notice into the database for a particular user.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveNotice | Remove a particular notice from the database.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateNotice | Update the notice details.

See Also

NoticeDB Class
OfficeClip.DBLayer.Desktop Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
NoticeDB..::.AddOutputParameter Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

NoticeDB Class
NoticeDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
NoticeDB..::.AddParameter Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

NoticeDB Class
NoticeDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
NoticeDB..::.AddParameters Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

NoticeDB Class
NoticeDB Members
OfficeClip.DBLayer.Desktop Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
NoticeDB..::.ExecuteNonQuery Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

NoticeDB Class
NoticeDB Members
OfficeClip.DBLayer.Desktop Namespace


GetAllNotices Method

[image]

OfficeClip API Documentation
NoticeDB..::.GetAllNotices Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the notices for a group

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetAllNotices(
    int groupId
)
Visual Basic (Declaration)
Public Function GetAllNotices ( _
    groupId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetAllNotices(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

Return Value

See Also

NoticeDB Class
OfficeClip.DBLayer.Desktop Namespace


GetCurrentNotice Method

[image]

OfficeClip API Documentation
NoticeDB..::.GetCurrentNotice Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

The details of the notice if any if it is Active for a particular user at the Current moment.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetCurrentNotice(
    int userId,
    ref string noticeDesc,
    ref DateTime fromDate,
    ref DateTime toDate,
    ref int createdUserId
)
Visual Basic (Declaration)
Public Function GetCurrentNotice ( _
    userId As Integer, _
    ByRef noticeDesc As String, _
    ByRef fromDate As DateTime, _
    ByRef toDate As DateTime, _
    ByRef createdUserId As Integer _
) As Integer
Visual C++
public:
int GetCurrentNotice(
    int userId,
    String^% noticeDesc,
    DateTime% fromDate,
    DateTime% toDate,
    int% createdUserId
)

Parameters

userId
Type: System..::.Int32
The ID of the user for which the Current notice
noticeDesc
Type: System..::.String%
The notice Description
fromDate
Type: System..::.DateTime%
The datetime from which the notice becomes Active.
toDate
Type: System..::.DateTime%
The datetime up to which the notice remains Active.
createdUserId
Type: System..::.Int32%
The ID of the user who created the User.

Return Value

The ID of the notice which is Current for a particular user at the time of the method request.

See Also

NoticeDB Class
OfficeClip.DBLayer.Desktop Namespace


GetNoticeDetail Method

[image]

OfficeClip API Documentation
NoticeDB..::.GetNoticeDetail Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the details of a particular notice.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetNoticeDetail(
    int messageId,
    ref string noticeDesc,
    ref DateTime fromDate,
    ref DateTime toDate
)
Visual Basic (Declaration)
Public Sub GetNoticeDetail ( _
    messageId As Integer, _
    ByRef noticeDesc As String, _
    ByRef fromDate As DateTime, _
    ByRef toDate As DateTime _
)
Visual C++
public:
void GetNoticeDetail(
    int messageId,
    String^% noticeDesc,
    DateTime% fromDate,
    DateTime% toDate
)

Parameters

messageId
Type: System..::.Int32
The ID of the notice for which the details are to be obtained.
noticeDesc
Type: System..::.String%
Notice Description
fromDate
Type: System..::.DateTime%
The datetime from which the notice becomes Active.
toDate
Type: System..::.DateTime%
The datetime up to which the notice is Active.

See Also

NoticeDB Class
OfficeClip.DBLayer.Desktop Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
NoticeDB..::.InitTransaction Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

NoticeDB Class
NoticeDB Members
OfficeClip.DBLayer.Desktop Namespace


InsertNotice Method

[image]

OfficeClip API Documentation
NoticeDB..::.InsertNotice Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Insert a new notice into the database for a particular user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertNotice(
    int userId,
    string noticeDesc,
    DateTime fromDate,
    DateTime toDate
)
Visual Basic (Declaration)
Public Function InsertNotice ( _
    userId As Integer, _
    noticeDesc As String, _
    fromDate As DateTime, _
    toDate As DateTime _
) As Integer
Visual C++
public:
int InsertNotice(
    int userId,
    String^ noticeDesc,
    DateTime fromDate,
    DateTime toDate
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
noticeDesc
Type: System..::.String
Notice Description.
fromDate
Type: System..::.DateTime
The datetime from which the notice should become Active.
toDate
Type: System..::.DateTime
The datetime up to which the notice should remain Active.

Return Value

Returns the ID of the notice created if successful else returns -1.

See Also

NoticeDB Class
OfficeClip.DBLayer.Desktop Namespace


RemoveNotice Method

[image]

OfficeClip API Documentation
NoticeDB..::.RemoveNotice Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Remove a particular notice from the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RemoveNotice(
    int messageId
)
Visual Basic (Declaration)
Public Function RemoveNotice ( _
    messageId As Integer _
) As Integer
Visual C++
public:
int RemoveNotice(
    int messageId
)

Parameters

messageId
Type: System..::.Int32
The ID of the notice to be removed.

Return Value

The ID of the notice removed if sucessful else returns -1.

See Also

NoticeDB Class
OfficeClip.DBLayer.Desktop Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
NoticeDB..::.SetSPCommand Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

NoticeDB Class
NoticeDB Members
OfficeClip.DBLayer.Desktop Namespace


UpdateNotice Method

[image]

OfficeClip API Documentation
NoticeDB..::.UpdateNotice Method
NoticeDB Class See Also

[This is preliminary documentation and is subject to change.]

Update the notice details.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateNotice(
    int messageId,
    string noticeDesc,
    DateTime fromDate,
    DateTime toDate
)
Visual Basic (Declaration)
Public Function UpdateNotice ( _
    messageId As Integer, _
    noticeDesc As String, _
    fromDate As DateTime, _
    toDate As DateTime _
) As Integer
Visual C++
public:
int UpdateNotice(
    int messageId,
    String^ noticeDesc,
    DateTime fromDate,
    DateTime toDate
)

Parameters

messageId
Type: System..::.Int32
The ID of the notice which needs to be udpated.
noticeDesc
Type: System..::.String
The notice Description.
fromDate
Type: System..::.DateTime
The datetime from which the notice becomes Active.
toDate
Type: System..::.DateTime
The datetime up to which the notice remains Active.

Return Value

The Id of the notice if successful else returns -1

See Also

NoticeDB Class
OfficeClip.DBLayer.Desktop Namespace


ResourcesDB Class

[image]

OfficeClip API Documentation
ResourcesDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Resource Reservation related functions.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class ResourcesDB : OfficeClipDB
Visual Basic (Declaration)
Public Class ResourcesDB _
    Inherits OfficeClipDB
Visual C++
public ref class ResourcesDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Desktop..::.ResourcesDB

See Also

ResourcesDB Members
OfficeClip.DBLayer.Desktop Namespace


ResourcesDB Members

[image] [image]

OfficeClip API Documentation
ResourcesDB Members
ResourcesDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ResourcesDB type exposes the following members.

Constructors

 | Name | Description
Public method | ResourcesDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteCalendarReservation | Deletes a reservation corresponding to an event in the calendar application.
Public method | DeleteResource | Marks the resource as deleted so that new future reservations can be created for this particular resource, but the existing reservations refering to this resource will not be affected.
Public method | DeleteResourceType | If unused, deletes specified resource
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllResources | Gets all the information for all the resources belonging to the currently selected group and visible to the currently logged in user.
Public method | GetCalendarResources | Gets all the resources available to a particular user.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetResourceAccessList | Gets a list of groups which have access to a particular resource belonging to the currently logged in user.
Public method | GetResourceInfo | Gets all the information related to a particular resource identified by the resourceId.
Public method | GetResourceNoAccessList | Gets a list of groups which do not have access to a particular resource belonging to the currently logged in user.
Public method | GetResourceTypes | Gets all the resources available to the currently logged in user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GrantResourceAccess | Grants access to a particular group to a resource.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertCalendarReservation | Inserts a reservation corresponding to an event in the calendar application.
Public method | InsertReservation | Inserts a new reservation into the database.
Public method | InsertResource | Inserts a resource for a particular group and its related information into the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RevokeResourceAccess | Revokes a particular group's access to a resource.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCalendarReservation | Updates all the reservation information into the database.
Public method | UpdateResource | Updates all the information related to the resource into the database.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


ResourcesDB Constructor

[image]

OfficeClip API Documentation
ResourcesDB Constructor
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ResourcesDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ResourcesDB()

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


ResourcesDB Methods

[image] [image]

OfficeClip API Documentation
ResourcesDB Methods
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

The ResourcesDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteCalendarReservation | Deletes a reservation corresponding to an event in the calendar application.
Public method | DeleteResource | Marks the resource as deleted so that new future reservations can be created for this particular resource, but the existing reservations refering to this resource will not be affected.
Public method | DeleteResourceType | If unused, deletes specified resource
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllResources | Gets all the information for all the resources belonging to the currently selected group and visible to the currently logged in user.
Public method | GetCalendarResources | Gets all the resources available to a particular user.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetResourceAccessList | Gets a list of groups which have access to a particular resource belonging to the currently logged in user.
Public method | GetResourceInfo | Gets all the information related to a particular resource identified by the resourceId.
Public method | GetResourceNoAccessList | Gets a list of groups which do not have access to a particular resource belonging to the currently logged in user.
Public method | GetResourceTypes | Gets all the resources available to the currently logged in user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GrantResourceAccess | Grants access to a particular group to a resource.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertCalendarReservation | Inserts a reservation corresponding to an event in the calendar application.
Public method | InsertReservation | Inserts a new reservation into the database.
Public method | InsertResource | Inserts a resource for a particular group and its related information into the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RevokeResourceAccess | Revokes a particular group's access to a resource.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCalendarReservation | Updates all the reservation information into the database.
Public method | UpdateResource | Updates all the information related to the resource into the database.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
ResourcesDB..::.AddOutputParameter Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

ResourcesDB Class
ResourcesDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
ResourcesDB..::.AddParameter Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

ResourcesDB Class
ResourcesDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
ResourcesDB..::.AddParameters Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

ResourcesDB Class
ResourcesDB Members
OfficeClip.DBLayer.Desktop Namespace


DeleteCalendarReservation Method

[image]

OfficeClip API Documentation
ResourcesDB..::.DeleteCalendarReservation Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a reservation corresponding to an event in the calendar application.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteCalendarReservation(
    int eventId
)
Visual Basic (Declaration)
Public Function DeleteCalendarReservation ( _
    eventId As Integer _
) As Integer
Visual C++
public:
int DeleteCalendarReservation(
    int eventId
)

Parameters

eventId
Type: System..::.Int32
Id of the event corresponding to which the reservation has to be removed.

Return Value

0 when successful, -1 in case of an error.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteResource Method

[image]

OfficeClip API Documentation
ResourcesDB..::.DeleteResource Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Marks the resource as deleted so that new future reservations can be created for this particular resource, but the existing reservations refering to this resource will not be affected.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteResource(
    int resourceId
)
Visual Basic (Declaration)
Public Function DeleteResource ( _
    resourceId As Integer _
) As Integer
Visual C++
public:
int DeleteResource(
    int resourceId
)

Parameters

resourceId
Type: System..::.Int32
Id of the resource being marked as deleted.

Return Value

0 when successful, -1 in case of an error.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteResourceType Method

[image]

OfficeClip API Documentation
ResourcesDB..::.DeleteResourceType Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

If unused, deletes specified resource

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteResourceType(
    int resourceTypeId,
    int groupId
)
Visual Basic (Declaration)
Public Function DeleteResourceType ( _
    resourceTypeId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int DeleteResourceType(
    int resourceTypeId,
    int groupId
)

Parameters

resourceTypeId
Type: System..::.Int32
Id of resource type to be deleted
groupId
Type: System..::.Int32
Group ID where the resource belongs

Return Value

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
ResourcesDB..::.ExecuteNonQuery Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

ResourcesDB Class
ResourcesDB Members
OfficeClip.DBLayer.Desktop Namespace


GetAllResources Method

[image]

OfficeClip API Documentation
ResourcesDB..::.GetAllResources Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information for all the resources belonging to the currently selected group and visible to the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAllResources(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetAllResources ( _
    userId As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAllResources(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32

Return Value

DataSet containing all the resources related information. This DataSet consists of a single DataTable with the following columns.
  • resourceId (System.Int32)Id of the resource.
  • ResourceName (System.String)Name of the resource.
  • Capacity (System.Stirng)Capacity in a meaning number of units pertaining to a particular resource for e.g. 10 people can be a Capacity of a conference room resource.
  • Features (System.String)Features of the resource.
  • Udf1Name (System.String)First user defined field name
  • Udf1Value (System.String)First user defined field value
  • Udf2Name (System.String)Second user defined field name
  • Udf2Value (System.String)Second user defined field value
  • addressId (System.Int32)Id of the Address record corresponding to the Address of the resource.
  • groupName (System.String)Name of the group to which this resource belongs.
  • ResourceType (System.String)Type of the resource. (this value is also specified by the user).
  • Line1 (System.String)First line of the Address of the resource.
  • Line2 (System.String)Second line of the Address of the resource.
  • city (System.String)City of the resource Address.
  • State (System.String)State of the resource Address.
  • zip (System.String)Zip code of the resource Address.
  • Country (System.String)Country of the resource addrres.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


GetCalendarResources Method

[image]

OfficeClip API Documentation
ResourcesDB..::.GetCalendarResources Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the resources available to a particular user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetCalendarResources(
    int userId
)
Visual Basic (Declaration)
Public Function GetCalendarResources ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetCalendarResources(
    int userId
)

Parameters

userId
Type: System..::.Int32
Id of the user.

Return Value

DataSet containing all the resource information of all the resources visible to a user. This DataSet consists of a single DataTable with the following columns.
  • resourceId (System.Int32)Id of the resource.
  • ResourceName (System.String)Name of the resource.
  • ResourceType (System.String)Type of the resource.
  • ResourceTypeId (System.Int32)Id of the type of the resource.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


GetResourceAccessList Method

[image]

OfficeClip API Documentation
ResourcesDB..::.GetResourceAccessList Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of groups which have access to a particular resource belonging to the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetResourceAccessList(
    int resourceId,
    int userId
)
Visual Basic (Declaration)
Public Function GetResourceAccessList ( _
    resourceId As Integer, _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetResourceAccessList(
    int resourceId,
    int userId
)

Parameters

resourceId
Type: System..::.Int32
Id of the resource for which all the groups having access has to be retrieved.
userId
Type: System..::.Int32
The unique id of the current user

Return Value

DataSet containing the ids and names of the groups having access to a particular resource. This DataSet consists of a single DataTable with the following columns.
  • GroupId (System.Int32)Id of the group.
  • groupName (System.String)Name of the group.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


GetResourceInfo Method

[image]

OfficeClip API Documentation
ResourcesDB..::.GetResourceInfo Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to a particular resource identified by the resourceId.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ResourceInfo GetResourceInfo(
    int resourceId
)
Visual Basic (Declaration)
Public Function GetResourceInfo ( _
    resourceId As Integer _
) As ResourceInfo
Visual C++
public:
ResourceInfo^ GetResourceInfo(
    int resourceId
)

Parameters

resourceId
Type: System..::.Int32
Id of the resource for which all the information has to be retrieved.

Return Value

Instance of the ResourceInfo object containing all the information related to a particular resource.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


GetResourceNoAccessList Method

[image]

OfficeClip API Documentation
ResourcesDB..::.GetResourceNoAccessList Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of groups which do not have access to a particular resource belonging to the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetResourceNoAccessList(
    int resourceId,
    int userId
)
Visual Basic (Declaration)
Public Function GetResourceNoAccessList ( _
    resourceId As Integer, _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetResourceNoAccessList(
    int resourceId,
    int userId
)

Parameters

resourceId
Type: System..::.Int32
Id of the resource for which all the groups not having access has to be retrieved.
userId
Type: System..::.Int32
The unique id of the current user

Return Value

DataSet containing the ids and names of the groups not having access to a particular resource. This DataSet consists of a single DataTable with the following columns.
  • GroupId (System.Int32)Id of the group.
  • groupName (System.String)Name of the group.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


GetResourceTypes Method

[image]

OfficeClip API Documentation
ResourcesDB..::.GetResourceTypes Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the resources available to the currently logged in user.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetResourceTypes(
    int groupId,
    int userId
)
Visual Basic (Declaration)
Public Function GetResourceTypes ( _
    groupId As Integer, _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetResourceTypes(
    int groupId,
    int userId
)

Parameters

groupId
Type: System..::.Int32
userId
Type: System..::.Int32

Return Value

DataSet containing all the resource information of all the resources visible to a user. This DataSet consists of a single DataTable with the following columns.
  • resourceId (System.Int32)Id of the resource.
  • ResourceName (System.String)Name of the resource.
  • ResourceType (System.String)Type of the resource.
  • ResourceTypeId (System.Int32)Id of the type of the resource.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


GrantResourceAccess Method

[image]

OfficeClip API Documentation
ResourcesDB..::.GrantResourceAccess Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Grants access to a particular group to a resource.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GrantResourceAccess(
    int groupId,
    int resourceId
)
Visual Basic (Declaration)
Public Function GrantResourceAccess ( _
    groupId As Integer, _
    resourceId As Integer _
) As Integer
Visual C++
public:
int GrantResourceAccess(
    int groupId,
    int resourceId
)

Parameters

groupId
Type: System..::.Int32
Id of the group for which access to the resource is being granted.
resourceId
Type: System..::.Int32
Id of the resource to which the access is being granted.

Return Value

0 when successful, -1 in case of an error.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
ResourcesDB..::.InitTransaction Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

ResourcesDB Class
ResourcesDB Members
OfficeClip.DBLayer.Desktop Namespace


InsertCalendarReservation Method

[image]

OfficeClip API Documentation
ResourcesDB..::.InsertCalendarReservation Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a reservation corresponding to an event in the calendar application.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertCalendarReservation(
    int eventId,
    int resourceId,
    DateTime startDatetime,
    DateTime endDatetime,
    string purpose,
    string isPrivate,
    int repeatingSequenceId,
    int EventUserId,
    int currentUserId
)
Visual Basic (Declaration)
Public Function InsertCalendarReservation ( _
    eventId As Integer, _
    resourceId As Integer, _
    startDatetime As DateTime, _
    endDatetime As DateTime, _
    purpose As String, _
    isPrivate As String, _
    repeatingSequenceId As Integer, _
    EventUserId As Integer, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int InsertCalendarReservation(
    int eventId,
    int resourceId,
    DateTime startDatetime,
    DateTime endDatetime,
    String^ purpose,
    String^ isPrivate,
    int repeatingSequenceId,
    int EventUserId,
    int currentUserId
)

Parameters

eventId
Type: System..::.Int32
Id of the event corresponding to which this reservation is updated.
resourceId
Type: System..::.Int32
Id of the resource being reserved for the reservation.
startDatetime
Type: System..::.DateTime
Starting Date and Time of the event. (This value should be sent converted into the Server's timezone)
endDatetime
Type: System..::.DateTime
Ending Date and Time of the event. (This value should be sent converted into the Server's timezone)
purpose
Type: System..::.String
Purpose of the reservation.
isPrivate
Type: System..::.String
Flag (Y/N) indicating whether the reservation created is private or for a group.
repeatingSequenceId
Type: System..::.Int32
Unique id to be assigned to a set of repeating reservations.
EventUserId
Type: System..::.Int32
The uer id of the owner of the event
currentUserId
Type: System..::.Int32
the user id for the current user

Return Value

Id of the newly created reservation when successful, -1 in case of error.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertReservation Method

[image]

OfficeClip API Documentation
ResourcesDB..::.InsertReservation Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new reservation into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertReservation(
    int resourceId,
    DateTime startDateTime,
    DateTime endDateTime,
    string purpose,
    string isPrivate,
    int repeatingSequenceId,
    int UserId
)
Visual Basic (Declaration)
Public Function InsertReservation ( _
    resourceId As Integer, _
    startDateTime As DateTime, _
    endDateTime As DateTime, _
    purpose As String, _
    isPrivate As String, _
    repeatingSequenceId As Integer, _
    UserId As Integer _
) As Integer
Visual C++
public:
int InsertReservation(
    int resourceId,
    DateTime startDateTime,
    DateTime endDateTime,
    String^ purpose,
    String^ isPrivate,
    int repeatingSequenceId,
    int UserId
)

Parameters

resourceId
Type: System..::.Int32
Id of the resource being reserved for the reservation.
startDateTime
Type: System..::.DateTime
Starting Date and Time of the reservation. (This value should be sent converted into the Server's timezone)
endDateTime
Type: System..::.DateTime
Ending Date and Time of the reservation. (This value should be sent converted into the Server's timezone)
purpose
Type: System..::.String
Purpose of the reservation.
isPrivate
Type: System..::.String
Flag (Y/N) indicating whether the reservation created is private or for a group.
repeatingSequenceId
Type: System..::.Int32
Unique id to be assigned to a set of repeating reservations.
UserId
Type: System..::.Int32
Id of the user creating the reservation.

Return Value

Id of the newly created reservation when successful, -1 in case of error.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertResource Method

[image]

OfficeClip API Documentation
ResourcesDB..::.InsertResource Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a resource for a particular group and its related information into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertResource(
    int groupId,
    ResourceInfo ri
)
Visual Basic (Declaration)
Public Function InsertResource ( _
    groupId As Integer, _
    ri As ResourceInfo _
) As Integer
Visual C++
public:
int InsertResource(
    int groupId,
    ResourceInfo^ ri
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.
ri
Type: OfficeClip.BusinessLayer.Desktop..::.ResourceInfo
Instance of the ResourceInfo object containing all information related to the resource.

Return Value

Id of the newly created resource when successful, -1 in case of an error.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


RevokeResourceAccess Method

[image]

OfficeClip API Documentation
ResourcesDB..::.RevokeResourceAccess Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Revokes a particular group's access to a resource.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RevokeResourceAccess(
    int groupId,
    int resourceId
)
Visual Basic (Declaration)
Public Function RevokeResourceAccess ( _
    groupId As Integer, _
    resourceId As Integer _
) As Integer
Visual C++
public:
int RevokeResourceAccess(
    int groupId,
    int resourceId
)

Parameters

groupId
Type: System..::.Int32
Id of the group whose access to the resource is being revoked.
resourceId
Type: System..::.Int32
Id of the resource from which the access is being revoked.

Return Value

0 when successful, -1 in case of an error.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
ResourcesDB..::.SetSPCommand Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

ResourcesDB Class
ResourcesDB Members
OfficeClip.DBLayer.Desktop Namespace


UpdateCalendarReservation Method

[image]

OfficeClip API Documentation
ResourcesDB..::.UpdateCalendarReservation Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the reservation information into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateCalendarReservation(
    int eventId,
    int resourceId,
    DateTime startDatetime,
    DateTime endDatetime,
    string purpose,
    string isPrivate
)
Visual Basic (Declaration)
Public Function UpdateCalendarReservation ( _
    eventId As Integer, _
    resourceId As Integer, _
    startDatetime As DateTime, _
    endDatetime As DateTime, _
    purpose As String, _
    isPrivate As String _
) As Integer
Visual C++
public:
int UpdateCalendarReservation(
    int eventId,
    int resourceId,
    DateTime startDatetime,
    DateTime endDatetime,
    String^ purpose,
    String^ isPrivate
)

Parameters

eventId
Type: System..::.Int32
Id of the event corresponding to which this reservation is updated.
resourceId
Type: System..::.Int32
Id of the resource being reserved for the reservation.
startDatetime
Type: System..::.DateTime
Starting Date and Time of the event. (This value should be sent converted into the Server's timezone)
endDatetime
Type: System..::.DateTime
Ending Date and Time of the event. (This value should be sent converted into the Server's timezone)
purpose
Type: System..::.String
Purpose of the reservation.
isPrivate
Type: System..::.String
Flag (Y/N) indicating whether the reservation created is private or for a group.

Return Value

0 when successful, -1 in case of error.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


UpdateResource Method

[image]

OfficeClip API Documentation
ResourcesDB..::.UpdateResource Method
ResourcesDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the information related to the resource into the database.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateResource(
    ResourceInfo ri
)
Visual Basic (Declaration)
Public Function UpdateResource ( _
    ri As ResourceInfo _
) As Integer
Visual C++
public:
int UpdateResource(
    ResourceInfo^ ri
)

Parameters

ri
Type: OfficeClip.BusinessLayer.Desktop..::.ResourceInfo
Instance of the ResourceInfo object containing all information related to the resource.

Return Value

0 when successful, -1 in case of an error.

See Also

ResourcesDB Class
OfficeClip.DBLayer.Desktop Namespace


TaskDB Class

[image]

OfficeClip API Documentation
TaskDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Tasks application related functions.

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TaskDB : OfficeClipDB
Visual Basic (Declaration)
Public Class TaskDB _
    Inherits OfficeClipDB
Visual C++
public ref class TaskDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Desktop..::.TaskDB

See Also

TaskDB Members
OfficeClip.DBLayer.Desktop Namespace


TaskDB Members

[image] [image]

OfficeClip API Documentation
TaskDB Members
TaskDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TaskDB type exposes the following members.

Constructors

 | Name | Description
Public method | TaskDB | Default Constructor

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ChangeTaskStatus | Change the status of the task
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteTask | Overloaded.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTask | Gets a particular task from the database
Public method | GetTasks | Gets all the tasks based on the given criteria
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertSingleTask | Inserts a single task. This inserertion does not take care of the recurrence
Public method | InsertTask | Inserts a task in the database
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateTask | Updates a task in the database

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

TaskDB Class
OfficeClip.DBLayer.Desktop Namespace


TaskDB Constructor

[image]

OfficeClip API Documentation
TaskDB Constructor
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Default Constructor

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TaskDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TaskDB()

See Also

TaskDB Class
OfficeClip.DBLayer.Desktop Namespace


TaskDB Methods

[image] [image]

OfficeClip API Documentation
TaskDB Methods
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

The TaskDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ChangeTaskStatus | Change the status of the task
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteTask | Overloaded.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTask | Gets a particular task from the database
Public method | GetTasks | Gets all the tasks based on the given criteria
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertSingleTask | Inserts a single task. This inserertion does not take care of the recurrence
Public method | InsertTask | Inserts a task in the database
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateTask | Updates a task in the database

See Also

TaskDB Class
OfficeClip.DBLayer.Desktop Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
TaskDB..::.AddOutputParameter Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

TaskDB Class
TaskDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
TaskDB..::.AddParameter Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

TaskDB Class
TaskDB Members
OfficeClip.DBLayer.Desktop Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
TaskDB..::.AddParameters Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

TaskDB Class
TaskDB Members
OfficeClip.DBLayer.Desktop Namespace


ChangeTaskStatus Method

[image]

OfficeClip API Documentation
TaskDB..::.ChangeTaskStatus Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Change the status of the task

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue ChangeTaskStatus(
    BusinessConstants..::.TaskStatus ts,
    ArrayList taskIds,
    int userId
)
Visual Basic (Declaration)
Public Function ChangeTaskStatus ( _
    ts As BusinessConstants..::.TaskStatus, _
    taskIds As ArrayList, _
    userId As Integer _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue ChangeTaskStatus(
    BusinessConstants..::.TaskStatus ts,
    ArrayList^ taskIds,
    int userId
)

Parameters

ts
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TaskStatus
The task status
taskIds
Type: System.Collections..::.ArrayList
The array of TaskId to be marked as complete
userId
Type: System..::.Int32
the unique id of the user

Return Value

Negative value if failed 0 if successful

See Also

TaskDB Class
OfficeClip.DBLayer.Desktop Namespace


DeleteTask Method

[image] [image]

OfficeClip API Documentation
TaskDB..::.DeleteTask Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | DeleteTask(ArrayList, DBConstants..::.ProcessWhichEvent, Boolean, Int32, Int32, Boolean) | Deletes multiple tasks
Public method | DeleteTask(Int32, DBConstants..::.ProcessWhichEvent, Boolean, Int32, Int32, Boolean) | Deletes a task

See Also

TaskDB Class
TaskDB Members
OfficeClip.DBLayer.Desktop Namespace


DeleteTask Method (ArrayList, DBConstants.ProcessWhichEvent, Boolean, Int32, Int32, Boolean)

[image]

OfficeClip API Documentation
TaskDB..::.DeleteTask Method (ArrayList, DBConstants..::.ProcessWhichEvent, Boolean, Int32, Int32, Boolean)
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes multiple tasks

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue DeleteTask(
    ArrayList taskIds,
    DBConstants..::.ProcessWhichEvent whichEvent,
    bool isRestricted,
    int userId,
    int groupId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function DeleteTask ( _
    taskIds As ArrayList, _
    whichEvent As DBConstants..::.ProcessWhichEvent, _
    isRestricted As Boolean, _
    userId As Integer, _
    groupId As Integer, _
    isAdmin As Boolean _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue DeleteTask(
    ArrayList^ taskIds,
    DBConstants..::.ProcessWhichEvent whichEvent,
    bool isRestricted,
    int userId,
    int groupId,
    bool isAdmin
)

Parameters

taskIds
Type: System.Collections..::.ArrayList
An array of taskId to be deleted
whichEvent
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Determines whether the event is for this group, all groups or personal event
isRestricted
Type: System..::.Boolean
if true then delete will verify the group and user id to protect deletion of task from the non-current group or personal task of other users
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the organization
isAdmin
Type: System..::.Boolean
is the user and administration

Return Value

Negative value if failed 0 if successful

See Also

TaskDB Class
DeleteTask Overload
OfficeClip.DBLayer.Desktop Namespace


DeleteTask Method (Int32, DBConstants.ProcessWhichEvent, Boolean, Int32, Int32, Boolean)

[image]

OfficeClip API Documentation
TaskDB..::.DeleteTask Method (Int32, DBConstants..::.ProcessWhichEvent, Boolean, Int32, Int32, Boolean)
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a task

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue DeleteTask(
    int taskId,
    DBConstants..::.ProcessWhichEvent whichEvent,
    bool isRestricted,
    int userId,
    int groupId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function DeleteTask ( _
    taskId As Integer, _
    whichEvent As DBConstants..::.ProcessWhichEvent, _
    isRestricted As Boolean, _
    userId As Integer, _
    groupId As Integer, _
    isAdmin As Boolean _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue DeleteTask(
    int taskId,
    DBConstants..::.ProcessWhichEvent whichEvent,
    bool isRestricted,
    int userId,
    int groupId,
    bool isAdmin
)

Parameters

taskId
Type: System..::.Int32
The unique id of the task
whichEvent
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Determines whether the event is for this group, all groups or personal event
isRestricted
Type: System..::.Boolean
if true then delete will verify the group and user id to protect deletion oftask from the non-current group or personal task of other users
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the organization
isAdmin
Type: System..::.Boolean
is the user and administration

Return Value

Negative value if failed 0 if successful

See Also

TaskDB Class
DeleteTask Overload
OfficeClip.DBLayer.Desktop Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
TaskDB..::.ExecuteNonQuery Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

TaskDB Class
TaskDB Members
OfficeClip.DBLayer.Desktop Namespace


GetTask Method

[image]

OfficeClip API Documentation
TaskDB..::.GetTask Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a particular task from the database

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TaskInfo GetTask(
    int taskId,
    int userId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function GetTask ( _
    taskId As Integer, _
    userId As Integer, _
    isAdmin As Boolean _
) As TaskInfo
Visual C++
public:
TaskInfo^ GetTask(
    int taskId,
    int userId,
    bool isAdmin
)

Parameters

taskId
Type: System..::.Int32
The unique id of the task in the database
userId
Type: System..::.Int32
The unique id of the user
isAdmin
Type: System..::.Boolean
Is the user an administrator

Return Value

The task information structure, null if the task is not found

See Also

TaskDB Class
OfficeClip.DBLayer.Desktop Namespace


GetTasks Method

[image]

OfficeClip API Documentation
TaskDB..::.GetTasks Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the tasks based on the given criteria

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TaskInfo[] GetTasks(
    BusinessConstants..::.TaskFilter tf,
    GroupSelection gsel,
    BusinessConstants..::.ObjectType oType,
    int objectId,
    bool showMyTask,
    bool showMyAssigned,
    bool showNoRead,
    bool showPrivateForGroups,
    int limitRows,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function GetTasks ( _
    tf As BusinessConstants..::.TaskFilter, _
    gsel As GroupSelection, _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer, _
    showMyTask As Boolean, _
    showMyAssigned As Boolean, _
    showNoRead As Boolean, _
    showPrivateForGroups As Boolean, _
    limitRows As Integer, _
    session As ConfigureInfo _
) As TaskInfo()
Visual C++
public:
array<TaskInfo^>^ GetTasks(
    BusinessConstants..::.TaskFilter tf,
    GroupSelection gsel,
    BusinessConstants..::.ObjectType oType,
    int objectId,
    bool showMyTask,
    bool showMyAssigned,
    bool showNoRead,
    bool showPrivateForGroups,
    int limitRows,
    ConfigureInfo^ session
)

Parameters

tf
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.TaskFilter
The task filter selected by the user
gsel
Type: OfficeClip.Utils..::.GroupSelection
The group section criteria, determines whether all groups, this group or only private tasks are to be shown. Note that the private tasks are always shown (also see the showPrivateFor Groups parameter below on how to limit this)
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The type of the parent object for which the task is required to be shown. A value of None will imply ignoring any parent.
objectId
Type: System..::.Int32
The id of the parent object for which the tasks are required to be shown, a value of -1 indicates ignore all parents.
showMyTask
Type: System..::.Boolean
if true shows only the task that the current logged in user is the owner.
showMyAssigned
Type: System..::.Boolean
Filter for showing the tasks assigned to me
showNoRead
Type: System..::.Boolean
Do not return the tasks that has no read privilege
showPrivateForGroups
Type: System..::.Boolean
if true shows the private tasks when the group tasks are requested
limitRows
Type: System..::.Int32
Limits the number of rows from the database. This is helpful when the tasks are shown in the portlet and speed is the consideration.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

null if failed, objects if successful

See Also

TaskDB Class
OfficeClip.DBLayer.Desktop Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
TaskDB..::.InitTransaction Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

TaskDB Class
TaskDB Members
OfficeClip.DBLayer.Desktop Namespace


InsertSingleTask Method

[image]

OfficeClip API Documentation
TaskDB..::.InsertSingleTask Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a single task. This inserertion does not take care of the recurrence

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertSingleTask(
    TaskInfo ti,
    ConfigureInfo session,
    ref DateTime modifiedTime
)
Visual Basic (Declaration)
Public Function InsertSingleTask ( _
    ti As TaskInfo, _
    session As ConfigureInfo, _
    ByRef modifiedTime As DateTime _
) As Integer
Visual C++
public:
int InsertSingleTask(
    TaskInfo^ ti,
    ConfigureInfo^ session,
    DateTime% modifiedTime
)

Parameters

ti
Type: OfficeClip.BusinessLayer.Desktop..::.TaskInfo
The taskinfo object
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session
modifiedTime
Type: System..::.DateTime%
The last modified time

Return Value

The task id of the task, null if there is an error and the task could not be saved

See Also

TaskDB Class
OfficeClip.DBLayer.Desktop Namespace


InsertTask Method

[image]

OfficeClip API Documentation
TaskDB..::.InsertTask Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a task in the database

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertTask(
    TaskInfo ti,
    string docIdList,
    ConfigureInfo session,
    ref DateTime modifiedTime
)
Visual Basic (Declaration)
Public Function InsertTask ( _
    ti As TaskInfo, _
    docIdList As String, _
    session As ConfigureInfo, _
    ByRef modifiedTime As DateTime _
) As Integer
Visual C++
public:
int InsertTask(
    TaskInfo^ ti,
    String^ docIdList,
    ConfigureInfo^ session,
    DateTime% modifiedTime
)

Parameters

ti
Type: OfficeClip.BusinessLayer.Desktop..::.TaskInfo
The taskinfo object to be inserted
docIdList
Type: System..::.String
The list of the document ids
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session
modifiedTime
Type: System..::.DateTime%
The last modified time

Return Value

-1 if failed, the taskId if successful

See Also

TaskDB Class
OfficeClip.DBLayer.Desktop Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
TaskDB..::.SetSPCommand Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

TaskDB Class
TaskDB Members
OfficeClip.DBLayer.Desktop Namespace


UpdateTask Method

[image]

OfficeClip API Documentation
TaskDB..::.UpdateTask Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates a task in the database

Namespace: OfficeClip.DBLayer.Desktop
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue UpdateTask(
    TaskInfo ti,
    bool isRestricted,
    string docIdList,
    string remDocIdList,
    ConfigureInfo session,
    ref DateTime lastUpdatedTime
)
Visual Basic (Declaration)
Public Function UpdateTask ( _
    ti As TaskInfo, _
    isRestricted As Boolean, _
    docIdList As String, _
    remDocIdList As String, _
    session As ConfigureInfo, _
    ByRef lastUpdatedTime As DateTime _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue UpdateTask(
    TaskInfo^ ti,
    bool isRestricted,
    String^ docIdList,
    String^ remDocIdList,
    ConfigureInfo^ session,
    DateTime% lastUpdatedTime
)

Parameters

ti
Type: OfficeClip.BusinessLayer.Desktop..::.TaskInfo
The taskinfo structure
isRestricted
Type: System..::.Boolean
if the task is restricted
docIdList
Type: System..::.String
The list of document ids
remDocIdList
Type: System..::.String
The list of document ids to be removed
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session
lastUpdatedTime
Type: System..::.DateTime%
The time of last modification

Return Value

Negative value if failed 0 if successful

See Also

TaskDB Class
OfficeClip.DBLayer.Desktop Namespace


OfficeClip.DBLayer.Extranet Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Extranet Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip extranet

Classes

 | Class | Description
Public class | ExtranetDB | The db layer for the extranet


ExtranetDB Class

[image]

OfficeClip API Documentation
ExtranetDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

The db layer for the extranet

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class ExtranetDB : OfficeClipDB
Visual Basic (Declaration)
Public Class ExtranetDB _
    Inherits OfficeClipDB
Visual C++
public ref class ExtranetDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Extranet..::.ExtranetDB

See Also

ExtranetDB Members
OfficeClip.DBLayer.Extranet Namespace


ExtranetDB Members

[image] [image]

OfficeClip API Documentation
ExtranetDB Members
ExtranetDB Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The ExtranetDB type exposes the following members.

Constructors

 | Name | Description
Public method | ExtranetDB | default constructor

Methods

 | Name | Description
Protected method | AddApplicationLinks | Adds the application links
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteAllExtranetUser | Deletes all Extranet users for a particular group and reassigns all their data to the group administrator
Public method | DeleteExtranetItem | Deletes extranet item having specified item ID
Public method | DeleteExtranetItemsAll | Deletes all extranet items in the DB
Public method | DeleteExtranetUser | Deletes Extranet user for specified group and user ID
Public method | DelExtranetPermissionsAll | Deletes all users authorized for specified item ID
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAdminControlName |
Public method | GetAllExtranetUserPermissions | Gets all assigned permissions for a given user
Public method | GetApplicationLinks | Gets list of public and secure application links for displaying on the Extranet Home Page.
Public method | GetAppsAndFeatureParentChildNodes | Get the parent and child nodes for applications and features
Public method | GetAppsAndFeaturesParentChildArray | Builds Array List to be used by parent/child control for displaying Applications and their associated feature items
Public method | GetExtranetCaseDetails | Returns case details for specified feature item, and group and case ID
Public method | GetExtranetCaseNotes | Get list of notes for specified group, user, and case ID
Public method | GetExtranetFeature | Returns business layer object for specified feature ID
Public method | GetExtranetItem | Get the Item Info for the specified item and Group ID
Public method | GetExtranetItemPermissions | Overloaded.
Public method | GetExtranetItemsList | Gets list of ItemInfo to be used by AdminStart to display current list of items.
Public method | GetExtranetOrg | Gets the Extranet Admin organization setup details and sets default values for initial setup
Public method | GetExtranetUserPermissions |
Public method | GetExtranetUserSelectedPermissions | Gets the permissions for the users and checks the corresponsing checkboxes on the user permissions page
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertExtranetItem | Inserts new feature item into database
Public method | InsertExtranetUser | Inserts new Extranet user into the database
Public method | InsExtranetPermissions | Inserts array of users into DB that are authorized for specified ID
Public method | LoadExtranetOrgDefault | Loads the extranet default parameters of the organization
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdActivateAllExtranetUsers | Sets active state of all extranet users
Public method | UpdActivateExtranetUser | Sets active state of specified user
Public method | UpdateExtranetCaseStatus | Updates specified case with provided status
Public method | UpdateExtranetItem | Updates Extranet Item in the database
Public method | UpdateExtranetOrg | Updates the database with the Extranet Admin Organization setup details
Public method | UpdateExtranetUserPermissions | Gets all the permission items on the permissions page that are checked and updates the database with the corresponding permission records for each item
Public method | ValidateUserLogin | Integer flag indicating whether the user could be successfully authenticated. Following is the list of possible values returned and their meanings.

Fields

 | Name | Description
Protected field | _error | Error string

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


ExtranetDB Constructor

[image]

OfficeClip API Documentation
ExtranetDB Constructor
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

default constructor

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExtranetDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExtranetDB()

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


ExtranetDB Fields

[image] [image]

OfficeClip API Documentation
ExtranetDB Fields
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

The ExtranetDB type exposes the following fields.

Fields

 | Name | Description
Protected field | _error | Error string

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


_error Field

[image]

OfficeClip API Documentation
ExtranetDB..::._error Field
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Error string

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string _error
Visual Basic (Declaration)
Protected _error As String
Visual C++
protected:
String^ _error

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


ExtranetDB Methods

[image] [image]

OfficeClip API Documentation
ExtranetDB Methods
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

The ExtranetDB type exposes the following methods.

Methods

 | Name | Description
Protected method | AddApplicationLinks | Adds the application links
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteAllExtranetUser | Deletes all Extranet users for a particular group and reassigns all their data to the group administrator
Public method | DeleteExtranetItem | Deletes extranet item having specified item ID
Public method | DeleteExtranetItemsAll | Deletes all extranet items in the DB
Public method | DeleteExtranetUser | Deletes Extranet user for specified group and user ID
Public method | DelExtranetPermissionsAll | Deletes all users authorized for specified item ID
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAdminControlName |
Public method | GetAllExtranetUserPermissions | Gets all assigned permissions for a given user
Public method | GetApplicationLinks | Gets list of public and secure application links for displaying on the Extranet Home Page.
Public method | GetAppsAndFeatureParentChildNodes | Get the parent and child nodes for applications and features
Public method | GetAppsAndFeaturesParentChildArray | Builds Array List to be used by parent/child control for displaying Applications and their associated feature items
Public method | GetExtranetCaseDetails | Returns case details for specified feature item, and group and case ID
Public method | GetExtranetCaseNotes | Get list of notes for specified group, user, and case ID
Public method | GetExtranetFeature | Returns business layer object for specified feature ID
Public method | GetExtranetItem | Get the Item Info for the specified item and Group ID
Public method | GetExtranetItemPermissions | Overloaded.
Public method | GetExtranetItemsList | Gets list of ItemInfo to be used by AdminStart to display current list of items.
Public method | GetExtranetOrg | Gets the Extranet Admin organization setup details and sets default values for initial setup
Public method | GetExtranetUserPermissions |
Public method | GetExtranetUserSelectedPermissions | Gets the permissions for the users and checks the corresponsing checkboxes on the user permissions page
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertExtranetItem | Inserts new feature item into database
Public method | InsertExtranetUser | Inserts new Extranet user into the database
Public method | InsExtranetPermissions | Inserts array of users into DB that are authorized for specified ID
Public method | LoadExtranetOrgDefault | Loads the extranet default parameters of the organization
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdActivateAllExtranetUsers | Sets active state of all extranet users
Public method | UpdActivateExtranetUser | Sets active state of specified user
Public method | UpdateExtranetCaseStatus | Updates specified case with provided status
Public method | UpdateExtranetItem | Updates Extranet Item in the database
Public method | UpdateExtranetOrg | Updates the database with the Extranet Admin Organization setup details
Public method | UpdateExtranetUserPermissions | Gets all the permission items on the permissions page that are checked and updates the database with the corresponding permission records for each item
Public method | ValidateUserLogin | Integer flag indicating whether the user could be successfully authenticated. Following is the list of possible values returned and their meanings.

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


AddApplicationLinks Method

[image]

OfficeClip API Documentation
ExtranetDB..::.AddApplicationLinks Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds the application links

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AddApplicationLinks(
    ApplicationLinksCollection appLnkColl,
    ItemInfo eii
)
Visual Basic (Declaration)
Protected Sub AddApplicationLinks ( _
    appLnkColl As ApplicationLinksCollection, _
    eii As ItemInfo _
)
Visual C++
protected:
void AddApplicationLinks(
    ApplicationLinksCollection^ appLnkColl,
    ItemInfo^ eii
)

Parameters

appLnkColl
Type: OfficeClip.BusinessLayer.Extranet.User..::.ApplicationLinksCollection
eii
Type: OfficeClip.BusinessLayer.Extranet..::.ItemInfo

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
ExtranetDB..::.AddOutputParameter Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

ExtranetDB Class
ExtranetDB Members
OfficeClip.DBLayer.Extranet Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
ExtranetDB..::.AddParameter Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

ExtranetDB Class
ExtranetDB Members
OfficeClip.DBLayer.Extranet Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
ExtranetDB..::.AddParameters Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

ExtranetDB Class
ExtranetDB Members
OfficeClip.DBLayer.Extranet Namespace


DeleteAllExtranetUser Method

[image]

OfficeClip API Documentation
ExtranetDB..::.DeleteAllExtranetUser Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all Extranet users for a particular group and reassigns all their data to the group administrator

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteAllExtranetUser(
    int groupId
)
Visual Basic (Declaration)
Public Sub DeleteAllExtranetUser ( _
    groupId As Integer _
)
Visual C++
public:
void DeleteAllExtranetUser(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


DeleteExtranetItem Method

[image]

OfficeClip API Documentation
ExtranetDB..::.DeleteExtranetItem Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes extranet item having specified item ID

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteExtranetItem(
    int itemId
)
Visual Basic (Declaration)
Public Sub DeleteExtranetItem ( _
    itemId As Integer _
)
Visual C++
public:
void DeleteExtranetItem(
    int itemId
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


DeleteExtranetItemsAll Method

[image]

OfficeClip API Documentation
ExtranetDB..::.DeleteExtranetItemsAll Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all extranet items in the DB

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteExtranetItemsAll(
    int groupId
)
Visual Basic (Declaration)
Public Sub DeleteExtranetItemsAll ( _
    groupId As Integer _
)
Visual C++
public:
void DeleteExtranetItemsAll(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


DeleteExtranetUser Method

[image]

OfficeClip API Documentation
ExtranetDB..::.DeleteExtranetUser Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes Extranet user for specified group and user ID

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteExtranetUser(
    int groupId,
    int userId
)
Visual Basic (Declaration)
Public Sub DeleteExtranetUser ( _
    groupId As Integer, _
    userId As Integer _
)
Visual C++
public:
void DeleteExtranetUser(
    int groupId,
    int userId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


DelExtranetPermissionsAll Method

[image]

OfficeClip API Documentation
ExtranetDB..::.DelExtranetPermissionsAll Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all users authorized for specified item ID

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DelExtranetPermissionsAll(
    int itemId
)
Visual Basic (Declaration)
Public Sub DelExtranetPermissionsAll ( _
    itemId As Integer _
)
Visual C++
public:
void DelExtranetPermissionsAll(
    int itemId
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
ExtranetDB..::.ExecuteNonQuery Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

ExtranetDB Class
ExtranetDB Members
OfficeClip.DBLayer.Extranet Namespace


GetAdminControlName Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetAdminControlName Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool GetAdminControlName(
    int featureId,
    out string name
)
Visual Basic (Declaration)
Public Function GetAdminControlName ( _
    featureId As Integer, _
    <OutAttribute> ByRef name As String _
) As Boolean
Visual C++
public:
bool GetAdminControlName(
    int featureId,
    [OutAttribute] String^% name
)

Parameters

featureId
Type: System..::.Int32
name
Type: System..::.String%

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetAllExtranetUserPermissions Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetAllExtranetUserPermissions Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all assigned permissions for a given user

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAllExtranetUserPermissions(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetAllExtranetUserPermissions ( _
    userId As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAllExtranetUserPermissions(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the organization

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetApplicationLinks Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetApplicationLinks Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets list of public and secure application links for displaying on the Extranet Home Page.

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetApplicationLinks(
    int groupId,
    int userId,
    out ApplicationLinksCollection publicLinks,
    out ApplicationLinksCollection securedLinks
)
Visual Basic (Declaration)
Public Sub GetApplicationLinks ( _
    groupId As Integer, _
    userId As Integer, _
    <OutAttribute> ByRef publicLinks As ApplicationLinksCollection, _
    <OutAttribute> ByRef securedLinks As ApplicationLinksCollection _
)
Visual C++
public:
void GetApplicationLinks(
    int groupId,
    int userId,
    [OutAttribute] ApplicationLinksCollection^% publicLinks,
    [OutAttribute] ApplicationLinksCollection^% securedLinks
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user
publicLinks
Type: OfficeClip.BusinessLayer.Extranet.User..::.ApplicationLinksCollection %
The collection of public links
securedLinks
Type: OfficeClip.BusinessLayer.Extranet.User..::.ApplicationLinksCollection %
The collection of secured links

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetAppsAndFeatureParentChildNodes Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetAppsAndFeatureParentChildNodes Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the parent and child nodes for applications and features

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<PcNode> GetAppsAndFeatureParentChildNodes()
Visual Basic (Declaration)
Public Function GetAppsAndFeatureParentChildNodes As List(Of PcNode)
Visual C++
public:
List<PcNode^>^ GetAppsAndFeatureParentChildNodes()

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetAppsAndFeaturesParentChildArray Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetAppsAndFeaturesParentChildArray Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Builds Array List to be used by parent/child control for displaying Applications and their associated feature items

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetAppsAndFeaturesParentChildArray()
Visual Basic (Declaration)
Public Function GetAppsAndFeaturesParentChildArray As ArrayList
Visual C++
public:
ArrayList^ GetAppsAndFeaturesParentChildArray()

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetExtranetCaseDetails Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetExtranetCaseDetails Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns case details for specified feature item, and group and case ID

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public CaseDetails GetExtranetCaseDetails(
    FeatureItem featureItem,
    int groupId,
    int caseId
)
Visual Basic (Declaration)
Public Function GetExtranetCaseDetails ( _
    featureItem As FeatureItem, _
    groupId As Integer, _
    caseId As Integer _
) As CaseDetails
Visual C++
public:
CaseDetails^ GetExtranetCaseDetails(
    FeatureItem^ featureItem,
    int groupId,
    int caseId
)

Parameters

featureItem
Type: OfficeClip.BusinessLayer.Extranet.Xml..::.FeatureItem
groupId
Type: System..::.Int32
caseId
Type: System..::.Int32

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetExtranetCaseNotes Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetExtranetCaseNotes Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Get list of notes for specified group, user, and case ID

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public NoteDetailsCollection GetExtranetCaseNotes(
    int groupId,
    int userId,
    int caseId
)
Visual Basic (Declaration)
Public Function GetExtranetCaseNotes ( _
    groupId As Integer, _
    userId As Integer, _
    caseId As Integer _
) As NoteDetailsCollection
Visual C++
public:
NoteDetailsCollection^ GetExtranetCaseNotes(
    int groupId,
    int userId,
    int caseId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user
caseId
Type: System..::.Int32

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetExtranetFeature Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetExtranetFeature Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns business layer object for specified feature ID

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public FeatureInfo GetExtranetFeature(
    int featureId
)
Visual Basic (Declaration)
Public Function GetExtranetFeature ( _
    featureId As Integer _
) As FeatureInfo
Visual C++
public:
FeatureInfo^ GetExtranetFeature(
    int featureId
)

Parameters

featureId
Type: System..::.Int32

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetExtranetItem Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetExtranetItem Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the Item Info for the specified item and Group ID

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ItemInfo GetExtranetItem(
    int itemId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetExtranetItem ( _
    itemId As Integer, _
    groupId As Integer _
) As ItemInfo
Visual C++
public:
ItemInfo^ GetExtranetItem(
    int itemId,
    int groupId
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
groupId
Type: System..::.Int32
The unique id of the group

Return Value

Teh extranet item object

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetExtranetItemPermissions Method

[image] [image]

OfficeClip API Documentation
ExtranetDB..::.GetExtranetItemPermissions Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetExtranetItemPermissions(Int32) | Returns collection of secure users authorized for provided item ID
Public method | GetExtranetItemPermissions(Int32, ItemPermission) | Gets Item Permissions for specified item ID

See Also

ExtranetDB Class
ExtranetDB Members
OfficeClip.DBLayer.Extranet Namespace


GetExtranetItemPermissions Method (Int32)

[image]

OfficeClip API Documentation
ExtranetDB..::.GetExtranetItemPermissions Method (Int32)
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns collection of secure users authorized for provided item ID

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PermissionItemCollection GetExtranetItemPermissions(
    int itemId
)
Visual Basic (Declaration)
Public Function GetExtranetItemPermissions ( _
    itemId As Integer _
) As PermissionItemCollection
Visual C++
public:
PermissionItemCollection^ GetExtranetItemPermissions(
    int itemId
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item

Return Value

See Also

ExtranetDB Class
GetExtranetItemPermissions Overload
OfficeClip.DBLayer.Extranet Namespace


GetExtranetItemPermissions Method (Int32, ItemPermission)

[image]

OfficeClip API Documentation
ExtranetDB..::.GetExtranetItemPermissions Method (Int32, ItemPermission)
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets Item Permissions for specified item ID

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PermissionItemCollection GetExtranetItemPermissions(
    int itemId,
    ItemPermission permissions
)
Visual Basic (Declaration)
Public Function GetExtranetItemPermissions ( _
    itemId As Integer, _
    permissions As ItemPermission _
) As PermissionItemCollection
Visual C++
public:
PermissionItemCollection^ GetExtranetItemPermissions(
    int itemId,
    ItemPermission permissions
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
permissions
Type: OfficeClip.BusinessLayer.Extranet.Utility..::.ItemPermission

Return Value

See Also

ExtranetDB Class
GetExtranetItemPermissions Overload
OfficeClip.DBLayer.Extranet Namespace


GetExtranetItemsList Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetExtranetItemsList Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets list of ItemInfo to be used by AdminStart to display current list of items.

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<ItemInfo> GetExtranetItemsList(
    int groupId,
    int userId
)
Visual Basic (Declaration)
Public Function GetExtranetItemsList ( _
    groupId As Integer, _
    userId As Integer _
) As List(Of ItemInfo)
Visual C++
public:
List<ItemInfo^>^ GetExtranetItemsList(
    int groupId,
    int userId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetExtranetOrg Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetExtranetOrg Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Extranet Admin organization setup details and sets default values for initial setup

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OrgInfo GetExtranetOrg(
    int groupId
)
Visual Basic (Declaration)
Public Function GetExtranetOrg ( _
    groupId As Integer _
) As OrgInfo
Visual C++
public:
OrgInfo^ GetExtranetOrg(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetExtranetUserPermissions Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetExtranetUserPermissions Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetExtranetUserPermissions(
    int userId
)
Visual Basic (Declaration)
Public Function GetExtranetUserPermissions ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetExtranetUserPermissions(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


GetExtranetUserSelectedPermissions Method

[image]

OfficeClip API Documentation
ExtranetDB..::.GetExtranetUserSelectedPermissions Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the permissions for the users and checks the corresponsing checkboxes on the user permissions page

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetExtranetUserSelectedPermissions(
    int userId
)
Visual Basic (Declaration)
Public Function GetExtranetUserSelectedPermissions ( _
    userId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetExtranetUserSelectedPermissions(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
ExtranetDB..::.InitTransaction Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

ExtranetDB Class
ExtranetDB Members
OfficeClip.DBLayer.Extranet Namespace


InsertExtranetItem Method

[image]

OfficeClip API Documentation
ExtranetDB..::.InsertExtranetItem Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts new feature item into database

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExtranetItem(
    ItemInfo item,
    int groupId
)
Visual Basic (Declaration)
Public Function InsertExtranetItem ( _
    item As ItemInfo, _
    groupId As Integer _
) As Integer
Visual C++
public:
int InsertExtranetItem(
    ItemInfo^ item,
    int groupId
)

Parameters

item
Type: OfficeClip.BusinessLayer.Extranet..::.ItemInfo
groupId
Type: System..::.Int32

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


InsertExtranetUser Method

[image]

OfficeClip API Documentation
ExtranetDB..::.InsertExtranetUser Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts new Extranet user into the database

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExtranetUser(
    bool isActive,
    string firstName,
    string lastName,
    string emailAddress,
    int createdUserId,
    string password,
    string address1,
    string address2,
    string city,
    string state,
    string zip,
    int countryId,
    string workPhone,
    string homePhone,
    string cellPhone,
    string fax,
    string title,
    string organization,
    int groupId
)
Visual Basic (Declaration)
Public Function InsertExtranetUser ( _
    isActive As Boolean, _
    firstName As String, _
    lastName As String, _
    emailAddress As String, _
    createdUserId As Integer, _
    password As String, _
    address1 As String, _
    address2 As String, _
    city As String, _
    state As String, _
    zip As String, _
    countryId As Integer, _
    workPhone As String, _
    homePhone As String, _
    cellPhone As String, _
    fax As String, _
    title As String, _
    organization As String, _
    groupId As Integer _
) As Integer
Visual C++
public:
int InsertExtranetUser(
    bool isActive,
    String^ firstName,
    String^ lastName,
    String^ emailAddress,
    int createdUserId,
    String^ password,
    String^ address1,
    String^ address2,
    String^ city,
    String^ state,
    String^ zip,
    int countryId,
    String^ workPhone,
    String^ homePhone,
    String^ cellPhone,
    String^ fax,
    String^ title,
    String^ organization,
    int groupId
)

Parameters

isActive
Type: System..::.Boolean
Active status of new user
firstName
Type: System..::.String
First name of new user
lastName
Type: System..::.String
Last name of new user
emailAddress
Type: System..::.String
email address of new user
createdUserId
Type: System..::.Int32
The unique id of the created user
password
Type: System..::.String
unecrypted password of new user
address1
Type: System..::.String
First line of user's address
address2
Type: System..::.String
Second line of user's address
city
Type: System..::.String
city of user
state
Type: System..::.String
state of user
zip
Type: System..::.String
zip code of user
countryId
Type: System..::.Int32
The unique id of the country
workPhone
Type: System..::.String
work phone of user
homePhone
Type: System..::.String
Home phone of user.
cellPhone
Type: System..::.String
Cellular phone of new uwer
fax
Type: System..::.String
fax number of user
title
Type: System..::.String
title of new user
organization
Type: System..::.String
organization of new user
groupId
Type: System..::.Int32
Group ID of new usr.

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


InsExtranetPermissions Method

[image]

OfficeClip API Documentation
ExtranetDB..::.InsExtranetPermissions Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts array of users into DB that are authorized for specified ID

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsExtranetPermissions(
    int itemId,
    ArrayList users
)
Visual Basic (Declaration)
Public Sub InsExtranetPermissions ( _
    itemId As Integer, _
    users As ArrayList _
)
Visual C++
public:
void InsExtranetPermissions(
    int itemId,
    ArrayList^ users
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
users
Type: System.Collections..::.ArrayList

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


LoadExtranetOrgDefault Method

[image]

OfficeClip API Documentation
ExtranetDB..::.LoadExtranetOrgDefault Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Loads the extranet default parameters of the organization

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int LoadExtranetOrgDefault(
    int groupId
)
Visual Basic (Declaration)
Public Function LoadExtranetOrgDefault ( _
    groupId As Integer _
) As Integer
Visual C++
public:
int LoadExtranetOrgDefault(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
ExtranetDB..::.SetSPCommand Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

ExtranetDB Class
ExtranetDB Members
OfficeClip.DBLayer.Extranet Namespace


UpdActivateAllExtranetUsers Method

[image]

OfficeClip API Documentation
ExtranetDB..::.UpdActivateAllExtranetUsers Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets active state of all extranet users

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdActivateAllExtranetUsers(
    bool isActive
)
Visual Basic (Declaration)
Public Sub UpdActivateAllExtranetUsers ( _
    isActive As Boolean _
)
Visual C++
public:
void UpdActivateAllExtranetUsers(
    bool isActive
)

Parameters

isActive
Type: System..::.Boolean
Whether users are active or not

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


UpdActivateExtranetUser Method

[image]

OfficeClip API Documentation
ExtranetDB..::.UpdActivateExtranetUser Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets active state of specified user

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdActivateExtranetUser(
    int userId,
    bool isActive
)
Visual Basic (Declaration)
Public Sub UpdActivateExtranetUser ( _
    userId As Integer, _
    isActive As Boolean _
)
Visual C++
public:
void UpdActivateExtranetUser(
    int userId,
    bool isActive
)

Parameters

userId
Type: System..::.Int32
The unique id of the user to activate
isActive
Type: System..::.Boolean
Whether user is active or not

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


UpdateExtranetCaseStatus Method

[image]

OfficeClip API Documentation
ExtranetDB..::.UpdateExtranetCaseStatus Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates specified case with provided status

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateExtranetCaseStatus(
    int caseId,
    int status
)
Visual Basic (Declaration)
Public Sub UpdateExtranetCaseStatus ( _
    caseId As Integer, _
    status As Integer _
)
Visual C++
public:
void UpdateExtranetCaseStatus(
    int caseId,
    int status
)

Parameters

caseId
Type: System..::.Int32
status
Type: System..::.Int32

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


UpdateExtranetItem Method

[image]

OfficeClip API Documentation
ExtranetDB..::.UpdateExtranetItem Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates Extranet Item in the database

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateExtranetItem(
    ItemInfo item
)
Visual Basic (Declaration)
Public Sub UpdateExtranetItem ( _
    item As ItemInfo _
)
Visual C++
public:
void UpdateExtranetItem(
    ItemInfo^ item
)

Parameters

item
Type: OfficeClip.BusinessLayer.Extranet..::.ItemInfo

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


UpdateExtranetOrg Method

[image]

OfficeClip API Documentation
ExtranetDB..::.UpdateExtranetOrg Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database with the Extranet Admin Organization setup details

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateExtranetOrg(
    OrgInfo eInfo
)
Visual Basic (Declaration)
Public Function UpdateExtranetOrg ( _
    eInfo As OrgInfo _
) As Integer
Visual C++
public:
int UpdateExtranetOrg(
    OrgInfo^ eInfo
)

Parameters

eInfo
Type: OfficeClip.BusinessLayer.Extranet..::.OrgInfo
The Extranet Organization business object

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


UpdateExtranetUserPermissions Method

[image]

OfficeClip API Documentation
ExtranetDB..::.UpdateExtranetUserPermissions Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the permission items on the permissions page that are checked and updates the database with the corresponding permission records for each item

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateExtranetUserPermissions(
    int itemId,
    int userId,
    bool grantPermission
)
Visual Basic (Declaration)
Public Sub UpdateExtranetUserPermissions ( _
    itemId As Integer, _
    userId As Integer, _
    grantPermission As Boolean _
)
Visual C++
public:
void UpdateExtranetUserPermissions(
    int itemId,
    int userId,
    bool grantPermission
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
userId
Type: System..::.Int32
The unique id of the user
grantPermission
Type: System..::.Boolean

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


ValidateUserLogin Method

[image]

OfficeClip API Documentation
ExtranetDB..::.ValidateUserLogin Method
ExtranetDB Class See Also

[This is preliminary documentation and is subject to change.]

Integer flag indicating whether the user could be successfully authenticated. Following is the list of possible values returned and their meanings.

Namespace: OfficeClip.DBLayer.Extranet
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExtranetLoginStatus ValidateUserLogin(
    string emailAddress,
    string password,
    int orgId,
    out ExtranetUserInfo user
)
Visual Basic (Declaration)
Public Function ValidateUserLogin ( _
    emailAddress As String, _
    password As String, _
    orgId As Integer, _
    <OutAttribute> ByRef user As ExtranetUserInfo _
) As ExtranetLoginStatus
Visual C++
public:
ExtranetLoginStatus ValidateUserLogin(
    String^ emailAddress,
    String^ password,
    int orgId,
    [OutAttribute] ExtranetUserInfo^% user
)

Parameters

emailAddress
Type: System..::.String
password
Type: System..::.String
orgId
Type: System..::.Int32
The unique id of the organization
user
Type: OfficeClip.BusinessLayer.Extranet..::.ExtranetUserInfo %

Return Value

See Also

ExtranetDB Class
OfficeClip.DBLayer.Extranet Namespace


OfficeClip.DBLayer.Framework Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Framework Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip framework

Classes

 | Class | Description
Public class | AddressDB | Allows management of Address related functions. It enables querying and modifying information related to an addresses.
Public class | ApplicationDB | Provides a set functions to manage the applications and application access permissions.
Public class | FrameworkDB | OfficeClip Framework data layer. Information in this class is read from the appmenus.xml file in the APP_Data folder. This information is cached in the application variable and used throughout the site.
Public class | GeneralDB | Provides a set of application related functions which involve database access and are used by all ther OfficeClip applications.
Public class | GlobalDB | Global settings. Started with application initiation
Public class | HolidaysDB |
Public class | OCEmail | Provides a set of all the email related functions.
Public class | OCSmsDB | Provides a set of all the SMS related functions.
Public class | ProfileDB | Provides a set of Profile subsystem related functions.
Public class | ReminderDB | Provides a set of Reminder application related functions.
Public class | RemoveUserDataDB | The Remove user class
Public class | ReportDB | Provides a set of reporting functions.
Public class | TimezoneDB | Provides a set of timezone related functions.
Public class | TrackTimeDB | Allows management of Address related functions. It enables querying and modifying information related to an addresses.
Public class | WorkflowDB | Provides a set of workflow framework related functions.


AddressDB Class

[image]

OfficeClip API Documentation
AddressDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Allows management of Address related functions. It enables querying and modifying information related to an addresses.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class AddressDB : OfficeClipDB
Visual Basic (Declaration)
Public Class AddressDB _
    Inherits OfficeClipDB
Visual C++
public ref class AddressDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.AddressDB

See Also

AddressDB Members
OfficeClip.DBLayer.Framework Namespace


AddressDB Members

[image] [image]

OfficeClip API Documentation
AddressDB Members
AddressDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AddressDB type exposes the following members.

Constructors

 | Name | Description
Public method | AddressDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAddressInfo | Gets the Address information related to the Address id
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

AddressDB Class
OfficeClip.DBLayer.Framework Namespace


AddressDB Constructor

[image]

OfficeClip API Documentation
AddressDB Constructor
AddressDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public AddressDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AddressDB()

See Also

AddressDB Class
OfficeClip.DBLayer.Framework Namespace


AddressDB Methods

[image] [image]

OfficeClip API Documentation
AddressDB Methods
AddressDB Class See Also

[This is preliminary documentation and is subject to change.]

The AddressDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAddressInfo | Gets the Address information related to the Address id
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddressDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
AddressDB..::.AddOutputParameter Method
AddressDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

AddressDB Class
AddressDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
AddressDB..::.AddParameter Method
AddressDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

AddressDB Class
AddressDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
AddressDB..::.AddParameters Method
AddressDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

AddressDB Class
AddressDB Members
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
AddressDB..::.ExecuteNonQuery Method
AddressDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

AddressDB Class
AddressDB Members
OfficeClip.DBLayer.Framework Namespace


GetAddressInfo Method

[image]

OfficeClip API Documentation
AddressDB..::.GetAddressInfo Method
AddressDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Address information related to the Address id

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public AddressInfo GetAddressInfo(
    int addressId
)
Visual Basic (Declaration)
Public Function GetAddressInfo ( _
    addressId As Integer _
) As AddressInfo
Visual C++
public:
AddressInfo^ GetAddressInfo(
    int addressId
)

Parameters

addressId
Type: System..::.Int32
The database provided unique identifier for the Address

Return Value

The Address information object, see AddressInfo

See Also

AddressDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
AddressDB..::.InitTransaction Method
AddressDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

AddressDB Class
AddressDB Members
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
AddressDB..::.SetSPCommand Method
AddressDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

AddressDB Class
AddressDB Members
OfficeClip.DBLayer.Framework Namespace


ApplicationDB Class

[image]

OfficeClip API Documentation
ApplicationDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set functions to manage the applications and application access permissions.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class ApplicationDB : OfficeClipDB
Visual Basic (Declaration)
Public Class ApplicationDB _
    Inherits OfficeClipDB
Visual C++
public ref class ApplicationDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.ApplicationDB

See Also

ApplicationDB Members
OfficeClip.DBLayer.Framework Namespace


ApplicationDB Members

[image] [image]

OfficeClip API Documentation
ApplicationDB Members
ApplicationDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ApplicationDB type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationDB | The default constructor

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetApplicationInfo | Gets the application information corresponding to the unique application identifier.
Public method | GetApplicationMatrix | This gets used in muliple instances to update Session.Applications whenever there is some system operation that can change the available applications.
Public method | GetApplicationReminderInfo | Gets the reminder information of a particular user corresponding to a particular application identified by objectId.
Public method | GetApplications | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetRepeatingSequenceId | Gets the next sequence number for a give application and the type of use.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Public method | SetSecurityRequest | Sets the default value of the last time the security information is changed.
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
 | SynchronizeSecurityInfo | Refreshes the security information, so that if a role has changed in the system, all the logged in user will have their roles changed accordingly. Note that this sets the session but does not really use the session, if it is not set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateApplicationAccess | Overloaded.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

ApplicationDB Class
OfficeClip.DBLayer.Framework Namespace


ApplicationDB Constructor

[image]

OfficeClip API Documentation
ApplicationDB Constructor
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ApplicationDB()

See Also

ApplicationDB Class
OfficeClip.DBLayer.Framework Namespace


ApplicationDB Methods

[image] [image]

OfficeClip API Documentation
ApplicationDB Methods
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

The ApplicationDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetApplicationInfo | Gets the application information corresponding to the unique application identifier.
Public method | GetApplicationMatrix | This gets used in muliple instances to update Session.Applications whenever there is some system operation that can change the available applications.
Public method | GetApplicationReminderInfo | Gets the reminder information of a particular user corresponding to a particular application identified by objectId.
Public method | GetApplications | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetRepeatingSequenceId | Gets the next sequence number for a give application and the type of use.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Public method | SetSecurityRequest | Sets the default value of the last time the security information is changed.
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
 | SynchronizeSecurityInfo | Refreshes the security information, so that if a role has changed in the system, all the logged in user will have their roles changed accordingly. Note that this sets the session but does not really use the session, if it is not set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateApplicationAccess | Overloaded.

See Also

ApplicationDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
ApplicationDB..::.AddOutputParameter Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

ApplicationDB Class
ApplicationDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
ApplicationDB..::.AddParameter Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

ApplicationDB Class
ApplicationDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
ApplicationDB..::.AddParameters Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

ApplicationDB Class
ApplicationDB Members
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
ApplicationDB..::.ExecuteNonQuery Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

ApplicationDB Class
ApplicationDB Members
OfficeClip.DBLayer.Framework Namespace


GetApplicationInfo Method

[image]

OfficeClip API Documentation
ApplicationDB..::.GetApplicationInfo Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the application information corresponding to the unique application identifier.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ApplicationInfo GetApplicationInfo(
    int applicationId
)
Visual Basic (Declaration)
Public Function GetApplicationInfo ( _
    applicationId As Integer _
) As ApplicationInfo
Visual C++
public:
ApplicationInfo^ GetApplicationInfo(
    int applicationId
)

Parameters

applicationId
Type: System..::.Int32
the unique application identifier

Return Value

The application info object. See ApplicationInfo. Returns a null value if the application id could not be found.

See Also

ApplicationDB Class
OfficeClip.DBLayer.Framework Namespace


GetApplicationMatrix Method

[image]

OfficeClip API Documentation
ApplicationDB..::.GetApplicationMatrix Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

This gets used in muliple instances to update Session.Applications whenever there is some system operation that can change the available applications.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public byte[] GetApplicationMatrix(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetApplicationMatrix ( _
    userId As Integer, _
    groupId As Integer _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetApplicationMatrix(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32

Return Value

See Also

ApplicationDB Class
OfficeClip.DBLayer.Framework Namespace


GetApplicationReminderInfo Method

[image]

OfficeClip API Documentation
ApplicationDB..::.GetApplicationReminderInfo Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the reminder information of a particular user corresponding to a particular application identified by objectId.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetApplicationReminderInfo(
    int userId,
    int objectId,
    DateTime startDatetime,
    ref bool isReminderSelected,
    ref string whoToRemind,
    ref string whenToRemind,
    ref DateTime remindTime,
    int applicationId
)
Visual Basic (Declaration)
Public Sub GetApplicationReminderInfo ( _
    userId As Integer, _
    objectId As Integer, _
    startDatetime As DateTime, _
    ByRef isReminderSelected As Boolean, _
    ByRef whoToRemind As String, _
    ByRef whenToRemind As String, _
    ByRef remindTime As DateTime, _
    applicationId As Integer _
)
Visual C++
public:
void GetApplicationReminderInfo(
    int userId,
    int objectId,
    DateTime startDatetime,
    bool% isReminderSelected,
    String^% whoToRemind,
    String^% whenToRemind,
    DateTime% remindTime,
    int applicationId
)

Parameters

userId
Type: System..::.Int32
The unique id for the user.
objectId
Type: System..::.Int32
Id of the object for which the reminder information is to be obtained.
startDatetime
Type: System..::.DateTime
Date and Time of the reminder created corresponding to a particular event.
isReminderSelected
Type: System..::.Boolean%
Flag (True/False) indicating whether a reminder is created for this event or not.
whoToRemind
Type: System..::.String%
This tells whether just the person creating the reminder has to be reminded or if it is a group event, all the group members should be reminded.
whenToRemind
Type: System..::.String%
The difference in time (with reference to the event start date and time) when the reminder will be sent.
remindTime
Type: System..::.DateTime%
The remind time
applicationId
Type: System..::.Int32
The unique id of the application

See Also

ApplicationDB Class
OfficeClip.DBLayer.Framework Namespace


GetApplications Method

[image] [image]

OfficeClip API Documentation
ApplicationDB..::.GetApplications Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetApplications()()() | Gets all the applications
Public method | GetApplications(Int32) | Gets all the applications
Public method | GetApplications(Boolean, Int32, Int32) | Gets a list of all the applications for a particular group

See Also

ApplicationDB Class
ApplicationDB Members
OfficeClip.DBLayer.Framework Namespace


GetApplications Method

[image]

OfficeClip API Documentation
ApplicationDB..::.GetApplications Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the applications

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<ApplicationInfo> GetApplications()
Visual Basic (Declaration)
Public Function GetApplications As List(Of ApplicationInfo)
Visual C++
public:
List<ApplicationInfo^>^ GetApplications()

Return Value

See Also

ApplicationDB Class
GetApplications Overload
OfficeClip.DBLayer.Framework Namespace


GetApplications Method (Int32)

[image]

OfficeClip API Documentation
ApplicationDB..::.GetApplications Method (Int32)
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the applications

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetApplications(
    int userId
)
Visual Basic (Declaration)
Public Function GetApplications ( _
    userId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetApplications(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user

Return Value

See Also

ApplicationDB Class
GetApplications Overload
OfficeClip.DBLayer.Framework Namespace


GetApplications Method (Boolean, Int32, Int32)

[image]

OfficeClip API Documentation
ApplicationDB..::.GetApplications Method (Boolean, Int32, Int32)
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the applications for a particular group

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetApplications(
    bool isAccess,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetApplications ( _
    isAccess As Boolean, _
    userId As Integer, _
    groupId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetApplications(
    bool isAccess,
    int userId,
    int groupId
)

Parameters

isAccess
Type: System..::.Boolean
if true returns the applications which the group has access to, if false, returns the applications which the group does not have access to
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id for the group.

Return Value

The list containing the fields AppId and name which corresponds to the application id and name.

See Also

ApplicationDB Class
GetApplications Overload
OfficeClip.DBLayer.Framework Namespace


GetRepeatingSequenceId Method

[image]

OfficeClip API Documentation
ApplicationDB..::.GetRepeatingSequenceId Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the next sequence number for a give application and the type of use.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetRepeatingSequenceId(
    Constants..::.ApplicationType applicationId,
    int sequenceNumber
)
Visual Basic (Declaration)
Public Function GetRepeatingSequenceId ( _
    applicationId As Constants..::.ApplicationType, _
    sequenceNumber As Integer _
) As Integer
Visual C++
public:
int GetRepeatingSequenceId(
    Constants..::.ApplicationType applicationId,
    int sequenceNumber
)

Parameters

applicationId
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
Id of the application for which the repeating sequence has to be obtained.
sequenceNumber
Type: System..::.Int32
Id for the type of use of the sequence number within a particular application.

Return Value

The next repeating sequence number.

See Also

ApplicationDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
ApplicationDB..::.InitTransaction Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

ApplicationDB Class
ApplicationDB Members
OfficeClip.DBLayer.Framework Namespace


SetSecurityRequest Method

[image]

OfficeClip API Documentation
ApplicationDB..::.SetSecurityRequest Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the default value of the last time the security information is changed.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetSecurityRequest(
    DateTime dt
)
Visual Basic (Declaration)
Public Sub SetSecurityRequest ( _
    dt As DateTime _
)
Visual C++
public:
void SetSecurityRequest(
    DateTime dt
)

Parameters

dt
Type: System..::.DateTime
The datetime value that needs to be set.

See Also

ApplicationDB Class
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
ApplicationDB..::.SetSPCommand Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

ApplicationDB Class
ApplicationDB Members
OfficeClip.DBLayer.Framework Namespace


SynchronizeSecurityInfo Method

[image]

OfficeClip API Documentation
ApplicationDB..::.SynchronizeSecurityInfo Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Refreshes the security information, so that if a role has changed in the system, all the logged in user will have their roles changed accordingly. Note that this sets the session but does not really use the session, if it is not set.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static bool SynchronizeSecurityInfo()
Visual Basic (Declaration)
Public Shared Function SynchronizeSecurityInfo As Boolean
Visual C++
public:
static bool SynchronizeSecurityInfo()

Return Value

false if no sync is done, true otherwise

See Also

ApplicationDB Class
OfficeClip.DBLayer.Framework Namespace


UpdateApplicationAccess Method

[image] [image]

OfficeClip API Documentation
ApplicationDB..::.UpdateApplicationAccess Method
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | UpdateApplicationAccess(Int32, Boolean, Int32) | Updates the application access for the group
Public method | UpdateApplicationAccess(Int32, Int32, Boolean) | Updates the application access for the currently selected group.

See Also

ApplicationDB Class
ApplicationDB Members
OfficeClip.DBLayer.Framework Namespace


UpdateApplicationAccess Method (Int32, Boolean, Int32)

[image]

OfficeClip API Documentation
ApplicationDB..::.UpdateApplicationAccess Method (Int32, Boolean, Int32)
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the application access for the group

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateApplicationAccess(
    int applicationId,
    bool isDeleted,
    int groupId
)
Visual Basic (Declaration)
Public Sub UpdateApplicationAccess ( _
    applicationId As Integer, _
    isDeleted As Boolean, _
    groupId As Integer _
)
Visual C++
public:
void UpdateApplicationAccess(
    int applicationId,
    bool isDeleted,
    int groupId
)

Parameters

applicationId
Type: System..::.Int32
The application id of the application to be updated
isDeleted
Type: System..::.Boolean
if true, then the application will be deleted from the group, else it will be added
groupId
Type: System..::.Int32
unique identifier for the group.

See Also

ApplicationDB Class
UpdateApplicationAccess Overload
OfficeClip.DBLayer.Framework Namespace


UpdateApplicationAccess Method (Int32, Int32, Boolean)

[image]

OfficeClip API Documentation
ApplicationDB..::.UpdateApplicationAccess Method (Int32, Int32, Boolean)
ApplicationDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the application access for the currently selected group.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateApplicationAccess(
    int groupId,
    int applicationId,
    bool isDeleted
)
Visual Basic (Declaration)
Public Sub UpdateApplicationAccess ( _
    groupId As Integer, _
    applicationId As Integer, _
    isDeleted As Boolean _
)
Visual C++
public:
void UpdateApplicationAccess(
    int groupId,
    int applicationId,
    bool isDeleted
)

Parameters

groupId
Type: System..::.Int32
Unique id of the organization.
applicationId
Type: System..::.Int32
Id of the application for which the access needs to be updated.
isDeleted
Type: System..::.Boolean
Flag (True/False) indicating whether the access to a particular application should be removed or added. It is removed when isDeleted is equal to True and it is added when it is equal to False.

See Also

ApplicationDB Class
UpdateApplicationAccess Overload
OfficeClip.DBLayer.Framework Namespace


FrameworkDB Class

[image]

OfficeClip API Documentation
FrameworkDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

OfficeClip Framework data layer. Information in this class is read from the appmenus.xml file in the APP_Data folder. This information is cached in the application variable and used throughout the site.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class FrameworkDB : OfficeClipDB
Visual Basic (Declaration)
Public Class FrameworkDB _
    Inherits OfficeClipDB
Visual C++
public ref class FrameworkDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.FrameworkDB

See Also

FrameworkDB Members
OfficeClip.DBLayer.Framework Namespace


FrameworkDB Members

[image] [image]

OfficeClip API Documentation
FrameworkDB Members
FrameworkDB Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The FrameworkDB type exposes the following members.

Constructors

 | Name | Description
Public method | FrameworkDB | Constructor

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChildMenuItems | Gets the child menu items
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLeftbar | Gets the left bar
Public method | GetMenubar | Gets the menubar
Protected method | GetNodeAttribute |
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetRightMenuButton | Gets the right menu button items
Public method | GetToolbar | Gets the toolbar
Public method | GetToolbarForApplication | Gets the toolbar object for an application
Protected method | GetToolbarMenuItems | Gets the toolbar menu items
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUrl | Gets the url
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReadInfobar |
Protected method | ReadLeftMenuFloatInfo |
Protected method | ReadMenubar | Reads the menubar
Protected method | ReadRightMenuButtonItems | Reads the right menubar items
Protected method | ReadRightMenuFloatInfo |
Protected method | ReadToolbar | Reads the toolbar
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Protected method | SetNameAndToolTip | Overloaded.
Protected method | SetPageFooter |
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Protected method | SetToolbarHidden |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | IsLeftMenuFloatInfo | Determines if the left menu shows the date
Public field | IsMenubarHidden | True if the menubar is present
Public field | IsRightMenuFloatInfo | Determines if the right menu shows the User
Public field | IsShowQuickLinks | True if the quicklinks are shown to the user
Public field | IsToolbarHidden | True if the toolbar need not be shown to the user
Protected field | mis | Menu items
Protected field | ocr | OfficeClip resources
Public field | OrganizationAlias | The alias for the organization name that is shown to the user
Public field | PageFooter | The footer that would show up on every page
Protected field | rMbItems | The right menu button items
Protected field | tis | toolbar items
Protected field | xpNavigator | Navigator

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


FrameworkDB Constructor

[image]

OfficeClip API Documentation
FrameworkDB Constructor
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public FrameworkDB(
    string fileName
)
Visual Basic (Declaration)
Public Sub New ( _
    fileName As String _
)
Visual C++
public:
FrameworkDB(
    String^ fileName
)

Parameters

fileName
Type: System..::.String

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


FrameworkDB Fields

[image] [image]

OfficeClip API Documentation
FrameworkDB Fields
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

The FrameworkDB type exposes the following fields.

Fields

 | Name | Description
Public field | IsLeftMenuFloatInfo | Determines if the left menu shows the date
Public field | IsMenubarHidden | True if the menubar is present
Public field | IsRightMenuFloatInfo | Determines if the right menu shows the User
Public field | IsShowQuickLinks | True if the quicklinks are shown to the user
Public field | IsToolbarHidden | True if the toolbar need not be shown to the user
Protected field | mis | Menu items
Protected field | ocr | OfficeClip resources
Public field | OrganizationAlias | The alias for the organization name that is shown to the user
Public field | PageFooter | The footer that would show up on every page
Protected field | rMbItems | The right menu button items
Protected field | tis | toolbar items
Protected field | xpNavigator | Navigator

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


IsLeftMenuFloatInfo Field

[image]

OfficeClip API Documentation
FrameworkDB..::.IsLeftMenuFloatInfo Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the left menu shows the date

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsLeftMenuFloatInfo
Visual Basic (Declaration)
Public IsLeftMenuFloatInfo As Boolean
Visual C++
public:
bool IsLeftMenuFloatInfo

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


IsMenubarHidden Field

[image]

OfficeClip API Documentation
FrameworkDB..::.IsMenubarHidden Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

True if the menubar is present

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsMenubarHidden
Visual Basic (Declaration)
Public IsMenubarHidden As Boolean
Visual C++
public:
bool IsMenubarHidden

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


IsRightMenuFloatInfo Field

[image]

OfficeClip API Documentation
FrameworkDB..::.IsRightMenuFloatInfo Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the right menu shows the User

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsRightMenuFloatInfo
Visual Basic (Declaration)
Public IsRightMenuFloatInfo As Boolean
Visual C++
public:
bool IsRightMenuFloatInfo

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


IsShowQuickLinks Field

[image]

OfficeClip API Documentation
FrameworkDB..::.IsShowQuickLinks Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

True if the quicklinks are shown to the user

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsShowQuickLinks
Visual Basic (Declaration)
Public IsShowQuickLinks As Boolean
Visual C++
public:
bool IsShowQuickLinks

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


IsToolbarHidden Field

[image]

OfficeClip API Documentation
FrameworkDB..::.IsToolbarHidden Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

True if the toolbar need not be shown to the user

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsToolbarHidden
Visual Basic (Declaration)
Public IsToolbarHidden As Boolean
Visual C++
public:
bool IsToolbarHidden

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


mis Field

[image]

OfficeClip API Documentation
FrameworkDB..::.mis Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Menu items

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected List<MenuItem> mis
Visual Basic (Declaration)
Protected mis As List(Of MenuItem)
Visual C++
protected:
List<MenuItem^>^ mis

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


ocr Field

[image]

OfficeClip API Documentation
FrameworkDB..::.ocr Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

OfficeClip resources

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected OCResources ocr
Visual Basic (Declaration)
Protected ocr As OCResources
Visual C++
protected:
OCResources^ ocr

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


OrganizationAlias Field

[image]

OfficeClip API Documentation
FrameworkDB..::.OrganizationAlias Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

The alias for the organization name that is shown to the user

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string OrganizationAlias
Visual Basic (Declaration)
Public OrganizationAlias As String
Visual C++
public:
String^ OrganizationAlias

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


PageFooter Field

[image]

OfficeClip API Documentation
FrameworkDB..::.PageFooter Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

The footer that would show up on every page

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string PageFooter
Visual Basic (Declaration)
Public PageFooter As String
Visual C++
public:
String^ PageFooter

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


rMbItems Field

[image]

OfficeClip API Documentation
FrameworkDB..::.rMbItems Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

The right menu button items

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected List<RightMenuButtonItem> rMbItems
Visual Basic (Declaration)
Protected rMbItems As List(Of RightMenuButtonItem)
Visual C++
protected:
List<RightMenuButtonItem^>^ rMbItems

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


tis Field

[image]

OfficeClip API Documentation
FrameworkDB..::.tis Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

toolbar items

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected List<ToolbarItem> tis
Visual Basic (Declaration)
Protected tis As List(Of ToolbarItem)
Visual C++
protected:
List<ToolbarItem^>^ tis

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


xpNavigator Field

[image]

OfficeClip API Documentation
FrameworkDB..::.xpNavigator Field
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Navigator

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected XPathNavigator xpNavigator
Visual Basic (Declaration)
Protected xpNavigator As XPathNavigator
Visual C++
protected:
XPathNavigator^ xpNavigator

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


FrameworkDB Methods

[image] [image]

OfficeClip API Documentation
FrameworkDB Methods
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

The FrameworkDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetChildMenuItems | Gets the child menu items
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLeftbar | Gets the left bar
Public method | GetMenubar | Gets the menubar
Protected method | GetNodeAttribute |
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetRightMenuButton | Gets the right menu button items
Public method | GetToolbar | Gets the toolbar
Public method | GetToolbarForApplication | Gets the toolbar object for an application
Protected method | GetToolbarMenuItems | Gets the toolbar menu items
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUrl | Gets the url
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ReadInfobar |
Protected method | ReadLeftMenuFloatInfo |
Protected method | ReadMenubar | Reads the menubar
Protected method | ReadRightMenuButtonItems | Reads the right menubar items
Protected method | ReadRightMenuFloatInfo |
Protected method | ReadToolbar | Reads the toolbar
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Protected method | SetNameAndToolTip | Overloaded.
Protected method | SetPageFooter |
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Protected method | SetToolbarHidden |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
FrameworkDB..::.AddOutputParameter Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

FrameworkDB Class
FrameworkDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
FrameworkDB..::.AddParameter Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

FrameworkDB Class
FrameworkDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
FrameworkDB..::.AddParameters Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

FrameworkDB Class
FrameworkDB Members
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
FrameworkDB..::.ExecuteNonQuery Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

FrameworkDB Class
FrameworkDB Members
OfficeClip.DBLayer.Framework Namespace


GetChildMenuItems Method

[image]

OfficeClip API Documentation
FrameworkDB..::.GetChildMenuItems Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the child menu items

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void GetChildMenuItems(
    XPathNavigator nav,
    MenuItem parentMenuItem,
    bool isTopLevel
)
Visual Basic (Declaration)
Protected Sub GetChildMenuItems ( _
    nav As XPathNavigator, _
    parentMenuItem As MenuItem, _
    isTopLevel As Boolean _
)
Visual C++
protected:
void GetChildMenuItems(
    XPathNavigator^ nav,
    MenuItem^ parentMenuItem,
    bool isTopLevel
)

Parameters

nav
Type: System.Xml.XPath..::.XPathNavigator
parentMenuItem
Type: OfficeClip.BusinessLayer.Framework..::.MenuItem
isTopLevel
Type: System..::.Boolean

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


GetLeftbar Method

[image]

OfficeClip API Documentation
FrameworkDB..::.GetLeftbar Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the left bar

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<LeftbarItem> GetLeftbar(
    Constants..::.ToolbarType tt
)
Visual Basic (Declaration)
Public Function GetLeftbar ( _
    tt As Constants..::.ToolbarType _
) As List(Of LeftbarItem)
Visual C++
public:
List<LeftbarItem^>^ GetLeftbar(
    Constants..::.ToolbarType tt
)

Parameters

tt
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ToolbarType

Return Value

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


GetMenubar Method

[image]

OfficeClip API Documentation
FrameworkDB..::.GetMenubar Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the menubar

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<MenuItem> GetMenubar()
Visual Basic (Declaration)
Public Function GetMenubar As List(Of MenuItem)
Visual C++
public:
List<MenuItem^>^ GetMenubar()

Return Value

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


GetNodeAttribute Method

[image]

OfficeClip API Documentation
FrameworkDB..::.GetNodeAttribute Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetNodeAttribute(
    XPathNavigator nav,
    string id,
    string _default
)
Visual Basic (Declaration)
Protected Function GetNodeAttribute ( _
    nav As XPathNavigator, _
    id As String, _
    _default As String _
) As String
Visual C++
protected:
String^ GetNodeAttribute(
    XPathNavigator^ nav,
    String^ id,
    String^ _default
)

Parameters

nav
Type: System.Xml.XPath..::.XPathNavigator
id
Type: System..::.String
_default
Type: System..::.String

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


GetRightMenuButton Method

[image]

OfficeClip API Documentation
FrameworkDB..::.GetRightMenuButton Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the right menu button items

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<RightMenuButtonItem> GetRightMenuButton()
Visual Basic (Declaration)
Public Function GetRightMenuButton As List(Of RightMenuButtonItem)
Visual C++
public:
List<RightMenuButtonItem^>^ GetRightMenuButton()

Return Value

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


GetToolbar Method

[image]

OfficeClip API Documentation
FrameworkDB..::.GetToolbar Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the toolbar

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<ToolbarItem> GetToolbar()
Visual Basic (Declaration)
Public Function GetToolbar As List(Of ToolbarItem)
Visual C++
public:
List<ToolbarItem^>^ GetToolbar()

Return Value

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


GetToolbarForApplication Method

[image]

OfficeClip API Documentation
FrameworkDB..::.GetToolbarForApplication Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the toolbar object for an application

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ToolbarItem GetToolbarForApplication(
    int appId
)
Visual Basic (Declaration)
Public Function GetToolbarForApplication ( _
    appId As Integer _
) As ToolbarItem
Visual C++
public:
ToolbarItem^ GetToolbarForApplication(
    int appId
)

Parameters

appId
Type: System..::.Int32
The unique id for the application

Return Value

The toolbar object for the application or null if not found

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


GetToolbarMenuItems Method

[image]

OfficeClip API Documentation
FrameworkDB..::.GetToolbarMenuItems Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the toolbar menu items

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void GetToolbarMenuItems(
    MenuItem parentMenuItem
)
Visual Basic (Declaration)
Protected Sub GetToolbarMenuItems ( _
    parentMenuItem As MenuItem _
)
Visual C++
protected:
void GetToolbarMenuItems(
    MenuItem^ parentMenuItem
)

Parameters

parentMenuItem
Type: OfficeClip.BusinessLayer.Framework..::.MenuItem

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


GetUrl Method

[image]

OfficeClip API Documentation
FrameworkDB..::.GetUrl Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the url

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetUrl(
    string url,
    int appId
)
Visual Basic (Declaration)
Protected Function GetUrl ( _
    url As String, _
    appId As Integer _
) As String
Visual C++
protected:
String^ GetUrl(
    String^ url,
    int appId
)

Parameters

url
Type: System..::.String
appId
Type: System..::.Int32

Return Value

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
FrameworkDB..::.InitTransaction Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

FrameworkDB Class
FrameworkDB Members
OfficeClip.DBLayer.Framework Namespace


ReadInfobar Method

[image]

OfficeClip API Documentation
FrameworkDB..::.ReadInfobar Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void ReadInfobar()
Visual Basic (Declaration)
Protected Sub ReadInfobar
Visual C++
protected:
void ReadInfobar()

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


ReadLeftMenuFloatInfo Method

[image]

OfficeClip API Documentation
FrameworkDB..::.ReadLeftMenuFloatInfo Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void ReadLeftMenuFloatInfo()
Visual Basic (Declaration)
Protected Sub ReadLeftMenuFloatInfo
Visual C++
protected:
void ReadLeftMenuFloatInfo()

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


ReadMenubar Method

[image]

OfficeClip API Documentation
FrameworkDB..::.ReadMenubar Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Reads the menubar

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void ReadMenubar()
Visual Basic (Declaration)
Protected Sub ReadMenubar
Visual C++
protected:
void ReadMenubar()

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


ReadRightMenuButtonItems Method

[image]

OfficeClip API Documentation
FrameworkDB..::.ReadRightMenuButtonItems Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Reads the right menubar items

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void ReadRightMenuButtonItems()
Visual Basic (Declaration)
Protected Sub ReadRightMenuButtonItems
Visual C++
protected:
void ReadRightMenuButtonItems()

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


ReadRightMenuFloatInfo Method

[image]

OfficeClip API Documentation
FrameworkDB..::.ReadRightMenuFloatInfo Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void ReadRightMenuFloatInfo()
Visual Basic (Declaration)
Protected Sub ReadRightMenuFloatInfo
Visual C++
protected:
void ReadRightMenuFloatInfo()

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


ReadToolbar Method

[image]

OfficeClip API Documentation
FrameworkDB..::.ReadToolbar Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Reads the toolbar

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void ReadToolbar()
Visual Basic (Declaration)
Protected Sub ReadToolbar
Visual C++
protected:
void ReadToolbar()

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


SetNameAndToolTip Method

[image] [image]

OfficeClip API Documentation
FrameworkDB..::.SetNameAndToolTip Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetNameAndToolTip(LeftbarItem) | Sets the name and the tooltip
Protected method | SetNameAndToolTip(MenuItem) | Sets the name and the tooltip
Protected method | SetNameAndToolTip(ToolbarItem) | Sets the name and the tooltip

See Also

FrameworkDB Class
FrameworkDB Members
OfficeClip.DBLayer.Framework Namespace


SetNameAndToolTip Method (LeftbarItem)

[image]

OfficeClip API Documentation
FrameworkDB..::.SetNameAndToolTip Method (LeftbarItem)
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the name and the tooltip

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetNameAndToolTip(
    LeftbarItem li
)
Visual Basic (Declaration)
Protected Sub SetNameAndToolTip ( _
    li As LeftbarItem _
)
Visual C++
protected:
void SetNameAndToolTip(
    LeftbarItem^ li
)

Parameters

li
Type: OfficeClip.BusinessLayer.Framework..::.LeftbarItem

See Also

FrameworkDB Class
SetNameAndToolTip Overload
OfficeClip.DBLayer.Framework Namespace


SetNameAndToolTip Method (MenuItem)

[image]

OfficeClip API Documentation
FrameworkDB..::.SetNameAndToolTip Method (MenuItem)
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the name and the tooltip

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetNameAndToolTip(
    MenuItem mi
)
Visual Basic (Declaration)
Protected Sub SetNameAndToolTip ( _
    mi As MenuItem _
)
Visual C++
protected:
void SetNameAndToolTip(
    MenuItem^ mi
)

Parameters

mi
Type: OfficeClip.BusinessLayer.Framework..::.MenuItem

See Also

FrameworkDB Class
SetNameAndToolTip Overload
OfficeClip.DBLayer.Framework Namespace


SetNameAndToolTip Method (ToolbarItem)

[image]

OfficeClip API Documentation
FrameworkDB..::.SetNameAndToolTip Method (ToolbarItem)
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the name and the tooltip

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetNameAndToolTip(
    ToolbarItem ti
)
Visual Basic (Declaration)
Protected Sub SetNameAndToolTip ( _
    ti As ToolbarItem _
)
Visual C++
protected:
void SetNameAndToolTip(
    ToolbarItem^ ti
)

Parameters

ti
Type: OfficeClip.BusinessLayer.Framework..::.ToolbarItem

See Also

FrameworkDB Class
SetNameAndToolTip Overload
OfficeClip.DBLayer.Framework Namespace


SetPageFooter Method

[image]

OfficeClip API Documentation
FrameworkDB..::.SetPageFooter Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetPageFooter()
Visual Basic (Declaration)
Protected Sub SetPageFooter
Visual C++
protected:
void SetPageFooter()

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
FrameworkDB..::.SetSPCommand Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

FrameworkDB Class
FrameworkDB Members
OfficeClip.DBLayer.Framework Namespace


SetToolbarHidden Method

[image]

OfficeClip API Documentation
FrameworkDB..::.SetToolbarHidden Method
FrameworkDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetToolbarHidden()
Visual Basic (Declaration)
Protected Sub SetToolbarHidden
Visual C++
protected:
void SetToolbarHidden()

See Also

FrameworkDB Class
OfficeClip.DBLayer.Framework Namespace


GeneralDB Class

[image]

OfficeClip API Documentation
GeneralDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of application related functions which involve database access and are used by all ther OfficeClip applications.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class GeneralDB : OfficeClipDB
Visual Basic (Declaration)
Public Class GeneralDB _
    Inherits OfficeClipDB
Visual C++
public ref class GeneralDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.GeneralDB

See Also

GeneralDB Members
OfficeClip.DBLayer.Framework Namespace


GeneralDB Members

[image] [image]

OfficeClip API Documentation
GeneralDB Members
GeneralDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The GeneralDB type exposes the following members.

Constructors

 | Name | Description
Public method | GeneralDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteClassification | Deletes a classification
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindNames | Find Names
Public method | GetClassification | Gets the details of a classification
Public method | GetClassifications | Gets the list of classifications
Public method | GetCorpMenuFiles | Gets all the files uploaded by the user to be used in a particular group's or organization's Menus.
Public method | GetCorpMenuPath | Checks if the Web Content menu xml file is present, and if the Web Content menu can be shown to the user, if so, returns the full path name of the xml file, if not returns the empty string. This menu file path is returned for a particular group..
Public method | GetCountries | Gets a list of all the countries names and the corresponding ids.
Public method | GetEmailActivationCode | Gets a randomly generated string which is used as an email activation code, which the users can Update after getting in their email in order to confirm that their email Address is valid as they could receive it.
Public method | GetFrameInformation | Is the top frame shown
Public method | GetGeneralCurrencyList | Gets the list of currencies
Public method | GetGroupListGridLayout | Returns the order in which the columns in the group list or address book are to be displayed. For more information refer to the OfficeClip customization document, level 1 customization using the groupList.xml.
Public method | GetGroupListGridNumberOfRows | Gets the number of rows per page as specified in the xml configuration file groupList.xml. Please refer to the OfficeClip level 1 customization help.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectDescription | Gets a short object description from the object type and object id
Public method | GetOfficeClipDbVersion | Retrives the OfficeClip Database Version
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetProxiedFromUsers | Gets the information related to the proxied users
Public method | GetProxyUsersList | Gets the proxy user list
Public method | GetRandomPassword | Gets a random password by matching a list of adjectives and nouns from the passwordCombination.xml file. Please refer to the OfficeClip level 1 customization help in order to customize the values of the randomly generated passwords.
Public method | GetSavedCorpMenu | Gets the menu definition chosen by the user which was stored in an xml file corresponding to a particular group.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertClassification | Inserts a new classification
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SaveCorpMenuFile | Saves a menu definition created by the user in the form of an xml document for a particular group.
Public method | SaveQuickHelpProfile | Saves the quick help profile
Public method | SetCodeProtectorValue | Sets the code protector value
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateClassification | Updates a classification
Public method | UpdateProxyUsers | Updates the list of users who can be proxied an application or a particular operation within an application for the currently logged in user.
Public method | UploadCorpMenuFile | Uploads a file which can be used as a link to one of a particular group or organization Menus.
Public method | ValidVersion | Validate the Version between the database and the code. It is assumed that if the major Version number and the minor Version number does not match, then the versions are mismatched and the application cannot run properly.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GeneralDB Constructor

[image]

OfficeClip API Documentation
GeneralDB Constructor
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GeneralDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GeneralDB()

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GeneralDB Methods

[image] [image]

OfficeClip API Documentation
GeneralDB Methods
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

The GeneralDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteClassification | Deletes a classification
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindNames | Find Names
Public method | GetClassification | Gets the details of a classification
Public method | GetClassifications | Gets the list of classifications
Public method | GetCorpMenuFiles | Gets all the files uploaded by the user to be used in a particular group's or organization's Menus.
Public method | GetCorpMenuPath | Checks if the Web Content menu xml file is present, and if the Web Content menu can be shown to the user, if so, returns the full path name of the xml file, if not returns the empty string. This menu file path is returned for a particular group..
Public method | GetCountries | Gets a list of all the countries names and the corresponding ids.
Public method | GetEmailActivationCode | Gets a randomly generated string which is used as an email activation code, which the users can Update after getting in their email in order to confirm that their email Address is valid as they could receive it.
Public method | GetFrameInformation | Is the top frame shown
Public method | GetGeneralCurrencyList | Gets the list of currencies
Public method | GetGroupListGridLayout | Returns the order in which the columns in the group list or address book are to be displayed. For more information refer to the OfficeClip customization document, level 1 customization using the groupList.xml.
Public method | GetGroupListGridNumberOfRows | Gets the number of rows per page as specified in the xml configuration file groupList.xml. Please refer to the OfficeClip level 1 customization help.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectDescription | Gets a short object description from the object type and object id
Public method | GetOfficeClipDbVersion | Retrives the OfficeClip Database Version
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetProxiedFromUsers | Gets the information related to the proxied users
Public method | GetProxyUsersList | Gets the proxy user list
Public method | GetRandomPassword | Gets a random password by matching a list of adjectives and nouns from the passwordCombination.xml file. Please refer to the OfficeClip level 1 customization help in order to customize the values of the randomly generated passwords.
Public method | GetSavedCorpMenu | Gets the menu definition chosen by the user which was stored in an xml file corresponding to a particular group.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertClassification | Inserts a new classification
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SaveCorpMenuFile | Saves a menu definition created by the user in the form of an xml document for a particular group.
Public method | SaveQuickHelpProfile | Saves the quick help profile
Public method | SetCodeProtectorValue | Sets the code protector value
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateClassification | Updates a classification
Public method | UpdateProxyUsers | Updates the list of users who can be proxied an application or a particular operation within an application for the currently logged in user.
Public method | UploadCorpMenuFile | Uploads a file which can be used as a link to one of a particular group or organization Menus.
Public method | ValidVersion | Validate the Version between the database and the code. It is assumed that if the major Version number and the minor Version number does not match, then the versions are mismatched and the application cannot run properly.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
GeneralDB..::.AddOutputParameter Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

GeneralDB Class
GeneralDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
GeneralDB..::.AddParameter Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

GeneralDB Class
GeneralDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
GeneralDB..::.AddParameters Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

GeneralDB Class
GeneralDB Members
OfficeClip.DBLayer.Framework Namespace


DeleteClassification Method

[image]

OfficeClip API Documentation
GeneralDB..::.DeleteClassification Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a classification

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteClassification(
    int labelId
)
Visual Basic (Declaration)
Public Sub DeleteClassification ( _
    labelId As Integer _
)
Visual C++
public:
void DeleteClassification(
    int labelId
)

Parameters

labelId
Type: System..::.Int32

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
GeneralDB..::.ExecuteNonQuery Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

GeneralDB Class
GeneralDB Members
OfficeClip.DBLayer.Framework Namespace


FindNames Method

[image]

OfficeClip API Documentation
GeneralDB..::.FindNames Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Find Names

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable FindNames(
    int userId,
    int groupId,
    BusinessConstants..::.ObjectType ot,
    string searchStr
)
Visual Basic (Declaration)
Public Function FindNames ( _
    userId As Integer, _
    groupId As Integer, _
    ot As BusinessConstants..::.ObjectType, _
    searchStr As String _
) As DataTable
Visual C++
public:
DataTable^ FindNames(
    int userId,
    int groupId,
    BusinessConstants..::.ObjectType ot,
    String^ searchStr
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
ot
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
searchStr
Type: System..::.String

Return Value

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetClassification Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetClassification Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the details of a classification

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public Classification GetClassification(
    int labelId
)
Visual Basic (Declaration)
Public Function GetClassification ( _
    labelId As Integer _
) As Classification
Visual C++
public:
Classification^ GetClassification(
    int labelId
)

Parameters

labelId
Type: System..::.Int32

Return Value

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetClassifications Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetClassifications Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of classifications

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<Classification> GetClassifications(
    int userId
)
Visual Basic (Declaration)
Public Function GetClassifications ( _
    userId As Integer _
) As List(Of Classification)
Visual C++
public:
List<Classification^>^ GetClassifications(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetCorpMenuFiles Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetCorpMenuFiles Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the files uploaded by the user to be used in a particular group's or organization's Menus.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetCorpMenuFiles(
    int groupId
)
Visual Basic (Declaration)
Public Function GetCorpMenuFiles ( _
    groupId As Integer _
) As DataView
Visual C++
public:
DataView^ GetCorpMenuFiles(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
Id of a particular group.

Return Value

DataView consisting of the following columns.
  • fileName (System.String)Name of the file.
  • filePath (System.String)Path of the file.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetCorpMenuPath Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetCorpMenuPath Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks if the Web Content menu xml file is present, and if the Web Content menu can be shown to the user, if so, returns the full path name of the xml file, if not returns the empty string. This menu file path is returned for a particular group..

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetCorpMenuPath(
    int groupId,
    bool showCorporateMenu
)
Visual Basic (Declaration)
Public Function GetCorpMenuPath ( _
    groupId As Integer, _
    showCorporateMenu As Boolean _
) As String
Visual C++
public:
String^ GetCorpMenuPath(
    int groupId,
    bool showCorporateMenu
)

Parameters

groupId
Type: System..::.Int32
Id of a particular group.
showCorporateMenu
Type: System..::.Boolean
Flag (True/False) indicating whether to show the corporate menu or not.

Return Value

Xml file path or empty string.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetCountries Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetCountries Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the countries names and the corresponding ids.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetCountries(
    bool isFirstLineBlank
)
Visual Basic (Declaration)
Public Function GetCountries ( _
    isFirstLineBlank As Boolean _
) As DataTable
Visual C++
public:
DataTable^ GetCountries(
    bool isFirstLineBlank
)

Parameters

isFirstLineBlank
Type: System..::.Boolean
Flag (True/False) indicating whether the first item in the list should be a blank entry or not.

Return Value

DataTable consisting of the following two columns.
  • id (System.Int32)Id of the Country.
  • name (System.String)Name of the Country.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetEmailActivationCode Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetEmailActivationCode Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a randomly generated string which is used as an email activation code, which the users can Update after getting in their email in order to confirm that their email Address is valid as they could receive it.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetEmailActivationCode()
Visual Basic (Declaration)
Public Function GetEmailActivationCode As String
Visual C++
public:
String^ GetEmailActivationCode()

Return Value

Randomly generated email activation code.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetFrameInformation Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetFrameInformation Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Is the top frame shown

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetFrameInformation(
    int accountId,
    ref bool isTopFrame,
    ref bool isTopBanner,
    ref bool isSideBanner
)
Visual Basic (Declaration)
Public Sub GetFrameInformation ( _
    accountId As Integer, _
    ByRef isTopFrame As Boolean, _
    ByRef isTopBanner As Boolean, _
    ByRef isSideBanner As Boolean _
)
Visual C++
public:
void GetFrameInformation(
    int accountId,
    bool% isTopFrame,
    bool% isTopBanner,
    bool% isSideBanner
)

Parameters

accountId
Type: System..::.Int32
isTopFrame
Type: System..::.Boolean%
isTopBanner
Type: System..::.Boolean%
isSideBanner
Type: System..::.Boolean%

Return Value

true if the top frame is shown, false otherwise

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetGeneralCurrencyList Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetGeneralCurrencyList Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of currencies

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetGeneralCurrencyList()
Visual Basic (Declaration)
Public Function GetGeneralCurrencyList As DataTable
Visual C++
public:
DataTable^ GetGeneralCurrencyList()

Return Value

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetGroupListGridLayout Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetGroupListGridLayout Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the order in which the columns in the group list or address book are to be displayed. For more information refer to the OfficeClip customization document, level 1 customization using the groupList.xml.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetGroupListGridLayout(
    OCResources ocr
)
Visual Basic (Declaration)
Public Function GetGroupListGridLayout ( _
    ocr As OCResources _
) As ArrayList
Visual C++
public:
ArrayList^ GetGroupListGridLayout(
    OCResources^ ocr
)

Parameters

ocr
Type: OfficeClip.Utils..::.OCResources
The OfficeClip resource object.

Return Value

ArrayList of the all the group list column names in the order in which they are to be displayed on the OfficeAgent Group List screen or Contact List screen.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetGroupListGridNumberOfRows Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetGroupListGridNumberOfRows Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the number of rows per page as specified in the xml configuration file groupList.xml. Please refer to the OfficeClip level 1 customization help.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetGroupListGridNumberOfRows(
    OCResources ocr
)
Visual Basic (Declaration)
Public Function GetGroupListGridNumberOfRows ( _
    ocr As OCResources _
) As Integer
Visual C++
public:
int GetGroupListGridNumberOfRows(
    OCResources^ ocr
)

Parameters

ocr
Type: OfficeClip.Utils..::.OCResources
The OfficeClip resource object.

Return Value

Number of rows to be displayed on the User Manager Group List screen or Contact List screen.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetObjectDescription Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetObjectDescription Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a short object description from the object type and object id

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetObjectDescription(
    BusinessConstants..::.ObjectType oType,
    int objectId
)
Visual Basic (Declaration)
Public Function GetObjectDescription ( _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer _
) As String
Visual C++
public:
String^ GetObjectDescription(
    BusinessConstants..::.ObjectType oType,
    int objectId
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type
objectId
Type: System..::.Int32
The unique id of the object

Return Value

The short description of the particular object. Empty, if no description could be found.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetOfficeClipDbVersion Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetOfficeClipDbVersion Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Retrives the OfficeClip Database Version

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetOfficeClipDbVersion()
Visual Basic (Declaration)
Public Function GetOfficeClipDbVersion As String
Visual C++
public:
String^ GetOfficeClipDbVersion()

Return Value

The OfficeClip database Version

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetProxiedFromUsers Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetProxiedFromUsers Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the information related to the proxied users

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetProxiedFromUsers(
    int ApplicationId,
    int ApplicationSecondaryId,
    int currentUserId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function GetProxiedFromUsers ( _
    ApplicationId As Integer, _
    ApplicationSecondaryId As Integer, _
    currentUserId As Integer, _
    currentGroupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetProxiedFromUsers(
    int ApplicationId,
    int ApplicationSecondaryId,
    int currentUserId,
    int currentGroupId
)

Parameters

ApplicationId
Type: System..::.Int32
The database generated unique id of the application
ApplicationSecondaryId
Type: System..::.Int32
The database generated application secondary id
currentUserId
Type: System..::.Int32
The unique id of the current user
currentGroupId
Type: System..::.Int32
The id of the current organization

Return Value

The dataset corresponding to the proxied users

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetProxyUsersList Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetProxyUsersList Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the proxy user list

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetProxyUsersList(
    int ApplicationId,
    int ApplicationSecondaryId,
    int currentUserId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function GetProxyUsersList ( _
    ApplicationId As Integer, _
    ApplicationSecondaryId As Integer, _
    currentUserId As Integer, _
    currentGroupId As Integer _
) As DataView
Visual C++
public:
DataView^ GetProxyUsersList(
    int ApplicationId,
    int ApplicationSecondaryId,
    int currentUserId,
    int currentGroupId
)

Parameters

ApplicationId
Type: System..::.Int32
The database generated unique id of the application
ApplicationSecondaryId
Type: System..::.Int32
The database generated application secondary id
currentUserId
Type: System..::.Int32
The unique id of the current user
currentGroupId
Type: System..::.Int32
The id of the current organization

Return Value

The dataview related to the proxied users

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetRandomPassword Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetRandomPassword Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a random password by matching a list of adjectives and nouns from the passwordCombination.xml file. Please refer to the OfficeClip level 1 customization help in order to customize the values of the randomly generated passwords.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetRandomPassword(
    OCResources ocr
)
Visual Basic (Declaration)
Public Function GetRandomPassword ( _
    ocr As OCResources _
) As String
Visual C++
public:
String^ GetRandomPassword(
    OCResources^ ocr
)

Parameters

ocr
Type: OfficeClip.Utils..::.OCResources
The OfficeClip Resource object.

Return Value

Randomly generated password string.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GetSavedCorpMenu Method

[image]

OfficeClip API Documentation
GeneralDB..::.GetSavedCorpMenu Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the menu definition chosen by the user which was stored in an xml file corresponding to a particular group.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MenuInfo GetSavedCorpMenu(
    int groupId
)
Visual Basic (Declaration)
Public Function GetSavedCorpMenu ( _
    groupId As Integer _
) As MenuInfo
Visual C++
public:
MenuInfo^ GetSavedCorpMenu(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group.

Return Value

Instance of a MenuInfo object containing of the menu definition.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
GeneralDB..::.InitTransaction Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

GeneralDB Class
GeneralDB Members
OfficeClip.DBLayer.Framework Namespace


InsertClassification Method

[image]

OfficeClip API Documentation
GeneralDB..::.InsertClassification Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new classification

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertClassification(
    int userId,
    string color,
    string name
)
Visual Basic (Declaration)
Public Function InsertClassification ( _
    userId As Integer, _
    color As String, _
    name As String _
) As Integer
Visual C++
public:
int InsertClassification(
    int userId,
    String^ color,
    String^ name
)

Parameters

userId
Type: System..::.Int32
color
Type: System..::.String
name
Type: System..::.String

Return Value

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


SaveCorpMenuFile Method

[image]

OfficeClip API Documentation
GeneralDB..::.SaveCorpMenuFile Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Saves a menu definition created by the user in the form of an xml document for a particular group.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SaveCorpMenuFile(
    int groupId,
    string xmlMenuStr
)
Visual Basic (Declaration)
Public Sub SaveCorpMenuFile ( _
    groupId As Integer, _
    xmlMenuStr As String _
)
Visual C++
public:
void SaveCorpMenuFile(
    int groupId,
    String^ xmlMenuStr
)

Parameters

groupId
Type: System..::.Int32
Id of a particular group corresponding to which the menu deinition needs to be saved.
xmlMenuStr
Type: System..::.String
The xml representation of the menu definition customized by the user.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


SaveQuickHelpProfile Method

[image]

OfficeClip API Documentation
GeneralDB..::.SaveQuickHelpProfile Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Saves the quick help profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SaveQuickHelpProfile(
    Page page,
    Constants..::.ToolbarType tt
)
Visual Basic (Declaration)
Public Sub SaveQuickHelpProfile ( _
    page As Page, _
    tt As Constants..::.ToolbarType _
)
Visual C++
public:
void SaveQuickHelpProfile(
    Page^ page,
    Constants..::.ToolbarType tt
)

Parameters

page
Type: System.Web.UI..::.Page
tt
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ToolbarType

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


SetCodeProtectorValue Method

[image]

OfficeClip API Documentation
GeneralDB..::.SetCodeProtectorValue Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the code protector value

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetCodeProtectorValue()
Visual Basic (Declaration)
Public Sub SetCodeProtectorValue
Visual C++
public:
void SetCodeProtectorValue()

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
GeneralDB..::.SetSPCommand Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

GeneralDB Class
GeneralDB Members
OfficeClip.DBLayer.Framework Namespace


UpdateClassification Method

[image]

OfficeClip API Documentation
GeneralDB..::.UpdateClassification Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates a classification

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateClassification(
    int labelId,
    string color,
    string name
)
Visual Basic (Declaration)
Public Function UpdateClassification ( _
    labelId As Integer, _
    color As String, _
    name As String _
) As Integer
Visual C++
public:
int UpdateClassification(
    int labelId,
    String^ color,
    String^ name
)

Parameters

labelId
Type: System..::.Int32
color
Type: System..::.String
name
Type: System..::.String

Return Value

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


UpdateProxyUsers Method

[image]

OfficeClip API Documentation
GeneralDB..::.UpdateProxyUsers Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the list of users who can be proxied an application or a particular operation within an application for the currently logged in user.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateProxyUsers(
    int ApplicationId,
    int ApplicationSecondaryId,
    string AddProxyUserListStr,
    string RemoveProxyUserListStr,
    int currentUserId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Sub UpdateProxyUsers ( _
    ApplicationId As Integer, _
    ApplicationSecondaryId As Integer, _
    AddProxyUserListStr As String, _
    RemoveProxyUserListStr As String, _
    currentUserId As Integer, _
    currentGroupId As Integer _
)
Visual C++
public:
void UpdateProxyUsers(
    int ApplicationId,
    int ApplicationSecondaryId,
    String^ AddProxyUserListStr,
    String^ RemoveProxyUserListStr,
    int currentUserId,
    int currentGroupId
)

Parameters

ApplicationId
Type: System..::.Int32
Id of the application which being proxied.
ApplicationSecondaryId
Type: System..::.Int32
Secondary Id of the application identifying the specific area within the application which is being delegated.
AddProxyUserListStr
Type: System..::.String
List of concatenated comma delimited Ids of the users who are being added as Proxy.
RemoveProxyUserListStr
Type: System..::.String
List of concatenated comma delimited Ids of the users who are being removed as being Proxy.
currentUserId
Type: System..::.Int32
The unique id of the current user
currentGroupId
Type: System..::.Int32
The id of the current organization

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


UploadCorpMenuFile Method

[image]

OfficeClip API Documentation
GeneralDB..::.UploadCorpMenuFile Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Uploads a file which can be used as a link to one of a particular group or organization Menus.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UploadCorpMenuFile(
    int groupId,
    HttpPostedFile pFile
)
Visual Basic (Declaration)
Public Function UploadCorpMenuFile ( _
    groupId As Integer, _
    pFile As HttpPostedFile _
) As Integer
Visual C++
public:
int UploadCorpMenuFile(
    int groupId,
    HttpPostedFile^ pFile
)

Parameters

groupId
Type: System..::.Int32
Id of a particular group.
pFile
Type: System.Web..::.HttpPostedFile
The posted (uploaded) file.

Return Value

0 if Successful 1 if Saving to server failed 2 if Client file not accessible 3 if Empty Posted File

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


ValidVersion Method

[image]

OfficeClip API Documentation
GeneralDB..::.ValidVersion Method
GeneralDB Class See Also

[This is preliminary documentation and is subject to change.]

Validate the Version between the database and the code. It is assumed that if the major Version number and the minor Version number does not match, then the versions are mismatched and the application cannot run properly.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool ValidVersion()
Visual Basic (Declaration)
Public Function ValidVersion As Boolean
Visual C++
public:
bool ValidVersion()

Return Value

True if the versions are valid,i.e. the code Version and the database Version are compatable, False if they are not.

See Also

GeneralDB Class
OfficeClip.DBLayer.Framework Namespace


GlobalDB Class

[image]

OfficeClip API Documentation
GlobalDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Global settings. Started with application initiation

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class GlobalDB : OfficeClipDB
Visual Basic (Declaration)
Public Class GlobalDB _
    Inherits OfficeClipDB
Visual C++
public ref class GlobalDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.GlobalDB

See Also

GlobalDB Members
OfficeClip.DBLayer.Framework Namespace


GlobalDB Members

[image] [image]

OfficeClip API Documentation
GlobalDB Members
GlobalDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The GlobalDB type exposes the following members.

Constructors

 | Name | Description
Public method | GlobalDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetHash | Gets the hash value
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetSysInfo | Gets the OfficeClip System Info
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetApplicationInfo | reads the application items from the xml file and saves them to a hashtable. It also sets the returned hashtable as an application variable.
Public method | SetCustomInfo | Sets the custom information.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

GlobalDB Class
OfficeClip.DBLayer.Framework Namespace


GlobalDB Constructor

[image]

OfficeClip API Documentation
GlobalDB Constructor
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GlobalDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GlobalDB()

See Also

GlobalDB Class
OfficeClip.DBLayer.Framework Namespace


GlobalDB Methods

[image] [image]

OfficeClip API Documentation
GlobalDB Methods
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

The GlobalDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetHash | Gets the hash value
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetSysInfo | Gets the OfficeClip System Info
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetApplicationInfo | reads the application items from the xml file and saves them to a hashtable. It also sets the returned hashtable as an application variable.
Public method | SetCustomInfo | Sets the custom information.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GlobalDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
GlobalDB..::.AddOutputParameter Method
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

GlobalDB Class
GlobalDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
GlobalDB..::.AddParameter Method
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

GlobalDB Class
GlobalDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
GlobalDB..::.AddParameters Method
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

GlobalDB Class
GlobalDB Members
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
GlobalDB..::.ExecuteNonQuery Method
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

GlobalDB Class
GlobalDB Members
OfficeClip.DBLayer.Framework Namespace


GetHash Method

[image]

OfficeClip API Documentation
GlobalDB..::.GetHash Method
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the hash value

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetHash(
    string str
)
Visual Basic (Declaration)
Protected Function GetHash ( _
    str As String _
) As String
Visual C++
protected:
String^ GetHash(
    String^ str
)

Parameters

str
Type: System..::.String

Return Value

See Also

GlobalDB Class
OfficeClip.DBLayer.Framework Namespace


GetSysInfo Method

[image]

OfficeClip API Documentation
GlobalDB..::.GetSysInfo Method
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the OfficeClip System Info

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCSysInfo GetSysInfo()
Visual Basic (Declaration)
Public Function GetSysInfo As OCSysInfo
Visual C++
public:
OCSysInfo^ GetSysInfo()

Return Value

Instance of the OCSysInfo object containing all the information related to the OfficeClip System Info. OfficeClip.BusinessLayer.Account..::.OCSysInfo

See Also

GlobalDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
GlobalDB..::.InitTransaction Method
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

GlobalDB Class
GlobalDB Members
OfficeClip.DBLayer.Framework Namespace


SetApplicationInfo Method

[image]

OfficeClip API Documentation
GlobalDB..::.SetApplicationInfo Method
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

reads the application items from the xml file and saves them to a hashtable. It also sets the returned hashtable as an application variable.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetApplicationInfo()
Visual Basic (Declaration)
Public Sub SetApplicationInfo
Visual C++
public:
void SetApplicationInfo()

Return Value

A hashtable with key and application info.

See Also

GlobalDB Class
OfficeClip.DBLayer.Framework Namespace


SetCustomInfo Method

[image]

OfficeClip API Documentation
GlobalDB..::.SetCustomInfo Method
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the custom information.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public Hashtable SetCustomInfo()
Visual Basic (Declaration)
Public Function SetCustomInfo As Hashtable
Visual C++
public:
Hashtable^ SetCustomInfo()

Return Value

Hashtable containing the custom values.

See Also

GlobalDB Class
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
GlobalDB..::.SetSPCommand Method
GlobalDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

GlobalDB Class
GlobalDB Members
OfficeClip.DBLayer.Framework Namespace


HolidaysDB Class

[image]

OfficeClip API Documentation
HolidaysDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class HolidaysDB : OfficeClipDB
Visual Basic (Declaration)
Public Class HolidaysDB _
    Inherits OfficeClipDB
Visual C++
public ref class HolidaysDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.HolidaysDB

See Also

HolidaysDB Members
OfficeClip.DBLayer.Framework Namespace


HolidaysDB Members

[image] [image]

OfficeClip API Documentation
HolidaysDB Members
HolidaysDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The HolidaysDB type exposes the following members.

Constructors

 | Name | Description
Public method | HolidaysDB | Constructor

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteHolidayWithId | Deletes an existing holiday with the given holidayId
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetHolidayDefaultCountryId | Returns the Default countryId for the Given accountId
Public method | GetHolidayFromId | Returns the details of the holiday for the given holidayId
Public method | GetHolidayListForAccountId | Returns list of holidays for the given accountId and countryId
Public method | GetHolidays | Returns the list of holidays for the given period
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertNewHoliday | Inserts a new holiday for the given accountId
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHolidayWithId | Updates an existing holiday with the given holidayId

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

HolidaysDB Class
OfficeClip.DBLayer.Framework Namespace


HolidaysDB Constructor

[image]

OfficeClip API Documentation
HolidaysDB Constructor
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public HolidaysDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HolidaysDB()

See Also

HolidaysDB Class
OfficeClip.DBLayer.Framework Namespace


HolidaysDB Methods

[image] [image]

OfficeClip API Documentation
HolidaysDB Methods
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

The HolidaysDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteHolidayWithId | Deletes an existing holiday with the given holidayId
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetHolidayDefaultCountryId | Returns the Default countryId for the Given accountId
Public method | GetHolidayFromId | Returns the details of the holiday for the given holidayId
Public method | GetHolidayListForAccountId | Returns list of holidays for the given accountId and countryId
Public method | GetHolidays | Returns the list of holidays for the given period
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertNewHoliday | Inserts a new holiday for the given accountId
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateHolidayWithId | Updates an existing holiday with the given holidayId

See Also

HolidaysDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
HolidaysDB..::.AddOutputParameter Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

HolidaysDB Class
HolidaysDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
HolidaysDB..::.AddParameter Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

HolidaysDB Class
HolidaysDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
HolidaysDB..::.AddParameters Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

HolidaysDB Class
HolidaysDB Members
OfficeClip.DBLayer.Framework Namespace


DeleteHolidayWithId Method

[image]

OfficeClip API Documentation
HolidaysDB..::.DeleteHolidayWithId Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes an existing holiday with the given holidayId

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteHolidayWithId(
    int accountId,
    int holidayId
)
Visual Basic (Declaration)
Public Sub DeleteHolidayWithId ( _
    accountId As Integer, _
    holidayId As Integer _
)
Visual C++
public:
void DeleteHolidayWithId(
    int accountId,
    int holidayId
)

Parameters

accountId
Type: System..::.Int32
accountId
holidayId
Type: System..::.Int32
holidayId

See Also

HolidaysDB Class
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
HolidaysDB..::.ExecuteNonQuery Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

HolidaysDB Class
HolidaysDB Members
OfficeClip.DBLayer.Framework Namespace


GetHolidayDefaultCountryId Method

[image]

OfficeClip API Documentation
HolidaysDB..::.GetHolidayDefaultCountryId Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the Default countryId for the Given accountId

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetHolidayDefaultCountryId(
    int accountId
)
Visual Basic (Declaration)
Public Function GetHolidayDefaultCountryId ( _
    accountId As Integer _
) As Integer
Visual C++
public:
int GetHolidayDefaultCountryId(
    int accountId
)

Parameters

accountId
Type: System..::.Int32
accountId

Return Value

See Also

HolidaysDB Class
OfficeClip.DBLayer.Framework Namespace


GetHolidayFromId Method

[image]

OfficeClip API Documentation
HolidaysDB..::.GetHolidayFromId Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the details of the holiday for the given holidayId

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetHolidayFromId(
    int holidayId
)
Visual Basic (Declaration)
Public Function GetHolidayFromId ( _
    holidayId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetHolidayFromId(
    int holidayId
)

Parameters

holidayId
Type: System..::.Int32
holidayId

Return Value

See Also

HolidaysDB Class
OfficeClip.DBLayer.Framework Namespace


GetHolidayListForAccountId Method

[image]

OfficeClip API Documentation
HolidaysDB..::.GetHolidayListForAccountId Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns list of holidays for the given accountId and countryId

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetHolidayListForAccountId(
    int accountId,
    int year,
    int countryId
)
Visual Basic (Declaration)
Public Function GetHolidayListForAccountId ( _
    accountId As Integer, _
    year As Integer, _
    countryId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetHolidayListForAccountId(
    int accountId,
    int year,
    int countryId
)

Parameters

accountId
Type: System..::.Int32
accountId
year
Type: System..::.Int32
year
countryId
Type: System..::.Int32
countryId

Return Value

See Also

HolidaysDB Class
OfficeClip.DBLayer.Framework Namespace


GetHolidays Method

[image]

OfficeClip API Documentation
HolidaysDB..::.GetHolidays Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the list of holidays for the given period

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetHolidays(
    int accId,
    DateTime fromDate,
    DateTime toDate
)
Visual Basic (Declaration)
Public Function GetHolidays ( _
    accId As Integer, _
    fromDate As DateTime, _
    toDate As DateTime _
) As DataSet
Visual C++
public:
DataSet^ GetHolidays(
    int accId,
    DateTime fromDate,
    DateTime toDate
)

Parameters

accId
Type: System..::.Int32
accountId
fromDate
Type: System..::.DateTime
from date
toDate
Type: System..::.DateTime
to date

Return Value

See Also

HolidaysDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
HolidaysDB..::.InitTransaction Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

HolidaysDB Class
HolidaysDB Members
OfficeClip.DBLayer.Framework Namespace


InsertNewHoliday Method

[image]

OfficeClip API Documentation
HolidaysDB..::.InsertNewHoliday Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new holiday for the given accountId

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertNewHoliday(
    int accountId,
    DateTime date,
    string name,
    string iconPath
)
Visual Basic (Declaration)
Public Sub InsertNewHoliday ( _
    accountId As Integer, _
    date As DateTime, _
    name As String, _
    iconPath As String _
)
Visual C++
public:
void InsertNewHoliday(
    int accountId,
    DateTime date,
    String^ name,
    String^ iconPath
)

Parameters

accountId
Type: System..::.Int32
accountId
date
Type: System..::.DateTime
date of holiday
name
Type: System..::.String
holiday name
iconPath
Type: System..::.String
holiday icon path

See Also

HolidaysDB Class
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
HolidaysDB..::.SetSPCommand Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

HolidaysDB Class
HolidaysDB Members
OfficeClip.DBLayer.Framework Namespace


UpdateHolidayWithId Method

[image]

OfficeClip API Documentation
HolidaysDB..::.UpdateHolidayWithId Method
HolidaysDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates an existing holiday with the given holidayId

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateHolidayWithId(
    int holidayId,
    DateTime date,
    string name,
    string iconPath
)
Visual Basic (Declaration)
Public Sub UpdateHolidayWithId ( _
    holidayId As Integer, _
    date As DateTime, _
    name As String, _
    iconPath As String _
)
Visual C++
public:
void UpdateHolidayWithId(
    int holidayId,
    DateTime date,
    String^ name,
    String^ iconPath
)

Parameters

holidayId
Type: System..::.Int32
holidayId
date
Type: System..::.DateTime
date of holiday
name
Type: System..::.String
holiday Name
iconPath
Type: System..::.String
holiday icon Path

See Also

HolidaysDB Class
OfficeClip.DBLayer.Framework Namespace


OCEmail Class

[image]

OfficeClip API Documentation
OCEmail Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of all the email related functions.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class OCEmail
Visual Basic (Declaration)
Public Class OCEmail
Visual C++
public ref class OCEmail

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Framework..::.OCEmail

See Also

OCEmail Members
OfficeClip.DBLayer.Framework Namespace


OCEmail Members

[image] [image]

OfficeClip API Documentation
OCEmail Members
OCEmail Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCEmail type exposes the following members.

Constructors

 | Name | Description
Public method | OCEmail |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSmtpFromAccountId |
 | GetSmtpFromConfig |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SendEMailToGroup | Sends the Email to all members of the Current group
 | SendMail | Overloaded.
 | SystemTestEmail | Tests the system email feature
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCEmail Class
OfficeClip.DBLayer.Framework Namespace


OCEmail Constructor

[image]

OfficeClip API Documentation
OCEmail Constructor
OCEmail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCEmail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCEmail()

See Also

OCEmail Class
OfficeClip.DBLayer.Framework Namespace


OCEmail Methods

[image] [image]

OfficeClip API Documentation
OCEmail Methods
OCEmail Class See Also

[This is preliminary documentation and is subject to change.]

The OCEmail type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSmtpFromAccountId |
 | GetSmtpFromConfig |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SendEMailToGroup | Sends the Email to all members of the Current group
 | SendMail | Overloaded.
 | SystemTestEmail | Tests the system email feature
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCEmail Class
OfficeClip.DBLayer.Framework Namespace


GetSmtpFromAccountId Method

[image]

OfficeClip API Documentation
OCEmail..::.GetSmtpFromAccountId Method
OCEmail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static OCSmtp GetSmtpFromAccountId(
    int EmailAccountId
)
Visual Basic (Declaration)
Public Shared Function GetSmtpFromAccountId ( _
    EmailAccountId As Integer _
) As OCSmtp
Visual C++
public:
static OCSmtp^ GetSmtpFromAccountId(
    int EmailAccountId
)

Parameters

EmailAccountId
Type: System..::.Int32

Return Value

See Also

OCEmail Class
OfficeClip.DBLayer.Framework Namespace


GetSmtpFromConfig Method

[image]

OfficeClip API Documentation
OCEmail..::.GetSmtpFromConfig Method
OCEmail Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static OCSmtp GetSmtpFromConfig()
Visual Basic (Declaration)
Public Shared Function GetSmtpFromConfig As OCSmtp
Visual C++
public:
static OCSmtp^ GetSmtpFromConfig()

Return Value

See Also

OCEmail Class
OfficeClip.DBLayer.Framework Namespace


SendEMailToGroup Method

[image]

OfficeClip API Documentation
OCEmail..::.SendEMailToGroup Method
OCEmail Class See Also

[This is preliminary documentation and is subject to change.]

Sends the Email to all members of the Current group

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static void SendEMailToGroup(
    string emailAddress,
    string templateFile,
    Hashtable values,
    int currentGroupId
)
Visual Basic (Declaration)
Public Shared Sub SendEMailToGroup ( _
    emailAddress As String, _
    templateFile As String, _
    values As Hashtable, _
    currentGroupId As Integer _
)
Visual C++
public:
static void SendEMailToGroup(
    String^ emailAddress,
    String^ templateFile,
    Hashtable^ values,
    int currentGroupId
)

Parameters

emailAddress
Type: System..::.String
The email Address of the user who sends the email.
templateFile
Type: System..::.String
The email template file name
values
Type: System.Collections..::.Hashtable
The hash table values of template variables
currentGroupId
Type: System..::.Int32
Id of the current group

See Also

OCEmail Class
OfficeClip.DBLayer.Framework Namespace


SendMail Method

[image] [image]

OfficeClip API Documentation
OCEmail..::.SendMail Method
OCEmail Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
SendMail(OCMailMessage) | The basic sendMail call
SendMail(String, String, String, String, String, Hashtable, String, ArrayList) | The generalized form of send message utility which accepts the template file for email template, the mail priority and the attachment.
SendMail(String, String, String, String, String, String, String, ArrayList) | Sends an email...

See Also

OCEmail Class
OCEmail Members
OfficeClip.DBLayer.Framework Namespace


SendMail Method ()

[image]

OfficeClip API Documentation
OCEmail..::.SendMail Method ()
OCEmail Class See Also

[This is preliminary documentation and is subject to change.]

The basic sendMail call

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static bool SendMail(
    OCMailMessage message
)
Visual Basic (Declaration)
Public Shared Function SendMail ( _
    message As OCMailMessage _
) As Boolean
Visual C++
public:
static bool SendMail(
    OCMailMessage^ message
)

Parameters

message
Type: OCMailMessage
The OfficeClip email message structure

Return Value

true if the mail could be sent false otherwise

See Also

OCEmail Class
SendMail Overload
OfficeClip.DBLayer.Framework Namespace


SendMail Method (String, String, String, String, String, Hashtable, String, ArrayList)

[image]

OfficeClip API Documentation
OCEmail..::.SendMail Method (String, String, String, String, String, Hashtable, String, ArrayList)
OCEmail Class See Also

[This is preliminary documentation and is subject to change.]

The generalized form of send message utility which accepts the template file for email template, the mail priority and the attachment.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static bool SendMail(
    string fromName,
    string fromAddress,
    string toName,
    string toAddress,
    string templateFile,
    Hashtable values,
    string mailPriority,
    ArrayList attachments
)
Visual Basic (Declaration)
Public Shared Function SendMail ( _
    fromName As String, _
    fromAddress As String, _
    toName As String, _
    toAddress As String, _
    templateFile As String, _
    values As Hashtable, _
    mailPriority As String, _
    attachments As ArrayList _
) As Boolean
Visual C++
public:
static bool SendMail(
    String^ fromName,
    String^ fromAddress,
    String^ toName,
    String^ toAddress,
    String^ templateFile,
    Hashtable^ values,
    String^ mailPriority,
    ArrayList^ attachments
)

Parameters

fromName
Type: System..::.String
fromAddress
Type: System..::.String
toName
Type: System..::.String
toAddress
Type: System..::.String
templateFile
Type: System..::.String
The template file which determines the template of the message.
values
Type: System.Collections..::.Hashtable
The values of the variables in the template.
mailPriority
Type: System..::.String
attachments
Type: System.Collections..::.ArrayList
An arraylist of strings of physical Address of the files to be sent as attachments with the email.

Return Value

See Also

OCEmail Class
SendMail Overload
OfficeClip.DBLayer.Framework Namespace


SendMail Method (String, String, String, String, String, String, String, ArrayList)

[image]

OfficeClip API Documentation
OCEmail..::.SendMail Method (String, String, String, String, String, String, String, ArrayList)
OCEmail Class See Also

[This is preliminary documentation and is subject to change.]

Sends an email...

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static bool SendMail(
    string fromName,
    string fromEmailAddress,
    string toName,
    string toEmailAddress,
    string title,
    string body,
    string mailPriority,
    ArrayList attachments
)
Visual Basic (Declaration)
Public Shared Function SendMail ( _
    fromName As String, _
    fromEmailAddress As String, _
    toName As String, _
    toEmailAddress As String, _
    title As String, _
    body As String, _
    mailPriority As String, _
    attachments As ArrayList _
) As Boolean
Visual C++
public:
static bool SendMail(
    String^ fromName,
    String^ fromEmailAddress,
    String^ toName,
    String^ toEmailAddress,
    String^ title,
    String^ body,
    String^ mailPriority,
    ArrayList^ attachments
)

Parameters

fromName
Type: System..::.String
fromEmailAddress
Type: System..::.String
toName
Type: System..::.String
toEmailAddress
Type: System..::.String
title
Type: System..::.String
body
Type: System..::.String
mailPriority
Type: System..::.String
attachments
Type: System.Collections..::.ArrayList

Return Value

See Also

OCEmail Class
SendMail Overload
OfficeClip.DBLayer.Framework Namespace


SystemTestEmail Method

[image]

OfficeClip API Documentation
OCEmail..::.SystemTestEmail Method
OCEmail Class See Also

[This is preliminary documentation and is subject to change.]

Tests the system email feature

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static bool SystemTestEmail(
    string from,
    string to,
    string subject,
    string body
)
Visual Basic (Declaration)
Public Shared Function SystemTestEmail ( _
    from As String, _
    to As String, _
    subject As String, _
    body As String _
) As Boolean
Visual C++
public:
static bool SystemTestEmail(
    String^ from,
    String^ to,
    String^ subject,
    String^ body
)

Parameters

from
Type: System..::.String
The from email address
to
Type: System..::.String
The to email address
subject
Type: System..::.String
body
Type: System..::.String

Return Value

true if successful, false otherwise

See Also

OCEmail Class
OfficeClip.DBLayer.Framework Namespace


OCSmsDB Class

[image]

OfficeClip API Documentation
OCSmsDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of all the SMS related functions.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class OCSmsDB : OfficeClipDB
Visual Basic (Declaration)
Public Class OCSmsDB _
    Inherits OfficeClipDB
Visual C++
public ref class OCSmsDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.OCSmsDB

See Also

OCSmsDB Members
OfficeClip.DBLayer.Framework Namespace


OCSmsDB Members

[image] [image]

OfficeClip API Documentation
OCSmsDB Members
OCSmsDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCSmsDB type exposes the following members.

Constructors

 | Name | Description
Public method | OCSmsDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
 | CreateVerificationCode | Creates a Unique SMS Device Verification Code.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MobileVerifiedState | Gives the SMS Device Verification Status.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
 | SendShortMessage | Sends SMS to the Mobile/SMS device using the SMS Email ID or ClickATell SMS system.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

OCSmsDB Class
OfficeClip.DBLayer.Framework Namespace


OCSmsDB Constructor

[image]

OfficeClip API Documentation
OCSmsDB Constructor
OCSmsDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCSmsDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCSmsDB()

See Also

OCSmsDB Class
OfficeClip.DBLayer.Framework Namespace


OCSmsDB Methods

[image] [image]

OfficeClip API Documentation
OCSmsDB Methods
OCSmsDB Class See Also

[This is preliminary documentation and is subject to change.]

The OCSmsDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
 | CreateVerificationCode | Creates a Unique SMS Device Verification Code.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MobileVerifiedState | Gives the SMS Device Verification Status.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
 | SendShortMessage | Sends SMS to the Mobile/SMS device using the SMS Email ID or ClickATell SMS system.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCSmsDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
OCSmsDB..::.AddOutputParameter Method
OCSmsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

OCSmsDB Class
OCSmsDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
OCSmsDB..::.AddParameter Method
OCSmsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

OCSmsDB Class
OCSmsDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
OCSmsDB..::.AddParameters Method
OCSmsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

OCSmsDB Class
OCSmsDB Members
OfficeClip.DBLayer.Framework Namespace


CreateVerificationCode Method

[image]

OfficeClip API Documentation
OCSmsDB..::.CreateVerificationCode Method
OCSmsDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates a Unique SMS Device Verification Code.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static string CreateVerificationCode()
Visual Basic (Declaration)
Public Shared Function CreateVerificationCode As String
Visual C++
public:
static String^ CreateVerificationCode()

Return Value

SMS Device Verification Code as String.

See Also

OCSmsDB Class
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
OCSmsDB..::.ExecuteNonQuery Method
OCSmsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

OCSmsDB Class
OCSmsDB Members
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
OCSmsDB..::.InitTransaction Method
OCSmsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

OCSmsDB Class
OCSmsDB Members
OfficeClip.DBLayer.Framework Namespace


MobileVerifiedState Method

[image]

OfficeClip API Documentation
OCSmsDB..::.MobileVerifiedState Method
OCSmsDB Class See Also

[This is preliminary documentation and is subject to change.]

Gives the SMS Device Verification Status.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static SmsInfoVerifiedState MobileVerifiedState(
    int uid,
    out SmsInfo ui
)
Visual Basic (Declaration)
Public Shared Function MobileVerifiedState ( _
    uid As Integer, _
    <OutAttribute> ByRef ui As SmsInfo _
) As SmsInfoVerifiedState
Visual C++
public:
static SmsInfoVerifiedState MobileVerifiedState(
    int uid,
    [OutAttribute] SmsInfo^% ui
)

Parameters

uid
Type: System..::.Int32
the User id of the Member for whom the SMS Satus is to be verified.
ui
Type: OfficeClip.BusinessLayer.Account..::.SmsInfo %
SmsInfo object. This is an out parameter, which is filled and given back.

Return Value

See Also

OCSmsDB Class
OfficeClip.DBLayer.Framework Namespace


SendShortMessage Method

[image]

OfficeClip API Documentation
OCSmsDB..::.SendShortMessage Method
OCSmsDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends SMS to the Mobile/SMS device using the SMS Email ID or ClickATell SMS system.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static bool SendShortMessage(
    SmsInfo ui,
    string fromEmailAddress,
    string msg
)
Visual Basic (Declaration)
Public Shared Function SendShortMessage ( _
    ui As SmsInfo, _
    fromEmailAddress As String, _
    msg As String _
) As Boolean
Visual C++
public:
static bool SendShortMessage(
    SmsInfo^ ui,
    String^ fromEmailAddress,
    String^ msg
)

Parameters

ui
Type: OfficeClip.BusinessLayer.Account..::.SmsInfo
The SmsInfo Object
fromEmailAddress
Type: System..::.String
msg
Type: System..::.String
The Message to be sent

Return Value

true if message is sent sucessfully else false.

See Also

OCSmsDB Class
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
OCSmsDB..::.SetSPCommand Method
OCSmsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

OCSmsDB Class
OCSmsDB Members
OfficeClip.DBLayer.Framework Namespace


ProfileDB Class

[image]

OfficeClip API Documentation
ProfileDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Profile subsystem related functions.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class ProfileDB : OfficeClipDB
Visual Basic (Declaration)
Public Class ProfileDB _
    Inherits OfficeClipDB
Visual C++
public ref class ProfileDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.ProfileDB

See Also

ProfileDB Members
OfficeClip.DBLayer.Framework Namespace


ProfileDB Members

[image] [image]

OfficeClip API Documentation
ProfileDB Members
ProfileDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ProfileDB type exposes the following members.

Constructors

 | Name | Description
Public method | ProfileDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteProfile | Deletes all the profile values for the organization and for the user, a value of -1 does not remove the profile.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllUserProfiles | Gets all the user profiles
Public method | GetBulletinBoardUserProfile | Gets the bulletin board user profile
Public method | GetCalendarGroupProfile | Gets the group profile for the calendar
Public method | GetCalendarUserProfile | Gets the user profile for the calendar
Public method | GetDocumentUserProfile | Gets the document user profile
Public method | GetExpenseGroupProfile | Gets the group profile for the expense reports
Public method | GetExpenseUserProfile | Gets the expense user profile
Public method | GetGeneralUserProfile | Gets the general user profile
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLoginSession | Gets the login session
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Protected method | GetProfileString | Gets the profile string
Protected method | GetProfileStringFromContext | Gets the profile string from context
Public method | GetPunchClockGroupProfile | Gets the group profile for the punch clock
Public method | GetPunchClockUserProfile | Gets the punch clock user profile
Public method | GetTimesheetGroupProfile | Gets the group profile for the timesheet
Public method | GetTimesheetUserProfile | Gets the timesheet user profile
Public method | GetTrackerUserProfile | Gets the tracker user profile
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetBulletinBoardUserProfile | Sets the bulletin board user profile
Public method | SetCalendarGroupProfile | Sets the group profile for the calendar
Public method | SetCalendarUserProfile | sets the user profile for the calendar
Public method | SetDocumentUserProfile | Sets the document user profile
Public method | SetExpenseGroupProfile | Sets the group profile for the expense reports
Public method | SetExpenseUserProfile | Sets the expense user profile
Public method | SetGeneralUserProfile | Sets the general user profile
Public method | SetLastVisitedApplicationId |
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetProfile | Sets the profile string
Protected method | SetProfileStringToContext | Sets the profile string from context
Public method | SetPunchClockGroupProfile | Sets the group profile for the punch clock
Public method | SetPunchClockUserProfile | Sets the punch clock user profile
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetTimesheetGroupProfile | Sets the group profile for the timesheet
Public method | SetTimesheetUserProfile | Sets the timesheet user profile
Public method | SetTrackerUserProfile | Sets the tracker user profile
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


ProfileDB Constructor

[image]

OfficeClip API Documentation
ProfileDB Constructor
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ProfileDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProfileDB()

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


ProfileDB Methods

[image] [image]

OfficeClip API Documentation
ProfileDB Methods
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

The ProfileDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteProfile | Deletes all the profile values for the organization and for the user, a value of -1 does not remove the profile.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllUserProfiles | Gets all the user profiles
Public method | GetBulletinBoardUserProfile | Gets the bulletin board user profile
Public method | GetCalendarGroupProfile | Gets the group profile for the calendar
Public method | GetCalendarUserProfile | Gets the user profile for the calendar
Public method | GetDocumentUserProfile | Gets the document user profile
Public method | GetExpenseGroupProfile | Gets the group profile for the expense reports
Public method | GetExpenseUserProfile | Gets the expense user profile
Public method | GetGeneralUserProfile | Gets the general user profile
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLoginSession | Gets the login session
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Protected method | GetProfileString | Gets the profile string
Protected method | GetProfileStringFromContext | Gets the profile string from context
Public method | GetPunchClockGroupProfile | Gets the group profile for the punch clock
Public method | GetPunchClockUserProfile | Gets the punch clock user profile
Public method | GetTimesheetGroupProfile | Gets the group profile for the timesheet
Public method | GetTimesheetUserProfile | Gets the timesheet user profile
Public method | GetTrackerUserProfile | Gets the tracker user profile
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetBulletinBoardUserProfile | Sets the bulletin board user profile
Public method | SetCalendarGroupProfile | Sets the group profile for the calendar
Public method | SetCalendarUserProfile | sets the user profile for the calendar
Public method | SetDocumentUserProfile | Sets the document user profile
Public method | SetExpenseGroupProfile | Sets the group profile for the expense reports
Public method | SetExpenseUserProfile | Sets the expense user profile
Public method | SetGeneralUserProfile | Sets the general user profile
Public method | SetLastVisitedApplicationId |
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetProfile | Sets the profile string
Protected method | SetProfileStringToContext | Sets the profile string from context
Public method | SetPunchClockGroupProfile | Sets the group profile for the punch clock
Public method | SetPunchClockUserProfile | Sets the punch clock user profile
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetTimesheetGroupProfile | Sets the group profile for the timesheet
Public method | SetTimesheetUserProfile | Sets the timesheet user profile
Public method | SetTrackerUserProfile | Sets the tracker user profile
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
ProfileDB..::.AddOutputParameter Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

ProfileDB Class
ProfileDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
ProfileDB..::.AddParameter Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

ProfileDB Class
ProfileDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
ProfileDB..::.AddParameters Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

ProfileDB Class
ProfileDB Members
OfficeClip.DBLayer.Framework Namespace


DeleteProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.DeleteProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all the profile values for the organization and for the user, a value of -1 does not remove the profile.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteProfile(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Sub DeleteProfile ( _
    userId As Integer, _
    groupId As Integer _
)
Visual C++
public:
void DeleteProfile(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the organization

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
ProfileDB..::.ExecuteNonQuery Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

ProfileDB Class
ProfileDB Members
OfficeClip.DBLayer.Framework Namespace


GetAllUserProfiles Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetAllUserProfiles Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the user profiles

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetAllUserProfiles(
    int userId,
    int groupId,
    ref BulletinBoardUserProfile bbProf,
    ref CalendarUserProfile calProf,
    ref DocumentUserProfile docProf,
    ref ExpenseUserProfile expProf,
    ref TimesheetUserProfile timeProf,
    ref TrackerUserProfile trkProf,
    ref PunchClockUserProfile pcProf
)
Visual Basic (Declaration)
Public Sub GetAllUserProfiles ( _
    userId As Integer, _
    groupId As Integer, _
    ByRef bbProf As BulletinBoardUserProfile, _
    ByRef calProf As CalendarUserProfile, _
    ByRef docProf As DocumentUserProfile, _
    ByRef expProf As ExpenseUserProfile, _
    ByRef timeProf As TimesheetUserProfile, _
    ByRef trkProf As TrackerUserProfile, _
    ByRef pcProf As PunchClockUserProfile _
)
Visual C++
public:
void GetAllUserProfiles(
    int userId,
    int groupId,
    BulletinBoardUserProfile^% bbProf,
    CalendarUserProfile^% calProf,
    DocumentUserProfile^% docProf,
    ExpenseUserProfile^% expProf,
    TimesheetUserProfile^% timeProf,
    TrackerUserProfile^% trkProf,
    PunchClockUserProfile^% pcProf
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
bbProf
Type: OfficeClip.BusinessLayer.Framework.Profile..::.BulletinBoardUserProfile %
calProf
Type: OfficeClip.BusinessLayer.Framework.Profile..::.CalendarUserProfile %
docProf
Type: OfficeClip.BusinessLayer.Framework.Profile..::.DocumentUserProfile %
expProf
Type: OfficeClip.BusinessLayer.Framework.Profile..::.ExpenseUserProfile %
timeProf
Type: OfficeClip.BusinessLayer.Framework.Profile..::.TimesheetUserProfile %
trkProf
Type: OfficeClip.BusinessLayer.Framework.Profile..::.TrackerUserProfile %
pcProf
Type: OfficeClip.BusinessLayer.Framework.Profile..::.PunchClockUserProfile %

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetBulletinBoardUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetBulletinBoardUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the bulletin board user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public BulletinBoardUserProfile GetBulletinBoardUserProfile(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetBulletinBoardUserProfile ( _
    userId As Integer, _
    groupId As Integer _
) As BulletinBoardUserProfile
Visual C++
public:
BulletinBoardUserProfile^ GetBulletinBoardUserProfile(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetCalendarGroupProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetCalendarGroupProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the group profile for the calendar

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public CalendarGroupProfile GetCalendarGroupProfile(
    int groupId
)
Visual Basic (Declaration)
Public Function GetCalendarGroupProfile ( _
    groupId As Integer _
) As CalendarGroupProfile
Visual C++
public:
CalendarGroupProfile^ GetCalendarGroupProfile(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetCalendarUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetCalendarUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the user profile for the calendar

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public CalendarUserProfile GetCalendarUserProfile(
    int userId
)
Visual Basic (Declaration)
Public Function GetCalendarUserProfile ( _
    userId As Integer _
) As CalendarUserProfile
Visual C++
public:
CalendarUserProfile^ GetCalendarUserProfile(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetDocumentUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetDocumentUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the document user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentUserProfile GetDocumentUserProfile(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetDocumentUserProfile ( _
    userId As Integer, _
    groupId As Integer _
) As DocumentUserProfile
Visual C++
public:
DocumentUserProfile^ GetDocumentUserProfile(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetExpenseGroupProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetExpenseGroupProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the group profile for the expense reports

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseGroupProfile GetExpenseGroupProfile(
    int groupId
)
Visual Basic (Declaration)
Public Function GetExpenseGroupProfile ( _
    groupId As Integer _
) As ExpenseGroupProfile
Visual C++
public:
ExpenseGroupProfile^ GetExpenseGroupProfile(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetExpenseUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetExpenseUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the expense user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseUserProfile GetExpenseUserProfile(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetExpenseUserProfile ( _
    userId As Integer, _
    groupId As Integer _
) As ExpenseUserProfile
Visual C++
public:
ExpenseUserProfile^ GetExpenseUserProfile(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetGeneralUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetGeneralUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the general user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GeneralUserProfile GetGeneralUserProfile(
    int userId
)
Visual Basic (Declaration)
Public Function GetGeneralUserProfile ( _
    userId As Integer _
) As GeneralUserProfile
Visual C++
public:
GeneralUserProfile^ GetGeneralUserProfile(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetLoginSession Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetLoginSession Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the login session

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ConfigureInfo GetLoginSession(
    int userId
)
Visual Basic (Declaration)
Public Function GetLoginSession ( _
    userId As Integer _
) As ConfigureInfo
Visual C++
public:
ConfigureInfo^ GetLoginSession(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetProfileString Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetProfileString Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the profile string

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetProfileString(
    int userId,
    int groupId,
    Constants..::.ApplicationType aType
)
Visual Basic (Declaration)
Protected Function GetProfileString ( _
    userId As Integer, _
    groupId As Integer, _
    aType As Constants..::.ApplicationType _
) As String
Visual C++
protected:
String^ GetProfileString(
    int userId,
    int groupId,
    Constants..::.ApplicationType aType
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
aType
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetProfileStringFromContext Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetProfileStringFromContext Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the profile string from context

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetProfileStringFromContext(
    int userId,
    int groupId,
    Constants..::.ApplicationType aType
)
Visual Basic (Declaration)
Protected Function GetProfileStringFromContext ( _
    userId As Integer, _
    groupId As Integer, _
    aType As Constants..::.ApplicationType _
) As String
Visual C++
protected:
String^ GetProfileStringFromContext(
    int userId,
    int groupId,
    Constants..::.ApplicationType aType
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
aType
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetPunchClockGroupProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetPunchClockGroupProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the group profile for the punch clock

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PunchClockGroupProfile GetPunchClockGroupProfile(
    int groupId
)
Visual Basic (Declaration)
Public Function GetPunchClockGroupProfile ( _
    groupId As Integer _
) As PunchClockGroupProfile
Visual C++
public:
PunchClockGroupProfile^ GetPunchClockGroupProfile(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetPunchClockUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetPunchClockUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the punch clock user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseUserProfile GetPunchClockUserProfile(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetPunchClockUserProfile ( _
    userId As Integer, _
    groupId As Integer _
) As ExpenseUserProfile
Visual C++
public:
ExpenseUserProfile^ GetPunchClockUserProfile(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetTimesheetGroupProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetTimesheetGroupProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the group profile for the timesheet

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetGroupProfile GetTimesheetGroupProfile(
    int groupId
)
Visual Basic (Declaration)
Public Function GetTimesheetGroupProfile ( _
    groupId As Integer _
) As TimesheetGroupProfile
Visual C++
public:
TimesheetGroupProfile^ GetTimesheetGroupProfile(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetTimesheetUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetTimesheetUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the timesheet user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetUserProfile GetTimesheetUserProfile(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetTimesheetUserProfile ( _
    userId As Integer, _
    groupId As Integer _
) As TimesheetUserProfile
Visual C++
public:
TimesheetUserProfile^ GetTimesheetUserProfile(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


GetTrackerUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.GetTrackerUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tracker user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerUserProfile GetTrackerUserProfile(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetTrackerUserProfile ( _
    userId As Integer, _
    groupId As Integer _
) As TrackerUserProfile
Visual C++
public:
TrackerUserProfile^ GetTrackerUserProfile(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
ProfileDB..::.InitTransaction Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

ProfileDB Class
ProfileDB Members
OfficeClip.DBLayer.Framework Namespace


SetBulletinBoardUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetBulletinBoardUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the bulletin board user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetBulletinBoardUserProfile(
    int userId,
    int groupId,
    BulletinBoardUserProfile tp
)
Visual Basic (Declaration)
Public Function SetBulletinBoardUserProfile ( _
    userId As Integer, _
    groupId As Integer, _
    tp As BulletinBoardUserProfile _
) As Integer
Visual C++
public:
int SetBulletinBoardUserProfile(
    int userId,
    int groupId,
    BulletinBoardUserProfile^ tp
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.BulletinBoardUserProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetCalendarGroupProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetCalendarGroupProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the group profile for the calendar

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetCalendarGroupProfile(
    int groupId,
    CalendarGroupProfile cp
)
Visual Basic (Declaration)
Public Function SetCalendarGroupProfile ( _
    groupId As Integer, _
    cp As CalendarGroupProfile _
) As Integer
Visual C++
public:
int SetCalendarGroupProfile(
    int groupId,
    CalendarGroupProfile^ cp
)

Parameters

groupId
Type: System..::.Int32
cp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.CalendarGroupProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetCalendarUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetCalendarUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

sets the user profile for the calendar

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetCalendarUserProfile(
    int userId,
    CalendarUserProfile tp
)
Visual Basic (Declaration)
Public Function SetCalendarUserProfile ( _
    userId As Integer, _
    tp As CalendarUserProfile _
) As Integer
Visual C++
public:
int SetCalendarUserProfile(
    int userId,
    CalendarUserProfile^ tp
)

Parameters

userId
Type: System..::.Int32
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.CalendarUserProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetDocumentUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetDocumentUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the document user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetDocumentUserProfile(
    int userId,
    int groupId,
    DocumentUserProfile tp
)
Visual Basic (Declaration)
Public Function SetDocumentUserProfile ( _
    userId As Integer, _
    groupId As Integer, _
    tp As DocumentUserProfile _
) As Integer
Visual C++
public:
int SetDocumentUserProfile(
    int userId,
    int groupId,
    DocumentUserProfile^ tp
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.DocumentUserProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetExpenseGroupProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetExpenseGroupProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the group profile for the expense reports

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetExpenseGroupProfile(
    int groupId,
    ExpenseGroupProfile tp
)
Visual Basic (Declaration)
Public Function SetExpenseGroupProfile ( _
    groupId As Integer, _
    tp As ExpenseGroupProfile _
) As Integer
Visual C++
public:
int SetExpenseGroupProfile(
    int groupId,
    ExpenseGroupProfile^ tp
)

Parameters

groupId
Type: System..::.Int32
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.ExpenseGroupProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetExpenseUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetExpenseUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the expense user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetExpenseUserProfile(
    int userId,
    int groupId,
    ExpenseUserProfile tp
)
Visual Basic (Declaration)
Public Function SetExpenseUserProfile ( _
    userId As Integer, _
    groupId As Integer, _
    tp As ExpenseUserProfile _
) As Integer
Visual C++
public:
int SetExpenseUserProfile(
    int userId,
    int groupId,
    ExpenseUserProfile^ tp
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.ExpenseUserProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetGeneralUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetGeneralUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the general user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetGeneralUserProfile(
    int userId,
    GeneralUserProfile tp
)
Visual Basic (Declaration)
Public Function SetGeneralUserProfile ( _
    userId As Integer, _
    tp As GeneralUserProfile _
) As Integer
Visual C++
public:
int SetGeneralUserProfile(
    int userId,
    GeneralUserProfile^ tp
)

Parameters

userId
Type: System..::.Int32
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.GeneralUserProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetLastVisitedApplicationId Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetLastVisitedApplicationId Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetLastVisitedApplicationId(
    Constants..::.ApplicationType aType
)
Visual Basic (Declaration)
Public Sub SetLastVisitedApplicationId ( _
    aType As Constants..::.ApplicationType _
)
Visual C++
public:
void SetLastVisitedApplicationId(
    Constants..::.ApplicationType aType
)

Parameters

aType
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the profile string

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected int SetProfile(
    int userId,
    int groupId,
    Constants..::.ApplicationType aType,
    ProfileBase tp
)
Visual Basic (Declaration)
Protected Function SetProfile ( _
    userId As Integer, _
    groupId As Integer, _
    aType As Constants..::.ApplicationType, _
    tp As ProfileBase _
) As Integer
Visual C++
protected:
int SetProfile(
    int userId,
    int groupId,
    Constants..::.ApplicationType aType,
    ProfileBase^ tp
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
aType
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.ProfileBase

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetProfileStringToContext Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetProfileStringToContext Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the profile string from context

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SetProfileStringToContext(
    int userId,
    int groupId,
    Constants..::.ApplicationType aType,
    string profile
)
Visual Basic (Declaration)
Protected Sub SetProfileStringToContext ( _
    userId As Integer, _
    groupId As Integer, _
    aType As Constants..::.ApplicationType, _
    profile As String _
)
Visual C++
protected:
void SetProfileStringToContext(
    int userId,
    int groupId,
    Constants..::.ApplicationType aType,
    String^ profile
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
aType
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
profile
Type: System..::.String

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetPunchClockGroupProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetPunchClockGroupProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the group profile for the punch clock

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetPunchClockGroupProfile(
    int groupId,
    PunchClockGroupProfile tp
)
Visual Basic (Declaration)
Public Function SetPunchClockGroupProfile ( _
    groupId As Integer, _
    tp As PunchClockGroupProfile _
) As Integer
Visual C++
public:
int SetPunchClockGroupProfile(
    int groupId,
    PunchClockGroupProfile^ tp
)

Parameters

groupId
Type: System..::.Int32
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.PunchClockGroupProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetPunchClockUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetPunchClockUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the punch clock user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetPunchClockUserProfile(
    int userId,
    int groupId,
    PunchClockUserProfile tp
)
Visual Basic (Declaration)
Public Function SetPunchClockUserProfile ( _
    userId As Integer, _
    groupId As Integer, _
    tp As PunchClockUserProfile _
) As Integer
Visual C++
public:
int SetPunchClockUserProfile(
    int userId,
    int groupId,
    PunchClockUserProfile^ tp
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.PunchClockUserProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
ProfileDB..::.SetSPCommand Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

ProfileDB Class
ProfileDB Members
OfficeClip.DBLayer.Framework Namespace


SetTimesheetGroupProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetTimesheetGroupProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the group profile for the timesheet

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetTimesheetGroupProfile(
    int groupId,
    TimesheetGroupProfile tp
)
Visual Basic (Declaration)
Public Function SetTimesheetGroupProfile ( _
    groupId As Integer, _
    tp As TimesheetGroupProfile _
) As Integer
Visual C++
public:
int SetTimesheetGroupProfile(
    int groupId,
    TimesheetGroupProfile^ tp
)

Parameters

groupId
Type: System..::.Int32
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.TimesheetGroupProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetTimesheetUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetTimesheetUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the timesheet user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetTimesheetUserProfile(
    int userId,
    int groupId,
    TimesheetUserProfile tp
)
Visual Basic (Declaration)
Public Function SetTimesheetUserProfile ( _
    userId As Integer, _
    groupId As Integer, _
    tp As TimesheetUserProfile _
) As Integer
Visual C++
public:
int SetTimesheetUserProfile(
    int userId,
    int groupId,
    TimesheetUserProfile^ tp
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.TimesheetUserProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


SetTrackerUserProfile Method

[image]

OfficeClip API Documentation
ProfileDB..::.SetTrackerUserProfile Method
ProfileDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the tracker user profile

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetTrackerUserProfile(
    int userId,
    int groupId,
    TrackerUserProfile tp
)
Visual Basic (Declaration)
Public Function SetTrackerUserProfile ( _
    userId As Integer, _
    groupId As Integer, _
    tp As TrackerUserProfile _
) As Integer
Visual C++
public:
int SetTrackerUserProfile(
    int userId,
    int groupId,
    TrackerUserProfile^ tp
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
tp
Type: OfficeClip.BusinessLayer.Framework.Profile..::.TrackerUserProfile

Return Value

See Also

ProfileDB Class
OfficeClip.DBLayer.Framework Namespace


ReminderDB Class

[image]

OfficeClip API Documentation
ReminderDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Reminder application related functions.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class ReminderDB : OfficeClipDB
Visual Basic (Declaration)
Public Class ReminderDB _
    Inherits OfficeClipDB
Visual C++
public ref class ReminderDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.ReminderDB

See Also

ReminderDB Members
OfficeClip.DBLayer.Framework Namespace


ReminderDB Members

[image] [image]

OfficeClip API Documentation
ReminderDB Members
ReminderDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ReminderDB type exposes the following members.

Constructors

 | Name | Description
Public method | ReminderDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DelReminderDetails | Deletes the reminder details, if there are no reminder details, then it deletes the reminder record too
Public method | DelReminderFromApplications | Deletes all the reminders corresponding to a particular application.
Public method | DelReminderGroupMembersApplicationReminders | Deletes all the reminders for all the group members (except for user's reminder) created for a specific application.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllApplicationReminders | Gets all the reminders created for a specific application associated with a specific object within that application.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPersonalReminderDetailsByUser | Gets the personal reminder details of all reminders created in the OfficeClip reminder application for the currently logged in user.
Public method | GetPersonalReminderInfo | Gets the personal reminder details of a particular reminder created in the OfficeClip reminder application for a particular user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsReminder | Inserts repeated reminders in the database.
Public method | InsReminderFromApplications | Inserts the Reminder into the Database.
Protected method | InsSingleReminder | Inserts the reminder details of a single reminder, this method is called from the main routine to Insert repeated reminders.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessReminders | Processes all the reminders and sends messages which have become due as of now. This method is called from the timer at application context level on start of the application.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateReminderStatus | Updates the status of the reminder whether the reminder was sent successfuly or not. If not another attempt is made (Max 3 times) when the ProcessReminders method is called the next time.
Public method | UpdReminderFromApplications | Updates the Reminder into the Database.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


ReminderDB Constructor

[image]

OfficeClip API Documentation
ReminderDB Constructor
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReminderDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReminderDB()

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


ReminderDB Methods

[image] [image]

OfficeClip API Documentation
ReminderDB Methods
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

The ReminderDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DelReminderDetails | Deletes the reminder details, if there are no reminder details, then it deletes the reminder record too
Public method | DelReminderFromApplications | Deletes all the reminders corresponding to a particular application.
Public method | DelReminderGroupMembersApplicationReminders | Deletes all the reminders for all the group members (except for user's reminder) created for a specific application.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllApplicationReminders | Gets all the reminders created for a specific application associated with a specific object within that application.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPersonalReminderDetailsByUser | Gets the personal reminder details of all reminders created in the OfficeClip reminder application for the currently logged in user.
Public method | GetPersonalReminderInfo | Gets the personal reminder details of a particular reminder created in the OfficeClip reminder application for a particular user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsReminder | Inserts repeated reminders in the database.
Public method | InsReminderFromApplications | Inserts the Reminder into the Database.
Protected method | InsSingleReminder | Inserts the reminder details of a single reminder, this method is called from the main routine to Insert repeated reminders.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessReminders | Processes all the reminders and sends messages which have become due as of now. This method is called from the timer at application context level on start of the application.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateReminderStatus | Updates the status of the reminder whether the reminder was sent successfuly or not. If not another attempt is made (Max 3 times) when the ProcessReminders method is called the next time.
Public method | UpdReminderFromApplications | Updates the Reminder into the Database.

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
ReminderDB..::.AddOutputParameter Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

ReminderDB Class
ReminderDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
ReminderDB..::.AddParameter Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

ReminderDB Class
ReminderDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
ReminderDB..::.AddParameters Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

ReminderDB Class
ReminderDB Members
OfficeClip.DBLayer.Framework Namespace


DelReminderDetails Method

[image]

OfficeClip API Documentation
ReminderDB..::.DelReminderDetails Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the reminder details, if there are no reminder details, then it deletes the reminder record too

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DelReminderDetails(
    int reminderId,
    int reminderDetailId
)
Visual Basic (Declaration)
Public Sub DelReminderDetails ( _
    reminderId As Integer, _
    reminderDetailId As Integer _
)
Visual C++
public:
void DelReminderDetails(
    int reminderId,
    int reminderDetailId
)

Parameters

reminderId
Type: System..::.Int32
Id of the reminder.
reminderDetailId
Type: System..::.Int32
Detail Id corresponding to the id of the reminder.

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


DelReminderFromApplications Method

[image]

OfficeClip API Documentation
ReminderDB..::.DelReminderFromApplications Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all the reminders corresponding to a particular application.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DelReminderFromApplications(
    Constants..::.ApplicationType applicationId,
    int id
)
Visual Basic (Declaration)
Public Function DelReminderFromApplications ( _
    applicationId As Constants..::.ApplicationType, _
    id As Integer _
) As Integer
Visual C++
public:
int DelReminderFromApplications(
    Constants..::.ApplicationType applicationId,
    int id
)

Parameters

applicationId
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
Id of the application corresponding to which the reminder has to be deleted.
id
Type: System..::.Int32
Id of the object in that particular application associated with which the reminder was created.

Return Value

0 if successful, -1 in case of an error.

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


DelReminderGroupMembersApplicationReminders Method

[image]

OfficeClip API Documentation
ReminderDB..::.DelReminderGroupMembersApplicationReminders Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all the reminders for all the group members (except for user's reminder) created for a specific application.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DelReminderGroupMembersApplicationReminders(
    int userId,
    Constants..::.ApplicationType applicationId,
    int id
)
Visual Basic (Declaration)
Public Function DelReminderGroupMembersApplicationReminders ( _
    userId As Integer, _
    applicationId As Constants..::.ApplicationType, _
    id As Integer _
) As Integer
Visual C++
public:
int DelReminderGroupMembersApplicationReminders(
    int userId,
    Constants..::.ApplicationType applicationId,
    int id
)

Parameters

userId
Type: System..::.Int32
Id of the user whose group members reminder should be deleted but not this user's.
applicationId
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
Id of the application for which the reminder has to be created.
id
Type: System..::.Int32
Id of the object belonging to the application.

Return Value

0 if successful, -1 in case of an error.

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
ReminderDB..::.ExecuteNonQuery Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

ReminderDB Class
ReminderDB Members
OfficeClip.DBLayer.Framework Namespace


GetAllApplicationReminders Method

[image]

OfficeClip API Documentation
ReminderDB..::.GetAllApplicationReminders Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the reminders created for a specific application associated with a specific object within that application.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAllApplicationReminders(
    int applicationId,
    int id
)
Visual Basic (Declaration)
Public Function GetAllApplicationReminders ( _
    applicationId As Integer, _
    id As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAllApplicationReminders(
    int applicationId,
    int id
)

Parameters

applicationId
Type: System..::.Int32
Id of the application related to which all the reminders are to be retrieved.
id
Type: System..::.Int32
Id of the object in that application associated with which the specific reminder are to be retrieved.

Return Value

DataSet containing all the appplication related reminders. This DataSet consists of a single DataTable with the following columns.
  • UserId (System.Int32)Id of the user for whom the reminder is created.
  • reminderId (System.Int32)Id of the reminder.
  • reminderDetailId (System.Int32)Secondary id for the reminder distinguishing between the set of repeating reminders.
  • remindAt (System.DateTime)Date and Time in user's timezone when the user wants the reminder to be sent.
  • remindAtServertime (System.DateTime)Date and Time in the server when the reminder should be sent so that it reaches at the date and time specified by user in his/her respective timezone.
  • isGroup (System.Int32)Flag (Y/N) indicating whether this reminder was created to send reminder messages to all the members of a particular group.

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


GetPersonalReminderDetailsByUser Method

[image]

OfficeClip API Documentation
ReminderDB..::.GetPersonalReminderDetailsByUser Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the personal reminder details of all reminders created in the OfficeClip reminder application for the currently logged in user.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPersonalReminderDetailsByUser(
    int userId
)
Visual Basic (Declaration)
Public Function GetPersonalReminderDetailsByUser ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetPersonalReminderDetailsByUser(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

DataSet containing all the reminder related information. This DataSet consists of a single DataTable with the following columns.
  • reminder_id (System.Int32)Id of the reminder.
  • reminder_detail_id (System.Int32)Additinal id differentiating the reminders from a set of repeating reminders.
  • remind_at (System.DateTime)Date and Time as per user's timezone when the user wants to be reminded.
  • message (System.String)Content of the message which needs to be sent as reminder.
  • status (System.String)Flag (Y/N) indicating whether the reminder has been sent or not.

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


GetPersonalReminderInfo Method

[image]

OfficeClip API Documentation
ReminderDB..::.GetPersonalReminderInfo Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the personal reminder details of a particular reminder created in the OfficeClip reminder application for a particular user.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPersonalReminderInfo(
    int userId,
    int reminderId
)
Visual Basic (Declaration)
Public Function GetPersonalReminderInfo ( _
    userId As Integer, _
    reminderId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetPersonalReminderInfo(
    int userId,
    int reminderId
)

Parameters

userId
Type: System..::.Int32
reminderId
Type: System..::.Int32

Return Value

DataSet containing all the reminder related information. This DataSet consists of a single DataTable with the following columns.
  • reminder_id (System.Int32)Id of the reminder.
  • reminder_detail_id (System.Int32)Additinal id differentiating the reminders from a set of repeating reminders.
  • remind_at (System.DateTime)Date and Time as per user's timezone when the user wants to be reminded.
  • message (System.String)Content of the message which needs to be sent as reminder.
  • status (System.String)Flag (Y/N) indicating whether the reminder has been sent or not.

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
ReminderDB..::.InitTransaction Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

ReminderDB Class
ReminderDB Members
OfficeClip.DBLayer.Framework Namespace


InsReminder Method

[image]

OfficeClip API Documentation
ReminderDB..::.InsReminder Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts repeated reminders in the database.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsReminder(
    string reminder_message,
    DateTime remind_at,
    RecurrenceInfo ri,
    int userId,
    TimeZoneInfo userTz
)
Visual Basic (Declaration)
Public Function InsReminder ( _
    reminder_message As String, _
    remind_at As DateTime, _
    ri As RecurrenceInfo, _
    userId As Integer, _
    userTz As TimeZoneInfo _
) As Integer
Visual C++
public:
int InsReminder(
    String^ reminder_message,
    DateTime remind_at,
    RecurrenceInfo^ ri,
    int userId,
    TimeZoneInfo^ userTz
)

Parameters

reminder_message
Type: System..::.String
The remind message.
remind_at
Type: System..::.DateTime
The time when reminded at.
ri
Type: OfficeClip.BusinessLayer.Desktop..::.RecurrenceInfo
Instance of the recurrenceInfo object containing repeating information. RecurrenceInfo
userId
Type: System..::.Int32
The unique id of the user
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone

Return Value

Id of the newly created reminder if successful, -1 in case of an error.

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


InsReminderFromApplications Method

[image]

OfficeClip API Documentation
ReminderDB..::.InsReminderFromApplications Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the Reminder into the Database.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsReminderFromApplications(
    int userId,
    string message,
    Constants..::.ApplicationType applicationId,
    int id,
    string isGroup,
    DateTime remindAtDatetime,
    DateTime remindAtServertime,
    TimeZoneInfo serverTz
)
Visual Basic (Declaration)
Public Function InsReminderFromApplications ( _
    userId As Integer, _
    message As String, _
    applicationId As Constants..::.ApplicationType, _
    id As Integer, _
    isGroup As String, _
    remindAtDatetime As DateTime, _
    remindAtServertime As DateTime, _
    serverTz As TimeZoneInfo _
) As Integer
Visual C++
public:
int InsReminderFromApplications(
    int userId,
    String^ message,
    Constants..::.ApplicationType applicationId,
    int id,
    String^ isGroup,
    DateTime remindAtDatetime,
    DateTime remindAtServertime,
    TimeZoneInfo^ serverTz
)

Parameters

userId
Type: System..::.Int32
Id of the user for whom the reminder is being created.
message
Type: System..::.String
The message which is sent with the reminder.
applicationId
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
The application Id for which it is being created.
id
Type: System..::.Int32
The Id of the application entity (for e.g. event_id when it is for calendar).
isGroup
Type: System..::.String
Y if it is a group reminder and N if private Reminder.
remindAtDatetime
Type: System..::.DateTime
The user's datetime for which the reminder is to be created.
remindAtServertime
Type: System..::.DateTime
The server datetime for which the reminder is created.
serverTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The server timezone

Return Value

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


InsSingleReminder Method

[image]

OfficeClip API Documentation
ReminderDB..::.InsSingleReminder Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the reminder details of a single reminder, this method is called from the main routine to Insert repeated reminders.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected int InsSingleReminder(
    int reminder_id,
    string reminder_message,
    DateTime remind_at,
    DateTime server_remind_at,
    int detail_id,
    int userId,
    TimeZoneInfo userTz
)
Visual Basic (Declaration)
Protected Function InsSingleReminder ( _
    reminder_id As Integer, _
    reminder_message As String, _
    remind_at As DateTime, _
    server_remind_at As DateTime, _
    detail_id As Integer, _
    userId As Integer, _
    userTz As TimeZoneInfo _
) As Integer
Visual C++
protected:
int InsSingleReminder(
    int reminder_id,
    String^ reminder_message,
    DateTime remind_at,
    DateTime server_remind_at,
    int detail_id,
    int userId,
    TimeZoneInfo^ userTz
)

Parameters

reminder_id
Type: System..::.Int32
Id of the previously created reminder for which subsequent repeating reminder details have to be created.
reminder_message
Type: System..::.String
The remind message.
remind_at
Type: System..::.DateTime
The time when to remind at for the user.
server_remind_at
Type: System..::.DateTime
The time when reminded at on the server.
detail_id
Type: System..::.Int32
Reminder detail id corresponding to the reminder to distinguish between a set of repeating reminders.
userId
Type: System..::.Int32
The unique id of the user
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone

Return Value

Id of the newly created reminder if successful, -1 in case of an error.

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


ProcessReminders Method

[image]

OfficeClip API Documentation
ReminderDB..::.ProcessReminders Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Processes all the reminders and sends messages which have become due as of now. This method is called from the timer at application context level on start of the application.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void ProcessReminders()
Visual Basic (Declaration)
Public Sub ProcessReminders
Visual C++
public:
void ProcessReminders()

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
ReminderDB..::.SetSPCommand Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

ReminderDB Class
ReminderDB Members
OfficeClip.DBLayer.Framework Namespace


UpdateReminderStatus Method

[image]

OfficeClip API Documentation
ReminderDB..::.UpdateReminderStatus Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the status of the reminder whether the reminder was sent successfuly or not. If not another attempt is made (Max 3 times) when the ProcessReminders method is called the next time.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateReminderStatus(
    int reminderId,
    int reminderDetailId,
    bool statusOk
)
Visual Basic (Declaration)
Public Function UpdateReminderStatus ( _
    reminderId As Integer, _
    reminderDetailId As Integer, _
    statusOk As Boolean _
) As Integer
Visual C++
public:
int UpdateReminderStatus(
    int reminderId,
    int reminderDetailId,
    bool statusOk
)

Parameters

reminderId
Type: System..::.Int32
Id of the reminder for which the status has to be updated.
reminderDetailId
Type: System..::.Int32
Detail id corresponding to the reminder id.
statusOk
Type: System..::.Boolean
Flag (True/False) indicating whether the reminder was sent successfully or not.

Return Value

0 if successful, -1 in case of an error.

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


UpdReminderFromApplications Method

[image]

OfficeClip API Documentation
ReminderDB..::.UpdReminderFromApplications Method
ReminderDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the Reminder into the Database.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdReminderFromApplications(
    int reminderId,
    int reminderDetailId,
    string message,
    DateTime remindAtDatetime,
    DateTime remindAtServertime
)
Visual Basic (Declaration)
Public Function UpdReminderFromApplications ( _
    reminderId As Integer, _
    reminderDetailId As Integer, _
    message As String, _
    remindAtDatetime As DateTime, _
    remindAtServertime As DateTime _
) As Integer
Visual C++
public:
int UpdReminderFromApplications(
    int reminderId,
    int reminderDetailId,
    String^ message,
    DateTime remindAtDatetime,
    DateTime remindAtServertime
)

Parameters

reminderId
Type: System..::.Int32
Id of the reminder.
reminderDetailId
Type: System..::.Int32
Reminder detail id corresponding to the reminder to distinguish between a set of repeating reminders.
message
Type: System..::.String
The message which is sent with the reminder.
remindAtDatetime
Type: System..::.DateTime
The user's datetime for which the reminder is to be created.
remindAtServertime
Type: System..::.DateTime
The server datetime for which the reminder is created.

Return Value

0 if successful, -1 in case of an error.

See Also

ReminderDB Class
OfficeClip.DBLayer.Framework Namespace


RemoveUserDataDB Class

[image]

OfficeClip API Documentation
RemoveUserDataDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

The Remove user class

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class RemoveUserDataDB : OfficeClipDB
Visual Basic (Declaration)
Public Class RemoveUserDataDB _
    Inherits OfficeClipDB
Visual C++
public ref class RemoveUserDataDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.RemoveUserDataDB

See Also

RemoveUserDataDB Members
OfficeClip.DBLayer.Framework Namespace


RemoveUserDataDB Members

[image] [image]

OfficeClip API Documentation
RemoveUserDataDB Members
RemoveUserDataDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RemoveUserDataDB type exposes the following members.

Constructors

 | Name | Description
Public method | RemoveUserDataDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PurgeUserData | Removes the user related data from the database. It will Remove the user record if there is no group specific data created by the user. If the user has created group related data, even that will be deleted.
Public method | RemoveUserData | Removes the user related data from the database. It will Remove the user record if there is no group specific data created by the user. If the user has created group related data, then the user record will not be deleted.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

RemoveUserDataDB Class
OfficeClip.DBLayer.Framework Namespace


RemoveUserDataDB Constructor

[image]

OfficeClip API Documentation
RemoveUserDataDB Constructor
RemoveUserDataDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public RemoveUserDataDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RemoveUserDataDB()

See Also

RemoveUserDataDB Class
OfficeClip.DBLayer.Framework Namespace


RemoveUserDataDB Methods

[image] [image]

OfficeClip API Documentation
RemoveUserDataDB Methods
RemoveUserDataDB Class See Also

[This is preliminary documentation and is subject to change.]

The RemoveUserDataDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PurgeUserData | Removes the user related data from the database. It will Remove the user record if there is no group specific data created by the user. If the user has created group related data, even that will be deleted.
Public method | RemoveUserData | Removes the user related data from the database. It will Remove the user record if there is no group specific data created by the user. If the user has created group related data, then the user record will not be deleted.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveUserDataDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
RemoveUserDataDB..::.AddOutputParameter Method
RemoveUserDataDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

RemoveUserDataDB Class
RemoveUserDataDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
RemoveUserDataDB..::.AddParameter Method
RemoveUserDataDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

RemoveUserDataDB Class
RemoveUserDataDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
RemoveUserDataDB..::.AddParameters Method
RemoveUserDataDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

RemoveUserDataDB Class
RemoveUserDataDB Members
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
RemoveUserDataDB..::.ExecuteNonQuery Method
RemoveUserDataDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

RemoveUserDataDB Class
RemoveUserDataDB Members
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
RemoveUserDataDB..::.InitTransaction Method
RemoveUserDataDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

RemoveUserDataDB Class
RemoveUserDataDB Members
OfficeClip.DBLayer.Framework Namespace


PurgeUserData Method

[image]

OfficeClip API Documentation
RemoveUserDataDB..::.PurgeUserData Method
RemoveUserDataDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the user related data from the database. It will Remove the user record if there is no group specific data created by the user. If the user has created group related data, even that will be deleted.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int PurgeUserData(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function PurgeUserData ( _
    userId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int PurgeUserData(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The id of the user whose data is to be removed from the system.
groupId
Type: System..::.Int32
The unique id of the ogranization

Return Value

0 - if removal successful -1 - if the user is an admin in atleast one of the groups where he/she belongs.

See Also

RemoveUserDataDB Class
OfficeClip.DBLayer.Framework Namespace


RemoveUserData Method

[image]

OfficeClip API Documentation
RemoveUserDataDB..::.RemoveUserData Method
RemoveUserDataDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the user related data from the database. It will Remove the user record if there is no group specific data created by the user. If the user has created group related data, then the user record will not be deleted.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RemoveUserData(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function RemoveUserData ( _
    userId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int RemoveUserData(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The id of the user whose data is to be removed from the system.
groupId
Type: System..::.Int32
The unique id of the ogranization

Return Value

0 - if removal successful -1 - if the user is an admin in atleast one of the groups where he/she belongs.

See Also

RemoveUserDataDB Class
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
RemoveUserDataDB..::.SetSPCommand Method
RemoveUserDataDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

RemoveUserDataDB Class
RemoveUserDataDB Members
OfficeClip.DBLayer.Framework Namespace


ReportDB Class

[image]

OfficeClip API Documentation
ReportDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of reporting functions.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class ReportDB : OfficeClipDB
Visual Basic (Declaration)
Public Class ReportDB _
    Inherits OfficeClipDB
Visual C++
public ref class ReportDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.ReportDB

See Also

ReportDB Members
OfficeClip.DBLayer.Framework Namespace


ReportDB Members

[image] [image]

OfficeClip API Documentation
ReportDB Members
ReportDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ReportDB type exposes the following members.

Constructors

 | Name | Description
Public method | ReportDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArguments | Overloaded.
Public method | GetFilterData | Gets the data from the database for populating various filters
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetReportData | Overloaded.
Public method | GetReportParameters | Gets the report parameters from the report xml file
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

ReportDB Class
OfficeClip.DBLayer.Framework Namespace


ReportDB Constructor

[image]

OfficeClip API Documentation
ReportDB Constructor
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReportDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReportDB()

See Also

ReportDB Class
OfficeClip.DBLayer.Framework Namespace


ReportDB Methods

[image] [image]

OfficeClip API Documentation
ReportDB Methods
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

The ReportDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArguments | Overloaded.
Public method | GetFilterData | Gets the data from the database for populating various filters
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetReportData | Overloaded.
Public method | GetReportParameters | Gets the report parameters from the report xml file
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReportDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
ReportDB..::.AddOutputParameter Method
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

ReportDB Class
ReportDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
ReportDB..::.AddParameter Method
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

ReportDB Class
ReportDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
ReportDB..::.AddParameters Method
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

ReportDB Class
ReportDB Members
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
ReportDB..::.ExecuteNonQuery Method
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

ReportDB Class
ReportDB Members
OfficeClip.DBLayer.Framework Namespace


GetArguments Method

[image] [image]

OfficeClip API Documentation
ReportDB..::.GetArguments Method
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetArguments(Int32, String%) | Gets the arguments of the report
Public method | GetArguments(Int32, String%, String) | Gets the arguments of the report. Also gets the report title

See Also

ReportDB Class
ReportDB Members
OfficeClip.DBLayer.Framework Namespace


GetArguments Method (Int32, String)

[image]

OfficeClip API Documentation
ReportDB..::.GetArguments Method (Int32, String%)
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the arguments of the report

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetArguments(
    int reportId,
    ref string reportTitle
)
Visual Basic (Declaration)
Public Function GetArguments ( _
    reportId As Integer, _
    ByRef reportTitle As String _
) As DataTable
Visual C++
public:
DataTable^ GetArguments(
    int reportId,
    String^% reportTitle
)

Parameters

reportId
Type: System..::.Int32
The unique id of the report
reportTitle
Type: System..::.String%
The report title

Return Value

Table with report arguments

See Also

ReportDB Class
GetArguments Overload
OfficeClip.DBLayer.Framework Namespace


GetArguments Method (Int32, String, String)

[image]

OfficeClip API Documentation
ReportDB..::.GetArguments Method (Int32, String%, String)
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the arguments of the report. Also gets the report title

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetArguments(
    int reportId,
    ref string reportTitle,
    string reportDiskPath
)
Visual Basic (Declaration)
Public Function GetArguments ( _
    reportId As Integer, _
    ByRef reportTitle As String, _
    reportDiskPath As String _
) As DataTable
Visual C++
public:
DataTable^ GetArguments(
    int reportId,
    String^% reportTitle,
    String^ reportDiskPath
)

Parameters

reportId
Type: System..::.Int32
The id of the report
reportTitle
Type: System..::.String%
The title to be shown inside the report
reportDiskPath
Type: System..::.String
The path of the report on the disk

Return Value

Returns a datatable containing two columns label and type. An empty table is returned if there are no arguments

See Also

ReportDB Class
GetArguments Overload
OfficeClip.DBLayer.Framework Namespace


GetFilterData Method

[image]

OfficeClip API Documentation
ReportDB..::.GetFilterData Method
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the data from the database for populating various filters

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetFilterData(
    int groupId,
    string filterType
)
Visual Basic (Declaration)
Public Function GetFilterData ( _
    groupId As Integer, _
    filterType As String _
) As DataTable
Visual C++
public:
DataTable^ GetFilterData(
    int groupId,
    String^ filterType
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
filterType
Type: System..::.String
The name of the filter

Return Value

The datatable that has the name value paid for the filter

See Also

ReportDB Class
OfficeClip.DBLayer.Framework Namespace


GetReportData Method

[image] [image]

OfficeClip API Documentation
ReportDB..::.GetReportData Method
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetReportData(Int32, Int32, String, String, String, String, String%, String%) | Gets the report data
Public method | GetReportData(Int32, Int32, String, String, String, String, String%, String%, String) | Gets the sql from the database and execute it with the given arguments for a particular group.

See Also

ReportDB Class
ReportDB Members
OfficeClip.DBLayer.Framework Namespace


GetReportData Method (Int32, Int32, String, String, String, String, String, String)

[image]

OfficeClip API Documentation
ReportDB..::.GetReportData Method (Int32, Int32, String, String, String, String, String%, String%)
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the report data

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetReportData(
    int groupId,
    int reportId,
    string arg1,
    string arg2,
    string arg3,
    string arg4,
    ref string path,
    ref string name
)
Visual Basic (Declaration)
Public Function GetReportData ( _
    groupId As Integer, _
    reportId As Integer, _
    arg1 As String, _
    arg2 As String, _
    arg3 As String, _
    arg4 As String, _
    ByRef path As String, _
    ByRef name As String _
) As DataSet
Visual C++
public:
DataSet^ GetReportData(
    int groupId,
    int reportId,
    String^ arg1,
    String^ arg2,
    String^ arg3,
    String^ arg4,
    String^% path,
    String^% name
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
reportId
Type: System..::.Int32
The unique id of the report
arg1
Type: System..::.String
The first argument
arg2
Type: System..::.String
The second argument
arg3
Type: System..::.String
The third argument
arg4
Type: System..::.String
The forth argument
path
Type: System..::.String%
The return path
name
Type: System..::.String%
The return name

Return Value

Returns the report data in the dataset

See Also

ReportDB Class
GetReportData Overload
OfficeClip.DBLayer.Framework Namespace


GetReportData Method (Int32, Int32, String, String, String, String, String, String, String)

[image]

OfficeClip API Documentation
ReportDB..::.GetReportData Method (Int32, Int32, String, String, String, String, String%, String%, String)
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the sql from the database and execute it with the given arguments for a particular group.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetReportData(
    int groupId,
    int reportId,
    string arg1,
    string arg2,
    string arg3,
    string arg4,
    ref string path,
    ref string name,
    string reportDiskPath
)
Visual Basic (Declaration)
Public Function GetReportData ( _
    groupId As Integer, _
    reportId As Integer, _
    arg1 As String, _
    arg2 As String, _
    arg3 As String, _
    arg4 As String, _
    ByRef path As String, _
    ByRef name As String, _
    reportDiskPath As String _
) As DataSet
Visual C++
public:
DataSet^ GetReportData(
    int groupId,
    int reportId,
    String^ arg1,
    String^ arg2,
    String^ arg3,
    String^ arg4,
    String^% path,
    String^% name,
    String^ reportDiskPath
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.
reportId
Type: System..::.Int32
The report Id.
arg1
Type: System..::.String
The first argument.
arg2
Type: System..::.String
The second argument.
arg3
Type: System..::.String
The third argument.
arg4
Type: System..::.String
The fourth argument.
path
Type: System..::.String%
The path of the report file.
name
Type: System..::.String%
The name of the report file.
reportDiskPath
Type: System..::.String
The path of the report on the disk

Return Value

DataSet corresponding to the report. To determine the columns returned in the DataTables of the DataSet, please refer to sql queries specified in the reports.xml resource file.

See Also

ReportDB Class
GetReportData Overload
OfficeClip.DBLayer.Framework Namespace


GetReportParameters Method

[image]

OfficeClip API Documentation
ReportDB..::.GetReportParameters Method
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the report parameters from the report xml file

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetReportParameters(
    string specsFile,
    int reportId,
    ref string path,
    ref string name,
    ref string sqlStr,
    ref string datasetName,
    ref string[] cols
)
Visual Basic (Declaration)
Public Sub GetReportParameters ( _
    specsFile As String, _
    reportId As Integer, _
    ByRef path As String, _
    ByRef name As String, _
    ByRef sqlStr As String, _
    ByRef datasetName As String, _
    ByRef cols As String() _
)
Visual C++
public:
void GetReportParameters(
    String^ specsFile,
    int reportId,
    String^% path,
    String^% name,
    String^% sqlStr,
    String^% datasetName,
    array<String^>^% cols
)

Parameters

specsFile
Type: System..::.String
The xml file where the report is specified
reportId
Type: System..::.Int32
The unique id of the report
path
Type: System..::.String%
The path of the report
name
Type: System..::.String%
The name of the report
sqlStr
Type: System..::.String%
The sql for the report
datasetName
Type: System..::.String%
The report dataset name
cols
Type: array<System..::.String>[]()[]%
The report columns

See Also

ReportDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
ReportDB..::.InitTransaction Method
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

ReportDB Class
ReportDB Members
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
ReportDB..::.SetSPCommand Method
ReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

ReportDB Class
ReportDB Members
OfficeClip.DBLayer.Framework Namespace


TimezoneDB Class

[image]

OfficeClip API Documentation
TimezoneDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of timezone related functions.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TimezoneDB : OfficeClipDB
Visual Basic (Declaration)
Public Class TimezoneDB _
    Inherits OfficeClipDB
Visual C++
public ref class TimezoneDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.TimezoneDB

See Also

TimezoneDB Members
OfficeClip.DBLayer.Framework Namespace


TimezoneDB Members

[image] [image]

OfficeClip API Documentation
TimezoneDB Members
TimezoneDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TimezoneDB type exposes the following members.

Constructors

 | Name | Description
Public method | TimezoneDB | Default Constructor

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTimeZoneFromId | Gets all the information related to a particular timezone identified by the timezoneId.
Public method | GetTimezones | Gets all the information related to all the timezones supported by OfficeClip system.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

TimezoneDB Class
OfficeClip.DBLayer.Framework Namespace


TimezoneDB Constructor

[image]

OfficeClip API Documentation
TimezoneDB Constructor
TimezoneDB Class See Also

[This is preliminary documentation and is subject to change.]

Default Constructor

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TimezoneDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimezoneDB()

See Also

TimezoneDB Class
OfficeClip.DBLayer.Framework Namespace


TimezoneDB Methods

[image] [image]

OfficeClip API Documentation
TimezoneDB Methods
TimezoneDB Class See Also

[This is preliminary documentation and is subject to change.]

The TimezoneDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTimeZoneFromId | Gets all the information related to a particular timezone identified by the timezoneId.
Public method | GetTimezones | Gets all the information related to all the timezones supported by OfficeClip system.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimezoneDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
TimezoneDB..::.AddOutputParameter Method
TimezoneDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

TimezoneDB Class
TimezoneDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
TimezoneDB..::.AddParameter Method
TimezoneDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

TimezoneDB Class
TimezoneDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
TimezoneDB..::.AddParameters Method
TimezoneDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

TimezoneDB Class
TimezoneDB Members
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
TimezoneDB..::.ExecuteNonQuery Method
TimezoneDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

TimezoneDB Class
TimezoneDB Members
OfficeClip.DBLayer.Framework Namespace


GetTimeZoneFromId Method

[image]

OfficeClip API Documentation
TimezoneDB..::.GetTimeZoneFromId Method
TimezoneDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to a particular timezone identified by the timezoneId.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TimeZoneInfo GetTimeZoneFromId(
    int timezoneId
)
Visual Basic (Declaration)
Public Function GetTimeZoneFromId ( _
    timezoneId As Integer _
) As TimeZoneInfo
Visual C++
public:
TimeZoneInfo^ GetTimeZoneFromId(
    int timezoneId
)

Parameters

timezoneId
Type: System..::.Int32
Id of the timezone for which all the details are to be retrieved.

Return Value

Instance of the TimeZoneInfo object containing all the information related to a particular timezone. TimeZoneInfo

See Also

TimezoneDB Class
OfficeClip.DBLayer.Framework Namespace


GetTimezones Method

[image]

OfficeClip API Documentation
TimezoneDB..::.GetTimezones Method
TimezoneDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to all the timezones supported by OfficeClip system.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SqlDataReader GetTimezones()
Visual Basic (Declaration)
Public Function GetTimezones As SqlDataReader
Visual C++
public:
SqlDataReader^ GetTimezones()

Return Value

SqlDataReader containing timezone information supported by OfficeClip system. SqlDataReader consists of the following columns.
  • timezoneId (System.Int32)Id of the timezone.
  • timezone (System.String)String descriptiton including the location of the timezone.

See Also

TimezoneDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
TimezoneDB..::.InitTransaction Method
TimezoneDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

TimezoneDB Class
TimezoneDB Members
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
TimezoneDB..::.SetSPCommand Method
TimezoneDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

TimezoneDB Class
TimezoneDB Members
OfficeClip.DBLayer.Framework Namespace


TrackTimeDB Class

[image]

OfficeClip API Documentation
TrackTimeDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Allows management of Address related functions. It enables querying and modifying information related to an addresses.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackTimeDB : OfficeClipDB
Visual Basic (Declaration)
Public Class TrackTimeDB _
    Inherits OfficeClipDB
Visual C++
public ref class TrackTimeDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.TrackTimeDB

See Also

TrackTimeDB Members
OfficeClip.DBLayer.Framework Namespace


TrackTimeDB Members

[image] [image]

OfficeClip API Documentation
TrackTimeDB Members
TrackTimeDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackTimeDB type exposes the following members.

Constructors

 | Name | Description
Public method | TrackTimeDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteTracktime | Removes the instance of the track time from the database
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTracktimeReport | Get list of TrackTime from the database
Public method | GetTracktimes | Get instance of TrackTime from the database
Public method | GetTrackTimeUdf | Get all instances of Tracktimeudf from the database
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertTrackTime | Update the instance of the track time on the database
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateTracktime | Update the instance of the track time on the database
Public method | UpdateTracktimeMark | Update the marks of the track time on the database
Public method | UpdateTracktimeUdf | Update the marks of the track time on the database

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

TrackTimeDB Class
OfficeClip.DBLayer.Framework Namespace


TrackTimeDB Constructor

[image]

OfficeClip API Documentation
TrackTimeDB Constructor
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackTimeDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackTimeDB()

See Also

TrackTimeDB Class
OfficeClip.DBLayer.Framework Namespace


TrackTimeDB Methods

[image] [image]

OfficeClip API Documentation
TrackTimeDB Methods
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

The TrackTimeDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteTracktime | Removes the instance of the track time from the database
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTracktimeReport | Get list of TrackTime from the database
Public method | GetTracktimes | Get instance of TrackTime from the database
Public method | GetTrackTimeUdf | Get all instances of Tracktimeudf from the database
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertTrackTime | Update the instance of the track time on the database
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateTracktime | Update the instance of the track time on the database
Public method | UpdateTracktimeMark | Update the marks of the track time on the database
Public method | UpdateTracktimeUdf | Update the marks of the track time on the database

See Also

TrackTimeDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
TrackTimeDB..::.AddOutputParameter Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

TrackTimeDB Class
TrackTimeDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
TrackTimeDB..::.AddParameter Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

TrackTimeDB Class
TrackTimeDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
TrackTimeDB..::.AddParameters Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

TrackTimeDB Class
TrackTimeDB Members
OfficeClip.DBLayer.Framework Namespace


DeleteTracktime Method

[image]

OfficeClip API Documentation
TrackTimeDB..::.DeleteTracktime Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the instance of the track time from the database

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue DeleteTracktime(
    int tracktimeId
)
Visual Basic (Declaration)
Public Function DeleteTracktime ( _
    tracktimeId As Integer _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue DeleteTracktime(
    int tracktimeId
)

Parameters

tracktimeId
Type: System..::.Int32

See Also

TrackTimeDB Class
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
TrackTimeDB..::.ExecuteNonQuery Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

TrackTimeDB Class
TrackTimeDB Members
OfficeClip.DBLayer.Framework Namespace


GetTracktimeReport Method

[image]

OfficeClip API Documentation
TrackTimeDB..::.GetTracktimeReport Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Get list of TrackTime from the database

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TracktimeInfo[] GetTracktimeReport(
    int isMarked,
    int applicationId,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetTracktimeReport ( _
    isMarked As Integer, _
    applicationId As Integer, _
    userId As Integer, _
    groupId As Integer _
) As TracktimeInfo()
Visual C++
public:
array<TracktimeInfo^>^ GetTracktimeReport(
    int isMarked,
    int applicationId,
    int userId,
    int groupId
)

Parameters

isMarked
Type: System..::.Int32
-1 if mark is not interpreted, 0 if false, 1 if true
applicationId
Type: System..::.Int32
The unique id of the application
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the group

Return Value

An array of TracktimeInfo information structure, empty array if the TrackTime is not found

See Also

TrackTimeDB Class
OfficeClip.DBLayer.Framework Namespace


GetTracktimes Method

[image]

OfficeClip API Documentation
TrackTimeDB..::.GetTracktimes Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Get instance of TrackTime from the database

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TracktimeInfo[] GetTracktimes(
    int tracktimeId,
    int applicationId,
    int userId,
    int primaryId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function GetTracktimes ( _
    tracktimeId As Integer, _
    applicationId As Integer, _
    userId As Integer, _
    primaryId As Integer, _
    currentGroupId As Integer _
) As TracktimeInfo()
Visual C++
public:
array<TracktimeInfo^>^ GetTracktimes(
    int tracktimeId,
    int applicationId,
    int userId,
    int primaryId,
    int currentGroupId
)

Parameters

tracktimeId
Type: System..::.Int32
The unique id of the TrackTime in the database
applicationId
Type: System..::.Int32
The unique id of the application
userId
Type: System..::.Int32
The unique id of the user
primaryId
Type: System..::.Int32
The primary id
currentGroupId
Type: System..::.Int32
the id of the current group

Return Value

An array of TracktimeInfo information structure, empty array if the TrackTime is not found

See Also

TrackTimeDB Class
OfficeClip.DBLayer.Framework Namespace


GetTrackTimeUdf Method

[image]

OfficeClip API Documentation
TrackTimeDB..::.GetTrackTimeUdf Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Get all instances of Tracktimeudf from the database

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackTimeUdfInfo GetTrackTimeUdf(
    int groupId,
    int applicationId
)
Visual Basic (Declaration)
Public Function GetTrackTimeUdf ( _
    groupId As Integer, _
    applicationId As Integer _
) As TrackTimeUdfInfo
Visual C++
public:
TrackTimeUdfInfo^ GetTrackTimeUdf(
    int groupId,
    int applicationId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the Tracktimeudf in the database
applicationId
Type: System..::.Int32
Teh unique id of the application

Return Value

The TrackTimeUdfInfo information structure, null if the Tracktimeudf is not found

See Also

TrackTimeDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
TrackTimeDB..::.InitTransaction Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

TrackTimeDB Class
TrackTimeDB Members
OfficeClip.DBLayer.Framework Namespace


InsertTrackTime Method

[image]

OfficeClip API Documentation
TrackTimeDB..::.InsertTrackTime Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Update the instance of the track time on the database

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertTrackTime(
    TracktimeInfo tti
)
Visual Basic (Declaration)
Public Function InsertTrackTime ( _
    tti As TracktimeInfo _
) As Integer
Visual C++
public:
int InsertTrackTime(
    TracktimeInfo^ tti
)

Parameters

tti
Type: OfficeClip.BusinessLayer.Framework.TrackTime..::.TracktimeInfo
The instance of tracktime that needs to be updated

See Also

TrackTimeDB Class
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
TrackTimeDB..::.SetSPCommand Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

TrackTimeDB Class
TrackTimeDB Members
OfficeClip.DBLayer.Framework Namespace


UpdateTracktime Method

[image]

OfficeClip API Documentation
TrackTimeDB..::.UpdateTracktime Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Update the instance of the track time on the database

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue UpdateTracktime(
    TracktimeInfo tti
)
Visual Basic (Declaration)
Public Function UpdateTracktime ( _
    tti As TracktimeInfo _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue UpdateTracktime(
    TracktimeInfo^ tti
)

Parameters

tti
Type: OfficeClip.BusinessLayer.Framework.TrackTime..::.TracktimeInfo
The instance of tracktime that needs to be updated

See Also

TrackTimeDB Class
OfficeClip.DBLayer.Framework Namespace


UpdateTracktimeMark Method

[image]

OfficeClip API Documentation
TrackTimeDB..::.UpdateTracktimeMark Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Update the marks of the track time on the database

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue UpdateTracktimeMark(
    bool isMark,
    int tracktimeId
)
Visual Basic (Declaration)
Public Function UpdateTracktimeMark ( _
    isMark As Boolean, _
    tracktimeId As Integer _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue UpdateTracktimeMark(
    bool isMark,
    int tracktimeId
)

Parameters

isMark
Type: System..::.Boolean
Shows if the track time is marked
tracktimeId
Type: System..::.Int32
Teh unique id of the track time

See Also

TrackTimeDB Class
OfficeClip.DBLayer.Framework Namespace


UpdateTracktimeUdf Method

[image]

OfficeClip API Documentation
TrackTimeDB..::.UpdateTracktimeUdf Method
TrackTimeDB Class See Also

[This is preliminary documentation and is subject to change.]

Update the marks of the track time on the database

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue UpdateTracktimeUdf(
    TrackTimeUdfInfo ttui
)
Visual Basic (Declaration)
Public Function UpdateTracktimeUdf ( _
    ttui As TrackTimeUdfInfo _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue UpdateTracktimeUdf(
    TrackTimeUdfInfo^ ttui
)

Parameters

ttui
Type: OfficeClip.BusinessLayer.Framework.TrackTime..::.TrackTimeUdfInfo
The instance of tracktime that needs to be updated

See Also

TrackTimeDB Class
OfficeClip.DBLayer.Framework Namespace


WorkflowDB Class

[image]

OfficeClip API Documentation
WorkflowDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of workflow framework related functions.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class WorkflowDB : OfficeClipDB
Visual Basic (Declaration)
Public Class WorkflowDB _
    Inherits OfficeClipDB
Visual C++
public ref class WorkflowDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Framework..::.WorkflowDB

See Also

WorkflowDB Members
OfficeClip.DBLayer.Framework Namespace


WorkflowDB Members

[image] [image]

OfficeClip API Documentation
WorkflowDB Members
WorkflowDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The WorkflowDB type exposes the following members.

Constructors

 | Name | Description
Public method | WorkflowDB | The default constructor

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DefaultRoutingMemberStatusId | status id of the default routing member corresponding to a particular application.
Public method | DefaultUserStatusId | Gets the default workflow status for a particular application.
Public method | DeleteAutoApproveUsers | Deletes all the users to whom autoapprove is set, for a Target User for a particular group
Public method | DeleteWorkflowDefinition | Deletes a particular workflow definition.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAutoApprovalForUser | Gets a boolean value specifying AutoApprove is enabled or not by a Target User for a particular user
Public method | GetAutoApproveUsers | Gets all users form whom the AutoApprove is enabled by the Target User for a particular group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNotifiableStatuses | Gets a list of statuses corresponding to which a notification rule can be defined inside a workflow definition.
Public method | GetNotificationList | Gets the notification list corresponding to a workflow definition.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowActions | Gets a list of possible workflow actions as defined in the OfficeClip system for a particular application depending on the stage and workflow type.
Public method | GetWorkflowActionsForRdlc | Returns workflow statuses based on the application Id. (used in rdl reports)
Public method | GetWorkflowAuthorizedUsers | Gets the authorized users
Public method | GetWorkflowDefinitionDetailsInfoById | Gets the list of all the workflow definition details for a particular workflow definition.
Public method | GetWorkflowDefinitionInfo | Overloaded.
Public method | GetWorkflowHistory | Gets list of workflow history of a particular timesheet or expense.
Public method | GetWorkflowInboxNotificationsById | Gets a list of workflow notifications as definied in a particular workflow definition.
Public method | GetWorkflowRoute | Gets the workflow routing type.
Public method | GetWorkflowRoutingMembers | Gets a list of workflow routing members for a particular user as per the workflow defined for that particular user in a particular group.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertWorkflowDefinition | Inserts a new workflow definition into the system.
Public method | InsertWorkflowDefinitionDetailsInfo | Inserts an individual workflow definition component into the database.
Public method | InsertWorkflowInboxNotificationsInfo | Inserts an individual workflow notification component into the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RerouteItemToMe | Reroutes a particular item to a particular group administrator no matter what stage and type of workflow it is in.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetAutoApprovalForUser | Sets the Auto approve option on a Target User for a particular user
Public method | SetAutoApprovalForUserList |
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetupUserWorkflow | Sets a workflow definition in the database.
Public method | SetupWorkflowDefinition | Sets a workflow definition into the database.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateUserWorkflow | Updates a user workflow definition into the database.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


WorkflowDB Constructor

[image]

OfficeClip API Documentation
WorkflowDB Constructor
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkflowDB()

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


WorkflowDB Methods

[image] [image]

OfficeClip API Documentation
WorkflowDB Methods
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

The WorkflowDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DefaultRoutingMemberStatusId | status id of the default routing member corresponding to a particular application.
Public method | DefaultUserStatusId | Gets the default workflow status for a particular application.
Public method | DeleteAutoApproveUsers | Deletes all the users to whom autoapprove is set, for a Target User for a particular group
Public method | DeleteWorkflowDefinition | Deletes a particular workflow definition.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAutoApprovalForUser | Gets a boolean value specifying AutoApprove is enabled or not by a Target User for a particular user
Public method | GetAutoApproveUsers | Gets all users form whom the AutoApprove is enabled by the Target User for a particular group
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNotifiableStatuses | Gets a list of statuses corresponding to which a notification rule can be defined inside a workflow definition.
Public method | GetNotificationList | Gets the notification list corresponding to a workflow definition.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkflowActions | Gets a list of possible workflow actions as defined in the OfficeClip system for a particular application depending on the stage and workflow type.
Public method | GetWorkflowActionsForRdlc | Returns workflow statuses based on the application Id. (used in rdl reports)
Public method | GetWorkflowAuthorizedUsers | Gets the authorized users
Public method | GetWorkflowDefinitionDetailsInfoById | Gets the list of all the workflow definition details for a particular workflow definition.
Public method | GetWorkflowDefinitionInfo | Overloaded.
Public method | GetWorkflowHistory | Gets list of workflow history of a particular timesheet or expense.
Public method | GetWorkflowInboxNotificationsById | Gets a list of workflow notifications as definied in a particular workflow definition.
Public method | GetWorkflowRoute | Gets the workflow routing type.
Public method | GetWorkflowRoutingMembers | Gets a list of workflow routing members for a particular user as per the workflow defined for that particular user in a particular group.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertWorkflowDefinition | Inserts a new workflow definition into the system.
Public method | InsertWorkflowDefinitionDetailsInfo | Inserts an individual workflow definition component into the database.
Public method | InsertWorkflowInboxNotificationsInfo | Inserts an individual workflow notification component into the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RerouteItemToMe | Reroutes a particular item to a particular group administrator no matter what stage and type of workflow it is in.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetAutoApprovalForUser | Sets the Auto approve option on a Target User for a particular user
Public method | SetAutoApprovalForUserList |
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetupUserWorkflow | Sets a workflow definition in the database.
Public method | SetupWorkflowDefinition | Sets a workflow definition into the database.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateUserWorkflow | Updates a user workflow definition into the database.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
WorkflowDB..::.AddOutputParameter Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

WorkflowDB Class
WorkflowDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
WorkflowDB..::.AddParameter Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

WorkflowDB Class
WorkflowDB Members
OfficeClip.DBLayer.Framework Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
WorkflowDB..::.AddParameters Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

WorkflowDB Class
WorkflowDB Members
OfficeClip.DBLayer.Framework Namespace


DefaultRoutingMemberStatusId Method

[image]

OfficeClip API Documentation
WorkflowDB..::.DefaultRoutingMemberStatusId Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

status id of the default routing member corresponding to a particular application.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DefaultRoutingMemberStatusId(
    int applicationId
)
Visual Basic (Declaration)
Public Function DefaultRoutingMemberStatusId ( _
    applicationId As Integer _
) As Integer
Visual C++
public:
int DefaultRoutingMemberStatusId(
    int applicationId
)

Parameters

applicationId
Type: System..::.Int32
Id of the application.

Return Value

status id of the default routing member.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


DefaultUserStatusId Method

[image]

OfficeClip API Documentation
WorkflowDB..::.DefaultUserStatusId Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the default workflow status for a particular application.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DefaultUserStatusId(
    int applicationId
)
Visual Basic (Declaration)
Public Function DefaultUserStatusId ( _
    applicationId As Integer _
) As Integer
Visual C++
public:
int DefaultUserStatusId(
    int applicationId
)

Parameters

applicationId
Type: System..::.Int32
Id of the application.

Return Value

status id of the default status.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


DeleteAutoApproveUsers Method

[image]

OfficeClip API Documentation
WorkflowDB..::.DeleteAutoApproveUsers Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all the users to whom autoapprove is set, for a Target User for a particular group

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteAutoApproveUsers(
    int targetUserId,
    int groupId,
    int appId
)
Visual Basic (Declaration)
Public Sub DeleteAutoApproveUsers ( _
    targetUserId As Integer, _
    groupId As Integer, _
    appId As Integer _
)
Visual C++
public:
void DeleteAutoApproveUsers(
    int targetUserId,
    int groupId,
    int appId
)

Parameters

targetUserId
Type: System..::.Int32
the target userid or the userid of the person who has to approve
groupId
Type: System..::.Int32
the groupid
appId
Type: System..::.Int32
the application Id

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


DeleteWorkflowDefinition Method

[image]

OfficeClip API Documentation
WorkflowDB..::.DeleteWorkflowDefinition Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a particular workflow definition.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteWorkflowDefinition(
    int workflowDefinitionId
)
Visual Basic (Declaration)
Public Function DeleteWorkflowDefinition ( _
    workflowDefinitionId As Integer _
) As Integer
Visual C++
public:
int DeleteWorkflowDefinition(
    int workflowDefinitionId
)

Parameters

workflowDefinitionId
Type: System..::.Int32
Id of the workflow definition which needs to be deleted.

Return Value

0 if successful, -1 in case of an error.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
WorkflowDB..::.ExecuteNonQuery Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

WorkflowDB Class
WorkflowDB Members
OfficeClip.DBLayer.Framework Namespace


GetAutoApprovalForUser Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetAutoApprovalForUser Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a boolean value specifying AutoApprove is enabled or not by a Target User for a particular user

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool GetAutoApprovalForUser(
    int targetUserId,
    int currentUserId,
    int groupId,
    int appId
)
Visual Basic (Declaration)
Public Function GetAutoApprovalForUser ( _
    targetUserId As Integer, _
    currentUserId As Integer, _
    groupId As Integer, _
    appId As Integer _
) As Boolean
Visual C++
public:
bool GetAutoApprovalForUser(
    int targetUserId,
    int currentUserId,
    int groupId,
    int appId
)

Parameters

targetUserId
Type: System..::.Int32
the target userid or the userid of the person who has to approve
currentUserId
Type: System..::.Int32
the userid of the user
groupId
Type: System..::.Int32
the groupid
appId
Type: System..::.Int32
the application Id

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


GetAutoApproveUsers Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetAutoApproveUsers Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all users form whom the AutoApprove is enabled by the Target User for a particular group

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetAutoApproveUsers(
    int targetUserId,
    int groupId,
    int appId
)
Visual Basic (Declaration)
Public Function GetAutoApproveUsers ( _
    targetUserId As Integer, _
    groupId As Integer, _
    appId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetAutoApproveUsers(
    int targetUserId,
    int groupId,
    int appId
)

Parameters

targetUserId
Type: System..::.Int32
the target userid or the userid of the person who has to approve
groupId
Type: System..::.Int32
the groupid
appId
Type: System..::.Int32
the application Id

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


GetNotifiableStatuses Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetNotifiableStatuses Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of statuses corresponding to which a notification rule can be defined inside a workflow definition.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetNotifiableStatuses(
    int applicationId
)
Visual Basic (Declaration)
Public Function GetNotifiableStatuses ( _
    applicationId As Integer _
) As DataView
Visual C++
public:
DataView^ GetNotifiableStatuses(
    int applicationId
)

Parameters

applicationId
Type: System..::.Int32
Id of the application.

Return Value

DataView containing the id and status name. This DataView consists of the following columns.
  • StatusId (System.Int32)Id of the status.
  • status (System.String)Name of the status.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


GetNotificationList Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetNotificationList Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the notification list corresponding to a workflow definition.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetNotificationList(
    WorkflowDefinitionInfo wfdi
)
Visual Basic (Declaration)
Public Function GetNotificationList ( _
    wfdi As WorkflowDefinitionInfo _
) As String
Visual C++
public:
String^ GetNotificationList(
    WorkflowDefinitionInfo^ wfdi
)

Parameters

wfdi
Type: OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowDefinitionInfo
Instance of the workflow definition object. WorkflowDefinitionInfo

Return Value

String value of the notification list.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


GetWorkflowActions Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetWorkflowActions Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of possible workflow actions as defined in the OfficeClip system for a particular application depending on the stage and workflow type.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetWorkflowActions(
    int applicationId,
    int stageId,
    WorkflowType workflowType,
    int id,
    int workflowDefinitionId
)
Visual Basic (Declaration)
Public Function GetWorkflowActions ( _
    applicationId As Integer, _
    stageId As Integer, _
    workflowType As WorkflowType, _
    id As Integer, _
    workflowDefinitionId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetWorkflowActions(
    int applicationId,
    int stageId,
    WorkflowType workflowType,
    int id,
    int workflowDefinitionId
)

Parameters

applicationId
Type: System..::.Int32
Id of the application.
stageId
Type: System..::.Int32
Id of the Current stage of a particular item in the workflow.
workflowType
Type: OfficeClip.Utils..::.WorkflowType
Type of the workflow applicable to that particular item.
id
Type: System..::.Int32
Id of the item i.e. expense or timesheet.
workflowDefinitionId
Type: System..::.Int32
Id of the workflow definition.

Return Value

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


GetWorkflowActionsForRdlc Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetWorkflowActionsForRdlc Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns workflow statuses based on the application Id. (used in rdl reports)

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetWorkflowActionsForRdlc(
    int appIDValue
)
Visual Basic (Declaration)
Public Function GetWorkflowActionsForRdlc ( _
    appIDValue As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetWorkflowActionsForRdlc(
    int appIDValue
)

Parameters

appIDValue
Type: System..::.Int32
Unique Application Id

Return Value

List of workflow statuses in a dataet

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


GetWorkflowAuthorizedUsers Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetWorkflowAuthorizedUsers Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the authorized users

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetWorkflowAuthorizedUsers(
    int applicationId,
    int groupId,
    int userId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function GetWorkflowAuthorizedUsers ( _
    applicationId As Integer, _
    groupId As Integer, _
    userId As Integer, _
    isAdmin As Boolean _
) As DataSet
Visual C++
public:
DataSet^ GetWorkflowAuthorizedUsers(
    int applicationId,
    int groupId,
    int userId,
    bool isAdmin
)

Parameters

applicationId
Type: System..::.Int32
groupId
Type: System..::.Int32
userId
Type: System..::.Int32
isAdmin
Type: System..::.Boolean

Return Value

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


GetWorkflowDefinitionDetailsInfoById Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetWorkflowDefinitionDetailsInfoById Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of all the workflow definition details for a particular workflow definition.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetWorkflowDefinitionDetailsInfoById(
    int workflowDefinitionId
)
Visual Basic (Declaration)
Public Function GetWorkflowDefinitionDetailsInfoById ( _
    workflowDefinitionId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetWorkflowDefinitionDetailsInfoById(
    int workflowDefinitionId
)

Parameters

workflowDefinitionId
Type: System..::.Int32
Id of the workflow definition.

Return Value

ArrayList of WorkflowDefinitionDetailsInfo object containing details of the individual workflow components belonging to one single workflow definition. WorkflowDefinitionDetailsInfo

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


GetWorkflowDefinitionInfo Method

[image] [image]

OfficeClip API Documentation
WorkflowDB..::.GetWorkflowDefinitionInfo Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetWorkflowDefinitionInfo(Int32) | Gets all the details corresponding to a particular workflow definition identified by workflowDefinitionId.
Public method | GetWorkflowDefinitionInfo(Int32, Int32, Int32) | Gets all the workflow details for a particular user (if defined) corresponding to a particular application and a particular group. Currently workflow supporting applications are only timesheets and expenses.

See Also

WorkflowDB Class
WorkflowDB Members
OfficeClip.DBLayer.Framework Namespace


GetWorkflowDefinitionInfo Method (Int32)

[image]

OfficeClip API Documentation
WorkflowDB..::.GetWorkflowDefinitionInfo Method (Int32)
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details corresponding to a particular workflow definition identified by workflowDefinitionId.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowDefinitionInfo GetWorkflowDefinitionInfo(
    int workflowDefinitionId
)
Visual Basic (Declaration)
Public Function GetWorkflowDefinitionInfo ( _
    workflowDefinitionId As Integer _
) As WorkflowDefinitionInfo
Visual C++
public:
WorkflowDefinitionInfo^ GetWorkflowDefinitionInfo(
    int workflowDefinitionId
)

Parameters

workflowDefinitionId
Type: System..::.Int32
Id of the workflow definition.

Return Value

Instance of workflowDefinitionInfo object containing all the details of a particular workflow. WorkflowDefinitionInfo

See Also

WorkflowDB Class
GetWorkflowDefinitionInfo Overload
OfficeClip.DBLayer.Framework Namespace


GetWorkflowDefinitionInfo Method (Int32, Int32, Int32)

[image]

OfficeClip API Documentation
WorkflowDB..::.GetWorkflowDefinitionInfo Method (Int32, Int32, Int32)
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the workflow details for a particular user (if defined) corresponding to a particular application and a particular group. Currently workflow supporting applications are only timesheets and expenses.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public WorkflowDefinitionInfo GetWorkflowDefinitionInfo(
    int groupId,
    int userId,
    int applicationId
)
Visual Basic (Declaration)
Public Function GetWorkflowDefinitionInfo ( _
    groupId As Integer, _
    userId As Integer, _
    applicationId As Integer _
) As WorkflowDefinitionInfo
Visual C++
public:
WorkflowDefinitionInfo^ GetWorkflowDefinitionInfo(
    int groupId,
    int userId,
    int applicationId
)

Parameters

groupId
Type: System..::.Int32
Id of the group.
userId
Type: System..::.Int32
Id of the user.
applicationId
Type: System..::.Int32
Id of the application i.e. that of timesheet or expense

Return Value

Instance of workflowDefinitionInfo object containing all the details of a particular workflow. WorkflowDefinitionInfo

See Also

WorkflowDB Class
GetWorkflowDefinitionInfo Overload
OfficeClip.DBLayer.Framework Namespace


GetWorkflowHistory Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetWorkflowHistory Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets list of workflow history of a particular timesheet or expense.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetWorkflowHistory(
    int applicationId,
    int id
)
Visual Basic (Declaration)
Public Function GetWorkflowHistory ( _
    applicationId As Integer, _
    id As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetWorkflowHistory(
    int applicationId,
    int id
)

Parameters

applicationId
Type: System..::.Int32
Id of the application (i.e. expense or timesheet).
id
Type: System..::.Int32
Id of the expense or timesheet.

Return Value

ArrayList of WorkflowHistoryInfo objects containing all the information of each workflow action performed on an item.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


GetWorkflowInboxNotificationsById Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetWorkflowInboxNotificationsById Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of workflow notifications as definied in a particular workflow definition.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetWorkflowInboxNotificationsById(
    int workflowDefinitionId
)
Visual Basic (Declaration)
Public Function GetWorkflowInboxNotificationsById ( _
    workflowDefinitionId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetWorkflowInboxNotificationsById(
    int workflowDefinitionId
)

Parameters

workflowDefinitionId
Type: System..::.Int32
Id of the workflow definition.

Return Value

ArrayList of WorkflowInboxNotificationsInfo objects containing workflow notification details as defined in a workflow. WorkflowInboxNotificationsInfo

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


GetWorkflowRoute Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetWorkflowRoute Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the workflow routing type.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetWorkflowRoute(
    WorkflowDefinitionInfo wfdi
)
Visual Basic (Declaration)
Public Function GetWorkflowRoute ( _
    wfdi As WorkflowDefinitionInfo _
) As String
Visual C++
public:
String^ GetWorkflowRoute(
    WorkflowDefinitionInfo^ wfdi
)

Parameters

wfdi
Type: OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowDefinitionInfo
Instance of the workflowDefinitionInfo object. WorkflowDefinitionInfo

Return Value

Name of the workflow routing.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


GetWorkflowRoutingMembers Method

[image]

OfficeClip API Documentation
WorkflowDB..::.GetWorkflowRoutingMembers Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of workflow routing members for a particular user as per the workflow defined for that particular user in a particular group.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetWorkflowRoutingMembers(
    int groupId,
    int userId
)
Visual Basic (Declaration)
Public Function GetWorkflowRoutingMembers ( _
    groupId As Integer, _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetWorkflowRoutingMembers(
    int groupId,
    int userId
)

Parameters

groupId
Type: System..::.Int32
Id of the group.
userId
Type: System..::.Int32
Id of the user for which the workflow routing members have to be retrieved.

Return Value

DataSet containing the id and name of the workflow routing members. This DataSet consists of a single DataTable with the following columns.
  • routingUserId (System.Int32)Id of the user in the routing list.
  • routingUserName (System.String)Name of the user in the routing list.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
WorkflowDB..::.InitTransaction Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

WorkflowDB Class
WorkflowDB Members
OfficeClip.DBLayer.Framework Namespace


InsertWorkflowDefinition Method

[image]

OfficeClip API Documentation
WorkflowDB..::.InsertWorkflowDefinition Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new workflow definition into the system.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertWorkflowDefinition(
    WorkflowDefinitionInfo wfdi
)
Visual Basic (Declaration)
Public Function InsertWorkflowDefinition ( _
    wfdi As WorkflowDefinitionInfo _
) As Integer
Visual C++
public:
int InsertWorkflowDefinition(
    WorkflowDefinitionInfo^ wfdi
)

Parameters

wfdi
Type: OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowDefinitionInfo
Instance of the workflowDefinitionInfo object containing all the details of the workflow. WorkflowDefinitionInfo

Return Value

Id of the newly created workflow definition when successful, -1 in case of an error.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


InsertWorkflowDefinitionDetailsInfo Method

[image]

OfficeClip API Documentation
WorkflowDB..::.InsertWorkflowDefinitionDetailsInfo Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts an individual workflow definition component into the database.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertWorkflowDefinitionDetailsInfo(
    WorkflowDefinitionDetailsInfo wddi
)
Visual Basic (Declaration)
Public Function InsertWorkflowDefinitionDetailsInfo ( _
    wddi As WorkflowDefinitionDetailsInfo _
) As Integer
Visual C++
public:
int InsertWorkflowDefinitionDetailsInfo(
    WorkflowDefinitionDetailsInfo^ wddi
)

Parameters

wddi
Type: OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowDefinitionDetailsInfo
Instance of the WorkflowDefinitionDetailsInfo object containing all the details of the workflow. WorkflowDefinitionDetailsInfo

Return Value

Id of the newly created workflow definition when successful, -1 in case of an error.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


InsertWorkflowInboxNotificationsInfo Method

[image]

OfficeClip API Documentation
WorkflowDB..::.InsertWorkflowInboxNotificationsInfo Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts an individual workflow notification component into the database.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertWorkflowInboxNotificationsInfo(
    WorkflowInboxNotificationsInfo wini
)
Visual Basic (Declaration)
Public Function InsertWorkflowInboxNotificationsInfo ( _
    wini As WorkflowInboxNotificationsInfo _
) As Integer
Visual C++
public:
int InsertWorkflowInboxNotificationsInfo(
    WorkflowInboxNotificationsInfo^ wini
)

Parameters

wini
Type: OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowInboxNotificationsInfo
Instance of the WorkflowInboxNotificationsInfo object containing notification details of the workflow. WorkflowInboxNotificationsInfo

Return Value

Id of the newly created workflow definition when successful, -1 in case of an error.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


RerouteItemToMe Method

[image]

OfficeClip API Documentation
WorkflowDB..::.RerouteItemToMe Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Reroutes a particular item to a particular group administrator no matter what stage and type of workflow it is in.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RerouteItemToMe(
    int applicationId,
    int id,
    int currentUserId
)
Visual Basic (Declaration)
Public Function RerouteItemToMe ( _
    applicationId As Integer, _
    id As Integer, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int RerouteItemToMe(
    int applicationId,
    int id,
    int currentUserId
)

Parameters

applicationId
Type: System..::.Int32
Id of the application i.e. expense or timesheet.
id
Type: System..::.Int32
Id of the item.
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

0 when successful, -1 in case of an error.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


SetAutoApprovalForUser Method

[image]

OfficeClip API Documentation
WorkflowDB..::.SetAutoApprovalForUser Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the Auto approve option on a Target User for a particular user

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetAutoApprovalForUser(
    int targetUserId,
    int currentUserId,
    int groupId,
    int appId,
    bool isAutoApprove
)
Visual Basic (Declaration)
Public Sub SetAutoApprovalForUser ( _
    targetUserId As Integer, _
    currentUserId As Integer, _
    groupId As Integer, _
    appId As Integer, _
    isAutoApprove As Boolean _
)
Visual C++
public:
void SetAutoApprovalForUser(
    int targetUserId,
    int currentUserId,
    int groupId,
    int appId,
    bool isAutoApprove
)

Parameters

targetUserId
Type: System..::.Int32
the target userid or the userid of the person who has to approve
currentUserId
Type: System..::.Int32
the userid of the user
groupId
Type: System..::.Int32
the groupid
appId
Type: System..::.Int32
the application Id
isAutoApprove
Type: System..::.Boolean
boolean value specifying autoapprove is enabled or not

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


SetAutoApprovalForUserList Method

[image]

OfficeClip API Documentation
WorkflowDB..::.SetAutoApprovalForUserList Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetAutoApprovalForUserList(
    int targetUserId,
    string userlist,
    int groupId,
    int appId,
    bool isAutoApprove
)
Visual Basic (Declaration)
Public Sub SetAutoApprovalForUserList ( _
    targetUserId As Integer, _
    userlist As String, _
    groupId As Integer, _
    appId As Integer, _
    isAutoApprove As Boolean _
)
Visual C++
public:
void SetAutoApprovalForUserList(
    int targetUserId,
    String^ userlist,
    int groupId,
    int appId,
    bool isAutoApprove
)

Parameters

targetUserId
Type: System..::.Int32
userlist
Type: System..::.String
groupId
Type: System..::.Int32
appId
Type: System..::.Int32
isAutoApprove
Type: System..::.Boolean

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
WorkflowDB..::.SetSPCommand Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

WorkflowDB Class
WorkflowDB Members
OfficeClip.DBLayer.Framework Namespace


SetupUserWorkflow Method

[image]

OfficeClip API Documentation
WorkflowDB..::.SetupUserWorkflow Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets a workflow definition in the database.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetupUserWorkflow(
    WorkflowInfo wi,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function SetupUserWorkflow ( _
    wi As WorkflowInfo, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int SetupUserWorkflow(
    WorkflowInfo^ wi,
    ConfigureInfo^ session
)

Parameters

wi
Type: OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowInfo
Instance of the WorkflowInfo object. WorkflowInfo
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

0 when successful, -1 in case of error.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


SetupWorkflowDefinition Method

[image]

OfficeClip API Documentation
WorkflowDB..::.SetupWorkflowDefinition Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets a workflow definition into the database.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetupWorkflowDefinition(
    int applicationId,
    WorkflowType wfType,
    ArrayList userListArr,
    ArrayList routingList,
    ArrayList notificationList,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function SetupWorkflowDefinition ( _
    applicationId As Integer, _
    wfType As WorkflowType, _
    userListArr As ArrayList, _
    routingList As ArrayList, _
    notificationList As ArrayList, _
    currentGroupId As Integer _
) As Integer
Visual C++
public:
int SetupWorkflowDefinition(
    int applicationId,
    WorkflowType wfType,
    ArrayList^ userListArr,
    ArrayList^ routingList,
    ArrayList^ notificationList,
    int currentGroupId
)

Parameters

applicationId
Type: System..::.Int32
Id of the application.
wfType
Type: OfficeClip.Utils..::.WorkflowType
Type of the workflow. WorkflowType
userListArr
Type: System.Collections..::.ArrayList
ArrayList of Ids of the users for whom the workflow has to be defined.
routingList
Type: System.Collections..::.ArrayList
ArrayList of the Ids of the users to whom the item should be routed to.
notificationList
Type: System.Collections..::.ArrayList
ArrayList of WorkflowInboxNotificationsInfo objects containing the notification rules information to be defined in a workflow.
currentGroupId
Type: System..::.Int32
Id of the current organization

Return Value

0 when successful, -1 in case of an error.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


UpdateUserWorkflow Method

[image]

OfficeClip API Documentation
WorkflowDB..::.UpdateUserWorkflow Method
WorkflowDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates a user workflow definition into the database.

Namespace: OfficeClip.DBLayer.Framework
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateUserWorkflow(
    WorkflowInfo wi,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateUserWorkflow ( _
    wi As WorkflowInfo, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int UpdateUserWorkflow(
    WorkflowInfo^ wi,
    ConfigureInfo^ session
)

Parameters

wi
Type: OfficeClip.BusinessLayer.Framework.Workflow..::.WorkflowInfo
Instance of WorkflowInfo object. WorkflowInfo
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

0 when successful, -1 in case of an error.

See Also

WorkflowDB Class
OfficeClip.DBLayer.Framework Namespace


OfficeClip.DBLayer.Metabase Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Metabase Namespace

[This is preliminary documentation and is subject to change.]

Data layer for the OfficeClip metabase

Classes

 | Class | Description
Public class | MetaAdminDB | Meta Administration Class
Public class | MetaDB | Class to manipulate meta information
Public class | MetaFilterDB | Class desription for the metabase filters
Public class | MetaSqlDB | The meta sql database class
Public class | TrackerMetaDB | Class to manipulate meta information


MetaAdminDB Class

[image]

OfficeClip API Documentation
MetaAdminDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Meta Administration Class

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaAdminDB : OfficeClipDB
Visual Basic (Declaration)
Public Class MetaAdminDB _
    Inherits OfficeClipDB
Visual C++
public ref class MetaAdminDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Metabase..::.MetaAdminDB

See Also

MetaAdminDB Members
OfficeClip.DBLayer.Metabase Namespace


MetaAdminDB Members

[image] [image]

OfficeClip API Documentation
MetaAdminDB Members
MetaAdminDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaAdminDB type exposes the following members.

Constructors

 | Name | Description
Public method | MetaAdminDB | Overloaded.

Methods

 | Name | Description
Public method | AddAttribute | Adds an attribute
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertListItem | Inserts the list item
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveAttribute | Moves the attributes up or down
Public method | MoveListItem | Move the list item
Public method | MoveSection | Moves a section up or down
Public method | RemoveAttribute | Removes the attribute
Public method | RemoveListItem | Removes the list item
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SortListItem | Sorts the list item
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAttribute | Updates an attribute parameter
Public method | UpdateListItem | Updates the list item
Public method | UpdateListItemDefault | Updates the list item default

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


MetaAdminDB Constructor

[image] [image]

OfficeClip API Documentation
MetaAdminDB Constructor
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaAdminDB()()() | Constructor
Public method | MetaAdminDB(OfficeClipDB) | Constructor

See Also

MetaAdminDB Class
MetaAdminDB Members
OfficeClip.DBLayer.Metabase Namespace


MetaAdminDB Constructor

[image]

OfficeClip API Documentation
MetaAdminDB Constructor
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaAdminDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaAdminDB()

See Also

MetaAdminDB Class
MetaAdminDB Overload
OfficeClip.DBLayer.Metabase Namespace


MetaAdminDB Constructor (OfficeClipDB)

[image]

OfficeClip API Documentation
MetaAdminDB Constructor (OfficeClipDB)
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaAdminDB(
    OfficeClipDB ma
)
Visual Basic (Declaration)
Public Sub New ( _
    ma As OfficeClipDB _
)
Visual C++
public:
MetaAdminDB(
    OfficeClipDB^ ma
)

Parameters

ma
Type: OfficeClip.DBLayer..::.OfficeClipDB
The base object

See Also

MetaAdminDB Class
MetaAdminDB Overload
OfficeClip.DBLayer.Metabase Namespace


MetaAdminDB Methods

[image] [image]

OfficeClip API Documentation
MetaAdminDB Methods
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

The MetaAdminDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddAttribute | Adds an attribute
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertListItem | Inserts the list item
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveAttribute | Moves the attributes up or down
Public method | MoveListItem | Move the list item
Public method | MoveSection | Moves a section up or down
Public method | RemoveAttribute | Removes the attribute
Public method | RemoveListItem | Removes the list item
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SortListItem | Sorts the list item
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAttribute | Updates an attribute parameter
Public method | UpdateListItem | Updates the list item
Public method | UpdateListItemDefault | Updates the list item default

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


AddAttribute Method

[image]

OfficeClip API Documentation
MetaAdminDB..::.AddAttribute Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds an attribute

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int AddAttribute(
    MetaConstants..::.MetaEntity me,
    int externalId,
    MetaConstants..::.MetaType mt,
    string attributeName,
    int roleId,
    bool isPreferred,
    bool isRequired
)
Visual Basic (Declaration)
Public Function AddAttribute ( _
    me As MetaConstants..::.MetaEntity, _
    externalId As Integer, _
    mt As MetaConstants..::.MetaType, _
    attributeName As String, _
    roleId As Integer, _
    isPreferred As Boolean, _
    isRequired As Boolean _
) As Integer
Visual C++
public:
int AddAttribute(
    MetaConstants..::.MetaEntity me,
    int externalId,
    MetaConstants..::.MetaType mt,
    String^ attributeName,
    int roleId,
    bool isPreferred,
    bool isRequired
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalId
Type: System..::.Int32
The external id , for example the group Id
mt
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaType
The meta type
attributeName
Type: System..::.String
The name of the attribute
roleId
Type: System..::.Int32
The unique id of the role
isPreferred
Type: System..::.Boolean
Is the attribute preferred
isRequired
Type: System..::.Boolean
Is the attribute required

Return Value

The attribute id for the added attribute, negative value if the attribute could not be added

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
MetaAdminDB..::.AddOutputParameter Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

MetaAdminDB Class
MetaAdminDB Members
OfficeClip.DBLayer.Metabase Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
MetaAdminDB..::.AddParameter Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

MetaAdminDB Class
MetaAdminDB Members
OfficeClip.DBLayer.Metabase Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
MetaAdminDB..::.AddParameters Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

MetaAdminDB Class
MetaAdminDB Members
OfficeClip.DBLayer.Metabase Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
MetaAdminDB..::.ExecuteNonQuery Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

MetaAdminDB Class
MetaAdminDB Members
OfficeClip.DBLayer.Metabase Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
MetaAdminDB..::.InitTransaction Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

MetaAdminDB Class
MetaAdminDB Members
OfficeClip.DBLayer.Metabase Namespace


InsertListItem Method

[image]

OfficeClip API Documentation
MetaAdminDB..::.InsertListItem Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the list item

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertListItem(
    int attributeId,
    string listText
)
Visual Basic (Declaration)
Public Function InsertListItem ( _
    attributeId As Integer, _
    listText As String _
) As Integer
Visual C++
public:
int InsertListItem(
    int attributeId,
    String^ listText
)

Parameters

attributeId
Type: System..::.Int32
The unique id of the attribute
listText
Type: System..::.String
The list text

Return Value

the id if successful, -1 if failure, -2 if the name is already present

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


MoveAttribute Method

[image]

OfficeClip API Documentation
MetaAdminDB..::.MoveAttribute Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Moves the attributes up or down

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void MoveAttribute(
    int attributeId,
    bool isUp
)
Visual Basic (Declaration)
Public Sub MoveAttribute ( _
    attributeId As Integer, _
    isUp As Boolean _
)
Visual C++
public:
void MoveAttribute(
    int attributeId,
    bool isUp
)

Parameters

attributeId
Type: System..::.Int32
The unique id of the attribute
isUp
Type: System..::.Boolean
True if the section is to be moved up, false if moved down

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


MoveListItem Method

[image]

OfficeClip API Documentation
MetaAdminDB..::.MoveListItem Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Move the list item

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int MoveListItem(
    int attributeId,
    int listItemId,
    bool isUp
)
Visual Basic (Declaration)
Public Function MoveListItem ( _
    attributeId As Integer, _
    listItemId As Integer, _
    isUp As Boolean _
) As Integer
Visual C++
public:
int MoveListItem(
    int attributeId,
    int listItemId,
    bool isUp
)

Parameters

attributeId
Type: System..::.Int32
The unique id of the attribute
listItemId
Type: System..::.Int32
The id of the list item
isUp
Type: System..::.Boolean
true if the list item is to be moved up

Return Value

negative if failed, else succeeds

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


MoveSection Method

[image]

OfficeClip API Documentation
MetaAdminDB..::.MoveSection Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Moves a section up or down

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void MoveSection(
    int sectionId,
    bool isUp
)
Visual Basic (Declaration)
Public Sub MoveSection ( _
    sectionId As Integer, _
    isUp As Boolean _
)
Visual C++
public:
void MoveSection(
    int sectionId,
    bool isUp
)

Parameters

sectionId
Type: System..::.Int32
The unique id of the section
isUp
Type: System..::.Boolean
True if the section is to be moved up, false if moved down

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


RemoveAttribute Method

[image]

OfficeClip API Documentation
MetaAdminDB..::.RemoveAttribute Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the attribute

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RemoveAttribute(
    MetaConstants..::.MetaEntity me,
    bool isList,
    int externalId,
    int attributeId,
    int currentUserId
)
Visual Basic (Declaration)
Public Function RemoveAttribute ( _
    me As MetaConstants..::.MetaEntity, _
    isList As Boolean, _
    externalId As Integer, _
    attributeId As Integer, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int RemoveAttribute(
    MetaConstants..::.MetaEntity me,
    bool isList,
    int externalId,
    int attributeId,
    int currentUserId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
isList
Type: System..::.Boolean
True if the attribute is a list
externalId
Type: System..::.Int32
The external id
attributeId
Type: System..::.Int32
The unique id of the attribute to be removed
currentUserId
Type: System..::.Int32
Unique id of the logged in user

Return Value

negative value if failed, otherwise successful

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


RemoveListItem Method

[image]

OfficeClip API Documentation
MetaAdminDB..::.RemoveListItem Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the list item

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RemoveListItem(
    MetaConstants..::.MetaEntity me,
    int externalId,
    int attributeId,
    bool isList,
    int listValue,
    int currentUserId
)
Visual Basic (Declaration)
Public Function RemoveListItem ( _
    me As MetaConstants..::.MetaEntity, _
    externalId As Integer, _
    attributeId As Integer, _
    isList As Boolean, _
    listValue As Integer, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int RemoveListItem(
    MetaConstants..::.MetaEntity me,
    int externalId,
    int attributeId,
    bool isList,
    int listValue,
    int currentUserId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalId
Type: System..::.Int32
The external id
attributeId
Type: System..::.Int32
The unique id of the attribute
isList
Type: System..::.Boolean
True if the attribute is a list
listValue
Type: System..::.Int32
The value of the list item
currentUserId
Type: System..::.Int32
Unique id of the logged in user

Return Value

negative if failed, else succeeds

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
MetaAdminDB..::.SetSPCommand Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

MetaAdminDB Class
MetaAdminDB Members
OfficeClip.DBLayer.Metabase Namespace


SortListItem Method

[image]

OfficeClip API Documentation
MetaAdminDB..::.SortListItem Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Sorts the list item

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SortListItem(
    int attributeId,
    bool isDescending
)
Visual Basic (Declaration)
Public Function SortListItem ( _
    attributeId As Integer, _
    isDescending As Boolean _
) As Integer
Visual C++
public:
int SortListItem(
    int attributeId,
    bool isDescending
)

Parameters

attributeId
Type: System..::.Int32
The unique id of the attribute
isDescending
Type: System..::.Boolean
true if the sort is done in the descending order

Return Value

negative if failed, else succeeds

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateAttribute Method

[image]

OfficeClip API Documentation
MetaAdminDB..::.UpdateAttribute Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates an attribute parameter

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateAttribute(
    MetaConstants..::.MetaEntity me,
    int externalId,
    int attributeId,
    string attributeName,
    int roleID,
    bool isPreferred,
    bool isRequired
)
Visual Basic (Declaration)
Public Function UpdateAttribute ( _
    me As MetaConstants..::.MetaEntity, _
    externalId As Integer, _
    attributeId As Integer, _
    attributeName As String, _
    roleID As Integer, _
    isPreferred As Boolean, _
    isRequired As Boolean _
) As Integer
Visual C++
public:
int UpdateAttribute(
    MetaConstants..::.MetaEntity me,
    int externalId,
    int attributeId,
    String^ attributeName,
    int roleID,
    bool isPreferred,
    bool isRequired
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalId
Type: System..::.Int32
The external id, usually the groupid
attributeId
Type: System..::.Int32
The unique id of the attribute
attributeName
Type: System..::.String
The name of the attribute
roleID
Type: System..::.Int32
The unique id of the role
isPreferred
Type: System..::.Boolean
If the attribute is preferred
isRequired
Type: System..::.Boolean
If the attribute is required

Return Value

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateListItem Method

[image]

OfficeClip API Documentation
MetaAdminDB..::.UpdateListItem Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the list item

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateListItem(
    int attributeId,
    int listValue,
    string listText
)
Visual Basic (Declaration)
Public Function UpdateListItem ( _
    attributeId As Integer, _
    listValue As Integer, _
    listText As String _
) As Integer
Visual C++
public:
int UpdateListItem(
    int attributeId,
    int listValue,
    String^ listText
)

Parameters

attributeId
Type: System..::.Int32
The unique id of the attribute
listValue
Type: System..::.Int32
The value of the list item
listText
Type: System..::.String
The text of the list item

Return Value

negative value if failed else succeeds

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateListItemDefault Method

[image]

OfficeClip API Documentation
MetaAdminDB..::.UpdateListItemDefault Method
MetaAdminDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the list item default

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateListItemDefault(
    int attributeId,
    int listItemId
)
Visual Basic (Declaration)
Public Function UpdateListItemDefault ( _
    attributeId As Integer, _
    listItemId As Integer _
) As Integer
Visual C++
public:
int UpdateListItemDefault(
    int attributeId,
    int listItemId
)

Parameters

attributeId
Type: System..::.Int32
The unique id of teh attribute
listItemId
Type: System..::.Int32
The id of the list item

Return Value

negative if failed, else succeed

See Also

MetaAdminDB Class
OfficeClip.DBLayer.Metabase Namespace


MetaDB Class

[image]

OfficeClip API Documentation
MetaDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to manipulate meta information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaDB : OfficeClipDB
Visual Basic (Declaration)
Public Class MetaDB _
    Inherits OfficeClipDB
Visual C++
public ref class MetaDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Metabase..::.MetaDB

See Also

MetaDB Members
OfficeClip.DBLayer.Metabase Namespace


MetaDB Members

[image] [image]

OfficeClip API Documentation
MetaDB Members
MetaDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaDB type exposes the following members.

Constructors

 | Name | Description
Public method | MetaDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | ConvertContact | Converts a Contact to an Account
Public method | Delete | Delete the information
Public method | DeleteContactRoleDetails |
Public method | DeleteMetaRoleInfo |
Public method | DeletePickList | Deletes the pick list
Public method | DeleteRelationDetails |
Public method | DeleteRelationType |
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccessPermission | Gets the access permission object
Public method | GetContactDetails |
Public method | GetContactRoleDetails | Gets the contact roles from the database
Public method | GetContactRoles | Gets the contact roles from the database
Public method | GetDataAll | Gets all the data
Public method | GetDataByFilter | Gets the data by filter
Public method | GetDataByPk | Gets the meta data information by the primary key
Public method | GetDataInfoByPk | Gets the data information by primary key
Public method | GetDataPreferred | Gets the preferred information
Public method | GetDataSearchClause | Get information according to the search clause
Public method | GetEmptyData | Gets an empty metadata
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMetaBase | Gets the information related to the metabase
Public method | GetMetaChildInfo | Gets the data for a child entity
Public method | GetMetaChildObjects | Gets the child objects for the metadata
Public method | GetMetaCustomInfo | Gets the custom information
Public method | GetMetaEmailAddress | Gets the email address
Public method | GetMetaHistory | Gets the meta history information
Public method | GetMetaInfo | Gets data for a specified entity
Public method | GetMetaKeys | Gets the meta keys
Public method | GetMetaListValue | Overloaded.
Public method | GetMetaName | Gets the meta name
Public method | GetMetaOwnerInfo | Gets the meta owner information
Public method | GetMetaParentInfo | Gets the parent information from the metabase
Public method | GetMetaRegardingName | Gets the regarding name from the metabase
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPickList | Gets the picklist information
Public method | GetRelationDetails | Gets the relation type details from the database
Public method | GetRelations | Gets the relation types from the database
Public method | GetRelationTypes | Gets the relation types from the database
Public method | GetSectionInfo | Gets the section information
Public method | GetSectionNames | Get the names of the section
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | Insert | Inserts meta data information
Public method | InsertContactRoleDetails | Gets the contact role name and role id from the database
Public method | InsertMetaRoleInfo | Inserts a new ContactRole into database
Public method | InsertPickList | INserts the picklist
Public method | InsertRelationDetails | Inserts a new Relation into database and returns RelationId
Public method | InsertRelationType | Inserts a new Relation Type into database and returns RelationTypeId
Public method | InsMetaHistory | Inserts the meta history object
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveUnreadableRows | Removes the unreadable rows
Public method | RenameSection | Renames a section
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetMetaOwner | Sets he meta owner
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates the meta infomation
Public method | UpdateContactRoles | Updates the contact roles
Public method | UpdateMetaChildObjects | Updates the meta child object
Public method | UpdateMetaParentInfo | Updates the parent inforamtion from the metabase
Public method | UpdateMetaParentObject | Updates attributes of an entity
Public method | UpdateMetaRoleInfo |
Public method | UpdateRelationDetails | Updates existing Relation into database
Public method | UpdateRelationType | Updates existing Relation Type with RelationTypeId
Public method | UpdateSingleField | Updates a single field

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


MetaDB Constructor

[image] [image]

OfficeClip API Documentation
MetaDB Constructor
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaDB()()() | The constructor
Public method | MetaDB(OfficeClipDB) | The constructor

See Also

MetaDB Class
MetaDB Members
OfficeClip.DBLayer.Metabase Namespace


MetaDB Constructor

[image]

OfficeClip API Documentation
MetaDB Constructor
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

The constructor

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaDB()

See Also

MetaDB Class
MetaDB Overload
OfficeClip.DBLayer.Metabase Namespace


MetaDB Constructor (OfficeClipDB)

[image]

OfficeClip API Documentation
MetaDB Constructor (OfficeClipDB)
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

The constructor

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaDB(
    OfficeClipDB ma
)
Visual Basic (Declaration)
Public Sub New ( _
    ma As OfficeClipDB _
)
Visual C++
public:
MetaDB(
    OfficeClipDB^ ma
)

Parameters

ma
Type: OfficeClip.DBLayer..::.OfficeClipDB
The base object

See Also

MetaDB Class
MetaDB Overload
OfficeClip.DBLayer.Metabase Namespace


MetaDB Methods

[image] [image]

OfficeClip API Documentation
MetaDB Methods
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

The MetaDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | ConvertContact | Converts a Contact to an Account
Public method | Delete | Delete the information
Public method | DeleteContactRoleDetails |
Public method | DeleteMetaRoleInfo |
Public method | DeletePickList | Deletes the pick list
Public method | DeleteRelationDetails |
Public method | DeleteRelationType |
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccessPermission | Gets the access permission object
Public method | GetContactDetails |
Public method | GetContactRoleDetails | Gets the contact roles from the database
Public method | GetContactRoles | Gets the contact roles from the database
Public method | GetDataAll | Gets all the data
Public method | GetDataByFilter | Gets the data by filter
Public method | GetDataByPk | Gets the meta data information by the primary key
Public method | GetDataInfoByPk | Gets the data information by primary key
Public method | GetDataPreferred | Gets the preferred information
Public method | GetDataSearchClause | Get information according to the search clause
Public method | GetEmptyData | Gets an empty metadata
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMetaBase | Gets the information related to the metabase
Public method | GetMetaChildInfo | Gets the data for a child entity
Public method | GetMetaChildObjects | Gets the child objects for the metadata
Public method | GetMetaCustomInfo | Gets the custom information
Public method | GetMetaEmailAddress | Gets the email address
Public method | GetMetaHistory | Gets the meta history information
Public method | GetMetaInfo | Gets data for a specified entity
Public method | GetMetaKeys | Gets the meta keys
Public method | GetMetaListValue | Overloaded.
Public method | GetMetaName | Gets the meta name
Public method | GetMetaOwnerInfo | Gets the meta owner information
Public method | GetMetaParentInfo | Gets the parent information from the metabase
Public method | GetMetaRegardingName | Gets the regarding name from the metabase
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPickList | Gets the picklist information
Public method | GetRelationDetails | Gets the relation type details from the database
Public method | GetRelations | Gets the relation types from the database
Public method | GetRelationTypes | Gets the relation types from the database
Public method | GetSectionInfo | Gets the section information
Public method | GetSectionNames | Get the names of the section
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | Insert | Inserts meta data information
Public method | InsertContactRoleDetails | Gets the contact role name and role id from the database
Public method | InsertMetaRoleInfo | Inserts a new ContactRole into database
Public method | InsertPickList | INserts the picklist
Public method | InsertRelationDetails | Inserts a new Relation into database and returns RelationId
Public method | InsertRelationType | Inserts a new Relation Type into database and returns RelationTypeId
Public method | InsMetaHistory | Inserts the meta history object
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveUnreadableRows | Removes the unreadable rows
Public method | RenameSection | Renames a section
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetMetaOwner | Sets he meta owner
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates the meta infomation
Public method | UpdateContactRoles | Updates the contact roles
Public method | UpdateMetaChildObjects | Updates the meta child object
Public method | UpdateMetaParentInfo | Updates the parent inforamtion from the metabase
Public method | UpdateMetaParentObject | Updates attributes of an entity
Public method | UpdateMetaRoleInfo |
Public method | UpdateRelationDetails | Updates existing Relation into database
Public method | UpdateRelationType | Updates existing Relation Type with RelationTypeId
Public method | UpdateSingleField | Updates a single field

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
MetaDB..::.AddOutputParameter Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

MetaDB Class
MetaDB Members
OfficeClip.DBLayer.Metabase Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
MetaDB..::.AddParameter Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

MetaDB Class
MetaDB Members
OfficeClip.DBLayer.Metabase Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
MetaDB..::.AddParameters Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

MetaDB Class
MetaDB Members
OfficeClip.DBLayer.Metabase Namespace


ConvertContact Method

[image]

OfficeClip API Documentation
MetaDB..::.ConvertContact Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Converts a Contact to an Account

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ConvertContact(
    MetaConstants..::.MetaEntity me,
    int metaId,
    int primaryKey,
    int currentUserId
)
Visual Basic (Declaration)
Public Function ConvertContact ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer, _
    primaryKey As Integer, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int ConvertContact(
    MetaConstants..::.MetaEntity me,
    int metaId,
    int primaryKey,
    int currentUserId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
metaId
Type: System..::.Int32
primaryKey
Type: System..::.Int32
currentUserId
Type: System..::.Int32
Unique id of the current user

Return Value

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


Delete Method

[image]

OfficeClip API Documentation
MetaDB..::.Delete Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Delete the information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Delete(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    int pkId
)
Visual Basic (Declaration)
Public Function Delete ( _
    me As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    pkId As Integer _
) As Integer
Visual C++
public:
int Delete(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    int pkId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external key id
pkId
Type: System..::.Int32
The primary key id

Return Value

negative value if failed, else succeeded

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


DeleteContactRoleDetails Method

[image]

OfficeClip API Documentation
MetaDB..::.DeleteContactRoleDetails Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteContactRoleDetails(
    int objectTypeId,
    int objectId,
    int contactId
)
Visual Basic (Declaration)
Public Sub DeleteContactRoleDetails ( _
    objectTypeId As Integer, _
    objectId As Integer, _
    contactId As Integer _
)
Visual C++
public:
void DeleteContactRoleDetails(
    int objectTypeId,
    int objectId,
    int contactId
)

Parameters

objectTypeId
Type: System..::.Int32
objectId
Type: System..::.Int32
contactId
Type: System..::.Int32

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


DeleteMetaRoleInfo Method

[image]

OfficeClip API Documentation
MetaDB..::.DeleteMetaRoleInfo Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteMetaRoleInfo(
    int contactRoleId
)
Visual Basic (Declaration)
Public Sub DeleteMetaRoleInfo ( _
    contactRoleId As Integer _
)
Visual C++
public:
void DeleteMetaRoleInfo(
    int contactRoleId
)

Parameters

contactRoleId
Type: System..::.Int32

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


DeletePickList Method

[image]

OfficeClip API Documentation
MetaDB..::.DeletePickList Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the pick list

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeletePickList(
    int picklistId
)
Visual Basic (Declaration)
Public Sub DeletePickList ( _
    picklistId As Integer _
)
Visual C++
public:
void DeletePickList(
    int picklistId
)

Parameters

picklistId
Type: System..::.Int32
The id of the picklist

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


DeleteRelationDetails Method

[image]

OfficeClip API Documentation
MetaDB..::.DeleteRelationDetails Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteRelationDetails(
    int relationId
)
Visual Basic (Declaration)
Public Sub DeleteRelationDetails ( _
    relationId As Integer _
)
Visual C++
public:
void DeleteRelationDetails(
    int relationId
)

Parameters

relationId
Type: System..::.Int32

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


DeleteRelationType Method

[image]

OfficeClip API Documentation
MetaDB..::.DeleteRelationType Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteRelationType(
    int relationTypeId
)
Visual Basic (Declaration)
Public Sub DeleteRelationType ( _
    relationTypeId As Integer _
)
Visual C++
public:
void DeleteRelationType(
    int relationTypeId
)

Parameters

relationTypeId
Type: System..::.Int32

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
MetaDB..::.ExecuteNonQuery Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

MetaDB Class
MetaDB Members
OfficeClip.DBLayer.Metabase Namespace


GetAccessPermission Method

[image]

OfficeClip API Documentation
MetaDB..::.GetAccessPermission Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the access permission object

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObject GetAccessPermission(
    MetaConstants..::.MetaEntity me,
    int pkId,
    int currentUserId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function GetAccessPermission ( _
    me As MetaConstants..::.MetaEntity, _
    pkId As Integer, _
    currentUserId As Integer, _
    currentGroupId As Integer _
) As SecurityObject
Visual C++
public:
SecurityObject^ GetAccessPermission(
    MetaConstants..::.MetaEntity me,
    int pkId,
    int currentUserId,
    int currentGroupId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity id
pkId
Type: System..::.Int32
The primary key
currentUserId
Type: System..::.Int32
Unique id of the current user
currentGroupId
Type: System..::.Int32
Unique id of the current group

Return Value

The access permission object

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetContactDetails Method

[image]

OfficeClip API Documentation
MetaDB..::.GetContactDetails Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetContactDetails(
    int groupId
)
Visual Basic (Declaration)
Public Function GetContactDetails ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetContactDetails(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetContactRoleDetails Method

[image]

OfficeClip API Documentation
MetaDB..::.GetContactRoleDetails Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the contact roles from the database

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<ContactRoleDetail> GetContactRoleDetails(
    MetaConstants..::.MetaEntity me,
    int metaId
)
Visual Basic (Declaration)
Public Function GetContactRoleDetails ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer _
) As List(Of ContactRoleDetail)
Visual C++
public:
List<ContactRoleDetail^>^ GetContactRoleDetails(
    MetaConstants..::.MetaEntity me,
    int metaId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
metaId
Type: System..::.Int32

Return Value

The list of contact roles

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetContactRoles Method

[image]

OfficeClip API Documentation
MetaDB..::.GetContactRoles Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the contact roles from the database

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<RoleInfo> GetContactRoles(
    int orgId
)
Visual Basic (Declaration)
Public Function GetContactRoles ( _
    orgId As Integer _
) As List(Of RoleInfo)
Visual C++
public:
List<RoleInfo^>^ GetContactRoles(
    int orgId
)

Parameters

orgId
Type: System..::.Int32
The unique id of the organization

Return Value

The list of contact roles

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetDataAll Method

[image]

OfficeClip API Documentation
MetaDB..::.GetDataAll Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the data

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetDataAll(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function GetDataAll ( _
    me As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    session As ConfigureInfo _
) As DataSet
Visual C++
public:
DataSet^ GetDataAll(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    ConfigureInfo^ session
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external key id, mostly group id
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The dataset of all the meta information

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetDataByFilter Method

[image]

OfficeClip API Documentation
MetaDB..::.GetDataByFilter Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the data by filter

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetDataByFilter(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    int id,
    int orderId,
    bool isDescending,
    bool isReport,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function GetDataByFilter ( _
    me As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    id As Integer, _
    orderId As Integer, _
    isDescending As Boolean, _
    isReport As Boolean, _
    session As ConfigureInfo _
) As DataSet
Visual C++
public:
DataSet^ GetDataByFilter(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    int id,
    int orderId,
    bool isDescending,
    bool isReport,
    ConfigureInfo^ session
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external id, usually the group id
id
Type: System..::.Int32
The unique id
orderId
Type: System..::.Int32
The order id
isDescending
Type: System..::.Boolean
if the returned resultset is arranged in the descending order
isReport
Type: System..::.Boolean
If the dataset is for the report
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The returned dataset

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetDataByPk Method

[image]

OfficeClip API Documentation
MetaDB..::.GetDataByPk Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta data information by the primary key

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetDataByPk(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    int pkId,
    bool IsReadOnly,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function GetDataByPk ( _
    ma As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    pkId As Integer, _
    IsReadOnly As Boolean, _
    session As ConfigureInfo _
) As DataSet
Visual C++
public:
DataSet^ GetDataByPk(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    int pkId,
    bool IsReadOnly,
    ConfigureInfo^ session
)

Parameters

ma
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity id
externalKeyId
Type: System..::.Int32
The external key id
pkId
Type: System..::.Int32
The primary key id
IsReadOnly
Type: System..::.Boolean
True if the data is read only
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The processed meta data

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetDataInfoByPk Method

[image]

OfficeClip API Documentation
MetaDB..::.GetDataInfoByPk Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the data information by primary key

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaInfoCollection GetDataInfoByPk(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    int pkId,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function GetDataInfoByPk ( _
    ma As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    pkId As Integer, _
    session As ConfigureInfo _
) As MetaInfoCollection
Visual C++
public:
MetaInfoCollection^ GetDataInfoByPk(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    int pkId,
    ConfigureInfo^ session
)

Parameters

ma
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external key id
pkId
Type: System..::.Int32
The primary key id
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The meta information collection

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetDataPreferred Method

[image]

OfficeClip API Documentation
MetaDB..::.GetDataPreferred Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the preferred information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetDataPreferred(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    int rows,
    int orderId,
    bool isDescending,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function GetDataPreferred ( _
    ma As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    rows As Integer, _
    orderId As Integer, _
    isDescending As Boolean, _
    session As ConfigureInfo _
) As DataSet
Visual C++
public:
DataSet^ GetDataPreferred(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    int rows,
    int orderId,
    bool isDescending,
    ConfigureInfo^ session
)

Parameters

ma
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entiy
externalKeyId
Type: System..::.Int32
The external key id, usually group id
rows
Type: System..::.Int32
The number of rows to be returned
orderId
Type: System..::.Int32
The order id
isDescending
Type: System..::.Boolean
Shows if the information is sorted in the descending order
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The returned dataset

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetDataSearchClause Method

[image]

OfficeClip API Documentation
MetaDB..::.GetDataSearchClause Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Get information according to the search clause

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetDataSearchClause(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    int rows,
    int orderId,
    bool isDescending,
    string searchStr,
    int searchId,
    ConfigureInfo session,
    int filterId
)
Visual Basic (Declaration)
Public Function GetDataSearchClause ( _
    ma As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    rows As Integer, _
    orderId As Integer, _
    isDescending As Boolean, _
    searchStr As String, _
    searchId As Integer, _
    session As ConfigureInfo, _
    filterId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetDataSearchClause(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    int rows,
    int orderId,
    bool isDescending,
    String^ searchStr,
    int searchId,
    ConfigureInfo^ session,
    int filterId
)

Parameters

ma
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external key id
rows
Type: System..::.Int32
The number of rows
orderId
Type: System..::.Int32
The order id
isDescending
Type: System..::.Boolean
if the result will be sorted in the descending order
searchStr
Type: System..::.String
The search string
searchId
Type: System..::.Int32
The unique search id
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session
filterId
Type: System..::.Int32

Return Value

The result dataset

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetEmptyData Method

[image]

OfficeClip API Documentation
MetaDB..::.GetEmptyData Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets an empty metadata

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetEmptyData(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    bool isAllEditable,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function GetEmptyData ( _
    ma As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    isAllEditable As Boolean, _
    session As ConfigureInfo _
) As DataSet
Visual C++
public:
DataSet^ GetEmptyData(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    bool isAllEditable,
    ConfigureInfo^ session
)

Parameters

ma
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity for which the data is sought
externalKeyId
Type: System..::.Int32
The group id
isAllEditable
Type: System..::.Boolean
true if all the fields are editable, false if the editable restriction is inplace. Editable restriction can happen when somebody changes that restriction via the admin
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The empty meta data

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaBase Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaBase Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the information related to the metabase

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetMetaBase(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId
)
Visual Basic (Declaration)
Public Function GetMetaBase ( _
    ma As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetMetaBase(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId
)

Parameters

ma
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity value
externalKeyId
Type: System..::.Int32
The external key id, usually the group id

Return Value

The information related to the metabase

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaChildInfo Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaChildInfo Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the data for a child entity

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetMetaChildInfo(
    MetaConstants..::.MetaEntity me,
    int childentityId,
    int metaId,
    int objectId
)
Visual Basic (Declaration)
Public Function GetMetaChildInfo ( _
    me As MetaConstants..::.MetaEntity, _
    childentityId As Integer, _
    metaId As Integer, _
    objectId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetMetaChildInfo(
    MetaConstants..::.MetaEntity me,
    int childentityId,
    int metaId,
    int objectId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
childentityId
Type: System..::.Int32
metaId
Type: System..::.Int32
objectId
Type: System..::.Int32

Return Value

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaChildObjects Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaChildObjects Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the child objects for the metadata

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<BusinessConstants..::.ObjectType> GetMetaChildObjects(
    MetaConstants..::.MetaEntity me,
    int metaId
)
Visual Basic (Declaration)
Public Function GetMetaChildObjects ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer _
) As List(Of BusinessConstants..::.ObjectType)
Visual C++
public:
List<BusinessConstants..::.ObjectType>^ GetMetaChildObjects(
    MetaConstants..::.MetaEntity me,
    int metaId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
metaId
Type: System..::.Int32
The unique meta id, usually the group id

Return Value

The list of the child objects

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaCustomInfo Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaCustomInfo Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the custom information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetMetaCustomInfo(
    int attributeId
)
Visual Basic (Declaration)
Public Function GetMetaCustomInfo ( _
    attributeId As Integer _
) As String
Visual C++
public:
String^ GetMetaCustomInfo(
    int attributeId
)

Parameters

attributeId
Type: System..::.Int32
The unique id of the attribute

Return Value

The custom information

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaEmailAddress Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaEmailAddress Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the email address

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetMetaEmailAddress(
    int entityId,
    int primaryKey
)
Visual Basic (Declaration)
Public Function GetMetaEmailAddress ( _
    entityId As Integer, _
    primaryKey As Integer _
) As String
Visual C++
public:
String^ GetMetaEmailAddress(
    int entityId,
    int primaryKey
)

Parameters

entityId
Type: System..::.Int32
The unique id of the entity
primaryKey
Type: System..::.Int32
the primary key

Return Value

The custom information

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaHistory Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaHistory Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta history information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetMetaHistory(
    MetaConstants..::.MetaEntity me,
    int pkId
)
Visual Basic (Declaration)
Public Function GetMetaHistory ( _
    me As MetaConstants..::.MetaEntity, _
    pkId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetMetaHistory(
    MetaConstants..::.MetaEntity me,
    int pkId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
pkId
Type: System..::.Int32
The primary key id

Return Value

The dataset of the history information

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaInfo Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaInfo Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets data for a specified entity

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetMetaInfo(
    MetaConstants..::.MetaEntity me,
    int metaId,
    int primaryKey
)
Visual Basic (Declaration)
Public Function GetMetaInfo ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer, _
    primaryKey As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetMetaInfo(
    MetaConstants..::.MetaEntity me,
    int metaId,
    int primaryKey
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
metaId
Type: System..::.Int32
primaryKey
Type: System..::.Int32

Return Value

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaKeys Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaKeys Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta keys

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetMetaKeys(
    MetaConstants..::.MetaEntity me,
    int metaId
)
Visual Basic (Declaration)
Public Function GetMetaKeys ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetMetaKeys(
    MetaConstants..::.MetaEntity me,
    int metaId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
metaId
Type: System..::.Int32
The meta id

Return Value

returns the meta keys

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaListValue Method

[image] [image]

OfficeClip API Documentation
MetaDB..::.GetMetaListValue Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetMetaListValue(MetaConstants..::.MetaEntity, Int32) | Gets the meta list value
Public method | GetMetaListValue(MetaConstants..::.MetaEntity, Int32, Int32) | Gets the meta list value

See Also

MetaDB Class
MetaDB Members
OfficeClip.DBLayer.Metabase Namespace


GetMetaListValue Method (MetaConstants.MetaEntity, Int32)

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaListValue Method (MetaConstants..::.MetaEntity, Int32)
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta list value

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetMetaListValue(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId
)
Visual Basic (Declaration)
Public Function GetMetaListValue ( _
    ma As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetMetaListValue(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId
)

Parameters

ma
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external key id

Return Value

The meta entity list values

See Also

MetaDB Class
GetMetaListValue Overload
OfficeClip.DBLayer.Metabase Namespace


GetMetaListValue Method (MetaConstants.MetaEntity, Int32, Int32)

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaListValue Method (MetaConstants..::.MetaEntity, Int32, Int32)
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta list value

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetMetaListValue(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    int attributeId
)
Visual Basic (Declaration)
Public Function GetMetaListValue ( _
    ma As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    attributeId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetMetaListValue(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    int attributeId
)

Parameters

ma
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external key id
attributeId
Type: System..::.Int32
The unique id of the attribute

Return Value

The meta entity list values

See Also

MetaDB Class
GetMetaListValue Overload
OfficeClip.DBLayer.Metabase Namespace


GetMetaName Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaName Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta name

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetMetaName(
    MetaConstants..::.MetaEntity me,
    int primaryKey
)
Visual Basic (Declaration)
Public Function GetMetaName ( _
    me As MetaConstants..::.MetaEntity, _
    primaryKey As Integer _
) As String
Visual C++
public:
String^ GetMetaName(
    MetaConstants..::.MetaEntity me,
    int primaryKey
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
primaryKey
Type: System..::.Int32
The unique primary id

Return Value

The meta name

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaOwnerInfo Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaOwnerInfo Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta owner information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetMetaOwnerInfo(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    int pkId
)
Visual Basic (Declaration)
Public Function GetMetaOwnerInfo ( _
    me As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    pkId As Integer _
) As DataView
Visual C++
public:
DataView^ GetMetaOwnerInfo(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    int pkId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external key id
pkId
Type: System..::.Int32
The primary key id

Return Value

The meta owner infomation

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaParentInfo Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaParentInfo Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the parent information from the metabase

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetMetaParentInfo(
    MetaConstants..::.MetaEntity me,
    int metaId,
    int pkId,
    ref BusinessConstants..::.ObjectType parentType,
    ref int objectId
)
Visual Basic (Declaration)
Public Sub GetMetaParentInfo ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer, _
    pkId As Integer, _
    ByRef parentType As BusinessConstants..::.ObjectType, _
    ByRef objectId As Integer _
)
Visual C++
public:
void GetMetaParentInfo(
    MetaConstants..::.MetaEntity me,
    int metaId,
    int pkId,
    BusinessConstants..::.ObjectType% parentType,
    int% objectId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
metaId
Type: System..::.Int32
pkId
Type: System..::.Int32
parentType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType %
objectId
Type: System..::.Int32%

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaRegardingName Method

[image]

OfficeClip API Documentation
MetaDB..::.GetMetaRegardingName Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the regarding name from the metabase

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetMetaRegardingName(
    BusinessConstants..::.ObjectType oType,
    int objectId
)
Visual Basic (Declaration)
Public Function GetMetaRegardingName ( _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer _
) As String
Visual C++
public:
String^ GetMetaRegardingName(
    BusinessConstants..::.ObjectType oType,
    int objectId
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
objectId
Type: System..::.Int32

Return Value

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetPickList Method

[image]

OfficeClip API Documentation
MetaDB..::.GetPickList Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the picklist information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPickList(
    int attributeId,
    string searchStr
)
Visual Basic (Declaration)
Public Function GetPickList ( _
    attributeId As Integer, _
    searchStr As String _
) As DataSet
Visual C++
public:
DataSet^ GetPickList(
    int attributeId,
    String^ searchStr
)

Parameters

attributeId
Type: System..::.Int32
The unique id of the attribute
searchStr
Type: System..::.String
The search string

Return Value

The picklist information

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetRelationDetails Method

[image]

OfficeClip API Documentation
MetaDB..::.GetRelationDetails Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the relation type details from the database

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public Relation GetRelationDetails(
    int relationId
)
Visual Basic (Declaration)
Public Function GetRelationDetails ( _
    relationId As Integer _
) As Relation
Visual C++
public:
Relation^ GetRelationDetails(
    int relationId
)

Parameters

relationId
Type: System..::.Int32
The unique id of the Relation

Return Value

The Relation Type Object

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetRelations Method

[image]

OfficeClip API Documentation
MetaDB..::.GetRelations Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the relation types from the database

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<Relation> GetRelations(
    int parentObjectTypeId,
    int parentObjectId
)
Visual Basic (Declaration)
Public Function GetRelations ( _
    parentObjectTypeId As Integer, _
    parentObjectId As Integer _
) As List(Of Relation)
Visual C++
public:
List<Relation^>^ GetRelations(
    int parentObjectTypeId,
    int parentObjectId
)

Parameters

parentObjectTypeId
Type: System..::.Int32
parentObjectId
Type: System..::.Int32

Return Value

The list of Relation Types

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetRelationTypes Method

[image]

OfficeClip API Documentation
MetaDB..::.GetRelationTypes Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the relation types from the database

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<RelationType> GetRelationTypes(
    int groupId
)
Visual Basic (Declaration)
Public Function GetRelationTypes ( _
    groupId As Integer _
) As List(Of RelationType)
Visual C++
public:
List<RelationType^>^ GetRelationTypes(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the organization

Return Value

The list of Relation Types

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetSectionInfo Method

[image]

OfficeClip API Documentation
MetaDB..::.GetSectionInfo Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the section information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetSectionInfo(
    MetaConstants..::.MetaEntity me,
    int metaId
)
Visual Basic (Declaration)
Public Function GetSectionInfo ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetSectionInfo(
    MetaConstants..::.MetaEntity me,
    int metaId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
metaId
Type: System..::.Int32
The id of the section

Return Value

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetSectionNames Method

[image]

OfficeClip API Documentation
MetaDB..::.GetSectionNames Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the names of the section

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetSectionNames(
    MetaConstants..::.MetaEntity me,
    int metaId,
    ref string section1,
    ref string section2,
    ref string section3,
    ref string section4
)
Visual Basic (Declaration)
Public Function GetSectionNames ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer, _
    ByRef section1 As String, _
    ByRef section2 As String, _
    ByRef section3 As String, _
    ByRef section4 As String _
) As Integer
Visual C++
public:
int GetSectionNames(
    MetaConstants..::.MetaEntity me,
    int metaId,
    String^% section1,
    String^% section2,
    String^% section3,
    String^% section4
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
metaId
Type: System..::.Int32
The meta id, usually the group id
section1
Type: System..::.String%
The name of the first section
section2
Type: System..::.String%
The name of the second section
section3
Type: System..::.String%
The name of the third section
section4
Type: System..::.String%
The name of the fourth section

Return Value

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
MetaDB..::.InitTransaction Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

MetaDB Class
MetaDB Members
OfficeClip.DBLayer.Metabase Namespace


Insert Method

[image]

OfficeClip API Documentation
MetaDB..::.Insert Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts meta data information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Insert(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    Hashtable vals,
    int currentUserId,
    out DateTime lastUpdatedTime
)
Visual Basic (Declaration)
Public Function Insert ( _
    ma As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    vals As Hashtable, _
    currentUserId As Integer, _
    <OutAttribute> ByRef lastUpdatedTime As DateTime _
) As Integer
Visual C++
public:
int Insert(
    MetaConstants..::.MetaEntity ma,
    int externalKeyId,
    Hashtable^ vals,
    int currentUserId,
    [OutAttribute] DateTime% lastUpdatedTime
)

Parameters

ma
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external key id, usually the group id
vals
Type: System.Collections..::.Hashtable
The hashtable of key value pair for each attribute
currentUserId
Type: System..::.Int32
Unique id of the current user
lastUpdatedTime
Type: System..::.DateTime%
The last updated time

Return Value

The unique id of the inserted information, negative if failed

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


InsertContactRoleDetails Method

[image]

OfficeClip API Documentation
MetaDB..::.InsertContactRoleDetails Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the contact role name and role id from the database

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertContactRoleDetails(
    List<ContactRoleDetail> cList,
    int objectType,
    int objectId
)
Visual Basic (Declaration)
Public Sub InsertContactRoleDetails ( _
    cList As List(Of ContactRoleDetail), _
    objectType As Integer, _
    objectId As Integer _
)
Visual C++
public:
void InsertContactRoleDetails(
    List<ContactRoleDetail^>^ cList,
    int objectType,
    int objectId
)

Parameters

cList
Type: System.Collections.Generic..::.List<(Of <( ContactRoleDetail >)>)
objectType
Type: System..::.Int32
objectId
Type: System..::.Int32

Return Value

The list of contact roles with their ids

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


InsertMetaRoleInfo Method

[image]

OfficeClip API Documentation
MetaDB..::.InsertMetaRoleInfo Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new ContactRole into database

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertMetaRoleInfo(
    int orgId,
    string roleName
)
Visual Basic (Declaration)
Public Sub InsertMetaRoleInfo ( _
    orgId As Integer, _
    roleName As String _
)
Visual C++
public:
void InsertMetaRoleInfo(
    int orgId,
    String^ roleName
)

Parameters

orgId
Type: System..::.Int32
roleName
Type: System..::.String

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


InsertPickList Method

[image]

OfficeClip API Documentation
MetaDB..::.InsertPickList Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

INserts the picklist

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertPickList(
    int attributeId,
    string name
)
Visual Basic (Declaration)
Public Function InsertPickList ( _
    attributeId As Integer, _
    name As String _
) As Integer
Visual C++
public:
int InsertPickList(
    int attributeId,
    String^ name
)

Parameters

attributeId
Type: System..::.Int32
The unique id of the attribute
name
Type: System..::.String
The attribute name

Return Value

The id of the entered picklist, negative if failed

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


InsertRelationDetails Method

[image]

OfficeClip API Documentation
MetaDB..::.InsertRelationDetails Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new Relation into database and returns RelationId

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertRelationDetails(
    Relation rType
)
Visual Basic (Declaration)
Public Function InsertRelationDetails ( _
    rType As Relation _
) As Integer
Visual C++
public:
int InsertRelationDetails(
    Relation^ rType
)

Parameters

rType
Type: OfficeClip.BusinessLayer.Metabase..::.Relation

Return Value

RelationId

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


InsertRelationType Method

[image]

OfficeClip API Documentation
MetaDB..::.InsertRelationType Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new Relation Type into database and returns RelationTypeId

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertRelationType(
    RelationType rType
)
Visual Basic (Declaration)
Public Function InsertRelationType ( _
    rType As RelationType _
) As Integer
Visual C++
public:
int InsertRelationType(
    RelationType^ rType
)

Parameters

rType
Type: OfficeClip.BusinessLayer.Metabase..::.RelationType

Return Value

RelationTyeId

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


InsMetaHistory Method

[image]

OfficeClip API Documentation
MetaDB..::.InsMetaHistory Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the meta history object

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsMetaHistory(
    BusinessConstants..::.ObjectType parentObjectType,
    int parentId,
    MetaConstants..::.MetaEntity childEntity,
    MetaConstants..::.MetaHistoryState action,
    string title,
    string description,
    int userId,
    DateTime dt
)
Visual Basic (Declaration)
Public Sub InsMetaHistory ( _
    parentObjectType As BusinessConstants..::.ObjectType, _
    parentId As Integer, _
    childEntity As MetaConstants..::.MetaEntity, _
    action As MetaConstants..::.MetaHistoryState, _
    title As String, _
    description As String, _
    userId As Integer, _
    dt As DateTime _
)
Visual C++
public:
void InsMetaHistory(
    BusinessConstants..::.ObjectType parentObjectType,
    int parentId,
    MetaConstants..::.MetaEntity childEntity,
    MetaConstants..::.MetaHistoryState action,
    String^ title,
    String^ description,
    int userId,
    DateTime dt
)

Parameters

parentObjectType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type of the parent
parentId
Type: System..::.Int32
The unique id of the parent
childEntity
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The child entity
action
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaHistoryState
the meta history state for the action
title
Type: System..::.String
The history title
description
Type: System..::.String
The history description
userId
Type: System..::.Int32
The unique id of the object
dt
Type: System..::.DateTime
The datetime

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


RemoveUnreadableRows Method

[image]

OfficeClip API Documentation
MetaDB..::.RemoveUnreadableRows Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the unreadable rows

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void RemoveUnreadableRows(
    MetaConstants..::.MetaEntity me,
    ref DataSet ds,
    ref DataView dview,
    int tableNum,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Sub RemoveUnreadableRows ( _
    me As MetaConstants..::.MetaEntity, _
    ByRef ds As DataSet, _
    ByRef dview As DataView, _
    tableNum As Integer, _
    session As ConfigureInfo _
)
Visual C++
public:
void RemoveUnreadableRows(
    MetaConstants..::.MetaEntity me,
    DataSet^% ds,
    DataView^% dview,
    int tableNum,
    ConfigureInfo^ session
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
ds
Type: System.Data..::.DataSet%
The dataset
dview
Type: System.Data..::.DataView%
The dataview
tableNum
Type: System..::.Int32
The table number
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


RenameSection Method

[image]

OfficeClip API Documentation
MetaDB..::.RenameSection Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Renames a section

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int RenameSection(
    MetaConstants..::.MetaEntity me,
    int metaId,
    string section1,
    string section2,
    string section3,
    string section4
)
Visual Basic (Declaration)
Public Function RenameSection ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer, _
    section1 As String, _
    section2 As String, _
    section3 As String, _
    section4 As String _
) As Integer
Visual C++
public:
int RenameSection(
    MetaConstants..::.MetaEntity me,
    int metaId,
    String^ section1,
    String^ section2,
    String^ section3,
    String^ section4
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
metaId
Type: System..::.Int32
The meta id, usually the group id
section1
Type: System..::.String
The name of the first section
section2
Type: System..::.String
The name of the second section
section3
Type: System..::.String
The name of the third section
section4
Type: System..::.String
The name of the fourth section

Return Value

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


SetMetaOwner Method

[image]

OfficeClip API Documentation
MetaDB..::.SetMetaOwner Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets he meta owner

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetMetaOwner(
    MetaConstants..::.MetaEntity me,
    int metaId,
    int pkId,
    int ownerId,
    int oldOwnerId,
    string attributeName,
    string ownerName,
    int currentUserId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Sub SetMetaOwner ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer, _
    pkId As Integer, _
    ownerId As Integer, _
    oldOwnerId As Integer, _
    attributeName As String, _
    ownerName As String, _
    currentUserId As Integer, _
    currentGroupId As Integer _
)
Visual C++
public:
void SetMetaOwner(
    MetaConstants..::.MetaEntity me,
    int metaId,
    int pkId,
    int ownerId,
    int oldOwnerId,
    String^ attributeName,
    String^ ownerName,
    int currentUserId,
    int currentGroupId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
metaId
Type: System..::.Int32
The meta id , usually the group id
pkId
Type: System..::.Int32
The unique primary key id
ownerId
Type: System..::.Int32
The unique id of the owner ofthe information
oldOwnerId
Type: System..::.Int32
The id of the previous owner
attributeName
Type: System..::.String
The name of the attribute
ownerName
Type: System..::.String
The name of the owner
currentUserId
Type: System..::.Int32
Unique id of the current user
currentGroupId
Type: System..::.Int32
Unique id of the current group

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
MetaDB..::.SetSPCommand Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

MetaDB Class
MetaDB Members
OfficeClip.DBLayer.Metabase Namespace


Update Method

[image]

OfficeClip API Documentation
MetaDB..::.Update Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the meta infomation

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Update(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    int pkId,
    Hashtable vals,
    ConfigureInfo session,
    out DateTime lastUpdatedTime
)
Visual Basic (Declaration)
Public Function Update ( _
    me As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    pkId As Integer, _
    vals As Hashtable, _
    session As ConfigureInfo, _
    <OutAttribute> ByRef lastUpdatedTime As DateTime _
) As Integer
Visual C++
public:
int Update(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    int pkId,
    Hashtable^ vals,
    ConfigureInfo^ session,
    [OutAttribute] DateTime% lastUpdatedTime
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The metaentity
externalKeyId
Type: System..::.Int32
The external key id
pkId
Type: System..::.Int32
The primary key id
vals
Type: System.Collections..::.Hashtable
The hash table of the key value pair for each data element
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session
lastUpdatedTime
Type: System..::.DateTime%
The last updated time

Return Value

Negative value if failed, else successful

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateContactRoles Method

[image]

OfficeClip API Documentation
MetaDB..::.UpdateContactRoles Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the contact roles

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool UpdateContactRoles(
    int orgId,
    List<string> roles
)
Visual Basic (Declaration)
Public Function UpdateContactRoles ( _
    orgId As Integer, _
    roles As List(Of String) _
) As Boolean
Visual C++
public:
bool UpdateContactRoles(
    int orgId,
    List<String^>^ roles
)

Parameters

orgId
Type: System..::.Int32
The unique id of the current organization
roles
Type: System.Collections.Generic..::.List<(Of <(String>)>)
The list of contact roles

Return Value

true if successful, false otherwise

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateMetaChildObjects Method

[image]

OfficeClip API Documentation
MetaDB..::.UpdateMetaChildObjects Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the meta child object

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateMetaChildObjects(
    MetaConstants..::.MetaEntity me,
    int metaId,
    ArrayList arr
)
Visual Basic (Declaration)
Public Function UpdateMetaChildObjects ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer, _
    arr As ArrayList _
) As Integer
Visual C++
public:
int UpdateMetaChildObjects(
    MetaConstants..::.MetaEntity me,
    int metaId,
    ArrayList^ arr
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
metaId
Type: System..::.Int32
The unique meta id, usually the group id
arr
Type: System.Collections..::.ArrayList
The child object array

Return Value

negative if failed, else succeeded

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateMetaParentInfo Method

[image]

OfficeClip API Documentation
MetaDB..::.UpdateMetaParentInfo Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the parent inforamtion from the metabase

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateMetaParentInfo(
    MetaConstants..::.MetaEntity me,
    int metaId,
    int pkId,
    BusinessConstants..::.ObjectType parentType,
    int parentObjectId
)
Visual Basic (Declaration)
Public Sub UpdateMetaParentInfo ( _
    me As MetaConstants..::.MetaEntity, _
    metaId As Integer, _
    pkId As Integer, _
    parentType As BusinessConstants..::.ObjectType, _
    parentObjectId As Integer _
)
Visual C++
public:
void UpdateMetaParentInfo(
    MetaConstants..::.MetaEntity me,
    int metaId,
    int pkId,
    BusinessConstants..::.ObjectType parentType,
    int parentObjectId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
metaId
Type: System..::.Int32
pkId
Type: System..::.Int32
parentType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
parentObjectId
Type: System..::.Int32

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateMetaParentObject Method

[image]

OfficeClip API Documentation
MetaDB..::.UpdateMetaParentObject Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates attributes of an entity

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateMetaParentObject(
    MetaConstants..::.MetaEntity childMe,
    MetaConstants..::.MetaEntity parentMe,
    int primaryId,
    int objectId
)
Visual Basic (Declaration)
Public Sub UpdateMetaParentObject ( _
    childMe As MetaConstants..::.MetaEntity, _
    parentMe As MetaConstants..::.MetaEntity, _
    primaryId As Integer, _
    objectId As Integer _
)
Visual C++
public:
void UpdateMetaParentObject(
    MetaConstants..::.MetaEntity childMe,
    MetaConstants..::.MetaEntity parentMe,
    int primaryId,
    int objectId
)

Parameters

childMe
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
parentMe
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
primaryId
Type: System..::.Int32
objectId
Type: System..::.Int32

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateMetaRoleInfo Method

[image]

OfficeClip API Documentation
MetaDB..::.UpdateMetaRoleInfo Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateMetaRoleInfo(
    int contactRoleId,
    string roleName
)
Visual Basic (Declaration)
Public Sub UpdateMetaRoleInfo ( _
    contactRoleId As Integer, _
    roleName As String _
)
Visual C++
public:
void UpdateMetaRoleInfo(
    int contactRoleId,
    String^ roleName
)

Parameters

contactRoleId
Type: System..::.Int32
roleName
Type: System..::.String

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateRelationDetails Method

[image]

OfficeClip API Documentation
MetaDB..::.UpdateRelationDetails Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates existing Relation into database

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateRelationDetails(
    Relation rType
)
Visual Basic (Declaration)
Public Sub UpdateRelationDetails ( _
    rType As Relation _
)
Visual C++
public:
void UpdateRelationDetails(
    Relation^ rType
)

Parameters

rType
Type: OfficeClip.BusinessLayer.Metabase..::.Relation

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateRelationType Method

[image]

OfficeClip API Documentation
MetaDB..::.UpdateRelationType Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates existing Relation Type with RelationTypeId

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateRelationType(
    RelationType rType
)
Visual Basic (Declaration)
Public Sub UpdateRelationType ( _
    rType As RelationType _
)
Visual C++
public:
void UpdateRelationType(
    RelationType^ rType
)

Parameters

rType
Type: OfficeClip.BusinessLayer.Metabase..::.RelationType

Return Value

RelationTyeId

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateSingleField Method

[image]

OfficeClip API Documentation
MetaDB..::.UpdateSingleField Method
MetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates a single field

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateSingleField(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    int pkId,
    int attributeId,
    Object oval,
    MetaConstants..::.MetaType mt,
    bool isFixed,
    int currentUserId,
    out DateTime lastUpdatedTime
)
Visual Basic (Declaration)
Public Function UpdateSingleField ( _
    me As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    pkId As Integer, _
    attributeId As Integer, _
    oval As Object, _
    mt As MetaConstants..::.MetaType, _
    isFixed As Boolean, _
    currentUserId As Integer, _
    <OutAttribute> ByRef lastUpdatedTime As DateTime _
) As Integer
Visual C++
public:
int UpdateSingleField(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    int pkId,
    int attributeId,
    Object^ oval,
    MetaConstants..::.MetaType mt,
    bool isFixed,
    int currentUserId,
    [OutAttribute] DateTime% lastUpdatedTime
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external key id
pkId
Type: System..::.Int32
The primary key id
attributeId
Type: System..::.Int32
The unique id of the attribute
oval
Type: System..::.Object
The value of the attribute
mt
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaType
The type of the attribute
isFixed
Type: System..::.Boolean
Shows if the parameter is fixed
currentUserId
Type: System..::.Int32
Unique id of the current user
lastUpdatedTime
Type: System..::.DateTime%
The last updated time

Return Value

Negative if failed, else succeeds

See Also

MetaDB Class
OfficeClip.DBLayer.Metabase Namespace


MetaFilterDB Class

[image]

OfficeClip API Documentation
MetaFilterDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class desription for the metabase filters

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaFilterDB : OfficeClipDB
Visual Basic (Declaration)
Public Class MetaFilterDB _
    Inherits OfficeClipDB
Visual C++
public ref class MetaFilterDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Metabase..::.MetaFilterDB

See Also

MetaFilterDB Members
OfficeClip.DBLayer.Metabase Namespace


MetaFilterDB Members

[image] [image]

OfficeClip API Documentation
MetaFilterDB Members
MetaFilterDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaFilterDB type exposes the following members.

Constructors

 | Name | Description
Public method | MetaFilterDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | CheckReportDuplicate | Checks the duplicate entries in the report
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteFilter | Remove a filter
Public method | DeleteReport | Removes a report
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributesForDropDown | Gets all the attribute for the dropdown box
Public method | GetCampaignHistory | Gets campaign history
Protected method | GetContactListForFilter | Gets the contact list for the filter
Protected method | GetFilterBooleanCondition | Gets the filter boolean condition
Public method | GetFilterCondition | Gets the filter condition
Protected method | GetFilterDateCondition | Gets the filter date condition
Public method | GetFilterInfo | Gets the information pertaining to a particular filter
Public method | GetFilterList | Get the list of filters
Protected method | GetFilterListCondition | Gets the filter list condition
Public method | GetFilterListWithContactIdsEncoded | Gets the filter list for contacts with contact ids encoded
Protected method | GetFilterNumberCondition | Gets the filter number condition
Protected method | GetFilterStrings | Gets the filter string
Protected method | GetFilterTextCondition | Gets the filter text condition
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetOpString | Gets the operation string
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetReportInfo | Overloaded.
Public method | GetReportList | Get the list of reports
Protected method | GetSelectLHS | Gets select the left hand side
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Modify | Modify the filter
Public method | ModifyReport | Overloaded.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


MetaFilterDB Constructor

[image] [image]

OfficeClip API Documentation
MetaFilterDB Constructor
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaFilterDB()()() | Constructor
Public method | MetaFilterDB(OfficeClipDB) | Constructor

See Also

MetaFilterDB Class
MetaFilterDB Members
OfficeClip.DBLayer.Metabase Namespace


MetaFilterDB Constructor

[image]

OfficeClip API Documentation
MetaFilterDB Constructor
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaFilterDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaFilterDB()

See Also

MetaFilterDB Class
MetaFilterDB Overload
OfficeClip.DBLayer.Metabase Namespace


MetaFilterDB Constructor (OfficeClipDB)

[image]

OfficeClip API Documentation
MetaFilterDB Constructor (OfficeClipDB)
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaFilterDB(
    OfficeClipDB ma
)
Visual Basic (Declaration)
Public Sub New ( _
    ma As OfficeClipDB _
)
Visual C++
public:
MetaFilterDB(
    OfficeClipDB^ ma
)

Parameters

ma
Type: OfficeClip.DBLayer..::.OfficeClipDB
The base class

See Also

MetaFilterDB Class
MetaFilterDB Overload
OfficeClip.DBLayer.Metabase Namespace


MetaFilterDB Methods

[image] [image]

OfficeClip API Documentation
MetaFilterDB Methods
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

The MetaFilterDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | CheckReportDuplicate | Checks the duplicate entries in the report
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteFilter | Remove a filter
Public method | DeleteReport | Removes a report
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributesForDropDown | Gets all the attribute for the dropdown box
Public method | GetCampaignHistory | Gets campaign history
Protected method | GetContactListForFilter | Gets the contact list for the filter
Protected method | GetFilterBooleanCondition | Gets the filter boolean condition
Public method | GetFilterCondition | Gets the filter condition
Protected method | GetFilterDateCondition | Gets the filter date condition
Public method | GetFilterInfo | Gets the information pertaining to a particular filter
Public method | GetFilterList | Get the list of filters
Protected method | GetFilterListCondition | Gets the filter list condition
Public method | GetFilterListWithContactIdsEncoded | Gets the filter list for contacts with contact ids encoded
Protected method | GetFilterNumberCondition | Gets the filter number condition
Protected method | GetFilterStrings | Gets the filter string
Protected method | GetFilterTextCondition | Gets the filter text condition
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetOpString | Gets the operation string
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetReportInfo | Overloaded.
Public method | GetReportList | Get the list of reports
Protected method | GetSelectLHS | Gets select the left hand side
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Modify | Modify the filter
Public method | ModifyReport | Overloaded.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
MetaFilterDB..::.AddOutputParameter Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

MetaFilterDB Class
MetaFilterDB Members
OfficeClip.DBLayer.Metabase Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
MetaFilterDB..::.AddParameter Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

MetaFilterDB Class
MetaFilterDB Members
OfficeClip.DBLayer.Metabase Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
MetaFilterDB..::.AddParameters Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

MetaFilterDB Class
MetaFilterDB Members
OfficeClip.DBLayer.Metabase Namespace


CheckReportDuplicate Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.CheckReportDuplicate Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks the duplicate entries in the report

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int CheckReportDuplicate(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int reportId,
    string name,
    bool isPrivate
)
Visual Basic (Declaration)
Public Function CheckReportDuplicate ( _
    me As MetaConstants..::.MetaEntity, _
    externalKey As Integer, _
    reportId As Integer, _
    name As String, _
    isPrivate As Boolean _
) As Integer
Visual C++
public:
int CheckReportDuplicate(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int reportId,
    String^ name,
    bool isPrivate
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKey
Type: System..::.Int32
The group id
reportId
Type: System..::.Int32
The unique id of the report
name
Type: System..::.String
The name of the report
isPrivate
Type: System..::.Boolean
true if the report is private

Return Value

0 if there is no duplicate

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


DeleteFilter Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.DeleteFilter Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Remove a filter

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteFilter(
    int filterId
)
Visual Basic (Declaration)
Public Sub DeleteFilter ( _
    filterId As Integer _
)
Visual C++
public:
void DeleteFilter(
    int filterId
)

Parameters

filterId
Type: System..::.Int32
The unique id of the filter

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


DeleteReport Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.DeleteReport Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes a report

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteReport(
    int reportId
)
Visual Basic (Declaration)
Public Sub DeleteReport ( _
    reportId As Integer _
)
Visual C++
public:
void DeleteReport(
    int reportId
)

Parameters

reportId
Type: System..::.Int32
The unique id of the report

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
MetaFilterDB..::.ExecuteNonQuery Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

MetaFilterDB Class
MetaFilterDB Members
OfficeClip.DBLayer.Metabase Namespace


GetAttributesForDropDown Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetAttributesForDropDown Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the attribute for the dropdown box

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetAttributesForDropDown(
    MetaConstants..::.MetaEntity me,
    int externalId,
    bool isDefaultBlank
)
Visual Basic (Declaration)
Public Function GetAttributesForDropDown ( _
    me As MetaConstants..::.MetaEntity, _
    externalId As Integer, _
    isDefaultBlank As Boolean _
) As DataTable
Visual C++
public:
DataTable^ GetAttributesForDropDown(
    MetaConstants..::.MetaEntity me,
    int externalId,
    bool isDefaultBlank
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalId
Type: System..::.Int32
The unique id of the group
isDefaultBlank
Type: System..::.Boolean
true if the default is blank

Return Value

the datatable that shows all the entries of the dropdown box

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetCampaignHistory Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetCampaignHistory Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets campaign history

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetCampaignHistory(
    int templateId
)
Visual Basic (Declaration)
Public Function GetCampaignHistory ( _
    templateId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetCampaignHistory(
    int templateId
)

Parameters

templateId
Type: System..::.Int32

Return Value

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetContactListForFilter Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetContactListForFilter Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the contact list for the filter

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetContactListForFilter(
    int filterId,
    int groupId
)
Visual Basic (Declaration)
Protected Function GetContactListForFilter ( _
    filterId As Integer, _
    groupId As Integer _
) As String
Visual C++
protected:
String^ GetContactListForFilter(
    int filterId,
    int groupId
)

Parameters

filterId
Type: System..::.Int32
groupId
Type: System..::.Int32

Return Value

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetFilterBooleanCondition Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetFilterBooleanCondition Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the filter boolean condition

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetFilterBooleanCondition(
    ref DataRow dr,
    ref string[] rhVals,
    string ops,
    string lhs
)
Visual Basic (Declaration)
Protected Function GetFilterBooleanCondition ( _
    ByRef dr As DataRow, _
    ByRef rhVals As String(), _
    ops As String, _
    lhs As String _
) As String
Visual C++
protected:
String^ GetFilterBooleanCondition(
    DataRow^% dr,
    array<String^>^% rhVals,
    String^ ops,
    String^ lhs
)

Parameters

dr
Type: System.Data..::.DataRow%
rhVals
Type: array<System..::.String>[]()[]%
ops
Type: System..::.String
lhs
Type: System..::.String

Return Value

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetFilterCondition Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetFilterCondition Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the filter condition

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetFilterCondition(
    MetaConstants..::.MetaEntity me,
    int externalId,
    FC cond,
    ref DataTable dt
)
Visual Basic (Declaration)
Public Function GetFilterCondition ( _
    me As MetaConstants..::.MetaEntity, _
    externalId As Integer, _
    cond As FC, _
    ByRef dt As DataTable _
) As String
Visual C++
public:
String^ GetFilterCondition(
    MetaConstants..::.MetaEntity me,
    int externalId,
    FC^ cond,
    DataTable^% dt
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
externalId
Type: System..::.Int32
cond
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.FC
dt
Type: System.Data..::.DataTable%

Return Value

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetFilterDateCondition Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetFilterDateCondition Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the filter date condition

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetFilterDateCondition(
    ref DataRow dr,
    ref string[] rhVals,
    string ops,
    string lhs
)
Visual Basic (Declaration)
Protected Function GetFilterDateCondition ( _
    ByRef dr As DataRow, _
    ByRef rhVals As String(), _
    ops As String, _
    lhs As String _
) As String
Visual C++
protected:
String^ GetFilterDateCondition(
    DataRow^% dr,
    array<String^>^% rhVals,
    String^ ops,
    String^ lhs
)

Parameters

dr
Type: System.Data..::.DataRow%
rhVals
Type: array<System..::.String>[]()[]%
ops
Type: System..::.String
lhs
Type: System..::.String

Return Value

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetFilterInfo Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetFilterInfo Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the information pertaining to a particular filter

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaFilterInfo GetFilterInfo(
    int filterId
)
Visual Basic (Declaration)
Public Function GetFilterInfo ( _
    filterId As Integer _
) As MetaFilterInfo
Visual C++
public:
MetaFilterInfo^ GetFilterInfo(
    int filterId
)

Parameters

filterId
Type: System..::.Int32
the unique id of the filter

Return Value

The filter information object

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetFilterList Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetFilterList Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the list of filters

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetFilterList(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int currentUserId
)
Visual Basic (Declaration)
Public Function GetFilterList ( _
    me As MetaConstants..::.MetaEntity, _
    externalKey As Integer, _
    currentUserId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetFilterList(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int currentUserId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKey
Type: System..::.Int32
The unique id of the group
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

The datatable that returns the list of filters

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetFilterListCondition Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetFilterListCondition Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the filter list condition

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetFilterListCondition(
    MetaConstants..::.MetaEntity me,
    int externalId,
    ref DataRow dr,
    ref string[] rhVals,
    string ops,
    string lhs
)
Visual Basic (Declaration)
Protected Function GetFilterListCondition ( _
    me As MetaConstants..::.MetaEntity, _
    externalId As Integer, _
    ByRef dr As DataRow, _
    ByRef rhVals As String(), _
    ops As String, _
    lhs As String _
) As String
Visual C++
protected:
String^ GetFilterListCondition(
    MetaConstants..::.MetaEntity me,
    int externalId,
    DataRow^% dr,
    array<String^>^% rhVals,
    String^ ops,
    String^ lhs
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
externalId
Type: System..::.Int32
dr
Type: System.Data..::.DataRow%
rhVals
Type: array<System..::.String>[]()[]%
ops
Type: System..::.String
lhs
Type: System..::.String

Return Value

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetFilterListWithContactIdsEncoded Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetFilterListWithContactIdsEncoded Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the filter list for contacts with contact ids encoded

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetFilterListWithContactIdsEncoded(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int userId
)
Visual Basic (Declaration)
Public Function GetFilterListWithContactIdsEncoded ( _
    me As MetaConstants..::.MetaEntity, _
    externalKey As Integer, _
    userId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetFilterListWithContactIdsEncoded(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int userId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
externalKey
Type: System..::.Int32
userId
Type: System..::.Int32

Return Value

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetFilterNumberCondition Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetFilterNumberCondition Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the filter number condition

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetFilterNumberCondition(
    ref DataRow dr,
    ref string[] rhVals,
    string ops,
    string lhs
)
Visual Basic (Declaration)
Protected Function GetFilterNumberCondition ( _
    ByRef dr As DataRow, _
    ByRef rhVals As String(), _
    ops As String, _
    lhs As String _
) As String
Visual C++
protected:
String^ GetFilterNumberCondition(
    DataRow^% dr,
    array<String^>^% rhVals,
    String^ ops,
    String^ lhs
)

Parameters

dr
Type: System.Data..::.DataRow%
rhVals
Type: array<System..::.String>[]()[]%
ops
Type: System..::.String
lhs
Type: System..::.String

Return Value

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetFilterStrings Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetFilterStrings Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the filter string

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void GetFilterStrings(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    MF mFilter,
    ref string selectString,
    ref string filterString
)
Visual Basic (Declaration)
Protected Sub GetFilterStrings ( _
    me As MetaConstants..::.MetaEntity, _
    externalKey As Integer, _
    mFilter As MF, _
    ByRef selectString As String, _
    ByRef filterString As String _
)
Visual C++
protected:
void GetFilterStrings(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    MF^ mFilter,
    String^% selectString,
    String^% filterString
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
externalKey
Type: System..::.Int32
mFilter
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.MF
selectString
Type: System..::.String%
filterString
Type: System..::.String%

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetFilterTextCondition Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetFilterTextCondition Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the filter text condition

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetFilterTextCondition(
    ref DataRow dr,
    ref string[] rhVals,
    string ops,
    string lhs
)
Visual Basic (Declaration)
Protected Function GetFilterTextCondition ( _
    ByRef dr As DataRow, _
    ByRef rhVals As String(), _
    ops As String, _
    lhs As String _
) As String
Visual C++
protected:
String^ GetFilterTextCondition(
    DataRow^% dr,
    array<String^>^% rhVals,
    String^ ops,
    String^ lhs
)

Parameters

dr
Type: System.Data..::.DataRow%
rhVals
Type: array<System..::.String>[]()[]%
ops
Type: System..::.String
lhs
Type: System..::.String

Return Value

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetOpString Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetOpString Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the operation string

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetOpString(
    MetaConstants..::.FilterFunction ff
)
Visual Basic (Declaration)
Protected Function GetOpString ( _
    ff As MetaConstants..::.FilterFunction _
) As String
Visual C++
protected:
String^ GetOpString(
    MetaConstants..::.FilterFunction ff
)

Parameters

ff
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.FilterFunction

Return Value

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetReportInfo Method

[image] [image]

OfficeClip API Documentation
MetaFilterDB..::.GetReportInfo Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetReportInfo(Int32) | Get the information related to a report
Public method | GetReportInfo(Int32, Boolean) | Get the information related to a report

See Also

MetaFilterDB Class
MetaFilterDB Members
OfficeClip.DBLayer.Metabase Namespace


GetReportInfo Method (Int32)

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetReportInfo Method (Int32)
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the information related to a report

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaReportInfo GetReportInfo(
    int reportId
)
Visual Basic (Declaration)
Public Function GetReportInfo ( _
    reportId As Integer _
) As MetaReportInfo
Visual C++
public:
MetaReportInfo^ GetReportInfo(
    int reportId
)

Parameters

reportId
Type: System..::.Int32
The unique id of the report

Return Value

the report information object

See Also

MetaFilterDB Class
GetReportInfo Overload
OfficeClip.DBLayer.Metabase Namespace


GetReportInfo Method (Int32, Boolean)

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetReportInfo Method (Int32, Boolean)
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the information related to a report

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaReportInfo GetReportInfo(
    int reportId,
    bool isExternal
)
Visual Basic (Declaration)
Public Function GetReportInfo ( _
    reportId As Integer, _
    isExternal As Boolean _
) As MetaReportInfo
Visual C++
public:
MetaReportInfo^ GetReportInfo(
    int reportId,
    bool isExternal
)

Parameters

reportId
Type: System..::.Int32
The unique id of the report
isExternal
Type: System..::.Boolean
true if it is an external report

Return Value

the report information object

See Also

MetaFilterDB Class
GetReportInfo Overload
OfficeClip.DBLayer.Metabase Namespace


GetReportList Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetReportList Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the list of reports

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetReportList(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int currentUserId
)
Visual Basic (Declaration)
Public Function GetReportList ( _
    me As MetaConstants..::.MetaEntity, _
    externalKey As Integer, _
    currentUserId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetReportList(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int currentUserId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The metaentity
externalKey
Type: System..::.Int32
The unique id of the group
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

The datatable that shows the list of report

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


GetSelectLHS Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.GetSelectLHS Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets select the left hand side

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetSelectLHS(
    DataRow drow
)
Visual Basic (Declaration)
Protected Function GetSelectLHS ( _
    drow As DataRow _
) As String
Visual C++
protected:
String^ GetSelectLHS(
    DataRow^ drow
)

Parameters

drow
Type: System.Data..::.DataRow

Return Value

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
MetaFilterDB..::.InitTransaction Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

MetaFilterDB Class
MetaFilterDB Members
OfficeClip.DBLayer.Metabase Namespace


Modify Method

[image]

OfficeClip API Documentation
MetaFilterDB..::.Modify Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Modify the filter

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Modify(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int filterId,
    string filterName,
    MF mFilter,
    bool isPrivate,
    bool isOwner,
    int currentUserId
)
Visual Basic (Declaration)
Public Function Modify ( _
    me As MetaConstants..::.MetaEntity, _
    externalKey As Integer, _
    filterId As Integer, _
    filterName As String, _
    mFilter As MF, _
    isPrivate As Boolean, _
    isOwner As Boolean, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int Modify(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int filterId,
    String^ filterName,
    MF^ mFilter,
    bool isPrivate,
    bool isOwner,
    int currentUserId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKey
Type: System..::.Int32
The unique id of the group
filterId
Type: System..::.Int32
The unique id of the filter
filterName
Type: System..::.String
The name of the filter
mFilter
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.MF
The meta filter object
isPrivate
Type: System..::.Boolean
true if the filter is private
isOwner
Type: System..::.Boolean
true if the current user is the owner of the filter
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

0 if successful

See Also

MetaFilterDB Class
OfficeClip.DBLayer.Metabase Namespace


ModifyReport Method

[image] [image]

OfficeClip API Documentation
MetaFilterDB..::.ModifyReport Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ModifyReport(MetaConstants..::.MetaEntity, Int32, Int32, String, ExtMF, Criteria, Boolean, Boolean, String, Int32) | Modify the report
Public method | ModifyReport(MetaConstants..::.MetaEntity, Int32, Int32, String, MF, Criteria, Boolean, Boolean, String, Int32) | Modifies the report
Public method | ModifyReport(MetaConstants..::.MetaEntity, Int32, Int32, String, String, Criteria, Boolean, Boolean, String, String, String, Int32) | Modifies the report

See Also

MetaFilterDB Class
MetaFilterDB Members
OfficeClip.DBLayer.Metabase Namespace


ModifyReport Method (MetaConstants.MetaEntity, Int32, Int32, String, ExtMF, Criteria, Boolean, Boolean, String, Int32)

[image]

OfficeClip API Documentation
MetaFilterDB..::.ModifyReport Method (MetaConstants..::.MetaEntity, Int32, Int32, String, ExtMF, Criteria, Boolean, Boolean, String, Int32)
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Modify the report

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ModifyReport(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int reportId,
    string reportName,
    ExtMF mFilter,
    Criteria criteria,
    bool isPrivate,
    bool isOwner,
    string description,
    int currentUserId
)
Visual Basic (Declaration)
Public Function ModifyReport ( _
    me As MetaConstants..::.MetaEntity, _
    externalKey As Integer, _
    reportId As Integer, _
    reportName As String, _
    mFilter As ExtMF, _
    criteria As Criteria, _
    isPrivate As Boolean, _
    isOwner As Boolean, _
    description As String, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int ModifyReport(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int reportId,
    String^ reportName,
    ExtMF^ mFilter,
    Criteria^ criteria,
    bool isPrivate,
    bool isOwner,
    String^ description,
    int currentUserId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The metaentity
externalKey
Type: System..::.Int32
The unique id of the group
reportId
Type: System..::.Int32
The unique id of the report
reportName
Type: System..::.String
The name of the report
mFilter
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.ExtMF
The filter object
criteria
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.Criteria
The filter criteria object
isPrivate
Type: System..::.Boolean
true if private
isOwner
Type: System..::.Boolean
true if owner
description
Type: System..::.String
The description of the report
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

0 if successful

See Also

MetaFilterDB Class
ModifyReport Overload
OfficeClip.DBLayer.Metabase Namespace


ModifyReport Method (MetaConstants.MetaEntity, Int32, Int32, String, MF, Criteria, Boolean, Boolean, String, Int32)

[image]

OfficeClip API Documentation
MetaFilterDB..::.ModifyReport Method (MetaConstants..::.MetaEntity, Int32, Int32, String, MF, Criteria, Boolean, Boolean, String, Int32)
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Modifies the report

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ModifyReport(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int reportId,
    string reportName,
    MF mFilter,
    Criteria criteria,
    bool isPrivate,
    bool isOwner,
    string description,
    int currentUserId
)
Visual Basic (Declaration)
Public Function ModifyReport ( _
    me As MetaConstants..::.MetaEntity, _
    externalKey As Integer, _
    reportId As Integer, _
    reportName As String, _
    mFilter As MF, _
    criteria As Criteria, _
    isPrivate As Boolean, _
    isOwner As Boolean, _
    description As String, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int ModifyReport(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int reportId,
    String^ reportName,
    MF^ mFilter,
    Criteria^ criteria,
    bool isPrivate,
    bool isOwner,
    String^ description,
    int currentUserId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKey
Type: System..::.Int32
The unique id of the group
reportId
Type: System..::.Int32
The unique id of teh report
reportName
Type: System..::.String
The name of the report
mFilter
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.MF
The filter object
criteria
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.Criteria
The filter criteria
isPrivate
Type: System..::.Boolean
true if private
isOwner
Type: System..::.Boolean
true if owner
description
Type: System..::.String
The description of the report
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

0 if successful

See Also

MetaFilterDB Class
ModifyReport Overload
OfficeClip.DBLayer.Metabase Namespace


ModifyReport Method (MetaConstants.MetaEntity, Int32, Int32, String, String, Criteria, Boolean, Boolean, String, String, String, Int32)

[image]

OfficeClip API Documentation
MetaFilterDB..::.ModifyReport Method (MetaConstants..::.MetaEntity, Int32, Int32, String, String, Criteria, Boolean, Boolean, String, String, String, Int32)
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Modifies the report

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ModifyReport(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int reportId,
    string reportName,
    string filterXml,
    Criteria criteria,
    bool isPrivate,
    bool isOwner,
    string description,
    string selectString,
    string filterString,
    int currentUserId
)
Visual Basic (Declaration)
Public Function ModifyReport ( _
    me As MetaConstants..::.MetaEntity, _
    externalKey As Integer, _
    reportId As Integer, _
    reportName As String, _
    filterXml As String, _
    criteria As Criteria, _
    isPrivate As Boolean, _
    isOwner As Boolean, _
    description As String, _
    selectString As String, _
    filterString As String, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int ModifyReport(
    MetaConstants..::.MetaEntity me,
    int externalKey,
    int reportId,
    String^ reportName,
    String^ filterXml,
    Criteria^ criteria,
    bool isPrivate,
    bool isOwner,
    String^ description,
    String^ selectString,
    String^ filterString,
    int currentUserId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The metaentity
externalKey
Type: System..::.Int32
The id of teh group
reportId
Type: System..::.Int32
The unique id of the report
reportName
Type: System..::.String
The name of the report
filterXml
Type: System..::.String
The filter xml string
criteria
Type: OfficeClip.BusinessLayer.Metabase.Filter..::.Criteria
The filter criteria
isPrivate
Type: System..::.Boolean
true if private
isOwner
Type: System..::.Boolean
true if owner
description
Type: System..::.String
The description of the report
selectString
Type: System..::.String
The select string that shows what fields are to be shown on the output
filterString
Type: System..::.String
The filter string
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

0 if successful

See Also

MetaFilterDB Class
ModifyReport Overload
OfficeClip.DBLayer.Metabase Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
MetaFilterDB..::.SetSPCommand Method
MetaFilterDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

MetaFilterDB Class
MetaFilterDB Members
OfficeClip.DBLayer.Metabase Namespace


MetaSqlDB Class

[image]

OfficeClip API Documentation
MetaSqlDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

The meta sql database class

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class MetaSqlDB : OfficeClipDB
Visual Basic (Declaration)
Public Class MetaSqlDB _
    Inherits OfficeClipDB
Visual C++
public ref class MetaSqlDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Metabase..::.MetaSqlDB

See Also

MetaSqlDB Members
OfficeClip.DBLayer.Metabase Namespace


MetaSqlDB Members

[image] [image]

OfficeClip API Documentation
MetaSqlDB Members
MetaSqlDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The MetaSqlDB type exposes the following members.

Constructors

 | Name | Description
Public method | MetaSqlDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | CheckMetaSqls | Checks the metasql statement and refresh the sql if necessary
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FixedListSelects | Selection of fixed lists
Protected method | GetForeignTableColumnName | Gets the foreign table column name
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetListExternalColumn | Gets the list of the external column
Protected method | GetListForeignColumn | Gets the foreign column list
Public method | GetMetaDataSet | Gets the meta data set
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Protected method | GetPrimaryTableColumnName | Gets the primary table column name
Protected method | GetPrimaryTableName | Get the primary table name
Protected method | GetSecondaryTableColumnName | Gets the secondary table column name
Protected method | GetSecondaryTableName | Gets the secondary table name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MainSqlJoin | The sql join string
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrimaryTableInsertParameters | Insert parameter for the primary table
Public method | RefreshSqls | Overloaded.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Protected method | SecondaryTableInsertParameters | Insert parameter for the secondary table
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SqlDelete | The sql delete statement
Public method | SqlInsert | The sql insert statement
Public method | SqlSelectAll | Sql for selecting all the information
Public method | SqlSelectByFilter | Sql statement for select by filter
Public method | SqlSelectByPk | Sql statement for select by primary key
Public method | SqlSelectLists | The sql select list
Public method | SqlSelectPreferred | Sql statement for preferred information
Public method | SqlUpdateFixed | The sql update statement for the fixed field
Public method | SqlUpdateUdf | The sql update statement for the user defined fields
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UdfListSelects | User defined list selects
Protected method | UpdateMetaSqls | Create the update sql for the metabase

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


MetaSqlDB Constructor

[image] [image]

OfficeClip API Documentation
MetaSqlDB Constructor
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | MetaSqlDB()()() | Constructor
Public method | MetaSqlDB(OfficeClipDB) | The constructor

See Also

MetaSqlDB Class
MetaSqlDB Members
OfficeClip.DBLayer.Metabase Namespace


MetaSqlDB Constructor

[image]

OfficeClip API Documentation
MetaSqlDB Constructor
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaSqlDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaSqlDB()

See Also

MetaSqlDB Class
MetaSqlDB Overload
OfficeClip.DBLayer.Metabase Namespace


MetaSqlDB Constructor (OfficeClipDB)

[image]

OfficeClip API Documentation
MetaSqlDB Constructor (OfficeClipDB)
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

The constructor

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public MetaSqlDB(
    OfficeClipDB ma
)
Visual Basic (Declaration)
Public Sub New ( _
    ma As OfficeClipDB _
)
Visual C++
public:
MetaSqlDB(
    OfficeClipDB^ ma
)

Parameters

ma
Type: OfficeClip.DBLayer..::.OfficeClipDB
The base object

See Also

MetaSqlDB Class
MetaSqlDB Overload
OfficeClip.DBLayer.Metabase Namespace


MetaSqlDB Methods

[image] [image]

OfficeClip API Documentation
MetaSqlDB Methods
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

The MetaSqlDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | CheckMetaSqls | Checks the metasql statement and refresh the sql if necessary
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FixedListSelects | Selection of fixed lists
Protected method | GetForeignTableColumnName | Gets the foreign table column name
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Protected method | GetListExternalColumn | Gets the list of the external column
Protected method | GetListForeignColumn | Gets the foreign column list
Public method | GetMetaDataSet | Gets the meta data set
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Protected method | GetPrimaryTableColumnName | Gets the primary table column name
Protected method | GetPrimaryTableName | Get the primary table name
Protected method | GetSecondaryTableColumnName | Gets the secondary table column name
Protected method | GetSecondaryTableName | Gets the secondary table name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MainSqlJoin | The sql join string
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PrimaryTableInsertParameters | Insert parameter for the primary table
Public method | RefreshSqls | Overloaded.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Protected method | SecondaryTableInsertParameters | Insert parameter for the secondary table
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SqlDelete | The sql delete statement
Public method | SqlInsert | The sql insert statement
Public method | SqlSelectAll | Sql for selecting all the information
Public method | SqlSelectByFilter | Sql statement for select by filter
Public method | SqlSelectByPk | Sql statement for select by primary key
Public method | SqlSelectLists | The sql select list
Public method | SqlSelectPreferred | Sql statement for preferred information
Public method | SqlUpdateFixed | The sql update statement for the fixed field
Public method | SqlUpdateUdf | The sql update statement for the user defined fields
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | UdfListSelects | User defined list selects
Protected method | UpdateMetaSqls | Create the update sql for the metabase

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
MetaSqlDB..::.AddOutputParameter Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

MetaSqlDB Class
MetaSqlDB Members
OfficeClip.DBLayer.Metabase Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
MetaSqlDB..::.AddParameter Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

MetaSqlDB Class
MetaSqlDB Members
OfficeClip.DBLayer.Metabase Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
MetaSqlDB..::.AddParameters Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

MetaSqlDB Class
MetaSqlDB Members
OfficeClip.DBLayer.Metabase Namespace


CheckMetaSqls Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.CheckMetaSqls Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks the metasql statement and refresh the sql if necessary

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void CheckMetaSqls(
    MetaConstants..::.MetaEntity me,
    int externalKeyId
)
Visual Basic (Declaration)
Public Sub CheckMetaSqls ( _
    me As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer _
)
Visual C++
public:
void CheckMetaSqls(
    MetaConstants..::.MetaEntity me,
    int externalKeyId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external id, usually the group id

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
MetaSqlDB..::.ExecuteNonQuery Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

MetaSqlDB Class
MetaSqlDB Members
OfficeClip.DBLayer.Metabase Namespace


FixedListSelects Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.FixedListSelects Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Selection of fixed lists

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string FixedListSelects(
    ref StringBuilder sb,
    DataRow drow,
    ref DataSet ds,
    int externalKeyId
)
Visual Basic (Declaration)
Protected Function FixedListSelects ( _
    ByRef sb As StringBuilder, _
    drow As DataRow, _
    ByRef ds As DataSet, _
    externalKeyId As Integer _
) As String
Visual C++
protected:
String^ FixedListSelects(
    StringBuilder^% sb,
    DataRow^ drow,
    DataSet^% ds,
    int externalKeyId
)

Parameters

sb
Type: System.Text..::.StringBuilder%
drow
Type: System.Data..::.DataRow
ds
Type: System.Data..::.DataSet%
externalKeyId
Type: System..::.Int32

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


GetForeignTableColumnName Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.GetForeignTableColumnName Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the foreign table column name

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetForeignTableColumnName(
    ref DataSet ds
)
Visual Basic (Declaration)
Protected Function GetForeignTableColumnName ( _
    ByRef ds As DataSet _
) As String
Visual C++
protected:
String^ GetForeignTableColumnName(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


GetListExternalColumn Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.GetListExternalColumn Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of the external column

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetListExternalColumn(
    ref DataSet ds,
    int id
)
Visual Basic (Declaration)
Protected Function GetListExternalColumn ( _
    ByRef ds As DataSet, _
    id As Integer _
) As String
Visual C++
protected:
String^ GetListExternalColumn(
    DataSet^% ds,
    int id
)

Parameters

ds
Type: System.Data..::.DataSet%
id
Type: System..::.Int32

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


GetListForeignColumn Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.GetListForeignColumn Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the foreign column list

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetListForeignColumn(
    ref DataSet ds,
    int id
)
Visual Basic (Declaration)
Protected Function GetListForeignColumn ( _
    ByRef ds As DataSet, _
    id As Integer _
) As String
Visual C++
protected:
String^ GetListForeignColumn(
    DataSet^% ds,
    int id
)

Parameters

ds
Type: System.Data..::.DataSet%
id
Type: System..::.Int32

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


GetMetaDataSet Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.GetMetaDataSet Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the meta data set

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetMetaDataSet(
    int metaId,
    MetaConstants..::.MetaEntity me
)
Visual Basic (Declaration)
Public Function GetMetaDataSet ( _
    metaId As Integer, _
    me As MetaConstants..::.MetaEntity _
) As DataSet
Visual C++
public:
DataSet^ GetMetaDataSet(
    int metaId,
    MetaConstants..::.MetaEntity me
)

Parameters

metaId
Type: System..::.Int32
The meta id
me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity

Return Value

The meta data set

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


GetPrimaryTableColumnName Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.GetPrimaryTableColumnName Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the primary table column name

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetPrimaryTableColumnName(
    ref DataSet ds
)
Visual Basic (Declaration)
Protected Function GetPrimaryTableColumnName ( _
    ByRef ds As DataSet _
) As String
Visual C++
protected:
String^ GetPrimaryTableColumnName(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


GetPrimaryTableName Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.GetPrimaryTableName Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the primary table name

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetPrimaryTableName(
    ref DataSet ds
)
Visual Basic (Declaration)
Protected Function GetPrimaryTableName ( _
    ByRef ds As DataSet _
) As String
Visual C++
protected:
String^ GetPrimaryTableName(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


GetSecondaryTableColumnName Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.GetSecondaryTableColumnName Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the secondary table column name

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetSecondaryTableColumnName(
    ref DataSet ds
)
Visual Basic (Declaration)
Protected Function GetSecondaryTableColumnName ( _
    ByRef ds As DataSet _
) As String
Visual C++
protected:
String^ GetSecondaryTableColumnName(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


GetSecondaryTableName Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.GetSecondaryTableName Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the secondary table name

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetSecondaryTableName(
    ref DataSet ds
)
Visual Basic (Declaration)
Protected Function GetSecondaryTableName ( _
    ByRef ds As DataSet _
) As String
Visual C++
protected:
String^ GetSecondaryTableName(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
MetaSqlDB..::.InitTransaction Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

MetaSqlDB Class
MetaSqlDB Members
OfficeClip.DBLayer.Metabase Namespace


MainSqlJoin Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.MainSqlJoin Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

The sql join string

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string MainSqlJoin(
    ref DataSet ds,
    bool isLoop
)
Visual Basic (Declaration)
Protected Function MainSqlJoin ( _
    ByRef ds As DataSet, _
    isLoop As Boolean _
) As String
Visual C++
protected:
String^ MainSqlJoin(
    DataSet^% ds,
    bool isLoop
)

Parameters

ds
Type: System.Data..::.DataSet%
isLoop
Type: System..::.Boolean
This is needed for the filters because what is happeneing is that the filter string is not doing the correct filtering because there are data of different types in the same column

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


PrimaryTableInsertParameters Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.PrimaryTableInsertParameters Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Insert parameter for the primary table

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string PrimaryTableInsertParameters(
    ref DataSet ds
)
Visual Basic (Declaration)
Protected Function PrimaryTableInsertParameters ( _
    ByRef ds As DataSet _
) As String
Visual C++
protected:
String^ PrimaryTableInsertParameters(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


RefreshSqls Method

[image] [image]

OfficeClip API Documentation
MetaSqlDB..::.RefreshSqls Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | RefreshSqls(MetaConstants..::.MetaEntity, Int32) | Refreshes the sql
Public method | RefreshSqls(MetaConstants..::.MetaEntity, Int32, Boolean, MetaConstants..::.MetaSqlTypes) | Refreshes the sql

See Also

MetaSqlDB Class
MetaSqlDB Members
OfficeClip.DBLayer.Metabase Namespace


RefreshSqls Method (MetaConstants.MetaEntity, Int32)

[image]

OfficeClip API Documentation
MetaSqlDB..::.RefreshSqls Method (MetaConstants..::.MetaEntity, Int32)
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Refreshes the sql

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void RefreshSqls(
    MetaConstants..::.MetaEntity me,
    int externalKeyId
)
Visual Basic (Declaration)
Public Sub RefreshSqls ( _
    me As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer _
)
Visual C++
public:
void RefreshSqls(
    MetaConstants..::.MetaEntity me,
    int externalKeyId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external key id, usually the group id

See Also

MetaSqlDB Class
RefreshSqls Overload
OfficeClip.DBLayer.Metabase Namespace


RefreshSqls Method (MetaConstants.MetaEntity, Int32, Boolean, MetaConstants.MetaSqlTypes)

[image]

OfficeClip API Documentation
MetaSqlDB..::.RefreshSqls Method (MetaConstants..::.MetaEntity, Int32, Boolean, MetaConstants..::.MetaSqlTypes)
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Refreshes the sql

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void RefreshSqls(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    bool isAll,
    MetaConstants..::.MetaSqlTypes sqlType
)
Visual Basic (Declaration)
Public Sub RefreshSqls ( _
    me As MetaConstants..::.MetaEntity, _
    externalKeyId As Integer, _
    isAll As Boolean, _
    sqlType As MetaConstants..::.MetaSqlTypes _
)
Visual C++
public:
void RefreshSqls(
    MetaConstants..::.MetaEntity me,
    int externalKeyId,
    bool isAll,
    MetaConstants..::.MetaSqlTypes sqlType
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity
externalKeyId
Type: System..::.Int32
The external key id, usually the group id
isAll
Type: System..::.Boolean
If all the sqls will be refreshed
sqlType
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaSqlTypes
The sql type

See Also

MetaSqlDB Class
RefreshSqls Overload
OfficeClip.DBLayer.Metabase Namespace


SecondaryTableInsertParameters Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.SecondaryTableInsertParameters Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Insert parameter for the secondary table

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string SecondaryTableInsertParameters(
    ref DataSet ds
)
Visual Basic (Declaration)
Protected Function SecondaryTableInsertParameters ( _
    ByRef ds As DataSet _
) As String
Visual C++
protected:
String^ SecondaryTableInsertParameters(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
MetaSqlDB..::.SetSPCommand Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

MetaSqlDB Class
MetaSqlDB Members
OfficeClip.DBLayer.Metabase Namespace


SqlDelete Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.SqlDelete Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

The sql delete statement

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string SqlDelete(
    ref DataSet ds
)
Visual Basic (Declaration)
Public Function SqlDelete ( _
    ByRef ds As DataSet _
) As String
Visual C++
public:
String^ SqlDelete(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%
The metabase dataset

Return Value

The sql statement

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


SqlInsert Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.SqlInsert Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

The sql insert statement

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string SqlInsert(
    ref DataSet ds
)
Visual Basic (Declaration)
Public Function SqlInsert ( _
    ByRef ds As DataSet _
) As String
Visual C++
public:
String^ SqlInsert(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%
The dataset for the metabase

Return Value

The sql string

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


SqlSelectAll Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.SqlSelectAll Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Sql for selecting all the information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string SqlSelectAll(
    ref DataSet ds,
    int externalKeyId
)
Visual Basic (Declaration)
Public Function SqlSelectAll ( _
    ByRef ds As DataSet, _
    externalKeyId As Integer _
) As String
Visual C++
public:
String^ SqlSelectAll(
    DataSet^% ds,
    int externalKeyId
)

Parameters

ds
Type: System.Data..::.DataSet%
The dataset
externalKeyId
Type: System..::.Int32
The external key id, usually the group id

Return Value

The sql string

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


SqlSelectByFilter Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.SqlSelectByFilter Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Sql statement for select by filter

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string SqlSelectByFilter(
    ref DataSet ds,
    int externalKeyId
)
Visual Basic (Declaration)
Public Function SqlSelectByFilter ( _
    ByRef ds As DataSet, _
    externalKeyId As Integer _
) As String
Visual C++
public:
String^ SqlSelectByFilter(
    DataSet^% ds,
    int externalKeyId
)

Parameters

ds
Type: System.Data..::.DataSet%
The dataset
externalKeyId
Type: System..::.Int32
The external id, usually the group id

Return Value

The sql string

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


SqlSelectByPk Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.SqlSelectByPk Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Sql statement for select by primary key

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string SqlSelectByPk(
    ref DataSet ds
)
Visual Basic (Declaration)
Public Function SqlSelectByPk ( _
    ByRef ds As DataSet _
) As String
Visual C++
public:
String^ SqlSelectByPk(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%
The dataset

Return Value

The sql string

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


SqlSelectLists Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.SqlSelectLists Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

The sql select list

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string SqlSelectLists(
    ref DataSet ds,
    int externalKeyId
)
Visual Basic (Declaration)
Public Function SqlSelectLists ( _
    ByRef ds As DataSet, _
    externalKeyId As Integer _
) As String
Visual C++
public:
String^ SqlSelectLists(
    DataSet^% ds,
    int externalKeyId
)

Parameters

ds
Type: System.Data..::.DataSet%
The metabase dataset
externalKeyId
Type: System..::.Int32
The external id, usually the group id

Return Value

The sql statement

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


SqlSelectPreferred Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.SqlSelectPreferred Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Sql statement for preferred information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string SqlSelectPreferred(
    ref DataSet ds,
    int externalKeyId
)
Visual Basic (Declaration)
Public Function SqlSelectPreferred ( _
    ByRef ds As DataSet, _
    externalKeyId As Integer _
) As String
Visual C++
public:
String^ SqlSelectPreferred(
    DataSet^% ds,
    int externalKeyId
)

Parameters

ds
Type: System.Data..::.DataSet%
The dataset
externalKeyId
Type: System..::.Int32
The external key id

Return Value

The sql string

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


SqlUpdateFixed Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.SqlUpdateFixed Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

The sql update statement for the fixed field

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string SqlUpdateFixed(
    ref DataSet ds
)
Visual Basic (Declaration)
Public Function SqlUpdateFixed ( _
    ByRef ds As DataSet _
) As String
Visual C++
public:
String^ SqlUpdateFixed(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%
The metabase dataset

Return Value

The sql statement

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


SqlUpdateUdf Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.SqlUpdateUdf Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

The sql update statement for the user defined fields

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string SqlUpdateUdf(
    ref DataSet ds
)
Visual Basic (Declaration)
Public Function SqlUpdateUdf ( _
    ByRef ds As DataSet _
) As String
Visual C++
public:
String^ SqlUpdateUdf(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%
The metabase dataset

Return Value

The sql statement

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


UdfListSelects Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.UdfListSelects Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

User defined list selects

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string UdfListSelects(
    ref StringBuilder sb,
    DataRow drow,
    ref DataSet ds,
    int externalKeyId
)
Visual Basic (Declaration)
Protected Function UdfListSelects ( _
    ByRef sb As StringBuilder, _
    drow As DataRow, _
    ByRef ds As DataSet, _
    externalKeyId As Integer _
) As String
Visual C++
protected:
String^ UdfListSelects(
    StringBuilder^% sb,
    DataRow^ drow,
    DataSet^% ds,
    int externalKeyId
)

Parameters

sb
Type: System.Text..::.StringBuilder%
drow
Type: System.Data..::.DataRow
ds
Type: System.Data..::.DataSet%
externalKeyId
Type: System..::.Int32

Return Value

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


UpdateMetaSqls Method

[image]

OfficeClip API Documentation
MetaSqlDB..::.UpdateMetaSqls Method
MetaSqlDB Class See Also

[This is preliminary documentation and is subject to change.]

Create the update sql for the metabase

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void UpdateMetaSqls(
    MetaConstants..::.MetaSqlTypes mst,
    MetaConstants..::.MetaEntity me,
    string sql,
    int externalKeyId
)
Visual Basic (Declaration)
Protected Sub UpdateMetaSqls ( _
    mst As MetaConstants..::.MetaSqlTypes, _
    me As MetaConstants..::.MetaEntity, _
    sql As String, _
    externalKeyId As Integer _
)
Visual C++
protected:
void UpdateMetaSqls(
    MetaConstants..::.MetaSqlTypes mst,
    MetaConstants..::.MetaEntity me,
    String^ sql,
    int externalKeyId
)

Parameters

mst
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaSqlTypes
me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
sql
Type: System..::.String
externalKeyId
Type: System..::.Int32

See Also

MetaSqlDB Class
OfficeClip.DBLayer.Metabase Namespace


TrackerMetaDB Class

[image]

OfficeClip API Documentation
TrackerMetaDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to manipulate meta information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerMetaDB : OfficeClipDB
Visual Basic (Declaration)
Public Class TrackerMetaDB _
    Inherits OfficeClipDB
Visual C++
public ref class TrackerMetaDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Metabase..::.TrackerMetaDB

See Also

TrackerMetaDB Members
OfficeClip.DBLayer.Metabase Namespace


TrackerMetaDB Members

[image] [image]

OfficeClip API Documentation
TrackerMetaDB Members
TrackerMetaDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerMetaDB type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerMetaDB | The default constructor

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTrackerData | Gets the tracker data and converts it into the metadata
Public method | GetTrackerDataForReport | Returns the metabase related to the tracker information. This helps in creation of the report using the existing infrastructure of the metabase report.
Public method | GetTrackerMetabase | Gets the tracker metabase information
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

TrackerMetaDB Class
OfficeClip.DBLayer.Metabase Namespace


TrackerMetaDB Constructor

[image]

OfficeClip API Documentation
TrackerMetaDB Constructor
TrackerMetaDB Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerMetaDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerMetaDB()

See Also

TrackerMetaDB Class
OfficeClip.DBLayer.Metabase Namespace


TrackerMetaDB Methods

[image] [image]

OfficeClip API Documentation
TrackerMetaDB Methods
TrackerMetaDB Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerMetaDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTrackerData | Gets the tracker data and converts it into the metadata
Public method | GetTrackerDataForReport | Returns the metabase related to the tracker information. This helps in creation of the report using the existing infrastructure of the metabase report.
Public method | GetTrackerMetabase | Gets the tracker metabase information
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerMetaDB Class
OfficeClip.DBLayer.Metabase Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
TrackerMetaDB..::.AddOutputParameter Method
TrackerMetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

TrackerMetaDB Class
TrackerMetaDB Members
OfficeClip.DBLayer.Metabase Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
TrackerMetaDB..::.AddParameter Method
TrackerMetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

TrackerMetaDB Class
TrackerMetaDB Members
OfficeClip.DBLayer.Metabase Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
TrackerMetaDB..::.AddParameters Method
TrackerMetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

TrackerMetaDB Class
TrackerMetaDB Members
OfficeClip.DBLayer.Metabase Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
TrackerMetaDB..::.ExecuteNonQuery Method
TrackerMetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

TrackerMetaDB Class
TrackerMetaDB Members
OfficeClip.DBLayer.Metabase Namespace


GetTrackerData Method

[image]

OfficeClip API Documentation
TrackerMetaDB..::.GetTrackerData Method
TrackerMetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tracker data and converts it into the metadata

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTrackerData(
    int projectId,
    int filterId,
    string[] fields,
    int currentUserId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function GetTrackerData ( _
    projectId As Integer, _
    filterId As Integer, _
    fields As String(), _
    currentUserId As Integer, _
    currentGroupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetTrackerData(
    int projectId,
    int filterId,
    array<String^>^ fields,
    int currentUserId,
    int currentGroupId
)

Parameters

projectId
Type: System..::.Int32
The unique if of the project
filterId
Type: System..::.Int32
The unique id of the filter
fields
Type: array<System..::.String>[]()[]
The array of field ids that should be shown in the output
currentUserId
Type: System..::.Int32
The id of the current user
currentGroupId
Type: System..::.Int32
The id of the current group

Return Value

The metadata for the tracker

See Also

TrackerMetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetTrackerDataForReport Method

[image]

OfficeClip API Documentation
TrackerMetaDB..::.GetTrackerDataForReport Method
TrackerMetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the metabase related to the tracker information. This helps in creation of the report using the existing infrastructure of the metabase report.

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTrackerDataForReport(
    int projectId,
    int reportId,
    int currentUserId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function GetTrackerDataForReport ( _
    projectId As Integer, _
    reportId As Integer, _
    currentUserId As Integer, _
    currentGroupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetTrackerDataForReport(
    int projectId,
    int reportId,
    int currentUserId,
    int currentGroupId
)

Parameters

projectId
Type: System..::.Int32
the unique id of the project
reportId
Type: System..::.Int32
The unique id of the report
currentUserId
Type: System..::.Int32
The id of the current user
currentGroupId
Type: System..::.Int32
The id of the current group

Return Value

The dataset related to the report

See Also

TrackerMetaDB Class
OfficeClip.DBLayer.Metabase Namespace


GetTrackerMetabase Method

[image]

OfficeClip API Documentation
TrackerMetaDB..::.GetTrackerMetabase Method
TrackerMetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tracker metabase information

Namespace: OfficeClip.DBLayer.Metabase
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetTrackerMetabase(
    int projectId,
    bool showBasicTypes
)
Visual Basic (Declaration)
Public Function GetTrackerMetabase ( _
    projectId As Integer, _
    showBasicTypes As Boolean _
) As DataTable
Visual C++
public:
DataTable^ GetTrackerMetabase(
    int projectId,
    bool showBasicTypes
)

Parameters

projectId
Type: System..::.Int32
The unique id of the project
showBasicTypes
Type: System..::.Boolean

Return Value

The datatable corresponding to the metabase

See Also

TrackerMetaDB Class
OfficeClip.DBLayer.Metabase Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
TrackerMetaDB..::.InitTransaction Method
TrackerMetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

TrackerMetaDB Class
TrackerMetaDB Members
OfficeClip.DBLayer.Metabase Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
TrackerMetaDB..::.SetSPCommand Method
TrackerMetaDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

TrackerMetaDB Class
TrackerMetaDB Members
OfficeClip.DBLayer.Metabase Namespace


OfficeClip.DBLayer.Oem Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Oem Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip Enterprise Manager. The Enterprise Manager is deprecated but this class is still used for various things

Classes

 | Class | Description
Public class | OemDB | Provides a set of OfficeClip Enterprise Manager related functions.

Enumerations

 | Enumeration | Description
Public enumeration | OemDB..::.OemPasswordValidate | Enumerated type for the password validation


OemDB Class

[image]

OfficeClip API Documentation
OemDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of OfficeClip Enterprise Manager related functions.

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class OemDB : OfficeClipDB
Visual Basic (Declaration)
Public Class OemDB _
    Inherits OfficeClipDB
Visual C++
public ref class OemDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Oem..::.OemDB

See Also

OemDB Members
OfficeClip.DBLayer.Oem Namespace


OemDB Members

[image] [image]

OfficeClip API Documentation
OemDB Members
OemDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OemDB type exposes the following members.

Constructors

 | Name | Description
Public method | OemDB |

Methods

Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method AnyGroups
Checks up if there are any groups in the OfficeClip system.
Public method ClearParameters
Clear all the sql stored procedure parameters
(Inherited from OfficeClipDB.)
Public method Close
Close the connection, data adapter and the command
(Inherited from OfficeClipDB.)
Public method Commit
Commits the transaction
(Inherited from OfficeClipDB.)
Public method Ddiff
Gets the difference between the expiry DateTime in the license and Current DateTime.
Public method DeleteLoginParameters
Deletes the login parameters
Public method Dispose
disposes the object for garbage collection
(Inherited from OfficeClipDB.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method ExecuteReader
Executes the sql datareader
(Inherited from OfficeClipDB.)
Protected method ExecuteScalar
Executes the query that returns a single valur
(Inherited from OfficeClipDB.)
Protected method Fill
Fills the dataset
(Inherited from OfficeClipDB.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDatabaseVersionNumber
Gets the database Version from the database.
Public method GetGroupsCount
Get the count of the total users
Public method GetHashCode
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
(Inherited from Object.)
Public method GetLoginParameters
Gets the login parameters
Public method GetParameterCount
Gets the parameter count
(Inherited from OfficeClipDB.)
Public method GetParameterValue
Gets the value of the parameter
(Inherited from OfficeClipDB.)
Public method GetSqlServerVersion
Gets the Sql Server version number.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUsersCount
Get the count of the total users
Protected method Init
Initialize the connection parameters
(Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method IsLicenseTimeLimitValid
Checks if the license time limit is valid
Public method IsLicenseUserLimitValid
Checks if the license user limit is valid
Public method IsOCSysAdmin
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method NewLicense
Updates the new license.
Public method Rollback
Rolls back the transaction
(Inherited from OfficeClipDB.)
Public method SetParameterValue
Sets the parameter value of the sql parameter to a known value
(Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method SetSPDataAdapter
Sets the stored procedure data adapter
(Inherited from OfficeClipDB.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method Udiff
Gets the difference between the number of users licensed in license file and Current number of users in the OfficeClip System.
Public method UpdateLdapAccountName
Updates the LDAP Account Name corresponding to a user identified by the userId.
Public method UpdateLoginParameters
Updates the login parameters
Public method Upddiff
Gets the difference between the upgrade Limit DateTime in the license and Current DateTime.
Public method UpdSiteAdministratorPassword
Updates the site administrator's password into the database.
Public method ValidateSiteAdministrator
Validate the site administrator, Checks up the following with regards to the site administrator password
  • Whether is password is set in the database
  • Whether the password validation succeeded
This function also encrypts the administrator's password and stores it in the database
Public method ValidateVersionNumber
Validates the Version number from the Constants file and the one in the database.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


OemDB Constructor

[image]

OfficeClip API Documentation
OemDB Constructor
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OemDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OemDB()

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


OemDB Methods

[image] [image]

OfficeClip API Documentation
OemDB Methods
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

The OemDB type exposes the following methods.

Methods

Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method AnyGroups
Checks up if there are any groups in the OfficeClip system.
Public method ClearParameters
Clear all the sql stored procedure parameters
(Inherited from OfficeClipDB.)
Public method Close
Close the connection, data adapter and the command
(Inherited from OfficeClipDB.)
Public method Commit
Commits the transaction
(Inherited from OfficeClipDB.)
Public method Ddiff
Gets the difference between the expiry DateTime in the license and Current DateTime.
Public method DeleteLoginParameters
Deletes the login parameters
Public method Dispose
disposes the object for garbage collection
(Inherited from OfficeClipDB.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method ExecuteReader
Executes the sql datareader
(Inherited from OfficeClipDB.)
Protected method ExecuteScalar
Executes the query that returns a single valur
(Inherited from OfficeClipDB.)
Protected method Fill
Fills the dataset
(Inherited from OfficeClipDB.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetDatabaseVersionNumber
Gets the database Version from the database.
Public method GetGroupsCount
Get the count of the total users
Public method GetHashCode
Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table.
(Inherited from Object.)
Public method GetLoginParameters
Gets the login parameters
Public method GetParameterCount
Gets the parameter count
(Inherited from OfficeClipDB.)
Public method GetParameterValue
Gets the value of the parameter
(Inherited from OfficeClipDB.)
Public method GetSqlServerVersion
Gets the Sql Server version number.
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetUsersCount
Get the count of the total users
Protected method Init
Initialize the connection parameters
(Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method IsLicenseTimeLimitValid
Checks if the license time limit is valid
Public method IsLicenseUserLimitValid
Checks if the license user limit is valid
Public method IsOCSysAdmin
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method NewLicense
Updates the new license.
Public method Rollback
Rolls back the transaction
(Inherited from OfficeClipDB.)
Public method SetParameterValue
Sets the parameter value of the sql parameter to a known value
(Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method SetSPDataAdapter
Sets the stored procedure data adapter
(Inherited from OfficeClipDB.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method Udiff
Gets the difference between the number of users licensed in license file and Current number of users in the OfficeClip System.
Public method UpdateLdapAccountName
Updates the LDAP Account Name corresponding to a user identified by the userId.
Public method UpdateLoginParameters
Updates the login parameters
Public method Upddiff
Gets the difference between the upgrade Limit DateTime in the license and Current DateTime.
Public method UpdSiteAdministratorPassword
Updates the site administrator's password into the database.
Public method ValidateSiteAdministrator
Validate the site administrator, Checks up the following with regards to the site administrator password
  • Whether is password is set in the database
  • Whether the password validation succeeded
This function also encrypts the administrator's password and stores it in the database
Public method ValidateVersionNumber
Validates the Version number from the Constants file and the one in the database.

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
OemDB..::.AddOutputParameter Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

OemDB Class
OemDB Members
OfficeClip.DBLayer.Oem Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
OemDB..::.AddParameter Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

OemDB Class
OemDB Members
OfficeClip.DBLayer.Oem Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
OemDB..::.AddParameters Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

OemDB Class
OemDB Members
OfficeClip.DBLayer.Oem Namespace


AnyGroups Method

[image]

OfficeClip API Documentation
OemDB..::.AnyGroups Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks up if there are any groups in the OfficeClip system.

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool AnyGroups()
Visual Basic (Declaration)
Public Function AnyGroups As Boolean
Visual C++
public:
bool AnyGroups()

Return Value

True if at least one group is created in OfficeClip, False otherwise.

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


Ddiff Method

[image]

OfficeClip API Documentation
OemDB..::.Ddiff Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the difference between the expiry DateTime in the license and Current DateTime.

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Ddiff()
Visual Basic (Declaration)
Public Function Ddiff As Integer
Visual C++
public:
int Ddiff()

Return Value

Number of days remaining to expire else -1.

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


DeleteLoginParameters Method

[image]

OfficeClip API Documentation
OemDB..::.DeleteLoginParameters Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the login parameters

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteLoginParameters()
Visual Basic (Declaration)
Public Sub DeleteLoginParameters
Visual C++
public:
void DeleteLoginParameters()

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
OemDB..::.ExecuteNonQuery Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

OemDB Class
OemDB Members
OfficeClip.DBLayer.Oem Namespace


GetDatabaseVersionNumber Method

[image]

OfficeClip API Documentation
OemDB..::.GetDatabaseVersionNumber Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the database Version from the database.

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetDatabaseVersionNumber()
Visual Basic (Declaration)
Public Function GetDatabaseVersionNumber As String
Visual C++
public:
String^ GetDatabaseVersionNumber()

Return Value

Database Version from the database.

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


GetGroupsCount Method

[image]

OfficeClip API Documentation
OemDB..::.GetGroupsCount Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the count of the total users

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetGroupsCount()
Visual Basic (Declaration)
Public Function GetGroupsCount As Integer
Visual C++
public:
int GetGroupsCount()

Return Value

The total number of users

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


GetLoginParameters Method

[image]

OfficeClip API Documentation
OemDB..::.GetLoginParameters Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the login parameters

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetLoginParameters(
    ref LoginSetupInfo loginSetupInfo,
    int accountId
)
Visual Basic (Declaration)
Public Sub GetLoginParameters ( _
    ByRef loginSetupInfo As LoginSetupInfo, _
    accountId As Integer _
)
Visual C++
public:
void GetLoginParameters(
    LoginSetupInfo^% loginSetupInfo,
    int accountId
)

Parameters

loginSetupInfo
Type: OfficeClip.BusinessLayer.Framework..::.LoginSetupInfo %
accountId
Type: System..::.Int32
The account id of the current account, if -1 then no account is specified

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


GetSqlServerVersion Method

[image]

OfficeClip API Documentation
OemDB..::.GetSqlServerVersion Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Sql Server version number.

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetSqlServerVersion()
Visual Basic (Declaration)
Public Function GetSqlServerVersion As String
Visual C++
public:
String^ GetSqlServerVersion()

Return Value

Sql Server version number.

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


GetUsersCount Method

[image]

OfficeClip API Documentation
OemDB..::.GetUsersCount Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the count of the total users

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetUsersCount()
Visual Basic (Declaration)
Public Function GetUsersCount As Integer
Visual C++
public:
int GetUsersCount()

Return Value

The total number of users

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
OemDB..::.InitTransaction Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

OemDB Class
OemDB Members
OfficeClip.DBLayer.Oem Namespace


IsLicenseTimeLimitValid Method

[image]

OfficeClip API Documentation
OemDB..::.IsLicenseTimeLimitValid Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks if the license time limit is valid

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsLicenseTimeLimitValid(
    int userId
)
Visual Basic (Declaration)
Public Function IsLicenseTimeLimitValid ( _
    userId As Integer _
) As Boolean
Visual C++
public:
bool IsLicenseTimeLimitValid(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


IsLicenseUserLimitValid Method

[image]

OfficeClip API Documentation
OemDB..::.IsLicenseUserLimitValid Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks if the license user limit is valid

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsLicenseUserLimitValid(
    int userId
)
Visual Basic (Declaration)
Public Function IsLicenseUserLimitValid ( _
    userId As Integer _
) As Boolean
Visual C++
public:
bool IsLicenseUserLimitValid(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


IsOCSysAdmin Method

[image]

OfficeClip API Documentation
OemDB..::.IsOCSysAdmin Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsOCSysAdmin(
    string pwd
)
Visual Basic (Declaration)
Public Function IsOCSysAdmin ( _
    pwd As String _
) As Boolean
Visual C++
public:
bool IsOCSysAdmin(
    String^ pwd
)

Parameters

pwd
Type: System..::.String

Return Value

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


NewLicense Method

[image]

OfficeClip API Documentation
OemDB..::.NewLicense Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the new license.

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void NewLicense(
    string ls
)
Visual Basic (Declaration)
Public Sub NewLicense ( _
    ls As String _
)
Visual C++
public:
void NewLicense(
    String^ ls
)

Parameters

ls
Type: System..::.String
String containing the new license key.

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
OemDB..::.SetSPCommand Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

OemDB Class
OemDB Members
OfficeClip.DBLayer.Oem Namespace


Udiff Method

[image]

OfficeClip API Documentation
OemDB..::.Udiff Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the difference between the number of users licensed in license file and Current number of users in the OfficeClip System.

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Udiff()
Visual Basic (Declaration)
Public Function Udiff As Integer
Visual C++
public:
int Udiff()

Return Value

Difference between the number of users licensed in license file and Current number of users in the OfficeClip System.

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


UpdateLdapAccountName Method

[image]

OfficeClip API Documentation
OemDB..::.UpdateLdapAccountName Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the LDAP Account Name corresponding to a user identified by the userId.

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateLdapAccountName(
    int userId,
    string ldapAccountName
)
Visual Basic (Declaration)
Public Function UpdateLdapAccountName ( _
    userId As Integer, _
    ldapAccountName As String _
) As Integer
Visual C++
public:
int UpdateLdapAccountName(
    int userId,
    String^ ldapAccountName
)

Parameters

userId
Type: System..::.Int32
Id of the user for whom the LDAP Account Name has to be updated.
ldapAccountName
Type: System..::.String
LDAP account name to be udpated.

Return Value

0 if successful, -1 in case of an error.

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


UpdateLoginParameters Method

[image]

OfficeClip API Documentation
OemDB..::.UpdateLoginParameters Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the login parameters

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateLoginParameters(
    string header,
    string message,
    int accountId
)
Visual Basic (Declaration)
Public Sub UpdateLoginParameters ( _
    header As String, _
    message As String, _
    accountId As Integer _
)
Visual C++
public:
void UpdateLoginParameters(
    String^ header,
    String^ message,
    int accountId
)

Parameters

header
Type: System..::.String
message
Type: System..::.String
accountId
Type: System..::.Int32

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


Upddiff Method

[image]

OfficeClip API Documentation
OemDB..::.Upddiff Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the difference between the upgrade Limit DateTime in the license and Current DateTime.

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Upddiff()
Visual Basic (Declaration)
Public Function Upddiff As Integer
Visual C++
public:
int Upddiff()

Return Value

Number of days remaining when the upgrade Limit expires else -1.

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


UpdSiteAdministratorPassword Method

[image]

OfficeClip API Documentation
OemDB..::.UpdSiteAdministratorPassword Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the site administrator's password into the database.

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdSiteAdministratorPassword(
    string password
)
Visual Basic (Declaration)
Public Sub UpdSiteAdministratorPassword ( _
    password As String _
)
Visual C++
public:
void UpdSiteAdministratorPassword(
    String^ password
)

Parameters

password
Type: System..::.String
Site administrator's password.

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


ValidateSiteAdministrator Method

[image]

OfficeClip API Documentation
OemDB..::.ValidateSiteAdministrator Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Validate the site administrator, Checks up the following with regards to the site administrator password
  • Whether is password is set in the database
  • Whether the password validation succeeded
This function also encrypts the administrator's password and stores it in the database

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OemDB..::.OemPasswordValidate ValidateSiteAdministrator(
    string password
)
Visual Basic (Declaration)
Public Function ValidateSiteAdministrator ( _
    password As String _
) As OemDB..::.OemPasswordValidate
Visual C++
public:
OemDB..::.OemPasswordValidate ValidateSiteAdministrator(
    String^ password
)

Parameters

password
Type: System..::.String
The clear text password

Return Value

The return value. OemDB..::.OemPasswordValidate

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


ValidateVersionNumber Method

[image]

OfficeClip API Documentation
OemDB..::.ValidateVersionNumber Method
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Validates the Version number from the Constants file and the one in the database.

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool ValidateVersionNumber()
Visual Basic (Declaration)
Public Function ValidateVersionNumber As Boolean
Visual C++
public:
bool ValidateVersionNumber()

Return Value

True if the Version numbers match, otherwise False.

See Also

OemDB Class
OfficeClip.DBLayer.Oem Namespace


OemDB.OemPasswordValidate Enumeration

[image]

OfficeClip API Documentation
OemDB..::.OemPasswordValidate Enumeration
OemDB Class See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for the password validation

Namespace: OfficeClip.DBLayer.Oem
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public enum OemPasswordValidate
Visual Basic (Declaration)
Public Enumeration OemPasswordValidate
Visual C++
public enum class OemPasswordValidate

Members

Member name | Description
OemPasswordError | If the password is incorrectly typed
OemPasswordSuccess | If the password is correctly typed
OemPasswordNoSet | If the password in the database is not set
OemPasswordSet | If the password is set in the database
OemPasswordUnknownError | Unknown Error in the database password match

See Also

OfficeClip.DBLayer.Oem Namespace


OfficeClip.DBLayer.OfficePortal Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.OfficePortal Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip Portal. The portal contains home page, alerts etc.

Classes

 | Class | Description
Public class | AlertDB | Allows management of OfficeClip Alerts.
Public class | AnnounceDB | Allows management of OfficeClip Announcements.
Public class | BbDB | Allows management of Bulletin Board related functions.
Public class | GroupbookmarkDB | Provides a set of Bookmark application related functions.
Public class | NotesDB | This is the database layer to handle Notes database queries.
Public class | PhotoDB | Provides a set of Photo application related functions.
Public class | PollDB | Provides a set of Poll application related functions.
Public class | PortletDB | Provides a set of Portlet application related functions.
Public class | RssDB | Summary description for the news feed.


AlertDB Class

[image]

OfficeClip API Documentation
AlertDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Allows management of OfficeClip Alerts.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class AlertDB : OfficeClipDB
Visual Basic (Declaration)
Public Class AlertDB _
    Inherits OfficeClipDB
Visual C++
public ref class AlertDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.OfficePortal..::.AlertDB

See Also

AlertDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AlertDB Members

[image] [image]

OfficeClip API Documentation
AlertDB Members
AlertDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AlertDB type exposes the following members.

Constructors

 | Name | Description
Public method | AlertDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DelAlert | Remove an alert.
Public method | DelAlertEvents | Remove alerts for the events that has been removed from the list.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlertDetailsByUser | Gets all the alerts for a particular user. This includes only Active alerts, i.e. not archived alerts.
Public method | GetArchivedAlertsByUser | Gets all the Archived alerts for a particular user
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | IsAlertPending | Checks if an alert is pending for the Current login user.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetAlert | This function will be used to send any transactional alerts in OfficeClip. When an alert is sent, the alert gif in officeclip starts blinking. If the sent to the group, all the members of the group (whether registered or not) will get separate alerts.
Public method | SetArchiveAlerts | Sets the alerts to the archived State. Alerts in the archived State are viewed by the user when they click on the archived alerts link. An exception is thrown if the data setting is not successful.
Public method | SetInvitationResponse | Sets a response to an invitation in the alert.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAlertEventChanged | Updates the alert message of an event

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AlertDB Constructor

[image]

OfficeClip API Documentation
AlertDB Constructor
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public AlertDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AlertDB()

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AlertDB Methods

[image] [image]

OfficeClip API Documentation
AlertDB Methods
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

The AlertDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DelAlert | Remove an alert.
Public method | DelAlertEvents | Remove alerts for the events that has been removed from the list.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlertDetailsByUser | Gets all the alerts for a particular user. This includes only Active alerts, i.e. not archived alerts.
Public method | GetArchivedAlertsByUser | Gets all the Archived alerts for a particular user
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | IsAlertPending | Checks if an alert is pending for the Current login user.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetAlert | This function will be used to send any transactional alerts in OfficeClip. When an alert is sent, the alert gif in officeclip starts blinking. If the sent to the group, all the members of the group (whether registered or not) will get separate alerts.
Public method | SetArchiveAlerts | Sets the alerts to the archived State. Alerts in the archived State are viewed by the user when they click on the archived alerts link. An exception is thrown if the data setting is not successful.
Public method | SetInvitationResponse | Sets a response to an invitation in the alert.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAlertEventChanged | Updates the alert message of an event

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
AlertDB..::.AddOutputParameter Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

AlertDB Class
AlertDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
AlertDB..::.AddParameter Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

AlertDB Class
AlertDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
AlertDB..::.AddParameters Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

AlertDB Class
AlertDB Members
OfficeClip.DBLayer.OfficePortal Namespace


DelAlert Method

[image]

OfficeClip API Documentation
AlertDB..::.DelAlert Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Remove an alert.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DelAlert(
    int alertId
)
Visual Basic (Declaration)
Public Sub DelAlert ( _
    alertId As Integer _
)
Visual C++
public:
void DelAlert(
    int alertId
)

Parameters

alertId
Type: System..::.Int32
The unique id of the event

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


DelAlertEvents Method

[image]

OfficeClip API Documentation
AlertDB..::.DelAlertEvents Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Remove alerts for the events that has been removed from the list.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DelAlertEvents(
    int eventId
)
Visual Basic (Declaration)
Public Sub DelAlertEvents ( _
    eventId As Integer _
)
Visual C++
public:
void DelAlertEvents(
    int eventId
)

Parameters

eventId
Type: System..::.Int32
The unique id of the event

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
AlertDB..::.ExecuteNonQuery Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

AlertDB Class
AlertDB Members
OfficeClip.DBLayer.OfficePortal Namespace


GetAlertDetailsByUser Method

[image]

OfficeClip API Documentation
AlertDB..::.GetAlertDetailsByUser Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the alerts for a particular user. This includes only Active alerts, i.e. not archived alerts.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAlertDetailsByUser(
    int userId
)
Visual Basic (Declaration)
Public Function GetAlertDetailsByUser ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAlertDetailsByUser(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id for the user.

Return Value

The DataSet containing all the alerts. Following are the columns of the dataset. The dataset consists of the following fields:
  • alertType(string)
  • action(string)
  • name(string as (firstname lastname))
  • alertId(int)
  • message(string)
  • createdDatetime(datetime)

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetArchivedAlertsByUser Method

[image]

OfficeClip API Documentation
AlertDB..::.GetArchivedAlertsByUser Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the Archived alerts for a particular user

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetArchivedAlertsByUser(
    int userId
)
Visual Basic (Declaration)
Public Function GetArchivedAlertsByUser ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetArchivedAlertsByUser(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique identifier for the user.

Return Value

The DataSet containing all the values The output dataset consists of the following columns:
  • alertType(string)
  • action(string)
  • name(string as (firstname lastname))
  • alertId(int)
  • message(string)
  • createdDatetime(datetime)

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
AlertDB..::.InitTransaction Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

AlertDB Class
AlertDB Members
OfficeClip.DBLayer.OfficePortal Namespace


IsAlertPending Method

[image]

OfficeClip API Documentation
AlertDB..::.IsAlertPending Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks if an alert is pending for the Current login user.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsAlertPending(
    int userId
)
Visual Basic (Declaration)
Public Function IsAlertPending ( _
    userId As Integer _
) As Boolean
Visual C++
public:
bool IsAlertPending(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique identifier for the user.

Return Value

if true than an alert is pending for the Current login user, if false otherwise.

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


SetAlert Method

[image]

OfficeClip API Documentation
AlertDB..::.SetAlert Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

This function will be used to send any transactional alerts in OfficeClip. When an alert is sent, the alert gif in officeclip starts blinking. If the sent to the group, all the members of the group (whether registered or not) will get separate alerts.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetAlert(
    int sendUserId,
    int isGroup,
    string message,
    string action,
    string alertType,
    string priority,
    int applicationId,
    int applicationSecondaryId,
    int id1,
    int id2,
    int isSecured,
    int userId,
    int sendGroupId
)
Visual Basic (Declaration)
Public Function SetAlert ( _
    sendUserId As Integer, _
    isGroup As Integer, _
    message As String, _
    action As String, _
    alertType As String, _
    priority As String, _
    applicationId As Integer, _
    applicationSecondaryId As Integer, _
    id1 As Integer, _
    id2 As Integer, _
    isSecured As Integer, _
    userId As Integer, _
    sendGroupId As Integer _
) As Integer
Visual C++
public:
int SetAlert(
    int sendUserId,
    int isGroup,
    String^ message,
    String^ action,
    String^ alertType,
    String^ priority,
    int applicationId,
    int applicationSecondaryId,
    int id1,
    int id2,
    int isSecured,
    int userId,
    int sendGroupId
)

Parameters

sendUserId
Type: System..::.Int32
The user id to whom the alert is sent. a -1 value indicates that the userId, is null
isGroup
Type: System..::.Int32
1 if it is group alert, 0 if user alert
message
Type: System..::.String
The alert message
action
Type: System..::.String
The javascript to which determines what happens when a user clicks on the action
alertType
Type: System..::.String
what kind of alert, e.g. Invitation
priority
Type: System..::.String
'L' = Low, 'M' = Middle and 'H' = High
applicationId
Type: System..::.Int32
The application which sent the alert
applicationSecondaryId
Type: System..::.Int32
application specific information
id1
Type: System..::.Int32
application specific information
id2
Type: System..::.Int32
application specific information
isSecured
Type: System..::.Int32
if 1, the system will check whether the user has access to send alert to another user or group. If 0, alert will be sent to anybody. Making it 0 can make the query run a little faster
userId
Type: System..::.Int32
Id of the the user from whom this alert is being sent.
sendGroupId
Type: System..::.Int32
Id of the group to which the message is being sent.

Return Value

Returns the alert_id if successful, returns a negative number if error

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


SetArchiveAlerts Method

[image]

OfficeClip API Documentation
AlertDB..::.SetArchiveAlerts Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the alerts to the archived State. Alerts in the archived State are viewed by the user when they click on the archived alerts link. An exception is thrown if the data setting is not successful.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetArchiveAlerts(
    string alertList,
    int userId,
    bool isArchive
)
Visual Basic (Declaration)
Public Sub SetArchiveAlerts ( _
    alertList As String, _
    userId As Integer, _
    isArchive As Boolean _
)
Visual C++
public:
void SetArchiveAlerts(
    String^ alertList,
    int userId,
    bool isArchive
)

Parameters

alertList
Type: System..::.String
The comma separated list of the alert ids.
userId
Type: System..::.Int32
The unique identifier for the user.
isArchive
Type: System..::.Boolean
true if alert is to be archived, false if it is to be restored

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


SetInvitationResponse Method

[image]

OfficeClip API Documentation
AlertDB..::.SetInvitationResponse Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets a response to an invitation in the alert.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SetInvitationResponse(
    int alertId,
    string response,
    int userId
)
Visual Basic (Declaration)
Public Function SetInvitationResponse ( _
    alertId As Integer, _
    response As String, _
    userId As Integer _
) As Integer
Visual C++
public:
int SetInvitationResponse(
    int alertId,
    String^ response,
    int userId
)

Parameters

alertId
Type: System..::.Int32
Id of the alert for which the response has to be set.
response
Type: System..::.String
The response to be set.
userId
Type: System..::.Int32
Unique id of the user

Return Value

0 when successful, -1 otherwise.

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
AlertDB..::.SetSPCommand Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

AlertDB Class
AlertDB Members
OfficeClip.DBLayer.OfficePortal Namespace


UpdateAlertEventChanged Method

[image]

OfficeClip API Documentation
AlertDB..::.UpdateAlertEventChanged Method
AlertDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the alert message of an event

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateAlertEventChanged(
    int eventId,
    string message
)
Visual Basic (Declaration)
Public Sub UpdateAlertEventChanged ( _
    eventId As Integer, _
    message As String _
)
Visual C++
public:
void UpdateAlertEventChanged(
    int eventId,
    String^ message
)

Parameters

eventId
Type: System..::.Int32
The unique id of the event
message
Type: System..::.String
The alert message string

See Also

AlertDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AnnounceDB Class

[image]

OfficeClip API Documentation
AnnounceDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Allows management of OfficeClip Announcements.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class AnnounceDB : OfficeClipDB
Visual Basic (Declaration)
Public Class AnnounceDB _
    Inherits OfficeClipDB
Visual C++
public ref class AnnounceDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.OfficePortal..::.AnnounceDB

See Also

AnnounceDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AnnounceDB Members

[image] [image]

OfficeClip API Documentation
AnnounceDB Members
AnnounceDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AnnounceDB type exposes the following members.

Constructors

 | Name | Description
Public method | AnnounceDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | Archive | Marks a particular annoucement as archived.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Overloaded.
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Delete | Deletes a particular annoucement.
Public method | DeleteArchive | Deletes a particular archived announcement.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnnounce | Gets the annoucements for the currently logged in user.
Public method | GetAnnounceArchive | Gets the archived announcements for the currently logged in user.
Public method | GetDetail | Gets the details for a particular annoucement identified by announceId
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | Insert | Inserts the announcement into the database
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Marks a particular annoucement as open.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates the announcement into the database.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AnnounceDB Constructor

[image]

OfficeClip API Documentation
AnnounceDB Constructor
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public AnnounceDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnnounceDB()

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AnnounceDB Methods

[image] [image]

OfficeClip API Documentation
AnnounceDB Methods
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

The AnnounceDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | Archive | Marks a particular annoucement as archived.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Overloaded.
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Delete | Deletes a particular annoucement.
Public method | DeleteArchive | Deletes a particular archived announcement.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnnounce | Gets the annoucements for the currently logged in user.
Public method | GetAnnounceArchive | Gets the archived announcements for the currently logged in user.
Public method | GetDetail | Gets the details for a particular annoucement identified by announceId
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | Insert | Inserts the announcement into the database
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Marks a particular annoucement as open.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates the announcement into the database.

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
AnnounceDB..::.AddOutputParameter Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

AnnounceDB Class
AnnounceDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
AnnounceDB..::.AddParameter Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

AnnounceDB Class
AnnounceDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
AnnounceDB..::.AddParameters Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

AnnounceDB Class
AnnounceDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Archive Method

[image]

OfficeClip API Documentation
AnnounceDB..::.Archive Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Marks a particular annoucement as archived.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Archive(
    int announceId,
    int userId
)
Visual Basic (Declaration)
Public Sub Archive ( _
    announceId As Integer, _
    userId As Integer _
)
Visual C++
public:
void Archive(
    int announceId,
    int userId
)

Parameters

announceId
Type: System..::.Int32
id of the archived announcement which is to be marked as archived.
userId
Type: System..::.Int32
The unique id for the user.

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


Close Method

[image] [image]

OfficeClip API Documentation
AnnounceDB..::.Close Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Close()()() | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Close(Int32) | Marks a particular annoucement as closed.

See Also

AnnounceDB Class
AnnounceDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Close Method (Int32)

[image]

OfficeClip API Documentation
AnnounceDB..::.Close Method (Int32)
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Marks a particular annoucement as closed.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Close(
    int announceId
)
Visual Basic (Declaration)
Public Sub Close ( _
    announceId As Integer _
)
Visual C++
public:
void Close(
    int announceId
)

Parameters

announceId
Type: System..::.Int32
id of the announcement which is marked as closed.

See Also

AnnounceDB Class
Close Overload
OfficeClip.DBLayer.OfficePortal Namespace


Delete Method

[image]

OfficeClip API Documentation
AnnounceDB..::.Delete Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a particular annoucement.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Delete(
    int announceId
)
Visual Basic (Declaration)
Public Sub Delete ( _
    announceId As Integer _
)
Visual C++
public:
void Delete(
    int announceId
)

Parameters

announceId
Type: System..::.Int32
id of the announcement which is to be deleted.

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


DeleteArchive Method

[image]

OfficeClip API Documentation
AnnounceDB..::.DeleteArchive Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a particular archived announcement.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteArchive(
    int announceId
)
Visual Basic (Declaration)
Public Sub DeleteArchive ( _
    announceId As Integer _
)
Visual C++
public:
void DeleteArchive(
    int announceId
)

Parameters

announceId
Type: System..::.Int32
id of the archived announcement which is to be deleted.

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
AnnounceDB..::.ExecuteNonQuery Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

AnnounceDB Class
AnnounceDB Members
OfficeClip.DBLayer.OfficePortal Namespace


GetAnnounce Method

[image]

OfficeClip API Documentation
AnnounceDB..::.GetAnnounce Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the annoucements for the currently logged in user.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAnnounce(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetAnnounce ( _
    userId As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAnnounce(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The unique identifier for the user.
groupId
Type: System..::.Int32
The unique id of the organization

Return Value

DataSet containing a single table with following colums
  • announceId (System.Int32) Id of the announcement.
  • gname (System.String) Name of the group for which the announcement is created.
  • announcet (System.String)title of the annoucement.
  • announced (System.String)Description of the annoucement.
  • closeDate (System.DateTime)Date and Time when this annoucement is closing.
  • createdUserId (System.Int32)Id of the user who created the annoucement.
  • CreatedDate (System.DateTime) Date and Time when this annoucement was created.
  • uName (System.String) The name of the user who for whom this annoucement is created.
  • IsAdmin (System.String) Flag (Y/N) which indicates whether the user is admin that group or not.

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetAnnounceArchive Method

[image]

OfficeClip API Documentation
AnnounceDB..::.GetAnnounceArchive Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the archived announcements for the currently logged in user.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAnnounceArchive(
    int userId
)
Visual Basic (Declaration)
Public Function GetAnnounceArchive ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAnnounceArchive(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique user identifier.

Return Value

DataSet containing a single table with following colums
  • announceId (System.Int32)Id of the announcement.
  • gname (System.String)Name of the group for which the announcement is created.
  • announcet (System.String)title of the annoucement.
  • announced (System.String)Description of the annoucement.
  • closeDate (System.DateTime)Date and Time when this annoucement is closing.
  • uName (System.String) The name of the user who for whom this annoucement is created.

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetDetail Method

[image]

OfficeClip API Documentation
AnnounceDB..::.GetDetail Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the details for a particular annoucement identified by announceId

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetDetail(
    int announceId,
    ref string title,
    ref string desc,
    ref DateTime cdt,
    ref DateTime edt,
    int groupId,
    int userId
)
Visual Basic (Declaration)
Public Sub GetDetail ( _
    announceId As Integer, _
    ByRef title As String, _
    ByRef desc As String, _
    ByRef cdt As DateTime, _
    ByRef edt As DateTime, _
    groupId As Integer, _
    userId As Integer _
)
Visual C++
public:
void GetDetail(
    int announceId,
    String^% title,
    String^% desc,
    DateTime% cdt,
    DateTime% edt,
    int groupId,
    int userId
)

Parameters

announceId
Type: System..::.Int32
The id of the announcement.
title
Type: System..::.String%
title of the announcement.
desc
Type: System..::.String%
Description of the annoucement.
cdt
Type: System..::.DateTime%
Date and Time when this annoucement was created.
edt
Type: System..::.DateTime%
Date and Time when this annoucement expires.
groupId
Type: System..::.Int32
The unique identifier for the group.
userId
Type: System..::.Int32
The unique id for the user.

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
AnnounceDB..::.InitTransaction Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

AnnounceDB Class
AnnounceDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Insert Method

[image]

OfficeClip API Documentation
AnnounceDB..::.Insert Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the announcement into the database

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Insert(
    string message,
    string title,
    DateTime expires,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function Insert ( _
    message As String, _
    title As String, _
    expires As DateTime, _
    userId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int Insert(
    String^ message,
    String^ title,
    DateTime expires,
    int userId,
    int groupId
)

Parameters

message
Type: System..::.String
The announcement Description
title
Type: System..::.String
The announcement title
expires
Type: System..::.DateTime
When the announcement expires, if empty then it is manual expiration and the database value is set to null
userId
Type: System..::.Int32
The unique identifier for the user.
groupId
Type: System..::.Int32
The unique identifier for the group.

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


Open Method

[image]

OfficeClip API Documentation
AnnounceDB..::.Open Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Marks a particular annoucement as open.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Open(
    int announceId
)
Visual Basic (Declaration)
Public Sub Open ( _
    announceId As Integer _
)
Visual C++
public:
void Open(
    int announceId
)

Parameters

announceId
Type: System..::.Int32
id of the announcement which is marked as closed.

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
AnnounceDB..::.SetSPCommand Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

AnnounceDB Class
AnnounceDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Update Method

[image]

OfficeClip API Documentation
AnnounceDB..::.Update Method
AnnounceDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the announcement into the database.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Update(
    int announceId,
    string message,
    string title,
    DateTime expires,
    int userId
)
Visual Basic (Declaration)
Public Sub Update ( _
    announceId As Integer, _
    message As String, _
    title As String, _
    expires As DateTime, _
    userId As Integer _
)
Visual C++
public:
void Update(
    int announceId,
    String^ message,
    String^ title,
    DateTime expires,
    int userId
)

Parameters

announceId
Type: System..::.Int32
Id of the annoucement whose information is to be udpated.
message
Type: System..::.String
The announcement Description.
title
Type: System..::.String
The announcement title.
expires
Type: System..::.DateTime
Date and Time when the annoucement is going to expire.
userId
Type: System..::.Int32
The unique identifier for the user.

See Also

AnnounceDB Class
OfficeClip.DBLayer.OfficePortal Namespace


BbDB Class

[image]

OfficeClip API Documentation
BbDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Allows management of Bulletin Board related functions.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class BbDB : OfficeClipDB
Visual Basic (Declaration)
Public Class BbDB _
    Inherits OfficeClipDB
Visual C++
public ref class BbDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.OfficePortal..::.BbDB

See Also

BbDB Members
OfficeClip.DBLayer.OfficePortal Namespace


BbDB Members

[image] [image]

OfficeClip API Documentation
BbDB Members
BbDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The BbDB type exposes the following members.

Constructors

 | Name | Description
Public method | BbDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | CloseTopic | Closes the Topic and corresponding replies from the Database.
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Delete | Deletes the entire forum along with all the Topics which belong to this particular forum and their corresponding replies
Public method | DeleteReply | Delete Reply message into the Database.
Public method | DeleteTopic | Deletes the Topic and corresponding replies from the Database.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetForumDetail | Get all the details belonging to the Forum
Public method | GetForums | Returns a dataset of all the Forums belonging to the currently selected Group.
Public method | GetForumsList | Returns a dataset of all the Forums belonging to the currentl selected Group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetReplies | Returns a dataset of all the Replies belonging to a Topic.
Public method | GetReplyDetail | Get Reply Detail.
Public method | GetReplyTopicId | Return the Topic Id of a Reply.
Public method | GetSearchResults | Returns a dataset of all the Forums belonging to the currently selected Group.
Public method | GetTopicDetail | Overloaded.
Public method | GetTopicForumId | Return the Forum Id for a Topic
Public method | GetTopics | Overloaded.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | Insert | Inserts a New Forum into the Database
Public method | InsertReply | Inserts a New Reply into the Database.
Public method | InsertTopic | Inserts a New Topic into the Database
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenTopic | Opens the Topic and corresponding replies from the Database.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates a New Forum into the Database
Public method | UpdateReply | Update Reply message into the Database.
Public method | UpdateTopic | Updates the Topic details into the Database.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


BbDB Constructor

[image]

OfficeClip API Documentation
BbDB Constructor
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public BbDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BbDB()

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


BbDB Methods

[image] [image]

OfficeClip API Documentation
BbDB Methods
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

The BbDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | CloseTopic | Closes the Topic and corresponding replies from the Database.
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Delete | Deletes the entire forum along with all the Topics which belong to this particular forum and their corresponding replies
Public method | DeleteReply | Delete Reply message into the Database.
Public method | DeleteTopic | Deletes the Topic and corresponding replies from the Database.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetForumDetail | Get all the details belonging to the Forum
Public method | GetForums | Returns a dataset of all the Forums belonging to the currently selected Group.
Public method | GetForumsList | Returns a dataset of all the Forums belonging to the currentl selected Group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetReplies | Returns a dataset of all the Replies belonging to a Topic.
Public method | GetReplyDetail | Get Reply Detail.
Public method | GetReplyTopicId | Return the Topic Id of a Reply.
Public method | GetSearchResults | Returns a dataset of all the Forums belonging to the currently selected Group.
Public method | GetTopicDetail | Overloaded.
Public method | GetTopicForumId | Return the Forum Id for a Topic
Public method | GetTopics | Overloaded.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | Insert | Inserts a New Forum into the Database
Public method | InsertReply | Inserts a New Reply into the Database.
Public method | InsertTopic | Inserts a New Topic into the Database
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenTopic | Opens the Topic and corresponding replies from the Database.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Updates a New Forum into the Database
Public method | UpdateReply | Update Reply message into the Database.
Public method | UpdateTopic | Updates the Topic details into the Database.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
BbDB..::.AddOutputParameter Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

BbDB Class
BbDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
BbDB..::.AddParameter Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

BbDB Class
BbDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
BbDB..::.AddParameters Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

BbDB Class
BbDB Members
OfficeClip.DBLayer.OfficePortal Namespace


CloseTopic Method

[image]

OfficeClip API Documentation
BbDB..::.CloseTopic Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Closes the Topic and corresponding replies from the Database.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void CloseTopic(
    int topicId
)
Visual Basic (Declaration)
Public Sub CloseTopic ( _
    topicId As Integer _
)
Visual C++
public:
void CloseTopic(
    int topicId
)

Parameters

topicId
Type: System..::.Int32
The Id of the Topic to be closed.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


Delete Method

[image]

OfficeClip API Documentation
BbDB..::.Delete Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the entire forum along with all the Topics which belong to this particular forum and their corresponding replies

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Delete(
    int forumId,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function Delete ( _
    forumId As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
) As Integer
Visual C++
public:
int Delete(
    int forumId,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

forumId
Type: System..::.Int32
The Id of the Forum to be Deleted
currentUserId
Type: System..::.Int32
The unique id of the user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


DeleteReply Method

[image]

OfficeClip API Documentation
BbDB..::.DeleteReply Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Delete Reply message into the Database.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteReply(
    int replyId
)
Visual Basic (Declaration)
Public Sub DeleteReply ( _
    replyId As Integer _
)
Visual C++
public:
void DeleteReply(
    int replyId
)

Parameters

replyId
Type: System..::.Int32
Incoming Id of the reply whose message has to be updated.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


DeleteTopic Method

[image]

OfficeClip API Documentation
BbDB..::.DeleteTopic Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the Topic and corresponding replies from the Database.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteTopic(
    int topicId,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function DeleteTopic ( _
    topicId As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
) As Integer
Visual C++
public:
int DeleteTopic(
    int topicId,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

topicId
Type: System..::.Int32
The Id of the Topic to be deleted.
currentUserId
Type: System..::.Int32
The unique id of the user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
BbDB..::.ExecuteNonQuery Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

BbDB Class
BbDB Members
OfficeClip.DBLayer.OfficePortal Namespace


GetForumDetail Method

[image]

OfficeClip API Documentation
BbDB..::.GetForumDetail Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Get all the details belonging to the Forum

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetForumDetail(
    int forumId,
    ref string name,
    ref string desc,
    ref int cuserid
)
Visual Basic (Declaration)
Public Sub GetForumDetail ( _
    forumId As Integer, _
    ByRef name As String, _
    ByRef desc As String, _
    ByRef cuserid As Integer _
)
Visual C++
public:
void GetForumDetail(
    int forumId,
    String^% name,
    String^% desc,
    int% cuserid
)

Parameters

forumId
Type: System..::.Int32
The incoming Forum Id
name
Type: System..::.String%
Forum Name
desc
Type: System..::.String%
Forum Description
cuserid
Type: System..::.Int32%
The userId, of the user who created the forum

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetForums Method

[image]

OfficeClip API Documentation
BbDB..::.GetForums Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns a dataset of all the Forums belonging to the currently selected Group.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetForums(
    bool allGroups,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetForums ( _
    allGroups As Boolean, _
    userId As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetForums(
    bool allGroups,
    int userId,
    int groupId
)

Parameters

allGroups
Type: System..::.Boolean
Flag indicating whether to get a list of forums belonging to all groups or the currently selected group.
userId
Type: System..::.Int32
The unique identifier for the user.
groupId
Type: System..::.Int32
The unique identifier for the group.

Return Value

The Dataset containg the list of all the Forums belonging to the currently selected Group DataSet consists of a single table with the following columns.
  • ForumId (System.Int32) Id of the forum.
  • ForumName (System.String) Name of the forum.
  • ForumDesc Forum Description.
  • GroupId (System.Int32) Id of the group to which the forum belongs.
  • ForumCount (System.Int32) Number of topics / replies created inside the forum.
  • LastPostedTimestamp (System.DateTime) Date and Time when the last posting was made in this forum.
  • createdByUserId (System.Int32) Id of the user who created the forum.
  • UserName Name of the user who created the forum.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetForumsList Method

[image]

OfficeClip API Documentation
BbDB..::.GetForumsList Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns a dataset of all the Forums belonging to the currentl selected Group.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetForumsList(
    bool allGroups,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetForumsList ( _
    allGroups As Boolean, _
    userId As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetForumsList(
    bool allGroups,
    int userId,
    int groupId
)

Parameters

allGroups
Type: System..::.Boolean
Flag to indicate whether to get Current selected group or all group where this user belongs
userId
Type: System..::.Int32
The unique user id.
groupId
Type: System..::.Int32
The unique group id.

Return Value

The Dataset containg the list of all the Forums belonging to the currently selected Group Dataset consists of single DataTable with the following columns.
  • ForumId (System.Int32) Id of the forum.
  • ForumName Name of the forum.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetReplies Method

[image]

OfficeClip API Documentation
BbDB..::.GetReplies Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns a dataset of all the Replies belonging to a Topic.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetReplies(
    int topicId
)
Visual Basic (Declaration)
Public Function GetReplies ( _
    topicId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetReplies(
    int topicId
)

Parameters

topicId
Type: System..::.Int32
The incoming Topic Id.

Return Value

Returns a dataset containing the list of all the Replies belonging to that particular Topic. DataSet consists of a single DataTable with the following columns.
  • replyAuther (System.String) Name of the user who has posted the reply.
  • replyId (System.Int32) Id of the reply.
  • replyPostedByUserId (System.Int32) Id of the user who posted the reply.
  • topicId (System.Int32) Id of the topic in which the reply is posted.
  • replyDesc (System.String) Description of the reply.
  • replyPostedTimestamp (System.DateTime) Date and time when the Current reply is posted.
  • replyRefPostedTimestamp (System.DateTime) Date and time of the posting in reference to which this Current reply is posted.
  • replyRefAuther (System.String) Name of the user in reference to whose posting this Current reply is posted.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetReplyDetail Method

[image]

OfficeClip API Documentation
BbDB..::.GetReplyDetail Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Get Reply Detail.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetReplyDetail(
    int replyId,
    ref int topicId,
    ref string forumName,
    ref string topicName,
    ref string replyDesc
)
Visual Basic (Declaration)
Public Sub GetReplyDetail ( _
    replyId As Integer, _
    ByRef topicId As Integer, _
    ByRef forumName As String, _
    ByRef topicName As String, _
    ByRef replyDesc As String _
)
Visual C++
public:
void GetReplyDetail(
    int replyId,
    int% topicId,
    String^% forumName,
    String^% topicName,
    String^% replyDesc
)

Parameters

replyId
Type: System..::.Int32
The incoming Reply Id.
topicId
Type: System..::.Int32%
The Topic Id of the topic to which this reply belongs.
forumName
Type: System..::.String%
Forum Name to which topic belongs.
topicName
Type: System..::.String%
Topic Name.
replyDesc
Type: System..::.String%
Reply Message.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetReplyTopicId Method

[image]

OfficeClip API Documentation
BbDB..::.GetReplyTopicId Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Return the Topic Id of a Reply.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetReplyTopicId(
    int replyId
)
Visual Basic (Declaration)
Public Function GetReplyTopicId ( _
    replyId As Integer _
) As Integer
Visual C++
public:
int GetReplyTopicId(
    int replyId
)

Parameters

replyId
Type: System..::.Int32
The incoming Id of the Reply.

Return Value

The Topic Id of the Reply.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetSearchResults Method

[image]

OfficeClip API Documentation
BbDB..::.GetSearchResults Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns a dataset of all the Forums belonging to the currently selected Group.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetSearchResults(
    int forumId,
    int numDays,
    int allGroups,
    string matchAll,
    string searchFor,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetSearchResults ( _
    forumId As Integer, _
    numDays As Integer, _
    allGroups As Integer, _
    matchAll As String, _
    searchFor As String, _
    userId As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetSearchResults(
    int forumId,
    int numDays,
    int allGroups,
    String^ matchAll,
    String^ searchFor,
    int userId,
    int groupId
)

Parameters

forumId
Type: System..::.Int32
The Id of the forum to look for. If 0 then search in all forums
numDays
Type: System..::.Int32
The number of days to look for. If 0 then do not consider date as a criteria
allGroups
Type: System..::.Int32
Flag to indicate whether all groups are selected or not. Contains value 0 or 1
matchAll
Type: System..::.String
Based on how many words are there this paramter tells whether to look for all the matching words or any of the words that is matching.
searchFor
Type: System..::.String
The text pattern to search for. If there are blank spaces in the text pattern, use it as a delimiter to identify words to look for.
userId
Type: System..::.Int32
The unique id for the user.
groupId
Type: System..::.Int32
The unique id for the group.

Return Value

The DataSet containing the list of all the search results. DataSet contains a single table with following columns.
  • forumName (System.String) The name of the forum.
  • forumId (System.Int32) Id of the forum.
  • topicDesc (System.String) Topic Description.
  • topicId (System.Int32) Id of the topic.
  • topicName (System.String) Topic name.
  • topicTimestamp (System.DateTime) Date and time when the topic was posted.
  • groupName (System.String) Name of the group for which the topic is created.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetTopicDetail Method

[image] [image]

OfficeClip API Documentation
BbDB..::.GetTopicDetail Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetTopicDetail(Int32, Int32%, String%, String%, Int32%) | Get all the details belonging to the Topic.
Public method | GetTopicDetail(Int32, Int32%, String%, String%, String%, String%, Int32%, DateTime%, String%) | Get all the details belonging to the Topic

See Also

BbDB Class
BbDB Members
OfficeClip.DBLayer.OfficePortal Namespace


GetTopicDetail Method (Int32, Int32, String, String, Int32)

[image]

OfficeClip API Documentation
BbDB..::.GetTopicDetail Method (Int32, Int32%, String%, String%, Int32%)
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Get all the details belonging to the Topic.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetTopicDetail(
    int topicId,
    ref int forumId,
    ref string name,
    ref string desc,
    ref int cuserid
)
Visual Basic (Declaration)
Public Sub GetTopicDetail ( _
    topicId As Integer, _
    ByRef forumId As Integer, _
    ByRef name As String, _
    ByRef desc As String, _
    ByRef cuserid As Integer _
)
Visual C++
public:
void GetTopicDetail(
    int topicId,
    int% forumId,
    String^% name,
    String^% desc,
    int% cuserid
)

Parameters

topicId
Type: System..::.Int32
The incoming Topic Id.
forumId
Type: System..::.Int32%
The forum Id of the Forum to which this topic belongs.
name
Type: System..::.String%
Topic Name.
desc
Type: System..::.String%
Topic Description.
cuserid
Type: System..::.Int32%
The userId, of the user who created the topic.

See Also

BbDB Class
GetTopicDetail Overload
OfficeClip.DBLayer.OfficePortal Namespace


GetTopicDetail Method (Int32, Int32, String, String, String, String, Int32, DateTime, String)

[image]

OfficeClip API Documentation
BbDB..::.GetTopicDetail Method (Int32, Int32%, String%, String%, String%, String%, Int32%, DateTime%, String%)
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Get all the details belonging to the Topic

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetTopicDetail(
    int topicId,
    ref int fid,
    ref string name,
    ref string desc,
    ref string nrnotify,
    ref string topiccreator,
    ref int tuid,
    ref DateTime tpcdt,
    ref string tpcsts
)
Visual Basic (Declaration)
Public Sub GetTopicDetail ( _
    topicId As Integer, _
    ByRef fid As Integer, _
    ByRef name As String, _
    ByRef desc As String, _
    ByRef nrnotify As String, _
    ByRef topiccreator As String, _
    ByRef tuid As Integer, _
    ByRef tpcdt As DateTime, _
    ByRef tpcsts As String _
)
Visual C++
public:
void GetTopicDetail(
    int topicId,
    int% fid,
    String^% name,
    String^% desc,
    String^% nrnotify,
    String^% topiccreator,
    int% tuid,
    DateTime% tpcdt,
    String^% tpcsts
)

Parameters

topicId
Type: System..::.Int32
The incoming Topic Id
fid
Type: System..::.Int32%
Forum Id being returned as reference
name
Type: System..::.String%
Topic Name
desc
Type: System..::.String%
Topic Message
nrnotify
Type: System..::.String%
The flag to tell users whether to notify members on new posting
topiccreator
Type: System..::.String%
The name of the person who created the topic
tuid
Type: System..::.Int32%
User Id of the User who created the topic
tpcdt
Type: System..::.DateTime%
Topic Creation date
tpcsts
Type: System..::.String%
Topic status whether currently closed or open

See Also

BbDB Class
GetTopicDetail Overload
OfficeClip.DBLayer.OfficePortal Namespace


GetTopicForumId Method

[image]

OfficeClip API Documentation
BbDB..::.GetTopicForumId Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Return the Forum Id for a Topic

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetTopicForumId(
    int topicId
)
Visual Basic (Declaration)
Public Function GetTopicForumId ( _
    topicId As Integer _
) As Integer
Visual C++
public:
int GetTopicForumId(
    int topicId
)

Parameters

topicId
Type: System..::.Int32
The Id of the Topic

Return Value

Forum Id of the Topic

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetTopics Method

[image] [image]

OfficeClip API Documentation
BbDB..::.GetTopics Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetTopics(Int32) | Gets a list of topics corresponding to a particular Forum identified by forumId.
Public method | GetTopics(Int32, Int32) | Returns a dataset of all the topics belonging to a Forum

See Also

BbDB Class
BbDB Members
OfficeClip.DBLayer.OfficePortal Namespace


GetTopics Method (Int32)

[image]

OfficeClip API Documentation
BbDB..::.GetTopics Method (Int32)
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of topics corresponding to a particular Forum identified by forumId.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTopics(
    int forumId
)
Visual Basic (Declaration)
Public Function GetTopics ( _
    forumId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetTopics(
    int forumId
)

Parameters

forumId
Type: System..::.Int32
Id of a particular forum.

Return Value

DataSet containing all the information related to the topics belonging to a forum. The DataSet contains a single table with following columns.
  • status (System.String) status of a topic whether it is closed or not.
  • forumId (System.Int32) Id of the forum to which this topic belongs.
  • topicId (System.Int32) Id of the topic.
  • topicName (System.String) Name of the topic.
  • informMembers (System.String) Flag (Y/N) indicating whether to inform members when new posts are created in this topic.
  • createdByUserId (System.Int32) Id of the user who created the topic.
  • numberOfReplies (System.Int32) The number of replies created in the topic.
  • lastPostedTimestamp (System.DateTime) Date and Time when the last post was created in this topic.
  • createdByUser (System.String) Name of the user who created this topic.

See Also

BbDB Class
GetTopics Overload
OfficeClip.DBLayer.OfficePortal Namespace


GetTopics Method (Int32, Int32)

[image]

OfficeClip API Documentation
BbDB..::.GetTopics Method (Int32, Int32)
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns a dataset of all the topics belonging to a Forum

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTopics(
    int forumId,
    int numDays
)
Visual Basic (Declaration)
Public Function GetTopics ( _
    forumId As Integer, _
    numDays As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetTopics(
    int forumId,
    int numDays
)

Parameters

forumId
Type: System..::.Int32
The incoming Forum Id
numDays
Type: System..::.Int32
The number of days from which to list all the topics.

Return Value

Returns a dataset containing the list of all the topics belonging to that particular forum The DataSet contains a single table with following columns.
  • status (System.String) status of a topic whether it is closed or not.
  • forumId (System.Int32) Id of the forum to which this topic belongs.
  • topicId (System.Int32) Id of the topic.
  • topicName (System.String) Name of the topic.
  • informMembers (System.String) Flag (Y/N) indicating whether to inform members when new posts are created in this topic.
  • createdByUserId (System.Int32) Id of the user who created the topic.
  • numberOfReplies (System.Int32) The number of replies created in the topic.
  • lastPostedTimestamp (System.DateTime) Date and Time when the last post was created in this topic.
  • createdByUser (System.String) Name of the user who created this topic.

See Also

BbDB Class
GetTopics Overload
OfficeClip.DBLayer.OfficePortal Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
BbDB..::.InitTransaction Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

BbDB Class
BbDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Insert Method

[image]

OfficeClip API Documentation
BbDB..::.Insert Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a New Forum into the Database

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Insert(
    string forumName,
    string forumDesc,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function Insert ( _
    forumName As String, _
    forumDesc As String, _
    userId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int Insert(
    String^ forumName,
    String^ forumDesc,
    int userId,
    int groupId
)

Parameters

forumName
Type: System..::.String
The Name of the Forum
forumDesc
Type: System..::.String
Forum Description
userId
Type: System..::.Int32
The unique user id.
groupId
Type: System..::.Int32
The unique group id.

Return Value

Forum Id

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


InsertReply Method

[image]

OfficeClip API Documentation
BbDB..::.InsertReply Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a New Reply into the Database.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertReply(
    int topicId,
    int forumId,
    string topicDesc,
    int parentReplyId,
    int userId
)
Visual Basic (Declaration)
Public Function InsertReply ( _
    topicId As Integer, _
    forumId As Integer, _
    topicDesc As String, _
    parentReplyId As Integer, _
    userId As Integer _
) As Integer
Visual C++
public:
int InsertReply(
    int topicId,
    int forumId,
    String^ topicDesc,
    int parentReplyId,
    int userId
)

Parameters

topicId
Type: System..::.Int32
The Name of the Topic.
forumId
Type: System..::.Int32
The Name of the Topic.
topicDesc
Type: System..::.String
Reply Message.
parentReplyId
Type: System..::.Int32
Reply ID if this post is in reply to a reply otherwise null if it is in reply to the topic itself.
userId
Type: System..::.Int32
The unique id for the user.

Return Value

Reply Id.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


InsertTopic Method

[image]

OfficeClip API Documentation
BbDB..::.InsertTopic Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a New Topic into the Database

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertTopic(
    int forumId,
    string topicName,
    string topicDesc,
    string notifyOnReply,
    string docIdList,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function InsertTopic ( _
    forumId As Integer, _
    topicName As String, _
    topicDesc As String, _
    notifyOnReply As String, _
    docIdList As String, _
    userId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int InsertTopic(
    int forumId,
    String^ topicName,
    String^ topicDesc,
    String^ notifyOnReply,
    String^ docIdList,
    int userId,
    int groupId
)

Parameters

forumId
Type: System..::.Int32
The forum id.
topicName
Type: System..::.String
The Name of the Topic
topicDesc
Type: System..::.String
Topic Message
notifyOnReply
Type: System..::.String
Flag to indicate that whether to notify the creator of the topic when threre is a new reply posted to this topic
docIdList
Type: System..::.String
The list of document ids of the attachments put with this new topic.
userId
Type: System..::.Int32
The unique id for the user.
groupId
Type: System..::.Int32
The unique id of the group

Return Value

Topic Id

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


OpenTopic Method

[image]

OfficeClip API Documentation
BbDB..::.OpenTopic Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Opens the Topic and corresponding replies from the Database.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void OpenTopic(
    int topicId
)
Visual Basic (Declaration)
Public Sub OpenTopic ( _
    topicId As Integer _
)
Visual C++
public:
void OpenTopic(
    int topicId
)

Parameters

topicId
Type: System..::.Int32
The Id of the Topic to be opened.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
BbDB..::.SetSPCommand Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

BbDB Class
BbDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Update Method

[image]

OfficeClip API Documentation
BbDB..::.Update Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates a New Forum into the Database

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Update(
    int forumId,
    string forumName,
    string forumDesc,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Sub Update ( _
    forumId As Integer, _
    forumName As String, _
    forumDesc As String, _
    userId As Integer, _
    groupId As Integer _
)
Visual C++
public:
void Update(
    int forumId,
    String^ forumName,
    String^ forumDesc,
    int userId,
    int groupId
)

Parameters

forumId
Type: System..::.Int32
The Id of the forum being updated
forumName
Type: System..::.String
The Name of the Forum
forumDesc
Type: System..::.String
Forum Description
userId
Type: System..::.Int32
The unique id for the user.
groupId
Type: System..::.Int32
The unique id for the group.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


UpdateReply Method

[image]

OfficeClip API Documentation
BbDB..::.UpdateReply Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Update Reply message into the Database.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateReply(
    int replyId,
    string replyDesc
)
Visual Basic (Declaration)
Public Sub UpdateReply ( _
    replyId As Integer, _
    replyDesc As String _
)
Visual C++
public:
void UpdateReply(
    int replyId,
    String^ replyDesc
)

Parameters

replyId
Type: System..::.Int32
Incoming Id of the reply whose message has to be updated.
replyDesc
Type: System..::.String
Reply Message.

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


UpdateTopic Method

[image]

OfficeClip API Documentation
BbDB..::.UpdateTopic Method
BbDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the Topic details into the Database.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReturnStatus UpdateTopic(
    int topicId,
    string topicName,
    string topicDesc,
    string notifyOnReply,
    string docIdList,
    string remDocIdList,
    int groupId,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function UpdateTopic ( _
    topicId As Integer, _
    topicName As String, _
    topicDesc As String, _
    notifyOnReply As String, _
    docIdList As String, _
    remDocIdList As String, _
    groupId As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
) As ReturnStatus
Visual C++
public:
ReturnStatus UpdateTopic(
    int topicId,
    String^ topicName,
    String^ topicDesc,
    String^ notifyOnReply,
    String^ docIdList,
    String^ remDocIdList,
    int groupId,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

topicId
Type: System..::.Int32
The Id of the Topic to be deleted.
topicName
Type: System..::.String
The Name of the Topic.
topicDesc
Type: System..::.String
Topic Message.
notifyOnReply
Type: System..::.String
Flag to indicate that whether to notify the creator of the topic when threre is a new reply posted to this topic.
docIdList
Type: System..::.String
Comma delimited doument ids of the documents attached with this particular topic.
remDocIdList
Type: System..::.String
Comma delimited document ids of the documents to be removed from this particular topic.
groupId
Type: System..::.Int32
The unique id of the organization
currentUserId
Type: System..::.Int32
The unique id of the user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Enumerated value Utils.ReturnStatus indicating if the operation succeeded or failed. OfficeClip.Utils..::.ReturnStatus

See Also

BbDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GroupbookmarkDB Class

[image]

OfficeClip API Documentation
GroupbookmarkDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Bookmark application related functions.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class GroupbookmarkDB : OfficeClipDB
Visual Basic (Declaration)
Public Class GroupbookmarkDB _
    Inherits OfficeClipDB
Visual C++
public ref class GroupbookmarkDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.OfficePortal..::.GroupbookmarkDB

See Also

GroupbookmarkDB Members
OfficeClip.DBLayer.OfficePortal Namespace


GroupbookmarkDB Members

[image] [image]

OfficeClip API Documentation
GroupbookmarkDB Members
GroupbookmarkDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The GroupbookmarkDB type exposes the following members.

Constructors

 | Name | Description
Public method | GroupbookmarkDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Delete | Removes a particular group's bookmark indentified by htmlId.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBookmarksByCategory | Get all the Active bookmarks for a Category identified by a Category id for a particular group.
Public method | GetBookmarksByRank | Returns the bookmarks for a particular group sorted by the reverse order of the rank. The rank is determined as, number of impression + number of clicks + (weight*2)+ (Date since last clicked)*2
Public method | GetCategories | Get a list of bookmark categories created for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | Insert | Inserts a new group bookmark in the database for a particular group.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRank | Updates the rating when a user clicks on a bookmark and visits the site. Each click increases the the rank of a bookmark by a single point.
Public method | UpdateWeight | Updates the weight of a particular a bookmark in the database when the user clicked on it.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

GroupbookmarkDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GroupbookmarkDB Constructor

[image]

OfficeClip API Documentation
GroupbookmarkDB Constructor
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GroupbookmarkDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupbookmarkDB()

See Also

GroupbookmarkDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GroupbookmarkDB Methods

[image] [image]

OfficeClip API Documentation
GroupbookmarkDB Methods
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

The GroupbookmarkDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Delete | Removes a particular group's bookmark indentified by htmlId.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBookmarksByCategory | Get all the Active bookmarks for a Category identified by a Category id for a particular group.
Public method | GetBookmarksByRank | Returns the bookmarks for a particular group sorted by the reverse order of the rank. The rank is determined as, number of impression + number of clicks + (weight*2)+ (Date since last clicked)*2
Public method | GetCategories | Get a list of bookmark categories created for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | Insert | Inserts a new group bookmark in the database for a particular group.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRank | Updates the rating when a user clicks on a bookmark and visits the site. Each click increases the the rank of a bookmark by a single point.
Public method | UpdateWeight | Updates the weight of a particular a bookmark in the database when the user clicked on it.

See Also

GroupbookmarkDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
GroupbookmarkDB..::.AddOutputParameter Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

GroupbookmarkDB Class
GroupbookmarkDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
GroupbookmarkDB..::.AddParameter Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

GroupbookmarkDB Class
GroupbookmarkDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
GroupbookmarkDB..::.AddParameters Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

GroupbookmarkDB Class
GroupbookmarkDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Delete Method

[image]

OfficeClip API Documentation
GroupbookmarkDB..::.Delete Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes a particular group's bookmark indentified by htmlId.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Delete(
    int userId,
    int groupId,
    int htmlId
)
Visual Basic (Declaration)
Public Sub Delete ( _
    userId As Integer, _
    groupId As Integer, _
    htmlId As Integer _
)
Visual C++
public:
void Delete(
    int userId,
    int groupId,
    int htmlId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the group.
htmlId
Type: System..::.Int32
Id of the bookmark which needs to be deleted from the database. Please note that this bookmark should belong the group whose GroupId is passed as argument.

See Also

GroupbookmarkDB Class
OfficeClip.DBLayer.OfficePortal Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
GroupbookmarkDB..::.ExecuteNonQuery Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

GroupbookmarkDB Class
GroupbookmarkDB Members
OfficeClip.DBLayer.OfficePortal Namespace


GetBookmarksByCategory Method

[image]

OfficeClip API Documentation
GroupbookmarkDB..::.GetBookmarksByCategory Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Get all the Active bookmarks for a Category identified by a Category id for a particular group.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetBookmarksByCategory(
    int groupId,
    int categoryId
)
Visual Basic (Declaration)
Public Function GetBookmarksByCategory ( _
    groupId As Integer, _
    categoryId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetBookmarksByCategory(
    int groupId,
    int categoryId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group.
categoryId
Type: System..::.Int32
Id of the Category for which the bookmarks have to be retrieved.

Return Value

DataSet containing all information related to the bookmarks of a particular Category for the currently selected group. This DataSet consists of a single DataTable with the following columns.
  • isGroup (System.String)Flag (Y/N) indicating whether a bookmark is a group bookmark or a private bookmark. Note that since this DataSet is returning only the bookmarks belonging to the currently selected group, the value of this flag will always be 'Y'.
  • htmlId (System.Int32)Id of the bookmark.
  • title (System.String)title of the bookmark.
  • url (System.String)Url of the web page which has been bookmarked.
  • descr (System.String)Description of the url giving information about the web page which has been bookmarked.
  • cdt (System.DateTime)Date and time when the bookmark has been created.
  • CreatedBy (System.Int32)Id of the user who has created the bookmark.
  • uname (System.String)Name of the user who has created the bookmark.

See Also

GroupbookmarkDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetBookmarksByRank Method

[image]

OfficeClip API Documentation
GroupbookmarkDB..::.GetBookmarksByRank Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the bookmarks for a particular group sorted by the reverse order of the rank. The rank is determined as, number of impression + number of clicks + (weight*2)+ (Date since last clicked)*2

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetBookmarksByRank(
    int groupId
)
Visual Basic (Declaration)
Public Function GetBookmarksByRank ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetBookmarksByRank(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.

Return Value

DataSet containing all information related to the bookmarks of a particular Category for the currently selected group in order described above. This DataSet consists of a single DataTable with the following columns.
  • isGroup (System.String)Flag (Y/N) indicating whether a bookmark is a group bookmark or a private bookmark. Note that since this DataSet is returning only the bookmarks belonging to the currently selected group, the value of this flag will always be 'Y'.
  • htmlId (System.Int32)Id of the bookmark.
  • title (System.String)title of the bookmark.
  • url (System.String)Url of the web page which has been bookmarked.
  • descr (System.String)Description of the url giving information about the web page which has been bookmarked.
  • cdt (System.DateTime)Date and time when the bookmark has been created.
  • CreatedBy (System.Int32)Id of the user who has created the bookmark.
  • uname (System.String)Name of the user who has created the bookmark.
  • urlWeight (System.Double)The weight of the url depending on how long it is in there, how many times it has been viewed and the rating that user has given to it.

See Also

GroupbookmarkDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetCategories Method

[image]

OfficeClip API Documentation
GroupbookmarkDB..::.GetCategories Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Get a list of bookmark categories created for a particular group.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SqlDataReader GetCategories(
    int groupId
)
Visual Basic (Declaration)
Public Function GetCategories ( _
    groupId As Integer _
) As SqlDataReader
Visual C++
public:
SqlDataReader^ GetCategories(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.

Return Value

DataSet containing the bookmark Category related information. This DataSet consists of a single DataTable with the following columns.
  • id (System.Int32)Id of a particular bookmark Category.
  • name (System.String)Name of the bookmark Category.

Remarks

Make sure to Close the SqlDataReader after the use otherwise it will leave and connection open (till garbage collector releases the Data Reader). If not closed explicitly, the .Net framework might hang and slow down because of the number of open connections Limit might be reached.

See Also

GroupbookmarkDB Class
OfficeClip.DBLayer.OfficePortal Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
GroupbookmarkDB..::.InitTransaction Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

GroupbookmarkDB Class
GroupbookmarkDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Insert Method

[image]

OfficeClip API Documentation
GroupbookmarkDB..::.Insert Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new group bookmark in the database for a particular group.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Insert(
    int userId,
    int groupId,
    string categoryName,
    string url,
    string descr,
    string title
)
Visual Basic (Declaration)
Public Sub Insert ( _
    userId As Integer, _
    groupId As Integer, _
    categoryName As String, _
    url As String, _
    descr As String, _
    title As String _
)
Visual C++
public:
void Insert(
    int userId,
    int groupId,
    String^ categoryName,
    String^ url,
    String^ descr,
    String^ title
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the group.
categoryName
Type: System..::.String
The name of the Category. If the Category is not present in the database, it will be inserted automatically
url
Type: System..::.String
The url of the web page being bookmarked.
descr
Type: System..::.String
The Description of the web page being bookmarked.
title
Type: System..::.String
The title corresponding to the url which shows up on the OfficeClip screen displaying the bookmark.

See Also

GroupbookmarkDB Class
OfficeClip.DBLayer.OfficePortal Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
GroupbookmarkDB..::.SetSPCommand Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

GroupbookmarkDB Class
GroupbookmarkDB Members
OfficeClip.DBLayer.OfficePortal Namespace


UpdateRank Method

[image]

OfficeClip API Documentation
GroupbookmarkDB..::.UpdateRank Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the rating when a user clicks on a bookmark and visits the site. Each click increases the the rank of a bookmark by a single point.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateRank(
    int htmlId
)
Visual Basic (Declaration)
Public Sub UpdateRank ( _
    htmlId As Integer _
)
Visual C++
public:
void UpdateRank(
    int htmlId
)

Parameters

htmlId
Type: System..::.Int32
The id of the groupbookmark which the user clicked on.

See Also

GroupbookmarkDB Class
OfficeClip.DBLayer.OfficePortal Namespace


UpdateWeight Method

[image]

OfficeClip API Documentation
GroupbookmarkDB..::.UpdateWeight Method
GroupbookmarkDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the weight of a particular a bookmark in the database when the user clicked on it.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateWeight(
    int userId,
    int htmlId,
    int urlWeight
)
Visual Basic (Declaration)
Public Sub UpdateWeight ( _
    userId As Integer, _
    htmlId As Integer, _
    urlWeight As Integer _
)
Visual C++
public:
void UpdateWeight(
    int userId,
    int htmlId,
    int urlWeight
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
htmlId
Type: System..::.Int32
The id of the groupbookmark on which the user clicked.
urlWeight
Type: System..::.Int32
The url weight decides how the user ranked the url, typical value varies from 0 to 10

See Also

GroupbookmarkDB Class
OfficeClip.DBLayer.OfficePortal Namespace


NotesDB Class

[image]

OfficeClip API Documentation
NotesDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

This is the database layer to handle Notes database queries.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class NotesDB : OfficeClipDB
Visual Basic (Declaration)
Public Class NotesDB _
    Inherits OfficeClipDB
Visual C++
public ref class NotesDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.OfficePortal..::.NotesDB

See Also

NotesDB Members
OfficeClip.DBLayer.OfficePortal Namespace


NotesDB Members

[image] [image]

OfficeClip API Documentation
NotesDB Members
NotesDB Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The NotesDB type exposes the following members.

Constructors

 | Name | Description
Public method | NotesDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteNote | Delete a note by passing the noteId
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllNotes | Gets all notes
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNote | Returns a single note and related info in a DataTable
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertNote | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateNote | Updates an existing note

Fields

 | Name | Description
Public field | OCDB | The officeclip DB object

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

NotesDB Class
OfficeClip.DBLayer.OfficePortal Namespace


NotesDB Constructor

[image]

OfficeClip API Documentation
NotesDB Constructor
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public NotesDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NotesDB()

See Also

NotesDB Class
OfficeClip.DBLayer.OfficePortal Namespace


NotesDB Fields

[image] [image]

OfficeClip API Documentation
NotesDB Fields
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

The NotesDB type exposes the following fields.

Fields

 | Name | Description
Public field | OCDB | The officeclip DB object

See Also

NotesDB Class
OfficeClip.DBLayer.OfficePortal Namespace


OCDB Field

[image]

OfficeClip API Documentation
NotesDB..::.OCDB Field
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

The officeclip DB object

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OfficeClipDB OCDB
Visual Basic (Declaration)
Public OCDB As OfficeClipDB
Visual C++
public:
OfficeClipDB^ OCDB

See Also

NotesDB Class
OfficeClip.DBLayer.OfficePortal Namespace


NotesDB Methods

[image] [image]

OfficeClip API Documentation
NotesDB Methods
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

The NotesDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteNote | Delete a note by passing the noteId
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllNotes | Gets all notes
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetNote | Returns a single note and related info in a DataTable
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertNote | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateNote | Updates an existing note

See Also

NotesDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
NotesDB..::.AddOutputParameter Method
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

NotesDB Class
NotesDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
NotesDB..::.AddParameter Method
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

NotesDB Class
NotesDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
NotesDB..::.AddParameters Method
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

NotesDB Class
NotesDB Members
OfficeClip.DBLayer.OfficePortal Namespace


DeleteNote Method

[image]

OfficeClip API Documentation
NotesDB..::.DeleteNote Method
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Delete a note by passing the noteId

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteNote(
    int noteId,
    int userId
)
Visual Basic (Declaration)
Public Sub DeleteNote ( _
    noteId As Integer, _
    userId As Integer _
)
Visual C++
public:
void DeleteNote(
    int noteId,
    int userId
)

Parameters

noteId
Type: System..::.Int32
The unique id of the note
userId
Type: System..::.Int32
The unique id of the user

See Also

NotesDB Class
OfficeClip.DBLayer.OfficePortal Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
NotesDB..::.ExecuteNonQuery Method
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

NotesDB Class
NotesDB Members
OfficeClip.DBLayer.OfficePortal Namespace


GetAllNotes Method

[image]

OfficeClip API Documentation
NotesDB..::.GetAllNotes Method
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all notes

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAllNotes(
    int userId,
    int groupId,
    int objectType,
    int objectId,
    bool isAllNotes,
    bool isSession
)
Visual Basic (Declaration)
Public Function GetAllNotes ( _
    userId As Integer, _
    groupId As Integer, _
    objectType As Integer, _
    objectId As Integer, _
    isAllNotes As Boolean, _
    isSession As Boolean _
) As DataSet
Visual C++
public:
DataSet^ GetAllNotes(
    int userId,
    int groupId,
    int objectType,
    int objectId,
    bool isAllNotes,
    bool isSession
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
objectType
Type: System..::.Int32
objectId
Type: System..::.Int32
isAllNotes
Type: System..::.Boolean
Returns all notes regardless of their parents
isSession
Type: System..::.Boolean

Return Value

See Also

NotesDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetNote Method

[image]

OfficeClip API Documentation
NotesDB..::.GetNote Method
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns a single note and related info in a DataTable

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetNote(
    int noteId
)
Visual Basic (Declaration)
Public Function GetNote ( _
    noteId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetNote(
    int noteId
)

Parameters

noteId
Type: System..::.Int32
The unique id for the note

Return Value

The dataset for a single note

See Also

NotesDB Class
OfficeClip.DBLayer.OfficePortal Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
NotesDB..::.InitTransaction Method
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

NotesDB Class
NotesDB Members
OfficeClip.DBLayer.OfficePortal Namespace


InsertNote Method

[image] [image]

OfficeClip API Documentation
NotesDB..::.InsertNote Method
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InsertNote(Int32, Int32, Int32, Int32, String) | Inserts a note in the note table. This function is only used where there is no session present
Public method | InsertNote(Int32, Int32, Int32, Int32, String, DateTime) | Inserts a note in the note table

See Also

NotesDB Class
NotesDB Members
OfficeClip.DBLayer.OfficePortal Namespace


InsertNote Method (Int32, Int32, Int32, Int32, String)

[image]

OfficeClip API Documentation
NotesDB..::.InsertNote Method (Int32, Int32, Int32, Int32, String)
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a note in the note table. This function is only used where there is no session present

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertNote(
    int userId,
    int groupId,
    int objectTypeId,
    int objectId,
    string note
)
Visual Basic (Declaration)
Public Function InsertNote ( _
    userId As Integer, _
    groupId As Integer, _
    objectTypeId As Integer, _
    objectId As Integer, _
    note As String _
) As Integer
Visual C++
public:
int InsertNote(
    int userId,
    int groupId,
    int objectTypeId,
    int objectId,
    String^ note
)

Parameters

userId
Type: System..::.Int32
The unique id of the user for which the note is created
groupId
Type: System..::.Int32
The unique id of the group
objectTypeId
Type: System..::.Int32
The object type id
objectId
Type: System..::.Int32
The object id
note
Type: System..::.String
The actual note

Return Value

The unique id of the note if successful, -1 otherwise

See Also

NotesDB Class
InsertNote Overload
OfficeClip.DBLayer.OfficePortal Namespace


InsertNote Method (Int32, Int32, Int32, Int32, String, DateTime)

[image]

OfficeClip API Documentation
NotesDB..::.InsertNote Method (Int32, Int32, Int32, Int32, String, DateTime)
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a note in the note table

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertNote(
    int userId,
    int groupId,
    int objectTypeId,
    int objectId,
    string note,
    DateTime dt
)
Visual Basic (Declaration)
Public Function InsertNote ( _
    userId As Integer, _
    groupId As Integer, _
    objectTypeId As Integer, _
    objectId As Integer, _
    note As String, _
    dt As DateTime _
) As Integer
Visual C++
public:
int InsertNote(
    int userId,
    int groupId,
    int objectTypeId,
    int objectId,
    String^ note,
    DateTime dt
)

Parameters

userId
Type: System..::.Int32
The unique id of the user for which the note is created
groupId
Type: System..::.Int32
The unique id of the group
objectTypeId
Type: System..::.Int32
The object type id
objectId
Type: System..::.Int32
The object id
note
Type: System..::.String
The actual note
dt
Type: System..::.DateTime
The datetime when this note needs to be created

Return Value

The unique id of the note if successful, -1 otherwise

See Also

NotesDB Class
InsertNote Overload
OfficeClip.DBLayer.OfficePortal Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
NotesDB..::.SetSPCommand Method
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

NotesDB Class
NotesDB Members
OfficeClip.DBLayer.OfficePortal Namespace


UpdateNote Method

[image]

OfficeClip API Documentation
NotesDB..::.UpdateNote Method
NotesDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates an existing note

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateNote(
    int noteId,
    string note,
    int userId,
    ref DateTime lastModifiedTime
)
Visual Basic (Declaration)
Public Sub UpdateNote ( _
    noteId As Integer, _
    note As String, _
    userId As Integer, _
    ByRef lastModifiedTime As DateTime _
)
Visual C++
public:
void UpdateNote(
    int noteId,
    String^ note,
    int userId,
    DateTime% lastModifiedTime
)

Parameters

noteId
Type: System..::.Int32
The unique id of the note
note
Type: System..::.String
The actual note
userId
Type: System..::.Int32
The unique id of the user
lastModifiedTime
Type: System..::.DateTime%
The last modified time

See Also

NotesDB Class
OfficeClip.DBLayer.OfficePortal Namespace


PhotoDB Class

[image]

OfficeClip API Documentation
PhotoDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Photo application related functions.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class PhotoDB : OfficeClipDB
Visual Basic (Declaration)
Public Class PhotoDB _
    Inherits OfficeClipDB
Visual C++
public ref class PhotoDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.OfficePortal..::.PhotoDB

See Also

PhotoDB Members
OfficeClip.DBLayer.OfficePortal Namespace


PhotoDB Members

[image] [image]

OfficeClip API Documentation
PhotoDB Members
PhotoDB Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The PhotoDB type exposes the following members.

Constructors

 | Name | Description
Public method | PhotoDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteAlbum | Removes the folder from the album.
Public method | DeletePhoto | Removes the photo from the album.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | EditPhotoDetail | Updates the photo details corresponding to a particular photo document identified by photoId.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlbumList | Gets the album list of all the albums which a particular user has access to.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPhotoDetail | Gets all the details of a photo identified by photoId.
Public method | GetPhotoList | Gets the list of photos for a particular album id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertAlbum | Inserts the Album corresponding to the currently selected group in the database and the file system for the currently logged in user.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SavePostedFile | Stores the posted (uploaded) file in the file system and Store the link in the database.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | ocr | Variable to hold the reference to Utils.OCResources to be used in any of the methods internally.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


PhotoDB Constructor

[image] [image]

OfficeClip API Documentation
PhotoDB Constructor
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PhotoDB()()() | The default constructor.
Public method | PhotoDB(OCResources) | Constructor which intializes the instance of PhotoDB class.

See Also

PhotoDB Class
PhotoDB Members
OfficeClip.DBLayer.OfficePortal Namespace


PhotoDB Constructor

[image]

OfficeClip API Documentation
PhotoDB Constructor
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PhotoDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PhotoDB()

See Also

PhotoDB Class
PhotoDB Overload
OfficeClip.DBLayer.OfficePortal Namespace


PhotoDB Constructor (OCResources)

[image]

OfficeClip API Documentation
PhotoDB Constructor (OCResources)
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor which intializes the instance of PhotoDB class.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PhotoDB(
    OCResources theOcr
)
Visual Basic (Declaration)
Public Sub New ( _
    theOcr As OCResources _
)
Visual C++
public:
PhotoDB(
    OCResources^ theOcr
)

Parameters

theOcr
Type: OfficeClip.Utils..::.OCResources
The OfficeClip resources.

See Also

PhotoDB Class
PhotoDB Overload
OfficeClip.DBLayer.OfficePortal Namespace


PhotoDB Fields

[image] [image]

OfficeClip API Documentation
PhotoDB Fields
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

The PhotoDB type exposes the following fields.

Fields

 | Name | Description
Protected field | ocr | Variable to hold the reference to Utils.OCResources to be used in any of the methods internally.

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


ocr Field

[image]

OfficeClip API Documentation
PhotoDB..::.ocr Field
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Variable to hold the reference to Utils.OCResources to be used in any of the methods internally.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected OCResources ocr
Visual Basic (Declaration)
Protected ocr As OCResources
Visual C++
protected:
OCResources^ ocr

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


PhotoDB Methods

[image] [image]

OfficeClip API Documentation
PhotoDB Methods
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

The PhotoDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteAlbum | Removes the folder from the album.
Public method | DeletePhoto | Removes the photo from the album.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | EditPhotoDetail | Updates the photo details corresponding to a particular photo document identified by photoId.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAlbumList | Gets the album list of all the albums which a particular user has access to.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPhotoDetail | Gets all the details of a photo identified by photoId.
Public method | GetPhotoList | Gets the list of photos for a particular album id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertAlbum | Inserts the Album corresponding to the currently selected group in the database and the file system for the currently logged in user.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SavePostedFile | Stores the posted (uploaded) file in the file system and Store the link in the database.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
PhotoDB..::.AddOutputParameter Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

PhotoDB Class
PhotoDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
PhotoDB..::.AddParameter Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

PhotoDB Class
PhotoDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
PhotoDB..::.AddParameters Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

PhotoDB Class
PhotoDB Members
OfficeClip.DBLayer.OfficePortal Namespace


DeleteAlbum Method

[image]

OfficeClip API Documentation
PhotoDB..::.DeleteAlbum Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the folder from the album.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DocumentStatus..::.DeleteFolderStatus DeleteAlbum(
    int albumId,
    int groupId,
    int userId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function DeleteAlbum ( _
    albumId As Integer, _
    groupId As Integer, _
    userId As Integer, _
    isAdmin As Boolean _
) As DocumentStatus..::.DeleteFolderStatus
Visual C++
public:
DocumentStatus..::.DeleteFolderStatus DeleteAlbum(
    int albumId,
    int groupId,
    int userId,
    bool isAdmin
)

Parameters

albumId
Type: System..::.Int32
Id of the album folder.
groupId
Type: System..::.Int32
Id of the group where is the user an administratorThe unique id of the user this album belongs.
userId
Type: System..::.Int32
isAdmin
Type: System..::.Boolean

Return Value

True if the folder is deleted, else False

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


DeletePhoto Method

[image]

OfficeClip API Documentation
PhotoDB..::.DeletePhoto Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the photo from the album.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool DeletePhoto(
    int photoId,
    int albumId,
    string fileName,
    int groupId,
    int userId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function DeletePhoto ( _
    photoId As Integer, _
    albumId As Integer, _
    fileName As String, _
    groupId As Integer, _
    userId As Integer, _
    isAdmin As Boolean _
) As Boolean
Visual C++
public:
bool DeletePhoto(
    int photoId,
    int albumId,
    String^ fileName,
    int groupId,
    int userId,
    bool isAdmin
)

Parameters

photoId
Type: System..::.Int32
Id of the photo document to be removed.
albumId
Type: System..::.Int32
Id of the album folder.
fileName
Type: System..::.String
The name of the photo document.
groupId
Type: System..::.Int32
Id of the group where this album belongs.
userId
Type: System..::.Int32
The unique id of the user
isAdmin
Type: System..::.Boolean
is the user an administrator

Return Value

True if the photo is deleted, else False.

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


EditPhotoDetail Method

[image]

OfficeClip API Documentation
PhotoDB..::.EditPhotoDetail Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the photo details corresponding to a particular photo document identified by photoId.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int EditPhotoDetail(
    int photoId,
    string photoName,
    string photoDesc
)
Visual Basic (Declaration)
Public Function EditPhotoDetail ( _
    photoId As Integer, _
    photoName As String, _
    photoDesc As String _
) As Integer
Visual C++
public:
int EditPhotoDetail(
    int photoId,
    String^ photoName,
    String^ photoDesc
)

Parameters

photoId
Type: System..::.Int32
Id of the photo document.
photoName
Type: System..::.String
Name of the photo document.
photoDesc
Type: System..::.String
Descripiton of the photo document.

Return Value

0 if successful, -1 in case of an error.

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
PhotoDB..::.ExecuteNonQuery Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

PhotoDB Class
PhotoDB Members
OfficeClip.DBLayer.OfficePortal Namespace


GetAlbumList Method

[image]

OfficeClip API Documentation
PhotoDB..::.GetAlbumList Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the album list of all the albums which a particular user has access to.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAlbumList(
    int userId
)
Visual Basic (Declaration)
Public Function GetAlbumList ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetAlbumList(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique Id of the user.

Return Value

The DataSet consisting of a single DataTable with the following columns.
  • folderId (System.Int32)Id of the folder.
  • folderName (System.String)Name of the album folder.
  • creatorUserId (System.Int32)Id of the user who created the album.
  • GroupId (System.Int32)Id of the group to which the album belongs.
  • numPhotos (System.Int32)Number of photos in the album.
  • CreatedDate (System.DateTime)Date and Time when the album was created.
  • name (System.String)Name of the album.

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetPhotoDetail Method

[image]

OfficeClip API Documentation
PhotoDB..::.GetPhotoDetail Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details of a photo identified by photoId.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PhotoInfo GetPhotoDetail(
    int photoId
)
Visual Basic (Declaration)
Public Function GetPhotoDetail ( _
    photoId As Integer _
) As PhotoInfo
Visual C++
public:
PhotoInfo^ GetPhotoDetail(
    int photoId
)

Parameters

photoId
Type: System..::.Int32
The database specific id of the photo.

Return Value

Instance of the PhotoInfo object containing all the information related to a photo. OfficeClip.BusinessLayer.OfficePortal..::.PhotoInfo

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetPhotoList Method

[image]

OfficeClip API Documentation
PhotoDB..::.GetPhotoList Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of photos for a particular album id.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPhotoList(
    int albumId
)
Visual Basic (Declaration)
Public Function GetPhotoList ( _
    albumId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetPhotoList(
    int albumId
)

Parameters

albumId
Type: System..::.Int32

Return Value

The DataSet consisting of a single DataTable with the following columns.
  • did (System.Int32)Id of the photo document.
  • dname (System.String)Name of the photo document.
  • descr (System.String)Description of the photo.
  • sof (System.Decimal)Size of the photo file.
  • Cdate (System.DateTime)Date and time when the photo document was created.
  • cid (System.Int32)Id of the user who created the photo document.
  • uname (System.String)Name of the user who created the photo document.

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
PhotoDB..::.InitTransaction Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

PhotoDB Class
PhotoDB Members
OfficeClip.DBLayer.OfficePortal Namespace


InsertAlbum Method

[image]

OfficeClip API Documentation
PhotoDB..::.InsertAlbum Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the Album corresponding to the currently selected group in the database and the file system for the currently logged in user.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertAlbum(
    string folderName,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function InsertAlbum ( _
    folderName As String, _
    userId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int InsertAlbum(
    String^ folderName,
    int userId,
    int groupId
)

Parameters

folderName
Type: System..::.String
The name of the folder where the album to be stored.
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
Unique id of the organization

Return Value

Folder id of the album if successful, -1 in case of an error.

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


SavePostedFile Method

[image]

OfficeClip API Documentation
PhotoDB..::.SavePostedFile Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Stores the posted (uploaded) file in the file system and Store the link in the database.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string SavePostedFile(
    HttpPostedFile postedFile,
    string postedTitle,
    string postedDescription,
    int albumId,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function SavePostedFile ( _
    postedFile As HttpPostedFile, _
    postedTitle As String, _
    postedDescription As String, _
    albumId As Integer, _
    session As ConfigureInfo _
) As String
Visual C++
public:
String^ SavePostedFile(
    HttpPostedFile^ postedFile,
    String^ postedTitle,
    String^ postedDescription,
    int albumId,
    ConfigureInfo^ session
)

Parameters

postedFile
Type: System.Web..::.HttpPostedFile
The posted (uploaded) file.
postedTitle
Type: System..::.String
The photo title.
postedDescription
Type: System..::.String
The photo Description.
albumId
Type: System..::.Int32
Id of the album folder.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

status of each posting file, the file is skipped if the return is not empty.

See Also

PhotoDB Class
OfficeClip.DBLayer.OfficePortal Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
PhotoDB..::.SetSPCommand Method
PhotoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

PhotoDB Class
PhotoDB Members
OfficeClip.DBLayer.OfficePortal Namespace


PollDB Class

[image]

OfficeClip API Documentation
PollDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Poll application related functions.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class PollDB : OfficeClipDB
Visual Basic (Declaration)
Public Class PollDB _
    Inherits OfficeClipDB
Visual C++
public ref class PollDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.OfficePortal..::.PollDB

See Also

PollDB Members
OfficeClip.DBLayer.OfficePortal Namespace


PollDB Members

[image] [image]

OfficeClip API Documentation
PollDB Members
PollDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PollDB type exposes the following members.

Constructors

 | Name | Description
Public method | PollDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | Archive | Sets a particular poll as archived.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Overloaded.
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Delete | Deletes a particular poll identified by pollId.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDetail | Gets all the details corresponding to a poll for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPoll | Gets all the information related to a poll for a particular user.
Public method | GetPollArchive | Gets all the information related to the polls that have been archived for a particular user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | Insert | Inserts the polls into the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Vote | Registers a vote for a particular poll.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

PollDB Class
OfficeClip.DBLayer.OfficePortal Namespace


PollDB Constructor

[image]

OfficeClip API Documentation
PollDB Constructor
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PollDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PollDB()

See Also

PollDB Class
OfficeClip.DBLayer.OfficePortal Namespace


PollDB Methods

[image] [image]

OfficeClip API Documentation
PollDB Methods
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

The PollDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | Archive | Sets a particular poll as archived.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Overloaded.
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Delete | Deletes a particular poll identified by pollId.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDetail | Gets all the details corresponding to a poll for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPoll | Gets all the information related to a poll for a particular user.
Public method | GetPollArchive | Gets all the information related to the polls that have been archived for a particular user.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | Insert | Inserts the polls into the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Vote | Registers a vote for a particular poll.

See Also

PollDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
PollDB..::.AddOutputParameter Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

PollDB Class
PollDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
PollDB..::.AddParameter Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

PollDB Class
PollDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
PollDB..::.AddParameters Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

PollDB Class
PollDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Archive Method

[image]

OfficeClip API Documentation
PollDB..::.Archive Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets a particular poll as archived.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Archive(
    int pollId,
    int userId
)
Visual Basic (Declaration)
Public Sub Archive ( _
    pollId As Integer, _
    userId As Integer _
)
Visual C++
public:
void Archive(
    int pollId,
    int userId
)

Parameters

pollId
Type: System..::.Int32
Id of the poll which need to be marked as archived.
userId
Type: System..::.Int32
The unique id of the user

See Also

PollDB Class
OfficeClip.DBLayer.OfficePortal Namespace


Close Method

[image] [image]

OfficeClip API Documentation
PollDB..::.Close Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Close()()() | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Close(Int32) | Closes a poll identified by pollId.

See Also

PollDB Class
PollDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Close Method (Int32)

[image]

OfficeClip API Documentation
PollDB..::.Close Method (Int32)
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Closes a poll identified by pollId.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Close(
    int pollId
)
Visual Basic (Declaration)
Public Sub Close ( _
    pollId As Integer _
)
Visual C++
public:
void Close(
    int pollId
)

Parameters

pollId
Type: System..::.Int32
Id of the poll which needs to be closed.

See Also

PollDB Class
Close Overload
OfficeClip.DBLayer.OfficePortal Namespace


Delete Method

[image]

OfficeClip API Documentation
PollDB..::.Delete Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a particular poll identified by pollId.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Delete(
    int pollId,
    int userId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Sub Delete ( _
    pollId As Integer, _
    userId As Integer, _
    isCurrentUserAdmin As Boolean _
)
Visual C++
public:
void Delete(
    int pollId,
    int userId,
    bool isCurrentUserAdmin
)

Parameters

pollId
Type: System..::.Int32
Id of the poll which needs to be deleted.
userId
Type: System..::.Int32
The unique id of the user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

See Also

PollDB Class
OfficeClip.DBLayer.OfficePortal Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
PollDB..::.ExecuteNonQuery Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

PollDB Class
PollDB Members
OfficeClip.DBLayer.OfficePortal Namespace


GetDetail Method

[image]

OfficeClip API Documentation
PollDB..::.GetDetail Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details corresponding to a poll for a particular group.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetDetail(
    int groupId,
    int pollId,
    ref string pollq,
    ref string security,
    ref string anonymity,
    ref string multipleChoice,
    ref DateTime closeDate,
    ref int totalPolls,
    ref int numUsersVoted,
    ref string usersNotVoted,
    ref int totalUsers,
    ref DataTable dtOption
)
Visual Basic (Declaration)
Public Sub GetDetail ( _
    groupId As Integer, _
    pollId As Integer, _
    ByRef pollq As String, _
    ByRef security As String, _
    ByRef anonymity As String, _
    ByRef multipleChoice As String, _
    ByRef closeDate As DateTime, _
    ByRef totalPolls As Integer, _
    ByRef numUsersVoted As Integer, _
    ByRef usersNotVoted As String, _
    ByRef totalUsers As Integer, _
    ByRef dtOption As DataTable _
)
Visual C++
public:
void GetDetail(
    int groupId,
    int pollId,
    String^% pollq,
    String^% security,
    String^% anonymity,
    String^% multipleChoice,
    DateTime% closeDate,
    int% totalPolls,
    int% numUsersVoted,
    String^% usersNotVoted,
    int% totalUsers,
    DataTable^% dtOption
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group.
pollId
Type: System..::.Int32
Id of the poll.
pollq
Type: System..::.String%
Description of the poll or the poll question.
security
Type: System..::.String%
Is the poll Secured (poll results are not shown before the polling is over).
anonymity
Type: System..::.String%
Is the poll Anonymous (names are not shown in anonymous poll).
multipleChoice
Type: System..::.String%
Is more than one choice allowed for the poll.
closeDate
Type: System..::.DateTime%
Date and Time (if closes automatically) when the poll expires.
totalPolls
Type: System..::.Int32%
Total number of votes cast for a poll.
numUsersVoted
Type: System..::.Int32%
Total distinct number of users who have voted for this particular poll.
usersNotVoted
Type: System..::.String%
Number of users who have not yet voted for this particular poll.
totalUsers
Type: System..::.Int32%
Total number of users who can vote for this particular poll.
dtOption
Type: System.Data..::.DataTable%
DataTable containing all the details of all the options specified for the poll. This DataTable has the following columns.
  • optionId (System.Int32)Id of the option.
  • pollOption (System.String)Text string describing the poll option.
  • totalEach (System.Int32)Number of votes for this particular option.
  • userNames (System.String)Name of users who have voted for this particular option.

See Also

PollDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetPoll Method

[image]

OfficeClip API Documentation
PollDB..::.GetPoll Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to a poll for a particular user.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPoll(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetPoll ( _
    userId As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetPoll(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user.
groupId
Type: System..::.Int32
The unique id of the organization

Return Value

DataSet containing all the information related to a poll. The DataSet consists of a single DataTable with the following columns.
  • pid (System.Int32)Id of the poll.
  • gname (System.String)Name of the group for which the poll has been created.
  • pollq (System.String)Poll Description or the question of the poll.
  • vote (System.Int32)Number of votes for a particular poll.
  • closeDate (System.DateTime)Date and Time when the Current poll expires.
  • createdUserId (System.Int32)Id of the user who created the poll.
  • CreatedDate (System.DateTime)Date and Time when the poll was created.
  • uName (System.String)Name of the user who created the poll.
  • IsAdmin (System.String)Flag (Y/N) indicating whether the user is the admin in the group for which the poll is created.

See Also

PollDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetPollArchive Method

[image]

OfficeClip API Documentation
PollDB..::.GetPollArchive Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to the polls that have been archived for a particular user.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPollArchive(
    int userId
)
Visual Basic (Declaration)
Public Function GetPollArchive ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetPollArchive(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id for the user.

Return Value

DataSet containing all the information related to all the polls that have been archived. This DataSet consists of a single DataTable with the following columns.
  • pid (System.Int32)Id of the poll.
  • gname (System.String)Name of the group for which the poll has been created.
  • pollq (System.String)Poll Description or the question of the poll.
  • vote (System.Int32)Number of votes for a particular poll.
  • closeDate (System.DateTime)Date and Time when the Current poll expires.
  • createdUserId (System.Int32)Id of the user who created the poll.
  • CreatedDate (System.DateTime)Date and Time when the poll was created.
  • uName (System.String)Name of the user who created the poll.

See Also

PollDB Class
OfficeClip.DBLayer.OfficePortal Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
PollDB..::.InitTransaction Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

PollDB Class
PollDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Insert Method

[image]

OfficeClip API Documentation
PollDB..::.Insert Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the polls into the database.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int Insert(
    string message,
    DateTime expires,
    bool isSecured,
    bool isAnonymous,
    bool isMultipleChoice,
    string[] choice,
    string docIdList,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function Insert ( _
    message As String, _
    expires As DateTime, _
    isSecured As Boolean, _
    isAnonymous As Boolean, _
    isMultipleChoice As Boolean, _
    choice As String(), _
    docIdList As String, _
    userId As Integer, _
    groupId As Integer _
) As Integer
Visual C++
public:
int Insert(
    String^ message,
    DateTime expires,
    bool isSecured,
    bool isAnonymous,
    bool isMultipleChoice,
    array<String^>^ choice,
    String^ docIdList,
    int userId,
    int groupId
)

Parameters

message
Type: System..::.String
The poll Description.
expires
Type: System..::.DateTime
Date and Time when the poll expires, if empty then it is manual expiration and the database value is set to null.
isSecured
Type: System..::.Boolean
Is the poll Secured (poll results are not shown before the polling is over).
isAnonymous
Type: System..::.Boolean
Is the poll Anonymous (names are not shown in anonymous poll).
isMultipleChoice
Type: System..::.Boolean
Users can select more than one poll choices.
choice
Type: array<System..::.String>[]()[]
All the poll choices in a string.
docIdList
Type: System..::.String
Comma delimited list of document ids of all the documents attached with this poll.
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the organization

Return Value

The pollId of the poll inserted.

See Also

PollDB Class
OfficeClip.DBLayer.OfficePortal Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
PollDB..::.SetSPCommand Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

PollDB Class
PollDB Members
OfficeClip.DBLayer.OfficePortal Namespace


Vote Method

[image]

OfficeClip API Documentation
PollDB..::.Vote Method
PollDB Class See Also

[This is preliminary documentation and is subject to change.]

Registers a vote for a particular poll.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Vote(
    int pollId,
    ArrayList vOption,
    int userId
)
Visual Basic (Declaration)
Public Sub Vote ( _
    pollId As Integer, _
    vOption As ArrayList, _
    userId As Integer _
)
Visual C++
public:
void Vote(
    int pollId,
    ArrayList^ vOption,
    int userId
)

Parameters

pollId
Type: System..::.Int32
Id of the poll.
vOption
Type: System.Collections..::.ArrayList
ArrayList of all the ids of the options belonging to this poll for which the user wants to vote.
userId
Type: System..::.Int32
The unique id of the user

See Also

PollDB Class
OfficeClip.DBLayer.OfficePortal Namespace


PortletDB Class

[image]

OfficeClip API Documentation
PortletDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Portlet application related functions.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class PortletDB : OfficeClipDB
Visual Basic (Declaration)
Public Class PortletDB _
    Inherits OfficeClipDB
Visual C++
public ref class PortletDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.OfficePortal..::.PortletDB

See Also

PortletDB Members
OfficeClip.DBLayer.OfficePortal Namespace


PortletDB Members

[image] [image]

OfficeClip API Documentation
PortletDB Members
PortletDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PortletDB type exposes the following members.

Constructors

 | Name | Description
Public method | PortletDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBusinessCenters | This function will retrieve the businesscenter portlets information from the businesscenter.xml resource file and load into DataSet.
Public method | GetGroupBookmarks | Gets all the bookmarks to be displayed on the homepage screen for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLatestContacts | Gets the latest Contacts. Only 10 latest members are returned
Public method | GetLatestGroupDocuments | Gets the latest group documents. Only 10 latest documents are returned
Public method | GetLatestMembers | Gets the latest members. Only 10 latest members are returned
Public method | GetNews | This function will retrieve the news portlets information from the news.xml resource file and load into DataSet.
Public method | GetOfficeClipPicks | Gets the links to different websites specified by the site administrator in OfficeClipPicks.xml resource file. Please refer to the OfficeClip level 1 customization in the OfficeClip customization help document in order to learn more about how different portlets consisting of links to other relevant websites can be provided in OfficeClip.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWhatsNew | Returns the information related to What's new for a particular user.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

PortletDB Class
OfficeClip.DBLayer.OfficePortal Namespace


PortletDB Constructor

[image]

OfficeClip API Documentation
PortletDB Constructor
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PortletDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PortletDB()

See Also

PortletDB Class
OfficeClip.DBLayer.OfficePortal Namespace


PortletDB Methods

[image] [image]

OfficeClip API Documentation
PortletDB Methods
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

The PortletDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBusinessCenters | This function will retrieve the businesscenter portlets information from the businesscenter.xml resource file and load into DataSet.
Public method | GetGroupBookmarks | Gets all the bookmarks to be displayed on the homepage screen for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLatestContacts | Gets the latest Contacts. Only 10 latest members are returned
Public method | GetLatestGroupDocuments | Gets the latest group documents. Only 10 latest documents are returned
Public method | GetLatestMembers | Gets the latest members. Only 10 latest members are returned
Public method | GetNews | This function will retrieve the news portlets information from the news.xml resource file and load into DataSet.
Public method | GetOfficeClipPicks | Gets the links to different websites specified by the site administrator in OfficeClipPicks.xml resource file. Please refer to the OfficeClip level 1 customization in the OfficeClip customization help document in order to learn more about how different portlets consisting of links to other relevant websites can be provided in OfficeClip.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWhatsNew | Returns the information related to What's new for a particular user.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PortletDB Class
OfficeClip.DBLayer.OfficePortal Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
PortletDB..::.AddOutputParameter Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

PortletDB Class
PortletDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
PortletDB..::.AddParameter Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

PortletDB Class
PortletDB Members
OfficeClip.DBLayer.OfficePortal Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
PortletDB..::.AddParameters Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

PortletDB Class
PortletDB Members
OfficeClip.DBLayer.OfficePortal Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
PortletDB..::.ExecuteNonQuery Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

PortletDB Class
PortletDB Members
OfficeClip.DBLayer.OfficePortal Namespace


GetBusinessCenters Method

[image]

OfficeClip API Documentation
PortletDB..::.GetBusinessCenters Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

This function will retrieve the businesscenter portlets information from the businesscenter.xml resource file and load into DataSet.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetBusinessCenters()
Visual Basic (Declaration)
Public Function GetBusinessCenters As DataSet
Visual C++
public:
DataSet^ GetBusinessCenters()

Return Value

DataSet corresponding to the businesscenter.xml resource file. Please refer to the OfficeClip level 1 customization in OfficeClip customization help document to learn more about the customization.

See Also

PortletDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetGroupBookmarks Method

[image]

OfficeClip API Documentation
PortletDB..::.GetGroupBookmarks Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the bookmarks to be displayed on the homepage screen for a particular group.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SqlDataReader GetGroupBookmarks(
    int groupId
)
Visual Basic (Declaration)
Public Function GetGroupBookmarks ( _
    groupId As Integer _
) As SqlDataReader
Visual C++
public:
SqlDataReader^ GetGroupBookmarks(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.

Return Value

SqlDataReader containing all the information related group bookmarks. The SqlDataReader has the following columns.
  • url (System.String)Url of the web page which has been bookmarked.
  • title (System.String)title of the bookmark.

Remarks

Make sure to Close the SqlDataReader after the use otherwise it will leave and connection open (till garbage collector releases the Data Reader). If not closed explicitly, the .Net framework might hang and slow down because of the number of open connections Limit might be reached.

See Also

PortletDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetLatestContacts Method

[image]

OfficeClip API Documentation
PortletDB..::.GetLatestContacts Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the latest Contacts. Only 10 latest members are returned

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetLatestContacts(
    int groupId
)
Visual Basic (Declaration)
Public Function GetLatestContacts ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetLatestContacts(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The id of the organization

See Also

PortletDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetLatestGroupDocuments Method

[image]

OfficeClip API Documentation
PortletDB..::.GetLatestGroupDocuments Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the latest group documents. Only 10 latest documents are returned

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetLatestGroupDocuments(
    int groupId
)
Visual Basic (Declaration)
Public Function GetLatestGroupDocuments ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetLatestGroupDocuments(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The id of the organization

See Also

PortletDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetLatestMembers Method

[image]

OfficeClip API Documentation
PortletDB..::.GetLatestMembers Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the latest members. Only 10 latest members are returned

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetLatestMembers(
    int groupId
)
Visual Basic (Declaration)
Public Function GetLatestMembers ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetLatestMembers(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The id of the organization

See Also

PortletDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetNews Method

[image]

OfficeClip API Documentation
PortletDB..::.GetNews Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

This function will retrieve the news portlets information from the news.xml resource file and load into DataSet.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetNews()
Visual Basic (Declaration)
Public Function GetNews As DataSet
Visual C++
public:
DataSet^ GetNews()

Return Value

DataSet corresponding to the news.xml resource file. Please refer to the OfficeClip level 1 customization in OfficeClip customization help document to learn more about this customization.

See Also

PortletDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetOfficeClipPicks Method

[image]

OfficeClip API Documentation
PortletDB..::.GetOfficeClipPicks Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the links to different websites specified by the site administrator in OfficeClipPicks.xml resource file. Please refer to the OfficeClip level 1 customization in the OfficeClip customization help document in order to learn more about how different portlets consisting of links to other relevant websites can be provided in OfficeClip.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetOfficeClipPicks()
Visual Basic (Declaration)
Public Function GetOfficeClipPicks As DataSet
Visual C++
public:
DataSet^ GetOfficeClipPicks()

Return Value

DataSet corresponding to the OfficeClipPicks.xml resource file.

See Also

PortletDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetWhatsNew Method

[image]

OfficeClip API Documentation
PortletDB..::.GetWhatsNew Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the information related to What's new for a particular user.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetWhatsNew(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetWhatsNew ( _
    userId As Integer, _
    groupId As Integer _
) As DataView
Visual C++
public:
DataView^ GetWhatsNew(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The unique id for the group.
groupId
Type: System..::.Int32
The unique id of the organization

Return Value

DataView consisting of all the What's New information. This DataView consists of the collowing columns.
  • Count (System.Int32)Number of items created of a particular type.
  • Type (System.String)Type of the item created in OfficeClip for e.g. Timesheets, Documents, Tracker cases etc.
  • ApplicationId (System.Int32)The applicationId of the document.
  • SecondaryName (System.String)Name of the Project if the item is a tracker case.
  • SecondaryId (System.Int32)Id of the Project if the item is a tracker case.

See Also

PortletDB Class
OfficeClip.DBLayer.OfficePortal Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
PortletDB..::.InitTransaction Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

PortletDB Class
PortletDB Members
OfficeClip.DBLayer.OfficePortal Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
PortletDB..::.SetSPCommand Method
PortletDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

PortletDB Class
PortletDB Members
OfficeClip.DBLayer.OfficePortal Namespace


RssDB Class

[image]

OfficeClip API Documentation
RssDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Summary description for the news feed.

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class RssDB
Visual Basic (Declaration)
Public Class RssDB
Visual C++
public ref class RssDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.OfficePortal..::.RssDB

See Also

RssDB Members
OfficeClip.DBLayer.OfficePortal Namespace


RssDB Members

[image] [image]

OfficeClip API Documentation
RssDB Members
RssDB Class Constructors Methods Fields See Also

[This is preliminary documentation and is subject to change.]

The RssDB type exposes the following members.

Constructors

 | Name | Description
Public method | RssDB | The default constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveDV | Gets the active dataview
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetPortletDV | Gets the portlet dataview
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserContentDS | Gets the user content dataset
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveUserContentFile | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | ocr |

See Also

RssDB Class
OfficeClip.DBLayer.OfficePortal Namespace


RssDB Constructor

[image]

OfficeClip API Documentation
RssDB Constructor
RssDB Class See Also

[This is preliminary documentation and is subject to change.]

The default constructor

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public RssDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RssDB()

See Also

RssDB Class
OfficeClip.DBLayer.OfficePortal Namespace


RssDB Fields

[image] [image]

OfficeClip API Documentation
RssDB Fields
RssDB Class See Also

[This is preliminary documentation and is subject to change.]

The RssDB type exposes the following fields.

Fields

 | Name | Description
Protected field | ocr |

See Also

RssDB Class
OfficeClip.DBLayer.OfficePortal Namespace


ocr Field

[image]

OfficeClip API Documentation
RssDB..::.ocr Field
RssDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected OCResources ocr
Visual Basic (Declaration)
Protected ocr As OCResources
Visual C++
protected:
OCResources^ ocr

See Also

RssDB Class
OfficeClip.DBLayer.OfficePortal Namespace


RssDB Methods

[image] [image]

OfficeClip API Documentation
RssDB Methods
RssDB Class See Also

[This is preliminary documentation and is subject to change.]

The RssDB type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveDV | Gets the active dataview
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetPortletDV | Gets the portlet dataview
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserContentDS | Gets the user content dataset
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveUserContentFile | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RssDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetActiveDV Method

[image]

OfficeClip API Documentation
RssDB..::.GetActiveDV Method
RssDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the active dataview

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetActiveDV(
    int userId
)
Visual Basic (Declaration)
Public Function GetActiveDV ( _
    userId As Integer _
) As DataView
Visual C++
public:
DataView^ GetActiveDV(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

The active dataview

See Also

RssDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetPortletDV Method

[image]

OfficeClip API Documentation
RssDB..::.GetPortletDV Method
RssDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the portlet dataview

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetPortletDV(
    int userId
)
Visual Basic (Declaration)
Public Function GetPortletDV ( _
    userId As Integer _
) As DataView
Visual C++
public:
DataView^ GetPortletDV(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

The portlet dataview

See Also

RssDB Class
OfficeClip.DBLayer.OfficePortal Namespace


GetUserContentDS Method

[image]

OfficeClip API Documentation
RssDB..::.GetUserContentDS Method
RssDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the user content dataset

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetUserContentDS(
    int userId
)
Visual Basic (Declaration)
Public Function GetUserContentDS ( _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetUserContentDS(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

The user content dataset

See Also

RssDB Class
OfficeClip.DBLayer.OfficePortal Namespace


SaveUserContentFile Method

[image] [image]

OfficeClip API Documentation
RssDB..::.SaveUserContentFile Method
RssDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | SaveUserContentFile(Int32) | Saves the content file
Public method | SaveUserContentFile(DataSet, Int32) | Saves the user content file

See Also

RssDB Class
RssDB Members
OfficeClip.DBLayer.OfficePortal Namespace


SaveUserContentFile Method (Int32)

[image]

OfficeClip API Documentation
RssDB..::.SaveUserContentFile Method (Int32)
RssDB Class See Also

[This is preliminary documentation and is subject to change.]

Saves the content file

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SaveUserContentFile(
    int userId
)
Visual Basic (Declaration)
Public Sub SaveUserContentFile ( _
    userId As Integer _
)
Visual C++
public:
void SaveUserContentFile(
    int userId
)

Parameters

userId
Type: System..::.Int32

See Also

RssDB Class
SaveUserContentFile Overload
OfficeClip.DBLayer.OfficePortal Namespace


SaveUserContentFile Method (DataSet, Int32)

[image]

OfficeClip API Documentation
RssDB..::.SaveUserContentFile Method (DataSet, Int32)
RssDB Class See Also

[This is preliminary documentation and is subject to change.]

Saves the user content file

Namespace: OfficeClip.DBLayer.OfficePortal
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SaveUserContentFile(
    DataSet ds,
    int userId
)
Visual Basic (Declaration)
Public Sub SaveUserContentFile ( _
    ds As DataSet, _
    userId As Integer _
)
Visual C++
public:
void SaveUserContentFile(
    DataSet^ ds,
    int userId
)

Parameters

ds
Type: System.Data..::.DataSet
The input dataset
userId
Type: System..::.Int32
The unique id of the user

See Also

RssDB Class
SaveUserContentFile Overload
OfficeClip.DBLayer.OfficePortal Namespace


OfficeClip.DBLayer.Projects Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Projects Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip projects

Classes

 | Class | Description
Public class | ProjectDB |


ProjectDB Class

[image]

OfficeClip API Documentation
ProjectDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class ProjectDB : OfficeClipDB
Visual Basic (Declaration)
Public Class ProjectDB _
    Inherits OfficeClipDB
Visual C++
public ref class ProjectDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Projects..::.ProjectDB

See Also

ProjectDB Members
OfficeClip.DBLayer.Projects Namespace


ProjectDB Members

[image] [image]

OfficeClip API Documentation
ProjectDB Members
ProjectDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ProjectDB type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectDB |

Methods

 | Name | Description
Public method | AccountExists | Checks whether a Customer with a particular screen name exists.
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteProject | Deletes a particular Project identified by projectId.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccount | Gets all the information related to a particular Customer identified by accountId.
Public method | GetClientAndProjectList | Get a list of all the Customer and Projects for a particular group.
Public method | GetClientAndProjectRestrictedList | Gets the restricted list for the client and the project
Public method | GetClientList | Gets the list of clients for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetProject | Gets all the Project related information from the database.
Public method | GetProjectList | Gets the list of projects
Public method | GetProjectsForRdlc | List of projects in a group (used in rdl reports)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserRestrictedList | Gets the restricted list for the user
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertAccount | inserts the account
Public method | InsertProject | Inserts all the Project related information from the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectExists | Checks whether a Project with a particular screen name exists.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAccountName | Updates a Customer and all its related information into the database.
Public method | UpdateClientProjectRestricted | Updates the client and the project restricted list
Public method | UpdateProject | Updates all the Project related information from the database.
Public method | UpdateUsersRestricted | Updates the users restricted list

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


ProjectDB Constructor

[image]

OfficeClip API Documentation
ProjectDB Constructor
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ProjectDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProjectDB()

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


ProjectDB Methods

[image] [image]

OfficeClip API Documentation
ProjectDB Methods
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

The ProjectDB type exposes the following methods.

Methods

 | Name | Description
Public method | AccountExists | Checks whether a Customer with a particular screen name exists.
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteProject | Deletes a particular Project identified by projectId.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccount | Gets all the information related to a particular Customer identified by accountId.
Public method | GetClientAndProjectList | Get a list of all the Customer and Projects for a particular group.
Public method | GetClientAndProjectRestrictedList | Gets the restricted list for the client and the project
Public method | GetClientList | Gets the list of clients for a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetProject | Gets all the Project related information from the database.
Public method | GetProjectList | Gets the list of projects
Public method | GetProjectsForRdlc | List of projects in a group (used in rdl reports)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserRestrictedList | Gets the restricted list for the user
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertAccount | inserts the account
Public method | InsertProject | Inserts all the Project related information from the database.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProjectExists | Checks whether a Project with a particular screen name exists.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAccountName | Updates a Customer and all its related information into the database.
Public method | UpdateClientProjectRestricted | Updates the client and the project restricted list
Public method | UpdateProject | Updates all the Project related information from the database.
Public method | UpdateUsersRestricted | Updates the users restricted list

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


AccountExists Method

[image]

OfficeClip API Documentation
ProjectDB..::.AccountExists Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks whether a Customer with a particular screen name exists.

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int AccountExists(
    string screenName,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function AccountExists ( _
    screenName As String, _
    currentGroupId As Integer _
) As Integer
Visual C++
public:
int AccountExists(
    String^ screenName,
    int currentGroupId
)

Parameters

screenName
Type: System..::.String
Screen name corresponding to a Customer which needs to be checked.
currentGroupId
Type: System..::.Int32
The id of the current group

Return Value

Id of the Customer if found, -1 otherwise.

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
ProjectDB..::.AddOutputParameter Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

ProjectDB Class
ProjectDB Members
OfficeClip.DBLayer.Projects Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
ProjectDB..::.AddParameter Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

ProjectDB Class
ProjectDB Members
OfficeClip.DBLayer.Projects Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
ProjectDB..::.AddParameters Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

ProjectDB Class
ProjectDB Members
OfficeClip.DBLayer.Projects Namespace


DeleteProject Method

[image]

OfficeClip API Documentation
ProjectDB..::.DeleteProject Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a particular Project identified by projectId.

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteProject(
    int projectId
)
Visual Basic (Declaration)
Public Function DeleteProject ( _
    projectId As Integer _
) As Integer
Visual C++
public:
int DeleteProject(
    int projectId
)

Parameters

projectId
Type: System..::.Int32
Id of the Project which needs to be deleted.

Return Value

0 when successful, -1 in case of an error.

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
ProjectDB..::.ExecuteNonQuery Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

ProjectDB Class
ProjectDB Members
OfficeClip.DBLayer.Projects Namespace


GetAccount Method

[image]

OfficeClip API Documentation
ProjectDB..::.GetAccount Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to a particular Customer identified by accountId.

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ClientInfo GetAccount(
    int accountId
)
Visual Basic (Declaration)
Public Function GetAccount ( _
    accountId As Integer _
) As ClientInfo
Visual C++
public:
ClientInfo^ GetAccount(
    int accountId
)

Parameters

accountId
Type: System..::.Int32
Id of the Customer for which all the information is to be retrieved.

Return Value

Instance of the ClientInfo object containing all the information related to the Customer. ClientInfo

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


GetClientAndProjectList Method

[image]

OfficeClip API Documentation
ProjectDB..::.GetClientAndProjectList Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Get a list of all the Customer and Projects for a particular group.

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetClientAndProjectList(
    int groupId
)
Visual Basic (Declaration)
Public Function GetClientAndProjectList ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetClientAndProjectList(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.

Return Value

DataSet containing the list of Customer and Projects. This DataSet consists of a single DataTable with the following columns.
  • id (System.Int32)Id of the Customer and/or the Project.
  • screenName (System.String)Screen name of the Customer or the Project.
  • accountId (System.Int32)Id of the Customer.
  • AccountName (System.String)Name of the Customer.
  • projectId (System.Int32)Id of the Project.
  • projectNameName of the Project.

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


GetClientAndProjectRestrictedList Method

[image]

OfficeClip API Documentation
ProjectDB..::.GetClientAndProjectRestrictedList Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the restricted list for the client and the project

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetClientAndProjectRestrictedList(
    int groupId,
    int userId
)
Visual Basic (Declaration)
Public Function GetClientAndProjectRestrictedList ( _
    groupId As Integer, _
    userId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetClientAndProjectRestrictedList(
    int groupId,
    int userId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user

Return Value

The restricted dataset of the client and the project

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


GetClientList Method

[image]

OfficeClip API Documentation
ProjectDB..::.GetClientList Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of clients for a particular group.

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetClientList(
    int groupId
)
Visual Basic (Declaration)
Public Function GetClientList ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetClientList(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.

Return Value

DataSet containing all the information related to the clients created for a particular group. This DataSet consists of a single DataTable with the following columns.
  • accountId (System.Int32)Id of the Account.
  • ContactAddressId (System.Int32)Id of the Address record corresponding to the Customer.
  • GroupId (System.Int32)Id of the group to which the Customer belongs.
  • name (System.String)Name of the Customer.
  • screenName (System.String)Name to be displayed on the screen.
  • clientName (System.String)This is the concatenated value of name and screenName.
  • id (System.String)Id is the ID corresponding to the same Customer in an external system. (To be used if an integration between Time and Expense system and that external application is desired.)
  • ContactPerson (System.String)Name of the contact person for the Customer.
  • ContactPhone (System.String)Contact phone number of the Customer.
  • emailAddress (System.String)Email Address of the Customer or the contact person of the Customer.
  • Notes (System.String)Notes describing some things about the Customer.
  • isActive (System.String)Flag (Y/N) indicating whether the Customer is Active or not.

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


GetProject Method

[image]

OfficeClip API Documentation
ProjectDB..::.GetProject Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the Project related information from the database.

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ProjectInfo GetProject(
    int projectId
)
Visual Basic (Declaration)
Public Function GetProject ( _
    projectId As Integer _
) As ProjectInfo
Visual C++
public:
ProjectInfo^ GetProject(
    int projectId
)

Parameters

projectId
Type: System..::.Int32
Id of the Project for which all the information has to be retrieved.

Return Value

Instance of the ProjectInfo object containing all the information related to the Project. ProjectInfo

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


GetProjectList Method

[image]

OfficeClip API Documentation
ProjectDB..::.GetProjectList Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the list of projects

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetProjectList(
    int accountId,
    bool isActiveOnly
)
Visual Basic (Declaration)
Public Function GetProjectList ( _
    accountId As Integer, _
    isActiveOnly As Boolean _
) As DataSet
Visual C++
public:
DataSet^ GetProjectList(
    int accountId,
    bool isActiveOnly
)

Parameters

accountId
Type: System..::.Int32
isActiveOnly
Type: System..::.Boolean

Return Value

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


GetProjectsForRdlc Method

[image]

OfficeClip API Documentation
ProjectDB..::.GetProjectsForRdlc Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

List of projects in a group (used in rdl reports)

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetProjectsForRdlc(
    int groupId
)
Visual Basic (Declaration)
Public Function GetProjectsForRdlc ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetProjectsForRdlc(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

list of available project names in a groups

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


GetUserRestrictedList Method

[image]

OfficeClip API Documentation
ProjectDB..::.GetUserRestrictedList Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the restricted list for the user

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetUserRestrictedList(
    int groupId,
    int accountId,
    int projectId
)
Visual Basic (Declaration)
Public Function GetUserRestrictedList ( _
    groupId As Integer, _
    accountId As Integer, _
    projectId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetUserRestrictedList(
    int groupId,
    int accountId,
    int projectId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
accountId
Type: System..::.Int32
The unique id of the client
projectId
Type: System..::.Int32
The unique id of the project

Return Value

The restricted dataset of the client and the project

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
ProjectDB..::.InitTransaction Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

ProjectDB Class
ProjectDB Members
OfficeClip.DBLayer.Projects Namespace


InsertAccount Method

[image]

OfficeClip API Documentation
ProjectDB..::.InsertAccount Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

inserts the account

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertAccount(
    ClientInfo ci,
    int userId
)
Visual Basic (Declaration)
Public Function InsertAccount ( _
    ci As ClientInfo, _
    userId As Integer _
) As Integer
Visual C++
public:
int InsertAccount(
    ClientInfo^ ci,
    int userId
)

Parameters

ci
Type: OfficeClip.BusinessLayer.Projects..::.ClientInfo
userId
Type: System..::.Int32

Return Value

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


InsertProject Method

[image]

OfficeClip API Documentation
ProjectDB..::.InsertProject Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the Project related information from the database.

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertProject(
    ProjectInfo pi
)
Visual Basic (Declaration)
Public Function InsertProject ( _
    pi As ProjectInfo _
) As Integer
Visual C++
public:
int InsertProject(
    ProjectInfo^ pi
)

Parameters

pi
Type: OfficeClip.BusinessLayer.Projects..::.ProjectInfo
Instance of the ProjectInfo object containing all the information related to the Project. ProjectInfo

Return Value

Id of the newly created Project when successful, -1 in case of an error.

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


ProjectExists Method

[image]

OfficeClip API Documentation
ProjectDB..::.ProjectExists Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks whether a Project with a particular screen name exists.

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ProjectExists(
    string screenName,
    int accountId
)
Visual Basic (Declaration)
Public Function ProjectExists ( _
    screenName As String, _
    accountId As Integer _
) As Integer
Visual C++
public:
int ProjectExists(
    String^ screenName,
    int accountId
)

Parameters

screenName
Type: System..::.String
Screen name corresponding to a Project which needs to be checked.
accountId
Type: System..::.Int32
The identifier for the Customer.

Return Value

Id of the Project if found, -1 otherwise.

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
ProjectDB..::.SetSPCommand Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

ProjectDB Class
ProjectDB Members
OfficeClip.DBLayer.Projects Namespace


UpdateAccountName Method

[image]

OfficeClip API Documentation
ProjectDB..::.UpdateAccountName Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates a Customer and all its related information into the database.

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateAccountName(
    int accountId,
    string name,
    string screenName
)
Visual Basic (Declaration)
Public Function UpdateAccountName ( _
    accountId As Integer, _
    name As String, _
    screenName As String _
) As Integer
Visual C++
public:
int UpdateAccountName(
    int accountId,
    String^ name,
    String^ screenName
)

Parameters

accountId
Type: System..::.Int32
the unique id of the account
name
Type: System..::.String
The name of the account
screenName
Type: System..::.String
the screen name of the account

Return Value

0 when successful, -1 in case of an error.

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


UpdateClientProjectRestricted Method

[image]

OfficeClip API Documentation
ProjectDB..::.UpdateClientProjectRestricted Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the client and the project restricted list

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateClientProjectRestricted(
    int groupId,
    int userId,
    Hashtable ht
)
Visual Basic (Declaration)
Public Sub UpdateClientProjectRestricted ( _
    groupId As Integer, _
    userId As Integer, _
    ht As Hashtable _
)
Visual C++
public:
void UpdateClientProjectRestricted(
    int groupId,
    int userId,
    Hashtable^ ht
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user
ht
Type: System.Collections..::.Hashtable
The hashtable that contains the project and customer information.

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


UpdateProject Method

[image]

OfficeClip API Documentation
ProjectDB..::.UpdateProject Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the Project related information from the database.

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateProject(
    ProjectInfo pi
)
Visual Basic (Declaration)
Public Function UpdateProject ( _
    pi As ProjectInfo _
) As Integer
Visual C++
public:
int UpdateProject(
    ProjectInfo^ pi
)

Parameters

pi
Type: OfficeClip.BusinessLayer.Projects..::.ProjectInfo
Instance of the ProjectInfo object containing all the information related to the Project. ProjectInfo

Return Value

0 when successful, -1 in case of an error.

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


UpdateUsersRestricted Method

[image]

OfficeClip API Documentation
ProjectDB..::.UpdateUsersRestricted Method
ProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the users restricted list

Namespace: OfficeClip.DBLayer.Projects
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateUsersRestricted(
    int groupId,
    int accountId,
    int projectId,
    Hashtable ht
)
Visual Basic (Declaration)
Public Sub UpdateUsersRestricted ( _
    groupId As Integer, _
    accountId As Integer, _
    projectId As Integer, _
    ht As Hashtable _
)
Visual C++
public:
void UpdateUsersRestricted(
    int groupId,
    int accountId,
    int projectId,
    Hashtable^ ht
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
accountId
Type: System..::.Int32
The unique id of the client
projectId
Type: System..::.Int32
The unique id of the project
ht
Type: System.Collections..::.Hashtable
The hashtable of information to be updated

See Also

ProjectDB Class
OfficeClip.DBLayer.Projects Namespace


OfficeClip.DBLayer.Provider Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Provider Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip Provider. OfficeClip uses the .Net provider architecture for various modules

Classes

 | Class | Description
Public class | PersonalizationDB | Exchanges role information with the database


PersonalizationDB Class

[image]

OfficeClip API Documentation
PersonalizationDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Exchanges role information with the database

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class PersonalizationDB : OfficeClipDB
Visual Basic (Declaration)
Public Class PersonalizationDB _
    Inherits OfficeClipDB
Visual C++
public ref class PersonalizationDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Provider..::.PersonalizationDB

See Also

PersonalizationDB Members
OfficeClip.DBLayer.Provider Namespace


PersonalizationDB Members

[image] [image]

OfficeClip API Documentation
PersonalizationDB Members
PersonalizationDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PersonalizationDB type exposes the following members.

Constructors

 | Name | Description
Public method | PersonalizationDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindStateOrg | Finds the organiation for a particular state
Public method | FindStateUser | Finds the users for a particular state
Public method | GetCountOfState | Gets the total count of the state
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetOrgBlob | Gets the organization blob
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPathIdFromPath | Get the path id from the path
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserBlob | Get the user blob
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetOrgState | Reset the organiation state
Public method | ResetUserState | Resets the user state
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SaveOrgBlob | Save the organiation blob
Public method | SaveUserBlob | Save the user blob
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


PersonalizationDB Constructor

[image] [image]

OfficeClip API Documentation
PersonalizationDB Constructor
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PersonalizationDB()()() | Default constructor
Public method | PersonalizationDB(OfficeClipDB) | Constructor

See Also

PersonalizationDB Class
PersonalizationDB Members
OfficeClip.DBLayer.Provider Namespace


PersonalizationDB Constructor

[image]

OfficeClip API Documentation
PersonalizationDB Constructor
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PersonalizationDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PersonalizationDB()

See Also

PersonalizationDB Class
PersonalizationDB Overload
OfficeClip.DBLayer.Provider Namespace


PersonalizationDB Constructor (OfficeClipDB)

[image]

OfficeClip API Documentation
PersonalizationDB Constructor (OfficeClipDB)
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PersonalizationDB(
    OfficeClipDB odb
)
Visual Basic (Declaration)
Public Sub New ( _
    odb As OfficeClipDB _
)
Visual C++
public:
PersonalizationDB(
    OfficeClipDB^ odb
)

Parameters

odb
Type: OfficeClip.DBLayer..::.OfficeClipDB
The base class

See Also

PersonalizationDB Class
PersonalizationDB Overload
OfficeClip.DBLayer.Provider Namespace


PersonalizationDB Methods

[image] [image]

OfficeClip API Documentation
PersonalizationDB Methods
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

The PersonalizationDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindStateOrg | Finds the organiation for a particular state
Public method | FindStateUser | Finds the users for a particular state
Public method | GetCountOfState | Gets the total count of the state
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetOrgBlob | Gets the organization blob
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPathIdFromPath | Get the path id from the path
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserBlob | Get the user blob
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetOrgState | Reset the organiation state
Public method | ResetUserState | Resets the user state
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SaveOrgBlob | Save the organiation blob
Public method | SaveUserBlob | Save the user blob
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
PersonalizationDB..::.AddOutputParameter Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

PersonalizationDB Class
PersonalizationDB Members
OfficeClip.DBLayer.Provider Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
PersonalizationDB..::.AddParameter Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

PersonalizationDB Class
PersonalizationDB Members
OfficeClip.DBLayer.Provider Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
PersonalizationDB..::.AddParameters Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

PersonalizationDB Class
PersonalizationDB Members
OfficeClip.DBLayer.Provider Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
PersonalizationDB..::.ExecuteNonQuery Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

PersonalizationDB Class
PersonalizationDB Members
OfficeClip.DBLayer.Provider Namespace


FindStateOrg Method

[image]

OfficeClip API Documentation
PersonalizationDB..::.FindStateOrg Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Finds the organiation for a particular state

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet FindStateOrg(
    string path,
    int orgId
)
Visual Basic (Declaration)
Public Function FindStateOrg ( _
    path As String, _
    orgId As Integer _
) As DataSet
Visual C++
public:
DataSet^ FindStateOrg(
    String^ path,
    int orgId
)

Parameters

path
Type: System..::.String
orgId
Type: System..::.Int32

Return Value

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


FindStateUser Method

[image]

OfficeClip API Documentation
PersonalizationDB..::.FindStateUser Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Finds the users for a particular state

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable FindStateUser(
    string path,
    int orgId,
    DateTime inactiveSinceDate,
    string userName
)
Visual Basic (Declaration)
Public Function FindStateUser ( _
    path As String, _
    orgId As Integer, _
    inactiveSinceDate As DateTime, _
    userName As String _
) As DataTable
Visual C++
public:
DataTable^ FindStateUser(
    String^ path,
    int orgId,
    DateTime inactiveSinceDate,
    String^ userName
)

Parameters

path
Type: System..::.String
orgId
Type: System..::.Int32
inactiveSinceDate
Type: System..::.DateTime
userName
Type: System..::.String

Return Value

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


GetCountOfState Method

[image]

OfficeClip API Documentation
PersonalizationDB..::.GetCountOfState Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the total count of the state

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetCountOfState(
    string path,
    int orgId,
    bool isAllUserScope,
    string userName,
    DateTime lastUpdatedServerDate
)
Visual Basic (Declaration)
Public Function GetCountOfState ( _
    path As String, _
    orgId As Integer, _
    isAllUserScope As Boolean, _
    userName As String, _
    lastUpdatedServerDate As DateTime _
) As Integer
Visual C++
public:
int GetCountOfState(
    String^ path,
    int orgId,
    bool isAllUserScope,
    String^ userName,
    DateTime lastUpdatedServerDate
)

Parameters

path
Type: System..::.String
orgId
Type: System..::.Int32
isAllUserScope
Type: System..::.Boolean
userName
Type: System..::.String
lastUpdatedServerDate
Type: System..::.DateTime

Return Value

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


GetOrgBlob Method

[image]

OfficeClip API Documentation
PersonalizationDB..::.GetOrgBlob Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the organization blob

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public byte[] GetOrgBlob(
    WebPartManager webPartManager,
    int orgId,
    int pathId
)
Visual Basic (Declaration)
Public Function GetOrgBlob ( _
    webPartManager As WebPartManager, _
    orgId As Integer, _
    pathId As Integer _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetOrgBlob(
    WebPartManager^ webPartManager,
    int orgId,
    int pathId
)

Parameters

webPartManager
Type: System.Web.UI.WebControls.WebParts..::.WebPartManager
orgId
Type: System..::.Int32
pathId
Type: System..::.Int32

Return Value

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


GetPathIdFromPath Method

[image]

OfficeClip API Documentation
PersonalizationDB..::.GetPathIdFromPath Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the path id from the path

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetPathIdFromPath(
    string path
)
Visual Basic (Declaration)
Public Function GetPathIdFromPath ( _
    path As String _
) As Integer
Visual C++
public:
int GetPathIdFromPath(
    String^ path
)

Parameters

path
Type: System..::.String

Return Value

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


GetUserBlob Method

[image]

OfficeClip API Documentation
PersonalizationDB..::.GetUserBlob Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the user blob

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public byte[] GetUserBlob(
    WebPartManager webPartManager,
    int orgId,
    string userName,
    int pathId
)
Visual Basic (Declaration)
Public Function GetUserBlob ( _
    webPartManager As WebPartManager, _
    orgId As Integer, _
    userName As String, _
    pathId As Integer _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetUserBlob(
    WebPartManager^ webPartManager,
    int orgId,
    String^ userName,
    int pathId
)

Parameters

webPartManager
Type: System.Web.UI.WebControls.WebParts..::.WebPartManager
orgId
Type: System..::.Int32
userName
Type: System..::.String
pathId
Type: System..::.Int32

Return Value

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
PersonalizationDB..::.InitTransaction Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

PersonalizationDB Class
PersonalizationDB Members
OfficeClip.DBLayer.Provider Namespace


ResetOrgState Method

[image]

OfficeClip API Documentation
PersonalizationDB..::.ResetOrgState Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Reset the organiation state

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ResetOrgState(
    int orgId,
    int pathId
)
Visual Basic (Declaration)
Public Function ResetOrgState ( _
    orgId As Integer, _
    pathId As Integer _
) As Integer
Visual C++
public:
int ResetOrgState(
    int orgId,
    int pathId
)

Parameters

orgId
Type: System..::.Int32
pathId
Type: System..::.Int32

Return Value

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


ResetUserState Method

[image]

OfficeClip API Documentation
PersonalizationDB..::.ResetUserState Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Resets the user state

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ResetUserState(
    int orgId,
    string userName,
    DateTime inactiveSinceDate,
    int pathId
)
Visual Basic (Declaration)
Public Function ResetUserState ( _
    orgId As Integer, _
    userName As String, _
    inactiveSinceDate As DateTime, _
    pathId As Integer _
) As Integer
Visual C++
public:
int ResetUserState(
    int orgId,
    String^ userName,
    DateTime inactiveSinceDate,
    int pathId
)

Parameters

orgId
Type: System..::.Int32
userName
Type: System..::.String
inactiveSinceDate
Type: System..::.DateTime
pathId
Type: System..::.Int32

Return Value

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


SaveOrgBlob Method

[image]

OfficeClip API Documentation
PersonalizationDB..::.SaveOrgBlob Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Save the organiation blob

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SaveOrgBlob(
    int orgId,
    byte[] dataBlob,
    int pathId
)
Visual Basic (Declaration)
Public Function SaveOrgBlob ( _
    orgId As Integer, _
    dataBlob As Byte(), _
    pathId As Integer _
) As Integer
Visual C++
public:
int SaveOrgBlob(
    int orgId,
    array<unsigned char>^ dataBlob,
    int pathId
)

Parameters

orgId
Type: System..::.Int32
dataBlob
Type: array<System..::.Byte>[]()[]
pathId
Type: System..::.Int32

Return Value

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


SaveUserBlob Method

[image]

OfficeClip API Documentation
PersonalizationDB..::.SaveUserBlob Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Save the user blob

Namespace: OfficeClip.DBLayer.Provider
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SaveUserBlob(
    int orgId,
    string userName,
    byte[] dataBlob,
    int pathId
)
Visual Basic (Declaration)
Public Function SaveUserBlob ( _
    orgId As Integer, _
    userName As String, _
    dataBlob As Byte(), _
    pathId As Integer _
) As Integer
Visual C++
public:
int SaveUserBlob(
    int orgId,
    String^ userName,
    array<unsigned char>^ dataBlob,
    int pathId
)

Parameters

orgId
Type: System..::.Int32
userName
Type: System..::.String
dataBlob
Type: array<System..::.Byte>[]()[]
pathId
Type: System..::.Int32

Return Value

See Also

PersonalizationDB Class
OfficeClip.DBLayer.Provider Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
PersonalizationDB..::.SetSPCommand Method
PersonalizationDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

PersonalizationDB Class
PersonalizationDB Members
OfficeClip.DBLayer.Provider Namespace


OfficeClip.DBLayer.Reports Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Reports Namespace

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:OfficeClip.DBLayer.Reports]

Classes

 | Class | Description
Public class | RdlReportDB | Class RdlReportDB inherited from OfficeClipDB [DB Object for RDL reports]


RdlReportDB Class

[image]

OfficeClip API Documentation
RdlReportDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class RdlReportDB inherited from OfficeClipDB [DB Object for RDL reports]

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class RdlReportDB : OfficeClipDB
Visual Basic (Declaration)
Public Class RdlReportDB _
    Inherits OfficeClipDB
Visual C++
public ref class RdlReportDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Reports..::.RdlReportDB

See Also

RdlReportDB Members
OfficeClip.DBLayer.Reports Namespace


RdlReportDB Members

[image] [image]

OfficeClip API Documentation
RdlReportDB Members
RdlReportDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RdlReportDB type exposes the following members.

Constructors

 | Name | Description
Public method | RdlReportDB | Initializes a new instance of the RdlReportDB class, Empty constructor

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DecrementRunningCounter | Decrements the Running Counter by 1.
Public method | DeleteRdlReport | Deletes a row from rdlreports table where report id equals the parameter passed.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDynamicFields | Returns list columns dynamically obtained from 1. contacts based on category id and type id 2. issue tracker based on project id
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetProjectClientOnGroup | List of accounts and / or projects in a particular group.
Public method | GetQualifiedScheduledReports | Returns DataSet containing the details of scheduled RDL Report
Public method | GetRdlReport | Returns ReportApplication object, sets GeneralObj object with data from database based on report Id.
Public method | GetRdlReportCountByCategory | Returns information of reports based on supplied groupid and report type id.
Public method | GetRdlReportsDataByCategory | Returns information of reports from rdlreports based on supplied groupid and category id
Public method | GetRdlReportTypes | Returns information of reports based on supplied groupid and report type id.
Public method | GetRdlSchedule | Returns DataRow containing the details of scheduled RDL Report
Public method | GetReportDetails | returns a datarow (contains information stroed in rdlreports table)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertCustomRdlReport | Returns report id after inserting a custom rdlc file's information in rdlreports table. [custom rdlc files are generated out side this environment]
Public method | InsertDefaultRdlReportType | A default report for each type is inserted into rdlreports table and an integer (Report ID) is returned.
Public method | InsertRdlReport | returns an integer (Report ID) obtained after inserting a report row in rdlreports table.
Public method | InsOrUpdRdlSchedule |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRdlReport | A report present in rdlreports table is updated with new information based on reportId.
Public method | UpdateRunningCounter | Updates the Running Counter and assigns it with total value

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


RdlReportDB Constructor

[image]

OfficeClip API Documentation
RdlReportDB Constructor
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the RdlReportDB class, Empty constructor

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public RdlReportDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RdlReportDB()

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


RdlReportDB Methods

[image] [image]

OfficeClip API Documentation
RdlReportDB Methods
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

The RdlReportDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DecrementRunningCounter | Decrements the Running Counter by 1.
Public method | DeleteRdlReport | Deletes a row from rdlreports table where report id equals the parameter passed.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDynamicFields | Returns list columns dynamically obtained from 1. contacts based on category id and type id 2. issue tracker based on project id
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetProjectClientOnGroup | List of accounts and / or projects in a particular group.
Public method | GetQualifiedScheduledReports | Returns DataSet containing the details of scheduled RDL Report
Public method | GetRdlReport | Returns ReportApplication object, sets GeneralObj object with data from database based on report Id.
Public method | GetRdlReportCountByCategory | Returns information of reports based on supplied groupid and report type id.
Public method | GetRdlReportsDataByCategory | Returns information of reports from rdlreports based on supplied groupid and category id
Public method | GetRdlReportTypes | Returns information of reports based on supplied groupid and report type id.
Public method | GetRdlSchedule | Returns DataRow containing the details of scheduled RDL Report
Public method | GetReportDetails | returns a datarow (contains information stroed in rdlreports table)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertCustomRdlReport | Returns report id after inserting a custom rdlc file's information in rdlreports table. [custom rdlc files are generated out side this environment]
Public method | InsertDefaultRdlReportType | A default report for each type is inserted into rdlreports table and an integer (Report ID) is returned.
Public method | InsertRdlReport | returns an integer (Report ID) obtained after inserting a report row in rdlreports table.
Public method | InsOrUpdRdlSchedule |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRdlReport | A report present in rdlreports table is updated with new information based on reportId.
Public method | UpdateRunningCounter | Updates the Running Counter and assigns it with total value

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
RdlReportDB..::.AddOutputParameter Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

RdlReportDB Class
RdlReportDB Members
OfficeClip.DBLayer.Reports Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
RdlReportDB..::.AddParameter Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

RdlReportDB Class
RdlReportDB Members
OfficeClip.DBLayer.Reports Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
RdlReportDB..::.AddParameters Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

RdlReportDB Class
RdlReportDB Members
OfficeClip.DBLayer.Reports Namespace


DecrementRunningCounter Method

[image]

OfficeClip API Documentation
RdlReportDB..::.DecrementRunningCounter Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Decrements the Running Counter by 1.

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DecrementRunningCounter()
Visual Basic (Declaration)
Public Sub DecrementRunningCounter
Visual C++
public:
void DecrementRunningCounter()

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


DeleteRdlReport Method

[image]

OfficeClip API Documentation
RdlReportDB..::.DeleteRdlReport Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a row from rdlreports table where report id equals the parameter passed.

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteRdlReport(
    string reportId
)
Visual Basic (Declaration)
Public Sub DeleteRdlReport ( _
    reportId As String _
)
Visual C++
public:
void DeleteRdlReport(
    String^ reportId
)

Parameters

reportId
Type: System..::.String
report id is passed as parameter

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
RdlReportDB..::.ExecuteNonQuery Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

RdlReportDB Class
RdlReportDB Members
OfficeClip.DBLayer.Reports Namespace


GetDynamicFields Method

[image]

OfficeClip API Documentation
RdlReportDB..::.GetDynamicFields Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns list columns dynamically obtained from 1. contacts based on category id and type id 2. issue tracker based on project id

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetDynamicFields(
    string categoryStr,
    string typeStr,
    int projectId,
    int mid,
    int groupId
)
Visual Basic (Declaration)
Public Function GetDynamicFields ( _
    categoryStr As String, _
    typeStr As String, _
    projectId As Integer, _
    mid As Integer, _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetDynamicFields(
    String^ categoryStr,
    String^ typeStr,
    int projectId,
    int mid,
    int groupId
)

Parameters

categoryStr
Type: System..::.String
report category id
typeStr
Type: System..::.String
report type id
projectId
Type: System..::.Int32
issue tracker project id
mid
Type: System..::.Int32
groupId
Type: System..::.Int32
groupId (unique)

Return Value

Dataset, contains column information along with data type.

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


GetProjectClientOnGroup Method

[image]

OfficeClip API Documentation
RdlReportDB..::.GetProjectClientOnGroup Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

List of accounts and / or projects in a particular group.

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetProjectClientOnGroup(
    int groupId
)
Visual Basic (Declaration)
Public Function GetProjectClientOnGroup ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetProjectClientOnGroup(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
group id in officeclip

Return Value

List of Accounts and / or projects in Dataset

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


GetQualifiedScheduledReports Method

[image]

OfficeClip API Documentation
RdlReportDB..::.GetQualifiedScheduledReports Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns DataSet containing the details of scheduled RDL Report

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetQualifiedScheduledReports()
Visual Basic (Declaration)
Public Function GetQualifiedScheduledReports As DataSet
Visual C++
public:
DataSet^ GetQualifiedScheduledReports()

Return Value

Returns DataSet containins details of scheduled RDL Report

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


GetRdlReport Method

[image]

OfficeClip API Documentation
RdlReportDB..::.GetRdlReport Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns ReportApplication object, sets GeneralObj object with data from database based on report Id.

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReportApplication GetRdlReport(
    string reportId,
    ReportApplication repApplication,
    out GeneralObject edtGenObj
)
Visual Basic (Declaration)
Public Function GetRdlReport ( _
    reportId As String, _
    repApplication As ReportApplication, _
    <OutAttribute> ByRef edtGenObj As GeneralObject _
) As ReportApplication
Visual C++
public:
ReportApplication^ GetRdlReport(
    String^ reportId,
    ReportApplication^ repApplication,
    [OutAttribute] GeneralObject^% edtGenObj
)

Parameters

reportId
Type: System..::.String
Report Id in RdlReports t-sql table
repApplication
Type: OfficeClip.BusinessLayer.Reports..::.ReportApplication
ReportApplication object passed as an argument
edtGenObj
Type: OfficeClip.BusinessLayer.Reports..::.GeneralObject %
GeneralObj object as out object

Return Value

ReportApplication object filled with filter values

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


GetRdlReportCountByCategory Method

[image]

OfficeClip API Documentation
RdlReportDB..::.GetRdlReportCountByCategory Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns information of reports based on supplied groupid and report type id.

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetRdlReportCountByCategory(
    int groupId,
    string categoryId,
    int secondaryId
)
Visual Basic (Declaration)
Public Function GetRdlReportCountByCategory ( _
    groupId As Integer, _
    categoryId As String, _
    secondaryId As Integer _
) As Integer
Visual C++
public:
int GetRdlReportCountByCategory(
    int groupId,
    String^ categoryId,
    int secondaryId
)

Parameters

groupId
Type: System..::.Int32
current session: group id
categoryId
Type: System..::.String
secondaryId
Type: System..::.Int32

Return Value

Report Dataset

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


GetRdlReportsDataByCategory Method

[image]

OfficeClip API Documentation
RdlReportDB..::.GetRdlReportsDataByCategory Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns information of reports from rdlreports based on supplied groupid and category id

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetRdlReportsDataByCategory(
    int groupId,
    string categoryId,
    int secID
)
Visual Basic (Declaration)
Public Function GetRdlReportsDataByCategory ( _
    groupId As Integer, _
    categoryId As String, _
    secID As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetRdlReportsDataByCategory(
    int groupId,
    String^ categoryId,
    int secID
)

Parameters

groupId
Type: System..::.Int32
current session: group id
categoryId
Type: System..::.String
report category id
secID
Type: System..::.Int32

Return Value

Report Dataset

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


GetRdlReportTypes Method

[image]

OfficeClip API Documentation
RdlReportDB..::.GetRdlReportTypes Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns information of reports based on supplied groupid and report type id.

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetRdlReportTypes(
    int groupId,
    string reportTypeId,
    int secondaryId
)
Visual Basic (Declaration)
Public Function GetRdlReportTypes ( _
    groupId As Integer, _
    reportTypeId As String, _
    secondaryId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetRdlReportTypes(
    int groupId,
    String^ reportTypeId,
    int secondaryId
)

Parameters

groupId
Type: System..::.Int32
current session: group id
reportTypeId
Type: System..::.String
unique report type id
secondaryId
Type: System..::.Int32

Return Value

Report Dataset

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


GetRdlSchedule Method

[image]

OfficeClip API Documentation
RdlReportDB..::.GetRdlSchedule Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns DataRow containing the details of scheduled RDL Report

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataRow GetRdlSchedule(
    int report_id
)
Visual Basic (Declaration)
Public Function GetRdlSchedule ( _
    report_id As Integer _
) As DataRow
Visual C++
public:
DataRow^ GetRdlSchedule(
    int report_id
)

Parameters

report_id
Type: System..::.Int32
Report Id in RdlReports t-sql table

Return Value

Returns DataRow containins details of scheduled RDL Report

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


GetReportDetails Method

[image]

OfficeClip API Documentation
RdlReportDB..::.GetReportDetails Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

returns a datarow (contains information stroed in rdlreports table)

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataRow GetReportDetails(
    int reportId
)
Visual Basic (Declaration)
Public Function GetReportDetails ( _
    reportId As Integer _
) As DataRow
Visual C++
public:
DataRow^ GetReportDetails(
    int reportId
)

Parameters

reportId
Type: System..::.Int32
report id in rdlreports t-sql table.

Return Value

datarow with report information

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
RdlReportDB..::.InitTransaction Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

RdlReportDB Class
RdlReportDB Members
OfficeClip.DBLayer.Reports Namespace


InsertCustomRdlReport Method

[image]

OfficeClip API Documentation
RdlReportDB..::.InsertCustomRdlReport Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns report id after inserting a custom rdlc file's information in rdlreports table. [custom rdlc files are generated out side this environment]

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertCustomRdlReport(
    string rdlcLocation,
    GeneralObject generalObject,
    int groupId,
    int userId
)
Visual Basic (Declaration)
Public Function InsertCustomRdlReport ( _
    rdlcLocation As String, _
    generalObject As GeneralObject, _
    groupId As Integer, _
    userId As Integer _
) As Integer
Visual C++
public:
int InsertCustomRdlReport(
    String^ rdlcLocation,
    GeneralObject^ generalObject,
    int groupId,
    int userId
)

Parameters

rdlcLocation
Type: System..::.String
Name of the rdlc file
generalObject
Type: OfficeClip.BusinessLayer.Reports..::.GeneralObject
GeneralObj object
groupId
Type: System..::.Int32
groupId (unique)
userId
Type: System..::.Int32
userId (unique)

Return Value

An integer (report Id)

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


InsertDefaultRdlReportType Method

[image]

OfficeClip API Documentation
RdlReportDB..::.InsertDefaultRdlReportType Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

A default report for each type is inserted into rdlreports table and an integer (Report ID) is returned.

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertDefaultRdlReportType(
    string rdlcLocation,
    GeneralObject generalObject,
    List<ReportFilter> filters,
    int groupId,
    int userId,
    int secondaryId
)
Visual Basic (Declaration)
Public Function InsertDefaultRdlReportType ( _
    rdlcLocation As String, _
    generalObject As GeneralObject, _
    filters As List(Of ReportFilter), _
    groupId As Integer, _
    userId As Integer, _
    secondaryId As Integer _
) As Integer
Visual C++
public:
int InsertDefaultRdlReportType(
    String^ rdlcLocation,
    GeneralObject^ generalObject,
    List<ReportFilter^>^ filters,
    int groupId,
    int userId,
    int secondaryId
)

Parameters

rdlcLocation
Type: System..::.String
Name of the rdlc file
generalObject
Type: OfficeClip.BusinessLayer.Reports..::.GeneralObject
GeneralObj object
filters
Type: System.Collections.Generic..::.List<(Of <( ReportFilter >)>)
List of ReportFilter objects
groupId
Type: System..::.Int32
groupId (unique)
userId
Type: System..::.Int32
userId (unique)
secondaryId
Type: System..::.Int32

Return Value

An integer (report Id)

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


InsertRdlReport Method

[image]

OfficeClip API Documentation
RdlReportDB..::.InsertRdlReport Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

returns an integer (Report ID) obtained after inserting a report row in rdlreports table.

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertRdlReport(
    ReportApplication appObject,
    GeneralObject generalObject,
    string rdlcLocation,
    string valString,
    int groupId,
    int userId,
    int secondaryId
)
Visual Basic (Declaration)
Public Function InsertRdlReport ( _
    appObject As ReportApplication, _
    generalObject As GeneralObject, _
    rdlcLocation As String, _
    valString As String, _
    groupId As Integer, _
    userId As Integer, _
    secondaryId As Integer _
) As Integer
Visual C++
public:
int InsertRdlReport(
    ReportApplication^ appObject,
    GeneralObject^ generalObject,
    String^ rdlcLocation,
    String^ valString,
    int groupId,
    int userId,
    int secondaryId
)

Parameters

appObject
Type: OfficeClip.BusinessLayer.Reports..::.ReportApplication
ReportApplication object
generalObject
Type: OfficeClip.BusinessLayer.Reports..::.GeneralObject
GeneralObj object
rdlcLocation
Type: System..::.String
full path of rdlc file
valString
Type: System..::.String
string containing filter values
groupId
Type: System..::.Int32
groupId (unique)
userId
Type: System..::.Int32
userId (unique)
secondaryId
Type: System..::.Int32

Return Value

An integer (Report ID)

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


InsOrUpdRdlSchedule Method

[image]

OfficeClip API Documentation
RdlReportDB..::.InsOrUpdRdlSchedule Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsOrUpdRdlSchedule(
    int report_id,
    string report_name,
    int totalValue,
    string toAddress,
    string exportFormat,
    int primaryId,
    int secondaryId
)
Visual Basic (Declaration)
Public Sub InsOrUpdRdlSchedule ( _
    report_id As Integer, _
    report_name As String, _
    totalValue As Integer, _
    toAddress As String, _
    exportFormat As String, _
    primaryId As Integer, _
    secondaryId As Integer _
)
Visual C++
public:
void InsOrUpdRdlSchedule(
    int report_id,
    String^ report_name,
    int totalValue,
    String^ toAddress,
    String^ exportFormat,
    int primaryId,
    int secondaryId
)

Parameters

report_id
Type: System..::.Int32
report_name
Type: System..::.String
totalValue
Type: System..::.Int32
toAddress
Type: System..::.String
exportFormat
Type: System..::.String
primaryId
Type: System..::.Int32
secondaryId
Type: System..::.Int32

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
RdlReportDB..::.SetSPCommand Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

RdlReportDB Class
RdlReportDB Members
OfficeClip.DBLayer.Reports Namespace


UpdateRdlReport Method

[image]

OfficeClip API Documentation
RdlReportDB..::.UpdateRdlReport Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

A report present in rdlreports table is updated with new information based on reportId.

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateRdlReport(
    GeneralObject generalObject,
    ReportApplication appObject,
    string valString,
    string reportId,
    int userId
)
Visual Basic (Declaration)
Public Sub UpdateRdlReport ( _
    generalObject As GeneralObject, _
    appObject As ReportApplication, _
    valString As String, _
    reportId As String, _
    userId As Integer _
)
Visual C++
public:
void UpdateRdlReport(
    GeneralObject^ generalObject,
    ReportApplication^ appObject,
    String^ valString,
    String^ reportId,
    int userId
)

Parameters

generalObject
Type: OfficeClip.BusinessLayer.Reports..::.GeneralObject
GeneralObj object
appObject
Type: OfficeClip.BusinessLayer.Reports..::.ReportApplication
ReportApplication object
valString
Type: System..::.String
string of filter values
reportId
Type: System..::.String
report id is passed as parameter
userId
Type: System..::.Int32
userId (unique)

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


UpdateRunningCounter Method

[image]

OfficeClip API Documentation
RdlReportDB..::.UpdateRunningCounter Method
RdlReportDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the Running Counter and assigns it with total value

Namespace: OfficeClip.DBLayer.Reports
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateRunningCounter()
Visual Basic (Declaration)
Public Sub UpdateRunningCounter
Visual C++
public:
void UpdateRunningCounter()

See Also

RdlReportDB Class
OfficeClip.DBLayer.Reports Namespace


OfficeClip.DBLayer.Rules Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Rules Namespace

[This is preliminary documentation and is subject to change.]

[Missing namespace summary documentation for N:OfficeClip.DBLayer.Rules]

Classes

 | Class | Description
Public class | RulesInfoDB | This class provides the database methods for the rulebase


RulesInfoDB Class

[image]

OfficeClip API Documentation
RulesInfoDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class provides the database methods for the rulebase

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class RulesInfoDB : OfficeClipDB
Visual Basic (Declaration)
Public Class RulesInfoDB _
    Inherits OfficeClipDB
Visual C++
public ref class RulesInfoDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Rules..::.RulesInfoDB

See Also

RulesInfoDB Members
OfficeClip.DBLayer.Rules Namespace


RulesInfoDB Members

[image] [image]

OfficeClip API Documentation
RulesInfoDB Members
RulesInfoDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RulesInfoDB type exposes the following members.

Constructors

 | Name | Description
Public method | RulesInfoDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DecrementRunningCounter | Decrements the Running Counter by 1.
Public method | DeleteRule | Deletes the Rule at given ruleId from RuleBase
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllRulesInfoInRuleGroup |
Public method | GetCaseDetails |
Public method | GetCaseEmail |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetIssuesValuesChanged |
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetQualifiedTimeTriggersRules | Gets the Time Based Rules that are qualified for execution.
Public method | GetRuleIds | Gets the RuleId of all the rules matching the userId, groupId, appId, secondaryId
Public method | GetRuleInfoFromTriggerName | Gets the rule info given a trigger name
Public method | GetRulesInfo | Gets the rulebase rules
Public method | GetRunningCounterValue |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertRulesInfo | Inserts a rule and returns ruleId
Public method | InsertTimeTriggerDetails | Inserts the Time Based rule info runningCounter,totalValue into the database with ruleId
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateArchiveIssues |
Public method | UpdateIssuesValues |
Public method | UpdateRules | Updates the rules at a gicen ruleId
Public method | UpdateRunningCounter | Updates the Running Counter and assigns it with total value

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


RulesInfoDB Constructor

[image]

OfficeClip API Documentation
RulesInfoDB Constructor
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public RulesInfoDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RulesInfoDB()

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


RulesInfoDB Methods

[image] [image]

OfficeClip API Documentation
RulesInfoDB Methods
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

The RulesInfoDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DecrementRunningCounter | Decrements the Running Counter by 1.
Public method | DeleteRule | Deletes the Rule at given ruleId from RuleBase
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllRulesInfoInRuleGroup |
Public method | GetCaseDetails |
Public method | GetCaseEmail |
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetIssuesValuesChanged |
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetQualifiedTimeTriggersRules | Gets the Time Based Rules that are qualified for execution.
Public method | GetRuleIds | Gets the RuleId of all the rules matching the userId, groupId, appId, secondaryId
Public method | GetRuleInfoFromTriggerName | Gets the rule info given a trigger name
Public method | GetRulesInfo | Gets the rulebase rules
Public method | GetRunningCounterValue |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertRulesInfo | Inserts a rule and returns ruleId
Public method | InsertTimeTriggerDetails | Inserts the Time Based rule info runningCounter,totalValue into the database with ruleId
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateArchiveIssues |
Public method | UpdateIssuesValues |
Public method | UpdateRules | Updates the rules at a gicen ruleId
Public method | UpdateRunningCounter | Updates the Running Counter and assigns it with total value

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
RulesInfoDB..::.AddOutputParameter Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

RulesInfoDB Class
RulesInfoDB Members
OfficeClip.DBLayer.Rules Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
RulesInfoDB..::.AddParameter Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

RulesInfoDB Class
RulesInfoDB Members
OfficeClip.DBLayer.Rules Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
RulesInfoDB..::.AddParameters Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

RulesInfoDB Class
RulesInfoDB Members
OfficeClip.DBLayer.Rules Namespace


DecrementRunningCounter Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.DecrementRunningCounter Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Decrements the Running Counter by 1.

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DecrementRunningCounter()
Visual Basic (Declaration)
Public Sub DecrementRunningCounter
Visual C++
public:
void DecrementRunningCounter()

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


DeleteRule Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.DeleteRule Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the Rule at given ruleId from RuleBase

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteRule(
    int ruleId
)
Visual Basic (Declaration)
Public Sub DeleteRule ( _
    ruleId As Integer _
)
Visual C++
public:
void DeleteRule(
    int ruleId
)

Parameters

ruleId
Type: System..::.Int32
ruleId of the rule as int

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
RulesInfoDB..::.ExecuteNonQuery Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

RulesInfoDB Class
RulesInfoDB Members
OfficeClip.DBLayer.Rules Namespace


GetAllRulesInfoInRuleGroup Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.GetAllRulesInfoInRuleGroup Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<RulesInfo> GetAllRulesInfoInRuleGroup(
    int userId,
    int groupId,
    int appId,
    string ruleGroupId,
    int secondaryId
)
Visual Basic (Declaration)
Public Function GetAllRulesInfoInRuleGroup ( _
    userId As Integer, _
    groupId As Integer, _
    appId As Integer, _
    ruleGroupId As String, _
    secondaryId As Integer _
) As List(Of RulesInfo)
Visual C++
public:
List<RulesInfo^>^ GetAllRulesInfoInRuleGroup(
    int userId,
    int groupId,
    int appId,
    String^ ruleGroupId,
    int secondaryId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
appId
Type: System..::.Int32
ruleGroupId
Type: System..::.String
secondaryId
Type: System..::.Int32

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


GetCaseDetails Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.GetCaseDetails Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataRow GetCaseDetails(
    int caseId,
    int projectId
)
Visual Basic (Declaration)
Public Function GetCaseDetails ( _
    caseId As Integer, _
    projectId As Integer _
) As DataRow
Visual C++
public:
DataRow^ GetCaseDetails(
    int caseId,
    int projectId
)

Parameters

caseId
Type: System..::.Int32
projectId
Type: System..::.Int32

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


GetCaseEmail Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.GetCaseEmail Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetCaseEmail(
    int userId
)
Visual Basic (Declaration)
Public Function GetCaseEmail ( _
    userId As Integer _
) As String
Visual C++
public:
String^ GetCaseEmail(
    int userId
)

Parameters

userId
Type: System..::.Int32

Return Value

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


GetIssuesValuesChanged Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.GetIssuesValuesChanged Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetIssuesValuesChanged(
    int projectId,
    int trackerFieldNameId,
    string fieldName,
    string fieldValue,
    int periodSinceChanged
)
Visual Basic (Declaration)
Public Function GetIssuesValuesChanged ( _
    projectId As Integer, _
    trackerFieldNameId As Integer, _
    fieldName As String, _
    fieldValue As String, _
    periodSinceChanged As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetIssuesValuesChanged(
    int projectId,
    int trackerFieldNameId,
    String^ fieldName,
    String^ fieldValue,
    int periodSinceChanged
)

Parameters

projectId
Type: System..::.Int32
trackerFieldNameId
Type: System..::.Int32
fieldName
Type: System..::.String
fieldValue
Type: System..::.String
periodSinceChanged
Type: System..::.Int32

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


GetQualifiedTimeTriggersRules Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.GetQualifiedTimeTriggersRules Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Time Based Rules that are qualified for execution.

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<RulesInfo> GetQualifiedTimeTriggersRules()
Visual Basic (Declaration)
Public Function GetQualifiedTimeTriggersRules As List(Of RulesInfo)
Visual C++
public:
List<RulesInfo^>^ GetQualifiedTimeTriggersRules()

Return Value

A BusinessLayer.Rules.RulesInfo List

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


GetRuleIds Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.GetRuleIds Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the RuleId of all the rules matching the userId, groupId, appId, secondaryId

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetRuleIds(
    int userId,
    int groupId,
    int appId,
    int secondaryId,
    string ruleGroupId
)
Visual Basic (Declaration)
Public Function GetRuleIds ( _
    userId As Integer, _
    groupId As Integer, _
    appId As Integer, _
    secondaryId As Integer, _
    ruleGroupId As String _
) As DataTable
Visual C++
public:
DataTable^ GetRuleIds(
    int userId,
    int groupId,
    int appId,
    int secondaryId,
    String^ ruleGroupId
)

Parameters

userId
Type: System..::.Int32
groupId
Type: System..::.Int32
appId
Type: System..::.Int32
secondaryId
Type: System..::.Int32
ruleGroupId
Type: System..::.String

Return Value

returns a System.Data.DataTable with ruleId and ruleGroupId

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


GetRuleInfoFromTriggerName Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.GetRuleInfoFromTriggerName Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the rule info given a trigger name

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<RulesInfo> GetRuleInfoFromTriggerName(
    string triggerName,
    int userId,
    int groupId,
    int appId,
    string ruleGroupId,
    int secondaryId
)
Visual Basic (Declaration)
Public Function GetRuleInfoFromTriggerName ( _
    triggerName As String, _
    userId As Integer, _
    groupId As Integer, _
    appId As Integer, _
    ruleGroupId As String, _
    secondaryId As Integer _
) As List(Of RulesInfo)
Visual C++
public:
List<RulesInfo^>^ GetRuleInfoFromTriggerName(
    String^ triggerName,
    int userId,
    int groupId,
    int appId,
    String^ ruleGroupId,
    int secondaryId
)

Parameters

triggerName
Type: System..::.String
triggerName as string
userId
Type: System..::.Int32
userId as int
groupId
Type: System..::.Int32
groupId as int
appId
Type: System..::.Int32
appId as int
ruleGroupId
Type: System..::.String
ruleGroupId as string
secondaryId
Type: System..::.Int32
secondaryId as int

Return Value

BusinessLayer.Rules.RulesInfo list

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


GetRulesInfo Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.GetRulesInfo Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the rulebase rules

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public RulesInfo GetRulesInfo(
    int userId,
    int groupId,
    int appId,
    int ruleId,
    string ruleGroupId,
    int secondaryId
)
Visual Basic (Declaration)
Public Function GetRulesInfo ( _
    userId As Integer, _
    groupId As Integer, _
    appId As Integer, _
    ruleId As Integer, _
    ruleGroupId As String, _
    secondaryId As Integer _
) As RulesInfo
Visual C++
public:
RulesInfo^ GetRulesInfo(
    int userId,
    int groupId,
    int appId,
    int ruleId,
    String^ ruleGroupId,
    int secondaryId
)

Parameters

userId
Type: System..::.Int32
the userId as int
groupId
Type: System..::.Int32
the groupId as int
appId
Type: System..::.Int32
the appId as int
ruleId
Type: System..::.Int32
the ruleId as int
ruleGroupId
Type: System..::.String
the ruleGroupId as string
secondaryId
Type: System..::.Int32
the secondaryId as int

Return Value

the filled BusinessLayer.Rules.RulesInfo object

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


GetRunningCounterValue Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.GetRunningCounterValue Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetRunningCounterValue(
    int ruleId
)
Visual Basic (Declaration)
Public Function GetRunningCounterValue ( _
    ruleId As Integer _
) As Integer
Visual C++
public:
int GetRunningCounterValue(
    int ruleId
)

Parameters

ruleId
Type: System..::.Int32

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
RulesInfoDB..::.InitTransaction Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

RulesInfoDB Class
RulesInfoDB Members
OfficeClip.DBLayer.Rules Namespace


InsertRulesInfo Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.InsertRulesInfo Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a rule and returns ruleId

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertRulesInfo(
    RulesInfo rulesInfo
)
Visual Basic (Declaration)
Public Function InsertRulesInfo ( _
    rulesInfo As RulesInfo _
) As Integer
Visual C++
public:
int InsertRulesInfo(
    RulesInfo^ rulesInfo
)

Parameters

rulesInfo
Type: OfficeClip.BusinessLayer.Rules..::.RulesInfo
RuleInfo Object

Return Value

ruleId

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


InsertTimeTriggerDetails Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.InsertTimeTriggerDetails Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the Time Based rule info runningCounter,totalValue into the database with ruleId

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertTimeTriggerDetails(
    int ruleId,
    int runningCounter,
    int totalValue
)
Visual Basic (Declaration)
Public Sub InsertTimeTriggerDetails ( _
    ruleId As Integer, _
    runningCounter As Integer, _
    totalValue As Integer _
)
Visual C++
public:
void InsertTimeTriggerDetails(
    int ruleId,
    int runningCounter,
    int totalValue
)

Parameters

ruleId
Type: System..::.Int32
ruleId as int
runningCounter
Type: System..::.Int32
runningCounter as int
totalValue
Type: System..::.Int32
totalValue as int

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
RulesInfoDB..::.SetSPCommand Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

RulesInfoDB Class
RulesInfoDB Members
OfficeClip.DBLayer.Rules Namespace


UpdateArchiveIssues Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.UpdateArchiveIssues Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateArchiveIssues(
    int caseId,
    bool archive
)
Visual Basic (Declaration)
Public Sub UpdateArchiveIssues ( _
    caseId As Integer, _
    archive As Boolean _
)
Visual C++
public:
void UpdateArchiveIssues(
    int caseId,
    bool archive
)

Parameters

caseId
Type: System..::.Int32
archive
Type: System..::.Boolean

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


UpdateIssuesValues Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.UpdateIssuesValues Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateIssuesValues(
    int caseId,
    int trackerFieldNameId,
    int fieldValueId
)
Visual Basic (Declaration)
Public Sub UpdateIssuesValues ( _
    caseId As Integer, _
    trackerFieldNameId As Integer, _
    fieldValueId As Integer _
)
Visual C++
public:
void UpdateIssuesValues(
    int caseId,
    int trackerFieldNameId,
    int fieldValueId
)

Parameters

caseId
Type: System..::.Int32
trackerFieldNameId
Type: System..::.Int32
fieldValueId
Type: System..::.Int32

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


UpdateRules Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.UpdateRules Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the rules at a gicen ruleId

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateRules(
    RulesInfo rulesInfo,
    int ruleId
)
Visual Basic (Declaration)
Public Sub UpdateRules ( _
    rulesInfo As RulesInfo, _
    ruleId As Integer _
)
Visual C++
public:
void UpdateRules(
    RulesInfo^ rulesInfo,
    int ruleId
)

Parameters

rulesInfo
Type: OfficeClip.BusinessLayer.Rules..::.RulesInfo
BusinessLayer.Rules.RulesInfo object
ruleId
Type: System..::.Int32
ruleId as int

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


UpdateRunningCounter Method

[image]

OfficeClip API Documentation
RulesInfoDB..::.UpdateRunningCounter Method
RulesInfoDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the Running Counter and assigns it with total value

Namespace: OfficeClip.DBLayer.Rules
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateRunningCounter()
Visual Basic (Declaration)
Public Sub UpdateRunningCounter
Visual C++
public:
void UpdateRunningCounter()

See Also

RulesInfoDB Class
OfficeClip.DBLayer.Rules Namespace


OfficeClip.DBLayer.Security Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Security Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip object security

Classes

 | Class | Description
Public class | RolesDB | Exchanges role information with the database
Public class | SecurityObjectDB | Exchanges role information with the database


RolesDB Class

[image]

OfficeClip API Documentation
RolesDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Exchanges role information with the database

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class RolesDB : OfficeClipDB
Visual Basic (Declaration)
Public Class RolesDB _
    Inherits OfficeClipDB
Visual C++
public ref class RolesDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Security..::.RolesDB

See Also

RolesDB Members
OfficeClip.DBLayer.Security Namespace


RolesDB Members

[image] [image]

OfficeClip API Documentation
RolesDB Members
RolesDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RolesDB type exposes the following members.

Constructors

 | Name | Description
Public method | RolesDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteRole | Removes a role.
Public method | DeleteRoleApplicationBlock | Deletes all the role application blocks
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccessInfo | Returns the role access array of a particular user of a particular group.
Public method | GetAllRoleBlockedApplications | Gets all the blocked applications for a user
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetRoleApplicationBlocks | Gets all the blocked applications for a role
Public method | GetRoleInfo | Returns an RoleInfo object.
Public method | GetRoles | Returns an array of roleinfo object. An important thing to be noted is that the role_id = -2 is reserved for the role name "Administrator" and the role_id = -3 is reserved for the role name "All Members".
Public method | GetRoleUsers | Gets all the role users for the group
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertRole | Inserts a new role to a particular group.
Public method | InsertRoleApplicationBlock | Insert a role application block
Public method | InsertRoleUser | Inserts a single user into a role.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRole | Updates a role name.
Public method | UpdateRoleAccess | Update the role access parameters in the database
Public method | UpdateRoleUsers | Updates the users associated with the role

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


RolesDB Constructor

[image] [image]

OfficeClip API Documentation
RolesDB Constructor
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | RolesDB()()() | Default constructor
Public method | RolesDB(OfficeClipDB) | Constructor

See Also

RolesDB Class
RolesDB Members
OfficeClip.DBLayer.Security Namespace


RolesDB Constructor

[image]

OfficeClip API Documentation
RolesDB Constructor
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public RolesDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RolesDB()

See Also

RolesDB Class
RolesDB Overload
OfficeClip.DBLayer.Security Namespace


RolesDB Constructor (OfficeClipDB)

[image]

OfficeClip API Documentation
RolesDB Constructor (OfficeClipDB)
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public RolesDB(
    OfficeClipDB odb
)
Visual Basic (Declaration)
Public Sub New ( _
    odb As OfficeClipDB _
)
Visual C++
public:
RolesDB(
    OfficeClipDB^ odb
)

Parameters

odb
Type: OfficeClip.DBLayer..::.OfficeClipDB
The base class

See Also

RolesDB Class
RolesDB Overload
OfficeClip.DBLayer.Security Namespace


RolesDB Methods

[image] [image]

OfficeClip API Documentation
RolesDB Methods
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

The RolesDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteRole | Removes a role.
Public method | DeleteRoleApplicationBlock | Deletes all the role application blocks
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccessInfo | Returns the role access array of a particular user of a particular group.
Public method | GetAllRoleBlockedApplications | Gets all the blocked applications for a user
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetRoleApplicationBlocks | Gets all the blocked applications for a role
Public method | GetRoleInfo | Returns an RoleInfo object.
Public method | GetRoles | Returns an array of roleinfo object. An important thing to be noted is that the role_id = -2 is reserved for the role name "Administrator" and the role_id = -3 is reserved for the role name "All Members".
Public method | GetRoleUsers | Gets all the role users for the group
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertRole | Inserts a new role to a particular group.
Public method | InsertRoleApplicationBlock | Insert a role application block
Public method | InsertRoleUser | Inserts a single user into a role.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRole | Updates a role name.
Public method | UpdateRoleAccess | Update the role access parameters in the database
Public method | UpdateRoleUsers | Updates the users associated with the role

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
RolesDB..::.AddOutputParameter Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

RolesDB Class
RolesDB Members
OfficeClip.DBLayer.Security Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
RolesDB..::.AddParameter Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

RolesDB Class
RolesDB Members
OfficeClip.DBLayer.Security Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
RolesDB..::.AddParameters Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

RolesDB Class
RolesDB Members
OfficeClip.DBLayer.Security Namespace


DeleteRole Method

[image]

OfficeClip API Documentation
RolesDB..::.DeleteRole Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes a role.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue DeleteRole(
    int roleId
)
Visual Basic (Declaration)
Public Function DeleteRole ( _
    roleId As Integer _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue DeleteRole(
    int roleId
)

Parameters

roleId
Type: System..::.Int32
The unique id of the role that needs to be updated

Return Value

Enumerated type return value.

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


DeleteRoleApplicationBlock Method

[image]

OfficeClip API Documentation
RolesDB..::.DeleteRoleApplicationBlock Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all the role application blocks

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteRoleApplicationBlock(
    int roleId,
    int applicationId
)
Visual Basic (Declaration)
Public Sub DeleteRoleApplicationBlock ( _
    roleId As Integer, _
    applicationId As Integer _
)
Visual C++
public:
void DeleteRoleApplicationBlock(
    int roleId,
    int applicationId
)

Parameters

roleId
Type: System..::.Int32
The unique id of the role
applicationId
Type: System..::.Int32
The unique id of the application that is to be unblocked

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
RolesDB..::.ExecuteNonQuery Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

RolesDB Class
RolesDB Members
OfficeClip.DBLayer.Security Namespace


GetAccessInfo Method

[image]

OfficeClip API Documentation
RolesDB..::.GetAccessInfo Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the role access array of a particular user of a particular group.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool[] GetAccessInfo(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetAccessInfo ( _
    userId As Integer, _
    groupId As Integer _
) As Boolean()
Visual C++
public:
array<bool>^ GetAccessInfo(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
the unique id of the group

Return Value

null if there is an error or the user does not belong to this group, the access array otherwise.

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


GetAllRoleBlockedApplications Method

[image]

OfficeClip API Documentation
RolesDB..::.GetAllRoleBlockedApplications Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the blocked applications for a user

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<int> GetAllRoleBlockedApplications(
    int userId
)
Visual Basic (Declaration)
Public Function GetAllRoleBlockedApplications ( _
    userId As Integer _
) As List(Of Integer)
Visual C++
public:
List<int>^ GetAllRoleBlockedApplications(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user

Return Value

The list of all the application ids that are blocked for the user

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


GetRoleApplicationBlocks Method

[image]

OfficeClip API Documentation
RolesDB..::.GetRoleApplicationBlocks Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the blocked applications for a role

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<int> GetRoleApplicationBlocks(
    int roleId
)
Visual Basic (Declaration)
Public Function GetRoleApplicationBlocks ( _
    roleId As Integer _
) As List(Of Integer)
Visual C++
public:
List<int>^ GetRoleApplicationBlocks(
    int roleId
)

Parameters

roleId
Type: System..::.Int32
The unique id of the role

Return Value

The list of all the application ids that are blocked for the role

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


GetRoleInfo Method

[image]

OfficeClip API Documentation
RolesDB..::.GetRoleInfo Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns an RoleInfo object.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public RoleInfo GetRoleInfo(
    int groupId,
    int roleId
)
Visual Basic (Declaration)
Public Function GetRoleInfo ( _
    groupId As Integer, _
    roleId As Integer _
) As RoleInfo
Visual C++
public:
RoleInfo^ GetRoleInfo(
    int groupId,
    int roleId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the current group.
roleId
Type: System..::.Int32
The unique id of the role for which the accesses is required.

Return Value

The RoleInfo object with the access information populated. A null is returned if there is some error

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


GetRoles Method

[image]

OfficeClip API Documentation
RolesDB..::.GetRoles Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns an array of roleinfo object. An important thing to be noted is that the role_id = -2 is reserved for the role name "Administrator" and the role_id = -3 is reserved for the role name "All Members".

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public RoleInfo[] GetRoles(
    int groupId
)
Visual Basic (Declaration)
Public Function GetRoles ( _
    groupId As Integer _
) As RoleInfo()
Visual C++
public:
array<RoleInfo^>^ GetRoles(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group for which the role names are desired.

Return Value

The array list of the RoleInfo object with the roleid and role name populated

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


GetRoleUsers Method

[image]

OfficeClip API Documentation
RolesDB..::.GetRoleUsers Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the role users for the group

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetRoleUsers(
    int groupId
)
Visual Basic (Declaration)
Public Function GetRoleUsers ( _
    groupId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetRoleUsers(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

Return Value

The datatable of all the role users

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
RolesDB..::.InitTransaction Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

RolesDB Class
RolesDB Members
OfficeClip.DBLayer.Security Namespace


InsertRole Method

[image]

OfficeClip API Documentation
RolesDB..::.InsertRole Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new role to a particular group.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertRole(
    int groupId,
    int userId,
    string roleName,
    string description
)
Visual Basic (Declaration)
Public Function InsertRole ( _
    groupId As Integer, _
    userId As Integer, _
    roleName As String, _
    description As String _
) As Integer
Visual C++
public:
int InsertRole(
    int groupId,
    int userId,
    String^ roleName,
    String^ description
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group where the role name is to be inserted
userId
Type: System..::.Int32
The unique id of the current logged in user
roleName
Type: System..::.String
The name of the role
description
Type: System..::.String
The description of the role

Return Value

roleId if successful and -1 if there is an error and -2 if another role with the same name already exists.

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


InsertRoleApplicationBlock Method

[image]

OfficeClip API Documentation
RolesDB..::.InsertRoleApplicationBlock Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Insert a role application block

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertRoleApplicationBlock(
    int roleId,
    int applicationId
)
Visual Basic (Declaration)
Public Sub InsertRoleApplicationBlock ( _
    roleId As Integer, _
    applicationId As Integer _
)
Visual C++
public:
void InsertRoleApplicationBlock(
    int roleId,
    int applicationId
)

Parameters

roleId
Type: System..::.Int32
The unique id of the role
applicationId
Type: System..::.Int32
The unique id of the application that is to be blocked

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


InsertRoleUser Method

[image]

OfficeClip API Documentation
RolesDB..::.InsertRoleUser Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a single user into a role.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue InsertRoleUser(
    int roleId,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function InsertRoleUser ( _
    roleId As Integer, _
    userId As Integer, _
    groupId As Integer _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue InsertRoleUser(
    int roleId,
    int userId,
    int groupId
)

Parameters

roleId
Type: System..::.Int32
The unique id of the role
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the group

Return Value

Enumerated type return value

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
RolesDB..::.SetSPCommand Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

RolesDB Class
RolesDB Members
OfficeClip.DBLayer.Security Namespace


UpdateRole Method

[image]

OfficeClip API Documentation
RolesDB..::.UpdateRole Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates a role name.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue UpdateRole(
    bool isChained,
    int roleId,
    int userId,
    string roleName,
    string description
)
Visual Basic (Declaration)
Public Function UpdateRole ( _
    isChained As Boolean, _
    roleId As Integer, _
    userId As Integer, _
    roleName As String, _
    description As String _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue UpdateRole(
    bool isChained,
    int roleId,
    int userId,
    String^ roleName,
    String^ description
)

Parameters

isChained
Type: System..::.Boolean
Shows if the role is a part of the transaction
roleId
Type: System..::.Int32
The unique id of the role that needs to be updated
userId
Type: System..::.Int32
The unique id of the current logged in user
roleName
Type: System..::.String
The name of the new role
description
Type: System..::.String
The description of the role

Return Value

Enumerated type for the return values.

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


UpdateRoleAccess Method

[image]

OfficeClip API Documentation
RolesDB..::.UpdateRoleAccess Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Update the role access parameters in the database

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue UpdateRoleAccess(
    int groupId,
    int roleId,
    int userId,
    RoleAccess[] ras
)
Visual Basic (Declaration)
Public Function UpdateRoleAccess ( _
    groupId As Integer, _
    roleId As Integer, _
    userId As Integer, _
    ras As RoleAccess() _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue UpdateRoleAccess(
    int groupId,
    int roleId,
    int userId,
    array<RoleAccess^>^ ras
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
roleId
Type: System..::.Int32
The unique id of the role
userId
Type: System..::.Int32
The unique id of the user who is changing the role
ras
Type: array< OfficeClip.BusinessLayer.Security..::.RoleAccess >[]()[]
The array of roleaccess objects

Return Value

Enumerated type that shows the result of the operation

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


UpdateRoleUsers Method

[image]

OfficeClip API Documentation
RolesDB..::.UpdateRoleUsers Method
RolesDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the users associated with the role

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue UpdateRoleUsers(
    int roleId,
    int groupId,
    int[] userIds
)
Visual Basic (Declaration)
Public Function UpdateRoleUsers ( _
    roleId As Integer, _
    groupId As Integer, _
    userIds As Integer() _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue UpdateRoleUsers(
    int roleId,
    int groupId,
    array<int>^ userIds
)

Parameters

roleId
Type: System..::.Int32
The unique id of the role
groupId
Type: System..::.Int32
The unique id of the group
userIds
Type: array<System..::.Int32>[]()[]
The array of integers showing userids

Return Value

Enumerated type return value

See Also

RolesDB Class
OfficeClip.DBLayer.Security Namespace


SecurityObjectDB Class

[image]

OfficeClip API Documentation
SecurityObjectDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Exchanges role information with the database

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class SecurityObjectDB : OfficeClipDB
Visual Basic (Declaration)
Public Class SecurityObjectDB _
    Inherits OfficeClipDB
Visual C++
public ref class SecurityObjectDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Security..::.SecurityObjectDB

See Also

SecurityObjectDB Members
OfficeClip.DBLayer.Security Namespace


SecurityObjectDB Members

[image] [image]

OfficeClip API Documentation
SecurityObjectDB Members
SecurityObjectDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The SecurityObjectDB type exposes the following members.

Constructors

 | Name | Description
Public method | SecurityObjectDB | Overloaded.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | CheckUrlSecurity | Checks the access information for an user in a group for a particular object
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteSecurityInfo | Deletes the security information.
Public method | DemoteUsers | Demote the access for the user, Use the access level as true if you do not want demote an access (e.g. accessRead)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccessInfo | Gets the access information
Protected method | GetAccessInfoHashForObject | Gets the access information
Public method | GetAccessInfoHashForUser | Gets the accessinfo of an object in a hashtable
Public method | GetAccessInfoNew | Gets the access information for an user in a group for a particular object
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetSecurityObjectsDefault | Returns an array of all the security object base entries. A base entry is the default security for an object of a particular type if the security is not defined.
Public method | GetSecurityObjectsForAllUsers | Gets the security object for all the users in a group
Public method | GetSecurityObjectsRaw | Returns an array of the security objects as it is represented in the database.
Public method | GetSecurityObjectsRoles | Gets the security objects defined for the role. This method does not return all the roles, it only return those roles that are present in the system.
Protected method | GetSecurityObjectsRolesBase | Gets the security objects defined for the role. This method does not return all the roles, it only return those roles that are present in the system.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PromoteUsers | Promote the access for the user, Use the access level as false if you do not want promote an access (e.g. accessRead)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Public method | SetPermissionOnDataSet | Overloaded.
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateSecurityInfo | Updates or inserts the security information. If the information is already present in the database it is updated, if not it is inserted.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


SecurityObjectDB Constructor

[image] [image]

OfficeClip API Documentation
SecurityObjectDB Constructor
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | SecurityObjectDB()()() | Default constructor
Public method | SecurityObjectDB(OfficeClipDB) | The copy constructor

See Also

SecurityObjectDB Class
SecurityObjectDB Members
OfficeClip.DBLayer.Security Namespace


SecurityObjectDB Constructor

[image]

OfficeClip API Documentation
SecurityObjectDB Constructor
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObjectDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SecurityObjectDB()

See Also

SecurityObjectDB Class
SecurityObjectDB Overload
OfficeClip.DBLayer.Security Namespace


SecurityObjectDB Constructor (OfficeClipDB)

[image]

OfficeClip API Documentation
SecurityObjectDB Constructor (OfficeClipDB)
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

The copy constructor

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObjectDB(
    OfficeClipDB odb
)
Visual Basic (Declaration)
Public Sub New ( _
    odb As OfficeClipDB _
)
Visual C++
public:
SecurityObjectDB(
    OfficeClipDB^ odb
)

Parameters

odb
Type: OfficeClip.DBLayer..::.OfficeClipDB

See Also

SecurityObjectDB Class
SecurityObjectDB Overload
OfficeClip.DBLayer.Security Namespace


SecurityObjectDB Methods

[image] [image]

OfficeClip API Documentation
SecurityObjectDB Methods
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

The SecurityObjectDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | CheckUrlSecurity | Checks the access information for an user in a group for a particular object
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteSecurityInfo | Deletes the security information.
Public method | DemoteUsers | Demote the access for the user, Use the access level as true if you do not want demote an access (e.g. accessRead)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAccessInfo | Gets the access information
Protected method | GetAccessInfoHashForObject | Gets the access information
Public method | GetAccessInfoHashForUser | Gets the accessinfo of an object in a hashtable
Public method | GetAccessInfoNew | Gets the access information for an user in a group for a particular object
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetSecurityObjectsDefault | Returns an array of all the security object base entries. A base entry is the default security for an object of a particular type if the security is not defined.
Public method | GetSecurityObjectsForAllUsers | Gets the security object for all the users in a group
Public method | GetSecurityObjectsRaw | Returns an array of the security objects as it is represented in the database.
Public method | GetSecurityObjectsRoles | Gets the security objects defined for the role. This method does not return all the roles, it only return those roles that are present in the system.
Protected method | GetSecurityObjectsRolesBase | Gets the security objects defined for the role. This method does not return all the roles, it only return those roles that are present in the system.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PromoteUsers | Promote the access for the user, Use the access level as false if you do not want promote an access (e.g. accessRead)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Public method | SetPermissionOnDataSet | Overloaded.
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateSecurityInfo | Updates or inserts the security information. If the information is already present in the database it is updated, if not it is inserted.

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
SecurityObjectDB..::.AddOutputParameter Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

SecurityObjectDB Class
SecurityObjectDB Members
OfficeClip.DBLayer.Security Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
SecurityObjectDB..::.AddParameter Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

SecurityObjectDB Class
SecurityObjectDB Members
OfficeClip.DBLayer.Security Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
SecurityObjectDB..::.AddParameters Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

SecurityObjectDB Class
SecurityObjectDB Members
OfficeClip.DBLayer.Security Namespace


CheckUrlSecurity Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.CheckUrlSecurity Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks the access information for an user in a group for a particular object

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void CheckUrlSecurity(
    BusinessConstants..::.ObjectType objType,
    ConfigureInfo session,
    int Id,
    int parentId,
    bool isAdminPage
)
Visual Basic (Declaration)
Public Sub CheckUrlSecurity ( _
    objType As BusinessConstants..::.ObjectType, _
    session As ConfigureInfo, _
    Id As Integer, _
    parentId As Integer, _
    isAdminPage As Boolean _
)
Visual C++
public:
void CheckUrlSecurity(
    BusinessConstants..::.ObjectType objType,
    ConfigureInfo^ session,
    int Id,
    int parentId,
    bool isAdminPage
)

Parameters

objType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
session
Type: OfficeClip.Utils..::.ConfigureInfo
Id
Type: System..::.Int32
parentId
Type: System..::.Int32
isAdminPage
Type: System..::.Boolean

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


DeleteSecurityInfo Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.DeleteSecurityInfo Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the security information.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue DeleteSecurityInfo(
    BusinessConstants..::.ObjectType oType,
    int objectId,
    int roleId,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function DeleteSecurityInfo ( _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer, _
    roleId As Integer, _
    userId As Integer, _
    groupId As Integer _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue DeleteSecurityInfo(
    BusinessConstants..::.ObjectType oType,
    int objectId,
    int roleId,
    int userId,
    int groupId
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The type of the object
objectId
Type: System..::.Int32
The unique id of the object, -1 if not available
roleId
Type: System..::.Int32
The role id, -1 if unavailable
userId
Type: System..::.Int32
The unique id for the user, -1 if unavailable
groupId
Type: System..::.Int32
The id of the group where the object belongs, -1 if unavailable

Return Value

The enumerated return value

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


DemoteUsers Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.DemoteUsers Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Demote the access for the user, Use the access level as true if you do not want demote an access (e.g. accessRead)

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DemoteUsers(
    BusinessConstants..::.ObjectType oType,
    int objectId,
    int userId,
    int groupId,
    bool accessRead,
    bool accessWrite,
    bool accessAppend,
    bool accessDelete,
    int currentUserId
)
Visual Basic (Declaration)
Public Sub DemoteUsers ( _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer, _
    userId As Integer, _
    groupId As Integer, _
    accessRead As Boolean, _
    accessWrite As Boolean, _
    accessAppend As Boolean, _
    accessDelete As Boolean, _
    currentUserId As Integer _
)
Visual C++
public:
void DemoteUsers(
    BusinessConstants..::.ObjectType oType,
    int objectId,
    int userId,
    int groupId,
    bool accessRead,
    bool accessWrite,
    bool accessAppend,
    bool accessDelete,
    int currentUserId
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
objectId
Type: System..::.Int32
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
accessRead
Type: System..::.Boolean
accessWrite
Type: System..::.Boolean
accessAppend
Type: System..::.Boolean
accessDelete
Type: System..::.Boolean
currentUserId
Type: System..::.Int32
The unique id of the current user

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
SecurityObjectDB..::.ExecuteNonQuery Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

SecurityObjectDB Class
SecurityObjectDB Members
OfficeClip.DBLayer.Security Namespace


GetAccessInfo Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.GetAccessInfo Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the access information

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObject GetAccessInfo(
    int groupId,
    int userId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)
Visual Basic (Declaration)
Public Function GetAccessInfo ( _
    groupId As Integer, _
    userId As Integer, _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer _
) As SecurityObject
Visual C++
public:
SecurityObject^ GetAccessInfo(
    int groupId,
    int userId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type
objectId
Type: System..::.Int32
The object id

Return Value

The security object for an object for an user for a group

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


GetAccessInfoHashForObject Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.GetAccessInfoHashForObject Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the access information

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected Hashtable GetAccessInfoHashForObject(
    int groupId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)
Visual Basic (Declaration)
Protected Function GetAccessInfoHashForObject ( _
    groupId As Integer, _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer _
) As Hashtable
Visual C++
protected:
Hashtable^ GetAccessInfoHashForObject(
    int groupId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)

Parameters

groupId
Type: System..::.Int32
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
objectId
Type: System..::.Int32

Return Value

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


GetAccessInfoHashForUser Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.GetAccessInfoHashForUser Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the accessinfo of an object in a hashtable

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public Hashtable GetAccessInfoHashForUser(
    int groupId,
    int userId,
    BusinessConstants..::.ObjectType oType
)
Visual Basic (Declaration)
Public Function GetAccessInfoHashForUser ( _
    groupId As Integer, _
    userId As Integer, _
    oType As BusinessConstants..::.ObjectType _
) As Hashtable
Visual C++
public:
Hashtable^ GetAccessInfoHashForUser(
    int groupId,
    int userId,
    BusinessConstants..::.ObjectType oType
)

Parameters

groupId
Type: System..::.Int32
userId
Type: System..::.Int32
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType

Return Value

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


GetAccessInfoNew Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.GetAccessInfoNew Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the access information for an user in a group for a particular object

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObject GetAccessInfoNew(
    int groupId,
    int userId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)
Visual Basic (Declaration)
Public Function GetAccessInfoNew ( _
    groupId As Integer, _
    userId As Integer, _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer _
) As SecurityObject
Visual C++
public:
SecurityObject^ GetAccessInfoNew(
    int groupId,
    int userId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type
objectId
Type: System..::.Int32
The object id

Return Value

The security object for a particular user in a group for an object

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


GetSecurityObjectsDefault Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.GetSecurityObjectsDefault Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns an array of all the security object base entries. A base entry is the default security for an object of a particular type if the security is not defined.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObject[] GetSecurityObjectsDefault(
    int groupId,
    BusinessConstants..::.ObjectType objectTypeId,
    int currentUserId
)
Visual Basic (Declaration)
Public Function GetSecurityObjectsDefault ( _
    groupId As Integer, _
    objectTypeId As BusinessConstants..::.ObjectType, _
    currentUserId As Integer _
) As SecurityObject()
Visual C++
public:
array<SecurityObject^>^ GetSecurityObjectsDefault(
    int groupId,
    BusinessConstants..::.ObjectType objectTypeId,
    int currentUserId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group.
objectTypeId
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The unique id of the object type
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

The array of the security object.

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


GetSecurityObjectsForAllUsers Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.GetSecurityObjectsForAllUsers Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the security object for all the users in a group

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObject[] GetSecurityObjectsForAllUsers(
    int groupId,
    BusinessConstants..::.ObjectType oType,
    int objectId,
    int currentUserId
)
Visual Basic (Declaration)
Public Function GetSecurityObjectsForAllUsers ( _
    groupId As Integer, _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer, _
    currentUserId As Integer _
) As SecurityObject()
Visual C++
public:
array<SecurityObject^>^ GetSecurityObjectsForAllUsers(
    int groupId,
    BusinessConstants..::.ObjectType oType,
    int objectId,
    int currentUserId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The unique id of the object type
objectId
Type: System..::.Int32
The unique id of the object
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

The array of security objects for all users in the group

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


GetSecurityObjectsRaw Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.GetSecurityObjectsRaw Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns an array of the security objects as it is represented in the database.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObject[] GetSecurityObjectsRaw(
    int groupId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)
Visual Basic (Declaration)
Public Function GetSecurityObjectsRaw ( _
    groupId As Integer, _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer _
) As SecurityObject()
Visual C++
public:
array<SecurityObject^>^ GetSecurityObjectsRaw(
    int groupId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group.
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The unique id of the object type
objectId
Type: System..::.Int32
The unique id of the object

Return Value

The array of the security object. A null represents some error.

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


GetSecurityObjectsRoles Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.GetSecurityObjectsRoles Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the security objects defined for the role. This method does not return all the roles, it only return those roles that are present in the system.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObject[] GetSecurityObjectsRoles(
    int groupId,
    int roleId,
    BusinessConstants..::.ObjectType oType,
    int objectId,
    int currentUserId
)
Visual Basic (Declaration)
Public Function GetSecurityObjectsRoles ( _
    groupId As Integer, _
    roleId As Integer, _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer, _
    currentUserId As Integer _
) As SecurityObject()
Visual C++
public:
array<SecurityObject^>^ GetSecurityObjectsRoles(
    int groupId,
    int roleId,
    BusinessConstants..::.ObjectType oType,
    int objectId,
    int currentUserId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group, the value of -1 gets information for all the groups
roleId
Type: System..::.Int32
The unique id of the role
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type
objectId
Type: System..::.Int32
The object id
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

The array of security objects

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


GetSecurityObjectsRolesBase Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.GetSecurityObjectsRolesBase Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the security objects defined for the role. This method does not return all the roles, it only return those roles that are present in the system.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected Hashtable GetSecurityObjectsRolesBase(
    int groupId,
    int roleId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)
Visual Basic (Declaration)
Protected Function GetSecurityObjectsRolesBase ( _
    groupId As Integer, _
    roleId As Integer, _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer _
) As Hashtable
Visual C++
protected:
Hashtable^ GetSecurityObjectsRolesBase(
    int groupId,
    int roleId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group, the value of -1 gets information for all the groups
roleId
Type: System..::.Int32
The unique id of the role
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type
objectId
Type: System..::.Int32
The object id

Return Value

The hashtable of security objects

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
SecurityObjectDB..::.InitTransaction Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

SecurityObjectDB Class
SecurityObjectDB Members
OfficeClip.DBLayer.Security Namespace


PromoteUsers Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.PromoteUsers Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Promote the access for the user, Use the access level as false if you do not want promote an access (e.g. accessRead)

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void PromoteUsers(
    BusinessConstants..::.ObjectType oType,
    int objectId,
    int userId,
    int groupId,
    bool accessRead,
    bool accessWrite,
    bool accessAppend,
    bool accessDelete,
    int currentUserId
)
Visual Basic (Declaration)
Public Sub PromoteUsers ( _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer, _
    userId As Integer, _
    groupId As Integer, _
    accessRead As Boolean, _
    accessWrite As Boolean, _
    accessAppend As Boolean, _
    accessDelete As Boolean, _
    currentUserId As Integer _
)
Visual C++
public:
void PromoteUsers(
    BusinessConstants..::.ObjectType oType,
    int objectId,
    int userId,
    int groupId,
    bool accessRead,
    bool accessWrite,
    bool accessAppend,
    bool accessDelete,
    int currentUserId
)

Parameters

oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
objectId
Type: System..::.Int32
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
accessRead
Type: System..::.Boolean
accessWrite
Type: System..::.Boolean
accessAppend
Type: System..::.Boolean
accessDelete
Type: System..::.Boolean
currentUserId
Type: System..::.Int32
The unique id of the current user

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


SetPermissionOnDataSet Method

[image] [image]

OfficeClip API Documentation
SecurityObjectDB..::.SetPermissionOnDataSet Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | SetPermissionOnDataSet(DataTable%, BusinessConstants..::.ObjectType, String, String, String, GroupSelection, Int32, Int32, Boolean, String, String, String, String) | Sets the permission on the entire dataset.
Public method | SetPermissionOnDataSet(DataTable%, BusinessConstants..::.ObjectType, String, String, String, GroupSelection, ConfigureInfo) | Sets the permission on the entire dataset. It creates four extra column in the dataset.

See Also

SecurityObjectDB Class
SecurityObjectDB Members
OfficeClip.DBLayer.Security Namespace


SetPermissionOnDataSet Method (DataTable, BusinessConstants.ObjectType, String, String, String, GroupSelection, Int32, Int32, Boolean, String, String, String, String)

[image]

OfficeClip API Documentation
SecurityObjectDB..::.SetPermissionOnDataSet Method (DataTable%, BusinessConstants..::.ObjectType, String, String, String, GroupSelection, Int32, Int32, Boolean, String, String, String, String)
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the permission on the entire dataset.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetPermissionOnDataSet(
    ref DataTable dt,
    BusinessConstants..::.ObjectType oType,
    string objectIdColumnName,
    string ownerIdColumnName,
    string groupIdColumnName,
    GroupSelection gsel,
    int currentUserId,
    int currentGroupId,
    bool isAdmin,
    string accessReadColumnName,
    string accessWriteColumnName,
    string accessAppendColumnName,
    string accessDeleteColumnName
)
Visual Basic (Declaration)
Public Sub SetPermissionOnDataSet ( _
    ByRef dt As DataTable, _
    oType As BusinessConstants..::.ObjectType, _
    objectIdColumnName As String, _
    ownerIdColumnName As String, _
    groupIdColumnName As String, _
    gsel As GroupSelection, _
    currentUserId As Integer, _
    currentGroupId As Integer, _
    isAdmin As Boolean, _
    accessReadColumnName As String, _
    accessWriteColumnName As String, _
    accessAppendColumnName As String, _
    accessDeleteColumnName As String _
)
Visual C++
public:
void SetPermissionOnDataSet(
    DataTable^% dt,
    BusinessConstants..::.ObjectType oType,
    String^ objectIdColumnName,
    String^ ownerIdColumnName,
    String^ groupIdColumnName,
    GroupSelection gsel,
    int currentUserId,
    int currentGroupId,
    bool isAdmin,
    String^ accessReadColumnName,
    String^ accessWriteColumnName,
    String^ accessAppendColumnName,
    String^ accessDeleteColumnName
)

Parameters

dt
Type: System.Data..::.DataTable%
The datatable where the permission is to be set
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type id
objectIdColumnName
Type: System..::.String
The column of the object id
ownerIdColumnName
Type: System..::.String
The column of the owner id
groupIdColumnName
Type: System..::.String
The column of the group id
gsel
Type: OfficeClip.Utils..::.GroupSelection
the group selection criteria
currentUserId
Type: System..::.Int32
The unique id of the current user
currentGroupId
Type: System..::.Int32
The unique id of the current group
isAdmin
Type: System..::.Boolean
True if the current user is an administrator
accessReadColumnName
Type: System..::.String
The column name for access read
accessWriteColumnName
Type: System..::.String
The column name for access write
accessAppendColumnName
Type: System..::.String
The column name for access append
accessDeleteColumnName
Type: System..::.String
The column name for access delete

See Also

SecurityObjectDB Class
SetPermissionOnDataSet Overload
OfficeClip.DBLayer.Security Namespace


SetPermissionOnDataSet Method (DataTable, BusinessConstants.ObjectType, String, String, String, GroupSelection, ConfigureInfo)

[image]

OfficeClip API Documentation
SecurityObjectDB..::.SetPermissionOnDataSet Method (DataTable%, BusinessConstants..::.ObjectType, String, String, String, GroupSelection, ConfigureInfo)
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the permission on the entire dataset. It creates four extra column in the dataset.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetPermissionOnDataSet(
    ref DataTable dt,
    BusinessConstants..::.ObjectType oType,
    string objectIdColumnName,
    string ownerIdColumnName,
    string groupIdColumnName,
    GroupSelection gsel,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Sub SetPermissionOnDataSet ( _
    ByRef dt As DataTable, _
    oType As BusinessConstants..::.ObjectType, _
    objectIdColumnName As String, _
    ownerIdColumnName As String, _
    groupIdColumnName As String, _
    gsel As GroupSelection, _
    session As ConfigureInfo _
)
Visual C++
public:
void SetPermissionOnDataSet(
    DataTable^% dt,
    BusinessConstants..::.ObjectType oType,
    String^ objectIdColumnName,
    String^ ownerIdColumnName,
    String^ groupIdColumnName,
    GroupSelection gsel,
    ConfigureInfo^ session
)

Parameters

dt
Type: System.Data..::.DataTable%
The datatable where the permission is to be set
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type id
objectIdColumnName
Type: System..::.String
The column of the object id
ownerIdColumnName
Type: System..::.String
The column of the owner id
groupIdColumnName
Type: System..::.String
The column of the group id
gsel
Type: OfficeClip.Utils..::.GroupSelection
the group selection criteria
session
Type: OfficeClip.Utils..::.ConfigureInfo
the user session

See Also

SecurityObjectDB Class
SetPermissionOnDataSet Overload
OfficeClip.DBLayer.Security Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
SecurityObjectDB..::.SetSPCommand Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

SecurityObjectDB Class
SecurityObjectDB Members
OfficeClip.DBLayer.Security Namespace


UpdateSecurityInfo Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.UpdateSecurityInfo Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates or inserts the security information. If the information is already present in the database it is updated, if not it is inserted.

Namespace: OfficeClip.DBLayer.Security
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DBConstants..::.ReturnValue UpdateSecurityInfo(
    SecurityObject so,
    int currentUserId
)
Visual Basic (Declaration)
Public Function UpdateSecurityInfo ( _
    so As SecurityObject, _
    currentUserId As Integer _
) As DBConstants..::.ReturnValue
Visual C++
public:
DBConstants..::.ReturnValue UpdateSecurityInfo(
    SecurityObject^ so,
    int currentUserId
)

Parameters

so
Type: OfficeClip.BusinessLayer.Security..::.SecurityObject
The security object
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

The enumerated return value

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Security Namespace


OfficeClip.DBLayer.Service Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Service Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip Service.

Classes

 | Class | Description
Public class | ContactDB |
Public class | ContactsDB |
Public class | EventDB |
Public class | General | The general service class
Public class | GroupEventsDB |
Public class | PrivateEventsDB |
Public class | RoleDB |
Public class | SecurityDB |
Public class | SecurityObjectDB |
Public class | SystemDB |
Public class | TaskDB |
Public class | TasksDB |
Public class | TrackerCaseDB | The tracker case db object
Public class | TrackerFieldsDB | Container for the tracker fields service object
Public class | TrackerProjectDB |
Public class | UserDB |
Public class | UsersDB |


ContactDB Class

[image]

OfficeClip API Documentation
ContactDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class ContactDB
Visual Basic (Declaration)
Public Class ContactDB
Visual C++
public ref class ContactDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.ContactDB

See Also

ContactDB Members
OfficeClip.DBLayer.Service Namespace


ContactDB Members

[image] [image]

OfficeClip API Documentation
ContactDB Members
ContactDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The ContactDB type exposes the following members.

Constructors

 | Name | Description
Public method | ContactDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds a new contact in the database that corresponds to this object
Public method | DeleteDb | Deletes the task from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

ContactDB Class
OfficeClip.DBLayer.Service Namespace


ContactDB Constructor

[image]

OfficeClip API Documentation
ContactDB Constructor
ContactDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ContactDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContactDB()

See Also

ContactDB Class
OfficeClip.DBLayer.Service Namespace


ContactDB Methods

[image] [image]

OfficeClip API Documentation
ContactDB Methods
ContactDB Class See Also

[This is preliminary documentation and is subject to change.]

The ContactDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds a new contact in the database that corresponds to this object
Public method | DeleteDb | Deletes the task from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

ContactDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
ContactDB..::.AddNewDb Method
ContactDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a new contact in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus AddNewDb(
    int groupId,
    int userId,
    OCContact occ,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    groupId As Integer, _
    userId As Integer, _
    occ As OCContact, _
    session As ConfigureInfo _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus AddNewDb(
    int groupId,
    int userId,
    OCContact^ occ,
    ConfigureInfo^ session
)

Parameters

groupId
Type: System..::.Int32
The unique id of the organization
userId
Type: System..::.Int32
The unique id of the user
occ
Type: OfficeClip.BusinessLayer.Service..::.OCContact
The OC Contact object
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

Returns success or failure values

See Also

ContactDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
ContactDB..::.DeleteDb Method
ContactDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the task from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask oct
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    pwe As DBConstants..::.ProcessWhichEvent, _
    oct As OCTask _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask^ oct
)

Parameters

pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Shows which tasks in recurring tasks needs to be processed
oct
Type: OfficeClip.BusinessLayer.Service..::.OCTask
The service task object

Return Value

Returns success or failure values

See Also

ContactDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
ContactDB..::.Populate Method
ContactDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(Int32, ConfigureInfo) | Constructor to create an instance from the database
Public method | Populate(String, String) | Constructor to create an instance from the xml file

See Also

ContactDB Class
ContactDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (Int32, ConfigureInfo)

[image]

OfficeClip API Documentation
ContactDB..::.Populate Method (Int32, ConfigureInfo)
ContactDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCContact Populate(
    int contactId,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function Populate ( _
    contactId As Integer, _
    session As ConfigureInfo _
) As OCContact
Visual C++
public:
OCContact^ Populate(
    int contactId,
    ConfigureInfo^ session
)

Parameters

contactId
Type: System..::.Int32
The unique id of the contact
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The OfficeClip task object

See Also

ContactDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
ContactDB..::.Populate Method (String, String)
ContactDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCContact Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCContact
Visual C++
public:
OCContact^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
the path of the schema file

Return Value

The OfficeClip task object

See Also

ContactDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image]

OfficeClip API Documentation
ContactDB..::.UpdateDb Method
ContactDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database from the created object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus UpdateDb(
    int taskId,
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask oct,
    OCServiceImportPolicy policy
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    taskId As Integer, _
    pwe As DBConstants..::.ProcessWhichEvent, _
    oct As OCTask, _
    policy As OCServiceImportPolicy _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus UpdateDb(
    int taskId,
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask^ oct,
    OCServiceImportPolicy policy
)

Parameters

taskId
Type: System..::.Int32
The unique id of the role to be updated
pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Shows which tasks needs to be updated
oct
Type: OfficeClip.BusinessLayer.Service..::.OCTask
The OfficeClip Service Task Object
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
The update policy

Return Value

Returns success or failure values

See Also

ContactDB Class
OfficeClip.DBLayer.Service Namespace


ContactsDB Class

[image]

OfficeClip API Documentation
ContactsDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class ContactsDB
Visual Basic (Declaration)
Public Class ContactsDB
Visual C++
public ref class ContactsDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.ContactsDB

See Also

ContactsDB Members
OfficeClip.DBLayer.Service Namespace


ContactsDB Members

[image] [image]

OfficeClip API Documentation
ContactsDB Members
ContactsDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The ContactsDB type exposes the following members.

Constructors

 | Name | Description
Public method | ContactsDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds a new contact in the database that corresponds to this object
Public method | DeleteDb | Deletes the task from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

ContactsDB Class
OfficeClip.DBLayer.Service Namespace


ContactsDB Constructor

[image]

OfficeClip API Documentation
ContactsDB Constructor
ContactsDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ContactsDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ContactsDB()

See Also

ContactsDB Class
OfficeClip.DBLayer.Service Namespace


ContactsDB Methods

[image] [image]

OfficeClip API Documentation
ContactsDB Methods
ContactsDB Class See Also

[This is preliminary documentation and is subject to change.]

The ContactsDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds a new contact in the database that corresponds to this object
Public method | DeleteDb | Deletes the task from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

ContactsDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
ContactsDB..::.AddNewDb Method
ContactsDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a new contact in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus AddNewDb(
    OCContacts occs,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    occs As OCContacts, _
    session As ConfigureInfo _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus AddNewDb(
    OCContacts^ occs,
    ConfigureInfo^ session
)

Parameters

occs
Type: OfficeClip.BusinessLayer.Service..::.OCContacts
The OC Contacts object
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

Returns success or failure values

See Also

ContactsDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
ContactsDB..::.DeleteDb Method
ContactsDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the task from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask oct
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    pwe As DBConstants..::.ProcessWhichEvent, _
    oct As OCTask _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask^ oct
)

Parameters

pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Shows which tasks in recurring tasks needs to be processed
oct
Type: OfficeClip.BusinessLayer.Service..::.OCTask
The service task object

Return Value

Returns success or failure values

See Also

ContactsDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
ContactsDB..::.Populate Method
ContactsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(ConfigureInfo) | Constructor to create an instance from the database
Public method | Populate(String, String) | Constructor to create an instance from the xml file

See Also

ContactsDB Class
ContactsDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (ConfigureInfo)

[image]

OfficeClip API Documentation
ContactsDB..::.Populate Method (ConfigureInfo)
ContactsDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCContacts Populate(
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function Populate ( _
    session As ConfigureInfo _
) As OCContacts
Visual C++
public:
OCContacts^ Populate(
    ConfigureInfo^ session
)

Parameters

session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The OfficeClip task object

See Also

ContactsDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
ContactsDB..::.Populate Method (String, String)
ContactsDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCContacts Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCContacts
Visual C++
public:
OCContacts^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
the path of the schema file

Return Value

The OfficeClip task object

See Also

ContactsDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image]

OfficeClip API Documentation
ContactsDB..::.UpdateDb Method
ContactsDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database from the created object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus UpdateDb(
    int taskId,
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask oct,
    OCServiceImportPolicy policy
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    taskId As Integer, _
    pwe As DBConstants..::.ProcessWhichEvent, _
    oct As OCTask, _
    policy As OCServiceImportPolicy _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus UpdateDb(
    int taskId,
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask^ oct,
    OCServiceImportPolicy policy
)

Parameters

taskId
Type: System..::.Int32
The unique id of the role to be updated
pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Shows which tasks needs to be updated
oct
Type: OfficeClip.BusinessLayer.Service..::.OCTask
The OfficeClip Service Task Object
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
The update policy

Return Value

Returns success or failure values

See Also

ContactsDB Class
OfficeClip.DBLayer.Service Namespace


EventDB Class

[image]

OfficeClip API Documentation
EventDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class EventDB : OfficeClipDB
Visual Basic (Declaration)
Public Class EventDB _
    Inherits OfficeClipDB
Visual C++
public ref class EventDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Service..::.EventDB

See Also

EventDB Members
OfficeClip.DBLayer.Service Namespace


EventDB Members

[image] [image]

OfficeClip API Documentation
EventDB Members
EventDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The EventDB type exposes the following members.

Constructors

 | Name | Description
Public method | EventDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds a new event in the database that corresponds to this object
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteDb | Deletes the event from the database
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

EventDB Class
OfficeClip.DBLayer.Service Namespace


EventDB Constructor

[image]

OfficeClip API Documentation
EventDB Constructor
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public EventDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EventDB()

See Also

EventDB Class
OfficeClip.DBLayer.Service Namespace


EventDB Methods

[image] [image]

OfficeClip API Documentation
EventDB Methods
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

The EventDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds a new event in the database that corresponds to this object
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteDb | Deletes the event from the database
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

EventDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
EventDB..::.AddNewDb Method
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a new event in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap AddNewDb(
    OCEvent oce,
    int groupId,
    int userId,
    TimeZoneInfo userTz
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    oce As OCEvent, _
    groupId As Integer, _
    userId As Integer, _
    userTz As TimeZoneInfo _
) As OCMap
Visual C++
public:
OCMap^ AddNewDb(
    OCEvent^ oce,
    int groupId,
    int userId,
    TimeZoneInfo^ userTz
)

Parameters

oce
Type: OfficeClip.BusinessLayer.Service..::.OCEvent
The role to be added to the database
groupId
Type: System..::.Int32
The unique id of the organization
userId
Type: System..::.Int32
The unique id of the user
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone

Return Value

The OfficeClip Map object

See Also

EventDB Class
OfficeClip.DBLayer.Service Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
EventDB..::.AddOutputParameter Method
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

EventDB Class
EventDB Members
OfficeClip.DBLayer.Service Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
EventDB..::.AddParameter Method
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

EventDB Class
EventDB Members
OfficeClip.DBLayer.Service Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
EventDB..::.AddParameters Method
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

EventDB Class
EventDB Members
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
EventDB..::.DeleteDb Method
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the event from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCEvent oce,
    int userId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    pwe As DBConstants..::.ProcessWhichEvent, _
    oce As OCEvent, _
    userId As Integer, _
    isAdmin As Boolean _
) As OCMap
Visual C++
public:
OCMap^ DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCEvent^ oce,
    int userId,
    bool isAdmin
)

Parameters

pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Shows which events in recurring tasks needs to be processed
oce
Type: OfficeClip.BusinessLayer.Service..::.OCEvent
The service event object
userId
Type: System..::.Int32
The unique id of the user
isAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Returns success or failure values

See Also

EventDB Class
OfficeClip.DBLayer.Service Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
EventDB..::.ExecuteNonQuery Method
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

EventDB Class
EventDB Members
OfficeClip.DBLayer.Service Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
EventDB..::.InitTransaction Method
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

EventDB Class
EventDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
EventDB..::.Populate Method
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(String, String) | Constructor to create an instance from the xml file
Public method | Populate(Int32, TimeZoneInfo, Int32) | Constructor to create an instance from the database

See Also

EventDB Class
EventDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
EventDB..::.Populate Method (String, String)
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCEvent Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCEvent
Visual C++
public:
OCEvent^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
the path of the xml schema

Return Value

The OfficeClip event structure

See Also

EventDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (Int32, TimeZoneInfo, Int32)

[image]

OfficeClip API Documentation
EventDB..::.Populate Method (Int32, TimeZoneInfo, Int32)
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCEvent Populate(
    int eventId,
    TimeZoneInfo userTz,
    int userId
)
Visual Basic (Declaration)
Public Function Populate ( _
    eventId As Integer, _
    userTz As TimeZoneInfo, _
    userId As Integer _
) As OCEvent
Visual C++
public:
OCEvent^ Populate(
    int eventId,
    TimeZoneInfo^ userTz,
    int userId
)

Parameters

eventId
Type: System..::.Int32
The unique id of the event
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone
userId
Type: System..::.Int32
The unique id of the user

See Also

EventDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
EventDB..::.SetSPCommand Method
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

EventDB Class
EventDB Members
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image]

OfficeClip API Documentation
EventDB..::.UpdateDb Method
EventDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database from the created object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap UpdateDb(
    int eventId,
    DBConstants..::.ProcessWhichEvent pwe,
    OCEvent oce,
    OCServiceImportPolicy policy,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    eventId As Integer, _
    pwe As DBConstants..::.ProcessWhichEvent, _
    oce As OCEvent, _
    policy As OCServiceImportPolicy, _
    session As ConfigureInfo _
) As OCMap
Visual C++
public:
OCMap^ UpdateDb(
    int eventId,
    DBConstants..::.ProcessWhichEvent pwe,
    OCEvent^ oce,
    OCServiceImportPolicy policy,
    ConfigureInfo^ session
)

Parameters

eventId
Type: System..::.Int32
The unique id of the event to be updated
pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Determines which event type to be updated
oce
Type: OfficeClip.BusinessLayer.Service..::.OCEvent
The OfficeClip Service Task Object
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
The update policy
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

Returns success or failure values

See Also

EventDB Class
OfficeClip.DBLayer.Service Namespace


General Class

[image]

OfficeClip API Documentation
General Class
Members See Also

[This is preliminary documentation and is subject to change.]

The general service class

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class General
Visual Basic (Declaration)
Public Class General
Visual C++
public ref class General

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.General

See Also

General Members
OfficeClip.DBLayer.Service Namespace


General Members

[image] [image]

OfficeClip API Documentation
General Members
General Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The General type exposes the following members.

Constructors

 | Name | Description
Public method | General |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateSid | Validates the Service Id of the object

See Also

General Class
OfficeClip.DBLayer.Service Namespace


General Constructor

[image]

OfficeClip API Documentation
General Constructor
General Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public General()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
General()

See Also

General Class
OfficeClip.DBLayer.Service Namespace


General Methods

[image] [image]

OfficeClip API Documentation
General Methods
General Class See Also

[This is preliminary documentation and is subject to change.]

The General type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateSid | Validates the Service Id of the object

See Also

General Class
OfficeClip.DBLayer.Service Namespace


ValidateSid Method

[image]

OfficeClip API Documentation
General..::.ValidateSid Method
General Class See Also

[This is preliminary documentation and is subject to change.]

Validates the Service Id of the object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public static OCServiceReturnStatus ValidateSid(
    int inputId,
    OCService o,
    OCServiceType ost,
    int groupId
)
Visual Basic (Declaration)
Public Shared Function ValidateSid ( _
    inputId As Integer, _
    o As OCService, _
    ost As OCServiceType, _
    groupId As Integer _
) As OCServiceReturnStatus
Visual C++
public:
static OCServiceReturnStatus ValidateSid(
    int inputId,
    OCService^ o,
    OCServiceType ost,
    int groupId
)

Parameters

inputId
Type: System..::.Int32
The primary id
o
Type: OfficeClip.BusinessLayer.Service..::.OCService
The object whose service id has to be validated
ost
Type: OfficeClip.Utils..::.OCServiceType
The service type for which the request is to be validated
groupId
Type: System..::.Int32
The unique id of the organization

Return Value

A negative integer corresponding to the error or a positing integer corresponding to the primary id of the object. 0 if successful

See Also

General Class
OfficeClip.DBLayer.Service Namespace


GroupEventsDB Class

[image]

OfficeClip API Documentation
GroupEventsDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class GroupEventsDB
Visual Basic (Declaration)
Public Class GroupEventsDB
Visual C++
public ref class GroupEventsDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.GroupEventsDB

See Also

GroupEventsDB Members
OfficeClip.DBLayer.Service Namespace


GroupEventsDB Members

[image] [image]

OfficeClip API Documentation
GroupEventsDB Members
GroupEventsDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The GroupEventsDB type exposes the following members.

Constructors

 | Name | Description
Public method | GroupEventsDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds new events in the database that corresponds to this object
Public method | DeleteDb | Deletes the tasks from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | Gets the event pertaining to the changes
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSignature |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Overloaded.

See Also

GroupEventsDB Class
OfficeClip.DBLayer.Service Namespace


GroupEventsDB Constructor

[image]

OfficeClip API Documentation
GroupEventsDB Constructor
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GroupEventsDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GroupEventsDB()

See Also

GroupEventsDB Class
OfficeClip.DBLayer.Service Namespace


GroupEventsDB Methods

[image] [image]

OfficeClip API Documentation
GroupEventsDB Methods
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

The GroupEventsDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds new events in the database that corresponds to this object
Public method | DeleteDb | Deletes the tasks from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | Gets the event pertaining to the changes
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSignature |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Overloaded.

See Also

GroupEventsDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
GroupEventsDB..::.AddNewDb Method
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds new events in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus AddNewDb(
    OCGroupEvents ocge,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    ocge As OCGroupEvents, _
    session As ConfigureInfo _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus AddNewDb(
    OCGroupEvents^ ocge,
    ConfigureInfo^ session
)

Parameters

ocge
Type: OfficeClip.BusinessLayer.Service..::.OCGroupEvents
The OfficeClip group event object
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

Returns success or failure values

See Also

GroupEventsDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
GroupEventsDB..::.DeleteDb Method
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the tasks from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCGroupEvents ocge,
    int userId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    pwe As DBConstants..::.ProcessWhichEvent, _
    ocge As OCGroupEvents, _
    userId As Integer, _
    isAdmin As Boolean _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCGroupEvents^ ocge,
    int userId,
    bool isAdmin
)

Parameters

pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Shows which tasks in recurring tasks needs to be processed
ocge
Type: OfficeClip.BusinessLayer.Service..::.OCGroupEvents
The OfficeClip group event object
userId
Type: System..::.Int32
The unique id of the user
isAdmin
Type: System..::.Boolean
is the user an administrator

Return Value

Returns success or failure values

See Also

GroupEventsDB Class
OfficeClip.DBLayer.Service Namespace


GetChanges Method

[image]

OfficeClip API Documentation
GroupEventsDB..::.GetChanges Method
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the event pertaining to the changes

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCEvent[] GetChanges(
    string folderId,
    string[] changes,
    TimeZoneInfo userTz,
    int userId
)
Visual Basic (Declaration)
Public Function GetChanges ( _
    folderId As String, _
    changes As String(), _
    userTz As TimeZoneInfo, _
    userId As Integer _
) As OCEvent()
Visual C++
public:
array<OCEvent^>^ GetChanges(
    String^ folderId,
    array<String^>^ changes,
    TimeZoneInfo^ userTz,
    int userId
)

Parameters

folderId
Type: System..::.String
The unique id of the floder
changes
Type: array<System..::.String>[]()[]
The string array of changes
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user time zone
userId
Type: System..::.Int32
unique id of the user

Return Value

The array of OfficeClip events

See Also

GroupEventsDB Class
OfficeClip.DBLayer.Service Namespace


GetSignature Method

[image]

OfficeClip API Documentation
GroupEventsDB..::.GetSignature Method
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCService[] GetSignature(
    string sid,
    TimeZoneInfo userTz,
    TimeZoneInfo serverTz,
    int userId
)
Visual Basic (Declaration)
Public Function GetSignature ( _
    sid As String, _
    userTz As TimeZoneInfo, _
    serverTz As TimeZoneInfo, _
    userId As Integer _
) As OCService()
Visual C++
public:
array<OCService^>^ GetSignature(
    String^ sid,
    TimeZoneInfo^ userTz,
    TimeZoneInfo^ serverTz,
    int userId
)

Parameters

sid
Type: System..::.String
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user time zone
serverTz
Type: OfficeClip.Utils..::.TimeZoneInfo
the server timezone
userId
Type: System..::.Int32
unique id of the user

Return Value

See Also

GroupEventsDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
GroupEventsDB..::.Populate Method
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(String, String) | Constructor to create an instance from the xml file
Public method | Populate(Int32, Int32, TimeZoneInfo, TimeZoneInfo) | Constructor to create an instance from the database

See Also

GroupEventsDB Class
GroupEventsDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
GroupEventsDB..::.Populate Method (String, String)
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCGroupEvents Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCGroupEvents
Visual C++
public:
OCGroupEvents^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
The path of the xml schema

See Also

GroupEventsDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (Int32, Int32, TimeZoneInfo, TimeZoneInfo)

[image]

OfficeClip API Documentation
GroupEventsDB..::.Populate Method (Int32, Int32, TimeZoneInfo, TimeZoneInfo)
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCGroupEvents Populate(
    int groupId,
    int userId,
    TimeZoneInfo userTz,
    TimeZoneInfo serverTz
)
Visual Basic (Declaration)
Public Function Populate ( _
    groupId As Integer, _
    userId As Integer, _
    userTz As TimeZoneInfo, _
    serverTz As TimeZoneInfo _
) As OCGroupEvents
Visual C++
public:
OCGroupEvents^ Populate(
    int groupId,
    int userId,
    TimeZoneInfo^ userTz,
    TimeZoneInfo^ serverTz
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone
serverTz
Type: OfficeClip.Utils..::.TimeZoneInfo
the server timezone

Return Value

The OfficeClip group events object

See Also

GroupEventsDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image] [image]

OfficeClip API Documentation
GroupEventsDB..::.UpdateDb Method
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | UpdateDb(OCGroupEvents, ConfigureInfo) | Updates the group event
Public method | UpdateDb(DBConstants..::.ProcessWhichEvent, OCGroupEvents, OCServiceImportPolicy, ConfigureInfo) | Updates the database from the created object

See Also

GroupEventsDB Class
GroupEventsDB Members
OfficeClip.DBLayer.Service Namespace


UpdateDb Method (OCGroupEvents, ConfigureInfo)

[image]

OfficeClip API Documentation
GroupEventsDB..::.UpdateDb Method (OCGroupEvents, ConfigureInfo)
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the group event

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus UpdateDb(
    OCGroupEvents ocge,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    ocge As OCGroupEvents, _
    session As ConfigureInfo _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus UpdateDb(
    OCGroupEvents^ ocge,
    ConfigureInfo^ session
)

Parameters

ocge
Type: OfficeClip.BusinessLayer.Service..::.OCGroupEvents
The OfficeClip group event object
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The return status of the update

See Also

GroupEventsDB Class
UpdateDb Overload
OfficeClip.DBLayer.Service Namespace


UpdateDb Method (DBConstants.ProcessWhichEvent, OCGroupEvents, OCServiceImportPolicy, ConfigureInfo)

[image]

OfficeClip API Documentation
GroupEventsDB..::.UpdateDb Method (DBConstants..::.ProcessWhichEvent, OCGroupEvents, OCServiceImportPolicy, ConfigureInfo)
GroupEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database from the created object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus UpdateDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCGroupEvents ocge,
    OCServiceImportPolicy policy,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    pwe As DBConstants..::.ProcessWhichEvent, _
    ocge As OCGroupEvents, _
    policy As OCServiceImportPolicy, _
    session As ConfigureInfo _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus UpdateDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCGroupEvents^ ocge,
    OCServiceImportPolicy policy,
    ConfigureInfo^ session
)

Parameters

pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Shows which event needs to be updated
ocge
Type: OfficeClip.BusinessLayer.Service..::.OCGroupEvents
The OfficeClip Group event object
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
The policy for the import
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

Returns success or failure values

See Also

GroupEventsDB Class
UpdateDb Overload
OfficeClip.DBLayer.Service Namespace


PrivateEventsDB Class

[image]

OfficeClip API Documentation
PrivateEventsDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class PrivateEventsDB
Visual Basic (Declaration)
Public Class PrivateEventsDB
Visual C++
public ref class PrivateEventsDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.PrivateEventsDB

See Also

PrivateEventsDB Members
OfficeClip.DBLayer.Service Namespace


PrivateEventsDB Members

[image] [image]

OfficeClip API Documentation
PrivateEventsDB Members
PrivateEventsDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The PrivateEventsDB type exposes the following members.

Constructors

 | Name | Description
Public method | PrivateEventsDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds new events in the database that corresponds to this object
Public method | DeleteDb | Deletes the tasks from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | Gets the changes related to the private event
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSignature | Gets the signature related to the private events
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | SetChanges | Sets the changes for the private event in the database
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Overloaded.

See Also

PrivateEventsDB Class
OfficeClip.DBLayer.Service Namespace


PrivateEventsDB Constructor

[image]

OfficeClip API Documentation
PrivateEventsDB Constructor
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PrivateEventsDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PrivateEventsDB()

See Also

PrivateEventsDB Class
OfficeClip.DBLayer.Service Namespace


PrivateEventsDB Methods

[image] [image]

OfficeClip API Documentation
PrivateEventsDB Methods
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

The PrivateEventsDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds new events in the database that corresponds to this object
Public method | DeleteDb | Deletes the tasks from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChanges | Gets the changes related to the private event
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSignature | Gets the signature related to the private events
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | SetChanges | Sets the changes for the private event in the database
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Overloaded.

See Also

PrivateEventsDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
PrivateEventsDB..::.AddNewDb Method
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds new events in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap[] AddNewDb(
    int groupId,
    int userId,
    OCPrivateEvents ocge,
    TimeZoneInfo userTz
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    groupId As Integer, _
    userId As Integer, _
    ocge As OCPrivateEvents, _
    userTz As TimeZoneInfo _
) As OCMap()
Visual C++
public:
array<OCMap^>^ AddNewDb(
    int groupId,
    int userId,
    OCPrivateEvents^ ocge,
    TimeZoneInfo^ userTz
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user
ocge
Type: OfficeClip.BusinessLayer.Service..::.OCPrivateEvents
The OfficeClip private event object
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user time zone

Return Value

The array of the OfficeClip map object

See Also

PrivateEventsDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
PrivateEventsDB..::.DeleteDb Method
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the tasks from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap[] DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCPrivateEvents ocge,
    int userId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    pwe As DBConstants..::.ProcessWhichEvent, _
    ocge As OCPrivateEvents, _
    userId As Integer, _
    isAdmin As Boolean _
) As OCMap()
Visual C++
public:
array<OCMap^>^ DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCPrivateEvents^ ocge,
    int userId,
    bool isAdmin
)

Parameters

pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Shows which tasks in recurring tasks needs to be processed
ocge
Type: OfficeClip.BusinessLayer.Service..::.OCPrivateEvents
The OfficeClip private event object
userId
Type: System..::.Int32
The unique id of the user
isAdmin
Type: System..::.Boolean
Is the user an administrator

Return Value

The array of the OfficeClip map object

See Also

PrivateEventsDB Class
OfficeClip.DBLayer.Service Namespace


GetChanges Method

[image]

OfficeClip API Documentation
PrivateEventsDB..::.GetChanges Method
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the changes related to the private event

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCEvent[] GetChanges(
    string folderId,
    string[] changes,
    TimeZoneInfo userTz,
    int userId
)
Visual Basic (Declaration)
Public Function GetChanges ( _
    folderId As String, _
    changes As String(), _
    userTz As TimeZoneInfo, _
    userId As Integer _
) As OCEvent()
Visual C++
public:
array<OCEvent^>^ GetChanges(
    String^ folderId,
    array<String^>^ changes,
    TimeZoneInfo^ userTz,
    int userId
)

Parameters

folderId
Type: System..::.String
The unique id of the folder
changes
Type: array<System..::.String>[]()[]
The array of changes
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
the user timezone object
userId
Type: System..::.Int32
Unique id of the user

Return Value

The private event array

See Also

PrivateEventsDB Class
OfficeClip.DBLayer.Service Namespace


GetSignature Method

[image]

OfficeClip API Documentation
PrivateEventsDB..::.GetSignature Method
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the signature related to the private events

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCService[] GetSignature(
    string sid,
    TimeZoneInfo userTz,
    TimeZoneInfo serverTz,
    int userId
)
Visual Basic (Declaration)
Public Function GetSignature ( _
    sid As String, _
    userTz As TimeZoneInfo, _
    serverTz As TimeZoneInfo, _
    userId As Integer _
) As OCService()
Visual C++
public:
array<OCService^>^ GetSignature(
    String^ sid,
    TimeZoneInfo^ userTz,
    TimeZoneInfo^ serverTz,
    int userId
)

Parameters

sid
Type: System..::.String
The service id
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone
serverTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The server timezone
userId
Type: System..::.Int32
The unique id of the user

Return Value

The array of the service object that contains the signature

See Also

PrivateEventsDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
PrivateEventsDB..::.Populate Method
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(String, String) | Constructor to create an instance from the xml file
Public method | Populate(Int32, Int32, TimeZoneInfo, TimeZoneInfo) | Constructor to create an instance from the database

See Also

PrivateEventsDB Class
PrivateEventsDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
PrivateEventsDB..::.Populate Method (String, String)
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCPrivateEvents Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCPrivateEvents
Visual C++
public:
OCPrivateEvents^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
The location of the schema

Return Value

The OfficeClip private events

See Also

PrivateEventsDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (Int32, Int32, TimeZoneInfo, TimeZoneInfo)

[image]

OfficeClip API Documentation
PrivateEventsDB..::.Populate Method (Int32, Int32, TimeZoneInfo, TimeZoneInfo)
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCPrivateEvents Populate(
    int groupId,
    int userId,
    TimeZoneInfo userTz,
    TimeZoneInfo serverTz
)
Visual Basic (Declaration)
Public Function Populate ( _
    groupId As Integer, _
    userId As Integer, _
    userTz As TimeZoneInfo, _
    serverTz As TimeZoneInfo _
) As OCPrivateEvents
Visual C++
public:
OCPrivateEvents^ Populate(
    int groupId,
    int userId,
    TimeZoneInfo^ userTz,
    TimeZoneInfo^ serverTz
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
the unique id of the user
userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone
serverTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The server timezone

Return Value

The OfficeClip private events object

See Also

PrivateEventsDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


SetChanges Method

[image]

OfficeClip API Documentation
PrivateEventsDB..::.SetChanges Method
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the changes for the private event in the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap[] SetChanges(
    string folderId,
    OCEvent[] changes,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function SetChanges ( _
    folderId As String, _
    changes As OCEvent(), _
    session As ConfigureInfo _
) As OCMap()
Visual C++
public:
array<OCMap^>^ SetChanges(
    String^ folderId,
    array<OCEvent^>^ changes,
    ConfigureInfo^ session
)

Parameters

folderId
Type: System..::.String
the unique id of the folder
changes
Type: array< OfficeClip.BusinessLayer.Service..::.OCEvent >[]()[]
The array of changes
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The array of the map object

See Also

PrivateEventsDB Class
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image] [image]

OfficeClip API Documentation
PrivateEventsDB..::.UpdateDb Method
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | UpdateDb(OCPrivateEvents, ConfigureInfo) | Updates the private events
Public method | UpdateDb(DBConstants..::.ProcessWhichEvent, OCPrivateEvents, OCServiceImportPolicy, ConfigureInfo) | Updates the database from the created object

See Also

PrivateEventsDB Class
PrivateEventsDB Members
OfficeClip.DBLayer.Service Namespace


UpdateDb Method (OCPrivateEvents, ConfigureInfo)

[image]

OfficeClip API Documentation
PrivateEventsDB..::.UpdateDb Method (OCPrivateEvents, ConfigureInfo)
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the private events

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap[] UpdateDb(
    OCPrivateEvents ocge,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    ocge As OCPrivateEvents, _
    session As ConfigureInfo _
) As OCMap()
Visual C++
public:
array<OCMap^>^ UpdateDb(
    OCPrivateEvents^ ocge,
    ConfigureInfo^ session
)

Parameters

ocge
Type: OfficeClip.BusinessLayer.Service..::.OCPrivateEvents
The OfficeClip private events object
session
Type: OfficeClip.Utils..::.ConfigureInfo
the user session

Return Value

The array of OfficeClip map object

See Also

PrivateEventsDB Class
UpdateDb Overload
OfficeClip.DBLayer.Service Namespace


UpdateDb Method (DBConstants.ProcessWhichEvent, OCPrivateEvents, OCServiceImportPolicy, ConfigureInfo)

[image]

OfficeClip API Documentation
PrivateEventsDB..::.UpdateDb Method (DBConstants..::.ProcessWhichEvent, OCPrivateEvents, OCServiceImportPolicy, ConfigureInfo)
PrivateEventsDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database from the created object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap[] UpdateDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCPrivateEvents ocge,
    OCServiceImportPolicy policy,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    pwe As DBConstants..::.ProcessWhichEvent, _
    ocge As OCPrivateEvents, _
    policy As OCServiceImportPolicy, _
    session As ConfigureInfo _
) As OCMap()
Visual C++
public:
array<OCMap^>^ UpdateDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCPrivateEvents^ ocge,
    OCServiceImportPolicy policy,
    ConfigureInfo^ session
)

Parameters

pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Determines which events needs to be updated
ocge
Type: OfficeClip.BusinessLayer.Service..::.OCPrivateEvents
The OfficeClip Group Event Object
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
The policy
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

An array of the OfficeClip Map object

See Also

PrivateEventsDB Class
UpdateDb Overload
OfficeClip.DBLayer.Service Namespace


RoleDB Class

[image]

OfficeClip API Documentation
RoleDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class RoleDB
Visual Basic (Declaration)
Public Class RoleDB
Visual C++
public ref class RoleDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.RoleDB

See Also

RoleDB Members
OfficeClip.DBLayer.Service Namespace


RoleDB Members

[image] [image]

OfficeClip API Documentation
RoleDB Members
RoleDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The RoleDB type exposes the following members.

Constructors

 | Name | Description
Public method | RoleDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds a new role in the database that corresponds to this object
Public method | DeleteDb | Deletes the role from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

RoleDB Class
OfficeClip.DBLayer.Service Namespace


RoleDB Constructor

[image]

OfficeClip API Documentation
RoleDB Constructor
RoleDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public RoleDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoleDB()

See Also

RoleDB Class
OfficeClip.DBLayer.Service Namespace


RoleDB Methods

[image] [image]

OfficeClip API Documentation
RoleDB Methods
RoleDB Class See Also

[This is preliminary documentation and is subject to change.]

The RoleDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds a new role in the database that corresponds to this object
Public method | DeleteDb | Deletes the role from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

RoleDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
RoleDB..::.AddNewDb Method
RoleDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a new role in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus AddNewDb(
    int groupId,
    int userId,
    OCRole ocr
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    groupId As Integer, _
    userId As Integer, _
    ocr As OCRole _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus AddNewDb(
    int groupId,
    int userId,
    OCRole^ ocr
)

Parameters

groupId
Type: System..::.Int32
The unique id of the current group
userId
Type: System..::.Int32
The unique id of the current user
ocr
Type: OfficeClip.BusinessLayer.Service..::.OCRole
The role to be added to the database

Return Value

Returns success or failure values

See Also

RoleDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
RoleDB..::.DeleteDb Method
RoleDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the role from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus DeleteDb(
    OCRole ocr
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    ocr As OCRole _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus DeleteDb(
    OCRole^ ocr
)

Parameters

ocr
Type: OfficeClip.BusinessLayer.Service..::.OCRole

Return Value

Returns success or failure values

See Also

RoleDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
RoleDB..::.Populate Method
RoleDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(Int32, Int32) | Constructor to create an instance from the database
Public method | Populate(String, String) | Constructor to create an instance from the xml file

See Also

RoleDB Class
RoleDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (Int32, Int32)

[image]

OfficeClip API Documentation
RoleDB..::.Populate Method (Int32, Int32)
RoleDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCRole Populate(
    int groupId,
    int roleId
)
Visual Basic (Declaration)
Public Function Populate ( _
    groupId As Integer, _
    roleId As Integer _
) As OCRole
Visual C++
public:
OCRole^ Populate(
    int groupId,
    int roleId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
roleId
Type: System..::.Int32
the unique id of the role

See Also

RoleDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
RoleDB..::.Populate Method (String, String)
RoleDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCRole Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCRole
Visual C++
public:
OCRole^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xmf file
schemaPath
Type: System..::.String
The path of the schema file

See Also

RoleDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image]

OfficeClip API Documentation
RoleDB..::.UpdateDb Method
RoleDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database from the created object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus UpdateDb(
    int groupId,
    int roleId,
    int userId,
    OCRole ocr,
    OCServiceImportPolicy policy
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    groupId As Integer, _
    roleId As Integer, _
    userId As Integer, _
    ocr As OCRole, _
    policy As OCServiceImportPolicy _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus UpdateDb(
    int groupId,
    int roleId,
    int userId,
    OCRole^ ocr,
    OCServiceImportPolicy policy
)

Parameters

groupId
Type: System..::.Int32
unique id of the current group
roleId
Type: System..::.Int32
The unique id of the role to be updated
userId
Type: System..::.Int32
The id of the current user
ocr
Type: OfficeClip.BusinessLayer.Service..::.OCRole
The OfficeClip Service Role Object
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
The update policy

Return Value

Returns success or failure values

See Also

RoleDB Class
OfficeClip.DBLayer.Service Namespace


SecurityDB Class

[image]

OfficeClip API Documentation
SecurityDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class SecurityDB
Visual Basic (Declaration)
Public Class SecurityDB
Visual C++
public ref class SecurityDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.SecurityDB

See Also

SecurityDB Members
OfficeClip.DBLayer.Service Namespace


SecurityDB Members

[image] [image]

OfficeClip API Documentation
SecurityDB Members
SecurityDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The SecurityDB type exposes the following members.

Constructors

 | Name | Description
Public method | SecurityDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds new security information in the database that corresponds to this object
Public method | DeleteDb | Removes the security information from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

SecurityDB Class
OfficeClip.DBLayer.Service Namespace


SecurityDB Constructor

[image]

OfficeClip API Documentation
SecurityDB Constructor
SecurityDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SecurityDB()

See Also

SecurityDB Class
OfficeClip.DBLayer.Service Namespace


SecurityDB Methods

[image] [image]

OfficeClip API Documentation
SecurityDB Methods
SecurityDB Class See Also

[This is preliminary documentation and is subject to change.]

The SecurityDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds new security information in the database that corresponds to this object
Public method | DeleteDb | Removes the security information from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

SecurityDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
SecurityDB..::.AddNewDb Method
SecurityDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds new security information in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus AddNewDb(
    int groupId,
    int userId,
    OCSecurity sec
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    groupId As Integer, _
    userId As Integer, _
    sec As OCSecurity _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus AddNewDb(
    int groupId,
    int userId,
    OCSecurity^ sec
)

Parameters

groupId
Type: System..::.Int32
The unique id of the current group
userId
Type: System..::.Int32
The unique id of the current user
sec
Type: OfficeClip.BusinessLayer.Service..::.OCSecurity
The security to be added to the database

Return Value

Returns success or failure values

See Also

SecurityDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
SecurityDB..::.DeleteDb Method
SecurityDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the security information from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus DeleteDb(
    OCSecurity sec
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    sec As OCSecurity _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus DeleteDb(
    OCSecurity^ sec
)

Parameters

sec
Type: OfficeClip.BusinessLayer.Service..::.OCSecurity

Return Value

Returns success or failure values

See Also

SecurityDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
SecurityDB..::.Populate Method
SecurityDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(Int32) | Constructor to create an instance from the database
Public method | Populate(String, String) | Constructor to create an instance from the xml file

See Also

SecurityDB Class
SecurityDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (Int32)

[image]

OfficeClip API Documentation
SecurityDB..::.Populate Method (Int32)
SecurityDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCSecurity Populate(
    int groupId
)
Visual Basic (Declaration)
Public Function Populate ( _
    groupId As Integer _
) As OCSecurity
Visual C++
public:
OCSecurity^ Populate(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

See Also

SecurityDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
SecurityDB..::.Populate Method (String, String)
SecurityDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCSecurity Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCSecurity
Visual C++
public:
OCSecurity^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
The path of the schema file

Return Value

The OfficeClip security object

See Also

SecurityDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image]

OfficeClip API Documentation
SecurityDB..::.UpdateDb Method
SecurityDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database from the created object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus UpdateDb(
    int groupId,
    int userId,
    OCSecurity sec,
    OCServiceImportPolicy policy
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    groupId As Integer, _
    userId As Integer, _
    sec As OCSecurity, _
    policy As OCServiceImportPolicy _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus UpdateDb(
    int groupId,
    int userId,
    OCSecurity^ sec,
    OCServiceImportPolicy policy
)

Parameters

groupId
Type: System..::.Int32
unique id of the current group
userId
Type: System..::.Int32
The id of the current user
sec
Type: OfficeClip.BusinessLayer.Service..::.OCSecurity
The OfficeClip Service Security Object
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
The update policy

Return Value

Returns success or failure values

See Also

SecurityDB Class
OfficeClip.DBLayer.Service Namespace


SecurityObjectDB Class

[image]

OfficeClip API Documentation
SecurityObjectDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class SecurityObjectDB
Visual Basic (Declaration)
Public Class SecurityObjectDB
Visual C++
public ref class SecurityObjectDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.SecurityObjectDB

See Also

SecurityObjectDB Members
OfficeClip.DBLayer.Service Namespace


SecurityObjectDB Members

[image] [image]

OfficeClip API Documentation
SecurityObjectDB Members
SecurityObjectDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The SecurityObjectDB type exposes the following members.

Constructors

 | Name | Description
Public method | SecurityObjectDB |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Constructor to create an instance from the xml file
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Service Namespace


SecurityObjectDB Constructor

[image]

OfficeClip API Documentation
SecurityObjectDB Constructor
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SecurityObjectDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SecurityObjectDB()

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Service Namespace


SecurityObjectDB Methods

[image] [image]

OfficeClip API Documentation
SecurityObjectDB Methods
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

The SecurityObjectDB type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Constructor to create an instance from the xml file
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image]

OfficeClip API Documentation
SecurityObjectDB..::.Populate Method
SecurityObjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCSecurityObject Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCSecurityObject
Visual C++
public:
OCSecurityObject^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The Xml File
schemaPath
Type: System..::.String
The path of the schema file

See Also

SecurityObjectDB Class
OfficeClip.DBLayer.Service Namespace


SystemDB Class

[image]

OfficeClip API Documentation
SystemDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class SystemDB
Visual Basic (Declaration)
Public Class SystemDB
Visual C++
public ref class SystemDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.SystemDB

See Also

SystemDB Members
OfficeClip.DBLayer.Service Namespace


SystemDB Members

[image] [image]

OfficeClip API Documentation
SystemDB Members
SystemDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The SystemDB type exposes the following members.

Constructors

 | Name | Description
Public method | SystemDB |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SystemDB Class
OfficeClip.DBLayer.Service Namespace


SystemDB Constructor

[image]

OfficeClip API Documentation
SystemDB Constructor
SystemDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SystemDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SystemDB()

See Also

SystemDB Class
OfficeClip.DBLayer.Service Namespace


SystemDB Methods

[image] [image]

OfficeClip API Documentation
SystemDB Methods
SystemDB Class See Also

[This is preliminary documentation and is subject to change.]

The SystemDB type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SystemDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
SystemDB..::.Populate Method
SystemDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(ConfigureInfo) | Constructor to create an instance from the database
Public method | Populate(String, String) | Constructor to create an instance from the xml file

See Also

SystemDB Class
SystemDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (ConfigureInfo)

[image]

OfficeClip API Documentation
SystemDB..::.Populate Method (ConfigureInfo)
SystemDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCSystem Populate(
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function Populate ( _
    session As ConfigureInfo _
) As OCSystem
Visual C++
public:
OCSystem^ Populate(
    ConfigureInfo^ session
)

Parameters

session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

the OfficeClip system object

See Also

SystemDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
SystemDB..::.Populate Method (String, String)
SystemDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCSystem Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCSystem
Visual C++
public:
OCSystem^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
The path of the schema

Return Value

The OfficeClip system object

See Also

SystemDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


TaskDB Class

[image]

OfficeClip API Documentation
TaskDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TaskDB
Visual Basic (Declaration)
Public Class TaskDB
Visual C++
public ref class TaskDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.TaskDB

See Also

TaskDB Members
OfficeClip.DBLayer.Service Namespace


TaskDB Members

[image] [image]

OfficeClip API Documentation
TaskDB Members
TaskDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The TaskDB type exposes the following members.

Constructors

 | Name | Description
Public method | TaskDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds a new task in the database that corresponds to this object
Public method | DeleteDb | Deletes the task from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

TaskDB Class
OfficeClip.DBLayer.Service Namespace


TaskDB Constructor

[image]

OfficeClip API Documentation
TaskDB Constructor
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TaskDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TaskDB()

See Also

TaskDB Class
OfficeClip.DBLayer.Service Namespace


TaskDB Methods

[image] [image]

OfficeClip API Documentation
TaskDB Methods
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

The TaskDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds a new task in the database that corresponds to this object
Public method | DeleteDb | Deletes the task from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

TaskDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
TaskDB..::.AddNewDb Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a new task in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus AddNewDb(
    int taskId,
    OCTask oct,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    taskId As Integer, _
    oct As OCTask, _
    session As ConfigureInfo _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus AddNewDb(
    int taskId,
    OCTask^ oct,
    ConfigureInfo^ session
)

Parameters

taskId
Type: System..::.Int32
The unique id of the task
oct
Type: OfficeClip.BusinessLayer.Service..::.OCTask
The role to be added to the database
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

Returns success or failure values

See Also

TaskDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
TaskDB..::.DeleteDb Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the task from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask oct,
    int userId,
    int groupId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    pwe As DBConstants..::.ProcessWhichEvent, _
    oct As OCTask, _
    userId As Integer, _
    groupId As Integer, _
    isAdmin As Boolean _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask^ oct,
    int userId,
    int groupId,
    bool isAdmin
)

Parameters

pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Shows which tasks in recurring tasks needs to be processed
oct
Type: OfficeClip.BusinessLayer.Service..::.OCTask
The service task object
userId
Type: System..::.Int32
The id of the current user
groupId
Type: System..::.Int32
The unique id of the active organization
isAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Returns success or failure values

See Also

TaskDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
TaskDB..::.Populate Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(String, String) | Constructor to create an instance from the xml file
Public method | Populate(Int32, Int32, Boolean) | Constructor to create an instance from the database

See Also

TaskDB Class
TaskDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
TaskDB..::.Populate Method (String, String)
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCTask Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCTask
Visual C++
public:
OCTask^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
the path of the schema file

Return Value

The OfficeClip task object

See Also

TaskDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (Int32, Int32, Boolean)

[image]

OfficeClip API Documentation
TaskDB..::.Populate Method (Int32, Int32, Boolean)
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCTask Populate(
    int taskId,
    int userId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function Populate ( _
    taskId As Integer, _
    userId As Integer, _
    isAdmin As Boolean _
) As OCTask
Visual C++
public:
OCTask^ Populate(
    int taskId,
    int userId,
    bool isAdmin
)

Parameters

taskId
Type: System..::.Int32
The unique id of the task
userId
Type: System..::.Int32
the unique id of the current user
isAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

The OfficeClip task object

See Also

TaskDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image]

OfficeClip API Documentation
TaskDB..::.UpdateDb Method
TaskDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database from the created object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus UpdateDb(
    int taskId,
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask oct,
    OCServiceImportPolicy policy,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    taskId As Integer, _
    pwe As DBConstants..::.ProcessWhichEvent, _
    oct As OCTask, _
    policy As OCServiceImportPolicy, _
    session As ConfigureInfo _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus UpdateDb(
    int taskId,
    DBConstants..::.ProcessWhichEvent pwe,
    OCTask^ oct,
    OCServiceImportPolicy policy,
    ConfigureInfo^ session
)

Parameters

taskId
Type: System..::.Int32
The unique id of the role to be updated
pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Shows which tasks needs to be updated
oct
Type: OfficeClip.BusinessLayer.Service..::.OCTask
The OfficeClip Service Task Object
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
The update policy
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

Returns success or failure values

See Also

TaskDB Class
OfficeClip.DBLayer.Service Namespace


TasksDB Class

[image]

OfficeClip API Documentation
TasksDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TasksDB
Visual Basic (Declaration)
Public Class TasksDB
Visual C++
public ref class TasksDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.TasksDB

See Also

TasksDB Members
OfficeClip.DBLayer.Service Namespace


TasksDB Members

[image] [image]

OfficeClip API Documentation
TasksDB Members
TasksDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The TasksDB type exposes the following members.

Constructors

 | Name | Description
Public method | TasksDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds a new task in the database that corresponds to this object
Public method | DeleteDb | Deletes the tasks from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

TasksDB Class
OfficeClip.DBLayer.Service Namespace


TasksDB Constructor

[image]

OfficeClip API Documentation
TasksDB Constructor
TasksDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TasksDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TasksDB()

See Also

TasksDB Class
OfficeClip.DBLayer.Service Namespace


TasksDB Methods

[image] [image]

OfficeClip API Documentation
TasksDB Methods
TasksDB Class See Also

[This is preliminary documentation and is subject to change.]

The TasksDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds a new task in the database that corresponds to this object
Public method | DeleteDb | Deletes the tasks from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

TasksDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
TasksDB..::.AddNewDb Method
TasksDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a new task in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus AddNewDb(
    OCTasks octs,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    octs As OCTasks, _
    session As ConfigureInfo _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus AddNewDb(
    OCTasks^ octs,
    ConfigureInfo^ session
)

Parameters

octs
Type: OfficeClip.BusinessLayer.Service..::.OCTasks
The OfficeClip tasks object
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session

Return Value

Returns success or failure values

See Also

TasksDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
TasksDB..::.DeleteDb Method
TasksDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the tasks from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCTasks octs,
    int userId,
    int groupId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    pwe As DBConstants..::.ProcessWhichEvent, _
    octs As OCTasks, _
    userId As Integer, _
    groupId As Integer, _
    isAdmin As Boolean _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus DeleteDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCTasks^ octs,
    int userId,
    int groupId,
    bool isAdmin
)

Parameters

pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Shows which tasks in recurring tasks needs to be processed
octs
Type: OfficeClip.BusinessLayer.Service..::.OCTasks
The service tasks object
userId
Type: System..::.Int32
The unique id of the current user
groupId
Type: System..::.Int32
The unique id of the organization
isAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Returns success or failure values

See Also

TasksDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
TasksDB..::.Populate Method
TasksDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(ConfigureInfo) | Constructor to create an instance from the database
Public method | Populate(String, String) | Constructor to create an instance from the xml file

See Also

TasksDB Class
TasksDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (ConfigureInfo)

[image]

OfficeClip API Documentation
TasksDB..::.Populate Method (ConfigureInfo)
TasksDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCTasks Populate(
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function Populate ( _
    session As ConfigureInfo _
) As OCTasks
Visual C++
public:
OCTasks^ Populate(
    ConfigureInfo^ session
)

Parameters

session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session

Return Value

The OfficeClip service tasks

See Also

TasksDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
TasksDB..::.Populate Method (String, String)
TasksDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCTasks Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCTasks
Visual C++
public:
OCTasks^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
the path of the schema file

Return Value

The OfficeClip tasks object

See Also

TasksDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image]

OfficeClip API Documentation
TasksDB..::.UpdateDb Method
TasksDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database from the created object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus UpdateDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCTasks octs,
    OCServiceImportPolicy policy,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    pwe As DBConstants..::.ProcessWhichEvent, _
    octs As OCTasks, _
    policy As OCServiceImportPolicy, _
    session As ConfigureInfo _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus UpdateDb(
    DBConstants..::.ProcessWhichEvent pwe,
    OCTasks^ octs,
    OCServiceImportPolicy policy,
    ConfigureInfo^ session
)

Parameters

pwe
Type: OfficeClip.DBLayer..::.DBConstants..::.ProcessWhichEvent
Determines which tasks are to be processed
octs
Type: OfficeClip.BusinessLayer.Service..::.OCTasks
The OfficeClip Service Tasks Object
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
The update policy
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session

Return Value

Returns success or failure values

See Also

TasksDB Class
OfficeClip.DBLayer.Service Namespace


TrackerCaseDB Class

[image]

OfficeClip API Documentation
TrackerCaseDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

The tracker case db object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerCaseDB
Visual Basic (Declaration)
Public Class TrackerCaseDB
Visual C++
public ref class TrackerCaseDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.TrackerCaseDB

See Also

TrackerCaseDB Members
OfficeClip.DBLayer.Service Namespace


TrackerCaseDB Members

[image] [image]

OfficeClip API Documentation
TrackerCaseDB Members
TrackerCaseDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The TrackerCaseDB type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerCaseDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds this case to the database
Protected method | ChangeUnspecifiedToEmpty | Change the unspecified to empty string
Public method | DeleteDb | Deletes the case from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates the object
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCase | Updates a tracker case
Public method | UpdateDb | Update the database

See Also

TrackerCaseDB Class
OfficeClip.DBLayer.Service Namespace


TrackerCaseDB Constructor

[image]

OfficeClip API Documentation
TrackerCaseDB Constructor
TrackerCaseDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerCaseDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerCaseDB()

See Also

TrackerCaseDB Class
OfficeClip.DBLayer.Service Namespace


TrackerCaseDB Methods

[image] [image]

OfficeClip API Documentation
TrackerCaseDB Methods
TrackerCaseDB Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerCaseDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds this case to the database
Protected method | ChangeUnspecifiedToEmpty | Change the unspecified to empty string
Public method | DeleteDb | Deletes the case from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates the object
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCase | Updates a tracker case
Public method | UpdateDb | Update the database

See Also

TrackerCaseDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
TrackerCaseDB..::.AddNewDb Method
TrackerCaseDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds this case to the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap AddNewDb(
    int projectId,
    ref OCTrackerCase octc,
    OCTrackerFields fields,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    projectId As Integer, _
    ByRef octc As OCTrackerCase, _
    fields As OCTrackerFields, _
    session As ConfigureInfo _
) As OCMap
Visual C++
public:
OCMap^ AddNewDb(
    int projectId,
    OCTrackerCase^% octc,
    OCTrackerFields^ fields,
    ConfigureInfo^ session
)

Parameters

projectId
Type: System..::.Int32
The project id where the case is to be added
octc
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerCase %
The service tracker case object
fields
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerFields
The tracker project field
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The OfficeClip map object

See Also

TrackerCaseDB Class
OfficeClip.DBLayer.Service Namespace


ChangeUnspecifiedToEmpty Method

[image]

OfficeClip API Documentation
TrackerCaseDB..::.ChangeUnspecifiedToEmpty Method
TrackerCaseDB Class See Also

[This is preliminary documentation and is subject to change.]

Change the unspecified to empty string

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string ChangeUnspecifiedToEmpty(
    string val
)
Visual Basic (Declaration)
Protected Function ChangeUnspecifiedToEmpty ( _
    val As String _
) As String
Visual C++
protected:
String^ ChangeUnspecifiedToEmpty(
    String^ val
)

Parameters

val
Type: System..::.String

Return Value

See Also

TrackerCaseDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
TrackerCaseDB..::.DeleteDb Method
TrackerCaseDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the case from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap DeleteDb(
    int projectId,
    ref OCTrackerCase octc,
    OCTrackerFields fields,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    projectId As Integer, _
    ByRef octc As OCTrackerCase, _
    fields As OCTrackerFields, _
    session As ConfigureInfo _
) As OCMap
Visual C++
public:
OCMap^ DeleteDb(
    int projectId,
    OCTrackerCase^% octc,
    OCTrackerFields^ fields,
    ConfigureInfo^ session
)

Parameters

projectId
Type: System..::.Int32
The id of the project
octc
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerCase %
The OfficeClip tracker case object
fields
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerFields
The list of all the fields
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The service map object

See Also

TrackerCaseDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image]

OfficeClip API Documentation
TrackerCaseDB..::.Populate Method
TrackerCaseDB Class See Also

[This is preliminary documentation and is subject to change.]

Populates the object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerCase Populate(
    TrackerCaseInfo tci
)
Visual Basic (Declaration)
Public Function Populate ( _
    tci As TrackerCaseInfo _
) As OCTrackerCase
Visual C++
public:
OCTrackerCase^ Populate(
    TrackerCaseInfo^ tci
)

Parameters

tci
Type: OfficeClip.BusinessLayer.Tracker..::.TrackerCaseInfo
The tracker case information object

Return Value

The service tracker case object

See Also

TrackerCaseDB Class
OfficeClip.DBLayer.Service Namespace


UpdateCase Method

[image]

OfficeClip API Documentation
TrackerCaseDB..::.UpdateCase Method
TrackerCaseDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates a tracker case

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap UpdateCase(
    int projectId,
    ref OCTrackerCase octc,
    OCTrackerFields fields,
    bool isActive,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateCase ( _
    projectId As Integer, _
    ByRef octc As OCTrackerCase, _
    fields As OCTrackerFields, _
    isActive As Boolean, _
    session As ConfigureInfo _
) As OCMap
Visual C++
public:
OCMap^ UpdateCase(
    int projectId,
    OCTrackerCase^% octc,
    OCTrackerFields^ fields,
    bool isActive,
    ConfigureInfo^ session
)

Parameters

projectId
Type: System..::.Int32
The unique id of the project
octc
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerCase %
The service tracker case object
fields
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerFields
Teh service tracker fields object
isActive
Type: System..::.Boolean
True if the case is active
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The service map object

See Also

TrackerCaseDB Class
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image]

OfficeClip API Documentation
TrackerCaseDB..::.UpdateDb Method
TrackerCaseDB Class See Also

[This is preliminary documentation and is subject to change.]

Update the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap UpdateDb(
    ref OCTrackerCase octc,
    int projectId,
    OCTrackerFields fields,
    OCServiceImportPolicy policy,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    ByRef octc As OCTrackerCase, _
    projectId As Integer, _
    fields As OCTrackerFields, _
    policy As OCServiceImportPolicy, _
    session As ConfigureInfo _
) As OCMap
Visual C++
public:
OCMap^ UpdateDb(
    OCTrackerCase^% octc,
    int projectId,
    OCTrackerFields^ fields,
    OCServiceImportPolicy policy,
    ConfigureInfo^ session
)

Parameters

octc
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerCase %
projectId
Type: System..::.Int32
fields
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerFields
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
session
Type: OfficeClip.Utils..::.ConfigureInfo

Return Value

See Also

TrackerCaseDB Class
OfficeClip.DBLayer.Service Namespace


TrackerFieldsDB Class

[image]

OfficeClip API Documentation
TrackerFieldsDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Container for the tracker fields service object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerFieldsDB
Visual Basic (Declaration)
Public Class TrackerFieldsDB
Visual C++
public ref class TrackerFieldsDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.TrackerFieldsDB

See Also

TrackerFieldsDB Members
OfficeClip.DBLayer.Service Namespace


TrackerFieldsDB Members

[image] [image]

OfficeClip API Documentation
TrackerFieldsDB Members
TrackerFieldsDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The TrackerFieldsDB type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerFieldsDB |

Methods

 | Name | Description
Public method | AddNewDb | Copies the object to the database as a new set of fields
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates the service tracker fields object
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerFieldsDB Class
OfficeClip.DBLayer.Service Namespace


TrackerFieldsDB Constructor

[image]

OfficeClip API Documentation
TrackerFieldsDB Constructor
TrackerFieldsDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerFieldsDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerFieldsDB()

See Also

TrackerFieldsDB Class
OfficeClip.DBLayer.Service Namespace


TrackerFieldsDB Methods

[image] [image]

OfficeClip API Documentation
TrackerFieldsDB Methods
TrackerFieldsDB Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerFieldsDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Copies the object to the database as a new set of fields
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Populates the service tracker fields object
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerFieldsDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
TrackerFieldsDB..::.AddNewDb Method
TrackerFieldsDB Class See Also

[This is preliminary documentation and is subject to change.]

Copies the object to the database as a new set of fields

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus AddNewDb(
    ref OCTrackerFields tfls,
    int projectId
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    ByRef tfls As OCTrackerFields, _
    projectId As Integer _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus AddNewDb(
    OCTrackerFields^% tfls,
    int projectId
)

Parameters

tfls
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerFields %
Reference to the OfficeClip tracker field object
projectId
Type: System..::.Int32
The id of the project for which the fields are to be inserted

Return Value

The success or failure result

See Also

TrackerFieldsDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image]

OfficeClip API Documentation
TrackerFieldsDB..::.Populate Method
TrackerFieldsDB Class See Also

[This is preliminary documentation and is subject to change.]

Populates the service tracker fields object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerFields Populate(
    int projectId
)
Visual Basic (Declaration)
Public Function Populate ( _
    projectId As Integer _
) As OCTrackerFields
Visual C++
public:
OCTrackerFields^ Populate(
    int projectId
)

Parameters

projectId
Type: System..::.Int32
The unique id of the project

Return Value

The Service Tracker Field object

See Also

TrackerFieldsDB Class
OfficeClip.DBLayer.Service Namespace


TrackerProjectDB Class

[image]

OfficeClip API Documentation
TrackerProjectDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerProjectDB
Visual Basic (Declaration)
Public Class TrackerProjectDB
Visual C++
public ref class TrackerProjectDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.TrackerProjectDB

See Also

TrackerProjectDB Members
OfficeClip.DBLayer.Service Namespace


TrackerProjectDB Members

[image] [image]

OfficeClip API Documentation
TrackerProjectDB Members
TrackerProjectDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The TrackerProjectDB type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerProjectDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds a new project in the database that corresponds to this object
Public method | ConvertTrackerScreenToBooleanDB | Convert the screen or file representation of the tracker boolean to the database representation
Public method | DeleteDb | Deletes the project from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSignature | Gets the signature of teh service tracker project object
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | SetChanges | Sets the changes for the service tracker project
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database

See Also

TrackerProjectDB Class
OfficeClip.DBLayer.Service Namespace


TrackerProjectDB Constructor

[image]

OfficeClip API Documentation
TrackerProjectDB Constructor
TrackerProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerProjectDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerProjectDB()

See Also

TrackerProjectDB Class
OfficeClip.DBLayer.Service Namespace


TrackerProjectDB Methods

[image] [image]

OfficeClip API Documentation
TrackerProjectDB Methods
TrackerProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerProjectDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds a new project in the database that corresponds to this object
Public method | ConvertTrackerScreenToBooleanDB | Convert the screen or file representation of the tracker boolean to the database representation
Public method | DeleteDb | Deletes the project from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetSignature | Gets the signature of teh service tracker project object
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | SetChanges | Sets the changes for the service tracker project
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database

See Also

TrackerProjectDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
TrackerProjectDB..::.AddNewDb Method
TrackerProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a new project in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus AddNewDb(
    ref OCTrackerProject octp,
    string projectName,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    ByRef octp As OCTrackerProject, _
    projectName As String, _
    session As ConfigureInfo _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus AddNewDb(
    OCTrackerProject^% octp,
    String^ projectName,
    ConfigureInfo^ session
)

Parameters

octp
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerProject %
The service tracker project object
projectName
Type: System..::.String
The name of the project to be used
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

Returns success or failure values

See Also

TrackerProjectDB Class
OfficeClip.DBLayer.Service Namespace


ConvertTrackerScreenToBooleanDB Method

[image]

OfficeClip API Documentation
TrackerProjectDB..::.ConvertTrackerScreenToBooleanDB Method
TrackerProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Convert the screen or file representation of the tracker boolean to the database representation

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void ConvertTrackerScreenToBooleanDB(
    OCTrackerProject octp
)
Visual Basic (Declaration)
Public Sub ConvertTrackerScreenToBooleanDB ( _
    octp As OCTrackerProject _
)
Visual C++
public:
void ConvertTrackerScreenToBooleanDB(
    OCTrackerProject^ octp
)

Parameters

octp
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerProject
The object related to the tracker project

See Also

TrackerProjectDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
TrackerProjectDB..::.DeleteDb Method
TrackerProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the project from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus DeleteDb(
    ref OCTrackerProject octp
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    ByRef octp As OCTrackerProject _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus DeleteDb(
    OCTrackerProject^% octp
)

Parameters

octp
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerProject %

Return Value

Returns success or failure values

See Also

TrackerProjectDB Class
OfficeClip.DBLayer.Service Namespace


GetSignature Method

[image]

OfficeClip API Documentation
TrackerProjectDB..::.GetSignature Method
TrackerProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the signature of teh service tracker project object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCService[] GetSignature(
    string sid,
    int currentUserId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function GetSignature ( _
    sid As String, _
    currentUserId As Integer, _
    currentGroupId As Integer _
) As OCService()
Visual C++
public:
array<OCService^>^ GetSignature(
    String^ sid,
    int currentUserId,
    int currentGroupId
)

Parameters

sid
Type: System..::.String
The service id
currentUserId
Type: System..::.Int32
The id of the current user
currentGroupId
Type: System..::.Int32
The id of the current group

Return Value

The service object that contains the signature

See Also

TrackerProjectDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
TrackerProjectDB..::.Populate Method
TrackerProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(String, String) | Constructor to create an instance from the xml file
Public method | Populate(Int32, Int32, Int32) | Constructor to create an instance frm the database

See Also

TrackerProjectDB Class
TrackerProjectDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
TrackerProjectDB..::.Populate Method (String, String)
TrackerProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerProject Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCTrackerProject
Visual C++
public:
OCTrackerProject^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
The path of the schema file

Return Value

The service tracker project object

See Also

TrackerProjectDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (Int32, Int32, Int32)

[image]

OfficeClip API Documentation
TrackerProjectDB..::.Populate Method (Int32, Int32, Int32)
TrackerProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance frm the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCTrackerProject Populate(
    int projectId,
    int currentUserId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function Populate ( _
    projectId As Integer, _
    currentUserId As Integer, _
    currentGroupId As Integer _
) As OCTrackerProject
Visual C++
public:
OCTrackerProject^ Populate(
    int projectId,
    int currentUserId,
    int currentGroupId
)

Parameters

projectId
Type: System..::.Int32
The unique id of the project
currentUserId
Type: System..::.Int32
The id of the current user
currentGroupId
Type: System..::.Int32
The id of the current group

See Also

TrackerProjectDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


SetChanges Method

[image]

OfficeClip API Documentation
TrackerProjectDB..::.SetChanges Method
TrackerProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the changes for the service tracker project

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap[] SetChanges(
    int projectId,
    OCTrackerCase[] changes,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function SetChanges ( _
    projectId As Integer, _
    changes As OCTrackerCase(), _
    session As ConfigureInfo _
) As OCMap()
Visual C++
public:
array<OCMap^>^ SetChanges(
    int projectId,
    array<OCTrackerCase^>^ changes,
    ConfigureInfo^ session
)

Parameters

projectId
Type: System..::.Int32
The unique id of the project
changes
Type: array< OfficeClip.BusinessLayer.Service..::.OCTrackerCase >[]()[]
Array of changes
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session

Return Value

The array of the service map object

See Also

TrackerProjectDB Class
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image]

OfficeClip API Documentation
TrackerProjectDB..::.UpdateDb Method
TrackerProjectDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCServiceReturnStatus UpdateDb(
    ref OCTrackerProject octp,
    int projectId,
    OCServiceImportPolicy policy,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    ByRef octp As OCTrackerProject, _
    projectId As Integer, _
    policy As OCServiceImportPolicy, _
    session As ConfigureInfo _
) As OCServiceReturnStatus
Visual C++
public:
OCServiceReturnStatus UpdateDb(
    OCTrackerProject^% octp,
    int projectId,
    OCServiceImportPolicy policy,
    ConfigureInfo^ session
)

Parameters

octp
Type: OfficeClip.BusinessLayer.Service..::.OCTrackerProject %
projectId
Type: System..::.Int32
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
session
Type: OfficeClip.Utils..::.ConfigureInfo

Return Value

See Also

TrackerProjectDB Class
OfficeClip.DBLayer.Service Namespace


UserDB Class

[image]

OfficeClip API Documentation
UserDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class UserDB
Visual Basic (Declaration)
Public Class UserDB
Visual C++
public ref class UserDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.UserDB

See Also

UserDB Members
OfficeClip.DBLayer.Service Namespace


UserDB Members

[image] [image]

OfficeClip API Documentation
UserDB Members
UserDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The UserDB type exposes the following members.

Constructors

 | Name | Description
Public method | UserDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds a new contact in the database that corresponds to this object
Public method | DeleteDb | Deletes the task from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

UserDB Class
OfficeClip.DBLayer.Service Namespace


UserDB Constructor

[image]

OfficeClip API Documentation
UserDB Constructor
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public UserDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserDB()

See Also

UserDB Class
OfficeClip.DBLayer.Service Namespace


UserDB Methods

[image] [image]

OfficeClip API Documentation
UserDB Methods
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

The UserDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds a new contact in the database that corresponds to this object
Public method | DeleteDb | Deletes the task from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

UserDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
UserDB..::.AddNewDb Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a new contact in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap AddNewDb(
    int groupId,
    int loggedInUserId,
    OCUser ocu
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    groupId As Integer, _
    loggedInUserId As Integer, _
    ocu As OCUser _
) As OCMap
Visual C++
public:
OCMap^ AddNewDb(
    int groupId,
    int loggedInUserId,
    OCUser^ ocu
)

Parameters

groupId
Type: System..::.Int32
The unique id of the task
loggedInUserId
Type: System..::.Int32
The unique id of the logged in user
ocu
Type: OfficeClip.BusinessLayer.Service..::.OCUser
The user to be added to the database

Return Value

Returns success or failure values

See Also

UserDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
UserDB..::.DeleteDb Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the task from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap DeleteDb(
    int groupId,
    OCUser ocu
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    groupId As Integer, _
    ocu As OCUser _
) As OCMap
Visual C++
public:
OCMap^ DeleteDb(
    int groupId,
    OCUser^ ocu
)

Parameters

groupId
Type: System..::.Int32
The unique id of teh group
ocu
Type: OfficeClip.BusinessLayer.Service..::.OCUser
The service user object

Return Value

The service map object

See Also

UserDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
UserDB..::.Populate Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(String, String) | Constructor to create an instance from the xml file
Public method | Populate(OCServiceType, Int32) | Constructor to create an instance from the database

See Also

UserDB Class
UserDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
UserDB..::.Populate Method (String, String)
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCUser Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCUser
Visual C++
public:
OCUser^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
The path of the schema file

Return Value

The service user object

See Also

UserDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (OCServiceType, Int32)

[image]

OfficeClip API Documentation
UserDB..::.Populate Method (OCServiceType, Int32)
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCUser Populate(
    OCServiceType ost,
    int userDetailId
)
Visual Basic (Declaration)
Public Function Populate ( _
    ost As OCServiceType, _
    userDetailId As Integer _
) As OCUser
Visual C++
public:
OCUser^ Populate(
    OCServiceType ost,
    int userDetailId
)

Parameters

ost
Type: OfficeClip.Utils..::.OCServiceType
The service type object
userDetailId
Type: System..::.Int32
The unique id of the user detail

Return Value

Teh service user object

See Also

UserDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image]

OfficeClip API Documentation
UserDB..::.UpdateDb Method
UserDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database from the created object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap UpdateDb(
    int loggedInUserId,
    int groupId,
    OCUser ocu,
    OCServiceImportPolicy policy,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    loggedInUserId As Integer, _
    groupId As Integer, _
    ocu As OCUser, _
    policy As OCServiceImportPolicy, _
    isAdmin As Boolean _
) As OCMap
Visual C++
public:
OCMap^ UpdateDb(
    int loggedInUserId,
    int groupId,
    OCUser^ ocu,
    OCServiceImportPolicy policy,
    bool isAdmin
)

Parameters

loggedInUserId
Type: System..::.Int32
The unique id of the logged in user
groupId
Type: System..::.Int32
The unique id of the group
ocu
Type: OfficeClip.BusinessLayer.Service..::.OCUser
The OfficeClip Service User Object
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
The update policy
isAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

The service map object

See Also

UserDB Class
OfficeClip.DBLayer.Service Namespace


UsersDB Class

[image]

OfficeClip API Documentation
UsersDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class UsersDB
Visual Basic (Declaration)
Public Class UsersDB
Visual C++
public ref class UsersDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Service..::.UsersDB

See Also

UsersDB Members
OfficeClip.DBLayer.Service Namespace


UsersDB Members

[image] [image]

OfficeClip API Documentation
UsersDB Members
UsersDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The UsersDB type exposes the following members.

Constructors

 | Name | Description
Public method | UsersDB |

Methods

 | Name | Description
Public method | AddNewDb | Adds a new user in the database that corresponds to this object
Public method | CreateNewPersonalAddressBook | Creates a new addressbook
Public method | DeleteAddressBook | Deletes the addressbook from the officeclip database
Public method | DeleteDb | Deletes the users from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChangesForAddressBook | Gets only those user information that is requested
Public method | GetChangesForGroupList | Gets only those user information that is requested
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLastError | Returns the last error
Public method | GetSignatureForAddressBook | Gets the signature of the OfficeClip object
Public method | GetSignatureForGroupList | Gets the signature of the OfficeClip object
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsExists | Finds if the folder exists
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | SetChanges | Sets the changes
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


UsersDB Constructor

[image]

OfficeClip API Documentation
UsersDB Constructor
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public UsersDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UsersDB()

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


UsersDB Methods

[image] [image]

OfficeClip API Documentation
UsersDB Methods
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

The UsersDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddNewDb | Adds a new user in the database that corresponds to this object
Public method | CreateNewPersonalAddressBook | Creates a new addressbook
Public method | DeleteAddressBook | Deletes the addressbook from the officeclip database
Public method | DeleteDb | Deletes the users from the database
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChangesForAddressBook | Gets only those user information that is requested
Public method | GetChangesForGroupList | Gets only those user information that is requested
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLastError | Returns the last error
Public method | GetSignatureForAddressBook | Gets the signature of the OfficeClip object
Public method | GetSignatureForGroupList | Gets the signature of the OfficeClip object
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsExists | Finds if the folder exists
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Populate | Overloaded.
Public method | SetChanges | Sets the changes
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateDb | Updates the database from the created object

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


AddNewDb Method

[image]

OfficeClip API Documentation
UsersDB..::.AddNewDb Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds a new user in the database that corresponds to this object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap[] AddNewDb(
    int groupId,
    int loggedInUserId,
    OCUsers ocus
)
Visual Basic (Declaration)
Public Function AddNewDb ( _
    groupId As Integer, _
    loggedInUserId As Integer, _
    ocus As OCUsers _
) As OCMap()
Visual C++
public:
array<OCMap^>^ AddNewDb(
    int groupId,
    int loggedInUserId,
    OCUsers^ ocus
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
loggedInUserId
Type: System..::.Int32
The unique id of teh logged in user
ocus
Type: OfficeClip.BusinessLayer.Service..::.OCUsers
The serive users object

Return Value

The array of the service map object

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


CreateNewPersonalAddressBook Method

[image]

OfficeClip API Documentation
UsersDB..::.CreateNewPersonalAddressBook Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates a new addressbook

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string CreateNewPersonalAddressBook(
    string addressBookName,
    int groupId,
    int userId
)
Visual Basic (Declaration)
Public Function CreateNewPersonalAddressBook ( _
    addressBookName As String, _
    groupId As Integer, _
    userId As Integer _
) As String
Visual C++
public:
String^ CreateNewPersonalAddressBook(
    String^ addressBookName,
    int groupId,
    int userId
)

Parameters

addressBookName
Type: System..::.String
The name of the addressbook to be created
groupId
Type: System..::.Int32
The unique id of the organization
userId
Type: System..::.Int32
The unique id of the current user

Return Value

the sid of the new addressbook, empty string if there is an error

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


DeleteAddressBook Method

[image]

OfficeClip API Documentation
UsersDB..::.DeleteAddressBook Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the addressbook from the officeclip database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool DeleteAddressBook(
    string sid,
    int groupId
)
Visual Basic (Declaration)
Public Function DeleteAddressBook ( _
    sid As String, _
    groupId As Integer _
) As Boolean
Visual C++
public:
bool DeleteAddressBook(
    String^ sid,
    int groupId
)

Parameters

sid
Type: System..::.String
The system id of the addressbook
groupId
Type: System..::.Int32
The unique id of the organization

Return Value

true if successful, false if there is an error, see the lasterror function to resolve errors.

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


DeleteDb Method

[image]

OfficeClip API Documentation
UsersDB..::.DeleteDb Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the users from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap[] DeleteDb(
    int groupId,
    OCUsers ocus
)
Visual Basic (Declaration)
Public Function DeleteDb ( _
    groupId As Integer, _
    ocus As OCUsers _
) As OCMap()
Visual C++
public:
array<OCMap^>^ DeleteDb(
    int groupId,
    OCUsers^ ocus
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
ocus
Type: OfficeClip.BusinessLayer.Service..::.OCUsers
The service users object

Return Value

Returns success or failure values

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


GetChangesForAddressBook Method

[image]

OfficeClip API Documentation
UsersDB..::.GetChangesForAddressBook Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets only those user information that is requested

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCUser[] GetChangesForAddressBook(
    string folderId,
    string[] changes
)
Visual Basic (Declaration)
Public Function GetChangesForAddressBook ( _
    folderId As String, _
    changes As String() _
) As OCUser()
Visual C++
public:
array<OCUser^>^ GetChangesForAddressBook(
    String^ folderId,
    array<String^>^ changes
)

Parameters

folderId
Type: System..::.String
The unique id of the folder
changes
Type: array<System..::.String>[]()[]
The array of strings for which the changes are required

Return Value

The arraylist of the service user

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


GetChangesForGroupList Method

[image]

OfficeClip API Documentation
UsersDB..::.GetChangesForGroupList Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets only those user information that is requested

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCUser[] GetChangesForGroupList(
    string folderId,
    string[] changes
)
Visual Basic (Declaration)
Public Function GetChangesForGroupList ( _
    folderId As String, _
    changes As String() _
) As OCUser()
Visual C++
public:
array<OCUser^>^ GetChangesForGroupList(
    String^ folderId,
    array<String^>^ changes
)

Parameters

folderId
Type: System..::.String
TThe unique id of the folder
changes
Type: array<System..::.String>[]()[]
The array of strings for which the changes are required

Return Value

The arraylist of BusinessLayer.Service.OCuser

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


GetLastError Method

[image]

OfficeClip API Documentation
UsersDB..::.GetLastError Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the last error

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetLastError()
Visual Basic (Declaration)
Public Function GetLastError As String
Visual C++
public:
String^ GetLastError()

Return Value

The last error message

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


GetSignatureForAddressBook Method

[image]

OfficeClip API Documentation
UsersDB..::.GetSignatureForAddressBook Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the signature of the OfficeClip object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCService[] GetSignatureForAddressBook(
    string sid
)
Visual Basic (Declaration)
Public Function GetSignatureForAddressBook ( _
    sid As String _
) As OCService()
Visual C++
public:
array<OCService^>^ GetSignatureForAddressBook(
    String^ sid
)

Parameters

sid
Type: System..::.String
The input sid for which the signature is desired

Return Value

only the sid and checksum is populated, null value signifies that there is some error

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


GetSignatureForGroupList Method

[image]

OfficeClip API Documentation
UsersDB..::.GetSignatureForGroupList Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the signature of the OfficeClip object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCService[] GetSignatureForGroupList(
    string sid
)
Visual Basic (Declaration)
Public Function GetSignatureForGroupList ( _
    sid As String _
) As OCService()
Visual C++
public:
array<OCService^>^ GetSignatureForGroupList(
    String^ sid
)

Parameters

sid
Type: System..::.String
The input sid for which the signature is desired

Return Value

only the sid and checksum is populated, null value signifies that there is some error

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


IsExists Method

[image]

OfficeClip API Documentation
UsersDB..::.IsExists Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Finds if the folder exists

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsExists(
    string folderId
)
Visual Basic (Declaration)
Public Function IsExists ( _
    folderId As String _
) As Boolean
Visual C++
public:
bool IsExists(
    String^ folderId
)

Parameters

folderId
Type: System..::.String
The unique id of the folder

Return Value

True if the folder exists, false otherwise

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


Populate Method

[image] [image]

OfficeClip API Documentation
UsersDB..::.Populate Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Populate(String, String) | Constructor to create an instance from the xml file
Public method | Populate(OCServiceType, OCServiceType, Int32) | Constructor to create an instance from the database

See Also

UsersDB Class
UsersDB Members
OfficeClip.DBLayer.Service Namespace


Populate Method (String, String)

[image]

OfficeClip API Documentation
UsersDB..::.Populate Method (String, String)
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the xml file

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCUsers Populate(
    string xmlFile,
    string schemaPath
)
Visual Basic (Declaration)
Public Function Populate ( _
    xmlFile As String, _
    schemaPath As String _
) As OCUsers
Visual C++
public:
OCUsers^ Populate(
    String^ xmlFile,
    String^ schemaPath
)

Parameters

xmlFile
Type: System..::.String
The xml file
schemaPath
Type: System..::.String
The path of the schema file

Return Value

The service users object

See Also

UsersDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


Populate Method (OCServiceType, OCServiceType, Int32)

[image]

OfficeClip API Documentation
UsersDB..::.Populate Method (OCServiceType, OCServiceType, Int32)
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Constructor to create an instance from the database

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCUsers Populate(
    OCServiceType priSerType,
    OCServiceType secSerType,
    int groupId
)
Visual Basic (Declaration)
Public Function Populate ( _
    priSerType As OCServiceType, _
    secSerType As OCServiceType, _
    groupId As Integer _
) As OCUsers
Visual C++
public:
OCUsers^ Populate(
    OCServiceType priSerType,
    OCServiceType secSerType,
    int groupId
)

Parameters

priSerType
Type: OfficeClip.Utils..::.OCServiceType
The primary service type object
secSerType
Type: OfficeClip.Utils..::.OCServiceType
Teh secondary service type object
groupId
Type: System..::.Int32
The unique id of the group

Return Value

Teh service user object

See Also

UsersDB Class
Populate Overload
OfficeClip.DBLayer.Service Namespace


SetChanges Method

[image]

OfficeClip API Documentation
UsersDB..::.SetChanges Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the changes

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap[] SetChanges(
    string folderId,
    int loggedInUserId,
    OCUser[] changes,
    int groupId,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function SetChanges ( _
    folderId As String, _
    loggedInUserId As Integer, _
    changes As OCUser(), _
    groupId As Integer, _
    isAdmin As Boolean _
) As OCMap()
Visual C++
public:
array<OCMap^>^ SetChanges(
    String^ folderId,
    int loggedInUserId,
    array<OCUser^>^ changes,
    int groupId,
    bool isAdmin
)

Parameters

folderId
Type: System..::.String
The unique id of the folder
loggedInUserId
Type: System..::.Int32
The unique id of the logged in user
changes
Type: array< OfficeClip.BusinessLayer.Service..::.OCUser >[]()[]
The array of the service user objects representing the changes
groupId
Type: System..::.Int32
The unique id of the organization
isAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

The array of the service map object

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


UpdateDb Method

[image]

OfficeClip API Documentation
UsersDB..::.UpdateDb Method
UsersDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database from the created object

Namespace: OfficeClip.DBLayer.Service
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public OCMap[] UpdateDb(
    int loggedInUserId,
    int groupId,
    OCUsers ocus,
    OCServiceImportPolicy policy,
    bool isAdmin
)
Visual Basic (Declaration)
Public Function UpdateDb ( _
    loggedInUserId As Integer, _
    groupId As Integer, _
    ocus As OCUsers, _
    policy As OCServiceImportPolicy, _
    isAdmin As Boolean _
) As OCMap()
Visual C++
public:
array<OCMap^>^ UpdateDb(
    int loggedInUserId,
    int groupId,
    OCUsers^ ocus,
    OCServiceImportPolicy policy,
    bool isAdmin
)

Parameters

loggedInUserId
Type: System..::.Int32
The unique id of the logged in user
groupId
Type: System..::.Int32
The unique id of the group
ocus
Type: OfficeClip.BusinessLayer.Service..::.OCUsers
The OfficeClip Service Users Object
policy
Type: OfficeClip.Utils..::.OCServiceImportPolicy
The update policy
isAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

Returns success or failure values

See Also

UsersDB Class
OfficeClip.DBLayer.Service Namespace


OfficeClip.DBLayer.TE Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.TE Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClipTtimesheet and Expenses

Classes

 | Class | Description
Public class | CommonDB | Provides a set of Time and Expenses application common functions.
Public class | ExpenseDB | Provides a set of Time and Expenses application related functions.
Public class | PaymentsDB | Provides Database functions for Payment and Reimbursement
Public class | PunchDB | Summary description for the rules engine.
Public class | QuickBooksDB | Provides a set of Time and Expenses application related functions.
Public class | TimesheetDB | Provides a set of Time and Expenses application related functions.


CommonDB Class

[image]

OfficeClip API Documentation
CommonDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Time and Expenses application common functions.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class CommonDB : OfficeClipDB
Visual Basic (Declaration)
Public Class CommonDB _
    Inherits OfficeClipDB
Visual C++
public ref class CommonDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.TE..::.CommonDB

See Also

CommonDB Members
OfficeClip.DBLayer.TE Namespace


CommonDB Members

[image] [image]

OfficeClip API Documentation
CommonDB Members
CommonDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The CommonDB type exposes the following members.

Constructors

 | Name | Description
Public method | CommonDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ArchiveItem | Archives either a particular timesheet or an expense based on the application id provided.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeletePayrollCategory | Deletes the payroll category
Public method | DeleteTeRates | Delete the rate
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDCAAHistory | Gets the DCAA history
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetInBoxOutBoxList | Gets all the inbox and outbox items for both the time and expenses.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPayrollList | Gets the payroll list
Public method | GetPayrollOverheads | Returns the payroll overheads
Public method | GetTERates | Gets the rates for all the user in the group
Public method | GetTEReadonly | Gets the Timesheet/Expense Readonly status
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertPayrollCategory | Inserts a new payroll category for a group
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdatePayrollCategory | Updates a payroll category
Public method | UpdateTeRates | Updates the billing rates
Public method | UpdTePayrollOverheads | Overloaded.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


CommonDB Constructor

[image]

OfficeClip API Documentation
CommonDB Constructor
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public CommonDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CommonDB()

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


CommonDB Methods

[image] [image]

OfficeClip API Documentation
CommonDB Methods
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

The CommonDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ArchiveItem | Archives either a particular timesheet or an expense based on the application id provided.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeletePayrollCategory | Deletes the payroll category
Public method | DeleteTeRates | Delete the rate
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDCAAHistory | Gets the DCAA history
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetInBoxOutBoxList | Gets all the inbox and outbox items for both the time and expenses.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPayrollList | Gets the payroll list
Public method | GetPayrollOverheads | Returns the payroll overheads
Public method | GetTERates | Gets the rates for all the user in the group
Public method | GetTEReadonly | Gets the Timesheet/Expense Readonly status
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertPayrollCategory | Inserts a new payroll category for a group
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdatePayrollCategory | Updates a payroll category
Public method | UpdateTeRates | Updates the billing rates
Public method | UpdTePayrollOverheads | Overloaded.

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
CommonDB..::.AddOutputParameter Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

CommonDB Class
CommonDB Members
OfficeClip.DBLayer.TE Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
CommonDB..::.AddParameter Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

CommonDB Class
CommonDB Members
OfficeClip.DBLayer.TE Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
CommonDB..::.AddParameters Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

CommonDB Class
CommonDB Members
OfficeClip.DBLayer.TE Namespace


ArchiveItem Method

[image]

OfficeClip API Documentation
CommonDB..::.ArchiveItem Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Archives either a particular timesheet or an expense based on the application id provided.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int ArchiveItem(
    int id,
    Constants..::.ApplicationType aType,
    bool isRestore,
    int currentUserId
)
Visual Basic (Declaration)
Public Function ArchiveItem ( _
    id As Integer, _
    aType As Constants..::.ApplicationType, _
    isRestore As Boolean, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int ArchiveItem(
    int id,
    Constants..::.ApplicationType aType,
    bool isRestore,
    int currentUserId
)

Parameters

id
Type: System..::.Int32
Id of a particular timesheet or expense.
aType
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
The application type
isRestore
Type: System..::.Boolean
true if it is really a restore operation and not archive operation
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

0 when successful, -1 in case of a general error, -2 when this timesheet or expense can not be archived because it is still pending in the workflow process.

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


DeletePayrollCategory Method

[image]

OfficeClip API Documentation
CommonDB..::.DeletePayrollCategory Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the payroll category

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeletePayrollCategory(
    int payrollCategoryId
)
Visual Basic (Declaration)
Public Sub DeletePayrollCategory ( _
    payrollCategoryId As Integer _
)
Visual C++
public:
void DeletePayrollCategory(
    int payrollCategoryId
)

Parameters

payrollCategoryId
Type: System..::.Int32
The unique id of the payroll category

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


DeleteTeRates Method

[image]

OfficeClip API Documentation
CommonDB..::.DeleteTeRates Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Delete the rate

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteTeRates(
    int id
)
Visual Basic (Declaration)
Public Sub DeleteTeRates ( _
    id As Integer _
)
Visual C++
public:
void DeleteTeRates(
    int id
)

Parameters

id
Type: System..::.Int32
The unique id

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
CommonDB..::.ExecuteNonQuery Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

CommonDB Class
CommonDB Members
OfficeClip.DBLayer.TE Namespace


GetDCAAHistory Method

[image]

OfficeClip API Documentation
CommonDB..::.GetDCAAHistory Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the DCAA history

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetDCAAHistory(
    int id,
    Constants..::.ApplicationType aType
)
Visual Basic (Declaration)
Public Function GetDCAAHistory ( _
    id As Integer, _
    aType As Constants..::.ApplicationType _
) As DataTable
Visual C++
public:
DataTable^ GetDCAAHistory(
    int id,
    Constants..::.ApplicationType aType
)

Parameters

id
Type: System..::.Int32
aType
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType

Return Value

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


GetInBoxOutBoxList Method

[image]

OfficeClip API Documentation
CommonDB..::.GetInBoxOutBoxList Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the inbox and outbox items for both the time and expenses.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetInBoxOutBoxList(
    bool allGroups,
    string inboxOutbox,
    TESortType teSortBy,
    OCSortDirection sortDir,
    bool showArchived,
    int currentGroupId,
    int currentUserId,
    Constants..::.ApplicationType aType,
    int maximumRows
)
Visual Basic (Declaration)
Public Function GetInBoxOutBoxList ( _
    allGroups As Boolean, _
    inboxOutbox As String, _
    teSortBy As TESortType, _
    sortDir As OCSortDirection, _
    showArchived As Boolean, _
    currentGroupId As Integer, _
    currentUserId As Integer, _
    aType As Constants..::.ApplicationType, _
    maximumRows As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetInBoxOutBoxList(
    bool allGroups,
    String^ inboxOutbox,
    TESortType teSortBy,
    OCSortDirection sortDir,
    bool showArchived,
    int currentGroupId,
    int currentUserId,
    Constants..::.ApplicationType aType,
    int maximumRows
)

Parameters

allGroups
Type: System..::.Boolean
Flag (True/False) indicating whether items corresponding to all groups where the currently logged in user is a member of should be returned or only the currently selected group's items should be returned.
inboxOutbox
Type: System..::.String
The type of the box
teSortBy
Type: OfficeClip.Utils..::.TESortType
The field on which to sort the result. TESortType
sortDir
Type: OfficeClip.Utils..::.OCSortDirection
The Direction in which the results should be sorted. OCSortDirection
showArchived
Type: System..::.Boolean
Flag (True/False) indicating whether to show archived items or not.
currentGroupId
Type: System..::.Int32
The id of the current organization
currentUserId
Type: System..::.Int32
The unique id of the current user
aType
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
The application type
maximumRows
Type: System..::.Int32

Return Value

DataSet containing all the information related inbox and outbox items for Time and Expenses. This DataSet consists of a single DataTable with the following columns.
  • itemId (System.Int32)Id of either the timesheet or the expense.
  • itemType (System.String)Flag (T/E) indicating whether the item is corresponding to a timesheet or an expense.
  • StatusId (System.Int32)Id of the Current status of the particular timesheet or expense.
  • status (System.String)Name of the status of the Current
  • isModifiable (System.String)Flag (Y/N) indicating whether a particular item (timesheet or expense) is modifiable by the currently logged in user.
  • cellBgcolor (System.String)Background color of the cell which distinguishes whether an item is a timesheet or an expense.
  • WorkflowTypeId (System.Int32)Id of the workflow type with which the particular item (timesheet or expense) was created.
  • StageId (System.Int32)Id of the stage in which the particular item is present i.e. first stage, second stage etc. (if it is a part of multi stage workflow.)
  • name (System.String)Name of the user to which this particular item belongs.
  • IsNew (System.Int32)Flag (1/0) indicating whether this particular item is newly created and the Current user is looking at it for the first time.
  • weekStarting (System.DateTime)Starting Date of the time period for which this particular item was created.
  • groupName (System.String)Name of the group for which this particular item is created.
  • totalValue (System.Decimal)Total Amount or the total number of hours for this expense or timesheet respectively.
  • applicationId (System.Int32)Id of the application for which this particular item was created.
  • isPending (System.Int32)Flag (0 or > 0) indicating whether there are other items pending related to this particular timesheet or expense in some other user's inbox.
  • Comments (System.String)Comments text of the last user who updated this particular item in the workflow.

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


GetPayrollList Method

[image]

OfficeClip API Documentation
CommonDB..::.GetPayrollList Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the payroll list

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PayrollCategoryInfo[] GetPayrollList(
    int groupId,
    int userId,
    int payrollCategoryId
)
Visual Basic (Declaration)
Public Function GetPayrollList ( _
    groupId As Integer, _
    userId As Integer, _
    payrollCategoryId As Integer _
) As PayrollCategoryInfo()
Visual C++
public:
array<PayrollCategoryInfo^>^ GetPayrollList(
    int groupId,
    int userId,
    int payrollCategoryId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user. Only returns active category for the user. If -1 returns categories all categories for all users
payrollCategoryId
Type: System..::.Int32
The unique id of the payroll category, if -1 returns all the categories

Return Value

The array of the payroll category object

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


GetPayrollOverheads Method

[image]

OfficeClip API Documentation
CommonDB..::.GetPayrollOverheads Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the payroll overheads

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetPayrollOverheads(
    int groupId,
    int payrollCategoryId
)
Visual Basic (Declaration)
Public Function GetPayrollOverheads ( _
    groupId As Integer, _
    payrollCategoryId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetPayrollOverheads(
    int groupId,
    int payrollCategoryId
)

Parameters

groupId
Type: System..::.Int32
Theunique id of the group
payrollCategoryId
Type: System..::.Int32
The unique id of the payroll category

Return Value

The datatable of payroll overheads

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


GetTERates Method

[image]

OfficeClip API Documentation
CommonDB..::.GetTERates Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the rates for all the user in the group

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTERates(
    int groupId,
    bool isLatest
)
Visual Basic (Declaration)
Public Function GetTERates ( _
    groupId As Integer, _
    isLatest As Boolean _
) As DataSet
Visual C++
public:
DataSet^ GetTERates(
    int groupId,
    bool isLatest
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
isLatest
Type: System..::.Boolean
Shows if only the latest rates are required

Return Value

The dataset for the rates for the group

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


GetTEReadonly Method

[image]

OfficeClip API Documentation
CommonDB..::.GetTEReadonly Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Timesheet/Expense Readonly status

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool GetTEReadonly(
    int id,
    Constants..::.ApplicationType aType,
    int stageId
)
Visual Basic (Declaration)
Public Function GetTEReadonly ( _
    id As Integer, _
    aType As Constants..::.ApplicationType, _
    stageId As Integer _
) As Boolean
Visual C++
public:
bool GetTEReadonly(
    int id,
    Constants..::.ApplicationType aType,
    int stageId
)

Parameters

id
Type: System..::.Int32
aType
Type: OfficeClip.BusinessLayer.Framework..::.Constants..::.ApplicationType
stageId
Type: System..::.Int32

Return Value

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
CommonDB..::.InitTransaction Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

CommonDB Class
CommonDB Members
OfficeClip.DBLayer.TE Namespace


InsertPayrollCategory Method

[image]

OfficeClip API Documentation
CommonDB..::.InsertPayrollCategory Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new payroll category for a group

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertPayrollCategory(
    int groupId,
    PayrollCategoryInfo pci
)
Visual Basic (Declaration)
Public Function InsertPayrollCategory ( _
    groupId As Integer, _
    pci As PayrollCategoryInfo _
) As Integer
Visual C++
public:
int InsertPayrollCategory(
    int groupId,
    PayrollCategoryInfo^ pci
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group
pci
Type: OfficeClip.BusinessLayer.TE..::.PayrollCategoryInfo
The payroll category information

Return Value

The newly created payroll id if successful, -1 if failed

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
CommonDB..::.SetSPCommand Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

CommonDB Class
CommonDB Members
OfficeClip.DBLayer.TE Namespace


UpdatePayrollCategory Method

[image]

OfficeClip API Documentation
CommonDB..::.UpdatePayrollCategory Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates a payroll category

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdatePayrollCategory(
    PayrollCategoryInfo pci
)
Visual Basic (Declaration)
Public Function UpdatePayrollCategory ( _
    pci As PayrollCategoryInfo _
) As Integer
Visual C++
public:
int UpdatePayrollCategory(
    PayrollCategoryInfo^ pci
)

Parameters

pci
Type: OfficeClip.BusinessLayer.TE..::.PayrollCategoryInfo
The payroll category id

Return Value

-1 if error, 0 if successful

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


UpdateTeRates Method

[image]

OfficeClip API Documentation
CommonDB..::.UpdateTeRates Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the billing rates

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateTeRates(
    int groupId,
    int userId,
    int accountId,
    DateTime effectiveDate,
    double cost,
    double billingRate
)
Visual Basic (Declaration)
Public Sub UpdateTeRates ( _
    groupId As Integer, _
    userId As Integer, _
    accountId As Integer, _
    effectiveDate As DateTime, _
    cost As Double, _
    billingRate As Double _
)
Visual C++
public:
void UpdateTeRates(
    int groupId,
    int userId,
    int accountId,
    DateTime effectiveDate,
    double cost,
    double billingRate
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of the user
accountId
Type: System..::.Int32
The unique id of the customer
effectiveDate
Type: System..::.DateTime
The effective date when the rates becomes effective
cost
Type: System..::.Double
The cost
billingRate
Type: System..::.Double
The billing rate

See Also

CommonDB Class
OfficeClip.DBLayer.TE Namespace


UpdTePayrollOverheads Method

[image] [image]

OfficeClip API Documentation
CommonDB..::.UpdTePayrollOverheads Method
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | UpdTePayrollOverheads(DataTable, Int32) | Update the payroll overheads
Public method | UpdTePayrollOverheads(Int32, Boolean) | Updates the payroll overheads
Public method | UpdTePayrollOverheads(Int32, Int32, Double, Double, Boolean) | Updates the Timesheet payroll overheads

See Also

CommonDB Class
CommonDB Members
OfficeClip.DBLayer.TE Namespace


UpdTePayrollOverheads Method (DataTable, Int32)

[image]

OfficeClip API Documentation
CommonDB..::.UpdTePayrollOverheads Method (DataTable, Int32)
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Update the payroll overheads

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdTePayrollOverheads(
    DataTable dt,
    int payrollCategoryId
)
Visual Basic (Declaration)
Public Sub UpdTePayrollOverheads ( _
    dt As DataTable, _
    payrollCategoryId As Integer _
)
Visual C++
public:
void UpdTePayrollOverheads(
    DataTable^ dt,
    int payrollCategoryId
)

Parameters

dt
Type: System.Data..::.DataTable
The datatable of overheads
payrollCategoryId
Type: System..::.Int32
The unique id of the payroll category

See Also

CommonDB Class
UpdTePayrollOverheads Overload
OfficeClip.DBLayer.TE Namespace


UpdTePayrollOverheads Method (Int32, Boolean)

[image]

OfficeClip API Documentation
CommonDB..::.UpdTePayrollOverheads Method (Int32, Boolean)
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the payroll overheads

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdTePayrollOverheads(
    int timesheetId,
    bool isAdd
)
Visual Basic (Declaration)
Public Sub UpdTePayrollOverheads ( _
    timesheetId As Integer, _
    isAdd As Boolean _
)
Visual C++
public:
void UpdTePayrollOverheads(
    int timesheetId,
    bool isAdd
)

Parameters

timesheetId
Type: System..::.Int32
isAdd
Type: System..::.Boolean

See Also

CommonDB Class
UpdTePayrollOverheads Overload
OfficeClip.DBLayer.TE Namespace


UpdTePayrollOverheads Method (Int32, Int32, Double, Double, Boolean)

[image]

OfficeClip API Documentation
CommonDB..::.UpdTePayrollOverheads Method (Int32, Int32, Double, Double, Boolean)
CommonDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the Timesheet payroll overheads

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdTePayrollOverheads(
    int payrollCategoryId,
    int userId,
    double availableTime,
    double usedTime,
    bool isActive
)
Visual Basic (Declaration)
Public Sub UpdTePayrollOverheads ( _
    payrollCategoryId As Integer, _
    userId As Integer, _
    availableTime As Double, _
    usedTime As Double, _
    isActive As Boolean _
)
Visual C++
public:
void UpdTePayrollOverheads(
    int payrollCategoryId,
    int userId,
    double availableTime,
    double usedTime,
    bool isActive
)

Parameters

payrollCategoryId
Type: System..::.Int32
The unique id of the payroll category
userId
Type: System..::.Int32
The unique id of the user
availableTime
Type: System..::.Double
The available time
usedTime
Type: System..::.Double
The used time
isActive
Type: System..::.Boolean
true, if the overhead is active

See Also

CommonDB Class
UpdTePayrollOverheads Overload
OfficeClip.DBLayer.TE Namespace


ExpenseDB Class

[image]

OfficeClip API Documentation
ExpenseDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Time and Expenses application related functions.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class ExpenseDB : OfficeClipDB
Visual Basic (Declaration)
Public Class ExpenseDB _
    Inherits OfficeClipDB
Visual C++
public ref class ExpenseDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.TE..::.ExpenseDB

See Also

ExpenseDB Members
OfficeClip.DBLayer.TE Namespace


ExpenseDB Members

[image] [image]

OfficeClip API Documentation
ExpenseDB Members
ExpenseDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ExpenseDB type exposes the following members.

Constructors

 | Name | Description
Public method | ExpenseDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteExpense | Deletes a particular expense identified by ExpenseId.
Public method | DeleteExpenseDetails | Deletes all the details corresponding to a particular expense identified by ExpenseId.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveExpenseRows | Gets a list of number of rows specified in the currently Active in the group.
Public method | GetActiveExpenseTypesInfo | Gets all the information related to the currently Active expense types corresponding to a particular group.
Public method | GetAirfareExpenseDetailInfo | Gets all the details for an airfare type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseAirfareInfo object as input.
Public method | GetAllExpenseTypes | Gets a list of all the expense types defined for a particular expense identified by the expenseId.
Public method | GetAllExpenseTypesInfo | Gets the all the information of expense types used in the expense with expenseId.
Public method | GetAutorentalExpenseDetailInfo | Gets all the details for an auto rental type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseAutorentalInfo object as input.
Public method | GetExpenseAlreadyExists | Checks for a given start date, whether an expense has already been created by a particular user corresponding to a particular group.
Public method | GetExpenseComments | Gets a list of all Comments corresponding to a particular expense.
Public method | GetExpenseDetails | Gets all the expense details items created within a particular expense identified by ExpenseId.
Public method | GetExpenseDetailsForCSV | Gets all the expense details items created within a particular expense identified by ExpenseId.
Public method | GetExpenseInfo | Gets all the details related to a particular expense identified by ExpenseId.
Public method | GetExpenseInfoComments | Gets all the Comments corresponding to a particular expense identified by ExpenseId.
Public method | GetExpenseRows | Gets a list of number of rows specified in a particular expense types.
Public method | GetExpenses | Gets a list of all the expenses for a set of users between a given date range for a particular group.
Public method | GetExpensesForExport | Gets a set of expenses which are ready to be exported which were created within a given Date range from a particular group.
Public method | GetExpenseTypeById | Gets the expense types for an expense type id.
Public method | GetExpenseTypeInfo | Gets all the details corresponding to a particular expense type.
Public method | GetExpenseTypeList | Gets a list of all the expense types defined in the Active expense types for a particular group.
Public method | GetExpenseTypes | Overloaded.
Public method | GetExpenseTypesForRdlc | List of expense types available for a group (used for rdl reports)
Public method | GetExpenseTypesInfoForExpenseId | Gets the expense types for expenseId, if the expenseId is -1 then gets the expense types for the groupId.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetHotelExpenseDetailInfo | Gets all the details for an hotel type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseHotelInfo object as input.
Public method | GetLastExpenseInfo | Gets all the informatin related to the most recent expense created by a particular user corresponding to a particular group.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTaxiExpenseDetailInfo | Gets all the details for a taxi type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseTaxiInfo object as input.
Public method | GetTelephoneExpenseDetailInfo | Gets all the details for a telephone type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseTelephoneInfo object as input.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertExpense | Inserts a new expense into the database and routes it to a particular user as defined in the workflow.
Public method | InsertExpenseAirfareInfo | Inserts airfare expense detail item crated inside an expense into the database.
Public method | InsertExpenseAutorentalInfo | Inserts auto rental expense detail item created inside an expense into the database.
Public method | InsertExpenseCommentInfo | Inserts a new expense Comment created inside an expense
Public method | InsertExpenseDetailInfo | Inserts individual expense detail items inside an expense into the database.
Public method | InsertExpenseHotelInfo | Inserts hotel expense detail item crated inside an expense into the database.
Public method | InsertExpenseInfo | Inserts a new expense into the database.
Public method | InsertExpenseTaxiInfo | Inserts taxi expense detail item created inside an expense into the database.
Public method | InsertExpenseTelephoneInfo | Inserts telephone expense detail item created inside an expense into the database.
Public method | InsertExpenseTypeInfo | Inserts all the information related to a expense type.
Public method | InsertExpenseTypes | Inserts all the information related to a expense types corresponding to a a particular group.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetExpenseExported | Sets the expired status of the expense
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateExpense | Updates all the details realted to a particular expense into the database and routes it to a particular user as defined in the workflow.
Public method | UpdateExpenseCommentInfo | Updates an expense Comment defined inside an expense.
Public method | UpdateExpenseTypeInfo | Inserts all the information related to a expense types.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


ExpenseDB Constructor

[image]

OfficeClip API Documentation
ExpenseDB Constructor
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExpenseDB()

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


ExpenseDB Methods

[image] [image]

OfficeClip API Documentation
ExpenseDB Methods
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

The ExpenseDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteExpense | Deletes a particular expense identified by ExpenseId.
Public method | DeleteExpenseDetails | Deletes all the details corresponding to a particular expense identified by ExpenseId.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveExpenseRows | Gets a list of number of rows specified in the currently Active in the group.
Public method | GetActiveExpenseTypesInfo | Gets all the information related to the currently Active expense types corresponding to a particular group.
Public method | GetAirfareExpenseDetailInfo | Gets all the details for an airfare type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseAirfareInfo object as input.
Public method | GetAllExpenseTypes | Gets a list of all the expense types defined for a particular expense identified by the expenseId.
Public method | GetAllExpenseTypesInfo | Gets the all the information of expense types used in the expense with expenseId.
Public method | GetAutorentalExpenseDetailInfo | Gets all the details for an auto rental type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseAutorentalInfo object as input.
Public method | GetExpenseAlreadyExists | Checks for a given start date, whether an expense has already been created by a particular user corresponding to a particular group.
Public method | GetExpenseComments | Gets a list of all Comments corresponding to a particular expense.
Public method | GetExpenseDetails | Gets all the expense details items created within a particular expense identified by ExpenseId.
Public method | GetExpenseDetailsForCSV | Gets all the expense details items created within a particular expense identified by ExpenseId.
Public method | GetExpenseInfo | Gets all the details related to a particular expense identified by ExpenseId.
Public method | GetExpenseInfoComments | Gets all the Comments corresponding to a particular expense identified by ExpenseId.
Public method | GetExpenseRows | Gets a list of number of rows specified in a particular expense types.
Public method | GetExpenses | Gets a list of all the expenses for a set of users between a given date range for a particular group.
Public method | GetExpensesForExport | Gets a set of expenses which are ready to be exported which were created within a given Date range from a particular group.
Public method | GetExpenseTypeById | Gets the expense types for an expense type id.
Public method | GetExpenseTypeInfo | Gets all the details corresponding to a particular expense type.
Public method | GetExpenseTypeList | Gets a list of all the expense types defined in the Active expense types for a particular group.
Public method | GetExpenseTypes | Overloaded.
Public method | GetExpenseTypesForRdlc | List of expense types available for a group (used for rdl reports)
Public method | GetExpenseTypesInfoForExpenseId | Gets the expense types for expenseId, if the expenseId is -1 then gets the expense types for the groupId.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetHotelExpenseDetailInfo | Gets all the details for an hotel type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseHotelInfo object as input.
Public method | GetLastExpenseInfo | Gets all the informatin related to the most recent expense created by a particular user corresponding to a particular group.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetTaxiExpenseDetailInfo | Gets all the details for a taxi type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseTaxiInfo object as input.
Public method | GetTelephoneExpenseDetailInfo | Gets all the details for a telephone type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseTelephoneInfo object as input.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertExpense | Inserts a new expense into the database and routes it to a particular user as defined in the workflow.
Public method | InsertExpenseAirfareInfo | Inserts airfare expense detail item crated inside an expense into the database.
Public method | InsertExpenseAutorentalInfo | Inserts auto rental expense detail item created inside an expense into the database.
Public method | InsertExpenseCommentInfo | Inserts a new expense Comment created inside an expense
Public method | InsertExpenseDetailInfo | Inserts individual expense detail items inside an expense into the database.
Public method | InsertExpenseHotelInfo | Inserts hotel expense detail item crated inside an expense into the database.
Public method | InsertExpenseInfo | Inserts a new expense into the database.
Public method | InsertExpenseTaxiInfo | Inserts taxi expense detail item created inside an expense into the database.
Public method | InsertExpenseTelephoneInfo | Inserts telephone expense detail item created inside an expense into the database.
Public method | InsertExpenseTypeInfo | Inserts all the information related to a expense type.
Public method | InsertExpenseTypes | Inserts all the information related to a expense types corresponding to a a particular group.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetExpenseExported | Sets the expired status of the expense
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateExpense | Updates all the details realted to a particular expense into the database and routes it to a particular user as defined in the workflow.
Public method | UpdateExpenseCommentInfo | Updates an expense Comment defined inside an expense.
Public method | UpdateExpenseTypeInfo | Inserts all the information related to a expense types.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
ExpenseDB..::.AddOutputParameter Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

ExpenseDB Class
ExpenseDB Members
OfficeClip.DBLayer.TE Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
ExpenseDB..::.AddParameter Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

ExpenseDB Class
ExpenseDB Members
OfficeClip.DBLayer.TE Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
ExpenseDB..::.AddParameters Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

ExpenseDB Class
ExpenseDB Members
OfficeClip.DBLayer.TE Namespace


DeleteExpense Method

[image]

OfficeClip API Documentation
ExpenseDB..::.DeleteExpense Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a particular expense identified by ExpenseId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteExpense(
    int expenseId,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function DeleteExpense ( _
    expenseId As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
) As Integer
Visual C++
public:
int DeleteExpense(
    int expenseId,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

expenseId
Type: System..::.Int32
Id of the expense which needs to be deleted.
currentUserId
Type: System..::.Int32
The unique id of the current user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


DeleteExpenseDetails Method

[image]

OfficeClip API Documentation
ExpenseDB..::.DeleteExpenseDetails Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all the details corresponding to a particular expense identified by ExpenseId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteExpenseDetails(
    int expenseId
)
Visual Basic (Declaration)
Public Function DeleteExpenseDetails ( _
    expenseId As Integer _
) As Integer
Visual C++
public:
int DeleteExpenseDetails(
    int expenseId
)

Parameters

expenseId
Type: System..::.Int32
Id of a particular expense for which all the details are to be deleted.

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
ExpenseDB..::.ExecuteNonQuery Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

ExpenseDB Class
ExpenseDB Members
OfficeClip.DBLayer.TE Namespace


GetActiveExpenseRows Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetActiveExpenseRows Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of number of rows specified in the currently Active in the group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetActiveExpenseRows(
    int currentGroupId
)
Visual Basic (Declaration)
Public Function GetActiveExpenseRows ( _
    currentGroupId As Integer _
) As DataView
Visual C++
public:
DataView^ GetActiveExpenseRows(
    int currentGroupId
)

Parameters

currentGroupId
Type: System..::.Int32

Return Value

DataView consisting a single column called rowNumber (System.Int32).

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetActiveExpenseTypesInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetActiveExpenseTypesInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to the currently Active expense types corresponding to a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GroupExpenseTypeInfo GetActiveExpenseTypesInfo(
    int groupId
)
Visual Basic (Declaration)
Public Function GetActiveExpenseTypesInfo ( _
    groupId As Integer _
) As GroupExpenseTypeInfo
Visual C++
public:
GroupExpenseTypeInfo^ GetActiveExpenseTypesInfo(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.

Return Value

Instance of the GroupExpenseTypeInfo object containing all the information of expense types related to the group. GroupExpenseTypeInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetAirfareExpenseDetailInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetAirfareExpenseDetailInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details for an airfare type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseAirfareInfo object as input.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseAirfareInfo GetAirfareExpenseDetailInfo(
    ExpenseAirfareInfo eafi
)
Visual Basic (Declaration)
Public Function GetAirfareExpenseDetailInfo ( _
    eafi As ExpenseAirfareInfo _
) As ExpenseAirfareInfo
Visual C++
public:
ExpenseAirfareInfo^ GetAirfareExpenseDetailInfo(
    ExpenseAirfareInfo^ eafi
)

Parameters

eafi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseAirfareInfo
Instance of the ExpenseAirfareInfo object containing the ExpenseId and ExpenseDetailId corresponding to which the details of a particular Airfare expense item are to be retrieved.

Return Value

Instance of ExpenseAirfareInfo object containing all the details of a particular Airfare expense item. ExpenseAirfareInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetAllExpenseTypes Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetAllExpenseTypes Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the expense types defined for a particular expense identified by the expenseId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetAllExpenseTypes(
    int groupId,
    int expenseId
)
Visual Basic (Declaration)
Public Function GetAllExpenseTypes ( _
    groupId As Integer, _
    expenseId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetAllExpenseTypes(
    int groupId,
    int expenseId
)

Parameters

groupId
Type: System..::.Int32
The Unique Id of the group
expenseId
Type: System..::.Int32
Id of the expense.

Return Value

ArrayList of ExpenseTypeInfo objects containing all the information related to the all the expense types defined for a particular expense. ExpenseTypeInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetAllExpenseTypesInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetAllExpenseTypesInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the all the information of expense types used in the expense with expenseId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GroupExpenseTypeInfo GetAllExpenseTypesInfo(
    int groupId,
    int expenseId
)
Visual Basic (Declaration)
Public Function GetAllExpenseTypesInfo ( _
    groupId As Integer, _
    expenseId As Integer _
) As GroupExpenseTypeInfo
Visual C++
public:
GroupExpenseTypeInfo^ GetAllExpenseTypesInfo(
    int groupId,
    int expenseId
)

Parameters

groupId
Type: System..::.Int32
Unique Id of the group
expenseId
Type: System..::.Int32
Id of the expense for which all the expense types needs to be retrieved.

Return Value

Instance of the GroupExpenseTypeInfo object containing all the information related to expense types. GroupExpenseTypeInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetAutorentalExpenseDetailInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetAutorentalExpenseDetailInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details for an auto rental type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseAutorentalInfo object as input.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseAutorentalInfo GetAutorentalExpenseDetailInfo(
    ExpenseAutorentalInfo eari
)
Visual Basic (Declaration)
Public Function GetAutorentalExpenseDetailInfo ( _
    eari As ExpenseAutorentalInfo _
) As ExpenseAutorentalInfo
Visual C++
public:
ExpenseAutorentalInfo^ GetAutorentalExpenseDetailInfo(
    ExpenseAutorentalInfo^ eari
)

Parameters

eari
Type: OfficeClip.BusinessLayer.TE..::.ExpenseAutorentalInfo
Instance of the ExpenseAutorentalInfo object containing the ExpenseId and ExpenseDetailId corresponding to which the details of a particular Auto rental expense item are to be retrieved.

Return Value

Instance of ExpenseAutorentalInfo object containing all the details of a particular Auto rental expense item. ExpenseAutorentalInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseAlreadyExists Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseAlreadyExists Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks for a given start date, whether an expense has already been created by a particular user corresponding to a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool GetExpenseAlreadyExists(
    int userId,
    int groupId,
    DateTime weekStartDate
)
Visual Basic (Declaration)
Public Function GetExpenseAlreadyExists ( _
    userId As Integer, _
    groupId As Integer, _
    weekStartDate As DateTime _
) As Boolean
Visual C++
public:
bool GetExpenseAlreadyExists(
    int userId,
    int groupId,
    DateTime weekStartDate
)

Parameters

userId
Type: System..::.Int32
The unique id for the user. Please note that the user should belong to the group whose id is passed as argument.
groupId
Type: System..::.Int32
The unique id for the group.
weekStartDate
Type: System..::.DateTime
Week starting date.

Return Value

Flag (True/False) indicating whether an expense has already been created or not for the given week starting date.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseComments Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseComments Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all Comments corresponding to a particular expense.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetExpenseComments(
    int expenseId
)
Visual Basic (Declaration)
Public Function GetExpenseComments ( _
    expenseId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetExpenseComments(
    int expenseId
)

Parameters

expenseId
Type: System..::.Int32
Id of the expense.

Return Value

DataSet containing all the information related to the Comments for a particular expense. This DataSet consists of a single DataTable with the following columns.
  • ExpenseId (System.Int32)Id of the timesheet.
  • CommentId (System.Int32)Id of the Comment.
  • UserId (System.Int32)Id of the user giving the Comment.
  • UserName (System.String)Name of the user giving the Comment.
  • Comment (System.String)Comment string.
  • CommentDate (System.DateTime)Date and Time when the Comment was given.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseDetails Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseDetails Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the expense details items created within a particular expense identified by ExpenseId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetExpenseDetails(
    int expenseId
)
Visual Basic (Declaration)
Public Function GetExpenseDetails ( _
    expenseId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetExpenseDetails(
    int expenseId
)

Parameters

expenseId
Type: System..::.Int32
Id of the particular expense.

Return Value

ArrayList of ExpenseDetailInfo, ExpenseAirfareInfo, ExpenseAutorentalInfo, ExpenseHotelInfo, ExpenseTaxiInfo, ExpenseTelephoneInfo objects depending on the type of expense detail item it is. Please note that ExpenseAirfareInfo, ExpenseAutorentalInfo, ExpenseHotelInfo, ExpenseTaxiInfo, ExpenseTelephoneInfo are inherited from ExpenseDetailInfo object. ExpenseDetailInfo ExpenseAirfareInfo ExpenseAutorentalInfo ExpenseHotelInfo ExpenseTaxiInfo ExpenseTelephoneInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseDetailsForCSV Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseDetailsForCSV Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the expense details items created within a particular expense identified by ExpenseId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetExpenseDetailsForCSV(
    int expenseId
)
Visual Basic (Declaration)
Public Function GetExpenseDetailsForCSV ( _
    expenseId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetExpenseDetailsForCSV(
    int expenseId
)

Parameters

expenseId
Type: System..::.Int32
Id of the particular expense.

Return Value

DataTable of expenses details

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details related to a particular expense identified by ExpenseId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseInfo GetExpenseInfo(
    int expenseId
)
Visual Basic (Declaration)
Public Function GetExpenseInfo ( _
    expenseId As Integer _
) As ExpenseInfo
Visual C++
public:
ExpenseInfo^ GetExpenseInfo(
    int expenseId
)

Parameters

expenseId
Type: System..::.Int32
Id of the expense for which all the details of the expense are to be retrieved.

Return Value

Instance of the ExpenseInfo object containing all the information related to a particular expense. ExpenseInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseInfoComments Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseInfoComments Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the Comments corresponding to a particular expense identified by ExpenseId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetExpenseInfoComments(
    int expenseId
)
Visual Basic (Declaration)
Public Function GetExpenseInfoComments ( _
    expenseId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetExpenseInfoComments(
    int expenseId
)

Parameters

expenseId
Type: System..::.Int32
Id of a paricular expense.

Return Value

ArrayList of ExpenseCommentInfo object containing all the Comment information related to the Comments of a paricular expense.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseRows Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseRows Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of number of rows specified in a particular expense types.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetExpenseRows(
    int numRows
)
Visual Basic (Declaration)
Public Function GetExpenseRows ( _
    numRows As Integer _
) As DataView
Visual C++
public:
DataView^ GetExpenseRows(
    int numRows
)

Parameters

numRows
Type: System..::.Int32
Number of rows

Return Value

DataView consisting a single column called rowNumber (System.Int32).

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenses Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenses Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the expenses for a set of users between a given date range for a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetExpenses(
    int groupId,
    string userList,
    DateTime fromDate,
    DateTime toDate,
    bool isRestricted
)
Visual Basic (Declaration)
Public Function GetExpenses ( _
    groupId As Integer, _
    userList As String, _
    fromDate As DateTime, _
    toDate As DateTime, _
    isRestricted As Boolean _
) As DataSet
Visual C++
public:
DataSet^ GetExpenses(
    int groupId,
    String^ userList,
    DateTime fromDate,
    DateTime toDate,
    bool isRestricted
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.
userList
Type: System..::.String
Comma delimited list of userIds for whom the expenses are to be retrieved.
fromDate
Type: System..::.DateTime
Starting Date of the range.
toDate
Type: System..::.DateTime
Ending Date of the range.
isRestricted
Type: System..::.Boolean

Return Value

DataSet containing all the information related to all the expenses for the respective users within the date range. This DataSet consists of a single DataTable with the following columns.
  • Amount (System.Decimal)Total Amount in the expense.
  • ExpenseId (System.Int32)Id of the expense.
  • status (System.String)Current status of the expense.
  • weekStartDate (System.String)Starting date of the expense.
  • name (System.String)User to which the expense belongs.
  • emailAddress (System.String)Email Address of the user.
  • withUserName (System.String)Name of the user to whom this expense is currently submitted.
  • withUserEmailAddress (System.String)Email Address of the user to whom this expense is currently submitted.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpensesForExport Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpensesForExport Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a set of expenses which are ready to be exported which were created within a given Date range from a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetExpensesForExport(
    int groupId,
    DateTime fromDate,
    DateTime toDate
)
Visual Basic (Declaration)
Public Function GetExpensesForExport ( _
    groupId As Integer, _
    fromDate As DateTime, _
    toDate As DateTime _
) As DataSet
Visual C++
public:
DataSet^ GetExpensesForExport(
    int groupId,
    DateTime fromDate,
    DateTime toDate
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.
fromDate
Type: System..::.DateTime
Starting date of the range.
toDate
Type: System..::.DateTime
Ending date of the ranage.

Return Value

DataSet containing all the information related to the timesheets which are ready to be exported. This DataSet consists of a single DataTable with the following columns.
  • expenseId (System.Int32)Id of the expense which is ready to be exported.
  • fromDate (System.DateTime)Starting date of the duration for which the expense was created.
  • toDate (System.DateTime)Ending date of the duration for which the expense was created.
  • createdTimestamp (System.DateTime)The timestamp when the expense was created.
  • createdByUserId (System.Int32)The user id of the user for which the expense was created.
  • name (System.String)Name of the user for which the expense was created.
  • approvedByUser (System.String)Name of the user who has approved the expense.
  • status (System.String)Flag (Y/N) indicating whether this particular expense has already been exported or not.
  • exportTimestamp (System.DateTime)Date and time when the expense was exported.
  • isActive (System.String)Returns "Y" if the expense is active.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseTypeById Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseTypeById Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the expense types for an expense type id.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetExpenseTypeById(
    int expenseTypeId
)
Visual Basic (Declaration)
Public Function GetExpenseTypeById ( _
    expenseTypeId As Integer _
) As String
Visual C++
public:
String^ GetExpenseTypeById(
    int expenseTypeId
)

Parameters

expenseTypeId
Type: System..::.Int32
Expense Type Id

Return Value

Expense type for an expense type id if found, empty string otherwise.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseTypeInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseTypeInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details corresponding to a particular expense type.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseTypeInfo GetExpenseTypeInfo(
    int expenseTypeUniqueId
)
Visual Basic (Declaration)
Public Function GetExpenseTypeInfo ( _
    expenseTypeUniqueId As Integer _
) As ExpenseTypeInfo
Visual C++
public:
ExpenseTypeInfo^ GetExpenseTypeInfo(
    int expenseTypeUniqueId
)

Parameters

expenseTypeUniqueId
Type: System..::.Int32
Unique id of the expense type.

Return Value

Instance of the ExpenseTypeInfo object containing all the information for a particlar expense type. ExpenseTypeInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseTypeList Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseTypeList Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the expense types defined in the Active expense types for a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetExpenseTypeList(
    int groupId
)
Visual Basic (Declaration)
Public Function GetExpenseTypeList ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetExpenseTypeList(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.

Return Value

DataSet containing all the expense type information. This DataSet consists of a single DataTable with the following columns.
  • expenseTypeId (System.Int32)Id of the expense type.
  • expenseName (System.String)Name of the expense.
  • isDetailMandatory (System.String)Flag (Y/N) indicating whether details should be mandatorily provided if the user selects this expense type.
  • isBillable (System.String)Flag (Y/N) indicating whether this expense type is billable.
  • allowBillableModify (System.String)Flag (Y/N) indicating whether the user creating the expense can change the billable option other than the default set by the group administrator.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseTypes Method

[image] [image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseTypes Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetExpenseTypes()()() | Gets all the details corresponding to all the expense types as defined in the ExpenseTypes.xml resource file. For more information on how to use and learn more about this please refer to the OfficeClip level 1 customization in the OfficeClip customization document.
Public method | GetExpenseTypes(Int32, Int32) |

See Also

ExpenseDB Class
ExpenseDB Members
OfficeClip.DBLayer.TE Namespace


GetExpenseTypes Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseTypes Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details corresponding to all the expense types as defined in the ExpenseTypes.xml resource file. For more information on how to use and learn more about this please refer to the OfficeClip level 1 customization in the OfficeClip customization document.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetExpenseTypes()
Visual Basic (Declaration)
Public Function GetExpenseTypes As DataSet
Visual C++
public:
DataSet^ GetExpenseTypes()

Return Value

DataSet corresponding to the ExpenseTypes.xml resource document.

See Also

ExpenseDB Class
GetExpenseTypes Overload
OfficeClip.DBLayer.TE Namespace


GetExpenseTypes Method (Int32, Int32)

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseTypes Method (Int32, Int32)
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetExpenseTypes(
    int groupId,
    int expenseId
)
Visual Basic (Declaration)
Public Function GetExpenseTypes ( _
    groupId As Integer, _
    expenseId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetExpenseTypes(
    int groupId,
    int expenseId
)

Parameters

groupId
Type: System..::.Int32
expenseId
Type: System..::.Int32

See Also

ExpenseDB Class
GetExpenseTypes Overload
OfficeClip.DBLayer.TE Namespace


GetExpenseTypesForRdlc Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseTypesForRdlc Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

List of expense types available for a group (used for rdl reports)

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetExpenseTypesForRdlc(
    int groupId
)
Visual Basic (Declaration)
Public Function GetExpenseTypesForRdlc ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetExpenseTypesForRdlc(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

List of exepense types in Dataset

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetExpenseTypesInfoForExpenseId Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetExpenseTypesInfoForExpenseId Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the expense types for expenseId, if the expenseId is -1 then gets the expense types for the groupId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GroupExpenseTypeInfo GetExpenseTypesInfoForExpenseId(
    int groupId,
    int expenseId
)
Visual Basic (Declaration)
Public Function GetExpenseTypesInfoForExpenseId ( _
    groupId As Integer, _
    expenseId As Integer _
) As GroupExpenseTypeInfo
Visual C++
public:
GroupExpenseTypeInfo^ GetExpenseTypesInfoForExpenseId(
    int groupId,
    int expenseId
)

Parameters

groupId
Type: System..::.Int32
Unique Id of the group
expenseId
Type: System..::.Int32
Id of the expense for which all the information needs to be retrieved.

Return Value

Instance of the GroupExpenseTypeInfo object containing all the information of expense types related to a particular expense. GroupExpenseTypeInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetHotelExpenseDetailInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetHotelExpenseDetailInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details for an hotel type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseHotelInfo object as input.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseHotelInfo GetHotelExpenseDetailInfo(
    ExpenseHotelInfo ehti
)
Visual Basic (Declaration)
Public Function GetHotelExpenseDetailInfo ( _
    ehti As ExpenseHotelInfo _
) As ExpenseHotelInfo
Visual C++
public:
ExpenseHotelInfo^ GetHotelExpenseDetailInfo(
    ExpenseHotelInfo^ ehti
)

Parameters

ehti
Type: OfficeClip.BusinessLayer.TE..::.ExpenseHotelInfo
Instance of the ExpenseHotelInfo object containing the ExpenseId and ExpenseDetailId corresponding to which the details of a particular Hotel expense item are to be retrieved.

Return Value

Instance of ExpenseHotelInfo object containing all the details of a particular Hotel expense item. ExpenseHotelInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetLastExpenseInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetLastExpenseInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the informatin related to the most recent expense created by a particular user corresponding to a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseInfo GetLastExpenseInfo(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetLastExpenseInfo ( _
    userId As Integer, _
    groupId As Integer _
) As ExpenseInfo
Visual C++
public:
ExpenseInfo^ GetLastExpenseInfo(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
The unique user Id. Please note that the user should belong to the group whose id is being passed as argument.
groupId
Type: System..::.Int32
The unique group id.

Return Value

Instance of the ExpenseInfo object containing all the information related to the most recent expense. ExpenseInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetTaxiExpenseDetailInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetTaxiExpenseDetailInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details for a taxi type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseTaxiInfo object as input.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseTaxiInfo GetTaxiExpenseDetailInfo(
    ExpenseTaxiInfo etxi
)
Visual Basic (Declaration)
Public Function GetTaxiExpenseDetailInfo ( _
    etxi As ExpenseTaxiInfo _
) As ExpenseTaxiInfo
Visual C++
public:
ExpenseTaxiInfo^ GetTaxiExpenseDetailInfo(
    ExpenseTaxiInfo^ etxi
)

Parameters

etxi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseTaxiInfo
Instance of the ExpenseTaxiInfo object containing the ExpenseId and ExpenseDetailId corresponding to which the details of a particular Taxi expense item are to be retrieved.

Return Value

Instance of ExpenseTaxiInfo object containing all the details of a particular Taxi expense item. ExpenseAutorentalInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


GetTelephoneExpenseDetailInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.GetTelephoneExpenseDetailInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details for a telephone type expense detail item based on the ExpenseId and ExpenseDetailId specified in the the ExpenseTelephoneInfo object as input.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ExpenseTelephoneInfo GetTelephoneExpenseDetailInfo(
    ExpenseTelephoneInfo etli
)
Visual Basic (Declaration)
Public Function GetTelephoneExpenseDetailInfo ( _
    etli As ExpenseTelephoneInfo _
) As ExpenseTelephoneInfo
Visual C++
public:
ExpenseTelephoneInfo^ GetTelephoneExpenseDetailInfo(
    ExpenseTelephoneInfo^ etli
)

Parameters

etli
Type: OfficeClip.BusinessLayer.TE..::.ExpenseTelephoneInfo
Instance of the ExpenseTelephoneInfo object containing the ExpenseId and ExpenseDetailId corresponding to which the details of a particular telephone expense item are to be retrieved.

Return Value

Instance of ExpenseTelephoneInfo object containing all the details of a particular telephone expense item. ExpenseTelephoneInfo

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
ExpenseDB..::.InitTransaction Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

ExpenseDB Class
ExpenseDB Members
OfficeClip.DBLayer.TE Namespace


InsertExpense Method

[image]

OfficeClip API Documentation
ExpenseDB..::.InsertExpense Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new expense into the database and routes it to a particular user as defined in the workflow.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExpense(
    ExpenseInfo ei,
    WorkflowAction wa,
    int routeToUserId,
    int stageId,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function InsertExpense ( _
    ei As ExpenseInfo, _
    wa As WorkflowAction, _
    routeToUserId As Integer, _
    stageId As Integer, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int InsertExpense(
    ExpenseInfo^ ei,
    WorkflowAction wa,
    int routeToUserId,
    int stageId,
    ConfigureInfo^ session
)

Parameters

ei
Type: OfficeClip.BusinessLayer.TE..::.ExpenseInfo
Instance of the ExpenseInfo object containing all the information related to the expense. ExpenseInfo
wa
Type: OfficeClip.Utils..::.WorkflowAction
Workflow action to be applied after inserting the new expense.
routeToUserId
Type: System..::.Int32
Id of the user to whom the timesheet should be routed.
stageId
Type: System..::.Int32
Stage Id of the user as defined in the workflow who is creating the new expense.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session

Return Value

Id of the newly created expense if successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


InsertExpenseAirfareInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.InsertExpenseAirfareInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts airfare expense detail item crated inside an expense into the database.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExpenseAirfareInfo(
    ExpenseAirfareInfo eafi
)
Visual Basic (Declaration)
Public Function InsertExpenseAirfareInfo ( _
    eafi As ExpenseAirfareInfo _
) As Integer
Visual C++
public:
int InsertExpenseAirfareInfo(
    ExpenseAirfareInfo^ eafi
)

Parameters

eafi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseAirfareInfo
Instance of the ExpenseAirfareInfo object containing all the details of an airfare expense detail item. ExpenseAirfareInfo

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


InsertExpenseAutorentalInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.InsertExpenseAutorentalInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts auto rental expense detail item created inside an expense into the database.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExpenseAutorentalInfo(
    ExpenseAutorentalInfo eari
)
Visual Basic (Declaration)
Public Function InsertExpenseAutorentalInfo ( _
    eari As ExpenseAutorentalInfo _
) As Integer
Visual C++
public:
int InsertExpenseAutorentalInfo(
    ExpenseAutorentalInfo^ eari
)

Parameters

eari
Type: OfficeClip.BusinessLayer.TE..::.ExpenseAutorentalInfo
Instance of the ExpenseAutorentalInfo object containing all the details of an auto rental expense detail item. ExpenseAutorentalInfo

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


InsertExpenseCommentInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.InsertExpenseCommentInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new expense Comment created inside an expense

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExpenseCommentInfo(
    ExpenseCommentInfo eci,
    int currentUserId
)
Visual Basic (Declaration)
Public Function InsertExpenseCommentInfo ( _
    eci As ExpenseCommentInfo, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int InsertExpenseCommentInfo(
    ExpenseCommentInfo^ eci,
    int currentUserId
)

Parameters

eci
Type: OfficeClip.BusinessLayer.TE..::.ExpenseCommentInfo
Instance of the ExpenseCommentInfo object containing the Comment information. ExpenseCommentInfo
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


InsertExpenseDetailInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.InsertExpenseDetailInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts individual expense detail items inside an expense into the database.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExpenseDetailInfo(
    ExpenseDetailInfo edti,
    int currentUserId
)
Visual Basic (Declaration)
Public Function InsertExpenseDetailInfo ( _
    edti As ExpenseDetailInfo, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int InsertExpenseDetailInfo(
    ExpenseDetailInfo^ edti,
    int currentUserId
)

Parameters

edti
Type: OfficeClip.BusinessLayer.TE..::.ExpenseDetailInfo
Instance of the ExpenseDetailInfo object containing all the details of an individual expense detail item. ExpenseDetailInfo
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


InsertExpenseHotelInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.InsertExpenseHotelInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts hotel expense detail item crated inside an expense into the database.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExpenseHotelInfo(
    ExpenseHotelInfo ehti
)
Visual Basic (Declaration)
Public Function InsertExpenseHotelInfo ( _
    ehti As ExpenseHotelInfo _
) As Integer
Visual C++
public:
int InsertExpenseHotelInfo(
    ExpenseHotelInfo^ ehti
)

Parameters

ehti
Type: OfficeClip.BusinessLayer.TE..::.ExpenseHotelInfo
Instance of the ExpenseHotelInfo object containing all the details of an hotel expense detail item. ExpenseHotelInfo

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


InsertExpenseInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.InsertExpenseInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new expense into the database.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExpenseInfo(
    ExpenseInfo ei,
    int currentGroupId,
    int currentUserId
)
Visual Basic (Declaration)
Public Function InsertExpenseInfo ( _
    ei As ExpenseInfo, _
    currentGroupId As Integer, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int InsertExpenseInfo(
    ExpenseInfo^ ei,
    int currentGroupId,
    int currentUserId
)

Parameters

ei
Type: OfficeClip.BusinessLayer.TE..::.ExpenseInfo
Instance of the ExpenseInfo object containing all the information related to the expense. ExpenseInfo
currentGroupId
Type: System..::.Int32
The id of the current organization
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

Id of the newly created expense if successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


InsertExpenseTaxiInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.InsertExpenseTaxiInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts taxi expense detail item created inside an expense into the database.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExpenseTaxiInfo(
    ExpenseTaxiInfo etxi
)
Visual Basic (Declaration)
Public Function InsertExpenseTaxiInfo ( _
    etxi As ExpenseTaxiInfo _
) As Integer
Visual C++
public:
int InsertExpenseTaxiInfo(
    ExpenseTaxiInfo^ etxi
)

Parameters

etxi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseTaxiInfo
Instance of the ExpenseTaxiInfo object containing all the details of an taxi expense detail item. ExpenseTaxiInfo

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


InsertExpenseTelephoneInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.InsertExpenseTelephoneInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts telephone expense detail item created inside an expense into the database.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExpenseTelephoneInfo(
    ExpenseTelephoneInfo etli
)
Visual Basic (Declaration)
Public Function InsertExpenseTelephoneInfo ( _
    etli As ExpenseTelephoneInfo _
) As Integer
Visual C++
public:
int InsertExpenseTelephoneInfo(
    ExpenseTelephoneInfo^ etli
)

Parameters

etli
Type: OfficeClip.BusinessLayer.TE..::.ExpenseTelephoneInfo
Instance of the ExpenseTelephoneInfo object containing all the details of an telephone expense detail item. ExpenseTelephoneInfo

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


InsertExpenseTypeInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.InsertExpenseTypeInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the information related to a expense type.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExpenseTypeInfo(
    ExpenseTypeInfo etyi
)
Visual Basic (Declaration)
Public Function InsertExpenseTypeInfo ( _
    etyi As ExpenseTypeInfo _
) As Integer
Visual C++
public:
int InsertExpenseTypeInfo(
    ExpenseTypeInfo^ etyi
)

Parameters

etyi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseTypeInfo
Instance of the ExpenseTypeInfo object containing all the expense types information. ExpenseTypeInfo

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


InsertExpenseTypes Method

[image]

OfficeClip API Documentation
ExpenseDB..::.InsertExpenseTypes Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the information related to a expense types corresponding to a a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertExpenseTypes(
    int groupId,
    GroupExpenseTypeInfo etmi
)
Visual Basic (Declaration)
Public Function InsertExpenseTypes ( _
    groupId As Integer, _
    etmi As GroupExpenseTypeInfo _
) As Integer
Visual C++
public:
int InsertExpenseTypes(
    int groupId,
    GroupExpenseTypeInfo^ etmi
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.
etmi
Type: OfficeClip.BusinessLayer.TE..::.GroupExpenseTypeInfo
Instance of the GroupExpenseTypeInfo object containing all the information GroupExpenseTypeInfo

Return Value

1 when successful, -1 in case of an error.

Remarks

When a new expense type is created, then new one being inserted and is marked as Active. This is to ensure that the expenses created corresponding to the previously Active type keep working and follow the the workflow and expense details.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


SetExpenseExported Method

[image]

OfficeClip API Documentation
ExpenseDB..::.SetExpenseExported Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the expired status of the expense

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetExpenseExported(
    int id
)
Visual Basic (Declaration)
Public Sub SetExpenseExported ( _
    id As Integer _
)
Visual C++
public:
void SetExpenseExported(
    int id
)

Parameters

id
Type: System..::.Int32
The unique id of the expense

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
ExpenseDB..::.SetSPCommand Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

ExpenseDB Class
ExpenseDB Members
OfficeClip.DBLayer.TE Namespace


UpdateExpense Method

[image]

OfficeClip API Documentation
ExpenseDB..::.UpdateExpense Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the details realted to a particular expense into the database and routes it to a particular user as defined in the workflow.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateExpense(
    ExpenseInfo ei,
    WorkflowAction wa,
    int routeToUserId,
    int stageId,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateExpense ( _
    ei As ExpenseInfo, _
    wa As WorkflowAction, _
    routeToUserId As Integer, _
    stageId As Integer, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int UpdateExpense(
    ExpenseInfo^ ei,
    WorkflowAction wa,
    int routeToUserId,
    int stageId,
    ConfigureInfo^ session
)

Parameters

ei
Type: OfficeClip.BusinessLayer.TE..::.ExpenseInfo
Instance of the ExpenseInfo object containing all the information relate to an expense.
wa
Type: OfficeClip.Utils..::.WorkflowAction
Workflow action to be applied after inserting the new expense.
routeToUserId
Type: System..::.Int32
Id of the user to whom the timesheet should be routed.
stageId
Type: System..::.Int32
Stage Id of the user as defined in the workflow who is creating the new expense.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The current login session

Return Value

Id of the newly created expense or -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


UpdateExpenseCommentInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.UpdateExpenseCommentInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates an expense Comment defined inside an expense.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateExpenseCommentInfo(
    ExpenseCommentInfo eci
)
Visual Basic (Declaration)
Public Function UpdateExpenseCommentInfo ( _
    eci As ExpenseCommentInfo _
) As Integer
Visual C++
public:
int UpdateExpenseCommentInfo(
    ExpenseCommentInfo^ eci
)

Parameters

eci
Type: OfficeClip.BusinessLayer.TE..::.ExpenseCommentInfo
Instance of the ExpenseCommentInfo object containing the Comment information. ExpenseCommentInfo

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


UpdateExpenseTypeInfo Method

[image]

OfficeClip API Documentation
ExpenseDB..::.UpdateExpenseTypeInfo Method
ExpenseDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the information related to a expense types.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateExpenseTypeInfo(
    ExpenseTypeInfo etyi
)
Visual Basic (Declaration)
Public Function UpdateExpenseTypeInfo ( _
    etyi As ExpenseTypeInfo _
) As Integer
Visual C++
public:
int UpdateExpenseTypeInfo(
    ExpenseTypeInfo^ etyi
)

Parameters

etyi
Type: OfficeClip.BusinessLayer.TE..::.ExpenseTypeInfo
Instance of the ExpenseTypeInfo object containing all the expense types information. ExpenseTypeInfo

Return Value

0 when successful, -1 in case of an error.

See Also

ExpenseDB Class
OfficeClip.DBLayer.TE Namespace


PaymentsDB Class

[image]

OfficeClip API Documentation
PaymentsDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides Database functions for Payment and Reimbursement

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class PaymentsDB : OfficeClipDB
Visual Basic (Declaration)
Public Class PaymentsDB _
    Inherits OfficeClipDB
Visual C++
public ref class PaymentsDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.TE..::.PaymentsDB

See Also

PaymentsDB Members
OfficeClip.DBLayer.TE Namespace


PaymentsDB Members

[image] [image]

OfficeClip API Documentation
PaymentsDB Members
PaymentsDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PaymentsDB type exposes the following members.

Constructors

 | Name | Description
Public method | PaymentsDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExpensePayments | Returns ReimbursementPaymentInfo of expensePayments for an expenseId
Public method | GetExpensesById | Returns a List of OfficeClip.BusinessLayer.TE.ExpenseDetailInfo where the expenseId matches
Public method | GetExpsBetweenDateRange | Returns DataSet of the expenses between specified date range for an userId
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsExpensePayment | Inserts into expnesePayment with the values in the OfficeClip.BusinessLayer.TE.ReimbursementPaymentInfo
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UdpExpenseDetails |
Public method | UpdExpensePayment | Updates expensePayment with the values in the OfficeClip.BusinessLayer.TE.ReimbursementPaymentInfo

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

PaymentsDB Class
OfficeClip.DBLayer.TE Namespace


PaymentsDB Constructor

[image]

OfficeClip API Documentation
PaymentsDB Constructor
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PaymentsDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaymentsDB()

See Also

PaymentsDB Class
OfficeClip.DBLayer.TE Namespace


PaymentsDB Methods

[image] [image]

OfficeClip API Documentation
PaymentsDB Methods
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

The PaymentsDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExpensePayments | Returns ReimbursementPaymentInfo of expensePayments for an expenseId
Public method | GetExpensesById | Returns a List of OfficeClip.BusinessLayer.TE.ExpenseDetailInfo where the expenseId matches
Public method | GetExpsBetweenDateRange | Returns DataSet of the expenses between specified date range for an userId
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsExpensePayment | Inserts into expnesePayment with the values in the OfficeClip.BusinessLayer.TE.ReimbursementPaymentInfo
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UdpExpenseDetails |
Public method | UpdExpensePayment | Updates expensePayment with the values in the OfficeClip.BusinessLayer.TE.ReimbursementPaymentInfo

See Also

PaymentsDB Class
OfficeClip.DBLayer.TE Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
PaymentsDB..::.AddOutputParameter Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

PaymentsDB Class
PaymentsDB Members
OfficeClip.DBLayer.TE Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
PaymentsDB..::.AddParameter Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

PaymentsDB Class
PaymentsDB Members
OfficeClip.DBLayer.TE Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
PaymentsDB..::.AddParameters Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

PaymentsDB Class
PaymentsDB Members
OfficeClip.DBLayer.TE Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
PaymentsDB..::.ExecuteNonQuery Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

PaymentsDB Class
PaymentsDB Members
OfficeClip.DBLayer.TE Namespace


GetExpensePayments Method

[image]

OfficeClip API Documentation
PaymentsDB..::.GetExpensePayments Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns ReimbursementPaymentInfo of expensePayments for an expenseId

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ReimbursementPaymentInfo GetExpensePayments(
    int expenseId
)
Visual Basic (Declaration)
Public Function GetExpensePayments ( _
    expenseId As Integer _
) As ReimbursementPaymentInfo
Visual C++
public:
ReimbursementPaymentInfo^ GetExpensePayments(
    int expenseId
)

Parameters

expenseId
Type: System..::.Int32
expenseId as int

Return Value

See Also

PaymentsDB Class
OfficeClip.DBLayer.TE Namespace


GetExpensesById Method

[image]

OfficeClip API Documentation
PaymentsDB..::.GetExpensesById Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns a List of OfficeClip.BusinessLayer.TE.ExpenseDetailInfo where the expenseId matches

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<ExpenseDetailInfo> GetExpensesById(
    int expenseId
)
Visual Basic (Declaration)
Public Function GetExpensesById ( _
    expenseId As Integer _
) As List(Of ExpenseDetailInfo)
Visual C++
public:
List<ExpenseDetailInfo^>^ GetExpensesById(
    int expenseId
)

Parameters

expenseId
Type: System..::.Int32
expenseId as int

Return Value

See Also

PaymentsDB Class
OfficeClip.DBLayer.TE Namespace


GetExpsBetweenDateRange Method

[image]

OfficeClip API Documentation
PaymentsDB..::.GetExpsBetweenDateRange Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns DataSet of the expenses between specified date range for an userId

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<ReimbursementPaymentInfo> GetExpsBetweenDateRange(
    int userId,
    DateTime from_date,
    DateTime to_date
)
Visual Basic (Declaration)
Public Function GetExpsBetweenDateRange ( _
    userId As Integer, _
    from_date As DateTime, _
    to_date As DateTime _
) As List(Of ReimbursementPaymentInfo)
Visual C++
public:
List<ReimbursementPaymentInfo^>^ GetExpsBetweenDateRange(
    int userId,
    DateTime from_date,
    DateTime to_date
)

Parameters

userId
Type: System..::.Int32
userId as int
from_date
Type: System..::.DateTime
from_date as DateTime
to_date
Type: System..::.DateTime
to_date as DateTime

Return Value

See Also

PaymentsDB Class
OfficeClip.DBLayer.TE Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
PaymentsDB..::.InitTransaction Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

PaymentsDB Class
PaymentsDB Members
OfficeClip.DBLayer.TE Namespace


InsExpensePayment Method

[image]

OfficeClip API Documentation
PaymentsDB..::.InsExpensePayment Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts into expnesePayment with the values in the OfficeClip.BusinessLayer.TE.ReimbursementPaymentInfo

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsExpensePayment(
    ReimbursementPaymentInfo info
)
Visual Basic (Declaration)
Public Sub InsExpensePayment ( _
    info As ReimbursementPaymentInfo _
)
Visual C++
public:
void InsExpensePayment(
    ReimbursementPaymentInfo^ info
)

Parameters

info
Type: OfficeClip.BusinessLayer.TE..::.ReimbursementPaymentInfo
info as OfficeClip.BusinessLayer.TE.ReimbursementPaymentInfo

See Also

PaymentsDB Class
OfficeClip.DBLayer.TE Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
PaymentsDB..::.SetSPCommand Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

PaymentsDB Class
PaymentsDB Members
OfficeClip.DBLayer.TE Namespace


UdpExpenseDetails Method

[image]

OfficeClip API Documentation
PaymentsDB..::.UdpExpenseDetails Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UdpExpenseDetails(
    List<ExpenseDetailInfo> listInfo
)
Visual Basic (Declaration)
Public Sub UdpExpenseDetails ( _
    listInfo As List(Of ExpenseDetailInfo) _
)
Visual C++
public:
void UdpExpenseDetails(
    List<ExpenseDetailInfo^>^ listInfo
)

Parameters

listInfo
Type: System.Collections.Generic..::.List<(Of <( ExpenseDetailInfo >)>)

See Also

PaymentsDB Class
OfficeClip.DBLayer.TE Namespace


UpdExpensePayment Method

[image]

OfficeClip API Documentation
PaymentsDB..::.UpdExpensePayment Method
PaymentsDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates expensePayment with the values in the OfficeClip.BusinessLayer.TE.ReimbursementPaymentInfo

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdExpensePayment(
    ReimbursementPaymentInfo info
)
Visual Basic (Declaration)
Public Sub UpdExpensePayment ( _
    info As ReimbursementPaymentInfo _
)
Visual C++
public:
void UpdExpensePayment(
    ReimbursementPaymentInfo^ info
)

Parameters

info
Type: OfficeClip.BusinessLayer.TE..::.ReimbursementPaymentInfo
info as OfficeClip.BusinessLayer.TE.ReimbursementPaymentInfo

See Also

PaymentsDB Class
OfficeClip.DBLayer.TE Namespace


PunchDB Class

[image]

OfficeClip API Documentation
PunchDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Summary description for the rules engine.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class PunchDB : OfficeClipDB
Visual Basic (Declaration)
Public Class PunchDB _
    Inherits OfficeClipDB
Visual C++
public ref class PunchDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.TE..::.PunchDB

See Also

PunchDB Members
OfficeClip.DBLayer.TE Namespace


PunchDB Members

[image] [image]

OfficeClip API Documentation
PunchDB Members
PunchDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The PunchDB type exposes the following members.

Constructors

 | Name | Description
Public method | PunchDB | Default Constructor

Methods

 | Name | Description
Protected method | AddBreakNote | Adds the notes for break time
Protected method | AddHistoryNote | Adds the notes for history
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPunchDay | Overloaded.
Public method | GetPunchDays | Gets the punch days information in a dataset
Public method | GetPunchDaysByMultipleUsers | Gets the punch days for multiple users
Public method | GetPunchHistory | Gets the punch history
Protected method | GetPunchLimitFromData | Gets the punch limit from data
Public method | GetPunchRows | Gets the punch rows. Also adds the rows to fill out the holes. For example if we are looking on a weekly punchcard and somebody has not punched on a particular day, this function supplies the additional records.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertHistory | Insert the history
Protected method | IsBreakFromData | Checks if there is break information
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PunchIn | Gets the punch in time
Public method | PunchOut | Gets the punch out time
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Public method | SetPunchDay | Sets the punch day
Public method | SetPunchHistory | Sets the punch history
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


PunchDB Constructor

[image]

OfficeClip API Documentation
PunchDB Constructor
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Default Constructor

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PunchDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PunchDB()

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


PunchDB Methods

[image] [image]

OfficeClip API Documentation
PunchDB Methods
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

The PunchDB type exposes the following methods.

Methods

 | Name | Description
Protected method | AddBreakNote | Adds the notes for break time
Protected method | AddHistoryNote | Adds the notes for history
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetPunchDay | Overloaded.
Public method | GetPunchDays | Gets the punch days information in a dataset
Public method | GetPunchDaysByMultipleUsers | Gets the punch days for multiple users
Public method | GetPunchHistory | Gets the punch history
Protected method | GetPunchLimitFromData | Gets the punch limit from data
Public method | GetPunchRows | Gets the punch rows. Also adds the rows to fill out the holes. For example if we are looking on a weekly punchcard and somebody has not punched on a particular day, this function supplies the additional records.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertHistory | Insert the history
Protected method | IsBreakFromData | Checks if there is break information
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PunchIn | Gets the punch in time
Public method | PunchOut | Gets the punch out time
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Public method | SetPunchDay | Sets the punch day
Public method | SetPunchHistory | Sets the punch history
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


AddBreakNote Method

[image]

OfficeClip API Documentation
PunchDB..::.AddBreakNote Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds the notes for break time

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AddBreakNote(
    StringBuilder sb,
    int breakTime,
    string title
)
Visual Basic (Declaration)
Protected Sub AddBreakNote ( _
    sb As StringBuilder, _
    breakTime As Integer, _
    title As String _
)
Visual C++
protected:
void AddBreakNote(
    StringBuilder^ sb,
    int breakTime,
    String^ title
)

Parameters

sb
Type: System.Text..::.StringBuilder
breakTime
Type: System..::.Int32
title
Type: System..::.String

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


AddHistoryNote Method

[image]

OfficeClip API Documentation
PunchDB..::.AddHistoryNote Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds the notes for history

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void AddHistoryNote(
    StringBuilder sb,
    PunchTimeInfo piOld,
    PunchTimeInfo piNew,
    int num
)
Visual Basic (Declaration)
Protected Sub AddHistoryNote ( _
    sb As StringBuilder, _
    piOld As PunchTimeInfo, _
    piNew As PunchTimeInfo, _
    num As Integer _
)
Visual C++
protected:
void AddHistoryNote(
    StringBuilder^ sb,
    PunchTimeInfo^ piOld,
    PunchTimeInfo^ piNew,
    int num
)

Parameters

sb
Type: System.Text..::.StringBuilder
piOld
Type: OfficeClip.BusinessLayer.TE..::.PunchTimeInfo
piNew
Type: OfficeClip.BusinessLayer.TE..::.PunchTimeInfo
num
Type: System..::.Int32

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
PunchDB..::.AddOutputParameter Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

PunchDB Class
PunchDB Members
OfficeClip.DBLayer.TE Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
PunchDB..::.AddParameter Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

PunchDB Class
PunchDB Members
OfficeClip.DBLayer.TE Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
PunchDB..::.AddParameters Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

PunchDB Class
PunchDB Members
OfficeClip.DBLayer.TE Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
PunchDB..::.ExecuteNonQuery Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

PunchDB Class
PunchDB Members
OfficeClip.DBLayer.TE Namespace


GetPunchDay Method

[image] [image]

OfficeClip API Documentation
PunchDB..::.GetPunchDay Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetPunchDay(Int32, ConfigureInfo) | Gets the punch day information
Public method | GetPunchDay(Int32, DateTime) | Gets the punch day information

See Also

PunchDB Class
PunchDB Members
OfficeClip.DBLayer.TE Namespace


GetPunchDay Method (Int32, ConfigureInfo)

[image]

OfficeClip API Documentation
PunchDB..::.GetPunchDay Method (Int32, ConfigureInfo)
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the punch day information

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PunchDayInfo GetPunchDay(
    int userId,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function GetPunchDay ( _
    userId As Integer, _
    session As ConfigureInfo _
) As PunchDayInfo
Visual C++
public:
PunchDayInfo^ GetPunchDay(
    int userId,
    ConfigureInfo^ session
)

Parameters

userId
Type: System..::.Int32
session
Type: OfficeClip.Utils..::.ConfigureInfo

Return Value

See Also

PunchDB Class
GetPunchDay Overload
OfficeClip.DBLayer.TE Namespace


GetPunchDay Method (Int32, DateTime)

[image]

OfficeClip API Documentation
PunchDB..::.GetPunchDay Method (Int32, DateTime)
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the punch day information

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PunchDayInfo GetPunchDay(
    int userId,
    DateTime dt
)
Visual Basic (Declaration)
Public Function GetPunchDay ( _
    userId As Integer, _
    dt As DateTime _
) As PunchDayInfo
Visual C++
public:
PunchDayInfo^ GetPunchDay(
    int userId,
    DateTime dt
)

Parameters

userId
Type: System..::.Int32
dt
Type: System..::.DateTime

Return Value

See Also

PunchDB Class
GetPunchDay Overload
OfficeClip.DBLayer.TE Namespace


GetPunchDays Method

[image]

OfficeClip API Documentation
PunchDB..::.GetPunchDays Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the punch days information in a dataset

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPunchDays(
    int userId,
    DateTime startDate,
    DateTime endDate
)
Visual Basic (Declaration)
Public Function GetPunchDays ( _
    userId As Integer, _
    startDate As DateTime, _
    endDate As DateTime _
) As DataSet
Visual C++
public:
DataSet^ GetPunchDays(
    int userId,
    DateTime startDate,
    DateTime endDate
)

Parameters

userId
Type: System..::.Int32
startDate
Type: System..::.DateTime
endDate
Type: System..::.DateTime

Return Value

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


GetPunchDaysByMultipleUsers Method

[image]

OfficeClip API Documentation
PunchDB..::.GetPunchDaysByMultipleUsers Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the punch days for multiple users

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPunchDaysByMultipleUsers(
    string users,
    DateTime startDate,
    DateTime endDate
)
Visual Basic (Declaration)
Public Function GetPunchDaysByMultipleUsers ( _
    users As String, _
    startDate As DateTime, _
    endDate As DateTime _
) As DataSet
Visual C++
public:
DataSet^ GetPunchDaysByMultipleUsers(
    String^ users,
    DateTime startDate,
    DateTime endDate
)

Parameters

users
Type: System..::.String
startDate
Type: System..::.DateTime
endDate
Type: System..::.DateTime

Return Value

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


GetPunchHistory Method

[image]

OfficeClip API Documentation
PunchDB..::.GetPunchHistory Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the punch history

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetPunchHistory(
    int userId,
    DateTime startDate,
    DateTime endDate
)
Visual Basic (Declaration)
Public Function GetPunchHistory ( _
    userId As Integer, _
    startDate As DateTime, _
    endDate As DateTime _
) As DataSet
Visual C++
public:
DataSet^ GetPunchHistory(
    int userId,
    DateTime startDate,
    DateTime endDate
)

Parameters

userId
Type: System..::.Int32
startDate
Type: System..::.DateTime
endDate
Type: System..::.DateTime

Return Value

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


GetPunchLimitFromData Method

[image]

OfficeClip API Documentation
PunchDB..::.GetPunchLimitFromData Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the punch limit from data

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected int GetPunchLimitFromData(
    PunchDayInfo[] apdi
)
Visual Basic (Declaration)
Protected Function GetPunchLimitFromData ( _
    apdi As PunchDayInfo() _
) As Integer
Visual C++
protected:
int GetPunchLimitFromData(
    array<PunchDayInfo^>^ apdi
)

Parameters

apdi
Type: array< OfficeClip.BusinessLayer.TE..::.PunchDayInfo >[]()[]

Return Value

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


GetPunchRows Method

[image]

OfficeClip API Documentation
PunchDB..::.GetPunchRows Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the punch rows. Also adds the rows to fill out the holes. For example if we are looking on a weekly punchcard and somebody has not punched on a particular day, this function supplies the additional records.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public PunchDayInfo[] GetPunchRows(
    int userId,
    DateTime startDate,
    int numDays,
    ref int punchLimit,
    ref bool IsBreakTime
)
Visual Basic (Declaration)
Public Function GetPunchRows ( _
    userId As Integer, _
    startDate As DateTime, _
    numDays As Integer, _
    ByRef punchLimit As Integer, _
    ByRef IsBreakTime As Boolean _
) As PunchDayInfo()
Visual C++
public:
array<PunchDayInfo^>^ GetPunchRows(
    int userId,
    DateTime startDate,
    int numDays,
    int% punchLimit,
    bool% IsBreakTime
)

Parameters

userId
Type: System..::.Int32
startDate
Type: System..::.DateTime
numDays
Type: System..::.Int32
punchLimit
Type: System..::.Int32%
IsBreakTime
Type: System..::.Boolean%

Return Value

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
PunchDB..::.InitTransaction Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

PunchDB Class
PunchDB Members
OfficeClip.DBLayer.TE Namespace


InsertHistory Method

[image]

OfficeClip API Documentation
PunchDB..::.InsertHistory Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Insert the history

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertHistory(
    PunchDayInfo pdiOld,
    PunchDayInfo pdiNew,
    int modifiedById
)
Visual Basic (Declaration)
Public Sub InsertHistory ( _
    pdiOld As PunchDayInfo, _
    pdiNew As PunchDayInfo, _
    modifiedById As Integer _
)
Visual C++
public:
void InsertHistory(
    PunchDayInfo^ pdiOld,
    PunchDayInfo^ pdiNew,
    int modifiedById
)

Parameters

pdiOld
Type: OfficeClip.BusinessLayer.TE..::.PunchDayInfo
pdiNew
Type: OfficeClip.BusinessLayer.TE..::.PunchDayInfo
modifiedById
Type: System..::.Int32

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


IsBreakFromData Method

[image]

OfficeClip API Documentation
PunchDB..::.IsBreakFromData Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks if there is break information

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected bool IsBreakFromData(
    PunchDayInfo[] apdi
)
Visual Basic (Declaration)
Protected Function IsBreakFromData ( _
    apdi As PunchDayInfo() _
) As Boolean
Visual C++
protected:
bool IsBreakFromData(
    array<PunchDayInfo^>^ apdi
)

Parameters

apdi
Type: array< OfficeClip.BusinessLayer.TE..::.PunchDayInfo >[]()[]

Return Value

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


PunchIn Method

[image]

OfficeClip API Documentation
PunchDB..::.PunchIn Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the punch in time

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int PunchIn(
    int punchLimit,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function PunchIn ( _
    punchLimit As Integer, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int PunchIn(
    int punchLimit,
    ConfigureInfo^ session
)

Parameters

punchLimit
Type: System..::.Int32
session
Type: OfficeClip.Utils..::.ConfigureInfo

Return Value

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


PunchOut Method

[image]

OfficeClip API Documentation
PunchDB..::.PunchOut Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the punch out time

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int PunchOut(
    int punchLimit,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function PunchOut ( _
    punchLimit As Integer, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int PunchOut(
    int punchLimit,
    ConfigureInfo^ session
)

Parameters

punchLimit
Type: System..::.Int32
session
Type: OfficeClip.Utils..::.ConfigureInfo

Return Value

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


SetPunchDay Method

[image]

OfficeClip API Documentation
PunchDB..::.SetPunchDay Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the punch day

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetPunchDay(
    PunchDayInfo pdi,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Sub SetPunchDay ( _
    pdi As PunchDayInfo, _
    session As ConfigureInfo _
)
Visual C++
public:
void SetPunchDay(
    PunchDayInfo^ pdi,
    ConfigureInfo^ session
)

Parameters

pdi
Type: OfficeClip.BusinessLayer.TE..::.PunchDayInfo
session
Type: OfficeClip.Utils..::.ConfigureInfo

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


SetPunchHistory Method

[image]

OfficeClip API Documentation
PunchDB..::.SetPunchHistory Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the punch history

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetPunchHistory(
    int userId,
    DateTime punchDate,
    int modifiedUserId,
    string notes
)
Visual Basic (Declaration)
Public Sub SetPunchHistory ( _
    userId As Integer, _
    punchDate As DateTime, _
    modifiedUserId As Integer, _
    notes As String _
)
Visual C++
public:
void SetPunchHistory(
    int userId,
    DateTime punchDate,
    int modifiedUserId,
    String^ notes
)

Parameters

userId
Type: System..::.Int32
punchDate
Type: System..::.DateTime
modifiedUserId
Type: System..::.Int32
notes
Type: System..::.String

See Also

PunchDB Class
OfficeClip.DBLayer.TE Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
PunchDB..::.SetSPCommand Method
PunchDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

PunchDB Class
PunchDB Members
OfficeClip.DBLayer.TE Namespace


QuickBooksDB Class

[image]

OfficeClip API Documentation
QuickBooksDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Time and Expenses application related functions.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class QuickBooksDB : OfficeClipDB
Visual Basic (Declaration)
Public Class QuickBooksDB _
    Inherits OfficeClipDB
Visual C++
public ref class QuickBooksDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.TE..::.QuickBooksDB

See Also

QuickBooksDB Members
OfficeClip.DBLayer.TE Namespace


QuickBooksDB Members

[image] [image]

OfficeClip API Documentation
QuickBooksDB Members
QuickBooksDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The QuickBooksDB type exposes the following members.

Constructors

 | Name | Description
Public method | QuickBooksDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetQbOcMapping | Get the Quickbooks mapping table
Public method | GetQuickBooksDataSet | Gets the mapping definition between OfficeClip system and the QuickBooks system as defined in the OCQBMapping.xsd xml schema definition resource file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertQuickBooksData | Inserts a set of customers to be imported and a set of tasks to be imported from the Quickbooks definition file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SaveQBMapping | Saves the mapping information between the OfficeClip system and the QuickBooks file for a particular group.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

QuickBooksDB Class
OfficeClip.DBLayer.TE Namespace


QuickBooksDB Constructor

[image]

OfficeClip API Documentation
QuickBooksDB Constructor
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public QuickBooksDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
QuickBooksDB()

See Also

QuickBooksDB Class
OfficeClip.DBLayer.TE Namespace


QuickBooksDB Methods

[image] [image]

OfficeClip API Documentation
QuickBooksDB Methods
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

The QuickBooksDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetQbOcMapping | Get the Quickbooks mapping table
Public method | GetQuickBooksDataSet | Gets the mapping definition between OfficeClip system and the QuickBooks system as defined in the OCQBMapping.xsd xml schema definition resource file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertQuickBooksData | Inserts a set of customers to be imported and a set of tasks to be imported from the Quickbooks definition file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SaveQBMapping | Saves the mapping information between the OfficeClip system and the QuickBooks file for a particular group.
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QuickBooksDB Class
OfficeClip.DBLayer.TE Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
QuickBooksDB..::.AddOutputParameter Method
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

QuickBooksDB Class
QuickBooksDB Members
OfficeClip.DBLayer.TE Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
QuickBooksDB..::.AddParameter Method
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

QuickBooksDB Class
QuickBooksDB Members
OfficeClip.DBLayer.TE Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
QuickBooksDB..::.AddParameters Method
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

QuickBooksDB Class
QuickBooksDB Members
OfficeClip.DBLayer.TE Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
QuickBooksDB..::.ExecuteNonQuery Method
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

QuickBooksDB Class
QuickBooksDB Members
OfficeClip.DBLayer.TE Namespace


GetQbOcMapping Method

[image]

OfficeClip API Documentation
QuickBooksDB..::.GetQbOcMapping Method
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the Quickbooks mapping table

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetQbOcMapping(
    int groupId
)
Visual Basic (Declaration)
Public Function GetQbOcMapping ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetQbOcMapping(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

The quickbooks mapping dataset

See Also

QuickBooksDB Class
OfficeClip.DBLayer.TE Namespace


GetQuickBooksDataSet Method

[image]

OfficeClip API Documentation
QuickBooksDB..::.GetQuickBooksDataSet Method
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the mapping definition between OfficeClip system and the QuickBooks system as defined in the OCQBMapping.xsd xml schema definition resource file.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetQuickBooksDataSet()
Visual Basic (Declaration)
Public Function GetQuickBooksDataSet As DataSet
Visual C++
public:
DataSet^ GetQuickBooksDataSet()

Return Value

DataSet corresponding to the OCQBMapping.xsd xml definition resource file.

Remarks

This mapping definition is represented in the form of a DataSet. Each DataTable in this DataSet represents a particular type of informaiton being mapped from OfficeClip to the QuickBooks system.

See Also

QuickBooksDB Class
OfficeClip.DBLayer.TE Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
QuickBooksDB..::.InitTransaction Method
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

QuickBooksDB Class
QuickBooksDB Members
OfficeClip.DBLayer.TE Namespace


InsertQuickBooksData Method

[image]

OfficeClip API Documentation
QuickBooksDB..::.InsertQuickBooksData Method
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a set of customers to be imported and a set of tasks to be imported from the Quickbooks definition file.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertQuickBooksData(
    ArrayList cil,
    GroupTimesheetTaskInfo ttmi,
    int currentGroupId,
    int currentUserId
)
Visual Basic (Declaration)
Public Function InsertQuickBooksData ( _
    cil As ArrayList, _
    ttmi As GroupTimesheetTaskInfo, _
    currentGroupId As Integer, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int InsertQuickBooksData(
    ArrayList^ cil,
    GroupTimesheetTaskInfo^ ttmi,
    int currentGroupId,
    int currentUserId
)

Parameters

cil
Type: System.Collections..::.ArrayList
ArrayList of ClientInfo objects imported from QuickBooks file.
ttmi
Type: OfficeClip.BusinessLayer.TE..::.GroupTimesheetTaskInfo
Instance of the GroupTimesheetTaskInfo object containing all the information about the tasks imported from the QuickBooks file. GroupTimesheetTaskInfo
currentGroupId
Type: System..::.Int32
The id of the current group
currentUserId
Type: System..::.Int32
The id of the current user

Return Value

0 when successful, -1 in case of an error.

See Also

QuickBooksDB Class
OfficeClip.DBLayer.TE Namespace


SaveQBMapping Method

[image]

OfficeClip API Documentation
QuickBooksDB..::.SaveQBMapping Method
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

Saves the mapping information between the OfficeClip system and the QuickBooks file for a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool SaveQBMapping(
    int groupId,
    DataSet ds
)
Visual Basic (Declaration)
Public Function SaveQBMapping ( _
    groupId As Integer, _
    ds As DataSet _
) As Boolean
Visual C++
public:
bool SaveQBMapping(
    int groupId,
    DataSet^ ds
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.
ds
Type: System.Data..::.DataSet
DataSet containing all the mapping information between the OfficeClip System and the QuickBooks file.

Return Value

Flag (True/False) indicating whether the mapping was successfuly saved or not.

See Also

QuickBooksDB Class
OfficeClip.DBLayer.TE Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
QuickBooksDB..::.SetSPCommand Method
QuickBooksDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

QuickBooksDB Class
QuickBooksDB Members
OfficeClip.DBLayer.TE Namespace


TimesheetDB Class

[image]

OfficeClip API Documentation
TimesheetDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a set of Time and Expenses application related functions.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TimesheetDB : OfficeClipDB
Visual Basic (Declaration)
Public Class TimesheetDB _
    Inherits OfficeClipDB
Visual C++
public ref class TimesheetDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.TE..::.TimesheetDB

See Also

TimesheetDB Members
OfficeClip.DBLayer.TE Namespace


TimesheetDB Members

[image] [image]

OfficeClip API Documentation
TimesheetDB Members
TimesheetDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TimesheetDB type exposes the following members.

Constructors

 | Name | Description
Public method | TimesheetDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Protected method | createDCAAString | Creates the DCAA string for logging history
Public method | DeleteTimesheet | Deletes a particular timesheet identified by timesheetId.
Public method | DeleteTimesheetDetails | Deletes all the individual timesheet detail items corresponding to a particular timesheet identified by timesheetId.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Public method | ExportTimesheets | Exports a list of timesheets in the QuickBooks timer file format based on the mapping stored corresponding to a particular group.
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveTimesheetTasksInfo | Gets the timesheet task information corresponding to the Active timesheet tasks corresponding to a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLastTimesheetInfo | Gets all the details of the most recent timesheet created for the a particular user for a particular group.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetParentChildNodes |
Public method | GetParentChildNodeString |
Public method | GetPayrollInfo |
Public method | GetTimesheetActiveRows | Gets a list of number of rows specified in the currently Active timesheet tasks in the current group.
Public method | GetTimesheetAlreadyExists | Checks whether a timesheet has already been created for a given week starting date for a particular user corresponding to a particular group.
Public method | GetTimesheetComments | Gets a list of all Comments corresponding to a particular timesheet.
Public method | GetTimesheetDetails | Gets the details of all the timesheet detail items for a particular timesheet identified by timesheetId.
Public method | GetTimesheetDetailsForCSV |
Public method | GetTimesheetInfo | Gets all the details corresponding to a particular timesheet identified by timesheetId.
Public method | GetTimesheetInfoComments | Gets all the Comments corresponding to a particular timesheet identified by timesheetId.
Public method | GetTimesheetRows | Gets a list of number of rows specified in a particular timesheet tasks.
Public method | GetTimesheets | Gets a list of all the timesheets for a set of users between a given date range for a particular group.
Public method | GetTimesheetsForExport | Gets a set of timesheets which are ready to be exported which were created within a given Date range from a particular group.
Public method | GetTimesheetTaskInfo | Gets all the information related to a particular task identified by taskId.
Public method | GetTimeSheetTaskNames | Gets a set of timesheet task names corresponding to a particular group.
Public method | GetTimesheetTasks | Gets a list of all Active tasks corresponding to a particular group.
Public method | GetTimesheetTasksByGroupId | Gets a set of timesheet tasks corresponding to a particular group.
Public method | GetTimesheetTasksForRdlc | List of timesheet tasks available for a group (used in rdl reports)
Public method | GetTimesheetTasksForTimesheetId | Gets a list of all tasks belonging to a particular timesheet.
Public method | GetTimesheetTasksInfo | Gets the timesheet task Information for active tasks corresponding to a particular timesheet.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnexportedTimesheets | Gets all the information related to the timesheets which have not yet been exported from OfficeClip from a particular group.
Public method | GetUnexportedTimesheetTaskNames | Gets a list of all the timesheet task names corresponding to a particular group which have net yet been exported to QuickBooks.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertTimesheet | Inserts a new timesheet into the database and routes it to a particular user as defined in the workflow.
Public method | InsertTimesheetCommentInfo | Inserts all the Comments related to a particular timesheet into the database.
Public method | InsertTimesheetDetailInfo | Inserts individual timesheet detail items inside an timesheet into the database.
Public method | InsertTimesheetInfo | Inserts a new timesheet into the database.
Public method | insertTimesheetTaskInfo | Inserts all the information related to a task.
Public method | InsertTimesheetTasks | Inserts all the information related to a timesheet Tasks corresponding to a particular group using which members of a group can create timesheets.
Public method | IsTimesheetDetailModified | Finds if the timesheet details is modified
Protected method | markTimesheetDetailModified | marks the timesheet details to be modified
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetTimesheetExported | Sets the expired status of the timesheet
Public method | TimesheetSubmissions | Returns the status of the timesheets submitted for a range of weeks
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateTimesheet | Updates all the information related to a particular timesheet into the database and routes it to a particular user as defined in the workflow.
Public method | UpdateTimesheetCommentInfo | Updates all the Comments related to a particular timesheet into the database.
Public method | updateTimesheetTaskInfo | Inserts all the information related to a task.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


TimesheetDB Constructor

[image]

OfficeClip API Documentation
TimesheetDB Constructor
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimesheetDB()

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


TimesheetDB Methods

[image] [image]

OfficeClip API Documentation
TimesheetDB Methods
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

The TimesheetDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Protected method | createDCAAString | Creates the DCAA string for logging history
Public method | DeleteTimesheet | Deletes a particular timesheet identified by timesheetId.
Public method | DeleteTimesheetDetails | Deletes all the individual timesheet detail items corresponding to a particular timesheet identified by timesheetId.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Public method | ExportTimesheets | Exports a list of timesheets in the QuickBooks timer file format based on the mapping stored corresponding to a particular group.
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveTimesheetTasksInfo | Gets the timesheet task information corresponding to the Active timesheet tasks corresponding to a particular group.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLastTimesheetInfo | Gets all the details of the most recent timesheet created for the a particular user for a particular group.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetParentChildNodes |
Public method | GetParentChildNodeString |
Public method | GetPayrollInfo |
Public method | GetTimesheetActiveRows | Gets a list of number of rows specified in the currently Active timesheet tasks in the current group.
Public method | GetTimesheetAlreadyExists | Checks whether a timesheet has already been created for a given week starting date for a particular user corresponding to a particular group.
Public method | GetTimesheetComments | Gets a list of all Comments corresponding to a particular timesheet.
Public method | GetTimesheetDetails | Gets the details of all the timesheet detail items for a particular timesheet identified by timesheetId.
Public method | GetTimesheetDetailsForCSV |
Public method | GetTimesheetInfo | Gets all the details corresponding to a particular timesheet identified by timesheetId.
Public method | GetTimesheetInfoComments | Gets all the Comments corresponding to a particular timesheet identified by timesheetId.
Public method | GetTimesheetRows | Gets a list of number of rows specified in a particular timesheet tasks.
Public method | GetTimesheets | Gets a list of all the timesheets for a set of users between a given date range for a particular group.
Public method | GetTimesheetsForExport | Gets a set of timesheets which are ready to be exported which were created within a given Date range from a particular group.
Public method | GetTimesheetTaskInfo | Gets all the information related to a particular task identified by taskId.
Public method | GetTimeSheetTaskNames | Gets a set of timesheet task names corresponding to a particular group.
Public method | GetTimesheetTasks | Gets a list of all Active tasks corresponding to a particular group.
Public method | GetTimesheetTasksByGroupId | Gets a set of timesheet tasks corresponding to a particular group.
Public method | GetTimesheetTasksForRdlc | List of timesheet tasks available for a group (used in rdl reports)
Public method | GetTimesheetTasksForTimesheetId | Gets a list of all tasks belonging to a particular timesheet.
Public method | GetTimesheetTasksInfo | Gets the timesheet task Information for active tasks corresponding to a particular timesheet.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnexportedTimesheets | Gets all the information related to the timesheets which have not yet been exported from OfficeClip from a particular group.
Public method | GetUnexportedTimesheetTaskNames | Gets a list of all the timesheet task names corresponding to a particular group which have net yet been exported to QuickBooks.
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertTimesheet | Inserts a new timesheet into the database and routes it to a particular user as defined in the workflow.
Public method | InsertTimesheetCommentInfo | Inserts all the Comments related to a particular timesheet into the database.
Public method | InsertTimesheetDetailInfo | Inserts individual timesheet detail items inside an timesheet into the database.
Public method | InsertTimesheetInfo | Inserts a new timesheet into the database.
Public method | insertTimesheetTaskInfo | Inserts all the information related to a task.
Public method | InsertTimesheetTasks | Inserts all the information related to a timesheet Tasks corresponding to a particular group using which members of a group can create timesheets.
Public method | IsTimesheetDetailModified | Finds if the timesheet details is modified
Protected method | markTimesheetDetailModified | marks the timesheet details to be modified
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetTimesheetExported | Sets the expired status of the timesheet
Public method | TimesheetSubmissions | Returns the status of the timesheets submitted for a range of weeks
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateTimesheet | Updates all the information related to a particular timesheet into the database and routes it to a particular user as defined in the workflow.
Public method | UpdateTimesheetCommentInfo | Updates all the Comments related to a particular timesheet into the database.
Public method | updateTimesheetTaskInfo | Inserts all the information related to a task.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
TimesheetDB..::.AddOutputParameter Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

TimesheetDB Class
TimesheetDB Members
OfficeClip.DBLayer.TE Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
TimesheetDB..::.AddParameter Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

TimesheetDB Class
TimesheetDB Members
OfficeClip.DBLayer.TE Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
TimesheetDB..::.AddParameters Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

TimesheetDB Class
TimesheetDB Members
OfficeClip.DBLayer.TE Namespace


createDCAAString Method

[image]

OfficeClip API Documentation
TimesheetDB..::.createDCAAString Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates the DCAA string for logging history

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string createDCAAString(
    TimesheetDetailInfo tdi,
    bool isAdded,
    PayrollCategoryInfo[] pcis,
    DataTable dtClientProjects,
    ArrayList tasks,
    List<UserInfo> uInfos,
    int userId
)
Visual Basic (Declaration)
Protected Function createDCAAString ( _
    tdi As TimesheetDetailInfo, _
    isAdded As Boolean, _
    pcis As PayrollCategoryInfo(), _
    dtClientProjects As DataTable, _
    tasks As ArrayList, _
    uInfos As List(Of UserInfo), _
    userId As Integer _
) As String
Visual C++
protected:
String^ createDCAAString(
    TimesheetDetailInfo^ tdi,
    bool isAdded,
    array<PayrollCategoryInfo^>^ pcis,
    DataTable^ dtClientProjects,
    ArrayList^ tasks,
    List<UserInfo^>^ uInfos,
    int userId
)

Parameters

tdi
Type: OfficeClip.BusinessLayer.TE..::.TimesheetDetailInfo
isAdded
Type: System..::.Boolean
pcis
Type: array< OfficeClip.BusinessLayer.TE..::.PayrollCategoryInfo >[]()[]
dtClientProjects
Type: System.Data..::.DataTable
tasks
Type: System.Collections..::.ArrayList
uInfos
Type: System.Collections.Generic..::.List<(Of <( UserInfo >)>)
userId
Type: System..::.Int32

Return Value

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


DeleteTimesheet Method

[image]

OfficeClip API Documentation
TimesheetDB..::.DeleteTimesheet Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a particular timesheet identified by timesheetId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteTimesheet(
    int timesheetId,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Function DeleteTimesheet ( _
    timesheetId As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
) As Integer
Visual C++
public:
int DeleteTimesheet(
    int timesheetId,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

timesheetId
Type: System..::.Int32
Id of the timesheet which needs to be deleted.
currentUserId
Type: System..::.Int32
unique id of the current user
isCurrentUserAdmin
Type: System..::.Boolean
is the current user an administrator

Return Value

0 when successful, -1 in case of an error.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


DeleteTimesheetDetails Method

[image]

OfficeClip API Documentation
TimesheetDB..::.DeleteTimesheetDetails Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes all the individual timesheet detail items corresponding to a particular timesheet identified by timesheetId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteTimesheetDetails(
    int timesheetId
)
Visual Basic (Declaration)
Public Function DeleteTimesheetDetails ( _
    timesheetId As Integer _
) As Integer
Visual C++
public:
int DeleteTimesheetDetails(
    int timesheetId
)

Parameters

timesheetId
Type: System..::.Int32
Id of the timesheet for which all the individual timesheet items are to deleted.

Return Value

0 when successful, -1 in case of an error.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
TimesheetDB..::.ExecuteNonQuery Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

TimesheetDB Class
TimesheetDB Members
OfficeClip.DBLayer.TE Namespace


ExportTimesheets Method

[image]

OfficeClip API Documentation
TimesheetDB..::.ExportTimesheets Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Exports a list of timesheets in the QuickBooks timer file format based on the mapping stored corresponding to a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string ExportTimesheets(
    int groupId,
    ArrayList timesheetList
)
Visual Basic (Declaration)
Public Function ExportTimesheets ( _
    groupId As Integer, _
    timesheetList As ArrayList _
) As String
Visual C++
public:
String^ ExportTimesheets(
    int groupId,
    ArrayList^ timesheetList
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.
timesheetList
Type: System.Collections..::.ArrayList
ArrayList of ids of the timesheets to be exported.

Return Value

Text string containing the exported timesheets in the QuickBooks timer file format.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetActiveTimesheetTasksInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetActiveTimesheetTasksInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the timesheet task information corresponding to the Active timesheet tasks corresponding to a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GroupTimesheetTaskInfo GetActiveTimesheetTasksInfo(
    int groupId
)
Visual Basic (Declaration)
Public Function GetActiveTimesheetTasksInfo ( _
    groupId As Integer _
) As GroupTimesheetTaskInfo
Visual C++
public:
GroupTimesheetTaskInfo^ GetActiveTimesheetTasksInfo(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.

Return Value

Instance of the TimesheetTaskInfo object containing all the information related to the Active timesheet tasks. TimesheetTaskInfo

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetLastTimesheetInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetLastTimesheetInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details of the most recent timesheet created for the a particular user for a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetInfo GetLastTimesheetInfo(
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetLastTimesheetInfo ( _
    userId As Integer, _
    groupId As Integer _
) As TimesheetInfo
Visual C++
public:
TimesheetInfo^ GetLastTimesheetInfo(
    int userId,
    int groupId
)

Parameters

userId
Type: System..::.Int32
Id of a particular user. Please note that the user should belong to the group whose Id is passed as argument.
groupId
Type: System..::.Int32
Id of a particular group.

Return Value

Instance of the TimesheetInfo object containing all the information related to the most recent timesheet created for the currently logged in user for the selected group. TimesheetInfo

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetParentChildNodes Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetParentChildNodes Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<ParentChildInfo> GetParentChildNodes(
    int groupId,
    int userId,
    int timesheetId
)
Visual Basic (Declaration)
Public Function GetParentChildNodes ( _
    groupId As Integer, _
    userId As Integer, _
    timesheetId As Integer _
) As List(Of ParentChildInfo)
Visual C++
public:
List<ParentChildInfo^>^ GetParentChildNodes(
    int groupId,
    int userId,
    int timesheetId
)

Parameters

groupId
Type: System..::.Int32
userId
Type: System..::.Int32
timesheetId
Type: System..::.Int32

Return Value

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetParentChildNodeString Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetParentChildNodeString Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetParentChildNodeString(
    List<ParentChildInfo> pcList
)
Visual Basic (Declaration)
Public Function GetParentChildNodeString ( _
    pcList As List(Of ParentChildInfo) _
) As String
Visual C++
public:
String^ GetParentChildNodeString(
    List<ParentChildInfo^>^ pcList
)

Parameters

pcList
Type: System.Collections.Generic..::.List<(Of <( ParentChildInfo >)>)

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetPayrollInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetPayrollInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetPayrollInfo(
    int UserId
)
Visual Basic (Declaration)
Public Function GetPayrollInfo ( _
    UserId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetPayrollInfo(
    int UserId
)

Parameters

UserId
Type: System..::.Int32

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetActiveRows Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetActiveRows Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of number of rows specified in the currently Active timesheet tasks in the current group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetTimesheetActiveRows(
    int currentGroupId
)
Visual Basic (Declaration)
Public Function GetTimesheetActiveRows ( _
    currentGroupId As Integer _
) As DataView
Visual C++
public:
DataView^ GetTimesheetActiveRows(
    int currentGroupId
)

Parameters

currentGroupId
Type: System..::.Int32
Id of a particular group.

Return Value

DataView consisting a single column called rowNumber (System.Int32).

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetAlreadyExists Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetAlreadyExists Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks whether a timesheet has already been created for a given week starting date for a particular user corresponding to a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool GetTimesheetAlreadyExists(
    int userId,
    int groupId,
    DateTime weekStartDate
)
Visual Basic (Declaration)
Public Function GetTimesheetAlreadyExists ( _
    userId As Integer, _
    groupId As Integer, _
    weekStartDate As DateTime _
) As Boolean
Visual C++
public:
bool GetTimesheetAlreadyExists(
    int userId,
    int groupId,
    DateTime weekStartDate
)

Parameters

userId
Type: System..::.Int32
The unique id for the user.
groupId
Type: System..::.Int32
The unique id for the group.
weekStartDate
Type: System..::.DateTime
Week starting date.

Return Value

Flag (True/False) indicating whether a timesheet has already been created for a given week starting date or not.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetComments Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetComments Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all Comments corresponding to a particular timesheet.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTimesheetComments(
    int timesheetId
)
Visual Basic (Declaration)
Public Function GetTimesheetComments ( _
    timesheetId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetTimesheetComments(
    int timesheetId
)

Parameters

timesheetId
Type: System..::.Int32
Id of the timesheet.

Return Value

DataSet containing all the information related to the Comments for a particular timesheet. This DataSet consists of a single DataTable with the following columns.
  • timesheetId (System.Int32)Id of the timesheet.
  • CommentId (System.Int32)Id of the Comment.
  • UserId (System.Int32)Id of the user giving the Comment.
  • UserName (System.String)Name of the user giving the Comment.
  • Comment (System.String)Comment string.
  • CommentDate (System.DateTime)Date and Time when the Comment was given.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetDetails Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetDetails Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the details of all the timesheet detail items for a particular timesheet identified by timesheetId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetTimesheetDetails(
    int timesheetId
)
Visual Basic (Declaration)
Public Function GetTimesheetDetails ( _
    timesheetId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetTimesheetDetails(
    int timesheetId
)

Parameters

timesheetId
Type: System..::.Int32
Id of the timesheet for which all the individual timesheet detail items are to be retrieved.

Return Value

ArrayList of TimesheetDetailInfo object containing all the details of the individual timesheet detail items for a particular timesheet.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetDetailsForCSV Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetDetailsForCSV Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTimesheetDetailsForCSV(
    int timesheetId
)
Visual Basic (Declaration)
Public Function GetTimesheetDetailsForCSV ( _
    timesheetId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetTimesheetDetailsForCSV(
    int timesheetId
)

Parameters

timesheetId
Type: System..::.Int32

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the details corresponding to a particular timesheet identified by timesheetId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetInfo GetTimesheetInfo(
    int timesheetId
)
Visual Basic (Declaration)
Public Function GetTimesheetInfo ( _
    timesheetId As Integer _
) As TimesheetInfo
Visual C++
public:
TimesheetInfo^ GetTimesheetInfo(
    int timesheetId
)

Parameters

timesheetId
Type: System..::.Int32
Id of the timesheet for which all the details are to be retrieved.

Return Value

Instance of the TimesheetInfo object containing all the information related to a particular timesheet. TimesheetInfo

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetInfoComments Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetInfoComments Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the Comments corresponding to a particular timesheet identified by timesheetId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetTimesheetInfoComments(
    int timesheetId
)
Visual Basic (Declaration)
Public Function GetTimesheetInfoComments ( _
    timesheetId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetTimesheetInfoComments(
    int timesheetId
)

Parameters

timesheetId
Type: System..::.Int32
Id of the timesheet for which all the Comments are to be retrieved.

Return Value

ArrayList of TimesheetCommentInfo objects corresponding to each Comment entered in a particular timesheet.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetRows Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetRows Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of number of rows specified in a particular timesheet tasks.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataView GetTimesheetRows(
    int numRows
)
Visual Basic (Declaration)
Public Function GetTimesheetRows ( _
    numRows As Integer _
) As DataView
Visual C++
public:
DataView^ GetTimesheetRows(
    int numRows
)

Parameters

numRows
Type: System..::.Int32
The number of rows.

Return Value

DataView consisting a single column called rowNumber (System.Int32).

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheets Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheets Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the timesheets for a set of users between a given date range for a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTimesheets(
    int groupId,
    string userList,
    DateTime fromDate,
    DateTime toDate,
    bool isRestricted
)
Visual Basic (Declaration)
Public Function GetTimesheets ( _
    groupId As Integer, _
    userList As String, _
    fromDate As DateTime, _
    toDate As DateTime, _
    isRestricted As Boolean _
) As DataSet
Visual C++
public:
DataSet^ GetTimesheets(
    int groupId,
    String^ userList,
    DateTime fromDate,
    DateTime toDate,
    bool isRestricted
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.
userList
Type: System..::.String
Comma delimited list of userIds for whom the timesheets are to be retrieved.
fromDate
Type: System..::.DateTime
Starting Date of the range.
toDate
Type: System..::.DateTime
Ending Date of the range.
isRestricted
Type: System..::.Boolean

Return Value

DataSet containing all the information related to all the timesheets for the respective users within the date range. This DataSet consists of a single DataTable with the following columns.
  • hours (System.Int32)Total number of hours in the timesheet.
  • timesheetId (System.Int32)Id of the timesheet.
  • status (System.String)Current status of the timesheet.
  • weekStartDate (System.String)Starting date of the timesheet.
  • name (System.String)User to which the timesheet belongs.
  • emailAddress (System.String)Email Address of the user.
  • withUserName (System.String)Name of the user to whom this timesheet is currently submitted.
  • withUserEmailAddress (System.String)Email Address of the user to whom this timesheet is currently submitted.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetsForExport Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetsForExport Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a set of timesheets which are ready to be exported which were created within a given Date range from a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTimesheetsForExport(
    int groupId,
    DateTime fromDate,
    DateTime toDate
)
Visual Basic (Declaration)
Public Function GetTimesheetsForExport ( _
    groupId As Integer, _
    fromDate As DateTime, _
    toDate As DateTime _
) As DataSet
Visual C++
public:
DataSet^ GetTimesheetsForExport(
    int groupId,
    DateTime fromDate,
    DateTime toDate
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.
fromDate
Type: System..::.DateTime
Starting date of the range.
toDate
Type: System..::.DateTime
Ending date of the ranage.

Return Value

DataSet containing all the information related to the timesheets which are ready to be exported. This DataSet consists of a single DataTable with the following columns.
  • timesheetId (System.Int32)Id of the timesheet which is ready to be exported.
  • fromDate (System.DateTime)Starting date of the duration for which the timesheet was created.
  • toDate (System.DateTime)Ending date of the duration for which the timesheet was created.
  • createdTimestamp (System.DateTime)The timestamp when the timesheet was created.
  • createdByUserId (System.Int32)The user id of the user for which the timesheet was created.
  • name (System.String)Name of the user for which the timesheet was created.
  • approvedByUser (System.String)Name of the user who has approved the timesheet.
  • status (System.String)Flag (Y/N) indicating whether this particular timesheet has already been exported or not.
  • exportTimestamp (System.DateTime)Date and time when the timesheet was exported.
  • isActive (System.String)Returns "Y" if the timesheet is active.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetTaskInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetTaskInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to a particular task identified by taskId.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TimesheetTaskInfo GetTimesheetTaskInfo(
    int taskId
)
Visual Basic (Declaration)
Public Function GetTimesheetTaskInfo ( _
    taskId As Integer _
) As TimesheetTaskInfo
Visual C++
public:
TimesheetTaskInfo^ GetTimesheetTaskInfo(
    int taskId
)

Parameters

taskId
Type: System..::.Int32
Task Id corresponding to a particular task.

Return Value

Instance of the TimesheetTaskInfo object corresponding to the taskId.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimeSheetTaskNames Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimeSheetTaskNames Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a set of timesheet task names corresponding to a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SqlDataReader GetTimeSheetTaskNames(
    int groupId
)
Visual Basic (Declaration)
Public Function GetTimeSheetTaskNames ( _
    groupId As Integer _
) As SqlDataReader
Visual C++
public:
SqlDataReader^ GetTimeSheetTaskNames(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.

Return Value

SqlDataReader containing all the details of the timesheet tasks. The SqlDataReader returns a single column TaskName (System.String).

Remarks

Make sure to Close the SqlDataReader after the use otherwise it will leave and connection open (till garbage collector releases the Data Reader). If not closed explicitly, the .Net framework might hang and slow down because of the number of open connections Limit might be reached.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetTasks Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetTasks Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all Active tasks corresponding to a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetTimesheetTasks(
    int groupId
)
Visual Basic (Declaration)
Public Function GetTimesheetTasks ( _
    groupId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetTimesheetTasks(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique Id of the group

Return Value

ArrayList of the TimesheetTaskInfo objects corresponding to each task that belongs to a particular group.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetTasksByGroupId Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetTasksByGroupId Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a set of timesheet tasks corresponding to a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetTimesheetTasksByGroupId(
    int groupId
)
Visual Basic (Declaration)
Public Function GetTimesheetTasksByGroupId ( _
    groupId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetTimesheetTasksByGroupId(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.

Return Value

ArrayList containing all the details of the timesheetTasks corresponding to a particular group.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetTasksForRdlc Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetTasksForRdlc Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

List of timesheet tasks available for a group (used in rdl reports)

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTimesheetTasksForRdlc(
    int groupId
)
Visual Basic (Declaration)
Public Function GetTimesheetTasksForRdlc ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetTimesheetTasksForRdlc(
    int groupId
)

Parameters

groupId
Type: System..::.Int32

Return Value

List of tasks in DataSet

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetTasksForTimesheetId Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetTasksForTimesheetId Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all tasks belonging to a particular timesheet.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetTimesheetTasksForTimesheetId(
    int groupId,
    int timesheetId
)
Visual Basic (Declaration)
Public Function GetTimesheetTasksForTimesheetId ( _
    groupId As Integer, _
    timesheetId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetTimesheetTasksForTimesheetId(
    int groupId,
    int timesheetId
)

Parameters

groupId
Type: System..::.Int32
The Unique Id of the group
timesheetId
Type: System..::.Int32
Id of the timesheet for which the task list has to be retrieved. If the timesheetId is -1 then will return all the active tasks of the group.

Return Value

ArrayList of the TimesheetTaskInfo objects corresponding to each task that belongs to a particular timesheet.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetTimesheetTasksInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetTimesheetTasksInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the timesheet task Information for active tasks corresponding to a particular timesheet.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public GroupTimesheetTaskInfo GetTimesheetTasksInfo(
    int groupId,
    int timesheetId
)
Visual Basic (Declaration)
Public Function GetTimesheetTasksInfo ( _
    groupId As Integer, _
    timesheetId As Integer _
) As GroupTimesheetTaskInfo
Visual C++
public:
GroupTimesheetTaskInfo^ GetTimesheetTasksInfo(
    int groupId,
    int timesheetId
)

Parameters

groupId
Type: System..::.Int32
The unique Id of group
timesheetId
Type: System..::.Int32
Id of the timesheet for which all the tasks is to be retrieved. If timesheetId is -1 then returns all active tasks of the group

Return Value

Instance of the TimesheetTaskInfo object containing all the information related to a particular timesheet TimesheetTaskInfo

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetUnexportedTimesheets Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetUnexportedTimesheets Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the information related to the timesheets which have not yet been exported from OfficeClip from a particular group.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetUnexportedTimesheets(
    int groupId
)
Visual Basic (Declaration)
Public Function GetUnexportedTimesheets ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetUnexportedTimesheets(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.

Return Value

DataSet containing all the information related to the timesheets which have not yet been exported from OfficeClip. This DataSet consists of a single DataTable with the following columns.
  • timesheetId (System.Int32)Id of the timesheet which has not yet been exported.
  • fromDate (System.DateTime)Starting Date of the duration for which the timesheet was created.
  • toDate (System.DateTime)Ending date of duration for which the timesheet was created.
  • name (System.String)Name of the user for which the timesheet was created.
  • approvedByUser (System.String)Name of the user who approved the timesheet.
  • status (System.String)Flag (Y/N) indicating the status whether the timesheet has been exported or not.
  • exportTimestamp (System.DateTime)Date and Time when the timesheet was exported. Please note as this timesheet has not yet been exported, this field will always be null.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


GetUnexportedTimesheetTaskNames Method

[image]

OfficeClip API Documentation
TimesheetDB..::.GetUnexportedTimesheetTaskNames Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the timesheet task names corresponding to a particular group which have net yet been exported to QuickBooks.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetUnexportedTimesheetTaskNames(
    int groupId
)
Visual Basic (Declaration)
Public Function GetUnexportedTimesheetTaskNames ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetUnexportedTimesheetTaskNames(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
Id of a particular group.

Return Value

DataSet consisting of all the timesheet task names which have not yet been exported to QuickBooks. This DataSet consists of a single DataTable containing a single column TaskName (System.String)

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
TimesheetDB..::.InitTransaction Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

TimesheetDB Class
TimesheetDB Members
OfficeClip.DBLayer.TE Namespace


InsertTimesheet Method

[image]

OfficeClip API Documentation
TimesheetDB..::.InsertTimesheet Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new timesheet into the database and routes it to a particular user as defined in the workflow.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertTimesheet(
    TimesheetInfo ti,
    WorkflowAction wa,
    int routeToUserId,
    int stageId,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function InsertTimesheet ( _
    ti As TimesheetInfo, _
    wa As WorkflowAction, _
    routeToUserId As Integer, _
    stageId As Integer, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int InsertTimesheet(
    TimesheetInfo^ ti,
    WorkflowAction wa,
    int routeToUserId,
    int stageId,
    ConfigureInfo^ session
)

Parameters

ti
Type: OfficeClip.BusinessLayer.TE..::.TimesheetInfo
Instance of the TimesheetInfo object containing all the information related to the timesheet. TimesheetInfo
wa
Type: OfficeClip.Utils..::.WorkflowAction
Workflow action to be applied after inserting the new timesheet.
routeToUserId
Type: System..::.Int32
Id of the user to whom the timesheet should be routed.
stageId
Type: System..::.Int32
Stage Id of the user as defined in the workflow who is creating the new timesheet.
session
Type: OfficeClip.Utils..::.ConfigureInfo
The session settings for the user

Return Value

Id of the newly created timesheet if successful, -1 in case of an error.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


InsertTimesheetCommentInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.InsertTimesheetCommentInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the Comments related to a particular timesheet into the database.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertTimesheetCommentInfo(
    TimesheetCommentInfo tci,
    int currentUserId
)
Visual Basic (Declaration)
Public Function InsertTimesheetCommentInfo ( _
    tci As TimesheetCommentInfo, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int InsertTimesheetCommentInfo(
    TimesheetCommentInfo^ tci,
    int currentUserId
)

Parameters

tci
Type: OfficeClip.BusinessLayer.TE..::.TimesheetCommentInfo
Instance of the TimesheetCommentInfo object containing the Comment information related to a particular timesheet.
currentUserId
Type: System..::.Int32
The unique id of the current user

Return Value

0 when successful, -1 in case of an error.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


InsertTimesheetDetailInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.InsertTimesheetDetailInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts individual timesheet detail items inside an timesheet into the database.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertTimesheetDetailInfo(
    TimesheetDetailInfo tdti,
    int currentUserId
)
Visual Basic (Declaration)
Public Function InsertTimesheetDetailInfo ( _
    tdti As TimesheetDetailInfo, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int InsertTimesheetDetailInfo(
    TimesheetDetailInfo^ tdti,
    int currentUserId
)

Parameters

tdti
Type: OfficeClip.BusinessLayer.TE..::.TimesheetDetailInfo
Instance of the TimesheetDetailInfo object containing all the details of an individual timesheet detail item. TimesheetDetailInfo
currentUserId
Type: System..::.Int32
Unique id of the current user

Return Value

0 when successful, -1 in case of an error.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


InsertTimesheetInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.InsertTimesheetInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new timesheet into the database.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertTimesheetInfo(
    TimesheetInfo ti,
    int currentGroupId,
    int currentUserId
)
Visual Basic (Declaration)
Public Function InsertTimesheetInfo ( _
    ti As TimesheetInfo, _
    currentGroupId As Integer, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int InsertTimesheetInfo(
    TimesheetInfo^ ti,
    int currentGroupId,
    int currentUserId
)

Parameters

ti
Type: OfficeClip.BusinessLayer.TE..::.TimesheetInfo
Instance of the TimesheetInfo object containing all the information related to a particular timesheet. TimesheetInfo
currentGroupId
Type: System..::.Int32
Unique id of the current group
currentUserId
Type: System..::.Int32
Unique id of the current user

Return Value

Id of the newly created timesheet, -1 in case of an error.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


insertTimesheetTaskInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.insertTimesheetTaskInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the information related to a task.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int insertTimesheetTaskInfo(
    TimesheetTaskInfo ttsi
)
Visual Basic (Declaration)
Public Function insertTimesheetTaskInfo ( _
    ttsi As TimesheetTaskInfo _
) As Integer
Visual C++
public:
int insertTimesheetTaskInfo(
    TimesheetTaskInfo^ ttsi
)

Parameters

ttsi
Type: OfficeClip.BusinessLayer.TE..::.TimesheetTaskInfo
Instance of the TimesheetTaskInfo object containing all the information related to the timesheet tasks. TimesheetTaskInfo

Return Value

taskId when successful, -1 in case of an error.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


InsertTimesheetTasks Method

[image]

OfficeClip API Documentation
TimesheetDB..::.InsertTimesheetTasks Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the information related to a timesheet Tasks corresponding to a particular group using which members of a group can create timesheets.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertTimesheetTasks(
    int groupId,
    GroupTimesheetTaskInfo ttmi
)
Visual Basic (Declaration)
Public Function InsertTimesheetTasks ( _
    groupId As Integer, _
    ttmi As GroupTimesheetTaskInfo _
) As Integer
Visual C++
public:
int InsertTimesheetTasks(
    int groupId,
    GroupTimesheetTaskInfo^ ttmi
)

Parameters

groupId
Type: System..::.Int32
The unique id for the group.
ttmi
Type: OfficeClip.BusinessLayer.TE..::.GroupTimesheetTaskInfo
Instance of the GroupTimesheetTaskInfo object containing all the information related to the timesheet tasks. GroupTimesheetTaskInfo

Return Value

returns 1 when successful, -1 in case of an error.

Remarks

When a Task item is removed that one is marked as inactive but not actually deleted. This is to ensure that the timesheets created using the removed taskitem keep working and follow the the workflow and task details as defined in the timesheet tasks.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


IsTimesheetDetailModified Method

[image]

OfficeClip API Documentation
TimesheetDB..::.IsTimesheetDetailModified Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Finds if the timesheet details is modified

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsTimesheetDetailModified(
    TimesheetInfo ti
)
Visual Basic (Declaration)
Public Function IsTimesheetDetailModified ( _
    ti As TimesheetInfo _
) As Boolean
Visual C++
public:
bool IsTimesheetDetailModified(
    TimesheetInfo^ ti
)

Parameters

ti
Type: OfficeClip.BusinessLayer.TE..::.TimesheetInfo

Return Value

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


markTimesheetDetailModified Method

[image]

OfficeClip API Documentation
TimesheetDB..::.markTimesheetDetailModified Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

marks the timesheet details to be modified

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void markTimesheetDetailModified(
    TimesheetInfo ti,
    ref TimesheetInfo tiOld
)
Visual Basic (Declaration)
Protected Sub markTimesheetDetailModified ( _
    ti As TimesheetInfo, _
    ByRef tiOld As TimesheetInfo _
)
Visual C++
protected:
void markTimesheetDetailModified(
    TimesheetInfo^ ti,
    TimesheetInfo^% tiOld
)

Parameters

ti
Type: OfficeClip.BusinessLayer.TE..::.TimesheetInfo
tiOld
Type: OfficeClip.BusinessLayer.TE..::.TimesheetInfo %

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
TimesheetDB..::.SetSPCommand Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

TimesheetDB Class
TimesheetDB Members
OfficeClip.DBLayer.TE Namespace


SetTimesheetExported Method

[image]

OfficeClip API Documentation
TimesheetDB..::.SetTimesheetExported Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the expired status of the timesheet

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetTimesheetExported(
    int id
)
Visual Basic (Declaration)
Public Sub SetTimesheetExported ( _
    id As Integer _
)
Visual C++
public:
void SetTimesheetExported(
    int id
)

Parameters

id
Type: System..::.Int32
The unique id of the timesheet

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


TimesheetSubmissions Method

[image]

OfficeClip API Documentation
TimesheetDB..::.TimesheetSubmissions Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the status of the timesheets submitted for a range of weeks

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable TimesheetSubmissions(
    int groupId,
    int numWeeks
)
Visual Basic (Declaration)
Public Function TimesheetSubmissions ( _
    groupId As Integer, _
    numWeeks As Integer _
) As DataTable
Visual C++
public:
DataTable^ TimesheetSubmissions(
    int groupId,
    int numWeeks
)

Parameters

groupId
Type: System..::.Int32
The system provided unique id of the current group
numWeeks
Type: System..::.Int32
The number of weeks from the current week

Return Value

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


UpdateTimesheet Method

[image]

OfficeClip API Documentation
TimesheetDB..::.UpdateTimesheet Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the information related to a particular timesheet into the database and routes it to a particular user as defined in the workflow.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateTimesheet(
    TimesheetInfo ti,
    WorkflowAction wa,
    int routeToUserId,
    int stageId,
    bool isDCAA,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function UpdateTimesheet ( _
    ti As TimesheetInfo, _
    wa As WorkflowAction, _
    routeToUserId As Integer, _
    stageId As Integer, _
    isDCAA As Boolean, _
    session As ConfigureInfo _
) As Integer
Visual C++
public:
int UpdateTimesheet(
    TimesheetInfo^ ti,
    WorkflowAction wa,
    int routeToUserId,
    int stageId,
    bool isDCAA,
    ConfigureInfo^ session
)

Parameters

ti
Type: OfficeClip.BusinessLayer.TE..::.TimesheetInfo
Instance of the TimesheetInfo object containing all the information related to a particular timesheet.
wa
Type: OfficeClip.Utils..::.WorkflowAction
Workflow action to be applied after inserting the new expense.
routeToUserId
Type: System..::.Int32
Id of the user to whom the timesheet should be routed.
stageId
Type: System..::.Int32
Stage Id of the user as defined in the workflow who is creating the new expense.
isDCAA
Type: System..::.Boolean
Is the DCAA logging is activated
session
Type: OfficeClip.Utils..::.ConfigureInfo
The session settings for the user

Return Value

Id of the timesheet being updated when successful, -1 in case of an error.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


UpdateTimesheetCommentInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.UpdateTimesheetCommentInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates all the Comments related to a particular timesheet into the database.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateTimesheetCommentInfo(
    TimesheetCommentInfo tci
)
Visual Basic (Declaration)
Public Function UpdateTimesheetCommentInfo ( _
    tci As TimesheetCommentInfo _
) As Integer
Visual C++
public:
int UpdateTimesheetCommentInfo(
    TimesheetCommentInfo^ tci
)

Parameters

tci
Type: OfficeClip.BusinessLayer.TE..::.TimesheetCommentInfo
Instance of the TimesheetCommentInfo object containing the Comment information related to a particular timesheet.

Return Value

0 when successful, -1 in case of an error.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


updateTimesheetTaskInfo Method

[image]

OfficeClip API Documentation
TimesheetDB..::.updateTimesheetTaskInfo Method
TimesheetDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts all the information related to a task.

Namespace: OfficeClip.DBLayer.TE
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int updateTimesheetTaskInfo(
    TimesheetTaskInfo ttsi
)
Visual Basic (Declaration)
Public Function updateTimesheetTaskInfo ( _
    ttsi As TimesheetTaskInfo _
) As Integer
Visual C++
public:
int updateTimesheetTaskInfo(
    TimesheetTaskInfo^ ttsi
)

Parameters

ttsi
Type: OfficeClip.BusinessLayer.TE..::.TimesheetTaskInfo
Instance of the TimesheetTaskInfo object containing all the information related to the timesheet tasks. TimesheetTaskInfo

Return Value

0 when successful, -1 in case of an error.

See Also

TimesheetDB Class
OfficeClip.DBLayer.TE Namespace


OfficeClip.DBLayer.Template Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Template Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip email templates

Classes

 | Class | Description
Public class | LetterheadDB | The DBLayer utilities for letterheads
Public class | TemplateDB | The DBLayer utilities templates
Public class | TemplateMailThreadDB |


LetterheadDB Class

[image]

OfficeClip API Documentation
LetterheadDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

The DBLayer utilities for letterheads

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class LetterheadDB : OfficeClipDB
Visual Basic (Declaration)
Public Class LetterheadDB _
    Inherits OfficeClipDB
Visual C++
public ref class LetterheadDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Template..::.LetterheadDB

See Also

LetterheadDB Members
OfficeClip.DBLayer.Template Namespace


LetterheadDB Members

[image] [image]

OfficeClip API Documentation
LetterheadDB Members
LetterheadDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The LetterheadDB type exposes the following members.

Constructors

 | Name | Description
Public method | LetterheadDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteLetterhead | Deletes the letterhead
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLetterhead | Get instance of Letterhead from the database
Public method | GetLetterheadList | Get all instances of Letterhead from the database
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertLetterhead | Inserts the letterhead
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLetterhead | Updates the letterhead

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

LetterheadDB Class
OfficeClip.DBLayer.Template Namespace


LetterheadDB Constructor

[image]

OfficeClip API Documentation
LetterheadDB Constructor
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public LetterheadDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LetterheadDB()

See Also

LetterheadDB Class
OfficeClip.DBLayer.Template Namespace


LetterheadDB Methods

[image] [image]

OfficeClip API Documentation
LetterheadDB Methods
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

The LetterheadDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteLetterhead | Deletes the letterhead
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLetterhead | Get instance of Letterhead from the database
Public method | GetLetterheadList | Get all instances of Letterhead from the database
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertLetterhead | Inserts the letterhead
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateLetterhead | Updates the letterhead

See Also

LetterheadDB Class
OfficeClip.DBLayer.Template Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
LetterheadDB..::.AddOutputParameter Method
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

LetterheadDB Class
LetterheadDB Members
OfficeClip.DBLayer.Template Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
LetterheadDB..::.AddParameter Method
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

LetterheadDB Class
LetterheadDB Members
OfficeClip.DBLayer.Template Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
LetterheadDB..::.AddParameters Method
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

LetterheadDB Class
LetterheadDB Members
OfficeClip.DBLayer.Template Namespace


DeleteLetterhead Method

[image]

OfficeClip API Documentation
LetterheadDB..::.DeleteLetterhead Method
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the letterhead

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteLetterhead(
    int letterheadId
)
Visual Basic (Declaration)
Public Sub DeleteLetterhead ( _
    letterheadId As Integer _
)
Visual C++
public:
void DeleteLetterhead(
    int letterheadId
)

Parameters

letterheadId
Type: System..::.Int32
The unique id of the letterhead

See Also

LetterheadDB Class
OfficeClip.DBLayer.Template Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
LetterheadDB..::.ExecuteNonQuery Method
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

LetterheadDB Class
LetterheadDB Members
OfficeClip.DBLayer.Template Namespace


GetLetterhead Method

[image]

OfficeClip API Documentation
LetterheadDB..::.GetLetterhead Method
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Get instance of Letterhead from the database

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public LetterheadInfo GetLetterhead(
    int letterheadId
)
Visual Basic (Declaration)
Public Function GetLetterhead ( _
    letterheadId As Integer _
) As LetterheadInfo
Visual C++
public:
LetterheadInfo^ GetLetterhead(
    int letterheadId
)

Parameters

letterheadId
Type: System..::.Int32
The unique id of the Letterhead in the database

Return Value

The LetterheadInfo information structure, null if the Letterhead is not found

See Also

LetterheadDB Class
OfficeClip.DBLayer.Template Namespace


GetLetterheadList Method

[image]

OfficeClip API Documentation
LetterheadDB..::.GetLetterheadList Method
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Get all instances of Letterhead from the database

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public LetterheadInfo[] GetLetterheadList(
    int userId
)
Visual Basic (Declaration)
Public Function GetLetterheadList ( _
    userId As Integer _
) As LetterheadInfo()
Visual C++
public:
array<LetterheadInfo^>^ GetLetterheadList(
    int userId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user

Return Value

The LetterheadInfo information structure, null if the Letterhead is not found

See Also

LetterheadDB Class
OfficeClip.DBLayer.Template Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
LetterheadDB..::.InitTransaction Method
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

LetterheadDB Class
LetterheadDB Members
OfficeClip.DBLayer.Template Namespace


InsertLetterhead Method

[image]

OfficeClip API Documentation
LetterheadDB..::.InsertLetterhead Method
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the letterhead

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertLetterhead(
    LetterheadInfo li
)
Visual Basic (Declaration)
Public Function InsertLetterhead ( _
    li As LetterheadInfo _
) As Integer
Visual C++
public:
int InsertLetterhead(
    LetterheadInfo^ li
)

Parameters

li
Type: OfficeClip.BusinessLayer.Template..::.LetterheadInfo
The letterhead information object

Return Value

a positive letterhead id if successful

See Also

LetterheadDB Class
OfficeClip.DBLayer.Template Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
LetterheadDB..::.SetSPCommand Method
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

LetterheadDB Class
LetterheadDB Members
OfficeClip.DBLayer.Template Namespace


UpdateLetterhead Method

[image]

OfficeClip API Documentation
LetterheadDB..::.UpdateLetterhead Method
LetterheadDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the letterhead

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateLetterhead(
    int letterheadId,
    string html,
    int lastUpdatedUserId
)
Visual Basic (Declaration)
Public Sub UpdateLetterhead ( _
    letterheadId As Integer, _
    html As String, _
    lastUpdatedUserId As Integer _
)
Visual C++
public:
void UpdateLetterhead(
    int letterheadId,
    String^ html,
    int lastUpdatedUserId
)

Parameters

letterheadId
Type: System..::.Int32
The unique id of the letterhead
html
Type: System..::.String
The html part of the letterhead
lastUpdatedUserId
Type: System..::.Int32
The user id of the user who last updated the letterhead

See Also

LetterheadDB Class
OfficeClip.DBLayer.Template Namespace


TemplateDB Class

[image]

OfficeClip API Documentation
TemplateDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

The DBLayer utilities templates

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TemplateDB : OfficeClipDB
Visual Basic (Declaration)
Public Class TemplateDB _
    Inherits OfficeClipDB
Visual C++
public ref class TemplateDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Template..::.TemplateDB

See Also

TemplateDB Members
OfficeClip.DBLayer.Template Namespace


TemplateDB Members

[image] [image]

OfficeClip API Documentation
TemplateDB Members
TemplateDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TemplateDB type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateDB | Overloaded.

Methods

 | Name | Description
Public method | AddMetaTemplateValues |
Public method | AddOfficeClipConstants | Adds the officeclip constants
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | AddRecipientUser | Adds the recepients
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteCampaign | Delete the campaign and all associated information
Public method | DeleteCampaignDetail | Deletes the campaign details
Public method | DeleteTemplate | Deletes the template
Public method | DisconnectSMTP |
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllCampaignsForContact | Gets the campaign information for a particular contact
Public method | GetCampaignDetails | Get the details of the campaign
Public method | GetCampaignDetailsInfo |
Public method | GetCampaignInfo | Gets the campaign information
Public method | GetCampaigns | Gats all the campaign information for the group
Public method | GetCampaignSentEmailText | Get the email text that is sent for the campaign
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetItems | Gets the object items of teh template
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetRemainingCampaignsForContact | Gets all campaigns for the contact
Public method | GetSystemTemplateValues | Returns the hashtable related to the system template. This hashtable returns all the keys and values.
Public method | GetTemplate | Get instance of Template from the database
Public method | GetTemplateCampaignInfo |
Public method | GetTemplateItems | Gets the items for the template
Public method | GetTemplateList | Get all instances of Template from the database
Protected method | GetTrackEmailOpenedHtml | Gets the tracker code for the html email
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueSystemTemplate | Gets the unique system template
Public method | GetUniqueTemplate | Gets the unique template from the database
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertCampaign | Inserts a campaign
Public method | InsertCampaignDetail | Insert the campaign details
Public method | InsertTemplate | Inserts a template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SendAnnounceSystemEmail | Sends the announcement email
Public method | SendBulletingBoardForumSystemEmail |
Public method | SendBulletingBoardReplySystemEmail |
Public method | SendBulletingBoardTopicSystemEmail |
Public method | SendCampaignEmails | Sends all the campaign emails
Public method | SendCustomerPortalPasswordViaSystemEmail | Sends the Extranet password via email
Protected method | SendEmail | Sends the email via OfficeClip templates
Public method | SendEventSystemEmail |
Public method | SendExtranetAdminUserEmail | Sends the extranet admin user email
Public method | SendExtranetCalendarRequestEventEmail | Sets the extranet calendar request event email
Public method | SendExtranetIssueTrackerEmail | Sends the extranet issue tracker email
Public method | SendExtranetPublicUserEmail | Sends the extranet public user email
Public method | SendForgotPasswordEmail | Sends the forgot password email
Public method | SendGenericSystemEmail |
Public method | SendGroupSystemEmail |
Public method | SendInviteMemberInGroup |
Public method | SendIssueTrackerSystemEmail |
Public method | SendLDAPInviteMemberInGroup |
Public method | SendLdapSystemEmail | Not Used
Public method | SendMetaTemplateEmail | This function is mainly used for user templates
Public method | SendPasswordSystemEmail |
Public method | SendPollSystemEmail | Not Used
Protected method | SendSystemTemplateSMS | Sends the sms
Public method | SendTimeAndExpensesSystemEmail |
Public method | SendUserDetailSystemEmail | Not Used
Protected method | SetCampaignEmailSentStatus | Sets the sent status of the campaign
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAccountTemplate | Updates the account template
Public method | UpdateCampaign | Updates the campaign
Public method | UpdateCampaignDetail | Updates the campaign detail
Public method | UpdateCampaignEmailOpened | Updates the campaign email opened status
Public method | UpdateCampaignEmailParameters | Updates the campaign email parameters
Public method | UpdateCampaignEmailSentText | Updates the campaign email text
Public method | UpdTemplateCampaignInfo |

Properties

 | Name | Description
Public property | AdminEmailAddress |
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)
Public property | HostStr |
Public property | HostURL |
Public property | UniqueID |

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


TemplateDB Constructor

[image] [image]

OfficeClip API Documentation
TemplateDB Constructor
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | TemplateDB()()() |
Public method | TemplateDB(String, String, String, String, String) |

See Also

TemplateDB Class
TemplateDB Members
OfficeClip.DBLayer.Template Namespace


TemplateDB Constructor

[image]

OfficeClip API Documentation
TemplateDB Constructor
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateDB()

See Also

TemplateDB Class
TemplateDB Overload
OfficeClip.DBLayer.Template Namespace


TemplateDB Constructor (String, String, String, String, String)

[image]

OfficeClip API Documentation
TemplateDB Constructor (String, String, String, String, String)
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateDB(
    string hostUrl,
    string hostStr,
    string uniqueId,
    string adminEmailId,
    string connString
)
Visual Basic (Declaration)
Public Sub New ( _
    hostUrl As String, _
    hostStr As String, _
    uniqueId As String, _
    adminEmailId As String, _
    connString As String _
)
Visual C++
public:
TemplateDB(
    String^ hostUrl,
    String^ hostStr,
    String^ uniqueId,
    String^ adminEmailId,
    String^ connString
)

Parameters

hostUrl
Type: System..::.String
hostStr
Type: System..::.String
uniqueId
Type: System..::.String
adminEmailId
Type: System..::.String
connString
Type: System..::.String

See Also

TemplateDB Class
TemplateDB Overload
OfficeClip.DBLayer.Template Namespace


TemplateDB Methods

[image] [image]

OfficeClip API Documentation
TemplateDB Methods
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddMetaTemplateValues |
Public method | AddOfficeClipConstants | Adds the officeclip constants
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | AddRecipientUser | Adds the recepients
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteCampaign | Delete the campaign and all associated information
Public method | DeleteCampaignDetail | Deletes the campaign details
Public method | DeleteTemplate | Deletes the template
Public method | DisconnectSMTP |
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllCampaignsForContact | Gets the campaign information for a particular contact
Public method | GetCampaignDetails | Get the details of the campaign
Public method | GetCampaignDetailsInfo |
Public method | GetCampaignInfo | Gets the campaign information
Public method | GetCampaigns | Gats all the campaign information for the group
Public method | GetCampaignSentEmailText | Get the email text that is sent for the campaign
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetItems | Gets the object items of teh template
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetRemainingCampaignsForContact | Gets all campaigns for the contact
Public method | GetSystemTemplateValues | Returns the hashtable related to the system template. This hashtable returns all the keys and values.
Public method | GetTemplate | Get instance of Template from the database
Public method | GetTemplateCampaignInfo |
Public method | GetTemplateItems | Gets the items for the template
Public method | GetTemplateList | Get all instances of Template from the database
Protected method | GetTrackEmailOpenedHtml | Gets the tracker code for the html email
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueSystemTemplate | Gets the unique system template
Public method | GetUniqueTemplate | Gets the unique template from the database
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertCampaign | Inserts a campaign
Public method | InsertCampaignDetail | Insert the campaign details
Public method | InsertTemplate | Inserts a template
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SendAnnounceSystemEmail | Sends the announcement email
Public method | SendBulletingBoardForumSystemEmail |
Public method | SendBulletingBoardReplySystemEmail |
Public method | SendBulletingBoardTopicSystemEmail |
Public method | SendCampaignEmails | Sends all the campaign emails
Public method | SendCustomerPortalPasswordViaSystemEmail | Sends the Extranet password via email
Protected method | SendEmail | Sends the email via OfficeClip templates
Public method | SendEventSystemEmail |
Public method | SendExtranetAdminUserEmail | Sends the extranet admin user email
Public method | SendExtranetCalendarRequestEventEmail | Sets the extranet calendar request event email
Public method | SendExtranetIssueTrackerEmail | Sends the extranet issue tracker email
Public method | SendExtranetPublicUserEmail | Sends the extranet public user email
Public method | SendForgotPasswordEmail | Sends the forgot password email
Public method | SendGenericSystemEmail |
Public method | SendGroupSystemEmail |
Public method | SendInviteMemberInGroup |
Public method | SendIssueTrackerSystemEmail |
Public method | SendLDAPInviteMemberInGroup |
Public method | SendLdapSystemEmail | Not Used
Public method | SendMetaTemplateEmail | This function is mainly used for user templates
Public method | SendPasswordSystemEmail |
Public method | SendPollSystemEmail | Not Used
Protected method | SendSystemTemplateSMS | Sends the sms
Public method | SendTimeAndExpensesSystemEmail |
Public method | SendUserDetailSystemEmail | Not Used
Protected method | SetCampaignEmailSentStatus | Sets the sent status of the campaign
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateAccountTemplate | Updates the account template
Public method | UpdateCampaign | Updates the campaign
Public method | UpdateCampaignDetail | Updates the campaign detail
Public method | UpdateCampaignEmailOpened | Updates the campaign email opened status
Public method | UpdateCampaignEmailParameters | Updates the campaign email parameters
Public method | UpdateCampaignEmailSentText | Updates the campaign email text
Public method | UpdTemplateCampaignInfo |

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


AddMetaTemplateValues Method

[image]

OfficeClip API Documentation
TemplateDB..::.AddMetaTemplateValues Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public Hashtable AddMetaTemplateValues(
    Hashtable ht,
    MetaConstants..::.MetaEntity me,
    int externalId,
    int pkId,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function AddMetaTemplateValues ( _
    ht As Hashtable, _
    me As MetaConstants..::.MetaEntity, _
    externalId As Integer, _
    pkId As Integer, _
    session As ConfigureInfo _
) As Hashtable
Visual C++
public:
Hashtable^ AddMetaTemplateValues(
    Hashtable^ ht,
    MetaConstants..::.MetaEntity me,
    int externalId,
    int pkId,
    ConfigureInfo^ session
)

Parameters

ht
Type: System.Collections..::.Hashtable
me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
externalId
Type: System..::.Int32
pkId
Type: System..::.Int32
session
Type: OfficeClip.Utils..::.ConfigureInfo

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


AddOfficeClipConstants Method

[image]

OfficeClip API Documentation
TemplateDB..::.AddOfficeClipConstants Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds the officeclip constants

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public Hashtable AddOfficeClipConstants(
    Hashtable ht
)
Visual Basic (Declaration)
Public Function AddOfficeClipConstants ( _
    ht As Hashtable _
) As Hashtable
Visual C++
public:
Hashtable^ AddOfficeClipConstants(
    Hashtable^ ht
)

Parameters

ht
Type: System.Collections..::.Hashtable

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
TemplateDB..::.AddOutputParameter Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

TemplateDB Class
TemplateDB Members
OfficeClip.DBLayer.Template Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
TemplateDB..::.AddParameter Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

TemplateDB Class
TemplateDB Members
OfficeClip.DBLayer.Template Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
TemplateDB..::.AddParameters Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

TemplateDB Class
TemplateDB Members
OfficeClip.DBLayer.Template Namespace


AddRecipientUser Method

[image]

OfficeClip API Documentation
TemplateDB..::.AddRecipientUser Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Adds the recepients

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public Hashtable AddRecipientUser(
    Hashtable ht,
    string toName,
    string emailAddress
)
Visual Basic (Declaration)
Public Function AddRecipientUser ( _
    ht As Hashtable, _
    toName As String, _
    emailAddress As String _
) As Hashtable
Visual C++
public:
Hashtable^ AddRecipientUser(
    Hashtable^ ht,
    String^ toName,
    String^ emailAddress
)

Parameters

ht
Type: System.Collections..::.Hashtable
toName
Type: System..::.String
emailAddress
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


DeleteCampaign Method

[image]

OfficeClip API Documentation
TemplateDB..::.DeleteCampaign Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Delete the campaign and all associated information

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteCampaign(
    int templateId
)
Visual Basic (Declaration)
Public Sub DeleteCampaign ( _
    templateId As Integer _
)
Visual C++
public:
void DeleteCampaign(
    int templateId
)

Parameters

templateId
Type: System..::.Int32
The unique id of the template

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


DeleteCampaignDetail Method

[image]

OfficeClip API Documentation
TemplateDB..::.DeleteCampaignDetail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the campaign details

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteCampaignDetail(
    int templateId,
    int objectId
)
Visual Basic (Declaration)
Public Sub DeleteCampaignDetail ( _
    templateId As Integer, _
    objectId As Integer _
)
Visual C++
public:
void DeleteCampaignDetail(
    int templateId,
    int objectId
)

Parameters

templateId
Type: System..::.Int32
The unique id of the template
objectId
Type: System..::.Int32
The unique id of the object whose details needs to be removed

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


DeleteTemplate Method

[image]

OfficeClip API Documentation
TemplateDB..::.DeleteTemplate Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the template

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteTemplate(
    int templateId
)
Visual Basic (Declaration)
Public Sub DeleteTemplate ( _
    templateId As Integer _
)
Visual C++
public:
void DeleteTemplate(
    int templateId
)

Parameters

templateId
Type: System..::.Int32
The unique id of the template

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


DisconnectSMTP Method

[image]

OfficeClip API Documentation
TemplateDB..::.DisconnectSMTP Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool DisconnectSMTP()
Visual Basic (Declaration)
Public Function DisconnectSMTP As Boolean
Visual C++
public:
bool DisconnectSMTP()

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
TemplateDB..::.ExecuteNonQuery Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

TemplateDB Class
TemplateDB Members
OfficeClip.DBLayer.Template Namespace


GetAllCampaignsForContact Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetAllCampaignsForContact Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the campaign information for a particular contact

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetAllCampaignsForContact(
    int contactId
)
Visual Basic (Declaration)
Public Function GetAllCampaignsForContact ( _
    contactId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetAllCampaignsForContact(
    int contactId
)

Parameters

contactId
Type: System..::.Int32
The id of the contact

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetCampaignDetails Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetCampaignDetails Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the details of the campaign

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetCampaignDetails(
    int templateId
)
Visual Basic (Declaration)
Public Function GetCampaignDetails ( _
    templateId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetCampaignDetails(
    int templateId
)

Parameters

templateId
Type: System..::.Int32
The unique id of the template

Return Value

The arraylist of the campaign details

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetCampaignDetailsInfo Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetCampaignDetailsInfo Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetCampaignDetailsInfo(
    int campaignmetaId
)
Visual Basic (Declaration)
Public Function GetCampaignDetailsInfo ( _
    campaignmetaId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetCampaignDetailsInfo(
    int campaignmetaId
)

Parameters

campaignmetaId
Type: System..::.Int32

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetCampaignInfo Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetCampaignInfo Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the campaign information

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public CampaignInfo GetCampaignInfo(
    int templateId
)
Visual Basic (Declaration)
Public Function GetCampaignInfo ( _
    templateId As Integer _
) As CampaignInfo
Visual C++
public:
CampaignInfo^ GetCampaignInfo(
    int templateId
)

Parameters

templateId
Type: System..::.Int32
The unique id of the template

Return Value

Teh campaign information object

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetCampaigns Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetCampaigns Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Gats all the campaign information for the group

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetCampaigns(
    int groupId
)
Visual Basic (Declaration)
Public Function GetCampaigns ( _
    groupId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetCampaigns(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

Return Value

The arraylist of campaigns

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetCampaignSentEmailText Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetCampaignSentEmailText Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the email text that is sent for the campaign

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetCampaignSentEmailText(
    int campaignEmailId
)
Visual Basic (Declaration)
Public Function GetCampaignSentEmailText ( _
    campaignEmailId As Integer _
) As String
Visual C++
public:
String^ GetCampaignSentEmailText(
    int campaignEmailId
)

Parameters

campaignEmailId
Type: System..::.Int32
The campaign email id

Return Value

The email text for teh campaign

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetItems Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetItems Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object items of teh template

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ObjectItem[] GetItems(
    TemplateType tt,
    int groupId
)
Visual Basic (Declaration)
Public Function GetItems ( _
    tt As TemplateType, _
    groupId As Integer _
) As ObjectItem()
Visual C++
public:
array<ObjectItem^>^ GetItems(
    TemplateType tt,
    int groupId
)

Parameters

tt
Type: OfficeClip.BusinessLayer.Template..::.TemplateType
The template type
groupId
Type: System..::.Int32
The unique id of the group

Return Value

Teh array of teh object items

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetRemainingCampaignsForContact Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetRemainingCampaignsForContact Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all campaigns for the contact

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetRemainingCampaignsForContact(
    int contactId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetRemainingCampaignsForContact ( _
    contactId As Integer, _
    groupId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetRemainingCampaignsForContact(
    int contactId,
    int groupId
)

Parameters

contactId
Type: System..::.Int32
The id of the contact
groupId
Type: System..::.Int32
the unique id of the organization

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetSystemTemplateValues Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetSystemTemplateValues Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the hashtable related to the system template. This hashtable returns all the keys and values.

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public Hashtable GetSystemTemplateValues(
    int eventId,
    int userId,
    int groupId,
    int announceId,
    int forumId,
    int topicId,
    int replyId,
    int userDetailId,
    int pollId,
    TemplateMailInfo tmi
)
Visual Basic (Declaration)
Public Function GetSystemTemplateValues ( _
    eventId As Integer, _
    userId As Integer, _
    groupId As Integer, _
    announceId As Integer, _
    forumId As Integer, _
    topicId As Integer, _
    replyId As Integer, _
    userDetailId As Integer, _
    pollId As Integer, _
    tmi As TemplateMailInfo _
) As Hashtable
Visual C++
public:
Hashtable^ GetSystemTemplateValues(
    int eventId,
    int userId,
    int groupId,
    int announceId,
    int forumId,
    int topicId,
    int replyId,
    int userDetailId,
    int pollId,
    TemplateMailInfo^ tmi
)

Parameters

eventId
Type: System..::.Int32
The unique id of the event, -1 if it is not available
userId
Type: System..::.Int32
The unique id of the user, -1 if not available
groupId
Type: System..::.Int32
The unique id of the group, -1 if not available
announceId
Type: System..::.Int32
The unique id of the announcement
forumId
Type: System..::.Int32
The unique id of the forum
topicId
Type: System..::.Int32
the unique id of the topic
replyId
Type: System..::.Int32
The unique id of the reply value
userDetailId
Type: System..::.Int32
The unique id of the user detail
pollId
Type: System..::.Int32
The unique id of the polls
tmi
Type: OfficeClip.BusinessLayer.Template..::.TemplateMailInfo

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetTemplate Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetTemplate Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Get instance of Template from the database

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateInfo GetTemplate(
    int templateId
)
Visual Basic (Declaration)
Public Function GetTemplate ( _
    templateId As Integer _
) As TemplateInfo
Visual C++
public:
TemplateInfo^ GetTemplate(
    int templateId
)

Parameters

templateId
Type: System..::.Int32
The unique id of the Template in the database

Return Value

The TemplateInfo information structure, null if the Template is not found

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetTemplateCampaignInfo Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetTemplateCampaignInfo Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTemplateCampaignInfo(
    int campaignmetaId
)
Visual Basic (Declaration)
Public Function GetTemplateCampaignInfo ( _
    campaignmetaId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetTemplateCampaignInfo(
    int campaignmetaId
)

Parameters

campaignmetaId
Type: System..::.Int32

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetTemplateItems Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetTemplateItems Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the items for the template

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public List<PcNode> GetTemplateItems(
    TemplateType tt,
    int groupId
)
Visual Basic (Declaration)
Public Function GetTemplateItems ( _
    tt As TemplateType, _
    groupId As Integer _
) As List(Of PcNode)
Visual C++
public:
List<PcNode^>^ GetTemplateItems(
    TemplateType tt,
    int groupId
)

Parameters

tt
Type: OfficeClip.BusinessLayer.Template..::.TemplateType
groupId
Type: System..::.Int32

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetTemplateList Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetTemplateList Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Get all instances of Template from the database

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateInfo[] GetTemplateList(
    Category category,
    TemplateType templateType,
    int userId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetTemplateList ( _
    category As Category, _
    templateType As TemplateType, _
    userId As Integer, _
    groupId As Integer _
) As TemplateInfo()
Visual C++
public:
array<TemplateInfo^>^ GetTemplateList(
    Category category,
    TemplateType templateType,
    int userId,
    int groupId
)

Parameters

category
Type: OfficeClip.BusinessLayer.Template..::.Category
The category of the template
templateType
Type: OfficeClip.BusinessLayer.Template..::.TemplateType
The type of the template
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the group

Return Value

The TemplateInfo information structure, null if the Template is not found

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetTrackEmailOpenedHtml Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetTrackEmailOpenedHtml Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tracker code for the html email

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string GetTrackEmailOpenedHtml(
    int id
)
Visual Basic (Declaration)
Protected Function GetTrackEmailOpenedHtml ( _
    id As Integer _
) As String
Visual C++
protected:
String^ GetTrackEmailOpenedHtml(
    int id
)

Parameters

id
Type: System..::.Int32

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetUniqueSystemTemplate Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetUniqueSystemTemplate Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the unique system template

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateInfo GetUniqueSystemTemplate(
    int userId,
    TemplateNameId stId
)
Visual Basic (Declaration)
Public Function GetUniqueSystemTemplate ( _
    userId As Integer, _
    stId As TemplateNameId _
) As TemplateInfo
Visual C++
public:
TemplateInfo^ GetUniqueSystemTemplate(
    int userId,
    TemplateNameId stId
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
stId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
The unique template name

Return Value

The template information object

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


GetUniqueTemplate Method

[image]

OfficeClip API Documentation
TemplateDB..::.GetUniqueTemplate Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the unique template from the database

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateInfo GetUniqueTemplate(
    int templateId
)
Visual Basic (Declaration)
Public Function GetUniqueTemplate ( _
    templateId As Integer _
) As TemplateInfo
Visual C++
public:
TemplateInfo^ GetUniqueTemplate(
    int templateId
)

Parameters

templateId
Type: System..::.Int32
The unique id of the tempalte

Return Value

Teh template information object

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
TemplateDB..::.InitTransaction Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

TemplateDB Class
TemplateDB Members
OfficeClip.DBLayer.Template Namespace


InsertCampaign Method

[image]

OfficeClip API Documentation
TemplateDB..::.InsertCampaign Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a campaign

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertCampaign(
    int groupId,
    TemplateType templateType,
    bool isHtml,
    string name,
    string description,
    string subject,
    string html,
    string text,
    int createdByUserId,
    int emailAccountId,
    bool isRecurring,
    bool isMailMerge,
    int letterheadId,
    int campaignmetaId,
    ref int templateId
)
Visual Basic (Declaration)
Public Function InsertCampaign ( _
    groupId As Integer, _
    templateType As TemplateType, _
    isHtml As Boolean, _
    name As String, _
    description As String, _
    subject As String, _
    html As String, _
    text As String, _
    createdByUserId As Integer, _
    emailAccountId As Integer, _
    isRecurring As Boolean, _
    isMailMerge As Boolean, _
    letterheadId As Integer, _
    campaignmetaId As Integer, _
    ByRef templateId As Integer _
) As Integer
Visual C++
public:
int InsertCampaign(
    int groupId,
    TemplateType templateType,
    bool isHtml,
    String^ name,
    String^ description,
    String^ subject,
    String^ html,
    String^ text,
    int createdByUserId,
    int emailAccountId,
    bool isRecurring,
    bool isMailMerge,
    int letterheadId,
    int campaignmetaId,
    int% templateId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
templateType
Type: OfficeClip.BusinessLayer.Template..::.TemplateType
The template type
isHtml
Type: System..::.Boolean
True if the template is an html template
name
Type: System..::.String
The name of the campaign
description
Type: System..::.String
The description of the campaign
subject
Type: System..::.String
The subject of the campaign
html
Type: System..::.String
The html of the campaign
text
Type: System..::.String
The text of the campaign
createdByUserId
Type: System..::.Int32
The unique id of the creator
emailAccountId
Type: System..::.Int32
The unique id of the email account
isRecurring
Type: System..::.Boolean
True if the template is a recurring template
isMailMerge
Type: System..::.Boolean
Shows if the template is the mail merge template
letterheadId
Type: System..::.Int32
The unique id of the letterhead associated with the template
campaignmetaId
Type: System..::.Int32
templateId
Type: System..::.Int32%
The template id

Return Value

The campaign id if successful

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


InsertCampaignDetail Method

[image]

OfficeClip API Documentation
TemplateDB..::.InsertCampaignDetail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Insert the campaign details

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertCampaignDetail(
    int templateId,
    int objectId
)
Visual Basic (Declaration)
Public Sub InsertCampaignDetail ( _
    templateId As Integer, _
    objectId As Integer _
)
Visual C++
public:
void InsertCampaignDetail(
    int templateId,
    int objectId
)

Parameters

templateId
Type: System..::.Int32
The unique id of the template
objectId
Type: System..::.Int32
The unnique id of the object

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


InsertTemplate Method

[image]

OfficeClip API Documentation
TemplateDB..::.InsertTemplate Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a template

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertTemplate(
    int accountId,
    int groupId,
    int userId,
    TemplateType templateType,
    Category category,
    bool isHtml,
    string name,
    string description,
    string subject,
    string html,
    string text,
    int createdByUserId
)
Visual Basic (Declaration)
Public Function InsertTemplate ( _
    accountId As Integer, _
    groupId As Integer, _
    userId As Integer, _
    templateType As TemplateType, _
    category As Category, _
    isHtml As Boolean, _
    name As String, _
    description As String, _
    subject As String, _
    html As String, _
    text As String, _
    createdByUserId As Integer _
) As Integer
Visual C++
public:
int InsertTemplate(
    int accountId,
    int groupId,
    int userId,
    TemplateType templateType,
    Category category,
    bool isHtml,
    String^ name,
    String^ description,
    String^ subject,
    String^ html,
    String^ text,
    int createdByUserId
)

Parameters

accountId
Type: System..::.Int32
The unique id of the account
groupId
Type: System..::.Int32
The unique id of the group
userId
Type: System..::.Int32
The unique id of teh user
templateType
Type: OfficeClip.BusinessLayer.Template..::.TemplateType
The template type
category
Type: OfficeClip.BusinessLayer.Template..::.Category
The template category
isHtml
Type: System..::.Boolean
True if the template is an html template
name
Type: System..::.String
The name of the template
description
Type: System..::.String
The description of the template
subject
Type: System..::.String
The subject of the template
html
Type: System..::.String
The html of the template
text
Type: System..::.String
The text of the template
createdByUserId
Type: System..::.Int32
The unique id of teh template creator

Return Value

A positive template id if successful

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendAnnounceSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendAnnounceSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends the announcement email

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendAnnounceSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int announceId,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendAnnounceSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    announceId As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendAnnounceSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int announceId,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
announceId
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendBulletingBoardForumSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendBulletingBoardForumSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendBulletingBoardForumSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int forumId,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendBulletingBoardForumSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    forumId As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendBulletingBoardForumSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int forumId,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
forumId
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendBulletingBoardReplySystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendBulletingBoardReplySystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendBulletingBoardReplySystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int forumId,
    int topicId,
    int replyId,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendBulletingBoardReplySystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    forumId As Integer, _
    topicId As Integer, _
    replyId As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendBulletingBoardReplySystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int forumId,
    int topicId,
    int replyId,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
forumId
Type: System..::.Int32
topicId
Type: System..::.Int32
replyId
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendBulletingBoardTopicSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendBulletingBoardTopicSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendBulletingBoardTopicSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int forumId,
    int topicId,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendBulletingBoardTopicSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    forumId As Integer, _
    topicId As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendBulletingBoardTopicSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int forumId,
    int topicId,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
forumId
Type: System..::.Int32
topicId
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendCampaignEmails Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendCampaignEmails Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends all the campaign emails

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable SendCampaignEmails(
    MetaConstants..::.MetaEntity me,
    int templateId,
    string fromName,
    string fromEmail,
    ConfigureInfo session,
    int EmailAccountId
)
Visual Basic (Declaration)
Public Function SendCampaignEmails ( _
    me As MetaConstants..::.MetaEntity, _
    templateId As Integer, _
    fromName As String, _
    fromEmail As String, _
    session As ConfigureInfo, _
    EmailAccountId As Integer _
) As DataTable
Visual C++
public:
DataTable^ SendCampaignEmails(
    MetaConstants..::.MetaEntity me,
    int templateId,
    String^ fromName,
    String^ fromEmail,
    ConfigureInfo^ session,
    int EmailAccountId
)

Parameters

me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
The meta entity for the campaign
templateId
Type: System..::.Int32
The unique id of the template
fromName
Type: System..::.String
The from name
fromEmail
Type: System..::.String
The from email address
session
Type: OfficeClip.Utils..::.ConfigureInfo
The user session
EmailAccountId
Type: System..::.Int32

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendCustomerPortalPasswordViaSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendCustomerPortalPasswordViaSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends the Extranet password via email

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendCustomerPortalPasswordViaSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail,
    string password,
    string customerPortalUrl
)
Visual Basic (Declaration)
Public Function SendCustomerPortalPasswordViaSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String, _
    password As String, _
    customerPortalUrl As String _
) As Integer
Visual C++
public:
int SendCustomerPortalPasswordViaSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail,
    String^ password,
    String^ customerPortalUrl
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String
password
Type: System..::.String
customerPortalUrl
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends the email via OfficeClip templates

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected string SendEmail(
    bool isHtml,
    string html,
    string text,
    string toEmail,
    string fromEmail,
    string subject,
    string priority,
    ArrayList attachments
)
Visual Basic (Declaration)
Protected Function SendEmail ( _
    isHtml As Boolean, _
    html As String, _
    text As String, _
    toEmail As String, _
    fromEmail As String, _
    subject As String, _
    priority As String, _
    attachments As ArrayList _
) As String
Visual C++
protected:
String^ SendEmail(
    bool isHtml,
    String^ html,
    String^ text,
    String^ toEmail,
    String^ fromEmail,
    String^ subject,
    String^ priority,
    ArrayList^ attachments
)

Parameters

isHtml
Type: System..::.Boolean
html
Type: System..::.String
text
Type: System..::.String
toEmail
Type: System..::.String
fromEmail
Type: System..::.String
subject
Type: System..::.String
priority
Type: System..::.String
attachments
Type: System.Collections..::.ArrayList

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendEventSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendEventSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendEventSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int eventId,
    string eventAttendees,
    string eventResources,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail,
    ArrayList attachments,
    TemplateMailInfo tmi
)
Visual Basic (Declaration)
Public Function SendEventSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    eventId As Integer, _
    eventAttendees As String, _
    eventResources As String, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String, _
    attachments As ArrayList, _
    tmi As TemplateMailInfo _
) As Integer
Visual C++
public:
int SendEventSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int eventId,
    String^ eventAttendees,
    String^ eventResources,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail,
    ArrayList^ attachments,
    TemplateMailInfo^ tmi
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
eventId
Type: System..::.Int32
eventAttendees
Type: System..::.String
eventResources
Type: System..::.String
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String
attachments
Type: System.Collections..::.ArrayList
tmi
Type: OfficeClip.BusinessLayer.Template..::.TemplateMailInfo

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendExtranetAdminUserEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendExtranetAdminUserEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends the extranet admin user email

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendExtranetAdminUserEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string password,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail,
    string extranetUrl
)
Visual Basic (Declaration)
Public Function SendExtranetAdminUserEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    password As String, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String, _
    extranetUrl As String _
) As Integer
Visual C++
public:
int SendExtranetAdminUserEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ password,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail,
    String^ extranetUrl
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
password
Type: System..::.String
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String
extranetUrl
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendExtranetCalendarRequestEventEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendExtranetCalendarRequestEventEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the extranet calendar request event email

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendExtranetCalendarRequestEventEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string eventName,
    string eventDescription,
    string eventStartDateTime,
    string eventDuration,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendExtranetCalendarRequestEventEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    eventName As String, _
    eventDescription As String, _
    eventStartDateTime As String, _
    eventDuration As String, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendExtranetCalendarRequestEventEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ eventName,
    String^ eventDescription,
    String^ eventStartDateTime,
    String^ eventDuration,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
eventName
Type: System..::.String
eventDescription
Type: System..::.String
eventStartDateTime
Type: System..::.String
eventDuration
Type: System..::.String
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendExtranetIssueTrackerEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendExtranetIssueTrackerEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends the extranet issue tracker email

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendExtranetIssueTrackerEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string caseNum,
    string subject,
    string caseDetail,
    string projectName,
    string extranetUrl,
    string extranetUserName,
    string extranetUserEmail,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendExtranetIssueTrackerEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    caseNum As String, _
    subject As String, _
    caseDetail As String, _
    projectName As String, _
    extranetUrl As String, _
    extranetUserName As String, _
    extranetUserEmail As String, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendExtranetIssueTrackerEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ caseNum,
    String^ subject,
    String^ caseDetail,
    String^ projectName,
    String^ extranetUrl,
    String^ extranetUserName,
    String^ extranetUserEmail,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
caseNum
Type: System..::.String
subject
Type: System..::.String
caseDetail
Type: System..::.String
projectName
Type: System..::.String
extranetUrl
Type: System..::.String
extranetUserName
Type: System..::.String
extranetUserEmail
Type: System..::.String
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendExtranetPublicUserEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendExtranetPublicUserEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends the extranet public user email

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendExtranetPublicUserEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail,
    string extranetUrl
)
Visual Basic (Declaration)
Public Function SendExtranetPublicUserEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String, _
    extranetUrl As String _
) As Integer
Visual C++
public:
int SendExtranetPublicUserEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail,
    String^ extranetUrl
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String
extranetUrl
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendForgotPasswordEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendForgotPasswordEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends the forgot password email

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendForgotPasswordEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string password,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendForgotPasswordEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    password As String, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendForgotPasswordEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ password,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
The template name id
userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the group
password
Type: System..::.String
The password
toName
Type: System..::.String
The name of the recepient
toEmail
Type: System..::.String
The email address of the recepient
fromName
Type: System..::.String
The name of the sender
fromEmail
Type: System..::.String
The email address of the sender

Return Value

0 if successful

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendGenericSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendGenericSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendGenericSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string objectType,
    string objectTitle,
    string objectDescription,
    string objectAdditionalInfo,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendGenericSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    objectType As String, _
    objectTitle As String, _
    objectDescription As String, _
    objectAdditionalInfo As String, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendGenericSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ objectType,
    String^ objectTitle,
    String^ objectDescription,
    String^ objectAdditionalInfo,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
objectType
Type: System..::.String
objectTitle
Type: System..::.String
objectDescription
Type: System..::.String
objectAdditionalInfo
Type: System..::.String
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendGroupSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendGroupSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendGroupSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendGroupSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendGroupSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendInviteMemberInGroup Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendInviteMemberInGroup Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendInviteMemberInGroup(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail,
    string password
)
Visual Basic (Declaration)
Public Function SendInviteMemberInGroup ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String, _
    password As String _
) As Integer
Visual C++
public:
int SendInviteMemberInGroup(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail,
    String^ password
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String
password
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendIssueTrackerSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendIssueTrackerSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendIssueTrackerSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string subject,
    string caseNum,
    string caseDetail,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail,
    ArrayList attachments
)
Visual Basic (Declaration)
Public Function SendIssueTrackerSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    subject As String, _
    caseNum As String, _
    caseDetail As String, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String, _
    attachments As ArrayList _
) As Integer
Visual C++
public:
int SendIssueTrackerSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ subject,
    String^ caseNum,
    String^ caseDetail,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail,
    ArrayList^ attachments
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
subject
Type: System..::.String
caseNum
Type: System..::.String
caseDetail
Type: System..::.String
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String
attachments
Type: System.Collections..::.ArrayList

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendLDAPInviteMemberInGroup Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendLDAPInviteMemberInGroup Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendLDAPInviteMemberInGroup(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string ldapLogin,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail,
    string password
)
Visual Basic (Declaration)
Public Function SendLDAPInviteMemberInGroup ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    ldapLogin As String, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String, _
    password As String _
) As Integer
Visual C++
public:
int SendLDAPInviteMemberInGroup(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ ldapLogin,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail,
    String^ password
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
ldapLogin
Type: System..::.String
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String
password
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendLdapSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendLdapSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Not Used

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendLdapSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string ldapLogin,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendLdapSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    ldapLogin As String, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendLdapSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ ldapLogin,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
ldapLogin
Type: System..::.String
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendMetaTemplateEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendMetaTemplateEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

This function is mainly used for user templates

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string SendMetaTemplateEmail(
    int templateId,
    MetaConstants..::.MetaEntity me,
    int primaryKey,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail,
    string priority,
    Hashtable htCustom,
    int emailHistoryId,
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function SendMetaTemplateEmail ( _
    templateId As Integer, _
    me As MetaConstants..::.MetaEntity, _
    primaryKey As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String, _
    priority As String, _
    htCustom As Hashtable, _
    emailHistoryId As Integer, _
    session As ConfigureInfo _
) As String
Visual C++
public:
String^ SendMetaTemplateEmail(
    int templateId,
    MetaConstants..::.MetaEntity me,
    int primaryKey,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail,
    String^ priority,
    Hashtable^ htCustom,
    int emailHistoryId,
    ConfigureInfo^ session
)

Parameters

templateId
Type: System..::.Int32
me
Type: OfficeClip.BusinessLayer.Metabase..::.MetaConstants..::.MetaEntity
primaryKey
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String
priority
Type: System..::.String
htCustom
Type: System.Collections..::.Hashtable
emailHistoryId
Type: System..::.Int32
session
Type: OfficeClip.Utils..::.ConfigureInfo

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendPasswordSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendPasswordSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendPasswordSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail,
    string password
)
Visual Basic (Declaration)
Public Function SendPasswordSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String, _
    password As String _
) As Integer
Visual C++
public:
int SendPasswordSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail,
    String^ password
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String
password
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendPollSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendPollSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Not Used

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendPollSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int pollId,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendPollSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    pollId As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendPollSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int pollId,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
pollId
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendSystemTemplateSMS Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendSystemTemplateSMS Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Sends the sms

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SendSystemTemplateSMS(
    TemplateNameId stnId,
    SmsInfo sms,
    string fromEmail,
    Hashtable mapping
)
Visual Basic (Declaration)
Protected Sub SendSystemTemplateSMS ( _
    stnId As TemplateNameId, _
    sms As SmsInfo, _
    fromEmail As String, _
    mapping As Hashtable _
)
Visual C++
protected:
void SendSystemTemplateSMS(
    TemplateNameId stnId,
    SmsInfo^ sms,
    String^ fromEmail,
    Hashtable^ mapping
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
sms
Type: OfficeClip.BusinessLayer.Account..::.SmsInfo
fromEmail
Type: System..::.String
mapping
Type: System.Collections..::.Hashtable

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendTimeAndExpensesSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendTimeAndExpensesSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendTimeAndExpensesSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    bool isTimesheet,
    string status,
    string periodStarting,
    string submittedBy,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendTimeAndExpensesSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    isTimesheet As Boolean, _
    status As String, _
    periodStarting As String, _
    submittedBy As String, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendTimeAndExpensesSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    bool isTimesheet,
    String^ status,
    String^ periodStarting,
    String^ submittedBy,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
isTimesheet
Type: System..::.Boolean
status
Type: System..::.String
periodStarting
Type: System..::.String
submittedBy
Type: System..::.String
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SendUserDetailSystemEmail Method

[image]

OfficeClip API Documentation
TemplateDB..::.SendUserDetailSystemEmail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Not Used

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SendUserDetailSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int userDetailId,
    string toName,
    string toEmail,
    string fromName,
    string fromEmail
)
Visual Basic (Declaration)
Public Function SendUserDetailSystemEmail ( _
    stnId As TemplateNameId, _
    userId As Integer, _
    groupId As Integer, _
    userDetailId As Integer, _
    toName As String, _
    toEmail As String, _
    fromName As String, _
    fromEmail As String _
) As Integer
Visual C++
public:
int SendUserDetailSystemEmail(
    TemplateNameId stnId,
    int userId,
    int groupId,
    int userDetailId,
    String^ toName,
    String^ toEmail,
    String^ fromName,
    String^ fromEmail
)

Parameters

stnId
Type: OfficeClip.BusinessLayer.Template..::.TemplateNameId
userId
Type: System..::.Int32
groupId
Type: System..::.Int32
userDetailId
Type: System..::.Int32
toName
Type: System..::.String
toEmail
Type: System..::.String
fromName
Type: System..::.String
fromEmail
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SetCampaignEmailSentStatus Method

[image]

OfficeClip API Documentation
TemplateDB..::.SetCampaignEmailSentStatus Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Sets the sent status of the campaign

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected int SetCampaignEmailSentStatus(
    int templateId,
    int objectId,
    string userName
)
Visual Basic (Declaration)
Protected Function SetCampaignEmailSentStatus ( _
    templateId As Integer, _
    objectId As Integer, _
    userName As String _
) As Integer
Visual C++
protected:
int SetCampaignEmailSentStatus(
    int templateId,
    int objectId,
    String^ userName
)

Parameters

templateId
Type: System..::.Int32
objectId
Type: System..::.Int32
userName
Type: System..::.String

Return Value

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
TemplateDB..::.SetSPCommand Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

TemplateDB Class
TemplateDB Members
OfficeClip.DBLayer.Template Namespace


UpdateAccountTemplate Method

[image]

OfficeClip API Documentation
TemplateDB..::.UpdateAccountTemplate Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the account template

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateAccountTemplate(
    int templateId,
    string name,
    bool isHtml,
    bool isActive,
    string description,
    string subject,
    string html,
    string text,
    int loginUserId
)
Visual Basic (Declaration)
Public Sub UpdateAccountTemplate ( _
    templateId As Integer, _
    name As String, _
    isHtml As Boolean, _
    isActive As Boolean, _
    description As String, _
    subject As String, _
    html As String, _
    text As String, _
    loginUserId As Integer _
)
Visual C++
public:
void UpdateAccountTemplate(
    int templateId,
    String^ name,
    bool isHtml,
    bool isActive,
    String^ description,
    String^ subject,
    String^ html,
    String^ text,
    int loginUserId
)

Parameters

templateId
Type: System..::.Int32
The unique id of the template
name
Type: System..::.String
The name of the template
isHtml
Type: System..::.Boolean
True if the template is an html template
isActive
Type: System..::.Boolean
True if the template is active
description
Type: System..::.String
The description of the template
subject
Type: System..::.String
The subject of the template
html
Type: System..::.String
The html of the template
text
Type: System..::.String
The text of the template
loginUserId
Type: System..::.Int32
The unique id of the login user

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


UpdateCampaign Method

[image]

OfficeClip API Documentation
TemplateDB..::.UpdateCampaign Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the campaign

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateCampaign(
    int templateId,
    bool isHtml,
    bool isActive,
    string name,
    string description,
    string subject,
    string html,
    string text,
    int loginUserId,
    int emailAccountId,
    bool isRecurring,
    bool isMailMerge,
    int letterheadId
)
Visual Basic (Declaration)
Public Sub UpdateCampaign ( _
    templateId As Integer, _
    isHtml As Boolean, _
    isActive As Boolean, _
    name As String, _
    description As String, _
    subject As String, _
    html As String, _
    text As String, _
    loginUserId As Integer, _
    emailAccountId As Integer, _
    isRecurring As Boolean, _
    isMailMerge As Boolean, _
    letterheadId As Integer _
)
Visual C++
public:
void UpdateCampaign(
    int templateId,
    bool isHtml,
    bool isActive,
    String^ name,
    String^ description,
    String^ subject,
    String^ html,
    String^ text,
    int loginUserId,
    int emailAccountId,
    bool isRecurring,
    bool isMailMerge,
    int letterheadId
)

Parameters

templateId
Type: System..::.Int32
The unique id of the tempalte
isHtml
Type: System..::.Boolean
True if the template is an html template
isActive
Type: System..::.Boolean
True if the template is active
name
Type: System..::.String
The name of the template
description
Type: System..::.String
The description of the template
subject
Type: System..::.String
The subject of the template
html
Type: System..::.String
The html of the template
text
Type: System..::.String
The text of the template
loginUserId
Type: System..::.Int32
The login user unique id
emailAccountId
Type: System..::.Int32
Teh email account unique id
isRecurring
Type: System..::.Boolean
True if the template is recurring
isMailMerge
Type: System..::.Boolean
Shows if the template is a mail merge template
letterheadId
Type: System..::.Int32
The unique id of the letterhead associated with the letterhead

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


UpdateCampaignDetail Method

[image]

OfficeClip API Documentation
TemplateDB..::.UpdateCampaignDetail Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the campaign detail

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateCampaignDetail(
    int templateId,
    ArrayList arrObjects
)
Visual Basic (Declaration)
Public Sub UpdateCampaignDetail ( _
    templateId As Integer, _
    arrObjects As ArrayList _
)
Visual C++
public:
void UpdateCampaignDetail(
    int templateId,
    ArrayList^ arrObjects
)

Parameters

templateId
Type: System..::.Int32
The unique id of the template
arrObjects
Type: System.Collections..::.ArrayList
The arraylist of the objects that needs to be updated

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


UpdateCampaignEmailOpened Method

[image]

OfficeClip API Documentation
TemplateDB..::.UpdateCampaignEmailOpened Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the campaign email opened status

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateCampaignEmailOpened(
    int id
)
Visual Basic (Declaration)
Public Sub UpdateCampaignEmailOpened ( _
    id As Integer _
)
Visual C++
public:
void UpdateCampaignEmailOpened(
    int id
)

Parameters

id
Type: System..::.Int32
The unique id of the campaign email

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


UpdateCampaignEmailParameters Method

[image]

OfficeClip API Documentation
TemplateDB..::.UpdateCampaignEmailParameters Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the campaign email parameters

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateCampaignEmailParameters(
    int templateId,
    int emailAccountId,
    string senderName,
    string senderEmail
)
Visual Basic (Declaration)
Public Sub UpdateCampaignEmailParameters ( _
    templateId As Integer, _
    emailAccountId As Integer, _
    senderName As String, _
    senderEmail As String _
)
Visual C++
public:
void UpdateCampaignEmailParameters(
    int templateId,
    int emailAccountId,
    String^ senderName,
    String^ senderEmail
)

Parameters

templateId
Type: System..::.Int32
The unique id of the template
emailAccountId
Type: System..::.Int32
The email account id
senderName
Type: System..::.String
the name of the sender
senderEmail
Type: System..::.String
the email address of the sender

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


UpdateCampaignEmailSentText Method

[image]

OfficeClip API Documentation
TemplateDB..::.UpdateCampaignEmailSentText Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the campaign email text

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateCampaignEmailSentText(
    int id,
    string emailText
)
Visual Basic (Declaration)
Public Sub UpdateCampaignEmailSentText ( _
    id As Integer, _
    emailText As String _
)
Visual C++
public:
void UpdateCampaignEmailSentText(
    int id,
    String^ emailText
)

Parameters

id
Type: System..::.Int32
The unique id of the campaign email
emailText
Type: System..::.String
The email text

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


UpdTemplateCampaignInfo Method

[image]

OfficeClip API Documentation
TemplateDB..::.UpdTemplateCampaignInfo Method
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdTemplateCampaignInfo(
    int campaignmetaId,
    bool emailOptOut
)
Visual Basic (Declaration)
Public Sub UpdTemplateCampaignInfo ( _
    campaignmetaId As Integer, _
    emailOptOut As Boolean _
)
Visual C++
public:
void UpdTemplateCampaignInfo(
    int campaignmetaId,
    bool emailOptOut
)

Parameters

campaignmetaId
Type: System..::.Int32
emailOptOut
Type: System..::.Boolean

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


TemplateDB Properties

[image] [image]

OfficeClip API Documentation
TemplateDB Properties
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateDB type exposes the following properties.

Properties

 | Name | Description
Public property | AdminEmailAddress |
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)
Public property | HostStr |
Public property | HostURL |
Public property | UniqueID |

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


AdminEmailAddress Property

[image]

OfficeClip API Documentation
TemplateDB..::.AdminEmailAddress Property
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string AdminEmailAddress { get; set; }
Visual Basic (Declaration)
Public Property AdminEmailAddress As String
Visual C++
public:
property String^ AdminEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


HostStr Property

[image]

OfficeClip API Documentation
TemplateDB..::.HostStr Property
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string HostStr { get; set; }
Visual Basic (Declaration)
Public Property HostStr As String
Visual C++
public:
property String^ HostStr {
    String^ get ();
    void set (String^ value);
}

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


HostURL Property

[image]

OfficeClip API Documentation
TemplateDB..::.HostURL Property
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string HostURL { get; set; }
Visual Basic (Declaration)
Public Property HostURL As String
Visual C++
public:
property String^ HostURL {
    String^ get ();
    void set (String^ value);
}

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


UniqueID Property

[image]

OfficeClip API Documentation
TemplateDB..::.UniqueID Property
TemplateDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string UniqueID { get; set; }
Visual Basic (Declaration)
Public Property UniqueID As String
Visual C++
public:
property String^ UniqueID {
    String^ get ();
    void set (String^ value);
}

See Also

TemplateDB Class
OfficeClip.DBLayer.Template Namespace


TemplateMailThreadDB Class

[image]

OfficeClip API Documentation
TemplateMailThreadDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TemplateMailThreadDB
Visual Basic (Declaration)
Public Class TemplateMailThreadDB
Visual C++
public ref class TemplateMailThreadDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer.Template..::.TemplateMailThreadDB

See Also

TemplateMailThreadDB Members
OfficeClip.DBLayer.Template Namespace


TemplateMailThreadDB Members

[image] [image]

OfficeClip API Documentation
TemplateMailThreadDB Members
TemplateMailThreadDB Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The TemplateMailThreadDB type exposes the following members.

Constructors

 | Name | Description
Public method | TemplateMailThreadDB |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SendMail |
Public method | SendTemplateMailThread |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateMailThreadDB Class
OfficeClip.DBLayer.Template Namespace


TemplateMailThreadDB Constructor

[image]

OfficeClip API Documentation
TemplateMailThreadDB Constructor
TemplateMailThreadDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TemplateMailThreadDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TemplateMailThreadDB()

See Also

TemplateMailThreadDB Class
OfficeClip.DBLayer.Template Namespace


TemplateMailThreadDB Methods

[image] [image]

OfficeClip API Documentation
TemplateMailThreadDB Methods
TemplateMailThreadDB Class See Also

[This is preliminary documentation and is subject to change.]

The TemplateMailThreadDB type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | SendMail |
Public method | SendTemplateMailThread |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemplateMailThreadDB Class
OfficeClip.DBLayer.Template Namespace


SendMail Method

[image]

OfficeClip API Documentation
TemplateMailThreadDB..::.SendMail Method
TemplateMailThreadDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void SendMail(
    Object s
)
Visual Basic (Declaration)
Protected Sub SendMail ( _
    s As Object _
)
Visual C++
protected:
void SendMail(
    Object^ s
)

Parameters

s
Type: System..::.Object

See Also

TemplateMailThreadDB Class
OfficeClip.DBLayer.Template Namespace


SendTemplateMailThread Method

[image]

OfficeClip API Documentation
TemplateMailThreadDB..::.SendTemplateMailThread Method
TemplateMailThreadDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Template
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SendTemplateMailThread(
    Object tInfo
)
Visual Basic (Declaration)
Public Sub SendTemplateMailThread ( _
    tInfo As Object _
)
Visual C++
public:
void SendTemplateMailThread(
    Object^ tInfo
)

Parameters

tInfo
Type: System..::.Object

See Also

TemplateMailThreadDB Class
OfficeClip.DBLayer.Template Namespace


OfficeClip.DBLayer.Tracker Namespace

[image]

OfficeClip API Documentation
OfficeClip.DBLayer.Tracker Namespace

[This is preliminary documentation and is subject to change.]

Data Layer for the OfficeClip issue tracker

Classes

 | Class | Description
Public class | TrackerDB | This class provides a database layer interface to the tracker application.
Public class | TrackerEmailDB | This class provides DBLayer methods for the tracker synchronization.
Public class | TrackerSyncDB | This class provides DBLayer methods for the tracker synchronization.

Enumerations

 | Enumeration | Description
Public enumeration | TrackerDB..::.UpdateProjectNameStatus | status for the return value of the UpdateProjectName function UpdateProjectName(Int32, String)
Public enumeration | TrackerDB..::.UpdateUdfNameStatus | The status of updating the udf name.


TrackerDB Class

[image]

OfficeClip API Documentation
TrackerDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class provides a database layer interface to the tracker application.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerDB : OfficeClipDB
Visual Basic (Declaration)
Public Class TrackerDB _
    Inherits OfficeClipDB
Visual C++
public ref class TrackerDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Tracker..::.TrackerDB

See Also

TrackerDB Members
OfficeClip.DBLayer.Tracker Namespace


TrackerDB Members

[image] [image]

OfficeClip API Documentation
TrackerDB Members
TrackerDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerDB type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ArchiveProject | archives the Project in the database, or restores it.
Public method | BulkArchive | Bulk archives the cases so that they are not shown to the user. This is called from UpdateOptions.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteAllCases | Deletes the all cases from the project
Public method | DeleteArchivedCases | Deletes the archived cases from the project
Public method | DeleteCase | Deletes a particular case
Public method | DeleteProject | Removes the Project in the database.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAdminProjectList | Gets the Project list which are accessible to the administrator. This method assumes that the currently logged in user is an administrator.
Public method | GetAttachmentPaths | Gets the attachment paths
Public method | GetCaseDetails | Provides an ArrayList of PropertyInfo for a tracker case.
Public method | GetCaseDetailString | Gets the tracker case detail in a String
Public method | GetCaseIdFromCaseNum | Gets the internal case id from the Project id and the case number.
Public method | GetCaseListExt | Gets the extension parameters of the case. The extension parameters are Description, Resolution and Comments.
Public method | GetCaseListInfo | Get the caselist information to display in the caselist screen of the tracker for a particular user.
Public method | GetCaseListInfoAll | Gets all the case information, this combines the normal case list information and also the Description, Resolution and Comments
Public method | GetCaseListInfoKB | Get the case list information for the knowledge base
Public method | GetChildren | Gets the children of an object
Public method | GetFieldListValues | Returns a datatable consisting of all the field list values.
Public method | GetFieldNames | Returns a datatable consisting of all the field names.
Public method | GetFieldValues | Gets the tracker case information consisting of all the field values.
Public method | GetFilterDetail | Gets the filter detail for a given filter
Public method | GetFilters | Gets all the filters
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetHistory | Gets the tracker history for display on the screen.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetProjectCount | Gets the count of the projects
Public method | GetProjectInfo | Gets the Project information.
Public method | GetProjects | Gets a list of all the Projects from the database
Public method | GetRowStyle | Returns the style of the row, the row style can be in terms of background color or font
Public method | GetStatisticalData | Gets the statistical data related to the list type fields.
Public method | GetTrackerExternalStatus | Gets the tracker status matrix for extranet users
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertCase | Inserts a new case in the tracker.
Public method | InsertFieldListValue | Modifies the field values of a list type.
Public method | IsTrackerCasePresent | Checks if the tracker case is present
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFieldListValueDown | Move the list item of a tracker field to one Position down.
Public method | MoveFieldListValueUp | Move the list item of a tracker field to one Position up.
Public method | RemoveFieldListValue | Removes the field list values
Public method | RemoveFilter | Delete a filter from the database
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SaveFilter | Saves a newly created filter in the database
Public method | SetColorCode |
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetStyleCode |
Public method | ShowListUnspecifiedWhenNull | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCase | Updates an existing case in the tracker.
Public method | UpdateFieldListDefault | Updates the default value of the list type field.
Public method | UpdateFieldListSortOrder | Updates the sort order of a field type of type list.
Public method | UpdateFieldListValue | Updates the list value of a particular list type field in tracker.
Public method | UpdateFixedFields | Updates the fixed field names.
Public method | UpdateFixedFieldsAdminEdit | Updates the edit capabilities of the fixed fields
Public method | UpdateFixedFieldsMandatory | Updates the mandatory capabilities of the fixed fields
Public method | UpdateOptions | Updates the database based on the values entered in the option screen.
Public method | UpdateProjectName | Changes the name of the Project.
Public method | UpdateUdfName | Changes the name of the udf field.

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


TrackerDB Constructor

[image]

OfficeClip API Documentation
TrackerDB Constructor
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerDB()

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


TrackerDB Methods

[image] [image]

OfficeClip API Documentation
TrackerDB Methods
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ArchiveProject | archives the Project in the database, or restores it.
Public method | BulkArchive | Bulk archives the cases so that they are not shown to the user. This is called from UpdateOptions.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | DeleteAllCases | Deletes the all cases from the project
Public method | DeleteArchivedCases | Deletes the archived cases from the project
Public method | DeleteCase | Deletes a particular case
Public method | DeleteProject | Removes the Project in the database.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAdminProjectList | Gets the Project list which are accessible to the administrator. This method assumes that the currently logged in user is an administrator.
Public method | GetAttachmentPaths | Gets the attachment paths
Public method | GetCaseDetails | Provides an ArrayList of PropertyInfo for a tracker case.
Public method | GetCaseDetailString | Gets the tracker case detail in a String
Public method | GetCaseIdFromCaseNum | Gets the internal case id from the Project id and the case number.
Public method | GetCaseListExt | Gets the extension parameters of the case. The extension parameters are Description, Resolution and Comments.
Public method | GetCaseListInfo | Get the caselist information to display in the caselist screen of the tracker for a particular user.
Public method | GetCaseListInfoAll | Gets all the case information, this combines the normal case list information and also the Description, Resolution and Comments
Public method | GetCaseListInfoKB | Get the case list information for the knowledge base
Public method | GetChildren | Gets the children of an object
Public method | GetFieldListValues | Returns a datatable consisting of all the field list values.
Public method | GetFieldNames | Returns a datatable consisting of all the field names.
Public method | GetFieldValues | Gets the tracker case information consisting of all the field values.
Public method | GetFilterDetail | Gets the filter detail for a given filter
Public method | GetFilters | Gets all the filters
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetHistory | Gets the tracker history for display on the screen.
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetProjectCount | Gets the count of the projects
Public method | GetProjectInfo | Gets the Project information.
Public method | GetProjects | Gets a list of all the Projects from the database
Public method | GetRowStyle | Returns the style of the row, the row style can be in terms of background color or font
Public method | GetStatisticalData | Gets the statistical data related to the list type fields.
Public method | GetTrackerExternalStatus | Gets the tracker status matrix for extranet users
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertCase | Inserts a new case in the tracker.
Public method | InsertFieldListValue | Modifies the field values of a list type.
Public method | IsTrackerCasePresent | Checks if the tracker case is present
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFieldListValueDown | Move the list item of a tracker field to one Position down.
Public method | MoveFieldListValueUp | Move the list item of a tracker field to one Position up.
Public method | RemoveFieldListValue | Removes the field list values
Public method | RemoveFilter | Delete a filter from the database
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SaveFilter | Saves a newly created filter in the database
Public method | SetColorCode |
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SetStyleCode |
Public method | ShowListUnspecifiedWhenNull | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCase | Updates an existing case in the tracker.
Public method | UpdateFieldListDefault | Updates the default value of the list type field.
Public method | UpdateFieldListSortOrder | Updates the sort order of a field type of type list.
Public method | UpdateFieldListValue | Updates the list value of a particular list type field in tracker.
Public method | UpdateFixedFields | Updates the fixed field names.
Public method | UpdateFixedFieldsAdminEdit | Updates the edit capabilities of the fixed fields
Public method | UpdateFixedFieldsMandatory | Updates the mandatory capabilities of the fixed fields
Public method | UpdateOptions | Updates the database based on the values entered in the option screen.
Public method | UpdateProjectName | Changes the name of the Project.
Public method | UpdateUdfName | Changes the name of the udf field.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
TrackerDB..::.AddOutputParameter Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

TrackerDB Class
TrackerDB Members
OfficeClip.DBLayer.Tracker Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
TrackerDB..::.AddParameter Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

TrackerDB Class
TrackerDB Members
OfficeClip.DBLayer.Tracker Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
TrackerDB..::.AddParameters Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

TrackerDB Class
TrackerDB Members
OfficeClip.DBLayer.Tracker Namespace


ArchiveProject Method

[image]

OfficeClip API Documentation
TrackerDB..::.ArchiveProject Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

archives the Project in the database, or restores it.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void ArchiveProject(
    int projectId,
    bool isActive
)
Visual Basic (Declaration)
Public Sub ArchiveProject ( _
    projectId As Integer, _
    isActive As Boolean _
)
Visual C++
public:
void ArchiveProject(
    int projectId,
    bool isActive
)

Parameters

projectId
Type: System..::.Int32
The database id of the Project.
isActive
Type: System..::.Boolean
true if the Project is Active, so Archive it, false if the Project is archived, so restore it.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


BulkArchive Method

[image]

OfficeClip API Documentation
TrackerDB..::.BulkArchive Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Bulk archives the cases so that they are not shown to the user. This is called from UpdateOptions.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void BulkArchive(
    int projectId,
    int StatusId,
    int numDays
)
Visual Basic (Declaration)
Public Sub BulkArchive ( _
    projectId As Integer, _
    StatusId As Integer, _
    numDays As Integer _
)
Visual C++
public:
void BulkArchive(
    int projectId,
    int StatusId,
    int numDays
)

Parameters

projectId
Type: System..::.Int32
The database id of the Project.
StatusId
Type: System..::.Int32
The id of the status for which cases will be archived.
numDays
Type: System..::.Int32
The number of days required to Archive the Project.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


DeleteAllCases Method

[image]

OfficeClip API Documentation
TrackerDB..::.DeleteAllCases Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the all cases from the project

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteAllCases(
    int projectId,
    int numDays,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Sub DeleteAllCases ( _
    projectId As Integer, _
    numDays As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
)
Visual C++
public:
void DeleteAllCases(
    int projectId,
    int numDays,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

projectId
Type: System..::.Int32
The unique id of the project
numDays
Type: System..::.Int32
The number of days for which the cases last modified
currentUserId
Type: System..::.Int32
The unique id of the current user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


DeleteArchivedCases Method

[image]

OfficeClip API Documentation
TrackerDB..::.DeleteArchivedCases Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the archived cases from the project

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteArchivedCases(
    int projectId,
    int numDays,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Sub DeleteArchivedCases ( _
    projectId As Integer, _
    numDays As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
)
Visual C++
public:
void DeleteArchivedCases(
    int projectId,
    int numDays,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

projectId
Type: System..::.Int32
The unique id of the project
numDays
Type: System..::.Int32
The number of days for which the cases needs to be archived
currentUserId
Type: System..::.Int32
The unique id of the current user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


DeleteCase Method

[image]

OfficeClip API Documentation
TrackerDB..::.DeleteCase Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes a particular case

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void DeleteCase(
    int caseId,
    int currentUserId,
    bool isCurrentUserAdmin
)
Visual Basic (Declaration)
Public Sub DeleteCase ( _
    caseId As Integer, _
    currentUserId As Integer, _
    isCurrentUserAdmin As Boolean _
)
Visual C++
public:
void DeleteCase(
    int caseId,
    int currentUserId,
    bool isCurrentUserAdmin
)

Parameters

caseId
Type: System..::.Int32
The unique id of the case
currentUserId
Type: System..::.Int32
The unique id of the current user
isCurrentUserAdmin
Type: System..::.Boolean
Is the current user an administrator

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


DeleteProject Method

[image]

OfficeClip API Documentation
TrackerDB..::.DeleteProject Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the Project in the database.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int DeleteProject(
    int projectId
)
Visual Basic (Declaration)
Public Function DeleteProject ( _
    projectId As Integer _
) As Integer
Visual C++
public:
int DeleteProject(
    int projectId
)

Parameters

projectId
Type: System..::.Int32
The database id of the Project.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
TrackerDB..::.ExecuteNonQuery Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

TrackerDB Class
TrackerDB Members
OfficeClip.DBLayer.Tracker Namespace


GetAdminProjectList Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetAdminProjectList Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Project list which are accessible to the administrator. This method assumes that the currently logged in user is an administrator.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetAdminProjectList(
    ConfigureInfo session
)
Visual Basic (Declaration)
Public Function GetAdminProjectList ( _
    session As ConfigureInfo _
) As DataSet
Visual C++
public:
DataSet^ GetAdminProjectList(
    ConfigureInfo^ session
)

Parameters

session
Type: OfficeClip.Utils..::.ConfigureInfo

Return Value

The following columns are returned in the dataset,
  • isActiveIf the Project is Active
  • projectIdThe unique id of the Project
  • projectNameThe name of the Project
  • groupNameThe name of the group
  • GroupIdThe unique id of the group
  • groupTypeThe type of the group, GroupType

Remarks

Please note that this method should be called by the currently logged in user who is an administrator.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetAttachmentPaths Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetAttachmentPaths Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the attachment paths

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetAttachmentPaths(
    int caseId,
    int groupId
)
Visual Basic (Declaration)
Public Function GetAttachmentPaths ( _
    caseId As Integer, _
    groupId As Integer _
) As ArrayList
Visual C++
public:
ArrayList^ GetAttachmentPaths(
    int caseId,
    int groupId
)

Parameters

caseId
Type: System..::.Int32
groupId
Type: System..::.Int32

Return Value

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetCaseDetails Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetCaseDetails Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Provides an ArrayList of PropertyInfo for a tracker case.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public ArrayList GetCaseDetails(
    int projectId,
    TrackerCaseInfo tci
)
Visual Basic (Declaration)
Public Function GetCaseDetails ( _
    projectId As Integer, _
    tci As TrackerCaseInfo _
) As ArrayList
Visual C++
public:
ArrayList^ GetCaseDetails(
    int projectId,
    TrackerCaseInfo^ tci
)

Parameters

projectId
Type: System..::.Int32
The system generated unique identifier for the Project.
tci
Type: OfficeClip.BusinessLayer.Tracker..::.TrackerCaseInfo
The tracker case infomration object to Store information regarding a particular case.

Return Value

The list of PropertyInfo for the tracker case.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetCaseDetailString Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetCaseDetailString Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tracker case detail in a String

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string GetCaseDetailString(
    int userId,
    int groupId,
    int projectId,
    TrackerCaseInfo tci
)
Visual Basic (Declaration)
Public Function GetCaseDetailString ( _
    userId As Integer, _
    groupId As Integer, _
    projectId As Integer, _
    tci As TrackerCaseInfo _
) As String
Visual C++
public:
String^ GetCaseDetailString(
    int userId,
    int groupId,
    int projectId,
    TrackerCaseInfo^ tci
)

Parameters

userId
Type: System..::.Int32
Unique id for the user
groupId
Type: System..::.Int32
Unique id for the organization
projectId
Type: System..::.Int32
The system generated unique identifier for the tracker Project.
tci
Type: OfficeClip.BusinessLayer.Tracker..::.TrackerCaseInfo
The tracker case information structure. This structure contains the detail of a tracker case.

Return Value

A textual representation of the tracker case.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetCaseIdFromCaseNum Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetCaseIdFromCaseNum Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the internal case id from the Project id and the case number.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetCaseIdFromCaseNum(
    string caseNum,
    int projectId
)
Visual Basic (Declaration)
Public Function GetCaseIdFromCaseNum ( _
    caseNum As String, _
    projectId As Integer _
) As Integer
Visual C++
public:
int GetCaseIdFromCaseNum(
    String^ caseNum,
    int projectId
)

Parameters

caseNum
Type: System..::.String
The case number as shown in the tracker case list screen.
projectId
Type: System..::.Int32
The internal id of the Project.

Return Value

The internal id of the case or -1 if the case is not found.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetCaseListExt Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetCaseListExt Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the extension parameters of the case. The extension parameters are Description, Resolution and Comments.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetCaseListExt(
    int projectId,
    string searchStr
)
Visual Basic (Declaration)
Public Function GetCaseListExt ( _
    projectId As Integer, _
    searchStr As String _
) As DataSet
Visual C++
public:
DataSet^ GetCaseListExt(
    int projectId,
    String^ searchStr
)

Parameters

projectId
Type: System..::.Int32
The unique id of the Project.
searchStr
Type: System..::.String
The string to be searched in all the output field, if this string is specified, the rows that are returned will have this string in one of its columns. Default is empty string.

Return Value

The dataset having a datatable with the following values
  • cidThe case id
  • DescriptionThe Description of the case
  • ResolutionThe Resolution of the case
  • CommentsThe Comments of the case

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetCaseListInfo Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetCaseListInfo Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the caselist information to display in the caselist screen of the tracker for a particular user.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetCaseListInfo(
    int projectId,
    string sortField,
    string sortState,
    int filterValue,
    ArrayList searchAL,
    string searchStr,
    bool isLike,
    bool showNew,
    int currentUserId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function GetCaseListInfo ( _
    projectId As Integer, _
    sortField As String, _
    sortState As String, _
    filterValue As Integer, _
    searchAL As ArrayList, _
    searchStr As String, _
    isLike As Boolean, _
    showNew As Boolean, _
    currentUserId As Integer, _
    currentGroupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetCaseListInfo(
    int projectId,
    String^ sortField,
    String^ sortState,
    int filterValue,
    ArrayList^ searchAL,
    String^ searchStr,
    bool isLike,
    bool showNew,
    int currentUserId,
    int currentGroupId
)

Parameters

projectId
Type: System..::.Int32
The database id of the Project.
sortField
Type: System..::.String
The field on which the sort is done.
sortState
Type: System..::.String
Whether ascending (ASC) or descending (DESC).
filterValue
Type: System..::.Int32
The filter id of the filter used in case list.
searchAL
Type: System.Collections..::.ArrayList
The search arraylist of all the field ids for which the search is requested, this is mostly used when a search is requested for all the parameters.
searchStr
Type: System..::.String
The string which needs to be searched.
isLike
Type: System..::.Boolean
true if the search is "Is" false if it is "Is Not"
showNew
Type: System..::.Boolean
Whether the new case indicator needs to be shown
currentUserId
Type: System..::.Int32
the id of the current user
currentGroupId
Type: System..::.Int32
The id of the current organization

Return Value

The dataset consisting of the following information:
  • filterIdThe unique id of the filter
  • filterNameThe name of the filter
  • caseNumThe unique number of the case
  • titleThe title of the case
  • DescriptionThe Description of the case (only the first 100 characters)
  • CreatedDateThe created date of the case
  • statusThe status of the case
  • CriticalityThe Criticality of the case
  • categotyThe Category of the case
  • kindThe kind of the case
  • CreatedByThe user id of the user who created the case
  • modifiedByThe user id of the user who last modified the case
  • The date when the case was last modified
    and all the udfs

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetCaseListInfoAll Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetCaseListInfoAll Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the case information, this combines the normal case list information and also the Description, Resolution and Comments

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetCaseListInfoAll(
    int projectId,
    string sortField,
    string sortState,
    int filterValue,
    ArrayList searchAL,
    string searchStr,
    bool showAll,
    int currentUserId,
    int currentGroupId
)
Visual Basic (Declaration)
Public Function GetCaseListInfoAll ( _
    projectId As Integer, _
    sortField As String, _
    sortState As String, _
    filterValue As Integer, _
    searchAL As ArrayList, _
    searchStr As String, _
    showAll As Boolean, _
    currentUserId As Integer, _
    currentGroupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetCaseListInfoAll(
    int projectId,
    String^ sortField,
    String^ sortState,
    int filterValue,
    ArrayList^ searchAL,
    String^ searchStr,
    bool showAll,
    int currentUserId,
    int currentGroupId
)

Parameters

projectId
Type: System..::.Int32
The unique id of the Project.
sortField
Type: System..::.String
The field on which the cases will be sorted on.
sortState
Type: System..::.String
The sort State, A-Ascending, D-Descending, otherwise no sort.
filterValue
Type: System..::.Int32
The filter string to filter the output.
searchAL
Type: System.Collections..::.ArrayList
The search arraylist that consists of all the fields to be searched.
searchStr
Type: System..::.String
The user entered search string.
showAll
Type: System..::.Boolean
If all the cases are required to be shown
currentUserId
Type: System..::.Int32
The unique id of the current user
currentGroupId
Type: System..::.Int32
The id of the current organization

Return Value

The output dataset consists of two tables data and dataExt and a relation between them based on the field cid (case id) in both the tables.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetCaseListInfoKB Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetCaseListInfoKB Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Get the case list information for the knowledge base

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetCaseListInfoKB(
    int projectId,
    ArrayList searchAL,
    string searchStr,
    bool showAll
)
Visual Basic (Declaration)
Public Function GetCaseListInfoKB ( _
    projectId As Integer, _
    searchAL As ArrayList, _
    searchStr As String, _
    showAll As Boolean _
) As DataSet
Visual C++
public:
DataSet^ GetCaseListInfoKB(
    int projectId,
    ArrayList^ searchAL,
    String^ searchStr,
    bool showAll
)

Parameters

projectId
Type: System..::.Int32
The system generated unque id of the project
searchAL
Type: System.Collections..::.ArrayList
The arraylist of the search parameters
searchStr
Type: System..::.String
The string to be searched
showAll
Type: System..::.Boolean
Shows if all cases should be shown

Return Value

The dataset corresponding to the case list

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetChildren Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetChildren Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the children of an object

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetChildren(
    int groupId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)
Visual Basic (Declaration)
Public Function GetChildren ( _
    groupId As Integer, _
    oType As BusinessConstants..::.ObjectType, _
    objectId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetChildren(
    int groupId,
    BusinessConstants..::.ObjectType oType,
    int objectId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
oType
Type: OfficeClip.BusinessLayer..::.BusinessConstants..::.ObjectType
The object type id
objectId
Type: System..::.Int32
The object id

Return Value

The datatable of the childern

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetFieldListValues Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetFieldListValues Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns a datatable consisting of all the field list values.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetFieldListValues(
    int projectId
)
Visual Basic (Declaration)
Public Function GetFieldListValues ( _
    projectId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetFieldListValues(
    int projectId
)

Parameters

projectId
Type: System..::.Int32
The system generated unique identifier for the Project.

Return Value

DataSet consisting of field list values names.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetFieldNames Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetFieldNames Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns a datatable consisting of all the field names.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetFieldNames(
    int projectId
)
Visual Basic (Declaration)
Public Function GetFieldNames ( _
    projectId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetFieldNames(
    int projectId
)

Parameters

projectId
Type: System..::.Int32
The unique id for the Project.

Return Value

Datatable consisting of field names.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetFieldValues Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetFieldValues Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tracker case information consisting of all the field values.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerCaseInfo GetFieldValues(
    int caseId,
    bool isSessionAvailable
)
Visual Basic (Declaration)
Public Function GetFieldValues ( _
    caseId As Integer, _
    isSessionAvailable As Boolean _
) As TrackerCaseInfo
Visual C++
public:
TrackerCaseInfo^ GetFieldValues(
    int caseId,
    bool isSessionAvailable
)

Parameters

caseId
Type: System..::.Int32
The unique id of the case.
isSessionAvailable
Type: System..::.Boolean
Shows if the user session is available.

Return Value

TrackerCaseInfo or null if the case information is not found in the database.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetFilterDetail Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetFilterDetail Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the filter detail for a given filter

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void GetFilterDetail(
    int filterId,
    ref string filterName,
    ref string displayString
)
Visual Basic (Declaration)
Public Sub GetFilterDetail ( _
    filterId As Integer, _
    ByRef filterName As String, _
    ByRef displayString As String _
)
Visual C++
public:
void GetFilterDetail(
    int filterId,
    String^% filterName,
    String^% displayString
)

Parameters

filterId
Type: System..::.Int32
The database id of the filter
filterName
Type: System..::.String%
The name of the filter
displayString
Type: System..::.String%
The display string of the filter

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetFilters Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetFilters Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets all the filters

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetFilters(
    int projectId,
    int userId
)
Visual Basic (Declaration)
Public Function GetFilters ( _
    projectId As Integer, _
    userId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetFilters(
    int projectId,
    int userId
)

Parameters

projectId
Type: System..::.Int32
The project id of the project
userId
Type: System..::.Int32
The unique id for the user

Return Value

The number of projects

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetHistory Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetHistory Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tracker history for display on the screen.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public SqlDataReader GetHistory(
    int caseId,
    int showNum
)
Visual Basic (Declaration)
Public Function GetHistory ( _
    caseId As Integer, _
    showNum As Integer _
) As SqlDataReader
Visual C++
public:
SqlDataReader^ GetHistory(
    int caseId,
    int showNum
)

Parameters

caseId
Type: System..::.Int32
The database identifier of the case.
showNum
Type: System..::.Int32
shows how many lines need to be shown at the output

Return Value

Returns the sqldatareader consisting of the following columns:
  • nameUser Name in lastname, first name format
  • columnNameThe name of the column
  • finalValueThe field value
  • chDateThe change date

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetProjectCount Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetProjectCount Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the count of the projects

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int GetProjectCount(
    string projectName,
    int groupId
)
Visual Basic (Declaration)
Public Function GetProjectCount ( _
    projectName As String, _
    groupId As Integer _
) As Integer
Visual C++
public:
int GetProjectCount(
    String^ projectName,
    int groupId
)

Parameters

projectName
Type: System..::.String
The name of the project
groupId
Type: System..::.Int32
The unique id for the group

Return Value

The number of projects

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetProjectInfo Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetProjectInfo Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the Project information.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerProjectInfo GetProjectInfo(
    int projectId
)
Visual Basic (Declaration)
Public Function GetProjectInfo ( _
    projectId As Integer _
) As TrackerProjectInfo
Visual C++
public:
TrackerProjectInfo^ GetProjectInfo(
    int projectId
)

Parameters

projectId
Type: System..::.Int32
The database id of the Project.

Return Value

The return status enumerated type ReturnStatus.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetProjects Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetProjects Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets a list of all the Projects from the database

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetProjects(
    int groupId
)
Visual Basic (Declaration)
Public Function GetProjects ( _
    groupId As Integer _
) As DataSet
Visual C++
public:
DataSet^ GetProjects(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique Id of the group for which the Project list is required

Return Value

The resultset has the following columns
  1. pidThe Project id
  2. pNameThe Project name
  3. pCountThe Project count
  4. pLastDateThe Project's Last modified date

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetRowStyle Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetRowStyle Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Returns the style of the row, the row style can be in terms of background color or font

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataTable GetRowStyle(
    int projectId
)
Visual Basic (Declaration)
Public Function GetRowStyle ( _
    projectId As Integer _
) As DataTable
Visual C++
public:
DataTable^ GetRowStyle(
    int projectId
)

Parameters

projectId
Type: System..::.Int32
The unique id of the project

Return Value

The datatable with the row style, returns null if no row style is defined

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetStatisticalData Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetStatisticalData Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the statistical data related to the list type fields.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetStatisticalData(
    int projectId,
    TrackerFieldsNameId tid
)
Visual Basic (Declaration)
Public Function GetStatisticalData ( _
    projectId As Integer, _
    tid As TrackerFieldsNameId _
) As DataSet
Visual C++
public:
DataSet^ GetStatisticalData(
    int projectId,
    TrackerFieldsNameId tid
)

Parameters

projectId
Type: System..::.Int32
The unique id for the Project.
tid
Type: OfficeClip.Utils..::.TrackerFieldsNameId
tracker field id.

Return Value

the dataset for the statistical data.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


GetTrackerExternalStatus Method

[image]

OfficeClip API Documentation
TrackerDB..::.GetTrackerExternalStatus Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tracker status matrix for extranet users

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public DataSet GetTrackerExternalStatus(
    int userId,
    int projectId,
    string emailAddress
)
Visual Basic (Declaration)
Public Function GetTrackerExternalStatus ( _
    userId As Integer, _
    projectId As Integer, _
    emailAddress As String _
) As DataSet
Visual C++
public:
DataSet^ GetTrackerExternalStatus(
    int userId,
    int projectId,
    String^ emailAddress
)

Parameters

userId
Type: System..::.Int32
The id of the user
projectId
Type: System..::.Int32
The id of the project
emailAddress
Type: System..::.String
The external email address of the tracker case

Return Value

The dataset for all the cases of the project that has the particular external email address

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
TrackerDB..::.InitTransaction Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

TrackerDB Class
TrackerDB Members
OfficeClip.DBLayer.Tracker Namespace


InsertCase Method

[image]

OfficeClip API Documentation
TrackerDB..::.InsertCase Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts a new case in the tracker.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int InsertCase(
    int projectId,
    string projName,
    ref TrackerCaseInfo tci,
    string docIdList,
    bool isSendMessage,
    ConfigureInfo session,
    ref DataTable fieldNames
)
Visual Basic (Declaration)
Public Function InsertCase ( _
    projectId As Integer, _
    projName As String, _
    ByRef tci As TrackerCaseInfo, _
    docIdList As String, _
    isSendMessage As Boolean, _
    session As ConfigureInfo, _
    ByRef fieldNames As DataTable _
) As Integer
Visual C++
public:
int InsertCase(
    int projectId,
    String^ projName,
    TrackerCaseInfo^% tci,
    String^ docIdList,
    bool isSendMessage,
    ConfigureInfo^ session,
    DataTable^% fieldNames
)

Parameters

projectId
Type: System..::.Int32
The Project id for the Project where the case is inserted.
projName
Type: System..::.String
The name of the Project. Used for sending rule based email and saving a round trip to the database.
tci
Type: OfficeClip.BusinessLayer.Tracker..::.TrackerCaseInfo %
The tracker case information class
docIdList
Type: System..::.String
The list of comma separated doc ids for uploaded documents.
isSendMessage
Type: System..::.Boolean
Is the message required to be sent
session
Type: OfficeClip.Utils..::.ConfigureInfo
The unique id of the session
fieldNames
Type: System.Data..::.DataTable%
Reference Parameter to be filled with Field Names and givn back

Return Value

If successful retuns the case id of the newly insterd case if failed returns the value of NotAvailable NotAvailable.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


InsertFieldListValue Method

[image]

OfficeClip API Documentation
TrackerDB..::.InsertFieldListValue Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Modifies the field values of a list type.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertFieldListValue(
    int projectId,
    int fieldType,
    int numDays,
    string val,
    string sortOrder
)
Visual Basic (Declaration)
Public Sub InsertFieldListValue ( _
    projectId As Integer, _
    fieldType As Integer, _
    numDays As Integer, _
    val As String, _
    sortOrder As String _
)
Visual C++
public:
void InsertFieldListValue(
    int projectId,
    int fieldType,
    int numDays,
    String^ val,
    String^ sortOrder
)

Parameters

projectId
Type: System..::.Int32
The unique id of the Project.
fieldType
Type: System..::.Int32
The type of the field, these are coded according to the type. TrackerFieldsNameId.
numDays
Type: System..::.Int32
The number of days (valid for Criticality fixed field).
val
Type: System..::.String
The value of the field
sortOrder
Type: System..::.String
The sort order can be 'N' - as is no sort 'D' as descending or 'A' - ascending.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


IsTrackerCasePresent Method

[image]

OfficeClip API Documentation
TrackerDB..::.IsTrackerCasePresent Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Checks if the tracker case is present

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public bool IsTrackerCasePresent(
    int caseId
)
Visual Basic (Declaration)
Public Function IsTrackerCasePresent ( _
    caseId As Integer _
) As Boolean
Visual C++
public:
bool IsTrackerCasePresent(
    int caseId
)

Parameters

caseId
Type: System..::.Int32

Return Value

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


MoveFieldListValueDown Method

[image]

OfficeClip API Documentation
TrackerDB..::.MoveFieldListValueDown Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Move the list item of a tracker field to one Position down.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void MoveFieldListValueDown(
    int projectId,
    int fieldType,
    int fieldId
)
Visual Basic (Declaration)
Public Sub MoveFieldListValueDown ( _
    projectId As Integer, _
    fieldType As Integer, _
    fieldId As Integer _
)
Visual C++
public:
void MoveFieldListValueDown(
    int projectId,
    int fieldType,
    int fieldId
)

Parameters

projectId
Type: System..::.Int32
The unique identifier of the Project.
fieldType
Type: System..::.Int32
The field type as given in TrackerFieldsNameId.
fieldId
Type: System..::.Int32
The unique identifier of the list item that is expencted to move down.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


MoveFieldListValueUp Method

[image]

OfficeClip API Documentation
TrackerDB..::.MoveFieldListValueUp Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Move the list item of a tracker field to one Position up.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void MoveFieldListValueUp(
    int projectId,
    int fieldType,
    int fieldId
)
Visual Basic (Declaration)
Public Sub MoveFieldListValueUp ( _
    projectId As Integer, _
    fieldType As Integer, _
    fieldId As Integer _
)
Visual C++
public:
void MoveFieldListValueUp(
    int projectId,
    int fieldType,
    int fieldId
)

Parameters

projectId
Type: System..::.Int32
The unique identifier of the Project.
fieldType
Type: System..::.Int32
The field type as given in TrackerFieldsNameId.
fieldId
Type: System..::.Int32
The unique identifier of the list item that is expected to move up.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


RemoveFieldListValue Method

[image]

OfficeClip API Documentation
TrackerDB..::.RemoveFieldListValue Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Removes the field list values

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void RemoveFieldListValue(
    int projectId,
    int fieldType,
    int fieldId
)
Visual Basic (Declaration)
Public Sub RemoveFieldListValue ( _
    projectId As Integer, _
    fieldType As Integer, _
    fieldId As Integer _
)
Visual C++
public:
void RemoveFieldListValue(
    int projectId,
    int fieldType,
    int fieldId
)

Parameters

projectId
Type: System..::.Int32
fieldType
Type: System..::.Int32
fieldId
Type: System..::.Int32

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


RemoveFilter Method

[image]

OfficeClip API Documentation
TrackerDB..::.RemoveFilter Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Delete a filter from the database

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void RemoveFilter(
    int filterId
)
Visual Basic (Declaration)
Public Sub RemoveFilter ( _
    filterId As Integer _
)
Visual C++
public:
void RemoveFilter(
    int filterId
)

Parameters

filterId
Type: System..::.Int32
The unique id of the filter

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


SaveFilter Method

[image]

OfficeClip API Documentation
TrackerDB..::.SaveFilter Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Saves a newly created filter in the database

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int SaveFilter(
    string FilterString,
    string displayString,
    int projectId,
    string filterName,
    int currentUserId
)
Visual Basic (Declaration)
Public Function SaveFilter ( _
    FilterString As String, _
    displayString As String, _
    projectId As Integer, _
    filterName As String, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int SaveFilter(
    String^ FilterString,
    String^ displayString,
    int projectId,
    String^ filterName,
    int currentUserId
)

Parameters

FilterString
Type: System..::.String
displayString
Type: System..::.String
projectId
Type: System..::.Int32
The database unique id of the Project.
filterName
Type: System..::.String
The name of the filter to be stored. If no name is mentioned, then the filter will be stored as the Current filter.
currentUserId
Type: System..::.Int32
the id of the current user

Return Value

The database id of the new filter is returned.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


SetColorCode Method

[image]

OfficeClip API Documentation
TrackerDB..::.SetColorCode Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetColorCode(
    int projectId,
    int colorCode,
    bool isEnabled
)
Visual Basic (Declaration)
Public Sub SetColorCode ( _
    projectId As Integer, _
    colorCode As Integer, _
    isEnabled As Boolean _
)
Visual C++
public:
void SetColorCode(
    int projectId,
    int colorCode,
    bool isEnabled
)

Parameters

projectId
Type: System..::.Int32
colorCode
Type: System..::.Int32
isEnabled
Type: System..::.Boolean

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
TrackerDB..::.SetSPCommand Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

TrackerDB Class
TrackerDB Members
OfficeClip.DBLayer.Tracker Namespace


SetStyleCode Method

[image]

OfficeClip API Documentation
TrackerDB..::.SetStyleCode Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SetStyleCode(
    int projectId,
    int styleCode,
    bool isEnabled
)
Visual Basic (Declaration)
Public Sub SetStyleCode ( _
    projectId As Integer, _
    styleCode As Integer, _
    isEnabled As Boolean _
)
Visual C++
public:
void SetStyleCode(
    int projectId,
    int styleCode,
    bool isEnabled
)

Parameters

projectId
Type: System..::.Int32
styleCode
Type: System..::.Int32
isEnabled
Type: System..::.Boolean

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


ShowListUnspecifiedWhenNull Method

[image] [image]

OfficeClip API Documentation
TrackerDB..::.ShowListUnspecifiedWhenNull Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ShowListUnspecifiedWhenNull(DataSet, Int32, Boolean, Boolean) | Changes the null to unspecified in the tracker case list
Public method | ShowListUnspecifiedWhenNull(DataSet, Int32, Int32, Boolean, Boolean) | Shows output as unspecified when the database returns as null.

See Also

TrackerDB Class
TrackerDB Members
OfficeClip.DBLayer.Tracker Namespace


ShowListUnspecifiedWhenNull Method (DataSet, Int32, Boolean, Boolean)

[image]

OfficeClip API Documentation
TrackerDB..::.ShowListUnspecifiedWhenNull Method (DataSet, Int32, Boolean, Boolean)
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Changes the null to unspecified in the tracker case list

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void ShowListUnspecifiedWhenNull(
    DataSet ds,
    int tableNum,
    bool isDisp,
    bool isBlank
)
Visual Basic (Declaration)
Public Sub ShowListUnspecifiedWhenNull ( _
    ds As DataSet, _
    tableNum As Integer, _
    isDisp As Boolean, _
    isBlank As Boolean _
)
Visual C++
public:
void ShowListUnspecifiedWhenNull(
    DataSet^ ds,
    int tableNum,
    bool isDisp,
    bool isBlank
)

Parameters

ds
Type: System.Data..::.DataSet
The input dataset
tableNum
Type: System..::.Int32
The table number in the dataset that needs to be changed
isDisp
Type: System..::.Boolean
If true, the output will be formatted to be displayed on the browser.
isBlank
Type: System..::.Boolean
if true then the output is shown as blank otherwise it is shown as unspecified.

See Also

TrackerDB Class
ShowListUnspecifiedWhenNull Overload
OfficeClip.DBLayer.Tracker Namespace


ShowListUnspecifiedWhenNull Method (DataSet, Int32, Int32, Boolean, Boolean)

[image]

OfficeClip API Documentation
TrackerDB..::.ShowListUnspecifiedWhenNull Method (DataSet, Int32, Int32, Boolean, Boolean)
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Shows output as unspecified when the database returns as null.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void ShowListUnspecifiedWhenNull(
    DataSet ds,
    int tableNum,
    int col,
    bool isDisp,
    bool isBlank
)
Visual Basic (Declaration)
Public Sub ShowListUnspecifiedWhenNull ( _
    ds As DataSet, _
    tableNum As Integer, _
    col As Integer, _
    isDisp As Boolean, _
    isBlank As Boolean _
)
Visual C++
public:
void ShowListUnspecifiedWhenNull(
    DataSet^ ds,
    int tableNum,
    int col,
    bool isDisp,
    bool isBlank
)

Parameters

ds
Type: System.Data..::.DataSet
Operates on the fixed fields of the dataset
tableNum
Type: System..::.Int32
The table number in the dataset
col
Type: System..::.Int32
The column Index in the table
isDisp
Type: System..::.Boolean
If true, the output will be formatted to be displayed on the browser.
isBlank
Type: System..::.Boolean
if true then the output is shown as blank otherwise it is shown as unspecified.

See Also

TrackerDB Class
ShowListUnspecifiedWhenNull Overload
OfficeClip.DBLayer.Tracker Namespace


UpdateCase Method

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateCase Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates an existing case in the tracker.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateCase(
    int projectId,
    string projName,
    int caseId,
    TrackerCaseInfo tci,
    ref TrackerCaseInfo tciOld,
    string docIdList,
    string remDocIdList,
    bool isSendRuleMessage,
    ConfigureInfo session,
    ref DataTable fieldNames
)
Visual Basic (Declaration)
Public Function UpdateCase ( _
    projectId As Integer, _
    projName As String, _
    caseId As Integer, _
    tci As TrackerCaseInfo, _
    ByRef tciOld As TrackerCaseInfo, _
    docIdList As String, _
    remDocIdList As String, _
    isSendRuleMessage As Boolean, _
    session As ConfigureInfo, _
    ByRef fieldNames As DataTable _
) As Integer
Visual C++
public:
int UpdateCase(
    int projectId,
    String^ projName,
    int caseId,
    TrackerCaseInfo^ tci,
    TrackerCaseInfo^% tciOld,
    String^ docIdList,
    String^ remDocIdList,
    bool isSendRuleMessage,
    ConfigureInfo^ session,
    DataTable^% fieldNames
)

Parameters

projectId
Type: System..::.Int32
The Project id for the Project where the case is updated.
projName
Type: System..::.String
The name of the Project. This is used for sending rule based email message and saving a round trip to the server.
caseId
Type: System..::.Int32
The unique identifier of each case.
tci
Type: OfficeClip.BusinessLayer.Tracker..::.TrackerCaseInfo
The tracker case information class.
tciOld
Type: OfficeClip.BusinessLayer.Tracker..::.TrackerCaseInfo %
The tracker case information class. ref parameter to be filled in with Old TrackerInfo Data and given back
docIdList
Type: System..::.String
The list of attached document ids.
remDocIdList
Type: System..::.String
The document list which needs to be removed.
isSendRuleMessage
Type: System..::.Boolean
Determines if the rules message will be sent The case number will not be updated if there is another case with the same number in the database.
session
Type: OfficeClip.Utils..::.ConfigureInfo
the user session object
fieldNames
Type: System.Data..::.DataTable%
ref parameter to be filled in with field Name and given back

Return Value

status = caseId if successful, -1 if failed.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


UpdateFieldListDefault Method

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateFieldListDefault Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the default value of the list type field.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateFieldListDefault(
    int projectId,
    int fieldType,
    int fieldId
)
Visual Basic (Declaration)
Public Sub UpdateFieldListDefault ( _
    projectId As Integer, _
    fieldType As Integer, _
    fieldId As Integer _
)
Visual C++
public:
void UpdateFieldListDefault(
    int projectId,
    int fieldType,
    int fieldId
)

Parameters

projectId
Type: System..::.Int32
The unique id of the Project.
fieldType
Type: System..::.Int32
The type of the field, these are coded. according to the type in TrackerFieldsNameId
fieldId
Type: System..::.Int32
The id of the field type.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


UpdateFieldListSortOrder Method

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateFieldListSortOrder Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the sort order of a field type of type list.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateFieldListSortOrder(
    int projectId,
    int fieldType,
    string sortOrder
)
Visual Basic (Declaration)
Public Sub UpdateFieldListSortOrder ( _
    projectId As Integer, _
    fieldType As Integer, _
    sortOrder As String _
)
Visual C++
public:
void UpdateFieldListSortOrder(
    int projectId,
    int fieldType,
    String^ sortOrder
)

Parameters

projectId
Type: System..::.Int32
The database id of the Project.
fieldType
Type: System..::.Int32
The type of the field, these are coded according to the type in TrackerFieldsNameId.
sortOrder
Type: System..::.String
The sort order can be 'N' - as is no sort 'D' as descending or 'A' - ascending.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


UpdateFieldListValue Method

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateFieldListValue Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the list value of a particular list type field in tracker.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateFieldListValue(
    int projectId,
    int fieldType,
    int fieldId,
    string val,
    bool isColorEnabled,
    string colorValue,
    bool isStyleEnabled,
    string styleValue
)
Visual Basic (Declaration)
Public Sub UpdateFieldListValue ( _
    projectId As Integer, _
    fieldType As Integer, _
    fieldId As Integer, _
    val As String, _
    isColorEnabled As Boolean, _
    colorValue As String, _
    isStyleEnabled As Boolean, _
    styleValue As String _
)
Visual C++
public:
void UpdateFieldListValue(
    int projectId,
    int fieldType,
    int fieldId,
    String^ val,
    bool isColorEnabled,
    String^ colorValue,
    bool isStyleEnabled,
    String^ styleValue
)

Parameters

projectId
Type: System..::.Int32
The unique identifier for the Project.
fieldType
Type: System..::.Int32
The type of the field as given by TrackerFieldsNameId
fieldId
Type: System..::.Int32
The unique identifier of the list item whose value is required to be changed.
val
Type: System..::.String
The value that the list item is supposed to change to.
isColorEnabled
Type: System..::.Boolean
Is the color enabled
colorValue
Type: System..::.String
The value of the color
isStyleEnabled
Type: System..::.Boolean
Is the style enabled
styleValue
Type: System..::.String
The value of the style

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


UpdateFixedFields Method

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateFixedFields Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the fixed field names.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateFixedFields(
    int projectId,
    ArrayList fixedFields
)
Visual Basic (Declaration)
Public Sub UpdateFixedFields ( _
    projectId As Integer, _
    fixedFields As ArrayList _
)
Visual C++
public:
void UpdateFixedFields(
    int projectId,
    ArrayList^ fixedFields
)

Parameters

projectId
Type: System..::.Int32
The database id for the Project.
fixedFields
Type: System.Collections..::.ArrayList
The name of the fixed fields in the array list.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


UpdateFixedFieldsAdminEdit Method

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateFixedFieldsAdminEdit Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the edit capabilities of the fixed fields

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateFixedFieldsAdminEdit(
    int projectId,
    ArrayList ffAdminEdit
)
Visual Basic (Declaration)
Public Sub UpdateFixedFieldsAdminEdit ( _
    projectId As Integer, _
    ffAdminEdit As ArrayList _
)
Visual C++
public:
void UpdateFixedFieldsAdminEdit(
    int projectId,
    ArrayList^ ffAdminEdit
)

Parameters

projectId
Type: System..::.Int32
the unique id of the project
ffAdminEdit
Type: System.Collections..::.ArrayList
The arraylist of the admin edits

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


UpdateFixedFieldsMandatory Method

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateFixedFieldsMandatory Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the mandatory capabilities of the fixed fields

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateFixedFieldsMandatory(
    int projectId,
    ArrayList ffMandatory
)
Visual Basic (Declaration)
Public Sub UpdateFixedFieldsMandatory ( _
    projectId As Integer, _
    ffMandatory As ArrayList _
)
Visual C++
public:
void UpdateFixedFieldsMandatory(
    int projectId,
    ArrayList^ ffMandatory
)

Parameters

projectId
Type: System..::.Int32
the unique id of the project
ffMandatory
Type: System.Collections..::.ArrayList
The arraylist of the mandatory

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


UpdateOptions Method

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateOptions Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the database based on the values entered in the option screen.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void UpdateOptions(
    int projectId,
    bool isFixedPrefix,
    string prefixText,
    DataTable dt,
    int numRec
)
Visual Basic (Declaration)
Public Sub UpdateOptions ( _
    projectId As Integer, _
    isFixedPrefix As Boolean, _
    prefixText As String, _
    dt As DataTable, _
    numRec As Integer _
)
Visual C++
public:
void UpdateOptions(
    int projectId,
    bool isFixedPrefix,
    String^ prefixText,
    DataTable^ dt,
    int numRec
)

Parameters

projectId
Type: System..::.Int32
The database id of the Project.
isFixedPrefix
Type: System..::.Boolean
If the case ids have a fixed three letter Prefix.
prefixText
Type: System..::.String
if isFixedPrefix is true, then shows is the Prefix.
dt
Type: System.Data..::.DataTable
The datatable shich shows which fields are selected.
numRec
Type: System..::.Int32
Number of records to be shown in the case list screen.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


UpdateProjectName Method

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateProjectName Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Changes the name of the Project.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerDB..::.UpdateProjectNameStatus UpdateProjectName(
    int projectId,
    string projectName
)
Visual Basic (Declaration)
Public Function UpdateProjectName ( _
    projectId As Integer, _
    projectName As String _
) As TrackerDB..::.UpdateProjectNameStatus
Visual C++
public:
TrackerDB..::.UpdateProjectNameStatus UpdateProjectName(
    int projectId,
    String^ projectName
)

Parameters

projectId
Type: System..::.Int32
The database id of the Project.
projectName
Type: System..::.String
The name of the Project.

Return Value

returns 0 id successful and -1 if it will create a duplicate name.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


UpdateUdfName Method

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateUdfName Method
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

Changes the name of the udf field.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int UpdateUdfName(
    int projectId,
    int mode,
    int udfNum,
    string name,
    string type,
    bool isAdminEdit,
    bool isMandatory
)
Visual Basic (Declaration)
Public Function UpdateUdfName ( _
    projectId As Integer, _
    mode As Integer, _
    udfNum As Integer, _
    name As String, _
    type As String, _
    isAdminEdit As Boolean, _
    isMandatory As Boolean _
) As Integer
Visual C++
public:
int UpdateUdfName(
    int projectId,
    int mode,
    int udfNum,
    String^ name,
    String^ type,
    bool isAdminEdit,
    bool isMandatory
)

Parameters

projectId
Type: System..::.Int32
The database id of the Project
mode
Type: System..::.Int32
The values are,
  • 0Update
  • 1Add
  • 2Delete
udfNum
Type: System..::.Int32
The udf number.
name
Type: System..::.String
The new name of the udf.
type
Type: System..::.String
The type of the udf, valid values are,
  • Text
  • List
  • Email
  • Date
  • User
isAdminEdit
Type: System..::.Boolean
Shows if edit is only permitted to the administrator
isMandatory
Type: System..::.Boolean
The the field mandatory

Return Value

=OK, -1=name already exists.

See Also

TrackerDB Class
OfficeClip.DBLayer.Tracker Namespace


TrackerDB.UpdateProjectNameStatus Enumeration

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateProjectNameStatus Enumeration
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

status for the return value of the UpdateProjectName function UpdateProjectName(Int32, String)

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public enum UpdateProjectNameStatus
Visual Basic (Declaration)
Public Enumeration UpdateProjectNameStatus
Visual C++
public enum class UpdateProjectNameStatus

Members

Member name | Description
Success | Update of the Project name status succeded
Duplicate | Update of the Project name status failed as there is another Project with that name.

See Also

OfficeClip.DBLayer.Tracker Namespace


TrackerDB.UpdateUdfNameStatus Enumeration

[image]

OfficeClip API Documentation
TrackerDB..::.UpdateUdfNameStatus Enumeration
TrackerDB Class See Also

[This is preliminary documentation and is subject to change.]

The status of updating the udf name.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public enum UpdateUdfNameStatus
Visual Basic (Declaration)
Public Enumeration UpdateUdfNameStatus
Visual C++
public enum class UpdateUdfNameStatus

Members

Member name | Description
NameAlreadyExists | Another udf of the same name exists in the same Project, so Update cannot happen.
Success | Update udf name successful.

See Also

OfficeClip.DBLayer.Tracker Namespace


TrackerEmailDB Class

[image]

OfficeClip API Documentation
TrackerEmailDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class provides DBLayer methods for the tracker synchronization.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerEmailDB : OfficeClipDB
Visual Basic (Declaration)
Public Class TrackerEmailDB _
    Inherits OfficeClipDB
Visual C++
public ref class TrackerEmailDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Tracker..::.TrackerEmailDB

See Also

TrackerEmailDB Members
OfficeClip.DBLayer.Tracker Namespace


TrackerEmailDB Members

[image] [image]

OfficeClip API Documentation
TrackerEmailDB Members
TrackerEmailDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerEmailDB type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerEmailDB | Default Constructor

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Protected method | DelTrackerEmailMessageIds | Deletes the tracker email message id
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetInfo | The email tracker information
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Protected method | GetTrackerEmailMessageIds | Gets the tracker email message id
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | InsTrackerEmailMessageIds | inserts the tracker email message ids
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessMessage | Processes the message
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SyncEmail | Syncs the email
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Update the tracker emails
Protected method | UpdTrackerEmailLastMessage | Updates the tracker email message

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

TrackerEmailDB Class
OfficeClip.DBLayer.Tracker Namespace


TrackerEmailDB Constructor

[image]

OfficeClip API Documentation
TrackerEmailDB Constructor
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Default Constructor

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerEmailDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerEmailDB()

See Also

TrackerEmailDB Class
OfficeClip.DBLayer.Tracker Namespace


TrackerEmailDB Methods

[image] [image]

OfficeClip API Documentation
TrackerEmailDB Methods
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerEmailDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Protected method | DelTrackerEmailMessageIds | Deletes the tracker email message id
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetInfo | The email tracker information
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Protected method | GetTrackerEmailMessageIds | Gets the tracker email message id
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Protected method | InsTrackerEmailMessageIds | inserts the tracker email message ids
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ProcessMessage | Processes the message
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | SyncEmail | Syncs the email
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Update the tracker emails
Protected method | UpdTrackerEmailLastMessage | Updates the tracker email message

See Also

TrackerEmailDB Class
OfficeClip.DBLayer.Tracker Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
TrackerEmailDB..::.AddOutputParameter Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

TrackerEmailDB Class
TrackerEmailDB Members
OfficeClip.DBLayer.Tracker Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
TrackerEmailDB..::.AddParameter Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

TrackerEmailDB Class
TrackerEmailDB Members
OfficeClip.DBLayer.Tracker Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
TrackerEmailDB..::.AddParameters Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

TrackerEmailDB Class
TrackerEmailDB Members
OfficeClip.DBLayer.Tracker Namespace


DelTrackerEmailMessageIds Method

[image]

OfficeClip API Documentation
TrackerEmailDB..::.DelTrackerEmailMessageIds Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Deletes the tracker email message id

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void DelTrackerEmailMessageIds(
    int projectId,
    string messageId
)
Visual Basic (Declaration)
Protected Sub DelTrackerEmailMessageIds ( _
    projectId As Integer, _
    messageId As String _
)
Visual C++
protected:
void DelTrackerEmailMessageIds(
    int projectId,
    String^ messageId
)

Parameters

projectId
Type: System..::.Int32
messageId
Type: System..::.String

See Also

TrackerEmailDB Class
OfficeClip.DBLayer.Tracker Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
TrackerEmailDB..::.ExecuteNonQuery Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

TrackerEmailDB Class
TrackerEmailDB Members
OfficeClip.DBLayer.Tracker Namespace


GetInfo Method

[image]

OfficeClip API Documentation
TrackerEmailDB..::.GetInfo Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

The email tracker information

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerEmailInfo[] GetInfo(
    int projectId,
    bool isAuto
)
Visual Basic (Declaration)
Public Function GetInfo ( _
    projectId As Integer, _
    isAuto As Boolean _
) As TrackerEmailInfo()
Visual C++
public:
array<TrackerEmailInfo^>^ GetInfo(
    int projectId,
    bool isAuto
)

Parameters

projectId
Type: System..::.Int32
isAuto
Type: System..::.Boolean

Return Value

See Also

TrackerEmailDB Class
OfficeClip.DBLayer.Tracker Namespace


GetTrackerEmailMessageIds Method

[image]

OfficeClip API Documentation
TrackerEmailDB..::.GetTrackerEmailMessageIds Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Gets the tracker email message id

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected ArrayList GetTrackerEmailMessageIds(
    int projectId
)
Visual Basic (Declaration)
Protected Function GetTrackerEmailMessageIds ( _
    projectId As Integer _
) As ArrayList
Visual C++
protected:
ArrayList^ GetTrackerEmailMessageIds(
    int projectId
)

Parameters

projectId
Type: System..::.Int32

Return Value

See Also

TrackerEmailDB Class
OfficeClip.DBLayer.Tracker Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
TrackerEmailDB..::.InitTransaction Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

TrackerEmailDB Class
TrackerEmailDB Members
OfficeClip.DBLayer.Tracker Namespace


InsTrackerEmailMessageIds Method

[image]

OfficeClip API Documentation
TrackerEmailDB..::.InsTrackerEmailMessageIds Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

inserts the tracker email message ids

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void InsTrackerEmailMessageIds(
    ArrayList msgIdArr,
    int projectId,
    string messageId
)
Visual Basic (Declaration)
Protected Sub InsTrackerEmailMessageIds ( _
    msgIdArr As ArrayList, _
    projectId As Integer, _
    messageId As String _
)
Visual C++
protected:
void InsTrackerEmailMessageIds(
    ArrayList^ msgIdArr,
    int projectId,
    String^ messageId
)

Parameters

msgIdArr
Type: System.Collections..::.ArrayList
projectId
Type: System..::.Int32
messageId
Type: System..::.String

See Also

TrackerEmailDB Class
OfficeClip.DBLayer.Tracker Namespace


ProcessMessage Method

[image]

OfficeClip API Documentation
TrackerEmailDB..::.ProcessMessage Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Processes the message

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void ProcessMessage(
    TrackerEmailInfo tei,
    OCMailMessage message
)
Visual Basic (Declaration)
Protected Sub ProcessMessage ( _
    tei As TrackerEmailInfo, _
    message As OCMailMessage _
)
Visual C++
protected:
void ProcessMessage(
    TrackerEmailInfo^ tei,
    OCMailMessage^ message
)

Parameters

tei
Type: OfficeClip.BusinessLayer.Tracker..::.TrackerEmailInfo
message
Type: OCMailMessage

See Also

TrackerEmailDB Class
OfficeClip.DBLayer.Tracker Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
TrackerEmailDB..::.SetSPCommand Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

TrackerEmailDB Class
TrackerEmailDB Members
OfficeClip.DBLayer.Tracker Namespace


SyncEmail Method

[image]

OfficeClip API Documentation
TrackerEmailDB..::.SyncEmail Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Syncs the email

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void SyncEmail()
Visual Basic (Declaration)
Public Sub SyncEmail
Visual C++
public:
void SyncEmail()

See Also

TrackerEmailDB Class
OfficeClip.DBLayer.Tracker Namespace


Update Method

[image]

OfficeClip API Documentation
TrackerEmailDB..::.Update Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Update the tracker emails

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void Update(
    int projectId,
    bool isEnable,
    TrackerEmailInfo tei,
    int userId
)
Visual Basic (Declaration)
Public Sub Update ( _
    projectId As Integer, _
    isEnable As Boolean, _
    tei As TrackerEmailInfo, _
    userId As Integer _
)
Visual C++
public:
void Update(
    int projectId,
    bool isEnable,
    TrackerEmailInfo^ tei,
    int userId
)

Parameters

projectId
Type: System..::.Int32
isEnable
Type: System..::.Boolean
tei
Type: OfficeClip.BusinessLayer.Tracker..::.TrackerEmailInfo
userId
Type: System..::.Int32

See Also

TrackerEmailDB Class
OfficeClip.DBLayer.Tracker Namespace


UpdTrackerEmailLastMessage Method

[image]

OfficeClip API Documentation
TrackerEmailDB..::.UpdTrackerEmailLastMessage Method
TrackerEmailDB Class See Also

[This is preliminary documentation and is subject to change.]

Updates the tracker email message

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
protected void UpdTrackerEmailLastMessage(
    int projectId,
    string messageId
)
Visual Basic (Declaration)
Protected Sub UpdTrackerEmailLastMessage ( _
    projectId As Integer, _
    messageId As String _
)
Visual C++
protected:
void UpdTrackerEmailLastMessage(
    int projectId,
    String^ messageId
)

Parameters

projectId
Type: System..::.Int32
messageId
Type: System..::.String

See Also

TrackerEmailDB Class
OfficeClip.DBLayer.Tracker Namespace


TrackerSyncDB Class

[image]

OfficeClip API Documentation
TrackerSyncDB Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class provides DBLayer methods for the tracker synchronization.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public class TrackerSyncDB : OfficeClipDB
Visual Basic (Declaration)
Public Class TrackerSyncDB _
    Inherits OfficeClipDB
Visual C++
public ref class TrackerSyncDB : public OfficeClipDB

Inheritance Hierarchy

System..::.Object
OfficeClip.DBLayer..::.OfficeClipDB
OfficeClip.DBLayer.Tracker..::.TrackerSyncDB

See Also

TrackerSyncDB Members
OfficeClip.DBLayer.Tracker Namespace


TrackerSyncDB Members

[image] [image]

OfficeClip API Documentation
TrackerSyncDB Members
TrackerSyncDB Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TrackerSyncDB type exposes the following members.

Constructors

 | Name | Description
Public method | TrackerSyncDB |

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | CreateNewProject | Overloaded.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertFixedFieldOptions | Inserts the fixed field options, by default all the fields are shown
Public method | InsertFixedFieldValues | Inserts the fixed field values
Public method | LoadProjectStructure | Loads the Project structure in the dataset and returns the XML representation of the Project strucure.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectionString | Gets the OfficeClip.DBLayer.ConnectionString property encapsulates a callout to the ASP+ Config System to obtain the database connection string for the application. (Inherited from OfficeClipDB.)
Protected property | DBConnString | The database connection string that is only available within the framework of the DBLayer. This should only be set through a constructor so this is not available outside the DBLayer. A default conection string is assumed if not set. (Inherited from OfficeClipDB.)

See Also

TrackerSyncDB Class
OfficeClip.DBLayer.Tracker Namespace


TrackerSyncDB Constructor

[image]

OfficeClip API Documentation
TrackerSyncDB Constructor
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public TrackerSyncDB()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TrackerSyncDB()

See Also

TrackerSyncDB Class
OfficeClip.DBLayer.Tracker Namespace


TrackerSyncDB Methods

[image] [image]

OfficeClip API Documentation
TrackerSyncDB Methods
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

The TrackerSyncDB type exposes the following methods.

Methods

 | Name | Description
Public method | AddOutputParameter | Overloaded.
Public method | AddParameter | Overloaded.
Protected method | AddParameters | Overloaded.
Public method | ClearParameters | Clear all the sql stored procedure parameters (Inherited from OfficeClipDB.)
Public method | Close | Close the connection, data adapter and the command (Inherited from OfficeClipDB.)
Public method | Commit | Commits the transaction (Inherited from OfficeClipDB.)
Public method | CreateNewProject | Overloaded.
Public method | Dispose | disposes the object for garbage collection (Inherited from OfficeClipDB.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteNonQuery | Overloaded.
Protected method | ExecuteReader | Executes the sql datareader (Inherited from OfficeClipDB.)
Protected method | ExecuteScalar | Executes the query that returns a single valur (Inherited from OfficeClipDB.)
Protected method | Fill | Fills the dataset (Inherited from OfficeClipDB.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetParameterCount | Gets the parameter count (Inherited from OfficeClipDB.)
Public method | GetParameterValue | Gets the value of the parameter (Inherited from OfficeClipDB.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Initialize the connection parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction | Overloaded.
Public method | InsertFixedFieldOptions | Inserts the fixed field options, by default all the fields are shown
Public method | InsertFixedFieldValues | Inserts the fixed field values
Public method | LoadProjectStructure | Loads the Project structure in the dataset and returns the XML representation of the Project strucure.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rollback | Rolls back the transaction (Inherited from OfficeClipDB.)
Public method | SetParameterValue | Sets the parameter value of the sql parameter to a known value (Inherited from OfficeClipDB.)
Protected method | SetSPCommand | Overloaded.
Protected method | SetSPDataAdapter | Sets the stored procedure data adapter (Inherited from OfficeClipDB.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrackerSyncDB Class
OfficeClip.DBLayer.Tracker Namespace


AddOutputParameter Method

[image] [image]

OfficeClip API Documentation
TrackerSyncDB..::.AddOutputParameter Method
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddOutputParameter(String, SqlDbType, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32) | Adds output parameter and returns the parameter (Inherited from OfficeClipDB.)
Public method | AddOutputParameter(String, SqlDbType, Int32, Int32, Int32) | Adds an output parameter (Inherited from OfficeClipDB.)
Protected method | AddOutputParameter(SqlCommand, String, SqlDbType, Int32, Int32, Int32) | Provides a way to add the output parameter to OfficeClip. (Inherited from OfficeClipDB.)

See Also

TrackerSyncDB Class
TrackerSyncDB Members
OfficeClip.DBLayer.Tracker Namespace


AddParameter Method

[image] [image]

OfficeClip API Documentation
TrackerSyncDB..::.AddParameter Method
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | AddParameter(String, Boolean) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, array<Byte>[]()[]) | Adds the stored procedure parameter (Inherited from OfficeClipDB.)
Public method | AddParameter(String, DateTime) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, SqlDbType, Int32) | Adds a parameter to the parameter list. The parameter value will be null (Inherited from OfficeClipDB.)
Public method | AddParameter(String, String, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)
Public method | AddParameter(String, Double, Int32, Int32, Int32) | Adds a parameter to the parameter list. (Inherited from OfficeClipDB.)

See Also

TrackerSyncDB Class
TrackerSyncDB Members
OfficeClip.DBLayer.Tracker Namespace


AddParameters Method

[image] [image]

OfficeClip API Documentation
TrackerSyncDB..::.AddParameters Method
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | AddParameters(SqlCommand, String, array<Byte>[]()[], SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, SqlDbType, Int32) | Adds a null parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Boolean, SqlDbType, Int32) | Adds a boolean parameter for the stored procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, DateTime, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Int32, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, String, SqlDbType, Int32) | Adds the parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)
Protected method | AddParameters(SqlCommand, String, Double, SqlDbType, Int32, Int32, Int32) | Adds a double parameter to the SqlCommand for the stored procedure. This done to make the parameter assignment simple for Stored Procedure. (Inherited from OfficeClipDB.)

See Also

TrackerSyncDB Class
TrackerSyncDB Members
OfficeClip.DBLayer.Tracker Namespace


CreateNewProject Method

[image] [image]

OfficeClip API Documentation
TrackerSyncDB..::.CreateNewProject Method
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | CreateNewProject(TrackerProjectInfo, Int32, Int32) | Creates a new empty project with minimum information
Public method | CreateNewProject(Int32, String, DataSet, Int32, Int32) | Creates a new Project from the XML file.

See Also

TrackerSyncDB Class
TrackerSyncDB Members
OfficeClip.DBLayer.Tracker Namespace


CreateNewProject Method (TrackerProjectInfo, Int32, Int32)

[image]

OfficeClip API Documentation
TrackerSyncDB..::.CreateNewProject Method (TrackerProjectInfo, Int32, Int32)
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates a new empty project with minimum information

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int CreateNewProject(
    TrackerProjectInfo tpi,
    int currentGroupId,
    int currentUserId
)
Visual Basic (Declaration)
Public Function CreateNewProject ( _
    tpi As TrackerProjectInfo, _
    currentGroupId As Integer, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int CreateNewProject(
    TrackerProjectInfo^ tpi,
    int currentGroupId,
    int currentUserId
)

Parameters

tpi
Type: OfficeClip.BusinessLayer.Tracker..::.TrackerProjectInfo
The tracker project information structure
currentGroupId
Type: System..::.Int32
Unique id of the current group
currentUserId
Type: System..::.Int32
Unique id of the current user

Return Value

Returns the project id if successful or -1 if failed

See Also

TrackerSyncDB Class
CreateNewProject Overload
OfficeClip.DBLayer.Tracker Namespace


CreateNewProject Method (Int32, String, DataSet, Int32, Int32)

[image]

OfficeClip API Documentation
TrackerSyncDB..::.CreateNewProject Method (Int32, String, DataSet, Int32, Int32)
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Creates a new Project from the XML file.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public int CreateNewProject(
    int selId,
    string projectName,
    DataSet ds,
    int currentGroupId,
    int currentUserId
)
Visual Basic (Declaration)
Public Function CreateNewProject ( _
    selId As Integer, _
    projectName As String, _
    ds As DataSet, _
    currentGroupId As Integer, _
    currentUserId As Integer _
) As Integer
Visual C++
public:
int CreateNewProject(
    int selId,
    String^ projectName,
    DataSet^ ds,
    int currentGroupId,
    int currentUserId
)

Parameters

selId
Type: System..::.Int32
The selected Project type.
projectName
Type: System..::.String
The Project name of the created Project.
ds
Type: System.Data..::.DataSet
The input dataset that needs to be populated.
currentGroupId
Type: System..::.Int32
Id of the current group
currentUserId
Type: System..::.Int32
Id of the current user

Return Value

The unique Project id if successful and -1 if failed, -2 a Project with same name already exists

See Also

TrackerSyncDB Class
CreateNewProject Overload
OfficeClip.DBLayer.Tracker Namespace


ExecuteNonQuery Method

[image] [image]

OfficeClip API Documentation
TrackerSyncDB..::.ExecuteNonQuery Method
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | ExecuteNonQuery()()() | Executes the query (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(Boolean) | (Inherited from OfficeClipDB.)
Protected method | ExecuteNonQuery(IsolationLevel) | Executes the query with isolation levels (Inherited from OfficeClipDB.)

See Also

TrackerSyncDB Class
TrackerSyncDB Members
OfficeClip.DBLayer.Tracker Namespace


InitTransaction Method

[image] [image]

OfficeClip API Documentation
TrackerSyncDB..::.InitTransaction Method
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | InitTransaction()()() | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)
Public method | InitTransaction(IsolationLevel) | Initialize the connection string and the transaction parameters (Inherited from OfficeClipDB.)

See Also

TrackerSyncDB Class
TrackerSyncDB Members
OfficeClip.DBLayer.Tracker Namespace


InsertFixedFieldOptions Method

[image]

OfficeClip API Documentation
TrackerSyncDB..::.InsertFixedFieldOptions Method
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the fixed field options, by default all the fields are shown

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertFixedFieldOptions(
    int projectId
)
Visual Basic (Declaration)
Public Sub InsertFixedFieldOptions ( _
    projectId As Integer _
)
Visual C++
public:
void InsertFixedFieldOptions(
    int projectId
)

Parameters

projectId
Type: System..::.Int32
The unique id of the Project

See Also

TrackerSyncDB Class
OfficeClip.DBLayer.Tracker Namespace


InsertFixedFieldValues Method

[image]

OfficeClip API Documentation
TrackerSyncDB..::.InsertFixedFieldValues Method
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Inserts the fixed field values

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public void InsertFixedFieldValues(
    int projectId,
    string caseName,
    string status,
    string criticality,
    string category,
    string kind,
    string createdBy,
    string modifiedBy,
    string createdDate,
    string modifiedDate,
    string assigned,
    string title,
    string description,
    string resolution,
    string comments
)
Visual Basic (Declaration)
Public Sub InsertFixedFieldValues ( _
    projectId As Integer, _
    caseName As String, _
    status As String, _
    criticality As String, _
    category As String, _
    kind As String, _
    createdBy As String, _
    modifiedBy As String, _
    createdDate As String, _
    modifiedDate As String, _
    assigned As String, _
    title As String, _
    description As String, _
    resolution As String, _
    comments As String _
)
Visual C++
public:
void InsertFixedFieldValues(
    int projectId,
    String^ caseName,
    String^ status,
    String^ criticality,
    String^ category,
    String^ kind,
    String^ createdBy,
    String^ modifiedBy,
    String^ createdDate,
    String^ modifiedDate,
    String^ assigned,
    String^ title,
    String^ description,
    String^ resolution,
    String^ comments
)

Parameters

projectId
Type: System..::.Int32
caseName
Type: System..::.String
status
Type: System..::.String
criticality
Type: System..::.String
category
Type: System..::.String
kind
Type: System..::.String
createdBy
Type: System..::.String
modifiedBy
Type: System..::.String
createdDate
Type: System..::.String
modifiedDate
Type: System..::.String
assigned
Type: System..::.String
title
Type: System..::.String
description
Type: System..::.String
resolution
Type: System..::.String
comments
Type: System..::.String

See Also

TrackerSyncDB Class
OfficeClip.DBLayer.Tracker Namespace


LoadProjectStructure Method

[image]

OfficeClip API Documentation
TrackerSyncDB..::.LoadProjectStructure Method
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Loads the Project structure in the dataset and returns the XML representation of the Project strucure.

Namespace: OfficeClip.DBLayer.Tracker
Assembly: OfficeClip.DBLayer (in OfficeClip.DBLayer)
Version: 8.1.1.0

Syntax

C#
public string LoadProjectStructure(
    DataSet ds,
    int projectId
)
Visual Basic (Declaration)
Public Function LoadProjectStructure ( _
    ds As DataSet, _
    projectId As Integer _
) As String
Visual C++
public:
String^ LoadProjectStructure(
    DataSet^ ds,
    int projectId
)

Parameters

ds
Type: System.Data..::.DataSet
The dataset where the Project schema is loaded
projectId
Type: System..::.Int32
The unique id of the Project

Return Value

The XML representation of the Project structure

See Also

TrackerSyncDB Class
OfficeClip.DBLayer.Tracker Namespace


SetSPCommand Method

[image] [image]

OfficeClip API Documentation
TrackerSyncDB..::.SetSPCommand Method
TrackerSyncDB Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | SetSPCommand(String) | Sets the stored procedure command (Inherited from OfficeClipDB.)
Protected method | SetSPCommand(String, Int32) | Sets the stored procedure command (Inherited from OfficeClipDB.)

See Also

TrackerSyncDB Class
TrackerSyncDB Members
OfficeClip.DBLayer.Tracker Namespace


OfficeClip.Utils Namespace

[image]

OfficeClip API Documentation
OfficeClip.Utils Namespace

[This is preliminary documentation and is subject to change.]

OfficeClip Utilities library

Classes

 | Class | Description
Public class | AlphabetConstants | Maps the real alphabets with the AlphabetFilter enumerated type
Public class | AppSettings | Retrives the appsettings from the configuration file. This file provides a wrapper over the web.config file.
Public class | ConfigureInfo | Stores the configuration information. This information is fetched from the database when the user logs into the system.
Public class | Constants | Stores all constants used throughout the OfficeClip application
Public class | DateTimeConst | This class provides functions to return meaningful names for various components of date according to the current locale.
Public class | OCConvert | Provides some common data conversion functions used throughout OfficeClip
Public class | OCCsvData | This class provides functions which aid in exchanging comma separated format data with OfficeClip.
Public class | OCDateTime | This class provides methods to manipulate the date and time variables in OfficeClip.
Public class | OCDebug | This class provides functions which aid in exchanging comma separated format data with OfficeClip.
Public class | OCException | This class is a wrapper over the existing Exception class. It provides a meaningful way to send user defined messages and Priority along with the exception.
Public class | OCFile | Class that supports file manipulation in OfficeCLip.
Public class | OCHighlighter | Provides methods to aid highlighting information in OfficeClip
Public class | OCHtmlControls | Provides dynamic html controls
Public class | OCHtmlProperties | Provides a wrapper for changing properties of the html elements on the screen.
Public class | OCImage | Provides methods for the manipulation of images in OfficeClip.
Public class | OCLogger | This class provides functionality to log events in the event log feature of windows 2000 operating system.
Public class | OCProfileData | This class is used to convert dataformat to and from the profile
Public class | OCResources | Provides a wrapper for resources and resource manager. Resource Managers are used for various purposes, e.g. converting data from different locale.
Public class | OCSecurity | This class will provide all the methods required to ensure that OfficeClip can be accessed in a secured fashion.
Public class | OCSerialize | Provides serilization for classes only contaning primitive types of type Int32, DateTime, String, Double. This uses a more storage efficient collection mechanism and does not support any other data types.
Public class | OCSms | Provides functions to Send SMS using Thirdparty API.
Public class | OCString | Provides methods for additional string manipulation in OfficeClip programs.
Public class | OCUri | Provides methods for the manipulation of the uri.
Public class | OCUserControl | Class for manipulation of user controls
Public class | PopulateDateItems | Populates the date components in a dropdown box. Examples of dropdown boxes are Month Dropdown, Week drop down etc.
Public class | Provider | Helper class for the personalization provider
Public class | RegionalSettings | The regional settings object
Public class | Service | Class to support the OfficeClip service layer interface
Public class | SessionSettings | Provides methods to access OfficeClip session information.
Public class | TimeZoneInfo | The Time Zone structure.
Public class | UpDownLoad | Provides methods for Upload and Download of files in OfficeClip.
Public class | XmlValidation | Validates the Xml document against a schema

Enumerations

 | Enumeration | Description
Public enumeration | AccessFunction | Creates the enumeration of Access permissions for all the functions in the system.This file will need to be modified when a new function is introduced in the system.
Public enumeration | AccessPerm | Defines the access matrix for the user, this matrix decides, which function the user has access to in OfficeClip. Each access element can have one of the four values 0 = No Access 1 = Full Access 2 = Read Access only 3 = Read and update Access only (no insert or delete)
Public enumeration | AlphabetFilter | Enumerated type for the alphabetic filter in the User Manager
Public enumeration | ApplicationReminderUpdateType | Enumerated type for updating the reminder when the event gets updated
Public enumeration | CalendarView | Enumerated type for providing different calendar view to the calendar application
Public enumeration | DeleteGroupAppType | Enumerated type for deleting various group applications in OfficeClip
Public enumeration | DocHistoryStatus | The status enumerated type of document in the document history.
Public enumeration | DocNodeType | Provides enumerated types for the document nodes.
Public enumeration | DocSelectControl | Provides enumerated types for the document selection control.
Public enumeration | DocTreeLeafSortType | Shows how the document tree leaves are sorted
Public enumeration | DocTreeType | The Document tree type can be private or public
Public enumeration | DocumentStorageType | Provides enumerated type for the Document storage types.
Public enumeration | EmailAttachmentStatus | Enumerated type for email attachment status.
Public enumeration | EmailFolders | Provides enumerated types for the various types of email folders.
Public enumeration | EmailPriority | Enumerated types for email Priority.
Public enumeration | EmailSearchBySize | Enumerated types of email search by its size logical operator.
Public enumeration | EmailSearchByTime | Enumerated type for email search by time.
Public enumeration | EmailSearchIn | Enumerated type of email search field
Public enumeration | EmailStatus | The enumerated type for email status.
Public enumeration | EmailTimestamps | Enumerated types for the email timestamps
Public enumeration | EventShowAs | Various user status in response to an event
Public enumeration | EventType | Enumerated type for various kinds of calendar events
Public enumeration | ExceptionType | Enumerated type for all the OfficeClip Exception types
Public enumeration | GroupSelection | Enumerated type for the group selection in various applications including the calendar and the bulletin board
Public enumeration | GroupType | Enumearted types for various types of groups in the User MAnager
Public enumeration | LastVisited | Provides enumerated types for the last visited application. The last visited application is enterd into the profile as OFF=6/2/2001 8:1:00;CAL=;RMD=;BBD=;BMK=;RSV=;TMS=;TRK=;.
Public enumeration | LoginAuthenticationMode | The login authentication type that is used to login to OfficeClip
Public enumeration | OCServiceImportPolicy | The import policy used when importing an xml to OfficeClip. These import policies are used when the OfficeClip service id is present and it matches the OfficeClip current installation and other parameters.
Public enumeration | OCServiceReturnStatus | Provides the return status of all the Service Calls
Public enumeration | OCServiceType | Types of various objects that are converted to Xml. Especially used for creating the service id of each object.
Public enumeration | OCSortDirection | Provides enumerated types for the direction of sort.
Public enumeration | Periodicity | Determins the enumerated type to define various periods in OfficeClip.
Public enumeration | PurchaseMethod | Provides the purchase method, this can either be credit card or purchase order.
Public enumeration | ReportExportFormat | The export format for reports
Public enumeration | ReturnStatus | The generic return status in OfficeClip. Can either be Failure or Success.
Public enumeration | SortByName | Enumerated type for sorting by name in various OfficeClip applications, especially in the User Manager
Public enumeration | TESortType | Provides enumerated types for the sort type of Time and Expense Reporting application.
Public enumeration | TimeAndExpenseAlias | Provides enumerated types for customers, projects and tasks for time and expense reporting.
Public enumeration | TraceDebugSwitch | The switch for the tracing and debugging in OfficeClip code
Public enumeration | TrackerFieldsNameId | Enumerated types for the tracker field names. In tracker, the field names can be chaged via the administrator utility
Public enumeration | TrackerFilterChoiceId | The enumerated type for the tracker filter choices
Public enumeration | UpDownLoad..::.UploadStatus | Returns the upload status of the file uploaded.
Public enumeration | UserType | The type of the OfficeClip user
Public enumeration | WorkflowAction | Provides enumerated types for the workflow actions.
Public enumeration | WorkflowType | Provides enumerated types of the workflow types.


AccessFunction Enumeration

[image]

OfficeClip API Documentation
AccessFunction Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Creates the enumeration of Access permissions for all the functions in the system.This file will need to be modified when a new function is introduced in the system.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum AccessFunction
Visual Basic (Declaration)
Public Enumeration AccessFunction
Visual C++
public enum class AccessFunction

Members

Member name | Description
DocumentsUpload | The access permission of the document uploaded. User needs this access permission to be able to upload document into OfficeClip.
DocumentsAddFolder | The access permission for adding a folder in the document management. system.
CreateEditTasks | Permission for creating and editing new tasks.
DocumentsCopy | The access permission for moving and copying documents in OfficeClip.
DocumentsShare | The access permission for the ability to share documents in OfficeClip. Sharing a document will enable OfficeClip users to allow non-OfficeClip users to view the document.
DocumentsRename | The access permission for renaming the documents in OfficeClip.
DocumentsDelete | The access permission for deleting documents in OfficeClip.
TrackerDelete | No operation kept for backward compatability reasons.
BulletinBoardCreateNewForum | Access Permission for creating New forum in the bulletin board.
BulletinBoardCreateNewTopic | Access permission for creating new topics in the bulletin board.
BulletinBoardPostReply | Access permission for posting a new reply in the bulletin board.
CalendarCreateNewGroupEvent | Access permission for creating a new group event.
CalendarSyncEvent | Access permission for synchronizing events with the OfficeClip calendar.
AlertsCreateNew | Access permission for creating new events in the calendar
OfficeAgentSyncGroupList | Access permission for synchronizing group list in the User Manager application.
TrackerEditCase | No operation, kept for backward compatability reasons.
OfficeAgentCreateNewGroup | Access permission for creating a new group in the tracker.
TrackerCreateNewCase | Access permission for creating a new case in the tracker.
TrackerSync | Access permission for synchronizing tracker cases with the outside world.
AnnouncementsCreateNew | Access permission for creating new announcements.
TimeExpensesAccessTimeSheet | Access permission for accessing timesheet from Time and Expense reporting module.
PollsCreateNew | Access permission for creating a new poll
TimeExpensesAccessExpenseReport | Access permission for accessing expense reports from the Time and Expense reporting module
ShowPermissionLinks | No operation, kept for backward compatability reasons.
AssignContacts | No operation, kept for backward compatability reasons.
AssignTasks | No operation, kept for backward compatability reasons.
ShowCalendarPlanner | No operation, kept for backward compatability reasons.
ContactManageCampaigns | Manage Contact Campaigns.
ContactViewReport | Contact View Reports.
HomePageAddMembers | Access Permission for Adding members in the home page.
HomePageCreateNewBookmarks | Access permission for creating new bookmarks in the home page.
NoOperation | No operation, Use this as a placeholder.
CreateContact | Access Permission for Creating a Contact.
EditContact | Access Permission for Editing a Contact.
AssignAccount | No operation, kept for backward compatability reasons.
AccountViewReport | Account View Reports
CreateAccount | Access Permission for Creating an Account.
EditAccount | Access Permission for Editing an Account.
AssignOpportunity | No operation, kept for backward compatability reasons.
CreateOpportunity | Access Permission for Creating an Opportunity.
EditOpportunity | Access Permission for Editing an Opportunity.
OpportunityReport | The opportunity report
ExtranetItemEdit | Extranet Item Edit
ExtranetUserEdit | Extranet User Edit
ProjectsCreateEdit | Edit or create a new project
ProjectsViewDetail | Allows users to view the detail of the project
AccountsViewDetail | Allows users to view the detail of the account or project
AccessFunctionSize | The size of the accessfunction, this parameters needs to be changed when a new fucntion is added

See Also

OfficeClip.Utils Namespace


AccessPerm Enumeration

[image]

OfficeClip API Documentation
AccessPerm Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Defines the access matrix for the user, this matrix decides, which function the user has access to in OfficeClip. Each access element can have one of the four values 0 = No Access 1 = Full Access 2 = Read Access only 3 = Read and update Access only (no insert or delete)

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum AccessPerm
Visual Basic (Declaration)
Public Enumeration AccessPerm
Visual C++
public enum class AccessPerm

Members

Member name | Description
None | No Access.
Full | Full Access.
ReadOnly | Read Only Access.
ReadAndUpdate | Read and update Access only (no insert or delete).

See Also

OfficeClip.Utils Namespace


AlphabetConstants Class

[image]

OfficeClip API Documentation
AlphabetConstants Class
Members See Also

[This is preliminary documentation and is subject to change.]

Maps the real alphabets with the AlphabetFilter enumerated type

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class AlphabetConstants
Visual Basic (Declaration)
Public Class AlphabetConstants
Visual C++
public ref class AlphabetConstants

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.AlphabetConstants

See Also

AlphabetConstants Members
OfficeClip.Utils Namespace


AlphabetConstants Members

[image] [image]

OfficeClip API Documentation
AlphabetConstants Members
AlphabetConstants Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The AlphabetConstants type exposes the following members.

Constructors

 | Name | Description
Public method | AlphabetConstants |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToAlphabetFilter | Returns the AlphabetFilter enumerated type given the alphabet
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlphabetConstants Class
OfficeClip.Utils Namespace


AlphabetConstants Constructor

[image]

OfficeClip API Documentation
AlphabetConstants Constructor
AlphabetConstants Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public AlphabetConstants()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AlphabetConstants()

See Also

AlphabetConstants Class
OfficeClip.Utils Namespace


AlphabetConstants Methods

[image] [image]

OfficeClip API Documentation
AlphabetConstants Methods
AlphabetConstants Class See Also

[This is preliminary documentation and is subject to change.]

The AlphabetConstants type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToAlphabetFilter | Returns the AlphabetFilter enumerated type given the alphabet
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AlphabetConstants Class
OfficeClip.Utils Namespace


ToAlphabetFilter Method

[image]

OfficeClip API Documentation
AlphabetConstants..::.ToAlphabetFilter Method
AlphabetConstants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the AlphabetFilter enumerated type given the alphabet

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static AlphabetFilter ToAlphabetFilter(
    string s
)
Visual Basic (Declaration)
Public Shared Function ToAlphabetFilter ( _
    s As String _
) As AlphabetFilter
Visual C++
public:
static AlphabetFilter ToAlphabetFilter(
    String^ s
)

Parameters

s
Type: System..::.String
The alphabet in string

Return Value

The AlphabeticFilter enumerated type

See Also

AlphabetConstants Class
OfficeClip.Utils Namespace


AlphabetFilter Enumeration

[image]

OfficeClip API Documentation
AlphabetFilter Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for the alphabetic filter in the User Manager

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum AlphabetFilter
Visual Basic (Declaration)
Public Enumeration AlphabetFilter
Visual C++
public enum class AlphabetFilter

Members

Member name | Description
All | Selection of the All Link.
A | Selection of 'A' link.
B | Selection of 'B' link.
C | Selection of 'C' link.
D | Selection of 'D' link.
E | Selection of 'E' link.
F | Selection of 'F' link.
G | Selection of 'G' link.
H | Selection of 'H' link.
I | Selection of 'I' link.
J | Selection of 'J' link.
K | Selection of 'K' link.
L | Selection of 'L' link.
M | Selection of 'M' link.
N | Selection of 'N' link.
O | Selection of 'O' link.
P | Selection of 'P' link.
Q | Selection of 'Q' link.
R | Selection of 'R' link.
S | Selection of 'S' link.
T | Selection of 'T' link.
U | Selection of 'U' link.
V | Selection of 'V' link.
W | Selection of 'W' link.
X | Selection of 'X' link.
Y | Selection of 'Y' link.
Z | Selection of 'Z' link.

See Also

OfficeClip.Utils Namespace


ApplicationReminderUpdateType Enumeration

[image]

OfficeClip API Documentation
ApplicationReminderUpdateType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for updating the reminder when the event gets updated

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum ApplicationReminderUpdateType
Visual Basic (Declaration)
Public Enumeration ApplicationReminderUpdateType
Visual C++
public enum class ApplicationReminderUpdateType

Members

Member name | Description
ExactlySame | The reminder type remains same when the event gets updated
OldOneWasRemindEveryBodyNewOneRemindMe | The old reminder was to remind everybody but the new reminder is set to remind me
OldOneWasRemindMeNewOneRemindEveryBody | The old reminder was to Remind me but the new reminder is for reminding everybody

See Also

OfficeClip.Utils Namespace


AppSettings Class

[image]

OfficeClip API Documentation
AppSettings Class
Members See Also

[This is preliminary documentation and is subject to change.]

Retrives the appsettings from the configuration file. This file provides a wrapper over the web.config file.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class AppSettings
Visual Basic (Declaration)
Public Class AppSettings
Visual C++
public ref class AppSettings

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.AppSettings

See Also

AppSettings Members
OfficeClip.Utils Namespace


AppSettings Members

[image] [image]

OfficeClip API Documentation
AppSettings Members
AppSettings Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The AppSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AppSettings |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConnectionString | Provides the database connection string to the application.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UploadFolderLocation | Provides the upload folder location to normal files and demo files

Properties

Name Description
AccountingAvailable
Enables or Disables the Billing/Accounting for the users in the system. Do no modify this entry directly by editing this value if it is originally off. By default it is Off. If you wish to switch it on, use the Enable Accounting in OEM
AdminEmailAddress
Provides the email address for the site administrator
AlertDeleteDays
The number of days after which the alert is supposed to be automatically deleted
AllowBulkUpload
Determines if the bulk uploading is allowed
AuditLogging
Logs the login attempts in the windows NT/2000/XP event log, possible values are: OffAudit logging is offLevel1Only failed login attempts are loggedLevel2Failed and successful login attempts are loggedOnSame as level2
BoxVersion
Returns whether this is a beb based version or box version, there may be various things which will be included in the box version.
BusyIconActivate
Status to show if the busy icon is to be shown
CheckDemoGuard
Checks if the current account is the demo account, if it is a demo account, the return value is an error, if not, the return value is an empty string.
CheckForOldFormatPassword
Activates or deactivates the OCReminder Service
ConnectionString
Provides the database connection string to the application.
CrystalReportsAvailable
Returns if the crystal reports is available as a part of the package.
CustomXml
This is where the custom pages are stored. It is advised that all custom files should be stored in the custom folder (and project) in a similar directory structure as that of officeclip. The value here is relative to the officeclip virtual directory folder.
DateStringFormat
Specify the date format used everywhere.
DiskSpaceQuota
If the disk space quota is enabled, this key determines how much amout of disk space (in MB) to be allocated for each account.
DocAccountDiskSpace
Returns the additional account disk space (MB) increment in document management
EmailServerName
The email server name that is used to send emails through OfficeClip. If this value is set to empty string in the web.config, no email will be sent
EmailServerName1
The Secondary Email Server Name, If the primary email server fails and this value in web.config is not empty, then OfficeClip will attempt to send emails through this server.
EmailServerName2
The Tertiary Email Server Name, If the primary and secondary email server fails and this value in web.config is not empty, then OfficeClip will attempt to send emails through this server.
HostStr
String for the host name where OfficeClip is installed
HostUrl
url representation of the HostStr
IsLdapAuthentication
Indicates whether all the necessary parameters for the LDAP authentication are available or not.
IsLoginPopup
Determines if the user is logged in on a popup window (no buttons, address bar etc.)
LdapAuthenticationString
The name of the LDAP Server with which OfficeClip is integrated. If there is value specified for this key, then the value for the next key i.e. LDAPAdminAccount must be specified for the whole integration to work properly.
LicenseServerLocation
The location of the license server
LoginAuthenticationMode
Gets the login authentication mode. This mainly depends on the web.config and the IIS settings
LoginPopupParameters
returns the popup parameter for the login screen (if the login popup is true)
MailFormat
The email format, it could be text or html. This is used to provide hints to the mail system if the OfficeClip send out html based emails.
MessageLogging
Logs the messages in the windows 2000 event log, possible values are
  • OffLogging is off
  • Level1Only errors and exceptions are logged
  • Level2errors, exceptions and warnings are logged
  • Level3errors, exceptions, warnings and information are logged
  • OnSame as level 3
OcDotComOnly
Use this for anything which is very very specific to OfficeClip.com only There are couple of instances which have to be specific to OfficeClip.com but should not be given to Non-BOXVERSIONS (e.g. people who will use OfficeClip as an Application Service Provider).
OcEmailAddress
Provides the email address for the OfficeClip administrator, this can also be the partner's email address for OfficeClip partners
OfficeClipWebSite
The OfficeClip website
PasswordStrength
Enter the password strength for creating the new password. The value is separated by semicolon. The first element is the minimum number of characters in the password, the second expression is the minimum number of non-alphanumeric characters in the password and the last element is the regular expression for the password. Note that you cannot put ; as a part of the regular expression. An empty value denotes that no password strength is enforced. All values are not required but the values should be put in the order specified. i.e. you cannot put the third value without putting the first and second value.
RegisteredCompany
Registered Company where the product is installed. This name shows up in the title bar.
RegistrationDetailsRequired
Tells if the registration detail is required. No registration detail information is asked if this is false.
ReminderActivated
Activates or deactivates the OCReminder Service
ReminderCallbackTimeSpan
Controls te timespan for the reminder callback
ServerTimeZoneId
The timezone id of the server is the index to the timezone table in the OfficeClip database. This value in the web.config file should not be changed by the user manually.
ServerUrl
Returns the complete server url to get to this OfficeClip web site
ShowQuickHelp
Status to show if the quickhelp is to be shown
ShowTracktime
Determines if the time tracking is on in various screens
ShowVersionOnTitle
Returns whether to show the product version on the title bar
SpellCheckerAvailable
Flag indicating whether spell checker is available or not.
SuccessNotification
If set to on, the success notifcication screen is shown after every successful inserts and updates
SupportEmailAddress
Provides the email address for the support personnel
TimeStringFormat
Specifying the time format used everywhere
TutorialLocation
Location of the OfficeClip tutorials
UniqueId
The unique id used as a key to extranet forms. When the extranet foms are submitted, this will be checked for a match. If the key is compromised, the key will have to change and all the forms will need to be changed.
UploadFolderPath
The Upload folder path
VDirPath
The Virtual Directory Path from where officeclip is accessed
WebContentMenuStatus
Indictes if the Web Content menus are enabled. Web Content menu is enabled only when the file Upload/corp/{groupid}/corpmenu.xml file is present in the document folder, values are:
  • OffNo Web Content menu is shown, irrespective of the presence of corpmenu.xml file
  • AlwaysWeb Content menu is always shown if corpmenu.xml is present
  • OnRequestWeb Content menu is shown if the page request it and corpmenu.xml is present. By default officeclip will have this enabled for the homepage

See Also

AppSettings Class
OfficeClip.Utils Namespace


AppSettings Constructor

[image]

OfficeClip API Documentation
AppSettings Constructor
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public AppSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AppSettings()

See Also

AppSettings Class
OfficeClip.Utils Namespace


AppSettings Methods

[image] [image]

OfficeClip API Documentation
AppSettings Methods
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The AppSettings type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConnectionString | Provides the database connection string to the application.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UploadFolderLocation | Provides the upload folder location to normal files and demo files

See Also

AppSettings Class
OfficeClip.Utils Namespace


GetConnectionString Method

[image]

OfficeClip API Documentation
AppSettings..::.GetConnectionString Method
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Provides the database connection string to the application.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetConnectionString(
    bool isDemo
)
Visual Basic (Declaration)
Public Shared Function GetConnectionString ( _
    isDemo As Boolean _
) As String
Visual C++
public:
static String^ GetConnectionString(
    bool isDemo
)

Parameters

isDemo
Type: System..::.Boolean

Return Value

See Also

AppSettings Class
OfficeClip.Utils Namespace


UploadFolderLocation Method

[image]

OfficeClip API Documentation
AppSettings..::.UploadFolderLocation Method
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Provides the upload folder location to normal files and demo files

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string UploadFolderLocation(
    bool isIncludeDemo
)
Visual Basic (Declaration)
Public Shared Function UploadFolderLocation ( _
    isIncludeDemo As Boolean _
) As String
Visual C++
public:
static String^ UploadFolderLocation(
    bool isIncludeDemo
)

Parameters

isIncludeDemo
Type: System..::.Boolean
If false, will always consider the top level location and will not test for demo

Return Value

The location

See Also

AppSettings Class
OfficeClip.Utils Namespace


AppSettings Properties

[image] [image]

OfficeClip API Documentation
AppSettings Properties
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The AppSettings type exposes the following properties.

Properties

Name Description
AccountingAvailable
Enables or Disables the Billing/Accounting for the users in the system. Do no modify this entry directly by editing this value if it is originally off. By default it is Off. If you wish to switch it on, use the Enable Accounting in OEM
AdminEmailAddress
Provides the email address for the site administrator
AlertDeleteDays
The number of days after which the alert is supposed to be automatically deleted
AllowBulkUpload
Determines if the bulk uploading is allowed
AuditLogging
Logs the login attempts in the windows NT/2000/XP event log, possible values are: OffAudit logging is offLevel1Only failed login attempts are loggedLevel2Failed and successful login attempts are loggedOnSame as level2
BoxVersion
Returns whether this is a beb based version or box version, there may be various things which will be included in the box version.
BusyIconActivate
Status to show if the busy icon is to be shown
CheckDemoGuard
Checks if the current account is the demo account, if it is a demo account, the return value is an error, if not, the return value is an empty string.
CheckForOldFormatPassword
Activates or deactivates the OCReminder Service
ConnectionString
Provides the database connection string to the application.
CrystalReportsAvailable
Returns if the crystal reports is available as a part of the package.
CustomXml
This is where the custom pages are stored. It is advised that all custom files should be stored in the custom folder (and project) in a similar directory structure as that of officeclip. The value here is relative to the officeclip virtual directory folder.
DateStringFormat
Specify the date format used everywhere.
DiskSpaceQuota
If the disk space quota is enabled, this key determines how much amout of disk space (in MB) to be allocated for each account.
DocAccountDiskSpace
Returns the additional account disk space (MB) increment in document management
EmailServerName
The email server name that is used to send emails through OfficeClip. If this value is set to empty string in the web.config, no email will be sent
EmailServerName1
The Secondary Email Server Name, If the primary email server fails and this value in web.config is not empty, then OfficeClip will attempt to send emails through this server.
EmailServerName2
The Tertiary Email Server Name, If the primary and secondary email server fails and this value in web.config is not empty, then OfficeClip will attempt to send emails through this server.
HostStr
String for the host name where OfficeClip is installed
HostUrl
url representation of the HostStr
IsLdapAuthentication
Indicates whether all the necessary parameters for the LDAP authentication are available or not.
IsLoginPopup
Determines if the user is logged in on a popup window (no buttons, address bar etc.)
LdapAuthenticationString
The name of the LDAP Server with which OfficeClip is integrated. If there is value specified for this key, then the value for the next key i.e. LDAPAdminAccount must be specified for the whole integration to work properly.
LicenseServerLocation
The location of the license server
LoginAuthenticationMode
Gets the login authentication mode. This mainly depends on the web.config and the IIS settings
LoginPopupParameters
returns the popup parameter for the login screen (if the login popup is true)
MailFormat
The email format, it could be text or html. This is used to provide hints to the mail system if the OfficeClip send out html based emails.
MessageLogging
Logs the messages in the windows 2000 event log, possible values are
  • OffLogging is off
  • Level1Only errors and exceptions are logged
  • Level2errors, exceptions and warnings are logged
  • Level3errors, exceptions, warnings and information are logged
  • OnSame as level 3
OcDotComOnly
Use this for anything which is very very specific to OfficeClip.com only There are couple of instances which have to be specific to OfficeClip.com but should not be given to Non-BOXVERSIONS (e.g. people who will use OfficeClip as an Application Service Provider).
OcEmailAddress
Provides the email address for the OfficeClip administrator, this can also be the partner's email address for OfficeClip partners
OfficeClipWebSite
The OfficeClip website
PasswordStrength
Enter the password strength for creating the new password. The value is separated by semicolon. The first element is the minimum number of characters in the password, the second expression is the minimum number of non-alphanumeric characters in the password and the last element is the regular expression for the password. Note that you cannot put ; as a part of the regular expression. An empty value denotes that no password strength is enforced. All values are not required but the values should be put in the order specified. i.e. you cannot put the third value without putting the first and second value.
RegisteredCompany
Registered Company where the product is installed. This name shows up in the title bar.
RegistrationDetailsRequired
Tells if the registration detail is required. No registration detail information is asked if this is false.
ReminderActivated
Activates or deactivates the OCReminder Service
ReminderCallbackTimeSpan
Controls te timespan for the reminder callback
ServerTimeZoneId
The timezone id of the server is the index to the timezone table in the OfficeClip database. This value in the web.config file should not be changed by the user manually.
ServerUrl
Returns the complete server url to get to this OfficeClip web site
ShowQuickHelp
Status to show if the quickhelp is to be shown
ShowTracktime
Determines if the time tracking is on in various screens
ShowVersionOnTitle
Returns whether to show the product version on the title bar
SpellCheckerAvailable
Flag indicating whether spell checker is available or not.
SuccessNotification
If set to on, the success notifcication screen is shown after every successful inserts and updates
SupportEmailAddress
Provides the email address for the support personnel
TimeStringFormat
Specifying the time format used everywhere
TutorialLocation
Location of the OfficeClip tutorials
UniqueId
The unique id used as a key to extranet forms. When the extranet foms are submitted, this will be checked for a match. If the key is compromised, the key will have to change and all the forms will need to be changed.
UploadFolderPath
The Upload folder path
VDirPath
The Virtual Directory Path from where officeclip is accessed
WebContentMenuStatus
Indictes if the Web Content menus are enabled. Web Content menu is enabled only when the file Upload/corp/{groupid}/corpmenu.xml file is present in the document folder, values are:
  • OffNo Web Content menu is shown, irrespective of the presence of corpmenu.xml file
  • AlwaysWeb Content menu is always shown if corpmenu.xml is present
  • OnRequestWeb Content menu is shown if the page request it and corpmenu.xml is present. By default officeclip will have this enabled for the homepage

See Also

AppSettings Class
OfficeClip.Utils Namespace


AccountingAvailable Property

[image]

OfficeClip API Documentation
AppSettings..::.AccountingAvailable Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Enables or Disables the Billing/Accounting for the users in the system. Do no modify this entry directly by editing this value if it is originally off. By default it is Off. If you wish to switch it on, use the Enable Accounting in OEM

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool AccountingAvailable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AccountingAvailable As Boolean
Visual C++
public:
static property bool AccountingAvailable {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


AdminEmailAddress Property

[image]

OfficeClip API Documentation
AppSettings..::.AdminEmailAddress Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Provides the email address for the site administrator

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string AdminEmailAddress { get; set; }
Visual Basic (Declaration)
Public Shared Property AdminEmailAddress As String
Visual C++
public:
static property String^ AdminEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


AlertDeleteDays Property

[image]

OfficeClip API Documentation
AppSettings..::.AlertDeleteDays Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The number of days after which the alert is supposed to be automatically deleted

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int AlertDeleteDays { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AlertDeleteDays As Integer
Visual C++
public:
static property int AlertDeleteDays {
    int get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


AllowBulkUpload Property

[image]

OfficeClip API Documentation
AppSettings..::.AllowBulkUpload Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the bulk uploading is allowed

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool AllowBulkUpload { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AllowBulkUpload As Boolean
Visual C++
public:
static property bool AllowBulkUpload {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


AuditLogging Property

[image]

OfficeClip API Documentation
AppSettings..::.AuditLogging Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Logs the login attempts in the windows NT/2000/XP event log, possible values are: OffAudit logging is offLevel1Only failed login attempts are loggedLevel2Failed and successful login attempts are loggedOnSame as level2

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string AuditLogging { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AuditLogging As String
Visual C++
public:
static property String^ AuditLogging {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


BoxVersion Property

[image]

OfficeClip API Documentation
AppSettings..::.BoxVersion Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Returns whether this is a beb based version or box version, there may be various things which will be included in the box version.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool BoxVersion { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BoxVersion As Boolean
Visual C++
public:
static property bool BoxVersion {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


BusyIconActivate Property

[image]

OfficeClip API Documentation
AppSettings..::.BusyIconActivate Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Status to show if the busy icon is to be shown

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool BusyIconActivate { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property BusyIconActivate As Boolean
Visual C++
public:
static property bool BusyIconActivate {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


CheckDemoGuard Property

[image]

OfficeClip API Documentation
AppSettings..::.CheckDemoGuard Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Checks if the current account is the demo account, if it is a demo account, the return value is an error, if not, the return value is an empty string.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string CheckDemoGuard { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CheckDemoGuard As String
Visual C++
public:
static property String^ CheckDemoGuard {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


CheckForOldFormatPassword Property

[image]

OfficeClip API Documentation
AppSettings..::.CheckForOldFormatPassword Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Activates or deactivates the OCReminder Service

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool CheckForOldFormatPassword { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CheckForOldFormatPassword As Boolean
Visual C++
public:
static property bool CheckForOldFormatPassword {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


ConnectionString Property

[image]

OfficeClip API Documentation
AppSettings..::.ConnectionString Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Provides the database connection string to the application.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConnectionString { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ConnectionString As String
Visual C++
public:
static property String^ ConnectionString {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


CrystalReportsAvailable Property

[image]

OfficeClip API Documentation
AppSettings..::.CrystalReportsAvailable Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Returns if the crystal reports is available as a part of the package.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool CrystalReportsAvailable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CrystalReportsAvailable As Boolean
Visual C++
public:
static property bool CrystalReportsAvailable {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


CustomXml Property

[image]

OfficeClip API Documentation
AppSettings..::.CustomXml Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

This is where the custom pages are stored. It is advised that all custom files should be stored in the custom folder (and project) in a similar directory structure as that of officeclip. The value here is relative to the officeclip virtual directory folder.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string CustomXml { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property CustomXml As String
Visual C++
public:
static property String^ CustomXml {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


DateStringFormat Property

[image]

OfficeClip API Documentation
AppSettings..::.DateStringFormat Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Specify the date format used everywhere.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string DateStringFormat { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DateStringFormat As String
Visual C++
public:
static property String^ DateStringFormat {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


DiskSpaceQuota Property

[image]

OfficeClip API Documentation
AppSettings..::.DiskSpaceQuota Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

If the disk space quota is enabled, this key determines how much amout of disk space (in MB) to be allocated for each account.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int DiskSpaceQuota { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DiskSpaceQuota As Integer
Visual C++
public:
static property int DiskSpaceQuota {
    int get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


DocAccountDiskSpace Property

[image]

OfficeClip API Documentation
AppSettings..::.DocAccountDiskSpace Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Returns the additional account disk space (MB) increment in document management

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int DocAccountDiskSpace { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DocAccountDiskSpace As Integer
Visual C++
public:
static property int DocAccountDiskSpace {
    int get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


EmailServerName Property

[image]

OfficeClip API Documentation
AppSettings..::.EmailServerName Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The email server name that is used to send emails through OfficeClip. If this value is set to empty string in the web.config, no email will be sent

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string EmailServerName { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EmailServerName As String
Visual C++
public:
static property String^ EmailServerName {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


EmailServerName1 Property

[image]

OfficeClip API Documentation
AppSettings..::.EmailServerName1 Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The Secondary Email Server Name, If the primary email server fails and this value in web.config is not empty, then OfficeClip will attempt to send emails through this server.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string EmailServerName1 { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EmailServerName1 As String
Visual C++
public:
static property String^ EmailServerName1 {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


EmailServerName2 Property

[image]

OfficeClip API Documentation
AppSettings..::.EmailServerName2 Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The Tertiary Email Server Name, If the primary and secondary email server fails and this value in web.config is not empty, then OfficeClip will attempt to send emails through this server.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string EmailServerName2 { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EmailServerName2 As String
Visual C++
public:
static property String^ EmailServerName2 {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


HostStr Property

[image]

OfficeClip API Documentation
AppSettings..::.HostStr Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

String for the host name where OfficeClip is installed

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string HostStr { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostStr As String
Visual C++
public:
static property String^ HostStr {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


HostUrl Property

[image]

OfficeClip API Documentation
AppSettings..::.HostUrl Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

url representation of the HostStr

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string HostUrl { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property HostUrl As String
Visual C++
public:
static property String^ HostUrl {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


IsLdapAuthentication Property

[image]

OfficeClip API Documentation
AppSettings..::.IsLdapAuthentication Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Indicates whether all the necessary parameters for the LDAP authentication are available or not.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsLdapAuthentication { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IsLdapAuthentication As Boolean
Visual C++
public:
static property bool IsLdapAuthentication {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


IsLoginPopup Property

[image]

OfficeClip API Documentation
AppSettings..::.IsLoginPopup Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the user is logged in on a popup window (no buttons, address bar etc.)

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsLoginPopup { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IsLoginPopup As Boolean
Visual C++
public:
static property bool IsLoginPopup {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


LdapAuthenticationString Property

[image]

OfficeClip API Documentation
AppSettings..::.LdapAuthenticationString Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The name of the LDAP Server with which OfficeClip is integrated. If there is value specified for this key, then the value for the next key i.e. LDAPAdminAccount must be specified for the whole integration to work properly.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string LdapAuthenticationString { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LdapAuthenticationString As String
Visual C++
public:
static property String^ LdapAuthenticationString {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


LicenseServerLocation Property

[image]

OfficeClip API Documentation
AppSettings..::.LicenseServerLocation Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The location of the license server

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string LicenseServerLocation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LicenseServerLocation As String
Visual C++
public:
static property String^ LicenseServerLocation {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


LoginAuthenticationMode Property

[image]

OfficeClip API Documentation
AppSettings..::.LoginAuthenticationMode Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the login authentication mode. This mainly depends on the web.config and the IIS settings

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static LoginAuthenticationMode LoginAuthenticationMode { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LoginAuthenticationMode As LoginAuthenticationMode
Visual C++
public:
static property LoginAuthenticationMode LoginAuthenticationMode {
    LoginAuthenticationMode get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


LoginPopupParameters Property

[image]

OfficeClip API Documentation
AppSettings..::.LoginPopupParameters Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

returns the popup parameter for the login screen (if the login popup is true)

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string LoginPopupParameters { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property LoginPopupParameters As String
Visual C++
public:
static property String^ LoginPopupParameters {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


MailFormat Property

[image]

OfficeClip API Documentation
AppSettings..::.MailFormat Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The email format, it could be text or html. This is used to provide hints to the mail system if the OfficeClip send out html based emails.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string MailFormat { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MailFormat As String
Visual C++
public:
static property String^ MailFormat {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


MessageLogging Property

[image]

OfficeClip API Documentation
AppSettings..::.MessageLogging Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Logs the messages in the windows 2000 event log, possible values are
  • OffLogging is off
  • Level1Only errors and exceptions are logged
  • Level2errors, exceptions and warnings are logged
  • Level3errors, exceptions, warnings and information are logged
  • OnSame as level 3

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string MessageLogging { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MessageLogging As String
Visual C++
public:
static property String^ MessageLogging {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


OcDotComOnly Property

[image]

OfficeClip API Documentation
AppSettings..::.OcDotComOnly Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Use this for anything which is very very specific to OfficeClip.com only There are couple of instances which have to be specific to OfficeClip.com but should not be given to Non-BOXVERSIONS (e.g. people who will use OfficeClip as an Application Service Provider).

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool OcDotComOnly { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OcDotComOnly As Boolean
Visual C++
public:
static property bool OcDotComOnly {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


OcEmailAddress Property

[image]

OfficeClip API Documentation
AppSettings..::.OcEmailAddress Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Provides the email address for the OfficeClip administrator, this can also be the partner's email address for OfficeClip partners

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string OcEmailAddress { get; set; }
Visual Basic (Declaration)
Public Shared Property OcEmailAddress As String
Visual C++
public:
static property String^ OcEmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


OfficeClipWebSite Property

[image]

OfficeClip API Documentation
AppSettings..::.OfficeClipWebSite Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The OfficeClip website

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string OfficeClipWebSite { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property OfficeClipWebSite As String
Visual C++
public:
static property String^ OfficeClipWebSite {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


PasswordStrength Property

[image]

OfficeClip API Documentation
AppSettings..::.PasswordStrength Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Enter the password strength for creating the new password. The value is separated by semicolon. The first element is the minimum number of characters in the password, the second expression is the minimum number of non-alphanumeric characters in the password and the last element is the regular expression for the password. Note that you cannot put ; as a part of the regular expression. An empty value denotes that no password strength is enforced. All values are not required but the values should be put in the order specified. i.e. you cannot put the third value without putting the first and second value.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string PasswordStrength { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PasswordStrength As String
Visual C++
public:
static property String^ PasswordStrength {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


RegisteredCompany Property

[image]

OfficeClip API Documentation
AppSettings..::.RegisteredCompany Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Registered Company where the product is installed. This name shows up in the title bar.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string RegisteredCompany { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RegisteredCompany As String
Visual C++
public:
static property String^ RegisteredCompany {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


RegistrationDetailsRequired Property

[image]

OfficeClip API Documentation
AppSettings..::.RegistrationDetailsRequired Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Tells if the registration detail is required. No registration detail information is asked if this is false.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool RegistrationDetailsRequired { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RegistrationDetailsRequired As Boolean
Visual C++
public:
static property bool RegistrationDetailsRequired {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


ReminderActivated Property

[image]

OfficeClip API Documentation
AppSettings..::.ReminderActivated Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Activates or deactivates the OCReminder Service

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool ReminderActivated { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ReminderActivated As Boolean
Visual C++
public:
static property bool ReminderActivated {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


ReminderCallbackTimeSpan Property

[image]

OfficeClip API Documentation
AppSettings..::.ReminderCallbackTimeSpan Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Controls te timespan for the reminder callback

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int ReminderCallbackTimeSpan { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ReminderCallbackTimeSpan As Integer
Visual C++
public:
static property int ReminderCallbackTimeSpan {
    int get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


ServerTimeZoneId Property

[image]

OfficeClip API Documentation
AppSettings..::.ServerTimeZoneId Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The timezone id of the server is the index to the timezone table in the OfficeClip database. This value in the web.config file should not be changed by the user manually.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int ServerTimeZoneId { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ServerTimeZoneId As Integer
Visual C++
public:
static property int ServerTimeZoneId {
    int get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


ServerUrl Property

[image]

OfficeClip API Documentation
AppSettings..::.ServerUrl Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Returns the complete server url to get to this OfficeClip web site

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ServerUrl { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ServerUrl As String
Visual C++
public:
static property String^ ServerUrl {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


ShowQuickHelp Property

[image]

OfficeClip API Documentation
AppSettings..::.ShowQuickHelp Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Status to show if the quickhelp is to be shown

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool ShowQuickHelp { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShowQuickHelp As Boolean
Visual C++
public:
static property bool ShowQuickHelp {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


ShowTracktime Property

[image]

OfficeClip API Documentation
AppSettings..::.ShowTracktime Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the time tracking is on in various screens

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ShowTracktime { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShowTracktime As String
Visual C++
public:
static property String^ ShowTracktime {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


ShowVersionOnTitle Property

[image]

OfficeClip API Documentation
AppSettings..::.ShowVersionOnTitle Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Returns whether to show the product version on the title bar

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool ShowVersionOnTitle { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ShowVersionOnTitle As Boolean
Visual C++
public:
static property bool ShowVersionOnTitle {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


SpellCheckerAvailable Property

[image]

OfficeClip API Documentation
AppSettings..::.SpellCheckerAvailable Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Flag indicating whether spell checker is available or not.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool SpellCheckerAvailable { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SpellCheckerAvailable As Boolean
Visual C++
public:
static property bool SpellCheckerAvailable {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


SuccessNotification Property

[image]

OfficeClip API Documentation
AppSettings..::.SuccessNotification Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

If set to on, the success notifcication screen is shown after every successful inserts and updates

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool SuccessNotification { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SuccessNotification As Boolean
Visual C++
public:
static property bool SuccessNotification {
    bool get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


SupportEmailAddress Property

[image]

OfficeClip API Documentation
AppSettings..::.SupportEmailAddress Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Provides the email address for the support personnel

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string SupportEmailAddress { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property SupportEmailAddress As String
Visual C++
public:
static property String^ SupportEmailAddress {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


TimeStringFormat Property

[image]

OfficeClip API Documentation
AppSettings..::.TimeStringFormat Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Specifying the time format used everywhere

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string TimeStringFormat { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TimeStringFormat As String
Visual C++
public:
static property String^ TimeStringFormat {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


TutorialLocation Property

[image]

OfficeClip API Documentation
AppSettings..::.TutorialLocation Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Location of the OfficeClip tutorials

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string TutorialLocation { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property TutorialLocation As String
Visual C++
public:
static property String^ TutorialLocation {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


UniqueId Property

[image]

OfficeClip API Documentation
AppSettings..::.UniqueId Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The unique id used as a key to extranet forms. When the extranet foms are submitted, this will be checked for a match. If the key is compromised, the key will have to change and all the forms will need to be changed.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string UniqueId { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UniqueId As String
Visual C++
public:
static property String^ UniqueId {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


UploadFolderPath Property

[image]

OfficeClip API Documentation
AppSettings..::.UploadFolderPath Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The Upload folder path

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string UploadFolderPath { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UploadFolderPath As String
Visual C++
public:
static property String^ UploadFolderPath {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


VDirPath Property

[image]

OfficeClip API Documentation
AppSettings..::.VDirPath Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The Virtual Directory Path from where officeclip is accessed

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string VDirPath { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property VDirPath As String
Visual C++
public:
static property String^ VDirPath {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


WebContentMenuStatus Property

[image]

OfficeClip API Documentation
AppSettings..::.WebContentMenuStatus Property
AppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Indictes if the Web Content menus are enabled. Web Content menu is enabled only when the file Upload/corp/{groupid}/corpmenu.xml file is present in the document folder, values are:
  • OffNo Web Content menu is shown, irrespective of the presence of corpmenu.xml file
  • AlwaysWeb Content menu is always shown if corpmenu.xml is present
  • OnRequestWeb Content menu is shown if the page request it and corpmenu.xml is present. By default officeclip will have this enabled for the homepage

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string WebContentMenuStatus { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property WebContentMenuStatus As String
Visual C++
public:
static property String^ WebContentMenuStatus {
    String^ get ();
}

See Also

AppSettings Class
OfficeClip.Utils Namespace


CalendarView Enumeration

[image]

OfficeClip API Documentation
CalendarView Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for providing different calendar view to the calendar application

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum CalendarView
Visual Basic (Declaration)
Public Enumeration CalendarView
Visual C++
public enum class CalendarView

Members

Member name | Description
Daily | occurs every day
Weekly | occurs once in a week
Monthly | occurs once in a month
Yearly | occurs once in an year
WorkWeek | Only occurs in work week
None | Unknown calendar view

See Also

OfficeClip.Utils Namespace


ConfigureInfo Class

[image]

OfficeClip API Documentation
ConfigureInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

Stores the configuration information. This information is fetched from the database when the user logs into the system.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class ConfigureInfo
Visual Basic (Declaration)
Public Class ConfigureInfo
Visual C++
public ref class ConfigureInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.ConfigureInfo

See Also

ConfigureInfo Members
OfficeClip.Utils Namespace


ConfigureInfo Members

[image] [image]

OfficeClip API Documentation
ConfigureInfo Members
ConfigureInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The ConfigureInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigureInfo | Default Constructor

Methods

 | Name | Description
Public method | Dump | Dumnps the content of the object in a string in readable format. Used mainly for debugging.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAdminOrCreator | Tests if the current user is the adminitrator or the creator of an object
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AccountId | The account id of the account that was logged in
Public property | Applications | List of OfficeClip applications
Public property | EmailAddress | Returns the email address of the user who has logged into OfficeClip. The email address is the unique key across all users in OfficeClip.
Public property | ErrFlag | Returns the error id of the last error encountered yb the program when the exception is thrown.
Public property | GroupId | Returns the group id of the current group where the user logged in. The group id is the internal OfficeClip id of the group. It is unique across all groups.
Public property | GroupName | Returns the group name of the current group where the user is logged in.
Public property | GroupType | Returns the type of the group that the user is currently logged in. For a list of valid group type, OfficeClip.Utils..::.GroupType
Public property | IsAdmin | Returns whether the logged on user is the administrator of the current group
Public property | IsDemoAccount | Determine if the account is the demo account
Public property | IsExtranetUser | Determines whether the user is the Extranet user
Public property | IsLeftBarMinimized | Status of the left bar (if it is minimized)
Public property | IsReadOnly | Returns whether the logged on user has only readonly previlege on OfficeClip. If this is true, the user will not be able to change any information on any OfficeClip screens.
Public property | LastSecurityChanged | Returns the last time the security is changed in the system.
Public property | Name | Returns the full name of the user who has logged into the system.
Public property | Ocr | Returns the OfficeClip Resource object. This resource object is used for various things in OfficeClip like localization etc.
Public property | RegionalSettings | The demilited regional rettings
Public property | RoleAccess | Returns the Role Access of the user who has logged on to the system.
Public property | ServerTzInfo | Returns the user timezone information for the OfficeClip server. For details please see OfficeClip.Utils..::.TimeZoneInfo
Public property | Theme | Returns the current theme of the logged on user.
Public property | UserId | Returns the OfficeClip user id of the user. This user id is an internal id by which an OfficeClip user is recognized.
Public property | UserTzInfo | Returns the user timezone information for the logged in user. For details please see OfficeClip.Utils..::.TimeZoneInfo

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


ConfigureInfo Constructor

[image]

OfficeClip API Documentation
ConfigureInfo Constructor
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Default Constructor

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public ConfigureInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConfigureInfo()

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


ConfigureInfo Methods

[image] [image]

OfficeClip API Documentation
ConfigureInfo Methods
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ConfigureInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Dumnps the content of the object in a string in readable format. Used mainly for debugging.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAdminOrCreator | Tests if the current user is the adminitrator or the creator of an object
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


Dump Method

[image]

OfficeClip API Documentation
ConfigureInfo..::.Dump Method
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Dumnps the content of the object in a string in readable format. Used mainly for debugging.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


IsAdminOrCreator Method

[image]

OfficeClip API Documentation
ConfigureInfo..::.IsAdminOrCreator Method
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Tests if the current user is the adminitrator or the creator of an object

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public bool IsAdminOrCreator(
    int ownerId
)
Visual Basic (Declaration)
Public Function IsAdminOrCreator ( _
    ownerId As Integer _
) As Boolean
Visual C++
public:
bool IsAdminOrCreator(
    int ownerId
)

Parameters

ownerId
Type: System..::.Int32
The unique id of the owner of the object

Return Value

True if the user is the administrator or the creator, false otherwise

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


ConfigureInfo Properties

[image] [image]

OfficeClip API Documentation
ConfigureInfo Properties
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

The ConfigureInfo type exposes the following properties.

Properties

 | Name | Description
Public property | AccountId | The account id of the account that was logged in
Public property | Applications | List of OfficeClip applications
Public property | EmailAddress | Returns the email address of the user who has logged into OfficeClip. The email address is the unique key across all users in OfficeClip.
Public property | ErrFlag | Returns the error id of the last error encountered yb the program when the exception is thrown.
Public property | GroupId | Returns the group id of the current group where the user logged in. The group id is the internal OfficeClip id of the group. It is unique across all groups.
Public property | GroupName | Returns the group name of the current group where the user is logged in.
Public property | GroupType | Returns the type of the group that the user is currently logged in. For a list of valid group type, OfficeClip.Utils..::.GroupType
Public property | IsAdmin | Returns whether the logged on user is the administrator of the current group
Public property | IsDemoAccount | Determine if the account is the demo account
Public property | IsExtranetUser | Determines whether the user is the Extranet user
Public property | IsLeftBarMinimized | Status of the left bar (if it is minimized)
Public property | IsReadOnly | Returns whether the logged on user has only readonly previlege on OfficeClip. If this is true, the user will not be able to change any information on any OfficeClip screens.
Public property | LastSecurityChanged | Returns the last time the security is changed in the system.
Public property | Name | Returns the full name of the user who has logged into the system.
Public property | Ocr | Returns the OfficeClip Resource object. This resource object is used for various things in OfficeClip like localization etc.
Public property | RegionalSettings | The demilited regional rettings
Public property | RoleAccess | Returns the Role Access of the user who has logged on to the system.
Public property | ServerTzInfo | Returns the user timezone information for the OfficeClip server. For details please see OfficeClip.Utils..::.TimeZoneInfo
Public property | Theme | Returns the current theme of the logged on user.
Public property | UserId | Returns the OfficeClip user id of the user. This user id is an internal id by which an OfficeClip user is recognized.
Public property | UserTzInfo | Returns the user timezone information for the logged in user. For details please see OfficeClip.Utils..::.TimeZoneInfo

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


AccountId Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.AccountId Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

The account id of the account that was logged in

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int AccountId { get; set; }
Visual Basic (Declaration)
Public Property AccountId As Integer
Visual C++
public:
property int AccountId {
    int get ();
    void set (int value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


Applications Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.Applications Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

List of OfficeClip applications

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public byte[] Applications { get; set; }
Visual Basic (Declaration)
Public Property Applications As Byte()
Visual C++
public:
property array<unsigned char>^ Applications {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


EmailAddress Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.EmailAddress Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the email address of the user who has logged into OfficeClip. The email address is the unique key across all users in OfficeClip.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string EmailAddress { get; set; }
Visual Basic (Declaration)
Public Property EmailAddress As String
Visual C++
public:
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


ErrFlag Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.ErrFlag Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the error id of the last error encountered yb the program when the exception is thrown.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int ErrFlag { get; set; }
Visual Basic (Declaration)
Public Property ErrFlag As Integer
Visual C++
public:
property int ErrFlag {
    int get ();
    void set (int value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


GroupId Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.GroupId Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the group id of the current group where the user logged in. The group id is the internal OfficeClip id of the group. It is unique across all groups.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; set; }
Visual Basic (Declaration)
Public Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
    void set (int value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


GroupName Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.GroupName Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the group name of the current group where the user is logged in.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string GroupName { get; set; }
Visual Basic (Declaration)
Public Property GroupName As String
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


GroupType Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.GroupType Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the type of the group that the user is currently logged in. For a list of valid group type, OfficeClip.Utils..::.GroupType

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public GroupType GroupType { get; set; }
Visual Basic (Declaration)
Public Property GroupType As GroupType
Visual C++
public:
property GroupType GroupType {
    GroupType get ();
    void set (GroupType value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace
OfficeClip.Utils..::.GroupType


IsAdmin Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.IsAdmin Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns whether the logged on user is the administrator of the current group

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public bool IsAdmin { get; set; }
Visual Basic (Declaration)
Public Property IsAdmin As Boolean
Visual C++
public:
property bool IsAdmin {
    bool get ();
    void set (bool value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


IsDemoAccount Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.IsDemoAccount Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Determine if the account is the demo account

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public bool IsDemoAccount { get; set; }
Visual Basic (Declaration)
Public Property IsDemoAccount As Boolean
Visual C++
public:
property bool IsDemoAccount {
    bool get ();
    void set (bool value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


IsExtranetUser Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.IsExtranetUser Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Determines whether the user is the Extranet user

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public bool IsExtranetUser { get; set; }
Visual Basic (Declaration)
Public Property IsExtranetUser As Boolean
Visual C++
public:
property bool IsExtranetUser {
    bool get ();
    void set (bool value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


IsLeftBarMinimized Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.IsLeftBarMinimized Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Status of the left bar (if it is minimized)

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public bool IsLeftBarMinimized { get; set; }
Visual Basic (Declaration)
Public Property IsLeftBarMinimized As Boolean
Visual C++
public:
property bool IsLeftBarMinimized {
    bool get ();
    void set (bool value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


IsReadOnly Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.IsReadOnly Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns whether the logged on user has only readonly previlege on OfficeClip. If this is true, the user will not be able to change any information on any OfficeClip screens.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic (Declaration)
Public Property IsReadOnly As Boolean
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


LastSecurityChanged Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.LastSecurityChanged Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the last time the security is changed in the system.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public DateTime LastSecurityChanged { get; set; }
Visual Basic (Declaration)
Public Property LastSecurityChanged As DateTime
Visual C++
public:
property DateTime LastSecurityChanged {
    DateTime get ();
    void set (DateTime value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


Name Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.Name Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the full name of the user who has logged into the system.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


Ocr Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.Ocr Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the OfficeClip Resource object. This resource object is used for various things in OfficeClip like localization etc.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCResources Ocr { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ocr As OCResources
Visual C++
public:
property OCResources^ Ocr {
    OCResources^ get ();
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


RegionalSettings Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.RegionalSettings Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

The demilited regional rettings

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string RegionalSettings { get; set; }
Visual Basic (Declaration)
Public Property RegionalSettings As String
Visual C++
public:
property String^ RegionalSettings {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


RoleAccess Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.RoleAccess Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the Role Access of the user who has logged on to the system.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public bool[] RoleAccess { get; set; }
Visual Basic (Declaration)
Public Property RoleAccess As Boolean()
Visual C++
public:
property array<bool>^ RoleAccess {
    array<bool>^ get ();
    void set (array<bool>^ value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


ServerTzInfo Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.ServerTzInfo Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the user timezone information for the OfficeClip server. For details please see OfficeClip.Utils..::.TimeZoneInfo

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public TimeZoneInfo ServerTzInfo { get; set; }
Visual Basic (Declaration)
Public Property ServerTzInfo As TimeZoneInfo
Visual C++
public:
property TimeZoneInfo^ ServerTzInfo {
    TimeZoneInfo^ get ();
    void set (TimeZoneInfo^ value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace
OfficeClip.Utils..::.TimeZoneInfo


Theme Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.Theme Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the current theme of the logged on user.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string Theme { get; set; }
Visual Basic (Declaration)
Public Property Theme As String
Visual C++
public:
property String^ Theme {
    String^ get ();
    void set (String^ value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


UserId Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.UserId Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the OfficeClip user id of the user. This user id is an internal id by which an OfficeClip user is recognized.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int UserId { get; set; }
Visual Basic (Declaration)
Public Property UserId As Integer
Visual C++
public:
property int UserId {
    int get ();
    void set (int value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace


UserTzInfo Property

[image]

OfficeClip API Documentation
ConfigureInfo..::.UserTzInfo Property
ConfigureInfo Class See Also

[This is preliminary documentation and is subject to change.]

Returns the user timezone information for the logged in user. For details please see OfficeClip.Utils..::.TimeZoneInfo

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public TimeZoneInfo UserTzInfo { get; set; }
Visual Basic (Declaration)
Public Property UserTzInfo As TimeZoneInfo
Visual C++
public:
property TimeZoneInfo^ UserTzInfo {
    TimeZoneInfo^ get ();
    void set (TimeZoneInfo^ value);
}

See Also

ConfigureInfo Class
OfficeClip.Utils Namespace
OfficeClip.Utils..::.TimeZoneInfo


Constants Class

[image]

OfficeClip API Documentation
Constants Class
Members See Also

[This is preliminary documentation and is subject to change.]

Stores all constants used throughout the OfficeClip application

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public sealed class Constants
Visual Basic (Declaration)
Public NotInheritable Class Constants
Visual C++
public ref class Constants sealed

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.Constants

See Also

Constants Members
OfficeClip.Utils Namespace


Constants Members

[image] [image]

OfficeClip API Documentation
Constants Members
Constants Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The Constants type exposes the following members.

Constructors

 | Name | Description
Public method | Constants |

Methods

 | Name | Description
 | DecimalValidationLooseRegularExpression | Regular expression for the decimal expression loosely
 | DecimalValidationRegularExpression | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumericValidationRegularExpression | Overloaded.
 | TimesheetTimeRegularExpression | Validates a signed decimal of any length.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AccountingTrialPeriodUsersMin | This is the minimum number of users added to th accounting table if accounting is turned off.
ApplicationEndingProgram | This is where the application will be redirected when the session is over
ApplicationNameExpenses | This name should be exactly same as the name of the timesheet program in the application table.
ApplicationNameTimesheets | This name should be exactly same as the name of the expense report program in the application table.
ApplicationStartupProgram | This is where the application will be send back after exit or logout
BooleanNo | Defines boolean value Yes will be interpreted in the tracker
BooleanUnspecified | Defines boolean value Unspecified will be interpreted in the tracker
BooleanYes | Defines boolean value Yes will be interpreted in the tracker
compatibleMicrosoftAccountingAddInVersion | Gives the compatible MS Accounting addin version. This means that this version of the product will work effectively with the MS Accounting add in version mentioned. If the versions do not match then the MS Accounting addin will not work.
compatibleOfflineTimeExpenseVersion | Gives the compatible Offline Timesheet version. This means that this version of the product will work effectively with the Offline Timesheet add in version mentioned. If the versions do not match then the Offline Timesheet addin will not work.
compatibleOutlookAddInVersion | Gives the compatible outlook addin version. This means that this version of the product will work effectively with the outlook add in version mentioned. If the versions do not match then the outlook addin will not work.
compatibleQuickbooksAddInVersion | Gives the compatible Quickbooks addin version. This means that this version of the product will work effectively with the quickbooks add in version mentioned. If the versions do not match then the Quickbooks addin will not work.
DBDateMaxValue | The sql server max date is not same as the .net maxvalue, so this will be used to pass to the sql server.
DBDateMinValue | The sql server min date is not same as the .net minvalue, so this will be used for the sql server
DefaultDevelopmentFolder | The default development folder, for internal OfficeClip use
defaultTEAllowSelfApprove | The default time and expenses self approve status
defaultTENumberOfRows | The default time and expenses number of rows on the entry screen
defaultTEWeekStartDay | The default Time & Expenses start day
docGifTypes | A list of all the document types. This is used to show the bitmaps of these types in the document management screen
EmailAddressMultipleValidationRegularExpression | The regular expression for validating Multiple Email Addresses
EmailAddressValidationRegularExpression | The regular expression for validating Email Address
FixedHugeTextName | The huge text (usually 64K for sql server 2005 but 4K for sql server 2000
FixedLongTextName | The long text field name, usually reserved for description, resolution and comments. Only used in the service layer.
IsCodeProtected | The name of the variable used to internally keep track of code changes. Helps separate what needs to go into release and what doesn't need to.
LicenseValidErrFlag | The license validate error flag, is checked during login
maxRowsToShowTopButtons | The maximum number of rows so that the top buttons are shows when the row number exceeds this value
NotAvailable | The value is not available. This should be used to return undeterministic return value from the library.
NumberOfPeriodForwards |
OneKB | numeric value of bytes in one kilobyte
OneMB | numberic value of bytes in one megabyte
OutlookContactsName | The name of the outlook address book that is created for synchronization with outlook
patchLevel | The patch level, this entry and the assembly info file version should be changed for each patch.
PercentageReqularValidationExpression | The regular expression for percentage
productSignature | The signature of the OfficeClip product. This signature may appear in various places including the browser title.
productVersion | The current OfficeClip product version. The product version consists of Major Version number, Minor Version number and the Release number. This constant need to be changed every time a new release is made.
ResTraceFlag | The Trace nuame for the appliction level resource
SelectAll | Constants for all the selection in the checkbox or list box
UdfBooleanName | The default udf boolean name, used to denote decimals
UdfDateName | The default udf date name
UdfDecimalName | The default udf decimal name, used to denote decimals
UdfEMailName | The default udf email name
UdfListName | The default udf list name
UdfNumberName | The default udf number name, used to denote numbers
UdfTextName | The default udf text name
UdfUserName | The default udf user name
WorkflowStatusSaved | The name of the saved workflow status

Properties

Name | Description
Blank | Returns the blank string in various locale.
PrivateFolderName | Returns the default private folder name alias
Select | Returns the select string in various locale.
Unspecified | Returns the unspecified string in various locale.

See Also

Constants Class
OfficeClip.Utils Namespace


Constants Constructor

[image]

OfficeClip API Documentation
Constants Constructor
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public Constants()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Constants()

See Also

Constants Class
OfficeClip.Utils Namespace


Constants Fields

[image] [image]

OfficeClip API Documentation
Constants Fields
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The Constants type exposes the following fields.

Fields

Name | Description
AccountingTrialPeriodUsersMin | This is the minimum number of users added to th accounting table if accounting is turned off.
ApplicationEndingProgram | This is where the application will be redirected when the session is over
ApplicationNameExpenses | This name should be exactly same as the name of the timesheet program in the application table.
ApplicationNameTimesheets | This name should be exactly same as the name of the expense report program in the application table.
ApplicationStartupProgram | This is where the application will be send back after exit or logout
BooleanNo | Defines boolean value Yes will be interpreted in the tracker
BooleanUnspecified | Defines boolean value Unspecified will be interpreted in the tracker
BooleanYes | Defines boolean value Yes will be interpreted in the tracker
compatibleMicrosoftAccountingAddInVersion | Gives the compatible MS Accounting addin version. This means that this version of the product will work effectively with the MS Accounting add in version mentioned. If the versions do not match then the MS Accounting addin will not work.
compatibleOfflineTimeExpenseVersion | Gives the compatible Offline Timesheet version. This means that this version of the product will work effectively with the Offline Timesheet add in version mentioned. If the versions do not match then the Offline Timesheet addin will not work.
compatibleOutlookAddInVersion | Gives the compatible outlook addin version. This means that this version of the product will work effectively with the outlook add in version mentioned. If the versions do not match then the outlook addin will not work.
compatibleQuickbooksAddInVersion | Gives the compatible Quickbooks addin version. This means that this version of the product will work effectively with the quickbooks add in version mentioned. If the versions do not match then the Quickbooks addin will not work.
DBDateMaxValue | The sql server max date is not same as the .net maxvalue, so this will be used to pass to the sql server.
DBDateMinValue | The sql server min date is not same as the .net minvalue, so this will be used for the sql server
DefaultDevelopmentFolder | The default development folder, for internal OfficeClip use
defaultTEAllowSelfApprove | The default time and expenses self approve status
defaultTENumberOfRows | The default time and expenses number of rows on the entry screen
defaultTEWeekStartDay | The default Time & Expenses start day
docGifTypes | A list of all the document types. This is used to show the bitmaps of these types in the document management screen
EmailAddressMultipleValidationRegularExpression | The regular expression for validating Multiple Email Addresses
EmailAddressValidationRegularExpression | The regular expression for validating Email Address
FixedHugeTextName | The huge text (usually 64K for sql server 2005 but 4K for sql server 2000
FixedLongTextName | The long text field name, usually reserved for description, resolution and comments. Only used in the service layer.
IsCodeProtected | The name of the variable used to internally keep track of code changes. Helps separate what needs to go into release and what doesn't need to.
LicenseValidErrFlag | The license validate error flag, is checked during login
maxRowsToShowTopButtons | The maximum number of rows so that the top buttons are shows when the row number exceeds this value
NotAvailable | The value is not available. This should be used to return undeterministic return value from the library.
NumberOfPeriodForwards |
OneKB | numeric value of bytes in one kilobyte
OneMB | numberic value of bytes in one megabyte
OutlookContactsName | The name of the outlook address book that is created for synchronization with outlook
patchLevel | The patch level, this entry and the assembly info file version should be changed for each patch.
PercentageReqularValidationExpression | The regular expression for percentage
productSignature | The signature of the OfficeClip product. This signature may appear in various places including the browser title.
productVersion | The current OfficeClip product version. The product version consists of Major Version number, Minor Version number and the Release number. This constant need to be changed every time a new release is made.
ResTraceFlag | The Trace nuame for the appliction level resource
SelectAll | Constants for all the selection in the checkbox or list box
UdfBooleanName | The default udf boolean name, used to denote decimals
UdfDateName | The default udf date name
UdfDecimalName | The default udf decimal name, used to denote decimals
UdfEMailName | The default udf email name
UdfListName | The default udf list name
UdfNumberName | The default udf number name, used to denote numbers
UdfTextName | The default udf text name
UdfUserName | The default udf user name
WorkflowStatusSaved | The name of the saved workflow status

See Also

Constants Class
OfficeClip.Utils Namespace


AccountingTrialPeriodUsersMin Field

[image]

OfficeClip API Documentation
Constants..::.AccountingTrialPeriodUsersMin Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

This is the minimum number of users added to th accounting table if accounting is turned off.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly int AccountingTrialPeriodUsersMin
Visual Basic (Declaration)
Public Shared ReadOnly AccountingTrialPeriodUsersMin As Integer
Visual C++
public:
static initonly int AccountingTrialPeriodUsersMin

See Also

Constants Class
OfficeClip.Utils Namespace


ApplicationEndingProgram Field

[image]

OfficeClip API Documentation
Constants..::.ApplicationEndingProgram Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

This is where the application will be redirected when the session is over

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string ApplicationEndingProgram
Visual Basic (Declaration)
Public Shared ReadOnly ApplicationEndingProgram As String
Visual C++
public:
static initonly String^ ApplicationEndingProgram

See Also

Constants Class
OfficeClip.Utils Namespace


ApplicationNameExpenses Field

[image]

OfficeClip API Documentation
Constants..::.ApplicationNameExpenses Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

This name should be exactly same as the name of the timesheet program in the application table.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string ApplicationNameExpenses
Visual Basic (Declaration)
Public Shared ReadOnly ApplicationNameExpenses As String
Visual C++
public:
static initonly String^ ApplicationNameExpenses

See Also

Constants Class
OfficeClip.Utils Namespace


ApplicationNameTimesheets Field

[image]

OfficeClip API Documentation
Constants..::.ApplicationNameTimesheets Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

This name should be exactly same as the name of the expense report program in the application table.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string ApplicationNameTimesheets
Visual Basic (Declaration)
Public Shared ReadOnly ApplicationNameTimesheets As String
Visual C++
public:
static initonly String^ ApplicationNameTimesheets

See Also

Constants Class
OfficeClip.Utils Namespace


ApplicationStartupProgram Field

[image]

OfficeClip API Documentation
Constants..::.ApplicationStartupProgram Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

This is where the application will be send back after exit or logout

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string ApplicationStartupProgram
Visual Basic (Declaration)
Public Shared ReadOnly ApplicationStartupProgram As String
Visual C++
public:
static initonly String^ ApplicationStartupProgram

See Also

Constants Class
OfficeClip.Utils Namespace


BooleanNo Field

[image]

OfficeClip API Documentation
Constants..::.BooleanNo Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Defines boolean value Yes will be interpreted in the tracker

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string BooleanNo
Visual Basic (Declaration)
Public Shared ReadOnly BooleanNo As String
Visual C++
public:
static initonly String^ BooleanNo

See Also

Constants Class
OfficeClip.Utils Namespace


BooleanUnspecified Field

[image]

OfficeClip API Documentation
Constants..::.BooleanUnspecified Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Defines boolean value Unspecified will be interpreted in the tracker

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string BooleanUnspecified
Visual Basic (Declaration)
Public Shared ReadOnly BooleanUnspecified As String
Visual C++
public:
static initonly String^ BooleanUnspecified

See Also

Constants Class
OfficeClip.Utils Namespace


BooleanYes Field

[image]

OfficeClip API Documentation
Constants..::.BooleanYes Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Defines boolean value Yes will be interpreted in the tracker

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string BooleanYes
Visual Basic (Declaration)
Public Shared ReadOnly BooleanYes As String
Visual C++
public:
static initonly String^ BooleanYes

See Also

Constants Class
OfficeClip.Utils Namespace


compatibleMicrosoftAccountingAddInVersion Field

[image]

OfficeClip API Documentation
Constants..::.compatibleMicrosoftAccountingAddInVersion Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gives the compatible MS Accounting addin version. This means that this version of the product will work effectively with the MS Accounting add in version mentioned. If the versions do not match then the MS Accounting addin will not work.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string compatibleMicrosoftAccountingAddInVersion
Visual Basic (Declaration)
Public Shared ReadOnly compatibleMicrosoftAccountingAddInVersion As String
Visual C++
public:
static initonly String^ compatibleMicrosoftAccountingAddInVersion

See Also

Constants Class
OfficeClip.Utils Namespace


compatibleOfflineTimeExpenseVersion Field

[image]

OfficeClip API Documentation
Constants..::.compatibleOfflineTimeExpenseVersion Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gives the compatible Offline Timesheet version. This means that this version of the product will work effectively with the Offline Timesheet add in version mentioned. If the versions do not match then the Offline Timesheet addin will not work.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string compatibleOfflineTimeExpenseVersion
Visual Basic (Declaration)
Public Shared ReadOnly compatibleOfflineTimeExpenseVersion As String
Visual C++
public:
static initonly String^ compatibleOfflineTimeExpenseVersion

See Also

Constants Class
OfficeClip.Utils Namespace


compatibleOutlookAddInVersion Field

[image]

OfficeClip API Documentation
Constants..::.compatibleOutlookAddInVersion Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gives the compatible outlook addin version. This means that this version of the product will work effectively with the outlook add in version mentioned. If the versions do not match then the outlook addin will not work.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string compatibleOutlookAddInVersion
Visual Basic (Declaration)
Public Shared ReadOnly compatibleOutlookAddInVersion As String
Visual C++
public:
static initonly String^ compatibleOutlookAddInVersion

See Also

Constants Class
OfficeClip.Utils Namespace


compatibleQuickbooksAddInVersion Field

[image]

OfficeClip API Documentation
Constants..::.compatibleQuickbooksAddInVersion Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Gives the compatible Quickbooks addin version. This means that this version of the product will work effectively with the quickbooks add in version mentioned. If the versions do not match then the Quickbooks addin will not work.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string compatibleQuickbooksAddInVersion
Visual Basic (Declaration)
Public Shared ReadOnly compatibleQuickbooksAddInVersion As String
Visual C++
public:
static initonly String^ compatibleQuickbooksAddInVersion

See Also

Constants Class
OfficeClip.Utils Namespace


DBDateMaxValue Field

[image]

OfficeClip API Documentation
Constants..::.DBDateMaxValue Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The sql server max date is not same as the .net maxvalue, so this will be used to pass to the sql server.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly DateTime DBDateMaxValue
Visual Basic (Declaration)
Public Shared ReadOnly DBDateMaxValue As DateTime
Visual C++
public:
static initonly DateTime DBDateMaxValue

See Also

Constants Class
OfficeClip.Utils Namespace


DBDateMinValue Field

[image]

OfficeClip API Documentation
Constants..::.DBDateMinValue Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The sql server min date is not same as the .net minvalue, so this will be used for the sql server

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly DateTime DBDateMinValue
Visual Basic (Declaration)
Public Shared ReadOnly DBDateMinValue As DateTime
Visual C++
public:
static initonly DateTime DBDateMinValue

See Also

Constants Class
OfficeClip.Utils Namespace


DefaultDevelopmentFolder Field

[image]

OfficeClip API Documentation
Constants..::.DefaultDevelopmentFolder Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default development folder, for internal OfficeClip use

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string DefaultDevelopmentFolder
Visual Basic (Declaration)
Public Shared ReadOnly DefaultDevelopmentFolder As String
Visual C++
public:
static initonly String^ DefaultDevelopmentFolder

See Also

Constants Class
OfficeClip.Utils Namespace


defaultTEAllowSelfApprove Field

[image]

OfficeClip API Documentation
Constants..::.defaultTEAllowSelfApprove Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default time and expenses self approve status

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string defaultTEAllowSelfApprove
Visual Basic (Declaration)
Public Shared ReadOnly defaultTEAllowSelfApprove As String
Visual C++
public:
static initonly String^ defaultTEAllowSelfApprove

See Also

Constants Class
OfficeClip.Utils Namespace


defaultTENumberOfRows Field

[image]

OfficeClip API Documentation
Constants..::.defaultTENumberOfRows Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default time and expenses number of rows on the entry screen

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly int defaultTENumberOfRows
Visual Basic (Declaration)
Public Shared ReadOnly defaultTENumberOfRows As Integer
Visual C++
public:
static initonly int defaultTENumberOfRows

See Also

Constants Class
OfficeClip.Utils Namespace


defaultTEWeekStartDay Field

[image]

OfficeClip API Documentation
Constants..::.defaultTEWeekStartDay Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default Time & Expenses start day

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly DayOfWeek defaultTEWeekStartDay
Visual Basic (Declaration)
Public Shared ReadOnly defaultTEWeekStartDay As DayOfWeek
Visual C++
public:
static initonly DayOfWeek defaultTEWeekStartDay

See Also

Constants Class
OfficeClip.Utils Namespace


docGifTypes Field

[image]

OfficeClip API Documentation
Constants..::.docGifTypes Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

A list of all the document types. This is used to show the bitmaps of these types in the document management screen

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string[] docGifTypes
Visual Basic (Declaration)
Public Shared ReadOnly docGifTypes As String()
Visual C++
public:
static initonly array<String^>^ docGifTypes

See Also

Constants Class
OfficeClip.Utils Namespace


EmailAddressMultipleValidationRegularExpression Field

[image]

OfficeClip API Documentation
Constants..::.EmailAddressMultipleValidationRegularExpression Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The regular expression for validating Multiple Email Addresses

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string EmailAddressMultipleValidationRegularExpression
Visual Basic (Declaration)
Public Shared ReadOnly EmailAddressMultipleValidationRegularExpression As String
Visual C++
public:
static initonly String^ EmailAddressMultipleValidationRegularExpression

Remarks

Use this with the MatchCollection Class.

See Also

Constants Class
OfficeClip.Utils Namespace


EmailAddressValidationRegularExpression Field

[image]

OfficeClip API Documentation
Constants..::.EmailAddressValidationRegularExpression Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The regular expression for validating Email Address

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string EmailAddressValidationRegularExpression
Visual Basic (Declaration)
Public Shared ReadOnly EmailAddressValidationRegularExpression As String
Visual C++
public:
static initonly String^ EmailAddressValidationRegularExpression

See Also

Constants Class
OfficeClip.Utils Namespace


FixedHugeTextName Field

[image]

OfficeClip API Documentation
Constants..::.FixedHugeTextName Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The huge text (usually 64K for sql server 2005 but 4K for sql server 2000

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string FixedHugeTextName
Visual Basic (Declaration)
Public Shared ReadOnly FixedHugeTextName As String
Visual C++
public:
static initonly String^ FixedHugeTextName

See Also

Constants Class
OfficeClip.Utils Namespace


FixedLongTextName Field

[image]

OfficeClip API Documentation
Constants..::.FixedLongTextName Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The long text field name, usually reserved for description, resolution and comments. Only used in the service layer.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string FixedLongTextName
Visual Basic (Declaration)
Public Shared ReadOnly FixedLongTextName As String
Visual C++
public:
static initonly String^ FixedLongTextName

See Also

Constants Class
OfficeClip.Utils Namespace


IsCodeProtected Field

[image]

OfficeClip API Documentation
Constants..::.IsCodeProtected Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The name of the variable used to internally keep track of code changes. Helps separate what needs to go into release and what doesn't need to.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsCodeProtected
Visual Basic (Declaration)
Public Shared IsCodeProtected As Boolean
Visual C++
public:
static bool IsCodeProtected

See Also

Constants Class
OfficeClip.Utils Namespace


LicenseValidErrFlag Field

[image]

OfficeClip API Documentation
Constants..::.LicenseValidErrFlag Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The license validate error flag, is checked during login

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly int LicenseValidErrFlag
Visual Basic (Declaration)
Public Shared ReadOnly LicenseValidErrFlag As Integer
Visual C++
public:
static initonly int LicenseValidErrFlag

See Also

Constants Class
OfficeClip.Utils Namespace


maxRowsToShowTopButtons Field

[image]

OfficeClip API Documentation
Constants..::.maxRowsToShowTopButtons Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The maximum number of rows so that the top buttons are shows when the row number exceeds this value

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly int maxRowsToShowTopButtons
Visual Basic (Declaration)
Public Shared ReadOnly maxRowsToShowTopButtons As Integer
Visual C++
public:
static initonly int maxRowsToShowTopButtons

See Also

Constants Class
OfficeClip.Utils Namespace


NotAvailable Field

[image]

OfficeClip API Documentation
Constants..::.NotAvailable Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The value is not available. This should be used to return undeterministic return value from the library.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly int NotAvailable
Visual Basic (Declaration)
Public Shared ReadOnly NotAvailable As Integer
Visual C++
public:
static initonly int NotAvailable

See Also

Constants Class
OfficeClip.Utils Namespace


NumberOfPeriodForwards Field

[image]

OfficeClip API Documentation
Constants..::.NumberOfPeriodForwards Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly int NumberOfPeriodForwards
Visual Basic (Declaration)
Public Shared ReadOnly NumberOfPeriodForwards As Integer
Visual C++
public:
static initonly int NumberOfPeriodForwards

See Also

Constants Class
OfficeClip.Utils Namespace


OneKB Field

[image]

OfficeClip API Documentation
Constants..::.OneKB Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

numeric value of bytes in one kilobyte

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly double OneKB
Visual Basic (Declaration)
Public Shared ReadOnly OneKB As Double
Visual C++
public:
static initonly double OneKB

See Also

Constants Class
OfficeClip.Utils Namespace


OneMB Field

[image]

OfficeClip API Documentation
Constants..::.OneMB Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

numberic value of bytes in one megabyte

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly double OneMB
Visual Basic (Declaration)
Public Shared ReadOnly OneMB As Double
Visual C++
public:
static initonly double OneMB

See Also

Constants Class
OfficeClip.Utils Namespace


OutlookContactsName Field

[image]

OfficeClip API Documentation
Constants..::.OutlookContactsName Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The name of the outlook address book that is created for synchronization with outlook

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string OutlookContactsName
Visual Basic (Declaration)
Public Shared ReadOnly OutlookContactsName As String
Visual C++
public:
static initonly String^ OutlookContactsName

See Also

Constants Class
OfficeClip.Utils Namespace


patchLevel Field

[image]

OfficeClip API Documentation
Constants..::.patchLevel Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The patch level, this entry and the assembly info file version should be changed for each patch.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string patchLevel
Visual Basic (Declaration)
Public Shared ReadOnly patchLevel As String
Visual C++
public:
static initonly String^ patchLevel

See Also

Constants Class
OfficeClip.Utils Namespace


PercentageReqularValidationExpression Field

[image]

OfficeClip API Documentation
Constants..::.PercentageReqularValidationExpression Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The regular expression for percentage

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string PercentageReqularValidationExpression
Visual Basic (Declaration)
Public Shared ReadOnly PercentageReqularValidationExpression As String
Visual C++
public:
static initonly String^ PercentageReqularValidationExpression

See Also

Constants Class
OfficeClip.Utils Namespace


productSignature Field

[image]

OfficeClip API Documentation
Constants..::.productSignature Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The signature of the OfficeClip product. This signature may appear in various places including the browser title.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string productSignature
Visual Basic (Declaration)
Public Shared ReadOnly productSignature As String
Visual C++
public:
static initonly String^ productSignature

See Also

Constants Class
OfficeClip.Utils Namespace


productVersion Field

[image]

OfficeClip API Documentation
Constants..::.productVersion Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The current OfficeClip product version. The product version consists of Major Version number, Minor Version number and the Release number. This constant need to be changed every time a new release is made.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string productVersion
Visual Basic (Declaration)
Public Shared ReadOnly productVersion As String
Visual C++
public:
static initonly String^ productVersion

See Also

Constants Class
OfficeClip.Utils Namespace


ResTraceFlag Field

[image]

OfficeClip API Documentation
Constants..::.ResTraceFlag Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The Trace nuame for the appliction level resource

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string ResTraceFlag
Visual Basic (Declaration)
Public Shared ReadOnly ResTraceFlag As String
Visual C++
public:
static initonly String^ ResTraceFlag

See Also

Constants Class
OfficeClip.Utils Namespace


SelectAll Field

[image]

OfficeClip API Documentation
Constants..::.SelectAll Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Constants for all the selection in the checkbox or list box

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly int SelectAll
Visual Basic (Declaration)
Public Shared ReadOnly SelectAll As Integer
Visual C++
public:
static initonly int SelectAll

See Also

Constants Class
OfficeClip.Utils Namespace


UdfBooleanName Field

[image]

OfficeClip API Documentation
Constants..::.UdfBooleanName Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default udf boolean name, used to denote decimals

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string UdfBooleanName
Visual Basic (Declaration)
Public Shared ReadOnly UdfBooleanName As String
Visual C++
public:
static initonly String^ UdfBooleanName

See Also

Constants Class
OfficeClip.Utils Namespace


UdfDateName Field

[image]

OfficeClip API Documentation
Constants..::.UdfDateName Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default udf date name

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string UdfDateName
Visual Basic (Declaration)
Public Shared ReadOnly UdfDateName As String
Visual C++
public:
static initonly String^ UdfDateName

See Also

Constants Class
OfficeClip.Utils Namespace


UdfDecimalName Field

[image]

OfficeClip API Documentation
Constants..::.UdfDecimalName Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default udf decimal name, used to denote decimals

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string UdfDecimalName
Visual Basic (Declaration)
Public Shared ReadOnly UdfDecimalName As String
Visual C++
public:
static initonly String^ UdfDecimalName

See Also

Constants Class
OfficeClip.Utils Namespace


UdfEMailName Field

[image]

OfficeClip API Documentation
Constants..::.UdfEMailName Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default udf email name

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string UdfEMailName
Visual Basic (Declaration)
Public Shared ReadOnly UdfEMailName As String
Visual C++
public:
static initonly String^ UdfEMailName

See Also

Constants Class
OfficeClip.Utils Namespace


UdfListName Field

[image]

OfficeClip API Documentation
Constants..::.UdfListName Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default udf list name

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string UdfListName
Visual Basic (Declaration)
Public Shared ReadOnly UdfListName As String
Visual C++
public:
static initonly String^ UdfListName

See Also

Constants Class
OfficeClip.Utils Namespace


UdfNumberName Field

[image]

OfficeClip API Documentation
Constants..::.UdfNumberName Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default udf number name, used to denote numbers

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string UdfNumberName
Visual Basic (Declaration)
Public Shared ReadOnly UdfNumberName As String
Visual C++
public:
static initonly String^ UdfNumberName

See Also

Constants Class
OfficeClip.Utils Namespace


UdfTextName Field

[image]

OfficeClip API Documentation
Constants..::.UdfTextName Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default udf text name

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string UdfTextName
Visual Basic (Declaration)
Public Shared ReadOnly UdfTextName As String
Visual C++
public:
static initonly String^ UdfTextName

See Also

Constants Class
OfficeClip.Utils Namespace


UdfUserName Field

[image]

OfficeClip API Documentation
Constants..::.UdfUserName Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The default udf user name

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string UdfUserName
Visual Basic (Declaration)
Public Shared ReadOnly UdfUserName As String
Visual C++
public:
static initonly String^ UdfUserName

See Also

Constants Class
OfficeClip.Utils Namespace


WorkflowStatusSaved Field

[image]

OfficeClip API Documentation
Constants..::.WorkflowStatusSaved Field
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The name of the saved workflow status

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string WorkflowStatusSaved
Visual Basic (Declaration)
Public Shared ReadOnly WorkflowStatusSaved As String
Visual C++
public:
static initonly String^ WorkflowStatusSaved

See Also

Constants Class
OfficeClip.Utils Namespace


Constants Methods

[image] [image]

OfficeClip API Documentation
Constants Methods
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The Constants type exposes the following methods.

Methods

 | Name | Description
 | DecimalValidationLooseRegularExpression | Regular expression for the decimal expression loosely
 | DecimalValidationRegularExpression | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumericValidationRegularExpression | Overloaded.
 | TimesheetTimeRegularExpression | Validates a signed decimal of any length.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Constants Class
OfficeClip.Utils Namespace


DecimalValidationLooseRegularExpression Method

[image]

OfficeClip API Documentation
Constants..::.DecimalValidationLooseRegularExpression Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Regular expression for the decimal expression loosely

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string DecimalValidationLooseRegularExpression()
Visual Basic (Declaration)
Public Shared Function DecimalValidationLooseRegularExpression As String
Visual C++
public:
static String^ DecimalValidationLooseRegularExpression()

Return Value

The validation regular expression

See Also

Constants Class
OfficeClip.Utils Namespace


DecimalValidationRegularExpression Method

[image] [image]

OfficeClip API Documentation
Constants..::.DecimalValidationRegularExpression Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DecimalValidationRegularExpression()()() | Validates a signed decimal of any length.
DecimalValidationRegularExpression(Int32, Int32) | validates the decimal expression.

See Also

Constants Class
Constants Members
OfficeClip.Utils Namespace


DecimalValidationRegularExpression Method

[image]

OfficeClip API Documentation
Constants..::.DecimalValidationRegularExpression Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Validates a signed decimal of any length.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string DecimalValidationRegularExpression()
Visual Basic (Declaration)
Public Shared Function DecimalValidationRegularExpression As String
Visual C++
public:
static String^ DecimalValidationRegularExpression()

Return Value

the regular expression.

See Also

Constants Class
DecimalValidationRegularExpression Overload
OfficeClip.Utils Namespace


DecimalValidationRegularExpression Method (Int32, Int32)

[image]

OfficeClip API Documentation
Constants..::.DecimalValidationRegularExpression Method (Int32, Int32)
Constants Class See Also

[This is preliminary documentation and is subject to change.]

validates the decimal expression.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string DecimalValidationRegularExpression(
    int beforeDecimal,
    int afterDecimal
)
Visual Basic (Declaration)
Public Shared Function DecimalValidationRegularExpression ( _
    beforeDecimal As Integer, _
    afterDecimal As Integer _
) As String
Visual C++
public:
static String^ DecimalValidationRegularExpression(
    int beforeDecimal,
    int afterDecimal
)

Parameters

beforeDecimal
Type: System..::.Int32
Number of places before the decimal point.
afterDecimal
Type: System..::.Int32
Number of places afterthe decimal point.

Return Value

The regular expression.

See Also

Constants Class
DecimalValidationRegularExpression Overload
OfficeClip.Utils Namespace


NumericValidationRegularExpression Method

[image] [image]

OfficeClip API Documentation
Constants..::.NumericValidationRegularExpression Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
NumericValidationRegularExpression()()() | Validates a signed number of any length
NumericValidationRegularExpression(Int32) | Validates a number of a particular length

See Also

Constants Class
Constants Members
OfficeClip.Utils Namespace


NumericValidationRegularExpression Method

[image]

OfficeClip API Documentation
Constants..::.NumericValidationRegularExpression Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Validates a signed number of any length

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string NumericValidationRegularExpression()
Visual Basic (Declaration)
Public Shared Function NumericValidationRegularExpression As String
Visual C++
public:
static String^ NumericValidationRegularExpression()

Return Value

the regular expression

See Also

Constants Class
NumericValidationRegularExpression Overload
OfficeClip.Utils Namespace


NumericValidationRegularExpression Method (Int32)

[image]

OfficeClip API Documentation
Constants..::.NumericValidationRegularExpression Method (Int32)
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Validates a number of a particular length

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string NumericValidationRegularExpression(
    int numberOfDigits
)
Visual Basic (Declaration)
Public Shared Function NumericValidationRegularExpression ( _
    numberOfDigits As Integer _
) As String
Visual C++
public:
static String^ NumericValidationRegularExpression(
    int numberOfDigits
)

Parameters

numberOfDigits
Type: System..::.Int32

Return Value

See Also

Constants Class
NumericValidationRegularExpression Overload
OfficeClip.Utils Namespace


TimesheetTimeRegularExpression Method

[image]

OfficeClip API Documentation
Constants..::.TimesheetTimeRegularExpression Method
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Validates a signed decimal of any length.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string TimesheetTimeRegularExpression()
Visual Basic (Declaration)
Public Shared Function TimesheetTimeRegularExpression As String
Visual C++
public:
static String^ TimesheetTimeRegularExpression()

Return Value

the regular expression.

See Also

Constants Class
OfficeClip.Utils Namespace


Constants Properties

[image] [image]

OfficeClip API Documentation
Constants Properties
Constants Class See Also

[This is preliminary documentation and is subject to change.]

The Constants type exposes the following properties.

Properties

Name | Description
Blank | Returns the blank string in various locale.
PrivateFolderName | Returns the default private folder name alias
Select | Returns the select string in various locale.
Unspecified | Returns the unspecified string in various locale.

See Also

Constants Class
OfficeClip.Utils Namespace


Blank Property

[image]

OfficeClip API Documentation
Constants..::.Blank Property
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the blank string in various locale.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Blank { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Blank As String
Visual C++
public:
static property String^ Blank {
    String^ get ();
}

See Also

Constants Class
OfficeClip.Utils Namespace


PrivateFolderName Property

[image]

OfficeClip API Documentation
Constants..::.PrivateFolderName Property
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the default private folder name alias

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string PrivateFolderName { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property PrivateFolderName As String
Visual C++
public:
static property String^ PrivateFolderName {
    String^ get ();
}

See Also

Constants Class
OfficeClip.Utils Namespace


Select Property

[image]

OfficeClip API Documentation
Constants..::.Select Property
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the select string in various locale.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Select { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Select As String
Visual C++
public:
static property String^ Select {
    String^ get ();
}

See Also

Constants Class
OfficeClip.Utils Namespace


Unspecified Property

[image]

OfficeClip API Documentation
Constants..::.Unspecified Property
Constants Class See Also

[This is preliminary documentation and is subject to change.]

Returns the unspecified string in various locale.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Unspecified { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Unspecified As String
Visual C++
public:
static property String^ Unspecified {
    String^ get ();
}

See Also

Constants Class
OfficeClip.Utils Namespace


DateTimeConst Class

[image]

OfficeClip API Documentation
DateTimeConst Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class provides functions to return meaningful names for various components of date according to the current locale.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class DateTimeConst
Visual Basic (Declaration)
Public Class DateTimeConst
Visual C++
public ref class DateTimeConst

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.DateTimeConst
OfficeClip.Utils..::.PopulateDateItems

See Also

DateTimeConst Members
OfficeClip.Utils Namespace


DateTimeConst Members

[image] [image]

OfficeClip API Documentation
DateTimeConst Members
DateTimeConst Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The DateTimeConst type exposes the following members.

Constructors

 | Name | Description
Public method | DateTimeConst | Default class constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAbbreviatedDayName | Gets the abbreviated day name
Public method | GetDayNames | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMonthNames | Returns the culture-specific full name of the specified month based on the System.Globalization.CultureInfo of the current thread. System.Globalization..::.DateTimeFormatInfo
Public method | GetRank | Returns the Rank of a particular integer
Public method | GetShortMonthNames | Returns the short name of the specified month based on the CultureOnfo of the current thread.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MediumDateFormat | Returns the medium date format for the current site. The medium date format is used in many places like lists where the short date format is too small and the long date format is too large
MediumDateTimeFormat | Returns the medium Datetime format for the current site. The medium Datetime format is used in many places like lists where the short Datetime format is too small and the long Datetime format is too large
MediumTimeFormat | Returns the medium time format for the current site. The medium time format is used in many places like lists where the short time format is too small and the long time format is too large

See Also

DateTimeConst Class
OfficeClip.Utils Namespace


DateTimeConst Constructor

[image]

OfficeClip API Documentation
DateTimeConst Constructor
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

Default class constructor

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public DateTimeConst()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DateTimeConst()

See Also

DateTimeConst Class
OfficeClip.Utils Namespace


DateTimeConst Methods

[image] [image]

OfficeClip API Documentation
DateTimeConst Methods
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

The DateTimeConst type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAbbreviatedDayName | Gets the abbreviated day name
Public method | GetDayNames | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMonthNames | Returns the culture-specific full name of the specified month based on the System.Globalization.CultureInfo of the current thread. System.Globalization..::.DateTimeFormatInfo
Public method | GetRank | Returns the Rank of a particular integer
Public method | GetShortMonthNames | Returns the short name of the specified month based on the CultureOnfo of the current thread.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DateTimeConst Class
OfficeClip.Utils Namespace


GetAbbreviatedDayName Method

[image]

OfficeClip API Documentation
DateTimeConst..::.GetAbbreviatedDayName Method
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

Gets the abbreviated day name

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string GetAbbreviatedDayName(
    int dayId
)
Visual Basic (Declaration)
Public Function GetAbbreviatedDayName ( _
    dayId As Integer _
) As String
Visual C++
public:
String^ GetAbbreviatedDayName(
    int dayId
)

Parameters

dayId
Type: System..::.Int32
The id of the day (0-6)

Return Value

The abbreviated day name

See Also

DateTimeConst Class
OfficeClip.Utils Namespace


GetDayNames Method

[image] [image]

OfficeClip API Documentation
DateTimeConst..::.GetDayNames Method
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetDayNames(ArrayList) | Returns the comma separated day names given an ArrayList of day id
Public method | GetDayNames(Int32) | Returns the day name in the current culture given the day id.

See Also

DateTimeConst Class
DateTimeConst Members
OfficeClip.Utils Namespace


GetDayNames Method (ArrayList)

[image]

OfficeClip API Documentation
DateTimeConst..::.GetDayNames Method (ArrayList)
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

Returns the comma separated day names given an ArrayList of day id

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string GetDayNames(
    ArrayList dayId
)
Visual Basic (Declaration)
Public Function GetDayNames ( _
    dayId As ArrayList _
) As String
Visual C++
public:
String^ GetDayNames(
    ArrayList^ dayId
)

Parameters

dayId
Type: System.Collections..::.ArrayList
The a\Arraylist of day Id. Each id value can be 0(Sunday) to 6(Saturday)

Return Value

A comma separated list of day names in the current locale

See Also

DateTimeConst Class
GetDayNames Overload
OfficeClip.Utils Namespace


GetDayNames Method (Int32)

[image]

OfficeClip API Documentation
DateTimeConst..::.GetDayNames Method (Int32)
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

Returns the day name in the current culture given the day id.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string GetDayNames(
    int dayId
)
Visual Basic (Declaration)
Public Function GetDayNames ( _
    dayId As Integer _
) As String
Visual C++
public:
String^ GetDayNames(
    int dayId
)

Parameters

dayId
Type: System..::.Int32
The integer id of the day of the week, it spans from 0=Sunday to 6=Saturday

Return Value

The corresponding day name in the current locale

See Also

DateTimeConst Class
GetDayNames Overload
OfficeClip.Utils Namespace


GetMonthNames Method

[image]

OfficeClip API Documentation
DateTimeConst..::.GetMonthNames Method
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

Returns the culture-specific full name of the specified month based on the System.Globalization.CultureInfo of the current thread. System.Globalization..::.DateTimeFormatInfo

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string GetMonthNames(
    int monthId
)
Visual Basic (Declaration)
Public Function GetMonthNames ( _
    monthId As Integer _
) As String
Visual C++
public:
String^ GetMonthNames(
    int monthId
)

Parameters

monthId
Type: System..::.Int32
An integer from 1 through 13 representing the name of the month to retrieve.

Return Value

The culture-specific full name of the month represented by month.

See Also

DateTimeConst Class
OfficeClip.Utils Namespace
System.Globalization..::.DateTimeFormatInfo


GetRank Method

[image]

OfficeClip API Documentation
DateTimeConst..::.GetRank Method
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

Returns the Rank of a particular integer

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string GetRank(
    int rank
)
Visual Basic (Declaration)
Public Function GetRank ( _
    rank As Integer _
) As String
Visual C++
public:
String^ GetRank(
    int rank
)

Parameters

rank
Type: System..::.Int32
The integer for which the rank is to be determined, valid values are 1-5

Return Value

The rank of the integer. For example: 1 is ranked first, 2 as second and so on. 5 is ranked as last. Returns "Error" if the input is not in the range of 1-5.

See Also

DateTimeConst Class
OfficeClip.Utils Namespace


GetShortMonthNames Method

[image]

OfficeClip API Documentation
DateTimeConst..::.GetShortMonthNames Method
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

Returns the short name of the specified month based on the CultureOnfo of the current thread.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string GetShortMonthNames(
    int monthId
)
Visual Basic (Declaration)
Public Function GetShortMonthNames ( _
    monthId As Integer _
) As String
Visual C++
public:
String^ GetShortMonthNames(
    int monthId
)

Parameters

monthId
Type: System..::.Int32
An integer from 1 through 13 representing the name of the month to retrieve.

Return Value

The culture-specific short name of the month represented by month.

See Also

DateTimeConst Class
OfficeClip.Utils Namespace


DateTimeConst Properties

[image] [image]

OfficeClip API Documentation
DateTimeConst Properties
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

The DateTimeConst type exposes the following properties.

Properties

Name | Description
MediumDateFormat | Returns the medium date format for the current site. The medium date format is used in many places like lists where the short date format is too small and the long date format is too large
MediumDateTimeFormat | Returns the medium Datetime format for the current site. The medium Datetime format is used in many places like lists where the short Datetime format is too small and the long Datetime format is too large
MediumTimeFormat | Returns the medium time format for the current site. The medium time format is used in many places like lists where the short time format is too small and the long time format is too large

See Also

DateTimeConst Class
OfficeClip.Utils Namespace


MediumDateFormat Property

[image]

OfficeClip API Documentation
DateTimeConst..::.MediumDateFormat Property
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

Returns the medium date format for the current site. The medium date format is used in many places like lists where the short date format is too small and the long date format is too large

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string MediumDateFormat { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MediumDateFormat As String
Visual C++
public:
static property String^ MediumDateFormat {
    String^ get ();
}

See Also

DateTimeConst Class
OfficeClip.Utils Namespace


MediumDateTimeFormat Property

[image]

OfficeClip API Documentation
DateTimeConst..::.MediumDateTimeFormat Property
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

Returns the medium Datetime format for the current site. The medium Datetime format is used in many places like lists where the short Datetime format is too small and the long Datetime format is too large

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string MediumDateTimeFormat { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MediumDateTimeFormat As String
Visual C++
public:
static property String^ MediumDateTimeFormat {
    String^ get ();
}

See Also

DateTimeConst Class
OfficeClip.Utils Namespace


MediumTimeFormat Property

[image]

OfficeClip API Documentation
DateTimeConst..::.MediumTimeFormat Property
DateTimeConst Class See Also

[This is preliminary documentation and is subject to change.]

Returns the medium time format for the current site. The medium time format is used in many places like lists where the short time format is too small and the long time format is too large

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string MediumTimeFormat { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property MediumTimeFormat As String
Visual C++
public:
static property String^ MediumTimeFormat {
    String^ get ();
}

See Also

DateTimeConst Class
OfficeClip.Utils Namespace


DeleteGroupAppType Enumeration

[image]

OfficeClip API Documentation
DeleteGroupAppType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for deleting various group applications in OfficeClip

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum DeleteGroupAppType
Visual Basic (Declaration)
Public Enumeration DeleteGroupAppType
Visual C++
public enum class DeleteGroupAppType

Members

Member name | Description
DepartmentPresent | Delete all the department present
RegisteredUsers | Delete all the registered users
UnregisteredUsers | delete all the unregistered users
Events | delete all the events
GroupAlerts | delete all the group alerts
Documents | delete all the documents
DocumentFolders | delete all the document folders
ApplicationDocuments | delete all the document which are created by the application
ApplicationDocumentFolders | delete all the folders of the application document
ResourceReservationByUsers | delete all the reservation created by the user
Resources | delete all the resources
GroupBookmarks | delete all the group bookmarks
TrackerProjects | delete all the tracker projects
Polls | delete all the polls
PhotoAlbum | delete the photo album and the photos
Announcements | delete all the announcements
Forums | delete all the forums
Topics | delete all the forum topics
Timesheets | delete all the timesheets
Expenses | delete all the expense reports
GroupAddressBook | delete the group address book

See Also

OfficeClip.Utils Namespace


DocHistoryStatus Enumeration

[image]

OfficeClip API Documentation
DocHistoryStatus Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The status enumerated type of document in the document history.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum DocHistoryStatus
Visual Basic (Declaration)
Public Enumeration DocHistoryStatus
Visual C++
public enum class DocHistoryStatus

Members

Member name | Description
Checkout | The document is checked out.
Checkin | the document is checked in.
UndoCheckout | An undo checkout is done on the document.
DocumentRename | The document is renamed.
ViewDownload | The document is downloaded in the read only mode.
MoveDocument | Teh document is moved.
CopyDocument | The document is copied.
DocumentUpload | The document is uploaded to the OfficeClip server.
CheckoutDownload | The document is downloaded and checked out simulataneously.

See Also

OfficeClip.Utils Namespace


DocNodeType Enumeration

[image]

OfficeClip API Documentation
DocNodeType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides enumerated types for the document nodes.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum DocNodeType
Visual Basic (Declaration)
Public Enumeration DocNodeType
Visual C++
public enum class DocNodeType

Members

Member name | Description
None | Node of unknown type.
Title | Node is a title.
Folder | Node is a folder.
Document | Node is a document.
LinkedDocument | Node is a linked document.
WebSite | Node is a web site.

See Also

OfficeClip.Utils Namespace


DocSelectControl Enumeration

[image]

OfficeClip API Documentation
DocSelectControl Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides enumerated types for the document selection control.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum DocSelectControl
Visual Basic (Declaration)
Public Enumeration DocSelectControl
Visual C++
public enum class DocSelectControl

Members

Member name | Description
None | Document Select control is not present.
CheckBoxInNode | There is a checkbox in the node (directories).
CheckBoxInLeaf | There is a checkbox in the leaves(files).
CheckBoxAll | Checkbox is present in both nodes and leaves.
RadioButtonInNode | A Radio button is present in all the nodes(directories).
RadioButtonInLeaf | A radio button is present in all the leaves(files).
RadioButtonAll | Radio button is present in both leaves and nodes.

See Also

OfficeClip.Utils Namespace


DocTreeLeafSortType Enumeration

[image]

OfficeClip API Documentation
DocTreeLeafSortType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Shows how the document tree leaves are sorted

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum DocTreeLeafSortType
Visual Basic (Declaration)
Public Enumeration DocTreeLeafSortType
Visual C++
public enum class DocTreeLeafSortType

Members

Member name | Description
None | Keeps the order the same as it was created.
Name | Sort by document name.
Size | sort by document size.
Type | sort by document type.
ModifiedBy | sort by modified by user id.
ModifiedDate | sort by modified by date.

See Also

OfficeClip.Utils Namespace


DocTreeType Enumeration

[image]

OfficeClip API Documentation
DocTreeType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The Document tree type can be private or public

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum DocTreeType
Visual Basic (Declaration)
Public Enumeration DocTreeType
Visual C++
public enum class DocTreeType

Members

Member name | Description
Private | The document tree is private (mainly for the user).
Public | The document tree is public (mainly for the group).
Both | The document tree can be either private or public.

See Also

OfficeClip.Utils Namespace


DocumentStorageType Enumeration

[image]

OfficeClip API Documentation
DocumentStorageType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides enumerated type for the Document storage types.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum DocumentStorageType
Visual Basic (Declaration)
Public Enumeration DocumentStorageType
Visual C++
public enum class DocumentStorageType

Members

Member name | Description
Private | Private document storage type
Group | Group document storage type
Account | Account storage type

See Also

OfficeClip.Utils Namespace


EmailAttachmentStatus Enumeration

[image]

OfficeClip API Documentation
EmailAttachmentStatus Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for email attachment status.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum EmailAttachmentStatus
Visual Basic (Declaration)
Public Enumeration EmailAttachmentStatus
Visual C++
public enum class EmailAttachmentStatus

Members

Member name | Description
Unkown | Unknown status.
WithAttachments | email with attachments.
WithoutAttachments | Email without attachments.

See Also

OfficeClip.Utils Namespace


EmailFolders Enumeration

[image]

OfficeClip API Documentation
EmailFolders Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides enumerated types for the various types of email folders.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum EmailFolders
Visual Basic (Declaration)
Public Enumeration EmailFolders
Visual C++
public enum class EmailFolders

Members

Member name | Description
None | Inbox folder.
InBox | Inbox folder.
SentMessages | Sent Messages folder.
Drafts | Folder to save drafts, Drafts are saved when the email could be composed, but could not be sent immediately.
Deleted | The deleted folder.
UserDefined | The user defined folder. User can create their own folders.

See Also

OfficeClip.Utils Namespace


EmailPriority Enumeration

[image]

OfficeClip API Documentation
EmailPriority Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types for email Priority.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum EmailPriority
Visual Basic (Declaration)
Public Enumeration EmailPriority
Visual C++
public enum class EmailPriority

Members

Member name | Description
None | No or unknown Priority.
Low | Low Priority.
Medium | Medium Priority.
High | High Priority.

See Also

OfficeClip.Utils Namespace


EmailSearchBySize Enumeration

[image]

OfficeClip API Documentation
EmailSearchBySize Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types of email search by its size logical operator.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum EmailSearchBySize
Visual Basic (Declaration)
Public Enumeration EmailSearchBySize
Visual C++
public enum class EmailSearchBySize

Members

Member name | Description
DoesntMatter | Size does not matter.
Equals | Size equal to a value.
BetweenRange | Size between a particular range.
LessThanValue | Size less than a particular value.
GreaterThanValue | Size greater than a particular value.

See Also

OfficeClip.Utils Namespace


EmailSearchByTime Enumeration

[image]

OfficeClip API Documentation
EmailSearchByTime Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for email search by time.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum EmailSearchByTime
Visual Basic (Declaration)
Public Enumeration EmailSearchByTime
Visual C++
public enum class EmailSearchByTime

Members

Member name | Description
Anytime | No time limit for search.
Yesterday | Search email for yesterday.
Today | Search email for today.
InLastSevenDays | Search email in last seven days.
LastWeek | Search email in the last week.
ThisWeek | Search email in this week.

See Also

OfficeClip.Utils Namespace


EmailSearchIn Enumeration

[image]

OfficeClip API Documentation
EmailSearchIn Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type of email search field

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum EmailSearchIn
Visual Basic (Declaration)
Public Enumeration EmailSearchIn
Visual C++
public enum class EmailSearchIn

Members

Member name | Description
Subject | Allows search by subject.
SubjectAndText | Allows search by email subject and text o fthe email.

See Also

OfficeClip.Utils Namespace


EmailStatus Enumeration

[image]

OfficeClip API Documentation
EmailStatus Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The enumerated type for email status.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum EmailStatus
Visual Basic (Declaration)
Public Enumeration EmailStatus
Visual C++
public enum class EmailStatus

Members

Member name | Description
Unknown | Unknown email status.
Unread | Status showing that the email is not read.
Read | Status showing that the email is read.
Replied | Status showing that the email is replied to.
Forwarded | Status showing that the email is forwarded.
RepliedToAll | Status showing that the email is being replied to all the person to whom the email was originally sent.

See Also

OfficeClip.Utils Namespace


EmailTimestamps Enumeration

[image]

OfficeClip API Documentation
EmailTimestamps Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types for the email timestamps

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum EmailTimestamps
Visual Basic (Declaration)
Public Enumeration EmailTimestamps
Visual C++
public enum class EmailTimestamps

Members

Member name | Description
None | Unknown or no timestamp.
Received | Timestamp showing that the email is received.
Sent | Timestamp showing that the email is sent.
Replied | Timestamp showing that the email is replied to.
Forwarded | Timstamp showing that the email is forwarded to.
Created | Timestamp showing that the email is created.

See Also

OfficeClip.Utils Namespace


EventShowAs Enumeration

[image]

OfficeClip API Documentation
EventShowAs Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Various user status in response to an event

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum EventShowAs
Visual Basic (Declaration)
Public Enumeration EventShowAs
Visual C++
public enum class EventShowAs

Members

Member name | Description
Busy | The user is set busy for the particular time in the calendar
Free | The user is set free for the particular time in the calendar
OutOfOffice | The user is set Out Of Office for the particular time in the calendar
Tentative | The user is set tentative for the particular time in the calendar

See Also

OfficeClip.Utils Namespace


EventType Enumeration

[image]

OfficeClip API Documentation
EventType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for various kinds of calendar events

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum EventType
Visual Basic (Declaration)
Public Enumeration EventType
Visual C++
public enum class EventType

Members

Member name | Description
None | Default event type (not set!)
GroupEvent | The event which all members of the group can share
Meeting | The meeting event which can only be seen by its members
PersonalEvent | The personal or private event

See Also

OfficeClip.Utils Namespace


ExceptionType Enumeration

[image]

OfficeClip API Documentation
ExceptionType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for all the OfficeClip Exception types

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum ExceptionType
Visual Basic (Declaration)
Public Enumeration ExceptionType
Visual C++
public enum class ExceptionType

Members

Member name | Description
NoError | Not an exception, provided for default value
UnknownError | The cause of the exception could not be determined
SystemError | The exception caused by the system error, e.g. disk failure.
ProgramError | The exception caused by error in OfficeClip programming
AssertionError | Exception caused by the assertion failure, note: only debug version of the library will show this error.
DatabaseError | Exception caused by the database.
SecurityError | Exception caused by the OfficeClip security violation
ConfigurationError | Exception caused by error in configuration of OfficeClip
FileSystemError | Exception caused by the error in file system, i.e a file could not be accessed

See Also

OfficeClip.Utils Namespace


GroupSelection Enumeration

[image]

OfficeClip API Documentation
GroupSelection Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for the group selection in various applications including the calendar and the bulletin board

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum GroupSelection
Visual Basic (Declaration)
Public Enumeration GroupSelection
Visual C++
public enum class GroupSelection

Members

Member name | Description
None | Default
AllGroups | Selects all the groups
CurrentGroup | Selects only the current group
Private | selects the private group
CurrentGroupWithoutPrivate | The current group information without any private information

See Also

OfficeClip.Utils Namespace


GroupType Enumeration

[image]

OfficeClip API Documentation
GroupType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumearted types for various types of groups in the User MAnager

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum GroupType
Visual Basic (Declaration)
Public Enumeration GroupType
Visual C++
public enum class GroupType

Members

Member name | Description
Department | Departments are like groups but has dependency on the organization. A member of a department automatically becomes a member of an organization.
Organization | Organization are group types which are parent of the departments. Various departments can be created under an organization.
None | Provided as a default value and error checking.

See Also

OfficeClip.Utils Namespace


LastVisited Enumeration

[image]

OfficeClip API Documentation
LastVisited Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides enumerated types for the last visited application. The last visited application is enterd into the profile as OFF=6/2/2001 8:1:00;CAL=;RMD=;BBD=;BMK=;RSV=;TMS=;TRK=;.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum LastVisited
Visual Basic (Declaration)
Public Enumeration LastVisited
Visual C++
public enum class LastVisited

Members

Member name | Description
OfficeAgent | The User Manager application.
Calendar | The Calendar application.
Reminder | The Reminder application.
BulletinBoard | The Bulletin Board application.
Bookmark | The Bookmark application.
Reservations | The Reservations application.
TE | The Time and Expenses application.
Tracker | The Tracker application.
Documents | The document management application.

See Also

OfficeClip.Utils Namespace


LoginAuthenticationMode Enumeration

[image]

OfficeClip API Documentation
LoginAuthenticationMode Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The login authentication type that is used to login to OfficeClip

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum LoginAuthenticationMode
Visual Basic (Declaration)
Public Enumeration LoginAuthenticationMode
Visual C++
public enum class LoginAuthenticationMode

Members

Member name | Description
FormsAnonymous | The Authentication mode in forms and anonymous
WindowsAuthenticated | The Authentication mode is windows and authenticated
LDAPAnonymous | The Authentication mode is LDAP and anonymous

See Also

OfficeClip.Utils Namespace


OCConvert Class

[image]

OfficeClip API Documentation
OCConvert Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides some common data conversion functions used throughout OfficeClip

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCConvert
Visual Basic (Declaration)
Public Class OCConvert
Visual C++
public ref class OCConvert

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCConvert

See Also

OCConvert Members
OfficeClip.Utils Namespace


OCConvert Members

[image] [image]

OfficeClip API Documentation
OCConvert Members
OCConvert Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCConvert type exposes the following members.

Constructors

 | Name | Description
Public method | OCConvert |

Methods

 | Name | Description
 | ConvertIntCSVToArrayList | Converts a comma separated list into an arraylist
 | ConvertTrackerBooleanDBToScreen | Overloaded.
 | ConvertTrackerScreenToBooleanDB | Converts the boolean values on the tracker screen to its database representation to store in the database. In general the database stores the values as '0' and '1', and the user sees them on the screen as the localized version of "Yes" and "No".
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FoldString | Folds the string so that if it is more than 75 characters, it adds a CRLF and a blank space
 | FromBase64String | Overloaded.
 | FromBase64UrlSafeString | Takes a base64 encoded string that has been modified and replaces the -,_,! characters with the +,/,= characters respectively
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseFullName | Converts the user name in proper format
 | ToArrayIdsFromStringIds | Converts string containing various integers delimited with a character to an arraylist.
 | ToArrayList | Converts an array to an arraylist
 | ToBase64String | Overloaded.
 | ToBase64UrlSafeString | Takes a base64 encoded string and replaces the +,/,= characters with the -,_,! characters respectively
 | ToDate | Parse a string to datetime format
 | ToDiskAppPath | This function is used to translate the apppaths obtained from the OCResources to the disk path
 | ToDiskPath | This function is used to translate the xml and xsd files, where disk file is required
 | ToDouble | Converts the string to double. This method, unlike the dotnet framework, does not throw any exception. Instead it returns 0.0 if the string cannot be converted to double.
 | ToFullName | Overloaded.
 | ToGroup | Converts groups into grouptype format
 | ToJavascriptConfirmString | Formats the javascript confirm string that is used in many delete buttons.
 | ToReminderDateTime | Extracts the remind at datetime from the startdatetime and remindnow
 | ToReminderText | Extracts the text used for the reminders
 | ToResourcePath | Return the disk path of the resource folder
 | ToShortDateString | Returns the string representation of the datetime to short date format
 | ToShortTimeString | Returns the string representation of the datetime to short time format
 | ToString | Overloaded.
 | ToUploadGroupPath | Return the disk path of the upload folder for group
 | ToUploadUserPath | Return the disk path of the upload folder for user
 | UnFoldString | Unfolds a folded string. Unfolding means merging the following patterns into a single string \r\n followed by a whitespace character

Properties

Name | Description
DemoGuardAlertString | Returns the demo guard alert string to be used by the javascript that shows the alert if any restricted function is attempted on the demo account.

See Also

OCConvert Class
OfficeClip.Utils Namespace


OCConvert Constructor

[image]

OfficeClip API Documentation
OCConvert Constructor
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCConvert()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCConvert()

See Also

OCConvert Class
OfficeClip.Utils Namespace


OCConvert Methods

[image] [image]

OfficeClip API Documentation
OCConvert Methods
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

The OCConvert type exposes the following methods.

Methods

 | Name | Description
 | ConvertIntCSVToArrayList | Converts a comma separated list into an arraylist
 | ConvertTrackerBooleanDBToScreen | Overloaded.
 | ConvertTrackerScreenToBooleanDB | Converts the boolean values on the tracker screen to its database representation to store in the database. In general the database stores the values as '0' and '1', and the user sees them on the screen as the localized version of "Yes" and "No".
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FoldString | Folds the string so that if it is more than 75 characters, it adds a CRLF and a blank space
 | FromBase64String | Overloaded.
 | FromBase64UrlSafeString | Takes a base64 encoded string that has been modified and replaces the -,_,! characters with the +,/,= characters respectively
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseFullName | Converts the user name in proper format
 | ToArrayIdsFromStringIds | Converts string containing various integers delimited with a character to an arraylist.
 | ToArrayList | Converts an array to an arraylist
 | ToBase64String | Overloaded.
 | ToBase64UrlSafeString | Takes a base64 encoded string and replaces the +,/,= characters with the -,_,! characters respectively
 | ToDate | Parse a string to datetime format
 | ToDiskAppPath | This function is used to translate the apppaths obtained from the OCResources to the disk path
 | ToDiskPath | This function is used to translate the xml and xsd files, where disk file is required
 | ToDouble | Converts the string to double. This method, unlike the dotnet framework, does not throw any exception. Instead it returns 0.0 if the string cannot be converted to double.
 | ToFullName | Overloaded.
 | ToGroup | Converts groups into grouptype format
 | ToJavascriptConfirmString | Formats the javascript confirm string that is used in many delete buttons.
 | ToReminderDateTime | Extracts the remind at datetime from the startdatetime and remindnow
 | ToReminderText | Extracts the text used for the reminders
 | ToResourcePath | Return the disk path of the resource folder
 | ToShortDateString | Returns the string representation of the datetime to short date format
 | ToShortTimeString | Returns the string representation of the datetime to short time format
 | ToString | Overloaded.
 | ToUploadGroupPath | Return the disk path of the upload folder for group
 | ToUploadUserPath | Return the disk path of the upload folder for user
 | UnFoldString | Unfolds a folded string. Unfolding means merging the following patterns into a single string \r\n followed by a whitespace character

See Also

OCConvert Class
OfficeClip.Utils Namespace


ConvertIntCSVToArrayList Method

[image]

OfficeClip API Documentation
OCConvert..::.ConvertIntCSVToArrayList Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts a comma separated list into an arraylist

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static ArrayList ConvertIntCSVToArrayList(
    string idList
)
Visual Basic (Declaration)
Public Shared Function ConvertIntCSVToArrayList ( _
    idList As String _
) As ArrayList
Visual C++
public:
static ArrayList^ ConvertIntCSVToArrayList(
    String^ idList
)

Parameters

idList
Type: System..::.String
The comma separated list of Ids

Return Value

The arraylist of Ids

See Also

OCConvert Class
OfficeClip.Utils Namespace


ConvertTrackerBooleanDBToScreen Method

[image] [image]

OfficeClip API Documentation
OCConvert..::.ConvertTrackerBooleanDBToScreen Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertTrackerBooleanDBToScreen(String) | Converts the boolean values on the tracker database to its screen representation . In general the database stores the values as '0' and '1', and the user sees them on the screen as the localized version of "Yes" and "No".
ConvertTrackerBooleanDBToScreen(DataSet, Int32, Int32) | Translates all the boolean on the case list

See Also

OCConvert Class
OCConvert Members
OfficeClip.Utils Namespace


ConvertTrackerBooleanDBToScreen Method (String)

[image]

OfficeClip API Documentation
OCConvert..::.ConvertTrackerBooleanDBToScreen Method (String)
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the boolean values on the tracker database to its screen representation . In general the database stores the values as '0' and '1', and the user sees them on the screen as the localized version of "Yes" and "No".

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertTrackerBooleanDBToScreen(
    string tciVal
)
Visual Basic (Declaration)
Public Shared Function ConvertTrackerBooleanDBToScreen ( _
    tciVal As String _
) As String
Visual C++
public:
static String^ ConvertTrackerBooleanDBToScreen(
    String^ tciVal
)

Parameters

tciVal
Type: System..::.String
The database values, It can be "0" or "1"

Return Value

This can only be "Yes" or "No"

See Also

OCConvert Class
ConvertTrackerBooleanDBToScreen Overload
OfficeClip.Utils Namespace


ConvertTrackerBooleanDBToScreen Method (DataSet, Int32, Int32)

[image]

OfficeClip API Documentation
OCConvert..::.ConvertTrackerBooleanDBToScreen Method (DataSet, Int32, Int32)
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Translates all the boolean on the case list

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ConvertTrackerBooleanDBToScreen(
    DataSet ds,
    int fieldTable,
    int dataTable
)
Visual Basic (Declaration)
Public Shared Sub ConvertTrackerBooleanDBToScreen ( _
    ds As DataSet, _
    fieldTable As Integer, _
    dataTable As Integer _
)
Visual C++
public:
static void ConvertTrackerBooleanDBToScreen(
    DataSet^ ds,
    int fieldTable,
    int dataTable
)

Parameters

ds
Type: System.Data..::.DataSet
The entire caselist dataset
fieldTable
Type: System..::.Int32
The index of the table on the dataset where the field information is stored
dataTable
Type: System..::.Int32
The index of the table on the dataset where the data information is stored

See Also

OCConvert Class
ConvertTrackerBooleanDBToScreen Overload
OfficeClip.Utils Namespace


ConvertTrackerScreenToBooleanDB Method

[image]

OfficeClip API Documentation
OCConvert..::.ConvertTrackerScreenToBooleanDB Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the boolean values on the tracker screen to its database representation to store in the database. In general the database stores the values as '0' and '1', and the user sees them on the screen as the localized version of "Yes" and "No".

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertTrackerScreenToBooleanDB(
    string tciVal
)
Visual Basic (Declaration)
Public Shared Function ConvertTrackerScreenToBooleanDB ( _
    tciVal As String _
) As String
Visual C++
public:
static String^ ConvertTrackerScreenToBooleanDB(
    String^ tciVal
)

Parameters

tciVal
Type: System..::.String
The screen values, If the culture is US English, possible values are "Yes" and "No"

Return Value

The output screen can be "0"(corresponds to "No") or "1" (corresponds to "Yes")

See Also

OCConvert Class
OfficeClip.Utils Namespace


FoldString Method

[image]

OfficeClip API Documentation
OCConvert..::.FoldString Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Folds the string so that if it is more than 75 characters, it adds a CRLF and a blank space

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string FoldString(
    string str
)
Visual Basic (Declaration)
Public Shared Function FoldString ( _
    str As String _
) As String
Visual C++
public:
static String^ FoldString(
    String^ str
)

Parameters

str
Type: System..::.String
The input string to be folded

Return Value

The folded string

See Also

OCConvert Class
OfficeClip.Utils Namespace


FromBase64String Method

[image] [image]

OfficeClip API Documentation
OCConvert..::.FromBase64String Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FromBase64String(String) | Converts a string from the base64 encoding
FromBase64String(String, Boolean) | Extracts a string from its base64 equivalent.

See Also

OCConvert Class
OCConvert Members
OfficeClip.Utils Namespace


FromBase64String Method (String)

[image]

OfficeClip API Documentation
OCConvert..::.FromBase64String Method (String)
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts a string from the base64 encoding

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string FromBase64String(
    string str
)
Visual Basic (Declaration)
Public Shared Function FromBase64String ( _
    str As String _
) As String
Visual C++
public:
static String^ FromBase64String(
    String^ str
)

Parameters

str
Type: System..::.String
The base 64 encoded string

Return Value

The extracted string

See Also

OCConvert Class
FromBase64String Overload
OfficeClip.Utils Namespace


FromBase64String Method (String, Boolean)

[image]

OfficeClip API Documentation
OCConvert..::.FromBase64String Method (String, Boolean)
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Extracts a string from its base64 equivalent.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string FromBase64String(
    string str,
    bool isUrlSafe
)
Visual Basic (Declaration)
Public Shared Function FromBase64String ( _
    str As String, _
    isUrlSafe As Boolean _
) As String
Visual C++
public:
static String^ FromBase64String(
    String^ str,
    bool isUrlSafe
)

Parameters

str
Type: System..::.String
The base64 string.
isUrlSafe
Type: System..::.Boolean
Determines if the encoded string is url safe

Return Value

The extracted string.

See Also

OCConvert Class
FromBase64String Overload
OfficeClip.Utils Namespace


FromBase64UrlSafeString Method

[image]

OfficeClip API Documentation
OCConvert..::.FromBase64UrlSafeString Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Takes a base64 encoded string that has been modified and replaces the -,_,! characters with the +,/,= characters respectively

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string FromBase64UrlSafeString(
    string base64ModifiedString
)
Visual Basic (Declaration)
Public Shared Function FromBase64UrlSafeString ( _
    base64ModifiedString As String _
) As String
Visual C++
public:
static String^ FromBase64UrlSafeString(
    String^ base64ModifiedString
)

Parameters

base64ModifiedString
Type: System..::.String
base64 modified encoded

Return Value

See Also

OCConvert Class
OfficeClip.Utils Namespace


ParseFullName Method

[image]

OfficeClip API Documentation
OCConvert..::.ParseFullName Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the user name in proper format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string[] ParseFullName(
    string name,
    SortByName mode
)
Visual Basic (Declaration)
Public Shared Function ParseFullName ( _
    name As String, _
    mode As SortByName _
) As String()
Visual C++
public:
static array<String^>^ ParseFullName(
    String^ name,
    SortByName mode
)

Parameters

name
Type: System..::.String
The name of the user
mode
Type: OfficeClip.Utils..::.SortByName
Determines the format of the output

Return Value

The name in the correct format

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToArrayIdsFromStringIds Method

[image]

OfficeClip API Documentation
OCConvert..::.ToArrayIdsFromStringIds Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts string containing various integers delimited with a character to an arraylist.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static ArrayList ToArrayIdsFromStringIds(
    string stringList,
    char delimiter
)
Visual Basic (Declaration)
Public Shared Function ToArrayIdsFromStringIds ( _
    stringList As String, _
    delimiter As Char _
) As ArrayList
Visual C++
public:
static ArrayList^ ToArrayIdsFromStringIds(
    String^ stringList,
    wchar_t delimiter
)

Parameters

stringList
Type: System..::.String
The list of delimited integers
delimiter
Type: System..::.Char
The delimiter character

Return Value

The arraylist that contains all the integers of the delimited string

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToArrayList Method

[image]

OfficeClip API Documentation
OCConvert..::.ToArrayList Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts an array to an arraylist

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static ArrayList ToArrayList(
    Object[] arr
)
Visual Basic (Declaration)
Public Shared Function ToArrayList ( _
    arr As Object() _
) As ArrayList
Visual C++
public:
static ArrayList^ ToArrayList(
    array<Object^>^ arr
)

Parameters

arr
Type: array<System..::.Object>[]()[]
The input array

Return Value

The output arraylist

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToBase64String Method

[image] [image]

OfficeClip API Documentation
OCConvert..::.ToBase64String Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ToBase64String(String) | Converts a string to base 64 encoding
ToBase64String(String, Boolean) | Converts a string to its base64 equivalent.

See Also

OCConvert Class
OCConvert Members
OfficeClip.Utils Namespace


ToBase64String Method (String)

[image]

OfficeClip API Documentation
OCConvert..::.ToBase64String Method (String)
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts a string to base 64 encoding

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToBase64String(
    string str
)
Visual Basic (Declaration)
Public Shared Function ToBase64String ( _
    str As String _
) As String
Visual C++
public:
static String^ ToBase64String(
    String^ str
)

Parameters

str
Type: System..::.String
The string to be encoded

Return Value

The encoded string

See Also

OCConvert Class
ToBase64String Overload
OfficeClip.Utils Namespace


ToBase64String Method (String, Boolean)

[image]

OfficeClip API Documentation
OCConvert..::.ToBase64String Method (String, Boolean)
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts a string to its base64 equivalent.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToBase64String(
    string str,
    bool isUrlSafe
)
Visual Basic (Declaration)
Public Shared Function ToBase64String ( _
    str As String, _
    isUrlSafe As Boolean _
) As String
Visual C++
public:
static String^ ToBase64String(
    String^ str,
    bool isUrlSafe
)

Parameters

str
Type: System..::.String
the input string to be converted.
isUrlSafe
Type: System..::.Boolean
Determines if the url safe nature of the string is desired.

Return Value

the base64 converted string.

See Also

OCConvert Class
ToBase64String Overload
OfficeClip.Utils Namespace


ToBase64UrlSafeString Method

[image]

OfficeClip API Documentation
OCConvert..::.ToBase64UrlSafeString Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Takes a base64 encoded string and replaces the +,/,= characters with the -,_,! characters respectively

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToBase64UrlSafeString(
    string base64InputString
)
Visual Basic (Declaration)
Public Shared Function ToBase64UrlSafeString ( _
    base64InputString As String _
) As String
Visual C++
public:
static String^ ToBase64UrlSafeString(
    String^ base64InputString
)

Parameters

base64InputString
Type: System..::.String
input base64 encoded string

Return Value

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToDate Method

[image]

OfficeClip API Documentation
OCConvert..::.ToDate Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Parse a string to datetime format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime ToDate(
    string strDateTime,
    string format,
    bool isThorough
)
Visual Basic (Declaration)
Public Shared Function ToDate ( _
    strDateTime As String, _
    format As String, _
    isThorough As Boolean _
) As DateTime
Visual C++
public:
static DateTime ToDate(
    String^ strDateTime,
    String^ format,
    bool isThorough
)

Parameters

strDateTime
Type: System..::.String
The string to be converted
format
Type: System..::.String
The format of the string
isThorough
Type: System..::.Boolean
Do a thorough parse, in case the user made a mistake in the format string

Return Value

The datetime string

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToDiskAppPath Method

[image]

OfficeClip API Documentation
OCConvert..::.ToDiskAppPath Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

This function is used to translate the apppaths obtained from the OCResources to the disk path

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToDiskAppPath(
    string name
)
Visual Basic (Declaration)
Public Shared Function ToDiskAppPath ( _
    name As String _
) As String
Visual C++
public:
static String^ ToDiskAppPath(
    String^ name
)

Parameters

name
Type: System..::.String
The app path path of the file

Return Value

The real path of the file on the disk

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToDiskPath Method

[image]

OfficeClip API Documentation
OCConvert..::.ToDiskPath Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

This function is used to translate the xml and xsd files, where disk file is required

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToDiskPath(
    string name
)
Visual Basic (Declaration)
Public Shared Function ToDiskPath ( _
    name As String _
) As String
Visual C++
public:
static String^ ToDiskPath(
    String^ name
)

Parameters

name
Type: System..::.String
The virtual path of the file

Return Value

The real name of the file

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToDouble Method

[image]

OfficeClip API Documentation
OCConvert..::.ToDouble Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the string to double. This method, unlike the dotnet framework, does not throw any exception. Instead it returns 0.0 if the string cannot be converted to double.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static double ToDouble(
    string str
)
Visual Basic (Declaration)
Public Shared Function ToDouble ( _
    str As String _
) As Double
Visual C++
public:
static double ToDouble(
    String^ str
)

Parameters

str
Type: System..::.String
The string that needs to be converted to double.

Return Value

The double representation of the string

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToFullName Method

[image] [image]

OfficeClip API Documentation
OCConvert..::.ToFullName Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ToFullName(String, String) | Converts the name parts into full name in lastname, first format
ToFullName(String, String, SortByName) | Outputs the name by first name or last ame
ToFullName(String, String, String) | Outputs the full name with the email address

See Also

OCConvert Class
OCConvert Members
OfficeClip.Utils Namespace


ToFullName Method (String, String)

[image]

OfficeClip API Documentation
OCConvert..::.ToFullName Method (String, String)
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the name parts into full name in lastname, first format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToFullName(
    string lastName,
    string firstName
)
Visual Basic (Declaration)
Public Shared Function ToFullName ( _
    lastName As String, _
    firstName As String _
) As String
Visual C++
public:
static String^ ToFullName(
    String^ lastName,
    String^ firstName
)

Parameters

lastName
Type: System..::.String
The last name
firstName
Type: System..::.String
The first name

Return Value

The full name of the user

See Also

OCConvert Class
ToFullName Overload
OfficeClip.Utils Namespace


ToFullName Method (String, String, SortByName)

[image]

OfficeClip API Documentation
OCConvert..::.ToFullName Method (String, String, SortByName)
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Outputs the name by first name or last ame

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToFullName(
    string lastName,
    string firstName,
    SortByName sbn
)
Visual Basic (Declaration)
Public Shared Function ToFullName ( _
    lastName As String, _
    firstName As String, _
    sbn As SortByName _
) As String
Visual C++
public:
static String^ ToFullName(
    String^ lastName,
    String^ firstName,
    SortByName sbn
)

Parameters

lastName
Type: System..::.String
The last name
firstName
Type: System..::.String
The first name
sbn
Type: OfficeClip.Utils..::.SortByName
Determines whether the name should be given by first name or last name

Return Value

The full name

See Also

OCConvert Class
ToFullName Overload
OfficeClip.Utils Namespace


ToFullName Method (String, String, String)

[image]

OfficeClip API Documentation
OCConvert..::.ToFullName Method (String, String, String)
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Outputs the full name with the email address

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToFullName(
    string lastName,
    string firstName,
    string emailAddress
)
Visual Basic (Declaration)
Public Shared Function ToFullName ( _
    lastName As String, _
    firstName As String, _
    emailAddress As String _
) As String
Visual C++
public:
static String^ ToFullName(
    String^ lastName,
    String^ firstName,
    String^ emailAddress
)

Parameters

lastName
Type: System..::.String
The last name
firstName
Type: System..::.String
The first name
emailAddress
Type: System..::.String
The email address

Return Value

The name in the format lastname, firstname (email-address)

See Also

OCConvert Class
ToFullName Overload
OfficeClip.Utils Namespace


ToGroup Method

[image]

OfficeClip API Documentation
OCConvert..::.ToGroup Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts groups into grouptype format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static GroupType ToGroup(
    string gType
)
Visual Basic (Declaration)
Public Shared Function ToGroup ( _
    gType As String _
) As GroupType
Visual C++
public:
static GroupType ToGroup(
    String^ gType
)

Parameters

gType
Type: System..::.String
a single digit group type

Return Value

the grouptype as specified in the Constants

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToJavascriptConfirmString Method

[image]

OfficeClip API Documentation
OCConvert..::.ToJavascriptConfirmString Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Formats the javascript confirm string that is used in many delete buttons.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToJavascriptConfirmString(
    string confirmStr
)
Visual Basic (Declaration)
Public Shared Function ToJavascriptConfirmString ( _
    confirmStr As String _
) As String
Visual C++
public:
static String^ ToJavascriptConfirmString(
    String^ confirmStr
)

Parameters

confirmStr
Type: System..::.String
The string to be shown

Return Value

The formatted string suitable for use as a javascript function

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToReminderDateTime Method

[image]

OfficeClip API Documentation
OCConvert..::.ToReminderDateTime Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Extracts the remind at datetime from the startdatetime and remindnow

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime ToReminderDateTime(
    DateTime startTime,
    string whenToRemind
)
Visual Basic (Declaration)
Public Shared Function ToReminderDateTime ( _
    startTime As DateTime, _
    whenToRemind As String _
) As DateTime
Visual C++
public:
static DateTime ToReminderDateTime(
    DateTime startTime,
    String^ whenToRemind
)

Parameters

startTime
Type: System..::.DateTime
The datetime of the event for which the reminder is required
whenToRemind
Type: System..::.String
The string representation of when to call the reminder

Return Value

The datetime when the reminder should be called

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToReminderText Method

[image]

OfficeClip API Documentation
OCConvert..::.ToReminderText Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Extracts the text used for the reminders

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToReminderText(
    DateTime startTime,
    DateTime remindTime
)
Visual Basic (Declaration)
Public Shared Function ToReminderText ( _
    startTime As DateTime, _
    remindTime As DateTime _
) As String
Visual C++
public:
static String^ ToReminderText(
    DateTime startTime,
    DateTime remindTime
)

Parameters

startTime
Type: System..::.DateTime
The start time
remindTime
Type: System..::.DateTime
The remind time

Return Value

The reminder text

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToResourcePath Method

[image]

OfficeClip API Documentation
OCConvert..::.ToResourcePath Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Return the disk path of the resource folder

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToResourcePath(
    string name
)
Visual Basic (Declaration)
Public Shared Function ToResourcePath ( _
    name As String _
) As String
Visual C++
public:
static String^ ToResourcePath(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the path

Return Value

The full disk path of the resource folder

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToShortDateString Method

[image]

OfficeClip API Documentation
OCConvert..::.ToShortDateString Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Returns the string representation of the datetime to short date format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToShortDateString(
    DateTime dt
)
Visual Basic (Declaration)
Public Shared Function ToShortDateString ( _
    dt As DateTime _
) As String
Visual C++
public:
static String^ ToShortDateString(
    DateTime dt
)

Parameters

dt
Type: System..::.DateTime
The datetime for which the string representation is desired

Return Value

The string representation of the datetime

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToShortTimeString Method

[image]

OfficeClip API Documentation
OCConvert..::.ToShortTimeString Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Returns the string representation of the datetime to short time format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToShortTimeString(
    DateTime dt
)
Visual Basic (Declaration)
Public Shared Function ToShortTimeString ( _
    dt As DateTime _
) As String
Visual C++
public:
static String^ ToShortTimeString(
    DateTime dt
)

Parameters

dt
Type: System..::.DateTime
The datetime for which the string representation is desired

Return Value

The string representation of the datetime

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToString Method

[image] [image]

OfficeClip API Documentation
OCConvert..::.ToString Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToString(GroupType) | Converts the GroupType to string
 | ToString(GroupType, Boolean) | Converts the GroupType to string

See Also

OCConvert Class
OCConvert Members
OfficeClip.Utils Namespace


ToString Method (GroupType)

[image]

OfficeClip API Documentation
OCConvert..::.ToString Method (GroupType)
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the GroupType to string

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToString(
    GroupType gt
)
Visual Basic (Declaration)
Public Shared Function ToString ( _
    gt As GroupType _
) As String
Visual C++
public:
static String^ ToString(
    GroupType gt
)

Parameters

gt
Type: OfficeClip.Utils..::.GroupType
The group type

Return Value

returns the group type as string

See Also

OCConvert Class
ToString Overload
OfficeClip.Utils Namespace


ToString Method (GroupType, Boolean)

[image]

OfficeClip API Documentation
OCConvert..::.ToString Method (GroupType, Boolean)
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Converts the GroupType to string

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToString(
    GroupType gt,
    bool isShort
)
Visual Basic (Declaration)
Public Shared Function ToString ( _
    gt As GroupType, _
    isShort As Boolean _
) As String
Visual C++
public:
static String^ ToString(
    GroupType gt,
    bool isShort
)

Parameters

gt
Type: OfficeClip.Utils..::.GroupType
The group type
isShort
Type: System..::.Boolean
if true only the first character is returned

Return Value

returns the group type as string

See Also

OCConvert Class
ToString Overload
OfficeClip.Utils Namespace


ToUploadGroupPath Method

[image]

OfficeClip API Documentation
OCConvert..::.ToUploadGroupPath Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Return the disk path of the upload folder for group

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToUploadGroupPath(
    string name
)
Visual Basic (Declaration)
Public Shared Function ToUploadGroupPath ( _
    name As String _
) As String
Visual C++
public:
static String^ ToUploadGroupPath(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the path

Return Value

The full disk path of the upload folder for group

See Also

OCConvert Class
OfficeClip.Utils Namespace


ToUploadUserPath Method

[image]

OfficeClip API Documentation
OCConvert..::.ToUploadUserPath Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Return the disk path of the upload folder for user

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToUploadUserPath(
    string name
)
Visual Basic (Declaration)
Public Shared Function ToUploadUserPath ( _
    name As String _
) As String
Visual C++
public:
static String^ ToUploadUserPath(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the path

Return Value

The full disk path of the upload folder for user

See Also

OCConvert Class
OfficeClip.Utils Namespace


UnFoldString Method

[image]

OfficeClip API Documentation
OCConvert..::.UnFoldString Method
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Unfolds a folded string. Unfolding means merging the following patterns into a single string \r\n followed by a whitespace character

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string UnFoldString(
    string str
)
Visual Basic (Declaration)
Public Shared Function UnFoldString ( _
    str As String _
) As String
Visual C++
public:
static String^ UnFoldString(
    String^ str
)

Parameters

str
Type: System..::.String
The initial string

Return Value

The unfolded string

See Also

OCConvert Class
OfficeClip.Utils Namespace


OCConvert Properties

[image] [image]

OfficeClip API Documentation
OCConvert Properties
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

The OCConvert type exposes the following properties.

Properties

Name | Description
DemoGuardAlertString | Returns the demo guard alert string to be used by the javascript that shows the alert if any restricted function is attempted on the demo account.

See Also

OCConvert Class
OfficeClip.Utils Namespace


DemoGuardAlertString Property

[image]

OfficeClip API Documentation
OCConvert..::.DemoGuardAlertString Property
OCConvert Class See Also

[This is preliminary documentation and is subject to change.]

Returns the demo guard alert string to be used by the javascript that shows the alert if any restricted function is attempted on the demo account.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string DemoGuardAlertString { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DemoGuardAlertString As String
Visual C++
public:
static property String^ DemoGuardAlertString {
    String^ get ();
}

See Also

OCConvert Class
OfficeClip.Utils Namespace


OCCsvData Class

[image]

OfficeClip API Documentation
OCCsvData Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class provides functions which aid in exchanging comma separated format data with OfficeClip.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCCsvData
Visual Basic (Declaration)
Public Class OCCsvData
Visual C++
public ref class OCCsvData

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCCsvData

See Also

OCCsvData Members
OfficeClip.Utils Namespace


OCCsvData Members

[image] [image]

OfficeClip API Documentation
OCCsvData Members
OCCsvData Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCCsvData type exposes the following members.

Constructors

 | Name | Description
Public method | OCCsvData | Constructor taking the csv data as arguments.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCsvMapping | Extracts the csv mapping from the XML schema to a dataset.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLine | Gets a single line
Public method | GetOcCsvPropertyList | Returns the property list for the csv file.
Public method | GetSavedUserCsvMapping | Reads the saved user csv mapping from the user's personal folder to the Hashtable.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveCsvMapping | Saves the CSV mapping from the dataset to the users personal document storage. The saved csv mapping is loaded as default, the next time user wants import or export information using the csv file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Data | Returns the data for the csv file.
Public property | Header | Returns the header information for the csv file.

See Also

OCCsvData Class
OfficeClip.Utils Namespace


OCCsvData Constructor

[image]

OfficeClip API Documentation
OCCsvData Constructor
OCCsvData Class See Also

[This is preliminary documentation and is subject to change.]

Constructor taking the csv data as arguments.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCCsvData(
    string csvData
)
Visual Basic (Declaration)
Public Sub New ( _
    csvData As String _
)
Visual C++
public:
OCCsvData(
    String^ csvData
)

Parameters

csvData
Type: System..::.String
The data n csv file.

See Also

OCCsvData Class
OfficeClip.Utils Namespace


OCCsvData Methods

[image] [image]

OfficeClip API Documentation
OCCsvData Methods
OCCsvData Class See Also

[This is preliminary documentation and is subject to change.]

The OCCsvData type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCsvMapping | Extracts the csv mapping from the XML schema to a dataset.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetLine | Gets a single line
Public method | GetOcCsvPropertyList | Returns the property list for the csv file.
Public method | GetSavedUserCsvMapping | Reads the saved user csv mapping from the user's personal folder to the Hashtable.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveCsvMapping | Saves the CSV mapping from the dataset to the users personal document storage. The saved csv mapping is loaded as default, the next time user wants import or export information using the csv file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCCsvData Class
OfficeClip.Utils Namespace


GetCsvMapping Method

[image]

OfficeClip API Documentation
OCCsvData..::.GetCsvMapping Method
OCCsvData Class See Also

[This is preliminary documentation and is subject to change.]

Extracts the csv mapping from the XML schema to a dataset.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public DataSet GetCsvMapping()
Visual Basic (Declaration)
Public Function GetCsvMapping As DataSet
Visual C++
public:
DataSet^ GetCsvMapping()

Return Value

The dataset that contains the csv mapping.

See Also

OCCsvData Class
OfficeClip.Utils Namespace


GetLine Method

[image]

OfficeClip API Documentation
OCCsvData..::.GetLine Method
OCCsvData Class See Also

[This is preliminary documentation and is subject to change.]

Gets a single line

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string GetLine(
    int i
)
Visual Basic (Declaration)
Public Function GetLine ( _
    i As Integer _
) As String
Visual C++
public:
String^ GetLine(
    int i
)

Parameters

i
Type: System..::.Int32
The line number

Return Value

The line string

See Also

OCCsvData Class
OfficeClip.Utils Namespace


GetOcCsvPropertyList Method

[image]

OfficeClip API Documentation
OCCsvData..::.GetOcCsvPropertyList Method
OCCsvData Class See Also

[This is preliminary documentation and is subject to change.]

Returns the property list for the csv file.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public DataView GetOcCsvPropertyList(
    Object o
)
Visual Basic (Declaration)
Public Function GetOcCsvPropertyList ( _
    o As Object _
) As DataView
Visual C++
public:
DataView^ GetOcCsvPropertyList(
    Object^ o
)

Parameters

o
Type: System..::.Object
The input object.

Return Value

The DataView having an id (field name) and description (field value)

See Also

OCCsvData Class
OfficeClip.Utils Namespace


GetSavedUserCsvMapping Method

[image]

OfficeClip API Documentation
OCCsvData..::.GetSavedUserCsvMapping Method
OCCsvData Class See Also

[This is preliminary documentation and is subject to change.]

Reads the saved user csv mapping from the user's personal folder to the Hashtable.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public Hashtable GetSavedUserCsvMapping(
    string fileName
)
Visual Basic (Declaration)
Public Function GetSavedUserCsvMapping ( _
    fileName As String _
) As Hashtable
Visual C++
public:
Hashtable^ GetSavedUserCsvMapping(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The filename where the user csv mapping is stored.

Return Value

the Hashtable where the mapping is loaded.

Exceptions

Exception | Condition
OfficeClip.Utils..::.OCException |

See Also

OCCsvData Class
OfficeClip.Utils Namespace


SaveCsvMapping Method

[image]

OfficeClip API Documentation
OCCsvData..::.SaveCsvMapping Method
OCCsvData Class See Also

[This is preliminary documentation and is subject to change.]

Saves the CSV mapping from the dataset to the users personal document storage. The saved csv mapping is loaded as default, the next time user wants import or export information using the csv file.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public bool SaveCsvMapping(
    DataSet ds,
    string fileName
)
Visual Basic (Declaration)
Public Function SaveCsvMapping ( _
    ds As DataSet, _
    fileName As String _
) As Boolean
Visual C++
public:
bool SaveCsvMapping(
    DataSet^ ds,
    String^ fileName
)

Parameters

ds
Type: System.Data..::.DataSet
The input dataset for the csv file.
fileName
Type: System..::.String
The filename of the file that is used to store the mapping.

Return Value

true if successful, false otherwise

Exceptions

Exception | Condition
OfficeClip.Utils..::.OCException |

See Also

OCCsvData Class
OfficeClip.Utils Namespace


OCCsvData Properties

[image] [image]

OfficeClip API Documentation
OCCsvData Properties
OCCsvData Class See Also

[This is preliminary documentation and is subject to change.]

The OCCsvData type exposes the following properties.

Properties

 | Name | Description
Public property | Data | Returns the data for the csv file.
Public property | Header | Returns the header information for the csv file.

See Also

OCCsvData Class
OfficeClip.Utils Namespace


Data Property

[image]

OfficeClip API Documentation
OCCsvData..::.Data Property
OCCsvData Class See Also

[This is preliminary documentation and is subject to change.]

Returns the data for the csv file.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public ArrayList Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As ArrayList
Visual C++
public:
property ArrayList^ Data {
    ArrayList^ get ();
}

See Also

OCCsvData Class
OfficeClip.Utils Namespace


Header Property

[image]

OfficeClip API Documentation
OCCsvData..::.Header Property
OCCsvData Class See Also

[This is preliminary documentation and is subject to change.]

Returns the header information for the csv file.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public ArrayList Header { get; }
Visual Basic (Declaration)
Public ReadOnly Property Header As ArrayList
Visual C++
public:
property ArrayList^ Header {
    ArrayList^ get ();
}

See Also

OCCsvData Class
OfficeClip.Utils Namespace


OCDateTime Class

[image]

OfficeClip API Documentation
OCDateTime Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class provides methods to manipulate the date and time variables in OfficeClip.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCDateTime
Visual Basic (Declaration)
Public Class OCDateTime
Visual C++
public ref class OCDateTime

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCDateTime

See Also

OCDateTime Members
OfficeClip.Utils Namespace


OCDateTime Members

[image] [image]

OfficeClip API Documentation
OCDateTime Members
OCDateTime Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCDateTime type exposes the following members.

Constructors

 | Name | Description
Public method | OCDateTime |

Methods

 | Name | Description
 | Convert | Converts the date from one timezone to another
 | ConvertFromTrackerUdfDate | Converts the tracker udf date to screen date format. Tracker udf date is always stored in MM/dd/yyyy format
 | ConvertFromUtc | Given the Date in UTC converts to the correct time in the given timezone
 | ConvertToServerTz | Converts the given date to the user datetime
 | ConvertToTrackerUdfDate | Converts the screen date to tracker udf date format. Tracker udf date is always stored in MM/dd/yyyy format
 | ConvertToUserTz | Overloaded.
 | ConvertToUtc | Converts the given time with the timezone to UTC
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCalendarViewName | Returns the string name of the calendar view given the enumerated type
 | GetDatePart | Gets the date part of the datetime object. Actually this method resets the time part to 12:00:00AM
 | GetDayOfMonth | Overloaded.
 | GetDayOfWeekName | Gets the day of the week in its string representation
 | GetDurationColon | Gets the duration in hh:mm format
 | GetDurationDecimal | Gets the duration in the format hh.mm
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMinutesFromTime | Extracts the number of minutes past midnight for the time string
 | GetNumberOfDaysInMonth | Gets the number of days in the month
 | GetPeriodicityName | Returns the name of the periodicity, given the enumerated type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseApproximate | Attempts to parse the date time and returns the mindate if the parse fails.
 | ParseExact | Parses the date exactly from the format. This function tests different value of culture before getting the date
 | Roundup15 | Round up the date in 15 minutes interval
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DateInputLabel | The date input label

See Also

OCDateTime Class
OfficeClip.Utils Namespace


OCDateTime Constructor

[image]

OfficeClip API Documentation
OCDateTime Constructor
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCDateTime()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCDateTime()

See Also

OCDateTime Class
OfficeClip.Utils Namespace


OCDateTime Methods

[image] [image]

OfficeClip API Documentation
OCDateTime Methods
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

The OCDateTime type exposes the following methods.

Methods

 | Name | Description
 | Convert | Converts the date from one timezone to another
 | ConvertFromTrackerUdfDate | Converts the tracker udf date to screen date format. Tracker udf date is always stored in MM/dd/yyyy format
 | ConvertFromUtc | Given the Date in UTC converts to the correct time in the given timezone
 | ConvertToServerTz | Converts the given date to the user datetime
 | ConvertToTrackerUdfDate | Converts the screen date to tracker udf date format. Tracker udf date is always stored in MM/dd/yyyy format
 | ConvertToUserTz | Overloaded.
 | ConvertToUtc | Converts the given time with the timezone to UTC
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCalendarViewName | Returns the string name of the calendar view given the enumerated type
 | GetDatePart | Gets the date part of the datetime object. Actually this method resets the time part to 12:00:00AM
 | GetDayOfMonth | Overloaded.
 | GetDayOfWeekName | Gets the day of the week in its string representation
 | GetDurationColon | Gets the duration in hh:mm format
 | GetDurationDecimal | Gets the duration in the format hh.mm
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetMinutesFromTime | Extracts the number of minutes past midnight for the time string
 | GetNumberOfDaysInMonth | Gets the number of days in the month
 | GetPeriodicityName | Returns the name of the periodicity, given the enumerated type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseApproximate | Attempts to parse the date time and returns the mindate if the parse fails.
 | ParseExact | Parses the date exactly from the format. This function tests different value of culture before getting the date
 | Roundup15 | Round up the date in 15 minutes interval
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCDateTime Class
OfficeClip.Utils Namespace


Convert Method

[image]

OfficeClip API Documentation
OCDateTime..::.Convert Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the date from one timezone to another

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime Convert(
    DateTime fromDt,
    TimeZoneInfo fromTz,
    TimeZoneInfo toTz
)
Visual Basic (Declaration)
Public Shared Function Convert ( _
    fromDt As DateTime, _
    fromTz As TimeZoneInfo, _
    toTz As TimeZoneInfo _
) As DateTime
Visual C++
public:
static DateTime Convert(
    DateTime fromDt,
    TimeZoneInfo^ fromTz,
    TimeZoneInfo^ toTz
)

Parameters

fromDt
Type: System..::.DateTime
the date which need to be converted to in the from time zone
fromTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The timezone for the source date
toTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The timezone for the destination date

See Also

OCDateTime Class
OfficeClip.Utils Namespace


ConvertFromTrackerUdfDate Method

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertFromTrackerUdfDate Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the tracker udf date to screen date format. Tracker udf date is always stored in MM/dd/yyyy format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertFromTrackerUdfDate(
    string outDate
)
Visual Basic (Declaration)
Public Shared Function ConvertFromTrackerUdfDate ( _
    outDate As String _
) As String
Visual C++
public:
static String^ ConvertFromTrackerUdfDate(
    String^ outDate
)

Parameters

outDate
Type: System..::.String
The date from the Database

Return Value

returns the date in tracker udf date format. returns an empty string if an exception occurs or if the input is empty.

See Also

OCDateTime Class
OfficeClip.Utils Namespace


ConvertFromUtc Method

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertFromUtc Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Given the Date in UTC converts to the correct time in the given timezone

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime ConvertFromUtc(
    DateTime dt,
    TimeZoneInfo tz
)
Visual Basic (Declaration)
Public Shared Function ConvertFromUtc ( _
    dt As DateTime, _
    tz As TimeZoneInfo _
) As DateTime
Visual C++
public:
static DateTime ConvertFromUtc(
    DateTime dt,
    TimeZoneInfo^ tz
)

Parameters

dt
Type: System..::.DateTime
The date in given timezone
tz
Type: OfficeClip.Utils..::.TimeZoneInfo
The timezone

See Also

OCDateTime Class
OfficeClip.Utils Namespace


ConvertToServerTz Method

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertToServerTz Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the given date to the user datetime

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime ConvertToServerTz(
    DateTime dt
)
Visual Basic (Declaration)
Public Shared Function ConvertToServerTz ( _
    dt As DateTime _
) As DateTime
Visual C++
public:
static DateTime ConvertToServerTz(
    DateTime dt
)

Parameters

dt
Type: System..::.DateTime
The date and time of the server timezone

See Also

OCDateTime Class
OfficeClip.Utils Namespace


ConvertToTrackerUdfDate Method

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertToTrackerUdfDate Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the screen date to tracker udf date format. Tracker udf date is always stored in MM/dd/yyyy format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertToTrackerUdfDate(
    string inDate
)
Visual Basic (Declaration)
Public Shared Function ConvertToTrackerUdfDate ( _
    inDate As String _
) As String
Visual C++
public:
static String^ ConvertToTrackerUdfDate(
    String^ inDate
)

Parameters

inDate
Type: System..::.String
The date from the screen

Return Value

returns the date in tracker udf date format. returns an empty string if an exception occurs.

See Also

OCDateTime Class
OfficeClip.Utils Namespace


ConvertToUserTz Method

[image] [image]

OfficeClip API Documentation
OCDateTime..::.ConvertToUserTz Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertToUserTz(DateTime) | Converts the given date to the user datetime
ConvertToUserTz(DataSet, String) | Converts the given date to the user datetime. This method converts the datetime column in all the rows of the column determined by the columnName. It returns the same dataset back to the user. Note: No check is made to make sure that the data being converted is in the correct input format. Also, if the incoming datetime is null then the item is automatically converted here to DateTime.MinValue
ConvertToUserTz(DataSet, Int32, String) | Converts the given date to the user datetime. This method converts the datetime column in all the rows of the column determined by the columnName. It returns the same dataset back to the user. Note: No check is made to make sure that the data being converted is in the correct input format. Also, if the incoming datetime is null then the item is automatically converted here to DateTime.MinValue
ConvertToUserTz(DataTable, String, Boolean) | Converts the server timezone to the user timezone. This function works on the entire column.
ConvertToUserTz(DataSet, Int32, String, Boolean) | Converts the given date to the user datetime. This method converts the datetime column in all the rows of the column determined by the columnName. It returns the same dataset back to the user. Note: No check is made to make sure that the data being converted is in the correct input format.
ConvertToUserTz(DataSet, String, TimeZoneInfo, TimeZoneInfo) | Converts the given date to the user datetime. This method converts the datetime column in all the rows of the column determined by the columnName. It returns the same dataset back to the user. Note: No check is made to make sure that the data being converted is in the correct input format. Also, if the incoming datetime is null then the item is automatically converted here to DateTime.MinValue
ConvertToUserTz(DataSet, Int32, String, TimeZoneInfo, TimeZoneInfo) | Converts the given date to the user datetime. This method converts the datetime column in all the rows of the column determined by the columnName. It returns the same dataset back to the user. Note: No check is made to make sure that the data being converted is in the correct input format. Also, if the incoming datetime is null then the item is automatically converted here to DateTime.MinValue

See Also

OCDateTime Class
OCDateTime Members
OfficeClip.Utils Namespace


ConvertToUserTz Method (DateTime)

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertToUserTz Method (DateTime)
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the given date to the user datetime

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime ConvertToUserTz(
    DateTime dt
)
Visual Basic (Declaration)
Public Shared Function ConvertToUserTz ( _
    dt As DateTime _
) As DateTime
Visual C++
public:
static DateTime ConvertToUserTz(
    DateTime dt
)

Parameters

dt
Type: System..::.DateTime
The date and time of the user timezone

See Also

OCDateTime Class
ConvertToUserTz Overload
OfficeClip.Utils Namespace


ConvertToUserTz Method (DataSet, String)

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertToUserTz Method (DataSet, String)
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the given date to the user datetime. This method converts the datetime column in all the rows of the column determined by the columnName. It returns the same dataset back to the user. Note: No check is made to make sure that the data being converted is in the correct input format. Also, if the incoming datetime is null then the item is automatically converted here to DateTime.MinValue

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ConvertToUserTz(
    DataSet ds,
    string columnName
)
Visual Basic (Declaration)
Public Shared Sub ConvertToUserTz ( _
    ds As DataSet, _
    columnName As String _
)
Visual C++
public:
static void ConvertToUserTz(
    DataSet^ ds,
    String^ columnName
)

Parameters

ds
Type: System.Data..::.DataSet
The dataset on which the operation is performed
columnName
Type: System..::.String
The nameof the column which needs to beconverted

See Also

OCDateTime Class
ConvertToUserTz Overload
OfficeClip.Utils Namespace


ConvertToUserTz Method (DataSet, Int32, String)

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertToUserTz Method (DataSet, Int32, String)
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the given date to the user datetime. This method converts the datetime column in all the rows of the column determined by the columnName. It returns the same dataset back to the user. Note: No check is made to make sure that the data being converted is in the correct input format. Also, if the incoming datetime is null then the item is automatically converted here to DateTime.MinValue

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ConvertToUserTz(
    DataSet ds,
    int position,
    string columnName
)
Visual Basic (Declaration)
Public Shared Sub ConvertToUserTz ( _
    ds As DataSet, _
    position As Integer, _
    columnName As String _
)
Visual C++
public:
static void ConvertToUserTz(
    DataSet^ ds,
    int position,
    String^ columnName
)

Parameters

ds
Type: System.Data..::.DataSet
The dataset on which the operation is performed
position
Type: System..::.Int32
The position where the table in the dataset is in 0 is the first position
columnName
Type: System..::.String
The nameof the column which needs to beconverted

See Also

OCDateTime Class
ConvertToUserTz Overload
OfficeClip.Utils Namespace


ConvertToUserTz Method (DataTable, String, Boolean)

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertToUserTz Method (DataTable, String, Boolean)
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the server timezone to the user timezone. This function works on the entire column.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ConvertToUserTz(
    DataTable dt,
    string columnName,
    bool isMinValue
)
Visual Basic (Declaration)
Public Shared Sub ConvertToUserTz ( _
    dt As DataTable, _
    columnName As String, _
    isMinValue As Boolean _
)
Visual C++
public:
static void ConvertToUserTz(
    DataTable^ dt,
    String^ columnName,
    bool isMinValue
)

Parameters

dt
Type: System.Data..::.DataTable
The datatable that needs to be converted
columnName
Type: System..::.String
The column name of the column that needs to be converted
isMinValue
Type: System..::.Boolean
if true converts the date to DateTime.MinValue if it is null

See Also

OCDateTime Class
ConvertToUserTz Overload
OfficeClip.Utils Namespace


ConvertToUserTz Method (DataSet, Int32, String, Boolean)

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertToUserTz Method (DataSet, Int32, String, Boolean)
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the given date to the user datetime. This method converts the datetime column in all the rows of the column determined by the columnName. It returns the same dataset back to the user. Note: No check is made to make sure that the data being converted is in the correct input format.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ConvertToUserTz(
    DataSet ds,
    int position,
    string columnName,
    bool isMinValue
)
Visual Basic (Declaration)
Public Shared Sub ConvertToUserTz ( _
    ds As DataSet, _
    position As Integer, _
    columnName As String, _
    isMinValue As Boolean _
)
Visual C++
public:
static void ConvertToUserTz(
    DataSet^ ds,
    int position,
    String^ columnName,
    bool isMinValue
)

Parameters

ds
Type: System.Data..::.DataSet
The dataset on which the operation is performed
position
Type: System..::.Int32
The position where the table in the dataset is in 0 is the first position
columnName
Type: System..::.String
The nameof the column which needs to be converted
isMinValue
Type: System..::.Boolean
if true converts the date to DateTime.MinValue if it is null

See Also

OCDateTime Class
ConvertToUserTz Overload
OfficeClip.Utils Namespace


ConvertToUserTz Method (DataSet, String, TimeZoneInfo, TimeZoneInfo)

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertToUserTz Method (DataSet, String, TimeZoneInfo, TimeZoneInfo)
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the given date to the user datetime. This method converts the datetime column in all the rows of the column determined by the columnName. It returns the same dataset back to the user. Note: No check is made to make sure that the data being converted is in the correct input format. Also, if the incoming datetime is null then the item is automatically converted here to DateTime.MinValue

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ConvertToUserTz(
    DataSet ds,
    string columnName,
    TimeZoneInfo fromTz,
    TimeZoneInfo toTz
)
Visual Basic (Declaration)
Public Shared Sub ConvertToUserTz ( _
    ds As DataSet, _
    columnName As String, _
    fromTz As TimeZoneInfo, _
    toTz As TimeZoneInfo _
)
Visual C++
public:
static void ConvertToUserTz(
    DataSet^ ds,
    String^ columnName,
    TimeZoneInfo^ fromTz,
    TimeZoneInfo^ toTz
)

Parameters

ds
Type: System.Data..::.DataSet
The dataset on which the operation is performed
columnName
Type: System..::.String
The nameof the column which needs to beconverted
fromTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The timezone information of the timezone we are converting from
toTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The timezone information of the timezone we are converting to

See Also

OCDateTime Class
ConvertToUserTz Overload
OfficeClip.Utils Namespace


ConvertToUserTz Method (DataSet, Int32, String, TimeZoneInfo, TimeZoneInfo)

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertToUserTz Method (DataSet, Int32, String, TimeZoneInfo, TimeZoneInfo)
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the given date to the user datetime. This method converts the datetime column in all the rows of the column determined by the columnName. It returns the same dataset back to the user. Note: No check is made to make sure that the data being converted is in the correct input format. Also, if the incoming datetime is null then the item is automatically converted here to DateTime.MinValue

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ConvertToUserTz(
    DataSet ds,
    int position,
    string columnName,
    TimeZoneInfo fromTz,
    TimeZoneInfo toTz
)
Visual Basic (Declaration)
Public Shared Sub ConvertToUserTz ( _
    ds As DataSet, _
    position As Integer, _
    columnName As String, _
    fromTz As TimeZoneInfo, _
    toTz As TimeZoneInfo _
)
Visual C++
public:
static void ConvertToUserTz(
    DataSet^ ds,
    int position,
    String^ columnName,
    TimeZoneInfo^ fromTz,
    TimeZoneInfo^ toTz
)

Parameters

ds
Type: System.Data..::.DataSet
The dataset on which the operation is performed
position
Type: System..::.Int32
The position where the table in the dataset is in 0 is the first position
columnName
Type: System..::.String
The nameof the column which needs to beconverted
fromTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The timezone information of the timezone we are converting from
toTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The timezone information of the timezone we are converting to

See Also

OCDateTime Class
ConvertToUserTz Overload
OfficeClip.Utils Namespace


ConvertToUtc Method

[image]

OfficeClip API Documentation
OCDateTime..::.ConvertToUtc Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Converts the given time with the timezone to UTC

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime ConvertToUtc(
    DateTime dt,
    TimeZoneInfo tz
)
Visual Basic (Declaration)
Public Shared Function ConvertToUtc ( _
    dt As DateTime, _
    tz As TimeZoneInfo _
) As DateTime
Visual C++
public:
static DateTime ConvertToUtc(
    DateTime dt,
    TimeZoneInfo^ tz
)

Parameters

dt
Type: System..::.DateTime
The given date
tz
Type: OfficeClip.Utils..::.TimeZoneInfo
The timezone at the given date

See Also

OCDateTime Class
OfficeClip.Utils Namespace


GetCalendarViewName Method

[image]

OfficeClip API Documentation
OCDateTime..::.GetCalendarViewName Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Returns the string name of the calendar view given the enumerated type

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetCalendarViewName(
    CalendarView calView
)
Visual Basic (Declaration)
Public Shared Function GetCalendarViewName ( _
    calView As CalendarView _
) As String
Visual C++
public:
static String^ GetCalendarViewName(
    CalendarView calView
)

Parameters

calView
Type: OfficeClip.Utils..::.CalendarView
The enumerated calendarview

Return Value

The string name of the calendar view

See Also

OCDateTime Class
OfficeClip.Utils Namespace


GetDatePart Method

[image]

OfficeClip API Documentation
OCDateTime..::.GetDatePart Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Gets the date part of the datetime object. Actually this method resets the time part to 12:00:00AM

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime GetDatePart(
    DateTime dt
)
Visual Basic (Declaration)
Public Shared Function GetDatePart ( _
    dt As DateTime _
) As DateTime
Visual C++
public:
static DateTime GetDatePart(
    DateTime dt
)

Parameters

dt
Type: System..::.DateTime
The input date

Return Value

The date part of the datetime

See Also

OCDateTime Class
OfficeClip.Utils Namespace


GetDayOfMonth Method

[image] [image]

OfficeClip API Documentation
OCDateTime..::.GetDayOfMonth Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetDayOfMonth(Int32, Int32, Int32, Int32) | Gets the first/second/third/forth/last Monday/Tuesday... of a month from the first day of the month for the date specified.
GetDayOfMonth(String, Int32, Int32, Int32, Int32) | Gets the first/second/third/forth/last Monday/Tuesday... of a month from the first day of the month for the date specified.
GetDayOfMonth(Int32, Int32, Int32, Int32, Int32, Int32) | Gets the first/second/third/forth/last Monday/Tuesday... of a month from the first day of the month for the date specified.

See Also

OCDateTime Class
OCDateTime Members
OfficeClip.Utils Namespace


GetDayOfMonth Method (Int32, Int32, Int32, Int32)

[image]

OfficeClip API Documentation
OCDateTime..::.GetDayOfMonth Method (Int32, Int32, Int32, Int32)
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Gets the first/second/third/forth/last Monday/Tuesday... of a month from the first day of the month for the date specified.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime GetDayOfMonth(
    int week,
    int weekDay,
    int month,
    int year
)
Visual Basic (Declaration)
Public Shared Function GetDayOfMonth ( _
    week As Integer, _
    weekDay As Integer, _
    month As Integer, _
    year As Integer _
) As DateTime
Visual C++
public:
static DateTime GetDayOfMonth(
    int week,
    int weekDay,
    int month,
    int year
)

Parameters

week
Type: System..::.Int32
For which week - legal values are 1, 2, 3, 4 5
weekDay
Type: System..::.Int32
The day of the week legal values are 0(Sunday) to 6(Saturday)
month
Type: System..::.Int32
The month in question
year
Type: System..::.Int32
The year in question

See Also

OCDateTime Class
GetDayOfMonth Overload
OfficeClip.Utils Namespace


GetDayOfMonth Method (String, Int32, Int32, Int32, Int32)

[image]

OfficeClip API Documentation
OCDateTime..::.GetDayOfMonth Method (String, Int32, Int32, Int32, Int32)
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Gets the first/second/third/forth/last Monday/Tuesday... of a month from the first day of the month for the date specified.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime GetDayOfMonth(
    string week,
    int weekDay,
    int month,
    int year,
    int timeMin
)
Visual Basic (Declaration)
Public Shared Function GetDayOfMonth ( _
    week As String, _
    weekDay As Integer, _
    month As Integer, _
    year As Integer, _
    timeMin As Integer _
) As DateTime
Visual C++
public:
static DateTime GetDayOfMonth(
    String^ week,
    int weekDay,
    int month,
    int year,
    int timeMin
)

Parameters

week
Type: System..::.String
For which week - legal values are first, second, third, forth or last
weekDay
Type: System..::.Int32
The day of the week legal values are 0(Sunday) to 6(Saturday)
month
Type: System..::.Int32
The month in question
year
Type: System..::.Int32
The year in question
timeMin
Type: System..::.Int32
The time past midnight

Return Value

See Also

OCDateTime Class
GetDayOfMonth Overload
OfficeClip.Utils Namespace


GetDayOfMonth Method (Int32, Int32, Int32, Int32, Int32, Int32)

[image]

OfficeClip API Documentation
OCDateTime..::.GetDayOfMonth Method (Int32, Int32, Int32, Int32, Int32, Int32)
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Gets the first/second/third/forth/last Monday/Tuesday... of a month from the first day of the month for the date specified.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime GetDayOfMonth(
    int week,
    int weekDay,
    int month,
    int year,
    int hour,
    int min
)
Visual Basic (Declaration)
Public Shared Function GetDayOfMonth ( _
    week As Integer, _
    weekDay As Integer, _
    month As Integer, _
    year As Integer, _
    hour As Integer, _
    min As Integer _
) As DateTime
Visual C++
public:
static DateTime GetDayOfMonth(
    int week,
    int weekDay,
    int month,
    int year,
    int hour,
    int min
)

Parameters

week
Type: System..::.Int32
For which week - legal values are first, second, third, forth or last
weekDay
Type: System..::.Int32
The day of the week legal values are 0(Sunday) to 6(Saturday)
month
Type: System..::.Int32
The month in question
year
Type: System..::.Int32
The year in question
hour
Type: System..::.Int32
The hour past midnight
min
Type: System..::.Int32
The minute in question

See Also

OCDateTime Class
GetDayOfMonth Overload
OfficeClip.Utils Namespace


GetDayOfWeekName Method

[image]

OfficeClip API Documentation
OCDateTime..::.GetDayOfWeekName Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Gets the day of the week in its string representation

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetDayOfWeekName(
    DayOfWeek dow
)
Visual Basic (Declaration)
Public Shared Function GetDayOfWeekName ( _
    dow As DayOfWeek _
) As String
Visual C++
public:
static String^ GetDayOfWeekName(
    DayOfWeek dow
)

Parameters

dow
Type: System..::.DayOfWeek
The day of the week in enum structure

Return Value

The string format day of the week e.g. "Monday"

See Also

OCDateTime Class
OfficeClip.Utils Namespace


GetDurationColon Method

[image]

OfficeClip API Documentation
OCDateTime..::.GetDurationColon Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Gets the duration in hh:mm format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetDurationColon(
    double durHr
)
Visual Basic (Declaration)
Public Shared Function GetDurationColon ( _
    durHr As Double _
) As String
Visual C++
public:
static String^ GetDurationColon(
    double durHr
)

Parameters

durHr
Type: System..::.Double
the duration in the string format

Return Value

the string representation of the duration

See Also

OCDateTime Class
OfficeClip.Utils Namespace


GetDurationDecimal Method

[image]

OfficeClip API Documentation
OCDateTime..::.GetDurationDecimal Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Gets the duration in the format hh.mm

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static double GetDurationDecimal(
    string durHr,
    out bool convertedOK
)
Visual Basic (Declaration)
Public Shared Function GetDurationDecimal ( _
    durHr As String, _
    <OutAttribute> ByRef convertedOK As Boolean _
) As Double
Visual C++
public:
static double GetDurationDecimal(
    String^ durHr,
    [OutAttribute] bool% convertedOK
)

Parameters

durHr
Type: System..::.String
the duration in the floating hour format
convertedOK
Type: System..::.Boolean%
returns the status of the conversion

Return Value

the duration in hh.mm

See Also

OCDateTime Class
OfficeClip.Utils Namespace


GetMinutesFromTime Method

[image]

OfficeClip API Documentation
OCDateTime..::.GetMinutesFromTime Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Extracts the number of minutes past midnight for the time string

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int GetMinutesFromTime(
    string time
)
Visual Basic (Declaration)
Public Shared Function GetMinutesFromTime ( _
    time As String _
) As Integer
Visual C++
public:
static int GetMinutesFromTime(
    String^ time
)

Parameters

time
Type: System..::.String
The timein format e.g. 02:30AM or 2:30PM

See Also

OCDateTime Class
OfficeClip.Utils Namespace


GetNumberOfDaysInMonth Method

[image]

OfficeClip API Documentation
OCDateTime..::.GetNumberOfDaysInMonth Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Gets the number of days in the month

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int GetNumberOfDaysInMonth(
    DateTime dt
)
Visual Basic (Declaration)
Public Shared Function GetNumberOfDaysInMonth ( _
    dt As DateTime _
) As Integer
Visual C++
public:
static int GetNumberOfDaysInMonth(
    DateTime dt
)

Parameters

dt
Type: System..::.DateTime
The date in question

Return Value

The number of days in the month

See Also

OCDateTime Class
OfficeClip.Utils Namespace


GetPeriodicityName Method

[image]

OfficeClip API Documentation
OCDateTime..::.GetPeriodicityName Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Returns the name of the periodicity, given the enumerated type.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetPeriodicityName(
    Periodicity period
)
Visual Basic (Declaration)
Public Shared Function GetPeriodicityName ( _
    period As Periodicity _
) As String
Visual C++
public:
static String^ GetPeriodicityName(
    Periodicity period
)

Parameters

period
Type: OfficeClip.Utils..::.Periodicity
The enumerated period.

Return Value

The name of the periodicity

See Also

OCDateTime Class
OfficeClip.Utils Namespace


ParseApproximate Method

[image]

OfficeClip API Documentation
OCDateTime..::.ParseApproximate Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Attempts to parse the date time and returns the mindate if the parse fails.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime ParseApproximate(
    string str
)
Visual Basic (Declaration)
Public Shared Function ParseApproximate ( _
    str As String _
) As DateTime
Visual C++
public:
static DateTime ParseApproximate(
    String^ str
)

Parameters

str
Type: System..::.String
The input string to be parsed

Return Value

The datetime

See Also

OCDateTime Class
OfficeClip.Utils Namespace


ParseExact Method

[image]

OfficeClip API Documentation
OCDateTime..::.ParseExact Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Parses the date exactly from the format. This function tests different value of culture before getting the date

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime ParseExact(
    string date,
    string format
)
Visual Basic (Declaration)
Public Shared Function ParseExact ( _
    date As String, _
    format As String _
) As DateTime
Visual C++
public:
static DateTime ParseExact(
    String^ date,
    String^ format
)

Parameters

date
Type: System..::.String
The date string
format
Type: System..::.String
The date format

Return Value

The date value

See Also

OCDateTime Class
OfficeClip.Utils Namespace


Roundup15 Method

[image]

OfficeClip API Documentation
OCDateTime..::.Roundup15 Method
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

Round up the date in 15 minutes interval

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime Roundup15(
    DateTime dt
)
Visual Basic (Declaration)
Public Shared Function Roundup15 ( _
    dt As DateTime _
) As DateTime
Visual C++
public:
static DateTime Roundup15(
    DateTime dt
)

Parameters

dt
Type: System..::.DateTime

Return Value

See Also

OCDateTime Class
OfficeClip.Utils Namespace


OCDateTime Properties

[image] [image]

OfficeClip API Documentation
OCDateTime Properties
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

The OCDateTime type exposes the following properties.

Properties

Name | Description
DateInputLabel | The date input label

See Also

OCDateTime Class
OfficeClip.Utils Namespace


DateInputLabel Property

[image]

OfficeClip API Documentation
OCDateTime..::.DateInputLabel Property
OCDateTime Class See Also

[This is preliminary documentation and is subject to change.]

The date input label

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string DateInputLabel { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DateInputLabel As String
Visual C++
public:
static property String^ DateInputLabel {
    String^ get ();
}

See Also

OCDateTime Class
OfficeClip.Utils Namespace


OCDebug Class

[image]

OfficeClip API Documentation
OCDebug Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class provides functions which aid in exchanging comma separated format data with OfficeClip.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCDebug
Visual Basic (Declaration)
Public Class OCDebug
Visual C++
public ref class OCDebug

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCDebug

See Also

OCDebug Members
OfficeClip.Utils Namespace


OCDebug Members

[image] [image]

OfficeClip API Documentation
OCDebug Members
OCDebug Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCDebug type exposes the following members.

Constructors

 | Name | Description
Public method | OCDebug |

Methods

 | Name | Description
 | Dump | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrintControlRecursive | Recursively prints the control tree
 | PrintControlTree | Prints the control tree in xml format
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCDebug Class
OfficeClip.Utils Namespace


OCDebug Constructor

[image]

OfficeClip API Documentation
OCDebug Constructor
OCDebug Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCDebug()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCDebug()

See Also

OCDebug Class
OfficeClip.Utils Namespace


OCDebug Methods

[image] [image]

OfficeClip API Documentation
OCDebug Methods
OCDebug Class See Also

[This is preliminary documentation and is subject to change.]

The OCDebug type exposes the following methods.

Methods

 | Name | Description
 | Dump | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrintControlRecursive | Recursively prints the control tree
 | PrintControlTree | Prints the control tree in xml format
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCDebug Class
OfficeClip.Utils Namespace


Dump Method

[image] [image]

OfficeClip API Documentation
OCDebug..::.Dump Method
OCDebug Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Dump(Hashtable) | Dump the object for debugging purposes
Dump(DataSet%) | Dumps the dataset to the console for debugging
Dump(DataTable) | Dumps the object to a string for debugging purposes

See Also

OCDebug Class
OCDebug Members
OfficeClip.Utils Namespace


Dump Method (Hashtable)

[image]

OfficeClip API Documentation
OCDebug..::.Dump Method (Hashtable)
OCDebug Class See Also

[This is preliminary documentation and is subject to change.]

Dump the object for debugging purposes

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Dump(
    Hashtable ht
)
Visual Basic (Declaration)
Public Shared Function Dump ( _
    ht As Hashtable _
) As String
Visual C++
public:
static String^ Dump(
    Hashtable^ ht
)

Parameters

ht
Type: System.Collections..::.Hashtable
The hashtable to be dumped

Return Value

The dumped string

See Also

OCDebug Class
Dump Overload
OfficeClip.Utils Namespace


Dump Method (DataSet)

[image]

OfficeClip API Documentation
OCDebug..::.Dump Method (DataSet%)
OCDebug Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the dataset to the console for debugging

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Dump(
    ref DataSet ds
)
Visual Basic (Declaration)
Public Shared Function Dump ( _
    ByRef ds As DataSet _
) As String
Visual C++
public:
static String^ Dump(
    DataSet^% ds
)

Parameters

ds
Type: System.Data..::.DataSet%
The dataset to be dumped

See Also

OCDebug Class
Dump Overload
OfficeClip.Utils Namespace


Dump Method (DataTable)

[image]

OfficeClip API Documentation
OCDebug..::.Dump Method (DataTable)
OCDebug Class See Also

[This is preliminary documentation and is subject to change.]

Dumps the object to a string for debugging purposes

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Dump(
    DataTable dt
)
Visual Basic (Declaration)
Public Shared Function Dump ( _
    dt As DataTable _
) As String
Visual C++
public:
static String^ Dump(
    DataTable^ dt
)

Parameters

dt
Type: System.Data..::.DataTable
The datatable to be dumped

Return Value

The dumped string

See Also

OCDebug Class
Dump Overload
OfficeClip.Utils Namespace


PrintControlRecursive Method

[image]

OfficeClip API Documentation
OCDebug..::.PrintControlRecursive Method
OCDebug Class See Also

[This is preliminary documentation and is subject to change.]

Recursively prints the control tree

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected static void PrintControlRecursive(
    Control startControl,
    StringBuilder sb
)
Visual Basic (Declaration)
Protected Shared Sub PrintControlRecursive ( _
    startControl As Control, _
    sb As StringBuilder _
)
Visual C++
protected:
static void PrintControlRecursive(
    Control^ startControl,
    StringBuilder^ sb
)

Parameters

startControl
Type: System.Web.UI..::.Control
The postion from where the control tree should start printing
sb
Type: System.Text..::.StringBuilder
The output stringbuilder for the control tree

See Also

OCDebug Class
OfficeClip.Utils Namespace


PrintControlTree Method

[image]

OfficeClip API Documentation
OCDebug..::.PrintControlTree Method
OCDebug Class See Also

[This is preliminary documentation and is subject to change.]

Prints the control tree in xml format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string PrintControlTree(
    Control startControl
)
Visual Basic (Declaration)
Public Shared Function PrintControlTree ( _
    startControl As Control _
) As String
Visual C++
public:
static String^ PrintControlTree(
    Control^ startControl
)

Parameters

startControl
Type: System.Web.UI..::.Control
Start printing the tree from this position

Return Value

The xml representation of the control tree

See Also

OCDebug Class
OfficeClip.Utils Namespace


OCException Class

[image]

OfficeClip API Documentation
OCException Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class is a wrapper over the existing Exception class. It provides a meaningful way to send user defined messages and Priority along with the exception.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
[SerializableAttribute]
public class OCException : ApplicationException
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OCException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class OCException : public ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
OfficeClip.Utils..::.OCException

See Also

OCException Members
OfficeClip.Utils Namespace


OCException Members

[image] [image]

OfficeClip API Documentation
OCException Members
OCException Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The OCException type exposes the following members.

Constructors

 | Name | Description
Public method | OCException | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
defaultMessage | Default OfficeClip Exception message that is shown on the screen and written on the log file.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Priority | Returns the Priority of the Exception. OfficeClip.Utils..::.ExceptionType
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OCException Class
OfficeClip.Utils Namespace


OCException Constructor

[image] [image]

OfficeClip API Documentation
OCException Constructor
OCException Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCException()()() | Constructor for OfficeCLip exception
Public method | OCException(String) | Constructor of OfficeClip exception
Public method | OCException(ExceptionType) | Constructor that accepts the exception Priority
Public method | OCException(SerializationInfo, StreamingContext) | Constructor for Exception in web services
Public method | OCException(String, Exception) | Constructor for the OfficeClip exception
Public method | OCException(ExceptionType, Exception) | Constructor that accept the prioroty and the exception that is thrown
Public method | OCException(ExceptionType, String) | Constructor that accept the prioroty, the message and the exception that is thrown
Public method | OCException(ExceptionType, String, Exception) | Constructor that accept the prioroty, the message and the exception that is thrown

See Also

OCException Class
OCException Members
OfficeClip.Utils Namespace


OCException Constructor

[image]

OfficeClip API Documentation
OCException Constructor
OCException Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for OfficeCLip exception

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCException()

See Also

OCException Class
OCException Overload
OfficeClip.Utils Namespace


OCException Constructor (String)

[image]

OfficeClip API Documentation
OCException Constructor (String)
OCException Class See Also

[This is preliminary documentation and is subject to change.]

Constructor of OfficeClip exception

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)
Visual C++
public:
OCException(
    String^ message
)

Parameters

message
Type: System..::.String
The message that would be outputted

See Also

OCException Class
OCException Overload
OfficeClip.Utils Namespace


OCException Constructor (ExceptionType)

[image]

OfficeClip API Documentation
OCException Constructor (ExceptionType)
OCException Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that accepts the exception Priority

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCException(
    ExceptionType pr
)
Visual Basic (Declaration)
Public Sub New ( _
    pr As ExceptionType _
)
Visual C++
public:
OCException(
    ExceptionType pr
)

Parameters

pr
Type: OfficeClip.Utils..::.ExceptionType
The Priority of the exception

See Also

OCException Class
OCException Overload
OfficeClip.Utils Namespace


OCException Constructor (SerializationInfo, StreamingContext)

[image]

OfficeClip API Documentation
OCException Constructor (SerializationInfo, StreamingContext)
OCException Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for Exception in web services

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic (Declaration)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
OCException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::.SerializationInfo
The serialization info
context
Type: System.Runtime.Serialization..::.StreamingContext
The serialization context

See Also

OCException Class
OCException Overload
OfficeClip.Utils Namespace


OCException Constructor (String, Exception)

[image]

OfficeClip API Documentation
OCException Constructor (String, Exception)
OCException Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for the OfficeClip exception

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCException(
    string message,
    Exception inner
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
OCException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::.String
The message that would be outputted
inner
Type: System..::.Exception
The inner exception

See Also

OCException Class
OCException Overload
OfficeClip.Utils Namespace


OCException Constructor (ExceptionType, Exception)

[image]

OfficeClip API Documentation
OCException Constructor (ExceptionType, Exception)
OCException Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that accept the prioroty and the exception that is thrown

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCException(
    ExceptionType pr,
    Exception e
)
Visual Basic (Declaration)
Public Sub New ( _
    pr As ExceptionType, _
    e As Exception _
)
Visual C++
public:
OCException(
    ExceptionType pr,
    Exception^ e
)

Parameters

pr
Type: OfficeClip.Utils..::.ExceptionType
The Priority of the exception
e
Type: System..::.Exception
the inner exception that is thrown

See Also

OCException Class
OCException Overload
OfficeClip.Utils Namespace


OCException Constructor (ExceptionType, String)

[image]

OfficeClip API Documentation
OCException Constructor (ExceptionType, String)
OCException Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that accept the prioroty, the message and the exception that is thrown

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCException(
    ExceptionType pr,
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    pr As ExceptionType, _
    message As String _
)
Visual C++
public:
OCException(
    ExceptionType pr,
    String^ message
)

Parameters

pr
Type: OfficeClip.Utils..::.ExceptionType
The Priority of the exception
message
Type: System..::.String
The message that is associated with this exception. This message is used to display the reason of the exeption to the user.

See Also

OCException Class
OCException Overload
OfficeClip.Utils Namespace


OCException Constructor (ExceptionType, String, Exception)

[image]

OfficeClip API Documentation
OCException Constructor (ExceptionType, String, Exception)
OCException Class See Also

[This is preliminary documentation and is subject to change.]

Constructor that accept the prioroty, the message and the exception that is thrown

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCException(
    ExceptionType pr,
    string message,
    Exception e
)
Visual Basic (Declaration)
Public Sub New ( _
    pr As ExceptionType, _
    message As String, _
    e As Exception _
)
Visual C++
public:
OCException(
    ExceptionType pr,
    String^ message,
    Exception^ e
)

Parameters

pr
Type: OfficeClip.Utils..::.ExceptionType
The Priority of the exception
message
Type: System..::.String
The message that is associated with this exception. This message is used to display the reason of the exeption to the user.
e
Type: System..::.Exception
the inner exception that is thrown

See Also

OCException Class
OCException Overload
OfficeClip.Utils Namespace


OCException Fields

[image] [image]

OfficeClip API Documentation
OCException Fields
OCException Class See Also

[This is preliminary documentation and is subject to change.]

The OCException type exposes the following fields.

Fields

Name | Description
defaultMessage | Default OfficeClip Exception message that is shown on the screen and written on the log file.

See Also

OCException Class
OfficeClip.Utils Namespace


defaultMessage Field

[image]

OfficeClip API Documentation
OCException..::.defaultMessage Field
OCException Class See Also

[This is preliminary documentation and is subject to change.]

Default OfficeClip Exception message that is shown on the screen and written on the log file.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static readonly string defaultMessage
Visual Basic (Declaration)
Public Shared ReadOnly defaultMessage As String
Visual C++
public:
static initonly String^ defaultMessage

See Also

OCException Class
OfficeClip.Utils Namespace


OCException Properties

[image] [image]

OfficeClip API Documentation
OCException Properties
OCException Class See Also

[This is preliminary documentation and is subject to change.]

The OCException type exposes the following properties.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Priority | Returns the Priority of the Exception. OfficeClip.Utils..::.ExceptionType
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OCException Class
OfficeClip.Utils Namespace


Priority Property

[image]

OfficeClip API Documentation
OCException..::.Priority Property
OCException Class See Also

[This is preliminary documentation and is subject to change.]

Returns the Priority of the Exception. OfficeClip.Utils..::.ExceptionType

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public ExceptionType Priority { get; set; }
Visual Basic (Declaration)
Public Property Priority As ExceptionType
Visual C++
public:
property ExceptionType Priority {
    ExceptionType get ();
    void set (ExceptionType value);
}

See Also

OCException Class
OfficeClip.Utils Namespace
OfficeClip.Utils..::.ExceptionType


OCFile Class

[image]

OfficeClip API Documentation
OCFile Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class that supports file manipulation in OfficeCLip.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCFile
Visual Basic (Declaration)
Public Class OCFile
Visual C++
public ref class OCFile

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCFile

See Also

OCFile Members
OfficeClip.Utils Namespace


OCFile Members

[image] [image]

OfficeClip API Documentation
OCFile Members
OCFile Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCFile type exposes the following members.

Constructors

 | Name | Description
Public method | OCFile |

Methods

 | Name | Description
 | BreakUpFileParts | Breaks the file part in name, version and extension. he version name is designated as {filename}_rev{revision number}.{extension}. For example the file xxx.doc can have versions like xxx_rev1.doc, xxx_rev2.doc and so on.
 | CreateDirectory | Creates a directory given the file path. This program creates the directory only if the directory does not exist.
 | CreateFile | Creates an empty file
 | DeleteFile | Removes the file
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCharsFromFile | Gets the content of the file and load it into a character array.
 | GetFileNameWithRevision | Returns the filename with revision encoded in it. This is useful int the document management system, when a new version of the file is generated
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRevision | Extracts the Revision from the file name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsFileAvailable | Returns true if the file is available and is not locked. This method tries 100 iterations and comes out if the file could not be found.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveFolder | Moving (or renaming) a folder loses the session variable in asp.net. So, this is an attempt to simulate the move method by a copy and delete. A mojor pain in the *** but there seems to be no other way to do it or is there...?
 | ReadTextFile | Reads data from the file in a string
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteTextFile | Writes data in the file

See Also

OCFile Class
OfficeClip.Utils Namespace


OCFile Constructor

[image]

OfficeClip API Documentation
OCFile Constructor
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCFile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCFile()

See Also

OCFile Class
OfficeClip.Utils Namespace


OCFile Methods

[image] [image]

OfficeClip API Documentation
OCFile Methods
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

The OCFile type exposes the following methods.

Methods

 | Name | Description
 | BreakUpFileParts | Breaks the file part in name, version and extension. he version name is designated as {filename}_rev{revision number}.{extension}. For example the file xxx.doc can have versions like xxx_rev1.doc, xxx_rev2.doc and so on.
 | CreateDirectory | Creates a directory given the file path. This program creates the directory only if the directory does not exist.
 | CreateFile | Creates an empty file
 | DeleteFile | Removes the file
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCharsFromFile | Gets the content of the file and load it into a character array.
 | GetFileNameWithRevision | Returns the filename with revision encoded in it. This is useful int the document management system, when a new version of the file is generated
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRevision | Extracts the Revision from the file name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsFileAvailable | Returns true if the file is available and is not locked. This method tries 100 iterations and comes out if the file could not be found.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoveFolder | Moving (or renaming) a folder loses the session variable in asp.net. So, this is an attempt to simulate the move method by a copy and delete. A mojor pain in the *** but there seems to be no other way to do it or is there...?
 | ReadTextFile | Reads data from the file in a string
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteTextFile | Writes data in the file

See Also

OCFile Class
OfficeClip.Utils Namespace


BreakUpFileParts Method

[image]

OfficeClip API Documentation
OCFile..::.BreakUpFileParts Method
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Breaks the file part in name, version and extension. he version name is designated as {filename}_rev{revision number}.{extension}. For example the file xxx.doc can have versions like xxx_rev1.doc, xxx_rev2.doc and so on.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void BreakUpFileParts(
    string fullName,
    ref string fileName,
    ref int revision,
    ref string extension
)
Visual Basic (Declaration)
Public Shared Sub BreakUpFileParts ( _
    fullName As String, _
    ByRef fileName As String, _
    ByRef revision As Integer, _
    ByRef extension As String _
)
Visual C++
public:
static void BreakUpFileParts(
    String^ fullName,
    String^% fileName,
    int% revision,
    String^% extension
)

Parameters

fullName
Type: System..::.String
The full file name with revision and extension
fileName
Type: System..::.String%
The file part of the name
revision
Type: System..::.Int32%
Only the revision, returns -1 if no revision is found
extension
Type: System..::.String%
Only the extension

See Also

OCFile Class
OfficeClip.Utils Namespace


CreateDirectory Method

[image]

OfficeClip API Documentation
OCFile..::.CreateDirectory Method
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Creates a directory given the file path. This program creates the directory only if the directory does not exist.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void CreateDirectory(
    string filePath
)
Visual Basic (Declaration)
Public Shared Sub CreateDirectory ( _
    filePath As String _
)
Visual C++
public:
static void CreateDirectory(
    String^ filePath
)

Parameters

filePath
Type: System..::.String
The complete file path where the directory is supposed to be created.

Exceptions

Exception | Condition
OfficeClip.Utils..::.OCException |

See Also

OCFile Class
OfficeClip.Utils Namespace


CreateFile Method

[image]

OfficeClip API Documentation
OCFile..::.CreateFile Method
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Creates an empty file

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void CreateFile(
    string filePath
)
Visual Basic (Declaration)
Public Shared Sub CreateFile ( _
    filePath As String _
)
Visual C++
public:
static void CreateFile(
    String^ filePath
)

Parameters

filePath
Type: System..::.String
The file path

See Also

OCFile Class
OfficeClip.Utils Namespace


DeleteFile Method

[image]

OfficeClip API Documentation
OCFile..::.DeleteFile Method
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Removes the file

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int DeleteFile(
    string filePath
)
Visual Basic (Declaration)
Public Shared Function DeleteFile ( _
    filePath As String _
) As Integer
Visual C++
public:
static int DeleteFile(
    String^ filePath
)

Parameters

filePath
Type: System..::.String
The full pathname of the file.

Return Value

0 if successful or an exception is thrown

Exceptions

Exception | Condition
OfficeClip.Utils..::.OCException |

See Also

OCFile Class
OfficeClip.Utils Namespace


GetCharsFromFile Method

[image]

OfficeClip API Documentation
OCFile..::.GetCharsFromFile Method
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Gets the content of the file and load it into a character array.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static char[] GetCharsFromFile(
    string fileName
)
Visual Basic (Declaration)
Public Shared Function GetCharsFromFile ( _
    fileName As String _
) As Char()
Visual C++
public:
static array<wchar_t>^ GetCharsFromFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
The full pathname of the file.

Return Value

A character array that contains all the characters of the file.

See Also

OCFile Class
OfficeClip.Utils Namespace


GetFileNameWithRevision Method

[image]

OfficeClip API Documentation
OCFile..::.GetFileNameWithRevision Method
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Returns the filename with revision encoded in it. This is useful int the document management system, when a new version of the file is generated

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetFileNameWithRevision(
    string fileName,
    int revision
)
Visual Basic (Declaration)
Public Shared Function GetFileNameWithRevision ( _
    fileName As String, _
    revision As Integer _
) As String
Visual C++
public:
static String^ GetFileNameWithRevision(
    String^ fileName,
    int revision
)

Parameters

fileName
Type: System..::.String
revision
Type: System..::.Int32

Return Value

See Also

OCFile Class
OfficeClip.Utils Namespace


GetRevision Method

[image]

OfficeClip API Documentation
OCFile..::.GetRevision Method
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Extracts the Revision from the file name

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected static int GetRevision(
    string str
)
Visual Basic (Declaration)
Protected Shared Function GetRevision ( _
    str As String _
) As Integer
Visual C++
protected:
static int GetRevision(
    String^ str
)

Parameters

str
Type: System..::.String
The name of the file

Return Value

The file revision

See Also

OCFile Class
OfficeClip.Utils Namespace


IsFileAvailable Method

[image]

OfficeClip API Documentation
OCFile..::.IsFileAvailable Method
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Returns true if the file is available and is not locked. This method tries 100 iterations and comes out if the file could not be found.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsFileAvailable(
    string filePath
)
Visual Basic (Declaration)
Public Shared Function IsFileAvailable ( _
    filePath As String _
) As Boolean
Visual C++
public:
static bool IsFileAvailable(
    String^ filePath
)

Parameters

filePath
Type: System..::.String
The path of the file that needs to be tested.

Return Value

true if the file is available (not locked) false otherwise

See Also

OCFile Class
OfficeClip.Utils Namespace


MoveFolder Method

[image]

OfficeClip API Documentation
OCFile..::.MoveFolder Method
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Moving (or renaming) a folder loses the session variable in asp.net. So, this is an attempt to simulate the move method by a copy and delete. A mojor pain in the *** but there seems to be no other way to do it or is there...?

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool MoveFolder(
    string sourcePath,
    string destPath,
    bool isKeep,
    bool isRecursive
)
Visual Basic (Declaration)
Public Shared Function MoveFolder ( _
    sourcePath As String, _
    destPath As String, _
    isKeep As Boolean, _
    isRecursive As Boolean _
) As Boolean
Visual C++
public:
static bool MoveFolder(
    String^ sourcePath,
    String^ destPath,
    bool isKeep,
    bool isRecursive
)

Parameters

sourcePath
Type: System..::.String
The source folder
destPath
Type: System..::.String
The destination folder
isKeep
Type: System..::.Boolean
if true the source folder is kept (similar to Copy)
isRecursive
Type: System..::.Boolean
If false, then only one level of directory is copied, if true, copies recursively

Return Value

True if Move Folder is Successful

See Also

OCFile Class
OfficeClip.Utils Namespace


ReadTextFile Method

[image]

OfficeClip API Documentation
OCFile..::.ReadTextFile Method
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Reads data from the file in a string

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ReadTextFile(
    string filePath
)
Visual Basic (Declaration)
Public Shared Function ReadTextFile ( _
    filePath As String _
) As String
Visual C++
public:
static String^ ReadTextFile(
    String^ filePath
)

Parameters

filePath
Type: System..::.String
The full pathname of the file.

Return Value

The string containing the content of the file.

See Also

OCFile Class
OfficeClip.Utils Namespace


WriteTextFile Method

[image]

OfficeClip API Documentation
OCFile..::.WriteTextFile Method
OCFile Class See Also

[This is preliminary documentation and is subject to change.]

Writes data in the file

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void WriteTextFile(
    string filePath,
    string dataStr
)
Visual Basic (Declaration)
Public Shared Sub WriteTextFile ( _
    filePath As String, _
    dataStr As String _
)
Visual C++
public:
static void WriteTextFile(
    String^ filePath,
    String^ dataStr
)

Parameters

filePath
Type: System..::.String
The complete pathname of the file.
dataStr
Type: System..::.String
The data string that will be written in the file.

See Also

OCFile Class
OfficeClip.Utils Namespace


OCHighlighter Class

[image]

OfficeClip API Documentation
OCHighlighter Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods to aid highlighting information in OfficeClip

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCHighlighter
Visual Basic (Declaration)
Public Class OCHighlighter
Visual C++
public ref class OCHighlighter

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCHighlighter

See Also

OCHighlighter Members
OfficeClip.Utils Namespace


OCHighlighter Members

[image] [image]

OfficeClip API Documentation
OCHighlighter Members
OCHighlighter Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCHighlighter type exposes the following members.

Constructors

 | Name | Description
Public method | OCHighlighter |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHighlight | Highlights the text using the current selected Theme.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCHighlighter Class
OfficeClip.Utils Namespace


OCHighlighter Constructor

[image]

OfficeClip API Documentation
OCHighlighter Constructor
OCHighlighter Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCHighlighter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCHighlighter()

See Also

OCHighlighter Class
OfficeClip.Utils Namespace


OCHighlighter Methods

[image] [image]

OfficeClip API Documentation
OCHighlighter Methods
OCHighlighter Class See Also

[This is preliminary documentation and is subject to change.]

The OCHighlighter type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHighlight | Highlights the text using the current selected Theme.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCHighlighter Class
OfficeClip.Utils Namespace


GetHighlight Method

[image]

OfficeClip API Documentation
OCHighlighter..::.GetHighlight Method
OCHighlighter Class See Also

[This is preliminary documentation and is subject to change.]

Highlights the text using the current selected Theme.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetHighlight(
    string originalString,
    string searchFor
)
Visual Basic (Declaration)
Public Shared Function GetHighlight ( _
    originalString As String, _
    searchFor As String _
) As String
Visual C++
public:
static String^ GetHighlight(
    String^ originalString,
    String^ searchFor
)

Parameters

originalString
Type: System..::.String
The original Text
searchFor
Type: System..::.String
Keywords to look for

See Also

OCHighlighter Class
OfficeClip.Utils Namespace


OCHtmlControls Class

[image]

OfficeClip API Documentation
OCHtmlControls Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides dynamic html controls

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCHtmlControls
Visual Basic (Declaration)
Public Class OCHtmlControls
Visual C++
public ref class OCHtmlControls

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCHtmlControls

See Also

OCHtmlControls Members
OfficeClip.Utils Namespace


OCHtmlControls Members

[image] [image]

OfficeClip API Documentation
OCHtmlControls Members
OCHtmlControls Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCHtmlControls type exposes the following members.

Constructors

 | Name | Description
Public method | OCHtmlControls |

Methods

 | Name | Description
 | CreateBusyBoxJs | Creates the OfficeClip busy box javascript
 | DataFormatValidationJs | Provides javascript code for validation of the data format
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EvaluationSiteHeader |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControlRecursive | Checks for a control recursively based on its id and returns it. Returns null if the control is not present.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCHtmlControls Class
OfficeClip.Utils Namespace


OCHtmlControls Constructor

[image]

OfficeClip API Documentation
OCHtmlControls Constructor
OCHtmlControls Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCHtmlControls()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCHtmlControls()

See Also

OCHtmlControls Class
OfficeClip.Utils Namespace


OCHtmlControls Methods

[image] [image]

OfficeClip API Documentation
OCHtmlControls Methods
OCHtmlControls Class See Also

[This is preliminary documentation and is subject to change.]

The OCHtmlControls type exposes the following methods.

Methods

 | Name | Description
 | CreateBusyBoxJs | Creates the OfficeClip busy box javascript
 | DataFormatValidationJs | Provides javascript code for validation of the data format
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EvaluationSiteHeader |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControlRecursive | Checks for a control recursively based on its id and returns it. Returns null if the control is not present.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCHtmlControls Class
OfficeClip.Utils Namespace


CreateBusyBoxJs Method

[image]

OfficeClip API Documentation
OCHtmlControls..::.CreateBusyBoxJs Method
OCHtmlControls Class See Also

[This is preliminary documentation and is subject to change.]

Creates the OfficeClip busy box javascript

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void CreateBusyBoxJs(
    OCResources ocr,
    Literal litBusyBoxHeader,
    Literal litBusyBoxFooter,
    HtmlGenericControl Body
)
Visual Basic (Declaration)
Public Shared Sub CreateBusyBoxJs ( _
    ocr As OCResources, _
    litBusyBoxHeader As Literal, _
    litBusyBoxFooter As Literal, _
    Body As HtmlGenericControl _
)
Visual C++
public:
static void CreateBusyBoxJs(
    OCResources^ ocr,
    Literal^ litBusyBoxHeader,
    Literal^ litBusyBoxFooter,
    HtmlGenericControl^ Body
)

Parameters

ocr
Type: OfficeClip.Utils..::.OCResources
The OfficeClip resource variable
litBusyBoxHeader
Type: System.Web.UI.WebControls..::.Literal
The header for the page
litBusyBoxFooter
Type: System.Web.UI.WebControls..::.Literal
The footer for the page
Body
Type: System.Web.UI.HtmlControls..::.HtmlGenericControl
The body of the page

See Also

OCHtmlControls Class
OfficeClip.Utils Namespace


DataFormatValidationJs Method

[image]

OfficeClip API Documentation
OCHtmlControls..::.DataFormatValidationJs Method
OCHtmlControls Class See Also

[This is preliminary documentation and is subject to change.]

Provides javascript code for validation of the data format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string DataFormatValidationJs()
Visual Basic (Declaration)
Public Shared Function DataFormatValidationJs As String
Visual C++
public:
static String^ DataFormatValidationJs()

Return Value

See Also

OCHtmlControls Class
OfficeClip.Utils Namespace


EvaluationSiteHeader Method

[image]

OfficeClip API Documentation
OCHtmlControls..::.EvaluationSiteHeader Method
OCHtmlControls Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string EvaluationSiteHeader(
    DateTime validUntil,
    bool isOwner
)
Visual Basic (Declaration)
Public Shared Function EvaluationSiteHeader ( _
    validUntil As DateTime, _
    isOwner As Boolean _
) As String
Visual C++
public:
static String^ EvaluationSiteHeader(
    DateTime validUntil,
    bool isOwner
)

Parameters

validUntil
Type: System..::.DateTime
isOwner
Type: System..::.Boolean

See Also

OCHtmlControls Class
OfficeClip.Utils Namespace


FindControlRecursive Method

[image]

OfficeClip API Documentation
OCHtmlControls..::.FindControlRecursive Method
OCHtmlControls Class See Also

[This is preliminary documentation and is subject to change.]

Checks for a control recursively based on its id and returns it. Returns null if the control is not present.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static Control FindControlRecursive(
    Control startControl,
    string id
)
Visual Basic (Declaration)
Public Shared Function FindControlRecursive ( _
    startControl As Control, _
    id As String _
) As Control
Visual C++
public:
static Control^ FindControlRecursive(
    Control^ startControl,
    String^ id
)

Parameters

startControl
Type: System.Web.UI..::.Control
The starting point from where the control is checked
id
Type: System..::.String
The id of the control

Return Value

the found control or null if the control is not found

See Also

OCHtmlControls Class
OfficeClip.Utils Namespace


OCHtmlProperties Class

[image]

OfficeClip API Documentation
OCHtmlProperties Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a wrapper for changing properties of the html elements on the screen.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCHtmlProperties
Visual Basic (Declaration)
Public Class OCHtmlProperties
Visual C++
public ref class OCHtmlProperties

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCHtmlProperties

See Also

OCHtmlProperties Members
OfficeClip.Utils Namespace


OCHtmlProperties Members

[image] [image]

OfficeClip API Documentation
OCHtmlProperties Members
OCHtmlProperties Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCHtmlProperties type exposes the following members.

Constructors

 | Name | Description
Public method | OCHtmlProperties |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsPleaseWaitPageSupported | If the please wait message is supported on pages
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCHtmlProperties Class
OfficeClip.Utils Namespace


OCHtmlProperties Constructor

[image]

OfficeClip API Documentation
OCHtmlProperties Constructor
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCHtmlProperties()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCHtmlProperties()

See Also

OCHtmlProperties Class
OfficeClip.Utils Namespace


OCHtmlProperties Methods

[image] [image]

OfficeClip API Documentation
OCHtmlProperties Methods
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

The OCHtmlProperties type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsPleaseWaitPageSupported | If the please wait message is supported on pages
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadOnly | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCHtmlProperties Class
OfficeClip.Utils Namespace


IsPleaseWaitPageSupported Method

[image]

OfficeClip API Documentation
OCHtmlProperties..::.IsPleaseWaitPageSupported Method
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

If the please wait message is supported on pages

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsPleaseWaitPageSupported(
    HttpRequest request
)
Visual Basic (Declaration)
Public Shared Function IsPleaseWaitPageSupported ( _
    request As HttpRequest _
) As Boolean
Visual C++
public:
static bool IsPleaseWaitPageSupported(
    HttpRequest^ request
)

Parameters

request
Type: System.Web..::.HttpRequest
The http request variable

Return Value

true if supported, false otherwise

See Also

OCHtmlProperties Class
OfficeClip.Utils Namespace


ReadOnly Method

[image] [image]

OfficeClip API Documentation
OCHtmlProperties..::.ReadOnly Method
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ReadOnly(Control) | Makes a control readonly
ReadOnly(CheckBox) | Makes a checkbox read-only.
ReadOnly(DropDownList) | Makes a dropdown combo box read-only.
ReadOnly(ImageButton) | Makes a image button read-only. A read-only image button cannot be modified.
ReadOnly(LinkButton) | Makes a Link Button read-only. A read-only link button cannot be clicked.
ReadOnly(ListBox) | Makes a Listbox read-only.
ReadOnly(RadioButton) | Makes a radio button read-only.
ReadOnly(TextBox) | Makes the textbox readonly.

See Also

OCHtmlProperties Class
OCHtmlProperties Members
OfficeClip.Utils Namespace


ReadOnly Method (Control)

[image]

OfficeClip API Documentation
OCHtmlProperties..::.ReadOnly Method (Control)
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

Makes a control readonly

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ReadOnly(
    Control c
)
Visual Basic (Declaration)
Public Shared Sub ReadOnly ( _
    c As Control _
)
Visual C++
public:
static void ReadOnly(
    Control^ c
)

Parameters

c
Type: System.Web.UI..::.Control
The control object

See Also

OCHtmlProperties Class
ReadOnly Overload
OfficeClip.Utils Namespace


ReadOnly Method (CheckBox)

[image]

OfficeClip API Documentation
OCHtmlProperties..::.ReadOnly Method (CheckBox)
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

Makes a checkbox read-only.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ReadOnly(
    CheckBox cb
)
Visual Basic (Declaration)
Public Shared Sub ReadOnly ( _
    cb As CheckBox _
)
Visual C++
public:
static void ReadOnly(
    CheckBox^ cb
)

Parameters

cb
Type: System.Web.UI.WebControls..::.CheckBox
The check box that is to be made read-only.

See Also

OCHtmlProperties Class
ReadOnly Overload
OfficeClip.Utils Namespace


ReadOnly Method (DropDownList)

[image]

OfficeClip API Documentation
OCHtmlProperties..::.ReadOnly Method (DropDownList)
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

Makes a dropdown combo box read-only.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ReadOnly(
    DropDownList dl
)
Visual Basic (Declaration)
Public Shared Sub ReadOnly ( _
    dl As DropDownList _
)
Visual C++
public:
static void ReadOnly(
    DropDownList^ dl
)

Parameters

dl
Type: System.Web.UI.WebControls..::.DropDownList
The dropdown list thatis to be made readonly.

See Also

OCHtmlProperties Class
ReadOnly Overload
OfficeClip.Utils Namespace


ReadOnly Method (ImageButton)

[image]

OfficeClip API Documentation
OCHtmlProperties..::.ReadOnly Method (ImageButton)
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

Makes a image button read-only. A read-only image button cannot be modified.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ReadOnly(
    ImageButton ib
)
Visual Basic (Declaration)
Public Shared Sub ReadOnly ( _
    ib As ImageButton _
)
Visual C++
public:
static void ReadOnly(
    ImageButton^ ib
)

Parameters

ib
Type: System.Web.UI.WebControls..::.ImageButton
The image button that is to be made read-only.

See Also

OCHtmlProperties Class
ReadOnly Overload
OfficeClip.Utils Namespace


ReadOnly Method (LinkButton)

[image]

OfficeClip API Documentation
OCHtmlProperties..::.ReadOnly Method (LinkButton)
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

Makes a Link Button read-only. A read-only link button cannot be clicked.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ReadOnly(
    LinkButton lb
)
Visual Basic (Declaration)
Public Shared Sub ReadOnly ( _
    lb As LinkButton _
)
Visual C++
public:
static void ReadOnly(
    LinkButton^ lb
)

Parameters

lb
Type: System.Web.UI.WebControls..::.LinkButton
The link-button that is supposed to be made read-only.

See Also

OCHtmlProperties Class
ReadOnly Overload
OfficeClip.Utils Namespace


ReadOnly Method (ListBox)

[image]

OfficeClip API Documentation
OCHtmlProperties..::.ReadOnly Method (ListBox)
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

Makes a Listbox read-only.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ReadOnly(
    ListBox lb
)
Visual Basic (Declaration)
Public Shared Sub ReadOnly ( _
    lb As ListBox _
)
Visual C++
public:
static void ReadOnly(
    ListBox^ lb
)

Parameters

lb
Type: System.Web.UI.WebControls..::.ListBox
The Listbox that is to be made read-only.

See Also

OCHtmlProperties Class
ReadOnly Overload
OfficeClip.Utils Namespace


ReadOnly Method (RadioButton)

[image]

OfficeClip API Documentation
OCHtmlProperties..::.ReadOnly Method (RadioButton)
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

Makes a radio button read-only.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ReadOnly(
    RadioButton rb
)
Visual Basic (Declaration)
Public Shared Sub ReadOnly ( _
    rb As RadioButton _
)
Visual C++
public:
static void ReadOnly(
    RadioButton^ rb
)

Parameters

rb
Type: System.Web.UI.WebControls..::.RadioButton
the Radio Button that is to be made read-only.

See Also

OCHtmlProperties Class
ReadOnly Overload
OfficeClip.Utils Namespace


ReadOnly Method (TextBox)

[image]

OfficeClip API Documentation
OCHtmlProperties..::.ReadOnly Method (TextBox)
OCHtmlProperties Class See Also

[This is preliminary documentation and is subject to change.]

Makes the textbox readonly.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void ReadOnly(
    TextBox tb
)
Visual Basic (Declaration)
Public Shared Sub ReadOnly ( _
    tb As TextBox _
)
Visual C++
public:
static void ReadOnly(
    TextBox^ tb
)

Parameters

tb
Type: System.Web.UI.WebControls..::.TextBox
The TextBox that is to be made read-only.

See Also

OCHtmlProperties Class
ReadOnly Overload
OfficeClip.Utils Namespace


OCImage Class

[image]

OfficeClip API Documentation
OCImage Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods for the manipulation of images in OfficeClip.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCImage
Visual Basic (Declaration)
Public Class OCImage
Visual C++
public ref class OCImage

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCImage

See Also

OCImage Members
OfficeClip.Utils Namespace


OCImage Members

[image] [image]

OfficeClip API Documentation
OCImage Members
OCImage Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCImage type exposes the following members.

Constructors

 | Name | Description
Public method | OCImage |

Methods

 | Name | Description
 | CreateThumbnail | Create the thumbnail from the inFilePath and store it in outFilePath.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ThumbnailCallback | Callback for the thumbnail
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCImage Class
OfficeClip.Utils Namespace


OCImage Constructor

[image]

OfficeClip API Documentation
OCImage Constructor
OCImage Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCImage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCImage()

See Also

OCImage Class
OfficeClip.Utils Namespace


OCImage Methods

[image] [image]

OfficeClip API Documentation
OCImage Methods
OCImage Class See Also

[This is preliminary documentation and is subject to change.]

The OCImage type exposes the following methods.

Methods

 | Name | Description
 | CreateThumbnail | Create the thumbnail from the inFilePath and store it in outFilePath.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ThumbnailCallback | Callback for the thumbnail
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCImage Class
OfficeClip.Utils Namespace


CreateThumbnail Method

[image]

OfficeClip API Documentation
OCImage..::.CreateThumbnail Method
OCImage Class See Also

[This is preliminary documentation and is subject to change.]

Create the thumbnail from the inFilePath and store it in outFilePath.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int CreateThumbnail(
    string inFilePath,
    string outFilePath
)
Visual Basic (Declaration)
Public Shared Function CreateThumbnail ( _
    inFilePath As String, _
    outFilePath As String _
) As Integer
Visual C++
public:
static int CreateThumbnail(
    String^ inFilePath,
    String^ outFilePath
)

Parameters

inFilePath
Type: System..::.String
The file where the input image file is.
outFilePath
Type: System..::.String
The file where the output image file is.

Return Value

0 if thumbnail is created correctly -1 if the thumbnail could not be stored in the file system -2 the input file is not in the proper format -3 if there is an unknown error

See Also

OCImage Class
OfficeClip.Utils Namespace


ThumbnailCallback Method

[image]

OfficeClip API Documentation
OCImage..::.ThumbnailCallback Method
OCImage Class See Also

[This is preliminary documentation and is subject to change.]

Callback for the thumbnail

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected static bool ThumbnailCallback()
Visual Basic (Declaration)
Protected Shared Function ThumbnailCallback As Boolean
Visual C++
protected:
static bool ThumbnailCallback()

Return Value

See Also

OCImage Class
OfficeClip.Utils Namespace


OCLogger Class

[image]

OfficeClip API Documentation
OCLogger Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class provides functionality to log events in the event log feature of windows 2000 operating system.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCLogger
Visual Basic (Declaration)
Public Class OCLogger
Visual C++
public ref class OCLogger

Remarks

The logs are separated into two categories,
    These two categories creates separate event logs. Both the logs can be enabled by the appropriate tags in the Web.config file. Currently in OfficeClip, exceptions are automatically logged in the global.cs file

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCLogger

See Also

OCLogger Members
OfficeClip.Utils Namespace


OCLogger Members

[image] [image]

OfficeClip API Documentation
OCLogger Members
OCLogger Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCLogger type exposes the following members.

Constructors

 | Name | Description
Public method | OCLogger |

Methods

 | Name | Description
 | Assert | Overloaded.
 | Debug | Traces a debug statement in the code. This works only if the Debug switch is set in the code.
 | DebugStackTrace | Traces a debug statement in the code. It also produces stack trace at the output. The listener finds this function from the stack trace and switches it on.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSwitchHandle | Gets the boolean switch handle for tracing. Tracing switch can be turned off or on from the web.config file
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TraceFunction | Traces a function call, This works only when the FunctionCall switch is on.
 | WriteError | Writes an error event. This indicates a significant problem the user should know about; usually a loss of functionality or data.
 | WriteException | Overloaded.
 | WriteFailureAudit | Writes a failure audit event. This indicates a security event that occurs when an audited access attempt fails; for example, a failed attempt to open a file.
 | WriteInformation | Writes an information event. This indicates a significant, successful operation.
 | WriteSuccessAudit | Writes a success audit event. This indicates a security event that occurs when an audited access attempt is successful; for example, logging on successfully.
 | WriteWarning | Writes a warning event. This indicates a problem that is not immediately significant, but that may signify conditions that could cause future problems.

See Also

OCLogger Class
OfficeClip.Utils Namespace


OCLogger Constructor

[image]

OfficeClip API Documentation
OCLogger Constructor
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCLogger()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCLogger()

See Also

OCLogger Class
OfficeClip.Utils Namespace


OCLogger Methods

[image] [image]

OfficeClip API Documentation
OCLogger Methods
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

The OCLogger type exposes the following methods.

Methods

 | Name | Description
 | Assert | Overloaded.
 | Debug | Traces a debug statement in the code. This works only if the Debug switch is set in the code.
 | DebugStackTrace | Traces a debug statement in the code. It also produces stack trace at the output. The listener finds this function from the stack trace and switches it on.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSwitchHandle | Gets the boolean switch handle for tracing. Tracing switch can be turned off or on from the web.config file
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TraceFunction | Traces a function call, This works only when the FunctionCall switch is on.
 | WriteError | Writes an error event. This indicates a significant problem the user should know about; usually a loss of functionality or data.
 | WriteException | Overloaded.
 | WriteFailureAudit | Writes a failure audit event. This indicates a security event that occurs when an audited access attempt fails; for example, a failed attempt to open a file.
 | WriteInformation | Writes an information event. This indicates a significant, successful operation.
 | WriteSuccessAudit | Writes a success audit event. This indicates a security event that occurs when an audited access attempt is successful; for example, logging on successfully.
 | WriteWarning | Writes a warning event. This indicates a problem that is not immediately significant, but that may signify conditions that could cause future problems.

See Also

OCLogger Class
OfficeClip.Utils Namespace


Assert Method

[image] [image]

OfficeClip API Documentation
OCLogger..::.Assert Method
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Assert(Boolean) | Traces an assertion, the assertion is only traced if it is false. This works only if the AssertFail switch is set in web.config
Assert(Boolean, String) | Traces an asertion, the assertion is only traced if it is false. This works only if the AssertFail switch is set in web.config
Assert(Boolean, String, String) | Traces an asertion, the assertion is only traced if it is false. This works only if the AssertFail switch is set in web.config

See Also

OCLogger Class
OCLogger Members
OfficeClip.Utils Namespace


Assert Method (Boolean)

[image]

OfficeClip API Documentation
OCLogger..::.Assert Method (Boolean)
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Traces an assertion, the assertion is only traced if it is false. This works only if the AssertFail switch is set in web.config

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void Assert(
    bool bval
)
Visual Basic (Declaration)
Public Shared Sub Assert ( _
    bval As Boolean _
)
Visual C++
public:
static void Assert(
    bool bval
)

Parameters

bval
Type: System..::.Boolean
The boolean value of the assertion

See Also

OCLogger Class
Assert Overload
OfficeClip.Utils Namespace


Assert Method (Boolean, String)

[image]

OfficeClip API Documentation
OCLogger..::.Assert Method (Boolean, String)
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Traces an asertion, the assertion is only traced if it is false. This works only if the AssertFail switch is set in web.config

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void Assert(
    bool bval,
    string str
)
Visual Basic (Declaration)
Public Shared Sub Assert ( _
    bval As Boolean, _
    str As String _
)
Visual C++
public:
static void Assert(
    bool bval,
    String^ str
)

Parameters

bval
Type: System..::.Boolean
The boolean value of the assertion
str
Type: System..::.String
The string to be printed if the assertion failed

See Also

OCLogger Class
Assert Overload
OfficeClip.Utils Namespace


Assert Method (Boolean, String, String)

[image]

OfficeClip API Documentation
OCLogger..::.Assert Method (Boolean, String, String)
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Traces an asertion, the assertion is only traced if it is false. This works only if the AssertFail switch is set in web.config

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void Assert(
    bool bval,
    string str1,
    string str2
)
Visual Basic (Declaration)
Public Shared Sub Assert ( _
    bval As Boolean, _
    str1 As String, _
    str2 As String _
)
Visual C++
public:
static void Assert(
    bool bval,
    String^ str1,
    String^ str2
)

Parameters

bval
Type: System..::.Boolean
The boolean value of the assertion
str1
Type: System..::.String
The first string to be printed if the assertion failed
str2
Type: System..::.String
The second string to be printed if the assertion failed

See Also

OCLogger Class
Assert Overload
OfficeClip.Utils Namespace


Debug Method

[image]

OfficeClip API Documentation
OCLogger..::.Debug Method
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Traces a debug statement in the code. This works only if the Debug switch is set in the code.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void Debug(
    string str
)
Visual Basic (Declaration)
Public Shared Sub Debug ( _
    str As String _
)
Visual C++
public:
static void Debug(
    String^ str
)

Parameters

str
Type: System..::.String
The string to be printed

See Also

OCLogger Class
OfficeClip.Utils Namespace


DebugStackTrace Method

[image]

OfficeClip API Documentation
OCLogger..::.DebugStackTrace Method
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Traces a debug statement in the code. It also produces stack trace at the output. The listener finds this function from the stack trace and switches it on.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void DebugStackTrace(
    string str
)
Visual Basic (Declaration)
Public Shared Sub DebugStackTrace ( _
    str As String _
)
Visual C++
public:
static void DebugStackTrace(
    String^ str
)

Parameters

str
Type: System..::.String
The first string to be printed

See Also

OCLogger Class
OfficeClip.Utils Namespace


GetSwitchHandle Method

[image]

OfficeClip API Documentation
OCLogger..::.GetSwitchHandle Method
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Gets the boolean switch handle for tracing. Tracing switch can be turned off or on from the web.config file

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static BooleanSwitch GetSwitchHandle(
    TraceDebugSwitch tds
)
Visual Basic (Declaration)
Public Shared Function GetSwitchHandle ( _
    tds As TraceDebugSwitch _
) As BooleanSwitch
Visual C++
public:
static BooleanSwitch^ GetSwitchHandle(
    TraceDebugSwitch tds
)

Parameters

tds
Type: OfficeClip.Utils..::.TraceDebugSwitch
The particular switch that is in question

Return Value

The Boolean Switch Handle

See Also

OCLogger Class
OfficeClip.Utils Namespace


TraceFunction Method

[image]

OfficeClip API Documentation
OCLogger..::.TraceFunction Method
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Traces a function call, This works only when the FunctionCall switch is on.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void TraceFunction()
Visual Basic (Declaration)
Public Shared Sub TraceFunction
Visual C++
public:
static void TraceFunction()

See Also

OCLogger Class
OfficeClip.Utils Namespace


WriteError Method

[image]

OfficeClip API Documentation
OCLogger..::.WriteError Method
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Writes an error event. This indicates a significant problem the user should know about; usually a loss of functionality or data.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void WriteError(
    string str
)
Visual Basic (Declaration)
Public Shared Sub WriteError ( _
    str As String _
)
Visual C++
public:
static void WriteError(
    String^ str
)

Parameters

str
Type: System..::.String
The string which needs to be written to the log file.

See Also

OCLogger Class
OfficeClip.Utils Namespace


WriteException Method

[image] [image]

OfficeClip API Documentation
OCLogger..::.WriteException Method
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
WriteException(Exception) | Writes generated Exception on the event log, the exception is recorded as an error.
WriteException(OCException) | Writes OfficeClip generated Exception on the event log, the exception is recorded as an error.

See Also

OCLogger Class
OCLogger Members
OfficeClip.Utils Namespace


WriteException Method (Exception)

[image]

OfficeClip API Documentation
OCLogger..::.WriteException Method (Exception)
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Writes generated Exception on the event log, the exception is recorded as an error.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void WriteException(
    Exception e
)
Visual Basic (Declaration)
Public Shared Sub WriteException ( _
    e As Exception _
)
Visual C++
public:
static void WriteException(
    Exception^ e
)

Parameters

e
Type: System..::.Exception
The Exception

See Also

OCLogger Class
WriteException Overload
OfficeClip.Utils Namespace


WriteException Method (OCException)

[image]

OfficeClip API Documentation
OCLogger..::.WriteException Method (OCException)
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Writes OfficeClip generated Exception on the event log, the exception is recorded as an error.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void WriteException(
    OCException oce
)
Visual Basic (Declaration)
Public Shared Sub WriteException ( _
    oce As OCException _
)
Visual C++
public:
static void WriteException(
    OCException^ oce
)

Parameters

oce
Type: OfficeClip.Utils..::.OCException
The OfficeClip Exception

See Also

OCLogger Class
WriteException Overload
OfficeClip.Utils Namespace


WriteFailureAudit Method

[image]

OfficeClip API Documentation
OCLogger..::.WriteFailureAudit Method
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Writes a failure audit event. This indicates a security event that occurs when an audited access attempt fails; for example, a failed attempt to open a file.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void WriteFailureAudit(
    string str
)
Visual Basic (Declaration)
Public Shared Sub WriteFailureAudit ( _
    str As String _
)
Visual C++
public:
static void WriteFailureAudit(
    String^ str
)

Parameters

str
Type: System..::.String
The string which needs to be written to the log file

See Also

OCLogger Class
OfficeClip.Utils Namespace


WriteInformation Method

[image]

OfficeClip API Documentation
OCLogger..::.WriteInformation Method
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Writes an information event. This indicates a significant, successful operation.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void WriteInformation(
    string str
)
Visual Basic (Declaration)
Public Shared Sub WriteInformation ( _
    str As String _
)
Visual C++
public:
static void WriteInformation(
    String^ str
)

Parameters

str
Type: System..::.String
The string which needs to be written to the log file.

See Also

OCLogger Class
OfficeClip.Utils Namespace


WriteSuccessAudit Method

[image]

OfficeClip API Documentation
OCLogger..::.WriteSuccessAudit Method
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Writes a success audit event. This indicates a security event that occurs when an audited access attempt is successful; for example, logging on successfully.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void WriteSuccessAudit(
    string str
)
Visual Basic (Declaration)
Public Shared Sub WriteSuccessAudit ( _
    str As String _
)
Visual C++
public:
static void WriteSuccessAudit(
    String^ str
)

Parameters

str
Type: System..::.String
The string which needs to be written to the log file

See Also

OCLogger Class
OfficeClip.Utils Namespace


WriteWarning Method

[image]

OfficeClip API Documentation
OCLogger..::.WriteWarning Method
OCLogger Class See Also

[This is preliminary documentation and is subject to change.]

Writes a warning event. This indicates a problem that is not immediately significant, but that may signify conditions that could cause future problems.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void WriteWarning(
    string str
)
Visual Basic (Declaration)
Public Shared Sub WriteWarning ( _
    str As String _
)
Visual C++
public:
static void WriteWarning(
    String^ str
)

Parameters

str
Type: System..::.String
The string which needs to be written to the log file.

See Also

OCLogger Class
OfficeClip.Utils Namespace


OCProfileData Class

[image]

OfficeClip API Documentation
OCProfileData Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class is used to convert dataformat to and from the profile

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCProfileData
Visual Basic (Declaration)
Public Class OCProfileData
Visual C++
public ref class OCProfileData

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCProfileData

See Also

OCProfileData Members
OfficeClip.Utils Namespace


OCProfileData Members

[image] [image]

OfficeClip API Documentation
OCProfileData Members
OCProfileData Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCProfileData type exposes the following members.

Constructors

 | Name | Description
Public method | OCProfileData |

Methods

 | Name | Description
 | ConvertDayOfWeekFromVbScript | Converts the DayOfWeek format from the vb script to the dotnet. This is required because the previous database design stores day of week as vbSunday, vbMonday etc. in the profile
 | ConvertDefaultCalendarViewFromProfile | Overloaded.
 | ConvertVbScriptFromDayOfWeek | Converts the DayOfWeek format to the vb script to the dotnet. This is required because the previous database design stores day of week as vbSunday, vbMonday etc. in the profile
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCProfileData Class
OfficeClip.Utils Namespace


OCProfileData Constructor

[image]

OfficeClip API Documentation
OCProfileData Constructor
OCProfileData Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCProfileData()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCProfileData()

See Also

OCProfileData Class
OfficeClip.Utils Namespace


OCProfileData Methods

[image] [image]

OfficeClip API Documentation
OCProfileData Methods
OCProfileData Class See Also

[This is preliminary documentation and is subject to change.]

The OCProfileData type exposes the following methods.

Methods

 | Name | Description
 | ConvertDayOfWeekFromVbScript | Converts the DayOfWeek format from the vb script to the dotnet. This is required because the previous database design stores day of week as vbSunday, vbMonday etc. in the profile
 | ConvertDefaultCalendarViewFromProfile | Overloaded.
 | ConvertVbScriptFromDayOfWeek | Converts the DayOfWeek format to the vb script to the dotnet. This is required because the previous database design stores day of week as vbSunday, vbMonday etc. in the profile
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCProfileData Class
OfficeClip.Utils Namespace


ConvertDayOfWeekFromVbScript Method

[image]

OfficeClip API Documentation
OCProfileData..::.ConvertDayOfWeekFromVbScript Method
OCProfileData Class See Also

[This is preliminary documentation and is subject to change.]

Converts the DayOfWeek format from the vb script to the dotnet. This is required because the previous database design stores day of week as vbSunday, vbMonday etc. in the profile

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DayOfWeek ConvertDayOfWeekFromVbScript(
    string vbDow
)
Visual Basic (Declaration)
Public Shared Function ConvertDayOfWeekFromVbScript ( _
    vbDow As String _
) As DayOfWeek
Visual C++
public:
static DayOfWeek ConvertDayOfWeekFromVbScript(
    String^ vbDow
)

Parameters

vbDow
Type: System..::.String
The previous day of week profile value

Return Value

The current day of week as DayOfWeek enumerator

See Also

OCProfileData Class
OfficeClip.Utils Namespace


ConvertDefaultCalendarViewFromProfile Method

[image] [image]

OfficeClip API Documentation
OCProfileData..::.ConvertDefaultCalendarViewFromProfile Method
OCProfileData Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertDefaultCalendarViewFromProfile(String) | Converts the periodicity representation in profile to the Periodicity structure
ConvertDefaultCalendarViewFromProfile(CalendarView) | Converts the periodicity representation to profile from the Periodicity structure.

See Also

OCProfileData Class
OCProfileData Members
OfficeClip.Utils Namespace


ConvertDefaultCalendarViewFromProfile Method (String)

[image]

OfficeClip API Documentation
OCProfileData..::.ConvertDefaultCalendarViewFromProfile Method (String)
OCProfileData Class See Also

[This is preliminary documentation and is subject to change.]

Converts the periodicity representation in profile to the Periodicity structure

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static CalendarView ConvertDefaultCalendarViewFromProfile(
    string s
)
Visual Basic (Declaration)
Public Shared Function ConvertDefaultCalendarViewFromProfile ( _
    s As String _
) As CalendarView
Visual C++
public:
static CalendarView ConvertDefaultCalendarViewFromProfile(
    String^ s
)

Parameters

s
Type: System..::.String
The periodicity representation as it is defined in the profile.

Return Value

the enumerated type for different calendar views.

See Also

OCProfileData Class
ConvertDefaultCalendarViewFromProfile Overload
OfficeClip.Utils Namespace


ConvertDefaultCalendarViewFromProfile Method (CalendarView)

[image]

OfficeClip API Documentation
OCProfileData..::.ConvertDefaultCalendarViewFromProfile Method (CalendarView)
OCProfileData Class See Also

[This is preliminary documentation and is subject to change.]

Converts the periodicity representation to profile from the Periodicity structure.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertDefaultCalendarViewFromProfile(
    CalendarView vw
)
Visual Basic (Declaration)
Public Shared Function ConvertDefaultCalendarViewFromProfile ( _
    vw As CalendarView _
) As String
Visual C++
public:
static String^ ConvertDefaultCalendarViewFromProfile(
    CalendarView vw
)

Parameters

vw
Type: OfficeClip.Utils..::.CalendarView
The calendar view enumerated type.

Return Value

The string representation of the calendar view.

See Also

OCProfileData Class
ConvertDefaultCalendarViewFromProfile Overload
OfficeClip.Utils Namespace


ConvertVbScriptFromDayOfWeek Method

[image]

OfficeClip API Documentation
OCProfileData..::.ConvertVbScriptFromDayOfWeek Method
OCProfileData Class See Also

[This is preliminary documentation and is subject to change.]

Converts the DayOfWeek format to the vb script to the dotnet. This is required because the previous database design stores day of week as vbSunday, vbMonday etc. in the profile

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertVbScriptFromDayOfWeek(
    DayOfWeek dow
)
Visual Basic (Declaration)
Public Shared Function ConvertVbScriptFromDayOfWeek ( _
    dow As DayOfWeek _
) As String
Visual C++
public:
static String^ ConvertVbScriptFromDayOfWeek(
    DayOfWeek dow
)

Parameters

dow
Type: System..::.DayOfWeek
The current day of week as DayOfWeek enumerator

Return Value

The previous day of week profile value

See Also

OCProfileData Class
OfficeClip.Utils Namespace


OCResources Class

[image]

OfficeClip API Documentation
OCResources Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides a wrapper for resources and resource manager. Resource Managers are used for various purposes, e.g. converting data from different locale.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCResources
Visual Basic (Declaration)
Public Class OCResources
Visual C++
public ref class OCResources

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCResources

See Also

OCResources Members
OfficeClip.Utils Namespace


OCResources Members

[image] [image]

OfficeClip API Documentation
OCResources Members
OCResources Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCResources type exposes the following members.

Constructors

 | Name | Description
Public method | OCResources | Overloaded.

Methods

 | Name | Description
Public method | AppPath | Gets the application path.
Public method | DiskPath | Returns the disk file path for a source file
Public method | DocsAppPath | Returns the complete application path of the OfficeClip documents.
Public method | EncodeQueryString | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetOSVersion | Get the operating system version
Public method | GetString | Returns the value of the specified String resource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImagePath | Returns the image path taking in view of the customizations
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redirect |
 | Remove | Removes the application variable that is used as a resource reference.
Public method | ResourceAppPath | Returns the complete path name of the appliction resource file.
Public method | ResourceDiskPath | Returns the disk path of the OfficeClip resources
Public method | SetApplication | Sets the resource application to the resource variable. Once this is done, the resource will be available to all instances of OfficeClip.
Public method | SetupSwitches | Sets up switches for the Tracer
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UrlPath | Return the complete url path of the OfficeClip application. The url path starts with http://
Public method | ValidateQueryStringSignature |

Properties

 | Name | Description
Public property | ApplicationMatrix | Property for the application matrix that decides which applications are accessible to the user.
Public property | CustomResources | Custom resource property. This will help switching the aspx files on the fly.
Public property | FrameworkResource | The framework resource
Public property | Item | Returns the value of the specified String resource.
Public property | License | The OfficeClip license object
Public property | SecurityRefreshResources | The application variable that corresponds to the date and time when any security parameter of the system got updated.
Public property | SerialNumberResource | The serial number of the OfficeClip installation
Public property | SqlServerVersion | The sql server version

See Also

OCResources Class
OfficeClip.Utils Namespace


OCResources Constructor

[image] [image]

OfficeClip API Documentation
OCResources Constructor
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | OCResources()()() | Constructor for creating a Resource Manager
Public method | OCResources(Boolean) | Constructor for creating a Resource Manager
Public method | OCResources(String) | Constructor for creating a Resource Manager
Public method | OCResources(String, String) | Constructor for creating a Resource Manager

See Also

OCResources Class
OCResources Members
OfficeClip.Utils Namespace


OCResources Constructor

[image]

OfficeClip API Documentation
OCResources Constructor
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for creating a Resource Manager

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCResources()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCResources()

See Also

OCResources Class
OCResources Overload
OfficeClip.Utils Namespace


OCResources Constructor (Boolean)

[image]

OfficeClip API Documentation
OCResources Constructor (Boolean)
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for creating a Resource Manager

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCResources(
    bool isQueryStringSecured
)
Visual Basic (Declaration)
Public Sub New ( _
    isQueryStringSecured As Boolean _
)
Visual C++
public:
OCResources(
    bool isQueryStringSecured
)

Parameters

isQueryStringSecured
Type: System..::.Boolean

See Also

OCResources Class
OCResources Overload
OfficeClip.Utils Namespace


OCResources Constructor (String)

[image]

OfficeClip API Documentation
OCResources Constructor (String)
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for creating a Resource Manager

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCResources(
    string baseName
)
Visual Basic (Declaration)
Public Sub New ( _
    baseName As String _
)
Visual C++
public:
OCResources(
    String^ baseName
)

Parameters

baseName
Type: System..::.String
The root name of the resources. For example, the root name for the resource file named "MyResource.en-US.resources" is "MyResource".

See Also

OCResources Class
OCResources Overload
OfficeClip.Utils Namespace


OCResources Constructor (String, String)

[image]

OfficeClip API Documentation
OCResources Constructor (String, String)
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Constructor for creating a Resource Manager

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCResources(
    string baseName,
    string resDir
)
Visual Basic (Declaration)
Public Sub New ( _
    baseName As String, _
    resDir As String _
)
Visual C++
public:
OCResources(
    String^ baseName,
    String^ resDir
)

Parameters

baseName
Type: System..::.String
The root name of the resources. For example, the root name for the resource file named "MyResource.en-US.resources" is "MyResource".
resDir
Type: System..::.String
The name of the directory to search for the resources.

See Also

OCResources Class
OCResources Overload
OfficeClip.Utils Namespace


OCResources Methods

[image] [image]

OfficeClip API Documentation
OCResources Methods
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

The OCResources type exposes the following methods.

Methods

 | Name | Description
Public method | AppPath | Gets the application path.
Public method | DiskPath | Returns the disk file path for a source file
Public method | DocsAppPath | Returns the complete application path of the OfficeClip documents.
Public method | EncodeQueryString | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetOSVersion | Get the operating system version
Public method | GetString | Returns the value of the specified String resource.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImagePath | Returns the image path taking in view of the customizations
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Redirect |
 | Remove | Removes the application variable that is used as a resource reference.
Public method | ResourceAppPath | Returns the complete path name of the appliction resource file.
Public method | ResourceDiskPath | Returns the disk path of the OfficeClip resources
Public method | SetApplication | Sets the resource application to the resource variable. Once this is done, the resource will be available to all instances of OfficeClip.
Public method | SetupSwitches | Sets up switches for the Tracer
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UrlPath | Return the complete url path of the OfficeClip application. The url path starts with http://
Public method | ValidateQueryStringSignature |

See Also

OCResources Class
OfficeClip.Utils Namespace


AppPath Method

[image]

OfficeClip API Documentation
OCResources..::.AppPath Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Gets the application path.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string AppPath(
    string name
)
Visual Basic (Declaration)
Public Function AppPath ( _
    name As String _
) As String
Visual C++
public:
String^ AppPath(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the path

Return Value

Returns the path that is of the applications. If a custom pathis defined, it returns the custom path.

See Also

OCResources Class
OfficeClip.Utils Namespace


DiskPath Method

[image]

OfficeClip API Documentation
OCResources..::.DiskPath Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Returns the disk file path for a source file

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string DiskPath(
    string name
)
Visual Basic (Declaration)
Public Function DiskPath ( _
    name As String _
) As String
Visual C++
public:
String^ DiskPath(
    String^ name
)

Parameters

name
Type: System..::.String
the file path starting from the application directory.

Return Value

The complete disk path of the file. e.g. c:\OfficeClip\utils\file.aspx

See Also

OCResources Class
OfficeClip.Utils Namespace


DocsAppPath Method

[image]

OfficeClip API Documentation
OCResources..::.DocsAppPath Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Returns the complete application path of the OfficeClip documents.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string DocsAppPath(
    string name
)
Visual Basic (Declaration)
Public Function DocsAppPath ( _
    name As String _
) As String
Visual C++
public:
String^ DocsAppPath(
    String^ name
)

Parameters

name
Type: System..::.String
The file name of the OfficeClip document file.

Return Value

The complete path of the OfficeClip documents.

See Also

OCResources Class
OfficeClip.Utils Namespace


EncodeQueryString Method

[image] [image]

OfficeClip API Documentation
OCResources..::.EncodeQueryString Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | EncodeQueryString(String) |
Public method | EncodeQueryString(String, Boolean) |

See Also

OCResources Class
OCResources Members
OfficeClip.Utils Namespace


EncodeQueryString Method (String)

[image]

OfficeClip API Documentation
OCResources..::.EncodeQueryString Method (String)
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string EncodeQueryString(
    string val
)
Visual Basic (Declaration)
Public Function EncodeQueryString ( _
    val As String _
) As String
Visual C++
public:
String^ EncodeQueryString(
    String^ val
)

Parameters

val
Type: System..::.String

See Also

OCResources Class
EncodeQueryString Overload
OfficeClip.Utils Namespace


EncodeQueryString Method (String, Boolean)

[image]

OfficeClip API Documentation
OCResources..::.EncodeQueryString Method (String, Boolean)
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string EncodeQueryString(
    string val,
    bool isAddOrgId
)
Visual Basic (Declaration)
Public Function EncodeQueryString ( _
    val As String, _
    isAddOrgId As Boolean _
) As String
Visual C++
public:
String^ EncodeQueryString(
    String^ val,
    bool isAddOrgId
)

Parameters

val
Type: System..::.String
isAddOrgId
Type: System..::.Boolean

See Also

OCResources Class
EncodeQueryString Overload
OfficeClip.Utils Namespace


GetOSVersion Method

[image]

OfficeClip API Documentation
OCResources..::.GetOSVersion Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Get the operating system version

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetOSVersion()
Visual Basic (Declaration)
Public Shared Function GetOSVersion As String
Visual C++
public:
static String^ GetOSVersion()

Return Value

The operating system version

See Also

OCResources Class
OfficeClip.Utils Namespace


GetString Method

[image]

OfficeClip API Documentation
OCResources..::.GetString Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Returns the value of the specified String resource.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string GetString(
    string txt
)
Visual Basic (Declaration)
Public Function GetString ( _
    txt As String _
) As String
Visual C++
public:
String^ GetString(
    String^ txt
)

Parameters

txt
Type: System..::.String
The name of the resource to get.

Return Value

The value of the resource localized for the caller's current culture settings. If a match is not possible, a null reference is returned.

See Also

OCResources Class
OfficeClip.Utils Namespace


ImagePath Method

[image]

OfficeClip API Documentation
OCResources..::.ImagePath Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Returns the image path taking in view of the customizations

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string ImagePath(
    string name
)
Visual Basic (Declaration)
Public Function ImagePath ( _
    name As String _
) As String
Visual C++
public:
String^ ImagePath(
    String^ name
)

Parameters

name
Type: System..::.String
The relative path of the image

Return Value

The converted image path

See Also

OCResources Class
OfficeClip.Utils Namespace


Redirect Method

[image]

OfficeClip API Documentation
OCResources..::.Redirect Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void Redirect(
    string val,
    bool isAddOrgId
)
Visual Basic (Declaration)
Public Sub Redirect ( _
    val As String, _
    isAddOrgId As Boolean _
)
Visual C++
public:
void Redirect(
    String^ val,
    bool isAddOrgId
)

Parameters

val
Type: System..::.String
isAddOrgId
Type: System..::.Boolean

See Also

OCResources Class
OfficeClip.Utils Namespace


Remove Method

[image]

OfficeClip API Documentation
OCResources..::.Remove Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Removes the application variable that is used as a resource reference.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void Remove()
Visual Basic (Declaration)
Public Shared Sub Remove
Visual C++
public:
static void Remove()

See Also

OCResources Class
OfficeClip.Utils Namespace


ResourceAppPath Method

[image]

OfficeClip API Documentation
OCResources..::.ResourceAppPath Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Returns the complete path name of the appliction resource file.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string ResourceAppPath(
    string name
)
Visual Basic (Declaration)
Public Function ResourceAppPath ( _
    name As String _
) As String
Visual C++
public:
String^ ResourceAppPath(
    String^ name
)

Parameters

name
Type: System..::.String
The file name.

Return Value

The complete path name of the application resource.

See Also

OCResources Class
OfficeClip.Utils Namespace


ResourceDiskPath Method

[image]

OfficeClip API Documentation
OCResources..::.ResourceDiskPath Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Returns the disk path of the OfficeClip resources

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string ResourceDiskPath(
    string name
)
Visual Basic (Declaration)
Public Function ResourceDiskPath ( _
    name As String _
) As String
Visual C++
public:
String^ ResourceDiskPath(
    String^ name
)

Parameters

name
Type: System..::.String
The resource file name in the resource directory.

Return Value

The complete resource path of the resource file.

See Also

OCResources Class
OfficeClip.Utils Namespace


SetApplication Method

[image]

OfficeClip API Documentation
OCResources..::.SetApplication Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Sets the resource application to the resource variable. Once this is done, the resource will be available to all instances of OfficeClip.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void SetApplication()
Visual Basic (Declaration)
Public Sub SetApplication
Visual C++
public:
void SetApplication()

See Also

OCResources Class
OfficeClip.Utils Namespace


SetupSwitches Method

[image]

OfficeClip API Documentation
OCResources..::.SetupSwitches Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Sets up switches for the Tracer

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void SetupSwitches()
Visual Basic (Declaration)
Public Sub SetupSwitches
Visual C++
public:
void SetupSwitches()

See Also

OCResources Class
OfficeClip.Utils Namespace


UrlPath Method

[image]

OfficeClip API Documentation
OCResources..::.UrlPath Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Return the complete url path of the OfficeClip application. The url path starts with http://

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string UrlPath(
    string name
)
Visual Basic (Declaration)
Public Function UrlPath ( _
    name As String _
) As String
Visual C++
public:
String^ UrlPath(
    String^ name
)

Parameters

name
Type: System..::.String
The name of the file for which url needs to be returned

Return Value

the complete url path of the file.

See Also

OCResources Class
OfficeClip.Utils Namespace


ValidateQueryStringSignature Method

[image]

OfficeClip API Documentation
OCResources..::.ValidateQueryStringSignature Method
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void ValidateQueryStringSignature()
Visual Basic (Declaration)
Public Sub ValidateQueryStringSignature
Visual C++
public:
void ValidateQueryStringSignature()

See Also

OCResources Class
OfficeClip.Utils Namespace


OCResources Properties

[image] [image]

OfficeClip API Documentation
OCResources Properties
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

The OCResources type exposes the following properties.

Properties

 | Name | Description
Public property | ApplicationMatrix | Property for the application matrix that decides which applications are accessible to the user.
Public property | CustomResources | Custom resource property. This will help switching the aspx files on the fly.
Public property | FrameworkResource | The framework resource
Public property | Item | Returns the value of the specified String resource.
Public property | License | The OfficeClip license object
Public property | SecurityRefreshResources | The application variable that corresponds to the date and time when any security parameter of the system got updated.
Public property | SerialNumberResource | The serial number of the OfficeClip installation
Public property | SqlServerVersion | The sql server version

See Also

OCResources Class
OfficeClip.Utils Namespace


ApplicationMatrix Property

[image]

OfficeClip API Documentation
OCResources..::.ApplicationMatrix Property
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Property for the application matrix that decides which applications are accessible to the user.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public ArrayList ApplicationMatrix { get; set; }
Visual Basic (Declaration)
Public Property ApplicationMatrix As ArrayList
Visual C++
public:
property ArrayList^ ApplicationMatrix {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

OCResources Class
OfficeClip.Utils Namespace


CustomResources Property

[image]

OfficeClip API Documentation
OCResources..::.CustomResources Property
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Custom resource property. This will help switching the aspx files on the fly.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public Hashtable CustomResources { get; set; }
Visual Basic (Declaration)
Public Property CustomResources As Hashtable
Visual C++
public:
property Hashtable^ CustomResources {
    Hashtable^ get ();
    void set (Hashtable^ value);
}

See Also

OCResources Class
OfficeClip.Utils Namespace


FrameworkResource Property

[image]

OfficeClip API Documentation
OCResources..::.FrameworkResource Property
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

The framework resource

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public Object FrameworkResource { get; set; }
Visual Basic (Declaration)
Public Property FrameworkResource As Object
Visual C++
public:
property Object^ FrameworkResource {
    Object^ get ();
    void set (Object^ value);
}

See Also

OCResources Class
OfficeClip.Utils Namespace


Item Property

[image]

OfficeClip API Documentation
OCResources..::.Item Property
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

Returns the value of the specified String resource.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string this[
    string res
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    res As String _
) As String
Visual C++
public:
property String^ default[String^ res] {
    String^ get (String^ res);
}

Parameters

res
Type: System..::.String
The name of the resource to get.

Return Value

The value of the resource localized for the caller's current culture settings. If a match is not possible, a null reference is returned.

See Also

OCResources Class
OfficeClip.Utils Namespace


License Property

[image]

OfficeClip API Documentation
OCResources..::.License Property
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

The OfficeClip license object

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public Object License { get; set; }
Visual Basic (Declaration)
Public Property License As Object
Visual C++
public:
property Object^ License {
    Object^ get ();
    void set (Object^ value);
}

See Also

OCResources Class
OfficeClip.Utils Namespace


SecurityRefreshResources Property

[image]

OfficeClip API Documentation
OCResources..::.SecurityRefreshResources Property
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

The application variable that corresponds to the date and time when any security parameter of the system got updated.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public DateTime SecurityRefreshResources { get; set; }
Visual Basic (Declaration)
Public Property SecurityRefreshResources As DateTime
Visual C++
public:
property DateTime SecurityRefreshResources {
    DateTime get ();
    void set (DateTime value);
}

See Also

OCResources Class
OfficeClip.Utils Namespace


SerialNumberResource Property

[image]

OfficeClip API Documentation
OCResources..::.SerialNumberResource Property
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

The serial number of the OfficeClip installation

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string SerialNumberResource { get; set; }
Visual Basic (Declaration)
Public Property SerialNumberResource As String
Visual C++
public:
property String^ SerialNumberResource {
    String^ get ();
    void set (String^ value);
}

See Also

OCResources Class
OfficeClip.Utils Namespace


SqlServerVersion Property

[image]

OfficeClip API Documentation
OCResources..::.SqlServerVersion Property
OCResources Class See Also

[This is preliminary documentation and is subject to change.]

The sql server version

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string SqlServerVersion { get; set; }
Visual Basic (Declaration)
Public Property SqlServerVersion As String
Visual C++
public:
property String^ SqlServerVersion {
    String^ get ();
    void set (String^ value);
}

See Also

OCResources Class
OfficeClip.Utils Namespace


OCSecurity Class

[image]

OfficeClip API Documentation
OCSecurity Class
Members See Also

[This is preliminary documentation and is subject to change.]

This class will provide all the methods required to ensure that OfficeClip can be accessed in a secured fashion.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCSecurity
Visual Basic (Declaration)
Public Class OCSecurity
Visual C++
public ref class OCSecurity

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCSecurity

See Also

OCSecurity Members
OfficeClip.Utils Namespace


OCSecurity Members

[image] [image]

OfficeClip API Documentation
OCSecurity Members
OCSecurity Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCSecurity type exposes the following members.

Constructors

 | Name | Description
Public method | OCSecurity |

Methods

 | Name | Description
 | DecryptFile | Overloaded.
 | DecryptString | Overloaded.
 | EncryptFile | Overloaded.
 | EncryptPassword | This function encrypts the password by creating a hash from the MD5 algorithm.
 | EncryptString | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCSecurity Class
OfficeClip.Utils Namespace


OCSecurity Constructor

[image]

OfficeClip API Documentation
OCSecurity Constructor
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCSecurity()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCSecurity()

See Also

OCSecurity Class
OfficeClip.Utils Namespace


OCSecurity Methods

[image] [image]

OfficeClip API Documentation
OCSecurity Methods
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The OCSecurity type exposes the following methods.

Methods

 | Name | Description
 | DecryptFile | Overloaded.
 | DecryptString | Overloaded.
 | EncryptFile | Overloaded.
 | EncryptPassword | This function encrypts the password by creating a hash from the MD5 algorithm.
 | EncryptString | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCSecurity Class
OfficeClip.Utils Namespace


DecryptFile Method

[image] [image]

OfficeClip API Documentation
OCSecurity..::.DecryptFile Method
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DecryptFile(String, String) | Decrypts a file. The file needs to be encrypted with the same secret key or with the default EncryptFile method given in this class.
DecryptFile(String, String, String) | Decrypts a file. The file needs to be encrypted with the same secret key or with the default EncryptFile method given in this class.

See Also

OCSecurity Class
OCSecurity Members
OfficeClip.Utils Namespace


DecryptFile Method (String, String)

[image]

OfficeClip API Documentation
OCSecurity..::.DecryptFile Method (String, String)
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Decrypts a file. The file needs to be encrypted with the same secret key or with the default EncryptFile method given in this class.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int DecryptFile(
    string sInputFilename,
    string sOutputFilename
)
Visual Basic (Declaration)
Public Shared Function DecryptFile ( _
    sInputFilename As String, _
    sOutputFilename As String _
) As Integer
Visual C++
public:
static int DecryptFile(
    String^ sInputFilename,
    String^ sOutputFilename
)

Parameters

sInputFilename
Type: System..::.String
The encrypted input file name.
sOutputFilename
Type: System..::.String
The decrypted output file name.

Return Value

0 if successful, -1 if failed.

See Also

OCSecurity Class
DecryptFile Overload
OfficeClip.Utils Namespace


DecryptFile Method (String, String, String)

[image]

OfficeClip API Documentation
OCSecurity..::.DecryptFile Method (String, String, String)
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Decrypts a file. The file needs to be encrypted with the same secret key or with the default EncryptFile method given in this class.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int DecryptFile(
    string sInputFilename,
    string sOutputFilename,
    string sKey
)
Visual Basic (Declaration)
Public Shared Function DecryptFile ( _
    sInputFilename As String, _
    sOutputFilename As String, _
    sKey As String _
) As Integer
Visual C++
public:
static int DecryptFile(
    String^ sInputFilename,
    String^ sOutputFilename,
    String^ sKey
)

Parameters

sInputFilename
Type: System..::.String
The encrypted input file name.
sOutputFilename
Type: System..::.String
The decrypted output file name.
sKey
Type: System..::.String
the secret key.

Return Value

0 if successful, -1 if failed.

Exceptions

Exception | Condition
OfficeClip.Utils..::.OCException |

See Also

OCSecurity Class
DecryptFile Overload
OfficeClip.Utils Namespace


DecryptString Method

[image] [image]

OfficeClip API Documentation
OCSecurity..::.DecryptString Method
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DecryptString(String) | Decrypts a previously encrypted string. It should be noted that this string will need to be encrypted with the same default key for the decrypted key to make sense.
DecryptString(String, String) | Decrypts a previously encrypted string. It should be noted that this string will need to be encrypted with the same key with which it is encrypted.

See Also

OCSecurity Class
OCSecurity Members
OfficeClip.Utils Namespace


DecryptString Method (String)

[image]

OfficeClip API Documentation
OCSecurity..::.DecryptString Method (String)
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Decrypts a previously encrypted string. It should be noted that this string will need to be encrypted with the same default key for the decrypted key to make sense.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string DecryptString(
    string input
)
Visual Basic (Declaration)
Public Shared Function DecryptString ( _
    input As String _
) As String
Visual C++
public:
static String^ DecryptString(
    String^ input
)

Parameters

input
Type: System..::.String
The input string.

Return Value

The decrypted string.

See Also

OCSecurity Class
DecryptString Overload
OfficeClip.Utils Namespace


DecryptString Method (String, String)

[image]

OfficeClip API Documentation
OCSecurity..::.DecryptString Method (String, String)
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Decrypts a previously encrypted string. It should be noted that this string will need to be encrypted with the same key with which it is encrypted.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string DecryptString(
    string input,
    string sKey
)
Visual Basic (Declaration)
Public Shared Function DecryptString ( _
    input As String, _
    sKey As String _
) As String
Visual C++
public:
static String^ DecryptString(
    String^ input,
    String^ sKey
)

Parameters

input
Type: System..::.String
the input string.
sKey
Type: System..::.String
The secret key that is used to encrypt the string.

Return Value

See Also

OCSecurity Class
DecryptString Overload
OfficeClip.Utils Namespace


EncryptFile Method

[image] [image]

OfficeClip API Documentation
OCSecurity..::.EncryptFile Method
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
EncryptFile(String, String) | Encrypts a file.
EncryptFile(String, String, String) | Encrypts a file.

See Also

OCSecurity Class
OCSecurity Members
OfficeClip.Utils Namespace


EncryptFile Method (String, String)

[image]

OfficeClip API Documentation
OCSecurity..::.EncryptFile Method (String, String)
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Encrypts a file.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int EncryptFile(
    string sInputFilename,
    string sOutputFilename
)
Visual Basic (Declaration)
Public Shared Function EncryptFile ( _
    sInputFilename As String, _
    sOutputFilename As String _
) As Integer
Visual C++
public:
static int EncryptFile(
    String^ sInputFilename,
    String^ sOutputFilename
)

Parameters

sInputFilename
Type: System..::.String
the full path name of the file to be converted.
sOutputFilename
Type: System..::.String
The full path name of the converted file.

Return Value

Returns 0 if successful, -1 if failed.

See Also

OCSecurity Class
EncryptFile Overload
OfficeClip.Utils Namespace


EncryptFile Method (String, String, String)

[image]

OfficeClip API Documentation
OCSecurity..::.EncryptFile Method (String, String, String)
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Encrypts a file.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int EncryptFile(
    string sInputFilename,
    string sOutputFilename,
    string sKey
)
Visual Basic (Declaration)
Public Shared Function EncryptFile ( _
    sInputFilename As String, _
    sOutputFilename As String, _
    sKey As String _
) As Integer
Visual C++
public:
static int EncryptFile(
    String^ sInputFilename,
    String^ sOutputFilename,
    String^ sKey
)

Parameters

sInputFilename
Type: System..::.String
the full path name of the file to be converted.
sOutputFilename
Type: System..::.String
The full path name of the converted file.
sKey
Type: System..::.String
The secret key.

Return Value

Returns 0 if successful, -1 if failed.

See Also

OCSecurity Class
EncryptFile Overload
OfficeClip.Utils Namespace


EncryptPassword Method

[image]

OfficeClip API Documentation
OCSecurity..::.EncryptPassword Method
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

This function encrypts the password by creating a hash from the MD5 algorithm.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string EncryptPassword(
    string stri
)
Visual Basic (Declaration)
Public Shared Function EncryptPassword ( _
    stri As String _
) As String
Visual C++
public:
static String^ EncryptPassword(
    String^ stri
)

Parameters

stri
Type: System..::.String
The input string that need to be converted

Return Value

The encrypted password

See Also

OCSecurity Class
OfficeClip.Utils Namespace


EncryptString Method

[image] [image]

OfficeClip API Documentation
OCSecurity..::.EncryptString Method
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
EncryptString(String) | Encrypts a string
EncryptString(String, String) | Encrypts a string

See Also

OCSecurity Class
OCSecurity Members
OfficeClip.Utils Namespace


EncryptString Method (String)

[image]

OfficeClip API Documentation
OCSecurity..::.EncryptString Method (String)
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Encrypts a string

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string EncryptString(
    string input
)
Visual Basic (Declaration)
Public Shared Function EncryptString ( _
    input As String _
) As String
Visual C++
public:
static String^ EncryptString(
    String^ input
)

Parameters

input
Type: System..::.String
The input string to be encrypted.

Return Value

The encrypted string.

See Also

OCSecurity Class
EncryptString Overload
OfficeClip.Utils Namespace


EncryptString Method (String, String)

[image]

OfficeClip API Documentation
OCSecurity..::.EncryptString Method (String, String)
OCSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Encrypts a string

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string EncryptString(
    string input,
    string sKey
)
Visual Basic (Declaration)
Public Shared Function EncryptString ( _
    input As String, _
    sKey As String _
) As String
Visual C++
public:
static String^ EncryptString(
    String^ input,
    String^ sKey
)

Parameters

input
Type: System..::.String
The input string to be encrypted.
sKey
Type: System..::.String
The secret key.

Return Value

The encrypted string.

See Also

OCSecurity Class
EncryptString Overload
OfficeClip.Utils Namespace


OCSerialize Class

[image]

OfficeClip API Documentation
OCSerialize Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides serilization for classes only contaning primitive types of type Int32, DateTime, String, Double. This uses a more storage efficient collection mechanism and does not support any other data types.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCSerialize
Visual Basic (Declaration)
Public Class OCSerialize
Visual C++
public ref class OCSerialize

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCSerialize

See Also

OCSerialize Members
OfficeClip.Utils Namespace


OCSerialize Members

[image] [image]

OfficeClip API Documentation
OCSerialize Members
OCSerialize Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCSerialize type exposes the following members.

Constructors

 | Name | Description
Public method | OCSerialize |

Methods

 | Name | Description
 | Deserialize | Deserialize the object from the string. The string should have been serialized using the serializer of this class. . Should not be used for any string that is persistent between versions
 | DotNetDeserialize | Deserialize the string and get the object back.
 | DotNetSerialize | Serialize an object into a string. Precondition is that in the Class definition you should have implemented the ISerialize interface. Example: meetingAttendee class.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QueryStringDeserialize |
 | QueryStringSerialize |
 | Serialize | Serialize the object. Should not be used for any string that is persistent between versions
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCSerialize Class
OfficeClip.Utils Namespace


OCSerialize Constructor

[image]

OfficeClip API Documentation
OCSerialize Constructor
OCSerialize Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCSerialize()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCSerialize()

See Also

OCSerialize Class
OfficeClip.Utils Namespace


OCSerialize Methods

[image] [image]

OfficeClip API Documentation
OCSerialize Methods
OCSerialize Class See Also

[This is preliminary documentation and is subject to change.]

The OCSerialize type exposes the following methods.

Methods

 | Name | Description
 | Deserialize | Deserialize the object from the string. The string should have been serialized using the serializer of this class. . Should not be used for any string that is persistent between versions
 | DotNetDeserialize | Deserialize the string and get the object back.
 | DotNetSerialize | Serialize an object into a string. Precondition is that in the Class definition you should have implemented the ISerialize interface. Example: meetingAttendee class.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | QueryStringDeserialize |
 | QueryStringSerialize |
 | Serialize | Serialize the object. Should not be used for any string that is persistent between versions
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCSerialize Class
OfficeClip.Utils Namespace


Deserialize Method

[image]

OfficeClip API Documentation
OCSerialize..::.Deserialize Method
OCSerialize Class See Also

[This is preliminary documentation and is subject to change.]

Deserialize the object from the string. The string should have been serialized using the serializer of this class. . Should not be used for any string that is persistent between versions

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static Object Deserialize(
    string byteArrStr,
    bool isUrlSafe
)
Visual Basic (Declaration)
Public Shared Function Deserialize ( _
    byteArrStr As String, _
    isUrlSafe As Boolean _
) As Object
Visual C++
public:
static Object^ Deserialize(
    String^ byteArrStr,
    bool isUrlSafe
)

Parameters

byteArrStr
Type: System..::.String
The string array
isUrlSafe
Type: System..::.Boolean

Return Value

The object that is deserialized

See Also

OCSerialize Class
OfficeClip.Utils Namespace


DotNetDeserialize Method

[image]

OfficeClip API Documentation
OCSerialize..::.DotNetDeserialize Method
OCSerialize Class See Also

[This is preliminary documentation and is subject to change.]

Deserialize the string and get the object back.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static Object DotNetDeserialize(
    string objectStr
)
Visual Basic (Declaration)
Public Shared Function DotNetDeserialize ( _
    objectStr As String _
) As Object
Visual C++
public:
static Object^ DotNetDeserialize(
    String^ objectStr
)

Parameters

objectStr
Type: System..::.String
Input string containing the serialized object

Return Value

The Deserialized object.

See Also

OCSerialize Class
OfficeClip.Utils Namespace


DotNetSerialize Method

[image]

OfficeClip API Documentation
OCSerialize..::.DotNetSerialize Method
OCSerialize Class See Also

[This is preliminary documentation and is subject to change.]

Serialize an object into a string. Precondition is that in the Class definition you should have implemented the ISerialize interface. Example: meetingAttendee class.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string DotNetSerialize(
    Object o
)
Visual Basic (Declaration)
Public Shared Function DotNetSerialize ( _
    o As Object _
) As String
Visual C++
public:
static String^ DotNetSerialize(
    Object^ o
)

Parameters

o
Type: System..::.Object
The Object to be serialized

Return Value

The serilized string.

See Also

OCSerialize Class
OfficeClip.Utils Namespace


QueryStringDeserialize Method

[image]

OfficeClip API Documentation
OCSerialize..::.QueryStringDeserialize Method
OCSerialize Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static NameValueCollection QueryStringDeserialize(
    string qStr
)
Visual Basic (Declaration)
Public Shared Function QueryStringDeserialize ( _
    qStr As String _
) As NameValueCollection
Visual C++
public:
static NameValueCollection^ QueryStringDeserialize(
    String^ qStr
)

Parameters

qStr
Type: System..::.String

See Also

OCSerialize Class
OfficeClip.Utils Namespace


QueryStringSerialize Method

[image]

OfficeClip API Documentation
OCSerialize..::.QueryStringSerialize Method
OCSerialize Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string QueryStringSerialize(
    NameValueCollection nvc
)
Visual Basic (Declaration)
Public Shared Function QueryStringSerialize ( _
    nvc As NameValueCollection _
) As String
Visual C++
public:
static String^ QueryStringSerialize(
    NameValueCollection^ nvc
)

Parameters

nvc
Type: System.Collections.Specialized..::.NameValueCollection

See Also

OCSerialize Class
OfficeClip.Utils Namespace


Serialize Method

[image]

OfficeClip API Documentation
OCSerialize..::.Serialize Method
OCSerialize Class See Also

[This is preliminary documentation and is subject to change.]

Serialize the object. Should not be used for any string that is persistent between versions

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Serialize(
    Object o,
    bool isUrlSafe
)
Visual Basic (Declaration)
Public Shared Function Serialize ( _
    o As Object, _
    isUrlSafe As Boolean _
) As String
Visual C++
public:
static String^ Serialize(
    Object^ o,
    bool isUrlSafe
)

Parameters

o
Type: System..::.Object
The object, should be of the following type Int32, DateTime, String, Double.
isUrlSafe
Type: System..::.Boolean
Notifies that the string is url safe

Return Value

The serialized string

See Also

OCSerialize Class
OfficeClip.Utils Namespace


OCServiceImportPolicy Enumeration

[image]

OfficeClip API Documentation
OCServiceImportPolicy Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The import policy used when importing an xml to OfficeClip. These import policies are used when the OfficeClip service id is present and it matches the OfficeClip current installation and other parameters.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum OCServiceImportPolicy
Visual Basic (Declaration)
Public Enumeration OCServiceImportPolicy
Visual C++
public enum class OCServiceImportPolicy

Members

Member name | Description
None | Default value, meaning is do nothing
OfficeClipOverride | For the same record, do not copy the matched entries from the external source but add new ones.
ExternalOverride | For the same record, overwrite the database entry with the external entry and add the new ones.
UseInternal | Use the Command tag in the external Xml file as the sole means to decide on what to do.

See Also

OfficeClip.Utils Namespace


OCServiceReturnStatus Enumeration

[image]

OfficeClip API Documentation
OCServiceReturnStatus Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides the return status of all the Service Calls

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum OCServiceReturnStatus
Visual Basic (Declaration)
Public Enumeration OCServiceReturnStatus
Visual C++
public enum class OCServiceReturnStatus

Members

Member name | Description
Success | The success result
GeneralFailure | The general failure result
NoPermission | Does not have any permission to write on this object
NotPresent | Is not present
DifferentInstallation | Not the same installation
IncorrectServiceType | The service type is not correct
IdDoesNotMatch | The Id does not match the the project that needs to be updated
UnspecifiedError | Unspecified error
NotImplemented | The function is not implemented

See Also

OfficeClip.Utils Namespace


OCServiceType Enumeration

[image]

OfficeClip API Documentation
OCServiceType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Types of various objects that are converted to Xml. Especially used for creating the service id of each object.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum OCServiceType
Visual Basic (Declaration)
Public Enumeration OCServiceType
Visual C++
public enum class OCServiceType

Members

Member name | Description
None | Default, should not be used
OCServiceTrackerBinder | The Service id of the tracker project
OCServiceTrackerField | The service id of one tracker field
OCServiceTrackerFields | The service id of all the tracker fields
OCServiceTrackerCase | The service id of the tracker case
OCServiceRole | The service id of the OfficeClip roles
OCServiceSecurityObject | The service id of the array of the security object
OCServiceSecurity | The service id object for security that contains role and objct security for a particular user
OCServiceTask | The service id for single task
OCServiceTasks | The service id for multiple tasks
OCServiceAddressBookEntry | The service id for the addressbook entry
OCServiceMember | The service id of the member
OCServiceAddressBook | The service id of the personal address book
OCServiceGroup | The service id of the group list
OCServiceEvent | The service id of the event
OCServiceGroupEvents | The service id of the group events
OCServicePersonalEvents | The service id of the personal events
OCServiceMetaValue | The service id of a metabase info
OCServiceContact | The service id of the contact object
OCServiceContacts | The service id of a bunch of contact objects
OCServiceNote | Service id of the note
OCMetaHistoryInfo | Service id of the meta history info
OCServiceTemplateParentChild | The parent child array of the system template
OCServiceAttachment | The service item for the document attachment
OCServiceReturnValue | The return value for the insert, update and delete queries
OCServiceDocument | Service id for documents
OCServiceTemplateKeyValue | The Template key value pairs
OCServiceCampaign | Service id for mail merge information
OCServiceCampaignRecipients | Service id for the mailmerge recipients, i.e. contacts for which the mailmerge campaign is created.
OCServiceSystemInfo | Provides session information and server information
OCServiceAccount | The OfficeClip Account
OCServiceProject | The OfficeClip Project
OCServiceServiceItem | The OfficeClip Service Item
OCServiceTimesheet | The OfficeClip Timesheet
OCServiceTimesheetDetail | The OfficeClip Timesheet Detail
OCServiceExpense | The OfficeClip Expense
OCServiceExpenseDetail | The OfficeClip Expense detail
OCServiceExpenseType | The OfficeClip Expense Template
OCServiceMetaInformation | The OfficeClip Meta Information
OCServicePayrollCategory | The OfficeClip Payroll Categories

See Also

OfficeClip.Utils Namespace


OCSms Class

[image]

OfficeClip API Documentation
OCSms Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides functions to Send SMS using Thirdparty API.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCSms
Visual Basic (Declaration)
Public Class OCSms
Visual C++
public ref class OCSms

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCSms

See Also

OCSms Members
OfficeClip.Utils Namespace


OCSms Members

[image] [image]

OfficeClip API Documentation
OCSms Members
OCSms Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCSms type exposes the following members.

Constructors

 | Name | Description
Public method | OCSms |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SendClickATellMsg | Sends a Message to Mobile Device using ClickATell API
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCSms Class
OfficeClip.Utils Namespace


OCSms Constructor

[image]

OfficeClip API Documentation
OCSms Constructor
OCSms Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCSms()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCSms()

See Also

OCSms Class
OfficeClip.Utils Namespace


OCSms Methods

[image] [image]

OfficeClip API Documentation
OCSms Methods
OCSms Class See Also

[This is preliminary documentation and is subject to change.]

The OCSms type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SendClickATellMsg | Sends a Message to Mobile Device using ClickATell API
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCSms Class
OfficeClip.Utils Namespace


SendClickATellMsg Method

[image]

OfficeClip API Documentation
OCSms..::.SendClickATellMsg Method
OCSms Class See Also

[This is preliminary documentation and is subject to change.]

Sends a Message to Mobile Device using ClickATell API

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool SendClickATellMsg(
    Hashtable smsInfo,
    string msg
)
Visual Basic (Declaration)
Public Shared Function SendClickATellMsg ( _
    smsInfo As Hashtable, _
    msg As String _
) As Boolean
Visual C++
public:
static bool SendClickATellMsg(
    Hashtable^ smsInfo,
    String^ msg
)

Parameters

smsInfo
Type: System.Collections..::.Hashtable
The SmsInfo Object
msg
Type: System..::.String
the message to send

Return Value

return true if message is sucessfully sent else false.

See Also

OCSms Class
OfficeClip.Utils Namespace


OCSortDirection Enumeration

[image]

OfficeClip API Documentation
OCSortDirection Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides enumerated types for the direction of sort.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum OCSortDirection
Visual Basic (Declaration)
Public Enumeration OCSortDirection
Visual C++
public enum class OCSortDirection

Members

Member name | Description
Ascending | In ascending order of sort.
Descending | In descending order of sort.

See Also

OfficeClip.Utils Namespace


OCString Class

[image]

OfficeClip API Documentation
OCString Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods for additional string manipulation in OfficeClip programs.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCString
Visual Basic (Declaration)
Public Class OCString
Visual C++
public ref class OCString

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCString

See Also

OCString Members
OfficeClip.Utils Namespace


OCString Members

[image] [image]

OfficeClip API Documentation
OCString Members
OCString Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCString type exposes the following members.

Constructors

 | Name | Description
Public method | OCString |

Methods

 | Name | Description
 | AppendDirectorySeparator | Appends a directory separator at the end of the path if not already present.
 | AppendToPath | Appends a file or directory to a path.
 | CheckFileExtension | Checks if the file extension matches (case insensitive) the comma separated extensions provided.
 | Concat | Overloaded.
 | ConvertFromCsvString | Convert a csv string to its comma separated equivalent.
 | ConvertFromHtml | Overloaded.
 | ConvertFromRFC822String | Converts any given string which is in RFC822 format to an ordinary string.
 | ConvertHtml | Overloaded.
 | ConvertLdapUrl | Converts a path to its LDAP URL by appending a "LDAP://" string at its front if not already present.
 | ConvertToCsvString | Converts a comma separated string into its csv counterpart. The output string consists of quoted values separated by commas. For example the string a,b,c will be converted to "a","b","c"
 | ConvertToRFC822String | Converts any given string (which is not already in RFC822 specification) to RFC822 specification compatible string.
 | ConvertUrl | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapeJavascriptComment | Escapes the javascript comment character with the a backslash character before the comment character
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHostStr | Returns the url of the OfficeClip installation. It uses the HostStr property of the web.config file to get the url.
 | GetInitialsFromName | Gets the initials from the name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDocTypeGifPresent | Verifies if the icon is present for a particular document type. The supported document types are shown in docGifTypes
 | IsValidEmailAddress | Uses regular expressions to test if a passed string is a valid email address
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseCsv | Parses the CSV string and loads all individual values in a string array.
 | ReadCsvLine | Reads a line from the comma separated StringReader. This function takes care of the fact that the csv line can span across multiple lines.
 | RemoveLastDirectorySeparator | removes the last directory separator from the path. No action is taken if there is no directory separator at the end of the string.
 | ReplaceDBNull | Overloaded.
 | ToApostrophe | Gets the string converted into the Apostrophe for that noun.
 | ToCommonName | Converts the name string from the last_name, first_name format to the common name format (first_name last_name).
 | ToDigitsOnly | Filters out all the non digits and returns only the digits back.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TruncateFront | Truncates the string but does it from the front instead of back.
 | TruncateStr | Truncates the string to its limit given as an integer argument. When the string is truncated, it is appended with three dots (...)

See Also

OCString Class
OfficeClip.Utils Namespace


OCString Constructor

[image]

OfficeClip API Documentation
OCString Constructor
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCString()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCString()

See Also

OCString Class
OfficeClip.Utils Namespace


OCString Methods

[image] [image]

OfficeClip API Documentation
OCString Methods
OCString Class See Also

[This is preliminary documentation and is subject to change.]

The OCString type exposes the following methods.

Methods

 | Name | Description
 | AppendDirectorySeparator | Appends a directory separator at the end of the path if not already present.
 | AppendToPath | Appends a file or directory to a path.
 | CheckFileExtension | Checks if the file extension matches (case insensitive) the comma separated extensions provided.
 | Concat | Overloaded.
 | ConvertFromCsvString | Convert a csv string to its comma separated equivalent.
 | ConvertFromHtml | Overloaded.
 | ConvertFromRFC822String | Converts any given string which is in RFC822 format to an ordinary string.
 | ConvertHtml | Overloaded.
 | ConvertLdapUrl | Converts a path to its LDAP URL by appending a "LDAP://" string at its front if not already present.
 | ConvertToCsvString | Converts a comma separated string into its csv counterpart. The output string consists of quoted values separated by commas. For example the string a,b,c will be converted to "a","b","c"
 | ConvertToRFC822String | Converts any given string (which is not already in RFC822 specification) to RFC822 specification compatible string.
 | ConvertUrl | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapeJavascriptComment | Escapes the javascript comment character with the a backslash character before the comment character
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHostStr | Returns the url of the OfficeClip installation. It uses the HostStr property of the web.config file to get the url.
 | GetInitialsFromName | Gets the initials from the name
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDocTypeGifPresent | Verifies if the icon is present for a particular document type. The supported document types are shown in docGifTypes
 | IsValidEmailAddress | Uses regular expressions to test if a passed string is a valid email address
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseCsv | Parses the CSV string and loads all individual values in a string array.
 | ReadCsvLine | Reads a line from the comma separated StringReader. This function takes care of the fact that the csv line can span across multiple lines.
 | RemoveLastDirectorySeparator | removes the last directory separator from the path. No action is taken if there is no directory separator at the end of the string.
 | ReplaceDBNull | Overloaded.
 | ToApostrophe | Gets the string converted into the Apostrophe for that noun.
 | ToCommonName | Converts the name string from the last_name, first_name format to the common name format (first_name last_name).
 | ToDigitsOnly | Filters out all the non digits and returns only the digits back.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TruncateFront | Truncates the string but does it from the front instead of back.
 | TruncateStr | Truncates the string to its limit given as an integer argument. When the string is truncated, it is appended with three dots (...)

See Also

OCString Class
OfficeClip.Utils Namespace


AppendDirectorySeparator Method

[image]

OfficeClip API Documentation
OCString..::.AppendDirectorySeparator Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Appends a directory separator at the end of the path if not already present.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string AppendDirectorySeparator(
    string str
)
Visual Basic (Declaration)
Public Shared Function AppendDirectorySeparator ( _
    str As String _
) As String
Visual C++
public:
static String^ AppendDirectorySeparator(
    String^ str
)

Parameters

str
Type: System..::.String
The input string path.

Return Value

The path with the appended directory separator.

See Also

OCString Class
OfficeClip.Utils Namespace


AppendToPath Method

[image]

OfficeClip API Documentation
OCString..::.AppendToPath Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Appends a file or directory to a path.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string AppendToPath(
    string path,
    string fileOrDirectory
)
Visual Basic (Declaration)
Public Shared Function AppendToPath ( _
    path As String, _
    fileOrDirectory As String _
) As String
Visual C++
public:
static String^ AppendToPath(
    String^ path,
    String^ fileOrDirectory
)

Parameters

path
Type: System..::.String
The path to which the directory or file is to be appended.
fileOrDirectory
Type: System..::.String
The file or directory name to be appended.

Return Value

The appended file or directory path.

See Also

OCString Class
OfficeClip.Utils Namespace


CheckFileExtension Method

[image]

OfficeClip API Documentation
OCString..::.CheckFileExtension Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Checks if the file extension matches (case insensitive) the comma separated extensions provided.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string CheckFileExtension(
    string pattern,
    string fileName
)
Visual Basic (Declaration)
Public Shared Function CheckFileExtension ( _
    pattern As String, _
    fileName As String _
) As String
Visual C++
public:
static String^ CheckFileExtension(
    String^ pattern,
    String^ fileName
)

Parameters

pattern
Type: System..::.String
A comma separated allowed extensions
fileName
Type: System..::.String
The full name of the file

Return Value

empty if there is a match, error message otherwise

See Also

OCString Class
OfficeClip.Utils Namespace


Concat Method

[image] [image]

OfficeClip API Documentation
OCString..::.Concat Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Concat(String, String, String, String, String) | Concatenate five strings in an efficient manner
Concat(String, String, String, String, String, String) | Concatenate six strings efficiently
Concat(String, String, String, String, String, String, String) | Concatenate seven strings efficiently

See Also

OCString Class
OCString Members
OfficeClip.Utils Namespace


Concat Method (String, String, String, String, String)

[image]

OfficeClip API Documentation
OCString..::.Concat Method (String, String, String, String, String)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Concatenate five strings in an efficient manner

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Concat(
    string str1,
    string str2,
    string str3,
    string str4,
    string str5
)
Visual Basic (Declaration)
Public Shared Function Concat ( _
    str1 As String, _
    str2 As String, _
    str3 As String, _
    str4 As String, _
    str5 As String _
) As String
Visual C++
public:
static String^ Concat(
    String^ str1,
    String^ str2,
    String^ str3,
    String^ str4,
    String^ str5
)

Parameters

str1
Type: System..::.String
The first string
str2
Type: System..::.String
The second string
str3
Type: System..::.String
The third string
str4
Type: System..::.String
The fourth string
str5
Type: System..::.String
The fifth string

Return Value

The concatenated string

See Also

OCString Class
Concat Overload
OfficeClip.Utils Namespace


Concat Method (String, String, String, String, String, String)

[image]

OfficeClip API Documentation
OCString..::.Concat Method (String, String, String, String, String, String)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Concatenate six strings efficiently

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Concat(
    string str1,
    string str2,
    string str3,
    string str4,
    string str5,
    string str6
)
Visual Basic (Declaration)
Public Shared Function Concat ( _
    str1 As String, _
    str2 As String, _
    str3 As String, _
    str4 As String, _
    str5 As String, _
    str6 As String _
) As String
Visual C++
public:
static String^ Concat(
    String^ str1,
    String^ str2,
    String^ str3,
    String^ str4,
    String^ str5,
    String^ str6
)

Parameters

str1
Type: System..::.String
The first string
str2
Type: System..::.String
The second string
str3
Type: System..::.String
The third string
str4
Type: System..::.String
The fourth string
str5
Type: System..::.String
The fifth string
str6
Type: System..::.String
The sixth string

Return Value

The concatenated string

See Also

OCString Class
Concat Overload
OfficeClip.Utils Namespace


Concat Method (String, String, String, String, String, String, String)

[image]

OfficeClip API Documentation
OCString..::.Concat Method (String, String, String, String, String, String, String)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Concatenate seven strings efficiently

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Concat(
    string str1,
    string str2,
    string str3,
    string str4,
    string str5,
    string str6,
    string str7
)
Visual Basic (Declaration)
Public Shared Function Concat ( _
    str1 As String, _
    str2 As String, _
    str3 As String, _
    str4 As String, _
    str5 As String, _
    str6 As String, _
    str7 As String _
) As String
Visual C++
public:
static String^ Concat(
    String^ str1,
    String^ str2,
    String^ str3,
    String^ str4,
    String^ str5,
    String^ str6,
    String^ str7
)

Parameters

str1
Type: System..::.String
The first string
str2
Type: System..::.String
The second string
str3
Type: System..::.String
The third string
str4
Type: System..::.String
The fourth string
str5
Type: System..::.String
The fifth string
str6
Type: System..::.String
The sixth string
str7
Type: System..::.String
The sixth string

Return Value

The concatenated string

See Also

OCString Class
Concat Overload
OfficeClip.Utils Namespace


ConvertFromCsvString Method

[image]

OfficeClip API Documentation
OCString..::.ConvertFromCsvString Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Convert a csv string to its comma separated equivalent.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertFromCsvString(
    string text
)
Visual Basic (Declaration)
Public Shared Function ConvertFromCsvString ( _
    text As String _
) As String
Visual C++
public:
static String^ ConvertFromCsvString(
    String^ text
)

Parameters

text
Type: System..::.String
The csv string

Return Value

The comma separated string with all the quotes stripped off.

See Also

OCString Class
OfficeClip.Utils Namespace


ConvertFromHtml Method

[image] [image]

OfficeClip API Documentation
OCString..::.ConvertFromHtml Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertFromHtml(String) | Converts an html string into its text equivalent. All the html tags are removed and some tags like break and paragraph tags appropriately converted.
ConvertFromHtml(String, Boolean) | Converts an html string into its text equivalent. All the html tags are removed and some tags like break and paragraph tags appropriately converted.

See Also

OCString Class
OCString Members
OfficeClip.Utils Namespace


ConvertFromHtml Method (String)

[image]

OfficeClip API Documentation
OCString..::.ConvertFromHtml Method (String)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts an html string into its text equivalent. All the html tags are removed and some tags like break and paragraph tags appropriately converted.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertFromHtml(
    string htmlText
)
Visual Basic (Declaration)
Public Shared Function ConvertFromHtml ( _
    htmlText As String _
) As String
Visual C++
public:
static String^ ConvertFromHtml(
    String^ htmlText
)

Parameters

htmlText
Type: System..::.String
The html text that needs to be converted.

Return Value

The text string after stripping all the tags.

See Also

OCString Class
ConvertFromHtml Overload
OfficeClip.Utils Namespace


ConvertFromHtml Method (String, Boolean)

[image]

OfficeClip API Documentation
OCString..::.ConvertFromHtml Method (String, Boolean)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts an html string into its text equivalent. All the html tags are removed and some tags like break and paragraph tags appropriately converted.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertFromHtml(
    string tempStr,
    bool ignoreAllTags
)
Visual Basic (Declaration)
Public Shared Function ConvertFromHtml ( _
    tempStr As String, _
    ignoreAllTags As Boolean _
) As String
Visual C++
public:
static String^ ConvertFromHtml(
    String^ tempStr,
    bool ignoreAllTags
)

Parameters

tempStr
Type: System..::.String
The html text that needs to be converted.
ignoreAllTags
Type: System..::.Boolean
Ignore all the tags

Return Value

The text string after stripping all the tags.

See Also

OCString Class
ConvertFromHtml Overload
OfficeClip.Utils Namespace


ConvertFromRFC822String Method

[image]

OfficeClip API Documentation
OCString..::.ConvertFromRFC822String Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts any given string which is in RFC822 format to an ordinary string.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertFromRFC822String(
    string text
)
Visual Basic (Declaration)
Public Shared Function ConvertFromRFC822String ( _
    text As String _
) As String
Visual C++
public:
static String^ ConvertFromRFC822String(
    String^ text
)

Parameters

text
Type: System..::.String
The input string in RFC822 format.

Return Value

The output string in ordinary format.

See Also

OCString Class
OfficeClip.Utils Namespace


ConvertHtml Method

[image] [image]

OfficeClip API Documentation
OCString..::.ConvertHtml Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertHtml(String) | Converts the input string into html. This method changes the line break and other formatting tag to its equivalent html format. It can be used to preserve formatting of the textarea control when dispayed on the screen as label. This method always converts the line break to the break tag in html. In addition it converts the < tags to the correct html equivalent.
ConvertHtml(String, Boolean) | Converts the input string into html. This method changes the line break and other formatting tag to its equivalent html format. It can be used to preserve formatting of the textarea control when dispayed on the screen as label. This method always converts the line break to the break tag in html.
ConvertHtml(String, Boolean, Boolean, Boolean) | Converts the input string into html. This method changes the line break and other formatting tag to its equivalent html format. It can be used to preserve formatting of the textarea control when dispayed on the screen as label.

See Also

OCString Class
OCString Members
OfficeClip.Utils Namespace


ConvertHtml Method (String)

[image]

OfficeClip API Documentation
OCString..::.ConvertHtml Method (String)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts the input string into html. This method changes the line break and other formatting tag to its equivalent html format. It can be used to preserve formatting of the textarea control when dispayed on the screen as label. This method always converts the line break to the break tag in html. In addition it converts the < tags to the correct html equivalent.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertHtml(
    string text
)
Visual Basic (Declaration)
Public Shared Function ConvertHtml ( _
    text As String _
) As String
Visual C++
public:
static String^ ConvertHtml(
    String^ text
)

Parameters

text
Type: System..::.String
The input text to be converted

Return Value

The converted html string

See Also

OCString Class
ConvertHtml Overload
OfficeClip.Utils Namespace


ConvertHtml Method (String, Boolean)

[image]

OfficeClip API Documentation
OCString..::.ConvertHtml Method (String, Boolean)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts the input string into html. This method changes the line break and other formatting tag to its equivalent html format. It can be used to preserve formatting of the textarea control when dispayed on the screen as label. This method always converts the line break to the break tag in html.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertHtml(
    string text,
    bool allow
)
Visual Basic (Declaration)
Public Shared Function ConvertHtml ( _
    text As String, _
    allow As Boolean _
) As String
Visual C++
public:
static String^ ConvertHtml(
    String^ text,
    bool allow
)

Parameters

text
Type: System..::.String
The input text to be converted
allow
Type: System..::.Boolean
Whether to allow < tags to pass through as is

Return Value

The converted html string

See Also

OCString Class
ConvertHtml Overload
OfficeClip.Utils Namespace


ConvertHtml Method (String, Boolean, Boolean, Boolean)

[image]

OfficeClip API Documentation
OCString..::.ConvertHtml Method (String, Boolean, Boolean, Boolean)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts the input string into html. This method changes the line break and other formatting tag to its equivalent html format. It can be used to preserve formatting of the textarea control when dispayed on the screen as label.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertHtml(
    string text,
    bool allow,
    bool isBreak,
    bool removeLastBreak
)
Visual Basic (Declaration)
Public Shared Function ConvertHtml ( _
    text As String, _
    allow As Boolean, _
    isBreak As Boolean, _
    removeLastBreak As Boolean _
) As String
Visual C++
public:
static String^ ConvertHtml(
    String^ text,
    bool allow,
    bool isBreak,
    bool removeLastBreak
)

Parameters

text
Type: System..::.String
The input text to be converted
allow
Type: System..::.Boolean
Whether to allow < tags to pass through as is
isBreak
Type: System..::.Boolean
Whether to convert the line break
removeLastBreak
Type: System..::.Boolean
Removes the break at the last line if isBreak is true

Return Value

The converted html string

See Also

OCString Class
ConvertHtml Overload
OfficeClip.Utils Namespace


ConvertLdapUrl Method

[image]

OfficeClip API Documentation
OCString..::.ConvertLdapUrl Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts a path to its LDAP URL by appending a "LDAP://" string at its front if not already present.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertLdapUrl(
    string url
)
Visual Basic (Declaration)
Public Shared Function ConvertLdapUrl ( _
    url As String _
) As String
Visual C++
public:
static String^ ConvertLdapUrl(
    String^ url
)

Parameters

url
Type: System..::.String
the path that needs to be converted.

Return Value

The converted url with a "LDAP://" at the front.

See Also

OCString Class
OfficeClip.Utils Namespace


ConvertToCsvString Method

[image]

OfficeClip API Documentation
OCString..::.ConvertToCsvString Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts a comma separated string into its csv counterpart. The output string consists of quoted values separated by commas. For example the string a,b,c will be converted to "a","b","c"

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertToCsvString(
    string text
)
Visual Basic (Declaration)
Public Shared Function ConvertToCsvString ( _
    text As String _
) As String
Visual C++
public:
static String^ ConvertToCsvString(
    String^ text
)

Parameters

text
Type: System..::.String
The input comma separated string

Return Value

The output csv converted string

See Also

OCString Class
OfficeClip.Utils Namespace


ConvertToRFC822String Method

[image]

OfficeClip API Documentation
OCString..::.ConvertToRFC822String Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts any given string (which is not already in RFC822 specification) to RFC822 specification compatible string.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertToRFC822String(
    string text
)
Visual Basic (Declaration)
Public Shared Function ConvertToRFC822String ( _
    text As String _
) As String
Visual C++
public:
static String^ ConvertToRFC822String(
    String^ text
)

Parameters

text
Type: System..::.String
The input string.

Return Value

The output string converted according to the RFC822 specification.

See Also

OCString Class
OfficeClip.Utils Namespace


ConvertUrl Method

[image] [image]

OfficeClip API Documentation
OCString..::.ConvertUrl Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ConvertUrl(String) | Converts the path to the url format. After conversion the path will contain "http://" at the front.
ConvertUrl(String, Boolean) | Converts the path to the url format. After conversion the path will contain "http://" or "https://" at the front.

See Also

OCString Class
OCString Members
OfficeClip.Utils Namespace


ConvertUrl Method (String)

[image]

OfficeClip API Documentation
OCString..::.ConvertUrl Method (String)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts the path to the url format. After conversion the path will contain "http://" at the front.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertUrl(
    string url
)
Visual Basic (Declaration)
Public Shared Function ConvertUrl ( _
    url As String _
) As String
Visual C++
public:
static String^ ConvertUrl(
    String^ url
)

Parameters

url
Type: System..::.String
The path that needs to be converted to url.

Return Value

The final converted url string.

See Also

OCString Class
ConvertUrl Overload
OfficeClip.Utils Namespace


ConvertUrl Method (String, Boolean)

[image]

OfficeClip API Documentation
OCString..::.ConvertUrl Method (String, Boolean)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts the path to the url format. After conversion the path will contain "http://" or "https://" at the front.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ConvertUrl(
    string url,
    bool isSecured
)
Visual Basic (Declaration)
Public Shared Function ConvertUrl ( _
    url As String, _
    isSecured As Boolean _
) As String
Visual C++
public:
static String^ ConvertUrl(
    String^ url,
    bool isSecured
)

Parameters

url
Type: System..::.String
The path that needs to be converted to url.
isSecured
Type: System..::.Boolean
if true, a "https://" prefix will be appended, if false a "http://" prefix will be appended.

Return Value

The final converted url string.

See Also

OCString Class
ConvertUrl Overload
OfficeClip.Utils Namespace


EscapeJavascriptComment Method

[image]

OfficeClip API Documentation
OCString..::.EscapeJavascriptComment Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Escapes the javascript comment character with the a backslash character before the comment character

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string EscapeJavascriptComment(
    string name,
    int type
)
Visual Basic (Declaration)
Public Shared Function EscapeJavascriptComment ( _
    name As String, _
    type As Integer _
) As String
Visual C++
public:
static String^ EscapeJavascriptComment(
    String^ name,
    int type
)

Parameters

name
Type: System..::.String
The input string to be escaped
type
Type: System..::.Int32
0 if we want to escape ' character, 1 if we want to escape " character and 2 if we want to escape both characters

Return Value

The escaped string

See Also

OCString Class
OfficeClip.Utils Namespace


GetHostStr Method

[image]

OfficeClip API Documentation
OCString..::.GetHostStr Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Returns the url of the OfficeClip installation. It uses the HostStr property of the web.config file to get the url.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetHostStr()
Visual Basic (Declaration)
Public Shared Function GetHostStr As String
Visual C++
public:
static String^ GetHostStr()

Return Value

The url of the OfficeClip installation.

See Also

OCString Class
OfficeClip.Utils Namespace


GetInitialsFromName Method

[image]

OfficeClip API Documentation
OCString..::.GetInitialsFromName Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Gets the initials from the name

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetInitialsFromName(
    string name
)
Visual Basic (Declaration)
Public Shared Function GetInitialsFromName ( _
    name As String _
) As String
Visual C++
public:
static String^ GetInitialsFromName(
    String^ name
)

Parameters

name
Type: System..::.String
The name

Return Value

The initials

See Also

OCString Class
OfficeClip.Utils Namespace


IsDocTypeGifPresent Method

[image]

OfficeClip API Documentation
OCString..::.IsDocTypeGifPresent Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Verifies if the icon is present for a particular document type. The supported document types are shown in docGifTypes

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsDocTypeGifPresent(
    string ext
)
Visual Basic (Declaration)
Public Shared Function IsDocTypeGifPresent ( _
    ext As String _
) As Boolean
Visual C++
public:
static bool IsDocTypeGifPresent(
    String^ ext
)

Parameters

ext
Type: System..::.String
The file extension of the type of the file tested for icon presence.

Return Value

true if the gif is present for the particular type of the document, false otherwise.

See Also

OCString Class
OfficeClip.Utils Namespace


IsValidEmailAddress Method

[image]

OfficeClip API Documentation
OCString..::.IsValidEmailAddress Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Uses regular expressions to test if a passed string is a valid email address

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsValidEmailAddress(
    string emailAddress
)
Visual Basic (Declaration)
Public Shared Function IsValidEmailAddress ( _
    emailAddress As String _
) As Boolean
Visual C++
public:
static bool IsValidEmailAddress(
    String^ emailAddress
)

Parameters

emailAddress
Type: System..::.String
Email Address to be tested

Return Value

true if passed string is a valid email address

See Also

OCString Class
OfficeClip.Utils Namespace


ParseCsv Method

[image]

OfficeClip API Documentation
OCString..::.ParseCsv Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Parses the CSV string and loads all individual values in a string array.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string[] ParseCsv(
    string str
)
Visual Basic (Declaration)
Public Shared Function ParseCsv ( _
    str As String _
) As String()
Visual C++
public:
static array<String^>^ ParseCsv(
    String^ str
)

Parameters

str
Type: System..::.String
The csv string.

Return Value

The string array containing the parsed string values.

See Also

OCString Class
OfficeClip.Utils Namespace


ReadCsvLine Method

[image]

OfficeClip API Documentation
OCString..::.ReadCsvLine Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Reads a line from the comma separated StringReader. This function takes care of the fact that the csv line can span across multiple lines.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ReadCsvLine(
    StringReader sr
)
Visual Basic (Declaration)
Public Shared Function ReadCsvLine ( _
    sr As StringReader _
) As String
Visual C++
public:
static String^ ReadCsvLine(
    StringReader^ sr
)

Parameters

sr
Type: System.IO..::.StringReader
The input reader from where the next line is read.

Return Value

The line in the csv format.

See Also

OCString Class
OfficeClip.Utils Namespace


RemoveLastDirectorySeparator Method

[image]

OfficeClip API Documentation
OCString..::.RemoveLastDirectorySeparator Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

removes the last directory separator from the path. No action is taken if there is no directory separator at the end of the string.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string RemoveLastDirectorySeparator(
    string str
)
Visual Basic (Declaration)
Public Shared Function RemoveLastDirectorySeparator ( _
    str As String _
) As String
Visual C++
public:
static String^ RemoveLastDirectorySeparator(
    String^ str
)

Parameters

str
Type: System..::.String
The input string path.

Return Value

The string path after the directory separator is removed.

See Also

OCString Class
OfficeClip.Utils Namespace


ReplaceDBNull Method

[image] [image]

OfficeClip API Documentation
OCString..::.ReplaceDBNull Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ReplaceDBNull(Object, Boolean) | Replaces null with the value provided, ifthe objcet is null, then return the integer i, otherwise return the integer value of the object.
ReplaceDBNull(Object, DateTime) | Replaces null with the value provided, ifthe objcet is null, then return the integer i, otherwise return the integer value of the object.
ReplaceDBNull(Object, Double) | Replaces null with the value provided, ifthe object is null, then return the string s, otherwise return the integer value of the object.
ReplaceDBNull(Object, Int32) | Replaces null with the value provided, ifthe objcet is null, then return the integer i, otherwise return the integer value of the object.
ReplaceDBNull(Object, String) | Replaces null with the value provided, ifthe object is null, then return the string s, otherwise return the integer value of the object.

See Also

OCString Class
OCString Members
OfficeClip.Utils Namespace


ReplaceDBNull Method (Object, Boolean)

[image]

OfficeClip API Documentation
OCString..::.ReplaceDBNull Method (Object, Boolean)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Replaces null with the value provided, ifthe objcet is null, then return the integer i, otherwise return the integer value of the object.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool ReplaceDBNull(
    Object obj,
    bool retVal
)
Visual Basic (Declaration)
Public Shared Function ReplaceDBNull ( _
    obj As Object, _
    retVal As Boolean _
) As Boolean
Visual C++
public:
static bool ReplaceDBNull(
    Object^ obj,
    bool retVal
)

Parameters

obj
Type: System..::.Object
The object to be tested
retVal
Type: System..::.Boolean
The return value in case the first parameter is null

Return Value

See Also

OCString Class
ReplaceDBNull Overload
OfficeClip.Utils Namespace


ReplaceDBNull Method (Object, DateTime)

[image]

OfficeClip API Documentation
OCString..::.ReplaceDBNull Method (Object, DateTime)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Replaces null with the value provided, ifthe objcet is null, then return the integer i, otherwise return the integer value of the object.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime ReplaceDBNull(
    Object obj,
    DateTime d
)
Visual Basic (Declaration)
Public Shared Function ReplaceDBNull ( _
    obj As Object, _
    d As DateTime _
) As DateTime
Visual C++
public:
static DateTime ReplaceDBNull(
    Object^ obj,
    DateTime d
)

Parameters

obj
Type: System..::.Object
The object to be tested
d
Type: System..::.DateTime
The return value in case the first parameter is null

Return Value

See Also

OCString Class
ReplaceDBNull Overload
OfficeClip.Utils Namespace


ReplaceDBNull Method (Object, Double)

[image]

OfficeClip API Documentation
OCString..::.ReplaceDBNull Method (Object, Double)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Replaces null with the value provided, ifthe object is null, then return the string s, otherwise return the integer value of the object.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static double ReplaceDBNull(
    Object o,
    double d
)
Visual Basic (Declaration)
Public Shared Function ReplaceDBNull ( _
    o As Object, _
    d As Double _
) As Double
Visual C++
public:
static double ReplaceDBNull(
    Object^ o,
    double d
)

Parameters

o
Type: System..::.Object
The object to be tested
d
Type: System..::.Double
The return value in case the first parameter is null

Return Value

See Also

OCString Class
ReplaceDBNull Overload
OfficeClip.Utils Namespace


ReplaceDBNull Method (Object, Int32)

[image]

OfficeClip API Documentation
OCString..::.ReplaceDBNull Method (Object, Int32)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Replaces null with the value provided, ifthe objcet is null, then return the integer i, otherwise return the integer value of the object.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int ReplaceDBNull(
    Object o,
    int i
)
Visual Basic (Declaration)
Public Shared Function ReplaceDBNull ( _
    o As Object, _
    i As Integer _
) As Integer
Visual C++
public:
static int ReplaceDBNull(
    Object^ o,
    int i
)

Parameters

o
Type: System..::.Object
The object to be tested
i
Type: System..::.Int32
The return value in case the first parameter is null

Return Value

See Also

OCString Class
ReplaceDBNull Overload
OfficeClip.Utils Namespace


ReplaceDBNull Method (Object, String)

[image]

OfficeClip API Documentation
OCString..::.ReplaceDBNull Method (Object, String)
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Replaces null with the value provided, ifthe object is null, then return the string s, otherwise return the integer value of the object.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ReplaceDBNull(
    Object o,
    string s
)
Visual Basic (Declaration)
Public Shared Function ReplaceDBNull ( _
    o As Object, _
    s As String _
) As String
Visual C++
public:
static String^ ReplaceDBNull(
    Object^ o,
    String^ s
)

Parameters

o
Type: System..::.Object
The object to be tested
s
Type: System..::.String
The return value in case the first parameter is null

Return Value

See Also

OCString Class
ReplaceDBNull Overload
OfficeClip.Utils Namespace


ToApostrophe Method

[image]

OfficeClip API Documentation
OCString..::.ToApostrophe Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Gets the string converted into the Apostrophe for that noun.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToApostrophe(
    string str
)
Visual Basic (Declaration)
Public Shared Function ToApostrophe ( _
    str As String _
) As String
Visual C++
public:
static String^ ToApostrophe(
    String^ str
)

Parameters

str
Type: System..::.String
The input string which needs to be converted to Apostrophe.

Return Value

The Apostrophe converted string.

See Also

OCString Class
OfficeClip.Utils Namespace


ToCommonName Method

[image]

OfficeClip API Documentation
OCString..::.ToCommonName Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Converts the name string from the last_name, first_name format to the common name format (first_name last_name).

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToCommonName(
    string name
)
Visual Basic (Declaration)
Public Shared Function ToCommonName ( _
    name As String _
) As String
Visual C++
public:
static String^ ToCommonName(
    String^ name
)

Parameters

name
Type: System..::.String
The name in any format

Return Value

converted string to first_name last_name format

See Also

OCString Class
OfficeClip.Utils Namespace


ToDigitsOnly Method

[image]

OfficeClip API Documentation
OCString..::.ToDigitsOnly Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Filters out all the non digits and returns only the digits back.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ToDigitsOnly(
    string str
)
Visual Basic (Declaration)
Public Shared Function ToDigitsOnly ( _
    str As String _
) As String
Visual C++
public:
static String^ ToDigitsOnly(
    String^ str
)

Parameters

str
Type: System..::.String
The digit which needs to be filtered out.

Return Value

The string containing only the digits.

See Also

OCString Class
OfficeClip.Utils Namespace


TruncateFront Method

[image]

OfficeClip API Documentation
OCString..::.TruncateFront Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Truncates the string but does it from the front instead of back.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string TruncateFront(
    string stx,
    int limit
)
Visual Basic (Declaration)
Public Shared Function TruncateFront ( _
    stx As String, _
    limit As Integer _
) As String
Visual C++
public:
static String^ TruncateFront(
    String^ stx,
    int limit
)

Parameters

stx
Type: System..::.String
The input string.
limit
Type: System..::.Int32
The maximum number of characters to be shown.

Return Value

The truncated string.

See Also

OCString Class
OfficeClip.Utils Namespace


TruncateStr Method

[image]

OfficeClip API Documentation
OCString..::.TruncateStr Method
OCString Class See Also

[This is preliminary documentation and is subject to change.]

Truncates the string to its limit given as an integer argument. When the string is truncated, it is appended with three dots (...)

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string TruncateStr(
    string stx,
    int limit
)
Visual Basic (Declaration)
Public Shared Function TruncateStr ( _
    stx As String, _
    limit As Integer _
) As String
Visual C++
public:
static String^ TruncateStr(
    String^ stx,
    int limit
)

Parameters

stx
Type: System..::.String
The input string to be truncated.
limit
Type: System..::.Int32
The number of charaters to which the string is terminated.

Return Value

The truncated string.

See Also

OCString Class
OfficeClip.Utils Namespace


OCUri Class

[image]

OfficeClip API Documentation
OCUri Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods for the manipulation of the uri.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCUri : Uri
Visual Basic (Declaration)
Public Class OCUri _
    Inherits Uri
Visual C++
public ref class OCUri : public Uri

Inheritance Hierarchy

System..::.Object
System..::.Uri
OfficeClip.Utils..::.OCUri

See Also

OCUri Members
OfficeClip.Utils Namespace


OCUri Members

[image] [image]

OfficeClip API Documentation
OCUri Members
OCUri Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The OCUri type exposes the following members.

Constructors

 | Name | Description
Public method | OCUri | Default constructor

Methods

 | Name | Description
Protected method | Canonicalize | Obsolete. Converts the internally stored URI to canonical form. (Inherited from Uri.)
Protected method | CheckSecurity | Obsolete. Calling this method has no effect. (Inherited from Uri.)
Public method | Equals | Compares two Uri instances for equality. (Inherited from Uri.)
Protected method | Escape | Obsolete. Converts any unsafe or reserved characters in the path component to their hexadecimal character representations. (Inherited from Uri.)
 | EscapeString | Converts a string to its escaped representation..
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetComponents | Gets the specified components of the current instance using the specified escaping for special characters. (Inherited from Uri.)
Public method | GetHashCode | Returns the hash code for the URI. (Inherited from Uri.)
 | GetHtml | Returns an html screen back for a page.
Public method | GetLeftPart | Returns the specified portion of a Uri instance. (Inherited from Uri.)
Protected method | GetObjectData | Returns the data needed to serialize the current instance. (Inherited from Uri.)
 | GetReferrerAbsoluteUrl | Overloaded.
 | GetReferrerLocalPath | Gets the UrlReferrer local path
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsBadFileSystemCharacter | Obsolete. Returns a Boolean value that indicates whether a character is invalid in a file system name. (Inherited from Uri.)
Public method | IsBaseOf | Determines whether the current Uri instance is a base of the specified Uri instance. (Inherited from Uri.)
Protected method | IsReservedCharacter | Obsolete. Returns a Boolean that indicates whether the specified character is a reserved character. (Inherited from Uri.)
Public method | IsWellFormedOriginalString | Indicates whether the string used to construct this Uri was well-formed. (Inherited from Uri.)
Public method | MakeRelative | Obsolete. Determines the difference between two Uri instances. (Inherited from Uri.)
Public method | MakeRelativeUri | Determines the difference between two Uri instances. (Inherited from Uri.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Parse | Obsolete. Parses the URI of the current instance to ensure it contains all the parts required for a valid URI. (Inherited from Uri.)
Public method | ToString | Returns a canonical string representation for the specified Uri instance. (Inherited from Uri.)
Protected method | Unescape | Obsolete. Converts the specified string by replacing any escape sequences with their unescaped representation. (Inherited from Uri.)

Properties

 | Name | Description
Public property | AbsolutePath | Gets the absolute path of the URI. (Inherited from Uri.)
Public property | AbsoluteUri | Gets the absolute URI. (Inherited from Uri.)
Public property | Authority | Gets the Domain Name System (DNS) host name or IP address and the port number for a server. (Inherited from Uri.)
Public property | DnsSafeHost | Gets an unescaped host name that is safe to use for DNS resolution. (Inherited from Uri.)
Public property | Fragment | Gets the escaped fragment. (Inherited from Uri.)
Public property | Host | Gets the host component of this instance. (Inherited from Uri.)
Public property | HostNameType | Returns the type of the host name specified in the URI. (Inherited from Uri.)
Public property | IsAbsoluteUri | Gets a Boolean value that indicates whether the Uri instance is absolute. (Inherited from Uri.)
Public property | IsDefaultPort | Gets a value indicating whether the port value of the URI is the default for this scheme. (Inherited from Uri.)
Public property | IsFile | Gets a value indicating whether the specified Uri is a file URI. (Inherited from Uri.)
Public property | IsLoopback | Gets a Boolean value indicating whether the specified Uri references the local host. (Inherited from Uri.)
Public property | IsUnc | Gets a Boolean value indicating whether the specified Uri is a universal naming convention (UNC) path. (Inherited from Uri.)
Public property | LocalPath | Gets a local operating-system representation of a file name. (Inherited from Uri.)
Public property | OriginalString | Gets the original URI string that was passed to the Uri constructor. (Inherited from Uri.)
Public property | PathAndQuery | Gets the AbsolutePath and Query properties separated by a question mark (?). (Inherited from Uri.)
Public property | Port | Gets the port number of this URI. (Inherited from Uri.)
Public property | Query | Gets any query information included in the specified URI. (Inherited from Uri.)
Public property | Scheme | Gets the scheme name for this URI. (Inherited from Uri.)
Public property | Segments | Gets an array containing the path segments that make up the specified URI. (Inherited from Uri.)
Public property | UserEscaped | Indicates that the URI string was completely escaped before the Uri instance was created. (Inherited from Uri.)
Public property | UserInfo | Gets the user name, password, or other user-specific information associated with the specified URI. (Inherited from Uri.)

See Also

OCUri Class
OfficeClip.Utils Namespace


OCUri Constructor

[image]

OfficeClip API Documentation
OCUri Constructor
OCUri Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCUri(
    string uriStr
)
Visual Basic (Declaration)
Public Sub New ( _
    uriStr As String _
)
Visual C++
public:
OCUri(
    String^ uriStr
)

Parameters

uriStr
Type: System..::.String

See Also

OCUri Class
OfficeClip.Utils Namespace


OCUri Methods

[image] [image]

OfficeClip API Documentation
OCUri Methods
OCUri Class See Also

[This is preliminary documentation and is subject to change.]

The OCUri type exposes the following methods.

Methods

 | Name | Description
Protected method | Canonicalize | Obsolete. Converts the internally stored URI to canonical form. (Inherited from Uri.)
Protected method | CheckSecurity | Obsolete. Calling this method has no effect. (Inherited from Uri.)
Public method | Equals | Compares two Uri instances for equality. (Inherited from Uri.)
Protected method | Escape | Obsolete. Converts any unsafe or reserved characters in the path component to their hexadecimal character representations. (Inherited from Uri.)
 | EscapeString | Converts a string to its escaped representation..
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetComponents | Gets the specified components of the current instance using the specified escaping for special characters. (Inherited from Uri.)
Public method | GetHashCode | Returns the hash code for the URI. (Inherited from Uri.)
 | GetHtml | Returns an html screen back for a page.
Public method | GetLeftPart | Returns the specified portion of a Uri instance. (Inherited from Uri.)
Protected method | GetObjectData | Returns the data needed to serialize the current instance. (Inherited from Uri.)
 | GetReferrerAbsoluteUrl | Overloaded.
 | GetReferrerLocalPath | Gets the UrlReferrer local path
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IsBadFileSystemCharacter | Obsolete. Returns a Boolean value that indicates whether a character is invalid in a file system name. (Inherited from Uri.)
Public method | IsBaseOf | Determines whether the current Uri instance is a base of the specified Uri instance. (Inherited from Uri.)
Protected method | IsReservedCharacter | Obsolete. Returns a Boolean that indicates whether the specified character is a reserved character. (Inherited from Uri.)
Public method | IsWellFormedOriginalString | Indicates whether the string used to construct this Uri was well-formed. (Inherited from Uri.)
Public method | MakeRelative | Obsolete. Determines the difference between two Uri instances. (Inherited from Uri.)
Public method | MakeRelativeUri | Determines the difference between two Uri instances. (Inherited from Uri.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Parse | Obsolete. Parses the URI of the current instance to ensure it contains all the parts required for a valid URI. (Inherited from Uri.)
Public method | ToString | Returns a canonical string representation for the specified Uri instance. (Inherited from Uri.)
Protected method | Unescape | Obsolete. Converts the specified string by replacing any escape sequences with their unescaped representation. (Inherited from Uri.)

See Also

OCUri Class
OfficeClip.Utils Namespace


EscapeString Method

[image]

OfficeClip API Documentation
OCUri..::.EscapeString Method
OCUri Class See Also

[This is preliminary documentation and is subject to change.]

Converts a string to its escaped representation..

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string EscapeString(
    string str
)
Visual Basic (Declaration)
Public Shared Function EscapeString ( _
    str As String _
) As String
Visual C++
public:
static String^ EscapeString(
    String^ str
)

Parameters

str
Type: System..::.String
The string to transform to its escaped representation.

Return Value

The escaped representation of the string.

See Also

OCUri Class
OfficeClip.Utils Namespace


GetHtml Method

[image]

OfficeClip API Documentation
OCUri..::.GetHtml Method
OCUri Class See Also

[This is preliminary documentation and is subject to change.]

Returns an html screen back for a page.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetHtml(
    string url
)
Visual Basic (Declaration)
Public Shared Function GetHtml ( _
    url As String _
) As String
Visual C++
public:
static String^ GetHtml(
    String^ url
)

Parameters

url
Type: System..::.String
Make sure you send url string with http:// in the front Basically it should be a fully qualified url.

Return Value

The output string.

See Also

OCUri Class
OfficeClip.Utils Namespace


GetReferrerAbsoluteUrl Method

[image] [image]

OfficeClip API Documentation
OCUri..::.GetReferrerAbsoluteUrl Method
OCUri Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetReferrerAbsoluteUrl(HttpRequest) | Gets the referrer Uri
GetReferrerAbsoluteUrl(HttpRequest, String) | Gets the referrer Uri or a default string

See Also

OCUri Class
OCUri Members
OfficeClip.Utils Namespace


GetReferrerAbsoluteUrl Method (HttpRequest)

[image]

OfficeClip API Documentation
OCUri..::.GetReferrerAbsoluteUrl Method (HttpRequest)
OCUri Class See Also

[This is preliminary documentation and is subject to change.]

Gets the referrer Uri

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetReferrerAbsoluteUrl(
    HttpRequest hr
)
Visual Basic (Declaration)
Public Shared Function GetReferrerAbsoluteUrl ( _
    hr As HttpRequest _
) As String
Visual C++
public:
static String^ GetReferrerAbsoluteUrl(
    HttpRequest^ hr
)

Parameters

hr
Type: System.Web..::.HttpRequest
The http request parameter of the page

Return Value

returns the referrer url if successful, empty string if failed

See Also

OCUri Class
GetReferrerAbsoluteUrl Overload
OfficeClip.Utils Namespace


GetReferrerAbsoluteUrl Method (HttpRequest, String)

[image]

OfficeClip API Documentation
OCUri..::.GetReferrerAbsoluteUrl Method (HttpRequest, String)
OCUri Class See Also

[This is preliminary documentation and is subject to change.]

Gets the referrer Uri or a default string

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetReferrerAbsoluteUrl(
    HttpRequest hr,
    string defaultUri
)
Visual Basic (Declaration)
Public Shared Function GetReferrerAbsoluteUrl ( _
    hr As HttpRequest, _
    defaultUri As String _
) As String
Visual C++
public:
static String^ GetReferrerAbsoluteUrl(
    HttpRequest^ hr,
    String^ defaultUri
)

Parameters

hr
Type: System.Web..::.HttpRequest
The http request parameter of the page
defaultUri
Type: System..::.String
The default uri used in case uri is not found

Return Value

returns the referrer url if successful, default uri if failed

See Also

OCUri Class
GetReferrerAbsoluteUrl Overload
OfficeClip.Utils Namespace


GetReferrerLocalPath Method

[image]

OfficeClip API Documentation
OCUri..::.GetReferrerLocalPath Method
OCUri Class See Also

[This is preliminary documentation and is subject to change.]

Gets the UrlReferrer local path

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetReferrerLocalPath(
    HttpRequest hr
)
Visual Basic (Declaration)
Public Shared Function GetReferrerLocalPath ( _
    hr As HttpRequest _
) As String
Visual C++
public:
static String^ GetReferrerLocalPath(
    HttpRequest^ hr
)

Parameters

hr
Type: System.Web..::.HttpRequest
The httprequest of the page

Return Value

returns the localpath if successful, empty string if failed

See Also

OCUri Class
OfficeClip.Utils Namespace


OCUserControl Class

[image]

OfficeClip API Documentation
OCUserControl Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class for manipulation of user controls

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class OCUserControl
Visual Basic (Declaration)
Public Class OCUserControl
Visual C++
public ref class OCUserControl

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.OCUserControl

See Also

OCUserControl Members
OfficeClip.Utils Namespace


OCUserControl Members

[image] [image]

OfficeClip API Documentation
OCUserControl Members
OCUserControl Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The OCUserControl type exposes the following members.

Constructors

 | Name | Description
Public method | OCUserControl |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControlRecursive | Checks for a control recursively based on its id and returns it. Returns null if the control is not present.
 | FindControlRecursiveByType | Recursive finds a control given its type
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCUserControl Class
OfficeClip.Utils Namespace


OCUserControl Constructor

[image]

OfficeClip API Documentation
OCUserControl Constructor
OCUserControl Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public OCUserControl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OCUserControl()

See Also

OCUserControl Class
OfficeClip.Utils Namespace


OCUserControl Methods

[image] [image]

OfficeClip API Documentation
OCUserControl Methods
OCUserControl Class See Also

[This is preliminary documentation and is subject to change.]

The OCUserControl type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControlRecursive | Checks for a control recursively based on its id and returns it. Returns null if the control is not present.
 | FindControlRecursiveByType | Recursive finds a control given its type
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OCUserControl Class
OfficeClip.Utils Namespace


FindControlRecursive Method

[image]

OfficeClip API Documentation
OCUserControl..::.FindControlRecursive Method
OCUserControl Class See Also

[This is preliminary documentation and is subject to change.]

Checks for a control recursively based on its id and returns it. Returns null if the control is not present.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static Control FindControlRecursive(
    Control startControl,
    string id
)
Visual Basic (Declaration)
Public Shared Function FindControlRecursive ( _
    startControl As Control, _
    id As String _
) As Control
Visual C++
public:
static Control^ FindControlRecursive(
    Control^ startControl,
    String^ id
)

Parameters

startControl
Type: System.Web.UI..::.Control
The starting point from where the control is checked
id
Type: System..::.String
The id of the control

Return Value

the found control or null if the control is not found

See Also

OCUserControl Class
OfficeClip.Utils Namespace


FindControlRecursiveByType Method

[image]

OfficeClip API Documentation
OCUserControl..::.FindControlRecursiveByType Method
OCUserControl Class See Also

[This is preliminary documentation and is subject to change.]

Recursive finds a control given its type

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static Control FindControlRecursiveByType(
    Control startControl,
    string type
)
Visual Basic (Declaration)
Public Shared Function FindControlRecursiveByType ( _
    startControl As Control, _
    type As String _
) As Control
Visual C++
public:
static Control^ FindControlRecursiveByType(
    Control^ startControl,
    String^ type
)

Parameters

startControl
Type: System.Web.UI..::.Control
The start control from where the recusive tree search should begin
type
Type: System..::.String
The type of the control

Return Value

The returned control, null if no control is found

See Also

OCUserControl Class
OfficeClip.Utils Namespace


Periodicity Enumeration

[image]

OfficeClip API Documentation
Periodicity Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Determins the enumerated type to define various periods in OfficeClip.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum Periodicity
Visual Basic (Declaration)
Public Enumeration Periodicity
Visual C++
public enum class Periodicity

Members

Member name | Description
None | No period, kept here for exception and error handling and to supply default value.
Daily | Occurs each day
Weekly | Occurs once in a week
Monthly | occurs once in a month
Yearly | occurs once in a year

See Also

OfficeClip.Utils Namespace


PopulateDateItems Class

[image]

OfficeClip API Documentation
PopulateDateItems Class
Members See Also

[This is preliminary documentation and is subject to change.]

Populates the date components in a dropdown box. Examples of dropdown boxes are Month Dropdown, Week drop down etc.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class PopulateDateItems : DateTimeConst
Visual Basic (Declaration)
Public Class PopulateDateItems _
    Inherits DateTimeConst
Visual C++
public ref class PopulateDateItems : public DateTimeConst

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.DateTimeConst
OfficeClip.Utils..::.PopulateDateItems

See Also

PopulateDateItems Members
OfficeClip.Utils Namespace


PopulateDateItems Members

[image] [image]

OfficeClip API Documentation
PopulateDateItems Members
PopulateDateItems Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The PopulateDateItems type exposes the following members.

Constructors

 | Name | Description
Public method | PopulateDateItems | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAbbreviatedDayName | Gets the abbreviated day name (Inherited from DateTimeConst.)
Public method | GetDayNames | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMonthNames | Returns the culture-specific full name of the specified month based on the System.Globalization.CultureInfo of the current thread. System.Globalization..::.DateTimeFormatInfo (Inherited from DateTimeConst.)
Public method | GetRank | Returns the Rank of a particular integer (Inherited from DateTimeConst.)
Public method | GetShortMonthNames | Returns the short name of the specified month based on the CultureOnfo of the current thread. (Inherited from DateTimeConst.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PopulateAmPm | Populate the AM and PM text in the drop down list.
Public method | PopulateDay | Overloaded.
Public method | PopulateDayOfWeek | Populates the day of the week in the drop down list.
Public method | PopulateHour | Populates the hour (1-12) in the drop down list.
Public method | PopulateMinute | Overloaded.
Public method | PopulateMonth | Overloaded.
Public method | PopulateMonthNumber | Populates the month number instead of the month names in the drop down box. The month number is represented from 1(January) to 12(December).
Public method | PopulateReminder | Populates the reminder dropdown list
Public method | PopulateWeekCount | Populate the week count in the drop down box. The drop down box created will have the following entries, first(1), second(2), third(3), fourth(4) and last(5).
Public method | PopulateYear | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PopulateDateItems Class
OfficeClip.Utils Namespace


PopulateDateItems Constructor

[image] [image]

OfficeClip API Documentation
PopulateDateItems Constructor
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PopulateDateItems()()() | Default constructor.
Public method | PopulateDateItems(DateTime) | Constructor taking the date as input.

See Also

PopulateDateItems Class
PopulateDateItems Members
OfficeClip.Utils Namespace


PopulateDateItems Constructor

[image]

OfficeClip API Documentation
PopulateDateItems Constructor
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Default constructor.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public PopulateDateItems()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PopulateDateItems()

See Also

PopulateDateItems Class
PopulateDateItems Overload
OfficeClip.Utils Namespace


PopulateDateItems Constructor (DateTime)

[image]

OfficeClip API Documentation
PopulateDateItems Constructor (DateTime)
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Constructor taking the date as input.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public PopulateDateItems(
    DateTime datim
)
Visual Basic (Declaration)
Public Sub New ( _
    datim As DateTime _
)
Visual C++
public:
PopulateDateItems(
    DateTime datim
)

Parameters

datim
Type: System..::.DateTime
The date time object.

See Also

PopulateDateItems Class
PopulateDateItems Overload
OfficeClip.Utils Namespace


PopulateDateItems Methods

[image] [image]

OfficeClip API Documentation
PopulateDateItems Methods
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

The PopulateDateItems type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAbbreviatedDayName | Gets the abbreviated day name (Inherited from DateTimeConst.)
Public method | GetDayNames | Overloaded.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetMonthNames | Returns the culture-specific full name of the specified month based on the System.Globalization.CultureInfo of the current thread. System.Globalization..::.DateTimeFormatInfo (Inherited from DateTimeConst.)
Public method | GetRank | Returns the Rank of a particular integer (Inherited from DateTimeConst.)
Public method | GetShortMonthNames | Returns the short name of the specified month based on the CultureOnfo of the current thread. (Inherited from DateTimeConst.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PopulateAmPm | Populate the AM and PM text in the drop down list.
Public method | PopulateDay | Overloaded.
Public method | PopulateDayOfWeek | Populates the day of the week in the drop down list.
Public method | PopulateHour | Populates the hour (1-12) in the drop down list.
Public method | PopulateMinute | Overloaded.
Public method | PopulateMonth | Overloaded.
Public method | PopulateMonthNumber | Populates the month number instead of the month names in the drop down box. The month number is represented from 1(January) to 12(December).
Public method | PopulateReminder | Populates the reminder dropdown list
Public method | PopulateWeekCount | Populate the week count in the drop down box. The drop down box created will have the following entries, first(1), second(2), third(3), fourth(4) and last(5).
Public method | PopulateYear | Overloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PopulateDateItems Class
OfficeClip.Utils Namespace


GetDayNames Method

[image] [image]

OfficeClip API Documentation
PopulateDateItems..::.GetDayNames Method
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | GetDayNames(ArrayList) | Returns the comma separated day names given an ArrayList of day id (Inherited from DateTimeConst.)
Public method | GetDayNames(Int32) | Returns the day name in the current culture given the day id. (Inherited from DateTimeConst.)

See Also

PopulateDateItems Class
PopulateDateItems Members
OfficeClip.Utils Namespace


PopulateAmPm Method

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateAmPm Method
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populate the AM and PM text in the drop down list.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateAmPm(
    DropDownList dr
)
Visual Basic (Declaration)
Public Sub PopulateAmPm ( _
    dr As DropDownList _
)
Visual C++
public:
void PopulateAmPm(
    DropDownList^ dr
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The drop down list to be populated.

See Also

PopulateDateItems Class
OfficeClip.Utils Namespace


PopulateDay Method

[image] [image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateDay Method
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PopulateDay(DropDownList) | Populates day in the drop down list.
Public method | PopulateDay(DropDownList, String) | Populates day in the drop down list by populating. The first row of the list can be created separately by this method. The value of the list item of the first row is set to -1.

See Also

PopulateDateItems Class
PopulateDateItems Members
OfficeClip.Utils Namespace


PopulateDay Method (DropDownList)

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateDay Method (DropDownList)
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populates day in the drop down list.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateDay(
    DropDownList dr
)
Visual Basic (Declaration)
Public Sub PopulateDay ( _
    dr As DropDownList _
)
Visual C++
public:
void PopulateDay(
    DropDownList^ dr
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The drop down list to be populated.

See Also

PopulateDateItems Class
PopulateDay Overload
OfficeClip.Utils Namespace


PopulateDay Method (DropDownList, String)

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateDay Method (DropDownList, String)
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populates day in the drop down list by populating. The first row of the list can be created separately by this method. The value of the list item of the first row is set to -1.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateDay(
    DropDownList dr,
    string firstRow
)
Visual Basic (Declaration)
Public Sub PopulateDay ( _
    dr As DropDownList, _
    firstRow As String _
)
Visual C++
public:
void PopulateDay(
    DropDownList^ dr,
    String^ firstRow
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The drop down list to be populated.
firstRow
Type: System..::.String
The text on the first row.

See Also

PopulateDateItems Class
PopulateDay Overload
OfficeClip.Utils Namespace


PopulateDayOfWeek Method

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateDayOfWeek Method
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populates the day of the week in the drop down list.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateDayOfWeek(
    DropDownList dr
)
Visual Basic (Declaration)
Public Sub PopulateDayOfWeek ( _
    dr As DropDownList _
)
Visual C++
public:
void PopulateDayOfWeek(
    DropDownList^ dr
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The drop down list to be populated.

See Also

PopulateDateItems Class
OfficeClip.Utils Namespace


PopulateHour Method

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateHour Method
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populates the hour (1-12) in the drop down list.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateHour(
    DropDownList dr
)
Visual Basic (Declaration)
Public Sub PopulateHour ( _
    dr As DropDownList _
)
Visual C++
public:
void PopulateHour(
    DropDownList^ dr
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
the drop down list to be populated.

See Also

PopulateDateItems Class
OfficeClip.Utils Namespace


PopulateMinute Method

[image] [image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateMinute Method
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PopulateMinute(DropDownList) | Populate the minutes (in increment of 5) in the drop down list.
Public method | PopulateMinute(DropDownList, Int32) | Populate the minutes (in increment of 5) in the drop down list.

See Also

PopulateDateItems Class
PopulateDateItems Members
OfficeClip.Utils Namespace


PopulateMinute Method (DropDownList)

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateMinute Method (DropDownList)
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populate the minutes (in increment of 5) in the drop down list.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateMinute(
    DropDownList dr
)
Visual Basic (Declaration)
Public Sub PopulateMinute ( _
    dr As DropDownList _
)
Visual C++
public:
void PopulateMinute(
    DropDownList^ dr
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The drop down list to be populated.

See Also

PopulateDateItems Class
PopulateMinute Overload
OfficeClip.Utils Namespace


PopulateMinute Method (DropDownList, Int32)

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateMinute Method (DropDownList, Int32)
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populate the minutes (in increment of 5) in the drop down list.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateMinute(
    DropDownList dr,
    int mi
)
Visual Basic (Declaration)
Public Sub PopulateMinute ( _
    dr As DropDownList, _
    mi As Integer _
)
Visual C++
public:
void PopulateMinute(
    DropDownList^ dr,
    int mi
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The drop down list to be populated.
mi
Type: System..::.Int32
Minute Increment.

See Also

PopulateDateItems Class
PopulateMinute Overload
OfficeClip.Utils Namespace


PopulateMonth Method

[image] [image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateMonth Method
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PopulateMonth(DropDownList) | Populate the short months in the month drop down list. An example of short months are Jan, Feb etc.
Public method | PopulateMonth(DropDownList, Boolean) | Populates the month(short or long) months in the drop down list.
Public method | PopulateMonth(DropDownList, String) | Populates the month drop down list by providing the first row. The first row is usually used to provide instructions (i.e. to select other rows etc.). This method populates the short form of the month in rest of the rows. The value of the first row is always -1 in the drop down list.
Public method | PopulateMonth(DropDownList, String, Boolean) | Populates the month drop down list by providing the first row. The first row is usually used to provide instructions (i.e. to select other rows etc.). The value of the first row is always -1 in the drop down list.

See Also

PopulateDateItems Class
PopulateDateItems Members
OfficeClip.Utils Namespace


PopulateMonth Method (DropDownList)

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateMonth Method (DropDownList)
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populate the short months in the month drop down list. An example of short months are Jan, Feb etc.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateMonth(
    DropDownList dr
)
Visual Basic (Declaration)
Public Sub PopulateMonth ( _
    dr As DropDownList _
)
Visual C++
public:
void PopulateMonth(
    DropDownList^ dr
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
the month drop down list.

See Also

PopulateDateItems Class
PopulateMonth Overload
OfficeClip.Utils Namespace


PopulateMonth Method (DropDownList, Boolean)

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateMonth Method (DropDownList, Boolean)
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populates the month(short or long) months in the drop down list.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateMonth(
    DropDownList dr,
    bool isShort
)
Visual Basic (Declaration)
Public Sub PopulateMonth ( _
    dr As DropDownList, _
    isShort As Boolean _
)
Visual C++
public:
void PopulateMonth(
    DropDownList^ dr,
    bool isShort
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The month drop down list.
isShort
Type: System..::.Boolean
if true populates the short months (Jan, Feb etc.), if false populates the long drop down months (January, February etc.).

See Also

PopulateDateItems Class
PopulateMonth Overload
OfficeClip.Utils Namespace


PopulateMonth Method (DropDownList, String)

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateMonth Method (DropDownList, String)
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populates the month drop down list by providing the first row. The first row is usually used to provide instructions (i.e. to select other rows etc.). This method populates the short form of the month in rest of the rows. The value of the first row is always -1 in the drop down list.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateMonth(
    DropDownList dr,
    string firstRow
)
Visual Basic (Declaration)
Public Sub PopulateMonth ( _
    dr As DropDownList, _
    firstRow As String _
)
Visual C++
public:
void PopulateMonth(
    DropDownList^ dr,
    String^ firstRow
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The drop down list to be populated.
firstRow
Type: System..::.String
The text of the first row.

See Also

PopulateDateItems Class
PopulateMonth Overload
OfficeClip.Utils Namespace


PopulateMonth Method (DropDownList, String, Boolean)

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateMonth Method (DropDownList, String, Boolean)
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populates the month drop down list by providing the first row. The first row is usually used to provide instructions (i.e. to select other rows etc.). The value of the first row is always -1 in the drop down list.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateMonth(
    DropDownList dr,
    string firstRow,
    bool isShort
)
Visual Basic (Declaration)
Public Sub PopulateMonth ( _
    dr As DropDownList, _
    firstRow As String, _
    isShort As Boolean _
)
Visual C++
public:
void PopulateMonth(
    DropDownList^ dr,
    String^ firstRow,
    bool isShort
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The drop down list to be populated.
firstRow
Type: System..::.String
The text on the first row.
isShort
Type: System..::.Boolean
if true populates the short months (Jan, Feb etc.), if false populates the long drop down months (January, February etc.).

See Also

PopulateDateItems Class
PopulateMonth Overload
OfficeClip.Utils Namespace


PopulateMonthNumber Method

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateMonthNumber Method
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populates the month number instead of the month names in the drop down box. The month number is represented from 1(January) to 12(December).

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateMonthNumber(
    DropDownList dr
)
Visual Basic (Declaration)
Public Sub PopulateMonthNumber ( _
    dr As DropDownList _
)
Visual C++
public:
void PopulateMonthNumber(
    DropDownList^ dr
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The dropdown box to populate the month number.

See Also

PopulateDateItems Class
OfficeClip.Utils Namespace


PopulateReminder Method

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateReminder Method
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populates the reminder dropdown list

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateReminder(
    DropDownList ddlWhenToRemind
)
Visual Basic (Declaration)
Public Sub PopulateReminder ( _
    ddlWhenToRemind As DropDownList _
)
Visual C++
public:
void PopulateReminder(
    DropDownList^ ddlWhenToRemind
)

Parameters

ddlWhenToRemind
Type: System.Web.UI.WebControls..::.DropDownList
The dropdown list item

See Also

PopulateDateItems Class
OfficeClip.Utils Namespace


PopulateWeekCount Method

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateWeekCount Method
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populate the week count in the drop down box. The drop down box created will have the following entries, first(1), second(2), third(3), fourth(4) and last(5).

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateWeekCount(
    DropDownList dr
)
Visual Basic (Declaration)
Public Sub PopulateWeekCount ( _
    dr As DropDownList _
)
Visual C++
public:
void PopulateWeekCount(
    DropDownList^ dr
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
the drop down list to be populated.

See Also

PopulateDateItems Class
OfficeClip.Utils Namespace


PopulateYear Method

[image] [image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateYear Method
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | PopulateYear(DropDownList, Int32) | Populates the year in the drop down list
Public method | PopulateYear(DropDownList, Int32, Int32) | Populates the year in the drop down list.

See Also

PopulateDateItems Class
PopulateDateItems Members
OfficeClip.Utils Namespace


PopulateYear Method (DropDownList, Int32)

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateYear Method (DropDownList, Int32)
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populates the year in the drop down list

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateYear(
    DropDownList dr,
    int dtSpan
)
Visual Basic (Declaration)
Public Sub PopulateYear ( _
    dr As DropDownList, _
    dtSpan As Integer _
)
Visual C++
public:
void PopulateYear(
    DropDownList^ dr,
    int dtSpan
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The drop down list where the year needs to be populated
dtSpan
Type: System..::.Int32
The span of year that needs to be populated in the drop down list. If the current year is 2002 and this parameter is 2, the years to be populated are 2001, 2002 and 2003.

See Also

PopulateDateItems Class
PopulateYear Overload
OfficeClip.Utils Namespace


PopulateYear Method (DropDownList, Int32, Int32)

[image]

OfficeClip API Documentation
PopulateDateItems..::.PopulateYear Method (DropDownList, Int32, Int32)
PopulateDateItems Class See Also

[This is preliminary documentation and is subject to change.]

Populates the year in the drop down list.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public void PopulateYear(
    DropDownList dr,
    int lowerSpan,
    int upperSpan
)
Visual Basic (Declaration)
Public Sub PopulateYear ( _
    dr As DropDownList, _
    lowerSpan As Integer, _
    upperSpan As Integer _
)
Visual C++
public:
void PopulateYear(
    DropDownList^ dr,
    int lowerSpan,
    int upperSpan
)

Parameters

dr
Type: System.Web.UI.WebControls..::.DropDownList
The drop down list to be populated.
lowerSpan
Type: System..::.Int32
The lower span
upperSpan
Type: System..::.Int32
The upper span

See Also

PopulateDateItems Class
PopulateYear Overload
OfficeClip.Utils Namespace


Provider Class

[image]

OfficeClip API Documentation
Provider Class
Members See Also

[This is preliminary documentation and is subject to change.]

Helper class for the personalization provider

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static class Provider
Visual Basic (Declaration)
Public NotInheritable Class Provider
Visual C++
public ref class Provider abstract sealed

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.Provider

See Also

Provider Members
OfficeClip.Utils Namespace


Provider Members

[image] [image]

OfficeClip API Documentation
Provider Members
Provider Class Methods See Also

[This is preliminary documentation and is subject to change.]

The Provider type exposes the following members.

Methods

Name | Description
GetDefaultAppName | Gets the default application name

See Also

Provider Class
OfficeClip.Utils Namespace


Provider Methods

[image] [image]

OfficeClip API Documentation
Provider Methods
Provider Class See Also

[This is preliminary documentation and is subject to change.]

The Provider type exposes the following methods.

Methods

Name | Description
GetDefaultAppName | Gets the default application name

See Also

Provider Class
OfficeClip.Utils Namespace


GetDefaultAppName Method

[image]

OfficeClip API Documentation
Provider..::.GetDefaultAppName Method
Provider Class See Also

[This is preliminary documentation and is subject to change.]

Gets the default application name

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetDefaultAppName()
Visual Basic (Declaration)
Public Shared Function GetDefaultAppName As String
Visual C++
public:
static String^ GetDefaultAppName()

Return Value

The default application name

See Also

Provider Class
OfficeClip.Utils Namespace


PurchaseMethod Enumeration

[image]

OfficeClip API Documentation
PurchaseMethod Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides the purchase method, this can either be credit card or purchase order.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum PurchaseMethod
Visual Basic (Declaration)
Public Enumeration PurchaseMethod
Visual C++
public enum class PurchaseMethod

Members

Member name | Description
CreditCard | Credit Card Purchase Method
PurchaseOrder | Purchase Order purchase Method
PayPal | PayPal purchase method

See Also

OfficeClip.Utils Namespace


RegionalSettings Class

[image]

OfficeClip API Documentation
RegionalSettings Class
Members See Also

[This is preliminary documentation and is subject to change.]

The regional settings object

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class RegionalSettings
Visual Basic (Declaration)
Public Class RegionalSettings
Visual C++
public ref class RegionalSettings

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.RegionalSettings

See Also

RegionalSettings Members
OfficeClip.Utils Namespace


RegionalSettings Members

[image] [image]

OfficeClip API Documentation
RegionalSettings Members
RegionalSettings Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The RegionalSettings type exposes the following members.

Constructors

 | Name | Description
Public method | RegionalSettings | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Serializer (Overrides Object..::.ToString()()().)

Properties

 | Name | Description
Public property | Culture | Culture code (e.g. en-US)
Public property | LongDate | Long date format
Public property | LongTime | Long time format
Public property | MediumDate | Medium date format
Public property | MediumTime | Medium time format
Public property | ShortDate | Short date format
Public property | ShortTime | Short time format
Public property | UICulture | UI culture code (e.g. en-US)

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


RegionalSettings Constructor

[image] [image]

OfficeClip API Documentation
RegionalSettings Constructor
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | RegionalSettings()()() | Constructor
Public method | RegionalSettings(String) | Constructor

See Also

RegionalSettings Class
RegionalSettings Members
OfficeClip.Utils Namespace


RegionalSettings Constructor

[image]

OfficeClip API Documentation
RegionalSettings Constructor
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public RegionalSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RegionalSettings()

See Also

RegionalSettings Class
RegionalSettings Overload
OfficeClip.Utils Namespace


RegionalSettings Constructor (String)

[image]

OfficeClip API Documentation
RegionalSettings Constructor (String)
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Constructor

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public RegionalSettings(
    string settings
)
Visual Basic (Declaration)
Public Sub New ( _
    settings As String _
)
Visual C++
public:
RegionalSettings(
    String^ settings
)

Parameters

settings
Type: System..::.String

See Also

RegionalSettings Class
RegionalSettings Overload
OfficeClip.Utils Namespace


RegionalSettings Methods

[image] [image]

OfficeClip API Documentation
RegionalSettings Methods
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

The RegionalSettings type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Serializer (Overrides Object..::.ToString()()().)

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


ToString Method

[image]

OfficeClip API Documentation
RegionalSettings..::.ToString Method
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Serializer

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The serialized string representing the regional settings

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


RegionalSettings Properties

[image] [image]

OfficeClip API Documentation
RegionalSettings Properties
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

The RegionalSettings type exposes the following properties.

Properties

 | Name | Description
Public property | Culture | Culture code (e.g. en-US)
Public property | LongDate | Long date format
Public property | LongTime | Long time format
Public property | MediumDate | Medium date format
Public property | MediumTime | Medium time format
Public property | ShortDate | Short date format
Public property | ShortTime | Short time format
Public property | UICulture | UI culture code (e.g. en-US)

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


Culture Property

[image]

OfficeClip API Documentation
RegionalSettings..::.Culture Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Culture code (e.g. en-US)

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string Culture { get; set; }
Visual Basic (Declaration)
Public Property Culture As String
Visual C++
public:
property String^ Culture {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


LongDate Property

[image]

OfficeClip API Documentation
RegionalSettings..::.LongDate Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Long date format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string LongDate { get; set; }
Visual Basic (Declaration)
Public Property LongDate As String
Visual C++
public:
property String^ LongDate {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


LongTime Property

[image]

OfficeClip API Documentation
RegionalSettings..::.LongTime Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Long time format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string LongTime { get; set; }
Visual Basic (Declaration)
Public Property LongTime As String
Visual C++
public:
property String^ LongTime {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


MediumDate Property

[image]

OfficeClip API Documentation
RegionalSettings..::.MediumDate Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Medium date format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string MediumDate { get; set; }
Visual Basic (Declaration)
Public Property MediumDate As String
Visual C++
public:
property String^ MediumDate {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


MediumTime Property

[image]

OfficeClip API Documentation
RegionalSettings..::.MediumTime Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Medium time format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string MediumTime { get; set; }
Visual Basic (Declaration)
Public Property MediumTime As String
Visual C++
public:
property String^ MediumTime {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


ShortDate Property

[image]

OfficeClip API Documentation
RegionalSettings..::.ShortDate Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Short date format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string ShortDate { get; set; }
Visual Basic (Declaration)
Public Property ShortDate As String
Visual C++
public:
property String^ ShortDate {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


ShortTime Property

[image]

OfficeClip API Documentation
RegionalSettings..::.ShortTime Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

Short time format

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string ShortTime { get; set; }
Visual Basic (Declaration)
Public Property ShortTime As String
Visual C++
public:
property String^ ShortTime {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


UICulture Property

[image]

OfficeClip API Documentation
RegionalSettings..::.UICulture Property
RegionalSettings Class See Also

[This is preliminary documentation and is subject to change.]

UI culture code (e.g. en-US)

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string UICulture { get; set; }
Visual Basic (Declaration)
Public Property UICulture As String
Visual C++
public:
property String^ UICulture {
    String^ get ();
    void set (String^ value);
}

See Also

RegionalSettings Class
OfficeClip.Utils Namespace


ReportExportFormat Enumeration

[image]

OfficeClip API Documentation
ReportExportFormat Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The export format for reports

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum ReportExportFormat
Visual Basic (Declaration)
Public Enumeration ReportExportFormat
Visual C++
public enum class ReportExportFormat

Members

Member name | Description
Unknown | Unknown format, mainly used for error conditions
PDF | PDF Format (can be viewed using adobe acrobat reader)
MicrosoftWord | Word .doc file format
Rtf | Microsoft word rtf file format
Excel | Microsoft excel format
Html32 | Html 3.2 format
Html40 | Html 4.0 format

See Also

OfficeClip.Utils Namespace


ReturnStatus Enumeration

[image]

OfficeClip API Documentation
ReturnStatus Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The generic return status in OfficeClip. Can either be Failure or Success.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum ReturnStatus
Visual Basic (Declaration)
Public Enumeration ReturnStatus
Visual C++
public enum class ReturnStatus

Members

Member name | Description
Failure | Failed Status.
Success | Success Status.

See Also

OfficeClip.Utils Namespace


Service Class

[image]

OfficeClip API Documentation
Service Class
Members See Also

[This is preliminary documentation and is subject to change.]

Class to support the OfficeClip service layer interface

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class Service
Visual Basic (Declaration)
Public Class Service
Visual C++
public ref class Service

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.Service

See Also

Service Members
OfficeClip.Utils Namespace


Service Members

[image] [image]

OfficeClip API Documentation
Service Members
Service Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The Service type exposes the following members.

Constructors

 | Name | Description
Public method | Service |

Methods

 | Name | Description
 | DeserializeXml | Deserialze the xml file to the object
 | DeserializeXmlString | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetApplicationType | Gets the type of the application
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSerial | Overloaded.
 | GetServiceType | Gets the service type
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicationOk | Tests if the application is valid
 | IsSerialOk | Checks and verifies teh serial number of the current installation against the sid
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrimaryId | The primary id extracted from the service type. The return value is -1 if the value could not be extracted
 | SecondaryId | Extracts the secondary id from the service id, the return value is -1 if this value does not exist or it could not be extracted.
 | Serialize | Overloaded.
 | SerializeXml | Serialize the given object to a xml file
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Service Class
OfficeClip.Utils Namespace


Service Constructor

[image]

OfficeClip API Documentation
Service Constructor
Service Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public Service()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Service()

See Also

Service Class
OfficeClip.Utils Namespace


Service Methods

[image] [image]

OfficeClip API Documentation
Service Methods
Service Class See Also

[This is preliminary documentation and is subject to change.]

The Service type exposes the following methods.

Methods

 | Name | Description
 | DeserializeXml | Deserialze the xml file to the object
 | DeserializeXmlString | Overloaded.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetApplicationType | Gets the type of the application
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetSerial | Overloaded.
 | GetServiceType | Gets the service type
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplicationOk | Tests if the application is valid
 | IsSerialOk | Checks and verifies teh serial number of the current installation against the sid
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrimaryId | The primary id extracted from the service type. The return value is -1 if the value could not be extracted
 | SecondaryId | Extracts the secondary id from the service id, the return value is -1 if this value does not exist or it could not be extracted.
 | Serialize | Overloaded.
 | SerializeXml | Serialize the given object to a xml file
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Service Class
OfficeClip.Utils Namespace


DeserializeXml Method

[image]

OfficeClip API Documentation
Service..::.DeserializeXml Method
Service Class See Also

[This is preliminary documentation and is subject to change.]

Deserialze the xml file to the object

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static Object DeserializeXml(
    string xmlFile,
    Object o
)
Visual Basic (Declaration)
Public Shared Function DeserializeXml ( _
    xmlFile As String, _
    o As Object _
) As Object
Visual C++
public:
static Object^ DeserializeXml(
    String^ xmlFile,
    Object^ o
)

Parameters

xmlFile
Type: System..::.String
The xml file to be deserialized
o
Type: System..::.Object
The object to be deserialized

Return Value

The deserialized object

See Also

Service Class
OfficeClip.Utils Namespace


DeserializeXmlString Method

[image] [image]

OfficeClip API Documentation
Service..::.DeserializeXmlString Method
Service Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
DeserializeXmlString(String, Object) | Deserialize the xml string to the object
DeserializeXmlString(String, Type) | Deserialize the xml string to the corresponding object

See Also

Service Class
Service Members
OfficeClip.Utils Namespace


DeserializeXmlString Method (String, Object)

[image]

OfficeClip API Documentation
Service..::.DeserializeXmlString Method (String, Object)
Service Class See Also

[This is preliminary documentation and is subject to change.]

Deserialize the xml string to the object

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static Object DeserializeXmlString(
    string str,
    Object o
)
Visual Basic (Declaration)
Public Shared Function DeserializeXmlString ( _
    str As String, _
    o As Object _
) As Object
Visual C++
public:
static Object^ DeserializeXmlString(
    String^ str,
    Object^ o
)

Parameters

str
Type: System..::.String
The string to be deserialized
o
Type: System..::.Object
The object to be created

Return Value

The deserialized object

See Also

Service Class
DeserializeXmlString Overload
OfficeClip.Utils Namespace


DeserializeXmlString Method (String, Type)

[image]

OfficeClip API Documentation
Service..::.DeserializeXmlString Method (String, Type)
Service Class See Also

[This is preliminary documentation and is subject to change.]

Deserialize the xml string to the corresponding object

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static Object DeserializeXmlString(
    string str,
    Type type
)
Visual Basic (Declaration)
Public Shared Function DeserializeXmlString ( _
    str As String, _
    type As Type _
) As Object
Visual C++
public:
static Object^ DeserializeXmlString(
    String^ str,
    Type^ type
)

Parameters

str
Type: System..::.String
the string to be deserialized
type
Type: System..::.Type
The type of the object that this string needs to be deserialized to

Return Value

The deserialized object

See Also

Service Class
DeserializeXmlString Overload
OfficeClip.Utils Namespace


GetApplicationType Method

[image]

OfficeClip API Documentation
Service..::.GetApplicationType Method
Service Class See Also

[This is preliminary documentation and is subject to change.]

Gets the type of the application

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static OCServiceType GetApplicationType(
    string sid
)
Visual Basic (Declaration)
Public Shared Function GetApplicationType ( _
    sid As String _
) As OCServiceType
Visual C++
public:
static OCServiceType GetApplicationType(
    String^ sid
)

Parameters

sid
Type: System..::.String
The unique service identifier

Return Value

The OfficeClip service type

See Also

Service Class
OfficeClip.Utils Namespace


GetSerial Method

[image] [image]

OfficeClip API Documentation
Service..::.GetSerial Method
Service Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
GetSerial(OCServiceType, Int32) | Gets the serial number of the OfficeClip object
GetSerial(OCServiceType, Int32, Int32) | Gets the serial number of the OfficeClip object

See Also

Service Class
Service Members
OfficeClip.Utils Namespace


GetSerial Method (OCServiceType, Int32)

[image]

OfficeClip API Documentation
Service..::.GetSerial Method (OCServiceType, Int32)
Service Class See Also

[This is preliminary documentation and is subject to change.]

Gets the serial number of the OfficeClip object

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetSerial(
    OCServiceType ost,
    int primaryId
)
Visual Basic (Declaration)
Public Shared Function GetSerial ( _
    ost As OCServiceType, _
    primaryId As Integer _
) As String
Visual C++
public:
static String^ GetSerial(
    OCServiceType ost,
    int primaryId
)

Parameters

ost
Type: OfficeClip.Utils..::.OCServiceType
The OfficeClip Service Type
primaryId
Type: System..::.Int32
The primary id of the object

Return Value

The serial number of the object

See Also

Service Class
GetSerial Overload
OfficeClip.Utils Namespace


GetSerial Method (OCServiceType, Int32, Int32)

[image]

OfficeClip API Documentation
Service..::.GetSerial Method (OCServiceType, Int32, Int32)
Service Class See Also

[This is preliminary documentation and is subject to change.]

Gets the serial number of the OfficeClip object

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetSerial(
    OCServiceType ost,
    int primaryId,
    int secondaryId
)
Visual Basic (Declaration)
Public Shared Function GetSerial ( _
    ost As OCServiceType, _
    primaryId As Integer, _
    secondaryId As Integer _
) As String
Visual C++
public:
static String^ GetSerial(
    OCServiceType ost,
    int primaryId,
    int secondaryId
)

Parameters

ost
Type: OfficeClip.Utils..::.OCServiceType
The OfficeClip Service Type
primaryId
Type: System..::.Int32
The primary id of the object
secondaryId
Type: System..::.Int32
The secondary id of the object

Return Value

The serial number of the object

See Also

Service Class
GetSerial Overload
OfficeClip.Utils Namespace


GetServiceType Method

[image]

OfficeClip API Documentation
Service..::.GetServiceType Method
Service Class See Also

[This is preliminary documentation and is subject to change.]

Gets the service type

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static OCServiceType GetServiceType(
    string sid
)
Visual Basic (Declaration)
Public Shared Function GetServiceType ( _
    sid As String _
) As OCServiceType
Visual C++
public:
static OCServiceType GetServiceType(
    String^ sid
)

Parameters

sid
Type: System..::.String
The unique service identifier

Return Value

The service type

See Also

Service Class
OfficeClip.Utils Namespace


IsApplicationOk Method

[image]

OfficeClip API Documentation
Service..::.IsApplicationOk Method
Service Class See Also

[This is preliminary documentation and is subject to change.]

Tests if the application is valid

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsApplicationOk(
    string sid,
    OCServiceType ost
)
Visual Basic (Declaration)
Public Shared Function IsApplicationOk ( _
    sid As String, _
    ost As OCServiceType _
) As Boolean
Visual C++
public:
static bool IsApplicationOk(
    String^ sid,
    OCServiceType ost
)

Parameters

sid
Type: System..::.String
The unique service identifier
ost
Type: OfficeClip.Utils..::.OCServiceType
The OfficeClip service type

Return Value

true if the application is okay, false otherwise

See Also

Service Class
OfficeClip.Utils Namespace


IsSerialOk Method

[image]

OfficeClip API Documentation
Service..::.IsSerialOk Method
Service Class See Also

[This is preliminary documentation and is subject to change.]

Checks and verifies teh serial number of the current installation against the sid

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsSerialOk(
    string sid
)
Visual Basic (Declaration)
Public Shared Function IsSerialOk ( _
    sid As String _
) As Boolean
Visual C++
public:
static bool IsSerialOk(
    String^ sid
)

Parameters

sid
Type: System..::.String

Return Value

See Also

Service Class
OfficeClip.Utils Namespace


PrimaryId Method

[image]

OfficeClip API Documentation
Service..::.PrimaryId Method
Service Class See Also

[This is preliminary documentation and is subject to change.]

The primary id extracted from the service type. The return value is -1 if the value could not be extracted

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int PrimaryId(
    string sid
)
Visual Basic (Declaration)
Public Shared Function PrimaryId ( _
    sid As String _
) As Integer
Visual C++
public:
static int PrimaryId(
    String^ sid
)

Parameters

sid
Type: System..::.String

See Also

Service Class
OfficeClip.Utils Namespace


SecondaryId Method

[image]

OfficeClip API Documentation
Service..::.SecondaryId Method
Service Class See Also

[This is preliminary documentation and is subject to change.]

Extracts the secondary id from the service id, the return value is -1 if this value does not exist or it could not be extracted.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int SecondaryId(
    string sid
)
Visual Basic (Declaration)
Public Shared Function SecondaryId ( _
    sid As String _
) As Integer
Visual C++
public:
static int SecondaryId(
    String^ sid
)

Parameters

sid
Type: System..::.String

See Also

Service Class
OfficeClip.Utils Namespace


Serialize Method

[image] [image]

OfficeClip API Documentation
Service..::.Serialize Method
Service Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Serialize(Object, StringBuilder%) | Serializes the object
Serialize(Object, StringBuilder%, Boolean) | Serializes and object

See Also

Service Class
Service Members
OfficeClip.Utils Namespace


Serialize Method (Object, StringBuilder)

[image]

OfficeClip API Documentation
Service..::.Serialize Method (Object, StringBuilder%)
Service Class See Also

[This is preliminary documentation and is subject to change.]

Serializes the object

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool Serialize(
    Object o,
    ref StringBuilder sb
)
Visual Basic (Declaration)
Public Shared Function Serialize ( _
    o As Object, _
    ByRef sb As StringBuilder _
) As Boolean
Visual C++
public:
static bool Serialize(
    Object^ o,
    StringBuilder^% sb
)

Parameters

o
Type: System..::.Object
The object to be serialized
sb
Type: System.Text..::.StringBuilder%
The string buffer where the serialized value will be written

Return Value

true if the serialization is successful, false otherwise

See Also

Service Class
Serialize Overload
OfficeClip.Utils Namespace


Serialize Method (Object, StringBuilder, Boolean)

[image]

OfficeClip API Documentation
Service..::.Serialize Method (Object, StringBuilder%, Boolean)
Service Class See Also

[This is preliminary documentation and is subject to change.]

Serializes and object

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool Serialize(
    Object o,
    ref StringBuilder sb,
    bool isFormatted
)
Visual Basic (Declaration)
Public Shared Function Serialize ( _
    o As Object, _
    ByRef sb As StringBuilder, _
    isFormatted As Boolean _
) As Boolean
Visual C++
public:
static bool Serialize(
    Object^ o,
    StringBuilder^% sb,
    bool isFormatted
)

Parameters

o
Type: System..::.Object
The object to be serialized
sb
Type: System.Text..::.StringBuilder%
The stringbuffer where the serialized object is to be written
isFormatted
Type: System..::.Boolean
true if the output xml needs to be formatted

Return Value

See Also

Service Class
Serialize Overload
OfficeClip.Utils Namespace


SerializeXml Method

[image]

OfficeClip API Documentation
Service..::.SerializeXml Method
Service Class See Also

[This is preliminary documentation and is subject to change.]

Serialize the given object to a xml file

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool SerializeXml(
    Object o,
    string xmlFile
)
Visual Basic (Declaration)
Public Shared Function SerializeXml ( _
    o As Object, _
    xmlFile As String _
) As Boolean
Visual C++
public:
static bool SerializeXml(
    Object^ o,
    String^ xmlFile
)

Parameters

o
Type: System..::.Object
The object to be serialized
xmlFile
Type: System..::.String
The xml file where the object should be written to

Return Value

True respresetnts successful and False represents failure

See Also

Service Class
OfficeClip.Utils Namespace


SessionSettings Class

[image]

OfficeClip API Documentation
SessionSettings Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods to access OfficeClip session information.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class SessionSettings
Visual Basic (Declaration)
Public Class SessionSettings
Visual C++
public ref class SessionSettings

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.SessionSettings

See Also

SessionSettings Members
OfficeClip.Utils Namespace


SessionSettings Members

[image] [image]

OfficeClip API Documentation
SessionSettings Members
SessionSettings Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The SessionSettings type exposes the following members.

Constructors

 | Name | Description
Public method | SessionSettings |

Methods

 | Name | Description
 | Abandon | invalidates the session. If this is executed, then the user will have to login to OfficeClip again to access any other functions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConfigureInfo | Gets the configuration information ConfigureInfo from the session.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAdminOrCreator | Checks if the current login user is an administrator or is same as the user given as argument.
 | IsAllowed | Get the value of a single role.
 | IsCreator | Returns true if the user is the creator, i.e. if the session user id matches the provided userid
 | IsLanguageChanged | Determins if the curent user has changed the locale on the browser.
 | IsSessionExists | Shows if the session exists
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetThemeVal | Sets the login users's Theme value of the configuration information ConfigureInfo.
 | SetUserTimezoneInfo | Sets the timezone information TimeZoneInfo for the login user in the configuration information ConfigureInfo.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AccountId | Gets the account id of the login user from the configuration information ConfigureInfo.
EmailAddress | Gets the login users's email address from the configuration information ConfigureInfo.
ErrFlag | Gets the error flag for the last error that has occured. Normally this flag is set when a user defined exception occurs.
GroupId | Gets the group id of the login user from the configuration information ConfigureInfo.
GroupName | Gets the group name of the login users from the configuration information ConfigureInfo.
GroupType | Gets the group type GroupType of the login users from the configuration information ConfigureInfo.
IsAdmin | Determines if the current login user is an administrator.
IsDemoAccount |
IsLeftBarMinimized | Status of the left bar (if it is minimized)
IsNull | Checks if the configuration information ConfigureInfo in the session is null.
LastSecurityChanged | Gets and Sets the last time any security information was changed in the system ConfigureInfo.
Name | Gets the login users's full name from the configuration information ConfigureInfo.
Ocr | Gets the object to access all resources in OfficeClip
RegionalSettings | Gets the login users's full name from the configuration information ConfigureInfo.
RoleAccess | The role access matrix
ServerTzInfo | Gets the server timezone information TimeZoneInfo from the configuration information ConfigureInfo.
ThemeVal | Gets the login users's theme value from the confuguration information ConfigureInfo.
UserId | Gets the user id of the login user from the configuration information ConfigureInfo.
UserTzInfo | Gets the login users's timezone information TimeZoneInfo from the configuration information ConfigureInfo.

See Also

SessionSettings Class
OfficeClip.Utils Namespace


SessionSettings Constructor

[image]

OfficeClip API Documentation
SessionSettings Constructor
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public SessionSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SessionSettings()

See Also

SessionSettings Class
OfficeClip.Utils Namespace


SessionSettings Methods

[image] [image]

OfficeClip API Documentation
SessionSettings Methods
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

The SessionSettings type exposes the following methods.

Methods

 | Name | Description
 | Abandon | invalidates the session. If this is executed, then the user will have to login to OfficeClip again to access any other functions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConfigureInfo | Gets the configuration information ConfigureInfo from the session.
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAdminOrCreator | Checks if the current login user is an administrator or is same as the user given as argument.
 | IsAllowed | Get the value of a single role.
 | IsCreator | Returns true if the user is the creator, i.e. if the session user id matches the provided userid
 | IsLanguageChanged | Determins if the curent user has changed the locale on the browser.
 | IsSessionExists | Shows if the session exists
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetThemeVal | Sets the login users's Theme value of the configuration information ConfigureInfo.
 | SetUserTimezoneInfo | Sets the timezone information TimeZoneInfo for the login user in the configuration information ConfigureInfo.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SessionSettings Class
OfficeClip.Utils Namespace


Abandon Method

[image]

OfficeClip API Documentation
SessionSettings..::.Abandon Method
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

invalidates the session. If this is executed, then the user will have to login to OfficeClip again to access any other functions.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void Abandon()
Visual Basic (Declaration)
Public Shared Sub Abandon
Visual C++
public:
static void Abandon()

See Also

SessionSettings Class
OfficeClip.Utils Namespace


GetConfigureInfo Method

[image]

OfficeClip API Documentation
SessionSettings..::.GetConfigureInfo Method
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the configuration information ConfigureInfo from the session.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static ConfigureInfo GetConfigureInfo()
Visual Basic (Declaration)
Public Shared Function GetConfigureInfo As ConfigureInfo
Visual C++
public:
static ConfigureInfo^ GetConfigureInfo()

Return Value

The configuration information.

See Also

SessionSettings Class
OfficeClip.Utils Namespace


IsAdminOrCreator Method

[image]

OfficeClip API Documentation
SessionSettings..::.IsAdminOrCreator Method
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Checks if the current login user is an administrator or is same as the user given as argument.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsAdminOrCreator(
    int userId
)
Visual Basic (Declaration)
Public Shared Function IsAdminOrCreator ( _
    userId As Integer _
) As Boolean
Visual C++
public:
static bool IsAdminOrCreator(
    int userId
)

Parameters

userId
Type: System..::.Int32
The user id of the user to be tested.

Return Value

true if the current login user is an administrator or is same as the user in the argument, false otherwise.

See Also

SessionSettings Class
OfficeClip.Utils Namespace


IsAllowed Method

[image]

OfficeClip API Documentation
SessionSettings..::.IsAllowed Method
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Get the value of a single role.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsAllowed(
    AccessFunction af
)
Visual Basic (Declaration)
Public Shared Function IsAllowed ( _
    af As AccessFunction _
) As Boolean
Visual C++
public:
static bool IsAllowed(
    AccessFunction af
)

Parameters

af
Type: OfficeClip.Utils..::.AccessFunction
The access function for which the access is to be determined.

Return Value

true if the function has the access false otherwise.

See Also

SessionSettings Class
OfficeClip.Utils Namespace


IsCreator Method

[image]

OfficeClip API Documentation
SessionSettings..::.IsCreator Method
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Returns true if the user is the creator, i.e. if the session user id matches the provided userid

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsCreator(
    int userId
)
Visual Basic (Declaration)
Public Shared Function IsCreator ( _
    userId As Integer _
) As Boolean
Visual C++
public:
static bool IsCreator(
    int userId
)

Parameters

userId
Type: System..::.Int32
The user id to be tested

Return Value

true if the user is the creator false otherwise

See Also

SessionSettings Class
OfficeClip.Utils Namespace


IsLanguageChanged Method

[image]

OfficeClip API Documentation
SessionSettings..::.IsLanguageChanged Method
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Determins if the curent user has changed the locale on the browser.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsLanguageChanged()
Visual Basic (Declaration)
Public Shared Function IsLanguageChanged As Boolean
Visual C++
public:
static bool IsLanguageChanged()

Return Value

true if the current user has changed the locale on the browser, false otherwise.

See Also

SessionSettings Class
OfficeClip.Utils Namespace


IsSessionExists Method

[image]

OfficeClip API Documentation
SessionSettings..::.IsSessionExists Method
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Shows if the session exists

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsSessionExists()
Visual Basic (Declaration)
Public Shared Function IsSessionExists As Boolean
Visual C++
public:
static bool IsSessionExists()

Return Value

true if the session exists

See Also

SessionSettings Class
OfficeClip.Utils Namespace


SetThemeVal Method

[image]

OfficeClip API Documentation
SessionSettings..::.SetThemeVal Method
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Sets the login users's Theme value of the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void SetThemeVal(
    string themeVal
)
Visual Basic (Declaration)
Public Shared Sub SetThemeVal ( _
    themeVal As String _
)
Visual C++
public:
static void SetThemeVal(
    String^ themeVal
)

Parameters

themeVal
Type: System..::.String
The theme value.

See Also

SessionSettings Class
OfficeClip.Utils Namespace


SetUserTimezoneInfo Method

[image]

OfficeClip API Documentation
SessionSettings..::.SetUserTimezoneInfo Method
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Sets the timezone information TimeZoneInfo for the login user in the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void SetUserTimezoneInfo(
    TimeZoneInfo userTz
)
Visual Basic (Declaration)
Public Shared Sub SetUserTimezoneInfo ( _
    userTz As TimeZoneInfo _
)
Visual C++
public:
static void SetUserTimezoneInfo(
    TimeZoneInfo^ userTz
)

Parameters

userTz
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone.

See Also

SessionSettings Class
OfficeClip.Utils Namespace


SessionSettings Properties

[image] [image]

OfficeClip API Documentation
SessionSettings Properties
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

The SessionSettings type exposes the following properties.

Properties

Name | Description
AccountId | Gets the account id of the login user from the configuration information ConfigureInfo.
EmailAddress | Gets the login users's email address from the configuration information ConfigureInfo.
ErrFlag | Gets the error flag for the last error that has occured. Normally this flag is set when a user defined exception occurs.
GroupId | Gets the group id of the login user from the configuration information ConfigureInfo.
GroupName | Gets the group name of the login users from the configuration information ConfigureInfo.
GroupType | Gets the group type GroupType of the login users from the configuration information ConfigureInfo.
IsAdmin | Determines if the current login user is an administrator.
IsDemoAccount |
IsLeftBarMinimized | Status of the left bar (if it is minimized)
IsNull | Checks if the configuration information ConfigureInfo in the session is null.
LastSecurityChanged | Gets and Sets the last time any security information was changed in the system ConfigureInfo.
Name | Gets the login users's full name from the configuration information ConfigureInfo.
Ocr | Gets the object to access all resources in OfficeClip
RegionalSettings | Gets the login users's full name from the configuration information ConfigureInfo.
RoleAccess | The role access matrix
ServerTzInfo | Gets the server timezone information TimeZoneInfo from the configuration information ConfigureInfo.
ThemeVal | Gets the login users's theme value from the confuguration information ConfigureInfo.
UserId | Gets the user id of the login user from the configuration information ConfigureInfo.
UserTzInfo | Gets the login users's timezone information TimeZoneInfo from the configuration information ConfigureInfo.

See Also

SessionSettings Class
OfficeClip.Utils Namespace


AccountId Property

[image]

OfficeClip API Documentation
SessionSettings..::.AccountId Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the account id of the login user from the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int AccountId { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property AccountId As Integer
Visual C++
public:
static property int AccountId {
    int get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


EmailAddress Property

[image]

OfficeClip API Documentation
SessionSettings..::.EmailAddress Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the login users's email address from the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string EmailAddress { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property EmailAddress As String
Visual C++
public:
static property String^ EmailAddress {
    String^ get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


ErrFlag Property

[image]

OfficeClip API Documentation
SessionSettings..::.ErrFlag Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the error flag for the last error that has occured. Normally this flag is set when a user defined exception occurs.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int ErrFlag { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ErrFlag As Integer
Visual C++
public:
static property int ErrFlag {
    int get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


GroupId Property

[image]

OfficeClip API Documentation
SessionSettings..::.GroupId Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the group id of the login user from the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int GroupId { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupId As Integer
Visual C++
public:
static property int GroupId {
    int get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


GroupName Property

[image]

OfficeClip API Documentation
SessionSettings..::.GroupName Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the group name of the login users from the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GroupName { get; set; }
Visual Basic (Declaration)
Public Shared Property GroupName As String
Visual C++
public:
static property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


GroupType Property

[image]

OfficeClip API Documentation
SessionSettings..::.GroupType Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the group type GroupType of the login users from the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static GroupType GroupType { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property GroupType As GroupType
Visual C++
public:
static property GroupType GroupType {
    GroupType get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


IsAdmin Property

[image]

OfficeClip API Documentation
SessionSettings..::.IsAdmin Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the current login user is an administrator.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsAdmin { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IsAdmin As Boolean
Visual C++
public:
static property bool IsAdmin {
    bool get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


IsDemoAccount Property

[image]

OfficeClip API Documentation
SessionSettings..::.IsDemoAccount Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsDemoAccount { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IsDemoAccount As Boolean
Visual C++
public:
static property bool IsDemoAccount {
    bool get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


IsLeftBarMinimized Property

[image]

OfficeClip API Documentation
SessionSettings..::.IsLeftBarMinimized Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Status of the left bar (if it is minimized)

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsLeftBarMinimized { get; set; }
Visual Basic (Declaration)
Public Shared Property IsLeftBarMinimized As Boolean
Visual C++
public:
static property bool IsLeftBarMinimized {
    bool get ();
    void set (bool value);
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


IsNull Property

[image]

OfficeClip API Documentation
SessionSettings..::.IsNull Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Checks if the configuration information ConfigureInfo in the session is null.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool IsNull { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property IsNull As Boolean
Visual C++
public:
static property bool IsNull {
    bool get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


LastSecurityChanged Property

[image]

OfficeClip API Documentation
SessionSettings..::.LastSecurityChanged Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets and Sets the last time any security information was changed in the system ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static DateTime LastSecurityChanged { get; set; }
Visual Basic (Declaration)
Public Shared Property LastSecurityChanged As DateTime
Visual C++
public:
static property DateTime LastSecurityChanged {
    DateTime get ();
    void set (DateTime value);
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


Name Property

[image]

OfficeClip API Documentation
SessionSettings..::.Name Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the login users's full name from the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Name { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Name As String
Visual C++
public:
static property String^ Name {
    String^ get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


Ocr Property

[image]

OfficeClip API Documentation
SessionSettings..::.Ocr Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the object to access all resources in OfficeClip

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static OCResources Ocr { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Ocr As OCResources
Visual C++
public:
static property OCResources^ Ocr {
    OCResources^ get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


RegionalSettings Property

[image]

OfficeClip API Documentation
SessionSettings..::.RegionalSettings Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the login users's full name from the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string RegionalSettings { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property RegionalSettings As String
Visual C++
public:
static property String^ RegionalSettings {
    String^ get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


RoleAccess Property

[image]

OfficeClip API Documentation
SessionSettings..::.RoleAccess Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

The role access matrix

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool[] RoleAccess { get; set; }
Visual Basic (Declaration)
Public Shared Property RoleAccess As Boolean()
Visual C++
public:
static property array<bool>^ RoleAccess {
    array<bool>^ get ();
    void set (array<bool>^ value);
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


ServerTzInfo Property

[image]

OfficeClip API Documentation
SessionSettings..::.ServerTzInfo Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the server timezone information TimeZoneInfo from the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static TimeZoneInfo ServerTzInfo { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ServerTzInfo As TimeZoneInfo
Visual C++
public:
static property TimeZoneInfo^ ServerTzInfo {
    TimeZoneInfo^ get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


ThemeVal Property

[image]

OfficeClip API Documentation
SessionSettings..::.ThemeVal Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the login users's theme value from the confuguration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string ThemeVal { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property ThemeVal As String
Visual C++
public:
static property String^ ThemeVal {
    String^ get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


UserId Property

[image]

OfficeClip API Documentation
SessionSettings..::.UserId Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the user id of the login user from the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int UserId { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UserId As Integer
Visual C++
public:
static property int UserId {
    int get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


UserTzInfo Property

[image]

OfficeClip API Documentation
SessionSettings..::.UserTzInfo Property
SessionSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the login users's timezone information TimeZoneInfo from the configuration information ConfigureInfo.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static TimeZoneInfo UserTzInfo { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property UserTzInfo As TimeZoneInfo
Visual C++
public:
static property TimeZoneInfo^ UserTzInfo {
    TimeZoneInfo^ get ();
}

See Also

SessionSettings Class
OfficeClip.Utils Namespace


SortByName Enumeration

[image]

OfficeClip API Documentation
SortByName Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated type for sorting by name in various OfficeClip applications, especially in the User Manager

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum SortByName
Visual Basic (Declaration)
Public Enumeration SortByName
Visual C++
public enum class SortByName

Members

Member name | Description
FirstName | Sort by the first name
LastName | Sort by the last name

See Also

OfficeClip.Utils Namespace


TESortType Enumeration

[image]

OfficeClip API Documentation
TESortType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides enumerated types for the sort type of Time and Expense Reporting application.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum TESortType
Visual Basic (Declaration)
Public Enumeration TESortType
Visual C++
public enum class TESortType

Members

Member name | Description
Item | Sort by an item.
Status | Sort by the status of the time and expense report.
LastName | Sort by the name of the time and expense report user.
WeekStarting | Sort by the week starting date of the time and expense report.
TotalValue | Sort by the total value (hours or amount) for each report.
GroupName | Sort by the name of the group to whom this report belongs.

See Also

OfficeClip.Utils Namespace


TimeAndExpenseAlias Enumeration

[image]

OfficeClip API Documentation
TimeAndExpenseAlias Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides enumerated types for customers, projects and tasks for time and expense reporting.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum TimeAndExpenseAlias
Visual Basic (Declaration)
Public Enumeration TimeAndExpenseAlias
Visual C++
public enum class TimeAndExpenseAlias

Members

Member name | Description
Customer | The customer for whom the time and expense reports are created.
Project | The project for the customers.
Task | The tasks for timesheets.

See Also

OfficeClip.Utils Namespace


TimeZoneInfo Class

[image]

OfficeClip API Documentation
TimeZoneInfo Class
Members See Also

[This is preliminary documentation and is subject to change.]

The Time Zone structure.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class TimeZoneInfo
Visual Basic (Declaration)
Public Class TimeZoneInfo
Visual C++
public ref class TimeZoneInfo

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.TimeZoneInfo

See Also

TimeZoneInfo Members
OfficeClip.Utils Namespace


TimeZoneInfo Members

[image] [image]

OfficeClip API Documentation
TimeZoneInfo Members
TimeZoneInfo Class Constructors Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The TimeZoneInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TimeZoneInfo |

Methods

 | Name | Description
Public method | Dump | Converts, the object into string (for debugging purposes)
Public method | Equals | Overloaded.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplyDst | Whether this timezone need to be applied.
Public property | DstDur | Daylight saving duration in minutes, 0 denotes null in the database.
Public property | FlDay | // Fall Day, Constants.NotAvailable denotes null in database, , legal values are 0(Sunday) - 6(Saturday).
Public property | FlMon | Fall Month, Constants.NotAvailable denotes null in database.
Public property | FlTimeMin | Fall minute in from the midnight.
Public property | FlWeek | Fall Week, "" denotes null in database.
Public property | SprDay | Spring Day of Week, Constants.NotAvailable denotes null in the database, legal values are 0(Sunday) - 6(Saturday)
Public property | SprMon | Spring Month, Constants.NotAvailable denotes null in the database.
Public property | SprTimeMin | Spring minute from the midnight.
Public property | SprWeek | Spring Week, "" denotes null in database.
Public property | TimeZoneId | Time zone id in the officeclip database, Constants.NotAvailable denotes uninitialized value .
Public property | TimeZoneVal | The offset from the GMT in minutes.

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


TimeZoneInfo Constructor

[image]

OfficeClip API Documentation
TimeZoneInfo Constructor
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public TimeZoneInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TimeZoneInfo()

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


TimeZoneInfo Methods

[image] [image]

OfficeClip API Documentation
TimeZoneInfo Methods
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimeZoneInfo type exposes the following methods.

Methods

 | Name | Description
Public method | Dump | Converts, the object into string (for debugging purposes)
Public method | Equals | Overloaded.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


Dump Method

[image]

OfficeClip API Documentation
TimeZoneInfo..::.Dump Method
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Converts, the object into string (for debugging purposes)

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string Dump()
Visual Basic (Declaration)
Public Function Dump As String
Visual C++
public:
String^ Dump()

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


Equals Method

[image] [image]

OfficeClip API Documentation
TimeZoneInfo..::.Equals Method
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(TimeZoneInfo) | Tests whether the timezone given in the argument is equal to the current class.

See Also

TimeZoneInfo Class
TimeZoneInfo Members
OfficeClip.Utils Namespace


Equals Method (TimeZoneInfo)

[image]

OfficeClip API Documentation
TimeZoneInfo..::.Equals Method (TimeZoneInfo)
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Tests whether the timezone given in the argument is equal to the current class.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public bool Equals(
    TimeZoneInfo tz
)
Visual Basic (Declaration)
Public Function Equals ( _
    tz As TimeZoneInfo _
) As Boolean
Visual C++
public:
bool Equals(
    TimeZoneInfo^ tz
)

Parameters

tz
Type: OfficeClip.Utils..::.TimeZoneInfo
The TimeZone to compare with

See Also

TimeZoneInfo Class
Equals Overload
OfficeClip.Utils Namespace


TimeZoneInfo Properties

[image] [image]

OfficeClip API Documentation
TimeZoneInfo Properties
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The TimeZoneInfo type exposes the following properties.

Properties

 | Name | Description
Public property | ApplyDst | Whether this timezone need to be applied.
Public property | DstDur | Daylight saving duration in minutes, 0 denotes null in the database.
Public property | FlDay | // Fall Day, Constants.NotAvailable denotes null in database, , legal values are 0(Sunday) - 6(Saturday).
Public property | FlMon | Fall Month, Constants.NotAvailable denotes null in database.
Public property | FlTimeMin | Fall minute in from the midnight.
Public property | FlWeek | Fall Week, "" denotes null in database.
Public property | SprDay | Spring Day of Week, Constants.NotAvailable denotes null in the database, legal values are 0(Sunday) - 6(Saturday)
Public property | SprMon | Spring Month, Constants.NotAvailable denotes null in the database.
Public property | SprTimeMin | Spring minute from the midnight.
Public property | SprWeek | Spring Week, "" denotes null in database.
Public property | TimeZoneId | Time zone id in the officeclip database, Constants.NotAvailable denotes uninitialized value .
Public property | TimeZoneVal | The offset from the GMT in minutes.

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


ApplyDst Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.ApplyDst Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Whether this timezone need to be applied.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public bool ApplyDst { get; set; }
Visual Basic (Declaration)
Public Property ApplyDst As Boolean
Visual C++
public:
property bool ApplyDst {
    bool get ();
    void set (bool value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


DstDur Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.DstDur Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Daylight saving duration in minutes, 0 denotes null in the database.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int DstDur { get; set; }
Visual Basic (Declaration)
Public Property DstDur As Integer
Visual C++
public:
property int DstDur {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


FlDay Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.FlDay Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

// Fall Day, Constants.NotAvailable denotes null in database, , legal values are 0(Sunday) - 6(Saturday).

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int FlDay { get; set; }
Visual Basic (Declaration)
Public Property FlDay As Integer
Visual C++
public:
property int FlDay {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


FlMon Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.FlMon Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Fall Month, Constants.NotAvailable denotes null in database.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int FlMon { get; set; }
Visual Basic (Declaration)
Public Property FlMon As Integer
Visual C++
public:
property int FlMon {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


FlTimeMin Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.FlTimeMin Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Fall minute in from the midnight.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int FlTimeMin { get; set; }
Visual Basic (Declaration)
Public Property FlTimeMin As Integer
Visual C++
public:
property int FlTimeMin {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


FlWeek Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.FlWeek Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Fall Week, "" denotes null in database.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string FlWeek { get; set; }
Visual Basic (Declaration)
Public Property FlWeek As String
Visual C++
public:
property String^ FlWeek {
    String^ get ();
    void set (String^ value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


SprDay Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.SprDay Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Spring Day of Week, Constants.NotAvailable denotes null in the database, legal values are 0(Sunday) - 6(Saturday)

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int SprDay { get; set; }
Visual Basic (Declaration)
Public Property SprDay As Integer
Visual C++
public:
property int SprDay {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


SprMon Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.SprMon Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Spring Month, Constants.NotAvailable denotes null in the database.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int SprMon { get; set; }
Visual Basic (Declaration)
Public Property SprMon As Integer
Visual C++
public:
property int SprMon {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


SprTimeMin Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.SprTimeMin Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Spring minute from the midnight.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int SprTimeMin { get; set; }
Visual Basic (Declaration)
Public Property SprTimeMin As Integer
Visual C++
public:
property int SprTimeMin {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


SprWeek Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.SprWeek Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Spring Week, "" denotes null in database.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string SprWeek { get; set; }
Visual Basic (Declaration)
Public Property SprWeek As String
Visual C++
public:
property String^ SprWeek {
    String^ get ();
    void set (String^ value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


TimeZoneId Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.TimeZoneId Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

Time zone id in the officeclip database, Constants.NotAvailable denotes uninitialized value .

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int TimeZoneId { get; set; }
Visual Basic (Declaration)
Public Property TimeZoneId As Integer
Visual C++
public:
property int TimeZoneId {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


TimeZoneVal Property

[image]

OfficeClip API Documentation
TimeZoneInfo..::.TimeZoneVal Property
TimeZoneInfo Class See Also

[This is preliminary documentation and is subject to change.]

The offset from the GMT in minutes.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int TimeZoneVal { get; set; }
Visual Basic (Declaration)
Public Property TimeZoneVal As Integer
Visual C++
public:
property int TimeZoneVal {
    int get ();
    void set (int value);
}

See Also

TimeZoneInfo Class
OfficeClip.Utils Namespace


TraceDebugSwitch Enumeration

[image]

OfficeClip API Documentation
TraceDebugSwitch Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The switch for the tracing and debugging in OfficeClip code

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum TraceDebugSwitch
Visual Basic (Declaration)
Public Enumeration TraceDebugSwitch
Visual C++
public enum class TraceDebugSwitch

Members

Member name | Description
FunctionCall | Traces only the function calls
Debug | Traces the user defined debug statement
AssertFail | Trace the assertions in the code

See Also

OfficeClip.Utils Namespace


TrackerFieldsNameId Enumeration

[image]

OfficeClip API Documentation
TrackerFieldsNameId Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types for the tracker field names. In tracker, the field names can be chaged via the administrator utility

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum TrackerFieldsNameId
Visual Basic (Declaration)
Public Enumeration TrackerFieldsNameId
Visual C++
public enum class TrackerFieldsNameId

Members

Member name | Description
NotAvailable | Not available... the default value
CaseNumName | The case number name
StatusName | The status name
CriticalityName | The criticality name
CategoryName | The category name
KindName | The kind name
CreateUserName | The name of the created user field
ModifiedUserName | The name of the modified user field
CreatedDateName | The name of the created date field
ModifiedDateName | The name of the modified date field
TitleName | The name of the title
DescriptionName | The name of the description
ResolutionName | The name of the resolution
CommentsName | The name of the comment
AssignedName | The name for assigned to
UdfFieldsStart | The start of the udf fields, subsequent udf fields are given consecutive numbers from this point. Do not add any other constants after this.

See Also

OfficeClip.Utils Namespace


TrackerFilterChoiceId Enumeration

[image]

OfficeClip API Documentation
TrackerFilterChoiceId Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The enumerated type for the tracker filter choices

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum TrackerFilterChoiceId
Visual Basic (Declaration)
Public Enumeration TrackerFilterChoiceId
Visual C++
public enum class TrackerFilterChoiceId

Members

Member name | Description
AllCases | All the cases need to be shown
ArchivedCases | Only archive cases needs to be shown

See Also

OfficeClip.Utils Namespace


UpDownLoad Class

[image]

OfficeClip API Documentation
UpDownLoad Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides methods for Upload and Download of files in OfficeClip.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class UpDownLoad
Visual Basic (Declaration)
Public Class UpDownLoad
Visual C++
public ref class UpDownLoad

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.UpDownLoad

See Also

UpDownLoad Members
OfficeClip.Utils Namespace


UpDownLoad Members

[image] [image]

OfficeClip API Documentation
UpDownLoad Members
UpDownLoad Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The UpDownLoad type exposes the following members.

Constructors

 | Name | Description
Public method | UpDownLoad |

Methods

 | Name | Description
 | Download | Overloaded.
 | DownloadFile | Download the file to the browser
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | Upload | Uploads the posted file on the OfficeClip server
 | UploadAs | Overloaded.
 | UploadToString | uploads the posted file content in the string

See Also

UpDownLoad Class
OfficeClip.Utils Namespace


UpDownLoad Constructor

[image]

OfficeClip API Documentation
UpDownLoad Constructor
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public UpDownLoad()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpDownLoad()

See Also

UpDownLoad Class
OfficeClip.Utils Namespace


UpDownLoad Methods

[image] [image]

OfficeClip API Documentation
UpDownLoad Methods
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

The UpDownLoad type exposes the following methods.

Methods

 | Name | Description
 | Download | Overloaded.
 | DownloadFile | Download the file to the browser
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | Upload | Uploads the posted file on the OfficeClip server
 | UploadAs | Overloaded.
 | UploadToString | uploads the posted file content in the string

See Also

UpDownLoad Class
OfficeClip.Utils Namespace


Download Method

[image] [image]

OfficeClip API Documentation
UpDownLoad..::.Download Method
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Download(String, array<Char>[]()[]) | Download a document to the browser. This method sets appropriate parameters so that the file can be downloaded to the browser.
Download(String, Stream) | Download a document to the browser. This method sets appropriate parameters so that the file can be downloaded to the browser.
Download(String, String) | Download a document to the browser. This method sets appropriate parameters so that the file can be downloaded to the browser.
Download(String, Stream, String) | Download a document to the browser. This method sets appropriate parameters so that the file can be downloaded to the browser.
Download(String, String, String) | Downloads the file

See Also

UpDownLoad Class
UpDownLoad Members
OfficeClip.Utils Namespace


Download Method (String, Char[])

[image]

OfficeClip API Documentation
UpDownLoad..::.Download Method (String, array<Char>[]()[])
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Download a document to the browser. This method sets appropriate parameters so that the file can be downloaded to the browser.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void Download(
    string fileName,
    char[] buf
)
Visual Basic (Declaration)
Public Shared Sub Download ( _
    fileName As String, _
    buf As Char() _
)
Visual C++
public:
static void Download(
    String^ fileName,
    array<wchar_t>^ buf
)

Parameters

fileName
Type: System..::.String
the full path name of the file on the local machine.
buf
Type: array<System..::.Char>[]()[]
The content of the file as a string array.

See Also

UpDownLoad Class
Download Overload
OfficeClip.Utils Namespace


Download Method (String, Stream)

[image]

OfficeClip API Documentation
UpDownLoad..::.Download Method (String, Stream)
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Download a document to the browser. This method sets appropriate parameters so that the file can be downloaded to the browser.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void Download(
    string fileName,
    Stream ms
)
Visual Basic (Declaration)
Public Shared Sub Download ( _
    fileName As String, _
    ms As Stream _
)
Visual C++
public:
static void Download(
    String^ fileName,
    Stream^ ms
)

Parameters

fileName
Type: System..::.String
the full path name of the file on the local machine.
ms
Type: System.IO..::.Stream
The content of the file as a stream.

See Also

UpDownLoad Class
Download Overload
OfficeClip.Utils Namespace


Download Method (String, String)

[image]

OfficeClip API Documentation
UpDownLoad..::.Download Method (String, String)
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Download a document to the browser. This method sets appropriate parameters so that the file can be downloaded to the browser.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void Download(
    string fileName,
    string str
)
Visual Basic (Declaration)
Public Shared Sub Download ( _
    fileName As String, _
    str As String _
)
Visual C++
public:
static void Download(
    String^ fileName,
    String^ str
)

Parameters

fileName
Type: System..::.String
the full path name of the file on the local machine.
str
Type: System..::.String
The content of the file as a string.

See Also

UpDownLoad Class
Download Overload
OfficeClip.Utils Namespace


Download Method (String, Stream, String)

[image]

OfficeClip API Documentation
UpDownLoad..::.Download Method (String, Stream, String)
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Download a document to the browser. This method sets appropriate parameters so that the file can be downloaded to the browser.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void Download(
    string fileName,
    Stream ms,
    string contentType
)
Visual Basic (Declaration)
Public Shared Sub Download ( _
    fileName As String, _
    ms As Stream, _
    contentType As String _
)
Visual C++
public:
static void Download(
    String^ fileName,
    Stream^ ms,
    String^ contentType
)

Parameters

fileName
Type: System..::.String
the full path name of the file on the local machine.
ms
Type: System.IO..::.Stream
The content of the file as a stream.
contentType
Type: System..::.String
The content type for the http

See Also

UpDownLoad Class
Download Overload
OfficeClip.Utils Namespace


Download Method (String, String, String)

[image]

OfficeClip API Documentation
UpDownLoad..::.Download Method (String, String, String)
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Downloads the file

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void Download(
    string fileName,
    string str,
    string contentType
)
Visual Basic (Declaration)
Public Shared Sub Download ( _
    fileName As String, _
    str As String, _
    contentType As String _
)
Visual C++
public:
static void Download(
    String^ fileName,
    String^ str,
    String^ contentType
)

Parameters

fileName
Type: System..::.String
The name of the file
str
Type: System..::.String
The file data in the string
contentType
Type: System..::.String
The content type of the file

See Also

UpDownLoad Class
Download Overload
OfficeClip.Utils Namespace


DownloadFile Method

[image]

OfficeClip API Documentation
UpDownLoad..::.DownloadFile Method
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Download the file to the browser

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static ReturnStatus DownloadFile(
    string fileName,
    string filePath
)
Visual Basic (Declaration)
Public Shared Function DownloadFile ( _
    fileName As String, _
    filePath As String _
) As ReturnStatus
Visual C++
public:
static ReturnStatus DownloadFile(
    String^ fileName,
    String^ filePath
)

Parameters

fileName
Type: System..::.String
The name of the file
filePath
Type: System..::.String
The complete filepath including the filename

Return Value

true if successful, false if the file does not exists

See Also

UpDownLoad Class
OfficeClip.Utils Namespace


Upload Method

[image]

OfficeClip API Documentation
UpDownLoad..::.Upload Method
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Uploads the posted file on the OfficeClip server

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static UpDownLoad..::.UploadStatus Upload(
    HttpPostedFile pFile,
    string dirPath
)
Visual Basic (Declaration)
Public Shared Function Upload ( _
    pFile As HttpPostedFile, _
    dirPath As String _
) As UpDownLoad..::.UploadStatus
Visual C++
public:
static UpDownLoad..::.UploadStatus Upload(
    HttpPostedFile^ pFile,
    String^ dirPath
)

Parameters

pFile
Type: System.Web..::.HttpPostedFile
The posted file
dirPath
Type: System..::.String
The directory where the file is stored on the server

Return Value

Return message, 0 - Successful 1 - Saving to server failed 2 - Client file not accessible 3 - Empty Posted File

See Also

UpDownLoad Class
OfficeClip.Utils Namespace


UploadAs Method

[image] [image]

OfficeClip API Documentation
UpDownLoad..::.UploadAs Method
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
UploadAs(Stream, String) | Uploads the file stream on the OfficeClip server.
UploadAs(HttpPostedFile, String) | Uploads the posted file on the OfficeClip server.
UploadAs(Stream, String, Boolean) | Uploads the file stream on the OfficeClip server.

See Also

UpDownLoad Class
UpDownLoad Members
OfficeClip.Utils Namespace


UploadAs Method (Stream, String)

[image]

OfficeClip API Documentation
UpDownLoad..::.UploadAs Method (Stream, String)
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Uploads the file stream on the OfficeClip server.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static UpDownLoad..::.UploadStatus UploadAs(
    Stream pFileStream,
    string filePath
)
Visual Basic (Declaration)
Public Shared Function UploadAs ( _
    pFileStream As Stream, _
    filePath As String _
) As UpDownLoad..::.UploadStatus
Visual C++
public:
static UpDownLoad..::.UploadStatus UploadAs(
    Stream^ pFileStream,
    String^ filePath
)

Parameters

pFileStream
Type: System.IO..::.Stream
The file stream to be uploaded.
filePath
Type: System..::.String
The full pathname of the file.

Return Value

The Upload Status enumerated type

See Also

UpDownLoad Class
UploadAs Overload
OfficeClip.Utils Namespace


UploadAs Method (HttpPostedFile, String)

[image]

OfficeClip API Documentation
UpDownLoad..::.UploadAs Method (HttpPostedFile, String)
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Uploads the posted file on the OfficeClip server.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int UploadAs(
    HttpPostedFile pFile,
    string filePath
)
Visual Basic (Declaration)
Public Shared Function UploadAs ( _
    pFile As HttpPostedFile, _
    filePath As String _
) As Integer
Visual C++
public:
static int UploadAs(
    HttpPostedFile^ pFile,
    String^ filePath
)

Parameters

pFile
Type: System.Web..::.HttpPostedFile
The posted file.
filePath
Type: System..::.String
The full pathname of the file.

Return Value

Return message, 0 - Successful 1 - Saving to server failed 2 - Client file not accessible 3 - Empty Posted File

See Also

UpDownLoad Class
UploadAs Overload
OfficeClip.Utils Namespace


UploadAs Method (Stream, String, Boolean)

[image]

OfficeClip API Documentation
UpDownLoad..::.UploadAs Method (Stream, String, Boolean)
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Uploads the file stream on the OfficeClip server.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static UpDownLoad..::.UploadStatus UploadAs(
    Stream pFileStream,
    string filePath,
    bool isCheckFileAlreadyPresent
)
Visual Basic (Declaration)
Public Shared Function UploadAs ( _
    pFileStream As Stream, _
    filePath As String, _
    isCheckFileAlreadyPresent As Boolean _
) As UpDownLoad..::.UploadStatus
Visual C++
public:
static UpDownLoad..::.UploadStatus UploadAs(
    Stream^ pFileStream,
    String^ filePath,
    bool isCheckFileAlreadyPresent
)

Parameters

pFileStream
Type: System.IO..::.Stream
The file stream to be uploaded.
filePath
Type: System..::.String
The full pathname of the file.
isCheckFileAlreadyPresent
Type: System..::.Boolean
Fails if the file is already present

Return Value

The Upload Status enumerated type

See Also

UpDownLoad Class
UploadAs Overload
OfficeClip.Utils Namespace


UploadToString Method

[image]

OfficeClip API Documentation
UpDownLoad..::.UploadToString Method
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

uploads the posted file content in the string

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string UploadToString(
    HttpPostedFile pFile
)
Visual Basic (Declaration)
Public Shared Function UploadToString ( _
    pFile As HttpPostedFile _
) As String
Visual C++
public:
static String^ UploadToString(
    HttpPostedFile^ pFile
)

Parameters

pFile
Type: System.Web..::.HttpPostedFile
The posted File

Return Value

the string which has the content of the file

See Also

UpDownLoad Class
OfficeClip.Utils Namespace


UpDownLoad.UploadStatus Enumeration

[image]

OfficeClip API Documentation
UpDownLoad..::.UploadStatus Enumeration
UpDownLoad Class See Also

[This is preliminary documentation and is subject to change.]

Returns the upload status of the file uploaded.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum UploadStatus
Visual Basic (Declaration)
Public Enumeration UploadStatus
Visual C++
public enum class UploadStatus

Members

Member name | Description
Success | Success Status
SavingToServerFailed | The file could not be saved to the OfficeClip server.
ClientFileNotAccessible | The client file could not be accessed from the OfficeClip Server.
EmptyPostedFile | The posted file is empty. OfficeClip does not store empty files.
FileAlreadyExists | Another file with the same name already exists in the same directory.

See Also

OfficeClip.Utils Namespace


UserType Enumeration

[image]

OfficeClip API Documentation
UserType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The type of the OfficeClip user

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum UserType
Visual Basic (Declaration)
Public Enumeration UserType
Visual C++
public enum class UserType

Members

Member name | Description
None | Undefined user type
OfficeClip | OfficeClip registered users
CustomerPortal | Extranet Users
All | OfficeClip registered users + Extranet users

See Also

OfficeClip.Utils Namespace


WorkflowAction Enumeration

[image]

OfficeClip API Documentation
WorkflowAction Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides enumerated types for the workflow actions.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum WorkflowAction
Visual Basic (Declaration)
Public Enumeration WorkflowAction
Visual C++
public enum class WorkflowAction

Members

Member name | Description
NoAction | No workflow action (or unknown action).
Save | Save Action.
Cancel | Cancel Action.
Submit | Submit Action.
Complete | Complete Action.
Reject | Reject Action.
Approve | Approve Action.
Reroute | Reroute action.

See Also

OfficeClip.Utils Namespace


WorkflowType Enumeration

[image]

OfficeClip API Documentation
WorkflowType Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Provides enumerated types of the workflow types.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum WorkflowType
Visual Basic (Declaration)
Public Enumeration WorkflowType
Visual C++
public enum class WorkflowType

Members

Member name | Description
NoWorkflow | There is no workflow.
Disable | Workflow is disabled.
Manual | Workflow is manual.
SinglePerson | Workflow is for a two person.
TwoPerson | Workflow is for three person.
ThreePerson | Workflow is for four person.

See Also

OfficeClip.Utils Namespace


XmlValidation Class

[image]

OfficeClip API Documentation
XmlValidation Class
Members See Also

[This is preliminary documentation and is subject to change.]

Validates the Xml document against a schema

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class XmlValidation
Visual Basic (Declaration)
Public Class XmlValidation
Visual C++
public ref class XmlValidation

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils..::.XmlValidation

See Also

XmlValidation Members
OfficeClip.Utils Namespace


XmlValidation Members

[image] [image]

OfficeClip API Documentation
XmlValidation Members
XmlValidation Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The XmlValidation type exposes the following members.

Constructors

 | Name | Description
Public method | XmlValidation |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateXml | Provides validation of the Xml file and against the supplied xml file.

See Also

XmlValidation Class
OfficeClip.Utils Namespace


XmlValidation Constructor

[image]

OfficeClip API Documentation
XmlValidation Constructor
XmlValidation Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public XmlValidation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
XmlValidation()

See Also

XmlValidation Class
OfficeClip.Utils Namespace


XmlValidation Methods

[image] [image]

OfficeClip API Documentation
XmlValidation Methods
XmlValidation Class See Also

[This is preliminary documentation and is subject to change.]

The XmlValidation type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateXml | Provides validation of the Xml file and against the supplied xml file.

See Also

XmlValidation Class
OfficeClip.Utils Namespace


ValidateXml Method

[image]

OfficeClip API Documentation
XmlValidation..::.ValidateXml Method
XmlValidation Class See Also

[This is preliminary documentation and is subject to change.]

Provides validation of the Xml file and against the supplied xml file.

Namespace: OfficeClip.Utils
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string ValidateXml(
    string xmlFile,
    string xsdFile
)
Visual Basic (Declaration)
Public Function ValidateXml ( _
    xmlFile As String, _
    xsdFile As String _
) As String
Visual C++
public:
String^ ValidateXml(
    String^ xmlFile,
    String^ xsdFile
)

Parameters

xmlFile
Type: System..::.String
The xml file to be validated
xsdFile
Type: System..::.String
The schema to be validated against

Return Value

empty if the xml is valid, otherwise provides the validation error

See Also

XmlValidation Class
OfficeClip.Utils Namespace


OfficeClip.Utils.Extranet Namespace

[image]

OfficeClip API Documentation
OfficeClip.Utils.Extranet Namespace

[This is preliminary documentation and is subject to change.]

Utilities library for the OfficeClip customer portal

Classes

 | Class | Description
Public class | AuthenticatedTicket | The authenticated ticket object
Public class | AuthTkt | Serializable class for encrypted argument acting as a business object container for User ID, Emai Address, and Host IP address.
Public class | Default | Default extranet screen class
Public class | ExAppSettings | Provides various url mapping needed for the Extranet application
Public class | ExSecurity | Interface for class

Interfaces

 | Interface | Description
Public interface | IAuthTkt | Interface definitions for ExSecurity class

Enumerations

 | Enumeration | Description
Public enumeration | ControlMode | The extranet input mode
Public enumeration | ExtranetLoginStatus | Enumeration of possible states seen after a user log in attempt
Public enumeration | IssueTrackerInputMode | Shows various input mode for the issue tracker
Public enumeration | ItemPermission | Enumerated types for permission of extranet items
Public enumeration | Restrictions | Enumerated types for Extranet Security restrictions
Public enumeration | WzPanel | Extranet control panel


AuthenticatedTicket Class

[image]

OfficeClip API Documentation
AuthenticatedTicket Class
Members See Also

[This is preliminary documentation and is subject to change.]

The authenticated ticket object

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class AuthenticatedTicket
Visual Basic (Declaration)
Public Class AuthenticatedTicket
Visual C++
public ref class AuthenticatedTicket

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils.Extranet..::.AuthenticatedTicket

See Also

AuthenticatedTicket Members
OfficeClip.Utils.Extranet Namespace


AuthenticatedTicket Members

[image] [image]

OfficeClip API Documentation
AuthenticatedTicket Members
AuthenticatedTicket Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The AuthenticatedTicket type exposes the following members.

Constructors

 | Name | Description
Public method | AuthenticatedTicket |

Methods

 | Name | Description
 | CookieAndUrlArgIsValidated | Determines if the cookie and the url object is validated
 | CreateAuthenticatedSession | Creates the authenticated session
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get_eAuthTktFromCookie | Retrieves the authenticated ticket from the cookie
 | GetEncodedCookieAndEncryptedArg | Class responsible for Extranet Authentication
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AuthenticatedTicket Class
OfficeClip.Utils.Extranet Namespace


AuthenticatedTicket Constructor

[image]

OfficeClip API Documentation
AuthenticatedTicket Constructor
AuthenticatedTicket Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public AuthenticatedTicket()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AuthenticatedTicket()

See Also

AuthenticatedTicket Class
OfficeClip.Utils.Extranet Namespace


AuthenticatedTicket Methods

[image] [image]

OfficeClip API Documentation
AuthenticatedTicket Methods
AuthenticatedTicket Class See Also

[This is preliminary documentation and is subject to change.]

The AuthenticatedTicket type exposes the following methods.

Methods

 | Name | Description
 | CookieAndUrlArgIsValidated | Determines if the cookie and the url object is validated
 | CreateAuthenticatedSession | Creates the authenticated session
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get_eAuthTktFromCookie | Retrieves the authenticated ticket from the cookie
 | GetEncodedCookieAndEncryptedArg | Class responsible for Extranet Authentication
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AuthenticatedTicket Class
OfficeClip.Utils.Extranet Namespace


CookieAndUrlArgIsValidated Method

[image]

OfficeClip API Documentation
AuthenticatedTicket..::.CookieAndUrlArgIsValidated Method
AuthenticatedTicket Class See Also

[This is preliminary documentation and is subject to change.]

Determines if the cookie and the url object is validated

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static bool CookieAndUrlArgIsValidated(
    int groupId,
    string encodedCookie,
    string encryptedUrlArg,
    string clientIpAddress
)
Visual Basic (Declaration)
Public Shared Function CookieAndUrlArgIsValidated ( _
    groupId As Integer, _
    encodedCookie As String, _
    encryptedUrlArg As String, _
    clientIpAddress As String _
) As Boolean
Visual C++
public:
static bool CookieAndUrlArgIsValidated(
    int groupId,
    String^ encodedCookie,
    String^ encryptedUrlArg,
    String^ clientIpAddress
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
encodedCookie
Type: System..::.String
the encoded cookie
encryptedUrlArg
Type: System..::.String
The encrypted url argument
clientIpAddress
Type: System..::.String
The ip address of the client

Return Value

true if the cookie and the argument is validated

See Also

AuthenticatedTicket Class
OfficeClip.Utils.Extranet Namespace


CreateAuthenticatedSession Method

[image]

OfficeClip API Documentation
AuthenticatedTicket..::.CreateAuthenticatedSession Method
AuthenticatedTicket Class See Also

[This is preliminary documentation and is subject to change.]

Creates the authenticated session

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void CreateAuthenticatedSession(
    int userId,
    int groupId,
    string userEmail,
    TimeZoneInfo tzInfo,
    HttpSessionState session
)
Visual Basic (Declaration)
Public Shared Sub CreateAuthenticatedSession ( _
    userId As Integer, _
    groupId As Integer, _
    userEmail As String, _
    tzInfo As TimeZoneInfo, _
    session As HttpSessionState _
)
Visual C++
public:
static void CreateAuthenticatedSession(
    int userId,
    int groupId,
    String^ userEmail,
    TimeZoneInfo^ tzInfo,
    HttpSessionState^ session
)

Parameters

userId
Type: System..::.Int32
The unique id of the user
groupId
Type: System..::.Int32
The unique id of the group
userEmail
Type: System..::.String
The user email address
tzInfo
Type: OfficeClip.Utils..::.TimeZoneInfo
The user timezone
session
Type: System.Web.SessionState..::.HttpSessionState
The user session

See Also

AuthenticatedTicket Class
OfficeClip.Utils.Extranet Namespace


Get_eAuthTktFromCookie Method

[image]

OfficeClip API Documentation
AuthenticatedTicket..::.Get_eAuthTktFromCookie Method
AuthenticatedTicket Class See Also

[This is preliminary documentation and is subject to change.]

Retrieves the authenticated ticket from the cookie

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static AuthTkt Get_eAuthTktFromCookie(
    string encodedCookieTxt,
    int groupId
)
Visual Basic (Declaration)
Public Shared Function Get_eAuthTktFromCookie ( _
    encodedCookieTxt As String, _
    groupId As Integer _
) As AuthTkt
Visual C++
public:
static AuthTkt^ Get_eAuthTktFromCookie(
    String^ encodedCookieTxt,
    int groupId
)

Parameters

encodedCookieTxt
Type: System..::.String
The text for the encoded cookie
groupId
Type: System..::.Int32
The unique id of the group

Return Value

The authenticated ticket object

See Also

AuthenticatedTicket Class
OfficeClip.Utils.Extranet Namespace


GetEncodedCookieAndEncryptedArg Method

[image]

OfficeClip API Documentation
AuthenticatedTicket..::.GetEncodedCookieAndEncryptedArg Method
AuthenticatedTicket Class See Also

[This is preliminary documentation and is subject to change.]

Class responsible for Extranet Authentication

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static void GetEncodedCookieAndEncryptedArg(
    int groupId,
    AuthTkt tkt,
    TimeSpan tsExpires,
    out HttpCookie cookie,
    out string encryptedArg
)
Visual Basic (Declaration)
Public Shared Sub GetEncodedCookieAndEncryptedArg ( _
    groupId As Integer, _
    tkt As AuthTkt, _
    tsExpires As TimeSpan, _
    <OutAttribute> ByRef cookie As HttpCookie, _
    <OutAttribute> ByRef encryptedArg As String _
)
Visual C++
public:
static void GetEncodedCookieAndEncryptedArg(
    int groupId,
    AuthTkt^ tkt,
    TimeSpan tsExpires,
    [OutAttribute] HttpCookie^% cookie,
    [OutAttribute] String^% encryptedArg
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
tkt
Type: OfficeClip.Utils.Extranet..::.AuthTkt
The authenticated ticket object
tsExpires
Type: System..::.TimeSpan
time period for the cookie expiration
cookie
Type: System.Web..::.HttpCookie%
The cookie to keep track of the session
encryptedArg
Type: System..::.String%
The encrypted argument

See Also

AuthenticatedTicket Class
OfficeClip.Utils.Extranet Namespace


AuthTkt Class

[image]

OfficeClip API Documentation
AuthTkt Class
Members See Also

[This is preliminary documentation and is subject to change.]

Serializable class for encrypted argument acting as a business object container for User ID, Emai Address, and Host IP address.

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class AuthTkt
Visual Basic (Declaration)
Public Class AuthTkt
Visual C++
public ref class AuthTkt

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils.Extranet..::.AuthTkt

See Also

AuthTkt Members
OfficeClip.Utils.Extranet Namespace


AuthTkt Members

[image] [image]

OfficeClip API Documentation
AuthTkt Members
AuthTkt Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The AuthTkt type exposes the following members.

Constructors

 | Name | Description
Public method | AuthTkt | default constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _email | The email address
Protected field | _ipAddress | The ip address
Protected field | _userId | The unique user id

Properties

 | Name | Description
Public property | Email | The email of the user
Public property | IpAddress | the ip address of the user
Public property | UserID | The unique id of the user

See Also

AuthTkt Class
OfficeClip.Utils.Extranet Namespace


AuthTkt Constructor

[image]

OfficeClip API Documentation
AuthTkt Constructor
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

default constructor

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public AuthTkt()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AuthTkt()

See Also

AuthTkt Class
OfficeClip.Utils.Extranet Namespace


AuthTkt Fields

[image] [image]

OfficeClip API Documentation
AuthTkt Fields
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The AuthTkt type exposes the following fields.

Fields

 | Name | Description
Protected field | _email | The email address
Protected field | _ipAddress | The ip address
Protected field | _userId | The unique user id

See Also

AuthTkt Class
OfficeClip.Utils.Extranet Namespace


_email Field

[image]

OfficeClip API Documentation
AuthTkt..::._email Field
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The email address

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected string _email
Visual Basic (Declaration)
Protected _email As String
Visual C++
protected:
String^ _email

See Also

AuthTkt Class
OfficeClip.Utils.Extranet Namespace


_ipAddress Field

[image]

OfficeClip API Documentation
AuthTkt..::._ipAddress Field
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The ip address

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected string _ipAddress
Visual Basic (Declaration)
Protected _ipAddress As String
Visual C++
protected:
String^ _ipAddress

See Also

AuthTkt Class
OfficeClip.Utils.Extranet Namespace


_userId Field

[image]

OfficeClip API Documentation
AuthTkt..::._userId Field
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The unique user id

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected int _userId
Visual Basic (Declaration)
Protected _userId As Integer
Visual C++
protected:
int _userId

See Also

AuthTkt Class
OfficeClip.Utils.Extranet Namespace


AuthTkt Properties

[image] [image]

OfficeClip API Documentation
AuthTkt Properties
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The AuthTkt type exposes the following properties.

Properties

 | Name | Description
Public property | Email | The email of the user
Public property | IpAddress | the ip address of the user
Public property | UserID | The unique id of the user

See Also

AuthTkt Class
OfficeClip.Utils.Extranet Namespace


Email Property

[image]

OfficeClip API Documentation
AuthTkt..::.Email Property
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The email of the user

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string Email { get; set; }
Visual Basic (Declaration)
Public Property Email As String
Visual C++
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

See Also

AuthTkt Class
OfficeClip.Utils.Extranet Namespace


IpAddress Property

[image]

OfficeClip API Documentation
AuthTkt..::.IpAddress Property
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

the ip address of the user

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string IpAddress { get; set; }
Visual Basic (Declaration)
Public Property IpAddress As String
Visual C++
public:
property String^ IpAddress {
    String^ get ();
    void set (String^ value);
}

See Also

AuthTkt Class
OfficeClip.Utils.Extranet Namespace


UserID Property

[image]

OfficeClip API Documentation
AuthTkt..::.UserID Property
AuthTkt Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the user

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int UserID { get; set; }
Visual Basic (Declaration)
Public Property UserID As Integer
Visual C++
public:
property int UserID {
    int get ();
    void set (int value);
}

See Also

AuthTkt Class
OfficeClip.Utils.Extranet Namespace


ControlMode Enumeration

[image]

OfficeClip API Documentation
ControlMode Enumeration
See Also

[This is preliminary documentation and is subject to change.]

The extranet input mode

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum ControlMode
Visual Basic (Declaration)
Public Enumeration ControlMode
Visual C++
public enum class ControlMode

Members

Member name | Description
Add | Add mode
Edit | Edit mode

See Also

OfficeClip.Utils.Extranet Namespace


Default Class

[image]

OfficeClip API Documentation
Default Class
Members See Also

[This is preliminary documentation and is subject to change.]

Default extranet screen class

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class Default
Visual Basic (Declaration)
Public Class Default
Visual C++
public ref class Default

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils.Extranet..::.Default

See Also

Default Members
OfficeClip.Utils.Extranet Namespace


Default Members

[image] [image]

OfficeClip API Documentation
Default Members
Default Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The Default type exposes the following members.

Constructors

 | Name | Description
Public method | Default |

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BrowserTitle | The title that shows up on the browser
CopyrightText | The copyright text that is shown at the bottom of the page
CopyrightUrl | The url where the control should go to when the copyright text is clicked
PageTitle | The title that shows up at the top of the page
SessionTimeout | The default session timeout for the extranet
XslUrl | The url of the xml stylesheet

Properties

Name | Description
Footer | The default extranet footer
Header | Deafault extranet header

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


Default Constructor

[image]

OfficeClip API Documentation
Default Constructor
Default Class See Also

[This is preliminary documentation and is subject to change.]

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public Default()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Default()

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


Default Fields

[image] [image]

OfficeClip API Documentation
Default Fields
Default Class See Also

[This is preliminary documentation and is subject to change.]

The Default type exposes the following fields.

Fields

Name | Description
BrowserTitle | The title that shows up on the browser
CopyrightText | The copyright text that is shown at the bottom of the page
CopyrightUrl | The url where the control should go to when the copyright text is clicked
PageTitle | The title that shows up at the top of the page
SessionTimeout | The default session timeout for the extranet
XslUrl | The url of the xml stylesheet

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


BrowserTitle Field

[image]

OfficeClip API Documentation
Default..::.BrowserTitle Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The title that shows up on the browser

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string BrowserTitle
Visual Basic (Declaration)
Public Shared BrowserTitle As String
Visual C++
public:
static String^ BrowserTitle

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


CopyrightText Field

[image]

OfficeClip API Documentation
Default..::.CopyrightText Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The copyright text that is shown at the bottom of the page

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string CopyrightText
Visual Basic (Declaration)
Public Shared CopyrightText As String
Visual C++
public:
static String^ CopyrightText

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


CopyrightUrl Field

[image]

OfficeClip API Documentation
Default..::.CopyrightUrl Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The url where the control should go to when the copyright text is clicked

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string CopyrightUrl
Visual Basic (Declaration)
Public Shared CopyrightUrl As String
Visual C++
public:
static String^ CopyrightUrl

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


PageTitle Field

[image]

OfficeClip API Documentation
Default..::.PageTitle Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The title that shows up at the top of the page

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string PageTitle
Visual Basic (Declaration)
Public Shared PageTitle As String
Visual C++
public:
static String^ PageTitle

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


SessionTimeout Field

[image]

OfficeClip API Documentation
Default..::.SessionTimeout Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The default session timeout for the extranet

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static int SessionTimeout
Visual Basic (Declaration)
Public Shared SessionTimeout As Integer
Visual C++
public:
static int SessionTimeout

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


XslUrl Field

[image]

OfficeClip API Documentation
Default..::.XslUrl Field
Default Class See Also

[This is preliminary documentation and is subject to change.]

The url of the xml stylesheet

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string XslUrl
Visual Basic (Declaration)
Public Shared XslUrl As String
Visual C++
public:
static String^ XslUrl

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


Default Properties

[image] [image]

OfficeClip API Documentation
Default Properties
Default Class See Also

[This is preliminary documentation and is subject to change.]

The Default type exposes the following properties.

Properties

Name | Description
Footer | The default extranet footer
Header | Deafault extranet header

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


Footer Property

[image]

OfficeClip API Documentation
Default..::.Footer Property
Default Class See Also

[This is preliminary documentation and is subject to change.]

The default extranet footer

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Footer { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Footer As String
Visual C++
public:
static property String^ Footer {
    String^ get ();
}

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


Header Property

[image]

OfficeClip API Documentation
Default..::.Header Property
Default Class See Also

[This is preliminary documentation and is subject to change.]

Deafault extranet header

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string Header { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Header As String
Visual C++
public:
static property String^ Header {
    String^ get ();
}

See Also

Default Class
OfficeClip.Utils.Extranet Namespace


ExAppSettings Class

[image]

OfficeClip API Documentation
ExAppSettings Class
Members See Also

[This is preliminary documentation and is subject to change.]

Provides various url mapping needed for the Extranet application

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class ExAppSettings
Visual Basic (Declaration)
Public Class ExAppSettings
Visual C++
public ref class ExAppSettings

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils.Extranet..::.ExAppSettings

See Also

ExAppSettings Members
OfficeClip.Utils.Extranet Namespace


ExAppSettings Members

[image] [image]

OfficeClip API Documentation
ExAppSettings Members
ExAppSettings Class Constructors Methods See Also

[This is preliminary documentation and is subject to change.]

The ExAppSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ExAppSettings | default constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetExtranetHomeUrl | Retrieves the path to the extranet home page
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MapExtranetAdminPath | Maps given file to the Extranet Admin virtual directory
 | MapExtranetFeatureItemUrl | Overloaded.
 | MapExtranetHomePage | Gets the extranet home page path
 | MapExtranetUsersPath | Maps given file to the Extranet Users virtual directory
 | MapOcPath | Returns the officeclip path
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExAppSettings Class
OfficeClip.Utils.Extranet Namespace


ExAppSettings Constructor

[image]

OfficeClip API Documentation
ExAppSettings Constructor
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

default constructor

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public ExAppSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ExAppSettings()

See Also

ExAppSettings Class
OfficeClip.Utils.Extranet Namespace


ExAppSettings Methods

[image] [image]

OfficeClip API Documentation
ExAppSettings Methods
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

The ExAppSettings type exposes the following methods.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetExtranetHomeUrl | Retrieves the path to the extranet home page
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MapExtranetAdminPath | Maps given file to the Extranet Admin virtual directory
 | MapExtranetFeatureItemUrl | Overloaded.
 | MapExtranetHomePage | Gets the extranet home page path
 | MapExtranetUsersPath | Maps given file to the Extranet Users virtual directory
 | MapOcPath | Returns the officeclip path
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExAppSettings Class
OfficeClip.Utils.Extranet Namespace


GetExtranetHomeUrl Method

[image]

OfficeClip API Documentation
ExAppSettings..::.GetExtranetHomeUrl Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Retrieves the path to the extranet home page

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string GetExtranetHomeUrl(
    int groupId
)
Visual Basic (Declaration)
Public Shared Function GetExtranetHomeUrl ( _
    groupId As Integer _
) As String
Visual C++
public:
static String^ GetExtranetHomeUrl(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

Return Value

The extranet home page path

See Also

ExAppSettings Class
OfficeClip.Utils.Extranet Namespace


MapExtranetAdminPath Method

[image]

OfficeClip API Documentation
ExAppSettings..::.MapExtranetAdminPath Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Maps given file to the Extranet Admin virtual directory

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string MapExtranetAdminPath(
    string filename
)
Visual Basic (Declaration)
Public Shared Function MapExtranetAdminPath ( _
    filename As String _
) As String
Visual C++
public:
static String^ MapExtranetAdminPath(
    String^ filename
)

Parameters

filename
Type: System..::.String
The name of the file

Return Value

The extranet administrator path

See Also

ExAppSettings Class
OfficeClip.Utils.Extranet Namespace


MapExtranetFeatureItemUrl Method

[image] [image]

OfficeClip API Documentation
ExAppSettings..::.MapExtranetFeatureItemUrl Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MapExtranetFeatureItemUrl(Int32, Int32) | gets the path to the extranet feature item url
MapExtranetFeatureItemUrl(Int32, Int32, String) | gets the path to the extranet feature item url

See Also

ExAppSettings Class
ExAppSettings Members
OfficeClip.Utils.Extranet Namespace


MapExtranetFeatureItemUrl Method (Int32, Int32)

[image]

OfficeClip API Documentation
ExAppSettings..::.MapExtranetFeatureItemUrl Method (Int32, Int32)
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

gets the path to the extranet feature item url

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string MapExtranetFeatureItemUrl(
    int itemId,
    int groupId
)
Visual Basic (Declaration)
Public Shared Function MapExtranetFeatureItemUrl ( _
    itemId As Integer, _
    groupId As Integer _
) As String
Visual C++
public:
static String^ MapExtranetFeatureItemUrl(
    int itemId,
    int groupId
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
groupId
Type: System..::.Int32
The unique id of the group

Return Value

The extranet feature item url

See Also

ExAppSettings Class
MapExtranetFeatureItemUrl Overload
OfficeClip.Utils.Extranet Namespace


MapExtranetFeatureItemUrl Method (Int32, Int32, String)

[image]

OfficeClip API Documentation
ExAppSettings..::.MapExtranetFeatureItemUrl Method (Int32, Int32, String)
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

gets the path to the extranet feature item url

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string MapExtranetFeatureItemUrl(
    int itemId,
    int groupId,
    string argument
)
Visual Basic (Declaration)
Public Shared Function MapExtranetFeatureItemUrl ( _
    itemId As Integer, _
    groupId As Integer, _
    argument As String _
) As String
Visual C++
public:
static String^ MapExtranetFeatureItemUrl(
    int itemId,
    int groupId,
    String^ argument
)

Parameters

itemId
Type: System..::.Int32
The unique id of the item
groupId
Type: System..::.Int32
the unique id of the group
argument
Type: System..::.String
The list of arguments

Return Value

The extranet feature item url

See Also

ExAppSettings Class
MapExtranetFeatureItemUrl Overload
OfficeClip.Utils.Extranet Namespace


MapExtranetHomePage Method

[image]

OfficeClip API Documentation
ExAppSettings..::.MapExtranetHomePage Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Gets the extranet home page path

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string MapExtranetHomePage(
    int groupId
)
Visual Basic (Declaration)
Public Shared Function MapExtranetHomePage ( _
    groupId As Integer _
) As String
Visual C++
public:
static String^ MapExtranetHomePage(
    int groupId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group

Return Value

The physical path to the extranet home page

See Also

ExAppSettings Class
OfficeClip.Utils.Extranet Namespace


MapExtranetUsersPath Method

[image]

OfficeClip API Documentation
ExAppSettings..::.MapExtranetUsersPath Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Maps given file to the Extranet Users virtual directory

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string MapExtranetUsersPath(
    string filename
)
Visual Basic (Declaration)
Public Shared Function MapExtranetUsersPath ( _
    filename As String _
) As String
Visual C++
public:
static String^ MapExtranetUsersPath(
    String^ filename
)

Parameters

filename
Type: System..::.String
The name of the file

Return Value

The extranet user path

See Also

ExAppSettings Class
OfficeClip.Utils.Extranet Namespace


MapOcPath Method

[image]

OfficeClip API Documentation
ExAppSettings..::.MapOcPath Method
ExAppSettings Class See Also

[This is preliminary documentation and is subject to change.]

Returns the officeclip path

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public static string MapOcPath(
    string filename
)
Visual Basic (Declaration)
Public Shared Function MapOcPath ( _
    filename As String _
) As String
Visual C++
public:
static String^ MapOcPath(
    String^ filename
)

Parameters

filename
Type: System..::.String
The name of the file

Return Value

See Also

ExAppSettings Class
OfficeClip.Utils.Extranet Namespace


ExSecurity Class

[image]

OfficeClip API Documentation
ExSecurity Class
Members See Also

[This is preliminary documentation and is subject to change.]

Interface for class

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public class ExSecurity : IAuthTkt
Visual Basic (Declaration)
Public Class ExSecurity _
    Implements IAuthTkt
Visual C++
public ref class ExSecurity : IAuthTkt

Inheritance Hierarchy

System..::.Object
OfficeClip.Utils.Extranet..::.ExSecurity

See Also

ExSecurity Members
OfficeClip.Utils.Extranet Namespace


ExSecurity Members

[image] [image]

OfficeClip API Documentation
ExSecurity Members
ExSecurity Class Constructors Methods Fields Properties See Also

[This is preliminary documentation and is subject to change.]

The ExSecurity type exposes the following members.

Constructors

 | Name | Description
Public method | ExSecurity | Overloaded.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | _argument | Te argument
Protected field | _decryptedCnt | The decrypted count
Protected field | _encodedAuthTkt | Encoded authentication ticket
Protected field | _encryptedId | The encrypted id
Protected field | _error | Error string
Protected field | _groupId | The group id
Protected field | _itemId | The item id
Protected field | _tkt | Authentication ticket

Properties

 | Name | Description
Public property | Argument | The list of the arguments
Public property | EncryptedId | The encrypted id
Public property | ErrorMsg | The error message
Public property | GroupId | The unique id of the group
Public property | IAuthTkt | Returns IAuthTkt interface for ExSecurity instance.
Public property | ItemId | The unique id of the item

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


ExSecurity Constructor

[image] [image]

OfficeClip API Documentation
ExSecurity Constructor
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Public method | ExSecurity(String) | constructor
Public method | ExSecurity(Int32, Int32) | constructor
Public method | ExSecurity(Int32, Int32, String) | constructor

See Also

ExSecurity Class
ExSecurity Members
OfficeClip.Utils.Extranet Namespace


ExSecurity Constructor (String)

[image]

OfficeClip API Documentation
ExSecurity Constructor (String)
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public ExSecurity(
    string encryptedId
)
Visual Basic (Declaration)
Public Sub New ( _
    encryptedId As String _
)
Visual C++
public:
ExSecurity(
    String^ encryptedId
)

Parameters

encryptedId
Type: System..::.String
The encrypted id

See Also

ExSecurity Class
ExSecurity Overload
OfficeClip.Utils.Extranet Namespace


ExSecurity Constructor (Int32, Int32)

[image]

OfficeClip API Documentation
ExSecurity Constructor (Int32, Int32)
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public ExSecurity(
    int groupId,
    int itemId
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    itemId As Integer _
)
Visual C++
public:
ExSecurity(
    int groupId,
    int itemId
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
itemId
Type: System..::.Int32
The unique id of the item

See Also

ExSecurity Class
ExSecurity Overload
OfficeClip.Utils.Extranet Namespace


ExSecurity Constructor (Int32, Int32, String)

[image]

OfficeClip API Documentation
ExSecurity Constructor (Int32, Int32, String)
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

constructor

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public ExSecurity(
    int groupId,
    int itemId,
    string argument
)
Visual Basic (Declaration)
Public Sub New ( _
    groupId As Integer, _
    itemId As Integer, _
    argument As String _
)
Visual C++
public:
ExSecurity(
    int groupId,
    int itemId,
    String^ argument
)

Parameters

groupId
Type: System..::.Int32
The unique id of the group
itemId
Type: System..::.Int32
The unique id of the item
argument
Type: System..::.String
The list of arguments

See Also

ExSecurity Class
ExSecurity Overload
OfficeClip.Utils.Extranet Namespace


ExSecurity Fields

[image] [image]

OfficeClip API Documentation
ExSecurity Fields
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The ExSecurity type exposes the following fields.

Fields

 | Name | Description
Protected field | _argument | Te argument
Protected field | _decryptedCnt | The decrypted count
Protected field | _encodedAuthTkt | Encoded authentication ticket
Protected field | _encryptedId | The encrypted id
Protected field | _error | Error string
Protected field | _groupId | The group id
Protected field | _itemId | The item id
Protected field | _tkt | Authentication ticket

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


_argument Field

[image]

OfficeClip API Documentation
ExSecurity..::._argument Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Te argument

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected string _argument
Visual Basic (Declaration)
Protected _argument As String
Visual C++
protected:
String^ _argument

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


_decryptedCnt Field

[image]

OfficeClip API Documentation
ExSecurity..::._decryptedCnt Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The decrypted count

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected int _decryptedCnt
Visual Basic (Declaration)
Protected _decryptedCnt As Integer
Visual C++
protected:
int _decryptedCnt

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


_encodedAuthTkt Field

[image]

OfficeClip API Documentation
ExSecurity..::._encodedAuthTkt Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Encoded authentication ticket

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected string _encodedAuthTkt
Visual Basic (Declaration)
Protected _encodedAuthTkt As String
Visual C++
protected:
String^ _encodedAuthTkt

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


_encryptedId Field

[image]

OfficeClip API Documentation
ExSecurity..::._encryptedId Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The encrypted id

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected string _encryptedId
Visual Basic (Declaration)
Protected _encryptedId As String
Visual C++
protected:
String^ _encryptedId

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


_error Field

[image]

OfficeClip API Documentation
ExSecurity..::._error Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Error string

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected string _error
Visual Basic (Declaration)
Protected _error As String
Visual C++
protected:
String^ _error

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


_groupId Field

[image]

OfficeClip API Documentation
ExSecurity..::._groupId Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The group id

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected int _groupId
Visual Basic (Declaration)
Protected _groupId As Integer
Visual C++
protected:
int _groupId

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


_itemId Field

[image]

OfficeClip API Documentation
ExSecurity..::._itemId Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The item id

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected int _itemId
Visual Basic (Declaration)
Protected _itemId As Integer
Visual C++
protected:
int _itemId

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


_tkt Field

[image]

OfficeClip API Documentation
ExSecurity..::._tkt Field
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Authentication ticket

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
protected AuthTkt _tkt
Visual Basic (Declaration)
Protected _tkt As AuthTkt
Visual C++
protected:
AuthTkt^ _tkt

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


ExSecurity Properties

[image] [image]

OfficeClip API Documentation
ExSecurity Properties
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The ExSecurity type exposes the following properties.

Properties

 | Name | Description
Public property | Argument | The list of the arguments
Public property | EncryptedId | The encrypted id
Public property | ErrorMsg | The error message
Public property | GroupId | The unique id of the group
Public property | IAuthTkt | Returns IAuthTkt interface for ExSecurity instance.
Public property | ItemId | The unique id of the item

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


Argument Property

[image]

OfficeClip API Documentation
ExSecurity..::.Argument Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The list of the arguments

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string Argument { get; }
Visual Basic (Declaration)
Public ReadOnly Property Argument As String
Visual C++
public:
property String^ Argument {
    String^ get ();
}

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


EncryptedId Property

[image]

OfficeClip API Documentation
ExSecurity..::.EncryptedId Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The encrypted id

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string EncryptedId { get; }
Visual Basic (Declaration)
Public ReadOnly Property EncryptedId As String
Visual C++
public:
property String^ EncryptedId {
    String^ get ();
}

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


ErrorMsg Property

[image]

OfficeClip API Documentation
ExSecurity..::.ErrorMsg Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The error message

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public string ErrorMsg { get; }
Visual Basic (Declaration)
Public ReadOnly Property ErrorMsg As String
Visual C++
public:
property String^ ErrorMsg {
    String^ get ();
}

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


GroupId Property

[image]

OfficeClip API Documentation
ExSecurity..::.GroupId Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the group

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int GroupId { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupId As Integer
Visual C++
public:
property int GroupId {
    int get ();
}

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


IAuthTkt Property

[image]

OfficeClip API Documentation
ExSecurity..::.IAuthTkt Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

Returns IAuthTkt interface for ExSecurity instance.

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public IAuthTkt IAuthTkt { get; }
Visual Basic (Declaration)
Public ReadOnly Property IAuthTkt As IAuthTkt
Visual C++
public:
property IAuthTkt^ IAuthTkt {
    IAuthTkt^ get ();
}

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


ItemId Property

[image]

OfficeClip API Documentation
ExSecurity..::.ItemId Property
ExSecurity Class See Also

[This is preliminary documentation and is subject to change.]

The unique id of the item

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public int ItemId { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemId As Integer
Visual C++
public:
property int ItemId {
    int get ();
}

See Also

ExSecurity Class
OfficeClip.Utils.Extranet Namespace


ExtranetLoginStatus Enumeration

[image]

OfficeClip API Documentation
ExtranetLoginStatus Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumeration of possible states seen after a user log in attempt

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum ExtranetLoginStatus
Visual Basic (Declaration)
Public Enumeration ExtranetLoginStatus
Visual C++
public enum class ExtranetLoginStatus

Members

Member name | Description
Success | Indicates successful extranet login
InvalidLoginPassword | Indicates invalid password
SiteLicenseExpired | Indicates that the OfficeClip license is expired
AccountLicenseExpired | Indicates that the account license is expired
DatabaseOfficeClipVersionMismatch | Indicates that there is mismatch between the OfficeClip and the database version
OfficeClipUndergoneMajorUpgrade | Indicates that OfficeClip has gone through a major upgrade
CurrentUpgradeIncompatibleWithOfficeClipLicense | Indicates that the upgrade on OfficeClip is not supported by the license

See Also

OfficeClip.Utils.Extranet Namespace


IAuthTkt Interface

[image]

OfficeClip API Documentation
IAuthTkt Interface
Members See Also

[This is preliminary documentation and is subject to change.]

Interface definitions for ExSecurity class

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public interface IAuthTkt
Visual Basic (Declaration)
Public Interface IAuthTkt
Visual C++
public interface class IAuthTkt

See Also

IAuthTkt Members
OfficeClip.Utils.Extranet Namespace


IAuthTkt Members

[image] [image]

OfficeClip API Documentation
IAuthTkt Members
IAuthTkt Interface Methods Properties See Also

[This is preliminary documentation and is subject to change.]

The IAuthTkt type exposes the following members.

Methods

 | Name | Description
Public method | CookieAndUrlArgIsValidated | Tests if the cookie and the url argument is valid
Public method | Get_eAuthTktFromCookie | Gets the authentication ticket from cookie
Public method | GetEncodedAuthTktCookie | Gets the encoded autentication cookie ticket
Public method | GetEncryptedUrlArg | Gets encrypted url argument

Properties

 | Name | Description
Public property | eAuthTkt | The authentication ticket

See Also

IAuthTkt Interface
OfficeClip.Utils.Extranet Namespace


IAuthTkt Methods

[image] [image]

OfficeClip API Documentation
IAuthTkt Methods
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

The IAuthTkt type exposes the following methods.

Methods

 | Name | Description
Public method | CookieAndUrlArgIsValidated | Tests if the cookie and the url argument is valid
Public method | Get_eAuthTktFromCookie | Gets the authentication ticket from cookie
Public method | GetEncodedAuthTktCookie | Gets the encoded autentication cookie ticket
Public method | GetEncryptedUrlArg | Gets encrypted url argument

See Also

IAuthTkt Interface
OfficeClip.Utils.Extranet Namespace


CookieAndUrlArgIsValidated Method

[image]

OfficeClip API Documentation
IAuthTkt..::.CookieAndUrlArgIsValidated Method
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

Tests if the cookie and the url argument is valid

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
bool CookieAndUrlArgIsValidated(
    string encodedCookie,
    string encryptedUrlArg,
    string clientIpAddress
)
Visual Basic (Declaration)
Function CookieAndUrlArgIsValidated ( _
    encodedCookie As String, _
    encryptedUrlArg As String, _
    clientIpAddress As String _
) As Boolean
Visual C++
bool CookieAndUrlArgIsValidated(
    String^ encodedCookie,
    String^ encryptedUrlArg,
    String^ clientIpAddress
)

Parameters

encodedCookie
Type: System..::.String
The encoded cookie
encryptedUrlArg
Type: System..::.String
The encrypted url argument
clientIpAddress
Type: System..::.String
The client ip address

Return Value

True if the the cookie and the url argument is valid, false otherwise

See Also

IAuthTkt Interface
OfficeClip.Utils.Extranet Namespace


Get_eAuthTktFromCookie Method

[image]

OfficeClip API Documentation
IAuthTkt..::.Get_eAuthTktFromCookie Method
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

Gets the authentication ticket from cookie

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
AuthTkt Get_eAuthTktFromCookie(
    string encodedCookie
)
Visual Basic (Declaration)
Function Get_eAuthTktFromCookie ( _
    encodedCookie As String _
) As AuthTkt
Visual C++
AuthTkt^ Get_eAuthTktFromCookie(
    String^ encodedCookie
)

Parameters

encodedCookie
Type: System..::.String
The encoded cookie

Return Value

The authentication ticket

See Also

IAuthTkt Interface
OfficeClip.Utils.Extranet Namespace


GetEncodedAuthTktCookie Method

[image]

OfficeClip API Documentation
IAuthTkt..::.GetEncodedAuthTktCookie Method
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

Gets the encoded autentication cookie ticket

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
HttpCookie GetEncodedAuthTktCookie(
    ref AuthTkt tkt,
    TimeSpan tsExpires
)
Visual Basic (Declaration)
Function GetEncodedAuthTktCookie ( _
    ByRef tkt As AuthTkt, _
    tsExpires As TimeSpan _
) As HttpCookie
Visual C++
HttpCookie^ GetEncodedAuthTktCookie(
    AuthTkt^% tkt,
    TimeSpan tsExpires
)

Parameters

tkt
Type: OfficeClip.Utils.Extranet..::.AuthTkt %
The authentication ticket
tsExpires
Type: System..::.TimeSpan
Timespan after which the ticket will expire

Return Value

The authntication cookie

See Also

IAuthTkt Interface
OfficeClip.Utils.Extranet Namespace


GetEncryptedUrlArg Method

[image]

OfficeClip API Documentation
IAuthTkt..::.GetEncryptedUrlArg Method
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

Gets encrypted url argument

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
string GetEncryptedUrlArg(
    ref AuthTkt tkt
)
Visual Basic (Declaration)
Function GetEncryptedUrlArg ( _
    ByRef tkt As AuthTkt _
) As String
Visual C++
String^ GetEncryptedUrlArg(
    AuthTkt^% tkt
)

Parameters

tkt
Type: OfficeClip.Utils.Extranet..::.AuthTkt %
The authenticaton tcket

Return Value

The encrypted url argument

See Also

IAuthTkt Interface
OfficeClip.Utils.Extranet Namespace


IAuthTkt Properties

[image] [image]

OfficeClip API Documentation
IAuthTkt Properties
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

The IAuthTkt type exposes the following properties.

Properties

 | Name | Description
Public property | eAuthTkt | The authentication ticket

See Also

IAuthTkt Interface
OfficeClip.Utils.Extranet Namespace


eAuthTkt Property

[image]

OfficeClip API Documentation
IAuthTkt..::.eAuthTkt Property
IAuthTkt Interface See Also

[This is preliminary documentation and is subject to change.]

The authentication ticket

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
AuthTkt eAuthTkt { get; }
Visual Basic (Declaration)
ReadOnly Property eAuthTkt As AuthTkt
Visual C++
property AuthTkt^ eAuthTkt {
    AuthTkt^ get ();
}

See Also

IAuthTkt Interface
OfficeClip.Utils.Extranet Namespace


IssueTrackerInputMode Enumeration

[image]

OfficeClip API Documentation
IssueTrackerInputMode Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Shows various input mode for the issue tracker

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum IssueTrackerInputMode
Visual Basic (Declaration)
Public Enumeration IssueTrackerInputMode
Visual C++
public enum class IssueTrackerInputMode

Members

Member name | Description
ListCases | List all the cases
EnterCase | Enter a new case
CaseDetails | Show case details

See Also

OfficeClip.Utils.Extranet Namespace


ItemPermission Enumeration

[image]

OfficeClip API Documentation
ItemPermission Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types for permission of extranet items

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum ItemPermission
Visual Basic (Declaration)
Public Enumeration ItemPermission
Visual C++
public enum class ItemPermission

Members

Member name | Description
Public | visible to logged and unlogged extranet users
AllExtranetUsers | visible to all secured extranet users
SelectedExtranetUsers | Only visible to selected extranet users

See Also

OfficeClip.Utils.Extranet Namespace


Restrictions Enumeration

[image]

OfficeClip API Documentation
Restrictions Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Enumerated types for Extranet Security restrictions

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum Restrictions
Visual Basic (Declaration)
Public Enumeration Restrictions
Visual C++
public enum class Restrictions

Members

Member name | Description
None | No restrictions
PublicOnly | Only public restrictions
SecureOnly | Only secured restrictions

See Also

OfficeClip.Utils.Extranet Namespace


WzPanel Enumeration

[image]

OfficeClip API Documentation
WzPanel Enumeration
See Also

[This is preliminary documentation and is subject to change.]

Extranet control panel

Namespace: OfficeClip.Utils.Extranet
Assembly: OfficeClip.Utils (in OfficeClip.Utils)
Version: 8.1.1.0

Syntax

C#
public enum WzPanel
Visual Basic (Declaration)
Public Enumeration WzPanel
Visual C++
public enum class WzPanel

Members

Member name | Description
One | Panel 1
Two | Panel 2
Three | Panel 3
Four | Panel 4

See Also

OfficeClip.Utils.Extranet Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
GeneralUserProfile..::.GetBool Method
GeneralUserProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

GeneralUserProfile Class
GeneralUserProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
PunchClockGroupProfile..::.GetBool Method
PunchClockGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

PunchClockGroupProfile Class
PunchClockGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
CalendarGroupProfile..::.GetBool Method
CalendarGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

CalendarGroupProfile Class
CalendarGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
TimesheetGroupProfile..::.GetBool Method
TimesheetGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

TimesheetGroupProfile Class
TimesheetGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace


GetBool Method

[image] [image]

OfficeClip API Documentation
ExpenseGroupProfile..::.GetBool Method
ExpenseGroupProfile Class See Also

[This is preliminary documentation and is subject to change.]

Overload List

 | Name | Description
Protected method | GetBool(Int32) | Gets the boolean value of the property (Inherited from ProfileBase.)
Protected method | GetBool(Int32, Boolean) | Gets the boolean value of the property with a default value (Inherited from ProfileBase.)

See Also

ExpenseGroupProfile Class
ExpenseGroupProfile Members
OfficeClip.BusinessLayer.Framework.Profile Namespace